ImageGear for .NET v16.1
For All Windows Platforms

AccuSoft Corporation
 AccuSoft.com
sales@accusoft.com


Copyright Information

Information in this document is subject to change without notice. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of AccuSoft® Corporation.

© 1996-2009 AccuSoft® Corporation. All rights reserved.

AccuSoft and ImageGear are registered trademarks of AccuSoft Corporation. High Performance Imaging and the "half gear" logo are trademarks of AccuSoft Corporation. All rights reserved. All other company and brand names are trademarks or registered trademarks of their respective owners.

This manual and the software described in it are both products of the USA.

Document revision number: 2-10-09

AccuSoft Corporation, 71 Lyman Street, Northborough, MA 01532

(508) 351-9092,

(508) 351-9086 (Fax)

Internet address: www.accusoft.com


Volume 1: ImageGear User's Guide

The first Volume of the ImageGear for .NET v16 User's Manual provides the following information:

  • The Introduction provides an overview of ImageGear features, improvements, namespace structure, plus information about AccuSoft's Product Support Services and descriptions of AccuSoft's other products.
  • Installing and Distributing ImageGear provides information on how to install and license ImageGear.
  • Getting Started provides information on how to incorporate ImageGear's imaging capabilities into your own applications by using the sample source imaging programs provided with your toolkit.
  • Using ImageGear for .NET provides information about how to call an ImageGear function, including setting up the variables and structures passed as arguments, and details which functions to use to perform a variety of imaging tasks. It also explains how to work with some ImageGear namespaces API.
  • The Software License Agreement provides you with AccuSoft's Software License Agreement and Software Support and Maintenance Policy.
  • The Glossary defines some commonly used industry and ImageGear terminology.


Introduction

This Introduction provides information about the following:

  • About ImageGear for .NET
  • In This Guide
  • What's New in ImageGear for .NET
  • Overview
  • Supported Formats and Compressions
  • ImageGear for .NET Namespaces
  • About Customer Support


About ImageGear for .NET

ImageGear for .NET v16 is the most advanced way to create, control, and deliver more secure, high-quality imaging applications. Using ImageGear, you can easily add powerful imaging capability to your applications. ImageGear supports all of the most commonly used graphics file formats and many more, providing complete compatibility when developing .NET solutions, whether they are Windows Forms applications, ASP.NET Web Forms applications, or ASP.NET Web Service applications across multiple platforms.

ImageGear for .NET v16 features include:

  • Reading and writing 100+ file formats
  • File format conversion
  • Download Manager engine
  • Multi-page images support
  • In-memory access to image pixel data
  • Access to image metadata
  • Display and printing
  • Comprehensive image processing
  • Image enhancement
  • Special effects
  • Analysis/correction/manipulation of computer-generated images
  • Color processing: reduction/promotion/dithering
  • ICC color profiles support
  • Thumbnail read and write support
  • Alpha channels support
  • Pantone channels support
  • ROI processing
  • Comprehensive Annotations support: adding/editing/burn-in/deleting
  • TWAIN scanning
  • Analysis/correction/manipulation of scanned images
  • JPEG2000, JPX and MJ2 formats support
  • Dramatic speed enhancement for heavily tiled JPEG2000 images
  • Native Adobe PDF/PS support
  • Powerful PDF/PS/EPS editing API
  • Native PDF writing
  • Native CAD/Vector formats support
  • Vector rasterization
  • Vector formats editing API
  • 3D image visualization, rendering and isosurface
  • Medical/DICOM format support
  • DICOM image processing
  • DICOM metadata support
  • Comprehensive Digital Camera RAW formats support
  • Barcode recognition
  • Optical Character Recognition for Documents (OCR)
  • Optical Mark Recognition for Scanned Documents (OMR)
  • Intelligent Character Recognition for Scanned Documents (ICR)
  • 2 pre-made voting interfaces - OmniPage and PLUS
  • Direct access to 3 leading OCR engines - MOR, MTX and FireWorX
  • Image and Document Clean processing
  • Windows Forms support
  • Server-side Web Forms support
  • Client-side Web Forms support

The toolkit has native support for all color spaces and bit depths, provides comprehensive handling of color channels, and supports the following bit depths internally: 1, 4, 8-bit gray level, 8i, 9-16-bit gray level, 24, 32, 48, 64. The toolkit can also read all the additional bit depths possible for the file formats ImageGear supports.

With ImageGear for .NET v16, you are assured of the high quality and performance you expect from AccuSoft, the industry leader in image processing toolkits. In addition, ImageGear's integrity is backed by the AccuSoft Image Guarantee: ImageGear is guaranteed to read all valid raster images in the supported formats. See the AccuSoft Image Guarantee Chapter for more information.


In This Guide

This manual consists of two Volumes, organized as follows:

Volume 1: ImageGear User's Guide provides the following information about ImageGear:

  • The Introduction includes information about ImageGear features, improvements, ImageGear namespace structure, plus information about AccuSoft's Product Support Services and descriptions of AccuSoft's other products.
  • The Installing and Distributing ImageGear chapter explains how to install ImageGear, and how to develop, deploy, and distribute your ImageGear imaging application using ImageGear licensing functionality and data sources.
  • The Getting Started chapter demonstrates how to incorporate ImageGear's imaging capabilities into your own applications by using the sample source imaging programs provided with your toolkit. It also provides you with information about ImageGear for .NET Samples.
  • The Using ImageGear for .NET chapter explains how to call an ImageGear function, including setting up the variables and structures passed as arguments, and details which functions to use to perform a variety of imaging tasks.

This volume also includes the following:

  • Glossary provides definitions of imaging toolkit terms and a Bibliography.
  • Software License Agreement document.

Volume 2: ImageGear Namespaces Reference provides detailed information about each class, structure, delegate, field, property, method, event, and enumeration of the following ImageGear Namespaces:

  • ImageGear.Core Namespace
  • ImageGear.ART Namespace
  • ImageGear.ART.Forms Namespace
  • ImageGear.Display Namespace
  • ImageGear.Formats Namespace
  • ImageGear.Formats.CAD Namespace
  • ImageGear.Formats.CGM Namespace
  • ImageGear.Formats.DGN Namespace
  • ImageGear.Formats.DICOM Namespace
  • ImageGear.Formats.EXIF Namespace
  • ImageGear.Formats.HPGL Namespace
  • ImageGear.Formats.IPTC Namespace
  • ImageGear.Formats.JPEG2K Namespace
  • ImageGear.Formats.JPG Namespace
  • ImageGear.Formats.PDF Namespace
  • ImageGear.Formats.TIF Namespace
  • ImageGear.Formats.U3D Namespace
  • ImageGear.Formats.XMP Namespace
  • ImageGear.Formats.XMP.AdobePDF Namespace
  • ImageGear.Formats.XMP.Basic Namespace
  • ImageGear.Formats.XMP.BasicJobTicket Namespace
  • ImageGear.Formats.XMP.CameraRaw Namespace
  • ImageGear.Formats.XMP.DublinCore Namespace
  • ImageGear.Formats.XMP.DynamicMedia Namespace
  • ImageGear.Formats.XMP.EXIF Namespace
  • ImageGear.Formats.XMP.EXIFAux Namespace
  • ImageGear.Formats.XMP.IPTC4XMPCore Namespace
  • ImageGear.Formats.XMP.MediaManagement Namespace
  • ImageGear.Formats.XMP.MicrosoftPhoto Namespace
  • ImageGear.Formats.XMP.PagedText Namespace
  • ImageGear.Formats.XMP.Photoshop Namespace
  • ImageGear.Formats.XMP.RightsManagement Namespace
  • ImageGear.Formats.XMP.TIFF Namespace
  • ImageGear.FreqIP Namespace
  • ImageGear.Processing Namespace
  • ImageGear.Processing.ImageClean Namespace
  • ImageGear.Processing.Layers Namespace
  • ImageGear.TWAIN Namespace
  • ImageGear.Vector Namespace
  • ImageGear.Web.Forms Namespace
  • ImageGear.Windows.Forms Namespace
  • ImageGear.Windows.Forms.Thumbnail Namespace
  • ImageGear.WPF Namespace
  • The ImageGear Imaging Formats Reference chapter provides detailed information on each of the file formats supported by ImageGear for .NET, plus "at-a-glance" tables that describe the features supported by each format, and provides guidelines on which formats may be most suitable when speed, storage space, or similar considerations are important.


What's New in ImageGear for .NET

This section highlights the new features in the latest ImageGear releases, and provides links to more detailed documentation:

  • ImageGear for .NET Version 16.1
  • ImageGear for .NET Version 16


ImageGear for .NET Version 16.1

ImageGear for .NET version 16.1 includes the following new or enhanced functionality:

  • DICOM Enhancements
  • Adobe PDF Enhancements
  • Windows.Forms Enhancements
  • ART Enhancements
  • Miscellaneous Enhancements

DICOM Enhancements

  • Window leveling support for 17-32 bit DICOM images has been implemented. The following public API has been added:
    • ImageGear.Core Namespace.ImGearLinearLUT Class
    • ImageGear.Formats.DICOM Namespace.ImGearVOIWindow Structure.Center64 Property
    • ImageGear.Formats.DICOM Namespace.ImGearVOIWindow Structure.Max64Property
    • ImageGear.Formats.DICOM Namespace.ImGearVOIWindow Structure.Min64 Property
    • ImageGear.Formats.DICOM Namespace.ImGearVOIWindow Structure.Width64 Property
    • ImageGear.Formats.DICOM Namespace.ImGearVOIWindow Structure.CreateFromMinMax Method
  • Added new values to ImGearDICOMServiceObjectPairs Enumeration and ImGearDICOMTransferSyntaxes Enumeration.
  • LoadConcatenateRepeatedDE control parameter has been added to the DICOM format filter.

Adobe PDF Enhancements

  • To improve the performance of zooming very deep on some larger PDFs, the new Adobe PDF control parameter DrawMode was added, as well as the ImageGear.Formats.PDF Namespace. ImGearPDFPageDrawMode Enumeration.
  • ImageGear.Formats.PDF Namespace.ImGearPDEElement Class.GetOCMDictionary Method has been added to allow editing/saving JP2 compressed image element.

Windows.Forms Enhancements

  • Added the following API to the ImageGear.Windows.Forms Namespace in implementing an Open File dialog with preview:
    • ImGearWinForms Class.SelectLocalFileToLoadEx Method
    • ImGearLoadingSelection Class.PageIndex Property
    • ImGearLoadingSelectionEx Class
  • The new event, AfterDrawEvent Event, has been added to the ImageGear.Windows.Forms Namespace.ImGearPageView Class. All internal uses of RegisterAfterDraw Method have been changed to use this new event instead. Although the RegisterAfterDraw Method can still be used, it is advisable to use the new event instead. The ImGearAfterDrawEventArgs Class was also added to the ImageGear.Windows.Forms Namespace.

ART Enhancements

  • Implemented calculation of area/perimeter of ART marks. Added the following classes to the ImageGear.ART Namespace:
    • ImGearARTLineMarkStat Class
    • ImGearARTMarkStat Class
    • ImGearARTPointMarkStat Class
    • ImGearARTShapeMarkStat Class
  • Added new ART mark ID enumerator. The following new public interfaces have been added to the ImageGear.ART Namespace:
    • IImGearARTMarkIDEnumerator Interface
    • IImGearARTMarkIDEnumerable Interface

Miscellaneous Enhancements

  • The following new members have been added to the ImageGear.Formats Namespace to allow passing a local copy of control parameters to loading and saving methods:
    • ImGearFileFilters Class.ImGearFileFilters Constructor
    • ImGearLoadOptions Class.Filters Property
    • ImGearSaveOptions Class.Filters Property

The following overload methods were also added to the ImageGear.Formats Namespace.ImGearFileFormats Class:

    • GetPageCount Method
    • GetSavingFilter Method
    • GetSavingFormats Method
    • LoadDocument Method
    • LoadPageHeader Method
    • UpdatePageMetadata Method

See Using Filter Control Parameters for more information.

  • Ability to enable/disable double-sided rendering for 3D vector images, and 3D PDF/U3D annotations, has been implemented. ImageGear.Vector Namespace.ImGearVectorView Class.CullFace Property and ImGearVectCullFace Enumeration were added.
  • Ability to show TWAIN source UI and Load/Save custom data has been implemented. See the following ImageGear.TWAIN Namespace.ImGearTWAIN Class methods:
    • LoadCustomDSData Method
    • SaveCustomDSData Method
    • ShowSourceUI Method
  • Improved the documentation for embedding color profiles into image files. See the following sections for more information:
    • ImageGear.Formats Namespace.ImGearCommonMetadata Class.ColorProfile Property
    • Pixel Format Conversion During Image Saving
    • Saving Image Files with Embedded Color Profiles


ImageGear for .NET Version 16

ImageGear for .NET version 16 includes many enhancements.

The following enhancements are available on 32-bit, .NET 64-bit, and .NET Compact Framework:

  • Digital Camera Raw Format Enhancements
  • File Format Enhancements
  • Image Processing Enhancements
  • Miscellaneous Enhancements

The following enhancements are available on 32-bit and .NET 64-bit only:

  • PDF Enhancements
  • Vector Enhancements
  • Miscellaneous Enhancements

Digital Camera Raw Format Enhancements

ImageGear version 16 introduces the following Digital Camera Raw format enhancements:

  • Support for more than 80 new digital camera Raw file formats. See ImageGear Supported Digital Camera RAW Formats Reference for a complete list of supported Raw Formats. Also see ImageGear Digital Camera RAW Filter .
  • Interactive GUI for Digital Camera RAW color reconstruction. See Reconstructing Camera Raw Images with ImageGear Processing API for more information.

File Format Enhancements

  • ImageGear provides support for the Adobe PSB (Photoshop Big) or Large Document format, which is a newer version of Adobe PSD designed for files over 2 gigabytes, supporting up to 300,000 pixels in any dimension. The PSB format is identical to the Photoshop native format (PSD) in many ways.
  • ImageGear now allows users to load layered Photoshop image files (Adobe PSD and Adobe PSB) and retain image layers for editing. Users can also create new image layers, delete existing ones, as well as flatten and display the selected composition of image layers. See Using ImageGear.Processing.Layers Namespace for more information. See ImageGear.Processing.Layers Namespace and related new classes in ImageGear.Windows.Forms Namespace: ImGearLayerProperties Class and ImGearLayersSwitching Class.
  • Enhanced support for the Spot Color Scheme (Pantone and others). See Working with Spot Colors.

Image Processing Enhancements

ImageGear v16 introduces new Image Processing enhancements in the following categories:

  • ImageClean Enhancements
  • Mathematical Morphology
  • Special Effects

ImageClean Enhancements

There are the following new ImageClean features:

  • Punch holes removal

RemovePunchHoles Method automatically detects and removes the punch holes on a 1-bit scanned image. It works for most common hole puncher standards including 2, 3, 4 and 5 hole puncher marks. The method takes a 1-bit image page and the set of advanced parameters specifying the location and diameter of punch holes.

  • Line removal

RemoveLines Method automatically detects and removes horizontal and vertical solid and broken lines on the 1-bit scanned image. The method takes a 1-bit image page and the set of advanced parameters specifying the line's attributes.

  • Dot Line removal

RemoveDotLines Method automatically detects and removes horizontal and vertical dotted lines on the 1-bit scanned image. The method takes a 1-bit image page and the set of advanced parameters specifying the attributes to be used for the processing.

Mathematical Morphology

The field of mathematical morphology contributes a wide range of operators to image processing, all based around a few simple mathematical concepts from set theory. The operators are particularly useful for the analysis of binary images and common usages include edge detection, noise removal, image enhancement and image segmentation.

The following morphology ImageProcessing functions have been added: Close Method, Dilate Method, Erode Method, and Open Method.

See Also:

Mathematical Morphology

Special Effects

ImageGear version 16 introduces the following new ImageProcessing effects:

  • Shear - The Shear Method applies a shearing effect to an image, moving the image rasters or columns according to the specified offsets.
  • Aging - The Aging Method applies an aging effect to make an image look older.
  • Spatter - The Spatter Method applies a spatter effect to an image, making it look to have been painted in the impressionist style of painting.
  • Shadow - The DropShadow Method adds a drop shadow to an image.
  • Oilify - The Oilify Method makes the image appear similar to an oil painting.
  • Functional Light -
    • The DirectionalLight Method adds bars of light according to a sine wave pattern.
    • The RadialLight Method adds circles of light according to a sine wave pattern.
    • The FreeDirectionalLight Method adds bars of light according to a custom pattern.
    • The FreeRadialLight Method adds circles of light according to a custom pattern.
  • Fragmentation - The Fragment Method fragments an image into four blended images which move diagonally outward from the original image.
  • Lens Flare - The LensFlare Method applies a lens flare effect to the image.
  • Pointillist - The Pointillist Method makes the image appear to have been painted in the pointillism style of painting.
  • Vignette - The Vignette Method either allows you to draw a vignette over an image or to turn an image into a semi-transparent vignette that you can then blend over other images.
  • Round Corners - The RoundCorners Method rounds the corners of the image and fills them with a specified color.
  • Night Vision - The NightVision Method applies "night vision" effect to the image.
  • Toy Camera - The ToyCamera Method makes the image look as if it was taken by a toy camera. It imitates the distortions caused by cheap lens and poor shooting conditions to create visual interest.
  • Sepia - The Sepia Method makes the image look like an old sepia toned photograph.
  • Duotone - The Duotone Method maps image colors to a gradient between the two specified colors.
  • Spotlights - The Spotlights Method darkens the image and highlights selected areas as if they are illuminated with a spotlight or sunlight. You can also use ImGearRasterProcessing.SpotlightsPreview Method method for fast generation of a small preview of the effect.
  • Picturize - The Picturize Method divides the image into rectangular cells, and replaces each cell with an image from the specified image collection, attempting to select cell images such that they match colors of course image.
  • High Density Range - The HighDensityRangeEffect Method increases contrast separately in shadow, highlight and midtone areas, imitating human eye's ability to adapt for light conditions at the point of interest.
  • Glowing Edges - The GlowingEdges Method highlights edges on the image with bright colors, and fills flat areas with black.
  • Sketch - The Sketch Method blends the source image with a texture image, making it look like painted by a pencil or charcoal.
  • Hot Wax - The HotWax Method makes an image look like it has been coated with wax.
  • Monochrome Film - The MonochromeFilm Method makes an image look like it has been taken with an analog camera, using a monochrome film.
  • Boost - The Boost Method increases saturation, brightness and contrast of the image.
  • Adjust White Balance - The AdjustWhiteBalance Method corrects white balance of the image.
  • Chromatic Aberration Removal - The RemoveChromaticAberration Method removes chromatic aberration artifacts from an image. Chromatic aberration is caused by differences in refraction of light components by the lens, and is seen as colored "fringes" around the image.
See Also:

Using ImageGear.Processing Namespace

Miscellaneous Enhancements

  • New VS 2008 samples are available.

PDF Enhancements

  • Support for 3D PDF Content
  • PDF/X and PDF/A Verifiers
  • PDF Display Performance Optimization

Support for 3D PDF Content

ImageGear v16 introduces support for 3D PDF content. Starting with version 1.6, PDF introduces the capability for collections of 3D objects, such as those used by CAD formats, to be embedded in PDF files. Such collections are called 3D models, and PDF refers to them as 3D Artwork. In PDF documents, 3D Artwork is represented by 3D annotations stored in Universal 3D (U3D) format (see Support for Universal 3D (U3D)).

See Also:

Working with 3D Artwork

Image Mark

PDF Marks

PDF/X and PDF/A Verifiers

There is new ImageGear API that verifies compliance with PDF/X and PDF/A standards, which are defined by the International Organization for Standardization (ISO).

  • PDF/X standards apply to graphic content exchange

The most widely used standards for a print publishing workflow are several PDF/X formats: PDF/X-1a, PDF/X-3, and PDF/X-4.

  • PDF/A standards apply to long-term archiving of electronic documents

The most widely used standards for PDF archiving are PDF/A-1a and PDF/A-1b (for less stringent requirements).

For more information on PDF/X and PDF/A, see the ISO website.

See Also:

PDF Standards

ImGearPDFPreflight Class

ImGearPDFPreflightReport Class

PDF Display Performance Optimization

ImageGear 16.0 introduces optimized PDF display rendering and scrolling capabilities. The ResetDisplayCache Method causes IG display API to re-render PDF page content for display.

Vector Enhancements

The following vector enhancements are introduced in ImageGear v16:

  • Support for Universal 3D (U3D)
  • Support for Design Web Format (DWF)
  • Support for Gradient Fill Type

Support for Universal 3D (U3D)

U3D file format, short for "Universal 3D", is a universal vector standard for storing three-dimensional data of all kinds to facilitate data exchange. The U3D format is natively supported by PDF, and 3D objects in U3D format can be inserted into PDF document files and interactively visualized by PDF viewers (also see Support for 3D PDF Content).

The ImageGear.Formats.U3D Namespace supports reading, writing and rasterizing the U3D vector files.

Support for Design Web Format (DWF)

DWF is an open file format developed by AutoDesk for storing DWG files on the Internet. DWF contains a vector based description of drawings and illustrations.

Support for Gradient Fill Type

Support for linear and radial gradient filling for vector objects has been added. Linear gradient filling specifies a transition of color from start to end point of the filling. Radial gradient specifies a transition from start point to the outer circle of the filling. Gradient filling uses an array of "stops" to define the transition function. See Working with Gradient Filling for more information.

Miscellaneous Enhancements

  • Support for the new XPS file format. The XPS Document format represents a set of related pages with a fixed layout, which are organized as one or more documents, in the traditional meaning of the word. ImageGear.WPF.XPS Namespace
  • .NET WPF Hand-Panning functionality. See Pan and ImGearPanCtl Class.
  • Improved all unmanaged libraries to have the version numbers matching the IG.NET.


Overview

ImageGear provides the most comprehensive set of imaging features available. It provides a complete set of over 2000+ methods and properties focused on the following features:

  • High Speed Display
  • Image Loading and Saving
  • Printing
  • Advanced TWAIN Scanning
  • Image Processing
  • Pixel Access
  • Compression
  • Native CMYK Support for All Color Spaces and Bit Depths
  • ROI Processing


High Speed Display

ImageGear gives you complete control over how your application displays each of its images. Among the attributes you can set on an image-by-image basis are:

  • Auto-color reduction for low color modes
  • High-quality display for all video modes
  • Contrast/Brightness control
  • Display effects (wipes, blocks, etc.)
  • Color reduction (several types)
  • Transparency
  • Gamma correction
  • Dithering
  • Rotation
  • The region within the display area where the image is to be displayed (this area is called the Device Rectangle)
  • The portion of the image to display (this array of pixels within the DIB bitmap is called the Image Rectangle)
  • How to fit the Image Rectangle to the Device Rectangle
  • The background fill pattern and color to use (for any area of the Device Rectangle left vacant by the image)
  • Center image in window
  • Fit to width/height/window
  • Precision scrolling
  • Sub-region display
  • Auto-aspect ratio
  • Preserve black and preserve white display for 1-bit images
  • Sub-second display rotation
  • Faster image display
  • Anti-alias display
  • Huge image display capability
  • Merge two Images during display
  • 4x faster scale-to-gray
  • Using LUTs (look-up tables) to cause the colors in an image's color palette to be translated to other colors you select (i.e., you can display an 8-bit grayscale image in any 256 colors you choose).

All of the above display attributes affect the display only. They do not alter either the image bitmap or the color palette in the DIB. In addition, any time your image is being displayed, you can center, zoom or scroll it from within your application. See ImageGear.Display Namespace for more information.


Image Loading and Saving

ImageGear supports over 100 raster file formats. See the ImageGear Imaging Formats Reference for more information. AccuSoft also is the only company willing to guarantee that all images in the listed formats will be displayed correctly (see AccuSoft Image Guarantee).


Printing

  • Print to any Windows printer with complete control
  • Auto-color reduction for high quality printing
  • Single- or multi-page printing
  • ImageGear automatically overcomes several inherent limitations of printer drivers to ensure your images print at the highest quality possible
  • ImageGear's printing functionality includes automatic sizing to full page, half, quarter, eighth and sixteenth, with auto page centering or specific placement
  • Printing many images to a single page is as simple as specifying the location of each image
  • Images can be printed to any location and at any size desired
  • ImageGear includes a sample to illustrate printing a single image onto multiple pages for creating posters of any size


Advanced TWAIN Scanning

ImageGear supports TWAIN 1.6, 1.7, 1.8, and 1.9, working with a wide variety of scanner devices, digital cameras, and video capture boards. No TWAIN toolkit is easier or more comprehensive. See ImageGear.TWAIN Namespace for more information.

ImageGear includes a wide array of functions, providing the developer with detailed control of the scanning process, including:

  • Control of the TWAIN transfer mode
  • Control of the available TWAIN device listing
  • Control of the scanning area
  • Control of the brightness and contrast
  • Control of the dots-per-inch (resolution)
  • Control of the display of the TWAIN UI
  • Setting of a callback function to gain control during scanning
  • Control of the ADF (Automatic Document Feeder) for multi-page scanning
  • Control of scanner capabilities


Image Processing

ImageGear for .NET has the following Image Processing functionality, among others:

  • Region of interest (ROI) support for basic rectangles as well as ellipses, polygons and other shapes
  • The most complete color space support, including color space conversions, color separation and combination, support for any color space found in any of the 100 supported formats, and support for color spaces such as CMYK, without conversion to RGB, for perfect fidelity
  • Powerful color reduction for maximum quality and minimum size
  • Encryption and decryption for entire image or any part of image
  • Matrix convolutions of any size with pre-defined or user-supplied matrix values
  • Special effects, automatic image correction, intelligent re-sizing

See ImageGear.Processing Namespace and Using ImageGear.Processing Namespace for more information.


Pixel Access

ImageGear is equipped with several functions that will allow you to get and set the values of individual pixels, rows or columns of pixels, and rectangular groups of pixels. This family of functions is referred to as the "pixel access" functions. For each kind of pixel access, you can obtain (get) the value(s) of a pixel or group of pixels, or set the value(s) of a pixel or group of pixels.


Compression

ImageGear supports all industry-standard compression algorithms. See the ImageGear Imaging Formats Reference for more information.


Native CMYK Support for All Color Spaces and Bit Depths

  • Images stored in CMYK format can be loaded into ImageGear without being converted to RGB, ensuring the original color information is maintained with perfect fidelity
  • Images can be saved to formats that support CMYK color space
  • Images stored in CMYK can be optionally converted to RGB when loaded (default for STD), or converted to RGB at any time after loading
  • Basic image processing, image access, display and other functions work with native CMYK image data
  • CMYK images can be color separated or converted to several other color spaces


ROI Processing

  • Specify rectangular ROI for nearly all image processing functions
  • Specify arbitrary ROI for most image processing functions (i.e., ellipse, polygon and freehand)
  • Create 1-bit mask image for identifying which pixels to include/disclude from image processing algorithms

See ImGearROI Class, ImGearROIMask Class, and ImGearROIRectangle Class for more information.


Supported Formats and Compressions

ImageGear for .NET 16.0 supports a great number of the most popular graphics file formats, preventing compatibility problems before they arise. You can see the complete list of supported formats and compressions as well as references for them in ImageGear Imaging Formats Reference Chapter.

ImageGear for .NET also provides support for 100+ latest Digital Camera RAW Formats. Please see the section ImageGear Supported Digital Camera RAW Formats Reference.


ImageGear for .NET Namespaces

ImageGear functionality is divided into namespaces. This provides flexibility in packaging and licensing ImageGear technology. Each namespace encapsulates a particular functionality of the product. All namespaces are enabled when you evaluate or purchase the product (there is an expiration date for the evaluation version). However, different licensing fees may be associated with different namespaces for deployment of your application. Please contact your AccuSoft sales representative for more information about deployment licensing fees.

You will need to initialize the namespace (other than Core namespace) before using it. See the Samples for a demonstration of initializing the namespaces. The sample code has been provided so that you may simply cut and paste the initializing namespace code into your own application.

Please see the Installing and Distributing ImageGear Chapter for information about ImageGear and the namespace licensing process.

This section provides an ImageGear Namespaces Availability table, indicating which Namespaces are available on which platforms, and also an ImageGear Namespaces Descriptions section that describes each Namespace.


ImageGear Namespaces Availability

The ImageGear for .NET documentation provides information for all platforms and .NET framework versions. However, not all features are available for all ImageGear for .NET versions. The following table describes which ImageGear for .NET Namespaces are available for which versions (Windows 32-bit platforms with .NET 2.0/3.0 Framework, Windows 64-bit platforms with .NET 2.0/3.0 Framework, .NET Compact Framework).

Namespace
32-bit
64-bit
.NET CF
ImageGear.Core
x
x
x
ImageGear.ART
x
x
ImageGear.ART.Forms
x
x
ImageGear.Display
x
x
x
ImageGear.Formats
x
x
x
ImageGear.Formats.CAD
x
x
ImageGear.Formats.CGM
x
x
ImageGear.Formats.DGN
x
x
ImageGear.Formats.DICOM
x
x
x
ImageGear.Formats.EXIF
x
x
x
ImageGear.Formats.HPGL
x
x
ImageGear.Formats.IPTC
x
x
x
ImageGear.Formats.JPEG2K
x
x
ImageGear.Formats.JPG
x
x
x
ImageGear.Formats.PDF
x
x
ImageGear.Formats.TIF
x
x
x
ImageGear.Formats.U3D
x
x
ImageGear.Formats.XMP Namespaces
x
x
x
ImageGear.FreqIP
x
ImageGear.Processing
x
x
x
ImageGear.Processing.ImageClean
x
x
x
ImageGear.Processing.Layers
x
x
x
ImageGear.TWAIN
x
ImageGear.Vector
x
x
ImageGear.Web.Forms
x
x
ImageGear.Windows.Forms
x
x
x
ImageGear.Windows.Forms.Thumbnail
x
x
x
ImageGear.WPF
x
x
ImageGear.WPF.XPS
x
x


ImageGear Namespaces Descriptions

This section summarizes the ImageGear for .NET namespaces that are currently available. For more information on these namespaces, refer to the Using ImageGear for .NET and ImageGear.Core Namespace chapters.

The following ImageGear namespaces are available:

  • ImageGear.Core Namespace
  • ImageGear.ART Namespace
  • ImageGear.ART.Forms Namespace
  • ImageGear.Display Namespace
  • ImageGear.Formats Namespace
  • ImageGear.Formats.CAD Namespace
  • ImageGear.Formats.CGM Namespace
  • ImageGear.Formats.DGN Namespace
  • ImageGear.Formats.DICOM Namespace
  • ImageGear.Formats.EXIF Namespace
  • ImageGear.Formats.HPGL Namespace
  • ImageGear.Formats.IPTC Namespace
  • ImageGear.Formats.JPEG2K Namespace
  • ImageGear.Formats.JPG Namespace
  • ImageGear.Formats.PDF Namespace
  • ImageGear.Formats.TIF Namespace
  • ImageGear.Formats.U3D Namespace
  • ImageGear.Formats.XMP Namespace
  • ImageGear.Formats.XMP.AdobePDF Namespace
  • ImageGear.Formats.XMP.Basic Namespace
  • ImageGear.Formats.XMP.BasicJobTicket Namespace
  • ImageGear.Formats.XMP.CameraRaw Namespace
  • ImageGear.Formats.XMP.DublinCore Namespace
  • ImageGear.Formats.XMP.DynamicMedia Namespace
  • ImageGear.Formats.XMP.EXIF Namespace
  • ImageGear.Formats.XMP.EXIFAux Namespace
  • ImageGear.Formats.XMP.IPTC4XMPCore Namespace
  • ImageGear.Formats.XMP.MediaManagement Namespace
  • ImageGear.Formats.XMP.MicrosoftPhoto Namespace
  • ImageGear.Formats.XMP.PagedText Namespace
  • ImageGear.Formats.XMP.Photoshop Namespace
  • ImageGear.Formats.XMP.RightsManagement Namespace
  • ImageGear.Formats.XMP.TIFF Namespace
  • ImageGear.FreqIP Namespace
  • ImageGear.Processing Namespace
  • ImageGear.Processing.ImageClean Namespace
  • ImageGear.Processing.Layers Namespace
  • ImageGear.TWAIN Namespace
  • ImageGear.Vector Namespace
  • ImageGear.Web.Forms Namespace
  • ImageGear.Windows.Forms Namespace
  • ImageGear.Windows.Forms.Thumbnail Namespace
  • ImageGear.WPF Namespace
  • ImageGear.WPF.XPS Namespace

ImageGear.Core Namespace

The ImageGear Core namespace is a foundation for all other namespaces and contains shared classes used in other namespaces such as ImGearPage Class, ImGearDocument Class and global attributes such as error handling classes and licensing.

For detailed information about using the Core component, see the chapter entitled ImageGear.Core Namespace .

ImageGear.ART Namespace

Using the ART namespace, you can annotate any image that your application loads into ImageGear. The annotations are called "ART marks", or "marks" for short. Marks objects are created by using their constructors, but their actual life starts when they are added into the ImGearARTPage Class. ART page can be associated with one or more ImGearPage Class objects. The association is done by using ImGearPageDisplay Class properties: Page and ARTPage. ART internally tracks the marks that are associated with the image and insures that marks are always displayed on the correct part of the image (even as the image is scrolled, rotated, flipped and zoomed). Your application can save an image with the marks into a separate file in legacy .ART file format or .XML file format. Anytime the image is reloaded, the ART marks can be reloaded with a simple function-call.

For detailed information about using the Core component, see the sections entitled Using ImageGear.ART Namespace, ART 2.0 and ART 3.0 Marks and the Chapter ImageGear.ART Namespace.

ImageGear.ART.Forms Namespace

The ImageGear.ART.Forms namespace allows you to add redlining and annotation capabilities to any application built with ImageGear. It provides ART GUI functionality that can simplify development of ImageGear based applications. This functionality is implemented in WinForms assembly, using only public ImageGear API, with source code provided to enable modifications. See ImageGear.ART.Forms Namespace for information.

ImageGear.Display Namespace

The ImageGear Display namespace provides access to ImageGear display API and contains shared classes and structures used for image drawing.

For detailed information about using the Display namespace, see the Chapter entitled ImageGear.Display Namespace. See also Displaying Images section.

ImageGear.Formats Namespace

The ImageGear Formats namespace provides image loading/saving operations for all other ImageGear namespaces.

For detailed information about using the Formats namespace, see the Chapter entitled ImageGear.Formats Namespace.

ImageGear.Formats.CAD Namespace

This namespace provides the API to create DWG and DXF vector formats. See ImageGear.Formats.CAD Namespace for more information.

ImageGear.Formats.CGM Namespace

This namespace provides the API to create CGM vector format. See ImageGear.Formats.CGM Namespace for more information.

ImageGear.Formats.DGN Namespace

This namespace provides the API to create DGN vector format. See ImageGear.Formats.DGN Namespace for more information.

ImageGear.Formats.DICOM Namespace

ImageGear.Formats.DICOM namespace provides features that are used with medical and DICOM images. The following sections discuss various aspects of working with these images.

DICOM is a public standard created to provide a flexible and expandable means for storing, sharing, and transporting digital medical images. Today DICOM is the standard for medical imaging throughout the world.

ImageGear DICOM namespace is a full-featured ImageGear component. It supports the DICOM format, contains a custom API, and includes expanded image processing capabilities beyond those of the baseline ImageGear library.

The format support of the MD component includes loading and saving monochrome, palettized, and true color medical images using the following file formats:

  • DICOM 3.0 Part 10-compliant images
  • DICOM 3.0 Raw Format (non-Part 10-compliant)

ImageGear DICOM namespace provides DICOM Presentation State objects that allow you to display images on various devices and media, to storage specific settings for display (contrast transformations, geometric transformations), to storage ART annotations and to display multiframe images.

In addition, your application will continue to support all ImageGear-supported file formats, allowing you to convert an image of a different format to a medical image format, and vice-versa.

For detailed information about using the DICOM namespace, see the Chapter entitled ImageGear.Formats.DICOM Namespace as well as Using ImageGear.Formats.DICOM Namespace, Displaying Medical Images and Metadata Dictionary sections in Using ImageGear for .NET.

ImageGear.Formats.EXIF Namespace

This namespace provides the API for operating with EXIF non-image data. See ImageGear.Formats.EXIF Namespace for more information.

ImageGear.Formats.HPGL Namespace

This namespace provides the API to create HPGL vector format. See ImageGear.Formats.HPGL Namespace for more information.

ImageGear.Formats.IPTC Namespace

This namespace contains classes, structures, and enumerations that provide simplified access to IPTC metadata. See ImageGear.Formats.IPTC Namespace for more information.

ImageGear.Formats.JPEG2K Namespace

The JPEG 2000 standard provides a set of features that take advantage of new technologies, making them important to many high-end and emerging applications. It addresses areas where current standards fail to produce the best quality or performance and provides capabilities to markets that currently do not use compression. The markets and applications better served by the JPEG 2000 standard are Internet, color facsimile, printing, scanning (consumer and pre-press), digital photography, remote sensing, mobile, medical imagery, digital libraries/archives and eCommerce. Each application area imposes some requirements that the standard should fulfill.

The ImageGear JPEG2K namespace is based on the Kakadu SDK, which allows you to use the diverse functionality of the JPEG 2000 wavelet-based compression technique. It provides such advantages:

  • Excellent image quality at high compression ratios
  • Fast compression and decompression
  • Both lossless (guaranteed pixel identity) and lossy image compression options
  • User-controlled compression ratio
  • Quicklook generation and scaled image reconstruction based on embedded coding techniques
  • Elimination of JPEG-like blocking artifacts

All these features outperform all other image compression techniques. JPEG 2000 image compression is best suited for compression either of sensitive images, because of the lossless feature, or for its excellent image quality at high compression ratios for uses such as transmission in low bandwidth applications.

The ImageGear JPEG2K namespace also provides support for JPX and Motion JPEG2000 formats.

For detailed information about using the JPEG 2000 namespaces, see the Chapter entitled ImageGear.Formats.JPEG2K Namespace.

ImageGear.Formats.JPG Namespace

This namespace provides enumerations values for JPEG format filter control parameters. See ImageGear.Formats.JPG Namespace for more information.

ImageGear.Formats.PDF Namespace

The ImageGear PDF namespace allows you to load, save and process PDF (Portable Document Format) files using Core ImageGear and other IG namespace functionality.

This namespace also allows you to read vector data from PS (PostScript) and EPS (Encapsulated PostScript) file formats (Core ImageGear namespace allows you to read only raster data from these two formats).

In addition, the PDF namespace provides the ability to extract text from loaded PDF and PS image files.

For detailed information about using the PDF namespace, see the section entitled Using ImageGear.Formats.PDF Namespace and ImageGear.Formats.PDF Namespace Chapter.

ImageGear.Formats.TIF Namespace

This namespace provides public API for TIFF format metadata operating and for TIFF filter control parameters. See ImageGear.Formats.TIF Namespace for more information.

ImageGear.Formats.U3D Namespace

This namespace provides the API to create U3D vector format. See ImageGear.Formats.U3D Namespace for more information.

ImageGear.Formats.XMP Namespace

This namespace provides the API for XMP format. See the section entitled ImageGear.Formats.XMP Namespace.

ImageGear.Formats.XMP.AdobePDF Namespace

This namespace provides the API for XMP.AdobePDF format. See the section entitled ImageGear.Formats.XMP.AdobePDF Namespace.

ImageGear.Formats.XMP.Basic Namespace

This namespace provides the API for XMP.Basic format. See the section entitled ImageGear.Formats.XMP.Basic Namespace.

ImageGear.Formats.XMP.BasicJobTicket Namespace

This namespace provides the API for XMP.BasicJobTicket format. See the section entitled ImageGear.Formats.XMP.BasicJobTicket Namespace.

ImageGear.Formats.XMP.CameraRaw Namespace

This namespace provides the API for XMP.CameraRaw format. See the section entitled ImageGear.Formats.XMP.CameraRaw Namespace.

ImageGear.Formats.XMP.DublinCore Namespace

This namespace provides the API for XMP.DublinCore format. See the section entitled ImageGear.Formats.XMP.DublinCore Namespace.

ImageGear.Formats.XMP.DynamicMedia Namespace

This namespace provides the API for XMP.DynamicMedia format. See the section entitled ImageGear.Formats.XMP.DynamicMedia Namespace.

ImageGear.Formats.XMP.EXIF Namespace

This namespace provides the API for XMP.EXIF format. See the section entitled ImageGear.Formats.XMP.EXIF Namespace.

ImageGear.Formats.XMP.EXIFAux Namespace

This namespace provides the API for XMP.EXIFAux format. See the section entitled ImageGear.Formats.XMP.EXIFAux Namespace.

ImageGear.Formats.XMP.IPTC4XMPCore Namespace

This namespace provides the API for XMP.IPTC4XMPCore format. See the section entitled ImageGear.Formats.XMP.IPTC4XMPCore Namespace.

ImageGear.Formats.XMP.MediaManagement Namespace

This namespace provides the API for XMP.MediaManagement format. See the section entitled ImageGear.Formats.XMP.MediaManagement Namespace.

ImageGear.Formats.XMP.MicrosoftPhoto Namespace

This namespace provides the API for XMP.MicrosoftPhoto format. See the section entitled ImageGear.Formats.XMP.MicrosoftPhoto Namespace.

ImageGear.Formats.XMP.PagedText Namespace

This namespace provides the API for XMP.PagedText format. See the section entitled ImageGear.Formats.XMP.PagedText Namespace.

ImageGear.Formats.XMP.Photoshop Namespace

This namespace provides the API for XMP.Photoshop format. See the section entitled ImageGear.Formats.XMP.Photoshop Namespace.

ImageGear.Formats.XMP.RightsManagement Namespace

This namespace provides the API for XMP.RightsManagement format. See the section entitled ImageGear.Formats.XMP.RightsManagement Namespace.

ImageGear.Formats.XMP.TIFF Namespace

This namespace provides the API for XMP.TIFF format. See the section entitled ImageGear.Formats.XMP.TIFF Namespace.

ImageGear.FreqIP Namespace

This namespace provides public API functions for features related to image processing in frequency domain, such as Fourier Transform, Low Pass Filter, etc. See ImageGear.FreqIP Namespace for more information.

ImageGear.Processing Namespace

The ImageGear Processing namespace is responsible for the image processing functionality. It provides the capability to resize, rotate, adjust brightness and contrast, reduce or promote bit depth, and perform many other image processing operations.

For detailed information about using the Processing namespace, see the Chapter entitled ImageGear.Processing Namespace. See also Processing Images section.

ImageGear.Processing.ImageClean Namespace

This namespace contains classes to enhance bi-level image support. It includes the ability to check for "noise" of black pixels, clean borders, invert white text, auto-orient image, auto invert black text on the white background, and auto-crop. See ImageGear.Processing.ImageClean Namespace for more information.

ImageGear.Processing.Layers Namespace

The ImageGear.Processing.Layers namespace provides an API for creating and editing image layers. This namespace also introduces a new type of ImGearLayeredPage Class, which consists of two parts: raster composition image and array of layers. See ImageGear.Processing.Layers Namespace for more information.

ImageGear.TWAIN Namespace

The TWAIN standard is widely supported by scanner manufacturers, with most users at TWAIN version 1.8. The ImageGear TWAIN component allows you to support all three TWAIN Transfer Modes: Native Data Transfer Mode (which is the TWAIN default); Disk File Transfer; and Buffered Memory.

For detailed information about using the TWAIN namespace, see the section entitled Using ImageGear.TWAIN Namespace and ImageGear.TWAIN Namespace Chapter.

ImageGear.Vector Namespace

The ImageGear.Vector namespace provides native support for vector data as used by CAD/vector formats such as DWF, DWG, CGM, DGN, and HPGL. When you load any of these formats, the resulting ImGearPage object is not automatically rasterized at load time. The data is kept in vector form for display and processing. It's possible to display the vector data from different viewpoints and edit individual vector entities. The vector data can also be rasterized, converting it to a bitmap form.

For detailed information about using the Vector namespace, see the section entitled Using ImageGear.Vector Namespace and ImageGear.Vector Namespace Chapter.

ImageGear.Web.Forms Namespace

ImageGear WebForms namespace, that is also named as ImageGear WebForms toolkit, allows you to view and process images through the internet. The main class of the WebForms toolkit is ImGearWebPageView Class. It is an ASP.Net server control. It allows you to display images on the client computer within a browser window. This class is fully integrated with the main API, which makes all of ImageGear functionality available for viewing on the client computer, and allows easy migration of imaging functionality from desktop applications to internet applications.Besides this, ImageGear WebForms toolkit provides:

  • Real-time client-side scrolling.
  • Drawing a selection rectangle over the image.

Please see Using ImageGear.Web.Forms Namespace and ImageGear for .NET WebForms Tutorial sections, as well as ImageGear.Web.Forms Namespace Chapter for more detailed information how to use new ImageGear WebForms namespace API.

ImageGear.Windows.Forms Namespace

The ImageGear.Windows.Forms Namespace provides common GUI functionality that can simplify development of Windows Forms based applications. This functionality is implemented in a separate assembly, using only public ImageGear API, with source code provided to enable modifications.

ImageGear.Windows.Forms.Thumbnail Namespace

The ImageGear.Windows.Forms.Thumbnail Namespace provides the GUI Thumbnail control API.

ImageGear.WPF Namespace

The ImageGear.WPF Namespace provides functionality for compatibility with the Windows Presentation Foundation framework, which is a new user interface subsystem and API based on XML and vector graphics available on Windows Vista.

ImageGear.WPF.XPS Namespace

The ImageGear.WPF.XPS Namespace provides full multi-page reading, writing and printing support for XPS documents and pages. You can detect, read, write, append, insert, replace, delete and print specified pages in the XPS document as well as convert raster images to XPS.


About Customer Support

This section provides information about AccuSoft Customer Support, including the following:

  • Need Help?
  • Software Support and Maintenance Policy
  • AccuSoft Image Guarantee


Need Help?

If you are unable to find an answer to your questions in the help, refer to the Release Notes, which provide release-specific information, including changes made to the product since the last update. If you need additional assistance, please read the procedures below:

  • Check the Manual provided with this product or the on-line documentation.
  • Check the Release Notes files for updated information.
  • Refer to Getting Started, Using ImageGear for .NET, and the AccuSoft Image Guarantee. These chapters contain a great deal of information on both programming your application and identifying image problems.
  • Take a look at the sample programs included with your product.
  • Visit www.accusoft.com. Our Web site provides access to a wealth of product information, including:
    • Product Information and Specifications
    • Product Downloads
    • Customer Support
    • Demonstrations and Tutorials
    • On-line Documentation

If you still need technical support assistance, please follow the instructions provided in the Software Support and Maintenance Policy.


AccuSoft Image Guarantee

ImageGear is guaranteed to read all valid raster images for supported formats. If for some reason, you cannot read an image with our library, one or more of three things may have occurred:

  1. The image is corrupted.
  2. The image is improperly coded.
  3. ImageGear is not reading this image properly.

See the section Identifying an Image Problem.

Identifying an Image Problem

In the rare instance that ImageGear cannot read an image, please try the following:

  1. Try to read the image with another software package. Be sure to use a different package from the one that created the image. Some products that claim to produce a particular graphics file format do not adhere completely to the format specifications. If you can successfully read the image with a different product, you can feel confident that it is a valid image.
  2. If you can read the file with a package other than the one that created the image, please refer to the section Sending the Image to Accusoft for the instructions how to send us your image.

Check the error count that is returned by ImageGear. For more information on doing this, you can consult either the ImageGear.Core Namespace, or the section entitled Warnings and Errors in Using ImageGear for .NET chapter.

Sending the Image to Accusoft

To send your image to AccuSoft, please log a support ticket via our web-ticketing system, and attach the file once the ticket is created, so that our Customer Support Team can address your problem as soon as possible.


Installing and Distributing ImageGear

This Chapter provides you with the following information:

  • System Requirements
  • Installing ImageGear for .NET
  • Directory Structure
  • Uninstalling ImageGear for .NET
  • Licensing and Distributing ImageGear for .NET
  • Licensing and Deployment Kit


System Requirements

This section has the system requirements for the following .NET Frameworks:

  • ImageGear for .NET Framework 2.0 and 3.0/3.5
  • ImageGear for .NET Compact Framework
NOTE: Microsoft Windows Vista and Visual Studio 2005/2008

Microsoft recommends running Visual Studio 2005/2008 with administrator privileges under Vista. To properly use the ImageGear Samples please run Visual Studio 2005/2008 with elevated permissions. To run Visual Studio 2005/2008 with elevated administrator permissions, first confirm you are a member of the "Administrators" group on the local machine. Then right-click the Visual Studio 2005/2008 shortcut and select the "Run as administrator" option from the context menu. Click `Continue' to the UAC prompt. To ensure you have the latest updates, after running Visual Studio 2005/2008 choose `Check for Updates' from the Help Menu.


ImageGear for .NET Framework 2.0 and 3.0/3.5

Supported Operating Systems

  • Windows 2000 Service Pack 4
  • Windows Server 2003 Service Pack 1
  • Windows Server 2003 x64 Edition
  • Windows XP Service Pack 2
  • Windows XP Professional x64 Edition
  • Windows Vista
  • Windows Vista 64-bit Edition
  • Windows Server 2008
  • Windows Server 2008 64-bit Edition

Supported .NET Framework

Microsoft .NET Framework 3.0, 3.5, or Microsoft .NET Framework 2.x

Disk Space

The Installation program will tell you how much disk space you need in order to load ImageGear. The disk space used will vary, depending upon the options you select during installation.


ImageGear for .NET Compact Framework

Supported Development Environment Operating Systems

  • Windows 2000 Service Pack 4
  • Windows Server 2003 Service Pack 1
  • Windows Server 2003 x64 Edition
  • Windows XP Service Pack 2
  • Windows XP Professional x64 Edition
  • Windows Vista
  • Windows Vista 64-bit Edition
  • Windows Server 2008
  • Windows Server 2008 64-bit Edition

Supported Runtime Environment Operating Systems

  • Windows CE .NET
  • Windows Mobile 2003 software for Pocket PCs
  • Windows Mobile 5.0 for PocketPC and Smartphone

Supported .NET Framework

Microsoft .NET Compact Framework version 2.0, 3.0, and 3.5

Disk Space

The Installation program will tell you how much disk space you need in order to load ImageGear. The disk space used will vary, depending upon the options you select during installation.


Installing ImageGear for .NET

To install ImageGear, perform the following steps:

  1. Start the installer
    1. From CD, insert the CD and auto-start should run setup.exe. If not you can manually run this from the CD. From setup.exe you can view the release notes or start the installer.
    2. From Web, after the download finishes run the exe.
  2. Click the "Next" button to continue past the welcome dialog.
  3. Carefully read the information contained in the "License Agreement" form before making a decision to accept the terms of the agreement. Choose "I accept the license agreement" to accept the conditions outlined in the License Agreement and then click the "Next" button to continue the installation, or click "Cancel" to exit the installation process.
  4. If you accepted the License Agreement and continued the installation process, the "User Information" form appears next. Enter your name and the name of your company in the "Full Name" and "Organization" text boxes, respectively. Then click "Next".
  5. After clicking "Next" the Destination Directory form is displayed. Choose the destination directory where the ImageGear product should be installed or choose the default installation destination directory. Then click "Next".
  6. Once you click the "Next" button, the product "Select Features" form is displayed. In this form you can:
    1. Choose the features and namespaces of the selected product to install on your PC.
    2. Get information about how much of your hard disk memory is required to install the product features that you have chosen in 5a.
  7. When all these options are chosen, click the "Next" button to continue the installation process and then click "Finish".


Directory Structure

If you accept the suggested default, the installation program creates the following directory structure:

Directory
Description
C:\Program Files\AccuSoft\ImageGear.NET v16\Bin
ImageGear for .NET assemblies and dependencies. Compiled sample binaries.
C:\Program Files\AccuSoft\ImageGear.NET v16\Docs
ImageGear for .NET Documentation
C:\Program Files\AccuSoft\ImageGear.NET v16\LDK
ImageGear for .NET Licensing and Deployment Kit.
C:\Program Files\AccuSoft\ImageGear.NET v16\Samples
ImageGear for .NET Sample Projects Source
C:\Program Files\AccuSoft\ImageGear.NET v16\Utils
ImageGear for .NET Utilities.
C:\Program Files\AccuSoft\ImageGear.NET v16\WinForms
ImageGear for .NET WinForms.


Uninstalling ImageGear for .NET

To uninstall ImageGear for .NET please do the following:

  • Run Add/Remove Programs from the Control Panel.
  • Choose "AccuSoft ImageGear for .NET".
  • Click "Change/Remove" button.
  • Select "Remove" and click Next.


Licensing and Distributing ImageGear for .NET

During the ImageGear for .NET installation, you need to obtain a license key using the AccuSoft License Manager that is run automatically at the end of the installation. If you need to run it manually in the future you can do it using the following shortcut:

Start Menu\Programs\AccuSoft\ImageGear for .NET v16\License Manager

The License Manager utility requires an Internet connection in order to manage the license keys. If you don't have Internet connection, please call AccuSoft Customer Service at 1-508-351-9092.

This section provides the following information:

  • ImageGear for .NET Evaluation License
  • ImageGear for .NET Development License
  • ImageGear for .NET Deployment License
  • Distributing ImageGear for .NET Application


ImageGear for .NET Evaluation License

If you are evaluating the product, please select the ImageGear evaluation license option from the initial screen of the License Manager utility. You will be prompted to log in using the same e-mail and password you have registered with on the AccuSoft Web site. After you supply login credentials, your license key will be automatically obtained and stored on your computer. An Evaluation license enables you to use any features of the product on your machine for a limited period of time.

To extend the Evaluation license:
  1. Run the License Manager utility.
  2. Select ImageGear evaluation license and click Continue.
  3. Click the Submit extension request to request an extension of the ImageGear evaluation.

Your request will be considered, and you will receive an e-mail notification when your license is extended. Then you need to run the License Manager utility again to generate a new license key.

NOTE: The License Manager utility stores license key in the registry and product samples are configured to read it from the registry.
NOTE: The license is being stored in the registry of the host machine, and is being deployed to the target machine via INSTALL.CAB file that is generated by License Manager utility when the license is obtained. ImageGear for .NET samples are configured to deploy INSTALL.CAB automatically..

When you evaluate the product, you have to call the SetSolutionName() method of the ImGearLicense Class object that is provided by the ImageGear.Core namespace. While you are evaluating the ImageGear product, you should specify the value "Accusoft 3-40-16" on the SetSolutionName Method () call:

C#
if (IntPtr.Size == 8)
    // 64bit eval and development solution name
    ImGearLicense.SetSolutionName("AccuSoft 3-41-16");
else
    // 32bit eval and development solution name
    ImGearLicense.SetSolutionName("AccuSoft 3-40-16");

VB .NET
If (IntPtr.Size = 8) Then
    '64bit eval and development solution name
    ImGearLicense.SetSolutionName("AccuSoft 3-41-16")
Else
    '32bit eval and development solution name
    ImGearLicense.SetSolutionName("AccuSoft 3-40-16")
End If


ImageGear for .NET Development License

If you bought the Development copy of ImageGear for .NET, please do the following:

  1. Select the ImageGear development license option from the initial screen of the License Manager utility.
  2. You will be prompted to log in using e-mail and password you have registered with on the AccuSoft Web site.
  3. Upon login, you will be presented with the combo-box containing different access keys for the AccuSoft products you have bought. Please select ImageGear access key and click "Get Key". Your license key will be automatically obtained and stored on your computer.

If you had an Evaluation license previously, it will be overwritten with the new Development license. A Development license enables you to use any of the ImageGear features. You need to run the License Manager utility for each machine where you need to use the product.

NOTE: The License Manager utility stores license key in the registry and product samples are configured to read it from the registry.
NOTE: The license is being stored in the registry of the host machine, and is being deployed to the target machine via INSTALL.CAB file that is generated by License Manager utility when the license is obtained. ImageGear for .NET samples are configured to deploy INSTALL.CAB automatically..

When you develop your application using ImageGear you have to call the SetSolutionName() method of the ImGearLicense object that is provided by the ImageGear.Core namespace. While you are developing, you should specify the value "Accusoft 3-40-16" on the SetSolutionName() call:

C#
if (IntPtr.Size == 8)
    // 64bit eval and development solution name
    ImGearLicense.SetSolutionName("AccuSoft 3-41-16");
else
    // 32bit eval and development solution name
    ImGearLicense.SetSolutionName("AccuSoft 3-40-16");

VB .NET
If (IntPtr.Size = 8) Then
    '64bit eval and development solution name
    ImGearLicense.SetSolutionName("AccuSoft 3-41-16")
Else
    '32bit eval and development solution name
    ImGearLicense.SetSolutionName("AccuSoft 3-40-16")
End If

You will also be provided with a deployment license key along with the unique solution name and solution key to be used for distributing your application. See the section ImageGear for .NET Deployment License for details.


ImageGear for .NET Deployment License

When you are ready to deploy your application, you need to change licensing calls to specify the Solution Name, Solution Key and License Key that AccuSoft will provide for you. These are specific to your application and depend on the type of deployment license you have purchased.

You will be provided also with the AccuSoft Licensing and Deployment Kit, which is designed to help you to distribute your application using your Deployment license.

Please refer to the Licensing and Deployment Kit section for information on how to implement the licensing API calls to deploy your ImageGear for .NET based application.


Distributing ImageGear for .NET Application

A managed code application using ImageGear for .NET can be targeted for any CPU .NET platform. In this case it will be running as a 32-bit process on a 32-bit machine and a 64-bit process on a 64-bit machine.

You must always distribute your application along with the ImageGear for .NET assembly - ImageGearV16n.dll.

  • To distribute an application that uses ImageGear.Windows.Forms namespace (including ImGearPageView control) you must include into the distribution package the ImageGear Windows Forms assembly - IGWinFormsV16n.dll along with the ImageGear for .NET assembly.
  • To distribute an application that uses ImageGear.Formats.JPEG2K namespace you must include into the distribution package the native ImageGear JPEG2K library - igJPEG2K16d.dll along with the ImageGear for .NET assembly.
  • To distribute an application that uses ImageGear.Vector and/or ImageGear.Formats.[CAD/CGM/DGN/HPGL] namespaces, you must include into the distribution package the native ImageGear Vector library - igvect16nu.dll along with the ImageGear for .NET assembly.
  • To distribute an application that uses ImageGear.Formats.CAD namespace you must include into the distribution package the native ImageGear Vector library - igvect16nu.dll - and CAD library - igcad16nu.dll along with the ImageGear for .NET assembly.
  • To distribute an application that uses ImageGear.Formats.DWF namespace you must include into the distribution package the native ImageGear Vector library - igvect16nu.dll - and DWF library - igdwf16nu.dll along with the ImageGear for .NET assembly.
  • To distribute an application that uses ImageGear.Formats.PDF namespace, see Distributing PDF and PS Fonts and Libraries with an Application.
  • To distribute an application that uses ImageGear.Web.Forms namespace, see Distributing WebForms Toolkit with an Application.


Distributing PDF and PS Fonts and Libraries with an Application

To distribute an application that uses ImageGear.Formats.PDF namespace you must include into the distribution package the native ImageGear PDF library - igPDF16nu.dll along with the ImageGear for .NET assembly and the following PDF resources:

  • Resource - Adobe PDF and PostScript resources directory
  • DL81ACE.dll - Adobe PDF library
  • DL81AdobeXMP.dll - Adobe PDF library
  • DL81AGM.dll - Adobe PDF library
  • DL81ARE.dll - Adobe PDF library
  • DL81AXE16SharedExpat.dll - Adobe PDF library
  • DL81AXE8SharedExpat.dll - Adobe PDF library
  • DL81BIB.dll - Adobe PDF library
  • DL81BIBUtils.dll - Adobe PDF library
  • DL81CoolType.dll - Adobe PDF library
  • DL81JP2KLib.dll - Adobe PDF library
  • DL81PDFL.dll - Adobe PDF library
  • ACE.dll - Adobe PostScript library
  • AGM.dll - Adobe PostScript library
  • BIB.dll - Adobe PostScript library
  • BIBUtils.dll - Adobe PostScript library
  • JP2KLib.dll - Adobe PostScript library
  • nserver.dll - Adobe PostScript library

Distributing PDF and PS Fonts with an Application

ImageGear toolkit comes with multiple PDF and PS fonts that can be used for developing an application based on ImageGear. However only four fonts are pre-licensed for distribution:

  • The two MultiMaster PDF fonts, AdobeSansMM (zx______.mmm) and AdobeSerifMM (zy______.mmm).
  • The two PostScript fonts, Courier and NotDefFont.

These fonts are the property of Adobe® Systems and are fully licensed for distribution with your application.

If you need to distribute the additional fonts, you need to get a license for the redistribution of those fonts. You are however not limited to the fonts supplied with ImageGear; it's possible to add other fonts to be used with ImageGear PDF/PostScript support. To do this, place your fonts to the PDF Resource directory as follows:

  • CID fonts (if any) to ...\Resource\PDF\CIDFont
  • CMaps fonts to ...\Resource\PDF\CMap
  • PDF fonts to ...\Resource\PDF\Font
  • PostScript fonts to ...\Resource\PS\Fonts

Please also note that the fonts that are pre-licensed for distribution (i.e., AdobeSansMM, AdobeSerifMM, "Courier" and "NotDefFont") provide the substitution capabilities for the other fonts, so they are likely to be enough for many cases. The below paragraph provides more technical details regarding fonts substitution.

The multiple master font format is an extension of the Type 1 font format that allows the generation of a wide variety of typeface styles from a single font program. This is accomplished through the presence of various design dimensions in the font. Examples of design dimensions are weight (light to extra-bold) and width (condensed to expanded). Coordinates along these design dimensions (such as the degree of boldness) are specified by numbers. A particular choice of numbers selects an instance of the multiple master font. Adobe® Technical Note #5015, Type 1 Font Format Supplement, describes multiple master fonts in detail.


Distributing WebForms Toolkit with an Application

In order to use ImGearWebPageView control, you should add the following directories and files to your web application's directory:

Directories

Directory
Necessary Access Permissions
ImGearWebPageView
Read, Execute scripts
ImGearWebPageView\Cache
Read, Write, Directory browsing, no execution
ImGearWebPageView\JS
Read, Execute scripts
ImGearWebPageView\Resource
Read
ImGearWebPageView\Tmp
Read, Write, Directory browsing, no execution

Files

Copy contents of IG_Net16_WebForms\ImGearWebPageView\JS\ and IG_Net16_WebForms\ImGearWebPageView\Resource\ directories to the corresponding directories of your application.

NOTE: The "ASP.NET 2.0 AJAX Extensions 1.0" must be installed. These can be obtained from Microsoft's web site at:
http://www.asp.net/ajax/downloads/archive/


Licensing and Deployment Kit

This section guides you through the process of deploying your developed ImageGear application to end users.

NOTE: See the Glossary for Licensing and Deployment Kit terminology.

There are two ImageGear deployment licensing models:

User

Not bound to hardware parameters. Therefore only one License Key is required per ImageGear-based application.
NOTE: The User licensing model was previously known as the "Platinum" model.

Server

Bound to hardware parameters. Therefore an individual node-locked License Key has to be generated for each system where the ImageGear-based solution is used. With this model, the Licensing Component running on the end user's machine can communicate directly to the Deployment Licensing Service but you also have the choice of setting up a Deployment Proxy Service at your site - in this case Licensing Component would communicate through this proxy service.
NOTE: The Server licensing model was previously known as the "Gold" model.

Read the appropriate section for the license model you have purchased from AccuSoft. After you complete the instructions in that section, refer to the "Deploying Your Product" section.

See Also:

User Licensing

Server Licensing

Deploying Your Product


User Licensing

With the User License (Platinum) deployment model, a single License Key is generated for each ImageGear-based solution and is used to initialize the ImageGear core component using the ImageGear product licensing API. No further actions are required to license your application on the end user's system. The User model includes both concurrent user and named user methods. Distribution is per AccuSoft's agreement for quarterly reporting (LDR).

You will use The Client Process, detailed in the next section.

The Client Process

This section specifies the steps you need to follow to properly license and install your end product on the end users machine when deploying your product to a client machine.

With the User License model, no Licensing Component is required. AccuSoft will email the necessary parameters to you: Solution Name, Solution Key and License Key for the deployment of your application. Using these parameters, you can then modify the code of your application to specify the Solution Name, Solution Key, and License Key using the following ImageGear API:

  • To specify the Solution Name, you call ImGearLicense.SetSolutionName Method method.
NOTE: When you are ready to deploy your ImageGear-based application, you need to replace the generic solution name that you have used with the ImageGear evaluation and development licenses with the unique solution name assigned to your application by AccuSoft.
  • To specify the Solution Key, you call ImGearLicense.SetSolutionKey Method method.
  • To specify the License Key for your application, you call ImGearLicense.SetOEMLicenseKey Method method.

You also need to use the Deployment Packaging Wizard to package the ImageGear run time components required for your application.

See Also:

Deploying Your Product

ImageGear Licensing API Reference

Code Samples for User (Platinum) Model

C# .NET
ImGearLicense.SetSolutionName("Your Solution Name");
ImGearLicense.SetSolutionKey(0x473F47EC, 0xDEDCEDC4, 0xAFFBB23E, 0xFBFBDE4A);
ImGearLicense.SetOEMLicenseKey("1.0.WkFoEmKFJkSdDHJfFDGsTRYdIUfIOsOPePf...");

VB .NET
Dim Key1, Key2, Key3, Key4 As UInt32
Dim LKey1, LKey2, LKey3, LKey4 As Long
LKey1 = 1382566911
LKey2 = 5853474885
LKey3 = 7422822616
LKey4 = 3275893442
Key1 = Convert.ToUInt32(LKey1)
Key2 = Convert.ToUInt32(LKey2)
Key3 = Convert.ToUInt32(LKey3)
Key4 = Convert.ToUInt32(LKey4)
ImGearLicense.SetSolutionName("Your Solution Name")
ImGearLicense.SetSolutionKey(Key1, Key2, Key3, Key4)
ImGearLicense.SetOEMLicenseKey("1.0.WkFoEmKFJkSdDHJfFDGsTRYdIUfIOsOPePf...")

See Also:

ImageGear Licensing API Reference


Server Licensing

The Server licensing model has three different scenarios. Once you have added the licensing calls to your application, as explained in the next section, you need to follow additional steps. Depending on the licensing scenario you choose, refer to one of the following sections for further information:

  • The Server Licensing Utility (SLU) Process

The SLU process is ideal for limited licensing (for example, an internally deployed server application). Less coding is required up-front, but there is manual intervention required.

  • The Automatic Scenario

The Automatic process requires that your end users have an Internet connection. The process is automatic, which means that there is less intervention, but also less control.

  • The Manual Scenario

The Manual process is designed for end users who do or do not have an Internet connection. Although the process is more complex, you have more control over licensing.

The manual and automatic scenarios achieve the same end result, and can be mixed among your end users, since the License Key is generated by the same Deployment Licensing Service for either scenario. The automatic scenario is the recommended method, but if an Internet connection is not available, then the manual scenario can be used.

Errors can occur during licensing with either scenario, e.g: Internet connection problems (in automatic mode), registry permission problems, invalid access keys, etc. To guarantee that your application runs after installation, the Licensing Component automatically activates the grace period when any error occurs during licensing. The default grace period is 14 days, but this can be customized for each deployment pool by request to AccuSoft. The licensing process can be repeated during the grace period, and once the application is licensed successfully, the grace period is cleared.

NOTE: With either scenario, your application only needs to be licensed once, after which it will work indefinitely. In the event that your end user recovers from a backup onto different hardware, the license needs to be transferred as described in the below and then bound to the new hardware.

AccuSoft provides the Licensing Component that facilitates the licensing process on the end user's system for the Server model.

The Server License model provides the following benefits:

  • You can integrate the Vendor Licensing Utility functionality into your own system (e.g., order processing system).
  • You can set up the Deployment Proxy Service on your site and program the Licensing Component to communicate with the Deployment Proxy Service instead of the Deployment Licensing Service.
  • You can set up custom End User licensing scenarios. For example, directing end users to come to a Web application hosted on your Web site to get a License Key.

The following tools and utilities are provided by AccuSoft to prepare your application for deployment:

  • The Vendor Licensing Utility
  • A License Deployment Kit (LDK) that includes:
    • Licensing Component
    • Sample VB-script (see Licensing Component Wrapper)
    • Sample MSI-package (see Licensing Component Wrapper)
    • Deployment Proxy Service
    • Deployment Packaging Wizard (see also Deploying Your Product)
  • A Configuration file to be used with the Licensing Component

Adding Licensing Calls to Your Application

With Server deployment (Gold) licensing, regardless of which scenario you choose, you need to provide your ImageGear-based application with a Solution Name and a Solution Key obtained using the Vendor Licensing Utility. You do this using the ImageGear licensing API:

  • To specify the Solution Name you call ImGearLicense.SetSolutionName Method method.
NOTE: When you are ready to deploy your ImageGear-based application, you need to replace the generic solution name that you have used with the ImageGear evaluation and development licenses with the unique solution name assigned to your application by AccuSoft.
  • To specify the Solution Key you call ImGearLicense.SetSolutionKey Method method.
See Also:

Code Samples for Server (Gold) Model

Once you have added the licensing calls to your application, depending on the licensing scenario you choose, refer to one of the following sections for further information:

  • The Server Licensing Utility (SLU) Process
  • The Automatic Scenario
  • The Manual Scenario

Code Samples for Server (Gold) Model

C# .NET
ImGearLicense.SetSolutionName("Accusoft 3-40-16");
ImGearLicense.SetSolutionKey(0x473F47EC, 0xDEDCEDC4, 0xAFFBB23E, 0xFBFBDE4A);

VB .NET
ImGearLicense.SetSolutionName("Your Server Solution Name")
ImGearLicense.SetSolutionKey(&H473F47ECUL, &HDEDCEDC4UL,&HAFFBB23EUL, &HFBFBDE4AUL)

The Server Licensing Utility (SLU) Process

In the Server Licensing Utility scenario, once you have added licensing calls to your application, as explained in the previous section (Adding Licensing Calls to Your Application), you only need to use our pre-packaged licensing utility for licensing either server-based ImageGear applications. The Utility obtains a license key for the target server when a valid configuration file is presented. The license key is stored in the registry of the target server.

With the configuration file sent after server licenses have been purchased, you will be able to use the Server Licensing Utility to license your ImageGear based server. This process can be used only once per license purchased. When you are ready to install the deployment license, follow these steps (requires internet connection):

1. Save the config.txt, previously sent from your purchase of server licensing, to the target server in a readily available directory.

2. Run the following utility: C:\Program Files\AccuSoft\ImageGear.NET16\LDK\Bin\LDK\Bin\SLU.exe

3. When the utility launches, click the Browse button, and browse to the config.txt file saved in step 1.

4. Click Auto Register.

If the auto register fails, it will start a manual process. If this occurs, then do the following:

a. In the second dialog window that appears, click the Copy Hardware Key button.

b. Go to: https://www.accusoft.com/Licensing/v1/WebDeployUser/WebDeployUser.aspx

c. In the Hardware Key box, paste the hardware key from the clipboard, which was obtained in step a.

d. Click Download License.

e. The resultant text file will be sent to your PC via your browser, which you can open.

f. Copy the entire License Key from the text file in step e.

g. Return to the licensing utility and paste the license key into the license key box.

h. Click License. The Server is now licensed for ImageGear.

The Automatic Scenario

The Automatic scenario consists of the following:

1. You distribute a unique Access Key to the End User from the pool of created access keys.

2. The end user enters the access key when the installation program prompts for it.

3. As an alternative to steps 1 and 2, an Access Key can be automatically obtained from the pool available for your application. In this case no input from the end user is required (i.e., call GetLicKeyAuto("")).

4. The Licensing Component is used to form a Hardware Key, obtain a License Key, and store it into the registry.

5. If an error occurs, the grace period is activated.

When using the Automatic Licensing Scenario, once you have added licensing calls to your application, as explained in the previous section (Adding Licensing Calls to Your Application), the only additional step you need to complete to license your product is to add calls to the Licensing Component. The Licensing Component facilitates the process of obtaining a License Key bound to the End User's system. This is typically done during the ImageGear-based solution installation, but you might want to consider providing a separate registration utility (or menu item in your application) if you are licensing manually or to handle errors that may occur during the installation.

Accessing the Licensing Component from the installer is typically done using a script that is executed during installation (AccuSoft provides a sample VB Script). The Licensing Component allows you to implement two scenarios - an Automatic Licensing Scenario and a Manual Licensing Scenario. You can use either scenario to obtain a license for the end user's machine, although the automatic method is easier to use.

In The Automatic Scenario, you only need to call a single method (GetLicKeyAuto) of the Licensing Component that does the following things for you:

1. Obtains the Hardware Key from the End User system.

2. Sends a request to the licensing authority (either the Deployment Licensing Service or Deployment Proxy Service).

3. Stores the License Key into the registry on the end user's machine.

NOTE: This is the preferred method since it requires very little manual intervention or no intervention at all, depending on whether or not you have decided to distribute individual access keys to end users explicitly.

The Manual Scenario

The Manual scenario consists of the following:

1. You distribute a unique Access Key to the End User from the pool of created access keys.

2. The end user enters the access key when the installation program prompts for it.

3. As an alternative to steps 1 and 2, an Access Key can be automatically obtained from the pool available for your application. In this case, no input from the end user is required (i.e. call GetLicKeyAuto and GetHdwKey methods with the accKey argument as an empty string).

4. The Licensing Component is used to form a Hardware Key that is reported to the end user.

5. The end user communicates the hardware key to you (through e-mail, Web portal, etc.).

6. You exchange the hardware key for a License Key either by using the End User Licensing Utility or Using the Deployment Licensing Service to Generate License Key directly (the latter is for Server License only).

7. You communicate the license key back to the end user (through e-mail, Web portal, etc.).

8. The end user passes the license key to the Licensing Component (this is usually done via the registration process).

9. The Licensing Component stores the License Key in the registry.

10. If an error occurs, the grace period is activated.

When using the Manual Licensing Scenario, once you have added licensing calls to your application, as explained in the previous section (Adding Licensing Calls to Your Application), you need to add calls to the Licensing Component. The Licensing Component facilitates the process of obtaining a License Key bound to the End User's system. This is typically done during the ImageGear-based solution installation, but you might want to consider providing a separate registration utility (or menu item in your application) if you are licensing manually or to handle errors that may occur during the installation.

Accessing the Licensing Component from the installer is typically done using a script that is executed during installation (AccuSoft provides a sample VB Script and a sample MSI-package that demonstrate both the automatic and manual scenarios. See Licensing Component Wrapper). The Licensing Component allows you to implement two scenarios - an Automatic Licensing Scenario and a Manual Licensing Scenario. You can use either scenario to obtain a license for the end user's machine, although the automatic method is easier to use.

See Also:

Licensing Component API Reference

Deploying Your Product

Acquiring an Access Key for the End User's Machine

With the Server License model, you can choose whether you want to distribute individual Access Keys for each end user, or not. There are tradeoffs with either approach:

  • If you choose to distribute individual access keys, your application is protected at no cost for you. You get the benefit of licensing protection from AccuSoft, but you have to manage your pool of access keys with the Vendor Licensing Utility yourself.
  • If you choose not to distribute individual access keys, then the Licensing Component automatically obtains an access key and licenses the product on the end user's machine. In this case, you don't have to manage your pool of access keys with the Vendor Licensing Utility, but your software is not protected against unauthorized distribution. As a result, anyone installing it will automatically obtain an ImageGear license thus decrementing the total number of available licenses from your license pool.
NOTE: If you choose not to distribute individual access keys, you should use the GetLicKeyAuto and GetHdwKey methods of the Licensing Component with their first argument (accKey) as an empty string.
Transferring your license to new hardware

If you choose to distribute individual access keys to end users then you will be assigning an access key to each end user's machine. Should the end user need to upgrade their machine, they can re-use the same access key for the new machine. There is a limit on how often a machine can be changed. This frequency is limited to the 45 days by default, but it can be changed for each deployment pool per request to AccuSoft.

If you choose to acquire access keys automatically, then you will need to use the LicenseInfo API of the Licensing Component to help end users transfer their access keys into new hardware. For example, you might want to develop a license transfer utility or provide this functionality from within your application. This will allow the end users to extract the access key (that was automatically obtained) from the registry on the old machine and store it onto the new machine. The limitation on the frequency of hardware upgrades applies to this method as well.

See Also:

Server Licensing

About Web-Based Licensing Utilities

User Licensing

The Automatic Scenario

The Manual Scenario

License Administration for the Server Deployment Model

Setting License Email Notifications

Licensing Component API Reference


About Web-Based Licensing Utilities

Before we discuss Application Preparation, you should be aware that there are two AccuSoft Web-based licensing utilities you will use with Server licensing: Vendor Licensing Utility and End User Licensing Utility.

Vendor Licensing Utility

The Vendor Licensing Utility (WebDeployClient utility) is the Web application that allows you to:

  • Browse solutions, deployment pools, and the attributes of both including the: Solution Name and Solution Key.
  • View the list of licensed product features and versions, e.g. CORE, OCR, Barcode, PDF, etc. for ImageGear Professional.
  • Generate new Access Keys and obtain existing access keys from license pools.

To run the Vendor Licensing Utility (WebDeployClient utility) enter the following URL:

https://www.accusoft.com/Licensing/v1/WebDeployClient/Login.aspx

into Internet Explorer and press Enter.

In the WebDeployClient Entry screen, enter the Username and Password provided to you by AccuSoft, and begin to manage your deployment solutions.

Integrating the Vendor Licensing Utility Functionality into Your System

The Deployment Licensing Service is implemented as a .NET Web Service; the following Deployment Licensing Service API has to be used to accomplish this (C# notation is used):

// obtains all solution names
[WebMethod]
[SoapHeader("LicServiceHeader")]
    public AccuWSStrArr GetSolutionNames();
// obtains solution key for the solution
[WebMethod]
[SoapHeader("LicServiceHeader")]
    public AccuWSStr GetSolutionKey( string solutionName);
// obtains names of all the pools associated with the solution
[WebMethod]
[SoapHeader("LicServiceHeader")]
    public AccuWSStrArr GetPoolNames( string solutionName);
// creates new access keys for the specified solution and pool
[WebMethod]
[SoapHeader("LicServiceHeader")]
    public AccuWSStrArr CreateNewLics( string solutionName, string poolName, int nLics,
bool sendKeys);
// obtains all access keys for the specified solution and pool
[WebMethod]
[SoapHeader("LicServiceHeader")]
    public AccuWSStrArr GetAccKeys( string solutionName, string poolName,
int startIndex, int numbKeys);
// this method returns pool attributes for the pool whose name is passed in as a parameter
[WebMethod]
[SoapHeader("LicServiceHeader")]
    public AccuWSDepPool GetPoolInfo (string solutionName, string poolName);
See Also:

Using the Deployment Licensing Service to Generate License Key

Setting License Email Notifications

Deployment Proxy Service (DPS)

Generating Access Keys

The Vendor Licensing Utility (WebDeployClient utility) can be used to generate Access Keys. After logging in to the utility and selecting the solution and deployment pool, the following screen is presented:

To generate access keys:

1. Specify the number of keys you wish to generate in the Number of new keys field.

2. If you want to download the new keys once they are created, click the Download new keys checkbox before generating the new keys.

3. Click the Create new access keys button to generate the specified number of access keys.

NOTE: To download all access keys available for this pool, click the Download all access keys button. This is non- reversible, so be sure you want to retrieve all your access keys before pressing this button.
NOTE: You will only need to use the Vendor Licensing Utility to generate access keys if you have decided to distribute access keys for end users explicitly. However even if you have decided to obtain access keys automatically using the Licensing Component, you can still use the Vendor Licensing Utility to retrieve the access keys that were automatically generated.
See Also:

Vendor Licensing Utility

End User Licensing Utility

The End User Licensing Utility (WebDeployUser utility) is the Web application that allows you to generate a License Key based on the Hardware Key. (This is used in the manual mode process).

To run the End User Licensing Utility (WebDeployUser utility) enter the following URL:

https://www.accusoft.com/Licensing/v1/WebDeployUser/WebDeployUser.aspx

in Internet Explorer and press Enter.

In the WebDeployUser Entry screen, type your Hardware Key and press the Download License button to get your License Key.

See Also:

Server Licensing

The Manual Scenario


License Administration for the Server Deployment Model

If you are using the Server deployment model, you have the ability to integrate licensing service into your infrastructure to manage licensing in a way similar to your other business processes. You can setup the Deployment Proxy Service (DPS) on your site for proxying between AccuSoft and your customers and implement your own versions of the Vendor Licensing Utility and End User Licensing Utility. The Deployment Proxy Service (DPS) also allows you to license a product in a scenario where an end user's machine has limited Internet access.

See Also:

Deployment Proxy Service (DPS)

Integrating the Vendor Licensing Utility Functionality into Your System

Using the Deployment Licensing Service to Generate License Key

Setting License Email Notifications

Using the Deployment Licensing Service to Generate License Key

At times it might be convenient to use the Deployment Licensing Service API directly to generate a License Key based on the Hardware Key. For example, it can be useful in the The Manual Scenario, to set up a custom licensing portal on your site.

Here is the API description, C# notation:

// it takes hardware key and returns license key.
[WebMethod]
[SoapHeader("LicServiceHeader")]
    public AccuWSStrTriplet GenerateLicKey( string licParams);
See Also:

Server Licensing

The Manual Scenario

Setting License Email Notifications

Setting License Email Notifications

License Thresholding and Email Notification services are built into the AccuSoft Deployment Licensing Service. This provides the ability to setup e-mail notifications when a set percentage of the licenses are used up in the pool.

When establishing a new license pool with AccuSoft you can specify whether or not you would like to be notified and threshold value (if you have chosen to be notified). You can always update your preferences later by contacting AccuSoft.

See Also:

Server Licensing

License Administration for the Server Deployment Model

Licensing Component API Reference

Deployment Proxy Service (DPS)

License Administration involves the distribution and accounting of licenses against deployed solutions. Your involvement with License Administration depends upon the licensing model (Server, User) you choose, and whether you decide to utilize the Access Key or no Access Key licensing mechanism. (Please see the section Acquiring an Access Key for the End User's Machine for the detailed information).

On the one extreme with the Server model, AccuSoft can perform License Administration for you and your end users. The AccuSoft Licensing Service administers the deployment of License Keys directly with your end users over the internet, with little or no intervention on their part.

At the other extreme with the User model or the "no Access key" Server model, licensing is completely managed by you. Only periodic reconciliation of licensing totals is expected with AccuSoft for license accounting.

In between these two extremes, with the Server model, you can assume a participative role in License Administration with AccuSoft. To facilitate this, a Deployment Proxy Service (DPS) is provided that you can adapt to broker between your corporate software infrastructure, your end users, and AccuSoft's Deployment Licensing Service. This gives you the flexibility to design licensing into your current business model. As a simple example, the Deployment Proxy Service (DPS) would be installed on a server at your location. The DPS then communicates with AccuSoft's Deployment Licensing Service to administer the deployment of licenses. Once installed, the DPS can then be modified to work with any CRM systems that exists in your own business infrastructure.

In this section, we will review a simple DPS implementation that sets up the licensing proxy service for communication with AccuSoft's Deployment Licensing Service. Following this, the Deployment Licensing API will be presented for further adaptation at your location.

In a baseline implementation there are three steps to DPS-based License Administration:

  • Server Preparation
  • Deployment Proxy Service (DPS) Installation
  • Binding Licensing Component to DPS

Server Preparation

License Administration is typically executed on a Microsoft Windows 2000 Server platform. The Deployment Proxy Service (DPS) is implemented as a .NET Web Service, working through the Microsoft Internet Information Server (IIS). So server setup involves setting up:

  • IIS - Internet Information Server
  • Microsoft .NET Framework
  • .NET Framework 'machine.config' file

Microsoft's Internet Information Server (IIS) is typically installed during a Windows 2000 Server installation. Verify that you have IIS installed on your server by checking that the C:\InetPub\wwwroot directory exists. This is the default location for IIS. If IIS is not installed, add the IIS web server components to the default directory (C:\InetPub\wwwroot).

The Microsoft .NET Redistributable Package can be downloaded from Microsoft's Web site at the following link:

http://msdn.microsoft.com/downloads/default.asp?url=/downloads/sample.asp?url=/msdn-files/027/001/829/msdncompositedoc.xml

It also contains installation requirements for the Microsoft .NET Redistributable Package.

Since some of the Deployment Licensing Service (DLS) methods may take some time to execute, AccuSoft recommends that you make the following modifications to the machine.config file after you have installed Microsoft .NET Framework:

1. Locate the file. On most PCs it would be at: C:\WINDOWS\Microsoft.NET\Framework\v1.0.3705\CONFIG\machine.config

2. In the file locate the processModel tag. The full path to it is:

<configuration>
<system.web>
<processModel>

3. Find the responseDeadlockInterval parameter within the processModel tag. By default it looks like:

responseDeadlockInterval="00:03:00"
Its format is [Infinite | HH:MM:SS]

4. Change the value to "00:30:00".

Deployment Proxy Service (DPS) Installation

Next, the Deployment Proxy Service (DPS) needs to be installed on the server where IIS and the .NET Framework were installed. For this example, we will use a zipfile (DplProxy.zip), available from AccuSoft, which contains a set of files for setting up a baseline DPS on your server to communicate with AccuSoft's Deployment Licensing Service. The first step is to extract the files under your Web Server (C:\InetPub\wwwroot), or to move them there after extraction. This will create a folder named "Licensing". You can extract the files in any folder, as long as you set up a virtual directory pointing to the folder where you unzipped the files.

From the IIS console, you then need to make sure that this "Licensing" folder is setup as an application. This can be done by right clicking on the folder and selecting Properties. Under the application settings section of the Directory tab, select the "create" button. This will create an application for this folder. The default of "licensing" will suffice, but you may name the application anything you'd like. The DPS is now setup with the Proxy Service on your server.

Binding Licensing Component to DPS

The Licensing Component has the property SrvURL that needs to be set to the URL of the Deployment Proxy Service like this (VB Script notation):

objLic.srvURL = "https://www.yoursite.com/licensing/dps/dps.asmx"

DPS Source Code

AccuSoft provides the source code for the Deployment Proxy Service. While you don't have to use the source code it can serve as an example if you choose to modify the provided proxy to your needs or develop your own proxy. The code is written in C# and can be compiled using MSVS .NET.

See Also:

Integrating the Vendor Licensing Utility Functionality into Your System

Using the Deployment Licensing Service to Generate License Key

Setting License Email Notifications

AccuSoft Corporation
 AccuSoft.com
sales@accusoft.com


Deploying Your Product

The first step in deploying your application is to package the required ImageGear for .NET run-time components. To do this, you run the Deployment Packaging Wizard to identify and generate the ImageGear run-time components required by your application. The Deployment Packaging Wizard packages the required components and stores them into a specified output folder, creating subfolders for the run-time and licensing components.

Running the Deployment Packaging Wizard

To package the required ImageGear for .NET run-time components, do the following:

1. From the Start menu, choose .../Programs/AccuSoft/ImageGear for .NET/Deployment Kit folder and run the Deployment Packaging Wizard program.

2. Enter the path where you want to place the components and click the Next button to continue.

3. In the ImageGear for .NET Run-Time Components form, select the type of ImageGear for .NET run-time components you would like to generate, then select the components you would like to include into the installation package for your application. Click Next to continue.

4. In the ImageGear for .NET Licensing Components form, check whether you want to generate the ImageGear for .NET licensing components, add the Server Licensing Utility, or to have no licensing (default for User). Click the Next button to continue.

5. Finally, you can see a list of all the selected components that will be generated for your deployment. If this looks correct, click the Finish button to complete the Deployment Packaging process.

Once the Deployment Packaging process is finished, the Deployment Packaging Wizard reports its successful completion.

Now you can take the files that the Deployment Packaging Wizard created for you and include them into the installation package along with your application.

See Also:

About Web-Based Licensing Utilities

Creating an Installer

Licensing Component Error Codes and Messages

Creating an Installer

With Server licensing using either the Automatic or Manual scenario, to prepare your Application for distribution, you create an Installer for the Application and include any required ImageGear for .NET components. While this varies based on your application, in general it includes the following:

1. Replace config.txt with the one given to you for deployment. This file is located at C:\Program Files\AccuSoft\ImageGear for .NET v16\[ImageGear Edition]\LDK\Config.

2. Create an Installer (see Example.msi - a Wise installer example, that is located at C:\Program Files\AccuSoft\ImageGear for .NET v16\[ImageGear Edition]\LDK\Samples\MSI). The config.txt file that you replace above is added to the installer.

3. Add the Runtime and Licensing components generated when you ran the DPW.

4. Rename and save the Installer (Example: myinstaller.msi).

Licensing Component Wrapper

A Licensing Component Wrapper is provided for you in the form of a sample VB-script file that demonstrates how to implement different licensing scenarios using the Licensing Component, and proposes default handling for all error situations. The sample VB-script file (AccuLicClient.vbs) is located in the \Samples\VBScript directory of your Licensing Deployment Kit installation.

Also, there is a sample MSI installation file with the VB-script wrapper integrated into it. The sample MSI installation file (Example.msi) is located in the \Samples\MSI directory of your Licensing Deployment Kit installation. This MSI sample can be taken and integrated into your installer.

See Also:

Licensing Component API Reference

Licensing Component Error Codes and Messages


ImageGear Licensing API Reference

This section provides you with the detailed reference for the following ImageGear for .NET licensing API:

  • ImGearLicense class
    • SetOEMLicenseKey Method
    • SetSolutionKey Method
    • SetSolutionName Method

ImGearLicense

Description:

This class manages licensing data (i.e., license type and key).

Assembly:

ImageGearV16n.dll

Declaration:

public sealed class ImGearLicense

Class Members:

SetOEMLicenseKey Method
Sets OEM license key.
SetSolutionKey Method
Sets solution key.
SetSolutionName Method
Sets name of solution.

Remarks:

To be able to use any ImageGear for .NET functionality, licensing information must be provided. For more information see ImageGear for .NET licensing scheme.

SetOEMLicenseKey Method

Description:

Sets OEM license key.

Declaration:

static void SetOEMLicenseKey(string licKey)

Parameters:

licKey
Obtained from AccuSoft OEM license key.

Remarks:

When there is an OEM license type, there is no need to call any other members of ImGearLicense class.

SetSolutionKey Method

Description:

Sets solution key.

Declaration:

static void SetSolutionKey(int key1, int key2, int key3, int key4)

Parameters:

key1
Key1 part of solution key.
key2
Key2 part of solution key.
key3
Key3 part of solution key.
key4
Key4 part of solution key.

Remarks:

Solution name must be set up in addition to key.

SetSolutionName Method

Description:

Sets the name of the solution.

Declaration:

static void SetSolutionName(string SolutionName)

Parameters:

SolutionName
Name of solution.

Remarks:

Solution key must be set up in addition to name.


Licensing Component API Reference

The Licensing Component's purpose is to obtain a license key bound to the end user's system.

The Licensing Component performs the following functions:

  • Obtains the Hardware Key of the End User system.
  • Sends a request to the licensing authority (either Deployment Licensing Service or Deployment Proxy Service).
  • Stores the License Key into the registry on the end user machine.

As mentioned in the section on Licensing Administration, you can set up the Deployment Proxy Service on your Web site and program the Licensing Component to communicate with the Deployment Proxy Service instead of the Deployment Licensing Service

Also, using the Licensing Component you can set up different custom End User licensing scenarios. For example, directing end users to come to a Web application hosted on your Web site to get a License Key.

The Licensing Component implements licensing via the following API.

ConfigPath

Property ConfigPath of BSTR type.

This property is used to set and get a path to the deployment configuration file.

NOTE: The Licensing Component has to be initialized with the path to the `config.txt' file before it can perform any of its functions. The `config.txt' file is provided to you by AccuSoft for each ImageGear-based solution. You need to distribute it with the Licensing Component in order for the component to work.

GetEvalPeriod

HRESULT GetEvalPeriod ([out, retval] long* EvalPeriod)

This method obtains the remianing time on an evaluation (in days). Returns EvalPeriod < 0 in case if the evaluation period is expired.

GetHdwKey

HRESULT GetHdwKey ([in] BSTR accKey, [out, retval] BSTR* hdwKey)

This method obtains a hardware key from the current machine and returns it (as hdwKey).

If you choose not to distribute individual access keys, you need to provide the accKey argument as an empty string.

See Also:

Acquiring an Access Key for the End User's Machine

GetLicKeyAuto

HRESULT GetLicKeyAuto ([in] BSTR accKey)

This method obtains a License Key for the end user's system using the automatic scenario. It takes an Access Key as its input parameter, and stores the obtained license key in the registry.

If you choose not to distribute individual access keys, you need to provide the accKey argument as an empty string.

See Also:

Acquiring an Access Key for the End User's Machine

LicenseInfo

Property LicenseInfo of BSTR type

This property is used to transfer license information into new system hardware.

To transfer the license information into new system hardware, do the following:

1. Get the LicenseInfo value and store it in a safe place.

2. Change the system hardware.

3. Set the LicenseInfo to the value you saved in step (1).

4. Run the GetLicKeyAuto method (or it's manual analog) to obtain a license for the new system hardware.

LicKey

Property LicKey of BSTR type.

This property stores the License Key to the registry when it is set, and reads it from the registry during the get operation.

ResultCode

Property ResultCode

This property can be used to contain any of the error codes described in Licensing Component Error Codes and Messages.

ResultString

Property ResultString

This property contains the string descriptions of errors.

SrvURL

Property SrvURL of BSTR type.

This property is used to set and get the URL path to the licensing web service. The default is the URL path to AccuSoft's Deployment Licensing Service.

StartEvalPeriod

HRESULT StartEvalPeriod()

This method sets an evaluation licensing mode for the product and starts an evaluation period. This method is provided so you can distribute an evaluation version of your application, without having to distribute Access Keys to people who would like to evaluate your software. Using this method you can license ImageGear on the end user's system for a limited time - the default is 30 days, but it can be customized per request to AccuSoft. If the evaluators purchase your software, you can then issue them an access key using either the automatic or manual scenarios to obtain a permanent ImageGear license, just as AccuSoft does for its evaluators.


Error Codes

Licensing Component Error Codes and Messages

The following are the Licensing Component error codes:

Error Constant
Error Description
LDK_SUCCESS
No error.
LDK_ERR_GENERAL
General error.
LDK_ERR_INET_CONN_BROKEN
No Internet connection.
LDK_ERR_REGISTRY_ACCESS
Can't write license key to the registry. This can happen if a user doesn't have administrative privileges.
LDK_ERR_LOCKOUT
Auto mode only, it should happen when we receive several requests from the same IP address within a short period of time with the wrong access keys.
LDK_ERR_HDW_INCOMPATIBLE
Manual mode only, it means that the utility had to verify the hardware ID and didn't match the one stored in the license.
LDK_ERR_HDW_ID_QUERY
Can't get the hardware ID of the client system. This should not happen unless something goes really wrong with the system.
LDK_ERR_HDW_ID_RELEASE
Auto mode only, this happens when someone is trying to change hardware ID within 45 days after a previous hardware ID has been associated with the license.
LDK_ERR_NO_LICENSE_KEY
No license key passed as a parameter.
LDK_ERR_INVALID_LICENSE_KEY
License key passed as a parameter is invalid.
LDK_ERR_NO_ACCESS_KEY
No access key passed as a parameter.
LDK_ERR_INVALID_ACCESS_KEY
Access key passed as a parameter is invalid.
LDK_ERR_INVALID_SOLUTION_NAME
Invalid solution name.
LDK_ERR_NO_CONFIG_FILE
Cannot find the configuration file.
LDK_ERR_INVALID_CONFIG_FILE
Invalid configuration file.
LDK_ERR_NOT_INITIALIZED
Licensing Component is not initialized.
LDK_ERR_NO_LICENSE_INFO
No license info passed as a parameter.
LDK_ERR_INVALID_LICENSE_INFO
License info is invalid.
LDK_ERR_INCOMPATIBLE_LICENSE
This license is not compatible with your deployment configuration.
LDK_ERR_OBTAINIG_LICENSE
Can't obtain license from the system.

The following are the default Licensing Component Wrapper error messages:

Error Constant
Error Description
MSG_LDK_SUCCESS
"The product has been successfully licensed!"
MSG_LDK_ERR_GENERAL
"An unknown error has occurred during licensing. Please contact your vendor."
MSG_LDK_ERR_INET_CONN_BROKEN
"No Internet connection is available. Please check your connection and retry."
MSG_LDK_ERR_REGISTRY_ACCESS
"Unable to write the License Key to the registry. Please verify that you have administrative privileges."
MSG_LDK_ERR_LOCKOUT
"Licensing has been locked out after multiple requests. Verify that you have a valid Access Key, then contact your vendor."
MSG_LDK_ERR_HDW_INCOMPATIBLE
"This license is not compatible with your system hardware, please contact your vendor."
MSG_LDK_ERR_HDW_ID_QUERY
"Unable to obtain the Hardware ID of your system. Please contact your vendor."
MSG_LDK_ERR_HDW_ID_RELEASE
"Your Hardware ID has changed. Please contact your vendor."
MSG_LDK_ERR_NO_ACCESS_KEY
"No Access Key was received. Please retry and enter an Access Key."
MSG_LDK_ERR_INVALID_ACCESS_KEY
"The Access Key entered appears invalid. Please retry, then contact your vendor."
MSG_LDK_ERR_NO_LICENSE_KEY
"No License Key was received during licensing. Please retry, then contact your vendor."
MSG_LDK_ERR_INVALID_LICENSE_KEY
"The License Key received appears invalid. Please retry, then contact your vendor."
MSG_LDK_ERR_INVALID_SOLUTION_NAME
"The Solution Name is invalid. Please contact your vendor."
MSG_LDK_ERR_NO_CONFIG_FILE
"Can't find configuration file. Please contact your vendor."
MSG_LDK_ERR_INVALID_CONFIG_FILE
"An invalid configuration file was received. Please contact your vendor."
MSG_LDK_ERR_NOT_INITIALIZED
"Licensing Component is not initialized. Please contact your vendor."

ImageGear Licensing Error Codes

The following table describes general ImageGear licensing errors that can occur at run-time if the product is not licensed properly:

Error Constant
Error Code
Error Description
Comment
IGE_FAILURE
-1
Failure to open registry value
This error occurs if the license key cannot be obtained from the registry. Server licensing model only.
IGE_NOT_LICENSED
-2
Invalid license key
This error occurs if the license key passed to the ImageGear is invalid. All licensing models.
IGE_NOT_LICENSED
-2
Version is not licensed
This error occurs if the license key is valid, but does not license the current version of the product. All licensing models.
IGE_NOT_LICENSED
-2
Your evaluation license has expired. Please run AccuSoft License Manager if you would like to get a new license
This error occurs if the evaluation license key has expired. Evaluation licensing only.
IGE_NOT_LICENSED
-2
The product is not licensed for this machine
This error occurs if the evaluation license key is not compatible with a hardware key for the current machine. Evaluation licensing only.
IGE_NOT_LICENSED
-2
The hardware ID of this machine doesn't match license information. Please run AccuSoft License Manager on this machine to add its hardware ID to your license.
This error occurs if the development license key is not compatible with a hardware key for the current machine. Development licensing only.
IGE_NOT_LICENSED
-2
Solution name is required
This error occurs if an empty solution name is passed as a parameter. All licensing models.
IGE_NOT_LICENSED
-2
Invalid solution name
This error occurs if the solution name from the license doesn't match the solution name passed as a parameter. All licensing models.
IGE_NOT_LICENSED
-2
Invalid solution key
This error occurs if the solution key from the license doesn't match the solution key passed as a parameter. All licensing models.
IGE_NOT_LICENSED
-2
Invalid executable name
This error occurs if the executable name from the license doesn't match the name of the application executable. Deployment licensing models locked to the executable only.
IGE_NOT_LICENSED
-2
Please use OEM licensing API with this license
This error occurs if the User/OEM license is being initialized via the registry. The User/OEM license has to be initialized by using the OEM API. User licensing model only.
IGE_NOT_LICENSED
-2
Please do not use OEM licensing API with this license
This error occurs if a non-User/OEM license is being initialized via the OEM API. Only the User/OEM license has to be initialized by using the OEM API. Server licensing model only.


Troubleshooting the Licensing Deployment Kit

This section reviews potential issues you may experience during the licensing process.

Some general notes about licensing you should be aware of:

  • This was designed as an Internet-based licensing process. It is best if your end users have an Internet connection to get a License Key. The only exceptions are if you are a User License Licensee, or if you are distributing licenses manually on a very limited basis.
  • Once an application is licensed, no further Internet connection or interaction is required until you re-install the system or restore a previously backed-up system onto new hardware.
  • End Users are blocked from using the same Access Key to install the same application on different hardware. This is to prevent piracy.
  • A lightweight Licensing Component will grant a grace period to your end user whenever there is a licensing issue for any reason. You can modify the end user instructions to solve the problem.
See Also:

End User has no Internet connection

Internet connection is temporarily broken during installation

Transferring ImageGear license into new hardware system

Reinstallation of ImageGear-based application into the same hardware system

The End User's Windows registry changed (licensing info lost)

End User has no Internet connection

User License level licensing or manual licensing is required if applications are going to be deployed to end users who will never have an Internet connection. Please be advised that manual licensing requires interaction on your part when installing the application on the end-user system.

Internet connection is temporarily broken during installation

In this case, the auto-licensing method will return an error, and the grace period will be activated. The grace period will allow your application to function normally during a limited period of time, and you will need to repeat the licensing process (either manual, or automatic after connection is restored).

Transferring ImageGear license into new hardware system

An error can occur during installation of your application into a new machine or as the result of restoring a backup into different system hardware.

When you need to transfer an ImageGear license onto new system hardware, you have to use the same Access Key that was used to license ImageGear on the old system.

If you are not distributing access keys to the end users you will need to provide a mechanism for transferring an access key into a new machine using the Licensing Component LicenseInfo API as described below.

The Deployment Licensing Service will issue a new license key if a certain number of days (default = 45) have already lapsed since the previous license key has been generated for the same access key with different hardware parameters. Otherwise end users would need to contact you, and you would need to call AccuSoft to authorize a license transfer.

Reinstallation of ImageGear-based application into the same hardware
system

In this case, the license will be either found in the registry, or obtained from Deployment Licensing Service, regardless of when it was last requested.

The End User's Windows registry changed (licensing info lost)

In general, if the registry is corrupted it might make sense to reinstall the application or even the entire system. But if the licensing info is the only data deleted from the registry, the licensing process that is executed as a part of the installation/registration can be repeated to retrieve a License Key from the Deployment Licensing Service.


Getting Started

This Chapter provides tutorials that demonstrate how to create a simple Windows Forms application using ImageGear for .NET.

There are the following tutorials:

  • ImageGear for .NET VS 2005 C# Tutorial
  • ImageGear for .NET VS 2005 VB Tutorial
  • ImageGear for .NET WebForms Tutorial
  • ImageGear for .NET WPF Tutorial

For more details how to create an imaging application using ImageGear for .NET please see ImageGear for .NET Samples.

NOTE: Microsoft Windows Vista and Visual Studio 2005/2008

Microsoft recommends running Visual Studio 2005/2008 with administrator privileges under Vista. To properly use the ImageGear Samples please run Visual Studio 2005/2008 with elevated permissions. To run Visual Studio 2005/2008 with elevated administrator permissions, first confirm you are a member of the "Administrators" group on the local machine. Then right-click the Visual Studio 2005/2008 shortcut and select the "Run as administrator" option from the context menu. Click `Continue' to the UAC prompt. To ensure you have the latest updates, after running Visual Studio 2005/2008 choose `Check for Updates' from the Help Menu.


ImageGear for .NET VS 2005 C# Tutorial

In this section you will learn how to create a simple C# Windows Forms application using ImageGear for .NET. The application in this tutorial loads, displays, zooms and rotates images.

  • Creating the Project
  • Designing the Form
  • Developing the Application
NOTE: The instructions in this tutorial are specific to Visual Studio .NET 2005.


Creating the Project

First start Visual Studio .NET. The Visual studio .NET environment will appear.

  1. Choose to start a new project and select Visual C# as the project type and Windows application as the template. The project name for this tutorial will be IGTutorial. Click OK after entering in the project name.

  2. Next go to the Windows Forms toolbox and right click in it. Select Choose Items... from the popup menu. In the .NET Framework Components tab click the Browse button. Navigate to ImageGear.NET\Bin and select IGWinFormsV16n.dll then click Open. You will see the page view, magnifier, and thumbnail controls added to the list of components. Make sure that it is checked and click OK.

  3. Next in the Solution Explorer right click on References and click Add Reference. Choose the Browse tab and go to the "...\ImageGear.NET V16\Bin\" directory, select both ImageGearV16n.dll and IGWinFormsV16n.dll and click Open. Then click OK to the Add Reference dialog. You should now have both files listed under References in the Solution explorer.


Designing the Form

  1. First we will create a menu on the form. In the Windows Forms toolbox drag a MainMenu control onto the form. Create three menus called File, View and Processing. Under the file menu add: Load Page and Exit. Under the view menu add: Zoom in and Zoom out. Under the processing menu add: Rotate 90, Rotate 180 and Rotate 270. For this tutorial we have kept the default names for the controls. Your menus should look as follows:

  2. Next we will add the ImageGear Page View control to the form. In the Windows Forms toolbox click and drag the ImGearPageView control onto the form. You can resize the control to take up the entire form if you wish but we will add code to handle this later in the tutorial. Keep the default control name, imGearPageView1, for this control. The form should now look as follows:


Developing the Application

  1. First we will add necessary Imports statements. Open the code for the form by right clicking on the form and clicking View Code. At the top of the code add the following statements:
    C#
    using System.IO;
using ImageGear;
using ImageGear.Core;
using ImageGear.Formats;
using ImageGear.Processing;
using ImageGear.Display;
  2. Next add the following global variables to Form1:
    C#
    // holds the image data
private ImGearPage igPage = null;
// controls how the page is displayed
private ImGearPageDisplay igPageDisplay = null;
  3. Add the following statement to the function Form1() for Form1 just before the call to InitializeComponent:
    C#
    if (IntPtr.Size == 8)
    // 64bit eval and development solution name
    ImGearLicense.SetSolutionName("AccuSoft 3-41-16");
else
    // 32bit eval and development solution name
    ImGearLicense.SetSolutionName("AccuSoft 3-40-16");
  4. Now, go back to the design view and double click on the Load Page menu item. This will bring up the code for the click event. Add the following code to the routine.
    C#
    OpenFileDialog openFileDialog1 = new OpenFileDialog();
openFileDialog1.Filter =
ImGearFileFormats.GetSavingFilter(ImGearSavingFormats.UNKNOWN);
if (openFileDialog1.ShowDialog() == DialogResult.OK)
{
    using (FileStream stream = new
    FileStream(openFileDialog1.FileName, FileMode.Open,
    FileAccess.Read, FileShare.Read))
    {
        try
        {
            // Load the image into the page
            igPage = ImGearFileFormats.LoadPage(stream, 0);
        }
        catch (Exception ex)
        {
            Console.WriteLine("Failed to load image");
        }
    }
    if (igPage != null && igPage.DIB != null &&
    !igPage.DIB.IsEmpty())
    {
        // create a new page display
        igPageDisplay = new ImGearPageDisplay(igPage);
        // associate the page display with the page view
        imGearPageView1.Display = igPageDisplay;
        // cause the page view to repaint
        imGearPageView1.Invalidate();
    }
}

The code above utilizes:

ImGearPageDisplay Class
Constructs a new PageDisplay object for the given page.
ImGearPageView Class.Invalidate
Invalidates the control thus causing it to repaint.
ImGearFileFormats Class.LoadPage
Loads a file from a given stream and returns a new ImGearPage.
ImGearFileFormats Class.GetSavingFilter
Gets a filter string which can be passed to a windows common dialog filter member.

  1. Go back into design view and double click on the Zoom in menu item. This will bring up the code for the click event. Add the following code to the routine:
    C#
    if (igPageDisplay != null && !igPageDisplay.Page.DIB.IsEmpty())
{
    // Get the current zoom info
    ImGearZoomInfo igZoomInfo = igPageDisplay.GetZoomInfo(imGearPageView1);
    // Increase the zoom
    igZoomInfo.Horizontal.Value = igZoomInfo.Horizontal.Value * 1.25;
    igZoomInfo.Vertical.Value = igZoomInfo.Vertical.Value * 1.25;
    igZoomInfo.Horizontal.Fixed = true;
    igZoomInfo.Vertical.Fixed = true;
    // Set the new zoom values and repaint the view
    igPageDisplay.UpdateZoomFrom(igZoomInfo);
    imGearPageView1.Invalidate();
}

The code above utilizes:

ImGearPageDisplay Class.GetZoomInfo
Retrieves the current zoom information from the display and page view.
ImGearPageDisplay Class.UpdateZoomFrom
Sets new zoom values from the given ImGearZoomInfo object.
ImGearZoomInfo Structure
Holds horizontal and vertical zoom values and settings.

  1. Go back into design view and double click on the Zoom out menu item. This will bring up the code for the click event. Add the following code to the routine:
    C#
    if (igPageDisplay != null && !igPageDisplay.Page.DIB.IsEmpty())
{
    ImGearZoomInfo igZoomInfo = igPageDisplay.GetZoomInfo(imGearPageView1);
    igZoomInfo.Horizontal.Value = igZoomInfo.Horizontal.Value * (1 / 1.25);
    igZoomInfo.Vertical.Value = igZoomInfo.Vertical.Value * (1 / 1.25);
    igZoomInfo.Horizontal.Fixed = true;
    igZoomInfo.Vertical.Fixed = true;
    igPageDisplay.UpdateZoomFrom(igZoomInfo);
    imGearPageView1.Invalidate();
}
  2. Go back to the design view and double click on the Rotate 90 menu item. This will bring you to the code for the click event. Add the following code to the routine:
    C#
    if (igPageDisplay != null && igPage != null && !igPageDisplay.Page.DIB.IsEmpty())
{
    try
    {
        ImGearProcessing.Rotate(igPage, ImGearRotationValues.VALUE_90);
    }
    catch (Exception ex)
    {
        Console.WriteLine(ex.Message);
    }
    imGearPageView1.Invalidate();
}

The code above utilizes:

ImGearProcessing Class.Rotate
Rotates the given page by the given amount

  1. The code for the click handlers for the Rotate 180 and Rotate 270 menu items are the same as above except that the amount to rotate by is ImGearRotationValues.VALUE_180 and ImGearRotationValues.VALUE_270 respectively.
  2. For Visual Studio 2005, set the Dock property of the imGearPageView1 control to 'Fill'. This will cause the control to resize as the form resizes.
  3. Lastly we can add the click code for the Exit menu item. Go to the design view and double click on the Exit menu item. Add the following line to the routine:
    C#
    this.Close();


ImageGear for .NET VS 2005 VB Tutorial

In this section you will learn how to create a simple VB.NET Windows Forms application using ImageGear for .NET. The application in this tutorial loads, displays, zooms and rotates images.

  • Creating the Project
  • Designing the Form
  • Developing the Application
NOTE: The instructions in this tutorial are specific to Visual Studio .NET 2005.


Creating the Project

First start Visual Studio .NET. The Visual studio .NET environment will appear.

  1. Choose to start a new project and select Visual Basic as the project type and Windows application as the template. The project name for this tutorial will be IGTutorial. Click OK after entering in the project name.

  2. Next go to the Windows Forms toolbox and right click in it. Select Choose Items... from the popup menu. In the .NET Framework Components tab click the Browse button. Navigate to ImageGear.NET\Bin and select IGWinFormsV16n.dll then click Open. You will see the page view, magnifier, and thumbnail controls added to the list of components. Make sure that it is checked and click OK.

  3. Next in the Solution Explorer right click on References and click Add Reference. Choose the Browse tab and go to the "...\ImageGear.NET V16\Bin\" directory, select both ImageGearV16n.dll and IGWinFormsV16n.dll and click Open. Then click OK to the Add Reference dialog. You should now have both files listed under References in the Solution explorer.


Developing the Application

  1. First we will add necessary Imports statements. Open the code for the form by right clicking on the form and clicking View Code. At the top of the code add the following statements:
    VB .NET
    Imports System.IO
Imports ImageGear
Imports ImageGear.Core
Imports ImageGear.Formats
Imports ImageGear.Processing
Imports ImageGear.Display
Imports ImageGear.Windows.Forms
  2. Next add the following global variables to Form1:
    VB .NET
    ' holds the image data
Private igPage As ImGearPage
' controls how the page is displayed
Private igPageDisplay As ImGearPageDisplay
  3. Add the following statement to the function Form1() for Form1 just before the call to InitializeComponent:
    VB .NET
    If (IntPtr.Size = 8) Then
    '64bit eval and development solution name
    ImGearLicense.SetSolutionName("AccuSoft 3-41-16")
Else
    '32bit eval and development solution name
    ImGearLicense.SetSolutionName("AccuSoft 3-40-16")
End If
  4. Now, go back to the design view and double click on the Load Page menu item. This will bring up the code for the click event. Add the following code to the routine.
    VB .NET
    Dim dlg As New OpenFileDialog
dlg.Filter = "All files (*.*)|*.*"
dlg.FilterIndex = 1
dlg.RestoreDirectory = True
If dlg.ShowDialog = DialogResult.OK Then
    Dim stream As New FileStream(dlg.FileName, FileMode.Open)
    Try
        ' load the image into the page
        igPage = ImGearFileFormats.LoadPage(stream, 0)
    Catch ex As Exception
        Console.WriteLine("Failed to load image")
    End Try
    If Not igPage Is Nothing AndAlso Not igPage.DIB Is Nothing Then
        ' create a new page display
        igPageDisplay = New ImGearPageDisplay(igPage)
        ' associate the page display with the page view
        ImGearPageView1.Display = igPageDisplay
        ' cause the page view to repaint
        ImGearPageView1.Invalidate()
    End If
End If

The code above utilizes:

ImGearPageDisplay Class
Constructs a new PageDisplay object for the given page.
ImGearPageView Class.Invalidate
Invalidates the control thus causing it to repaint.
ImGearFileFormats Class.LoadPage
Loads a file from a given stream and returns a new ImGearPage.

  1. Go back into design view and double click on the Zoom in menu item. This will bring up the code for the click event. Add the following code to the routine:
    VB .NET
    If Not igPageDisplay Is Nothing AndAlso Not igPageDisplay.Page.DIB.IsEmpty() Then
    ' get the current zoom info
    Dim igZoomInfo As ImGearZoomInfo
    igZoomInfo = igPageDisplay.GetZoomInfo(ImGearPageView1)
    ' increase the zoom
    igZoomInfo.Horizontal.Value = igZoomInfo.Horizontal.Value * 1.25
    igZoomInfo.Vertical.Value = igZoomInfo.Vertical.Value * 1.25
    igZoomInfo.Horizontal.Fixed = True
    igZoomInfo.Vertical.Fixed = True
    ' set the new zoom values and repaint the view
    igPageDisplay.UpdateZoomFrom(igZoomInfo)
    ImGearPageView1.Invalidate()
End If

The code above utilizes:

ImGearPageDisplay Class.GetZoomInfo
Retrieves the current zoom information from the display and page view.
ImGearPageDisplay Class.UpdateZoomFrom
Sets new zoom values from the given ImGearZoomInfo object.
ImGearZoomInfo Structure
Holds horizontal and vertical zoom values and settings.

  1. Go back into design view and double click on the Zoom out menu item. This will bring up the code for the click event. Add the following code to the routine:
    VB .NET
    If Not igPageDisplay Is Nothing AndAlso Not igPageDisplay.Page.DIB.IsEmpty() Then
    ' get the current zoom info
    Dim igZoomInfo As ImGearZoomInfo
    igZoomInfo = igPageDisplay.GetZoomInfo(ImGearPageView1)
    ' decrease the zoom
    igZoomInfo.Horizontal.Value = igZoomInfo.Horizontal.Value / 1.25
    igZoomInfo.Vertical.Value = igZoomInfo.Vertical.Value / 1.25
    igZoomInfo.Horizontal.Fixed = True
    igZoomInfo.Vertical.Fixed = True
    ' set the new zoom values and repaint the view
    igPageDisplay.UpdateZoomFrom(igZoomInfo)
    ImGearPageView1.Invalidate()
End If
  2. Go back to the design view and double click on the Rotate 90 menu item. This will bring you to the code for the click event. Add the following code to the routine:
    VB .NET
    If Not igPage Is Nothing Then
    Try
        ImGearProcessing.Rotate(igPage, ImGearRotationValues.VALUE_90)
    Catch ex As Exception
        Console.WriteLine(ex.Message)
    End Try
    ImGearPageView1.Invalidate()
End If

The code above utilizes:

ImGearProcessing Class.Rotate
Rotates the given page by the given amount

  1. The code for the click handlers for the Rotate 180 and Rotate 270 menu items are the same as above except that the amount to rotate by is ImGearRotationValues.VALUE_180 and ImGearRotationValues.VALUE_270 respectively.
  2. For Visual Studio 2005, set the Dock property of the imGearPageView1 control to 'Fill'. This will cause the control to resize as the form resizes.
  3. Lastly we can add the click code for the Exit menu item. Go to the design view and double click on the Exit menu item. Add the following line to the routine:
    VB .NET
    Application.Exit()


ImageGear for .NET WebForms Tutorial

In this section you will learn how to create a simple ASP.Net Web Forms application using ImageGear for .NET WebForms namespace functionality. The application in this tutorial loads, displays and flips images.

  • Adding ImGearWebPageView Control to the Form
  • Setting up Auxiliary Folders and Files
  • Adding Other Controls
  • Adding the Code
  • Running the Test Application
NOTE: The instructions in this tutorial apply to Visual Studio .NET 2005.


Adding ImGearWebPageView Control to the Form

  1. Open Visual Studio .NET 2005
  2. Create a new project, using ASP.Net Web Site template
  3. Add ImGearWebPageView component to the toolbox: Right-click on the toolbox pane; select "Choose items" from context menu; find and check "ImGearWebPageView" in the components list.
  4. Open your ASP.Net form in Design view
  5. Drag ImGearWebPageView icon from toolbox to the form. By default, the control will use ImGearWebPageView1 name.


Setting up Auxiliary Folders and Files

  1. Add the following directories to the home directory of your web application:
    Directory
    Necessary access permissions
    ImGearWebPageView
    Read, Execute scripts
    ImGearWebPageView\Cache
    Read, Write, Directory browsing, no execution
    ImGearWebPageView\JS
    Read, Execute scripts
    ImGearWebPageView\Resource
    Read
    ImGearWebPageView\Tmp
    Read, Write, Directory browsing, no execution
  2. Copy contents of IG_Net2_WebForms\ImGearWebPageView\JS\ and IG_Net2_WebForms\ImGearWebPageView\Resource\ directories to corresponding directories of your application.
  3. Create a directory for images that your test application will display. This directory is not used by the toolkit, it will only be used for this test application:
    Directory
    Necessary access permissions
    Img
    Read

Put a few image files to this directory.


Adding Other Controls

  1. Put a dropdown list control and two button controls to the form. By default, dropdown list control will use DropDownList1 name.
  2. Change buttons text to "Load" and "Flip" and rename button names in the Name property to "ButtonLoad" and "ButtonFlip" for each correspondingly.


Adding the Code

  1. Switch to the code view.
  2. Add these using statements to your code file:
    C#
    using System.IO;
using ImageGear;
using ImageGear.Core;
using ImageGear.Formats;
using ImageGear.Processing;
using ImageGear.Web.Forms;
  3. Add the following code to the Page_Load event handler:
    C#
    // Put user code to initialize the page here
ImGearLicense.SetSolutionName("AccuSoft 3-40-16");
if (!IsPostBack)
{
    string ImgPath = MapPath("Img");
    string filename;
    string[] files = Directory.GetFiles(ImgPath, "*.*");
    foreach (string filepath in files)
    {
        filename = Path.GetFileName(filepath);
        if (string.Compare(filename, "Thumbs.db", false) != 0)
            DropDownList1.Items.Add(filename);
    }
}
NOTE: The code above applies to Windows 32-bit.:
ImGearLicense.SetSolutionName("Accusoft 3-40-16");
For Windows 64-bit, use the following line instead:
ImGearLicense.SetSolutionName("Accusoft 3-40-16");

This code will fill dropdown list with names of files that are present in the Img directory.

  1. Switch to the Design view and double-click on the Load button.
  2. Visual Studio will create a handler for the button click event. Add the following code to it:
    C#
    string path = MapPath("Img/" + DropDownList1.SelectedValue);
using (FileStream InStream = new FileStream(path,FileMode.Open, FileAccess.Read))
{
    ImGearWebPageView1.ImagePage = ImGearFileFormats.LoadPage(InStream, 0);
}
  3. Switch to the Design view and double-click on the Flip button.
  4. Add the following code to the event handler:
    C#
    if (ImGearWebPageView1.ImagePage != null)
    ImGearProcessing.Flip(ImGearWebPageView1.ImagePage,ImGearFlipModes.VERTICAL);


Running the Test Application

  1. Run the application. Visual Studio will launch a browser window with your form loaded in it.
  2. Select a file name from dropdown list and press the Load button. ImGearWebPageView will show the image.

  3. Press Flip button to flip the image.


ImageGear for .NET WPF Tutorial

This section provides ImageGear for .NET WPF tutorials, which show how to create a simple WPF application using ImageGear for .NET. There are the following tutorials specific to Visual Studio .NET 2005:

  • ImageGear for .NET VS 2005 C# WPF Tutorial
  • ImageGear for .NET VS 2005 VB WPF Tutorial
NOTES: The ImageGear.WPF Namespace used in these tutorials requires the final released version of Windows Workflow Foundation Runtime Components, Microsoft Windows Vista, or the .NET Framework 3.0 Runtime Components.

Creating WPF Tutorial samples with Visual Studio 2005 requires Visual Studio 2005 extensions for .NET Framework 3.0 to be installed. It can be downloaded from the Microsoft web site and installed as an extension plug-in to the Visual Studio 2005.


ImageGear for .NET VS 2005 C# WPF Tutorial

In this section you will learn how to create a simple C# WPF application using ImageGear for .NET. This application loads, displays, and saves images. This section will also show how to enable ImageGear WPF functionality (like HD Photo format support) and use it in the sample application.

  • Creating the Project
  • Designing the Application Window
  • Developing the Application

Creating the Project

First start Visual Studio .NET 2005. The Visual Studio .NET 2005 environment will appear.

  1. Choose to start a new project and select Visual C# as the project type and .NET Framework 3.0 Windows Application (WPF) as the template. The project name for this tutorial will be WPFTutorial. Click OK after entering in the project name.

  2. Next go to the Windows Forms toolbox and right click in it. Select Choose Items... from the popup menu. In the .NET Framework Components tab click the Browse button. Navigate to ImageGear.NET\Bin and select IGWinFormsV16n.dll then click Open. You will see the page view, magnifier, and thumbnail controls added to the list of components. Make sure that it is checked and click OK.

  3. Next in the Solution Explorer right click on References and click Add Reference. Choose the .NET tab, select WindowsFormsIntegration and click OK to the Add Reference dialog. You should now have it listed under References in the Solution explorer.

  4. Next in the Solution Explorer right click on References and click Add Reference. Choose the .NET tab, select System.Windows.Forms and click OK to the Add Reference dialog. You should now have it listed under References in the Solution explorer.

  5. Next in the Solution Explorer right click on References and click Add Reference. Choose the Browse tab and go to the "...\ImageGear.NET V16\Bin\" directory, select both ImageGearV16n.dll, IGWinFormsV16n.dll and IGWpfV16n.dll and click Open. Then click OK to the Add Reference dialog. You should now have both files listed under References in the Solution explorer.

Designing the Application Window

  1. First we will add the Page View control to the sample.

Open up the main window (Window1.xaml) in the XAML designer, which should look like this:

<Window x:Class="WPFTutorial.Window1"
xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
             Title="WPFTutorial" Height="434" Width="629"
>
        <Grid></Grid>
</Window>

Insert WinForms namespace alias and WPFTutorial namespace alias into the header as well as WindowsFormsHost text block that defines the PageView control.

  1. Next we will create a menu on the form.

Once again, open up the main window (Window1.xaml) in the XAML designer. Insert Window.CommandBindings section describing the menu handlers and the actual MenuItem tags describing each individual menu.

NOTE: You would need to put MenuItem definitions inside of the DockPanel tags.

Your XAML file should now look as follows:

<Window x:Class="WPFTutorial.Window1"
        xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
        xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
        xmlns:igwf="clr-namespace:ImageGear.Windows.Forms;assembly=IGWinFormsV16n"
        xmlns:custom="clr-namespace:WPFTutorial"
        Title="WPFTutorial" Height="434" Width="629"
        >
        <Window.CommandBindings>
            <CommandBinding Command="ApplicationCommands.Open"
                                            Executed="OpenCmdExecuted"
                                            CanExecute="OpenCmdCanExecute"/>
            <CommandBinding Command="ApplicationCommands.Save"
                                            Executed="SaveCmdExecuted"
                                            CanExecute="SaveCmdCanExecute"/>
            <CommandBinding Command="{x:Static custom:Window1.AppExitCmd}"
                                            Executed="AppExitCmdExecuted"
                                            CanExecute="AppExitCmdCanExecute"/>
            <CommandBinding Command="ApplicationCommands.Help"
                                            Executed="HelpCmdExecuted"
                                            CanExecute="HelpCmdCanExecute"/>
        </Window.CommandBindings>
        <DockPanel>
            <Menu DockPanel.Dock="Top"
                        Height="25">
                <MenuItem Header="_File">
                    <MenuItem Header="Load Page" Command="ApplicationCommands.Open"/>
                    <MenuItem Header="Save Page"  Command="ApplicationCommands.Save"/>
                    <Separator/>
                    <MenuItem Header="_Exit" Command="{x:Static custom:Window1.AppExitCmd}"/>
                </MenuItem>
                <MenuItem Header="_Help">
                    <MenuItem Header="_About" Command="ApplicationCommands.Help"/>
                </MenuItem>
            </Menu>
            <Grid>
                <WindowsFormsHost  x:Name="PageViewHost"							Grid.Row="1">
                    <igwf:ImGearPageView x:Name="imGearPageView" Width="200" Height="100"/>
                </WindowsFormsHost>
            </Grid>
        </DockPanel>
</Window>

Developing the Application

  1. First we will add necessary Import statements. Open the code for the form by double clicking on Window1.xaml.cs. At the top of the code add the following statements:
    C#
    using System;
using System.IO;
using System.Windows.Input;
using ImageGear.Core;
using ImageGear.Display;
using ImageGear.WPF;
using ImageGear.Formats;
using ImageGear.Windows.Forms;

  2. Next add the following global variables:
    C#
    private static readonly string applicationTitle =
ImGearVersion.ProductName + " WPF Sample";

  3. Add the initialization code, licensing code and enable HD Photo format support available in WPF assembly in the main window constructor:
    C#
    public Window1()
{
if (IntPtr.Size == 8)
{
//Win64
ImGearLicense.SetSolutionName("Accusoft 3-40-16");
}
else
{
//Win32
ImGearLicense.SetSolutionName("Accusoft 3-40-16");
}
// HD Photo format should be inserted before TIFF format
// (TIFF 2-byte signature is a part of wpd signature).
ImGearFileFormats.Filters.Insert(0,   ImGearHDPhoto.CreateHDPhotoFormat());
InitializeComponent();
this.Title = applicationTitle;
}

  4. Now add the routed commands for the XAML command binding definitions:

    5. C#
    #region routed commands
// The custom command.
// Note, the command binding is done in XAML.
public static RoutedCommand AppExitCmd = new RoutedCommand();
#endregion

  5. And finally add the menu event handlers:
    C#
    void OpenCmdExecuted(object target, ExecutedRoutedEventArgs e)
{
ImGearLoadingSelection selection =
ImGearWinForms.SelectLocalFileToLoad(null, "Select File");
if (null != selection)
{
using (FileStream fileContent = ((ImGearLocalFile)
   selection.File).OpenToRead())
{
ImGearPage page = ImGearFileFormats.LoadPage(fileContent, 0);
ImGearColorProfileSettings.CheckColorMismatch(page);
imGearPageView.Page = page;
// Reset display settings
imGearPageView.Display = new ImGearPageDisplay(imGearPageView.Page);
imGearPageView.Update();
}
}
}
void OpenCmdCanExecute(object sender, CanExecuteRoutedEventArgs e)
{
e.CanExecute = true;
}
void SaveCmdExecuted(object target, ExecutedRoutedEventArgs e)
{
ImGearSavingSelection selection =
ImGearWinForms.SelectLocalFileToSave(null, "Save Page", imGearPageView.Page);
if (null != selection)
{
using (FileStream content = ((ImGearLocalFile)
   selection.File).OpenToWrite())
{
ImGearFileFormats.SavePage(imGearPageView.Page, content, 0,
ImGearSavingModes.OVERWRITE, selection.Format, null);
}
}
}
void SaveCmdCanExecute(object sender, CanExecuteRoutedEventArgs e)
{
e.CanExecute = (imGearPageView != null && imGearPageView.Page != null);
}
void AppExitCmdExecuted(object target, ExecutedRoutedEventArgs e)
{
this.Close();
}
void AppExitCmdCanExecute(object sender, CanExecuteRoutedEventArgs e)
{
e.CanExecute = true;
}
void HelpCmdExecuted(object target, ExecutedRoutedEventArgs e)
{
ImGearWinForms.ShowAboutBox(null, applicationTitle);
}
void HelpCmdCanExecute(object sender, CanExecuteRoutedEventArgs e)
{
e.CanExecute = true;
}

  6. You are now ready to compile and run the application.


ImageGear for .NET VS 2005 VB WPF Tutorial

In this section you will learn how to create a simple VB WPF application using ImageGear for .NET. This application loads, displays and saves images. This section will also show how to enable ImageGear WPF functionality (like HD Photo format support) and use it in the sample application.

  • Creating the Project
  • Designing the Application Window
  • Developing the Application

Creating the Project

First start Visual Studio .NET 2005. The Visual Studio .NET 2005 environment will appear.

  1. Choose to start a new project and select Visual Basic as the project type and .NET Framework 3.0 Windows Application (WPF) as the template. The project name for this tutorial will be WPFTutorial. Click OK after entering in the project name.

  2. Next go to the Windows Forms toolbox and right click in it. Select Choose Items... from the popup menu. In the .NET Framework Components tab click the Browse button. Navigate to ImageGear.NET\Bin and select IGWinFormsV16n.dll then click Open. You will see the page view, magnifier, and thumbnail controls added to the list of components. Make sure that it is checked and click OK.

  3. Next in the Solution Explorer right click on WPFTutorial and click Add Reference. Choose the .NET tab, select WindowsFormsIntegration and click OK to the Add Reference dialog. You should now have it listed under References in the Solution explorer.

  4. Next in the Solution Explorer right click on WPFTutorial and click Add Reference. Choose the .NET tab, select System.Windows.Forms and click OK to the Add Reference dialog. You should now have it listed under References in the Solution explorer.

  5. Next in the Solution Explorer right click on WPFTutorial and click Add Reference. Choose the Browse tab and go to the "...\ImageGear.NET V16\Bin\" directory, select both ImageGearV16n.dll, IGWinFormsV16n.dll and IGWpfV16n.dll and click Open. Then click OK to the Add Reference dialog. You should now have both files listed under References in the Solution explorer.

Designing the Application Window

  1. First we will add the Page View control to the sample.

Open up the main window (Window1.xaml) in the XAML designer, which should look like this:

<Window x:Class="WPFTutorial.Window1"
xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
             Title="WPFTutorial" Height="434" Width="629"
>
        <Grid></Grid>
</Window>

Insert WinForms namespace alias and WPFTutorial namespace alias into the header as well as WindowsFormsHost text block that defines the PageView control.

<Window x:Class="WPFTutorial.Window1"
xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
xmlns:igwf="clr-namespace:ImageGear.Windows.Forms;assembly=IGWinFormsV16n"
        xmlns:custom="clr-namespace:WPFTutorial"
Title="WPFTutorial" Height="434" Width="629"
>
        <Grid>
            <WindowsFormsHost  x:Name="PageViewHost"							Grid.Row="1">
                <igwf:ImGearPageView x:Name="imGearPageView" Width="200" Height="100"/>
            </WindowsFormsHost>
        </Grid>
</Window>
  1. Next we will create a menu on the form.

Once again, open up the main window (Window1.xaml) in the XAML designer. Insert Window.CommandBindings section describing the menu handlers and the actual MenuItem tags describing each individual menu.

NOTE: You would need to put MenuItem definitions inside of the DockPanel tags.

Your XAML file should now look as follows:

<Window x:Class="WPFTutorial.Window1"
        xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
        xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
        xmlns:igwf="clr-namespace:ImageGear.Windows.Forms;assembly=IGWinFormsV16n"
        xmlns:custom="clr-namespace:WPFTutorial"
        Title="WPFTutorial" Height="434" Width="629"
        >
        <Window.CommandBindings>
            <CommandBinding Command="ApplicationCommands.Open"
                                            Executed="OpenCmdExecuted"
                                            CanExecute="OpenCmdCanExecute"/>
            <CommandBinding Command="ApplicationCommands.Save"
                                            Executed="SaveCmdExecuted"
                                            CanExecute="SaveCmdCanExecute"/>
            <CommandBinding Command="ApplicationCommands.Help"
                                            Executed="HelpCmdExecuted"
                                            CanExecute="HelpCmdCanExecute"/>
        </Window.CommandBindings>
        <DockPanel>
            <Menu DockPanel.Dock="Top"
                        Height="25">
                <MenuItem Header="_File">
                    <MenuItem Header="Load Page" Command="ApplicationCommands.Open"/>
                    <MenuItem Header="Save Page"  Command="ApplicationCommands.Save"/>
                </MenuItem>
                <MenuItem Header="_Help">
                    <MenuItem Header="_About" Command="ApplicationCommands.Help"/>
                </MenuItem>
            </Menu>
            <Grid>
                <WindowsFormsHost  x:Name="PageViewHost"							Grid.Row="1">
                    <igwf:ImGearPageView x:Name="iGearPageView" Width="200" Height="100"/>
                </WindowsFormsHost>
            </Grid>
        </DockPanel>
</Window>

Developing the Application

  1. First we will add necessary Import statements. Open the code for the form by double clicking on Window1.xaml.vb. At the top of the code add the following statements:

    2. VB
    Imports System
Imports System.IO
Imports System.Windows.Input
Imports ImageGear.Core
Imports ImageGear.Display
Imports ImageGear.WPF
Imports ImageGear.Formats
Imports ImageGear.Windows.Forms

  2. Next add WPFTutorial namespace:

    3. VB
    Namespace WPFTutorial
' Interaction logic for Window1.xaml
Partial Public Class Window1
Inherits System.Windows.Window
...
End Class
End Namespace

  3. Next add the following global variables:

    4. VB
    Private applicationTitle As String = _
 ImGearVersion.ProductName + " WPF Sample"

  4. Add the initialization code, licensing code and enable HD Photo format support available in WPF assembly in the main window constructor:

    5. VB
    Public Sub New()
If IntPtr.Size = 8 Then
'Win64
ImGearLicense.SetSolutionName("Accusoft 3-40-16")
Else
'Win32
ImGearLicense.SetSolutionName("Accusoft 3-40-16")
End If
' HD Photo format should be inserted before TIFF format
' (TIFF 2-byte signature is a part of wpd signature).
ImGearFileFormats.Filters.Insert(0,  ImGearHDPhoto.CreateHDPhotoFormat())
Me.Title = applicationTitle
End Sub

  5. And finally add the menu event handlers:

    6. VB
    Private Sub OpenCmdExecuted(ByVal target As Object, ByVal e As ExecutedRoutedEventArgs)
Dim selection As ImGearLoadingSelection = _
 ImGearWinForms.SelectLocalFileToLoad(Nothing, "Select File")
If Not selection Is Nothing Then
Dim localFile As ImGearLocalFile = selection.File
Dim fileContent As FileStream = localFile.OpenToRead()
Dim page As ImGearPage = ImGearFileFormats.LoadPage(fileContent, 0)
ImGearColorProfileSettings.CheckColorMismatch(page)
iGearPageView.Page = page
' Reset display settings
iGearPageView.Display = New ImGearPageDisplay(iGearPageView.Page)
iGearPageView.Update()
End If
End Sub
Private Sub OpenCmdCanExecute(ByVal sender As Object, ByVal e As CanExecuteRoutedEventArgs)
e.CanExecute = True
End Sub
Private Sub SaveCmdExecuted(ByVal target As Object, ByVal e As ExecutedRoutedEventArgs)
Dim selection As ImGearSavingSelection = _
 ImGearWinForms.SelectLocalFileToSave(Nothing, "Save Page", iGearPageView.Page)
If Not selection Is Nothing Then
Dim localFile As ImGearLocalFile = selection.File
Dim content As FileStream = localFile.OpenToWrite()
ImGearFileFormats.SavePage(iGearPageView.Page, content, 0, _
 ImGearSavingModes.OVERWRITE, selection.Format, Nothing)
End If
End Sub
Private Sub SaveCmdCanExecute(ByVal sender As Object, ByVal e As CanExecuteRoutedEventArgs)
e.CanExecute = True
End Sub
Private Sub HelpCmdExecuted(ByVal target As Object, ByVal e As ExecutedRoutedEventArgs)
ImGearWinForms.ShowAboutBox(Nothing, applicationTitle)
End Sub
Private Sub HelpCmdCanExecute(ByVal sender As Object, ByVal e As CanExecuteRoutedEventArgs)
e.CanExecute = True
End Sub

  6. You are now ready to compile and run the application.


ImageGear for .NET Samples

ImageGear for .NET has the following samples:

  • The ImageGear ASP.NET sample shows how to display non-web-friendly images over the web without downloading any applets or client side components. The sample consists of two pages. The main page has an HTML link to an "image" and the second page acts as the "image" by outputting only a pure image with no HTML. The main page has a simple user interface that displays an image and allows the user to zoom in, zoom out and scroll the image. To ensure the minimum data transfer, first the application cuts only the visible area of the image and resizes it to fit the image rectangle on the UI page. Then the image is converted to one of the web image formats according to the following scheme: 1-bit images are converted to TIFF Group 4, 8-bit images to GIF and 24-bit images to JPEG. After all the conversions are done the application outputs the resulting image by writing the image data to Response.OutputStream. For more details please refer to the ImageGear ASP.NET Sample.
  • The ImageGear WebForms AJAX sample shows how to use ImageGear WebForms with ASP .NET AJAX to display and process images on a web page without relying on full-page postbacks.
  • ImageGear C#.NET ART sample shows how to manipulate with ART annotations, import and export them from/to XML. ImageGear C#.NET ART sample shows how to manipulate ART annotations and import and export them from/to XML.
  • ImageGear C#.NET Core sample demonstrates the core product functionality, working with documents and individual pages.
  • ImageGear C#.NET Display sample shows display capabilities, which includes anti-aliasing, transparency and extra channels.
  • ImageGear C#.NET FreqIP sample is for demonstrating the features related to image processing in frequency domain, such as Fourier Transform, Low Pass Filter, etc.
  • ImageGear C#.NET Medical sample is provided for working with DICOM images and medical functionality.
  • ImageGear C#.NET PDF sample is provided for working with PDF documents and demonstrates PDF specific capabilities of the product.
  • ImageGear C#.NET Processing sample shows the variation of the image processing supported by the product, which includes different types of color and image transformation as well as the color space and color profiles conversion.
  • ImageGear C#.NET Timing sample provides the benchmarking methods for input, output, display and image processing functionality.
  • ImageGear C#.NET TWAIN sample demonstrates product's scanning capabilities using the installed TWAIN drivers.
  • ImageGear C#.NET Vector sample shows how to deal with CAD and other vector files providing a comprehensive GUI for vector and 3D processing.
  • ImageGear C#.NET WPF sample enables support for HD Photo images and demonstrates the XAML based thumbnail and magnifier controls.
  • ImageGear VB.NET Tutorial sample is just a simple template application with basic product functionality for VB.NET developers.


Using ImageGear for .NET

ImageGear for .NET is implemented as safe and managed code and offers the hierarchy of classes, structures, interfaces, and enumerations. It is structured into several namespaces, providing APIs in the following categories: Core Functionality, Formats, Processing, and Display. Below you will find a description of the product architecture as well as the information regarding using each of the provided namespaces.

  • Architecture
  • Image and ImGearPage
  • Loading/Saving Pages and Documents
  • Displaying Images
  • Processing Images
  • Working with Color Profiles
  • Working with Spot Colors
  • Working with Transparent Color
  • Non-Image Data Processing
  • Warnings and Errors
  • Using ImageGear.ART Namespace
  • Using ImageGear.Display Namespace
  • Using ImageGear Digital Camera RAW Formats
  • Using ImageGear.Formats.DICOM Namespace
  • Using ImageGear.Formats.JPEG2K Namespace
  • Using ImageGear.Formats.PDF Namespace
  • Using ImageGear.Formats.U3D Namespace
  • Using ImageGear.FreqIP Namespace
  • Using ImageGear.Processing Namespace
  • Using ImageGear.Processing.ImageClean Namespace
  • Using ImageGear.Processing.Layers Namespace
  • Using ImageGear.TWAIN Namespace
  • Using ImageGear.Vector Namespace
  • Using ImageGear.Web.Forms Namespace
  • Using ImageGear.Windows.Forms Namespace
  • Using ImageGear.Windows.Forms.Thumbnail Namespace
  • Using ImageGear.WPF Namespace


Architecture

The ImageGear for .NET library is logically divided into five major parts, encapsulated into following namespaces - Core, Processing, Formats, Display and extensions. An example of their relationship is shown in the following diagram:

ImageGear.Core Namespace is the basis of ImageGear for .NET toolkit. This namespace contains classes to operate with graphics primitives, to license product, and most importantly, primary ImageGear entities like page and document. Page is implemented in the ImGearPage Class and represents an image in memory. It contains image attributes, pixels, and offers functions for basic operating like access to stored pixels or metadata assignment.

Since the most persistent form of storage for images are files, ImageGear offers the ImGearFileFormats Class class, located in ImageGear.Formats Namespace, to handle them. Using this class, it is possible to load and store single pages from local and network files, obtain properties like width and height without loading an entire image, and operate with multi-image documents (ImGearDocument Class) like TIFF. The toolkit also contains classes like ImGearLoadOptions Class and interfaces like the ImGearControlParameter Class to control image loading and saving processes (including saving the format and its characteristics).

A file is not the only source an image may be obtained from. To acquire a page or document from a scanner device, the ImGearTWAIN Class class should be used. It helps to properly set up device parameters and obtain scanned images as single page or multi-page documents.

Once an image (in its representation as ImGearPage Class) is created or obtained from a file or scanner, it is possible to process it using the ImGearProcessing Class class. It defines a series of members that can be applied to any ImGearPage Class instance. Adjusting brightness/contrast, flipping, inversion, rotation and other operations are available for developers. Additionally, an export to managed GDI + Bitmap class is also available through ImGearProcessing Class.

The ImGearPageDisplay Class class serves to represent an image on the computer's screen. It exists in the ImageGear.Display Namespace and allows drawing the attached ImGearPage Class onto a Windows form with an impressive variety of options.

NOTE: TWAIN scanning is not supported by ImageGear for .NET CF version. To get the support for TWAIN scanning, as well as for PDF and JPEG 2000 extensions, please purchase the regular ImageGear for .NET version for 32-bit Operating System (Win98SE/Me/2000/XP).


Image and ImGearPage

One of the primary entities in the ImageGear for .NET toolkit is page and its implementation as ImGearPage Class.

ImGearPage Class consists of three main parts: image data, metadata and region of interest.

Image data (or simply, image) is available for manipulations through the DIB property and has a ImGearDIB Class class type. Color space, channels, width and height are major attributes which define image structure.

ImageGear for .NET considers image as a collection of channels, each of which gives some single piece of information about the pixels in a whole image. Channels are defined as an array of depths for each channel. Depth specifies the quantity of different values for a particular channel. This data is constant for the page until image processing functions are applied. It may be accessed through the ImGearDIB Class.ChannelDepth Property property.

The ImGearColorSpace Structure structure (returned by the ImGearDIB Class . ColorSpace Property property) defines the semantics of the information stored in all channels (i.e., whether the second channel is the green component of RGB color, magenta of CMYK, or alpha value of a grayscale image). This information may be formed from ImGearColorSpaceIDs Enumeration flags and placed into the constructor of ImGearPage Class.

Pixels in ImGearDIB Class may be accessed as both individual pixels or groups of pixels. GetPixelCopy Method () and UpdateColumnFrom Method () are examples of such members. An important issue is that all of these routines return copies of the data stored in an image as an array of the ImGearPixel Class. None of these members allows direct access to the pixel store.

To gain direct access to an image, GetImage Method () or GetRaster Method () members of ImGearDIB Class should be used. This is an efficient way to implement image processing routines, since all changes made to the structures (returned by these functions) will be reflected in the image. Users of GetImage Method () and GetRaster Method () should completely understand the structure of the internal pixel store to avoid producing ill-formed images.

The following example creates an RGB image and swaps red and blue channel values for diagonal pixels.

C#
const int pageSize = 200;
const int redChannel = 0;
const int greenChannel = 1;
const int blueChannel = 2;
// Creates page with RGB colorspace and 8 bits channels.
ImGearPage igPage = new ImGearRasterPage(pageSize, pageSize,
    new ImGearColorSpace(ImGearColorSpaceIDs.RGB),
    new int[] { 8, 8, 8 },
    true);
// Iterates all rows in created page.
for (int row = 0; row < igPage.DIB.Height; ++row)
{
    // Obtains reference to raster store.
    ImGearArrayRef igArrayRef = igPage.DIB.GetRaster(row);
    // Casts content to byte[] since all channels are 8 bit.
    byte[] raster = (byte[])igArrayRef.Content;
    // Offset of diagonal pixel in raster.
    int pixelOffset = igArrayRef.Offset + row * igPage.DIB.ChannelCount;
    // Swaps red & blue.
    byte red = raster[pixelOffset + redChannel];
    raster[pixelOffset + redChannel] = raster[pixelOffset + blueChannel];
    raster[pixelOffset + blueChannel] = red;
}

Metadata is non-image data, often available in some complex formats like TIFF or PNG. It may have complexity and is completely dependent on the nature of file format. To provide a way of manipulating such data, ImageGear for .NET offers a set of classes composed from ImGearMetadataNode Class, ImGearMetadataNodeList Class and ImGearMetadataTree Class and their descendants. For a particular ImGearPage Class instance, metadata may be accesses through the Metadata Property.

Region of interest (ImGearROI Class) represents a free-shape image area (rectangular, non-rectangluar or entire space) and specifies a meanful part of an image. For example, a region of interest may be established to define an area where some image processing functions should be applied.


Loading/Saving Pages and Documents

ImGearFileFormats Class class should be used to load/save images. It offers LoadPage Method (), SavePage Method (), LoadDocument Method () and SaveDocument Method () members for these purposes. Each of these members mainly loads (saves) image from a given .NET Stream object. ImageGear supports loading from streams having the seek ability, as well as from streams that don't have the seek ability, such as network streams.

ImageGear only supports saving to streams that have the seek ability.

The following example demonstrates how to load a single page from a local file:

C#
ImGearPage igPage;
using (FileStream localFile = new FileStream("photo.jpg",FileMode.Open))
{
    igPage = ImGearFileFormats.LoadPage(localFile, 0);
}

The next example demonstrates how to load a page from a remote file:

C#
ImGearPage igPage;
WebRequest request = WebRequest.Create("http://www.google.com/intl/en_ALL/images/logo.gif");
using (WebResponse response = request.GetResponse())
    using (Stream stream = response.GetResponseStream())
        igPage = ImGearFileFormats.LoadPage(stream, 0);

The example below demonstrates how to stream a particular page of document into memory:

C#
ImGearDocument igDocument;
using (FileStream localFile = new FileStream("MULTIPAG.TIF", FileMode.Open))
{
    int pageCount = ImGearFileFormats.GetPageCount(localFile, ImGearFormats.UNKNOWN);
    igDocument = ImGearFileFormats.LoadDocument(localFile, 0, pageCount);
}
System.IO.MemoryStream memory = new MemoryStream();
ImGearFileFormats.SavePage(igDocument.Pages[0], memory, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.JPG);
byte[] array = memory.ToArray();

Also refer to the following sections:

  • Loading Pages and Documents from Internet
  • Pixel Format Conversion during Image Saving
  • Using Filter Control Parameters


Loading Pages and Documents from Internet

ImageGear provides a specialized stream class for loading of images from internet: ImGearWebStream Class. This class is most useful for loading of multipage images, because it downloads only the necessary portion of remote file.

ImGearWebStream Class only supports loading images from servers that use HTTP protocol.

The following example demonstrates how to load a page from a remote document using ImGearWebStream Class:

C#
ImGearPage igPage;
using (ImGearWebStream igWebStream = new ImGearWebStream ("http://localhost/MULTIPAG.TIF"))
    igPage = ImGearFileFormats.LoadPage(igWebStream, 2);


Pixel Format Conversion during Image Saving

ImageGear supports a variety of pixel formats (color spaces and channel depths). However, most image file formats support only a limited set of pixel formats. For example, PNG format does not support CMYK color space, and JPEG Lossy format does not support storing 16 bit per channel pixel values. ImageGear provides conversion from source image's pixel format into one of the pixel formats supported by destination image file format.

Availability of a specific pixel format for saving depends on requested compression, saving options and filter control parameters.

ImageGear uses the following logic to select the pixel format for saving:

  • if the format filter directly supports saving of image's pixel format, ImageGear uses this pixel format;
  • otherwise, if the format filter supports saving of pixel formats that exceed the image's pixel format (so no image quality degradation occur), ImageGear uses the one that takes least storage space;
  • otherwise, ImageGear uses the pixel format that results in least degradation of image quality.

A special case is when the image color space has to converted, and multiple choices of channel depths are available. In that case ImageGear selects channel depths that are equal to image's channel depths, rather than larger channel depths. This results in a slightly worse quality degradation, but avoids unexpected increase in image size. For example, PNG format does not support CMYK color space, but it supports storing 8 or 16 bits per channel. ImageGear saves a 32-bit CMYK to PNG as 24-bit RGB rather than 48-bit RGB.

NOTE: ImageGear does not support conversion from multichannel truecolor color spaces (RGB, CMYK, etc) into indexed color space during saving.

Use ImGearSaveOptions Class.ConversionMode Property to specify the acceptability of image quality degradation or bit depth promotion during saving.

Use ImGearSaveOptions Class.ForceColorspace Property to make ImageGear use a specific color space for saving.


Using Filter Control Parameters

Many format filters in ImageGear have control parameters that affect filter operations, such as image reading and writing. Those parameters may be declared by the format specification or they may be specific to format implementation by ImageGear.

There are two ways to specify filter control parameters:

  • Specify parameters globally. This affects all format reading and writing operations, and threads in the process. Use the Filters static property of the ImGearFileFormats Class to set parameters globally.
  • Specify parameters locally. This affects only one reading or writing operation, and thus can be used for setting different parameters in different threads. To specify the local parameters, create an instance of ImGearFileFilters Class, assign it to ImGearLoadOptions Class.Filters property or ImGearSaveOptions Class.Filters property, and pass the Load or Save options object to the reading or writing method, correspondingly.

The following example sets a global control parameter:

C#
IImGearFormat JpgFormat = ImGearFileFormats.Filters.Get(ImGearFormats.JPG);
ImGearControlParameter Param = JpgFormat.Parameters.GetByName("SaveType");
Param.Value = 1; // Lossless
using (FileStream fsWrite = File.Open("Test.jpg", FileMode.Create, FileAccess.ReadWrite, FileShare.None))
    ImGearFileFormats.SavePage(imGearPage, fsWrite, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.JPG, null);

The following example sets a local control parameter:

C#
ImGearFileFilters LocalFilters = new ImGearFileFilters();
IImGearFormat JpgFormat = LocalFilters.Get(ImGearFormats.JPG);
ImGearControlParameter Param = JpgFormat.Parameters.GetByName("SaveType");
Param.Value = 1; // Lossless
ImGearSaveOptions SaveOptions = new ImGearSaveOptions();
SaveOptions.Filters = LocalFilters;
using (FileStream fsWrite = File.Open("Test.jpg", FileMode.Create, FileAccess.ReadWrite, FileShare.None))
    ImGearFileFormats.SavePage(imGearPage, fsWrite, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.JPG, SaveOptions);


Displaying Images

Once the ImGearPage Class object is obtained (either by itself, or as part of an ImGearDocument Class), the most common thing to do with it is to display it on the computer screen. Usually, an application will only display a given image on the computer screen once. However, there are many situations when an application will need to display the same image more than once (e.g., to allow the end user to apply some alternate display settings, the application needs to show "before" and "after" images at the same time). The various control options used to determine the appearance on the screen are all bundled together in a single object called ImGearPageDisplay Class. Each ImGearPageDisplay Class is associated with one (and only one) ImGearPage Class, but a given ImGearPage Class can have any number (0, 1 or more) of ImGearPageDisplay Class associated with it.

All that is necessary is to create an ImGearPageDisplay Class instance attached to the page, setup displaying style optionally, and call its Draw Method member during paint event handling.


ImGearPageDisplay Class

To work with the ImGearPageDisplay Class class, your application must create an ImGearPage Class object first, and load an image into it. The following example shows the use of the ImGearFileFormats Class . LoadPage Method, but any of the techniques could be used:

C#
// declared somewhere in you application
public ImGearPage m_igPage = null;

....
C#
using (FileStream stream = new FileStream(
    "test1.tif", FileMode.Open,
    FileAccess.Read, FileShare.Read))
{
    m_igPage = ImGearFileFormats.LoadPage(stream, 0);
}

Next, your application must create an ImGearPageDisplay Class object for the ImGearPage Class. This is done by declaring a respective variable and initializing it:

C#
// declared somewhere in you application
public ImGearPageDisplay m_igPageDisplay = null;

....
C#
m_igPageDisplay = new ImGearPageDisplay(m_igPage);

By itself, the ImGearPageDisplay Class object does not cause the image to appear on the computer screen. For that to happen, .NET provides a construct of type Graphics. There are many .NET API functions that can be used to obtain a Graphics for ImGearPageDisplay Class to use. A simple case instance of Graphics is provided as part of the Paint event

To simplify programming, ImageGear provides a .NET control called ImGearPageView Class that automatically performs image drawing according to settings stored in ImGearPageDisplay Class. The application programmer simply places the ImGearPageView Class onto a dialog or other window, and then adds a line of code to the application to associate the ImGearPageView Class with the ImGearPageDisplay Class object.

ImGearPageDisplay Class offers several options for rendering the image:

  1. Using an ImGearPageView Class, as shown above.
  2. Directly into a Graphics. The application program must obtain the Graphics for this purpose (e.g., from HDC handle returned by Windows GDI GetDC() function). The image is rendered by calling the ImGearPageDisplay Class . Draw Method.
  3. Directly into a printer Device Context. The application must obtain the printer Graphics for this purpose (e.g., from the Printer Common Dialog). The image is printed by calling the ImGearPageDisplay Class.Print Method.

When the ImGearPageDisplay Class is created, ImageGear creates the structures needed to render the image. When the ImGearPageDisplay Class is associated with an ImGearPageView Class, and the ImGearPageView Class.Update Method is called, then the image is rendered into the Graphics defined by the ImGearPageView Class. There are a host of display setting properties in ImGearPageDisplay Class. They can be altered to change the way that the image is rendered - those properties will be discussed below. After setting any of the ImGearPageDisplay Class properties, or modifying the image in the ImGearPage Class object, the application must call ImGearPageView Class.Update Method once again to re-render the image:

C#
imGearPageView.Display = m_igPageDisplay;
imGearPageView.Update();

Neither changes to the display settings (e.g., changes to ImGearPageDisplay Class properties), nor changes to the ImGearPage Class object associated with the ImGearPageDisplay Class will cause an automatic redraw of the ImGearPageView Class - the application must call the ImGearPageView Class.Update Method to have it regenerate the DIB for the image. Continuing our example, assume that the application loads a different image into the ImGearPage Class object:

C#
using (FileStream stream = new FileStream(
    "photo.jpg", FileMode.Open,
    FileAccess.Read, FileShare.Read))
{
    m_igPage = ImGearFileFormats.LoadPage(stream, 0);
}
m_igPageDisplay.Page = m_igPage;

ImGearPage Class is changed, but image is not yet rendered:

C#
imGearPageView.Update();


ImGearPageDisplay Functions

ImGearPageDisplay Class provides a great deal of display-related properties and methods. All of the methods, and most of these properties, are used by your application program to control the way the image is displayed in the application.

NOTE: The following ImGearPageDisplay Class properties and methods affect the display of an image only, not the image itself (as contained in the ImGearPage Class object). They do not alter the image bitmap. To alter the image itself, use the Image Manipulation facilities of ImageGear, described below.

A few of these properties are "read-only", and provide information about the rendered image to your application. The ImGearPageDisplay Class properties are grouped into data-value objects as a way to organize them. The data-value objects, and the properties that they contain, are as follows (for complete descriptions of these properties and methods, see the ImageGear.Display Namespace Chapter).

IImGearAntiAlias Interface
Properties used to make scanned text more readable, by removing or minimizing the "aliasing" (jagged edges of characters and other thin lines). For example:
Original Image
With AntiAliasing

These properties can be referenced directly, using the AntiAliasing Property of ImGearPageDisplay Class:
imGearPageView.Display.AntiAliasing.Method =
ImGearAliasModes.NONE;
IImGearBackground Interface
Controls the appearance of the area that is inside ImGearPageView Class, but outside of the displayed image. For example:
Default Background

Your application can set the background to a solid color or disable background drawing. These properties can be referenced directly, using the Background Property of ImGearPageDisplay Class:
imGearPageView.Display.Background.Mode =
ImGearBackgroundModes.NONE;
ImGearScrollInfo Structure
Controls the way a portion of a large image is visible within the smaller ImGearPageView Class. Scrolling can either be automatic (ImageGear takes care of it) or manual (your application has to react to mouse events and tell ImGearPageDisplay Class how to position the image). The scroll properties are all inter-related, and so they are "gotten" from ImGearPageDisplay Class as a group, and they are "updated" in ImGearPageDisplay Class as a group. Access them as follows:
ImGearScrollInfo igScrollInfo;
igScrollInfo =
imGearPageView.Display.GetScrollInfo(imGearPageView);
Change the properties as follows: :
igScrollInfo.Horizontal.Mode =
ImGearScrollBarModes.SCROLLBAR_ENABLE;
imGearPageView.Display.UpdateScrollFrom(imGearPageView,
igScrollInfo);
ImGearZoomInfo Structure
Controls the way that an image is magnified before being displayed in the ImGearPageView Class. For example:
Actual Size
300% Zoom

The zoom properties are all inter-related, and so they are "gotten" from ImGearPageDisplay Class as a group, and they are "updated" in ImGearPageDisplay Class as a group. Access them as follows:
ImGearZoomInfo igZoomInfo;
igZoomInfo =
imGearPageView.Display.GetZoomInfo(imGearPageView);
bool isHorizontalFixed;
// Check if the horizontal zoom mode is fixed.
isHorizontalFixed = igZoomInfo.Horizontal.Fixed;
Change the properties as follows:
igZoomInfo.Horizontal.Fixed = true;
igZoomInfo.Horizontal.Value = 0.5;
igZoomInfo.Vertical.Fixed = true;
igZoomInfo.Vertical.Value = 0.5;
imGearPageView.Display.UpdateZoomFrom(igZoomInfo);
ImGearPageView Class.Layout Property
Controls the geometric appearance (full image or partial image, centered or not, etc.) of the image as displayed in ImGearPageView Class.
Layout settings include three rectangles (ImageRect, ClipRect and DeviceRect) that can be used to control the layout of the image as rendered - see ImageRect, ClipRect, and DeviceRect for a description of these rectangles. Normally your application won't reference these rectangles, as they default to the size of the image and the size of the ImGearPageView Class client area, respectively.
The most commonly used layout properties are Alignment and FitMode:
Alignment.Horizontal: Left
Alignment.Vertical: Top
Fit: To Window Height
These properties can be referenced directly, using the Layout property of ImGearPageDisplay Class:
imGearPageView.Display.Layout.FitMode =
ImGearFitModes.ACTUAL_SIZE;
ImGearFitModes igFitMode;
igFitMode = imGearPageView.Display.Layout.FitMode;

The Orientation Property attribute is accessible directly from the ImGearPageDisplay Class object:

ImGearPageView Class.Orientation Property
Another control that determines the geometric appearance of the image as displayed in ImGearPageView Class. For example:
BOTTOM_RIGHT
RIGHT_BOTTOM

These properties can be referenced directly:
imGearPageView.Display.Orientation.Value =
ImGearOrientationModes.BOTTOM_RIGHT;
ImGearOrientationModes igOrientationMode;
igOrientationMode = imGearPageView.Display.Orientation.Value;

The following ImGearPageDisplay Class methods can be used to change the way the ImGearPage Class image is rendered:

ScrollTo Method ()
An alternate mechanism for scrolling the image
ZoomToRectangle Method ()
An alternate mechanism for setting the zoom properties


ImageRect, ClipRect, and DeviceRect

ImageRect

This rectangle defines the part of the image that is output to the device. It is expressed in image coordinates. By default, this option is set to the entire image. Use the ImGearPageDisplay Class.Layout Property.ImageRect Property to change this attribute.

ClipRect

This rectangle identifies the destination device area affected by the display operations. It is expressed by device coordinates and is initially assigned to the entire client area of the ImGearPageView Class. Use the ImGearPageDisplay Class.Layout Property.ClipRect Property to change this attribute.

DeviceRect

The image does not have to necessarily fit exactly into the device rectangle. The position of the image inside the device rectangle may also be determined by other display options such as AspectRatio Property, FitMode Property and Alignment Property. Use the ImGearPageDisplay Class.Layout Property.DeviceRect Property to change this attribute.

Displayed Image Rectangle (DisplayedImageRect)

Although this is not a display option you can set, it is an important concept. This rectangular area represents the image size and location on the device and is therefore expressed in device coordinates. It is NOT related to the ClipRect Property, which represents the visible part of the image. The DisplayedImageRect value can be calculated and used but cannot be set directly.

This figure illustrates the meaning of the rectangles listed above:

Accordingly, if the ImageRect Property remains at its default value (equal to the entire image), and the DeviceRect Property and ClipRect Property remain at their default values (equal to the size of the ImGearPageView Class), and if the FitMode Property is FIT_TO_DEVICE, then the result will be as follows:

If your application makes the DisplayRect 2x wider and 2x taller, but leaves the ClipRect Property set to the size of the ImGearPageView Class (this is the same as setting a 2x zoom), then the following will result:

On the other hand, if your application leaves the DisplayRect set to the size of the ImGearPageView Class, but makes the ClipRect Property half as wide and half as tall, then the following will result:

Note that the settings for ImageRect Property, DeviceRect Property, ClipRect Property, Layout Property.FitMode Property, Layout Property.Alignment Property, ZoomToRectangle Method, ScrollTo Method and Orientation Property can specify conflicting values. The resolution to this is a hierarchy, wherein some of these properties take precedence over others. We will further explain how ImageGear deals with the options when conflicting values are applied.

Consider the general display rendering algorithm. It consists of several steps. Within each step, ImageGear processes some options to introduce modifications to the resulting image. ImageRect Property is oriented according to OrientMode. ClipRect Property and DeviceRect Property are calculated according to their definitions above.

If FitMode Property is set to ACTUAL_SIZE, then DisplayedImageRect.width and DisplayImageRect.height are set to ImageRect Property width and ImageRect Property height respectively. Otherwise, DisplayedImageRect is computed using DeviceRect Property. According to Horizontal and Vertical zoom modes (fixed or not), Horizontal and Vertical zoom values, DisplayedImageRect.width and DisplayedImageRect.height are modified as follows:

If (zoomHorizontal.Fixed)
    DisplayedImageRect.Width = DisplayedImageRect.width*zoomHorizontal.Value
and
If (zoomVertical.Fixed)
    DisplayedImageRect.Height = DisplayedImageRect.height*zoomVertical.Value;
If AspectRatio.Fixed is set to true, zoomVertical.Value is not used, and the above
procedure is changed in the following way:
If (zoomHorizontal.Fixed)
{
    DisplayedImageRect.Width = DisplayedImageRect.width*zoomHorizontal.Value;
    DisplayedImageRect.Height = DisplayedImageRect.width*zoomHorizontal.Value
}

DisplayedImageRect.x and DisplayedImageRect.y are computed so that DisplayedImageRect is aligned as specified by AlignMode. The scrolling range is calculated so that DisplayedImageRect can be viewed within ClipRect Property. Then DisplayedImageRect.x and DisplayedImageRect.y are shifted according to the current scroll position.


Displaying Medical Images

ImageGear provides special display features for medical images, such as Value Of Interest (Window Levelling), Modality transform, and presentation state display support. These features are accumilated in the ImGearDICOMDisplaySettings Class class. An instance of ImGearDICOMDisplaySettings Class class can be attached to ImGearRasterPage Class as a member:

ImGearRasterPage Class.DICOMDisplaySettings Property

When ImageGear loads a DICOM image, it initializes DICOMDisplaySettings Property with settings found in the image. Display code applies these settings during image display. This allows you to load and display DICOM images properly without the need for any DICOM specific application code.

DICOMDisplaySettings Property member only affects the grayscale images. It is ignored, if attached to the color images.

Application can attach DICOMDisplaySettings Property to an image, even if it was not loaded from a DICOM file.

ImGearDICOMDisplaySettings Class stores display settings in their original form. For example, if linear VOI transform is used, ImageGear stores Window Center and Window Width values, rather than a LUT calculated from these values. In particular, if an automatic VOI transform is used during image loading, the application can obtain Window Width and Window Center values that have been automatically selected.

A special member of this class, DisplaySummaryLUT Property, is a look up table that concatenates all transforms from ImGearDICOMDisplaySettings Class. The application have to call UpdateDisplaySummaryLUT Method to update the LUT after any transformations have been changed.

NOTE: If the application changes any display settings, such as VOI, Modality, etc, and then saves the image, ImageGear writes the changed settings to the file.


Processing Images

Using the ImGearProcessing Class and ImGearRasterProcessing Class, it is possible to manipulate an image in different ways.

Resize, crop, rotate and flip may be done with the identical members of the ImGearProcessing Class and ImGearRasterProcessing Class.

Change of contrast, brightness and/or gamma correction are available through InvertContrast Method (), AdjustContrast Method () and other members.

To convert from one color representation to another (e.g., from RGB to CYMK, or RGBA to Grayscale, or 8-bit color to 32-bit color) ConvertColorSpace Method () and ChangeChannelsDepths Method () functions can be used.

A combination of two images into a new one may be created using the Merge Method (), CombineChannels Method () and Blend Method () functions.

The alpha channel may be operated though the BlendWithAlpha Method () and ConvertColorSpace Method () members.

The System Bitmap instance for particular page may be obtained with the Export Method () routine.


Using ImGearProcessing and ImGearRasterProcessing Classes

The classes ImGearProcessing Class and ImGearRasterProcessing Class present a set of methods for modifying an image. You do not need to create an ImGearProcessing Class object to call its methods since all methods are static. Any method takes an image to be processed and some additional parameters necessary for processing the operation. For example, the Rotate Method will be called as follows:

ImGearProcessing.Rotate(Page, ImGearRotationValues.VALUE_90);

Image processing methods are shown below:

Action group
API reference
Crop - removes part of the image
ImGearProcessing Class.Crop Method
Resize - retains the same image, but either increase the number of pixels (interpolating to determine the color values for the new ones), or reduce the number of pixels
ImGearProcessing Class.Resize Method
Changes the geometry of the image
ImGearProcessing Class.Flip Method
ImGearProcessing Class.Rotate Method
ImGearRasterProcessing Class . Shear Method
ImGearRasterProcessing Class . Perspective Method
Changes the contrast, brightness and/or gamma correction in the image - all these methods have two representations: the second type takes two additional parameters Contrast Mode and Channel Range; the first representation of any method calculates these parameters according the image type and color space.
ImGearRasterProcessing Class.InvertContrast Method
ImGearRasterProcessing Class.AdjustContrast Method
ImGearRasterProcessing Class.StretchContrast Method
ImGearRasterProcessing Class.EqualizeContrast Method
Creating a thumbnail - an image with the new size is created but source image is not changed
ImGearProcessing Class.CreateThumbnail Method
Checking for grayscale image
ImGearRasterProcessing Class.ImageIsGray Method
Filter methods - these methods are based on the convolution of the image and the filter matrix. Any filter method (except Convolution) has two representations: with and without channel range.
ImGearRasterProcessing Class.Convolve Method
ImGearRasterProcessing Class.Sharpen Method
ImGearRasterProcessing Class.Smooth Method
ImGearRasterProcessing Class.FilterWithMedian Method
ImGearRasterProcessing Class.FilterWithUnsharpMask Method
Methods for combining two or more images - these methods have two representation: with and without channel range
ImGearRasterProcessing Class.Merge Method
ImGearRasterProcessing Class.Blend Method
ImGearRasterProcessing Class.BlendWithAlpha Method
Methods for manipulating with image channels and color spaces
ImGearRasterProcessing Class.ConvertColorSpace Method
ImGearRasterProcessing Class.ChangeChannelsDepths Method
ImGearRasterProcessing Class.CombineChannels Method
ImGearRasterProcessing Class.SeparateChannels Method
ImGearRasterProcessing Class.InsertChannel Method
ImGearRasterProcessing Class.RemoveChannel Method
ImGearRasterProcessing Class.CreateChannelCopy Method
ImGearRasterProcessing Class.UpdateChannelFrom Method
ImGearRasterProcessing Class.SwapChannels Method
Processing binary and grayscale images by applying erosion and dilation
ImGearRasterProcessing Class . Dilate Method
ImGearRasterProcessing Class . Erode Method ImGearRasterProcessing Class . Close Method
ImGearRasterProcessing Class . Open Method
Stylization - these methods imitate scanned paper photographs, analog cameras, or special photo equipment
ImGearRasterProcessing Class . Aging Method
ImGearRasterProcessing Class . NightVision Method
ImGearRasterProcessing Class . ToyCamera Method
Artistic effects - these methods make the image look like a hand painted picture
ImGearRasterProcessing Class . Oilify Method
ImGearRasterProcessing Class . Pointillist Method
ImGearRasterProcessing Class . Spatter Method
Rendering effects - these methods change image lightness or color using a specific shaper or pattern
ImGearRasterProcessing Class . DirectionalLight Method
ImGearRasterProcessing Class . FreeDirectionalLight Method
ImGearRasterProcessing Class . FreeRadialLight Method
ImGearRasterProcessing Class . LensFlare Method
ImGearRasterProcessing Class . RadialLight Method
ImGearRasterProcessing Class . Spotlights Method
ImGearRasterProcessing Class . SpotlightsPreview Method
Image enhancement - these methods enhance image detail
ImGearRasterProcessing Class . EnhanceLocal Method
Borders and frames - these methods add borders, frames, or vignettes to the image
ImGearRasterProcessing Class . DropShadow Method
ImGearRasterProcessing Class . RoundCorners Method
ImGearRasterProcessing Class . Vignette Method
Distortions - these methods rearrange pixels using a specific pattern or texture
ImGearRasterProcessing Class . Fragment Method
ImGearRasterProcessing Class . Mosaic Method
ImGearRasterProcessing Class . Pinch Method
ImGearRasterProcessing Class . RadialWave Method
ImGearRasterProcessing Class . WarpCylinder Method
ImGearRasterProcessing Class . WarpParabolic Method
ImGearRasterProcessing Class . WarpSphere Method
Color effects - these methods give the image a new look by changing its color
ImGearRasterProcessing Class . Duotone Method
ImGearRasterProcessing Class . Sepia Method
ImGearRasterProcessing Class . Spotlights Method
ImGearRasterProcessing Class . SpotlightsPreview Method
ImGearRasterProcessing Class . Solarize Method
Removes red eye
ImGearPixelCheckerRedEyeRGB Class . ImGearPixelCheckerRedEyeRGB Constructor
ImGearPixelProcessorRedEyeRGB Class . ImGearPixelProcessorRedEyeRGB Constructor
Detects image edges
ImGearRasterProcessing Class . EdgeDetection Method
Speckle removal - these methods remove noise from a grayscale or bitonal image
ImGearRasterProcessing Class . Despeckle Method
ImGearRasterProcessing Class . GeomDespeckle Method

The C# samples given below illustrate how to work with some Image Processing methods (in the samples, assume that igPage is a valid object of type ImGearPage Class):

Sample 1: Rotate:

C#
// Rotate the page to 45 degrees and expand according to the new image
// size. The background will be set to black.
// Create background color object
ImGearPixel igPixelBackground = new ImGearPixel(igPage.DIB.ChannelCount,
    igPage.DIB.BitsPerChannel);
// Rotate
ImGearProcessing.Rotate(igPage, 45, ImGearRotationModes.EXPAND, igPixelBackground);

Sample 2: Crop:

C#
// Cut a quarter of an image from left, top, right and bottom
int cutWidth = igPage.DIB.Width / 4;
int cutHeight = igPage.DIB.Height / 4;
// Crop
ImGearProcessing.Crop(igPage, cutWidth, cutHeight, 2 * cutWidth, 2 * cutHeight);

Sample 3: AdjustContrast:

C#
double contrast = 1.2;
double brightness = 64;
double gamma = 1.5;
ImGearRasterProcessing.AdjustContrast((ImGearRasterPage)igPage, contrast, brightness, gamma);


Working with Color Profiles

ImageGear for .NET supports color profiles while performing color conversion operations as well as when displaying color profiled images. can apply the embedded image profile as well as the global color profile for display. See ColorProfile property of ImGearRasterPage Class and ImGearColorProfileManager Class class.

Detailed information about color processing based on profiles can be found at www.color.org. The following sections describe how color profiles can be used with ImageGear:

  • Color Profile Basic Concepts
  • ImageGear Color Profile API
  • Pixel Format Conversion During Image Saving
  • Saving Image Files with Embedded Color Profiles


Color Profile Basic Concepts

It is often necessary to use color profiles in order to obtain desirable results when converting image data between color spaces such as CMYK and RGB. Different color spaces have different gamuts, or sets of colors which can be represented. Color profiles contain complex mappings which make it possible to carefully manage the translations of colors between different color spaces and gamuts.

A color profile define instructions for how to map colors from a particular color space to and from a special intermediate color space known as the PCS - profile connection space. There are different ways to do this mapping, representing different tradeoffs and processes, so it is possible to use a wide variety of color profiles. Color profiles typically exist for different input and output devices, such as scanners, cameras, monitors, and printers. Their mappings take into account the physical device characteristics.

When performing color space conversion using color profiles, it is necessary to define a source color profile whose color space matches the color space of the image being converted, as well as a destination color profile whose color space matches the color space the image is to be converted to.

In addition to source and destination color profiles, a rendering intent is also specified. The rendering intent allows additional control over the conversion process by indicating how certain tradeoffs should be made. For more information, see the ImGearRenderingIntents Enumeration and the ICC color profile specifications at www.color.org.


ImageGear Color Profile API

ImageGear for .NET offers two ways to specify color profiles to use for color conversion operations.

  • The first way is a global profile storage system which allows implicit use of color profiles throughout ImageGear.
  • The second way involves explicit specification of profiles when calling certain overloads of methods such as ImGearRasterProcessing Class.ConvertColorSpace Method.

Both ways are easy to use and you should use whichever one suits your particular application needs.

To enable implicit or "automatic" usage of color profiles for color conversion operations, use the ImGearColorProfileManager Class object. ImGearColorProfileManager Class and its methods allow enabling and disabling the automatic use of global color profiles for color space conversion and display operations. You will need to set its EnableProfiles Property property to True, and specify global color profiles via its CmykProfile Property and/or RgbProfile Property properties. Once you have done this, these profiles will be used for the color space conversion. If a profile is associated with a particular image via ImGearRasterPage Class.ColorProfile Property property that profile will be used instead of a global profile as the source profile in a color space conversion. For example, the following code sets the global profiles and converts an image from CMYK to RGB:

C#
ImGearColorProfileManager.EnableProfiles = true;
using (FileStream fs = File.OpenRead("ig_cmyk_profile.icm"))
    ImGearColorProfileManager.CmykProfile = new ImGearColorProfile(fs);
using (FileStream fs = File.OpenRead("ig_rgb_profile.icm"))
    ImGearColorProfileManager.RgbProfile = new ImGearColorProfile(fs);
ImGearRasterProcessing.ConvertColorSpace((ImGearRasterPage)igPage,
    new ImGearColorSpace(ImGearColorSpaceIDs.RGB));

To use explicit specification of color profiles, call the method ImGearRasterProcessing Class.ConvertColorSpace Method or overload it. The conversion operation will use the color profiles specified by the parameters, ignoring any settings of the ImGearColorProfileManager Class object. For example, the following code converts an image from CMYK to RGB by explicitly specifying color profiles:

C#
ImGearColorProfile igColorProfileSource, igColorProfileDest;
using (FileStream fs = File.OpenRead("ig_cmyk_profile.icm"))
    igColorProfileSource = new ImGearColorProfile(fs);
using (FileStream fs = File.OpenRead("ig_rgb_profile.icm"))
    igColorProfileDest = new ImGearColorProfile(fs);
ImGearRasterProcessing.ConvertColorSpace((ImGearRasterPage)igPage,
    new ImGearColorSpace(ImGearColorSpaceIDs.RGB),
    igColorProfileSource, igColorProfileDest, ImGearRenderingIntents.PERCEPTUAL);


Pixel Format Conversion During Image Saving

ImageGear supports a variety of pixel formats (color spaces and channel depths). However, most image file formats support only a limited set of pixel formats. For example, PNG format does not support CMYK color space, and JPEG Lossy format does not support storing 16 bit per channel pixel values. ImageGear provides conversion from the source image's pixel format into one of the pixel formats supported by the destination image file format.

Availability of a specific pixel format for saving depends on requested compression, saving options, and filter control parameters.

ImageGear uses the following logic to select the pixel format for saving:

  • If the format filter directly supports saving of image's pixel format, ImageGear uses this pixel format;
  • Otherwise, if the format filter supports saving of pixel formats that exceed the image's pixel format (so no image quality degradation occurs), ImageGear uses the one that takes least storage space;
  • Otherwise, ImageGear uses the pixel format that results in least degradation of image quality.

A special case is when the image color space has to converted, and multiple choices of channel depths are available. In that case, ImageGear selects channel depths that are equal to the image's channel depths, rather than larger channel depths. This results in a slightly worse quality degradation, but avoids an unexpected increase in image size. For example, PNG format does not support CMYK color space, but it supports storing 8 or 16 bits per channel. ImageGear saves a 32-bit CMYK to PNG as 24-bit RGB rather than 48-bit RGB.

NOTE: ImageGear does not support conversion from multichannel truecolor color spaces (RGB, CMYK, etc.) into indexed color space during saving.

Use ImGearSaveOptions Class.ConversionMode Property to specify the acceptability of image quality degradation or bit depth promotion during saving.

Use ImGearSaveOptions Class.ForceColorspace Property to make ImageGear use a specific color space for saving.

See Saving Image Files with Embedded Color Profiles for details on saving color profiles during image saving.


Saving Image Files with Embedded Color Profiles

ImageGear supports saving color profiles when saving image files. Currently, ImageGear embeds color profiles in the following file formats:

  • JPEG
  • PNG
  • TIFF

Use EmbedColorProfile Property of ImGearSaveOptions Class to enable or disable embedding of color profiles in image files. By default this property is set to true.

When this property is set to true (default), ImageGear saves the color profile to the file being saved. If the destination format supports the image colorspace, ImageGear saves color profile attached to the image, or global color profile selected in ImageGear for this colorspace. If the color space selected for saving does not match the image colorspace, ImageGear converts the image to the destination colorspace, using the global color profile for the destination colorspace, and saves global color profile to the file.

When this property is set to false, ImageGear does not save the color profile to the destination file. It converts the image to the global color profile during saving. ImageGear also uses this logic for formats that do not support embedded color profiles.


Working with Spot Colors

This section provides information about working with Spot Colors.

  • Color Channels
  • Alpha Channel
  • Extra Channel
  • Mask Channel
  • Spot Channel
  • Unknown Channel
  • ImageGear Support


Color Channels

The following types of color channels are currently supported by ImageGear for reading, writing and display.


Alpha Channel

Alpha channel defines opacity/transparency of an image. Only one Alpha channel per image can exist. Color space with Alpha channel can be pre-multiplied or non-pre-multiplied. This is the common definition of an Alpha channel, used by most file formats, such as TIFF, PNG, SGI, TGA, etc.


Extra Channel

Extra channel is any channel besides regular color channels or Alpha. There can be any number of Extra channels per image. Extra channels may have some defined semantics, such as Mask or Spot channels, or can be "Unknown", meaning that ImageGear does not know how to display or process them.


Mask Channel

Mask channel specifies a mask or selection in the image. There can be any number of mask channels per image. Images are never pre-multiplied by mask channels. In ImageGear, Mask channel is a subtype of Extra channel.


Spot Channel

Spot channel uses a specific color. The color can be specified using a standard color space, such as RGB or CMYK, or using a custom color, such as Pantone, TRUMATCH, etc. The custom spot color is defined by its Vendor ID and Color ID.

Existing Vendor IDs:

  • 3000 (ANPA)
  • 3001 (Focoltone)
  • 3002 (PantoneCoated)
  • 3003 (PantoneProcess)
  • 3004 (PantoneProSlim)
  • 3005 (PantoneUncoated)
  • 3006 (Toyo)
  • 3007 (Trumatch)
  • 3008 (HKSE)
  • 3009 (HKSK)
  • 3010 (HKSN)
  • 3011 (HKSZ)
  • 3012 (DIC)
  • 3013 (PantoneMatte)
  • 3020 (PantonePastelCoated)
  • 3021 (PantonePastelUncoated)
  • 3022 (PantoneMetallic)
  • 3024 (HKSEProcess)
  • 3025 (HKSKProcess)
  • 3026 (HKSNProcess)
  • 3027 (HKSZProcess)
  • 3028 (PantoneProSlimEuro)
  • 3029 (PantoneProcessUncoated)

In ImageGear, Spot channel is a subtype of Extra channel.


Unknown Channel

Unknown channel is an additional channel which purpose is unknown to ImageGear. In ImageGear, Unknown channel is a subtype of Extra channel.


ImageGear Support

This section provides information about ImageGear support of Spot colors.

Extra Color Space

An image may contain multiple Extra channels. An Extra channel can belong to one of the following subtypes: Mask, Spot or Unknown. These channels can be mixed in arbitrary order. ImageGear does not use separate bitmasks from ImGearColorSpaceIDs Enumeration for Mask and Spot channels. Instead, it uses ImGearColorSpaceIDs Enumeration .Extra bitmask to specify presence of any of these channels in an image.

ImageGear stores an array of ImGearExtraChannelInfo Classes in IGDIBStd. Length of this array must always be equal to the number of extra channels in the DIB. DIB constructors, color space and channel manipulation functions must insure this.

If an entry of the info array is ImGearSpotChannelInfo Class then corresponding Extra channel is a Spot channel. ImGearSpotChannelInfo Class contains information that is necessary for displaying the spot channel. ImageGear uses spot color channels for display and color space conversions, and saves them to output files when supported by format. If output format does not allow storing additional channels, ImageGear converts Spot channels, together with regular color channels, to the destination color space.

If an entry of the info array is ImGearMaskChannelInfo then corresponding Extra channel is a Mask channel. ImageGear uses Mask channels for display and saves them to output files when supported by format. However, it does not use them in color space conversions. If output format does not allow storing additional channels, ImageGear ignores Mask channels in conversion to the destination color space.

If an entry is ImGearExtraChannelInfo Class then corresponding Extra channel is unknown. It is not used in display and color conversions, but preserved and saved to output files when possible.

Spot color, Mask and Extra channels can be appended after any regular color channels, in any order, including color spaces that contain Alpha or Pre-multiplied Alpha channel.

Reader, Writer and Format Converter

ImageGear for .NET can load extra channels from TIFF and PSD file formats. The extra channels are internally stored as specified above and saved back as extra channels when the output format is either TIFF or PSD. Spot color support is added to the raster color conversion mechanism, so when saving an image to a format that doesn't support extra channels the image spot channels are get blended to the base channels. The alpha channels are skipped in this case.

Color Books

ImageGear for .NET can load Adobe Color Books and apply the loaded colors for displaying spot channels. Color books API allows specifying a path to the color books, enumerates loaded books and colors within a book, and retrieves info on the specific spot color. Display and processing code use color books to convert spot colors to regular colors such as CMYK, RGB etc.


Working with Transparent Color

Reading and writing of transparent color is supported for GIF, PNG and XPM file formats.

Transparent color is automatically extracted from the image file and attached to ImGearPage Class.Transparency Field. This color will be transparent on display.


Non-Image Data Processing

Such complex file formats as EXIF, TIFF, JPEG-JFIF, PNG and some others contain a lot of non-image data generally refered to as metadata. ImageGear provides functionality allowing to read the meta-data during image loading, to store it with the image in memory, and modify metadata during image saving.

ImageGear for .NET provides two sets of API for working with non-image data:

  • General Metadata API. This set of API provides unified access to metadata of all supported image formats. Non-image data itself can be of any possible complex type and completely depends on the nature of the file format itself. ImageGear processes this complex data through a single interface and provides uniform processing that does not depend on the actual data format and varies from information fields of such simple formats as BMP and PCX, up to the complex EXIF and IPTC metadata support in such filters as TIFF and JPEG.
  • Simplified Metadata API. This set of API provides access to standard tags of specific complex formats, such as TIFF, EXIF and IPTC. It takes care of location of particular tags in the metadata tree, decodes and encodes complex metadata values, and provides structures and enumerations for data types according to the metadata standard.

ImageGear for .NET is responsible for translating this format-dependent data into a standard uniform format. As soon as an image is loaded, its metadata is accessible through the Metadata properties of ImGearPage Class and ImGearDocument Class objects.

You do not need to load image pixels to obtain the non-image data. Use ImGearFileFormats Class.LoadPageHeader Method to load DIB info and metadata without loading pixel data.


Common Non-Image Data

ImageGear for .NET uses its Metadata API to provide information that is common for all image file formats, such as compression of file page from which the image was loaded.

Use ImGearMetadataHead Class.Common Property to access common metadata.


Accessing Non-Image Data

ImageGear for .NET uses the different storages for Document level metadata and Page level metadata:

  • Document level metadata is only used with file formats that are capable of storing multiple pages. This metadata includes only values that are common for all pages of the image.
  • Page level metadata is available for all file formats. It includes data that describes an image page.

Different file formats use different metadata structures and tags. When saving an image to a file format which differs from the format of metadata attached to the image, image's metadata is ignored, and default metadata is created instead.

ImageGear uses a tree structure to store format metadata. All nodes of the metadata use a common parent class: ImGearMetadataNode Class. The two following classes are derived from it:

  • ImGearMetadataLeaf Class can only contain data and no nested nodes;
  • ImGearMetadataTree Class can contain the nested nodes but cannot contain the data values.

A special node of type ImGearMetadataHead Class is always present in every ImGearPage Class and ImGearDocument Class as a class member. It cannot be attached to any metadata node, and it can only have one child. If the page (document) has metadata, then metadata tree is attached to this Head node. Otherwise, the Head does not have child nodes.

A node can be un-referenced or referenced from the one parent, but it cannot be referenced from the multiple parents. The node cannot reference itself directly or indirectly. ImageGear checks this when node is attached to another node. Metadata tree can not be shared between multiple pages or documents.

Every metadata node has Format Field property of ImGearMetadataFormats Enumeration type. This allows you to store, for example, EXIF metadata under TIFF metadata. Format value of ImGearMetadataFormats Enumeration.NONE can be used to indicate a custom/unknown format.

Actual data in ImGearMetadataLeaf Class uses System.Object type. NativeType Field of the ImGearMetadataLeaf Class object specifies the type of data which is used by a file format.

Several leafs can reference the same object. ImageGear does not check or maintain consistency between image and metadata attached to it. For example, if an image loaded from TIF file is resized, ImageGear does not update ImageWidth and ImageHeight tags in the image metadata. However, when you save this image, the correct values will be written to the file.


Metadata Dictionary

ImageGear provides a metadata dictionary that stores necessary information for all known metadata tags of all supported formats.

The application can obtain information record for any tag that is present in the dictionary, using ImGearMetadataDictionary Class.LookUp Method .

All tag information records implement IImGearMetadataDictRecord Interface . This interface provides minimal information for a tag - its name. This is sufficient for most ImageGear supported formats. These formats use ImGearCommonMetadataDictRecord Structure for storing tag information. This structure only contains tag and its name.

Dictionary records for DICOM tags contain additional fields, such as Value Representation and Value Multiplicity. ImageGear uses ImGearDICOMMetadataDictRecord Class to store DICOM tag information.

ImageGear contains a big set of predefined dictionary records. In addition, the dictionary allows adding new records for new or custom tags that are not present in the predefined dictionary. The dictionary also allows overwriting predefined information for a tag with a custom one. Use ImGearMetadataDictionary Class.AddRecord Method for this.

Use ImGearMetadataDictionary Class.Reset Method to reset the dictionary to its initial state. This method removes all records that were added by AddRecord Method , and leaves only predefined records.

Metadata dictionary only affects General Metadata API. It does not affect Simplified Metadata API.


Working with XMP Metadata

Extensible Metadata Platform (XMP) is an XML-based standard for storage and interchange of metadata, developed by Adobe Systems Inc. The standard defines the rules for storage and processing of the metadata, and provides a number of schemas for storage of information that is typically asociated with images and documents, such as Title, Author, Creation date/time, Rating, etc. Applications can add their own schemas to store arbitrary information.

XMP metadata can be attached to files of various formats, such as TIFF, JPEG, PSD and PDF, or stored as a standalone file.

ImageGear provides the following ways for working with XMP metadata.

  1. Accessing XMP properties via the ImageGear Metadata API. In this mode, ImageGear decodes XMP properties and accumulates them in the metadata structure, which is attached to the ImGearPage object. Then, the application can access individual properties in one of the two ways:
    1. General Metadata API. In this mode, the application works with a tree structure containing XMP properties. This mode supports arbitrary XMP schemas. However, working in this mode requires that application developer has some knowledge of both the XMP standard and particular schemas.
    2. Simplified Metadata API. In this mode, the application works with classes that allow simple access to particular properties, without the need to know details of the XMP standard, and with only the minimal knowledge of XMP schemas. Simplified API only supports schemas that are known to ImageGear. See description of ImGearXMPMetadataRoot Class for a list of supported schemas.
  2. Working with unprocessed XMP metadata. In this mode, ImageGear passes XMP to the application as a single byte array containing XMP tags. The application can parse this array using a third party XML parser. On the writing side, the application prepares an array containing XMP tags, and passes it to ImageGear. Unprocessed XMP metadata can be accessed via the metadata structure of the containing format, such as TIFF or JPEG, using General Metadata API. The metadata tree will contain the only tag XMP, containing a binary array.

By default, ImageGear parses XMP stream into its metadata structure, and does not provide the Raw XMP stream. If you don't want ImageGear to parse the XMP stream, and prefer to access the unprocessed XMP stream, set ImGearLoadOptions Class.ParseXMP Property to false.

During saving, if XMP tag contains a tree, ImageGear serializes the tree into XMP stream. Alternatively, if XMP tag contains a byte array, ImageGear saves this array verbatim.

Accessing XMP Tags via the General Metadata API

Since XMP standard identifies schema properties using string names, rather than numbers, ImageGear also uses names to identify XMP properties. However, it uses numeric identifiers to differentiate between the kinds of entities, such as Description (schema), Array, Property, Qualifier, etc. All properties have ID = ImGearXMPTagIDs.Property, but differ by their names.

See XMP Non-Image Data Structure section for description of XMP metadata structure in ImageGear.

Example:

Representation of XMP metadata using the General API:

- XMP

  • http://ns.adobe.com/xap/1.0/
    • About = "uuid:faf5bdd5-ba3d-11da-ad31-d33d75182f1b"
    • Namespace
      • Prefix = "xmp"
      • URI = "http://ns.adobe.com/xap/1.0/"
    • Namespace
      • Prefix = "xmpidq"
      • URI = "http://ns.adobe.com/xmp/Identifier/qual/1.0/"
    • Properties
      • xap:Rating
o Value = 4
      • xap:Identifier
o Value = "1234.0345.34532.234231"
o Qualifiers
      • xmpidq:Schema
o Value = "Accusoft doc IDs"
  • http://purl.org/dc/elements/1.1/
    • Namespace
      • Prefix = "dc"
      • URI = http://purl.org/dc/elements/1.1/
    • Properties
      • dc:subject
o Bag
      • Item
o Value = "Test subject 1"
      • Item
o Value = "Test subject 2"
      • dc:title
o Alt
      • Item
o Lang = "x-default"
o Value = "XMP Support Specification"

Accessing XMP Tags via the Simplified Metadata API

Simplified Metadata API allows the application to work with classes that allow simple access to particular properties, without the need to know details of the XMP standard, and with only the minimal knowledge of XMP schemas.

Simplified API only supports schemas that are known to ImageGear. See description of ImGearXMPMetadataRoot Class for a list of supported schemas.

XMP schemas use arrays and structures extensively. Please make sure to read Using Arrays and Structures topic.


Simplified Access to Non-Image Data

ImageGear provides simplified API for accessing specific types of metadata. This API provides the ability to read and write metadata items without the need to know the exact location of these items in the metadata tree. ImGearMetadataHead Class contains accessor members that provide access to metadata structures, such as TIFF, EXIF or IPTC. These accessors represent all standard metadata tags via their properties. Each property uses a specific type, corresponding to the metadata item type, as defined in the specification.

For example:

string ImageDescription = page.Metadata.TIFF.ImageDescription;

A file does not have to include all of the metadata items that are defined by the standard. If a particular item is not present in the metadata tree, the corresponding property returns null. In order to allow such behavior for integers and other value types, corresponding properties use Nullable types.

C#
ImGearTIFFOrientation igTIFFOrientation =
    igPage.Metadata.TIFF.Orientation.GetValueOrDefault(ImGearTIFFOrientation.TopLeft);

VB.NET:
Dim igTIFFOrientation As ImGearTIFFOrientation =
igPage.Metadata.TIFF.Orientation.GetValueOrDefault(ImGearTIFFOrientation.TopLeft)

On the writing side, setting a property to some value replaces the existing value with a new one. Setting a property to null removes the corresponding item from the metadata tree.

Metadata Structures

Currently, ImageGear provides simplified access for the following types of metadata:

Metadata type
ImageGear class
ImGearMetadataHead property
TIFF
ImGearTIFFMetadata Class
TIFF
EXIF
ImGearEXIFMetadata Class
EXIF
IPTC
ImGearIPTCMetadata Class
IPTC

EXIF metadata also has subtrees that are represented by the following classes:

Metadata type
ImageGear class
ImGearEXIFMetadata property
EXIF GPS
ImGearEXIFGPSMetadata Class
GPS
EXIF Interoperability
ImGearEXIFInteropMetadata Class
Interoperability

Classes of the simplified API do not store their own copy of the metadata values. Instead, they access values that are stored in the general metadata tree.

If the page does not contain a specific metadata structure, the corresponding accessor returns null. For example, if an ImGearPage Class was loaded from a BMP image, it will not contain EXIF metadata, and page.Metadata.EXIF will return null.

Simplified API only supports metadata items that were known to AccuSoft at the time of toolkit development, i.e. standard or well-known items. Use general metadata API to access custom and non-standard metadata items.

Creating New Metadata Structures

If a metadata structure does not exist in the image, the application can create it.

For example:

C#
igPage.Metadata.IPTC = new ImGearIPTCMetadata();

VB.NET:
igPage.Metadata.IPTC = New ImGearIPTCMetadata()

However, the page's target metadata format should support the metadata tree being created. For example, if a page was loaded from a BMP image, you can't add IPTC metadata to it. In order to do that, you should set target metadata format to one that supports the metadata structure you are going to add. Use ImGearMetadataHead Class.SetTargetFormat Method and ImGearMetadataHead Class.GetTargetFormat Method to control the target metadata format of the page. Note that changing the target metadata format erases all data from the previous format.

Updating File Metadata Without Updating its Pixel Data

There are cases when an application needs to update metadata of an image file, while leaving its pixel data unchanged. For example, if the image is compressed using a Lossy compression scheme, this avoids degradation of image quality.

Use ImGearFileFormats Class.UpdatePageMetadata Method to update metadata in an image file without changing its pixel data.

Currently, the method only supports metadata updating in the DICOM file format.

Supported File Formats for Simplified Access to Non-Image Data

Metadata type
File formats that can contain the metadata structure
TIFF
TIFF, JFIF JPEG, Camera Raw formats
EXIF
TIFF, JFIF JPEG, Camera Raw formats
IPTC
TIFF, JFIF JPEG, Camera Raw formats

EXIF vs. TIFF Metadata

The EXIF specification uses a subset of tags defined in the TIFF specification. Due to this, ImGearEXIFMetadata Class contains a subset of TIFF tags (those that are referenced in the EXIF specification). These tags can be accessed through either ImGearEXIFMetadata Class or ImGearTIFFMetadata Class accessors.

Common Language Specification Compatibility

Properties of the metadata accessors use types that match native metadata types as close as possible. Some of these types, however, do not belong to the .NET Common Language Specification, i.e. are not guaranteed to be supported in all .NET development environments. These types include: System.Sbyte, System.UInt16, System.UInt32 and System.UInt64. In particular,Visual Basic .NET 2003 does not support these types (Visual Basic .NET 2005 does).

If you use a development environment does not support these types, convert them to the next more capatious supported type. You can use System.Convert class for this.

Use the opposite conversion for adding values to metadata.

Using Arrays and Structures

Note that ImageGear does not use a separate data storage for the Simplified Metadata API. Instead, it uses the General Metadata storage engine. Simplified API classes only provide easy access to the data stored in the General metadata tree. As a result, there are a few points you may consider.

Each time you access an array or a structure in the Simplified Metadata API, ImageGear returns a new instance of array or structure, with all corresponding data copied into it. In order to keep good performance, it is better to assign the array to a local variable, and then access its values, rather than access the array property from the metadata for retrieving each value:

C#
// Access array property once - good performance
ImGearXMPBag<ImGearXMPString> Subject = igPage.Metadata.XMP.DublinCore.Subject;
if (Subject != null)
{
    for (int i = 0; i < Subject.Count; i++)
        Debug.WriteLine(Subject[i].Value);
}
// Access array property multiple times - array is
// created and copied each time a value is accessed (poor performance)
if (igPage.Metadata.XMP.DublinCore.Subject != null)
{
    for (int i = 0; i < Subject.Count; i++)
        Debug.WriteLine(igPage.Metadata.XMP.DublinCore.Subject[i].Value);
}

VB.NET:
' Access array property once - good performance
Dim Subject As ImGearXMPBag(Of ImGearXMPString) = igPage.Metadata.XMP.DublinCore.Subject
If Subject IsNot Nothing Then
    For i As Integer = 0 To Subject.Count - 1
        Debug.WriteLine(Subject(i).Value)
    Next
End If
' Access array property multiple times - array is
' created and copied each time a value is accessed (poor performance)
If igPage.Metadata.XMP.DublinCore.Subject IsNot Nothing Then
    For i As Integer = 0 To Subject.Count - 1
        Debug.WriteLine(igPage.Metadata.XMP.DublinCore.Subject(i).Value)
    Next
End If

In order to set an array or structure type property, create a new array (structure), set its values as needed, and then assign this array (structure) to the corresponding property of the Simplified API. Changing values of an array or structure which has already been set will not have any effect.

C#
// Incorrect: The array will remain empty
igPage.Metadata.XMP.DublinCore.Subject = new ImGearXMPBag<ImGearXMPString>();
igPage.Metadata.XMP.DublinCore.Subject.Add(new ImGearXMPString("Subject1"));
igPage.Metadata.XMP.DublinCore.Subject.Add(new ImGearXMPString("Subject2"));
// Correct: The array will contain the 2 strings
ImGearXMPBag<ImGearXMPString> Subject = new ImGearXMPBag<ImGearXMPString>();
Subject.Add(new ImGearXMPString("Subject1"));
Subject.Add(new ImGearXMPString("Subject2"));
igPage.Metadata.XMP.DublinCore.Subject = Subject;

VB.NET:
' Incorrect: The array will remain empty
igPage.Metadata.XMP.DublinCore.Subject = New ImGearXMPBag(Of ImGearXMPString)()
igPage.Metadata.XMP.DublinCore.Subject.Add(New ImGearXMPString("Subject1"))
igPage.Metadata.XMP.DublinCore.Subject.Add(New ImGearXMPString("Subject2"))
' Correct: The array will contain the 2 strings
Dim Subject As New ImGearXMPBag(Of ImGearXMPString)()
Subject.Add(New ImGearXMPString("Subject1"))
Subject.Add(New ImGearXMPString("Subject2"))
igPage.Metadata.XMP.DublinCore.Subject = Subject


Warnings and Errors

The common language runtime provides an exception handling model that is based on the representation of exceptions as objects.

ImageGear for .NET natively supports the functionality of the new platform and reports errors by throwing an exception containing specific information about the error. It is important to note that not only ImageGear for .NET exceptions can be thrown from its classes - system or currently executing application exceptions may be thrown as well.

ImageGear defines the ImGearException Class to represent errors during execution of its code. Although this class doesn't have any public constructor, the ThrowError() member may be used to report a problem with an appropriate identifier listed in ImGearErrorCodes Enumeration.

The ImGearException Class is used to report critical errors (i.e., when incorrect parameters are specified or internal errors occurr). However, to report minor and non-critical mistakes (i.e., an inconsistency of the metadata or image attributes in ImGearPage Class entered into the SavePage Method of the ImGearFileFormats Class), the toolkit uses yet another class - ImGearAddWarning Delegate. To use this functionality, the developer should register a defined delegate to receive information about errors at this level.


Using ImageGear.ART Namespace

Using the ImageGear.ART Namespace, you can annotate any image that your application loads into ImageGear. The annotations are called "ART marks", or "marks" for short. Marks objects are created using their constructors, but their actual life starts when they are added into the ImGearARTPage Class. ART page can be associated with one or more ImGearPage Class objects. The association is done by using ImGearPageDisplay Class properties: Page Property and ARTPage Property. ART internally tracks the marks that are associated with the image and insures that marks are always displayed on the correct part of the image (even as the image is scrolled, rotated, flipped and zoomed). Your application can save an image with the marks into a separate file in legacy .ART file format or .XML file format. Anytime the image is reloaded, the ART marks can be reloaded with a simple function-call.

ImageGear.ART Namespace consists of the marks objects as well as the objects for handling marks.

ImageGear.ART.Forms Namespace consists of the GUI objects for interacting with marks and toolbars and marks property dialogs.

To enable the ImageGear.ART Namespace in your project, specify the following directive:

using ImageGear.ART;

To enable the ImageGear.ART.Forms Namespace in your project, specify the following directive:

using ImageGear.ART.Forms;


Annotation and Redlining

ImageGear ART helps developers to add redlining and annotation capabilities to any application built with ImageGear. If you have an application that can read, display, and print images, with ImageGear.ART Namespace enabled you can add marking capabilities, such as lines, arrows, highlighting, and sticky notes to documents images, and use them as though you were working on printed sheets of paper.

The fundamental "unit" of annotation is called an "ART Mark", or "mark" for short (the original name of ImageGear ART was the "Annotation and Redlining Toolkit"). When the end-user uses your application to annotate an image, (s)he is creating marks. Each mark is defined by some geometry ((x,y) position on the image, height and width, etc.), and (for some marks) textual information (a text string, a date, etc.). While the rest of ImageGear typically works with raster (pixel-based) images, ImageGear ART marks are vector objects - they can be moved, resized and deleted.

While the marks are vector objects, they typically are intended to be related to some part of the raster image. For example, one of the marks is a digital version of a "PostIt" note (called an "Attach A Note" mark):

If the user scrolls or zooms the image, it's critical that the mark scrolls or zooms with the image - so that it always appears over the same part of the image. ImageGear ART works in conjunction with ImGearPageDisplay Class to make sure that this happens.

ImageGear ART provides ART Forms (GUI) tool that the end-user works with to create and edit the marks. Enabling the ART Forms tool makes adding annotation/redlining capabilities to your application basically trivial.

Once the end-user has created marks for a given image, they need to be saved. ART marks can be saved in any of 4 ways:

  • Save the annotations in a separate .ART or .XML file.
  • "Burn in" the annotations permanently (making them part of the image file).
  • Save the annotations in the image format that supports storing annotations (for example TIFF files).
  • You may also combine these methods. You can, for example, leave classified information in an ART file and "burn in" non-classified information into the image.

The various marks that can be created with ImageGear ART are described in the following table. Please refer to the ImageGear.ART Namespace for complete descriptions of the ImageGear ART namespace methods.

ART 3.0/ART 2.0 Mark
Example
Text

Line

Freehand Polyline

Rectangle

Ellipse

Polygon

Polyline

Audio (a WAV file on disk is read, and the sound played when the user clicks in the mark)

Image (your application provides the image used - the one shown here is the one used in the sample program)

Ruler (automatically labels the line according to the units defined in the image-file header).

Protractor

Encryption (visually looks like a filled rectangle). When user clicks on the rectangle, an event is raised allowing to request a password. If password matches the one in the mark, then application can make the mark transparent, which displays the image)

Button (when user clicks on the button, an event is raised allowing to take action)

Hotspot (when end-user clicks in shaded area, an event is raised to which your application can respond)

Rich Text

ART 2.0 Mark
Example
Arrow

Filled Rectangle

Hollow Rectangle

Filled Ellipse

Hollow Ellipse

Filled Polygon

Hollow Polygon

Redaction (looks just like a filled rectangle, but cannot be moved after the marks are written to a file)

Hightlighter Rectangle

Typed Text

Text Stamp (automatically set to date and/or time the mark was created)

Attach A Note

Text From File (a text file on disk is read, and the text displayed in the mark)

Pin-up Text (when user clicks on the pushpin, an event is raised allowing the application to display additional text).

Embedded Image (your application provides the image used - the one shown here is the one used in the sample program)

Image Reference (an image file on disk is read, and the image in the file is displayed for the mark - the one shown here is just a sample)


Creating, Saving, Loading, Modifying, and Deleting ART Marks

Creating a Mark via the ToolBar

End users can create a mark using the ART toolbar, or your application can create them directly by calling ART functions. This section describes how to create marks with user interaction through the ART toolbar.

When a button is selected from the toolbar, ART goes into "edit mode", where the mouse is used to place and size the mark. The sequence of events depends on whether the mark is one of the types that contains text or not:

Mark does not contain text:

  • User drags a rectangle on the image
  • Mark is placed and sized on the image, and is selected.
  • Control returns to the application.

Mark contains text:

  • User drags a rectangle on the image
  • Mark is placed and sized on the image, and is placed in text-edit mode.
  • Blinking "I-Beam" insertion point is placed in the mark.
  • User types text into the mark, as desired.
  • User clicks the mouse-button. Mark goes from text-edit mode to selected.
  • Control returns to the application

Note that ART ToolBar event handlers are implemented in the ART Forms open source code and can be modified at any time and any way, but in order for them to work your application need to interact with the following events:

C#
private void imGearPageView_MouseDown(object sender, System.Windows.Forms.MouseEventArgs e)
{
    igARTForms.MouseDown(sender, e);
}
private void imGearPageView_MouseMove(object sender, System.Windows.Forms.MouseEventArgs e)
{
    igARTForms.MouseMove(sender, e);
}
private void imGearPageView_MouseUp(object sender, System.Windows.Forms.MouseEventArgs e)
{
    igARTForms.MouseUp(sender, e);
}

Creating a Mark via Function Calls

Some applications won't use the ART ToolBar, or will provide the ToolBar and other options, for creating marks. In that case, some function in your application will need to create the marks directly. ART marks are created by using their constructors. For example rectangle can be created as follows:

C#
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(255, 0, 0);
ImGearRectangle igRectangle = new ImGearRectangle(0, 0, 100, 100);
ImGearARTRectangle igARTRectangle = new ImGearARTRectangle(igRectangle, igRGBQuad);

Once it is created it should be added to the ART page:

C#
int markID;
markID = igARTPage.AddMark(igARTRectangle, ImGearARTCoordinatesType.IMAGE_COORD);

Mark properties can be edited at any time:

C#
// Get the mark we just added.
igARTRectangle = (ImGearARTRectangle)igARTPage.MarkGet(markID);
igARTRectangle.Opacity = 128;

Saving ART Marks

Once the end-user of your application has created some marks, they're probably going to want to save them somewhere. Your application has 5 choices of where to save them:

  • Save them to a separate .ART file. This is a legacy ART storage format supported in the previous versions of ImageGear ART. Using this method, your application will have to keep track of which .ART file goes with which image file, and load them together. Use ImGearART Class.SavePage Method with ImGearARTSaveType Enumeration.LEGACY parameter to do this.
  • Save them to a separate .XML file. This is a more flexible and extendable storage format highly recommended for using. Using this method, your application will have to keep track of which .XML file goes with which image file, and load them together. Use ImGearART Class.SavePage Method with ImGearARTSaveType Enumeration.XML parameter to do this.
  • Save the art marks as tags or objects inside the image file. This option is only available for the raster file formats that support storing annotations, like TIFF files. Use ImGearART Class.SavePage Method that takes ImGearPage Class to do this.
  • Save the art marks as annotations inside the PDF file. This option is only available for PDF format. Use ImGearART Class.SavePage Method that takes ImGearPage Class to do this.
  • "Burn In" the ART marks. This converts the ART marks from their native representation to the format of the raster image file, which usually destroys a lot of their functionality (for instance, once a mark is burned in to a JPEG image, it cannot be moved, resized or hidden). Use ImGearART Class.BurnIn Method to do this.
NOTE: .ART files can be read by any other application developed with ImageGear. In addition, the .ART file format is supported by the Imaging for Windows application (from Kodak) supplied with Windows.

Loading ART Marks

Once ART marks have been saved, they can be reloaded (by the same user or a different user, using the same program or using any other ImageGear-enabled application). The way that the marks were saved will determine how they must be reloaded:

  • .ART / .XML / image file / PDF file: Your application loads the image using any of the ImGearFileFormats Class Loadxxx methods and then loads ART page using the appropriate ImGearART Class.LoadPage Method.
  • Burned In: Your application loads the image using any of the ImGearFileFormats Class Loadxxx methods. The burned-in remains of the marks are loaded as part of the image.

Edit Mode, Run Mode, and View Mode

ART GUI can interact in one of three modes:

  • Edit mode lets users create or edit marks.
  • Run mode lets users operate on Encryption, Image Embedded, Audio, and Button activities.
  • View-only mode allows users to view marks--not add or modify them.

Your application can switch the mode from one to another by simply setting ImGearARTForms Class.Mode Property.

While you are in in View mode, your application will not have to deal with any ART-related events: it simply loads the image and ART marks and displays them.

If your application switches to Run mode, then it will have to start dealing with specific ART-related events via ImGearARTRunProcessor. For example, for an Encryption mark, when the image and ART marks are first loaded and displayed, the Encryption mark will obscure some or all of the image. When the user moves the cursor over the mark, the cursor will change to pointing hand cursor. ART Forms event handler will display a dialog box asking for the password to enable viewing of that portion of the image, and then (if the user gets the password right), unobscure the image.

If your application switches to Edit mode, then it will have to start dealing with specific ART-related events via ImGearARTEditProcessor.

Modifying Marks

As long as you are in Edit mode, marks can be modified. There are two ways to modify marks:

  • The first is to use ART Forms property dialogs.
  • The second is to use mark objects' properties and methods.

Geometric changes (like moving and resizing) are done automatically, as a result of ART Forms implementation, as shown in Creating a Mark via the ToolBar. To make other changes to a mark, your application makes a simple call to the mark's properties and methods.

The technique for modifying marks via function call is used in the ART Forms dialogs code. The marks attributes can be modified by changing their properties and using their methods.

Deleting Marks

Marks are deleted by using ImGearARTPage Class.MarkRemove Method or RemoveMarks Method methods.


Operating with ART Marks

Clipboard Operations

ART marks can be cut from and copied to the clipboard as well as and pasted into an image individually or in groups. The ImGearARTPage Class object provides the methods to perform clipboard operations.

Iterating Through Marks

Sometimes, your application will need to iterate through the marks in an ImGearARTPage Class object. This can be done by using "foreach" mechanism:

For example, to delete all the selected marks, your application would do the following:

C#
// Build a list of selected marks.
ArrayList igARTMarks = new ArrayList();
foreach (ImGearARTMark igARTMark in igARTForms.Page)
{
    if (igARTForms.Page.MarkIsSelected(igARTMark))
        igARTMarks.Add(igARTMark);
}
// Delete the marks.
igARTForms.Page.RemoveMarks(igARTMarks);
// Redraw the view.
imGearPageView1.Invalidate();

Mark Groups

ImGearARTPage Class provides a facility called "mark groups" (or just "groups", for short) that provides a powerful mechanism for implementing application features. Every mark belongs to one and only one group; by default all marks belong to a group with index 0 and named "[Untitled]". Your application can create as many groups as needed - each group is simply given a unique index. ImGearARTPage Class provides a set of methods that manipulate all of the marks in a group (hide them all, make them all visible, etc.). Your application could use groups to provide annotation layers (each "layer" would simply be a group), so that the user could choose which layer, and thus which set of annotations, to view. Alternatively, your application could use groups to provide private annotations (each person would only be able to see "their" annotations).

The various methods that operate on groups are provided by ImGearARTGroup Class and ImGearARTGroupArray Class objects.

Event Handling

Event handlers are implemented in the ART Forms open source code and can be modified at any time and in any way. To enable ART Forms event handlers your application need to interact with the ART Forms methods:

  • MouseDown
  • MouseMove
  • MouseUp


ART 2.0 and ART 3.0 Marks

This section describes two sets of marks available in ImageGear ART namespace:

  • ART 3.0/ART 2.0 Marks
  • ART 2.0 Legacy Marks

ART 3.0 set consists of the enhanced list of more flexible marks. These marks are recommended for new applications. The ART 2.0 (Legacy) set consists of the marks backward compatible with the previous ART versions.

Only ART 2.0 marks can be loaded from the .ART files created with previous ART versions, and only ART 2.0 marks can be saved into the legacy ART storage format.

Both ART 2.0 and 3.0 marks can be saved into the XML storage format, please note however that ART 2.0 marks will be converted to the appropriate ART 3.0 super class marks. Only ART 3.0 marks are loaded from the XML storage format.

NOTE: Some ART marks, such as Attach-a-Note, Text Stamp may require Wang compatibility mode enabled to be saved properly in legacy storage format. On the contrary the Highlighter mark should be saved in legacy format without Wang compatibility mode on.

ART 3.0/ART 2.0 Marks

Text

The Text mark enables the end user to add descriptive text to their annotated image or document. The text can be created in various fonts, sizes, colors and opacity. It can be with or without border, fill color and pin icon. The text appears over the original image or document.

Edit mode: End users create this mark by clicking the Text button with the left mouse button and then dragging the resulting rectangle over the area to be annotated. This rectangle helps to position the Text annotations. Text annotations are easily modified when the application is in the Edit mode. To modify it, the end user double-clicks the left mouse button when the cursor is over the text mark. The cursor appears at the beginning of the text, and transforms to allow editing.

Line

The Line mark enables the end user to create straight lines on an image or document.

Edit Mode: To create this mark, end users:

  1. Click on the Line button with the left mouse button.
  2. Click on the left mouse button at the point where the line shoud begin.
  3. While holding the left mouse button down, drag the line to the point at which the line should end.
  4. Release the left mouse button to complete the line.
  5. Press the right mouse button after the mark is created to activate the popup Edit menu.

Freehand Polyline

The Freehand Polyline mark enables the end user to use freehand drawing for annotation. With this mark, end users create drawings as though they are using a pen and paper.

Edit Mode: In Edit mode, end users create this mark by clicking the Freehand Polyline button with the left mouse button, dragging the image, and then releasing the left mouse button. Pressing the right mouse button after the mark is created activates the popup edit menu.

Rectangle

The Rectangle mark enables end users to cover areas of an image or document with a rectangle. The Rectangle can be with or without border and filled color. It can have a different opacity level.

Edit Mode: In Edit mode, end users create this mark by clicking the Rectangle button with the left mouse button and then dragging the resulting rectangle over the items to be covered. Pressing the right mouse button after the mark is created activates the popup edit menu.

Ellipse

The Ellipse mark enables end users to cover areas of an image or document with an ellipse. The Ellipse can be with or without border and filled color. It can have a different opacity level.

Edit Mode: In Edit mode, end users create this mark by clicking the Ellipse button with the left mouse button and then dragging the resulting ellipse over the items to be covered. Pressing the right mouse button after the mark is created activates the popup edit menu.

Polygon

The Polygon mark enables the end user to cover areas of an image or document with a polygon.

Edit Mode: To create a Polygon mark, end users:

  1. Click the left mouse button at the point where the polygon starts.
  2. Drag the mouse to the location of a vertice and click the left mouse button.
  3. Repeat step 2 to add the desired number of vertices to the polygon, clicking the left mouse button to add a vertice.
  4. Double-click the left mouse button to complete the polygon.
  5. Press the right mouse button after the mark is created to activate the popup Edit menu.

Polyline

The Polyline mark enables the end user to create several connected straight lines by dragging and clicking the mouse.

Edit Mode: To create a Polyline mark in an application, end users:

  1. Click the left mouse button at the point where the polyline starts.
  2. Drag the left mouse button to the location of a vertice.
  3. Drag and click the left mouse button to create each additional vertice.
  4. Move the cursor to the location where the polyline ends.
  5. Double-click the left mouse button.

Pressing the right mouse button after the mark is created activates the popup Edit menu.

Audio

The Audio mark enables end users to hear sounds when annotating an image or document. It is useful for drawing attention to a particular area of a text or image file. This mark plays a waveform audio file (.WAV).

Edit Mode: In Edit mode, end users create this mark by clicking on the Audio button with the left mouse button and then dragging the mark (a loud-speaker-shaped bitmap) to its destination. To display the dialog box, the user double-clicks the left mouse button on the loud-speaker. This allows the user to specify the name of the .WAV file that plays during Run mode.

When the application is in the Run mode, the cursor changes to a pointing hand when it passes over the loud-speaker bitmap. As the mark is activated (makes a sound), lines representing sound waves appear and disappear from the end of the loud-speaker.

Image

The Image mark enables the end user to embed or file reference a bitmap or a vector image in a document or image.

Edit Mode: In Edit mode, end users create a mark by clicking the Image button with the left mouse button, dragging the image, and then releasing the left mouse button. When the left mouse button is released, the image becomes embedded. Once the bitmap or the vector image is in place on the annotation window, it can be re-sized by using the left mouse button. Right-clicking the mark activates the popup edit menu.

To create an Image mark, do the following:

  1. Click the Image button.
  2. Drag the image to the desired location and release the left mouse button. When the left mouse button is released, the image becomes embedded.
  3. Re-size the bitmap or vector image by clicking the left-mouse button and dragging the image to the desired size.
  4. Right-click the mark to activate the popup Edit menu.

Run Mode: In Run mode, end users interact with a vector Image mark by clicking over the mark and using the popup 3D toolbar. End users can rotate, scale, and move 3D data, as well as change lights and view settings.

To work with the image, do the following:

  1. Click on the image mark and use items from the popup 3D toolbar.
  2. Using the toolbar, end users can rotate, scale and move 3D data, as well as change light and view settings.

Ruler

The Ruler mark enables the end user to create a line that displays its measurement.

Edit Mode: To create a measured line, the end users:

  1. Click on the Ruler button.
  2. Click the left mouse button where the end of the line begins and drag it to the end of the line.
  3. Release the left mouse button to complete the line.
  4. Press the right mouse button to activate the popup Edit menu.

Protractor

The Protractor mark enables the end user to create an angle that displays the arc and the angle measurement.

Edit Mode: To create a measured angle, end users:

  1. Click the Protractor button.
  2. Drag the mouse to create the first line of the angle.
  3. Click the left mouse button to end the first line. This click creates the vertex and begins the second line.
  4. Click the left mouse button where you want your second line to end. The measured angle is complete.
  5. Press the right mouse button after the mark is created to activate the popup Edit menu.

Encryption

The Encryption mark enables your users to scramble all or part of the image.

Edit mode: End users create this mark by clicking the Encryption button with the left mouse button and then dragging the resulting rectangle over the area to be scrambled.

NOTE: Encrypted marks cannot overlap

Button

The Button mark places a programmable button on an image. For example, a button can be programmed to zoom into part of an image.

Edit Mode: In the Edit mode, end users create this mark by clicking on the Button button with the left mouse button and then dragging the resulting mark to its destination. The button can be resized by dragging the resize handles. You can set your application to respond to a right-mouse click by displaying the properties box and selecting the appropriate property. Your user can set several attributes for a button, including font, foreground color, background color and text.

When the application is in Run mode, the cursor changes to a pointing hand when it passes over the Button bitmap.

Curve

The Curve mark enables the end user to use spline curve drawings. With this mark, end users create spline curves between the specified points and using the specified tension.

Edit Mode: To create a Curve mark in an application, end users:

  1. Click the left mouse button at the point where the curve starts.
  2. Drag the left mouse button to the location of a vertice.
  3. Drag and click the left mouse button to create each additional vertice.
  4. Move the cursor to the location where the curve ends.
  5. Double-click the left mouse button.

Hot Spot

The Hot Spot mark enables the end user to define an invisible region in a document or image that can be used to hold hidden messages.

Edit Mode: In Edit mode, end users create this mark by clicking the Hot Spot button with the left mouse button, dragging the image, and then releasing the left mouse button. When the left mouse button is released, the resulting rectangle becomes the hot spot region. It remains visible while the application is in edit mode. Pressing the right mouse button after the mark is created activates the popup edit menu.

Run Mode: When a user passes the cursor over this region, the cursor changes, indicating that there is something special about the contents within the invisible region. If the user clicks the left mouse button while the cursor is in the region, your application sends a message detailing the information about the contents of the region.

NOTE: The Hot Spot region is visible only when the application is in Edit mode.

Rich Text

The Rich Text mark enables end users to edit, load, and display RTF text.

Edit mode: In Edit mode, end users create this mark by clicking the Rich Text button with the left mouse button and then dragging the resulting rectangle over the area to be annotated. The RTF Editor Tool allows users to load RTF files and edit the RTF text using the menu and toolbar buttons.

ART 2.0 Legacy Marks

Arrow

The Arrow mark enables the end user to create an arrow over an image or document. It allows users to point to areas of a document that may be of interest to its reader.

Edit Mode: Users of the completed application can create this mark by clicking the Arrow button with the left mouse button, dragging the image, and then releasing. The head of the arrow is drawn at the point where the left mouse button is first pushed, and the tail (end) of the arrow is set at the location where the left mouse button is released. Pressing the right mouse button after the mark is created activates the popup edit menu.

Filled Rectangle

The Filled Rectangle mark enables end users to cover areas of an image or document with a rectangle.

Edit Mode: In Edit mode, end users create this mark by clicking the Filled Rectangle button with the left mouse button and then dragging the resulting rectangle over the items to be covered. Pressing the right mouse button after the mark is created activates the popup edit menu.

Hollow Rectangle

The Hollow Rectangle mark enables users to surround areas of an image or document with a hollow rectangle.

Edit Mode: In Edit mode, end users of your application create this mark by clicking the Hollow Rectangle button with the left mouse button and then dragging the resulting rectangle over the items to be surrounded. Pressing the right mouse button after the mark is created activates the popup edit menu.

Filled Ellipse

The Filled Ellipse mark enables end users to cover areas of an image or document with an ellipse.

Edit Mode: In the edit mode, end users create this mark by clicking the Filled Ellipse button with the left mouse button, dragging the image, and then releasing the left mouse button. Pressing the right mouse button after the mark is created activates the popup edit menu.

Hollow Ellipse

The Hollow Ellipse mark enables the end user to create a hollow ellipse to surround important areas.

Edit Mode: In Edit mode, end users of the completed application create this mark by clicking the Hollow Ellipse button with the left mouse button, dragging the image, and then releasing the left mouse button. Pressing the right mouse button after the mark is created activates the popup edit menu.

Description
A hollow ellipse whose boundaries are defined by a rectangle. Two points define the rectangle, an upper left point and a bottom right point.
Attr Properties
AttrBounds, AttrForeColor, AttrHighlight, AttrLineSize

Filled Polygon

The Filled Polygon mark enables the end user to cover areas of an image or document with a polygon.

Edit Mode: To create a Filled Polygon mark, end users:

  1. Click the left mouse button at the point where the polygon starts.
  2. Drag the mouse to the location of a vertice and click the left mouse button.
  3. Repeat step 2 to add the desired number of vertices to the polygon, clicking the left mouse button to add a vertice.
  4. Double-click the left mouse button to complete the polygon.
  5. Press the right mouse button after the mark is created to activate the popup Edit menu.

Hollow Polygon

The Hollow Polygon mark enables the end user to surround areas of an image or document with a polygon.

Edit Mode: To create a Hollow Polygon mark, end users:

  1. Click the left mouse button at the point where the polygon starts.
  2. Drag and click the left mouse button to create each vertice you want to add.
  3. Double-click the left mouse button to complete the polygon.
  4. Press the right mouse button after the mark is created to activate the popup edit menu.

Redaction

The Redaction mark enables end users to hide or black out areas of their annotated image or document.

Edit Mode: In Edit mode, end users create this mark by clicking the Redaction button with the left mouse button and then dragging the resulting rectangle over the items they wish to cover. The rectangle covers whatever is underneath it. Pressing the right mouse button after the mark is created activates the popup Edit menu.

Highlighter

The Highlighter mark enables end users to highlight areas of their annotated image or document.

Edit Mode: In Edit mode, end users:

  1. Create this mark by clicking the Highlighter button with the left mouse button and then dragging the resulting rectangle over the items they wish to cover.
  2. The resulting rectangle highlights whatever is underneath it.
  3. Pressing the right mouse button after the mark is created user activates the popup Edit menu.

Typed Text

The Typed Text mark enables the end user to add descriptive text to their annotated image or document. The text can be created in various fonts, sizes, colors. The text appears over the original image or document.

Edit mode: End users create this mark by clicking the Typed Text button with the left mouse button and then dragging the resulting rectangle over the area to be annotated. This rectangle helps to position the Text annotations. Text annotations are easily modified when the application is in the Edit mode. To modify it, the end user double-clicks the left mouse button when the cursor is over the text mark. The cursor appears at the beginning of the text, and transforms to allow editing.

NOTE: If end users create a text mark without any text with a Transparent background, the resulting mark will exist but will not be visible.

Text Stamp

The Text Stamp mark allows the end user to annotate documents and images with text.

Edit Mode: In Edit mode, end users create this mark by clicking on the Text Stamp button with the left mouse button. Pressing the right mouse button after the mark is created activates the popup Edit menu, which allows you to enter the text of the stamp.

Attach-a-Note

The Attach-A-Note mark enables your end users to add notes to their annotated image or document.

Edit Mode: In the edit mode, end users create this mark by clicking the Attach-A-Note button with the left mouse button and then dragging the resulting rectangle over the area to be annotated.

Pressing the right mouse button activates the popup menu that enables users to change the font or the background colors of the note.

The Choose Font option displays a dialog box that allows users to change text properties. If the application is in Edit mode, and an end user wants to modify the text, they simply double-click the left mouse button when the cursor is over the note. The cursor appears at the beginning of the text to allow editing.

The Set Background Color option enables end users to change the color of the note. When this option is selected, a dialog box appears with a range of options.

Text from File

The Text From File mark enables the end user to add descriptive text to an annotated image or document. The text can be created in various fonts, sizes, colors, and even angles of presentation. The text appears to lay over the original image or document.

Edit mode: End users create this mark by clicking the Text From File button with the left mouse button and then dragging the rectangle over the area to be annotated. This rectangle helps to position the Text annotations. Text annotations are modified when the application is in Edit mode. To modify the text, the end user double-clicks the left mouse button when the cursor is over the text mark. The cursor appears at the beginning of the text, and transforms to allow editing.

While creating this mark and entering text, end users use the right mouse button to access a popup menu that enables them to change several attributes of the mark.

  • Choose Fontoption allows users to select the color of the text fonts.
  • Adjust Angle option enables end users to rotate the text mark with a dialog box. The square at the lower left corner of the Adjust Angle dialog box shows the appearance of the text mark with the selected text display angle.
  • Set Background Color option is identical to the one available while creating the Attach-a-Note mark.
  • Set Background Mode option enables end users to change the visibility level of the region within the Text mark. When this option is selected, a dialog box appears.
      • If Transparent is selected, the interior of the text mark is not visible; only the text is visible.
      • If Opaque is selected, end users are not able to see through the interior of the text mark.
      • If Tinted is selected, the text mark resembles a tinted glass. End users are able to see through the mark.
NOTE: If end users create a text mark without any text with a Transparent background, the resulting mark will exist but will not be visible.

Pin Up Text

The Pin Up Text mark enables the user to create a mark that appears to be tacked onto the image with a push pin.

Edit Mode: This mark can have an optional label. The label indicates which data can be obtained by clicking on the pin in while in Run mode. You can add code to the MouseNotify event to display additional data when the push pin is pressed

Image Embedded

The Image Embedded mark enables the end user to embed a bitmap image in a document or image.

Edit Mode: In Edit mode, end users embed an image by clicking the Image Embedded button with the left mouse button, dragging the image, and then releasing the left mouse button. When the left mouse button is released, the image becomes imbedded. Once the bitmap is in place on the annotation window, it can be re-sized by using the left mouse button. Pressing the right mouse button over the mark to activate the popup edit menu.

Image Embedded marks are intended for use with bitmaps that use no more than the standard 20 Windows colors. Therefore, 1-bit and 4-bit bitmaps are allowed. If you try to display an 8-bit bitmap in the mark, it is displayed using only the standard 20 colors.

Image Reference

The Image Reference mark enables the end user to include an image by reference in a document or image.

Edit Mode: In Edit mode, end users reference an image by clicking the Image Reference button with the left mouse button, dragging the image, and then releasing the left mouse button. When the left mouse button is released, an image is displayed. To insert an image, press the right mouse button over the mark to activate the popup Edit menu and choose Properties. Select the image you wish to reference.


PDF Marks

ImageGear ART can convert ART marks to PDF annotations and PDF annotations to ART marks giving the user an ability to edit PDF annotations using the same ImageGear ART Forms GUI.

The following table lists all the ART marks that can be converted to PDF annotations and describes how the marks are being converted:

ART Marks
PDF Annotations
Text
FreeText
Legacy Typed Text
FreeText
Legacy Text Stamp
FreeText
Legacy Text From File
FreeText
Legacy Attach-A-Note
FreeText
Rich Text (RTF)
FreeText
Rectangle
Square
Legacy Filled Rectangle
Square
Legacy Hollow Rectangle
Square
Legacy Redaction
Square
Legacy Highlighter
Square
Ellipse
Circle
Legacy Filled Ellipse
Circle
Legacy Hollow Ellipse
Circle
Image (vector)
3D
Line
Line
Legacy Arrow
Line
Polyline and Freehand Polyline
PolyLine
Polygon
Polygon
Legacy Filled Polygon
Polygon
Legacy Hollow Polygon
Polygon

The following PDF annotations can be converted to ART marks:

PDF Annotations
ART Marks
3D
Image (vector)
FreeText (simple style text)
Text
FreeText (RTF style text)
Rich Text
Line
Line
Square
Rectangle
Circle
Ellipse
PolyLine
Polyline
Polygon
Polygon


Using ImageGear.Display Namespace

The ImageGear.Display Namespace provides functionality for the following areas:

  • Color Anti-Aliasing
  • Re-Sampling


Color Anti-Aliasing

Color anti-aliasing is used to enhance the display of non 1-bit-per-pixel color images. Color anti-aliasing is applicable when an image is zoomed out. Color anti-aliasing attributes can be referenced directly using the ColorAntiAliasing Property of ImGearPageDisplay Class:

imGearPageView.Display.ColorAntiAliasing.Method = ImGearColorAliasModes.NONE


Re-Sampling

Re-sampling is used to enhance image display when it is zoomed in. Re-sampling attributes can be referenced directly using the Resampling Property of ImGearPageDisplay Class:

imGearPageView.Display.Resampling.Method = ImGearResampleModes.BILINEAR


Using ImageGear Digital Camera RAW Formats

  • ImageGear Digital Camera RAW Filter
  • Reconstructing Camera Raw Images with ImageGear Processing API


ImageGear Digital Camera RAW Filter

ImageGear supports reading raw images created by many digital cameras. Support for raw images includes reading of image pixel data, color reconstruction of raw images, and reading of metadata stored with the images.

Loading Raw Images

Load camera raw images in the same way as you load images of all other formats, using one of the image loading methods, such as ImGearFileFormats Class.LoadPage Method. Use control parameters of corresponding format filter to control loading of raw images.

By default, ImageGear attempts to reconstruct the full color image from raw data. You can also load unprocessed or partially processed image and apply some custom processing to it.

Loading of Pixel Data from RAW and DNG Images

Digital cameras store raw images in exactly the same format as obtained from the camera sensor. A number of image processing operations must be performed to reconstruct full color image from the raw data. By All raw format filters and Adobe DNG have the same set of loading options that allows loading unprocessed or partially processed image. Partially processed images can then be processed with the help of ImageGear image processing methods.

Note that camera manufacturers do not publish specifications on their raw formats. ImageGear attempts to reconstruct color images correctly where it is possible. For some cameras not all of the color balance data is available. The application may need to apply additional processing to such images.

The section ImageGear Supported Digital Camera RAW Formats Reference lists the level of support that ImageGear provides for particular cameras.

Headerless Digital Camera Raw Images

A special group of camera raw formats is Headerless Camera Raw formats. The Headerless Digital Camera file filter provides support for Digital Camera Raw images that only contain pixel data and no header.

Due to the absence of a header, such files cannot be detected reliably. ImageGear uses low detection priority for these images, and by default, detection of this filter is disabled. Also, since these files do not contain any metadata describing color reconstruction, ImageGear support level for them is limited to "S2" - pixel decoding only.


Reconstructing Camera Raw Images with ImageGear Processing API

By default, ImageGear reconstructs Camera Raw images automatically, using the settings found in image metadata. However, one of the main benefits of Raw formats is that they can be custom adjusted during conversion to the working RGB color space.

ImageGear provides an API that allows you to specify white balance and tone settings for Raw image reconstruction.

In order to adjust white balance for the image, set ApplyColorspaceConversion option to false (see DCRAW format Control Parameters). Use ImGearCameraRawProcessing Class.CalculateCameraToRGBMatrix Method to calculate a conversion matrix, based on selected white balance and on known conversion matrices obtained from metadata. Use ImGearWhiteBalance Class for preset white balance settings and for converting between color temperature and white point XY values. ApplyColorspaceConversion only has effect if ApplyLowLevelProcessing option is True.

In order to adjust image tone (contrast/brightness curve), set ApplyToneCorrection filter option to False. This will tell ImageGear to skip the tone correction step. The application can create a Tone correction LUT using ImGearCameraRawProcessing Class.BuildToneLUT Method, or build its own Tone LUT. In order to convert the image to the standard sRGB color space, an additional sRGB Gamma LUT must be applied. ApplyToneCorrection only has effect if both ApplyLowLevelProcessing and ApplyColorspaceConversion options are True.


Using ImageGear.Formats.DICOM Namespace

ImageGear.Formats.DICOM Namespace provides features that are used with medical and DICOM images. The following sections discuss various aspects of working with these images.

See Also:

ImageGear.Formats.DICOM Namespace

Displaying Medical Images

Metadata Dictionary

DICOM


Loading and Saving DICOM Images

Load DICOM images in the same way as you load images of other formats. Use DICOM format options to set specific features for image loading.

Save DICOM images in the same way as you save images of other formats. However, there are a few items that need to be discussed about saving DICOM images.

Transfer syntaxes

There are two ways to specify transfer syntax (compression) for DICOM image saving: SaveFormat parameter, and TransferSyntax DICOM format option. SaveFormat is an easy-to-use shortcut, while TransferSytnax option provides the full selection of transfer syntaxes for image saving.

ImGearSavingFormats
ImGearCompressions
Transfer Syntax
DICOM
AUTO
Defined by SaveSyntax option
DICOM_UNCOMP
NONE
ImplicitLittleEndian
DICOM_RLE
RLE
RLE
DICOM_JPEG
JPEG
JPEG Lossy
DICOM_JPEG2K
JPEG2K
JPEG2K Lossy

Saving DICOM Images Using JPEG Compression

ImageGear supports the following modes for saving JPEG compressed DICOM images:

JPEG Lossy Baseline or Extended

This is the default mode for saving DICOM images with JPEG compression in ImageGear. In this mode, depending on the channel depth of the source image, ImageGear saves it as either 8 bits per channel, using "JPEG Baseline (Process 1)" transfer syntax, or as 9..12 bits per channel, using "JPEG Extended (Process 2 & 4)" transfer syntax.

Use one of these ways to save an image as DICOM JPEG Baseline or Extended:

  • Save the image as ImGearSavingFormats Enumeration.DICOM_JPEG (SaveSyntax parameter is ignored)
  • Save the image as ImGearSavingFormats Enumeration.DICOM and set SaveSyntax to ImGearDICOMTransferSyntaxes.JPEG_LOSSY
  • Save the image as ImGearSavingFormats Enumeration.DICOM and set SaveSyntax to ImGearDICOMTransferSyntaxes.JPEG_EXTENDED_PR_2_4

JPEG Lossy Baseline Only

This mode provides compatibility with viewers that do not support JPEG Extended coding process (12-bit images). In this mode ImageGear saves images as 8 bits per channel, using "JPEG Baseline (Process 1)" transfer syntax. If the image has greater bit depth, ImageGear reduces it to 8 bits per channel for saving.

To save an image as DICOM JPEG Baseline, use ImGearSavingFormats.DICOM saving format, and set SaveSyntax to ImGearDICOMTransferSyntaxes.JPEG_BASELINE_PR_1.

JPEG Lossless

In this mode, depending on the channel depth of the source image, ImageGear saves it as 8...16 bits per channel, using "JPEG Lossless, Non-Hierarchical (Process 14)" transfer syntax.

To save an image as DICOM JPEG Lossless, use ImGearSavingFormats.DICOM saving format, and set SaveSyntax to ImGearDICOMTransferSyntaxes.JPEG_LOSSLESS or ImGearDICOMTransferSyntaxes.JPEG_LOSSLESS_NONH_PR_14.

Saving Non-DICOM Images to DICOM Format

ImageGear for .NET allows saving of non-DICOM images to DICOM format. A default Secondary Capture DataSet is created for such images.

Saving Multiframe Images

DICOM format is not designed for an easy insertion of pages. The following issues exist:

  • Pages are stored consequently rather than in arbitrary order. If image is compressed, replacing a page requires rewriting all consequent pages.
  • "Number of pages" tag is stored as "Integer string". If, for example, tag is equal to "99", adding a page requires to increase length of this tag, and thus requires rewriting of the whole image.
  • All pages in the file must have the same dimensions and compression.
  • Some DICOM modalities support multiframe images, while others don't.

According to the above issues, DICOM format filter in ImageGear for .NET has the following limitations:

  • Only APPEND and OVERWRITE saving modes are supported.
  • ImageGear for .NET allows apending a page to a DICOM file only if the file already has "Number Of Pages" tag, and this tag has maximum possible length for an Integer String: 12 bytes.
  • Page being saved must have the same dimensions and compression as existing pages in the file .
  • ImageGear does not check if image's modality allows multipage images.

If any of the limitations is met, ImageGear throws an exception.

To save a multipage image:

  1. Load an image to ImageGear for .NET.
  2. Save image to a new file (or use OVERWRITE mode).
  3. Load next image to ImageGear for .NET.
  4. Save image to existing file, using APPEND mode.
  5. Repeat steps 3 and 4 for all pages to be written.

Alternatively, create an ImGearDocument Class and save to DICOM using SaveDocument Method function.


Overlays

Use ImGearDICOM.LoadOverlay Method() to load graphic overlays from DICOM DataSet to ART annotations. Use ImGearDICOM.SaveOverlay Method() save ART annotations into DICOM DataSet as overlay data.


DICOM Metadata Support

ImageGear for .NET uses its general metadata engine for all file formats, including DICOM. When ImageGear loads a DICOM image, it builds a metadata tree structure and attached it to the new ImGearPage Class object. Use ImageGear for .NET Metadata support classes to access data items in this tree.

A DICOM file includes one header with metadata, and zero, one or multiple images. Metadata applies to all images in the file. ImageGear for .NET loads a copy of DICOM metadata into every loaded page. DICOM Document metadata is empty.

See DICOM section in the ImageGear Imaging Formats Reference chapter for the info about the detailed structure of the DICOM Metadata tree.

DICOM tags map to ImageGear metadata tags as follows:

Tag group number, element number
ImGearMetadataNode Class.Tag Property
Value Representation
ImGearMetadataLeaf Class.NativeType Field
Value Length
Not stored explicitly. Application can use string and array lengths instead
Value Multiplicity ( Item count)
Not stored explicitly. For values of OB/OW/OF it is always 1. For other Value Representations, if data is singular it is 1, otherwise it is equal to the length of the data array.
Data
ImGearMetadataLeaf Class.Data Property

"Sequence" (SQ) tags are represented by nested metadata trees. SQ contains one or more Sequence Items, and can't contain normal DICOM tags. Sequence Item contains a set of DICOM tags.

The following tags are read from the file, but not added to the metadata tree:

  • Group lengths
  • Sequence Delimination items
  • Item delimination items

The following table lists the mapping between DICOM Value Representations and .NET system types:

VR
Meaning
System type to which it converts on reading
Allowed system types on writing
AE
Application Entity
String
String
AS
Age String
String
String
AT
Attribute Tag
String
String
CS
Code String
String
String
DA
Date
String
String
DS
Decimal String
double
all numeric types, String
DT
Date Time
String
String
FL
Floating Point Single
float
all numeric types, String
FD
Floating Point Double
double
all numeric types, String
IS
Integer String
long (64-bit)
all integer types, String
LO
Long String
String
String
LT
Long Text
String
String
OB
Other Byte String
byte[]
byte[]
OW
Other Word String
ushort[]
ushort[]
PN
Person Name
String
String
SH
Short String
String
String
SL
Signed Long
int
all integer types, String
SQ
Sequence
-
-
SS
Signed Short
short
all integer types, String
ST
Short Text
String
String
TM
Time
String
String
UI
Unique Identifier
String
String
UL
Unsigned Long
uint
all integer types, String
UN
Unknown
byte[]
byte[]
US
Unsigned Short
ushort
all integer types, String
UT
Unlimited Text
String
String
OF
Other Float String
float[]
float[], double[]

For types other than OB, OW and OF, if the system type is an array, a multivalued data element is saved.

Example of conversion on metadata reading:

VR
tag value
Metadata leaf data type
Metadata leaf value
US
0x0001
ushort
1
OW
0x0001 0x0002 0x0003
ushort[]
{1, 2, 3}
DS
"0.12345\0.6789"
double[]
{0.12345, 0.6789}
CS
"MR"
string
"MR"
CS
"ORIGINAL\PRIMARY"
string[]
{"ORIGINAL", "PRIMARY"}


Presentation State

Presentation State (PS) objects serve for the following purposes:

  • Consistent display of images on various devices and media
  • Storage of specific settings for display (contrast transformations, geometric transformations)
  • Storage of annotations
  • Special display of multiframe images

Presentation State objects do not include actual images, but reference one or more images.

Presentation State objects, in addition to LUTs, display parameters and annotations, contain other tags, such as Patient/Study/Series info, Referenced Image UIDs, etc. ImageGear loads all tags from Presentation State object into a metadata tree, which is available to the application.

Consistent Display of Images

DICOM standard introduces the Standardized Display System. A Standardized Display System may be a printer, a monitor or some other display device which has been calibrated according to the Grayscale Standard Display Function. The main feature of such display system is that throughout its display range, equal differences in digital input values correspond to visually equal differences in luminosity. Two Standardized Display Systems will always show the same detail in an image, even if their physical characteristics are different.

The values that can be used as input to a Standardized Display System are called "Presentation Values" ("P-Values"). To map image pixel intensities into P-Values, Presentation Look Up Table ("P-LUT") is used. It is applied after Modality and VOI LUTs.

Presentation LUT is stored in a Presentation State DataSet.

If a display device is not physically calibrated to comply with the Standard Display Function, but its characteristic curve (a table that lists luminosities for each digital input value) is known, it can be calibrated at the software level. In that case, P-Values shall be used as input to a Standard Display LUT, which will map them to the device's input values according to Standard Display Function. Thus, a non-standardized device together with its Standard Display LUT can be considered as Standardized Display System.

ImageGear Medical namespace allows you to build a Standard Display LUT from a device's Characteristic Curve.

ImageGear uses all available LUTs (Modality LUT, VOI LUT, Presentation LUT and Standard Display LUT), to build the Summary LUT that maps image pixel values into display input values.

Presentation LUT and Standard Display LUT, as well as Modality and VOI LUTs are stored in the ImGearDICOMDisplaySettings Class. It can be attached to any ImGearRasterPage Class.

Grayscale Contrast Transformations

Presentation State DataSet may include VOI and Modality LUTs. Their usage is the same as in normal DICOM images. When a Presentation State is applied to an image, its LUTs override the LUTs found in the image.

Geometric Transformations

Presentation State DataSet may include Rectangle of Interest, scale mode (True size, Scale to Fit, Magnify), and orientation (Rotate, Flip).

Annotations

Annotation objects include: Textbox, Point, Polyline, Spline, Circle, Ellipse. Graphical objects can be filled or not filled. Annotations can be grouped into layers.

uses ART marks to represent DICOM annotation objects. When a Presentation State DataSet is applied to an image, ImageGear creates ART marks for each of the annotation objects. These marks can then be edited with the ART API methods.

DICOM Graphic Annotation objects can be grouped into Layers. All objects on the same layer have the same color (recommended grayscale value). ImageGear uses ART mark groups to represent layers.

Use PreparePresStateMetadata Method to prepare presentation state metadata from image's display settings and annotation marks. This metadata can be saved as a presentation state object file.

When preparing presentation state from ImGearPage Class that has ART marks attached to it, ART marks are converted to DICOM Graphic Annotation objects or Text Annotation objects. The table below lists ART marks that can be converted, corresponding DICOM Graphic Annotation objects, and properties that Graphic Annotation objects support. Marks that are not listed in this table are ignored.

ImGearARTMarkType
value
DICOM Graphic Annotation Object
Supported properties
POINT
POINT
Point coordinates
POLYLINE
POLYLINE
Node coordinates, "Filled" property
POLYGON
POLYLINE
Node coordinates, "Filled" property
FILLED_POLYGON
POLYLINE
Node coordinates, "Filled" property
CURVE
INTERPOLATED
Node coordinates, "Filled" property
ELLIPSE
ELLIPSE
Bounds coordinates, "Filled" property
FILLED_ELLIPSE
ELLIPSE
Bounds coordinates, "Filled" property
HOLLOW_ELLIPSE
ELLIPSE
Bounds coordinates, "Filled" property

The following ART marks are saved as DICOM Text Annotation objects:

ImGearARTMarkType
Supported properties
TEXT
Text, bounds coordinates, anchor point coordinates, anchor point visibility
TYPED_TEXT
Text, bounds coordinates
CALLOUT
Text, bounds coordinates, anchor point coordinates, anchor point visibility

Graphic Annotation objects do not have a color property. Instead, Graphic Layer has "Recommended Display Grayscale Value" property. ImageGear converts the color of the first mark in the ART group to grayscale and uses this value to initialize the "Recommended Display Grayscale Value" property of the layer.

Working with Presentation State Objects

Loading and Applying Presentation State Objects

Use ImGearDICOM Class.LoadPresState Method to load a Presentation State object and apply it to an image.

Extracting and Saving Presentation State Objects

Use these steps to extract and save a presentation state object:

  1. Use ImGearDICOM Class.PreparePresStateMetadata Method to extract presentation state settings from image and image's display, and to prepare metadata tree for the Presentation State object.
  2. Edit Presentation State metadata if needed.
  3. Use ImGearDICOM Class.SavePresState Method to save Presentation State metadata as Presentation State object.


Waveform Image Support

ImageGear for .NET supports both DICOM raster and vector (waveform) images. ImageGear loads DICOM raster pages as ImGearRasterPage Class, and vector images as ImGearVectPage Class.

ImageGear reads and displays waveform data (graphs), as well as axes and some annotations.

Currently, ImageGear creates the following annotations for waveform images:

  • X axis with second marks, according to SamplingFrequency tag value.
  • X axis for every image, if it is visible and does not intersect with other images
  • Y axis for all images.
  • Minimum and maximum waveform values for each graph.


Using ImageGear.Formats.JPEG2K Namespace

The ImageGear JPEG2K namespace allows you to create an imaging application that supports JPEG 2000 Standard Part I (JP2, J2K, JPC), JPEG 2000 Part II (JPX) and JPEG 2000 Part IV (MJ2) image file formats.

The JPEG 2000 Standard Part I (JP2, J2K, JPC) provides a set of features that are of importance to many high-end and emerging applications by taking advantage of new technologies. It addresses areas where current standards fail to produce the best quality or performance and provides capabilities to markets that currently do not use compression. The markets and applications better served by the JPEG 2000 standard are Internet, color facsimile, printing, scanning (consumer and pre-press), digital photography, remote sensing, mobile, medical imagery, digital libraries/archives and eCommerce. Each application area imposes some requirements that the standard should fulfill.

JPEG 2000 Part II (JPX) is an extension to the JPEG 2000 file format. It is provided for the exchange of compressed image files between application environments. Many applications may choose to use this optional file format to contain JPEG 2000 compressed image data.

While the JP2 file format provides a method by which applications can interchange image files in such a way that all conforming readers can properly interpret and display the image, some applications require extensions to the JP2 file format that would prevent the file from being properly interpreted by a conforming reader. For example, an image encoded in a CMYK color space will not be properly interpreted by a conforming JP2 reader. To avoid such confusions JPX format is used in applications that require functionality or data structures beyond those defined in the JP2 file format.

Support of Motion JPEG2000 file format (JPEG 2000 Part IV (MJ2)) is based on support of JP2 file formats, since MJ2 is designed to contain one or more motion sequences of JPEG2000 images. Thus ImageGear JPEG2K filter is able to handle all features of single image which can be extracted from any track, available in MJ2 file.

For more information about JP2, JPX and MJ2 formats please go to the site:

http://www.jpeg.org/JPEG 2000.html

JPEG 2000 Standard Part I (JP2, J2K, JPC)

The ImageGear.Formats.JPEG2K Namespace (based on Kakadu SDK) allows for utilizing the wide functionality of the JPEG 2000 standard Part 1 (ISO/IEC 15444-1).

It provides the following advantages:

  • The ability to read/write JPEG 2000 codestream and JP2 format. Also see FileFormat control parameter.
  • Excellent image quality at high compression rates. A major difference between JPEG 2000 and the well known JPEG (Joint Photographic Experts Group) technique is the use of the analyzing method. While JPEG uses the Discrete Cosine Transform, JPEG 2000 uses a special Discrete Wavelet Transform, which results in improved image quality. The Discrete Wavelet Analysis is performed over the whole image without partitioning it into many different tiles. The reconstructed image does not contain blocking artifacts corresponding to these initial tiles even at high compression rates. Refer to Discrete Wavelet Transform (DWT) and WaveletFilter, WaveletLevels control parameters.
  • Choice of lossless and lossy image compression. The analyzing wavelet filter operation allows a lossless compression at low compression rates and a lossy compression at higher rates. The lossless compression is the lowest possible compression rate. The JPEG 2000 compression is very efficient, and outperforms comparable lossless image compression techniques like LZW and TIFF.
  • User controlled output lossy compression rate. The image to be stored may be compressed to a pre-determined rate or to achieve a desired quality. If set for a pre-determined compression rate, the size of the resulting JPEG 2000 file will meet the rate exactly. While using other compression techniques, the size of a compressed file depends on the image contents and differs over a wide range. The different progression orders available in a JPEG 2000 compressed file allows for size-dependent compression control. Of course, you may also compress an image with the control set for a desired quality. In addition to compression rate, this component allows you to set a different number of quality layers. Also see RateBytes control parameter.
  • Support of different image types. The JPEG2K Component supports the following image types and bit depths: palette-based (1-, 4- , 8-bit depths), grayscale (8-, 16-bit depths), truecolor (24-bit depth) and CMYK (32-bit depth).
  • User-controlled opacity and transparency information (alpha channel transparency). The ImageGear JPEG2K component allows you to store and load alpha channel transparency for all color channels. Loading and saving of additional alpha channels can be performed using core ImageGear functionality. Also see AlphaChannels.
  • User controlled reading/writing of JPEG 2000 format metadata (XML and IPR). Non-image information (XML and IPR) does not affect the decoding or visual appearance of the image itself. Also see JPEG 2000 Part I (JP2) Metadata Tags and Non-image Dataset Structure for JPEG2K as well as "XML" and "IPR".
  • Quicklook generation and scaled image reconstruction based on embedded coding techniques. The resolution progression feature of the compressed JPEG 2000 data is best suited to perform a scaled reconstruction. The reconstruction process can be interrupted at any time and the partly processed data contains information of the full-size image. The reconstructed image appears in the appropriate quality corresponding to the processed amount of image data. If the image is reconstructed only for quicklook purposes, the best quality is not necessary because it is displayed at a fraction of the original image size. Using the ImageGear JPEG2K component, the quality and size of the reconstructed image can be scaled. This reconstructed image may be shown clearly because critical image information is located at the beginning of the compressed file, and remaining data follows in the order of detail. Also see DiscardLevels, Mode control parameters.

These features outperform all other image compression techniques. JPEG 2000 image compression is suited well for sensitive image compressions (because of the lossless feature), or for its excellent image quality at high compression ratios for uses such as transmission in low bandwidth applications.

JPEG 2000 Part II (JPX)

JPEG 2000 Part II (JPX) defines a file architecture rather than a specific, fixed set of data structures that will be found in a file. The ImageGear JPEG2K namespace provides you with the support of the following important JPX features:

  • CMYK support. JPX CMYK image is saved such that any other JPX software is able to read the image as CMYK.
  • Multipage support. ImageGear JPEG2K namespace allows you to read/write multipage JPX documents with many compositing layers. You also may add new pages to the end of already existing pages in the multipage file.
  • Separate codestreams support. Each JPX transparency channel can be separated from the color channels and can be written as single codestream. This feature is very useful, if we have multipage JPX document and want to set one transparency channel for all pages. In this case, it is possible to save this transparency channel as a separate codestream and then add a pointer to this codestream to all pages. This ability allows you to significantly reduce the size of the output multipage JPX document.
  • Chroma-key opacity support. This JPX feature allows you to specify the color value of every transparent pixel.
  • User controlled reading/writing of JPEG 2000 format metadata (XML and IPR). Non-image information (XML and IPR) does not affect the decoding or visual appearance of the image itself. Also see JPEG 2000 Part II (JPX) Metadata Tags and Non-image Dataset Structure for JPX as well as "XML" and "IPR".

JPEG 2000 Part IV (MJ2)

Support of Motion JPEG2000 file format (MJ2) is based on support of JP2 file formats, since MJ2 is designed to contain one or more motion sequences of JPEG2000 images. Thus ImageGear JPEG2K component is able to handle all features of single image which can be extracted from any track, available in MJ2 file. To select particular video track VideoTrack control parameter should be used.


JP2 File Format

To enable JP2 file format in your project add a reference to ImageGearV16n.dll, specify this directive:

using ImageGear.Formats.JPEG2K;

...and use this API:

ImGearFileFormats.Filters.Add( ImGearJPEG2K.CreateJP2Format());

You can detect, read and write JPEG 2000 (JP2) files using ImageGear File Formats API. The following bit depths are supported: 1, 4, 8, 16, 24 and 32.


JPX File Format

To enable JPX file format in your project add a reference to ImageGearV16n.dll, specify this directive:

using ImageGear.Formats.JPEG2K;

...and use this API

ImGearFileFormats.Filters.Add( ImGearJPEG2K.CreateJPXFormat());

You can detect, read and write JPEG 2000 (JPX) files using ImageGear File Formats API. The following bit depths are supported: 1, 4, 8, 16, 24 and 32.


MJ2 File Format

To enable MJ2 file format in your project add a reference to ImageGearV16n.dll, specify this directive:

using ImageGear.Formats.JPEG2K;

...and use this API

ImGearFileFormats.Filters.Add( ImGearJPEG2K.CreateMJ2Format());

You can detect, read and write Motion JPEG 2000 (MJ2) files using ImageGear File Formats API. The following bit depths are supported: 1, 4, 8, 16, 24 and 32.

See Also:

ImageGear.Formats.JPEG2K Namespace


Using ImageGear.Formats.PDF Namespace

The Postscript (PS) language is a simple, interpretive programming language with powerful graphics capabilities. Its primary application is to describe the appearance of text, graphical shapes and sampled images on printed or displayed pages, according to the Adobe imaging model. A program in this language can communicate a description of a document from a composition system to a printing system or control the appearance of text and graphics on a display. The description is high-level and device-independent.

The Adobe Portable Document Format (PDF) is the native file format of the Adobe Acrobat family of products. PDF relies on the same imaging model as the PostScript page description language to describe text and graphics in a device-independent and resolution-independent manner. A document can be converted straightforwardly between PDF and the PostScript language; the two representations produce the same output when printed. To improve performance for interactive viewing, PDF defines a more structured format than that used by most PostScript language programs. PDF also includes objects, such as annotations and hypertext links that are not part of the page itself but are useful for interactive viewing and document interchange. However, PDF lacks the general-purpose programming language framework of the PostScript language.

The ImageGear PDF namespace allows you to load, save and process native PDF and PostScript documents. It also allows rasterization of PDF and PostScript documents, by converting them to bitmap, and provides you with the possibility of text extraction from loaded PDF and PostScript documents.

PDF support is compatible with Adobe PDF v1.7 as defined in the Portable Document Format Reference Manual Version 1.7, distributed by Adobe Systems, Incorporated. It provides reading capability up to the PDF v1.7 and writing of PDF v1.7 documents.

PostScript support is compatible with Adobe PostScript (TM) 3.0 language as defined in the PostScript Format Reference Manual, distributed by Adobe Systems, Incorporated. It provides reading capability up to the PostScript 3.0 Language, Level 3, and writing of the PostScript 3.0 files with Language Levels 1, 2 and 3. This includes writing of Encapsulated PostScript (EPS) files with standard and extended preview as well as without preview at all.

ImageGear PDF namespace provides full multi-page reading and writing support for the entire document as well as specified set of pages. You can detect, read, write, append, insert, replace, swap and delete a specified page in the PDF document as well as to edit its content.

To enable ImageGear.Formats.PDF Namespace in your project specify the following directive:

using ImageGear.Formats.PDF;


PDF Standards

PDF/X and PDF/A standards are defined by the International Organization for Standardization (ISO).

  • PDF/X standards apply to graphic content exchange

The most widely used standards for a print publishing workflow are several PDF/X formats: PDF/X-1a,
PDF/X-3, and PDF/X-4.

  • PDF/A standards apply to long-term archiving of electronic documents

The most widely used standards for PDF archiving are PDF/A-1a and PDF/A-1b (for less stringent requirements).

For more information on PDF/X and PDF/A, see the ISO website.

PDF/A

PDF/A is a file format based on PDF. It provides a mechanism for representing electronic documents in a manner that preserves their visual appearance over time, independent of the tools and systems used for creating, storing, or rendering the files.

PDF/A-1a

Level A conforming files shall adhere to all of the requirements of the ISO 19005-1:2005 specification.

A file meeting this conformance level is said to be a "conforming PDF/A -1a file."

PDF/A-1b

In recognition of the varying preservation needs of the diverse user communities making use of PDF files, the ISO 19005-1:2005 specification defines a Level B conformance level. Level B conforming files shall adhere to all of the requirements of the specification except those applicable to Level A only.

A file meeting this conformance level is said to be a "conforming PDF/A-1b file."

NOTE: The Level B conformance requirements are intended to be those minimally necessary to ensure that the rendered visual appearance of a conforming file is preservable over the long term. However, Level B conforming files might not have sufficiently rich internal information to allow for the preservation of the document's logical structure and content text stream in natural reading order, which is provided by Level A conformance. The requirements for Level A conformance place greater responsibilities on writers of conforming files and those preparing such files, but these requirements allow for a higher level of document preservation service and confidence.

PDF/X

PDF/X is a PDF based format for the exchange of object-based data where individual objects may be in either vector or raster data structures. PDF/X defines a data format and its usage to permit the predictable dissemination of a compound entity to one or more locations, as color-managed, CMYK, gray, RGB, and/or spot color data, in a form ready for final print reproduction, by transfer of a single file. This file contains all the content information necessary to process and render the document, as intended by the sender, coded inside a single PDF file. No other parts, either external files nor internally embedded files, are required or permitted. This exchange requires no prior knowledge of the sending and receiving environments and is sometimes referred to as "blindî" exchange. It is platform- and transport-independent.

PDF/X-3:2003

PDF/X-3:2003 conforming files shall adhere to all of the requirements of the ISO 15930-6:2003 specification defining "Prepress digital data exchange using PDF -- Part 6: Complete exchange of printing data suitable for colour-managed workflows using PDF 1.4 (PDF/X-3)."

A file meeting this conformance level is said to be a "conforming PDF/X-3 file."


Content Editing

Content editing provides an API for creating, accessing and editing PDF page content objects. With this API you can work with a page's content as with a list of such objects like images, texts, forms. Retain, modify and save their data and properties.


Document Fonts

Document font support includes:

  • Listing the fonts available in the host system and finding a system font that matches a PDF font
  • Creating a font from the system font and encoding as well as from the specified attributes
  • Changing font's information
  • Editing and embedding a font in the document
  • Both single and multiple bytes fonts are supported


Word Extraction

Text words extraction includes:

  • Extracting words from a PDF document or specified page
  • Enumerating and sorting the words
  • Getting word layouts, styles and characters


Document Metadata

You can get and set PDF document metadata corresponding to a document's Info dictionary.


Native Printing

Native PDF document printing now renders the document content directly to the printer, so it is fast and requires less memory.


Working with PDF Layers

This section provides information about working with PDF Layers, as follows:

  • Layer objects and visibility
  • Layers Diagram
  • Visibility Policy
  • Working with Containers, Dictionaries and Layers using ImageGear PDF sample

For more information, see the following API sections: ImGearPDFDictionary Class, ImGearPDFDocument Class, and ImGearPDFLayer Class.

Layer objects and visibility

The following objects are related to PDF Layers and responsible for the visibility.

Layers

Each layer has a name and a visibility state for the containers connected to the layer through a Dictionary. The visibility state can have one of two values - ON or OFF.

Dictionaries

Each dictionary contains the array of layers and a Boolean function, which takes all the layers' states as input and applies the visibility policy function to the layers' state values producing the Boolean result whether or not to display all the objects from the dictionary's container. The output can have one of two values - ON or OFF.

Containers

Each container is an arbitrary set of PDF elements or other containers. Each container is associated with a dictionary. The container and all its elements (including the other containers) are displayed when its dictionary's visibility policy Boolean function results with ON.

The following diagram shows the relationship between containers and the other PDF document objects:

Layers Diagram

The following diagram shows interconnection between PDF objects and layers:

Visibility Policy

Dictionary Boolean function define the visibility policy. It can be one of the following:

  • AllOn - equivalent to "AND" function for all input parameters,
  • AnyOn - equivalent to "OR" function for all input parameters,
  • AnyOff - equivalent to "NOT-OR" function for all input parameters,
  • AllOff - equivalent to "NOT-AND" function for all input parameters,

In other words:

AllOn
All the containers from the dictionary will be displayed when all the input layers' states are 'ON'
AnyOn
All the containers from the dictionary will be displayed when at least one of the input layers state is 'ON'
AnyOff
All the containers from the dictionary will be displayed when at least one of the input layers state is 'OFF'
AllOff
All the containers from the dictionary will be displayed when all the input layers' states are 'OFF'

Working with Containers, Dictionaries and Layers using ImageGear PDF sample

Before creating a container you need to create one or more layers using the View -> Layers menu. Make sure to create some simple elements like text, paths or images as well.

In order to create container right click on the PDF page and select Create -> Container. You will be prompted to select all the layers you want to associate with the containers dictionary, which will affect the container's visibility. You also need to select the visibility policy and check all the elements you want to include into the new container. When container is created a new dictionary is automatically created as well.

To show or hide the container's elements use View -> Layers menu to change the layer's state to ON or OFF.

In order to rearrange the container's elements you can right click to delete the existing container, which will free its elements and create the new one.


Working with 3D Artwork

Starting with version 1.7, PDF introduces the capability for collections of 3D objects, such as those used by CAD formats, to be embedded in PDF files. Such collections are called 3D models, and PDF refers to them as 3D Artwork. In PDF documents, 3D Artwork is represented by 3D annotations stored in Universal 3D (U3D) format.

ImageGear.Formats.PDF namespace allows the following 3D features:

  • 3D content can be rendered within a page.
  • Multiple instances of 3D data can appear within a page or document.
  • Specific views of 3D artwork can be available, including a default view that is displayed initially and other views that can be selected.
  • Users can rotate and move 3D data, enabling them to examine complex objects from any angle or orientation.

Working Process

ImageGear 3D Artwork processing integrates the following namespaces:

  • ImageGear.Formats.PDF Namespace - PDF content reader and writer.
  • ImageGear.Formats.U3D Namespace - U3D format decoder and encoder.
  • ImageGear.ART Namespace - Image annotation mark used to represent 3D Artwork.
  • ImageGear.ART.Forms Namespace - Interactive GUI forms and toolbar.
  • ImageGear.Vector Namespace - Vector data storage and API for interaction.

3D PDF Artwork is converted into the ART Image mark referencing a vector ImGearPage Class, so it can be edited, interacted with, and/or saved back to PDF.

3D Interaction is possible in the ART RUN Mode, by clicking over the mark and using the popup 3D toolbar. Users can rotate, scale and move 3D data, as well as change light and view settings.

XML Import and Export

The vector Image mark representing 3D data can be exported to XML in the U3D format. While saving to XML, vector ImGearPage associated with the Image mark will be converted to U3D stream and saved to XML Data tag. While loading from XML, U3D stream will be loaded as a vector ImGearPage and will be attached to the Image mark.


Using PDF from Multiple Threads

While ImageGear.Formats.PDF Namespace is thread safe and can be used from the multiple threads, it has some limitation. The PDF component must be initialized on the main/parent thread. Each child thread before calling to the PDF component methods should initialize it using ImGearPDF Class . Initialize Method. Each child thread should also terminate the PDF component using ImGearPDF Class . Terminate Method when done using it. You can process multiple PDF documents from the multiple threads as long as each document is operated on the thread that created/opened this document.


Using ImageGear.Formats.U3D Namespace

The ImageGear.Formats.U3D Namespace provides the API to create U3D vector format. This namespace provides read and write support for the following features of Universal 3D format: CLOD Progressive Mesh, Normals, Colors (diffuse and specular), Views, Lights, Textures, Transparency, Linesets, and Pointsets.


Using ImageGear.FreqIP Namespace

The ImageGear.FreqIP Namespace provides public API functions for features related to image processing in frequency domain, such as Fourier Transform, Low Pass Filter, etc. This includes the following areas:

  • Fast Fourier Transform
  • Image Filtering
  • Image Restoration
  • Convolution
  • Discrete Cosine Transform and Discrete Sine Transform


Fast Fourier Transform

Fast Fourier Transform (FFT) performs a multidimensional FFT on the input object specified by Input File. FFT is based on the FFTW 3 library (see www.fftw.org).

Before using these functions, like other frequency processing functions, ImGearFrequencyProcessing Class.InitializeFFTW Method() must be called first to enable the support for FFTW.

  • ForwardFFT
  • ForwardFFTFromImage
  • InverseFFT
  • InverseFFTToImage

ForwardFFT

The ForwardFFT Method performs a forward Fast Fourier Transform.

NOTE: You must keep track how the transform is centered, as well as the scaling method, in the forward FFT in order to know how to de-center it during the inverse FFT.

This method can be applied only to valid ImGearComplexObject Class object.

Method ImGearFrequencyProcessingVerifier Class.CanApplyForwardFFT Method can be called to check whether the operation can be performed or not.

ForwardFFTFromImage

This ForwardFFTFromImage Method performs a forward Fast Fourier Transform of the input image. The difference between this function and ForwardFFT is that this function takes an ImGearPage Class as the input object.

NOTE: You must keep track how the transform is centered, as well as the scaling method, in the forward FFT in order to know how to de-center it during the inverse FFT.

This method can be applied only to 8, 16, or 32bit grayscale images with one channel.

Method ImGearFrequencyProcessingVerifier Class.CanApplyForwardFFTFromImage Method can be called to check whether the operation can be performed or not.

InverseFFT

This InverseFFT Method performs an inverse Fast Fourier Transform.

This method can be applied only to valid ImGearComplexObject Class object.

Method ImGearFrequencyProcessingVerifier Class.CanApplyInverseFFT Method can be called to check whether the operation can be performed or not.

InverseFFTToImage

This InverseFFTToImage Method performs an inverse Fast Fourier Transform.

This method can be applied only to valid ImGearComplexObject Class object.

Method ImGearFrequencyProcessingVerifier Class.CanApplyInverseFFTToImage Method can be called to check whether the operation can be performed or not.


Image Filtering

The following image filtering features are available in the ImageGear.FreqIP Namespace:

  • BandPassFilter
  • BandStopFilter
  • HighPassFilter
  • LowPassFilter

BandPassFilter

This BandPassFilter Method filters the image using a band-pass filter.

Available filter brands include Ideal, Butterworth, Gaussian, Chebyshev I, and Chebyshev II.

Cutoff frequency is normalized between 0 and 1.0 where 0 is DC, and 1.0 is the Nyquist frequency.

Before using this function, like other frequency processing functions, ImGearFrequencyProcessing Class.InitializeFFTW Method must be called first to enable the support for FFTW.

Can be applied only to 8bit grayscale images with one channel.

Method ImGearFrequencyProcessingVerifier Class.CanApplyBandPassFilter Method can be called to check whether the operation can be performed or not.

BandStopFilter

This BandStopFilter Method filters the image using a band-stop filter.

Available filter brands include Ideal, Butterworth, Gaussian, Chebyshev I, and Chebyshev II.

Cutoff frequency is normalized between 0 and 1.0 where 0 is DC, and 1.0 is the Nyquist frequency.

Before using this function, like other frequency processing functions, ImGearFrequencyProcessing Class.InitializeFFTW Method() must be called first to enable the support for FFTW.

Can be applied only to 8bit grayscale images with one channel.

Method ImGearFrequencyProcessingVerifier Class.CanApplyBandStopFilter Method can be called to check whether the operation can be performed or not.

HighPassFilter

This HighPassFilter Method filters the image using a high-pass filter.

Available filter brands include Ideal, Butterworth, Gaussian, Chebyshev I, and Chebyshev II.

Before using this function, like other frequency processing functions, ImGearFrequencyProcessing Class.InitializeFFTW Method() must be called first to enable the support for FFTW.

Can be applied only to 8bit grayscale images with one channel.

Method ImGearFrequencyProcessingVerifier Class.CanApplyHighPassFilter Method can be called to check whether the operation can be performed or not.

LowPassFilter

This LowPassFilter Method filters the image using a low-pass filter.

Available filter brands include Ideal, Butterworth, Gaussian, Chebyshev I, and Chebyshev II.

Before using this function, like other frequency processing functions, ImGearFrequencyProcessing Class.InitializeFFTW Method() must be called first to enable the support for FFTW.

Can be applied only to 8bit grayscale images with one channel.

Method ImGearFrequencyProcessingVerifier Class.CanApplyLowPassFilter Method can be called to check whether the operation can be performed or not.


Image Restoration

The image restoration filters include: Inverse Filtering and Wiener Filtering.

Inverse Filtering

This InverseRestore Method restores an image using inverse filtering in the frequency domain. The idea is to deconvolve PSF from the blurred data to extract the original image.

The deconvolution involves dividing the Fourier transform of the blurred image by the Fourier transform of PSF. If the transform of PSF has very small values, then the division result from those small values could easily dominate the entire result. The approach used to get around this issue is to limit the smallest value of the transform of PSF, thus we require a threshold value, dThreshold, to be passed in as a parameter. Ideally, this value will be just above the noise level in the image. This function places zeros in the output for those data points where the magnitude of PSF transform is below the threshold. In this respect, InverseRestore is actually an implementation of a pseudo-inverse filter.

Before using this function, like other frequency processing functions, ImGearFrequencyProcessing Class.InitializeFFTW Method() must be called first to enable the support for FFTW.

Can be applied only to 8bit grayscale images with one channel.

Method ImGearFrequencyProcessingVerifier Class.CanApplyInverseRestore Method can be called to check whether the operation can be performed or not.

Wiener Filtering

This WienerRestore Method performs image restoration using Wiener filtering in the frequency domain. This filter is also commonly referred to as the minimum mean square error filter or the least square error filter.

Usually Wiener filtering can produce better results than inverse filtering.

Before using this function, like other frequency processing functions, ImGearFrequencyProcessing Class.InitializeFFTW Method() must be called first to enable the support for FFTW.

Can be applied only to 8bit grayscale images with one channel.

Method ImGearFrequencyProcessingVerifier Class.CanApplyWienerRestore Method can be called to check whether the operation can be performed or not.


Convolution

This Convolve Method convolves an image with the given kernel matrix. The convolution is implemented using FFT, based on the Convolution Theorem, which provides improved performance for larger kernel matrix.

The result of the convolution is multiplied by a normalizer to scale the data. For kernels that sum to zero, the normalizer is usually set to 1.0.

Before using this function, like other frequency processing functions, ImGearFrequencyProcessing Class.InitializeFFTW Method() must be called first to enable the support for FFTW.

Can be applied only to 8, 16, or 32bit grayscale images with one channel.

Method ImGearFrequencyProcessingVerifier Class.CanApplyConvolve Method can be called to check whether the operation can be performed or not.


Discrete Cosine Transform and Discrete Sine Transform

Before using these functions, like other frequency processing functions, ImGearFrequencyProcessing Class.InitializeFFTW Method() must be called first to enable the support for FFTW.

  • Forward Discrete Cosine Transform (DCT)
  • Inverse Discrete Cosine Transform (IDCT)
  • Forward Discrete Sine Transform (DST)
  • Inverse Discrete Sine Transform (IDST)

Forward Discrete Cosine Transform (DCT)

  • The ForwardDCT Method computes the forward Discrete Cosine Transform (DCT) of the input data.
  • The ForwardDCTFromImage Method computes the forward Discrete Cosine Transform (DCT) of the input image. The difference between this function and ForwardDCT is that this function takes an ImGearPage Class as the input. Can be applied only to 8, 16, or 32bit grayscale images with one channel.

Inverse Discrete Cosine Transform (IDCT)

  • The InverseDCT Method computes the inverse Discrete Cosine Transform (IDCT) of the input data.
  • The InverseDCTToImage Method computes the inverse Discrete Cosine Transform (IDCT) of the input image. The difference between this function and InverseDCT is that this function returns an ImGearPage Class as the result, using the default conversion type ImGearCoObjConvType.REAL.

Forward Discrete Sine Transform (DST)

  • The ForwardDST Method computes the forward Discrete Sine Transform (DST) of the input data.
  • The ForwardDSTFromImage Method computes the forward Discrete Sine Transform (DST) of the input image. The difference between this function and ForwardDST() is that this function takes an ImGearPage Class as the input. Can be applied only to 8, 16, or 32bit grayscale images with one channel.

Inverse Discrete Sine Transform (IDST)

  • The InverseDST Method computes the inverse Discrete Sine Transform (IDST) of the input data.
  • The InverseDSTToImage Method computes the inverse Discrete Sine Transform (IDST) of the input data. The difference between this function and InverseDST is that this function returns an ImGearPage Class as the result, using the default conversion type ImGearCoObjConvType.REAL.


Using ImageGear.Processing Namespace

The ImageGear.Processing Namespace API provides various image processing capabilities, including the following:

  • Bi-Linear and Bi-Cubic Interpolation
  • Red-Eye Removal
  • Mosaic Effect
  • Duotone Effect
  • Shear Effect
  • Fragmentation Effect
  • Functional Lights Effects
  • Borders and Shadows Effects
  • Lens Flare Effect
  • Aging Effect
  • Artistic Effects
  • Boost Effect
  • Gaussian Blur
  • Glowing Edges Effect
  • High Density Range Effect
  • Hot Wax Effect
  • Monochrome Film Effect
  • Pinch Effect
  • Ripple Effect
  • Sketch Effect
  • Solarize Effect
  • NightVision Effect
  • Perspective Effect
  • Picturize Effect
  • Removing Chromatic Aberration
  • RoundCorners Effect
  • Sepia Effect
  • Spotlights Effect
  • ToyCamera Effect
  • Vignette Effect
  • Warp Effect
  • White Balance Correction
  • Edge Detection
  • Speckle Removal
  • Image Enhancement
  • Background Correction
  • Edge Map
  • Mathematical Morphology


Bi-Linear and Bi-Cubic Interpolation

ImageGear's implementation of bilinear and bicubic interpolation for image resize is designed for high image quality, especially when resizing large images down to small sizes (e.g., for thumbnail generation). There's also a property called Sharpness in ImGearBilinearInterpolationOptions Class and ImGearBicubicInterpolationOptions Class that allows you to fine-tune the sharpness of the resulting image.


Red-Eye Removal

Red-eye removal removes the "red eye" effect in color images by converting the red color in the eye to the new specified color. ImageGear's Red-Eye Removal works by detecting an area around a specified point where the colors correspond to the point color with the specified threshold. This detected area is saved as a Region of Interest (ROI) of the raster page. Red eye is then removed for every point in the ROI of a raster page. It is designed only for red eye removal, not other colors (as may occur with animal eyes).

The ImGearProcessing Class.ImGearPixelCheckerRedEyeRGB Constructor detects an area around specified point where the colors correspond to the point color with the specified threshold. The detected area is saved as ROI of the raster page.

For example, the color of the specified point is:

Red == 212;

Green == 96;

Blue == 128;

And threshold is 10.

The method detects a closed polygon around the specified point in which the color components belong to the range.

Red - 202.. 222;

Green - 86..106

Blue - 118.. 138

The ImGearPixelProcessorRedEyeRGB Constructor removes red eye for every point in the ROI of a raster page. It is designed only for red eye removal, not other colors (as occurs with animal eyes). First, the red component must be reduced to be around the same level of the green and blue components. Then, all three components must be reduced. The following are some examples of corrected color values:

210,39,71 -> 25,23,26

186,77,82 -> 64,54,53

236,95,101 -> 80,80,78


Mosaic Effect

Mosaic Method - Mosaic API provides the following methods:

  • Simple Mosaic - imposes a mosaic effect on a bitmap by dividing an image into tiles of a specified size and changing the color of all pixels in each tile to the average color of pixels within the tile.
  • Tile Mosaic - creates a mosaic effect on an image by dividing an image into rectangular or arc-shaped cells with irregular boundaries and modifying the color of each cell.
  • Dot Mosaic - converts image colors into randomly placed dots to create a pointillist painting, and uses the background color to fill the area between dots.
  • Roman mosaic - segments the image into rectangular or rounded rectangular tiles and fills them with a color chosen randomly from the colors of the tiles pixels.

The mosaic effect divides a bitmap into tiles of a specified size and changes the color of all pixels in each tile to the average color of pixels within the tile.

See Also:

ImGearMosaicBorderParams Class

ImGearMosaicCellParams Class

ImGearMosaicFillParams Class

ImGearMosaicShadowParams Class


Duotone Effect

The Duotone Method maps image colors to a gradient between the two specified colors.

Original

Duotone


Shear Effect

The Shear Method applies a shearing effect to an image, moving the image rasters or columns according to the specified offsets.

Original

Shear effect

AccuSoft Corporation
 AccuSoft.com
sales@accusoft.com


Fragmentation Effect

The Fragment Method fragments an image into four blended images which move diagonally outward from the original image.

Original

Fragmentation effect

AccuSoft Corporation
 AccuSoft.com
sales@accusoft.com


Functional Lights Effects

Functional Lights methods change the colors of an image according to the pattern of a sine wave, or an application defined pattern. The image will appear to have circles or bars of light and/or shadow overlaid on top of it.

The DirectionalLight Method adds bars of light according to a sine wave pattern.

The RadialLight Method adds circles of light according to a sine wave pattern.

The FreeDirectionalLight Method adds bars of light according to a custom pattern.

The FreeRadialLight Method adds circles of light according to a custom pattern.

Original

Directional Light

Radial Light

Free Directional Light


Borders and Shadows Effects

The DropShadow Method adds a drop shadow to an image. The image is enlarged to contain a background and shadowed area.

Original

Drop Shadow Effect


Lens Flare Effect

The LensFlare Method applies a lens flare effect to the image. The effect simulates a bright light, such as the sun, and some reflections within the lens. It is typically used to add a sense of drama or realism to a photographic image.

Original

Lens Flare Effect

AccuSoft Corporation
 AccuSoft.com
sales@accusoft.com


Aging Effect

The Aging Method applies an aging effect to make an image look older. The effect can adjust image saturation and contrast, and add noise and random vertical lines to the image.

Original

Aging Effect

AccuSoft Corporation
 AccuSoft.com
sales@accusoft.com


Artistic Effects

ImageGear artistic effects make the image appear to have been hand-painted.

The Oilify Method makes the image appear similar to an oil painting.

The Pointillist Method makes the image appear to have been painted in the pointillism style of painting. This effect is also known as Dot Mosaic. The painted points are randomly generated, therefore, the resultant image is different each time the method is applied with the exact same settings.

The Spatter Method applies a spatter effect to an image, making it look to have been painted in the impressionist style of painting. The painted points are randomly generated, therefore, the resultant image is different each time the method is applied with the exact same settings.

Original

Oilify Effect

Spatter Effect

Pointillist Effect


Boost Effect

The Boost Method increases saturation, brightness and contrast of the image. Use this method if you need a simple way to make old and faded images look more vivid.

Original image

Boost effect

AccuSoft Corporation
 AccuSoft.com
sales@accusoft.com


Gaussian Blur

The GaussianBlur Method smoothes the images using Gaussian transform. It makes images look softer and out of focus.

The radius parameter corresponds to the Standard Deviation (Sigma) in Gaussian transform. It can range from 0.1 to 500. Typical values for high-resolution images range from 1.0 to 2.0. Larger values will cause greater softening, and take more processing time. The width of the area considered for each pixel is approximately 6 * radius.

Original image

Image filtered with Gaussian Blur filter


Glowing Edges Effect

The GlowingEdges Method highlights edges on the image with bright colors, and fills flat areas with black..

Original

Glowing Edges effect

AccuSoft Corporation
 AccuSoft.com
sales@accusoft.com


High Density Range Effect

The HighDensityRangeEffect Method increases contrast separately in shadow, highlight and midtone areas, imitating human eye's ability to adapt for light conditions at the point of interest.

Original

High Density Range effect

AccuSoft Corporation
 AccuSoft.com
sales@accusoft.com


Hot Wax Effect

The HotWax Method makes an image look like it has been coated with wax..

Original

Hot Wax effect

AccuSoft Corporation
 AccuSoft.com
sales@accusoft.com


Monochrome Film Effect

The MonochromeFilm Method makes an image look like it has been taken with an analog camera, using a monochrome film. The method takes a parameter specifying the settings, which imitate particular films.

Original

Monochrome Film effect

AccuSoft Corporation
 AccuSoft.com
sales@accusoft.com


Pinch Effect

Pinch Method transforms the current DIB by making it appear as if it were pinched in the center.

A region of interest (ROI) can be used as a pinch base.


Ripple Effect

The Ripple Effect can be created using one of the following methods:

  • The RadialWave Method
  • The RippleFreeHand Method
  • The RippleTexture Method
  • The Ripple Method

The RadialWave Method

The RadialWave Method warps the image in concentric rings.

The RippleFreeHand Method

The RippleFreeHand Method provides the ripple effect on the image, as if it is looked at through a relief glass. The function uses a custom ripple pattern, defined as two one-dimensional arrays containing light deviations in X and Y directions.

The RippleTexture Method

The RippleTexture Method provides the ripple effect on the image, as if it is looked at through a relief glass. The function uses an image as a ripple pattern.

The Ripple Method

The Ripple Method uses one of the prefefined ripple patterns defined in the ImGearRipplePattern Enumeration..

Original

Ripple 0: Sea ripple

Ripple 1: Crosshatch

Ripple 2: Tiles with convex border

Ripple 3: Tiles with concave center

Ripple 4: Flat tiles with bevel edges

Ripple 5: Diagonal flat tiles with bevel edges


Sketch Effect

The Sketch Method blends the source image with a texture image, making it look like painted by a pencil or charcoal.

Original

Sketch effect

AccuSoft Corporation
 AccuSoft.com
sales@accusoft.com


Solarize Effect

The Solarize Method effect mimics the accidental exposure of photographic film to light.

Solarize inverts the colors of pixels whose lightness exceeds a given threshold. If lightness is considered on a 0 to 1.0 scale, the default threshold used by various paint programs is 0.5.

In the following set of images, Solarize was performed with a threshold that caused the color of the sky to be inverted while the rest of the image remained unaffected.


NightVision Effect

The NightVision Method applies "night vision" effect to the image.

Original

Night vision, "Binoculars" mode

Night Vision, "Sniper" mode

Night vision, "Television" mode


Picturize Effect

The Picturize Method divides the image into rectangular cells, and replaces each cell with an image from the specified image collection, attempting to select cell images such that they match colors of course image.

Original

Picturize effect

AccuSoft Corporation
 AccuSoft.com
sales@accusoft.com


Perspective Effect

The Perspective Method effect gives a bitmap a 3D effect, as if it exists on a flat plane and has been skewed into a different shape.


Removing Chromatic Aberration

The RemoveChromaticAberration Method removes chromatic aberration artifacts from an image. Chromatic aberration is caused by differences in refraction of light components by the lens, and is seen as colored "fringes" around the image.

Original image:

Image after removing chromatic aberration:


RoundCorners Effect

The RoundCorners Method rounds the corners of the image and fills them with a specified color.

Original

Round corners


Sepia Effect

The Sepia Method makes the image look like an old sepia toned photograph.

Original

Sepia effect

AccuSoft Corporation
 AccuSoft.com
sales@accusoft.com


Spotlights Effect

The Spotlights Method darkens the image and highlights selected areas as if they are illuminated with a spotlight or sunlight. You can also use ImGearRasterProcessing.SpotlightsPreview Method method for fast generation of a small preview of the effect.

Original

Spotlights effect

AccuSoft Corporation
 AccuSoft.com
sales@accusoft.com


ToyCamera Effect

The ToyCamera Method makes the image look as if it was taken by a toy camera. It imitates the distortions caused by cheap lens and poor shooting conditions. Such distortions, however, sometimes make the image look more attractive and lively.

Original

Toy Camera effect


Vignette Effect

You can use the Vignette Method for two purposes:

1. Draw a vignette over an image.

Original

With vignette

2. Turn an image into a semi-transparent vignette. You can then blend this vignette over other images.

Original

Vignette

Image to be blended with vignette

Vignette blended over an image


Warp Effect

The WarpCylinder Method, WarpParabolic Method, and WarpSphere Method effects perform a point-to-point stretch of the image to give a warping effect.


White Balance Correction

The AdjustWhiteBalance Method corrects white balance of the image.

For example, if the image was taken in the daylight, but the camera white balance setting was set to Tungsten, white objects would display as blue. To correct this (make the white objects display white), use AdjustWhiteBalance method, setting source white balance to Tungsten and destination white balance to Daylight.

This method can also be used to make image colors "cooler" or "warmer". To make the image look warmer, use source white point corresponding to a higher color temperature, and destination white point corresponding to a lower color temperature. To make the image look cooler, use source white point corresponding to a lower color temperature, and destination white point corresponding to a higher color temperature.

There are several overloads of this method.

Original image, taken with wrong white balance settings

Image with corrected white balance.


Edge Detection

Edge detection is one of the most important subjects in image processing, which finds wide applications in the pattern recognition, the scene analysis and the 3-D vision, because the edges correspond in general to the important changes of physical or geometrical properties of objects in the scene and they are widely used as primitives in pattern recognition, image matching, etc.

The edges coincide, generally speaking, with gray level transition, so they can be detected by maxima of gradient or the zero-crossing of the second derivatives calculated by some differential operators. Because the differential operators are sensitive to noise, a preprocessing such as smoothing is often necessary to eliminate the noise.

There are three types of edge detection:

  • Edge detection using the maxima of gradient, i.e., maxima of the first order derivative.
  • Edge detection using the zero-crossings of second order derivative along the gradient.
  • Edge detection using an optimal difference recursive filter.

Can be applied only to 8bit grayscale images with one channel.

See EdgeDetection Method for more information.


Speckle Removal

  • The Despeckle Method removes the color noise from a 1-bit image. It looks for an average color value inside the square area that you specify near the pixel and replaces the pixel with this value. Processes color channels only.
  • The GeomDespeckle Method is used to reduce speckle noise from an image by using the Crimmins algorithm. It reduces the speckle index of an image by sending the image through a geometric filter, which uses the complementary hulling technique. The method has the effect of reducing the undesired speckle noise while preserving the edges of the original image. It can be applied only to 8bit grayscale images with one channel.


Image Enhancement

This EnhanceLocal Method enhances an image using the local standard deviation and mean.

It transforms the input image f(x, y) to a new image g(x, y) based on the following formula,

g(x, y) = A(x, y) * [f(x, y) - m(x, y)] + m(x, y)

where,

A(x, y) = k * M / sigma(x, y), with k being a scaling factor within the range [0, 1], m(x, y) and sigma(x, y) being the local mean and local standard deviation, and M being the global mean of the input image.

To avoid the problem of spikes caused by too small local standard deviation, a check against the minimum allowed standard deviation is performed. If the local standard deviation is too small, the minimum allowed instead will be used in the calculation.

Can be applied only to 8-bit grayscale images with one channel.

ImGearRasterProcessingVerifier Class.CanApplyEnhanceLocal Method can be called to check whether the operation can be performed or not.


Background Correction

You can add, remove, or find the tilt for a specified image.

Adding Tilt

The AddTilt Method adds a specified plane to the input image to correct for a tilt in the image luminance. The plane has X and Y zero crossing at the center of the input image with the slope of the plane in X direction and the slope of the plane in Y direction, as specified in the arguments.

Can be applied only to 8, 16 or 32-bpp grayscale images with one channel.

ImGearRasterProcessingVerifier Class.CanApplyAddTilt Method can be called to check whether the operation can be performed or not.

Removing Tilt

The RemoveTilt Method method computes the best-fit plane for an image, and then subtracts that plane from the image to produce the output. This is very handy for correcting illumination gradients in a poorly digitized image.

Can be applied only to 8, 16 or 32-bpp grayscale images with one channel.

ImGearRasterProcessingVerifier Class.CanApplyRemoveTilt Method can be called to check whether the operation can be performed or not.

Finding Tilt

The FindTilt Method method computes the least-squares best fit plane for an image. The plane will be given by formula:

f(x, y) = SlopeX * x + SlopeY * y + Piston.

Can be applied only to 8, 16 or 32bit grayscale images with one channel.

ImGearRasterProcessingVerifier Class.CanApplyFindTilt Method can be called to check whether the operation can be performed or not.


Edge Map

An edge map is an image that shows where there are changes in contrast in the original image. Where there are no changes, the resulting image is black. The stronger the contrast change, the brighter the resultant image. The different types of edge maps are slight variations of the algorithms used, and produce slightly different results.

This EdgeMap Method performs the edge map operation specified by the Method argument. Processes specified range of channels. Processes color channels only.

This method takes into account the ROI settings of page object, that are accessible via the ImGearRasterPage Class.ROI Property. By default ROI is set to the entire image.

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

ImGearRasterProcessingVerifier Class.CanApplyEdgeMap Method can be called to check whether the operation can be performed or not.


Mathematical Morphology

The field of mathematical morphology contributes a wide range of operators to image processing, all based around a few simple mathematical concepts from set theory. The operators are particularly useful for the analysis of binary images. Common usages include edge detection, noise removal, image enhancement, and image segmentation.

The two fundamental operations in mathematical morphology are Erosion and Dilation. Both of these operators take two pieces of data as input: an image to be eroded or dilated, and a structuring element (also known as a kernel). The two pieces of input data are each treated as representing sets of coordinates in a way that is slightly different for binary and grayscale images.

For a binary image, white pixels are normally taken to represent foreground regions, while black pixels denote background. (Note that, in some implementations, this convention is reversed. It is very important to set up input images with the correct polarity for the implementation being used.) The set of coordinates corresponding to that image is simply the set of two-dimensional Euclidean coordinates of all the foreground pixels in the image, with an origin normally taken in one of the corners so that all coordinates have positive elements.

For a grayscale image, the intensity value is taken to represent height above a base plane, so that the grayscale image represents a surface in three-dimensional Euclidean space. The set of coordinates associated with this image surface is simply the set of three-dimensional Euclidean coordinates of all the points within this surface, as well as all points below the surface, down to the base plane. Note that even when we are only considering points with integer coordinates, this is a lot of points, so usually algorithms are employed that do not need to consider all the points.

The structuring element is already just a set of point coordinates (although it is often represented as a binary image). It differs from the input image coordinate set in that it is normally much smaller, and its coordinate origin is often not in a corner, so that some coordinate elements will have negative values. Note that in many implementations of morphological operators, the structuring element is assumed to be a particular shape (e.g., a 3×3 square) and so is hardwired into the algorithm.

Binary morphology can be seen as a special case of grayscale morphology in which the input image has only two gray levels at values 0 and 1.

Erosion and dilation work (at least conceptually) by translating the structuring element to various points in the input image, and examining the intersection between the translated kernel coordinates and the input image coordinates. For example, in the case of erosion, the output coordinate set consists of just those points to which the origin of the structuring element can be translated, while the element still remains entirely "within" the input image.

Virtually all other mathematical morphology operators can be defined in terms of combinations of erosion and dilation together with set operators such as intersection and union. Some of the more important are Opening and Closing.

Erosion

Erosion is one of the fundamental operations in the mathematical morphology. It is usually applied to black and white images, but can also be applicable to grayscale ones. The basic effect of the operation is to erode away the boundaries of regions of foreground pixels (white pixels). Thus, areas of foreground pixels shrink in size, and holes within those areas become larger. Applying this to the grayscale image will make bright objects smaller, that is, the image will be darker.

Both erosion and dilation work by translating the structuring element to various points in the input image, and examining the intersection between the translated kernel coordinates and the input image coordinates. For example, in the case of erosion, the output coordinate set consists of just those points to which the origin of the structuring element can be translated, while the element still remains entirely "within" the input image. In the case of dilation, the effect is the opposite.

For more information, see ImGearRasterProcessing Class . Erode Method.

Dilation

Dilation is one of the fundamental operators in the mathematical morphology. It is usually applied to black and white images, but can also be applicable to grayscale ones. The basic effect of the operation is to gradually enlarge the boundaries of regions of foreground pixels (white pixels). Thus, areas of foreground pixels grow in size while holes within those regions become smaller. Applying this to the grayscale image will make bright objects larger, that is, the image will be lighter.

Both erosion and dilation work by translating the structuring element to various points in the input image, and examining the intersection between the translated kernel coordinates and the input image coordinates. For example, in the case of erosion, the output coordinate set consists of just those points to which the origin of the structuring element can be translated, while the element still remains entirely "within" the input image. In the case of erosion, the effect is the opposite.

For more information, see ImGearRasterProcessing Class . Dilate Method.

Opening

Opening is another operation from mathematical morphology that is derived from the fundamental operations of erosion and dilation. Like those operators it is usually applied to black and white images, but can be applicable to grayscale images as well. The basic effect of an opening is somewhat like erosion in that it tends to remove some of the foreground (bright) pixels from the edges of regions of foreground pixels. However it is less destructive than erosion in general. As with other morphological operators, the exact operation is determined by a structuring element. The effect of the operator is to preserve foreground regions that have a similar shape to this structuring element, or that can completely contain the structuring element, while eliminating all other regions of foreground pixels.

For more information, see ImGearRasterProcessing Class . Open Method.

Closing

Closing is another operation from mathematical morphology that is derived from the fundamental operations of erosion and dilation. Like those operators it is usually applied to black and white images, but can be applicable to grayscale images as well. Closing is similar in some ways to dilation in that it tends to enlarge the boundaries of foreground (bright) regions in an image (and shrink background color holes in such regions), but it is less destructive of the original boundary shape. As with other morphological operators, the exact operation is determined by a structuring element. The effect of the operator is to preserve background regions that have a similar shape to this structuring element, or that can completely contain the structuring element, while eliminating all other regions of background pixels.

For more information, see ImGearRasterProcessing Class . Close Method.


Using ImageGear.Processing.ImageClean Namespace

The ImageGear.Processing.ImageClean Namespace contains classes to enhance bi-level image support. It includes the ability to check for "noise" of black pixels, clean borders, invert white text, auto-orient image, auto invert black text on the white background, and auto-crop.


Using ImageGear.Processing.Layers Namespace

ImageGear Layers

ImageGear allows users to load layered image files and retain image layers for editing. User can also create new layers and delete existing ones, as well as flatten and display the selected layers.

ImageGear currently supports layers for Adobe PSD and large PSD (Adobe PSB) file formats.

ImageGear provides a set of API for working with layers. See ImageGear.Processing.Layers Namespace.

Layer

Layers are used to specify different elements of an image. There are different types of layers. They represent a part of an image either as image pixels or as adjustment instructions. They are stacked on top of each other producing the resulting appearance of the image. ImageGear supports the image layers described in the next chapter.

Image Layer

Image Layer is a type of layer containing image pixels which can be applied/blended with other layers. The image from the Image Layer can cover the same area as the resulting image or just a part, specified by its rectangle. The Image Layer is associated with a certain opacity and other properties.

Layered Page

An ImageGear layered page is a raster image page containg the composition of layers. Layers associated with an image page can be blended in the order in which they appear to provide the resulting page. The result of such blending represents the final image view and is stored in the page's DIB.

See Also:

ImageGear.Processing.Layers Namespace


Using ImageGear.TWAIN Namespace

Another technique for loading an ImGearPage Class object involves obtaining the image from a device, like a scanner or a camera. ImageGear supports the acquisition of images from TWAIN-compliant devices.

For the complete description of how to use ImageGear TWAIN namespace, see ImageGear.TWAIN Namespace chapter.

Acquiring Images from TWAIN Devices

TWAIN was developed by a consortium of software and hardware manufacturers to standardize the communications between application programs and image acquisition devices. The interface is optimized for the acquisition of graphics images. The TWAIN standard is widely supported by scanner manufacturers. The most widely used version of TWAIN is v1.9 (as of this writing). In addition to scanners, TWAIN is being used with digital cameras and video capture boards. ImageGear supports all three TWAIN Transfer Modes: Native Data Transfer Mode (which is the TWAIN default), Disk File Transfer, and Buffered Memory.

A TWAIN-compliant image acquisition device is one whose device driver complies with the TWAIN specification. The device driver understands the TWAIN protocol, thus allowing interaction with the Data Source Manager, the main interface module of the TWAIN software. The Data Source Manager "manages the session" between the application program and the raster-generating data source. Three software elements work together in TWAIN: the application, the Data Source (DS), and the Data Source Manager (DSM) as shown in the illustration below:

The following terminology is used to discuss ImageGear scanning:

  • Data Source: Software provided by the manufacturer of the device. Windows refers to this as a "Device Driver". It must be installed in the system where your application program will run.
  • Data Source Manager: The TWAIN manager for the device drivers. This is software developed by the TWAIN consortium to provide a common mechanism for managing and using the Data Sources from all the different device manufacturers. It must be installed in the system where your application will run.
  • Device: Any device from which images can be acquired using the TWAIN protocol, including scanners and cameras.
NOTE: The TWAIN Data Source for your device and the TWAIN Data Source Manager should be included as part of your scanner software. They are not part of the ImageGear software.

The process of acquiring an image (or set of images) from a device is as follows:

  1. Open the Data Source. This can be done automatically by the application (it chooses the Data Source for the end-user). Alternatively, the application can obtain a list of Data Sources from the Data Source Manager and let the end-user choose, or the application can have ImGearTWAIN Class display the list via its standard dialog box.
  2. Set the the image acquisition parameters (single-page, multi-page, image size, etc.). This can be done automatically by the application, or the application can obtain the various Data Source capabilities (called "ScanCaps"), display them to the end-user in a dialog, and let the end-user choose the values. Alternatively, the application can let ImGearTWAIN Class obtain the settings from the end-user via its standard ScanCaps dialog.
  3. Acquire the image(s). Each image is loaded into an ImGearPage Class object. For a multi-page acquisition, the ImGearPages are loaded into an ImGearDocument Class.
  4. Close the Data Source.

Thus, an example of the code needed to acquire an image from a TWAIN Data Source is as follows:

C#
ImGearTWAIN igTWAIN = new ImGearTWAIN();
igTWAIN.WindowHandle = this.Handle;
igTWAIN.UseUI = true;
// Open a data source
igTWAIN.OpenSource("");
// Set simplex mode
ImGearCapOneValue igCapOneValue = new ImGearCapOneValue(ImGearCapabilities.CAP_DUPLEXENABLED);
igCapOneValue.Value = false;
igTWAIN.SetCapability(igCapOneValue, ImGearMessages.SET);
// Acquire image
ImGearPage igPage = igTWAIN.AcquireToPage();
// Close the data source
igTWAIN.CloseSource();


Using ImageGear.Vector Namespace

The ImageGear.Vector Namespace provides native support for vector data as used by CAD/vector formats such as DXF, DWG, CGM, DGN, HPGL, and U3D. When you load any of these formats, the resulting ImGearPage Class object is not automatically rasterized at load time. The data is kept in vector form for display and processing. It's possible to display the vector data from different viewpoints and edit individual vector entities. The vector data can also be rasterized, converting it to a bitmap form.


Working with Vector Data

provides native support for vector formats. Examples of such formats include PDF and and CAD/vector file formats such as DXF, DWG, CGM, DGN, U3D, and HPGL. When you load any of these vector formats, the resulting page object is of type ImGearVectPage Class, which is derived from ImGearPage Class. The page is not automatically rasterized at load time. Instead, its data is kept in vector form for the display and processing.

You can work with a vector page as either a general ImGearPage Class object or a more specific ImGearVectPage Class object. ImGearVectPage Class provides a Rasterize Method that you can use to create a rasterized copy of the vector page.

An even more specific type of page is ImGearVectPage Class, which is derived from ImGearVectorPage. Pages loaded from CAD/vector file formats are available as ImGearVectPage Class. This object is part of the ImageGear.Vector Namespace. It provides properties and methods for controlling display and manipulation of vector data.

NOTE: ImageGear vector renderer takes advantage of standard system rendering APIs which may be hardware accelerated. Due to differences in graphics chipsets, settings, drivers, and operating systems, performance and appearance (in particular, lighting effects) may vary. It is recommended to tune and test your application for the environments on which you will be deploying.

For more information about PDF, please refer to ImageGear.Formats.PDF Namespace.

For more information about CAD/Vector, please refer to ImageGear.Vector Namespace.

For more information about U3D, please refer to ImageGear.Formats.U3D Namespace.


Loading a Vector Drawing

Loading a vector drawing is done using the same methods used to load other types of images. However, before loading the drawing, you must first enable support for the vector formats you want to use. For example:

C#
//Placed at start of source file.
using ImageGear.Vector;
using ImageGear.Formats;
using ImageGear.Formats.CAD;
using ImageGear.Formats.HPGL;
using ImageGear.Formats.DGN;
using ImageGear.Formats.CGM;

C#
//Placed during application load.
ImGearFileFormats.Filters.Add(ImGearCAD.CreateDWGFormat());
ImGearFileFormats.Filters.Add(ImGearCAD.CreateDXFFormat());
ImGearFileFormats.Filters.Add(ImGearHPGL.CreateHPGLFormat());
ImGearFileFormats.Filters.Add(ImGearDGN.CreateDGNFormat());
ImGearFileFormats.Filters.Add(ImGearCGM.CreateCGMFormat());


Rasterizing a Vector Drawing

To rasterize a vector drawing, use the Rasterize Method of ImGearVectPage Class. This creates a copy of the drawing in bitmap form. For example:

C#
if (igPage is ImGearVectorPage)
    igPage = ((ImGearVectorPage)igPage).Rasterize();

To control the size of the rasterized bitmap, you can do one of following:

  • Before loading the vector drawing, set the Width filter control parameter of the format filter used to load the drawing to the desired width of the rasterized image in pixels. (The height will be calculated automatically based on the aspect ratio of the drawing.)
  • Call the Resize Method of ImGearProcessing Class before calling Rasterize Method. This will let you to specify the rasterized dimensions in pixels.


Displaying and Manipulating Vector Data

Vector drawings are displayed using the normal ImageGear display methods. However, there is a specific API for controlling display and manipulation of the vector data. ImGearVectPage Class provides a property called VectorData Property, which returns an ImGearVectorData Class object that can be used to access a drawing's vector data. This object provides methods and properties for working with individual vector entities as well as controlling how the vector data is displayed. For the complete description of how to use the ImGearVectorData Class object, see ImageGear.Vector Namespace chapter.

Also see the C# Vector sample for a demonstration of the use of ImGearVectorData Class.

Working with Gradient Filling

Gradient filling properties are encapsulated in an ImGearVectorGradient Class. Objects of this class are attached to ImGearVectorFilltype Class objects.

There are two types of gradient filllings: linear and radial. They are represented by ImGearVectorGradientLinear Class and ImGearVectorGradientRadial Class, respectively.

Linear gradient is defined by its start and end points. Radial gradient is defined by a start point and an outer circle. Start point should be located inside the outer circle, but not necessarily in its center. Coordinates of the gradient can be absolute or relative (to the bounding rectangle of the entity that uses the gradient).

The color of the gradient is defined by an array of stops. A stop comprises a pair of offset and color. Stop offsets are relative to gradient coordinates. 0.0 corresponds to the start point, 1.0 corresponds to the end points, in the case of a linear gradient, or to a point at the outer circle, in the case of radial gradient. If the first stop offset is greater than 0.0, or the last stop offset is less than 1.0, the gradient is expanded according to its Spread method. Gradient color is linearly interpolated between the stops.

Gradient filling can be transformed with an affine matrix.


Disposal of Vector Data

ImGearVectorData Class provides a standard .NET Dispose Method. It's recommended to call this method whenever vector data is no longer needed, such as when a vector drawing is being unloaded or replaced. If the Dispose Method is not called, the vector data will consume memory until .NET garbage collection occurs.


3D Visualization API

The classes ImGear3DVisualization Class, ImGear3DVisualizationVerifier Class and ImGearIsosurfaceOptions Class present a set of properties and methods for generating isosurface for 3D objects.

The 3D algorithm works on the set of images, that should comprise a 3D object, and generate an isosurface for 3D visualization. It allows the options of adding "cover-up" slices at both ends, and also limiting the surface depth to reduce the number of triangles in the isosurface. Both of these two options, along with a few others, can be passed to the algorithm through an object of type ImGearIsosurfaceOptions Class.

Usually, you need to create an object of class ImGearIsosurfaceOptions Class to store the values of options to be passed to the isosurface algorithm. There is no need to explicitly instantiate any object for class ImGear3DVisualization Class, since the only public function in class ImGear3DVisualization Class, GenerateIsosurface Method, is a static function. Class ImGear3DVisualization Class also has a static member Verifier Property of type ImGear3DVisualizationVerifier Class, that can be used to check whether an ImGearDocument Class can be used to calculate isosurface from. The user should use this Verifier Property instead of instantiating such an object.

The algorithm itself takes an ImGearDocument Class object as the data source, so there is no limitation as far as the image format is concerned. It is the user's responsibility to somehow read data from the images and store them in an ImGearDocument Class object. It is important to make sure that the slices of images in the ImGearDocument Class are in the desired order as it would be in the 3D object.

This algorithm generates an ImGearVectPage Class as the result, in which the vertices of triangles together with the normals at those vertices are included. This ImGearVectPage Class should be associated with an ImGearVectorView Class object in order to visualize it.

C#
// Declare an ImGearDocument object and load it with data.
ImGearDocument igDocument = new ImGearDocument();
// ......
// Load images into igDocument
// ......
// Call function CanApplyGenerateIsosurface() on igDocument to
// check whether it is suitable for the algorithm
if (!ImGear3DVisualization.Verifier.CanApplyGenerateIsosurface(igDocument))
{
    // Show some error message regarding this fact that igDocument
    // is not suitable
    return;
}
// Instantiate an object of type ImGearIsosurfaceOptions for the
// options to be passed to the algorithm
ImGearIsosurfaceOptions isoOptions = new ImGearIsosurfaceOptions();
// Set the values for the members of isoOptions, usually, a
// dialog should be presented for the end user to set/modify these
// options
isoOptions.IsoValue = 120.0; // the intensity of pixels on the surface,
// this needs to be determined BEFOREHAND.
isoOptions.IsDoNorms = true;
/// .....
// Call function GenerateIsosurface to generate the isosurface
ImGearVectPage igVectPage = ImGear3DVisualization.GenerateIsosurface(igDocument, isoOptions);

For a complete sample program, please see the "Medical" sample for .


Using ImageGear.Web.Forms Namespace

ImageGear.Web.Forms Namespace, which is also named ImageGear WebForms toolkit, provides you with objects that allow image viewing, processing, and annotating through the internet.

ImageGear WebForms namespace functionality is based on ImGearWebPageView Class control. It is an ASP.NET server control. It allows you to display images on the client computer within a browser window. This object is fully integrated with the main API, which makes all of ImageGear functionality available for viewing on the client computer.

ImageGear WebForms toolkit also provides:

  • Real-time client-side scrolling.
  • Server-based zooming
  • Server-based interface to ImageGear.NET API
  • The Selection tool that allows a user to draw a selection rectangle over the image. The selected rectangle coordinates are passed to the server code and can be processed by the application, or used for auto zooming within the selected rectangle.
  • The possibility of an easy migration of imaging functionality from the desktop applications to the internet applications.

ImageGear WebForms toolkit provides the following two types of API:

  • Server-Side API
  • Client-Side API


Server-Side API

Server-side API of ImageGear WebForms toolkit consists of ImGearWebPageView Class, and ImGearSelectEventArgs Class, SelectEventHandler Delegate and ImGearSelectionMode Enumeration that are fully described in ImageGear.Web.Forms Namespace Chapter.

The most important properties of ImGearWebPageView Class control are ImagePage Property and PageDisplay Property. They allow the application to load and process images and control display settings.

ImGearWebPageView Class object also implements IImGearScrollableView Interface. This provides programmatic access to scrolling features of the control.

SelectionMode Property and Select Event of ImGearWebPageView Class object as well as ImGearSelectEventArgs Class API, SelectEventHandler Delegate and ImGearSelectionMode Enumeration allow to manipulate selection rectangle.

NOTE: Server-side API of the ImGearWebPageView Class is very similar to API of the ImGearPageView Class control. This allows you to transfer easily your imaging functionality code from desktop applications to internet applications.


Client-Side API

Client-side API provides the means for handling control rendering errors.

You can override the onerror method of the ImGearWebPageView Class javascript object to provide custom client-side Error Handling.


Error Handling

There are two possible cases where errors can occur, when you use ImGearWebPageView Class object.

  • When you use or ImGearWebPageView Class API calls. When there is an error, you will receive an exception (ImGearException Class object). You can catch this exception and handle it as you prefer in your server-side code.
  • During control initialization, rendering or unloading. In this case you can not catch error in your server-side code. Instead, WebForms toolkit encodes the error information and sends it to the client. On the client, by default, ImGearWebPageView Class JavaScript object pops up a message box with error description. You can override default error handler in the JavaScript client code to provide custom error handling, for example, put a error message to the web page.


Partial-Page Updates with AJAX

The ImageGear WebForms toolkit is compatible with ASP.NET AJAX 2.0 partial-page updates and the UpdatePanel control. This allows the application to update the displayed image, as well as handle selection events with server-side code, without needing to do a full page postback. By using this technique, the application can offer a more responsive and seamless user interface. Note that the use of AJAX is optional, and an application can pick and choose when to use a full-page synchronous postback versus an asynchronous partial-page update. The WebForms AJAX sample demonstrates both situations, using asynchronous postbacks for everything except the Upload button, which triggers a full-page postback.

The key to using AJAX with the ImageGear WebForms toolkit is to place an ImGearWebPageView Class control inside the content area of an UpdatePanel control. If you're not familiar with the UpdatePanel control, refer to the ASP.NET AJAX documentation for a tutorial and detailed information. Basically, the UpdatePanel control is a container that lets an application easily take advantage of AJAX without having to worry about the implementation details of asynchronous communication and partial page updates. The purpose of the UpdatePanel is to identify an area of the page that can be updated in a partial page update. In this case, page content outside of the UpdatePanel control is not processed or communicated over the network.

When an ImGearWebPageView Class control is inside an UpdatePanel control, it can be updated in several ways. It will be updated as usual in the event of a synchronous full-page postback. It can also be updated if another control triggers an asynchronous postback that includes the UpdatePanel control containing it. Finally, it can be updated during an asynchronous postback by server-side code that calls the UpdatePanel control's Update method. This is useful in event handlers such as the ImGearWebPageView Class control's Select event.

The ImGearWebPageView Class control's Select event triggers an asynchronous postback when the ImGearWebPageView Class control is inside an UpdatePanel control. The server-side event handler can then choose whether or not to update the ImGearWebPageView Class control by calling or not calling the UpdatePanel control's Update method. This is particularly important when the ImGearWebPageView Class control's SelectionMode property is set to ImGearSelectionMode.FireAndZoom. In such a case, the Select event handler must call the UpdatePanel control's Update method in order to achieve the fire-and-zoom functionality.

The WebForms AJAX sample demonstrates updating the ImGearWebPageView Class control and providing a user interface using asynchronous postbacks. It consists of a single ImGearWebPageView Class control hosted in its own dedicated UpdatePanel control. Since the ImGearWebPageView Class control is inside this UpdatePanel control, its Select event triggers an asynchronous postback. Asynchronous postbacks are also triggered for this UpdatePanel by any controls inside the TabContainer control which are configured to initiate a postback, such as Button and DropDownList controls. The Upload button is a special case. It's configured to trigger a full-page postback because the FileUpload control used to allow the user to upload an image file is not compatible with asynchronous postbacks.

In summary, to build an AJAX-enabled web application using the ImageGear WebForms toolkit, place the ImGearWebPageView Class control inside an UpdatePanel control. Then add other controls to the web page, either inside the same UpdatePanel control or outside it but defined as triggers for the UpdatePanel control. Set these controls to initiate postbacks, typically done by setting their AutoPostBack property to True. These postbacks will be asynchronous by default. In the event handlers for these controls, use the ImGearWebPageView Class control to change the display settings or image content. These changes will automatically be made visible as the ImGearWebPageView Class control is updated along with the UpdatePanel control. When working with event handlers for the ImGearWebPageView Class control itself, be sure to call the containing UpdatePanel control's Update method if an update is desired.


Using ImageGear.Windows.Forms Namespace

The ImageGear.Windows.Forms Namespace provides common GUI functionality that can simplify development of Windows Forms based applications. This functionality is implemented in a separate assembly, using only public ImageGear API, with source code provided to enable modifications.


The GUI Magnifier Window

The ImGearMagnifier Class control provides a magnified view of a portion of the image in ImGearPageView Class control. It appears either in a separate, stationary window, or as a popup area within the ImGearPageView Class window. When the GUI Magnifier control is active, and the user drags the mouse within the ImGearPageView Class control, the magnified display of the image tracks the location of the mouse. If the popup view is used, the magnified display of the image tracks the mouse within the ImGearPageView Class control. The programmer can set the magnification factor, and can optionally expose that capability to the end user. If the separate, stationary window is used, the area of the image that is displayed in the floating window is displayed in reverse video in the ImGearPageView Class control. A scroll bar is provided in the magnify window. When the user drags this magnify window scroll bar, ImageGear automatically changes the magnification factor.


The GUI Pan Window

The GUI Pan Control allows the visible portion of an image displayed in the ImGearPageView Class control to be moved by dragging the mouse around in the image. Optionally, a floating window can be used to display the complete image, scaled to fit within the floating window. By dragging the mouse within this floating window, the image in the ImGearPageView Class control is repositioned. The portion of the image that is visible in the ImGearPageView Class control is displayed within the floating window in reverse video.


Using ImageGear.Windows.Forms.Thumbnail Namespace

The ImageGear.Windows.Forms.Thumbnail Namespace provides the following GUI window:


The GUI Thumbnail Window

The GUI Thumbnail Control provides the ability to work with thumbnail images displayed on a thumbnail browser window. Every thumbnail is associated with the ImGearThumbnailItem Class object, which contains full information about the image. The collection of ImGearThumbnailItem Class objects is implemented within the ImGearThumbnailCtl Class class.

When the application program runs, the thumbnail browser will appear as a series of image buttons on the window.

There are 4 ways that an application interacts with the GUI Thumbnail control:

  • Loading: when thumbnail items are being loaded
  • Sorting: when the thumbnail items are being re-sequenced on the display
  • Selecting: when the user clicks on a thumbnail item
  • Dragging: when the user drags a thumbnail item to a new position in the display

Loading

The thumbnail items are created in response to calls to DirectoryAppend Method, FileAppend Method, PageAppend Method, or DocumentAppend Method. The thumbnail items can also be created in response to the user dragging and dropping a file-icon from Windows Explorer onto the ImGearThumbnailCtl Class control. This will cause the BeforeLoad and AfterLoad event handlers to be called exactly as if FileAppend Method had been called.

Sorting

The thumbnail items are displayed unsorted by default. The application can re-sequence them by calling Sort. The call to Sort can specify that the items should be sorted by title (ascending or descending), or that a custom sort-sequence can be provided. The custom sort sequence is implemented via a SortComparer interface.

Selecting

When the user clicks on a thumbnail item in the display, any of several things will happen (depending on the way that ImGearThumbnailCtl Class properties are set, and how the mouse-button is used):

Left-click the mouse button to select an item under the cursor. If the MultiSelect Property value is set to false, then all other items are deselected. Left mouse double clicking fires an event with the Index parameter set to the item being clicked. If this parameter is equal to -1 then the cursor is outside any thumbnail image. Typically, this event causes the application to load the corresponding image into the main program window.

Click the right mouse button to show the thumbnail magnifier if the ShowMagnify Property has been set to true. Releasing the right button will hide the magnifier.

ImGearThumbnailCtl Class will automatically change the appearance of the selected thumbnail item, as per the SelectionBackColor Property and SelectionForeColor Property.

The application can also apply a different appearance to selected thumbnail items, called "Highlighting" them. Each thumbnail item has a Highlighted Property that can be set by the application. When Highlighted is set, the thumbnail item's appearance is determined by the HighlightBackColor Property and HighlightForeColor Property.

NOTE: ImGearThumbnailCtl Class supports MultiSelect. If the MultiSelect Property is set to True, then the user can select multiple thumbnail items at a time (using Ctrl-left-click and Shift-left-click).

Dragging

ImGearThumbnailCtl Class control supports internally implemented Drag and Drop operations that can be enabled or disabled via DragDropOptions Property. If the ImGearDragDropOptions Enumeration.Drag flag is set then the thumbnail browser will operate as a source of file Drag operation. If the ImGearDragDropOptions Enumeration.Drop flag is set then the thumbnail browser will be able to receive the image files via Drop operation.


Using ImageGear.WPF Namespace

The ImageGear.WPF Namespace provides functionality for compatibility with the Windows Presentation Foundation framework, which is a new user interface subsystem and API based on XML and vector graphics available on Windows Vista.

NOTE: ImageGear WPF Sample requires Visual Studio 2005 extensions for .NET Framework 3.0 or later to be installed. It can be downloaded from the Microsoft web site and installed as an extension plug-in to Visual Studio 2005.

The following are the major parts of the ImageGear.WPF namespace:

  • BitmapSource Interface
  • HD Photo Format
  • XAML GUI Controls and Templates


BitmapSource Interface

BitmapSource is the basic building block of the WPF imaging pipeline, conceptually representing a single, constant set of pixels at a certain size and resolution. A BitmapSource could be a single frame in an image file that a decoder provides, or it could be the result of a transform that operates on a BitmapSource of its own. BitmapSource is not used to represent a multi-frame image or an animation.

ImageGear.WPF Namespace provides an interface to convert between WPF BitmapSource and ImGearPage Class objects.


HD Photo Format

ImageGear.WPF Namespaceprovides a read/write support HD Photo file format. See the ImageGear Imaging Formats Reference chapter for information.


XAML GUI Controls and Templates

ImageGear.WPF Namespace implemented two XAML configurable template based GUI controls: Thumbnail and Magnifier.

Thumbnail

WPF Thumbnail control is similar to the one provided by ImageGear.Windows.Forms Namespace, but it can be easily configured using the following XAML templates:

  • ImGearThumbnailCtl
  • ThumbnailListBoxStyle
  • ThumbnailListBoxItemStyle
  • ImGearThumbnailItem

ImGearThumbnailCtl

The following template defines ImGearThumbnailCtl Class style and consists of ScrollViewer with binding, ScrollBarVisibility dependency propery, and ListBox control with another binded property (SelectionMode), items source (ItemsSource="{Binding Path = Thumbnails}") and overidden styles, called ThumbnailListBoxItemStyle for generic items and ThumbnailListBoxStyle for ListBox itself.

  <Style TargetType="{x:Type local:ImGearThumbnailCtl}
    <Setter Property="HorizontalAlignment" Value="Stretch"/>
    <Setter Property="VerticalAlignment" Value="Stretch"/>
    <Setter Property="Template
      <Setter.Value>
        <ControlTemplate TargetType="{x:Type local:ImGearThumbnailCtl}
          <ScrollViewer
            VerticalScrollBarVisibility="{Binding ScrollBarVisibility}"
            HorizontalScrollBarVisibility="Disabled"
            Background ="{Binding Background}
            <ListBox
                IsSynchronizedWithCurrentItem="True"
                Name="ThumbnailListBox"
                SelectedIndex="0"
                SelectionMode="{Binding SelectionMode}"
                Style ="{StaticResource ThumbnailListBoxStyle}"
                ItemsSource="{Binding Path = Thumbnails}"
                ItemContainerStyle =
"{StaticResource ThumbnailListBoxItemStyle}"
                >
            </ListBox>
          </ScrollViewer>
        </ControlTemplate>
      </Setter.Value>
    </Setter>
  </Style>

ThumbnailListBoxStyle

The following template defines a style that determines what type of panel is used in the Thumbnail control. It is a WrapPanel by default. User can overwrite this style in his application to use StackPanel, Panel etc, using given properties (like Margin, Background in current implementation). In this case it is necessary to overwrite main style for thumbnail control to set ListBox Style property to newly created style.

<Style TargetType="{x:Type ListBox}" x:Key="ThumbnailListBoxStyle
    <Setter Property="Template
      <Setter.Value>
        <ControlTemplate TargetType="{x:Type ListBox}
          <WrapPanel IsItemsHost="True" Orientation="Horizontal"
                     Background="{Binding Background}"
                     Margin="{Binding Margin}"
                     ItemWidth="{Binding CellSize.Width}"
                     ItemHeight="{Binding CellSize.Height}
          </WrapPanel>
        </ControlTemplate>
      </Setter.Value>
    </Setter>
  </Style>

ThumbnailListBoxItemStyle

The following template is used to cancel default selection drawing, because there is a special selection/highlighting logic in the Thumbnail control.

 <Style TargetType="{x:Type ListBoxItem}" x:Key="ThumbnailListBoxItemStyle
    <Setter Property="Template
      <Setter.Value>
        <ControlTemplate TargetType="{x:Type ListBoxItem}" >
          <ContentPresenter
            VerticalAlignment="Top"
            HorizontalAlignment="Left"/>
        </ControlTemplate>
      </Setter.Value>
    </Setter>
  </Style>

ImGearThumbnailItem

The following template is used by framework to show ImGearThumbnailItem Class in any Panel control. This data template is only related to ImGearThumbnailItem Class data type and doesn't depend on the container type. ImGearThumbnailItem Class data template consists of shadow, border, image and label.

  <!-- Thumbnail Template -->
  <DataTemplate DataType="{x:Type local:ImGearThumbnailItem}
    <Grid
      VerticalAlignment="Top"
      HorizontalAlignment="Left"
      Margin="0"
      >
      <!-- Drop Shadow -->
      <Border
        VerticalAlignment="Top"
        HorizontalAlignment="Left"
        Width="{Binding ParentCtl.ItemWidth}"
        Height="{Binding ParentCtl.ItemHeight}"
        CornerRadius="{Binding ParentCtl.BorderWidth}"
        Background="#55000000"
        Visibility="{Binding ParentCtl.ShadowsVisibility}"
        >
      <!-- Drop Shadow shift and blur effect-->
        <Border.RenderTransform>
          <TranslateTransform X="{Binding ParentCtl.ShadowWidth}" Y="{Binding
ParentCtl.ShadowWidth}" />
        </Border.RenderTransform>
        <Border.BitmapEffect>
          <BlurBitmapEffect Radius="{Binding Path=ParentCtl.ShadowWidth}" />
        </Border.BitmapEffect>
      </Border>
      <!-Border (select and highlight)-->
      <Border
        x:Name="IGThumbnailSelectionBorder"
        VerticalAlignment="Top"
        HorizontalAlignment="Left"
        BorderThickness="{Binding ParentCtl.BorderWidth}"
        BorderBrush="{Binding CurrentBackground}"
        CornerRadius="{Binding ParentCtl.BorderWidth}"
        Background="White"
        Width="{Binding ParentCtl.ItemWidth}"
        Height="{Binding ParentCtl.ItemHeight}
          <StackPanel Orientation="Vertical" Margin=
"{Binding ParentCtl.Interior}
              <!-Thumbnail image-->
            <Image Width="{Binding ParentCtl.ImageSize.Width}"
                   Height="{Binding ParentCtl.ImageSize.Height}"
                   VerticalAlignment="Center"
                   HorizontalAlignment="Center"
                   Source ="{Binding Image}"/>
  <!--Title-->
            <Label Content="{Binding Title}"
                   HorizontalAlignment="Center"
                   VerticalAlignment="Center"
                   Foreground ="{Binding CurrentForeground}"
                   Visibility ="{Binding ParentCtl.TitlesVisibility}"
                   >
            </Label>
          </StackPanel>
       </Border>
    </Grid>
</DataTemplate>

Magnifier

WPF magnifier control is similar to the one provided by ImageGear.Windows.Forms Namespace, but it can be easily configured using the following XAML templates:

  • ImGearMagnifierCtl
  • ImGearMagnifierPopUpCtl

ImGearMagnifierCtl

The following template defines ImGearThumbnailMagnifierCtl Class control. Since ImGearMagnifierCtl Class is an invisible control, its template consists of placeholder and resource section that contains a visual template for ellipse magnifier. Note that this style is turning on in code-behind, so it must be in resource section to find it there.

<Style TargetType="{x:Type local:ImGearMagnifierCtl}
    <Setter Property="HorizontalAlignment" Value="Left"/>
    <Setter Property="VerticalAlignment" Value="Top"/>
    <Setter Property="Visibility" Value="Collapsed"/>
    <Setter Property="Template
      <Setter.Value>
        <ControlTemplate TargetType="{x:Type local:ImGearMagnifierCtl}
  <!--Resources-->
          <ControlTemplate.Resources>
     <!--Style for ellipse popup magnifier-->
            <Style TargetType="{x:Type local:ImGearMagnifierPopUpCtl}"
x:Key="EllipseMagnifier
              <Setter Property="HorizontalAlignment" Value="Left"/>
              <Setter Property="VerticalAlignment" Value="Top"/>
              <Setter Property="Template
                <Setter.Value>
                  <ControlTemplate
TargetType="{x:Type local:ImGearMagnifierPopUpCtl}
                    <Grid>
                      <Path x:Name="Path"
Width="{Binding ParentCtl.PopupWidth}"
Height="{Binding ParentCtl.PopupHeight}"
Stretch="Fill" StrokeLineJoin="Round"
Stroke="#55000000" Fill="#55000000" >
                        <Path.Data>
                          <EllipseGeometry x:Name="EllipseGeom"
                    Center="100,100"
RadiusX="{Binding ParentCtl.PopupWidth}" RadiusY="{Binding ParentCtl.PopupHeight}"/>
                        </Path.Data>
                      </Path>
                      <StackPanel ClipToBounds="True
                        <Image HorizontalAlignment="Center"
Source="{Binding ParentCtl.MagnifiedImage}
                          <Image.Clip>
                            <EllipseGeometry
Center="{Binding Center}"
RadiusX="{Binding ImageRadius.Width}" RadiusY="{Binding ImageRadius.Height}"/>
                          </Image.Clip>
                        </Image>
                      </StackPanel>
                    </Grid>
                  </ControlTemplate>
                </Setter.Value>
              </Setter>
            </Style>
          </ControlTemplate.Resources>
<!--Placeholder-->
          <Border Background="Indigo" CornerRadius="3
            <Label>ImGearMagnifierCtl Control</Label>
          </Border>
        </ControlTemplate>
      </Setter.Value>
    </Setter>
  </Style>

ImGearMagnifierPopUpCtl

The following template defines style for popup rectangle magnifier window. Consists of border and image that is binded to MagnifiedImage Property of ImGearMagnifierCtl Class.

<Style TargetType="{x:Type local:ImGearMagnifierPopUpCtl}
    <Setter Property="HorizontalAlignment" Value="Left"/>
    <Setter Property="VerticalAlignment" Value="Top"/>
        <Setter Property="Template
          <Setter.Value>
            <ControlTemplate TargetType="{x:Type local:ImGearMagnifierPopUpCtl}
              <Border
                BorderBrush="#55000000"
                CornerRadius="3"
                BorderThickness="3"
                Background="#55000000"
                Width ="{Binding ParentCtl.PopupWidth}"
                Height="{Binding ParentCtl.PopupHeight}
                <Image Source="{Binding ParentCtl.MagnifiedImage}"/>
              </Border>
            </ControlTemplate>
          </Setter.Value>
        </Setter>
  </Style>

Pan

WPF Pan control is similar to the one provided by ImageGear.Windows.Forms Namespace, but it can be easily configured using the following XAML templates:

ImGearPanCtl

The following template defines ImGearPanCtl Class control.

<Style TargetType="{x:Type local:ImGearPanCtl}">
    <Setter Property="HorizontalAlignment" Value="Left"/>
    <Setter Property="VerticalAlignment" Value="Top"/>
    <Setter Property="Visibility" Value="Collapsed"/>
    <Setter Property="Template">
        <Setter.Value>
            <ControlTemplate TargetType="{x:Type local:ImGearPanCtl}">
                <ControlTemplate.Resources>
                </ControlTemplate.Resources>
                <Border Background="Indigo" CornerRadius="3">
                    <Label>ImGearPanCtl Control</Label>
                </Border>
            </ControlTemplate>
        </Setter.Value>
    </Setter>
</Style>


Software License Agreement

YOUR INSTALLATION, USE AND DISTRIBUTION OF THIS SOFTWARE PRODUCT ("THE PRODUCT") SIGNIFIES YOUR ACCEPTANCE OF THE TERMS OF THIS LICENSING AGREEMENT BETWEEN YOU ("LICENSEE") AND PEGASUS IMAGING CORPORATION, A FLORIDA CORPORATION WITH ITS PRINCIPAL PLACE OF BUSINESS AT 4001 NORTH RIVERSIDE DRIVE, TAMPA, FL 3360371 ("PEGASUS IMAGING")

Article 1: Definitions.

Section 1.0. Defined Terms. Terms defined in this Article 1 shall have the meanings given below. Defined terms may be used in the singular or plural.

Section 1.1. "Agreement" means this Software License Agreement, which includes this Agreement's terms and conditions, Order Forms, Schedules, Exhibits, Addenda, and Amendments, if any, which are incorporated in, and form an integral part of, this Agreement.

Section 1.2. "Application" means only the software application program or programs developed by Licensee (and all versions and releases thereof) that contain a copy of, and is linked to, the Product's Distributable Files.

Section 1.3. "Business Day" means a day or part of a day when Pegasus Imaging is open for business, excluding Saturdays, Sundays, official United States federal holidays, state holidays, and Pegasus Imaging holidays.

Section 1.4. "Confidential information" means any data or information, oral or written, that relates to either party's (or, if either party is bound to protect the confidentiality of any other person's information, such other person's) past, present, or future research, development or business activities, including any unannounced product(s) and service(s), and including any information relating to services, developments, inventions, processes, plans, financial information, customer lists, forecasts, and projections, including the terms of this Agreement.

Section 1.5. "Develop" or "Development" means the development of one or more Applications by Licensee that contain a copy of the Product's Distributable Files.

Section 1.6. "Distributable File" means those files contained in the Product that may be distributed with Licensee's Application, as defined in Section 1.2. The list of Distributable Files for each Product is identified in the documentation that accompanies each Product.

Section 1.7. "Distribute" or "Distribution" means the distributing, deploying, selling, reselling, leasing, renting, licensing, lending or any other act whereby Licensee distributes the Application to an End User, whether such End User is internal or external to Licensee.

(a) "External Distribution" means that the Application containing the product is distributed for any reason other than internal distribution.

(b) "Internal Distribution" means that the Application containing the Product is not distributed for either commercial use or for sale (or resale), and is for use by End Users who are employees, interns, or contract employees of Licensee.

Section 1.8. "Distribution Method" means the method by which Licensee's End User accesses the Distributable Files. A Distribution Method may include one or more of the following:

(a) "Client/Server" means the End User is permitted to install the Distributable File on a Server specifically designated to host the Application from which a fixed number of Named or Concurrent Users can access the Application at any one time.

(b) "Concurrent User" means the End User is permitted to have (i) a fixed number of simultaneous individual users who are authorized to use the Application, or (ii) a multiple number of individual users who can sequentially use the Application on one single computer or workstation (i.e. a "kiosk model").

(c) "Named User" means the End User is permitted to have only one single, named individual user who is authorized to use one copy of the Application on a single personal computer.

(d) "Server" means the End User is permitted to install the Distributable File on a networked processor specifically designated to process one or more instances of the Application by (i) individual users via a single computer or workstation, (ii) non-user computers for automated tasks (a "Process Machine") (for example, batch imaging conversion processing, printer server processing, etc.), or (iii) a client applet server accessible via a web browser (a "Web Server").

Section 1.9. "End User" means the person or entity to which Licensee distributes the Application for use in the ordinary course of its business, and not for re-distribution or resale by such person or entity.

Section 1.10. "Installation" means the act of installing the Product on any system.

Section 1.11. "Licensing Fees" mean the fees identified in the Order Form that are mutually agreed to by Pegasus Imaging and Licensee.

Section 1.12. "Order Form" means the order form, or other such document prescribed by Pegasus Imaging, that details the Product(s), quantities, fees, and term of this Agreement and is executed by both parties.

Section 1.13. "Product" means the software product or products, including any accompanying documentation, identified in the Order Form and licensed by Pegasus Imaging under this Agreement.

Section 1.14. "Supplier" means any software product or products, including any accompanying documentation, licensed by Pegasus Imaging for use and distribution in the Product.

Section 1.15. "Term" means the period of time of this Agreement, as identified in the Order Form.

Article 2: Scope of License.

Section 2.1. Evaluation License. If the Product installed by Licensee is for evaluation purposes only, Pegasus Imaging grants Licensee a license solely for the purpose of sampling and evaluating such Product for the timeframe specified in the evaluation period. No other rights, including but not limited to the rights stated in Sections 2.2 and 2.3, are applicable to evaluation copies of the product.

Section 2.2. Development License. Subject to the terms and conditions set forth in this Agreement, Pegasus Imaging grants Licensee a non-exclusive, non-transferable, worldwide license to use the Product on a single machine, and incorporate all or portions of the Distributable Files into one or more Applications for Distribution by Licensee. Unless otherwise agreed to in writing by the parties, no more than one developer is authorized to use one single Product, and the Product is not to be used concurrently or on a site-wide basis, via a server or other networked connection. Licensee may make one copy of the Product for backup or archive purposes. If Licensee desires to have more than one developer use the Product, Licensee must purchase additional development licenses from Pegasus Imaging.

Section 2.3. Distribution License. Subject to the terms and conditions set forth in this Agreement, Pegasus Imaging grants Licensee a non-exclusive, non-transferable, worldwide license to distribute to End Users (either directly or indirectly) a copy of one or more distributable files in any applications developed pursuant to Section 2.2 by the Distribution Method identified on the Order Form during the Term of the Agreement. The Licensing Fee for a Distribution License will vary depending on the type or subtype of Distribution Method and the quantities licensed. If Licensee distributes more licenses than it has pre-purchased, as identified on the Order Form, Licensee's purchase of such additional licenses shall be subject to the terms and conditions set forth in Article 3 of this Agreement.

Section 2.4. Licensee shall distribute the Distributable Files in object code form only. No license or other right is granted to Licensee with respect to any of the Product's source code. Licensee shall not alter, modify, disassemble, decompile or reverse engineer the Product in any way or manner.

Section 2.5. Licensee shall distribute the Application to its resellers, OEMs, or other distribution channels only pursuant to a written agreement that binds the resellers, OEMs, or other distribution channels to comply with the terms and conditions of Articles 2 and 5 of this Agreement.

Section 2.6. Licensee shall distribute the Application to its End Users only pursuant to a written agreement that prohibits the End User from Distributing, creating, copying, duplicating, re-distributing, disassembling, decompiling, reverse engineering, or sublicensing the Product, and shall use its best efforts to ensure the same.

Section 2.7. Licensee may distribute the Application only if the Application:

(a) operates solely on the hardware and operating system(s) for which the Product is intended to be used;

(b) does not extend access to the Product's application programming interface (API);

(c) includes within the executable object files of all copies of the Product, including all Distributable Files, Pegasus Imaging's patent, copyright, trademark and proprietary notices; and

(d) recognizes Pegasus Imaging's copyright ownership in the Application initialization screen or "About Box", and/or in the documentation for the Application as follows: Imaging Technology provided under License by Pegasus Imaging Corporation. ImageGear © 1996-2008. All Rights Reserved." Italics are not required. This requirement is not applicable if Licensee's internal application has neither an initialization screen nor an "About Box."

Section 2.8. If Licensee's Application is intended for external distribution, Licensee's Application shall also:

(a) not compete to any degree with the Product. Such competitive products are defined as imaging software development toolkit intended for use by application programmers and/or system integrators;

(b) be substantially greater in scope with greater functionality and features than those of the Product;

(c) not be a software development toolkit or provide a software development environment to the End User, and

(d) recognize Pegasus Imaging's copyright ownership in the Application initialization screen (or "About Box") and/or in the documentation for the Application as follows: Imaging Technology provided under License by Pegasus Imaging Corporation. ImageGear © 1996-2008. All Rights Reserved." Italics are not required.

Section 2.9. As required by United States export regulations, Licensee shall not permit export of the Product, or any direct products thereof, to any country to which export is then controlled by the United States Bureau of Export Administration, unless Licensee has that agency's prior written approval. Licensee shall require its End Users to comply with the provisions of this Section.

Section 2.10. If Licensee (or Licensee's End User) is an office, branch or agency of the U.S. Government, then its use, duplication and disclosure of the Product or any part thereof, shall be subject to the following additional requirements: The Product is a "commercial item," as such term is defined in 48 C.F.R. 12.101 (Oct. 1995), consisting of "commercial computer software" and "commercial computer software documentation," as such terms are used in 48 C.F. 12.212 (September 1995). Consistent with 48 C.F.R. 12.212 and 48 C.F.R. 227.7202-1 through 227.7202-4, the U.S. Government End Users acquire the Product and/or Application with only those rights set forth in this section.

Section 2.11. Pegasus Imaging reserves the right to include in the Product one or more software devices to ensure that Licensee's use of the Application is consistent with the use identified in the Order Form, and does not exceed the maximum number of fixed licenses granted by Pegasus Imaging, if any.

Article 3: Fees and Reporting.

Section 3.1. Licensee shall pay to Pegasus Imaging all Licensing Fees due for all copies of the Application containing the Distributable Files licensed and Distributed by Licensee. All Licensing Fees are payable in U.S. dollars and are non-refundable.

Section 3.2. Timely payment of the Licensing Fee permits Licensee to use the Product, and Distribute its Application (either directly or indirectly) to End Users. For U.S. based Licensees, payment is due 30 days from the date of the invoice. For all other Licensees, payment is due in full prior to or contemporaneously with the licensing of the Product. Late payment charges shall be imposed on all outstanding balances for each month or portion thereof that the outstanding balance remains unpaid, at the rate of 1.5% per month or the maximum rate permitted by law for such charge.

Section 3.3. Where required by law, Pegasus Imaging will collect from Licensee, and Licensee is responsible to pay for, sales and all other taxes associated with the order, unless Pegasus Imaging is provided a valid and correct tax exemption certificate prior to order acceptance. The payment of such tax is the sole responsibility of Licensee.

Section 3.4. Licensee understands and acknowledges that in order to receive bulk discount pricing for distribution Licensing Fees, it must pre-pay for such licenses. In the event that Licensee Distributes more licenses than it has purchased, or distributes by a Distribution Method not stated on the Order Form, Licensee shall pay Pegasus Imaging's then-current quantity-one pricing for each copy distributed over the number licenses purchased. Quantity-one pricing is defined as the fee associated with purchasing one (1) distribution license.

Section 3.5. Licensee shall inform Pegasus Imaging in writing within thirty (30) days after the date of the first shipment of copies of the Application. Thereafter, Licensee shall complete a License Distribution Report (or other such Distribution Fee statements provided by Pegasus Imaging) each calendar quarter stating the number of Distribution Licenses distributed during each Disclosure Period and estimating the number of Distribution License that may be used during the next Disclosure Period. An authorized officer of Licensee shall sign all such License Distribution Reports.

Section 3.6. Upon Pegasus Imaging's request, at mutually agreeable times no more frequently than once annually, an auditor chosen by Pegasus Imaging shall be provided reasonable access during normal business hours to the relevant records of Licensee for the purpose of an audit of Distribution Fees due. Such records shall include, without limitation, information concerning copies of the Application made and distributed and other information necessary to verify the payments and amounts due Pegasus Imaging hereunder. Pegasus Imaging shall maintain in confidence any proprietary information of Licensee obtained during the course of such audit. The results of any such audit shall be final and dispositive. If the auditor's report indicates an underpayment of more than 10% for any auditing period, Licensee shall pay the full cost of the audit, and pay Pegasus Imaging the balance due within thirty (30) days from presentation of the report.

Article 4: Support.

Section 4.1. For one year after Licensee's purchase or installation of the Product (pursuant to Section 2.2 of this Agreement), whichever is earlier, Pegasus Imaging shall provide Licensee with the level of product support and maintenance identified on the Order Form. A copy of each of Pegasus Imaging's various product support and maintenance levels may be found in the on-line help section included with the Product. If no such product support and maintenance is identified, the Product does not come with support.

Section 4.2. Licensee agrees that, within thirty days of its release of any Application built with the Product, it will provide Pegasus Imaging with two (2) copies of such Application for support purposes. Pegasus Imaging's use of such Application will be limited to providing support to Licensee, and shall be governed by the provisions of Article 7 of this Agreement.

Article 5: Intellectual Property.

Section 5.1. Licensee recognizes and acknowledges the exclusive right of Pegasus Imaging (and its Suppliers) in and to all patents, trademarks, service marks, trade names, copyrights, and other intellectual property and proprietary rights in and to the Product, and that such patents, trademarks, service marks, trade names, copyrights, and other intellectual property and proprietary rights are the sole and exclusive property of Pegasus Imaging and its Suppliers.

Section 5.2. Licensee waives its right to contest any of Pegasus Imaging's or its Supplier's patents, trademarks, service marks, trade names, copyrights, and other intellectual property and proprietary rights in and to the Product.

Section 5.3. Licensee shall not use such trademarks, service marks, and trade names except where permitted under this Agreement without receiving Pegasus Imaging's prior written approval of such use. If such approval is granted, Licensee's right to use such trademarks, service marks, and trade names shall end upon the termination of this Agreement.

Article 6: Confidentiality.

Section 6.1. Licensee shall remain in exclusive control of the Product, including but not limited to, the physical media, downloads, sample code, and documentation. The parties agree that neither party shall disclose or otherwise make available any confidential information provided to it by the other party. Unless otherwise agreed to by the parties, the scope of this Section shall be given the broadest interpretation possible and shall include, but not be limited to, the terms and conditions of this Agreement, the Order Form, and pricing.

Section 6.2. The obligations of non-disclosure in Section 6.1 shall not apply to information that (i) is publicly available or in the public domain at the time disclosed; (ii) is, or becomes, publicly available or enters the public domain through no fault of the party receiving such information; (iii) is rightfully communicated to the recipient by persons not bound by confidentiality obligations with respect thereto; (iv) is already in the recipient's possession free of any confidentiality obligations with respect thereto at the time of disclosure; (v) is independently developed by the recipient; (vi) is approved for release or disclosure by the disclosing party without restriction, (vii) is required by a court of competent jurisdiction.

Article 7: Term and Termination.

Section 7.1. Unless otherwise agreed to by the parties, this Agreement shall become effective upon its execution by both parties, and shall continue in full force and effect until terminated in accordance with the terms set forth in the Order Form or this Agreement.

Section 7.2. In the event that Licensee materially breaches this Agreement, or ceases business or is adjudged bankrupt or insolvent, then Pegasus Imaging may, at its option, terminate this Agreement, by giving ten (10) Business Days written notice of such termination, which notice shall identify and describe the basis for such termination. If, prior to expiration of such period, Licensee cures such default, termination shall not take place.

Section 7.3. In the event of any termination of this Agreement, Licensee shall stop manufacturing and Distributing the Application containing a copy of the Distributable Files, and require its resellers, OEMs, and other distribution channels (if any) to likewise stop manufacturing and Distributing the Application containing a copy of the Distributable Files. Within ten (10) Business Days thereafter, Licensee shall return or, at Pegasus Imaging's option, destroy the Product and all copies in whole or in part thereof, whether or not incorporated in or with the Application, and within Licensee's possession, custody and control, and shall certify to Pegasus Imaging in writing within ten (10) Business Days thereafter that it has complied with the foregoing obligation.

Section 7.4. For external distributions, the termination of this Agreement shall not affect any rights of End Users to use the Application if such copies were shipped prior to the termination of this Agreement. So long as Licensee's external distributions to End Users and the End Users' use of the Application conforms to the terms and conditions set forth in this Agreement, the End User's rights to use the Product as incorporated into the Application shall be perpetual.

Section 7.5. Articles 1, 5, 6, 7, 8 and 9 shall continue in full force and effect, notwithstanding any such termination of this Agreement.

Article 8: Limited Warranty.

Section 8.1. Pegasus Imaging represents and warrants that it has full power and authority to enter into this Agreement, and has sufficient right, title, and interest in the Product to enter into this Agreement.

Section 8.2. Licensee understands and acknowledges that the Product, although functionally complete, has not been extensively tested by Pegasus Imaging or its Suppliers as to the correctness or speed of operation in Licensee's Application. Although Pegasus Imaging will make reasonable efforts to correct any material nonconformity between the Product and its then-current documentation that is brought to Pegasus Imaging's attention with written, documented reports from Licensee, PEGASUS IMAGING AND ITS SUPPLIERS DO NOT AND CANNOT WARRANT THE RESULTS OBTAINED BY USING THE PRODUCT. Pegasus Imaging's entire liability and Licensee's exclusive remedy under this Agreement shall be to provide reasonable support services.

Section 8.3. THE PRODUCT IS PROVIDED "AS IS." PEGASUS IMAGING AND ITS SUPPLIERS SPECIFICALLY DISCLAIM ANY AND ALL WARRANTY TO LICENSEE OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, PERFORMANCE RESULTS AND NON INFRINGEMENT. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE PRODUCT IS WITH LICENSEE.

Section 8.4. IN NO EVENT WILL PEGASUS IMAGING OR ITS SUPPLIERS BE LIABLE TO LICENSEE FOR ANY DAMAGES, INCLUDING LOST PROFITS, LOST SAVINGS, OR OTHER INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING FROM THE USE OR INABILITY TO USE THE PRODUCT EVEN IF IT HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY CLAIM BY ANY OTHER PARTY. Some states or jurisdictions do not allow the exclusion or limitation of incidental, consequential or special damages, or the exclusion of implied warranties, or limitations on how long an implied warranty may last, so the above limitations may not apply to Licensee. To the extent permissible, any implied warranties are limited to thirty (30) days. This warranty gives Licensee specific legal rights. Licensee may have other rights which vary from state to state or jurisdiction to jurisdiction.

Section 8.5. The warranty extended in this Article extends only to Licensee, and shall not apply to any other person or entity including, but not limited to, Licensee's End Users.

Article 9: General Provisions.

Section 9.1. Pegasus Imaging and Licensee warrant that they have the requisite authority to enter into this Agreement.

Section 9.2. This Agreement constitutes the entire understanding and agreement between Pegasus Imaging and Licensee regarding its subject matter, and supercedes all previous oral and written communications, agreements, memoranda, representations, or understandings between Pegasus Imaging and Licensee regarding this Agreement. No other rights or licenses are granted to Licensee, except as expressly provided herein.

Section 9.3. This Agreement shall not be amended, altered, changed or modified in any way, unless agreed to in writing by both Pegasus Imaging and Licensee. Such writing must be executed by a duly authorized representative of Pegasus Imaging and a duly authorized representative of Licensee.

Section 9.4. This Agreement is not transferable or assignable by Licensee under any circumstances, without the prior written consent of Pegasus Imaging. Pegasus Imaging will not unreasonably withhold such consent. This agreement shall be binding upon, and is made for the benefit of, each party, its successors, and permitted assignees (if any). For the purposes of this Agreement, any change in control of Licensee shall constitute an assignment or transfer of this Agreement. As used in this section, a change in control is defined as (i) any change in ownership of more than fifty percent (50%) of the voting interest in Licensee, whether by merger, purchase, foreclosure of a security interest or other transaction, or (ii) a sale of all or substantially all of the assets of Licensee.

Section 9.5. The relationship established by this Agreement between Licensee and Pegasus Imaging shall be that of licensee and licensor. Nothing contained in this Agreement shall be construed as creating a relationship of agency, joint venture or partnership between Licensee and Pegasus Imaging. Neither party shall have any right whatsoever to incur any liabilities or obligations on behalf of the other party.

Section 9.6. The laws of the Commonwealth of Massachusetts shall govern this Agreement, excluding that body of law known as conflict of laws and the United Nations Convention on Contracts for the Sale of Goods. Any action or proceeding brought by either party against the other arising out of, or related to, this Agreement shall be brought only in a state or federal court of competent jurisdiction located in the Commonwealth of Massachusetts and the parties hereby consent to the personal jurisdiction of said courts.

Section 9.7. In the event that any provision of this Agreement is found invalid or unenforceable pursuant to a judicial decree or decision, the remainder of this Agreement shall remain valid and enforceable according to its terms.

Section 9.8. Pegasus Imaging's failure to perform any term or condition of this Agreement as a result of conditions beyond its control such as, but not limited to, war, strikes, fires, floods, acts of God, governmental restrictions, power failures, or damage or destruction of any network facilities or servers, shall not be deemed a breach of this Agreement.

Section 9.9. In the event of suit or any legal action due to any breach of this Agreement is commenced to enforce this Agreement or otherwise relating to this Agreement, the prevailing party shall be entitled to all attorneys' fees and costs incurred in connection therewith.

Section 9.10. The headings provided in this Agreement are for convenience and reference purposes only. In the event of a conflict between the terms and conditions listed in Articles 1 through 10, and the attached Schedules, the terms and conditions shall govern.

Section 9.11. A waiver of a breach, violation, or default under this Agreement shall not be a waiver of any subsequent breach, violation or default. Failure of either party to enforce compliance with any term or condition of this Agreement shall not constitute a waiver of such term or condition.

Section 9.12. All notices and communications shall be in writing and shall be deemed to have been duly given when delivered or three (3) Business Days after mailing by certified mail, return receipt requested, postage prepaid, addressed to the parties at their respective addresses set forth on the Order Form or at such other addresses as the parties may designate by written notice in accordance with this section.

Section 9.13. The Order Form, and any amendments or addenda to this Agreement, may be executed in counterparts, each of which will be considered an original, but all counterparts together will constitute one agreement. A facsimile of a signed copy of this Agreement, or an electronic or other digital signature imprinted on this Agreement, may be relied upon as an original.


Schedule A: Additional Terms and Conditions Applicable to Adobe® Technology

1. Adobe Technology

If Licensee's use and distribution of the Product includes Adobe Technology and related documentation, the term "Product" as defined in Section 1.13 of the Agreement includes Adobe Technology and related documentation, and any upgrades, modified versions, updates, additions, and copies thereof.

2. Font License.

If the Product includes font software, Licensee may embed the font software, or outlines of the font software, into its Application to the extent that the font vendor copyright owner allows for such embedding. The fonts contained in this package may contain both Adobe and non-Adobe owned fonts. Licensee may fully embed any font owned by Adobe.

3. Limited Warranty

ARTICLE 8 OF THE AGREEMENT STATES THE SOLE AND EXCLUSIVE REMEDIES FOR PEGASUS IMAGING'S BREACH OF WARRANTY. EXCEPT FOR THE FOREGOING LIMITED WARRANTY, ADOBE AND ITS SUPPLIERS MAKE NO WARRANTY, EXPRESS OR IMPLIED, AS TO MERCHANTABILITY, FITNESS FOR ANY PARTICULAR PURPOSE, OR NON-INFRINGEMENT. IN NO EVENT WILL ADOBE OR ITS SUPPLIERS BE LIABLE TO LICENSEE FOR ANY CONSEQUENTIAL, INCIDENTAL OR SPECIAL DAMAGES, INCLUDING ANY LOST PROFITS OR LOST SAVINGS, EVEN IF AN ADOBE REPRESENTATIVE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY CLAIM BY ANY THIRD PARTY. Some states or jurisdictions do not allow the exclusion or limitation of incidental, consequential or special damages, or the exclusion of implied warranties, or limitations on how long an implied warranty may last, so the above limitations may not apply to Licensee. To the extent permissible, any implied warranties are limited to thirty (30) days. This warranty gives Licensee specific legal rights. Licensee may have other rights which vary from state to state or jurisdiction to jurisdiction.

4. Trademarks.

Adobe and Adobe PDF Library are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States and/or other countries.


Schedule B: Additional Terms and Conditions Applicable to MIT's FFTW Technology

1. FFTW Technology

If Licensee's use and distribution of the Product includes FFTW Technology, please note that the FFTW technology is provided to Pegasus Imaging under a copyright license from the Massachusetts Institute of Technology (MIT).

2. Disclosure of Customer's Information

If Licensee informs Pegasus Imaging that is desires to license the FFTW technology, Pegasus Imaging is required to notify MIT of Licensee's name and contact information. Additionally, upon request from MIT, Pegasus Imaging may be required to provide MIT with a copy of this specific licensing agreement. MIT shall treat all this information as confidential information of the Pegasus Imaging.

3. Termination.

In the event MIT terminates its FFTW copyright license with Pegasus Imaging, Licensee's rights to use the FFTW technology may be affected as follows:

a. If Licensee is the End User of the Product (e.g. the Application is for Licensee's internal use only), and has no rights to sublicense or distribute the Product, Licensee's right to continued use of the FFTW technology within the Product shall not be affected by such termination.

b. If Licensee is a Sublicensee of the Product, and has the rights to sublicense or distribute Product containing the FFTW technology, Licensee shall be required to contact MIT directly to procure the appropriate level of licensing. By Agreement, Pegasus Imaging is required to provide MIT with a list of all customers who have sublicensing or distribution rights. All such information is deemed confidential in the Pegasus Imaging-MIT Agreement.

c. However, Licenses of derivative works created by Licensee shall survive the termination of this Agreement, so long as Licensee understands that MIT specifically disclaims any and all warranties in relation to the derivative works, and that Licensee, in its License Agreement, specifically disclaim any and all warranties by MIT. in relation to the derivatives to the full extent permitted by law and limit MIT's liability for damages related to the derivatives to the full extent permitted by law.

4. Limited Warranty

ARTICLE 8 OF THE AGREEMENT STATES THE SOLE AND EXCLUSIVE REMEDIES FOR PEGASUS IMAGING'S BREACH OF WARRANTY. THIS ARTICLE SHALL BE SUPERSEDED BY THE FOLLOWING: MIT MAKES NO WARRANTY, EXPRESS OR IMPLIED, AS TO MERCHANTABILITY, FITNESS FOR ANY PARTICULAR PURPOSE, OR NON-INFRINGEMENT. IN NO EVENT WILL MIT OR ITS SUPPLIERS BE LIABLE TO LICENSEE FOR ANY CONSEQUENTIAL, INCIDENTAL OR SPECIAL DAMAGES, INCLUDING ANY LOST PROFITS OR LOST SAVINGS, EVEN IF AN MIT REPRESENTATIVE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY CLAIM BY ANY THIRD PARTY. Some states or jurisdictions do not allow the exclusion or limitation of incidental, consequential or special damages, or the exclusion of implied warranties, or limitations on how long an implied warranty may last, so the above limitations may not apply to Licensee. To the extent permissible, any implied warranties are limited to thirty (30) days. This warranty gives Licensee specific legal rights. Licensee may have other rights which vary from state to state or jurisdiction to jurisdiction.


Schedule C: Additional Terms and Conditions Applicable to Microsoft's XPS Functionality

1. Microsoft's Technology

If Licensee's use and distribution of the Product includes Microsoft's XPS Functionality (as defined below), please note that the XPS Functionality technology is provided to Pegasus Imaging under a royalty free copyright license from Microsoft. XPS Functionality includes the following:

a. Microsoft's XPS Essentials Pack;

b. Microsoft's MSXML 6.0; and

c. Microsoft's Windows Desktop 4.0 Search Preview.

2. XPS Technology License

Under the terms of Microsoft's various licensing agreements, Pegasus Imaging has a perpetual, royalty-free license to redistribute the XPS functionality to the Licensee. However, if Licensee desires to Externally Distribute such XPS Functionality to its End Users, Licensee is required to download directly the XPS Functionality prior to any such External Distribution.

3. Limited Warranty

ARTICLE 8 OF THE AGREEMENT STATES THE SOLE AND EXCLUSIVE REMEDIES FOR PEGASUS IMAGING'S BREACH OF WARRANTY. EXCEPT FOR THE FOREGOING LIMITED WARRANTY, MICROSOFT AND ITS SUPPLIERS MAKE NO WARRANTY, EXPRESS OR IMPLIED, AS TO MERCHANTABILITY, FITNESS FOR ANY PARTICULAR PURPOSE, OR NON-INFRINGEMENT. IN NO EVENT WILL ADOBE OR ITS SUPPLIERS BE LIABLE TO LICENSEE FOR ANY CONSEQUENTIAL, INCIDENTAL OR SPECIAL DAMAGES, INCLUDING ANY LOST PROFITS OR LOST SAVINGS, EVEN IF AN ADOBE REPRESENTATIVE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY CLAIM BY ANY THIRD PARTY. Some states or jurisdictions do not allow the exclusion or limitation of incidental, consequential or special damages, or the exclusion of implied warranties, or limitations on how long an implied warranty may last, so the above limitations may not apply to Licensee. To the extent permissible, any implied warranties are limited to thirty (30) days. This warranty gives Licensee specific legal rights. Licensee may have other rights which vary from state to state or jurisdiction to jurisdiction.

4. Trademarks.

Microsoft and the components of the XPS Functionality are either registered trademarks or trademarks of Microsoft in the United States and/or other countries.


Software Support and Maintenance Policy

Getting Support

Benefits of Registering your Development Kit

Purchasers of development kits need to register with Pegasus in order to be notified of updates and receive support now or in the future. Registration is automatic when purchased directly from the Pegasus web site. If purchased through a Pegasus re-seller, please register your purchase by filling out the form at PegasusImaging.com/registration.htm.


Vehicles for Support

Samples

Samples are included in the downloaded installation. The product installation program installs a common sample folder accessible via the Start Menu.

Web Support

Visit the Pegasus Imaging web site frequently asked questions page PegasusImaging.com/faq.htm for the fastest answers to common questions. The web site also provides other support options that are accessible at PegasusImaging.com/supportagree.htm.

E-mail Support

Both pre-sale and post-sale e-mail support is offered free of charge. Questions are answered on a First-Come-First-Served basis. Support@JPG.com responds instantly to e-mail received with a helpful set of locations to find additional information on Pegasus products including FAQ's, sample code and other current information pertaining to the use of the products. The support request is then added to the queue of outstanding requests. The goal of the support team is to respond to each e-mail within 1 business day.

The sales team is always available as a backup to the support team. If you feel you have an urgent support or sales issue please contact Sales@JPG.com. They will assist you promptly.

On-Demand Phone Support

On-demand priority phone support can be purchased in 15 minute increments with a credit card via the Pegasus Imaging Corporation web site Support, General Info page. If you decide to purchase "on-demand" phone support, instructions will immediately be e-mailed upon receipt of your purchase.

1. Chariot Support

All Pegasus Imaging customers are given the opportunity to purchase a Chariot Support agreement. This is a maintenance and upgrade agreement that entitles customers to priority e-mail service, direct phone support from the support and development staff and free product upgrades for the covered products. Since upgrades are included for Chariot customers at no additional charge, Chariot customers can frequently save money, plus obtain the benefits of phone and expedited support. Pegasus Imaging reserves the right to change the terms of this service at any renewal period. Contact Sales via the web at PegasusImaging.com/contactform.htm for more information.

2. Galleon Support

Customers are given the opportunity to purchase Galleon Support for Pegasus Imaging products that are applications and for products that require run time licensing. Galleon Support includes licensing of product upgrades for deployed installations at no additional license fee cost. Pegasus Imaging reserves the right to change the terms of this service at any renewal period. Contact Sales via the web at PegasusImaging.com/contactform.htm for more information.

3. Atlas Support

All Pegasus Imaging customers are given the opportunity to purchase an Atlas Support agreement on currently supported products. This is an agreement that entitles customers to priority e-mail service and direct phone support from the support and development staff. It differs from Chariot Support in that it does not include version upgrades free of charge. Pegasus Imaging reserves the right to change the terms of this service at any renewal period. Contact Sales via the web at PegasusImaging.com/contactform.htm for more information.

For the latest and most up-to-date support information, access PegasusImaging.com/contactsupport.htm.


Glossary

This glossary contains a mixture of terminology used by AccuSoft in both its software products and its documentation. Since these terms come from many different disciplines and because many of the terms have different meanings in each discipline, each glossary entry is followed by the name of the field from which the definition is taken.

For a detailed description, refer to the references listed in the Bibliography.

To find terms which start with a numeral (0-9), look under its spelling, for example, the term "8-bit gray level" can be found as - "eight bit gray level."

ImageGear Licensing and Deployment Kit Terminology is listed separately.

absolute coordinates (imaging)

Absolute coordinates refer to a common origin, for example, the upper left corner of a display screen. This is the opposite of relative coordinates.

ACCUAPI (AccuSoft)

AccuSoft Application Program Interface.

See Also:

API (software)

additive primary colors (imaging)

Red, Green, Blue - the 3 colors used to create all other colors when direct, or transmitted light is used (as in a video monitor). They are called additive primaries, because when these three colors are superimposed they produce white.

anti-aliasing (imaging)

A method of filling in data that is missing due to under-sampling. In imaging, this usually involves the process of removing jagged edges by interpolating values in-between pixels of contrast. These methods are most often used to remove or reduce the stair-stepping artifact found in digital high contrast images.

AOI (Image Processing)

Area Of Interest. An area of interest is a rectangle within an image defined as two points within the image. An AOI can be written as (x1,y1)-(x2,y2). All AOIs are parallel with the image's axes.

See Also:

ROI (AccuSoft image processing)

API (software)

Application Programmer's Interface. The set of routines that make up a library or toolkit. Some times called a binding.

aspect ratio (imaging)

The proportion of an image's size given in terms of the horizontal length verses the vertical height. An aspect ratio of 4:3 indicates that the image is 4/3 times as wide as it is high.

Bezier curve (graphics)

A curve created from endpoints and two or more control points that serve as positions for the shape of the curve. Originated by P. Bezier (~1962) for the use in car body descriptions.

bit block transfer

A raster operation that moves a block of bits representing a portion of an image or scene from one location in the frame buffer to another. Usually written as "bit blt".

bin (image processing)

See Also:

histogram (imaging)

Bit Block Transfer (Windows)

An optimized movement of a large block of computer memory from one location to another. Used for moving images or sub-images to and from areas of computer memory.

bitmap (imaging)

An image is a bitmap if it contains a value for each of its pixels. This is the opposite of vector images where a small set of values generate an object.

bit plane (imaging)

A hypothetical 2-D plane containing a single bit of memory for each pixel in a image. If each 8-bit pixel is thought of as a stack of 8 coins, and an image as many rows and columns of these stacked coins then the 3rd bit plane would be the plane consisting of the 3rd coin from each stack.

bounding rectangle (geometry)

The smallest rectangle that fits around a given object. In imaging, the rectangle is usually rotationally restricted to be parallel to both image axes.

.BMP (file format extension)

Format originator: Microsoft Corporation

16011 NE 36th Way, Box 97917

Redmond, WA 98073

Call-back function (software)

A function that is passed to another function as a parameter. The function receiving the call-back function can call this function. This is used to change the behavior of a given routine without knowing beforehand what it is expected to do.

Cartesian coordinates (imaging)

A 2-dimensional equally spaced grid iron that uniquely assigns every point in the plane, (one and only one), co-ordinate pair; (x, y). In imaging, each point is usually referred to as a pixel and the x and y values take on integer values. Most images use the top-left as the (0,0), or origin.

See Also:

coordinates

Chroma-key (image processing)

An image blending function that replaces pixels of a specified hue range with pixels from a second image. This is often referred to the weatherman effect because most weather forecasters use a solid blue or green background to make it look as if they are standing in front of a huge weather map. It is important to remember that it is the hue that is used in the blending function and not the intensity or saturation.

C.I.E (color imaging)

Commission Internationale de l'Eclairage. (International Commission of Illumination). A standards organization which provides specifications for the description of device independent color.

clipboard (Windows)

The clipboard is a windows data structure used to exchanged data between applications. It is a common area where applications place data and others can access it. These operations are usually referred to as Cut (place data in) and Paste (take data out).

closing (image processing)

See Also:

morphology (image processing)

CMY & CMYK

Cyan, Magenta, Yellow, (K) black. Computer monitors are additive, but color printers are subtractive. Instead of combining light from monitor phosphors, printers coat paper with colored pigment that removes specific colors from the illumination light.

CMY is the subtractive color model that corresponds to the additive RGB model. Cyan, magenta, and yellow are the color complements of red, green, and blue. Due to the difficulties of manufacturing pigments that produce black when mixed together, a separate black ink is often used and is referred to as K (`B' is already used for blue).

color map (imaging)

See Also:

Look-Up-Table (computer hardware)

color model (imaging)

See Also:

color space (imaging)

color space (imaging)

A mathematical coordinate system (space) for assigning numerical values to colors. There are many ways to define such spaces, each with its own benefits and problems.

See Also:
  • CMY & CMYK
  • HIS (color imaging)
  • HLS (color imaging)
  • HSV (color imaging)
  • RGB (imaging)
  • YIQ (color imaging)

compression (imaging)

An image processing method for saving valuable disk and memory space by reducing the amount of space required to save a digital image. The graphics data is rewritten allowing it to be represented by a smaller set of data. Do not confuse this with encoding. See "lossless (image compression)" on page -322 and "lossy (image compression)" on page -322.

compression ratio (imaging)

The ratio of a file's uncompressed size over its compressed size.

concave (geometry)

A 2-dimensional blob, for example, a region of interest (ROI), where at least one tangent is drawn that touches the blob at two different locations, and there is a point on the tangent between the two contacts that does not touch the blob.

In simpler words, if a rubber band could be snugly wrapped around a concave blob there would be places where the rubber band lifts off and does not touch the blob. Concave is the opposite of convex.

convex (geometry)

A 2-dimensional blob, for example, a region of interest (ROI), where every tangent that can be drawn touches the blob at a continuous stretch of the blob's surface with no gaps.

In simpler words, if a rubber band could be snugly wrapped around a convex blob there would be no places where the rubber band lifts off and is not touching the blob. Convex is the opposite of concave.

convolution (image processing)

An image processing operation that is used to spatially filter an image. A convolution is defined by a kernel that is a small matrix of fixed numbers. The size of the kernel, the numbers within it, and a single normalizer value define the operation that is applied to the image. The kernel is applied to the image by placing the kernel over the image to be convolved and sliding it around to center it over every pixel in the original image.

At each placement the numbers (pixel values) from the original image are multiplied by the kernel number that is currently aligned above it. The sum of all these products is tabulated and divided by the kernel's normalizer. This result is placed into the new image at the position of the kernel's center. The kernel is translated to the next pixel position and the process repeats until all image pixels have been processed.

As an example, a 3x3 kernel holding all `1's with a normalizer of 9 performs a neighborhood averaging operation. Each pixel in the new image is the average of its 9 neighbors from the original.

coordinates

A pair of numbers that represent a specific location in a two-dimensional plane, for example, an image or on a map.

See Also:
  • absolute coordinates (imaging)
  • device coordinates (imaging)
  • Cartesian coordinates (imaging)
  • polar coordinates (imaging)
  • relative coordinates
  • screen coordinates (imaging)
  • world coordinates

crop (Imaging)

An image processing method for removing the region near the edge of the image, but keeping the central area.

.DCX (file format extension)

Format originator: Intel

DDB (Windows)

Device Dependent Bitmap. A Window image specification that depends on the capabilities of a specific graphics display controller. Since a DDB is matched to the current graphics controller, it is fast and easy to display since large blocks of memory need only be copied to the controller.

See Also:

DIB (Windows)

decompression (imaging)

When an image or other digital data set is compressed and stored, it is not usable until it is decompressed into it original form.

device coordinates (imaging)

The co-ordinates of the coordinate system that describe the physical units that defines the computer screen.

device dependent (software)

Software written to work on a specific set of hardware platforms. Since these routines make use of physical device attributes, they may behave differently on other devices, although they will most often not work on other devices.

See Also:

device independent (software)

DIB (Windows)

device driver (software)

A set of low-level software routines that work with and control a specific hardware device. The names and functions are often standardized across many similar devices. This allows higher level software to use the hardware as a generic device. This frees the higher-level software from dealing with the particulars of specific devices and allows devices to be interchanged.

device independent (software)

Software or data structures that are designed to work with or on a wide set of hardware platforms. See device-dependent and DIB.

DIB (Windows)

Device Independent Bitmap is a Windows-defined image format specification. It is called device-independent because of its straightforward, common-denominator, format. It has all the information that a basic digital image needs and is laid out in a simple specification. Its simplicity makes it an ideal format for holding images that need to be shared by several programs.

See Also:

DDB (Windows)

dilation (image processing)

See Also:

morphology (image processing)

dithering (imaging)

The method of using neighborhoods of display pixels to represent one image intensity or color. This method allows low-intensity resolution display devices to simulate higher resolution images. For example, a binary laser printer can use block patterns to display grayscale images. See Halftone.

DLL (Microsoft Windows)

Dynamic Linked Library. A compiled and linked collection of computer functions that are not directly bound to an executable. These libraries are linked at run-time by Windows. Since Windows is in charge of managing (loading, linking, and removing) the DLLs, they are available to all executables currently running. Each executable links to a shared DLL saving memory by avoiding redundant functions from co-existing. DLLs allow a new level of modularity by providing a means to modify and update executables without re-linking. Just copy a new version of the DLL to the correct disk directory.

DPI (printing)

Dots Per Inch. The number of printer dots that can be printed in one inch. The printer's resolution is defined by the number of dots per inch: lower resolution = less dots per inch, higher resolution = more dots per inch.

edge (image processing)

In an image, an edge is a region of contrast or color change. Edges are useful in machine vision since optical edges often mark the boundary of physical objects.

edge detection (image processing)

A method that isolates and locates an optical edge in a digital image.

edge map (image processing)

An edge map is the output of an image-processing filter that transforms an image into an image where intensity represents a change in the contrast (optical edge) of the original image.

(eight) 8 bit image (digital imaging)

An image where each pixel has 8-bits of information. An 8-bit pixel contains one of 256 possible values. There are two common types of 8-bit images: grayscale and indexed color.

In a grayscale image, each pixel takes one of 256 shades of gray and the shades are linearly distributed from 0 (black) to 256 (white). An 8-bit grayscale image does not require a palette but may have one.

An indexed color image is always a palette image. Each pixel is used as an index to the palette. These images can have up to 256 different colors. This includes hues as well as shades. Indexed 8-bit images are good for low color resolution images that do not need processing. They are 3 times smaller than full-color RGB images, but because the pixel values are not linear, many image-processing algorithms cannot work with them. They must be promoted to 24-bit for image processing.

8-bit gray level (AccuSoft term)

This indicates 8-bit grayscale. 8-bit gray level is used to distinguish between 8-bit indexed color (8i) and 8 bit grayscale. An 8-bit gray level DIB image is one where each pixel in the bitmap is unchanged by its palette when displayed. Each palette entry is the same as its index.

8i (AccuSoft term)

This indicates 8-bit indexed color. 8i is used throughout this manual to distinguish between 8-bit grayscale (8-bit gray level) and 8-bit indexed color. An 8-bit indexed color DIB is one where each 8-bit pixel value in the bitmap is used as an index to the palette.

The palette dictates which RGB color the pixel displays. These images are compact ways of storing color images. However they are difficult to process because the bytes that make up the pixel can no longer be ordered with any certainty.

Encoding

The format for storing uncompressed data (binary, ASCII, etc.), how it is packed (e.g. 4-bit pixels may be packed at a rate of two pixels per byte), and the unique set of symbols used to represent the range of data items.

.EPS (file format extension)

Format originator: Adobe Systems, Inc.

1585 Charleston Road

Mountain View, CA 94039

equalize (image processing)

An image-processing algorithm that redistributes the frequency of image pixel values allowing equal representation for any given continuous range of values. In an ideal world, an equalized image has the same number of pixels in the range from 10-20 as it does from 200-210. However, since digital images have quantized intensity values, the range totals are rarely identical but usually close.

erosion (image processing)

See Also:

morphology (image processing)

file format (software)

A specification for holding computer data in a disk file. The format dictates what information is present in the file and how it is organized.

filter (image processing)

An image-processing filter is a transform that removes a specified quantity from an image. For instance a spatial filter removes high, medium or low spatial frequencies from an image.

(four) 4 bit image (digital imaging)

An image file format that allows 4-bits per pixel. This image can contain up to 16 (24) different colors or levels of gray.

frame (imaging)

A single picture, usually taken from a collection of images for example, a movie or video stream.

frame buffer (imaging hardware)

A computer peripheral that stores and sometimes manipulating digital images.

frame processes (image processing)

Image-processing algorithms that operate on a single image.

fx (imaging)

See Also:

special effects (image processing)

gain & level (imaging)

Gain and level are image-processing terms that correspond to the brightness and contrast control on a television. The gain is the "contrast", and the level is the "brightness." By changing the level, the entire range of pixel values are linearly shifted brighter or darker. Gain on the other hand linearly stretches or shrinks the intensity range, altering the contrast.

gamma correction (imaging)

A non-linear function that is used to correct the inherent non-linearities of cameras and monitors. The intensity of the luminescent phosphor on the raster display is non-linear. Gamma correction is an adjustment to the pixel intensity values that make up for this inherent non-linearity.

geometric transform (image processing)

A class of image processing transforms that alter the location of pixels. This class includes rotates and warps.

.GIF (file format extension)

Name: Graphics Interchange File Format

Format originator: CompuServe Inc.

500 Arlington Center Blvd.

Columbus, OH 43220

This format uses the LZW compression created by Unisys. It is the same as the LZW compression used in the TIFF file format, except that the bytes are reversed and the string table is upside-down.

All GIF files have a palette. Some GIF files can be interlaced - the raster lines can appear as every 4 lines, then every 8 lines, then every other line. This is due to GIF files usually being received from a modem.

GUI

Graphical User Interface. A computer-user interface that uses graphical objects and a mouse for user interaction, for example Microsoft Windows.

graphics library (software)

A collection of software routines that work on digital images. These collections usually contain routines for drawing various graphical objects, for example, lines, circles, and rectangles.

gray level (imaging)

A shade of gray assigned to a pixel. The shades are usually positive integer values taken from the grayscale. In an 8-bit image a gray level can have a value from 0 to 255.

grayscale (imaging)

A range of gray levels. Zero is usually black and higher numbers indicate brighter pixels.

group III Fax (Imaging compression)

A CCITT standard for transmission of facsimile data. It compresses black and white images using a combination of differential, run length and Huffman coding.

halftone (imaging)

The reproduction of a continuous-tone image on a device that does not directly support continuous output. This is done by displaying or printing a pattern of small dots that simulate the desired output color or intensity. These methods are used extensively in magazines and newspapers.

handle (software)

A handle references a data object. A handle is a type of pointer but it usually contains, internally, more information about the referenced object.

histogram (imaging)

A tabulation of pixel value populations displayed as a bar chart where the x-axis represents all the possible pixel values and the y-axis is the total image count of each given pixel value. A histogram counts how many pixels in the image have a given intensity value or range of values.

Each histogram intensity value or range of values is called a bin. Each bin contains a positive number that represents the number of pixels in the image that fall within the bin's range. A typical 8-bit grayscale histogram contains 256 bins. Each bin has a range of a single intensity value. Bin 0 contains the number of pixels in the image that have a grayscale value of 0 or black; bin 255 contains the number of white (255) pixels. When the collection of bins are sorted (0-255) and charted, the graph displays the intensity distributions of all the images pixels.

HLS (color imaging)

Hue Saturation, and Lightness. A method that describes any color as a triplet of real values. The hue represents the color or wavelength of the color. It is sometimes called tone and is commonly known as color. The hue is taken from the standard color wheel and is calibrated in degrees.

Saturation is the depth of the color. It states how gray the color is. It is a real valued parameter from 0.0 to 1.0 with 0.0 indicating full gray and 1.0 representing pure hue.

Lightness determines how black or white a color is. It ranges from 0.0 to 1.0 but with 0.0 representing black and 1.0 white. A lightness of 0.5 is a pure hue.

HSV (color imaging)

Hue, Saturation, and Value.

Huffman coding (image compression)

A method of encoding symbols that varies the length of the code in proportion to its information content. Groups of pixels that appear frequently in a image are coded with fewer bits than those of lower occurrence.

HIS (color imaging)

Intensity, Hue, and Saturation.

image format (image storage)

There are many digital image formats. Some of these are: TIFF, DIB, GIF, and JPEG. The image format specification dictates which image information is present and how it is organized in memory. Many formats support various sub-formats or `flavors'.

image processing

The general term "image processing" refers to a computer discipline wherein digital images are the main data object. This type of processing can be broken down into several sub-categories: compression, image enhancement, image filtering, image distortion, image display and coloring, and image editing.

See Also:

machine vision

indexed color image (imaging)

An image where each pixel value is used as an index to a palette for interpretation before the pixel is displayed. These images contain a palette that is initialized specifically for a given image. The pixel values are usually 8-bit and the palette 24-bit (8-red, 8-green, and 8-blue).

See Also:

(eight) 8 bit image (digital imaging)

invert intensity (image processing)

An image processing operation where each pixel is subtracted from the maximum pixel value allowed. This produces a photographic negative of the original. For an 8-bit image the inverse function is:

invert(pix) = 255-pix;

For an 8-bit RGB image the function is:

invert(Rpix) = 255-Rpix;

invert(Gpix) = 255-Gpix;

invert(Bpix) = 255-Bpix;

`jaggies' (imaging)

A term used to describe the visual appearance of lines and shapes in raster pictures that results from a grid of insufficient spatial resolution.

JPEG JFIF (image compression)

Joint Photographic Experts Group. A collaborative specification of the CCITT and the ISO for image compression. The standard JPEG compression algorithm, which is used by ImageGear, is a lossy compression scheme - it loses data.

See Also:

lossy (image compression)

.JPG (file format extension)

Format originator: Joint Photographics Experts Group

kernel (image processing)

A small matrix of pixels, usually no bigger that 9x9, that is used as an operator during image convolution. The kernel is set prior to the convolution in a fashion that emphasizes a particular feature of the image. Kernels are often used as spatial filters, each one tuned to a specific spatial frequency that the convolution is intended to highlight.

See Also:

convolution (image processing)

Lempel Ziff Welch (data compression)

A dictionary-based image compression method with lossless performance that results in fair compression ratios. Most files are compressed at 2:1.

level (imaging)

See Also:

gain & level (imaging)

library (software)

A collection of software functions that can be called upon by a higher level program. Most libraries are collections of similar routines, for example, those used for graphical or image processing.

See Also:

DLL (Microsoft Windows)

Look-Up-Table (computer hardware)

A look-up-table or LUT is a continuous block of computer memory that computes the values of a function for one variable. The LUT is set up for the function's variable to be used as an address or offset into the memory block. The value that resides at this memory location becomes the function's output. Because the LUT values need only be initialized once, LUTs are very useful for image processing due to their inherent high speed.

LUT[pixel_value] = f(pixel_value)

LUTs come in various widths, usually in units of bits. An nxm bit LUT has 2n addresses or 256 stored values. Each value is 2m bits wide.

If the second dimension is left off it can be assumed to be equal to the first. In grayscale image processing, LUTs are commonly 8x8, and the bit widths are usually assumed.

A linear LUT, sometimes called a NOP LUT or pass through, is a LUT that is initialized to output the same values as the input. NOP_LUT[pixel_value] = pixel_value.

See Also:

palette (digital imaging)

lossless (image compression)

A method of image compression where there is no loss in quality when the image is uncompressed. The uncompressed image is mathematically identical to its original. Lossless compression is usually lower in compression ratio than lossy compression.

lossy (image compression)

A method of image compression where some image quality is sacrificed in exchange for higher compression ratios. The amount of quality degradation depends on the compression algorithm used and by a user-selected quality variable.

LUT (computer)

Look-Up-Table.

See Also:

Look-Up-Table (computer hardware)

LUT transform (image processing)

A LUT transform is an image processing method that takes an image and passes each pixel, one at a time, through a pre-set LUT. Each new pixel is a function of one and only one pixel from the original image and is arranged in the same location.

Any image-processing algorithm that transforms a single pixel into another single pixel, both from the same location, can be performed quickly using a LUT.

Square_root_LUT[pixel_value] = sqrt(pixel_value)

See Look-Up Table

LZW (data compression)

Lempel Ziff Welch.

See Also:

Lempel Ziff Welch (data compression)

machine vision

A sub-discipline of artificial intelligence that uses video cameras or scanners to obtain information about a given environment. Machine vision processes extract information from digital images about objects in the image. This is the opposite of computer graphics that takes various data describing objects in and produces an output image. Machine vision takes an image in and outputs some level of description about the objects in it, (i.e. color, size, brightness).

See Also:

image processing

matrix operation (image processing)

See Also:

neighborhood process (image processing)

median filter (image processing)

An image spatial filtering operation based on an input pixel and its 8 neighbors. The resulting value is the median (5th from the sorted values). A median filter is often used to reduce spike or speckling noise from a grayscale image. It has the advantage over convolution smoothing - it better preserves edges.

morphing (image processing)

An imaging process where one image is gradually transformed into a second image, where both images previously existed. The result is a sequence of in-between images when played sequentially, as in a film loop show, give the appearance of the starting image being transformed to the second image.

Morphing is made up of a collection of image processing algorithms. The two major groups are: warps and blends. Do not confuse this with morphology.

morphology (image processing)

A neighborhood image-processing algorithm similar to image convolution except that Boolean logic is applied instead of arithmetic. There are two types of morphology, binary and grayscale. Both have similar operation but are carried out differently because of the data width. The four major operations are:

    • Erode - a filter that makes bright objects smaller.
    • Dilation - a filter that makes bright objects larger.
    • Opening - erosion followed by dilation.
    • Closing - dilation followed by rosion.

Do not confuse with morphing.

MPEG (image compression)

Motion Pictures Experts Group. An ISO specification for the compression of digital-broadcast quality full-motion video and sound.

neighborhood process (image processing)

A class of image-processing routines that works on neighborhoods of pixels. Each pixel in the new image is computed as a function of the neighborhood of the pixel from the original pixel. The neighborhood ID is defined by a kernel that is set once for each image to be processed.

See Also:

point process (image processing)

(one) 1 bit image (digital imaging)

An image comprised of pixels that contain only a single bit of information. Each pixel is either on or off. Normally, "on" is white and "off" is black.

opening (image processing)

See Also:

morphology (image processing)

overlay (imaging)

An image or sub-image that can be placed over a given image. The pixels from the original image are not altered but the overlay can be viewed as if they had been. Usually used to place temporary text and annotation marks, for example, arrows on a image.

packed bits (imaging)

A binary image is usually stored in computer memory (8 pixels per byte). In this case each byte is referred to as being filled with packed bits. This saves space but makes reading and writing any individual pixel harder since most computers cannot directly access memory in chunks smaller than a byte.

palette (digital imaging)

A digital image palette is a collection of 3 look-up-tables or "LUTs" that are used to define a given pixel's display color. One LUT is for red, one for green and one for blue. The number of entries in the LUTs depend on the width (in bits) of the image's pixels.

A palette image requires its palette in order to be displayed in a fashion that makes sense to the viewer. This is often the case for color 8-bit images. Without a palette describing what color each pixel needs for display, this type of image would most likely be displayed as randomly selected noise.

A grayscale palette is one where each of the 3 LUTs are linear. The output is whatever is input to them. Since each color component (R, G, B) is an equal value, any pixels input to them are displayed in a varying shade of gray.

See Also:

Look-Up-Table (computer hardware)

pattern recognition (imaging)

A sub-discipline of machine vision where images are searched for specific patterns. Optical character recognition or "OCR" is one type of pattern recognition, where images are searched for the letters of the alphabet.

.PCX (file format extension)

Format originator: ZSoft Corp.

450 Franklin Road Suite 100

Marietta, GA 30067

pixel (imaging)

An abbreviated version of the term PIcture (X) ELement. This is the most fundamental element of a digital image. A digital image is made up of rows and columns of points of light. Each indivisible point of light is a pixel. Each pixel in an image is addressed by its column (x) and its row (y) usually written as the coordinate pair (x, y). An 8-bit pixel can take on one of 256 values. A 24-bit pixel has 3, 8-bit components for each of the primary colors, red, green, and blue.

point process (image processing)

A class of image processing transforms where every pixel is taken, one at a time from an image, and mathematically transformed into a new value with no input from any other pixel in the image. A point process is a degenerative neighborhood process where the kernel is a matrix of pixels that is 1x1 or in other words a single pixel.

polar coordinates (imaging)

An alternative to the usual Cartesian method of addressing image pixels. Polar coordinates use the coordinate pair, angle and radius from an origin instead of column and row.

posterize (imaging)

A special effect that decreases the number of colors or grayscales in an image. The default image pixel contains 256 levels of gray or 256 levels of red, green, and blue. Using this effect reduces these numbers.

pseudocolor (image processing)

A method of assigning color to ranges of a grayscale image's pixel values. Most often used to highlight subtle contrast gradients or for visually quantifying pixel values. The applied color usually has no correspondence to the original scene. The colors are used only as a guide or highlight.

raster (imaging)

A term that describes a single row of a digital image. A raster image is made up of rows of pixels. This is opposed to vector images, where an image is made up of a list of polygon nodes. A raster is sometimes called a scan-line.

relative coordinates

Relative coordinates refer to position, as identified as the distance from a local origin.

render (imaging)

The process of displaying an image. The final and actual displayed image is said to be rendered.

resolution (imaging)

There are two types of resolution in digital images; spatial and intensity. Spatial resolution is the number of pixels per unit of length along the x and y axis. Intensity resolution is the number of quantized levels that a pixel can have.

RGB (imaging)

Red, Green, Blue. A triplet of numeric values that describe a color.

RGBQUAD

Red, Green, Blue, Quad. A set of four numbers used to describe a color. The forth number is always set to zero. This creates an efficient color LUT or palette. It is more efficient because most computers find multiplying by 4 easier then by 3, as is the case in an RGB triplet.

ROI (AccuSoft image processing)

Region Of Interest. A region of interest or ROI is a specification and date structure that allows for the definition of arbitrarily shaped regions within a given image, often called sub-images. A ROI can be thought of as a place holder which remembers a location within an image. ROIs are of several types, each defined in a manor that makes sense for its type.

ROIs are either a rectangle (also called an AOI), square, circle, or a segment list. A rectangle is defined by any two points in the image. From these two points one and only one rectangle can be drawn. A square is defined by a single point and a single length. A circle is defined by its center and radius. A segment list is an arbitrary list of triplets (x, y, xlen); a single point and a length to the right.

Every point in an image is either inside or outside of a given ROI.

Most image processing functions in this package work only within a given ROI. The ROI can encompass the entire image.

See Also:

AOI (Image Processing)

scan line (imaging)

See Also:

raster (imaging)

screen coordinates (imaging)

Screen coordinates are those of the actual graphics display controller. The origin is almost always at the upper left-hand corner of the display.

See Also:

coordinates

segment (imaging)

A contiguous section of a raster line. It is defined in physical coordinates by the triplet of its left most point and length (x, y, length).

skew (image processing)

A skew is image distortion that often occurs when a scanner is sampling an image and the image slides to either side before the scan is complete. This has the effect of transforming squares into rhombuses.

special effects (image processing)

Any image processing transform that is applied mostly for its artistic value. Special effects include, wipes, transitions, barn doors, etc.

stretch intensity (image processing)

An image processing method that takes a given image and assures that the intensity distribution fills the entire range of possible values. An 8-bit image that is stretched always has at least one pixel with a value of zero and one of 255. The term comes from the before and after histogram of the given image. A stretch operation linearly stretches a histogram so that is ranges from the minimum pixel value to the maximum pixel value.

.TGA (file format extension)

Format originator:Truevision, Inc.

7340 Shadeland Station

Indianapolis, IN 46255

TIFF (file format)

Tagged Image File Format.

.TIF (file format extension)

Format originator: Aldus Corp

411 First Ave South

Seattle, WA 98104, and

Microsoft Corp

16011 NE 36th Way

Redmond, WA 98073

thumbnail (imaging)

A small copy of an image. Thumbnails are used to display many images on the screen at once.

transform (image processing)

An algorithm that takes an image, alters it, and outputs a new image. Sometimes written as `xform'.

See Also:
  • point process (image processing)
  • neighborhood process (image processing)
  • geometric transform (image processing)

triplet (digital imaging)

Three numbers used together to represent a single quantity or location, for example, RGB or (x, y, z).

(twenty-four) 24 bit image (digital imaging)

A 24-bit image contains pixels made from RGB triplets.

video stream (video)

A sequence of still images that are transmitted and displayed in synchronous order that give the appearance of live motion.

warp (image processing)

A geometric image processing routine that distorts an image by spatially compressing and stretching regions.

world coordinates

The real valued coordinates that make sense for the object, treating it as if it really exists. The world coordinates of a house on a map would be in miles or longitude and latitude. This is the opposite of screen, device or model coordinates.

.WPG (file format extension)

Format originator: WordPerfect Corp

(x, y)

A mathematical method for referring to a pixel from a digital image. Since most digital images are maintained as a Cartesian matrix of pixels, each pixel has a unique address that can be described as an x or horizontal displacement from the origin and a y or vertical displacement from the origin.

See Also:

coordinates

xform

Shorthand for transform.

YIQ (color imaging)

(Y) luminance, (I), (Q). YIQ is the color model used for U.S. commercial television. It was designed to be backwards compatible with the old black and white television sets. "Y" or luminance is a weighted average of the red, green, and blue that gives more weight to red and green than to blue. The I and Q contain the color components. Together they are called chromoticity.

(Z)

A mathematical method that refers to a pixel's intensity from a digital image. An image can be written as: I(x,y)=z


ImageGear Licensing and Deployment Kit Terminology

Access Key

The key provided to the end user for licensing the application. Uniquely identifies each license issued by AccuSoft. You can only generate as many different access keys as the total number of deployment licenses purchased. One an access key needs to be associated with each end user's machine, you can choose to either: distribute access keys to end users explicitly, or use the Licensing Component to acquire access keys automatically behind the scenes.

Concurrent

Licenses that are co-used by a specific number of users and that are counted as 1 license.

Deployment Kit

A set of wizards and tools that help you license your applications.

Deployment Licensing Service

The Web service at AccuSoft that handles all licensing requests.

Deployment Packaging Wizard

The tool included in the Deployment Kit that helps you package the appropriate ImageGear runtime components.

Deployment Pool

Each solution can have several deployment pools associated with it. A Pool is a set of licenses of the same type. When a pool is set up, the product features, the deployment model, and other information are associated with it. All the licenses from the same pool have the same attributes, except for hardware parameters (if bound to hardware parameters).

Deployment Proxy Service

The Web service running at your site for proxying between the Deployment Licensing Service and the Licensing Component running on the end user's system.

End User

The customer using your application.

End User Licensing Utility

The Web application you use to generate license keys based on hardware keys.

Hardware Key

The key dynamically constructed on the end user's machine by combining the access key and hardware parameters of the machine. Obtained on the end user's machine by combining the access key and the hardware parameters of the end user system. This typically happens during an installation process using the Licensing Component.

ImageGear Runtime Components

The ImageGear runtime components that are licensed for deployment with your application.

License Key

The key containing information about ImageGear licensed features and hardware parameters of the target machine (if bound to hardware parameters). Generated by the Deployment Licensing Service in exchange for the hardware key, and stored in the End User's system registry.

Licensing Component

A component that obtains an ImageGear license for the end user's machine.

Licensing Component Wrapper

A VBScript wrapper around the Licensing Component with methods for handling error result codes, etc. This wrapper serves as a template that can be modified as needed.

Named

Licenses that are counted as they are deployed to individual users.

Server License

Bound to hardware parameters. Therefore an individual node-locked License Key has to be generated for each system where the ImageGear-based solution is used. With this model, the Licensing Component running on the end user's machine can communicate directly to the Deployment Licensing Service but you also have the choice of setting up a Deployment Proxy Service at your site - in this case Licensing Component would communicate through this proxy service.

Server Licensing Utility

A standalone program that can be used to generate a license key given a configuration file.

Solution Key

A combination of 4 32-bit integers that are unique for each solution using AccuSoft's technology. This key is generated and assigned to your solution by AccuSoft.

Solution Name

The name of your ImageGear-based application.

User License

Not bound to hardware parameters. Therefore only one license key is required per ImageGear-based application.

Vendor

The Accusoft customer who is developing an ImageGear-based application (you).

Vendor Licensing Utility

The Web application you use to view deployment pools and obtain access keys.


Bibliography

Books

Brown, Wayne C., and Barry J. Shepherd. Graphics File Formats Reference and Guide. Greenwich, CT: Manning Publications, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. Windcrest Books, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. 2d ed. Windcrest/McGraw-Hill, 1995.

Murray, James D., and William vanRyper. Encyclopedia of Graphics File Formats. Sebastapol, CA: O'Reilly & Associates, Inc., 1994.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats, 2d ed. Sebastopol, CA: O'Reilly & Associates, Inc., 1996.

Petzold, Charles. Programming Windows: The Microsoft Guide to Writing Applications for Windows 3. Redmond, WA: Microsoft Press, 1990.

Articles

Wegner, Tim. "Coding for PNG Graphics", PC Techniques (Feb/Mar 1996): 32-38.

Other

"Graphic Image Format FAQ 3-4." James D. Murray, 1994-1996.

PBM, PGM, PPM, PNM Specifications by Jef Poskanzer, copyright " 1989, 1991.

PNG (Portable Network Graphics), tenth draft. Page 5, copyright Thomas Boutell, May 1995.


Volume 2: ImageGear Namespaces Reference

This part of ImageGear for .NET 16.0 User's Manual provides detailed information about each class, interface, structure, delegate, method, property, field and enumeration of all ImageGear Namespaces. This information includes function's calling sequence, arguments, use, possible return values, `See Also' links, code samples as well as other useful information.

Currently there are the following ImageGear namespaces:

  • ImageGear.Core Namespace
  • ImageGear.ART Namespace
  • ImageGear.ART.Forms Namespace
  • ImageGear.Display Namespace
  • ImageGear.Formats Namespace
  • ImageGear.Formats.CAD Namespace
  • ImageGear.Formats.CGM Namespace
  • ImageGear.Formats.DGN Namespace
  • ImageGear.Formats.DICOM Namespace
  • ImageGear.Formats.EXIF Namespace
  • ImageGear.Formats.HPGL Namespace
  • ImageGear.Formats.IPTC Namespace
  • ImageGear.Formats.JPEG2K Namespace
  • ImageGear.Formats.JPG Namespace
  • ImageGear.Formats.PDF Namespace
  • ImageGear.Formats.TIF Namespace
  • ImageGear.Formats.U3D Namespace
  • ImageGear.Formats.XMP Namespace
  • ImageGear.FreqIP Namespace
  • ImageGear.Processing Namespace
  • ImageGear.Processing.ImageClean Namespace
  • ImageGear.Processing.Layers Namespace
  • ImageGear.TWAIN Namespace
  • ImageGear.Vector Namespace
  • ImageGear.Web.Forms Namespace
  • ImageGear.Windows.Forms Namespace
  • ImageGear.Windows.Forms.Thumbnail Namespace
  • ImageGear.WPF Namespace

For information about the imaging file formats that ImageGear Supports, please see ImageGear Imaging Formats Reference chapter.


ImageGear.Core Namespace

ImageGear.Core Namespace

32-bit
64-bit
CF
P
P
P

Description:

The ImageGear.Core namespace is the basis of the ImageGear for .NET toolkit. This namespace contains classes to operate with graphics primitives, to license the product and, most importantly, primary ImageGear entities like page and document.

Declaration:

namespace ImageGear.Core

Members:

Classes:
Name
Description
ImGearColorBook Class
Represents a color book.
ImGearColorBookColor Class
Represents a color in the color book.
ImGearColorBooks Class
Represents a static collection of color books.
ImGearColorChannelInfo Class
Spot channel class that uses regular color space like RGB, CMYK, etc.
ImGearColorProfile Class
Represents a color profile.
ImGearColorProfileManager Class
Provides global profile storage and allows enabling and disabling the automatic use of global color profiles for color space conversion and display operations.
ImGearDIB Class
Encapsulates image, which consists of the pixel data and its attributes.
ImGearDICOMMetadataDictRecord Class
Represents DICOM metadata dictionary record.
ImGearDisplayChannel Class
Represents display attributes for individual channel.
ImGearDisplayChannels Class
Represents a collection of ImGearDisplayChannel Classes.
ImGearDocument Class
Represents a collection of ImGearPage objects. May be stand-alone ImageGear for .NET or associated with external file.
ImGearDocumentPageArray Class
Collection to manage pages within ImGearDocument object.
ImGearException Class
Base class for all exceptions thrown by the ImageGear for .NET library. Contains error codes and optionally supplied data.
ImGearExtraChannelInfo Class
This is a general extra channel class.
ImGearFullLUT Class
Represents a Look Up table that contains a full table of values for each possible input index.
ImGearLicense Class
Manages licensing data like license type and key.
ImGearLUT Class
Provides a base for Look Up Tables (LUTs) that are used in ImageGear.
ImGearMaskColorChannelInfo Class
Mask color channel class.
ImGearMaskSpotChannelInfo Class
Mask spot channel class that uses a special (like Pantone) color.
ImGearMetadataDictionary Class
Provides access to Metadata Dictionary that is used in ImageGear.
ImGearMetadataHead Class
Head of metadata tree.
ImGearMetadataLeaf Class
Middle-level node in metadata tree.
ImGearMetadataNode Class
Abstraction of node in metadata tree.
ImGearMetadataNodeList Class
Collection of metadata nodes. Processes additional verifications concerning collection structure. Used as a part of ImGearMetadataTree.
ImGearMetadataTree Class
Encapsulates entity of file format metadata tree.
ImGearMultichannelLUT Class
Represents a multichannel look up table.
ImGearPage Class
Represents single-page image. In addition to image pixels, contains other attributes like ROI and metadata.
ImGearPixel Class
Encapsulates attributes and operations for a particular image pixel.
ImGearPixelArray Class
One dimensional array of image pixels.
ImGearPolygon Class
Polygon shape defined as an array of sequentially connected (two or more) points.
ImGearRasterPage Class
Represents the raster image.
ImGearRGBLUT Class
Represents RGB look up table (LUT).
ImGearROI Class
Region of interest associated with ImGearPage instance.
ImGearROIMask Class
1-bit (binary) image that specifies non-rectangular region of interest.
ImGearROIRectangle Class
Rectangular region of interest.
ImGearSpotChannelInfo Class
Spot channel class that uses a special (like Pantone) color.
ImGearTransparency Class
Specifies image transparency attributes like transparent color for display.
ImGearVectorPage Class
Represents page with vector image.
ImGearVersion Class
This class provides static properties to retrieve version info for the product assembly.
ImGearWarning Class
Base class for all warnings handled by the ImageGear for .NET library. Contains error code and optionally supplied data.

Interfaces:
Name
Description
IImGearMetadataDictRecord Interface
Specifies baseline features for a metadata dictionary record.
IImGearRoundedRectangle Interface
Represents a rounded rectangle.

Structures:
Name
Description
ImGearArrayRef Structure
Stores ImageGear arrays.
ImGearChannelRange Structure
This structure describes channels to be processed with ImGearProcessing Class methods.
ImGearColorSpace Structure
Defines semantics of information, stored in all image channels.
ImGearCommonMetadataDictRecord Structure
Contains data for a common metadata dictionary record.
ImGearDoublePoint Structure
Stores a set of two double precision numbers that represent the point.
ImGearDoubleRectangle Structure
Stores a set of four double precision numbers that represent the location and size of a rectangle.
ImGearEllipse Structure
Stores a set of two ImGear values that represent the location and size of an ellipse.
ImGearOrientation Structure
Specifies orientation of page or display.
ImGearPoint Structure
Encapsulates a point in a 2-D coordinate system.
ImGearRationalInt Structure
Specifies rational fraction as an indicated division of Numerator/Denominator.
ImGearRationalUInt Structure
Specifies rational fraction as an indicated division of Numerator/Denominator.
ImGearRect Structure
Stores a set of four integer numbers that represent the location and size of the rectangle.
ImGearRectangle Structure
Stores a set of four integer numbers that represent the location and size of a rectangle.
ImGearResolution Structure
Stores ImageGear resolution data.
ImGearRGBQuad Structure
Specifies RGB value.
ImGearSize Structure
Implements a relative coordinate or position.

Delegates:
Name
Description
ImGearAddWarning Delegate
Specifies the processing warning routine to be called when the warning is added.

Enumerations:
Name
Description
ImGearChannelGroups Enumeration
Specifies alpha channels.
ImGearColorSpaceIDs Enumeration
Specifies ImageGear color space IDs.
ImGearErrorCodes Enumeration
Specifies ImageGear error codes.
ImGearExtraChannelType Enumeration
Specifies all the supported types of extra channels.
ImGearFlipModes Enumeration
Specifies flip modes.
ImGearLicenseType Enumeration
Specifies the type of ImageGear license.
ImGearMaskChannelModes Enumeration
Specifies whether the color indicates masked or selected area.
ImGearOrientationModes Enumeration
Specifies orientation modes.
ImGearRenderingIntents Enumeration
Controls how colors are transformed during color space conversion using color profiles.
ImGearResolutionUnits Enumeration
Specifies the measurements of resolution units.
ImGearRotationValues Enumeration
Specifies the value of the rotation angle.
ImGearSpotColorVendorID Enumeration
Specifies all supported vendor IDs.


ImageGear.Core Namespace Classes

The ImageGear.Core Namespace has the following class members:

Classes:
Name
Description
ImGearColorBook Class
Represents a color book.
ImGearColorBookColor Class
Represents a color in the color book.
ImGearColorBooks Class
Represents a static collection of color books.
ImGearColorChannelInfo Class
Spot channel class that uses regular color space like RGB, CMYK, etc.
ImGearColorProfile Class
Represents a color profile.
ImGearColorProfileManager Class
Provides global profile storage and allows enabling and disabling the automatic use of global color profiles for color space conversion and display operations.
ImGearDIB Class
Encapsulates image, which consists of the pixel data and its attributes.
ImGearDICOMMetadataDictRecord Class
Represents DICOM metadata dictionary record.
ImGearDisplayChannel Class
Represents display attributes for individual channel.
ImGearDisplayChannels Class
Represents a collection of ImGearDisplayChannel Classes.
ImGearDocument Class
Represents a collection of ImGearPage objects. May be stand-alone ImageGear for .NET or associated with external file.
ImGearDocumentPageArray Class
Collection to manage pages within ImGearDocument object.
ImGearException Class
Base class for all exceptions thrown by the ImageGear for .NET library. Contains error codes and optionally supplied data.
ImGearExtraChannelInfo Class
This is a general extra channel class.
ImGearFullLUT Class
Represents a Look Up table that contains a full table of values for each possible input index.
ImGearLicense Class
Manages licensing data like license type and key.
ImGearLUT Class
Provides a base for Look Up Tables (LUTs) that are used in ImageGear.
ImGearMaskColorChannelInfo Class
Mask color channel class.
ImGearMaskSpotChannelInfo Class
Mask spot channel class that uses a special (like Pantone) color.
ImGearMetadataDictionary Class
Provides access to Metadata Dictionary that is used in ImageGear.
ImGearMetadataHead Class
Head of metadata tree.
ImGearMetadataLeaf Class
Middle-level node in metadata tree.
ImGearMetadataNode Class
Abstraction of node in metadata tree.
ImGearMetadataNodeList Class
Collection of metadata nodes. Processes additional verifications concerning collection structure. Used as a part of ImGearMetadataTree.
ImGearMetadataTree Class
Encapsulates entity of file format metadata tree.
ImGearMultichannelLUT Class
Represents a multichannel look up table.
ImGearPage Class
Represents single-page image. In addition to image pixels, contains other attributes like ROI and metadata.
ImGearPixel Class
Encapsulates attributes and operations for a particular image pixel.
ImGearPixelArray Class
One dimensional array of image pixels.
ImGearPolygon Class
Polygon shape defined as an array of sequentially connected (two or more) points.
ImGearRasterPage Class
Represents the raster image.
ImGearRGBLUT Class
Represents RGB look up table (LUT).
ImGearROI Class
Region of interest associated with ImGearPage instance.
ImGearROIMask Class
1-bit (binary) image that specifies non-rectangular region of interest.
ImGearROIRectangle Class
Rectangular region of interest.
ImGearSpotChannelInfo Class
Spot channel class that uses a special (like Pantone) color.
ImGearTransparency Class
Specifies image transparency attributes like transparent color for display.
ImGearVectorPage Class
Represents page with vector image.
ImGearVersion Class
This class provides static properties to retrieve version info for the product assembly.
ImGearWarning Class
Base class for all warnings handled by the ImageGear for .NET library. Contains error code and optionally supplied data.


ImGearColorBook Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents a color book.

Declaration:

public sealed class ImGearColorBook

Members:

Constructors
Name
Description
ImGearColorBook Constructor
Creates new instance of ImGearColorBook Class.
ImGearColorBook Constructor
Creates new instance of ImGearColorBook Class.

Properties
Name
Description
Colors Property
Specifies array of colors in the color book.
ColorsPerPage Property
Specifies the number of colors per page.
ColorType Property
Specifies the color space value used for displaying all the colors from the color book.
Description Property
Specifies description of the color book.
FileName Property
Specifies the color book file name.
KeyColorPage Property
Specifies the key color on the page.
NumberOfColors Property
Specifies the number of colors in the color book.
Postfix Property
Specifies the color book postfix string value.
Prefix Property
Specifies the color book prefix string value.
Title Property
Specifies the color book title.
VendorID Property
Specifies the color book vendor ID value.

Methods
Name
Description
Add Method
Adds color to the color book.
Create Method
Creates and initializes an instance of ImGearColorBook Class.
Get Method
Returns a color with the specified ID from the color book.
GetEnumerator Method
Returns IEnumerator interface used for enumeration all the colors in the color book.


ImGearColorBook Constructors

The ImGearColorBook Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearColorBook Constructor
Creates a new instance of ImGearColorBook Class.
ImGearColorBook Constructor
Creates a new instance of ImGearColorBook Class.


ImGearColorBook Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearColorBook Class from the specified parameters. It allows the user to create a color book.

Declaration:

public ImGearColorBook(ImageGear.Core.ImGearSpotColorVendorID VendorID, string FileName,
string Title, string Prefix, string Postfix, string Description, int NumberOfColors, int
ColorsPerPage, ImageGear.Core.ImGearColorSpaceIDs ColorType)

Parameters:

Name
Type
Description
VendorID
ImGearSpotColorVendorID Enumeration
Color book vendor ID.
FileName
string
Color book file name.
Title
string
Color book title.
Prefix
string
Color book prefix.
Postfix
string
Color book postfix.
Description
string
Color book description.
NumberOfColors
int
Number of colors in color book.
ColorsPerPage
int
Number of colors per page in color book.
ColorType
ImGearColorSpaceIDs Enumeration
Color type.

Return Value:

The new instance of ImGearColorBook Class.

Example:

C#
ImGearColorBooks.Initialize(files);
ImGearColorBook book = new ImGearColorBook(ImGearSpotColorVendorID.PantoneProcess, "", "My Color Book", "Prefix", "Postfix",
"Description", 2, 2, ImGearColorSpaceIDs.LAB);
ImGearPixel p = new ImGearPixel(3, 8);
p[0] = 138; p[1] = 202; p[2] = 169;
book.Add(new ImGearColorBookColor("PANTONE Red 032 C", 90452819915331, p, ImGearColorSpaceIDs.LAB));
p[0] = 48; p[1] = 160; p[2] = 54;
book.Add(new ImGearColorBookColor("PANTONE reflex Blue C", 90457418519875, p, ImGearColorSpaceIDs.LAB));
ImGearColorBooks.Add(book);

Visual Basic
ImGearColorBooks.Initialize(files)
book = New ImGearColorBook(ImGearSpotColorVendorID.PantoneProcess, "", "My Color Book", "Prefix", "Postfix", "Description", 2, 2,
ImGearColorSpaceIDs.LAB)
p = New ImGearPixel(3, 8)
p[0] = 138
p[1] = 202
p[2] = 169
book.Add(New ImGearColorBookColor("PANTONE Red 032 C", 90452819915331, p, ImGearColorSpaceIDs.LAB))
p[0] = 48
p[1] = 160
p[2] = 54
book.Add(New ImGearColorBookColor("PANTONE reflex Blue C", 90457418519875, p, ImGearColorSpaceIDs.LAB))
ImGearColorBooks.Add(book)

See Also:

ImGearColorBook Class


ImGearColorBook Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearColorBook Class from the specified file stream.

Declaration:

public ImGearColorBook(System.IO.FileStream content)

Parameters:

Name
Type
Description
content
System.IO.FileStream
File stream to load color book from.

Return Value:

The new instance of ImGearColorBook Class.

Example:

C#
book = new ImGearColorBook(fileStream);

Visual Basic
book = New ImGearColorBook(fileStream)

See Also:

ImGearColorBook Class


ImGearColorBook Properties

The ImGearColorBook Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
Colors Property
Specifies array of colors in the color book.
ColorsPerPage Property
Specifies the number of colors per page.
ColorType Property
Specifies the color space value used for displaying all the colors from the color book.
Description Property
Specifies description of the color book.
FileName Property
Specifies the color book file name.
KeyColorPage Property
Specifies the key color on the page.
NumberOfColors Property
Specifies the number of colors in the color book.
Postfix Property
Specifies the color book postfix string value.
Prefix Property
Specifies the color book prefix string value.
Title Property
Specifies the color book title.
VendorID Property
Specifies the color book vendor ID value.


Colors Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the array of colors in the color book.

Declaration:

public ImageGear.Core.ImGearColorBookColor[ ] Colors { get; }

Value:

ImGearColorBookColor Class.

See Also:

ImGearColorBookColor Class


ColorsPerPage Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the number of colors per page. Must be less than or equal to 9.

Declaration:

public int ColorsPerPage { get; }

Value:

Integer value.

Example:

C#
numPerPage = pantoneBook.ColorsPerPage;

Visual Basic
numPerPage = pantoneBook.ColorsPerPage

See Also:

ImGearColorBook Class


ColorType Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the color space value used for displaying all the colors from the color book. It can be RGB, CMYK or Lab.

Declaration:

public ImageGear.Core.ImGearColorSpaceIDs ColorType { get; }

Value:

ImGearColorSpaceIDs Enumeration value.

See Also:

ImGearColorSpaceIDs Enumeration


Description Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the description of the color book.

Declaration:

public string Description { get; }

Value:

String.

See Also:

ImGearColorBook Class


FileName Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the color book file name.

Declaration:

public string FileName { get; }

Value:

String.

See Also:

ImGearColorBook Class


KeyColorPage Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the key color on the page. Must be less than or equal to colors per page.

Declaration:

public int KeyColorPage { get; }

Value:

Integer value.

See Also:

ImGearColorBook Class


NumberOfColors Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the number of colors in the color book. Must be less than or equal to 8000.

Declaration:

public int NumberOfColors { get; }

Value:

Integer value.

See Also:

ImGearColorBook Class


Postfix Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the color book postfix string value.

Declaration:

public string Postfix { get; }

Value:

String value.

See Also:

ImGearColorBook Class


Prefix Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the color book prefix string value.

Declaration:

public string Prefix { get; }

Value:

String.

See Also:

ImGearColorBook Class


Title Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the color book title.

Declaration:

public string Title { get; }

Value:

String.

See Also:

ImGearColorBook Class


VendorID Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the color book vendor ID value.

Declaration:

public ImageGear.Core.ImGearSpotColorVendorID VendorID { get; }

Value:

ImGearSpotColorVendorID Enumeration.

See Also:

ImGearSpotColorVendorID Enumeration


ImGearColorBook Methods

The ImGearColorBook Class of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
Add Method
Adds color to the color book.
Create Method
Creates and initializes an instance of ImGearColorBook Class.
Get Method
Returns a color with the specified ID from the color book.
GetEnumerator Method
Returns IEnumerator interface used for enumeration all the colors in the color book.


Add Method

32-bit
64-bit
CF
P
P
P

Description:

This method adds color to the color book.

Declaration:

public void Add(ImageGear.Core.ImGearColorBookColor Color)

Parameters:

Name
Type
Description
Color
ImGearColorBookColor Class
Color book color object.

Return Value:

None.

Example:

C#
book.Add(new ImGearColorBookColor("PANTONE reflex Blue C", 90457418519875, p, ImGearColorSpaceIDs.LAB));

Visual Basic
book.Add(New ImGearColorBookColor("PANTONE reflex Blue C", 90457418519875, p, ImGearColorSpaceIDs.LAB))

See Also:

ImGearColorBookColor Class


Create Method

32-bit
64-bit
CF
P
P
P

Description:

This method creates and initializes an instance of ImGearColorBook Class.

Declaration:

public static ImageGear.Core.ImGearColorBook Create(ImageGear.Core.ImGearSpotColorVendorID
VendorID, string Title, ImageGear.Core.ImGearColorSpaceIDs ColorType)

Parameters:

Name
Type
Description
VendorID
ImGearSpotColorVendorID Enumeration
Color book vendor ID.
Title
string
Color book title.
ColorType
ImGearColorSpaceIDs Enumeration
Color type.

Return Value:

ImGearColorBook Class.

Example:

C#
ImGearColorBook book = ImGearColorBook.Create(ImGearSpotColorVendorID.PantoneProcess, "My Color Book", ImGearColorSpaceIDs.LAB);

Visual Basic
book = ImGearColorBook.Create(ImGearSpotColorVendorID.PantoneProcess, "My Color Book", ImGearColorSpaceIDs.LAB)

See Also:

ImGearColorBook Class

ImGearSpotColorVendorID Enumeration

ImGearColorSpaceIDs Enumeration


Get Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns a color with the specified ID from the color book.

Declaration:

public ImageGear.Core.ImGearColorBookColor Get(long ID)

Parameters:

Name
Type
Description
ID
long
ID of the requested color.

Return Value:

ImGearColorBookColor Class.

Example:

C#
color = pantoneBook.Get(1112299335);

Visual Basic
color = pantoneBook.Get(1112299335)

See Also:

ImGearColorBookColor Class


GetEnumerator Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns the IEnumerator interface used for enumeration of all the colors in the color book.

Declaration:

public System.Collections.IEnumerator GetEnumerator()

Return Value:

System.Collections.IEnumerator.

Example:

C#
enumerator = pantoneBook.GetEnumerator();

Visual Basic
enumerator = pantoneBook.GetEnumerator

See Also:

ImGearColorBook Class


ImGearColorBookColor Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents a color in the color book.

Declaration:

public sealed class ImGearColorBookColor

Members:

Constructors
Name
Description
ImGearColorBookColor Constructor
Creates new instance of ImGearColorBookColor Class.

Properties
Name
Description
ColorSpace Property
Specifies a color space of the color used for display.
ID Property
Specifies color ID.
Name Property
Specifies color name.

Methods
Name
Description
GetColorValueCopy Method
Returns a copy of the color value used for display.


ImGearColorBookColor Constructors

The ImGearColorBookColor Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearColorBookColor Constructor
Creates new instance of ImGearColorBookColor Class.


ImGearColorBookColor Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearColorBookColor Class.

Declaration:

public ImGearColorBookColor(string Name, long ID, ImageGear.Core.ImGearPixel Color,
ImageGear.Core.ImGearColorSpaceIDs ColorType)

Parameters:

Name
Type
Description
Name
string
Name of the color.
ID
long
ID of the color.
Color
ImGearPixel
ImGearPixel value of the color.
ColorType
ImGearColorSpaceIDs Enumeration
Color space.

Return Value:

The new instance of ImGearColorBookColor Class.

Example:

C#
colors[i] = new ImGearColorBookColor(colorName, colorID, pixel, colorType);

Visual Basic
colors[i] = New ImGearColorBookColor(colorName, colorID, pixel, colorType)

See Also:

ImGearColorBookColor Class

ImGearPixel Class

ImGearColorSpaceIDs Enumeration


ImGearColorBookColor Properties

The ImGearColorBookColor Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
ColorSpace Property
Specifies a color space of the color used for display.
ID Property
Specifies color ID.
Name Property
Specifies color name.


ColorSpace Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies a color space of the color used for display.

Declaration:

public ImageGear.Core.ImGearColorSpace ColorSpace { get; }

Value:

ImGearColorSpace Structure.

See Also:

ImGearColorSpace Structure


ID Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies color ID.

Declaration:

public long ID { get; }

Value:

Long value.

See Also:

ImGearColorBookColor Class


Name Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies color name.

Declaration:

public string Name { get; }

Value:

String.

See Also:

ImGearColorBookColor Class


ImGearColorBookColor Methods

The ImGearColorBookColor Class of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
GetColorValueCopy Method
Returns a copy of the color value used for display.


GetColorValueCopy Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns a copy of the color value used for display.

Declaration:

public ImageGear.Core.ImGearPixel GetColorValueCopy()

Return Value:

ImGearPixel Class.

Example:

C#
pixel = color.GetColorValueCopy();

Visual Basic
pixel = color.GetColorValueCopy

See Also:

ImGearPixel Class

ImGearColorBookColor Class


ImGearColorBooks Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents a static collection of color books.

Declaration:

public sealed class ImGearColorBooks

Members:

Constructors
Name
Description
ImGearColorBooks Constructor
Creates new instance of ImGearColorBooks Class.

Properties
Name
Description
Count Property
Specifies the number of color books in the collection.
Initalized Property
Specifies whether the collection has been initialized or not.
IsSynchronized Property
Gets a value indicating whether access to the collection is synchronized.
SyncRoot Property
Gets an object that can be used to synchronize access to the collection.

Methods
Name
Description
Add Method
Adds a new color book to the collection.
AddBookFromFile Method
Adds a new color book to the collection from the specified file name.
CopyTo Method
Copies a range of elements to the specified array.
Get Method
Retrieves a color book for the specified vendor ID.
GetAllBooks Method
Retrieves the entire collection of color books.
GetByIndex Method
Retrieves a color book with the specified index.
GetSynonyms Method
Returns an array of vendor IDs associated with the specified ID.
GetEnumerator Method
Returns IEnumerator interface used for enumeration all the color books in the collection.
Initialize Method
Loads the color book collection from the specified file paths.
Remove Method
Removes color book for the specified vendor ID.
RemoveAt Method
Removes color book with the specified index.


ImGearColorBooks Constructors

The ImGearColorBooks Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearColorBooks Constructor
Creates new instance of ImGearColorBooks Class.


ImGearColorBooks Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearColorBooks Class.

Declaration:

public ImGearColorBooks()

Return Value:

The new instance of ImGearColorBooks Class.

See Also:

ImGearColorBooks Class


ImGearColorBooks Properties

The ImGearColorBooks Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
Count Property
Specifies the number of color books in the collection.
Initalized Property
Specifies whether the collection has been initialized or not.
IsSynchronized Property
Gets a value indicating whether access to the collection is synchronized.
SyncRoot Property
Gets an object that can be used to synchronize access to the collection.


Count Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the number of color books in the collection.

Declaration:

public int Count { get; }

Value:

Integer value.

See Also:

ImGearColorBooks Class


Initalized Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies whether the collection has been initialized or not.

Declaration:

public static bool Initalized { get; }

Value:

true/false.

See Also:

ImGearColorBooks Class


IsSynchronized Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets a value indicating whether access to the collection is synchronized.

Declaration:

public bool IsSynchronized { get; }

Value:

true/false.

See Also:

ImGearColorBooks Class


SyncRoot Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets an object that can be used to synchronize access to the collection.

Declaration:

public object SyncRoot { get; }

Value:

Object

See Also:

ImGearColorBooks Class


ImGearColorBooks Methods

The ImGearColorBooks Class of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
Add Method
Adds a new color book to the collection.
AddBookFromFile Method
Adds a new color book to the collection from the specified file name.
CopyTo Method
Copies a range of elements to the specified array.
Get Method
Retrieves a color book for the specified vendor ID.
GetAllBooks Method
Retrieves the entire collection of color books.
GetByIndex Method
Retrieves a color book with the specified index.
GetSynonyms Method
Returns an array of vendor IDs associated with the specified ID.
GetEnumerator Method
Returns the IEnumerator interface used for enumeration of all the color books in the collection.
Initialize Method
Loads the color book collection from the specified file paths.
Remove Method
Removes color book for the specified vendor ID.
RemoveAt Method
Removes color book with the specified index.


Add Method

32-bit
64-bit
CF
P
P
P

Description:

This method adds a new color book to the collection.

Declaration:

public static int Add(ImageGear.Core.ImGearColorBook newColorBook)

Parameters:

Name
Type
Description
newColorBook
ImGearColorBook Class
New color book to add.

Return Value:

Integer value.

Example:

C#
ImGearColorBooks.Add(pantoneBook);

Visual Basic
ImGearColorBooks.Add(pantoneBook)

See Also:

ImGearColorBook Class

ImGearColorBooks Class


AddBookFromFile Method

32-bit
64-bit
CF
P
P
P

Description:

This method adds a new color book to the collection from the specified file name.

Declaration:

public static int AddBookFromFile(string FileName)

Parameters:

Name
Type
Description
FileName
string
Color book file.

Return Value:

Integer value.

See Also:

ImGearColorBook Class

ImGearColorBooks Class


CopyTo Method

32-bit
64-bit
CF
P
P
P

Description:

This method copies a range of elements to the specified array.

Declaration:

public void CopyTo(System.Array array, int index)

Parameters:

Name
Type
Description
array
System.Array
ImGearColorBook[] array to copy the color elements to.
index
int
The zero-based index in array at which copying begins.

Return Value:

None.

See Also:

ImGearColorBook Class

ImGearColorBooks Class


Get Method

32-bit
64-bit
CF
P
P
P

Description:

This method retrieves a color book for the specified vendor ID.

Declaration:

public static ImageGear.Core.ImGearColorBook Get(ImageGear.Core.ImGearSpotColorVendorID
vendorID)

Parameters:

Name
Type
Description
vendorID
ImGearSpotColorVendorID Enumeration
Vendor ID for which to get the color book.

Return Value:

ImGearColorBook Class.

See Also:

ImGearColorBook Class

ImGearColorBooks Class

ImGearSpotColorVendorID Enumeration


GetAllBooks Method

32-bit
64-bit
CF
P
P
P

Description:

This method retrieves the entire collection of color books.

Declaration:

public static ImageGear.Core.ImGearColorBook[ ] GetAllBooks()

Return Value:

ImGearColorBook Class.

See Also:

ImGearColorBook Class

ImGearColorBooks Class


GetByIndex Method

32-bit
64-bit
CF
P
P
P

Description:

This method retrieves a color book with the specified index.

Declaration:

public static ImageGear.Core.ImGearColorBook GetByIndex(int index)

Parameters:

Name
Type
Description
index
int
Index of the color book to get.

Return Value:

ImGearColorBook Class.

See Also:

ImGearColorBook Class

ImGearColorBooks Class


GetSynonyms Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns an array of vendor IDs associated with the specified ID.

Declaration:

public static ImGearSpotColorVendorID[ ] GetSynonyms(ImGearSpotColorVendorID Vendor)

Parameters:

Name
Type
Description
Vendor
ImGearSpotColorVendorID Enumeration
Vendor ID.

Return Value:

Short array.

See Also:

ImGearColorBook Class

ImGearColorBooks Class

ImGearSpotColorVendorID Enumeration


GetEnumerator Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns the IEnumerator interface used for enumeration of all the color books in the collection.

Declaration:

public System.Collections.IEnumerator GetEnumerator()

Return Value:

System.Collections.IEnumerator.

See Also:

ImGearColorBook Class

ImGearColorBooks Class


Initialize Method

32-bit
64-bit
CF
P
P
P

Description:

This method loads the color book collection from the specified file paths.

Declaration:

public static void Initialize(string[ ] ColorBookFiles)

Parameters:

Name
Type
Description
ColorBookFiles
string[ ]
List of color book paths.

Return Value:

None.

See Also:

ImGearColorBook Class

ImGearColorBooks Class


Remove Method

32-bit
64-bit
CF
P
P
P

Description:

This method removes color book for the specified vendor ID.

Declaration:

public static void Remove(ImageGear.Core.ImGearSpotColorVendorID vendorID)

Parameters:

Name
Type
Description
vendorID
ImGearSpotColorVendorID Enumeration
Vendor ID.

Return Value:

None.

See Also:

ImGearColorBook Class

ImGearColorBooks Class

ImGearSpotColorVendorID Enumeration


RemoveAt Method

32-bit
64-bit
CF
P
P
P

Description:

This method removes a color book with the specified index.

Declaration:

public static void RemoveAt(int index)

Parameters:

Name
Type
Description
index
int
Color book index.

Return Value:

None.

See Also:

ImGearColorBook Class

ImGearColorBooks Class


ImGearColorChannelInfo Class

32-bit
64-bit
CF
P
P
P

Description:

This is a spot channel class that uses regular color space like RGB, CMYK, etc.

Declaration:

public class ImGearColorChannelInfo : ImageGear.Core.ImGearExtraChannelInfo

Members:

Constructors
Name
Description
ImGearColorChannelInfo Constructor
Creates a new instance of ImGearColorChannelInfo Class.

Properties
Name
Description
ColorSpace Property
Specifies color channel's color space.
Opacity Property
Specifies opacity of the color channel.

Methods
Name
Description
GetColorValueCopy Method
Returns a copy of the color value.
GetColorValueCopy16 Method
Returns a copy of the color value in 16-bit format.
GetColorValueCopy8 Method
Returns a copy of the color value in 8-bit format.

See Also:

ImGearExtraChannelInfo Class


ImGearColorChannelInfo Constructors

The ImGearColorChannelInfo Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearColorChannelInfo Constructor
Creates new instance of ImGearColorChannelInfo Class.


ImGearColorChannelInfo Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearColorChannelInfo Class by using color space and color value.

Declaration:

public ImGearColorChannelInfo(ImageGear.Core.ImGearColorSpace colorSpace,
ImageGear.Core.ImGearPixel colorValue)

Parameters:

Name
Type
Description
colorSpace
ImGearColorSpace Structure
Color space object.
colorValue
ImGearPixel Class
ImGearPixel color value.

Return Value:

The new instance of ImGearColorChannelInfo Class.

See Also:

ImGearColorChannelInfo Class

ImGearColorSpace Structure

ImGearPixel Class


ImGearColorChannelInfo Properties

The ImGearColorChannelInfo Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
ColorSpace Property
Specifies color channel's color space.
Opacity Property
Specifies opacity of the color channel.


ColorSpace Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies a color channel's color space.

Declaration:

public ImageGear.Core.ImGearColorSpace ColorSpace { get; }

Value:

ImGearColorSpace Structure.

See Also:

ImGearColorChannelInfo Class

ImGearColorSpace Structure


Opacity Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the opacity of the color channel. The opacity value is between 0 and 100.

Declaration:

public int Opacity { get;  set; }

Value:

Integer value.

Example

C#
colorCh.Opacity = 50;

:

Visual Basic
colorCh.Opacity = 50

See Also:

ImGearColorChannelInfo Class


ImGearColorChannelInfo Methods

The ImGearColorChannelInfo Class of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
GetColorValueCopy Method
Returns a copy of the color value.
GetColorValueCopy16 Method
Returns a copy of the color value in 16-bit format.
GetColorValueCopy8 Method
Returns a copy of the color value in 8-bit format.


GetColorValueCopy Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns a copy of the color value.

Declaration:

public ImageGear.Core.ImGearPixel GetColorValueCopy()

Return Value:

ImGearPixel Class.

See Also:

ImGearColorChannelInfo Class

ImGearPixel Class


GetColorValueCopy16 Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns a copy of the color value in 16-bit format.

Declaration:

public ImageGear.Core.ImGearPixel GetColorValueCopy16()

Return Value:

ImGearPixel Class value with 16 bits per channel.

See Also:

ImGearColorChannelInfo Class

ImGearPixel Class


GetColorValueCopy8 Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns a copy of the color value in 8-bit format.

Declaration:

public ImageGear.Core.ImGearPixel GetColorValueCopy8()

Return Value:

ImGearPixel Class value with 8 bits per channel.

See Also:

ImGearColorChannelInfo Class

ImGearPixel Class


ImGearColorProfile Class

32-bit
64-bit
CF
P
P
P

Description:

This object represents a color profile.

Declaration:

public sealed class ImGearColorProfile

Members:

Constructors
Name
Description
ImGearColorProfile Constructor
Creates new instance of ImGearColorProfile Class.
ImGearColorProfile Constructor
Creates new instance of ImGearColorProfile Class.

Properties
Name
Description
ColorSpace Property
Provides read-only access to color profile data.
ProfileData Property
Color space of the color profile.
RenderingIntent Property
Rendering intent associated with the color profile.

See Also:

ImGearColorProfileManager Class


ImGearColorProfile Constructors

The ImGearColorProfile Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearColorProfile Constructor
Creates new instance of ImGearColorProfile Class.
ImGearColorProfile Constructor
Creates new instance of ImGearColorProfile Class.


ImGearColorProfile Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates new instance of ImGearColorProfile Class. It reads profile data from a byte array. The profile data must be in standard ICC color profile format.

Declaration:

public ImGearColorProfile(byte[] profileData)

Parameters:

Name
Type
Description
profileData
byte[]
Profile data to read.

Return Value:

The new instance of ImGearColorProfile Class.

See Also:

ImGearColorProfile Class


ImGearColorProfile Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates new instance of ImGearColorProfile Class. It reads profile data from a stream. The profile data must be in standard ICC color profile format.

Declaration:

public Imgearcolorprofile(Stream content)

Parameters:

Name
Type
Description
content
Stream
Profile data.

Return Value:

The new instance of ImGearColorProfile Class.

See Also:

ImGearColorProfile Class


ImGearColorProfile Properties

The ImGearColorProfile Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
ColorSpace Property
Provides read-only access to color profile data.
ProfileData Property
Color space of the color profile.
RenderingIntent Property
Rendering intent associated with the color profile.


ColorSpace Property

32-bit
64-bit
CF
P
P
P

Description:

Returns color space of the color profile, typically RGB or CMYK.

Declaration:

public ImGearColorSpaceIDs ColorSpace {get;}

Value:

ImGearColorSpaceIDs Enumeration value.

See Also:

ImGearColorSpaceIDs Enumeration


ProfileData Property

32-bit
64-bit
CF
P
P
P

Description:

Provides read-only access to color profile data. Color profiles are not updated through this property; create a new ImGearColorProfile Class object instead.

Declaration:

public byte[] ProfileData {get;}

Value:

Array of bytes.

See Also:

ImGearColorProfile Class


RenderingIntent Property

32-bit
64-bit
CF
P
P
P

Description:

Rendering intent associated with the color profile. Rendering intent controls how color matching is performed during color space conversion.

Declaration:

public ImGearRenderingIntents RenderingIntent {get;}

Value:

ImGearRenderingIntents Enumeration value.

See Also:

ImGearRenderingIntents Enumeration


ImGearColorProfileManager Class

32-bit
64-bit
CF
P
P
P

Description:

This object provides global profile storage and allows enabling and disabling the automatic use of global color profiles for color space conversion and display operations.

Declaration:

public class ImGearColorProfileManager

Members:

Properties
Name
Description
CmykProfile Property
Global CMYK color profile to use for implicit color space conversions when global profiles are enabled.
EnableProfiles Property
Enables or disables the automatic use of color profiles for color space conversion operations.
GrayProfile Property
Returns or assigns a color profile for appropriate color space.
LabProfile Property
Returns or assigns a color profile for appropriate color space.
RenderingIntent Property
Rendering intent to use for implicit color space conversions when global profiles are enabled.
RgbProfile Property
Global RGB color profile to use for implicit color space conversions when global profiles are enabled.

Methods
Name
Description
AssignProfile Method
Associates a given instance of a color profile with the specified color space.
GetProfile Method
Returns an instance of a color profile associated with the given color space.

See Also:

ImGearColorProfile Class


ImGearColorProfileManager Properties

The ImGearColorProfileManager Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
CmykProfile Property
Global CMYK color profile to use for implicit color space conversions when global profiles are enabled.
EnableProfiles Property
Enables or disables the automatic use of color profiles for color space conversion operations.
GrayProfile Property
Returns or assigns a color profile for the appropriate color space.
LabProfile Property
Returns or assigns a color profile for the appropriate color space.
RenderingIntent Property
Rendering intent to use for implicit color space conversions when global profiles are enabled.
RgbProfile Property
Global RGB color profile to use for implicit color space conversions when global profiles are enabled.


CmykProfile Property

32-bit
64-bit
CF
P
P
P

Description:

Global CMYK color profile to use for implicit color space conversions when global profiles are enabled.

Declaration:

public ImGearColorProfile CmykProfile { get; set }

Value:

ImGearColorProfile Class object.

Default Value:

NULL

See Also:

ImGearColorProfile Class


EnableProfiles Property

32-bit
64-bit
CF
P
P
P

Description:

This property enables or disables the automatic use of color profiles for color space conversion operations. If this property is enabled, global color profiles (specified by other properties of this object such as CmykProfile Property and RgbProfile Property) and local color profiles (ImGearRasterPage Class ColorProfile Property property) will be used to perform color space conversions.

Declaration:

public bool EnableProfiles { get; set }

Value:

True, False

Default Value:

False.


GrayProfile Property

32-bit
64-bit
CF
P
P
P

Description:

This property returns or assigns color profile for appropriate color space.

Declaration:

public static ImGearColorProfile GrayProfile { get; set; }

Value:

ImGearColorProfile Class

See Also:

ImGearColorProfile Class


LabProfile Property

32-bit
64-bit
CF
P
P
P

Description:

This property returns or assigns color profile for appropriate color space.

Declaration:

public static ImGearColorProfile LabProfile { get; set; }

Value:

ImGearColorProfile Class

See Also:

ImGearColorProfile Class


RenderingIntent Property

32-bit
64-bit
CF
P
P
P

Description:

Rendering intent to use for implicit color space conversions when global profiles are enabled. Rendering intent controls how color matching is performed during color space conversion.

Declaration:

public ImGearRenderingIntents RenderingIntent { get; set }

Value:

ImGearRenderingIntents Enumeration value.

Default Value:

PERCEPTUAL

See Also:

ImGearRenderingIntents Enumeration


RgbProfile Property

32-bit
64-bit
CF
P
P
P

Description:

Global RGB color profile to use for implicit color space conversions when global profiles are enabled.

Declaration:

public ImGearColorProfile RgbProfile { get; set }

Value:

ImGearColorProfile Class object.

Default Value:

NULL

See Also:

ImGearColorProfile Class


ImGearColorProfileManager Methods

The ImGearColorProfileManager Class of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
AssignProfile Method
Associates given instance of color profile with specified color space.
GetProfile Method
Returns an instance of the color profile associated with a given color space.


AssignProfile Method

32-bit
64-bit
CF
P
P
P

Description:

Associates a given instance of a color profile with the specified color space. Represents an alternative way of assigning global profiles with color spaces. In particular, to assign a global profile with a gray color space, either GrayProfile Property or AssignProfile(ImGearColorSpaceIDs.Gy) call could be used.

Declaration:

public static void AssignProfile(ImGearColorSpaceIDs colorSpace, ImGearColorProfile
colorProfile)

Parameters:

Name
Type
Description
colorSpace
ImGearColorSpaceIDs Enumeration
Color space.
colorProfile
ImGearColorProfile Class
Color profile.

Return value:

None

See Also:

ImGearColorProfile Class

ImGearColorSpaceIDs Enumeration


GetProfile Method

32-bit
64-bit
CF
P
P
P

Description:

Returns an instance of the color profile associated with a given color space. Represents an alternative way of obtaining profiles associated with color spaces. In particular, the profile associated with the gray color space could be obtained using GrayProfile property or calling GetProfile method with ImGearColorSpaceIDs.Gy parameter.

Declaration:

public static ImGearColorProfile GetProfile(ImGearColorSpaceIDs colorSpace)

Parameters:

Name
Type
Description
colorSpace
ImGearColorSpaceIDs Enumeration
Color space.

Return value:

ImGearColorProfile Class

See Also:

ImGearColorProfile Class

ImGearColorSpaceIDs Enumeration


ImGearDIB Class

32-bit
64-bit
CF
P
P
P

Description:

Encapsulates an image, which consists of pixel data and its attributes. This class does not have any public constructor. Instances of ImGearDIB exist only as a member objects of ImGearPage or ImGearROIMask classes.

Declaration:

public class ImGearDIB : ICloneable

Members:

Properties
Name
Description
BitDepth Property
Total quantity of bits used to store a single pixel.
BitsPerChannel Property
Allocated (actual) size of store for each channel in bits.
ChannelCount Property
Total quantity of channels in image.
ChannelDepth Property
Depth of particular channel in image.
ChannelDepths Property
Determines the bit depth of each color channel in the image.
ColorSpace Property
Color Space of current image.
ExtraChannelInfo Property
Extra channel info. Always non-null, length is always equal to number of extra channels in the image. Has zero length if the image contains no extra channels.
Height Property
Height of image in pixels.
Palette Property
Array of ImGearRGBQuad objects that specify RGB colors for indexed color space. May be null if ImGearDIB instance has other color space.
Resolution Property
Image resolution attributes.
Signed Property
Specifies whether image is signed or not.
Width Property
Width of image in pixels.

Methods
Name
Description
AllocateImage Method
Allocates pixel data based on the DIB header information.
Clone Method
Creates a new object that is a copy of the current instance.
GetAreaCopy Method
Returns an array of pixels that are exact copies of pixels in the requested rectangular part of the image.
GetColumnCopy Method
Returns an array of pixels that are exact copies of pixels in requested column part.
GetImage Method
Returns a reference to raw image store. Should be used to gain direct access to image pixels.
GetLineCopy Method
Returns an array of pixels that are exact copies of pixels on requested line of image.
GetPixelCopy Method
Returns exact copy of requested pixel.
GetRaster Method
Returns reference to raw raster store. Should be used to gain direct access to raster pixels.
GetRowCopy Method
Returns array of pixels that are exact copies of pixels in requested row part of image.
IsEmpty Method
Tells whether store for the pixels has been allocated or not.
UpdateAreaFrom Method
Updates rectangular part of image with new values of incoming pixels.
UpdateColumnFrom Method
Updates part of column with new pixels.
UpdateLineFrom Method
Updates part of line with new pixels.
UpdatePixelFrom Method
Updates single pixel with new value.
UpdateRowFrom Method
Updates part of row with new pixels.

Sample Code:

C#
ImGearPage igPage;
// Load an image into a ImGearPage object
using (FileStream localFile = new FileStream("IMG_0713.CR2", FileMode.Open))
    igPage = ImGearFileFormats.LoadPage(localFile, 0);
// Create a black pixel appropriate to this image.
ImGearPixel igPixel = new ImGearPixel(igPage.DIB.ChannelCount,igPage.DIB.BitsPerChannel);
for (int channel = 0; channel < igPixel.ChannelCount; ++channel)
    igPixel[channel] = 0;
// Change a diagonal line across image to this igPixel.
for (int row = 0; row < igPage.DIB.Height && row < igPage.DIB.Width; ++row)
    igPage.DIB.UpdatePixelFrom(row,row,igPixel);

VB .NET
Dim igPage As ImGearPage
'Load an image into a ImGearPage object
Dim localFile As FileStream = New FileStream("IMG_0713.CR2", FileMode.Open)
Try
    igPage = ImGearFileFormats.LoadPage(localFile, 0)
Finally
    localFile.Close()
End Try
'Create a black pixel appropiate to this image.
Dim igPixel As ImGearPixel = New ImGearPixel(igPage.DIB.ChannelCount, igPage.DIB.BitsPerChannel)
For channel As Integer = 0 To (igPixel.ChannelCount - 1)
    igPixel(channel) = 0
Next
'Change a diagonal line across image to this igPixel.
Dim shorter As Integer
If (igPage.DIB.Width < igPage.DIB.Height) Then
    shorter = igPage.DIB.Width - 1
Else
    shorter = igPage.DIB.Height - 1
End If
For row As Integer = 0 To shorter
    igPage.DIB.UpdatePixelFrom(row, row, igPixel)
Next


ImGearDIB Properties

The ImGearDIB Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
BitDepth Property
Total quantity of bits used to store a single pixel.
BitsPerChannel Property
Allocated (actual) size of store for each channel in bits.
ChannelCount Property
Total quantity of channels in image.
ChannelDepth Property
Depth of particular channel in image.
ChannelDepths Property
Determines the bit depth of each color channel in the image.
ColorSpace Property
Color Space of current image.
ExtraChannelInfo Property
Extra channel info. Always non-null, length is always equal to number of extra channels in the image. Has zero length if image contains no extra channels.
Height Property
Height of image in pixels.
Palette Property
Array of ImGearRGBQuad objects that specify RGB colors for indexed color space. May be null if ImGearDIB instance has other color space.
Resolution Property
Image resolution attributes.
Signed Property
Specifies whether image is signed or not.
Width Property
Width of image in pixels.


BitDepth Property

32-bit
64-bit
CF
P
P
P

Description:

Returns total quantity of bits used to store a single pixel.

Declaration:

public int BitDepth { get; }

Value:

Positive value that represents size of a single pixel in bits.


BitsPerChannel Property

32-bit
64-bit
CF
P
P
P

Description:

Returns allocated (actual) size of any image channel in bits. The values 8, 16 and 32 are used as a basis for the array allocation.

Declaration:

public int BitsPerChannel { get; }

Value:

Positive number that specifies the actual size of channel in bits.

Remarks:

Value returned by this property is correct for uncompressed DIBs only. Compressed DIBs have yet another channels structure. For such DIBs, the property does not have a sense.


ChannelCount Property

32-bit
64-bit
CF
P
P
P

Description:

Returns quantity of channels in image.

Declaration:

public int ChannelCount{ get; }

Value:

Non-zero channels quantity.

Remarks:

Returns the same value as ChannelDepth.Length.


ChannelDepth Property

32-bit
64-bit
CF
P
P
P

Description:

Returns array of depths of each channel in image.

Declaration:

public int[] ChannelDepth{ get; }

Value:

Array of depths for each channel.

Remarks:

Returned value (array) represents structure of image channels. Do not modify any entries of returned array. Doing so may cause ImageGear for .NET to malfunction. Use ImGearProcessing.ChangeChannelDepth member to change channel depths.


ChannelDepths Property

32-bit
64-bit
CF
P
P
P

Description:

This property determines the bit depth of each color channel in the image.

Declaration:

public int[ ] ChannelDepths [get]

Value:

Bit depth of the color channel.


ColorSpace Property

32-bit
64-bit
CF
P
P
P

Description:

Returns image color space information.

Declaration:

public ImGearColorSpace ColorSpace{ get; }

Value:

ImGearColorSpace Structure.

See Also:

ImGearColorSpace Structure


ExtraChannelInfo Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies extra channel info. Always non-null, length is always equal to number of extra channels in the image. Has zero length if image contains no extra channels.

Declaration:

public ImageGear.Core.ImGearExtraChannelInfo[ ] ExtraChannelInfo { get;  set; }

Value:

Array of ImGearExtraChannelInfo Class objects.

See Also:

ImGearExtraChannelInfo Class


Height Property

32-bit
64-bit
CF
P
P
P

Description:

Returns height of image.

Declaration:

public int Height{ get; }

Value:

Height of image in pixels.


Palette Property

32-bit
64-bit
CF
P
P
P

Description:

Provides full access to the DIB's palette represented as array of ImGearRGBQuad.

Palette must present in images with ImGearColorSpaceIDs.I colorspace.

Declaration:

public ImGearRGBQuad[] Palette { get; set }

Value:

null or array of ImGearRGBQuad Structure objects.

Sample Code:

C#
ImGearPage igPage;
// Load an image into a ImGearPage object which already contains
// a palette.
using (FileStream localFile = new FileStream("PALETTE.gif", FileMode.Open))
    igPage = ImGearFileFormats.LoadPage(localFile, 0);
// Create a simple palette of red colors
ImGearRGBQuad[] igRGBQuad = new ImGearRGBQuad[256];
for (int i = 0; i < 256; ++i)
    igRGBQuad[i].Red = (byte)i;
// Assign the new Palette
igPage.DIB.Palette = igRGBQuad;

VB .NET
Dim igPage As ImGearPage
'Load an image into a ImGearPage object which already contains
' a palette.
Dim localFile As FileStream = New FileStream("PALETTE.gif", FileMode.Open)
Try
    igPage = ImGearFileFormats.LoadPage(localFile, 0)
Finally
    localFile.Close()
End Try
'Create a simple palette of red colors
Dim igRGBQuad(256) As ImGearRGBQuad
For i As Integer = 0 To 255
    igRGBQuad(i).Red = i
Next
'Assign the new Palette
igPage.DIB.Palette = igRGBQuad

See Also:

ImGearRGBQuad Structure


Resolution Property

32-bit
64-bit
CF
P
P
P

Description:

Access to image resolution.

Declaration:

public IImGearResolution Resolution { get; set }

Value:

instance of ImGearResolution Structure type.


Signed Property

32-bit
64-bit
CF
P
P
P

Description:

Returns signed/unsigned attribute, applicable to medical images only.

Declaration:

public bool Signed { get }

Value:

false for all non-medical images.


Width Property

32-bit
64-bit
CF
P
P
P

Description:

Returns width of image.

Declaration:

public int Width{ get; }

Value:

Width of image in pixels.


ImGearDIB Methods

The ImGearDIB Class of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
AllocateImage Method
Allocates pixel data based on the DIB header information.
Clone Method
Creates a new object that is a copy of the current instance.
GetAreaCopy Method
Returns array of pixels that are exact copies of pixels in requested rectangular part of image.
GetColumnCopy Method
Returns array of pixels that are exact copies of pixels in requested column part.
GetImage Method
Returns reference to raw image store. Should be used to gain direct access to image pixels.
GetLineCopy Method
Returns array of pixels that are exact copies of pixels on requested line of image.
GetPixelCopy Method
Returns exact copy of requested pixel.
GetRaster Method
Returns reference to raw raster store. Should be used to gain direct access to raster pixels.
GetRowCopy Method
Returns array of pixels that are exact copies of pixels in requested row part of image.
IsEmpty Method
Tells whether store for the pixels has been allocated or not.
UpdateAreaFrom Method
Updates rectangular part of image with new values of incoming pixels.
UpdateColumnFrom Method
Updates part of column with new pixels.
UpdateLineFrom Method
Updates part of line with new pixels.
UpdatePixelFrom Method
Updates single pixel with new value.
UpdateRowFrom Method
Updates part of row with new pixels.


AllocateImage Method

32-bit
64-bit
CF
P
P
P

Description:

Allocates store for pixel data based on the DIB header information. Previous store will be lost if any allocation was made before.

Declaration:

public abstract void AllocateImage()

Return value:

None.

See Also:

ImGearDIB Class


Clone Method

32-bit
64-bit
CF
P
P
P

Description:

Creates new object that is an exact copy of the current instance.

Declaration:

public abstract ImGearDIB Clone()

Return value:

Non-null instance of ImGearDIB Class.

Remarks:

In contrast to MemberwiseClone, this member provides deep copy of object (i.e., all internal objects are cloned as well).


GetAreaCopy Method

32-bit
64-bit
CF
P
P
P

Description:

Returns array of pixels that are exact copies of pixels located in requested rectangular area.

Declaration:

public abstract ImGearPixelArray GetAreaCopy(
    int startColumn, int startRow, int endColumn, int endRow)

Parameters:

Name
Type
Description
startColumn
int
X coordinate of top-left point of rectangular area.
startRow
int
Y coordinate of top-left point of rectangular area.
endColumn
int
X coordinate of bottom-right point of rectangular area.
endRow
int
Y coordinate of bottom-right point of rectangular area.

Return value:

ImGearPixelArray Class instance.


GetColumnCopy Method

32-bit
64-bit
CF
P
P
P

Description:

Returns array of pixels that are exact copies of pixels located in requested column area.

Throws exception if specified points are outside image bounds.

Declaration:

public abstract ImGearPixelArray GetColumnCopy(
    int column, int row, int pointCount)

Parameters:

Name
Type
Description
column
int
Number of column in image.
row
int
Y offset in requested column.
pointCount
int
Quantity of pixels to be retrieved.

Return value:

ImGearPixelArray Class instance.

See Also:

ImGearPixelArray Class


GetImage Method

32-bit
64-bit
CF
P
P
P

Description:

Returns reference to raw pixels store. May be used to obtain direct access to the entire image store.

Structure of image store depends on channels structure and may differ for different DIBs.

Rasters in ImageGear for .NET pixel storage are DWORD-aligned.

Raster size for standard DIBs (not run-ends) in ImageGear for .NET can be calculated using the following formula:

((Width * BitsPerChannel * ChannelCount + 31) & ~31) / BitsPerChannel

Note that the +31 and & ~31 indicate DWORD alignment.

Declaration:

public virtual ImGearArrayRef GetImage()

Parameters:

None.

Return value:

ImGearArrayRef Structure instance.

See Also:

ImGearArrayRef Structure


GetLineCopy Method

32-bit
64-bit
CF
P
P
P

Description:

Returns an array of pixels that are exact copies of the pixels located in the requested (free oriented) line.

Incoming coordinates must not exceed the image area bounds. Otherwise, an exception will be thrown.

Declaration:

public abstract ImGearPixelArray GetLineCopy(
int startColumn, int startRow, int endColumn, int endRow)

Parameters:

Name
Type
Description
startColumn
int
X dimension of line start point.
startRow
int
Y dimension of line start point.
endColumn
int
X dimension of line end point.
endRow
int
Y dimension of line end point.

Return value:

ImGearPixelArray Class instance.

See Also:

ImGearPixelArray Class


GetPixelCopy Method

32-bit
64-bit
CF
P
P
P

Description:

Returns a copy of the requested pixel.

Throws an exception if the coordinates of the requested pixel are outside of the image bounds.

Declaration:

public abstract ImGearPixel GetPixelCopy(int column, int row)

Parameters:

Name
Type
Description
column
int
X coordinate of requested pixel.
row
int
Y coordinate of requested pixel.

Return value:

ImGearPixel Class instance.

See Also:

ImGearPixel Class


GetRaster Method

32-bit
64-bit
CF
P
P
P

Description:

Returns reference to the requested raster store. May be used to obtain direct access to the pixels in the raster.

In ImageGear for .NET, all rasters are kept and indexed in the normal form: the first raster is the top raster, the last raster is the bottom raster. This differs from BMP and older ImageGear versions, where rasters are stored in reverse mode: from bottom to top.

Rasters in ImageGear for .NET pixel storage are DWORD-aligned.

Raster size for standard DIBs (not run-ends) in ImageGear for .NET can be calculated using the following formula:

((Width * BitsPerChannel * ChannelCount + 31) & ~31) / BitsPerChannel

The +31 and & ~31 indicate DWORD alignment. The raster size is in terms of channel values. To calculate the raster size in terms of bytes, divide by 8 instead of BitsPerChannel.

Declaration:

public abstract ImGearArrayRef GetRaster(int row)

Parameters:

Name
Type
Description
row
int
Number of requested row.

Return value:

ImGearArrayRef Structure instance that refers to the raster raw store.

See Also:

ImGearArrayRef Structure


GetRowCopy Method

32-bit
64-bit
CF
P
P
P

Description:

Returns an array of pixels that are exact copies of the pixels located in the requested part of the row.

Throws an exception if the specified points are outside of the image area.

Declaration:

public abstract ImGearPixelArray GetRowCopy(
int column, int row, int pointCount)

Parameters:

Name
Type
Description
column
int
X offset in requested row.
row
int
Number of row in image.
pointCount
int
Quantity of pixels to be retrieved.

Return value:

Non-null reference to ImGearPixelArray Class.

See Also:

ImGearPixelArray Class


IsEmpty Method

32-bit
64-bit
CF
P
P
P

Description:

Tells whether the DIB has pixel data or not.

Declaration:

public abstract bool IsEmpty()

Return value:

true if the store for pixels was allocated during DIB (page) construction or by AllocateImage Method.

See Also:

AllocateImage Method


UpdateAreaFrom Method

32-bit
64-bit
CF
P
P
P

Description:

Updates the pixels of the specified rectangular area.

Declaration:

public abstract void UpdateAreaFrom(int startColumn, int startRow, int endColumn, int
endRow, ImGearPixelArray pixels)

Parameters:

Name
Type
Description
startColumn
int
X coordinate of top-left point of area to be updated.
startRow
int
Y coordinate of top-left point of area to be updated.
endColumn
int
X coordinate of bottom-right point of area to be updated.
endRow
int
Y coordinate of bottom-right point of area to be updated.
pixels
ImGearPixelArray Class
New values for the pixels being updated.

Return Value:

None

Sample Code:

C#
ImGearPage igPage;
// Load an image into a ImGearPage object
using (FileStream localFile = new FileStream("photo.jpg", FileMode.Open))
    igPage = ImGearFileFormats.LoadPage(localFile, 0);
// Get the upper left square of the image to perform a transpose on.
int transposeSize;
if ( igPage.DIB.Height > igPage.DIB.Width)
    transposeSize = igPage.DIB.Width / 2;
else
    transposeSize = igPage.DIB.Height / 2;
ImGearPixelArray igPixelArray = igPage.DIB.GetAreaCopy(0, 0, transposeSize - 1, transposeSize - 1);
// Transpose the pixels in igPixelArray
int channelData;
int transposePosition1, transposePosition2;
for (int row = 1; row < transposeSize; ++ row)
    for (int column = 0; column < row; ++column)
    {
        transposePosition1 = (row * transposeSize) + column;
        transposePosition2 = (column * transposeSize) + row;
        for (int channel = 0; channel < igPixelArray.ChannelCount; channel++)
        {
            channelData = igPixelArray[transposePosition1,channel];
            igPixelArray[transposePosition1, channel] = igPixelArray[transposePosition2,channel];
            igPixelArray[transposePosition2, channel] = channelData;
        }
    }
// Update the original image with the transposed array
igPage.DIB.UpdateAreaFrom(0, 0, transposeSize - 1, transposeSize - 1, igPixelArray);

VB .NET
Dim igPage As ImGearPage
'Load an image into a ImGearPage object
Dim localFile As FileStream = New FileStream("IMG_0713.CR2", FileMode.Open)
Try
    igPage = ImGearFileFormats.LoadPage(localFile, 0)
Finally
    localFile.Close()
End Try
'Get the upper left square of the image to perform a transpose on.
Dim transposeSize As Integer
If (igPage.DIB.Height > igPage.DIB.Width) Then
    transposeSize = igPage.DIB.Width / 2
Else
    transposeSize = igPage.DIB.Height / 2
End If
Dim igPixelArray As ImGearPixelArray = igPage.DIB.GetAreaCopy(0, 0, transposeSize - 1, transposeSize - 1)
'Transpose the pixels in igPixelArray
Dim channelData, transposePosition1, transposePosition2 As Integer
For row As Integer = 1 To transposeSize - 1
    For column As Integer = 0 To row - 1
        transposePosition1 = (row * transposeSize) + column
        transposePosition2 = (column * transposeSize) + row
        For channel As Integer = 0 To igPixelArray.ChannelCount - 1
            channelData = igPixelArray(transposePosition1, channel)
            igPixelArray(transposePosition1, channel) = igPixelArray(transposePosition2, channel)
            igPixelArray(transposePosition2, channel) = channelData
        Next
    Next
Next
'Update the original image with the transposed array
igPage.DIB.UpdateAreaFrom(0, 0, transposeSize - 1, transposeSize - 1, igPixelArray)

See Also:

ImGearPixelArray Class


UpdateColumnFrom Method

32-bit
64-bit
CF
P
P
P

Description:

Updates the pixels of the specified column area.

Declaration:

public abstract void UpdateColumnFrom(int column, int row, ImGearPixelArray pixels)

Parameters:

Name
Type
Description
column
int
Number of column to update.
row
int
Y offset in column.
pixels
ImGearPixelArray Class
New values for pixels being updated.

Return Value:

None

See Also:

ImGearPixelArray Class


UpdateLineFrom Method

32-bit
64-bit
CF
P
P
P

Description:

This method exchanges the pixels of the specified line.

Declaration:

public abstract void UpdateLineFrom(int startColumn, int startRow, int endColumn, int
endRow, ImGearPixelArray pixels)

Parameters:

Name
Type
Description
startColumn
int
X coordinate of line start.
startRow
int
Y coordinate of line start.
endColumn
int
X coordinate of line end.
endRow
int
Y coordinate of line end.
pixels
ImGearPixelArray Class
New values for pixels being updated.

Return Value:

None

See Also:

ImGearPixelArray Class


UpdatePixelFrom Method

32-bit
64-bit
CF
P
P
P

Description:

Updates a particular pixel value.

Declaration:

public abstract void UpdatePixelFrom(int column, int row, ImGearPixel Pixel)

Parameters:

Name
Type
Description
column
int
X coordinate of pixel.
row
int
Y coordinate of pixel.
Pixel
ImGearPixel Class
New value for the pixel.

Return Value:

None

See Also:

ImGearPixel Class


UpdateRowFrom Method

32-bit
64-bit
CF
P
P
P

Description:

Updates the pixels of the specified row area.

Declaration:

public abstract void UpdateRowFrom(int column, int row, ImGearPixelArray pixels)

Parameters:

Name
Type
Description
column
int
X offset in row.
row
int
Number of row to be updated.
pixels
ImGearPixelArray Class
New values for the pixels being updated.

Return Value:

None

See Also:

ImGearPixelArray Class


ImGearDICOMMetadataDictRecord Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents DICOM metadata dictionary record.

Declaration:

public class ImGearDICOMMetadataDictRecord

Members:

Constructors
Name
Description
ImGearDICOMMetadataDictRecord Constructor
Creates a new instance of ImGearDICOMMetadataDictRecord structure.

Properties
Name
Description
Name Property
Tag name.
Tag Property
Tag ID.

Fields
Name
Description
MaxMultiplicity Field
Maximum value multiplicity allowed for this tag.
ValueRepresentation Field
Default value representation for this tag.


ImGearDICOMMetadataDictRecord Constructors

The ImGearDICOMMetadataDictRecord Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearDICOMMetadataDictRecord Constructor
Creates a new instance of ImGearDICOMMetadataDictRecord structure.


ImGearDICOMMetadataDictRecord Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates a new instance of ImGearDICOMMetadataDictRecord Class object.

Declaration:

public ImGearDICOMMetadataDictRecord ( System.Int32 tag , System.String name ,
ImageGear.Formats.DICOM.ImGearDICOMValueRepresentations vr , System.Int32 maxVM )

Parameters:

Name
Type
Description
tag
Int32
Tag ID
name
String
Tag name
vr
ImGearDICOMValueRepresentations Enumeration
Default Value Representation
maxVM
Int32
Maximum allowed value multiplicity

Return Value:

The new instance of ImGearDICOMMetadataDictRecord Class object.

See Also:

ImGearDICOMMetadataDictRecord Class

ImGearDICOMValueRepresentations Enumeration


ImGearDICOMMetadataDictRecord Properties

The ImGearDICOMMetadataDictRecord Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
Name Property
Tag name
Tag Property
Tag ID


Name Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the tag name.

Declaration:

public virtual new string Name { get, set }

Value:

Any string.

Default value:

""


Tag Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the tag ID.

Declaration:

public virtual new int Tag { get, set }

Value:

Any integer number.

Default value:

0


ImGearDICOMMetadataDictRecord Fields

The ImGearDICOMMetadataDictRecord Class of the ImageGear.Core Namespace has the following fields:

Fields
Name
Description
MaxMultiplicity Field
Maximum value multiplicity allowed for this tag.
ValueRepresentation Field
Default value representation for this tag.


MaxMultiplicity Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies the maximum value multiplicity (number of data values) allowed for this tag:

  • Positive value means that the data element must have exactly MaxMultiplicity values.
  • Negative value means that the data element must have from 1 to -MaxMultiplicity values.
  • Zero value means that the data element can have any number of values.

Declaration:

public int MaxMultiplicity

Value:

Any integer number.

Default value:

0


ValueRepresentation Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies the default value representation (native type) for the tag.

Declaration:

public ImageGear.Formats.DICOM.ImGearDICOMValueRepresentations ValueRepresentation

Value:

Any ImGearDICOMValueRepresentations Enumeration value.

Default value:

ImGearDICOMValueRepresentations Enumeration.None

See Also:

ImGearDICOMValueRepresentations Enumeration


ImGearDisplayChannel Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents the display attributes for an individual channel.

Declaration:

public class ImGearDisplayChannel

Members:

Constructors
Name
Description
ImGearDisplayChannel Constructor
Creates and initializes an instance of ImGearDisplayChannel Class.

Fields
Name
Description
Visible Field
Specifies a visibility attribute.

See Also:

ImGearDisplayChannels Class


ImGearDisplayChannel Constructors

The ImGearDisplayChannel Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearDisplayChannel Constructor
Creates and initializes an instance of ImGearDisplayChannel Class.


ImGearDisplayChannel Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearDisplayChannel Class.

Declaration:

public ImGearDisplayChannel()

Return Value:

The new instance of ImGearDisplayChannel Class.

See Also:

ImGearDisplayChannel Class


ImGearDisplayChannel Fields

The ImGearDisplayChannel Class of the ImageGear.Core Namespace has the following fields:

Fields
Name
Description
Visible Field
Specifies a visibility attribute.


Visible Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies a visibility attribute.

Declaration:

public bool Visible

Value:

true/false.

Example:

C#
m_PageView.Display.Channels[StartExtra + 0].Visible = true;

Visual Basic
m_PageView.Display.Channels[StartExtra + 0].Visible = True
Display.Channels[StartExtra + 0].Visible

See Also:

ImGearDisplayChannel Class


ImGearDisplayChannels Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents a collection of ImGearDisplayChannel Classes.

Declaration:

public class ImGearDisplayChannels

Members:

Properties
Name
Description
Count Property
Specifies the number of ImGearDisplayChannel Class objects in the collection.
IsSynchronized Property
Gets a value indicating whether access to the collection is synchronized.
SyncRoot Property
Gets an object that can be used to synchronize access to the collection.
this Property
Gets the collection member with specified index.

Methods
Name
Description
CopyTo Method
Copies a range of elements to the specified array.
GetEnumerator Method
Returns IEnumerator interface used for enumeration all ImGearDisplayChannel Class objects in the collection.

See Also:

ImGearDisplayChannel Class


ImGearDisplayChannels Properties

The ImGearDisplayChannels Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
Count Property
Specifies the number of ImGearDisplayChannel Class objects in the collection.
IsSynchronized Property
Gets a value indicating whether access to the collection is synchronized.
SyncRoot Property
Gets an object that can be used to synchronize access to the collection.
this Property
Gets the collection member with specified index.


Count Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the number of ImGearDisplayChannel Class objects in the collection.

Declaration:

public int Count { get; }

Value:

Integer value.

See Also:

ImGearDisplayChannels Class


IsSynchronized Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets a value indicating whether access to the collection is synchronized.

Declaration:

public bool IsSynchronized { get; }

Value:

true/false.

See Also:

ImGearDisplayChannels Class


SyncRoot Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets an object that can be used to synchronize access to the collection.

Declaration:

public object SyncRoot { get; }

Value:

Object.

Example:

C#
syncRoot = m_PageView.Display.Channels.SyncRoot;

Visual Basic
syncRoot = m_PageView.Display.Channels.SoyncRot

See Also:

ImGearDisplayChannels Class


this Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets the collection member with the specified index.

Declaration:

public ImageGear.Display.ImGearDisplayChannel this[int index] { get;  set; }

Value:

ImGearDisplayChannel Class.

See Also:

ImGearDisplayChannels Class


ImGearDisplayChannels Methods

The ImGearDisplayChannels Class of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
CopyTo Method
Copies a range of elements to the specified array.
GetEnumerator Method
Returns IEnumerator interface used for enumeration all ImGearDisplayChannel Class objects in the collection.


CopyTo Method

32-bit
64-bit
CF
P
P
P

Description:

This method copies a range of elements to the specified array.

Declaration:

public void CopyTo(System.Array array, int index)

Parameters:

Name
Type
Description
array
System.Array
ImGearDisplayChannel[] array to copy the color elements to.
index
int
The zero-based index in array at which copying begins.

Return Value:

None.

Example:

C#
m_PageView.Display.Channels.CopyTo(array, idx);

Visual Basic
m_PageView.Display.Channels.CopyTo(array, idx)

See Also:

ImGearDisplayChannels Class


GetEnumerator Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns IEnumerator interface used for enumeration all ImGearDisplayChannel Class objects in the collection.

Declaration:

public System.Collections.IEnumerator GetEnumerator()

Return Value:

System.Collections.IEnumerator interface.

See Also:

ImGearDisplayChannels Class


ImGearDocument Class

32-bit
64-bit
CF
P
P
P

Description:

Represents a collection of ImGearPage objects. May be stand-alone or associated with an external file. In addition to pages, it contains the document level metadata.

Declaration:

public class ImGearDocument

Members:

Constructors
Name
Description
ImGearDocument Constructor
Initializes instance from list of pages and metadata tree.

Properties
Name
Description
Metadata Property
Document-level metadata tree.
Pages Property
List of pages available in document.

Methods
Name
Description
Clone Method
Creates a new object that is the exact copy of the current instance.


ImGearDocument Constructors

The ImGearDocument Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearDocument Constructor
Initializes an instance from a list of pages and metadata tree.


ImGearDocument Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes the instance of ImGearDocument Class.

Declaration:

public ImGearDocument()

Return Value:

New instance of ImGearDocument Class.

See Also:

ImGearDocument Class


ImGearDocument Properties

The ImGearDocument Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
Metadata Property
Document-level metadata tree.
Pages Property
List of pages available in document.


Metadata Property

32-bit
64-bit
CF
P
P
P

Description:

Read-only property to obtain document-level metadata.

Declaration:

public ImageGear.Core.ImGearMetadataHead Metadata { get; }

Value:

ImGearMetadataHead Class.

See Also:

ImGearMetadataHead Class


Pages Property

32-bit
64-bit
CF
P
P
P

Description:

Returns a modifiable list of pages available in the document.

Declaration:

public virtual ImageGear.Core.ImGearDocumentPageArray Pages { get; }

Value:

ImGearDocumentPageArray Class.

See Also:

ImGearDocumentPageArray Class


ImGearDocument Methods

The ImGearDocument Class of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
Clone Method
Creates a new object that is the exact copy of the current instance.


Clone Method

32-bit
64-bit
CF
P
P
P

Description:

Creates a new object that is the exact copy of the current instance.

In contrast to MemberwiseClone, this method performs a deep copy (i.e., all objects, including contained pages, are cloned as well).

Declaration:

public ImGearDocument Clone()

Value:

ImGearDocument Class.

See Also:

ImGearDocument Class


ImGearDocumentPageArray Class

32-bit
64-bit
CF
P
P
P

Description:

Represents a collection of pages within ImGearDocument class.

On adding pages, checks that the new page is not attached to any other document. The Remove method detaches a page from the document. If it is referenced from anywhere else, it remains a valid stand-alone page.

null is a valid value as a contained reference. Well-formed page array may contain any number of null entries. An exception is made for the formats where pages are physically continuous (i.e., PDF). Note that setting a page to null is different from removing a page from the document - the former does not change page count, whereas the latter does.

Declaration:

public class ImGearDocumentPageArray

Members:

Properties
Name
Description
Count Property
Gets the number of pages contained in the document.
IsFixedSize Property
Gets a value indicating whether the Array has a fixed size.
IsReadOnly Property
Gets a value indicating whether the Array is read-only.
IsSynchronized Property
Gets a value indicating whether access to the Array is synchronized (thread-safe).
SyncRoot Property
Gets an object that can be used to synchronize access to the Array.
this Property
Gets or sets the element at the specified index.

Methods
Name
Description
Add Method
Adds a new ImGearPage to the end of the array of pages.
Clear Method
Removes all pages from the document.
Clone Method
Performs a deep copy of the page array.
Contains Method
Tells whether the array contains a particular page.
CopyTo Method
Copies all the pages from the current page array to the page array starting at index.
GetEnumerator Method
Returns an enumerator that can iterate through the page array.
IndexOf Method
Returns the index of a page in the array.
Insert Method
Inserts a page into the array at index position.
Remove Method
Removes a page from the array.
RemoveAt Method
This method removes page with specified index from the array.

Sample Code:

C#
ImGearDocument igDocument;
using (FileStream localFile = new FileStream("MULTIPAG.TIF", FileMode.Open))
{
    int pageCount = ImGearFileFormats.GetPageCount(localFile, ImGearFormats.UNKNOWN);
    igDocument = ImGearFileFormats.LoadDocument(localFile, 0, pageCount);
}
ImGearPage igPage = igDocument.Pages[0];
igDocument.Pages.Remove(igPage);
igDocument.Pages.Insert(1,igPage);

VB .NET
Dim igDocument As ImGearDocument
Dim localFile As FileStream = New FileStream("MULTIPAG.TIF", FileMode.Open)
Try
    Dim pageCount As Integer = ImGearFileFormats.GetPageCount(localFile, ImGearFormats.UNKNOWN)
    igDocument = ImGearFileFormats.LoadDocument(localFile, 0, pageCount)
Finally
    localFile.Close()
End Try
Dim igPage As ImGearPage = igDocument.Pages(0)
igDocument.Pages.Remove(igPage)
igDocument.Pages.Insert(1, igPage)


ImGearDocumentPageArray Properties

The ImGearDocumentPageArray Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
Count Property
Gets the number of pages contained in the document.
IsFixedSize Property
Gets a value indicating whether the Array has a fixed size.
IsReadOnly Property
Gets a value indicating whether the Array is read-only.
IsSynchronized Property
Gets a value indicating whether access to the Array is synchronized (thread-safe).
SyncRoot Property
Gets an object that can be used to synchronize access to the Array.
this Property
Gets or sets the element at the specified index.


Count Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets the number of pages contained in the document.

Declaration:

public int Count [get]

Value:

Any positive integer value.


IsFixedSize Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets a value indicating whether the Array has a fixed size.

Declaration:

public bool IsFixedSize [get]

Value:

True, false


IsReadOnly Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets a value indicating whether the Array is read-only.

Declaration:

public bool IsReadOnly [get]

Value:

True, false


IsSynchronized Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets a value indicating whether access to the Array is synchronized (thread-safe).

Declaration:

public bool IsSynchronized [get]

Value:

True, false


SyncRoot Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets an object that can be used to synchronize access to the Array.

Declaration:

public object SyncRoot [get]

Value:

An object that can be used to synchronize access to the Array.


this Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets or sets the element at the specified index.

Declaration:

public virtual ImageGear.Core.ImGearPage this[int index] {public  get; public  set; }

Value:

ImGearPage Class

See Also:

ImGearPage Class


ImGearDocumentPageArray Methods

The ImGearDocumentPageArray Class of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
Add Method
Adds a new ImGearPage to the end of the array of pages.
Clear Method
Removes all pages from the document.
Clone Method
Performs a deep copy of the page array.
Contains Method
This method tells whether the array contains a particular page.
CopyTo Method
Copies all the pages from the current page array to the page array starting at index.
GetEnumerator Method
Returns an enumerator that can iterate through the page array.
IndexOf Method
Returns the index of a page in the array.
Insert Method
Inserts page into the array at index position.
Remove Method
Removes a page from the array.
RemoveAt Method
This method removes page with specified index from the array.


Add Method

32-bit
64-bit
CF
P
P
P

Description:

This method adds a new ImGearPage to the end of the array of pages.

The method throws an exception if the page is already attached to some document.

Declaration:

public virtual int Add(ImGearPage page);

Parameters:

Name
Type
Description
page
ImGearPage Class
Page to be added.

Return value:

Index in the array where new page is added.

See Also:

ImGearPage Class


Clear Method

32-bit
64-bit
CF
P
P
P

Description:

This method removes all pages from the document.

Declaration:

public virtual void Clear();

Return Value:

None.

See Also:

N/A


Clone Method

32-bit
64-bit
CF
P
P
P

Description:

This method performs a deep copy of the page array, i.e., clones the pages as well.

Declaration:

public ImGearDocumentPageArray Clone();

Return Value:

None.

See Also:

ImGearDocumentPageArray Class


Contains Method

32-bit
64-bit
CF
P
P
P

Description:

This method tells whether the array contains a particular page.

Declaration:

public bool Contains(ImGearPage page);

Parameters:

Name
Type
Description
page
ImGearPage Class
The page to check for.

Return value:

True or False.

See Also:

ImGearPage Class


CopyTo Method

32-bit
64-bit
CF
P
P
P

Description:

This method copies all the pages from the current page array to the page array starting at index.

Declaration:

public virtual void CopyTo(System.Array ar, int index)

Parameters:

Name
Type
Description
ar
ImGearPage Class
Destination array
index
int
Starting index

Return value:

None.


GetEnumerator Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns an enumerator that can iterate through the page array.

NOTE: Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection. Initially, the enumerator is positioned before the first element in the collection.

Declaration:

public System.Collections.IEnumerator GetEnumerator()

Return Value:

An IEnumerator that can be used to iterate through the page array.

See Also:

ImGearDocumentPageArray Class


IndexOf Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns the index of a page in the array.

Declaration:

public int IndexOf(ImGearPage page);

Parameters:

Name
Type
Description
page
ImGearPage Class
Page to retrieve index of.

Return value:

The location (index) of a page in the array, or -1 if the page is not in the list.

See Also:

ImGearPage Class


Insert Method

32-bit
64-bit
CF
P
P
P

Description:

This method inserts a page into the array at index position.

Declaration:

public virtual void Insert(int index, ImGearPage page);

Parameters:

Name
Type
Description
index
int
Position to insert at
page
ImGearPage Class
Page to insert

Return value:

None.

See Also:

ImGearPage Class


Remove Method

32-bit
64-bit
CF
P
P
P

Description:

This method removes a page from the array.

Declaration:

public virtual void Remove(ImGearPage page)

Parameters:

Name
Type
Description
page
ImGearPage Class
Page to remove.

Return value:

None.

See Also:

ImGearPage Class


RemoveAt Method

32-bit
64-bit
CF
P
P
P

Description:

This method removes a page with the specified index from the array.

Declaration:

public virtual void RemoveAt(int index);

Parameters:

Name
Type
Description
index
int
Page index to remove at.

Return value:

None.


ImGearException Class

32-bit
64-bit
CF
P
P
P

Description:

Base class for all exceptions thrown by ImageGear for .NET. Contains detailed information about the error that occured.

This Class does not have any public constructor. All instances are created implicitly by overloads of the ThrowError static member.

Declaration:

public sealed class ImGearException : System.Exception

Members:

Properties
Name
Description
ErrorCode Property
Error code from ImGearErrorCodes enumeration.
Value1 Property
Integer data supplied to error code.
Value2 Property
Integer data supplied to error code.

Methods
Name
Description
ThrowError Method
Throws exception of ImGearException class.
ThrowError Method
Throws exception of ImGearException class.
ThrowError Method
Throws exception of ImGearException class.
ThrowError Method
Throws exception of ImGearException class.


ImGearException Properties

The ImGearException Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
ErrorCode Property
Error code from ImGearErrorCodes enumeration.
Value1 Property
Integer data supplied to error code.
Value2 Property
Integer data supplied to error code.


ErrorCode Property

32-bit
64-bit
CF
P
P
P

Description

Returns or updates the code of the error that occured.

Declaration:

public ImageGear.Core.ImGearErrorCodes ErrorCode { get;  set; }

Value:

ImGearErrorCodes Enumeration value.

See Also:

ImGearErrorCodes Enumeration


Value1 Property

32-bit
64-bit
CF
P
P
P

Description

Integer data supplied to the error code. Its meaning depends on the reason of exception.

Declaration:

public int Value1 { get;  set; }

Value:

Integer value.

See Also:

ImGearException Class

ThrowError Method

ThrowError Method


Value2 Property

32-bit
64-bit
CF
P
P
P

Description

Integer data supplied to the error code. Its meaning depends on the reason of exception.

Declaration:

public int Value2 { get;  set; }

Value:

Integer value.

See Also:

ImGearException Class

ThrowError Method


ImGearException Methods

The ImGearException Class of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
ThrowError Method
Throws exception of ImGearException class.
ThrowError Method
Throws exception of ImGearException class.
ThrowError Method
Throws exception of ImGearException class.
ThrowError Method
Throws exception of ImGearException class.


ThrowError Method

32-bit
64-bit
CF
P
P
P

Description:

Throws exception of ImGearException class.

Declaration:

static void ThrowError(ImGearErrorCodes errCode, string description, int value1, int
value2)

Parameters:

Name
Type
Description
errCode
ImGearErrorCodes Enumeration
Numeric code of error from ImGearErrorCodes.
description
string
Human readable information about reason of exception.
value1
int
Integer data supplied to error code. Its meaning depends on reason of exception.
value2
int
Integer data supplied to error code. Its meaning depends on reason of exception.

Return Value:

None.

See Also:

ImGearErrorCodes Enumeration

Value1 Property

Value2 Property


ThrowError Method

32-bit
64-bit
CF
P
P
P

Description:

Throws exception of ImGearException class.

Declaration:

static void ThrowError(ImGearErrorCodes errCode, string description, int value1)

Parameters:

Name
Type
Description
errCode
ImGearErrorCodes Enumeration
Numeric code of error from ImGearErrorCodes.
description
string
Human readable information about reason of exception.
value1
int
Integer data supplied to error code. Its meaning depends on reason of exception.

Return Value:

None.

See Also:

ImGearErrorCodes Enumeration

Value1 Property


ThrowError Method

32-bit
64-bit
CF
P
P
P

Description:

Throws exception of ImGearException class.

Declaration:

static void ThrowError(ImGearErrorCodes errCode, string description)

Parameters:

Name
Type
Description
errCode
ImGearErrorCodes Enumeration
Numeric code of error from ImGearErrorCodes.
description
string
Human readable information about reason of exception.

Return Value:

None.

See Also:

ImGearErrorCodes Enumeration


ThrowError Method

32-bit
64-bit
CF
P
P
P

Description:

Throws exception of ImGearException class.

Declaration:

static void ThrowError(ImGearErrorCodes errCode)

Parameters:

Name
Type
Description
errCode
ImGearErrorCodes Enumeration
Numeric code of error from ImGearErrorCodes.

Return Value:

None.

See Also:

ImGearErrorCodes Enumeration


ImGearExtraChannelInfo Class

32-bit
64-bit
CF
P
P
P

Description:

This is a general extra channel class. Each extra channel in image has ImGearExtraChannelInfo object associated with it.

Declaration:

public class ImGearExtraChannelInfo

Members:

Constructors
Name
Description
ImGearExtraChannelInfo Constructor
Creates a new instance of ImGearExtraChannelInfo class.

Properties
Name
Description
Name Property
Specifies the name of extra channel.
Type Property
Specifies the type of extra channel.


ImGearExtraChannelInfo Constructors

The ImGearExtraChannelInfo Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearExtraChannelInfo Constructor
Creates a new instance of ImGearExtraChannelInfo class.


ImGearExtraChannelInfo Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearExtraChannelInfo Class.

Declaration:

public ImGearExtraChannelInfo()

Return Value:

The new instance of ImGearExtraChannelInfo Class.

See Also:

ImGearExtraChannelInfo Class


ImGearExtraChannelInfo Properties

The ImGearExtraChannelInfo Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
Name Property
Specifies the name of extra channel.
Type Property
Specifies the type of extra channel.


Name Property

32-bit
64-bit
CF
P
P
P

Description

This property specifies the name of the extra channel.

Declaration:

public string Name { get;  set; }

Value:

String.

Example:

C#
name = dib.ExtraChannelInfo[0].Name;

Visual Basic
name = dib.ExtraChannelInfo[0].Name

See Also:

ImGearExtraChannelInfo Class


Type Property

32-bit
64-bit
CF
P
P
P

Description

This property specifies the type of extra channel.

Declaration:

public ImageGear.Core.ImGearExtraChannelType Type { get; }

Value:

ImGearExtraChannelType Enumeration value.

See Also:

ImGearExtraChannelType Enumeration


ImGearFullLUT Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents a Look Up table that contains full table of values for each possible input index.

Declaration:

public class ImGearFullLUT : ImageGear.Core.ImGearLUT

Members:

Constructors
Name
Description
ImGearFullLUT Constructor
Creates a new instance of ImGearFullLUT class.

Properties
Name
Description
InputDepth Property
Specifies input depth of the LUT
InputIsSigned Property
Specifies whether LUT input values are signed
OutputDepth Property
Specifies output depth of the LUT
OutputIsSigned Property
Specifies whether LUT output values are signed
this Property
Returns LUT output value corresponding to Int32 input value.
this Property
Returns LUT output value corresponding to Int64 input value.

Fields
Name
Description
Table Field
Provides direct access to the LUT table.

Methods
Name
Description
Clone Method
Creates a deep copy of the object.
Concatenate Method
Concatenates the content of the specified lut into the instance of the ImGearFullLUT Class.
CopyFrom Method
Duplicates the content of the specified lut into the instance of the ImGearFullLUT class that this method is called from.
GetTableIndex Method
Obtains index in the table corresponding to Int32 input value.
GetTableIndex Method
Obtains index in the table corresponding to Int64 input value.


ImGearFullLUT Constructors

The ImGearColorProfile Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearFullLUT Constructor
Creates a new instance of ImGearFullLUT class.


ImGearFullLUT Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates a new instance of ImGearFullLUT object, and allocates the internal table, according to input and output depths.

Declaration:

public ImGearFullLUT ( int inputDepth , bool inputIsSigned , int outputDepth , bool
outputIsSigned )

Parameters:

Name
Type
Description
inputDepth
Int
Specifies input depth of the LUT
inputIsSigned
Boolean
Specifies whether LUT input is signed
outputDepth
Int
Specifies output depth of the LUT
outputIsSigned
Boolean
Specifies whether LUT output is signed

Return Value:

The new instance of ImGearFullLUT Class object.


ImGearFullLUT Properties

The ImGearFullLUT Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
InputDepth Property
Specifies input depth of the LUT
InputIsSigned Property
Specifies whether LUT input values are signed
OutputDepth Property
Specifies output depth of the LUT
OutputIsSigned Property
Specifies whether LUT output values are signed
this Property
Returns LUT output value corresponding to Int32 input value.
this Property
Returns LUT output value corresponding to Int64 input value.


InputDepth Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the input depth of the LUT.

Declaration:

public override int InputDepth { get }

Value:

Any integer number.

Default value:

0


InputIsSigned Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies whether LUT input values are signed.

Declaration:

public override bool InputIsSigned{ get }

Value:

True, False

Default value:

False


OutputDepth Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the output depth of the LUT.

Declaration:

public override int OutputDepth{ get }

Value:

Any integer number.

Default value:

N/A


OutputIsSigned Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies whether the LUT output values are signed.

Declaration:

public override bool OutputIsSigned { get }

Value:

True, False

Default value:

False


this Property

32-bit
64-bit
CF
P
P
P

Description:

This indexed property sets or returns LUT output value corresponding to Int32 input value.

Declaration:

public const override int this (Integer Index){ get, set }

Value:

Integer number.

Default value:

None


this Property

32-bit
64-bit
CF
P
P
P

Description:

This indexed property sets or returns LUT output value corresponding to Int64 input value.

Declaration:

public const override long this (long Index){ get, set }

Value:

Long number

Default value:

None


ImGearFullLUT Fields

The ImGearFullLUT Class of the ImageGear.Core Namespace has the following fields:

Fields
Name
Description
Table Field
Provides direct access to the LUT table.


Table Field

32-bit
64-bit
CF
P
P
P

Description:

This field provides direct access to the LUT table.

Actual type of the array depends on the output depth of the LUT:

  • If output depth is between 1 and 8, Table is byte[ ]
  • If output depth is between 9 and 16, Table is Int16[ ]
  • If output depth is between 17 and 32, Table is Int32[ ]

Length of the table depends on the input depth, as follows:

Length = 2 ^ inputDepth.

Declaration:

public System.Array Table

Value:

byte[ ], Int16[ ] or Int32[ ]

Default value:

None


ImGearFullLUT Methods

The ImGearFullLUT Class of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
Clone Method
Creates a deep copy of the object
Concatenate Method
Concatenates the content of the specified lut into the instance of the ImGearFullLUT Class
CopyFrom Method
Duplicates the content of the specified lut into the instance of the ImGearFullLUT class that this method is called from.
GetTableIndex Method
Obtains index in the table corresponding to Int32 input value.
GetTableIndex Method
Obtains index in the table corresponding to Int64 input value.


Clone Method

32-bit
64-bit
CF
P
P
P

Description:

This method clones ImGearFullLUT Class object.

Declaration:

public override ImageGear.Core.ImGearLUT Clone ()

Return Value:

The new instance of ImGearLUT Class.

Example:

ImGearFullLUT clone = (ImGearFullLUT)fullLUT.Clone();


Concatenate Method

32-bit
64-bit
CF
P
P
P

Description:

This method concatenates the content of the specified LUT into the instance of the ImGearFullLUT Class that this method is called from.

Declaration:

public override ImageGear.Core.ImGearLUT Concatenate(ImageGear.Core.ImGearLUT lut)

Parameters:

Name
Type
Description
lut
ImGearLUT Class
LUT to be concatenated.

Return Value:

ImGearLUT Class.

See Also:

ImGearLUT Class


CopyFrom Method

32-bit
64-bit
CF
P
P
P

Description:

This method duplicates the content of the specified LUT into the instance of the ImGearFullLUT Class class that this method is called from. LUT type and depths attributes must be compatible with the class this method is called from.

Declaration:

public override void CopyFrom ( ImageGear.Core.ImGearLUT lut )

Parameters:

Name
Type
Description
lut
ImGearLUT Class
LUT to be copied.

Return Value:

None.


GetTableIndex Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns table index corresponding to input value. If LUT input is signed, and input value is negative, table index is calculated as 2's complement to number of table entries. Otherwise, table index is equal to input value.

For example, if input depth is 12, and input value is -1, table index is 4096 - 1 = 4095.

Declaration:

public uint GetTableIndex(int InputIndex)

Parameters:

Name
Type
Description
InputIndex
Int
Input index.

Return Value:

Integer number.

Example:

int InputValue = -1000;
uint TableIndex = fullLUT.GetTableIndex(Inputvalue);


GetTableIndex Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns table index corresponding to input value. If LUT input is signed, and input value is negative, table index is calculated as 2's complement to number of table entries. Otherwise, table index is equal to input value.

For example, if input depth is 12, and input value is -1, table index is 4096 - 1 = 4095.

Declaration:

public uint GetTableIndex(long InputIndex)

Parameters:

Name
Type
Description
InputIndex
long
Input index.

Return Value:

Integer number.

Example:

int InputValue = -1000;
UInt TableIndex = fullLUT.GetTableIndex(Inputvalue);


ImGearLicense Class

32-bit
64-bit
CF
P
P
P

Description:

Manages licensing data (i.e., license type and key).

NOTE: To be able to use any ImageGear for .NET functionality, licensing information must be provided. For more information see ImageGear for .NET licensing scheme.

Declaration:

public sealed class ImGearLicense

Members:

Constructors
Name
Description
ImGearLicense Constructor
Creates new instance of ImGearLicense Class.

Methods
Name
Description
SetOEMLicenseKey Method
Sets OEM license key.
SetSolutionKey Method
Sets solution key.
SetSolutionName Method
Sets name of solution.

Sample Code:

C#
// Solution Name, Key, and License Key provided by AccuSoft for your deployment
ImGearLicense.SetSolutionName("Your Platinum Solution Name");
ImGearLicense.SetSolutionKey(0x473F47EC, 0xDEDCEDC4, 0xAFFBB23E, 0xFBFBDE4A);
ImGearLicense.SetOEMLicenseKey("1.0.ETNBUSPpPqd7dcDjWSWgxSagvcdq4p4pDSUhWK07WjbKPLIcWjUgxgvcUhD7vBacmKlqmgW" +
    "SUcbjeqeLNpWHdpPHPLaL4SmLIBNpdcNp0LlqbgmjD7W6itvhelD6agvqagvSDuPcWBbKmu0gIux7aKdKPPbgDTvcWjxGDHxpWGlKP" +
    "gxHagNKPKau0KvhepUSmh46aT4B4gP6vp4pb7bcITeqmhdpljxBUHIjepWL0h4gmKv6Wp0jWlaurY5khtnSbjP6vKNpmu0pIHWj4KI" +
    "caKbhmqxqmHa6v64BDGdqdueGaq0u4WNgj");

C#
if (IntPtr.Size == 8)
    // 64bit eval and development solution name
    ImGearLicense.SetSolutionName("AccuSoft 3-41-16");
else
    // 32bit eval and development solution name
    ImGearLicense.SetSolutionName("AccuSoft 3-40-16");

VB .NET
'Solution Name, Key, and License Key provided by AccuSoft for your deployment
ImGearLicense.SetSolutionName("Your Platinum Solution Name")
ImGearLicense.SetSolutionKey(&H473F47ECUL, &HDEDCEDC4UL, &HAFFBB23EUL, &HFBFBDE4AUL)
ImGearLicense.SetOEMLicenseKey("1.0.ETNBUSPpPqd7dcDjWSWgxSagvcdq4p4pDSUhWK07WjbKPLIcWjUgxgvcUhD7vBacmKlqmgW" + _
    "SUcbjeqeLNpWHdpPHPLaL4SmLIBNpdcNp0LlqbgmjD7W6itvhelD6agvqagvSDuPcWBbKmu0gIux7aKdKPPbgDTvcWjxGDHxpWGlKP" + _
    "gxHagNKPKau0KvhepUSmh46aT4B4gP6vp4pb7bcITeqmhdpljxBUHIjepWL0h4gmKv6Wp0jWlaurY5khtnSbjP6vKNpmu0pIHWj4KI" + _
    "caKbhmqxqmHa6v64BDGdqdueGaq0u4WNgj")

VB .NET
If (IntPtr.Size = 8) Then
    '64bit eval and development solution name
    ImGearLicense.SetSolutionName("AccuSoft 3-41-16")
Else
    '32bit eval and development solution name
    ImGearLicense.SetSolutionName("AccuSoft 3-40-16")
End If


ImGearLicense Constructors

The ImGearLicense Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearLicense Constructor
Creates new instance of ImGearLicense Class.


ImGearLicense Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates a new instance of ImGearLicense Class.

Declaration:

public ImGearLicense()

Return Value:

The new instance of ImGearLicense Class object.

See Also:

ImGearLicense Class

32-bit
64-bit
CF
P
P
P


ImGearLicense Methods

The ImGearLicense Class of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
SetOEMLicenseKey Method
Sets OEM license key.
SetSolutionKey Method
Sets solution key.
SetSolutionName Method
Sets name of solution.


SetOEMLicenseKey Method

32-bit
64-bit
CF
P
P
P

Description:

Sets OEM license key.

When there iswhen there is an OEM license type, there is no need to call any other members of ImGearLicense class.

Declaration:

static void SetOEMLicenseKey(string licKey)

Parameters:

Name
Type
Description
licKey
string
Obtained from AccuSoft OEM license key.

Return Value:

None.

See Also:

ImGearLicense Class


SetSolutionKey Method

32-bit
64-bit
CF
P
P
P

Description:

Sets solution key.

Solution name must be set up in addition to key.

Declaration:

static void SetSolutionKey(int key1, int key2, int key3, int key4)

Parameters:

Name
Type
Description
key1
int
Key1 part of solution key.
key2
int
Key2 part of solution key.
key3
int
Key3 part of solution key.
key4
int
Key4 part of solution key.

Return Value:

None.

See Also:

ImGearLicense Class


SetSolutionName Method

32-bit
64-bit
CF
P
P
P

Description:

Sets name of solution for which key was obtained.

Solution key must be set up in addition to name.

Declaration:

static void SetSolutionName(string SolutionName)

Parameters:

Name
Type
Description
SolutionName
string
Name of solution.

Return Value:

None.

See Also:

ImGearLicense Class


ImGearLinearLUT Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents a Look Up table that does not store the actual LUT values but calculates output values dynamically using a linear formula. Such LUTs can be used for window levelling of 17-32 bit per channel images.

Declaration:

public class ImGearLinearLUT : ImageGear.Core.ImGearLUT

Members:

Constructors
Name
Description
ImGearLinearLUT Constructor
Creates a new instance of ImGearFullLUT Class.

Properties
Name
Description
InputDepth Property
Specifies input depth of the LUT
InputIsSigned Property
Specifies whether LUT input values are signed
OutputDepth Property
Specifies output depth of the LUT
OutputIsSigned Property
Specifies whether LUT output values are signed
thisProperty
Returns LUT output value corresponding to Int32 input value.
this Property
Returns LUT output value corresponding to Int64 input value.
Slope Property
Returns/Sets LUT Slope value
Intercept Property
Returns/Sets LUT Intercept value

Methods
Name
Description
Clone Method
Creates a deep copy of the object.
Concatenate Method
Concatenates the content of the specified lut into the instance of the ImGearFullLUT Class.
CopyFromMethod
Duplicates the content of the specified lut into the instance of the ImGearLinearLUT Class from which this method is called.


ImGearLinearLUT Constructors

The ImGearLinearLUT Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearLinearLUT Constructor
Creates a new instance of ImGearFullLUT Class.


ImGearLinearLUT Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates a new instance of ImGearLinearLUT Class object. Slope/Intercept will get default values (1.0/0.0) and must be initialized later, if necessary, via corresponding set properties.

Declaration:

public ImGearLinearLUT ( int inputDepth , bool inputIsSigned , int outputDepth , bool
outputIsSigned )

Parameters:

Name
Type
Description
inputDepth
Int
Specifies input depth of the LUT
inputIsSigned
Boolean
Specifies whether LUT input is signed
outputDepth
Int
Specifies output depth of the LUT
outputIsSigned
Boolean
Specifies whether LUT output is signed

Return Value:

The new instance of ImGearLinearLUT Class object.


ImGearLinearLUT Properties

The ImGearLinearLUT Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
InputDepth Property
Specifies input depth of the LUT
InputIsSigned Property
Specifies whether LUT input values are signed
OutputDepth Property
Specifies output depth of the LUT
OutputIsSigned Property
Specifies whether LUT output values are signed
thisProperty
Returns LUT output value corresponding to Int32 input value.
this Property
Returns LUT output value corresponding to Int64 input value.
Slope Property
Returns/Sets LUT Slope value
Intercept Property
Returns/Sets LUT Intercept value


thisProperty

32-bit
64-bit
CF
P
P
P

Description:

Get accessor of this indexed property returns LUT output value corresponding to Int32 input value. The formula is:

result = input_value * Slope + Intercept + 0.5.

Set accessor throws exception, as far as such operation is invalid for this LUT.

Declaration:

public const override int this (Integer Index){ get, set }.

Value:

Integer number.

Default value:

None


this Property

32-bit
64-bit
CF
P
P
P

Description:

Get accessor of this indexed property returns LUT output value corresponding to Int64 input value. The formula is:

result = input_value * Slope + Intercept + 0.5.

Set accessor throws exception, as far as such operation is invalid for this LUT.

Declaration:

public const override int this (Long Index){ get, set }.

Value:

Long number

Default value:

None


Slope Property

32-bit
64-bit
CF
P
P
P

Description:

Sets/gets Slope value of the LUT.

Declaration:

public double Slope{ get, set }

Value:

Double value

Default value:

None


Intercept Property

32-bit
64-bit
CF
P
P
P

Description:

Sets/gets Intercept value of the LUT.

Declaration:

public double Intercept{ get, set }

Value:

Double value

Default value:

None


ImGearLinearLUT Methods

The ImGearLinearLUT Class of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
Clone Method
Creates a deep copy of the object.
Concatenate Method
Concatenates the content of the specified lut into the instance of the ImGearFullLUT Class.
CopyFromMethod
Duplicates the content of the specified lut into the instance of the ImGearLinearLUT Class from which this method is called.


Clone Method

32-bit
64-bit
CF
P
P
P

Description:

This method clones ImGearLinearLUT Class object.

Declaration:

public override ImageGear.Core.ImGearLinearLUT Clone ()

Return Value:

The new instance of ImGearLinearLUT Class.

Example:

ImGearLinearLUT clone = (ImGearLinearLUT)fullLUT.Clone();


Concatenate Method

32-bit
64-bit
CF
P
P
P

Description:

This method concatenates the content of the specified LUT into the instance of the ImGearLinearLUT Class that this method is called from.

If the lut parameter is not an ImGearLinearLUT Class object, the method returns ImGearErrorCodes Enumeration.PARAMETER_HAS_INVALID_VALUE exception.

Declaration:

public override ImageGear.Core.ImGearLUT Concatenate(ImageGear.Core.ImGearLUT lut)

Parameters:

Name
Type
Description
lut
ImGearLUT Class
LUT to be concatenated.

Return Value:

ImGearLUT Class.

See Also:

ImGearLUT Class


CopyFromMethod

32-bit
64-bit
CF
P
P
P

Description:

This method duplicates the content of the specified LUT into the instance of the ImGearLinearLUT Class that this method is called from. LUT type and depths attributes must be compatible with the class from which this method is called.

Declaration:

public override void CopyFrom ( ImageGear.Core.ImGearLUT lut )

Parameters:

Name
Type
Description
lut
ImGearLUT Class
LUT to be copied.

Return Value:

None.


ImGearLUT Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides a base for Look Up Tables (LUTs) that are used in ImageGear. A LUT is characterized by input depth, output depth; both input and output of the LUT can be signed or unsigned.

Declaration:

public abstract class ImGearLUT

Members:

Properties
Name
Description
InputDepth Property
Specifies input depth of the LUT.
InputIsSigned Property
Specifies whether LUT input values are signed.
OutputDepth Property
Specifies output depth of the LUT.
OutputIsSigned Property
Specifies whether LUT output values are signed.
this Property
Returns LUT output value corresponding to Int32 input value.
this Property
Returns LUT output value corresponding to Int64 input value.

Methods
Name
Description
Clone Method
Creates a deep copy of the object.
Concatenate Method
Concatenates the content of the specified LUT into the instance of the ImGearLUT Class.
CopyFrom Method
Duplicates the content of the specified LUT into the instance of the ImGearLUT class that this method is called from.


ImGearLUT Properties

The ImGearLUT Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
InputDepth Property
Specifies input depth of the LUT.
InputIsSigned Property
Specifies whether LUT input values are signed.
OutputDepth Property
Specifies output depth of the LUT.
OutputIsSigned Property
Specifies whether LUT output values are signed.
this Property
Returns LUT output value corresponding to Int32 input value.
this Property
Returns LUT output value corresponding to Int64 input value.


InputDepth Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the input depth of the LUT.

Declaration:

public abstract int InputDepth { get }

Value:

Any integer number.

Default value:

0


InputIsSigned Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies whether LUT input values are signed.

Declaration:

public abstract bool InputIsSigned { get }

Value:

True, False

Default value:

False


OutputDepth Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the output depth of the LUT.

Declaration:

public abstract int OutputDepth{ get }

Value:

Any integer number.

Default value:

N/A


OutputIsSigned Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies whether LUT output values are signed.

Declaration:

public abstract bool OutputIsSigned { get }

Value:

True, False

Default value:

False


this Property

32-bit
64-bit
CF
P
P
P

Description:

This indexed property sets or returns LUT output value corresponding to Int32 input value.

Declaration:

public const abstract int this (Integer Index){ get, set }

Value:

Integer number.

Default value:

None


this Property

32-bit
64-bit
CF
P
P
P

Description:

This indexed property sets or returns LUT output value corresponding to Int64 input value.

Declaration:

public const abstract long this (long Index){ get, set }

Value:

Long number.

Default value:

None


ImGearLUT Methods

The ImGearLUT Class of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
Clone Method
Creates a deep copy of the object.
Concatenate Method
Concatenates the content of the specified LUT into the instance of the ImGearLUT Class.
CopyFrom Method
Duplicates the content of the specified LUT into the instance of the ImGearLUT class that this method is called from.


Clone Method

32-bit
64-bit
CF
P
P
P

Description:

This method clones ImGearLUT object.

Declaration:

public abstract new ImageGear.Core.ImGearLUT Clone ()

Return Value:

The new instance of ImGearLUT Class object.

Example:

ImGearLUT clone = lut.Clone();

Sample:

None


Concatenate Method

32-bit
64-bit
CF
P
P
P

Description:

This method concatenates the content of the specified LUT into the instance of the ImGearLUT Class that this method is called from.

Declaration:

public abstract ImageGear.Core.ImGearLUT Concatenate(ImageGear.Core.ImGearLUT lut)

Parameters:

Name
Type
Description
lut
ImGearLUT Class
LUT to be concatenated.

Return Value:

ImGearLUT Class

See Also:

ImGearLUT Class


CopyFrom Method

32-bit
64-bit
CF
P
P
P

Description:

This method duplicates the content of the specified LUT into the instance of the ImGearLUT Class that this method is called from. LUT type and depths attributes must be compatible with the class this method is called from.

Declaration:

public abstract void CopyFrom ( ImageGear.Core.ImGearLUT lut )

Parameters:Parameters:

Name
Type
Description
lut
ImGearLUT Class
LUT to be copied.

Return Value:

None.

See Also:

ImGearLUT Class


ImGearMaskColorChannelInfo Class

32-bit
64-bit
CF
P
P
P

Description:

This is a mask color channel class that uses regular color space like RGB, CMYK, etc.

Declaration:

public class ImGearMaskColorChannelInfo : ImageGear.Core.ImGearColorChannelInfo

Members:

Constructors
Name
Description
ImGearMaskColorChannelInfo Constructor
Creates and initializes an instance of ImGearMaskColorChannelInfo Class

Properties
Name
Description
Mode Property
Specifies mask channel mode.


ImGearMaskColorChannelInfo Constructors

The ImGearMaskColorChannelInfo Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearMaskColorChannelInfo Constructor
Creates and initializes an instance of ImGearMaskColorChannelInfo Class.


ImGearMaskColorChannelInfo Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearMaskColorChannelInfo Class by using color space and color value.

Declaration:

public ImGearMaskColorChannelInfo(ImageGear.Core.ImGearMaskChannelModes mode,
ImageGear.Core.ImGearColorSpace colorSpace, ImageGear.Core.ImGearPixel colorValue)

Parameters:

Name
Type
Description
mode
ImGearMaskChannelModes Enumeration
ImGearMaskChannelModes value.
colorSpace
ImGearColorSpace Structure
Color space object.
colorValue
ImGearPixel Class
ImGearPixel color value.

Return Value:

The new instance of ImGearMaskColorChannelInfo Class.

See Also:

ImGearMaskColorChannelInfo Class

ImGearMaskChannelModes Enumeration

ImGearColorSpace Structure

ImGearPixel Class


ImGearMaskColorChannelInfo Properties

The ImGearMaskColorChannelInfo Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
Mode Property
Specifies mask channel mode.


Mode Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies mask channel mode.

Declaration:

public ImageGear.Core.ImGearMaskChannelModes Mode { get;  set; }

Value:

ImGearMaskChannelModes Enumeration value.

Example:

C#
mode = mask.Mode;

Visual Basic
mode = mask.Mode

See Also:

ImGearMaskChannelModes Enumeration


ImGearMaskSpotChannelInfo Class

32-bit
64-bit
CF
P
P
P

Description:

This is a mask spot channel class that uses a special (like Pantone) color.

Declaration:

public class ImGearMaskSpotChannelInfo : ImageGear.Core.ImGearSpotChannelInfo

Members:

Constructors
Name
Description
ImGearMaskSpotChannelInfo Constructor
Creates and initializes an instance of ImGearMaskSpotChannelInfo Class.

Properties
Name
Description
Mode Property
Specifies mask channel mode.


ImGearMaskSpotChannelInfo Constructors

The ImGearMaskSpotChannelInfo Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearMaskSpotChannelInfo Constructor
Creates and initializes an instance of ImGearMaskSpotChannelInfo Class.


ImGearMaskSpotChannelInfo Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearMaskSpotChannelInfo Class.

Declaration:

public ImGearMaskSpotChannelInfo(ImageGear.Core.ImGearMaskChannelModes mode,
ImageGear.Core.ImGearSpotColorVendorID vendorID, long colorID)

Parameters:

Name
Type
Description
mode
ImGearMaskChannelModes Enumeration
ImGearMaskChannelModes value.
vendorID
ImGearSpotColorVendorID Enumeration
Vendor ID of the spot color.
colorID
long
Spot color ID in Vendor's color book.

Return Value:

The new instance of ImGearMaskSpotChannelInfo Class.

Example:

C#
mask = new ImGearMaskSpotChannelInfo(ImGearMaskChannelModes.ColorIndicatesMaskedArea, ImGearSpotColorVendorID.Pantone,
1112299335);

Visual Basic
mask = New ImGearMaskSpotChannelInfo(ImGearMaskChannelModes.ColorIndicatesMaskedArea, ImGearSpotColorVendorID.Pantone,
1112299335)

See Also:

ImGearMaskSpotChannelInfo Class

ImGearMaskChannelModes Enumeration

ImGearSpotColorVendorID Enumeration


ImGearMaskSpotChannelInfo Properties

The ImGearMaskSpotChannelInfo Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
Mode Property
Specifies mask channel mode.


ImGearMetadataDictionary Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides access to the Metadata Dictionary that is used in ImageGear.

Declaration:

public class ImGearMetadataDictionary

Members:

Methods
Name
Description
AddRecord Method
Adds new record to the dictionary.
LookUp Method
Looks up a record in the dictionary.
Reset Method
Resets the dictionary to its default state.


ImGearMetadataDictionary Methods

The ImGearMetadataDictionary Class of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
AddRecord Method
Adds new record to the dictionary.
LookUp Method
Looks up a record in the dictionary.
Reset Method
Resets the dictionary to its default state.


AddRecord Method

32-bit
64-bit
CF
P
P
P

Description:

This method adds a new record to the dictionary.

Declaration:

public static void AddRecord ( ImageGear.Formats.ImGearMetadataFormats format ,
ImageGear.Core.IImGearMetadataDictRecord record )

Parameters:

Name
Type
Description
format
ImGearMetadataFormats Enumeration
Metadata format associated with the record.
record
IImGearMetadataDictRecord Interface
New record.

Return Value:

None.

Example:

// Add DICOM record to metadata dictionary
ImGearDICOMMetadataDictRecord DicomRecord = new ImGearDICOMMetadataDictRecord (0x1234,
"Custom DICOM tag", ImGearDICOMValueRepresentations.IntegerString, 0);
ImGearMetadataDictionary.AddRecord(ImGearMetadataFormats.DICOM, DicomRecord)
// Add TIFF record to metadata dictionary
ImGearCommonMetadataDictRecord TiffRecord = new ImGearCommonMetadataDictRecord(0x567,
"Custom TIFF tag");
ImGearMetadataDictionary.AddRecord(ImGearMetadataFormats.TIFF, Record)

See Also:

ImGearMetadataFormats Enumeration

IImGearMetadataDictRecord Interface


LookUp Method

32-bit
64-bit
CF
P
P
P

Description:

This method looks up a record in the dictionary, based on metadata format and tag ID.

Declaration:

public static ImageGear.Core.IImGearMetadataDictRecord LookUp (
ImageGear.Formats.ImGearMetadataFormats Format , int Tag )

Parameters:

Name
Type
Description
Format
ImGearMetadataFormats Enumeration
Metadata format
Tag
int
Tag ID

Return Value:

IImGearMetadataDictRecord Interface object.

Example:

IImGearMetadataDictRecord record =
ImGearMetadataDictionary.LookUp(ImGearMetatadaFormats.DICOM, 0x1234);

See Also:

ImGearMetadataFormats Enumeration

IImGearMetadataDictRecord Interface


Reset Method

32-bit
64-bit
CF
P
P
P

Description:

This method resets the dictionary to its default state, i.e., removes all user-defined records.

Declaration:

public static void Reset ()

Return Value:

None.

Example:

ImGearMetadataDictionary.Reset();
32-bit
64-bit
CF
P
P
P
32-bit
64-bit
CF
P
P
P


ImGearMetadataHead Class

32-bit
64-bit
CF
P
P
P

Description:

ImGearMetadataHead is a special case of metadata node with null Parent field and not more than one child. It is always present in every instance of ImGearPage Class or ImGearDocument Class as class member.

If the page or document has metadata, the instance of ImGearMetadataTree Class is attached to the head as a child node. Otherwise, the head does not have child nodes.

The head may only be the root of metadata tree. Attempting to attach the head to any node causes exception throwing.

Declaration:

public sealed class ImGearMetadataHead : ImageGear.Core.ImGearMetadataNode

Members:

Constructors
Name
Description
ImGearMetadataHead Constructor
Initializes member with empty (null) child.

Properties
Name
Description
Child Property
Returns or updates reference to child node.
Common Property
Provides access to metadata that is common for all format filters.
EXIF Property
Provides simplified access to EXIF metadata.
IPTC Property
Provides simplified access to IPTC metadata.
TIFF Property
Provides simplified access to TIFF metadata.
XMP Property
Provides simplified access to XMP metadata.

Methods
Name
Description
Clone Method
Creates a new object that is a copy of the current instance.
GetTargetFormat Method
This method returns target format of the page metadata.
SetTargetFormat Method
This method sets target format of the page metadata.


ImGearMetadataHead Constructors

The ImGearMetadataHead Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearMetadataHead Constructor
Initializes member with empty (null) child.


ImGearMetadataHead Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes node with empty metadata tree (null child).

Parent field is always null for the instances of this class. Trying to insert ImGearMetadataHead object as a Child to any node causes exception.

Declaration:

Public ImGearMetadataHead()

Return Value:

New instance of ImGearMetadataHead Class.

See Also:

ImGearMetadataHead Class


ImGearMetadataHead Properties

The ImGearMetadataHead Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
Child Property
Returns or updates reference to child node.
Common Property
Provides access to metadata that is common for all format filters.
EXIF Property
Provides simplified access to EXIF metadata.
IPTC Property
Provides simplified access to IPTC metadata.
TIFF Property
Provides simplified access to TIFF metadata.
XMP Property
Provides simplified access to XMP metadata.


Child Property

32-bit
64-bit
CF
P
P
P

Description:

Returns or updates child node reference.

Assigning value must be stand-alone (Parent == null) and not an instance of ImGearMetadataHead class.

Declaration:

public ImGearMetadataNode Child { get; set }

Value:

Instance of ImGearMetadataNode Class. May be null.

See Also:

ImGearMetadataNode Class


Common Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides access to metadata that is common for all format filters.

Declaration:

public ImageGear.Formats.ImGearCommonMetadata Common {  get;}

Value:

ImageGear.Formats.ImGearCommonMetadata Class object.

See Also:

ImGearCommonMetadata Class


EXIF Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides simplified access to EXIF metadata. The user does not need to know exact location of EXIF metadata in the metadata tree. If no EXIF metadata exists in the metadata tree, the property returns null.

You can add EXIF metadata to a metadata tree, if it was not present, by creating a new instance of ImGearEXIFMetadata Class and assigning it to the EXIF property. However, this only allowed if metadata tree's target format is compatible with EXIF. Currently, two target formats support EXIF metadata: TIFF and JPEG.

Declaration:

public ImageGear.Formats.EXIF.ImGearEXIFMetadata EXIF { set; get; }

Value:

Instance of ImGearEXIFMetadata Class.

See Also:

ImGearEXIFMetadata Class


IPTC Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides simplified access to IPTC metadata. The user does not need to know exact location of IPTC metadata in the metadata tree. If no IPTC metadata exists in the metadata tree, the property returns null.

You can add IPTC metadata to a metadata tree, if it was not present, by creating a new instance of ImGearIPTCMetadata Class and assigning it to the IPTC property. However, this only allowed if metadata tree's target format is compatible with IPTC. Currently, two target formats support IPTC metadata: TIFF and JPEG.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCMetadata IPTC { set; get; }

Value:

Instance of ImGearIPTCMetadata Class.

See Also:

ImGearIPTCMetadata Class


TIFF Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides simplified access to TIFF metadata. The user does not need to know exact location of TIFF metadata in the metadata tree. If no TIFF metadata exists in the metadata tree, the property returns null.

You can add TIFF metadata to a metadata tree, if it was not present, by creating a new instance of ImGearTIFFMetadata Class and assigning it to the TIFF property. However, this only allowed if metadata tree's target format is compatible with TIFF. Currently, two target formats support TIFF metadata: TIFF and JPEG.

Declaration:

public ImageGear.Formats.TIF.ImGearTIFFMetadata TIFF { set; get; }

Value:

Instance of ImGearTIFFMetadata Class.

See Also:

ImGearTIFFMetadata Class


XMP Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides simplified access to XMP metadata. If no XMP metadata exists in the metadata tree, the property returns null.

You can add XMP metadata to a metadata tree, if it is not present, by creating a new instance of ImGearXMPMetadataRoot Class and assigning it to the XMP property. However, this is only allowed if metadata tree's target format is compatible with XMP. Currently, the following target formats support XMP metadata: TIFF, JPEG, PSD.

Declaration:

public ImGearXMPMetadataRoot XMP { get; set; }

Value:

ImGearXMPMetadataRoot Class value.

See Also:

ImGearXMPMetadataRoot Class


ImGearMetadataHead Methods

The ImGearMetadataHead Class of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
Clone Method
Creates a new object that is a copy of the current instance.
GetTargetFormat Method
This method returns target format of the page metadata.
SetTargetFormat Method
This method sets target format of the page metadata.


Clone Method

32-bit
64-bit
CF
P
P
P

Description:

Creates a new object that is a copy of the current instance.

Declaration:

public virtual ImageGear.Core.ImGearMetadataNode Clone()

Return value:

ImGearMetadataNode Class object that is a copy of the current instance.

See Also:

ImGearMetadataNode Class


GetTargetFormat Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns target format of the page metadata. Target format is the file format to which the current metadata tree can be saved. For example, if ImGearPage has been loaded from a JFIF JPEG image, its target format is JPEG. The application can modify metadata tags and save the image back to JPEG; modified metadata will be saved to the result file. However, if target format is JPEG, and the image is saved to BMP, metadata modifications will not be saved to the result file, because of incompatibility of metadata formats.

Target format affects Simplified Metadata API. A simplified metadata accessor can be initialized for the metadata tree only if it has a compatible target format. For example, if target format is TIFF or JPEG, the application can initialize an IPTC accessor for the metadata tree and add IPTC tags. But if target format is BMP, adding an IPTC accessor will result in an exception.

Declaration:

public ImageGear.Formats.ImGearFormats GetTargetFormat()

Return value:

ImGearFormats Enumeration object that is a copy of the current instance.

See Also:

ImGearFormats Enumeration


SetTargetFormat Method

32-bit
64-bit
CF
P
P
P

Description:

This method sets target format of the page metadata.

If new target format is the same as current target format, no action is made. If new format is different from current format, existing metadata is discarded and a new empty tree with specified target format is created.

See GetTargetFormat() for details on target format usage.

Declaration:

public void SetTargetFormat(ImageGear.Formats.ImGearFormats format)

Return value:

None.

Remarks:

ImGearFormats Enumeration


ImGearMetadataLeaf Class

32-bit
64-bit
CF
P
P
P

Description:

Implements interface of non-head metadata tree node. Stores actual (meta) data as System.Object.

Declaration:

public sealed class ImGearMetadataLeaf : ImageGear.Core.ImGearMetadataNode

Members:

Constructors
Name
Description
ImGearMetadataLeaf Constructor
Initializes instance with data attached to the node and its type as value of ImGearNativeTypes enum.
ImGearMetadataLeaf Constructor
Initializes instance with data attached to the node and its type as value of ImGearNativeTypes enum.
ImGearMetadataLeaf Constructor
Initializes instance with data attached to the node and its type as value of ImGearNativeTypes enum.

Properties
Name
Description
Data Property
Reference to opaque data stored in leaf. Type of object returned by this field depends on value of NativeType property.
IgnoredOnSave Property
Tells whether current node should be ignored during page/document saving or not.

Fields
Name
Description
NativeType Field
Specifies the type of data stored in leaf.

Methods
Name
Description
Clone Method
Creates a new object that is a copy of the current instance.
IsValidDataObject Method
Indicates whether the data type of an object is valid (supported by metadata leaf).


ImGearMetadataLeaf Constructors

The ImGearMetadataLeaf Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearMetadataLeaf Constructor
Initializes instance with data attached to the node and its type as value of ImGearNativeTypes enum.
ImGearMetadataLeaf Constructor
Initializes instance with data attached to the node and its type as value of ImGearNativeTypes enum.
ImGearMetadataLeaf Constructor
Initializes instance with data attached to the node and its type as value of ImGearNativeTypes enum.


ImGearMetadataLeaf Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes instance with data attached to the node and its type as value of ImGearNativeTypes enum.

It is good for several leaves to refer to the same data object.

Declaration:

public ImGearMetadataLeaf(ImageGear.Formats.ImGearMetadataFormats format, int tag, object
data, object nativeType, bool ignoredOnSave, string name)

Parameters:

Name
Type
Description
format
ImGearMetadataFormats Enumeration
Type of file format to which metadata belongs. This allows you to store JPEG metadata under TIFF metadata.
tag
int
Represents identifier of metadata for particular file format.
data
object
Actual data to be stored in metadata node.
nativeType
object
Identifier of attached data type.
ignoredOnSave
bool
Specifies whether node should be ignored during page (document) saving or not.
name
string
Name of the leaf.

Return Value:

New instance of ImGearMetadataLeaf Class.

See Also:

ImGearMetadataLeaf Class


ImGearMetadataLeaf Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes instance with data attached to the node and its type as value of ImGearNativeTypes enum.

It is good for several leaves to refer to the same data object.

Declaration:

public ImGearMetadataLeaf(ImGearFormats format, int tag, object data,
ImGearNativeDataTypes nativeType, bool ignoredOnSave)

Parameters:

Name
Type
Description
format
ImGearMetadataFormats Enumeration
Type of file format to which metadata belongs. This allows you to store JPEG metadata under TIFF metadata.
tag
int
Represents identifier of metadata for particular file format.
data
object
Actual data to be stored in metadata node.
nativeType
object
Identifier of attached data type.
ignoredOnSave
bool
Specifies whether node should be ignored during page (document) saving or not.

Return Value:

New instance of ImGearMetadataLeaf Class.

See Also:

ImGearMetadataLeaf Class


ImGearMetadataLeaf Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes instance with data attached to the node and its type as value of ImGearNativeTypes enum.

It is good for several leaves to refer to the same data object.

Declaration:

public public ImGearMetadataLeaf()

Return Value:

New instance of ImGearMetadataLeaf Class.

See Also:

ImGearMetadataLeaf Class


ImGearMetadataLeaf Properties

The ImGearMetadataLeaf Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
Data Property
Reference to opaque data stored in leaf. Type of object returned by this field depends on value of NativeType property.
IgnoredOnSave Property
Tells whether current node should be ignored during page/document saving or not.


Data Property

32-bit
64-bit
CF
P
P
P

Description

Represents (meta) data assigned to metadata node as System.Object. The following types of objects are allowed to be stored:

  • System.ValueType
  • System.String
  • System.Array

Otherwise, an exception will be thrown.

Declaration:

public Object Data { get; set }

Value:

System.Object.


IgnoredOnSave Property

32-bit
64-bit
CF
P
P
P

Description:

If this property is set to true, data contained in ImGearMetadataLeaf is ignored during image saving and data from the medatada container (page or document) will be used instead.

Declaration:

public bool IgnoredOnSave { get; }

Value:

true/false

See Also:

ImGearMetadataLeaf Class


ImGearMetadataLeaf Fields

The ImGearMetadataLeaf Class of the ImageGear.Core Namespace has the following fields:

Fields
Name
Description
NativeType Field
Specifies the type of data stored in leaf.


NativeType Field

32-bit
64-bit
CF
P
P
P

Description:

Identifies the type of data stored in a leaf. When metadata is loaded from a file, all leaves have this field set to explicit values. When a leaf is created by user, it is set to UNKNOWN. It is not necessary to set NativeType to explicit value. The filter will try to determine the native type from its dictionary or from System.Type of Data object.

Declaration:

public object NativeType

Value:

Object.


ImGearMetadataLeaf Methods

The ImGearMetadataLeaf Class of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
Clone Method
Creates a new object that is a copy of the current instance.
IsValidDataObject Method
Indicates whether the data type of an object is valid (supported by metadata leaf).


Clone Method

32-bit
64-bit
CF
P
P
P

Description:

Creates a new object that is a copy of the current instance.

Declaration:

public virtual ImageGear.Core.ImGearMetadataNode Clone()

Return value:

ImGearMetadataNode Class object that is a copy of the current instance.


IsValidDataObject Method

32-bit
64-bit
CF
P
P
P

Description:

Indicates whether the data type of an object is valid (supported by metadata leaf).

Declaration:

public static bool IsValidDataObject(object value)

Parameters:

Name
Type
Description
value
object
The data to be validated.

Return value:

True, false.


ImGearMetadataNode Class

32-bit
64-bit
CF
P
P
P

Description:

An abstraction of node in metadata tree. Node can be unreferenced or referenced from one parent node, but it cannot be referenced from multiple parents. Node cannot refer to itself directly or indirectly.

Declaration:

public abstract class ImGearMetadataNode

Members:

Properties
Name
Description
FormatName Property
Gets the name of the type of the file format to which metadata belongs.
Name Property
Returns string name of tag.
Parent Property
Reference to parent node.

Fields
Name
Description
Format Field
Type of file format to which metadata belongs. This allows you to store JPEG metadata under TIFF metadata.
Tag Field
Represents identifier of metadata node for particular file format.

Methods
Name
Description
Clone Method
Creates a new object that is a copy of the current instance.
CompareTo Method
Compares the current instance with another object of the same type.


ImGearMetadataNode Properties

The ImGearMetadataNode Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
FormatName Property
Gets the name of the type of the file format to which metadata belongs.
Name Property
Returns string name of tag.
Parent Property
Reference to parent node.


FormatName Property

32-bit
64-bit
CF
P
P
P

Description:

Gets the name of the type of the file format to which metadata belongs.

Declaration:

public string FormatName [get]

Value:

Any string name of format.


Name Property

32-bit
64-bit
CF
P
P
P

Description:

Returns tag name from the internal dictionary, or empty string if tag is unknown in ImageGear for .NET.

Declaration:

public string Name { get; }

Return value:

String identifier of medatada tag.


Parent Property

32-bit
64-bit
CF
P
P
P

Description:

Specifies reference to parent node in metadata tree. This property may be null. Accordingly, the instance is stand-alone (not attached), or otherwise, has special type like ImGearMetadataHead.

Declaration:

public ImGearMetadataNode Parent{ get; }

Value:

ImGearMetadataNode Class


ImGearMetadataNode Fields

The ImGearMetadataNode Class of the ImageGear.Core Namespace has the following fields:

Fields
Name
Description
Format Field
Type of file format to which metadata belongs. This allows you to store JPEG metadata under TIFF metadata.
Tag Field
Represents identifier of metadata node for particular file format.


Format Field

32-bit
64-bit
CF
P
P
P

Description:

Specifies type of file format to which metadata belongs. This allows you to store JPEG metadata under TIFF metadata.

NOTE: ImGearFormats.UNKNOWN means custom (unknown) format.

Declaration:

public ImageGear.Formats.ImGearMetadataFormats Format

Value:

ImGearMetadataFormats Enumeration

See Also:

ImGearMetadataFormats Enumeration


Tag Field

32-bit
64-bit
CF
P
P
P

Description:

Identifies what kind of data is stored in metadata node. Specific for particular file format.

Values for the tags are taken from tag list of file formats, represented in ImageGear for .NET as ImGear%FORMAT%TagIDs (where %FORMAT% is BMP, TIFF, etc.) enumerations.

Declaration:

public int Tag

Value:

Integer value


ImGearMetadataNode Methods

The ImGearMetadataNode Class of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
Clone Method
Creates a new object that is a copy of the current instance.
CompareTo Method
Compares the current instance with another object of the same type.


Clone Method

32-bit
64-bit
CF
P
P
P

Description:

Creates a new object that is a copy of the current instance.

Declaration:

public abstract ImageGear.Core.ImGearMetadataNode Clone()

Return value:

ImGearMetadataNode Class that is a copy of the current instance.

See Also:

ImGearMetadataNode Class


CompareTo Method

32-bit
64-bit
CF
P
P
P

Description:

Compares the current instance with another object of the same type.

Declaration:

public int CompareTo(object obj)

Parameters:

Name
Type
Description
obj
object
An object to compare with this instance.

Return Value:

  • -1 - This instance is less than obj.
  • 0 - This instance is equal to obj.
  • 1 - This instance is greater than obj.


ImGearMetadataNodeList Class

32-bit
64-bit
CF
P
P
P

Description:

Represents container (list) of ImGearMetadataNode instances and provides additional verifications for stored objects. For example, on adding, new MetadataNode is checked to be non-null, stand-alone (Parent == null) and not the same as the top node of the tree to which it is added.

Nodes with different Format values are allowed to be present in the same list. Multiple nodes with the same Tag value are also allowed. The list is not sorted automatically because the order of items may be significant for a particular format.

This class does not have any public constructor. Instances exist only as members of ImGearMetadataTree objects.

Declaration:

public sealed class ImGearMetadataNodeList

Members:

Properties
Name
Description
Count Property
Gets the number of elements contained in the List.
IsFixedSize Property
Gets a value indicating whether the List has a fixed size.
IsReadOnly Property
Gets a value indicating whether the List is read-only.
IsSynchronized Property
Gets a value indicating whether access to the List is synchronized (thread-safe).
Item Property
Gets or sets the element at the specified index.
SyncRoot Property
Gets an object that can be used to synchronize access to the List.

Methods
Name
Description
Add Method
Adds a node to the list.
Clear Method
Clears the list.
Clone Method
Clones the list.
Contains Method
Checks whether or not the list contains the specified node.
CopyTo Method
Copies the list to the specified array at the specified position.
GetEnumerator Method
Used to enumerate the list items.
IndexOf Method
Returns index of the node.
Insert Method
Inserts a node at the specified position.
LookUp Method
Searches the node list for a node which Tag is equal to the specified tag ID.
LookUp Method
Searches the node list for a node which Tag is equal to the numerical value of the specified tag ID.
LookUp Method
Searches the node list recursively for a node, according to the path parameter.
LookUp Method
Searches the node list recursively for a node, according to the path parameter.
LookUp Method
Searches the node list for a node whose Name is equal to the specified string value.
RecursiveSort Method
Sorts the list items recursively so that items within each level are sorted.
Remove Method
Removes the specified node.
Remove Method
Removes the node with the specified ID.
RemoveAt Method
Removes the node at the specified index.
Sort Method
Sorts the list items.


ImGearMetadataNodeList Properties

The ImGearMetadataNodeList Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
Count Property
Gets the number of elements contained in the List.
IsFixedSize Property
Gets a value indicating whether the List has a fixed size.
IsReadOnly Property
Gets a value indicating whether the List is read-only.
IsSynchronized Property
Gets a value indicating whether access to the List is synchronized (thread-safe).
Item Property
Gets or sets the element at the specified index.
SyncRoot Property
Gets an object that can be used to synchronize access to the List.


Count Property

32-bit
64-bit
CF
P
P
P

Description:

Gets the number of elements contained in the List.

Declaration:

public int Count [get]

Value:

Any integer value.


IsFixedSize Property

32-bit
64-bit
CF
P
P
P

Description:

Gets a value indicating whether the List has a fixed size.

Declaration:

public bool IsFixedSize [get]

Value:

True, false.


IsReadOnly Property

32-bit
64-bit
CF
P
P
P

Description:

Gets a value indicating whether the List is read-only.

Declaration:

public bool IsReadOnly [get]

Value:

True, false.


IsSynchronized Property

32-bit
64-bit
CF
P
P
P

Description:

Gets a value indicating whether access to the List is synchronized (thread-safe).

Declaration:

public bool IsSynchronized [get]

Value:

True, false.


Item Property

32-bit
64-bit
CF
P
P
P

Description:

Gets or sets the element at the specified index.

Declaration:

public ImageGear.Core.ImGearMetadataNode Item(int index) [get, set]

Value:

ImGearMetadataNode Class

See Also:

ImGearMetadataNode Class


SyncRoot Property

32-bit
64-bit
CF
P
P
P

Description:

Gets an object that can be used to synchronize access to the List.

Declaration:

public object SyncRoot [get]

Value:

An object that can be used to synchronize access to the List.


ImGearMetadataNodeList Methods

The ImGearMetadataNodeList Class of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
Add Method
Adds a node to the list.
Clear Method
Clears the list.
Clone Method
Clones the list.
Contains Method
Checks whether or not the list contains the specified node.
CopyTo Method
Copies the list to the specified array at the specified position.
GetEnumerator Method
Used to enumerate the list items.
IndexOf Method
Returns index of the node.
Insert Method
Inserts a node at the specified position.
LookUp Method
Searches the node list for a node which Tag is equal to the specified tag ID.
LookUp Method
Searches the node list for a node which Tag is equal to the numerical value of the specified tag ID.
LookUp Method
Searches the node list recursively for a node, according to the path parameter.
LookUp Method
Searches the node list recursively for a node, according to the path parameter.
LookUp Method
Searches the node list for a node whose Name is equal to the specified string value.
RecursiveSort Method
Sorts the list items recursively so that items within each level are sorted.
Remove Method
Removes the specified node.
Remove Method
Removes the node with the specified ID.
RemoveAt Method
Removes the node at the specified index.
Sort Method
Sorts the list items.


Add Method

32-bit
64-bit
CF
P
P
P

Description:

This method adds a node to the list.

Declaration:

public int Add(ImageGear.Core.ImGearMetadataNode node)

Parameters:

Name
Type
Description
node
ImGearMetadataNode Class
The node.

Return Value:

ImGearMetadataNode Class.

See Also:

ImGearMetadataNode Class


Clear Method

32-bit
64-bit
CF
P
P
P

Description:

This method clears the list.

Declaration:

public void Clear()

Return Value:

None.

See Also:

N/A


Clone Method

32-bit
64-bit
CF
P
P
P

Description:

This method clones the list.

Declaration:

public ImageGear.Core.ImGearMetadataNodeList Clone()

Return Value:

ImGearMetadataNodeList Class.

See Also:

ImGearMetadataNodeList Class


Contains Method

32-bit
64-bit
CF
P
P
P

Description:

This method checks whether or not the list contains the specified node.

Declaration:

public bool Contains(ImageGear.Core.ImGearMetadataNode node)

Parameters:

Name
Type
Description
node
ImGearMetadataNode Class
The specified node.

Return Value:

true/false.

See Also:

ImGearMetadataNode Class


CopyTo Method

32-bit
64-bit
CF
P
P
P

Description:

This method copies the list to the specified array at the specified position.

Declaration:

public void CopyTo(System.Array ar, int index)

Parameters:

Name
Type
Description
ar
System.Array
The specified array.
index
int
The specified position.

Return Value:

None.

See Also:

ImGearMetadataNodeList Class


GetEnumerator Method

32-bit
64-bit
CF
P
P
P

Description:

This method is used to enumerate the list items.

Declaration:

public System.Collections.IEnumerator GetEnumerator()

Return Value:

System.Collections.IEnumerator

See Also:

ImGearMetadataNodeList Class


IndexOf Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns index of the node.

Declaration:

public int IndexOf(ImageGear.Core.ImGearMetadataNode node)

Parameters:

Name
Type
Description
node
ImGearMetadataNode Class
The specified node.

Return Value:

Integer value.

See Also:

ImGearMetadataNode Class


Insert Method

32-bit
64-bit
CF
P
P
P

Description:

This method inserts a node at the specified position.

Declaration:

public void Insert(int index, ImageGear.Core.ImGearMetadataNode node)

Parameters:

Name
Type
Description
index
int
The specified position.
node
ImGearMetadataNode Class
The node to insert.

Return Value:

None.

See Also:

ImGearMetadataNode Class


LookUp Method

32-bit
64-bit
CF
P
P
P

Description:

This method searches the node list for a node which Tag is equal to the specified tag ID. If the list contains several nodes with this tag ID, the method returns the first record. If a node is not present, the method returns NULL.

The method does not search in the subtrees of the node list.

Declaration:

public ImageGear.Core.ImGearMetadataNode LookUp ( int tag )

Parameters:

Name
Type
Description
tag
int
Tag ID to search for.

Return Value:

ImGearMetadataNode Class.

See Also:

ImGearMetadataNode Class


LookUp Method

32-bit
64-bit
CF
P
P
P

Description:

This method searches the node list for a node whose Tag is equal to the numerical value of the specified tag ID. If the list contains several nodes with this tag ID, method returns the first record. If a node is not present, the method returns NULL.

The method does not search in the subtrees of the node list.

Declaration:

public ImageGear.Core.ImGearMetadataNode LookUp ( System.Enum tag )

Parameters:

Name
Type
Description
tag
System.Enum
Tag ID to search for.

Return Value:

ImGearMetadataNode Class object.

Example:

ImGearMetadataTree rootTree = (ImGearMetadataTree)page.Metadata.child;
ImGearMetadataNode node = rootTree.children.LookUp(ImGearBMPTagIDs.BitCount);


LookUp Method

32-bit
64-bit
CF
P
P
P

Description:

This method searches the node list recursively for a node, according to the path parameter. Length of the path should correspond to the metadata structure depth, at which the desired node is located.

If a node is not present, the method returns NULL.

The method does not search in the subtrees of the node list.

Declaration:

public static ImageGear.Core.IImGearMetadataDictRecord LookUp ( System.Enum path)

Parameters:

Name
Type
Description
path
System.Enum
Path to a data element in the metadata structure.

Return Value:

IImGearMetadataDictRecord Interface object.

Example:

ImGearDICOMTagIDs path = new Enum[]
{
    ImGearDICOMTagsIDs.DisplayedAreaSelectionSequence,
    ImGearDICOMTagsIDs.ItemItem,
    ImGearDICOMTagsIDs.DisplayedAreaTopLeftHandCorner
ImGearMetadataNode Node = rootNode.Children.LookUp(path);

See Also:

IImGearMetadataDictRecord Interface


LookUp Method

32-bit
64-bit
CF
P
P
P

Description:

This method searches the node list recursively for a node, according to the path parameter. Length of the path should correspond to the metadata structure depth, at which the desired node is located.

If a node is not present, the method returns NULL.

The method does not search in the subtrees of the node list.

Declaration:

public ImageGear.Core.ImGearMetadataNode LookUp(System.Enum[ ] path)

Parameters:

Name
Type
Description
path
System.Enum[ ]
Path to a data element in the metadata structure.

Return Value:

IImGearMetadataDictRecord Interface object.

Example:

ImGearDICOMTagIDs path = new Enum[]
{
    ImGearDICOMTagsIDs.DisplayedAreaSelectionSequence,
    ImGearDICOMTagsIDs.ItemItem,
    ImGearDICOMTagsIDs.DisplayedAreaTopLeftHandCorner
ImGearMetadataNode Node = rootNode.Children.LookUp(path);

See Also:

IImGearMetadataDictRecord Interface


LookUp Method

32-bit
64-bit
CF
P
P
P

Description:

This method searches the node list for a node whose Name is equal to the specified string value. If the list contains several nodes with this Name, method returns the first record. If a node is not present, the method returns NULL.

The method does not search in the subtrees of the node list.

Declaration:

public ImageGear.Core.ImGearMetadataNode LookUp ( String name )

Parameters:

Name
Type
Description
name
string
Tag Name for which to search.

Return Value:

ImGearMetadataNode Class object.

Example:

ImGearMetadataTree rootTree =
(ImGearMetadataTree)page.Metadata.child;
ImGearMetadataNode node = rootTree.children.LookUp("ImageWidth");

See Also:

ImGearMetadataNode Class

ImGearDICOMTagsIDs.DisplayedAreaTopLeftHandCorner
ImGearMetadataNode Node = rootNode.Children.LookUp(path);

See Also:

IImGearMetadataDictRecord Interface


RecursiveSort Method

32-bit
64-bit
CF
P
P
P

Description:

This method sorts the list items recursively so that items within each level are sorted.

Declaration:

public void RecursiveSort()

Parameters:

None.

Return Value:

None.

See Also:

ImGearMetadataNodeList Class


Remove Method

32-bit
64-bit
CF
P
P
P

Description:

This method removes the specified node.

Declaration:

public void Remove(ImageGear.Core.ImGearMetadataNode node)

Parameters:

Name
Type
Description
node
ImGearMetadataNode Class
The node to remove.

Return Value:

None.

See Also:

ImGearMetadataNode Class


Remove Method

32-bit
64-bit
CF
P
P
P

Description:

This method removes the node with the specified ID.

Declaration:

public void Remove(int id)

Parameters:

Name
Type
Description
id
int
The ID of the node to remove.

Return Value:

None.

See Also:

ImGearMetadataNodeList Class


RemoveAt Method

32-bit
64-bit
CF
P
P
P

Description:

This method removes the node at the specified index.

Declaration:

public void RemoveAt(int index)

Parameters:

Name
Type
Description
index
int
The specified index.

Return Value:

None.

See Also:

ImGearMetadataNodeList Class


Sort Method

32-bit
64-bit
CF
P
P
P

Description:

This method sorts the list items.

Declaration:

public void Sort()

Return Value:

None.

See Also:

ImGearMetadataNodeList Class


ImGearMetadataTree Class

32-bit
64-bit
CF
P
P
P

Description:

Represents metadata tree with structure of any complexity. Similar to ImGearMetadataHead, ImGearMetadataTree, this is a special case of metadata node with Parent property set to null.

Declaration:

public sealed class ImGearMetadataTree : ImageGear.Core.ImGearMetadataNode

Members:

Constructors
Name
Description
ImGearMetadataTree Constructor
Initializes the instance of ImGearMetadataTree Class.
ImGearMetadataTree Constructor
Initializes the instance of ImGearMetadataTree Class.
ImGearMetadataTree Constructor
Initializes the instance of ImGearMetadataTree Class.

Properties
Name
Description
Children Property
Array of child nodes.

Methods
Name
Description
Clone Method
Creates a new object that is a copy of the current instance.


ImGearMetadataTree Constructors

The ImGearMetadataTree Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearMetadataTree Constructor
Initializes the instance of ImGearMetadataTree Class.
ImGearMetadataTree Constructor
Initializes the instance of ImGearMetadataTree Class.
ImGearMetadataTree Constructor
Initializes the instance of ImGearMetadataTree Class.


ImGearMetadataTree Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes an instance of ImGearMetadataTree Class.

Declaration:

public ImGearMetadataTree()

Return Value:

The new instance of ImGearMetadataTree Class.

See Also:

ImGearMetadataTree Class


ImGearMetadataTree Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes an instance of ImGearMetadataTree Class.

Declaration:

public ImGearMetadataTree(ImageGear.Formats.ImGearMetadataFormats format, int tag)

Parameters:

Name
Type
Description
format
ImGearMetadataFormats Enumeration
Type of file format to which metadata belongs. This allows you to store JPEG metadata under TIFF metadata.
tag
int
Identifies type of metadata node for file format.

Return Value:

The new instance of ImGearMetadataTree Class.

See Also:

ImGearMetadataTree Class

ImGearMetadataFormats Enumeration


ImGearMetadataTree Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes an instance of ImGearMetadataTree Class.

Declaration:

public ImGearMetadataTree(ImageGear.Formats.ImGearMetadataFormats format, int tag, string
name)

Parameters:

Name
Type
Description
format
ImGearMetadataFormats Enumeration
Type of file format to which metadata belongs. This allows you to store JPEG metadata under TIFF metadata.
tag
int
Identifies type of metadata node for file format.
name
string
Name of the tag.

Return Value:

The new instance of ImGearMetadataTree Class.

See Also:

ImGearMetadataTree Class

ImGearMetadataFormats Enumeration


ImGearMetadataTree Properties

The ImGearMetadataTree Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
Children Property
Array of child nodes.


Children Property

32-bit
64-bit
CF
P
P
P

Description:

List of children nodes as ImGearMetadataNodeList Class.

Declaration:

public ImGearMetadataNodeList Children { get; }

Value:

ImGearMetadataNodeList Class instance or null.

See Also:

ImGearMetadataNodeList Class


ImGearMetadataTree Methods

The ImGearMetadataTree Class of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
Clone Method
Creates a new object that is a copy of the current instance.


Clone Method

32-bit
64-bit
CF
P
P
P

Description:

Creates a new object that is a copy of the current instance.

Declaration:

public abstract ImageGear.Core.ImGearMetadataNode Clone()

Return value:

ImGearMetadataTree Class that is a copy of the current instance.

See Also:

ImGearMetadataTree Class


ImGearMultichannelLUT Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents a multichannel look up table (LUT). An ImGearMultichannelLUT object contains an array of single-channel ImGearLUT Class objects.

Declaration:

public class ImGearMultichannelLUT

Members:

Constructors
Name
Description
ImGearMultichannelLUT Constructor
Creates a new instance of the object.
ImGearMultichannelLUT Constructor
Creates a new instance of the object.

Properties
Name
Description
ChannelCount Property
Returns number of single channel LUTs.
this Property
Provides access to single channel LUTs within ImGearMultichannelLUT.

Methods
Name
Description
Clone Method
Creates a deep copy of the object.


ImGearMultichannelLUT Constructors

The ImGearMultichannelLUT Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearMultichannelLUT Constructor
Creates a new instance of the object.
ImGearMultichannelLUT Constructor
Creates a new instance of the object.


ImGearMultichannelLUT Constructor

32-bit
64-bit
CF
P
P
P

Description:

This method creates a new instance of ImGearMultichannelLUT Class class, with the specified number of single-channel LUTs.

Declaration:

public ImGearMultichannelLUT(int channelCount)

Parameters:

Name
Type
Description
channelCount
int
Specifies number of channels in the multichannel LUT.

Return Value:

The new instance of ImGearMultichannelLUT Class object.

Example:

// Create a 3-channel LUT
ImGearMultichannelLUT lut = new ImGearMultichannelLUT(3);

See Also:

ImGearMultichannelLUT Class


ImGearMultichannelLUT Constructor

32-bit
64-bit
CF
P
P
P

Description:

This method creates a new instance of ImGearMultichannelLUT Class class and allocates its single-channel LUTs.

Declaration:

public ImGearMultichannelLUT(int channelCount, int inputDepth, int outputDepth)

Parameters:

Name
Type
Description
channelCount
int
Specifies number of channels in the multichannel LUT.
inputDepth
int
Specifies input depth for single-channel LUTs.
outputDepth
int
Specifies output depth for single-channel LUTs.

Return Value:

The new instance of ImGearMultichannelLUT Class object.

Example:

// Create a 3-channel LUT for converting 24-bit image into 24-bit image.
ImGearMultichannelLUT lut = new ImGearMultichannelLUT(3, 8, 8);

See Also:

ImGearMultichannelLUT Class


ImGearMultichannelLUT Properties

The ImGearMultichannelLUT Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
ChannelCount Property
Returns number of single channel LUTs.
this Property
Provides access to single channel LUTs within ImGearMultichannelLUT.


ChannelCount Property

32-bit
64-bit
CF
P
P
P

Description:

This property returns number of single-channel LUT in the multi-channel LUT.

Declaration:

public int ChannelCount { get }

Value:

Any integer number.

Default value:

None


this Property

32-bit
64-bit
CF
P
P
P

Description:

This indexed property sets or returns a single channel LUT within the multichannel LUT.

Declaration:

public ImageGear.Core.ImGearLUT this[int index] { get;  set; }

Value:

ImGearLUT Class.

See Also:

ImGearLUT Class


ImGearMultichannelLUT Constructors

The ImGearMultichannelLUT Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
Clone Method
Creates a deep copy of the object.


Clone Method

32-bit
64-bit
CF
P
P
P

Description:

This method makes a deep copy of the ImGearMultichannelLUT Class object.

Declaration:

public function Clone() As ImageGear.Core.ImGearMultichannelLUT

Return Value:

The new instance of ImGearMultichannelLUT Class object.

Example:

ImGearMultichannelLUT clone = MultiLUT.Clone();

See Also:

ImGearMultichannelLUT Class


ImGearPage Class

32-bit
64-bit
CF
P
P
P

Description:

Represents the image and consists of three main parts:

  • Image data (pixels)
  • Metadata (non-image data)
  • Region of interest

The page can be either stand-alone (not referenced from any ImGearDocument Class instance) or attached to document.

Region of interest (ImGearROI Class) represents free-shape image area (rectangular, non-rectangular or entire space) and specifies a meaningful part of an image. For example, it may be set up for some image processing functions to define the area to which the filter should be applied.

Metadata is non-image data, often available in some complex formats like TIFF or PNG. It may have any complexity and completely depends on the nature of file format. To provide a way for manipulating this data, ImageGear for .NET offers a set of classes composed from ImGearMetadataNode Class, ImGearMetadataNodeList Class and ImGearMetadataTree Class and their descendants. For particular page instance, metadata may be accessed through the Metadata Property.

Image data (or simply, image) is available for manipulations through the DIB Property and has ImGearDIB Class class type. Color Space, channels, width and height are major attributes that define the image structure.

Declaration:

public abstract class ImGearPage

Members:

Properties
Name
Description
DIB Property
Provides access to image data.
Document Property
Document to which page belongs, or null if page is stand-alone.
Metadata Property
Non-image data.

Fields
Name
Description
Orientation Field
Page orientation.
Transparency Field
Specifies image transparency attributes like transparent color for display.

Methods
Name
Description
Clone Method
Creates new object that is exact copy of current instance.

Sample Code:

C#
// Creates a 512x512 24bit RGB image
ImGearPage igPage = new ImGearRasterPage(512, 512,
    new ImGearColorSpace(ImGearColorSpaceIDs.RGB),
    new int[] { 8, 8, 8 },true);

VB .NET
'Creates a 512x512 24bit RGB image
Dim igPage As ImGearPage = New ImGearRasterPage(512, 512, _
    New ImGearColorSpace(ImGearColorSpaceIDs.RGB), _
    New Integer() {8, 8, 8}, True)


ImGearPage Properties

The ImGearPage Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
DIB Property
Provides access to image data.
Document Property
Document to which page belongs, or null if page is stand-alone.
Metadata Property
Non-image data.


DIB Property

32-bit
64-bit
CF
P
P
P

Description:

Provides access to image (pixels) data.

Although DIB property returns always non-null reference, pixels store may not be allocated. To detect whether pixels were allocated or not, ImGearDIB.IsEmpty member should be used.

Declaration:

public ImGearDIB DIB { get; }

Value:

Non-null reference to the object of ImGearDIB Class type.

See Also:

ImGearDIB Class


Document Property

32-bit
64-bit
CF
P
P
P

Description:

Document instance to which page belongs (attached) to.

null reference stand-alone means page is stand-alone.

Declaration:

public ImGearDocument Document { get; }

Value:

ImGearDocument Class instance or null.

See Also:

ImGearDocument Class


Metadata Property

32-bit
64-bit
CF
P
P
P

Description:

Provides access to the head of metadata tree.

Declaration:

public ImGearMetadataHead Metadata { get; }

Value:

Non-null reference to ImGearMetadataHead Class instance.

See Also:

ImGearMetadataHead Class


ImGearPage Fields

The ImGearPage Class of the ImageGear.Core Namespace has the following fields:

Fields
Name
Description
Orientation Field
Page orientation.
Transparency Field
Specifies image transparency attributes like transparent color for display.


Orientation Field

32-bit
64-bit
CF
P
P
P

Description:

Defines orientation of page instance. It supplements image representation and thus, allows you to flip and rotate a page without modification of its data (pixels).

Declaration:

public ImageGear.Core.IImGearOrientation Orientation

Value:

Non-null reference to instance of ImGearOrientation Structure interface type.

See Also:

ImGearOrientation Structure


Transparency Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies image transparency attributes like transparent color for display.

Declaration:

public ImageGear.Core.ImGearTransparency Transparency

Value:

ImGearTransparency Class.

See Also:

ImGearTransparency Class


ImGearPage Methods

The ImGearPage Class of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
Clone Method
Creates new object that is exact copy of current instance.


Clone Method

32-bit
64-bit
CF
P
P
P

Description:

Creates a new object that is a copy of the current instance.

Declaration:

public abstract ImageGear.Core.ImGearPage Clone()

Return Value:

ImGearPage Class object that is a copy of the current instance.

See Also

ImGearPage Class


ImGearPixel Class

32-bit
64-bit
CF
P
P
P

Description:

Encapsulates particular image pixels and represents colors store for each channel value.

For simplicity, ImGearPixel does not contain any information about channels depths and color space. Therefore, identical by structure (see construction attributes), pixels may belong to images with significantly different channels, structure, and color space.

Declaration:

public sealed class ImGearPixel

Members:

Constructors
Name
Description
ImGearPixel Constructor
Initializes ImGearPixel Class.

Properties
Name
Description
BitsPerChannel Property
Gets the number of bits per color channel
ChannelCount Property
Quantity of channels in pixel.
this Property
Channels indexing property.

Sample Code:

C#
// Create a pixel for an image with an 8bit palette.
ImGearPixel igPixelIndexed = new ImGearPixel(1, 8);
// Assign the pixel palette position 176.
igPixelIndexed[0] = 176;
// Create a 512x512 8bit indexed image.
ImGearPage igPageIndex = new ImGearRasterPage(512, 512,
    new ImGearColorSpace(ImGearColorSpaceIDs.I),
    new int[] { 8 }, true);
// Allocate a new palette
igPageIndex.DIB.Palette = new ImGearRGBQuad[256];
// Set the 176th palette entry to green.
igPageIndex.DIB.Palette[176].Red = 0;
igPageIndex.DIB.Palette[176].Green = 127;
igPageIndex.DIB.Palette[176].Blue = 0;
// Update the full image with this pixel.
for (int height = 0; height < igPageIndex.DIB.Height; height++)
    for (int width = 0; width < igPageIndex.DIB.Width; width++)
        igPageIndex.DIB.UpdatePixelFrom(width, height, igPixelIndexed);
// Create a pixel for a 32bit CMYK image.
ImGearPixel igPixelCMYK = new ImGearPixel(4, 8);
// Assign the pixel a blue color.
igPixelCMYK[0] = 255;
igPixelCMYK[1] = 255;
igPixelCMYK[2] = 0;
igPixelCMYK[3] = 127;
// Creates a 512x512 32bit CMYK image.
ImGearPage igPageCMYK = new ImGearRasterPage(512, 512,
    new ImGearColorSpace(ImGearColorSpaceIDs.CMYK),
    new int[] { 8, 8, 8, 8 }, true);
for (int height = 0; height < igPageCMYK.DIB.Height; height++)
    for (int width = 0; width < igPageCMYK.DIB.Width; width++)
        igPageCMYK.DIB.UpdatePixelFrom(width, height, igPixelCMYK);

VB .NET
'Create a pixel for an image with an 8bit palette.
Dim igPixelIndexed As ImGearPixel = New ImGearPixel(1, 8)
'Assign the pixel palette position 176.
igPixelIndexed(0) = 176
'Create a 512x512 8bit indexed image.
Dim igPageIndex As ImGearPage = New ImGearRasterPage(512, 512, _
    New ImGearColorSpace(ImGearColorSpaceIDs.I), _
    New Integer() {8}, True)
'Allocate a new palette
ReDim igPageIndex.DIB.Palette(256)
'Set the 176th palette entry to green.
igPageIndex.DIB.Palette(176).Red = 0
igPageIndex.DIB.Palette(176).Green = 127
igPageIndex.DIB.Palette(176).Blue = 0
'Update the full image with this pixel.
For height As Integer = 0 To igPageIndex.DIB.Height - 1
    For width As Integer = 0 To igPageIndex.DIB.Width - 1
        igPageIndex.DIB.UpdatePixelFrom(width, height, igPixelIndexed)
    Next
Next
'Create a pixel for a 32bit CMYK image.
Dim igPixelCMYK As ImGearPixel = New ImGearPixel(4, 8)
'Assign the pixel a blue color.
igPixelCMYK(0) = 255
igPixelCMYK(1) = 255
igPixelCMYK(2) = 0
igPixelCMYK(3) = 127
'Creates a 512x512 32bit CMYK image.
Dim igPageCMYK As ImGearPage = New ImGearRasterPage(512, 512, _
    New ImGearColorSpace(ImGearColorSpaceIDs.CMYK), _
    New Integer() {8, 8, 8, 8}, True)
For height As Integer = 0 To igPageCMYK.DIB.Height - 1
    For width As Integer = 0 To igPageCMYK.DIB.Width - 1
        igPageCMYK.DIB.UpdatePixelFrom(width, height, igPixelCMYK)
    Next
Next


ImGearPixel Constructors

The ImGearPixel Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearPixel Constructor
Initializes ImGearPixel Class.


ImGearPixel Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes pixel store using defining attributes.

Declaration:

public ImGearPixel(int channelQty, int channelSize)

Parameters:

Name
Type
Description
channelQty
int
Quantity of channels in image.
channelSize
int
Actual size of store to contain color of each image channel.

Return Value:

New instance of ImGearPixel Class.

See Also:

ImGearPixel Class


ImGearPixel Properties

The ImGearPixel Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
BitsPerChannel Property
Gets the number of bits per color channel.
ChannelCount Property
Quantity of channels in pixel.
this Property
Channels indexing property.


BitsPerChannel Property

32-bit
64-bit
CF
P
P
P

Description:

Gets the number of bits per color channel.

Declaration:

public int BitsPerChannel [get]

Value:

Any integer value.


ChannelCount Property

32-bit
64-bit
CF
P
P
P

Description:

Gets the number of channels in pixel.

Declaration:

public int ChannelCount { get; }

Value:

Non-zero value.


this Property

32-bit
64-bit
CF
P
P
P

Description:

Accesses the color value using channel index.

Declaration:

public int this [int index]{ get; set }

Value:

Value from 0 to 2^(ChannelDepth) - 1 range.


ImGearPixelArray Class

32-bit
64-bit
CF
P
P
P

Description:

Represents one dimensional array of pixels.

Declaration:

public sealed class ImGearPixelArray

Members:

Constructors
Name
Description
ImGearPixelArray Constructor
Initializes pixels store.

Properties
Name
Description
ChannelCount Property
Quantity of channels in particular pixel.
PixelCount Property
Quantity of pixels in array.
this Property
Indexed property for direct access to contained pixels.


ImGearPixelArray Constructors

The ImGearPixelArray Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearPixelArray Constructor
Initializes pixels store.


ImGearPixelArray Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes pixels store using pixel defining attributes and length of array.

Declaration:

public ImGearPixelArray(int length, int channelQty, int channelSize)

Parameters:

Name
Type
Description
length
int
Quantity of pixels to stored in array.
channelQty
int
Quantity of channels in an image whose pixels are stored in array.
channelSize
int
Actual size of store to contain color value for each image channel.

Return Value:

New instance of ImGearPixelArray Class.

See Also:

ImGearPixelArray Class


ImGearPixelArray Properties

The ImGearColorProfile Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
ChannelCount Property
Quantity of channels in particular pixel.
PixelCount Property
Quantity of pixels in array.
this Property
Indexed property for direct access to contained pixels.


ChannelCount Property

32-bit
64-bit
CF
P
P
P

Description:

Returns the number of channels in a particular pixel.

Declaration:

public Int ChannelCount { get; }

Value:

Non-zero quantity of channels.


PixelCount Property

32-bit
64-bit
CF
P
P
P

Description:

Obtains the number of elements (pixels) in an array.

Declaration:

public Int PointCount { get; }

Value:

Array length.


this Property

32-bit
64-bit
CF
P
P
P

Description:

Provides access to color values of stored pixels and their channels.

Declaration:

public Int this [int Pixel, int Channel] { get; set }

Parameters:

Name
Type
Description
Pixel
int
Number of pixel in array.
Channel
int
Channel number in particular pixel.

Value:

Color value of requested channel in requested pixel.


ImGearPolygon Class

32-bit
64-bit
CF
P
P
P

Description:

Encapsulates polygon (i.e., 2D shape defined by set of two or more points connected by straight lines).

Declaration:

public class ImGearPolygon

Members:

Constructors
Name
Description
ImGearPolygon Constructor
Initializes empty polygon.

Fields
Name
Description
Points Field
Array of points that define polygon structure.


ImGearPolygon Constructors

The ImGearPolygon Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearPolygon Constructor
Initializes empty polygon.


ImGearPolygon Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes polygon instance without any points. Creator of new instance should allocate points array and attach it to created object using Points property.

Declaration:

public ImGearPolygon()

Return Value:

New instance of ImGearPolygon Class

See Also:

ImGearPolygon Class


ImGearPolygon Fields

The ImGearPolygon Class of the ImageGear.Core Namespace has the following fields:

Fields
Name
Description
Points Field
Array of points that define polygon structure.


Points Field

32-bit
64-bit
CF
P
P
P

Description:

Array of points that defines polygon structure.

Declaration:

public ImGearPoint[] Points { get; set }

Value:

Array of ImGearPoint Structure objects or null.


ImGearRasterPage Class

32-bit
64-bit
CF
P
P
P

Description:

Represents the raster image.

Declaration:

public class ImGearRasterPage : ImageGear.Core.ImGearPage

Members:

Constructors
Name
Description
ImGearRasterPage Constructor
Initializes page from main attributes. Optionally, allocates store for image data.

Properties
Name
Description
ColorProfile Property
A local color profile associated with the image.
DICOMDisplaySettings Property
Provides access to DICOM specific display contrast settings.
ROI Property
Region of interest.

Methods
Name
Description
Clone Method
Creates new object that is exact copy of current instance.
CreateFromDIB Method
Creates new page with same image data as given DIB.
CreateFromImage Method
Creates new page with the same image data as incoming image.
DuplicateRect Method
Returns a new raster page object representing a part of the ImGearRasterPage object limited by the specified rectangle.


ImGearRasterPage Constructors

The ImGearRasterPage Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearRasterPage Constructor
Initializes page from main attributes. Optionally, allocates store for image data.


ImGearRasterPage Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes page with set of image defining attributes. Optionally, allocates store for pixels.

It is possible to receive an exception while contructing page instance when there is image attributes incompatibility (e.g., ChannelDepths has length smaller than colors channels quantity in specified color space).

Declaration:

public ImGearRasterPage (int width, int height, ImGearColorSpace colorSpace, int[]
channelDepths, bool allocatePixels)

Parameters:

Name
Type
Description
width
int
Width of page in pixels.
height
int
Height of page in pixels.
colorSpace
ImGearColorSpace Structure
Pixels' color space.
channelDepths
int[]
Channels depths of new page.
allocatePixels
bool
Indicates whether pixels store should be allocated or not.

Return Value:

New instance of ImGearRasterPage Class

See Also:

ImGearRasterPage Class


ImGearRasterPage Properties

The ImGearRasterPage Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
ColorProfile Property
A local color profile associated with the image.
DICOMDisplaySettings Property
Provides access to DICOM specific display contrast settings.
ROI Property
Region of interest.


ColorProfile Property

32-bit
64-bit
CF
P
P
P

Description:

A local color profile associated with the image. If a color profile is set here, and profiles are enabled in ImGearColorProfileManager Class, the local color profile will be used for color space conversions (instead of a global color profile).

Declaration:

public ImGearColorProfile ColorProfile { get; set }

Value:

ImGearColorProfile Class object.

Default Value:

NULL


DICOMDisplaySettings Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides access to DICOM specific display contrast settings.

DICOM specification defines several contrast transformations, such as Modality LUT, VOI LUT, etc. When ImageGear loads a DICOM image, it initializes DICOMDisplaySettings Property of ImGearRasterPage Class with settings found in the file. During display, ImageGear checks for presence of DICOMDisplaySettings, and if it is present, uses it in display processing pipeline. This allows you to load and display DICOM images with proper contrast, without the need for extra application code.

DICOMDisplaySettings can be attached to an ImGearRasterPage Class or to a ImGearPageDisplay Class. If ImGearPageDisplay Class.DICOMDisplaySettings Property is not null, ImageGear uses it for display. If ImGearPageDisplay Class.DICOMDisplaySettings Property is null, ImageGear checks ImGearRasterPage Class for presence of DICOMDisplaySettings, and if it is not null, uses it for display. In other words, DICOMDisplaySettings attached to Display has higher priority than DICOMDisplaySettings attached to ImGearRasterPage.

DICOMDisplaySettings Property can be also used if the image was not loaded from a DICOM file. It can be useful for non-medical images as well.

This property affects grayscale images with bit depths from 2 to 31.

Declaration:

public ImageGear.Formats.DICOM.ImGearDICOMDisplaySettings DICOMDisplaySettings { get, set
}

Value:

ImGearDICOMDisplaySettings Class object.

Default value:

NULL


ROI Property

32-bit
64-bit
CF
P
P
P

Description:

Provides access to region of interest.

Region of interest may have both rectangular or non-rectangular shape. It is also allowed to have smaller bounds than the image rectangle. null reference is treated as valid value and refers to the entire image area.

Declaration:

public ImGearROI ROI { get; set }

Value:

ImGearROI Class instance or null.

See Also:

ImGearROI Class


ImGearRasterPage Methods

The ImGearRasterPage Class of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
Clone Method
Creates new object that is exact copy of current instance.
CreateFromDIB Method
Creates new page with same image data as given DIB.
CreateFromImage Method
Creates new page with the same image data as incoming image.
DuplicateRect Method
Returns a new raster page object representing a part of the ImGearRasterPage object limited by the specified rectangle.


Clone Method

32-bit
64-bit
CF
P
P
P

Description:

Creates a new object that is a copy of the current instance.

Declaration:

public abstract ImageGear.Core.ImGearRasterPage Clone()

Return Value:

ImGearRasterPage Class object that is a copy of the current instance.


CreateFromDIB Method

32-bit
64-bit
CF
P
P
P

Description:

Creates new page with the same image data as incoming DIB.

Declaration:

public static ImGearRasterPage CreateFromDIB(ImGearDIB dib)

Parameters:

Name
Type
Description
dib
ImGearDIB Class
Non-null reference to ImGearDIB instance.

Return value:

New instance of ImGearRasterPage Class.

See Also:

ImGearRasterPage Class

ImGearDIB Class


CreateFromImage Method

32-bit
64-bit
CF
P
P
P

Description:

Creates new page with the same image data as incoming image.

Declaration:

public static ImageGear.Core.ImGearRasterPage CreateFromImage(System.Drawing.Image image)

Parameters:

Name
Type
Description
image
System.Drawing.Image
Non-null reference to the image.

Return value:

New instance of ImGearRasterPage Class.

See Also:

ImGearRasterPage Class


DuplicateRect Method

32-bit
64-bit
CF
P
P
P

Description:

Returns a new raster page object representing a part of the ImGearRasterPage object limited by the specified rectangle.

Declaration:

public ImageGear.Core.ImGearRasterPage DuplicateRect(ImageGear.Core.ImGearRectangle rc)

Parameters:

Name
Type
Description
rc
ImGearRectangle Structure
The rectangle.

Return value:

ImGearRasterPage Class.

See Also:

ImGearRasterPage Class


ImGearRGBLUT Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents RGB look-up table (LUT).

Declaration:

public class ImGearRGBLUT : ImageGear.Core.ImGearMultichannelLUT

Members:

Constructors
Name
Description
ImGearRGBLUT Constructor
Creates a new instance of the object.
ImGearRGBLUT Constructor
Creates a new instance of the object.

Properties
Name
Description
BlueLUT Property
Provides access to single channel LUT for the Blue channel.
GreenLUT Property
Provides access to single channel LUT for the Green channel.
RedLUT Property
Provides access to single channel LUT for the Red channel.


ImGearRGBLUT Constructors

The ImGearRGBLUT Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearRGBLUT Constructor
Creates a new instance of the object.
ImGearRGBLUT Constructor
Creates a new instance of the object.


ImGearRGBLUT Constructor

32-bit
64-bit
CF
P
P
P

Description:

This method creates a new instance of ImGearRGBLUT Class class.

Declaration:

public ImGearRGBLUT()

Return Value:

The new instance of ImGearRGBLUT Class object.

Example:

// Create an RGB LUT
ImGearRGBLUT lut = new ImGearRGBLUT();

See Also:

ImGearRGBLUT Class


ImGearRGBLUT Constructor

32-bit
64-bit
CF
P
P
P

Description:

This method creates a new instance of ImGearRGBLUT Class class and allocates its single-channel LUTs.

Declaration:

public ImGearRGBLUT(int inputDepth, int outputDepth)

Parameters:

Name
Type
Description
inputDepth
int
Specifies input depth for single-channel LUTs.
outputDepth
int
Specifies output depth for single-channel LUTs.

Return Value:

The new instance of ImGearRGBLUT Class object.

Example:

// Create a RGB LUT for converting 24-bit image into 24-bit image.
ImGearRGBLUT lut = new ImGearRGBLUT(8, 8);

See Also:

ImGearRGBLUT Class


ImGearRGBLUT Properties

The ImGearRGBLUT Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
BlueLUT Property
Provides access to single channel LUT for the Blue channel.
GreenLUT Property
Provides access to single channel LUT for the Green channel.
RedLUT Property
Provides access to single channel LUT for the Red channel.


BlueLUT Property

32-bit
64-bit
CF
P
P
P

Description:

This property sets/gets the single-channel LUT that corresponds to the Blue channel.

Declaration:

public override ImGearLUT BlueLUT { get; set }

Value:

An instance of ImGearLUT Class class.

Default value:

NULL


GreenLUT Property

32-bit
64-bit
CF
P
P
P

Description:

This property sets/gets the single-channel LUT that corresponds to the Green channel.

Declaration:

public override ImGearLUT GreenLUT { get; set }

Value:

An instance of ImGearLUT Class class.

Default value:

NULL


RedLUT Property

32-bit
64-bit
CF
P
P
P

Description:

This property sets/gets the single-channel LUT that corresponds to the Red channel.

Declaration:

public override ImGearLUT RedLUT { get; set }

Value:

An instance of ImGearLUT Class class.

Default value:

NULL


ImGearROI Class

32-bit
64-bit
CF
P
P
P

Description:

Region of interest (ImGearROI) represents free-shape image area (rectangular, non-rectangular or entire space) and specifies the meaningful part of an image. For example, it may be set up for some image processing functions to define the area to which a filter should be applied.

Declaration:

public abstract class ImGearROI

Members:

Properties
Name
Description
BoundRectangle Property
Gets the bounding rectangle.

Fields
Name
Description
Left Field
X offset of region in the image.
Top Field
Y offset of region in the image.

Methods
Name
Description
Clone Method
Creates a new object that is a copy of the current instance.
PointInRegion Method
Checks whether or not the specified point is in the ROI.


ImGearROI Properties

The ImGearROI Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
BoundRectangle Property
Gets the bounding rectangle.


BoundRectangle Property

32-bit
64-bit
CF
P
P
P

Description:

Gets the bounding rectangle.

Declaration:

public abstract ImageGear.Core.ImGearRectangle BoundRectangle [get]

Value:

ImGearRectangle Structure

See Also:

ImGearRectangle Structure


ImGearROI Fields

The ImGearROI Class of the ImageGear.Core Namespace has the following fields:

Fields
Name
Description
Left Field
X offset of region in the image.
Top Field
Y offset of region in the image.


Left Field

32-bit
64-bit
CF
P
P
P

Description:

Specifies left side of rectangle in case of ImGearROIRectangle, and reference point in case of ImGearROIMask.

Declaration:

public int Left

Value:

Integer value


Top Field

32-bit
64-bit
CF
P
P
P

Description:

Specifies top side of rectangle in case of ImGearROIRectangle, and the reference point in case of ImGearROIMask.

Declaration:

public int Top

Value:

Integer value


ImGearROI Methods

The ImGearROI Class of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
Clone Method
Creates a new object that is a copy of the current instance.
PointInRegion Method
Checks whether or not the specified point is in the ROI.


Clone Method

32-bit
64-bit
CF
P
P
P

Description:

Creates a new object that is a copy of the current instance.

Declaration:

public abstract ImageGear.Core.ImGearROI Clone()

Return Value:

ImGearROI Class object that is a copy of the current instance.


PointInRegion Method

32-bit
64-bit
CF
P
P
P

Description:

Checks whether or not the specified point is in the ROI.

Declaration:

public abstract bool PointInRegion(int x, int y)

Parameters:

Name
Type
Description
x
int
The x value of the point.
y
int
The y value of the point.

Return Value:

True, false


ImGearROIMask Class

32-bit
64-bit
CF
P
P
P

Description:

Represents free-shape (non-rectangular) region of interest.

Declaration:

public sealed class ImGearROIMask : ImageGear.Core.ImGearROI

Members:

Constructors
Name
Description
ImGearROIMask Constructor
Initializes region from mask or shape object.
ImGearROIMask Constructor
Initializes region from mask or shape object.
ImGearROIMask Constructor
Initializes region from mask or shape object.
ImGearROIMask Constructor
Creates new instance of ImGearROIMask object, corresponding to area in page that is filled with MaskColor.

Properties
Name
Description
BoundRectangle Property
Gets the bounding rectangle.
Mask Property
1-bit image that defines region shape.

Methods
Name
Description
Clone Method
Creates a new object that is a copy of the current instance.
Dilate Method
Dilates ROI mask on the specified pixel count.
Erode Method
Erodes ROI mask on the specified pixel count.
PointInRegion Method
Checks whether or not the specified point is in the ROI.


ImGearROIMask Constructors

The ImGearROIMask Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearROIMask Constructor
Initializes region from mask or shape object.
ImGearROIMask Constructor
Initializes region from mask or shape object.
ImGearROIMask Constructor
Initializes region from mask or shape object.
ImGearROIMask Constructor
Creates new instance of ImGearROIMask object, corresponding to an area in a page that is filled with MaskColor.


ImGearROIMask Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes mask from shape (ImGearShape) or page (ImGearPage) object.

This constructor clones incoming image (mask) that must not be an empty page with exactly one channel and BitDepth of 1. ROI's mask image will be exact copy (clone) of incoming image.

Declaration:

public ImGearROIMask(int left, int top, ImageGear.Core.ImGearPage mask)

Parameters:

Name
Type
Description
left
int
Left side of region.
top
int
Top side of region.
mask
ImGearPage Class
1-bit image that defines ROI shape.

Return Value:

New instance of ImGearROIMask Class.

See Also:

ImGearROIMask Class


ImGearROIMask Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes mask from shape (ImGearShape) or page (ImGearPage) object.

This constructor generates mask image from the shape with minimal possible dimensions. Left member is set to the sum of left parameter and x coordinate of left-most point of the Shape. The Top member is set to the sum of the top parameter and the y coordinate of the topmost point of the Shape.

Declaration:

public ImGearROIMask(int left, int top, ImageGear.Core.IImGearShape shape)

Parameters:

Name
Type
Description
left
int
Left side of region.
top
int
Top side of region.
shape
IImGearShape
Shape from which mask will be generated.

Return Value:

New instance of ImGearROIMask Class.

See Also:

ImGearROIMask Class


ImGearROIMask Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes mask from shape (ImGearShape) or page (ImGearPage) object.

This constructor clones incoming image (mask) just as the first constructor does, supposing that Left & Top = 0.

Declaration:

public ImGearROIMask(ImageGear.Core.ImGearPage mask)

Parameters:

Name
Type
Description
mask
ImGearPage Class
1-bit image that defines ROI shape.

Return Value:

New instance of ImGearROIMask Class.

See Also:

ImGearROIMask Class


ImGearROIMask Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates new instance of ImGearROIMask object, corresponding to area in page that is filled with MaskColor. If InvertSelection is True, then mask is created for the area that is not filled with MaskColor.

MaskColor should correspond to page's number of channels and bit depth.

This function can be used to create ROI Mask based on DICOM Pixel Padding Value.

Declaration:

public ImGearROIMask ( ImageGear.Core.ImGearPage page , ImageGear.Core.ImGearPixel
MaskColor , bool InvertSelection )

Parameters:

Name
Type
Description
page
ImGearPage Class
Page, according to which the ROIMask is built.
MaskColor
ImGearPixel Class
Mask color.
InvertSelection
Boolean
Set to true to build mask according to area not filled with MaskColor.

Return Value:

The new instance of ImGearROIMask Class object.

Example:

// Set ROI to area that is not filled with Pixel Padding Value
ImGearPixel ppv = new ImGearPixel(1, 16);
ppv.Item(0) = 1024;
page.ROI = new ImGearROIMask(page, ppv);

See Also:

ImGearROIMask Class


ImGearROIMask Properties

The ImGearROIMask Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
BoundRectangle Property
Gets the bounding rectangle.
Mask Property
1-bit image that defines region shape.


Mask Property

32-bit
64-bit
CF
P
P
P

Description:

Region of interest expressed in binary (1-bit) image.

Declaration:

public ImGearDIB Mask { get; }

Value:

Instance of ImGearDIB Class type.

See Also:

ImGearDIB Class


ImGearROIMask Methods

The ImGearROIMask Class of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
Clone Method
Creates a new object that is a copy of the current instance.
Dilate Method
Dilates ROI mask on the specified pixel count.
Erode Method
Erodes ROI mask on the specified pixel count.
PointInRegion Method
Checks whether or not the specified point is in the ROI.


Clone Method

32-bit
64-bit
CF
P
P
P

Description:

Creates a new object that is a copy of the current instance.

Declaration:

public override ImageGear.Core.ImGearROI Clone()

Return Value:

ImGearROI Class that is a copy of the current instance.

See Also:

ImGearROI Class


Dilate Method

32-bit
64-bit
CF
P
P
P

Description:

This method dilates ROI mask on the specified pixel count.

Declaration:

public void Dilate(int pixCount)

Parameters:

Name
Type
Description
pixCount
int
The pixel count.

Return Value:

None

See Also:

Erode Method


Erode Method

32-bit
64-bit
CF
P
P
P

Description:

This method erodes ROI mask on the specified pixel count.

Declaration:

public void Erode(int pixCount)

Parameters:

Name
Type
Description
pixCount
int
The pixel count.

Return Value:

None.

See Also:

Dilate Method


PointInRegion Method

32-bit
64-bit
CF
P
P
P

Description:

This method checks whether or not the specified point is in the ROI.

Declaration:

public override bool PointInRegion(int x, int y)

Parameters:

Name
Type
Description
x
int
The x value of the point.
y
int
The y value of the point.

Return Value:

True, false

See Also:

ImGearROIMask Class


ImGearROIRectangle Class

32-bit
64-bit
CF
P
P
P

Description:

Encapsulates rectangular region of interest.

Declaration:

public sealed class ImGearROIRectangle : ImageGear.Core.ImGearROI

Members:

Constructors
Name
Description
ImGearROIRectangle Constructor
Initializes instance with offset and size values of interested rectangle.
ImGearROIRectangle Constructor
Initializes instance with offset and size values of interested rectangle.

Properties
Name
Description
BoundRectangle Property
Gets the bounding rectangle.

Fields
Name
Description
Height Field
Height of rectangle in pixels.
Width Field
Width of rectangle in pixels.

Methods
Name
Description
Clone Method
Creates a new object that is a copy of the current instance.
PointInRegion Method
Checks whether or not the specified point is in the ROI.


ImGearROIRectangle Constructors

The ImGearROIRectangle Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearROIRectangle Constructor
Initializes instance with offset and size values of interested rectangle.
ImGearROIRectangle Constructor
Initializes instance with offset and size values of interested rectangle.


ImGearROIRectangle Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes instance with offset and size values of interested rectangle.

Declaration:

public ImGearROIRectangle (int left, int top, int width, int height)

Parameters:

Name
Type
Description
left
int
Left side of rectangle.
top
int
Top side of rectangle.
width
int
Width of rectangle.
height
int
Height of rectangle.

Return Value:

New instance of ImGearROIRectangle Class.

See Also:

ImGearROIRectangle Class


ImGearROIRectangle Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes instance with offset and size values of interested rectangle.

This constructor works, supposing that left & top = 0.

Declaration:

public ImGearROIRectangle(int width, int height)

Parameters:

Name
Type
Description
width
int
Width of rectangle.
height
int
Height of rectangle.

Return Value:

New instance of ImGearROIRectangle Class.

See Also:

ImGearROIRectangle Class


ImGearROIRectangle Properties

The ImGearROIRectangle Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
BoundRectangle Property
Gets the bounding rectangle.


BoundRectangle Property

32-bit
64-bit
CF
P
P
P

Description:

Gets the bounding rectangle.

Declaration:

public override ImageGear.Core.ImGearRectangle BoundRectangle { get; }

Value:

ImGearRectangle Structure

See Also:

ImGearRectangle Structure


ImGearROIRectangle Fields

The ImGearROIRectangle Class of the ImageGear.Core Namespace has the following fields:

Fields
Name
Description
Height Field
Height of rectangle in pixels.
Width Field
Width of rectangle in pixels.


Height Field

32-bit
64-bit
CF
P
P
P

Description:

Height of rectangle in pixels.

Declaration:

public int Height

Value:

Integer value

See Also:

Width Field


Width Field

32-bit
64-bit
CF
P
P
P

Description:

Width of rectangle in pixels.

Declaration:

public int Width

Value:

Integer value

See Also:

Height Field


ImGearROIRectangle Methods

The ImGearROIRectangle Class of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
Clone Method
Creates a new object that is a copy of the current instance.
PointInRegion Method
Checks whether or not the specified point is in the ROI.


Clone Method

32-bit
64-bit
CF
P
P
P

Description:

Creates a new object that is a copy of the current instance.

Declaration:

public abstract ImageGear.Core.ImGearROI Clone()

Return Value:

ImGearROI Class that is a copy of the current instance.

See Also:

ImGearROI Class


ImGearSpotChannelInfo Class

32-bit
64-bit
CF
P
P
P

Description:

This is a spot channel class that uses a special (like Pantone) color. This class does not store a color name, but looks it up from the loaded color books.

Declaration:

public class ImGearSpotChannelInfo : ImageGear.Core.ImGearExtraChannelInfo

Members:

Constructors
Name
Description
ImGearSpotChannelInfo Constructor
Creates and initializes an instance of ImGearSpotChannelInfo class.
ImGearSpotChannelInfo Constructor
Creates and initializes an instance of ImGearSpotChannelInfo class.

Properties
Name
Description
ColorID Property
Specifies ID of the spot color.
ColorName Property
Looks up color name from the internal color books.
Opacity Property
Specifies opacity of the spot color.
VendorID Property
Specifies vendor ID of the spot color.


ImGearSpotChannelInfo Constructors

The ImGearSpotChannelInfo Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearSpotChannelInfo Constructor
Creates and initializes an instance of ImGearSpotChannelInfo class.
ImGearSpotChannelInfo Constructor
Creates and initializes an instance of ImGearSpotChannelInfo class.


ImGearSpotChannelInfo Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearSpotChannelInfo class by using spot color vendor ID and the color ID itself.

Declaration:

public ImGearSpotChannelInfo(ImageGear.Core.ImGearSpotColorVendorID vendorID, long
colorID)

Parameters:

Name
Type
Description
vendorID
ImGearSpotColorVendorID Enumeration
Vendor ID of the spot color.
colorID
long
Spot color ID in Vendor's color book.

Return Value:

New instance of ImGearSpotChannelInfo Class.

Example:

C#
spot = new ImGearSpotChannelInfo(ImGearSpotColorVendorID.Pantone, 1112299335);

Visual Basic
spot = New ImGearSpotChannelInfo(ImGearSpotColorVendorID.Pantone, 1112299335)

See Also:

ImGearSpotChannelInfo Class


ImGearSpotChannelInfo Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearSpotChannelInfo class by using spot color vendor ID and the color name.

Declaration:

public ImGearSpotChannelInfo(string name)

Parameters:

Name
Type
Description
name
string
Spot color name in Vendor's color book.

Return Value:

New instance of ImGearSpotChannelInfo Class.

See Also:

ImGearSpotChannelInfo Class


ImGearSpotChannelInfo Properties

The ImGearSpotChannelInfo Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
ColorID Property
Specifies ID of the spot color.
ColorName Property
Looks up color name from the internal color books.
Opacity Property
Specifies opacity of the spot color.
VendorID Property
Specifies vendor ID of the spot color.


ColorID Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies ID of the spot color.

Declaration:

public long ColorID { get; }

Value:

Long value.

See Also:

ImGearSpotChannelInfo Constructor


ColorName Property

32-bit
64-bit
CF
P
P
P

Description:

This property looks up color name from the internal color books.

Declaration:

public string ColorName { get; }

Value:

String value.

See Also:

ImGearSpotChannelInfo Constructor


Opacity Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies opacity of the spot color. The opacity value is between 0 and 100.

Declaration:

public int Opacity { get;  set; }

Value:

Integer value.

See Also:

N/A


VendorID Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies vendor ID of the spot color.

Declaration:

public ImageGear.Core.ImGearSpotColorVendorID VendorID { get; }

Value:

ImGearSpotColorVendorID Enumeration value.

See Also:

ImGearSpotChannelInfo Constructor


ImGearTransparency Class

32-bit
64-bit
CF
P
P
P

Description:

This class specifies image transparency attributes like transparent color for display.

Declaration:

public class ImGearTransparency

Members:

Constructors
Name
Description
ImGearTransparency Constructor
Creates and initializes an instance of ImGearTransparency class.

Fields
Name
Description
DisplayColor Field
Specifies transparent color for display.


ImGearTransparency Constructors

The ImGearTransparency Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearTransparency Constructor
Creates and initializes an instance of ImGearTransparency class.


ImGearTransparency Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearTransparency class by specifying a transparent color for display in RGB format.

Declaration:

public ImGearTransparency(byte DisplayRed, byte DisplayGreen, byte DisplayBlue)

Parameters:

Name
Type
Description
DisplayRed
byte
Red value of the transparent color for display.
DisplayGreen
byte
Green value of the transparent color for display.
DisplayBlue
byte
Blue value of the transparent color for display.

Return Value:

New instance of ImGearTransparency Class.

Example:

C#
whiteTransparency = new ImGearTransparency(255, 255, 255);

Visual Basic
whiteTransparency = New ImGearTransparency(255, 255, 255)

See Also:

ImGearTransparency Class


ImGearTransparency Fields

The ImGearTransparency Class of the ImageGear.Core Namespace has the following fields:

Fields
Name
Description
DisplayColor Field
Specifies transparent color for display.


DisplayColor Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies transparent color for display.

Declaration:

public ImageGear.Core.IImGearRGBQuad DisplayColor

Value:

ImGearRGBQuad Structure.

See Also:

ImGearRGBQuad Structure


ImGearVectorPage Class

32-bit
64-bit
CF
P
P
P

Description:

Represents page with vector image. DIB property is non-null for the instances of this type, but it is always empty (does not have pixels).

Declaration:

public abstract class ImGearVectorPage : ImageGear.Core.ImGearPage

Members:

Methods
Name
Description
Clone Method
Creates a new object that is a copy of the current instance.
Rasterize Method
Creates raster image representation of contained vector image.


ImGearVectorPage Methods

The ImGearVectorPage Class of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
Clone Method
Creates a new object that is a copy of the current instance.
Rasterize Method
Creates raster image representation of contained vector image.


Clone Method

32-bit
64-bit
CF
P
P
P

Description:

Creates a new object that is a copy of the current instance.

Declaration:

public abstract ImageGear.Core.ImGearPage Clone()

Return Value:

ImGearVectorPage Class that is a copy of the current instance.

See Also:

ImGearVectorPage Class


Rasterize Method

32-bit
64-bit
CF
P
P
P

Description:

Rasterizes vector data into raster page.

Declaration:

public static void ImGearPage Rasterize()

Value:

Stand-alone instance of ImGearPage Class.

See Also:

ImGearPage Class

Sample Code:

C#
ImGearPage igPage;
// Load a vector image into a ImGearPage object
using (FileStream localFile = new FileStream("vector.cgm", FileMode.Open))
    igPage = ImGearFileFormats.LoadPage(localFile, 0);
// Check if vector page, and rasterize if it is.
if (igPage is ImGearVectorPage)
{
    // Adjust the image size to 1024 width maintaining aspect ratio
    ImGearProcessing.Resize(igPage, 1024,
        igPage.DIB.Height * 1024 / igPage.DIB.Width, null);
    // Get a rasterized version of the vector image at this resolution
    igPage = ((ImGearVectorPage)igPage).Rasterize();
}

VB .NET
Dim igPage As ImGearPage
'Load a vector image into a ImGearPage object.
Dim localFile As FileStream = New FileStream("vector.cgm", FileMode.Open)
Try
    igPage = ImGearFileFormats.LoadPage(localFile, 0)
Finally
    localFile.Close()
End Try
'Check if vector page, and rasterize if it is.
If (TypeOf igPage Is ImGearVectorPage) Then
    'Adjust the image size to 1024 width maintaining aspect ratio.
    ImGearProcessing.Resize(igPage, 1024, _
        igPage.DIB.Height * 1024 / igPage.DIB.Width, Nothing)
    'Get a rasterized version of the vector image at this resolution.
    igPage = CType(igPage, ImGearVectorPage).Rasterize()
End If


ImGearVersion Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides static properties to retrieve version info for the product assembly.

Declaration:

public sealed class ImGearVersion

Members:

Properties
Name
Description
AssemblyVersionInfo Property
Version info for this assembly
Build Property
Build number
Copyright Property
Copyright info
Major Property
Major version number
Minor Property
Minor version number
ProductName Property
Product name
Revision Property
Revision number
VersionString Property
Product version in the string format


ImGearVersion Properties

The ImGearVersion Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
AssemblyVersionInfo Property
Version info for this assembly
Build Property
Build number
Copyright Property
Copyright info
Major Property
Major version number
Minor Property
Minor version number
ProductName Property
Product name
Revision Property
Revision number
VersionString Property
Product version in the string format


AssemblyVersionInfo Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides version info for this assembly.

Declaration:

public static System.Diagnostics.FileVersionInfo AssemblyVersionInfo { get; }

Value:

System.Diagnostics.FileVersionInfo

See Also:

N/A


Build Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides the build number.

Declaration:

public static int Build { get; }

Value:

Integer value

See Also:

N/A


Copyright Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides copyright information.

Declaration:

public static string Copyright { get; }

Value:

String value

See Also:

N/A


Major Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides a major version number.

Declaration:

public static int Major { get; }

Value:

Integer value

See Also:

N/A


Minor Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides a minor version number.

Declaration:

public static int Minor { get; }

Value:

Integer value

See Also:

N/A


ProductName Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides the product name.

Declaration:

public static string ProductName { get; }

Value:

String

See Also:

N/A


Revision Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides the revision number.

Declaration:

public static int Revision { get; }

Value:

Integer value

See Also:

N/A


VersionString Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides the product version in string format.

Declaration:

public static string VersionString { get; }

Value:

String value

See Also:

N/A


ImGearWarning Class

32-bit
64-bit
CF
P
P
P

Description:

Base class for all warnings handled by the ImageGear for .NET library. Contains error code and optionally supplied data.

Declaration:

public sealed class ImGearWarning

Members:

Properties
Name
Description
AddWarning Property
Reference to the AddWarning delegate.
Description Property
Description.
ErrorCode Property
Error code.


ImGearWarning Properties

The ImGearWarning Class of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
AddWarning Property
Reference to the AddWarning delegate.
Description Property
Description.
ErrorCode Property
Error code.


AddWarning Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides a reference to the AddWarning delegate.

Declaration:

public static ImageGear.Core.ImGearAddWarning AddWarning {public  get; public  set; }

Value:

ImGearAddWarning Delegate

See Also:

ImGearAddWarning Delegate


Description Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies a description.

Declaration:

public string Description { get;  set; }

Value:

String value

See Also:

N/A


ErrorCode Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies an error code.

Declaration:

public ImageGear.Core.ImGearErrorCodes ErrorCode { get;  set; }

Value:

ImGearErrorCodes Enumeration value.

See Also:

ImGearErrorCodes Enumeration


ImageGear.Core Namespace Interfaces

The ImageGear.Core Namespace has the following interface members:

Interfaces:
Name
Description
IImGearMetadataDictRecord Interface
Specifies baseline features for a metadata dictionary record.
IImGearRoundedRectangle Interface
Represents a rounded rectangle.

32-bit
64-bit
CF
P
P
P
32-bit
64-bit
CF
P
P
P
32-bit
64-bit
CF
P
P
P
32-bit
64-bit
CF
P
P
P


IImGearMetadataDictRecord Interface

32-bit
64-bit
CF
P
P
P

Description:

This interface specifies baseline features for a metadata dictionary record.

Declaration:

public interface IImGearMetadataDictRecord

Members:

Properties
Name
Description
Name Property
Tag name
Tag Property
Tag ID


IImGearMetadataDictRecord Properties

The IImGearMetadataDictRecord Interface of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
Name Property
Tag name
Tag Property
Tag ID


Name Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies tag name.

Declaration:

public string Name { get;  set; }

Value:

any string

Default value:

""


Tag Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies tag ID.

Declaration:

public int Tag { get;  set; }

Value:

Any integer number.

Default value:

0

32-bit
64-bit
CF
P
P
P


IImGearRoundedRectangle Interface

32-bit
64-bit
CF
P
P
P

Description:

This interface represents a rounded rectangle.

Declaration:

public interface IImGearRoundedRectangle : IImGearShape

Members:

Properties
Name
Description
LeftTop Property
Specifies coordinates of the upper-left corner of the rectangle.
RightBottom Property
Specifies coordinates of the right-bottom corner of the rectangle.
Radius Property
Specifies the radius for the rounded edges.


IImGearRoundedRectangle Properties

The IImGearRoundedRectangle Interface of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
LeftTop Property
Specifies coordinates of the upper-left corner of the rectangle.
RightBottom Property
Specifies coordinates of the right-bottom corner of the rectangle.
Radius Property
Specifies the radius for the rounded edges.


LeftTop Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies coordinates of the upper-left corner of the rectangle. .

Declaration:

public ImGearPoint LeftTop {get; set;}

Value:

ImGearPoint Structure


RightBottom Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies coordinates of the right-bottom corner of the rectangle. .

Declaration:

public ImGearPoint RightBottom {get; set;}

Value:

ImGearPoint Structure


Radius Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the radius for the rounded edges.

Declaration:

public int Radius {get; set;}

Value:

int


ImageGear.Core Namespace Structures

The ImageGear.Core Namespace has the following stucture members:

Structures:
Name
Description
ImGearArrayRef Structure
Stores ImageGear arrays.
ImGearChannelRange Structure
This structure describes channels to be processed with ImGearProcessing Class methods.
ImGearColorSpace Structure
Defines semantics of information, stored in all image channels.
ImGearCommonMetadataDictRecord Structure
Contains data for a common metadata dictionary record.
ImGearDoublePoint Structure
Stores a set of two double precision numbers that represent the point.
ImGearDoubleRectangle Structure
Stores a set of four double precision numbers that represent the location and size of a rectangle.
ImGearEllipse Structure
Stores a set of two ImGear values that represent the location and size of an ellipse.
ImGearOrientation Structure
Specifies orientation of page or display.
ImGearPoint Structure
Encapsulates a point in a 2-D coordinate system.
ImGearRationalInt Structure
Specifies rational fraction as an indicated division of Numerator/Denominator.
ImGearRationalUInt Structure
Specifies rational fraction as an indicated division of Numerator/Denominator.
ImGearRect Structure
Stores a set of four integer numbers that represent the location and size of the rectangle.
ImGearRectangle Structure
Stores a set of four integer numbers that represent the location and size of a rectangle.
ImGearRoundedRectangle Structure
Represents a rounded rectangle.
ImGearResolution Structure
Stores ImageGear resolution data.
ImGearRGBQuad Structure
Specifies RGB value.
ImGearSize Structure
Implements a relative coordinate or position.


ImGearArrayRef Structure

32-bit
64-bit
CF
P
P
P

Description:

Stores ImageGear arrays.

Declaration:

public struct ImGearArrayRef

Members:

Constructors
Name
Description
ImGearArrayRef Constructor
Initializes a new instance of the ImGearArrayRef structure.
ImGearArrayRef Constructor
Initializes a new instance of the ImGearArrayRef structure.

Fields
Name
Description
Content Field
Specifies structure content.
Offset Field
Specifies structure offset.


ImGearArrayRef Constructors

The ImGearArrayRef Structure of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearArrayRef Constructor
Initializes a new instance of the ImGearArrayRef structure.
ImGearArrayRef Constructor
Initializes a new instance of the ImGearArrayRef structure.


ImGearArrayRef Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes a new instance of the ImGearArrayRef structure.

Declaration:

public ImGearArrayRef(System.Array content)

Parameters:

Name
Type
Description
content
System.Array
Structure content.

Return Value:

New instance of ImGearArrayRef Structure.

See Also:

ImGearArrayRef Structure


ImGearArrayRef Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes a new instance of the ImGearArrayRef Structure.

Declaration:

public ImGearArrayRef(System.Array content, int offset)

Parameters:

Name
Type
Description
content
System.Array
Structure content.
offset
int

Return Value:

New instance of ImGearArrayRef Structure.

See Also:

ImGearArrayRef Structure


ImGearArrayRef Fields

The ImGearArrayRef Structure of the ImageGear.Core Namespace has the following fields:

Fields
Name
Description
Content Field
Specifies structure content.
Offset Field
Specifies structure offset.


Content Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies structure content.

Declaration:

public System.Array Content

Value:

System.Array.

See Also:

ImGearArrayRef Constructor

ImGearArrayRef Constructor


Offset Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies structure offset.

Declaration:

public int Offset

Value:

Integer value.

See Also:

ImGearArrayRef Constructor


ImGearChannelRange Structure

32-bit
64-bit
CF
P
P
P

Description:

This structure describes channels to be processed with ImGearProcessing Class methods. It is passed to some methods such as AdjustContrast Method, StretchContrast Method, and others.

Declaration:

public struct ImGearChannelRange

Members:

Constructors
Name
Description
ImGearChannelRange Constructor
Creates ImGearChannelRange structure from the start channel number and channel count.
ImGearChannelRange Constructor
Creates ImGearChannelRange structure from the color space and channel group identifier.

Fields
Name
Description
Count Field
Count of channel.
Start Field
Start channel number.

See Also:

ImGearRasterProcessing Class


ImGearChannelRange Constructors

The ImGearChannelRange Structure of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearChannelRange Constructor
Creates ImGearChannelRange structure from the start channel number and channel count.
ImGearChannelRange Constructor
Creates ImGearChannelRange structure from the color space and channel group identifier.


ImGearChannelRange Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates ImGearChannelRange Structure from the start channel number and channel count.

Declaration:

public ImGearChannelRange(int start, int count) |

Parameters:

Name
Type
Description
start
int
Start channel number.
count
int
Channel count.

Return value:

New instance of ImGearChannelRange Structure.

See Also:

ImGearChannelRange Structure


ImGearChannelRange Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates ImGearChannelRange structure from the color space and channel group identifier.

Declaration:

public ImGearChannelRange(ImGearColorSpace colorspace, ImGearChannelGroups group)

Parameters:

Name
Type
Description
colorspace
ImGearColorSpace Structure
Color Space for which the channel range structure is created.
group
ImGearChannelGroups Enumeration
Channel group constant.

Return value:

New instance of ImGearChannelRange Structure.

See Also:

ImGearChannelRange Structure

ImGearColorSpace Structure

ImGearChannelGroups Enumeration


ImGearChannelRange Fields

The ImGearChannelRange Structure of the ImageGear.Core Namespace has the following fields:

Fields
Name
Description
Count Field
Count of channel.
Start Field
Start channel number.


Count Field

32-bit
64-bit
CF
P
P
P

Description:

This field returns or sets channel count in the range (-1 indicates from Start to last channel of the DIB).

Declaration:

public int Count

Value:

-1, 0, ... maximum channel count


Start Field

32-bit
64-bit
CF
P
P
P

Description:

This field returns or sets the start channel in the channel range.

Declaration:

public int Start

Value:

0... maximum channel number


ImGearColorSpace Structure

32-bit
64-bit
CF
P
P
P

Description:

Defines semantics of information stored in all image channels.

Declaration:

public struct ImGearColorSpace

Members:

Constructors
Name
Description
ImGearColorSpace Constructor
Initializes instance from combination of ImGearColorSpaceIDs flags. Peforms verification of incoming value and throws ImGearException exception in case of any misfit.

Properties
Name
Description
AlphaChannelCount Property
Gets the number of alpha channels in the color space.
AlphaIndex Property
Gets the Index of the alpha channel in the color space.
Color Property
Returns color part of value identifier.
ColorChannelCount Property
Returns quantity of color channels. It does not include Alpha and Extra channels.
ContainsAlpha Property
Tells whether alpha or pre-multiplied alpha channel exits in image or not. It does not take into account whether color channels are pre-multiplied by alpha channel or not.
ContainsExtra Property
Checks existence of extra (unknown) channels in the image.
ExtraStartIndex Property
Gets the index of the first extra channel in the color space.
IsPremultiplied Property
Tells whether alpha channel exists and all color channels are pre-multiplied with alpha value or not.
Value Property
Gives access to combination of color space identifiers.

Methods
Name
Description
GetExtraChannelCount Method
Returns quantity of extra channels.
IsWellFormed Method
Verifies whether color space combination is valid (supported).


ImGearColorSpace Constructors

The ImGearColorSpace Structure of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearColorSpace Constructor
Initializes instance from combination of ImGearColorSpaceIDs flags. Peforms verification of incoming value and throws ImGearException exception in case of any misfit.


ImGearColorSpace Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes instance from combination of ImGearColorSpaceIDs flags. Pefroms verification of incoming value and throws ImGearException exception in case of any misfit.

Well-formed values are those which contain both alpha and pre-multiplied alpha flags or specify alpha (pre-multiplied) channel for non-RGB and non-Gy colorspaces.

Declaration:

public ImGearColorSpace(ImGearColorSpaceIDs value)

Parameters:

Name
Type
Description
value
ImGearColorSpaceIDs Enumeration
Well-formed combination of ImGearColorSpaceIDs flags.

Return Value:

New instance of ImGearColorSpace Structure.

See Also:

ImGearColorSpace Structure

ImGearColorSpaceIDs Enumeration


ImGearColorSpace Properties

The ImGearColorSpace Structure of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
AlphaChannelCount Property
Gets the number of alpha channels in the color space.
AlphaIndex Property
Gets the Index of the alpha channel in the color space.
Color Property
Returns color part of value identifier.
ColorChannelCount Property
Returns quantity of color channels. It does not include Alpha and Extra channels.
ContainsAlpha Property
Tells whether alpha or pre-multiplied alpha channel exits in image or not. It does not take into account whether color channels are pre-multiplied by alpha channel or not.
ContainsExtra Property
Checks existence of extra (unknown) channels in the image.
ExtraStartIndex Property
Gets the index of the first extra channel in the color space
IsPremultiplied Property
Tells whether alpha channel exists and all color channels are pre-multiplied with alpha value or not.
Value Property
Gives access to combination of color space identifiers.


AlphaChannelCount Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets the number of alpha channels in the color space.

Declaration:

public int AlphaChannelCount [get]

Value:

Any positive integer value.


AlphaIndex Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets the Index of the alpha channel in the color space.

Declaration:

public int AlphaIndex [get]

Value:

Any positive integer value.


Color Property

32-bit
64-bit
CF
P
P
P

Description:

Returns color part of value identifier.

Declaration:

public ImGearColorSpaceIDs Color { get; }

Value:

ImGearColorSpaceIDs Enumeration values.

See Also:

ImGearColorSpaceIDs Enumeration


ColorChannelCount Property

32-bit
64-bit
CF
P
P
P

Description:

Returns quantity of color channels in the image. Result value does not include Alpha and Extra channels.

Declaration:

public int ColorChannelCount {get;}

Value:

Non-negative value that represents quantity of color channels.


ContainsAlpha Property

32-bit
64-bit
CF
P
P
P

Description:

Specifies whether alpha or pre-multiplied alpha channel exists in image or not. It does not take into account whether color channels are pre-multiplied by alpha channel or not.

Declaration:

public bool ContainsAlpha { get; }

Value:

true if ImGearColorSpaceIDs Enumeration .A or ImGearColorSpaceIDs Enumeration .P bit specified in color space Value. Otherwise, returns false.

See Also:

ImGearColorSpaceIDs Enumeration


ContainsExtra Property

32-bit
64-bit
CF
P
P
P

Description:

Checks existence of extra (unknown) channels in the image.

Declaration:

public bool ContainExtra { get; }

Value:

Returns true, if ImGearColorSpaceIDs Enumeration .Ex bit specified in color space Value. Otherwise, returns false.

See Also:

ImGearColorSpaceIDs Enumeration


ExtraStartIndex Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets the index of the first extra channel in the color space.

Declaration:

public int ExtraStartIndex [get]

Value:

Any positive integer value.


IsPremultiplied Property

32-bit
64-bit
CF
P
P
P

Description:

Specifies whether color channels are pre-multiplied with appropriate alpha values or not.

Declaration:

public bool IsPremultiplied { get; }

Value:

true if ImGearColorSpaceIDs Enumeration .P bit is set in color space's Value.

See Also:

ImGearColorSpaceIDs Enumeration


Value Property

32-bit
64-bit
CF
P
P
P

Description:

Gives get/update access to combination of color space identifiers.

Throws ImGearException Class in case of update with invalid value.

Declaration:

public ImGearColorSpaceIDs Value { get; set }

Value:

Well-formed combination of ImGearColorSpaceIDs Enumeration values.

See Also:

ImGearColorSpaceIDs Enumeration


ImGearColorSpace Methods

The ImGearColorSpace Structure of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
GetExtraChannelCount Method
Returns quantity of extra channels.
IsWellFormed Method
Verifies whether color space combination is valid (supported).


GetExtraChannelCount Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns quantity of extra channels or 0 if color-space value doesn't contain ImGearColorSpaceIDs.Ex bit.

Declaration:

public int GetExtraChannelCount(int[] channels)

Parameters:

Name
Type
Description
channels
int[]
Total quantity of channels in the image.

Return value:

Quantity of extra channels or zero in case if color-space value doesn't contain ImGearColorSpaceIDs Enumeration .Ex bit.

See Also:

ImGearColorSpaceIDs Enumeration


IsWellFormed Method

32-bit
64-bit
CF
P
P
P

Description:

This method verifies whether color space combination is valid (supported).

Declaration:

public static bool IsWellFormed(ImageGear.Core.ImGearColorSpaceIDs value)

Parameters:

Name
Type
Description
value
ImGearColorSpaceIDs Enumeration
Color space ID.

Return value:

True, False

See Also:

ImGearColorSpaceIDs Enumeration


ImGearCommonMetadataDictRecord Structure

32-bit
64-bit
CF
P
P
P

Description:

This structure contains data for a common metadata dictionary record. This structure is used with most ImageGear supported formats.

Declaration:

public struct ImGearCommonMetadataDictRecord

Members:

Constructors
Name
Description
ImGearCommonMetadataDictRecord Constructor
Creates a new instance of ImGearCommonMetadataDictRecord structure.

Properties
Name
Description
Name Property
Tag name.
Tag Property
Tag ID.


ImGearCommonMetadataDictRecord Constructors

The ImGearCommonMetadataDictRecord Structure of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearCommonMetadataDictRecord Constructor
Creates a new instance of ImGearCommonMetadataDictRecord structure.


ImGearCommonMetadataDictRecord Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearCommonMetadataDictRecord Structure object.

Declaration:

public ImGearCommonMetadataDictRecord(int tag, string name)

Parameters:

Name
Type
Description
tag
int
Tag name.
name
string
Tag ID.

Return Value:

The new instance of ImGearCommonMetadataDictRecord Structure.

See Also:

ImGearCommonMetadataDictRecord Structure


ImGearCommonMetadataDictRecord Properties

The ImGearCommonMetadataDictRecord Structure of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
Name Property
Tag name.
Tag Property
Tag ID.


Name Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies tag name.

Declaration:

public string Name { get;  set; }

Value:

Any string.

Default value:

""


Tag Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies tag ID.

Declaration:

public int Tag { get;  set; }

Value:

Any integer number.

Default value:

0


ImGearDoublePoint Structure

32-bit
64-bit
CF
P
P
P

Description:

Stores a set of two double precision numbers that represent the point.

Declaration:

public struct ImGearDoublePoint

Members:

Constructors
Name
Description
ImGearDoublePoint Constructor
Creates the new instance of ImGearDoublePoint Structure.
ImGearDoublePoint Constructor
Creates the new instance of ImGearDoublePoint Structure.

Properties
Name
Description
X Property
Specifies X coordinate of the point.
Y Property
Specifies Y coordinate of the point.

Methods
Name
Description
Offset Method
Shifts the points coordinates by the specified dx and dy values.


ImGearDoublePoint Constructors

The ImGearDoublePoint Structure of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearDoublePoint Constructor
Creates the new instance of ImGearDoublePoint Structure.
ImGearDoublePoint Constructor
Creates the new instance of ImGearDoublePoint Structure.


ImGearDoublePoint Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearDoublePoint Structure.

Declaration:

public ImGearDoublePoint(double x, double y)

Parameters:

Name
Type
Description
x
double
X coordinate
y
double
Y coordinate

Return Value:

The new instance of ImGearDoublePoint Structure.

See Also:

ImGearDoublePoint Structure


ImGearDoublePoint Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearDoublePoint Structure.

Declaration:

public ImGearDoublePoint(ImageGear.Core.IImGearDoublePoint ipt)

Parameters:

Name
Type
Description
ipt
ImGearDoublePoint Structure
IImGearDoublePoint interface.

Return Value:

The new instance of ImGearDoublePoint Structure.

See Also:

ImGearDoublePoint Structure


ImGearDoublePoint Properties

The ImGearDoublePoint Structure of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
X Property
Specifies X coordinate of the point.
Y Property
Specifies Y coordinate of the point.


X Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies X coordinate of the point.

Declaration:

public double X { get;  set; }

Value:

Any double value.

Default value:

0


Y Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies Y coordinate of the point.

Declaration:

public double Y { get;  set; }

Value:

Any double value.

Default value:

0


ImGearDoublePoint Methods

The ImGearDoublePoint Structure of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
Offset Method
Shifts the points coordinates by the specified dx and dy values.


Offset Method

32-bit
64-bit
CF
P
P
P

Description:

This method shifts the points coordinates by the specified dx and dy values.

Declaration:

public void Offset(double dx, double dy)

Parameters:

Name
Type
Description
dx
double
x value
dy
double
y value

Return Value:

None.

See Also:

N/A


ImGearDoubleRectangle Structure

32-bit
64-bit
CF
P
P
P

Description:

Stores a set of four double precision numbers that represent the location and size of a rectangle.

Declaration:

public struct ImGearDoubleRectangle

Members:

Constructors
Name
Description
ImGearDoubleRectangle Constructor
Creates the new instance of ImGearDoubleRectangle Structure.
ImGearDoubleRectangle Constructor
Creates the new instance of ImGearDoubleRectangle Structure.
ImGearDoubleRectangle Constructor
Creates the new instance of ImGearDoubleRectangle Structure.

Properties
Name
Description
Bottom Property
Specifies the y-coordinate of the lower-right corner of the rectangle.
Height Property
Gets the height of the rectangle.
Left Property
Specifies the x-coordinate of the upper-left corner of the rectangle.
Right Property
Specifies the x-coordinate of the lower-right corner of the rectangle.
Top Property
Specifies the y-coordinate of the upper-left corner of the rectangle.
Width Property
Gets the width of the rectangle.

Methods
Name
Description
CopyFrom Method
This method copies rectangle from IImGearDoubleRectangle interface.
Empty Method
Sets all numeric properties of the rectangle to their initial values.
Intersect Method
Checks whether or not the rectangle is intersected with the specified rectangle.
IsEmpty Method
Tests whether all numeric properties of the rectangle have their initial values.
IsWellFormed Method
Checks if rectangle's width is greater than or equal to zero and if its height is greater than or equal to zero.
Offset Method
Shifts the rectangle points by the specified dx and dy values.


ImGearDoubleRectangle Constructors

The ImGearDoubleRectangle Structure of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearDoubleRectangle Constructor
Creates the new instance of ImGearDoubleRectangle Structure.
ImGearDoubleRectangle Constructor
Creates the new instance of ImGearDoubleRectangle Structure.
ImGearDoubleRectangle Constructor
Creates the new instance of ImGearDoubleRectangle Structure.


ImGearDoubleRectangle Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearDoubleRectangle Structure.

Declaration:

public ImGearDoubleRectangle(double width, double height)

Parameters:

Name
Type
Description
width
double
Width of the rectangle.
height
double
Height of the rectangle.

Return Value:

The new instance of ImGearDoubleRectangle Structure.

See Also:

ImGearDoubleRectangle Structure


ImGearDoubleRectangle Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearDoubleRectangle Structure.

Declaration:

public ImGearDoubleRectangle(double left, double top, double width, double height)

Parameters:

Name
Type
Description
left
double
X coordinate of left-top rectangular point.
top
double
Y coordinate of left-top rectangular point.
width
double
Width of the rectangle.
height
double
Height of the rectangle.

Return Value:

The new instance of ImGearDoubleRectangle Structure.

See Also:

ImGearDoubleRectangle Structure


ImGearDoubleRectangle Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearDoubleRectangle Structure.

Declaration:

public ImGearDoubleRectangle(ImageGear.Core.IImGearDoubleRectangle rc)

Parameters:

Name
Type
Description
rc
ImGearDoubleRectangle Structure
IImGearDoubleRectangle interface.

Return Value:

The new instance of ImGearDoubleRectangle Structure.

See Also:

ImGearDoubleRectangle Structure


ImGearDoubleRectangle Properties

The ImGearDoubleRectangle Structure of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
Bottom Property
Specifies the y-coordinate of the lower-right corner of the rectangle.
Height Property
Gets the height of the rectangle.
Left Property
Specifies the x-coordinate of the upper-left corner of the rectangle.
Right Property
Specifies the x-coordinate of the lower-right corner of the rectangle.
Top Property
Specifies the y-coordinate of the upper-left corner of the rectangle.
Width Property
Gets the width of the rectangle.


Bottom Property

32-bit
64-bit
CF
P
P
P

Description:

Specifies the y-coordinate of the lower-right corner of the rectangle.

Declaration:

public double Bottom [get, set]

Value:

Any double precision number.


Height Property

32-bit
64-bit
CF
P
P
P

Description:

Gets the height of the rectangle.

NOTE: The Height and Width properties assume that the rectangle is being used with the endpoint-inclusive semantics. Using endpoint-inclusive semantics, a rectangle with left, top, right, and bottom coordinates all equal to 0 is one pixel wide and one pixel tall. So, for example, the Width property is calculated as Right - Left + 1. Sometimes rectangles are used with endpoint-exclusive semantics, in which the width of the rectangle should be calculated as Right - Left. In this case, the Width and Height properties should not be used.

Declaration:

public double Height [get]

Value:

Any double precision number.


Left Property

32-bit
64-bit
CF
P
P
P

Description:

Specifies the x-coordinate of the upper-left corner of the rectangle.

Declaration:

public double Left [get, set]

Value:

Any double precision number.


Right Property

32-bit
64-bit
CF
P
P
P

Description:

Specifies the x-coordinate of the lower-right corner of the rectangle.

Declaration:

public double Right [get, set]

Value:

Any double precision number.


Top Property

32-bit
64-bit
CF
P
P
P

Description:

Specifies the y-coordinate of the upper-left corner of the rectangle.

Declaration:

public double Top [get, set]

Value:

Any double precision number.


Width Property

32-bit
64-bit
CF
P
P
P

Description:

Gets the width of the rectangle.

NOTE: The Height and Width properties assume that the rectangle is being used with the endpoint-inclusive semantics. Using endpoint-inclusive semantics, a rectangle with left, top, right, and bottom coordinates all equal to 0 is one pixel wide and one pixel tall. So, for example, the Width property is calculated as Right - Left + 1. Sometimes rectangles are used with endpoint-exclusive semantics, in which the width of the rectangle should be calculated as Right - Left. In this case, the Width and Height properties should not be used.

Declaration:

public double Width [get]

Value:

Any double precision number.


ImGearDoubleRectangle Methods

The ImGearDoubleRectangle Structure of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
CopyFrom Method
This method copies rectangle from IImGearDoubleRectangle interface.
Empty Method
Sets all numeric properties of the rectangle to their initial values.
Intersect Method
Checks whether or not the rectangle is intersected with the specified rectangle.
IsEmpty Method
Tests whether all numeric properties of the rectangle have their initial values.
IsWellFormed Method
Checks if rectangle's width is greater than or equal to zero and if its height is greater than or equal to zero.
Offset Method
Shifts the rectangle points by the specified dx and dy values.


CopyFrom Method

32-bit
64-bit
CF
P
P
P

Description:

This method copies rectangle from IImGearDoubleRectangle interface.

Declaration:

public void CopyFrom(ImageGear.Core.IImGearDoubleRectangle rc)

Parameters:

Name
Type
Description
rc
ImGearDoubleRectangle Structure
Rectangle to copy.

Return Value:

None.

See Also:

ImGearDoubleRectangle Structure


Empty Method

32-bit
64-bit
CF
P
P
P

Description:

Sets all numeric properties of the rectangle to their initial values.

Declaration:

public void Empty()

Retirn Value:

None.


Intersect Method

32-bit
64-bit
CF
P
P
P

Description:

This method checks whether or not the rectangle is intersected with the specified rectangle.

Declaration:

public bool Intersect(ImageGear.Core.IImGearDoubleRectangle rc)

Parameters:

Name
Type
Description
rc
ImGearDoubleRectangle Structure
Double rectangle.

Return Value:

true/false

See Also:

ImGearDoubleRectangle Structure


IsEmpty Method

32-bit
64-bit
CF
P
P
P

Description:

Tests whether all numeric properties of the rectangle have their initial values.

Declaration:

public bool IsEmpty()

Return value:

True, False


IsWellFormed Method

32-bit
64-bit
CF
P
P
P

Description:

This method checks if rectangle's width is greater than or equal to zero and if its height is greater than or equal to zero.

Declaration:

public bool IsWellFormed()

Return Value:

true/false

See Also:

N/A


Offset Method

32-bit
64-bit
CF
P
P
P

Description:

This method shifts the rectangle points by the specified dx and dy values.

Declaration:

public void Offset(double dx, double dy)

Parameters:

Name
Type
Description
dx
double
The dx value.
dy
double
The dy value.

Return Value:

None

See Also:

N/A


ImGearEllipse Structure

32-bit
64-bit
CF
P
P
P

Description:

Stores a set of two ImGear values that represent the location and size of an ellipse. The center of the ellipse is the center of the specified bounding rectangle.

Declaration:

public struct ImGearEllipse

Members:

Properties
Name
Description
LeftTop Property
Specifies the coordinate of the upper-left corner of the bounding rectangle.
RightBottom Property
Specifies the x-coordinate of the lower-right corner of the bounding rectangle.


ImGearEllipse Properties

The ImGearEllipse Structure of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
LeftTop Property
Specifies the coordinate of the upper-left corner of the bounding rectangle.
RightBottom Property
Specifies the x-coordinate of the lower-right corner of the bounding rectangle.


LeftTop Property

32-bit
64-bit
CF
P
P
P

Description:

Specifies the coordinate of the upper-left corner of the bounding rectangle.

Declaration:

public ImageGear.Core.ImGearPoint LeftTop [get, set]

Value:

ImGearPoint Structure

See Also:

ImGearPoint Structure


RightBottom Property

32-bit
64-bit
CF
P
P
P

Description:

Specifies the x-coordinate of the lower-right corner of the bounding rectangle.

Declaration:

public ImageGear.Core.ImGearPoint RightBottom [get, set]

Value:

ImGearPoint Structure

See Also:

ImGearPoint Structure


ImGearOrientation Structure

32-bit
64-bit
CF
P
P
P

Description:

Defines orientation of an image. It supplements image representation and thus allows you to flip and rotate an image without modification of its data (pixels).

It is useful to manipulate the orientation of scanned black-and-white images. Since ImageGear for .NET stores such images using lossless compression, this may avoid significant expansion of memory usage while operating on these images.

Some files formats support orientation natively and this allows you to save flipped or rotated images without loss of pixel data or file size enlargement using compressions.

Declaration:

public struct ImGearOrientation

Members:

Constructors
Name
Description
ImGearOrientation Constructor
Creates the new instance of ImGearOrientation Structure.

Properties
Name
Description
Value Property
Numeric representation of orientation.

Methods
Name
Description
Combine Method
Returns orientation that is super-imposition of two values.
Flip Method
Changes orientation to flip image.
Rotate Method
Changes orientation to rotate image.
SetToDefault Method
Resets orientation to default value.


ImGearOrientation Constructors

The ImGearColorProfile Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearOrientation Constructor
Creates the new instance of ImGearOrientation Structure.


ImGearOrientation Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearOrientation Structure.

Declaration:

public ImGearOrientation(ImageGear.Core.ImGearOrientationModes newValue)

Parameters:

Name
Type
Description
newValue
ImGearOrientationModes Enumeration
Orientation mode.

Return Value:

The new instance of ImGearOrientation Structure.

See Also:

ImGearOrientation Structure


ImGearOrientation Orientation

The ImGearOrientation Structure of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
Value Property
Numeric representation of orientation.


Value Property

32-bit
64-bit
CF
P
P
P

Description:

Represents orientation as numeric value.

Declaration:

public ImGearOrientationModes Value { get; set}

Value:

Any of ImGearOrientationModes Enumeration values.

See also:

ImGearOrientationModes Enumeration


ImGearColorProfile Constructors

The ImGearColorProfile Class of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
Combine Method
Returns orientation that is super-imposition of two values.
Flip Method
Changes orientation to flip image.
Rotate Method
Changes orientation to rotate image.
SetToDefault Method
Resets orientation to default value.


Combine Method

32-bit
64-bit
CF
P
P
P

Description:

Returns super-imposition of two orientations. In other words, returned value equals to sequential application of two given orientations onto one source.

Declaration:

static ImGearOrientation Combine(
    ImGearOrientation first, ImGearOrientation second)

Parameters:

Name
Type
Description
first
ImGearOrientation Structure
First of orientation values to be combined.
second
ImGearOrientation Structure
Second of orientation values to be combined.

Return value:

New ImGearOrientation Structure value.

Example:

The following steps may be used to move display orientation to page:

igPage.Orientation = ImGearOrientation.Combine(
    igPage.Orientation, igPageDisplay.Orientation);
igPageDisplay.Orientation.SetToDefault();

See Also:

ImGearOrientation Structure


Flip Method

32-bit
64-bit
CF
P
P
P

Description:

Flips current orientation.

Declaration:

public void Flip(ImGearFlipModes flipMode)

Parameters:

Name
Type
Description
flipMode
ImGearFlipModes Enumeration
Specifies how to flip orientation.

Return Value:

None

See Also:

ImGearFlipModes Enumeration


Rotate Method

32-bit
64-bit
CF
P
P
P

Description:

Rotates current orientation.

Declaration:

public void Rotate(ImGearRotationValues rotationValue)

Parameters:

Name
Type
Description
rotationValue
ImGearRotationValues Enumeration
Specifies how to rotate orientation.

Return Value:

None

See Also:

ImGearRotationValues Enumeration


SetToDefault Method

32-bit
64-bit
CF
P
P
P

Description:

Resets orientation to default (top-left) state.

Declaration:

public void SetToDefault()

Return Value:

None


ImGearPoint Structure

32-bit
64-bit
CF
P
P
P

Description:

Encapsulates a point in a 2-D coordinate system.

Declaration:

public struct ImGearPoint

Members:

Constructors
Name
Description
ImGearPoint Constructor
Creates the new instance of ImGearPoint Structure.
ImGearPoint Constructor
Creates the new instance of ImGearPoint Structure.

Properties
Name
Description
X Property
Specifies the x-coordinate of the point.
Y Property
Specifies the y-coordinate of the point.

Methods
Name
Description
Offset Method
Shifts the points coordinates by the specified dx and dy values.


ImGearPoint Constructors

The ImGearPoint Structure of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearPoint Constructor
Creates the new instance of ImGearPoint Structure.
ImGearPoint Constructor
Creates the new instance of ImGearPoint Structure.


ImGearPoint Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearPoint Structure.

Declaration:

public ImGearPoint(ImageGear.Core.IImGearPoint ipt)

Parameters:

Name
Type
Description
ipt
ImGearPoint Structure
IImGearPoint interface.

Return Value:

The new instance of ImGearPoint Structure.

See Also:

ImGearPoint Structure


ImGearPoint Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearPoint Structure.

Declaration:

public ImGearPoint(int x, int y)

Parameters:

Name
Type
Description
x
int
X coordinate.
y
int
Y coordinate.

Return Value:

The new instance of ImGearPoint Structure.

See Also:

ImGearPoint Structure


ImGearPoint Properties

The ImGearPoint Structure of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
X Property
Specifies the x-coordinate of the point.
Y Property
Specifies the y-coordinate of the point.


X Property

32-bit
64-bit
CF
P
P
P

Description:

Specifies the x-coordinate of the point.

Declaration:

public int X [get, set]

Value:

Any integer value.

See Also:

ImGearPoint Constructor


Y Property

32-bit
64-bit
CF
P
P
P

Description:

Specifies the y-coordinate of the point.

Declaration:

public int Y [get, set]

Value:

Any integer value.

See Also:

ImGearPoint Constructor


ImGearPoint Methods

The ImGearPoint Structure of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
Offset Method
Shifts the points coordinates by the specified dx and dy values.


Offset Method

32-bit
64-bit
CF
P
P
P

Description:

This method shifts the points coordinates by the specified dx and dy values.

Declaration:

public void Offset(int dx, int dy)

Parameters:

Name
Type
Description
dx
int
The dx value.
dy
int
The dy value.

Return Value:

None

See Also:

N/A


ImGearRationalInt Structure

32-bit
64-bit
CF
P
P
P

Description:

Specifies rational fraction as an indicated division of Numerator/Denominator.

Declaration:

public struct ImGearRationalInt

Members:

Constructors
Name
Description
ImGearRationalInt Constructor
Initializes a new instance of the ImGearRationalInt class.
ImGearRationalInt Constructor
Initializes a new instance of the ImGearRationalInt class.
ImGearRationalInt Constructor
Initializes a new instance of the ImGearRationalInt class

Fields
Name
Description
Denominator Field
Denominator value.
Numerator Field
Numerator value.

Methods
Name
Description
FromString Method
Creates a ImGearRationalInt from the specified string.
ToDouble Method
Converts the value of this instance to its equivalent double representation.
ToString Method
Converts the value of this instance to its equivalent string representation.


ImGearRationalInt Constructors

The ImGearRationalInt Structure of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearRationalInt Constructor
Initializes a new instance of the ImGearRationalInt class
ImGearRationalInt Constructor
Initializes a new instance of the ImGearRationalInt class
ImGearRationalInt Constructor
Initializes a new instance of the ImGearRationalInt class


ImGearRationalInt Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes a new instance of the ImGearRationalInt class.

Declaration:

public ImGearRationalInt(int numerator)

Parameters:

Name
Type
Description
numerator
int
Integer that represents the numerator of a fraction. Must be nonnegative.

Return Value:

New instance of ImGearRationalInt Structure.

See Also:

ImGearRationalInt Structure


ImGearRationalInt Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes a new instance of the ImGearRationalInt class.

Declaration:

public ImGearRationalInt(int numerator, int denominator)

Parameters:

Name
Type
Description
numerator
int
Integer that represents the numerator of a fraction. Must be nonnegative.
denominator
int
Integer that represents the denominator of a fraction. Must be nonnegative.

Return Value:

New instance of ImGearRationalInt Structure.

See Also:

ImGearRationalInt Structure


ImGearRationalInt Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes a new instance of the ImGearRationalInt class.

Declaration:

public ImGearRationalInt( )

Return Value:

New instance of ImGearRationalInt Structure.

See Also:

ImGearRationalInt Structure


ImGearRationalInt Fields

The ImGearRationalInt Structure of the ImageGear.Core Namespace has the following fields:

Fields
Name
Description
Denominator Field
Denominator value.
Numerator Field
Numerator value.


Denominator Field

32-bit
64-bit
CF
P
P
P

Description:

Determines the Denominator value.

Declaration:

public int Denominator

Value:

Any integer value.


Numerator Field

32-bit
64-bit
CF
P
P
P

Description:

Determines the Numerator value.

Declaration:

public int Numerator

Value:

Any integer value.


ImGearRationalInt Methods

The ImGearRationalInt Structure of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
FromString Method
Creates a ImGearRationalInt from the specified string.
ToDouble Method
Converts the value of this instance to its equivalent double representation.
ToString Method
Converts the value of this instance to its equivalent string representation.


FromString Method

32-bit
64-bit
CF
P
P
P

Description:

Creates a ImGearRationalInt from the specified string.

Declaration:

public static ImageGear.Core.ImGearRationalInt FromString(string parseStr)

Parameters:

Name
Type
Description
parseStr
string
The string.

Return value:

A new ImGearRationalInt Structure.

See Also:

ImGearRationalInt Structure


ToDouble Method

32-bit
64-bit
CF
P
P
P

Description:

Converts the value of this instance to its equivalent double representation.

Declaration:

public double ToDouble()

Return value:

Double value.

See Also:

ToString Method


ToString Method

32-bit
64-bit
CF
P
P
P

Description:

Converts the value of this instance to its equivalent string representation.

Declaration:

public override string ToString()

Return value:

String value.

See Also:

ToDouble Method


ImGearRationalUInt Structure

32-bit
64-bit
CF
P
P
P

Description:

Specifies rational fraction as an indicated division of Numerator/Denominator.

Declaration:

public struct ImGearRationalUInt

Members:

Constructors
Name
Description
ImGearRationalUInt Constructor
Initializes a new instance of the ImGearRationalUInt class
ImGearRationalUInt Constructor
Initializes a new instance of the ImGearRationalUInt class
ImGearRationalUInt Constructor
Initializes a new instance of the ImGearRationalUInt class

Fields
Name
Description
Denominator Field
Denominator value.
Numerator Field
Numerator value.

Methods
Name
Description
FromString Method
Creates a ImGearRationalUInt from the specified string.
ToDouble Method
Converts the value of this instance to its equivalent double representation.
ToString Method
Converts the value of this instance to its equivalent string representation.


ImGearRationalUInt Constructors

The ImGearRationalUInt Structure of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearRationalUInt Constructor
Initializes a new instance of the ImGearRationalUInt class
ImGearRationalUInt Constructor
Initializes a new instance of the ImGearRationalUInt class
ImGearRationalUInt Constructor
Initializes a new instance of the ImGearRationalUInt class


ImGearRationalUInt Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes a new instance of the ImGearRationalUInt class.

Declaration:

public ImGearRationalUInt(uint numerator)

Parameters:

Name
Type
Description
numerator
uint
UInt value that represents the numerator of a fraction. Must be nonnegative.

Return Value:

New instance of ImGearRationalUInt Structure.

See Also:

ImGearRationalUInt Structure


ImGearRationalUInt Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes a new instance of the ImGearRationalUInt class.

Declaration:

public ImGearRationalUInt(uint numerator, uint denominator)

Parameters:

Name
Type
Description
numerator
uint
Uint value that represents the numerator of a fraction. Must be nonnegative.
denominator
uint
Uint value that represents the denominator of a fraction. Must be nonnegative.

Return Value:

New instance of ImGearRationalUInt Structure.

See Also:

ImGearRationalUInt Structure


ImGearRationalUInt Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes a new instance of the ImGearRationalUInt class.

Declaration:

public ImGearRationalUInt( )

Return Value:

New instance of ImGearRationalUInt Structure.

See Also:

ImGearRationalUInt Structure


ImGearRationalUInt Fields

The ImGearRationalUInt Structure of the ImageGear.Core Namespace has the following fields:

Fields
Name
Description
Denominator Field
Denominator value.
Numerator Field
Numerator value.


Denominator Field

32-bit
64-bit
CF
P
P
P

Description:

Determines the Denominator value.

Declaration:

public uint Denominator

Value:

Any integer value.


Numerator Field

32-bit
64-bit
CF
P
P
P

Description:

Determines the Numerator value.

Declaration:

public uint Numerator

Value:

Any integer value.


ImGearRationalUInt Methods

The ImGearRationalUInt Structure of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
FromString Method
Creates a ImGearRationalUInt from the specified string.
ToDouble Method
Converts the value of this instance to its equivalent double representation.
ToString Method
Converts the value of this instance to its equivalent string representation.


FromString Method

32-bit
64-bit
CF
P
P
P

Description:

Creates a ImGearRationalUInt from the specified string.

Declaration:

public static ImageGear.Core.ImGearRationalUInt FromString(string parseStr)

Parameters:

Name
Type
Description
parseStr
string
The string.

Return value:

A new ImGearRationalUInt Structure.

See Also:

ImGearRationalUInt Structure


ImGearRect Structure

32-bit
64-bit
CF
P
P
P

Description:

Stores a set of four integer numbers that represent the location and size of the rectangle.

Declaration:

public struct ImGearRect

Members:

Properties
Name
Description
Bottom Property
Specifies the y-coordinate of the lower-right corner of the rectangle.
Left Property
Specifies the x-coordinate of the upper-left corner of the rectangle.
Right Property
Specifies the x-coordinate of the lower-right corner of the rectangle.
Top Property
Specifies the y-coordinate of the upper-left corner of the rectangle.


ImGearRect Properties

The ImGearRect Structure of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
Bottom Property
Specifies the y-coordinate of the lower-right corner of the rectangle.
Left Property
Specifies the x-coordinate of the upper-left corner of the rectangle.
Right Property
Specifies the x-coordinate of the lower-right corner of the rectangle.
Top Property
Specifies the y-coordinate of the upper-left corner of the rectangle.


Bottom Property

32-bit
64-bit
CF
P
P
P

Description:

Specifies the y-coordinate of the lower-right corner of the rectangle.

Declaration:

public int Bottom { get;  set; }

Value:

Any integer value.

See Also:

ImGearRect Structure


Left Property

32-bit
64-bit
CF
P
P
P

Description:

Specifies the x-coordinate of the upper-left corner of the rectangle.

Declaration:

public int Left { get;  set; }

Value:

Any integer value.

See Also:

ImGearRect Structure


Right Property

32-bit
64-bit
CF
P
P
P

Description:

Specifies the x-coordinate of the lower-right corner of the rectangle.

Declaration:

public int Right { get;  set; }

Value:

Any integer value.

See Also:

ImGearRect Structure


Top Property

32-bit
64-bit
CF
P
P
P

Description:

Specifies the y-coordinate of the upper-left corner of the rectangle.

Declaration:

public int Top { get;  set; }

Value:

Any integer value.

See Also:

ImGearRect Structure


ImGearRectangle Structure

32-bit
64-bit
CF
P
P
P

Description:

Stores a set of API that represent the rectangle.

Declaration:

public struct ImGearRectangle

Members:

Constructors
Name
Description
ImGearRectangle Constructor
Initializes a new instance of the ImGearRectangle class.
ImGearRectangle Constructor
Initializes a new instance of the ImGearRectangle class.
ImGearRectangle Constructor
Initializes a new instance of the ImGearRectangle class.
ImGearRectangle Constructor
Initializes a new instance of the ImGearRectangle class.

Properties
Name
Description
Bottom Property
Specifies the y-coordinate of the lower-right corner of the rectangle.
Height Property
Gets the height of the rectangle.
Left Property
Specifies the x-coordinate of the upper-left corner of the rectangle.
Right Property
Specifies the x-coordinate of the lower-right corner of the rectangle.
Top Property
Specifies the y-coordinate of the upper-left corner of the rectangle.
Width Property
Gets the width of the rectangle.

Methods
Name
Description
Contains Method
Checks if the specified point's coordinates are inside of the rectangle.
CopyFrom Method
Copies the specified ImGearRectangle object into this instance of the ImGearRectangle class.
Empty Method
Sets all numeric properties of the rectangle to their initial values.
Intersect Method
Replaces this rectangle with the intersection of itself and another rectangle.
IsEmpty Method
Tests whether all numeric properties of the rectangle have their initial values.
IsWellFormed Method
Tests whether the rectangle is valid.
Join Method
Changes the rectangle's points to contain the specified point.
Offset Method
Shifts the rectangle points by the specified dx and dy values.


ImGearRectangle Constructors

The ImGearRectangle Structure of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearRectangle Constructor
Initializes a new instance of the ImGearRectangle class.
ImGearRectangle Constructor
Initializes a new instance of the ImGearRectangle class.
ImGearRectangle Constructor
Initializes a new instance of the ImGearRectangle class.
ImGearRectangle Constructor
Initializes a new instance of the ImGearRectangle class.


ImGearRectangle Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes a new instance of the ImGearRectangle Structure.

Declaration:

public ImGearRectangle(ImageGear.Core.IImGearRectangle rc)

Parameters:

Name
Type
Description
rc
ImGearRectangle Structure
A rectangle object.

Return Value:

The new instance of ImGearRectangle Structure.

See Also:

ImGearRectangle Structure


ImGearRectangle Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes a new instance of the ImGearRectangle Structure.

Declaration:

public ImGearRectangle(int width, int height)

Parameters:

Name
Type
Description
width
int
Width of a rectangle.
height
int
Height of a rectangle.

Return Value:

The new instance of ImGearRectangle Structure.

See Also:

ImGearRectangle Structure


ImGearRectangle Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes a new instance of the ImGearRectangle Structure.

Declaration:

public ImGearRectangle(int left, int top, int width, int height)

Parameters:

Name
Type
Description
left
int
x-coordinate of the upper-left corner of a rectangle.
top
int
y-coordinate of the upper-left corner of a rectangle.
width
int
x-coordinate of the lower-right corner of a rectangle.
height
int
y-coordinate of the lower-right corner of a rectangle.

Return Value:

The new instance of ImGearRectangle Structure.

See Also:

ImGearRectangle Structure


ImGearRectangle Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes a new instance of the ImGearRectangle Structure.

Declaration:

public ImGearRectangle(ImageGear.Core.IImGearPoint pt1, ImageGear.Core.IImGearPoint pt2)

Parameters:

Name
Type
Description
pt1
ImGearPoint Structure
Used to initialize Left and Top points of the rectangle.
pt2
ImGearPoint Structure
Used to initialize Right and Bottom points of the rectangle.

Return Value:

The new instance of ImGearRectangle Structure.

See Also:

ImGearRectangle Structure


ImGearRectangle Properties

The ImGearRectangle Structure of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
Bottom Property
Specifies the y-coordinate of the lower-right corner of the rectangle.
Height Property
Gets the height of the rectangle.
Left Property
Specifies the x-coordinate of the upper-left corner of the rectangle.
Right Property
Specifies the x-coordinate of the lower-right corner of the rectangle.
Top Property
Specifies the y-coordinate of the upper-left corner of the rectangle.
Width Property
Gets the width of the rectangle.


Bottom Property

32-bit
64-bit
CF
P
P
P

Description:

Specifies the y-coordinate of the lower-right corner of the rectangle.

Declaration:

public int Bottom [get, set]

Value:

Any integer value.


Height Property

32-bit
64-bit
CF
P
P
P

Description:

Gets the height of the rectangle.

NOTE: The Height and Width properties assume that the rectangle is being used with the endpoint-inclusive semantics. Using endpoint-inclusive semantics, a rectangle with left, top, right, and bottom coordinates all equal to 0 is one pixel wide and one pixel tall. So, for example, the Width property is calculated as Right - Left + 1. Sometimes rectangles are used with endpoint-exclusive semantics, in which the width of the rectangle should be calculated as Right - Left. In this case, the Width and Height properties should not be used.

Declaration:

public int Height [get]

Value:

Any integer value.


Left Property

32-bit
64-bit
CF
P
P
P

Description:

Specifies the x-coordinate of the upper-left corner of the rectangle.

Declaration:

public int Left [get, set]

Value:

Any integer value.


Right Property

32-bit
64-bit
CF
P
P
P

Description:

Specifies the x-coordinate of the lower-right corner of the rectangle.

Declaration:

public int Right [get, set]

Value:

Any integer value.


Top Property

32-bit
64-bit
CF
P
P
P

Description:

Specifies the y-coordinate of the upper-left corner of the rectangle.

Declaration:

public int Top [get, set]

Value:

Any integer value.


Width Property

32-bit
64-bit
CF
P
P
P

Description:

Gets the width of the rectangle.

NOTE: The Height and Width properties assume that the rectangle is being used with endpoint-inclusive semantics. Using endpoint-inclusive semantics, a rectangle with left, top, right, and bottom coordinates all equal to 0 is one pixel wide and one pixel tall. So, for example, the Width property is calculated as Right - Left + 1. Sometimes rectangles are used with endpoint-exclusive semantics, in which the width of the rectangle should be calculated as Right - Left. In this case, the Width and Height properties should not be used.

Declaration:

public int Width [get]

Value:

Any integer value.


ImGearRectangle Methods

The ImGearRectangle Structure of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
Contains Method
Checks if the specified point's coordinates are inside of the rectangle.
CopyFrom Method
Copies the specified ImGearRectangle object into this instance of the ImGearRectangle class.
Empty Method
Sets all numeric properties of the rectangle to their initial values.
Intersect Method
Replaces this rectangle with the intersection of itself and another rectangle.
IsEmpty Method
Tests whether all numeric properties of the rectangle have their initial values.
IsWellFormed Method
Tests whether the rectangle is valid.
Join Method
Changes the rectangle's points to contain the specified point.
Offset Method
Shifts the rectangle points by the specified dx and dy values.


Contains Method

32-bit
64-bit
CF
P
P
P

Description:

This method checks if the specified point's coordinates are inside of the rectangle.

Declaration:

public bool Contains(ImageGear.Core.IImGearPoint pt)

Parameters:

Name
Type
Description
pt
ImGearPoint Structure
The point.

Return Value:

True/false.

See Also:

ImGearRectangle Structure

ImGearPoint Structure


CopyFrom Method

32-bit
64-bit
CF
P
P
P

Description:

Copies the specified ImGearRectangle object into this instance of the ImGearRectangle class.

Declaration:

public void CopyFrom(ImageGear.Core.IImGearRectangle rc)

Parameters:

Name
Type
Description
rc
ImGearRectangle Structure
A rectangle object.

Return Value:

None.

See Also:

ImGearRectangle Structure


Empty Method

32-bit
64-bit
CF
P
P
P

Description:

Sets all numeric properties of the rectangle to their initial values.

Declaration:

public void Empty()

Return Value:

None.

See Also:

ImGearRectangle Structure


Intersect Method

32-bit
64-bit
CF
P
P
P

Description:

Replaces this rectangle with the intersection of itself and another rectangle.

Declaration:

public bool Intersect(ImageGear.Core.IImGearRectangle rc)

Parameters:

Name
Type
Description
rc
ImGearRectangle Structure
A rectangle object.

Return value:

True, false

See Also:

ImGearRectangle Structure


IsEmpty Method

32-bit
64-bit
CF
P
P
P

Description:

Tests whether all numeric properties of the rectangle have their initial values.

Declaration:

public bool IsEmpty()

Return value:

True, false

See Also:

ImGearRectangle Structure


IsWellFormed Method

32-bit
64-bit
CF
P
P
P

Description:

Tests whether the rectangle is valid.

Declaration:

public bool IsWellFormed()

Return value:

True, false

See Also:

ImGearRectangle Structure


Join Method

32-bit
64-bit
CF
P
P
P

Description:

This method changes the rectangle's points to contain the specified point.

Declaration:

public void Join(ImageGear.Core.IImGearPoint pt)

Parameters:

Name
Type
Description
pt
ImGearPoint Structure
The point.

Return value:

None

See Also:

ImGearRectangle Structure

ImGearPoint Structure


Offset Method

32-bit
64-bit
CF
P
P
P

Description:

This method shifts the rectangle points by the specified dx and dy values.

Declaration:

public void Offset(int dx, int dy)

Parameters:

Name
Type
Description
dx
int
The dx value.
dy
int
The dy value.

Return value:

None

See Also:

ImGearRectangle Structure


ImGearRoundedRectangle Structure

32-bit
64-bit
CF
P
P
P

Description:

This structure represents a rounded rectangle.

Declaration:

public struct ImGearRoundedRectangle : IImGearRoundedRectangle

Members:

Properties
Name
Description
LeftTop Property
Specifies coordinates of the upper-left corner of the rectangle.
RightBottom Property
Specifies coordinates of the right-bottom corner of the rectangle.
Radius Property
Specifies the radius for the rounded edges.


ImGearRoundedRectangle Properties

The ImGearRoundedRectangle Structure of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
LeftTop Property
Specifies coordinates of the upper-left corner of the rectangle.
RightBottom Property
Specifies coordinates of the right-bottom corner of the rectangle.
Radius Property
Specifies the radius for the rounded edges.


LeftTop Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies coordinates of the upper-left corner of the rectangle.

Declaration:

public ImGearPoint LeftTop {get; set;}

Value:

ImGearPoint Structure


RightBottom Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies coordinates of the right-bottom corner of the rectangle.

Declaration:

public ImGearPoint RightBottom {get; set;}

Value:

ImGearPoint Structure


Radius Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the radius for the rounded edges.

Declaration:

public int Radius {get; set;}

Value:

int value


ImGearResolution Structure

32-bit
64-bit
CF
P
P
P

Description:

Specifies image resolution attributes.

Declaration:

public struct ImGearResolution

Members:

Constructors
Name
Description
ImGearResolution Constructor
Creates new instance of ImGearResolution object.
ImGearResolution Constructor
Creates new instance of ImGearResolution object.

Properties
Name
Description
Units Property
Provides resolution units.
XDenominator Property
Provides the denominator of the X component of the resolution.
XNumerator Property
Provides the numerator of the X component of the resolution.
YDenominator Property
Provides the denominator of the Y component of the resolution.
YNumerator Property
Provides the numerator of the Y component of the resolution.

Methods
Name
Description
ConvertUnits Method
Converts the resolution data into the new units.


ImGearResolution Constructors

The ImGearResolution Structure of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearResolution Constructor
Creates new instance of ImGearResolution object.
ImGearResolution Constructor
Creates new instance of ImGearResolution object.


ImGearResolution Constructor

32-bit
64-bit
CF
P
P
P

Description:

Creates new instance of ImGearResolution Structure.

Declaration:

public ImGearResolution(ImageGear.Core.ImGearResolutionUnits units)

Parameters:

Name
Type
Description
units
ImGearResolutionUnits Enumeration
Resolution units.

Return Value:

The new instance of ImGearResolution Structure.

See Also:

ImGearResolution Structure

ImGearResolutionUnits Enumeration


ImGearResolution Constructor

32-bit
64-bit
CF
P
P
P

Description:

Creates new instance of ImGearResolution Structure.

Declaration:

public ImGearResolution(int xNumerator, int xDenumerator, int yNumerator, int
yDenumerator, ImageGear.Core.ImGearResolutionUnits units)

Parameters:

Name
Type
Description
xNumerator
int
Numerator of the X component of the resolution.
xDenumerator
int
Denominator of the X component of the resolution.
yNumerator
int
Numerator of the Y component of the resolution.
yDenumerator
int
Denominator of the Y component of the resolution.
units
ImGearResolutionUnits Enumeration
Resolution units.

Return Value:

The new instance of ImGearResolution Structure.

See Also:

ImGearResolution Structure

ImGearResolutionUnits Enumeration


ImGearResolution Properties

The ImGearResolution Structure of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
Units Property
Provides resolution units.
XDenominator Property
Provides the denominator of the X component of the resolution.
XNumerator Property
Provides the numerator of the X component of the resolution.
YDenominator Property
Provides the denominator of the Y component of the resolution.
YNumerator Property
Provides the numerator of the Y component of the resolution.


Units Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides resolution data units.

Declaration:

public ImageGear.Core.ImGearResolutionUnits Units [get, set]

Value:

ImGearResolutionUnits Enumeration values.

See Also:

ImGearResolution Constructor

ImGearResolution Constructor

ImGearResolutionUnits Enumeration


XDenominator Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides the denominator of the X component of the resolution.

Declaration:

public int XDenominator [get, set]

Value:

Any integer value.

See Also:

ImGearResolution Constructor


XNumerator Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides the numerator of the X component of the resolution.

Declaration:

public int XNumerator [get, set]

Value:

Any integer value.

See Also:

ImGearResolution Constructor


YDenominator Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides the denominator of the Y component of the resolution.

Declaration:

public int YDenominator [get, set]

Value:

Any integer value.

See Also:

ImGearResolution Constructor


YNumerator Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides the numerator of the Y component of the resolution.

Declaration:

public int YNumerator [get, set]

Value:

Any integer value.

See Also:

ImGearResolution Constructor


ImGearResolution Methods

The ImGearResolution Structure of the ImageGear.Core Namespace has the following methods:

Methods
Name
Description
ConvertUnits Method
Converts the resolution data into the new units.


ConvertUnits Method

32-bit
64-bit
CF
P
P
P

Description:

This method converts the resolution data into new units.

Declaration:

public void ConvertUnits(ImageGear.Core.ImGearResolutionUnits newUnits)

Parameters:

Name
Type
Description
newUnits
ImGearResolutionUnits Enumeration
New resolution data units.

Return Value:

None

See Also:

ImGearResolutionUnits Enumeration


ImGearRGBQuad Structure

32-bit
64-bit
CF
P
P
P

Description:

Specifies RGB value.

Declaration:

public struct ImGearRGBQuad

Members:

Constructors
Name
Description
ImGearRGBQuad Constructor
Creates the new instance of ImGearRGBQuad object.
ImGearRGBQuad Constructor
Creates the new instance of ImGearRGBQuad object.
ImGearRGBQuad Constructor
Creates the new instance of ImGearRGBQuad object.
ImGearRGBQuad Constructor
Creates the new instance of ImGearRGBQuad object.

Properties
Name
Description
Blue Property
Blue value.
Green Property
Green value.
Red Property
Red value.

Methods
Name
Description
IsGray Method
Checks whether or not the RGB value is grayscale value, i.e., Red=Green=Blue
IsGray Method
Checks whether or not the RGB value is grayscale value equal to value, i.e., Red=Green=Blue=Value.


ImGearRGBQuad Constructors

The ImGearRGBQuad Structure of the ImageGear.Core Namespace has the following constructors:

Constructors
Name
Description
ImGearRGBQuad Constructor
Creates the new instance of ImGearRGBQuad object.
ImGearRGBQuad Constructor
Creates the new instance of ImGearRGBQuad object.
ImGearRGBQuad Constructor
Creates the new instance of ImGearRGBQuad object.
ImGearRGBQuad Constructor
Creates the new instance of ImGearRGBQuad object.


ImGearRGBQuad Constructor

32-bit
64-bit
CF
P
P
P

Description:

Creates the new instance of ImGearRGBQuad Structure.

Declaration:

public ImGearRGBQuad(int gray)

Parameters:

Name
Type
Description
gray
int
Gray color value.

Return Value:

The new instance of ImGearRGBQuad Structure.

See Also:

ImGearRGBQuad Structure


ImGearRGBQuad Constructor

32-bit
64-bit
CF
P
P
P

Description:

Creates the new instance of ImGearRGBQuad Structure.

Declaration:

public ImGearRGBQuad(int red, int green, int blue)

Parameters:

Name
Type
Description
red
int
Red color value.
green
int
Green color value.
blue
int
Blue color value.

Return Value:

The new instance of ImGearRGBQuad Structure.

See Also:

ImGearRGBQuad Structure


ImGearRGBQuad Constructor

32-bit
64-bit
CF
P
P
P

Description:

Creates the new instance of ImGearRGBQuad Structure.

Declaration:

public ImGearRGBQuad(int red, int greed, int blue, int reserved)

Parameters:

Name
Type
Description
red
int
Red color value.
green
int
Green color value.
blue
int
Blue color value.
reserved
int
Reserved.

Return Value:

The new instance of ImGearRGBQuad Structure.

See Also:

ImGearRGBQuad Structure


ImGearRGBQuad Constructor

32-bit
64-bit
CF
P
P
P

Description:

Creates the new instance of ImGearRGBQuad Structure.

Declaration:

public ImGearRGBQuad(ImageGear.Core.IImGearRGBQuad iRGB)

Parameters:

Name
Type
Description
iRGB
ImGearRGBQuad Structure
IImGearRGBQuad interface.

Return Value:

The new instance of ImGearRGBQuad Structure.

See Also:

ImGearRGBQuad Structure


ImGearRGBQuad Properties

The ImGearRGBQuad Structure of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
Blue Property
Blue value.
Green Property
Green value.
Red Property
Red value.


Blue Property

32-bit
64-bit
CF
P
P
P

Description:

Provides Blue color value.

Declaration:

public byte Blue [get, set]

Value:

0 - 255

See Also:

ImGearRGBQuad Structure


Green Property

32-bit
64-bit
CF
P
P
P

Description:

Provides Green color value.

Declaration:

public byte Green [get, set]

Value:

0 - 255

See Also:

ImGearRGBQuad Structure


Red Property

32-bit
64-bit
CF
P
P
P

Description:

Provides Red color value.

Declaration:

public byte Red [get, set]

Value:

0 - 255

See Also:

ImGearRGBQuad Structure


ImGearRGBQuad Methods

The ImGearRGBQuad Structure of the ImageGear.Core Namespace has the following method:

Methods
Name
Description
IsGray Method
Checks whether or not the RGB value is grayscale value, i.e., Red=Green=Blue.
IsGray Method
Checks whether or not the RGB value is grayscale value equal to value, i.e., Red=Green=Blue=Value.


IsGray Method

32-bit
64-bit
CF
P
P
P

Description:

Checks whether or not the RGB value is grayscale value, i.e., Red=Green=Blue.

Declaration:

public bool IsGray()

Return Value:

True, false.

See Also:

ImGearRGBQuad Structure


IsGray Method

32-bit
64-bit
CF
P
P
P

Description:

Checks whether or not the RGB value is grayscale value equal to value, i.e., Red=Green=Blue=value.

Declaration:

public bool IsGray(byte value)

Parameters:

Name
Type
Description
value
byte
Gray color value.

Return Value:

True, false.

See Also:

ImGearRGBQuad Structure

ImGearRGBQuad Constructor


ImGearSize Structure

32-bit
64-bit
CF
P
P
P

Description:

Implements a relative coordinate or position.

Declaration:

public struct ImGearSize

Members:

Properties
Name
Description
cX Property
Specifies the rectangle's width.
cY Property
Specifies the rectangle's height.


ImGearSize Properties

The ImGearSize Structure of the ImageGear.Core Namespace has the following properties:

Properties
Name
Description
cX Property
Specifies the rectangle's width.
cY Property
Specifies the rectangle's height.


cX Property

32-bit
64-bit
CF
P
P
P

Description:

Specifies the rectangle's width.

Declaration:

public int cX [get, set]

Value:

Any integer value.


cY Property

32-bit
64-bit
CF
P
P
P

Description:

Specifies the rectangle's height.

Declaration:

public int cY [get, set]

Value:

Any integer value.


ImageGear.Core Namespace Delegates

The ImageGear.Core Namespace has the following delegate members:

Delegates:
Name
Description
ImGearAddWarning Delegate
Specifies the processing warning routine to be called when the warning is added.


ImGearAddWarning Delegate

32-bit
64-bit
CF
P
P
P

Description:

This delegate specifies the processing warning routine to be called when the warning is added.

Declaration:

public delegate void ImGearAddWarning(ImageGear.Core.ImGearWarning warning)

Parameters:

Name
Type
Description
warning
ImGearWarning Class
ImGearWarning class.

Return Value:

None.

See Also:

ImGearWarning Class


ImageGear.Core Namespace Enumerations

The ImageGear.Core Namespace has the following enumeration members:

Enumerations:
Name
Description
ImGearChannelGroups Enumeration
Specifies alpha channels.
ImGearColorSpaceIDs Enumeration
Specifies ImageGear color space IDs.
ImGearErrorCodes Enumeration
Specifies ImageGear error codes.
ImGearExtraChannelType Enumeration
Specifies all the supported types of extra channels.
ImGearFlipModes Enumeration
Specifies flip modes.
ImGearLicenseType Enumeration
Specifies the type of ImageGear license.
ImGearMaskChannelModes Enumeration
Specifies whether the color indicates masked or selected area.
ImGearOrientationModes Enumeration
Specifies orientation modes.
ImGearRenderingIntents Enumeration
Controls how colors are transformed during color space conversion using color profiles.
ImGearResolutionUnits Enumeration
Specifies the measurements of resolution units.
ImGearRotationValues Enumeration
Specifies the value of the rotation angle.
ImGearSpotColorVendorID Enumeration
Specifies all supported vendor IDs.


ImGearChannelGroups Enumeration

32-bit
64-bit
CF
P
P
P

Description:

Specifies alpha channels.

Declaration:

public enum ImGearChannelGroups : System.Enum

Values:

Name
Value
Description
ALL
5
All channels
ALPHA
1
Alpha channels
ALPHA_EXTRA
4
Extra alpha channels
COLOR
0
Color channels
COLOR_ALPHA
3
Color alpha channels
EXTRA
2
Extra channels


ImGearColorSpaceIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

Specifies color space IDs. All colorspaces are supported for internal image storage.

Declaration:

public enum ImGearColorSpaceIDs

Values:

Name
Value
Description
A
256
Image has alpha channel; color channels are not pre-multiplied by Alpha channel
CMY
8
Image has CMY channels
CMYK
9
Image has CMYK channels
CMYKEx
1033
CMYK + Extra channel
ColorMask
255
Bitmask used to access color space description for color channels only (e.g., RGBEx & ColorMask == RGB, GyA & ColorMask == Gy)
Ex
1024
Extra channel
Gy
2
Grayscale
GyA
258
Grayscale + Alpha channel
GyPA
514
Grayscale + premultiplied alpha channel
GyPAEx
1538
Grayscale + premultiplied alpha channel + extra channel
HLS
5
HLS
I
3
Indexed RGB. Has RGBQuad palette and one channel. Channel depth is <= 8; the number of palette entries is 2^<channel depth>. No other color space can have non-null palette.
IHS
4
IHS
LAB
6
LAB
NONE
0
P
512
Premultiplied channel
RGB
1
RGB
RGBA
257
RGB + alpha channel
RGBAEx
1281
RGB + alpha + extra channel
RGBEx
1025
RGB + extra channel
RGBPA
513
RGB + premultiplied alpha channel
RGBPAEx
1537
RGB + premultiplied alpha channel + extra channel
Unknown
1024
Only "Extra" channels are present (1 or more channels)
YCbCr
10
Standard color space for JFIF
YIQ
7
YIQ
YUV
11
YUV


ImGearErrorCodes Enumeration

32-bit
64-bit
CF
P
P
P

Description:

Specifies error codes.

Declaration:

public enum ImGearErrorCodes

Values:

Name
Value
Description
CANT_DETECT_FORMAT
CANT_DETECT_FORMAT
Cannot detect format.
CANT_FIND_FORMAT
CANT_FIND_FORMAT
Cannot find format.
CANT_READ_PIXELS
CANT_READ_PIXELS
Cannot read image pixels.
CANT_SAVE_FORMAT
CANT_SAVE_FORMAT
Cannot save format.
CYCLIC_REFERENCE
CYCLIC_REFERENCE
Cyclic reference.
FORMAT_ALREADY_ADDED
FORMAT_ALREADY_ADDED
The specified format is already in the collection.
INTERNAL_FAILURE
INTERNAL_FAILURE
Internal failure.
INVALID_BITCOUNT_FOR_FORMAT
INVALID_BITCOUNT_FOR_FORMAT
Invalid bit depth for the specified format.
INVALID_COMPRESSION
INVALID_COMPRESSION
Invalid compression.
INVALID_HEADER_FOR_FORMAT
INVALID_HEADER_FOR_FORMAT
Invalid header for the format.
INVALID_IMAGE_DIMENSIONS
INVALID_IMAGE_DIMENSIONS
Invalid image dimensions.
INVALID_IMAGE_TILE_DIMENSIONS
INVALID_IMAGE_TILE_DIMENSIONS
Invalid image tile dimensions.
INVALID_TYPE
INVALID_TYPE
Invalid type.
IP_FUNCTION_NOT_APPLICABLE_TO_DIB
IP_FUNCTION_NOT_APPLICABLE_TO_DIB
The IP method is not supported for the specified DIB.
JPEG2K_FAILURE
JPEG2K_FAILURE
The JPEG 2000 failure.
NOT_IMPLEMENTED_YET
NOT_IMPLEMENTED_YET
The API is not yet implemented.
NOT_LICENSED
NOT_LICENSED
The product of feature are not licensed.
OWNER_ALREADY_ASSIGNED
OWNER_ALREADY_ASSIGNED
Owned has already been assigned.
OWNER_NOT_ASSIGNED
OWNER_NOT_ASSIGNED
Owned has not been assigned.
PAGE_NOT_PRESENT
PAGE_NOT_PRESENT
The specified page is not present.
PARAMETER_HAS_INVALID_VALUE
PARAMETER_HAS_INVALID_VALUE
The parameter has an invalid value.
PDF_FAILURE
PDF_FAILURE
The PDF failure.
TILE_NOT_PRESENT
TILE_NOT_PRESENT
The specified tile is not present.
TWAIN_FAILURE
TWAIN_FAILURE
The TWAIN failure.
TWAIN_OPERATION_CANCELED
TWAIN_OPERATION_CANCELED
The TWAIN operation is canceled.
VALUES_ARE_INCOMPATIBLE
VALUES_ARE_INCOMPATIBLE
The specified values are incompatible.
WRONG_METADATA_FORMAT
WRONG_METADATA_FORMAT
Wrong metadata format.


ImGearExtraChannelType Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies all the supported types of extra channels.

Declaration:

public enum ImGearExtraChannelType

Values:

Name
Value
Description
Mask
1
Mask channel
Spot
2
Spot channel
Unknown
0
Unknown channel


ImGearFlipModes Enumeration

32-bit
64-bit
CF
P
P
P

Description:

Specifies ImageGear flip modes.

Declaration:

public enum ImGearFlipModes

Values:

Name
Value
Description
HORIZONTAL
0
Flip around horizontal axis
VERTICAL
1
Flip around vertical axis


ImGearLicenseType Enumeration

32-bit
64-bit
CF
P
P
P

Description:

Specifies ImageGear license types.

Declaration:

public enum ImGearLicenseType

Values:

Name
Value
Description
DEPLOYMENT
3
Deployment license
DEVELOPMENT
2
Development license
EVALUATION
1
Evaluation license


ImGearMaskChannelModes Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies whether the color indicates masked or selected area.

Declaration:

public enum ImGearMaskChannelModes

Values:

Name
Value
Description
ColorIndicatesMaskedArea
1
Specifies that color indicates masked area.
ColorIndicatesSelectedArea
0
Specifies that color indicates selected area.


ImGearOrientationModes Enumeration

32-bit
64-bit
CF
P
P
P

Description:

Specifies ImageGear orientation modes.

Declaration:

public enum ImGearOrientationModes

Values:

Name
Value
Description
BOTTOM_LEFT
4
Bottom to the Left orientation
BOTTOM_RIGHT
3
Bottom to the Right orientation
LEFT_BOTTOM
8
Left to the Bottom orientation
LEFT_TOP
5
Left to the Top orientation
RIGHT_BOTTOM
7
Right to the Bottom orientation
RIGHT_TOP
6
Right to the Top orientation
TOP_LEFT
1
Top to the Left orientation
TOP_RIGHT
2
Top to the Right orientation


ImGearRenderingIntents Enumeration

32-bit
64-bit
CF
P
P
P

Description:

Rendering intent controls how colors are transformed during color space conversion using color profiles.

Declaration:

public enum ImGearRenderingIntents

Values:

Name
Value
Description
PERCEPTUAL
0
Perceptual intent, also known as Picture intent, is the most commonly used intent. It scales all colors in the gamut to fit the new color space, preserving gray balance at the possible expense of colorimetric accuracy.
RELATIVE_COLORIMETRIC
1
Relative colorimetric intent, also known as Proof intent, changes only the colors that cannot be represented in the new gamut. They are changed to the nearest colors in the new gamut. The white point is not preserved.
SATURATION
2
Saturation intent, also known as Graphic intent, preserves the saturation of the image at the possible expense of hue and lightness. It is intended for graphics such as charts.
ABSOLUTE_COLORIMETRIC
3
Absolute colorimetric, also known as Match intent, changes only the colors that cannot be represented in the new gamut. They are changed to the nearest colors in the new gamut. The white point is preserved.


ImGearResolutionUnits Enumeration

32-bit
64-bit
CF
P
P
P

Description:

Specifies the measurements of image resolution units.

Declaration:

public enum ImGearResolutionUnits

Values:

Name
Value
Description
CENTIMETERS
3
Centimeters
INCHES
2
Inches
METERS
1
Meters
NO_ABS
0
No abs
TEN_CENTIMETERS
5
Ten centimeters
TEN_INCHES
4
Ten inches


ImGearRotationValues Enumeration

32-bit
64-bit
CF
P
P
P

Description:

Specifies the angles of image rotation.

Declaration:

public enum ImGearRotationValues

Values:

Name
Value
Description
VALUE_0
0
No rotation
VALUE_180
2
Rotation on 180 grades
VALUE_270
3
Rotation on 270 grades
VALUE_90
1
Rotation on 90 grades


ImGearSpotColorVendorID Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies all supported vendor IDs.

Declaration:

public enum ImGearSpotColorVendorID

Values:

Name
Value
Description
ANPA
3000
ANPA vendor ID
DIC
3012
DIC vendor ID
DIC
11
DIC vendor ID
Focoltone
3001
Focoltone vendor ID
Focoltone
4
Focoltone vendor ID
HKS
10
HKS vendor ID
HKSE
3008
HKSE vendor ID
HKSEProcess
3024
HKSEProcess vendor ID
HKSK
3009
HKSK vendor ID
HKSKProcess
3025
HKSKProcess vendor ID
HKSN
3010
HKSN vendor ID
HKSNProcess
3026
HKSNProcess vendor ID
HKSZ
3011
HKSZ vendor ID
HKSZProcess
3027
HKSZProcess vendor ID
Pantone
3
Pantone vendor ID
PantoneCoated
3002
PantoneCoated vendor ID
PantoneMatte
3013
PantoneMatte vendor ID
PantoneMetallic
3022
PantoneMetallic vendor ID
PantonePastelCoated
3020
PantonePastelCoated vendor ID
PantonePastelUncoated
3021
PantonePastelUncoated vendor ID
PantoneProcess
3003
PantoneProcess vendor ID
PantoneProSlim
3004
PantoneProSlim vendor
PantoneProSlimEuro
3028
PantoneProSlimEuro vendor ID
PantoneProcessUncoated
3029
PantoneProcessUncoated vendor ID
PantoneUncoated
3005
PantoneUncoated vendor ID
Toyo
3006
Toyo vendor ID
Toyo
6
Toyo vendor ID
Trumatch
3007
Trumatch vendor ID
Trumatch
5
Trumatch vendor ID
UserColorBook
3100
Vendor ID reserved for user color books


ImageGear.ART Namespace

ImageGear.ART Namespace

32-bit
64-bit
CF
P
P

Description:

The ImageGear ART namespace allows you to add redlining and annotation capabilities to any application built with ImageGear. If you have an application that can read, display, and print images, with ImageGear ART namespace enabled you can add marking capabilities, such as lines, arrows, highlighting, and sticky notes to document images, and use them as though you were working on printed sheets of paper. This chapter provides the ART namespace API reference.

Declaration:

namespace ImageGear.ART

Members:

Classes:
Name
Description
ImGearART Class
ART component super-class that provides general functionality and access to the global properties and methods.
ImGearARTArrow Class
Legacy ART Arrow mark.
ImGearARTAudio Class
ART Audio mark.
ImGearARTBorder Class
Mark's border attributes.
ImGearARTButton Class
ART Button mark.
ImGearARTCallout Class
Specifies text mark's callout attributes.
ImGearARTCurve Class
ART Curve mark.
ImGearARTEllipse Class
ART Ellipse mark.
ImGearARTEncryption Class
ART Encryption mark.
ImGearARTFilledEllipse Class
Legacy ART Filled Ellipse mark.
ImGearARTFilledPolygon Class
Legacy ART Filled Polygon mark.
ImGearARTFilledRectangle Class
Legacy ART Filled Rectangle mark.
ImGearARTFreeLine Class
Legacy ART Freehand Line mark.
ImGearARTGroup Class
Collection of ART marks united into a group.
ImGearARTGroupArray Class
Array of ART groups.
ImGearARTGroupEnumerator Class
Used for ImGearARTGroup to iterate through the collection of marks by using foreach statement.
ImGearARTHighlighter Class
Legacy ART Highlighter.
ImGearARTHollowEllipse Class
Legacy ART Hollow Ellipse mark.
ImGearARTHollowPolygon Class
Legacy ART Hollow Polygon mark.
ImGearARTHollowRectangle Class
Legacy ART Hollow Rectangle mark.
ImGearARTHotSpot Class
ART Hot Spot mark.
ImGearARTImage Class
ART Image mark.
ImGearARTImageEmb Class
Legacy ART Embedded Image mark.
ImGearARTImageRef Class
Legacy ART Image Reference mark.
ImGearARTLine Class
ART Line mark.
ImGearARTLineMarkStat Class
This class represents specific statistics information about the line ART marks.
ImGearARTMark Class
Abstract ART mark class that provides general properties and methods for all mark types.
ImGearARTMarkStat Class
This abstract class is a base for a set of classes intented to represent some specific statistics information about ART marks.
ImGearARTNote Class
Legacy ART Attach-A-Note mark.
ImGearARTPage Class
Collection of ART groups. This class provides methods and properties for accessing to individual marks on the page as well as to group of marks.
ImGearARTPageEnumerator Class
Page enumerator class is used for ImGearARTPage to iterate through the collection of marks by using foreach statement.
ImGearARTPin Class
Text mark's pin icon.
ImGearARTPinUpText Class
Legacy ART Pin-Up-Text mark.
ImGearARTPoint Class
ART Point mark.
ImGearARTPointMarkStat Class
This class represents specific statistics information about the point ART marks.
ImGearARTPolygon Class
ART Polygon mark.
ImGearARTPolyline Class
ART Polyline mark.
ImGearARTProtractor Class
ART Protractor mark.
ImGearARTRectangle Class
ART Rectangle mark.
ImGearARTRedaction Class
Legacy ART Redaction mark.
ImGearARTRichText Class
ART Rich Text mark.
ImGearARTRichTextControl Class
ART Rich Text control is a class based on System.Windows.Forms.RichTextBox suitable for ART processing and drawing.
ImGearARTRuler Class
ART Ruler mark
ImGearARTSelection Class
Abstract class that defines internal interface for mark selection.
ImGearARTShapeMarkStat Class
This class represents specific statistics information about the shaped ART marks.
ImGearARTText Class
ART Text mark.
ImGearARTTextCallout Class
Legacy ART "Callout Text" mark.
ImGearARTTextFromFile Class
Legacy ART Text From File mark.
ImGearARTTextStamp Class
Legacy ART Text Stamp mark.
ImGearARTTypedText Class
Legacy ART Typed Text mark.

Interfaces:
Name
Description
IImGearARTMarkIDEnumerator Interface
Mark ID enumerator interface is used for ImGearARTPage Class and ImGearARTGroup Class to iterate through the collection of marks by using foreach statement.
IImGearARTMarkIDEnumerable Interface
Mark ID enumerable interface is used for ImGearARTPage Class and ImGearARTGroup Class to iterate through the collection of marks by using foreach statement.

Enumerations:
Name
Description
ImGearARTAccess Enumeration
Specifies group access.
ImGearARTBurnInOptions Enumeration
Specifies BurnIn options.
ImGearARTButtonState Enumeration
Specifies Button mark state.
ImGearARTCalloutType Enumeration
Specifies ART Callout types.
ImGearARTCoordinatesType Enumeration
Specifies mark's coordinate types.
ImGearARTLineHeadType Enumeration
Specifies line's head types.
ImGearARTMarkHitTest Enumeration
Specifies HitTest results.
ImGearARTMarkType Enumeration
Specifies mark types.
ImGearARTPenStyle Enumeration
Specifies pen styles.
ImGearARTPinAlignment Enumeration
Specifies pin alignment modes.
ImGearARTSaveType Enumeration
Specifies ART save types.
ImGearARTTextType Enumeration
Specifies Text mark types.

See Also:

Using ImageGear.ART Namespace


ImageGear.ART Namespace Classes

The ImageGear.ART Namespace has the following class members:

Classes:
Name
Description
ImGearART Class
ART component super-class that provides general functionality and access to the global properties and methods.
ImGearARTArrow Class
Legacy ART Arrow mark.
ImGearARTAudio Class
ART Audio mark.
ImGearARTBorder Class
Mark's border attributes.
ImGearARTButton Class
ART Button mark.
ImGearARTCallout Class
Specifies text mark's callout attributes.
ImGearARTCurve Class
ART Curve mark.
ImGearARTEllipse Class
ART Ellipse mark.
ImGearARTEncryption Class
ART Encryption mark.
ImGearARTFilledEllipse Class
Legacy ART Filled Ellipse mark.
ImGearARTFilledPolygon Class
Legacy ART Filled Polygon mark.
ImGearARTFilledRectangle Class
Legacy ART Filled Rectangle mark.
ImGearARTFreeLine Class
Legacy ART Freehand Line mark.
ImGearARTGroup Class
Collection of ART marks united into a group.
ImGearARTGroupArray Class
Array of ART groups.
ImGearARTGroupEnumerator Class
Used for ImGearARTGroup to iterate through the collection of marks by using foreach statement.
ImGearARTHighlighter Class
Legacy ART Highlighter.
ImGearARTHollowEllipse Class
Legacy ART Hollow Ellipse mark.
ImGearARTHollowPolygon Class
Legacy ART Hollow Polygon mark.
ImGearARTHollowRectangle Class
Legacy ART Hollow Rectangle mark.
ImGearARTHotSpot Class
ART Hot Spot mark.
ImGearARTImage Class
ART Image mark.
ImGearARTImageEmb Class
Legacy ART Embedded Image mark.
ImGearARTImageRef Class
Legacy ART Image Reference mark.
ImGearARTLine Class
ART Line mark.
ImGearARTLineMarkStat Class
This class represents specific statistics information about the line ART marks.
ImGearARTMark Class
Abstract ART mark class that provides general properties and methods for all mark types.
ImGearARTMarkStat Class
This abstract class is a base for a set of classes intented to represent some specific statistics information about ART marks.
ImGearARTNote Class
Legacy ART Attach-A-Note mark.
ImGearARTPage Class
Collection of ART groups. This class provides methods and properties for accessing to individual marks on the page as well as to group of marks.
ImGearARTPageEnumerator Class
Page enumerator class is used for ImGearARTPage to iterate through the collection of marks by using foreach statement.
ImGearARTPin Class
Text mark's pin icon.
ImGearARTPinUpText Class
Legacy ART Pin-Up-Text mark.
ImGearARTPoint Class
ART Point mark.
ImGearARTPointMarkStat Class
This class represents specific statistics information about the point ART marks.
ImGearARTPolygon Class
ART Polygon mark.
ImGearARTPolyline Class
ART Polyline mark.
ImGearARTProtractor Class
ART Protractor mark.
ImGearARTRectangle Class
ART Rectangle mark.
ImGearARTRedaction Class
Legacy ART Redaction mark.
ImGearARTRichText Class
ART Rich Text mark.
ImGearARTRichTextControl Class
ART Rich Text control is a class based on System.Windows.Forms.RichTextBox suitable for ART processing and drawing.
ImGearARTRuler Class
ART Ruler mark
ImGearARTSelection Class
Abstract class that defines internal interface for mark selection.
ImGearARTShapeMarkStat Class
This class represents specific statistics information about the shaped ART marks.
ImGearARTText Class
ART Text mark.
ImGearARTTextCallout Class
Legacy ART "Callout Text" mark.
ImGearARTTextFromFile Class
Legacy ART Text From File mark.
ImGearARTTextStamp Class
Legacy ART Text Stamp mark.
ImGearARTTypedText Class
Legacy ART Typed Text mark.


ImGearART Class

32-bit
64-bit
CF
P
P

Description:

ART component super-class that provides general functionality and access to the global properties and methods.

Declaration:

public class ImGearART

Members:

Properties
Name
Description
DisablePPM Property
Control option to enable/disable PPM in font size calculations.
LegacyMode Property
Control option to enable/disable Legacy Mode in font size calculations.

Methods
Name
Description
BurnIn Method
Merges marks permanently into ImGearPage Class.
LoadPage Method
Loads ART marks from ImGearPage Class.
LoadPage Method
Loads ART marks from a stream.
SavePage Method
Saves ART marks into ImGearPage Class.
SavePage Method
Saves ART marks into a stream.

Sample Code:

C#
ImGearPage igPage;
// Load an image containing embedded ART 2.0 annotations into a ImGearPage object
using (FileStream localFile = new FileStream("test1_art.tif", FileMode.Open))
    igPage = ImGearFileFormats.LoadPage(localFile, 0);
// Load the ImGearARTPage from the metadata in the ImGearPage.
igARTForms.Page = ImGearART.LoadPage(igPage);
// Burn the annotations into the image.
igPage = ImGearART.BurnIn(igPage, igARTForms.Page, ImGearARTBurnInOptions.ALL, null);
imGearPageView1.Page = igPage;
// Clear the annotations from the art page.
igARTForms.Page.RemoveMarks();
// Update the Display with the new ARTPage.
if (igARTForms.Page != null)
    imGearPageView1.Display.ARTPage = igARTForms.Page;

VB .NET
Dim igPage As ImGearPage
' Load an image containing embedded ART 2.0 annotations into a ImGearPage object
Using localFile As New FileStream("test1_art.tif", FileMode.Open)
    igPage = ImGearFileFormats.LoadPage(localFile, 0)
End Using
' Load the ImGearARTPage from the metadata in the ImGearPage.
igARTForms.Page = ImGearART.LoadPage(igPage)
' Burn the annotations into the image.
igPage = ImGearART.BurnIn(igPage, igARTForms.Page, ImGearARTBurnInOptions.ALL, Nothing)
ImGearPageView1.Page = igPage
' Clear the annotations from the art page.
igARTForms.Page.RemoveMarks()
' Update the Display with the new ARTPage.
If igARTForms.Page IsNot Nothing Then
    ImGearPageView1.Display.ARTPage = igARTForms.Page
End If


ImGearART Properties

The ImGearART Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
DisablePPM Property
Control option to enable/disable PPM in font size calculations.
LegacyMode Property
Control option to enable/disable Legacy Mode in font size calculations.


DisablePPM Property

32-bit
64-bit
CF
P
P

Description:

ART control option.

True - disables PPM and display parameters in font size calculations for all text marks displayed, False - enables font size calculations.

Declaration:

public static bool DisablePPM { get, set }

Value:

true/false

Default value:

False

See Also:

ImGearART Class


LegacyMode Property

32-bit
64-bit
CF
P
P

Description:

ART control option.

True - enables legacy mode for calculating text font size for display, False - uses new mode for calculating text font size.

Declaration:

public static bool LegacyMode { get, set }

Value:

true/false

Default Value:

False

See Also:

ImGearART Class


ImGearART Methods

The ImGearART Class of the ImageGear.ART Namespace has the following methods:

Methods
Name
Description
BurnIn Method
Merges marks permanently into ImGearPage Class.
LoadPage Method
Loads ART marks from ImGearPage Class.
LoadPage Method
Loads ART marks from a stream.
SavePage Method
Saves ART marks into ImGearPage Class.
SavePage Method
Saves ART marks into a stream.


BurnIn Method

32-bit
64-bit
CF
P
P

Description:

Merges marks permanently into igPage. They are converted from vector-format constructs into raster-format. The image may be temporarily promoted to a higher bit-depth for the purpose of the merge (see ImGearARTBurnInOptions Enumeration).

Declaration:

public static ImageGear.Core.ImGearPage BurnIn ( ImageGear.Core.ImGearPage igPage ,
ImageGear.ART.ImGearARTPage artPage , ImageGear.ART.ImGearARTBurnInOptions burnOpts ,
int[] indexes )

Parameters:

Name
Type
Description
igPage
ImGearPage Class
ImGearPage Class to burn marks in.
artPage
ImGearARTPage Class
ART page to get marks from.
burnOpts
ImGearARTBurnInOptions Enumeration
BurnIn options.
indexes
int
List of group indexes to apply burn in to, null - all groups.

Return Value:

ImGearPage Class object.

Sample Code:

C#
// Select half of the annotations.
int count = 0;
foreach (ImGearARTMark igARTMark in igARTPage)
{
    if (count++ % 2 == 1)
        igARTPage.MarkSelect(igARTMark, true);
}
// Burn the selected annotations into the image.
ImGearPage igPageNew = ImGearART.BurnIn(igPage, igARTPage, ImGearARTBurnInOptions.SELECTED, null);
igPageView.Page = igPageNew;
// Remove the burned in annotations from the art page.
foreach (ImGearARTMark igARTMark in igARTPage)
{
    if (igARTPage.MarkIsSelected(igARTMark))
        igARTPage.MarkRemove(igARTMark);
}

VB.NET
' Select half of the annotations.
Dim count As Integer = 0
For Each igARTMark As ImGearARTMark In igARTPage
    If System.Math.Max(System.Threading.Interlocked.Increment(count), count - 1) Mod 2 = 1 Then
        igARTPage.MarkSelect(igARTMark, True)
    End If
Next
' Burn the selected annotations into the image.
Dim igPageNew As ImGearPage = ImGearART.BurnIn(igPage, igARTPage, ImGearARTBurnInOptions.SELECTED, Nothing)
igPageView.Page = igPageNew
' Remove the burned in annotations from the art page.
For Each igARTMark As ImGearARTMark In igARTPage
    If igARTPage.MarkIsSelected(igARTMark) Then
        igARTPage.MarkRemove(igARTMark)
    End If
Next

See Also:

ImGearPage Class

ImGearARTPage Class

ImGearARTBurnInOptions Enumeration


LoadPage Method

32-bit
64-bit
CF
P
P

Description:

This method loads ART marks from igPage. This method can be used to load ART marks from TIF or PDF page.

Declaration:

public static ImageGear.ART.ImGearARTPage LoadPage ( ImageGear.Core.ImGearPage igPage )

Parameters:

Name
Type
Description
igPage
ImGearPage Class
Page to load marks from.

Return Value:

ImGearARTPage Class.

Sample Code:

C#
ImGearPage igPage;
// Load an image containing embedded ART 2.0 annotations into a ImGearPage object
using (FileStream localFile = new FileStream("test1_art.tif", FileMode.Open))
    igPage = ImGearFileFormats.LoadPage(localFile, 0);
// Load the ImGearARTPage from the metadata in the ImGearPage.
igARTForms.Page = ImGearART.LoadPage(igPage);
// Burn the annotations into the image.
igPage = ImGearART.BurnIn(igPage, igARTForms.Page, ImGearARTBurnInOptions.ALL, null);
imGearPageView1.Page = igPage;
// Clear the annotations from the art page.
igARTForms.Page.RemoveMarks();
// Update the Display with the new ARTPage.
if (igARTForms.Page != null)
    imGearPageView1.Display.ARTPage = igARTForms.Page;

VB.NET
Dim igPage As ImGearPage
' Load an image containing embedded ART 2.0 annotations into a ImGearPage object
Using localFile As New FileStream("test1_art.tif", FileMode.Open)
    igPage = ImGearFileFormats.LoadPage(localFile, 0)
End Using
' Load the ImGearARTPage from the metadata in the ImGearPage.
igARTForms.Page = ImGearART.LoadPage(igPage)
' Burn the annotations into the image.
igPage = ImGearART.BurnIn(igPage, igARTForms.Page, ImGearARTBurnInOptions.ALL, Nothing)
ImGearPageView1.Page = igPage
' Clear the annotations from the art page.
igARTForms.Page.RemoveMarks()
' Update the Display with the new ARTPage.
If igARTForms.Page IsNot Nothing Then
    ImGearPageView1.Display.ARTPage = igARTForms.Page
End If

See Also:

ImGearARTPage Class

ImGearPage Class


LoadPage Method

32-bit
64-bit
CF
P
P

Description:

This method loads ART 2.0 & 3.0 marks from a stream. This method can be used to load ART 2.0 marks from TIF page and ART 3.0 marks from PDF page.

Declaration:

public static ImageGear.ART.ImGearARTPage LoadPage ( System.IO.Stream sysStream , Int
pageNumber )

Parameters:

Name
Type
Description
sysStream
System.IO.Stream
Stream from which to load marks. The LoadPage method works from the current stream position, so if you are indexing pages from the beginning of the multi-page annotations file, you need to reset the stream position to the beginning.
pageNumber
Int
Zero-based page number. First page is 0.

Return Value:

ImGearARTPage Class.

Sample Code:

C#
// Load first page of ART data from an ART file.
ImGearARTPage igARTPageNew;
using (FileStream localFile = new FileStream("test.xml", FileMode.Open))
    igARTPageNew = ImGearART.LoadPage(localFile, 0);
// Update display with new page.
igPageView.Display.ARTPage = igARTPageNew;

VB.NET
' Load first page of ART data from an ART file.
Dim igARTPageNew As ImGearARTPage
Using localFile As New FileStream("test.xml", FileMode.Open)
    igARTPageNew = ImGearART.LoadPage(localFile, 0)
End Using
' Update display with new page.
igPageView.Display.ARTPage = igARTPageNew

See Also:

ImGearARTPage Class


SavePage Method

32-bit
64-bit
CF
P
P

Description:

Saves ART 2.0 & 3.0 marks into igPage. This method can be used to export ART 2.0 marks to TIF page and ART 3.0 marks to PDF page.

Declaration:

public static void SavePage ( ImageGear.ART.ImGearARTPage artPage ,
ImageGear.Core.ImGearPage igPage )

Parameters:

Name
Type
Description
artPage
ImGearARTPage Class
ART page with marks to save.
igPage
ImGearPage Class
ImGearPage Class to save to.

Return Value:

None.

Sample Code:

C#
// Save reference to the original metadata.
ImGearMetadataTree igMetadataTreeOriginal =
    (ImGearMetadataTree)igPage.Metadata.Child;
// Prepare a TIF metadata tree.
ImGearMetadataTree igMetaDataTreeTIF =
    (igPage.Metadata.Child.Format == ImGearMetadataFormats.TIF) ?
    (ImGearMetadataTree)igPage.Metadata.Child.Clone() :
    new ImGearMetadataTree(ImGearMetadataFormats.TIF, (Int32)ImGearTIFTagIDs.FORMAT);
// Replace page metadata with igMetaDataTreeTIF.
igPage.Metadata.Child = igMetaDataTreeTIF;
// Save the art data into the metadata of the image.
ImGearART.SavePage(igARTPage, igPage);
// Save an image containing embedded ART 2.0 annotations into a ImGearPage object
using (FileStream localFile = new FileStream("test_art_save.tif", FileMode.Create))
    ImGearFileFormats.SavePage(igPage, localFile, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.TIF_UNCOMP, null);
// Restore original meta data.
igPage.Metadata.Child = igMetadataTreeOriginal;

VB.NET
' Save reference to the original metadata.
Dim igMetadataTreeOriginal As ImGearMetadataTree = DirectCast(igPage.Metadata.Child, ImGearMetadataTree)
' Prepare a TIF metadata tree.
Dim igMetaDataTreeTIF As ImGearMetadataTree
If (igPage.Metadata.Child.Format = ImGearMetadataFormats.TIF) Then
    igMetaDataTreeTIF = DirectCast(igPage.Metadata.Child.Clone(), ImGearMetadataTree)
Else
    igMetaDataTreeTIF = New ImGearMetadataTree(ImGearMetadataFormats.TIF, DirectCast(ImGearTIFTagIDs.FORMAT, Int32))
End If
' Replace page metadata with igMetaDataTreeTIF.
igPage.Metadata.Child = igMetaDataTreeTIF
' Save the art data into the metadata of the image.
ImGearART.SavePage(igARTPage, igPage)
' Save an image containing embedded ART 2.0 annotations into a ImGearPage object
Using localFile As New FileStream("test_art_save.tif", FileMode.Create)
    ImGearFileFormats.SavePage(igPage, localFile, 0, _
     ImGearSavingModes.OVERWRITE, ImGearSavingFormats.TIF_UNCOMP, Nothing)
End Using
' Restore original meta data.
igPage.Metadata.Child = igMetadataTreeOriginal

See Also:

ImGearARTPage Class

ImGearPage Class


SavePage Method

32-bit
64-bit
CF
P
P

Description:

Saves ART marks into a stream. This method can be used to export ART marks to legacy ART 2.0 or XML ART3.0 stream.

NOTE: Saving a multipage ART XML file with ImGearSavingModes.APPEND for the 4th parameter is a special case that requires seeking to the start of the stream before the SavePage call. Otherwise an attempt to save several ART pages into one XML file could result in an improperly formatted file from which only the annotations for the 1st page will be loaded, being saved. See the Sample Code below.

Declaration:

public static void SavePage ( ImageGear.ART.ImGearARTPage artPage , System.IO.Stream
sysStream , Int pageNum , ImageGear.Formats.ImGearSavingModes saveMode ,
ImageGear.ART.ImGearARTSaveType type )

Parameters:

Name
Type
Description
artPage
ImGearARTPage Class
ART page with marks to save.
sysStream
System.IO.Stream
Stream to which to save annotation marks. The SavePage method works from the current stream position, so if you are intending to re-write the stream, you need to reset the stream position to the beginning.
pageNum
Int
Page number to save. First page is 1.
saveMode
ImGearSavingModes Enumeration
Saving mode.
type
ImGearARTSaveType Enumeration
Saving type.

Return Value:

None.

Sample Code:

C#
private static void SaveMultipageArt(ImGearARTPage[] igARTPages, string XmlFilePath)
{
    using (FileStream fileContent = new FileStream(XmlFilePath, FileMode.OpenOrCreate, FileAccess.ReadWrite))
    {
        for (int i = 0; i < igARTPages.Length; i++)
        {
            if (igARTPages[i] != null)
            {
                //Must seek to the start of the stream before saving each ImGearARTPage
                // to a multipage XML ART file using ImGearSavingModes.APPEND
                fileContent.Position = 0;
                ImGearART.SavePage(igARTPages[i], fileContent, i, ImGearSavingModes.APPEND, ImGearARTSaveType.XML);
            }
        }
    }
}

VB.NET
Sub SaveMultipageArt(ByVal igARTPages() As ImGearARTPage, ByVal XmlFilePath As String)
    Dim fileContent As FileStream
    Try
        fileContent = New FileStream(XmlFilePath, FileMode.OpenOrCreate, FileAccess.ReadWrite)
        For i As Integer = 0 To igARTPages.Length - 1
            If (Not (igARTPages(i) Is Nothing)) Then
                'Must seek to the start of the stream before saving each ImGearARTPage
                ' to a multipage XML ART file using ImGearSavingModes.APPEND
                fileContent.Position = 0
                ImGearART.SavePage(igARTPages(i), fileContent, i, ImGearSavingModes.APPEND, ImGearARTSaveType.XML)
            End If
        Next
    Finally
        fileContent.Close()
    End Try
End Sub

See Also:

ImGearARTPage Class

ImGearARTSaveType Enumeration


ImGearARTArrow Class

32-bit
64-bit
CF
P
P

Description:

Legacy ART Arrow mark.

Declaration:

public class ImGearARTArrow : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTArrow Constructor
creates a new instance of ImGearARTArrow object.
ImGearARTArrow Constructor
creates a new instance of ImGearARTArrow object.
ImGearARTArrow Constructor
creates a new instance of ImGearARTArrow object.

Properties
Name
Description
Color Property
Color of the arrow.
EndPoint Property
End point of the arrow.
HeadAngle Property
The head angle of the arrow.
HeadLength Property
The head length of the arrow.
HeadType Property
The head type of the arrow.
Highlight Property
Arrow highlight.
StartPoint Property
Start point of the arrow.
Width Property
Arrow width.

Sample Code:

C#
// Setup start and endpoint for the arrow.
ImGearPoint igPointStart = new ImGearPoint(0, 0);
ImGearPoint igPointEnd = new ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2);
// Setup color for annotation.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(0, 255, 0);
// Create the Arrow annotation with a width of 4, no highlight,
//  regular pointer head type, a 30 degree angle for the head, and a length of 20 for the head.
ImGearARTArrow igARTArrow = new ImGearARTArrow(
    igPointStart, igPointEnd, igRGBQuad, 4, false,
    ImGearARTLineHeadType.POINTER, 30, 20
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTArrow, ImGearARTCoordinatesType.IMAGE_COORD);

VB.NET
' Setup start and endpoint for the arrow.
Dim igPointStart As New ImGearPoint(0, 0)
Dim igPointEnd As New ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2)
' Setup color for annotation.
Dim igRGBQuad As New ImGearRGBQuad(0, 255, 0)
' Create the Arrow annotation with a width of 4, no highlight,
'  regular pointer head type, a 30 degree angle for the head, and a length of 20 for the head.
Dim igARTArrow As New ImGearARTArrow( _
 igPointStart, igPointEnd, igRGBQuad, _
 4, False, ImGearARTLineHeadType.POINTER, 30, 20)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTArrow, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTArrow Constructors

The ImGearARTArrow Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTArrow Constructor
creates a new instance of ImGearARTArrow object.
ImGearARTArrow Constructor
creates a new instance of ImGearARTArrow object.
ImGearARTArrow Constructor
creates a new instance of ImGearARTArrow object.


ImGearARTArrow Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTArrow Class object.

Declaration:

public ImGearARTArrow ( ImageGear.Core.ImGearPoint StartPoint , ImageGear.Core.ImGearPoint
EndPoint , ImageGear.Core.IImGearRGBQuad Color )

Parameters:

Name
Type
Description
StartPoint
ImGearPoint Structure
Start point of the arrow.
EndPoint
ImGearPoint Structure
End point of the arrow.
Color
ImGearRGBQuad Structure
Arrow color.

Return Value:

The new instance of ImGearARTArrow Class object.

See Also:

ImGearPoint Structure

ImGearRGBQuad Structure


ImGearARTArrow Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTArrow object.

Declaration:

public ImGearARTArrow ( ImageGear.Core.ImGearPoint StartPoint , ImageGear.Core.ImGearPoint
EndPoint , ImageGear.Core.IImGearRGBQuad Color , Int Width , Bool Highlight )

Parameters:

Name
Type
Description
StartPoint
ImGearPoint Structure
Start point of the arrow.
EndPoint
ImGearPoint Structure
End point of the arrow.
Color
ImGearRGBQuad Structure
Arrow color.
Width
Int
Arrow width.
Highlight
Bool
Arrow highlight.

Return Value:

The new instance of ImGearARTArrow Class object.

See Also:

ImGearPoint Structure

ImGearRGBQuad Structure

ImGearARTArrow Class


ImGearARTArrow Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTArrow Class object.

Declaration:

public ImGearARTArrow ( ImageGear.Core.ImGearPoint StartPoint , ImageGear.Core.ImGearPoint
EndPoint , ImageGear.Core.IImGearRGBQuad Color , Int Width , Bool Highlight ,
ImageGear.ART.ImGearARTLineHeadType HeadType , Int HeadAngle , Int HeadLength )

Parameters:

Name
Type
Description
StartPoint
ImGearPoint Structure
Start point of the arrow.
EndPoint
ImGearPoint Structure
End point of the arrow.
Color
ImGearRGBQuad Structure
Arrow color.
Width
Int
Arrow width.
Highlight
Bool
Arrow highlight.
HeadType
ImGearARTLineHeadType Enumeration
Type of arrow head.
HeadAngle
Int
Angle of arrow head.
HeadLength
Int
Length of arrow head.

Return Value:

The new instance of ImGearARTArrow Class object.

See Also:

ImGearPoint Structure

ImGearRGBQuad Structure

ImGearARTLineHeadType Enumeration

ImGearARTArrow Class


ImGearARTArrow Properties

The ImGearARTArrow Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
Color Property
Color of the arrow.
EndPoint Property
End point of the arrow.
HeadAngle Property
The head angle of the arrow.
HeadLength Property
The head length of the arrow.
HeadType Property
The head type of the arrow.
Highlight Property
Arrow highlight.
StartPoint Property
Start point of the arrow.
Width Property
Arrow width.


Color Property

32-bit
64-bit
CF
P
P

Description:

Arrow color.

Declaration:

public ImageGear.Core.IImGearRGBQuad Color { get, set }

Value:

IImGearRGBQuad

Default value:

N/A

See Also:

ImGearRGBQuad Structure


EndPoint Property

32-bit
64-bit
CF
P
P

Description:

The End Point of the arrow.

Declaration:

public ImageGear.Core.ImGearPoint EndPoint { get, set }

Value:

ImGearPoint Structure object.

Default value:

N/A

See Also:

ImGearPoint Structure


HeadAngle Property

32-bit
64-bit
CF
P
P

Description:

The angle of the arrow head.

Declaration:

public int HeadAngle { get, set }

Value:

Integer value.

Default value:

0


HeadLength Property

32-bit
64-bit
CF
P
P

Description:

The length of the arrow head.

Declaration:

public int HeadLength { get, set }

Value:

Integer value.

Default value:

N/A


HeadType Property

32-bit
64-bit
CF
P
P

Description:

The type of the arrow head.

Declaration:

public ImageGear.ART.ImGearARTLineHeadType HeadType { get, set }

Value:

ImGearARTLineHeadType Enumeration value.

Default value:

N/A

See Also:

ImGearARTLineHeadType Enumeration


Highlight Property

32-bit
64-bit
CF
P
P

Description:

The arrow highlight.

Declaration:

public bool Highlight { get, set }

Value:

True, False

Default value:

N/A


StartPoint Property

32-bit
64-bit
CF
P
P

Description:

The Start Point of the arrow.

Declaration:

public ImageGear.Core.ImGearPoint StartPoint { get, set }

Value:

ImGearPoint Structure object.

Default value:

N/A

See Also:

ImGearPoint Structure


Width Property

32-bit
64-bit
CF
P
P

Description:

The width of the arrow line.

Declaration:

public int Width { get, set }

Value:

Integer value.

Default value:

N/A


ImGearARTAudio Class

32-bit
64-bit
CF
P
P

Description:

ART Audio mark.

Declaration:

public class ImGearARTAudio : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTAudio Constructor
creates a new instance of ImGearARTAudio object.

Properties
Name
Description
FileName Property
The sound file name.
Height Property
The height of the mark.
Width Property
The width of the mark.
X Property
The X coordinate of the left-top point of the mark.
Y Property
The Y coordinate of the left-top point of the mark.

Sample Code:

C#
// Setup rectangle for the audio mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10,10,100,20);
// Create the audio mark annotation pointing to test.wav
ImGearARTAudio igARTAudio = new ImGearARTAudio(
    igRectangle, "test.wav"
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTAudio, ImGearARTCoordinatesType.IMAGE_COORD);

VB.NET
' Setup rectangle for the audio mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 100, 20)
' Create the audio mark annotation pointing to test.wav
Dim igARTAudio As New ImGearARTAudio(igRectangle, "test.wav")
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTAudio, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTAudio Constructors

The ImGearARTAudio Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTAudio Constructor
creates a new instance of ImGearARTAudio object.


ImGearARTAudio Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTAudio Class object.

Declaration:

public ImGearARTAudio ( ImageGear.Core.IImGearRectangle Rect , String FileName )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
The mark rectangle.
FileName
String
The filename of the mark.

Return Value:

The new instance of ImGearARTAudio Class object.

See Also:

ImGearRectangle Structure


ImGearARTAudio Properties

The ImGearARTAudio Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
FileName Property
The sound file name. .
Height Property
The height of the mark.
Width Property
The width of the mark.
X Property
The X coordinate of the left-top point of the mark.
Y Property
The Y coordinate of the left-top point of the mark.


FileName Property

32-bit
64-bit
CF
P
P

Description:

The sound file name. The sound specified by this parameter must fit into available physical memory and be playable by an installed waveform-audio device driver.

Declaration:

public string FileName { get, set }

Value:

Name string.

Default value:

N/A


Height Property

32-bit
64-bit
CF
P
P

Description:

The height of the mark.

Declaration:

public int Height { get, set }

Value:

Integer value.

Default value:

N/A


Width Property

32-bit
64-bit
CF
P
P

Description:

The width of the mark.

Declaration:

public int Width { get, set }

Value:

Integer value.

Default value:

N/A


X Property

32-bit
64-bit
CF
P
P

Description:

The X coordinate of the left-top point of the mark.

Declaration:

public int X { get, set }

Value:

Integer value.

Default value:

N/A


Y Property

32-bit
64-bit
CF
P
P

Description:

The Y coordinate of the left-top point of the mark.

Declaration:

public int Y { get, set }

Value:

Integer value.

Default value:

N/A


ImGearARTBorder Class

32-bit
64-bit
CF
P
P

Description:

Specifies mark's border attributes.

Declaration:

public class ImGearARTBorder

Members:

Constructors
Name
Description
ImGearARTBorder Constructor
Creates border object.
ImGearARTBorder Constructor
Creates border object.

Properties
Name
Description
Color Property
The border color.
Style Property
The border style.
Width Property
The width of border line.

Sample Code:

C#
// Setup color for the border.
ImGearRGBQuad igRGBQuadBorder = new ImGearRGBQuad(0, 255, 0);
// Setup a border with a width of 3 and a dot pattern.
ImGearARTBorder igARTBorder = new ImGearARTBorder(
    igRGBQuadBorder, 3, ImGearARTPenStyle.DOT
);
// Setup color for the pin.
ImGearRGBQuad igRGBQuadPin = new ImGearRGBQuad(0, 0, 255);
// Create pin to be used in the annotation.
ImGearARTPin igARTPin = new ImGearARTPin(igRGBQuadPin, ImGearARTPinAlignment.RIGHT_TOP);
// Setup color for the callout border.
ImGearRGBQuad igRGBQuadBorderCallout = new ImGearRGBQuad(0, 255, 255);
// Setup a border with a width of 3 and a solid pattern.
ImGearARTBorder igARTBorderCallout = new ImGearARTBorder(
    igRGBQuadBorder, 3, ImGearARTPenStyle.SOLID
);
// Create a callout to be used for the text annotation.
ImGearARTCallout igARTCallout = new ImGearARTCallout(
    ImGearARTCalloutType.LINE, igPage.DIB.Width / 2,
    igPage.DIB.Height / 2, igARTBorderCallout
);
// Setup rectangle for the text mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 330, 40);
// Setup color for the text.
ImGearRGBQuad igRGBQuadText = new ImGearRGBQuad(255, 0, 255);
// Setup color for the fill.
ImGearRGBQuad igRGBQuadFill = new ImGearRGBQuad(200, 200, 200);
// Create the text annotation.
ImGearARTText igARTText = new ImGearARTText(
    igRectangle, "ImGearARTText annotation", igRGBQuadText,
    ImGearARTTextType.DIRECT_TEXT, igRGBQuadFill, igARTBorder, false,
    255, "Arial", (float)14.0, FontStyle.Regular, igARTPin, igARTCallout
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTText, ImGearARTCoordinatesType.IMAGE_COORD);

VB.NET
' Setup color for the border.
Dim igRGBQuadBorder As New ImGearRGBQuad(0, 255, 0)
' Setup a border with a width of 3 and a dot pattern.
Dim igARTBorder As New ImGearARTBorder(igRGBQuadBorder, 3, ImGearARTPenStyle.DOT)
' Setup color for the pin.
Dim igRGBQuadPin As New ImGearRGBQuad(0, 0, 255)
' Create pin to be used in the annotation.
Dim igARTPin As New ImGearARTPin(igRGBQuadPin, ImGearARTPinAlignment.RIGHT_TOP)
' Setup color for the callout border.
Dim igRGBQuadBorderCallout As New ImGearRGBQuad(0, 255, 255)
' Setup a border with a width of 3 and a solid pattern.
Dim igARTBorderCallout As New ImGearARTBorder(igRGBQuadBorder, 3, ImGearARTPenStyle.SOLID)
' Create a callout to be used for the text annotation.
Dim igARTCallout As New ImGearARTCallout( _
 ImGearARTCalloutType.LINE, igPage.DIB.Width / 2, igPage.DIB.Height / 2, igARTBorderCallout)
' Setup rectangle for the text mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 330, 40)
' Setup color for the text.
Dim igRGBQuadText As New ImGearRGBQuad(255, 0, 255)
' Setup color for the fill.
Dim igRGBQuadFill As New ImGearRGBQuad(200, 200, 200)
' Create the text annotation.
Dim igARTText As New ImGearARTText( _
 igRectangle, "ImGearARTText annotation", igRGBQuadText, _
 ImGearARTTextType.DIRECT_TEXT, igRGBQuadFill, igARTBorder, False, _
 255, "Arial", CSng(14), FontStyle.Regular, igARTPin, igARTCallout)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTText, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTBorder Constructors

The ImGearARTBorder Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTBorder Constructor
Creates border object.
ImGearARTBorder Constructor
Creates border object.


ImGearARTBorder Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTBorder Class object.

Declaration:

public ImGearARTBorder ( ImageGear.Core.IImGearRGBQuad Color , Int Width )

Parameters:

Name
Type
Description
Color
ImGearRGBQuad Structure
The border color.
Width
Int
The border width.

Return Value:

The new instance of ImGearARTBorder Class object.

See Also:

ImGearRGBQuad Structure


ImGearARTBorder Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTBorder Class object.

Declaration:

public ImGearARTBorder ( ImageGear.Core.IImGearRGBQuad Color , Int Width ,
ImageGear.ART.ImGearARTPenStyle Style )

Parameters:

Name
Type
Description
Color
ImGearRGBQuad Structure
The border color.
Width
Int
The border width.
Style
ImGearARTPenStyle Enumeration
The border style.

Return Value:

The new instance of ImGearARTBorder Class object.

See Also:

ImGearRGBQuad Structure

ImGearARTPenStyle Enumeration


ImGearARTBorder Properties

The ImGearARTBorder Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
Color Property
The border color.
Style Property
The border style.
Width Property
The width of border line.


Color Property

32-bit
64-bit
CF
P
P

Description:

The border color.

Declaration:

public ImageGear.Core.IImGearRGBQuad Color { get, set }

Value:

ImGearRGBQuad Structure object.

Default value:

N/A

See Also:

ImGearRGBQuad Structure


Style Property

32-bit
64-bit
CF
P
P

Description:

The border style.

Declaration:

public ImageGear.ART.ImGearARTPenStyle Style { get, set }

Value:

ImGearARTPenStyle Enumeration value.

Default value:

N/A

See Also:

ImGearARTPenStyle Enumeration


Width Property

32-bit
64-bit
CF
P
P

Description:

The width of the border line.

Declaration:

public int Width { get, set }

Value:

Integer value.

Default value:

N/A


ImGearARTButton Class

32-bit
64-bit
CF
P
P

Description:

ART Button mark.

Declaration:

public class ImGearARTButton : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTButton Constructor
Creates a new instance of ImGearARTButton object.
ImGearARTButton Constructor
Creates a new instance of ImGearARTButton object.

Properties
Name
Description
FillColor Property
Mark's fillcolor.
FontName Property
The name of the mark's font.
FontSize Property
The size of the mark's font.
FontStyle Property
The style of the mark's font.
FontDisablePPM Property
Option to enable/disable PPM in font size calculations.
Height Property
The height of the button.
Opacity Property
Mark's opacity.
State Property
The state of the mark.
Text Property
The text the button.
TextColor Property
The color of the button's text.
Width Property
The width of the button
X Property
The x coordinate of the left-top point of the mark.
Y Property
The y coordinate of the left-top point of the mark.

Sample Code:

C#
// Setup rectangle for the text mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 100, 40);
// Setup color for the text.
ImGearRGBQuad igRGBQuadText = new ImGearRGBQuad(40, 40, 200);
// Setup color for the fill.
ImGearRGBQuad igRGBQuadFill = new ImGearRGBQuad(200, 200, 200);
// Create the button annotation.
ImGearARTButton igARTButton = new ImGearARTButton(
    igRectangle, "ImGearARTButton annotation", igRGBQuadText,
    igRGBQuadFill, 255, "Arial", (float)14.0, FontStyle.Regular
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTButton, ImGearARTCoordinatesType.IMAGE_COORD);

VB.NET
' Setup rectangle for the text mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 100, 40)
' Setup color for the text.
Dim igRGBQuadText As New ImGearRGBQuad(40, 40, 200)
' Setup color for the fill.
Dim igRGBQuadFill As New ImGearRGBQuad(200, 200, 200)
' Create the button annotation.
Dim igARTButton As New ImGearARTButton( _
 igRectangle, "ImGearARTButton annotation", igRGBQuadText, _
 igRGBQuadFill, 255, "Arial", CSng(14), FontStyle.Regular)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTButton, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTButton Constructors

The ImGearARTButton Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTButton Constructor
Creates a new instance of ImGearARTButton object.
ImGearARTButton Constructor
Creates a new instance of ImGearARTButton object.


ImGearARTButton Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTButton Class object.

Declaration:

public ImGearARTButton ( ImageGear.Core.IImGearRectangle Rect , String Text )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
The mark rectangle.
Text
String
Button text.

Return Value:

The new instance of ImGearARTButton Class object.

See Also:

ImGearRectangle Structure


ImGearARTButton Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTButton Class object.

Declaration:

public ImGearARTButton ( ImageGear.Core.IImGearRectangle Rect , String Text ,
ImageGear.Core.IImGearRGBQuad TextColor , ImageGear.Core.IImGearRGBQuad FillColor , Int
Opacity , String FontName , float FontSize , System.Drawing.FontStyle FontStyle )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
The mark rectangle.
Text
String
Button text.
TextColor
ImGearRGBQuad Structure
Button text color.
FillColor
ImGearRGBQuad Structure
The fill color of the button.
Opacity
Int
Button opacity.
FontName
String
The name of the font.
FontSize
float
The size of the font in points.
FontStyle
System.Drawing.FontStyle
The style of the font.

Return Value:

The new instance of ImGearARTButton Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure


ImGearARTButton Properties

The ImGearARTButton Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
FillColor Property
Mark's fill color.
FontName Property
The name of the mark's font.
FontSize Property
The size of the mark's font.
FontStyle Property
The style of the mark's font.
FontDisablePPM Property
Option to enable/disable PPM in font size calculations.
Height Property
The height of the button.
Opacity Property
Mark's opacity.
State Property
The state of the mark.
Text Property
The text the button.
TextColor Property
The color of the button's text.
Width Property
The width of the button
X Property
The x coordinate of the left-top point of the mark.
Y Property
The y coordinate of the left-top point of the mark.


FillColor Property

32-bit
64-bit
CF
P
P

Description:

The fill color of the button.

Declaration:

public ImageGear.Core.IImGearRGBQuad FillColor { get, set }

Value:

ImGearRGBQuad Structure object.

Default value:

N/A

See Also:

ImGearRGBQuad Structure


FontName Property

32-bit
64-bit
CF
P
P

Description:

The font name of the button's text.

Declaration:

public string FontName { get, set }

Value:

Name string.

Default value:

N/A


FontSize Property

32-bit
64-bit
CF
P
P

Description:

The size of the font in points.

Declaration:

public float FontSize { get, set }

Value:

Any positive value.

Default value:

N/A


FontStyle Property

32-bit
64-bit
CF
P
P

Description:

The font style of the button's text.

Declaration:

public System.Drawing.FontStyle FontStyle { get, set }

Value:

FontStyle value.

Default value:

N/A


FontDisablePPM Property

32-bit
64-bit
CF
P
P

Description:

True - disables PPM and display parameters in font size calculations for the current mark, False - enables font size calculations.

Declaration:

public System.Boolean FontDisablePPM { get, set }

Value:

System.Boolean

Default value:

False


Height Property

32-bit
64-bit
CF
P
P

Description:

The height of the button.

Declaration:

public int Height { get, set }

Value:

Integer value.

Default value:

N/A


Opacity Property

32-bit
64-bit
CF
P
P

Description:

The opacity of the button.

Declaration:

public int Opacity { get, set }

Value:

Integer value from 0 (transparent) to 255 (opaque).

Default value:

255


State Property

32-bit
64-bit
CF
P
P

Description:

The state of the button.

Declaration:

public ImageGear.ART.ImGearARTButtonState State { get, set }

Value:

ImGearARTButtonState Enumeration object.

Default value:

N/A

See Also:

ImGearARTButtonState Enumeration


Text Property

32-bit
64-bit
CF
P
P

Description:

The button text.

Declaration:

public string Text { get, set }

Value:

Text string.

Default value:

N/A


TextColor Property

32-bit
64-bit
CF
P
P

Description:

The text color.

Declaration:

public ImageGear.Core.IImGearRGBQuad TextColor { get, set }

Value:

ImGearRGBQuad Structure object.

Default value:

N/A

See Also:

ImGearRGBQuad Structure


Width Property

32-bit
64-bit
CF
P
P

Description:

The width of the button.

Declaration:

public int Width { get, set }

Value:

Integer value.

Default value:

N/A


X Property

32-bit
64-bit
CF
P
P

Description:

The X coordinate of the top-left point of the button.

Declaration:

public int X { get, set }

Value:

Integer value.

Default value:

N/A


Y Property

32-bit
64-bit
CF
P
P

Description:

The X coordinate of the top-left point of the button.

Declaration:

public int Y { get, set }

Value:

Integer value.

Default value:

N/A


ImGearARTCallout Class

32-bit
64-bit
CF
P
P

Description:

Specifies text mark's callout attributes.

NOTE: Callout is the shape object that points to the object it tells about.

Declaration:

public class ImGearARTCallout

Members:

Constructors
Name
Description
ImGearARTCallout Constructor
Creates the new instance of ImGearCallout object.
ImGearARTCallout Constructor
Creates the new instance of ImGearCallout object.

Properties
Name
Description
Line Property
Callout line attributes.
Type Property
Callout type.
X Property
Callout pointer X location.
Y Property
Callout pointer Y location.

Sample Code:

C#
// Setup color for the border.
ImGearRGBQuad igRGBQuadBorder = new ImGearRGBQuad(0, 255, 0);
// Setup a border with a width of 3 and a dot pattern.
ImGearARTBorder igARTBorder = new ImGearARTBorder(
    igRGBQuadBorder, 3, ImGearARTPenStyle.DOT
);
// Setup color for the pin.
ImGearRGBQuad igRGBQuadPin = new ImGearRGBQuad(0, 0, 255);
// Create pin to be used in the annotation.
ImGearARTPin igARTPin = new ImGearARTPin(igRGBQuadPin, ImGearARTPinAlignment.RIGHT_TOP);
// Setup color for the callout border.
ImGearRGBQuad igRGBQuadBorderCallout = new ImGearRGBQuad(0, 255, 255);
// Setup a border with a width of 3 and a solid pattern.
ImGearARTBorder igARTBorderCallout = new ImGearARTBorder(
    igRGBQuadBorder, 3, ImGearARTPenStyle.SOLID
);
// Create a callout to be used for the text annotation.
ImGearARTCallout igARTCallout = new ImGearARTCallout(
    ImGearARTCalloutType.LINE, igPage.DIB.Width / 2,
    igPage.DIB.Height / 2, igARTBorderCallout
);
// Setup rectangle for the text mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 330, 40);
// Setup color for the text.
ImGearRGBQuad igRGBQuadText = new ImGearRGBQuad(255, 0, 255);
// Setup color for the fill.
ImGearRGBQuad igRGBQuadFill = new ImGearRGBQuad(200, 200, 200);
// Create the text annotation.
ImGearARTText igARTText = new ImGearARTText(
    igRectangle, "ImGearARTText annotation", igRGBQuadText,
    ImGearARTTextType.DIRECT_TEXT, igRGBQuadFill, igARTBorder, false,
    255, "Arial", (float)14.0, FontStyle.Regular, igARTPin, igARTCallout
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTText, ImGearARTCoordinatesType.IMAGE_COORD);

VB.NET
' Setup color for the border.
Dim igRGBQuadBorder As New ImGearRGBQuad(0, 255, 0)
' Setup a border with a width of 3 and a dot pattern.
Dim igARTBorder As New ImGearARTBorder(igRGBQuadBorder, 3, ImGearARTPenStyle.DOT)
' Setup color for the pin.
Dim igRGBQuadPin As New ImGearRGBQuad(0, 0, 255)
' Create pin to be used in the annotation.
Dim igARTPin As New ImGearARTPin(igRGBQuadPin, ImGearARTPinAlignment.RIGHT_TOP)
' Setup color for the callout border.
Dim igRGBQuadBorderCallout As New ImGearRGBQuad(0, 255, 255)
' Setup a border with a width of 3 and a solid pattern.
Dim igARTBorderCallout As New ImGearARTBorder(igRGBQuadBorder, 3, ImGearARTPenStyle.SOLID)
' Create a callout to be used for the text annotation.
Dim igARTCallout As New ImGearARTCallout( _
 ImGearARTCalloutType.LINE, igPage.DIB.Width / 2, igPage.DIB.Height / 2, igARTBorderCallout)
' Setup rectangle for the text mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 330, 40)
' Setup color for the text.
Dim igRGBQuadText As New ImGearRGBQuad(255, 0, 255)
' Setup color for the fill.
Dim igRGBQuadFill As New ImGearRGBQuad(200, 200, 200)
' Create the text annotation.
Dim igARTText As New ImGearARTText( _
 igRectangle, "ImGearARTText annotation", igRGBQuadText, _
 ImGearARTTextType.DIRECT_TEXT, igRGBQuadFill, igARTBorder, False, _
 255, "Arial", CSng(14), FontStyle.Regular, igARTPin, igARTCallout)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTText, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTCallout Constructors

The ImGearARTCallout Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTCallout Constructor
Creates the new instance of ImGearCallout object.
ImGearARTCallout Constructor
Creates the new instance of ImGearCallout object.


ImGearARTCallout Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTCallout Class object.

Declaration:

public ImGearARTCallout ( ImageGear.ART.ImGearARTCalloutType Type , Int X , Int Y )

Parameters:

Name
Type
Description
Type
ImGearARTCalloutType Enumeration
The callout type.
X
Int
Callout pointer X location.
Y
Int
Callout pointer Y location.

Return Value:

The new instance of ImGearARTCallout Class object.


ImGearARTCallout Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTCallout Class object.

Declaration:

public ImGearARTCallout ( ImageGear.ART.ImGearARTCalloutType Type , Int X , Int Y ,
ImageGear.ART.ImGearARTBorder Line )

Parameters:

Name
Type
Description
Type
ImGearARTCalloutType Enumeration
The callout type.
X
Int
Callout pointer X location.
Y
Int
Callout pointer Y location.
Line
ImGearARTBorder Class
Callout line attributes.

Return Value:

The new instance of ImGearARTCallout Class object.

See Also:

ImGearARTCalloutType Enumeration

ImGearARTBorder Class


ImGearARTCallout Properties

The ImGearARTCallout Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
Line Property
Callout line attributes.
Type Property
Callout type.
X Property
Callout pointer X location.
Y Property
Callout pointer Y location.


Line Property

32-bit
64-bit
CF
P
P

Description:

The Callout line attributes.

Declaration:

public ImageGear.ART.ImGearARTBorder Line { get, set }

Value:

ImGearARTBorder Class

Default value:

N/A

See Also:

ImGearARTBorder Class


Type Property

32-bit
64-bit
CF
P
P

Description:

The Callout type.

Declaration:

public ImageGear.ART.ImGearARTCalloutType Enumeration Type { get, set }

Value:

ImGearARTCalloutType Enumeration

Default value:

N/A

See Also:

ImGearARTCalloutType Enumeration


X Property

32-bit
64-bit
CF
P
P

Description:

The Callout pointer X location.

Declaration:

public int X { get, set }

Value:

Any integer value.

Default value:

N/A


Y Property

32-bit
64-bit
CF
P
P

Description:

The Callout pointer Y location.

Declaration:

public int Y { get, set }

Value:

Any integer value.

Default value:

N/A


ImGearARTCurve Class

32-bit
64-bit
CF
P
P

Description:

ART Curve mark.

Declaration:

public class ImGearARTCurve : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTCurve Constructor
Creates a new instance of ImGearARTCurve object.
ImGearARTCurve Constructor
Creates a new instance of ImGearARTCurve object.

Properties
Name
Description
Color Property
Color of the mark.
NumberOfPoints Property
Actual number of mark's points.
Opacity Property
Opacity of the mark.
Points Property
Raw points array.
Style Property
The style of the mark.
Tension Property
Tension of the curve.
Width Property
Width of the mark.

Methods
Name
Description
GetPoint Method
Gets the point with specified index.
SetPoint Method
Sets the point with specified index.

Sample Code:

C#
// Create an array of 5 points for the curve.
ImGearPoint[] igPoints = new ImGearPoint[5];
igPoints[0] = new ImGearPoint(0, 0);
igPoints[1] = new ImGearPoint(20, 40);
igPoints[2] = new ImGearPoint(40, 40);
igPoints[3] = new ImGearPoint(80, 40);
igPoints[4] = new ImGearPoint(120, 120);
// Setup color for the curve.
ImGearRGBQuad igRGBQuadCurve = new ImGearRGBQuad(40, 40, 200);
// Create curve with a dashed pattern, width of 4, tension of 0.75 and opacity of 127 (50%)
ImGearARTCurve igARTCurve = new ImGearARTCurve(
    igPoints, igRGBQuadCurve, ImGearARTPenStyle.DASH, 4, (float)0.75, 127
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTCurve, ImGearARTCoordinatesType.IMAGE_COORD);

VB.NET
' Create an array of 5 points for the curve.
Dim igPoints As ImGearPoint() = New ImGearPoint(4) {}
igPoints(0) = New ImGearPoint(0, 0)
igPoints(1) = New ImGearPoint(20, 40)
igPoints(2) = New ImGearPoint(40, 40)
igPoints(3) = New ImGearPoint(80, 40)
igPoints(4) = New ImGearPoint(120, 120)
' Setup color for the curve.
Dim igRGBQuadCurve As New ImGearRGBQuad(40, 40, 200)
' Create curve with a dashed pattern, width of 4, tension of 0.75 and opacity of 127 (50%)
Dim igARTCurve As New ImGearARTCurve( _
 igPoints, igRGBQuadCurve, ImGearARTPenStyle.DASH, 4, CSng(0.75), 127)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTCurve, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTCurve Constructors

The ImGearARTCurve Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTCurve Constructor
Creates a new instance of ImGearARTCurve object.
ImGearARTCurve Constructor
Creates a new instance of ImGearARTCurve object.


ImGearARTCurve Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTCurve Class object.

Declaration:

public ImGearARTCurve ( ImageGear.Core.ImGearPoint[] Points ,
ImageGear.Core.IImGearRGBQuad Color )

Parameters:

Name
Type
Description
Points
ImGearPoint Structure
Raw points array.
Color
ImGearRGBQuad Structure
Color of the mark.

Return Value:

The new instance of ImGearARTCurve Class object.

See Also:

ImGearRGBQuad Structure

ImGearPoint Structure


ImGearARTCurve Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTCurve Class object.

Declaration:

public ImGearARTCurve ( ImageGear.Core.ImGearPoint[] Points ,
ImageGear.Core.IImGearRGBQuad Color , ImageGear.ART.ImGearARTPenStyle Style , Int Width ,
float Tension , Int Opacity )

Parameters:

Name
Type
Description
Points
ImGearPoint Structure
Raw points array.
Color
ImGearRGBQuad Structure
Color of the mark.
Style
ImGearARTPenStyle Enumeration
Style of the mark.
Width
Int
Width of the mark.
Tension
float
Tension of the curve.
Opacity
Int
Opacity of the mark.

Return Value:

The new instance of ImGearARTCurve Class object.

See Also:

ImGearRGBQuad Structure

ImGearPoint Structure

ImGearARTPenStyle Enumeration


ImGearARTCurve Properties

The ImGearARTCurve Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
Color Property
Color of the mark.
NumberOfPoints Property
Actual number of mark's points.
Opacity Property
Opacity of the mark.
Points Property
Raw points array.
Style Property
The style of the mark.
Tension Property
Tension of the curve.
Width Property
Width of the mark.


Color Property

32-bit
64-bit
CF
P
P

Description:

The color of the mark.

Declaration:

public ImageGear.Core.IImGearRGBQuad Color { get, set }

Value:

ImGearRGBQuad Structure object.

Default value:

N/A

See Also:

ImGearRGBQuad Structure


NumberOfPoints Property

32-bit
64-bit
CF
P
P

Description:

The actual number of mark's points.

Declaration:

public int NumberOfPoints { get }

Value:

Any integer value.

Default value:

N/A


Opacity Property

32-bit
64-bit
CF
P
P

Description:

The opacity of the mark.

Declaration:

public int Opacity { get, set }

Value:

Any integer value.

Default value:

127


Points Property

32-bit
64-bit
CF
P
P

Description:

The raw points array.

Declaration:

public ImageGear.Core.ImGearPoint[] Points { get }

Value:

ImGearPoint Structure array.

Default value:

N/A

See Also:

ImGearPoint Structure


Style Property

32-bit
64-bit
CF
P
P

Description:

The style of the mark.

Declaration:

public ImageGear.ART.ImGearARTPenStyle Style { get, set }

Value:

ImGearARTPenStyle Enumeration value.

Default value:

N/A

See Also:

ImGearARTPenStyle Enumeration


Tension Property

32-bit
64-bit
CF
P
P

Description:

The tension of the mark.

Declaration:

public float Tension { get, set }

Value:

Any float value.

Default value:

N/A


Width Property

32-bit
64-bit
CF
P
P

Description:

The width of the mark.

Declaration:

public int Width { get, set }

Value:

Any integer value.

Default value:

N/A


ImGearARTCurve Methods

The ImGearARTCurve Class of the ImageGear.ART Namespace has the following methods:

Methods
Name
Description
GetPoint Method
Gets the point with specified index.
SetPoint Method
Sets the point with specified index.


GetPoint Method

32-bit
64-bit
CF
P
P

Description:

Gets the point with the specified index.

Declaration:

public ImageGear.Core.ImGearPoint GetPoint ( Int nIndex )

Parameters:

Name
Type
Description
nIndex
Int
Index of the point.

Return Value:

ImGearPoint Structure

See Also:

ImGearPoint Structure


SetPoint Method

32-bit
64-bit
CF
P
P

Description:

Sets the point at specified index.

Declaration:

public void SetPoint ( Int nIndex , ImageGear.Core.ImGearPoint pt )

Parameters:

Name
Type
Description
nIndex
Int
Index of the point.
pt
ImGearPoint Structure
The point to set.

Return Value:

None

See Also:

ImGearPoint Structure


ImGearARTEllipse Class

32-bit
64-bit
CF
P
P

Description:

ART Ellipse mark.

Declaration:

public class ImGearARTEllipse : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTEllipse Constructor
Creates a new instance of ImGearARTEllipse object.
ImGearARTEllipse Constructor
Creates a new instance of ImGearARTEllipse object.
ImGearARTEllipse Constructor
Creates a new instance of ImGearARTEllipse object.

Properties
Name
Description
Border Property
Mark border.
FillColor Property
FillColor of the mark.
Height Property
Height of the mark.
Opacity Property
Opacity of the mark.
Width Property
Width of the mark.
X Property
The x coordinate of the left-top point of the mark.
Y Property
The y coordinate of the left-top point of the mark.

Sample Code:

C#
// Setup rectangle for the ellipse mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 300, 100);
// Setup color for the ellipse.
ImGearRGBQuad igRGBQuadEllipse = new ImGearRGBQuad(40, 40, 200);
// Setup color for the ellipse border.
ImGearRGBQuad igRGBQuadEllipseBorder = new ImGearRGBQuad(60, 60, 255);
// Create ellipse with a solid 4 pixel border and opacity of 127 (50%)
ImGearARTEllipse igARTEllipse = new ImGearARTEllipse(
    igRectangle, igRGBQuadEllipse, igRGBQuadEllipseBorder, ImGearARTPenStyle.SOLID, 4, 127
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTEllipse, ImGearARTCoordinatesType.IMAGE_COORD);

VB.NET
' Setup rectangle for the ellipse mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 300, 100)
' Setup color for the ellipse.
Dim igRGBQuadEllipse As New ImGearRGBQuad(40, 40, 200)
' Setup color for the ellipse border.
Dim igRGBQuadEllipseBorder As New ImGearRGBQuad(60, 60, 255)
' Create ellipse with a solid 4 pixel border and opacity of 127 (50%)
Dim igARTEllipse As New ImGearARTEllipse( _
 igRectangle, igRGBQuadEllipse, igRGBQuadEllipseBorder, ImGearARTPenStyle.SOLID, 4, 127)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTEllipse, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTEllipse Constructors

The ImGearARTEllipse Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTEllipse Constructor
Creates a new instance of ImGearARTEllipse object.
ImGearARTEllipse Constructor
Creates a new instance of ImGearARTEllipse object.
ImGearARTEllipse Constructor
Creates a new instance of ImGearARTEllipse object.


ImGearARTEllipse Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTEllipse Class object.

Declaration:

public ImGearARTEllipse ( ImageGear.Core.IImGearRectangle Rect ,
ImageGear.Core.IImGearRGBQuad FillColor )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
The mark rectangle.
FillColor
ImGearRGBQuad Structure
FillColor of the mark.

Return Value:

The new instance of ImGearARTEllipse Class object.

See Also:

ImGearRGBQuad Structure

ImGearRectangle Structure


ImGearARTEllipse Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTEllipse Class object.

Declaration:

public ImGearARTEllipse ( ImageGear.Core.IImGearRectangle Rect ,
ImageGear.Core.IImGearRGBQuad BorderColor , ImageGear.ART.ImGearARTPenStyle BorderStyle ,
Int BorderWidth )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
The mark rectangle.
BorderColor
ImGearRGBQuad Structure
Border color of the mark.
BorderStyle
ImGearARTPenStyle Enumeration
Border style of the mark.
BorderWidth
Int
Width of the border line.

Return Value:

The new instance of ImGearARTEllipse Class object.

See Also:

ImGearRGBQuad Structure

ImGearRectangle Structure

ImGearARTPenStyle Enumeration


ImGearARTEllipse Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTEllipse Class object.

Declaration:

public ImGearARTEllipse ( ImageGear.Core.IImGearRectangle Rect ,
ImageGear.Core.IImGearRGBQuad FillColor , ImageGear.Core.IImGearRGBQuad BorderColor ,
ImageGear.ART.ImGearARTPenStyle BorderStyle , Int BorderWidth , Int Opacity )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
The mark rectangle.
FillColor
ImGearRGBQuad Structure
Fill color of the mark.
BorderColor
ImGearRGBQuad Structure
Border color of the mark.
BorderStyle
ImGearARTPenStyle Enumeration
Border style of the mark.
BorderWidth
Int
Border width of the mark.
Opacity
Int
Opacity of the mark.

Return Value:

The new instance of ImGearARTEllipse Class object.

See Also:

ImGearRGBQuad Structure

ImGearRectangle Structure

ImGearARTPenStyle Enumeration


ImGearARTEllipse Properties

The ImGearARTEllipse Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
Border Property
Mark border.
FillColor Property
FillColor of the mark.
Height Property
Height of the mark.
Opacity Property
Opacity of the mark.
Width Property
Width of the mark.
X Property
The x coordinate of the left-top point of the mark.
Y Property
The y coordinate of the left-top point of the mark.


Border Property

32-bit
64-bit
CF
P
P

Description:

The border of the mark.

Declaration:

public ImageGear.ART.ImGearARTBorder Border { get, set }

Value:

ImGearARTBorder Class object.

Default value:

N/A

See Also:

ImGearARTBorder Class


FillColor Property

32-bit
64-bit
CF
P
P

Description:

The fill color of the mark.

Declaration:

public ImageGear.Core.IImGearRGBQuad FillColor { get, set }

Value:

ImGearRGBQuad Structure object.

Default value:

N/A

See Also:

ImGearRGBQuad Structure


Opacity Property

32-bit
64-bit
CF
P
P

Description:

The opacity of the mark.

Declaration:

public int Opacity { get, set }

Value:

Integer value.

Default value:

255


X Property

32-bit
64-bit
CF
P
P

Description:

The X coordinate of the top-left point of the mark.

Declaration:

public int Y { get, set }

Value:

Integer value.

Default value:

N/A


Y Property

32-bit
64-bit
CF
P
P

Description:

The Y coordinate of the top-left point of the mark.

Declaration:

public int Y { get, set }

Value:

Integer value.

Default value:

N/A


ImGearARTEncryption Class

32-bit
64-bit
CF
P
P

Description:

ART Encryption mark.

Declaration:

public class ImGearARTEncryption : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTEncryption Constructor
Creates a new instance of ImGearARTEncryption object.

Properties
Name
Description
Applied Property
Determines whether Encryption is applied or not.
Height Property
Height of the Encryption.
Password Property
Encryption password.
Width Property
Width of the encryption.
X Property
The X coordinate of the top-left point of the encryption.
Y Property
The Y coordinate of the top-left point of the encryption.

Sample Code:

C#
// Setup rectangle for the encryption mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 300, 300);
// Create the encryption mark.
ImGearARTEncryption igARTEncryption = new ImGearARTEncryption(
    igRectangle, "abcdefg"
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTEncryption, ImGearARTCoordinatesType.IMAGE_COORD);

VB.NET
' Setup rectangle for the encryption mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 300, 300)
' Create the encryption mark.
Dim igARTEncryption As New ImGearARTEncryption( _
 igRectangle, "abcdefg")
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTEncryption, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTEncryption Constructors

The ImGearARTEncryption Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTEncryption Constructor
Creates a new instance of ImGearARTEncryption object.


ImGearARTEncryption Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTEncryption Class object.

Declaration:

public ImGearARTEncryption ( ImageGear.Core.IImGearRectangle Rect , String Password )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
The mark rectangle.
Password
String
Encryption password.

Return Value:

The new instance of ImGearARTEncryption Class object.

See Also:

ImGearRectangle Structure


ImGearARTEncryption Properties

The ImGearARTEncryption Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
Applied Property
Determines whether Encryption is applied or not.
Height Property
Height of the Encryption.
Password Property
Encryption password.
Width Property
Width of the encryption.
X Property
The X coordinate of the top-left point of the encryption.
Y Property
The Y coordinate of the top-left point of the encryption.


Applied Property

32-bit
64-bit
CF
P
P

Description:

If True, encryption is applied, False - otherwise.

Declaration:

public bool Applied { get, set }

Value:

True, False

Default value:

True


Height Property

32-bit
64-bit
CF
P
P

Description:

Height of the encryption.

Declaration:

public int Height { get, set }

Value:

Integer value.

Default value:

N/A


Password Property

32-bit
64-bit
CF
P
P

Description:

The encryption password.

Declaration:

public string Password { get, set }

Value:

Any string.

Default value:

N/A


Width Property

32-bit
64-bit
CF
P
P

Description:

The width of the encryption.

Declaration:

public int Width { get, set }

Value:

Integer value.

Default value:

N/A


X Property

32-bit
64-bit
CF
P
P

Description:

The X coordinate of the top-left point of the encryption.

Declaration:

public int x { get, set }

Value:

Integer value.

Default value:

N/A


Y Property

32-bit
64-bit
CF
P
P

Description:

The Y coordinate of the top-left point of the encryption.

Declaration:

public int Y { get, set }

Value:

Integer value.

Default value:

N/A


ImGearARTFilledEllipse Class

32-bit
64-bit
CF
P
P

Description:

Legacy ART Filled Ellipse mark.

Declaration:

public class ImGearARTFilledEllipse : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTFilledEllipse Constructor
Creates a new instance of ImGearARTFilledEllipse object.
ImGearARTFilledEllipse Constructor
Creates a new instance of ImGearARTFilledEllipse object.

Properties
Name
Description
FillColor Property
Fill color of the mark.
Height Property
Height of the mark.
Highlight Property
Highlight of the mark.
Width Property
Width of the mark.
X Property
The X coordinate of the top-left point of the mark.
Y Property
The Y coordinate of the top-left point of the mark.

Sample Code:

C#
// Setup rectangle for the ellipse mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 300, 100);
// Setup color for the ellipse.
ImGearRGBQuad igRGBQuadEllipse = new ImGearRGBQuad(40, 40, 200);
// Create ellipse with highlight on.
ImGearARTFilledEllipse igARTFilledEllipse = new ImGearARTFilledEllipse(
    igRectangle, igRGBQuadEllipse, true
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTFilledEllipse, ImGearARTCoordinatesType.IMAGE_COORD);

VB.NET
' Setup rectangle for the ellipse mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 300, 100)
' Setup color for the ellipse.
Dim igRGBQuadEllipse As New ImGearRGBQuad(40, 40, 200)
' Create ellipse with highlight on.
Dim igARTFilledEllipse As New ImGearARTFilledEllipse( _
 igRectangle, igRGBQuadEllipse, True)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTFilledEllipse, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTFilledEllipse Constructors

The ImGearARTFilledEllipse Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTFilledEllipse Constructor
Creates a new instance of ImGearARTFilledEllipse object.
ImGearARTFilledEllipse Constructor
Creates a new instance of ImGearARTFilledEllipse object.


ImGearARTFilledEllipse Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTFilledEllipse Class object.

Declaration:

public ImGearARTFilledEllipse ( ImageGear.Core.IImGearRectangle Rect ,
ImageGear.Core.IImGearRGBQuad FillColor )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
The mark's rectangle.
FillColor
ImGearRGBQuad Structure
Fill color of the mark.

Return Value:

The new instance of ImGearARTFilledEllipse Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure


ImGearARTFilledEllipse Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTFilledEllipse Class object.

Declaration:

public ImGearARTFilledEllipse ( ImageGear.Core.IImGearRectangle Rect ,
ImageGear.Core.IImGearRGBQuad FillColor , Bool Highlight )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
The mark's rectangle.
FillColor
ImGearRGBQuad Structure
Fill color of the mark.
Highlight
Bool
Shows whether mark is highlighted or not.

Return Value:

The new instance of ImGearARTFilledEllipse Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure


ImGearARTFilledEllipse Properties

The ImGearARTFilledEllipse Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
FillColor Property
Fill color of the mark.
Height Property
Height of the mark.
Highlight Property
Highlight of the mark.
Width Property
Width of the mark.
X Property
The X coordinate of the top-left point of the mark.
Y Property
The Y coordinate of the top-left point of the mark.


FillColor Property

32-bit
64-bit
CF
P
P

Description:

Fill color of the mark.

Declaration:

public ImageGear.Core.IImGearRGBQuad FillColor { get, set }

Value:

ImGearRGBQuad Structure object.

Default Value:

N/A

See Also:

ImGearRGBQuad Structure


Highlight Property

32-bit
64-bit
CF
P
P

Description:

Determines whether the mark is highlighted.

Declaration:

public bool Highlight { get, set }

Value:

True, False

Default value:

N/A


X Property

32-bit
64-bit
CF
P
P

Description:

The X coordinate of the top-left point of the mark.

Declaration:

public int X { get, set }

Value:

Integer value.

Default value:

N/A


ImGearARTFilledPolygon Class

32-bit
64-bit
CF
P
P

Description:

Legacy ART Filled Polygon mark.

Declaration:

public class ImGearARTFilledPolygon : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTFilledPolygon Constructor
Creates a new instance of ImGearARTFilledPolygon object.
ImGearARTFilledPolygon Constructor
Creates a new instance of ImGearARTFilledPolygon object.

Properties
Name
Description
FillColor Property
Fill color of the mark.
Highlight Property
Determines whether the mark is highlighted.
NumberOfPoints Property
Actual number of points.
Points Property
Raw points array.

Methods
Name
Description
GetPoint Method
Gets point with specified index.
SetPoint Method
Sets point at specified index.

Sample Code:

C#
// Create an array of 5 points for the polygon.
ImGearPoint[] igPoints = new ImGearPoint[5];
igPoints[0] = new ImGearPoint(20, 20);
igPoints[1] = new ImGearPoint(200, 40);
igPoints[2] = new ImGearPoint(200, 60);
igPoints[3] = new ImGearPoint(120, 120);
igPoints[4] = new ImGearPoint(20, 40);
// Setup color for the polygon.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(40, 200, 40);
// Create polygon with highlight on.
ImGearARTFilledPolygon igARTFilledPolygon = new ImGearARTFilledPolygon(
    igPoints, igRGBQuad, true
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTFilledPolygon, ImGearARTCoordinatesType.IMAGE_COORD);

VB.NET
' Create an array of 5 points for the polygon.
Dim igPoints As ImGearPoint() = New ImGearPoint(4) {}
igPoints(0) = New ImGearPoint(20, 20)
igPoints(1) = New ImGearPoint(200, 40)
igPoints(2) = New ImGearPoint(200, 60)
igPoints(3) = New ImGearPoint(120, 120)
igPoints(4) = New ImGearPoint(20, 40)
' Setup color for the polygon.
Dim igRGBQuad As New ImGearRGBQuad(40, 200, 40)
' Create polygon with highlight on.
Dim igARTFilledPolygon As New ImGearARTFilledPolygon( _
 igPoints, igRGBQuad, True)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTFilledPolygon, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTFilledPolygon Constructors

The ImGearARTFilledPolygon Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTFilledPolygon Constructor
Creates a new instance of ImGearARTFilledPolygon object.
ImGearARTFilledPolygon Constructor
Creates a new instance of ImGearARTFilledPolygon object.


ImGearARTFilledPolygon Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTFilledPolygon Class object.

Declaration:

public ImGearARTFilledPolygon ( ImageGear.Core.ImGearPoint[] Points,
ImageGear.Core.IImGearRGBQuad FillColor )

Parameters:

Name
Type
Description
Points
ImGearPoint Structure
Raw points array to create a polygon from.
FillColor
ImGearRGBQuad Structure
Fill color of the mark.

Return Value:

The new instance of ImGearARTFilledPolygon Class object.

See Also:

ImGearPoint Structure

ImGearRGBQuad Structure


ImGearARTFilledPolygon Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTFilledPolygon Class object.

Declaration:

public ImGearARTFilledPolygon ( ImageGear.Core.ImGearPoint[] Points ,
ImageGear.Core.IImGearRGBQuad FillColor , Bool Highlight )

Parameters:

Name
Type
Description
Rect
ImGearPoint Structure
Raw points array to create a polygon from.
FillColor
ImGearRGBQuad Structure
Fill color of the mark.
Highlight
Bool
Shows whether mark is highlighted or not.

Return Value:

The new instance of ImGearARTFilledPolygon Class object.

See Also:

ImGearPoint Structure

ImGearRGBQuad Structure


ImGearARTFilledPolygon Properties

The ImGearARTFilledPolygon Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
FillColor Property
Fill color of the mark.
Highlight Property
Determines whether the mark is highlighted.
NumberOfPoints Property
Actual number of points.
Points Property
Raw points array.


FillColor Property

32-bit
64-bit
CF
P
P

Description:

Determines the fill color of the mark.

Declaration:

public ImageGear.Core.IImGearRGBQuad FillColor { get, set }

Value:

ImGearRGBQuad Structure object.

Default value:

N/A

See Also:

ImGearRGBQuad Structure


Highlight Property

32-bit
64-bit
CF
P
P

Description:

Determines whether the mark is highlighted.

Declaration:

public bool Highlight { get, set }

Value:

True, False

Default value:

False


NumberOfPoints Property

32-bit
64-bit
CF
P
P

Description:

Determines the number of points for the polygon.

Declaration:

public int NumberOfPoints { get, set }

Value:

Integer number.

Default value:

N/A


Points Property

32-bit
64-bit
CF
P
P

Description:

Raw points array.

Declaration:

public ImageGear.Core.ImGearPoint[] Points { get }

Value:

ImGearPoint Structure array.

Default value:

N/A

See Also:

ImGearPoint Structure


ImGearARTFilledPolygon Methods

The ImGearARTFilledPolygon Class of the ImageGear.ART Namespace has the following methods:

Methods
Name
Description
GetPoint Method
Gets point with specified index.
SetPoint Method
Sets point at specified index.


GetPoint Method

32-bit
64-bit
CF
P
P

Description:

This method gets point with specified index.

Declaration:

public ImageGear.Core.ImGearPoint GetPoint ( Int Index )

Parameters:

Name
Type
Description
Index
Int
Actual index of the point to get.

Return Value:

ImGearPoint Structure array.

See Also:

ImGearPoint Structure


SetPoint Method

32-bit
64-bit
CF
P
P

Description:

This method sets point at the specified index.

Declaration:

public void SetPoint ( Int Index , ImageGear.Core.ImGearPoint Point )

Parameters:

Name
Type
Description
Index
Int
Index to set at.
Point
ImGearPoint Structure
Point to set.

Return Value:

None.

See Also:

ImGearPoint Structure


ImGearARTFilledRectangle Class

32-bit
64-bit
CF
P
P

Description:

Legacy ART Filled Rectangle mark.

Declaration:

public class ImGearARTFilledRectangle : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTFilledRectangle Constructor
Creates a new instance of ImGearARTFilledRectangle object.
ImGearARTFilledRectangle Constructor
Creates a new instance of ImGearARTFilledRectangle object.

Properties
Name
Description
FillColor Property
Fill color of the mark.
Height Property
Height of the mark.
Highlight Property
Determines whether the mark is highlighted.
Width Property
Width of the mark.
X Property
The X coordinate of the top-left point of the mark.
Y Property
The Y coordinate of the top-left point of the mark.

Sample Code:

C#
// Setup rectangle for the rectangle mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 300, 100);
// Setup color for the rectangle.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(40, 200, 40);
// Create rectangle with highlight on.
ImGearARTFilledRectangle igARTFilledRectangle = new ImGearARTFilledRectangle(
    igRectangle, igRGBQuad, true
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTFilledRectangle, ImGearARTCoordinatesType.IMAGE_COORD);

VB.NET
' Setup rectangle for the rectangle mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 300, 100)
' Setup color for the rectangle.
Dim igRGBQuad As New ImGearRGBQuad(40, 200, 40)
' Create rectangle with highlight on.
Dim igARTFilledRectangle As New ImGearARTFilledRectangle( _
 igRectangle, igRGBQuad, True)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTFilledRectangle, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTFilledRectangle Constructors

The ImGearARTFilledRectangle Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTFilledRectangle Constructor
Creates a new instance of ImGearARTFilledRectangle object.
ImGearARTFilledRectangle Constructor
Creates a new instance of ImGearARTFilledRectangle object.


ImGearARTFilledRectangle Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTFilledRectangle Class object.

Declaration:

public ImGearARTFilledRectangle ( ImageGear.Core.IImGearRectangle Rect ,
ImageGear.Core.IImGearRGBQuad FillColor )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
The mark's rectangle.
FillColor
ImGearRGBQuad Structure
Fill color of the mark.

Return Value:

The new instance of ImGearARTFilledRectangle Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure


ImGearARTFilledRectangle Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTFilledRectangle Class object.

Declaration:

public ImGearARTFilledEllipse ( ImageGear.Core.IImGearRectangle Rect ,
ImageGear.Core.IImGearRGBQuad FillColor , Bool Highlight )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
The mark's rectangle.
FillColor
ImGearRGBQuad Structure
Fill color of the mark.
Highlight
Bool
Shows whether mark is highlighted or not.

Return Value:

The new instance of ImGearARTFilledRectangle Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure


ImGearARTFilledRectangle Properties

The ImGearARTFilledRectangle Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
FillColor Property
Fill color of the mark.
Height Property
Height of the mark.
Highlight Property
Determines whether the mark is highlighted.
Width Property
Width of the mark.
X Property
The X coordinate of the top-left point of the mark.
Y Property
The Y coordinate of the top-left point of the mark.


FillColor Property

32-bit
64-bit
CF
P
P

Description:

Fill color of the mark.

Declaration:

public ImageGear.Core.IImGearRGBQuad FillColor { get, set }

Value:

ImGearRGBQuad Structure object.

Default value:

N/A

See Also:

ImGearRGBQuad Structure


Highlight Property

32-bit
64-bit
CF
P
P

Description:

Determines whether the mark is highlighted.

Declaration:

public bool Highlight { get, set }

Value:

True, False.

Default value:

N/A


ImGearARTFreeLine Class

32-bit
64-bit
CF
P
P

Description:

Legacy ART Freehand line mark.

Declaration:

public class ImGearARTFreeLine : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTFreeLine Constructor
Creates the new instance of ImGearARTFreeLine object.
ImGearARTFreeLine Constructor
Creates the new instance of ImGearARTFreeLine object.

Properties
Name
Description
Color Property
The color of the line.
Highlight Property
Determines whether the mark is highlighted.
IsClosed Property
Determines whether the line is closed.
NumberOfPoints Property
Actual number of points on the line mark.
Points Property
Raw points array.
Width Property
The width of the line.

Methods
Name
Description
GetPoint Method
Gets point with specified index.
SetPoint Method
Sets point at specified index.

Sample Code:

C#
// Create an array of 5 points for the line.
ImGearPoint[] igPoints = new ImGearPoint[5];
igPoints[0] = new ImGearPoint(0, 0);
igPoints[1] = new ImGearPoint(20, 40);
igPoints[2] = new ImGearPoint(40, 40);
igPoints[3] = new ImGearPoint(80, 40);
igPoints[4] = new ImGearPoint(120, 120);
// Setup color for the line.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(40, 40, 200);
// Create line with a width of 4, highlight off, and not closed.
ImGearARTFreeLine igARTFreeLine = new ImGearARTFreeLine(
    igPoints, igRGBQuad, 4, false, false
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTFreeLine, ImGearARTCoordinatesType.IMAGE_COORD);

VB.NET
' Create an array of 5 points for the line.
Dim igPoints As ImGearPoint() = New ImGearPoint(4) {}
igPoints(0) = New ImGearPoint(0, 0)
igPoints(1) = New ImGearPoint(20, 40)
igPoints(2) = New ImGearPoint(40, 40)
igPoints(3) = New ImGearPoint(80, 40)
igPoints(4) = New ImGearPoint(120, 120)
' Setup color for the line.
Dim igRGBQuad As New ImGearRGBQuad(40, 40, 200)
' Create line with a width of 4, highlight off, and not closed.
Dim igARTFreeLine As New ImGearARTFreeLine( _
 igPoints, igRGBQuad, 4, False, False)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTFreeLine, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTFreeLine Constructors

The ImGearARTFreeLine Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTFreeLine Constructor
Creates the new instance of ImGearARTFreeLine object.
ImGearARTFreeLine Constructor
Creates the new instance of ImGearARTFreeLine object.


ImGearARTFreeLine Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTFreeLine Class object.

Declaration:

public ImGearARTFreeLine ( ImageGear.Core.ImGearPoint[] Points ,
ImageGear.Core.IImGearRGBQuad Color )

Parameters:

Name
Type
Description
Points
ImGearPoint Structure
Points on the line.
Color
ImGearRGBQuad Structure
Color of the line.

Return Value:

The new instance of ImGearARTFreeLine Class object.

See Also:

ImGearPoint Structure

ImGearRGBQuad Structure


ImGearARTFreeLine Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTFreeLine Class object.

Declaration:

public ImGearARTFreeLine ( ImageGear.Core.ImGearPoint[] Points ,
ImageGear.Core.IImGearRGBQuad Color , Int Width , Bool Highlight , Bool IsClosed )

Parameters:

Name
Type
Description
Points
ImGearPoint Structure
The mark's points.
Color
ImGearRGBQuad Structure
Fill color of the mark.
Width
Int
Width of the line.
Highlight
Bool
Shows whether mark is highlighted or not.
IsClosed
Bool
True if the line is closed, False - otherwise.

Return Value:

The new instance of ImGearARTFreeLine Class object.

See Also:

ImGearPoint Structure

ImGearRGBQuad Structure


ImGearARTFreeLine Properties

The ImGearARTFreeLine Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
Color Property
The color of the line.
Highlight Property
Determines wether the mark is highlighted.
IsClosed Property
Determines whether the line is closed.
NumberOfPoints Property
Actual number of points on the line mark.
Points Property
Raw points array.
Width Property
The width of the line.


Color Property

32-bit
64-bit
CF
P
P

Description:

Color of the line.

Declaration:

public ImageGear.Core.IImGearRGBQuad Color { get, set }

Value:

ImGearRGBQuad Structure object.

Default value:

N/A

See Also:

ImGearRGBQuad Structure


Highlight Property

32-bit
64-bit
CF
P
P

Description:

Determines whether the line is highlighted or not.

Declaration:

public bool Highlight { get, set }

Value:

True, False.

Default value:

N/A


IsClosed Property

32-bit
64-bit
CF
P
P

Description:

Determines whether the line is closed or not.

Declaration:

public bool IsClosed { get, set }

Value:

True, False.

Default value:

N/A


NumberOfPoints Property

32-bit
64-bit
CF
P
P

Description:

Actual number of points of the freehand line.

Declaration:

public int NumberOfPoints { get, set }

Value:

Integer value.

Default value:

N/A


Points Property

32-bit
64-bit
CF
P
P

Description:

Raw points array.

Declaration:

public ImageGear.Core.ImGearPoint[] Points { get, set }

Value:

ImGearPoint Structure array.

Default value:

N/A

See Also:

ImGearPoint Structure


Width Property

32-bit
64-bit
CF
P
P

Description:

Width of the line.

Declaration:

public int Width { get, set }

Value:

Integer value.

Default value:

N/A


ImGearARTFreeLine Methods

The ImGearARTFreeLine Class of the ImageGear.ART Namespace has the following methods:

Methods
Name
Description
GetPoint Method
Gets point with specified index.
SetPoint Method
Sets point at specified index.


GetPoint Method

32-bit
64-bit
CF
P
P

Description:

This method gets the point specified by Index.

Declaration:

public ImageGear.Core.ImGearPoint GetPoint ( Int Index )

Parameters:

Name
Type
Description
Index
Int
Index of the point.

Return Value:

ImGearPoint Structure

See Also:

ImGearPoint Structure


SetPoint Method

32-bit
64-bit
CF
P
P

Description:

This method sets the point at the specified index.

Declaration:

public void SetPoint ( Int Index , ImageGear.Core.ImGearPoint Point )

Parameters:

Name
Type
Description
Index
Int
Index to set the point at.
Point
ImGearPoint Structure
Point to set.

Return Value:

None.

See Also:

ImGearPoint Structure


ImGearARTGroup Class

32-bit
64-bit
CF
P
P

Description:

Collection of ART marks united into a group. This class provides methods and properties general for the entire group.

Declaration:

public class ImGearARTGroup

Members:

Constructors
Name
Description
ImGearARTGroup Constructor
Creates a new instance of ImGearARTGroup object.

Properties
Name
Description
Access Property
Provides access to the group.
Count Property
Count of marks in the group.
Description Property
Group description.
Name Property
Group name.
this Property
Indexed property for accessing individual mark from group.

Methods
Name
Description
BringToFront Method
Moves a group of marks to the top of the Z-Order.
Copy Method
Copies a group of marks to the Windows clipboard.
Cut Method
Cuts a group of marks to the Windows clipboard.
GetEnumerator Method
Returns ImGearARTGroupEnumerator Class.
RemoveAll Method
Removes all marks from the group.
RemoveAt Method
Removes the mark specified by Index from the group.
Select Method
Selects/Deselects a group of marks.
SendToBack Method
Moves a group of marks to the bottom of the Z-Order.

Sample Code:

C#
// Create and add some groups to the Groups array.
igARTPage.Groups.Add(new ImGearARTGroup("Group1", "First test group"));
igARTPage.Groups.Add(new ImGearARTGroup("Group2", "Second test group"));
// Create start and end point points.
ImGearPoint igPointStart = new ImGearPoint();
ImGearPoint igPointEnd = new ImGearPoint();
// Setup color for the line.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(40, 40, 200);
// Create a series of diagonal lines adding each one to the 2 groups,
// alternating between them.
ImGearARTLine igARTLine;
for (int i = 0; i < 20; i++)
{
    igPointStart.X = i * 10;
    igPointStart.Y = 10;
    igPointEnd.X = i * 10 + 100;
    igPointEnd.Y = 110;
    igARTLine = new ImGearARTLine(igPointStart, igPointEnd, igRGBQuad);
    // Add the annotation to one of the 2 groups.
    if (i % 2 == 0)
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group1");
    else
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group2");
}
// Select Group1
igARTPage.Groups["Group1"].Select(true);
// Delete Group2
MessageBox.Show("Deleting second group of lines.", "Deleting...");
igARTPage.Groups["Group2"].RemoveAll();

VB.NET
' Create and add some groups to the Groups array.
igARTPage.Groups.Add(New ImGearARTGroup("Group1", "First test group"))
igARTPage.Groups.Add(New ImGearARTGroup("Group2", "Second test group"))
' Create start and end point points.
Dim igPointStart As New ImGearPoint()
Dim igPointEnd As New ImGearPoint()
' Setup color for the line.
Dim igRGBQuad As New ImGearRGBQuad(40, 40, 200)
' Create a series of diagonal lines adding each one to the 2 groups,
' alternating between them.
Dim igARTLine As ImGearARTLine
For i As Integer = 0 To 19
    igPointStart.X = i * 10
    igPointStart.Y = 10
    igPointEnd.X = i * 10 + 100
    igPointEnd.Y = 110
    igARTLine = New ImGearARTLine(igPointStart, igPointEnd, igRGBQuad)
    ' Add the annotation to one of the 2 groups.
    If i Mod 2 = 0 Then
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group1")
    Else
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group2")
    End If
Next
' Select Group1
igARTPage.Groups("Group1").[Select](True)
' Delete Group2
MessageBox.Show("Deleting second group of lines.", "Deleting...")
igARTPage.Groups("Group2").RemoveAll()


ImGearARTGroup Constructors

The ImGearARTGroup Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTGroup Constructor
Creates a new instance of ImGearARTGroup object.


ImGearARTGroup Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTGroup Class object.

Declaration:

public ImGearARTGroup ( String strName , String strDescription )

Parameters:

Name
Type
Description
strName
String
Group name.
strDescription
String
Group description.

Return Value:

The new instance of ImGearARTGroup Class object.


ImGearARTGroup Properties

The ImGearARTGroup Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
Access Property
Provides access to the group.
Count Property
Count of marks in the group.
Description Property
Group description.
Name Property
Group name.
this Property
Indexed property for accessing individual mark from group.


Access Property

32-bit
64-bit
CF
P
P

Description:

Provides access to the group.

Declaration:

public ImageGear.ART.ImGearARTAccess Access { get, set }

Value:

ImGearARTAccess Enumeration value.

Default value:

N/A

See Also:

ImGearARTAccess Enumeration


Count Property

32-bit
64-bit
CF
P
P

Description:

Count of the marks in the group.

Declaration:

public int Count { get }

Value:

Integer value.

Default value:

N/A


Description Property

32-bit
64-bit
CF
P
P

Description:

ART group decription.

Declaration:

public string Description { get, set }

Value:

String description.

Default value:

N/A


Name Property

32-bit
64-bit
CF
P
P

Description:

The name of the group.

Declaration:

public string Name { get, set }

Value:

String name.

Default value:

N/A


this Property

32-bit
64-bit
CF
P
P

Description:

Indexed property for accessing an individual mark from a group.

Declaration:

public const ImageGear.ART.ImGearARTMark this { get, set }

Value:

ImGearARTMark Class object.

Default value:

N/A

See Also:

ImGearARTMark Class


ImGearARTGroup Methods

The ImGearARTGroup Class of the ImageGear.ART Namespace has the following methods:

Methods
Name
Description
BringToFront Method
Moves a group of marks to the top of the Z-Order.
Copy Method
Copies a group of marks to the Windows clipboard.
Cut Method
Cuts a group of marks to the Windows clipboard.
GetEnumerator Method
Returns ImGearARTGroupEnumerator Class.
RemoveAll Method
Removes all marks from the group.
RemoveAt Method
Removes the mark specified by Index from the group.
Select Method
Selects/Deselects a group of marks.
SendToBack Method
Moves a group of marks to the bottom of the Z-Order.


BringToFront Method

32-bit
64-bit
CF
P
P

Description:

Moves a group of marks to the top of the Z-Order.

Declaration:

public void BringToFront( )

Return Value:

None


Copy Method

32-bit
64-bit
CF
P
P

Description:

Copies a group of marks to the Windows clipboard.

Declaration:

public void Copy ( )

Return Value:

None


Cut Method

32-bit
64-bit
CF
P
P

Description:

Cuts a group of marks to the Windows clipboard.

Declaration:

public void Cut ( )

Return Value:

None


GetEnumerator Method

32-bit
64-bit
CF
P
P

Description:

This method returns ImGearARTGroupEnumerator Class.

Declaration:

public ImageGear.ART.ImGearARTGroupEnumerator GetEnumerator()

Return Value:

ImGearARTGroupEnumerator Class

See Also:

ImGearARTGroupEnumerator Class


RemoveAll Method

32-bit
64-bit
CF
P
P

Description:

This method removes all marks from the group.

Declaration:

public void RemoveAll (  )

Return Value:

None


RemoveAt Method

32-bit
64-bit
CF
P
P

Description:

This method removes the mark specified by Index from the group.

Declaration:

public void RemoveAt ( Int nIndex )

Parameters:

Name
Type
Description
Index
Int
Index of the mark in the group.

Return Value:

None.


Select Method

32-bit
64-bit
CF
P
P

Description:

Selects/Deselects a group of marks.

Declaration:

public void Select ( Bool State )

Parameters:

Name
Type
Description
State
Bool
True - selects marks, False - deselects.

Return Value:

None


SendToBack Method

32-bit
64-bit
CF
P
P

Description:

Moves a group of marks to the bottom of the Z-Order.

Declaration:

public void SendToBack ( )

Return Value:

None


ImGearARTGroupArray Class

32-bit
64-bit
CF
P
P

Description:

Array of ART groups.

Declaration:

public class ImGearARTGroupArray

Members:

Properties
Name
Description
Count Property
Count of ART groups in the array.
this Property
Indexed property for accessing individual group by name.
this Property
Indexed property for accessing individual group by index.

Methods
Name
Description
Add Method
Adds an ART group to the array.
Find Method
Finds the group specified by name in the array.
GetEnumerator Method
Returns an IEnumerator for the Array.
GetGroup Method
Gets the group specified by name.
Remove Method
Removes the specified group from array.
Remove Method
Removes a group with specified Name from array.
RemoveAll Method
Removes all groups from the array.
RemoveAt Method
Removes the group specified by Index from the array.

Sample Code:

C#
// Create and add some groups to the Groups array.
igARTPage.Groups.Add(new ImGearARTGroup("Group1", "First test group"));
igARTPage.Groups.Add(new ImGearARTGroup("Group2", "Second test group"));
// Create start and end point points.
ImGearPoint igPointStart = new ImGearPoint();
ImGearPoint igPointEnd = new ImGearPoint();
// Setup color for the line.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(40, 40, 200);
// Create a series of diagonal lines adding each one to the 2 groups,
// alternating between them.
ImGearARTLine igARTLine;
for (int i = 0; i < 20; i++)
{
    igPointStart.X = i * 10;
    igPointStart.Y = 10;
    igPointEnd.X = i * 10 + 100;
    igPointEnd.Y = 110;
    igARTLine = new ImGearARTLine(igPointStart, igPointEnd, igRGBQuad);
    // Add the annotation to one of the 2 groups.
    if (i % 2 == 0)
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group1");
    else
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group2");
}
// Select Group1
igARTPage.Groups["Group1"].Select(true);
// Delete Group2
MessageBox.Show("Deleting second group of lines.", "Deleting...");
igARTPage.Groups["Group2"].RemoveAll();

VB.NET
' Create and add some groups to the Groups array.
igARTPage.Groups.Add(New ImGearARTGroup("Group1", "First test group"))
igARTPage.Groups.Add(New ImGearARTGroup("Group2", "Second test group"))
' Create start and end point points.
Dim igPointStart As New ImGearPoint()
Dim igPointEnd As New ImGearPoint()
' Setup color for the line.
Dim igRGBQuad As New ImGearRGBQuad(40, 40, 200)
' Create a series of diagonal lines adding each one to the 2 groups,
' alternating between them.
Dim igARTLine As ImGearARTLine
For i As Integer = 0 To 19
    igPointStart.X = i * 10
    igPointStart.Y = 10
    igPointEnd.X = i * 10 + 100
    igPointEnd.Y = 110
    igARTLine = New ImGearARTLine(igPointStart, igPointEnd, igRGBQuad)
    ' Add the annotation to one of the 2 groups.
    If i Mod 2 = 0 Then
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group1")
    Else
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group2")
    End If
Next
' Select Group1
igARTPage.Groups("Group1").[Select](True)
' Delete Group2
MessageBox.Show("Deleting second group of lines.", "Deleting...")
igARTPage.Groups("Group2").RemoveAll()


ImGearARTGroupArray Properties

The ImGearARTGroupArray Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
Count Property
Count of ART groups in the array.
this Property
Indexed property for accessing individual group by name.
this Property
Indexed property for accessing individual group by index.


Count Property

32-bit
64-bit
CF
P
P

Description:

Count of the groups in the array.

Declaration:

public int Count { get }

Value:

Integer number

Default value:

N/A


this Property

32-bit
64-bit
CF
P
P

Description:

Indexed property for accessing individual group by name.

Declaration:

public const ImageGear.ART.ImGearARTGroup this { get }

Value:

ImGearARTGroup Class object.

Default value:

N/A

See Also:

ImGearARTGroup Class


this Property

32-bit
64-bit
CF
P
P

Description:

Indexed property for accessing individual group by index.

Declaration:

public const ImageGear.ART.ImGearARTGroup this { get, set }

Value:

ImGearARTGroup Class object.

Default value:

N/A

See Also:

ImGearARTGroup Class


ImGearARTGroupArray Methods

The ImGearARTGroupArray Class of the ImageGear.ART Namespace has the following methods:

Methods
Name
Description
Add Method
Adds an ART group to the array.
Find Method
Finds the group specified by name in the array.
GetEnumerator Method
Returns an IEnumerator for the Array.
GetGroup Method
Gets the group specified by name.
Remove Method
Removes the specified group from array.
Remove Method
Removes a group with specified Name from array.
RemoveAll Method
Removes all groups from the array.
RemoveAt Method
Removes the group specified by Index from the array.


Add Method

32-bit
64-bit
CF
P
P

Description:

This method adds an ART group to the array.

Declaration:

public int Add ( ImageGear.ART.ImGearARTGroup grp )

Parameters:

Name
Type
Description
grp
ImGearARTGroup Class
Group to add.

Return Value:

Integer value.

See Also:

ImGearARTGroup Class


Find Method

32-bit
64-bit
CF
P
P

Description:

This method finds the group specified by Name in the array.

Declaration:

public ImageGear.ART.ImGearARTGroup Find ( String Name )

Parameters:

Name
Type
Description
Name
String
Name of the group to be found.

Return Value:

ImGearARTGroup Class object.

See Also:

ImGearARTGroup Class


GetEnumerator Method

32-bit
64-bit
CF
P
P

Description:

This method returns an IEnumerator for the array.

Declaration:

public new System.Collections.IEnumerator GetEnumerator (  )

Return Value:

IEnumerator


GetGroup Method

32-bit
64-bit
CF
P
P

Description:

This method gets the group specified by name.

Declaration:

public ImageGear.ART.ImGearARTGroup GetGroup ( String strName )

Parameters:

Name
Type
Description
strName
String
Name of the group.

Return Value:

ImGearARTGroup Class object.

See Also:

ImGearPoint Structure

ImGearRGBQuad Structure

ImGearARTGroup Class


Remove Method

32-bit
64-bit
CF
P
P

Description:

This method removes the specified group from an array.

Declaration:

public void Remove ( ImageGear.ART.ImGearARTGroup Group )

Parameters:

Name
Type
Description
Group
ImGearARTGroup Class
The group to remove.

Return Value:

None

See Also:

ImGearARTGroup Class


Remove Method

32-bit
64-bit
CF
P
P

Description:

This method removes a group with specified Name from array.

Declaration:

public void Remove ( String Name )

Parameters:

Name
Type
Description
Name
String
The name of the group to remove.

Return Value:

None


RemoveAll Method

32-bit
64-bit
CF
P
P

Description:

This method removes all groups from the array.

Declaration:

public void RemoveAll (  )

Return Value:

None


RemoveAt Method

32-bit
64-bit
CF
P
P

Description:

This method removes the group specified by Index from the array.

Declaration:

public void RemoveAt ( Int nIndex )

Parameters:

Name
Type
Description
Index
Int
Index of the group in the array.

Return Value:

None


ImGearARTGroupEnumerator Class

32-bit
64-bit
CF
P
P

Description:

Group enumerator class is used for ImGearARTGroup to iterate through the collection of marks by using foreach statement.

Declaration:

public class ImGearARTGroupEnumerator

Members:

Constructors
Name
Description
ImGearARTGroupEnumerator Constructor
Creates a new instance of ImGearARTGroupEnumerator object.

Properties
Name
Description
Current Property
Gets the current element in the collection.

Methods
Name
Description
MoveNext Method
Advances the enumerator to the next element of the collection.


ImGearARTGroupEnumerator Constructors

The ImGearARTGroupEnumerator Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTGroupEnumerator Constructor
Creates a new instance of ImGearARTGroupEnumerator object.


ImGearARTGroupEnumerator Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTGroupEnumerator Class object.

Declaration:

public ImGearARTGroupEnumerator(ImageGear.ART.ImGearARTGroup ARTGroup)

Parameters:

Name
Type
Description
ARTGroup
ImGearARTGroup Class
ART group to enumerate the marks from.

Return Value:

The new instance of ImGearARTGroupEnumerator Class object.

See Also:

ImGearARTGroup Class

ImGearARTGroupEnumerator Class


ImGearARTGroupEnumerator Properties

The ImGearARTGroupEnumerator Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
Current Property
Gets the current element in the collection.


Current Property

32-bit
64-bit
CF
P
P

Description:

Gets the current element in the collection.

Declaration:

public ImageGear.ART.ImGearARTMark Current { get; }

Value:

ImGearARTMark Class object.

Default value:

N/A

See Also:

ImGearARTMark Class


ImGearARTGroupEnumerator Methods

The ImGearARTGroupEnumerator Class of the ImageGear.ART Namespace has the following methods:

Methods
Name
Description
MoveNext Method
Advances the enumerator to the next element of the collection.


MoveNext Method

32-bit
64-bit
CF
P
P

Description:

This method advances the enumerator to the next element of the collection.

Declaration:

public bool MoveNext()

Return Value:

True, False


ImGearARTHighlighter Class

32-bit
64-bit
CF
P
P

Description:

Legacy ART Highlighter mark.

Declaration:

public class ImGearARTHighlighter : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTHighlighter Constructor
Creates a new instance of ImGearARTHighlighter object.

Properties
Name
Description
FillColor Property
Fill color of the mark.
Height Property
Height of the mark.
Width Property
Width of the mark.
X Property
The X coordinate of top-left point of mark's rectangle.
Y Property
The Y coordinate of top-left point of mark's rectangle.

Sample Code:

C#
// Setup rectangle for the highlighter mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 300, 100);
// Setup color for the highlighter.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(40, 200, 40);
// Create highlighter.
ImGearARTHighlighter igARTHighlighter = new ImGearARTHighlighter(
    igRectangle, igRGBQuad
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTHighlighter, ImGearARTCoordinatesType.IMAGE_COORD);

VB.NET
' Setup rectangle for the highlighter mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 300, 100)
' Setup color for the highlighter.
Dim igRGBQuad As New ImGearRGBQuad(40, 200, 40)
' Create highlighter.
Dim igARTHighlighter As New ImGearARTHighlighter( _
 igRectangle, igRGBQuad)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTHighlighter, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTHighlighter Constructors

The ImGearARTHighlighter Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTHighlighter Constructor
Creates a new instance of ImGearARTHighlighter object.


ImGearARTHighlighter Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTHighlighter Class object.

Declaration:

public ImGearARTHighlighter ( ImageGear.Core.IImGearRectangle Rect ,
ImageGear.Core.IImGearRGBQuad FillColor )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Mark's rectangle.
FillColor
ImGearRGBQuad Structure
Fill color of the mark.

Return Value:

The new instance of ImGearARTHighlighter Class object.

See Also:

ImGearRGBQuad Structure

ImGearRectangle Structure


ImGearARTHighlighter Properties

The ImGearARTHighlighter Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
FillColor Property
Fill color of the mark.
Height Property
Height of the mark.
Width Property
Width of the mark.
X Property
The X coordinate of top-left point of mark's rectangle.
Y Property
The Y coordinate of top-left point of mark's rectangle.


FillColor Property

32-bit
64-bit
CF
P
P

Description:

Fill color of the Highlighter mark.

Declaration:

public ImageGear.Core.IImGearRGBQuad FillColor { get, set }

Value:

ImGearRGBQuad Structure object interface.

Default value:

N/A

See Also:

ImGearRGBQuad Structure


Height Property

32-bit
64-bit
CF
P
P

Description:

Height of the Highlighter mark rectangle.

Declaration:

public int Height { get, set }

Value:

Integer value

Default value:

N/A


Width Property

32-bit
64-bit
CF
P
P

Description:

Width of the Highlighter mark rectangle.

Declaration:

public int Width { get, set }

Value:

Integer value

Default value:

N/A


X Property

32-bit
64-bit
CF
P
P

Description:

The X coordinate of top-left point of Highlighter mark rectangle.

Declaration:

public int X { get, set }

Value:

Integer value

Default value:

N/A


Y Property

32-bit
64-bit
CF
P
P

Description:

The Y coordinate of top-left point of Highlighter mark rectangle.

Declaration:

public int Y { get, set }

Value:

Integer value

Default value:

N/A


ImGearARTHollowEllipse Class

32-bit
64-bit
CF
P
P

Description:

Legacy ART Hollow Ellipse mark.

Declaration:

public class ImGearARTHollowEllipse : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTHollowEllipse Constructor
Creates a new instance of ImGearARTHollowEllipse object.
ImGearARTHollowEllipse Constructor
Creates a new instance of ImGearARTHollowEllipse object.

Properties
Name
Description
BorderColor Property
Border color of the mark.
BorderWidth Property
Border width of the mark.
Height Property
Height of the mark.
Highlight Property
Determines whether the mark is highlighted.
Width Property
Width of the mark.
X Property
The X coordinate of top-left point of the mark.
Y Property
The Y coordinate of top-left point of the mark.

Sample Code:

C#
// Setup rectangle for the hollow ellipse mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 300, 100);
// Setup color for the hollow ellipse.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(40, 200, 40);
// Create hollow ellipse with a border of 10 and highlight off.
ImGearARTHollowEllipse igARTHollowEllipse = new ImGearARTHollowEllipse(
    igRectangle, igRGBQuad, 10, false
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTHollowEllipse, ImGearARTCoordinatesType.IMAGE_COORD);

VB.NET
' Setup rectangle for the hollow ellipse mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 300, 100)
' Setup color for the hollow ellipse.
Dim igRGBQuad As New ImGearRGBQuad(40, 200, 40)
' Create hollow ellipse with a border of 10 and highlight off.
Dim igARTHollowEllipse As New ImGearARTHollowEllipse( _
 igRectangle, igRGBQuad, 10, False)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTHollowEllipse, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTHollowEllipse Constructors

The ImGearARTHollowEllipse Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTHollowEllipse Constructor
Creates a new instance of ImGearARTHollowEllipse object.
ImGearARTHollowEllipse Constructor
Creates a new instance of ImGearARTHollowEllipse object.


ImGearARTHollowEllipse Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTHollowEllipse Class object.

Declaration:

public ImGearARTHollowEllipse ( ImageGear.Core.IImGearRectangle Rect ,
ImageGear.Core.IImGearRGBQuad BorderColor )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Mark's rectangle.
BorderColor
ImGearRGBQuad Structure
Border color of the mark.

Return Value:

The new instance of ImGearARTHollowEllipse Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure


ImGearARTHollowEllipse Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTHollowEllipse Class object.

Declaration:

public ImGearARTHollowEllipse ( ImageGear.Core.IImGearRectangle Rect ,
ImageGear.Core.IImGearRGBQuad BorderColor , Int BorderWidth , Bool Highlight )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Mark's rectangle.
BorderColor
ImGearRGBQuad Structure
Border color of the mark.
BorderWidth
Int
The width of mark border.
Highlight
Bool
True if mark is highlighted, False - otherwise.

Return Value:

The new instance of ImGearARTHollowEllipse Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure


ImGearARTHollowEllipse Properties

The ImGearARTHollowEllipse Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
BorderColor Property
Border color of the mark.
BorderWidth Property
Border width of the mark.
Height Property
Height of the mark.
Highlight Property
Determines whether the mark is highlighted.
Width Property
Width of the mark.
X Property
The X coordinate of top-left point of the mark.
Y Property
The Y coordinate of top-left point of the mark.


BorderColor Property

32-bit
64-bit
CF
P
P

Description:

The border color of the mark.

Declaration:

public ImageGear.Core.IImGearRGBQuad BorderColor { get, set }

Value:

ImGearRGBQuad Structure object.

Default value:

N/A

See Also:

ImGearRGBQuad Structure


BorderWidth Property

32-bit
64-bit
CF
P
P

Description:

Width of the mark's border.

Declaration:

public int BorderWidth { get, set }

Value:

Integer value

Default value:

N/A


Height Property

32-bit
64-bit
CF
P
P

Description:

Height of the mark's rectangle.

Declaration:

public int Height { get, set }

Value:

Integer value

Default value:

N/A


Highlight Property

32-bit
64-bit
CF
P
P

Description:

Determines whether the mark is highlighted.

Declaration:

public bool Highlight { get, set }

Value:

True - mark is highlighted, False - otherwise.

Default value:

N/A


Width Property

32-bit
64-bit
CF
P
P

Description:

Width of the mark's rectangle.

Declaration:

public int Width { get, set }

Value:

Integer value

Default value:

N/A


X Property

32-bit
64-bit
CF
P
P

Description:

The X coordinate of top-left point of the mark's rectangle.

Declaration:

public int x { get, set }

Value:

Integer value

Default value:

N/A


Y Property

32-bit
64-bit
CF
P
P

Description:

The Y coordinate of top-left point of the mark's rectangle.

Declaration:

public int Y { get, set }

Value:

Integer value

Default value:

N/A


ImGearARTHollowPolygon Class

32-bit
64-bit
CF
P
P

Description:

Legacy ART Hollow Polygon mark.

Declaration:

public class ImGearARTHollowPolygon : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTHollowPolygon Constructor
Creates a new instance of ImGearARTHollowPolygon object.
ImGearARTHollowPolygon Constructor
Creates a new instance of ImGearARTHollowPolygon object.

Properties
Name
Description
BorderColor Property
Border color of the mark.
BorderWidth Property
Border width of the mark.
Highlight Property
Determines whether the mark is highlighted.
NumberOfPoints Property
Number of points of the mark.
Points Property
Raw points array.

Methods
Name
Description
GetPoint Method
Gets the point with specified index.
SetPoint Method
Sets the point at the specified index.

Sample Code:

C#
// Create an array of 5 points for the hollow polygon.
ImGearPoint[] igPoints = new ImGearPoint[5];
igPoints[0] = new ImGearPoint(20, 20);
igPoints[1] = new ImGearPoint(200, 40);
igPoints[2] = new ImGearPoint(200, 60);
igPoints[3] = new ImGearPoint(120, 120);
igPoints[4] = new ImGearPoint(20, 40);
// Setup color for the hollow polygon.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(40, 200, 40);
// Create hollow polygon with a width of 10 and highlight off.
ImGearARTHollowPolygon igARTHollowPolygon = new ImGearARTHollowPolygon(
    igPoints, igRGBQuad, 10, false
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTHollowPolygon, ImGearARTCoordinatesType.IMAGE_COORD);

VB.NET
' Create an array of 5 points for the hollow polygon.
Dim igPoints As ImGearPoint() = New ImGearPoint(4) {}
igPoints(0) = New ImGearPoint(20, 20)
igPoints(1) = New ImGearPoint(200, 40)
igPoints(2) = New ImGearPoint(200, 60)
igPoints(3) = New ImGearPoint(120, 120)
igPoints(4) = New ImGearPoint(20, 40)
' Setup color for the hollow polygon.
Dim igRGBQuad As New ImGearRGBQuad(40, 200, 40)
' Create hollow polygon with a width of 10 and highlight off.
Dim igARTHollowPolygon As New ImGearARTHollowPolygon( _
 igPoints, igRGBQuad, 10, False)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTHollowPolygon, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTHollowPolygon Constructors

The ImGearARTHollowPolygon Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTHollowPolygon Constructor
Creates a new instance of ImGearARTHollowPolygon object.
ImGearARTHollowPolygon Constructor
Creates a new instance of ImGearARTHollowPolygon object.


ImGearARTHollowPolygon Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTHollowPolygon Class object.

Declaration:

public ImGearARTHollowPolygon ( ImageGear.Core.ImGearPoint[] Points ,
ImageGear.Core.IImGearRGBQuad BorderColor )

Parameters:

Name
Type
Description
Points
ImGearPoint Structure
Mark's points.
BorderColor
ImGearRGBQuad Structure
Border color of the mark.

Return Value:

The new instance of ImGearARTHollowPolygon Class object.

See Also:

ImGearPoint Structure

ImGearRGBQuad Structure


ImGearARTHollowPolygon Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTHollowPolygon Class object.

Declaration:

public ImGearARTHollowPolygon ( ImageGear.Core.ImGearPoint[] Points ,
ImageGear.Core.ImGearRGBQuad BorderColor , Int BorderWidth , Bool Highlight )

Parameters:

Name
Type
Description
Points
ImGearPoint Structure
Mark's rectangle.
BorderColor
ImGearRGBQuad Structure
Border color of the mark.
BorderWidth
Int
Width of the mark border.
Highlight
Bool
True if the mark is highlighted, False - otherwise.

Return Value:

The new instance of ImGearARTHollowPolygon Class object.

See Also:

ImGearPoint Structure

ImGearRGBQuad Structure


ImGearARTHollowPolygon Properties

The ImGearARTHollowPolygon Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
BorderColor Property
Border color of the mark.
BorderWidth Property
Border width of the mark.
Highlight Property
Determines whether the mark is highlighted.
NumberOfPoints Property
Number of points of the mark.
Points Property
Raw points array.


BorderColor Property

32-bit
64-bit
CF
P
P

Description:

The border color of the mark.

Declaration:

public ImageGear.Core.IImGearRGBQuad BorderColor { get, set }

Value:

ImGearRGBQuad Structure object interface.

Default value:

N/A

See Also:

ImGearRGBQuad Structure


BorderWidth Property

32-bit
64-bit
CF
P
P

Description:

Width of the mark border.

Declaration:

public int BorderWidth { get, set }

Value:

Integer value

Default value:

N/A


Highlight Property

32-bit
64-bit
CF
P
P

Description:

True if mark is highlighted, False - otherwise.

Declaration:

public bool Highlight { get, set }

Value:

True, False

Default value:

N/A


NumberOfPoints Property

32-bit
64-bit
CF
P
P

Description:

The actual number of mark's points.

Declaration:

public int NumberOfPoints { get, set }

Value:

Integer value

Default value:

N/A


ImGearARTHollowPolygon Methods

The ImGearARTFilledPolygon Class of the ImageGear.ART Namespace has the following methods:

Methods
Name
Description
GetPoint Method
Gets the point with specified index.
SetPoint Method
Sets the point at the specified index.


GetPoint Method

32-bit
64-bit
CF
P
P

Description:

This method gets the point specified with Index.

Declaration:

public ImageGear.Core.ImGearPoint GetPoint ( Int Index )

Parameters:

Name
Type
Description
Index
Int
Index of the point in the mark points array.

Return Value:

ImGearPoint Structure object.

See Also:

ImGearPoint Structure


SetPoint Method

32-bit
64-bit
CF
P
P

Description:

This method sets the point at specified index.

Declaration:

public void SetPoint ( Int Index , ImageGear.Core.ImGearPoint Point )

Parameters:

Name
Type
Description
Index
Int
Index of the point in the mark points array.
Point
ImGearPoint Structure
The point to be set.

Return Value:

None

See Also:

ImGearPoint Structure


ImGearARTHollowRectangle Class

32-bit
64-bit
CF
P
P

Description:

Legacy ART Hollow Rectangle mark.

Declaration:

public class ImGearARTHollowRectangle : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTHollowRectangle Constructor
Creates a new instance of ImGearARTHollowRectangle object.
ImGearARTHollowRectangle Constructor
Creates a new instance of ImGearARTHollowRectangle object.

Properties
Name
Description
BorderColor Property
Border color of the mark.
BorderWidth Property
Border width of the mark.
Height Property
Height of the mark.
Highlight Property
Determines whether the mark is highlighted.
Width Property
Width of the mark.
X Property
The X coordinate of top-left point of the mark.
Y Property
The Y coordinate of top-left point of the mark.

Sample Code:

C#
// Setup rectangle for the hollow rectangle mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 300, 100);
// Setup color for the hollow rectangle.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(40, 200, 40);
// Create hollow rectangle with a border of 10 and highlight off.
ImGearARTHollowRectangle igARTHollowRectangle = new ImGearARTHollowRectangle(
    igRectangle, igRGBQuad, 10, false
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTHollowRectangle, ImGearARTCoordinatesType.IMAGE_COORD);

VB.NET
' Setup rectangle for the hollow rectangle mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 300, 100)
' Setup color for the hollow rectangle.
Dim igRGBQuad As New ImGearRGBQuad(40, 200, 40)
' Create hollow rectangle with a border of 10 and highlight off.
Dim igARTHollowRectangle As New ImGearARTHollowRectangle( _
 igRectangle, igRGBQuad, 10, False)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTHollowRectangle, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTHollowRectangle Constructors

The ImGearARTHollowRectangle Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTHollowRectangle Constructor
Creates a new instance of ImGearARTHollowRectangle object.
ImGearARTHollowRectangle Constructor
Creates a new instance of ImGearARTHollowRectangle object.


ImGearARTHollowRectangle Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTHollowRectangle Class object.

Declaration:

public ImGearARTHollowRectangle ( ImageGear.Core.IImGearRectangle Rect ,
ImageGear.Core.ImGearRGBQuad BorderColor )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Mark's rectangle.
BorderColor
ImGearRGBQuad Structure
Border color of the mark.

Return Value:

The new instance of ImGearARTHollowRectangle Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure


ImGearARTHollowRectangle Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTHollowRectangle Class object.

Declaration:

public ImGearARTHollowRectangle ( ImageGear.Core.IImGearRectangle Rect ,
ImageGear.Core.ImGearRGBQuad BorderColor , Int BorderWidth , Bool Highlight )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Mark's rectangle.
BorderColor
ImGearRGBQuad Structure
Border color of the mark.
BorderWidth
Int
The width of mark border.
Highlight
Bool
True if mark is highlighted, False - otherwise.

Return Value:

The new instance of ImGearARTHollowRectangle Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure


ImGearARTHollowRectangle Properties

The ImGearARTHollowRectangle Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
BorderColor Property
Border color of the mark.
BorderWidth Property
Border width of the mark.
Height Property
Height of the mark.
Highlight Property
Determines whether the mark is highlighted.
Width Property
Width of the mark.
X Property
The X coordinate of top-left point of the mark.
Y Property
The Y coordinate of top-left point of the mark.


ImGearARTHotSpot Class

32-bit
64-bit
CF
P
P

Description:

ART Hot Spot mark.

Declaration:

public class ImGearARTHotSpot : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTHotSpot Constructor
Creates a new instance of ImGearARTHotSpot object.
ImGearARTHotSpot Constructor
Creates a new instance of ImGearARTHotSpot object.

Properties
Name
Description
FillColor Property
Fill color of the mark.
Height Property
Height of the mark's rectangle.
Opacity Property
Opacity of the mark.
Width Property
Width of the mark's rectangle.
X Property
X coordinate of the top-left point of the mark's rectangle.
Y Property
Y coordinate of the top-left point of the mark's rectangle.

Sample Code:

C#
// Setup rectangle for the hotspot mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 300, 100);
// Setup color for the hotspot.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(40, 200, 40);
// Create hotspot with an opacity of 75%.
ImGearARTHotSpot igARTHotSpot = new ImGearARTHotSpot(
    igRectangle, igRGBQuad, (int)(0.75 * 255)
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTHotSpot, ImGearARTCoordinatesType.IMAGE_COORD);

VB.NET
' Setup rectangle for the hotspot mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 300, 100)
' Setup color for the hotspot.
Dim igRGBQuad As New ImGearRGBQuad(40, 200, 40)
' Create hotspot with an opacity of 75%.
Dim igARTHotSpot As New ImGearARTHotSpot( _
 igRectangle, igRGBQuad, CInt(0.75 * 255))
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTHotSpot, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTHotSpot Constructors

The ImGearARTHotSpot Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTHotSpot Constructor
Creates a new instance of ImGearARTHotSpot object.
ImGearARTHotSpot Constructor
Creates a new instance of ImGearARTHotSpot object.


ImGearARTHotSpot Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTHotSpot Class object.

Declaration:

public ImGearARTHotSpot ( ImageGear.Core.IImGearRectangle Rect,
ImageGear.Core.IImGearRGBQuad FillColor )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Rectangle of the mark.
FillColor
ImGearRGBQuad Structure
Fill color of the mark.

Return Value:

The new instance of ImGearARTHotSpot Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure


ImGearARTHotSpot Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTHotSpot Class object.

Declaration:

public ImGearARTHotSpot ( ImageGear.Core.IImGearRectangle Rect,
ImageGear.Core.IImGearRGBQuad FillColor , Int Opacity )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Rectangle of the mark.
FillColor
ImGearRGBQuad Structure
Fill color of the mark.
Opacity
Int
Opacity of the mark.

Return Value:

The new instance of ImGearARTHotSpot Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure


ImGearARTHotSpot Properties

The ImGearARTHotSpot Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
FillColor Property
Fill color of the mark.
Height Property
Height of the mark's rectangle.
Opacity Property
Opacity of the mark.
Width Property
Width of the mark's rectangle.
X Property
X coordinate of the top-left point of the mark's rectangle.
Y Property
Y coordinate of the top-left point of the mark's rectangle.


FillColor Property

32-bit
64-bit
CF
P
P

Description:

Fill color of the mark.

Declaration:

public ImageGear.Core.IImGearRGBQuad FillColor { get, set }

Value:

ImGearRGBQuad Structure object interface.

Default value:

N/A

See Also:

ImGearRGBQuad Structure


Height Property

32-bit
64-bit
CF
P
P

Description:

The height of the mark's rectangle.

Declaration:

public int Height { get, set }

Value:

Integer value.

Default value:

N/A


ImGearARTImage Class

32-bit
64-bit
CF
P
P

Description:

ART Image mark.

Declaration:

public class ImGearARTImage : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTImage Constructor
Creates a new instance of ImGearARTImage object.
ImGearARTImage Constructor
Creates a new instance of ImGearARTImage object.
ImGearARTImage Constructor
Creates a new instance of ImGearARTImage object.

Properties
Name
Description
AlignmentH Property
Horizontal alignment of image.
AlignmentV Property
Vertical alignment of image.
AspectRatio Property
Aspect ratio.
FileName Property
File name of the image reference.
FitMode Property
Fitting mode.
Height Property
Height of the image.
Orientation Property
Image orientation.
Page Property
ImGearPage Class that contains the image.
Width Property
Width of the image.
X Property
The X coordinate of the top-left point of the image.
Y Property
The Y coordinate of the top-left point of the image.

Sample Code:

C#
// Setup rectangle for the image mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 100, 100);
// Create image mark using a file "PNGTEST.png".
ImGearARTImage igARTImage = new ImGearARTImage(
    igRectangle, "PNGTEST.png"
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTImage, ImGearARTCoordinatesType.IMAGE_COORD);

VB.NET
' Setup rectangle for the image mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 100, 100)
' Create image mark using a file "PNGTEST.png".
Dim igARTImage As New ImGearARTImage( _
 igRectangle, "PNGTEST.png")
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTImage, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTImage Constructors

The ImGearARTImage Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTImage Constructor
Creates a new instance of ImGearARTImage object.
ImGearARTImage Constructor
Creates a new instance of ImGearARTImage object.
ImGearARTImage Constructor
Creates a new instance of ImGearARTImage object.


ImGearARTImage Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTImage Class object.

Declaration:

public ImGearARTImage ( ImageGear.Core.IImGearRectangle Rect )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Image rectangle.

Return Value:

The new instance of ImGearARTImage Class object.

See Also:

ImGearRectangle Structure


ImGearARTImage Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTImage Class object.

Declaration:

public ImGearARTImage ( ImageGear.Core.IImGearRectangle Rect , String FileName )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Image rectangle.
FileName
String
File name of the image.

Return Value:

The new instance of ImGearARTImage Class object.

See Also:

ImGearRectangle Structure


ImGearARTImage Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTImage Class object.

Declaration:

public ImGearARTImage ( ImageGear.Core.IImGearRectangle Rect , ImageGear.Core.ImGearPage
Page )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
The image rectangle.
Page
ImGearPage Class
The page to create a mark from.

Return Value:

The new instance of ImGearARTImage Class object.

See Also:

ImGearPage Class

ImGearRectangle Structure


ImGearARTImage Properties

The ImGearARTImage Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
AlignmentH Property
Horizontal alignment of image.
AlignmentV Property
Vertical alignment of image.
AspectRatio Property
Aspect ratio.
FileName Property
File name of the image reference.
FitMode Property
Fitting mode.
Height Property
Height of the image.
Orientation Property
Image orientation.
Page Property
ImGearPage Class that contains the image.
Width Property
Width of the image.
X Property
The X coordinate of the top-left point of the image.
Y Property
The Y coordinate of the top-left point of the image.


AlignmentH Property

32-bit
64-bit
CF
P
P

Description:

Horizontal alignment of the image.

Declaration:

public ImageGear.Display.ImGearAlignmentHModes AlignmentH { get, set }

Value:

ImGearAlignmentHModes Enumeration value.

Default value:

0

See Also:

ImGearAlignmentHModes Enumeration


AlignmentV Property

32-bit
64-bit
CF
P
P

Description:

Vertical alignment of the image.

Declaration:

public ImageGear.Display.ImGearAlignmentVModes AlignmentV { get, set }

Value:

ImGearAlignmentVModes Enumeration value.

Default value:

0

See Also:

ImGearAlignmentVModes Enumeration


AspectRatio Property

32-bit
64-bit
CF
P
P

Description:

Aspect ratio of the image.

Declaration:

public double AspectRatio { get, set }

Value:

Any positive number.

Default value:

1


FileName Property

32-bit
64-bit
CF
P
P

Description:

The file name of the image reference.

Declaration:

public string FileName { get, set }

Value:

String name.

Default value:

N/A


FitMode Property

32-bit
64-bit
CF
P
P

Description:

Fitting mode of the image.

Declaration:

public ImageGear.Display.ImGearFitModes FitMode { get, set }

Value:

ImGearFitModes Enumeration value.

Default value:

0

See Also:

ImGearFitModes Enumeration


Height Property

32-bit
64-bit
CF
P
P

Description:

The height of the rectangle.

Declaration:

public int Height { get, set }

Value:

Integer value.

Default value:

N/A


Orientation Property

32-bit
64-bit
CF
P
P

Description:

Image orientation.

Declaration:

public ImageGear.Core.ImGearOrientationModes Orientation { get, set }

Value:

ImGearOrientationModes Enumeration value.

Default value:

1

See Also:

ImGearOrientationModes Enumeration


Page Property

32-bit
64-bit
CF
P
P

Description:

ImGearPage Class that contains the image.

Declaration:

public ImageGear.Core.ImGearPage Page { get, set }

Value:

ImGearPage Class object.

Default value:

N/A

See Also:

ImGearPage Class


Width Property

32-bit
64-bit
CF
P
P

Description:

The width of the rectangle.

Declaration:

public int Width { get, set }

Value:

Integer value.

Default value:

N/A


X Property

32-bit
64-bit
CF
P
P

Description:

The X coordinate of the top-left point of the rectangle.

Declaration:

public int X { get, set }

Value:

Integer value.

Default value:

N/A


Y Property

32-bit
64-bit
CF
P
P

Description:

The Y coordinate of the top-left point of the rectangle.

Declaration:

public int Y { get, set }

Value:

Integer value.

Default value:

N/A


ImGearARTImageEmb Class

32-bit
64-bit
CF
P
P

Description:

Legacy ART Embedded Image mark.

Declaration:

public class ImGearARTImageEmb : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTImageEmb Constructor
Creates a new instance of ImGearARTImageEmb object.
ImGearARTImageEmb Constructor
Creates a new instance of ImGearARTImageEmb object.

Properties
Name
Description
AlignmentH Property
Horizontal alignment of image.
AlignmentV Property
Vertical alignment of image.
AspectRatio Property
Aspect ratio.
FitMode Property
Fitting mode.
Height Property
Height of the image.
Orientation Property
Image orientation.
Page Property
ImGearPage Class that contains the image.
Width Property
Width of the image.
X Property
The X coordinate of the top-left point of the image.
Y Property
The Y coordinate of the top-left point of the image.

Sample Code:

C#
// Setup rectangle for the embedded image mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 100, 100);
// Load an image to embed
ImGearPage igPageEmbedded;
using (FileStream localFile = new FileStream("photo.jpg", FileMode.Open))
{
    igPageEmbedded = ImGearFileFormats.LoadPage(localFile, 0);
}
// Create embedded image mark using igPageEmbedded.
ImGearARTImageEmb igARTImageEmb = new ImGearARTImageEmb(
    igRectangle, igPageEmbedded
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTImageEmb, ImGearARTCoordinatesType.IMAGE_COORD);

VB.NET
' Setup rectangle for the embedded image mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 100, 100)
' Load an image to embed
Dim igPageEmbedded As ImGearPage
Using localFile As New FileStream("photo.jpg", FileMode.Open)
    igPageEmbedded = ImGearFileFormats.LoadPage(localFile, 0)
End Using
' Create embedded image mark using igPageEmbedded.
Dim igARTImageEmb As New ImGearARTImageEmb( _
 igRectangle, igPageEmbedded)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTImageEmb, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTImageEmb Constructors

The ImGearARTImageEmb Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTImageEmb Constructor
Creates a new instance of ImGearARTImageEmb object.
ImGearARTImageEmb Constructor
Creates a new instance of ImGearARTImageEmb object.


ImGearARTImageEmb Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTImageEmb Class object.

Declaration:

public ImGearARTImageEmb ( ImageGear.Core.IImGearRectangle Rect )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
The image rectangle.

Return Value:

The new instance of ImGearARTImageEmb Class object.

See Also:

ImGearRectangle Structure


ImGearARTImageEmb Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTImageEmb Class object.

Declaration:

public ImGearARTImageEmb ( ImageGear.Core.IImGearRectangle Rect ,
ImageGear.Core.ImGearPage Page )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
The image rectangle.
Page
ImGearPage Class
The page to create a mark from.

Return Value:

The new instance of ImGearARTImageEmb Class object.

See Also:

ImGearPage Class

ImGearRectangle Structure


ImGearARTImageEmb Properties

The ImGearARTImageEmb Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
AlignmentH Property
Horizontal alignment of image.
AlignmentV Property
Vertical alignment of image.
AspectRatio Property
Aspect ratio.
FitMode Property
Fitting mode.
Height Property
Height of the image.
Orientation Property
Image orientation.
Page Property
ImGearPage Class that contains the image.
Width Property
Width of the image.
X Property
The X coordinate of the top-left point of the image.
Y Property
The Y coordinate of the top-left point of the image.


AlignmentH Property

32-bit
64-bit
CF
P
P

Description:

Horizontal alignment of the image.

Declaration:

public ImageGear.Display.ImGearAlignmentHModes AlignmentH { get, set }

Value:

ImGearAlignmentHModes Enumeration value.

Default value:

N/A

See Also:

ImGearAlignmentHModes Enumeration


AlignmentV Property

32-bit
64-bit
CF
P
P

Description:

Vertical alignment of the image.

Declaration:

public ImageGear.Display.ImGearAlignmentVModes AlignmentV { get, set }

Value:

ImGearAlignmentVModes Enumeration value.

Default value:

N/A

See Also:

ImGearAlignmentVModes Enumeration


AspectRatio Property

32-bit
64-bit
CF
P
P

Description:

Aspect ratio of the image.

Declaration:

public double AspectRatio { get, set }

Value:

Any positive number.

Default value:

N/A


FitMode Property

32-bit
64-bit
CF
P
P

Description:

Fitting mode of the image.

Declaration:

public ImageGear.Display.ImGearFitModes FitMode { get, set }

Value:

ImGearFitModes Enumeration value.

Default value:

N/A

See Also:

ImGearFitModes Enumeration


Orientation Property

32-bit
64-bit
CF
P
P

Description:

Image orientation.

Declaration:

public ImageGear.Core.ImGearOrientationModes Orientation { get, set }

Value:

ImGearOrientationModes Enumeration value.

Default value:

N/A

See Also:

ImGearOrientationModes Enumeration


ImGearARTImageRef Class

32-bit
64-bit
CF
P
P

Description:

Legacy ART Image Reference mark.

Declaration:

public class ImGearARTImageRef : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTImageRef Constructor
Creates a new instance of ImGearARTImageRef object.
ImGearARTImageRef Constructor
Creates a new instance of ImGearARTImageRef object.

Properties
Name
Description
AlignmentH Property
Horizontal alignment of image.
AlignmentV Property
Vertical alignment of image.
AspectRatio Property
Aspect ratio.
FileName Property
File name of the image reference.
FitMode Property
Fitting mode.
Height Property
Height of the image.
Orientation Property
Image orientation.
Width Property
Width of the image.
X Property
The X coordinate of the top-left point of the image.
Y Property
The Y coordinate of the top-left point of the image.

Sample Code:

C#
// Setup rectangle for the reference image mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 100, 100);
// Create reference image mark using a file "PNGTEST.png".
ImGearARTImageRef igARTImageRef = new ImGearARTImageRef(
    igRectangle, "PNGTEST.png"
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTImageRef, ImGearARTCoordinatesType.IMAGE_COORD);

VB.NET
' Setup rectangle for the reference image mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 100, 100)
' Create reference image mark using a file "PNGTEST.png".
Dim igARTImageRef As New ImGearARTImageRef( _
 igRectangle, "PNGTEST.png")
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTImageRef, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTImageRef Constructors

The ImGearARTImageRef Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTImageRef Constructor
Creates a new instance of ImGearARTImageRef object.
ImGearARTImageRef Constructor
Creates a new instance of ImGearARTImageRef object.


ImGearARTImageRef Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTImageRef Class object.

Declaration:

public ImGearARTImageRef ( ImageGear.Core.IImGearRectangle Rect )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Image rectangle.

Return Value:

The new instance of ImGearARTImageRef Class object.

See Also:

ImGearRectangle Structure


ImGearARTImageRef Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTImageRef Class object.

Declaration:

public ImGearARTImageRef ( ImageGear.Core.IImGearRectangle Rect, String FileName )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
The image rectangle.
FileName
String
The file name of the image reference.

Return Value:

The new instance of ImGearARTImageRef Class object.

See Also:

ImGearRectangle Structure


ImGearARTImageRef Properties

The ImGearARTImageRef Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
AlignmentH Property
Horizontal alignment of image.
AlignmentV Property
Vertical alignment of image.
AspectRatio Property
Aspect ratio.
FileName Property
File name of the image reference.
FitMode Property
Fitting mode.
Height Property
Height of the image.
Orientation Property
Image orientation.
Width Property
Width of the image.
X Property
The X coordinate of the top-left point of the image.
Y Property
The Y coordinate of the top-left point of the image.


FileName Property

32-bit
64-bit
CF
P
P

Description:

The file name of the image.

Declaration:

public string FileName { get, set }

Value:

String name.

Default value:

N/A


ImGearARTLine Class

32-bit
64-bit
CF
P
P

Description:

ART Line mark.

Declaration:

public class ImGearARTLine : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTLine Constructor
Creates a new instance of ImGearARTLine object.
ImGearARTLine Constructor
Creates a new instance of ImGearARTLine object.
ImGearARTLine Constructor
Creates a new instance of ImGearARTLine object.

Properties
Name
Description
Color Property
Line color.
EndHeadAngle Property
The angle of the line's end head.
EndHeadLength Property
The length of the line's end head.
EndHeadType Property
The type of the line's end head.
EndPoint Property
End point of the line.
HeadFillColor Property
Fill color of the line's head.
Opacity Property
Line opacity.
StartHeadAngle Property
The angle of the line's start head.
StartHeadLength Property
The length of the line's start head.
StartHeadType Property
The type of the line's start head.
StartPoint Property
Start point of the line.
Style Property
The style of the line.
Width Property
The line width.

Sample Code:

C#
// Setup start and endpoint for the line.
ImGearPoint igPointStart = new ImGearPoint(0, 0);
ImGearPoint igPointEnd = new ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2);
// Setup color for the line.
ImGearRGBQuad igRGBQuadLine = new ImGearRGBQuad(0, 255, 0);
// Setup color for the heads.
ImGearRGBQuad igRGBQuadHead = new ImGearRGBQuad(0, 0, 200);
// Create the line annotation with solid pen style, a width of 4, 25% opacity,
//  open head type at the start point with a 30 degree angle and length of 20,
//  solid head type at the end point with a 30 degree angle and length of 20.
ImGearARTLine igARTLine = new ImGearARTLine(
    igPointStart, igPointEnd, igRGBQuadLine, ImGearARTPenStyle.SOLID, 4,
    (int)(0.25 * 255), igRGBQuadHead, ImGearARTLineHeadType.OPEN, 30, 20,
    ImGearARTLineHeadType.POINTER_SOLID, 30, 20
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD);

VB.NET
' Setup start and endpoint for the line.
Dim igPointStart As New ImGearPoint(0, 0)
Dim igPointEnd As New ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2)
' Setup color for the line.
Dim igRGBQuadLine As New ImGearRGBQuad(0, 255, 0)
' Setup color for the heads.
Dim igRGBQuadHead As New ImGearRGBQuad(0, 0, 200)
' Create the line annotation with solid pen style, a width of 4, 25% opacity,
'  open head type at the start point with a 30 degree angle and length of 20,
'  solid head type at the end point with a 30 degree angle and length of 20.
Dim igARTLine As New ImGearARTLine( _
 igPointStart, igPointEnd, igRGBQuadLine, ImGearARTPenStyle.SOLID, 4, _
 CInt(0.25 * 255), igRGBQuadHead, ImGearARTLineHeadType.OPEN, 30, 20, _
 ImGearARTLineHeadType.POINTER_SOLID, 30, 20)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTLine Constructors

The ImGearARTLine Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTLine Constructor
Creates a new instance of ImGearARTLine object.
ImGearARTLine Constructor
Creates a new instance of ImGearARTLine object.
ImGearARTLine Constructor
Creates a new instance of ImGearARTLine object.


ImGearARTLine Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTLine Class object.

Declaration:

public ImGearARTLine ( ImageGear.Core.ImGearPoint StartPoint , ImageGear.Core.ImGearPoint
EndPoint , ImageGear.Core.IImGearRGBQuad Color )

Parameters:

Name
Type
Description
StartPoint
ImGearPoint Structure
The start point of the line.
EndPoint
ImGearPoint Structure
The end point of the line.
Color
ImGearRGBQuad Structure
The color of the line.

Return Value:

The new instance of ImGearARTLine Class object.

See Also:

ImGearPoint Structure

ImGearRGBQuad Structure


ImGearARTLine Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTLine Class object.

Declaration:

public ImGearARTLine ( ImageGear.Core.ImGearPoint StartPoint , ImageGear.Core.ImGearPoint
EndPoint , ImageGear.Core.IImGearRGBQuad Color , ImageGear.ART.ImGearARTPenStyle Style ,
Int Width , Int Opacity )

Parameters:

Name
Type
Description
StartPoint
ImGearPoint Structure
The start point of the line.
EndPoint
ImGearPoint Structure
The end point of the line.
Color
ImGearRGBQuad Structure
The color of the line.
Style
ImGearARTPenStyle Enumeration
The line style.
Width
Int
The width of the line.
Opacity
Int
Opacity of the line.

Return Value:

The new instance of ImGearARTLine Class object.

See Also:

ImGearPoint Structure

ImGearRGBQuad Structure

ImGearARTPenStyle Enumeration


ImGearARTLine Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTLine Class object.

Declaration:

public ImGearARTLine ( ImageGear.Core.ImGearPoint StartPoint , ImageGear.Core.ImGearPoint
EndPoint , ImageGear.Core.IImGearRGBQuad Color , ImageGear.ART.ImGearARTPenStyle Style ,
Int Width , Int Opacity , ImageGear.Core.IImGearRGBQuad HeadFillColor ,
ImageGear.ART.ImGearARTLineHeadType StartHeadType , Int StartHeadAngle , Int
StartHeadLength , ImageGear.ART.ImGearARTLineHeadType EndHeadType , Int EndHeadAngle , Int
EndHeadLength )

Parameters:

Name
Type
Description
StartPoint
ImGearPoint Structure
The start point of the line.
EndPoint
ImGearPoint Structure
The end point of the line.
Color
ImGearRGBQuad Structure
The color of the line.
Style
ImGearARTPenStyle Enumeration
The line style.
Width
Int
The width of the line.
Opacity
Int
Opacity of the line.
HeadFillColor
ImGearRGBQuad Structure
Fill color of the line's head.
StartHeadType
ImGearARTLineHeadType Enumeration
The type of the line's start head.
StartHeadAngle
Int
The angle of the line's start head.
StartHeadLength
Int
The length of the line's start head.
EndHeadType
ImGearARTLineHeadType Enumeration
The type of the line's end head.
EndHeadAngle
Int
The angle of the line's end head.
EndHeadLength
Int
The length of the line's end head.

Return Value:

The new instance of ImGearARTLine Class object.

See Also:

ImGearPoint Structure

ImGearRGBQuad Structure

ImGearARTPenStyle Enumeration

ImGearARTLineHeadType Enumeration


ImGearARTLine Properties

The ImGearARTLine Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
Color Property
Line color.
EndHeadAngle Property
The angle of the line's end head.
EndHeadLength Property
The length of the line's end head.
EndHeadType Property
The type of the line's end head.
EndPoint Property
End point of the line.
HeadFillColor Property
Fill color of the line's head.
Opacity Property
Line opacity.
StartHeadAngle Property
The angle of the line's start head.
StartHeadLength Property
The length of the line's start head.
StartHeadType Property
The type of the line's start head.
StartPoint Property
Start point of the line.
Style Property
The style of the line.
Width Property
The line width.


Color Property

32-bit
64-bit
CF
P
P

Description:

The line color.

Declaration:

public ImageGear.Core.IImGearRGBQuad Color { get, set }

Value:

ImGearRGBQuad Structure object interface.

Default value:

N/A

See Also:

ImGearRGBQuad Structure


EndHeadAngle Property

32-bit
64-bit
CF
P
P

Description:

The angle of the line's end head.

Declaration:

public int EndHeadAngle { get, set }

Value:

Integer value

Default value:

N/A


EndHeadLength Property

32-bit
64-bit
CF
P
P

Description:

The length of the line's end head.

Declaration:

public int EndHeadLength { get, set }

Value:

Integer value

Default value:

N/A


EndHeadType Property

32-bit
64-bit
CF
P
P

Description:

The type of the line's end head.

Declaration:

public ImageGear.ART.ImGearARTLineHeadType EndHeadType { get, set }

Value:

ImGearARTLineHeadType Enumeration value.

Default value:

N/A

See Also:

ImGearARTLineHeadType Enumeration


EndPoint Property

32-bit
64-bit
CF
P
P

Description:

The end point of the line.

Declaration:

public ImageGear.Core.ImGearPoint EndPoint { get, set }

Value:

ImGearPoint Structure object.

Default value:

N/A

See Also:

ImGearPoint Structure


HeadFillColor Property

32-bit
64-bit
CF
P
P

Description:

Fill color of the line's head.

Declaration:

public ImageGear.Core.IImGearRGBQuad HeadFillColor { get, set }

Value:

ImGearRGBQuad Structure object interface.

Default value:

N/A

See Also:

ImGearRGBQuad Structure


Opacity Property

32-bit
64-bit
CF
P
P

Description:

Opacity of the line.

Declaration:

public int Opacity { get, set }

Value:

Integer value

Default value:

255


StartHeadAngle Property

32-bit
64-bit
CF
P
P

Description:

The angle of the line's start head.

Declaration:

public int StartHeadAngle { get, set }

Value:

Integer value

Default value:

N/A


StartHeadLength Property

32-bit
64-bit
CF
P
P

Description:

The length of the line's start head.

Declaration:

public int StartHeadLength { get, set }

Value:

Integer value

Default value:

N/A


StartHeadType Property

32-bit
64-bit
CF
P
P

Description:

The type of the line's start head.

Declaration:

public ImageGear.ART.ImGearARTLineHeadType StartHeadType { get, set }

Value:

ImGearARTLineHeadType Enumeration value.

Default value:

N/A

See Also:

ImGearARTLineHeadType Enumeration


StartPoint Property

32-bit
64-bit
CF
P
P

Description:

The start point of the line.

Declaration:

public ImageGear.Core.ImGearPoint StartPoint { get, set }

Value:

ImGearPoint Structure object.

Default value:

N/A

See Also:

ImGearPoint Structure


Style Property

32-bit
64-bit
CF
P
P

Description:

The line style.

Declaration:

public ImageGear.ART.ImGearARTPenStyle Style { get, set }

Value:

ImGearARTPenStyle Enumeration value.

Default value:

N/A

See Also:

ImGearARTPenStyle Enumeration


Width Property

32-bit
64-bit
CF
P
P

Description:

Width of the line.

Declaration:

public int Width { get, set }

Value:

Integer value

Default value:

1


ImGearARTLineMarkStat Class

32-bit
64-bit
CF
P
P

Description:

This class represents specific statistics information about the line ART marks. This information is: length of the ART mark.

An instance of the ImGearARTLineMarkStat Class is always created for the specified mark object and should not be used after destroying that mark object.

Declaration:

public class ImGearARTLineMarkStat : ImGearARTMarkStat

Members:

Properties
Name
Description
Length Property
Specifies the total length of the line mark.

See Also:

ImGearARTMarkStat Class

ImGearARTShapeMarkStat Class

ImGearARTPointMarkStat Class


ImGearARTLineMarkStat Properties

The ImGearARTLineMarkStat Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
Length Property
Specifies the total length of the line mark.


Length Property

32-bit
64-bit
CF
P
P

Description:

This property specifies the total length of the original ART mark.

Declaration:

public double Length { get }

Value:

double value


ImGearARTMark Class

32-bit
64-bit
CF
P
P

Description:

Abstract ART mark class that provides general properties and methods for all mark types.

Declaration:

public abstract class ImGearARTMark : ImageGear.ART.ImGearARTSelection

Members:

Properties
Name
Description
Bounds Property
Mark's bounding rectangle in abstract coordinates.
Type Property
Mark's type.
Visible Property
Mark's visibility state.
UserData Property
Gets/Sets user data specified for the mark.

Methods
Name
Description
Clone Method
Creates new object that is an exact copy of the current mark.
FromLegacyMark Method
Converts legacy ART2.0 mark into the appropriate ART 3.0 mark.
Move Method
Method that moves mark.

Sample Code:

C#
// Iterate through art marks on the page, foreach uses ImGearARTPage.GetEnumerator()
//  to get a ImGearARTPageEnumerator which is used for the foreach.
foreach( ImGearARTMark igARTMark in igARTPage)
{
    //Move the art mark.
    igARTMark.Move(50, 50);
}

VB.NET
' Iterate through art marks on the page, foreach uses ImGearARTPage.GetEnumerator()
'  to get a ImGearARTPageEnumerator which is used for the foreach.
For Each igARTMark As ImGearARTMark In igARTPage
    'Move the art mark.
    igARTMark.Move(50, 50)
Next


ImGearARTMark Properties

The ImGearARTMark Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
Bounds Property
Mark's bounding rectangle in abstract coordinates.
Type Property
Mark's type.
Visible Property
Mark's visibility state.
UserData Property
Gets/Sets user data specified for the mark.


Bounds Property

32-bit
64-bit
CF
P
P

Description:

Mark's bounding rectangle in abstract coordinates. Type of the mark's coordinate system is specifying when using ImGearARTPage Class . AddMark Method.

Declaration:

public abstract ImageGear.Core.ImGearRectangle Bounds { get }

Value:

ImGearRectangle Structure object.

Default value:

N/A

See Also:

ImGearRectangle Structure


Type Property

32-bit
64-bit
CF
P
P

Description:

Mark's type.

Declaration:

public abstract ImageGear.ART.ImGearARTMarkType Type { get }

Value:

ImGearARTMarkType Enumeration value.

Default value:

N/A

See Also:

ImGearARTMarkType Enumeration


Visible Property

32-bit
64-bit
CF
P
P

Description:

Determines whether the mark is visible or not.

Declaration:

public abstract bool Visible { get, set }

Value:

True, False

Default value:

True


UserData Property

32-bit
64-bit
CF
P
P

Description:

Gets/Sets user data specified for the mark. You can save/load the data associated with this property to/from XML.

In order to do that you need to declare serializable class, create and initialize an object of that class, and attach it to ImGearARTMark.UserData:

[Serializable]
    public class UserData
    {
        string StringData;
        int IntData;
        public UserData(string stringData, int intData)
        {
            StringData = stringData;
            IntData = intData;
        }
    }

To save user data use this before exporting to XML:

    UserData userData = new UserData("string data to export to XML", 99);
    artGUI.Page.MarkGet(0).UserData = userData;

To load user data import the XML content and use this:

    UserData olddata = (UserData)artGUI.Page.MarkGet(0).UserData;

Declaration:

public System.Object UserData { get, set }

Value:

Object

Default value:

N/A


ImGearARTMark Methods

The ImGearARTMark Class of the ImageGear.ART Namespace has the following methods:

Methods
Name
Description
Clone Method
Creates new object that is an exact copy of the current mark.
FromLegacyMark Method
Converts legacy ART2.0 mark into the appropriate ART 3.0 mark.
Move Method
Method that moves mark.


Clone Method

32-bit
64-bit
CF
P
P

Description:

Creates new object that is an exact copy of the current mark.

Declaration:

public System.Object Clone (  )

Return Value:

The copy of the current mark.


FromLegacyMark Method

32-bit
64-bit
CF
P
P

Description:

Converts legacy ART2.0 mark into the appropriate ART 3.0 mark.

Declaration:

public static ImageGear.ART.ImGearARTMark FromLegacyMark ( ImageGear.ART.ImGearARTMark
LegacyMark )

Parameters:

Name
Type
Description
LegacyMark
ImGearARTMark Class
Legacy ART 2.0 mark to convert.

Return Value:

ART 3.0 mark.

See Also:

ImGearARTMark Class


Move Method

32-bit
64-bit
CF
P
P

Description:

Moves mark by specified offset.

Declaration:

public abstract void Move ( Int OffsetX , Int OffsetY )

Parameters:

Name
Type
Description
OffsetX
Int
X offset to move.
OffsetY
Int
Y offset to move.

Return Value:

None


ImGearARTMarkStat Class

32-bit
64-bit
CF
P
P

Description:

This abstract class is a base for a set of classes intented to represent some specific statistics information about ART marks. Such information could be: area and perimeter for shape marks (rectangle, ellipse, etc.), length for line marks (line, polyline, arrow, etc.), and so on.

Declaration:

public abstract class ImGearARTMarkStat

Members:

Properties
Name
Description
BoundsArea Property
Specifies the area of the marks' bounds rectangle.
BoundsPerimeter Property
Specifies the perimeter of the marks' bounds rectangle.
Mark Property
Reference to the original ART mark.

Methods
Name
Description
Create Method
Creates and initializes an instance of the ImGearARTMarkStat Class for an ART mark.

See Also:

ImGearARTShapeMarkStat Class

ImGearARTLineMarkStat Class

ImGearARTPointMarkStat Class


ImGearARTMarkStat Properties

The ImGearARTMarkStat Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
BoundsArea Property
Specifies the area of the marks' bounds rectangle.
BoundsPerimeter Property
Specifies the perimeter of the marks' bounds rectangle.
Mark Property
Reference to the original ART mark.


BoundsArea Property

32-bit
64-bit
CF
P
P

Description:

This property specifies the area of the marks' bounds rectangle.

Declaration:

public double BoundsArea { get }

Value:

double value


BoundsPerimeter Property

32-bit
64-bit
CF
P
P

Description:

This property specifies the perimeter of the mark's bounds rectangle.

Declaration:

public double BoundsPerimeter { get }

Value:

double value


Mark Property

32-bit
64-bit
CF
P
P

Description:

This property specifies a reference to the original ART mark.

Declaration:

public ImGearARTMark Mark { get }

Value:

ImGearARTMark Class


ImGearARTMarkStat Methods

The ImGearARTMarkStat Class of the ImageGear.ART Namespace has the following methods:

Methods
Name
Description
Create Method
Creates and initializes an instance of the ImGearARTMarkStat Class for an ART mark.


Create Method

32-bit
64-bit
CF
P
P

Description:

This static method creates and initializes an instance of ImGearARTMarkStat Class for a given ART mark.

Declaration:

public static ImGearARTMarkStat Create(ImGearARTMark Mark)

Parameters:

Name
Type
Description
Mark
ImGearARTMark Class
The original ART mark.

Return Value:

Created instance of the ImGearARTMarkStat Class.


ImGearARTNote Class

32-bit
64-bit
CF
P
P

Description:

Legacy ART Attach-A-Note mark.

Declaration:

public class ImGearARTNote : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTNote Constructor
Creates a new instance of ImGearARTNote object.
ImGearARTNote Constructor
Creates a new instance of ImGearARTNote object.

Properties
Name
Description
FillColor Property
Fill color of the mark.
FontName Property
Font name of the text of the mark.
FontSize Property
Font size of the text of the mark.
FontStyle Property
Font style of the text of the mark.
FontDisablePPM Property
Option to enable/disable PPM in font size calculations.
Height Property
Height of the mark's rectangle.
Text Property
Text of the note.
TextColor Property
Color of the text.
Width Property
Width of the mark's rectangle.
X Property
The X coordinate of the top-left point of the mark's rectangle.
Y Property
The Y coordinate of the top-left point of the mark's rectangle.

Methods
Name
Description
BeginEdit Method
Begins text editing process.
EndEdit Method
Ends text editing process.

Sample Code:

C#
// Setup rectangle for the note mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 300, 100);
// Setup color for the note text.
ImGearRGBQuad igRGBQuadText = new ImGearRGBQuad(0, 0, 0);
// Setup color for the note fill.
ImGearRGBQuad igRGBQuadFill = new ImGearRGBQuad(40, 200, 40);
// Create note mark using size 16 italic Arial font
ImGearARTNote igARTNote = new ImGearARTNote(
    igRectangle, "ImGearARTNote test", igRGBQuadText, igRGBQuadFill,
    "Arial", (float)16.0, FontStyle.Italic
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTNote, ImGearARTCoordinatesType.IMAGE_COORD);

VB.NET
' Setup rectangle for the note mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 300, 100)
' Setup color for the note text.
Dim igRGBQuadText As New ImGearRGBQuad(0, 0, 0)
' Setup color for the note fill.
Dim igRGBQuadFill As New ImGearRGBQuad(40, 200, 40)
' Create note mark using size 16 italic Arial font
Dim igARTNote As New ImGearARTNote( _
 igRectangle, "ImGearARTNote test", igRGBQuadText, igRGBQuadFill, _
"Arial", CSng(16), FontStyle.Italic)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTNote, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTNote Constructors

The ImGearARTNote Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTNote Constructor
Creates a new instance of ImGearARTNote object.
ImGearARTNote Constructor
Creates a new instance of ImGearARTNote object.


ImGearARTNote Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTNote Class object.

Declaration:

public ImGearARTNote ( ImageGear.Core.IImGearRectangle Rect , String Text ,
ImageGear.Core.IImGearRGBQuad TextColor , ImageGear.Core.IImGearRGBQuad FillColor )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
The mark rectangle.
Text
String
The text of the mark.
TextColor
ImGearRGBQuad Structure
The color of the text.
FillColor
ImGearRGBQuad Structure
The fill color of the mark.

Return Value:

The new instance of ImGearARTNote Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure


ImGearARTNote Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTNote Class object.

Declaration:

public ImGearARTNote ( ImageGear.Core.IImGearRectangle Rect , String Text ,
ImageGear.Core.IImGearRGBQuad TextColor , ImageGear.Core.IImGearRGBQuad FillColor , String
FontName , float FontSize , System.Drawing.FontStyle FontStyle )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
The mark rectangle.
Text
String
The text of the mark.
TextColor
ImGearRGBQuad Structure
The color of the text.
FillColor
ImGearRGBQuad Structure
The fill color of the mark.
FontName
String
The name of the font.
FontSize
float
The size of the font in points.
FontStyle
System.Drawing.FontStyle
The style of the font.

Return Value:

The new instance of ImGearARTNote Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure


ImGearARTNote Properties

The ImGearARTNote Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
FillColor Property
Fill color of the mark.
FontName Property
Font name of the text of the mark.
FontSize Property
Font size of the text of the mark.
FontStyle Property
Font style of the text of the mark.
FontDisablePPM Property
Option to enable/disable PPM in font size calculations.
Height Property
Height of the mark's rectangle.
Text Property
Text of the note.
TextColor Property
Color of the text.
Width Property
Width of the mark's rectangle.
X Property
The X coordinate of the top-left point of the mark's rectangle.
Y Property
The Y coordinate of the top-left point of the mark's rectangle.


FontName Property

32-bit
64-bit
CF
P
P

Description:

The font name of the mark's text.

Declaration:

public string FontName { get, set }

Value:

Font name string

Default value:

N/A


FontSize Property

32-bit
64-bit
CF
P
P

Description:

The font size, in points, of the mark's text.

Declaration:

public float FontSize { get, set }

Value:

Any positive value.

Default value:

N/A


FontStyle Property

32-bit
64-bit
CF
P
P

Description:

The font style of the mark's text.

Declaration:

public System.Drawing.FontStyle FontStyle { get, set }

Value:

FontStyle value.

Default value:

N/A


FontDisablePPM Property

32-bit
64-bit
CF
P
P

Description:

True - disables PPM and display parameters in font size calculations for the current mark, False - enables font size calculations.

Declaration:

public bool FontDisablePPM { get, set }

Value:

true/false

Default value:

false


Height Property

32-bit
64-bit
CF
P
P

Description:

Height of the mark rectangle.

Declaration:

public int Height { get, set }

Value:

Integer value

Default value:

N/A


Text Property

32-bit
64-bit
CF
P
P

Description:

The text of the mark.

Declaration:

public string Text { get, set }

Value:

Text string

Default value:

N/A


TextColor Property

32-bit
64-bit
CF
P
P

Description:

The text color.

Declaration:

public ImageGear.Core.IImGearRGBQuad TextColor { get, set }

Value:

ImGearRGBQuad Structure object interface.

Default value:

N/A

See Also:

ImGearRGBQuad Structure


Width Property

32-bit
64-bit
CF
P
P

Description:

Width of the mark rectangle.

Declaration:

public int Width { get, set }

Value:

Integer value

Default value:

N/A


X Property

32-bit
64-bit
CF
P
P

Description:

The X coordinate of the top-left point of the mark's rectangle.

Declaration:

public int X { get, set }

Value:

Integer value

Default value:

N/A


Y Property

32-bit
64-bit
CF
P
P

Description:

The Y coordinate of the top-left point of the mark's rectangle.

Declaration:

public int Y { get, set }

Value:

Integer value

Default value:

N/A


ImGearARTNote Methods

The ImGearARTNote Class of the ImageGear.ART Namespace has the following methods:

Methods
Name
Description
BeginEdit Method
Begins text editing process.
EndEdit Method
Ends text editing process.


BeginEdit Method

32-bit
64-bit
CF
P
P

Description:

Begins text editing process.

Declaration:

public System.Boolean BeginEdit ( ImageGear.Display.IImGearScrollableView PageView ,
ImageGear.Display.ImGearPageDisplay PageDisplay )

Parameters:

Name
Type
Description
PageView
IImGearScrollableView Interface
PageView control that contains text mark.
PageDisplay
ImGearPageDisplay Class
PageDisplay of the PageView control.

Return Value:

True if the editing has begun, False - otherwise.

See Also:

IImGearScrollableView Interface

ImGearPageDisplay Class


EndEdit Method

32-bit
64-bit
CF
P
P

Description:

Ends text editing process.

Declaration:

public void EndEdit ( ImageGear.Display.IImGearScrollableView PageView )

Parameters:

Name
Type
Description
PageView
IImGearScrollableView Interface
PageView control that contains text mark.

Return Value:

None.

See Also:

IImGearScrollableView Interface


ImGearARTPage Class

32-bit
64-bit
CF
P
P

Description:

Collection of ART groups. This class provides methods and properties for accessing individual marks on the page as well as a group of marks.

ImGearARTPage is completely independent from ImGearPage Class and can be associated with one or more ImGearPage Class objects.

Declaration:

public class ImGearARTPage

Members:

Constructors
Name
Description
ImGearARTPage Constructor
Creates a new instance of ImGearARTPage object.

Properties
Name
Description
Bounds Property
Specifies bounding rectangle for a page.
Groups Property
Array of ART groups on the page.
MarkCount Property
Marks count.
Orientation Property
Specifies ART page layout orientation, see Bounds for more information about page's layout rectangle.
PasteCount Property
The number of marks currently in the Windows clipboard.
StartIndex Property
Start index of the marks enumeration on the page.

Methods
Name
Description
AddMark Method
Adds the specified mark into the ARTPage's mark collection.
AddMark Method
Adds the specified mark into the ARTPage's group with the specified index.
AddMark Method
Adds the specified mark into the ARTPage's group with the specified name.
ConvertCoordinates Method
Translates coordinates between image and device coordinate systems.
CopyMarks Method
Copies an array of specified marks to the Windows clipboard.
CopyMarks Method
Copies a collection of specified marks to the Windows clipboard.
CutMarks Method
Cuts an array of specified marks to the Windows clipboard.
CutMarks Method
Cuts a collection of specified marks to the Windows clipboard.
GetEnumerator Method
Returns ImGearARTPageEnumerator.
HitTest Method
Returns the index of the mark located at the screen position [x, y]. If there are no marks at [x,y], the return value from this method is -1.
MarkBringToFront Method
Moves a specified mark to the top of the Z-Order.
MarkBringToFront Method
Moves a specified mark to the top of the Z-Order.
MarkCopy Method
Copies a specified mark to the Windows clipboard.
MarkCopy Method
Copies a specified mark to the Windows clipboard.
MarkCut Method
Cuts a specified mark to the Windows clipboard.
MarkCut Method
Cuts a specified mark to the Windows clipboard.
MarkGet Method
Gets the mark by its ID.
MarkIsSelected Method
Checks the specified mark if it is selected.
MarkIsSelected Method
Checks the mark specified by its ID if it is selected.
MarkIsValid Method
Checks the specified ID if it is valid mark ID.
MarkRemove Method
Deletes the mark specified.
MarkRemove Method
Deletes the mark specified by ID.
MarkSelect Method
Selects the mark specified.
MarkSelect Method
Selects the mark specified by ID.
MarkSendToBack Method
Moves a specified mark to the bottom of the Z-Order.
MarkSendToBack Method
Moves a specified mark to the bottom of the Z-Order.
MarkSetCoordType Method
Sets new type of the coordinates system for the specified mark.
MarkSetCoordType Method
Sets new type of the coordinates system for the specified mark.
PasteMarks Method
Pastes all the marks from the Windows clipboard to the ART page.
RemoveMarks Method
Deletes all marks from the ARTPage.
RemoveMarks Method
Deletes an array of specified marks.
RemoveMarks Method
Deletes a collection of specified marks.
SelectMarks Method
Selects/deselects all marks in the ART Page.
SetCoordType Method
Sets new type of the coordinates system for the entire mark collection.

Sample Code:

C#
// Build a list of selected marks.
ArrayList igARTMarks = new ArrayList();
foreach (ImGearARTMark igARTMark in igARTForms.Page)
{
    if (igARTForms.Page.MarkIsSelected(igARTMark))
        igARTMarks.Add(igARTMark);
}
// Delete the marks.
igARTForms.Page.RemoveMarks(igARTMarks);
// Redraw the view.
imGearPageView1.Invalidate();

VB .NET
' Build a list of selected marks.
Dim igARTMarks As ArrayList = New ArrayList()
For Each igARTMark As ImGearARTMark In igARTForms.Page
    If (igARTForms.Page.MarkIsSelected(igARTMark)) Then
        igARTMarks.Add(igARTMark)
    End If
Next
' Delete the marks.
igARTForms.Page.RemoveMarks(igARTMarks)
' Redraw the view.
ImGearPageView1.Invalidate()


ImGearARTPage Constructors

The ImGearARTPage Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTPage Constructor
Creates a new instance of ImGearARTPage object.


ImGearARTPage Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTPage Class object.

Declaration:

public ImGearARTPage (  )

Return Value:

The new instance of ImGearARTPage Class object.


ImGearARTPage Properties

The ImGearARTPage Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
Bounds Property
Specifies bounding rectangle for a page.
Groups Property
Array of ART groups on the page.
MarkCount Property
Marks count.
Orientation Property
Specifies ART page layout orientation, see Bounds for more information about page's layout rectangle.
PasteCount Property
The number of marks currently in the Windows clipboard.
StartIndex Property
Start index of the marks enumeration on the page.


Bounds Property

32-bit
64-bit
CF
P
P

Description:

Specifies bounding rectangle for a page. This is a rectangle that encloses all annotation marks on the page.

This property can be used if you want to change the default bounding rectangle or when the marks' coordinates are specified in device units. If this property is set to null and ART page is associated with ImGearPage Class the ImGearPage Class's rectangle is used.

Declaration:

public ImageGear.Core.IImGearRectangle Bounds { get, set }

Value:

ImGearRectangle Structure object interface.

Default value:

NULL

See Also:

ImGearRectangle Structure


Groups Property

32-bit
64-bit
CF
P
P

Description:

Array of ART groups.

Declaration:

public ImageGear.ART.ImGearARTGroupArray Groups { get }

Value:

ImGearARTGroupArray Class object.

Default value:

N/A

Sample Code:

C#
// Create and add some groups to the Groups array.
igARTPage.Groups.Add(new ImGearARTGroup("Group1", "First test group"));
igARTPage.Groups.Add(new ImGearARTGroup("Group2", "Second test group"));
// Create start and end point points.
ImGearPoint igPointStart = new ImGearPoint();
ImGearPoint igPointEnd = new ImGearPoint();
// Setup color for the line.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(40, 40, 200);
// Create a series of diagonal lines adding each one to the 2 groups,
// alternating between them.
ImGearARTLine igARTLine;
for (int i = 0; i < 20; i++)
{
    igPointStart.X = i * 10;
    igPointStart.Y = 10;
    igPointEnd.X = i * 10 + 100;
    igPointEnd.Y = 110;
    igARTLine = new ImGearARTLine(igPointStart, igPointEnd, igRGBQuad);
    // Add the annotation to one of the 2 groups.
    if (i % 2 == 0)
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group1");
    else
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group2");
}
// Select Group1
igARTPage.Groups["Group1"].Select(true);
// Delete Group2
MessageBox.Show("Deleting second group of lines.", "Deleting...");
igARTPage.Groups["Group2"].RemoveAll();

VB.NET
' Create and add some groups to the Groups array.
igARTPage.Groups.Add(New ImGearARTGroup("Group1", "First test group"))
igARTPage.Groups.Add(New ImGearARTGroup("Group2", "Second test group"))
' Create start and end point points.
Dim igPointStart As New ImGearPoint()
Dim igPointEnd As New ImGearPoint()
' Setup color for the line.
Dim igRGBQuad As New ImGearRGBQuad(40, 40, 200)
' Create a series of diagonal lines adding each one to the 2 groups,
' alternating between them.
Dim igARTLine As ImGearARTLine
For i As Integer = 0 To 19
    igPointStart.X = i * 10
    igPointStart.Y = 10
    igPointEnd.X = i * 10 + 100
    igPointEnd.Y = 110
    igARTLine = New ImGearARTLine(igPointStart, igPointEnd, igRGBQuad)
    ' Add the annotation to one of the 2 groups.
    If i Mod 2 = 0 Then
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group1")
    Else
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group2")
    End If
Next
' Select Group1
igARTPage.Groups("Group1").[Select](True)
' Delete Group2
MessageBox.Show("Deleting second group of lines.", "Deleting...")
igARTPage.Groups("Group2").RemoveAll()

See Also:

ImGearARTGroupArray Class


MarkCount Property

32-bit
64-bit
CF
P
P

Description:

The number of marks on the page.

Declaration:

public int MarkCount { get }

Value:

Integer value

Default value:

N/A


Orientation Property

32-bit
64-bit
CF
P
P

Description:

Specifies ART page layout orientation, see Bounds Property for more information about page's layout rectangle.

Declaration:

public ImageGear.Core.ImGearOrientation Orientation { get, set }

Value:

ImGearOrientationModes Enumeration value.

Default value:

1

See Also:

ImGearOrientation Structure

ImGearOrientationModes Enumeration


PasteCount Property

32-bit
64-bit
CF
P
P

Description:

The number of marks currently in the Windows clipboard.

Declaration:

public int PasteCount { get }

Value:

Integer value

Default value:

N/A


StartIndex Property

32-bit
64-bit
CF
P
P

Description:

Start index of the marks enumeration on the page.

Declaration:

public int StartIndex { get, set }

Value:

Integer value

Default value:

N/A


ImGearARTPage Methods

The ImGearARTPage Class of the ImageGear.ART Namespace has the following methods:

Methods
Name
Description
AddMark Method
Adds the specified mark into the ARTPage's mark collection.
AddMark Method
Adds the specified mark into the ARTPage's group with the specified index.
AddMark Method
Adds the specified mark into the ARTPage's group with the specified name.
ConvertCoordinates Method
Translates coordinates between image and device coordinate systems.
CopyMarks Method
Copies an array of specified marks to the Windows clipboard.
CopyMarks Method
Copies a collection of specified marks to the Windows clipboard.
CutMarks Method
Cuts an array of specified marks to the Windows clipboard.
CutMarks Method
Cuts a collection of specified marks to the Windows clipboard.
GetEnumerator Method
Returns ImGearARTPageEnumerator.
HitTest Method
Returns the index of the mark located at the screen position [x, y]. If there are no marks at [x,y], the return value from this method is -1.
MarkBringToFront Method
Moves a specified mark to the top of the Z-Order.
MarkBringToFront Method
Moves a specified mark to the top of the Z-Order.
MarkCopy Method
Copies a specified mark to the Windows clipboard.
MarkCopy Method
Copies a specified mark to the Windows clipboard.
MarkCut Method
Cuts a specified mark to the Windows clipboard.
MarkCut Method
Cuts a specified mark to the Windows clipboard.
MarkGet Method
Gets the mark by its ID.
MarkIsSelected Method
Checks the specified mark if it is selected.
MarkIsSelected Method
Checks the mark specified by its ID if it is selected.
MarkIsValid Method
Checks the specified ID if it is valid mark ID.
MarkRemove Method
Deletes the mark specified.
MarkRemove Method
Deletes the mark specified by ID.
MarkSelect Method
Selects the mark specified.
MarkSelect Method
Selects the mark specified by ID.
MarkSendToBack Method
Moves a specified mark to the bottom of the Z-Order.
MarkSendToBack Method
Moves a specified mark to the bottom of the Z-Order.
MarkSetCoordType Method
Sets new type of the coordinates system for the specified mark.
PasteMarks Method
Pastes all the marks from the Windows clipboard to the ART page.
RemoveMarks Method
Deletes all marks from the ARTPage.
RemoveMarks Method
Deletes an array of specified marks.
RemoveMarks Method
Deletes a collection of specified marks.
SelectMarks Method
Selects/deselects all marks in the ART Page.
SetCoordType Method
Sets new type of the coordinates system for the entire mark collection.


AddMark Method

32-bit
64-bit
CF
P
P

Description:

Adds the specified mark into the ARTPage's mark collection. You must specify the type of the mark's coordinate system. The mark will be drawn according to the type of its coordinate system.

Declaration:

public Int AddMark ( ImageGear.ART.ImGearARTMark Mark ,
ImageGear.ART.ImGearARTCoordinatesType Type )

Parameters:

Name
Type
Description
Mark
ImGearARTMark Class
Reference to the mark to add.
Type
ImGearARTCoordinatesType Enumeration
Type of the coordinate system the mark coordinates are specified in.

Return Value:

Integer value

Sample Code:

C#
ImGearARTPage igARTPage = igARTForms.Page;
// Setup rectangle for new annotation.
ImGearRectangle igRectangle = new ImGearRectangle(0,0,200,20);
// Setup color for annotation.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(0, 255, 0);
// Create the annotation.
ImGearARTTypedText igARTTypedText = new ImGearARTTypedText(
    igRectangle, "Test Typed Text Annotation", igRGBQuad
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTTypedText, ImGearARTCoordinatesType.IMAGE_COORD);

VB .NET
Dim igARTPage As ImGearARTPage = igARTForms.Page
'Setup rectangle for new annotation.
Dim igRectangle As ImGearRectangle = New ImGearRectangle(0, 0, 200, 20)
'Setup color for annotation.
Dim igRGBQuad As ImGearRGBQuad = New ImGearRGBQuad(0, 255, 0)
'Create the annotation.
Dim igARTTypedText As ImGearARTTypedText = New ImGearARTTypedText( _
        igRectangle, "Test Typed Text Annotation", igRGBQuad _
        )
'Add the annotation to the ARTPage.
igARTPage.AddMark(igARTTypedText, ImGearARTCoordinatesType.IMAGE_COORD)

See Also:

ImGearARTMark Class

ImGearARTCoordinatesType Enumeration


AddMark Method

32-bit
64-bit
CF
P
P

Description:

Adds the specified mark into the ARTPage's group with the specified index. You must specify the type of the mark's coordinate system. The mark will be drawn according to the type of its coordinate system.

Declaration:

public Int AddMark ( ImageGear.ART.ImGearARTMark Mark ,
ImageGear.ART.ImGearARTCoordinatesType Type , Int GroupIndex )

Parameters:

Name
Type
Description
Mark
ImGearARTMark Class
Reference to the mark to add.
Type
ImGearARTCoordinatesType Enumeration
Type of the coordinate system the mark coordinates are specified in.
GroupIndex
Int
Index of the group to add the mark to.

Return Value:

Integer value

See Also:

ImGearARTMark Class

ImGearARTCoordinatesType Enumeration


AddMark Method

32-bit
64-bit
CF
P
P

Description:

Adds the specified mark into the ARTPage's group with the specified name. You must specify the type of the mark's coordinate system. The mark will be drawn according to the type of its coordinate system.

Declaration:

public Int AddMark ( ImageGear.ART.ImGearARTMark Mark ,
ImageGear.ART.ImGearARTCoordinatesType Type , String GroupName )

Parameters:

Name
Type
Description
Mark
ImGearARTMark Class
Reference to the mark to add.
Type
ImGearARTCoordinatesType Enumeration
Type of the coordinate system the mark coordinates are specified in.
GroupName
String
Name of the group to add the mark to.

Return Value:

Integer value

Sample Code:

C#
// Create and add some groups to the Groups array.
igARTPage.Groups.Add(new ImGearARTGroup("Group1", "First test group"));
igARTPage.Groups.Add(new ImGearARTGroup("Group2", "Second test group"));
// Create start and end point points.
ImGearPoint igPointStart = new ImGearPoint();
ImGearPoint igPointEnd = new ImGearPoint();
// Setup color for the line.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(40, 40, 200);
// Create a series of diagonal lines adding each one to the 2 groups,
// alternating between them.
ImGearARTLine igARTLine;
for (int i = 0; i < 20; i++)
{
    igPointStart.X = i * 10;
    igPointStart.Y = 10;
    igPointEnd.X = i * 10 + 100;
    igPointEnd.Y = 110;
    igARTLine = new ImGearARTLine(igPointStart, igPointEnd, igRGBQuad);
    // Add the annotation to one of the 2 groups.
    if (i % 2 == 0)
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group1");
    else
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group2");
}
// Select Group1
igARTPage.Groups["Group1"].Select(true);
// Delete Group2
MessageBox.Show("Deleting second group of lines.", "Deleting...");
igARTPage.Groups["Group2"].RemoveAll();

VB.NET
' Create and add some groups to the Groups array.
igARTPage.Groups.Add(New ImGearARTGroup("Group1", "First test group"))
igARTPage.Groups.Add(New ImGearARTGroup("Group2", "Second test group"))
' Create start and end point points.
Dim igPointStart As New ImGearPoint()
Dim igPointEnd As New ImGearPoint()
' Setup color for the line.
Dim igRGBQuad As New ImGearRGBQuad(40, 40, 200)
' Create a series of diagonal lines adding each one to the 2 groups,
' alternating between them.
Dim igARTLine As ImGearARTLine
For i As Integer = 0 To 19
    igPointStart.X = i * 10
    igPointStart.Y = 10
    igPointEnd.X = i * 10 + 100
    igPointEnd.Y = 110
    igARTLine = New ImGearARTLine(igPointStart, igPointEnd, igRGBQuad)
    ' Add the annotation to one of the 2 groups.
    If i Mod 2 = 0 Then
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group1")
    Else
        igARTPage.AddMark(igARTLine, ImGearARTCoordinatesType.IMAGE_COORD, "Group2")
    End If
Next
' Select Group1
igARTPage.Groups("Group1").[Select](True)
' Delete Group2
MessageBox.Show("Deleting second group of lines.", "Deleting...")
igARTPage.Groups("Group2").RemoveAll()

See Also:

ImGearARTMark Class

ImGearARTCoordinatesType Enumeration


ConvertCoordinates Method

32-bit
64-bit
CF
P
P

Description:

This method translates coordinates between image and device coordinate systems (depending on the value of the Mode parameter) taking into account orientation of the ART page. The array can point to array of points or double points.

Declaration:

public void ConvertCoordinates ( ImageGear.Display.IImGearScrollableView PageView ,
ImageGear.Display.ImGearPageDisplay PageDisplay , System.Drawing.Graphics gr ,
ImageGear.Display.ImGearCoordConvModes Mode , System.Array array )

Parameters:

Name
Type
Description
PageView
IImGearScrollableView Interface
IImGearScrollableView interface; represents .NET form to draw image on.
PageDisplay
ImGearPageDisplay Class
PageDisplay associated with PageView control.
gr
System.Drawing.Graphics
Graphics object used to draw this image.
Mode
ImGearCoordConvModes Enumeration
Specifies translation direction; either IMAGE_TO_DEVICE or DEVICE_TO_IMAGE.
array
System.Array
Array with point coordinates.

Return Value:

None

Sample Code:

C#
//Create array for use of ConvertCoordinates function.
ImGearPoint[] igPoints = new ImGearPoint[1];
// Setup location for the point based on display coordinates,
//  often received from mouse events.
igPoints[0] = new ImGearPoint(100, 100);
// Convert point from display coordinates to image coordinates.
igARTPage.ConvertCoordinates(
    igPageView, igPageView.Display, igPageView.CreateGraphics(),
    ImGearCoordConvModes.DEVICE_TO_IMAGE, igPoints
);
// Setup color for the point.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(0, 255, 0);
// Create the point annotation with a width of 10 and 60% opacity
ImGearARTPoint igARTPoint = new ImGearARTPoint(
    igPoints[0], igRGBQuad, 10, (int)(0.60 * 255)
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTPoint, ImGearARTCoordinatesType.IMAGE_COORD);

VB.NET
'Create array for use of ConvertCoordinates function.
Dim igPoints As ImGearPoint() = New ImGearPoint(0) {}
' Setup location for the point based on display coordinates,
'  often received from mouse events.
igPoints(0) = New ImGearPoint(100, 100)
' Convert point from display coordinates to image coordinates.
igARTPage.ConvertCoordinates(igPageView, igPageView.Display, igPageView.CreateGraphics(), _
 ImGearCoordConvModes.DEVICE_TO_IMAGE, igPoints)
' Setup color for the point.
Dim igRGBQuad As New ImGearRGBQuad(0, 255, 0)
' Create the point annotation with a width of 10 and 60% opacity
Dim igARTPoint As New ImGearARTPoint(igPoints(0), igRGBQuad, 10, CInt((0.6 * 255)))
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTPoint, ImGearARTCoordinatesType.IMAGE_COORD)

See Also:

IImGearScrollableView Interface

ImGearPageDisplay Class

ImGearCoordConvModes Enumeration


CopyMarks Method

32-bit
64-bit
CF
P
P

Description:

Copies an array of specified marks to the Windows clipboard.

Declaration:

public void CopyMarks ( int[] MarksIDs )

Parameters:

Name
Type
Description
MarksIDs
int
Array of mark IDs to copy.

Return Value:

None


CopyMarks Method

32-bit
64-bit
CF
P
P

Description:

Copies a collection of specified marks to the Windows clipboard.

Declaration:

public void CopyMarks ( System.Collections.ArrayList Marks )

Parameters:

Name
Type
Description
Marks
System.Collections.ArrayList
Collection of marks to copy.

Return Value:

None

Sample Code:

C#
// Array to hold a list of marks.
ArrayList igARTMarkList = new ArrayList();
// Add all valid marks with id's between 0 to 999 to an array.
for (int i = 0; i < 1000; ++i)
{
    if (igARTPage.MarkIsValid(i))
        igARTMarkList.Add(igARTPage.MarkGet(i));
}
// Copy the marks from the page to the clipboard.
igARTPage.CopyMarks(igARTMarkList);
// Move all the marks
foreach (ImGearARTMark igARTMark in igARTPage)
{
    igARTMark.Move(50, 50);
}
//Paste the original marks back onto the page.
igARTPage.PasteMarks();

VB.NET
' Array to hold a list of marks.
Dim igARTMarkList As New ArrayList()
For i As Integer = 0 To 999
    ' Add all valid marks with id's between 0 to 999 to an array.
    If igARTPage.MarkIsValid(i) Then
        igARTMarkList.Add(igARTPage.MarkGet(i))
    End If
Next
' Copy the marks from the page to the clipboard.
igARTPage.CopyMarks(igARTMarkList)
' Move all the marks
For Each igARTMark As ImGearARTMark In igARTPage
    igARTMark.Move(50, 50)
Next
'Paste the original marks back onto the page.
igARTPage.PasteMarks()


CutMarks Method

32-bit
64-bit
CF
P
P

Description:

Cuts an array of specified marks to the Windows clipboard.

Declaration:

public void CutMarks ( int[] MarksIDs )

Parameters:

Name
Type
Description
MarksIDs
int
Array of mark IDs to copy.

Return Value:

None


CutMarks Method

32-bit
64-bit
CF
P
P

Description:

Cuts a collection of specified marks to the Windows clipboard.

Declaration:

public void CutMarks ( System.Collections.ArrayList Marks )

Parameters:

Name
Type
Description
Marks
System.Collections.ArrayList
Collection of marks to cut.

Return Value:

None

Sample Code:

C#
// Array to hold a list of marks.
ArrayList igARTMarkList = new ArrayList();
// Add all valid marks with id's between 0 to 999 to an array.
for (int i = 0; i < 1000; ++i )
{
    if (igARTPage.MarkIsValid(i))
        igARTMarkList.Add(igARTPage.MarkGet(i));
}
// Cut the marks from the page to the clipboard.
igARTPage.CutMarks(igARTMarkList);
// Create a new art page and paste the marks into it.
ImGearARTPage igARTPageNew = new ImGearARTPage();
igARTPageNew.PasteMarks();
// Change the displayed marks to the new art page.
igPageView.Display.ARTPage = igARTPageNew;
igPageView.Invalidate();

VB.NET
' Array to hold a list of marks.
Dim igARTMarkList As New ArrayList()
For i As Integer = 0 To 999
    ' Add all valid marks with id's between 0 to 999 to an array.
    If igARTPage.MarkIsValid(i) Then
        igARTMarkList.Add(igARTPage.MarkGet(i))
    End If
Next
' Cut the marks from the page to the clipboard.
igARTPage.CutMarks(igARTMarkList)
' Create a new art page and paste the marks into it.
Dim igARTPageNew As New ImGearARTPage()
igARTPageNew.PasteMarks()
' Change the displayed marks to the new art page.
igPageView.Display.ARTPage = igARTPageNew
igPageView.Invalidate()


GetEnumerator Method

32-bit
64-bit
CF
P
P

Description:

Returns ImGearARTPageEnumerator.

Declaration:

public ImageGear.ART.ImGearARTPageEnumerator GetEnumerator (  )

Return Value:

ImGearARTPageEnumerator Class object.

See Also:

ImGearARTPageEnumerator Class

Sample Code:

C#
// Iterate through art marks on the page, foreach uses ImGearARTPage.GetEnumerator()
//  to get a ImGearARTPageEnumerator which is used for the foreach.
foreach( ImGearARTMark igARTMark in igARTPage)
{
    //Move the art mark.
    igARTMark.Move(50, 50);
}

VB.NET
' Iterate through art marks on the page, foreach uses ImGearARTPage.GetEnumerator()
'  to get a ImGearARTPageEnumerator which is used for the foreach.
For Each igARTMark As ImGearARTMark In igARTPage
    'Move the art mark.
    igARTMark.Move(50, 50)
Next


HitTest Method

32-bit
64-bit
CF
P
P

Description:

Returns the index of the mark located at the screen position [x, y]. If there are no marks at [x,y], the return value from this method is -1.

Declaration:

public Int HitTest ( ImageGear.Core.ImGearPoint DevicePoint ,
ImageGear.Display.IImGearScrollableView PageView , ImageGear.Display.ImGearPageDisplay
PageDisplay , ImageGear.Display.IGGraphics gr , Int offLeft , Int offTop )

Parameters:

Name
Type
Description
DevicePoint
ImGearPoint Structure
Screen point to test.
PageView
IImGearScrollableView Interface
PageView control that contains the marks.
PageDisplay
ImGearPageDisplay Class
PageDisplay associated with PageView control.
gr
IGGraphics
PageView's graphics object.
offLeft
Int
Offset from left.
offTop
Int
Offset from top.

Return Value:

Integer value.

Sample Code:

C#
private void imGearPageView1_MouseDown(object sender, MouseEventArgs e)
{
    if (!runHitTest)
        igARTForms.MouseDown(sender,e);
    else
    {
        ImGearARTPage igARTPage = igARTForms.Page;
        // Create point parameter for current mouse position.
        ImGearPoint igPoint = new ImGearPoint(e.X, e.Y);
        // Get the IGGraphics object for the current PageView.
        IGGraphics igGraphics = new IGGraphics(
            imGearPageView1.CreateGraphics(),imGearPageView1);
        // Run HitTest on current position getting the top most mark.
        int markID = igARTPage.HitTest(igPoint, imGearPageView1,
            imGearPageView1.Display, igGraphics, 0, 0);
        // Check if any mark was found.
        if (markID >= 0)
        {
            igARTPage.MarkSelect(markID, true);
            imGearPageView1.Invalidate();
        }
    }
}

VB .NET
Private Sub ImGearPageView1_MouseDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) _
                Handles ImGearPageView1.MouseDown
    If (Not runHitTest) Then
        igARTForms.MouseDown(sender, e)
    Else
        Dim igARTPage As ImGearARTPage = igARTForms.Page
        'Create point parameter for current mouse position.
        Dim igPoint As ImGearPoint = New ImGearPoint(e.X, e.Y)
        'Get the IGGraphics object for the current PageView.
        Dim igGraphics As IGGraphics = New IGGraphics( _
            ImGearPageView1.CreateGraphics(), ImGearPageView1)
        'Run HitTest on current position getting the top most mark.
        Dim markID As Integer = igARTPage.HitTest(igPoint, ImGearPageView1, _
            ImGearPageView1.Display, igGraphics, 0, 0)
        'Check if any mark was found.
        If (markID >= 0) Then
            igARTPage.MarkSelect(markID, True)
            ImGearPageView1.Invalidate()
        End If
    End If
End Sub

See Also:

ImGearPoint Structure

IImGearScrollableView Interface

ImGearPageDisplay Class


MarkBringToFront Method

32-bit
64-bit
CF
P
P

Description:

Moves a specified mark to the top of the Z-Order.

Declaration:

public void MarkBringToFront ( Int MarkID )

Parameters:

Name
Type
Description
MarkID
Int
ID of the mark to move.

Return Value:

None


MarkBringToFront Method

32-bit
64-bit
CF
P
P

Description:

Moves a specified mark to the top of the Z-Order.

Declaration:

public void MarkBringToFront ( ImageGear.ART.ImGearARTMark Mark )

Parameters:

Name
Type
Description
mark
ImGearARTMark Class
Mark to be moved.

Return Value:

None

Sample Code:

C#
// Send any text marks true the back of the z order, and line marks to the front.
foreach (ImGearARTMark igARTMark in igARTPage.Groups[0])
{
    if (igARTMark is ImGearARTText)
        igARTPage.MarkSendToBack(igARTMark);
    else if (igARTMark is ImGearARTLine)
        igARTPage.MarkBringToFront(igARTMark);
}

VB.NET
' Send any text marks true the back of the z order, and line marks to the front.
For Each igARTMark As ImGearARTMark In igARTPage.Groups(0)
    If TypeOf igARTMark Is ImGearARTText Then
        igARTPage.MarkSendToBack(igARTMark)
    ElseIf TypeOf igARTMark Is ImGearARTLine Then
        igARTPage.MarkBringToFront(igARTMark)
    End If
Next

See Also:

ImGearARTMark Class


MarkCopy Method

32-bit
64-bit
CF
P
P

Description:

Copies a specified mark to the Windows clipboard.

Declaration:

public void MarkCopy ( Int MarkID )

Parameters:

Name
Type
Description
MarkID
Int
The ID of the mark to be copied.

Return Value:

None


MarkCopy Method

32-bit
64-bit
CF
P
P

Description:

Copies a specified mark to the Windows clipboard.

Declaration:

public void MarkCopy ( ImageGear.ART.ImGearARTMark Mark )

Parameters:

Name
Type
Description
Mark
ImGearARTMark Class
Mark to be copied.

Return Value:

None

Sample Code:

C#
// Copy first mark found to be selected to the clipboard
foreach (ImGearARTMark igARTMark in igARTPage)
{
    if (igARTPage.MarkIsSelected(igARTMark))
    {
        igARTPage.MarkCopy(igARTMark);
        break;
    }
}

VB.NET
' Copy first mark found to be selected to the clipboard
For Each igARTMark As ImGearARTMark In igARTPage
    If igARTPage.MarkIsSelected(igARTMark) Then
        igARTPage.MarkCopy(igARTMark)
        Exit For
    End If
Next

See Also:

ImGearARTMark Class


MarkCut Method

32-bit
64-bit
CF
P
P

Description:

Cuts a specified mark to the Windows clipboard.

Declaration:

public void MarkCut ( Int MarkID )

Parameters:

Name
Type
Description
MarkID
Int
The ID of the mark to be cut.

Return Value:

None


MarkCut Method

32-bit
64-bit
CF
P
P

Description:

Cuts a specified mark to the Windows clipboard.

Declaration:

public void MarkCut ( ImageGear.ART.ImGearARTMark Mark )

Parameters:

Name
Type
Description
Mark
ImGearARTMark Class
Mark to be cut.

Return Value:

None

Sample Code:

C#
// Cut first mark found to be selected to the clipboard
foreach (ImGearARTMark igARTMark in igARTPage)
{
    if (igARTPage.MarkIsSelected(igARTMark))
    {
        igARTPage.MarkCut(igARTMark);
        break;
    }
}

VB.NET
' Cut first mark found to be selected to the clipboard
For Each igARTMark As ImGearARTMark In igARTPage
    If igARTPage.MarkIsSelected(igARTMark) Then
        igARTPage.MarkCut(igARTMark)
        Exit For
    End If
Next

See Also:

ImGearARTMark Class


MarkGet Method

32-bit
64-bit
CF
P
P

Description:

Gets the mark by its ID.

Declaration:

public ImageGear.ART.ImGearARTMark MarkGet ( Int MarkID )

Parameters:

Name
Type
Description
MarkID
Int
Mark's ID.

Return Value:

ImGearARTMark Class object.

Sample Code:

C#
// Array to hold a list of marks.
ArrayList igARTMarkList = new ArrayList();
// Add all valid marks with id's between 0 to 999 to an array.
for (int i = 0; i < 1000; ++i )
{
    if (igARTPage.MarkIsValid(i))
        igARTMarkList.Add(igARTPage.MarkGet(i));
}
// Cut the marks from the page to the clipboard.
igARTPage.CutMarks(igARTMarkList);
// Create a new art page and paste the marks into it.
ImGearARTPage igARTPageNew = new ImGearARTPage();
igARTPageNew.PasteMarks();
// Change the displayed marks to the new art page.
igPageView.Display.ARTPage = igARTPageNew;
igPageView.Invalidate();

VB.NET
' Array to hold a list of marks.
Dim igARTMarkList As New ArrayList()
For i As Integer = 0 To 999
    ' Add all valid marks with id's between 0 to 999 to an array.
    If igARTPage.MarkIsValid(i) Then
        igARTMarkList.Add(igARTPage.MarkGet(i))
    End If
Next
' Cut the marks from the page to the clipboard.
igARTPage.CutMarks(igARTMarkList)
' Create a new art page and paste the marks into it.
Dim igARTPageNew As New ImGearARTPage()
igARTPageNew.PasteMarks()
' Change the displayed marks to the new art page.
igPageView.Display.ARTPage = igARTPageNew
igPageView.Invalidate()

See Also:

ImGearARTMark Class


MarkIsSelected Method

32-bit
64-bit
CF
P
P

Description:

Checks the mark specified by its ID if it is selected.

Declaration:

public Bool MarkIsSelected ( Int MarkID )

Parameters:

Name
Type
Description
MarkID
Int
ID of the mark to check.

Return Value:

Returns True if mark is selected, False - otherwise.

Sample Code:

C#
// Select half of the annotations.
int count = 0;
foreach (ImGearARTMark igARTMark in igARTPage)
{
    if (count++ % 2 == 1)
        igARTPage.MarkSelect(igARTMark, true);
}
// Burn the selected annotations into the image.
ImGearPage igPageNew = ImGearART.BurnIn(igPage, igARTPage, ImGearARTBurnInOptions.SELECTED, null);
igPageView.Page = igPageNew;
// Remove the burned in annotations from the art page.
foreach (ImGearARTMark igARTMark in igARTPage)
{
    if (igARTPage.MarkIsSelected(igARTMark))
        igARTPage.MarkRemove(igARTMark);
}

VB.NET
' Select half of the annotations.
Dim count As Integer = 0
For Each igARTMark As ImGearARTMark In igARTPage
    If System.Math.Max(System.Threading.Interlocked.Increment(count), count - 1) Mod 2 = 1 Then
        igARTPage.MarkSelect(igARTMark, True)
    End If
Next
' Burn the selected annotations into the image.
Dim igPageNew As ImGearPage = ImGearART.BurnIn(igPage, igARTPage, ImGearARTBurnInOptions.SELECTED, Nothing)
igPageView.Page = igPageNew
' Remove the burned in annotations from the art page.
For Each igARTMark As ImGearARTMark In igARTPage
    If igARTPage.MarkIsSelected(igARTMark) Then
        igARTPage.MarkRemove(igARTMark)
    End If
Next


MarkIsSelected Method

32-bit
64-bit
CF
P
P

Description:

Checks the specified mark if it is selected.

Declaration:

public Bool MarkIsSelected ( ImageGear.ART.ImGearARTMark Mark )

Parameters:

Name
Type
Description
Mark
ImGearARTMark
The mark to check.arkIsValid.

Return Value:

Returns True if mark is selected, False - otherwise.

See Also:

ImGearARTMark Class


MarkIsValid Method

32-bit
64-bit
CF
P
P

Description:

Checks the mark's ID to see if it is a valid mark ID.

Declaration:

public Bool MarkIsValid ( Int MarkID )

Parameters:

Name
Type
Description
MarkID
Int
Mark ID to check.

Return Value:

Returns True if mark is valid, False - otherwise.

Sample Code:

C#
// Array to hold a list of marks.
ArrayList igARTMarkList = new ArrayList();
// Add all valid marks with id's between 0 to 999 to an array.
for (int i = 0; i < 1000; ++i )
{
    if (igARTPage.MarkIsValid(i))
        igARTMarkList.Add(igARTPage.MarkGet(i));
}
// Cut the marks from the page to the clipboard.
igARTPage.CutMarks(igARTMarkList);
// Create a new art page and paste the marks into it.
ImGearARTPage igARTPageNew = new ImGearARTPage();
igARTPageNew.PasteMarks();
// Change the displayed marks to the new art page.
igPageView.Display.ARTPage = igARTPageNew;
igPageView.Invalidate();

VB .NET
' Array to hold a list of marks.
Dim igARTMarkList As New ArrayList()
For i As Integer = 0 To 999
    ' Add all valid marks with id's between 0 to 999 to an array.
    If igARTPage.MarkIsValid(i) Then
        igARTMarkList.Add(igARTPage.MarkGet(i))
    End If
Next
' Cut the marks from the page to the clipboard.
igARTPage.CutMarks(igARTMarkList)
' Create a new art page and paste the marks into it.
Dim igARTPageNew As New ImGearARTPage()
igARTPageNew.PasteMarks()
' Change the displayed marks to the new art page.
igPageView.Display.ARTPage = igARTPageNew
igPageView.Invalidate()


MarkRemove Method

32-bit
64-bit
CF
P
P

Description:

Deletes the mark specified.

Declaration:

public void MarkRemove ( ImageGear.ART.ImGearARTMark mark )

Parameters:

Name
Type
Description
mark
ImGearARTMark Class
Mark to be deleted.

Return Value:

None

Sample Code:

C#
// Select half of the annotations.
int count = 0;
foreach (ImGearARTMark igARTMark in igARTPage)
{
    if (count++ % 2 == 1)
        igARTPage.MarkSelect(igARTMark, true);
}
// Burn the selected annotations into the image.
ImGearPage igPageNew = ImGearART.BurnIn(igPage, igARTPage, ImGearARTBurnInOptions.SELECTED, null);
igPageView.Page = igPageNew;
// Remove the burned in annotations from the art page.
foreach (ImGearARTMark igARTMark in igARTPage)
{
    if (igARTPage.MarkIsSelected(igARTMark))
        igARTPage.MarkRemove(igARTMark);
}

VB .NET
' Select half of the annotations.
Dim count As Integer = 0
For Each igARTMark As ImGearARTMark In igARTPage
    If System.Math.Max(System.Threading.Interlocked.Increment(count), count - 1) Mod 2 = 1 Then
        igARTPage.MarkSelect(igARTMark, True)
    End If
Next
' Burn the selected annotations into the image.
Dim igPageNew As ImGearPage = ImGearART.BurnIn(igPage, igARTPage, ImGearARTBurnInOptions.SELECTED, Nothing)
igPageView.Page = igPageNew
' Remove the burned in annotations from the art page.
For Each igARTMark As ImGearARTMark In igARTPage
    If igARTPage.MarkIsSelected(igARTMark) Then
        igARTPage.MarkRemove(igARTMark)
    End If
Next

See Also:

ImGearARTMark Class


MarkRemove Method

32-bit
64-bit
CF
P
P

Description:

Deletes the mark specified by its ID.

Declaration:

public void MarkRemove ( Int MarkID )

Parameters:

Name
Type
Description
MarkID
Int
ID of the mark to be deleted.

Return Value:

None


MarkSelect Method

32-bit
64-bit
CF
P
P

Description:

Selects/Deselects the mark with specified ID.

Declaration:

public void MarkSelect ( Int MarkID , Bool State )

Parameters:

Name
Type
Description
MarkID
Int
Mark ID to select/deselect.
State
Bool
True - select, False - deselect.

Return Value:

None


MarkSelect Method

32-bit
64-bit
CF
P
P

Description:

Selects/Deselects the specified mark.

Declaration:

public void MarkSelect (ImageGear.ART.ImGearARTMark Mark, Bool State )

Parameters:

Name
Type
Description
Mark
ImGearARTMark Class
Mark to select/deselect.
State
Bool
True - select, False - deselect.

Return Value:

None

Sample Code:

C#
// Select half of the annotations.
int count = 0;
foreach (ImGearARTMark igARTMark in igARTPage)
{
    if (count++ % 2 == 1)
        igARTPage.MarkSelect(igARTMark, true);
}
// Burn the selected annotations into the image.
ImGearPage igPageNew = ImGearART.BurnIn(igPage, igARTPage, ImGearARTBurnInOptions.SELECTED, null);
igPageView.Page = igPageNew;
// Remove the burned in annotations from the art page.
foreach (ImGearARTMark igARTMark in igARTPage)
{
    if (igARTPage.MarkIsSelected(igARTMark))
        igARTPage.MarkRemove(igARTMark);
}

VB .NET
' Select half of the annotations.
Dim count As Integer = 0
For Each igARTMark As ImGearARTMark In igARTPage
    If System.Math.Max(System.Threading.Interlocked.Increment(count), count - 1) Mod 2 = 1 Then
        igARTPage.MarkSelect(igARTMark, True)
    End If
Next
' Burn the selected annotations into the image.
Dim igPageNew As ImGearPage = ImGearART.BurnIn(igPage, igARTPage, ImGearARTBurnInOptions.SELECTED, Nothing)
igPageView.Page = igPageNew
' Remove the burned in annotations from the art page.
For Each igARTMark As ImGearARTMark In igARTPage
    If igARTPage.MarkIsSelected(igARTMark) Then
        igARTPage.MarkRemove(igARTMark)
    End If
Next

See Also:

ImGearARTMark Class


MarkSendToBack Method

32-bit
64-bit
CF
P
P

Description:

Moves a specified mark to the bottom of the Z-Order.

Declaration:

public void MarkSendToBack ( Int MarkID )

Parameters:

Name
Type
Description
MarkID
Int
Index of the mark to move.

Return Value:

None


MarkSendToBack Method

32-bit
64-bit
CF
P
P

Description:

Moves a specified mark to the bottom of the Z-Order.

Declaration:

public void MarkSendToBack ( ImageGear.ART.ImGearARTMark Mark )

Parameters:

Name
Type
Description
Mark
ImGearARTMark Class
The mark to be moved.

Return Value:

None

Sample Code:

C#
// Send any text marks true the back of the z order, and line marks to the front.
foreach (ImGearARTMark igARTMark in igARTPage.Groups[0])
{
    if (igARTMark is ImGearARTText)
        igARTPage.MarkSendToBack(igARTMark);
    else if (igARTMark is ImGearARTLine)
        igARTPage.MarkBringToFront(igARTMark);
}

VB .NET
' Send any text marks true the back of the z order, and line marks to the front.
For Each igARTMark As ImGearARTMark In igARTPage.Groups(0)
    If TypeOf igARTMark Is ImGearARTText Then
        igARTPage.MarkSendToBack(igARTMark)
    ElseIf TypeOf igARTMark Is ImGearARTLine Then
        igARTPage.MarkBringToFront(igARTMark)
    End If
Next

See Also:

ImGearARTMark Class


MarkSetCoordType Method

32-bit
64-bit
CF
P
P

Description:

Sets new type of the coordinates system for the specified mark.

Declaration:

public void MarkSetCoordType ( Int MarkID , ImageGear.ART.ImGearARTCoordinatesType Type )

Parameters:

Name
Type
Description
MarkID
Int
Index of the mark to set the new coordinates type.
Type
ImGearARTCoordinatesType Enumeration
Type of the coordinate system.

Return Value:

None

See Also:

ImGearARTCoordinatesType Enumeration


MarkSetCoordType Method

32-bit
64-bit
CF
P
P

Description:

Sets new type of the coordinates system for the specified mark.

Declaration:

public void MarkSetCoordType(ImageGear.ART.ImGearARTMark Mark,
ImageGear.ART.ImGearARTCoordinatesType Type)

Parameters:

Name
Type
Description
Mark
ImGearARTMark Class
Mark to set the new coordinates type for.
Type
ImGearARTCoordinatesType Enumeration
Type of the coordinate system.

Return Value:

None

See Also:

ImGearARTCoordinatesType Enumeration

ImGearARTMark Class


PasteMarks Method

32-bit
64-bit
CF
P
P

Description:

Pastes all the marks from the Windows clipboard to the ART page.

Declaration:

public void PasteMarks (  )

Return Value:

None

Sample Code:

C#
// Array to hold a list of marks.
ArrayList igARTMarkList = new ArrayList();
// Add all valid marks with id's between 0 to 999 to an array.
for (int i = 0; i < 1000; ++i )
{
    if (igARTPage.MarkIsValid(i))
        igARTMarkList.Add(igARTPage.MarkGet(i));
}
// Cut the marks from the page to the clipboard.
igARTPage.CutMarks(igARTMarkList);
// Create a new art page and paste the marks into it.
ImGearARTPage igARTPageNew = new ImGearARTPage();
igARTPageNew.PasteMarks();
// Change the displayed marks to the new art page.
igPageView.Display.ARTPage = igARTPageNew;
igPageView.Invalidate();

VB .NET
' Array to hold a list of marks.
Dim igARTMarkList As New ArrayList()
For i As Integer = 0 To 999
    ' Add all valid marks with id's between 0 to 999 to an array.
    If igARTPage.MarkIsValid(i) Then
        igARTMarkList.Add(igARTPage.MarkGet(i))
    End If
Next
' Cut the marks from the page to the clipboard.
igARTPage.CutMarks(igARTMarkList)
' Create a new art page and paste the marks into it.
Dim igARTPageNew As New ImGearARTPage()
igARTPageNew.PasteMarks()
' Change the displayed marks to the new art page.
igPageView.Display.ARTPage = igARTPageNew
igPageView.Invalidate()


RemoveMarks Method

32-bit
64-bit
CF
P
P

Description:

Deletes all marks from the ART Page.

Declaration:

public void RemoveMarks (  )

Return Value:

None

Sample Code:

C#
ImGearPage igPage;
// Load an image containing embedded ART 2.0 annotations into a ImGearPage object
using (FileStream localFile = new FileStream("test1_art.tif", FileMode.Open))
    igPage = ImGearFileFormats.LoadPage(localFile, 0);
// Load the ImGearARTPage from the metadata in the ImGearPage.
igARTForms.Page = ImGearART.LoadPage(igPage);
// Burn the annotations into the image.
igPage = ImGearART.BurnIn(igPage, igARTForms.Page, ImGearARTBurnInOptions.ALL, null);
imGearPageView1.Page = igPage;
// Clear the annotations from the art page.
igARTForms.Page.RemoveMarks();
// Update the Display with the new ARTPage.
if (igARTForms.Page != null)
    imGearPageView1.Display.ARTPage = igARTForms.Page;

VB .NET
Dim igPage As ImGearPage
' Load an image containing embedded ART 2.0 annotations into a ImGearPage object
Using localFile As New FileStream("test1_art.tif", FileMode.Open)
    igPage = ImGearFileFormats.LoadPage(localFile, 0)
End Using
' Load the ImGearARTPage from the metadata in the ImGearPage.
igARTForms.Page = ImGearART.LoadPage(igPage)
' Burn the annotations into the image.
igPage = ImGearART.BurnIn(igPage, igARTForms.Page, ImGearARTBurnInOptions.ALL, Nothing)
ImGearPageView1.Page = igPage
' Clear the annotations from the art page.
igARTForms.Page.RemoveMarks()
' Update the Display with the new ARTPage.
If igARTForms.Page IsNot Nothing Then
    ImGearPageView1.Display.ARTPage = igARTForms.Page
End If


RemoveMarks Method

32-bit
64-bit
CF
P
P

Description:

Deletes an array of specified marks.

Declaration:

public void RemoveMarks ( int[] MarksIDs )

Parameters:

Name
Type
Description
MarksIDs
Int
Array of mark IDs to delete.

Return Value:

None


RemoveMarks Method

32-bit
64-bit
CF
P
P

Description:

Deletes a collection of specified marks.

Declaration:

public void RemoveMarks ( System.Collections.ArrayList Marks )

Parameters:

Name
Type
Description
Marks
System.Collections.ArrayList
Collection of marks to delete.

Return Value:

None


SelectMarks Method

32-bit
64-bit
CF
P
P

Description:

Selects/deselects all marks in the ART Page.

Declaration:

public void SelectMarks ( Bool State )

Parameters:

Name
Type
Description
State
Bool
True - selects marks, False - deselects.

Return Value:

None


SetCoordType Method

32-bit
64-bit
CF
P
P

Description:

Sets new type of the coordinates system for the entire mark collection.

Declaration:

public void SetCoordType (ImageGear.ART.ImGearARTCoordinatesType Type )

Parameters:

Name
Type
Description
Type
ImGearARTCoordinatesType Enumeration
Type of the coordinate system.

Return Value:

None

See Also:

ImGearARTCoordinatesType Enumeration


ImGearARTPageEnumerator Class

32-bit
64-bit
CF
P
P

Description:

Page enumerator class is used for ImGearARTPage Class to iterate through the collection of marks by using foreach statement.

Declaration:

public class ImGearARTPageEnumerator

Members:

Constructors
Name
Description
ImGearARTPageEnumerator Constructor
Creates a new instance of ImGearARTPageEnumerator object.

Properties
Name
Description
Current Property
Gets the current element in the collection.

Methods
Name
Description
MoveNext Method
Advances the enumerator to the next element of the collection.

Sample Code:

C#
// Iterate through art marks on the page, foreach uses ImGearARTPage.GetEnumerator()
//  to get a ImGearARTPageEnumerator which is used for the foreach.
foreach( ImGearARTMark igARTMark in igARTPage)
{
    //Move the art mark.
    igARTMark.Move(50, 50);
}

VB .NET
' Iterate through art marks on the page, foreach uses ImGearARTPage.GetEnumerator()
'  to get a ImGearARTPageEnumerator which is used for the foreach.
For Each igARTMark As ImGearARTMark In igARTPage
    'Move the art mark.
    igARTMark.Move(50, 50)
Next


ImGearARTPageEnumerator Constructors

The ImGearARTPageEnumerator Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTPageEnumerator Constructor
Creates a new instance of ImGearARTPageEnumerator object.


ImGearARTPageEnumerator Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTPageEnumerator Class object.

Declaration:

public ImGearARTPageEnumerator ( ImageGear.ART.ImGearARTPage ARTPage )

Parameters:

Name
Type
Description
ARTPage
ImGearARTPage Class
ART page to enumerate the marks from.

Return Value:

The new instance of ImGearARTPageEnumerator Class object.

See Also:

ImGearARTPage Class


ImGearARTPageEnumerator Properties

The ImGearARTPageEnumerator Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
Current Property
Gets the current element in the collection.


Current Property

32-bit
64-bit
CF
P
P

Description:

Gets the current element in the collection.

Declaration:

public ImageGear.ART.ImGearARTMark Current { get }

Value:

ImGearARTMark Class object.

Default value:

N/A

See Also:

ImGearARTMark Class


ImGearARTPageEnumerator Methods

The ImGearARTPageEnumerator Class of the ImageGear.ART Namespace has the following methods:

Methods
Name
Description
MoveNext Method
Advances the enumerator to the next element of the collection.


MoveNext Method

32-bit
64-bit
CF
P
P

Description:

Advances the enumerator to the next element of the collection.

Declaration:

public bool MoveNext (  )

Return Value:

True, False


ImGearARTPin Class

32-bit
64-bit
CF
P
P

Description:

Specifies text mark's pin icon.

Declaration:

public class ImGearARTPin

Members:

Constructors
Name
Description
ImGearARTPin Constructor
Creates a new instance of ImGearARTPin object.
ImGearARTPin Constructor
Creates a new instance of ImGearARTPin object.

Properties
Name
Description
Alignment Property
Specifies alignment of the pin icon.
Color Property
Color of the pin icon.

Sample Code:

C#
// Setup color for the border.
ImGearRGBQuad igRGBQuadBorder = new ImGearRGBQuad(0, 255, 0);
// Setup a border with a width of 3 and a dot pattern.
ImGearARTBorder igARTBorder = new ImGearARTBorder(
    igRGBQuadBorder, 3, ImGearARTPenStyle.DOT
);
// Setup color for the pin.
ImGearRGBQuad igRGBQuadPin = new ImGearRGBQuad(0, 0, 255);
// Create pin to be used in the annotation.
ImGearARTPin igARTPin = new ImGearARTPin(igRGBQuadPin, ImGearARTPinAlignment.RIGHT_TOP);
// Setup color for the callout border.
ImGearRGBQuad igRGBQuadBorderCallout = new ImGearRGBQuad(0, 255, 255);
// Setup a border with a width of 3 and a solid pattern.
ImGearARTBorder igARTBorderCallout = new ImGearARTBorder(
    igRGBQuadBorder, 3, ImGearARTPenStyle.SOLID
);
// Create a callout to be used for the text annotation.
ImGearARTCallout igARTCallout = new ImGearARTCallout(
    ImGearARTCalloutType.LINE, igPage.DIB.Width / 2,
    igPage.DIB.Height / 2, igARTBorderCallout
);
// Setup rectangle for the text mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 330, 40);
// Setup color for the text.
ImGearRGBQuad igRGBQuadText = new ImGearRGBQuad(255, 0, 255);
// Setup color for the fill.
ImGearRGBQuad igRGBQuadFill = new ImGearRGBQuad(200, 200, 200);
// Create the text annotation.
ImGearARTText igARTText = new ImGearARTText(
    igRectangle, "ImGearARTText annotation", igRGBQuadText,
    ImGearARTTextType.DIRECT_TEXT, igRGBQuadFill, igARTBorder, false,
    255, "Arial", (float)14.0, FontStyle.Regular, igARTPin, igARTCallout
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTText, ImGearARTCoordinatesType.IMAGE_COORD);

VB .NET
' Setup color for the border.
Dim igRGBQuadBorder As New ImGearRGBQuad(0, 255, 0)
' Setup a border with a width of 3 and a dot pattern.
Dim igARTBorder As New ImGearARTBorder(igRGBQuadBorder, 3, ImGearARTPenStyle.DOT)
' Setup color for the pin.
Dim igRGBQuadPin As New ImGearRGBQuad(0, 0, 255)
' Create pin to be used in the annotation.
Dim igARTPin As New ImGearARTPin(igRGBQuadPin, ImGearARTPinAlignment.RIGHT_TOP)
' Setup color for the callout border.
Dim igRGBQuadBorderCallout As New ImGearRGBQuad(0, 255, 255)
' Setup a border with a width of 3 and a solid pattern.
Dim igARTBorderCallout As New ImGearARTBorder(igRGBQuadBorder, 3, ImGearARTPenStyle.SOLID)
' Create a callout to be used for the text annotation.
Dim igARTCallout As New ImGearARTCallout( _
 ImGearARTCalloutType.LINE, igPage.DIB.Width / 2, igPage.DIB.Height / 2, igARTBorderCallout)
' Setup rectangle for the text mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 330, 40)
' Setup color for the text.
Dim igRGBQuadText As New ImGearRGBQuad(255, 0, 255)
' Setup color for the fill.
Dim igRGBQuadFill As New ImGearRGBQuad(200, 200, 200)
' Create the text annotation.
Dim igARTText As New ImGearARTText( _
 igRectangle, "ImGearARTText annotation", igRGBQuadText, _
 ImGearARTTextType.DIRECT_TEXT, igRGBQuadFill, igARTBorder, False, _
 255, "Arial", CSng(14), FontStyle.Regular, igARTPin, igARTCallout)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTText, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTPin Constructors

The ImGearARTPin Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTPin Constructor
Creates a new instance of ImGearARTPin object.
ImGearARTPin Constructor
Creates a new instance of ImGearARTPin object.


ImGearARTPin Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTPin Class object.

Declaration:

public ImGearARTPin ( ImageGear.Core.IImGearRGBQuad Color )

Parameters:

Name
Type
Description
Color
ImGearRGBQuad Structure
Color of the pin icon.

Return Value:

The new instance of ImGearARTPin Class object.

See Also:

ImGearRGBQuad Structure


ImGearARTPin Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTPin Class object.

Declaration:

public ImGearARTPin ( ImageGear.Core.IImGearRGBQuad Color ,
ImageGear.ART.ImGearARTPinAlignment Alignment )

Parameters:

Name
Type
Description
Color
ImGearRGBQuad Structure
Color of the pin icon.
Alignment
ImGearARTPinAlignment Enumeration
Pin icon alignment.

Return Value:

The new instance of ImGearARTPin Class object.

See Also:

ImGearRGBQuad Structure

ImGearARTPinAlignment Enumeration


ImGearARTPin Properties

The ImGearARTPin Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
Alignment Property
Specifies alignment of the pin icon.
Color Property
Color of the pin icon.


Alignment Property

32-bit
64-bit
CF
P
P

Description:

Pin icon alignment.

Declaration:

public ImageGear.ART.ImGearARTPinAlignment Alignment { get, set }

Value:

ImGearARTPinAlignment Enumeration value.

Default value:

0

See Also:

ImGearARTPinAlignment Enumeration


Color Property

32-bit
64-bit
CF
P
P

Description:

Pin icon color.

Declaration:

public ImageGear.Core.IImGearRGBQuad Color { get, set }

Value:

ImGearRGBQuad Structure object.

Default value:

N/A

See Also:

ImGearRGBQuad Structure


ImGearARTPinUpText Class

32-bit
64-bit
CF
P
P

Description:

Legacy ART Pin-Up-Text mark.

Declaration:

public class ImGearARTPinUpText : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTPinUpText Constructor
Creates a new instance of ImGearARTPinUpText object.
ImGearARTPinUpText Constructor
Creates a new instance of ImGearARTPinUpText object.

Properties
Name
Description
FontName Property
Font name of the text font.
FontSize Property
Font size of the text font.
FontStyle Property
Font style of the text font.
FontDisablePPM Property
Option to enable/disable PPM in font size calculations.
Height Property
Height of the mark's rectangle.
PinColor Property
Pin color.
Text Property
Text of the mark.
TextColor Property
Text color.
Width Property
Width of the mark's rectangle.
X Property
The X coordinate of the top-left point of the mark rectangle.
Y Property
The Y coordinate of the top-left point of the mark rectangle.

Sample Code:

C#
// Setup rectangle for the pinup mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 300, 100);
// Setup color for the text.
ImGearRGBQuad igRGBQuadText = new ImGearRGBQuad(0, 0, 0);
// Setup color for the pin.
ImGearRGBQuad igRGBQuadPin = new ImGearRGBQuad(40, 200, 40);
// Create pinup mark using size 14 bold Arial font
ImGearARTPinUpText igARTPinUpText = new ImGearARTPinUpText(
    igRectangle, "ImGearARTPinUpText test", igRGBQuadText, "Arial", (float)14.0, FontStyle.Bold, igRGBQuadPin
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTPinUpText, ImGearARTCoordinatesType.IMAGE_COORD);

VB .NET
' Setup rectangle for the pinup mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 300, 100)
' Setup color for the text.
Dim igRGBQuadText As New ImGearRGBQuad(0, 0, 0)
' Setup color for the pin.
Dim igRGBQuadPin As New ImGearRGBQuad(40, 200, 40)
' Create pinup mark using size 14 bold Arial font
Dim igARTPinUpText As New ImGearARTPinUpText( _
 igRectangle, "ImGearARTPinUpText test", igRGBQuadText, _
 "Arial", CSng(14), FontStyle.Bold, igRGBQuadPin)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTPinUpText, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTPinUpText Constructors

The ImGearARTPinUpText Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTPinUpText Constructor
Creates a new instance of ImGearARTPinUpText object.
ImGearARTPinUpText Constructor
Creates a new instance of ImGearARTPinUpText object.


ImGearARTPinUpText Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTPinUpText Class object.

Declaration:

public ImGearARTPinUpText ( ImageGear.Core.IImGearRectangle Rect , String Text ,
ImageGear.Core.IImGearRGBQuad TextColor )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Rectangle of the mark.
Text
String
Pin Up text.
TextColor
ImGearRGBQuad Structure
Text color.

Return Value:

The new instance of ImGearARTPinUpText Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure


ImGearARTPinUpText Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTPinUpText Class object.

Declaration:

public ImGearARTPinUpText ( ImageGear.Core.IImGearRectangle Rect , String Text ,
ImageGear.Core.IImGearRGBQuad TextColor , String FontName , float FontSize ,
System.Drawing.FontStyle FontStyle , ImageGear.Core.IImGearRGBQuad PinColor )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Rectangle of the mark.
Text
String
Pin Up text.
TextColor
ImGearRGBQuad Structure
Text color.
FontName
String
Font name.
FontSize
float
Font size.
FontStyle
System.Drawing.FontStyle
Font style.
PinColor
IImGearRGBQuad
Pin color.

Return Value:

The new instance of ImGearARTPinUpText Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure


ImGearARTPinUpText Properties

The ImGearARTPinUpText Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
FontName Property
Font name of the text font.
FontSize Property
Font size of the text font.
FontStyle Property
Font style of the text font.
FontDisablePPM Property
Option to enable/disable PPM in font size calculations.
Height Property
Height of the mark's rectangle.
PinColor Property
Pin color.
Text Property
Text of the mark.
TextColor Property
Text color.
Width Property
Width of the mark's rectangle.
X Property
The X coordinate of the top-left point of the mark rectangle.
Y Property
The Y coordinate of the top-left point of the mark rectangle.


FontName Property

32-bit
64-bit
CF
P
P

Description:

Font name.

Declaration:

public string FontName { get, set }

Value:

Name string.

Default value:

N/A


FontStyle Property

32-bit
64-bit
CF
P
P

Description:

Font style.

Declaration:

public System.Drawing.FontStyle FontStyle { get, set }

Value:

FontStyle value.

Default value:

N/A


PinColor Property

32-bit
64-bit
CF
P
P

Description:

Pin color.

Declaration:

public ImageGear.Core.IImGearRGBQuad PinColor{ get, set }

Value:

ImGearRGBQuad Structure object interface.

Default value:

N/A

See Also:

ImGearRGBQuad Structure


Text Property

32-bit
64-bit
CF
P
P

Description:

Text of the mark.

Declaration:

public string Text { get, set }

Value:

Any string

Default value:

N/A


TextColor Property

32-bit
64-bit
CF
P
P

Description:

Color of the mark's text.

Declaration:

public ImageGear.Core.IImGearRGBQuad TextColor { get, set }

Value:

ImGearRGBQuad Structure object interface.

Default value:

N/A

See Also:

ImGearRGBQuad Structure


ImGearARTPoint Class

32-bit
64-bit
CF
P
P

Description:

ART Point mark.

Declaration:

public class ImGearARTPoint : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTPoint Constructor
Creates a new instance of ImGearARTPoint object.
ImGearARTPoint Constructor
Creates a new instance of ImGearARTPoint object.

Properties
Name
Description
Color Property
Color of the mark.
Opacity Property
Opacity of the mark.
Width Property
Width of the mark.
X Property
X coordinate of the mark.
Y Property
Y coordinate of the mark.

Sample Code:

C#
// Setup location for the point
ImGearPoint igPoint = new ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2);
// Setup color for the point.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(0, 255, 0);
// Create the point annotation with a width of 10 and 60% opacity
ImGearARTPoint igARTPoint = new ImGearARTPoint(
    igPoint, igRGBQuad, 10, (int)(0.60 * 255)
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTPoint, ImGearARTCoordinatesType.IMAGE_COORD);

VB .NET
' Setup location for the point
Dim igPoint As New ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2)
' Setup color for the point.
Dim igRGBQuad As New ImGearRGBQuad(0, 255, 0)
' Create the point annotation with a width of 10 and 60% opacity
Dim igARTPoint As New ImGearARTPoint( _
 igPoint, igRGBQuad, 10, CInt(0.6 * 255))
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTPoint, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTPoint Constructors

The ImGearARTPoint Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTPoint Constructor
Creates a new instance of ImGearARTPoint object.
ImGearARTPoint Constructor
Creates a new instance of ImGearARTPoint object.


ImGearARTPoint Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTPoint Class object.

Declaration:

public ImGearARTPoint ( ImageGear.Core.IImGearPoint Point, ImageGear.Core.IImGearRGBQuad
Color )

Parameters:

Name
Type
Description
Point
ImGearPoint Structure
The point mark.
Color
ImGearRGBQuad Structure
Color of the mark.

Return Value:

The new instance of ImGearARTPoint Class object.

See Also:

ImGearPoint Structure

ImGearRGBQuad Structure


ImGearARTPoint Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTPoint Class object.

Declaration:

public ImGearARTPoint ( ImageGear.Core.IImGearPoint Point , ImageGear.Core.IImGearRGBQuad
Color , Int Width , Int Opacity )

Parameters:

Name
Type
Description
Point
ImGearPoint Structure
The point mark.
Color
ImGearRGBQuad Structure
Color of the mark.
Width
Int
Width of the mark.
Opacity
Int
Opacity of the mark.

Return Value:

The new instance of ImGearARTPoint Class object.

See Also:

ImGearPoint Structure

ImGearRGBQuad Structure


ImGearARTPoint Properties

The ImGearARTPoint Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
Color Property
Color of the mark.
Opacity Property
Opacity of the mark.
Width Property
Width of the mark.
X Property
X coordinate of the mark.
Y Property
Y coordinate of the mark.


Color Property

32-bit
64-bit
CF
P
P

Description:

The color of the mark.

Declaration:

public ImageGear.Core.IImGearRGBQuad Color { get, set }

Value:

ImGearRGBQuad Structure

See Also:

ImGearRGBQuad Structure


Opacity Property

32-bit
64-bit
CF
P
P

Description:

The opacity of the mark.

Declaration:

public int Opacity { get, set }

Value:

Any integer value from 0 (transparent) to 255 (opaque).

Default value:

255


X Property

32-bit
64-bit
CF
P
P

Description:

X coordinate of the mark.

Declaration:

public int X { get, set }

Value:

Any integer value.

Default value:

N/A


Y Property

32-bit
64-bit
CF
P
P

Description:

Y coordinate of the mark.

Declaration:

public int Y { get, set }

Value:

Any integer value.

Default value:

N/A


ImGearARTPointMarkStat Class

32-bit
64-bit
CF
P
P

Description:

This class represents specific statistics information about the point ART marks.

For now this statistics class represents only the ImGearARTMarkType Enumeration.POINT mark type. There is no statistic information available for such mark type.

An instance of the ImGearARTPointMarkStat Class is always created for the specified mark object and should not be used after destroying that mark object.

Declaration:

public class ImGearARTPointMarkStat : ImGearARTMarkStat

See Also:

ImGearARTLineMarkStat Class

ImGearARTMarkStat Class

ImGearARTShapeMarkStat Class

ImGearARTMarkType Enumeration


ImGearARTPolygon Class

32-bit
64-bit
CF
P
P

Description:

ART Polygon mark.

Declaration:

public class ImGearARTPolygon : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTPolygon Constructor
Creates a new instance of ImGearARTPolygon object.
ImGearARTPolygon Constructor
Creates a new instance of ImGearARTPolygon object.
ImGearARTPolygon Constructor
Creates a new instance of ImGearARTPolygon object.

Properties
Name
Description
Border Property
The border of the mark.
FillColor Property
Fill color of the mark.
NumberOfPoints Property
Actual number of points on the mark.
Opacity Property
Mark opacity.
Points Property
Raw points array.

Methods
Name
Description
GetPoint Method
Gets point with specified index.
SetPoint Method
Sets point at specified index.

Sample Code:

C#
// Create an array of 5 points for the polygon.
ImGearPoint[] igPoints = new ImGearPoint[5];
igPoints[0] = new ImGearPoint(20, 20);
igPoints[1] = new ImGearPoint(200, 40);
igPoints[2] = new ImGearPoint(200, 60);
igPoints[3] = new ImGearPoint(120, 120);
igPoints[4] = new ImGearPoint(20, 40);
// Setup color for the polygon fill.
ImGearRGBQuad igRGBQuadFill = new ImGearRGBQuad(40, 200, 40);
// Setup color for the polygon border.
ImGearRGBQuad igRGBQuadBorder = new ImGearRGBQuad(0, 0, 0);
// Create polygon with a solid border of width 10, and 33% opacity
ImGearARTPolygon igARTPolygon = new ImGearARTPolygon(
    igPoints, igRGBQuadFill, igRGBQuadBorder,
    ImGearARTPenStyle.SOLID, 10, (int)(0.33 * 255)
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTPolygon, ImGearARTCoordinatesType.IMAGE_COORD);

VB .NET
' Create an array of 5 points for the polygon.
Dim igPoints As ImGearPoint() = New ImGearPoint(4) {}
igPoints(0) = New ImGearPoint(20, 20)
igPoints(1) = New ImGearPoint(200, 40)
igPoints(2) = New ImGearPoint(200, 60)
igPoints(3) = New ImGearPoint(120, 120)
igPoints(4) = New ImGearPoint(20, 40)
' Setup color for the polygon fill.
Dim igRGBQuadFill As New ImGearRGBQuad(40, 200, 40)
' Setup color for the polygon border.
Dim igRGBQuadBorder As New ImGearRGBQuad(0, 0, 0)
' Create polygon with a solid border of width 10, and 33% opacity
Dim igARTPolygon As New ImGearARTPolygon( _
 igPoints, igRGBQuadFill, igRGBQuadBorder, _
 ImGearARTPenStyle.SOLID, 10, CInt((0.33 * 255)))
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTPolygon, ImGearARTCoordinatesType.IMAGE_COORD)

See Also:

ImGearARTMark Class


ImGearARTPolygon Constructors

The ImGearARTPolygon Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTPolygon Constructor
Creates a new instance of ImGearARTPolygon object.
ImGearARTPolygon Constructor
Creates a new instance of ImGearARTPolygon object.
ImGearARTPolygon Constructor
Creates a new instance of ImGearARTPolygon object.


ImGearARTPolygon Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTPolygon Class object.

Declaration:

public ImGearARTPolygon ( ImageGear.Core.ImGearPoint[] Points ,
ImageGear.Core.IImGearRGBQuad FillColor )

Parameters:

Name
Type
Description
Points
ImGearPoint Structure
The mark's points.
FillColor
ImGearRGBQuad Structure
Fill color of the mark.

Return Value:

The new instance of ImGearARTPolygon Class object.

See Also:

ImGearPoint Structure

ImGearRGBQuad Structure


ImGearARTPolygon Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTPolygon Class object.

Declaration:

public ImGearARTPolygon ( ImageGear.Core.ImGearPoint[] Points ,
ImageGear.Core.IImGearRGBQuad BorderColor , ImageGear.ART.ImGearARTPenStyle BorderStyle ,
Int BorderWidth )

Parameters:

Name
Type
Description
Points
ImGearPoint Structure
The mark's points.
BorderColor
ImGearRGBQuad Structure
The border color of the mark.
BorderStyle
ImGearARTPenStyle Enumeration
The border style of the mark.
BorderWidth
Int
The border width of the mark.

Return Value:

The new instance of ImGearARTPolygon Class object.

See Also:

ImGearPoint Structure

ImGearRGBQuad Structure

ImGearARTPenStyle Enumeration


ImGearARTPolygon Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTPolygon Class object.

Declaration:

public ImGearARTPolygon ( ImageGear.Core.ImGearPoint[] Points ,
ImageGear.Core.IImGearRGBQuad FillColor , ImageGear.Core.IImGearRGBQuad BorderColor ,
ImageGear.ART.ImGearARTPenStyle BorderStyle , Int BorderWidth , Int Opacity )

Parameters:

Name
Type
Description
Points
ImGearPoint Structure
The mark's points.
FillColor
ImGearRGBQuad Structure
Fill color of the mark.
BorderColor
ImGearRGBQuad Structure
The border color of the mark.
BorderStyle
ImGearARTPenStyle Enumeration
The border style of the mark.
BorderWidth
Int
The border width of the mark.
Opacity
Int
Opacity of the mark.

Return Value:

The new instance of ImGearARTPolygon Class object.

See Also:

ImGearPoint Structure

ImGearRGBQuad Structure

ImGearARTPenStyle Enumeration


ImGearARTPolygon Properties

The ImGearARTPolygon Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
Border Property
The border of the mark.
FillColor Property
Fill color of the mark.
NumberOfPoints Property
Actual number of points on the mark.
Opacity Property
Mark opacity.
Points Property
Raw points array.


NumberOfPoints Property

32-bit
64-bit
CF
P
P

Description:

Actual number of points on the mark.

Declaration:

public int NumberOfPoints { get, set }

Value:

Integer value.

See Also:

ImGearPoint Structure


Opacity Property

32-bit
64-bit
CF
P
P

Description:

Opacity of the mark.

Declaration:

public int Opacity { get, set }

Value:

Integer value from 0 (transparent) to 255 (opaque).

Default value:

255


ImGearARTPolygon Methods

The ImGearARTPolygon Class of the ImageGear.ART Namespace has the following methods:

Methods
Name
Description
GetPoint Method
Gets point with specified index.
SetPoint Method
Sets point at specified index.


GetPoint Method

32-bit
64-bit
CF
P
P

Description:

Gets point with specified index.

Declaration:

public ImageGear.Core.ImGearPoint GetPoint ( Int nIndex )

Parameters:

Name
Type
Description
nIndex
Int
The index of the point to get.

Return Value:

ImGearPoint Structure object.

See Also:

ImGearPoint Structure


SetPoint Method

32-bit
64-bit
CF
P
P

Description:

Sets point at specified index.

Declaration:

public void SetPoint ( Int nIndex , ImageGear.Core.ImGearPoint pt )

Parameters:

Name
Type
Description
nIndex
Int
Index of the point.
pt
ImGearPoint Structure
The point to set.

Return Value:

None

See Also:

ImGearPoint Structure


ImGearARTPolyline Class

32-bit
64-bit
CF
P
P

Description:

ART Polyline mark.

Declaration:

public class ImGearARTPolyline : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTPolyline Constructor
Creates a new instance of ImGearARTPolyline object.
ImGearARTPolyline Constructor
Creates a new instance of ImGearARTPolyline object.
ImGearARTPolyline Constructor
Creates a new instance of ImGearARTPolyline object.

Properties
Name
Description
Color Property
Color of the mark.
EndHeadAngle Property
The end head angle of the mark.
EndHeadLength Property
The end head length of the mark.
EndHeadType Property
The end head type of the mark.
IsClosed Property
Determines whether the polyline is closed.
NumberOfPoints Property
Actual number of mark's points.
Opacity Property
Opacity of the mark.
Points Property
Raw points array.
StartHeadAngle Property
The start head angle of the mark.
StartHeadLength Property
The start head length of the mark.
StartHeadType Property
The start head type of the mark.
Style Property
The style of the mark.
Width Property
The width of the mark.

Methods
Name
Description
GetPoint Method
Gets point with specified index.
SetPoint Method
Sets point at specified index.

Sample Code:

C#
// Create an array of 5 points for the line.
ImGearPoint[] igPoints = new ImGearPoint[5];
igPoints[0] = new ImGearPoint(0, 0);
igPoints[1] = new ImGearPoint(20, 40);
igPoints[2] = new ImGearPoint(40, 40);
igPoints[3] = new ImGearPoint(80, 40);
igPoints[4] = new ImGearPoint(120, 120);
// Setup color for the line.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(40, 40, 200);
// Create poly line with a dot-dashed pattern, width of 4, 100% opaque, closed,
//  and no heads.
ImGearARTPolyline igARTPolyLine = new ImGearARTPolyline(
    igPoints, igRGBQuad, ImGearARTPenStyle.DASHDOT, 4, 255, true,
    null, ImGearARTLineHeadType.NONE, 0, 0, ImGearARTLineHeadType.NONE, 0, 0
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTPolyLine, ImGearARTCoordinatesType.IMAGE_COORD);

VB .NET
' Create an array of 5 points for the line.
Dim igPoints As ImGearPoint() = New ImGearPoint(4) {}
igPoints(0) = New ImGearPoint(0, 0)
igPoints(1) = New ImGearPoint(20, 40)
igPoints(2) = New ImGearPoint(40, 40)
igPoints(3) = New ImGearPoint(80, 40)
igPoints(4) = New ImGearPoint(120, 120)
' Setup color for the line.
Dim igRGBQuad As New ImGearRGBQuad(40, 40, 200)
' Create poly line with a dot-dashed pattern, width of 4, 100% opaque, closed,
'  and no heads.
Dim igARTPolyLine As New ImGearARTPolyline( _
 igPoints, igRGBQuad, ImGearARTPenStyle.DASHDOT, 4, 255, True, _
 Nothing, ImGearARTLineHeadType.NONE, 0, 0, ImGearARTLineHeadType.NONE, 0, 0)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTPolyLine, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTPolyline Constructors

The ImGearARTPolyline Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTPolyline Constructor
Creates a new instance of ImGearARTPolyline object.
ImGearARTPolyline Constructor
Creates a new instance of ImGearARTPolyline object.
ImGearARTPolyline Constructor
Creates a new instance of ImGearARTPolyline object.


ImGearARTPolyline Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTPolyline Class object.

Declaration:

public ImGearARTPolyline ( ImageGear.Core.ImGearPoint[] Points ,
ImageGear.Core.IImGearRGBQuad Color )

Parameters:

Name
Type
Description
Points
ImGearPoint Structure
The mark's points.
Color
ImGearRGBQuad Structure
Color of the mark.

Return Value:

The new instance of ImGearARTPolyline Class object.

See Also:

ImGearPoint Structure

ImGearRGBQuad Structure


ImGearARTPolyline Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTPolyline Class object.

Declaration:

public ImGearARTPolyline ( ImageGear.Core.ImGearPoint[] Points ,
ImageGear.Core.IImGearRGBQuad Color , ImageGear.ART.ImGearARTPenStyle Style , Int Width ,
Int Opacity , Bool IsClosed )

Parameters:

Name
Type
Description
Points
ImGearPoint Structure
The mark's points.
Color
ImGearRGBQuad Structure
Color of the mark.
Style
ImGearARTPenStyle Enumeration
The line style.
Width
Int
The line width.
Opacity
Int
Opacity of the mark.
IsClosed
Bool
True if polyline is closed, False - otherwise.

Return Value:

The new instance of ImGearARTPolyline Class object.

See Also:

ImGearPoint Structure

ImGearRGBQuad Structure

ImGearARTPenStyle Enumeration


ImGearARTPolyline Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTPolyline Class object.

Declaration:

public ImGearARTPolyline ( ImageGear.Core.ImGearPoint[] Points ,
ImageGear.Core.IImGearRGBQuad Color , ImageGear.ART.ImGearARTPenStyle Style , Int Width ,
Int Opacity , Bool IsClosed , ImageGear.Core.IImGearRGBQuad HeadFillColor ,
ImageGear.ART.ImGearARTLineHeadType StartHeadType , Int StartHeadAngle , Int
StartHeadLength , ImageGear.ART.ImGearARTLineHeadType EndHeadType , Int EndHeadAngle , Int
EndHeadLength )

Parameters:

Name
Type
Description
Points
ImGearPoint Structure
The mark's points.
Color
ImGearRGBQuad Structure
Color of the mark.
Style
ImGearARTPenStyle Enumeration
The line style.
Width
Int
The line width.
Opacity
Int
Opacity of the mark.
IsClosed
Bool
True if polyline is closed, False - otherwise.
HeadFillColor
ImGearRGBQuad Structure
Fill color of the line's head.
StartHeadType
ImGearARTLineHeadType Enumeration
Start head type.
StartHeadAngle
Int
Start head angle.
StartHeadLength
Int
Start head length.
EndHeadType
ImGearARTLineHeadType Enumeration
End head type.
EndHeadAngle
Int
End head angle.
EndHeadLength
Int
End head length.

Return Value:

The new instance of ImGearARTPolyline Class object.

See Also:

ImGearPoint Structure

ImGearRGBQuad Structure

ImGearARTPenStyle Enumeration

ImGearARTLineHeadType Enumeration


ImGearARTPolyline Properties

The ImGearARTPolyline Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
Color Property
Color of the mark.
EndHeadAngle Property
The end head angle of the mark.
EndHeadLength Property
The end head length of the mark.
EndHeadType Property
The end head type of the mark.
IsClosed Property
Determines whether the polyline is closed.
NumberOfPoints Property
Actual number of mark's points.
Opacity Property
Opacity of the mark.
Points Property
Raw points array.
StartHeadAngle Property
The start head angle of the mark.
StartHeadLength Property
The start head length of the mark.
StartHeadType Property
The start head type of the mark.
Style Property
The style of the mark.
Width Property
The width of the mark.


Color Property

32-bit
64-bit
CF
P
P

Description:

Color of the mark.

Declaration:

public ImageGear.Core.IImGearRGBQuad Color { get, set }

Value:

ImGearRGBQuad Structure object interface.

Default value:

N/A

See Also:

ImGearRGBQuad Structure


EndHeadAngle Property

32-bit
64-bit
CF
P
P

Description:

The end head angle of the mark.

Declaration:

public int EndHeadAngle { get, set }

Value:

Integer value.

Default value:

N/A


EndHeadLength Property

32-bit
64-bit
CF
P
P

Description:

The end head length of the mark.

Declaration:

public int EndHeadLength { get, set }

Value:

Integer value.

Default value:

N/A


EndHeadType Property

32-bit
64-bit
CF
P
P

Description:

The end head type of the mark.

Declaration:

public ImageGear.ART.ImGearARTLineHeadType EndHeadType { get, set }

Value:

ImGearARTLineHeadType Enumeration value.

Default value:

N/A

See Also:

ImGearARTLineHeadType Enumeration


IsClosed Property

32-bit
64-bit
CF
P
P

Description:

Determines whether the polyline is closed or not.

Declaration:

public bool IsClosed { get, set }

Value:

True, False

Default value:

False


NumberOfPoints Property

32-bit
64-bit
CF
P
P

Description:

Actual number of points of the polyline.

Declaration:

public int NumberOfPoints { get, set}

Value:

Integer value.

Default value:

N/A


StartHeadAngle Property

32-bit
64-bit
CF
P
P

Description:

The start head angle of the line.

Declaration:

public int StartHeadAngle { get, set }

Value:

Integer value.

Default value:

N/A


StartHeadLength Property

32-bit
64-bit
CF
P
P

Description:

The start head length of the line.

Declaration:

public int StartHeadLength { get, set }

Value:

Integer value.

Default value:

N/A


StartHeadType Property

32-bit
64-bit
CF
P
P

Description:

The start head type of the line.

Declaration:

public ImageGear.ART.ImGearARTLineHeadType StartHeadType { get, set }

Value:

ImGearARTLineHeadType Enumeration value.

Default value:

N/A

See Also:

ImGearARTLineHeadType Enumeration


Style Property

32-bit
64-bit
CF
P
P

Description:

The style of the line.

Declaration:

public ImageGear.ART.ImGearARTPenStyle Style { get, set }

Value:

ImGearARTPenStyle Enumeration value.

Default value:

N/A

See Also:

ImGearARTPenStyle Enumeration


Width Property

32-bit
64-bit
CF
P
P

Description:

The line width.

Declaration:

public int Width { get, set }

Value:

Integer value.

Default value:

N/A


ImGearARTPolyline Methods

The ImGearARTPolyline Class of the ImageGear.ART Namespace has the following methods:

Methods
Name
Description
GetPoint Method
Gets point with specified index.
SetPoint Method
Sets point at specified index.


GetPoint Method

32-bit
64-bit
CF
P
P

Description:

Gets point with specified index.

Declaration:

public ImageGear.Core.ImGearPoint GetPoint ( Int nIndex )

Parameters:

Name
Type
Description
nIndex
Int
Index of the point.

Return Value:

ImGearPoint Structure object.

See Also:

ImGearPoint Structure


ImGearARTProtractor Class

32-bit
64-bit
CF
P
P

Description:

ART Protractor mark.

Declaration:

public class ImGearARTProtractor : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTProtractor Constructor
Creates a new instance of ImGearARTProtractor object.
ImGearARTProtractor Constructor
Creates a new instance of ImGearARTProtractor object.

Properties
Name
Description
ArcRadius Property
The radius, in pixels, of the arc drawn in the mark.
AspectDenominatorX Property
Mark's X aspect denominator value.
AspectDenominatorY Property
Mark's Y aspect denominator value.
AspectNumeratorX Property
Mark's X aspect numerator value.
AspectNumeratorY Property
Mark's Y aspect numerator value.
Color Property
Mark color.
EndPoint Property
End point of the protractor.
FontName Property
Font name of the text font.
FontSize Property
Font size of the text font.
FontStyle Property
Font style of the text font.
FontDisablePPM Property
Option to enable/disable PPM in font size calculations.
HeadPoint Property
Head point of the protractor.
Opacity Property
Opacity of the mark.
Precision Property
The number of decimal digits displayed for the mark.
StartPoint Property
Start point of the protractor.
Style Property
Style of the mark's line.
Width Property
Width of the mark's line.

Sample Code:

C#
// Setup location for the protractor
ImGearPoint igPointStart = new ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2);
ImGearPoint igPointHead = new ImGearPoint(50, 50);
ImGearPoint igPointEnd = new ImGearPoint(igPage.DIB.Width / 2, 50);
// Setup color for the protractor.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(0, 255, 0);
// Create the protractor annotation with a width of 3 and 90% opacity,
// 1:1 aspect ratio, radius of 100 for the arc drawn in the protractor,
// 3 decimals of precision, and size 12 regular Times New Roman font.
ImGearARTProtractor igARTProtractor = new ImGearARTProtractor(
    igPointStart, igPointHead, igPointEnd, igRGBQuad,
    ImGearARTPenStyle.SOLID, 3, (int)(0.90 * 255),
    1, 1, 1, 1, 100,
    3, "Times New Roman", (float)12.0, FontStyle.Regular
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTProtractor, ImGearARTCoordinatesType.IMAGE_COORD);

VB .NET
' Setup location for the protractor
Dim igPointStart As New ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2)
Dim igPointHead As New ImGearPoint(50, 50)
Dim igPointEnd As New ImGearPoint(igPage.DIB.Width / 2, 50)
' Setup color for the protractor.
Dim igRGBQuad As New ImGearRGBQuad(0, 255, 0)
' Create the protractor annotation with a width of 3 and 90% opacity,
' 1:1 aspect ratio, radius of 100 for the arc drawn in the protractor,
' 3 decimals of precision, and size 12 regular Times New Roman font.
Dim igARTProtractor As New ImGearARTProtractor( _
 igPointStart, igPointHead, igPointEnd, igRGBQuad, _
 ImGearARTPenStyle.SOLID, 3, CInt(0.9 * 255), _
 1, 1, 1, 1, 100, _
 3, "Times New Roman", CSng(12), FontStyle.Regular)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTProtractor, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTProtractor Constructors

The ImGearARTProtractor Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTProtractor Constructor
Creates a new instance of ImGearARTProtractor object.
ImGearARTProtractor Constructor
Creates a new instance of ImGearARTProtractor object.


ImGearARTProtractor Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTProtractor Class object.

Declaration:

public ImGearARTProtractor ( ImageGear.Core.ImGearPoint StartPoint ,
ImageGear.Core.ImGearPoint HeadPoint , ImageGear.Core.ImGearPoint EndPoint ,
ImageGear.Core.IImGearRGBQuad Color )

Parameters:

Name
Type
Description
StartPoint
ImGearPoint Structure
Start point of the mark.
HeadPoint
ImGearPoint Structure
Head point of the mark.
EndPoint
ImGearPoint Structure
End point of the mark.
Color
ImGearRGBQuad Structure
Mark color.

Return Value:

The new instance of ImGearARTProtractor Class object.

See Also:

ImGearPoint Structure

ImGearRGBQuad Structure


ImGearARTProtractor Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTProtractor Class object.

Declaration:

public ImGearARTProtractor ( ImageGear.Core.ImGearPoint StartPoint ,
ImageGear.Core.ImGearPoint HeadPoint , ImageGear.Core.ImGearPoint EndPoint ,
ImageGear.Core.IImGearRGBQuad Color , ImageGear.ART.ImGearARTPenStyle Style , Int Width ,
Int Opacity , Int AspectNumeratorX , Int AspectDenominatorX , Int AspectNumeratorY , Int
AspectDenominatorY , Int ArcRadius , Int Precision , String FontName , float FontSize ,
System.Drawing.FontStyle FontStyle )

Parameters:

Name
Type
Description
StartPoint
ImGearPoint Structure
Start point of the mark.
HeadPoint
ImGearPoint Structure
Head point of the mark.
EndPoint
ImGearPoint Structure
End point of the mark.
Color
ImGearRGBQuad Structure
Mark color.
Style
ImGearARTPenStyle Enumeration
Mark's line style.
Width
Int
Mark's line width.
Opacity
Int
Opacity of the mark.
AspectNumeratorX
Int
Mark's X aspect numerator value.
AspectDenominatorX
Int
Mark's X aspect denominator value.
AspectNumeratorY
Int
Mark's Y aspect numerator value.
AspectDenominatorY
Int
Mark's Y aspect denominator value.
ArcRadius
Int
The radius, in pixels, of the arc drawn in the mark.
Precision
Int
The number of decimal digits displayed for the mark.
FontName
String
The name of the font.
FontSize
float
The size of the font in points.
FontStyle
System.Drawing.FontStyle
The style of the font.

Return Value:

The new instance of ImGearARTProtractor Class object.

See Also:

ImGearPoint Structure

ImGearRGBQuad Structure

ImGearARTPenStyle Enumeration


ImGearARTProtractor Properties

The ImGearARTProtractor Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
ArcRadius Property
The radius, in pixels, of the arc drawn in the mark.
AspectDenominatorX Property
Mark's X aspect denominator value.
AspectDenominatorY Property
Mark's Y aspect denominator value.
AspectNumeratorX Property
Mark's X aspect numerator value.
AspectNumeratorY Property
Mark's Y aspect numerator value.
Color Property
Mark color.
EndPoint Property
End point of the protractor.
FontName Property
Font name of the text font.
FontSize Property
Font size of the text font.
FontStyle Property
Font style of the text font.
FontDisablePPM Property
Option to enable/disable PPM in font size calculations.
HeadPoint Property
Head point of the protractor.
Opacity Property
Opacity of the mark.
Precision Property
The number of decimal digits displayed for the mark.
StartPoint Property
Start point of the protractor.
Style Property
Style of the mark's line.
Width Property
Width of the mark's line.'


ArcRadius Property

32-bit
64-bit
CF
P
P

Description:

The radius, in pixels, of the arc drawn in the mark.

Declaration:

public int ArcRadius { get, set }

Value:

Integer value

Default value:

0


AspectDenominatorX Property

32-bit
64-bit
CF
P
P

Description:

Mark's X aspect denominator value.

Declaration:

public int AspectDenominatorX { get, set }

Value:

Integer value

Default value:

1


AspectDenominatorY Property

32-bit
64-bit
CF
P
P

Description:

Mark's Y aspect denominator value.

Declaration:

public int AspectDenominatorY { get, set }

Value:

Integer value

Default value:

1


AspectNumeratorX Property

32-bit
64-bit
CF
P
P

Description:

Mark's X aspect numerator value.

Declaration:

public int AspectNumeratorX { get, set }

Value:

Integer value

Default value:

1


AspectNumeratorY Property

32-bit
64-bit
CF
P
P

Description:

Mark's Y aspect numerator value.

Declaration:

public int AspectNumeratorY { get, set }

Value:

Integer value

Default value:

1


EndPoint Property

32-bit
64-bit
CF
P
P

Description:

End point of the mark.

Declaration:

public ImageGear.Core.ImGearPoint EndPoint { get, set }

Value:

ImGearPoint Structure

See Also:

ImGearPoint Structure


FontName Property

32-bit
64-bit
CF
P
P

Description:

Text font name.

Declaration:

public string FontName { get, set }

Value:

Name string.

Default value:

N/A


FontStyle Property

32-bit
64-bit
CF
P
P

Description:

Text font style.

Declaration:

public System.Drawing.FontStyle FontStyle { get, set }

Value:

FontStyle

Default value:

N/A


HeadPoint Property

32-bit
64-bit
CF
P
P

Description:

Head point of the mark.

Declaration:

public ImageGear.Core.ImGearPoint HeadPoint { get, set }

Value:

ImGearPoint Structure object.

Default value:

N/A

See Also:

ImGearPoint Structure


Precision Property

32-bit
64-bit
CF
P
P

Description:

The number of decimal digits displayed for the mark.

Declaration:

public int Precision { get, set }

Value:

Integer value

Default value:

1


StartPoint Property

32-bit
64-bit
CF
P
P

Description:

Start point of the mark.

Declaration:

public ImageGear.Core.ImGearPoint StartPoint { get, set }

Value:

ImGearPoint Structure object.

Default value:

N/A

See Also:

ImGearPoint Structure


Style Property

32-bit
64-bit
CF
P
P

Description:

The style of the mark's line.

Declaration:

public ImageGear.ART.ImGearARTPenStyle Style { get, set }

Value:

ImGearARTPenStyle Enumeration value.

Default value:

N/A

See Also:

ImGearARTPenStyle Enumeration


Width Property

32-bit
64-bit
CF
P
P

Description:

The width of the mark's line.

Declaration:

public int Width { get, set }

Value:

Integer value.

Default value:

N/A


ImGearARTRectangle Class

32-bit
64-bit
CF
P
P

Description:

ART Rectangle mark.

Declaration:

public class ImGearARTRectangle : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTRectangle Constructor
Creates a new instance of ImGearARTRectangle object.
ImGearARTRectangle Constructor
Creates a new instance of ImGearARTRectangle object.
ImGearARTRectangle Constructor
Creates a new instance of ImGearARTRectangle object.

Properties
Name
Description
Border Property
Border of the mark.
FillColor Property
Fill color of the mark.
Height Property
Height of rectangle.
Opacity Property
Opacity of the rectangle.
Width Property
Width of the rectangle.
X Property
The X coordinate of top-left point of the mark.
Y Property
The Y coordinate of top-left point of the mark.

Sample Code:

C#
// Setup rectangle for the rectangle mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 300, 100);
// Setup color for the rectangle.
ImGearRGBQuad igRGBQuadFill = new ImGearRGBQuad(40, 200, 40);
// Setup color for the rectangle border.
ImGearRGBQuad igRGBQuadBorder = new ImGearRGBQuad(0, 0, 0);
// Create rectangle with a solid border of width 10, and 33% opacity.
ImGearARTRectangle igARTRectangle = new ImGearARTRectangle(
    igRectangle, igRGBQuadFill, igRGBQuadBorder,
    ImGearARTPenStyle.SOLID, 10, (int)(0.33 * 255)
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTRectangle, ImGearARTCoordinatesType.IMAGE_COORD);

VB .NET
' Setup rectangle for the rectangle mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 300, 100)
' Setup color for the rectangle.
Dim igRGBQuadFill As New ImGearRGBQuad(40, 200, 40)
' Setup color for the rectangle border.
Dim igRGBQuadBorder As New ImGearRGBQuad(0, 0, 0)
' Create rectangle with a solid border of width 10, and 33% opacity.
Dim igARTRectangle As New ImGearARTRectangle( _
 igRectangle, igRGBQuadFill, igRGBQuadBorder, _
 ImGearARTPenStyle.SOLID, 10, CInt(0.33 * 255))
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTRectangle, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTRectangle Constructors

The ImGearARTRectangle Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTRectangle Constructor
Creates a new instance of ImGearARTRectangle object.
ImGearARTRectangle Constructor
Creates a new instance of ImGearARTRectangle object.
ImGearARTRectangle Constructor
Creates a new instance of ImGearARTRectangle object.


ImGearARTRectangle Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTRectangle Class object.

Declaration:

public ImGearARTRectangle ( ImageGear.Core.IImGearRectangle Rect ,
ImageGear.Core.IImGearRGBQuad FillColor )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Mark rectangle.
FillColor
ImGearRGBQuad Structure
Fill color of the rectangle.

Return Value:

The new instance of ImGearARTRectangle Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure


ImGearARTRectangle Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTRectangle Class object.

Declaration:

public ImGearARTRectangle ( ImageGear.Core.IImGearRectangle Rect ,
ImageGear.Core.IImGearRGBQuad BorderColor , ImageGear.ART.ImGearARTPenStyle BorderStyle ,
Int BorderWidth )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
The mark's rectangle.
BorderColor
ImGearRGBQuad Structure
The border color of the mark.
BorderStyle
ImGearARTPenStyle Enumeration
The border style of the mark.
BorderWidth
Int
The border width of the mark.

Return Value:

The new instance of ImGearARTRectangle Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure

ImGearARTPenStyle Enumeration


ImGearARTRectangle Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTRectangle Class object.

Declaration:

public ImGearARTRectangle ( ImageGear.Core.IImGearRectangle Rect ,
ImageGear.Core.IImGearRGBQuad FillColor , ImageGear.Core.IImGearRGBQuad BorderColor ,
ImageGear.ART.ImGearARTPenStyle BorderStyle , Int BorderWidth , Int Opacity )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Mark rectangle.
FillColor
ImGearRGBQuad Structure
Fill color of the rectangle.
BorderColor
ImGearRGBQuad Structure
The border color of the mark.
BorderStyle
ImGearARTPenStyle Enumeration
The border style of the mark.
BorderWidth
Int
The border width of the mark.
Opacity
Int
Opacity of the rectangle.

Return Value:

The new instance of ImGearARTRectangle Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure

ImGearARTPenStyle Enumeration


ImGearARTRectangle Properties

The ImGearARTRectangle Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
Border Property
Border of the mark.
FillColor Property
Fill color of the mark.
Height Property
Height of rectangle.
Opacity Property
Opacity of the rectangle.
Width Property
Width of the rectangle.
X Property
The X coordinate of top-left point of the mark.
Y Property
The Y coordinate of top-left point of the mark.


FillColor Property

32-bit
64-bit
CF
P
P

Description:

The fill color of the mark.

Declaration:

public ImageGear.Core.IImGearRGBQuad FillColor { get, set }

Value:

ImGearRGBQuad Structure object interface.

Default value:

N/A

See Also:

ImGearRGBQuad Structure


Opacity Property

32-bit
64-bit
CF
P
P

Description:

The opacity of the rectangle.

Declaration:

public int Opacity { get, set }

Value:

Integer value from 0 (transparent) to 255 (opaque).

Default value:

255


ImGearARTRedaction Class

32-bit
64-bit
CF
P
P

Description:

Legacy ART Redaction mark.

Declaration:

public class ImGearARTRedaction : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTRedaction Constructor
Creates a new instance of ImGearARTRedaction object.

Properties
Name
Description
FillColor Property
Fill color of the mark.
Height Property
Height of the mark's rectangle.
Width Property
Width of the mark's rectangle.
X Property
The X coordinate of the top-left point of the mark's rectangle.
Y Property
The Y coordinate of the top-left point of the mark's rectangle.

Sample Code:

C#
// Setup rectangle for the red action mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 300, 100);
// Setup color for the red action.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(255, 0, 0);
// Create red action mark.
ImGearARTRedaction igARTRedaction = new ImGearARTRedaction(
    igRectangle, igRGBQuad
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTRedaction, ImGearARTCoordinatesType.IMAGE_COORD);

VB .NET
' Setup rectangle for the red action mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 300, 100)
' Setup color for the red action.
Dim igRGBQuad As New ImGearRGBQuad(255, 0, 0)
' Create red action mark.
Dim igARTRedaction As New ImGearARTRedaction( _
 igRectangle, igRGBQuad)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTRedaction, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTRedaction Constructors

The ImGearARTRedaction Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTRedaction Constructor
Creates a new instance of ImGearARTRedaction object.


ImGearARTRedaction Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTRedaction Class object.

Declaration:

public ImGearARTRedaction ( ImageGear.Core.IImGearRectangle Rect ,
ImageGear.Core.IImGearRGBQuad FillColor )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Mark's rectangle.
FillColor
ImGearRGBQuad Structure
Fill color of the mark.

Return Value:

The new instance of ImGearARTRedaction Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure


ImGearARTRedaction Properties

The ImGearARTRedaction Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
FillColor Property
Fill color of the mark.
Height Property
Height of the mark's rectangle.
Width Property
Width of the mark's rectangle.
X Property
The X coordinate of the top-left point of the mark's rectangle.
Y Property
The Y coordinate of the top-left point of the mark's rectangle.


Width Property

32-bit
64-bit
CF
P
P

Description:

The width of the mark's rectangle.

Declaration:

public int Width { get, set }

Value:

Integer value.

Default value:

N/A


ImGearARTRichText Class

32-bit
64-bit
CF
P
P

Description:

ART Rich Text mark.

Declaration:

public class ImGearARTRichText : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTRichText Constructor
Creates a new instance of ImGearARTRichText object.
ImGearARTRichText Constructor
Creates a new instance of ImGearARTRichText object.

Properties
Name
Description
Border Property
Specifies RichText mark's border.
Control Property
ART Rich Text control based on System.Windows.Forms.RichTextBox suitable for ART processing and drawing.
FillColor Property
Specifies RichText mark's fill color.
Height Property
Height of the mark's rectangle.
Opacity Property
Opacity of the RichText mark.
Orientation Property
Rich Text Orientation.
Width Property
Width of the mark's rectangle.
X Property
The X coordinate of the top-left point of the mark's rectangle.
Y Property
The Y coordinate of the top-left point of the mark's rectangle.

Methods
Name
Description
BeginEdit Method
Begins text editing process.
EndEdit Method
Ends text editing process.

Sample Code:

C#
// Setup color for the rich text border.
ImGearRGBQuad igRGBQuadBorder = new ImGearRGBQuad(0, 255, 255);
// Setup a border with a width of 3 and a solid pattern.
ImGearARTBorder igARTBorder = new ImGearARTBorder(
    igRGBQuadBorder, 3, ImGearARTPenStyle.SOLID
);
// Setup rectangle for the rich text mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 300, 40);
// Setup fill color for the rich text mark.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(210, 210, 210);
// Set initial rich text string
string richText = "{\\rtf1\\ansi\\ansicpg1252\\deff0\\deflang1033{\\fonttbl{\\f0\\fnil\\fcharset0 Arial;}}\r\n";
richText += "\\viewkind4\\uc1\\pard\\fs23 ImGearARTRichText test\\par\r\n}\r\n";
// Create rich text mark with 70% opacity
ImGearARTRichText igARTRichText = new ImGearARTRichText(
    igRectangle, richText, igRGBQuad, igARTBorder, (int)(0.70 * 255)
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTRichText, ImGearARTCoordinatesType.IMAGE_COORD);

VB .NET
' Setup color for the rich text border.
Dim igRGBQuadBorder As New ImGearRGBQuad(0, 255, 255)
' Setup a border with a width of 3 and a solid pattern.
Dim igARTBorder As New ImGearARTBorder(igRGBQuadBorder, 3, ImGearARTPenStyle.SOLID)
' Setup rectangle for the rich text mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 300, 40)
' Setup fill color for the rich text mark.
Dim igRGBQuad As New ImGearRGBQuad(210, 210, 210)
' Set initial rich text string
Dim richText As String = "{\rtf1\ansi\ansicpg1252\deff0\deflang1033{\fonttbl{\f0\fnil\fcharset0 Arial;}}"
richText += Chr(13) & "" & Chr(10) & "\viewkind4\uc1\pard\fs23 ImGearARTRichText test\par"
richText += Chr(13) & "" & Chr(10) & "}" & Chr(13) & "" & Chr(10) & ""
' Create rich text mark with 70% opacity
Dim igARTRichText As New ImGearARTRichText( _
 igRectangle, richText, igRGBQuad, igARTBorder, CInt(0.7 * 255))
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTRichText, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTRichText Constructors

The ImGearARTRichText Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTRichText Constructor
Creates a new instance of ImGearARTRichText object.
ImGearARTRichText Constructor
Creates a new instance of ImGearARTRichText object.


ImGearARTRichText Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTRichText Class object.

Declaration:

public ImGearARTRichText ( ImageGear.Core.IImGearRectangle Rect, String RichText )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Mark's rectangle.
RichText
String
RTF formatted text.

Return Value:

The new instance of ImGearARTRichText Class object.

See Also:

ImGearRectangle Structure


ImGearARTRichText Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTRichText Class object.

Declaration:

public ImGearARTRichText ( ImageGear.Core.IImGearRectangle Rect, String RichText,
ImageGear.Core.IImGearRGBQuad FillColor, ImageGear.ART.ImGearARTBorder Border, Int Opacity
)

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Mark's rectangle.
RichText
String
RTF formatted text.
FillColor
ImGearRGBQuad Structure
RichText mark's fill color.
Border
ImGearARTBorder Class
RichText mark's border.
Opacity
Int
Opacity of the RichText mark.

Return Value:

The new instance of ImGearARTRichText Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure

ImGearARTBorder Class


ImGearARTRichText Properties

The ImGearARTRichText Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
Border Property
Specifies RichText mark's border.
Control Property
ART Rich Text control based on System.Windows.Forms.RichTextBox suitable for ART processing and drawing.
FillColor Property
Specifies RichText mark's fill color.
Height Property
Height of the mark's rectangle.
Opacity Property
Opacity of the RichText mark.
Orientation Property
Rich Text Orientation.
Width Property
Width of the mark's rectangle.
X Property
The X coordinate of the top-left point of the mark's rectangle.
Y Property
The Y coordinate of the top-left point of the mark's rectangle.


Border Property

32-bit
64-bit
CF
P
P

Description:

Specifies the RichText mark's border.

Declaration:

public ImageGear.ART.ImGearARTBorder Border { get, set }

Value:

ImGearARTBorder Class object.

Default value:

N/A

See Also:

ImGearARTBorder Class


Control Property

32-bit
64-bit
CF
P
P

Description:

Reference to the ART Rich Text control.

Declaration:

public ImageGear.ART.ImGearARTRichTextControl Control { get }

Value:

ImGearARTRichTextControl Class object.

Default value:

N/A

See Also:

ImGearARTRichTextControl Class


FillColor Property

32-bit
64-bit
CF
P
P

Description:

Specifies the RichText mark's fill color.

Declaration:

public ImageGear.Core.IImGearRGBQuad FillColor { get, set }

Value:

ImGearRGBQuad Structure object interface.

Default value:

N/A

See Also:

ImGearRGBQuad Structure


Opacity Property

32-bit
64-bit
CF
P
P

Description:

Opacity of the RichText mark.

Declaration:

public int Opacity { get, set }

Value:

Integer value from 0 (transparent) to 255 (opaque).

Default value:

255


Orientation Property

32-bit
64-bit
CF
P
P

Description:

Rich text orientation.

Declaration:

public ImageGear.Core.ImGearOrientationModes Orientation { get, set }

Value:

ImGearOrientationModes Enumeration value.

Default value:

TOP_LEFT

See Also:

ImGearOrientationModes Enumeration


ImGearARTRichText Methods

The ImGearARTRichText Class of the ImageGear.ART Namespace has the following methods:

Methods
Name
Description
BeginEdit Method
Begins text editing process.
EndEdit Method
Ends text editing process.


BeginEdit Method

32-bit
64-bit
CF
P
P

Description:

Begins the text editing process.

Declaration:

public bool BeginEdit ( ImageGear.Display.IImGearScrollableView PageView ,
ImageGear.Display.ImGearPageDisplay PageDisplay )

Parameters:

Name
Type
Description
PageView
IImGearScrollableView Interface
PageView control that contains the mark.
PageDisplay
ImGearPageDisplay Class
PageDisplay of the PageView control.

Return Value:

True if the editing has begun, False - otherwise.

See Also:

IImGearScrollableView Interface

ImGearPageDisplay Class


EndEdit Method

32-bit
64-bit
CF
P
P

Description:

Ends the text editing process.

Declaration:

public void EndEdit ( ImageGear.Display.IImGearScrollableView PageView )

Parameters:

Name
Type
Description
PageView
IImGearScrollableView Interface
PageView control that contains text mark.

Return Value:

None.

See Also:

IImGearScrollableView Interface


ImGearARTRichTextControl Class

32-bit
64-bit
CF
P
P

Description:

ART Rich Text control is a class based on System.Windows.Forms.RichTextBox suitable for ART processing and drawing.

Declaration:

public class ImGearARTRichTextControl : System.Windows.Forms.RichTextBox

Members:

See System.Windows.Forms.RichTextBox in MSDN.


ImGearARTRuler Class

32-bit
64-bit
CF
P
P

Description:

ART Ruler mark.

Declaration:

public class ImGearARTRuler : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTRuler Constructor
Creates a new instance of ImGearARTRuler object.
ImGearARTRuler Constructor
Creates a new instance of ImGearARTRuler object.

Properties
Name
Description
AspectDenominatorX Property
Mark's X aspect denominator value.
AspectDenominatorY Property
Mark's Y aspect denominator value.
AspectNumeratorX Property
Mark's X aspect numerator value.
AspectNumeratorY Property
Mark's Y aspect numerator value.
Color Property
Color of the mark.
EndLineLength Property
The length of the mark's end line.
EndPoint Property
End point of the mark.
FontName Property
Font name of the text font.
FontSize Property
Font size of the text font.
FontStyle Property
Font style of the text font.
FontDisablePPM Property
Option to enable/disable PPM in font size calculations.
Label Property
Mark label.
Opacity Property
Opacity of the mark.
Precision Property
The number of decimal digits displayed for the mark.
StartLineLength Property
The length of the marks' start line.
StartPoint Property
Start point of the mark.
Style Property
Mark's line style.
Width Property
Mark's line width.

Sample Code:

C#
// Setup start and endpoint for the ruler.
ImGearPoint igPointStart = new ImGearPoint(10, 10);
ImGearPoint igPointEnd = new ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2);
// Setup color for annotation.
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(0, 255, 0);
// Create the ruler annotation with a solid line of width 2 and 75% opacity,
//  1:1 aspect ratio, end lines of with 50, 3 decimal places of precision,
//  and a label in size 12 regular Arial font.
ImGearARTRuler igARTRuler = new ImGearARTRuler(
    igPointStart, igPointEnd, igRGBQuad,
    ImGearARTPenStyle.SOLID, 2, (int)(0.75 * 255),
    1, 1, 1, 1, 50, 50, 3,
    "ImGearARTRuler test", "Arial", (float)12.0, FontStyle.Regular
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTRuler, ImGearARTCoordinatesType.IMAGE_COORD);

VB .NET
' Setup start and endpoint for the ruler.
Dim igPointStart As New ImGearPoint(10, 10)
Dim igPointEnd As New ImGearPoint(igPage.DIB.Width / 2, igPage.DIB.Height / 2)
' Setup color for annotation.
Dim igRGBQuad As New ImGearRGBQuad(0, 255, 0)
' Create the ruler annotation with a solid line of width 2 and 75% opacity,
'  1:1 aspect ratio, end lines of with 50, 3 decimal places of precision,
'  and a label in size 12 regular Arial font.
Dim igARTRuler As New ImGearARTRuler( _
 igPointStart, igPointEnd, igRGBQuad, _
 ImGearARTPenStyle.SOLID, 2, CInt(0.75 * 255), _
 1, 1, 1, 1, 50, 50, 3, _
 "ImGearARTRuler test", "Arial", CSng(12), FontStyle.Regular)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTRuler, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTRuler Constructors

The ImGearARTRuler Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTRuler Constructor
Creates a new instance of ImGearARTRuler object.
ImGearARTRuler Constructor
Creates a new instance of ImGearARTRuler object.


ImGearARTRuler Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTRuler Class object.

Declaration:

public ImGearARTRuler ( ImageGear.Core.ImGearPoint StartPoint , ImageGear.Core.ImGearPoint
EndPoint , ImageGear.Core.IImGearRGBQuad Color )

Parameters:

Name
Type
Description
StartPoint
ImGearPoint Structure
Start point of the mark.
EndPoint
ImGearPoint Structure
End point of the mark.
Color
ImGearRGBQuad Structure
Mark color.

Return Value:

The new instance of ImGearARTRuler Class object.

See Also:

ImGearPoint Structure

ImGearRGBQuad Structure


ImGearARTRuler Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTRuler Class object.

Declaration:

public ImGearARTRuler ( ImageGear.Core.ImGearPoint StartPoint , ImageGear.Core.ImGearPoint
EndPoint , ImageGear.Core.IImGearRGBQuad Color , ImageGear.ART.ImGearARTPenStyle Style ,
Int Width , Int Opacity , Int AspectNumeratorX , Int AspectDenominatorX , Int
AspectNumeratorY , Int AspectDenominatorY , Int StartLineLength , Int EndLineLength , Int
Precision , String Label , String FontName , float FontSize , System.Drawing.FontStyle
FontStyle )

Parameters:

Name
Type
Description
StartPoint
ImGearPoint Structure
Start point of the mark.
EndPoint
ImGearPoint Structure
End point of the mark.
Color
ImGearRGBQuad Structure
Mark color.
Style
ImGearARTPenStyle Enumeration
Mark's line style
Width
Int
Mark's line width.
Opacity
Int
Opacity of the mark.
AspectNumeratorX
Int
Mark's X aspect numerator value.
AspectDenominatorX
Int
Mark's X aspect denominator value.
AspectNumeratorY
Int
Mark's Y aspect numerator value.
AspectDenominatorY
Int
Mark's Y aspect denominator value.
StartLineLength
Int
Length of the start line of the mark.
EndLineLength
Int
Length of the end line of the mark.
Precision
Int
The number of decimal digits displayed for the mark.
Label
String
Mark's label.
FontName
String
The name of the font.
FontSize
float
The size of the font in points.
FontStyle
System.Drawing.FontStyle
The style of the font.

Return Value:

The new instance of ImGearARTRuler object.

See Also:

ImGearPoint Structure

ImGearRGBQuad Structure

ImGearARTPenStyle Enumeration


ImGearARTRuler Properties

The ImGearARTRuler Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
AspectDenominatorX Property
Mark's X aspect denominator value.
AspectDenominatorY Property
Mark's Y aspect denominator value.
AspectNumeratorX Property
Mark's X aspect numerator value.
AspectNumeratorY Property
Mark's Y aspect numerator value.
Color Property
Color of the mark.
EndLineLength Property
The length of the mark's end line.
EndPoint Property
End point of the mark.
FontName Property
Font name of the text font.
FontSize Property
Font size of the text font.
FontStyle Property
Font style of the text font.
FontDisablePPM Property
Option to enable/disable PPM in font size calculations.
Label Property
Mark label.
Opacity Property
Opacity of the mark.
Precision Property
The number of decimal digits displayed for the mark.
StartLineLength Property
The length of the marks' start line.
StartPoint Property
Start point of the mark.
Style Property
Mark's line style.
Width Property
Mark's line width.


AspectDenominatorX Property

32-bit
64-bit
CF
P
P

Description:

Mark's X aspect denominator value.

Declaration:

public int AspectDenominatorX { get, set }

Value:

Integer value

Default value:

1

Remarks:

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurment units like meters or inches.

For instance, with the following values the distance is measured in meters:

AspectNumeratorX = AspectNumeratorY = 1;
AspectDenominatorX = dwXPelsPerMeter;
AspectDenominatorY = dwYPelsPerMeter;

Here dwXPelsPerMeter and dwYPelsPerMeter are image horizontal and vertical resolutions respectively measured in PPM (pixels per meter).


AspectDenominatorY Property

32-bit
64-bit
CF
P
P

Description:

Mark's Y aspect denominator value.

Declaration:

public int AspectDenominatorY { get, set }

Value:

Integer value

Default value:

1

Remarks:

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

For instance, with the following values the distance is measured in meters:

AspectNumeratorX = AspectNumeratorY = 1;
AspectDenominatorX = dwXPelsPerMeter;
AspectDenominatorY = dwYPelsPerMeter;

Here dwXPelsPerMeter and dwYPelsPerMeter are image horizontal and vertical resolutions respectively measured in PPM (pixels per meter).


AspectNumeratorX Property

32-bit
64-bit
CF
P
P

Description:

Mark's X aspect numerator value.

Declaration:

public int AspectNumeratorX { get, set }

Value:

Integer value

Default value:

1

Remarks:

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

For instance, with the following values the distance is measured in meters:

AspectNumeratorX = AspectNumeratorY = 1;
AspectDenominatorX = dwXPelsPerMeter;
AspectDenominatorY = dwYPelsPerMeter;

Here dwXPelsPerMeter and dwYPelsPerMeter are image horizontal and vertical resolutions respectively measured in PPM (pixels per meter).


AspectNumeratorY Property

32-bit
64-bit
CF
P
P

Description:

Mark's Y aspect numerator value.

Declaration:

public int AspectNumeratorY { get, set }

Value:

Integer value

Default value:

1

Remarks:

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

For instance, with the following values the distance is measured in meters:

AspectNumeratorX = AspectNumeratorY = 1;
AspectDenominatorX = dwXPelsPerMeter;
AspectDenominatorY = dwYPelsPerMeter;

Here dwXPelsPerMeter and dwYPelsPerMeter are image horizontal and vertical resolutions respectively measured in PPM (pixels per meter).


EndLineLength Property

32-bit
64-bit
CF
P
P

Description:

The length of the mark's end line.

Declaration:

public int EndLineLength { get, set }

Value:

Integer value

Default value:

20


EndPoint Property

32-bit
64-bit
CF
P
P

Description:

The end point of the mark.

Declaration:

public ImageGear.Core.ImGearPoint EndPoint { get, set }

Value:

ImGearPoint Structure object.

Default value:

N/A

See Also:

ImGearPoint Structure


FontName Property

32-bit
64-bit
CF
P
P

Description:

Text font name.

Declaration:

public string FontName { get, set }

Value:

Name string.

Default value:

""


FontSize Property

32-bit
64-bit
CF
P
P

Description:

Text font size in points.

Declaration:

public float FontSize { get, set }

Value:

Any positive value.

Default value:

N/A


Label Property

32-bit
64-bit
CF
P
P

Description:

Mark's label.

Declaration:

public string Label { get, set }

Value:

String value

Default value:

""


StartLineLength Property

32-bit
64-bit
CF
P
P

Description:

The length of the mark's start line.

Declaration:

public int StartLineLength { get, set }

Value:

Integer value

Default value:

20


StartPoint Property

32-bit
64-bit
CF
P
P

Description:

The srart point of the mark.

Declaration:

public ImageGear.Core.ImGearPoint StartPoint { get, set }

Value:

ImGearPoint Structure object.

Default value:

N/A

See Also:

ImGearPoint Structure


Style Property

32-bit
64-bit
CF
P
P

Description:

The mark's line style.

Declaration:

public ImageGear.ART.ImGearARTPenStyle Style { get, set }

Value:

ImGearARTPenStyle Enumeration value.

Default value:

N/A

See Also:

ImGearARTPenStyle Enumeration


Width Property

32-bit
64-bit
CF
P
P

Description:

The mark's line width.

Declaration:

public int Width { get, set }

Value:

Integer value

Default value:

N/A


ImGearARTSelection Class

32-bit
64-bit
CF
P
P

Description:

This abstract class defines internal interface for mark selection.

Declaration:

public abstract class ImGearARTSelection

Members:

N/A


ImGearARTShapeMarkStat Class

32-bit
64-bit
CF
P
P

Description:

This class represents specific statistics information about the shaped ART marks. This information is: area and perimeter of the mark.

An instance of the ImGearARTShapeMarkStat Class is always created for the specified mark object and should not be used after destroying that mark object.

Declaration:

public class ImGearARTShapeMarkStat : ImGearARTMarkStat

Members:

Properties
Name
Description
Area Property
Specifies the area of the shape mark.
Perimeter Property
Specifies the perimeter of the shape mark.

See Also:

ImGearARTMarkStat Class

ImGearARTLineMarkStat Class

ImGearARTPointMarkStat Class


ImGearARTShapeMarkStat Properties

The ImGearARTShapeMarkStat Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
Area Property
Specifies the area of the shape mark.
Perimeter Property
Specifies the perimeter of the shape mark.


Area Property

32-bit
64-bit
CF
P
P

Description:

This property specifies the area of the original ART mark.

Declaration:

public double Area { get }

Value:

double value


Perimeter Property

32-bit
64-bit
CF
P
P

Description:

This property specifies the perimeter of the original ART mark.

Declaration:

public double Perimeter { get }

Value:

double value


ImGearARTText Class

32-bit
64-bit
CF
P
P

Description:

ART Text mark.

Declaration:

public class ImGearARTText : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTText Constructor
Creates a new instance of ImGearARTText object.
ImGearARTText Constructor
Creates a new instance of ImGearARTText object.
ImGearARTText Constructor
Creates a new instance of ImGearARTText object.

Properties
Name
Description
AlignmentH Property
Specifies text horizontal alignment.
AlignmentV Property
Specifies text vertical alignment.
Border Property
Border of the mark.
BorderShading Property
Border shading of the mark.
Callout Property
ImGearARTCallout Class object that specifies mark's callout attributes.
FillColor Property
Fill color of the mark.
FontName Property
Font name of the mark's text.
FontSize Property
Font size of the mark's text.
FontStyle Property
Font style of the mark's text.
FontDisablePPM Property
Option to enable/disable PPM in font size calculations.
Height Property
Height of the mark's rectangle.
Opacity Property
Opacity of the mark.
Orientation Property
Text orientation.
Pin Property
ImGearARTPin object that specifies mark's pin icon attributes.
Text Property
Text string.
TextColor Property
Color of the text.
TextType Property
Type of the text.
Width Property
Width of the mark's rectangle.
X Property
X coordinate of the top-left point of the mark's rectangle.
Y Property
Y coordinate of the top-left point of the mark's rectangle.

Methods
Name
Description
BeginEdit Method
Begins text editing process.
EndEdit Method
Ends text editing process.

Sample Code:

C#
// Setup color for the border.
ImGearRGBQuad igRGBQuadBorder = new ImGearRGBQuad(0, 255, 0);
// Setup a border with a width of 3 and a dot pattern.
ImGearARTBorder igARTBorder = new ImGearARTBorder(
    igRGBQuadBorder, 3, ImGearARTPenStyle.DOT
);
// Setup color for the pin.
ImGearRGBQuad igRGBQuadPin = new ImGearRGBQuad(0, 0, 255);
// Create pin to be used in the annotation.
ImGearARTPin igARTPin = new ImGearARTPin(igRGBQuadPin, ImGearARTPinAlignment.RIGHT_TOP);
// Setup color for the callout border.
ImGearRGBQuad igRGBQuadBorderCallout = new ImGearRGBQuad(0, 255, 255);
// Setup a border with a width of 3 and a solid pattern.
ImGearARTBorder igARTBorderCallout = new ImGearARTBorder(
    igRGBQuadBorder, 3, ImGearARTPenStyle.SOLID
);
// Create a callout to be used for the text annotation.
ImGearARTCallout igARTCallout = new ImGearARTCallout(
    ImGearARTCalloutType.LINE, igPage.DIB.Width / 2,
    igPage.DIB.Height / 2, igARTBorderCallout
);
// Setup rectangle for the text mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 330, 40);
// Setup color for the text.
ImGearRGBQuad igRGBQuadText = new ImGearRGBQuad(255, 0, 255);
// Setup color for the fill.
ImGearRGBQuad igRGBQuadFill = new ImGearRGBQuad(200, 200, 200);
// Create the text annotation.
ImGearARTText igARTText = new ImGearARTText(
    igRectangle, "ImGearARTText annotation", igRGBQuadText,
    ImGearARTTextType.DIRECT_TEXT, igRGBQuadFill, igARTBorder, false,
    255, "Arial", (float)14.0, FontStyle.Regular, igARTPin, igARTCallout
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTText, ImGearARTCoordinatesType.IMAGE_COORD);

VB .NET
' Setup color for the border.
Dim igRGBQuadBorder As New ImGearRGBQuad(0, 255, 0)
' Setup a border with a width of 3 and a dot pattern.
Dim igARTBorder As New ImGearARTBorder(igRGBQuadBorder, 3, ImGearARTPenStyle.DOT)
' Setup color for the pin.
Dim igRGBQuadPin As New ImGearRGBQuad(0, 0, 255)
' Create pin to be used in the annotation.
Dim igARTPin As New ImGearARTPin(igRGBQuadPin, ImGearARTPinAlignment.RIGHT_TOP)
' Setup color for the callout border.
Dim igRGBQuadBorderCallout As New ImGearRGBQuad(0, 255, 255)
' Setup a border with a width of 3 and a solid pattern.
Dim igARTBorderCallout As New ImGearARTBorder(igRGBQuadBorder, 3, ImGearARTPenStyle.SOLID)
' Create a callout to be used for the text annotation.
Dim igARTCallout As New ImGearARTCallout( _
 ImGearARTCalloutType.LINE, igPage.DIB.Width / 2, igPage.DIB.Height / 2, igARTBorderCallout)
' Setup rectangle for the text mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 330, 40)
' Setup color for the text.
Dim igRGBQuadText As New ImGearRGBQuad(255, 0, 255)
' Setup color for the fill.
Dim igRGBQuadFill As New ImGearRGBQuad(200, 200, 200)
' Create the text annotation.
Dim igARTText As New ImGearARTText( _
 igRectangle, "ImGearARTText annotation", igRGBQuadText, _
 ImGearARTTextType.DIRECT_TEXT, igRGBQuadFill, igARTBorder, False, _
 255, "Arial", CSng(14), FontStyle.Regular, igARTPin, igARTCallout)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTText, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTText Constructors

The ImGearARTText Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTText Constructor
Creates a new instance of ImGearARTText object.
ImGearARTText Constructor
Creates a new instance of ImGearARTText object.
ImGearARTText Constructor
Creates a new instance of ImGearARTText object.


ImGearARTText Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTText Class object.

Declaration:

public ImGearARTText ( ImageGear.Core.IImGearRectangle Rect , String Text ,
ImageGear.Core.IImGearRGBQuad TextColor )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Mark's rectangle.
Text
String
Text of the mark.
TextColor
ImGearRGBQuad Structure
Color of the mark's text.

Return Value:

The new instance of ImGearARTText Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure


ImGearARTText Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTText Class object.

Declaration:

public ImGearARTText ( ImageGear.Core.IImGearRectangle Rect , String Text ,
ImageGear.Core.IImGearRGBQuad TextColor , ImageGear.ART.ImGearARTTextType TextType ,
ImageGear.Core.IImGearRGBQuad FillColor , ImageGear.ART.ImGearARTBorder Border , Bool
BorderShading , Int Opacity , String FontName , float FontSize , System.Drawing.FontStyle
FontStyle , ImageGear.ART.ImGearARTPin Pin )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Mark's rectangle.
Text
String
Text of the mark.
TextColor
ImGearRGBQuad Structure
Color of the mark's text.
TextType
ImGearARTTextType Enumeration
Text type.
FillColor
ImGearRGBQuad Structure
Fill color of the mark.
Border
ImGearARTBorder Class
Border of the mark.
BorderShading
Bool
Border shading of the mark.
Opacity
Int
Opacity of the mark.
FontName
String
The name of the font.
FontSize
float
The size of the font in points.
FontStyle
System.Drawing.FontStyle
The style of the font.
Pin
ImGearARTPin Class
ImGearARTPin object that specifies mark's pin icon attributes.

Return Value:

The new instance of ImGearARTText Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure

ImGearARTTextType Enumeration

ImGearARTBorder Class

ImGearARTPin Class


ImGearARTText Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTText Class object.

Declaration:

public ImGearARTText(ImageGear.Core.IImGearRectangle Rect, string Text,
ImageGear.Core.IImGearRGBQuad TextColor, ImageGear.ART.ImGearARTTextType TextType,
ImageGear.Core.IImGearRGBQuad FillColor, ImageGear.ART.ImGearARTBorder Border, bool
BorderShading, int Opacity, string FontName, float FontSize, System.Drawing.FontStyle
FontStyle, ImageGear.ART.ImGearARTPin Pin, ImageGear.ART.ImGearARTCallout Callout)

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Mark's rectangle.
Text
String
Text of the mark.
TextColor
ImGearRGBQuad Structure
Color of the mark's text.
TextType
ImGearARTTextType Enumeration
Text type.
FillColor
ImGearRGBQuad Structure
Fill color of the mark.
Border
ImGearARTBorder Class
Border of the mark.
BorderShading
Bool
Border shading of the mark.
Opacity
Int
Opacity of the mark.
FontName
String
The name of the font.
FontSize
float
The size of the font in points.
FontStyle
System.Drawing.FontStyle
The style of the font.
Pin
ImGearARTPin Class
ImGearARTPin object that specifies mark's pin icon attributes.
Callout
ImGearARTCallout Class
ImGearARTCallout Class object that specifies mark's callout attributes.

Return Value:

The new instance of ImGearARTText Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure

ImGearARTTextType Enumeration

ImGearARTBorder Class

ImGearARTPin Class

ImGearARTCallout Class


ImGearARTText Properties

The ImGearARTText Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
AlignmentH Property
Specifies text horizontal alignment.
AlignmentV Property
Specifies text vertical alignment.
Border Property
Border of the mark.
BorderShading Property
Border shading of the mark.
Callout Property
ImGearARTCallout Class object that specifies mark's callout attributes.
FillColor Property
Fill color of the mark.
FontName Property
Font name of the mark's text.
FontSize Property
Font size of the mark's text.
FontStyle Property
Font style of the mark's text.
FontDisablePPM Property
Option to enable/disable PPM in font size calculations.
Height Property
Height of the mark's rectangle.
Opacity Property
Opacity of the mark.
Orientation Property
Text orientation.
Pin Property
ImGearARTPin object that specifies mark's pin icon attributes.
Text Property
Text string.
TextColor Property
Color of the text.
TextType Property
Type of the text.
Width Property
Width of the mark's rectangle.
X Property
X coordinate of the top-left point of the mark's rectangle.
Y Property
Y coordinate of the top-left point of the mark's rectangle.


AlignmentH Property

32-bit
64-bit
CF
P
P

Description:

Specifies text horizontal alignment, ImGearAlignmentHModes Enumeration.LEFT by default

Declaration:

public ImageGear.Display.ImGearAlignmentHModes AlignmentH { set; get; }

Value:

ImGearAlignmentHModes Enumeration value.

Default value:

ImGearAlignmentHModes Enumeration.LEFT

See Also:

ImGearAlignmentHModes Enumeration


AlignmentV Property

32-bit
64-bit
CF
P
P

Description:

Specifies text vertical alignment, ImGearAlignmentVModes Enumeration.TOP by default

Declaration:

public ImageGear.Display.ImGearAlignmentVModes AlignmentV { set; get; }

Value:

ImGearAlignmentVModes Enumeration value.

Default value:

ImGearAlignmentVModes Enumeration.TOP

See Also:

ImGearAlignmentVModes Enumeration


Border Property

32-bit
64-bit
CF
P
P

Description:

The border of the mark's rectangle.

Declaration:

public ImageGear.ART.ImGearARTBorder Border { get, set }

Value:

ImGearARTBorder Class object.

Default value:

N/A

See Also:

ImGearARTBorder Class


BorderShading Property

32-bit
64-bit
CF
P
P

Description:

Determines whether the border is shaded or not.

Declaration:

public bool BorderShading { get, set }

Value:

True, False.

Default value:

N/A


Callout Property

32-bit
64-bit
CF
P
P

Description:

This property represents ImGearARTCallout Class object that specifies mark's callout attributes.

Declaration:

public ImageGear.ART.ImGearARTCallout Callout { get, set }

Value:

ImGearARTCallout Class object.

Default value:

N/A

See Also:

ImGearARTCallout Class


FontName Property

32-bit
64-bit
CF
P
P

Description:

The font name of the mark text.

Declaration:

public string FontName { get, set }

Value:

String name.

Default value:

N/A


FontSize Property

32-bit
64-bit
CF
P
P

Description:

The font size, in points, of the mark text.

Declaration:

public float FontSize { get, set }

Value:

Any positive value.

Default value:

N/A


FontStyle Property

32-bit
64-bit
CF
P
P

Description:

The font style of the mark text.

Declaration:

public System.Drawing.FontStyle FontStyle { get, set }

Value:

FontStyle

Default value:

N/A


Opacity Property

32-bit
64-bit
CF
P
P

Description:

The opacity of the mark.

Declaration:

public int Opacity { get, set }

Value:

Integer value from 0 (transparent) to 255 (opaque).

Default value:

255


Orientation Property

32-bit
64-bit
CF
P
P

Description:

Text orientation.

Declaration:

public ImageGear.Core.ImGearOrientationModes Orientation { get, set }

Value:

ImGearOrientationModes Enumeration value.

Default value:

TOP_LEFT

See Also:

ImGearOrientationModes Enumeration


Pin Property

32-bit
64-bit
CF
P
P

Description:

ImGearARTPin object that specifies mark's pin icon attributes.

Declaration:

public ImageGear.ART.ImGearARTPin Pin { get, set }

Value:

ImGearARTPin Class object.

Default value:

N/A

See Also:

ImGearARTPin Class


Text Property

32-bit
64-bit
CF
P
P

Description:

The text of the mark.

Declaration:

public string Text { get, set }

Value:

Text string.

Default value:

N/A


TextColor Property

32-bit
64-bit
CF
P
P

Description:

The color of the mark text.

Declaration:

public ImageGear.Core.IImGearRGBQuad TextColor { get, set }

Value:

ImGearRGBQuad Structure object interface.

Default value:

N/A

See Also:

ImGearRGBQuad Structure


TextType Property

32-bit
64-bit
CF
P
P

Description:

The text type.

Declaration:

public ImageGear.ART. TextType { get, set }

Value:

ImGearARTTextType Enumeration value.

Default value:

0

See Also:

ImGearARTTextType Enumeration


ImGearARTText Methods

The ImGearARTText Class of the ImageGear.ART Namespace has the following methods:

Methods
Name
Description
BeginEdit Method
Begins text editing process.
EndEdit Method
Ends text editing process.


BeginEdit Method

32-bit
64-bit
CF
P
P

Description:

Begins the text editing process.

Declaration:

public bool BeginEdit ( ImageGear.Display.IImGearScrollableView PageView ,
ImageGear.Display.ImGearPageDisplay PageDisplay )

Parameters:

Name
Type
Description
PageView
IImGearScrollableView Interface
PageView control that contains text mark.
PageDisplay
ImGearPageDisplay Class
PageDisplay of the PageView control.

Return Value:

True if the editing has begun, False - otherwise.

See Also:

ImGearPageDisplay Class

IImGearScrollableView Interface


ImGearARTTextCallout Class

32-bit
64-bit
CF
P
P

Description:

Legacy ART "Callout Text" mark.

Declaration:

public class ImGearARTTextCallout : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTTextCallout Constructor
Creates a new instance of ImGearARTTextCallout Class object.
ImGearARTTextCallout Constructor
Creates a new instance of ImGearARTTextCallout Class object.

Properties
Name
Description
Callout Property
ImGearARTCallout object that specifies mark's callout attributes.
FontDisablePPM Property
Option to enable/disable PPM in font size calculations.
FontName Property
Font name of the text.
FontSize Property
Font size of the text.
FontStyle Property
Font style of the text.
Height Property
Height of the mark rectangle.
Text Property
Text string.
TextColor Property
Color of the text.
Width Property
Width of the mark rectangle.
X Property
The X coordinate of top-left point of the mark's rectangle.
Y Property
The Y coordinate of top-left point of the mark's rectangle.

Methods
Name
Description
BeginEdit Method
Begins text editing process.
EndEdit Method
Ends text editing process.

Sample Code:

C#
// Setup color for the callout border.
ImGearRGBQuad igRGBQuadBorderCallout = new ImGearRGBQuad(0, 255, 255);
// Setup a border with a width of 3 and a solid pattern.
ImGearARTBorder igARTBorderCallout = new ImGearARTBorder(
    igRGBQuadBorderCallout, 3, ImGearARTPenStyle.SOLID
);
// Create a callout to be used for the annotation.
ImGearARTCallout igARTCallout = new ImGearARTCallout(
    ImGearARTCalloutType.LINE, igPage.DIB.Width / 2,
    igPage.DIB.Height / 2, igARTBorderCallout
);
// Setup rectangle for the text mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 200, 20);
// Setup color for the text.
ImGearRGBQuad igRGBQuadText = new ImGearRGBQuad(255, 0, 255);
// Create the text callout annotation.
ImGearARTTextCallout igARTTextCallout = new ImGearARTTextCallout(
    igRectangle, "ImGearARTText annotation", igRGBQuadText,
    "Arial", (float)14.0, FontStyle.Regular, igARTCallout
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTTextCallout, ImGearARTCoordinatesType.IMAGE_COORD);

VB .NET
' Setup color for the callout border.
Dim igRGBQuadBorderCallout As New ImGearRGBQuad(0, 255, 255)
' Setup a border with a width of 3 and a solid pattern.
Dim igARTBorderCallout As New ImGearARTBorder(igRGBQuadBorderCallout, 3, ImGearARTPenStyle.SOLID)
' Create a callout to be used for the annotation.
Dim igARTCallout As New ImGearARTCallout( _
 ImGearARTCalloutType.LINE, igPage.DIB.Width / 2, _
 igPage.DIB.Height / 2, igARTBorderCallout)
' Setup rectangle for the text mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 200, 20)
' Setup color for the text.
Dim igRGBQuadText As New ImGearRGBQuad(255, 0, 255)
' Create the text callout annotation.
Dim igARTTextCallout As New ImGearARTTextCallout( _
 igRectangle, "ImGearARTText annotation", igRGBQuadText, _
 "Arial", CSng(14), FontStyle.Regular, igARTCallout)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTTextCallout, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTTextCallout Constructors

The ImGearARTTextCallout Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTTextCallout Constructor
Creates a new instance of ImGearARTTextCallout Class object.
ImGearARTTextCallout Constructor
Creates a new instance of ImGearARTTextCallout Class object.


ImGearARTTextCallout Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTTextCallout Class object.

Declaration:

public ImGearARTTextCallout ( ImageGear.Core.IImGearRectangle Rect , String Text ,
ImageGear.Core.IImGearRGBQuad TextColor , ImageGear.ART.ImGearARTCallout Callout )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Handle of IImGearRectangle.
Text
String
Text string.
TextColor
ImGearRGBQuad Structure
Color of the text.
Callout
ImGearARTCallout Class
ImGearARTCallout object that specifies mark's callout attributes.

Return Value:

The new instance of ImGearARTTextCallout Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure

ImGearARTCallout Class


ImGearARTTextCallout Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTTextCallout Class object.

Declaration:

public ImGearARTTextCallout ( ImageGear.Core.IImGearRectangle Rect , String Text ,
ImageGear.Core.IImGearRGBQuad TextColor , String FontName , float FontSize ,
System.Drawing.FontStyle FontStyle , ImageGear.ART.ImGearARTCallout Callout )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Handle of IImGearRectangle.
Text
String
Text string.
TextColor
ImGearRGBQuad Structure
Color of the text.
FontName
String
The name of the font.
FontSize
float
The size of the font in points.
FontStyle
System.Drawing.FontStyle
The style of the font.
Callout
ImGearARTCallout Class
ImGearARTCallout object that specifies mark's callout attributes.

Return Value:

The new instance of ImGearARTTextCallout Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure

ImGearARTCallout Class


ImGearARTTextCallout Properties

The ImGearARTTextCallout Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
Callout Property
ImGearARTCallout object that specifies mark's callout attributes.
FontDisablePPM Property
Option to enable/disable PPM in font size calculations.
FontName Property
Font name of the text.
FontSize Property
Font size of the text.
FontStyle Property
Font style of the text.
Height Property
Height of the mark rectangle.
Text Property
Text string.
TextColor Property
Color of the text.
Width Property
Width of the mark rectangle.
X Property
The X coordinate of top-left point of the mark's rectangle.
Y Property
The Y coordinate of top-left point of the mark's rectangle.


Callout Property

32-bit
64-bit
CF
P
P

Description:

ImGearARTCallout Class object that specifies mark's callout attributes.

Declaration:

public ImageGear.ART.ImGearARTCallout Callout { get, set }

Value:

Handle of ImGearARTCallout Class object.

Default value:

N/A


FontDisablePPM Property

32-bit
64-bit
CF
P
P

Description:

Option to enable/disable PPM in font size calculations.

Declaration:

public bool FontDisablePPM { get, set }

Value:

True, False

Default value:

False


FontName Property

32-bit
64-bit
CF
P
P

Description:

Font name of the text.

Declaration:

public string FontName { get, set }

Value:

Any string Font name.

Default value:

N/A


FontSize Property

32-bit
64-bit
CF
P
P

Description:

Font size of the text.

Declaration:

public float FontSize { get, set }

Value:

Integer value.

Default value:

N/A


FontStyle Property

32-bit
64-bit
CF
P
P

Description:

Font style of the text.

Declaration:

public System.Drawing.FontStyle FontStyle { get, set }

Value:

System font style.

Default value:

N/A


Height Property

32-bit
64-bit
CF
P
P

Description:

Height of the mark rectangle.

Declaration:

public int Height { get, set }

Value:

Integer value.

Default value:

1


Text Property

32-bit
64-bit
CF
P
P

Description:

Text string.

Declaration:

public string Text { get, set }

Value:

Text string.

Default value:

N/A


TextColor Property

32-bit
64-bit
CF
P
P

Description:

Color of the text.

Declaration:

public ImageGear.Core.IImGearRGBQuad TextColor { get, set }

Value:

Handle of ImGearRGBQuad Structure object interface.

Default value:

N/A

See Also:

ImGearRGBQuad Structure


Width Property

32-bit
64-bit
CF
P
P

Description:

Width of the mark rectangle.

Declaration:

public int Width { get, set }

Value:

Integer value.

Default value:

1


X Property

32-bit
64-bit
CF
P
P

Description:

The X coordinate of the top-left point of the mark's rectangle.

Declaration:

public int X { get, set }

Value:

Integer value.

Default value:

N/A


Y Property

32-bit
64-bit
CF
P
P

Description:

The Y coordinate of the top-left point of the mark's rectangle.

Declaration:

public int Y { get, set }

Value:

Integer value.

Default value:

N/A


ImGearARTTextCallout Methods

The ImGearARTTextCallout Class of the ImageGear.ART Namespace has the following methods:

Methods
Name
Description
BeginEdit Method
Begins text editing process.
EndEdit Method
Ends text editing process.


BeginEdit Method

32-bit
64-bit
CF
P
P

Description:

Begins text editing process.

Declaration:

public System.Boolean BeginEdit ( ImageGear.Display.IImGearScrollableView PageView ,
ImageGear.Display.ImGearPageDisplay PageDisplay )

Parameters:

Name
Type
Description
PageView
IImGearScrollableView Interface
PageView control that contains text mark.
PageDisplay
ImGearPageDisplay Class
PageDisplay of the PageView control.

Return Value:

True - process begins, False - otherwise.

See Also:

ImGearPageDisplay Class

IImGearScrollableView Interface


ImGearARTTextFromFile Class

32-bit
64-bit
CF
P
P

Description:

Legacy ART Text From File mark.

Declaration:

public class ImGearARTTextFromFile : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTTextFromFile Constructor
Creates a new instance of ImGearARTTextFromFile object.
ImGearARTTextFromFile Constructor
Creates a new instance of ImGearARTTextFromFile object.

Properties
Name
Description
FontName Property
Font name of the text.
FontSize Property
Font size of the text.
FontStyle Property
Font style of the text.
FontDisablePPM Property
Option to enable/disable PPM in font size calculations.
Height Property
Height of the mark rectangle.
Text Property
Path to the text file.
TextColor Property
Color of the text.
Width Property
Width of the mark rectangle.
X Property
The X coordinate of the top-left point of the mark's rectangle.
Y Property
The Y coordinate of the top-left point of the mark's rectangle.

Methods
Name
Description
BeginEdit Method
Begins text editing process.
EndEdit Method
Ends text editing process.

Sample Code:

C#
// Setup rectangle for the text mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 200, 20);
// Setup color for the text.
ImGearRGBQuad igRGBQuadText = new ImGearRGBQuad(255, 0, 255);
// Create the text annotation with the contents of test.txt.
ImGearARTTextFromFile igARTTextFromFile = new ImGearARTTextFromFile(
    igRectangle, "test.txt", igRGBQuadText,
    "Arial", (float)14.0, FontStyle.Regular
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTTextFromFile, ImGearARTCoordinatesType.IMAGE_COORD);

VB .NET
' Setup rectangle for the text mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 200, 20)
' Setup color for the text.
Dim igRGBQuadText As New ImGearRGBQuad(255, 0, 255)
' Create the text annotation with the contents of test.txt.
Dim igARTTextFromFile As New ImGearARTTextFromFile( _
 igRectangle, "test.txt", igRGBQuadText, _
 "Arial", CSng(14), FontStyle.Regular)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTTextFromFile, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTTextFromFile Constructors

The ImGearARTTextFromFile Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTTextFromFile Constructor
Creates a new instance of ImGearARTTextFromFile object.
ImGearARTTextFromFile Constructor
Creates a new instance of ImGearARTTextFromFile object.


ImGearARTTextFromFile Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTTextFromFile Class object.

Declaration:

public ImGearARTTextFromFile ( ImageGear.Core.IImGearRectangle Rect , String Text ,
ImageGear.Core.IImGearRGBQuad TextColor )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Mark's rectangle.
Text
String
Path to the file to load text from.
TextColor
ImGearRGBQuad Structure
Color of the mark's text.

Return Value:

The new instance of ImGearARTTextFromFile Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure


ImGearARTTextFromFile Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTTextFromFile Class object.

Declaration:

public ImGearARTTextFromFile ( ImageGear.Core.IImGearRectangle Rect , String Text ,
ImageGear.Core.IImGearRGBQuad TextColor , String FontName , float FontSize ,
System.Drawing.FontStyle FontStyle )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Mark's rectangle.
Text
String
Path to the file to load text from.
TextColor
ImGearRGBQuad Structure
Color of the mark's text.
FontName
String
The name of the font.
FontSize
float
The size of the font in points.
FontStyle
System.Drawing.FontStyle
The style of the font.

Return Value:

The new instance of ImGearARTTextFromFile Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure


ImGearARTTextFromFile Properties

The ImGearARTTextFromFile Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
FontName Property
Font name of the text.
FontSize Property
Font size of the text.
FontStyle Property
Font style of the text.
FontDisablePPM Property
Option to enable/disable PPM in font size calculations.
Height Property
Height of the mark rectangle.
Text Property
Path to the text file.
TextColor Property
Color of the text.
Width Property
Width of the mark rectangle.
X Property
The X coordinate of the top-left point of the mark's rectangle.
Y Property
The Y coordinate of the top-left point of the mark's rectangle.


FontName Property

32-bit
64-bit
CF
P
P

Description:

The font name of the mark's text.

Declaration:

public string FontName { get, set }

Value:

String name.

Default value:

N/A


FontStyle Property

32-bit
64-bit
CF
P
P

Description:

The font style of the mark's text.

Declaration:

public System.Drawing.FontStyle FontStyle { get, set }

Value:

FontStyle

Default value:

N/A


Text Property

32-bit
64-bit
CF
P
P

Description:

Path to the text file.

Declaration:

public string Text { get, set }

Value:

Text string.

Default value:

N/A


ImGearARTTextFromFile Methods

The ImGearARTTextFromFile Class of the ImageGear.ART Namespace has the following methods:

Methods
Name
Description
BeginEdit Method
Begins text editing process.
EndEdit Method
Ends text editing process.


BeginEdit Method

32-bit
64-bit
CF
P
P

Description:

Begins the text editing process.

Declaration:

public System.Boolean BeginEdit ( ImageGear.Display.IImGearScrollableView PageView ,
ImageGear.Display.ImGearPageDisplay PageDisplay )

Parameters:

Name
Type
Description
PageView
IImGearScrollableView Interface
PageView control that contains text mark.
PageDisplay
ImGearPageDisplay Class
PageDisplay of the PageView control.

Return Value:

True if the editing has begun, False - otherwise.

See Also:

ImGearPageDisplay Class

IImGearScrollableView Interface


ImGearARTTextStamp Class

32-bit
64-bit
CF
P
P

Description:

Legacy ART Text Stamp mark.

Declaration:

public class ImGearARTTextStamp : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTTextStamp Constructor
Creates a new instance of ImGearARTTextStamp object.
ImGearARTTextStamp Constructor
Creates a new instance of ImGearARTTextStamp object.

Properties
Name
Description
FontName Property
Font name of the text.
FontSize Property
Font size of the text.
FontStyle Property
Font style of the text.
FontDisablePPM Property
Option to enable/disable PPM in font size calculations.
Height Property
Height of the mark rectangle.
Text Property
Text string.
TextColor Property
Color of the text.
Width Property
Width of the mark rectangle.
X Property
The X coordinate of the top-left point of the mark's rectangle.
Y Property
The Y coordinate of the top-left point of the mark's rectangle.

Methods
Name
Description
BeginEdit Method
Begins text editing process.
EndEdit Method
Ends text editing process.

Sample Code:

C#
// Setup rectangle for the text mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 200, 20);
// Setup color for the text.
ImGearRGBQuad igRGBQuadText = new ImGearRGBQuad(255, 0, 255);
// Create the text stamp annotation
ImGearARTTextStamp igARTTextStamp = new ImGearARTTextStamp(
    igRectangle, "ImGearARTTextStamp test", igRGBQuadText,
    "Arial", (float)14.0, FontStyle.Regular
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTTextStamp, ImGearARTCoordinatesType.IMAGE_COORD);

VB .NET
' Setup rectangle for the text mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 200, 20)
' Setup color for the text.
Dim igRGBQuadText As New ImGearRGBQuad(255, 0, 255)
' Create the text stamp annotation
Dim igARTTextStamp As New ImGearARTTextStamp( _
 igRectangle, "ImGearARTTextStamp test", igRGBQuadText, _
 "Arial", CSng(14), FontStyle.Regular)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTTextStamp, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTTextStamp Constructors

The ImGearARTTextStamp Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTTextStamp Constructor
Creates a new instance of ImGearARTTextStamp object.
ImGearARTTextStamp Constructor
Creates a new instance of ImGearARTTextStamp object.


ImGearARTTextStamp Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTTextStamp Class object.

Declaration:

public ImGearARTTextStamp ( ImageGear.Core.IImGearRectangle Rect , String Text ,
ImageGear.Core.IImGearRGBQuad TextColor )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Mark's rectangle.
Text
String
Text of the mark.
TextColor
ImGearRGBQuad Structure
Color of the mark's text.

Return Value:

The new instance of ImGearARTTextStamp Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure


ImGearARTTextStamp Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTTextStamp Class object.

Declaration:

public ImGearARTTextStamp ( ImageGear.Core.IImGearRectangle Rect , String Text ,
ImageGear.Core.IImGearRGBQuad TextColor , String FontName , float FontSize ,
System.Drawing.FontStyle FontStyle )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Mark's rectangle.
Text
String
Text of the mark.
TextColor
ImGearRGBQuad Structure
Color of the mark's text.
FontName
String
The name of the font.
FontSize
float
The size of the font in points.
FontStyle
System.Drawing.FontStyle
The style of the font.

Return Value:

The new instance of ImGearARTTextStamp Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure


ImGearARTTextStamp Properties

The ImGearARTTextStamp Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
FontName Property
Font name of the text.
FontSize Property
Font size of the text.
FontStyle Property
Font style of the text.
FontDisablePPM Property
Option to enable/disable PPM in font size calculations.
Height Property
Height of the mark rectangle.
Text Property
Text string.
TextColor Property
Color of the text.
Width Property
Width of the mark rectangle.
X Property
The X coordinate of the top-left point of the mark's rectangle.
Y Property
The Y coordinate of the top-left point of the mark's rectangle.


Text Property

32-bit
64-bit
CF
P
P

Description:

The text string of the mark.

Declaration:

public string Text { get, set }

Value:

Text string.

Default value:

N/A


ImGearARTTextStamp Methods

The ImGearARTTextStamp Class of the ImageGear.ART Namespace has the following methods:

Methods
Name
Description
BeginEdit Method
Begins text editing process.
EndEdit Method
Ends text editing process.


ImGearARTTypedText Class

32-bit
64-bit
CF
P
P

Description:

Legacy ART Typed Text mark.

Declaration:

public class ImGearARTTypedText : ImageGear.ART.ImGearARTMark

Members:

Constructors
Name
Description
ImGearARTTypedText Constructor
Creates a new instance of ImGearARTTypedText object.
ImGearARTTypedText Constructor
Creates a new instance of ImGearARTTypedText object.

Properties
Name
Description
FontName Property
Font name of the text.
FontSize Property
Font size of the text.
FontStyle Property
Font style of the text.
FontDisablePPM Property
Option to enable/disable PPM in font size calculations.
Height Property
Height of the mark rectangle.
Text Property
Text string.
TextColor Property
Color of the text.
Width Property
Width of the mark rectangle.
X Property
The X coordinate of the top-left point of the mark's rectangle.
Y Property
The Y coordinate of the top-left point of the mark's rectangle.

Methods
Name
Description
BeginEdit Method
Begins text editing process.
EndEdit Method
Ends text editing process.

Sample Code:

C#
// Setup rectangle for the text mark's location.
ImGearRectangle igRectangle = new ImGearRectangle(10, 10, 200, 20);
// Setup color for the text.
ImGearRGBQuad igRGBQuadText = new ImGearRGBQuad(0, 0, 255);
// Create the typed text annotation
ImGearARTTypedText igARTTypedText = new ImGearARTTypedText(
    igRectangle, "ImGearARTTypedText test", igRGBQuadText,
    "Arial", (float)14.0, FontStyle.Regular
);
// Add the annotation to the ARTPage.
igARTPage.AddMark(igARTTypedText, ImGearARTCoordinatesType.IMAGE_COORD);

VB .NET
' Setup rectangle for the text mark's location.
Dim igRectangle As New ImGearRectangle(10, 10, 200, 20)
' Setup color for the text.
Dim igRGBQuadText As New ImGearRGBQuad(0, 0, 255)
' Create the typed text annotation
Dim igARTTypedText As New ImGearARTTypedText( _
 igRectangle, "ImGearARTTypedText test", igRGBQuadText, _
 "Arial", CSng(14), FontStyle.Regular)
' Add the annotation to the ARTPage.
igARTPage.AddMark(igARTTypedText, ImGearARTCoordinatesType.IMAGE_COORD)


ImGearARTTypedText Constructors

The ImGearARTTypedText Class of the ImageGear.ART Namespace has the following constructors:

Constructors
Name
Description
ImGearARTTypedText Constructor
Creates a new instance of ImGearARTTypedText object.
ImGearARTTypedText Constructor
Creates a new instance of ImGearARTTypedText object.


ImGearARTTypedText Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTTypedText Class object.

Declaration:

public ImGearARTTypedText ( ImageGear.Core.IImGearRectangle Rect , String Text ,
ImageGear.Core.IImGearRGBQuad TextColor )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Mark's rectangle.
Text
String
Text of the mark.
TextColor
ImGearRGBQuad Structure
Color of the mark's text.

Return Value:

The new instance of ImGearARTTypedText Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure


ImGearARTTypedText Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTTypedText Class object.

Declaration:

public ImGearARTTypedText ( ImageGear.Core.IImGearRectangle Rect , String Text ,
ImageGear.Core.IImGearRGBQuad TextColor , String FontName , float FontSize ,
System.Drawing.FontStyle FontStyle )

Parameters:

Name
Type
Description
Rect
ImGearRectangle Structure
Mark's rectangle.
Text
String
Text of the mark.
TextColor
ImGearRGBQuad Structure
Color of the mark's text.
FontName
String
The name of the font.
FontSize
float
The size of the font in points.
FontStyle
System.Drawing.FontStyle
The style of the font.

Return Value:

The new instance of ImGearARTTypedText Class object.

See Also:

ImGearRectangle Structure

ImGearRGBQuad Structure


ImGearARTTypedText Properties

The ImGearARTTypedText Class of the ImageGear.ART Namespace has the following properties:

Properties
Name
Description
FontName Property
Font name of the text.
FontSize Property
Font size of the text.
FontStyle Property
Font style of the text.
FontDisablePPM Property
Option to enable/disable PPM in font size calculations.
Height Property
Height of the mark rectangle.
Text Property
Text string.
TextColor Property
Color of the text.
Width Property
Width of the mark rectangle.
X Property
The X coordinate of the top-left point of the mark's rectangle.
Y Property
The Y coordinate of the top-left point of the mark's rectangle.


ImGearARTTypedText Methods

The ImGearARTTypedText Class of the ImageGear.ART Namespace has the following methods:

Methods
Name
Description
BeginEdit Method
Begins text editing process.
EndEdit Method
Ends text editing process.


ImageGear.ART Namespace Interfaces

The ImageGear.ART Namespace has the following interfaces:

Interfaces:
Name
Description
IImGearARTMarkIDEnumerator Interface
Mark ID enumerator interface is used for ImGearARTPage Class and ImGearARTGroup Class to iterate through the collection of marks by using foreach statement.
IImGearARTMarkIDEnumerable Interface
Mark ID enumerable interface is used for ImGearARTPage Class and ImGearARTGroup Class to iterate through the collection of marks by using foreach statement.


IImGearARTMarkIDEnumerator Interface

32-bit
64-bit
CF
P
P

Description:

Mark ID enumerator interface is used for ImGearARTPage Class and ImGearARTGroup Class to iterate through the collection of marks by using foreach statement.

Declaration:

public interface IImGearARTMarkIDEnumerator : IEnumerator

See Also:

IImGearARTMarkIDEnumerable Interface


IImGearARTMarkIDEnumerable Interface

32-bit
64-bit
CF
P
P

Description:

Mark ID enumerable interface is used for ImGearARTPage Class and ImGearARTGroup Class to iterate through the collection of marks by using foreach statement.

Declaration:

public interface IImGearARTMarkIDEnumerable : IEnumerable

Example:

foreach (int id in (IImGearARTMarkIDEnumerable)artGUI.Page)
{
    ImGearARTMark mark = artGUI.Page.MarkGet(id);
}
foreach (int id in (IImGearARTMarkIDEnumerable)artGUI.Page.Groups[0])
{
    ImGearARTMark mark = artGUI.Page.MarkGet(id);
}

See Also:

IImGearARTMarkIDEnumerator Interface


ImageGear.ART Namespace Enumerations

The ImageGear.ART Namespace has the following enumeration members:

Enumerations:
Name
Description
ImGearARTAccess Enumeration
Specifies group access.
ImGearARTBurnInOptions Enumeration
Specifies BurnIn options.
ImGearARTButtonState Enumeration
Specifies Button mark state.
ImGearARTCalloutType Enumeration
Specifies ART Callout types.
ImGearARTCoordinatesType Enumeration
Specifies mark's coordinates types.
ImGearARTLineHeadType Enumeration
Specifies line's head types.
ImGearARTMarkHitTest Enumeration
Specifies HitTest results.
ImGearARTMarkType Enumeration
Specifies mark types.
ImGearARTPenStyle Enumeration
Specifies pen styles.
ImGearARTPinAlignment Enumeration
Specifies pin alignment modes.
ImGearARTSaveType Enumeration
Specifies ART save types.
ImGearARTTextType Enumeration
Specifies Text mark types.


ImGearARTAccess Enumeration

32-bit
64-bit
CF
P
P

Description:

ART group access level.

Declaration:

public enum ImGearARTAccess

Values:

Name
Value
Description
LOCKED
Access denied.
UNLOCKED
Access granted.


ImGearARTBurnInOptions Enumeration

32-bit
64-bit
CF
P
P

Description:

BurnIn options.

Declaration:

public enum ImGearARTBurnInOptions

Values:

Name
Value
Description
ALL
Burns in all annotation marks.
DELETE_MARKS
Deletes affected marks after burning them in.
VISIBLE
Burns in all visible marks.
SELECTED
Burns in all selected marks.


ImGearARTButtonState Enumeration

32-bit
64-bit
CF
P
P

Description:

ART Button mark state options.

Declaration:

public enum ImGearARTButtonState

Values:

Name
Value
Description
NORMAL
Button is unpressed.
PRESSED
Button is pressed.


ImGearARTCalloutType Enumeration

32-bit
64-bit
CF
P
P

Description:

Specifies the type of callout.

Declaration:

public enum ImGearARTCalloutType

Values:

Name
Value
Description
LINE
Line type of callout.
TRIANGLE
Triangle type of callout.


ImGearARTCoordinatesType Enumeration

32-bit
64-bit
CF
P
P

Description:

Coordinate systems that can be used to specify mark's coordinates.

Declaration:

public enum ImGearARTCoordinatesType

Values:

Name
Value
Description
IMAGE_COORD
Specifies image coordinate system.
DEVICE_COORD
Specifies device coordinate system.


ImGearARTLineHeadType Enumeration

32-bit
64-bit
CF
P
P

Description:

Arrow types of the line's heads.

Declaration:

public enum ImGearARTLineHeadType

Values:

Name
Value
Description
POINTER
Regular pointer head.
SOLID
Solid head.
OPEN
Open pointer head.
POINTER_SOLID
Solid pointer head.
NONE
No head.


ImGearARTMarkHitTest Enumeration

32-bit
64-bit
CF
P
P

Description:

HitTest results.

Declaration:

public enum ImGearARTMarkHitTest

Values:

Name
Value
Description
OUTSIDE
Not on mark.
INBOUNDARY
Somewhere within mark boundary, but not on mark pixels.
ONMARK
Selected point belongs to mark.


ImGearARTMarkType Enumeration

32-bit
64-bit
CF
P
P

Description:

Types of ART annotation marks.

Declaration:

public enum ImGearARTMarkType

Values:

Name
Value
Description
SELECT
Mark selector.
TEXT
ART 3.0 Text mark.
LINE
ART 3.0/2.0 Line mark.
RECTANGLE
ART 3.0 Rectangle mark.
ELLIPSE
ART 3.0 Ellipse mark.
POLYGON
ART 3.0 Polygon mark.
POLYLINE
ART 3.0/2.0 Polyline mark.
AUDIO
ART 3.0/2.0 Audio mark.
IMAGE
ART 3.0 Image mark.
RULER
ART 3.0/2.0 Ruler mark.
PROTRACTOR
ART 3.0/2.0 Protractor mark.
ENCRYPTION
ART 3.0/2.0 Encryption mark.
BUTTON
ART 3.0/2.0 Button mark.
HOTSPOT
ART 3.0/2.0 HotSpot mark.
RICH_TEXT
ART 3.0/2.0 Rich Text mark.
POINT
Point mark.
CURVE
Curve mark.
CALLOUT
Callout mark.
FREEHAND_LINE
Legacy ART 2.0 Freehand Line mark.
ARROW
Legacy ART 2.0 Arrow mark.
FILLED_RECTANGLE
Legacy ART 2.0 Filled Rectangle mark.
HOLLOW_RECTANGLE
Legacy ART 2.0 Hollow Rectangle mark.
FILLED_ELLIPSE
Legacy ART 2.0 Filled Ellipse mark.
HOLLOW_ELLIPSE
Legacy ART 2.0 Hollow Ellipse mark.
FILLED_POLYGON
Legacy ART 2.0 Filled Polygon mark.
HOLLOW_POLYGON
Legacy ART 2.0 Hollow Polygon mark.
REDACTION
Legacy ART 2.0 Redaction mark.
HIGHLIGHTER
Legacy ART 2.0 Highlighter mark.
TYPED_TEXT
Legacy ART 2.0 Typed Text mark.
TEXT_STAMP
Legacy ART 2.0 Text Stamp mark.
ATTACH_A_NOTE
Legacy ART 2.0 Attach-A-Note mark.
TEXT_FROM_FILE
Legacy ART 2.0 Text From File mark.
IMAGE_EMBEDDED
Legacy ART 2.0 Embedded Image mark.
IMAGE_REFERENCE
Legacy ART 2.0 Image Reference mark.
PIN_UP_TEXT
Legacy ART 2.0 Pin-Up Text mark.


ImGearARTPenStyle Enumeration

32-bit
64-bit
CF
P
P

Description:

ART pen styles.

Declaration:

public enum ImGearARTPenStyle

Values:

Name
Value
Description
SOLID
Specifies a solid line.
DASH
Specifies a line consisting of dashes.
DOT
Specifies a line consisting of dots.
DASHDOT
Specifies a line consisting of a repeating pattern of dash-dot.
DASHDOTDOT
Specifies a line consisting of a repeating pattern of dash-dot-dot.
PDFDASH1
Specifies dash pattern compatible with Adobe Acrobat's "Dashed 1" style.
PDFDASH2
Specifies dash pattern compatible with Adobe Acrobat's "Dashed 2" style.
PDFDASH3
Specifies dash pattern compatible with Adobe Acrobat's "Dashed 3" style.
PDFDASH4
Specifies dash pattern compatible with Adobe Acrobat's "Dashed 4" style.
PDFDASH5
Specifies dash pattern compatible with Adobe Acrobat's "Dashed 5" style.
PDFDASH6
Specifies dash pattern compatible with Adobe Acrobat's "Dashed 6" style.


ImGearARTPinAlignment Enumeration

32-bit
64-bit
CF
P
P

Description:

Alignment of the pin icon.

Declaration:

public enum ImGearARTPinAlignment

Values:

Name
Value
Description
LEFT_TOP
Left Top.
LEFT_BOTTOM
Left Bottom.
RIGHT_TOP
Right Top.
RIGHT_BOTTON
Right Bottom.


ImGearARTSaveType Enumeration

32-bit
64-bit
CF
P
P

Description:

ART saving types.

Declaration:

public enum ImGearARTSaveType

Values:

Name
Value
Description
XML
XML storage format.
LEGACY
Legacy ART 2.0 storage format.


ImGearARTTextType Enumeration

32-bit
64-bit
CF
P
P

Description:

Types of Text mark.

Declaration:

public enum ImGearARTTextType

Values:

Name
Value
Description
DIRECT_TEXT
Text is stored directly in the mark.
FILE_NAME
Text is stored in the file specified by mark's "Text" property.


ImageGear.ART.Forms Namespace

ImageGear.ART.Forms Namespace

32-bit
64-bit
CF
P
P

Description:

The ImageGear.ART.Forms namespace allows you to add redlining and annotation capabilities to any application built with ImageGear. It provides ART GUI functionality that can simplify development of ImageGear based applications. This functionality is implemented in WinForms assembly, using only public ImageGear API, with source code provided to enable modifications.

Declaration:

namespace ImageGear.ART.Forms

Members:

Classes:
Name
Description
ImGearARTPropertyDialog Class
GUI dialog class for accessing ART annotations properties.
ImGearARTForms Class
Provides properties and methods for using ART forms functionality.
ImGearARTRTFToolBar Class
Toolbar for editing RTF text and style.
ImGearARTToolBar Class
Toolbar for creating, selecting and editing ART annotation.

Enumerations:
Name
Description
ImGearARTModes Enumeration
ART modes.
ImGearARTModifyReason Enumeration
Reasons for NotifyModifyMark delegate to be called.
ImGearARTToolBarModes Enumeration
ART toolbar modes: legacy 2.0 marks and 3.0 marks.

See Also:

ImageGear.ART Namespace

Using ImageGear.ART Namespace


ImageGear.ART.Forms Namespace Classes

The ImageGear.ART.Forms Namespace has the following class members:

Classes:
Name
Description
ImGearARTPropertyDialog Class
GUI dialog class for accessing ART annotations properties.
ImGearARTForms Class
Provides properties and methods for using ART forms functionality.
ImGearARTRTFToolBar Class
Toolbar for editing RTF text and style.
ImGearARTToolBar Class
Toolbar for creating, selecting and editing ART annotation.


ImGearARTPropertyDialog Class

32-bit
64-bit
CF
P
P

Description:

This class is used for accessing ART annotations properties.

Declaration:

public class ImGearARTPropertyDialog : System.Windows.Forms.Form

Members:

Constructors
Name
Description
ImGearARTPropertyDialog Constructor
Creates and initializes an instance of ImGearARTPropertyDialog Class.


ImGearARTPropertyDialog Constructors

The ImGearARTPropertyDialog Class of the ImageGear.ART.Forms Namespace has the following constructors:

Constructors
Name
Description
ImGearARTPropertyDialog Constructor
Creates and initializes an instance of ImGearARTPropertyDialog Class.


ImGearARTPropertyDialog Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates and initializes an instance of ImGearARTPropertyDialog Class.

Declaration:

public ImGearARTPropertyDialog(ImageGear.Windows.Forms.ImGearPageView PageView,
ImageGear.ART.ImGearARTMark Mark)

Parameters:

Name
Type
Description
PageView
ImGearPageView Class
Reference to page view control.
Mark
ImGearARTMark Class
Reference to the mark object whose properties are requested.

Return Value:

The new instance of ImGearARTPropertyDialog Class GUI object.

See Also:

ImGearPageView Class

ImGearARTMark Class


ImGearARTForms Class

32-bit
64-bit
CF
P
P

Description:

This class provides properties and methods for using ART forms functionality.

Declaration:

public sealed class ImGearARTForms

Members:

Constructors
Name
Description
ImGearARTForms Constructor
Creates a new instance of ImGearARTForms Class object.
ImGearARTForms Constructor
Creates a new instance of ImGearARTForms Class object.
ImGearARTForms Constructor
Creates a new instance of ImGearARTForms Class object.

Properties
Name
Description
AggregateSelect Property
Specifies if the aggregate selection of annotations is allowed.
ButtonAction Property
Specifies a reference to ButtonAction delegate if registered.
HotSpotAction Property
Reference to HotSpotAction delegate if registered. It is automatically called from the ART forms running in the RUN mode when the user clicks on the Hot Spot annotation.
Mode Property
Specifies ART mode.
Page Property
Reference to ART page object the ART forms are working with.
PageView Property
Reference to page view control.
ToolBar Property
Reference to ART toolbar.
PropertyDialog Property
Reference to the property dialog object.

Methods
Name
Description
MouseDown Method
Provides mouse down interaction functionality. It is supposed to be called from the application's PageView_MouseDown event handler.
MouseMove Method
Provides mouse move interaction functionality. It is supposed to be called from the application's PageView_MouseMove event handler.
MouseUp Method
Provides mouse up interaction functionality. It is supposed to be called from the application's PageView_MouseUp event handler.

Delegates
Name
Description
DelegateButtonAction Delegate
This delegate, if registered, is automatically called from the ART forms running in the RUN mode when the user clicks on the Button annotation.
DelegateHotSpotAction Delegate
HotSpotAction delegate method.


ImGearARTForms Constructors

The ImGearARTForms Class of the ImageGear.ART.Forms Namespace has the following constructors:

Constructors
Name
Description
ImGearARTForms Constructor
Creates a new instance of ImGearARTForms Class object.
ImGearARTForms Constructor
Creates a new instance of ImGearARTForms Class object.
ImGearARTForms Constructor
Creates a new instance of ImGearARTForms Class object.


ImGearARTForms Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTForms Class object.

Declaration:

public ImGearARTForms(ImageGear.Windows.Forms.ImGearPageView PageView,
ImageGear.ART.ImGearARTPage Page, ImageGear.ART.Forms.ImGearARTToolBarModes Modes)

Parameters:

Name
Type
Description
PageView
ImGearPageView Class
Reference to page view control.
Page
ImGearARTPage Class
Reference to ART page object the ART forms are going to work with.
Modes
ImGearARTToolBarModes Enumeration
Specifies ART tool bar mode: legacy 2.0 marks or 3.0 marks.

Return Value:

The new instance of ImGearARTForms Class object.

See Also:

ImGearPageView Class

ImGearARTPage Class

ImGearARTToolBarModes Enumeration


ImGearARTForms Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTForms Class object.

Declaration:

public ImGearARTForms(ImageGear.Windows.Forms.ImGearPageView PageView,
ImageGear.ART.Forms.ImGearARTToolBarModes Modes)

Parameters:

Name
Type
Description
PageView
ImGearPageView Class
Reference to page view control.
Modes
ImGearARTToolBarModes Enumeration
Specifies ART tool bar mode: legacy 2.0 marks or 3.0 marks.

Return Value:

The new instance of ImGearARTForms Class object.

See Also:

ImGearPageView Class

ImGearARTToolBarModes Enumeration


ImGearARTForms Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTForms Class object.

Declaration:

public ImGearARTForms(ImageGear.Windows.Forms.ImGearPageView PageView)

Parameters:

Name
Type
Description
PageView
ImGearPageView Class
Reference to page view control.

Return Value:

The new instance of ImGearARTForms Class object.

See Also:

ImGearPageView Class


ImGearARTForms Properties

The ImGearARTForms Class of the ImageGear.ART.Forms Namespace has the following properties:

Properties
Name
Description
AggregateSelect Property
Specifies if the aggregate selection of annotations is allowed.
ButtonAction Property
Specifies a reference to ButtonAction delegate if registered.
HotSpotAction Property
Reference to HotSpotAction delegate if registered. It is automatically called from the ART forms running in the RUN mode when the user clicks on the Hot Spot annotation.
Mode Property
Specifies ART mode.
Page Property
Reference to ART page object the ART forms are working with.
PageView Property
Reference to page view control.
ToolBar Property
Reference to ART toolbar.
PropertyDialog Property
Reference to the property dialog object.


AggregateSelect Property

32-bit
64-bit
CF
P
P

Description:

This property specifies if the aggregate selection of annotations is allowed.

Declaration:

public bool AggregateSelect { set; get; }

Value:

true, false

See Also:

N/A


ButtonAction Property

32-bit
64-bit
CF
P
P

Description:

This property specifies a reference to ButtonAction delegate if registered. It is automatically called from the ART forms running in the RUN mode when the user clicks on the Button annotation.

Declaration:

public ImageGear.ART.Forms.ImGearARTForms.DelegateButtonAction ButtonAction { set; get; }

Value:

DelegateButtonAction Delegate

See Also:

DelegateButtonAction Delegate


HotSpotAction Property

32-bit
64-bit
CF
P
P

Description:

This property specifies a reference to HotSpotAction delegate if registered. It is automatically called from the ART forms running in the RUN mode when the user clicks on the Hot Spot annotation.

Declaration:

public ImageGear.ART.Forms.ImGearARTForms.DelegateHotSpotAction HotSpotAction { set; get;
}

Value:

DelegateHotSpotAction Delegate

See Also:

DelegateHotSpotAction Delegate


Mode Property

32-bit
64-bit
CF
P
P

Description:

This property specifies ART mode.

Declaration:

public ImageGear.ART.Forms.ImGearARTModes Mode { set; get; }

Value:

ImGearARTModes Enumeration value.

See Also:

ImGearARTModes Enumeration


Page Property

32-bit
64-bit
CF
P
P

Description:

This property specifies a reference to ART page object the ART forms are working with.

Declaration:

public ImageGear.ART.ImGearARTPage Page { set; get; }

Value:

ImGearARTPage Class object.

See Also:

ImGearARTPage Class


PageView Property

32-bit
64-bit
CF
P
P

Description:

This property specifies a reference to page view control.

Declaration:

public ImageGear.Windows.Forms.ImGearPageView PageView { set; get; }

Value:

ImGearPageView Class object.

See Also:

ImGearPageView Class


ToolBar Property

32-bit
64-bit
CF
P
P

Description:

This property specifies a reference to ART toolbar.

Declaration:

public ImageGear.ART.Forms.ImGearARTToolBar ToolBar { set; get; }

Value:

ImGearARTToolBar Class object.

See Also:

ImGearARTToolBar Class


PropertyDialog Property

32-bit
64-bit
CF
P
P

Description:

This property specifies a reference to the property dialog object.

Declaration:

public ImageGear.ART.Forms.ImGearARTPropertyDialog PropertyDialog { set; get; }

Value:

ImGearARTPropertyDialog Class object.

See Also:

ImGearARTPropertyDialog Class


ImGearARTForms Methods

The ImGearARTForms Class of the ImageGear.ART.Forms Namespace has the following methods:

Methods
Name
Description
MouseDown Method
Provides mouse down interaction functionality. It is supposed to be called from the application's PageView_MouseDown event handler.
MouseMove Method
Provides mouse move interaction functionality. It is supposed to be called from the application's PageView_MouseMove event handler.
MouseUp Method
Provides mouse up interaction functionality. It is supposed to be called from the application's PageView_MouseUp event handler.


MouseDown Method

32-bit
64-bit
CF
P
P

Description:

This method provides mouse down interaction functionality. It is supposed to be called from the application's PageView_MouseDown event handler.

Declaration:

public void MouseDown(object sender, System.Windows.Forms.MouseEventArgs e)

Parameters:

Name
Type
Description
sender
object
Sender object.
e
MouseEventArgs
Event arguments.

Return Value:

None


MouseMove Method

32-bit
64-bit
CF
P
P

Description:

This method provides mouse move interaction functionality. It is supposed to be called from the application's PageView_MouseMove event handler.

Declaration:

public void MouseMove(object sender, System.Windows.Forms.MouseEventArgs e)

Parameters:

Name
Type
Description
sender
object
Sender object.
e
MouseEventArgs
Event arguments.

Return Value:

None


MouseUp Method

32-bit
64-bit
CF
P
P

Description:

This method provides mouse up interaction functionality. It is supposed to be called from the application's PageView_MouseUp event handler.

Declaration:

public void MouseUp(object sender, System.Windows.Forms.MouseEventArgs e)

Parameters:

Name
Type
Description
sender
object
Sender object.
e
MouseEventArgs
Event arguments.

Return Value:

None


ImGearARTForms Delegates

The ImGearARTForms Class of the ImageGear.ART.Forms Namespace has the following delegates:

Delegates
Name
Description
DelegateButtonAction Delegate
This delegate, if registered, is automatically called from the ART forms running in the RUN mode when the user clicks on the Button annotation.
DelegateHotSpotAction Delegate
HotSpotAction delegate method.


DelegateButtonAction Delegate

32-bit
64-bit
CF
P
P

Description:

This delegate, if registered, is automatically called from the ART forms running in the RUN mode when the user clicks on the Button annotation.

Declaration:

public delegate void DelegateButtonAction(ImageGear.ART.ImGearARTButton Mark)

Parameters:

Name
Type
Description
Mark
ImGearARTButton Class
Reference to Button mark.

Return Value:

None.

See Also:

ImGearARTButton Class

ButtonAction Property


DelegateHotSpotAction Delegate

32-bit
64-bit
CF
P
P

Description:

This delegate, if registered, is automatically called from the ART forms running in the RUN mode when the user clicks on the Hot Spot annotation.

Declaration:

public delegate void DelegateHotSpotAction(ImageGear.ART.ImGearARTHotSpot Mark)

Parameters:

Name
Type
Description
Mark
ImGearARTHotSpot Class
Reference to Hot Spot mark.

Return Value:

None.

See Also:

ImGearARTHotSpot Class


ImGearARTRTFToolBar Class

32-bit
64-bit
CF
P
P

Description:

This class specifies a toolbar for editing RTF text and style.

Declaration:

public class ImGearARTRTFToolBar : System.Windows.Forms.Form

Members:

Constructors
Name
Description
ImGearARTRTFToolBar Constructor
Creates a new instance of ImGearARTRTFToolBar Class object.


ImGearARTRTFToolBar Constructors

The ImGearARTRTFToolBar Class of the ImageGear.ART.Forms Namespace has the following constructors:

Constructors
Name
Description
ImGearARTRTFToolBar Constructor
Creates a new instance of ImGearARTRTFToolBar Class object.


ImGearARTRTFToolBar Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTRTFToolBar Class object.

Declaration:

public ImGearARTRTFToolBar(ImageGear.Windows.Forms.ImGearPageView PageView,
ImageGear.ART.ImGearARTRichTextControl Control)

Parameters:

Name
Type
Description
PageView
ImGearPageView Class
Reference to page view control.
Control
ImGearARTRichTextControl Class
Reference to ImGearARTRichTextControl object.

Return Value:

The new instance of ImGearARTRTFToolBar Class object.

See Also:

ImGearARTRTFToolBar Class

ImGearPageView Class

ImGearARTRichTextControl Class


ImGearARTToolBar Class

32-bit
64-bit
CF
P
P

Description:

This class specifies toolbar for creating, selecting and editing ART annotation.

Declaration:

public class ImGearARTToolBar : System.Windows.Forms.Form

Members:

Constructors
Name
Description
ImGearARTToolBar Constructor
Creates a new instance of ImGearARTToolBar Class object.

Properties
Name
Description
btnSelect Property
Reference to select button object.
Button Property
Reference to the currectly selected toolbar button.
NotifyCreateMark Property
Reference to NotifyCreateMark delegate if registered. It is automatically called from the ART forms when the user creates a mark.
NotifyDeleteMark Property
Reference to NotifyDeleteMark delegate if registered. It is automatically called from the ART forms when the user deletes a mark.
NotifyModifyMark Property
Reference to NotifyModifyMark delegate if registered. It is automatically called from the ART forms when the user modifies a mark.
NotifyPreCreateMark Property
Specifies a reference to PreCreateMark delegate, if registered.
NotifySelect Property
Reference to NotifySelect delegate if registered. It is automatically called from the ART forms when the user clicks toolbar button to select a mark type.

Methods
Name
Description
IsButtonVisible Method
Returns visible state of a button corresponding to a given mark type.
SetButtonVisible Method
Sets visible state of a button corresponding to a given mark type.

Delegates
Name
Description
DelegateCreateMark Delegate
NotifyCreateMark delegate method.
DelegateDeleteMark Delegate
NotifyDeleteMark delegate method.
DelegateModifyMark Delegate
NotifyModifyMark delegate method.
DelegatePreCreateMark Delegate
NotifyPreCreateMark delegate method.
DelegateSelect Delegate
NotifySelect delegate method.


ImGearARTToolBar Constructors

The ImGearARTToolBar Class of the ImageGear.ART.Forms Namespace has the following constructors:

Constructors
Name
Description
ImGearARTToolBar Constructor
Creates a new instance of ImGearARTToolBar Class object.


ImGearARTToolBar Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new instance of ImGearARTToolBar Class object.

Declaration:

public ImGearARTToolBar(ImageGear.ART.Forms.ImGearARTToolBarModes Modes)

Parameters:

Name
Type
Description
Modes
ImGearARTToolBarModes Enumeration
ART toolbar mode.

Return Value:

The new instance of ImGearARTToolBar Class object.

See Also:

ImGearARTToolBar Class

ImGearARTToolBarModes Enumeration


ImGearARTToolBar Properties

The ImGearARTToolBar Class of the ImageGear.ART.Forms Namespace has the following properties:

Properties
Name
Description
btnSelect Property
Reference to select button object.
Button Property
Reference to the currectly selected toolbar button.
NotifyCreateMark Property
Reference to NotifyCreateMark delegate if registered. It is automatically called from the ART forms when the user creates a mark.
NotifyDeleteMark Property
Reference to NotifyDeleteMark delegate if registered. It is automatically called from the ART forms when the user deletes a mark.
NotifyModifyMark Property
Reference to NotifyModifyMark delegate if registered. It is automatically called from the ART forms when the user modifies a mark.
NotifyPreCreateMark Property
Specifies a reference to PreCreateMark delegate, if registered
NotifySelect Property
Reference to NotifySelect delegate if registered. It is automatically called from the ART forms when the user clicks toolbar button to select a mark type.


btnSelect Property

32-bit
64-bit
CF
P
P

Description:

This property specifies a reference to select button object.

Declaration:

public System.Windows.Forms.Button btnSelect { get, set }

Value:

System.Windows.Forms.Button value.

See Also:

N/A


Button Property

32-bit
64-bit
CF
P
P

Description:

This property specifies a reference to the currectly selected toolbar button.

Declaration:

public ImageGear.ART.ImGearARTMarkType Button { get, set }

Value:

ImGearARTMarkType Enumeration value.

See Also:

ImGearARTMarkType Enumeration


NotifyCreateMark Property

32-bit
64-bit
CF
P
P

Description:

This property specifies a reference to CreateMark delegate, if registered. It is automatically called from the ART forms when the user creates a mark.

Declaration:

public ImageGear.ART.Forms.ImGearARTToolBar.DelegateCreateMark NotifyCreateMark { get, set
}

Value:

DelegateCreateMark Delegate value.

See Also:

DelegateCreateMark Delegate


NotifyDeleteMark Property

32-bit
64-bit
CF
P
P

Description:

This property specifies a reference to DeleteMark delegate if registered. It is automatically called from the ART forms when the user deletes a mark.

Declaration:

public ImageGear.ART.Forms.ImGearARTToolBar.DelegateDeleteMark NotifyDeleteMark { get, set
}

Value:

DelegateDeleteMark Delegate value.

See Also:

DelegateDeleteMark Delegate


NotifyModifyMark Property

32-bit
64-bit
CF
P
P

Description:

This property specifies a reference to ModifyMark delegate if registered. It is automatically called from the ART forms when the user modifies a mark.

Declaration:

public ImageGear.ART.Forms.ImGearARTToolBar.DelegateModifyMark NotifyModifyMark { get, set
}

Value:

DelegateModifyMark Delegate value.

See Also:

DelegateModifyMark Delegate


NotifyPreCreateMark Property

32-bit
64-bit
CF
P
P

Description:

This property specifies a reference to DelegatePreCreateMark Delegate, if registered. It is automatically called from the ART forms when the user is about to create a mark. This delegate can be used to change a mark's default attributes before its creation.

Declaration:

public ImageGear.ART.Forms.ImGearARTToolBar.DelegatePreCreateMark NotifyCreateMark { get,
set }

Value:

DelegatePreCreateMark Delegate value.

See Also:

DelegatePreCreateMark Delegate


NotifySelect Property

32-bit
64-bit
CF
P
P

Description:

This property specifies a reference to Select delegate if registered. It is automatically called from the ART forms when the user clicks toolbar button to select a mark type.

Declaration:

public ImageGear.ART.Forms.ImGearARTToolBar.DelegateSelect NotifySelect { get, set }

Value:

DelegateSelect Delegate value.

See Also:

DelegateSelect Delegate


ImGearARTToolBar Methods

The ImGearARTToolBar Class of the ImageGear.ART.Forms Namespace has the following methods:

Methods
Name
Description
IsButtonVisible Method
Returns visible state of a button corresponding to a given mark type.
SetButtonVisible Method
Sets visible state of a button corresponding to a given mark type.


IsButtonVisible Method

32-bit
64-bit
CF
P
P

Description:

Returns visible state of a button corresponding to a given mark type.

Declaration:

public bool IsButtonVisible(ImGearARTMarkType Id)

Parameters:

Name
Type
Description
Id
ImGearARTMarkType Enumeration
The mark type.

Return Value:

True/False

See Also:

ImGearARTMarkType Enumeration


SetButtonVisible Method

32-bit
64-bit
CF
P
P

Description:

Sets visible state of a button corresponding to a given mark type.

Declaration:

public void SetButtonVisible(ImGearARTMarkType Id, bool Visible)

Parameters:

Name
Type
Description
Id
ImGearARTMarkType Enumeration
The mark type.
Visible
bool
Visible state of a button.

Return Value:

None

See Also:

ImGearARTMarkType Enumeration


ImGearARTToolBar Delegates

The ImGearARTToolBar Class of the ImageGear.ART.Forms Namespace has the following delegates:

Delegates
Name
Description
DelegateCreateMark Delegate
NotifyCreateMark delegate method.
DelegateDeleteMark Delegate
NotifyDeleteMark delegate method.
DelegateModifyMark Delegate
NotifyModifyMark delegate method.
DelegatePreCreateMark Delegate
NotifyPreCreateMark delegate method.
DelegateSelect Delegate
NotifySelect delegate method.


DelegateCreateMark Delegate

32-bit
64-bit
CF
P
P

Description:

This delegate, if registered, is automatically called from the ART forms when the user creates a mark.

Declaration:

public delegate void DelegateCreateMark(ImageGear.ART.ImGearARTPage Page,
ImageGear.ART.ImGearARTMark Mark)

Parameters:

Name
Type
Description
Page
ImGearARTPage Class
Reference to ART page object.
Mark
ImGearARTMark Class
Reference to the created mark.

Return Value:

None.

See Also:

ImGearARTPage Class

ImGearARTMark Class


DelegateDeleteMark Delegate

32-bit
64-bit
CF
P
P

Description:

This delegate, if registered, is automatically called from the ART forms when the user deletes a mark.

Declaration:

public delegate void DelegateDeleteMark(ImageGear.ART.ImGearARTPage Page,
ImageGear.ART.ImGearARTMark Mark)

Parameters:

Name
Type
Description
Page
ImGearARTPage Class
Reference to ART page object.
Mark
ImGearARTMark Class
Reference to mark to delete.

Return Value:

None.

See Also:

ImGearARTPage Class

ImGearARTMark Class


DelegateModifyMark Delegate

32-bit
64-bit
CF
P
P

Description:

This delegate, if registered, is automatically called from the ART forms when the user modifies a mark.

Declaration:

public delegate void DelegateModifyMark(ImageGear.ART.ImGearARTPage Page,
ImageGear.ART.ImGearARTMark Mark, ImageGear.ART.Forms.ImGearARTModifyReason Reason)

Parameters:

Name
Type
Description
Page
ImGearARTPage Class
Reference to ART page object.
Mark
ImGearARTMark Class
Reference to the modofied mark.
Reason
ImGearARTModifyReason Enumeration
Reason of the mark is change .

Return Value:

None.

See Also:

ImGearARTPage Class

ImGearARTMark Class

ImGearARTModifyReason Enumeration


DelegatePreCreateMark Delegate

32-bit
64-bit
CF
P
P

Description:

This delegate, if registered, is automatically called from the ART forms when the user is about to create a mark. It can be used to change a mark's default attributes before its creation.

Declaration:

public delegate void DelegatePreCreateMark(ImageGear.ART.ImGearARTPage Page,
ImageGear.ART.ImGearARTMark Mark)

Parameters:

Name
Type
Description
Page
ImGearARTPage Class
Reference to ART page object..
Mark
ImGearARTMark Class
Reference to the creating mark.

Return Value:

None.

See Also:

ImGearARTPage Class

ImGearARTMark Class


DelegateSelect Delegate

32-bit
64-bit
CF
P
P

Description:

This delegate, if registered, is automatically called from the ART forms when the user clicks toolbar button to select a mark type.

Declaration:

public delegate void DelegateSelect(ImageGear.ART.ImGearARTMarkType Button)

Parameters:

Name
Type
Description
Button
ImGearARTMarkType Enumeration
Selected mark type.

Return Value:

None.

See Also:

ImGearARTMarkType Enumeration


ImageGear.ART.Forms Namespace Enumerations

The ImageGear.ART.Forms Namespace has the following enumeration members:

Enumerations:
Name
Description
ImGearARTModes Enumeration
ART modes.
ImGearARTModifyReason Enumeration
Reasons for NotifyModifyMark delegate to be called.
ImGearARTToolBarModes Enumeration
ART toolbar modes: legacy 2.0 marks and 3.0 marks.


ImGearARTModes Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration specifies ART modes.

Declaration:

public enum ImGearARTModes

Values:

Name
Value
Description
EDIT
EDIT
Edit mode
RUN
RUN
Run mode
VIEW
VIEW
View mode


ImGearARTModifyReason Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration specifies reasons for NotifyModifyMark delegate to be called.

Declaration:

public enum ImGearARTModifyReason

Values:

Name
Value
Description
ATTRIBUTE_CHANGE
ATTRIBUTE_CHANGE
One of the mark's attributes as been changed.
MOVE
MOVE
Mark has been moved.
RESIZE
RESIZE
Mark has been resized.
RTF_EDIT
RTF_EDIT
RTF mark has beed changed.
TEXT_EDIT
TEXT_EDIT
Text mark's text has been changed.


ImGearARTToolBarModes Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration specifies ART toolbar modes: legacy 2.0 marks and 3.0 marks.

Declaration:

public enum ImGearARTToolBarModes

Values:

Name
Value
Description
ART20
ART20
Legacy ART 2.0 mode. Specifies the old style marks.
ART30
ART30
ART 3.0 marks mode. Specifies the new style marks.


ImageGear.Display Namespace

ImageGear.Display Namespace

32-bit
64-bit
CF
P
P
P

Description:

The ImageGear.Display namespace provides the ImageGear for .NET API for displaying and printing.

Declaration:

namespace ImageGear.Display

Members:

Classes:
Name
Description
ImGearPageDisplay Class
Main class implementing whole IG.NET display API.
ImGearPageDisplayConverter Class
Provides methods that override methods of the TypeConverter.
ImGearScrollComponentInfoConverter Class
Provides methods that override methods of the TypeConverter.
ImGearZoomInfoConverter Class
Provides methods that override methods of the TypeConverter.

Interfaces:
Name
Description
IImGearAlignment Interface
Provides methods to access image alignment settings.
IImGearAntiAlias Interface
Provides methods to access image aliasing settings.
IImGearAspectRatio Interface
Provides methods to access aspect ratio settings of image.
IImGearBackground Interface
Provides methods to access display background parameters.
IImGearColorAntiAlias Interface
This is an interface for color anti-aliasing attributes.
IImGearContrastSettings Interface
Contrast settings structure used by ImGearPageDisplay.UpdateLUT method.
IImGearDisplayObject Interface
Base interface implemented in several display code structures.
IImGearLayout Interface
Provides methods to access image layout settings.
IImGearResample Interface
This is an interface for re-sampling attributes.
IImGearScrollableView Interface
IG display code interacts with .NET windows and forms via this interface.

Structures:
Name
Description
ImGearContrastSettings Structure
Contrast settings structure used by ImGearPageDisplay.UpdateLUT method.
ImGearScrollComponentInfo Structure
Structure used to implement state of one scroll bar.
ImGearScrollInfo Structure
Implements image scrolling information (state of two scrolbars).
ImGearZoomComponentInfo Structure
Simple auxiliary structure used in ImGearZoomInfo.
ImGearZoomInfo Structure
Implements image zoom information for horizontal and vertical zoom.

Enumerations:
Name
Description
ImGearAliasModes Enumeration
Identifies different types of display anti-aliasing.
ImGearAlignmentHModes Enumeration
Identifies different types of image display horizontal alignment.
ImGearAlignmentVModes Enumeration
Identifies different types of image display vertical alignment.
ImGearBackgroundModes Enumeration
Identifies different modes of background drawing.
ImGearColorAliasModes Enumeration
Specifies color anti-aliasing modes currently supported.
ImGearCoordConvModes Enumeration
Identifies types of coordinate conversion.
ImGearFitModes Enumeration
Identifies image display fit modes.
ImGearResampleModes Enumeration
Specifies re-sampling modes currently supported.
ImGearScrollBarModes Enumeration
Identifies different types of scrollbars appearance mode.
ImGearScrollBarType Enumeration
Identifies possible scrollbar types.


ImageGear.Display Namespace Classes

The ImageGear.Display Namespace has the following class members:

Classes:
Name
Description
ImGearPageDisplay Class
Main class implementing whole IG.NET display API.
ImGearPageDisplayConverter Class
Provides methods that override methods of the TypeConverter.
ImGearScrollComponentInfoConverter Class
Provides methods that override methods of the TypeConverter.
ImGearZoomInfoConverter Class
Provides methods that override methods of the TypeConverter.


ImGearPageDisplay Class

32-bit
64-bit
CF
P
P
P

Description:

Main class implementing the whole IG .NET display API.

Declaration:

public sealed class ImGearPageDisplay

Members:

Constructors
Name
Description
ImGearPageDisplay Constructor
Creates instance of ImGearPageDisplay object.
ImGearPageDisplay Constructor
Creates instance of ImGearPageDisplay object.
ImGearPageDisplay Constructor
Creates instance of ImGearPageDisplay object.

Properties
Name
Description
AntiAliasing Property
Provides access to display anti-aliasing settings, reference to internal object.
ARTPage Property
ImGearARTPage object associated with this display page.
Background Property
Provides access to background drawing attributes, reference to internal object.
Channels Property
Specifies the list of extra channels and their display options.
ColorAntiAliasing Property
Specifies color anti-aliasing attributes.
DICOMDisplaySettings Property
Provides access to DICOM specific display contrast settings.
Layout Property
Provides access to display layout settings, reference to internal object.
LUT Property
Display Look up table. Must be an instance of ImGearRGBLUT.
Orientation Property
Provides access to display image orientation, reference to internal object.
Page Property
ImGearPage object associated with this display page.
Resampling Property
Specifies re-sampling attributes.

Methods
Name
Description
Clone Method
CopiesImGearPageDisplay object.
ConvertCoordinates Method
Translates coordinates between image and device coordinate systems.
Draw Method
Draws image on drawable surface (Graphics).
DrawEx Method
Draws image on .NET Graphics.
GetScrollInfo Method
Returns current scrolling settings (new instance of object created).
GetZoomInfo Method
Returns current zoom settings (new instance of object created).
HandleScroll Method
Handler for scrolling events.
Print Method
Draws image on .NET Graphics for printer.
ScrollTo Method
Scrolls image to the specified position.
UpdateLUT Method
Updates ImGearPageDisplay's display look up table.
UpdateScrollFrom Method
Updates scrolling information.
UpdateZoomFrom Method
Updates zoom information.
ZoomToRectangle Method
Zoom image to the rectangle specified and return new zoom information.

Sample Code:

C#
// Create a new ImGearPageDisplay based upon an ImGearPage.
ImGearPageDisplay igPageDisplay = new ImGearPageDisplay(igPage);
// Set the Anti Aliasing method to scale to gray at a 50% threshold.
igPageDisplay.AntiAliasing.Method = ImGearAliasModes.SCALE_TO_GRAY;
igPageDisplay.AntiAliasing.Threshold = 50;
// Set the fit mode to the width.
igPageDisplay.Layout.FitMode = ImGearFitModes.FIT_TO_WIDTH;
// Set the current ImGearPageView to use this new display.
imGearPageView.Display = igPageDisplay;

VB .NET
'Create a new ImGearPageDisplay based upon an ImGearPage.
Dim igPageDisplay As ImGearPageDisplay = New ImGearPageDisplay(igPage)
'Set the Anti Aliasing method to scale to gray at a 50% threshold.
igPageDisplay.AntiAliasing.Method = ImGearAliasModes.SCALE_TO_GRAY
igPageDisplay.AntiAliasing.Threshold = 50
'Set the fit mode to the width.
igPageDisplay.Layout.FitMode = ImGearFitModes.FIT_TO_WIDTH
'Set the current ImGearPageView to use this new display.
ImGearPageView1.Display = igPageDisplay


ImGearPageDisplay Constructors

The ImGearPageDisplay Class of the ImageGear.Display Namespace has the following constructors:

Constructors
Name
Description
ImGearPageDisplay Constructor
Creates instance of ImGearPageDisplay object.
ImGearPageDisplay Constructor
Creates instance of ImGearPageDisplay object.
ImGearPageDisplay Constructor
Creates instance of ImGearPageDisplay object.


ImGearPageDisplay Constructor

32-bit
64-bit
CF
P
P
P

Description:

Creates the new instance of ImGearPageDisplay Class and initializes it.

Declaration:

public ImGearPageDisplay ( )

Return Value:

The new instance of ImGearPageDisplay Class.

See Also:

ImGearPageDisplay Class


ImGearPageDisplay Constructor

32-bit
64-bit
CF
P
P
P

Description:

Creates the new instance of ImGearPageDisplay Class and initializes it.

Declaration:

public ImGearPageDisplay ( ImageGear.Core.ImGearPage igPage )

Parameters:

Name
Type
Description
igPage
ImGearPage Class
Specifies the ImGearPage object to associate with new ImGearPageDisplay instance.

Return Value:

The new instance of ImGearPageDisplay Class.

See Also:

ImGearPageDisplay Class

ImGearPage Class


ImGearPageDisplay Constructor

32-bit
64-bit
CF
P
P
P

Description:

Creates the new instance of ImGearPageDisplay Class and initializes it using the specified ImGearPage and ImGearARTPage objects.

Declaration:

public ImGearPageDisplay(ImageGear.Core.ImGearPage igPage, ImageGear.ART.ImGearARTPage
igArtPage)

Parameters:

Name
Type
Description
igPage
ImGearPage Class
Specifies the ImGearPage object to associate with new ImGearPageDisplay instance.
igArtPage
ImGearARTPage Class
ImGearARTPage object to associate with ImGearPage for display.

Return Value:

The new instance of ImGearPageDisplay Class.

See Also:

ImGearPageDisplay Class

ImGearPage Class

ImGearARTPage Class


ImGearPageDisplay Properties

The ImGearPageDisplay Class of the ImageGear.Display Namespace has the following properties:

Properties
Name
Description
AntiAliasing Property
Provides access to display anti-aliasing settings, reference to internal object.
ARTPage Property
ImGearARTPage object associated with this display page.
Background Property
Provides access to background drawing attributes, reference to internal object.
Channels Property
Specifies the list of extra channels and their display options.
ColorAntiAliasing Property
Specifies color anti-aliasing attributes.
DICOMDisplaySettings Property
Provides access to DICOM specific display contrast settings.
Layout Property
Provides access to display layout settings, reference to internal object.
LUT Property
Display Look up table. Must be an instance of ImGearRGBLUT.
Orientation Property
Provides access to display image orientation, reference to internal object.
Page Property
ImGearPage object associated with this display page.
Resampling Property
Specifies re-sampling attributes.


AntiAliasing Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides access to image display anti-aliasing settings.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

Declaration:

public ImageGear.Display.IImGearAntiAlias AntiAliasing { get; }

Value:

IImGearAntiAlias Interface

See Also:

IImGearAntiAlias Interface


ARTPage Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides ImGearARTPage object associated with this display page.

Declaration:

public ImageGear.ART.ImGearARTPage ARTPage { get;  set; }

Value:

ImGearARTPage Class

See Also:

ImGearARTPage Class


Background Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides access to background drawing attributes.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

Declaration:

public ImageGear.Display.IImGearBackground Background { get; }

Value:

IImGearBackground Interface

See Also:

IImGearBackground Interface


Channels Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the list of extra channels and their display options.

Declaration:

public ImageGear.Display.ImGearDisplayChannels Channels { get; }

Value:

ImGearDisplayChannels Class

Example:

C#
visibleFirstExtra = m_PageView.Display.Channels[StartExtra + 0].Visible;

Visual Basic
visibleFirstExtra = m_PageView.Display.Channels[StartExtra + 0].Visible

See Also:

ImGearDisplayChannels Class


ColorAntiAliasing Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies color anti-aliasing attributes.

Declaration:

public ImageGear.Display.IImGearColorAntiAlias ColorAntiAliasing { get; }

Value:

IImGearAntiAlias Interface

Example:

C#
imGearPageView.Display.ColorAntiAliasing.Method =	ImGearColorAliasModes.INTERPOLATE;

Visual Basic
imGearPageView.Display.ColorAntiAliasing.Method =	ImGearColorAliasModes.INTERPOLATE

See Also:

IImGearAntiAlias Interface


DICOMDisplaySettings Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides access to DICOM specific display contrast settings.

DICOM specification defines several contrast transformations, such as Modality LUT, VOI LUT, etc. When ImageGear loads a DICOM image, it initializes DICOMDisplaySettings field of ImGearRasterPage Class with settings found in the file. During display, ImageGear checks for presence of DICOMDisplaySettings, and if it is present, uses it in display processing pipeline. This allows you to load and display DICOM images with proper contrast, without the need for extra application code.

DICOMDisplaySettings can be attached to an ImGearRasterPage Class or to a ImGearPageDisplay Class. If ImGearPageDisplay.DICOMDisplaySettings is not null, ImageGear uses it for display. If ImGearPageDisplay.DICOMDisplaySettings is null, ImageGear checks ImGearRasterPage for presence of .DICOMDisplaySettings, and if it is not null, uses it for display. In other words, DICOMDisplaySettings attached to Display has higher priority than DICOMDisplaySettings attached to ImGearRasterPage..

DICOMDisplaySetings can be also used if the image was not loaded from a DICOM file. It can be useful for non-medical images as well.

This property affects grayscale images with bit depths from 2 to 16.

Declaration:

public ImageGear.Formats.DICOM.ImGearDICOMDisplaySettings DICOMDisplaySettings { get, set
}

Value:

ImGearDICOMDisplaySettings Class object.

Default Value:

NULL


Layout Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides access to image display layout settings.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

Declaration:

public ImageGear.Display.IImGearLayout Layout { get; }

Value:

IImGearLayout Interface

See Also:

IImGearLayout Interface


LUT Property

32-bit
64-bit
CF
P
P
P

Description:

This property displays Look up table. Must be an instance of ImGearRGBLUT Class.

Value returned is a reference to ImGearMultichannelLUT Class object.

Declaration:

public ImageGear.Core.ImGearMultichannelLUT LUT { get;  set; }

Value:

ImGearMultichannelLUT Class

See Also:

ImGearMultichannelLUT Class


Orientation Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides access to image orientation attributes.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

Declaration:

public ImageGear.Core.IImGearOrientation Orientation { get; }

Value:

ImGearOrientation Structure

See Also:

ImGearOrientation Structure


Page Property

32-bit
64-bit
CF
P
P
P

Description:

ImGearPage object associated with this display page.

Declaration:

public ImageGear.Core.ImGearPage Page { get; set; }

Value:

Valid ImGearPage Class object or null.

See Also:

ImGearPage Class


Resampling Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies re-sampling attributes.

Declaration:

public ImageGear.Display.IImGearResample Resampling { get; }

Value:

IImGearResample Interface object.

Example:

C#
imGearPageView.Display.Resampling.Method =
    ImGearResampleModes.BILINEAR;

Visual Basic
imGearPageView.Display.Resampling.Method =
    ImGearResampleModes.BILINEAR

See Also:

IImGearResample Interface


ImGearPageDisplay Methods

The ImGearPageDisplay Class of the ImageGear.Display Namespace has the following methods:

Methods
Name
Description
Clone Method
CopiesImGearPageDisplay object.
ConvertCoordinates Method
Translates coordinates between image and device coordinate systems.
Draw Method
Draws image on drawable surface (Graphics).
DrawEx Method
Draws image on .NET Graphics.
GetScrollInfo Method
Returns current scrolling settings (new instance of object created).
GetZoomInfo Method
Returns current zoom settings (new instance of object created).
HandleScroll Method
Handler for scrolling events.
Print Method
Draws image on .NET Graphics for printer.
ScrollTo Method
Scrolls image to the specified position.
UpdateLUT Method
Updates ImGearPageDisplay's display look up table.
UpdateScrollFrom Method
Updates scrolling information.
UpdateZoomFrom Method
Updates zoom information.
ZoomToRectangle Method
Zoom image to the rectangle specified and return new zoom information.


Clone Method

32-bit
64-bit
CF
P
P
P

Description:

This method copies ImGearPageDisplay Class object.

Declaration:

public ImageGear.Display.ImGearPageDisplay Clone()

Return value:

New instance of ImGearPageDisplay Class object.

See Also:

ImGearPageDisplay Class


ConvertCoordinates Method

32-bit
64-bit
CF
P
P
P

Description:

This method translates coordinates between image and device coordinate systems (depending on the value of the `Mode' parameter). The `coordArray' can point to array of points or double points.

Declaration:

public void ConvertCoordinates(ImageGear.Display.IImGearScrollableView frmWnd,
System.Drawing.Graphics hdc, ImageGear.Display.ImGearCoordConvModes Mode, System.Array
array)

Parameters:

Name
Type
Description
frmWnd
IImGearScrollableView Interface
IImGearScrollableView interface; represents .NET form to draw image on.
hdc
System.Drawing.Graphics
Graphics object used to draw this image.
Mode
ImGearCoordConvModes Enumeration
Specifies translation direction; either
IMAGE_TO_DEVICE or
DEVICE_TO_IMAGE
array
System.Array
Array with point coordinates.

Return Value:

None

See Also:

IImGearScrollableView Interface

ImGearCoordConvModes Enumeration


Draw Method

32-bit
64-bit
CF
P
P
P

Description:

This method draws image on .NET Graphics.

Declaration:

public void Draw (ImageGear.Core.IImGearScrollableView frmWnd , System.Drawing.Graphics
hdc)

Parameters:

Name
Type
Description
frmWnd
IImGearScrollableView Interface
IImGearScrollableView Interface interface; represents .NET form to draw image on.
hdc
System.Drawing.Graphics
Graphics object to draw image on

Return Value:

None

See Also:

IImGearScrollableView Interface


DrawEx Method

32-bit
64-bit
CF
P
P
P

Description:

This method draws image on .NET Graphics.

Declaration:

public void DrawEx(ImageGear.Display.IImGearScrollableView frmWnd, System.Drawing.Graphics
hdc, bool bDoPrint)

Parameters:

Name
Type
Description
frmWnd
IImGearScrollableView Interface
IImGearScrollableView Interface, represents .NET Form to draw image in.
hdc
System.Drawing.Graphics
Graphics object to draw image on.
bDoPrint
bool
Boolean flag indicating that drawing is performed for printer Graphics or not.

Return Value:

None

See Also:

IImGearScrollableView Interface

32-bit
64-bit
CF
P
P
P
32-bit
64-bit
CF
P
P
P
32-bit
64-bit
CF
P
P
P
32-bit
64-bit
CF
P
P
P
32-bit
64-bit
CF
P
P
P
ImageGear.Display Namespace > ImGearPageDisplay Class > GetScrollInfo Method


GetScrollInfo Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns new instance of image scrolling attributes object.

Declaration:

public ImageGear.Display.ImGearScrollInfo
GetScrollInfo(ImageGear.Display.IImGearScrollableView frmWnd)

Parameters:

Name
Type
Description
frmWnd
IImGearScrollableView Interface
IImGearScrollableView interface, represents .NET Form to draw image in.

Return value:

New instance of ImGearScrollInfo Structure object.

See Also:

ImGearScrollInfo Structure

IImGearScrollableView Interface


GetZoomInfo Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns new instance of object with image current zoom settings.

Declaration:

public ImageGear.Display.ImGearZoomInfo
GetZoomInfo(ImageGear.Display.IImGearScrollableView frmWnd)

Parameters:

Name
Type
Description
frmWnd
IImGearScrollableView Interface
IImGearScrollableView interface, represents .NET Form to draw image in.

Return value:

New instance of ImGearZoomInfo Structure object.

See Also:

ImGearZoomInfo Structure

IImGearScrollableView Interface


HandleScroll Method

32-bit
64-bit
CF
P
P
P

Description:

This method is to use to handle scrolling events.

Use this function only to handle scrolling events. To scroll image to particular position, use ScrollTo Method () method instead.

Declaration:

public void HandleScroll(ImageGear.Display.IImGearScrollableView frmWnd,
ImageGear.Display.ImGearScrollBarType nType, int nValue)

Parameters:

Name
Type
Description
frmWnd
IImGearScrollableView Interface
IImGearScrollableView interface, represents .NET Form to draw image in.
nType
ImGearScrollBarType Enumeration
Type of scrolling event: horizontal or vertical. Possible values are:
ImGearScrollBarType.HORIZONTAL and
ImGearScrollBarType.VERTICAL
nValue
int
Scroll value. Specifies new scrolling position.

Return Value:

None.

See Also:

IImGearScrollableView Interface

ImGearScrollBarType Enumeration


Print Method

32-bit
64-bit
CF
P
P
P

Description:

This method draws image on .NET Graphics for printer.

Call to Print(hdc) is equal to call DrawEx(null, hdc, true);

Declaration:

public void Print(System.Drawing.Graphics hdc)

Parameters:

Name
Type
Description
hdc
System.Drawing.Graphics
Graphics object to draw image on.

Return Value:

None

Sample Code:

C#
private void PrintPage(object sender, EventArgs e)
{
    // Load an image
    ImGearPage igPage;
    using (FileStream localFile = new FileStream("test1.tif", FileMode.Open))
    {
        igPage = ImGearFileFormats.LoadPage(localFile, 0);
    }
    // Create a new ImGearPageDisplay based upon an ImGearPage.
    ImGearPageDisplay igPageDisplay = new ImGearPageDisplay(igPage);
    // Set the current ImGearPageView to use this new display.
    imGearPageView.Display = igPageDisplay;
    // Initialize a PrintDialog for the user to select a printer.
    using (PrintDocument document = new PrintDocument())
    using (PrintDialog printDialog = new PrintDialog())
    {
        printDialog.Document = document;
        // Set the page range to 1 page.
        printDialog.AllowSomePages = true;
        printDialog.PrinterSettings.MinimumPage = 1;
        printDialog.PrinterSettings.MaximumPage = 1;
        printDialog.PrinterSettings.FromPage = 1;
        printDialog.PrinterSettings.ToPage = 1;

        if (DialogResult.OK == printDialog.ShowDialog(this))
        {
            // Set a name for the print job.
            document.DocumentName = this.Text;
            // Define a PrintPage event handler and start printing.
            document.PrintPage +=
                new PrintPageEventHandler(HandlePrinting);
            document.Print();
        }
    }
}
void HandlePrinting(object sender, PrintPageEventArgs args)
{
    // Clone the current Display for use as a printing display.
    ImGearPageDisplay igPageDisplayPrinting =
        imGearPageView.Display.Clone();
    igPageDisplayPrinting.Page = imGearPageView.Display.Page;
    // Get the current Zoom settings and disabled fixed zoom.
    ImGearZoomInfo igZoomInfo =
        igPageDisplayPrinting.GetZoomInfo(imGearPageView);
    igZoomInfo.Horizontal.Fixed =
        igZoomInfo.Vertical.Fixed = false;
    igPageDisplayPrinting.UpdateZoomFrom(igZoomInfo);
    // Disable any background before printing.
    igPageDisplayPrinting.Background.Mode =
        ImGearBackgroundModes.NONE;
    // Print to the Graphics device chosen from the PrintDialog.
    igPageDisplayPrinting.Print(args.Graphics);
    // Let the PrintDialog know there are no more pages.
    args.HasMorePages = false;
}

VB .NET
Private Sub PrintPage(ByVal sender As System.Object, ByVal e As System.EventArgs) _
                Handles ImGearPageDisplayPrintToolStripMenuItem.Click
    'Load an image
    Dim igPage As ImGearPage
    Dim localFile As FileStream = New FileStream("test1.tif", FileMode.Open)
    Try
        igPage = ImGearFileFormats.LoadPage(localFile, 0)
    Finally
        localFile.Close()
    End Try
    'Create a new ImGearPageDisplay based upon an ImGearPage.
    Dim igPageDisplay As ImGearPageDisplay = New ImGearPageDisplay(igPage)
    'Set the current ImGearPageView to use this new display.
    ImGearPageView1.Display = igPageDisplay
    'Initialize a PrintDialog for the user to select a printer.
    Dim document As PrintDocument = New PrintDocument()
    Dim printDialog As PrintDialog = New PrintDialog()
    Try
        printDialog.Document = document
        'Set the page range to 1 page.
        printDialog.AllowSomePages = True
        printDialog.PrinterSettings.MinimumPage = 1
        printDialog.PrinterSettings.MaximumPage = 1
        printDialog.PrinterSettings.FromPage = 1
        printDialog.PrinterSettings.ToPage = 1
        If (printDialog.ShowDialog(Me) = DialogResult.OK) Then
            'Set a name for the print job.
            document.DocumentName = Me.Text
            'Define a PrintPage event handler and start printing.
            AddHandler document.PrintPage, _
                New PrintPageEventHandler(AddressOf HandlePrinting)
            document.Print()
        End If
    Finally
        printDialog.Dispose()
        document.Dispose()
    End Try
End Sub
Private Sub HandlePrinting(ByVal sender As Object, ByVal args As PrintPageEventArgs)
    'Clone the current Display for use as a printing display.
    Dim igPageDisplayPrinting As ImGearPageDisplay = _
        ImGearPageView1.Display.Clone()
    igPageDisplayPrinting.Page = ImGearPageView1.Display.Page
    'Get the current Zoom settings and disabled fixed zoom.
    Dim igZoomInfo As ImGearZoomInfo = _
        igPageDisplayPrinting.GetZoomInfo(ImGearPageView1)
    igZoomInfo.Horizontal.Fixed = False
    igZoomInfo.Vertical.Fixed = False
    igPageDisplayPrinting.UpdateZoomFrom(igZoomInfo)
    'Disable any background before printing.
    igPageDisplayPrinting.Background.Mode = _
        ImGearBackgroundModes.NONE
    'Print to the Graphics device chosen from the PrintDialog.
    igPageDisplayPrinting.Print(args.Graphics)
    'Let the PrintDialog know there are no more pages.
    args.HasMorePages = False
End Sub

See Also:

ImGearPageDisplay Class


ScrollTo Method

32-bit
64-bit
CF
P
P
P

Description:

This method scrolls the image to the specified position and updates the scrollbars accordingly. It can be used whether the actual scrollbar controls are visible in the Form object or not.

X_Pos and Y_Pos both should be in the valid ranges that can be retrieved with GetScrollInfo Method.

Declaration:

public ImageGear.Display.ImGearScrollInfo ScrollTo(ImageGear.Display.IImGearScrollableView
frmWnd, int X_Pos, int Y_Pos)

Parameters:

Name
Type
Description
frmWnd
IImGearScrollableView Interface
IImGearScrollableView interface; represents .NET form to draw image in.
X_Pos
int
New horizontal scroll position.
Y_Pos
int
New vertical scroll position.

Return value:

Instance of ImGearScrollInfo Structure object.

See Also:

ImGearScrollInfo Structure

IImGearScrollableView Interface


UpdateLUT Method

32-bit
64-bit
CF
P
P
P

Description:

This method updates ImGearPageDisplay display look up table as follows:

  • If colorLUT is not NULL, it is duplicated into ImGearPageDisplay's LUT. colorLUT type and depths attributes must be compatible with ImGearPageDisplay's LUT.
  • If contrastSettings is not NULL, its values are used to update ImGearPageDisplay's LUT.

Declaration:

public void UpdateLUT ( ImageGear.Core.ImGearMultichannelLUT Class colorLUT,
ImageGear.Display.IImGearContrastSettings contrastSettings )

Parameters:

Name
Type
Description
colorLUT
ImGearMultichannelLUT Class
Multichannel look up table.
contrastSettings
IImGearContrastSettings Interface
Contrast settings.

Return value:

None.

See Also:

ImGearMultichannelLUT Class

IImGearContrastSettings Interface


UpdateScrollFrom Method

32-bit
64-bit
CF
P
P
P

Description:

This method updates image scroll attributes with new values.

Declaration:

public void UpdateScrollFrom(ImageGear.Display.IImGearScrollableView frmWnd,
ImageGear.Display.ImGearScrollInfo si)

Parameters:

Name
Type
Description
frmWnd
IImGearScrollableView Interface
IImGearScrollableView interface; represents .NET form to draw image in.
si
ImGearScrollInfo Structure
ImGearScrollInfo object with new attributes for vertical and horizontal scrollbars.

Return Value:

None

See Also:

IImGearScrollableView Interface

ImGearScrollInfo Structure


UpdateZoomFrom Method

32-bit
64-bit
CF
P
P
P

Description:

This method updates image zoom attributes.

Declaration:

public void UpdateZoomFrom(ImageGear.Display.ImGearZoomInfo zi)

Parameters:

Name
Type
Description
zi
ImGearZoomInfo Structure
ImGearZoomInfo object with new zoom attributes.

Return Value:

None

Sample Code:

C#
// Get the current Zoom settings
ImGearZoomInfo igZoomInfo =
    imGearPageView.Display.GetZoomInfo(imGearPageView);
// Change zoom to fixed to disable any current Fit modes.
igZoomInfo.Horizontal.Fixed = true;
igZoomInfo.Vertical.Fixed = true;
// Double the current zoom level.
igZoomInfo.Horizontal.Value *= 2;
igZoomInfo.Vertical.Value *= 2;
imGearPageView.Display.UpdateZoomFrom(igZoomInfo);
// Cause a redraw with the new zoom.
imGearPageView.Invalidate();

VB .NET
'Get the current Zoom settings
Dim igZoomInfo As ImGearZoomInfo = _
    ImGearPageView1.Display.GetZoomInfo(ImGearPageView1)
'Change zoom to fixed to disable any current Fit modes.
igZoomInfo.Horizontal.Fixed = True
igZoomInfo.Vertical.Fixed = True
'Double the current zoom level.
igZoomInfo.Horizontal.Value *= 2
igZoomInfo.Vertical.Value *= 2
ImGearPageView1.Display.UpdateZoomFrom(igZoomInfo)
'Cause a redraw with the new zoom.
ImGearPageView1.Invalidate()

See Also:

ImGearZoomInfo Structure


ZoomToRectangle Method

32-bit
64-bit
CF
P
P
P

Description:

This method performs zooming to specified device rectangle and returns new zoom information.

This method calculates the zoom and scroll values, so that the specified rectangle is fitted to ClipRect and zoom image is fitted to the rectangle calculated. For both horizontal and vertical zoom attributes, it sets ImGearZoomComponentInfo.Fixed field to true, calculates and modifies ImGearZoomComponentInfo.Value field, the horizontal and vertical scroll positions, and returns new instance of ImGearZoomInfo object with new zoom attributes.

Declaration:

public void ZoomToRectangle(ImageGear.Display.IImGearScrollableView frmWnd,
ImageGear.Core.ImGearRectangle rc)

Parameters:

Name
Type
Description
frmWnd
IImGearScrollableView Interface
ImGearZoomInfo object with new zoom attributes.
rc
ImGearRectangle Structure
Specified device rectangle.

Return value:

None.

Sample Code:

C#
// Variable to toggle if user is currently selecting an area.
private bool m_bZoomToRectSelect = false;
// Set of points defining the selected area.
private ImGearPoint[] igPointsZoomToRect;
// Color of selection box.
private Color m_SelectorColor = Color.White;
// Function to return appropriate height for a specific width
// based upon the size of a scrollable view.
private int GetHeight(IImGearScrollableView igScrollableView, int Width)
{
    return Width * igScrollableView.ClientRectangle.Height / igScrollableView.ClientRectangle.Width;
}
private void menuZoomToRect_Click(object sender, EventArgs e)
{
    // Menu item used to toggle if Zoom to Rectangle is on or not.
    menuZoomToRect.Checked = !menuZoomToRect.Checked;
}
private void imGearPageView1_MouseDown(object sender, System.Windows.Forms.MouseEventArgs e)
{
    if (menuZoomToRect.Checked)
    {
        // Enter Zoom to Rectangle selection mode.
        m_bZoomToRectSelect = true;
        // Create a new pair of points to define the rectangle,
        // setting the first point to the current position.
        igPointsZoomToRect = new ImGearPoint[2];
        igPointsZoomToRect[0].X = e.X;
        igPointsZoomToRect[0].Y = e.Y;
        // Register function to draw the selection rectangle.
        imGearPageView.RegisterAfterDraw(
            new ImGearPageView.AfterDraw(DrawSelector));
    }
}
private void imGearPageView1_MouseUp(object sender, System.Windows.Forms.MouseEventArgs e)
{
    if (m_bZoomToRectSelect)
    {
        // Leave Zoom to Rectangle selection mode.
        imGearPageView.RegisterAfterDraw(null);
        m_bZoomToRectSelect = false;
        // Record the second point of the zoom rectangle,
        // normalizing it to the view's aspect ratio.
        igPointsZoomToRect[1].X = e.X;
        igPointsZoomToRect[1].Y = igPointsZoomToRect[0].Y +
            GetHeight(imGearPageView, Math.Abs(igPointsZoomToRect[1].X - igPointsZoomToRect[0].X) + 1) - 1;
        // Create a rectangle based upon the 2 points.
        ImGearRectangle igRectangle = new ImGearRectangle(igPointsZoomToRect[0], igPointsZoomToRect[1]);
        // Cancel the zoom if it would be for a 0x0 or 1x1 rectangle.
        if (igRectangle.Width <= 1 || igRectangle.Height <= 1)
            return;
        // Zoom to the selected rectangle
        imGearPageView.Display.ZoomToRectangle(imGearPageView, igRectangle);
        imGearPageView.Invalidate();
        // Disable Zoom to Rectangle.
        menuZoomToRect.Checked = false;
    }
}
private void imGearPageView1_MouseMove(object sender, System.Windows.Forms.MouseEventArgs e)
{
    if (m_bZoomToRectSelect)
    {
        // Record the second point of the zoom rectangle,
        // normalizing it to the view's aspect ratio.
        igPointsZoomToRect[1].X = e.X;
        igPointsZoomToRect[1].Y = igPointsZoomToRect[0].Y +
            GetHeight(imGearPageView, Math.Abs(igPointsZoomToRect[1].X - igPointsZoomToRect[0].X) + 1) - 1;
        // Cause a redraw which will update the zoom selection rectangle.
        imGearPageView.Invalidate();
    }
}
private void DrawSelector(System.Drawing.Graphics gr)
{
    if (m_bZoomToRectSelect)
    {
        // Create a new pen to draw dotted lines.
        Pen pen = new Pen(m_SelectorColor);
        pen.DashStyle = DashStyle.Dot;
        // Define the currently selected zoom rectangle.
        ImGearRectangle igRectangleZoom = new ImGearRectangle(igPointsZoomToRect[0], igPointsZoomToRect[1]);
        // Draw the selection box.
        gr.DrawRectangle(pen, igRectangleZoom.Left, igRectangleZoom.Top,
            igRectangleZoom.Width, igRectangleZoom.Height);
    }
}

VB .NET
'Variable to toggle if user is currently selecting an area.
Private m_bZoomToRectSelect As Boolean = False
'Set of points defining the selected area.
Private igPointsZoomToRect() As ImGearPoint
'Color of selection box.
Private m_SelectorColor As Color = Color.White
'Function to return appropriate height for a specific width
' based upon the size of a scrollable view.
Private Function GetHeight(ByVal igScrollableView As IImGearScrollableView, ByVal Width As Integer) As Integer
    GetHeight = Width * igScrollableView.ClientRectangle.Height / igScrollableView.ClientRectangle.Width
End Function
Private Sub menuZoomtoRect_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) _
                Handles menuZoomtoRect.Click
    menuZoomtoRect.Checked = Not menuZoomtoRect.Checked
End Sub
Private Sub ImGearPageView1_MouseDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) _
                Handles ImGearPageView1.MouseDown
    If (menuZoomtoRect.Checked) Then
        'Enter Zoom to Rectangle selection mode.
        m_bZoomToRectSelect = True
        'Create a new pair of points to define the rectangle,
        ' setting the first point to the current position.
        ReDim igPointsZoomToRect(2)
        igPointsZoomToRect(0).X = e.X
        igPointsZoomToRect(0).Y = e.Y
        'Register function to draw the selection rectangle.
        ImGearPageView1.RegisterAfterDraw( _
            New ImGearPageView.AfterDraw(AddressOf DrawSelector))
    End If
End Sub
Private Sub ImGearPageView1_MouseUp(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) _
                Handles ImGearPageView1.MouseUp
    If (m_bZoomToRectSelect) Then
        'Leave Zoom to Rectangle selection mode.
        ImGearPageView1.RegisterAfterDraw(Nothing)
        m_bZoomToRectSelect = False
        'Record the second point of the zoom rectangle,
        ' normalizing it to the view's aspect ratio.
        igPointsZoomToRect(1).X = e.X
        igPointsZoomToRect(1).Y = igPointsZoomToRect(0).Y + _
            GetHeight(ImGearPageView1, Math.Abs(igPointsZoomToRect(1).X - igPointsZoomToRect(0).X) + 1) - 1
        'Create a rectangle based upon the 2 points.
        Dim igRectangle As ImGearRectangle = New ImGearRectangle(igPointsZoomToRect(0), igPointsZoomToRect(1))
        'Cancel the zoom if it would be for a 0x0 or 1x1 rectangle.
        If (igRectangle.Width <= 1 Or igRectangle.Height <= 1) Then
            Return
        End If
        'Zoom to the selected rectangle
        ImGearPageView1.Display.ZoomToRectangle(ImGearPageView1, igRectangle)
        ImGearPageView1.Invalidate()
        'Disable Zoom to Rectangle.
        menuZoomtoRect.Checked = False
    End If
End Sub
Private Sub ImGearPageView1_MouseMove(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) _
                Handles ImGearPageView1.MouseMove
    If (m_bZoomToRectSelect) Then
        'Record the second point of the zoom rectangle,
        ' normalizing it to the view's aspect ratio.
        igPointsZoomToRect(1).X = e.X
        igPointsZoomToRect(1).Y = igPointsZoomToRect(0).Y + _
            GetHeight(ImGearPageView1, Math.Abs(igPointsZoomToRect(1).X - igPointsZoomToRect(0).X) + 1) - 1
        'Cause a redraw which will update the zoom selection rectangle.
        ImGearPageView1.Invalidate()
    End If
End Sub
Private Sub DrawSelector(ByVal gr As System.Drawing.Graphics)
    If (m_bZoomToRectSelect) Then
        'Create a new pen to draw dotted lines.
        Dim pen As Pen = New Pen(m_SelectorColor)
        Pen.DashStyle = DashStyle.Dot
        'Define the currently selected zoom rectangle.
        Dim igRectangleZoom As ImGearRectangle = New ImGearRectangle(igPointsZoomToRect(0), igPointsZoomToRect(1))
        'Draw the selection box.
        gr.DrawRectangle(pen, igRectangleZoom.Left, igRectangleZoom.Top, igRectangleZoom.Width, igRectangleZoom.Height)
    End If
End Sub

See Also:

IImGearScrollableView Interface

ImGearRectangle Structure


ImGearPageDisplayConverter Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides methods that override methods of the TypeConverter.

Declaration:

public class ImGearPageDisplayConverter : System.ComponentModel.TypeConverter

Members:

Constructors
Name
Description
ImGearPageDisplayConverter Constructor
Creates the new instance of ImGearPageDisplayConverter Class.

Methods
Name
Description
CanConvertFrom Method
Overrides the CanConvertFrom method of TypeConverter.
ConvertFrom Method
Overrides the ConvertFrom method of TypeConverter.
ConvertTo Method
Overrides the ConvertTo method of TypeConverter.


ImGearPageDisplayConverter Constructors

The ImGearPageDisplayConverter Class of the ImageGear.Display Namespace has the following constructors:

Constructors
Name
Description
ImGearPageDisplayConverter Constructor
Creates the new instance of ImGearPageDisplayConverter Class.


ImGearPageDisplayConverter Constructor

32-bit
64-bit
CF
P
P
P

Description:

Creates the new instance of ImGearPageDisplayConverter Class and initializes it.

Declaration:

public ImGearPageDisplayConverter()

Return Value:

The new instance of ImGearPageDisplayConverter Class.

See Also:

ImGearPageDisplayConverter Class


ImGearPageDisplayConverter Methods

The ImGearPageDisplayConverter Class of the ImageGear.Display Namespace has the following methods:

Methods
Name
Description
CanConvertFrom Method
Overrides the CanConvertFrom method of TypeConverter.
ConvertFrom Method
Overrides the ConvertFrom method of TypeConverter.
ConvertTo Method
Overrides the ConvertTo method of TypeConverter.


CanConvertFrom Method

32-bit
64-bit
CF
P
P
P

Description:

This method overrides the CanConvertFrom method of TypeConverter. The ITypeDescriptorContext interface provides the context for the conversion. Typically, this interface is used at design time to provide information about the design-time container.

Declaration:

public override bool CanConvertFrom(System.ComponentModel.ITypeDescriptorContext context,
System.Type sourceType)

Parameters:

Name
Type
Description
context
ITypeDescriptorContext
An ITypeDescriptorContext object that provides a format context. You can use this object to get additional information about the environment from which this converter is being invoked.
sourceType
System.Type
The type from which you want to convert.

Return Value:

This method returns true if this object can perform the conversion; otherwise, false.

See Also:

ImGearPageDisplayConverter Class

ImGearPageDisplay Class


ConvertFrom Method

32-bit
64-bit
CF
P
P
P

Description:

This method overrides the ConvertFrom method of TypeConverter.

Declaration:

public override object ConvertFrom(System.ComponentModel.ITypeDescriptorContext context,
System.Globalization.CultureInfo culture, object value)

Parameters:

Name
Type
Description
context
ITypeDescriptorContext
An TypeDescriptor object that provides a format context. You can use this object to get additional information about the environment from which this converter is being invoked.
culture
System.Globalization.CultureInfo
A CultureInfo object that specifies the culture to represent the Color.
value
object
The object to convert.

Return Value:

The converted object. This method will throw an exception if the conversion could not be performed.

See Also:

ImGearPageDisplayConverter Class

ImGearPageDisplay Class


ConvertTo Method

32-bit
64-bit
CF
P
P
P

Description:

This method overrides the ConvertTo method of TypeConverter.

Declaration:

public override object ConvertTo(System.ComponentModel.ITypeDescriptorContext context,
System.Globalization.CultureInfo culture, object value, System.Type destinationType)

Parameters:

Name
Type
Description
context
ITypeDescriptorContext
A formatter context. Use this object to extract additional information about the environment from which this converter is being invoked. Always check whether this value is null. Also, properties on the context object may also return null.
culture
System.Globalization.CultureInfo
A CultureInfo object that specifies the culture to represent the Color.
value
object
The object to convert.
destinationType
System.Type
The type to convert the object to.

Return Value:

The converted object. If this method cannot convert to the destination type, it throws a NotSupportedException.

See Also:

ImGearPageDisplayConverter Class

ImGearPageDisplay Class


ImGearScrollComponentInfoConverter Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides methods that overrides methods of the TypeConverter.

Declaration:

public class ImGearScrollComponentInfoConverter : System.ComponentModel.TypeConverter

Members:

Constructors
Name
Description
ImGearScrollComponentInfoConverter Constructor
Creates the new instance of ImGearScrollComponentInfoConverter Class.

Methods
Name
Description
CanConvertFrom Method
Overrides the CanConvertFrom method of TypeConverter.
ConvertFrom Method
Overrides the ConvertFrom method of TypeConverter.
ConvertTo Method
Overrides the ConvertTo method of TypeConverter.


ImGearScrollComponentInfoConverter Constructors

The ImGearScrollComponentInfoConverter Class of the ImageGear.Display Namespace has the following constructors:

Constructors
Name
Description
ImGearScrollComponentInfoConverter Constructor
Creates the new instance of ImGearScrollComponentInfoConverter Class.


ImGearScrollComponentInfoConverter Constructor

32-bit
64-bit
CF
P
P
P

Description:

Creates the new instance of ImGearScrollComponentInfoConverter Class and initializes it.

Declaration:

public ImGearScrollComponentInfoConverter()

Return Value:

The new instance of ImGearScrollComponentInfoConverter Class.

See Also:

ImGearScrollComponentInfoConverter Class


ImGearScrollComponentInfoConverter Methods

The ImGearScrollComponentInfoConverter Class of the ImageGear.Display Namespace has the following methods:

Methods
Name
Description
CanConvertFrom Method
Overrides the CanConvertFrom method of TypeConverter.
ConvertFrom Method
Overrides the ConvertFrom method of TypeConverter.
ConvertTo Method
Overrides the ConvertTo method of TypeConverter.


CanConvertFrom Method

32-bit
64-bit
CF
P
P
P

Description:

This method overrides the CanConvertFrom method of TypeConverter. The ITypeDescriptorContext interface provides the context for the conversion. Typically, this interface is used at design time to provide information about the design-time container.

Declaration:

public override bool CanConvertFrom(System.ComponentModel.ITypeDescriptorContext context,
System.Type sourceType)

Parameters:

Name
Type
Description
context
ITypeDescriptorContext
An ITypeDescriptorContext object that provides a format context. You can use this object to get additional information about the environment from which this converter is being invoked.
sourceType
System.Type
The type from which you want to convert.

Return Value:

This method returns true if this object can perform the conversion; otherwise, false.

See Also:

ImGearScrollComponentInfoConverter Class

ImGearScrollComponentInfo Structure


ConvertFrom Method

32-bit
64-bit
CF
P
P
P

Description:

This method overrides the ConvertFrom method of TypeConverter.

Declaration:

public override object ConvertFrom(System.ComponentModel.ITypeDescriptorContext context,
System.Globalization.CultureInfo culture, object value)

Parameters:

Name
Type
Description
context
ITypeDescriptorContext
An TypeDescriptor object that provides a format context. You can use this object to get additional information about the environment from which this converter is being invoked.
culture
System.Globalization.CultureInfo
A CultureInfo object that specifies the culture to represent the Color.
value
object
The object to convert.

Return Value:

The converted object. This method will throw an exception if the conversion could not be performed.

See Also:

ImGearScrollComponentInfoConverter Class

ImGearScrollComponentInfo Structure


ConvertTo Method

32-bit
64-bit
CF
P
P
P

Description:

This method overrides the ConvertTo method of TypeConverter.

Declaration:

public override object ConvertTo(System.ComponentModel.ITypeDescriptorContext context,
System.Globalization.CultureInfo culture, object value, System.Type destinationType)

Parameters:

Name
Type
Description
context
ITypeDescriptorContext
A formatter context. Use this object to extract additional information about the environment from which this converter is being invoked. Always check whether this value is null. Also, properties on the context object may also return null.
culture
System.Globalization.CultureInfo
A CultureInfo object that specifies the culture to represent the Color.
value
object
The object to convert.
destinationType
System.Type
The type to convert the object to.

Return Value:

The converted object. If this method cannot convert to the destination type, it throws a NotSupportedException.

See Also:

ImGearScrollComponentInfoConverter Class

ImGearScrollComponentInfo Structure


ImGearZoomInfoConverter Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides methods that override methods of the TypeConverter.

Declaration:

public class ImGearZoomInfoConverter : System.ComponentModel.TypeConverter

Members:

Constructors
Name
Description
ImGearZoomInfoConverter Constructor
Creates the new instance of ImGearZoomInfoConverter Class.

Methods
Name
Description
CanConvertFrom Method
Overrides the CanConvertFrom method of TypeConverter.
ConvertFrom Method
Overrides the ConvertFrom method of TypeConverter.
ConvertTo Method
Overrides the ConvertTo method of TypeConverter.


ImGearZoomInfoConverter Constructors

The ImGearZoomInfoConverter Class of the ImageGear.Display Namespace has the following constructors:

Constructors
Name
Description
ImGearZoomInfoConverter Constructor
Creates the new instance of ImGearZoomInfoConverter Class.


ImGearZoomInfoConverter Constructor

32-bit
64-bit
CF
P
P
P

Description:

Creates the new instance of ImGearZoomInfoConverter Class and initializes it.

Declaration:

public ImGearZoomInfoConverter()

Return Value:

The new instance of ImGearZoomInfoConverter Class.

See Also:

ImGearZoomInfoConverter Class


ImGearZoomInfoConverter Methods

The ImGearZoomInfoConverter Class of the ImageGear.Display Namespace has the following methods:

Methods
Name
Description
CanConvertFrom Method
Overrides the CanConvertFrom method of TypeConverter.
ConvertFrom Method
Overrides the ConvertFrom method of TypeConverter.
ConvertTo Method
Overrides the ConvertTo method of TypeConverter.


CanConvertFrom Method

32-bit
64-bit
CF
P
P
P

Description:

This method overrides the CanConvertFrom method of TypeConverter. The ITypeDescriptorContext interface provides the context for the conversion. Typically, this interface is used at design time to provide information about the design-time container.

Declaration:

public override bool CanConvertFrom(System.ComponentModel.ITypeDescriptorContext context,
System.Type sourceType)

Parameters:

Name
Type
Description
context
ITypeDescriptorContext
An ITypeDescriptorContext object that provides a format context. You can use this object to get additional information about the environment from which this converter is being invoked.
sourceType
System.Type
The type from which you want to convert.

Return Value:

This method returns true if this object can perform the conversion; otherwise, false.

See Also:

ImGearZoomInfoConverter Class

ImGearZoomInfo Structure


ConvertFrom Method

32-bit
64-bit
CF
P
P
P

Description:

This method overrides the ConvertFrom method of TypeConverter.

Declaration:

public override object ConvertFrom(System.ComponentModel.ITypeDescriptorContext context,
System.Globalization.CultureInfo culture, object value)

Parameters:

Name
Type
Description
context
ITypeDescriptorContext
A TypeDescriptor object that provides a format context. You can use this object to get additional information about the environment from which this converter is being invoked.
culture
System.Globalization.CultureInfo
A CultureInfo object that specifies the culture to represent the Color.
value
object
The object to convert.

Return Value:

The converted object. This method will throw an exception if the conversion could not be performed.

See Also:

ImGearZoomInfoConverter Class

ImGearZoomInfo Structure


ConvertTo Method

32-bit
64-bit
CF
P
P
P

Description:

This method overrides the ConvertTo method of TypeConverter.

Declaration:

public override object ConvertTo(System.ComponentModel.ITypeDescriptorContext context,
System.Globalization.CultureInfo culture, object value, System.Type destinationType)

Parameters:

Name
Type
Description
context
ITypeDescriptorContext
A formatter context. Use this object to extract additional information about the environment from which this converter is being invoked. Always check whether this value is null. Also, properties on the context object may also return null.
culture
System.Globalization.CultureInfo
A CultureInfo object that specifies the culture to represent the Color.
value
object
The object to convert.
destinationType
System.Type
The type to convert the object to.

Return Value:

The converted object. If this method cannot convert to the destination type, it throws a NotSupportedException.

See Also:

ImGearZoomInfoConverter Class

ImGearZoomInfo Structure


ImageGear.Display Namespace Interfaces

The ImageGear.Display Namespace has the following interface members:

Interfaces:
Name
Description
IImGearAlignment Interface
Provides methods to access image alignment settings.
IImGearAntiAlias Interface
Provides methods to access image aliasing settings.
IImGearAspectRatio Interface
Provides methods to access aspect ratio settings of image.
IImGearBackground Interface
Provides methods to access display background parameters.
IImGearColorAntiAlias Interface
This is an interface for color anti-aliasing attributes.
IImGearContrastSettings Interface
Contrast settings interface used by ImGearPageDisplay.UpdateLUT method.
IImGearDisplayObject Interface
Base interface implemented in several display code structures.
IImGearLayout Interface
Provides methods to access image layout settings.
IImGearResample Interface
This is an interface for re-sampling attributes.
IImGearScrollableView Interface
IG display code interacts with .NET windows and forms via this interface.


IImGearAlignment Interface

32-bit
64-bit
CF
P
P
P

Description:

This interface provides access to image display alignment modes.

Declaration:

public interface IImGearAlignment

Members:

Properties
Name
Description
Horizontal Property
Horizontal alignment mode.
Vertical Property
Vertical alignment mode.


IImGearAlignment Properties

The IImGearAlignment Interface of the ImageGear.Display Namespace has the following properties:

Properties
Name
Description
Horizontal Property
Horizontal alignment mode.
Vertical Property
Vertical alignment mode.


Horizontal Property

32-bit
64-bit
CF
P
P
P

Description:

Image horizontal alignment mode stored in this property.

Declaration:

public ImageGear.Display.ImGearAlignmentHModes Horizontal { get;  set; }

Value:

ImGearAlignmentHModes Enumeration values.

See Also:

ImGearAlignmentHModes Enumeration


Vertical Property

32-bit
64-bit
CF
P
P
P

Description:

Image vertical alignment mode stored in this property.

Declaration:

public ImageGear.Display.ImGearAlignmentVModes Vertical { get;  set; }

Value:

ImGearAlignmentVModes Enumeration values.

See Also:

ImGearAlignmentVModes Enumeration


IImGearAntiAlias Interface

32-bit
64-bit
CF
P
P
P

Description:

This interface is used to access display anti-aliasing settings.

Declaration:

public interface IImGearAntiAlias

Members:

Properties
Name
Description
Method Property
Anti-aliasing method.
Threshold Property
Threshold parameter used by several anti-aliasing methods.


IImGearAntiAlias Properties

The IImGearAntiAlias Interface of the ImageGear.Display Namespace has the following properties:

Properties
Name
Description
Method Property
Anti-aliasing method.
Threshold Property
Threshold parameter used by several anti-aliasing methods.


Method Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the image anti-aliasing method to use. This mode is applicable only if a 1-bit-per-pixel image is to be drawn and if the destination image has a lower resolution than the original one.

Declaration:

public ImageGear.Display.ImGearAliasModes Method { get;  set; }

Value:

ImGearAliasModes Enumeration value.

See Also:

ImGearAliasModes Enumeration


Threshold Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies image aliasing threshold attribute (a threshold integer value from 0 to 100). Its meaning depends on the Method value:

If Method is set to ImGearAliasModes.SCALE_TO_GRAY, Threshold determines the number of black and white pixels in the destination gray pixel value. A value of 100 directs ImageGear to take 100% of white pixels. A value of 0 directs ImageGear to take 100% of black pixels. The default value, which is 50, directs ImageGear to take 50% white and 50% black pixels.

If Method is set to ImGearAliasModes.PRESERVE_BLACK, Threshold determines the number of black pixels to preserve. A value of 100 means that 100% of the black pixels are preserved. The default value is 50.

If Method is set to ImGearAliasModes.PRESERVE_WHITE, Threshold determines the number of white pixels to preserve. A value of 100 means that 100% of white pixels are preserved. The default value is 50.

Declaration:

public Int Threshold { get; set }

Value:

Integer in range [0..100]

See Also:

ImGearAliasModes Enumeration

Method Property


IImGearAspectRatio Interface

32-bit
64-bit
CF
P
P
P

Description:

This interface is used to operate with image aspect ratio attributes.

Declaration:

public interface IImGearAspectRatio

Members:

Properties
Name
Description
Fixed Property
Aspect ratio mode.
Value Property
Aspect ratio value.


IImGearAspectRatio Properties

The IImGearAspectRatio Interface of the ImageGear.Display Namespace has the following properties:

Properties
Name
Description
Fixed Property
Aspect ratio mode.
Value Property
Aspect ratio value.


Fixed Property

32-bit
64-bit
CF
P
P
P

Description:

This property identifies the different types of image display aspect ratio (i.e., width-to-height ratio).

Fixed set to true indicates that the aspect ratio is specified by Value Field parameter.

Value false indicates that the aspect ratio is specified by the device rectangle.

Declaration:

public bool Fixed { get; set }

Value:

True, False

See Also:

Value Field


Value Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies image's display aspect ratio (i.e., width-to-height ratio).

When Fixed Field, field is set to true. This field value specifies image aspect ratio. Otherwise, it is ignored.

Declaration:

public double Value { get; set }

Value:

Double value.

See Also:

Fixed Field


IImGearBackground Interface

32-bit
64-bit
CF
P
P
P

Description:

This interface provides access to image display background attributes. There are no objects implementing this interface. It is accessed via Background Property of ImGearPageDisplay Class.

Declaration:

public interface IImGearBackground

Members:

Properties
Name
Description
Color Property
Background color.
Mode Property
Background drawing mode.


IImGearBackground Properties

The IImGearBackground Interface of the ImageGear.Display Namespace has the following properties:

Properties
Name
Description
Color Property
Background color.
Mode Property
Background drawing mode.


Color Property

32-bit
64-bit
CF
P
P
P

Description:

Background color of displayed image. Area on screen not covered by image is filled with this color.

Declaration:

public ImageGear.Core.IImGearRGBQuad Color { get; }

Value:

ImGearRGBQuad Structure object interface.

See Also:

ImGearRGBQuad Structure


Mode Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets/sets background drawing mode.

Declaration:

public ImageGear.Display.ImGearBackgroundModes Mode { get;  set; }

Value:

  • ImGearBackgroundModes Enumeration .NONE - do not draw background
  • ImGearBackgroundModes Enumeration .BEYOND_IMAGE - fill device rectangle with background color before image drawing

See Also:

ImGearBackgroundModes Enumeration


IImGearColorAntiAlias Interface

32-bit
64-bit
CF
P
P
P

Description:

This is an interface for color anti-aliasing attributes.

Declaration:

public interface IImGearColorAntiAlias

Members:

Properties
Name
Description
Method Property
Specifies the color anti-aliasing method to use.


IImGearColorAntiAlias Properties

The IImGearColorAntiAlias Interface of the ImageGear.Display Namespace has the following properties:

Properties
Name
Description
Method Property
Specifies the color anti-aliasing method to use.


Method Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the color anti-aliasing method to use. This mode is applicable only if a non 1-bit-per-pixel image is to be drawn and if the destination image has a lower resolution than the original one, i.e., when the image is zoomed out.

Declaration:

public ImageGear.Display.ImGearColorAliasModes Method { get;  set; }

Value:

ImGearColorAliasModes Enumeration value.

See Also:

ImGearColorAliasModes Enumeration


IImGearContrastSettings Interface

32-bit
64-bit
CF
P
P
P

Description:

Contrast settings interface used by ImGearPageDisplay.UpdateLUT method.

Declaration:

public interface IImGearContrastSettings

Members:

Properties
Name
Description
Brightness Property
Brightness attribute.
Contrast Property
Contrast attribute.
Gamma Property
Gamma attribute.

See Also:

ImGearContrastSettings Structure


IImGearContrastSettings Properties

The IImGearContrastSettings Interface of the ImageGear.Display Namespace has the following properties:

Properties
Name
Description
Brightness Property
Brightness attribute.
Contrast Property
Contrast attribute.
Gamma Property
Gamma attribute.


Brightness Property

32-bit
64-bit
CF
P
P
P

Description:

Brightness attribute.

Declaration:

public double Brightness { get;  set; }

Value:

Double value

See Also:

IImGearContrastSettings Interface


Contrast Property

32-bit
64-bit
CF
P
P
P

Description:

Contrast attribute.

Declaration:

public double Contrast { get;  set; }

Value:

Double value

See Also:

IImGearContrastSettings Interface


Gamma Property

32-bit
64-bit
CF
P
P
P

Description:

Gamma attribute.

Declaration:

public double Gamma { get;  set; }

Value:

Double value

See Also:

IImGearContrastSettings Interface


IImGearDisplayObject Interface

32-bit
64-bit
CF
P
P
P

Description:

Base interface for display API objects. Implemented in several display code structures.

Declaration:

public interface IImGearDisplayObject

Members:

Methods
Name
Description
CopyFrom Method
Make the current object equal with one passed to this function.
InitToDefault Method
Initialize object to its default value.


IImGearDisplayObject Methods

The IImGearDisplayObject Interface of the ImageGear.Display Namespace has the following methods:

Methods
Name
Description
CopyFrom Method
Make the current object equal with one passed to this function.
InitToDefault Method
Initialize object to its default value.


CopyFrom Method

32-bit
64-bit
CF
P
P
P

Description:

This method duplicates existing object. Source and destination objects must be of the same type and implements IImGearDisplayObject Interface interface.

Declaration:

void CopyFrom(ImageGear.Display.IImGearDisplayObject src)

Parameters:

Name
Type
Description
src
IImGearDisplayObject Interface
Source object to copy.

Return Value:

None.

See Also:

IImGearDisplayObject Interface


InitToDefault Method

32-bit
64-bit
CF
P
P
P

Description:

Initialize object to default value. This method has been introduced to complement default structure constructor (that cannot be overloaded).

Declaration:

public void InitToDefault ( )

Return Value:

None.

See Also:

IImGearDisplayObject Interface


IImGearLayout Interface

32-bit
64-bit
CF
P
P
P

Description:

This interface provides access to image display layout attributes. There are no objects implementing this interface. It is accessed via Layout property of ImGearPageDisplay object.

Declaration:

public interface IImGearLayout

Members:

Properties
Name
Description
Alignment Property
Image alignment.
AspectRatio Property
Image aspect ratio.
ClipRect Property
Clipping rectangle.
DeviceRect Property
Device rectangle.
FitMode Property
Image fit mode.
ImageRect Property
Image rectangle.
UseImageResolution Property
Flag specifying whether to use image resolution or not.


IImGearLayout Properties

The IImGearLayout Interface of the ImageGear.Display Namespace has the following properties:

Properties
Name
Description
Alignment Property
Image alignment.
AspectRatio Property
Image aspect ratio.
ClipRect Property
Clipping rectangle.
DeviceRect Property
Device rectangle.
FitMode Property
Image fit mode.
ImageRect Property
Image rectangle.
UseImageResolution Property
Flag specifying whether to use image resolution or not.


Alignment Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides access to image alignment attributes. Value returned is a reference to IImGearLayout internal object.

Declaration:

public ImageGear.Display.IImGearAlignment Alignment { get; }

Value:

IImGearAlignment Interface

See Also:

IImGearAlignment Interface


AspectRatio Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides access to image aspect ratio attributes. Value returned is a reference to IImGearLayout internal object.

Declaration:

public ImageGear.Display.IImGearAspectRatio AspectRatio { get; }

Value:

IImGearAspectRatio Interface

See Also:

IImGearAspectRatio Interface


ClipRect Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides access to image clip rectangle attribute. Value returned is a reference to IImGearLayout internal object.

See the section Displaying Images.

Declaration:

public ImageGear.Core.IImGearRectangle ClipRect { get; }

Value:

ImGearRectangle Structure object interface.

See Also:

ImGearRectangle Structure


DeviceRect Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides access to device rectangle attribute. Value returned is a reference to IImGearLayout internal object.

See the section Displaying Images

Declaration:

public ImageGear.Core.IImGearRectangle DeviceRect { get; }

Value:

ImGearRectangle Structure object interface.

See Also:

ImGearRectangle Structure


FitMode Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets/sets image fit mode.

Declaration:

public ImageGear.Core.ImGearFitModes FitMode { get; set }

Value:

ImGearFitModes Enumeration values.

See Also:

ImGearFitModes Enumeration


ImageRect Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides access to image rectangle attribute. Value returned is a reference to IImGearLayout internal object.

Declaration:

public ImageGear.Core.IImGearRectangle ImageRect { get; }

Value:

ImGearRectangle Structure object interface.

See Also:

ImGearRectangle Structure


UseImageResolution Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies whether or not the image resolution attribute affects displaying.

Declaration:

public bool UseImageResolution { get; set }

Value:

True, False.

See Also:

IImGearLayout Interface


IImGearResample Interface

32-bit
64-bit
CF
P
P
P

Description:

This is an interface for re-sampling attributes.

Declaration:

public interface IImGearResample

Members:

Properties
Name
Description
Method Property
Specifies re-sampling method to use.


IImGearResample Properties

The IImGearResample Interface of the ImageGear.Display Namespace has the following properties:

Properties
Name
Description
Method Property
Specifies re-sampling method to use.


Method Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the re-sampling method to use. This mode is applicable for all bit depths if the destination image has a higher resolution than the original one, i.e., when the image is zoomed in.

Declaration:

public ImageGear.Display.ImGearResampleModes Method { get;  set; }

Value:

ImGearResampleModes Enumeration value.

See Also:

ImGearResampleModes Enumeration


IImGearScrollableView Interface

32-bit
64-bit
CF
P
P
P

Description:

This interface is designed to separate IG display API from .NET windows and forms. It is used to obtain all information required by IG display code and to modify some attributes of underlying window (scroll bar states actually). Any object implementing this interface can be used.

Null value can also be specified. In this case all required information will be obtained from Graphics object. In all calls, display API call IImGearScrollableView parameter is accompanied with Graphics object.

To draw on printer, Graphics null value should be passed as value of IImGearScrollableView variable.

Declaration:

public interface IImGearScrollableView

Members:

Properties
Name
Description
ClientRectangle Property
Returns client rectangle within whole windows client area.

Methods
Name
Description
GetScrollBarDimensions Method
Returns dimensions of scrollbar associated with window.
GetScrollParams Method
Return attributes of scroll bar.
IsScrollBarVisible Method
Returns visibility attribute of scroll bar.
SetScrollParams Method
Updates scroll bar attributes.
ShowScrollBar Method
Show or hide windows scroll.


IImGearScrollableView Properties

The IImGearScrollableView Interface of the ImageGear.Display Namespace has the following properties:

Properties
Name
Description
ClientRectangle Property
Returns client rectangle within whole windows client area.


ClientRectangle Property

32-bit
64-bit
CF
P
P
P

Description:

This property returns the rectangle ImageGear display code that should be used as the client area rectangle.

Declaration:

public ImageGear.Core.ImGearRectangle ClientRectangle { get; }

Value:

ImGearRectangle Structure object.

See Also:

ImGearRectangle Structure


IImGearScrollableView Methods

The IImGearScrollableView Interface of the ImageGear.Display Namespace has the following methods:

Methods
Name
Description
GetScrollBarDimensions Method
Returns dimensions of scrollbar associated with window.
GetScrollParams Method
Return attributes of scroll bar.
IsScrollBarVisible Method
Returns visibility attribute of scroll bar.
SetScrollParams Method
Updates scroll bar attributes.
ShowScrollBar Method
Show or hide windows scroll.


GetScrollBarDimensions Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns width and height dimensions of the windows scroll bar.

Declaration:

public ImageGear.Core.ImGearSize GetScrollBarDimensions
(ImageGear.Core.ImGearScrollBarType sbType)

Parameters:

Name
Type
Description
sbType
ImGearScrollBarType Enumeration
Specifies the scrollbar whose attributes are requested.

Return Value:

ImGearSize Structure.

See Also:

ImGearScrollBarType Enumeration

ImGearSize Structure


GetScrollParams Method

32-bit
64-bit
CF
P
P
P

Description:

This method obtains the attributes of the scrollbar specified.

Declaration:

public void GetScrollParams (ImageGear.Core.ImGearScrollBarType sbType, ref
ImageGear.Core.ImGearScrollInfo SI)

Parameters:

Name
Type
Description
sbType
ImGearScrollBarType Enumeration
Specifies the scrollbar whose attributes are requested.
SI
ImGearScrollInfo Structure
Output parameter; horizontal or vertical field of this parameter is updated with requested information.

Return Value:

None.

See Also:

ImGearScrollBarType Enumeration

ImGearScrollInfo Structure


IsScrollBarVisible Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns visibility state of the scrollbar specified.

Declaration:

public System.Boolean IsScrollBarVisible (ImageGear.Core.ImGearScrollBarType sbType)

Parameters:

Name
Type
Description
sbType
ImGearScrollBarType Enumeration
Specifies the scrollbar whose attributes are requested.

Return Value:

True or False.

See Also:

ImGearScrollBarType Enumeration


SetScrollParams Method

32-bit
64-bit
CF
P
P
P

Description:

This method updates the state of specified scrollbar with new values.

Declaration:

public void SetScrollParams (ImageGear.Core.ImGearScrollBarType sbType,
ImageGear.Core.ImGearScrollInfo SI, bool bReadraw)

Parameters:

Name
Type
Description
sbType
ImGearScrollBarType Enumeration
Specifies the scrollbar whose attributes are requested.
SI
ImGearScrollInfo Structure
New scrollbar state.
bReadraw
bool
Specifies whether or not to redraw image in window.

Return Value:

None

See Also:

ImGearScrollBarType Enumeration

ImGearScrollInfo Structure


ShowScrollBar Method

32-bit
64-bit
CF
P
P
P

Description:

Change visibility state of scrollbars associated with window.

Declaration:

public void ShowScrollBar (ImageGear.Core.ImGearScrollBarType sbType, bool bState)

Parameters:

Name
Type
Description
sbType
ImGearScrollBarType Enumeration
Specifies the scrollbar whose attributes are requested.
bState
bool
Show (true) or hide (false) scrollbar.

Return Value:

None.

See Also:

ImGearScrollBarType Enumeration


ImageGear.Display Namespace Structures

The ImageGear.Display Namespace has the following structure members:

Classes:
Name
Description
ImGearContrastSettings Structure
Contrast settings structure used by ImGearPageDisplay.UpdateLUT method.
ImGearScrollComponentInfo Structure
Structure used to implement state of one scroll bar.
ImGearScrollInfo Structure
Implements image scrolling information (state of two scrolbars).
ImGearZoomComponentInfo Structure
Simple auxiliary structure used in ImGearZoomInfo.
ImGearZoomInfo Structure
Implements image zoom information for horizontal and vertical zoom.


ImGearContrastSettings Structure

32-bit
64-bit
CF
P
P
P

Description:

Contrast settings structure used by ImGearPageDisplay.UpdateLUT method.

Declaration:

public struct ImGearContrastSettings

Members:

Constructors
Name
Description
ImGearContrastSettings Constructor
Creates the new instance of ImGearContrastSettings Structure and initializes it.

Properties
Name
Description
Brightness Property
Brightness attribute.
Contrast Property
Contrast attribute.
Gamma Property
Gamma attribute.

Methods
Name
Description
CopyFrom Method
Initializes ImGearContrastSettings structure from src attributes.
CreateDefault Method
Creates ImGearContrastSettings Structure.

See Also:

IImGearContrastSettings Interface


ImGearContrastSettings Constructors

The ImGearContrastSettings Structure of the ImageGear.Display Namespace has the following constructors:

Constructors
Name
Description
ImGearContrastSettings Constructor
Creates the new instance of ImGearContrastSettings Structure and initializes it.


ImGearContrastSettings Constructor

32-bit
64-bit
CF
P
P
P

Description:

Creates the new instance of ImGearContrastSettings Structure and initializes it.

Declaration:

public ImGearContrastSettings()

Return Value:

The new instance of ImGearContrastSettings Structure.

See Also:

ImGearContrastSettings Structure


ImGearContrastSettings Properties

The ImGearContrastSettings Structure of the ImageGear.Display Namespace has the following properties:

Properties
Name
Description
Brightness Property
Brightness attribute.
Contrast Property
Contrast attribute.
Gamma Property
Gamma attribute.


ImGearContrastSettings Methods

The ImGearContrastSettings Structure of the ImageGear.Display Namespace has the following methods:

Methods
Name
Description
CopyFrom Method
Initializes ImGearContrastSettings structure from src attributes.
CreateDefault Method
Creates ImGearContrastSettings Structure.


CopyFrom Method

32-bit
64-bit
CF
P
P
P

Description:

This method initializes ImGearContrastSettings structure from src attributes.

Declaration:

public void CopyFrom(ImageGear.Display.IImGearContrastSettings src)

Parameters:

Name
Type
Description
src
IImGearContrastSettings Interface
Source interface.

Return value:

None

See Also:

IImGearContrastSettings Interface


CreateDefault Method

32-bit
64-bit
CF
P
P
P

Description:

This method creates ImGearContrastSettings Structure with the following default attributes:

Contrast = 1.0

Brightness = 0.0

Gamma = 1.0

Declaration:

public static ImageGear.Display.ImGearContrastSettings CreateDefault()

Return value:

ImGearContrastSettings Structure object.

See Also:

ImGearContrastSettings Structure


ImGearScrollComponentInfo Structure

32-bit
64-bit
CF
P
P
P

Description:

This structure implements state of one scrollbar and uses pass scrolling information to and from ImageGear display code.

Declaration:

public struct ImGearScrollComponentInfo

Members:

Properties
Name
Description
Max Field
Maximim scrolling value.
Min Field
Minimum scrolling value.
Mode Field
Scrollbar appearance mode.
Page Field
Size of scrolling page (used for dynamic update of thumb dimensions).
Pos Field
Current scrolling position.


ImGearScrollComponentInfo Fields

The ImGearScrollComponentInfo Structure of the ImageGear.Display Namespace has the following fields:

Fields
Name
Description
Max Field
Maximim scrolling value.
Min Field
Minimum scrolling value.
Mode Field
Scrollbar appearance mode.
Page Field
Size of scrolling page (used for dynamic update of thumb dimensions).
Pos Field
Current scrolling position.


Max Field

32-bit
64-bit
CF
P
P
P

Description:

Maximim scrolling position.

Declaration:

public int Max { get, set}

Value:

Integer value.

See Also:

ImGearScrollComponentInfo Structure


Min Field

32-bit
64-bit
CF
P
P
P

Description:

Minimum scrolling position.

Declaration:

public int Min { get, set}

Value:

Integer value.

See Also:

ImGearScrollComponentInfo Structure


Mode Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies the scrollbar visibility mode.

Declaration:

public ImageGear.Display.ImGearScrollBarModes Mode

Value:

ImGearScrollBarModes Enumeration values.

See Also:

ImGearScrollBarModes Enumeration


Page Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies the page size. A scrollbar uses this value to determine the appropriate size of the proportional scroll box. Also see the description of SCROLLINFO structure in Windows SDK.

Declaration:

public int Page { get, set}

Value:

Integer value.

See Also:

ImGearScrollComponentInfo Structure


Pos Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies current image scrolling position.

Declaration:

public int Pos { get, set}

Value:

Integer value.

See Also:

ImGearScrollComponentInfo Structure


ImGearScrollInfo Structure

32-bit
64-bit
CF
P
P
P

Description:

This structure represents scrolling state of the image.

Declaration:

public struct ImGearScrollInfo

Members:

Fields
Name
Description
Horizontal Field
Scrolling state in horizontal dimension.
Vertical Field
Scrolling state in vertical dimension.

Methods
Name
Description
CopyFrom Method
Initializes ImGearScrollInfo structure from src attributes.
InitToDefault Method
Initializes the object with default valid values.


ImGearScrollInfo Fields

The ImGearScrollInfo Structure of the ImageGear.Display Namespace has the following fields:

Fields
Name
Description
Horizontal Field
Scrolling state in horizontal dimension.
Vertical Field
Scrolling state in vertical dimension.


Horizontal Field

32-bit
64-bit
CF
P
P
P

Description:

This field stores information about horizontal image scrolling state.

Declaration:

public ImageGear.Display.ImGearScrollComponentInfo Horizontal

Value:

ImGearScrollComponentInfo Structure object.

See Also:

ImGearScrollComponentInfo Structure


Vertical Field

32-bit
64-bit
CF
P
P
P

Description:

This field stores information about vertical image scrolling state.

Declaration:

public ImageGear.Display.ImGearScrollComponentInfo Vertical

Value:

ImGearScrollComponentInfo Structure

See Also:

ImGearScrollComponentInfo Structure


ImGearScrollInfo Methods

The ImGearScrollInfo Structure of the ImageGear.Display Namespace has the following methods:

Methods
Name
Description
CopyFrom Method
This method Initializes ImGearScrollInfo structure from src attributes.
InitToDefault Method
Initializes the object with default valid values.


CopyFrom Method

32-bit
64-bit
CF
P
P
P

Description:

This method initializes ImGearScrollInfo structure from src attributes.

Declaration:

public void CopyFrom(ImageGear.Display.IImGearDisplayObject src)

Parameters:

Name
Type
Description
src
IImGearDisplayObject Interface
Source interface.

Return Value:

None.

See Also:

IImGearDisplayObject Interface


InitToDefault Method

32-bit
64-bit
CF
P
P
P

Description:

This method initializes the object with default valid values.

Default scroll values for both vertical and horizontal directions are following:

  • Scrollbar mode is set to ImGearScrollBarModes.SCROLLBAR_AUTO
  • Min, Max, Pos and Page properties are set to 0

Declaration:

public void InitToDefault()

Return Value:

None.

See Also:

ImGearScrollBarModes Enumeration


ImGearZoomComponentInfo Structure

32-bit
64-bit
CF
P
P
P

Description:

This structure stores information about image zoom in one dimension (vertical or horizontal).

Declaration:

public struct ImGearZoomComponentInfo

Members:

Fields
Name
Description
Fixed Field
Specifies fixed or non-fixed zoom mode.
Value Field
Zoom value.


ImGearZoomComponentInfo Fields

The ImGearZoomComponentInfo Structure of the ImageGear.Display Namespace has the following fields:

Fields
Name
Description
Fixed Field
Specifies fixed or non-fixed zoom mode.
Value Field
Zoom value.


Fixed Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies fixed or non-fixed zoom mode.

Fixed zoom value (true) indicates that Value field is in use. With non-fixed zoom value (false), actual zoom factor is calculated without Value field information.

Declaration:

public bool Fixed

Value:

True, false

See Also:

ImGearZoomComponentInfo Structure


Value Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies zoom value.

When zoom mode (Fixed field) is set to false, this field is ignored.

Declaration:

public double Value

Value:

Any positive double-type value.

See Also:

ImGearZoomComponentInfo Structure


ImGearZoomInfo Structure

32-bit
64-bit
CF
P
P
P

Description:

This structure represents complete image zoom information.

Declaration:

public struct ImGearZoomInfo

Members:

Constructors
Name
Description
ImGearZoomInfo Constructor
Creates and initializes an instance of ImGearZoomInfo Structure.

Properties
Name
Description
Horizontal Field
Horizontal dimension zoom information.
Vertical Field
Vertical dimension zoom information.

Methods
Name
Description
CopyFrom Method
Initializes ImGearZoomInfo structure from src attributes.
InitToDefault Method
Initializes the object with default valid values.


ImGearZoomInfo Constructors

The ImGearZoomInfo Structure of the ImageGear.Display Namespace has the following constructors:

Constructors
Name
Description
ImGearZoomInfo Constructor
Creates and initializes an instance of ImGearZoomInfo Structure.


ImGearZoomInfo Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates a new instance of an object and initializes it with specified values.

Declaration:

public ImGearZoomInfo (System.Double dH, System.Double dV, Boolean hFixed, Boolean vFixed)

Parameters:

dH
Horizontal zoom value.
dV
Vertical zoom value.
hFixed
Horizontal zoom mode (fixed or not).
vFixed
Vertical zoom mode (fixed or not).

Return Value:

New instance of ImGearZoomInfo Structure.

See Also:

ImGearZoomInfo Structure


ImGearZoomInfo Fields

The ImGearZoomInfo Structure of the ImageGear.Display Namespace has the following fields:

Fields
Name
Description
Horizontal Field
Horizontal dimension zoom information.
Vertical Field
Vertical dimension zoom information.


Horizontal Field

32-bit
64-bit
CF
P
P
P

Description:

Horizontal zoom information.

Declaration:

public ImageGear.Display.ImGearZoomComponentInfo Horizontal

Value:

ImGearZoomComponentInfo Structure

See Also:

ImGearZoomComponentInfo Structure


Vertical Field

32-bit
64-bit
CF
P
P
P

Description:

Vertical zoom information.

Declaration:

public ImageGear.Display.ImGearZoomComponentInfo Vertical

Value:

ImGearZoomComponentInfo Structure

See Also:

ImGearZoomComponentInfo Structure


ImGearZoomInfo Methods

The ImGearZoomInfo Structure of the ImageGear.Display Namespace has the following methods:

Methods
Name
Description
CopyFrom Method
Initializes ImGearZoomInfo structure from src attributes.
InitToDefault Method
Initializes the object with default valid values.


CopyFrom Method

32-bit
64-bit
CF
P
P
P

Description:

This method initializes ImGearZoomInfo structure from src attributes.

Declaration:

public void CopyFrom(ImageGear.Display.IImGearDisplayObject src)

Parameters:

Name
Type
Description
src
IImGearDisplayObject Interface
Source interface.

Return Value:

None.

See Also:

IImGearDisplayObject Interface


InitToDefault Method

32-bit
64-bit
CF
P
P
P

Description:

This method initializes the object with default valid values.

Default zoom value is 1 and non-fixed mode (for both vertical and horizontal directions).

Declaration:

public void InitToDefault()

Return Value:

None.

See Also:

ImGearZoomInfo Structure


ImageGear.Display Namespace Enumerations

The ImageGear.Display Namespace has the following enumeration members:

Enumerations:
Name
Description
ImGearAliasModes Enumeration
Identifies different types of display anti-aliasing.
ImGearAlignmentHModes Enumeration
Identifies different types of image display horizontal alignment.
ImGearAlignmentVModes Enumeration
Identifies different types of image display vertical alignment.
ImGearBackgroundModes Enumeration
Identifies different modes of background drawing.
ImGearColorAliasModes Enumeration
Specifies color anti-aliasing modes currently supported.
ImGearCoordConvModes Enumeration
Identifies types of coordinate conversion.
ImGearFitModes Enumeration
Identifies image display fit modes.
ImGearResampleModes Enumeration
Specifies re-sampling modes currently supported.
ImGearScrollBarModes Enumeration
Identifies different types of scrollbars appearance mode.
ImGearScrollBarType Enumeration
Identifies possible scrollbar types.


ImGearAliasModes Enumeration

32-bit
64-bit
CF
P
P
P

Description:

Identifies the different types of image aliasing. Applicable only if a 1-bit-per-pixel image is to be drawn and only if the destination image has a lower resolution than the original one.

Declaration:

public enum ImGearAliasModes

Values:

Name
Value
Description
NONE
0
Anti-aliasing is not used
SCALE_TO_GRAY
1
The scale-to-gray algorithm is used, and the output image becomes 4-bits-per-pixel
PRESERVE_BLACK
2
This mode directs ImageGear to preserve black pixels while drawing
PRESERVE_WHITE
3
This mode directs ImageGear to preserve white pixels while drawing


ImGearAlignmentHModes Enumeration

32-bit
64-bit
CF
P
P
P

Description:

Identifies the different types of image display alignment modes (i.e., identifies how the displayed image is aligned relative to the device rectangle).

Declaration:

public enum ImGearAlignmentHModes

Values:

Name
Value
Description
LEFT
0
The image is aligned to the left border of the device rectangle
CENTER
16
The image is centered horizontally
RIGHT
32
The image is aligned to the right border of the device rectangle


ImGearAlignmentVModes Enumeration

32-bit
64-bit
CF
P
P
P

Description:

Identifies the different types of image display alignment modes (i.e., identifies how the displayed image is aligned relative to the device rectangle).

Declaration:

public enum ImGearAlignmentVModes

Values:

Name
Value
Description
TOP
0
The image is aligned to the top border of the device rectangle
CENTER
1
The image is centered vertically
BOTTOM
2
The image is aligned to the bottom border of the device rectangle


ImGearBackgroundModes Enumeration

32-bit
64-bit
CF
P
P
P

Description:

Specifies ImageGear background modes.

Declaration:

public enum ImGearBackgroundModes

Values:

Name
Value
Description
NONE
0
Do not draw background
BEYOND_IMAGE
2
Fill device rectangle with background color before image drawing
UNDER_IMAGE
1
Fill device rectangle with background color after image drawing


ImGearColorAliasModes Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies color anti-aliasing modes currently supported.

Declaration:

public enum ImGearColorAliasModes

Values:

Name
Value
Description
INTERPOLATE
1
Interpolation anti-aliasing is used for color images.
NONE
0
Anti-aliasing is not used for color images.


ImGearCoordConvModes Enumeration

32-bit
64-bit
CF
P
P
P

Description:

Identifies the coordinate translation methods.

Declaration:

public enum ImGearCoordConvModes

Values:

Name
Value
Description
DEVICE_TO_IMAGE
1
Converts coordinates from device coordinates to image ones
IMAGE_TO_DEVICE
0
Converts coordinates from image coordinates to device ones


ImGearFitModes Enumeration

32-bit
64-bit
CF
P
P
P

Description:

Identifies how an image fits to the device rectangle.

Declaration:

public enum ImGearFitModes

Values:

Name
Value
Description
ACTUAL_SIZE
3
The device rectangle is ignored, and the image is scaled 1:1
FIT_TO_DEVICE
0
The image is scaled to fit both the width and height of the device rectangle.
FIT_TO_HEIGHT
2
The image is scaled to fit the height of the device rectangle.
FIT_TO_WIDTH
1
The image is scaled to fit the width of the device rectangle.


ImGearResampleModes Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies re-sampling modes currently supported.

Declaration:

public enum ImGearResampleModes

Values:

Name
Value
Description
BILINEAR
1
Bilinear re-sampling is used.
NONE
0
Re-sampling is not used.


ImGearScrollBarModes Enumeration

32-bit
64-bit
CF
P
P
P

Description:

Identifies the scroll bar visibility methods.

Declaration:

public enum ImGearScrollBarModes

Values:

Name
Value
Description
SCROLLBAR_AUTO
128
Automatically show and hide scrollbars when required according to image zoom
SCROLLBAR_ENABLE
1
Always show scrollbar
SCROLLBAR_DISABLE
2
Always hide scrollbar


ImGearScrollBarType Enumeration

32-bit
64-bit
CF
P
P
P

Description:

Identifies possible scrollbar types.

Declaration:

public enum ImGearScrollBarType

Values:

Name
Value
Description
HORIZONTAL
1
Horizontal scrollbar
VERTICAL
2
Vertical scrollbar


ImageGear.Formats Namespace

ImageGear.Formats Namespace

32-bit
64-bit
CF
P
P
P

Description:

ImageGear.Formats namespace provides the ImageGear for .NET API for working with formats filters, thumbnails and formats metadata.

Declaration:

namespace ImageGear.Formats

Members:

Classes:
Name
Description
ImGearCommonMetadata Class
Provides access to metadata that is common for all format filters
ImGearControlParameter Class
Provides access to the attributes of a control parameter
ImGearFileFilters Class
Provides access to formats settings
ImGearFileFormats Class
Main class for working with file formats
ImGearFormatMetadata Class
Allows you to manage image metadata
ImGearFormatParameters Class
Allows you to manage format's control parameters
ImGearLoadOptions Class
Specifies additional loading options, such as thumbnail loading or loading an image specifying its format explicitly
ImGearNativeDataTypeHelper Class
Helps to work with ImageGear native data types associated with file formats metadata
ImGearSaveOptions Class
Specifies additional saving options
ImGearSaveThumbnailOptions Class
Specifies thumbnail attributes such as width and height to be used when saving a thumbnail
ImGearWebStream Class
Provides a specialized stream for loading of images from internet

Interfaces:
Name
Description
IImGearFormat Interface
Base interface for all file formats (filters); provides access to format's settings

Enumerations:
Name
Description
ImGearBMPTagIDs Enumeration
Lists all BMP tag identifiers
ImGearBTRTagIDs Enumeration
Lists all BTR tag identifiers
ImGearCALTagIDs Enumeration
Lists all CAL tag identifiers
ImGearCIFFCanonCameraSettingsTagIDs Enumeration
Lists all CIFF Canon Camera Settings tag identifiers
ImGearCIFFFocalLengthTagIDs Enumeration
Lists all CIFF Focal Length tag identifiers
ImGearCIFFImageInfoTagIDs Enumeration
Lists all CIFF Image Info tag identifiers
ImGearCIFFPictureInfoTagIDs Enumeration
Lists all CIFF Picture Info tag identifiers
ImGearCIFFShotInfoTagIDs Enumeration
Lists all CIFF Shot Info tag identifiers
ImGearCIFFTagIDs Enumeration
Lists all CIFF tag identifiers
ImGearCLPTagIDs Enumeration
Lists all CLP tag identifiers
ImGearCompressions Enumeration
Lists all compressions (e.g., Group 4, etc.)
ImGearCUTTagIDs Enumeration
Lists all CUT tag identifiers
ImGearDCRAWTagIDs Enumeration
Lists all Digital Camera RAW tag identifiers
ImGearDCXTagIDs Enumeration
Lists all DCX tag identifiers
ImGearDisplayInfoTagIDs Enumeration
Lists all Photoshop DisplayInfo tag identifiers
ImGearEXIFFPXRTagIDs Enumeration
Lists all EXIF FPXR tag identifiers
ImGearEXIFGPSTagIDs Enumeration
Lists all EXIF GPS tag identifiers
ImGearEXIFInterOpTagIDs Enumeration
Lists all EXIF Interoperability tag identifiers
ImGearEXIFMakerNoteFujiTagIDs Enumeration
Lists all Fujifilm EXIF MakerNote tag identifiers
ImGearEXIFMakerNoteNikonType1TagIDs Enumeration
Lists all Nikon EXIF MakerNote Type 1 tag identifiers
ImGearEXIFMakerNoteNikonType2TagIDs Enumeration
Lists all Nikon EXIF MakerNote Type 2 tag identifiers
ImGearEXIFMakerNoteOlympusTagIDs Enumeration
Lists all Olympus EXIF MakerNote tag identifiers
ImGearEXIFMakerNotePentaxTagIDs Enumeration
Lists all Pentax EXIF MakerNote tag identifiers
ImGearEXIFMakerNoteTagIDs Enumeration
Lists all general EXIF MakerNote tag identifiers
ImGearEXIFMakerNoteType Enumeration
Lists all EXIF MakerNote types
ImGearEXIFTagIDs Enumeration
Lists all EXIF tag identifiers
ImGearFillOrder Enumeration
Specifies fill order that is used for saving some file formats (e.g., TIFF, etc.).
ImGearFormats Enumeration
Lists all ImageGear supported file formats (e.g., TIFF, etc.)
ImGearGEMTagIDs Enumeration
Lists all GEM tag identifiers
ImGearGIFTagIDs Enumeration
Lists all GIF tag identifiers
ImGearHDPhotoTagIDs Enumeration
Lists all HDPhoto tag identifiers
ImGearICATagIDs Enumeration
Lists all ICA tag identifiers
ImGearICOTagIDs Enumeration
Lists all ICO tag identifiers
ImGearIFFTagIDs Enumeration
Lists all IFF tag identifiers
ImGearIMGTagIDs Enumeration
Lists all IMG tag identifiers
ImGearIMTTagIDs Enumeration
Lists all IMT tag identifiers
ImGearIPTCRecord1EnvDatasetTags Enumeration
Lists all IPTC Record 1 (Envelope) DataSet tags
ImGearIPTCRecord2AppDatasetTags Enumeration
Lists all IPTC Record 2 (Application) DataSet tags
ImGearIPTCRecord3PhotoDatasetTags Enumeration
Lists all IPTC Record 3 (Digital Newsphoto Parameter) DataSet tags
ImGearIPTCRecord7PreObjDatasetTags Enumeration
Lists all IPTC Record 7 (Pre-Object) DataSet tags
ImGearIPTCRecord8ObjDatasetTags Enumeration
Lists all IPTC Record 8 (Object) DataSet tags
ImGearIPTCRecord9PostObjDatasetTags Enumeration
Lists all IPTC Record 9 (Post-Object) DataSet tags
ImGearIPTCRecordTags Enumeration
Lists all IPTC Record tags
ImGearIPTCTags Enumeration
Lists all general IPTC tags
ImGearJP2TagIDs Enumeration
Lists all JP2 tag identifiers
ImGearJPEGTagIDs Enumeration
Lists all JPEG tag identifiers
ImGearJPXTagIDs Enumeration
Lists all JPX tag identifiers
ImGearKFXTagIDs Enumeration
Lists all KFX tag identifiers
ImGearLVTagIDs Enumeration
Lists all LV tag identifiers
ImGearMetadataFormats Enumeration
Lists all metadata formats; metadata formats correspond to the file formats for the most part, but some file formats (i.e., EXIF) define several metadata formats
ImGearMJ2TagIDs Enumeration
Lists all MJ2 tag identifiers
ImGearMSPTagIDs Enumeration
Lists all MSP tag identifiers
ImGearNativeDataTypes Enumeration
Specifies the data types that file formats use to store metadata values.
ImGearNCRTagIDs Enumeration
Lists all NCR tag identifiers
ImGearPBMTagIDs Enumeration
Lists all PBM tag identifiers
ImGearPCDTagIDs Enumeration
Lists all PCD tag identifiers
ImGearPCXTagIDs Enumeration
Lists all PCX tag identifiers
ImGearPhotoshopAdditionalLayerInfoTagIDs Enumeration
Lists all PhotoshopAdditionalLayerInfo tag identifiers
ImGearPhotoshopLayerInfoTagIDs Enumeration
Lists all PhotoshopLayerInfo tag identifiers
ImGearPhotoshopLayerMaskInfoTagIDs Enumeration
Lists all PhotoshopLayerMaskInfo tag identifiers
ImGearPhotoshopResourceGenericTagIDs Enumeration
Lists all PhotoshopResourceGeneric tag identifiers
ImGearPHOTOSHOPTagIDs Enumeration
Lists all Photoshop tag identifiers
ImGearPhotoshopVersionInfoTagIDs Enumeration
Lists all PhotoshopVersionInfo tag identifiers
ImGearPNGCompLevel Enumeration
Lists all PNG compression levels
ImGearPNGStrip Enumeration
Lists all PNG strip modes
ImGearPNGTagIDs Enumeration
Lists all PNG tag identifiers
ImGearPSDTagIDs Enumeration
Lists all PSD tag identifiers
ImGearPTOCATagIDs Enumeration
Lists all PTOCA tag identifiers
ImGearRASTagIDs Enumeration
Lists all RAS tag identifiers
ImGearRasterConversionModes Enumeration
Lists all raster conversion modes
ImGearRectangleInfoTagIDs Enumeration
Lists all Photoshop Rectangle Info tag ids
ImGearResolutionInfoTagIDs Enumeration
Lists all Photoshop Resolution Info tag ids
ImGearSavingFormats Enumeration
Lists all saving formats; saving format is a combination of a format and a compression (e.g., TIFF-G4)
ImGearSavingModes Enumeration
Lists all saving modes (e.g., overwrite image, insert page, etc.)
ImGearSCITagIDs Enumeration
Lists all SCI tag identifiers
ImGearSGITagIDs Enumeration
Lists all SGI tag identifiers
ImGearTGATagIDs Enumeration
Lists all TGA tag identifiers
ImGearThumbnailInfoTagIDs Enumeration
Lists all Photoshop Thumbnail Info tag identifiers
ImGearTIFTagIDs Enumeration
Lists all TIF tag identifiers
ImGearWBMPTagIDs Enumeration
Lists all WBMP tag identifiers
ImGearWPGTagIDs Enumeration
Lists all WPG tag identifiers
ImGearXBMTagIDs Enumeration
Lists all XBM tag identifiers
ImGearXPMTagIDs Enumeration
Lists all XPM tag identifiers
ImGearXWDTagIDs Enumeration
Lists all XWD tag identifiers


ImageGear.Formats Namespace Classes

The ImageGear.Formats Namespace has the following class members:

Classes:
Name
Description
ImGearCommonMetadata Class
Provides access to metadata that is common for all format filters
ImGearControlParameter Class
Provides access to the attributes of a control parameter
ImGearFileFilters Class
Provides access to formats settings
ImGearFileFormats Class
Main class for working with file formats
ImGearFormatMetadata Class
Allows you to manage image metadata
ImGearFormatParameters Class
Allows you to manage format's control parameters
ImGearLoadOptions Class
Specifies additional loading options such as thumbnail loading or loading an image specifying its format explicitly
ImGearNativeDataTypeHelper Class
Helps to work with ImageGear native data types associated with file formats metadata
ImGearSaveOptions Class
Specifies additional saving options
ImGearSaveThumbnailOptions Class
Specifies thumbnail attributes such as width and height to be used when saving a thumbnail
ImGearWebStream Class
Provides a specialized stream for loading of images from internet.


ImGearCommonMetadata Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides access to metadata that is common for all format filters.

Declaration:

public class ImGearCommonMetadata : ImageGear.Formats.ImGearFormatMetadata

Members:

Properties
Name
Description
ColorProfile Property
Returns color profile data of the file page from which the image was loaded, or null if the format filter does not support loading of color profiles.
Compression Property
Returns compression of the file page from which the image was loaded.
ResolutionLayersCount Property
Returns number of resolution layers in the image page from which ImGearPage object was loaded, or null if the format filter does not support loading of different resolutions.


ImGearCommonMetadata Properties

The ImGearCommonMetadata Class of the ImageGear.Formats Namespace has the following properties:

Properties
Name
Description
ColorProfile Property
Returns color profile data of the file page from which the image was loaded, or null if the format filter does not support loading of color profiles.
Compression Property
Returns compression of the file page from which the image was loaded.
ResolutionLayersCount Property
Returns number of resolution layers in the image page from which ImGearPage object was loaded, or null if the format filter does not support loading of different resolutions.


ColorProfile Property

32-bit
64-bit
CF
P
P
P

Description:

This property returns the color profile data of the file page from which the image was loaded, or null if the format filter does not support loading of color profiles. This property also returns null (source file page color profile is undefined) if the page was created using a ImGearRasterPage Class or ImGearVectorPage Class constructor, or using an image processing function.

This property does not necessarily correspond to the color profile actually attached to the image, because the color profile can be modified after loading, or an image can be converted to a different color space.

The property does not have a Set accessor. On image writing, ImageGear ignores this property, and uses the profile attached to the image DIB.

Declaration:

public byte[] ColorProfile { get; };

Value:

byte[] value.

See Also:

ImGearRasterPage Class

ImGearVectorPage Class


Compression Property

32-bit
64-bit
CF
P
P
P

Description:

This property returns compression of the file page from which the image or image header was loaded. If the page was created using ImGearRasterPage Class or ImGearVectorPage Class constructor, or using an image processing function, this property returns null (source file page compression is undefined).

Declaration:

public ImageGear.Formats.ImGearCompressions? Compression { get; set; };

Value:

Nullable (boxed) ImageGear.Formats.ImGearCompressions Enumeration value.

See Also:

ImGearCompressions Enumeration

ImGearRasterPage Class

ImGearVectorPage Class


ResolutionLayersCount Property

32-bit
64-bit
CF
P
P
P

Description:

This property returns the number of resolution layers in the image page from which ImGearPage Class object was loaded, or null if the format filter does not support loading of different resolutions.

Currently, only PCD format sets this property.

Declaration:

public ImageGear.Formats.Int32? ResolutionLayersCount { get; set; };

Value:

Nullable (boxed) Int32 value.

See Also:

ImGearPage Class


ImGearControlParameter Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides access to the attributes of a control parameter. Most of the control parameters affect the way images are saved, while a few also affect image loading as well.

Declaration:

public sealed class ImGearControlParameter

Members:

Properties
Name
Description
Name Property
The name of the parameter
Value Property
Current value of the parameter

Methods
Name
Description
GetDefaultValue Method
Gets default value of the parameter
SetToDefault Method
Sets parameter to its default value


ImGearControlParameter Properties

The ImGearControlParameter Class of the ImageGear.Formats Namespace has the following properties:

Properties
Name
Description
Name Property
The name of the parameter
Value Property
Current value of the parameter


Name Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides access to the parameter's name.

Declaration:

public string Name { get; }

Value:

String containing parameter's name.


Value Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides access to the parameter's value.

Declaration:

public object Value { get; set }

Value:

Object containing parameter's value.

Remarks:

When setting this property, please make sure that the type of the object representing a new value is the same as that of the old value. Otherwise an exception will be thrown.


ImGearControlParameter Methods

The ImGearControlParameter Class of the ImageGear.Formats Namespace has the following methods:

Methods
Name
Description
GetDefaultValue Method
Gets default value of the parameter
SetToDefault Method
Sets parameter to its default value


GetDefaultValue Method

32-bit
64-bit
CF
P
P
P

Description:

This method gets the default value of the parameter.

Declaration:

public object GetDefaultValue()

Return Value:

Object containing parameter's value.


SetToDefault Method

32-bit
64-bit
CF
P
P
P

Description:

This method sets parameter to its default value.

Declaration:

public void SetToDefault()

Return Value:

None.


ImGearFileFilters Class

32-bit
64-bit
CF
P
P
P

Description:

This class allows you to manage file formats and provides access to their settings. It contains a list of formats ImageGear is working with and provides an API for accessing and editing this list. When the format of an image is being detected, the formats are called in the order in which they are contained in the list.

The majority of file formats are added to the list automatically during class initialization. However, you need to add optional formats such as PDF, PostScript, and JPEG 2000 explicitly. If you do not need a particular format, you can remove it from the list. Re-ordering formats in the list allows you to optimize the format detection process. You can control a format's settings by getting a format from the list and accessing it via the IImGearformat interface.

Declaration:

public sealed class ImGearFileFilters

Members:

Constructors
Name
Description
ImGearFileFilters Constructor
Creates a new instance of the ImGearFileFilters Class.

Properties
Name
Description
Count Property
Gets the total number of formats currently in the collection.
IsSynchronized Property
Gets a value indicating whether access to the collection is synchronized (thread-safe).
SyncRoot Property
Gets an object that can be used to synchronize access to the collection.

Methods
Name
Description
Add Method
Adds a new format to the end of the list of formats
Contains Method
Tells whether a particular format is in the list of formats
CopyTo Method
Copies IImGearFormat entries to an Array of IImGearFormat elements, starting at a particular Array index
Get Method
Gets a format in the list based on the format ID
GetEnumerator Method
Returns an enumerator that can iterate through a collection.
IndexOf Method
Gets an index of a format in the list based on the format ID
Insert Method
Inserts a new format to the list of formats at the specified position
InsertAfter Method
Inserts a new format to the list of formats after the specified format
Remove Method
Removes a format from the list based on the format ID
RemoveAt Method
Removes a format from the list at the specified position


ImGearFileFilters Constructors

The ImGearFileFilters Class of the ImageGear.Formats Namespace has the following constructors:

Constructors
Name
Description
ImGearFileFilters Constructor
Creates a new instance of the ImGearFileFilters Class.


ImGearFileFilters Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates a new instance of the ImGearFileFilters Class class object.

Declaration:

public ImGearFileFilters()

Remarks:

Use this constructor if you need to pass a local copy of filter control parameters to a specific image loading or saving method, rather than change control parameters globally.

See also:

ImGearLoadOptions Class

ImGearSaveOptions Class


ImGearFileFilters Properties

The ImGearFileFilters Class of the ImageGear.Formats Namespace has the following properties:

Properties
Name
Description
Count Property
Gets the total number of formats currently in the collection.
IsSynchronized Property
Gets a value indicating whether access to the collection is synchronized (thread-safe).
SyncRoot Property
Gets an object that can be used to synchronize access to the collection.


Count Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets the total number of formats currently in the collection.

Declaration:

public int Count [get]

Value:

Any integer value.


IsSynchronized Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets a value indicating whether access to the collection is synchronized (thread-safe).

Declaration:

public bool IsSynchronized [get]

Value:

True, false.


SyncRoot Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets an object that can be used to synchronize access to the collection.

Declaration:

public object SyncRoot [get]

Value:

An object that can be used to synchronize access to the collection.


ImGearFileFilters Methods

The ImGearFileFilters Class of the ImageGear.Formats Namespace has the following methods:

Methods
Name
Description
Add Method
Adds a new format to the end of the list of formats
Contains Method
Tells whether a particular format is in the list of formats
CopyTo Method
Copies IImGearFormat entries to an Array of IImGearFormat elements, starting at a particular Array index
Get Method
Gets a format in the list based on the format ID
GetEnumerator Method
Returns an enumerator that can iterate through a collection.
IndexOf Method
Gets an index of a format in the list based on the format ID
Insert Method
Inserts a new format to the list of formats at the specified position
InsertAfter Method
Inserts a new format to the list of formats after the specified format
Remove Method
Removes a format from the list based on the format ID
RemoveAt Method
Removes a format from the list at the specified position


Add Method

32-bit
64-bit
CF
P
P
P

Description:

This method adds a new format to the end of the list of formats.

If the list contains the format with the same ID as the new one, the new format is not added, and the index of the existing format is returned instead.

Declaration:

public int Add(ImageGear.Formats.IImGearFormat newFormat)

Parameters:

Name
Type
Description
newFormat
IImGearFormat Interface
New format to be added.

Return value:

A place in the list where new format is placed.


Contains Method

32-bit
64-bit
CF
P
P
P

Description:

This method tells whether the list contains a particular format.

Declaration:

public bool Contains(ImageGear.Formats.ImGearFormats formatID)

Parameters:

Name
Type
Description
formatID
ImGearFormats Enumeration
ID of the format.

Return value:

True or false.


CopyTo Method

32-bit
64-bit
CF
P
P
P

Description:

This method copies IImGearFormat entries to an Array of IImGearFormat elements, starting at a particular Array index.

Declaration:

public void CopyTo(System.Array array, int index)

Parameters:

Name
Type
Description
array
System.Array
The one-dimensional Array of ImGearFormat elements that is the destination of the elements copied. The Array must have zero-based indexing.
index
int
The zero-based index in array at which copying begins.

Return Value:

None.


Get Method

32-bit
64-bit
CF
P
P
P

Description:

This method obtains (gets) a format from the list, allowing you to access format's settings.

Use this method to manage format's control parameters and access the format's attributes (i.e., name, default file extension, etc.). If a format is not in the list, an exception is thrown.

Declaration:

public ImageGear.Formats.IImGearFormat Get(ImageGear.Formats.ImGearFormats formatID)

Parameters:

Name
Type
Description
formatID
ImGearFormats Enumeration
The ID of the format.

Return value:

The IImGearFormat Interface of a format in the list.


GetEnumerator Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns an enumerator that can iterate through a collection.

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection. Initially, the enumerator is positioned before the first element in the collection.

Declaration:

public System.Collections.IEnumerator GetEnumerator()

Return Value:

An IEnumerator that can be used to iterate through the collection.


IndexOf Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns the index of a format in the list.

The formats are called in the order in which they are kept in the list when the format of an image is detected during loading. Therefore, this method can be used to learn the place of a format in the detection process.

Declaration:

public int IndexOf(ImageGear.Formats.ImGearFormats formatID)

Parameters:

Name
Type
Description
formatID
ImGearFormats Enumeration
ID of the format.

Return value:

The location (index) of a format in the list, or -1 if the format is not in the list.


Insert Method

32-bit
64-bit
CF
P
P
P

Description:

This method inserts a new format to the formats list at the specified position.

Use this method instead of Add if you want to control the detection process. If the format with the same ID exists in the list, an exception is thrown. You can use the Contains method to check if a format is already added, and call Remove/RemoveAt methods to remove a format.

Declaration:

public void Insert(int index, ImageGear.Formats.IImGearFormat newFormat)

Parameters:

Name
Type
Description
index
int
Position where to insert a new format
newFormat
IImGearFormat Interface
New format to be inserted

Return Value:

None.


InsertAfter Method

32-bit
64-bit
CF
P
P
P

Description:

This method inserts a new format to the list after a particular format.

Use this method if you want a new format to be called after a particular format during format detection. If a format with the same ID as the new one exists in the list, an exception is thrown. You can use Contains Method method to check if a format is already added, and call Remove Method/RemoveAt Method methods to remove a format.

Declaration:

public void InsertAfter(ImageGear.Formats.ImGearFormats formatID,
ImageGear.Formats.IImGearFormat newFormat)

Parameters:

Name
Type
Description
formatID
ImGearFormats Enumeration
ID of the format after which to insert a new format
newFormat
IImGearFormat Interface
New format to be inserted

Return Value:

None.


Remove Method

32-bit
64-bit
CF
P
P
P

Description:

This method removes a format from the list.

Use this method if you do not need a particular format. This will exclude it from all ImageGear operations.

NOTE: If you just need to exclude a format from the auto-detection process, you can set its DetectionEnabled Property property to false. If the format is not in the list, nothing is done.

Declaration:

public void Remove(ImageGear.Formats.ImGearFormats formatID)

Parameters:

Name
Type
Description
formatID
ImGearFormats Enumeration
ID of the format to be removed

Return Value:

None.

See Also:

ImGearFormats Enumeration


RemoveAt Method

32-bit
64-bit
CF
P
P
P

Description:

This method removes a format from the list at the specified location.

Use this method if you don't need a particular format. This will exclude it from all ImageGear operations.

NOTE: If you just need to exclude a format from the auto-detection process, you can set its DetectionEnabled Property property to false. If the index is out of boundaries, an exception is thrown.

Declaration:

public void RemoveAt (int index)

Parameters:

Name
Type
Description
index
int
Location (index) of an item to be removed

Return Value:

None.


ImGearFileFormats Class

32-bit
64-bit
CF
P
P
P

Description:

This is the main class for working with file formats. It contains an API for loading, detecting and saving images, getting image information, and provides access to format's settings class. The image is read from and written to a .NET stream. In order for ImageGear to work with the stream, it must be seekable. Consult ImageGear sample code for the examples of how to create a .NET stream from different image sources (i.e., file, memory, URL).

Declaration:

public sealed class ImGearFileFormats

Members:

Properties
Name
Description
Filters Property
Provides access to the file formats settings

Methods
Name
Description
Detect Method
Detects the format of an image
GetPageCount Method
Calculates the number of pages in an image
GetPageCount Method
Calculates the number of pages in an image
GetSavingFilter Method
Returns the saving filter for a particular format
GetSavingFilter Method
Returns the saving filter for a particular format
GetSavingFormats Method
Returns an array of all file saving formats compatible with a particular ImGearPage
GetSavingFormats Method
Returns an array of all file saving formats compatible with a particular ImGearPage and the conversion mode
GetSavingFormats Method
Returns an array of all file saving formats compatible with a particular ImGearPage and the conversion mode
LoadDocument Method
Loads a range of pages from an image
LoadDocument Method
Loads a range of pages from an image
LoadPage Method
Loads a single page from an image
LoadPage Method
Loads a single page from an image
LoadPageHeader Method
Loads image metadata for a particular page without decoding pixel data
LoadPageHeader Method
Loads image metadata for a particular page without decoding pixel data
SaveDocument Method
Saves document to an image
SavePage Method
Saves page to an image
SavePage Method
Saves page to an image
UpdatePageMetadata Method
Creates a new file with exact copy of source file's pixel data and with new metadata.
UpdatePageMetadata Method
Creates a new file with exact copy of source file's pixel data and with new metadata.


ImGearFileFormats Properties

The ImGearFileFormats Class of the ImageGear.Formats Namespace has the following properties:

Properties
Name
Description
Filters Property
Provides access to the file formats settings


Filters Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides access to the file formats settings.

Use this property to get access to the ImGearFileFilters Class instance that enables you to manage file formats and their settings.

Declaration:

public static ImageGear.Formats.ImGearFileFilters Filters { get; }

Value:

Instance of class for managing file formats.

See Also:

ImGearFileFilters Class


ImGearFileFormats Methods

The ImGearFileFormats Class of the ImageGear.Formats Namespace has the following methods:

Methods
Name
Description
Detect Method
Detects the format of an image
GetPageCount Method
Calculates the number of pages in an image
GetPageCount Method
Calculates the number of pages in an image
GetSavingFilter Method
Returns the saving filter for a particular format
GetSavingFilter Method
Returns the saving filter for a particular format
GetSavingFormats Method
Returns an array of all file saving formats compatible with a particular ImGearPage
GetSavingFormats Method
Returns an array of all file saving formats compatible with a particular ImGearPage and the conversion mode
GetSavingFormats Method
Returns an array of all file saving formats compatible with a particular ImGearPage and the conversion mode
LoadDocument Method
Loads a range of pages from an image
LoadDocument Method
Loads a range of pages from an image
LoadPage Method
Loads a single page from an image
LoadPage Method
Loads a single page from an image
LoadPageHeader Method
Loads image metadata for a particular page without decoding pixel data
LoadPageHeader Method
Loads image metadata for a particular page without decoding pixel data
SaveDocument Method
Saves document to an image
SavePage Method
Saves page to an image
SavePage Method
Saves page to an image
UpdatePageMetadata Method
Creates a new file with exact copy of source file's pixel data and with new metadata.
UpdatePageMetadata Method
Creates a new file with exact copy of source file's pixel data and with new metadata.


Detect Method

32-bit
64-bit
CF
P
P
P

Description:

This method detects the format of an image.

If an image cannot be detected, an exception is thrown.

Declaration:

public static ImageGear.Formats.IImGearFormat Detect(System.IO.Stream sysStream)

Parameters:

Name
Type
Description
stream
System.IO.Stream
.NET stream containing an image

Return value:

The format from the list of formats.

SeeAlso:

IImGearFormat Interface


GetPageCount Method

32-bit
64-bit
CF
P
P
P

Description:

This method calculates the number of pages in an image.

Declaration:

public static int GetPageCount(System.IO.Stream sysStream, ImageGear.Formats.ImGearFormats
formatID)

Parameters:

Name
Type
Description
stream
System.IO.Stream
.NET stream containing an image
formatID
ImGearFormats Enumeration
Format ID: if `UNKNOWN' is specified, image format is auto-detected

Return value:

Number of pages in the image.

Remarks:

If format ID is not `UNKNOWN' and image format cannot be detected, an exception is thrown.

See Also:

ImGearFormats Enumeration


GetPageCount Method

32-bit
64-bit
CF
P
P
P

Description:

This method calculates the number of pages in an image.

Declaration:

public static int GetPageCount(System.IO.Stream sysStream, ImageGear.Formats.ImGearFormats
formatID, ImGearLoadOptions options)

Parameters:

Name
Type
Description
stream
System.IO.Stream
.NET stream containing an image
formatID
ImGearFormats Enumeration
Format ID: if `UNKNOWN' is specified, image format is auto-detected
loadOptions
ImGearLoadOptions Class
The loading options.

Return value:

Number of pages in the image.

Remarks:

If format ID is not `UNKNOWN' and image format cannot be detected, an exception is thrown.

See Also:

ImGearFormats Enumeration

ImGearLoadOptions Class


GetSavingFilter Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns the saving filter for a particular format.

Declaration:

public static string GetSavingFilter(ImageGear.Formats.ImGearSavingFormats saveFormat)

Parameters:

Name
Type
Description
saveFormat
ImGearSavingFormats Enumeration
A format for which to return a filter.

Remarks:

This method comes handy when you need to populate the filter for the Save File dialog with different saving formats.

See Also:

ImGearSavingFormats Enumeration


GetSavingFilter Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns the saving filter for a particular format.

Declaration:

public static string GetSavingFilter(ImageGear.Formats.ImGearSavingFormats saveFormat,
ImGearSaveOptions options)

Parameters:

Name
Type
Description
saveFormat
ImGearSavingFormats Enumeration
A format for which to return a filter.
saveOptions
ImGearSaveOptions Class
Additional saving options such as allowed color conversions.

Remarks:

This method comes handy when you need to populate the filter for the Save File dialog with different saving formats.

See Also:

ImGearSavingFormats Enumeration

ImGearSaveOptions Class


GetSavingFormats Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns an array of all file saving formats compatible with a particular ImGearPage.

This method comes handy when you need to initialize Save File dialog with all saving formats applicable to the ImGearPage object.

Declaration:

public static ImageGear.Formats.ImGearSavingFormats[ ]
GetSavingFormats(ImageGear.Core.ImGearPage page)

Parameters:

Name
Type
Description
page
ImGearPage Class
ImGearPage object to get saving formats for.

Return Value:

ImGearSavingFormats Enumeration value.

See Also:

ImGearSavingFormats Enumeration

ImGearPage Class


GetSavingFormats Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns an array of all file saving formats compatible with a particular ImGearPage and the conversion mode.

This method comes handy when you need to initialize Save File dialog with all saving formats applicable to the ImGearPage object.

Declaration:

public static ImageGear.Formats.ImGearSavingFormats[]
GetSavingFormats(ImageGear.Core.ImGearPage page,
ImageGear.Formats.ImGearRasterConversionModes rasterConversionModes)

Parameters:

Name
Type
Description
page
ImGearPage Class
ImGearPage object to get saving formats for.
rasterConversionModes
ImGearRasterConversionModes Enumeration
Raster converter mode.

Return Value:

ImGearSavingFormats Enumeration array.

Example:

C#
ImGearFileFormats.GetSavingFormats(page,ImGearRasterConversionModes.DIRECT_MATCH);

Visual Basic
ImGearFileFormats.GetSavingFormats(page,ImGearRasterConversionModes.DIRECT_MATCH)

See Also:

ImGearSavingFormats Enumeration

ImGearPage Class

ImGearRasterConversionModes Enumeration


GetSavingFormats Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns an array of all file saving formats compatible with a particular ImGearPage Class and the conversion mode.

This method comes handy when you need to initialize Save File dialog with all saving formats applicable to the ImGearPage Class object.

Declaration:

public static ImageGear.Formats.ImGearSavingFormats[]
GetSavingFormats(ImageGear.Core.ImGearPage page,
ImageGear.Formats.ImGearRasterConversionModes rasterConversionModes, ImGearSaveOptions
options)

Parameters:

Name
Type
Description
page
ImGearPage Class
ImGearPage object to get saving formats for.
rasterConversionModes
ImGearRasterConversionModes Enumeration
Raster converter mode.
saveOptions
ImGearSaveOptions Class
Additional saving options and filter control parameters.

Return Value:

ImGearSavingFormats Enumeration array.

Remarks:

If saveOptions parameter is not null, rasterConversionModes supersedes saveOptions.ConversionMode field.

Example:

See Also:

ImGearSavingFormats Enumeration

ImGearPage Class

ImGearRasterConversionModes Enumeration

ImGearSaveOptions Class


LoadDocument Method

32-bit
64-bit
CF
P
P
P

Description:

This method loads a range of pages from an image.

This method allows you to load several pages in a single call and get access to the document level metadata of an image. It is recommended to use this method when working with PDF format since pages inside a PDF file depend on each other, and thus, loading them at once (as a document) is preferable to loading pages individually. If the format of an image can not be detected, an exception is thrown.

Declaration:

public static ImageGear.Core.ImGearDocument LoadDocument(System.IO.Stream sysStream, int
startPageNumber, int count)

Parameters:

Name
Type
Description
stream
Stream
.NET stream containing an image
startPageNumber
Int
The number of the first page to load
count
Int
Total number of pages to load

Return value:

New instance of ImGearDocument Class.


LoadDocument Method

32-bit
64-bit
CF
P
P
P

Description:

This method loads a range of pages from an image.

This method allows you to load several pages in a single call and get access to the document level metadata of an image. It is recommended to use this method when working with PDF format since pages inside a PDF file depend on each other, and thus, loading them at once (as a document) is preferable to loading pages individually. If the format of an image can not be detected, an exception is thrown.

This method provides more flexibility for loading images (i.e., the ability to load image thumbnail and specify image format explicitly).

Declaration:

public static ImageGear.Core.ImGearDocument LoadDocument(System.IO.Stream sysStream, int
startPageNumber, int count, ImGearLoadOptions options)

Parameters:

Name
Type
Description
stream
Stream
.NET stream containing an image
startPageNumber
Int
The number of the first page to load
count
Int
Total number of pages to load
loadOptions
ImGearLoadOptions Class
The loading options

Return value:

New instance of ImGearDocument Class.

See Also:

ImGearLoadOptions Class

ImGearDocument Class


LoadPage Method

32-bit
64-bit
CF
P
P
P

Description:

This method loads a single page from an image.

This is the simplest method for loading an image into ImageGear. If the format of an image cannot be detected, an exception is thrown.

Declaration:

public static ImageGear.Core.ImGearPage LoadPage(System.IO.Stream sysStream, int
pageNumber)

Parameters:

Name
Type
Description
stream
System.IO.Stream
.NET stream containing an image
pageNumber
Int
The number of page to load; this is a 0-based index

Return value:

A new instance of ImGearPage Class.

See Also:

ImGearPage Class


LoadPage Method

32-bit
64-bit
CF
P
P
P

Description:

This method loads a single page from an image.

This method provides more flexibility for loading images (i.e., the ability to load image thumbnail and specify image format explicitly).

Declaration:

public static ImageGear.Core.ImGearPage LoadPage(System.IO.Stream sysStream, int pageNum,
ImageGear.Formats.ImGearLoadOptions loadOptions)

Parameters:

Name
Type
Description
stream
System.IO.Stream
.NET stream containing an image
pageNum
Int
The number of page to load
loadOptions
ImGearLoadOptions Class
The loading options

Return value:

A new instance of ImGearPage Class.

See Also:

ImGearLoadOptions Class

ImGearPage Class


LoadPageHeader Method

32-bit
64-bit
CF
P
P
P

Description:

This method loads image metadata for a particular page without decoding pixel data.

This method returns an ImGear page containing DIB, metadata, image resolution and all other attributes except for pixel data and the palette. This is useful when you need to look up a particular tag in the metadata or get information about image dimensions while avoiding time consuming operation of decoding the pixel data.

Declaration:

public static ImageGear.Core.ImGearPage LoadPageHeader(System.IO.Stream sysStream, int
pageNumber)

Parameters:

Name
Type
Description
stream
System.IO.Stream
.NET stream containing an image
pageNumber
Int
The number of page to load header from

Return value:

A new instance of ImGearPage Class.

See Also:

ImGearPage Class


LoadPageHeader Method

32-bit
64-bit
CF
P
P
P

Description:

This method loads image metadata for a particular page without decoding pixel data.

This method returns an ImGearPage Class containing DIB, metadata, image resolution and all other attributes except for pixel data and the palette. This is useful when you need to look up a particular tag in the metadata or get information about image dimensions while avoiding time consuming operation of decoding the pixel data.

Declaration:

public static ImageGear.Core.ImGearPage LoadPageHeader(System.IO.Stream sysStream, int
pageNumber, ImGearLoadOptions options)

Parameters:

Name
Type
Description
stream
System.IO.Stream
.NET stream containing an image
pageNumber
Int
The number of page to load header from
loadOptions
ImGearLoadOptions Class
The loading options

Return value:

A new instance of ImGearPage Class.

See Also:

ImGearPage Class

ImGearLoadOptions Class


SaveDocument Method

32-bit
64-bit
CF
P
P
P

Description:

This method saves document to an image.

This method allows you to save the entire document in a single call. Both page pixel data and page metadata are saved. If a new image is created (or overwritten), document level metadata is saved as well, otherwise, it is ignored.

Declaration:

public static void SaveDocument(ImageGear.Core.ImGearDocument doc, System.IO.Stream
sysStream, int startPageFile, ImageGear.Formats.ImGearSavingModes mode,
ImageGear.Formats.ImGearSavingFormats saveFormat, ImageGear.Formats.ImGearSaveOptions
saveOptions)

Parameters:

Name
Type
Description
doc
ImGearDocument Class
ImageGear document to save
stream
Stream
.NET stream to write an image to
startPageFile
Int
The number of a start page in the image where document pages are saved
mode
ImGearSavingModes Enumeration
Specifies how new pages should be saved to an image; replace pages, insert pages, append pages, or overwrite the entire image
saveFormat
ImGearSavingFormats Enumeration
The format to save new pages in. This is a combination of a file format and a compresison (e.g., TIFF-G4).
saveOptions
ImGearSaveOptions Class
Additional saving options such as thumbnail dimensions

Return Value:

None.

See Also:

ImGearDocument Class

ImGearPage Class

ImGearSavingModes Enumeration

ImGearSavingFormats Enumeration

ImGearSaveOptions Class


SavePage Method

32-bit
64-bit
CF
P
P
P

Description:

This method saves page to an image. Both page pixel data and page metadata are saved by this method.

NOTE: Any time SavePage is used with ImGearSavingModes.APPEND, the stream must be at the beginning of the file to be appended to.

Declaration:

public static void SavePage(ImageGear.Core.ImGearPage page, System.IO.Stream sysStream,
int pageNum, ImageGear.Formats.ImGearSavingModes saveMode,
ImageGear.Formats.ImGearSavingFormats saveFormat)

Parameters:

Name
Type
Description
page
ImGearPage Class
ImageGear page to save
stream
System.IO.Stream
.NET stream to write an image to
pageNum
Int
Specifies page number in the image where to put a new page. New page can replace current page, or be inserted depending on the mode parameter.
mode
ImGearSavingModes Enumeration
Specifies how new page should be saved to an image; replace page, insert page, append page, or overwrite the entire image.
NOTE: Any time SavePage is used with ImGearSavingModes.APPEND, the stream must be at the beginning of the file to be appended to.
saveFormat
ImGearSavingFormats Enumeration
The format to save new pages in. This is a combination of a file format and a compresison (e.g., TIFF-G4).

Remarks:

None.

See Also:

ImGearPage Class

ImGearSavingModes Enumeration

ImGearSavingFormats Enumeration


SavePage Method

32-bit
64-bit
CF
P
P
P

Description:

This method saves page to an image. Both page pixel data and page metadata are saved by this method.

NOTE: Any time SavePage is used with ImGearSavingModes.APPEND, the stream must be at the beginning of the file to be appended to.

Declaration:

public static void SavePage(ImageGear.Core.ImGearPage page, System.IO.Stream sysStream,
int pageNum, ImageGear.Formats.ImGearSavingModes mode,
ImageGear.Formats.ImGearSavingFormats saveFormat, ImageGear.Formats.ImGearSaveOptions
saveOptions)

Parameters:

Name
Type
Description
page
ImGearPage Class
ImageGear page to save
stream
Stream
.NET stream to write an image to
pageNum
Int
Specifies page number in the image where to put a new page. New page can replace current page, or be inserted depending on the mode parameter.
mode
ImGearSavingModes Enumeration
Specifies how new page should be saved to an image; replace page, insert page, append page, or overwrite the entire image.
NOTE: Any time SavePage is used with ImGearSavingModes.APPEND, the stream must be at the beginning of the file to be appended to.
saveFormat
ImGearSavingFormats Enumeration
The format to save new pages in. This is a combination of a file format and a compresison (e.g., TIFF-G4).
saveOptions
ImGearSaveOptions Class
Additional saving options such as thumbnail dimensions

Remarks:

None.

See Also:

ImGearPage Class

ImGearSavingModes Enumeration

ImGearSavingFormats Enumeration

ImGearSaveOptions Class


UpdatePageMetadata Method

32-bit
64-bit
CF
P
P
P

Description:

This function creates a new file with an exact copy of the source file's pixel data and with new metadata. Pixel data is not decoded but copied directly from source to destination file.

This function can be used for updating metadata in an image file without modifying the pixel data. To achieve this, delete the source file after calling this function, and rename result file to the source file name.

Tags that affect decoding of pixel data are transferred from the source file, and not replaced with tags from metadata.

Currently, the method only supports metadata updating in the DICOM file format.

Declaration

public static void UpdatePageMetadata(System.IO.Stream srcStream, System.IO.Stream
dstStream, ImageGear.Core.ImGearMetadataHead metadata)

Parameters:

Name
Type
Description
srcStream
System.IO.Stream
NET stream, containing source image
dstStream
System.IO.Stream
NET stream to which to write result image
metadata
ImGearMetadataHead Class
Metadata to be saved to result file

Sample:

Medical

Return Value:

None.

See Also:

ImGearMetadataHead Class


UpdatePageMetadata Method

32-bit
64-bit
CF
P
P
P

Description:

This function creates a new file with an exact copy of the source file's pixel data and with new metadata. Pixel data is not decoded but copied directly from source to destination file.

This function can be used for updating metadata in an image file without modifying the pixel data. To achieve this, delete the source file after calling this function, and rename result file to the source file name.

Tags that affect decoding of pixel data are transferred from the source file, and not replaced with tags from metadata.

Currently, the method only supports metadata updating in the DICOM file format.

Declaration

public static void UpdatePageMetadata(System.IO.Stream srcStream, System.IO.Stream
dstStream, ImageGear.Core.ImGearMetadataHead metadata, ImGearLoadOptions options)

Parameters:

Name
Type
Description
srcStream
System.IO.Stream
NET stream, containing source image
dstStream
System.IO.Stream
NET stream to which to write result image
metadata
ImGearMetadataHead Class
Metadata to be saved to result file
loadOptions
ImGearLoadOptions Class
The loading options

Sample:

Medical

Return Value:

None.

See Also:

ImGearMetadataHead Class

ImGearLoadOptions Class


ImGearFormatMetadata Class

32-bit
64-bit
CF
P
P
P

Description:

This class allows you to manage image metadata.

Declaration:

public class ImGearFormatMetadata

Members:

N/A


ImGearFormatParameters Class

32-bit
64-bit
CF
P
P
P

Description:

This class allows you to manage format's control parameters.

Declaration:

public sealed class ImGearFormatParameters

Members:

Properties
Name
Description
Count Property
Gets the total number of parameters
this Property
Gets control parameter by index

Methods
Name
Description
GetByName Method
Gets control parameter by name
GetEnumerator Method
Gets enumerator.
SetToDefault Method
Sets all control parameters to their default values


ImGearFormatParameters Properties

The ImGearFormatParameters Class of the ImageGear.Formats Namespace has the following properties:

Properties
Name
Description
Count Property
Gets the total number of parameters
this Property
Gets control parameter by index


Count Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets the total number of control parameters for the format.

Declaration:

public int Count { get; }

Value:

Any non-negative integer value.


this Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets control parameter by index.

Declaration:

public ImageGear.Formats.ImGearControlParameter this[int i] { get; }

Value:

The ImGearControlParameter Class interface of the control parameter from the collection of parameters.

See Also:

ImGearControlParameter Class


ImGearFormatParameters Methods

The ImGearFormatParameters Class of the ImageGear.Formats Namespace has the following methods:

Methods
Name
Description
GetByName Method
Gets control parameter by name
GetEnumerator Method
Gets enumerator.
SetToDefault Method
Sets all control parameters to their default values


GetByName Method

32-bit
64-bit
CF
P
P
P

Description:

This method gets control parameter by name.

Declaration:

public ImageGear.Formats.ImGearControlParameter GetByName(string name)

Parameters:

Name
Type
Description
Name
string
The name of the parameter.

Return Value:

The ImGearControlParameter Class of the control parameter from the collection of parameters.

See Also:

ImGearControlParameter Class


GetEnumerator Method

32-bit
64-bit
CF
P
P
P

Description:

This method gets enumerator.

Declaration:

public System.Collections.IEnumerator GetEnumerator()

Return Value:

System.Collections.IEnumerator


SetToDefault Method

32-bit
64-bit
CF
P
P
P

Description:

This method sets all control parameters for the particular format to their default values.

Declaration:

public void SetToDefault()

Return Value:

None.

32-bit
64-bit
CF
P
P
P
32-bit
64-bit
CF
P
P
P
32-bit
64-bit
CF
P
P
P
32-bit
64-bit
CF
P
P
P
32-bit
64-bit
CF
P
P
P
32-bit
64-bit
CF
P
P
P
32-bit
64-bit
CF
P
P
P
32-bit
64-bit
CF
P
P
P
32-bit
64-bit
CF
P
P
P
32-bit
64-bit
CF
P
P
P
32-bit
64-bit
CF
P
P
P
32-bit
64-bit
CF
P
P
P
32-bit
64-bit
CF
P
P
P
32-bit
64-bit
CF
P
P
P
32-bit
64-bit
CF
P
P
P


ImGearLoadOptions Class

32-bit
64-bit
CF
P
P
P

Description:

This class specifies additional loading options, such as thumbnail loading or loading an image specifying image format explicitly.

Declaration:

public sealed class ImGearLoadOptions

Members:

Constructors
Name
Description
ImGearLoadOptions Constructor
Creates a new instance of the load options object

Properties
Name
Description
Filters Property
Specifies filter settings to be used in a particular image loading operation.
Format Property
Format ID; specifying `UNKNOWN' will force auto-detection.
ParseXMP Property
Specifies whether ImageGear shall parse XMP stream or provide it to the application as a single binary tag.
ThumbnailLoading Property
If set to true, enables ImageGear to load a thumbnailed version of an image.
TilesToStitch Property
Determines the tiles to be stitched.


ImGearLoadOptions Constructors

The ImGearLoadOptions Class of the ImageGear.Formats Namespace has the following constructors:

Constructors
Name
Description
ImGearLoadOptions Constructor
Creates a new instance of the load options object


ImGearLoadOptions Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates a new instance of the ImGearLoadOptions Class object.

Declaration:

public ImGearLoadOptions()

Remarks:

If you need additional flexibility in a way how images are loaded, you can achieve it by creating an instance of the ImGearLoadOptions object and pass it to the LoadPage method.


ImGearLoadOptions Properties

The ImGearLoadOptions Class of the ImageGear.Formats Namespace has the following properties:

Properties
Name
Description
Filters Property
Specifies filter settings to be used in a particular image loading operation.
Format Property
Format ID; specifying `UNKNOWN' will force auto-detection.
ParseXMP Property
Specifies whether ImageGear shall parse XMP stream or provide it to the application as a single binary tag.
ThumbnailLoading Property
If set to true, enables ImageGear to load a thumbnailed version of an image.
TilesToStitch Property
Determines the tiles to be stitched.


Filters Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies filter settings to be used in a particular image loading operation. If this property is not null, it overrides the global settings specified by ImGearFileFormats Class.Filters.

This property can be used in a multithreaded application, in order to use different filter control parameters in different threads.

Declaration:

public ImGearFileFilters Filters { set; get; }

Value:

ImGearFileFilters Class value.

See Also:

ImGearFileFilters Class


Format Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies file format of an image to load, specifying `UNKNOWN' will force auto-detection.

Use this property when you need to bypass auto-detection and specify image format explicitly.

Declaration:

public ImageGear.Formats.ImGearFormats Format { set; get; }

Value:

Any member of ImGearFormats Enumeration value.

See Also:

ImGearFormats Enumeration


ParseXMP Property

32-bit
64-bit
CF
P
P
P

Description:

Specifies whether ImageGear shall parse XMP stream or provide it to the application as a single binary tag.

Declaration:

public bool ParseXMP { set; get; }

Value:

false, true


ThumbnailLoading Property

32-bit
64-bit
CF
P
P
P

Description:

This property, if set to true, enables ImageGear to load a thumbnailed version of an image. Otherwise, the entire image is loaded.

NOTE: Thumbnail loading feature in the current version of ImageGear is not implemented yet.

Use this property if you need to load an image thumbnail. This will only work for file formats that support storing a thumbnail, and when thumbnail is actually stored as a part of an image. For all other cases, load the entire image and create a thumbnail using ImGearProcessing Class.CreateThumbnail Method.

Declaration:

public bool ThumbnailLoading { get; set }

Value:

True, false.


TilesToStitch Property

32-bit
64-bit
CF
P
P
P

Description:

This property determines the tiles to be stitched.

Declaration:

public ImageGear.Core.ImGearRectangle TilesToStitch { set; get; }

Value:

ImGearRectangle Structure object.


ImGearNativeDataTypeHelper Class

32-bit
64-bit
CF
P
P
P

Description:

This class helps to work with ImageGear native data types associated with file formats metadata.

Declaration:

public class ImGearNativeDataTypeHelper

Members:

Constructors
Name
Description
ImGearNativeDataTypeHelper Constructor
Creates a new instance of ImGearNativeDataTypeHelper Class.

Methods
Name
Description
GetValueSize Method
Returns the value size for the data type.


ImGearNativeDataTypeHelper Constructors

The ImGearNativeDataTypeHelper Class of the ImageGear.Formats Namespace has the following constructors:

Constructors
Name
Description
ImGearNativeDataTypeHelper Constructor
Creates a new instance of ImGearNativeDataTypeHelper Class.


ImGearNativeDataTypeHelper Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates a new instance of ImGearNativeDataTypeHelper Class.

Declaration:

public ImGearNativeDataTypeHelper()

Remarks:

A new instance of ImGearNativeDataTypeHelper Class.

See Also:

ImGearNativeDataTypeHelper Class


ImGearNativeDataTypeHelper Methods

The ImGearNativeDataTypeHelper Class of the ImageGear.Formats Namespace has the following methods:

Methods
Name
Description
GetValueSize Method
Returns the value size for the data type.


GetValueSize Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns the value size for the data type.

Declaration:

public static int GetValueSize(ImageGear.Formats.ImGearNativeDataTypes typeID)

Parameters:

Name
Type
Description
typeID
ImGearNativeDataTypes Enumeration
Data type for which to get the size.

Remarks:

This method allows you to find the size of the different data types in bytes.

See Also:

ImGearNativeDataTypes Enumeration


ImGearSaveOptions Class

32-bit
64-bit
CF
P
P
P

Description:

This class specifies additional saving options.

Declaration:

public sealed class ImGearSaveOptions

Members:

Constructors
Name
Description
ImGearSaveOptions Constructor
Creates a new instance of the save options object

Properties
Name
Description
ConversionMode Property
Specifies allowed raster converter's conversion mode for saving.
EmbedColorProfile Property
Tells whether color profile associated with image (or color space in which image pixels are) have to be embedded into file or not. That is, if there's color profile associated with image being saved, or there's global profile installed for the color space in which image pixels are, this options control whether color profiles will be plugged into file together with image data or not.
Filters Property
Specifies filter settings to be used in a particular image saving operation.
ForceColorspace Property
Tells ImageGear to save images only in the specified color space.
Thumbnail Property
Gets access to thumbnail saving options.


ImGearSaveOptions Constructors

The ImGearSaveOptions Class of the ImageGear.Formats Namespace has the following constructors:

Constructors
Name
Description
ImGearSaveOptions Constructor
Creates a new instance of the save options object


ImGearSaveOptions Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates a new instance of the ImGearSaveOptions Class object.

Declaration:

public ImGearSaveOptions()

Remarks:

If you need additional flexibility how images are saved, you can achieve it by creating an instance of the ImGearSaveOptions Class object and pass it to the SavePage method.


ImGearSaveOptions Properties

The ImGearSaveOptions Class of the ImageGear.Formats Namespace has the following properties:

Properties
Name
Description
ConversionMode Property
Specifies allowed raster converter's conversion mode for saving.
EmbedColorProfile Property
Tells whether color profile associated with image (or color space in which image pixels are) have to be embedded into file or not. That is, if there's color profile associated with image being saved, or there's global profile installed for the color space in which image pixels are, this options control whether color profiles will be plugged into file together with image data or not.
Filters Property
Specifies filter settings to be used in a particular image saving operation.
ForceColorspace Property
Tells ImageGear to save images only in the specified color space.
Thumbnail Property
Gets access to thumbnail saving options.


ConversionMode Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies allowed raster converter's conversion mode for saving.

Declaration:

public ImageGear.Formats.ImGearRasterConversionModes ConversionMode { set; get; }

Value:

ImGearRasterConversionModes Enumeration value.

Example:

C#
ImGearSaveOptions saveOptions = new ImGearSaveOptions();
saveOptions.ConversionMode = ImGearRasterConversionModes.DIRECT_MATCH;

Visual Basic
Dim saveOptions As ImGearSaveOptions = New ImGearSaveOptions()
saveOptions.ConversionMode = ImGearRasterConversionModes.DIRECT_MATCH

See Also:

ImGearRasterConversionModes Enumeration


EmbedColorProfile Property

32-bit
64-bit
CF
P
P
P

Description:

This property tells whether color profile associated with image (or color space in which image pixels are) have to be embedded into file or not. If color profile associated with image being saved, or global profile installed for the color space in which image pixels are, this option controls whether color profiles will be plugged into file together with image data or not.

This option has affect only if:

  • Profiles are activated through ImGearColorProfileManager.EnableProfiles property.
  • Destination file format supports profiles embedding.

Declaration:

public bool EmbedColorProfile { get; set; }

Value:

true/false

See Also:

ImGearColorProfileManager Class


Filters Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies filter settings to be used in a particular image saving operation. If this property is not null, it overrides the global settings specified by ImGearFileFormats Class.Filters.

This property can be used in a multithreaded application, in order to use different filter control parameters in different threads.

Declaration:

public ImGearFileFilters Filters { set; get; }

Value:

ImGearFileFilters Class value.

See Also:

ImGearFileFilters Class


ForceColorspace Property

32-bit
64-bit
CF
P
P
P

Description:

Set this property to a specific color space ID to tell ImageGear use only this color space for image saving. If the file format supports this color space for saving, and other settings and control parameters allow saving to this color space, the image will be saved with the specified color space. Otherwise, ImageGear will throw an exception with ImGearErrorCodes Enumeration.CANT_SAVE_FORMAT code.

This mode can be used for conversion of image files from one color space to another, without having to store converted image in memory. To convert an image, load it into ImageGear, set ForceColorspace to desired color space, and save the image.

If the property is set to ImGearColorSpaceIDs Enumeration.NONE (the default value), ImageGear does not force conversion to any color space, and uses the color space that best matches the source image.

Declaration:

public ImGearColorSpaceIDs ForceColorspace { set; get; }

Value:

ImGearColorSpaceIDs Enumeration

Default Value:

ImGearColorSpaceIDs Enumeration.NONE

See Also:

ImGearErrorCodes Enumeration

ImGearColorSpaceIDs Enumeration


Thumbnail Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets access to thumbnail saving options.

Declaration:

public ImGearSaveThumbnailOptions Thumbnail { get; }

Value:

An instance of the thumbnail options class.

See Also:

ImGearSaveThumbnailOptions Class


ImGearSaveThumbnailOptions Class

32-bit
64-bit
CF
P
P
P

Description:

This class specifies thumbnail attributes, such as width and height, to be used when saving a thumbnail.

Declaration:

public sealed class ImGearSaveThumbnailOptions

Members:

Properties
Name
Description
Enabled Property
Setting it to true will enable saving a thumbnail
Height Property
The height of the thumbnail
Width Property
The width of the thumbnail


ImGearSaveThumbnailOptions Properties

The ImGearSaveThumbnailOptions Class of the ImageGear.Formats Namespace has the following properties:

Properties
Name
Description
Enabled Property
Setting it to true will enable saving a thumbnail
Height Property
The height of the thumbnail
Width Property
The width of the thumbnail


Enabled Property

32-bit
64-bit
CF
P
P
P

Description:

Setting this property to true will enable saving a thumbnail.

Declaration:

public bool Enabled { get; set }

Value:

True, false.


Height Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the height of the thumbnail.

Declaration:

public int Height { get; set }

Value:

Any integer value greater than 0.


Width Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the width of the thumbnail.

Declaration:

public int Width { get; set }

Value:

Any integer value greater than 0.


ImGearWebStream Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides a specialized stream for loading of images from internet. It is most useful for loading of multipage images, because it downloads only the necessary portion of remote file.

Declaration:

public class ImGearWebStream : System.IO.Stream

Members:

Constructors
Name
Description
ImGearWebStream Constructor
Creates instance of ImGearWebStream object.
ImGearWebStream Constructor
Creates instance of ImGearWebStream object.

Properties
Name
Description
CanRead Property
When overridden in a derived class, gets a value indicating whether the current stream supports reading.
CanSeek Property
When overridden in a derived class, gets a value indicating whether the current stream supports seeking.
CanWrite Property
When overridden in a derived class, gets a value indicating whether the current stream supports writing.
Length Property
When overridden in a derived class, gets the length in bytes of the stream.
Position Property
When overridden in a derived class, gets or sets the position within the current stream.

Methods
Name
Description
Close Method
Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream.
Flush Method
When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device.
Read Method
When overridden in a derived class, reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read.
Seek Method
When overridden in a derived class, sets the position within the current stream.
SetLength Method
When overridden in a derived class, sets the length of the current stream.
Write Method
When overridden in a derived class, writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written.


ImGearWebStream Constructors

The ImGearWebStream Class of the ImageGear.Formats Namespace has the following constructors:

Constructors
Name
Description
ImGearWebStream Constructor
Creates instance of ImGearWebStream object.
ImGearWebStream Constructor
Creates instance of ImGearWebStream object.


ImGearWebStream Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates a new instance of ImGearWebStream Class object.

Declaration:

public ImGearWebStream ( String path )

Parameters:

Name
Type
Description
path
String
A relative or absolute URL of the file that ImGearWebStream object will incapsulate.

Return Value:

New instance of ImGearWebStream Class object.


ImGearWebStream Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates a new instance of ImGearWebStream Class object.

Declaration:

public ImGearWebStream ( String path , System.Net.NetworkCredential credentials ,
System.Net.IWebProxy proxy )

Parameters:

Name
Type
Description
path
String
A relative or absolute URL of the file that ImGearWebStream object will incapsulate.
credentials
System.Net.NetworkCredential
Provides authentication information.
proxy
System.Net.IWebProxy
Provides proxy information.

Return Value:

New instance of ImGearWebStream Class object.


ImGearWebStream Properties

The ImGearWebStream Class of the ImageGear.Formats Namespace has the following properties:

Properties
Name
Description
CanRead Property
When overridden in a derived class, gets a value indicating whether the current stream supports reading.
CanSeek Property
When overridden in a derived class, gets a value indicating whether the current stream supports seeking.
CanWrite Property
When overridden in a derived class, gets a value indicating whether the current stream supports writing.
Length Property
When overridden in a derived class, gets the length in bytes of the stream.
Position Property
When overridden in a derived class, gets or sets the position within the current stream.


CanRead Property

32-bit
64-bit
CF
P
P
P

Description:

When overridden in a derived class, gets a value indicating whether the current stream supports reading.

Declaration:

public override bool CanRead { get }

Value:

True - the current stream supports reading, False - otherwise.


CanSeek Property

32-bit
64-bit
CF
P
P
P

Description:

When overridden in a derived class, gets a value indicating whether the current stream supports seeking.

Declaration:

public override bool CanSeek { get }

Value:

True - the current stream supports seeking, False - otherwise.


CanWrite Property

32-bit
64-bit
CF
P
P
P

Description:

When overridden in a derived class, gets a value indicating whether the current stream supports writing.

Declaration:

public override bool CanWrite { get }

Value:

True - the current stream supports writing, False - otherwise.


Length Property

32-bit
64-bit
CF
P
P
P

Description:

When overridden in a derived class, gets the length in bytes of the stream.

Declaration:

public override long Length { get }

Value:

Any positive value.


Position Property

32-bit
64-bit
CF
P
P
P

Description:

When overridden in a derived class, gets or sets the position within the current stream.

Declaration:

public override long Position { get, set }

Value:

Any positive value.


ImGearWebStream Methods

The ImGearWebStream Class of the ImageGear.Formats Namespace has the following methods:

Methods
Name
Description
Close Method
Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream.
Flush Method
When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device.
Read Method
When overridden in a derived class, reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read.
Seek Method
When overridden in a derived class, sets the position within the current stream.
SetLength Method
When overridden in a derived class, sets the length of the current stream.
Write Method
When overridden in a derived class, writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written.


Close Method

32-bit
64-bit
CF
P
P
P

Description:

Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream.

Declaration:

public override void Close (  )

Return Value:

None.


Flush Method

32-bit
64-bit
CF
P
P
P

Description:

When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device.

Declaration:

public override void Flush (  )

Return Value:

None


Read Method

32-bit
64-bit
CF
P
P
P

Description:

When overridden in a derived class, reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read.

Declaration:

public override System.Int32 Read ( byte[] buffer , Int offset , Int count )

Parameters:

Name
Type
Description
buffer
byte
When this method returns, contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the current source.
offset
Int
The byte offset in array at which to begin reading.
count
Int
The maximum number of bytes to read.

Return Value:

Integer value.


Seek Method

32-bit
64-bit
CF
P
P
P

Description:

When overridden in a derived class, sets the position within the current stream.

Declaration:

public override long Seek(long offset, System.IO.SeekOrigin origin)

Parameters:

Name
Type
Description
offset
long
The point relative to origin from which to begin seeking.
origin
System.IO.SeekOrigin
Specifies the beginning, the end, or the current position as a reference point for origin, using a value of type SeekOrigin.

Return Value:

Integer value.


SetLength Method

32-bit
64-bit
CF
P
P
P

Description:

When overridden in a derived class, sets the length of the current stream.

Declaration:

public override void SetLength(long value)

Parameters:

Name
Type
Description
value
long
The new length of the stream.

Return Value:

None


Write Method

32-bit
64-bit
CF
P
P
P

Description:

When overridden in a derived class, writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written.

Declaration:

public override void Write(byte[] buffer, int offset, int count)

Parameters:

Name
Type
Description
buffer
byte
The array to which bytes are written.
offset
int
The byte offset in array at which to begin writing.
count
int
The maximum number of bytes to write.

Return Value:

None.


ImageGear.Formats Namespace Interfaces

The ImageGear.Formats Namespace has the following interface members:

Interfaces:
Name
Description
IImGearFormat Interface
Base interface for all file formats (filters); provides access to format's settings


IImGearFormat Interface

32-bit
64-bit
CF
P
P
P

Description:

This is a base interface for all file formats (filters) and it provides access to format's settings.

Declaration:

public interface IImGearFormat

Members:

Properties
Name
Description
DefaultExtension Property
Default extension used when naming files containing images in this format (e.g., `*.bmp' for the BMP format).
DetectionEnabled Property
Specifies whether the format should be used in the image detection process.
FullName Property
The full name of the format.
ID Property
The ID of the format.
MIME Property
Provides the MIME Media Type assiciated with the format.
Name Property
The short name of the format.
Parameters Property
Provides access to format's control parameters.


IImGearFormat Properties

The IImGearFormat Interface of the ImageGear.Formats Namespace has the following properties:

Properties
Name
Description
DefaultExtension Property
Default extension used when naming files containing images in this format (e.g., `*.bmp' for the BMP format).
DetectionEnabled Property
Specifies whether the format should be used in the image detection process.
FullName Property
The full name of the format.
ID Property
The ID of the format.
MIME Property
Provides the MIME Media Type assiciated with the format.
Name Property
The short name of the format.
Parameters Property
Provides access to format's control parameters.


DefaultExtension Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the default extension used when naming files containing images in this format (e.g., `*.bmp' for the BMP format).

Declaration:

public string DefaultExtension { get; }

Value:

String containing format extension.

Remarks:

This property is used when populating the filter for the SaveFileDialog.


DetectionEnabled Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies whether the format should be used in the image detection process.

Declaration:

public bool DetectionEnabled { get; set }

Value:

True, false.

Remarks:

Detection is enabled for all formats by default. Use this property to exclude a format from detection.


FullName Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides the full name of the format.

Declaration:

public string FullName { get; }

Value:

String containing the format's name.


ID Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the ID of the format.

Declaration:

public ImGearFormats ID { get; }

Value:

Any member of the ImGearFormats Enumeration except `UNKNOWN'.

See Also:

ImGearFormats Enumeration


MIME Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides the MIME Media Type assiciated with the format, such as "image/jpeg", "image/tiff", etc.

Declaration:

public string MIMEType { get; }

Value:

String containing the format's MIME Type.


Name Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides the short name of the format.

Declaration:

public string Name { get; }

Value:

String containing the format's name.


Parameters Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides access to format's control parameters.

Declaration:

ImageGear.Formats.ImGearFormatParameters Parameters { get; }

Value:

An instance of the class for managing format's control parameters.

See Also:

ImGearFormatParameters Class


ImageGear.Formats Namespace Enumerations

The ImageGear.Formats Namespace has the following enumeration members:

Enumerations:
Name
Description
ImGearBMPTagIDs Enumeration
Lists all BMP tag identifiers
ImGearBTRTagIDs Enumeration
Lists all BTR tag identifiers
ImGearCALTagIDs Enumeration
Lists all CAL tag identifiers
ImGearCIFFCanonCameraSettingsTagIDs Enumeration
Lists all CIFF Canon Camera Settings tag identifiers
ImGearCIFFFocalLengthTagIDs Enumeration
Lists all CIFF Focal Length tag identifiers
ImGearCIFFImageInfoTagIDs Enumeration
Lists all CIFF Image Info tag identifiers
ImGearCIFFPictureInfoTagIDs Enumeration
Lists all CIFF Picture Info tag identifiers
ImGearCIFFShotInfoTagIDs Enumeration
Lists all CIFF Shot Info tag identifiers
ImGearCIFFTagIDs Enumeration
Lists all CIFF tag identifiers
ImGearCLPTagIDs Enumeration
Lists all CLP tag identifiers
ImGearCompressions Enumeration
Lists all compressions (e.g., Group 4, etc.)
ImGearCUTTagIDs Enumeration
Lists all CUT tag identifiers
ImGearDCRAWTagIDs Enumeration
Lists all Digital Camera RAW tag identifiers
ImGearDCXTagIDs Enumeration
Lists all DCX tag identifiers
ImGearDisplayInfoTagIDs Enumeration
Lists all Photoshop DisplayInfo tag identifiers
ImGearEXIFFPXRTagIDs Enumeration
Lists all EXIF FPXR tag identifiers
ImGearEXIFGPSTagIDs Enumeration
Lists all EXIF GPS tag identifiers
ImGearEXIFInterOpTagIDs Enumeration
Lists all EXIF Interoperability tag identifiers
ImGearEXIFMakerNoteFujiTagIDs Enumeration
Lists all Fujifilm EXIF MakerNote tag identifiers
ImGearEXIFMakerNoteNikonType1TagIDs Enumeration
Lists all Nikon EXIF MakerNote Type 1 tag identifiers
ImGearEXIFMakerNoteNikonType2TagIDs Enumeration
Lists all Nikon EXIF MakerNote Type 2 tag identifiers
ImGearEXIFMakerNoteOlympusTagIDs Enumeration
Lists all Olympus EXIF MakerNote tag identifiers
ImGearEXIFMakerNotePentaxTagIDs Enumeration
Lists all Pentax EXIF MakerNote tag identifiers
ImGearEXIFMakerNoteTagIDs Enumeration
Lists all general EXIF MakerNote tag identifiers
ImGearEXIFMakerNoteType Enumeration
Lists all EXIF MakerNote types
ImGearEXIFTagIDs Enumeration
Lists all EXIF tag identifiers
ImGearFillOrder Enumeration
Specifies fill order that is used for saving some file formats (e.g., TIFF, etc.).
ImGearFormats Enumeration
Lists all ImageGear supported file formats (e.g., TIFF, etc.)
ImGearGEMTagIDs Enumeration
Lists all GEM tag identifiers
ImGearGIFTagIDs Enumeration
Lists all GIF tag identifiers
ImGearHDPhotoTagIDs Enumeration
Lists all HDPhoto tag identifiers
ImGearICATagIDs Enumeration
Lists all ICA tag identifiers
ImGearICOTagIDs Enumeration
Lists all ICO tag identifiers
ImGearIFFTagIDs Enumeration
Lists all IFF tag identifiers
ImGearIMGTagIDs Enumeration
Lists all IMG tag identifiers
ImGearIMTTagIDs Enumeration
Lists all IMT tag identifiers
ImGearIPTCRecord1EnvDatasetTags Enumeration
Lists all IPTC Record 1 (Envelope) DataSet tags
ImGearIPTCRecord2AppDatasetTags Enumeration
Lists all IPTC Record 2 (Application) DataSet tags
ImGearIPTCRecord3PhotoDatasetTags Enumeration
Lists all IPTC Record 3 (Digital Newsphoto Parameter) DataSet tags
ImGearIPTCRecord7PreObjDatasetTags Enumeration
Lists all IPTC Record 7 (Pre-Object) DataSet tags
ImGearIPTCRecord8ObjDatasetTags Enumeration
Lists all IPTC Record 8 (Object) DataSet tags
ImGearIPTCRecord9PostObjDatasetTags Enumeration
Lists all IPTC Record 9 (Post-Object) DataSet tags
ImGearIPTCRecordTags Enumeration
Lists all IPTC Record tags
ImGearIPTCTags Enumeration
Lists all general IPTC tags
ImGearJP2TagIDs Enumeration
Lists all JP2 tag identifiers
ImGearJPEGTagIDs Enumeration
Lists all JPEG tag identifiers
ImGearJPXTagIDs Enumeration
Lists all JPX tag identifiers
ImGearKFXTagIDs Enumeration
Lists all KFX tag identifiers
ImGearLVTagIDs Enumeration
Lists all LV tag identifiers
ImGearMetadataFormats Enumeration
Lists all metadata formats; metadata formats correspond to the file formats for the most part, but some file formats (i.e., EXIF) define several metadata formats
ImGearMJ2TagIDs Enumeration
Lists all MJ2 tag identifiers
ImGearMSPTagIDs Enumeration
Lists all MSP tag identifiers
ImGearNativeDataTypes Enumeration
Specifies the data types that file formats use to store metadata values.
ImGearNCRTagIDs Enumeration
Lists all NCR tag identifiers
ImGearPBMTagIDs Enumeration
Lists all PBM tag identifiers
ImGearPCDTagIDs Enumeration
Lists all PCD tag identifiers
ImGearPCXTagIDs Enumeration
Lists all PCX tag identifiers
ImGearPhotoshopAdditionalLayerInfoTagIDs Enumeration
Lists all PhotoshopAdditionalLayerInfo tag identifiers
ImGearPhotoshopLayerInfoTagIDs Enumeration
Lists all PhotoshopLayerInfo tag identifiers
ImGearPhotoshopLayerMaskInfoTagIDs Enumeration
Lists all PhotoshopLayerMaskInfo tag identifiers
ImGearPhotoshopResourceGenericTagIDs Enumeration
Lists all PhotoshopResourceGeneric tag identifiers
ImGearPHOTOSHOPTagIDs Enumeration
Lists all Photoshop tag identifiers
ImGearPhotoshopVersionInfoTagIDs Enumeration
Lists all PhotoshopVersionInfo tag identifiers
ImGearPNGCompLevel Enumeration
Lists all PNG compression levels
ImGearPNGStrip Enumeration
Lists all PNG strip modes
ImGearPNGTagIDs Enumeration
Lists all PNG tag identifiers
ImGearPSDTagIDs Enumeration
Lists all PSD tag identifiers
ImGearPTOCATagIDs Enumeration
Lists all PTOCA tag identifiers
ImGearRASTagIDs Enumeration
Lists all RAS tag identifiers
ImGearRasterConversionModes Enumeration
Lists all raster conversion modes
ImGearRectangleInfoTagIDs Enumeration
Lists all Photoshop Rectangle Info tag ids
ImGearResolutionInfoTagIDs Enumeration
Lists all Photoshop Resolution Info tag ids
ImGearSavingFormats Enumeration
Lists all saving formats; saving format is a combination of a format and a compression (e.g., TIFF-G4)
ImGearSavingModes Enumeration
Lists all saving modes (e.g., overwrite image, insert page, etc.)
ImGearSCITagIDs Enumeration
Lists all SCI tag identifiers
ImGearSGITagIDs Enumeration
Lists all SGI tag identifiers
ImGearTGATagIDs Enumeration
Lists all TGA tag identifiers
ImGearThumbnailInfoTagIDs Enumeration
Lists all Photoshop Thumbnail Info tag identifiers
ImGearTIFTagIDs Enumeration
Lists all TIF tag identifiers
ImGearWBMPTagIDs Enumeration
Lists all WBMP tag identifiers
ImGearWPGTagIDs Enumeration
Lists all WPG tag identifiers
ImGearXBMTagIDs Enumeration
Lists all XBM tag identifiers
ImGearXPMTagIDs Enumeration
Lists all XPM tag identifiers
ImGearXWDTagIDs Enumeration
Lists all XWD tag identifiers


ImGearBMPTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all BMP tag identifiers.

Declaration:

public enum ImGearBMPTagIDs

Values:

Name
Value
Description
FORMAT
ImGearFormats.BMP
BMP
SIZE
100
Size
WIDTH
101
Width
HEIGHT
102
Height
PLANES
103
Planes
BITCOUNT
104
Bit count
COMPRESSION
105
Compression
XPELSPERMETER
106
X pels per meter
YPELSPERMETER
107
Y pels per meter
CLRUSED
108
CLR used
CLRIMPORTANT
109
CLR important
UNITS
110
Units
RECORDING
111
Recording
RENDERING
112
Rendering
SIZE1
113
Size 1
SIZE2
114
Size 2
COLORENCODING
115
Color encoding
IDENTIFIER
116
Identifier
TYPE
117
Type


ImGearBTRTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all BTR tag identifiers.

Declaration:

public enum ImGearBTRTagIDs

Values:

Name
Value
Description
FORMAT
ImGearMetadataFormats.BTR
BTR metadata format identifier
MANUFACTURER
900
Manufacturer
VERSION
901
Version
IMAGETYPE
902
Image type
HORZRES
903
Horizontal resolution
VERTRES
904
Vertical resolution
BITSPERPIXEL
905
Bits per pixel
PIXELSPERLINE
906
Pixels per line
STORAGEFMT
907
Storage format
TRANSFMT
908
Trans format
PREVPAGE
909
Previous page
NEXTPAGE
910
Next page
NUMLINES
911
Number of lines


ImGearCALTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all CAL tag identifiers.

Declaration:

public enum ImGearCALTagIDs

Values:

Name
Value
Description
FORMAT
ImGearMetadataFormats.CAL
CAL metadata format identifier
SPECVERSION
300
Spec version
SRCDOCID
301
Source doc id
DSTDOCID
302
Destination doc id
TXTFILID
303
Txt fil id
FIGID
304
Fig id
RTYPE
305
R type
RORIENT
306
RORIENT
RPELCNT
307
RPELCNT
RDENSITY
308
R density
SRCGPH
309
SRCGPH
DOCCLS
310
DOCCLS
FOSIPUBID
311
FOSIPUBID
NOTES
312
Notes


ImGearCIFFCanonCameraSettingsTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all CIFF Canon Camera Settings tag identifiers.

Declaration:

public enum ImGearCIFFCanonCameraSettingsTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.CIFFCanonCameraSettings
CIFFCanonCameraSettings metadata format identifier
MACRO_MODE
1
Macro mode
SELF_TIMER
2
Self-timer
QUALITY
3
Quality
CANON_FLASH_MODE
4
Canon flash mode
CONTINUOUS_DRIVE
5
Continuous drive
FOCUS_MODE
7
Focus mode
CANON_IMAGE_SIZE
10
Canon image size
EASY_MODE
11
Easy mode
DIGITAL_ZOOM
12
Digital zoom
CONTRAST
13
Contrast
SATURATION
14
Saturation
SHARPNESS
15
Sharpness
ISO
16
Camera ISO
METERING_MODE
17
Metering mode
FOCUS_TYPE
18
Focus type
AFPOINT
19
AF point
CANON_EXPOSURE_MODE
20
Canon exposure mode
LENS_TYPE
22
Lens type
LONG_FOCAL
23
Long focal
SHORT_FOCAL
24
Short focal
FOCAL_UNITS
25
Focal units
FLASH_ACTIVITY
28
Flash activity
FLASH_BITS
29
Flash bits
FOCUS_CONTINUOUS
32
Focus continuous
ZOOMED_RESOLUTION
36
Zoomed resolution
ZOOMED_RESOLUTION_BASE
37
Zoomed resolution base
COLOR_TONE
42
Color tone


ImGearCIFFFocalLengthTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all CIFF Focal Length tag identifiers.

Declaration:

public enum ImGearCIFFFocalLengthTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.CIFFFocalLength
CIFFFocalLength metadata format identifier
LENGTH
1
Focal length
PLANE_XSIZE
2
Focal plane X size
PLANE_YSIZE
3
Focal plane Y size


ImGearCIFFImageInfoTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all CIFF Image Info tag identifiers.

Declaration:

public enum ImGearCIFFImageInfoTagIDs

Value

Name
Value
Description
FORMAT
ImGearMetadataFormats.CIFFImageInfo
CIFF Image Info metadata format identifier
WIDTH
0
Image width
HEIGHT
1
Image height
PIXEL_ASPECT_RATIO
2
Pixel aspect ratio
ROTATION
3
Rotation
COMPONENT_BIT_DEPTH
4
Component bit depth
COLOR_BIT_DEPTH
5
Color bit depth
COLOR_BW
6
Color BW


ImGearCIFFPictureInfoTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all CIFF Picture Info tag identifiers.

Declaration:

public enum ImGearCIFFPictureInfoTagIDs

Values:

Name
Value
Description
FORMAT
ImGearMetadataFormats.CIFFPictureInfo
CIFF Picture Info metadata format identifier
IMAGE_WIDTH
2
Canon image width
IMAGE_HEIGHT
3
Canon image height
IMAGE_WIDTH_AS_SHOT
4
Canon image width as shot
IMAGE_HEIGHT_AS_SHOT
5
Canon image height as shot
AFPOINTS_USED
22
AF points used


ImGearCIFFShotInfoTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all CIFF Shot Info tag identifiers.

Declaration:

public enum ImGearCIFFShotInfoTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.CIFFShotInfo
CIFF Shot Info metadata format identifier
ISO
2
ISO
EXPOSURE_COMPENSATION
6
Exposure compensation
WHITE_BALANCE
7
White balance
SEQUENCE_NUMBER
9
Sequence number
IXUS_AFPOINT
14
Ixus AF point
FLASH_EXPOSURE_COMP
15
Flash exposure comp
AUTO_EXPOSURE_BRACKETING
16
Auto exposure bracketing
AEBBRACKET_VALUE
17
AEB bracket value
FOCUS_DISTANCE_UPPER
19
Focus distance upper
FOCUS_DISTANCE_LOWER
20
Focus distance lower
FNUMBER
21
F number
EXPOSURE_TIME
22
Exposure time
BULB_DURATION
24
Bulb duration
AUTO_ROTATE
27
Auto rotate
SELF_TIMER2
29
Self-timer 2


ImGearCIFFTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all CIFF tag identifiers.

Declaration:

public enum ImGearCIFFTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.CIFF
CIFF metadata format identifier
NULL_RECORD
0x0000
Null record
FREE_BYTES
0x0001
Free bytes
CANON_COLOR_INFO1
0x0032
Canon color info 1
CANON_FILE_DESCRIPTION
0x0805
Canon file description
USER_COMMENT
0x0805
User comment
CANON_RAW_MAKE_MODEL
0x080A
Canon raw make model
CANON_FIRMWARE_VERSION
0x080B
Canon firmware version
COMPONENT_VERSION
0x080C
Component version
ROM_OPERATION_MODE
0x080D
ROM operation mode
OWNER_NAME
0x0810
Owner name
CANON_IMAGE_TYPE
0x0815
Canon image type
ORIGINAL_FILE_NAME
0x0816
Original file name
THUMBNAIL_FILE_NAME
0x0817
Thumbnail file name
TARGET_IMAGE_TYPE
0x100A
Target image type
SHUTTER_RELEASE_METHOD
0x1010
Shutter release method
SHUTTER_RELEASE_TIMING
0x1011
Shutter release timing
RELEASE_SETTING
0x1016
Release setting
BASE_ISO
0x101C
Base ISO
FOCAL_LENGTH
0x1029
Focal length
CANON_SHOT_INFO
0x102A
Canon shot info
CANON_COLOR_INFO2
0x102C
Canon color info 2
CANON_CAMERA_SETTINGS
0x102D
Canon camera settings
WHITE_SAMPLE
0x1030
White sample
SENSOR_INFO
0x1031
Sensor info
CANON_CUSTOM_FUNCTIONS
0x1033
Canon custom functions
CANON_PICTURE_INFO
0x1038
Canon picture info
WHITE_BALANCE_TABLE
0x10A9
White balance table
COLOR_TEMPERATURE
0x10AE
Color temperature
COLOR_SPACE
0x10B4
Color space
IMAGE_FORMAT
0x1803
Image format
RECORD_ID
0x1804
Record ID
SELF_TIMER_TIME
0x1806
Self timer time
TARGET_DISTANCE_SETTING
0x1807
Target distance setting
SERIAL_NUMBER
0x180B
Serial number
TIME_STAMP
0x180E
Time stamp
IMAGE_INFO
0x1810
Image info
FLASH_INFO
0x1813
Flash info
MEASURED_EV
0x1814
Measured EV
FILE_NUMBER
0x1817
File number
EXPOSURE_INFO
0x1818
Exposure info
DECODER_TABLE
0x1835
Decoder table
RAW_DATA
0x2005
Raw data
JPG_FROM_RAW
0x2007
Jpg from raw
THUMBNAIL_IMAGE
0x2008
Thumbnail image
IMAGE_DESCRIPTION
0x2804
Image description
CAMERA_OBJECT
0x2807
Camera object
SHOOTING_RECORD
0x3002
Shooting record
MEASURED_INFO
0x3003
Measured info
CAMERA_SPECIFICATION
0x3004
Camera specification
IMAGE_PROPS
0x300A
Image props
EXIF_INFORMATION
0x300B
Exif information


ImGearCLPTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all CLP tag identifiers.

Declaration:

public enum ImGearCLPTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.CLP
CLP metadata format identifier
FILE_ID
1701
File id
FORMAT_COUNT
1702
Format count


ImGearCompressions Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration contains IDs of image compressions.

Declaration:

public enum ImGearCompressions

Values:

Name
Value
Description
ABIC
IBM ABIC compression
ABIC_BW
IBM ABIC Bilevel compression
ABIC_GRAY
IBM ABIC Concatenated compression
ASCII
ASCII
AUTO
Compression is selected by the format.
AUTO
On loading: compression is unknown
On saving: compression is selected by file format.
CANON_CRW
Canon CRW compression
CCITT_G3
CCITT Group 3
CCITT_G32D
CCITT Group 3 2D
CCITT_G4
CCITT Group 4
DEFLATE
Deflate
HDPhoto
HD Photo compression
HUFFMAN
Huffman
IBM_MMR
IBM MMR
JBIG
JBIG compression
JBIG2
JBIG2 compression
JPEG
JPEG
JPEG2K
JPEG 2000
KODAK_RAW
Kodak RAW compression
LZW
LZW
NONE
Uncompressed
PACKED_BITS
Packed bits
RAW
Raw
RLE
Run Length Encoded


ImGearCUTTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all CUT tag identifiers.

Declaration:

public enum ImGearCUTTagIDs

Values:

Name
Value
Description
FORMAT
ImGearMetadataFormats.CUT
CUT metadata format identifier
WIDTH
0
Width
HEIGHT
1
Height
RESERVED
2
Reserved


ImGearDCRAWTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all Digital Camera RAW tag identifiers.

Declaration:

public enum ImGearDCRAWTagIDs

Values:

Name
Value
Description
FORMAT
ImGearMetadataFormats.DCRAW
DCRAW metadata format identifier
COMMON
4200
Common
STATISTICS
4201
Statistics
IMAGEWIDTH
4202
Image width
IMAGEHEIGHT
4203
Image height
BITSPERSAMPLE
4204
Bits per sample
PHOTOMETRICINTERPRETATION
4205
Photometric interpretation
SAMPLESPERPIXEL
4206
Samples per pixel
UNIQUECAMERAMODEL
4207
Unique camera model
MAKE
4208
Make
MODEL
4209
Model
TIMESTAMP
4210
Time stamp
CFAREPEATPATTERNDIM
4211
CFA repeat pattern dim
CFAPATTERN
4212
CFA pattern
BLACKLEVELREPEATDIM
4213
Black level repeat dim
BLACKLEVEL
4214
Black level
ASSHOTNEUTRAL
4215
As shot neutral
WHITELEVEL
4216
White level
CALIBRATIONILLUMINANT1
4217
Calibration illuminant 1
CALIBRATIONILLUMINANT2
4218
Calibration illuminant 2
COLORMATRIX1
4219
Color matrix 1
COLORMATRIX2
4220
Color matrix 2
BASELINEEXPOSURE
4221
Baseline exposure
RAWLEFT
4222
Raw left
RAWTOP
4223
Raw top
RAWWIDTH
4224
Raw width
RAWHEIGHT
4225
Raw height
COLORPLANES
4226
Color planes


ImGearDCXTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all DCX tag identifiers.

Declaration:

public enum ImGearDCXTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.DCX
DCX metadata format identifier
MAGIC
500
Magic
PAGE_LIST
501
Page list


ImGearDisplayInfoTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all Photoshop DisplayInfo tag identifiers.

Declaration:

public enum ImGearDisplayInfoTagIDs

Values:

Name
Value
Description
FORMAT
ImGearMetadataFormats.DisplayInfo
Display info metadata format identifier
LENGTH
0
Length
DATA
1
Data


ImGearEXIFFPXRTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all EXIF FPXR tag identifiers.

Declaration:

public enum ImGearEXIFFPXRTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.EXIF_FPXR
EXIF_FPXR metadata format identifier
HEADER
61221
FPXR_HEADER
VERSION
61222
FPXR version
EXTENSIONID
61223
FPXR extension ID
INTEROPERABILITYCOUNT
61224
FPXR interoperability count
INDEXTOCONTENTSLIST
61225
FPXR index to contents list
OFFSETTOSTREAM
61226
FPXR offset to stream
STREAMDATA
61227
FPXR stream data
RESERVEDDATA
61228
FPXR reserved data


ImGearEXIFGPSTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all EXIF GPS tag identifiers.

Declaration:

public enum ImGearEXIFGPSTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.EXIF_GPS
EXIF_GPS metadata format identifier
VERSIONID
0
GPS version ID
LATITUDEREF
1
GPS latitude ref
LATITUDE
2
GPS latitude
LONGITUDEREF
3
GPS longitude ref
LONGITUDE
4
GPS longitude
ALTITUDEREF
5
GPS altitude ref
ALTITUDE
6
GPS altitude
TIMESTAMP
7
GPS time stamp
SATELLITES
8
GPS satellites
STATUS
9
GPS status
MEASUREMODE
10
GPS measure mode
DOP
11
GPS DOP
SPEEDREF
12
GPS speed ref
SPEED
13
GPS speed
TRACKREF
14
GPS track ref
TRACK
15
GPS track
IMGDIRECTIONREF
16
GPS img direction ref
IMGDIRECTION
17
GPS img direction
MAPDATUM
18
GPS map datum
DESTLATITUDEREF
19
GPS dest latitude ref
DESTLATITUDE
20
GPS dest latitude
DESTLONGITUDEREF
21
GPS dest longitude ref
DESTLONGITUDE
22
GPS dest longitude
DESTBEARINGREF
23
GPS dest bearing ref
DESTBEARING
24
GPS dest bearing
DESTDISTANCEREF
25
GPS dest distance ref
DESTDISTANCE
26
GPS dest distance
PROCESSINGMETHOD
27
GPS processing method
AREAINFORMATION
28
GPS area information
DATESTAMP
29
GPS date stamp
DIFFERENTIAL
30
GPS differential


ImGearEXIFInterOpTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all EXIF Interoperability tag identifiers.

Declaration:

public enum ImGearEXIFInterOpTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.EXIF_InterOp
EXIF_Interoperability metadata format identifier
INTEROPERABILITYINDEX
1
Interoperability index
INTEROPERABILITYVERSION
2
Interoperability version
RELATEDIMAGEFILEFORMAT
4096
Related image file format
RELATEDIMAGEWIDTH
4097
Related image width
RELATEDIMAGELENGTH
4098
Related image length


ImGearEXIFMakerNoteFujiTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all Fujifilm EXIF MakerNote tag identifiers.

Declaration:

public enum ImGearEXIFMakerNoteFujiTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.EXIF_MakerNote_Fuji
EXIF_MakerNote_Fuji metadata format identifier
VERSION
0x0000
Version
QUALITY
0x1000
Quality
SHARPNESS
0x1001
Sharpness
WHITEBALANCE
0x1002
White balance
COLOUR
0x1003
Color
TONE
0x1004
Tone
FLASHMODE
0x1010
Flash mode
FLASHSTRENGTH
0x1011
Flash strength
MACRO
0x1020
Macro
FOCUSMODE
0x1021
Focus mode
SLOWSYNCMODE
0x1030
Slow synchro mode
PICTUREMODE
0x1031
Picture mode
CONTINUOUSTAKINGORAUTOBRACKETINGMODE
0x1100
Continuous taking or auto bracketting mode
BLURWARNING
0x1300
Blur warning
FOCUSWARNING
0x1301
Focus warning
AUTOEXPOSUREWARNING
0x1302
Auto exposure warning


ImGearEXIFMakerNoteNikonType1TagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all Nikon EXIF MakerNote Type 1 tag identifiers.

Declaration:

public enum ImGearEXIFMakerNoteNikonType1TagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.EXIF_MakerNote_NikonType1
EXIF_MakerNote_NikonType metadata format identifier
QUALITY
3
Quality
COLOURMODE
4
Colour mode
IMAGEADJUSTMENT
5
Image adjustment
CCDSENSITIVITY
6
CCD sensitivity
WHITEBALANCELOOKUP
7
White balance look up
WHITEBALANCE
8
White balance
DIGITALZOOM
10
Digital zoom
CONVERTER
11
Converter


ImGearEXIFMakerNoteNikonType2TagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all Nikon EXIF MakerNote Type 2 tag identifiers.

Declaration:

public enum ImGearEXIFMakerNoteNikonType2TagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.EXIF_MakerNote_NikonType2
EXIF_MakerNote_NikonType2 metadata format identifier
NIKONMAKERNOTEVERSION
1
Nikon makernote version
ISOSPEEDUSED
2
ISO speed used
COLOURMODE1
3
Colour mode
QUALITY
4
Quality
WHITEBALANCE
5
White balance
SHARPNING
6
Sharpening
FOCUSMODE
7
Focus mode
FLASHSETTING
8
Flash setting
AUTOFLASHMODE
9
Auto flash mode
WHITEBALANCEBIASVALUE
11
White balance bias value
WHITEBALANCEREDBLUECOEFFISIENTS
12
White balance red blue coefficients
ISOSELECTION
15
ISO selection
FLASHCOMPENSATION
18
Flash compensation
ISOSPEEDREQUESTED
19
ISO speed requested
PHOTOCORNERCOORDINATES
22
Photo corner coordinates
FLASHBRACKETCOMPENSATIONAPPLIED
24
Flash bracket compensation applied
AEBRACKETCOMPENSATIONAPPLIED
25
AE bracket compensation applied
IMAGEADJUSTMENT
128
Image adjustment
TONECOMPENSATION
129
Tone compensation
AUXILIARYLENS
130
Auxiliary lens
LENSTYPE
131
Lens type
LENSMINMAXFOCALLENGTHMAXAPERTURE
132
Lens min/Max focal length max aperture
MANUALFOCUSDISTANCE
133
Manual focus distance
DIGITALZOOMFACTOR
134
Digital zoom factor
FLASHUSED
135
Flash used
AUTOFOCUSAREA
136
Auto focus area
BRACKETINGANDSHOOTINGMODE
137
Bracketing and shooting mode
COLOURMODE2
141
Colour mode
SCENEMODE
143
Scene mode
LIGHTINGTYPE
144
Lighting type
HUEADJUSTMENT
146
Hue adjustment
SATURATIONLOOKUP
148
Saturation
NOISEREDUCTION
149
Noise reduction
TOTALNUMBEROFSHUTTERRELEASESFORCAMERA
167
Total numberof shutter releasesfor camera
IMAGEOPTIMIZATION
169
Image optimization
SATURATION
170
Saturation
DIGITALVARIPROGRAM
171
Digital vari program


ImGearEXIFMakerNoteOlympusTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all Olympus EXIF MakerNote tag identifiers.

Declaration:

public enum ImGearEXIFMakerNoteOlympusTagIDs

Values:

Name
Value
Description
FORMAT
ImGearMetadataFormats.EXIF_MakerNote_Olympus
EXIF_MakerNote_Olympus metadata format identifier
SPECIALMODE
512
Special mode
QUALITY
513
Quality
MAKRO
514
Macro
BWMODE
515
BW mode
DIGITALZOOM
516
Digital zoom
FOCALPLANEDIAGONAL
517
Focal plane diagonal
FIRMWAREVERSION
519
Firmware version
PICTUREINFO
520
Picture info
CAMERAID
521
Camera ID
PRECAPTUREFRAMES
768
Pre capture frames
ONETOUCHWB
770
One touch WB
DATADUMP
3840
Data dump
FLASHMODE
4100
Flash mode
FLASHDEVICE
4101
Flash device
BRACKET
4102
Bracket
FOCUSMODE
4107
Focus mode
FOCUSDISTANCE
4108
Focus distance
ZOOM
4109
Zoom
MACROFOCUS
4110
Macro focus
SHARPNESS
4111
Sharpness factor
COLORMATRIX
4113
Color matrix
BLACKLEVEL
4114
Black level
WHITEBALANCE
4117
White balance
REDBALANCE
4119
Red balance
BLUEBALANCE
4120
Blue balance
SERIALNUMBER
4122
Serial number
FLASHBIAS
4131
Flash bias
CONTRAST
4137
Contrast
SHARPNESSFACTOR
4138
Sharpness factor
COLORCONTROL
4139
Color control
VALIDBITS
4140
Valid bits
CORINGFILTER
4141
Coring filter
IMAGEWIDTH
4142
Image width
IMAGEHEIGHT
4143
Image height


ImGearEXIFMakerNotePentaxTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all Pentax EXIF MakerNote tag identifiers.

Declaration:

public enum ImGearEXIFMakerNotePentaxTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.EXIF_MakerNote_Pentax
EXIF_MakerNote_Pentax metadata format identifier
CAPTUREMODE
1
Capture mode
QUALITYLEVEL
2
Quality level
FOCUSMODE
3
Focus mode
FLASHMODE
3
Flash mode
WHITEBALANCE
7
White balance
DIGITALZOOM
10
Digital zoom
SHARPNESS
11
Sharpness
CONTRAST
12
Contrast
SATURATION
13
Saturation
ISOSPEED
20
ISO speed
COLOUR
23
Colour
PRINTIMAGEMMATCHINGINFO
3584
Print image matching info
TIMEZONE
0x1000
Time zone
DAYLIGHTSAVINGS
0x1001
Daylight savings


ImGearEXIFMakerNoteTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all general EXIF MakerNote tag identifiers.

Declaration:

public enum ImGearEXIFMakerNoteTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.EXIF_MakerNote
EXIF_Maker note metadata format identifier
TYPE
1
Type
PREFIX
2
Makernote prefix
BINARY
1000
Binary data
DATA_IFD
1001
Data IFD


ImGearEXIFMakerNoteType Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all EXIF MakerNote types.

Declaration:

public enum ImGearEXIFMakerNoteType

Values:

Name
Value
Description
UNKNOWN
0
Unknown. This is the default type. This type means that ImageGear can't decect Makernote as any other type. Preserving such makernote and saving it with the file, most likely, does not make any sence, because IFD offsets will be corrupted.
IFD
1
TIFF IFD. Makernote is a valid TIF IFD.
IFD_PREFIXED
2
Prefixed TIFF IFD. Same as IFD, but with a short prefix before the IFD. The prefix is also preserved, so the whole Makernote is preserved when writing to a file.
TIF_HEADER_PREFIXED
3
Makernote starts with a prefix, then goes TIF image header, which points to an IFD.
IFD_PREFIXED_OFFSET_II
4
Makernote starts with a prefix, then goes offset to the IFD, then IFD itself. Makernote IFD uses Intel byte ordering (II), even though the whole file uses Motorola ordering.
IG_MAKERNOTE_TYPES_MAX
4
Keep the number identical to the last makernote type


ImGearEXIFTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all EXIF tag identifiers.

Declaration:

public enum ImGearEXIFTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.EXIF
EXIF metadata format identifier
EXPOSURETIME
33434
Exposure time
FNUMBER
33437
F number
EXPOSUREPROGRAM
34850
Exposure program
SPECTRALSENSITIVITY
34852
Spectral sensitivity
ISOSPEEDRATING
34855
ISO speed ratings
OECF
34856
OECF
VERSION
36864
Exif version
DATETIMEORIGINAL
36867
Date time original
DATETIMEDIGITIZED
36868
Date time digitized
COMPONENTCONFIGURATION
37121
Components configuration
COMPRESSEDBITSPERPIXEL
37122
Compressed bits per pixel
SHUTTERSPEEDVALUE
37377
Shutter speed value
APERTUREVALUE
37378
Aperture value
BRIGHTNESSVALUE
37379
Brightness value
EXPOSUREBIASVALUE
37380
Exposure bias value
MAXAPERTUREVALUE
37381
Max aperture value
SUBJECTDISTANCE
37382
Subject distance
METERINGMODE
37383
Metering mode
LIGHTSOURCE
37384
Light source
FLASH
37385
Flash
FOCALLENGTH
37386
Focal length
SUBJECTAREA
37396
Subject area
MAKERNOTE
37500
Maker note
USERCOMMENT
37510
User comment
SUBSECTIME
37520
Sub sec time
SUBSECTIMEORIGINAL
37521
Sub sec time original
SUBSECTIMEDIGITIZED
37522
Sub sec time digitized
FLASHPIXVERSION
40960
Flash pix version
COLORSPACE
40961
Color space
PIXELXDIMENSION
40962
Pixel X dimension
PIXELYDIMENSION
40963
Pixel Y dimension
RELATEDSOUNDFILE
40964
Related sound file
INTEROPERABILITYIFD
40965
Interoperability IFD pointer
FLASHENERGY
41483
Flash energy
SPATIALFREQUENCYRESPONSE
41484
Spatial frequency response
FOCALPLANEXRESOLUTION
41486
Focal plane X resolution
FOCALPLANEYRESOLUTION
41487
Focal plane Y resolution
FOCALPLANERESOLUTIONUNIT
41488
Focal plane resolution unit
SUBJECTLOCATION
41492
Subject location
EXPOSUREINDEX
41493
Exposure index
SENSINGMETHOD
41495
Sensing method
FILESOURCE
41728
File source
SCENETYPE
41729
Scene type
CFAPATTERN
41730
CFA pattern
CUSTOMRENDERED
41985
Custom rendered
EXPOSUREMODE
41986
Exposure mode
WHITEBALANCE
41987
White balance
DIGITALZOOMRATIO
41988
Digital zoom ratio
FOCALLENGTHIN35MMFILM
41989
Focal length in 35mm film
SCENECAPTURETYPE
41990
Scene capture type
GAINCONTROL
41991
Gain control
CONTRAST
41992
Contrast
SATURATION
41993
Saturation
SHARPNESS
41994
Sharpness
DEVICESETTINGDESCRIPTION
41995
Device setting description
SUBJECTDISTANCERANGE
41996
Subject distance range
IMAGEUNIQUEID
42016
Image unique ID
HEADER
59935
Header


ImGearFillOrder Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies fill order that is used for saving some file formats, like TIFF, CCITT Group3/Group4, etc., or for loading raw CCITT data.

Declaration:

public enum ImGearFillOrder

Values:

Name
Value
Description
LSB
Least significant bit is stored first
MSB
Most significant bit is stored first


ImGearFormats Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration contains IDs of file formats.

Declaration:

public enum ImGearFormats

Values:

Name
Value
Description
Adobe DNG
Digital Negative file format
Adobe PDF
Adobe Portable Document Format.
Adobe PS
PostScript language files.
Adobe PSB
Adobe Photoshop Big
Adobe PSD
Adobe Photoshop
BMP
Standard Windows format including OS/2 bitmap format
BTR
Brooktrout FAX format, Group III or Group III 2D or 301
CAL
CALS raster, Type I
CGM
Computer Graphics Metafile.
CLP
Windows Clipboard format for raster images
CUR
For reading Windows 3.x and Windows95 mouse cursor display.
CUT
Dr. Halo CUT format
DCRaw
1300
Digital camera RAW format
DCX
Intel multi-page FAX format
DGN
MicroStation Drawing (Drawing format used by MicroStation construction design software).
DIB
DIB (Microsoft Windows Device Independent Bitmap).
DICOM
DICOM is a public standard that provides a flexible and expandable means for storing, sharing, and transporting digital medical images.
DWG
DWG (AutoDesk AutoCAD) format.
DXF
DXF (AutoDesk AutoCAD) format.
GEM
GEM Paint Raster format
GIF
Graphic Image Format developed originally in accommodate the transmission of images via a modem; uses LZW compression algorithm.
HPGL
Hewlett-Packard Graphics Language format.
IBM IOCA
Image Object Content Architecture, Group III, Group III 2D, Group IV, IBM MMR, uncompressed.
IBM MO:DCA
Mixed Object Document Content Architecture format, Group III, Group III 2D, Group IV, IBM MMR, uncompressed.
ICO
Windows ICON format.
IFF
Electronic Arts format.
IMG
Xerox raster format, Group IV
IMR
IMRS-Raster image format.
IMT
IMNET format, Groups III and IV.
JPEG
ANSI-standard, full-color image format; IG supports all aspects of this format including lossless and progressive; JFIF - industry standard header for JPEG compressed images
JPEG2000
New JPEG 2000 standard, based on the EBCOT (Embedded Block Coding with Optimized Truncation of the embedded bitstreams) algorithm;
JPX
JPX file format is an extension to JPEG 2000 file format. .
KFX
Kofax format, Group IV
LV
LaserView, LaserData, Group IV
Motion JPEG2000
Motion JPEG2000 file format is designed to contain one or more motion sequences of JPEG2000 images. .
MSP
Microsoft Paint format
NCR
NCR Group IV format.
PBM
Portable BitMap (UNIX graphic file format)
PCD
Kodak format for high resolution photographs
PCX
PC Paintbrush format
PGM
Portable BitMap (UNIX graphic file format)
PNG
Portable Network Graphics, intended as successor to GIF
PNM
Portable BitMap (UNIX graphic file format)
PPM
Portable BitMap (UNIX graphic file format)
PTOCA
Presentation Text Object Content Architecture support for IBM's AFP printer architecture.
RAS
SUN raster format
Scitex CT
For electronic pre-press and visual communications systems, part of the HandShake Foreign File Transfer Protocol, a standard for defining storage formats and data interchange protocols
SGI
Silicon Graphics raster format
TGA
Targa file format. ImageGear supports many aspects of this format including alpha channel
TIFF
Tagged Image File Format; IG supports every aspect of this format
U3D
Universal 3D format
WBMP
Optimized to support mobile computing devices that use the Wireless Application Protocol (WAP).
WPG
Wordperfect Graphic Format. IG reads bitmaps stored in this format
XBM
X Windows Bitmap format
XPM
X Windows Pixmap format
XWD
X Windows Dump format


ImGearGEMTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all GEM tag identifiers.

Declaration:

public enum ImGearGEMTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.GEM
GEM metadata format identifier
VERSION
0
Version
HEADERSIZE
1
Header size
PLANES
2
Planes
PATTERNLENGTH
3
Pattern length
WIDTH
4
Width
HEIGHT
5
Height


ImGearGIFTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all GIF tag identifiers.

Declaration:

public enum ImGearGIFTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.GIF
GIF metadata format identifier
HEADER
0x10
GIF header
HDR_SIGNATURE
0x101
Signature
HDR_VERSION
0x102
Version
SCREEN_DESCRIPTOR
0x20
Logical screen descriptor
SCR_SCREEN_WIDTH
0x201
Logical screen width
SCR_SCREEN_HEIGHT
0x202
Logical screen height
SCR_BACKGROUND_COLOR
0x203
Background color index
SCR_ASPECT_RATIO
0x204
Pixel aspect ratio
SCR_FIELDS
0x205
Fields
SCR_FLD_GL_COLOR_TABLE
0x206
Global color table flag
SCR_FLD_COLOR_RES
0x207
Color resolution
SCR_FLD_SORT
0x208
Sort flag
SCR_FLD_SIZE
0x209
Global color table size
GLOBAL_COLOR_TABLE
0x30
Global color table
IMAGE_DESCRIPTOR
0x2C
Image descriptor
IMG_LEFT_POSITION
0x2C1
Image left position
IMG_TOP_POSITION
0x2C2
Image top position
IMG_IMAGE_WIDTH
0x2C3
Image width
IMG_IMAGE_HEIGHT
0x2C4
Image height
IMG_FIELDS
0x2C5
Fields
IMG_FLD_LOC_COLOR_TABLE
0x2C6
Local color table flag
IMG_FLD_INTERLACE
0x2C7
Interlace flag
IMG_FLD_SORT
0x2C8
Sort flag
IMG_FLD_SIZE
0x2C9
Local color table size
LOCAL_COLOR_TABLE
0x40
Local color table
GRAPHIC_CONTROL_EXT
0xF9
Graphic control extension
GCE_FIELDS
0xF91
Fields
GCE_FLD_DISPOSAL_METHOD
0xF92
Disposal method
GCE_FLD_USER_INPUT
0xF93
User input flag
GCE_FLD_TRANSPARENT
0xF94
Transparent color flag
GCE_DELAY_TIME
0xF95
Delay time
GCE_TRANSPARENT_COLOR
0xF96
Transparent color index
COMMENT_EXTENSION
0xFE
Comment extension
PLAIN_TEXT_EXTENSION
0x01
Plain text extension
TXT_GRID_LEFT
0x11
Text grid left position
TXT_GRID_TOP
0x12
Text grid top position
TXT_GRID_WIDTH
0x13
Text grid width
TXT_GRID_HEIGHT
0x14
Text grid height
TXT_CELL_WIDTH
0x15
Character cell width
TXT_CELL_HEIGHT
0x16
Character cell height
TXT_FOREGROUND_COLOR
0x17
Text foreground color index
TXT_BACKGROUND_COLOR
0x18
Text background color index
TXT_TEXT_DATA
0x19
Plain text data
APP_EXTENSION
0xFF
Application extension
APP_IDENTIFIER
0xFF1
Application identifier
APP_AUTH_CODE
0xFF2
Application authentication code
APP_DATA
0xFF3
Application data
AFTER_IMAGE_EXT
0xFFF
After image extensions


ImGearHDPhotoTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all HD Photo tag identifiers.

Declaration:

public enum ImGearHDPhotoTagIDs

Values:

Name
Value
Description
FORMAT
ImGearMetadataFormats.HDPHOTO
CONTAINER_LEVEL
Container level
FRAME_LEVEL
Frame level
APPLICATION_NAME
Application name
AUTHORS
Authors
AUTHOR
Author
CAMERA_MANUFACTURER
Camera manufacturer
CAMERA_MODEL
Camera model
COMMENT
Comment
COPYRIGHT
Copyright
DATE_TAKEN
Date taken
KEYWORDS
Keywords
KEYWORD
Keyword
RATING
Rating
SUBJECT
Subject
TITLE
Title


ImGearICATagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all IOCA tag identifiers.

Declaration:

public enum ImGearICATagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.ICA
IOCA metadata format identifier
WIDTH
1001
Width
HEIGHT
1002
Height
DEPTH
1003
Depth
XDPI
1004
XDPI
YDPI
1005
YDPI
BITORDER
1006
Bit order
BASE
1007
Base
COMPRESSION
1008
Compression
FILLORDER
1009
Fill order


ImGearICOTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all ICO tag identifiers.

Declaration:

public enum ImGearICOTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.ICO
ICO metadata format identifier
PAGE_METADATA
1
Page metadata
DOCUMENT_METADATA
2
Document metadata
TYPE
3
Type
COUNT
4
Count


ImGearIFFTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all IFF tag identifiers.

Declaration:

public enum ImGearIFFTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.IFF
IFF metadata format identifier
WIDE
0
Wide
HIGH
1
High
XORG
2
XORG
YORG
3
YORG
PLANES
4
Planes
MASK
5
Mask
COMPRESSION
6
Compression
TRAN_ASPT
7
Tran aspt
PAGE_W
8
Page width
PAGE_H
9
Page height
VIEW_MODE
10
View mode
TRANSP_COLOR
11
Transp color
X_ASPECT
12
X aspect
Y_ASPECT
13
Y aspect


ImGearIMGTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all IMG tag identifiers.

Declaration:

public enum ImGearIMGTagIDs

Values:

Name
Value
Description
FORMAT
ImGearMetadataFormats.IMG
IMG metadata format identifier


ImGearIMTTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all IMT tag identifiers.

Declaration:

public enum ImGearIMTTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.IMT
IMT metadata format identifier
TYPE
1000
Type
FMT
1001
Fmt
HEIGHT
1002
Height
WIDTH
1003
Width
RESOLUTION
1004
Resolution
BITSWAP
1005
Swap bits
SWAB
1006
Swap byte
INVERT
1007
Invert


ImGearIPTCRecord1EnvDatasetTags Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all IPTC Record 1 (Envelope) DataSet tags.

Declaration:

public enum ImGearIPTCRecord1EnvDatasetTags

Values:

Name
Value
Description
FORMAT
ImGearMetadataFormats.IPTC_EnvDataset
IPTC_EnvDataset metadata format identifier
MODEL_VERSION
0
Model version
DESTINATION
5
Destination
FILE_FORMAT
20
File format
FILE_FORMAT_VERSION
22
File format version
SERVICE_IDENTIFIER
30
Service identifier
ENVELOPE_NUMBER
40
Envelope number
PRODUCT_ID
50
Product ID
ENVELOPE_PRIORITY
60
Envelope priority
DATE_SENT
70
Date sent
TIME_SENT
80
Time sent
CODED_CHARACTER_SET
90
Coded character set
UNO
100
UNO
ARM_IDENTIFIER
120
ARM identifier
ARM_VERSION
122
ARM version


ImGearIPTCRecord2AppDatasetTags Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all IPTC Record 2 (Application) DataSet tags.

Declaration:

public enum ImGearIPTCRecord2AppDatasetTags

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.IPTC_AppDataset
IPTC_AppDataset metadata format identifier
RECORD_VERSION
0
Record version
OBJ_TYPE_REF
3
Object type reference
OBJ_ATTRIBUTE_REF
4
Object attribute reference
OBJ_NAME
5
Object name
EDIT_STATUS
7
Edit status
EDITORIAL_UPDATE
8
Editorial update
URGENCY
10
Urgency
SUBJECT_REFERENCE
12
Subject reference
CATEGORY
15
Category
SUPPLEMENTAL_CATEGORY
20
Supplemental category
FIXTURE_IDENTIFIER
22
Fixture identifier
KEYWORDS
25
Keywords
CONTENT_LOCATION_CODE
26
Content location code
CONTENT_LOCATION_NAME
27
Content location name
RELEASE_DATE
30
Release date
RELEASE_TIME
35
Release time
EXPIRATION_DATE
37
Expiration date
EXPIRATION_TIME
38
Expiration time
SPECIAL_INSTRUCTIONS
40
Special instructions
ACTION_ADVISED
42
Action advised
REFERENCE_SERVICE
45
Reference service
REFERENCE_DATE
47
Reference date
REFERENCE_NUMBER
50
Reference number
DATE_CREATED
55
Date created
TIME_CREATED
60
Time created
DIGITAL_CREATION_DATE
62
Digital creation date
DIGITAL_CREATION_TIME
63
Digital creation time
ORIGINATING_PROGRAM
65
Originating program
PROGRAM_VERSION
70
Program version
OBJECT_CYCLE
75
Object cycle
BY_LINE
80
By-line
BY_LINE_TITLE
85
By-line title
CITY
90
City
SUBLOCATION
92
Sublocation
PROVINCE_STATE
95
Province/State
COUNTRY_PRIMARY_LOC_CODE
100
Country/Primary location code
COUNTRY_PRIMARY_LOC_NAME
101
Country/Primary location name
ORIGINAL_TRANSM_REF
103
Original transmission reference
HEADLINE
105
Headline
CREDIT
110
Credit
SOURCE
115
Source
COPYRIGHT_NOTICE
116
Copyright notice
CONTACT
118
Contact
CAPTION_ABSTRACT
120
Caption/Abstract
WRITER_EDITOR
122
Writer/Editor
RASTERIZED_CAPTION
125
Rasterized caption
IMAGE_TYPE
130
Image type
IMAGE_ORIENTATION
131
Image orientation
LANGUAGE_IDENTIFIER
135
Language identifier
AUDIO_TYPE
150
Audio type
AUDIO_SAMPLING_RATE
151
Audio sampling rate
AUDIO_SAMPLING_RESOLUTION
152
Audio sampling resolution
AUDIO_DURATION
153
Audio duration
AUDIO_OUTCUE
154
Audio outcue
OBJ_DATA_PREV_FILE_FORMAT
200
Object data preview file format
OBJ_DATA_PREV_FILE_FORMAT_VER
201
Object data preview file format version
OBJ_DATA_PREV_DATA
202
Object data preview data


ImGearIPTCRecord3PhotoDatasetTags Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all IPTC Record 3 (Digital Newsphoto Parameter) DataSet tags.

Declaration:

public enum ImGearIPTCRecord3PhotoDatasetTags

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.IPTC_PhotoDataset
IPTC_PhotoDataset metadata format identifier
RECORD_VERSION
0
Record version
PICTURE_NUMBER
10
Picture number
PIXELS_PER_LINE
20
Pixels per line
NUMBER_OF_LINE
30
Number of line
PIXEL_SIZE_SCAN_DIR
40
Pixel size in scanning direction
PIXEL_SIZE_PERP_DIR
50
Pixel size perpendicular to scanning direction
SUPPLEMENT_TYPE
55
Supplement type
COLOUR_REPRESENTATION
60
Colour representation
INTERCHANGE_COLOUR_SPACE
64
Interchange colour space
COLOUR_SEQUENCE
65
Colour sequence
ICC_INPUT_COLOUR_PROFILE
66
ICC input colour profile
COLOUR_MATRIX_TABLE
70
Colour calibration matrix table
LOOKUP_TABLE
80
Lookup table
NUMBER_OF_INDEX_ENTRIES
84
Number of index entries
COLOUR_PALETTE
85
Colour palette
NUMBER_OF_BITS_PER_SAMPLE
86
Number of bits per sample
SAMPLING_STRUCTURE
90
Sampling structure
SCANNING_DIRECTION
100
Scanning direction
IMAGE_ROTATION
102
Image rotation
DATA_COMPRESSION_METHOD
110
Data compression method
QUANTISATION_METHOD
120
Quantisation method
END_POINTS
125
End points
EXCURSION_TOLERANCE
130
Excursion tolerance
BITS_PER_COMPONENT
135
Bits per component
MAXIMUM_DENSITY_RANGE
140
Maximum density range
GAMMA_COMPENSATED_VALUE
145
Gamma compensated value


ImGearIPTCRecord7PreObjDatasetTags Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all IPTC Record 7 (Pre-Object) DataSet tags.

Declaration:

public enum ImGearIPTCRecord7PreObjDatasetTags

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.IPTC_PreObjDataset
IPTC_PreObjDataset metadata format identifier
SIZE_MODE
10
Size mode
MAX_SUBFILE_SIZE
20
Max subfile size
OBJ_DATA_SIZE_ANN
90
Object data size announced
MAX_OBJ_DATA_SIZE
95
Maximum object data size


ImGearIPTCRecord8ObjDatasetTags Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all IPTC Record 8 (Object) DataSet tags.

Declaration:

public enum ImGearIPTCRecord8ObjDatasetTags

Values:

Name
Value
Description
FORMAT
ImGearMetadataFormats.IPTC_ObjDataset
IPTC_ObjDataset metadata format identifier
SUBFILE
10
Subfile


ImGearIPTCRecord9PostObjDatasetTags Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all IPTC Record 9 (Post-Object) DataSet tags.

Declaration:

public enum ImGearIPTCRecord9PostObjDatasetTags

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.IPTC_PostObjDataset
IPTC_PostObjDataset metadata format identifier
CONFIRMED_OBJ_DATA_SIZE
10
Confirmed object data size


ImGearIPTCRecordTags Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all IPTC Record tags.

Declaration:

public enum ImGearIPTCRecordTags

Values:

Name
Value
Description
FORMAT
ImGearMetadataFormats.IPTC_Record
IPTC_Record metadata format identifier
ENVELOPE_RECORD
1
Envelope record
APPLICATION_RECORD
2
Application record
DIG_NEWS_PHOTO_PAR_RECORD
3
Digital Newsphoto Pararameter record
PREOBJ_DESC_RECORD
7
Pre-object record
OBJECT_RECORD
8
Object record
POSTOBJ_DESC_RECORD
9
Post-object record
UNDEFINED
999
Undefined


ImGearIPTCTags Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all general IPTC tags.

Declaration:

public enum ImGearIPTCTags

Values:

Name
Value
Description
IPTC_FORMAT
7168
IPTC metadata format identifier


ImGearJP2TagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all JP2 tag identifiers.

Declaration:

public enum ImGearJP2TagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.JP2
JP2 metadata format identifier
ALPHA_CHANNELS
1001
Alpha channel
COMPRESSION
1002
Compression
IPR
1003
IPR
TYPE
1005
Type
XML
1006
XML
ALPHA_MAPPING
4
Alpha mapping
ALPHA_1
7
Alpha 1
ALPHA_2
8
Alpha 2
ALPHA_3
9
Alpha 3


ImGearJPEGTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all JPEG tag identifiers.

Declaration:

public enum ImGearJPEGTagIDs

Values:

Name
Value
Description
FORMAT
ImGearFormats.JPG
JPEG metadata format identifier
SOI
0xFFD8
Start of Image
EOI
0xFFD9
End of Image
SOF0
0xFFC0
Baseline DCT
SOF1
0xFFC1
Extended sequential DCT
SOF2
0xFFC2
Progressive DCT
SOF3
0xFFC3
Lossless (sequential)
SOF5
0xFFC5
Differential sequential DCT
SOF6
0xFFC6
Differential progressive DCT
SOF7
0xFFC7
Differential lossless
SOF9
0xFFC9
Extended sequential DCT - arithmetic encoding
SOF10
0xFFCA
Progressive DCT - arithmetic encoding
SOF11
0xFFCB
Lossless sequential - arithmetic encoding
SOF13
0xFFCD
Differential sequential DCT - arithmetic encoding
SOF14
0xFFCE
Differential progressive DCT - arithmetic encoding
SOF15
0xFFCF
Differential lossless - arithmetic encoding
DQT
0xFFDB
Quantization tables
DHT
0xFFC4
Huffman tables
SOS
0xFFDA
Start of Segment
DRI
0xFFDD
Restart Interval
JFIF
0xFFE0
Application marker - JFIF header (APP0)
APP1
0xFFE1
Application marker - first
APP2
0xFFE2
Application marker - 2
APP3
0xFFE3
Application marker - 3
APP4
0xFFE4
Application marker - 4
APP5
0xFFE5
Application marker - 5
APP6
0xFFE6
Application marker - 6
APP7
0xFFE7
Application marker - 7
APP8
0xFFE8
Application marker - 8
APP9
0xFFE9
Application marker - 9
APP10
0xFFEA
Application marker - 10
APP11
0xFFEB
Application marker - 11
APP12
0xFFEC
Application marker - 12
APP13
0xFFED
Application marker - 13
APP14
0xFFEE
Application marker - 14
APP15
0xFFEF
Application marker - last
COM
0xFFFE
Comment
DAC
0xFFCC
DAC - Define Arithmetic coding Conditioning
DHP
0xFFDE
Define hierarchical progression
DNL
0xFFDC
Define number of lines
EXP
0xFFDF
Expand reference image
JPG
0xFFC8
Reserved for JPEG extensions
RST0
0xFFD0
Restart marker
RST1
0xFFD1
Restart marker
RST2
0xFFD2
Restart marker
RST3
0xFFD3
Restart marker
RST4
0xFFD4
Restart marker
RST5
0xFFD5
Restart marker
RST6
0xFFD6
Restart marker
RST7
0xFFD7
Restart marker
TEM
0xFF01
TEM marker
FRAME_PRECISION
300
SOF Precision
FRAME_LINES
301
SOF Lines
FRAME_SAMPLES_PER_LINE
302
SOF Samples Per Line
FRAME_NUMBER_OF_COMPONENTS
303
SOF Number of components
FRAME_COMPONENT_SPEC
304
SOF Component specification
FRAME_COMPONENT_ID
305
SOF Component ID
FRAME_COMPONENT_HV_SAMPLING
306
SOF Component HV Sampling
FRAME_COMPONENT_QUANT_SELECTOR
307
SOF Component quantization table selector
QUANT_TABLE
310
Quantization table
QUANT_TABLE_DESCRIPTOR
311
Quantization table descriptor
QUANT_TABLE_ELEMENTS
312
Quantization table elements
HUFFMAN_TABLE
320
Huffman table
HUFFMAN_TABLE_DESCRIPTOR
321
Huffman table descriptor
HUFFMAN_TABLE_LENGTHS
322
Huffman table lengths
HUFFMAN_TABLE_VALUES
323
Huffman table values
SCAN_COMPONENT_NUMBER
330
Scan component number
SCAN_COMPONENT
331
Scan component
SCAN_SELECTOR
332
Scan selector
SCAN_DC_AC
333
Scan AC, DC
SCAN_SP_START
334
Scan spectral start
SCAN_SP_END
335
Scan spectral end
SCAN_AH_AL
336
Scan AH, AL
RESTART_INTERVAL
340
Restart interval
COMMENT
350
Comment
JFIF_ID
360
JFIF ID
JFIF_VERSION
361
JFIF version
JFIF_UNITS
362
JFIF resolution unit
JFIF_X_RES
363
JFIF X resolution
JFIF_Y_RES
364
JFIF Y resolution
JFIF_THUMB_WIDTH
365
JFIF thumbnail width
JFIF_THUMB_HEIGHT
366
JFIF thumbnail height
BINARY_DATA
370
Segment binary data
EXIF_ID
380
EXIF ID
PHOTOSHOP_ID
390
Photoshop ID
PHOTOSHOP_RESOURCES
391
Photoshop Resources
IDENTIFIER
392
Segment identifier
ICCPROFILEDATA
393
ICC Profile data
CHUNKNUMBER
394
Chunk number


ImGearJPXTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all JPX tag identifiers.

Declaration:

public enum ImGearJPXTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.JPX
JPX metadata format identifier
COMPRESSION
1002
Compression
IPR
1003
IPR
TYPE
1005
Type
XML
1006
XML
CHROMA
1007
Chroma
ALPHA_MAPPING
4
Alpha mapping
ALPHA_1
7
Alpha 1
ALPHA_2
8
Alpha 2
ALPHA_3
9
Alpha 3
ALPHA_4
10
Alpha 4


ImGearKFXTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all KFX tag identifiers.

Declaration:

public enum ImGearKFXTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.KFX
KFX metadata format identifier
ID
1901
Id
HDR_SIZE
1902
Hdr size
HDR_VER
1903
Hdr version
IMAGE_ID
1904
Image ID
WIDTH
1905
Width
LENGTH
1906
Length
KFX_FORMAT
1907
Format
BIT_SEX
1908
Bit sex
COLOR
1909
Color
XRES
1910
X_Res
YRES
1911
Y_Res
PLANES
1912
Planes
BITS_PER_PIX
1913
Bits per pixel
PAPER_SIZE
1914
Paper size
DATE_CRT
1915
Date crt
DATE_MOD
1916
Date mod
DATE_ACC
1917
Date acc
IDX_OFFSET
1918
IDX_Offset
IDX_LEN
1919
IDX_Len
COM_OFFSET
1920
Com_Offset
COM_LEN
1921
Com_Len
USER_OFFSET
1922
User_Offset
USER_LEN
1923
User_Len
DATA_OFFSET
1924
Data_Offset
DATA_LEN
1925
Data_Len


ImGearLVTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all LV tag identifiers.

Declaration:

public enum ImGearLVTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.LV
LV metadata format identifier
YORIGIN
1100
Y origin
XORIGIN
1101
X origin
LINES
1102
Lines
PIXELS
1103
Pixels
BITSPIX
1104
Bits pix
COMPRESSION
1105
Compression
BYTEFORMAT
1106
Byte format
COMPVERSION
1107
Comp version
YAXIS
1108
Y_Axis
XAXIS
1109
X_Axis
NBLOCKTYPE
1110
N_Block type
DISPLAYMETHOD
1111
Display method
XSEPERATION
1112
X_Separation
YSEPERATION
1113
Y_Separation
BLOCKLENGTH
1114
Block length
TEXT
1115
Text


ImGearMetadataFormats Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all formats that are used for storing file format metadata. Most of the members of this enum correspond to members of ImGearFormats. However, some file formats allow storing complex metadata, or metadata structures of various types. ImGearMetadataFormats enum has special members for such metadata structures.

For example, a TIFF image can have metadata of ImGearMetadataFormats.TIF, which in turn can have a subtree with metadata of type ImGearMetadataFormats.EXIF

Declaration:

public enum ImGearMetadataFormats

Values:

Name
Value
Description
BMP
BMP metadata
BTR
BTR metadata
CAL
CALS metadata
CIFF
CIFF metadata
CIFFCanonCameraSettings
CIFFCanonCameraSettings metadata
CIFFFocalLength
CIFFFocalLength metadata
CIFFImageInfo
CIFFImageInfo metadata
CIFFPictureInfo
CIFFPictureInfo metadata
CIFFShotInfo
CIFFShotInfo metadata
CLP
CLP metadata
Common
Used internally
CUT
CUT metadata
DCRAW
Digital Camera RAW metadata
DCX
DCX metadata
DICOM
DICOM metadata
DisplayInfo
Photoshop Display info metadata
EXIF
EXIF metadata. Can only exist as a subtree within EXIF or JPEG metadata
EXIF_FPXR
EXIF FPX Ready metadata. Can only exist as a subtree within EXIF metadata
EXIF_GPS
EXIF GPS metadata. Can only exist as a subtree within EXIF metadata
EXIF_InterOp
EXIF Interoperability metadata. Can only exist as a subtree within EXIF metadata
EXIF_MakerNote
EXIF Makernote metadata. Can only exist as a subtree within EXIF metadata
EXIF_MakerNote_Fuji
Fujifilm EXIF MakerNote metadata
EXIF_MakerNote_NikonType1
Nikon EXIF MakerNote Type 1 metadata
EXIF_MakerNote_NikonType2
Nikon EXIF MakerNote Type 2 metadata
EXIF_MakerNote_Olympus
Olympus EXIF MakerNote metadata
EXIF_MakerNote_Pentax
Pentax EXIF MakerNote metadata
GEM
GEM metadata
GIF
GIF
HDPHOTO
HDPhoto metadata
ICA
ICA metadata
ICO
ICO metadata
IFF
IFF metadata
IMG
IMG metadata
IMR
IMR metadata
IMT
IMT metadata
IPTC
general IPTC metadata
IPTC_AppDataset
IPTC Record 2 (Application) metadata
IPTC_EnvDataset
IPTC Record 1 (Envelope) metadata.
IPTC_ObjDataset
IPTC Record 8 (Object) metadata
IPTC_PhotoDataset
IPTC Record 3 (Digital Newsphoto Parameter) metadata
IPTC_PostObjDataset
IPTC Record 9 (Post-Object) metadata
IPTC_PreObjDataset
IPTC Record 7 (Pre-Object) metadata
IPTC_Record
IPTC Record tags.
JP2
JPEG 2000 metadata
JPG
JPEG metadata
JPX
JPX metadata
KFX
KFX metadata
LV
LV metadata
MJ2
MJ2 metadata
MODCA
MODCA metadata
MSP
MSP metadata
NCR
NCR metadata
PBM
PBM metadata
PCD
PhotoCD metadata
PCX
PCX metadata
PDF
PDF metadata
PhotoshopAdditionalLayerInfo
Photoshop Additional LayerInfo metadata
PhotoshopLayerInfo
Photoshop Layer Info metadata
PhotoshopLayerMaskInfo
Photoshop Layer MaskI nfo metadata
PhotoshopResourceGeneric
Photoshop Resource Generic metadata
PhotoshopResources
Photoshop Resources metadata
PhotoshopVersionInfo
Photoshop Version Info metadata
PNG
PNG metadata
PS
PostScript metadata
PSD
PSD metadata
PTOCA
PTOCA metadata
RAS
RAS metadata
Rectangle
Photoshop Rectangle Info metadata
ResolutionInfo
Photoshop Resolution Info metadata
SCI
Scitex CT metadata
SGI
SGI metadata
TGA
TGA metadata
ThumbnailInfo
Photoshop Thumbnail Info metadata
TIF
TIFF metadata
UNKNOWN
Unknown metadata
WBMP
Wireless Bitmap Metadata
WPG
WPG metadata
XBM
XBM metadata
XPM
XPM metadata
XWD
XWD metadata


ImGearMJ2TagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all MJ2 tag identifiers.

Declaration:

public enum ImGearMJ2TagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.MJ2
MJ2 metadata format identifier
ALPHA_CHANNELS
1001
Alpha channels
COMPRESSION
1002
Compression
IPR
1003
IPR
TYPE
1005
Type
XML
1006
XML
ALPHA_MAPPING
4
Alpha mapping
ALPHA_1
7
Alpha 1
ALPHA_2
8
Alpha 2
ALPHA_3
9
Alpha 3


ImGearMSPTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all MSP tag identifiers.

Declaration:

public enum ImGearMSPTagIDs

Values:

Name
Value
Description
FORMAT
ImGearMetadataFormats.MSP
MSP metadata format identifier
KEY1
1800
Magic number
KEY2
1801
Magic number
WIDTH
1802
Width of the bitmap in pixels
HEIGHT
1803
Height of the bitmap in pixels
XARBITMAP
1804
X Aspect ratio of the bitmap
YARBITMAP
1805
Y Aspect ratio of the bitmap
XARPRINTER
1806
X Aspect ratio of the printer
YARPRINTER
1807
Y Aspect ratio of the printer
PRINTERWIDTH
1808
Width of the printer in pixels
PRINTERHEIGHT
1809
Height of the printer in pixels
XASPECTCORR
1810
X aspect correction (unused)
YASPECTCORR
1811
Y aspect correction (unused)
CHECKSUM
1812
Checksum of previous 24 bytes
PADDING
1813
Unused padding


ImGearNativeDataTypes Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies the data types that file formats use to store metadata values.

Declaration:

public enum ImGearNativeDataTypes

Values:

Name
Value
Description
BOOL
Boolean
DOUBLE
64-bit IEEE floating point number
FLOAT
32-bit IEEE floating point number
INT16
16-bit signed integer
INT32
32-bit signed integer
INT64
64-bit signed integer
INT8
8-bit signed integer
RATIONAL_INT32
A pair of 32-bit signed integers: Numerator and Denominator of a rational number
RATIONAL_UINT32
A pair of 32-bit unsigned integers: Numerator and Denominator of a rational number
RAW_DATA
Byte array
STRING
ASCII string
UINT16
16-bit unsigned integer
UINT32
32-bit unsigned integer
UINT64
64-bit unsigned integer
UINT8
8-bit unsigned integer
UNKNOWN
Native data type is unknown


ImGearNCRTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all NCR tag identifiers.

Declaration:

public enum ImGearNCRTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.NCR
NCR metadata format identifier
DATA_FORMAT
2001
Data format
OPTIONS
2002
Options
ENCRYPTION
2003
Encryption
AUTHENTICATION
2004
Authentication
AUTH_MAC
2005
Auth mac
DATA_SIZE
2006
Data size
REAL_BPP
2007
Real bpp
STORE_BPP
2008
Store bpp
REAL_WIDTH
2009
Real width
STORE_WIDTH
2010
Store width
REAL_HEIGHT
2011
Real height
STORE_HEIGHT
2012
Store height
ORIENT
2013
Orient
PMI
2014
PMI
DATA_ENDIAN
2015
Data endian
FILL_ORDER
2016
Fill order
GRANULARITY
2017
Granularity
MIN_PIX_VALUE
2018
Min pix value
MAX_PIX_VALUE
2019
Max pix value
X_RES
2020
X_Res
Y_RES
2021
Y_Res
RES_UNIT
2022
Res unit
ERROR
2023
Error


ImGearPBMTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all PBM tag identifiers.

Declaration:

public enum ImGearPBMTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.PBM
PBM metadata format identifier
TYPE
0
Type
WIDTH
1
Width
HEIGHT
2
Height
MAXCOLOR
3
Max color value
BITCOUNT
4
Bit count
COMMENTS
5
Comments


ImGearPCDTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all PCD tag identifiers.

Declaration:

public enum ImGearPCDTagIDs

Values:

Name
Value
Description
FORMAT
ImGearMetadataFormats.PCD
PCD metadata format identifier
IPICA_RESERVED
4000
IPICA reserved
IPICA_IMAGE_PACK_PARAMS
4001
IPICA image pack params
IPICA_BASE4_STOP_OFFSET
4002
IPICA base4 stop offset
IPICA_BASE16_STOP_OFFSET
4003
IPICA base16 stop offset
IPICA_IPE_STOP_OFFSET
4004
IPICA IPE stop offset
IPICA_IP_INTERLEAVE_RATIO
4005
IPICA IP interleave ratio
IPI_SIGNATURE
4006
IPI signature
IPI_VERSION_NUMBER
4007
IPI version number
IPI_SOFTWARE_RELEASE
4008
IPI software release
IPI_IMAGE_MAG_DESCRIPTION
4009
IPI image mag description
IPI_IMAGE_SCAN_TIME
4010
IPI image scan time
IPI_LAST_MODIFICATION_DATE
4011
IPI last modification date
IPI_MED_ORIGINAL_RECORDING
4012
IPI med original recording
IPI_TYPE_ORIGINAL_RECORDING
4013
IPI type original recording
IPI_SCANNER_VENDOR
4014
IPI scanner vendor
IPI_SCANNER_PRODUCT
4015
IPI scanner product
IPI_SCANNER_FIRMWARE_LEVEL
4016
IPI scanner firmware level
IPI_SCANNER_FIRMWARE_DATE
4017
IPI scanner firmware date
IPI_SCANNER_SERIAL_NUMBER
4018
IPI scanner serial number
IPI_SCANNER_PIXEL_SIZE
4019
IPI scanner pixel size
IPI_EQUIPMENT_MANUFACTURER
4020
IPI equipment manufacturer
IPI_PHOTONAME_CHAR_SET
4021
IPI photoname char set
IPI_PHOTONAME_ESC_SEQ
4022
IPI photoname esc seq
IPI_PHOTONAME
4023
IPI photoname
IPI_SBA_DATA
4024
IPI SBA data
IPI_COPYRIGHT_STATUS
4025
IPI copyright status
IPI_COPYRIGHT_FILENAME
4026
IPI copyright filename

,


ImGearPCXTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all PCX tag identifiers.

Declaration:

public enum ImGearPCXTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.PCX
PCX metadata format identifier
MANUFACTURER
400
Manufacturer
VERSION_INFO
401
Version info
ENCODE
402
Encode
BIT_PER_PLANE
403
Bit per plane
X1
404
X1
Y1
405
Y1
X2
406
X2
Y2
407
Y2
H_RES
408
H_Res
V_RES
409
V_Res
PALETTE_TABLE
410
Palette table
VIDEO_MODE
411
Video mode
NUM_OF_PLANES
412
Num of planes
BYTES_PER_LINE
413
Bytes per line
PALETTE_INFO
414
Palette info
SCANNER_H_RES
415
Scanner H_Res
SCANNER_V_RES
416
Scanner V_Res
EXTRA
417
Extra


ImGearPhotoshopAdditionalLayerInfoTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all Photoshop Additional Layer Info tag identifiers.

Declaration:

public enum ImGearPhotoshopAdditionalLayerInfoTagIDs

Values:

Name
Value
Description
FORMAT
ImGearMetadataFormats.PhotoshopAdditionalLayerInfo
Photoshop additional layer info metadata format identifier
Key
0
Key
Data
1
Data


ImGearPhotoshopLayerInfoTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all Photoshop Layer Info tag identifiers.

Declaration:

public enum ImGearPhotoshopLayerInfoTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.PhotoshopLayerInfo
Photoshop layer info metadata format identifier
Rectangle
0
Rectangle
ChannelCount
1
Channel count
ChannelID
2
Channel ID
BlendModeSignature
3
Blend mode signature
BlendModeKey
4
Blend mode key
Opacity
5
Opacity
Clipping
6
Clipping
Flags
7
Flags
MaskData
8
Mask data
BlendingRanges
9
Blending ranges
Name
10
Name
ExtraData
11
Extra data


ImGearPhotoshopLayerMaskInfoTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all Photoshop Layer Mask Info tag identifiers.

Declaration:

public enum ImGearPhotoshopLayerMaskInfoTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.PhotoshopLayerMaskInfo
Photoshop layer mask info metadata format identifier
Rectangle
0
Rectangle
DefaultColor
1
Default color
Flags
2
Flags
RealFlags
3
Real flags
RealUserMaskBg
4
Real user mask bg


ImGearPhotoshopResourceGenericTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all Photoshop Resource Generic tag identifiers.

Declaration:

public enum ImGearPhotoshopResourceGenericTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.PhotoshopResourceGeneric
Photoshop resource generic metadata format identifier
SIGNATURE
0
SIGNATURE
ID
1
ID
NAME
2
Name
DATA
3
Data


ImGearPHOTOSHOPTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all general Photoshop tag identifiers.

Declaration:

public enum ImGearPHOTOSHOPTagIDs

Values:

Name
Value
Description
FORMAT
ImGearMetadataFormats.PhotoshopResources
PhotoshopResource metadata format identifier
HEADER
0
Header
RESOURCE
1
Resource
RESOURCE_SIZE
2
Resource size
COMMENT
3
Comment
SEGMENTDATA
4
Segment data
IPTC
0x0404
IPTC


ImGearPhotoshopVersionInfoTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all Photoshop Version Info tag identifiers.

Declaration:

public enum ImGearPhotoshopVersionInfoTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.PhotoshopVersionInfo
Photoshop version info metadata format identifier
Version
0
Version
hasRealMergedData
1
Has real merged data
WriteName
2
Write name
ReaderName
3
Reader name
FileVersion
4
File version


ImGearPNGCompLevel Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all PNG compression levels.

Declaration:

public enum ImGearPNGCompLevel

Values:

Name
Value
Description
DEFAULT_COMPRESSION
Default compression
MAX_COMPRESSION
Maximum compression
MIN_COMPRESSION
Minimum compression


ImGearPNGStrip Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all PNG strip modes.

Declaration:

public enum ImGearPNGStrip

Values:

Name
Value
Description
STRIP_FIXED_BUFFER
Fixed buffer
STRIP_FIXED_COUNT
Fixed strip count


ImGearPNGTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all PNG tag identifiers.

Declaration:

public enum ImGearPNGTagIDs

Values:

Name
Value
Description
FORMAT
ImGearMetadataFormats.PNG
PNG metadata format identifier
HEADER
0x49484452
Header
TRANSPARENCY
0x74524e53
Transparency
GAMMA
0x67414d41
Gamma
CHROMATICITIES
0x6348524d
Chromaticities
SRGB
0x73524742
sRGB
ICC_PROFILE
0x69434350
ICC profile
BACKGROUND
0x624b4744
Background
SIGNIFICANT_BITS
0x73424954
Significant bits
SUGGESTED_PALETTE
0x73504c54
Suggested palette
HISTOGRAM
0x68495354
Histogram
TIME
0x74494d45
Time
TEXT
0x74455874
Text
COMPRESSED_TEXT
0x7a545874
Compressed text
INTERNATIONAL_TEXT
0x69545874
International text
CALIBRATION
0x7043414c
Calibration
PHYSICAL_SCALE
0x7343414c
Physical scale
GIF_APP_EXT
0x67494678
GIF application extension
GIF_CONTROL
0x67494667
GIF control
IMAGE_OFFSET
0x6f464673
Image offset
FRACTAL_PARAMETERS
0x66524163
Fractal parameters
GIF_TEXT_EXT
0x67494674
Gif text extension
RESOLUTION
0x70485973
Resolution
IHDR_WIDTH
Width
IHDR_HEIGHT
Height
IHDR_BIT_DEPTH
BitDepth
IHDR_COLOR_TYPE
ColorType
IHDR_COMPRESSION
CompressionType
IHDR_FILTER_TYPE
FilterType
IHDR_INTERLACE_TYPE
InterlaceType
PHYS_X_AXIS
"XAxis
PHYS_Y_AXIS
YAxis
PHYS_UNIT
UnitSpecifier
ICCP_NAME
ProfileName
ICCP_DATA
ProfileData
CHRM_WHITE
WhitePoint
CHRM_RED
Red
CHRM_GREEN
Green
CHRM_BLUE
Blue
CHRM_X
x
CHRM_Y
y
TEXT_KEYWORD
Keyword
TEXT_TEXT
Text
CTXT_KEYWORD
Keyword
CTXT_COMPR_METHOD
CompressionMethod
CTXT_TEXT
Text
ITXT_KEYWORD
Keyword
ITXT_COMPR_FLAG
CompressionFlag
ITXT_COMPR_METHOD
CompressionMethod
ITXT_LANGUAGE
LanguageTag
ITXT_TRANSL_KEYWORD
"TranslatedKeyword
ITXT_TEXT
Text
SPLT_NAME
PaletteName
SPLT_DEPTH
SampleDepth
SPLT_ENTRY_COUNT
PaletteEntryCount
SPLT_ENTRY
PaletteEntry
SPLT_RED
Red
SPLT_GREEN
Green
SPLT_BLUE
Blue
SPLT_ALPHA
Alpha
SPLT_FREQUENCY
Frequency
TIME_YEAR
Year
TIME_MONTH
Month
TIME_DAY
Day
TIME_HOUR
Hour
TIME_MINUTE
Minute
TIME_SECOND
Second
OFFS_X_POSITION
XPosition
OFFS_Y_POSITION
YPosition
OFFS_UNIT
UnitSpecifier
PCAL_NAME
CalibrationName
PCAL_X0
OriginalZero(x0)
PCAL_X1
OriginalMax(x1)
PCAL_EQUATION
EquationType
PCAL_PAR_COUNT
NumberOfParameters
PCAL_UNIT
UnitName
PCAL_PARAMETER
CalibrationParameter
SCAL_UNIT
UnitSpecifier
SCAL_WIDTH
PixelWidth
SCAL_HEIGHT
PixelHeigt
GIFG_DISPOSAL_METHOD
DisposalMethod
GIFG_USER_INPUT_FLAG
UserInputFlag
GIFG_DELAY_TIME
DelayTime
GIFX_APP_ID
ApplicationIdentifier
GIFX_AUTHENTICATION
AuthenticationCode
GIFX_APP_DATA
ApplicationData


ImGearPSDTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all PSD tag identifiers.

Declaration:

public enum ImGearPSDTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.PSD
PSD metadata format identifier
SIGNATURE
2100
Signature
VERSION
2101
Version
ROWS
2102
Rows
COLS
2103
Cols
DEPTH
2104
Depth
MODE
2105
Color mode
MODE_LEN
2106
Color mode data length
COMPRESSION
2107
Compression
FILE_HDR
2108
File header
COLOR_DATA
2109
Color data
RESOURCE
2110
Photoshop resources
LAYER
2111
Layers


ImGearPTOCATagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all PTOCA tag identifiers.

Declaration:

public enum ImGearPTOCATagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.PTOCA
PTOCA metadata format identifier
WIDTH
1001
Width
HEIGHT
1002
Height


ImGearRASTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all RAS tag identifiers.

Declaration:

public enum ImGearRASTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.RAS
RAS metadata format identifier
MAGIC
0
Magic
WIDTH
1
Width
HEIGHT
2
Height
DEPTH
3
Depth
LENGTH
4
Length
TYPE
5
Type
COLOR_MAP_TYPE
6
Color map type
COLOR_MAP_LENGTH
7
Color map length


ImGearRasterConversionModes Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all raster conversion modes for image saving.

Declaration:

public enum ImGearRasterConversionModes

Values:

Name
Value
Description
ANY
Allow any conversion supported by ImageGear
DIRECT_MATCH
Allow saving only unchanged pixel data
NO_QUALITY_LOSS
Only allow pixel data conversion that does not degrade image quality


ImGearRectangleInfoTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all Photoshop Rectangle Info tag ids.

Declaration:

public enum ImGearRectangleInfoTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.Rectangle
Rectangle metadata format identifier
Left
0
Left
Top
1
Top
Right
2
Right
Bottom
3
Bottom


ImGearResolutionInfoTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all Photoshop Resolution Info tag ids.

Declaration:

public enum ImGearResolutionInfoTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.ResolutionInfo
Resolution info metadata format identifier
H_RESOLUTION
0
Horizontal
H_RESOLUTION_UNIT
1
Horizontal unit
WIDTH_UNIT
2
Width unit
V_RESOLUTION
3
Vertical
V_RESOLUTION_UNIT
4
Vertical unit
HEIGHT_UNIT
5
Height unit


ImGearSavingFormats Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration contains IDs of saving formats. Saving format is a combination of a file format and a compression (e.g., TIF_G4 specifies TIF file format and CCITT Group4 compression). ImGearCompressions.AUTO specifies default compression for the format.

Declaration:

public enum ImGearSavingFormats

Values:

Name
Value
File Format
Compression
Description
UNKNOWN
0x00000000
UNKNOWN
AUTO
Unknown format.
BMP_RLE
0x00080001
BMP
RLE
BMP RLE
BMP_UNCOMP
0x00010001
BMP
NONE
BMP Uncompressed
BTR
0x0000001D
BTR
AUTO
BTR CCITT Group 3
BTR_G3_2D
0x0005001D
BTR
CCITT_G32D
BTR CCITT Group 3 2D
CAL
0x00000002
CAL
AUTO
CAL CCITT Group 4
CGM
0x00000017
CGM
AUTO
CGM (vector)
CLP
0x00000003
CLP
AUTO
CLP Uncompressed
CLP_RLE
0x00080003
CLP
RLE
CLP RLE
CUR
0x0000001B
CUR
AUTO
CUR Uncompressed
CUT_RLE
0x00000023
CUT
AUTO
CUT RLE
DCX
0x00000004
DCX
AUTO
DCX RLE
DICOM
0x00000030
DICOM
AUTO
DICOM (Control parameters define compression)
DICOM_JPEG
0x00070030
DICOM
JPEG
DICOM JPEG
DICOM_JPEG2K
0x000B0030
DICOM
JPEG2K
DICOM JPEG2K
DICOM_RLE
0x00080030
DICOM
RLE
DICOM RLE
DICOM_UNCOMP
0x00010030
DICOM
NONE
DICOM Uncompressed
DWF
0x00000040
DWF
AUTO
DWF (vector)
DWG
0x00000015
DWG
AUTO
DWG (vector)
DXF
0x00000016
DXF
AUTO
DXF (vector)
GIF
0x00000005
GIF
AUTO
GIF LZW
HDPHOTO
0x00000032
HDPHOTO
AUTO
HD PHOTO
ICA_G3
0x00030006
ICA
CCITT_G3
ICA CCITT Group 3
ICA_G4
0x00040006
ICA
CCITT_G4
ICA CCITT Group 4
ICA_MMR
0x000E0006
ICA
IBM_MMR
ICA IBM MMR
ICO
0x0000001A
ICO
AUTO
ICO Uncompressed
IFF
0x00000025
IFF
AUTO
IFF Uncompressed
IFF_RLE
0x00080025
IFF
RLE
IFF RLE
JP2
0x0000002D
JP2
AUTO
JP2 JPEG2K
JPG
0x0000002E
JPG
AUTO
JPG JPEG
JPX
0x0000002F
JPX
AUTO
JPX JPEG2K
MJ2
0x0000001C
MJ2
AUTO
MJ2 JPEG2K
MODCA_G3
0x00030007
MODCA
CCITT_G3
MODCA CCITT Group 3
MODCA_G4
0x00040007
MODCA
CCITT_G4
MODCA CCITT Group 4
MODCA_MMR
0x000E0007
MODCA
IBM_MMR
MODCA IBM MMR
NCR
0x00000022
NCR
AUTO
NCR CCITT Group 4
PBM_ASCII
0x000C000A
PBM
ASCII
PBM ASCII
PBM_RAW
0x000D000A
PBM
RAW
PBM RAW
PCX
0x0000000C
PCX
AUTO
PCX RLE
PDF
0x0000000D
PDF
AUTO
PDF Uncompressed
PDF_DEFLATE
0x000A000D
PDF
DEFLATE
PDF Deflate
PDF_G3
0x0003000D
PDF
CCITT_G3
PDF CCITT Group 3
PDF_G3_2D
0x0005000D
PDF
CCITT_G32D
PDF CCITT Group 3 2D
PDF_G4
0x0004000D
PDF
CCITT_G4
PDF CCITT Group 4
PDF_JPEG2K
0x000B000D
PDF
JPEG2K
PDF JPEG2K
PDF_JPG
0x0007000D
PDF
JPEG
PDF JPEG
PDF_LZW
0x0009000D
PDF
LZW
PDF LZW
PDF_RLE
0x0008000D
PDF
RLE
PDF RLE
PDF_UNCOMP
0x0001000D
PDF
NONE
PDF Uncompressed
PNG
0x0000000E
PNG
AUTO
PNG Deflate
PS
0x0000000F
PS
AUTO
PS Uncompressed
PS_DEFLATE
0x000A000F
PS
DEFLATE
PS Deflate
PS_G3
0x0003000F
PS
CCITT_G3
PS CCITT Group 3
PS_G3_2D
0x0005000F
PS
CCITT_G32D
PS CCITT Group 3 2D
PS_G4
0x0004000F
PS
CCITT_G4
PS CCITT Group 4
PS_JPEG2K
0x000B000F
PS
JPEG2K
PS JPEG2K
PS_JPG
0x0007000F
PS
JPEG
PS JPEG
PS_LZW
0x0009000F
PS
LZW
PS LZW
PS_RLE
0x0008000F
PS
RLE
PS RLE
PS_UNCOMP
0x0001000F
PS
NONE
PS Uncompressed
PSB_PACKED
0x00060041
PSB
PACKED_BITS
PSB RLE
PSB_UNCOMP
0x00010041
PSB
NONE
PSB Uncompressed
PSD_PACKED
0x00060010
PSD
PACKED_BITS
PSD RLE
PSD_UNCOMP
0x00010010
PSD
NONE
PSD Uncompressed
RAS
0x00000026
RAS
AUTO
RAS Uncompressed
RAS_RLE
0x00080026
RAS
RLE
RAS RLE
SCI
0x00000011
SCI
AUTO
SCI Uncompressed
SGI
0x00000012
SGI
AUTO
SGI Uncompressed
SGI_RLE
0x00080012
SGI
RLE
SGI RLE
SVG
0x00000031
SVG
AUTO
SVG (Vector)
TGA_RLE
0x00080013
TGA
RLE
TGA RLE
TGA_UNCOMP
0x00010013
TGA
NONE
TGA Uncompressed
TIF_DEFLATE
0x000A0014
TIF
DEFLATE
TIFF Deflate
TIF_G3
0x00030014
TIF
CCITT_G3
TIFF CCITT Group 3
TIF_G3_2D
0x00050014
TIF
CCITT_G32D
TIFF CCITT Group 3 2D
TIF_G4
0x00040014
TIF
CCITT_G4
TIFF CCITT Group 4
TIF_HUFFMAN
0x00020014
TIF
HUFFMAN
TIFF Huffman
TIF_JPG
0x00070014
TIF
JPEG
TIFF JPEG
TIF_LZW
0x00090014
TIF
LZW
TIFF LZW
TIF_PACKED
0x00060014
TIF
PACKED_BITS
TIFF PackBits
TIF_UNCOMP
0x00010014
TIF
NONE
TIFF Uncompressed
U3D
0x00010042
U3D
NONE
U3D (Vector)
WBMP
0x00000028
WBMP
AUTO
WBMP Uncompressed
XBM
0x0000002B
XBM
AUTO
XBM Uncompressed
XPM
0x0000002C
XPM
AUTO
XPM Uncompressed
XPS
0x0000003F
XPS
AUTO
XPS (Vector)
XWD
0x00000029
XWD
AUTO
XWD Uncompressed


ImGearSavingModes Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies available saving modes.

Declaration:

public enum ImGearSavingModes

Values:

Name
Value
Description
OVERWRITE
A new image is created during saving. If old image existed, it is overwritten.
APPEND
New pages are appended to existing image.
NOTE: Any time SavePage Method is used with ImGearSavingModes.APPEND, the stream must be at the beginning of the file to be appended to.
INSERT
New pages are inserted into existing image.
REPLACE
New pages replace existing pages in the image.


ImGearSCITagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all Scitex CT tag identifiers.

Declaration:

public enum ImGearSCITagIDs

Values:

Name
Value
Description
FORMAT
ImGearMetadataFormats.SCI
SCI metadata format identifier
TYPE
4100
Type
BLOCKSIZE
4101
Block size
PRM_UNITS_OF_MEASUREMENT
4102
PRM units of measurement
PRM_NUM_COLOR_SEPARATIONS
4103
PRM num color separations
PRM_SEPARATIONS_BIT_MASK
4104
PRM separations bit mask
PRM_HEIGHT_IN_UNITS
4105
PRM height in units
PRM_WIDTH_IN_UNITS
4106
PRM width in units
PRM_HEIGHT_IN_PIXELS
4107
PRM height in pixels
PRM_WIDTH_IN_PIXELS
4108
PRM width in pixels
PRM_SCAN_DIRECTION
4109
PRM scan direction


ImGearSGITagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all SGI tag identifiers.

Declaration:

public enum ImGearSGITagIDs

Values:

Name
Value
Description
FORMAT
ImGearMetadataFormats.SGI
SGI metadata format identifier
MAGIC
1400
Magic
STORAGE
1401
Storage
BPC
1402
BPC
DIMENSION
1403
Dimension
X_SIZE
1404
X size
Y_SIZE
1405
Y size
Z_SIZE
1406
Z size
PIX_MIN
1407
Pix min
PIX_MAX
1408
Pix max
DUMMY1
1409
Dummy 1
IMAGE_NAME
1410
Image name
COLOR_MAP
1411
Color map
DUMMY2
1412
Dummy 2


ImGearTGATagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all TGA tag identifiers.

Declaration:

public enum ImGearTGATagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.TGA
TGA metadata format identifier
HEAD
1
Header
HEAD_IDLENGTH
2
ID length
HEAD_COLORMAPTYPE
3
Color map type
HEAD_IMAGETYPE
4
Image type
HEAD_CMAPSTART
5
CMap start
HEAD_CMAPLENGTH
6
CMap length
HEAD_CMAPDEPTH
7
CMap depth
HEAD_XOFFSET
8
X offset
HEAD_YOFFSET
9
Y offset
HEAD_WIDTH
10
Width
HEAD_HEIGHT
11
Height
HEAD_PIXELDEPTH
12
Pixel depth
HEAD_IMAGEDESCRIPTOR
13
Image descriptor
FOOT
14
Footer
FOOT_EXTENSION_OFFSET
15
Extension offset
FOOT_DEVELOPER_OFFSET
16
Developer offset
FOOT_SIGNATURE
17
Signature
EXT
18
Extension
EXT_SIZE
19
Size
EXT_AUTHORNAME
20
Author name
EXT_AUTHORCOMMENT
21
Author comment
EXT_STAMPMONTH
22
Stamp month
EXT_STAMPDAY
23
Stamp day
EXT_STAMPYEAR
24
Stamp year
EXT_STAMPHOUR
25
Stamp hour
EXT_STAMPMINUTE
26
Stamp minute
EXT_STAMPSECOND
27
Stamp second
EXT_JOBNAME
28
Job name
EXT_JOBHOUR
29
Job hour
EXT_JOBMINUTE
30
Job minute
EXT_JOBSECOND
31
Job second
EXT_SOFTWAREID
32
Software ID
EXT_VERSIONNUMBER
33
Version number
EXT_VERSIONLETTER
34
Version letter
EXT_KEYCOLOR
35
Key color
EXT_PIXELNUMERATOR
36
Pixel numerator
EXT_PIXELDENOMINATOR
37
Pixel denominator
EXT_GAMMANUMERATOR
38
Gamma numerator
EXT_GAMMADENOMINATOR
39
Gamma denominator
EXT_COLOROFFSET
40
Color offset
EXT_STAMPOFFSET
41
Stamp offset
EXT_SCANOFFSET
42
Scan offset
EXT_ATTRIBUTESTYPE
43
Attributes type
IMAGE_ID
44
Image ID


ImGearThumbnailInfoTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all Photoshop Thumbnail Info tag identifiers.

Declaration:

public enum ImGearThumbnailInfoTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.ThumbnailInfo
Thumbnail info metadata format identifier
IMG_FORMAT
0
Image format
WIDTH
1
Width
HEIGHT
2
Height
WIDTHBYTES
3
Width bytes
SIZE_TOTAL
4
Size total
SIZE_COMPRESSED
5
Size compressed
BITS_PER_PIXEL
6
Bits per pixel
PLANES
7
Planes


ImGearTIFTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all TIF tag identifiers.

Declaration:

public enum ImGearTIFTagIDs

Value

Name
Value
Description
FORMAT
ImGearFormats.TIF
TIF metadata format identifier
NEW_SUBFILE_TYPE
254
New subfile type
SUBFILE_TYPE
255
Subfile type
IMAGE_WIDTH
256
Image width
IMAGE_HEIGHT
257
Image height
BITS_PER_SAMPLE
258
Bits per sample
COMPRESSION
259
Compression
PHOTO_INTERP
262
Photometric interpretation
THRESHOLDING
263
Threshholding
CELL_WIDTH
264
Cell width
CELL_HEIGHT
265
Cell height
FILL_ORDER
266
Fill order
DOC_NAME
269
Document name
DESCRIPTION
270
Image description
MAKE
271
Make
MODEL
272
Model
STRIP_OFFSETS
273
Strip offsets
ORIENTATION
274
Orientation
SAMPLES_PER_PIXEL
277
Samples per pixel
ROWS_PER_STRIP
278
Rows per strip
STRIP_BYTE_COUNT
279
Strip byte counts
MIN_SAMPLE_VAL
280
Min sample value
MAX_SAMPLE_VAL
281
Max sample value
X_RES
282
X resolution
Y_RES
283
Y resolution
PLANAR_CONFIG
284
Planar configuration
PAGE_NAME
285
Page name
X_POS
286
X position
Y_POS
287
Y position
FREE_OFFSETS
288
Free offsets
FREE_BYTE_COUNTS
289
Free byte counts
GRAY_RESPONSE_UNIT
290
Gray response unit
GRAY_RESPONSE_CURVE
291
Gray response curve
T4_OPTIONS
292
T4Options
T6_OPTIONS
293
T6Options
RES_UNIT
296
Resolution unit
PAGE_NUMBER
297
Page number
TRANSFER_FUNC
301
Transfer function
SOFTWARE
305
Software
DATE_TIME
306
Date time
ARTIST
315
Artist
HOST_COMPUTER
316
Host computer
PREDICTOR
317
Predictor
WHITE_POINT
318
White point
PRIMARY_CHROMA
319
Primary chromaticities
COLOR_MAP
320
Color map
HALFTONE_HINTS
321
Halftone hints
TILE_WIDTH
322
Tile width
TILE_HEIGHT
323
Tile height
TILE_OFFSETS
324
Tile offsets
TILE_BYTE_COUNT
325
Tile byte counts
SUB_IFDS
330
IFDs
INK_SET
332
Ink set
INK_NAMES
333
Ink names
NUMBER_OF_INKS
334
Number of inks
DOT_RANGE
336
Dot range
TARGET_PRINTER
337
Target printer
EXTRA_SAMPLES
338
Extra samples
SAMPLE_FORMAT
339
Sample format
SMIN_SAMPLE_VAL
340
S min sample value
SMAX_SAMPLE_VAL
341
S max sample value
TRANSFER_RANGE
342
Transfer range
JPEG_TABLES
347
JPEG tables
JPEG_PROC
512
JPEG proc
JPEG_INTERCHANGE
513
JPEG interchange format
JPEG_INTERCHANGE_LEN
514
JPEG interchange format lngth
JPEG_RESTART_INTERVAL
515
JPEG restart interval
JPEG_LOSSLESS_PREDICTOR
517
JPEG lossless predictors
JPEG_POINT_TRANSFORMS
518
JPEG point transforms
JPEG_Q_TABLES
519
JPEG Q tables
JPEG_DC_TABLES
520
JPEG DC tables
JPEG_AC_TABLES
521
JPEG AC tables
YCBCR_COEFFICIENTS
529
YCbCr coefficients
YCBCR_SUBSAMPLING
530
YCbCr sub sampling
YCBCR_POS
531
YCbCr positioning
REFERENCE_BLACK_WHITE
532
Reference black white
COPYRIGHT
33432
Copyright
IPTC_NAA
33723
IPTC/NAA
PHOTOSHOP_RESOURCES
34377
Photoshop resources
EXIF_IFDPOINTER
34665
Exif IFD pointer
ICC_PROFILE
34675
ICC color profile
DNG_PRIVATE_DATA
50740
DNG private data
BYTE_ORDER
59937
Byte order
IDENTIFIER
59938
Identifier
GPSINFOIFDPOINTER
34853
Exif IFD pointer
ART_DATA
32932
ART annotation data (ImageGear tag)
EXPOSURE_TIME
33434
Exposure time
FNUMBER
33437
F number
CFA_REPEAT_PATTERN_DIM
33421
CFA repeat pattern dim
CFA_PATTERN
33422
CFA pattern
BATTERY_LEVEL
33423
Battery level
EXPOSURE_PROGRAM
34850
Exposure program
SPECTRAL_SENSITIVITY
34852
Spectral sensitivity
ISOSPEEDRAITINGS
34855
ISO speed raitings
OECF
34856
OECF
INTERLACE
34857
Interlace
TIMEZONE_OFFSET
34858
Time zone offset
SELFTIMER_MODE
34859
Self timer mode
DATETIMEORIGINAL
36867
Date time original
COMPRESSEDBITSPERPIXEL
37122
Compressed bits per pixel
SHUTTERSPEED_VALUE
37377
Shutter speed value
APERTURE_VALUE
37378
Aperture value
BRIGHTNESS_VALUE
37379
Brightness value
EXPOSURE_BIAS_VALUE
37380
Exposure bias value
MAXAPERTURE_VALUE
37381
Max aperture value
SUBJECTDISTANCE
37382
Subject distance
METERING_MODE
37383
Metering mode
LIGHT_SOURCE
37384
Light source
FLASH
37385
Flash
FOCAL_LENGTH
37386
Focal length
FLASHENERGY
37387
Flash energy
SPATIAL_FREQUENCY_RESPONSE
37388
Spatial frequency response
NOISE
37389
Noise
FOCAL_PLANE_XRESOLUTION
37390
Focal plane xresolution
FOCAL_PLANE_YRESOLUTION
37391
Focal plane yresolution
FOCAL_PLANE_RESOLUTION_UNIT
37392
Focal plane resolution unit
IMAGE_NUMBER
37393
Image number
SECURITY_CLASSIFICATION
37394
Security classification
IMAGE_HISTORY
37395
Image history
SUBJECT_LOCATION
37396
Subject location
EXPOSURE_INDEX
37397
Exposure index
TIFFEP_STANDARDID
37398
TIFF/EP standard ID
SENSING_METHOD
37399
Sensing method
DNG_VERSION
50706
DNG version
DNG_BACKWARDVERSION
50707
DNG backward version
UNIQUE_CAMERAMODEL
50708
Unique camera model
LOCALIZED_CAMERAMODEL
50709
Localized camera model
CFA_PlANECOLOR
50710
CFA plane color
CFA_LAYOUT
50711
CFA layout
LINEARIZATION_TABLE
50712
Linearization table
BLACK_LEVELREPEAT_DIM
50713
Black level repeat dim
BLACK_LEVEL
50714
Black level
BLACK_LEVEL_DELTAH
50715
Black level delta H
BLACK_LEVEL_DELTAV
50716
Black level delta V
WHITE_LEVEL
50717
White level
DEFAULT_SCALE
50718
Default scale
BEST_QUALITY_SCALE
50780
Best quality scale
DEFAULT_CROP_ORIGIN
50719
Default crop origin
DEFAULT_CROP_SIZE
50720
Default crop size
CALIBRATION_ILLUMINANT1
50778
Calibration illuminant 1
CALIBRATION_ILLUMINANT2
50779
Calibration illuminant 2
COLOR_MATRIX1
50721
Color matrix 1
COLOR_MATRIX2
50722
Color matrix 2
CAMERA_CALIBRATION1
50723
Camera calibration 1
CAMERA_CALIBRATION2
50724
Camera calibration 2
REDUCTION_MATRIX1
50725
Reduction matrix 1
REDUCTION_MATRIX2
50726
Reduction matrix 2
ANALOG_BALANCE
50727
Analog balance
AS_SHOT_NEUTRAL
50728
As shot neutral
AS_SHOT_WHITEXY
50729
As shot white XY
BASELINE_EXPOSURE
50730
Baseline exposure
BASELINE_NOISE
50731
Baseline noise
BASELINE_SHARPNESS
50732
Baseline sharpness
BAYER_GREEN_SPLIT
50733
Bayer green split
LINEAR_RESPONSE_LIMIT
50734
Linear response limit
CAMERA_SERIAL_NUMBER
50735
Camera serial number
LENS_INFO
50736
Lens info
CHROMA_BLUR_RADIUS
50737
Chroma blur radius
ANTI_ALIAS_STRENGTH
50738
Anti alias strength
MAKER_NOTE_SAFETY
50741
Maker note safety
SHADOW_SCALE
50739
Shadow scale
RAW_DATA_UNIQUE_ID
50781
Raw data unique ID
ORIGINAL_RAW_FILE_NAME
50827
Original raw file name
ORIGINAL_RAW_FILE_DATA
50828
Original raw file data
ACTIVE_AREA
50829
Active area
MASKED_AREAS
50830
Masked areas
ASSHOT_ICC_PROFILE
50831
As shot ICC profile
ASSHOT_PRE_PROFILE_MATRIX
50832
As shot pre profile matrix
CURRENT_ICC_PROFILE
50833
Current ICC profile
CURRENT_PRE_PROFILE_MATRIX
50834
Current pre profile matrix


ImGearWBMPTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all WBMP tag identifiers.

Declaration:

public enum ImGearWBMPTagIDs

Values:

Name
Value
Description
FORMAT
ImGearMetadataFormats.WBMP
WBMP metadata format identifier


ImGearWPGTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all WPG tag identifiers.

Declaration:

public enum ImGearWPGTagIDs

Values:

Name
Value
Description
FORMAT
ImGearMetadataFormats.WPG
WPG metadata format identifier


ImGearXBMTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all XBM tag identifiers.

Declaration:

public enum ImGearXBMTagIDs

Values:

Name
Value
Description
FORMAT
ImGearMetadataFormats.XBM
XBM metadata format identifier


ImGearXPMTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all XPM tag identifiers.

Declaration:

public enum ImGearXPMTagIDs

Values:

Name
Value
Description
FORMAT
ImGearMetadataFormats.XPM
XPM metadata format identifier


ImGearXWDTagIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all XWD tag identifiers.

Declaration:

public enum ImGearXWDTagIDs

Values

Name
Value
Description
FORMAT
ImGearMetadataFormats.XWD
XWD metadata format identifier
HEADER_SIZE
1
Header size
FILE_VERSION
2
File version
X11_PIXMAP_FORMAT
3
Pixmap format
X11_PIXMAP_DEPTH
4
Pixmap depth
X11_PIXMAP_WIDTH
5
Pixmap width
X11_PIXMAP_HEIGHT
6
Pixmap height
X11_X_OFFSET
7
Xoffset
X11_BYTE_ORDER
8
Byte order
X11_BITMAP_UNIT
9
Bitmap unit
X11_BITMAP_BIT_ORDER
10
Bitmap bit order
X11_BITMAP_PAD
11
Bitmap pad
X11_BITS_PER_PIXEL
12
Bits per pixel
X11_BYTES_PER_LINE
13
Bytes per line
X11_VISUAL_CLASS
14
Visual class
X11_RED_MASK
15
Red mask
X11_GREEN_MASK
16
Green mask
X11_BLUE_MASK
17
Blue mask
X11_BITS_PER_RGB
18
Bp RGB
X11_NUMBER_OF_COLORS
19
Colors number
X11_COLOR_MAP_ENTRIES
20
Color map entries
X11_WINDOW_WIDTH
21
Window width
X11_WINDOW_HEIGHT
22
Window height
X11_WINDOW_X
23
Window X
X11_WINDOW_Y
24
Window Y
X11_WINDOW_BORDER_WIDTH
25
Window border width


ImageGear.Formats.CAD Namespace

ImageGear.Formats.CAD Namespace

32-bit
64-bit
CF
P
P

Description:

This namespace provides the API to create DWG and DXF vector formats.

Declaration:

namespace ImageGear.Formats.CAD

Members:

Classes:
Name
Description
ImGearCAD Class
This class is used to create DWG and DXF vector formats.

See Also:

DWG

DXF


ImageGear.Formats.CAD Namespace Classes

The ImageGear.Formats.CAD Namespace has the following class members:

Classes:
Name
Description
ImGearCAD Class
This class is used to create DWG and DXF vector formats.


ImGearCAD Class

32-bit
64-bit
CF
P
P

Description:

This class is used to create DWG and DXF vector formats.

Declaration:

public sealed class ImGearCAD

Members:

Constructors
Name
Description
ImGearCAD Constructor
This constructor creates and initializes an instance of ImGearCAD Class.

Methods
Name
Description
CreateDWGFormat Method
Creates an instance of DWG format.
CreateDWGFormat Method
Creates an instance of DWG format.
CreateDXFFormat Method
Creates an instance of DXF format.
CreateDXFFormat Method
Creates an instance of DXF format.


ImGearCAD Constructors

The ImGearCAD Class of the ImageGear.Formats.CAD Namespace has the following constructors:

Constructors
Name
Description
ImGearCAD Constructor
This constructor creates and initializes an instance of ImGearCAD Class.


ImGearCAD Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates and initializes an instance of ImGearCAD Class.

Declaration:

public ImGearCAD()

Return Value:

The new instance of ImGearCAD Class.

See Also:

ImGearCAD Class


ImGearCAD Methods

The ImGearCAD Class of the ImageGear.Formats.CAD Namespace has the following methods:

Methods
Name
Description
CreateDWGFormat Method
Creates an instance of DWG format.
CreateDWGFormat Method
Creates an instance of DWG format.
CreateDXFFormat Method
Creates an instance of DXF format.
CreateDXFFormat Method
Creates an instance of DXF format.


CreateDWGFormat Method

32-bit
64-bit
CF
P
P

Description:

This method creates an instance of DWG format.

Declaration:

public static ImageGear.Formats.IImGearFormat CreateDWGFormat()

Return value:

An instance of DWG format.

See Also:

ImGearCAD Class

IImGearFormat Interface


CreateDWGFormat Method

32-bit
64-bit
CF
P
P

Description:

This method creates an instance of DWG format. LibraryPath parameter specifies a folder path to load CAD and Vector native code libraries from.

If LibraryPath is blank, then the current directory is used.

Declaration:

public static ImageGear.Formats.IImGearFormat CreateDWGFormat(string LibraryPath)

Parameters:

Name
Type
Description
LibraryPath
string
Path to load CAD and Vector native libraries from.

Return value:

An instance of DWG format.

See Also:

ImGearCAD Class

IImGearFormat Interface


CreateDXFFormat Method

32-bit
64-bit
CF
P
P

Description:

This method creates an instance of DXF format.

Declaration:

public static ImageGear.Formats.IImGearFormat CreateDXFFormat()

Return value:

An instance of DXF format.

See Also:

ImGearCAD Class

IImGearFormat Interface


CreateDXFFormat Method

32-bit
64-bit
CF
P
P

Description:

This method creates an instance of DXF format. LibraryPath parameter specifies a folder path to load CAD and Vector native code libraries from.

If LibraryPath is blank then the current directory is used.

Declaration:

public static ImageGear.Formats.IImGearFormat CreateDXFFormat(string LibraryPath)

Parameters:

Name
Type
Description
LibraryPath
string
Path to load JPEG2K native libraries from.

Return value:

An instance of DXF format.

See Also:

ImGearCAD Class

IImGearFormat Interface


ImageGear.Formats.CGM Namespace

ImageGear.Formats.CGM Namespace

32-bit
64-bit
CF
P
P

Description:

This namespace provides the API to create CGM vector format.

Declaration:

namespace ImageGear.Formats.CGM

Members:

Classes:
Name
Description
ImGearCGM Class
This class is used to create CGM vector format.

See Also:

CGM


ImageGear.Formats.CGM Namespace Classes

The ImageGear.Formats.CGM Namespace has the following class members:

Classes:
Name
Description
ImGearCGM Class
This class is used to create CGM vector format.


ImGearCGM Class

32-bit
64-bit
CF
P
P

Description:

This class is used to create CGM vector format.

Declaration:

public sealed class ImGearCGM

Members:

Constructors
Name
Description
ImGearCGM Constructor
This constructor creates and initializes an instance of ImGearCGM Class.

Methods
Name
Description
CreateCGMFormat Method
Creates an instance of CGM format.
CreateCGMFormat Method
Creates an instance of CGM format.


ImGearCGM Constructors

The ImGearCGM Class of the ImageGear.Formats.CGM Namespace has the following constructors:

Constructors
Name
Description
ImGearCGM Constructor
This constructor creates and initializes an instance of ImGearCGM Class.


ImGearCGM Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates and initializes an instance of ImGearCGM Class.

Declaration:

public ImGearCGM()

Return Value:

The new instance of ImGearCGM Class.

See Also:

ImGearCGM Class


ImGearCGM Methods

The ImGearCGM Class of the ImageGear.Formats.CGM Namespace has the following methods:

Methods
Name
Description
CreateCGMFormat Method
Creates an instance of CGM format.
CreateCGMFormat Method
Creates an instance of CGM format.


CreateCGMFormat Method

32-bit
64-bit
CF
P
P

Description:

This method creates an instance of CGM format.

Declaration:

public static ImageGear.Formats.IImGearFormat CreateCGMFormat()

Return value:

An instance of CGM format.

See Also:

ImGearCGM Class

IImGearFormat Interface


CreateCGMFormat Method

32-bit
64-bit
CF
P
P

Description:

This method creates an instance of CGM format. LibraryPath parameter specifies a folder path to load Vector native code libraries from.

If LibraryPath is blank then the current directory is used.

Declaration:

public static ImageGear.Formats.IImGearFormat CreateCGMFormat(string LibraryPath)

Parameters:

Name
Type
Description
LibraryPath
string
Path to load Vector native libraries from.

Return value:

An instance of CGM format.

See Also:

ImGearCGM Class

IImGearFormat Interface


ImageGear.Formats.DGN Namespace

ImageGear.Formats.DGN Namespace

32-bit
64-bit
CF
P
P

Description:

This namespace provides the API to create DGN vector format.

Declaration:

namespace ImageGear.Formats.DGN

Members:

Classes:
Name
Description
ImGearDGN Class
This class is used to create DGN vector format.

See Also:

DGN


ImageGear.Formats.DGN Namespace Classes

The ImageGear.Formats.DGN Namespace has the following class members:

Classes:
Name
Description
ImGearDGN Class
This class is used to create DGN vector format.


ImGearDGN Class

32-bit
64-bit
CF
P
P

Description:

This class is used to create DGN vector format.

Declaration:

public sealed class ImGearDGN

Members:

Constructors
Name
Description
ImGearDGN Constructor
This constructor creates and initializes an instance of ImGearDGN Class.

Methods
Name
Description
CreateDGNFormat Method
Creates an instance of DGN format.
CreateDGNFormat Method
Creates an instance of DGN format.


ImGearDGN Constructors

The ImGearDGN Class of the ImageGear.Formats.DGN Namespace has the following constructors:

Constructors
Name
Description
ImGearDGN Constructor
This constructor creates and initializes an instance of ImGearDGN Class.


ImGearDGN Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates and initializes an instance of ImGearDGN Class.

Declaration:

public ImGearDGN()

Return Value:

The new instance of ImGearDGN Class.

See Also:

ImGearDGN Class


ImGearDGN Methods

The ImGearDGN Class of the ImageGear.Formats.DGN Namespace has the following methods:

Methods
Name
Description
CreateDGNFormat Method
Creates an instance of DGN format.
CreateDGNFormat Method
Creates an instance of DGN format.


CreateDGNFormat Method

32-bit
64-bit
CF
P
P

Description:

This method creates an instance of DGN format.

Declaration:

public static ImageGear.Formats.IImGearFormat CreateDGNFormat()

Return value:

An instance of DGN format.

See Also:

ImGearDGN Class

IImGearFormat Interface


CreateDGNFormat Method

32-bit
64-bit
CF
P
P

Description:

This method creates an instance of DGN format. LibraryPath parameter specifies a folder path to load Vector native code libraries from.

If LibraryPath is blank then the current directory is used.

Declaration:

public static ImageGear.Formats.IImGearFormat CreateDGNFormat(string LibraryPath)

Parameters:

Name
Type
Description
LibraryPath
string
Path to load Vector native libraries from.

Return value:

An instance of DGN format.

See Also:

ImGearDGN Class

IImGearFormat Interface


ImageGear.Formats.DICOM Namespace

ImageGear.Formats.DICOM Namespace

32-bit
64-bit
CF
P
P
P

Description:

ImageGear.Formats.DICOM namespace provides features that are used with medical and DICOM images. This chapter provides you with ImageGear.Formats.DICOM namespace API reference.

Declaration:

namespace ImageGear.Formats.DICOM

Members:

Classes:
Name
Description
ImGearDICOM Class
Provides DICOM specific features, such as DICOM Presentation State support.
ImGearDICOMDisplaySettings Class
Provides the means to display medical images with proper contrast.
ImGearModalityTransform Class
Implements DICOM Modality transform.
ImGearVOITransform Class
Implements DICOM Value Of Interest (VOI) transform.

Structures:
Name
Description
ImGearLinearTransform Structure
Encapsulates coefficients for a linear floating-point one-dimensional transform.
ImGearPresStateOptions Structure
Encapsulates options for loading and saving presentation state objects.
ImGearVOIWindow Structure
Encapsulates linear DICOM VOI transform.

Enumerations:
Name
Description
ImGearDICOMPhotoInterpretations Enumeration
Specifies DICOM Photometric Interpretations
ImGearDICOMPixelRepresenations Enumeration
Specifies DICOM Pixel Representations
ImGearDICOMPlanarConfigurations Enumeration
Specifies DICOM Planar Configurations
ImGearDICOMServiceObjectPairs Enumeration
Specifies DICOM Service Object Pair constants
ImGearDICOMTagsIDs Enumeration
Specifies DICOM tag identifiers
ImGearDICOMTransferSyntaxes Enumeration
Specifies DICOM Transfer Syntaxes
ImGearDICOMValueRepresentations Enumeration
Specifies DICOM Value Representations
ImGearPseudocolorSchemes Enumeration
Specifies predefined pseudocoloring schemes.

See Also:

Using ImageGear.Formats.DICOM Namespace


ImageGear.Formats.DICOM Namespace Classes

The ImageGear.Formats.DICOM Namespace has the following class members:

Classes:
Name
Description
ImGearDICOM Class
Provides DICOM specific features, such as DICOM Presentation State support.
ImGearDICOMDisplaySettings Class
Provides the means to display medical images with proper contrast.
ImGearModalityTransform Class
Implements DICOM Modality transform.
ImGearVOITransform Class
Implements DICOM Value Of Interest (VOI) transform.


ImGearDICOM Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides DICOM specific features, such as DICOM Presentation State support.

Declaration:

public sealed class ImGearDICOM

Members:

Methods
Name
Description
BuildColorLimitsLUT Method
Builds a LUT that highlights image extremes.
BuildPseudocolorLUT Method
Builds a pseudocolor LUT.
BuildStandardDisplayLUT Method
Builds Standard Display LUT.
CreateDICOMFormat Method
Creates an instance of DICOM format.
LoadOverlay Method
Loads overlay planes from DICOM metadata.
LoadPresState Method
Loads Presentation State object and applies it to an image.
PreparePresStateMetadata Method
Prepares Presentation State metadata based on current image display settings and annotations.
SaveOverlay Method
Saves ART marks into DICOM dataset as overlay planes.
SavePresState Method
Saves Presentation State metadata to a Presentation State object.


ImGearDICOM Methods

The ImGearDICOM Class of the ImageGear.Formats.DICOM Namespace has the following methods:

Methods
Name
Description
BuildColorLimitsLUT Method
Builds a LUT that highlights image extremes.
BuildPseudocolorLUT Method
Builds a pseudocolor LUT.
BuildStandardDisplayLUT Method
Builds Standard Display LUT.
CreateDICOMFormat Method
Creates an instance of DICOM format.
LoadOverlay Method
Loads overlay planes from DICOM metadata.
LoadPresState Method
Loads Presentation State object and applies it to an image.
PreparePresStateMetadata Method
Prepares Presentation State metadata based on current image display settings and annotations.
SaveOverlay Method
Saves ART marks into DICOM dataset as overlay planes.
SavePresState Method
Saves Presentation State metadata to a Presentation State object.


BuildColorLimitsLUT Method

32-bit
64-bit
CF
P
P
P

Description:

This method fills the look up table (LUT) so that it highlights the brightest and darkest pixels in a grayscale image. Use this method to initialize ImGearPageDisplay Class.LUT Property . This is typically used to clearly see pixel values that are over-saturated (255 and up) or under-saturated (0 and below). However, this function lets you customize the settings for the upper and lower pixel value limits with lowThreshold and highThreshold.

ImGearPageDisplay Class.LUT Property is used on the last stage of display processing, after that all geometric, color space and depth conversions have been done. This allows you to use a 24-bit RGB to 24-bit RGB look up table for displaying images of any color space and depth.

Declaration:

public static void BuildColorLimitsLUT(int lowThreshold, ImageGear.Core.ImGearPixel
lowColor, int highThreshold, ImageGear.Core.ImGearPixel highColor,
ImageGear.Core.ImGearRGBLUT lut)

Parameters:

Name
Type
Description
lowThreshold
int
Lower pixel value limit. All pixels at or below this value will be pseudocolored.
lowColor
ImGearPixel Class
An RGB value that will be used to pseudocolor the pixels with intensities equal or smaller than lowThreshold
highThreshold
int
Higher pixel value limit. All pixels at or above this value will be pseudocolored.
highColor
ImGearPixel Class
An RGB value that will be used to pseudocolor the pixels with intensities equal or greater than highThreshold.
lut
ImGearRGBLUT Class
Look up table to fill. It should contain three single-channel LUTs with input and output depths set to 8.

Example:

ImGearPageDisplay pageDisplay;
// Highlight low values with blue
ImGearPixel LowColor = new ImGearPixel(3, 8);
LowColor[0] = 0;
LowColor[1] = 0;
LowColor[2] = 255;
// Highlight high values with red
ImGearPixel HighColor = new ImGearPixel(3, 8);
HighColor[0] = 255;
HighColor[1] = 0;
HighColor[2] = 0;
ImGearRGBLUT lut = new ImGearRGBLUT(8, 8);
ImGearContrastSettings ContrastSettings = ImGearContrastSettings.CreateDefault();
ImGearDICOM.BuildColorLimitsLUT(0, LowColor, 255, HighColor, lut);
pageDisplay.UpdateLUT(lut, ContrastSettings);

See Also:

ImGearPixel Class

ImGearRGBLUT Class


BuildPseudocolorLUT Method

32-bit
64-bit
CF
P
P
P

Description:

This method fills a look up table (LUT) according to one of the predefined 24-bit RGB to 24-bit RGB pseudocoloring schemes. Use this method to initialize ImGearPageDisplay Class.LUT Property.

ImGearPageDisplay Class.LUT Property is used on the last stage of display processing when all geometric, color space and depth conversions have been done. This allows you to use a 24-bit RGB to 24-bit RGB look up table for displaying images of any color space and depth.

Declaration:

public static void BuildPseudocolorLUT(ImageGear.Formats.DICOM.ImGearPseudocolorSchemes
scheme, ImageGear.Core.ImGearRGBLUT lut)

Parameters:

Name
Type
Description
scheme
ImGearPseudocolorSchemes Enumeration
Predefined pseudocoloring scheme.
lut
ImGearRGBLUT Class
Look up table to fill. It should contain three single-channel LUTs with input and output depths set to 8.

Example:

ImGearPageDisplay pageDisplay;
ImGearContrastSettings ContrastSettings = ImGearContrastSettings.CreateDefault();
ImGearRGBLUT lut = new ImGearRGBLUT(8, 8);
ImGearDICOM.BuildPseudocolorLUT(ImGearPseudocolorSchemes.OilFilm, lut);
pageDisplay.UpdateLUT(lut, ContrastSettings);

See Also:

ImGearRGBLUT Class

ImGearPseudocolorSchemes Enumeration


BuildStandardDisplayLUT Method

32-bit
64-bit
CF
P
P
P

Description:

This method builds a look up table that maps pixel intensities from DICOM Presentation space (P-Values) into pixel intensities of the display device. Use this look up table to initialize ImGearDICOMDisplaySettings Class.StandardDisplayLUT Property member.

The source data for this function is a characteristic curve - an array that lists luminosities of display device corresponding to each pixel intensity.

Declaration:

public static ImageGear.Core.ImGearFullLUT BuildStandardDisplayLUT(int inputDepth, int
outputDepth, double[] charactCurve)

Parameters:

Name
Type
Description
inputDepth
int
Input depth of the LUT. inputDepth = 12 is the typical value, sufficient for most medical images.
outputDepth
int
Output depth of the LUT. Set to 8 for a monitor that can display 256 shades of gray.
charactCurve
double
Characteristic curve of the display device.

Return Value:

New instance of ImGearFullLUT Class object, containing the Standard Display LUT, based on the provided characteristic curve.

Example:

double[] CharacteristicCurve;
// Fill characteristic curve, e.g. load from a file
ImGearFullLUT StdLUT = ImGearDICOM.BuildStandardDisplayLUT(12, 8, CharacteristicCurve);

See Also:

ImGearFullLUT Class


CreateDICOMFormat Method

32-bit
64-bit
CF
P
P
P

Description:

This method creates an instance of DICOM format.

Declaration:

public static ImageGear.Formats.IImGearFormat CreateDICOMFormat()

Return Value:

An instance of DICOM format.

See Also:

IImGearFormat Interface


LoadOverlay Method

32-bit
64-bit
CF
P
P
P

Description:

Loads overlay planes from DICOM metadata (DataSet) attached to the image and creates ART marks of type ImGearARTImage Class for each overlay plane. Each mark is placed in a separate ART group.

Overlay planes do not support specifying the colors (even black or white). An overlay pixel can only be visible or unvisible. All visible overlay pixels are displayed with the same color, which is specified by the application and not stored in the DICOM DataSet. By default, ImageGear uses yellow color to display overlays. The application can change overlay color by going through all marks in the ImGearARTPage Class and changing palette of ImGearARTImage Class marks.

Declaration:

public static ImageGear.ART.ImGearARTPage LoadOverlay(ImageGear.Core.ImGearRasterPage
page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page from which to load overlay planes.

Return Value:

New ImGearARTPage Class with annotations loaded from overlay.

See Also:

ImGearRasterPage Class

ImGearARTPage Class

ImGearARTImage Class


LoadPresState Method

32-bit
64-bit
CF
P
P
P

Description:

This method loads Presentation State object from a stream, and applies settings found in this object to the page and to the pageDisplay. Specifically:

  • Adjusts page's ImGearDICOMDisplaySettings Class member, using VOI, Modality and Presentation LUTs found in the Presentation State DataSet;
  • Sets image rectangle and orientation of the pageDisplay;
  • Adds annotation objects to the pageDisplay.

All previous settings and annotations of the page and pageDisplay are discarded.

This method also returns all metadata found in the Presentation State object.

Declaration:

public static ImageGear.Core.ImGearMetadataHead LoadPresState(System.IO.Stream strm,
ImageGear.Core.ImGearRasterPage page, ImageGear.Display.ImGearPageDisplay pageDisplay,
ImageGear.Formats.DICOM.ImGearPresStateOptions options)

Parameters:

Name
Type
Description
strm
Stream
Stream containing presentation state object
page
ImGearRasterPage Class
page to apply Presentation State to
pageDisplay
ImGearPageDisplay Class
pageDisplay to apply Presentation State to
options
ImGearPresStateOptions Structure
options structure, tells which settings need to be applied.

Return Value:

New instance of ImGearMetadataHead Class object, containing metadata loaded from the Presentation State object.

Example:

ImGearPresStateOptions opts = new ImGearPresStateOptions();
ImGearMetadataHead presStateOrigMetadata =
ImGearDICOM.LoadPresState(fileContent, rasterPage,
pageDisplay, opts);

See Also:

ImGearRasterPage Class

ImGearPresStateOptions Structure

ImGearPageDisplay Class


PreparePresStateMetadata Method

32-bit
64-bit
CF
P
P
P

Description:

This method prepares metadata for a presentation state object, based on page's DICOMDisplaySettings member, on pageDisplay settings, and on annotations that are attached to image, if any.

After that presentation state metadata has been prepared, application may add or edit it, and then save as presentation state object using SavePresState Method method.

The following features of the ImGearDICOMDisplaySettings Class are saved to presentation state metadata:

  • VOI LUT;
  • Modality LUT;
  • Presentation LUT.

The following settings of pageDisplay are saved to presentation state metadata:

  • Orientation;
  • Image rectangle;

The following annotations are saved to saved to presentation state metadata: Text, Callout, Polygon, Polyline, Point, Curve, Ellipse.

This method takes user metadata as a parameter. If this parameter is not null, and contains a DICOM metadata tree, the method will use it as a base for building output metadata.

Declaration:

public static ImageGear.Core.ImGearMetadataTree
PreparePresStateMetadata( ImageGear.Core.ImGearRasterPage page,
ImageGear.Display.ImGearPageDisplay pageDisplay, ImageGear.Core.ImGearMetadataHead
userMetadata, ImageGear.Formats.DICOM.ImGearPresStateOptions options)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page from which presentation state settings shall be extracted
pageDisplay
ImGearPageDisplay Class
pageDisplay from which presentation state settings shall be extracted
userMetadata
ImGearMetadataHead Class
User supplied metadata
options
ImGearPresStateOptions Structure
Options structure telling which settings shall be extracted to the presentation state metadata.

Return Value:

New instance of ImGearMetadataTree Class object, containing presentation state metadata.

Example:

ImGearPresStateOptions opts = new ImGearPresStateOptions();
ImGearMetadataHead presStateMetadata =
ImGearDICOM.PreparePresStateMetadata(rasterPage,
pageDisplay, presStateOrigMetadata, opts);

See Also:

ImGearRasterPage Class

ImGearMetadataHead Class

ImGearPresStateOptions Structure

ImGearPageDisplay Class

ImGearMetadataTree Class


SaveOverlay Method

32-bit
64-bit
CF
P
P
P

Description:

Saves ART marks into DICOM dataset as overlay planes. Each ART group is saved into a separate overlay plane.

Since overlay planes do not support any types of graphic objects other than bitonal bitmaps, all ART marks from a group are converted into a bitmap before saving into an overlay.

Overlay planes do not support specifying the colors (even black or white). An overlay pixel can only be visible or invisible. All visible overlay pixels are displayed with the same color, which is specified by the application and not stored in the DICOM DataSet.

Declaration:

public static void SaveOverlay(ImageGear.ART.ImGearARTPage artpage,
ImageGear.Core.ImGearRasterPage page )

Parameters:

Name
Type
Description
artpage
ImGearARTPage Class
ART page with marks to save to overlay.
page
ImGearRasterPage Class
Page to which to save annotations.

Return Value:

None.

See Also:

ImGearRasterPage Class

ImGearARTPage Class

ImGearARTImage Class


SavePresState Method

32-bit
64-bit
CF
P
P
P

Description:

This method saves presentation state metadata as a presentation state object. Use PreparePresStateMetadata Method method to extract presentation state settings from page and pageDisplay and build metadata for presentation state.

This method expects DICOM metadata tree in the presStateMetadata parameter:

  • DICOM
    • Preamble (optional)
    • MetaInfoHeader (optional)
    • DataSet (required).

Declaration:

public static void SavePresState(System.IO.Stream strm, ImageGear.Core.ImGearMetadataHead
presStateMetadata)

Parameters:

Name
Type
Description
strm
Stream
Stream to save presentation state to.
presStateMetadata
ImGearMetadataHead Class
Presentation state metadata.

Return Value:

None.

Example:

ImGearMetadataHead presStateMetadata =
ImGearDICOM.PreparePresStateMetadata((ImGearRasterPage)imGearPage,
imGearPageView.Display, presStateOrigMetadata, opts);
using (FileStream fileContent = new System.IO.FileStream(FileName, FileMode.Create))
{
ImGearDICOM.SavePresState(fileContent, presStateMetadata);
}

See Also:

ImGearMetadataHead Class


ImGearDICOMDisplaySettings Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides the means to display medical images with proper contrast.

Declaration:

public class ImGearDICOMDisplaySettings

Members:

Constructors
Name
Description
ImGearDICOMDisplaySettings Constructor
Creates new instance of ImGearDICOMDisplaySettings Class object.

Properties
Name
Description
DisplaySummaryLUT Property
Provides summary LUT based on all settings of the ImGearDICOMDisplaySettings Class object
Inverted Property
Specifies whether image contrast shall be inverted.
Modality Property
Provides access to Modality transform
PresentationLUT Property
Provides access to Presentation LUT
StandardDisplayLUT Property
Provides access to Standard Display LUT
VOI Property
Provides access to VOI transform

Methods
Name
Description
Clone Method
Creates a deep copy of the ImGearDICOMDisplaySettings Class object
SetAutoVOITransform Method
Automatically caclulates VOI transform based on image's contrast range
UpdateDisplaySummaryLUT Method
Updates DisplaySummaryLUT with current settings of the ImGearDICOMDisplaySettings Class members
UpdateFromMetadata Method
Updates the object from DICOM metadata
UpdateFromPresStateMetadata Method
Updates the object from DICOM Presentation State metadata


ImGearDICOMDisplaySettings Constructors

The ImGearDICOMDisplaySettings Class of the ImageGear.Formats.DICOM Namespace has the following constructors:

Constructors
Name
Description
ImGearDICOMDisplaySettings Constructor
Creates new instance of ImGearDICOMDisplaySettings Class object.


ImGearDICOMDisplaySettings Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates new instance of ImGearDICOMDisplaySettings Class object.

Declaration:

public ImGearDICOMDisplaySettings ()

Return Value:

The new instance of ImGearDICOMDisplaySettings Class object.


ImGearDICOMDisplaySettings Properties

The ImGearDICOMDisplaySettings Class of the ImageGear.Formats.DICOM Namespace has the following properties:

Properties
Name
Description
DisplaySummaryLUT Property
Provides summary LUT based on all settings of the ImGearDICOMDisplaySettings Class object
Inverted Property
Specifies whether image contrast shall be inverted
Modality Property
Provides access to Modality transform
PresentationLUT Property
Provides access to Presentation LUT
StandardDisplayLUT Property
Provides access to Standard Display LUT
VOI Property
Provides access to VOI transform


DisplaySummaryLUT Property

32-bit
64-bit
CF
P
P
P

Description:

This property concatenates all transforms that are present in the ImGearDICOMDisplaySettings Class object, and builds a summary LUT. Display code does not check any other transforms of the ImGearDICOMDisplaySettings Class, but uses this LUT to display medical images with proper contrast.

If the application changes any members of ImGearDICOMDisplaySettings Class, it will call UpdateDisplaySummaryLUT Method method to allow display make use of the changed settings.

Declaration:

public ImageGear.Core.ImGearLUT DisplaySummaryLUT { get, set }

Value:

ImGearLUT Class object.

Default value:

N/A

See Also:

ImGearLUT Class


Inverted Property

32-bit
64-bit
CF
P
P
P

Description:

This property tells whether the image shall be displayed with inverted contrast. ImageGear sets this property to true for images that have Photometric Interpretation set to MONOCHROME1, or Presentation LUT set to INVERSE.

UpdateDisplaySummaryLUT Method takes this property into account when it builds the summary LUT.

Declaration:

public bool Inverted { get, set }

Value:

True, False

Default value:

False


Modality Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides access to DICOM Modality transform.

Declaration:

public ImageGear.Formats.DICOM.ImGearModalityTransform
Modality {get, set }

Value:

ImGearModalityTransform Class object.

Default value:

NULL

See Also:

ImGearModalityTransform Class


PresentationLUT Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides access to DICOM Presentation LUT.

Declaration:

public ImageGear.Core.ImGearFullLUT PresentationLUT { get, set }

Value:

ImGearFullLUT Class object.

Default value:

NULL

See Also:

ImGearFullLUT Class


StandardDisplayLUT Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides access to Standard Display LUT.

Declaration:

Public ImageGear.Core.ImGearFullLUT StandardDisplayLUT { get, set }

Value:

ImGearFullLUT Class object.

Default value:

NULL

See Also:

ImGearFullLUT Class


VOI Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides access to DICOM Value Of Interest (VOI) transform.

Declaration:

public ImageGear.Formats.DICOM.ImGearVOITransform VOI { get, set }

Value:

ImGearVOITransform Class object.

Default value:

NULL

See Also:

ImGearVOITransform Class


ImGearDICOMDisplaySettings Methods

The ImGearDICOMDisplaySettings Class of the ImageGear.Formats.DICOM Namespace has the following methods:

Methods
Name
Description
Clone Method
Creates a deep copy of the ImGearDICOMDisplaySettings Class object
SetAutoVOITransform Method
Automatically caclulates VOI transform based on image's contrast range
UpdateDisplaySummaryLUT Method
Updates DisplaySummaryLUT with current settings of the ImGearDICOMDisplaySettings Class members
UpdateFromMetadata Method
Updates the object from DICOM metadata
UpdateFromPresStateMetadata Method
Updates the object from DICOM Presentation State metadata


Clone Method

32-bit
64-bit
CF
P
P
P

Description:

This method creates a deep copy of the ImGearDICOMDisplaySettings Class object.

Declaration:

public ImageGear.Formats.DICOM.ImGearDICOMDisplaySettings Clone()

Return Value:

The new instance of ImGearDICOMDisplaySettings Class object.

Example:

ImGearDICOMDisplaySettings CurrentDisplaySettings = page.DICOMDisplaySettings.Clone();

See Also:

ImGearDICOMDisplaySettings Class


SetAutoVOITransform Method

32-bit
64-bit
CF
P
P
P

Description:

This method automatically calculates the linear VOI transform coefficients (Window Center and Width) based on image minimum and maximum values. It takes image's ROI (Region Of Interest) into account.

Declaration:

public void SetAutoVOITransform ( ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page which minimum and maximum values are obtained to build the transform.

Return Value:

None.

Example:

rasterPage.DICOMDisplaySettings.SetAutoVOITransform(rasterPage);

See Also:

ImGearRasterPage Class


UpdateDisplaySummaryLUT Method

32-bit
64-bit
CF
P
P
P

Description:

This method updates DisplaySummaryLUT Property property based on the transforms that are present in the ImGearDICOMDisplaySettings Class object.

Transforms are applied in the following order:

  1. Modality
  2. VOI
  3. Inverted
  4. Presentation LUT
  5. Standard Display LUT

Resulting DisplaySummaryLUT Property has input depth equal to image bit depth and output depth equal to grayscale depth of the display device (8).

Declaration:

public void UpdateDisplaySummaryLUT(ImageGear.Core.ImGearDIB dib)

Parameters:

Name
Type
Description
dib
ImGearDIB Class
DIB for which the DisplaySummaryLUT is to be built.

Return Value:

None.

Example:

rasterPage.DICOMDisplaySettings.UpdateDisplaySummaryLUT(rasterPage.DIB);

See Also:

ImGearDIB Class


UpdateFromMetadata Method

32-bit
64-bit
CF
P
P
P

Description:

This method updates ImGearDICOMDisplaySettings Class object from DICOM metadata. It sets the following members:

  • Modality
  • VOI
  • Inverted

Presentation State metadata uses a different structure than metadata of a DICOM image. To update ImGearDICOMDisplaySettings Class from presentation state metadata, use UpdateFromPresStateMetadata Method method.

NOTE: This method does not update DisplaySummaryLUT Property. Use UpdateDisplaySummaryLUT Method method for this.

Declaration:

public void UpdateFromMetadata(ImageGear.Core.ImGearMetadataHead mdHead)

Parameters:

Name
Type
Description
mdHead
ImGearMetadataHead Class
DICOM Metadata from which display settings shall be obtained.

Return Value:

None.

Example:

rasterPage.DICOMDisplaySettings.UpdateFromMetadata(rasterPage.Metadata);

See Also:

ImGearMetadataHead Class


UpdateFromPresStateMetadata Method

32-bit
64-bit
CF
P
P
P

Description:

This method updates ImGearDICOMDisplaySettings Class object from DICOM metadata. It sets the following members:

  • Modality
  • VOI
  • Inverted
  • Presentation LUT

Declaration:

public void UpdateFromPresStateMetadata( ImageGear.Core.ImGearMetadataHead mdHead)

Parameters:

Name
Type
Description
mdHead
ImGearMetadataHead Class
Presentation State metadata from which display settings shall be obtained.

Return Value:

None.

Example:

rasterPage.DICOMDisplaySettings.UpdateFromPresStateMetadata(rasterPage.Metadata);

See Also:

ImGearMetadataHead Class

32-bit
64-bit
CF
P
P
P
32-bit
64-bit
CF
P
P
P
ImageGear.Formats.DICOM Namespace > ImGearModalityTransform Class


ImGearModalityTransform Class

32-bit
64-bit
CF
P
P
P

Description:

This class implements DICOM Modality transform.

Declaration:

public class ImGearModalityTransform

Members:

Constructors
Name
Description
ImGearModalityTransform Constructor
Creates new instance of ImGearModalityTransform object.

Properties
Name
Description
Rescale Property
Specifies linear modality transform

Methods
Name
Description
Clone Method
Creates a deep copy of the object


ImGearModalityTransform Constructors

The ImGearModalityTransform Class of the ImageGear.Formats.DICOM Namespace has the following constructors:

Constructors
Name
Description
ImGearModalityTransform Constructor
Creates new instance of ImGearModalityTransform object.


ImGearModalityTransform Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates new instance of ImGearModalityTransform Class object.

Declaration:

public ImGearModalityTransform (  )

Return Value:

The new instance of ImGearModalityTransform Class object.

See Also:

ImGearModalityTransform Class


ImGearModalityTransform Properties

The ImGearModalityTransform Class of the ImageGear.Formats.DICOM Namespace has the following properties:

Properties
Name
Description
Rescale Property
Specifies linear modality transform


Rescale Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies a linear Modality transform. This transform corresponds to RescaleSlope and RescaleIntercept DICOM tags.

Declaration:

Public ImageGear.Formats.DICOM.ImGearLinearTransform Rescale {get, set }

Value:

ImGearLinearTransform Structure object.

See Also:

ImGearLinearTransform Structure


ImGearModalityTransform Methods

The ImGearModalityTransform Class of the ImageGear.Formats.DICOM Namespace has the following methods:

Methods
Name
Description
Clone Method
Creates a deep copy of the object


Clone Method

32-bit
64-bit
CF
P
P
P

Description:

This method makes a deep copy of the ImGearModalityTransform Class object.

Declaration:

public ImageGear.Formats.DICOM.ImGearModalityTransform Clone()

Return Value:

The new instance of ImGearModalityTransform Class object.

See Also:

ImGearModalityTransform Class


ImGearVOITransform Class

32-bit
64-bit
CF
P
P
P

Description:

This class implements DICOM Value Of Interest (VOI) transform.

Declaration:

public class ImGearVOITransform

Members:

Constructors
Name
Description
ImGearVOITransform Constructor
Creates new instance of ImGearVOITransform Class object.

Properties
Name
Description
Window Property
Specifies linear VOI transform

Methods
Name
Description
Clone Method
Creates a deep copy of the object.


ImGearVOITransform Constructors

The ImGearVOITransform Class of the ImageGear.Formats.DICOM Namespace has the following constructors:

Constructors
Name
Description
ImGearVOITransform Constructor
Creates new instance of ImGearVOITransform Class object.


ImGearVOITransform Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates new instance of ImGearVOITransform Class object.

Declaration:

public ImGearVOITransform (  )

Return Value:

The new instance of ImGearVOITransform Class object.


ImGearVOITransform Properties

The ImGearVOITransform Class of the ImageGear.Formats.DICOM Namespace has the following properties:

Properties
Name
Description
Window Property
Specifies linear VOI transform


Window Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies linear VOI transform. This corresponds to WindowCenter and WindowWidth DICOM tags.

Declaration:

Public ImageGear.Formats.DICOM.ImGearVOIWindow Window {get, set }

Value:

ImGearVOIWindow Structure object.

See Also:

ImGearVOIWindow Structure


ImGearVOITransform Methods

The ImGearVOITransform Class of the ImageGear.Formats.DICOM Namespace has the following methods:

Methods
Name
Description
Clone Method
Creates a deep copy of the object.


Clone Method

32-bit
64-bit
CF
P
P
P

Description:

This method creates a deep copy of the ImGearVOITransform Class object.

Declaration:

public ImageGear.Formats.DICOM.ImGearVOITransform Clone()

Return Value:

The new instance of ImGearVOITransform Class object.

Example:

ImGearVOITransform clone = voi.Clone();

See Also:

ImGearVOITransform Class


ImageGear.Formats.DICOM Namespace Structures

The ImageGear.Formats.DICOM Namespace has the following structure members:

Structures:
Name
Description
ImGearLinearTransform Structure
Encapsulates coefficients for a linear floating-point one-dimensional transform.
ImGearPresStateOptions Structure
Encapsulates options for loading and saving presentation state objects.
ImGearVOIWindow Structure
Encapsulates linear DICOM VOI transform.


ImGearLinearTransform Structure

32-bit
64-bit
CF
P
P
P

Description:

This class encapsulates coefficients for a linear floating-point one-dimensional transform.

Result of the transform is calculated as:

y = x * Slope + Intercept

This class can be used to hold DICOM Modality Rescale coefficients.

Declaration:

public struct ImGearLinearTransform

Members:

Constructors
Name
Description
ImGearLinearTransform Constructor
Creates an instance of ImGearLinearTransform

Properties
Name
Description
Intercept Property
Intercept coefficient
Slope Property
Slope coefficient

Methods
Name
Description
CreateIdentity Method
Creates an identity transform


ImGearLinearTransform Constructors

The ImGearLinearTransform Structure of the ImageGear.Formats.DICOM Namespace has the following constructors:

Constructors
Name
Description
ImGearLinearTransform Constructor
Creates an instance of ImGearLinearTransform


ImGearLinearTransform Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates new instance of ImGearLinearTransform Structure object.

Declaration:

public ImGearLinearTransform (Double slope, Double intercept)

Parameters:

Name
Type
Description
slope
Double
Slope
intercept
Double
Intercept

Return Value:

The new instance of ImGearLinearTransform Structure object.


ImGearLinearTransform Properties

The ImGearLinearTransform Structure of the ImageGear.Formats.DICOM Namespace has the following properties:

Properties
Name
Description
Intercept Property
Intercept coefficient
Slope Property
Slope coefficient


Intercept Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies Intercept coefficient of the transform.

Declaration:

public double Intercept { get, set }

Value:

Any double value.

Default value:

0.0


Slope Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies Slope coefficient of the transform.

Declaration:

public double Slope { get, set }

Value:

Any double value.

Default value:

0.0


ImGearLinearTransform Methods

The ImGearLinearTransform Structure of the ImageGear.Formats.DICOM Namespace has the following methods:

Methods
Name
Description
CreateIdentity Method
Creates an identity transform


CreateIdentity Method

32-bit
64-bit
CF
P
P
P

Description:

This method creates an identity transform, using

Slope = 1.0;
Intercept = 0.0;

Declaration:

public static ImageGear.Formats.DICOM.ImGearLinearTransform CreateIdentity()

Return Value:

ImGearLinearTransform Structure object.

Example:

ImGearLinearTransform tr = ImGearLinearTransform.CreateIdentity()

See Also:

ImGearLinearTransform Structure


ImGearPresStateOptions Structure

32-bit
64-bit
CF
P
P
P

Description:

This class encapsulates options for loading and saving presentation state objects.

Declaration:

public struct ImGearPresStateOptions

Members:

Properties
Name
Description
UseAnnotations Property
Tells whether to use or ignore annotations.
UseDisplayedArea Property
Tells whether to use or ignore displayed area.
UseModalityLUT Property
Tells whether to use or ignore Modality LUT.
UseOrientation Property
Tells whether to use or ignore orientation.
UsePresentationLUT Property
Tells whether to use or ignore Presentation LUT.
UseVOILUT Property
Tells whether to use or ignore VOI LUT.


ImGearPresStateOptions Properties

The ImGearPresStateOptions Structure of the ImageGear.Formats.DICOM Namespace has the following properties:

Properties
Name
Description
UseAnnotations Property
Tells whether to use or ignore annotations.
UseDisplayedArea Property
Tells whether to use or ignore displayed area.
UseModalityLUT Property
Tells whether to use or ignore Modality LUT.
UseOrientation Property
Tells whether to use or ignore orientation.
UsePresentationLUT Property
Tells whether to use or ignore Presentation LUT.
UseVOILUT Property
Tells whether to use or ignore VOI LUT.


UseAnnotations Property

32-bit
64-bit
CF
P
P
P

Description:

This property tells whether to use or ignore annotations when loading or saving a presentation state object.

Declaration:

public bool UseAnnotations { get, set }

Value:

True, False

Default value:

True


UseDisplayedArea Property

32-bit
64-bit
CF
P
P
P

Description:

This property tells whether to use or ignore displayed area setting when loading or saving a presentation state object.

Declaration:

public bool UseDisplayedArea { get, set }

Value:

True, False

Default value:

True


UseModalityLUT Property

32-bit
64-bit
CF
P
P
P

Description:

This property tells whether to use or ignore Modality LUT when loading or saving a presentation state object.

Declaration:

public bool UseModalityLUT { get, set }

Value:

True, False

Default value:

True


UseOrientation Property

32-bit
64-bit
CF
P
P
P

Description:

This property tells whether to use or ignore orientation setting when loading or saving a presentation state object.

Declaration:

public bool UseOrientation { get, set }

Value:

True, False

Default value:

True


UsePresentationLUT Property

32-bit
64-bit
CF
P
P
P

Description:

This property tells whether to use or ignore Presentation LUT when loading or saving a presentation state object.

Declaration:

public bool UsePresentationLUT { get, set }

Value:

True, False

Default value:

True


UseVOILUT Property

32-bit
64-bit
CF
P
P
P

Description:

This property tells whether to use or ignore VOI LUT when loading or saving a presentation state object.

Declaration:

public bool UseVOILUT { get, set }

Value:

True, False

Default value:

True


ImGearVOIWindow Structure

32-bit
64-bit
CF
P
P
P

Description:

This class encapsulates linear DICOM VOI transform. It contains two member values: Center Property and Width Property. This transform tells which contrast range of an image shall be mapped to contrast range of the display device.

Declaration:

public struct ImGearVOIWindow

Members:

Constructors
Name
Description
ImGearVOIWindow Constructor
Creates a new instance of ImGearVOITransform
ImGearVOIWindow Constructor
Creates a new instance of ImGearVOITransform

Properties
Name
Description
Center Property
Provides access to Window Center
Center64 Property
Provides access to Window Center as 64 bit integer
Max Property
Returns Window Maximum value
Max64Property
Returns Window Maximum value as 64 bit integer
Min Property
Returns Window Minimum value
Min64 Property
Returns Window Minimum value as 64 bit integer
Width Property
Provides access to Window Width
Width64 Property
Provides access to Window Width as 64 bit integer

Methods
Name
Description
CreateDefault Method
Creates default transform
CreateFromChannelSpec Method
Creates a Window transform based on channel depth and signed attribute
CreateFromMinMax Method
Creates Window transform from Window minimum and maximum values
CreateFromMinMax64 Method
Creates Window transform from Window minimum (64 bit) and maximum (64 bit) values


ImGearVOIWindow Constructors

The ImGearVOIWindow Structure of the ImageGear.Formats.DICOM Namespace has the following constructors:

Constructors
Name
Description
ImGearVOIWindow Constructor
Creates a new instance of ImGearVOITransform
ImGearVOIWindow Constructor
Creates a new instance of ImGearVOITransform


ImGearVOIWindow Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates new instance of ImGearVOIWindow Structure object, using the specified 32-bit values for window center and width.

Declaration:

public ImGearVOIWindow ( Int32 center, Int32 width )

Parameters:

Name
Type
Description
center
Int32
Window Center
width
Int32
Window Width

Return Value:

The new instance of ImGearVOIWindow Structure object.


ImGearVOIWindow Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates new instance of ImGearVOIWindow Structure object, using the specified 64-bit values for window center and width.

Declaration:

public ImGearVOIWindow ( Int64 center, Int64 width )

Parameters:

Name
Type
Description
center
Int64
Window Center
width
Int64
Window Width

Return Value:

The new instance of ImGearVOIWindow Structure object.


ImGearVOIWindow Properties

The ImGearVOIWindow Structure of the ImageGear.Formats.DICOM Namespace has the following properties:

Properties
Name
Description
Center Property
Provides access to Window Center
Center64 Property
Provides access to Window Center as 64 bit integer
Max Property
Returns Window Maximum value
Max64Property
Returns Window Maximum value as 64 bit integer
Min Property
Returns Window Minimum value
Min64 Property
Returns Window Minimum value as 64 bit integer
Width Property
Provides access to Window Width
Width64 Property
Provides access to Window Width as 64 bit integer


Center Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides access to Window Center value, as a 32-bit integer. Please use Center64 Property if you are working with 17-32 bit per channel images..

Declaration:

public int Center { get, set }

Value:

Any integer value.

Default value:

0


Center64 Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides access to Window Center value as 64 bit integer.

Declaration:

public Int64 Center64 { get, set }

Value:

Any long integer value.

Default value:

0


Max Property

32-bit
64-bit
CF
P
P
P

Description:

This property returns maximum window value, as a 32-bit integer. Please use Max64Property if you are working with 17-32 bit per channel images..

Declaration:

public int Max { get }

Value:

Any integer number.

Default value:

N/A


Max64Property

32-bit
64-bit
CF
P
P
P

Description:

This property returns maximum window value as 64 bit integer.

Declaration:

public Int64 Max64 { get }

Value:

Any long integer number.

Default value:

N/A


Min Property

32-bit
64-bit
CF
P
P
P

Description:

This property returns minimum window value as a 32-bit integer. Please use Min64 Property if you are working with 17-32 bit per channel images.

Declaration:

public int Min { get }

Value:

Any integer number.

Default value:

N/A


Min64 Property

32-bit
64-bit
CF
P
P
P

Description:

This property returns minimum window value as 64 bit integer.

Declaration:

public Int64 Min64 { get }

Value:

Any long integer number.

Default value:

N/A


Width Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides access to Window Width value as a 32-bit integer. Please use Width64 Property if you are working with 17-32 bit per channel images.

Declaration:

public int Width { get, set }

Value:

Any integer number.

Default value:

0


Width64 Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides access to Window Width value as 64 bit integer.

Declaration:

public Int64 Width64 { get, set }

Value:

Any long integer number.

Default value:

0


ImGearVOIWindow Methods

The ImGearVOIWindow Structure of the ImageGear.Formats.DICOM Namespace has the following methods:

Methods
Name
Description
CreateDefault Method
Creates default transform
CreateFromChannelSpec Method
Creates a Window transform based on channel depth and signed attribute
CreateFromMinMax Method
Creates Window transform from Window minimum and maximum values
CreateFromMinMax64 Method
Creates Window transform from Window minimum (64 bit) and maximum (64 bit) values


CreateDefault Method

32-bit
64-bit
CF
P
P
P

Description:

This method creates default VOI Window transform.

Declaration:

public static ImageGear.Formats.DICOM.ImGearVOIWindow Structure CreateDefault ()

Return Value:

ImGearVOIWindow Structure object.

See Also:

ImGearVOIWindow Structure


CreateFromChannelSpec Method

32-bit
64-bit
CF
P
P
P

Description:

This method creates Window transform based on channel depth and Signed attribute. Transform is initialized according to minimum and maximum possible values of a signed or unsigned pixel.

Declaration:

public static ImageGear.Formats.DICOM.ImGearVOIWindow CreateFromChannelSpec ( int
inputDepth , bool signed )

Parameters:

Name
Type
Description
inputDepth
int
Depth of an image to which the Window transform will be applied
signed
bool
Signed attribute of an image to which the Window transform will be applied

Return Value:

ImGearVOIWindow Structure object.

Example:

rasterPage.DICOMDisplaySettings.VOI.Window =
ImGearVOIWindow.CreateFromChannelSpec(imGearPage.DIB.ChannelDepths[0],
imGearPage.DIB.Signed);

See Also:

ImGearVOIWindow Structure


CreateFromMinMax Method

32-bit
64-bit
CF
P
P
P

Description:

This method creates Window transform from 32-bit integer Minimum and Maximum values. Please use CreateFromMinMax64 Method if you are working with 17-32 bit per channel images.

Declaration:

public static ImageGear.Formats.DICOM.ImGearVOIWindow CreateFromMinMax ( int min , int max
)

Parameters:

Name
Type
Description
min
int
Window Minimum
max
int
Window Maximum

Return Value:

ImGearVOIWindow Structure object.

Example:

ImGearVOIWindow window = ImGearVOIWindow.CreateFromMinMax(1024, 2048);

See Also:

ImGearVOIWindow Structure


CreateFromMinMax64 Method

32-bit
64-bit
CF
P
P
P

Description:

This method creates Window transform from Minimum and Maximum 64 bit values.

Declaration:

public static ImageGear.Formats.DICOM.ImGearVOIWindow CreateFromMinMax64 ( Int64 min,
Int64 max )

Parameters:

Name
Type
Description
min
Int64
Window Minimum
max
Int64
Window Maximum

Return Value:

ImGearVOIWindow Structure object.

Example:

ImGearVOIWindow window = ImGearVOIWindow.CreateFromMinMax(1024, 2048);

See Also:

ImGearVOIWindow Structure


ImageGear.Formats.DICOM Namespace Enumerations

The ImageGear.Formats.DICOM Namespace has the following enumeration members:

Enumerations:
Name
Description
ImGearDICOMPhotoInterpretations Enumeration
Specifies DICOM Photometric Interpretations
ImGearDICOMPixelRepresenations Enumeration
Specifies DICOM Pixel Representations
ImGearDICOMPlanarConfigurations Enumeration
Specifies DICOM Planar Configurations
ImGearDICOMServiceObjectPairs Enumeration
Specifies DICOM Service Object Pair constants
ImGearDICOMTagsIDs Enumeration
Specifies DICOM tag identifiers
ImGearDICOMTransferSyntaxes Enumeration
Specifies DICOM Transfer Syntaxes
ImGearDICOMValueRepresentations Enumeration
Specifies DICOM Value Representations
ImGearPseudocolorSchemes Enumeration
Specifies predefined pseudocoloring schemes.


ImGearDICOMPhotoInterpretations Enumeration

32-bit
64-bit
CF
P
P
P

Description:

Specifies DICOM Photometric Interpretations.

Declaration:

public enum ImGearDICOMPhotoInterpretations

Values:

Name
Value
Description
ARGB
Retired
CMYK
Retired
HSV
Retired
MONOCHROME1
Pixel data represent a single monochrome image plane. The minimum sample value is intended to be displayed as white.
MONOCHROME2
Pixel data represent a single monochrome image plane. The minimum sample value is intended to be displayed as black.
PALETTE_COLOR
Pixel data describe a color image with a single sample per pixel (single image plane). The pixel value is used as an index into each of the Red, Blue, and Green Palette Color Lookup Tables
RGB
Pixel data represent a color image described by red, green, and blue image planes.
UNKNOWN
Photometric interpretation is unknown.
YBR_FULL
Pixel data represent a color image described by one luminance (Y) and two chrominance planes (Cb and Cr).
YBR_FULL_422
The same as YBR_FULL except that the Cb and Cr values are sampled horizontally at half the Y rate and as a result there are half as many Cb and Cr values as Y values.
YBR_ICT
Irreversible Color Transformation. Pixel data represent a color image described by one luminance (Y) and two chrominance planes (Cb and Cr). Used with JPEG 2000 transfer syntax.
YBR_PARTIAL_422
The same as YBR_FULL_422 with certain limitations. See DICOM specification PS 3.3 for more detail.
YBR_RCT
Reversible Color Transformation. Pixel data represent a color image described by one luminance (Y) and two chrominance planes (Cb and Cr). Used with JPEG 2000 transfer syntax.


ImGearDICOMPixelRepresenations Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies DICOM Pixel Representations.

Declaration:

public enum ImGearDICOMPixelRepresenations

Values:

Name
Value
Description
COMPLEMENT_2S
Pixels are signed, encoded in 2's complement form.
UNKNOWN
Unknown
UNSIGNED
Pixels are unsigned


ImGearDICOMPlanarConfigurations Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies DICOM Planar Configurations.

Declaration:

public enum ImGearDICOMPlanarConfigurations

Values:

Name
Value
Description
PIXEL_BY_PIXEL
Pixel by pixel (interleaved by color channel)
PLANE_BY_PLANE
Plane by plane (not interleaved by color channel)


ImGearDICOMServiceObjectPairs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies DICOM Service Object Pair (SOP) constants.

Declaration:

public enum ImGearDICOMServiceObjectPairs

Values:

Name
Value
Description
AMBULATORY_ECG_WAVEFORM_STORAGE
Ambulatory ECG Waveform Storage
BASIC_ANNOTATION_BOX
Basic Annotation Box
BASIC_COLOR_IMG_BOX
Basic color img box
BASIC_COLOR_PRINT_MGMT_META
Basic color print management meta
BASIC_FILM_BOX
Basic film box
BASIC_FILM_SESSION
Basic film session
BASIC_GRAY_IMG_BOX
Basic gray image box
BASIC_GRAY_PRINT_MGMT_META
Basic grayscale print management meta
BASIC_PRINT_IMAGE_OVERLAY_BOX
Basic print image overlay box (Retired)
BASIC_STUDY_CONTENT_NOTIFICATION
Basic study content notification (Retired)
BASIC_VOICE_AUDIO_WAVEFORM_STORAGE
Basic voice audio waveform storage
BLENDING_SOFTCOPY_PRES_STATE_STORAGE
Blending Softcopy Presentation State Storage
BREAST_IMAGING_RELEVANT_PATIENT_INFORMATION_QUERY
Breast Imaging Relevant Patient Information Query
CARDIAC_ELECTROPHYSIOLOGY_WAVEFORM_STORAGE
Cardiac electrophysiology waveform storage
CARDIAC_RELEVANT_PATIENT_INFORMATION_QUERY
Cardiac Relevant Patient Information Query
COLOR_SOFTCOPY_PRES_STATE_STORAGE
Color Softcopy Pres State Storage
CR_STORAGE
Computed Radiography Image Storage
CT_ENHANCED_STORAGE
Enhanced CT Image Storage
CT_STORAGE
CT Image storage
CURVE_STORAGE
Standalone Curve Storage (Retired)
DEFORMABLE_SPATIAL_REGISTRATION_STORAGE
Deformable Spatial Registration Storage
DICOM_APP_CONTEXT
DICOM Application Context Name
DICOM_CONTROLLED_TERMINOLOGY
DICOM Controlled Terminology Coding Scheme
DICOM_UID_REGISTRY
DICOM UID Registry (UIDs as a Coding Scheme)
DIGI_INTRA_ORAL_PRES_IMG_STORAGE
Digital intra oral presentation image storage - for presentation
DIGI_INTRA_ORAL_PROC_IMG_STORAGE
Digital intra oral processing image storage - for processing
DIGI_MAMMO_PRES_IMG_STORAGE
Digital mammo presentation image storage - for presentation
DIGI_MAMMO_PROC_IMG_STORAGE
Digital mammo processing image storage - for processing
DIGI_XRAY_PRES_IMG_STORAGE
Digital X-ray presentation image storage - for presentation
DIGI_XRAY_PROC_IMG_STORAGE
Digital X-ray processing image storage - for processing
ENCAPSULATED_CDA_STORAGE
SOP Encapsulated CDA Storage
ENCAPSULATED_PDF_STORAGE
SOP Encapsulated PDF Storage
ENHANCED_XRF_IMAGE_STORAGE
Enhanced XRF Image Storage
GE_MACHINE_STORAGE
GE machine storage
GE_PLAN_STORAGE
GE plan storage
GEN_PERFORMED_PROC_STEP
General purpose performed procedure step
GEN_SCHEDULED_PROC_STEP
General purpose scheduled procedure step
GEN_WORKLIST_FIND
General purpose worklist information model - find
GEN_WORKLIST_MANAGEMENT_META
General purpose worklist management meta
GENERAL_RELEVANT_PATIENT_INFORMATION_QUERY
General Relevant Patient Information Query
GRAY_SOFTCOPY_PRES_STATE_STORAGE
Gray softcopy presentation state storage
HANGING_PROTOCOL_INFORMATION_MODEL_FIND
Hanging Protocol Information Model - FIND
HANGING_PROTOCOL_INFORMATION_MODEL_MOVE
Hanging Protocol Information Model - MOVE
HANGING_PROTOCOL_STORAGE
Hanging Protocol Storage
HARDCOPY_COLOR_STORAGE
Hardcopy color storage (Retired)
HARDCOPY_GRAYSCALE_STORAGE
Hardcopy grayscale storage (Retired)
IMG_OVLY_BOX
Image Overlay box (Retired)
INSTANCE_AVAILABILITY_NOTIFICATION
Instance Availability Notification
INTERP_MGMT_DET
Interp Management detached
KEY_OBJECT_SELECTION_DOCUMENT
Key object selection document storage
MEDIA_CREATION_MANAGEMENT_UID
Media Creation Management UID
MEDIA_STORAGE_DIR_STORAGE
Media storage directory storage
MOD_LUT_STORAGE
Standalone Modality LUT storage (Retired)
MOD_PERF_PROC_STEP
Modality Performed Procedure step (Retired)
MOD_PERF_PROC_STEP_NOTIFY
Modality Performed Procedure Step notification
MOD_PERF_PROC_STEP_RETRIEVE
Modality Performed Procedure Step retrieve
MODALITY_WORKLIST_FIND
Modality worklist information model - find
MR_ENHANCED_IMAGE_STORAGE
MR enhanced image storage
MR_SPECTROSCOPY_STORAGE
MR spectroscopy storage
MR_STORAGE
MR storage
MSICOM3_LZW_STORAGE
Msicom3 LZW storage
NM_STORAGE
Nuclear Medicine Image storage
NM_STORAGE__RET
Nuclear Medicine Image storage (Retired)
NULL
Null
OPHTHALMIC_PHOTOGRAPHY_16_BIT_IMAGE_STORAGE
Ophthalmic Photography 16 Bit Image Storage
OPHTHALMIC_PHOTOGRAPHY_8_BIT_IMAGE_STORAGE
Ophthalmic Photography 8 Bit Image Storage
OPHTHALMIC_TOMOGRAPHY_IMAGE_STORAGE
Ophthalmic Tomography Image Storage
OVERLAY_STORAGE
Standalone Overlay storage (Retired)
PAT_MGMT_DET
Detached Patient Management (Retired)
PAT_MGMT_META
Detached Patient Management MetaClass (Retired)
PAT_ROOT_QR_FIND
Patient root Q/R find
PAT_ROOT_QR_GET
Patient root Q/R get
PAT_ROOT_QR_MOVE
Patient root Q/R move
PAT_STUDY_ROOT_QR_FIND
Patient study root Q/R find
PAT_STUDY_ROOT_QR_GET
Patient study root Q/R get
PAT_STUDY_ROOT_QR_MOVE
Patient study root Q/R move
PET_CURVE_STORAGE
Positron Emission Tomography curve storage (Retired)
PET_STORAGE
Positron Emission Tomography storage
PRESENTATION_LUT
Presentation LUT
PRINT_JOB
Print job
PRINT_QUEUE_INSTANCE
Print queue instance (Retired)
PRINT_QUEUE_MGMT
Print queue management (Retired)
PRINTER
Printer
PRINTER_CONFIGURATION_RETRIEVAL
Printer configuration retrieval class
PRINTER_CONFIGURATION_RETRIEVAL_INSTANCE
Printer configuration retrieval instance
PRINTER_INSTANCE
Printer instance
PROCEDURAL_EVENT_LOGGING
Procedural Event Logging Class
PROCEDURAL_EVENT_LOGGING_INSTANCE
Procedural Event Logging Instance
PROCEDURE_LOG
Procedure Log Storage
PRODUCT_CHARACTERISTICS
Product Characteristics
PSEUDO_COLOR_SOFTCOPY_PRES_STATE_STORAGE
Pseudo-Color Softcopy Presentation State Storage
PULL_PRINT_REQUEST
Pull print request (Retired)
PULL_STORED_PRINT_MGMT_META
Pull stored print Management meta (Retired)
RAW_DATA_STORAGE
RAW data storage
REAL_WORLD_VALUE_MAPPING_STORAGE
Real World Value Mapping Storage
REF_COLOR_PRINT_MGMT_META
Referenced Color Print Management Meta SOP Class
REF_GRAY_PRINT_MGMT_META
Referenced Grayscale Print Management Meta Class(Retired)
REF_IMG_BOX
Referenced image box (Retired)
RESULT_MGMT_DET
Detached Results Management Class (Retired)
RESULT_MGMT_META
Result Management meta
RT_BEAMS_DELIVERY_INSTRUCTION_STORAGE
RT Beams Delivery Instruction Storage (Supplement 74 Frozen Draft)
RT_BEAMS_TREATMENT_RECORD_STORAGE
RT Beams treatment record storage
RT_BRACHY_TREATMENT_RECORD_STORAGE
RT brachy treatment record storage
RT_CONVENTIONAL_MACHINE_VERIFICATION
RT Conventional Machine Verification (Supplement 74 Frozen Draft)
RT_DOSE_STORAGE
RT dose storage
RT_IMG_STORAGE
RT image storage
RT_ION_BEAMS_TREATMENT_RECORD_STORAGE
RT Ion Beams Treatment Record Storage
RT_ION_MACHINE_VERIFICATION
RT Ion Machine Verification (Supplement 74 Frozen Draft)
RT_ION_PLAN_STORAGE
RT Ion Plan Storage
RT_PLAN_STORAGE
RT plan storage
RT_STRUCTURE_SET_STORAGE
RT structure set storage
RT_TREATMENT_RECORD_STORAGE
RT treatment record storage
RT_TREATMENT_SUMMARY_RECORD_STORAGE
RT treatment summary record storage
SC_MF_GRAYSCALE_BYTE_IMAGE_STORAGE
Secondary Capture Multi-frame grayscale byte image storage
SC_MF_GRAYSCALE_WORD_IMAGE_STORAGE
Secondary Capture Multi-frame grayscale word image storage
SC_MF_SINGLE_BIT_IMAGE_STORAGE
Secondary Capture Multi-frame single bit image storage
SC_MF_TRUE_COLOR_IMAGE_STORAGE
Secondary Capture Multi-frame true color image storage
SC_STORAGE
Secondary Capture storage
SEGMENTATION_STORAGE
Segmentation Storage
SPATIAL_FIDUCIALS_STORAGE
Spatial Fiducials Storage
SPATIAL_REGISTRATION_STORAGE
Spatial Registration Storage
SR_AUDIO_STORAGE
Audio SR Storage - Trial (Retired)
SR_BASIC_TEXT
Basic Text SR Storage
SR_CHEST_CAD
Chest CADSR Storage
SR_COMPREHENSIVE
Comprehensive SR Storage
SR_COMPREHENSIVE_STORAGE
Comprehensive SR Storage - Trial (Retired)
SR_DETAIL_STORAGE
Detail SR Storage - Trial (Retired)
SR_ENHANCED
Enhanced SR Storage
SR_MAMMO_CAD
Mammography CADSR Storage
SR_TEXT_STORAGE
Text SR Storage - Trial (Retired)
STEREOMETRIC_RELATIONSHIP_STORAGE
Stereometric Relationship Storage
STORAGE_COMMITMENT_PULL_CLASS
Storage commitment pull model (Retired)
STORAGE_COMMITMENT_PULL_INSTANCE
Storage commitment pull model instance (Retired)
STORAGE_COMMITMENT_PUSH_CLASS
Storage commitment push model
STORAGE_COMMITMENT_PUSH_INSTANCE
Storage commitment push model instance
STORAGE_SERVICE_CLASS
Storage Service Class
STORED_PRINT_STORAGE
Stored print storage (Retired)
STUDY_MGMT_COMP
Study Component Management (Retired)
STUDY_MGMT_DET
Detached Study Management (Retired)
STUDY_MGMT_META
Study Management meta
STUDY_ROOT_QR_FIND
Study root Q/R find
STUDY_ROOT_QR_GET
Study root Q/R get
STUDY_ROOT_QR_MOVE
Study root Q/R move
SUBSTANCE_ADMINISTRATION_LOGGING
Substance Administration Logging Class
SUBSTANCE_ADMINISTRATION_LOGGING_INSTANCE
Substance Administration Logging Instance
SUBSTANCE_APPROVAL_QUERY
Substance Approval Query
UNIFIED_PROC_STEP_EVENT
Unified Procedure Step - Event SOP Class
UNIFIED_PROC_STEP_PULL
Unified Procedure Step - Pull SOP Class
UNIFIED_PROC_STEP_PUSH
Unified Procedure Step - Push SOP Class
UNIFIED_PROC_STEP_WATCH
Unified Procedure Step - Watch SOP Class
UNIFIED_WORKLIST_PROC_STEP_INSTANCE
Unified Worklist and Procedure Step SOP Instance
UNIFIED_WORKLIST_PROC_STEP_SERVICE_CLASS
Unified Worklist and Procedure Step Service Class
US_STORAGE
Ultrasound image storage
US_STORAGE__RET
Ultrasound image storage (Retired)
USMF_STORAGE
Ultrasound Multi-frame image storage
USMF_STORAGE__RET
Ultrasound Multi-frame image storage (Retired)
VERIFICATION
Verification
VIDEO_ENDOSCOPIC_IMAGE_STORAGE
Video Endoscopic Image Storage
VIDEO_MICROSCOPIC_IMAGE_STORAGE
VL Microscopic Image Storage
VIDEO_PHOTOGRAPHIC_IMAGE_STORAGE
Video Photographic Image Storage
VISIT_MGMT_DET
Detached Visit Management (Retired)
VL_ENDO_IMG_STORAGE
VL endo image storage
VL_IMG_STORAGE
VL Image Storage - Trial (Retired)
VL_MICRO_IMG_STORAGE
VL micro image storage
VL_MULTIFRAME_IMG_STORAGE
VL Multi-frame Image Storage - Trial (Retired)
VL_PHOTO_IMG_STORAGE
VL photo image storage
VL_SLIDE_MICRO_IMG_STORAGE
VL slide-coordinates microscopic image storage
VOI_LUT_BOX
VOI LUT box
VOI_LUT_STORAGE
Standalone VOI LUT storage (Retired)
WAVEFORM_12_LEAD_ECG_STORAGE
Waveform 12 lead ECG storage
WAVEFORM_AUDIO_STORAGE
Waveform audio storage
WAVEFORM_ECG_STORAGE
Waveform ECG storage
WAVEFORM_GEN_ECG_STORAGE
Waveform general ECG audio storage
WAVEFORM_HEMO_STORAGE
Waveform Hemodynamic storage
WAVEFORM_STORAGE
Waveform storage - trial (retired)
XRAY_3D_ANGIOGRAPHIC_STORAGE
X-Ray 3D Angiographic Image Storage
XRAY_3D_CRANIOFACIAL_STORAGE
X-Ray 3D Craniofacial Image Storage
XRAY_ANGIO_BI_PLANE_STORAGE
X-Ray Angiographic Bi-Plane Image storage (Retired)
XRAY_ANGIO_STORAGE
X-Ray Angiographic Image storage
XRAY_ENHANCED_XA_IMAGE_STORAGE
Enhanced XA Image Storage
XRAY_RADIATION_DOSE_SR_STORAGE
X-Ray Radiation Dose SR Storage
XRAY_RF_STORAGE
X-Ray Radiofluoroscopic Image storage


ImGearDICOMTagsIDs Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies DICOM tag identifiers.

This enumeration currently includes more than 1800 DICOM tags, so they are not listed in this manual. The table below lists some of the most frequently used tags. For the rest of DICOM tags please see Digital Imaging and Communications in Medicine (DICOM) Part 6: Data Dictionary.

Declaration:

public enum ImGearDICOMTagsIDs

Values:

Name
Value
Description
TransferSyntaxUID
(0002, 0010) Transfer Syntax UID of the DICOM file. This tells whether the DICOM file uses big or little endian format, which compression is used, if any, and whether the file uses Implicit or Explicit Value Representation syntax.
Rows
(0028, 0010) Height of the DICOM image
Columns
(0028, 0011) Width of the DICOM image
PixelData
(7fe0, 0010) Pixel Data of the DICOM image


ImGearDICOMTransferSyntaxes Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies DICOM Transfer Syntaxes.

Declaration:

public enum ImGearDICOMTransferSyntaxes

Values:

Name
Value
Description
AUTODETECT
Autodetect. This value is used with DICOM LoadSyntax format option, to allow automatic detection of transfer syntax.
DEFAULT
DICOM default transfer syntax: Implicit VR Little Endian.
DEFLATED_EXPLICIT_VR_LE
Deflated Explicit VR Little Endian
EXPLICIT_VR_BE
Explicit VR Big Endian (uncompressed)
EXPLICIT_VR_LE
Explicit VR Little Endian (uncompressed)
IMPLICIT_VR_LE
Implicit VR Little Endian (uncompressed)
JPEG_2000_PART_2_MULTI_COMPONENT_IMAGE_COMPRESSION
JPEG-2K Multi Component Image Compression
JPEG_2000_PART_2_MULTI_COMPONENT_IMAGE_COMPRESSION_Lossless_Only
JPEG-2K Multi Component Lossless Only Compression
JPEG_2K
JPEG 2000 compression
JPEG_2K_LOSSLESS_ONLY
JPEG 2000 compression (Lossless Only)
JPEG_BASELINE_PR_1
JPEG Baseline (Process 1): Default Transfer Syntax for Lossy JPEG 8 Bit Image Compression
JPEG_EXTENDED_HIER_PR_16_18
JPEG Extended, Hierarchical (Process 16 & 18) (Retired)
JPEG_EXTENDED_HIER_PR_17_19
JPEG Extended, Hierarchical (Process 17 & 19) (Retired)
JPEG_EXTENDED_PR_2_4
JPEG Extended (Process 2 & 4): Default Transfer Syntax for Lossy JPEG 12 Bit Image Compression (Process 4 only)
JPEG_EXTENDED_PR_3_5
JPEG Extended (Process 3 & 5) (Retired)
JPEG_FULL_PROG_HIER_PR_24_26
JPEG Full Progression, Hierarchical (Process 24 & 26) (Retired)
JPEG_FULL_PROG_HIER_PR_25_27
JPEG Full Progression, Hierarchical (Process 25 & 27) (Retired)
JPEG_FULL_PROG_NONH_PR_10_12
JPEG Full Progression, Non-Hierarchical (Process 10 & 12) (Retired)
JPEG_FULL_PROG_NONH_PR_11_13
JPEG Full Progression, Non-Hierarchical (Process 11 & 13) (Retired)
JPEG_LOSSLESS
JPEG Lossless, Non-Hierarchical (Process 14)
JPEG_LOSSLESS_HIER_PR_28
JPEG Lossless, Hierarchical (Process 28) (Retired)
JPEG_LOSSLESS_HIER_PR_29
JPEG Lossless, Hierarchical (Process 29) (Retired)
JPEG_LOSSLESS_NONH_FIRSTORDER_PR_14
JPEG Lossless, Non-Hierarchical, First-Order Prediction (Process 14 [Selection Value 1]): Default Transfer Syntax for Lossless JPEG Image Compression
JPEG_LOSSLESS_NONH_PR_14
JPEG Lossless, Non-Hierarchical (Process 14)
JPEG_LOSSLESS_NONH_PR_15
JPEG Lossless, Non-Hierarchical (Process 15) (Retired)
JPEG_LOSSY
JPEG Baseline (Process 1): Default Transfer Syntax for Lossy JPEG 8 Bit Image Compression
JPEG_LS_LOSSLESS
JPEG-LS Lossless Image Compression
JPEG_LS_LOSSY
JPEG-LS Lossy (Near-Lossless) Image Compression
JPEG_SPECTRAL_HIER_PR_20_22
JPEG Spectral Selection, Hierarchical (Process 20 & 22) (Retired)
JPEG_SPECTRAL_HIER_PR_21_23
JPEG Spectral Selection, Hierarchical (Process 21 & 23) (Retired)
JPEG_SPECTRAL_NONH_PR_6_8
JPEG Spectral Selection, Non-Hierarchical (Process 6 & 8) (Retired)
JPEG_SPECTRAL_NONH_PR_7_9
JPEG Spectral Selection, Non-Hierarchical (Process 7 & 9) (Retired)
JPIP_REFERENCED
JPIP Referenced Compression
JPIP_REFERENCED_DEFLATE
JPIP Referenced Deflate Compression
MPEG2_MAIN_PROFILE
MPEG2 Main Profile
PART_10
Autodetect. This value is used with DICOM LoadSyntax format option, to allow detection of DICOM Part10 compliant images.
RFC_2557_MIME_ENCAPSULATION
RFC 2557 MIME encapsulation
RLE
RLE Image Compression
UNKNOWN
Unknown
XML
XML Encoding


ImGearDICOMValueRepresentations Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies DICOM Value Representations. Value Representation specifies type and format of the value(s) contained in data element.

Declaration:

public enum ImGearDICOMValueRepresentations

Values:

Name
Value
Description
AgeString
Age String
ApplicationEntity
Application Entity
AttributeTag
Attribute Tag
CodeString
Code String
Date
Date
DateTime
Date Time
DecimalString
Decimal String
FloatingPointDouble
Floating Double Point
FloatingPointSingle
Floating Single Point
IntegerString
Integer String
LongString
Long String
LongText
Long Text
None
None
OtherByteString
Other Byte String
OtherFloatString
Other Float String
OtherWordString
Other Word String
PersonName
Person Name
SequenceOfItems
Sequence of Items
ShortString
Short String
ShortText
Short Text
SignedLong
Signed Long
SignedShort
Signed Short
Time
Time
UniqueIdentifier
Unique Identifier
Unknown
Unknown
UnlimitedText
Unlimited Text
UnsignedLong
Unsigned Long
UnsignedShort
Unsigned Short


ImGearPseudocolorSchemes Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies predefined pseudocolor schemes.

Declaration:

public enum ImGearPseudocolorSchemes

Values:

Name
Value
Description
BrightRainbow
Bright rainbow color scheme
DarkBlueToBightRed
From DarkBlue to BrightRed color scheme
Default
Default color scheme
GreenToRed
GreenToRed color scheme
OilFilm
OilFilm color scheme
RedGreenBlue
RGB color scheme
Thermal
Thermal color scheme


ImageGear.Formats.EXIF Namespace

ImageGear.Formats.EXIF Namespace

32-bit
64-bit
CF
P
P
P

Description:

This namespace provides the API for operating with EXIF non-image data.

Declaration:

namespace ImageGear.Formats.EXIF

Members:

Classes:
Name
Description
ImGearEXIFGPSMetadata Class
Provides simplified access to EXIF GPS metadata.
ImGearEXIFInteropMetadata Class
Provides simplified access to EXIF Interoperability metadata.
ImGearEXIFMetadata Class
Provides simplified access to EXIF metadata.

:

Enumerations:
Name
Description
ImGearEXIFColorSpace Enumeration
Represents EXIF Color Spaces.
ImGearEXIFContrastMode Enumeration
Represents EXIF Contrast Modes.
ImGearEXIFCustomRendered Enumeration
Represents EXIF Custom Rendered modes.
ImGearEXIFExposureMode Enumeration
Represents EXIF Exposure Modes.
ImGearEXIFExposureProgram Enumeration
Represents EXIF Exposure Programs.
ImGearEXIFFileSource Enumeration
Represents EXIF File Sources.
ImGearEXIFFlashMode Enumeration
Represents EXIF Flash mode.
ImGearEXIFFlashReturn Enumeration
Represents EXIF Flash return.
ImGearEXIFGainControl Enumeration
Represents EXIF Gain Controls.
ImGearEXIFGPSAltitudeReference Enumeration
Represents EXIF GPS Altitude References.
ImGearEXIFGPSDifferential Enumeration
Represents EXIF GPS Differentials.
ImGearEXIFGPSDirectionReference Enumeration
Represents EXIF GPS Direction References.
ImGearEXIFGPSDistanceReference Enumeration
Represents EXIF GPS Distance References.
ImGearEXIFGPSLatitudeReference Enumeration
Represents EXIF GPS Latitude References.
ImGearEXIFGPSLongitudeReference Enumeration
Represents EXIF GPS Longitude References.
ImGearEXIFGPSMeasureMode Enumeration
Represents EXIF GPS Measure Modes.
ImGearEXIFGPSSpeedReference Enumeration
Represents EXIF GPS Speed Reference Modes.
ImGearEXIFGPSStatus Enumeration
Represents EXIF GPS Statuses.
ImGearEXIFLightSource Enumeration
Represents EXIF Light Sources.
ImGearEXIFMeteringMode Enumeration
Represents EXIF Metering Modes.
ImGearEXIFSaturationMode Enumeration
Represents EXIF Saturation Modes.
ImGearEXIFSceneCaptureType Enumeration
Represents EXIF scene capture types.
ImGearEXIFSceneType Enumeration
Represents EXIF Scene Types.
ImGearEXIFSensingMethod Enumeration
Represents EXIF Sensing Methods.
ImGearEXIFSharpnessMode Enumeration
Represents EXIF Sharpness Modes.
ImGearEXIFSubjectDistanceRange Enumeration
Represents EXIF Subject Distance Ranges.
ImGearEXIFWhiteBalanceMode Enumeration
Represents EXIF White Balance Modes.


ImageGear.Formats Namespace Classes

The ImageGear.Formats.EXIF Namespace has the following class members:

Classes:
Name
Description
ImGearEXIFGPSMetadata Class
Provides simplified access to EXIF GPS metadata.
ImGearEXIFInteropMetadata Class
Provides simplified access to EXIF Interoperability metadata.
ImGearEXIFMetadata Class
Provides simplified access to EXIF metadata.


ImGearEXIFGPSMetadata Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides simplified access to EXIF GPS metadata.

Declaration:

public class ImGearEXIFGPSMetadata : ImageGear.Formats.ImGearFormatMetadata

Members:

Constructors
Name
Description
ImGearEXIFGPSMetadata Constructor
Creates and initializes an instance of ImGearEXIFGPSMetadata Class.

Properties
Name
Description
Altitude Property
Accesses Altitude Tag.
AltitudeReference Property
Accesses AltitudeReference Tag.
AreaInformation Property
Accesses AreaInformation Tag.
DateStamp Property
Accesses DateStamp Tag.
DestBearing Property
Accesses DestBearing Tag.
DestBearingReference Property
Accesses DestBearingReference Tag.
DestDistance Property
Accesses DestDistance Tag.
DestDistanceReference Property
Accesses DestDistanceReference Tag.
DestLatitude Property
Accesses DestLatitude Tag.
DestLatitudeReference Property
Accesses DestLatitudeReference Tag.
DestLongitude Property
Accesses DestLongitude Tag.
DestLongitudeReference Property
Accesses DestLongitudeReference Tag.
Differential Property
Accesses Differential Tag.
DOP Property
Accesses DOP Tag.
ImgDirection Property
Accesses ImgDirection Tag.
ImgDirectionReference Property
Accesses ImgDirectionReference Tag.
Latitude Property
Accesses Latitude Tag.
LatitudeReference Property
Accesses LatitudeReference Tag.
Longitude Property
Accesses Longitude Tag.
LongitudeReference Property
Accesses LongitudeReference Tag.
MapDatum Property
Accesses MapDatum Tag.
MeasureMode Property
Accesses MeasureMode Tag.
ProcessingMethod Property
Accesses ProcessingMethod Tag.
Satellites Property
Accesses Satellites Tag.
Speed Property
Accesses Speed Tag.
SpeedReference Property
Accesses SpeedReference Tag.
Status Property
Accesses Status Tag.
TimeStamp Property
Accesses TimeStamp Tag.
Track Property
Accesses Track Tag.
TrackReference Property
Accesses TrackReference Tag.
VersionID Property
Accesses VersionID Tag.


ImGearEXIFGPSMetadata Constructors

The ImGearEXIFGPSMetadata Class of the ImageGear.Formats.EXIF Namespace has the following constructors:

Constructors
Name
Description
ImGearEXIFGPSMetadata Constructor
Creates and initializes an instance of ImGearEXIFGPSMetadata Class.


ImGearEXIFGPSMetadata Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearEXIFGPSMetadata Class.

Declaration:

public ImGearEXIFGPSMetadata()

Return Value:

The new instance of ImGearEXIFGPSMetadata Class.

See Also:

ImGearEXIFGPSMetadata Class


ImGearEXIFGPSMetadata Properties

The ImGearEXIFGPSMetadata Class of the ImageGear.Formats.EXIF Namespace has the following properties:

Properties
Name
Description
Altitude Property
Accesses Altitude Tag.
AltitudeReference Property
Accesses AltitudeReference Tag.
AreaInformation Property
Accesses AreaInformation Tag.
DateStamp Property
Accesses DateStamp Tag.
DestBearing Property
Accesses DestBearing Tag.
DestBearingReference Property
Accesses DestBearingReference Tag.
DestDistance Property
Accesses DestDistance Tag.
DestDistanceReference Property
Accesses DestDistanceReference Tag.
DestLatitude Property
Accesses DestLatitude Tag.
DestLatitudeReference Property
Accesses DestLatitudeReference Tag.
DestLongitude Property
Accesses DestLongitude Tag.
DestLongitudeReference Property
Accesses DestLongitudeReference Tag.
Differential Property
Accesses Differential Tag.
DOP Property
Accesses DOP Tag.
ImgDirection Property
Accesses ImgDirection Tag.
ImgDirectionReference Property
Accesses ImgDirectionReference Tag.
Latitude Property
Accesses Latitude Tag.
LatitudeReference Property
Accesses LatitudeReference Tag.
Longitude Property
Accesses Longitude Tag.
LongitudeReference Property
Accesses LongitudeReference Tag.
MapDatum Property
Accesses MapDatum Tag.
MeasureMode Property
Accesses MeasureMode Tag.
ProcessingMethod Property
Accesses ProcessingMethod Tag.
Satellites Property
Accesses Satellites Tag.
Speed Property
Accesses Speed Tag.
SpeedReference Property
Accesses SpeedReference Tag.
Status Property
Accesses Status Tag.
TimeStamp Property
Accesses TimeStamp Tag.
Track Property
Accesses Track Tag.
TrackReference Property
Accesses TrackReference Tag.
VersionID Property
Accesses VersionID Tag.


Altitude Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSAltitude tag. The tag indicates the altitude based on the reference in AltitudeReference. Altitude is expressed as one RATIONAL value. The reference unit is meters.

Get accessor returns the tag value, if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt? Altitude { set; get; }

Value:

Nullable (boxed) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


AltitudeReference Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSAltitudeRef tag. The tag indicates the altitude used as the reference altitude. If the reference is sea level and the altitude is above sea level, 0 is given. If the altitude is below sea level, a value of 1 is given and the altitude is indicated as an absolute value in the GPSAltitude tag.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree; adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearEXIFGPSAltitudeReference? AltitudeReference { set; get; }

Value:

Nullable (boxed) ImGearEXIFGPSAltitudeReference Enumeration value.

See Also:

ImGearEXIFGPSAltitudeReference Enumeration


AreaInformation Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSAreaInformation tag. The tag specifies a character string recording the name of the GPS area.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public byte[] AreaInformation { set; get; }

Value:

Array of bytes.


DateStamp Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSDateStamp tag. The tag specifies a character string recording date and time information relative to UTC (Coordinated Universal Time). The format is "YYYY:MM:DD."

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public string DateStamp { set; get; }

Value:

String value.


DestBearing Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSDestBearing tag. The tag indicates the bearing to the destination point. The range of values is from 0.00 to 359.99.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt? DestBearing { set; get; }

Value:

Nullable (boxed) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


DestBearingReference Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSDestBearingRef tag. The tag indicates the reference used for giving the bearing to the destination point.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearEXIFGPSDirectionReference? DestBearingReference { set; get;
}

Value:

Nullable (boxed) ImGearEXIFGPSDirectionReference Enumeration value.

See Also:

ImGearEXIFGPSDirectionReference Enumeration


DestDistance Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSDestDistance tag. The tag indicates the distance to the destination point.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt? DestDistance { set; get; }

Value:

Nullable (boxed) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


DestDistanceReference Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSDestDistanceRef tag. The tag indicates the unit used to express the distance to the destination point.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearEXIFGPSDistanceReference? DestDistanceReference { set; get;
}

Value:

Nullable (boxed) ImGearEXIFGPSDistanceReference Enumeration value.

See Also:

ImGearEXIFGPSDistanceReference Enumeration


DestLatitude Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSDestLatitude tag. The tag indicates the latitude of the destination point. The latitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If latitude is expressed as degrees, minutes, and seconds, a typical format would be dd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be dd/1,mmmm/100,0/1.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt[] DestLatitude { set; get; }

Value:

ImGearRationalUInt Structure[] array.

See Also:

ImGearRationalUInt Structure


DestLatitudeReference Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSDestLatitudeRef tag. The tag indicates whether the latitude of the destination point is north or south latitude.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearEXIFGPSLatitudeReference? DestLatitudeReference { set; get;
}

Value:

Nullable (boxed) ImGearEXIFGPSLatitudeReference Enumeration value.

See Also:

ImGearEXIFGPSLatitudeReference Enumeration


DestLongitude Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSDestLongitude tag. The tag indicates the longitude of the destination point. The longitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If longitude is expressed as degrees, minutes, and seconds, a typical format would be ddd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be ddd/1,mmmm/100,0/1.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt[] DestLongitude { set; get; }

Value:

ImGearRationalUInt Structure array.

See Also:

ImGearRationalUInt Structure


DestLongitudeReference Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSDestLongitudeRef tag. The tag indicates whether the longitude of the destination point is east or west longitude.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearEXIFGPSLongitudeReference? DestLongitudeReference { set;
get; }

Value:

Nullable (boxed) ImGearEXIFGPSLongitudeReference Enumeration value.

See Also:

ImGearEXIFGPSLongitudeReference Enumeration


Differential Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSDifferential tag. The tag indicates whether differential correction is applied to the GPS receiver.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearEXIFGPSDifferential? Differential { set; get; }

Value:

Nullable (boxed) ImGearEXIFGPSDifferential Enumeration value.

See Also:

ImGearEXIFGPSDifferential Enumeration


DOP Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSDOP tag. The tag indicates the GPS DOP (data degree of precision). An HDOP value is written during two-dimensional measurement, and PDOP during three-dimensional measurement.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt? DOP { set; get; }

Value:

Nullable (boxed) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


ImgDirection Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSImgDirection tag. The tag indicates the direction of the image when it was captured. The range of values is from 0.00 to 359.99.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

.NET 2.0:

public ImageGear.Core.ImGearRationalUInt? ImgDirection { set; get; }

.NET 2.0:

public ImageGear.Core.ImGearRationalUIntBoxed ImgDirection { set; get; }

Value:

Nullable (boxed) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


ImgDirectionReference Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSImgDirectionRef tag. The tag indicates the reference for giving the direction of the image when it is captured.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearEXIFGPSDirectionReference? ImgDirectionReference { set;
get; }

Value:

Nullable (boxed) ImGearEXIFGPSDirectionReference Enumeration value.

See Also:

ImGearEXIFGPSDirectionReference Enumeration


Latitude Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSLatitude tag. The tag indicates the latitude. The latitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If latitude is expressed as degrees, minutes, and seconds, a typical format would be dd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be dd/1,mmmm/100,0/1.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt[] Latitude { set; get; }

Value:

ImGearRationalUInt Structure[] array.

See Also:

ImGearRationalUInt Structure


LatitudeReference Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSLatitudeRef tag. The tag indicates whether the latitude is north or south latitude.

Declaration:

public ImageGear.Formats.ImGearEXIFGPSLatitudeReference? LatitudeReference { set; get; }

Value:

Nullable (boxed) ImGearEXIFGPSLatitudeReference Enumeration value.

See Also:

ImGearEXIFGPSLatitudeReference Enumeration


Longitude Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSLongitude tag. The tag indicates the longitude. The longitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If longitude is expressed as degrees, minutes, and seconds, a typical format would be ddd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be ddd/1,mmmm/100,0/1.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt[] Longitude { set; get; }

Value:

ImGearRationalUInt Structure array.

See Also:

ImGearRationalUInt Structure


LongitudeReference Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSLongitudeRef tag. The tag indicates whether the longitude is east or west longitude.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearEXIFGPSLongitudeReference? LongitudeReference { set; get; }

Value:

Nullable (boxed) ImGearEXIFGPSLongitudeReference Enumeration value.

See Also:

ImGearEXIFGPSLongitudeReference Enumeration


MapDatum Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSMapDatum tag. The tag indicates the geodetic survey data used by the GPS receiver.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public string MapDatum { set; get; }

Value:

String value.


MeasureMode Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSMeasureMode tag. The tag indicates the GPS measurement mode.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearEXIFGPSMeasureMode? MeasureMode { set; get; }

Value:

Nullable (boxed) ImGearEXIFGPSMeasureMode Enumeration value.

See Also:

ImGearEXIFGPSMeasureMode Enumeration


ProcessingMethod Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSProcessingMethod tag. The tag contains a character string recording the name of the method used for location finding.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public byte[] ProcessingMethod { set; get; }

Value:

Array of bytes.


Satellites Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSSatellites tag. The tag indicates the GPS satellites used for measurements.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public string Satellites { set; get; }

Value:

String value.


Speed Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSSpeed tag. The tag indicates the speed of GPS receiver movement.

Declaration:

public ImageGear.Core.ImGearRationalUInt? Speed { set; get; }

Value:

Nullable (boxed) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


SpeedReference Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSSpeedRef tag. The tag indicates the unit used to express the GPS receiver speed of movement.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearEXIFGPSSpeedReference? SpeedReference { set; get; }

Value:

Nullable (boxed) ImGearEXIFGPSSpeedReference Enumeration value.

See Also:

ImGearEXIFGPSSpeedReference Enumeration


Status Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSStatus tag. The tag indicates the status of the GPS receiver when the image is recorded.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearEXIFGPSStatus? Status { set; get; }

Value:

Nullable (boxed) ImGearEXIFGPSStatus Enumeration value.

See Also:

ImGearEXIFGPSStatus Enumeration


TimeStamp Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSTimeStamp tag. The tag indicates the time as UTC (Coordinated Universal Time). TimeStamp is expressed as three RATIONAL values giving the hour, minute, and second.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt[] TimeStamp { set; get; }

Value:

ImGearRationalUInt Structure array.

See Also:

ImGearRationalUInt Structure


Track Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSTrack tag. The tag indicates the direction of GPS receiver movement. The range of values is from 0.00 to 359.99.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt Track { set; get; }

Value:

ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


TrackReference Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSTrackRef tag. The tag indicates the reference for giving the direction of GPS receiver movement.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearEXIFGPSDirectionReference? TrackReference { set; get; }

Value:

Nullable (boxed) ImGearEXIFGPSDirectionReference Enumeration value.

See Also:

ImGearEXIFGPSDirectionReference Enumeration


VersionID Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPSVersionID tag. The tag indicates the version of GPSInfoIFD.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public byte[] VersionID { set; get; }

Value:

Array of bytes.


ImGearEXIFInteropMetadata Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides simplified access to EXIF Interoperability metadata.

Declaration:

public class ImGearEXIFInteropMetadata : ImageGear.Formats.ImGearFormatMetadata

Members:

Constructors
Name
Description
ImGearEXIFInteropMetadata Constructor
Creates and initializes an instance of ImGearEXIFInteropMetadata Class.

Properties
Name
Description
InteroperabilityIndex Property
Accesses InteroperabilityIndex Tag.
InteroperabilityVersion Property
Accesses InteroperabilityVersion Tag.
RelatedImageFileFormat Property
Accesses RelatedImageFileFormat Tag.
RelatedImageLength Property
Accesses RelatedImageLength Tag.
RelatedImageWidth Property
Accesses RelatedImageWidth Tag.


ImGearEXIFInteropMetadata Constructors

The ImGearEXIFInteropMetadata Class of the ImageGear.Formats.EXIF Namespace has the following constructors:

Constructors
Name
Description
ImGearEXIFInteropMetadata Constructor
Creates and initializes an instance of ImGearEXIFInteropMetadata Class.


ImGearEXIFInteropMetadata Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearEXIFInteropMetadata Class.

Declaration:

public ImGearEXIFInteropMetadata()

Return Value:

The new instance of ImGearEXIFInteropMetadata Class.

See Also:

ImGearEXIFInteropMetadata Class


ImGearEXIFInteropMetadata Properties

The ImGearEXIFInteropMetadata Class of the ImageGear.Formats.EXIF Namespace has the following properties:

Properties
Name
Description
InteroperabilityIndex Property
Accesses InteroperabilityIndex Tag.
InteroperabilityVersion Property
Accesses InteroperabilityVersion Tag.
RelatedImageFileFormat Property
Accesses RelatedImageFileFormat Tag.
RelatedImageLength Property
Accesses RelatedImageLength Tag.
RelatedImageWidth Property
Accesses RelatedImageWidth Tag.


InteroperabilityIndex Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the InteroperabilityIndex tag. The tag indicates the identification of the Interoperability rule.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public string InteroperabilityIndex { set; get; }

Value:

String value.


InteroperabilityVersion Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the InteroperabilityVersion tag.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public byte[] InteroperabilityVersion { set; get; }

Value:

Array of bytes.


RelatedImageFileFormat Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the RelatedImageFileFormat tag.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public string RelatedImageFileFormat { set; get; }

Value:

String value.


RelatedImageLength Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the RelatedImageLength tag.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ushort? RelatedImageLength { set; get; }

Value:

Nullable (boxed) ushort value.


RelatedImageWidth Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the RelatedImageWidth tag.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ushort? RelatedImageWidth { set; get; }

Value:

Nullable (boxed) ushort value.


ImGearEXIFMetadata Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides simplified access to EXIF metadata.

Declaration:

public class ImGearEXIFMetadata : ImageGear.Formats.ImGearFormatMetadata

Members:

Constructors
Name
Description
ImGearEXIFMetadata Constructor
Creates and initializes an instance of ImGearEXIFMetadata Class.

Properties
Name
Description
ApertureValue Property
Accesses ApertureValue Tag.
Artist Property
Accesses Artist Tag.
BitsPerSample Property
Accesses BitsPerSample Tag.
BrightnessValue Property
Accesses BrightnessValue Tag.
CFAPattern Property
Accesses CFAPattern Tag.
ColorSpace Property
Accesses ColorSpace Tag.
ComponentsConfiguration Property
Accesses ComponentsConfiguration Tag.
CompressedBitsPerPixel Property
Accesses CompressedBitsPerPixel Tag.
Compression Property
Accesses Compression Tag.
Contrast Property
Accesses Contrast Tag.
Copyright Property
Accesses Copyright Tag.
CustomRendered Property
Accesses CustomRendered Tag.
DateTime Property
Accesses DateTime Tag.
DateTimeDigitized Property
Accesses DateTimeDigitized Tag.
DateTimeOriginal Property
Accesses DateTimeOriginal Tag.
DeviceSettingDescription Property
Accesses DeviceSettingDescription Tag.
DigitalZoomRatio Property
Accesses DigitalZoomRatio Tag.
ExifVersion Property
Accesses ExifVersion Tag.
ExposureBiasValue Property
Accesses ExposureBiasValue Tag.
ExposureIndex Property
Accesses ExposureIndex Tag.
ExposureMode Property
Accesses ExposureMode Tag.
ExposureProgram Property
Accesses ExposureProgram Tag.
ExposureTime Property
Accesses ExposureTime Tag.
FileSource Property
Accesses FileSource Tag.
Flash Property
Accesses Flash Tag.
FlashEnergy Property
Accesses FlashEnergy Tag.
FlashPixVersion Property
Accesses FlashPixVersion Tag.
FNumber Property
Accesses FNumber Tag.
FocalLength Property
Accesses FocalLength Tag.
FocalLengthIn35mmFilm Property
Accesses FocalLengthIn35mmFilm Tag.
FocalPlaneResolutionUnit Property
Accesses FocalPlaneResolutionUnit Tag.
FocalPlaneXResolution Property
Accesses FocalPlaneXResolution Tag.
FocalPlaneYResolution Property
Accesses FocalPlaneYResolution Tag.
GainControl Property
Accesses GainControl Tag.
GPS Property
Accesses GPS Tag.
ImageDescription Property
Accesses ImageDescription Tag.
ImageLength Property
Accesses ImageLength Tag.
ImageWidth Property
Accesses ImageWidth Tag.
InterColorProfile Property
Accesses InterColorProfile Tag.
Interoperability Property
Accesses Interoperability Tag.
ISOSpeedRatings Property
Accesses ISOSpeedRatings Tag.
JPEGInterchangeFormat Property
Accesses JPEGInterchangeFormat Tag.
JPEGInterchangeFormatLngth Property
Accesses JPEGInterchangeFormatLngth Tag.
LightSource Property
Accesses LightSource Tag.
Make Property
Accesses Make Tag.
MaxApertureValue Property
Accesses MaxApertureValue Tag.
MeteringMode Property
Accesses MeteringMode Tag.
Model Property
Accesses Model Tag.
OECF Property
Accesses OECF Tag.
Orientation Property
Accesses Orientation Tag.
PhotometricInterpretation Property
Accesses PhotometricInterpretation Tag.
PixelXDimension Property
Accesses PixelXDimension Tag.
PixelYDimension Property
Accesses PixelYDimension Tag.
PlanarConfig Property
Accesses PlanarConfig Tag.
PrimaryChromaticities Property
Accesses PrimaryChromaticities Tag.
ReferenceBlackWhite Property
Accesses ReferenceBlackWhite Tag.
RelatedSoundFile Property
Accesses RelatedSoundFile Tag.
ResolutionUnit Property
Accesses ResolutionUnit Tag.
RowsPerStrip Property
Accesses RowsPerStrip Tag.
SamplesPerPixel Property
Accesses SamplesPerPixel Tag.
Saturation Property
Accesses Saturation Tag.
SceneCaptureType Property
Accesses SceneCaptureType Tag.
SceneType Property
Accesses SceneType Tag.
SensingMethod Property
Accesses SensingMethod Tag.
Sharpness Property
Accesses Sharpness Tag.
ShutterSpeedValue Property
Accesses ShutterSpeedValue Tag.
Software Property
Accesses Software Tag.
SpatialFrequencyResponse Property
Accesses SpatialFrequencyResponse Tag.
SpectralSensitivity Property
Accesses SpectralSensitivity Tag.
StripByteCounts Property
Accesses StripByteCounts Tag.
StripOffsets Property
Accesses StripOffsets Tag.
SubjectArea Property
Accesses SubjectArea Tag.
SubjectDistance Property
Accesses SubjectDistance Tag.
SubjectDistanceRange Property
Accesses SubjectDistanceRange Tag.
SubjectLocation Property
Accesses SubjectLocation Tag.
SubSecTime Property
Accesses SubSecTime Tag.
SubSecTimeDigitized Property
Accesses SubSecTimeDigitized Tag.
SubSecTimeOriginal Property
Accesses SubSecTimeOriginal Tag.
TransferFunction Property
Accesses TransferFunction Tag.
UserComment Property
Accesses UserComment Tag.
WhiteBalance Property
Accesses WhiteBalance Tag.
WhitePoint Property
Accesses WhitePoint Tag.
XResolution Property
Accesses XResolution Tag.
YCbCrCoefficients Property
Accesses YCbCrCoefficients Tag.
YCbCrPositioning Property
Accesses YCbCrPositioning Tag.
YCbCrSubSampling Property
Accesses YCbCrSubSampling Tag.
YResolution Property
Accesses YResolution Tag.


ImGearEXIFMetadata Constructors

The ImGearEXIFMetadata Class of the ImageGear.Formats.EXIF Namespace has the following constructors:

Constructors
Name
Description
ImGearEXIFMetadata Constructor
Creates and initializes an instance of ImGearEXIFMetadata Class.


ImGearEXIFMetadata Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearEXIFMetadata Class.

Declaration:

public ImGearEXIFMetadata()

Return Value:

The new instance of ImGearEXIFMetadata Class.

See Also:

ImGearEXIFMetadata Class


ImGearEXIFMetadata Properties

The ImGearEXIFMetadata Class of the ImageGear.Formats.EXIF Namespace has the following properties:

Properties
Name
Description
ApertureValue Property
Accesses ApertureValue Tag.
Artist Property
Accesses Artist Tag.
BitsPerSample Property
Accesses BitsPerSample Tag.
BrightnessValue Property
Accesses BrightnessValue Tag.
CFAPattern Property
Accesses CFAPattern Tag.
ColorSpace Property
Accesses ColorSpace Tag.
ComponentsConfiguration Property
Accesses ComponentsConfiguration Tag.
CompressedBitsPerPixel Property
Accesses CompressedBitsPerPixel Tag.
Compression Property
Accesses Compression Tag.
Contrast Property
Accesses Contrast Tag.
Copyright Property
Accesses Copyright Tag.
CustomRendered Property
Accesses CustomRendered Tag.
DateTime Property
Accesses DateTime Tag.
DateTimeDigitized Property
Accesses DateTimeDigitized Tag.
DateTimeOriginal Property
Accesses DateTimeOriginal Tag.
DeviceSettingDescription Property
Accesses DeviceSettingDescription Tag.
DigitalZoomRatio Property
Accesses DigitalZoomRatio Tag.
ExifVersion Property
Accesses ExifVersion Tag.
ExposureBiasValue Property
Accesses ExposureBiasValue Tag.
ExposureIndex Property
Accesses ExposureIndex Tag.
ExposureMode Property
Accesses ExposureMode Tag.
ExposureProgram Property
Accesses ExposureProgram Tag.
ExposureTime Property
Accesses ExposureTime Tag.
FileSource Property
Accesses FileSource Tag.
Flash Property
Accesses Flash Tag.
FlashEnergy Property
Accesses FlashEnergy Tag.
FlashPixVersion Property
Accesses FlashPixVersion Tag.
FNumber Property
Accesses FNumber Tag.
FocalLength Property
Accesses FocalLength Tag.
FocalLengthIn35mmFilm Property
Accesses FocalLengthIn35mmFilm Tag.
FocalPlaneResolutionUnit Property
Accesses FocalPlaneResolutionUnit Tag.
FocalPlaneXResolution Property
Accesses FocalPlaneXResolution Tag.
FocalPlaneYResolution Property
Accesses FocalPlaneYResolution Tag.
GainControl Property
Accesses GainControl Tag.
GPS Property
Accesses GPS Tag.
ImageDescription Property
Accesses ImageDescription Tag.
ImageLength Property
Accesses ImageLength Tag.
ImageWidth Property
Accesses ImageWidth Tag.
InterColorProfile Property
Accesses InterColorProfile Tag.
Interoperability Property
Accesses Interoperability Tag.
ISOSpeedRatings Property
Accesses ISOSpeedRatings Tag.
JPEGInterchangeFormat Property
Accesses JPEGInterchangeFormat Tag.
JPEGInterchangeFormatLngth Property
Accesses JPEGInterchangeFormatLngth Tag.
LightSource Property
Accesses LightSource Tag.
Make Property
Accesses Make Tag.
MaxApertureValue Property
Accesses MaxApertureValue Tag.
MeteringMode Property
Accesses MeteringMode Tag.
Model Property
Accesses Model Tag.
OECF Property
Accesses OECF Tag.
Orientation Property
Accesses Orientation Tag.
PhotometricInterpretation Property
Accesses PhotometricInterpretation Tag.
PixelXDimension Property
Accesses PixelXDimension Tag.
PixelYDimension Property
Accesses PixelYDimension Tag.
PlanarConfig Property
Accesses PlanarConfig Tag.
PrimaryChromaticities Property
Accesses PrimaryChromaticities Tag.
ReferenceBlackWhite Property
Accesses ReferenceBlackWhite Tag.
RelatedSoundFile Property
Accesses RelatedSoundFile Tag.
ResolutionUnit Property
Accesses ResolutionUnit Tag.
RowsPerStrip Property
Accesses RowsPerStrip Tag.
SamplesPerPixel Property
Accesses SamplesPerPixel Tag.
Saturation Property
Accesses Saturation Tag.
SceneCaptureType Property
Accesses SceneCaptureType Tag.
SceneType Property
Accesses SceneType Tag.
SensingMethod Property
Accesses SensingMethod Tag.
Sharpness Property
Accesses Sharpness Tag.
ShutterSpeedValue Property
Accesses ShutterSpeedValue Tag.
Software Property
Accesses Software Tag.
SpatialFrequencyResponse Property
Accesses SpatialFrequencyResponse Tag.
SpectralSensitivity Property
Accesses SpectralSensitivity Tag.
StripByteCounts Property
Accesses StripByteCounts Tag.
StripOffsets Property
Accesses StripOffsets Tag.
SubjectArea Property
Accesses SubjectArea Tag.
SubjectDistance Property
Accesses SubjectDistance Tag.
SubjectDistanceRange Property
Accesses SubjectDistanceRange Tag.
SubjectLocation Property
Accesses SubjectLocation Tag.
SubSecTime Property
Accesses SubSecTime Tag.
SubSecTimeDigitized Property
Accesses SubSecTimeDigitized Tag.
SubSecTimeOriginal Property
Accesses SubSecTimeOriginal Tag.
TransferFunction Property
Accesses TransferFunction Tag.
UserComment Property
Accesses UserComment Tag.
WhiteBalance Property
Accesses WhiteBalance Tag.
WhitePoint Property
Accesses WhitePoint Tag.
XResolution Property
Accesses XResolution Tag.
YCbCrCoefficients Property
Accesses YCbCrCoefficients Tag.
YCbCrPositioning Property
Accesses YCbCrPositioning Tag.
YCbCrSubSampling Property
Accesses YCbCrSubSampling Tag.
YResolution Property
Accesses YResolution Tag.


ApertureValue Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ApertureValue tag. The tag specifies the lens aperture. The unit is the APEX value.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt? ApertureValue { set; get; }

Value:

Nullable (boxed) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


Artist Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Artist tag. The tag specifies the person who created the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public string Artist { set; get; }

Value:

value.


BitsPerSample Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the BitsPerSample tag. The tag specifies the number of bits per component.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ushort[] BitsPerSample { set; get; }

Value:

ushort[] array.


BrightnessValue Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the BrightnessValue tag. The tag specifies the value of brightness. The unit is the APEX value.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalInt? BrightnessValue { set; get; }

Value:

Nullable (boxed) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


CFAPattern Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the CFAPAttern tag. The tag indicates the color filter array (CFA) geometric pattern of the image sensor when a one-chip color area sensor is used. It does not apply to all sensing methods.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public byte[] CFAPattern { set; get; }

Value:

Array of bytes.


ColorSpace Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ColorSpace tag. The tag specifies the color space information.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearEXIFColorSpace? ColorSpace { set; get; }

Value:

Nullable (boxed) ImGearEXIFColorSpace Enumeration value.

See Also:

ImGearEXIFColorSpace Enumeration


ComponentsConfiguration Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ComponentsConfiguration tag. The tag specifies information specific to compressed data. The channels of each component are arranged in order from the 1st component to the 4th. For uncompressed data, the data arrangement is given in the PhotometricInterpretation tag. However, since PhotometricInterpretation can only express the order of Y, Cb, and Cr, this tag is provided for cases when compressed data uses components other than Y, Cb, and Cr and to enable support of other sequences.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public byte[] ComponentsConfiguration { set; get; }

Value:

Array of bytes.


CompressedBitsPerPixel Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the CompressedBitsPerPixel tag. The tag specifies information specific to compressed data. The compression mode used for a compressed image is indicated in unit bits per pixel.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt? CompressedBitsPerPixel { set; get; }

Value:

Nullable (boxed) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


Compression Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Compression tag. The tag specifies the compression scheme used on the image data.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearTIFFCompression? Compression { set; get; }

Value:

Nullable (boxed) ImGearTIFFCompression Enumeration value.

See Also:

ImGearTIFFCompression Enumeration


Contrast Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Contrast tag. The tag indicates the direction of contrast processing applied by the camera when the image was shot.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearEXIFContrastMode? Contrast { set; get; }

Value:

Nullable (boxed) ImGearEXIFContrastMode Enumeration value.

See Also:

ImGearEXIFContrastMode Enumeration


Copyright Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Copyright tag. The tag specifies the copyright notice.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public string Copyright { set; get; }

Value:

String value.


CustomRendered Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the CustomRendered tag. This tag indicates the use of special processing on image data, such as rendering geared to output. When special processing is performed, the reader is expected to disable or minimize any further processing.

Declaration:

public ImageGear.Formats.ImGearEXIFCustomRendered? CustomRendered { set; get; }

Value:

Nullable (boxed) ImGearEXIFCustomRendered Enumeration value.

See Also:

ImGearEXIFCustomRendered Enumeration


DateTime Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the DateTime tag. The tag specifies the date and time of image creation.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See TIFF 6.0 specification for tag usage details.

Declaration:

public string DateTime { set; get; }

Value:

String value.


DateTimeDigitized Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the DateTimeDigitized tag. The tag specifies the date and time when the image was stored as digital data. If, for example, an image was captured by DSC and at the same time the file was recorded, then the DateTimeOriginal and DateTimeDigitized will have the same contents. The format is "YYYY:MM:DD HH:MM:SS" with time shown in 24-hour format, and the date and time separated by one blank character [20.H].

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public String DateTimeDigitized { set; get; }

Value:

String value.


DateTimeOriginal Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the DateTimeOriginal tag. The tag specifies the date and time when the original image data was generated. For a DSC, the date and time the picture was taken are recorded. The format is "YYYY:MM:DD HH:MM:SS" with time shown in 24-hour format, and the date and time separated by one blank character [20.H]. When the date and time are unknown, all the character spaces except colons (":") may be filled with blank characters, or else the Interoperability field may be filled with blank characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public System.DateTime DateTimeOriginal { set; get; }

Value:

System.DateTime value.


DeviceSettingDescription Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the DeviceSettingDescription tag. This tag indicates information on the picture-taking conditions of a particular camera model. The tag is used only to indicate the picture-taking conditions in the reader.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public byte[] DeviceSettingDescription { set; get; }

Value:

Array of bytes.


DigitalZoomRatio Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the DigitalZoomRatio tag. This tag indicates the digital zoom ratio when the image was shot. If the numerator of the recorded value is 0, this indicates that digital zoom was not used.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt? DigitalZoomRatio { set; get; }

Value:

Nullable (boxed) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


ExifVersion Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ExifVersion tag. The tag specifies the version of this standard supported.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public byte[] ExifVersion { set; get; }

Value:

Array of bytes.


ExposureBiasValue Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ExposureBiasValue tag. The tag specifies the exposure bias. The unit is the APEX value. Ordinarily it is given in the range of -99.99 to 99.99.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalInt? ExposureBiasValue { set; get; }

Value:

Nullable (boxed) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


ExposureIndex Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ExposureIndex tag. The tag indicates the exposure index selected on the camera or input device at the time the image is captured.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt? ExposureIndex { set; get; }

Value:

Nullable (boxed) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


ExposureMode Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ExposureMode tag. This tag indicates the exposure mode set when the image was shot. In auto-bracketing mode, the camera shoots a series of frames of the same scene at different exposure settings.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearEXIFExposureMode? ExposureMode { set; get; }

Value:

Nullable (boxed) ImGearEXIFExposureMode Enumeration value.

See Also:

ImGearEXIFExposureMode Enumeration


ExposureProgram Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ExposureProgram tag. The tag specifies the class of the program used by the camera to set exposure when the picture is taken.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearEXIFExposureProgram? ExposureProgram { set; get; }

Value:

Nullable 9boxed) ImGearEXIFExposureProgram Enumeration value.

See Also:

ImGearEXIFExposureProgram Enumeration


ExposureTime Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ExposureTime tag. The tag specifies exposure time, given in seconds.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt? ExposureTime { set; get; }

Value:

Nullable (boxed) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


FileSource Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the FileSource tag. The tag indicates the image source.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearEXIFFileSource? FileSource { set; get; }

Value:

Nullable (boxed) ImGearEXIFFileSource Enumeration value.

See Also:

ImGearEXIFFileSource Enumeration


Flash Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Flash tag. This tag indicates the status of the flash when the image was shot.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ushort? Flash { set; get; }

Value:

Nullable (boxed) Ushort value.


FlashEnergy Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the FlashEnergy tag. The tag indicates the strobe energy at the time the image is captured, as measured in Beam Candle Power Seconds (BCPS).

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt? FlashEnergy { set; get; }

Value:

Nullable (boxed) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


FlashPixVersion Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the FlashpixVersion tag. The tag specifies the Flashpix format version supported by a FPXR file.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public byte[] FlashPixVersion { set; get; }

Value:

Array of bytes.


FNumber Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the FNumber tag. The tag specifies the F number.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt? FNumber { set; get; }

Value:

Nullable (boxed) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


FocalLength Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the FocalLength tag. The tag specifies the actual focal length of the lens, in mm. Conversion is not made to the focal length of a 35 mm film camera.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt? FocalLength { set; get; }

Value:

Nullable (boxed) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


FocalLengthIn35mmFilm Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the FocalLengthIn35mmFilm tag. This tag indicates the equivalent focal length, assuming a 35mm film camera, in mm. A value of 0 means the focal length is unknown. Note that this tag differs from the FocalLength tag.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ushort? FocalLengthIn35mmFilm { set; get; }

Value:

Nullable (boxed) Ushort value.


FocalPlaneResolutionUnit Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the FocalPlaneResolutionUnit tag. The tag indicates the unit for measuring FocalPlaneXResolution and FocalPlaneYResolution.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearTIFFResolutionUnit? FocalPlaneResolutionUnit { set; get; }

Value:

Nullable (boxed) ImGearTIFFResolutionUnit Enumeration value.

See Also:

ImGearTIFFResolutionUnit Enumeration


FocalPlaneXResolution Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the FocalPlaneXResolution tag. The tag indicates the number of pixels in the image width (X) direction per FocalPlaneResolutionUnit on the camera focal plane.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt? FocalPlaneXResolution { set; get; }

Value:

Nullable (boxed) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


FocalPlaneYResolution Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the FocalPlaneYResolution tag. The tag indicates the number of pixels in the image height (Y) direction per FocalPlaneResolutionUnit on the camera focal plane.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt? FocalPlaneYResolution { set; get; }

Value:

Nullable (boxed) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


GainControl Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GainControl tag. This tag indicates the degree of overall image gain adjustment.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearEXIFGainControl? GainControl { set; get; }

Value:

Nullable (boxed) ImGearEXIFGainControl Enumeration value.

See Also:

ImGearEXIFGainControl Enumeration


GPS Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GPS IFD metadata.

Declaration:

public ImageGear.Formats.ImGearEXIFGPSMetadata GPS { set; get; }

Value:

ImGearEXIFGPSMetadata Class value.

See Also:

ImGearEXIFGPSMetadata Class


ImageDescription Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ImageDescription tag. The tag describes the subject of the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public string ImageDescription { set; get; }

Value:

String value.


ImageLength Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ImageLength tag. The tag specifies the number of rows of pixels in the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public uint? ImageLength { set; get; }

Value:

Nullable (boxed) uint value.


ImageWidth Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ImageWidth tag. The tag specifies the number of pixels per row.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public uint? ImageWidth { set; get; }

Value:

Nullable (boxed) uint value.


InterColorProfile Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the InterColorProfile tag. The tag encodes an embedded InterColor (ICC) device profile relating to the camera color characterization.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public byte[] InterColorProfile { set; get; }

Value:

Array of bytes.


Interoperability Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides access to the EXIF Interoperability IFD metadata.

Declaration:

public ImageGear.Formats.ImGearEXIFInteropMetadata Interoperability { set; get; }

Value:

ImGearEXIFInteropMetadata Class value.

See Also:

ImGearEXIFInteropMetadata Class


ISOSpeedRatings Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ISOSpeedRatings tag. The tag indicates the ISO Speed and ISO Latitude of the camera or input device as specified in ISO 12232.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ushort[] ISOSpeedRatings { set; get; }

Value:

Array of ushort values.


JPEGInterchangeFormat Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the JPEGInterchangeFormat tag. This Field indicates whether a JPEG interchange format bitstream is present in the TIFF file. If a JPEG interchange format bitstream is present, then this tag points to the Start of Image (SOI) marker code.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public uint? JPEGInterchangeFormat { set; get; }

Value:

Nullable (boxed) Uint value.


JPEGInterchangeFormatLngth Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the JPEGInterchangeFormatLength tag. This tag indicates the length in bytes of the JPEG interchange format bitstream.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public uint? JPEGInterchangeFormatLngth { set; get; }

Value:

Nullable (boxed) Uint value.


LightSource Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the LightSource tag. The tag specifies the kind of light source.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearEXIFLightSource? LightSource { set; get; }

Value:

Nullable (boxed) ImGearEXIFLightSource Enumeration value.

See Also:

ImGearEXIFLightSource Enumeration


Make Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Make tag. The tag specifies the scanner or digital camera manufacturer.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public string Make { set; get; }

Value:

String value.


MaxApertureValue Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the MaxApertureValue tag. The tag specifies the smallest F number of the lens. The unit is the APEX value. Ordinarily it is given in the range of 00.00 to 99.99, but it is not limited to this range.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt? MaxApertureValue { set; get; }

Value:

Nullable (boxed) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


MeteringMode Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the MeteringMode tag. The tag specifies the metering mode.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearEXIFMeteringMode? MeteringMode { set; get; }

Value:

Nullable (boxed) ImGearEXIFMeteringMode Enumeration value.

See Also:

ImGearEXIFMeteringMode Enumeration


Model Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Model tag. The tag specifies the scanner or digital camera model name or number.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public string Model { set; get; }

Value:

String value.


OECF Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the OECF tag. The tag indicates the Opto-Electric Conversion Function (OECF) specified in ISO 14524. OECF is the relationship between the camera optical input and the image values.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public byte[] OECF { set; get; }

Value:

Array of bytes.


Orientation Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Orientation tag. The tag specifies the orientation of the image with respect to the rows and columns.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores value of this tag during image saving, and saves a value that corresponds to the saved image parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

.NET 2.0:

public ImageGear.Formats.ImGearTIFFOrientation? Orientation { set; get; }

.NET 2.0:

public ImageGear.Formats.ImGearTIFFOrientationBoxed Orientation { set; get; }

Value:

Nullable (boxed) ImGearTIFFOrientation Enumeration value.

See Also:

ImGearTIFFOrientation Enumeration


PhotometricInterpretation Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the PhotometricInterpretation tag. This tag indicates the color space of the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearTIFFPhotoInterpretations? PhotometricInterpretation { set;
get; }

Value:

Nullable (boxed) ImGearTIFFPhotoInterpretation Enumeration value.

See Also:

ImGearTIFFPhotoInterpretation Enumeration


PixelXDimension Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the PixelXDimension tag. The tag specifies information specific to compressed data. When a compressed file is recorded, the valid width of the meaningful image shall be recorded in this tag, whether or not there is padding data or a restart marker.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public uint? PixelXDimension { set; get; }

Value:

Nullable (boxed) uint value.


PixelYDimension Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the PixelYDimension tag. The tag specifies information specific to compressed data. When a compressed file is recorded, the valid height of the meaningful image shall be recorded in this tag, whether or not there is padding data or a restart marker.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public uint? PixelYDimension { set; get; }

Value:

Nullable (boxed) Uint value.


PlanarConfig Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the PlanarConfig tag. The tag specifies how the components of each pixel are stored.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearTIFFPlanarConfig? PlanarConfig { set; get; }

Value:

Nullable (boxed) ImGearTIFFPlanarConfig Enumeration value.

See Also:

ImGearTIFFPlanarConfig Enumeration


PrimaryChromaticities Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the PrimaryChromaticities tag. The tag specifies the chromaticities of the primaries of the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt[] PrimaryChromaticities { set; get; }

Value:

ImGearRationalUInt Structure[] array.

See Also:

ImGearRationalUInt Structure


ReferenceBlackWhite Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ReferenceBlackWhite tag. The tag specifies a pair of headroom and footroom image data values (codes) for each pixel component. The first component code within a pair is associated with ReferenceBlack, and the second is associated with ReferenceWhite.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public uint[] ReferenceBlackWhite { set; get; }

Value:

Uint[] array.


RelatedSoundFile Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the RelatedSoundFile tag. This tag is used to record the name of an audio file related to the image data.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public string RelatedSoundFile { set; get; }

Value:

String value.


ResolutionUnit Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ResolutionUnit tag. The tag specifies the unit of measurement for XResolution and YResolution.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearTIFFResolutionUnit? ResolutionUnit { set; get; }

Value:

Nullable (boxed) ImGearTIFFResolutionUnit Enumeration value.

See Also:

ImGearTIFFResolutionUnit Enumeration


RowsPerStrip Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the RowsPerStrip tag. The tag specifies the number of rows per strip.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public uint? RowsPerStrip { set; get; }

Value:

Nullable (boxed) Uint value.


SamplesPerPixel Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the SamplesPerPixel tag. The tag specifies the number of components per pixel.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ushort? SamplesPerPixel { set; get; }

Value:

Nullable (boxed) ushort value.


Saturation Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Saturation tag. This tag indicates the direction of saturation processing applied by the camera when the image was shot.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearEXIFSaturationMode? Saturation { set; get; }

Value:

Nullable (boxed) ImGearEXIFSaturationMode Enumeration value.

See Also:

ImGearEXIFSaturationMode Enumeration


SceneCaptureType Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the SceneCaptureType tag. This tag indicates the type of scene that was shot. It can also be used to record the mode in which the image was shot. Note that this differs from the scene type (SceneType) tag.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ushort? SceneCaptureType { set; get; }

Value:

Nullable (boxed) ushort value.


SceneType Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the SceneType tag. The tag indicates the type of scene. If a DSC recorded the image, this tag value shall always be set to 1, indicating that the image was directly photographed.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearEXIFSceneType? SceneType { set; get; }

Value:

Nullable (boxed) ImGearEXIFSceneType Enumeration value.

See Also:

ImGearEXIFSceneType Enumeration


SensingMethod Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the SensingMethod tag. The tag Indicates the image sensor type on the camera or input device.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearEXIFSensingMethod? SensingMethod { set; get; }

Value:

Nullable (boxed) ImGearEXIFSensingMethod Enumeration value.

See Also:

ImGearEXIFSensingMethod Enumeration


Sharpness Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Sharpness tag. This tag indicates the direction of sharpness processing applied by the camera when the image was shot.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearEXIFSharpnessMode? Sharpness { set; get; }

Value:

Nullable (boxed) ImGearEXIFSharpnessMode Enumeration value.

See Also:

ImGearEXIFSharpnessMode Enumeration


ShutterSpeedValue Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ShutterSpeedValue tag. The tag specifies the shutter speed. The unit is the APEX (Additive System of Photographic Exposure) setting.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalInt? ShutterSpeedValue { set; get; }

Value:

Nullable (boxed) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


Software Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Software tag. The tag specifies the name and version number of the software package(s) used to create the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public string Software { set; get; }

Value:

String value.


SpatialFrequencyResponse Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the SpatialFrequencyResponse tag. The tag records the camera or input device spatial frequency table and SFR values in the direction of image width, image height, and diagonal direction, as specified in ISO 12233.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public byte[] SpatialFrequencyResponse { set; get; }

Value:

Array of bytes.


SpectralSensitivity Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the SpectralSensitivity tag. This tag indicates the spectral sensitivity of each channel of the camera used. The tag value is an ASCII string compatible with the standard developed by the ASTM Technical committee.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public string SpectralSensitivity { set; get; }

Value:

String value.


StripByteCounts Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the StripByteCounts tag. The tag specifies the number of bytes after any compression, for each strip.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public uint[] StripByteCounts { set; get; }

Value:

uint[] array.


StripOffsets Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the StripOffsets tag. The tag specifies the byte offset for each strip.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public uint[] StripOffsets { set; get; }

Value:

uint[] array.


SubjectArea Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the SubjectArea tag. This tag indicates the location and area of the main subject in the overall scene.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ushort[] SubjectArea { set; get; }

Value:

ushort[] array.


SubjectDistance Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the SubjectDistance tag. The tag specifies the distance to the subject, given in meters. Note that if the numerator of the recorded value is FFFFFFFF.H, Infinity shall be indicated; and if the numerator is 0, Distance unknown shall be indicated.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt? SubjectDistance { set; get; }

Value:

Nullable (boxed) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


SubjectDistanceRange Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the SubjectDistanceRange tag. The tag indicates the distance to the subject.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearEXIFSubjectDistanceRange? SubjectDistanceRange { set; get;
}

Value:

Nullable (boxed) ImGearEXIFSubjectDistanceRange Enumeration value.

See Also:

ImGearEXIFSubjectDistanceRange Enumeration


SubjectLocation Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the SubjectLocation tag. The tag indicates the location of the main subject in the scene. The value of this tag represents the pixel at the center of the main subject relative to the left edge, prior to rotation processing as per the Rotation tag. The first value indicates the X column number and second indicates the Y row number.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ushort[] SubjectLocation { set; get; }

Value:

ushort[] array.


SubSecTime Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the SubsecTime tag. The tag is used to record fractions of seconds for the DateTime tag.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public string SubSecTime { set; get; }

Value:

String value.


SubSecTimeDigitized Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the SubsecTimeDigitized tag. The tag is used to record fractions of seconds for the DateTimeDigitized tag.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public string SubSecTimeDigitized { set; get; }

Value:

String value.


SubSecTimeOriginal Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the SubsecTimeOriginal tag. The tag is used to record fractions of seconds for the DateTimeOriginal tag.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public string SubSecTimeOriginal { set; get; }

Value:

String value.


TransferFunction Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the TransferFunction tag. The tag specifies a transfer function for the image, described in tabular style. Normally this tag is not necessary, since color space is specified in the color space information tag (ColorSpace).

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ushort[] TransferFunction { set; get; }

Value:

ushort[] array.


UserComment Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the UserComment tag. The tag contains keywords or comments on the image besides those in ImageDescription, and without the character code limitations of the ImageDescription tag.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public byte[] UserComment { set; get; }

Value:

Array of bytes.


WhiteBalance Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the WhiteBalance tag. The tag indicates the white balance mode set when the image was shot.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearEXIFWhiteBalanceMode? WhiteBalance { set; get; }

Value:

Nullable (boxed)ImGearEXIFWhiteBalanceMode Enumeration value.

See Also:

ImGearEXIFWhiteBalanceMode Enumeration


WhitePoint Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the WhitePoint tag. The tag specifies the chromaticity of the white point of the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt[] WhitePoint { set; get; }

Value:

ImGearRationalUInt Structure[] array.

See Also:

ImGearRationalUInt Structure


XResolution Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the XResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageWidth (typically, horizontal - see Orientation) direction.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt? XResolution { set; get; }

Value:

Nullable (boxed) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


YCbCrCoefficients Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the YCbCrCoefficients tag. The tag specifies the transformation from RGB to YCbCr image data.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt[] YCbCrCoefficients { set; get; }

Value:

ImGearRationalUInt Structure[] array.

See Also:

ImGearRationalUInt Structure


YCbCrPositioning Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the YCbCrPositioning tag. The tag specifies the positioning of subsampled chrominance components relative to luminance samples.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ushort? YCbCrPositioning { set; get; }

Value:

Nullable (boxed) Ushort value.


YCbCrSubSampling Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the YCbCrSubSampling tag. The tag specifies the subsampling factors used for the chrominance components of a YCbCr image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ushort[] YCbCrSubSampling { set; get; }

Value:

ushort[] array.


YResolution Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the YResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageLength (typically, vertical) direction.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt? YResolution { set; get; }

Value:

Nullable (boxed) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure

32-bit
64-bit
CF
P
P
P
32-bit
64-bit
CF
P
P
P
ImageGear.Formats Namespace Enumerations

The ImageGear.Formats.EXIF Namespace has the following enumeration members:

Enumerations:
Name
Description
ImGearEXIFColorSpace Enumeration
Represents EXIF Color Spaces.
ImGearEXIFContrastMode Enumeration
Represents EXIF Contrast Modes.
ImGearEXIFCustomRendered Enumeration
Represents EXIF Custom Rendered modes.
ImGearEXIFExposureMode Enumeration
Represents EXIF Exposure Modes.
ImGearEXIFExposureProgram Enumeration
Represents EXIF Exposure Programs.
ImGearEXIFFileSource Enumeration
Represents EXIF File Sources.
ImGearEXIFFlashMode Enumeration
Represents EXIF Flash mode.
ImGearEXIFFlashReturn Enumeration
Represents EXIF Flash return.
ImGearEXIFGainControl Enumeration
Represents EXIF Gain Controls.
ImGearEXIFGPSAltitudeReference Enumeration
Represents EXIF GPS Altitude References.
ImGearEXIFGPSDifferential Enumeration
Represents EXIF GPS Differentials.
ImGearEXIFGPSDirectionReference Enumeration
Represents EXIF GPS Direction References.
ImGearEXIFGPSDistanceReference Enumeration
Represents EXIF GPS Distance References.
ImGearEXIFGPSLatitudeReference Enumeration
Represents EXIF GPS Latitude References.
ImGearEXIFGPSLongitudeReference Enumeration
Represents EXIF GPS Longitude References.
ImGearEXIFGPSMeasureMode Enumeration
Represents EXIF GPS Measure Modes.
ImGearEXIFGPSSpeedReference Enumeration
Represents EXIF GPS Speed Reference Modes.
ImGearEXIFGPSStatus Enumeration
Represents EXIF GPS Statuses.
ImGearEXIFLightSource Enumeration
Represents EXIF Light Sources.
ImGearEXIFMeteringMode Enumeration
Represents EXIF Metering Modes.
ImGearEXIFSaturationMode Enumeration
Represents EXIF Saturation Modes.
ImGearEXIFSceneCaptureType Enumeration
Represents EXIF scene capture types.
ImGearEXIFSceneType Enumeration
Represents EXIF Scene Types.
ImGearEXIFSensingMethod Enumeration
Represents EXIF Sensing Methods.
ImGearEXIFSharpnessMode Enumeration
Represents EXIF Sharpness Modes.
ImGearEXIFSubjectDistanceRange Enumeration
Represents EXIF Subject Distance Ranges.
ImGearEXIFWhiteBalanceMode Enumeration
Represents EXIF White Balance Modes.


ImGearEXIFColorSpace Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF Color Spaces.

Declaration:

public enum ImGearEXIFColorSpace

Values:

Name
Value
Description
SRGB
1
sRGB
Uncalibrated
0xFFFF
Color space other than sRGB is used


ImGearEXIFContrastMode Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF Contrast Modes.

Declaration:

public enum ImGearEXIFContrastMode

Values:

Name
Value
Description
Hard
2
Hard
Normal
0
Normal
Soft
1
Soft


ImGearEXIFCustomRendered Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF Custom Rendered modes.

Declaration:

public enum ImGearEXIFCustomRendered

Values:

Name
Value
Description
CustomProcess
1
Custom process
NormalProcess
0
Normal process


ImGearEXIFExposureMode Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF Exposure Modes.

Declaration:

public enum ImGearEXIFExposureMode

Values:

Name
Value
Description
AutoBracket
2
Auto Bracket
AutoExposure
0
Auto exposure
ManualExposure
1
Manual exposure


ImGearEXIFExposureProgram Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF Exposure Programs.

Declaration:

public enum ImGearEXIFExposureProgram

Values:

Name
Value
Description
Undefined
0
Undefined
Manual
1
Manual
NormalProgram
2
Normal program
AperturePriority
3
Aperture Priority
ShutterPriority
4
Shutter program
CreativeProgram
5
Biased toward depth of field
ActionProgram
6
Biased toward fast shutter speed
PortraitMode
7
For closeup photos with the background out of focus
LandscapeMode
8
For landscape photos with the background in focus


ImGearEXIFFileSource Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF File Sources.

Declaration:

public enum ImGearEXIFFileSource

Values:

Name
Value
Description
DSC
3
DSC


ImGearEXIFFlashMode Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF flash mode.

Declaration:

public enum ImGearEXIFFlashMode

Members:

Name
Description
Unknown
Unknown
CompulsoryFlashFiring
Compulsory flash firing
CompulsoryFlashSuppression
Compulsory flash suppression
AutoMode
Auto mode


ImGearEXIFFlashReturn Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF flash return.

Declaration:

public enum ImGearEXIFFlashReturn

Members:

Name
Description
NoStrobeReturnDetection
No strobe return detection
StrobeReturnLightNotDetected
Strobe return light not detected
StrobeReturnLightDetected
Strobe return light detected


ImGearEXIFGainControl Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF Gain Control modes.

Declaration:

public enum ImGearEXIFGainControl

Values:

Name
Value
Description
HighGainDown
4
High gain down
HighGainUp
2
High gain up
LowGainDown
3
Low gain down
LowGainUp
1
Low gain up
None
0
None


ImGearEXIFGPSAltitudeReference Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF GPS Altitude References.

Declaration:

public enum ImGearEXIFGPSAltitudeReference

Values:

Name
Value
Description
SeaLevel
0
The altitude reference is sea level
SeaLevelReference
1
The altitude is below sea level


ImGearEXIFGPSDifferential Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF GPS Differential modes.

Declaration:

public enum ImGearEXIFGPSDifferential

Values:

Name
Value
Description
DifferentialCorrectionApplied
1
Differential correction applied
WithoutDifferentialCorrection
0
Measurement without differential correction


ImGearEXIFGPSDirectionReference Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF GPS Direction References.

Declaration:

public enum ImGearEXIFGPSDirectionReference

Values:

Name
Value
Description
Magnetic
Magnetic direction
True
True direction


ImGearEXIFGPSDistanceReference Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF GPS Distance References.

Declaration:

public enum ImGearEXIFGPSDistanceReference

Values:

Name
Value
Description
Kilometers
Kilometers
Knots
Knots
Miles
Miles


ImGearEXIFGPSLatitudeReference Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF GPS Latitude References.

Declaration:

public enum ImGearEXIFGPSLatitudeReference

Values:

Name
Value
Description
North
North
South
South


ImGearEXIFGPSLongitudeReference Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF GPS Longitude References.

Declaration:

public enum ImGearEXIFGPSLongitudeReference

Values:

Name
Value
Description
East
East
West
West


ImGearEXIFGPSMeasureMode Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF GPS Measure Modes.

Declaration:

public enum ImGearEXIFGPSMeasureMode

Values:

Name
Value
Description
Mode2D
Two-dimensional measurement
Mode3D
Three-dimensional measurement


ImGearEXIFGPSSpeedReference Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF GPS Speed Reference modes.

Declaration:

public enum ImGearEXIFGPSSpeedReference

Values:

Name
Value
Description
KilometersPerHour
Kilometers Per Hour
Knots
Knots
MilesPerHour
Miles Per Hour


ImGearEXIFGPSStatus Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF GPS Statuses.

Declaration:

public enum ImGearEXIFGPSStatus

Values:

Name
Value
Description
InProgress
Measurement is in progress
Interoperability
Measurement is Interoperability


ImGearEXIFLightSource Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF Light Sources.

Declaration:

public enum ImGearEXIFLightSource

Values:

Name
Value
Description
Unknown
0
Unknown
Daylight
1
Daylight
Fluorescent
2
Fluorescent
Tungsten
3
Tungsten
Flash
4
Flash
FineWeather
9
Fine Weather
CloudyWeather
10
Cloudy Weather
Shade
11
Shade
DaylightFluorescent
12
Daylight Fluorescent
DayWhiteFluorescent
13
Day White Fluorescent
CoolWhiteFluorescent
14
Cool White Fluorescent
WhiteFluorescent
15
White Fluorescent
StandardLightA
17
Standard Light A
StandardLightB
18
Standard Light B
StandardLightC
19
Standard Light C
D55
20
D55
D65
21
D65
D75
22
D75
D50
23
D50
ISOStudioTungsten
24
ISO Studio Tungsten
Other
255
Other Light Source


ImGearEXIFMeteringMode Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF Metering Modes.

Declaration:

public enum ImGearEXIFMeteringMode

Values:

Name
Value
Description
Unknown
0
Unknown
Average
1
Average
CenterWeightedAverage
2
Center Weighted Average
Spot
3
Spot
MultiSpot
4
MultiSpot
Pattern
5
Pattern
Partial
6
Partial
Other
255
Other


ImGearEXIFSaturationMode Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF Saturation Modes.

Declaration:

public enum ImGearEXIFSaturationMode

Values:

Name
Value
Description
High
2
High
Low
1
Low
Normal
0
Normal


ImGearEXIFSceneCaptureType Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF scene capture types.

Declaration:

public enum ImGearEXIFSceneCaptureType

Members:

Name
Description
East
East direction
North
North direction
South
South direction
West
West direction


ImGearEXIFSceneType Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF Scene Types.

Declaration:

public enum ImGearEXIFSceneType

Values:

Name
Value
Description
DirectlyPhotographedImage
1
Directly Photographed Image


ImGearEXIFSensingMethod Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF Sensing Methods.

Declaration:

public enum ImGearEXIFSensingMethod

Values:

Name
Value
Description
ColorSequentialAreaSensor
5
Color Sequential Area Sensor
ColorSequentialLinearSensor
8
Color Sequential Linear Sensor
OneChipColorAreaSensor
2
One Chip Color Area Sensor
ThreeChipColorAreaSensor
4
Three Chip Color Area Sensor
TrilinearSensor
7
Trilinear Sensor
TwoChipColorAreaSensor
3
Two Chip Color Area Sensor
Undefined
1
Undefined


ImGearEXIFSharpnessMode Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF Sharpness Modes.

Declaration:

public enum ImGearEXIFSharpnessMode

Values:

Name
Value
Description
Hard
2
Hard
Normal
0
Normal
Soft
1
Soft


ImGearEXIFSubjectDistanceRange Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF Subject Distance Ranges.

Declaration:

public enum ImGearEXIFSubjectDistanceRange

Values:

Name
Value
Description
CloseView
2
Close View
DistantView
3
Distant View
Macro
1
Macro
Unknown
0
Unknown


ImGearEXIFWhiteBalanceMode Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents EXIF White Balance Modes.

Declaration:

public enum ImGearEXIFWhiteBalanceMode

Values:

Name
Value
Description
Auto
0
Auto
Manual
1
Manual


ImageGear.Formats.HPGL Namespace

ImageGear.Formats.HPGL Namespace

32-bit
64-bit
CF
P
P

Description:

This namespace provides the API to create HPGL vector format.

Declaration:

namespace ImageGear.Formats.HPGL

Members:

Classes:
Name
Description
ImGearHPGL Class
This class is used to create HPGL vector format.

See Also:

HPGL


ImageGear.Formats.HPGL Namespace Classes

The ImageGear.Formats.HPGL Namespace has the following class members:

Classes:
Name
Description
ImGearHPGL Class
This class is used to create HPGL vector format.


ImGearHPGL Class

32-bit
64-bit
CF
P
P

Description:

This class is used to create HPGL vector format.

Declaration:

public sealed class ImGearHPGL

Members:

Constructors
Name
Description
ImGearHPGL Constructor
This constructor creates and initializes an instance of ImGearHPGL Class.

Methods
Name
Description
CreateHPGLFormat Method
Creates an instance of HPGL format.
CreateHPGLFormat Method
Creates an instance of HPGL format.


ImGearHPGL Constructors

The ImGearHPGL Class of the ImageGear.Formats.HPGL Namespace has the following constructors:

Constructors
Name
Description
ImGearHPGL Constructor
This constructor creates and initializes an instance of ImGearHPGL Class.


ImGearHPGL Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates and initializes an instance of ImGearHPGL Class.

Declaration:

public ImGearHPGL()

Return Value:

The new instance of ImGearHPGL Class.

See Also:

ImGearHPGL Class


ImGearHPGL Methods

The ImGearHPGL Class of the ImageGear.Formats.HPGL Namespace has the following methods:

Methods
Name
Description
CreateHPGLFormat Method
Creates an instance of HPGL format.
CreateHPGLFormat Method
Creates an instance of HPGL format.


CreateHPGLFormat Method

32-bit
64-bit
CF
P
P

Description:

This method creates an instance of HPGL format.

Declaration:

public static ImageGear.Formats.IImGearFormat CreateHPGLFormat()

Return value:

An instance of HPGL format.

See Also:

ImGearHPGL Class


CreateHPGLFormat Method

32-bit
64-bit
CF
P
P

Description:

This method creates an instance of HPGL format. LibraryPath parameter specifies a folder path to load Vector native code libraries from.

If LibraryPath is blank then the current directory is used.

Declaration:

public static ImageGear.Formats.IImGearFormat CreateHPGLFormat(string LibraryPath)

Parameters:

Name
Type
Description
LibraryPath
string
Path to load Vector native libraries from.

Return value:

An instance of HPGL format.

See Also:

ImGearHPGL Class


ImageGear.Formats.IPTC Namespace

ImageGear.Formats.IPTC Namespace

32-bit
64-bit
CF
P
P
P

Description:

This namespace contains classes, structures, and enumerations that provide simplified access to IPTC metadata.

Declaration:

namespace ImageGear.Formats.IPTC

Members:

Classes:
Name
Description
ImGearIPTCMetadata Class
Provides simplified access to IPTC metadata.

Structures:
Name
Description
ImGearIPTCAudioType Structure
Represents IPTC Audio Type structure.
ImGearIPTCColourRepresentation Structure
Represents IPTC Colour Representation structure.
ImGearIPTCImageType Structure
Represents IPTC Image Type structure.
ImGearIPTCObjectAttributeReference Structure
Represents IPTC Object Attribute Reference structure.
ImGearIPTCObjectTypeReference Structure
Represents IPTC Object Type Reference structure.
ImGearIPTCPictureNumber Structure
Represents IPTC Picture Number structure.
ImGearIPTCSubjectReference Structure
Represents IPTC Subject Reference structure .
ImGearIPTCUNO Structure
Represents IPTC UNO structure.

Enumerations:
Name
Description
ImGearIPTCActionAdvised Enumeration
Represents IPTC Advised Actions.
ImGearIPTCAudioChannelMode Enumeration
Represents IPTC Audio Channel Modes.
ImGearIPTCAudioContentType Enumeration
Represents IPTC Audio Content Types.
ImGearIPTCDataCompressionMethod Enumeration
Represents IPTC Data Compression Methods.
ImGearIPTCExcursionTolerance Enumeration
Represents IPTC Excursion Tolerances.
ImGearIPTCFileFormatID Enumeration
Represents IPTC File Format IDs.
ImGearIPTCImageBuildUpStructure Enumeration
Represents IPTC Image Build Up Structures.
ImGearIPTCImageColourMode Enumeration
Represents IPTC Image Colour Modes.
ImGearIPTCImageComponentMode Enumeration
Represents IPTC Image Component Modes.
ImGearIPTCImageOrientation Enumeration
Represents IPTC Image Orientations.
ImGearIPTCImageRotation Enumeration
Represents IPTC Image Rotations.
ImGearIPTCInterchangeColourSpace Enumeration
Represents IPTC Interchange Colour Spaces.
ImGearIPTCObjectAttributeNumber Enumeration
Represents IPTC Object Attribute Numbers.
ImGearIPTCObjectCycle Enumeration
Represents IPTC Object Cycles.
ImGearIPTCObjectTypeNumber Enumeration
Represents IPTC Object Type Numbers.
ImGearIPTCQuantisationMethod Enumeration
Represents IPTC Quantisation Methods.
ImGearIPTCSamplingStructure Enumeration
Represents IPTC Sampling Structures.
ImGearIPTCScanningDirection Enumeration
Represents IPTC Scanning Directions.
ImGearIPTCSizeMode Enumeration
Represents IPTC Size Modes.
ImGearIPTCSubjectReferenceNumber Enumeration
Represents IPTC Subject Reference Numbers.
ImGearIPTCSupplementType Enumeration
Represents IPTC Supplement Types.


ImageGear.Formats.IPTC Namespace Classes

The ImageGear.Formats.IPTC Namespace has the following class members:

Classes:
Name
Description
ImGearIPTCMetadata Class
Provides simplified access to IPTC metadata.

32-bit
64-bit
CF
P
P
P
32-bit
64-bit
CF
P
P
P
ImageGear.Formats.IPTC Namespace > ImGearIPTCMetadata Class


ImGearIPTCMetadata Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides simplified access to IPTC metadata.

Declaration:

public class ImGearIPTCMetadata : ImageGear.Formats.ImGearFormatMetadata

Members:

Constructors
Name
Description
ImGearIPTCMetadata Constructor
Creates and initializes an instance of ImGearIPTCMetadata Class.

Properties
Name
Description
ActionAdvised Property
Accesses Action Advised IPTC dataset.
ARMIdentifier Property
Accesses ARM Identifier IPTC dataset.
ARMVersion Property
Accesses ARM Version IPTC dataset.
AudioDuration Property
Accesses Audio Duration IPTC dataset.
AudioOutcue Property
Accesses Audio Outcue IPTC dataset.
AudioSamplingRate Property
Accesses Audio Sampling Rate IPTC dataset.
AudioSamplingResolution Property
Accesses Audio Sampling Resolution IPTC dataset.
AudioType Property
Accesses Audio Type IPTC dataset.
BitsPerComponent Property
Accesses Bits Per Component IPTC dataset.
ByLine Property
Accesses By Line IPTC dataset.
ByLineTitle Property
Accesses By Line Title IPTC dataset.
Caption_Abstract Property
Accesses Caption/Abstract IPTC dataset.
Category Property
Accesses Category IPTC dataset.
City Property
Accesses City IPTC dataset.
CodedCharacterSet Property
Accesses Coded Character Set IPTC dataset.
ColourCalibrationMatrixTable Property
Accesses Colour Calibration Matrix Table IPTC dataset.
ColourPalette Property
Accesses Colour Palette IPTC dataset.
ColourRepresentation Property
Accesses Colour Representation IPTC dataset.
ColourSequence Property
Accesses Colour Sequence IPTC dataset.
ConfirmedObjectDataSize Property
Accesses Confirmed Object Data Size IPTC dataset.
Contact Property
Accesses Contact IPTC dataset.
ContentLocationCode Property
Accesses Content Location Code IPTC dataset.
ContentLocationName Property
Accesses Content Location Name IPTC dataset.
CopyrightNotice Property
Accesses Copyright Notice IPTC dataset.
CountryPrimaryLocationCode Property
Accesses Country Primary Location Code IPTC dataset.
CountryPrimaryLocationName Property
Accesses Country Primary Location Name IPTC dataset.
Credit Property
Accesses Credit IPTC dataset.
DataCompressionMethod Property
Accesses Data Compression Method IPTC dataset.
DateCreated Property
Accesses Date Created IPTC dataset.
DateSent Property
Accesses Date Sent IPTC dataset.
Destination Property
Accesses Destination IPTC dataset.
DigitalCreationDate Property
Accesses Digital Creation Date IPTC dataset.
DigitalCreationTime Property
Accesses Digital Creation Time IPTC dataset.
EditorialUpdate Property
Accesses Editorial Update IPTC dataset.
EditStatus Property
Accesses Edit Status IPTC dataset.
EndPoints Property
Accesses End Points IPTC dataset.
EnvelopeNumber Property
Accesses Envelope Number IPTC dataset.
EnvelopePriority Property
Accesses Envelope Priority IPTC dataset.
ExcursionTolerance Property
Accesses Excursion Tolerance IPTC dataset.
ExpirationDate Property
Accesses Expiration Date IPTC dataset.
ExpirationTime Property
Accesses Expiration Time IPTC dataset.
FileFormat Property
Accesses File Format IPTC dataset.
FileFormatVersion Property
Accesses File Format Version IPTC dataset.
FixtureIdentifier Property
Accesses Fixture Identifier IPTC dataset.
GammaCompensatedValue Property
Accesses Gamma Compensated Value IPTC dataset.
Headline Property
Accesses Headline IPTC dataset.
ICCInputColourProfile Property
Accesses ICC Input Colour Profile IPTC dataset.
ImageOrientation Property
Accesses Image Orientation IPTC dataset.
ImageRotation Property
Accesses Image Rotation IPTC dataset.
ImageType Property
Accesses Image Type IPTC dataset.
InterchangeColourSpace Property
Accesses Interchange Colour Space IPTC dataset.
Keywords Property
Accesses Keywords IPTC dataset.
LanguageIdentifier Property
Accesses Language Identifier IPTC dataset.
LookupTable Property
Accesses Lookup Table IPTC dataset.
MaximumDensityRange Property
Accesses Maximum Density Range IPTC dataset.
MaximumObjectDataSize Property
Accesses Maximum Object Data Size IPTC dataset.
MaxSubfileSize Property
Accesses Max Subfile Size IPTC dataset.
ModelVersion Property
Accesses Model Version IPTC dataset.
NumberOfBitsPerSample Property
Accesses Number Of Bits Per Sample IPTC dataset.
NumberOfIndexEntries Property
Accesses Number Of Index Entries IPTC dataset.
NumberOfLines Property
Accesses Number Of Line IPTC dataset.
ObjectAttributeReference Property
Accesses Object Attribute Reference IPTC dataset.
ObjectCycle Property
Accesses Object Cycle IPTC dataset.
ObjectDataPreviewData Property
Accesses Object Data Preview Data IPTC dataset.
ObjectDataPreviewFileFormat Property
Accesses ObjectData Preview File Format DataSet (2:200).
ObjectDataPreviewFileFormatVersion Property
Accesses Object Data Preview File Format Version IPTC dataset.
ObjectDataSizeAnnounced Property
Accesses Object Data Size Announced IPTC dataset.
ObjectName Property
Accesses Object Name IPTC dataset.
ObjectTypeReference Property
Accesses Object Type Reference IPTC dataset.
OriginalTransmissionReference Property
Accesses Original Transmission Reference IPTC dataset.
OriginatingProgram Property
Accesses Originating Program IPTC dataset.
PictureNumber Property
Accesses Picture Number IPTC dataset.
PixelSizeInScanningDirection Property
Accesses Pixel Size In Scanning Direction IPTC dataset.
PixelSizePerpendicularToScanningDirection Property
Accesses Pixel Size Perpendicular To Scanning Direction IPTC dataset.
PixelsPerLine Property
Accesses Pixels Per Line IPTC dataset.
ProductID Property
Accesses ProductID IPTC dataset.
ProgramVersion Property
Accesses Program Version IPTC dataset.
ProvinceState Property
Accesses Province State IPTC dataset.
QuantisationMethod Property
Accesses Quantisation Method IPTC dataset.
RasterizedCaption Property
Accesses Rasterized Caption IPTC dataset.
Record2Version Property
Accesses Record2 Version IPTC dataset.
Record3Version Property
Accesses Record3 Version IPTC dataset.
ReferenceDate Property
Accesses Reference Date IPTC dataset.
ReferenceNumber Property
Accesses Reference Number IPTC dataset.
ReferenceService Property
Accesses Reference Service IPTC dataset
ReleaseDate Property
Accesses Release Date IPTC dataset.
ReleaseTime Property
Accesses Release Time IPTC dataset.
SamplingStructure Property
Accesses Sampling Structure IPTC dataset.
ScanningDirection Property
Accesses Scanning Direction IPTC dataset.
ServiceIdentifier Property
Accesses Service Identifier IPTC dataset.
SizeMode Property
Accesses Size Mode IPTC dataset.
Source Property
Accesses Source IPTC dataset.
SpecialInstructions Property
Accesses Special Instructions IPTC dataset.
SubjectReference Property
Accesses Subject Reference IPTC dataset.
Sublocation Property
Accesses Sublocation IPTC dataset.
SupplementalCategory Property
Accesses Supplemental Category IPTC dataset.
SupplementType Property
Accesses Supplement Type IPTC dataset.
TimeCreated Property
Accesses Time Created IPTC dataset.
TimeSent Property
Accesses Time Sent IPTC dataset.
UNO Property
Accesses UNO IPTC dataset.
Urgency Property
Accesses Urgency IPTC dataset.
Writer_Editor Property
Accesses Writer/Editor IPTC dataset.


ImGearIPTCMetadata Constructors

The ImGearIPTCMetadata Class of the ImageGear.Formats.IPTC Namespace has the following constructors:

Constructors
Name
Description
ImGearIPTCMetadata Constructor
Creates and initializes an instance of ImGearIPTCMetadata Class.


ImGearIPTCMetadata Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearIPTCMetadata Class.

Declaration:

public ImGearIPTCMetadata()

Return Value:

The new instance of ImGearIPTCMetadata Class.

See Also:

ImGearIPTCMetadata Class


ImGearIPTCMetadata Properties

The ImGearIPTCMetadata Class of the ImageGear.Formats.IPTC Namespace has the following properties:

Properties
Name
Description
ActionAdvised Property
Accesses Action Advised IPTC dataset.
ARMIdentifier Property
Accesses ARM Identifier IPTC dataset.
ARMVersion Property
Accesses ARM Version IPTC dataset.
AudioDuration Property
Accesses Audio Duration IPTC dataset.
AudioOutcue Property
Accesses Audio Outcue IPTC dataset.
AudioSamplingRate Property
Accesses Audio Sampling Rate IPTC dataset.
AudioSamplingResolution Property
Accesses Audio Sampling Resolution IPTC dataset.
AudioType Property
Accesses Audio Type IPTC dataset.
BitsPerComponent Property
Accesses Bits Per Component IPTC dataset.
ByLine Property
Accesses By Line IPTC dataset.
ByLineTitle Property
Accesses By Line Title IPTC dataset.
Caption_Abstract Property
Accesses Caption/Abstract IPTC dataset.
Category Property
Accesses Category IPTC dataset.
City Property
Accesses City IPTC dataset.
CodedCharacterSet Property
Accesses Coded Character Set IPTC dataset.
ColourCalibrationMatrixTable Property
Accesses Colour Calibration Matrix Table IPTC dataset.
ColourPalette Property
Accesses Colour Palette IPTC dataset.
ColourRepresentation Property
Accesses Colour Representation IPTC dataset.
ColourSequence Property
Accesses Colour Sequence IPTC dataset.
ConfirmedObjectDataSize Property
Accesses Confirmed Object Data Size IPTC dataset.
Contact Property
Accesses Contact IPTC dataset.
ContentLocationCode Property
Accesses Content Location Code IPTC dataset.
ContentLocationName Property
Accesses Content Location Name IPTC dataset.
CopyrightNotice Property
Accesses Copyright Notice IPTC dataset.
CountryPrimaryLocationCode Property
Accesses Country Primary Location Code IPTC dataset.
CountryPrimaryLocationName Property
Accesses Country Primary Location Name IPTC dataset.
Credit Property
Accesses Credit IPTC dataset.
DataCompressionMethod Property
Accesses Data Compression Method IPTC dataset.
DateCreated Property
Accesses Date Created IPTC dataset.
DateSent Property
Accesses Date Sent IPTC dataset.
Destination Property
Accesses Destination IPTC dataset.
DigitalCreationDate Property
Accesses Digital Creation Date IPTC dataset.
DigitalCreationTime Property
Accesses Digital Creation Time IPTC dataset.
EditorialUpdate Property
Accesses Editorial Update IPTC dataset.
EditStatus Property
Accesses Edit Status IPTC dataset.
EndPoints Property
Accesses End Points IPTC dataset.
EnvelopeNumber Property
Accesses Envelope Number IPTC dataset.
EnvelopePriority Property
Accesses Envelope Priority IPTC dataset.
ExcursionTolerance Property
Accesses Excursion Tolerance IPTC dataset.
ExpirationDate Property
Accesses Expiration Date IPTC dataset.
ExpirationTime Property
Accesses Expiration Time IPTC dataset.
FileFormat Property
Accesses File Format IPTC dataset.
FileFormatVersion Property
Accesses File Format Version IPTC dataset.
FixtureIdentifier Property
Accesses Fixture Identifier IPTC dataset.
GammaCompensatedValue Property
Accesses Gamma Compensated Value IPTC dataset.
Headline Property
Accesses Headline IPTC dataset.
ICCInputColourProfile Property
Accesses ICC Input Colour Profile IPTC dataset.
ImageOrientation Property
Accesses Image Orientation IPTC dataset.
ImageRotation Property
Accesses Image Rotation IPTC dataset.
ImageType Property
Accesses Image Type IPTC dataset.
InterchangeColourSpace Property
Accesses Interchange Colour Space IPTC dataset.
Keywords Property
Accesses Keywords IPTC dataset.
LanguageIdentifier Property
Accesses Language Identifier IPTC dataset.
LookupTable Property
Accesses Lookup Table IPTC dataset.
MaximumDensityRange Property
Accesses Maximum Density Range IPTC dataset.
MaximumObjectDataSize Property
Accesses Maximum Object Data Size IPTC dataset.
MaxSubfileSize Property
Accesses Max Subfile Size IPTC dataset.
ModelVersion Property
Accesses Model Version IPTC dataset.
NumberOfBitsPerSample Property
Accesses Number Of Bits Per Sample IPTC dataset.
NumberOfIndexEntries Property
Accesses Number Of Index Entries IPTC dataset.
NumberOfLines Property
Accesses Number Of Line IPTC dataset.
ObjectAttributeReference Property
Accesses Object Attribute Reference IPTC dataset.
ObjectCycle Property
Accesses Object Cycle IPTC dataset.
ObjectDataPreviewData Property
Accesses Object Data Preview Data IPTC dataset.
ObjectDataPreviewFileFormatVersion Property
Accesses Object Data Preview File Format Version IPTC dataset.
ObjectDataSizeAnnounced Property
Accesses Object Data Size Announced IPTC dataset.
ObjectName Property
Accesses Object Name IPTC dataset.
ObjectTypeReference Property
Accesses Object Type Reference IPTC dataset.
OriginalTransmissionReference Property
Accesses Original Transmission Reference IPTC dataset.
OriginatingProgram Property
Accesses Originating Program IPTC dataset.
PictureNumber Property
Accesses Picture Number IPTC dataset.
PixelSizeInScanningDirection Property
Accesses Pixel Size In Scanning Direction IPTC dataset.
PixelSizePerpendicularToScanningDirection Property
Accesses Pixel Size Perpendicular To Scanning Direction IPTC dataset.
PixelsPerLine Property
Accesses Pixels Per Line IPTC dataset.
ProductID Property
Accesses ProductID IPTC dataset.
ProgramVersion Property
Accesses Program Version IPTC dataset.
ProvinceState Property
Accesses Province State IPTC dataset.
QuantisationMethod Property
Accesses Quantisation Method IPTC dataset.
RasterizedCaption Property
Accesses Rasterized Caption IPTC dataset.
Record2Version Property
Accesses Record2 Version IPTC dataset.
Record3Version Property
Accesses Record3 Version IPTC dataset.
ReferenceDate Property
Accesses Reference Date IPTC dataset.
ReferenceNumber Property
Accesses Reference Number IPTC dataset.
ReferenceService Property
Accesses Reference Service IPTC dataset
ReleaseDate Property
Accesses Release Date IPTC dataset.
ReleaseTime Property
Accesses Release Time IPTC dataset.
SamplingStructure Property
Accesses Sampling Structure IPTC dataset.
ScanningDirection Property
Accesses Scanning Direction IPTC dataset.
ServiceIdentifier Property
Accesses Service Identifier IPTC dataset.
SizeMode Property
Accesses Size Mode IPTC dataset.
Source Property
Accesses Source IPTC dataset.
SpecialInstructions Property
Accesses Special Instructions IPTC dataset.
SubjectReference Property
Accesses Subject Reference IPTC dataset.
Sublocation Property
Accesses Sublocation IPTC dataset.
SupplementalCategory Property
Accesses Supplemental Category IPTC dataset.
SupplementType Property
Accesses Supplement Type IPTC dataset.
TimeCreated Property
Accesses Time Created IPTC dataset.
TimeSent Property
Accesses Time Sent IPTC dataset.
UNO Property
Accesses UNO IPTC dataset.
Urgency Property
Accesses Urgency IPTC dataset.
Writer_Editor Property
Accesses Writer/Editor IPTC dataset.


ActionAdvised Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Action Advised IPTC DataSet (2:42). The dataset indicates the type of action that this object provides to a previous object.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCActionAdvised? ActionAdvised { set; get; }

Value:

Nullable (boxed) ImGearIPTCActionAdvised Enumeration value.

See Also:

ImGearIPTCActionAdvised Enumeration


ARMIdentifier Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ARM Identifier IPTC DataSet (1:120). The DataSet identifies the Abstract Relationship Method (ARM), which is described in a document registered by the originator of the ARM with the IPTC and NAA.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public ushort? ARMIdentifier { set; get; }

Value:

Nullable (boxed) ushort value.


ARMVersion Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ARM Version IPTC DataSet (1:122). The DataSet represents the particular version of the ARM specified in DataSet 1:120.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public ushort? ARMVersion { set; get; }

Value:

Nullable (boxed) ushort value.


AudioDuration Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Audio Duration IPTC DataSet (2:153). The DataSet designates in the form HHMMSS the running time of an audio object data when played back at the speed at which it was recorded.

Contains six bytes, consisting of numeric characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string AudioDuration { set; get; }

Value:

string value.


AudioOutcue Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Audio Outcue IPTC DataSet (2:154). The DataSet identifies the content of the end of an audio objectdata, according to guidelines established by the provider.

Maximum 64 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string AudioOutcue { set; get; }

Value:

string value.


AudioSamplingRate Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Audio Sampling Rate DataSet (2:151). The DataSet represents the sampling rate in hertz (Hz).

Six bytes with leading zero(s), consisting of numeric characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string AudioSamplingRate { set; get; }

Value:

string value.


AudioSamplingResolution Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Audio Sampling Resolution DataSet (2:152). The DataSet represents the number of bits in each audio sample.

Contains two bytes with leading zero(s), consisting of numeric characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string AudioSamplingResolution { set; get; }

Value:

string value.


AudioType Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Audio Type DataSet (2:150). The DataSet represents the number of audio channels and the exact type of audio contained in the current objectdata.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCAudioType? AudioType { set; get; }

Value:

Nullable (boxed) ImGearIPTCAudioType Structure value.

See Also:

ImGearIPTCAudioType Structure


BitsPerComponent Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Bits Per Component DataSet (3:135). The DataSet contains a sequence of one or more bytes describing the number of bits used to encode each component. The sequence is specified by the order of components in DataSet 3:65.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Declaration:

public byte BitsPerComponent { set; get; }

Value:

Bytes value.


ByLine Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the By-line DataSet (2:80). The DataSet contains the name of the creator of the objectdata, e.g., writer, photographer, or graphic artist.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string[] ByLine { set; get; }

Value:

string[] array.


ByLineTitle Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the By-line Title DataSet (2:85). The DataSet specifies the title of the creator or creators of an objectdata.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string[] ByLineTitle { set; get; }

Value:

string[] array.


Caption_Abstract Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Caption/Abstract DataSet (2:120). The DataSet contains a textual description of the objectdata, particularly used where the object is not text.

Maximum of 2000 bytes, consisting of graphic characters plus carriage-returns, linefeeds, and spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string Caption_Abstract { set; get; }

Value:

string value.


Category Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Category DataSet (2:15). The DataSet identifies the subject of the objectdata in the opinion of the provider.

Maximum three bytes, consisting of alphabetic characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string Category { set; get; }

Value:

string value.


City Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the City DataSet (2:90). The DataSet identifies the city of objectdata origin according to guidelines established by the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string City { set; get; }

Value:

string value.


CodedCharacterSet Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Coded Character Set DataSet (1:90). The DataSet consists of one or more control functions used for the announcement, invocation, or designation of coded character sets. The control functions follow the ISO 2022 standard and may consist of the escape control character and one or more graphic characters.

Contains up to 32 bytes.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string CodedCharacterSet { set; get; }

Value:

string value.


ColourCalibrationMatrixTable Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Colour Calibration Matrix Table DataSet (3:70). The DataSet is no longer required as its contents have been rendered obsolete by the introduction of DataSet P3:66 (ICC Input Colour Profile).

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Declaration:

public byte[] ColourCalibrationMatrixTable { set; get; }

Value:

Array of bytes.


ColourPalette Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Colour Palette DataSet (3:85). The purpose of the Colour Palette is to act as a lookup table mapping the pixel values into the Colour Space defined in Interchange Colour Space DataSet (3:64).

Contains up to 524,288 (4 x 65536 x 2) bytes.

A number of default palettes may be held to be selected according to the device identifier component of the Picture Number 3:10.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Declaration:

public byte[] ColourPalette { set; get; }

Value:

Array of bytes.


ColourRepresentation Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Colour Representation DataSet (3:60). The DataSet specifies the number of image components and the build-up structure of the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCColourRepresentation? ColourRepresentation { set;
get; }

Value:

Nullable (boxed) ImGearIPTCColourRepresentation Structure value.

See Also:

ImGearIPTCColourRepresentation Structure


ColourSequence Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Colour Sequence DataSet (3:65). The DataSet specifies the sequence of the components as they appear in the objectdata.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Declaration:

public byte[] ColourSequence { set; get; }

Value:

Array of bytes.


ConfirmedObjectDataSize Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ConfirmedObjectDataSize DataSet (9:10). The DataSet specifies total size of the objectdata, in bytes, without tags.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public ulong? ConfirmedObjectDataSize { set; get; }

Value:

Nullable (boxed) ulong value.


Contact Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Contact DataSet (2:118). The DataSet identifies the person or organization that can provide further background information on the objectdata.

Repeatable (array items represent repeated values), maximum of 128 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string[] Contact { set; get; }

Value:

Array of strings.


ContentLocationCode Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ContentLocationCode DataSet (2:26). The DataSet indicates the code of a country/geographical location referenced by the content of the object.

Repeatable (array items represent repeated values), 3 bytes consisting of alphabetic characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string[] ContentLocationCode { set; get; }

Value:

Array of strings.


ContentLocationName Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ContentLocationName DataSet (2:27). The DataSet provides a full, publishable name of a country/geographical location referenced by the content of the object, according to guidelines of the provider.

Repeatable (array items represent repeated values), maximum 64 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string[] ContentLocationName { set; get; }

Value:

Array of strings.


CopyrightNotice Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the CopyrightNotice DataSet (2:116). The DataSet contains any necessary copyright notice.

Contains maximum of 128 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string CopyrightNotice { set; get; }

Value:

string value.


CountryPrimaryLocationCode Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Country/PrimaryLocationCode DataSet (2:100). The DataSet indicates the code of the country/primary location where the intellectual property of the objectdata was created, e.g., a photo was taken, an event occured.

Contains three bytes consisting of alphabetic characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string[] CountryPrimaryLocationCode { set; get; }

Value:

Array of strings.


CountryPrimaryLocationName Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Country/PrimaryLocationName DataSet (2:101). The DataSet provides the full, publishable name of the country/primary location where the intellectual property of the objectdata was created, according to guidelines of the provider.

Contains maximum 64 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string[] CountryPrimaryLocationName { set; get; }

Value:

Array of strings.


Credit Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Credit DataSet (2:110). The DataSet identifies the provider of the objectdata, not necessarily the owner/creator.

Contains maximum of 32 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string Credit { set; get; }

Value:

string value.


DataCompressionMethod Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Data Compression Method DataSet (3:110). The DataSet specifies the provider/owner, type, and version of the compression algorithm.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCDataCompressionMethod? DataCompressionMethod {
set; get; }

Value:

Nullable (boxed) ImGearIPTCDataCompressionMethod Enumeration value.

See Also:

ImGearIPTCDataCompressionMethod Enumeration


DateCreated Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the DateCreated DataSet (2:55). The DataSet represented in the form CCYYMMDD to designate the date the intellectual content of the objectdata was created rather than the date of the creation of the physical representation.

Contains eight bytes, consisting of numeric characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string DateCreated { set; get; }

Value:

string value.


DateSent Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Date Sent DataSet (1:70). The DataSet uses the format CCYYMMDD (century, year, month, day) as defined in ISO 8601 to indicate year, month, and day the service sent the material.

Contains eight bytes, consisting of numeric characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string DateSent { set; get; }

Value:

string value.


Destination Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Destination DataSet (1:05). The DataSet is to accommodate some providers who require routing information above the appropriate OSI layers.

Repeatable (array items represent repeated values), maximum 1024 bytes, consisting of sequentially contiguous graphic characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string[] Destination { set; get; }

Value:

Array of strings.


DigitalCreationDate Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the DigitalCreationDate DataSet (2:62). The DataSet represented in the form CCYYMMDD to designate the date the digital representation of the objectdata was created.

Contains eight bytes, consisting of numeric characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string DigitalCreationDate { set; get; }

Value:

string value.


DigitalCreationTime Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the DigitalCreationTime DataSet (2:63). The DataSet is represented in the form HHMMSS±HHMM to designate the time the digital representation of the objectdata was created. Follows ISO 8601 standard.

Contains 11 bytes, consisting of graphic characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string DigitalCreationTime { set; get; }

Value:

string value.


EditorialUpdate Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the EditorialUpdate DataSet (2:08). The DataSet indicates the type of update that this object provides to a previous object.

Contains 2 bytes, consisting of numeric characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string EditorialUpdate { set; get; }

Value:

string value.


EditStatus Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Edit Status DataSet (2:07). The DataSet specifies the status of the objectdata, according to the practice of the provider.

Maximum 64 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string EditStatus { set; get; }

Value:

string value.


EndPoints Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the EndPoints DataSet (3:125). The DataSet contains the values representing minimum and maximum density for each component.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Declaration:

public byte[] EndPoints { set; get; }

Value:

Array of bytes.


EnvelopeNumber Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the EnvelopeNumber DataSet (1:40). Characters of the DataSet form a number that will be unique for the date specified in 1:70 and for the Service Identifier specified in 1:30.

Contains eight bytes, consisting of numeric characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string EnvelopeNumber { set; get; }

Value:

string value.


EnvelopePriority Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the EnvelopePriority DataSet (1:60). The DataSet specifies the envelope handling priority and not the editorial urgency (see 2:10, Urgency). '1' indicates the most urgent, '5' the normal urgency, and '8' the least urgent copy. The numeral '9' indicates a User Defined Priority. The numeral '0' is reserved for future use.

Contains a single byte, consisting of a numeric character.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string EnvelopePriority { set; get; }

Value:

string value.


ExcursionTolerance Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ExcursionTolerance DataSet (3:130). The DataSet indicates if values outside the range defined by the end points in DataSet 3:125 may occur.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCExcursionTolerance? ExcursionTolerance { set; get;
}

Value:

Nullable (boxed) ImGearIPTCExcursionTolerance Enumeration value.

See Also:

ImGearIPTCExcursionTolerance Enumeration


ExpirationDate Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ExpirationDate DataSet (2:37). The DataSet designates in the form CCYYMMDD the latest date the provider or owner intends the objectdata to be used.

Contains eight bytes, consisting of numeric characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string ExpirationDate { set; get; }

Value:

string value.


ExpirationTime Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ExpirationTime DataSet (2:38). The DataSet designates in the form HHMMSS±HHMM the latest time the provider or owner intends the objectdata to be used.

Contains 11 bytes, consisting of graphic characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string ExpirationTime { set; get; }

Value:

string value.


FileFormat Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the File Format DataSet (1:20). The DataSet represents the file format. The file format must be registered with IPTC or NAA with a unique number. The information is used to route the data to the appropriate system and to allow the receiving system to perform the appropriate actions thereto.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCFileFormatID? FileFormat { set; get; }

Value:

Nullable (boxed) ImGearIPTCFileFormatID Enumeration value.

See Also:

ImGearIPTCFileFormatID Enumeration


FileFormatVersion Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the File Format Version DataSet (1:22). The DataSet contains a binary number representing the particular version of the File Format specified in 1:20.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public ushort? FileFormatVersion { set; get; }

Value:

Nullable (boxed) ushort value.


FixtureIdentifier Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Fixture Identifier DataSet (2:22). The DataSet identifies objectdata that recurs often and predictably. Enables users to immediately find or recall such an object.

Contains maximum 32 bytes, consisting of graphic characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string FixtureIdentifier { set; get; }

Value:

string value.


GammaCompensatedValue Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GammaCompensatedValue DataSet (3:145). The DataSet specifies the value of gamma for the device multiplied by 100. If this DataSet is omitted, receiving equipment should assume that a gamma value of 2.22 applies.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Declaration:

public ushort? GammaCompensatedValue { set; get; }

Value:

Nullable (boxed) ushort value.


Headline Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Headline DataSet (2:105). The DataSet contains a publishable entry providing a synopsis of the contents of the objectdata.

Contains maximum of 256 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string Headline { set; get; }

Value:

string value.


ICCInputColourProfile Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ICC InputColourProfile DataSet (3:66). The DataSet specifies the International Color Consortium profile for the scanning/source device used to generate the digital image files.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Declaration:

public byte[] ICCInputColourProfile { set; get; }

Value:

Array of bytes.


ImageOrientation Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ImageOrientation DataSet (2:131). The DataSet indicates the layout of the image area.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCImageOrientation? ImageOrientation { set; get; }

Value:

Nullable (boxed) ImGearIPTCImageOrientation Enumeration value.

See Also:

ImGearIPTCImageOrientation Enumeration


ImageRotation Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ImageRotation DataSet (3:102). The DataSet indicates the clockwise rotation applied to the image for presentation.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCImageRotation? ImageRotation { set; get; }

Value:

Nullable (boxed) ImGearIPTCImageRotation Enumeration value.

See Also:

ImGearIPTCImageRotation Enumeration


ImageType Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Image Type DataSet (2:130). The DataSet specifies whether the objectdata contains an image or a supplemental object, number of channels in the image and exact content of the objectdata in terms of colour composition.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCImageType? ImageType { set; get; }

Value:

Nullable (boxed) ImGearIPTCImageType Structure value.

See Also:

ImGearIPTCImageType Structure


InterchangeColourSpace Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the InterchangeColourSpace DataSet (3:64). The DataSet indicates the colour space in which the pixel values are expressed for each component in the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCInterchangeColourSpace? InterchangeColourSpace {
set; get; }

Value:

Nullable (boxed) ImGearIPTCInterchangeColourSpace Enumeration value.

See Also:

ImGearIPTCInterchangeColourSpace Enumeration


Keywords Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Keywords DataSet (2:25). The DataSet indicates specific information retrieval words.

Repeatable (array items represent repeated values), maximum 64 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string[] Keywords { set; get; }

Value:

Array of strings.


LanguageIdentifier Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Language Identifier DataSet (2:135). The DataSet describes the major national language of the object, according to the 2-letter codes of ISO 639:1988.

Contains two or three bytes, consisting of alphabetic characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string LanguageIdentifier { set; get; }

Value:

string value.


LookupTable Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the LookupTable DataSet (3:80). The DataSet consists of one, three or four one-dimensional lookup tables (LUT).The LUT relates to the image data in the colour space defined in DataSet 3:64 and specifies the correction to apply to the pixel values before display or printing of the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Declaration:

public byte[] LookupTable { set; get; }

Value:

Array of bytes.


MaximumDensityRange Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the MaximumDensityRange DataSet (3:140). The DataSet represents the difference between the lowest density and the highest density points that can be encoded by the originating system.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Declaration:

public ushort? MaximumDensityRange { set; get; }

Value:

Nullable (boxing) ushort value.


MaximumObjectDataSize Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the MaximumObjectDataSize DataSet (7:95). When objectdata size is not known, the DataSet indicates the largest size, expressed in bytes, that the objectdata can possibly have, not including tags.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public ulong? MaximumObjectDataSize { set; get; }

Value:

Nullable (boxing) ulong value.


MaxSubfileSize Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Max SubfileSize DataSet (7:20). The DataSet indicates the maximum size for the following Subfile DataSet(s).

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public ulong? MaxSubfileSize { set; get; }

Value:

Nullable (boxing) ulong value.


ModelVersion Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Model Version DataSet (1:00). The DataSet identifies the version of the Information Interchange Model, Part I, utilized by the provider.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public ushort? ModelVersion { set; get; }

Value:

Nullable (boxing) ushort value.


NumberOfBitsPerSample Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Number of Bits per Sample DataSet (3:86). The DataSet indicates the number of bits per pixel value used as entries in the Colour Palette.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Declaration:

public byte? NumberOfBitsPerSample { set; get; }

Value:

Nullable (boxing) byte value.


NumberOfIndexEntries Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Number of Index Entries DataSet (3:84). The DataSet represents the number of index entries in the DataSet 3:85 (Colour Palette).

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Declaration:

public ushort? NumberOfIndexEntries { set; get; }

Value:

Nullable (boxing) ushort value.


NumberOfLines Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Number of Lines DataSet (3:30). The DataSet represents the number of scan lines comprising the image for the component with the highest resolution.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Declaration:

public ushort? NumberOfLine { set; get; }

Value:

Nullable (boxing) ushort value.


ObjectAttributeReference Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ObjectAttributeReference DataSet (2:04). The DataSet defines the nature of the object independent of the Subject.

Repeatable (array items represent repeated values).

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCObjectAttributeReference[]
ObjectAttributeReference { set; get; }

Value:

ImGearIPTCObjectAttributeReference Structure[] array.

See Also:

ImGearIPTCObjectAttributeReference Structure


ObjectCycle Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Object Cycle DataSet (2:75). The DataSet represents object cycle, virtually only used in North America.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCObjectCycle? ObjectCycle { set; get; }

Value:

Nullable (boxing) ImGearIPTCObjectCycle Enumeration value.

See Also:

ImGearIPTCObjectCycle Enumeration


ObjectDataPreviewData Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ObjectData Preview Data DataSet (2:202).

Maximum size: 256000 bytes.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public byte[] ObjectDataPreviewData { set; get; }

Value:

Array of bytes.


ObjectDataPreviewFileFormat Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ObjectData Preview File Format DataSet (2:200). The DataSet represents the file format of the ObjectData Preview.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public ImGearIPTCFileFormatID? ObjectDataPreviewFileFormat { set; get; }

Value:

Nullable (boxed) ImGearIPTCFileFormatID Enumeration value.


ObjectDataPreviewFileFormatVersion Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ObjectData Preview File Format Version DataSet (2:201). The DataSet represents the particular version of the ObjectData Preview File Format specified in 2:200.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public ushort? ObjectDataPreviewFileFormatVersion { set; get; }

Value:

Nullable (boxing) ushort value.


ObjectDataSizeAnnounced Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ObjectData Size Announced DataSet (7:90). The DataSet represents the overall size of the objectdata, expressed in bytes, not including tags, if that size is known when transfer commences.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public ulong? ObjectDataSizeAnnounced { set; get; }

Value:

Nullable (boxing) ulong value.

See Also:

ImGearIPTCMetadata Class


ObjectName Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Object Name DataSet (2:05). The DataSet used as a shorthand reference for the object.

Maximum 64 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string ObjectName { set; get; }

Value:

string value.


ObjectTypeReference Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Object Type Reference DataSet (2:03). The DataSet is used to distinguish between different types of objects within the IIM.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCObjectTypeReference? ObjectTypeReference { set;
get; }

Value:

Nullable (boxing) ImGearIPTCObjectTypeReference Structure value.

See Also:

ImGearIPTCObjectTypeReference Structure


OriginalTransmissionReference Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Original Transmission Reference DataSet (2:103). The DataSet represents the location of original transmission according to practices of the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string OriginalTransmissionReference { set; get; }

Value:

string value.


OriginatingProgram Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Originating Program DataSet (2:65). The DataSet identifies the type of program used to originate the objectdata.

Maximum of 32 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string OriginatingProgram { set; get; }

Value:

string value.


PictureNumber Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Picture Number DataSet (3:10). The DataSet provides a universally unique reference to an image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCPictureNumber? PictureNumber { set; get; }

Value:

Nullable (boxing) ImGearIPTCPictureNumber Structure value.

See Also:

ImGearIPTCPictureNumber Structure


PixelSizeInScanningDirection Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Pixel Size In Scanning Direction DataSet (3:40). The DataSet indicates the number of pixels per unit length in the scanning direction.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Declaration:

public ushort? PixelSizeInScanningDirection { set; get; }

Value:

Nullable (boxing) ushort value.


PixelSizePerpendicularToScanningDirection Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Pixel Size Perpendicular To Scanning Direction DataSet (3:50). The DataSet indicates the number of pixels per unit length perpendicular to the scanning direction.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Declaration:

public ushort? PixelSizePerpendicularToScanningDirection { set; get; }

Value:

Nullable (boxing) ushort value.


PixelsPerLine Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Pixels Per Line DataSet (3:20). The DataSet represents the number of pixels in a scan line for the component with the highest resolution.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Declaration:

public ushort? PixelsPerLine { set; get; }

Value:

Nullable (boxing) ushort value.


ProductID Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Product I.D. DataSet (1:50). The DataSet allows a provider to identify subsets of its overall service. Used to provide receiving organization data on which to select, route, or otherwise handle data.

Repeatable (array items represent repeated values). Up to 32 bytes, consisting of graphic characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string[] ProductID { set; get; }

Value:

Array of strings.


ProgramVersion Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Program Version DataSet (2:70). The DataSet identifies the version of the program mentioned in Originating Program DataSet (2:65). Invalid if 2:65 is not present.

Maximum of 10 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string ProgramVersion { set; get; }

Value:

string value.


ProvinceState Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Province/State DataSet (2:95). The DataSet identifies Province/State of origin according to guidelines established by the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string ProvinceState { set; get; }

Value:

String value.


QuantisationMethod Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Quantisation Method DataSet (3:120). The DataSet identifies the quantisation law. The relations between different quantisation methods are described in DNPR Guideline 1.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCQuantisationMethod? QuantisationMethod { set; get;
}

Value:

Nullable (boxing) ImGearIPTCQuantisationMethod Enumeration value.

See Also:

ImGearIPTCQuantisationMethod Enumeration


RasterizedCaption Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Rasterized Caption DataSet (2:125). The DataSet contains the rasterized objectdata description and is used where characters that have not been coded are required for the caption.

Contains 7360 bytes, consisting of binary data, one bit per pixel, two value bitmap where 1 (one) represents black and 0 (zero) represents white. Image width 460 pixels and image height 128 pixels. Scanning direction bottom to top, left to right.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public byte[] RasterizedCaption { set; get; }

Value:

Array of bytes.


Record2Version Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Record II Version DataSet (2:00). The DataSet identifies the version of the Information Interchange Model, Part II (Record 2:xx), utilised by the provider. Version numbers are assigned by IPTC and NAA.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public ushort? Record2Version { set; get; }

Value:

Nullable (boxing) ushort value.


Record3Version Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Record Version DataSet (3:00). The DataSet represents the version of the Digital Newsphoto Parameter Record utilized by the provider. Version numbers are assigned by IPTC and NAA.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Declaration:

public ushort? Record3Version { set; get; }

Value:

Nullable (boxing) ushort value.


ReferenceDate Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Reference Date DataSet (2:47). The DataSet identifies the date of a prior envelope to which the current object refers.

Repeatable (array items represent repeated values). Uses the format CCYYMMDD (century, year, month, day) as defined in ISO 8601 to indicate year, month and day.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string[] ReferenceDate { set; get; }

Value:

Array of strings.


ReferenceNumber Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Reference Number DataSet (2:50). The DataSet identifies the Envelope Number of a prior envelope to which the current object refers.

Repeatable (array items represent repeated values), eight bytes, consisting of numeric characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string[] ReferenceNumber { set; get; }

Value:

Array of strings.


ReferenceService Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Reference Service DataSet (2:45). The DataSet identifies the Service Identifier of a prior envelope to which the current object refers.

Repeatable (array items represent repeated values), up to 10 bytes, consisting of graphic characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string[] ReferenceService { set; get; }

Value:

Array of strings.


ReleaseDate Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Release Date DataSet (2:30). The DataSet designates in the form CCYYMMDD the earliest date the provider intends the object to be used. Follows ISO 8601 standard.

Eight bytes, consisting of numeric characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string ReleaseDate { set; get; }

Value:

string value.


ReleaseTime Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Release Time DataSet (2:35). The DataSet designates in the form HHMMSS±HHMM the earliest time the provider intends the object to be used. Follows ISO 8601 standard.

Contains 11 bytes, consisting of graphic characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string ReleaseTime { set; get; }

Value:

string value.


SamplingStructure Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Sampling Structure DataSet (3:90). The DataSet defines the spatial and temporal relationship between pixels.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCSamplingStructure? SamplingStructure { set; get; }

Value:

Nullable (boxing) ImGearIPTCSamplingStructure Enumeration value.

See Also:

ImGearIPTCSamplingStructure Enumeration


ScanningDirection Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Scanning Direction DataSet (3:100). The DataSet indicates the correct relative two dimensional order of the pixels in the objectdata.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCScanningDirection? ScanningDirection { set; get; }

Value:

Nullable (boxing) ImGearIPTCScanningDirection Enumeration value.

See Also:

ImGearIPTCScanningDirection Enumeration


ServiceIdentifier Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Service Identifier DataSet (1:30). The DataSet identifies the provider and product.

Contains up to 10 bytes, consisting of graphic characters.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string ServiceIdentifier { set; get; }

Value:

string value.


SizeMode Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Size Mode DataSet (7:10). The DataSet indicates whether the size of the objectdata is known at the beginning of transfer.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCSizeMode? SizeMode { set; get; }

Value:

Nullable (boxing) ImGearIPTCSizeMode Enumeration value.

See Also:

ImGearIPTCSizeMode Enumeration


Source Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Source DataSet (2:115). The DataSet identifies the original owner of the intellectual content of the objectdata. This could be an agency, a member of an agency or an individual.

Maximum of 32 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string Source { set; get; }

Value:

string value.


SpecialInstructions Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Special Instructions DataSet (2:40). The DataSet contains other editorial instructions concerning the use of the objectdata, such as embargoes and warnings.

Maximum 256 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string SpecialInstructions { set; get; }

Value:

string value.


SubjectReference Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Subject Reference DataSet (2:12). The DataSet represents a structured definition of the subject matter.

Repeatable (array items represent repeated values).

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCSubjectReference[] SubjectReference { set; get; }

Value:

ImGearIPTCSubjectReference Structure[] array.

See Also:

ImGearIPTCSubjectReference Structure


Sublocation Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Sublocation DataSet (2:92). The DataSet identifies the location within a city from which the objectdata originates, according to guidelines established by the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string Sublocation { set; get; }

Value:

string value.


SupplementalCategory Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Supplemental Category DataSet (2:20). The DataSet further refines the subject of an objectdata.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string[] SupplementalCategory { set; get; }

Value:

Array of strings.


SupplementType Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Supplement Type. DataSet (3:55). The DataSet indicates the image content.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCSupplementType? SupplementType { set; get; }

Value:

Nullable (boxing) ImGearIPTCSupplementType Enumeration value.

See Also:

ImGearIPTCSupplementType Enumeration


TimeCreated Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Time Created DataSet (2:60). The DataSet designates the time the intellectual content of the objectdata current source material was created rather than the creation of the physical representation.

Contains 11 bytes, consisting of graphic characters. Represented in the form HHMMSS±HHMM. Follows ISO 8601 standard.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string TimeCreated { set; get; }

Value:

string value.


TimeSent Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Time Sent DataSet (1:80). The DataSet indicates the time the service sent the material.

Contains 11 bytes, consisting of graphic characters. Uses the format HHMMSS±HHMM where HHMMSS refers to local hour, minute, and seconds and HHMM refers to hours and minutes ahead (+) or behind (-) Universal Coordinated Time as described in ISO 8601.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string TimeSent { set; get; }

Value:

string value.


UNO Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the UNO DataSet (1:100). The UNO (Unique Name of Object) DataSet provides eternal, globally unique identification for objects as specified in the IIM, independent of provider and for any media form. The provider must ensure the UNO is unique. Objects with the same UNO are identical.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCUNO? UNO { set; get; }

Value:

Nullable (boxing) ImGearIPTCUNO Structure object.

See Also:

ImGearIPTCUNO Structure


Urgency Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Urgency DataSet (2:10). The DataSet Specifies the editorial urgency of content and not necessarily the envelope handling priority.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string Urgency { set; get; }

Value:

string value.


Writer_Editor Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Writer/Editor DataSet (2:122). The DataSet contains identification of the name of the person involved in the writing, editing, or correcting the objectdata or caption/abstract.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Declaration:

public string[] Writer_Editor { set; get; }

Value:

Array of strings.


ImageGear.Formats.IPTC Namespace Structures

The ImageGear.Formats.IPTC Namespace has the following structure members:

Structures:
Name
Description
ImGearIPTCAudioType Structure
Represents IPTC Audio Type structure.
ImGearIPTCColourRepresentation Structure
Represents IPTC Colour Representation structure.
ImGearIPTCImageType Structure
Represents IPTC Image Type structure.
ImGearIPTCObjectAttributeReference Structure
Represents IPTC Object Attribute Reference structure.
ImGearIPTCObjectTypeReference Structure
Represents IPTC Object Type Reference structure.
ImGearIPTCPictureNumber Structure
Represents IPTC Picture Number structure.
ImGearIPTCSubjectReference Structure
Represents IPTC Subject Reference structure.
ImGearIPTCUNO Structure
Represents IPTC UNO structure.


ImGearIPTCAudioType Structure

32-bit
64-bit
CF
P
P
P

Description:

This structure represents IPTC Audio Type structure, used in Audio Type DataSet (2:150).

Declaration:

public struct ImGearIPTCAudioType

Members:

Constructors
Name
Description
ImGearIPTCAudioType Constructor
Creates and initializes an instance of ImGearIPTCAudioType Structure.

Properties
Name
Description
ChannelMode Property
Indicates the number of channels.
ContentType Property
Indicates exact type of audio contained in the current objectdata.


ImGearIPTCAudioType Constructors

The ImGearIPTCAudioType Structure of the ImageGear.Formats.IPTC Namespace has the following constructors:

Constructors
Name
Description
ImGearIPTCAudioType Constructor
Creates and initializes an instance of ImGearIPTCAudioType Structure.


ImGearIPTCAudioType Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearIPTCAudioType Structure.

Declaration:

public ImGearIPTCAudioType()

Return Value:

The new instance of ImGearIPTCAudioType Structure.

See Also:

ImGearIPTCAudioType Structure


ImGearIPTCAudioType Properties

The ImGearIPTCAudioType Structure of the ImageGear.Formats.IPTC Namespace has the following properties:

Properties
Name
Description
ChannelMode Property
Indicates the number of channels.
ContentType Property
Indicates exact type of audio contained in the current objectdata.


ChannelMode Property

32-bit
64-bit
CF
P
P
P

Description:

This property indicates the number of channels in the objectdata.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCAudioChannelMode ChannelMode { set; get; }

Value:

ImGearIPTCAudioChannelMode Enumeration value.

See Also:

ImGearIPTCAudioChannelMode Enumeration


ContentType Property

32-bit
64-bit
CF
P
P
P

Description:

This property indicates the exact type of audio contained in the current objectdata.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCAudioContentType ContentType{ set; get; }

Value:

ImGearIPTCAudioContentType Enumeration value.

See Also:

ImGearIPTCAudioContentType Enumeration


ImGearIPTCColourRepresentation Structure

32-bit
64-bit
CF
P
P
P

Description:

This structure represents IPTC Colour Representation structure, used in Colour Representation DataSet (3:60).

Declaration:

public struct ImGearIPTCColourRepresentation

Members:

Constructors
Name
Description
ImGearIPTCColourRepresentation Constructor
Creates and initializes an instance of ImGearIPTCColourRepresentation Structure.

Properties
Name
Description
BuildUpStructure Property
Gives the build-up structure of the image.
NumberOfComponents Property
Specifies the number of components.


ImGearIPTCColourRepresentation Constructors

The ImGearIPTCColourRepresentation Structure of the ImageGear.Formats.IPTC Namespace has the following constructors:

Constructors
Name
Description
ImGearIPTCColourRepresentation Constructor
Creates and initializes an instance of ImGearIPTCColourRepresentation Structure.


ImGearIPTCColourRepresentation Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearIPTCColourRepresentation Structure.

Declaration:

public ImGearIPTCColourRepresentation()

Return Value:

The new instance of ImGearIPTCColourRepresentation Structure.

See Also:

ImGearIPTCColourRepresentation Structure


ImGearIPTCColourRepresentation Properties

The ImGearIPTCColourRepresentation Structure of the ImageGear.Formats.IPTC Namespace has the following properties:

Properties
Name
Description
BuildUpStructure Property
Gives the build-up structure of the image.
NumberOfComponents Property
Specifies the number of components.


BuildUpStructure Property

32-bit
64-bit
CF
P
P
P

Description:

This property gives the build-up structure of the image.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCImageBuildUpStructure BuildUpStructure { set; get;
}

Value:

ImGearIPTCImageBuildUpStructure Enumeration value.

See Also:

ImGearIPTCImageBuildUpStructure Enumeration


NumberOfComponents Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the number of components in the image.

Allowed values are as follows:

0 - No Image

1 - Monochrome

3 - Three components

4 - Four components

Declaration:

public int NumberOfComponents { set; get; }

Value:

int value.


ImGearIPTCImageType Structure

32-bit
64-bit
CF
P
P
P

Description:

This structure represents IPTC Image Type structure, used in Image Type DataSet (2:130).

Declaration:

public struct ImGearIPTCImageType

Members:

Constructors
Name
Description
ImGearIPTCImageType Constructor
Creates and initializes an instance of ImGearIPTCImageType Structure.

Properties
Name
Description
Colour Property
Indicates the exact content of the current objectdata in terms of colour composition.
Component Property
Indicates the number of components in the image, or that the objectdata contains supplementary data or Record 2 caption.


ImGearIPTCImageType Constructors

The ImGearIPTCImageType Structure of the ImageGear.Formats.IPTC Namespace has the following constructors:

Constructors
Name
Description
ImGearIPTCImageType Constructor
Creates and initializes an instance of ImGearIPTCImageType Structure.


ImGearIPTCImageType Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearIPTCImageType Structure.

Declaration:

public ImGearIPTCImageType()

Return Value:

The new instance of ImGearIPTCImageType Structure.

See Also:

ImGearIPTCImageType Structure


ImGearIPTCImageType Properties

The ImGearIPTCImageType Structure of the ImageGear.Formats.IPTC Namespace has the following properties:

Properties
Name
Description
Colour Property
Indicates the exact content of the current objectdata in terms of colour composition.
Component Property
Indicates the number of components in the image, or that the objectdata contains supplementary data or Record 2 caption.


Colour Property

32-bit
64-bit
CF
P
P
P

Description:

This property indicates the exact content of the current objectdata in terms of colour composition.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCImageColourMode Colour { set; get; }

Value:

ImGearIPTCImageColourMode Enumeration value.

See Also:

ImGearIPTCImageColourMode Enumeration


Component Property

32-bit
64-bit
CF
P
P
P

Description:

This property indicates one of the following:

  • Record 2 caption for a specific image
  • Number of components in an image, in single or multiple envelopes
  • The objectdata contains supplementary data to an image (as defined in the Digital Newsphoto Parameter Record DataSet 3:55).

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCImageComponentMode Component { set; get; }

Value:

ImGearIPTCImageComponentMode Enumeration value.

See Also:

ImGearIPTCImageComponentMode Enumeration


ImGearIPTCObjectAttributeReference Structure

32-bit
64-bit
CF
P
P
P

Description:

This structure represents IPTC Object Attribute Reference structure, used in the Object Attribute Reference DataSet (2:04).

Declaration:

public struct ImGearIPTCObjectAttributeReference

Members:

Constructors
Name
Description
ImGearIPTCObjectAttributeReference Constructor
Creates and initializes an instance of ImGearIPTCObjectAttributeReference Structure.

Properties
Name
Description
Name Property
Object Attribute Name.
Number Property
Object Attribute Number.


ImGearIPTCObjectAttributeReference Constructors

The ImGearIPTCObjectAttributeReference Structure of the ImageGear.Formats.IPTC Namespace has the following constructors:

Constructors
Name
Description
ImGearIPTCObjectAttributeReference Constructor
Creates and initializes an instance of ImGearIPTCObjectAttributeReference Structure.


ImGearIPTCObjectAttributeReference Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearIPTCObjectAttributeReference Structure.

Declaration:

public ImGearIPTCObjectAttributeReference()

Return Value:

The new instance of ImGearIPTCObjectAttributeReference Structure.

See Also:

ImGearIPTCObjectAttributeReference Structure


ImGearIPTCObjectAttributeReference Properties

The ImGearIPTCObjectAttributeReference Structure of the ImageGear.Formats.IPTC Namespace has the following properties:

Properties
Name
Description
Name Property
Object Attribute Name.
Number Property
Object Attribute Number.


Name Property

32-bit
64-bit
CF
P
P
P

Description:

This property contains an optional text representation of the Object Attribute Number.

Contains a maximum of 64 bytes consisting of graphic characters plus spaces.

Declaration:

public string Name { set; get; }

Value:

string value.


Number Property

32-bit
64-bit
CF
P
P
P

Description:

This property represents a language independent international reference to an Object Attribute.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCObjectAttributeNumber Number { set; get; }

Value:

ImGearIPTCObjectAttributeNumber Enumeration value.

See Also:

ImGearIPTCObjectAttributeNumber Enumeration


ImGearIPTCObjectTypeReference Structure

32-bit
64-bit
CF
P
P
P

Description:

This structure represents IPTC Object Type Reference structure, used in the Object Type Reference DataSet (2:03). The Object Type is used to distinguish between different types of objects within the IIM.

Declaration:

public struct ImGearIPTCObjectTypeReference

Members:

Constructors
Name
Description
ImGearIPTCObjectTypeReference Constructor
Creates and initializes an instance of ImGearIPTCObjectTypeReference Structure.

Properties
Name
Description
Name Property
Object Type Name.
Number Property
Object Type Number.


ImGearIPTCObjectTypeReference Constructors

The ImGearIPTCObjectTypeReference Structure of the ImageGear.Formats.IPTC Namespace has the following constructors:

Constructors
Name
Description
ImGearIPTCObjectTypeReference Constructor
Creates and initializes an instance of ImGearIPTCObjectTypeReference Structure.


ImGearIPTCObjectTypeReference Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearIPTCObjectTypeReference Structure.

Declaration:

public ImGearIPTCObjectTypeReference()

Return Value:

The new instance of ImGearIPTCObjectTypeReference Structure.

See Also:

ImGearIPTCObjectTypeReference Structure


ImGearIPTCObjectTypeReference Properties

The ImGearIPTCObjectTypeReference Structure of the ImageGear.Formats.IPTC Namespace has the following properties:

Properties
Name
Description
Name Property
Object Type Name.
Number Property
Object Type Number.


Name Property

32-bit
64-bit
CF
P
P
P

Description:

This property contains an optional text representation of the Object Type Number.

Contains a maximum of 64 bytes consisting of graphic characters plus spaces.

Declaration:

public string Name { set; get; }

Value:

string value.


Number Property

32-bit
64-bit
CF
P
P
P

Description:

This property represents a language independent international reference to an Object Type.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCObjectTypeNumber Number { set; get; }

Value:

ImGearIPTCObjectTypeNumber Enumeration value.

See Also:

ImGearIPTCObjectTypeNumber Enumeration


ImGearIPTCPictureNumber Structure

32-bit
64-bit
CF
P
P
P

Description:

This structure represents IPTC Picture Number structure, used in the Picture Number DataSet (3:10). The picture number provides a universally unique reference to an image. For example, color images, when split with color components into multiple objects, i.e., envelopes, would carry the same Picture Number.

Declaration:

public struct ImGearIPTCPictureNumber

Members:

Constructors
Name
Description
ImGearIPTCPictureNumber Constructor
Creates and initializes an instance of ImGearIPTCPictureNumber Structure.

Properties
Name
Description
DateIdentifier Property
Indicates the date the picture number was generated.
DeviceIdentifier Property
Identifies the device that has generated the picture number.
NumericIdentifier Property
A binary number generated each time a picture number is created and being unique for the same device and for the date contained in this DataSet.


ImGearIPTCPictureNumber Constructors

The ImGearIPTCPictureNumber Structure of the ImageGear.Formats.IPTC Namespace has the following constructors:

Constructors
Name
Description
ImGearIPTCPictureNumber Constructor
Creates and initializes an instance of ImGearIPTCPictureNumber Structure.


ImGearIPTCPictureNumber Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearIPTCPictureNumber Structure.

Declaration:

public ImGearIPTCPictureNumber()

Return Value:

The new instance of ImGearIPTCPictureNumber Structure.

See Also:

ImGearIPTCPictureNumber Structure


ImGearIPTCPictureNumber Properties

The ImGearIPTCPictureNumber Structure of the ImageGear.Formats.IPTC Namespace has the following properties:

Properties
Name
Description
DateIdentifier Property
Indicates the date the picture number was generated.
DeviceIdentifier Property
Identifies the device that has generated the picture number.
NumericIdentifier Property
A binary number generated each time a picture number is created and being unique for the same device and for the date contained in this DataSet.


DateIdentifier Property

32-bit
64-bit
CF
P
P
P

Description:

This property contains eight numeric characters using the format CCYYMMDD (century, year, month, day) as defined in ISO 8601 to indicate year, month, and day the picture number was generated.

Declaration:

public string DateIdentifier { set; get; }

Value:

string value.


DeviceIdentifier Property

32-bit
64-bit
CF
P
P
P

Description:

This property contains a binary number identifying the device that has generated the picture number.

Declaration:

public int DeviceIdentifier { set; get; }

Value:

int value.


NumericIdentifier Property

32-bit
64-bit
CF
P
P
P

Description:

This property contains a binary number generated each time a picture number is created and being unique for the same device and for the date contained in this DataSet.

Declaration:

public int NumericIdentifier { set; get; }

Value:

int value.


ImGearIPTCSubjectReference Structure

32-bit
64-bit
CF
P
P
P

Description:

This structure represents IPTC Subject Reference structure, used in the Subject Reference DataSet (2:12). The Subject Reference is a structured definition of the subject matter.

Declaration:

public struct ImGearIPTCSubjectReference

Members:

Constructors
Name
Description
ImGearIPTCSubjectReference Constructor
Creates and initializes an instance of ImGearIPTCSubjectReference Structure.

Properties
Name
Description
IPR Property
Information Provider Reference.
SubjectDetailName Property
Subject Detail Name.
SubjectMatterName Property
Subject Matter Name.
SubjectName Property
Subject Name.
SubjectReferenceNumber Property
Subject Reference Number.


ImGearIPTCSubjectReference Constructors

The ImGearIPTCSubjectReference Structure of the ImageGear.Formats.IPTC Namespace has the following constructors:

Constructors
Name
Description
ImGearIPTCSubjectReference Constructor
Creates and initializes an instance of ImGearIPTCSubjectReference Structure.


ImGearIPTCSubjectReference Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearIPTCSubjectReference Structure.

Declaration:

public ImGearIPTCSubjectReference()

Return Value:

The new instance of ImGearIPTCSubjectReference Structure.

See Also:

ImGearIPTCSubjectReference Structure


ImGearIPTCSubjectReference Properties

The ImGearIPTCSubjectReference Structure of the ImageGear.Formats.IPTC Namespace has the following properties:

Properties
Name
Description
IPR Property
Information Provider Reference.
SubjectDetailName Property
Subject Detail Name.
SubjectMatterName Property
Subject Matter Name.
SubjectName Property
Subject Name.
SubjectReferenceNumber Property
Subject Reference Number.


IPR Property

32-bit
64-bit
CF
P
P
P

Description:

A name, registered with the IPTC/NAA, identifying the provider that provides an indicator of the SDR content. The default value for the IPR is "IPTC" and is mandatory if the Subject Reference exists in the IPTC coding scheme.

Contains 1-32 bytes.

Declaration:

public string IPR { set; get; }

Value:

string value.


SubjectDetailName Property

32-bit
64-bit
CF
P
P
P

Description:

This property contains a text representation of the Subject Detail Number.

Contains a maximum of 64 bytes consisting of graphic characters plus spaces.

Declaration:

public string SubjectDetailName { set; get; }

Value:

string value.


SubjectMatterName Property

32-bit
64-bit
CF
P
P
P

Description:

This property contains a text representation of the Subject Matter Number.

Contains a maximum of 64 bytes consisting of graphic characters plus spaces.

Declaration:

public string SubjectMatterName { set; get; }

Value:

string value.


SubjectName Property

32-bit
64-bit
CF
P
P
P

Description:

This property contains a text representation of the Subject Number.

Contains a maximum of 64 bytes consisting of graphic characters plus spaces.

Declaration:

public string SubjectName { set; get; }

Value:

string value.


SubjectReferenceNumber Property

32-bit
64-bit
CF
P
P
P

Description:

This property provides a numeric code to indicate the Subject Name plus optional Subject Matter and Subject Detail Names in the language of the service.

Declaration:

public ImageGear.Formats.IPTC.ImGearIPTCSubjectReferenceNumber SubjectReferenceNumber {
set; get; }

Value:

ImGearIPTCSubjectReferenceNumber Enumeration value.

See Also:

ImGearIPTCSubjectReferenceNumber Enumeration


ImGearIPTCUNO Structure

32-bit
64-bit
CF
P
P
P

Description:

This structure represents UNO structure, used in the UNO DataSet (1:100). The UNO (Unique Name of Object) provides eternal, globally unique identification for objects as specified in the IIM, independent of provider and for any media form. The provider must ensure the UNO is unique. Objects with the same UNO are identical.

Declaration:

public struct ImGearIPTCUNO

Members:

Constructors
Name
Description
ImGearIPTCUNO Constructor
Creates and initializes an instance of ImGearIPTCUNO Structure.

Properties
Name
Description
IPR Property
Information Provider Reference (IPR).
ODE Property
Object Descriptor Element (ODE).
OVI Property
Object Variant Indicator (OVI).
UCD Property
UNO Creation Date (UCD).


ImGearIPTCUNO Constructors

The ImGearIPTCUNO Structure of the ImageGear.Formats.IPTC Namespace has the following constructors:

Constructors
Name
Description
ImGearIPTCUNO Constructor
Creates and initializes an instance of ImGearIPTCUNO Structure.


ImGearIPTCUNO Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearIPTCUNO Structure.

Declaration:

public ImGearIPTCUNO()

Return Value:

The new instance of ImGearIPTCUNO Structure.

See Also:

ImGearIPTCUNO Structure


ImGearIPTCUNO Properties

The ImGearIPTCUNO Structure of the ImageGear.Formats.IPTC Namespace has the following properties:

Properties
Name
Description
IPR Property
Information Provider Reference (IPR).
ODE Property
Object Descriptor Element (ODE).
OVI Property
Object Variant Indicator (OVI).
UCD Property
UNO Creation Date (UCD).


IPR Property

32-bit
64-bit
CF
P
P
P

Description:

This property represents the IPR element of IPTC UNO structure. The IPR (Information Provider Reference) specifies a name, registered with the IPTC/NAA, identifying the provider that guarantees the uniqueness of the UNO. It may assist in locating an object source.

Contains a minimum of one and a maximum of 32 bytes. A string of graphic characters, except colon `:' solidus `/', asterisk `*' and question mark `?', registered with, and approved by, the IPTC.

Declaration:

public string IPR { set; get; }

Value:

string value.


ODE Property

32-bit
64-bit
CF
P
P
P

Description:

This property represents the ODE element of IPTC UNO structure. The ODE (Object Descriptor Element), in conjunction with the UCD and the IPR, ensures the uniqueness of the UNO. The provider may structure the element by use of a solidus `/' character.

Contains a minimum of one and a maximum of 60 minus the number of IPR bytes, consisting of graphic characters, except colon `:' asterisk `*' and question mark `?'.

Declaration:

public string ODE { set; get; }

Value:

string value.


OVI Property

32-bit
64-bit
CF
P
P
P

Description:

This property represents the OVI element of IPTC UNO structure. The OVI (Object Variant Indicator) indicates technical variants of the object such as partial objects, or changes of file formats, and coded character sets.

Contains a minimum of one and a maximum of 9 bytes, consisting of graphic characters, except colon `:', asterisk `*' and question mark `?'.

Declaration:

public string OVI { set; get; }

Value:

string value.


UCD Property

32-bit
64-bit
CF
P
P
P

Description:

This property represents the UCD element of IPTC UNO structure. The UCD (UNO Creation Date) specifies a 24 hour period in which the further elements of the UNO have to be unique. It also provides a search facility.

Contains 8 bytes in ISO 8601 date format (CCYYMMDD), consisting of numeric characters.

Declaration:

public string UCD { set; get; }

Value:

string value.


ImageGear.Formats.IPTC Namespace Enumerations

The ImageGear.Formats.IPTC Namespace has the following enumeration members:

Enumerations:
Name
Description
ImGearIPTCActionAdvised Enumeration
Represents IPTC Advised Actions
ImGearIPTCAudioChannelMode Enumeration
Represents IPTC Audio Channel Modes
ImGearIPTCAudioContentType Enumeration
Represents IPTC Audio Content Types
ImGearIPTCDataCompressionMethod Enumeration
Represents IPTC Data Compression Methods
ImGearIPTCExcursionTolerance Enumeration
Represents IPTC Excursion Tolerances
ImGearIPTCFileFormatID Enumeration
Represents IPTC File Format IDs
ImGearIPTCImageBuildUpStructure Enumeration
Represents IPTC Image Build Up Structures
ImGearIPTCImageColourMode Enumeration
Represents IPTC Image Colour Modes
ImGearIPTCImageComponentMode Enumeration
Represents IPTC Image Component Modes
ImGearIPTCImageOrientation Enumeration
Represents IPTC Image Orientations
ImGearIPTCImageRotation Enumeration
Represents IPTC Image Rotations
ImGearIPTCInterchangeColourSpace Enumeration
Represents IPTC Interchange Colour Spaces
ImGearIPTCObjectAttributeNumber Enumeration
Represents IPTC Object Attribute Numbers
ImGearIPTCObjectCycle Enumeration
Represents IPTC Object Cycles
ImGearIPTCObjectTypeNumber Enumeration
Represents IPTC Object Type Numbers
ImGearIPTCQuantisationMethod Enumeration
Represents IPTC Quantisation Methods
ImGearIPTCSamplingStructure Enumeration
Represents IPTC Sampling Structures
ImGearIPTCScanningDirection Enumeration
Represents IPTC Scanning Directions
ImGearIPTCSizeMode Enumeration
Represents IPTC Size Modes
ImGearIPTCSubjectReferenceNumber Enumeration
Represents IPTC Subject Reference Numbers
ImGearIPTCSupplementType Enumeration
Represents IPTC Supplement Types


ImGearIPTCActionAdvised Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents IPTC Advised Actions.

Declaration:

public enum ImGearIPTCActionAdvised

Values:

Name
Value
Description
ObjectKill
1
Object Kill
ObjectReplace
2
Object Replace
ObjectAppend
3
Object Append
ObjectReference
4
Object Reference


ImGearIPTCAudioChannelMode Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents IPTC Audio Channel Modes.

Declaration:

public enum ImGearIPTCAudioChannelMode

Values:

Name
Value
Description
NoObjectdata
0
No Objectdata
Monaural
1
Monaural (1 channel) audio
Stereo
2
Stereo (2 channel) audio.


ImGearIPTCAudioContentType Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents IPTC Audio Content Types.

Declaration:

public enum ImGearIPTCAudioContentType

Values:

Name
Value
Description
Actuality
Actuality
QuestionAndAnswerSession
Question and answer session
MusicTransmittedByItself
Music, transmitted by itself
ResponseToAQuestion
Response to a question
RawSound
Raw sound
Scener
Scener
TextOnly
Text only
Voicer
Voicer
Wrap
Wrap


ImGearIPTCDataCompressionMethod Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents IPTC Data Compression Methods.

Declaration:

public enum ImGearIPTCDataCompressionMethod

Values:

Name
Value
Description
JPEG
0x0111
JPEG ITU-T Rec T.81 /ISO/IEC 10918-1
JFIF_1_01
0x0121
JFIF 1.01
JFIF_1_02
0x0122
JFIF 1.02
Hasselblad_2
0x0221
Hasselblad type 2
Hasselblad_3
0x0231
Hasselblad type 3


ImGearIPTCExcursionTolerance Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents IPTC Excursion Tolerance modes.

Declaration:

public enum ImGearIPTCExcursionTolerance

Values:

Name
Value
Description
NotAllowed
0
Not allowed
MayOccur
1
May occur


ImGearIPTCFileFormatID Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents IPTC File Format IDs.

Declaration:

public enum ImGearIPTCFileFormatID

Values:

Name
Value
Description
NoObjectData
0
No ObjectData
IPTCNAADigitalNewsphotoParameterRecord
01
IPTC-NAA Digital Newsphoto Parameter Record
IPTC7901RecommendedMessageFormat
02
IPTC7901 Recommended Message Format
TIFF
03
Tagged Image File Format (Adobe/Aldus Image data)
Illustrator
04
Illustrator (Adobe Graphics data)
AppleSingle
05
AppleSingle (Apple Computer Inc)
NAA_89_3_ANPA_1312
06
NAA 89-3 (ANPA 1312)
MacBinaryII
07
MacBinary II
UCOFF
08
IPTC Unstructured Character Oriented File Format (UCOFF)
UPI_ANPA_1312_Variant
09
United Press International ANPA 1312 variant
UPIDownLoadMessage
10
United Press International Down-Load Message
JFIF
11
JPEG File Interchange (JFIF)
PhotoCD
12
Photo-CD Image-Pac (Eastman Kodak)
BMP
13
Microsoft Bit Mapped Graphics File [*.BMP]
WAV
14
Digital Audio File [*.WAV] (Microsoft & Creative Labs)
AVI
15
Audio plus Moving Video [*.AVI] (Microsoft)
Executable
16
PC DOS/Windows Executable Files [*.COM][*.EXE]
ZIP
17
Compressed Binary File [*.ZIP] (PKWare Inc)
AIFF
18
Audio Interchange File Format AIFF (Apple Computer Inc)
RIFFWave
19
RIFF Wave (Microsoft Corporation)
Freehand
20
Freehand (Macromedia/Aldus)
HTML
21
Hypertext Markup Language "HTML" (The Internet Society)
MPEG2AudioLayer2
22
MPEG 2 Audio Layer 2 (Musicom)
MPEG2AudioLayer3
23
MPEG 2 Audio Layer 3
PDF
24
Portable Document File (*.PDF) Adobe
NITF
25
News Industry Text Format (NITF)
TAR
26
Tape Archive (*.TAR)
TTNITF
27
Tidningarnas Telegrambyrå NITF version (TTNITF DTD)
RBNITF
28
Ritzaus Bureau NITF version (RBNITF DTD)
CorelDraw
29
Corel Draw [*.CDR]


ImGearIPTCImageBuildUpStructure Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents IPTC Image Build Up Structures.

Declaration:

public enum ImGearIPTCImageBuildUpStructure

Values:

Name
Value
Description
SingleFrame
0
Single Frame
FrameSequentialInMultipleObjects
1
Frame Sequential In Multiple Objects
FrameSequentialInOneObject
2
Frame Sequential In One Object
LineSequential
3
Line Sequential
PixelSequential
4
Pixel Sequential
SpecialInterleavingStructure
5
Special Interleaving Structure


ImGearIPTCImageColourMode Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents IPTC Image Colour Modes.

Declaration:

public enum ImGearIPTCImageColourMode

Values:

Name
Value
Description
Monochrome
Monochrome
YellowComponent
Yellow Component
MagentaComponent
Magenta Component
CyanComponent
Cyan Component
BlackComponent
Black Component
RedComponent
Red Component
GreenComponent
Green Component
BlueComponent
Blue Component
TextOnly
Text Only
FullColourCompositeFrameSequential
Full Colour Composite Frame Sequential
FullColourCompositeLineSequential
Full Colour Composite Line Sequential
FullColourCompositePixelSequential
Full Colour Composite Pixel Sequential
FullColourCompositeSpecialInterleaving
Full Colour Composite Special Interleaving


ImGearIPTCImageComponentMode Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents IPTC Image Component Modes.

Declaration:

public enum ImGearIPTCImageComponentMode

Values:

Name
Value
Description
NoObjectData
0
No Objectdata
SingleComponent
1
Single Component
MultiComponent2
2
2 components
MultiComponent3
3
3 components
MultiComponent4
4
4 conponents
SupplementalObjects
9
Supplemental objects


ImGearIPTCImageOrientation Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents IPTC Image Orientations.

Declaration:

public enum ImGearIPTCImageOrientation

Values:

Name
Value
Description
Portrait
Portrait
Landscape
Landscape
Square
Square


ImGearIPTCImageRotation Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration

Declaration:

public enum ImGearIPTCImageRotation

Values:

Name
Value
Description
NoRotation
0
No rotation
Rotation90Degrees
1
90 degrees rotation
Rotation180Degrees
2
180 degrees rotation
Rotation270Degrees
3
270 degrees rotation


ImGearIPTCInterchangeColourSpace Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents IPTC Interchange Colour Spaces.

Declaration:

public enum ImGearIPTCInterchangeColourSpace

Values:

Name
Value
Description
CIEXYZ
1
X,Y,Z CIE colour space (default illuminant D50)
SMPTERGB
2
RGB SMPTE
YUV_K
3
Y,U,V (K) (default illuminant D65)
DeviceDependentRGB
4
RGB device dependent
DeviceDependentCMYK
5
CMY(K) device dependent
CIELab_K
6
L*a*b* (K) CIE colour space (default illuminant D50)
YCbCr
7
YCbCr
sRGB
8
sRGB


ImGearIPTCObjectAttributeNumber Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents IPTC Object Attribute Numbers.

Declaration:

public enum ImGearIPTCObjectAttributeNumber

Values:

Name
Value
Description
Current
1
Current
Analysis
2
Analysis
ArchiveMaterial
3
Archive Material
Background
4
Background
Feature
5
Feature
Forecast
6
Forecast
History
7
History
Obituary
8
Obituary
Opinion
9
Opinion
PollsAndSurveys
10
Polls And Surveys
Profile
11
Profile
ResultsListingsAndTables
12
Results Listings And Tables
SideBarAndSupportingInformation
13
Side Bar And Supporting Information
Summary
14
Summary
TranscriptAndVerbatim
15
Transcript And Verbatim
Interview
16
Interview
FromTheScene
17
From The Scene
Retrospective
18
Retrospective
Statistics
19
Statistics
Update
20
Update
WrapUp
21
Wrap Up
PressRelease
22
Press Release


ImGearIPTCObjectCycle Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents IPTC Object Cycles.

Declaration:

public enum ImGearIPTCObjectCycle

Values:

Name
Value
Description
Morning
Morning
Evening
Evening
Both
Both


ImGearIPTCObjectTypeNumber Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents IPTC Object Type Numbers.

Declaration:

public enum ImGearIPTCObjectTypeNumber

Values:

Name
Value
Description
News
1
News
Data
2
Data
Advisory
3
Advisory


ImGearIPTCQuantisationMethod Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents IPTC Quantisation Methods.

Declaration:

public enum ImGearIPTCQuantisationMethod

Values:

Name
Value
Description
LinearReflectance_Transmittance
0
Linear Reflectance/Transmittance
LinearDensity
1
Linear Density
IPTCRefB
2
IPTC Ref B
LinearDotPercent
3
Linear Dot Percent
APDomesticAnalogue
4
AP Domestic Analogue
CompressionMethodSpecific
5
Compression Method Specific
ColourSpaceSpecific
6
Colour Space Specific
GammaCompensated
7
Gamma Compensated


ImGearIPTCSamplingStructure Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents IPTC Sampling Structures.

Declaration:

public enum ImGearIPTCSamplingStructure

Values:

Name
Value
Description
Orthogonal
0
Orthogonal with the same relative sampling frequencies on each component.
Orthogonal_422_4
1
Orthogonal with the sampling frequencies in the ratio of 4:2:2:(4) as described in Appendix G. This structure can only be used with the YUV(K) or LAB(K) colour spaces.
DefinedWithinCompressionProcess
2
Defined within the compression process.


ImGearIPTCScanningDirection Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents IPTC Scanning Directions.

Declaration:

public enum ImGearIPTCScanningDirection

Values:

Name
Value
Description
LeftToRight_TopToBottom
0
Left To Right, Top To Bottom
RightToLeft_TopToBottom
1
Right To Left, Top To Bottom
LeftToRight_BottomToTop
2
Left To Right, Bottom To Top
RightToLeft_BottomToTop
3
Right To Left, Bottom To Top
TopToBottom_LeftToRight
4
Top To Bottom, Left To Right
BottomToTop_LeftToRight
5
Bottom To Top, Left To Right
TopToBottom_RightToLeft
6
Top To Bottom, Right To Left
BottomToTop_RightToLeft
7
Bottom To Top, Right To Left


ImGearIPTCSizeMode Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents IPTC Size Modes.

Declaration:

public enum ImGearIPTCSizeMode

Values:

Name
Value
Description
NotKnown
0
Size is not known
Known
1
Size is known


ImGearIPTCSubjectReferenceNumber Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents IPTC Subject Reference Numbers.

Declaration:

public enum ImGearIPTCSubjectReferenceNumber

Values:

Name
Value
Description
ArtsCultureEntertainment
01000000
Arts, Culture & Entertainment
CrimeLawJustice
02000000
Crime, Law & Justice
DisastersAccidents
03000000
Disasters & Accidents
EconomyBusinessFinance
04000000
Economy, Business & Finance
Education
05000000
Education
EnvironmentalIssues
06000000
Environmental Issues
Health
07000000
Health
HumanInterest
08000000
Human Interest
Labour
09000000
Labour
LifestyleAndLeisure
10000000
Lifestyle & Leisure
Politics
11000000
Politics
ReligionAndBelief
12000000
Religion & Belief
ScienceAndTechnology
13000000
Science & Technology
SocialIssues
14000000
Social Issues
Sport
15000000
Sport
UnrestConflictsWar
16000000
Unrest, Conflicts & War
Weather
17000000
Weather
Archaeology
01001000
Archaeology
Architecture
01002000
Architecture
Bullfighting
01003000
Bullfighting
Carnival
01004000
Carnival
Cinema
01005000
Cinema
Dance
01006000
Dance
Fashion
01007000
Fashion
Language
01008000
Language
LibrariesAndMuseums
01009000
Libraries & Museums
Literature
01010000
Literature
Music
01011000
Music
Painting
01012000
Painting
Photography
01013000
Photography
Radio
01014000
Radio
Sculpture
01015000
Sculpture
Television
01016000
Television
Theatre
01017000
Theatre
Crime
02001000
Crime
Judiciary
02002000
Judiciary
Police
02003000
Police
Punishment
02004000
Punishment
Prison
02005000
Prison
Drought
03001000
Drought
Earthquake
03002000
Earthquake
Famine
03003000
Famine
Fire
03004000
Fire
Flood
03005000
Flood
IndustrialAccident
03006000
Industrial accident
MeteorologicalDisaster
03007000
Meteorological disaster
NuclearAccident
03008000
Nuclear accident
Pollution
03009000
Pollution
TransportAccident
03010000
Transport accident
VolcanicEruption
03011000
Volcanic eruption
Agriculture
04001000
Agriculture
Chemicals
04002000
Chemicals
ComputingAndInformationTechnology
04003000
Computing & Information Technology
ConstructionAndProperty
04004000
Construction & Property
EnergyAndResources
04005000
Energy & Resources
FinancialAndBusinessServices
04006000
Financial & Business Services
GoodsDistribution
04007000
Goods Distribution
MacroEconomics
04008000
Macro Economics
Markets
04009000
Markets
Media
04010000
Media
MetalGoodsAndEngineering
04011000
Metal Goods & Engineering
MetalsAndMinerals
04012000
Metals & Minerals
ProcessIndustries
04013000
Process Industries
TourismAndLeisure
04014000
Tourism & Leisure
Transport
04015000
Transport
AdultEducation
05001000
Adult Education
FurtherEducation
05002000
Further Education
ParentOrganisations
05003000
Parent Organisations
Preschooling
05004000
Preschooling
Schools
05005000
Schools
TeachersUnions
05006000
Teachers Unions
University
05007000
University
AlternativeEnergy
06001000
Alternative Energy
Conservation
06002000
Conservation
EnergySavings
06003000
Energy Savings
EnvironmentalPolitics
06004000
Environmental Politics
EnvironmentalPollution
06005000
Environmental pollution
NaturalResources
06006000
Natural resources
Nature
06007000
Nature
Population
06008000
Population
Waste
06009000
Waste
WaterSupplies
06010000
Water Supplies
Diseases
07001000
Diseases
EpidemicAndPlague
07002000
Epidemic & Plague
HealthTreatment
07003000
Health treatment
HealthOrganisations
07004000
Health organisations
MedicalResearch
07005000
Medical research
MedicalStaff
07006000
Medical staff
Medicines
07007000
Medicines
PreventativeMedicine
07008000
Preventative medicine
Animals
08001000
Animals
Curiosities
08002000
Curiosities
People
08003000
People
Apprentices
09001000
Apprentices
CollectiveContracts
09002000
Collective contracts
Employment
09003000
Employment
LabourDispute
09004000
Labour dispute
LabourLegislation
09005000
Labour legislation
Retirement
09006000
Retirement
Retraining
09007000
Retraining
Strike
09008000
Strike
Unemployment
09009000
Unemployment
Unions
09010000
Unions
WagesAndPensions
09011000
Wages & Pensions
WorkRelations
09012000
Work Relations
Games
10001000
Games
GamingAndLotteries
10002000
Gaming & Lotteries
Gastronomy
10003000
Gastronomy
Hobbies
10004000
Hobbies
HolidaysAndVacations
10005000
Holidays or vacations
Tourism
10006000
Tourism
Defence
11001000
Defence
Diplomacy
11002000
Diplomacy
Elections
11003000
Elections
EspionageAndIntelligence
11004000
Espionage & Intelligence
ForeignAid
11005000
Foreign Aid
Government
11006000
Government
HumanRights
11007000
Human Rights
LocalAuthorities
11008000
Local authorities
Parliament
11009000
Parliament
Parties
11010000
Parties
Refugees
11011000
Refugees
RegionalAuthorities
11012000
Regional authorities
StateBudget
11013000
State Budget
TreatiesAndOrganisations
11014000,
Treaties & Organisations
CultsAndSects
12001000
Cults & sects
Faith
12002000
Faith
FreeMasonry
12003000
Free masonry
ReligiousInstitutions
12004000
Religious institutions
AppliedSciences
13001000
Applied Sciences
Engineering
13002000
Engineering
HumanSciences
13003000
Human Sciences
NaturalSciences
13004000
Natural Sciences
PhilosophicalSciences
13005000
Philosophical Sciences
Research
13006000
Research
ScientificExploration
13007000
Scientific exploration
SpaceProgrammes
13008000
Space programmes
Addiction
14001000
Addiction
Charity
14002000
Charity
Demographics
14003000
Demographics
Disabled
14004000
Disabled
Euthanasia
14005000
Euthanasia
Family
14006000
Family
FamilyPlanning
14007000
Family planning
HealthInsurance
14008000
Health insurance
Homelessness
14009000
Homelessness
MinorityGroups
14010000
Minority groups
Pornography
14011000
Pornography
Poverty
14012000
Poverty
Prostitution
14013000
Prostitution
Racism
14014000
Racism
Welfare
14015000
Welfare
AeroAndAviationSports
15001000
Aero and Aviation Sports
AlpineSkiing
15002000
Alpine Skiing
AmericanFootball
15003000
American Football
Archery
15004000
Archery
AthleticsTrackField
15005000
Athletics, Track & Field
Badminton
15006000
Badminton
Baseball
15007000
Baseball
Basketball
15008000
Basketball
Biathlon
15009000
Biathlon
BilliardsSnookerPool
15010000
Billiards, Snooker and Pool
Bobsleigh
15011000
Bobsleigh
Bowling
15012000
Bowling
BowlsAndPetanque
15013000
Bowls & Petanque
Boxing
15014000
Boxing
CanoeingAndKayaking
15015000
Canoeing & Kayaking
Climbing
15016000
Climbing
Cricket
15017000
Cricket
Curling
15018000
Curling
Cycling
15019000
Cycling
Dancing
15020000
Dancing
Diving
15021000
Diving
Equestrian
15022000
Equestrian
Fencing
15023000
Fencing
FieldHockey
15024000
Field Hockey
FigureSkating
15025000
Figure Skating
FreestyleSkiing
15026000
Freestyle Skiing
Golf
15027000
Golf
Gymnastics
15028000
Gymnastics
Handball_Team
15029000
Handball (Team)
HorseRacingAndHarnessRacing
15030000
Horse Racing, Harness Racing
IceHockey
15031000
Ice Hockey
JaiAlai_Pelota
15032000
Jai Alai (Pelota)
Judo
15033000
Judo
Karate
15034000
Karate
Lacrosse
15035000
Lacrosse
Luge
15036000
Luge
Marathon
15037000
Marathon
ModernPentathlon
15038000
Modern Pentathlon
MotorRacing
15039000
Motor Racing
MotorRallying
15040000
Motor Rallying
Motorcycling
15041000
Motorcycling
Netball
15042000
Netball
NordicSkiing
15043000
Nordic Skiing
Orienteering
15044000
Orienteering
Polo
15045000
Polo
PowerBoating
15046000
Power Boating
Rowing
15047000
Rowing
RugbyLeague
15048000
Rugby League
RugbyUnion
15049000
Rugby Union
Sailing
15050000
Sailing
Shooting
15051000
Shooting
SkiJumping
15052000
Ski Jumping
SnowBoarding
15053000
Snow Boarding
Soccer
15054000
Soccer
Softball
15055000
Softball
SpeedSkating
15056000
Speed Skating
Speedway
15057000
Speedway
SportsOrganisations
15058000
Sports Organisations
Squash
15059000
Squash
SumoWrestling
15060000
Sumo Wrestling
Surfing
15061000
Surfing
Swimming
15062000
Swimming
TableTennis
15063000
Table Tennis
TaekwonDo
15064000
Taekwon-Do
Tennis
15065000
Tennis
Triathlon
15066000
Triathlon
Volleyball
15067000
Volleyball
WaterPolo
15068000
Water Polo
WaterSkiing
15069000
Water Skiing
Weightlifting
15070000
Weightlifting
Windsurfing
15071000
Windsurfing
Wrestling
15072000
Wrestling
ActsOfTerror
16001000
Acts of terror
ArmedConflict
16002000
Armed conflict
CivilUnrest
16003000
Civil unrest
CoupDEtat
16004000
Coup d'Etat
GuerrillaActivities
16005000
Guerrilla activities
Massacre
16006000
Massacre
Riots
16007000
Riots
ViolentDemonstrations
16008000
Violent demonstrations
War
16009000
War
Forecasts
17001000
Forecasts
GlobalChange
17002000
Global change
Reports
17003000
Reports
Statistics
17004000
Statistics
Warnings
17005000
Warnings
ArableFarming
04001001
Arable Farming
FishingIndustry
04001002
Fishing Industry
ForestryAndTimber
04001003
Forestry & Timber
LivestockFarming
04001004
Livestock Farming
Biotechnology
04002001
Biotechnology
Fertilisers
04002002
Fertilisers
HealthAndBeautyProducts
04002003
Health & Beauty products
InorganicChemicals
04002004
Inorganic chemicals
OrganicChemicals
04002005
Organic chemicals
Pharmaceuticals
04002006
Pharmaceuticals
SyntheticsAndPlastics
04002007
Synthetics & Plastics
Hardware
04003001
Hardware
Networking
04003002
Networking
SatelliteTechnology
04003003
Satellite technology
SemiconductorsAndActiveComponents
04003004
Semiconductors & active components
Software
04003005
Software
TelecommunicationsEquipment
04003006
Telecommunications Equipment
TelecommunicationsServices
04003007
Telecommunications Services
HeavyConstruction
04004001
Heavy construction
HouseBuilding
04004002
House building
RealEstate
04004003
Real Estate
AlternativeEnergy_EnergyAndResources
04005001
Alternative energy
Coal
04005002
Coal
OilGasDownstreamActivities
04005003
Oil & Gas - Downstream activities
OilGasUpstreamActivities
04005004
Oil & Gas - Upstream activities
NuclearPower
04005005
Nuclear power
ElectricityProductionAndDistribution
04005006
Electricity Production & Distribution
WasteManagementAndPollutionControl
04005007
Waste Management & Pollution Control
WaterSupply
04005008
Water Supply
AccountancyAndAuditing
04006001
Accountancy & Auditing
Banking
04006002
Banking
ConsultancyServices
04006003
Consultancy Services
EmploymentAgencies
04006004
Employment Agencies
HealthcareProviders
04006005
Healthcare Providers
Insurance
04006006
Insurance
LegalServices
04006007
Legal services
MarketResearch
04006008
Market research
StockBroking
04006009
Stock broking
Clothing
04007001
Clothing
DepartmentStores
04007002
Department stores
Food
04007003
Food
MailOrder
04007004
Mail Order
Retail
04007005
Retail
SpecialityStores
04007006
Speciality stores
Wholesale
04007007
Wholesale
CentralBanks
04008001
Central Banks
ConsumerIssues
04008002
Consumer Issues
DebtMarkets
04008003
Debt Markets
EconomicIndicators
04008004
Economic Indicators
EmergingMarketsDebt
04008005
Emerging Markets Debt
ForeignExchangeMarkets
04008006
Foreign Exchange Markets
GovernmentAid
04008007
Government Aid
GovernmentDebt
04008008
Government Debt
InterestRates
04008009
Interest Rates
InternationalEconomicInstitutions
04008010
International Economic Institutions
InternationalTradeIssues
04008011
International Trade Issues
LoanMarkets
04008012
Loan Markets
Energy
04009001
Energy
Metals
04009002
Metals
Securities
04009003
Securities
SoftCommodities
04009004
Soft Commodities
Advertising
04010001
Advertising
Books
04010002
Books
Cinema_Media
04010003
Cinema
NewsAgencies
04010004
News Agencies
NewspaperAndMagazines
04010005
Newspaper & Magazines
Online
04010006
Online
PublicRelations
04010007
Public Relations
Radio_Media
04010008
Radio
SatelliteAndCableServices
04010009
Satellite & Cable Services
Television_Media
04010010
Television
Aerospace
04011001
Aerospace
AutomotiveEquipment
04011002
Automotive Equipment
DefenceEquipment
04011003
Defence Equipment
ElectricalAppliances
04011004
Electrical Appliances
HeavyEngineering
04011005
Heavy engineering
IndustrialComponents
04011006
Industrial components
InstrumentEngineering
04011007
Instrument engineering
Shipbuilding
04011008
Shipbuilding
BuildingMaterials
04012001
Building materials
GoldAndPreciousMaterials
04012002
Gold & Precious Materials
IronAndSteel
04012003
Iron & Steel
NonFerrousMetals
04012004
Non ferrous metals
AlcoholicDrinks
04013001
Alcoholic Drinks
Food_ProcessIndustries
04013002
Food
FurnishingsAndFurniture
04013003
Furnishings & Furniture
PaperAndPackagingProducts
04013004
Paper & packaging products
RubberProducts
04013005
Rubber products
SoftDrinks
04013006
Soft Drinks
TextilesAndClothing
04013007
Textiles & Clothing
Tobacco
04013008
Tobacco
CasinosAndGambling
04014001
Casinos & Gambling
HotelsAndAccommodation
04014002
Hotels & accommodation
RecreationalAndSportsGoods
04014003
Recreational & Sports goods
RestaurantsAndCatering
04014004
Restaurants & catering
TourOperators
04014005
Tour operators
AirTransport
04015001
Air Transport
Railway
04015002
Railway
RoadTransport
04015003
Road Transport
WaterwayAndMaritimeTransport
04015004
Waterway & Maritime Transport


ImGearIPTCSupplementType Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents IPTC Supplement Types.

Declaration:

public enum ImGearIPTCSupplementType

Values:

Name
Value
Description
NotSupplement
0
Not a supplement
ReducedResolutionImage
1
Reduced resolution image
Logo
2
Logo
RasterizedCaption
3
Rasterized caption


ImageGear.Formats.JPEG2K Namespace

ImageGear.Formats.JPEG2K Namespace

32-bit
64-bit
CF
P
P

Description:

This namespace provides methods to create JP2, JPX and MJ2 formats as well as enumerations values for these formats filters control parameters.

Declaration:

namespace ImageGear.Formats.JPEG2K

Members:

Classes:
Name
Description
ImGearJPEG2K Class
Core JPEG2K class is used to create JP2, JPX and MJ2 formats.

Enumerations:
Name
Description
ImGearJPEG2KCodeBlockStyles Enumeration
JPEG2K code block styles
ImGearJPEG2KCompressions Enumeration
JPEG2K compressions
ImGearJPEG2KFilters Enumeration
JPEG2K filters
ImGearJPEG2KMode Enumeration
JPEG2K modes
ImGearJPEG2KProgressionOrders Enumeration
JPEG2K progression orders
ImGearJPEG2KType Enumeration
JPEG2K types

See Also:

JPEG2000

JPX

Motion JPEG2000


ImageGear.Formats.JPEG2K Namespace Classes

The ImageGear.Formats.JPEG2K Namespace has the following class members:

Classes:
Name
Description
ImGearJPEG2K Class
Core JPEG2K class is used to create JP2, JPX and MJ2 formats.


ImGearJPEG2K Class

32-bit
64-bit
CF
P
P

Description:

Core JPEG2K class is used to create JP2, JPX and MJ2 formats.

Declaration:

public sealed class ImGearJPEG2K

Members:

Methods
Name
Description
CreateJP2Format Method
Creates an instance of JP2 format
CreateJP2Format Method
Creates an instance of JP2 format
CreateJPXFormat Method
Creates an instance of JPX format
CreateJPXFormat Method
Creates an instance of JPX format
CreateMJ2Format Method
Creates an instance of MJ2 format
CreateMJ2Format Method
Creates an instance of MJ2 format


ImGearJPEG2K Methods

The ImGearJPEG2K Class of the ImageGear.Formats.JPEG2K Namespace has the following methods:

Methods
Name
Description
CreateJP2Format Method
Creates an instance of JP2 format
CreateJP2Format Method
Creates an instance of JP2 format
CreateJPXFormat Method
Creates an instance of JPX format
CreateJPXFormat Method
Creates an instance of JPX format
CreateMJ2Format Method
Creates an instance of MJ2 format
CreateMJ2Format Method
Creates an instance of MJ2 format


CreateJP2Format Method

32-bit
64-bit
CF
P
P

Description:

This method creates an instance of JP2 format.

Declaration:

public static ImageGear.Formats.IImGearFormat CreateJP2Format()

Return value:

An instance of JP2 format.

See Also:

ImGearJPEG2K Class

IImGearFormat Interface


CreateJP2Format Method

32-bit
64-bit
CF
P
P

Description:

This method creates an instance of JP2 format. LibraryPath parameter specifies a folder path to load JPEG2K native code libraries from.

If LibraryPath is blank then the current directory is used.

Declaration:

public static ImageGear.Formats.IImGearFormat CreateJP2Format(string LibraryPath)

Parameters:

Name
Type
Description
LibraryPath
string
Path to load JPEG2K native libraries from.

Return value:

An instance of JP2 format.

See Also:

ImGearJPEG2K Class

IImGearFormat Interface


CreateJPXFormat Method

32-bit
64-bit
CF
P
P

Description:

This method creates an instance of JPX format.

Declaration:

public static ImageGear.Formats.IImGearFormat CreateJPXFormat()

Return value:

An instance of JPX format.

See Also:

ImGearJPEG2K Class

IImGearFormat Interface


CreateJPXFormat Method

32-bit
64-bit
CF
P
P

Description:

This method creates an instance of JPX format. LibraryPath parameter specifies a folder path to load JPEG2K native code libraries from.

If LibraryPath is blank then the current directory is used.

Declaration:

public static ImageGear.Formats.IImGearFormat CreateJPXFormat(string LibraryPath)

Parameters:

Name
Type
Description
LibraryPath
string
Path to load JPEG2K native libraries from.

Return value:

An instance of JPX format.

See Also:

ImGearJPEG2K Class

IImGearFormat Interface


CreateMJ2Format Method

32-bit
64-bit
CF
P
P

Description:

This method creates an instance of MJ2 format.

Declaration:

public static ImageGear.Formats.IImGearFormat CreateMJ2Format()

Return value:

An instance of MJ2 format.

See Also:

ImGearJPEG2K Class

IImGearFormat Interface


CreateMJ2Format Method

32-bit
64-bit
CF
P
P

Description:

This method creates an instance of MJ2 format. LibraryPath parameter specifies a folder path to load JPEG2K native code libraries from.

If LibraryPath is blank then the current directory is used.

Declaration:

public static ImageGear.Formats.IImGearFormat CreateMJ2Format(string LibraryPath)

Parameters:

Name
Type
Description
LibraryPath
string
Path to load JPEG2K native libraries from.

Return value:

An instance of MJ2 format.

See Also:

ImGearJPEG2K Class

IImGearFormat Interface


ImageGear.Formats.JPEG2K Namespace Enumerations

The ImageGear.Formats.JPEG2K Namespace has the following enumeration members:

Enumerations:
Name
Description
ImGearJPEG2KCodeBlockStyles Enumeration
JPEG2K code block styles
ImGearJPEG2KCompressions Enumeration
JPEG2K compressions
ImGearJPEG2KFilters Enumeration
JPEG2K filters
ImGearJPEG2KMode Enumeration
JPEG2K modes
ImGearJPEG2KProgressionOrders Enumeration
JPEG2K progression orders
ImGearJPEG2KType Enumeration
JPEG2K types


ImGearJPEG2KCodeBlockStyles Enumeration

32-bit
64-bit
CF
P
P

Description:

Specifies JPEG2K code block styles.

Declaration:

public enum ImGearJPEG2KCodeBlockStyles

Values:

Name
Value
Description
ALL_OFF
0
No code block styles
BYPASS
1
Selective MQ coder bypass
RESET
2
Reset context states
RESTART
4
Terminate and restart MQ coder
CAUSAL
8
Stripe-causal context formation
ERTERM
16
Predictable tremination
SEGMARK
32
Segmentation marker


ImGearJPEG2KCompressions Enumeration

32-bit
64-bit
CF
P
P

Description:

Specifies JPEG2K compressions types.

Declaration:

public enum ImGearJPEG2KCompressions

Values:

Name
Value
Description
LOSSY
0
Lossy compression
LOSSLESS
1
Lossless compression


ImGearJPEG2KFilters Enumeration

32-bit
64-bit
CF
P
P

Description:

Specifies JPEG2K filters.

Declaration:

public enum ImGearJPEG2KFilters

Values:

Name
Value
Description
AUTO
-1
Automatically selects the best transform depending on image type. It selects irreversible transform for true color and grayscale images, and reversible transform for paletted images.
REVERSIBLE
0
Reversible transform based on 5/3 filter
IRREVERSIBLE
1
Irreversible transform based on Daubechies' 9/7 filter


ImGearJPEG2KMode Enumeration

32-bit
64-bit
CF
P
P

Description:

Specifies JPEG2K modes.

Declaration:

public enum ImGearJPEG2KModes

Values:

Name
Value
Description
FAST
0
The fast mode is used by default. In this case, compliance is assumed and checking is minimized; there is no attempt to recover from any errors.
FUSSY
1
In the fussy mode, the code-stream management machinery makes a serious attempt to identify compliance violations and generates an appropriate terminal error message if it finds one.
RESILIENT
2
In the resilient mode, the code-stream management machinery makes a serious attempt to both detect and recover from errors in the code-stream. We attempt to guarantee that decompression will not fail, so long as the main header is uncorrupted and there is only one tile with one tile-part.


ImGearJPEG2KProgressionOrders Enumeration

32-bit
64-bit
CF
P
P

Description:

Specifies JPEG2K progression orders.

Declaration:

public enum ImGearJPEG2KProgressionOrders

Values:

Name
Value
Description
LRCP
0
Layer-Resolution-Component-Position progression
RLCP
1
Resolution-Layer-Component-Position progression
RPCL
2
Resolution-Position-Component-Layer progression
PCRL
3
Position-Component-Resolution-Layer progression
CPRL
4
Component-Position-Resolution-Layer progression


ImGearJPEG2KType Enumeration

32-bit
64-bit
CF
P
P

Description:

Specifies JPEG2K type.

Declaration:

public enum ImGearJPEG2KType

Values:

Name
Value
Description
CODESTREAM
0
JP2 code stream
FILE_FORMAT
1
JP2 file format


ImageGear.Formats.JPG Namespace

ImageGear.Formats.JPG Namespace

32-bit
64-bit
CF
P
P
P

Description:

This namespace provides enumerations values for JPEG format filter control parameters.

Declaration:

namespace ImageGear.Formats.JPG

Members:

Enumerations:
Name
Description
ImGearDecimationTypes Enumeration
Lists all possible JPEG decimation values.

See Also:

JPEG


ImageGear.Formats.JPG Namespace Enumerations

The ImageGear.Formats.JPG Namespace has the following enumeration members:

Enumerations:
Name
Description
ImGearDecimationTypes Enumeration
Lists all possible JPEG decimation values.


ImGearDecimationTypes Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists all possible JPEG decimation values.

The format of these ImageGear decimation constants is:

Decim_<H1>x<V1>_<H2>x<V2>_<H3>x<V3>,

where Hi, Vi = horizontal and vertical decimation values for the i-channel.

The following is a simple example of decimation. For a more detailed definition, please see the JPEG Specification.

A decimation setting of Decim_4x2_1x1_1x1 would yield the following results:

As shown, 8 Y components in the source image have yielded one Cb and one Cr component. In general, this setting will reduce the quality of the compression, unless the image has many continuous tone areas.

  • Maximum quality can be reached using a value of Decim_1x1_1x1_1x1.
  • Maximum compression ratio can be reached with a value of Decim_4x4_2x2_2x2.
  • The ImageGear default decimation value is: Decim_2x2_1x1_1x1.

Declaration:

public enum ImGearDecimationTypes

Values:

Name
Value
Description
Decim_1x1_1x1_1x1
0
For each Y sample, one Cb sample and one Cr sample are stored
Decim_1x2_1x1_1x1
2
For each horizontal pair of Y samples, one Cb sample and one Cr sample are stored
Decim_2x2_2x1_2x1
4
For each four (two horizontal by two vertical) Y samples, two horizontal Cb samples and two horizontal Cr samples are stored
Decim_2x4_1x1_1x1
6
For each six (two horizontal by four vertical) Y samples, one Cb sample and one Cr sample are stored
Decim_1x4_1x1_1x1
8
For each four vertical Y samples, one Cb sample and one Cr sample are stored
Decim_1x4_1x2_1x2
10
For each four vertical Y samples, two vertical Cb samples and two vertical Cr samples are stored
Decim_2x1_1x1_1x1
1
For each vertical pair of Y samples, one Cb sample and one Cr sample are stored
Decim_2x2_1x1_1x1
3
For each four (two horizontal by two vertical) Y samples, one Cb sample and one Cr sample are stored
Decim_4x2_1x1_1x1
5
For each six (four horizontal by two vertical) Y samples, one Cb sample and one Cr sample are stored
Decim_4x1_1x1_1x1
7
For each four horizontal Y samples, one Cb sample and one Cr sample are stored.
Decim_4x1_2x1_2x1
9
For each four horizontal Y samples, two horizontal Cb samples and two horizontal Cr samples are stored
Decim_4x4_2x2_2x2
11
For each 16 (four horizontal by four vertical) Y samples, four (two horizontal by two vertical) Cb samples and four (two horizontal by two vertical) Cr samples are stored

See Also:

JPEG


ImageGear.Formats.PDF Namespace

ImageGear.Formats.PDF Namespace

32-bit
64-bit
CF
P
P

Description:

ImageGear PDF namespace provides full multi-page reading and writing support for the entire document, as well as for a specified set of pages. You can detect, read, write, append, insert, replace, swap, and delete a specified page in the PDF document, as well as to edit its content.

To enable ImageGear.Formats.PDF namespace in your project, specify the following directive:

using ImageGear.Formats.PDF;

Declaration:

namespace ImageGear.Formats.PDF

Members:

Classes:
Name
Description
ImGearPDEClip Class
A list of elements containing Paths and Texts that describe a clip state.
ImGearPDEColorData Class
General color data abstract class.
ImGearPDEColorDataCalGray Class
Describes a CalGray color space.
ImGearPDEColorDataCalLab Class
Describes a L*a*b* color space.
ImGearPDEColorDataCalRGB Class
Describes a CalRGB color space.
ImGearPDEColorDataDeviceN Class
DeviceN color space.
ImGearPDEColorDataICCBased Class
ICC based color space.
ImGearPDEColorDataIndexed Class
Indexed color space.
ImGearPDEColorDataSeparation Class
Separation color space.
ImGearPDEColorRange Class
Color range.
ImGearPDEColorSpace Class
A reference to a color space used on a page in a PDF file. The color space is part of the graphics state attributes of a PDE Element.
ImGearPDEColorSpec Class
Color specification.
ImGearPDEColorValue Class
Color value.
ImGearPDEContainer Class
A group of elements on a page in a PDF file. In the PDF file, containers are delimited by Marked Content BMC/EMC or BDC/EMC pairs. Every container has a Marked Content tag associated with it. In addition to grouping a set of elements, a BDC/EMC pair specifies a property list to be associated with the grouping. Thus a container corresponding to a BDC/EMC pair also has a property list dictionary associated with it.
ImGearPDEContent Class
Modifiable content of a PDF page, which contains elements. Content may be obtained from an existing page or from a Form XObject.
ImGearPDEContentAttrs Class
Attributes of the PDE Content object.
ImGearPDEDash Class
Dash specification, as described in Table 4.8 in the PDF Reference. See Section 4.3.2 for more information on line dash patterns.
ImGearPDEElement Class
Base class for the elements of a page display list (PDE content) and for clip objects. The general PDE element methods allow you to get and set general element properties.
ImGearPDEFilterArray Class
Array of filter specifications usually containing two or less filters: encoding and/or compression.
ImGearPDEFilterSpec Class
Filter element in a filter array.
ImGearPDEFont Class
This is a reference to a font used on a page in a PDF file. It may be equated with a font in the system.
ImGearPDEFontAttrs Class
Attributes for ImGearPDEFont and ImGearPDFSysFont.
ImGearPDEFontCreateFromSysFontParams Class
Used with PDE Font creation.
ImGearPDEFontInfo Class
PDE font information.
ImGearPDEForm Class
This is an element that corresponds to an instance of XObject Form on a page (or other containing stream such as another XObject Form or annotation form). The context associated with this instance includes the actual stream that represents the XObject Form and the initial conditions of the graphics state. The latter consists of the transformation matrix, initial color values, and so forth. It is possible to have two Forms that refer to the same XObject Form. The forms will exist at different places on the same page, depending on the transformation matrix. They may also have different colors or line stroking parameters. In the case of a transparency group, the opacity is specified in the gstate.
Within a Form, each element has its own gstate (or is a container, place, or group object). These gstates are independent of the parent Form gstate. Form elements may have their own opacity.
Content may be obtained from a Form to edit the form's display list.
ImGearPDEGraphicState Class
Attributes of a PDE element or a PDE text sub-element.
ImGearPDEGroup Class
The PDE group object is an in-memory representation of objects in Content. It has no state and is not represented in any way in a content stream (that is, Content).
When used in a Clip, this object is used to associate Text objects into a single clipping object.
ImGearPDEImage Class
An element that contains an Image XObject or in-line image. You can associate data or a stream with an image.
ImGearPDEImageAttrs Class
Attributes of a PDE Image object.
ImGearPDEObject Class
Base class for all the PDE objects.
ImGearPDEPath Class
This is an element that contains a path. Path objects can be stroked, filled, and/or serve as a clipping path.
ImGearPDEPlace Class
The PDE place object is an element that marks a place on a page in a PDF file. In a PDF file, a place is represented by the MP or DP Marked Content operators.
Marked content is useful for adding structure information to a PDF file. For instance, a drawing program may want to mark a point with information, such as the start of a path of a certain type. Marked content provides a way to retain this information in the PDF file. A DP operator functions the same as the MP operator and, in addition, allows a property list dictionary to be associated with a place.
ImGearPDEPostScript Class
The PDE PostScript object is an element representing in-line or XObject pass-through PostScript object. XObject PostScripts are listed in page XObject resources.
ImGearPDEPSAttrs Class
Attributes of a PDE PostScript object.
ImGearPDEShading Class
The PDE shading object is an element that represents smooth shading.
ImGearPDESoftMask Class
The PDE soft mask object is an object for creating and manipulating a soft mask in a PDF file.
ImGearPDEText Class
The PDE text object is an element representing text. It is a container for text as show strings or as individual characters. Each sub-element may have different graphics state properties. However, the same clip applies to all sub-elements of a Text. Also, the char path of a Text can be used to represent a clip.
ImGearPDETextItem Class
The PDE text item object is a PDE element representing a text object.
ImGearPDETextState Class
Attributes of a PDE text element.
ImGearPDEXGroup Class
The PDE XGroup object is a transparency (XGroup) resource.
ImGearPDEXObject Class
An element representing an arbitrary XObject.
ImGearPDEXYZColor Class
XYZ color data.
ImGearPDF Class
Core PDF class.
ImGearPDFAction Class
This is a task that performs when a user clicks on a link or a bookmark.
ImGearPDFAtom Class
A hashed token used in place of strings to optimize performance.
ImGearPDFBasArray Class
An array object is a one-dimensional collection of objects arranged sequentially.
ImGearPDFBasBool Class
PDF provides Boolean objects identified by the keywords true and false.
ImGearPDFBasDict Class
A dictionary object is an associative table containing pairs of objects, known as the dictionary's entries.
ImGearPDFBasFixed Class
Fixed objects approximate mathematical real numbers, but with limited range and precision; they are typically represented in fixed-point, rather than floating-point, form.
ImGearPDFBasInt Class
Integer objects represent mathematical integers within a certain interval centered at 0.
ImGearPDFBasName Class
A name object is an atomic symbol uniquely defined by a sequence of characters.
ImGearPDFBasNull Class
The null object has a type and value that are unequal to those of any other object.
ImGearPDFBasObj Class
Basic abstract objects.
ImGearPDFBasString Class
Basic string object interface. A string object consists of a series of bytes-unsigned integer values in the range 0 to 255.
ImGearPDFBookmark Class
PDF bookmark allows the user to navigate interactively from one part of the document to another. It consists of a tree-structured hierarchy of bookmarks.
ImGearPDFDestination Class
PDF destination represents a particular view of a page in a document.
ImGearPDFDictionary Class
PDF dictionary.
ImGearPDFDocument Class
PDF document.
ImGearPDFDocumentPageArray Class
PDF document page array.
ImGearPDFFixedMatrix Class
Matrix containing fixed numbers.
ImGearPDFFixedPoint Class
Point (in two-dimensional space) represented by two fixed numbers.
ImGearPDFFixedQuad Class
Quadrilateral represented by four fixed points (one at each corner).
ImGearPDFFixedRect Class
A rectangle represented by the coordinates of its four sides.
ImGearPDFLayer Class
PDF layer object represents a named object whose state can be toggled in a UI to affect changes in visibility of content.
ImGearPDFObject Class
General PDF Object that provides a disposing routine for all the unmanaged resources.
ImGearPDFPreflight Class
PDF class that provides preflight capabilities.
ImGearPDFPreflightReport Class
PDF class for preflight reporting.
ImGearPDFPrintOptions Class
PDF printing options.
ImGearPDFSecurityData Class
PDF security data object describes data for the standard security handler.
ImGearPDFStream Class
A data stream that may be a buffer in memory, or an arbitrary user-written procedure.
ImGearPDFStyle Class
PDF style object provides access to information about the fonts, font sizes, and colors used in a Word.
ImGearPDFSysEncoding Class
System encoding object provides system encoding for a PDF file.
ImGearPDFSysFont Class
This is a reference to a font installed in the host system.
ImGearPDFWord Class
A word in a PDF file. Each word contains a sequence of characters in one or more styles
ImGearPDFWordFinder Class
A word in a PDF file. Each word contains a sequence of characters in one or more styles

Enumerations:
Name
Description
ImGearPDEContentFlags Enumeration
Bit field for ImGearPDEContentAttrs Class.
ImGearPDEElementCopyFlags Enumeration
Bitfield for PDE element copy.
ImGearPDEFontCreateFlags Enumeration
Flags for PDE font creation routine.
ImGearPDEFontCreateNeedFlags Enumeration
Flags for PDE Font CreateNeedFlags.
ImGearPDEFontFlags Enumeration
Constants that indicate a font's attributes (fixed width, roman or symbolic, sans serif, and so forth).
ImGearPDEFontProtection Enumeration
Setting for disabling font embedding.
ImGearPDEGraphicStateWasSetFlags Enumeration
Structure describing the graphics state that was set.
ImGearPDEImageAttrFlags Enumeration
Flags for AT_PDE_IMAGEATTRS/ImGearPDEImageAttrs.
ImGearPDEImageDataFlags Enumeration
Image Data Flags.
ImGearPDEInsertElement Enumeration
Used for inserting a PDE element into the content.
ImGearPDEPathElementType Enumeration
Constant values that describe path segment operators in PDE path elements.
ImGearPDEPathOpFlags Enumeration
Flags for paint operators in a PDE path.
ImGearPDEPSAttrFlags Enumeration
Flags for ImGearPDEPSAttrs Class.
ImGearPDESoftMaskCreateFlags Enumeration
Flags for use with SoftMask create.
ImGearPDESysFontMatchFlags Enumeration
Font matching flags for SysFont find routine.
ImGearPDESysFontPackageType Enumeration
Flags for packageType of AT_PDE_FONTATTRS/ImGearPDEFontAttrs.
ImGearPDETextFlags Enumeration
Flags used in the text API.
ImGearPDEType Enumeration
Types of the editing objects.
ImGearPDEXGroupCreateFlags Enumeration
Enumerated data type used to specify the type of transparency group to create.
ImGearPDFBasicType Enumeration
Basic PDF objects.
ImGearPDFBookmarkFlags Enumeration
Represents PDF bookmark flags.
ImGearPDFCodePages Enumeration
Code page character-mapping constants.
ImGearPDFContextFlags Enumeration
This enumeration determines context flags.
ImGearPDFDestinationType Enumeration
Represents the types of PDF object destination.
ImGearPDFFixedValues Enumeration
PDF Fixed value. A variety of predefined fixed-point constants.
ImGearPDFInsertFlags Enumeration
Insert flags.
ImGearPDFOCMDVisPolicy Enumeration
PDF Dictionaries (OCMD) VisPolicy types.
ImGearPDFPageDrawMode Enumeration
Specifes default PDF rendering methods used by the ImageGear PDF component to draw PDF page content.
ImGearPDFPageNumber Enumeration
PageNumber specification.
ImGearPDFPageRange Enumeration
Page ranges specification.
ImGearPDFPermReqObj Enumeration
Enumerated data type used to describe the target object of a permission request.
ImGearPDFPermReqOpr Enumeration
Enumerated data type used to describe the target operation of a permissions request.
ImGearPDFPermReqStatus Enumeration
An enumerated data type that provides the status of PDF Doc-related permissions methods.
ImGearPDFPermsFlags Enumeration
Flags that describe permissions wanted and granted for a document.
ImGearPDFPreflightProfile Enumeration
Specifies types of the preflight profiles supported by ImageGear.
ImGearPDFPreflightReportCodes Enumeration
Defines PDF preflight error codes describing incompliance with the specified profile.
ImGearPDFRevision Enumeration
Specifies Adobe® Acrobat revision number.
ImGearPDFSaveFlags Enumeration
Save flags for PDF document.
ImGearPDFSecurityInfoFlags Enumeration
Flags used to specify various information about the Adobe® Acrobat viewer's security and permissions.
ImGearPDFSmoothFlags Enumeration
Bit flags indicating how a page is rendered.
ImGearPDFStdSecurityMethod Enumeration
Specifies standard security algorithms.
ImGearPDFTextEncoding Enumeration
Determines PDF ASCII encoding.
ImGearPDFWordFinderVersion Enumeration
WordFinder algorithm version.
ImGearPSLevel Enumeration
Determines the PostScript language level.
ImGearPSType Enumeration
Determines output PostScript type.


ImageGear.Formats.PDF Namespace Classes

The ImageGear.Formats.PDF Namespace has the following class members:

Classes:
Name
Description
ImGearPDEClip Class
A list of elements containing Paths and Texts that describe a clip state.
ImGearPDEColorData Class
General color data abstract class.
ImGearPDEColorDataCalGray Class
Describes a CalGray color space.
ImGearPDEColorDataCalLab Class
Describes a L*a*b* color space.
ImGearPDEColorDataCalRGB Class
Describes a CalRGB color space.
ImGearPDEColorDataDeviceN Class
DeviceN color space.
ImGearPDEColorDataICCBased Class
ICC based color space.
ImGearPDEColorDataIndexed Class
Indexed color space.
ImGearPDEColorDataSeparation Class
Separation color space.
ImGearPDEColorRange Class
Color range.
ImGearPDEColorSpace Class
A reference to a color space used on a page in a PDF file. The color space is part of the graphics state attributes of a PDE Element.
ImGearPDEColorSpec Class
Color specification.
ImGearPDEColorValue Class
Color value.
ImGearPDEContainer Class
A group of elements on a page in a PDF file. In the PDF file, containers are delimited by Marked Content BMC/EMC or BDC/EMC pairs. Every container has a Marked Content tag associated with it. In addition to grouping a set of elements, a BDC/EMC pair specifies a property list to be associated with the grouping. Thus a container corresponding to a BDC/EMC pair also has a property list dictionary associated with it.
ImGearPDEContent Class
Modifiable content of a PDF page, which contains elements. Content may be obtained from an existing page or from a Form XObject.
ImGearPDEContentAttrs Class
Attributes of the PDE Content object.
ImGearPDEDash Class
Dash specification, as described in Table 4.8 in the PDF Reference. See Section 4.3.2 for more information on line dash patterns.
ImGearPDEElement Class
Base class for the elements of a page display list (PDE content) and for clip objects. The general PDE element methods allow you to get and set general element properties.
ImGearPDEFilterArray Class
Array of filter specifications usually containing two or less filters: encoding and/or compression.
ImGearPDEFilterSpec Class
Filter element in a filter array.
ImGearPDEFont Class
This is a reference to a font used on a page in a PDF file. It may be equated with a font in the system.
ImGearPDEFontAttrs Class
Attributes for ImGearPDEFont and ImGearPDFSysFont.
ImGearPDEFontCreateFromSysFontParams Class
Used with PDE Font creation.
ImGearPDEFontInfo Class
PDE font information.
ImGearPDEForm Class
This is an element that corresponds to an instance of XObject Form on a page (or other containing stream such as another XObject Form or annotation form). The context associated with this instance includes the actual stream that represents the XObject Form and the initial conditions of the graphics state. The latter consists of the transformation matrix, initial color values, and so forth. It is possible to have two Forms that refer to the same XObject Form. The forms will exist at different places on the same page, depending on the transformation matrix. They may also have different colors or line stroking parameters. In the case of a transparency group, the opacity is specified in the gstate.
Within a Form, each element has its own gstate (or is a container, place, or group object). These gstates are independent of the parent Form gstate. Form elements may have their own opacity.
Content may be obtained from a Form to edit the form's display list.
ImGearPDEGraphicState Class
Attributes of a PDE element or a PDE text sub-element.
ImGearPDEGroup Class
The PDE group object is an in-memory representation of objects in Content. It has no state and is not represented in any way in a content stream (that is, Content).
When used in a Clip, this object is used to associate Text objects into a single clipping object.
ImGearPDEImage Class
An element that contains an Image XObject or in-line image. You can associate data or a stream with an image.
ImGearPDEImageAttrs Class
Attributes of a PDE Image object.
ImGearPDEObject Class
Base class for all the PDE objects.
ImGearPDEPath Class
This is an element that contains a path. Path objects can be stroked, filled, and/or serve as a clipping path.
ImGearPDEPlace Class
The PDE place object is an element that marks a place on a page in a PDF file. In a PDF file, a place is represented by the MP or DP Marked Content operators.
Marked content is useful for adding structure information to a PDF file. For instance, a drawing program may want to mark a point with information, such as the start of a path of a certain type. Marked content provides a way to retain this information in the PDF file. A DP operator functions the same as the MP operator and, in addition, allows a property list dictionary to be associated with a place.
ImGearPDEPostScript Class
The PDE PostScript object is an element representing in-line or XObject pass-through PostScript object. XObject PostScripts are listed in page XObject resources.
ImGearPDEPSAttrs Class
Attributes of a PDE PostScript object.
ImGearPDEShading Class
The PDE shading object is an element that represents smooth shading.
ImGearPDESoftMask Class
The PDE soft mask object is an object for creating and manipulating a soft mask in a PDF file.
ImGearPDEText Class
The PDE text object is an element representing text. It is a container for text as show strings or as individual characters. Each sub-element may have different graphics state properties. However, the same clip applies to all sub-elements of a Text. Also, the char path of a Text can be used to represent a clip.
ImGearPDETextItem Class
The PDE text item object is a PDE element representing a text object.
ImGearPDETextState Class
Attributes of a PDE text element.
ImGearPDEXGroup Class
The PDE XGroup object is a transparency (XGroup) resource.
ImGearPDEXObject Class
An element representing an arbitrary XObject.
ImGearPDEXYZColor Class
XYZ color data.
ImGearPDF Class
Core PDF class.
ImGearPDFAction Class
This is a task that performs when a user clicks on a link or a bookmark.
ImGearPDFAtom Class
A hashed token used in place of strings to optimize performance.
ImGearPDFBasArray Class
An array object is a one-dimensional collection of objects arranged sequentially.
ImGearPDFBasBool Class
PDF provides Boolean objects identified by the keywords true and false.
ImGearPDFBasDict Class
A dictionary object is an associative table containing pairs of objects, known as the dictionary's entries.
ImGearPDFBasFixed Class
Fixed objects approximate mathematical real numbers, but with limited range and precision; they are typically represented in fixed-point, rather than floating-point, form.
ImGearPDFBasInt Class
Integer objects represent mathematical integers within a certain interval centered at 0.
ImGearPDFBasName Class
A name object is an atomic symbol uniquely defined by a sequence of characters.
ImGearPDFBasNull Class
The null object has a type and value that are unequal to those of any other object.
ImGearPDFBasObj Class
Basic abstract objects.
ImGearPDFBasString Class
Basic string object interface. A string object consists of a series of bytes-unsigned integer values in the range 0 to 255.
ImGearPDFBookmark Class
PDF bookmark allows the user to navigate interactively from one part of the document to another. It consists of a tree-structured hierarchy of bookmarks.
ImGearPDFDestination Class
PDF destination represents a particular view of a page in a document.
ImGearPDFDictionary Class
PDF dictionary.
ImGearPDFDocument Class
PDF document.
ImGearPDFDocumentPageArray Class
PDF document page array.
ImGearPDFFixedMatrix Class
Matrix containing fixed numbers.
ImGearPDFFixedPoint Class
Point (in two-dimensional space) represented by two fixed numbers.
ImGearPDFFixedQuad Class
Quadrilateral represented by four fixed points (one at each corner).
ImGearPDFFixedRect Class
A rectangle represented by the coordinates of its four sides.
ImGearPDFLayer Class
PDF layer object represents a named object whose state can be toggled in a UI to affect changes in visibility of content.
ImGearPDFObject Class
General PDF Object that provides a disposing routine for all the unmanaged resources.
ImGearPDFPreflight Class
PDF class that provides preflight capabilities.
ImGearPDFPreflightReport Class
PDF class for preflight reporting.
ImGearPDFPrintOptions Class
PDF printing options.
ImGearPDFSecurityData Class
PDF security data object describes data for the standard security handler.
ImGearPDFStream Class
A data stream that may be a buffer in memory, or an arbitrary user-written procedure.
ImGearPDFStyle Class
PDF style object provides access to information about the fonts, font sizes, and colors used in a Word.
ImGearPDFSysEncoding Class
System encoding object provides system encoding for a PDF file.
ImGearPDFSysFont Class
This is a reference to a font installed in the host system.
ImGearPDFWord Class
A word in a PDF file. Each word contains a sequence of characters in one or more styles
ImGearPDFWordFinder Class
A word in a PDF file. Each word contains a sequence of characters in one or more styles


ImGearPDEClip Class

32-bit
64-bit
CF
P
P

Description:

This is a list of elements containing Paths and Texts that describe a clip state. Clips can be created and built up with PDE Clip methods. Any PDE Element object can have Clip associated with it. Clip objects can contain PDE Containers and PDE Groups to an arbitrary level of nesting. This allows PDE Containers to be used to mark clip objects.

PDE Groups inside PDE Clips that contain at least one PDE Text and no PDE Paths have a special meaning. All PDE Text objects contained in such a PDE Group are considered to be part of the same BT/ET block. This means that the union of these PDE Texts makes up a single clipping path-as opposed to the intersection of the PDE Texts.

See Section 5.3 in the PDF reference for more information about BT/ET block.

Declaration:

public sealed class ImGearPDEClip : ImageGear.Formats.PDF.ImGearPDEElement

Members:

Constructors
Name
Description
ImGearPDEClip Constructor
Creates new clip object.

Properties
Name
Description
ElementCount Property
The number of top-level elements in a clip object.

Methods
Name
Description
AddElement Method
Adds an element to a clip path.
Clone Method
Makes a deep copy of a PDE Clip object.
Enumerate Method
Enumerates all the PDE Elements of the current clip in a flattened manner.
GetElement Method
Gets an element from a clip object.
RemoveElements Method
Removes one or more elements from a clip object.

Delegates
Name
Description
ImGearPDEClipEnumerate Delegate
Delegate for the format of the clip enumeration procedure.


ImGearPDEClip Constructors

The ImGearPDEClip Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEClip Constructor
Creates new clip object.


ImGearPDEClip Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates the new clip object.

Declaration:

public ImGearPDEClip ( )

Return Value:

The new instance of the clip object.

See Also:

ImGearPDEClip Class


ImGearPDEClip Properties

The ImGearPDEClip Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
ElementCount Property
The number of top-level elements in a clip object.


ElementCount Property

32-bit
64-bit
CF
P
P

Description:

This property provides the number of top-level elements in a clip object. Top-level elements may be a path or char-path, a marked content container or place, or a group. Paths are represented as PDE Path objects; char-paths are represented as PDE Text objects. If clip contains PDE Groups, this counts the top-level PDE Path, PDE Text, PDE Container, PDE Group, or PDE Place object. Use Enumerate to see only the PDE Path and PDE Text objects.

Declaration:

public int ElementCount { get }

Value:

Any integer number.

Default value:

N/A


ImGearPDEClip Methods

The ImGearPDEClip Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
AddElement Method
Adds an element to a clip path.
Clone Method
Makes a deep copy of a PDE Clip object.
Enumerate Method
Enumerates all the PDE Elements of the current clip in a flattened manner.
GetElement Method
Gets an element from a clip object.
RemoveElements Method
Removes one or more elements from a clip object.


AddElement Method

32-bit
64-bit
CF
P
P

Description:

This method adds an element to a clip path.

Declaration:

public void AddElement(int AfterIndex, ImageGear.Formats.PDF.ImGearPDEElement Element)

Parameters:

Name
Type
Description
AfterIndex
int
The index after which to add Element. Use BEFORE_FIRST to insert an element at the beginning of the clip object.
Element
ImGearPDEElement Class
The element added, which may be a PDE Path, a PDE Text, a PDE Container, a PDE Group or a PDE Place object.

Return Value:

None.

See Also:

ImGearPDEElement Class


Clone Method

32-bit
64-bit
CF
P
P

Description:

This method makes a deep copy of a PDE Clip object.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEClip Clone ( )

Return Value:

ImGearPDEClip Class object, which is a deep copy of the current clip object.

See Also:

ImGearPDEClip Class


Enumerate Method

32-bit
64-bit
CF
P
P

Description:

This method enumerates all the PDE Elements of the current clip in a flattened manner. So PDE Containers and PDE Groups nested in the PDE Clip will not be handed back, but any PDE Paths and PDE Texts nested in them will be.

PDE Place objects inside the PDE Clip are not returned.

Declaration:

public static void Enumerate ( ImageGear.Formats.PDF.ImGearPDEClip.ImGearPDEClipEnumerate
EnumerateProc , Object ClientData )

Parameters:

Name
Type
Description
EnumerateProc
ImGearPDEClipEnumerate Delegate
Function of ImGearPDEClipEnumerate type.
ClientData
Object
Client data passed into EnumerateProc.

Return Value:

None.

See Also:

ImGearPDEClipEnumerate Delegate


GetElement Method

32-bit
64-bit
CF
P
P

Description:

This method gets an element from a clip object.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEElement GetElement ( Int Index )

Parameters:

Name
Type
Description
Index
int
Index of element to get from clip.

Return Value:

The new instance of ImGearPDEElement Class object.

See Also:

ImGearPDEElement Class


RemoveElements Method

32-bit
64-bit
CF
P
P

Description:

This method removes one or more elements from a clip object.

Declaration:

public void RemoveElements ( Int Index , Int Count )

Parameters:

Name
Type
Description
Index
int
First element to remove.
Count
int
Number of elements to remove.

Return Value:

None.


ImGearPDEClip Delegates

The ImGearPDEClip Class of the ImageGear.Formats.PDF Namespace has the following delegates:

Delegates
Name
Description
ImGearPDEClipEnumerate Delegate
Delegate for the format of the clip enumeration procedure.


ImGearPDEClipEnumerate Delegate

32-bit
64-bit
CF
P
P

Description:

This delegate is for the format of the clip enumeration procedure.

Declaration:

public delegate bool ImGearPDEClipEnumerate(ImageGear.Formats.PDF.ImGearPDEClip Clip,
object ClientData)

Parameters:

Name
Type
Description
Clip
ImGearPDEClip Class
The clip
ClientData
object
The client data

Return Value:

true, false

See Also:

ImGearPDEClip Class


ImGearPDEColorData Class

32-bit
64-bit
CF
P
P

Description:

General color data abstract class. Please see section 7.10 of the PDF Reference Manual for information on color spaces.

Declaration:

public abstract class ImGearPDEColorData

Members:

N/A


ImGearPDEColorDataCalGray Class

32-bit
64-bit
CF
P
P

Description:

Describes a CalGray color space.

Default calGray = {{0, 0, 0}, {0, 0, 0}, 1};

Declaration:

public sealed class ImGearPDEColorDataCalGray : ImageGear.Formats.PDF.ImGearPDEColorData

Members:

Constructors
Name
Description
ImGearPDEColorDataCalGray Constructor
Creates new instance

Properties
Name
Description
Gamma Property
Gets/sets gamma value.
BlackPoint Property
Gets/sets black point value.
WhitePoint Property
Gets/sets white point value.


ImGearPDEColorDataCalGray Constructors

The ImGearPDEColorDataCalGray Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEColorDataCalGray Constructor
Creates new instance


ImGearPDEColorDataCalGray Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates the new instance of ImGearPDEColorDataCalGray object.

Declaration:

public ImGearPDEColorDataCalGray (  )

Return Value:

The new instance of ImGearPDEColorDataCalGray Class object.

See Also:

ImGearPDEColorDataCalGray Class


ImGearPDEColorDataCalGray Properties

The ImGearPDEColorDataCalGray Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
Gamma Property
Gets/sets gamma value.
BlackPoint Property
Gets/sets black point value.
WhitePoint Property
Gets/sets white point value.


Gamma Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the gamma value.

Declaration:

public float Gamma { get, set }

Value:

Any positive value.

Default value:

1


BlackPoint Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the black point value.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEXYZColor BlackPoint { get, set }

Value:

ImGearPDEXYZColor Class object.

Default value:

N/A

See also:

ImGearPDEXYZColor Class


WhitePoint Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the white point value.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEXYZColor WhitePoint { get, set }

Value:

Any value of ImGearPDEXYZColor Class.

Default value:

N/A

See also:

ImGearPDEXYZColor Class


ImGearPDEColorDataCalLab Class

32-bit
64-bit
CF
P
P

Description:

Describes a L*a*b* color space.

Default lab = {{0, 0, 0}, {0, 0, 0}, {-100, 100}, {-100, 100}};

Declaration:

public sealed class ImGearPDEColorDataCalLab : ImageGear.Formats.PDF.ImGearPDEColorData

Members:

Constructors
Name
Description
ImGearPDEColorDataCalLab Constructor
Creates new instance of ImGearPDEColorDataCalLab object.

Properties
Name
Description
BlackPoint Property
Gets/sets Black point value.
RangeA Property
Gets/sets Color range A.
RangeB Property
Gets/sets Color range B.
WhitePoint Property
Gets/sets White point value


ImGearPDEColorDataCalLab Constructors

The ImGearPDEColorDataCalLab Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEColorDataCalLab Constructor
Creates new instance of ImGearPDEColorDataCalLab object.


ImGearPDEColorDataCalLab Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates the new instance of ImGearPDEColorDataCalLab Class object.

Declaration:

public ImGearPDEColorDataCalLab (  )

Return Value:

The new instance of ImGearPDEColorDataCalLab Class object.

See Also:

ImGearPDEColorDataCalLab Class


ImGearPDEColorDataCalLab Properties

The ImGearPDEColorDataCalLab Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
BlackPoint Property
Gets/sets Black point value.
RangeA Property
Gets/sets Color range A.
RangeB Property
Gets/sets Color range B.
WhitePoint Property
Gets/sets White point value


BlackPoint Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the black point value.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEXYZColor BlackPoint { get, set }

Value:

Any value of ImGearPDEXYZColor Class.

Default value:

N/A

See Also:

ImGearPDEXYZColor Class


RangeA Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the black point value.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEColorRange RangeA { get, set }

Value:

Any value of ImGearPDEColorRange Class.

Default value:

N/A

See Also:

ImGearPDEColorRange Class


RangeB Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the black point value.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEColorRange RangeB { get, set }

Value:

Any value of ImGearPDEColorRange Class.

Default value:

N/A

See Also:

ImGearPDEColorRange Class


WhitePoint Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the white point value.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEXYZColor WhitePoint { get, set }

Value:

Any value of ImGearPDEXYZColor Class.

Default value:

N/A

See Also:

ImGearPDEXYZColor Class


ImGearPDEColorDataCalRGB Class

32-bit
64-bit
CF
P
P

Description:

Describes a CalRGB color space.

Default calRGB = {{0, 0, 0}, {0, 0, 0}, 1, 1, 1, {1, 0, 0, 0, 1, 0, 0, 0, 1}};

Declaration:

public sealed class ImGearPDEColorDataCalRGB : ImageGear.Formats.PDF.ImGearPDEColorData

Members:

Constructors
Name
Description
ImGearPDEColorDataCalRGB Constructor
Creates the new instance of ImGearPDEColorDataCalRGB object.

Properties
Name
Description
BlackPoint Property
Gets/sets Black point value
BlueGamma Property
Gets/sets Blue gamma value
GreenGamma Property
Gets/sets Green gamma value
Matrix Property
Gets/sets Matrix
RedGamma Property
Gets/sets Red gamma value
WhitePoint Property
Gets/sets White point value


ImGearPDEColorDataCalRGB Constructors

The ImGearPDEColorDataCalRGB Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEColorDataCalRGB Constructor
Creates the new instance of ImGearPDEColorDataCalRGB object.


ImGearPDEColorDataCalRGB Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates the new instance of ImGearPDEColorDataCalRGB Class object.

Declaration:

public ImGearPDEColorDataCalLab (  )

Return Value:

The new instance of ImGearPDEColorDataCalRGB Class object.

See Also:

ImGearPDEColorDataCalRGB Class


ImGearPDEColorDataCalRGB Properties

The ImGearPDEColorDataCalRGB Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
BlackPoint Property
Gets/sets Black point value
BlueGamma Property
Gets/sets Blue gamma value
GreenGamma Property
Gets/sets Green gamma value
Matrix Property
Gets/sets Matrix
RedGamma Property
Gets/sets Red gamma value
WhitePoint Property
Gets/sets White point value


BlueGamma Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the Blue gamma value.

Declaration:

public float BlueGamma { get, set }

Value:

Any positive value.

Default value:

1


GreenGamma Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the Green gamma value.

Declaration:

public float GreenGamma { get, set }

Value:

Any positive value.

Default value:

1


Matrix Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the Matrix.

Declaration:

public float[] Matrix { get, set }

Value:

Any positive value.

Default value:

{1, 0, 0, 0, 1, 0, 0, 0, 1}


RedGamma Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the Red gamma value.

Declaration:

public float RedGamma { get, set }

Value:

Any positive value.

Default value:

1


ImGearPDEColorDataDeviceN Class

32-bit
64-bit
CF
P
P

Description:

DeviceN color space.

Declaration:

public sealed class ImGearPDEColorDataDeviceN : ImageGear.Formats.PDF.ImGearPDEColorData

Members:

Constructors
Name
Description
ImGearPDEColorDataDeviceN Constructor
Creates the new instance of ImGearPDEColorDataDeviceN object.

Properties
Name
Description
AltColorSpace Property
Gets/sets alternative color space.
Names Property
Gets/sets the Names of colorants.
TintTransform Property
Gets/sets the the tintTransform dictionary or function.

See Also:

ImGearPDEColorData Class


ImGearPDEClip Constructors

The ImGearPDEColorDataDeviceN Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEColorDataDeviceN Constructor
Creates the new instance of ImGearPDEColorDataDeviceN object.


ImGearPDEColorDataDeviceN Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates the new instance of ImGearPDEColorDataDeviceN Class object.

Declaration:

public ImGearPDEColorDataDeviceN ( )

Return Value:

The new instance of ImGearPDEColorDataDeviceN Class object.

See Also:

ImGearPDEColorDataDeviceN Class


ImGearPDEClip Properties

The ImGearPDEColorDataDeviceN Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
AltColorSpace Property
Gets/sets alternative color space.
Names Property
Gets/sets the Names of colorants.
TintTransform Property
Gets/sets the the tintTransform dictionary or function.


AltColorSpace Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets alternative color space.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEColorSpace AltColorSpace { get, set }

Value:

Any value of ImGearPDEColorSpace Class.

Default value:

NULL

See Also:

ImGearPDEColorSpace Class


Names Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the Names of colorants.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom[] Names { get, set }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFAtom Class


TintTransform Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the tintTransform dictionary or function. See Section 4.5.5 in the PDF Reference for more information.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFBasObj TintTransform { get, set }

Value:

ImGearPDFBasObj Class object.

Default value:

NULL

See Also:

ImGearPDFBasObj Class


ImGearPDEColorDataICCBased Class

32-bit
64-bit
CF
P
P

Description:

ICC based color space.

Declaration:

public sealed class ImGearPDEColorDataICCBased : ImageGear.Formats.PDF.ImGearPDEColorData

Members:

Constructors
Name
Description
ImGearPDEColorDataICCBased Constructor
Creates new instance of ImGearPDEColorDataICCBased object.

Properties
Name
Description
AltColorSpace Property
Gets/sets alternate color space.
CompsCount Property
Gets/sets the number of color components (1, 3, or 4).
ICCStream Property
Gets/sets the stream containing ICC Profile.


ImGearPDEColorDataICCBased Constructors

The ImGearPDEColorDataICCBased Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEColorDataICCBased Constructor
Creates new instance of ImGearPDEColorDataICCBased object.


ImGearPDEColorDataICCBased Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates the new instance of ImGearPDEColorDataICCBased Class object.

Declaration:

public ImGearPDEColorDataICCBased ( )

Return Value:

The new instance of ImGearPDEColorDataICCBased Class object.

See Also:

ImGearPDEColorDataICCBased Class


ImGearPDEColorDataICCBased Properties

The ImGearPDEColorDataICCBased Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
AltColorSpace Property
Gets/sets alternate color space.
CompsCount Property
Gets/sets the number of color components (1, 3, or 4).
ICCStream Property
Gets/sets the stream containing ICC Profile.


AltColorSpace Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets alternate color space.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEColorSpace AltColorSpace { get, set }

Value:

ImGearPDEColorSpace Class object.

Default value:

NULL

See Also:

ImGearPDEColorSpace Class


CompsCount Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the number of color components (1, 3, or 4).

Declaration:

public int CompsCount { get, set }

Value:

1, 3 or 4

Default value:

NULL


ICCStream Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the stream containing ICC Profile.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFBasObj TintTransform { get, set }

Value:

ImGearPDFBasObj Class object.

Default value:

NULL

See Also:

ImGearPDFBasObj Class


ImGearPDEColorDataIndexed Class

32-bit
64-bit
CF
P
P

Description:

This class presents the Indexed color space.

Declaration:

public sealed class ImGearPDEColorDataIndexed : ImageGear.Formats.PDF.ImGearPDEColorData

Members:

Constructors
Name
Description
ImGearPDEColorDataIndexed Constructor
Creates the new instance of ImGearPDEColorDataIndexed object.

Properties
Name
Description
BaseColorSpace Property
Gets/sets the Base color space.
HiVal Property
Gets/sets the Highest color value.
LookUp Property
Gets/sets the Indexed color lookup data.


ImGearPDEColorDataIndexed Constructors

The ImGearPDEColorDataIndexed Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEColorDataIndexed Constructor
Creates the new instance of ImGearPDEColorDataIndexed object.


ImGearPDEColorDataIndexed Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates the new instance of ImGearPDEColorDataIndexed Class object.

Declaration:

public ImGearPDEColorDataIndexed ( )

Return Value:

The new instance of ImGearPDEColorDataIndexed Class object.

See also:

ImGearPDEColorDataIndexed Class


ImGearPDEColorDataIndexed Properties

The ImGearPDEColorDataIndexed Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
BaseColorSpace Property
Gets/sets the Base color space.
HiVal Property
Gets/sets the Highest color value.
LookUp Property
Gets/sets the Indexed color lookup data.


BaseColorSpace Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the Base color space.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEColorSpace BaseColorSpace { get, set }

Value:

ImGearPDEColorSpace Class object.

Default value:

NULL

See Also:

ImGearPDEColorSpace Class


HiVal Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the Highest color value.

Declaration:

public int HiVal{ get, set }

Value:

Integer value

Default value:

NULL


LookUp Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the Indexed color lookup data.

Declaration:

public byte[] LookUp { get, set }

Value:

Integer byte array.

Default value:

N/A


ImGearPDEColorDataSeparation Class

32-bit
64-bit
CF
P
P

Description:

Separation color space class.

Declaration:

public sealed class ImGearPDEColorDataSeparation :
ImageGear.Formats.PDF.ImGearPDEColorData

Members:

Constructors
Name
Description
ImGearPDEColorDataSeparation Constructor
Creates the new instance of ImGearPDEColorDataSeparation object.

Properties
Name
Description
AltColorSpace Property
Gets/sets the Alternative color space.
Name Property
Gets/sets the Name of separation or colorant.
TintTransform Property
Gets/sets the TintTransform dictionary or function.


ImGearPDEColorDataSeparation Constructors

The ImGearPDEColorDataSeparation Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEColorDataSeparation Constructor
Creates the new instance of ImGearPDEColorDataSeparation object.


ImGearPDEColorDataSeparation Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates the new instance of ImGearPDEColorDataSeparation object.

Declaration:

public ImGearPDEColorDataSeparation ( )

Return Value:

The new instance of ImGearPDEColorDataSeparation Class object.

See Also:

ImGearPDEColorDataSeparation Class


ImGearPDEColorDataSeparation Properties

The ImGearPDEColorDataSeparation Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
AltColorSpace Property
Gets/sets the Alternative color space.
Name Property
Gets/sets the Name of separation or colorant.
TintTransform Property
Gets/sets the TintTransform dictionary or function.


AltColorSpace Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the Alternative color space.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEColorSpace AltColorSpace { get, set }

Value:

ImGearPDEColorSpace Class object.

Default value:

NULL

See Also:

ImGearPDEColorSpace Class


Name Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the Name of separation or colorant.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom Name{ get, set }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFAtom Class


TintTransform Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the TintTransform dictionary or function. See Section 4.5.5 in the PDF Reference for more information.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFBasObj TintTransform { get, set }

Value:

ImGearPDFBasObj Class object.

Default value:

NULL

See Also:

ImGearPDFBasObj Class


ImGearPDEColorRange Class

32-bit
64-bit
CF
P
P

Description:

This class contains color range.

Declaration:

public sealed class ImGearPDEColorRange : System.Object

Members:

Constructors
Name
Description
ImGearPDEColorRange Constructor
Creates the new instance of ImGearPDEColorRange object.

Properties
Name
Description
Max Property
Gets/sets Max value.
Min Property
Gets/sets Min value.


ImGearPDEColorRange Constructors

The ImGearPDEColorRange Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEColorRange Constructor
Creates the new instance of ImGearPDEColorRange object.


ImGearPDEColorRange Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates the new instance of ImGearPDEColorRange object.

Declaration:

public ImGearPDEColorRange ( )

Return Value:

The new instance of ImGearPDEColorRange Class object.

See Also:

ImGearPDEColorRange Class


ImGearPDEColorRange Properties

The ImGearPDEColorRange Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
Max Property
Gets/sets Max value.
Min Property
Gets/sets Min value.


Max Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets Max value.

Declaration:

public float Max { get, set }

Value:

Float value.

Default value:

NULL


Min Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets Min value.

Declaration:

public float Min { get, set }

Value:

Float value.

Default value:

NULL


ImGearPDEColorSpace Class

32-bit
64-bit
CF
P
P

Description:

This class represents a reference to a color space used on a page in a PDF file. The color space is the part of the graphics state attributes of a PDE Element.

Declaration:

public sealed class ImGearPDEColorSpace : ImageGear.Formats.PDF.ImGearPDEObject

Members:

Constructors
Name
Description
ImGearPDEColorSpace Constructor
Creates a new color space object of the specified type.
ImGearPDEColorSpace Constructor
Creates a new color space object of the specified type.

Properties
Name
Description
BaseColorComponents Property
Gets the number of components in the base color space of an indexed color space.
BaseName Property
Gets the name of the base color space.
ColorComponents Property
Gets the number of components in the color space.
HiVal Property
Gets the highest index for the color lookup table for an indexed color space.
Name Property
Gets the color space object's name.

Methods
Name
Description
GetCTable Method
Gets the color lookup table, which is BaseColorComponents *(HiVal + 1) bytes long, where ColorComponents = number of components in the base color space.


ImGearPDEColorSpace Constructors

The ImGearPDEColorSpace Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEColorSpace Constructor
Creates a new color space object of the specified type.
ImGearPDEColorSpace Constructor
Creates a new color space object of the specified type.


ImGearPDEColorSpace Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new color space object of the specified type.

Declaration:

public ImGearPDEColorSpace ( ImageGear.Formats.PDF.ImGearPDFAtom Name ,
ImageGear.Formats.PDF.ImGearPDEColorData ColorData )

Parameters:

Name
Type
Description
Name
ImGearPDFAtom Class
Supports the following PDF color spaces:
- Device-dependent names: DeviceCMYK, DeviceGray, DeviceN, or DeviceRGB.
- Device-independent names: CalGray, CalRGB, Lab, or ICCBased.
- Special names: Indexed, Pattern, or Separation.
ColorData
ImGearPDEColorData Class
Color data for the type of color space you want to create.

Return Value:

The new instance of ImGearPDEColorSpace Class object.

See Also:

ImGearPDFAtom Class

ImGearPDEColorData Class


ImGearPDEColorSpace Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new color space object of the specified type.

Declaration:

public ImGearPDEColorSpace ( ImageGear.Formats.PDF.ImGearPDFAtom Name )

Parameters:

Name
Type
Description
Name
ImGearPDFAtom Class
Supports the following PDF color spaces:
- Device-dependent names: DeviceCMYK, DeviceGray, DeviceN, or DeviceRGB.
- Device-independent names: CalGray, CalRGB, Lab, or ICCBased.
- Special names: Indexed, Pattern, or Separation.

Return Value:

The new instance of ImGearPDEColorSpace Class object.

See Also:

ImGearPDFAtom Class


ImGearPDEColorSpace Properties

The ImGearPDEColorSpace Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
BaseColorComponents Property
Gets the number of components in the base color space of an indexed color space.
BaseName Property
Gets the name of the base color space.
ColorComponents Property
Gets the number of components in the color space.
HiVal Property
Gets the highest index for the color lookup table for an indexed color space.
Name Property
Gets the color space object's name.


BaseColorComponents Property

32-bit
64-bit
CF
P
P

Description:

Gets the number of components in the base color space of an indexed color space. For example, for [/Indexed /DeviceRGB...], the number of components is 3.

Declaration:

public int BaseColorComponents { get }

Value:

Integer number.

Default value:

N/A


BaseName Property

32-bit
64-bit
CF
P
P

Description:

This property gets the name of the base color space. This is a helper routine for indexed color spaces.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom BaseName { get }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFAtom Class


ColorComponents Property

32-bit
64-bit
CF
P
P

Description:

This property gets the number of components in the color space. For the following color spaces the number of components is:

  • DeviceGray, CalGray, Separation: 1.
  • DeviceRGB, CalRGB: 3.
  • DeviceCMYK, Lab: 4.
  • DeviceN, ICCBased: the number of components dependent on the specific color space object
  • Indexed: 1.

Use BaseColorComponents to get the number of components in the base color space.

Declaration:

public int ColorComponents { get }

Value:

1, 3, 4

Default value:

N/A


HiVal Property

32-bit
64-bit
CF
P
P

Description:

This property gets the highest index for the color lookup table for an indexed color space. Since the color table is indexed from 0 to HiVal, the actual number of entries is HiVal + 1.

Declaration:

public int HiVal { get }

Value:

Integer value

Default value:

N/A


Name Property

32-bit
64-bit
CF
P
P

Description:

This property gets the color space object's name. Supports the following PDF color spaces:

  • Device-dependent names: DeviceCMYK, DeviceGray, DeviceN, or DeviceRGB.
  • Device-independent names: CalGray, CalRGB, Lab, or ICCBased.
  • Special names: Indexed, Pattern, or Separation..

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom Name { get }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFAtom Class


ImGearPDEColorSpace Methods

The ImGearPDEColorSpace Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
GetCTable Method
Gets the color lookup table, which is BaseColorComponents *(HiVal + 1) bytes long, where ColorComponents = number of components in the base color space.


GetCTable Method

32-bit
64-bit
CF
P
P

Description:

This method gets the color lookup table, which is BaseColorComponents *(HiVal + 1) bytes long, where ColorComponents = number of components in the base color space. Each entry in the table contains BaseColorComponents bytes, and the table is indexed 0 to HiVal, where HiVal is the highest index in the color table. The table is indexed from 0 to HiVal, thus the table contains HiVal + 1 entries.

Declaration:

public byte[] GetCTable ( )

Return Value:

Array of bytes.

See also:

ImGearPDEColorSpace Properties


ImGearPDEColorSpec Class

32-bit
64-bit
CF
P
P

Description:

This class describes color specification.

Declaration:

public sealed class ImGearPDEColorSpec : ImageGear.Formats.PDF.ImGearPDFObject

Members:

Constructors
Name
Description
ImGearPDEColorSpec Constructor
Creates a new color spec object.

Properties
Name
Description
Space Property
Reference to color space object.
Value Property
Reference to color value object.


ImGearPDEColorSpec Constructors

The ImGearPDEColorSpec Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEColorSpec Constructor
Creates a new color spec object.


ImGearPDEColorSpec Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new color spec object.

Declaration:

public ImGearPDEColorSpec ( )

Return Value:

The new instance of ImGearPDEColorSpec Class object.

See Also:

ImGearPDEColorSpec Class


ImGearPDEColorSpec Properties

The ImGearPDEColorSpec Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
Space Property
Reference to color space object.
Value Property
Reference to color value object.


Space Property

32-bit
64-bit
CF
P
P

Description:

Reference to color space object.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEColorSpace Space { get, set }

Value:

ImGearPDEColorSpace Class object.

Default value:

N/A

See Also:

ImGearPDEColorSpace Class


Value Property

32-bit
64-bit
CF
P
P

Description:

Reference to color value object.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEColorValue Value { get, set }

Value:

ImGearPDEColorValue Class object.

Default value:

N/A

See Also:

ImGearPDEColorValue Class


ImGearPDEColorValue Class

32-bit
64-bit
CF
P
P

Description:

This class describes color value.

Declaration:

public sealed class ImGearPDEColorValue : ImageGear.Formats.PDF.ImGearPDFObject

Members:

Constructors
Name
Description
ImGearPDEColorValue Constructor
Creates a new color value object.

Properties
Name
Description
Color Property
Color value components.
ColorObj Property
Parameter for color spaces whose color values do not have numeric values.
ColorObj2 Property
For DeviceN color space.


ImGearPDEColorValue Constructors

The ImGearPDEColorValue Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEColorValue Constructor
Creates a new color value object.


ImGearPDEColorValue Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new color value object.

Declaration:

public ImGearPDEColorValue ( )

Return Value:

The new instance of ImGearPDEColorValue Class object.

See Also:

ImGearPDEColorValue Class


ImGearPDEColorValue Properties

The ImGearPDEColorValue Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
Color Property
Color value components.
ColorObj Property
Parameter for color spaces whose color values do not have numeric values.
ColorObj2 Property
For DeviceN color space.


Color Property

32-bit
64-bit
CF
P
P

Description:

Color value components. For instance, Gray color space has 1 component, RGB color space has 3 components and CMYK has 4 components.

Declaration:

public int[] Color { get, set }

Value:

1, 3, 4

Default value:

N/A


ColorObj Property

32-bit
64-bit
CF
P
P

Description:

Parameter for color spaces whose color values do not have numeric values, such as the Pattern and Separation color spaces.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEObject ColorObj { get, set }

Value:

ImGearPDEObject Class object.

Default value:

N/A

See Also:

ImGearPDEObject Class


ColorObj2 Property

32-bit
64-bit
CF
P
P

Description:

For DeviceN color space.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEObject ColorObj2 { get, set }

Value:

ImGearPDEObject Class object.

Default value:

N/A

See Also:

ImGearPDEObject Class


ImGearPDEContainer Class

32-bit
64-bit
CF
P
P

Description:

This is a group of elements on a page in a PDF file. In the PDF file, containers are delimited by Marked Content BMC/EMC or BDC/EMC pairs. Every container has a Marked Content tag associated with it. In addition to grouping a set of elements, a BDC/EMC pair specifies a property list to be associated with the grouping. Thus a container corresponding to a BDC/EMC pair also has a property list dictionary associated with it.

See Section 10.5 in the PDF reference for more information about Marked Content operators.

Declaration:

public sealed class ImGearPDEContainer : ImageGear.Formats.PDF.ImGearPDEElement

Members:

Constructors
Name
Description
ImGearPDEContainer Constructor
Creates container object

Properties
Name
Description
IsDictionaryInline Property
True if the dictionary is inline, false otherwise.

Methods
Name
Description
GetContent Method
Gets container's content object.
GetDictionary Method
Gets marked Content dictionary for a container.
GetMCTag Method
Gets Marked Content tag for a container.
SetContent Method
Sets container's content object.
SetDictionary Method
Changes the Marked Content dictionary for the container.
SetMCTag Method
Sets Marked Content tag for a container.


ImGearPDEContainer Constructors

The ImGearPDEContainer Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEContainer Constructor
Creates container object


ImGearPDEContainer Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates container object.

Declaration:

public ImGearPDEContainer ( ImageGear.Formats.PDF.ImGearPDFAtom MCTag ,
ImageGear.Formats.PDF.ImGearPDFBasObj MCDictionary , Boolean IsInline )

Parameters:

Name
Type
Description
MCTag
ImGearPDFAtom Class
Tag name for the container.
MCDictionary
ImGearPDFBasObj Class
Optional Marked Content dictionary for the container.
IsInline
Boolean
If True, emits container into the page content stream inline.

Return Value:

The new instance of ImGearPDEContainer Class object.

See Also:

ImGearPDFAtom Class

ImGearPDFBasObj Class


ImGearPDEContainer Properties

The ImGearPDEContainer Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
IsDictionaryInline Property
True if the dictionary is inline, false otherwise.


IsDictionaryInline Property

32-bit
64-bit
CF
P
P

Description:

True if the dictionary is inline, False otherwise. Undefined if the container has no Marked Content dictionary.

Declaration:

public bool IsDictionaryInline { get }

Value:

True, False

Default value:

N/A


ImGearPDEContainer Methods

The ImGearPDEContainer Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
GetContent Method
Gets container's content object.
GetDictionary Method
Gets marked Content dictionary for a container.
GetMCTag Method
Gets Marked Content tag for a container.
SetContent Method
Sets container's content object.
SetDictionary Method
Changes the Marked Content dictionary for the container.
SetMCTag Method
Sets Marked Content tag for a container.


GetContent Method

32-bit
64-bit
CF
P
P

Description:

This method gets container's content object.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEContent GetContent ( )

Return Value:

ImGearPDEContent Class object.

See Also:

ImGearPDEContent Class


GetDictionary Method

32-bit
64-bit
CF
P
P

Description:

This method gets marked Content dictionary for a container. NULL if the container has no Marked Content dictionary.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFBasDict GetDictionary (  )

Return Value:

ImGearPDFBasDict Class object.

See Also:

ImGearPDFBasDict Class


GetMCTag Method

32-bit
64-bit
CF
P
P

Description:

This method gets Marked Content tag for a container..

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom GetMCTag ( )

Return Value:

ImGearPDFAtom Class object.

See Also:

ImGearPDFAtom Class


SetContent Method

32-bit
64-bit
CF
P
P

Description:

This method sets container's content object.

Declaration:

public void SetContent ( ImageGear.Formats.PDF.ImGearPDEContent Content )

Parameters:

Name
Type
Description
Content
ImGearPDEContent Class
Container's content object

Return Value:

None.

See Also:

ImGearPDEContent Class


SetDictionary Method

32-bit
64-bit
CF
P
P

Description:

This method changes the Marked Content dictionary for the container.

Declaration:

public void SetDictionary ( ImageGear.Formats.PDF.ImGearPDFBasDict Dictionary , Boolean
IsInline )

Parameters:

Name
Type
Description
Dictionary
ImGearPDFBasDict Class
Marked Content dictionary being set into the container.
IsInline
Boolean
If True, the dictionary is emitted inline.

Return Value:

None.

See Also:

ImGearPDFBasDict Class


SetMCTag Method

32-bit
64-bit
CF
P
P

Description:

This method sets Marked Content tag for a container.

Declaration:

public void SetMCTag ( ImageGear.Formats.PDF.ImGearPDFAtom MCTag )

Parameters:

Name
Type
Description
MCTag
ImGearPDFAtom Class
Marked Content tag for a container.

Return Value:

None.

See Also:

ImGearPDFAtom Class


ImGearPDEContent Class

32-bit
64-bit
CF
P
P

Description:

PDE content object. Modifiable content of a PDF page, which contains elements. Content may be obtained from an existing page or from a Form XObject.

Declaration:

public sealed class ImGearPDEContent : ImageGear.Formats.PDF.ImGearPDEObject

Members:

Properties
Name
Description
ElementCount Property
The number of elements in the ImGearPDEContent.

Methods
Name
Description
AddElement Method
Inserts an element into content.
CreateEmptyContent Method
Creates empty ImGearPDEContent.
GetAttributes Method
Gets the content attributes.
GetDefaultColorSpace Method
Gets a default color space from the current content.
GetElement Method
Obtains requested element from content.
RemoveElement Method
Removes an element from content.


ImGearPDEContent Properties

The ImGearPDEContent Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
ElementCount Property
The number of elements in the ImGearPDEContent.


ElementCount Property

32-bit
64-bit
CF
P
P

Description:

The number of elements in the ImGearPDEContent.

Declaration:

public int ElementCount { get }

Value:

Integer number.

Default value:

N/A

See Also:

ImGearPDEContent Class


ImGearPDEContent Methods

The ImGearPDEContent Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
AddElement Method
Inserts an element into content.
CreateEmptyContent Method
Creates empty ImGearPDEContent.
GetAttributes Method
Gets the content attributes.
GetDefaultColorSpace Method
Gets a default color space from the current content.
GetElement Method
Obtains requested element from content.
RemoveElement Method
Removes an element from content.


AddElement Method

32-bit
64-bit
CF
P
P

Description:

This method Inserts an element into content.

Declaration:

public void AddElement ( int AfterIndex , ImageGear.Formats.PDF.ImGearPDEElement Element )

Parameters:

Name
Type
Description
AfterIndex
int
Location after which Element is added. Should be BEFORE_FIRST_PAGE to add to the beginning of the display list.
Element
ImGearPDEElement Class
ImGearPDEElement interface of the element to insert into content.

Return Value:

None.

See Also:

ImGearPDEElement Class


CreateEmptyContent Method

32-bit
64-bit
CF
P
P

Description:

This method creates empty ImGearPDEContent Class.

Declaration:

public static ImGearPDEContent CreateEmptyContent()

Parameters:

None

Return Value:

The empty ImGearPDEContent Class.

See Also:

ImGearPDEElement Class


GetAttributes Method

32-bit
64-bit
CF
P
P

Description:

This method gets the content attributes.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEContentAttrs GetAttributes ( )

Return Value:

ImGearPDEContentAttrs Class object.

See Also:

ImGearPDEContentAttrs Class


GetDefaultColorSpace Method

32-bit
64-bit
CF
P
P

Description:

This method Gets a default color space from the current content.

See Section 4.5.4 in the PDF Reference for more information about default color spaces.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEColorSpace GetDefaultColorSpace
(ImageGear.Formats.PDF.ImGearPDFAtom ColorSpaceName)

Parameters:

Name
Type
Description
ColorSpaceName
ImGearPDFAtom Class
An atom for the name of the desired color space. Must be an atom for one of DefaultRGB, DefaultCMYK, or DefaultGray.

Return Value:

ImGearPDEColorSpace Class object. Returns NULL, if ColorSpaceName does not correspond to a known default, such as DefaultRGB.

See Also:

ImGearPDEColorSpace Class

ImGearPDFAtom Class


GetElement Method

32-bit
64-bit
CF
P
P

Description:

This method obtains requested element from content.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEElement GetElement ( int Index )

Parameters:

Name
Type
Description
Index
int
Index of the element to get.

Return Value:

ImGearPDEElement Class object.

See Also:

ImGearPDEElement Class


RemoveElement Method

32-bit
64-bit
CF
P
P

Description:

This method removes an element from content.

Declaration:

public void RemoveElement ( int Index )

Parameters:

Name
Type
Description
Index
int
Index of the element to remove.

Return Value:

None.


ImGearPDEContentAttrs Class

32-bit
64-bit
CF
P
P

Description:

Attributes of a PDE Content object.

Declaration:

public sealed class ImGearPDEContentAttrs : System.Object

Members:

Constructors
Name
Description
ImGearPDEContentAttrs Constructor
Creates new instance of ImGearPDEContentAttrs object.

Properties
Name
Description
BBox Property
Bounding box of the content object.
CacheDevice Property
If flags has SET_CACHE_DEVICE set, the first 6 cache device values contain the operands for the d1 (setcachdevice) page operator. If flags has SET_CHAR_WIDTH set, cacheDevice contains 2 charwidth values.
Flags Property
Content flags.
FormType Property
Only used if the content contains a Form XObject. Corresponds to FormType key in the XObject Form attributes dictionary.
Matrix Property
Transformation matrix for the content object.


ImGearPDEContentAttrs Constructors

The ImGearPDEContentAttrs Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEContentAttrs Constructor
Creates new instance of ImGearPDEContentAttrs object.


ImGearPDEContentAttrs Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor Creates new instance of ImGearPDEContentAttrs object.

Declaration:

public ImGearPDEContentAttrs ( )

Return Value:

The new instance of ImGearPDEContentAttrs Class object.

See Also:

ImGearPDEContentAttrs Class


ImGearPDEContentAttrs Properties

The ImGearPDEContentAttrs Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
BBox Property
Bounding box of the content object.
CacheDevice Property
If flags has SET_CACHE_DEVICE set, the first 6 cache device values contain the operands for the d1 (setcachdevice) page operator. If flags has SET_CHAR_WIDTH set, cacheDevice contains 2 charwidth values.
Flags Property
Content flags.
FormType Property
Only used if the content contains a Form XObject. Corresponds to FormType key in the XObject Form attributes dictionary.
Matrix Property
Transformation matrix for the content object.


BBox Property

32-bit
64-bit
CF
P
P

Description:

Bounding box of the content object. Only used if the content contains a Form. Corresponds to BBox key in the XObject Form attributes dictionary.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFFixedRect BBox { get, set }

Value:

ImGearPDFFixedRect Class object.

Default value:

N/A

See Also:

ImGearPDFFixedRect Class


CacheDevice Property

32-bit
64-bit
CF
P
P

Description:

If Flags has SET_CACHE_DEVICE set, the first 6 cache device values contain the operands for the d1 (setcachdevice) page operator. If Flags has SET_CHAR_WIDTH set, cache device contains 2 char width values.

Declaration:

public int[] CacheDevice{ get, set }

Value:

Integer array.

Default value:

{0, 0, 0, 0, 0, 0, 0, 0}


Flags Property

32-bit
64-bit
CF
P
P

Description:

Content flags.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEContentFlags Flags { get, set }

Value:

ImGearPDEContentFlags Enumeration value.

Default value:

NULL

See Also:

ImGearPDEContentFlags Enumeration


FormType Property

32-bit
64-bit
CF
P
P

Description:

Only used, if the content contains a Form XObject. Corresponds to FormType key in the XObject Form attributes dictionary.

Declaration:

public int FormType { get, set }

Value:

Integer number.

Default value:

NULL


Matrix Property

32-bit
64-bit
CF
P
P

Description:

Transformation matrix for the content object. Only used, if the content contains a Form. Corresponds to Matrix key in the XObject Form attributes dictionary.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFFixedMatrix Matrix { get, set }

Value:

ImGearPDFFixedMatrix Class object.

Default value:

N/A

See Also:

ImGearPDFFixedMatrix Class


ImGearPDEDash Class

32-bit
64-bit
CF
P
P

Description:

Describes dash specification, as described in Table 4.8 in the PDF Reference. See Section 4.3.2 for more information on line dash patterns.

Declaration:

public sealed class ImGearPDEDash

Members:

Constructors
Name
Description
ImGearPDEDash Constructor
Creates new instance of ImGearPDEDash object.

Properties
Name
Description
Phase Property
Dash phase.
Dashes Property
Dash array, which specifies distances in user space for the length of dashes and gaps.


ImGearPDEDash Constructors

The ImGearPDEDash Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEDash Constructor
Creates new instance of ImGearPDEDash object.


ImGearPDEDash Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor Creates new instance of ImGearPDEDash object.

Declaration:

public ImGearPDEDash ( )

Return Value:

The new instance of ImGearPDEDash Class object.

See also:

ImGearPDEDash Class


ImGearPDEDash Properties

The ImGearPDEDash Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
Phase Property
Dash phase.
Dashes Property
Dash array, which specifies distances in user space for the length of dashes and gaps.


Phase Property

32-bit
64-bit
CF
P
P

Description:

Phase is a number that specifies a distance in user space into the dash pattern at which to begin marking the path.

Declaration:

public int Phase { get, set }

Value:

Any integer number.

Default value:

0


Dashes Property

32-bit
64-bit
CF
P
P

Description:

Dash array, which specifies distances in user space for the length of dashes and gaps.

Declaration:

public int[] Dashes { get, set }

Value:

Array of integer numbers.

Default value:

N/A


ImGearPDEElement Class

32-bit
64-bit
CF
P
P

Description:

Base class for the elements of a page display list (PDE content) and for clip objects. The general PDE element methods allow you to get and set general element properties.

Declaration:

public abstract class ImGearPDEElement : ImageGear.Formats.PDF.ImGearPDEObject

Members:

Properties
Name
Description
HasGState Property
True if the element has a graphics state; False otherwise.

Methods
Name
Description
Clone Method
Makes a copy of an element.
GetBBox Method
Gets the bounding box for an element, specified in user space coordinates.
GetClip Method
Gets the current clip for an element.
GetDictionary Method
Returns a Dictionary (OCMD object) that is associated with this Element.
GetGState Method
Gets the graphics state information for an element.
GetMatrix Method
Gets the transformation matrix for an element.
GetOCMDictionary Method
Gets a dictionary (OCMD object), which is associated with this Element.
IsAtPoint Method
Tests whether a point is on an element.
IsAtRect Method
Tests whether any part of a rectangle is on an element.
SetClip Method
Sets the current clip for an element.
SetGState Method
Sets the graphics state information for an element.
SetMatrix Method
Sets the transformation matrix for an element.
UniqueId Method
Returns some 32-bit integer that is unique for all Element objects.


ImGearPDEElement Properties

The ImGearPDEElement Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
HasGState Property
True if the element has a graphics state; False otherwise.


HasGState Property

32-bit
64-bit
CF
P
P

Description:

True if the element has a graphics state; false otherwise.

Declaration:

public bool HasGState { get }

Value:

True, False.

Default value:

N/A


ImGearPDEElement Methods

The ImGearPDEElement Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
Clone Method
Makes a copy of an element.
GetBBox Method
Gets the bounding box for an element, specified in user space coordinates.
GetClip Method
Gets the current clip for an element.
GetDictionary Method
Returns a Dictionary (OCMD object) that is associated with this Element.
GetGState Method
Gets the graphics state information for an element.
GetMatrix Method
Gets the transformation matrix for an element.
GetOCMDictionary Method
Gets a dictionary (OCMD object), which is associated with this Element.
IsAtPoint Method
Tests whether a point is on an element.
IsAtRect Method
Tests whether any part of a rectangle is on an element.
SetClip Method
Sets the current clip for an element.
SetGState Method
Sets the graphics state information for an element.
SetMatrix Method
Sets the transformation matrix for an element.
UniqueId Method
Returns some 32-bit integer that is unique for all Element objects.


Clone Method

32-bit
64-bit
CF
P
P

Description:

This method makes a copy of an element.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEElement Clone (
ImageGear.Formats.PDF.ImGearPDEElementCopyFlags Flags )

Parameters:

Name
Type
Description
Flags
ImGearPDEElementCopyFlags Enumeration
Bit field of enumImGearPDEElementCopyFlags.

Return Value:

ImGearPDEElement Class object.

See Also:

ImGearPDEElement Class

ImGearPDEElementCopyFlags Enumeration


GetBBox Method

32-bit
64-bit
CF
P
P

Description:

Gets the bounding box for an element, specified in user space coordinates

The bounding box is guaranteed to encompass the element, but is not guaranteed to be the smallest box that could contain the element. For example, for an arc, the bounding box encloses the Bezier control points-not just the curve itself.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFFixedRect GetBBox (  )

Return Value:

ImGearPDFFixedRect Class object.

See Also:

ImGearPDFFixedRect Class


GetClip Method

32-bit
64-bit
CF
P
P

Description:

This method gets the current clip for an element

NOTE: A clip may be shared by many elements. Use care when modifying a clip. Copy it first if you want to modify the clip for a specific element.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEClip GetClip (  )

Return Value:

ImGearPDEClip Class object.

See Also:

ImGearPDEClip Class


GetDictionary Method

32-bit
64-bit
CF
P
P

NOTE: This method is obsolete, please use GetOCMDictionary Method instead.

Description:

Returns a Dictionary (OCMD object), which is associated with this Element. If no Dictionary is associated, returns NULL.

Declaration:

ImGearPDEElement.GetDictionary
(propget)

Return Value:

Associated Dictionary, or NULL if no Dictionary is associated.

See Also:

ImGearPDFDictionary Class


GetGState Method

32-bit
64-bit
CF
P
P

Description:

This method gets the graphics state information for an element.

This method is only valid for PDE Form, PDE Image, PDE Path and PDE Shading elements.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEGraphicState GetGState (  )

Return Value:

ImGearPDEGraphicState Class object.

See Also:

ImGearPDEGraphicState Class


GetMatrix Method

32-bit
64-bit
CF
P
P

Description:

This method gets the transformation matrix for an element.

This matrix provides the transformation from user space to device space for the element. If there is no cm operator (concatmatrix) in the page stream, the matrix is the identity matrix.

For text object, it specifies the identity matrix.

Writing is not supported for PDE Container, a PDE Group, a PDE Place or a PDE Text.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFFixedMatrix GetMatrix (  )

Return Value:

ImGearPDFFixedMatrix Class object.

See Also:

ImGearPDFFixedMatrix Class


GetOCMDictionary Method

32-bit
64-bit
CF
P
P

Description:

Gets a dictionary (OCMD object), which is associated with this Element. If no dictionary is associated, returns null.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFDictionary GetOCMDictionary()

Return Value:

Associated Dictionary, or null if no dictionary is associated.

See Also:

ImGearPDFDictionary Class


IsAtPoint Method

32-bit
64-bit
CF
P
P

Description:

This method tests whether a point is on an element.

If the current element is a Text or Image, it uses the bounding box of the element to make the check. If the current element is a Path and it is stroked, it checks if the point is on the path. If the current element is a Path and it is filled, it checks if the point is in the fill area, taking into consideration whether it is filled using the non-zero winding number rule or the even-odd rule.

Declaration:

public bool IsAtPoint ( ImageGear.Formats.PDF.ImGearPDFFixedPoint Point )

Parameters:

Name
Type
Description
Point
ImGearPDFFixedPoint Class
A point, specified in user space coordinates.

Return Value:

True if a point is on an element, False otherwise.

See Also:

ImGearPDFFixedPoint Class


IsAtRect Method

32-bit
64-bit
CF
P
P

Description:

This method tests whether any part of a rectangle is on an element.

If the current element is a PDE Text or PDE Image, it uses the bounding box of the PDE Element to make the check. If the current element is a PDE Path and it is stroked, it checks if the rectangle is on the path.

If the current element is a PDE Path and it is filled, it checks if the rectangle is in the fill area, taking into consideration whether it is filled using the non-zero winding number rule or the even-odd rule.

Declaration:

public bool IsAtRect ( ImageGear.Formats.PDF.ImGearPDFFixedRect Rect )

Parameters:

Name
Type
Description
Rect
ImGearPDFFixedRect Class
A rectangle, specified in user space coordinates.

Return Value:

True if any part of a rectangle is on an element, False otherwise.

See Also:

ImGearPDFFixedRect Class


SetClip Method

32-bit
64-bit
CF
P
P

Description:

This method sets the current clip for an element.

NOTE: A clip may be shared by many elements. Use care when modifying a clip. Copy it first if you want to modify the clip for a specific element.

Declaration:

public void SetClip ( ImageGear.Formats.PDF.ImGearPDEClip Clip )

Parameters:

Name
Type
Description
Clip
ImGearPDEClip Class
The clip for an element.

Return Value:

None.

See Also:

ImGearPDEClip Class


SetGState Method

32-bit
64-bit
CF
P
P

Description:

This method sets the graphics state information for an element

This method is only valid for PDE Form, PDE Image, PDE Path and PDE Shading elements.

Declaration:

public void SetGState ( ImageGear.Formats.PDF.ImGearPDEGraphicState GraphicState )

Parameters:

Name
Type
Description
GraphicState
ImGearPDEGraphicState Class
The graphics state information for an element.

Return Value:

None.

See Also:

ImGearPDEGraphicState Class


SetMatrix Method

32-bit
64-bit
CF
P
P

Description:

This method sets the transformation matrix for an element

This matrix provides the transformation from user space to device space for the element. If there is no cm operator (concatmatrix) in the page stream, the matrix is the identity matrix.

For text object, it specifies the identity matrix.

Writing is not supported for PDE Container, a PDE Group, a PDE Place or a PDE Text.

Declaration:

public void SetMatrix ( ImageGear.Formats.PDF.ImGearPDFFixedMatrix Matrix )

Parameters:

Name
Type
Description
Matrix
ImGearPDFFixedMatrix Class
The transformation matrix for an element.

Return Value:

None.

See Also:

ImGearPDFFixedMatrix Class


UniqueId Method

32-bit
64-bit
CF
P
P

Description:

Returns a 32-bit integer that is unique for all Element objects. In other words, it is guaranteed that there cannot be two Element objects with the same UniqueIds.

Can be used for Element objects' identification.

Declaration:

ImGearPDEElement.UniqueId
(get property)

Parameters:

None

Return Value:

A unique identifier of this Element Object.

See Also:

ImGearPDFDictionary Class


ImGearPDEFilterArray Class

32-bit
64-bit
CF
P
P

Description:

Array of filter specifications usually containing two or less filters: encoding and/or compression.

Declaration:

public sealed class ImGearPDEFilterArray

Members:

Constructors
Name
Description
ImGearPDEFilterArray Constructor
Creates new instance of ImGearPDEFilterArray object.

Properties
Name
Description
Count Property
Number of filters in the array.

Methods
Name
Description
AddSpec Method
Adds new filter specification to the filters array.
GetSpec Method
Gets a filter specification with specified Index.


ImGearPDEFilterArray Constructors

The ImGearPDEFilterArray Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEFilterArray Constructor
Creates new instance of ImGearPDEFilterArray object.


ImGearPDEFilterArray Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDEFilterArray object.

Declaration:

public ImGearPDEFilterArray ( )

Return Value:

The new instance of ImGearPDEFilterArray Class object.

See Also:

ImGearPDEFilterArray Class


ImGearPDEFilterArray Properties

The ImGearPDEFilterArray Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
Count Property
Number of filters in the array.


Count Property

32-bit
64-bit
CF
P
P

Description:

Number of filters in the array.

Declaration:

public int Count { get }

Value:

Any integer number.

Default value:

0


ImGearPDEFilterArray Methods

The ImGearPDEFilterArray Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
AddSpec Method
Adds new filter specification to the filters array.
GetSpec Method
Gets a filter specification with specified Index.


AddSpec Method

32-bit
64-bit
CF
P
P

Description:

This method adds new filter specification to the filters array.

Declaration:

public void AddSpec ( ImageGear.Formats.PDF.ImGearPDEFilterSpec FilterSpec )

Parameters:

Name
Type
Description
FilterSpec
ImGearPDEFilterSpec Class
Filter specification to add.

Return Value:

None.

See Also:

ImGearPDEFilterSpec Class


GetSpec Method

32-bit
64-bit
CF
P
P

Description:

Gets a filter specification with specified Index.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEFilterSpec GetSpec ( int Index )

Parameters:

Name
Type
Description
Index
int
The index of specification to get.

Return Value:

ImGearPDEFilterSpec Class object.

See Also:

ImGearPDEFilterSpec Class


ImGearPDEFilterSpec Class

32-bit
64-bit
CF
P
P

Description:

Filter element in a filter array.

Declaration:

public sealed class ImGearPDEFilterSpec

Members:

Constructors
Name
Description
ImGearPDEFilterSpec Constructor
Creates new instance of ImGearPDEFilterSpec object.

Properties
Name
Description
DecodeParams Property
Parameters used by the decoding filters specified with the Filter key.
EncodeParams Property
Parameters used when encoding the stream.
Name Property
Filter name.


ImGearPDEFilterSpec Constructors

The ImGearPDEFilterSpec Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEFilterSpec Constructor
Creates new instance of ImGearPDEFilterSpec object.


ImGearPDEFilterSpec Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDEFilterSpec object.

Declaration:

public ImGearPDEFilterSpec ( )

Return Value:

The new instance of ImGearPDEFilterSpec Class object.

See Also:

ImGearPDEFilterSpec Class


ImGearPDEFilterSpec Properties

The ImGearPDEFilterSpec Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
DecodeParams Property
Parameters used by the decoding filters specified with the Filter key.
EncodeParams Property
Parameters used when encoding the stream.
Name Property
Filter name.


DecodeParams Property

32-bit
64-bit
CF
P
P

Description:

Parameters used by the decoding filters specified with the Filter key. Corresponds to DecodeParms key in the stream dictionary. Must be set to null if filter spec is specified but no decode parameters are specified. This can be done by zeroing the unused decode params. Required decode params for DCTDecode are Columns, Rows, and Colors.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFBasObj DecodeParams { get, set }

Value:

ImGearPDFBasObj Class object.

Default value:

null

See Also:

ImGearPDFBasObj Class


EncodeParams Property

32-bit
64-bit
CF
P
P

Description:

Parameters used when encoding the stream. Required for DCTDecode filter; optional for other filters. Must be set to null if filter spec is specified but no encode parameters are specified.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFBasObj EncodeParams { get, set }

Value:

ImGearPDFBasObj Class object.

Default value:

null

See Also:

ImGearPDFBasObj Class


Name Property

32-bit
64-bit
CF
P
P

Description:

Filter name. Supported filters are:

  • ASCIIHexDecode
  • ASCII85Decode
  • LZWDecode
  • DCTDecode
  • CCITTFaxDecode
  • RunLengthDecode
  • FlateDecode
  • JPXDecode

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom Name { get, set }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFAtom Class


ImGearPDEFont Class

32-bit
64-bit
CF
P
P

Description:

This is a reference to a font used on a page in a PDF file. It may be equated with a font in the system.

Declaration:

public sealed class ImGearPDEFont : ImageGear.Formats.PDF.ImGearPDEObject

Members:

Constructors
Name
Description
ImGearPDEFont Constructor
Creates new instance of ImGearPDEFont object.
ImGearPDEFont Constructor
Creates new instance of ImGearPDEFont object.
ImGearPDEFont Constructor
Creates new instance of ImGearPDEFont object.
ImGearPDEFont Constructor
Creates new instance of ImGearPDEFont object.

Properties
Name
Description
CreateNeedFlags Property
Flags indicating what needs to be done to make the current font complete.
IsEmbedded Property
True if the font is embedded, False if it is not, or if it was created in one document and embedded in a different document.
IsMultibyte Property
True if the font contains any multi-byte characters, False otherwise.

Methods
Name
Description
CreateToUnicodeNow Method
Creates the /ToUnicode table.
CreateWidthsNow Method
Creates width entries for font.
EmbedNow Method
Embeds font stream.
EmbedNowDontSubset Method
Embeds the font inside Doc without creating a subset.
GetAttributes Method
Gets the font attributes.
GetCodeByteCount Method
Gets the number of bytes in a string of single or multi-byte character codes.
GetOneByteEncoding Method
Gets an atom array that is filled with the delta encodings for font.
GetSysEncoding Method
Gets the system encoding object associated with a font object.
GetSysFont Method
Gets the system font object associated with a font object.
GetWidths Method
Gets widths array.
GetWidthsNow Method
Creates width entries for font.
SetSysEncoding Method
Sets the system encoding object associated with a font object.
SetSysFont Method
Sets the system font object associated with a font object.
SubsetNow Method
Subsets a given PDE Font in Doc.
SumWidths Method
Gets the sum to the widths from a string of single or multi-byte characters.


ImGearPDEFont Constructors

The ImGearPDEFont Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEFont Constructor
Creates new instance of ImGearPDEFont object.
ImGearPDEFont Constructor
Creates new instance of ImGearPDEFont object.
ImGearPDEFont Constructor
Creates new instance of ImGearPDEFont object.
ImGearPDEFont Constructor
Creates new instance of ImGearPDEFont object.


ImGearPDEFont Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDEFont object.

Declaration:

public ImGearPDEFont ( ImageGear.Formats.PDF.ImGearPDFSysFont SysFont ,
ImageGear.Formats.PDF.ImGearPDEFontCreateFromSysFontParams Params )

Parameters:

Name
Type
Description
SysFont
ImGearPDFSysFont Class
PDF system font object referencing a system font.
Params
ImGearPDEFontCreateFromSysFontParams Class
Create parameters.

Return Value:

The new instance of ImGearPDEFont Class object.

See Also:

ImGearPDEFont Class

ImGearPDFSysFont Class

ImGearPDEFontCreateFromSysFontParams Class


ImGearPDEFont Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDEFont object.

Declaration:

public ImGearPDEFont ( ImageGear.Formats.PDF.ImGearPDFSysFont SysFont,
ImageGear.Formats.PDF.ImGearPDFSysEncoding SysEncoding,
ImageGear.Formats.PDF.ImGearPDFAtom UseThisBaseFont,
ImageGear.Formats.PDF.ImGearPDEFontCreateFlags Flags )

Parameters:

Name
Type
Description
SysFont
ImGearPDFSysFont Class
PDF system font object referencing a system font.
SysEncoding
ImGearPDFSysEncoding Class
A PDF SysEncoding object.
UseThisBaseFont
ImGearPDFAtom Class
The base font. An error will be set if the base font name passed is a subset name (XXXXXX+FontName) or an empty string.
Flags
ImGearPDEFontCreateFlags Enumeration
One of the enumImGearPDEFontCreateFlags values.

Return Value:

The new instance of ImGearPDEFont Class object.

See Also:

ImGearPDEFont Class

ImGearPDFSysFont Class

ImGearPDEFontCreateFlags Enumeration

ImGearPDFSysEncoding Class

ImGearPDFAtom Class


ImGearPDEFont Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDEFont object.

Declaration:

public ImGearPDEFont ( ImageGear.Formats.PDF.ImGearPDFSysFont SysFont,
ImageGear.Formats.PDF.ImGearPDEFontCreateFlags Flags, ImageGear.Formats.PDF.ImGearPDFAtom
SnapshotName, int[] MMDesignVector )

Parameters:

Name
Type
Description
SysFont
ImGearPDFSysFont Class
PDF system font object referencing a system font.
Flags
ImGearPDEFontCreateFlags Enumeration
Indicates whether to embed the font and whether to subset the font. Must be one of enumImGearPDEFontCreateFlags. If you want to subset a font, set both the CREATE_EMBEDDED and WILL_SUBSET flags.
SnapshotName
ImGearPDFAtom Class
Name to be associated with this particular instantiation of the PDE Font.
MMDesignVector
int[]
Multiple master font design vector.

Return Value:

The new instance of ImGearPDEFont Class object.

See Also:

ImGearPDEFont Class

ImGearPDFSysFont Class

ImGearPDEFontCreateFlags Enumeration

ImGearPDFAtom Class


ImGearPDEFont Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDEFont object.

Declaration:

public ImGearPDEFont ( ImageGear.Formats.PDF.ImGearPDEFontAttrs Attributes, int
FirstCharIndex, int LastCharIndex, short[] Widths, string[] Encoding,
ImageGear.Formats.PDF.ImGearPDFAtom EncodingBaseName,
ImageGear.Formats.PDF.ImGearPDFStream FontStream, int Len1, int Len2, int Len3 )

Parameters:

Name
Type
Description
Attributes
ImGearPDEFontAttrs Class
ImGearPDEFontAttrs for the font attributes.
FirstCharIndex
int
First character index for the widths array, Widths.
LastCharIndex
int
Last character index for the widths array, Widths.
Widths
short[]
Widths array.
Encoding
string[]
Array of 256 glyph names specifying the custom encoding. If any pointer is null, no encoding information is written for that entry.
EncodingBaseName
ImGearPDFAtom Class
Encoding base name if the encoding is a custom encoding. If encoding is null, encodingBaseName is used as the value of the encoding, and must be one of WinAnsiEncoding, MacRomanEncoding, or MacExpertEncoding. If no encoding value is desired, use null Atom.
FontStream
ImGearPDFStream Class
Stream with font information.
Len1
int
Length in bytes of the ASCII portion of the Type 1 font file after it has been decoded. For other font formats, such as TrueType or CFF, only Len1 is used, and it is the size of the font.
Len2
int
Length in bytes of the encrypted portion of the Type 1 font file after it has been decoded.
Len3
int
Length in bytes of the portion of the Type 1 font file that contains the 512 zeros, plus the cleartomark operator, plus any following data.

Return Value:

The new instance of ImGearPDEFont Class object.

See Also:

ImGearPDEFont Class

ImGearPDEFontAttrs Class

ImGearPDFStream Class

ImGearPDFAtom Class


ImGearPDEFont Properties

The ImGearPDEFont Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
CreateNeedFlags Property
Flags indicating what needs to be done to make the current font complete.
IsEmbedded Property
True if the font is embedded, False if it is not, or if it was created in one document and embedded in a different document.
IsMultibyte Property
True if the font contains any multi-byte characters, False otherwise.


CreateNeedFlags Property

32-bit
64-bit
CF
P
P

Description:

Flags indicating what needs to be done to make the current font complete. WIDTHS can be cleared by CreateWidthsNow Method. TO_UNICODE can be cleared by CreateToUnicodeNow Method. EMBED can be cleared by EmbedNow Method.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEFontCreateNeedFlags CreateNeedFlags { get }

Value:

ImGearPDEFontCreateNeedFlags Enumeration values.

See Also:

ImGearPDEFontCreateNeedFlags Enumeration


IsEmbedded Property

32-bit
64-bit
CF
P
P

Description:

Parameters used when encoding the stream. Required for DCTDecode filter; optional for other filters. Must be set to NULL if filter spec is specified but no encode parameters are specified.

Declaration:

public bool IsEmbedded { get }

Value:

True, False

Default value:

N/A


IsMultibyte Property

32-bit
64-bit
CF
P
P

Description:

True if the font contains any multi-byte characters, False otherwise.

Declaration:

public bool IsMultibyte { get }

Value:

True, False.

Default value:

N/A


ImGearPDEFont Methods

The ImGearPDEFont Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
CreateToUnicodeNow Method
Creates the /ToUnicode table.
CreateWidthsNow Method
Creates width entries for font.
EmbedNow Method
Embeds font stream.
EmbedNowDontSubset Method
Embeds the font inside Doc without creating a subset.
GetAttributes Method
Gets the font attributes.
GetCodeByteCount Method
Gets the number of bytes in a string of single or multi-byte character codes.
GetOneByteEncoding Method
Gets an atom array that is filled with the delta encodings for font.
GetSysEncoding Method
Gets the system encoding object associated with a font object.
GetSysFont Method
Gets the system font object associated with a font object.
GetWidths Method
Gets widths array.
GetWidthsNow Method
Creates width entries for font.
SetSysEncoding Method
Sets the system encoding object associated with a font object.
SetSysFont Method
Sets the system font object associated with a font object.
SubsetNow Method
Subsets a given PDE Font in Doc.
SumWidths Method
Gets the sum to the widths from a string of single or multi-byte characters.


CreateToUnicodeNow Method

32-bit
64-bit
CF
P
P

Description:

This method creates the /ToUnicode table. The user can check the value of CreateNeedFlags to see if calling of CreateToUnicodeNow is needed.

Declaration:

public void CreateToUnicodeNow ( ImageGear.Formats.PDF.ImGearPDFDocument Doc )

Parameters:

Name
Type
Description
Doc
ImGearPDFDocument Class
The container document.

Return Value:

None.

See Also:

ImGearPDFDocument Class


CreateWidthsNow Method

32-bit
64-bit
CF
P
P

Description:

This method creates width entries for font. The user can check the value of CreateNeedFlags to see if calling of CreateWidthsNow is needed.

Declaration:

public void CreateWidthsNow ( ImageGear.Formats.PDF.ImGearPDFDocument Doc )

Parameters:

Name
Type
Description
Doc
ImGearPDFDocument Class
The container document.

Return Value:

None.

See Also:

ImGearPDFDocument Class


EmbedNow Method

32-bit
64-bit
CF
P
P

Description:

This method embeds font stream. The user can check the value of CreateNeedFlags to see if calling of EmbedNow is needed.

Declaration:

public void EmbedNow ( ImageGear.Formats.PDF.ImGearPDFDocument Doc )

Parameters:

Name
Type
Description
Doc
ImGearPDFDocument Class
The container document.

Return Value:

None.

See Also:

ImGearPDFDocument Class


EmbedNowDontSubset Method

32-bit
64-bit
CF
P
P

Description:

Embeds the font inside Doc without creating a subset. Use this method instead of EmbedNow Method if you created font with the WILL_SUBSET flag but changed your mind.

Declaration:

public void EmbedNowDontSubset ( ImageGear.Formats.PDF.ImGearPDFDocument Doc )

Parameters:

Name
Type
Description
Doc
ImGearPDFDocument Class
The container document.

Return Value:

None.

See Also:

ImGearPDFDocument Class


GetAttributes Method

32-bit
64-bit
CF
P
P

Description:

Gets the font attributes.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEFontAttrs GetAttributes (  )

Return Value:

ImGearPDEFontAttrs Class object values.

See Also:

ImGearPDEFontAttrs Class


GetCodeByteCount Method

32-bit
64-bit
CF
P
P

Description:

Gets the number of bytes in a string of single or multi-byte character codes.

Declaration:

public int GetCodeByteCount ( String Text )

Parameters:

Name
Type
Description
Text
String
A string chracters.

Return Value:

Number of bytes in the Text.


GetOneByteEncoding Method

32-bit
64-bit
CF
P
P

Description:

Gets an atom array that is filled with the delta encodings for font. Each entry is the atom for a glyph name that differs from the base encoding. See Section 5.5.5 in the PDF Reference for more information about font encodings.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom[] GetOneByteEncoding (  )

Return Value:

ImGearPDFAtom Class array object.

See Also:

ImGearPDFAtom Class


GetSysEncoding Method

32-bit
64-bit
CF
P
P

Description:

Gets the system encoding object associated with a font object.

NOTE: Changing the system encoding may produce unexpected results.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFSysEncoding GetSysEncoding ( )

Return Value:

ImGearPDFSysEncoding Class object.

See Also:

ImGearPDFSysEncoding Class


GetSysFont Method

32-bit
64-bit
CF
P
P

Description:

Gets the system font object associated with a font object.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFSysFont GetSysFont ( )

Return Value:

ImGearPDFSysFont Class object.

See Also:

ImGearPDFSysFont Class


GetWidths Method

32-bit
64-bit
CF
P
P

Description:

Gets widths array. The widths are returned in character space (1000 EM units). An EM is a typographic unit of measurement equal to the size of a font. To convert to text space, divide the value returned by 1000. To convert to user space, multiply the text space value by the font size.

Declaration:

public short[] GetWidths (  )

Return Value:

Widths array.


GetWidthsNow Method

32-bit
64-bit
CF
P
P

Description:

Gets a Type0 font's width information for only the characters used in the file. Call this routine when the font was created with the DEFER_WIDTHS flag but without the CREATE_EMBEDDED flag (if the font is to be embedded, call SubsetNow Method, which also gets the width info).

Declaration:

public void GetWidthsNow ( ImageGear.Formats.PDF.ImGearPDFDocument Doc )

Parameters:

Name
Type
Description
Doc
ImGearPDFDocument Class
The container document.

Return Value:

None

See Also:

ImGearPDFDocument Class


SetSysEncoding Method

32-bit
64-bit
CF
P
P

Description:

Sets the system encoding object associated with a font object.

NOTE: Changing the system encoding may produce unexpected results.

Declaration:

public void SetSysEncoding ( ImageGear.Formats.PDF.ImGearPDFSysEncoding SysEncoding )

Parameters:

Name
Type
Description
SysEncoding
ImGearPDFSysEncoding Class
The system encoding object to set.

Return Value:

None.

See Also:

ImGearPDFSysEncoding Class


SetSysFont Method

32-bit
64-bit
CF
P
P

Description:

Sets the system font object associated with a font object.

Declaration:

public void SetSysFont ( ImageGear.Formats.PDF.ImGearPDFSysFont SysFont )

Parameters:

Name
Type
Description
SysFont
ImGearPDFSysFont Class
The system font object to set.

Return Value:

None

See Also:

ImGearPDFSysFont Class


SubsetNow Method

32-bit
64-bit
CF
P
P

Description:

Subsets a given PDE Font in Doc.

If you created font with CreatePDEFontFromSysFont, you must have set both the CREATE_EMBEDDED and WILL_SUBSET set in the flags parameter to be able to subset font.

Declaration:

public void SubsetNow ( ImageGear.Formats.PDF.ImGearPDFDocument Doc )

Parameters:

Name
Type
Description
Doc
ImGearPDFDocument Class
The document whose font is subsetted.

Return Value:

None

See Also:

ImGearPDFDocument Class


SumWidths Method

32-bit
64-bit
CF
P
P

Description:

Gets the sum to the widths from a string of single or multi-byte characters.

Declaration:

public int SumWidths ( string Text )

Parameters:

Name
Type
Description
Text
string
A string of characters.

Return Value:

Width of text string in EM space. (In EM space, the width of "M" is about 1000 EM units).


ImGearPDEFontAttrs Class

32-bit
64-bit
CF
P
P

Description:

Attributes for ImGearPDEFont and ImGearPDFSysFont.

Declaration:

public sealed class ImGearPDEFontAttrs : System.Object

Members:

Constructors
Name
Description
ImGearPDEFontAttrs Constructor
Creates the new instance of ImGearPDEFontAttrs object.

Properties
Name
Description
Ascent Property
Maximum ascender height.
AvgWidth Property
Average character width.
BBox Property
Font bounding box in 1000 EM units.
CantEmbed Property
A non-zero value means the font cannot be embedded.
CapHeight Property
Capital height.
CharSet Property
An atom for "Roman" or Null.
CIDFontType Property
Atom representing the CID font type: CIDFontType0 or CIDFontType2.
DeltaEncoding Property
The name of the base encoding
Descent Property
Maximum descender depth.
Encoding Property
An atom for font encoding.
Flags Property
Desired font flags, one or more values of enumImGearPDFFontFlags.
ItalicAngle Property
Italic angle in degrees, if any.
Lang Property
Atom representing the ISO 639 language code.
Leading Property
Additional leading between lines.
MaxWidth Property
Additional leading between lines.
MissingWidth Property
Width of missing character.
Name Property
An atom for font name
Ordering Property
Atom representing the CIDFont's Ordering information, for example, "1".
PackageType Property
Package type, one of enumImGearPDFSysFontPackageType.
PlatformName Property
The platform name.
Protection Property
Allows setting one of the following bits to disable font embedding:
PSName Property
Atom representing the PostScript name of a TrueType font.
Registry Property
Atom representing the CIDFont's Registry information, as in "Adobe-Japan".
StemH Property
Horizontal stem width.
StemV Property
Vertical stem width.
Supplement Property
The SystemSupplement field from the CIDFont.
Type Property
An atom for font type, corresponding to the Subtype key in a font dictionary.
WritingMode Property
Writing mode.
XHeight Property
X height.


ImGearPDEFontAttrs Constructors

The ImGearPDEFontAttrs Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEFontAttrs Constructor
Creates the new instance of ImGearPDEFontAttrs object.


ImGearPDEFontAttrs Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDEFontAttrs object.

Declaration:

public ImGearPDEFontAttrs ( )

Return Value:

The new instance of ImGearPDEFontAttrs Class object.

See Also:

ImGearPDEFontAttrs Class


ImGearPDEFontAttrs Properties

The ImGearPDEFontAttrs Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
Ascent Property
Maximum ascender height.
AvgWidth Property
Average character width.
BBox Property
Font bounding box in 1000 EM units.
CantEmbed Property
A non-zero value means the font cannot be embedded.
CapHeight Property
Capital height.
CharSet Property
An atom for "Roman" or Null.
CIDFontType Property
Atom representing the CID font type: CIDFontType0 or CIDFontType2.
DeltaEncoding Property
The name of the base encoding
Descent Property
Maximum descender depth.
Encoding Property
An atom for font encoding.
Flags Property
Desired font flags, one or more values of enumImGearPDFFontFlags.
ItalicAngle Property
Italic angle in degrees, if any.
Lang Property
Atom representing the ISO 639 language code.
Leading Property
Additional leading between lines.
MaxWidth Property
Additional leading between lines.
MissingWidth Property
Width of missing character.
Name Property
An atom for font name
Ordering Property
Atom representing the CIDFont's Ordering information, for example, "1".
PackageType Property
Package type, one of enumImGearPDFSysFontPackageType.
PlatformName Property
The platform name.
Protection Property
Allows setting one of the following bits to disable font embedding:
PSName Property
Atom representing the PostScript name of a TrueType font.
Registry Property
Atom representing the CIDFont's Registry information, as in "Adobe-Japan".
StemH Property
Horizontal stem width.
StemV Property
Vertical stem width.
Supplement Property
The SystemSupplement field from the CIDFont.
Type Property
An atom for font type, corresponding to the Subtype key in a font dictionary.
WritingMode Property
Writing mode.
XHeight Property
X height.


Ascent Property

32-bit
64-bit
CF
P
P

Description:

Maximum ascender height.

Declaration:

public short Ascent { get, set }

Value:

Integer

Default value:

0


AvgWidth Property

32-bit
64-bit
CF
P
P

Description:

Average character width.

Declaration:

public short AvgWidth { get, set }

Value:

Integer

Default value:

0


BBox Property

32-bit
64-bit
CF
P
P

Description:

Font bounding box in 1000 EM units.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFFixedRect BBox { get }

Value:

ImGearPDFFixedRect Class object.

Default value:

N/A

See Also:

ImGearPDFFixedRect Class


CantEmbed Property

32-bit
64-bit
CF
P
P

Description:

A non-zero value means the font cannot be embedded.

Declaration:

public int CantEmbed { get }

Value:

Integer

Default value:

0


CapHeight Property

32-bit
64-bit
CF
P
P

Description:

Capital height.

Declaration:

public short CapHeight { get, set }

Value:

Integer

Default value:

0


CharSet Property

32-bit
64-bit
CF
P
P

Description:

An atom for "Roman" or Null. If "Roman," the characters must be a subset of the Adobe Standard Roman Character Set.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom CharSet { get, set }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFAtom Class


CIDFontType Property

32-bit
64-bit
CF
P
P

Description:

Atom representing the CID font type: CIDFontType0 or CIDFontType2.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom CIDFontType { get, set }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFAtom Class


DeltaEncoding Property

32-bit
64-bit
CF
P
P

Description:

The name of the base encoding; that is, the BaseEncoding entry in an encoding dictionary (see section 5.5.5 of the PDF Reference). The Differences entry of the encoding dictionary describes differences (deltas) from the base encoding.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom DeltaEncoding { get, set }

Value:

ImGearPDFAtom Class

Default value:

N/A

See Also:

ImGearPDFAtom Class


Descent Property

32-bit
64-bit
CF
P
P

Description:

Maximum descender depth.

Declaration:

public short Descent { get, set }

Value:

Integer

Default value:

0


Encoding Property

32-bit
64-bit
CF
P
P

Description:

An atom for font encoding. May be MacRomanEncoding, WinAnsiEncoding, or Null. In the case of Null, call ImGearPDFSysFont.GetEncoding to get more information about the encoding.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom Encoding { get, set }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFAtom Class


Flags Property

32-bit
64-bit
CF
P
P

Description:

Desired font flags, one or more values of enumImGearPDFFontFlags.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEFontFlags Flags { get, set }

Value:

ImGearPDEFontFlags Enumeration value

Default value:

UNKNOWN

See Also:

ImGearPDEFontFlags Enumeration


ItalicAngle Property

32-bit
64-bit
CF
P
P

Description:

Italic angle in degrees, if any.

Declaration:

public short ItalicAngle { get, set }

Value:

Integer

Default value:

0


Lang Property

32-bit
64-bit
CF
P
P

Description:

Atom representing the ISO 639 language code. These are available from http://www.iso.ch.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom Lang { get, set }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFAtom Class


Leading Property

32-bit
64-bit
CF
P
P

Description:

Additional leading between lines.

Declaration:

public short Leading { get, set }

Value:

Integer

Default value:

0


MaxWidth Property

32-bit
64-bit
CF
P
P

Description:

Additional leading between lines.

Declaration:

public short MaxWidth { get, set }

Value:

Integer

Default value:

0


MissingWidth Property

32-bit
64-bit
CF
P
P

Description:

Width of missing character.

Declaration:

public short MissingWidth { get, set }

Value:

Integer

Default value:

0


Name Property

32-bit
64-bit
CF
P
P

Description:

An atom for font name, as in "CourierStd". Corresponds to the BaseFont key in the font dictionary of a PDF file (see Section 5.6.3 in the PDF Reference).

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom Name { get, set }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFAtom Class


Ordering Property

32-bit
64-bit
CF
P
P

Description:

Atom representing the CIDFont's Ordering information, for example, "1".

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom Ordering { get, set }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFAtom Class


PackageType Property

32-bit
64-bit
CF
P
P

Description:

Package type, one of ImGearPDESysFontPackageType.

Declaration:

public ImageGear.Formats.PDF.ImGearPDESysFontPackageType PackageType{ get, set }

Value:

ImGearPDESysFontPackageType Enumeration value.

Default value:

UNKNOWN

See Also:

ImGearPDESysFontPackageType Enumeration


PlatformName Property

32-bit
64-bit
CF
P
P

Description:

The platform name.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom PlatformName { get, set }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFAtom Class


Protection Property

32-bit
64-bit
CF
P
P

Description:

Allows setting one of the following bits to disable font embedding:

  • NO_EMBEDDING - font should not be embedded.
  • NO_EDITABLE_EMBEDDING - font should not be embedded for editing purposes.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEFontProtection Protection { get, set }

Value:

ImGearPDEFontProtection Enumeration value

Default value:

NO_EMBEDDING

See Also:

ImGearPDEFontProtection Enumeration


PSName Property

32-bit
64-bit
CF
P
P

Description:

Atom representing the PostScript name of a TrueType font.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom PSName { get, set }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFAtom Class


Registry Property

32-bit
64-bit
CF
P
P

Description:

Atom representing the CIDFont's Registry information, as in "Adobe-Japan".

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom Registry { get, set }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFAtom Class


StemH Property

32-bit
64-bit
CF
P
P

Description:

Horizontal stem width.

Declaration:

public short StemH { get, set }

Value:

Integer

Default value:

0


StemV Property

32-bit
64-bit
CF
P
P

Description:

Vertical stem width.

Declaration:

public short StemV { get, set }

Value:

Integer

Default value:

0


Supplement Property

32-bit
64-bit
CF
P
P

Description:

The SystemSupplement field from the CIDFont.

Declaration:

public int Supplement { get, set }

Value:

Integer

Default value:

0


Type Property

32-bit
64-bit
CF
P
P

Description:

An atom for font type, corresponding to the Subtype key in a font dictionary. May be "Type1", "TrueType", "MMType1", or "Type0."

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom Type { get, set }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFAtom Class


WritingMode Property

32-bit
64-bit
CF
P
P

Description:

Writing mode. Must be one of:

  • 0 for horizontal writing
  • 1 for vertical writing

Declaration:

public short WritingMode { get, set }

Value:

Integer

Default value:

0


XHeight Property

32-bit
64-bit
CF
P
P

Description:

X height.

Declaration:

public short XHeight
{ get, set }

Value:

Integer

Default value:

0


ImGearPDEFontCreateFromSysFontParams Class

32-bit
64-bit
CF
P
P

Description:

This class is used with PDE Font creation

Declaration:

public sealed class ImGearPDEFontCreateFromSysFontParams : System.Object

Members:

Constructors
Name
Description
ImGearPDEFontCreateFromSysFontParams Constructor
Creates new instance of ImGearPDEFontCreateFromSysFontParams object.

Properties
Name
Description
CodePage Property
Used to select a specific code page supported by the font.
Flags Property
A bit mask of the ImGearPDEFontCreateFlags.
Encoding Property
Used to specify which encoding to use with a CID font.
MMDesignVec Property
Multiple master font design vector.
SnapshotName Property
The name of a multiple master snapshot.


ImGearPDEFontCreateFromSysFontParams Constructors

The ImGearPDEFontCreateFromSysFontParams Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEFontCreateFromSysFontParams Constructor
Creates new instance of ImGearPDEFontCreateFromSysFontParams object.


ImGearPDEFontCreateFromSysFontParams Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDEFontCreateFromSysFontParams object.

Declaration:

public ImGearPDEFontCreateFromSysFontParams ( )

Return Value:

The new instance of ImGearPDEFontCreateFromSysFontParams Class object.

See also:

ImGearPDEFontCreateFromSysFontParams Class


ImGearPDEFontCreateFromSysFontParams Properties

The ImGearPDEFontCreateFromSysFontParams Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
CodePage Property
Used to select a specific code page supported by the font.
Flags Property
A bit mask of the ImGearPDEFontCreateFlags.
Encoding Property
Used to specify which encoding to use with a CID font.
MMDesignVec Property
Multiple master font design vector.
SnapshotName Property
The name of a multiple master snapshot.


CodePage Property

32-bit
64-bit
CF
P
P

Description:

Used to select a specific code page supported by the font. When a non-zero code page is supplied, embedding must be turned on and the ENCODE_BY_GID flag set.

Declaration:

public int CodePage { get, set }

Value:

Integer

Default value:

0


Flags Property

32-bit
64-bit
CF
P
P

Description:

A bit mask of the ImGearPDEFontCreateFlags.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEFontCreateFlags Flags { get, set }

Value:

ImGearPDEFontCreateFlags Enumeration value.

Default value:

0

See also:

ImGearPDEFontCreateFlags Enumeration


Encoding Property

32-bit
64-bit
CF
P
P

Description:

Used to specify which encoding to use with a CID font. Pass NULL to use the platform default.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom Encoding { get, set }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See also:

ImGearPDFAtom Class


MMDesignVec Property

32-bit
64-bit
CF
P
P

Description:

Multiple master font design vector.

Declaration:

public int[] MMDesignVec { get, set }

Value:

Integer array

Default value:

N/A


SnapshotName Property

32-bit
64-bit
CF
P
P

Description:

The name of a multiple master snapshot. See PDF Reference for more information on snapshots.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom SnapshotName { get, set }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See also:

ImGearPDFAtom Class


ImGearPDEFontInfo Class

32-bit
64-bit
CF
P
P

Description:

PDE font information class.

Declaration:

public sealed class ImGearPDEFontInfo

Members:

Constructors
Name
Description
ImGearPDEFontInfo Constructor
Creates new object.

Properties
Name
Description
CharSet Property
Character set.
Encoding Property
Font encoding.
Name Property
Font name.
Type Property
Font type.
WritingMode Property
Writing mode: 0 = horizontal; 1 = vertical.


ImGearPDEFontInfo Constructors

The ImGearPDEFontInfo Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEFontInfo Constructor
Creates new object.


ImGearPDEFontInfo Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDEFontInfo object.

Declaration:

public ImGearPDEFontInfo ( )

Return Value:

The new instance of ImGearPDEFontInfo Class object.

See Also:

ImGearPDEFontInfo Class


ImGearPDEFontInfo Properties

The ImGearPDEFontInfo Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
CharSet Property
Character set.
Encoding Property
Font encoding.
Name Property
Font name.
Type Property
Font type.
WritingMode Property
Writing mode: 0 = horizontal; 1 = vertical.


CharSet Property

32-bit
64-bit
CF
P
P

Description:

Character set. If "Roman," the characters must be a subset of the Adobe Standard Roman Character Set.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom CharSet { get, set }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFAtom Class


Encoding Property

32-bit
64-bit
CF
P
P

Description:

Font encoding.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom Encoding { get, set }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFAtom Class


Name Property

32-bit
64-bit
CF
P
P

Description:

Font name.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom Name { get, set }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFAtom Class


Type Property

32-bit
64-bit
CF
P
P

Description:

Font type.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom Type { get, set }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFAtom Class


WritingMode Property

32-bit
64-bit
CF
P
P

Description:

Writing mode: 0 = horizontal; 1 = vertical.

Declaration:

public short WritingMode { get, set }

Value:

Integer

Default value:

0


ImGearPDEForm Class

32-bit
64-bit
CF
P
P

Description:

This is an element that corresponds to an instance of XObject Form on a page (or other containing stream such as another XObject Form or annotation form). The context associated with this instance includes the actual stream that represents the XObject Form and the initial conditions of the graphics state. The latter consists of the transformation matrix, initial color values, and so forth. It is possible to have two Forms that refer to the same XObject Form. The forms will exist at different places on the same page, depending on the transformation matrix. They may also have different colors or line stroking parameters. In the case of a transparency group, the opacity is specified in the gstate.

Within a Form, each element has its own gstate (or is a container, place, or group object). These gstates are independent of the parent Form gstate. Form elements may have their own opacity.

Content may be obtained from a Form to edit the form's display list.

Declaration:

public sealed class ImGearPDEForm : ImageGear.Formats.PDF.ImGearPDEElement

Members:

Constructors
Name
Description
ImGearPDEForm Constructor
creates the new instance of ImGearPDEForm object.

Properties
Name
Description
HasXGroup Property
True if the XObject form has a Transparency XGroup.

Methods
Name
Description
Clone Method
Creates a new form from an existing form object.
GetContent Method
Gets Form's content object.
GetXGroup Method
Gets the transparency group dictionary of the XObject form.
SetContent Method
Sets Form's content object.
SetXGroup Method
Sets the transparency group dictionary of the XObject form.


ImGearPDEForm Constructors

The ImGearPDEForm Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEForm Constructor
creates the new instance of ImGearPDEForm object.


ImGearPDEForm Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDEForm object.

Declaration:

public ImGearPDEForm ( )

Return Value:

The new instance of ImGearPDEForm Class object.

See Also:

ImGearPDEForm Class


ImGearPDEForm Properties

The ImGearPDEForm Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
HasXGroup Property
True if the XObject form has a Transparency XGroup.


HasXGroup Property

32-bit
64-bit
CF
P
P

Description:

True if the XObject form has a Transparency XGroup.

Declaration:

public bool HasXGroup { get }

Value:

True, False

Default value:

N/A


ImGearPDEForm Methods

The ImGearPDEForm Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
Clone Method
Creates a new form from an existing form object.
GetContent Method
Gets Form's content object.
GetXGroup Method
Gets the transparency group dictionary of the XObject form.
SetContent Method
Sets Form's content object.
SetXGroup Method
Sets the transparency group dictionary of the XObject form.


Clone Method

32-bit
64-bit
CF
P
P

Description:

Creates a new form from an existing form object. Creates a copy of the PDE Form, including the underlying objects.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEForm Clone (  )

Return Value:

The newly created ImGearPDEForm Class object.

See Also:

ImGearPDEForm Class


GetContent Method

32-bit
64-bit
CF
P
P

Description:

Gets Form's content object.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEContent GetContent (  )

Return Value:

ImGearPDEContent Class object.

See Also:

ImGearPDEContent Class


GetXGroup Method

32-bit
64-bit
CF
P
P

Description:

Gets the transparency group dictionary of the XObject form.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEXGroup GetXGroup (  )

Return Value:

ImGearPDEXGroup Class object.

See Also:

ImGearPDEXGroup Class


SetContent Method

32-bit
64-bit
CF
P
P

Description:

Sets Form's content object.

Declaration:

public void SetContent ( ImageGear.Formats.PDF.ImGearPDEContent Content )

Parameters:

Name
Type
Description
Content
ImGearPDEContent Class
Content

Return Value:

None

See Also:

ImGearPDEContent Class


SetXGroup Method

32-bit
64-bit
CF
P
P

Description:

Sets the transparency group dictionary of the XObject form.

Declaration:

public void SetXGroup ( ImageGear.Formats.PDF.ImGearPDEXGroup XGroup )

Parameters:

Name
Type
Description
XGroup
ImGearPDEXGroup Class
The transparency group dictionary of the XObject form.

Return Value:

None.

See Also:

ImGearPDEXGroup Class


ImGearPDEGraphicState Class

32-bit
64-bit
CF
P
P

Description:

Attributes of a PDE element or a PDE text sub-element.

Declaration:

public sealed class ImGearPDEGraphicState : ImageGear.Formats.PDF.ImGearPDFObject

Members:

Constructors
Name
Description
ImGearPDEGraphicState Constructor
Creates the new instance of ImGearPDEGraphicState object.

Properties
Name
Description
Dash Property
Dash specification.
FillColorSpec Property
Fill color specification.
Flatness Property
Line flatness, corresponding to the i (setflat) operator.
LineCap Property
Line cap style, corresponding to the J (setlinecap) operator.
LineJoin Property
Line join style, corresponding to the j (setlinejoin) operator.
LineWidth Property
Line width, corresponding to the w (setlinewidth) operator.
MiterLimit Property
Miter limit, corresponding to the M (setmiterlimit) operator.
RenderIntent Property
A color rendering intent, corresponding to the Intent key in the image dictionary.
StrokeColorSpec Property
Stroke color specification.
WasSetFlags Property
Indicates if an attribute has been set.


ImGearPDEGraphicState Constructors

The ImGearPDEGraphicState Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEGraphicState Constructor
Creates the new instance of ImGearPDEGraphicState object.


ImGearPDEGraphicState Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDEGraphicState Class object.

Declaration:

public ImGearPDEGraphicState ( )

Return Value:

The new instance of ImGearPDEGraphicState Class object.

See Also:

ImGearPDEGraphicState Class


ImGearPDEGraphicState Properties

The ImGearPDEGraphicState Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
Dash Property
Dash specification.
FillColorSpec Property
Fill color specification.
Flatness Property
Line flatness, corresponding to the i (setflat) operator.
LineCap Property
Line cap style, corresponding to the J (setlinecap) operator.
LineJoin Property
Line join style, corresponding to the j (setlinejoin) operator.
LineWidth Property
Line width, corresponding to the w (setlinewidth) operator.
MiterLimit Property
Miter limit, corresponding to the M (setmiterlimit) operator.
RenderIntent Property
A color rendering intent, corresponding to the Intent key in the image dictionary.
StrokeColorSpec Property
Stroke color specification.
WasSetFlags Property
Indicates if an attribute has been set.


Dash Property

32-bit
64-bit
CF
P
P

Description:

Dash specification.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEDash Dash { get, set }

Value:

ImGearPDEDash Class value.

Default value:

DeviceGray

See Also:

ImGearPDEDash Class


FillColorSpec Property

32-bit
64-bit
CF
P
P

Description:

Fill color specification.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEColorSpec FillColorSpec { get, set }

Value:

ImGearPDEColorSpec Class value

Default value:

DeviceGray

See Also:

ImGearPDEColorSpec Class


Flatness Property

32-bit
64-bit
CF
P
P

Description:

Line flatness, corresponding to the i (setflat) operator.

Declaration:

public int Flatness { get, set }

Value:

Integer

Default value:

ZERO


LineCap Property

32-bit
64-bit
CF
P
P

Description:

Line cap style, corresponding to the J (setlinecap) operator.

Declaration:

public int LineCap { get, set }

Value:

Integer

Default value:

0


LineJoin Property

32-bit
64-bit
CF
P
P

Description:

Line join style, corresponding to the j (setlinejoin) operator.

Declaration:

public int LineJoin { get, set }

Value:

Integer

Default value:

0


LineWidth Property

32-bit
64-bit
CF
P
P

Description:

Line width, corresponding to the w (setlinewidth) operator.

Declaration:

public int LineWidth { get, set }

Value:

Integer

Default value:

ONE


MiterLimit Property

32-bit
64-bit
CF
P
P

Description:

Miter limit, corresponding to the M (setmiterlimit) operator.

Declaration:

public int MiterLimit { get, set }

Value:

Integer

Default value:

TEN


RenderIntent Property

32-bit
64-bit
CF
P
P

Description:

A color rendering intent, corresponding to the Intent key in the image dictionary.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom RenderIntent { get, set }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFAtom Class


StrokeColorSpec Property

32-bit
64-bit
CF
P
P

Description:

Stroke color specification.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEColorSpec StrokeColorSpec { get, set }

Value:

ImGearPDEColorSpec Class value

Default value:

DeviceGray

See Also:

ImGearPDEColorSpec Class


WasSetFlags Property

32-bit
64-bit
CF
P
P

Description:

Indicates if an attribute has been set.

NOTE: Support for these flags is not complete. For compatibility, you should set them, but do not depend on reading their values back. The intended use is with XObject Forms to indicate whether the value is inherited or explicitly set.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEGraphicStateWasSetFlags WasSetFlags { get, set }

Value:

ImGearPDEGraphicStateWasSetFlags Enumeration value.

Default value:

0

See Also:

ImGearPDEGraphicStateWasSetFlags Enumeration


ImGearPDEGroup Class

32-bit
64-bit
CF
P
P

Description:

The PDE group object is an in-memory representation of objects in Content. It has no state and is not represented in any way in a content stream (that is, Content).

When used in a Clip, this object is used to associate Text objects into a single clipping object.

Declaration:

public sealed class ImGearPDEGroup : ImageGear.Formats.PDF.ImGearPDEElement

Members:

Constructors
Name
Description
ImGearPDEGroup Constructor
Creates the new instance of ImGearPDEGroup object.

Methods
Name
Description
GetContent Method
Gets Group's content object.
SetContent Method
Sets Group's content object.


ImGearPDEGroup Constructors

The ImGearPDEGroup Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEGroup Constructor
Creates the new instance of ImGearPDEGroup object.


ImGearPDEGroup Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDEGroup object.

Declaration:

public ImGearPDEGroup ( )

Return Value:

The new instance of ImGearPDEGroup Class object.

See Also:

ImGearPDEGroup Class


ImGearPDEGroup Methods

The ImGearPDEGroup Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
GetContent Method
Gets Group's content object.
SetContent Method
Sets Group's content object.


GetContent Method

32-bit
64-bit
CF
P
P

Description:

Gets Group's content object.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEContent GetContent ( )

Return Value:

ImGearPDEContent Class object.

See Also:

ImGearPDEContent Class


SetContent Method

32-bit
64-bit
CF
P
P

Description:

Sets Group's content object.

Declaration:

public void SetContent ( ImageGear.Formats.PDF.ImGearPDEContent Content )

Parameters:

Name
Type
Description
Content
ImGearPDEContent Class
Group's content object.

Return Value:

None.

See Also:

ImGearPDEContent Class


ImGearPDEImage Class

32-bit
64-bit
CF
P
P

Description:

An element that contains an Image XObject or in-line image. You can associate data or a stream with an image.

Declaration:

public sealed class ImGearPDEImage : ImageGear.Formats.PDF.ImGearPDEElement

Members:

Constructors
Name
Description
ImGearPDEImage Constructor
Creates new instance of ImGearPDEImage object.

Properties
Name
Description
DataLength Property
Number of bytes of image data, specified by the width, height, bits per component, and color space of the image.
EncodedLength Property
Length of the encoded data-if the data is encoded, that is, IsDataEncoded is True.
HasSoftMask Property
True if the soft mask exists; False otherwise.
IsDataEncoded Property
True if GetData returns encoded data, false otherwise. Returns false for XObject images
IsXObject Property
True if the image is an XObject image, false otherwise.

Methods
Name
Description
GetAttributes Method
Gets image attributes.
GetColorMask Method
Obtains the Mask entry from the image dictionary.
GetColorSpace Method
Gets the color space object for an image.
GetData Method
Gets an image's data.
GetDataStream Method
Gets a data stream for an image.
GetDecodeArray Method
Gets the decode array for an image.
GetDictionary Method
Gets the dictionary for an image.
GetFilterArray Method
Gets the filter array for an image.
GetMatteArray Method
Gets the matte array for the image XObject.
GetSoftMask Method
Gets the soft mask for an image.
SetColorMask Method
Sets the Mask entry from the image dictionary.
SetColorSpace Method
Sets the color space object for an image.
SetData Method
Sets data for an image.
SetDataStream Method
Sets a data stream for an image.
SetDecodeArray Method
Sets the decode array for an image.
SetMatteArray Method
Sets the matte array for the image XObject.
SetSoftMask Method
Sets the soft mask for an image.


ImGearPDEImage Constructors

The ImGearPDEImage Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEImage Constructor
Creates new instance of ImGearPDEImage object.


ImGearPDEImage Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDEImage object. The image data may be specified as a stream or as a buffer. If DataStream is non-null, Data is ignored.

Declaration:

public ImGearPDEImage(ImageGear.Formats.PDF.ImGearPDEImageAttrs Attrs,
ImageGear.Formats.PDF.ImGearPDFFixedMatrix Matrix,
ImageGear.Formats.PDF.ImGearPDEImageDataFlags Flags,
ImageGear.Formats.PDF.ImGearPDEColorSpace ColorSpace,
ImageGear.Formats.PDF.ImGearPDEColorValue ColorValue,
ImageGear.Formats.PDF.ImGearPDEFilterArray Filters, ImageGear.Formats.PDF.ImGearPDFStream
DataStream, byte[] Data)

Parameters:

Name
Type
Description
Attrs
ImGearPDEImageAttrs Class
ImGearPDEImageAttrs for the image attributes.
Matrix
ImGearPDFFixedMatrix Class
ImGearPDFFixedMatrix that holds the transformation matrix to use for the image.
Flags
ImGearPDEImageDataFlags Enumeration
enumImGearPDEImageDataFlags flags.
ColorSpace
ImGearPDEColorSpace Class
Color space of the image. When the image is an imagemask, ColorSpace is the color space of the ColorValue argument.
ColorValue
ImGearPDEColorValue Class
ImGearPDEColorValue object. If the image is an image mask, ColorValue must be provided.
Filters
ImGearPDEFilterArray Class
ImGearPDEFilterArray that specifies which filters to use in encoding the contents; may be null. Filters will be used to encode the data in the order in which they are specified in the array.
DataStream
ImGearPDFStream Class
Image data. If DataStream is non-null, Data parameter is ignored. If there is a great deal of data, as for a large image, it is recommended you use the DataStream parameter for the image data.
Data
byte[]
Single byte image data array. If DataStream is non-null, data is ignored. If there is a great deal of data, as for a large image, it is recommended you use the DataStream parameter for the image data.

Return Value:

The new instance of ImGearPDEImage Class object.

See Also:

ImGearPDEImage Class

ImGearPDEImageAttrs Class

ImGearPDFFixedMatrix Class

ImGearPDEImageDataFlags Enumeration

ImGearPDEColorSpace Class

ImGearPDEColorValue Class

ImGearPDEFilterArray Class

ImGearPDFStream Class


ImGearPDEImage Properties

The ImGearPDEImage Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
DataLength Property
Number of bytes of image data, specified by the width, height, bits per component, and color space of the image.
EncodedLength Property
Length of the encoded data-if the data is encoded, that is, IsDataEncoded is True.
HasSoftMask Property
True if the soft mask exists; False otherwise.
IsDataEncoded Property
True if GetData returns encoded data, false otherwise. Returns false for XObject images
IsXObject Property
True if the image is an XObject image, false otherwise.


DataLength Property

32-bit
64-bit
CF
P
P

Description:

Number of bytes of image data, specified by the width, height, bits per component, and color space of the image.

Declaration:

public int DataLength { get }

Value:

Integer number.

Default value:

None


EncodedLength Property

32-bit
64-bit
CF
P
P

Description:

Length of the encoded data-if the data is encoded, that is, IsDataEncoded is True.

Declaration:

public int EncodedLength { get }

Value:

Integer number.

Default value:

N/A


HasSoftMask Property

32-bit
64-bit
CF
P
P

Description:

True if the soft mask exists; False otherwise.

Declaration:

public bool HasSoftMask { get }

Value:

True, False

Default value:

N/A


IsDataEncoded Property

32-bit
64-bit
CF
P
P

Description:

True if GetData returns encoded data, false otherwise. Returns false for XObject images.

Declaration:

public bool IsDataEncoded { get }

Value:

True, False.

Default value:

N/A


IsXObject Property

32-bit
64-bit
CF
P
P

Description:

True if the image is an XObject image, false otherwise.

Declaration:

public bool IsXObject { get }

Value:

True, False

Default value:

N/A


ImGearPDEImage Methods

The ImGearPDEImage Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
GetAttributes Method
Gets image attributes.
GetColorMask Method
Obtains the Mask entry from the image dictionary.
GetColorSpace Method
Gets the color space object for an image.
GetData Method
Gets an image's data.
GetDataStream Method
Gets a data stream for an image.
GetDecodeArray Method
Gets the decode array for an image.
GetDictionary Method
Gets the dictionary for an image.
GetFilterArray Method
Gets the filter array for an image.
GetMatteArray Method
Gets the matte array for the image XObject.
GetSoftMask Method
Gets the soft mask for an image.
SetColorMask Method
Sets the Mask entry from the image dictionary.
SetColorSpace Method
Sets the color space object for an image.
SetData Method
Sets data for an image.
SetDataStream Method
Sets a data stream for an image.
SetDecodeArray Method
Sets the decode array for an image.
SetMatteArray Method
Sets the matte array for the image XObject.
SetSoftMask Method
Sets the soft mask for an image.


GetAttributes Method

32-bit
64-bit
CF
P
P

Description:

Gets image attributes.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEImageAttrs GetAttributes (  )

Return Value:

ImGearPDEImageAttrs Class object.

See Also:

ImGearPDEImageAttrs Class


GetColorMask Method

32-bit
64-bit
CF
P
P

Description:

Use this method to obtain the Mask entry from the image dictionary. The mask entry is an array specifying a range of colors to be masked out. Samples in the image that fall within this range are not painted, allowing the existing background to show through. The effect is similar to that of the video technique known as chroma-key.

The value of the Mask entry is an array of 2n integers, [min1 max1 ... minn maxn], where n is the number of color components in the image's color space. Each integer must be in the range 0 to 2 in power of BitsPerComponent - 1, representing color values before decoding with the Decode array. An image sample is masked (not painted) if all of its color components before decoding, c1...cn, fall within the specified ranges.

Declaration:

public int[] GetColorMask (  )

Return Value:

Integer array


GetColorSpace Method

32-bit
64-bit
CF
P
P

Description:

Gets the color space object for an image. NULL if image an image mask.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEColorSpace GetColorSpace (  )

Return Value:

ImGearPDEColorSpace Class value.

See Also:

ImGearPDEColorSpace Class


GetData Method

32-bit
64-bit
CF
P
P

Description:

Gets an image's data.

If the image is a XObject image, data is always returned as decoded data.

Declaration:

public byte[] GetData (  )

Return Value:

Array in bytes.


GetDataStream Method

32-bit
64-bit
CF
P
P

Description:

Gets a data stream for an image. May only be called for XObject images.

The caller must dispose of the returned stream by calling its Dispose() method.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFStream GetDataStream (
ImageGear.Formats.PDF.ImGearPDEImageDataFlags Flags )

Parameters:

Name
Type
Description
Flags
ImGearPDEImageDataFlags Enumeration
ImGearPDEImageDataFlags flags. If the ENCODED flag is set, data is returned in encoded form. Otherwise, data is decoded.

Return Value:

ImGearPDFStream Class object.

See Also:

ImGearPDFStream Class

ImGearPDEImageDataFlags Enumeration


GetDecodeArray Method

32-bit
64-bit
CF
P
P

Description:

Gets the decode array for an image.

Declaration:

public int[] GetDecodeArray (  )

Return Value:

Integer array.


GetDictionary Method

32-bit
64-bit
CF
P
P

Description:

This method gets the dictionary for an image.

Declaration:

public ImGearPDFBasDict GetDictionary()

Return Value:

ImGearPDFBasDict Class object


GetFilterArray Method

32-bit
64-bit
CF
P
P

Description:

Gets the filter array for an image.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEFilterArray GetFilterArray (  )

Return Value:

ImGearPDEFilterArray Class object.

See Also:

ImGearPDEFilterArray Class


GetMatteArray Method

32-bit
64-bit
CF
P
P

Description:

Gets the matte array for the image XObject.

Declaration:

public int[] GetMatteArray (  )

Return Value:

Integer array.


GetSoftMask Method

32-bit
64-bit
CF
P
P

Description:

Gets the soft mask for an image.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEImage GetSoftMask (  )

Return Value:

ImGearPDEImage Class object.

See Also:

ImGearPDEImage Class


SetColorMask Method

32-bit
64-bit
CF
P
P

Description:

Use this method to set the Mask entry from the image dictionary. The mask entry is an array specifying a range of colors to be masked out. Samples in the image that fall within this range are not painted, allowing the existing background to show through. The effect is similar to that of the video technique known as chroma-key.

The value of the Mask entry is an array of 2n integers, [min1 max1 ... minn maxn], where n is the number of color components in the image's color space. Each integer must be in the range 0 to 2 in power of BitsPerComponent - 1, representing color values before decoding with the Decode array. An image sample is masked (not painted) if all of its color components before decoding, c1...cn, fall within the specified ranges.

Declaration:

public void SetColorMask ( int[] Mask )

Parameters:

Name
Type
Description
Mask
int[]
Array of long values containing the color mask.

Return Value:

None.


SetColorSpace Method

32-bit
64-bit
CF
P
P

Description:

Sets the color space object for an image. NULL if image an image mask.

Declaration:

public void SetColorSpace ( ImageGear.Formats.PDF.ImGearPDEColorSpace ColorSpace )

Parameters:

Name
Type
Description
ColorSpace
ImGearPDEColorSpace Class
The color space to set

Return Value:

None.

See Also:

ImGearPDEColorSpace Class


SetData Method

32-bit
64-bit
CF
P
P

Description:

Sets data for an image.

Declaration:

public void SetData ( ImageGear.Formats.PDF.ImGearPDEImageDataFlags Flags , byte[] Data )

Parameters:

Name
Type
Description
Flags
ImGearPDEImageDataFlags Enumeration
A set of ImGearPDEImageDataFlags flags. If ENCODED is set, the data must be encoded for the current filters. If the ENCODED flag is not set, data is not encoded.
Data
byte[]
Image data.

Return Value:

None.

See Also:

ImGearPDEImageDataFlags Enumeration


SetDataStream Method

32-bit
64-bit
CF
P
P

Description:

Sets a data stream for an image. Can only be used for XObject images.

Declaration:

public void SetDataStream ( ImageGear.Formats.PDF.ImGearPDEImageDataFlags Flags ,
ImageGear.Formats.PDF.ImGearPDEFilterArray Filters , ImageGear.Formats.PDF.ImGearPDFStream
DataStream )

Parameters:

Name
Type
Description
Flags
ImGearPDEImageDataFlags Enumeration
ImGearPDEImageDataFlags flags. If the ENCODED flag is set, the stream must be encoded.
Filters
ImGearPDEFilterArray Class
ImGearPDEFilterArray object. If not NULL, is used to build the objects for the Filter, DecodeParms, and EncodeParms objects. If is NULL, the existing Filter and DecodeParms are used. EncodeParms is set to DecodeParms if it exists.
DataStream
ImGearPDFStream Class
Stream for the image data.

Return Value:

None.

See Also:

ImGearPDEImageDataFlags Enumeration

ImGearPDEFilterArray Class

ImGearPDFStream Class


SetDecodeArray Method

32-bit
64-bit
CF
P
P

Description:

Sets the decode array for an image.

Normally, the decode array is accessed through the decode field in the ImGearPDEImageAttrs. However, this method defines a decode array to handle images with a color space that has more than 4 components.

Declaration:

public void SetDecodeArray ( int[] Decode )

Parameters:

Name
Type
Description
Decode
int[]
The decode array to set.

Return Value:

None.


SetMatteArray Method

32-bit
64-bit
CF
P
P

Description:

Sets the matte array for the image XObject.

Declaration:

public void SetMatteArray ( int[] Matte )

Parameters:

Name
Type
Description
Matte
int[]
The matte array to set.

Return Value:

None.


SetSoftMask Method

32-bit
64-bit
CF
P
P

Description:

Sets the soft mask for an image.

Declaration:

public void SetSoftMask ( ImageGear.Formats.PDF.ImGearPDEImage SoftMask )

Parameters:

Name
Type
Description
SoftMask
ImGearPDEImage Class
The soft mask to set.

Return Value:

None.

See Also:

ImGearPDEImage Class


ImGearPDEImageAttrs Class

32-bit
64-bit
CF
P
P

Description:

Attributes of a PDE Image object

Declaration:

public sealed class ImGearPDEImageAttrs

Members:

Constructors
Name
Description
ImGearPDEImageAttrs Constructor
Creates the new instance of ImGearPDEImageAttrs object.

Properties
Name
Description
BitsPerComponent Property
Number of bits used to represent each color component in the image.
Decode Property
An array of numbers specifying the mapping from sample values in the image to values appropriate for the current color space. These values correspond to the Decode key in the image dictionary.
Flags Property
Indicates image attributes.
Intent Property
Color rendering intent, corresponding to the Intent key in the image dictionary.
Height Property
Height of the image, corresponding to the Height key in the image dictionary.
Width Property
Width of the image, corresponding to the Width key in the image dictionary.


ImGearPDEImageAttrs Constructors

The ImGearPDEImageAttrs Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEImageAttrs Constructor
Creates the new instance of ImGearPDEImageAttrs object.


ImGearPDEImageAttrs Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDEImageAttrs object.

Declaration:

public ImGearPDEImageAttrs ( )

Return Value:

The new instance of ImGearPDEImageAttrs Class object.

See Also:

ImGearPDEImageAttrs Class


ImGearPDEImageAttrs Properties

The ImGearPDEImageAttrs Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
BitsPerComponent Property
Number of bits used to represent each color component in the image.
Decode Property
An array of numbers specifying the mapping from sample values in the image to values appropriate for the current color space. These values correspond to the Decode key in the image dictionary.
Flags Property
Indicates image attributes.
Intent Property
Color rendering intent, corresponding to the Intent key in the image dictionary.
Height Property
Height of the image, corresponding to the Height key in the image dictionary.
Width Property
Width of the image, corresponding to the Width key in the image dictionary.


BitsPerComponent Property

32-bit
64-bit
CF
P
P

Description:

Number of bits used to represent each color component in the image, corresponding to the BitsPerComponent key in the image dictionary.

Declaration:

public int BitsPerComponent { get, set }

Value:

Integer

Default value:

0


Decode Property

32-bit
64-bit
CF
P
P

Description:

An array of numbers specifying the mapping from sample values in the image to values appropriate for the current color space. These values correspond to the Decode key in the image dictionary.

Declaration:

public int[] Decode { get, set }

Value:

Array of integers

Default value:

{0, 0, 0, 0, 0, 0, 0, 0}


Flags Property

32-bit
64-bit
CF
P
P

Description:

Indicates image attributes.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEImageAttrFlags Flags { get, set }

Value:

ImGearPDEImageAttrFlags Enumeration value.

Default value:

0

See Also:

ImGearPDEImageAttrFlags Enumeration


Intent Property

32-bit
64-bit
CF
P
P

Description:

Color rendering intent, corresponding to the Intent key in the image dictionary.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom Intent { get, set }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFAtom Class


Height Property

32-bit
64-bit
CF
P
P

Description:

Height of the image, corresponding to the Height key in the image dictionary.

Declaration:

public int Height { get }

Value:

Integer value

Default value:

0


Width Property

32-bit
64-bit
CF
P
P

Description:

Width of the image, corresponding to the Width key in the image dictionary.

Declaration:

public int Width { get, set }

Value:

Integer

Default value:

0


ImGearPDEObject Class

32-bit
64-bit
CF
P
P

Description:

Base class for all the PDE objects.

Declaration:

public abstract class ImGearPDEObject : ImageGear.Formats.PDF.ImGearPDFObject

Members:

Properties
Name
Description
Type Property
Type of the object.


ImGearPDEObject Properties

The ImGearPDEClip Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
Type Property
Type of the object.


Type Property

32-bit
64-bit
CF
P
P

Description:

Type of the object.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEType Type { get }

Value:

ImGearPDEType Enumeration value

Default value:

N/A

See Also:

ImGearPDEType Enumeration


ImGearPDEPath Class

32-bit
64-bit
CF
P
P

Description:

This is an element that contains a path. Path objects can be stroked, filled, and/or serve as a clipping path.

Declaration:

public sealed class ImGearPDEPath : ImageGear.Formats.PDF.ImGearPDEElement

Members:

Constructors
Name
Description
ImGearPDEPath Constructor
Creates new instance of ImGearPDEPath object.

Properties
Name
Description
PaintOp Property
The fill and stroke attributes of a path.

Methods
Name
Description
AddSegment Method
Adds a segment to a path.
GetData Method
Gets the path data.
SetData Method
Sets new path data for a path element.


ImGearPDEPath Constructors

The ImGearPDEPath Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEPath Constructor
Creates new instance of ImGearPDEPath object.


ImGearPDEPath Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDEPath object.

Declaration:

public ImGearPDEPath ( )

Return Value:

The new instance of ImGearPDEPath Class object.

See Also:

ImGearPDEPath Class


ImGearPDEPath Properties

The ImGearPDEPath Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
PaintOp Property
The fill and stroke attributes of a path.


PaintOp Property

32-bit
64-bit
CF
P
P

Description:

The fill and stroke attributes of a path.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEPathOpFlags PaintOp { get, set }

Value:

ImGearPDEPathOpFlags Enumeration value

Default value:

N/A

See Also:

ImGearPDEPathOpFlags Enumeration


ImGearPDEPath Methods

The ImGearPDEPath Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
AddSegment Method
Adds a segment to a path.
GetData Method
Gets the path data.
SetData Method
Sets new path data for a path element.


AddSegment Method

32-bit
64-bit
CF
P
P

Description:

Adds a segment to a path. The number of values used depends upon SegType:

  • MOVE_TO: X1, Y1
  • LINE_TO: X1, Y1
  • CURVE_TO: X1, Y1, X2, Y2, X3, Y3
  • CURVE_TO_V: X1, Y1, X2, Y2
  • CURVE_TO_Y: X1, Y1, X2, Y2
  • RECT: X1, Y1, X2 (width), Y2 (height)
  • CLOSE_PATH: None

Declaration:

public void AddSegment ( ImageGear.Formats.PDF.ImGearPDEPathElementType SegType , int X1 ,
int Y1 , int X2 , int Y2 , int X3 , int Y3 )

Parameters:

Name
Type
Description
SegType
ImGearPDEPathElementType Enumeration
A ImGearPDEPathElementType value indicating the type of path to add.
X1
int
x-coordinate of first point.
Y1
int
y-coordinate of first point.
X2
int
x-coordinate of second point.
Y2
int
y-coordinate of second point.
X3
int
x-coordinate of third point.
Y3
int
y-coordinate of third point.

Return Value:

None.

See Also:

ImGearPDEPathElementType Enumeration


GetData Method

32-bit
64-bit
CF
P
P

Description:

Gets the path data.

Declaration:

public int[] GetData (  )

Return Value:

ImGearIntegerArray object that contains a variable-sized array of path operators and operands. The format is a 32-bit operator followed by 0 to 3 ImGearPDFFixedPoint values, depending on the operator. Opcodes are codes for moveto, lineto, curveto, rect, or closepath operators; operands are ImGearPDFFixedPoint values.

NOTE: Returns "raw" path data. If you want the points in page coordinates, concatenate the path data points with the PDE Element matrix obtained from ImGearPDEElement.GetMatrix.


SetData Method

32-bit
64-bit
CF
P
P

Description:

Sets new path data for a path element.

Declaration:

public void SetData ( int[] Data )

Parameters:

Name
Type
Description
Data
int[]
ImGearIntegerArray object, which is a variable-sized array of path operators and operands. The format is a 32-bit operator followed by 0 to 3 ImGearPDFFixedPoint values, depending on the operator. Operators are codes for moveto, lineto, curveto, rect, or closepath operators and must be one of ImGearPDEPathElementType. Operands are ImGearPDFFixedPoint values.

Return Value:

None.


ImGearPDEPlace Class

32-bit
64-bit
CF
P
P

Description:

The PDE place object is an element that marks a place on a page in a PDF file. In a PDF file, a place is represented by the MP or DP Marked Content operators.

Marked content is useful for adding structure information to a PDF file. For instance, a drawing program may want to mark a point with information, such as the start of a path of a certain type. Marked content provides a way to retain this information in the PDF file. A DP operator functions the same as the MP operator and, in addition, allows a property list dictionary to be associated with a place.

Declaration:

public sealed class ImGearPDEPlace : ImageGear.Formats.PDF.ImGearPDEElement

Members:

Constructors
Name
Description
ImGearPDEPlace Constructor
Creates new instance of ImGearPDEPlace object.

Properties
Name
Description
IsDictionaryInline Property
True if the dictionary is inline, false otherwise.

Methods
Name
Description
GetDictionary Method
Gets marked Content dictionary for a place.
GetMCTag Method
Gets Marked Content tag for a place.
SetDictionary Method
Sets the Marked Content dictionary for a place.
SetMCTag Method
Sets Marked Content tag for a place.


ImGearPDEPlace Constructors

The ImGearPDEPlace Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEPlace Constructor
Creates new instance of ImGearPDEPlace object.


ImGearPDEPlace Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDEPlace object.

Declaration:

public ImGearPDEPlace ( )

Return Value:

The new instance of ImGearPDEPlace Class object.

See also:

ImGearPDEPlace Class


ImGearPDEPlace Properties

The ImGearPDEPlace Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
IsDictionaryInline Property
True if the dictionary is inline, false otherwise.


IsDictionaryInline Property

32-bit
64-bit
CF
P
P

Description:

True if the dictionary is inline, false otherwise. Undefined if the place has no Marked Content dictionary.

Declaration:

public bool IsDictionaryInline { get }

Value:

True, False

Default value:

N/A


ImGearPDEPlace Methods

The ImGearPDEPlace Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
GetDictionary Method
Gets marked Content dictionary for a place.
GetMCTag Method
Gets Marked Content tag for a place.
SetDictionary Method
Sets the Marked Content dictionary for a place.
SetMCTag Method
Sets Marked Content tag for a place.


GetDictionary Method

32-bit
64-bit
CF
P
P

Description:

Gets marked Content dictionary for a place. NULL if the place has no Marked Content dictionary.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFBasDict GetDictionary (  )

Return Value:

ImGearPDFBasDict Class object.

See also:

ImGearPDFBasDict Class


GetMCTag Method

32-bit
64-bit
CF
P
P

Description:

Gets Marked Content tag for a place.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom GetMCTag (  )

Return Value:

ImGearPDFAtom Class object.

See also:

ImGearPDFAtom Class


SetDictionary Method

32-bit
64-bit
CF
P
P

Description:

Sets the Marked Content dictionary for a place.

Declaration:

public void SetDictionary ( ImageGear.Formats.PDF.ImGearPDFBasDict Dictionary , bool
IsInline )

Parameters:

Name
Type
Description
Dictionary
ImGearPDFBasDict Class
Marked Content dictionary for a place.
IsInline
bool
If True, the dictionary is emitted inline.

Return Value:

None.

See also:

ImGearPDFBasDict Class


SetMCTag Method

32-bit
64-bit
CF
P
P

Description:

Sets Marked Content tag for a place.

Declaration:

public void SetMCTag ( ImageGear.Formats.PDF.ImGearPDFAtom MCTag )

Parameters:

Name
Type
Description
MCTag
ImGearPDFAtom Class
Marked Content tag for a place.

Return Value:

None.

See also:

ImGearPDFAtom Class


ImGearPDEPostScript Class

32-bit
64-bit
CF
P
P

Description:

The PDE PostScript object is an element representing in-line or XObject pass-through PostScript object. XObject PostScripts are listed in page XObject resources.

Declaration:

public sealed class ImGearPDEPostScript : ImageGear.Formats.PDF.ImGearPDEElement

Members:

Constructors
Name
Description
ImGearPDEPostScript Constructor
Creates new instance of ImGearPDEPostScript object.

Methods
Name
Description
GetAttributes Method
Gets postscript attributes.
GetData Method
Gets all or part of the image data.
GetDataStream Method
Gets a stream for the data.
SetData Method
Sets the data for the postscript.
SetDataStream Method
Sets a stream for the data.


ImGearPDEPostScript Constructors

The ImGearPDEPostScript Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEPostScript Constructor
Creates new instance of ImGearPDEPostScript object.


ImGearPDEPostScript Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDEPostScript object.

Declaration:

public ImGearPDEPostScript ( )

Return Value:

The new instance of ImGearPDEPostScript Class object.

See Also:

ImGearPDEPostScript Class


ImGearPDEPostScript Methods

The ImGearPDEPostScript Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
GetAttributes Method
Gets postscript attributes.
GetData Method
Gets all or part of the image data.
GetDataStream Method
Gets a stream for the data.
SetData Method
Sets the data for the postscript.
SetDataStream Method
Sets a stream for the data.


GetAttributes Method

32-bit
64-bit
CF
P
P

Description:

Gets postscript attributes.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEPSAttrs GetAttributes (  )

Return Value:

ImGearPDEPSAttrs Class value.

See Also:

ImGearPDEPSAttrs Class


GetData Method

32-bit
64-bit
CF
P
P

Description:

Gets all or part of the image data.

Declaration:

public byte[] GetData ( int Offset )

Parameters:

Name
Type
Description
Offset
int
Offset into the source data at which to start filling buffer.

Return Value:

Integer Array.

See Also:

ImGearPDEPostScript Class


GetDataStream Method

32-bit
64-bit
CF
P
P

Description:

Gets a stream for the data. The data in the stream is decoded (no filters).

Declaration:

public ImageGear.Formats.PDF.ImGearPDFStream GetDataStream (  )

Return Value:

ImGearPDFStream Class object.

See Also:

ImGearPDFStream Class


SetData Method

32-bit
64-bit
CF
P
P

Description:

Sets the data for the postscript.

Declaration:

public void SetData ( byte[] Data )

Parameters:

Name
Type
Description
Data
byte[]
The data to be set.

Return Value:

None.


SetDataStream Method

32-bit
64-bit
CF
P
P

Description:

Sets a stream for the data. The data must be un-encoded (no filters).

Declaration:

public void SetDataStream ( ImageGear.Formats.PDF.ImGearPDFStream DataStream )

Parameters:

Name
Type
Description
DataStream
ImGearPDFStream Class
Stream for the data.

Return Value:

None.

See Also:

ImGearPDFStream Class


ImGearPDEPSAttrs Class

32-bit
64-bit
CF
P
P

Description:

Attributes of a PDE PostScript object.

Declaration:

public sealed class ImGearPDEPSAttrs

Members:

Constructors
Name
Description
ImGearPDEPSAttrs Constructor
Creates new instance of ImGearPDEPSAttrs object

Properties
Name
Description
Flags Property
Flags for PostScript.


ImGearPDEPSAttrs Constructors

The ImGearPDEPSAttrs Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEPSAttrs Constructor
Creates new instance of ImGearPDEPSAttrs object


ImGearPDEPSAttrs Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDEPSAttrs object.

Declaration:

public ImGearPDEPSAttrs ( )

Return Value:

The new instance of ImGearPDEPSAttrs Class object.

See Also:

ImGearPDEPSAttrs Class


ImGearPDEPSAttrs Properties

The ImGearPDEPSAttrs Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
Flags Property
Flags for PostScript.


Flags Property

32-bit
64-bit
CF
P
P

Description:

Flags for PostScript.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEPSAttrFlags Flags
{ get, set }

Value:

ImGearPDEPSAttrFlags Enumeration value.

Default value:

INLINE

See Also:

ImGearPDEPSAttrFlags Enumeration


ImGearPDEShading Class

32-bit
64-bit
CF
P
P

Description:

The PDE shading object is an element that represents smooth shading.

Declaration:

public sealed class ImGearPDEShading : ImageGear.Formats.PDF.ImGearPDEElement

Members:

Constructors
Name
Description
ImGearPDEShading Constructor
Creates new instance of ImGearPDEShading object.

Methods
Name
Description
GetDictionary Method
This method gets dictionary for a shading.


ImGearPDEShading Constructors

The ImGearPDEShading Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEShading Constructor
Creates new instance of ImGearPDEShading object.


ImGearPDEShading Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDEShading object.

Declaration:

public ImGearPDEShading ( )

Return Value:

The new instance of ImGearPDEShading Class object.

See Also:

ImGearPDEShading Class


ImGearPDEShading Methods

The ImGearPDEShading Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
GetDictionary Method
This method gets dictionary for a shading.


GetDictionary Method

32-bit
64-bit
CF
P
P

Description:

This method gets dictionary for a shading.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFBasDict GetDictionary (  )

Return Value:

ImGearPDFBasDict Class object.

See Also:

ImGearPDFBasDict Class


ImGearPDESoftMask Class

32-bit
64-bit
CF
P
P

Description:

The PDE soft mask object is an object for creating and manipulating a soft mask in a PDF file.

Declaration:

public sealed class ImGearPDESoftMask : ImageGear.Formats.PDF.ImGearPDEElement

Members:

Constructors
Name
Description
ImGearPDESoftMask Constructor
Creates new instance of ImGearPDESoftMask object.
ImGearPDESoftMask Constructor
Creates new instance of ImGearPDESoftMask object.

Properties
Name
Description
Name Property
The soft mask name.

Methods
Name
Description
GetBackdropColor Method
Gets the array of color values of the backdrop color.
GetForm Method
Acquires the form that defines the soft mask.
SetBackdropColor Method
Sets the backdrop color values.
SetForm Method
Sets the form that defines the soft mask.


ImGearPDESoftMask Constructors

The ImGearPDESoftMask Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDESoftMask Constructor
Creates new instance of ImGearPDESoftMask object.
ImGearPDESoftMask Constructor
Creates new instance of ImGearPDESoftMask object.


ImGearPDESoftMask Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDESoftMask object.

Declaration:

public ImGearPDESoftMask ( ImageGear.Formats.PDF.ImGearPDFAtom Name )

Parameters:

Name
Type
Description
Name
ImGearPDFAtom Class
The name of the soft mask.

Return Value:

The new instance of ImGearPDESoftMask Class object.

See Also:

ImGearPDESoftMask Class

ImGearPDFAtom Class


ImGearPDESoftMask Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDESoftMask Class object.

Declaration:

public ImGearPDESoftMask ( ImageGear.Formats.PDF.ImGearPDFDocument Doc ,
ImageGear.Formats.PDF.ImGearPDESoftMaskCreateFlags Type ,
ImageGear.Formats.PDF.ImGearPDEForm Form )

Parameters:

Name
Type
Description
Doc
ImGearPDFDocument Class
The container document.
Type
ImGearPDESoftMaskCreateFlags Enumeration
Specifies how the mask is to be computed. One of the enumImGearPDESoftMaskCreateFlags.
Form
ImGearPDEForm Class
The form XObject that defines the soft mask. It is the source of the mask values and the color space in which the composite computation is to be done.

Return Value:

The new instance of ImGearPDESoftMask Class object.

See Also:

ImGearPDESoftMask Class

ImGearPDFDocument Class

ImGearPDESoftMaskCreateFlags Enumeration

ImGearPDEForm Class


ImGearPDESoftMask Properties

The ImGearPDESoftMask Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
Name Property
The soft mask name.


Name Property

32-bit
64-bit
CF
P
P

Description:

Provides the name of the soft mask.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom Name { get }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFAtom Class


ImGearPDESoftMask Methods

The ImGearPDESoftMask Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
GetBackdropColor Method
Gets the array of color values of the backdrop color.
GetForm Method
Acquires the form that defines the soft mask.
SetBackdropColor Method
Sets the backdrop color values.
SetForm Method
Sets the form that defines the soft mask.


GetBackdropColor Method

32-bit
64-bit
CF
P
P

Description:

Gets the array of color values of the backdrop color.

Declaration:

public int[] GetBackdropColor (  )

Return Value:

Array of color values.


GetForm Method

32-bit
64-bit
CF
P
P

Description:

Acquires the form that defines the soft mask.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEForm GetForm (
ImageGear.Formats.PDF.ImGearPDFFixedMatrix Matrix )

Parameters:

Name
Type
Description
Matrix
ImGearPDFFixedMatrix Class
Defining the transformation from coordinate space to user space.

Return Value:

ImGearPDEForm Class object.

See Also:

ImGearPDEForm Class

ImGearPDFFixedMatrix Class


SetBackdropColor Method

32-bit
64-bit
CF
P
P

Description:

Sets the backdrop color values.

Declaration:

public void SetBackdropColor ( int[] ColorValues )

Parameters:

Name
Type
Description
ColorValues
int[]
Array of color values.

Return Value:

None.


SetForm Method

32-bit
64-bit
CF
P
P

Description:

Sets the form that defines the soft mask.

Declaration:

public void SetForm ( ImageGear.Formats.PDF.ImGearPDEForm Form )

Parameters:

Name
Type
Description
Form
ImGearPDEForm Class
The form XObject.

Return Value:

None.

See Also:

ImGearPDEForm Class


ImGearPDEText Class

32-bit
64-bit
CF
P
P

Description:

The PDE text object is an element representing text. It is a container for text as show strings or as individual characters. Each sub-element may have different graphics state properties. However, the same clip applies to all sub-elements of a Text. Also, the char path of a Text can be used to represent a clip.

Declaration:

public sealed class ImGearPDEText : ImageGear.Formats.PDF.ImGearPDEElement

Members:

Constructors
Name
Description
ImGearPDEText Constructor
Creates new instance of ImGearPDEText object.

Properties
Name
Description
CharCount Property
The number of text runs (show strings) in the text object.
RunsCount Property
The number of text runs (show strings) in the text object.
RunGetCharCount Property
The number of characters in the specified text run.
RunGetCharOffset Property
The character offset of the first character of the specified text run.

Methods
Name
Description
Add Method
Adds a character or a text run to a PDE Text object.
AddItem Method
Adds a text item to a text element at a given index position.
GetAdvance Method
Gets the advance width of a character or a text element.
GetBBox Method
Gets the bounding box of a character or a text run.
GetByteCount Method
Gets the number of bytes occupied by the character code or text run.
GetFont Method
Gets the font for a text character or element.
GetGState Method
Gets the graphics state of a character or a text run.
GetItem Method
Obtains a text item from a text element at a given index position.
GetMatrix Method
Returns the matrix of a character or a text element.
GetQuad Method
Gets the quad bounding the specified text run or character.
GetRunForChar Method
Gets the index of the text run that contains the nth character in a text object.
GetState Method
Gets the text state of a character or a text element.
GetStrokeMatrix Method
Gets the stroke matrix of a character or a text run.
GetText Method
Gets the text for a text run or character.
IsAtPoint Method
Tests whether a point is on specified text.
IsAtRect Method
Tests whether any part of a rectangle is on the specified text.
Remove Method
Removes characters or text runs from a text object.
RemoveItems Method
Removes contiguous text items from a text element starting at a given index position.
ReplaceChars Method
Replaces characters in a text object.
RunSetFont Method
Sets the font of a text run.
RunSetGState Method
Sets the text state of a text run.
RunSetMatrix Method
Sets the matrix of a text run.
RunSetState Method
Sets the text state of a text run.
RunSetStrokeMatrix Method
Sets the stroke matrix of a text run.
SplitRunAt Method
Splits a text run into two text runs.


ImGearPDEText Constructors

The ImGearPDEText Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEText Constructor
Creates new instance of ImGearPDEText object.


ImGearPDEText Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDEText Class object.

Declaration:

public ImGearPDEText (  )

Return Value:

The new instance of ImGearPDEText Class object.

See Also:

ImGearPDEText Class


ImGearPDEText Properties

The ImGearPDEText Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
CharCount Property
The number of text runs (show strings) in the text object.
RunsCount Property
The number of text runs (show strings) in the text object.
RunGetCharCount Property
The number of characters in the specified text run.
RunGetCharOffset Property
The character offset of the first character of the specified text run.


CharCount Property

32-bit
64-bit
CF
P
P

Description:

The number of characters in the text object.

Declaration:

public int CharCount { get }

Value:

Integer number.

Default value:

N/A


RunsCount Property

32-bit
64-bit
CF
P
P

Description:

The number of text runs (show strings) in the text object.

Declaration:

public int RunsCount { get }

Value:

Integer number.

Default value:

N/A


RunGetCharCount Property

32-bit
64-bit
CF
P
P

Description:

The number of characters in the specified text run.

RunIndex is in the range of [0 to RunsCount-1].

Declaration:

public int RunGetCharCount ( int RunIndex ){ get }

Value:

Integer number.

Default value:

N/A


RunGetCharOffset Property

32-bit
64-bit
CF
P
P

Description:

The character offset of the first character of the specified text run.

RunIndex is in the range of [0 to RunsCount-1].

Declaration:

public int RunGetCharOffset ( int RunIndex ){ get }

Value:

Integer number.

Default value:

N/A


ImGearPDEText Methods

The ImGearPDEText Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
Add Method
Adds a character or a text run to a PDE Text object.
AddItem Method
Adds a text item to a text element at a given index position.
GetAdvance Method
Gets the advance width of a character or a text element.
GetBBox Method
Gets the bounding box of a character or a text run.
GetByteCount Method
Gets the number of bytes occupied by the character code or text run.
GetFont Method
Gets the font for a text character or element.
GetGState Method
Gets the graphics state of a character or a text run.
GetItem Method
Obtains a text item from a text element at a given index position.
GetMatrix Method
Returns the matrix of a character or a text element.
GetQuad Method
Gets the quad bounding the specified text run or character.
GetRunForChar Method
Gets the index of the text run that contains the nth character in a text object.
GetState Method
Gets the text state of a character or a text element.
GetStrokeMatrix Method
Gets the stroke matrix of a character or a text run.
GetText Method
Gets the text for a text run or character.
IsAtPoint Method
Tests whether a point is on specified text.
IsAtRect Method
Tests whether any part of a rectangle is on the specified text.
Remove Method
Removes characters or text runs from a text object.
RemoveItems Method
Removes contiguous text items from a text element starting at a given index position.
ReplaceChars Method
Replaces characters in a text object.
RunSetFont Method
Sets the font of a text run.
RunSetGState Method
Sets the text state of a text run.
RunSetMatrix Method
Sets the matrix of a text run.
RunSetState Method
Sets the text state of a text run.
RunSetStrokeMatrix Method
Sets the stroke matrix of a text run.
SplitRunAt Method
Splits a text run into two text runs.


Add Method

32-bit
64-bit
CF
P
P

Description:

Adds a character or a text run to a PDE Text object.

Declaration:

public void Add ( ImageGear.Formats.PDF.ImGearPDETextFlags Flags , int Index , string Text
, ImageGear.Formats.PDF.ImGearPDEFont Font , ImageGear.Formats.PDF.ImGearPDEGraphicState
GState , ImageGear.Formats.PDF.ImGearPDETextState TState ,
ImageGear.Formats.PDF.ImGearPDFFixedMatrix TextMatrix ,
ImageGear.Formats.PDF.ImGearPDFFixedMatrix StrokeMatrix )

Parameters:

Name
Type
Description
Flags
ImGearPDETextFlags Enumeration
ImGearPDETextFlag flag that specifies what kind of text to add. Must be either:
CHAR - for a text character
RUN - for a text run
Index
int
Index after which to add character or text run.
Text
string
String with characters to add.
NOTE: Passing NULL for text can invalidate the text object but will not raise an error. Callers must not pass NULL for this parameter.
Font
ImGearPDEFont Class
Font for the element.
GState
ImGearPDEGraphicState Class
The graphics state for the element.
TState
ImGearPDETextState Class
The text state for the element.
TextMatrix
ImGearPDFFixedMatrix Class
The matrix for the element.
StrokeMatrix
ImGearPDFFixedMatrix Class
The matrix for the line width when stroking text. May be NULL.

Return Value:

None.

See Also:

ImGearPDETextFlags Enumeration

ImGearPDEFont Class

ImGearPDEGraphicState Class

ImGearPDETextState Class

ImGearPDFFixedMatrix Class


AddItem Method

32-bit
64-bit
CF
P
P

Description:

Adds a text item to a text element at a given index position.

Declaration:

public void AddItem ( int Index , ImageGear.Formats.PDF.ImGearPDETextItem TextItem )

Parameters:

Name
Type
Description
Index
int
Index of the text item.
TextItem
ImGearPDETextItem Class
The text item to add.

Return Value:

None.

See Also:

ImGearPDETextItem Class


GetAdvance Method

32-bit
64-bit
CF
P
P

Description:

Gets the advance width of a character or a text element. Advance width is returned in either character space or user space. The advance width is the amount by which the current point advances when the character is drawn.

Advance width may be horizontal or vertical, depending on the writing style. Thus the return value has both a horizontal and vertical component.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFFixedPoint GetAdvance (
ImageGear.Formats.PDF.ImGearPDETextFlags Flags , int Index )

Parameters:

Name
Type
Description
Flags
ImGearPDETextFlags Enumeration
ImGearPDETextFlag value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either:
  • CHAR - for a text character
  • RUN - for a text run
In addition, set the PAGE_SPACE flag to obtain the advance width in user space. If it is not set, the advance width is in character space.
If this flag is not set, this method returns a value that is independent of any sizes, matrices, or scaling, simply adding up the font's raw glyph widths, supplemented only by unscaled character and word spacing.
Index
int
Index of the character or text run in the text.

Return Value:

ImGearPDFFixedPoint Class object indicating the advance width.

See Also:

ImGearPDFFixedPoint Class

ImGearPDETextFlags Enumeration


GetBBox Method

32-bit
64-bit
CF
P
P

Description:

Gets the bounding box of a character or a text run.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFFixedRect GetBBox (
ImageGear.Formats.PDF.ImGearPDETextFlags Flags , System.Int32 Index )

Parameters:

Name
Type
Description
Flags
ImGearPDETextFlags Enumeration
ImGearPDETextFlag value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either:
  • CHAR - for a text character
  • RUN - for a text run
Index
int
Index of the character or text run in the text object.

Return Value:

ImGearPDFFixedRect Class object, which is the bounding box of specified character or text run.

See Also:

ImGearPDFFixedRect Class

ImGearPDETextFlags Enumeration


GetByteCount Method

32-bit
64-bit
CF
P
P

Description:

Gets the number of bytes occupied by the character code or text run.

Declaration:

public System.Int32 GetByteCount ( ImageGear.Formats.PDF.ImGearPDETextFlags Flags , int
Index )

Parameters:

Name
Type
Description
Flags
ImGearPDETextFlags Enumeration
ImGearPDETextFlag value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either:
  • CHAR - for a text character
  • RUN - for a text run
Index
int
Index of the character or text run in the text object.

Return Value:

Number of bytes occupied by the text run or character.

See Also:

ImGearPDETextFlags Enumeration


GetFont Method

32-bit
64-bit
CF
P
P

Description:

Gets the font for a text character or element.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEFont GetFont (
ImageGear.Formats.PDF.ImGearPDETextFlags Flags , int Index )

Parameters:

Name
Type
Description
Flags
ImGearPDETextFlags Enumeration
Specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either:
  • CHAR - for a text character
  • RUN - for a text run
Index
int
Index of the character or text run in the text object.

Return Value:

ImGearPDEFont Class object.

See Also:

ImGearPDETextFlags Enumeration

ImGearPDEFont Class


GetGState Method

32-bit
64-bit
CF
P
P

Description:

Gets the graphics state of a character or a text run.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEGraphicState GetGState (
ImageGear.Formats.PDF.ImGearPDETextFlags Flags , int Index )

Parameters:

Name
Type
Description
Flags
ImGearPDETextFlags Enumeration
ImGearPDETextFlag value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either:
  • CHAR - for a text character
  • RUN - for a text run
Index
int
Index of the character or text run in the text object.

Return Value:

ImGearPDEGraphicState Class object, which is the graphics state of specified character or text run.

See Also:

ImGearPDETextFlags Enumeration

ImGearPDEGraphicState Class


GetItem Method

32-bit
64-bit
CF
P
P

Description:

Obtains a text item from a text element at a given index position.

Declaration:

public ImageGear.Formats.PDF.ImGearPDETextItem GetItem ( int Index )

Parameters:

Name
Type
Description
Index
int
Index of the text item in the text object.

Return Value:

ImGearPDETextItem Class object.

See Also:

ImGearPDETextItem Class


GetMatrix Method

32-bit
64-bit
CF
P
P

Description:

Returns the matrix of a character or a text element.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFFixedMatrix GetMatrix (
ImageGear.Formats.PDF.ImGearPDETextFlags Flags , int Index )

Parameters:

Name
Type
Description
Flags
ImGearPDETextFlags Enumeration
ImGearPDETextFlag value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either:
  • CHAR - for a text character
  • RUN - for a text run
Index
int
Index of the character or text run in the text object.

Return Value:

ImGearPDFFixedMatrix Class object that holds the matrix of specified character or text run.

See Also:

ImGearPDETextFlags Enumeration

ImGearPDFFixedMatrix Class


GetQuad Method

32-bit
64-bit
CF
P
P

Description:

Gets the quad bounding the specified text run or character.

The advance portion of the quad is based on the left side bearing and advance width.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFFixedQuad GetQuad (
ImageGear.Formats.PDF.ImGearPDETextFlags Flags , int Index )

Parameters:

Name
Type
Description
Flags
ImGearPDETextFlags Enumeration
ImGearPDETextFlag value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either:
  • CHAR - for a text character
  • RUN - for a text run
In addition, if the GET_BOUNDS flag is set, this method uses the font descriptor's FontBBox, which is the smallest rectangle that encloses all characters in the font. The advance portion is based on the x-coordinates of the left and right sides of FontBBox and the advance width.
Index
int
Index of the character or text run in the text object.

Return Value:

ImGearPDFFixedQuad Class object that bounds the specified character or text run.

See Also:

ImGearPDETextFlags Enumeration

ImGearPDFFixedQuad Class


GetRunForChar Method

32-bit
64-bit
CF
P
P

Description:

Gets the index of the text run that contains the nth character in a text object.

Declaration:

public int GetRunForChar ( int CharIndex )

Parameters:

Name
Type
Description
CharIndex
int
Number of the character to find in the text object.

Return Value:

Index of the text run with the specified character index in the text object.


GetState Method

32-bit
64-bit
CF
P
P

Description:

Gets the text state of a character or a text element.

Declaration:

public ImageGear.Formats.PDF.ImGearPDETextState GetState (
ImageGear.Formats.PDF.ImGearPDETextFlags Flags , int Index )

Parameters:

Name
Type
Description
Flags
ImGearPDETextFlags Enumeration
ImGearPDETextFlag value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either:
  • CHAR - for a text character
  • RUN - for a text run
Index
int
Index of the character or text run in the text object.

Return Value:

ImGearPDETextState Class object, which is the text state of the specified character or text run.

See Also:

ImGearPDETextFlags Enumeration

ImGearPDETextState Class


GetStrokeMatrix Method

32-bit
64-bit
CF
P
P

Description:

Gets the stroke matrix of a character or a text run.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFFixedMatrix GetStrokeMatrix (
ImageGear.Formats.PDF.ImGearPDETextFlags Flags , int Index )

Parameters:

Name
Type
Description
Flags
ImGearPDETextFlags Enumeration
ImGearPDETextFlag value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either:
  • CHAR - for a text character
  • RUN - for a text run
Index
int
Index of the character or text run in the text object.

Return Value:

ImGearPDFFixedMatrix Class object that that holds the stroke matrix of specified character or text run. This matrix is the transformation for line widths when stroking. The h and v values of the matrix are ignored.

See Also:

ImGearPDETextFlags Enumeration

ImGearPDFFixedMatrix Class


GetText Method

32-bit
64-bit
CF
P
P

Description:

Gets the text for a text run or character.

Declaration:

public System.String GetText ( ImageGear.Formats.PDF.ImGearPDETextFlags Flags , int Index
)

Parameters:

Name
Type
Description
Flags
ImGearPDETextFlags Enumeration
ImGearPDETextFlag value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either:
  • CHAR - for a text character
  • RUN - for a text run
Index
int
Index of the character or text run in the text object.

Return Value:

String.

See Also:

ImGearPDETextFlags Enumeration


IsAtPoint Method

32-bit
64-bit
CF
P
P

Description:

Tests whether a point is on specified text. Checks if the point is in a bounding box for the text.

Declaration:

public bool IsAtPoint ( ImageGear.Formats.PDF.ImGearPDETextFlags Flags , int Index ,
ImageGear.Formats.PDF.ImGearPDFFixedPoint Point )

Parameters:

Name
Type
Description
Flags
ImGearPDETextFlags Enumeration
ImGearPDETextFlag value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either:
  • CHAR - for a text character
  • RUN - for a text run
Index
int
Index of the character or text run in the text object.
Point
ImGearPDFFixedPoint Class
A point, specified in user space coordinates.

Return Value:

True if the point is on the text, False otherwise.

See Also:

ImGearPDETextFlags Enumeration

ImGearPDFFixedPoint Class


IsAtRect Method

32-bit
64-bit
CF
P
P

Description:

Tests whether any part of a rectangle is on the specified text.

Declaration:

public bool IsAtRect ( ImageGear.Formats.PDF.ImGearPDETextFlags Flags , int Index ,
ImageGear.Formats.PDF.ImGearPDFFixedRect Rect )

Parameters:

Name
Type
Description
Flags
ImGearPDETextFlags Enumeration
ImGearPDETextFlag value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either:
  • CHAR - for a text character
  • RUN - for a text run
Index
int
Index of the character or text run in the text object.
Rect
ImGearPDFFixedRect Class
A rectangle, specified in user space coordinates.

Return Value:

True if the text is on the rectangle, False otherwise.

See Also:

ImGearPDETextFlags Enumeration

ImGearPDFFixedRect Class


Remove Method

32-bit
64-bit
CF
P
P

Description:

Removes characters or text runs from a text object.

Declaration:

public void Remove ( ImageGear.Formats.PDF.ImGearPDETextFlags Flags , int Index , int Count
)

Parameters:

Name
Type
Description
Flags
ImGearPDETextFlags Enumeration
ImGearPDETextFlag value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either:
  • CHAR - for a text character
  • RUN - for a text run
Index
int
Index of the character or text run in the text object.
Count
int
Number of characters or text runs to remove.

Return Value:

None.

See Also:

ImGearPDETextFlags Enumeration


RemoveItems Method

32-bit
64-bit
CF
P
P

Description:

Removes contiguous text items from a text element starting at a given index position.

Declaration:

public void RemoveItems ( int Index , int Count )

Parameters:

Name
Type
Description
Index
int
Index of the first text item in pdeText to remove.
Count
int
The number of text items to remove.

Return Value:

None.


ReplaceChars Method

32-bit
64-bit
CF
P
P

Description:

Replaces characters in a text object.

This method does not change the number of characters in the text object-extra characters are ignored.

Declaration:

public void ReplaceChars ( ImageGear.Formats.PDF.ImGearPDETextFlags Flags , int Index ,
string Text )

Parameters:

Name
Type
Description
Flags
ImGearPDETextFlags Enumeration
ImGearPDETextFlag value that specifies whether index refers to the character offset from the beginning of the text object or the index of the text run in the text object. Must be either:
  • CHAR - for a text character
  • RUN - for a text run
Index
int
Index of the character or text run in the text object.
Text
string
Replacement text.

Return Value:

None.

See Also:

ImGearPDETextFlags Enumeration


RunSetFont Method

32-bit
64-bit
CF
P
P

Description:

Sets the font of a text run.

Declaration:

public void RunSetFont ( int RunIndex, ImageGear.Formats.PDF.ImGearPDEFont Font )

Parameters:

Name
Type
Description
RunIndex
int
Index of the text run.
Font
ImGearPDEFont Class
Font set for the text run.

Return Value:

None.

See Also:

ImGearPDEFont Class


RunSetGState Method

32-bit
64-bit
CF
P
P

Description:

Sets the graphics state of a text run.

Declaration:

public void RunSetGState ( int RunIndex , ImageGear.Formats.PDF.ImGearPDEGraphicState
GState )

Parameters:

Name
Type
Description
RunIndex
int
Index of the text run.
GState
ImGearPDEGraphicState Class
ImGearPDEGraphicState with graphics state to set.

Return Value:

None.

See Also:

ImGearPDEGraphicState Class


RunSetMatrix Method

32-bit
64-bit
CF
P
P

Description:

Sets the matrix of a text run.

Declaration:

public void RunSetMatrix ( int RunIndex , ImageGear.Formats.PDF.ImGearPDFFixedMatrix
Matrix )

Parameters:

Name
Type
Description
RunIndex
int
Index of the text run.
Matrix
ImGearPDFFixedMatrix Class
ImGearPDFFixedMatrix with matrix to set.

Return Value:

None.

See Also:

ImGearPDFFixedMatrix Class


RunSetState Method

32-bit
64-bit
CF
P
P

Description:

Sets the text state of a text run.

Declaration:

public void RunSetState ( int RunIndex , ImageGear.Formats.PDF.ImGearPDETextState TState )

Parameters:

Name
Type
Description
RunIndex
int
Index of the text run.
TState
ImGearPDETextState Class
ImGearPDETextState Class with state to set.

Return Value:

None.

See Also:

ImGearPDETextState Class


RunSetStrokeMatrix Method

32-bit
64-bit
CF
P
P

Description:

Sets the stroke matrix of a text run.

Declaration:

public void RunSetStrokeMatrix ( int RunIndex , ImageGear.Formats.PDF.ImGearPDFFixedMatrix
Matrix )

Parameters:

Name
Type
Description
RunIndex
int
Index of the text run.
Matrix
ImGearPDFFixedMatrix Class
ImGearPDFFixedMatrix Class with store matrix to set.

Return Value:

None.

See Also:

ImGearPDFFixedMatrix Class


SplitRunAt Method

32-bit
64-bit
CF
P
P

Description:

Splits a text run into two text runs.

Declaration:

public void SplitRunAt ( int SplitLoc )

Parameters:

Name
Type
Description
SplitLoc
int
Split location, relative to the text object. The first text run is from character index 0 up to SplitLoc. The second text run is from SplitLoc + 1 to the end of the run.

Return Value:

None.


ImGearPDETextItem Class

32-bit
64-bit
CF
P
P

Description:

The PDE text item object is a PDE element representing a text object.

Declaration:

public sealed class ImGearPDETextItem : ImageGear.Formats.PDF.ImGearPDEElement

Members:

Constructors
Name
Description
ImGearPDETextItem Constructor
Creates new instance of ImGearPDETextItem object.

Properties
Name
Description
TextLength Property
The text length for a text item, in bytes.

Methods
Name
Description
CopyText Method
Copies the text from a text item element.
GetFont Method
Gets the font for a text item.
GetGState Method
Gets the graphics state for a text item.
GetMatrix Method
Gets the text matrix for a character in a text item.
GetState Method
Gets the text state of a text item.
RemoveChars Method
Removes contiguous characters from a text item.
ReplaceChars Method
Replaces characters in a text item.
ReplaceText Method
Replaces all of the text in a text item.
SetFont Method
Sets a font for a text item.
SetGState Method
Sets the graphics state of a text item.
SetMatrix Method
Sets the text matrix for a text item.
SetState Method
Sets the text state of a text item.


ImGearPDETextItem Constructors

The ImGearPDETextItem Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDETextItem Constructor
Creates new instance of ImGearPDETextItem object.


ImGearPDETextItem Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDETextItem object.

Declaration:

public ImGearPDETextItem ( string Text , ImageGear.Formats.PDF.ImGearPDEFont Font ,
ImageGear.Formats.PDF.ImGearPDEGraphicState GState ,
ImageGear.Formats.PDF.ImGearPDETextState TState ,
ImageGear.Formats.PDF.ImGearPDFFixedMatrix TextMatrix )

Parameters:

Name
Type
Description
Text
string
The text string.
Font
ImGearPDEFont Class
The font for a text item.
GState
ImGearPDEGraphicState Class
The graphics state for a text item.
TState
ImGearPDETextState Class
The text state of a text item.
TextMatrix
ImGearPDFFixedMatrix Class
The text matrix for a character in a text item.

Return Value:

The new instance of ImGearPDETextItem Class object.

See Also:

ImGearPDETextItem Class

ImGearPDEFont Class

ImGearPDEGraphicState Class

ImGearPDETextState Class

ImGearPDFFixedMatrix Class


ImGearPDETextItem Properties

The ImGearPDETextItem Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
TextLength Property
The text length for a text item, in bytes.


TextLength Property

32-bit
64-bit
CF
P
P

Description:

The text length for a text item, in bytes.

Declaration:

public int TextLength { get }

Value:

Integer number.

Default value:

N/A


ImGearPDETextItem Methods

The ImGearPDETextItem Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
CopyText Method
Copies the text from a text item element.
GetFont Method
Gets the font for a text item.
GetGState Method
Gets the graphics state for a text item.
GetMatrix Method
Gets the text matrix for a character in a text item.
GetState Method
Gets the text state of a text item.
RemoveChars Method
Removes contiguous characters from a text item.
ReplaceChars Method
Replaces characters in a text item.
ReplaceText Method
Replaces all of the text in a text item.
SetFont Method
Sets a font for a text item.
SetGState Method
Sets the graphics state of a text item.
SetMatrix Method
Sets the text matrix for a text item.
SetState Method
Sets the text state of a text item.


CopyText Method

32-bit
64-bit
CF
P
P

Description:

Copies the text from a text item element.

Declaration:

public string CopyText (  )

Return Value:

Text string.


GetFont Method

32-bit
64-bit
CF
P
P

Description:

Gets the font for a text item.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEFont GetFont (  )

Return Value:

ImGearPDEFont Class object.

See Also:

ImGearPDEFont Class


GetGState Method

32-bit
64-bit
CF
P
P

Description:

Gets the graphics state for a text item.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEGraphicState GetGState (  )

Return Value:

ImGearPDEGraphicState Class object.

See Also:

ImGearPDEGraphicState Class


GetMatrix Method

32-bit
64-bit
CF
P
P

Description:

Gets the text matrix for a character in a text item.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFFixedMatrix GetMatrix ( int CharOffset )

Parameters:

Name
Type
Description
CharOffset
int
The offset of the character whose text matrix is obtained.

Return Value:

ImGearPDFFixedMatrix Class object.

See Also:

ImGearPDFFixedMatrix Class


GetState Method

32-bit
64-bit
CF
P
P

Description:

Gets the text state of a text item.

Declaration:

public ImageGear.Formats.PDF.ImGearPDETextState GetState (  )

Return Value:

ImGearPDETextState Class object.

See Also:

ImGearPDETextState Class


RemoveChars Method

32-bit
64-bit
CF
P
P

Description:

Removes contiguous characters from a text item.

Declaration:

public void RemoveChars ( int CharOffset , int Count )

Parameters:

Name
Type
Description
CharOffset
int
Offset of the first character to remove.
Count
int
The number of characters to remove.

Return Value:

None.


ReplaceChars Method

32-bit
64-bit
CF
P
P

Description:

Replaces characters in a text item.

This method does not change the number of characters in the text item-extra characters are ignored.

Declaration:

public void ReplaceChars ( int CharIndex , string Text )

Parameters:

Name
Type
Description
CharIndex
int
Index position of the characters to replace.
Text
string
Replacement text.

Return Value:

None.


ReplaceText Method

32-bit
64-bit
CF
P
P

Description:

Replaces all of the text in a text item.

Declaration:

public void ReplaceText ( string Text )

Parameters:

Name
Type
Description
Text
string
Replacement text.

Return Value:

None.


SetFont Method

32-bit
64-bit
CF
P
P

Description:

Sets a font for a text item.

Declaration:

public void SetFont ( ImageGear.Formats.PDF.ImGearPDEFont Font )

Parameters:

Name
Type
Description
Font
ImGearPDEFont Class
Font set for a text item.

Return Value:

None.

See Also:

ImGearPDEFont Class


SetGState Method

32-bit
64-bit
CF
P
P

Description:

Sets the graphics state of a text item.

Declaration:

public void SetGState ( ImageGear.Formats.PDF.ImGearPDEGraphicState GState )

Parameters:

Name
Type
Description
GState
ImGearPDEGraphicState Class
The graphics state information to set.

Return Value:

None.

See Also:

ImGearPDEGraphicState Class


SetMatrix Method

32-bit
64-bit
CF
P
P

Description:

Sets the text matrix for a text item.

Declaration:

public void SetMatrix ( ImageGear.Formats.PDF.ImGearPDFFixedMatrix Matrix )

Parameters:

Name
Type
Description
Matrix
ImGearPDFFixedMatrix Class
The new text matrix of the text item.

Return Value:

None.

See Also:

ImGearPDFFixedMatrix Class


SetState Method

32-bit
64-bit
CF
P
P

Description:

Sets the text state of a text item.

Declaration:

public void SetState ( ImageGear.Formats.PDF.ImGearPDETextState TState )

Parameters:

Name
Type
Description
TState
ImGearPDETextState Class
With new text state of the text item.

Return Value:

None.

See Also:

ImGearPDETextState Class


ImGearPDETextState Class

32-bit
64-bit
CF
P
P

Description:

Attributes of a PDE text element.

Declaration:

public sealed class ImGearPDETextState

Members:

Constructors
Name
Description
ImGearPDETextState Constructor
Creates new instance of ImGearPDETextState object.

Properties
Name
Description
CharSpacing Property
Character spacing was set, corresponding to the Tc operator.
FontSize Property
Font size.
RenderMode Property
Text rendering mode, corresponding to the Tr operator.
Scale Property
Scale in percents.
TextRise Property
Specifies the distance, in text space units that are not scaled, to move the baseline up or down from its default location.
WasSetFlags Property
Indicates if an attribute has been set.
WordSpacing Property
Word spacing, corresponding to the Tw operator.


ImGearPDETextState Constructors

The ImGearPDETextState Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDETextState Constructor
Creates new instance of ImGearPDETextState object.


ImGearPDETextState Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDETextState Class object.

Declaration:

public ImGearPDETextState (  )

Return Value:

The new instance of ImGearPDETextState Class object.

See Also:

ImGearPDETextState Class


ImGearPDETextState Properties

The ImGearPDETextState Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
CharSpacing Property
Character spacing was set, corresponding to the Tc operator.
FontSize Property
Font size.
RenderMode Property
Text rendering mode, corresponding to the Tr operator.
Scale Property
Scale in percents.
TextRise Property
Specifies the distance, in text space units that are not scaled, to move the baseline up or down from its default location.
WasSetFlags Property
Indicates if an attribute has been set.
WordSpacing Property
Word spacing, corresponding to the Tw operator.


CharSpacing Property

32-bit
64-bit
CF
P
P

Description:

Character spacing was set, corresponding to the Tc operator.

Declaration:

public int CharSpacing { get, set }

Value:

Integer number.

Default value:

0


FontSize Property

32-bit
64-bit
CF
P
P

Description:

Font size.

Declaration:

public int FontSize { get, set }

Value:

Integer number.

Default value:

1


RenderMode Property

32-bit
64-bit
CF
P
P

Description:

Text rendering mode, corresponding to the Tr operator.

Declaration:

public int RenderMode { get, set }

Value:

Integer number.

Default value:

0


Scale Property

32-bit
64-bit
CF
P
P

Description:

Scale in percents.

Declaration:

public int Scale { get, set }

Value:

Integer number.

Default value:

100


TextRise Property

32-bit
64-bit
CF
P
P

Description:

Specifies the distance, in text space units that are not scaled, to move the baseline up or down from its default location. See Section 5.2.6 in the PDF Reference.

Declaration:

public int TextRise { get, set }

Value:

Integer number.

Default value:

0


WordSpacing Property

32-bit
64-bit
CF
P
P

Description:

Word spacing, corresponding to the Tw operator.

Declaration:

public int WordSpacing { get, set }

Value:

Integer number.

Default value:

0


ImGearPDEXGroup Class

32-bit
64-bit
CF
P
P

Description:

The PDE XGroup object is a transparency (XGroup) resource.

Declaration:

public sealed class ImGearPDEXGroup : ImageGear.Formats.PDF.ImGearPDEElement

Members:

Constructors
Name
Description
ImGearPDEXGroup Constructor
Creates new instance of ImGearPDEXGroup object.

Properties
Name
Description
Isolated Property
The XGroup isolated boolean value.
Knockout Property
The knockout boolean value of the transparency group.

Methods
Name
Description
GetColorSpace Method
Acquires the color space of the transparency group.
SetColorSpace Method
Sets the color space for the XGroup.


ImGearPDEXGroup Constructors

The ImGearPDEXGroup Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEXGroup Constructor
Creates new instance of ImGearPDEXGroup object.


ImGearPDEXGroup Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDEXGroup object.

Declaration:

public ImGearPDEXGroup ( ImageGear.Formats.PDF.ImGearPDFDocument Doc ,
ImageGear.Formats.PDF.ImGearPDEXGroupCreateFlags Flags )

Parameters:

Name
Type
Description
Doc
ImGearPDFDocument Class
The document the object will be created in.
Flags
ImGearPDEXGroupCreateFlags Enumeration
enumImGearPDEXGroupCreateFlags value.

Return Value:

The new instance of ImGearPDEXGroup Class object.

See Also:

ImGearPDEXGroup Class

ImGearPDFDocument Class

ImGearPDEXGroupCreateFlags Enumeration


ImGearPDEXGroup Properties

The ImGearPDEXGroup Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
Isolated Property
The XGroup isolated boolean value.
Knockout Property
The knockout boolean value of the transparency group.


Isolated Property

32-bit
64-bit
CF
P
P

Description:

The XGroup isolated boolean value. Corresponds to the /I key within the XGroup's dictionary.

Declaration:

public bool Isolated { get, set }

Value:

True, False.

Default value:

N/A


Knockout Property

32-bit
64-bit
CF
P
P

Description:

The knockout boolean value of the transparency group.

Declaration:

public bool Knockout { get, set }

Value:

True, False.

Default value:

N/A


ImGearPDEXGroup Methods

The ImGearPDEXGroup Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
GetColorSpace Method
Acquires the color space of the transparency group.
SetColorSpace Method
Sets the color space for the XGroup.


GetColorSpace Method

32-bit
64-bit
CF
P
P

Description:

Acquires the color space of the transparency group.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEColorSpace GetColorSpace (  )

Return Value:

ImGearPDEColorSpace Class object.

See Also:

ImGearPDEColorSpace Class


SetColorSpace Method

32-bit
64-bit
CF
P
P

Description:

Sets the color space for the XGroup.

Declaration:

public void SetColorSpace ( ImageGear.Formats.PDF.ImGearPDEColorSpace ColorSpace )

Parameters:

Name
Type
Description
ColorSpace
ImGearPDEColorSpace Class
The color space to associate with the XGroup.

Return Value:

None.

See Also:

ImGearPDEColorSpace Class


ImGearPDEXObject Class

32-bit
64-bit
CF
P
P

Description:

XObject - an element representing an arbitrary XObject.

Declaration:

public sealed class ImGearPDEXObject : ImageGear.Formats.PDF.ImGearPDEElement

Members:

Constructors
Name
Description
ImGearPDEXObject Constructor
Creates new instance of XObject.


ImGearPDEXObject Constructors

The ImGearPDEXObject Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEXObject Constructor
Creates new instance of XObject.


ImGearPDEXObject Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDEXObject object.

Declaration:

public ImGearPDEXObject ( ImageGear.Formats.PDF.ImGearPDFBasObj BaseObject )

Parameters:

Name
Type
Description
BaseObject
ImGearPDFBasObj Class
Base PDF object.

Return Value:

The new instance of ImGearPDEXObject Class object.

See Also:

ImGearPDEXObject Class

ImGearPDFBasObj Class


ImGearPDEXYZColor Class

32-bit
64-bit
CF
P
P

Description:

XYZ color data.

Declaration:

public sealed class ImGearPDEXYZColor

Members:

Constructors
Name
Description
ImGearPDEXYZColor Constructor
Creates new instance of ImGearPDEXYZColor object.

Properties
Name
Description
X Property
X value.
Y Property
Y value.
Z Property
Z value.


ImGearPDEXYZColor Constructors

The ImGearPDEXYZColor Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDEXYZColor Constructor
Creates new instance of ImGearPDEXYZColor object.


ImGearPDEXYZColor Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDEXYZColor Class object.

Declaration:

public ImGearPDEXYZColor (  )

Return Value:

The new instance of ImGearPDEXYZColor Class object.

See Also:

ImGearPDEXYZColor Class


ImGearPDEXYZColor Properties

The ImGearPDEXYZColor Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
X Property
X value.
Y Property
Y value.
Z Property
Z value.


X Property

32-bit
64-bit
CF
P
P

Description:

X value.

Declaration:

public float X { get, set }

Value:

Float value

Default value:

0

See Also:

ImGearPDEXYZColor Class


Y Property

32-bit
64-bit
CF
P
P

Description:

Y value.

Declaration:

public float Y { get, set }

Value:

Float value.

Default value:

0

See Also:

ImGearPDEXYZColor Class


Z Property

32-bit
64-bit
CF
P
P

Description:

Z value.

Declaration:

public float Z { get, set }

Value:

Float value.

Default value:

0

See Also:

ImGearPDEXYZColor Class


ImGearPDF Class

32-bit
64-bit
CF
P
P

Description:

Core PDF class is used to create, initialize and terminate PDF and PS formats and provides general functionality.

Declaration:

public sealed class ImGearPDF

Members:

Constructors
Name
Description
ImGearPDF Constructor
Creates new instance of ImGearPDF object.

Properties
Name
Description
HostEncoding Property
Indicates what kind of host encoding a system uses.

Methods
Name
Description
CreatePDFFormat Method
Creates an instance of PDF format.
CreatePDFFormat Method
Creates an instance of PDF format.
CreatePSFormat Method
Creates an instance of PS format.
CreatePSFormat Method
Creates an instance of PS format.
DoubleToFixed Method
Converts DoubleValue to a PDF fixed value and returns it.
FixedRoundToInt Method
Converts FixedValue to an integer, rounding it to the nearest integer value and returns it.
FixedRoundToShort Method
Converts FixedValue to an integer.
FixedToDouble Method
Converts FixedValue to a double value and returns it.
FixedTruncToInt Method
Converts FixedValue to an integer, truncating it to the next lower integer value and returns it.
FixedTruncToShort Method
Converts FixedValue to an integer, truncating it to the next lower short integer value and returns it.
GetDefaultGraphicState Method
Gets default graphic state attributes.
Initialize Method
Initializes PDF and PS libraries.
Initialize Method
Initializes PDF and PS libraries.
IntToFixed Method
Converts IntValue to a PDF fixed value and returns it.
ShortToFixed Method
Converts ShortValue to a PDF fixed value and returns it.
Terminate Method
Terminates PDF and PS libraries.

Initialization

ImageGear PDF namespace includes two filters: PDF and PS. To enable those filters use:

    ImGearFileFormats.Add(ImGearPDF.CreatePDFFormat());
    ImGearFileFormats.Add(ImGearPDF.CreatePSFormat());
ImGearPDF.Initialize();

The following resource content is required by the ImageGear PDF initialization routine.

  • Resource\PDF\CIDFont\ - PDF CID fonts directory
  • Resource\PDF\CMap\ - PDF font CMaps directory
  • Resource\PDF\Font\ - PDF fonts directory
  • Resource\PS\ColorRendering\ - color rendering PostScript
  • Resource\PS\ICCProfiles\ - Directory containing the ICC profiles that allow using the Adobe Color Engine (ACE)
  • Resource\PS\Fonts\ - PS fonts directory
  • Resource\PS\ProcSet\ - PostScript procedures
  • Resource\PS\ps.vm - a file for initialization the PostScript Interpreter's virtual memory.
  • Resource\PS\startupNORM.ps - startup PostScript program is used to initialize the PostScript Interpreter.
  • Resource\PS\superatm.db - Adobe® Type Manager® (ATM®) database is used to substitute missing fonts.

Termination

PDF and PS libraries must be terminated when the application dispose method is called.

Example:

    protected override void Dispose(bool disposing)
    {
        if (disposing)
        {
            if (components != null)
            {
                components.Dispose();
            }

            // Disposing objects
            ...

            // Terminating PDF and PS libraries.
ImGearPDF.Terminate();
        }
        base.Dispose(disposing);
    }


ImGearPDF Constructors

The ImGearPDF Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDF Constructor
Creates new instance of ImGearPDF object.


ImGearPDF Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDF Class object.

Declaration:

public ImGearPDF (  )

Return Value:

The new instance of ImGearPDF Class object.

See Also:

ImGearPDF Class


ImGearPDF Properties

The ImGearPDF Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
HostEncoding Property
Indicates what kind of host encoding a system uses.


HostEncoding Property

32-bit
64-bit
CF
P
P

Description:

Indicates what kind of host encoding a system uses. Allows you to determine whether a system is Roman or non-Roman. (Non-Roman is also known as CJK-capable, that is, capable of handling multi-byte character sets, such as Chinese, Japanese, or Korean.)

Host encoding is a platform-dependent encoding for the host machine. It is WinAnsiEncoding in Windows.

For non-Roman systems, the host encoding may be a variety of encodings, which are defined by a CMap (character map). See Section 5.6.4 in the PDF Reference for a list of predefined CMaps.

Use HostEncoding to determine if a system's host encoding is Roman or not. 0 for a Roman system; nonzero for a non-Roman system. Users should simply test whether this value is 0 or not.

Declaration:

public int HostEncoding { get }

Value:

Integer value.

Default value:

N/A

See Also:

ImGearPDF Class


ImGearPDF Methods

The ImGearPDF Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
CreatePDFFormat Method
Creates an instance of PDF format.
CreatePDFFormat Method
Creates an instance of PDF format.
CreatePSFormat Method
Creates an instance of PS format.
CreatePSFormat Method
Creates an instance of PS format.
DoubleToFixed Method
Converts DoubleValue to a PDF fixed value and returns it.
FixedRoundToInt Method
Converts FixedValue to an integer, rounding it to the nearest integer value and returns it.
FixedRoundToShort Method
Converts FixedValue to an integer.
FixedToDouble Method
Converts FixedValue to a double value and returns it.
FixedTruncToInt Method
Converts FixedValue to an integer, truncating it to the next lower integer value and returns it.
FixedTruncToShort Method
Converts FixedValue to an integer, truncating it to the next lower short integer value and returns it.
GetDefaultGraphicState Method
Gets default graphic state attributes.
Initialize Method
Initializes PDF and PS libraries.
Initialize Method
Initializes PDF and PS libraries.
IntToFixed Method
Converts IntValue to a PDF fixed value and returns it.
ShortToFixed Method
Converts ShortValue to a PDF fixed value and returns it.
Terminate Method
Terminates PDF and PS libraries.


CreatePDFFormat Method

32-bit
64-bit
CF
P
P

Description:

This method creates an instance of PDF format.

Declaration:

public static ImageGear.Formats.IImGearFormat CreatePDFFormat ( )

Return value:

New instance of PDF format.

See Also:

ImGearPDF Class

IImGearFormat Interface


CreatePDFFormat Method

32-bit
64-bit
CF
P
P

Description:

This method creates an instance of PDF format. LibraryPath parameter specifies a folder path to load PDF native code libraries from.

If LibraryPath is blank than the current directory is used.

Declaration:

public static ImageGear.Formats.IImGearFormat CreatePDFFormat(string LibraryPath)

Parameters:

Name
Type
Description
LibraryPath
string
Path to load PDF native libraries from.

Return value:

New instance of PDF format.

See Also:

ImGearPDF Class

IImGearFormat Interface


CreatePSFormat Method

32-bit
64-bit
CF
P
P

Description:

This method creates an instance of PostScript format.

NOTE: ImageGear cannot initialize PS support more than once.

PS support requires that calls such as

ImGearFileFormats.Filters.Add(ImGearPDF.CreatePDFFormat(  Path  ));
ImGearFileFormats.Filters.Add(ImGearPDF.CreatePSFormat( Path ));

both be made before the call

ImGearPDF.Initialize( Path );

Declaration:

public static ImageGear.Formats.IImGearFormat CreatePSFormat ( )

Return value:

New instance of PostScript format.

See Also:

ImGearPDF Class

IImGearFormat Interface


CreatePSFormat Method

32-bit
64-bit
CF
P
P

Description:

This method creates an instance of PS format. LibraryPath parameter specifies a folder path to load PS native code libraries from.

If LibraryPath is blank than the current directory is used.

NOTE: ImageGear cannot initialize PS support more than once.

PS support requires that calls such as

ImGearFileFormats.Filters.Add(ImGearPDF.CreatePDFFormat(  Path  ));
ImGearFileFormats.Filters.Add(ImGearPDF.CreatePSFormat( Path ));

both be made before the call

ImGearPDF.Initialize( Path );

Declaration:

public static ImageGear.Formats.IImGearFormat CreatePSFormat(string LibraryPath)

Parameters:

Name
Type
Description
LibraryPath
string
Path to load PS native libraries from.

Return value:

New instance of PS format.

See Also:

ImGearPDF Class

IImGearFormat Interface


DoubleToFixed Method

32-bit
64-bit
CF
P
P

Description:

Converts DoubleValue to a PDF fixed value and returns it.

Declaration:

public static int DoubleToFixed ( double DoubleValue )

Parameters:

Name
Type
Description
DoubleValue
double
Double value to be converted to fixed.

Return Value:

PDF fixed value.

See Also:

ImGearPDF Class


FixedRoundToInt Method

32-bit
64-bit
CF
P
P

Description:

Converts FixedValue to an integer, rounding it to the nearest integer value and returns it.

Declaration:

public static int FixedRoundToInt ( int FixedValue )

Parameters:

Name
Type
Description
FixedValue
int
Fixed value to be converted.

Return Value:

Integer value

See Also:

ImGearPDF Class


FixedRoundToShort Method

32-bit
64-bit
CF
P
P

Description:

Converts FixedValue to an integer, rounding it to the nearest short integer value and returns it.

Declaration:

public static short FixedRoundToShort ( int FixedValue )

Parameters:

Name
Type
Description
ColorSpace
int
Fixed value to be converted.

Return Value:

Short integer value.

See Also:

ImGearPDF Class


FixedToDouble Method

32-bit
64-bit
CF
P
P

Description:

Converts FixedValue to a double value and returns it.

Declaration:

public static double FixedToDouble ( int FixedValue )

Parameters:

Name
Type
Description
FixedValue
int
Fixed value to be converted.

Return Value:

Double value

See Also:

ImGearPDF Class


FixedTruncToInt Method

32-bit
64-bit
CF
P
P

Description:

Converts FixedValue to an integer, truncating it to the next lower integer value and returns it.

Declaration:

public static int FixedTruncToInt ( int FixedValue )

Parameters:

Name
Type
Description
FixedValue
int
Fixed value to be converted.

Return Value:

Integer value.

See Also:

ImGearPDF Class


FixedTruncToShort Method

32-bit
64-bit
CF
P
P

Description:

Converts FixedValue to an integer, truncating it to the next lower short integer value and returns it.

Declaration:

public static short FixedTruncToShort ( int nFixedValue )

Parameters:

Name
Type
Description
nFixedValue
int
Fixed value to be converted.

Return Value:

Short integer value.

See Also:

ImGearPDF Class


GetDefaultGraphicState Method

32-bit
64-bit
CF
P
P

Description:

Gets default graphic state attributes.

Declaration:

public static ImageGear.Formats.PDF.ImGearPDEGraphicState GetDefaultGraphicState (  )

Return Value:

ImGearPDEGraphicState Class object.

See Also:

ImGearPDEGraphicState Class


Initialize Method

32-bit
64-bit
CF
P
P

Description:

Initializes PDF and PS libraries. This initialization method must be called for each thread in the multi-threaded application.

Example:

ImGearPDF.Initialize ("C:\\Program Files\\AccuSoft\\ImageGear.NET\\Bin\\")
NOTE: ImageGear cannot initialize PS support more than once.

PS support requires that calls such as

ImGearFileFormats.Filters.Add(ImGearPDF.CreatePDFFormat(  Path  ));
ImGearFileFormats.Filters.Add(ImGearPDF.CreatePSFormat( Path ));

both be made before the call

ImGearPDF.Initialize( Path );

Declaration:

public static void Initialize ( string PathToResourse )

Parameters:

Name
Type
Description
PathToResourse
string
Path to PDF/PS library.

Return Value:

None.

See Also:

ImGearPDF Class

Terminate Method

Using PDF from Multiple Threads


Initialize Method

32-bit
64-bit
CF
P
P

Description:

Initializes PDF and PS libraries. This initialization method must be called for each thread in the multi-threaded application.

The resource content must be located in the same to ImageGear assembly place.

NOTE: ImageGear cannot initialize PS support more than once.

PS support requires that calls such as

ImGearFileFormats.Filters.Add(ImGearPDF.CreatePDFFormat(  Path  ));
ImGearFileFormats.Filters.Add(ImGearPDF.CreatePSFormat( Path ));

both be made before the call

ImGearPDF.Initialize( Path );

Declaration:

public static void Initialize (  )

Return Value:

None.

See Also:

ImGearPDF Class

Terminate Method

Using PDF from Multiple Threads


IntToFixed Method

32-bit
64-bit
CF
P
P

Description:

Converts IntValue to a PDF fixed value and returns it.

Declaration:

public static int IntToFixed ( int IntValue )

Parameters:

Name
Type
Description
IntValue
int
Integer value to be converted.

Return Value:

PDF fixed value.

See Also:

ImGearPDF Class


ShortToFixed Method

32-bit
64-bit
CF
P
P

Description:

Converts ShortValue to a PDF fixed value and returns it.

Declaration:

public static int ShortToFixed ( short ShortValue )

Parameters:

Name
Type
Description
ShortValue
short
Short value to be converted.

Return Value:

PDF fixed value.

See Also:

ImGearPDF Class


Terminate Method

32-bit
64-bit
CF
P
P

Description:

Terminates PDF and PS libraries. Must be paired with Initialize() method. Call this method when the application is disposed.

NOTE: ImageGear cannot initialize PS support more than once.

Declaration:

public static void Terminate (  )

Return Value:

None.

See Also:

ImGearPDF Class

Initialize Method

Initialize Method

Using PDF from Multiple Threads


ImGearPDFAction Class

32-bit
64-bit
CF
P
P

Description:

This is a task that performs when a user clicks on a link or a bookmark. Action types include:

  • Going to another view within the same document
  • Going to a specified view in another PDF file
  • Launching an arbitrary file
  • Resolving a URL

See Section 8.5 in the PDF Reference for more information on actions.

Declaration:

public sealed class ImGearPDFAction : ImageGear.Formats.PDF.ImGearPDFObject

Members:

Constructors
Name
Description
ImGearPDFAction Constructor
Creates new instance of ImGearPDFAction object.
ImGearPDFAction Constructor
Creates new instance of ImGearPDFAction object.
ImGearPDFAction Constructor
Creates new instance of ImGearPDFAction object.

Properties
Name
Description
Type Property
Action type.

Methods
Name
Description
GetDestination Method
Gets the action's destination view.
GetDictionary Method
Gets the dictionary corresponding to the action.
GetFileName Method
Gets a file name from the action.


ImGearPDFAction Constructors

The ImGearPDFAction Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDFAction Constructor
Creates new instance of ImGearPDFAction object.
ImGearPDFAction Constructor
Creates new instance of ImGearPDFAction object.
ImGearPDFAction Constructor
Creates new instance of ImGearPDFAction object.


ImGearPDFAction Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates an action of the specified type from a file name.

Declaration:

public ImGearPDFAction ( ImageGear.Formats.PDF.ImGearPDFDocument Doc ,
ImageGear.Formats.PDF.ImGearPDFAtom Type , string FileName )

Parameters:

Name
Type
Description
Doc
ImGearPDFDocument Class
PDF document.
Type
ImGearPDFAtom Class
PDF atom type.
FileName
string
The file name.

Return Value:

The new instance of ImGearPDFAction Class object.

See also:

ImGearPDFAction Class

ImGearPDFDocument Class

ImGearPDFAtom Class


ImGearPDFAction Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new action that takes the user to the specified destination view. This method can only be used for destinations in the same document as the source document. Cross-document links must be built up from the base level, populating the Action dictionary for the GotoR action as described in Section 8.5.3 in the PDF Reference.

Declaration:

public ImGearPDFAction ( ImageGear.Formats.PDF.ImGearPDFDocument Doc ,
ImageGear.Formats.PDF.ImGearPDFDestination Dest )

Parameters:

Name
Type
Description
Doc
ImGearPDFDocument Class
PDF document.
Dest
ImGearPDFDestination Class
Destination.

Return Value:

The new instance of ImGearPDFAction Class object.

See also:

ImGearPDFAction Class

ImGearPDFDocument Class

ImGearPDFDestination Class


ImGearPDFAction Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDFAction object.

Declaration:

public ImGearPDFAction ( ImageGear.Formats.PDF.ImGearPDFDocument Doc ,
ImageGear.Formats.PDF.ImGearPDFAtom Type )

Parameters:

Name
Type
Description
Doc
ImGearPDFDocument Class
PDF document.
Type
ImGearPDFAtom Class
PDF atom type.

Return Value:

The new instance of ImGearPDFAction Class object.

See also:

ImGearPDFAction Class

ImGearPDFDocument Class

ImGearPDFAtom Class


ImGearPDFAction Properties

The ImGearPDFAction Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
Type Property
Action type.


Type Property

32-bit
64-bit
CF
P
P

Description:

Determines the action's type.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom Type { get }

Value:

The atom corresponding to the action's type.

Default value:

N/A

See also:

ImGearPDFAction Class

ImGearPDFAtom Class


ImGearPDFAction Methods

The ImGearPDFAction Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
GetDestination Method
Gets the action's destination view.
GetDictionary Method
Gets the dictionary corresponding to the action.
GetFileName Method
Gets a file name from the action.


GetDestination Method

32-bit
64-bit
CF
P
P

Description:

Gets the action's destination view. This only works for actions that contain a view destination - that is, actions whose type is GoTo. For named destinations, this method may return a basic string or name object. See Section 8.2.1 in the PDF Reference for more information on named destinations.

NOTE: Since this method may not return an explicit destination, use the ImGearPDFDestination.Resolve on the returned value to obtain an explicit destination.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFDestination GetDestination (  )

Return Value:

The action's destination, which may be either an explicit or named (basic string or name object). Use the ImGearPDFDestination.Resolve on this returned value to obtain an explicit destination.

See also:

ImGearPDFAction Class

ImGearPDFDestination Class


GetDictionary Method

32-bit
64-bit
CF
P
P

Description:

Gets the dictionary corresponding to the action.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFBasDict GetDictionary (  )

Return Value:

Dictionary object for the action.

See also:

ImGearPDFAction Class

ImGearPDFBasDict Class


GetFileName Method

32-bit
64-bit
CF
P
P

Description:

Gets a file name from the action. Not all types of actions have file names; this method only works for actions that contain a file specification. See Section 8.5 in the PDF Reference for more information on the contents of various types of actions.

Declaration:

public string GetFileName (  )

Return Value:

The action's file name.

See also:

ImGearPDFAction Class


ImGearPDFAtom Class

32-bit
64-bit
CF
P
P

Description:

A hashed token used in place of strings to optimize performance (it is much faster to compare Atoms than strings).

Declaration:

public class ImGearPDFAtom : ImageGear.Formats.PDF.ImGearPDFObject

Members:

Constructors
Name
Description
ImGearPDFAtom Constructor
Creates new instance of ImGearPDFAtom object.
ImGearPDFAtom Constructor
Creates new instance of ImGearPDFAtom object.

Properties
Name
Description
String Property
The string corresponding to the atom.


ImGearPDFAtom Constructors

The ImGearPDFAtom Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDFAtom Constructor
Creates new instance of ImGearPDFAtom object.
ImGearPDFAtom Constructor
Creates new instance of ImGearPDFAtom object.


ImGearPDFAtom Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDFAtom Class object.

Declaration:

public ImGearPDFAtom ( )

Return Value:

The new instance of ImGearPDFAtom Class object.

See Also:

ImGearPDFAtom Class


ImGearPDFAtom Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates new instance of ImGearPDFAtom object.

Declaration:

public ImGearPDFAtom ( string str )

Parameters:

Name
Type
Description
str
string
The string corresponding to the atom.

Return Value:

The new instance of ImGearPDFAtom Class object.

See Also:

ImGearPDFAtom Class


ImGearPDFAtom Properties

The ImGearPDFAtom Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
String Property
The string corresponding to the atom.


String Property

32-bit
64-bit
CF
P
P

Description:

The string corresponding to the atom.

Declaration:

public string String { get, set }

Value:

String

See Also:

ImGearPDFAtom Class


ImGearPDFBasArray Class

32-bit
64-bit
CF
P
P

Description:

An array object is a one-dimensional collection of objects arranged sequentially. Unlike arrays in many other computer languages, PDF arrays may be heterogeneous; that is, an array's elements may be any combination of numbers, strings, dictionaries, or any other objects, including other arrays.

Declaration:

public sealed class ImGearPDFBasArray : ImageGear.Formats.PDF.ImGearPDFBasObj

Members:

Constructors
Name
Description
ImGearPDFBasArray Constructor
Creates a new array object associated with the specified document and with the specified value.

Properties
Name
Description
Length Property
The number of elements in the array.

Methods
Name
Description
Get Method
Gets the specified element from an array.
Put Method
Puts the specified object into the specified location in an array.
PutBool Method
Puts the specified boolean value into the specified location in an array.
PutFixed Method
Puts the specified fixed value into the specified location in an array.
PutInt Method
Puts the specified integer value into the specified location in an array.
PutName Method
Puts the name integer value into the specified location in an array.
Remove Method
Finds the first element, if any, equal to the specified object and removes it from the array.
RemoveAt Method
Checks whether the position is within the array bounds and then removes it from the array and moves each subsequent element to the slot with the next smaller index and decrements the array's length by 1.


ImGearPDFBasArray Constructors

The ImGearPDFBasArray Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDFBasArray Constructor
Creates a new array object associated with the specified document and with the specified value.


ImGearPDFBasArray Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new array object associated with the specified document and with the specified value.

Declaration:

public ImGearPDFBasArray ( ImageGear.Formats.PDF.ImGearPDFDocument Doc , bool Indirect ,
uint Entries )

Parameters:

Name
Type
Description
Doc
ImGearPDFDocument Class
The document in which the array is used.
Indirect
bool
If True, creates the array as an indirect object. If False, creates the array as a direct object.
Entries
uint
Number of entries in the array. This value is only a hint - the arrays grow dynamically as needed.

Return Value:

The new instance of ImGearPDFBasArray Class object.

See Also:

ImGearPDFBasArray Class

ImGearPDFDocument Class


ImGearPDFBasArray Properties

The ImGearPDFBasArray Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
Length Property
The number of elements in the array.


Length Property

32-bit
64-bit
CF
P
P

Description:

The number of elements in the array.

Declaration:

public int Length { get }

Value:

Integer number.


ImGearPDFBasArray Methods

The ImGearPDFBasArray Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
Get Method
Gets the specified element from an array.
Put Method
Puts the specified object into the specified location in an array.
PutBool Method
Puts the specified boolean value into the specified location in an array.
PutFixed Method
Puts the specified fixed value into the specified location in an array.
PutInt Method
Puts the specified integer value into the specified location in an array.
PutName Method
Puts the name integer value into the specified location in an array.
Remove Method
Finds the first element, if any, equal to the specified object and removes it from the array.
RemoveAt Method
Checks whether the position is within the array bounds and then removes it from the array and moves each subsequent element to the slot with the next smaller index and decrements the array's length by 1.


Get Method

32-bit
64-bit
CF
P
P

Description:

Gets the specified element from an array.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFBasObj Get ( uint Index )

Parameters:

Name
Type
Description
Index
uint
Index of an element to get. The first element in an array has an index of zero.

Return Value:

The basic object occupying the Index element of array. Returns NULL object if index is outside the array bounds.

See Also:

ImGearPDFBasObj Class


Put Method

32-bit
64-bit
CF
P
P

Description:

Puts the specified object into the specified location in an array. The array is extended as much as necessary.

Declaration:

public void Put ( ImageGear.Formats.PDF.ImGearPDFAtom Key ,
ImageGear.Formats.PDF.ImGearPDFBasObj Value )

Parameters:

Name
Type
Description
Key
ImGearPDFAtom Class
The location in array to store an object. The first element of an array has an index of zero.
Value
ImGearPDFBasObj Class
The object to insert into array.

Return Value:

None.

See Also:

ImGearPDFAtom Class

ImGearPDFBasObj Class


PutBool Method

32-bit
64-bit
CF
P
P

Description:

Puts the specified boolean value into the specified location in an array. The array is extended as much as necessary.

Declaration:

public void PutBool ( ImageGear.Formats.PDF.ImGearPDFAtom Key , bool Indirect , bool Value
)

Parameters:

Name
Type
Description
Key
ImGearPDFAtom Class
The location in array to store a value. The first element of an array has an index of zero.
Indirect
bool
If true, creates the key value as an indirect object. If false, creates the key value as a direct object.
Value
bool
The integer value to insert into array.

Return Value:

None

See Also:

ImGearPDFAtom Class


PutFixed Method

32-bit
64-bit
CF
P
P

Description:

Puts the specified fixed value into the specified location in an array. The array is extended as much as necessary.

Declaration:

public void PutFixed ( ImageGear.Formats.PDF.ImGearPDFAtom Key , bool Indirect , int
FixedValue )

Parameters:

Name
Type
Description
Key
ImGearPDFAtom Class
The location in array to store a value. The first element of an array has an index of zero.
Indirect
bool
If true, creates the key value as an indirect object. If false, creates the key value as a direct object.
FixedValue
int
Fixed value to put in the array.

Return Value:

None

See Also:

ImGearPDFAtom Class


PutInt Method

32-bit
64-bit
CF
P
P

Description:

Puts the specified integer value into the specified location in an array. The array is extended as much as necessary.

Declaration:

public void PutInt ( int nIndex , bool Indirect , int Value )

Parameters:

Name
Type
Description
nIndex
int
The location in array to store a value. The first element of an array has an index of zero.
Indirect
bool
If true, creates the key value as an indirect object. If false, creates the key value as a direct object.
Value
int
Integer value to put in the array.

Return Value:

None

See Also:

ImGearPDFBasArray Class


PutName Method

32-bit
64-bit
CF
P
P

Description:

Puts the name integer value into the specified location in an array. The array is extended as much as necessary.

Declaration:

public void PutName ( ImageGear.Formats.PDF.ImGearPDFAtom Key , bool Indirect ,
ImageGear.Formats.PDF.ImGearPDFAtom Name )

Parameters:

Name
Type
Description
Key
ImGearPDFAtom Class
The location in array to store a value. The first element of an array has an index of zero.
Indirect
bool
If true, creates the key value as an indirect object. If false, creates the key value as a direct object.
Name
ImGearPDFAtom Class
Name integer value to put in the array.

Return Value:

None

See Also:

ImGearPDFAtom Class


Remove Method

32-bit
64-bit
CF
P
P

Description:

Finds the first element, if any, equal to the specified object and removes it from the array.

Declaration:

public void Remove ( ImageGear.Formats.PDF.ImGearPDFBasObj Object )

Parameters:

Name
Type
Description
Object
ImGearPDFBasObj Class
The object to remove.

Return Value:

None

See Also:

ImGearPDFBasObj Class


RemoveAt Method

32-bit
64-bit
CF
P
P

Description:

Checks whether the position is within the array bounds and then removes it from the array and moves each subsequent element to the slot with the next smaller index and decrements the array's length by 1.

Declaration:

public void RemoveAt ( int Index )

Parameters:

Name
Type
Description
Index
int
The index for the array member to remove. Array indices start at 0.

Return Value:

None

See Also:

ImGearPDFBasArray Class


ImGearPDFBasBool Class

32-bit
64-bit
CF
P
P

Description:

PDF provides Boolean objects identified by the keywords true and false. Boolean objects can be used as the values of array elements and dictionary entries.

Declaration:

public sealed class ImGearPDFBasBool : ImageGear.Formats.PDF.ImGearPDFBasObj

Members:

Constructors
Name
Description
ImGearPDFBasBool Constructor
Creates a new Boolean object associated with the specified document and with the specified value.

Properties
Name
Description
Value Property
The value of the specified Boolean object.


ImGearPDFBasBool Constructors

The ImGearPDFBasBool Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDFBasBool Constructor
Creates a new Boolean object associated with the specified document and with the specified value.


ImGearPDFBasBool Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a new Boolean object associated with the specified document and with the specified value.

Declaration:

public ImGearPDFBasBool(ImageGear.Formats.PDF.ImGearPDFDocument Doc, bool Indirect, bool
Value)

Parameters:

Name
Type
Description
Doc
ImGearPDFDocument Class
The document in which the boolean is used.
Indirect
bool
If True, creates the boolean object as an indirect object. If False, creates the boolean as a direct object.
Value
bool
The value the new boolean will have.

Return Value:

The new instance of ImGearPDFBasBool Class object.

See Also:

ImGearPDFBasBool Class

ImGearPDFDocument Class


ImGearPDFBasBool Properties

The ImGearPDFBasBool Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
Value Property
The value of the specified Boolean object.


Value Property

32-bit
64-bit
CF
P
P

Description:

The value of the specified Boolean object.

Declaration:

public bool Value { get }

Value:

True, False

Default value:

N/A

See Also:

ImGearPDFBasBool Class


ImGearPDFBasDict Class

32-bit
64-bit
CF
P
P

Description:

A dictionary object is an associative table containing pairs of objects, known as the dictionary's entries. The first element of each entry is the key and the second element is the value. The key must be a name. The value can be any kind of object, including another dictionary.

Declaration:

public sealed class ImGearPDFBasDict : ImageGear.Formats.PDF.ImGearPDFBasObj

Members:

Constructors
Name
Description
ImGearPDFBasDict Constructor
Creates a new dictionary object associated with the specified document and with the specified value.

Methods
Name
Description
Get Method
Gets the value of the specified key in the specified dictionary.
Known Method
Tests whether a specific key is found in the specified dictionary.
Put Method
Sets the value of a dictionary key, adding the key to the dictionary if it is not already present.
PutBool Method
Sets the Boolean value of a dictionary key, adding the key to the dictionary if it is not already present.
PutFixed Method
Sets the fixed value of a dictionary key, adding the key to the dictionary if it is not already present.
PutInt Method
Sets the integer value of a dictionary key, adding the key to the dictionary if it is not already present.
PutName Method
Sets the integer value of a dictionary key, adding the key to the dictionary if it is not already present.
Remove Method
Removes a key-value pair from a dictionary.


ImGearPDFBasDict Constructors

The ImGearPDFBasDict Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDFBasDict Constructor
Creates a new dictionary object associated with the specified document and with the specified value.


ImGearPDFBasDict Constructor

32-bit
64-bit
CF
P
P

Description:

Creates a new dictionary object associated with the specified document and with the specified value.

Declaration:

public ImGearPDFBasDict(ImageGear.Formats.PDF.ImGearPDFDocument Doc, bool bIndirect, uint
nEntries)

Parameters:

Name
Type
Description
Doc
ImGearPDFDocument Class
The document in which the dictionary is used.
Indirect
bool
If True, creates the dictionary as an indirect object. If False, creates the dictionary as a direct object.
Entries
uint
Number of entries in the dictionary. This value is only a hint - the dictionaries grow dynamically as needed.

Return Value:

The new instance of ImGearPDFBasDict Class object.

See Also:

ImGearPDFBasDict Class

ImGearPDFDocument Class


ImGearPDFBasDict Methods

The ImGearPDFBasDict Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
Get Method
Gets the value of the specified key in the specified dictionary.
Known Method
Tests whether a specific key is found in the specified dictionary.
Put Method
Sets the value of a dictionary key, adding the key to the dictionary if it is not already present.
PutBool Method
Sets the Boolean value of a dictionary key, adding the key to the dictionary if it is not already present.
PutFixed Method
Sets the fixed value of a dictionary key, adding the key to the dictionary if it is not already present.
PutInt Method
Sets the integer value of a dictionary key, adding the key to the dictionary if it is not already present.
PutName Method
Sets the integer value of a dictionary key, adding the key to the dictionary if it is not already present.
Remove Method
Removes a key-value pair from a dictionary.


Get Method

32-bit
64-bit
CF
P
P

Description:

Gets the value of the specified key in the specified dictionary. If called with a stream object instead of a dictionary object, this method gets the value of the specified key from the stream's attributes dictionary.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFBasObj Get(ImageGear.Formats.PDF.ImGearPDFAtom Key)

Parameters:

Name
Type
Description
Key
ImGearPDFAtom Class
The key to get value of.

Return Value:

ImGearPDFBasObj Class object.

See Also:

ImGearPDFBasObj Class

ImGearPDFAtom Class


Known Method

32-bit
64-bit
CF
P
P

Description:

Tests whether a specific key is found in the specified dictionary.

Declaration:

public bool Known(ImageGear.Formats.PDF.ImGearPDFAtom Key)

Parameters:

Name
Type
Description
Key
ImGearPDFAtom Class
Key to test.

Return Value:

True, False.

See Also:

ImGearPDFAtom Class


Put Method

32-bit
64-bit
CF
P
P

Description:

Sets the value of a dictionary key, adding the key to the dictionary if it is not already present.

Declaration:

public void Put(ImageGear.Formats.PDF.ImGearPDFAtom Key,
ImageGear.Formats.PDF.ImGearPDFBasObj Value)

Parameters:

Name
Type
Description
Key
ImGearPDFAtom Class
Key to set the value to.
Value
ImGearPDFBasObj Class
Key Value to be set.

Return Value:

None

See Also:

ImGearPDFAtom Class

ImGearPDFBasObj Class


PutBool Method

32-bit
64-bit
CF
P
P

Description:

Sets the Boolean value of a dictionary key, adding the key to the dictionary if it is not already present.

Declaration:

public void PutBool(ImageGear.Formats.PDF.ImGearPDFAtom Key, bool Indirect, bool Value)

Parameters:

Name
Type
Description
Key
ImGearPDFAtom Class
The key whose value is set. See the PDF Reference to obtain the names of keys in dictionary objects that are part of standard PDF, such as annotations or page objects.
Indirect
bool
If true, creates the key value as an indirect object. If false, creates the key value as a direct object.
Value
bool
The boolean value to set.

Return Value:

None

See Also:

ImGearPDFAtom Class


PutFixed Method

32-bit
64-bit
CF
P
P

Description:

Sets the fixed value of a dictionary key, adding the key to the dictionary if it is not already present.

Declaration:

public void PutFixed(ImageGear.Formats.PDF.ImGearPDFAtom Key, bool Indirect, int
FixedValue)

Parameters:

Name
Type
Description
Key
ImGearPDFAtom Class
The key whose value is set. See the PDF Reference to obtain the names of keys in dictionary objects that are part of standard PDF, such as annotations or page objects.
Indirect
bool
If true, creates the key value as an indirect object. If false, creates the key value as a direct object.
FixedValue
int
The fixed value to set.

Return Value:

None

See Also:

ImGearPDFAtom Class


PutInt Method

32-bit
64-bit
CF
P
P

Description:

Sets the integer value of a dictionary key, adding the key to the dictionary if it is not already present.

Declaration:

public void PutInt(ImageGear.Formats.PDF.ImGearPDFAtom Key, bool Indirect, int Value)

Parameters:

Name
Type
Description
Key
ImGearPDFAtom Class
The key whose value is set. See the PDF Reference to obtain the names of keys in dictionary objects that are part of standard PDF, such as annotations or page objects.
Indirect
bool
If true, creates the key value as an indirect object. If false, creates the key value as a direct object.
Value
int
The integer value to set.

Return Value:

None

See Also:

ImGearPDFAtom Class


PutName Method

32-bit
64-bit
CF
P
P

Description:

Sets the integer value of a dictionary key, adding the key to the dictionary if it is not already present.

Declaration:

public void PutName(ImageGear.Formats.PDF.ImGearPDFAtom Key, bool Indirect,
ImageGear.Formats.PDF.ImGearPDFAtom Name)

Parameters:

Name
Type
Description
Key
ImGearPDFAtom Class
The key whose value is set. See the PDF Reference to obtain the names of keys in dictionary objects that are part of standard PDF, such as annotations or page objects.
Indirect
bool
If true, creates the key value as an indirect object. If false, creates the key value as a direct object.
Name
ImGearPDFAtom Class
The name value to set.

Return Value:

None

See Also:

ImGearPDFAtom Class


Remove Method

32-bit
64-bit
CF
P
P

Description:

Removes a key-value pair from a dictionary.

Declaration:

public void Remove ( ImageGear.Formats.PDF.ImGearPDFAtom Key )

Parameters:

Name
Type
Description
Key
ImGearPDFAtom Class
The object to remove.

Return Value:

None

See Also:

ImGearPDFAtom Class


ImGearPDFBasFixed Class

32-bit
64-bit
CF
P
P

Description:

Fixed objects approximate mathematical real numbers, but with limited range and precision; they are typically represented in fixed-point, rather than floating-point, form.

Declaration:

public sealed class ImGearPDFBasFixed : ImageGear.Formats.PDF.ImGearPDFBasObj

Members:

Constructors
Name
Description
ImGearPDFBasFixed Constructor
Creates a new fixed object associated with the specified document and with the specified value.

Properties
Name
Description
Value Property
The value of the specified fixed object.


ImGearPDFBasFixed Constructors

The ImGearPDFBasFixed Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDFBasFixed Constructor
Creates a new fixed object associated with the specified document and with the specified value.


ImGearPDFBasFixed Constructor

32-bit
64-bit
CF
P
P

Description:

Creates a new fixed object associated with the specified document and with the specified value.

Declaration:

public ImGearPDFBasFixed(ImageGear.Formats.PDF.ImGearPDFDocument Doc, bool Indirect, int
FixedValue)

Parameters:

Name
Type
Description
Doc
ImGearPDFDocument Class
The document in which the fixed is used.
Indirect
bool
If True, creates the fixed as an indirect object. If False, creates the fixed as a direct object.
FixedValue
int
The value the new fixed will have.

Return Value:

The new instance of ImGearPDFBasFixed Class object.

See Also:

ImGearPDFBasFixed Class

ImGearPDFDocument Class


ImGearPDFBasFixed Properties

The ImGearPDFBasFixed Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
Value Property
The value of the specified fixed object.


Value Property

32-bit
64-bit
CF
P
P

Description:

The value of the specified fixed object.

Declaration:

public int Value { get }

Value:

Integer value

Default value:

N/A

See Also:

ImGearPDFBasFixed Class


ImGearPDFBasInt Class

32-bit
64-bit
CF
P
P

Description:

Integer objects represent mathematical integers within a certain interval centered at 0.

Declaration:

public sealed class ImGearPDFBasInt : ImageGear.Formats.PDF.ImGearPDFBasObj

Members:

Constructors
Name
Description
ImGearPDFBasInt Constructor
Creates a new integer object associated with the specified document and with the specified value.

Properties
Name
Description
Value Property
The value of the specified integer object.


ImGearPDFBasInt Constructors

The ImGearPDFBasInt Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDFBasInt Constructor
Creates a new integer object associated with the specified document and with the specified value.


ImGearPDFBasInt Constructor

32-bit
64-bit
CF
P
P

Description:

Creates a new integer object associated with the specified document and with the specified value.

Declaration:

public ImGearPDFBasInt(ImageGear.Formats.PDF.ImGearPDFDocument Doc, bool Indirect, int
Value)

Parameters:

Name
Type
Description
Doc
ImGearPDFDocument Class
The document in which the integer is used.
Indirect
bool
If True, creates the integer as an indirect object. If False, creates the integer as a direct object.
Value
int
The value the new integer will have.

Return Value:

The new instance of ImGearPDFBasInt Class object.

See Also:

ImGearPDFBasInt Class

ImGearPDFDocument Class


ImGearPDFBasInt Properties

The ImGearPDFBasInt Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
Value Property
The value of the specified integer object.


Value Property

32-bit
64-bit
CF
P
P

Description:

The value of the specified integer object.

Declaration:

public int Value { get }

Value:

Integer value

Default value:

N/A

See Also:

ImGearPDFBasInt Class


ImGearPDFBasName Class

32-bit
64-bit
CF
P
P

Description:

A name object is an atomic symbol uniquely defined by a sequence of characters.

Uniquely defined means that any two name objects made up of the same sequence of characters are identically the same object. Atomic means that a name has no internal structure; although it is defined by a sequence of characters, those characters are not "elements" of the name.

Declaration:

public sealed class ImGearPDFBasName : ImageGear.Formats.PDF.ImGearPDFBasObj

Members:

Constructors
Name
Description
ImGearPDFBasName Constructor
Creates a new name object associated with the specified document and with the specified value.

Properties
Name
Description
Value Property
The value of the specified name object


ImGearPDFBasName Constructors

The ImGearPDFBasName Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDFBasName Constructor
Creates a new name object associated with the specified document and with the specified value.


ImGearPDFBasName Constructor

32-bit
64-bit
CF
P
P

Description:

Creates a new name object associated with the specified document and with the specified value.

Declaration:

public ImGearPDFBasName(ImageGear.Formats.PDF.ImGearPDFDocument Doc, bool Indirect,
ImageGear.Formats.PDF.ImGearPDFAtom Name)

Parameters:

Name
Type
Description
Doc
ImGearPDFDocument Class
The document in which the name is used.
Indirect
bool
If True, creates the name as an indirect object. If False, creates the name as a direct object.
Name
ImGearPDFAtom Class
The value the new name will have.

Return Value:

The new instance of ImGearPDFBasName Class object.

See Also:

ImGearPDFBasName Class

ImGearPDFDocument Class

ImGearPDFAtom Class


ImGearPDFBasName Properties

The ImGearPDFBasName Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
Value Property
The value of the specified name object


Value Property

32-bit
64-bit
CF
P
P

Description:

The value of the specified name object.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom Value { get }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFBasName Class

ImGearPDFAtom Class


ImGearPDFBasNull Class

32-bit
64-bit
CF
P
P

Description:

The null object has a type and value that are unequal to those of any other object. There is only one object of type null, denoted by the keyword null.

Declaration:

public sealed class ImGearPDFBasNull : ImageGear.Formats.PDF.ImGearPDFBasObj

Members:

Constructors
Name
Description
ImGearPDFBasNull Constructor
Creates a direct null object.


ImGearPDFBasNull Constructors

The ImGearPDFBasNull Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDFBasNull Constructor
Creates a direct null object.


ImGearPDFBasNull Constructor

32-bit
64-bit
CF
P
P

Description:

Creates a direct null object.

Declaration:

public ImGearPDFBasNull (  )

Return Value:

The new instance of ImGearPDFBasNull Class object.

See also:

ImGearPDFBasNull Class


ImGearPDFBasObj Class

32-bit
64-bit
CF
P
P

Description:

Basic abstract object. PDF supports eight basic types of object:

  • Boolean values
  • Integer and Fixed (real) numbers
  • Strings
  • Names
  • Arrays
  • Dictionaries
  • Streams
  • The null object

Objects may be labeled so that they can be referred to by other objects. A labeled object is called an indirect object.

Declaration:

public abstract class ImGearPDFBasObj : ImageGear.Formats.PDF.ImGearPDFObject

Members:

Properties
Name
Description
Type
Object's type


ImGearPDFBasObj Properties

The ImGearPDFBasObj Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
Type
Object's type


Type Property

32-bit
64-bit
CF
P
P

Description:

Object's type.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFBasicType Type { get }

Value:

ImGearPDFBasicType Enumeration value.

See Also:

ImGearPDFBasObj Class

ImGearPDFBasicType Enumeration


ImGearPDFBasString Class

32-bit
64-bit
CF
P
P

Description:

Basic string object interface. A string object consists of a series of bytes-unsigned integer values in the range 0 to 255. The string elements are not integer objects, but are stored in a more compact format.

Declaration:

public sealed class ImGearPDFBasString : ImageGear.Formats.PDF.ImGearPDFBasObj

Members:

Constructors
Name
Description
ImGearPDFBasString Constructor
Creates a new string object associated with the specified document and with the specified value.

Properties
Name
Description
Value Property
The value of the specified string object.


ImGearPDFBasString Constructors

The ImGearPDFBasString Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDFBasString Constructor
Creates a new string object associated with the specified document and with the specified value.


ImGearPDFBasString Constructor

32-bit
64-bit
CF
P
P

Description:

Creates a new string object associated with the specified document and with the specified value.

Declaration:

public ImGearPDFBasString(ImageGear.Formats.PDF.ImGearPDFDocument Doc, bool Indirect,
string Value)

Parameters:

Name
Type
Description
Doc
ImGearPDFDocument Class
The document in which the string is used.
Indirect
bool
If True, creates the string as an indirect object. If False, creates the string as a direct object.
Value
string
The value the new string will have.

Return Value:

The new instance of ImGearPDFBasString Class object.

See Also:

ImGearPDFBasString Class

ImGearPDFDocument Class


ImGearPDFBasString Properties

The ImGearPDFBasString Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
Value Property
The value of the specified string object.


Value Property

32-bit
64-bit
CF
P
P

Description:

The value of the specified string object.

Declaration:

public string Value { get }

Value:

String value

Default value:

N/A

See Also:

ImGearPDFBasString Class


ImGearPDFBookmark Class

32-bit
64-bit
CF
P
P

Description:

PDF bookmark allows the user to navigate interactively from one part of the document to another. It consists of a tree-structured hierarchy of bookmarks. Each bookmark has:

  • A title that appears on screen
  • An action that specifies what happens when the user clicks on the bookmark

The typical action for a user-created bookmark is to move to another location in the current document or outside of it. Each bookmark in the bookmark tree structure has zero or more children that appear indented on screen, and zero or more siblings that appear at the same indentation level. All bookmarks except the bookmark at the top level of the hierarchy have one parent, the bookmark under which it is indented. A bookmark is said to be open if its children are visible on screen, and closed if they are not. See section 8.2.2, "Document Outline," in the PDF Reference for more information on bookmarks.

Declaration:

public sealed class ImGearPDFBookmark : ImageGear.Formats.PDF.ImGearPDFObject

Members:

Properties
Name
Description
Count Property
Number of open bookmarks in the sub-tree (not including the current one).
Flags Property
Bookmark's flags.
HasChildren Property
True if the bookmark has any children, False otherwise.
Indent Property
The indentation level of the bookmark in its containing tree.
Open Property
True if the bookmark is open (shows all its children),
Title Property
String specifying the bookmark's title.

Methods
Name
Description
AddChild Method
Adds Child as the last child of parent.
AddNewChild Method
Adds a new bookmark to the tree containing the current bookmark, as the new last child of it.
AddNewSibling Method
Adds a new bookmark to the tree containing the current bookmark as the new right sibling.
AddNext Method
Adds Next as the new right sibling to the current one.
AddPrev Method
Adds Prev as the new left sibling to the current bookmark, adjusting the tree containing the current bookmark appropriately.
AddSubtree Method
Adds a copy of the bookmark sub-tree source to the current bookmark, as a new last child of the current bookmark.
FindTitle Method
Gets the first bookmark whose title is Title.
GetAction Method
Gets the bookmark's action.
GetColor Method
Gets the color of the bookmark.
GetFirstChild Method
Gets the bookmark's first child.
GetLastChild Method
Gets the bookmark's last child.
GetNext Method
Gets the bookmark's next (right) sibling.
GetParent Method
Gets the bookmark's parent bookmark.
GetPrev Method
Gets the bookmark 's previous (left) sibling.
Remove Method
Removes the bookmark's sub-tree from the bookmark tree containing it.
RemoveAction Method
Removes the bookmark's action.
SetAction Method
Sets the bookmark's action.
SetColor Method
Sets the bookmark's color.
Unlink Method
Unlinks the current bookmark from the bookmark tree that contains it, and adjusts the tree appropriately.


ImGearPDFBookmark Properties

The ImGearPDFBookmark Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
Count Property
Number of open bookmarks in the sub-tree (not including the current one).
Flags Property
Bookmark's flags.
HasChildren Property
True if the bookmark has any children, False otherwise.
Indent Property
The indentation level of the bookmark in its containing tree.
Open Property
True if the bookmark is open (shows all its children),
Title Property
String specifying the bookmark's title.


Count Property

32-bit
64-bit
CF
P
P

Description:

Number of open bookmarks in the sub-tree (not including the current one).

Declaration:

public int Count { get }

Value:

Integer value

Default value:

N/A


Flags Property

32-bit
64-bit
CF
P
P

Description:

Bookmark's flags. The OR value of the ImGearPDFBookmarkFlags.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFBookmarkFlags Flags { get, set }

Value:

ImGearPDFBookmarkFlags Enumeration value.

Default value:

N/A

See also:

ImGearPDFBookmarkFlags Enumeration


HasChildren Property

32-bit
64-bit
CF
P
P

Description:

True if the bookmark has any children, False otherwise.

Declaration:

public bool HasChildren { get }

Value:

True, False

Default value:

N/A


Indent Property

32-bit
64-bit
CF
P
P

Description:

The indentation level of the bookmark in its containing tree. The root level has an indentation level of zero.

Declaration:

public int Indent { get }

Value:

Integer value

Default value:

N/A


Open Property

32-bit
64-bit
CF
P
P

Description:

True if the bookmark is open (shows all its children), False otherwise.

Declaration:

public bool Open { get, set }

Value:

True, False

Default value:

N/A


Title Property

32-bit
64-bit
CF
P
P

Description:

String specifying the bookmark's title.

Declaration:

public string Title { get, set }

Value:

String value

Default value:

N/A


ImGearPDFBookmark Methods

The ImGearPDFBookmark Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
AddChild Method
Adds Child as the last child of parent.
AddNewChild Method
Adds a new bookmark to the tree containing the current bookmark, as the new last child of it.
AddNewSibling Method
Adds a new bookmark to the tree containing the current bookmark as the new right sibling.
AddNext Method
Adds Next as the new right sibling to the current one.
AddPrev Method
Adds Prev as the new left sibling to the current bookmark, adjusting the tree containing the current bookmark appropriately.
AddSubtree Method
Adds a copy of the bookmark sub-tree source to the current bookmark, as a new last child of the current bookmark.
FindTitle Method
Gets the first bookmark whose title is Title.
GetAction Method
Gets the bookmark's action.
GetColor Method
Gets the color of the bookmark.
GetFirstChild Method
Gets the bookmark's first child.
GetLastChild Method
Gets the bookmark's last child.
GetNext Method
Gets the bookmark's next (right) sibling.
GetParent Method
Gets the bookmark's parent bookmark.
GetPrev Method
Gets the bookmark 's previous (left) sibling.
Remove Method
Removes the bookmark's sub-tree from the bookmark tree containing it.
RemoveAction Method
Removes the bookmark's action.
SetAction Method
Sets the bookmark's action.
SetColor Method
Sets the bookmark's color.
Unlink Method
Unlinks the current bookmark from the bookmark tree that contains it, and adjusts the tree appropriately.


AddChild Method

32-bit
64-bit
CF
P
P

Description:

Adds Child as the last child of parent, adjusting the tree containing parent appropriately. If parent previously had no children, it is open after the child is added.

Declaration:

public void AddChild ( ImageGear.Formats.PDF.ImGearPDFBookmark Child )

Parameters:

Name
Type
Description
Child
ImGearPDFBookmark Class
The bookmark that will become the last child of the current bookmark. Child must have been previously unlinked.

Return Value:

None

See Also:

ImGearPDFBookmark Class


AddNewChild Method

32-bit
64-bit
CF
P
P

Description:

Adds a new bookmark to the tree containing the current bookmark, as the new last child of it. If the current bookmark previously had no children, it will be open after the child is added.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFBookmark AddNewChild ( string InitialText )

Parameters:

Name
Type
Description
InitialText
string
The new bookmark's title.

Return Value:

ImGearPDFBookmark Class object.

See Also:

ImGearPDFBookmark Class


AddNewSibling Method

32-bit
64-bit
CF
P
P

Description:

Adds a new bookmark to the tree containing the current bookmark as the new right sibling.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFBookmark AddNewSibling ( string InitialText )

Parameters:

Name
Type
Description
InitialText
string
The new bookmark's title.

Return Value:

The newly created bookmark.

See Also:

ImGearPDFBookmark Class


AddNext Method

32-bit
64-bit
CF
P
P

Description:

Adds Next as the new right sibling to the current one.

Declaration:

public void AddNext ( ImageGear.Formats.PDF.ImGearPDFBookmark Next )

Parameters:

Name
Type
Description
Next
ImGearPDFBookmark Class
The bookmark to become the new right sibling of the current bookmark. Next must have been previously unlinked.

Return Value:

None

See Also:

ImGearPDFBookmark Class


AddPrev Method

32-bit
64-bit
CF
P
P

Description:

Adds Prev as the new left sibling to the current bookmark, adjusting the tree containing the current bookmark appropriately.

Declaration:

public void AddPrev ( ImageGear.Formats.PDF.ImGearPDFBookmark Prev )

Parameters:

Name
Type
Description
Prev
ImGearPDFBookmark Class
The bookmark to become the new left sibling of the current bookmark. Prev must have been previously unlinked.

Return Value:

None

See Also:

ImGearPDFBookmark Class


AddSubtree Method

32-bit
64-bit
CF
P
P

Description:

Adds a copy of the bookmark sub-tree source to the current bookmark, as a new last child of the current bookmark. This new item will have the text value SourceTitle, will be open, and will have no destination attribute. Subtree must have been previously unlinked. If the current bookmark previously had no children, it will be open after the sub-tree is added.

Declaration:

public void AddSubtree ( ImageGear.Formats.PDF.ImGearPDFBookmark Subtree , string
SourceTitle )

Parameters:

Name
Type
Description
Subtree
ImGearPDFBookmark Class
The bookmark sub-tree to add.
SourceTitle
string
The new bookmark's title.

Return Value:

None

See Also:

ImGearPDFBookmark Class


FindTitle Method

32-bit
64-bit
CF
P
P

Description:

Gets the first bookmark whose title is Title.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFBookmark FindTitle ( string Title , int MaxDepth )

Parameters:

Name
Type
Description
Title
string
The text value to search for.
MaxDepth
int
The number of sub-tree levels to search, not counting the root level.
  • 0 - Only look at the current bookmark, not at any of its children.
  • 1 - Check the current bookmark and its children, but not any grandchildren or great grandchildren, and so on.
  • -1 - Check the entire sub-tree.

Return Value:

The bookmark with the specified title or NULL if there is no such bookmark.

See Also:

ImGearPDFBookmark Class


GetAction Method

32-bit
64-bit
CF
P
P

Description:

Gets the bookmark's action.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAction GetAction (  )

Return Value:

The bookmark's action - ImGearPDFAction Class object.

See Also:

ImGearPDFAction Class


GetColor Method

32-bit
64-bit
CF
P
P

Description:

Gets the color of the bookmark.

Declaration:

public ImageGear.Core.ImGearPixel GetColor (  )

Return Value:

ImGearPixel Class - Color of the bookmark.

See Also:

ImGearPixel Class


GetFirstChild Method

32-bit
64-bit
CF
P
P

Description:

Gets the bookmark's first child.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFBookmark GetFirstChild (  )

Return Value:

First child of the bookmark or NULL if the bookmark has no children.

See Also:

ImGearPDFBookmark Class


GetLastChild Method

32-bit
64-bit
CF
P
P

Description:

Gets the bookmark's last child.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFBookmark GetLastChild (  )

Return Value:

Last child of the bookmark or NULL if the bookmark has no children.

See Also:

ImGearPDFBookmark Class


GetNext Method

32-bit
64-bit
CF
P
P

Description:

Gets the bookmark's next (right) sibling.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFBookmark GetNext (  )

Return Value:

The bookmark's next (right) sibling or NULL if the bookmark has no next sibling (it is its parent's last child).

See Also:

ImGearPDFBookmark Class


GetParent Method

32-bit
64-bit
CF
P
P

Description:

Gets the bookmark's parent bookmark.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFBookmark GetParent (  )

Return Value:

Parent bookmark of the bookmark or NULL if the bookmark is the root of its tree.

See Also:

ImGearPDFBookmark Class


GetPrev Method

32-bit
64-bit
CF
P
P

Description:

Gets the bookmark 's previous (left) sibling.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFBookmark GetPrev (  )

Return Value:

Previous (left) sibling of the bookmark or NULL if the bookmark has no previous sibling (it is its parent's first child).

See Also:

ImGearPDFBookmark Class


Remove Method

32-bit
64-bit
CF
P
P

Description:

Removes the bookmark's sub-tree from the bookmark tree containing it.

Declaration:

public void Remove (  )

Return Value:

None


RemoveAction Method

32-bit
64-bit
CF
P
P

Description:

Removes the bookmark's action.

Declaration:

public void RemoveAction (  )

Return Value:

None


SetAction Method

32-bit
64-bit
CF
P
P

Description:

Sets the bookmark's action.

Declaration:

public void SetAction ( ImageGear.Formats.PDF.ImGearPDFAction Action )

Parameters:

Name
Type
Description
Action
ImGearPDFAction Class
The bookmark action to set.

Return Value:

None

See Also:

ImGearPDFAction Class


SetColor Method

32-bit
64-bit
CF
P
P

Description:

Sets the bookmark's color.

Declaration:

public void SetColor ( ImageGear.Core.ImGearPixel Color )

Parameters:

Name
Type
Description
Color
ImGearPixel Class
The bookmark's color to set. Must be RGB.

Return Value:

None

See Also:

ImGearPixel Class


Unlink Method

32-bit
64-bit
CF
P
P

Description:

Unlinks the current bookmark from the bookmark tree that contains it, and adjusts the tree appropriately.

Declaration:

public void Unlink (  )

Return Value:

None


ImGearPDFDestination Class

32-bit
64-bit
CF
P
P

Description:

PDF destination represents a particular view of a page in a document. It contains a reference to a page, a rectangle on that page, and information specifying how to adjust the view to fit the window's size and shape. See section 8.2, "Document-Level Navigation," in the PDF Reference for more information on destinations.

Declaration:

public sealed class ImGearPDFDestination : ImageGear.Formats.PDF.ImGearPDFObject

Members:

Constructors
Name
Description
ImGearPDFDestination Constructor
Creates new instance of ImGearPDFDestination object.

Properties
Name
Description
FitType Property
The destination's fit type. Applies only to EXPLICIT type of destination.
PageNumber Property
The page number of the destination's page.
Type Property
The destination type.
Zoom Property
The destination's zoom factor.

Methods
Name
Description
GetName Method
Gets the destination's named attributes. Applies only to NAMED type of destination.
GetRect Method
Gets the destination rectangle. Applies only to EXPLICIT type of destination.
Remove Method
Removes a view destination object. Before deleting a view destination, ensure that no link or bookmark refers to it.
Resolve Method
Resolves the destination.


ImGearPDFDestination Constructors

The ImGearPDFDestination Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDFDestination Constructor
Creates new instance of ImGearPDFDestination object.


ImGearPDFDestination Constructor

32-bit
64-bit
CF
P
P

Description:

Creates a new instance of ImGearPDFDestination Class object.

Declaration:

public ImGearPDFDestination ( ImageGear.Formats.PDF.ImGearPDFDocument Doc ,
ImageGear.Formats.PDF.ImGearPDFPage InitialPage , ImageGear.Formats.PDF.ImGearPDFAtom
InitialFitType , ImageGear.Formats.PDF.ImGearPDFFixedRect InitialRect , int InitialZoom ,
int PageNumber )

Parameters:

Name
Type
Description
Doc
ImGearPDFDocument Class
The document in which the destination is used.
InitialPage
ImGearPDFPreflight Class
The destination page.
InitialFitType
ImGearPDFAtom Class
Destination fit type. Must be one of the View Destination Fit Types.
InitialRect
ImGearPDFFixedRect Class
Destination rectangle, specified in user space coordinates. The appropriate information will be extracted from InitialRect, depending on InitialFitType, to create the destination.
All four of InitialRect's components should be set.
InitialZoom
int
The zoom factor to set for the destination. Used only if InitialFitType is XYZ.
PageNumber
int
Page number of the destination's page.

Return Value:

The new instance of ImGearPDFDestination Class object.

See Also:

ImGearPDFDestination Class

ImGearPDFDocument Class

ImGearPDFPreflight Class

ImGearPDFAtom Class

ImGearPDFFixedRect Class


ImGearPDFDestination Properties

The ImGearPDFDestination Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
FitType Property
The destination's fit type. Applies only to EXPLICIT type of destination.
PageNumber Property
The page number of the destination's page.
Type Property
The destination type.
Zoom Property
The destination's zoom factor.


FitType Property

32-bit
64-bit
CF
P
P

Description:

The destination's fit type. Applies only to EXPLICIT type of destination.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom FitType { get }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFDestination Class

ImGearPDFAtom Class


PageNumber Property

32-bit
64-bit
CF
P
P

Description:

The page number of the destination's page. Applies only to EXPLICIT type of destination.

Declaration:

public int PageNumber { get }

Value:

Integer value

Default value:

N/A


Type Property

32-bit
64-bit
CF
P
P

Description:

The destination type. One of the ImGearPDFDestinationType values.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFDestinationType Type { get }

Value:

ImGearPDFDestination Class object.

Default value:

N/A

See Also:

ImGearPDFDestination Class

ImGearPDFDestinationType Enumeration


Zoom Property

32-bit
64-bit
CF
P
P

Description:

The destination's zoom factor. Applies only to EXPLICIT type of destination.

Declaration:

public int Zoom { get }

Value:

Integer value

Default value:

N/A


ImGearPDFDestination Methods

The ImGearPDFDestination Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
GetName Method
Gets the destination's named attributes. Applies only to NAMED type of destination.
GetRect Method
Gets the destination rectangle. Applies only to EXPLICIT type of destination.
Remove Method
Removes a view destination object. Before deleting a view destination, ensure that no link or bookmark refers to it.
Resolve Method
Resolves the destination.


GetName Method

32-bit
64-bit
CF
P
P

Description:

Gets the destination's named attributes. Applies only to NAMED type of destination.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFBasObj GetName (  )

Return Value:

Basic array object for the destination. Returns NULL if the destination is invalid.

See Also:

ImGearPDFDestination Class

ImGearPDFBasObj Class


GetRect Method

32-bit
64-bit
CF
P
P

Description:

Gets the destination rectangle. Applies only to EXPLICIT type of destination.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFFixedRect GetRect (  )

Return Value:

The destination's rectangle specified in user space coordinates.

See Also:

ImGearPDFDestination Class

ImGearPDFFixedRect Class


Remove Method

32-bit
64-bit
CF
P
P

Description:

Removes a view destination object. Before deleting a view destination, ensure that no link or bookmark refers to it.

Declaration:

public void Remove (  )

Return Value:

None


Resolve Method

32-bit
64-bit
CF
P
P

Description:

Resolves the destination. The destination is a value of the D key in an action. It can be a real destination (an array) or a name. If it is a name, look it up in Document Dests dictionary. The value found there can be a real destination (an array) or a dictionary. If it's a dictionary, look up the D key in that dictionary. This method is useful for getting an explicit view destination from an action.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFDestination Resolve (
ImageGear.Formats.PDF.ImGearPDFDocument Doc )

Parameters:

Name
Type
Description
Doc
ImGearPDFDocument Class
The PDF document that contains the destination.

Return Value:

The resolved view destination.

See Also:

ImGearPDFDestination Class

ImGearPDFDocument Class


ImGearPDFDictionary Class

32-bit
64-bit
CF
P
P

Description:

PDF dictionary class is used to work with optional content.

Declaration:

public sealed class ImGearPDFDictionary : ImageGear.Core.ImGearDocument

Members:

Methods
Name
Description
GetBasObj Method
Returns a BasObj of the Dictionary.
GetLayer Method
Gets the layer with the specified index in a membership dictionary.
LayersCount Method
Gets the number of layers listed in a membership dictionary.
UniqueId Method
Returns some 32-bit integer that is unique for all Dictionary objects.
VisPolicy Method
Gets the optional-content membership dictionary's visibility policy.


ImGearPDFDictionary Methods

The ImGearPDFDictionary Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
GetBasObj Method
Returns a BasObj of the Dictionary.
GetLayer Method
Gets the layer with the specified index in a membership dictionary.
LayersCount Method
Gets the number of layers listed in a membership dictionary.
UniqueId Method
Returns some 32-bit integer that is unique for all Dictionary objects.
VisPolicy Method
Gets the optional-content membership dictionary's visibility policy.


GetBasObj Method

32-bit
64-bit
CF
P
P

Description:

Returns a BasObj of the Dictionary. Used for Container creation.

Declaration:

ImGearPDFBasObj ImGearPDFDictionary.GetBasObj()

Parameters:

None

Return Value:

ImGearPDFBasObj Class of the Dictionary.

See Also:

ImGearPDFBasObj Class

ImGearPDFDictionary Class


GetLayer Method

32-bit
64-bit
CF
P
P

Description:

Gets the layer with the specified index in a membership dictionary.

Declaration:

ImGearPDFLayer ImGearPDFDictionary.GetLayer(
    int nIndex)

Parameters:

Name
Type
Description
nIndex
integer
The index of the needed layer in the dictionary.

Return Value:

Layer object.

See Also:

ImGearPDFDictionary Class

ImGearPDFLayer Class


LayersCount Method

32-bit
64-bit
CF
P
P

Description:

Gets the number of layers listed in a membership dictionary.

Declaration:

int ImGearPDFDictionary.LayersCount

Parameters:

None

Return Value:

The count of the document's layers.

See Also:

ImGearPDFDictionary Class

ImGearPDFLayer Class


UniqueId Method

32-bit
64-bit
CF
P
P

Description:

Returns some 32-bit integer that is unique for all Dictionary objects. In other words, it is guaranteed that there cannot be two Dictionary objects with the same UniqueIds.

Can be used for Dictionary objects' identification.

Declaration:

ImGearPDFDictionary.UniqueId
(get property)

Parameters:

None

Return Value:

A unique identifier of this Dictionary Object.

See Also:

ImGearPDFDictionary Class

ImGearPDFLayer Class


VisPolicy Method

32-bit
64-bit
CF
P
P

Description:

Gets the optional-content membership dictionary's visibility policy, which determines the visibility of content with respect to the ON-OFF state of the layers listed in the dictionary.

Declaration:

ImGearPDFOCMDVisPolicy ImGearPDFDictionary.VisPolicy

Parameters:

None

Return Value:

The visibility policy, an ImGearPDFOCMDVisPolicy Enumeration value.

See Also:

ImGearPDFOCMDVisPolicy Enumeration

ImGearPDFDictionary Class

ImGearPDFLayer Class


ImGearPDFDocument Class

32-bit
64-bit
CF
P
P

Description:

PDF document class is used to work with PDF or PS documents.

Declaration:

public sealed class ImGearPDFDocument : ImageGear.Core.ImGearDocument

Members:

Constructors
Name
Description
ImGearPDFDocument Constructor
Creates an empty document

Properties
Name
Description
LayerCount Property
Layer count for the document.
Pages Property
Access to the document pages

Methods
Name
Description
Clone Method
Clones current document
CreateDictionary Method
Creates a new optional-content membership dictionary object in the given document for the given layers and visibility policy.
CreateLayer Method
Creates a new layer (optional-content group) object in the document.
CreateNewPage Method
Creates new page in the document
Dispose Method
Disposes document's unmanaged resources
ExtractText Method
Extracts text from the document
GetBookmark Method
Gets the root of the document's bookmark tree.
GetInfo Method
Gets the value of a key in a document's Info dictionary, or the value of this same key in the XMP metadata, whichever is latest.
GetLayer Method
Gets the layer with a specified index.
GetNewCryptHandler Method
This method gets the specified document's new security handler (that is, the security handler that will be used after the document is saved). If the document does not have a new security handler, returns the document's current security handler.
GetNewSecurityData Method
This method gets the security data for the specified document's new security handler.
GetNewSecurityInfo Method
This method gets the security information from the specified document's new security handler. No permissions are required to call this method.
GetRoot Method
This method returns the Catalog dictionary of the PDF document.
GetSecurityData Method
This method gets the security data for the specified document's current security handler. Use GetNewSecurityData to get the data for the document's new security handler.
InsertPages Method
This method inserts PageCount pages from Doc into the current document.
PermRequest Method
Checks the permissions associated with the specified document using the latest permissions format and determines whether the requested operation is allowed for the specified object in the document.
Print Method
Prints document
RegisterAuthProc Method
Registers the authorization procedure, which will be called when open a secured PDF file, i.e. a PDF that has either the user or the master password set.
RemoveLayer Method
Destroys the layer (optional-content group) object.
Save Method
Native PDF saving routine, recommended for saving PDF and PS documents.
Save Method
Native PDF saving routine, recommended for saving PDF and PS documents to System.IO.Stream object.
SetInfo Method
Sets the value of a key in a document's Info dictionary.
SetNewCryptHandler Method
This method sets specified document's new security handler (the security handler that will be used after the document is saved).
SetNewSecurityData Method
This method sets the security data structure for the specified document's new security handler. The new security handler must have been previously set using SetNewCryptHandler.

Delegates
Name
Description
ImGearAuthProc Delegate
Delegate describing format of the authorization procedure.


ImGearPDFDocument Constructors

The ImGearPDFDocument Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDFDocument Constructor
Creates an empty document


ImGearPDFDocument Constructor

32-bit
64-bit
CF
P
P

Description:

Creates a new instance of ImGearPDFDocument Class object.

Declaration:

public ImGearPDFDocument (  )

Return Value:

The new instance of ImGearPDFDocument Class object.

See also:

ImGearPDFDocument Class


ImGearPDFDocument Properties

The ImGearPDFDocument Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
LayerCount Property
Layer count for the document.
Pages Property
Access to the document pages


LayerCount Property

32-bit
64-bit
CF
P
P

Description:

Layer count for the document.

Declaration:

public int LayerCount { get }

Value:

Integer value

Default value:

N/A


Pages Property

32-bit
64-bit
CF
P
P

Description:

This property provides access to the document page array.

Declaration:

public override ImageGear.Core.ImGearDocumentPageArray Pages{ get; }

Value:

ImGearPDFDocumentPageArray Class object.

See also:

ImGearPDFDictionary Class

ImGearPDFDocumentPageArray Class


ImGearPDFDocument Methods

The ImGearPDFDocument Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
Clone Method
Clones current document
CreateDictionary Method
Creates a new optional-content membership dictionary object in the given document for the given layers and visibility policy.
CreateLayer Method
Creates a new layer (optional-content group) object in the document.
CreateNewPage Method
Creates new page in the document
Dispose Method
Disposes document's unmanaged resources
ExtractText Method
Extracts text from the document
GetBookmark Method
Gets the root of the document's bookmark tree.
GetInfo Method
Gets the value of a key in a document's Info dictionary, or the value of this same key in the XMP metadata, whichever is latest.
GetLayer Method
Gets the layer with a specified index.
GetNewCryptHandler Method
This method gets the specified document's new security handler (that is, the security handler that will be used after the document is saved). If the document does not have a new security handler, returns the document's current security handler.
GetNewSecurityData Method
This method gets the security data for the specified document's new security handler.
GetNewSecurityInfo Method
This method gets the security information from the specified document's new security handler. No permissions are required to call this method.
GetRoot Method
This method returns the Catalog dictionary of the PDF document.
GetSecurityData Method
This method gets the security data for the specified document's current security handler. Use GetNewSecurityData to get the data for the document's new security handler.
InsertPages Method
This method inserts PageCount pages from Doc into the current document.
PermRequest Method
Checks the permissions associated with the specified document using the latest permissions format and determines whether the requested operation is allowed for the specified object in the document.
Print Method
Prints document
RegisterAuthProc Method
Registers the authorization procedure, which will be called when open a secured PDF file, i.e. a PDF that has either the user or the master password set.
RemoveLayer Method
Destroys the layer (optional-content group) object.
Save Method
Native PDF saving routine, recommended for saving PDF and PS documents.
Save Method
Native PDF saving routine, recommended for saving PDF and PS documents to System.IO.Stream object.
SetInfo Method
Sets the value of a key in a document's Info dictionary.
SetNewCryptHandler Method
This method sets specified document's new security handler (the security handler that will be used after the document is saved).
SetNewSecurityData Method
This method sets the security data structure for the specified document's new security handler. The new security handler must have been previously set using SetNewCryptHandler.


Clone Method

32-bit
64-bit
CF
P
P

Description:

This method clones current document.

Declaration:

public override ImageGear.Core.ImGearDocument Clone ( )

Return value:

Copy of the document.

See also:

ImGearPDFDocument Class


CreateDictionary Method

32-bit
64-bit
CF
P
P

Description:

Creates a new optional-content membership dictionary object in the given document for the given layers and visibility policy.

To add a layer to the existing dictionary, get the current layers' list, modify it, then create a new dictionary with the new list of layers.

Declaration:

ImGearPDFDictionary ImGearPDFDocument.CreateDictionary(
    ImGearPDFLayer[] layers,
    ImGearPDFOCMDVisPolicy nVisPolicy)

Parameters:

Name
Type
Description
nVisPolicy
ImGearPDFOCMDVisPolicy Enumeration
The visibility policy that determines the visibility of content with respect to the ON/OFF state of the layers listed in the dictionary.

Return Value:

The newly created dictionary object, or NULL if no layers are supplied.

See also:

ImGearPDFDictionary Class

ImGearPDFLayer Class

ImGearPDFOCMDVisPolicy Enumeration


CreateLayer Method

32-bit
64-bit
CF
P
P

Description:

Creates a new layer (optional-content group) object in the document.

Declaration:

ImGearPDFLayer ImGearPDFDocument.CreateLayer(
    String name)

Parameters:

Name
Type
Description
name
String
The name of the layer.

Return Value:

The newly created group object.

See also:

ImGearPDFDictionary Class

ImGearPDFLayer Class


CreateNewPage Method

32-bit
64-bit
CF
P
P

Description:

Creates new page in the document.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFPage CreateNewPage(int AfterPage,
ImageGear.Formats.PDF.ImGearPDFFixedRect MediaBox)

Parameters:

Name
Type
Description
AfterPage
int
The page number after which the new page is inserted. The first page is 0. Use BEFORE_FIRST_PAGE to insert the new page at the beginning of a document.
MediaBox
ImGearPDFFixedRect Class
Rectangle specifying the page's media box, specified in user space coordinates.

Return Value:

ImGearPDFPreflight Class object.

See also:

ImGearPDFPreflight Class

ImGearPDFFixedRect Class


Dispose Method

32-bit
64-bit
CF
P
P

Description:

Disposes document's unmanaged resources.

Declaration:

public void Dispose (  )

Return Value:

The resolved view destination.

See also:

ImGearPDFDictionary Class


ExtractText Method

32-bit
64-bit
CF
P
P

Description:

This method extracts text from the document pages determined by arguments StartPageNumber and PageCount according to the specified Flags. The resulting stream is output to TextStream.

Declaration:

public void ExtractText(int StartPageNumber, int PageCount,
ImageGear.Formats.PDF.ImGearPDFContextFlags Flags, stream TextStream)

Parameters:

Name
Type
Description
StartPageNumber
int
Start page index.
PageCount
int
Page count.
Flags
ImGearPDFContextFlags Enumeration
Context flags.
TextStream
stream
Output stream.

Return Value:

None

See also:

ImGearPDFDictionary Class

ImGearPDFContextFlags Enumeration


GetBookmark Method

32-bit
64-bit
CF
P
P

Description:

Gets the root of the document's bookmark tree. The returned value is valid even if document's bookmark tree is empty.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFBookmark GetBookmark (  )

Return Value:

The document's root bookmark.

See also:

ImGearPDFDictionary Class

ImGearPDFBookmark Class


GetInfo Method

32-bit
64-bit
CF
P
P

Description:

Gets the value of a key in a document's Info dictionary, or the value of this same key in the XMP metadata, whichever is latest.

See Section 10.2.1 in the PDF Reference for information about Info dictionaries. All values in the Info dictionary should be strings; other data types such as numbers and Booleans should not be used as values in the Info dictionary.

Users may define their own Info dictionary entries. In this case, it is strongly recommended that the key have the developer's prefix assigned by the Adobe Solutions Network.

Declaration:

public System.String GetInfo ( string InfoKey )

Parameters:

Name
Type
Description
InfoKey
string
The name of the Info dictionary key whose value is obtained.

Return Value:

String containing the value associated with InfoKey.

See also:

ImGearPDFDictionary Class


GetLayer Method

32-bit
64-bit
CF
P
P

Description:

Gets the layer with a specified index.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFLayer GetLayer ( int Index )

Parameters:

Name
Type
Description
Index
int
Index of the layer to obtain.

Return Value:

ImGearPDFLayer Class layer object.

See also:

ImGearPDFDictionary Class

ImGearPDFLayer Class


GetNewCryptHandler Method

32-bit
64-bit
CF
P
P

Description:

This method gets the specified document's new security handler (that is, the security handler that will be used after the document is saved). If the document does not have a new security handler, returns the document's current security handler.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom GetNewCryptHandler (  )

Return Value:

ImGearPDFAtom Class corresponding to the name of the document's new security handler. NULL if the document does not have a new security handler.

See also:

ImGearPDFDictionary Class

ImGearPDFAtom Class


GetNewSecurityData Method

32-bit
64-bit
CF
P
P

Description:

This method gets the security data for the specified document's new security handler. Use GetSecurityData to get the security data for the document's current security handler.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFSecurityData GetNewSecurityData (  )

Return Value:

ImGearPDFSecurityData Class object for the document's new security handler.

See also:

ImGearPDFDictionary Class

ImGearPDFSecurityData Class


GetNewSecurityInfo Method

32-bit
64-bit
CF
P
P

Description:

This method gets the security information from the specified document's new security handler. No permissions are required to call this method.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFSecurityInfoFlags GetNewSecurityInfo (  )

Return Value:

The document's new security information. The OR value of the ImGearPDFSecurityInfoFlags Enumeration.

See also:

ImGearPDFDictionary Class

ImGearPDFSecurityInfoFlags Enumeration


GetRoot Method

32-bit
64-bit
CF
P
P

Description:

This method returns the Catalog dictionary of the PDF document (this Catalog dictionary is the root of a PDF document's object hierarchy).

See also the PDF Reference, ch.3.6.

Declaration:

public ImGearPDFBasDict GetRoot();

Return Value:

The resulting Catalog dictionary.

Example:

C#
dict = pdfDoc.GetRoot();

VB
dict = pdfDoc.GetRoot

See Also:

ImGearPDFBasDict Class


GetSecurityData Method

32-bit
64-bit
CF
P
P

Description:

This method gets the security data for the specified document's current security handler. Use GetNewSecurityData to get the data for the document's new security handler.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFSecurityData GetSecurityData (  )

Return Value:

ImGearPDFSecurityData Class - the document's current security data object.

See also:

ImGearPDFDictionary Class

ImGearPDFSecurityData Class


InsertPages Method

32-bit
64-bit
CF
P
P

Description:

Creates new page in the document.

Declaration:

public void InsertPages(int AfterThisPage, ImageGear.Formats.PDF.ImGearPDFDocument Doc,
int StartPage, int PageCount, ImageGear.Formats.PDF.ImGearPDFInsertFlags InsertFlags)

Parameters:

Name
Type
Description
AfterThisPage
int
The page number in the current document after which pages from Doc2 are inserted. The first page is 0. If BEFORE_FIRST_PAGE is used, the pages are inserted before the first page in the current document. Use LAST_PAGE to insert pages after the last page in the current document.
Doc
ImGearPDFDocument Class
The document containing the pages that are inserted into the current document.
StartPage
int
The page number of the first page in Doc2 to insert into the current document. The first page is 0.
PageCount
int
The number of pages in Doc2 to insert into the current document. Use ALL_PAGES to insert all pages from Doc2 into the current document.
InsertFlags
ImGearPDFInsertFlags Enumeration
Flags that determine what additional information is copied from Doc2 into the current document. An OR of enumImGearPDFInsertFlags constants:
  • BOOKMARKS - Inserts bookmarks as well as pages. The bookmark tree of Doc2 is merged into the bookmark tree of the current document by copying it as a new first-level subtree of the current document's bookmark tree root, of which it becomes the last child. If the current document has no bookmark tree, it acquires one identical to the bookmark tree from Doc2.
  • THREADS - Inserts threads as well as pages.
  • ALL - Inserts document data from pages.

Return Value:

None

See also:

ImGearPDFDocument Class

ImGearPDFInsertFlags Enumeration


PermRequest Method

32-bit
64-bit
CF
P
P

Description:

Checks the permissions associated with the specified document using the latest permissions format and determines whether the requested operation is allowed for the specified object in the document.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFPermReqStatus PermRequest (
ImageGear.Formats.PDF.ImGearPDFPermReqObj ReqObj ,
ImageGear.Formats.PDF.ImGearPDFPermReqOpr ReqOpr , string Password )

Parameters:

Name
Type
Description
ReqObj
ImGearPDFPermReqObj Enumeration
The target object of the permissions request.
ReqOpr
ImGearPDFPermReqOpr Enumeration
The target operation of the permissions request.
Password
Password
An authorization data (password string).

Return Value:

One of ImGearPDFPermReqStatus Enumeration request status constants.

See also:

ImGearPDFDictionary Class

ImGearPDFPermReqObj Enumeration

ImGearPDFPermReqOpr Enumeration

ImGearPDFPermReqStatus Enumeration


Print Method

32-bit
64-bit
CF
P
P

Description:

This method prints document with options specified in Options.

Declaration:

public void Print (ImageGear.PDF.ImGearPDFPrintOptions Options)

Parameters:

Name
Type
Description
Options
ImGearPDFPrintOptions Class
Printing options.

Return Value:

None.

See also:

ImGearPDFDictionary Class

ImGearPDFPrintOptions Class


RegisterAuthProc Method

32-bit
64-bit
CF
P
P

Description:

Registers the authorization procedure, which will be called when open a secured PDF file, i.e. a PDF that has either the user or the master password set. See ImGearPDFDocument.ImGearAuthProc for more details.

Declaration:

public static void RegisterAuthProc (
ImageGear.Formats.PDF.ImGearPDFDocument.ImGearAuthProc AuthProc , object ClientData )

Parameters:

Name
Type
Description
AuthProc
ImGearAuthProc Delegate
Authorization procedure.
ClientData
object
Client data.

Return Value:

None

See also:

ImGearPDFDictionary Class

ImGearAuthProc Delegate


RemoveLayer Method

32-bit
64-bit
CF
P
P

Description:

Destroys the layer (optional-content group) object. This does not delete any content.

Declaration:

void ImGearPDFDocument.RemoveLayer(
    ImGearPDFLayer layer)

Parameters:

Name
Type
Description
layer
ImGearPDFLayer Class
The layer object.

Return Value:

None

See also:

ImGearPDFDictionary Class

ImGearPDFLayer Class


Save Method

32-bit
64-bit
CF
P
P

Description:

Native PDF saving routine, recommended for saving PDF and PS documents.

Declaration:

public void Save(string FileName, ImageGear.Formats.ImGearSavingFormats Format, int
StartPageFile, int StartIndexDoc, int PageCount, ImageGear.Formats.ImGearSavingModes
SaveMode)

Parameters:

Name
Type
Description
FileName
string
File name of file to be saved.
Format
ImGearSavingFormats Enumeration
File format to save in.
StartPageFile
int
Strating page number in the file.
StartIndexDoc
int
Starting page number in the document.
PageCount
int
The number of pages to be saved.
SaveMode
ImGearSavingModes Enumeration
Saving mode.

Return Value:

None

See also:

ImGearPDFDictionary Class

ImGearSavingFormats Enumeration

ImGearSavingModes Enumeration


Save Method

32-bit
64-bit
CF
P
P

Description:

This method is the native PDF saving routine, recommended for saving PDF and PS documents to System.IO.Stream object.

Declaration:

public void Save(System.IO.Stream Stream, ImageGear.Formats.ImGearSavingFormats Format,
int StartPageStream, int StartIndexDoc, int PageCount, ImageGear.Formats.ImGearSavingModes
SaveMode)

Parameters:

Name
Type
Description
Stream
Stream
Stream object to save to. Only FileStream and MemoryStream are currently supported.
Format
ImGearSavingFormats Enumeration
File format to save in.
StartPageStream
int
Starting page number in the stream.
StartIndexDoc
int
Starting page number in the document.
PageCount
int
The number of pages to be saved.
SaveMode
ImGearSavingModes Enumeration
Saving mode.

Return Value:

None

Example:

if (imGearDocument is ImGearPDFDocument)
    {
        ImGearPDFDocument doc = (ImGearPDFDocument)imGearDocument;
        using (MemoryStream mem = new MemoryStream())
        {
            doc.Save(mem, ImGearSavingFormats.PDF, 0, 0, doc.Pages.Count,
ImGearSavingModes.OVERWRITE);
            using (FileStream file = new FileStream("c:\\out.pdf", FileMode.CreateNew))
            {
                byte[] bytes = mem.ToArray();
                file.Write(bytes, 0, bytes.Length);
            }
        }
    }

See also:

ImGearPDFDictionary Class

ImGearSavingFormats Enumeration

ImGearSavingModes Enumeration


SetInfo Method

32-bit
64-bit
CF
P
P

Description:

Sets the value of a key in a document's Info dictionary.

See Section 10.2.1 on Info dictionaries in the PDF Reference for information about Info dictionaries. All values in the Info dictionary should be strings; other data types such as numbers and Booleans should not be used as values in the Info dictionary. If an info dictionary key is specified that is not currently in the info dictionary, it is added to the dictionary.

Declaration:

public void SetInfo ( string InfoKey , string InfoValue )

Parameters:

Name
Type
Description
InfoKey
string
The name of the Info dictionary key whose value is set.
InfoValue
string
String containing the value to associate with InfoKey.

Return Value:

None

See also:

ImGearPDFDictionary Class


SetNewCryptHandler Method

32-bit
64-bit
CF
P
P

Description:

This method sets specified document's new security handler (the security handler that will be used after the document is saved). This method returns with no action if the new security handler is the same as the old one.

Declaration:

public void SetNewCryptHandler ( ImageGear.Formats.PDF.ImGearPDFAtom NewCryptHandler )

Parameters:

Name
Type
Description
NewCryptHandler
ImGearPDFAtom Class
The PDF atom for the name of the new security handler to use for the document. Use NULL to remove security from the document.

Return Value:

None

See also:

ImGearPDFDictionary Class

ImGearPDFAtom Class


SetNewSecurityData Method

32-bit
64-bit
CF
P
P

Description:

Checks the permissions associated with the specified document using the latest permissions format and determines whether the requested operation is allowed for the specified object in the document.

Declaration:

public void SetNewSecurityData ( ImageGear.Formats.PDF.ImGearPDFSecurityData
NewSecurityData)

Parameters:

Name
Type
Description
NewSecurityData
ImGearPDFSecurityData Class
The new security data object to set for doc.

Return Value:

None

See also:

ImGearPDFDictionary Class

ImGearPDFSecurityData Class


ImGearPDFDocument Delegates

The ImGearPDFDocument Class of the ImageGear.Formats.PDF Namespace has the following delegates:

Delegates
Name
Description
ImGearAuthProc Delegate
Delegate describing format of the authorization procedure.


ImGearAuthProc Delegate

32-bit
64-bit
CF
P
P

Description:

Delegate describing format of the authorization procedure.

Declaration:

public sealed delegate ImGearPDFDocument.ImGearAuthProc : System.MulticastDelegate

See also:

ImGearPDFDocument Class


ImGearPDFDocumentPageArray Class

32-bit
64-bit
CF
P
P

Description:

This class provides an access to the document page array.

Declaration:

public sealed class ImGearPDFDocumentPageArray : ImageGear.Core.ImGearDocumentPageArray

Members:

Properties
Name
Description
this Property
Accesses to the individual pages.

Methods
Name
Description
Add Method
Adds new page.
Clear Method
Removes all pages.
CopyTo Method
Copies all the pages.
Dispose Method
Disposes document's unmanaged resources.
Insert Method
Insets new page.
Remove Method
Removes page.
Remove Method
Removes page.
RemoveAt Method
Removes page.


ImGearPDFDocumentPageArray Properties

The ImGearPDFDocumentPageArray Class of the ImageGear.Formats.PDF Namespace has the following Properties:

Properties
Name
Description
this Property
Accesses to the individual pages.


this Property

32-bit
64-bit
CF
P
P

Description:

This is the indexed property for accessing the individual page from the document.

Declaration:

public override ImageGear.Core.ImGearPage this{ get; set }

Values:

ImGearPage Class object.

See Also:

ImGearPage Class


ImGearPDFDocumentPageArray Methods

The ImGearPDFDocumentPageArray Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
Add Method
Adds new page.
Clear Method
Removes all pages.
CopyTo Method
Copies all the pages.
Dispose Method
Disposes document's unmanaged resources.
Insert Method
Insets new page.
Remove Method
Removes page.
Remove Method
Removes page.
RemoveAt Method
Removes page.


Add Method

32-bit
64-bit
CF
P
P

Description:

This method adds page at the end of the document. The page must be parentless. If you want to add a page from another document, clone the page first. Method returns index of the newly added page in the document.

Declaration:

public override int Add(ImageGear.Core.ImGearPage Page)

Parameters:

Name
Type
Description
Page
ImGearPage Class
Page to add.

Return Value:

Integer value.


Clear Method

32-bit
64-bit
CF
P
P

Description:

This method removes all pages from the document.

Declaration:

public override void Clear ( )

Return Value:

None.


CopyTo Method

32-bit
64-bit
CF
P
P

Description:

This method copies all the pages from the current page array to the page array starting at index.

Declaration:

public override void CopyTo(System.Array ar, int index)

Parameters:

Name
Type
Description
ar
System.Array
Destination array.
index
int
Starting index.

Return Value:

None.


Dispose Method

32-bit
64-bit
CF
P
P

Description:

Disposes document's unmanaged resources.

Declaration:

public virtual new void Dispose (  )

Return Value:

None


Insert Method

32-bit
64-bit
CF
P
P

Description:

This method inserts page in the document at index position.

Declaration:

public override void Insert (int index , ImageGear.Core.ImGearPage page)

Parameters:

Name
Type
Description
index
int
Position to insert at.
page
ImGearPage Class
Page to insert.

Return Value:

None.

See Also:

ImGearPage Class


Remove Method

32-bit
64-bit
CF
P
P

Description:

This method removes page value from the document.

Declaration:

public override void Remove (System.Object value)

Parameters:

Name
Type
Description
value
System.Object
Page to remove.

Return Value:

None.


Remove Method

32-bit
64-bit
CF
P
P

Description:

This method removes page from the document.

Declaration:

public override void Remove (ImageGear.Core.ImGearPage page)

Parameters:

Name
Type
Description
page
ImGearPage Class
Page to remove.

Return value:

None.

See Also:

ImGearPage Class


RemoveAt Method

32-bit
64-bit
CF
P
P

Description:

This method removes page with index from the document.

Declaration:

public override void RemoveAt (int index)

Parameters:

Name
Type
Description
index
int
Page index to remove at.

Return Value:

None.


ImGearPDFFixedMatrix Class

32-bit
64-bit
CF
P
P

Description:

Matrix containing fixed numbers.

Declaration:

public sealed class ImGearPDFFixedMatrix

Members:

Properties
Name
Description
A Property
A value.
B Property
B value.
C Property
C value.
D Property
D value.
H Property
H value.
V Property
V value.

Methods
Name
Description
Empty Method
Sets all numeric properties of the matrix to their initial values.


ImGearPDFFixedMatrix Properties

The ImGearPDFFixedMatrix Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
A Property
A value.
B Property
B value.
C Property
C value.
D Property
D value.
H Property
H value.
V Property
V value.


A Property

32-bit
64-bit
CF
P
P

Description:

A value.

Declaration:

public int A { get, set }

Value:

Integer value

Default value:

N/A


B Property

32-bit
64-bit
CF
P
P

Description:

B value.

Declaration:

public int B { get, set }

Value:

Integer value

Default value:

N/A


C Property

32-bit
64-bit
CF
P
P

Description:

C value.

Declaration:

public int C { get, set }

Value:

Integer value

Default value:

N/A


D Property

32-bit
64-bit
CF
P
P

Description:

D value.

Declaration:

public int D { get, set }

Value:

Integer value

Default value:

N/A


H Property

32-bit
64-bit
CF
P
P

Description:

H value.

Declaration:

public int H { get, set }

Value:

Integer value

Default value:

N/A


V Property

32-bit
64-bit
CF
P
P

Description:

V value.

Declaration:

public int V { get, set }

Value:

Integer value

Default value:

N/A


ImGearPDFFixedMatrix Methods

The ImGearPDFFixedMatrix Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
Empty Method
Sets all numeric properties of the matrix to their initial values.


Empty Method

32-bit
64-bit
CF
P
P

Description:

Sets all numeric properties of the matrix to their initial values.

Declaration:

public void Empty (  )

Return Value:

None


ImGearPDFFixedPoint Class

32-bit
64-bit
CF
P
P

Description:

Point (in two-dimensional space) represented by two fixed numbers.

Declaration:

public sealed class ImGearPDFFixedPoint

Members:

Properties
Name
Description
H Property
Horizontal value.
V Property
Vertical value.


ImGearPDFFixedPoint Properties

The ImGearPDFFixedPoint Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
H Property
Horizontal value.
V Property
Vertical value.


H Property

32-bit
64-bit
CF
P
P

Description:

Horizontal value.

Declaration:

public int H { get, set }

Value:

Integer value

Default value:

N/A


V Property

32-bit
64-bit
CF
P
P

Description:

Vertical value.

Declaration:

public int V { get, set }

Value:

Integer value

Default value:

N/A


ImGearPDFFixedQuad Class

32-bit
64-bit
CF
P
P

Description:

Quadrilateral represented by four fixed points (one at each corner). A quadrilateral differs from a rectangle in that the latter must always have horizontal and vertical sides, and opposite sides must be parallel.

Declaration:

public sealed class ImGearPDFFixedQuad

Members:

Properties
Name
Description
BottomLeft Property
Bottom Left value.
BottomRight Property
Bottom Right value.
TopLeft Property
Top Left value.
TopRight Property
Top Right value.


ImGearPDFFixedQuad Properties

The ImGearPDFFixedQuad Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
BottomLeft Property
Bottom Left value.
BottomRight Property
Bottom Right value.
TopLeft Property
Top Left value.
TopRight Property
Top Right value.


BottomLeft Property

32-bit
64-bit
CF
P
P

Description:

Bottom Left value.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFFixedPoint BottomLeft { get, set }

Value:

ImGearPDFFixedPoint Class object.

Default value:

N/A

See Also:

ImGearPDFFixedPoint Class


BottomRight Property

32-bit
64-bit
CF
P
P

Description:

Bottom Right value.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFFixedPoint BottomRight { get, set }

Value:

ImGearPDFFixedPoint Class object.

Default value:

N/A

See Also:

ImGearPDFFixedPoint Class


TopLeft Property

32-bit
64-bit
CF
P
P

Description:

Top Left value.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFFixedPoint TopLeft { get, set }

Value:

ImGearPDFFixedPoint Class object.

Default value:

N/A

See Also:

ImGearPDFFixedPoint Class


TopRight Property

32-bit
64-bit
CF
P
P

Description:

Top Right value.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFFixedPoint TopRight { get, set }

Value:

ImGearPDFFixedPoint Class object.

Default value:

N/A

See Also:

ImGearPDFFixedPoint Class


ImGearPDFFixedRect Class

32-bit
64-bit
CF
P
P

Description:

A rectangle represented by the coordinates of its four sides. A rectangle differs from a quadrilateral in that the former must always have horizontal and vertical sides, and opposite sides must be parallel.

Declaration:

public sealed class ImGearPDFFixedRect

Members:

Constructors
Name
Description
ImGearPDFFixedRect Constructor
Initializes a new instance of the ImGearPDFFixedRect class.

Properties
Name
Description
Bottom Property
Specifies the y-coordinate of the lower-right corner of the rectangle.
Left Property
Specifies the x-coordinate of the upper-left corner of the rectangle.
Right Property
Specifies the x-coordinate of the lower-right corner of the rectangle.
Top Property
Specifies the y-coordinate of the upper-left corner of the rectangle.

Methods
Name
Description
Empty Method
Sets all numeric properties of the rectangle to their initial values.


ImGearPDFFixedRect Constructors

The ImGearPDFFixedRect Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDFFixedRect Constructor
Initializes a new instance of the ImGearPDFFixedRect class.


ImGearPDFFixedRect Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates the new instance of ImGearPDFFixedRect object.

Declaration:

public ImGearPDFFixedRect(int left, int top, int right, int bottom)

Parameters:

Name
Type
Description
Left
int
The x-coordinate of the upper-left corner of the rectangle.
Top
int
The y-coordinate of the upper-left corner of the rectangle.
Right
int
The x-coordinate of the lower-right corner of the rectangle.
Bottom
int
The y-coordinate of the lower-right corner of the rectangle.

Return Value:

The new instance of ImGearPDFFixedRect Class object.

See Also:

ImGearPDFFixedRect Class


ImGearPDFFixedRect Properties

The ImGearPDFFixedRect Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
Bottom Property
Specifies the y-coordinate of the lower-right corner of the rectangle.
Left Property
Specifies the x-coordinate of the upper-left corner of the rectangle.
Right Property
Specifies the x-coordinate of the lower-right corner of the rectangle.
Top Property
Specifies the y-coordinate of the upper-left corner of the rectangle.


Bottom Property

32-bit
64-bit
CF
P
P

Description:

Specifies the y-coordinate of the lower-right corner of the rectangle.

Declaration:

public int Bottom { get, set }

Value:

Integer value

Default value:

N/A

See Also:

ImGearPDFFixedRect Class


Left Property

32-bit
64-bit
CF
P
P

Description:

Specifies the x-coordinate of the upper-left corner of the rectangle.

Declaration:

public int Left { get, set }

Value:

Integer value

Default value:

N/A

See Also:

ImGearPDFFixedRect Class


Right Property

32-bit
64-bit
CF
P
P

Description:

Specifies the x-coordinate of the lower-right corner of the rectangle.

Declaration:

public int Right { get, set }

Value:

Integer value

Default value:

N/A

See Also:

ImGearPDFFixedRect Class


Top Property

32-bit
64-bit
CF
P
P

Description:

Specifies the y-coordinate of the upper-left corner of the rectangle.

Declaration:

public int Top { get, set }

Value:

Integer value

Default value:

N/A

See Also:

ImGearPDFFixedRect Class


ImGearPDFFixedRect Methods

The ImGearPDFFixedRect Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
Empty Method
Sets all numeric properties of the rectangle to their initial values.


Empty Method

32-bit
64-bit
CF
P
P

Description:

Sets all numeric properties of the rectangle to their initial values.

Declaration:

public void Empty (  )

Return Value:

None

See Also:

ImGearPDFFixedRect Class


ImGearPDFLayer Class

32-bit
64-bit
CF
P
P

Description:

PDF layer object represents a named object whose state can be toggled in a UI to affect changes in visibility of content.

Declaration:

public sealed class ImGearPDFLayer : ImageGear.Formats.PDF.ImGearPDFObject

Members:

Properties
Name
Description
CurrentState Property
Current ON-OFF state of the layer object.
HasUsageInfo Property
Tests whether a layer object is associated with a Usage dictionary.
InitialState Property
Initial ON-OFF state of the layer object.
Name Property
Name of the Layer..

Methods
Name
Description
GetIntent Method
Gets the intent list for a layer.
GetUsageInfo Method
Gets usage information from a layer object.
SetIntent Method
Sets the Intent entry in a layer's dictionary.
SetUsageInfo Method
Sets a Usage dictionary entry in a layer object.
UniqueId Method
Returns a 32-bit integer that is unique for all layer objects.


ImGearPDFLayer Properties

The ImGearPDFLayer Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
CurrentState Property
Current ON-OFF state of the layer object.
HasUsageInfo Property
Tests whether a layer object is associated with a Usage dictionary.
InitialState Property
Initial ON-OFF state of the layer object.
Name Property
Name of the Layer..


CurrentState Property

32-bit
64-bit
CF
P
P

Description:

Current ON-OFF state of the layer object, true if the state is ON, false if it is OFF.

Declaration:

public bool CurrentState { get, set }

Value:

True, False

Default value:

N/A


HasUsageInfo Property

32-bit
64-bit
CF
P
P

Description:

Tests whether a layer object is associated with a Usage dictionary. True if the layer has a Usage dictionary, false otherwise.

Declaration:

public bool HasUsageInfo { get, set }

Value:

True, False

Default value:

N/A


InitialState Property

32-bit
64-bit
CF
P
P

Description:

Initial ON-OFF state of the layer object, true if the state is initially ON, false if it is OFF.

Declaration:

public bool InitialState { get, set }

Value:

True, False

Default value:

N/A


Name Property

32-bit
64-bit
CF
P
P

Description:

Name of the Layer.

Declaration:

public string Name { get, set }

Value:

String value

Default value:

N/A


ImGearPDFLayer Methods

The ImGearPDFLayer Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
GetIntent Method
Gets the intent list for a layer.
GetUsageInfo Method
Gets usage information from a layer object.
SetIntent Method
Sets the Intent entry in a layer's dictionary.
SetUsageInfo Method
Sets a Usage dictionary entry in a layer object.
UniqueId Method
Returns a 32-bit integer that is unique for all layer objects.


GetIntent Method

32-bit
64-bit
CF
P
P

Description:

Gets the intent list for a layer. Intent is an atom value broadly describing the intended use, either View or Design. A layer's content is considered to be optional (that is, the layer's state is considered in its visibility) if any intent in its list matches an intent of the context. The intent list of the context is usually set from the intent list of the document configuration.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom[] GetIntent (  )

Return Value:

ImGearPDFAtom Class object array.

See Also:

ImGearPDFAtom Class


GetUsageInfo Method

32-bit
64-bit
CF
P
P

Description:

Gets usage information from a layer object. A Usage dictionary entry provides more specific intended usage information than an intent entry.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFBasObj GetUsageInfo (
ImageGear.Formats.PDF.ImGearPDFAtom UsageKey )

Parameters:

Name
Type
Description
UsageKey
ImGearPDFAtom Class
The usage key in the usage dictionary entry. Possible key values are:
  • CreatorInfo
  • Language
  • Export
  • Zoom
  • Print
  • View
  • User
  • PageElement

Return Value:

Returns the usage information associated with the given key in the Usage dictionary for the layer, or a NULL, if the operation fails (because the layer is malformed or has no dictionary, or because the dictionary has no entry corresponding to the given key).

See Also:

ImGearPDFAtom Class

ImGearPDFBasObj Class


SetIntent Method

32-bit
64-bit
CF
P
P

Description:

Sets the Intent entry in a layer's dictionary. Intent is an atom value broadly describing the intended use, either View or Design. A layer's content is considered to be optional (that is, the layer's state is considered in its visibility) if any intent in its list matches an intent of the context. The intent list of the context is usually set from the intent list of the document configuration.

Declaration:

public void SetIntent ( ImageGear.Formats.PDF.ImGearPDFAtom[] Intent )

Parameters:

Name
Type
Description
Intent
ImGearPDFAtom Class
The new Intent entry value, an array of intent entries (atoms).

Return Value:

None

See Also:

ImGearPDFAtom Class

ImGearPDFBasObj Class


SetUsageInfo Method

32-bit
64-bit
CF
P
P

Description:

Sets a Usage dictionary entry in a layer object. The entry associates usage information with an entry key for retrieval. If a dictionary does not exist, the method creates one.

A Usage dictionary entry provides more specific intended usage information than an intent entry.

The usage value can act as a kind of metadata, describing the sort of things that belong to the layer: for example, text in French, fine detail on a map, or a watermark. The usage values can also be used by the AutoState mechanism to make decisions about what layers should be on and what layers should be off.

Declaration:

public void SetUsageInfo ( ImageGear.Formats.PDF.ImGearPDFAtom UsageKey ,
ImageGear.Formats.PDF.ImGearPDFBasObj UsageInfo )

Parameters:

Name
Type
Description
UsageKey
ImGearPDFAtom Class
The usage key in the usage dictionary entry. Possible key values are:
  • CreatorInfo
  • Language
  • Export
  • Zoom
  • Print
  • View
  • User
  • PageElement
UsageInfo
ImGearPDFBasObj Class
The usage information to associate with the key.

Return Value:

None

See Also:

ImGearPDFAtom Class

ImGearPDFBasObj Class


UniqueId Method

32-bit
64-bit
CF
P
P

Description:

Returns some 32-bit integer, which is unique for all Layer objects. In other words, it is guaranteed that there cannot be two Layer objects with the same UniqueIds.

Can be used for Layer objects' identification.

Declaration:

ImGearPDFLayer.UniqueId
(get property)

Parameters:

None

Return Value:

A unique identifier of this Layer Object.

See Also:

ImGearPDFDocument Class

ImGearPDFDictionary Class


ImGearPDFObject Class

32-bit
64-bit
CF
P
P

Description:

General PDF Object that provides a disposing routine for all the unmanaged resources.

Declaration:

public abstract class ImGearPDFObject

Members:

Methods
Name
Description
Dispose Method
Disposes object's unmanaged resources.


ImGearPDFObject Methods

The ImGearPDFObject Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
Dispose Method
Disposes object's unmanaged resources.


Dispose Method

32-bit
64-bit
CF
P
P

Description:

Disposes object's unmanaged resources.

Declaration:

public void Dispose (  )

Return Value:

None

See Also:

ImGearPDFObject Class


ImGearPDFPage Class

32-bit
64-bit
CF
P
P

Description:

This class is used to work with individual PDF or PS pages.

Declaration:

public sealed class ImGearPDFPage : ImageGear.Core.ImGearVectorPage

Members:

Properties
Name
Description
CropRectangle Property
Specifies the PDF page's crop rectangle (crop box).
Rotation Property
Specifies the PDF page's rotation value.

Methods
Name
Description
VerifyCompliance Method
Clones current page.
Dispose Method
Disposes page's unmanaged resources.
GetContent Method
Creates PDE Content object from the page contents and resources.
Rasterize Method
Rasterizes current page.
Rasterize Method
Rasterizes current PDF page.
ReleaseContent Method
Decrements page's PDE content internal reference count.
ResetDisplayCache Method
Causes IG display API to re-render PDF page content for display.
SetContent Method
Sets the page's PDE content back into the page object.

See Also:

ImGearVectorPage Class


ImGearPDFPage Properties

The ImGearPDFPage Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
CropRectangle Property
Specifies the PDF page's crop rectangle (crop box).
Rotation Property
Specifies the PDF page's rotation value.


CropRectangle Property

32-bit
64-bit
CF
P
P

Description:

This property specifies the PDF page's crop rectangle (crop box). The crop rectangle sets a visible part of the PDF page content for display and printing..

Declaration:

public ImageGear.Core.ImGearRectangle CropRectangle { get; }

Value:

ImGearRectangle Structure object.

Default value:

N/A

See Also:

ImGearRectangle Structure


Rotation Property

32-bit
64-bit
CF
P
P

Description:

This property specifies the PDF page's rotation value.

Declaration:

public ImageGear.Core.ImGearRotationValues Rotation { get; }

Value:

ImGearRotationValues Enumeration value

Default value:

N/A

See Also:

ImGearRotationValues Enumeration


ImGearPDFPage Methods

The ImGearPDFPage Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
Clone Method
Clones current page.
Dispose Method
Disposes page's unmanaged resources.
GetContent Method
Creates PDE Content object from the page contents and resources.
Rasterize Method
Rasterizes current page.
Rasterize Method
Rasterizes current PDF page.
ReleaseContent Method
Decrements page's PDE content internal reference count.
ResetDisplayCache Method
Causes IG display API to re-render PDF page content for display.
SetContent Method
Sets the page's PDE content back into the page object.


Clone Method

32-bit
64-bit
CF
P
P

Description:

This method clones current page.

Declaration:

public override ImageGear.Core.ImGearPage Clone ( )

Return Value:

ImGearPage Class object.

See Also:

ImGearPage Class


Dispose Method

32-bit
64-bit
CF
P
P

Description:

Disposes page's unmanaged resources.

Declaration:

public void Dispose (  )

Return Value:

None


GetContent Method

32-bit
64-bit
CF
P
P

Description:

Creates PDE Content object from the page contents and resources. The PDE content is cached, so that subsequent calls on the same page return the same PDF content.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEContent GetContent (  )

Return Value:

ImGearPDEContent Class object

See Also:

ImGearPDEContent Class


Rasterize Method

32-bit
64-bit
CF
P
P

Description:

This method rasterizes current page.

Declaration:

public override ImageGear.Core.ImGearRasterPage Rasterize()

Return Value:

ImGearRasterPage Class

See Also:

ImGearRasterPage Class


Rasterize Method

32-bit
64-bit
CF
P
P

Description:

This method rasterizes (converts to pixels) current PDF page.

Declaration:

public ImageGear.Core.ImGearRasterPage Rasterize(int BitDepth, int ResolutionX, int
ResolutionY)

Parameters:

Name
Type
Description
BitDepth
int
This parameter specifies bit depth in bits-per-pixel during the PDF document conversion into the raster image. The greater this value, the higher the quality of the raster image you get and the more memory required for rasterization. The DIB of the output raster image has this value as a bit count. (available values: 1, 8, 24)
ResolutionX
int
This parameter specifies the horizontal resolution in dots-per-inch during the PDF document conversion into a raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image has this value as an X resolution.
ResolutionY
int
This parameter specifies the vertical resolution in dots-per-inch during the PDF document conversion into the raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image has this value as an Y resolution.

Return Value:

ImGearRasterPage Class with rasterized vector data.


ReleaseContent Method

32-bit
64-bit
CF
P
P

Description:

Decrements page's PDE content internal reference count. The content is not automatically deleted when the reference count becomes zero - it remains in the cache until the cache slot is needed for another page. Thus, you do not need to keep a content acquired for performance reasons.

Declaration:

public void ReleaseContent (  )

Return Value:

None

See Also:

ImGearPDEContent Class


ResetDisplayCache Method

32-bit
64-bit
CF
P
P

Description:

This method causes IG display API to re-render PDF page content for display.

Declaration:

public void ResetDisplayCache ()

Return Value:

N/A

See Also:

AccuSoft Corporation
 AccuSoft.com
sales@accusoft.com


SetContent Method

32-bit
64-bit
CF
P
P

Description:

Sets the page's PDE content back into the page object, using the same compression filters with which the content was previously encoded.

Declaration:

public bool SetContent (  )

Return Value:

True, False

See Also:

ImGearPDEContent Class


ImGearPDFPreflight Class

32-bit
64-bit
CF
P
P

Description:

This class provides PDF preflight capabilities.

Declaration:

public sealed class ImGearPDFPreflight : ImageGear.Formats.PDF.ImGearPDF.Object

Members:

Constructor
Name
Description
ImGearPDFPreflight Constructor
Creates new preflight class for the specified PDF document.

Methods
Name
Description
VerifyCompliance Method
Analyzes the PDF document and determines whether the preflight was created in compliace with PDF/A and PDF/X standards.

See Also:

ImGearPDEObject Class


ImGearPDFPreflight Constructors

The ImGearPDFPreflight Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructor
Name
Description
ImGearPDFPreflight Constructor
Creates new preflight class for the specified PDF document.


ImGearPDFPreflight Constructor

32-bit
64-bit
CF
P
P

Description:

Creates new preflight class for the specified PDF document.

Declaration:

public ImGearPDFPreflight(ImageGear.Formats.PDF.ImGearPDFDocument Doc)

Parameters:

Name
Type
Description
Doc
ImGearPDFDictionary Class
The PDF document for which to create a preflight.

Return Value:

The new instance of ImGearPDFPreflight Class object.

See Also:

ImGearPDFDictionary Class


ImGearPDFPreflight Methods

The ImGearPDFPreflight Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
VerifyCompliance Method
Analyzes the PDF document and determines whether the preflight was created in compliace with PDF/A and PDF/X standards.


VerifyCompliance Method

32-bit
64-bit
CF
P
P

Description:

This method analyzes the PDF document the preflight was created for and checks it for compliance with PDF/A and PDF/X standards. The result is returned as an ImGearPDFPreflightReport object.

If the document is compliant with the specified profile, the output report's code value is equal to ImGearPDFPreflightReportCodes.SUCCESS.

If the document is not compliant, the output report's code value is equal to ImGearPDFPreflightReportCodes. INCOMPLIANT_DOCUMENT and its Records property will have a complete report of noncompliances.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFPreflightReport
VerifyCompliance(ImageGear.Formats.PDF.ImGearPDFPreflightProfile profile, int startPage,
int pageCount)

Parameters:

Name
Type
Description
profile
ImGearPDFPreflightProfile Enumeration
Preflight profile with which compliance is being verified.
startPage
int
The first page of the document to analyze.
pageCount
int
The number of pages to verify. Specify -1 to verify all pages.

Return Value:

Result of the verification as an ImGearPDFPreflightReport Class object.

See Also:

ImGearPDFPreflightReport Class

ImGearPDFPreflightProfile Enumeration


ImGearPDFPreflightReport Class

32-bit
64-bit
CF
P
P

Description:

This class contains a PDF preflight report in a tree form.

Declaration:

public sealed class ImGearPDFPreflightReport

Members:

Properties
Name
Description
Code Property
Preflight report code of the current report node.
Description Property
Description of the current report node.
Records Property
Array of child report nodes.


ImGearPDFPreflightReport Properties

The ImGearPDFPreflightReport Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
Code Property
Preflight report code of the current report node.
Description Property
Description of the current report node.
Records Property
Array of child report nodes.


Code Property

32-bit
64-bit
CF
P
P

Description:

Preflight report code of the current report node.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFPreflightReportCodes Code { get; }

Value:

ImGearPDFPreflightReportCodes Enumeration

See Also:

ImGearPDFPreflightReport Class

ImGearPDFPreflightReportCodes Enumeration


Description Property

32-bit
64-bit
CF
P
P

Description:

Description of the current report node.

Declaration:

public string Description { get; }

Value:

String

See Also:

ImGearPDFPreflightReport Class


Records Property

32-bit
64-bit
CF
P
P

Description:

Array of child report nodes.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFPreflightReport[] Records { get; }

Value:

ImGearPDFPreflightReport array

See Also:

ImGearPDFPreflightReport Class


ImGearPDFPrintOptions Class

32-bit
64-bit
CF
P
P

Description:

This class specifies options for the native PDF printing.

Declaration:

public sealed class ImGearPDFPrintOptions

Members:

Constructors
Name
Description
ImGearPDFPreflight Constructor
Creates new instance of ImGearPDFPrintOptions object.

Properties
Name
Description
BinaryOK Property
True turns on binary data, False turns it off.
DeviceName Property
Name of device to print to.
DevMode Property
Optional - allows you to pass a DEVMODE structure in if you have one.
DriverName Property
Name of the driver.
EmitHalftones Property
True turns on emit half-tones, False turns it off.
EndPage Property
Page to end printing on.
InFileName Property
Specifies name of the document.
OutFileName Property
Specifies the name of an output file.
PaperWidth Property
Width of paper in points.
PaperHeight Property
Height of paper in points.
PortName Property
Name of Port.
PrintAnnots Property
True turns on printing annotations, false turns it off.
Reverse Property
True reverses print order, false does regular order.
ShrinkToFit Property
True turns on shrink to fit, false turns it off.
StartPage Property
Page to start printing with, 0-based.
TransQuality Property
Transparency flattening quality - 1 is fastest, 5 is best.


ImGearPDFPrintOptions Constructors

The ImGearPDFPrintOptions Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDFPreflight Constructor
Creates new instance of ImGearPDFPrintOptions object.


ImGearPDFPrintOptions Constructor

32-bit
64-bit
CF
P
P

Description:

Creates a new instance of ImGearPDFPrintOptions object.

Declaration:

public ImGearPDFPrintOptions ()

Return Value:

New instance of ImGearPDFPrintOptions Class object.

See Also:

ImGearPDFPrintOptions Class


ImGearPDFPrintOptions Properties

The ImGearPDFPrintOptions Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
BinaryOK Property
True turns on binary data, False turns it off.
DeviceName Property
Name of device to print to.
DevMode Property
Optional - allows you to pass a DEVMODE structure in if you have one.
DriverName Property
Name of the driver.
EmitHalftones Property
True turns on emit half-tones, False turns it off.
EndPage Property
Page to end printing on.
InFileName Property
Specifies name of the document.
OutFileName Property
Specifies the name of an output file.
PaperWidth Property
Width of paper in points.
PaperHeight Property
Height of paper in points.
PortName Property
Name of Port.
PrintAnnots Property
True turns on printing annotations, false turns it off.
Reverse Property
True reverses print order, false does regular order.
ShrinkToFit Property
True turns on shrink to fit, false turns it off.
StartPage Property
Page to start printing with, 0-based.
TransQuality Property
Transparency flattening quality - 1 is fastest, 5 is best.


BinaryOK Property

32-bit
64-bit
CF
P
P

Description:

True turns on binary data, False turns it off.

Declaration:

public bool BinaryOK { get, set }

Value:

True, False

Default value:

N/A

See Also:

ImGearPDFPrintOptions Class


DeviceName Property

32-bit
64-bit
CF
P
P

Description:

Name of device to print to (available devices can be found in the Windows Registry at HKEY_CURRENT_USER\Software\Microsoft\WindowsNT
\CurrentVersion\Devices). PrinterSettings.PrinterName can be used to get a device name.

Declaration:

public string DeviceName { get; set }

Value:

The string name of the device.

See Also:

ImGearPDFPrintOptions Class


DevMode Property

32-bit
64-bit
CF
P
P

Description:

Optional - allows you to pass a DEVMODE structure in if you have one. If you do not pass in your own DEVMODE structure, a new one will be created based on the other properties.

Declaration:

public System.IntPtr DevMode { set; get; }

Value:

A pointer to Windows GDI DEVMODE structure.

Default value:

IntPtr.Zero

See Also:

ImGearPDFPrintOptions Class


DriverName Property

32-bit
64-bit
CF
P
P

Description:

Name of the driver (e.g., "winspool").

Declaration:

public string DriverName { get; set }

Value:

String name of the driver.

See Also:

ImGearPDFPrintOptions Class


EmitHalftones Property

32-bit
64-bit
CF
P
P

Description:

True turns on emit half-tones, False turns it off.

Declaration:

public bool EmitHalftones { get, set }

Value:

True, False

Default value:

N/A

See Also:

ImGearPDFPrintOptions Class


EndPage Property

32-bit
64-bit
CF
P
P

Description:

Page to end printing on.

Declaration:

public int EndPage { get; set }

Value:

The number of page.

See Also:

ImGearPDFPrintOptions Class


InFileName Property

32-bit
64-bit
CF
P
P

Description:

Specifies the name of the document.

Declaration:

public string InFileName { get; set }

Value:

The string name.

See Also:

ImGearPDFPrintOptions Class


OutFileName Property

32-bit
64-bit
CF
P
P

Description:

Specifies the name of an output file. If the string is empty, the output will be sent to the device identified by DeviceName, DriverName, and PortName.

Declaration:

public string OutFileName { get, set }

Value:

String name of an output file.

Default value:

N/A

See Also:

ImGearPDFPrintOptions Class


PaperWidth Property

32-bit
64-bit
CF
P
P

Description:

Width of paper in points.

Declaration:

public ushort PaperWidth { get; set }

Value:

Any ushort value.

See Also:

ImGearPDFPrintOptions Class


PaperHeight Property

32-bit
64-bit
CF
P
P

Description:

Height of paper in points.

Declaration:

public ushort PaperHeight { get; set }

Value:

Any ushort value.

See Also:

ImGearPDFPrintOptions Class


PortName Property

32-bit
64-bit
CF
P
P

Description:

Name of Port (e.g., "Ne00"). See registry key for DeviceName.

Declaration:

public string PortName { get; set }

Value:

The string name.

See Also:

ImGearPDFPrintOptions Class


PrintAnnots Property

32-bit
64-bit
CF
P
P

Description:

True turns on printing annotations; false turns it off.

Declaration:

public bool PrintAnnots { get; set }

Value:

True, false.

See Also:

ImGearPDFPrintOptions Class


Reverse Property

32-bit
64-bit
CF
P
P

Description:

True reverses print order; false specifies regular order.

Declaration:

public bool Reverse { get; set }

Value:

True, false.

See Also:

ImGearPDFPrintOptions Class


ShrinkToFit Property

32-bit
64-bit
CF
P
P

Description:

True turns on shrink to fit; false turns it off.

Declaration:

public bool ShrinkToFit { get; set }

Value:

True, false.

See Also:

ImGearPDFPrintOptions Class


StartPage Property

32-bit
64-bit
CF
P
P

Description:

Page to start printing (0-based).

Declaration:

public int StartPage { get; set }

Value:

Any integer value.

See Also:

ImGearPDFPrintOptions Class


TransQuality Property

32-bit
64-bit
CF
P
P

Description:

Transparency flattening quality (where 1 is fastest and 5 is best).

Declaration:

public int TransQuality { get; set }

Value:

Any int value.

See Also:

ImGearPDFPrintOptions Class


ImGearPDFSecurityData Class

32-bit
64-bit
CF
P
P

Description:

PDF security data object describes data for the standard security handler.

Declaration:

public sealed class ImGearPDFSecurityData

Members:

Constructors
Name
Description
ImGearPDFSecurityData Constructor
Create a new instance of ImGearPDFSecurityData object.

Properties
Name
Description
EncryptAttachmentsOnly Property
Flag to indicate that only Attachments are encrypted - EncryptMetadata and EncryptAttachmentsOnly cannot both be true.
EncryptMetadata Property
Flag that indicates whether document metadata will be encrypted.
EncryptMethod Property
Method of encryption for filters to use.
HasOwnerPW Property
True if the owner password is provided, False otherwise.
HasUserPW Property
True if the user password is provided, False otherwise.
KeyLength Property
Encryption key length in byte.
NewOwnerPW Property
True if the owner password should be changed, False otherwise.
NewUserPW Property
True if the user password should be changed, False otherwise.
OwnerPW Property
The owner password string.
Perms Property
Permissions to allow. An OR of the ImGearPDFPermsFlags values.
Revision Property
Indicates /R revision value.
UserPW Property
The user password string.


ImGearPDFSecurityData Constructors

The ImGearPDFSecurityData Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDFSecurityData Constructor
Create a new instance of ImGearPDFSecurityData object.


ImGearPDFSecurityData Constructor

32-bit
64-bit
CF
P
P

Description:

Creates a new instance of ImGearPDFSecurityData Class object.

Declaration:

public ImGearPDFSecurityData (  )

Return Value:

A new instance of ImGearPDFSecurityData Class object.

See Also:

ImGearPDFSecurityData Class


ImGearPDFSecurityData Properties

The ImGearPDFSecurityData Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
EncryptAttachmentsOnly Property
Flag to indicate that only Attachments are encrypted - EncryptMetadata and EncryptAttachmentsOnly cannot both be true.
EncryptMetadata Property
Flag that indicates whether document metadata will be encrypted.
EncryptMethod Property
Method of encryption for filters to use.
HasOwnerPW Property
True if the owner password is provided, False otherwise.
HasUserPW Property
True if the user password is provided, False otherwise.
KeyLength Property
Encryption key length in byte.
NewOwnerPW Property
True if the owner password should be changed, False otherwise.
NewUserPW Property
True if the user password should be changed, False otherwise.
OwnerPW Property
The owner password string.
Perms Property
Permissions to allow. An OR of the ImGearPDFPermsFlags values.
Revision Property
Indicates /R revision value.
UserPW Property
The user password string.


EncryptAttachmentsOnly Property

32-bit
64-bit
CF
P
P

Description:

Flag to indicate that only Attachments are encrypted - EncryptMetadata and EncryptAttachmentsOnly cannot both be true.

Declaration:

public bool EncryptAttachmentsOnly { get, set }

Value:

True, False

Default value:

False


EncryptMetadata Property

32-bit
64-bit
CF
P
P

Description:

Flag that indicates whether document metadata will be encrypted.

Declaration:

public bool EncryptMetadata { get, set }

Value:

True, False

Default value:

False


EncryptMethod Property

32-bit
64-bit
CF
P
P

Description:

Method of encryption for filters to use. One of the ImGearPDFStdSecurityMethod values.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFStdSecurityMethod EncryptMethod{ get, set }

Value:

ImGearPDFStdSecurityMethod Enumeration value.

Default value:

N/A

See Also:

ImGearPDFStdSecurityMethod Enumeration


HasOwnerPW Property

32-bit
64-bit
CF
P
P

Description:

True if the owner password is provided, False otherwise.

Declaration:

public bool HasOwnerPW { get, set }

Value:

True, False

Default value:

False


HasUserPW Property

32-bit
64-bit
CF
P
P

Description:

True if the user password is provided, False otherwise.

Declaration:

public bool HasUserPW { get, set }

Value:

True, False

Default value:

False


KeyLength Property

32-bit
64-bit
CF
P
P

Description:

Encryption key length in byte.

Declaration:

public int KeyLength { get, set }

Value:

Integer value

Default value:

N/A


NewOwnerPW Property

32-bit
64-bit
CF
P
P

Description:

True if the owner password should be changed, False otherwise.

Declaration:

public bool NewOwnerPW { get, set }

Value:

True, False

Default value:

False


NewUserPW Property

32-bit
64-bit
CF
P
P

Description:

True if the user password should be changed, False otherwise.

Declaration:

public bool NewUserPW { get, set }

Value:

True, False

Default value:

False


OwnerPW Property

32-bit
64-bit
CF
P
P

Description:

The owner password string.

Declaration:

public string OwnerPW { get, set }

Value:

String

Default value:

N/A


Perms Property

32-bit
64-bit
CF
P
P

Description:

Permissions to allow. An OR of the ImGearPDFPermsFlags values.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFPermsFlags Perms { get, set }

Value:

ImGearPDFPermsFlags Enumeration value.

Default value:

N/A

See Also:

ImGearPDFPermsFlags Enumeration


Revision Property

32-bit
64-bit
CF
P
P

Description:

Indicates /R revision value.

Declaration:

public int Revision { get, set }

Value:

Integer value

Default value:

N/A


UserPW Property

32-bit
64-bit
CF
P
P

Description:

The user password string.

Declaration:

public string UserPW { get, set }

Value:

Password string.

Default value:

N/A


ImGearPDFStream Class

32-bit
64-bit
CF
P
P

Description:

A data stream that may be a buffer in memory, or an arbitrary user-written procedure. Typically used to extract or provide data.

Declaration:

public class ImGearPDFStream : ImageGear.Formats.PDF.ImGearPDFObject

Members:

Constructors
Name
Description
ImGearPDFStream Constructor
Creates the new instance of ImGearPDFStream object.
ImGearPDFStream Constructor
Creates the new instance of ImGearPDFStream object.
ImGearPDFStream Constructor
Creates the new instance of ImGearPDFStream object.

Methods
Name
Description
Flush Method
Flushes any buffered data to the specified stream.
Read Method
Reads data from the stream into memory.
Write Method
Reads data from memory buffer to the stream.

Delegates
Name
Description
ImGearPDFStreamCleanUp Delegate
Delegate describing PDF stream clean up routine.
ImGearPDFStreamReader Delegate
Delegate describing PDF stream reader.
ImGearPDFStreamWriter Delegate
Delegate describing PDF stream writer.


ImGearPDFStream Constructors

The ImGearPDFStream Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDFStream Constructor
Creates the new instance of ImGearPDFStream object.
ImGearPDFStream Constructor
Creates the new instance of ImGearPDFStream object.
ImGearPDFStream Constructor
Creates the new instance of ImGearPDFStream object.


ImGearPDFStream Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates the new instance of ImGearPDFStream object.

Declaration:

public ImGearPDFStream ( ImageGear.Formats.PDF.ImGearPDFStream.ImGearPDFStreamReader
Reader , System.Object ClientData )

Parameters:

Name
Type
Description
Reader
ImGearPDFStreamReader Delegate
PDF stream reader routine.
ClientData
System.Object
Client data.

Return Value:

The new instance of ImGearPDFStream Class object.

See Also:

ImGearPDFStream Class

ImGearPDFStreamReader Delegate


ImGearPDFStream Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates the new instance of ImGearPDFStream object.

Declaration:

public ImGearPDFStream ( ImageGear.Formats.PDF.ImGearPDFStream.ImGearPDFStreamWriter
Writer , ImageGear.Formats.PDF.ImGearPDFStream.ImGearPDFStreamCleanUp CleanUp ,
System.Object ClientData )

Parameters:

Name
Type
Description
Writer
ImGearPDFStreamWriter Delegate
PDF stream writer routine.
CleanUp
ImGearPDFStreamCleanUp Delegate
PDF stream clean up routine.
ClientData
System.Object
Client data.

Return Value:

The new instance of ImGearPDFStream Class object.

See Also:

ImGearPDFStream Class

ImGearPDFStreamCleanUp Delegate

ImGearPDFStreamWriter Delegate


ImGearPDFStream Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates the new instance of ImGearPDFStream object.

Declaration:

public ImGearPDFStream ( byte[] ByteArray )

Parameters:

Name
Type
Description
ByteArray
byte[]
Memory buffer to create PDF stream from.

Return Value:

The new instance of ImGearPDFStream Class object.

See Also:

ImGearPDFStream Class


ImGearPDFStream Methods

The ImGearPDFStream Class of the ImageGear.Formats.PDF Namespace has the following Methods:

Methods
Name
Description
Flush Method
Flushes any buffered data to the specified stream.
Read Method
Reads data from the stream into memory.
Write Method
Reads data from memory buffer to the stream.


Flush Method

32-bit
64-bit
CF
P
P

Description:

Flushes any buffered data to the specified stream.

Declaration:

public int Flush (  )

Return Value:

0 if successful, otherwise non-zero.

See Also:

ImGearPDFStream Class


Read Method

32-bit
64-bit
CF
P
P

Description:

Reads data from the stream into memory.

Declaration:

public byte[] Read ( int Items , int ItemSize )

Parameters:

Name
Type
Description
Items
int
Number of items to read. The amount of data read into the memory buffer will be Items × ItemSize, unless an EOF is encountered first.
The relative values of Items and ItemSize really do not matter; the only thing that matters is their product. It is often convenient to set ItemSize to 1, so that Items is the number of bytes to read.
ItemSize
int
Number of bytes in an item in the stream.

Return Value:

ImageGear integer array which contains stream data.

See Also:

ImGearPDFStream Class


Write Method

32-bit
64-bit
CF
P
P

Description:

Reads data from memory buffer to the stream.

Declaration:

public void Write ( byte[] Data , int Items , int ItemSize )

Parameters:

Name
Type
Description
Data
byte[]
Buffer.
Items
int
Number of items to write. The amount of data written into the memory buffer will be Items × ItemSize.
The relative values of Items and ItemSize really do not matter; the only thing that matters is their product. It is often convenient to set ItemSize to 1, so that Items is the number of bytes to write.
ItemSize
int
Number of bytes in an item.

Return Value:

None

See Also:

ImGearPDFStream Class


ImGearPDFStream Delegates

The ImGearPDFStream Class of the ImageGear.Formats.PDF Namespace has the following delegates:

Delegates
Name
Description
ImGearPDFStreamCleanUp Delegate
Delegate describing PDF stream clean up routine.
ImGearPDFStreamReader Delegate
Delegate describing PDF stream reader.
ImGearPDFStreamWriter Delegate
Delegate describing PDF stream writer.


ImGearPDFStreamCleanUp Delegate

32-bit
64-bit
CF
P
P

Description:

Delegate describing PDF stream clean up routine.

Declaration:

public sealed delegate ImGearPDFStream.ImGearPDFStreamCleanUp : System.MulticastDelegate

Return Value:

N/A

See Also:

ImGearPDFStream Class


ImGearPDFStreamReader Delegate

32-bit
64-bit
CF
P
P

Description:

Delegate describing PDF stream reader.

Declaration:

public sealed delegate ImGearPDFStream.ImGearPDFStreamReader : System.MulticastDelegate

Return Value:

N/A

See Also:

ImGearPDFStream Class


ImGearPDFStreamWriter Delegate

32-bit
64-bit
CF
P
P

Description:

Delegate describing PDF stream writer.

Declaration:

public sealed delegate ImGearPDFStream.ImGearPDFStreamWriter : System.MulticastDelegate

Return Value:

N/A

See Also:

ImGearPDFStream Class


ImGearPDFStyle Class

32-bit
64-bit
CF
P
P

Description:

PDF style object provides access to information about the fonts, font sizes, and colors used in a Word.

Declaration:

public sealed class ImGearPDFStyle : ImageGear.Formats.PDF.ImGearPDFObject

Members:

Properties
Name
Description
FontSize Property
A style's font size.


ImGearPDFStyle Properties

The ImGearPDFStyle Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
FontSize Property
A style's font size.


FontSize Property

32-bit
64-bit
CF
P
P

Description:

A style's font size.

Declaration:

public int FontSize { get }

Value:

Integer value

Default value:

N/A

See also:

ImGearPDFStyle Class


ImGearPDFSysEncoding Class

32-bit
64-bit
CF
P
P

Description:

System encoding object provides system encoding for a PDF file.

Declaration:

public sealed class ImGearPDFSysEncoding : ImageGear.Formats.PDF.ImGearPDEObject

Members:

Constructors
Name
Description
ImGearPDFSysEncoding Constructor
Creates new instance of ImGearPDFSysEncoding object.
ImGearPDFSysEncoding Constructor
Creates new instance of ImGearPDFSysEncoding object.
ImGearPDFSysEncoding Constructor
Creates new instance of ImGearPDFSysEncoding object.

Properties
Name
Description
IsIdentity Property
True for Identity-H or Identity-V encoding; false otherwise.
IsMultiByte Property
True for CMap encoding; false otherwise.
WritingMode Property
Writing mode (horizontal or vertical).


ImGearPDFSysEncoding Constructors

The ImGearPDFSysEncoding Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDFSysEncoding Constructor
Creates new instance of ImGearPDFSysEncoding object.
ImGearPDFSysEncoding Constructor
Creates new instance of ImGearPDFSysEncoding object.
ImGearPDFSysEncoding Constructor
Creates new instance of ImGearPDFSysEncoding object.


ImGearPDFSysEncoding Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates an encoding object from a code page..

Declaration:

public ImGearPDFSysEncoding ( ImageGear.Formats.PDF.ImGearPDFCodePages CodePage , short
WritingMode )

Parameters:

Name
Type
Description
CodePage
ImGearPDFCodePages Enumeration
The code page character-mapping construct.
WritingMode
short
0 for horizontal writing, 1 for vertical writing.

Return Value:

The new instance of ImGearPDFSysEncoding Class object.

See Also:

ImGearPDFSysEncoding Class

ImGearPDFCodePages Enumeration


ImGearPDFSysEncoding Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates an encoding object from a PDF CMap name.

Declaration:

public ImGearPDFSysEncoding ( ImageGear.Formats.PDF.ImGearPDFAtom CMapName )

Parameters:

Name
Type
Description
CMapName
ImGearPDFAtom Class
The CMap name.

Return Value:

The new instance of ImGearPDFSysEncoding Class object.

See Also:

ImGearPDFSysEncoding Class

ImGearPDFAtom Class


ImGearPDFSysEncoding Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates an encoding object from base name.

Declaration:

public ImGearPDFSysEncoding ( ImageGear.Formats.PDF.ImGearPDFAtom BaseEncName , string[]
DiffEnc )

Parameters:

Name
Type
Description
BaseEncName
ImGearPDFAtom Class
The base encoding. See Section 5.5.5 in the PDF Reference.
DiffEnc
string[]
Array of 256 Strings describing the differences from the encoding specified by BaseName. May be NULL.

Return Value:

The new instance of ImGearPDFSysEncoding Class object.

See Also:

ImGearPDFSysEncoding Class

ImGearPDFAtom Class


ImGearPDFSysEncoding Properties

The ImGearPDFSysEncoding Class of the ImageGear.Formats.PDF Namespace has the following Properties:

Properties
Name
Description
IsIdentity Property
True for Identity-H or Identity-V encoding; false otherwise.
IsMultiByte Property
True for CMap encoding; false otherwise.
WritingMode Property
Writing mode (horizontal or vertical).


IsIdentity Property

32-bit
64-bit
CF
P
P

Description:

True for Identity-H or Identity-V encoding; false otherwise.

Declaration:

public bool IsIdentity { get }

Value:

True, False

Default value:

N/A


IsMultiByte Property

32-bit
64-bit
CF
P
P

Description:

True for CMap encoding; false otherwise.

Declaration:

public bool IsMultiByte { get }

Value:

True, False

Default value:

N/A


WritingMode Property

32-bit
64-bit
CF
P
P

Description:

Writing mode. 0 for horizontal writing and 1 for vertical writing.

Declaration:

public short WritingMode { get }

Value:

Integer value

Default value:

N/A


ImGearPDFSysFont Class

32-bit
64-bit
CF
P
P

Description:

This is a reference to a font installed in the host system. System font methods allow you to list the fonts available in the host system and to find a font in the system that matches a PDE Font, if it is present.

Declaration:

public sealed class ImGearPDFSysFont : ImageGear.Formats.PDF.ImGearPDEObject

Members:

Properties
Name
Description
CIDOrdering Property
The ordering information of a multi-byte system font.
CIDRegistry Property
The registry information of a multi-byte system font.
CIDSupplement Property
The supplement information of a multi-byte system font.
Name Property
The PostScript or TrueType styled name for a system font.

Methods
Name
Description
Enumerate Method
Enumerates system fonts.
FindSysFont Method
Finds a system font that matches the requested attributes.
FindSysFont Method
Finds a system font that matches the requested attributes.
GetAttributes Method
Gets the attributes of a system font.
GetCreateFlags Method
Obtains create flags that can be passed to the PDE font creation routine.
GetInfo Method
Gets high-level information about a system font.
GetWidths Method
Gets the widths of a single byte encoded system font.

Delegates
Name
Description
ImGearPDFSysFontEnumerate Delegate
Delegate describing sysfont enumeration routine.


ImGearPDFSysFont Properties

The ImGearPDFSysFont Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
CIDOrdering Property
The ordering information of a multi-byte system font.
CIDRegistry Property
The registry information of a multi-byte system font.
CIDSupplement Property
The supplement information of a multi-byte system font.
Name Property
The PostScript or TrueType styled name for a system font.


CIDOrdering Property

32-bit
64-bit
CF
P
P

Description:

The ordering information of a multi-byte system font.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom CIDOrdering { get }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFAtom Class


CIDRegistry Property

32-bit
64-bit
CF
P
P

Description:

The registry information of a multi-byte system font.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom CIDRegistry { get }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFAtom Class


CIDSupplement Property

32-bit
64-bit
CF
P
P

Description:

The supplement information of a multi-byte system font.

Declaration:

public int CIDSupplement { get }

Value:

Integer value

Default value:

N/A


Name Property

32-bit
64-bit
CF
P
P

Description:

The PostScript or TrueType styled name for a system font.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFAtom Name { get }

Value:

ImGearPDFAtom Class object.

Default value:

N/A

See Also:

ImGearPDFAtom Class


ImGearPDFSysFont Methods

The ImGearPDFSysFont Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
Enumerate Method
Enumerates system fonts.
FindSysFont Method
Finds a system font that matches the requested attributes.
FindSysFont Method
Finds a system font that matches the requested attributes.
GetAttributes Method
Gets the attributes of a system font.
GetCreateFlags Method
Obtains create flags that can be passed to the PDE font creation routine.
GetInfo Method
Gets high-level information about a system font.
GetWidths Method
Gets the widths of a single byte encoded system font.


Enumerate Method

32-bit
64-bit
CF
P
P

Description:

Enumerates all of the system fonts with EnumerateProc.

The SysFont parameters must be copied during the enumeration if they are needed beyond the EnumerateProc.

Developers should not assume that the EnumerateProc will get called. If no system fonts are found, EnumerateProc is never called.

Declaration:

public static void Enumerate (
ImageGear.Formats.PDF.ImGearPDFSysFont.ImGearPDFSysFontEnumerate EnumerateProc ,
System.Object ClientData )

Parameters:

Name
Type
Description
EnumerateProc
ImGearPDFSysFontEnumerate Delegate
SysFont enumeration procedure.
ClientData
System.Object
Client data.

Return Value:

None

See Also:

ImGearPDFAtom Class

ImGearPDFSysFontEnumerate Delegate


FindSysFont Method

32-bit
64-bit
CF
P
P

Description:

Finds a system font that matches the requested attributes.

Declaration:

public static ImageGear.Formats.PDF.ImGearPDFSysFont FindSysFont (
ImageGear.Formats.PDF.ImGearPDEFont Font ,
ImageGear.Formats.PDF.ImGearPDESysFontMatchFlags Flags )

Parameters:

Name
Type
Description
Font
ImGearPDEFont Class
A PDE Font whose matching system font is found.
Flags
ImGearPDESysFontMatchFlags Enumeration
Bit field comprised of enumImGearPDFSysFontMatchFlags values. Passing zero matches font by name only.

Return Value:

ImGearPDFSysFont Class object.

See Also:

ImGearPDFAtom Class

ImGearPDFSysFont Class

ImGearPDEFont Class

ImGearPDESysFontMatchFlags Enumeration


FindSysFont Method

32-bit
64-bit
CF
P
P

Description:

Finds a system font that matches the requested attributes.

Declaration:

public static ImageGear.Formats.PDF.ImGearPDFSysFont FindSysFont (
ImageGear.Formats.PDF.ImGearPDEFontAttrs Attributes ,
ImageGear.Formats.PDF.ImGearPDESysFontMatchFlags Flags )

Parameters:

Name
Type
Description
Attributes
ImGearPDEFontAttrs Class
ImGearPDEFontAttrs for the font attributes.
Flags
ImGearPDESysFontMatchFlags Enumeration
Bit field comprised of enumImGearPDFSysFontMatchFlags values. Passing zero matches font by name only.

Return Value:

ImGearPDFSysFont Class object.

See Also:

ImGearPDFAtom Class

ImGearPDFSysFont Class

ImGearPDEFontAttrs Class

ImGearPDESysFontMatchFlags Enumeration


GetAttributes Method

32-bit
64-bit
CF
P
P

Description:

Gets the attributes of a system font.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEFontAttrs GetAttributes (  )

Return Value:

ImGearPDEFontAttrs Class object.

See Also:

ImGearPDFAtom Class

ImGearPDFSysFont Class

ImGearPDEFontAttrs Class

ImGearPDESysFontMatchFlags Enumeration


GetCreateFlags Method

32-bit
64-bit
CF
P
P

Description:

Obtains create flags that can be passed to the PDE font creation routine. If the combination of the current SysFont and SysEncoding is not allowed, it is set to CREATE_NOT_ALLOWED.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEFontCreateFlags GetCreateFlags (
ImageGear.Formats.PDF.ImGearPDFSysEncoding SysEncoding )

Parameters:

Name
Type
Description
SysEncoding
ImGearPDFSysEncoding Class
A SysEncoding object.

Return Value:

Obtains create flags that can be passed to the PDE font creation routine.

See Also:

ImGearPDFAtom Class

ImGearPDFSysFont Class

ImGearPDEFontCreateFlags Enumeration

ImGearPDFSysEncoding Class


GetInfo Method

32-bit
64-bit
CF
P
P

Description:

Gets high-level information about a system font.

Declaration:

public ImageGear.Formats.PDF.ImGearPDEFontInfo GetInfo (  )

Return Value:

ImGearPDEFontInfo Class object

See Also:

ImGearPDFAtom Class

ImGearPDFSysFont Class

ImGearPDEFontAttrs Class

ImGearPDEFontInfo Class


GetWidths Method

32-bit
64-bit
CF
P
P

Description:

Gets the widths of a single byte encoded system font.Gets the widths of a single byte encoded system font.

Declaration:

public short[] GetWidths ( int[] MMDesignVector )

Parameters:

Name
Type
Description
MMDesignVector
int[]

Return Value:

ImageGear integer array of the widths of a single byte encoded system font.

See Also:

ImGearPDFAtom Class

ImGearPDFSysFont Class

ImGearPDEFontAttrs Class

ImGearPDEFontInfo Class


ImGearPDFSysFont Delegates

The ImGearPDFSysFont Class of the ImageGear.Formats.PDF Namespace has the following delegates:

Delegates
Name
Description
ImGearPDFSysFontEnumerate Delegate
Delegate describing sysfont enumeration routine.


ImGearPDFSysFontEnumerate Delegate

32-bit
64-bit
CF
P
P

Description:

Delegate describing sysfont enumeration routine.

Declaration:

public sealed delegate ImGearPDFSysFont.ImGearPDFSysFontEnumerate :
System.MulticastDelegate

See Also:

ImGearPDFSysFont Class


ImGearPDFWord Class

32-bit
64-bit
CF
P
P

Description:

A word in a PDF file. Each word contains a sequence of characters in one or more styles (see ImGearPDFStyle).

Declaration:

public sealed class ImGearPDFWord : ImageGear.Formats.PDF.ImGearPDFObject

Members:

Properties
Name
Description
CharOffset Property
A word's character offset from the beginning of its page.
Length Property
The number of bytes in a word.
QuadCount Property
The number of quads in a word.
String Property
Gets a word's text and also converts ligatures to their constituent characters.

Methods
Name
Description
GetCharStyle Method
Returns a PDF Style object for the specified style in a word.
GetQuad Method
The specified word's quad, specified in user space coordinates.
GetStyleTransition Method
Gets the locations of style transitions in a word.


ImGearPDFWord Properties

The ImGearPDFWord Class of the ImageGear.Formats.PDF Namespace has the following properties:

Properties
Name
Description
CharOffset Property
A word's character offset from the beginning of its page.
Length Property
The number of bytes in a word.
QuadCount Property
The number of quads in a word.
String Property
Gets a word's text and also converts ligatures to their constituent characters.


CharOffset Property

32-bit
64-bit
CF
P
P

Description:

A word's character offset from the beginning of its page.

Declaration:

public int CharOffset { get }

Value:

Integer value

Default value:

N/A


Length Property

32-bit
64-bit
CF
P
P

Description:

The number of bytes in a word. This property also works on non-Roman systems.

Declaration:

public int Length { get }

Value:

Integer value

Default value:

N/A


QuadCount Property

32-bit
64-bit
CF
P
P

Description:

The number of quads in a word.

A quad is a quadrilateral bounding a contiguous piece of a word. Every word has at least one quad. A word has more than one quad, for example, if it is hyphenated and split across multiple lines or if the word is set on a curve rather than on a straight line.

Declaration:

public int QuadCount { get }

Value:

Integer value

Default value:

N/A


String Property

32-bit
64-bit
CF
P
P

Description:

Gets a word's text and also converts ligatures to their constituent characters. The string to return includes any word break characters (such as space characters) that follow the word, but not any that precede the word. The characters that are treated as word breaks are defined in the EncInfo parameter of ImGearPDFWordFinder constructor.

This method produces a string in whatever encoding the PDF Word uses, for both Roman and non-Roman systems.

Declaration:

public string String { get }

Value:

Text string

Default value:

N/A


ImGearPDFWord Methods

The ImGearPDFWord Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
GetCharStyle Method
Returns a PDF Style object for the specified style in a word.
GetQuad Method
The specified word's quad, specified in user space coordinates.
GetStyleTransition Method
Gets the locations of style transitions in a word.


GetCharStyle Method

32-bit
64-bit
CF
P
P

Description:

Returns a PDF Style object for the specified style in a word.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFStyle GetCharStyle (
ImageGear.Formats.PDF.ImGearPDFWordFinder WordFinder , int Index )

Parameters:

Name
Type
Description
WordFinder
ImGearPDFWordFinder Class
A word finder object.
Index
int
The index of the style to obtain. The first style in a word has an index of zero.

Return Value:

ImGearPDFStyle Class object.

See Also:

ImGearPDFStyle Class

ImGearPDFWordFinder Class


GetQuad Method

32-bit
64-bit
CF
P
P

Description:

The specified word's quad, specified in user space coordinates. See QuadCount property for a description of a quad.

The quad's height is the height of the font's bounding box, not the height of the tallest character used in the word. The font's bounding box is determined by the glyphs in the font that extend farthest above and below the baseline; it often extends somewhat above the top of "A" and below the bottom of "y."

The quad's width is determined from the characters actually present in the word.

As an example, the quads for the words "AWAY" and "away" have the same height, but generally do not have the same width unless the font is a mono-spaced font (a font in which all characters have the same width).

Declaration:

public ImageGear.Formats.PDF.ImGearPDFFixedQuad GetQuad ( int Index )

Parameters:

Name
Type
Description
Index
int
The index of the quad to obtain. The first quad in a word has an index of zero.

Return Value:

ImGearPDFFixedQuad Class object

See Also:

ImGearPDFFixedQuad Class

ImGearPDFWordFinder Class


GetStyleTransition Method

32-bit
64-bit
CF
P
P

Description:

Gets the locations of style transitions in a word. Every word has at least one style transition, at character position zero in the word.

Declaration:

public int GetStyleTransition ( short[] TransTable , int Size )

Parameters:

Name
Type
Description
TransTable
short[]
Style transitions in a word.
Size
int
Number of entries requested for the locations of style transitions. The word is searched only until this number of style transitions has been found.

Return Value:

The locations of style transitions in a word.

See Also:

ImGearPDFStyle Class

ImGearPDFWordFinder Class


ImGearPDFWordFinder Class

32-bit
64-bit
CF
P
P

Description:

PDF word finder object extracts words from a PDF file, and enumerates the words on a single page or on all pages in a document.

Declaration:

public sealed class ImGearPDFWordFinder : ImageGear.Formats.PDF.ImGearPDFObject

Members:

Constructors
Name
Description
ImGearPDFWordFinder Constructor
Creates a word finder that is used to extract text in the host encoding from a PDF file.
ImGearPDFWordFinder Constructor
Creates a word finder that is used to extract text in the host encoding from a PDF file.

Methods
Name
Description
AcquireWordList Method
Finds all words on the specified page.
GetWord Method
Gets the word in the word list obtained using AcquireWordList.
ReleaseWordList Method
Releases the word list for a given page.


ImGearPDFWordFinder Constructors

The ImGearPDFWordFinder Class of the ImageGear.Formats.PDF Namespace has the following constructors:

Constructors
Name
Description
ImGearPDFWordFinder Constructor
Creates a word finder that is used to extract text in the host encoding from a PDF file.
ImGearPDFWordFinder Constructor
Creates a word finder that is used to extract text in the host encoding from a PDF file.


ImGearPDFWordFinder Constructor

32-bit
64-bit
CF
P
P

Description:

Creates a word finder that is used to extract text in the host encoding from a PDF file.

NOTE: The word finder also extracts text from Form XObjects that are executed in the page contents. For information about Form XObjects, see Section 4.9 in the PDF Reference.

Declaration:

public ImGearPDFWordFinder ( ImageGear.Formats.PDF.ImGearPDFDocument Doc ,
ImageGear.Formats.PDF.ImGearPDFWordFinderVersion AlgVersion ,
ImageGear.Formats.PDF.ImGearPDFContextFlags Flags )

Parameters:

Name
Type
Description
Doc
ImGearPDFDocument Class
PDF document to fine wrods in.
AlgVersion
ImGearPDFWordFinderVersion Enumeration
The version of the word-finding algorithm to use.
Flags
ImGearPDFContextFlags Enumeration
Word-finding options that determine the tables filled when using ImGearPDFWordFinder.AcquireWordList. Must be an OR of one or more of enumImGearPDFWordFlags.

Return Value:

The new instance of ImGearPDFWordFinder Class object.

See Also:

ImGearPDFWordFinder Class

ImGearPDFDictionary Class

ImGearPDFWordFinderVersion Enumeration

ImGearPDFContextFlags Enumeration


ImGearPDFWordFinder Constructor

32-bit
64-bit
CF
P
P

Description:

Creates a word finder that is used to extract text in the host encoding from a PDF file.

NOTE: The word finder also extracts text from Form XObjects that are executed in the page contents. For information about Form XObjects, see Section 4.9 in the PDF Reference.

This method also works for non-Roman (CJK or Chinese-Japanese-Korean) viewers. In this case, words are extracted to the host encoding.

The type of WordFinder determines the encoding of the string returned by ImGearPDFWord.String.

For CJK viewers, words are stored internally using CID encoding. For more information on CIDFonts and related topics, see Section 5.6 in the PDF Reference. For detailed information on CIDFonts, see Technical Note #5092, CID-Keyed Font Technology Overview, and Technical Note #5014, Adobe CMap and CIDFont Files Specification.

Declaration:

public ImGearPDFWordFinder ( ImageGear.Formats.PDF.ImGearPDFDocument Doc , short[] EncInfo
, string[] EncVec , string[] LigatureTbl ,
ImageGear.Formats.PDF.ImGearPDFWordFinderVersion AlgVersion ,
ImageGear.Formats.PDF.ImGearPDFContextFlags Flags )

Parameters:

Name
Type
Description
Doc
ImGearPDFDocument Class
PDF document to find words in.
EncInfo
short[]
Array of 256 flags, specifying the type of character at each position in the encoding. Each flag is an OR of the Character Type Codes.
If EncInfo is NULL, the platform's default encoding info is used. Use EncInfo and EncInfo together; for every EncInfo use a corresponding EncVec to specify the character at that position in the encoding.
EncVec
string[]
Array of 256 null-terminated strings that are the glyph names in encoding order. See the discussion of character names in Section 5.3 of the PostScript Language Reference Manual, Third Edition.
If EncVec is NULL, the platform's default encoding vector is used.
Use this parameter with EncInfo.
LigatureTbl
string[]
A null-terminated array of null-terminated strings. Each string is the glyph name of a ligature in the font. When a word contains a ligature, the glyph name of the ligature is substituted for the ligature (for example, ff is substituted for the ff ligature).
If ligatureTbl is NULL, a default ligature table is used, containing the following ligatures: fi, ff, fl, ffi, ffl, ch, cl, ct, ll, ss, fs, st, oe, OE.
AlgVersion
ImGearPDFWordFinderVersion Enumeration
The version of the word-finding algorithm to use.
Flags
ImGearPDFContextFlags Enumeration
Word-finding options that determine the tables filled when using ImGearPDFWordFinder.AcquireWordList. Must be an OR of one or more of enumImGearPDFWordFlags.

Return Value:

The new instance of ImGearPDFWordFinder Class object.

See Also:

ImGearPDFWordFinder Class

ImGearPDFDictionary Class

ImGearPDFWordFinderVersion Enumeration

ImGearPDFContextFlags Enumeration


ImGearPDFWordFinder Methods

The ImGearPDFWordFinder Class of the ImageGear.Formats.PDF Namespace has the following methods:

Methods
Name
Description
AcquireWordList Method
Finds all words on the specified page.
GetWord Method
Gets the word in the word list obtained using AcquireWordList.
ReleaseWordList Method
Releases the word list for a given page.


AcquireWordList Method

32-bit
64-bit
CF
P
P

Description:

Finds all words on the specified page. Only words within or partially within the page's crop box are enumerated. Words outside the crop box are skipped. There can be only one word list in existence at a time; clients must release the previous word list, using ImGearPDFWordFinder.ReleaseWordList, before creating a new one.

Declaration:

public int AcquireWordList ( int PageNumber )

Parameters:

Name
Type
Description
PageNumber
int
The page number for which words are found. First page is 0.

Return Value:

Word count.

See Also:

ImGearPDFWordFinder Class

ImGearPDFDictionary Class

ImGearPDFWordFinderVersion Enumeration

ImGearPDFContextFlags Enumeration


GetWord Method

32-bit
64-bit
CF
P
P

Description:

Gets the word in the word list obtained using AcquireWordList.

Declaration:

public ImageGear.Formats.PDF.ImGearPDFWord GetWord (
ImageGear.Formats.PDF.ImGearPDFContextFlags Flags , int WordNumber )

Parameters:

Name
Type
Description
Flags
ImGearPDFContextFlags Enumeration
Word-finding options. Must be an OR of one or more of ImGearPDFContextFlags.
WordNumber
int
The index of the word to obtain. The first word on a page has an index of zero. Words are counted in PDF order.

Return Value:

ImGearPDFWord Class object

See Also:

ImGearPDFWord Class

ImGearPDFDictionary Class

ImGearPDFWordFinderVersion Enumeration

ImGearPDFContextFlags Enumeration


ReleaseWordList Method

32-bit
64-bit
CF
P
P

Description:

Releases the word list for a given page. Use this to release a list created by AcquireWordList when you are done using this list.

Declaration:

public void ReleaseWordList ( int PageNumber )

Parameters:

Name
Type
Description
PageNumber
int
The page number for which the word list is released.

Return Value:

None

See Also:

ImGearPDFWordFinder Class

ImGearPDFDictionary Class

ImGearPDFWordFinderVersion Enumeration

ImGearPDFContextFlags Enumeration


ImageGear.Formats.PDF Namespace Enumerations

The ImageGear.Formats.PDF Namespace has the following enumeration members:

Enumerations:
Name
Description
ImGearPDEContentFlags Enumeration
Bit field for ImGearPDEContentAttrs Class.
ImGearPDEElementCopyFlags Enumeration
Bitfield for PDE element copy.
ImGearPDEFontCreateFlags Enumeration
Flags for PDE font creation routine.
ImGearPDEFontCreateNeedFlags Enumeration
Flags for PDE Font CreateNeedFlags.
ImGearPDEFontFlags Enumeration
Constants that indicate a font's attributes (fixed width, roman or symbolic, sans serif, and so forth).
ImGearPDEFontProtection Enumeration
Setting for disabling font embedding.
ImGearPDEGraphicStateWasSetFlags Enumeration
Structure describing the graphics state that was set.
ImGearPDEImageAttrFlags Enumeration
Flags for AT_PDE_IMAGEATTRS/ImGearPDEImageAttrs.
ImGearPDEImageDataFlags Enumeration
Image Data Flags.
ImGearPDEInsertElement Enumeration
Used for inserting a PDE element into the content.
ImGearPDEPathElementType Enumeration
Constant values that describe path segment operators in PDE path elements.
ImGearPDEPathOpFlags Enumeration
Flags for paint operators in a PDE path.
ImGearPDEPSAttrFlags Enumeration
Flags for ImGearPDEPSAttrs Class.
ImGearPDESoftMaskCreateFlags Enumeration
Flags for use with SoftMask create.
ImGearPDESysFontMatchFlags Enumeration
Font matching flags for SysFont find routine.
ImGearPDESysFontPackageType Enumeration
Flags for packageType of AT_PDE_FONTATTRS/ImGearPDEFontAttrs.
ImGearPDETextFlags Enumeration
Flags used in the text API.
ImGearPDEType Enumeration
Types of the editing objects.
ImGearPDEXGroupCreateFlags Enumeration
Enumerated data type used to specify the type of transparency group to create.
ImGearPDFBasicType Enumeration
Basic PDF objects.
ImGearPDFBookmarkFlags Enumeration
Represents PDF bookmark flags.
ImGearPDFCodePages Enumeration
Code page character-mapping constants.
ImGearPDFContextFlags Enumeration
This enumeration determines context flags.
ImGearPDFDestinationType Enumeration
Represents the types of PDF object destination.
ImGearPDFFixedValues Enumeration
PDF Fixed value. A variety of predefined fixed-point constants.
ImGearPDFInsertFlags Enumeration
Insert flags.
ImGearPDFOCMDVisPolicy Enumeration
PDF Dictionaries (OCMD) VisPolicy types.
ImGearPDFPageDrawMode Enumeration
Specifes default PDF rendering methods used by the ImageGear PDF component to draw PDF page content.
ImGearPDFPageNumber Enumeration
PageNumber specification.
ImGearPDFPageRange Enumeration
Page ranges specification.
ImGearPDFPermReqObj Enumeration
Enumerated data type used to describe the target object of a permission request.
ImGearPDFPermReqOpr Enumeration
Enumerated data type used to describe the target operation of a permissions request.
ImGearPDFPermReqStatus Enumeration
An enumerated data type that provides the status of PDF Doc-related permissions methods.
ImGearPDFPermsFlags Enumeration
Flags that describe permissions wanted and granted for a document.
ImGearPDFPreflightReportCodes Enumeration
Defines PDF preflight error codes describing incompliance with the specified profile.
ImGearPDFRevision Enumeration
Specifies Adobe® Acrobat revision number.
ImGearPDFSaveFlags Enumeration
Save flags for PDF document.
ImGearPDFSecurityInfoFlags Enumeration
Flags used to specify various information about the Adobe® Acrobat viewer's security and permissions.
ImGearPDFSmoothFlags Enumeration
Bit flags indicating how a page is rendered.
ImGearPDFStdSecurityMethod Enumeration
Specifies standard security algorithms.
ImGearPDFTextEncoding Enumeration
Determines PDF ASCII encoding.
ImGearPDFWordFinderVersion Enumeration
WordFinder algorithm version.
ImGearPSLevel Enumeration
Determines the PostScript language level.
ImGearPSType Enumeration
Determines output PostScript type.


ImGearPDEContentFlags Enumeration

32-bit
64-bit
CF
P
P

Description:

Bit field for ImGearPDEContentAttrs Class.

Declaration:

public enum ImGearPDEContentFlags : uint

Values:

Name
Value
Description
CACHE_DEVICE
0x0001
if set, cacheDevice contains 6 cache device values
CHAR_WIDTH
0x0002
if set, cacheDevice contains 2 charwidth values
FORM_MATRIX
0x0004
if set, formMatrix contains a valid matrix


ImGearPDEElementCopyFlags Enumeration

32-bit
64-bit
CF
P
P

Description:

Bitfield for PDE element copy.

Declaration:

public enum ImGearPDEElementCopyFlags

Values:

Name
Value
Description
FOR_CLIP
0x0001
Copied element does not need gstate or clip
CLIPPING
0x0002
Acquire the clip path and put it in the copied object


ImGearPDEFontCreateFlags Enumeration

32-bit
64-bit
CF
P
P

Description:

Flags for PDE font creation routine. If you want to subset a font, set both the CREATE_EMBEDDED and WILL_SUBSET flags.

Declaration:

public enum ImGearPDEFontCreateFlags

Values:

Name
Value
Description
CREATE_NOT_ALLOWED
-1
Creation is not allowed. Usually returns by SysFont's "getCreateFlags" when the combination of SysFont and SysEncoding is not allowed.
CREATE_EMBEDDED
0x0001
Embed the font. Create an embedded font. By itself, this will not subset the font.
WILL_SUBSET
0x0002
Subset the font. If you want to subset a font, set both the CREATE_EMBEDDED and WILL_SUBSET flags. You must call "subsetNow" to actually subset the font. Both embedding and sub-setting a font creates a CFF font.
DO_NOT_EMBED
0x0004
Do not embed the font. You cannot set both this and the WILL_SUBSET flags. Nor can you set CREATE_EMBEDDED.
ENCODE_BY_GID
0x0008
Create a CIDFont with identity (GID) encoding.
DEFER_WIDTHS
0x0010
Wait to get widths until later (affects Type0 fonts only).
CREATE_SUBSET
0x0002
Subset the font. If you want to subset a font, set both the CREATE_EMBEDDED and WILL_SUBSET flags. You must call "subsetNow" to actually subset the font. Both embedding and sub-setting a font creates a CFF font.
CREATE_GID_OVERRIDE
0x0020
The library will convert cp to gid with identity embedded
CREATE_TO_UNICODE
0x0040
Create ToUnicode cmap
CREATE_ALL_WIDTHS
0x0080
Supply entire widths table (affects Type0 fonts only)


ImGearPDEFontCreateNeedFlags Enumeration

32-bit
64-bit
CF
P
P

Description:

Flags for PDE Font CreateNeedFlags.

Declaration:

public enum ImGearPDEFontCreateNeedFlags

Values:

Name
Value
Description
WIDTHS
0x00010000
Need to create width
TO_UNICODE
0x00020000
Need to create ToUnicode stream
EMBED
0x00040000
Need to embed it


ImGearPDEFontFlags Enumeration

32-bit
64-bit
CF
P
P

Description:

Constants that indicate a font's attributes (fixed width, roman or symbolic, sans serif, and so forth).

Declaration:

public enum ImGearPDEFontFlags

Values:

Name
Value
Description
FIXED_WIDTH
0x00000001
All glyphs in the font are the same width.
SERIF
0x00000002
The font is a serif font.
PI
0x00000004
The font is a symbolic (pi) font.
SCRIPT
0x00000008
The font is a script font.
STD_ENCODING
0x00000020
The font uses standard encoding.
ITALIC
0x00000040
The font is an italic font.
ALL_CAP
0x00010000
The font is an all-caps font.
SMALL_CAP
0x00020000
The font is a small caps font.
FORCE_BOLD
0x00040000
Force bold characters to draw bold even at small point sizes.


ImGearPDEFontProtection Enumeration

32-bit
64-bit
CF
P
P

Description:

Setting for disabling font embedding.

Declaration:

public enum ImGearPDEFontProtection

Values:

Name
Value
Description
NO_EMBEDDING
0x00000001
Flags for protection of IGPDEFontAttrs - embedding is not allowed.
NO_EDITABLE_EMBEDDING
0x00000002
Flags for protection of IGPDEFontAttrs - editable embedding is not allowed.


ImGearPDEGraphicStateWasSetFlags Enumeration

32-bit
64-bit
CF
P
P

Description:

Structure describing the graphics state that was set.

Declaration:

public enum ImGearPDEGraphicStateWasSetFlags

Values:

Name
Value
Description
FILL_CSPACE
0x0001
A fill color space was set, corresponding to the cs (setcolorspace) operator.
FILL_CVALUE
0x0002
A color fill value was set, corresponding to the sc (setcolor) operator.
STROKE_CSPACE
0x0004
A color space stroke value was set, corresponding to the CS (setcolorspace) operator.
STROKE_CVALUE
0x0008
A color stroke value was set, corresponding to the SC (setcolor) operator.
DASH
0x0010
A dash specification was set, corresponding to the d (setdash) operator.
LINE_WIDTH
0x0020
The line width was set, corresponding to the w (setlinewidth) operator.
MITER_LIMIT
0x0040
The miter limit was set, corresponding to the M (setmiterlimit) operator.
FLATNESS
0x0080
Line flatness was set, corresponding to the i (setflat) operator.
LINE_CAP
0x0100
Line cap style was set, corresponding to the J (setlinecap) operator.
LINE_JOIN
0x0200
Line join style was set, corresponding to the j (setlinejoin) operator.
RENDER_INTENT
0x0400
A color rendering intent was set, corresponding to the Intent key in the image dictionary.
EXT_GSTATE
0x0800
An extended graphics state was set, corresponding to the gs operator.


ImGearPDEImageAttrFlags Enumeration

32-bit
64-bit
CF
P
P

Description:

Flags for AT_PDE_IMAGEATTRS/ImGearPDEImageAttrs. See Section 4.8.4 in the PDF Reference for more information on image attributes.

Declaration:

public enum ImGearPDEImageAttrFlags

Values:

Name
Value
Description
EXTERNAL
0x0001
Image is an XObject
MASK
0x0002
Image is an imagemask
INTERPOLATE
0x0004
Interpolate is true
HAVE_DECODE
0x0008
We have a decode array
INDEXED
0x0010
Uses an indexed color space
MASKED_BY_POSITION
0x0020
Image has a Mask key containing an ImageMask stream
MASKED_BY_COLOR
0x0040
Image has a Mask key containing an array of color values


ImGearPDEImageDataFlags Enumeration

32-bit
64-bit
CF
P
P

Description:

Image Data Flags.

Declaration:

public enum ImGearPDEImageDataFlags

Values:

Name
Value
Description
DATA_NOT_ENCODED
0x0000
Indicates filter is active; data is not encoded.
ENCODED_DATA
0x0001
Indicates filter is active; data is encoded.


ImGearPDEInsertElement Enumeration

32-bit
64-bit
CF
P
P

Description:

Used for inserting a PDE element into the content.

Declaration:

public enum ImGearPDEInsertElement

Values:

Name
Value
Description
BEFORE_FIRST
((LONG) -1)
Specifies position before the first element. Usually used to insert first content element.
AFTER_LAST
(MAX - 1)
Specifies the last element position. Usually used to insert last content element.


ImGearPDEPathElementType Enumeration

32-bit
64-bit
CF
P
P

Description:

Constant values that describe path segment operators in PDE path elements.

Declaration:

public enum ImGearPDEPathElementType

Values:

Name
Value
Description
MOVE_TO
0
Designates m (moveto) operator, which moves the current point.
LINE_TO
1
Designates l (lineto) operator, which appends a straight line segment from the current point.
CURVE_TO
2
Designates c (curveto) operator, which appends a Bézier curve to the path.
CURVE_TO_V
3
Designates v (curveto) operator, which appends a Bézier curve to the current path when the first control point coincides with initial point on the curve.
CURVE_TO_Y
4
Designates y (curveto) operator, which appends a Bézier curve to the current path when the second control point coincides with final point on the curve.
RECT
5
Designates re operator, which adds a rectangle to the current path.
CLOSE_PATH
6
Designates h (closepath) operator, which closes the current subpath.


ImGearPDEPathOpFlags Enumeration

32-bit
64-bit
CF
P
P

Description:

Flags for paint operators in a PDE path.

Declaration:

public enum ImGearPDEPathOpFlags

Values:

Name
Value
Description
INVISIBLE
0x00
Path is neither stroked nor filled, so it is invisible.
STROKE
0x01
Stroke the path, as with the S (stroke) operator.
FILL
0x02
Fills the path, using the nonzero winding number rule to determine the region to fill, as with the f (fill) operator.
EO_FILL
0x04
Fills the path, using the even-odd rule to determine the region to fill, as with the f* (eofill) operator.


ImGearPDEPSAttrFlags Enumeration

32-bit
64-bit
CF
P
P

Description:

Flags for ImGearPDEPSAttrs Class.

Declaration:

public enum ImGearPDEPSAttrFlags

Values:

Name
Value
Description
INLINE
0
Inline PostScript


ImGearPDESoftMaskCreateFlags Enumeration

32-bit
64-bit
CF
P
P

Description:

Flags for use with SoftMask create.

Declaration:

public enum ImGearPDESoftMaskCreateFlags

Values:

Name
Value
Description
LUMINOSITY
0x0001
Specifies how the mask is to be computed.
ALPHA
0x0002
Specifies how the mask is to be computed.


ImGearPDESysFontMatchFlags Enumeration

32-bit
64-bit
CF
P
P

Description:

Font matching flags for SysFont find routine.

Declaration:

public enum ImGearPDESysFontMatchFlags

Values:

Name
Value
Description
NAME_AND_CHARSET
0x0001
Match the font name and character set.
FONT_TYPE
0x0002
Match the font type
WRITING_MODE
0x0004
Match the writing mode, that is, horizontal or vertical.


ImGearPDESysFontPackageType Enumeration

32-bit
64-bit
CF
P
P

Description:

Flags for packageType of AT_PDE_FONTATTRS/ImGearPDEFontAttrs.

Declaration:

public enum ImGearPDESysFontPackageType

Values:

Name
Value
Description
UNKNOWN
0
Unknown
TYPE1
1
Type1
TRUETYPE
2
TrueType
CID
3
CID
ATC
4
ATC
OCF
5
OCF
OPENTYPE_CFF
6
OpenType CFF
OPENTYPE_CID
7
OpenType CID
OPENTYPE_TT
8
OpenType TT


ImGearPDETextFlags Enumeration

32-bit
64-bit
CF
P
P

Description:

Flags used in the text API.

Declaration:

public enum ImGearPDETextFlags

Values:

Name
Value
Description
RUN
0x0001
Specifies an action for the run
CHAR
0x0002
Specifies an action for single character
PAGE_SPACE
0x0004
Specifies user space
GET_BOUNDS
0x0008
Specifies using the font descriptor's FontBBox


ImGearPDEType Enumeration

32-bit
64-bit
CF
P
P

Description:

Types of the editing objects.

Declaration:

public enum ImGearPDEType

Values:

Name
Value
Description
CONTENT
0
Content
TEXT
1
Text
PATH
2
Path
IMAGE
3
Image
FORM
4
Form
POSTSCRIPT
5
PostScript
XOBJECT
6
XObject
CLIP
7
Clip
FONT
8
Font
COLORSPACE
9
color space
GSTATE
10
Graphic State
PLACE
11
Place
CONTAINER
12
Container
IG_PDF_SYSFONT
13
System Font
PATTERN
14
Pattern
DEVICENCOLORS
15
Device N Colors
SHADING
16
Shading
GROUP
17
Group
UNKNOWN
18
Unknown
BEGIN_CONTAINER
19
Begin Container
END_CONTAINER
20
End Container
BEGIN_GROUP
21
Begin Group
END_GROUP
22
End Group
XGROUP
23
XGroup
SOFTMASK
24
SoftMask
IG_PDF_SYSENCODING
25
System Encoding
DOC
26
Document
PAGE
27
Page
READER
28
Reader
WRITER
29
Writer
TEXTITEM
30
Text Item
LASTTYPE
31
Last Type


ImGearPDEXGroupCreateFlags Enumeration

32-bit
64-bit
CF
P
P

Description:

Enumerated data type used to specify the type of transparency group to create.

Declaration:

public enum ImGearPDEXGroupCreateFlags

Values:

Name
Value
Description
XGROUP_TYPE_TRANSPARENCY
0x0001
Creates a transparency XGroup object.


ImGearPDFBasicType Enumeration

32-bit
64-bit
CF
P
P

Description:

Basic PDF objects.

Declaration:

public enum ImGearPDFBasicType

Values:

Name
Value
Description
NULL
0
Null object
INT
1
Integer object
FIXED
2
Fixed (real) object
BOOL
3
Boolean object
NAME
4
Name object
STRING
5
String object
DICT
6
Dictionary object
ARRAY
7
Array object
STREAM
8
Stream object


ImGearPDFBookmarkFlags Enumeration

32-bit
64-bit
CF
P
P

Description:

Represents PDF bookmark flags.

Declaration:

public enum ImGearPDFBookmarkFlags

Values:

Name
Value
Description
ITALIC
1
Italic font
BOLD
2
Bold font


ImGearPDFCodePages Enumeration

32-bit
64-bit
CF
P
P

Description:

Code page character-mapping constants.

Declaration:

public enum ImGearPDFCodePages

Values:

Name
Value
Description
WIN_EAST_EUROPEAN_ROMAN
1250
Windows code pages
WIN_CYRILLIC
1251
Windows code pages
WIN_GREEK
1253
Windows code pages
WIN_TURKISH
1254
Windows code pages
WIN_HEBREW
1255
Windows code pages
WIN_ARABIC
1256
Windows code pages
WIN_BALTIC
1257
Windows code pages
MAC_CENTRAL_EUROPEAN
-9994
Macintosh pseudo code pages
MAC_CROATIAN
-9993
Macintosh pseudo code pages
MAC_ROMANIAN
-9992
Macintosh pseudo code pages
MAC_CYRILLIC
-9991
Macintosh pseudo code pages
MAC_UKRAINIAN
-9990
Macintosh pseudo code pages
MAC_GREEK
-9989
Macintosh pseudo code pages
MAC_TURKISH
-9988
Macintosh pseudo code pages
MAC_HEBREW
-9987
Macintosh pseudo code pages
MAC_ARABIC
-9986
Macintosh pseudo code pages


ImGearPDFContextFlags Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration determines context flags.

Declaration:

public enum ImGearPDFContextFlags

Values:

Name
Value
Description
PDF_ORDER
Enumerates words in the order they appear in the PDF file.
XY_ORDER
Enumerates words sorted by their x- and y-coordinates on the page.


ImGearPDFDestinationType Enumeration

32-bit
64-bit
CF
P
P

Description:

Represents the types of PDF object destination.

Declaration:

public enum ImGearPDFDestinationType

Values:

Name
Value
Description
INVALID
0
Invalid destination
EXPLICIT
1
Explicit destination
NAMED
2
Named destination


ImGearPDFFixedValues Enumeration

32-bit
64-bit
CF
P
P

Description:

PDF Fixed value. A variety of predefined fixed-point constants.

Declaration:

public enum ImGearPDFFixedValues

Values:

Name
Value
Description
ZERO
((LONG) 0x00000000L)
0
HUNDREDTH
((LONG) 0x0000028FL)
1/100
SIXTEENTH
((LONG) 0x00001000L)
1/16
TWELFTH
((LONG) 0x00001555L)
1/12
TENTH
((LONG) 0x00001999L)
1/10
EIGHTH
((LONG) 0x00002000L)
1/8
QUARTER
((LONG) 0x00004000L)
1/4
THIRD
((LONG) 0x00005555L)
1/3
HALF
((LONG) 0x00008000L)
1/2
TWOTHIRDS
((LONG) 0x0000AAAAL)
2/3
THREEQUARTERS
((LONG) 0x0000C000L)
3/4
PI4
((LONG) 0x0000c910L)
PI/4
SEVENEIGHTS
((LONG) 0x0000E000L)
7/8
ONE1
((LONG) 0x0000ffffL)
-1
ONE
((LONG) 0x00010000L)
1
PI2
((LONG) 0x00019220L)
PI/2
GOLDEN
((LONG) 0x00019e37L)
Golden
TEN
((LONG) 0x000A0000L)
10
MAX
((LONG) 0x7FFFFFFF)
Max fixed-point value
MIN
((LONG) 0x80000000)
Min fixed-point value
NEGATIVE_INFINITY
((LONG) MAX)
Negative fixed-point infinity
POSITIVE_INFINITY
((LONG) MIN)
Positive fixed-point infinity


ImGearPDFInsertFlags Enumeration

32-bit
64-bit
CF
P
P

Description:

Insert flags.

Declaration:

public enum ImGearPDFInsertFlags

Values:

Name
Value
Description
DEFAULT
0x0000
Insert by default.
BOOKMARKS
0x0001
Insert bookmarks as well as pages.
ALL
0x1000
Insert all Catalog and Info Dictionary values as well as pages.
THREADS
0x0002
Insert articles as well.


ImGearPDFOCMDVisPolicy Enumeration

32-bit
64-bit
CF
P
P

Description:

PDF Dictionaries (OCMD) VisPolicy types.

Declaration:

public enum ImGearPDFOCMDVisPolicy

Values:

Name
Value
Description
ALL_ON
0
Content is visible if all layers are on.
ANY_ON
1
Content is visible if at least one layer is on.
ANY_OFF
2
Content is invisible if at least one layer is off.
ALL_OFF
3
Content is invisible if all layers are off.


ImGearPDFPageDrawMode Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration specifes default PDF rendering methods used by the ImageGear PDF component to draw PDF page content.

Declaration:

public enum ImGearPDFPageDrawMode

Values:

Name
Value
Description
ENTIRE_PAGE
0
Draws entire page content into the cache. This method is optimized for fast scrolling.
VISIBLE_AREA
1
Draws visible page content area. This method is optimized for fast rendering, but would re-render the content each time it is being scrolled.


ImGearPDFPageNumber Enumeration

32-bit
64-bit
CF
P
P

Description:

PageNumber specification.

Declaration:

public enum ImGearPDFPageNumber

Values:

Name
Value
Description
BEFORE_FIRST_PAGE
-1
Specifies position before the first page. Usually used to insert first document page.
LAST_PAGE
-2
Specifies the last page position. Usually used to insert last document page.


ImGearPDFPageRange Enumeration

32-bit
64-bit
CF
P
P

Description:

Page ranges specification.

Declaration:

public enum ImGearPDFPageRange

Values:

Name
Value
Description
ALL_PAGES
-3
All pages in the document
ODD_PAGES
-4
Odd pages in the document
EVEN_PAGES
-5
Even pages in the document


ImGearPDFPermReqObj Enumeration

32-bit
64-bit
CF
P
P

Description:

Enumerated data type used to describe the target object of a permission request.

Declaration:

public enum ImGearPDFPermReqObj : uint

Values:

Name
Value
Description
DOC
1
Document
PAGE
2
Page
LINK
3
Link
BOOKMARK
4
Bookmark
THUMBNAIL
5
Thumbnail
ANNOT
6
Annotation
FORM
7
Form
SIGNATURE
8
Signature
LAST
9
Used to for checking cache size


ImGearPDFPermReqOpr Enumeration

32-bit
64-bit
CF
P
P

Description:

Enumerated data type used to describe the target operation of a permissions request.

Declaration:

public enum ImGearPDFPermReqOpr : uint

Values:

Name
Value
Description
ALL
1
Check all operations
CREATE
2
Generic operation
DELETE
3
Delete
MODIFY
4
Modify
COPY
5
Copy
ACCESSIBLE
6
For Accessibility use
SELECT
7
For doc or page, selecting (not copying) text or graphics
OPEN
8
For document open
SECURE
9
For doc to changing security settings
PRINT_HIGH
10
For doc, Regular printing
PRINT_LOW
11
For doc, low quality printing
FILL_IN
12
Form fill-in or Sign existing field
ROTATE
13
Rotate
CROP
14
Crop
SUMMARIZE
15
For summarize notes
INSERT
16
Insert
REPLACE
17
for page
REORDER
18
for page
FULL_SAVE
19
For doc
IMPORT
20
For notes & Image
EXPORT
21
For notes. ExportPS should check print
ANY
22
Used for checking to see if any operation is allowed
UNKNOWNOPR
23
Used for error checking
SUBMIT_STANDALONE
24
Submit forms outside of the browser
SPAWN_TEMPLATE
25
Allows form to spawn template page
LAST
26
This should be always the last item


ImGearPDFPermReqStatus Enumeration

32-bit
64-bit
CF
P
P

Description:

An enumerated data type that provides the status of PDF Doc-related permissions methods.

Declaration:

public enum ImGearPDFPermReqStatus : short

Values:

Name
Value
Description
DENIED
-1
Request was denied.
GRANTED
0
Request was granted.
UNKNOWN_OBJECT
1
The object is unknown.
UNKNOWN_OPERATION
2
The operation is unknown.
OPERATION_NA
3
The operation is not applicable for the specified object.
PENDING
4
The handler doesn't have enough info to answer at this point. Try again later


ImGearPDFPermsFlags Enumeration

32-bit
64-bit
CF
P
P

Description:

Flags that describe permissions wanted and granted for a document. Not all permissions will be granted, if the document is protected or if the document is newer version than the application knows about.

Declaration:

public enum ImGearPDFPermsFlags : uint

Values:

Name
Value
Description
OPEN
0x01
The user is permitted to open and decrypt the document.
SECURE
0x02
The user is permitted to change the document's security settings.
PRINT
0x04
The user is permitted to print the document. Page Setup access is unaffected by this permission, since that affects Acrobat's preferences - not the document's. In the Document Security dialog, this corresponds to the Printing entry.
EDIT
0x08
The user is permitted to edit the document more than adding or modifying text notes (see also EDIT_NOTES). In the Document Security dialog, this corresponds to the Changing the Document entry.
COPY
0x10
The user is permitted to copy information from the document to the clipboard. In the Document Security dialog, this corresponds to the Content Copying or Extraction entry.
EDIT_NOTES
0x20
The user is permitted to add, modify, and delete text notes (see also EDIT). In the Document Security dialog, this corresponds to the Authoring Comments and Form Fields entry.
SAVE_AS
0x40
The user is permitted to perform a "Save As..." If both EDIT and EDIT_NOTES are disallowed, "Save" will be disabled but "Save As..." is enabled. The "Save As..." menu item is not necessarily disabled even if the user is not permitted to perform a "Save As...".
NOTE: Not settable by clients.
EXT
0x80
FILL_AND_SIGN
0x100
Override other ImGearPDFPermsFlags bits. It allows user to fill-in or sign existing form or signature fields.
ACCESSIBLE
0x200
Override COPY to enable Accessibility API. If a document is saved in Rev2 format (Acrobat 4.0 compatible), only COPY bit is checked to determine Accessibility API state.
DOC_ASSEMBLY
0x400
Override various EDIT bit and allow the following operations; page insert/delete/rotate and create bookmark and thumbnail.
HIGH_PRINT
0x800
This bit is supplement to PRINT. If it is clear (disabled) only low quality printing (Print As Image) is allowed. Under UNIX platforms, where "Print As Image" doesn't exist, printing is disabled.
OWNER
0x8000
The user is permitted to perform all operations, regardless of the permissions specified by the document. Unless this permission is set, the document's permissions will be reset to those in the document after a full save.
FORM_SUBMIT
0x10000
Should be set if user can submit forms outside of the browser. This bit is supplement to FILL_AND_SIGN.
FORM_SPAWN_TEMPL
0x20000
Should be set if user can spawn template pages. This bit will allow page template spawning even if IG_PDF_PERM_EDIT and IG_PDF_PERM_EDIT_NOTES are clear.
ALL
0xFFFFFFFF
SETTABLE
PRINT + EDIT + COPY + EDIT_NOTES
The OR of all operations that can be set by the user in the Standard Security dialog (PRINT + EDIT + COPY + EDIT_NOTES)
USER
ALL - OPEN - SECURE
All permissions.


ImGearPDFPreflightProfile Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration specifies the types of the supported preflight profiles supported by ImageGear.

Declaration:

public enum ImGearPDFPreflightProfile

Values:

Name
Description
PDFA_1A_2005
Profile for PDF/A-1a standard, revision 2005.
PDFA_1B_2005
Profile for PDF/A-1b, revision 2005.
PDFX_3_2003
Profile for PDF/X-3, revision 2003.

See Also:

AccuSoft Corporation
 AccuSoft.com
sales@accusoft.com


ImGearPDFPreflightReportCodes Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration defines PDF preflight error codes describing incompliance with the specified profile.

Declaration:

public enum ImGearPDFPreflightReportCodes

Values:

Returned Text
Description
Standard Used
SUCCESS = 0
Document or Page is compliant with the specified preflight profile.
Reported by PDF/A and PDF/X compliance verifier.
INCOMPLIANT_DOCUMENT
Document is not compliant.
Reported by PDF/A and PDF/X compliance verifier.
INCOMPLIANT_PAGE
Page is not compliant.
Reported by PDF/A and PDF/X compliance verifier.
INCOMPLIANT_FILE_STRUCTURE
File structure is not compliant.
Reported by PDF/A compliance verifier.
INCOMPLIANT_FILE_HEADER
File header is not compliant.
Reported by PDF/A compliance verifier.
INCOMPLIANT_FILE_TRAILER
File trailer is not compliant.
Reported by PDF/A compliance verifier.
INCOMPLIANT_FILTERS
Document contains non-compliant filters.
Reported by PDF/A and PDF/X compliance verifier.
INCOMPLIANT_EMBEDDED_FILES
Embedded files are not compliant.
Reported by PDF/A compliance verifier.
INCOMPLIANT_OPTIONAL_CONTENT
Optional content is not compliant.
Reported by PDF/A compliance verifier.
INCOMPLIANT_GRAPHICS
Graphics is not compliant.
Reported by PDF/A compliance verifier.
INCOMPLIANT_COLOR_SPACES
Color spaces are not compliant.
Reported by PDF/A compliance verifier.
INCOMPLIANT_ICC_COLOR_SPACES
Not compliant ICCBased colour spaces.
Reported by PDF/A compliance verifier.
INCOMPLIANT_DEVICE_COLOR_SPACES
Not compliant uncalibrated colour spaces.
Reported by PDF/A compliance verifier.
INCOMPLIANT_SPECIAL_COLOR_SPACES
Not compliant Separation/DeviceN colour spaces.
Reported by PDF/A compliance verifier.
INCOMPLIANT_IMAGES
Images are not compliant.
Reported by PDF/A and PDF/X compliance verifier.
INCOMPLIANT_FORMS
Form XObjects are not compliant.
Reported by PDF/A compliance verifier.
INCOMPLIANT_POSTSCRIPT
PostScript XObjects are not compliant.
Reported by PDF/A and PDF/X compliance verifier.
INCOMPLIANT_EXTGSTATE
Extended graphics state is not compliant.
Reported by PDF/A and PDF/X compliance verifier.
INCOMPLIANT_FONTS
Fonts are not compliant.
Reported by PDF/A and PDF/X compliance verifier.
INCOMPLIANT_COMPOSITE_FONTS
Composite fonts are not compliant.
Reported by PDF/A compliance verifier.
INCOMPLIANT_CID_FONTS
CIDFonts are not compliant.
Reported by PDF/A compliance verifier.
INCOMPLIANT_NOT_EMBEDDED_FONTS
Not embedded font programs are not compliant.
Reported by PDF/A and PDF/X compliance verifier.
INCOMPLIANT_FONTS_SUBSETS
Fonts subsets are not compliant.
Reported by PDF/A compliance verifier.
INCOMPLIANT_CHAR_ENCODINGS
Character encodings are not compliant.
Reported by PDF/A compliance verifier.
INCOMPLIANT_UCHAR_MAPS
Unicode character maps are not compliant.
Reported by PDF/A compliance verifier.
INCOMPLIANT_TRANSPARENCY
Transparency is not compliant.
Reported by PDF/A and PDF/X compliance verifier.
INCOMPLIANT_ANNOTATIONS
Annotations are not compliant.
Reported by PDF/A and PDF/X compliance verifier.
INCOMPLIANT_MULT_ANNOTATIONS
Multimedia annotations are not compliant.
Reported by PDF/A compliance verifier.
INCOMPLIANT_ANNOTATIONS_DICT
Annotation dictionaries are not compliant.
Reported by PDF/A compliance verifier.
INCOMPLIANT_ACTIONS
Actions are not compliant.
Reported by PDF/A and PDF/X compliance verifier.
INCOMPLIANT_TRIGGER_EVENTS
Trigger events are not compliant.
Reported by PDF/A compliance verifier.
INCOMPLIANT_METADATA
Metadata is not compliant.
Reported by PDF/A compliance verifier.
INCOMPLIANT_DOCINFO
Mismatch between document information dictionary and XMP metadata.
Reported by PDF/A compliance verifier.
INCOMPLIANT_IDENTIFICATION_SCHEMA
PDF/A identification schema is missing or incompliant with namespace URI <http://www.aiim.org/pdfa/ns/id>.
Reported by PDF/A compliance verifier.
INCOMPLIANT_LOGICAL_STRUCTURE
Logical structure is not compliant.
Reported by PDF/A compliance verifier.
INCOMPLIANT_TAGGED_PDF
Document doesn't conform to the Tagged PDF conventions.
Reported by PDF/A compliance verifier.
INCOMPLIANT_ARTIFACTS
Artifacts are not compliant.
Reported by PDF/A compliance verifier.
INCOMPLIANT_INTERACTIVE_FORMS
Interactive forms are not compliant.
Reported by PDF/A compliance verifier.
INCOMPLIANT_COLOR_DATA
Color data is not compliant.
Reported by PDF/X compliance verifier.
INCOMPLIANT_CHAR_PRINTING_
CONDITION
Characterized printing condition is not compliant.
Reported by PDF/X compliance verifier.
INCOMPLIANT_FILE_SPEC
File specifications are not compliant.
Reported by PDF/X compliance verifier.
INCOMPLIANT_TRAPPING
Trapping is not compliant.
Reported by PDF/X compliance verifier.
INCOMPLIANT_FILE_IDENTIFICATION
PDF file identification is not compliant.
Reported by PDF/X compliance verifier.
INCOMPLIANT_BOUNDING_BOXES
Bounding boxes are not compliant.
Reported by PDF/X compliance verifier.
INCOMPLIANT_ENCRYPTION
Encryption is not compliant.
Reported by PDF/X compliance verifier.
INCOMPLIANT_VIEW_PREFERENCES
Viewer preferences are not compliant.
Reported by PDF/X compliance verifier.

See Also:

AccuSoft Corporation
 AccuSoft.com
sales@accusoft.com


ImGearPDFRevision Enumeration

32-bit
64-bit
CF
P
P

Description:

Specifies Adobe® Acrobat revision number.

Declaration:

public enum ImGearPDFRevision

Values:

Name
Value
Description
REVISION_2
2
Support by Acrobat 3.0 and up.
REVISION_3
3
Support by Acrobat 5.0 and up.
REVISION_4
4
Support by Acrobat 6.0 and up.


ImGearPDFSaveFlags Enumeration

32-bit
64-bit
CF
P
P

Description:

Save flags for PDF document.

All undefined flags should be set to zero.

If either COLLECT_GARBAGE or COPY are used, FULL must be used.

Declaration:

public enum ImGearPDFSaveFlags

Values:

Name
Value
Description
INCREMENTAL
Only write those portions of the file that have been changed.
FULL
Write the entire file to the filename specified by newPath. In addition to this flag, the COLLECT_GARBAGE, COPY, and LINEARIZED may be specified.
COPY
Write a copy of the file, but keep using the old file. This flag can only be specified if FULL is also used.
LINEARIZED
Write the file linearized for page-served remote (network) access. This flag can only be specified if FULL is also used.
During linearization, all objects in the PDF file can be (and usually are) renumbered and recached in memory. Any objects stored prior to linearization are invalidated if LINEARIZED is set.
Thus, if any objects have been acquired, they need to be released prior to saving a document linearized.
WITH_PS_HEADER
(Obsolete) Write a PostScript header as part of the saved file.
BINARY_OK
It is OK to store binary data in the PDF file.
COLLECT_GARBAGE
Remove unreferenced objects, often reducing file size. This flag can only be specified if FULL is also used.
FORCE_INCREMENTAL
Perform an incremental save even if the save is to a different file or the document's version number has changed.
KEEP_MODDATE
Do not update ModDate in InfoDict.


ImGearPDFSecurityInfoFlags Enumeration

32-bit
64-bit
CF
P
P

Description:

Flags used to specify various information about the Adobe® Acrobat viewer's security and permissions.

Declaration:

public enum ImGearPDFSecurityInfoFlags : uint

Values:

Name
Value
Description
HAS_USER_PW
The document has a user password.
HAS_OWNER_PW
The document has an owner password.
CAN_PRINT
The document can be printed.
CAN_EDIT
The document can be modified, for example by adding notes, links, or bookmarks.
CAN_COPY
The document text and graphics can be copied to the clipboard.


ImGearPDFSmoothFlags Enumeration

32-bit
64-bit
CF
P
P

Description:

Bit flags indicating how a page is rendered.

Declaration:

public enum ImGearPDFSmoothFlags

Values:

Name
Value
Description
SMOOTH_TEXT
Draw smooth text.
SMOOTH_LINE_ART
Draw smooth line art.
SMOOTH_IMAGE
Draw smooth image.
NONE


ImGearPDFStdSecurityMethod Enumeration

32-bit
64-bit
CF
P
P

Description:

Specifies standard security algorithms.

Declaration:

public enum ImGearPDFStdSecurityMethod

Values:

Name
Value
Description
RC4_V2
2
RC4 algorithm for encryption.
AES_V1
5
AES algorithm for encryption with a zero initialized iv.
AES_V2
6
AES algorithm for encryption with a random initialized iv.


ImGearPDFTextEncoding Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration determines PDF ASCII encoding.

Declaration:

public enum ImGearPDFTextEncoding

Values:

Name
Value
Description
NONE
No ASCII encoding.
ASCII_85
ASCII 85 encoding.
ASCII_HEX
ASCII HEX encoding.


ImGearPDFWordFinderVersion Enumeration

32-bit
64-bit
CF
P
P

Description:

WordFinder algorithm version.

Declaration:

public enum ImGearPDFWordFinderVersion : short

Values:

Name
Value
Description
LATEST_VERSION
0
The latest available version.
VERSION_2
2
Version used for Acrobat 3.x, 4.x.
VERSION_3
3
Available in Acrobat 5.0 without Accessibility enabled. Includes some improved word piecing algorithms.
VERSION_4
4
For Acrobat 5.0 with Accessibility enabled. Includes advanced word ordering algorithms in addition to improved word piecing algorithms.


ImGearPSLevel Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration determines the PostScript language level.

Declaration:

public enum ImGearPSLevel

Values:

Name
Value
Description
LEVEL_1
PS language level 1.
LEVEL_2
PS language level 2.
LEVEL_3
PS language level 3.


ImGearPSType Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration determines output PostScript type.

Declaration:

public enum ImGearPSType

Values:

Name
Value
Description
POSTSCRIPT
PS file.
EPS_NO_PREVIEW
EPS file with no preview.
EPS_STANDARD_PREVIEW
EPS file with standard preview.
EPS_EXTENDED_PREVIEW
EPS file with extended preview.


ImageGear.Formats.TIF Namespace

ImageGear.Formats.TIF Namespace

32-bit
64-bit
CF
P
P
P

Description:

This namespace provides public API for TIFF format metadata operating and for TIFF filter control parameters.

Declaration:

namespace ImageGear.Formats.TIF

Members:

Classes:
Name
Description
ImGearTIFFMetadata Class
Provides simplified access to TIFF metadata.

Enumerations:
Name
Description
ImGearPhotoInterpretations Enumeration
This enumeration specifies all the supported types of TIFF photometric interpretations.
ImGearStripModes Enumeration
This enumeration specifies all the supported strip and tile modes for TIFF image writing.
ImGearTIFFBitonalPaletteMode Enumeration
Specifies whether ImageGear shall fix strange looking palettes when reading bitonal TIFF images.
ImGearTIFFCompression Enumeration
Represents TIFF compressions.
ImGearTIFFFillOrder Enumeration
Represents TIFF fill orders.
ImGearTIFFNewSubFileTypeMasks Enumeration
Represents TIFF New Subfile Type masks.
ImGearTIFFOrientation Enumeration
Represents TIFF orientations.
ImGearTIFFPhotoInterpretation Enumeration
Represents TIFF photometric interpretations.
ImGearTIFFPlanarConfig Enumeration
Represents TIFF planar configurations.
ImGearTIFFPredictorType Enumeration
Represents TIFF predictor types.
ImGearTIFFResolutionUnit Enumeration
Represents TIFF resolution units.
ImGearTIFFSubFileType Enumeration
Represents TIFF subfile types.

See Also:

TIFF


ImageGear.Formats.TIF Namespace Classes

The ImageGear.Formats.TIF Namespace has the following class members:

Classes:
Name
Description
ImGearTIFFMetadata Class
Provides simplified access to TIFF metadata.


ImGearTIFFMetadata Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides simplified read/write access to TIFF metadata of an ImGearPage. Properties of this class represent specific TIFF tags.

The following file formats may contain TIFF metadata:

- TIFF

- JPEG with EXIF metadata (EXIF specification uses TIFF structure and a subset of TIFF tags).

ImGearTIFFMetadata class provides access to data stored in the general metadata tree. It does not store its own copy of the data.

Types of properties of the class represent TIFF tag types, e.g., string, byte[ ], etc. Instead of value types, ImageGear uses corresponding Nullable types.

If a specific tag is not present in the metadata, corresponding property returns null. Similarly, to remove a specific tag from metadata, set the corresponding property to null.

Declaration:

public class ImGearTIFFMetadata : ImageGear.Formats.ImGearFormatMetadata

Members:

Constructors
Name
Description
ImGearTIFFMetadata Constructor
Creates and initializes an instance of ImGearTIFFMetadata Class.

Properties
Name
Description
Artist Property
Accesses Artist tag.
BitsPerSample Property
Accesses BitsPerSample tag.
CellLength Property
Accesses CellLength tag.
CellWidth Property
Accesses CellWidth tag.
ColorMap Property
Accesses ColorMap tag.
Compression Property
Accesses Compression tag.
Copyright Property
Accesses Copyright tag.
DateTime Property
Accesses DateTime tag.
DocumentName Property
Accesses DocumentName tag.
DotRange Property
Accesses DotRange tag.
ExtraSamples Property
Accesses ExtraSamples tag.
FillOrder Property
Accesses FillOrder tag.
FreeByteCounts Property
Accesses FreeByteCounts tag.
FreeOffsets Property
Accesses FreeOffsets tag.
GrayResponseCurve Property
Accesses GrayResponseCurve tag.
GrayResponseUnit Property
Accesses GrayResponseUnit tag.
HalftoneHints Property
Accesses HalftoneHints tag.
HostComputer Property
Accesses HostComputer tag.
ImageDescription Property
Accesses ImageDescription tag.
ImageLength Property
Accesses ImageLength tag.
ImageWidth Property
Accesses ImageWidth tag.
InkNames Property
Accesses InkNames tag.
InkSet Property
Accesses InkSet tag.
InterColorProfile Property
Accesses InterColorProfile tag.
JPEGACTables Property
Accesses JPEGACTables tag.
JPEGDCTables Property
Accesses JPEGDCTables tag.
JPEGInterchangeFormat Property
Accesses JPEGInterchangeFormat tag.
JPEGInterchangeFormatLength Property
Accesses JPEGInterchangeFormatLngth tag.
JPEGLosslessPredictors Property
Accesses JPEGLosslessPredictors tag.
JPEGPointTransforms Property
Accesses JPEGPointTransforms tag.
JPEGProc Property
Accesses JPEGProc tag.
JPEGQTables Property
Accesses JPEGQTables tag.
JPEGRestartInterval Property
Accesses JPEGRestartInterval tag.
Make Property
Accesses Make tag.
MaxSampleValue Property
Accesses MaxSampleValue tag.
MinSampleValue Property
Accesses MinSampleValue tag.
Model Property
Accesses Model tag.
NewSubfileType Property
Accesses NewSubfileType tag.
NumberOfInks Property
Accesses NumberOfInks tag.
Orientation Property
Accesses Orientation tag.
PageName Property
Accesses PageName tag.
PageNumber Property
Accesses PageNumber tag.
PhotometricInterpretation Property
Accesses PhotometricInterpretation tag.
PlanarConfig Property
Accesses PlanarConfig tag.
PredictorType Property
Accesses PredictorType tag.
PrimaryChromaticities Property
Accesses PrimaryChromaticities tag.
ReferenceBlackWhite Property
Accesses ReferenceBlackWhite tag.
ResolutionUnit Property
Accesses ResolutionUnit tag.
RowsPerStrip Property
Accesses RowsPerStrip tag.
SampleFormat Property
Accesses SampleFormat tag.
SamplesPerPixel Property
Accesses SamplesPerPixel tag.
SMaxSampleValue Property
Accesses SMaxSampleValue tag.
SMinSampleValue Property
Accesses SMinSampleValue tag.
Software Property
Accesses Software tag.
StripByteCounts Property
Accesses StripByteCounts tag.
StripOffsets Property
Accesses StripOffsets tag.
SubFileType Property
Accesses SubFileType tag.
T4Options Property
Accesses T4Options tag.
T6Options Property
Accesses T6Options tag.
TargetPrinter Property
Accesses TargetPrinter tag.
Threshholding Property
Accesses Threshholding tag.
TileByteCounts Property
Accesses TileByteCounts tag.
TileLength Property
Accesses TileLength tag.
TileOffsets Property
Accesses TileOffsets tag.
TileWidth Property
Accesses TileWidth tag.
TransferFunction Property
Accesses TransferFunction tag.
TransferRange Property
Accesses TransferRange tag.
WhitePoint Property
Accesses WhitePoint tag.
XPosition Property
Accesses XPosition tag.
XResolution Property
Accesses XResolution tag.
YCbCrCoefficients Property
Accesses YCbCrCoefficients tag.
YCbCrPositioning Property
Accesses YCbCrPositioning tag.
YCbCrSubSampling Property
Accesses YCbCrSubSampling tag.
YPosition Property
Accesses YPosition tag.
YResolution Property
Accesses YResolution tag.


ImGearTIFFMetadata Constructors

The ImGearTIFFMetadata Class of the ImageGear.Formats.TIF Namespace has the following constructors:

Constructors
Name
Description
ImGearTIFFMetadata Constructor
Creates and initializes an instance of ImGearTIFFMetadata Class.


ImGearTIFFMetadata Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearTIFFMetadata Class.

Declaration:

public ImGearTIFFMetadata()

Return Value:

The new instance of ImGearTIFFMetadata Class.

See Also:

ImGearTIFFMetadata Class


ImGearTIFFMetadata Properties

The ImGearTIFFMetadata Class of the ImageGear.Formats.TIF Namespace has the following properties:

Properties
Name
Description
Artist Property
Accesses Artist tag.
BitsPerSample Property
Accesses BitsPerSample tag.
CellLength Property
Accesses CellLength tag.
CellWidth Property
Accesses CellWidth tag.
ColorMap Property
Accesses ColorMap tag.
Compression Property
Accesses Compression tag.
Copyright Property
Accesses Copyright tag.
DateTime Property
Accesses DateTime tag.
DocumentName Property
Accesses DocumentName tag.
DotRange Property
Accesses DotRange tag.
ExtraSamples Property
Accesses ExtraSamples tag.
FillOrder Property
Accesses FillOrder tag.
FreeByteCounts Property
Accesses FreeByteCounts tag.
FreeOffsets Property
Accesses FreeOffsets tag.
GrayResponseCurve Property
Accesses GrayResponseCurve tag.
GrayResponseUnit Property
Accesses GrayResponseUnit tag.
HalftoneHints Property
Accesses HalftoneHints tag.
HostComputer Property
Accesses HostComputer tag.
ImageDescription Property
Accesses ImageDescription tag.
ImageLength Property
Accesses ImageLength tag.
ImageWidth Property
Accesses ImageWidth tag.
InkNames Property
Accesses InkNames tag.
InkSet Property
Accesses InkSet tag.
InterColorProfile Property
Accesses InterColorProfile tag.
JPEGACTables Property
Accesses JPEGACTables tag.
JPEGDCTables Property
Accesses JPEGDCTables tag.
JPEGInterchangeFormat Property
Accesses JPEGInterchangeFormat tag.
JPEGInterchangeFormatLength Property
Accesses JPEGInterchangeFormatLngth tag.
JPEGLosslessPredictors Property
Accesses JPEGLosslessPredictors tag.
JPEGPointTransforms Property
Accesses JPEGPointTransforms tag.
JPEGProc Property
Accesses JPEGProc tag.
JPEGQTables Property
Accesses JPEGQTables tag.
JPEGRestartInterval Property
Accesses JPEGRestartInterval tag.
Make Property
Accesses Make tag.
MaxSampleValue Property
Accesses MaxSampleValue tag.
MinSampleValue Property
Accesses MinSampleValue tag.
Model Property
Accesses Model tag.
NewSubfileType Property
Accesses NewSubfileType tag.
NumberOfInks Property
Accesses NumberOfInks tag.
Orientation Property
Accesses Orientation tag.
PageName Property
Accesses PageName tag.
PageNumber Property
Accesses PageNumber tag.
PhotometricInterpretation Property
Accesses PhotometricInterpretation tag.
PlanarConfig Property
Accesses PlanarConfig tag.
PredictorType Property
Accesses PredictorType tag.
PrimaryChromaticities Property
Accesses PrimaryChromaticities tag.
ReferenceBlackWhite Property
Accesses ReferenceBlackWhite tag.
ResolutionUnit Property
Accesses ResolutionUnit tag.
RowsPerStrip Property
Accesses RowsPerStrip tag.
SampleFormat Property
Accesses SampleFormat tag.
SamplesPerPixel Property
Accesses SamplesPerPixel tag.
SMaxSampleValue Property
Accesses SMaxSampleValue tag.
SMinSampleValue Property
Accesses SMinSampleValue tag.
Software Property
Accesses Software tag.
StripByteCounts Property
Accesses StripByteCounts tag.
StripOffsets Property
Accesses StripOffsets tag.
SubFileType Property
Accesses SubFileType tag.
T4Options Property
Accesses T4Options tag.
T6Options Property
Accesses T6Options tag.
TargetPrinter Property
Accesses TargetPrinter tag.
Threshholding Property
Accesses Threshholding tag.
TileByteCounts Property
Accesses TileByteCounts tag.
TileLength Property
Accesses TileLength tag.
TileOffsets Property
Accesses TileOffsets tag.
TileWidth Property
Accesses TileWidth tag.
TransferFunction Property
Accesses TransferFunction tag.
TransferRange Property
Accesses TransferRange tag.
WhitePoint Property
Accesses WhitePoint tag.
XPosition Property
Accesses XPosition tag.
XResolution Property
Accesses XResolution tag.
YCbCrCoefficients Property
Accesses YCbCrCoefficients tag.
YCbCrPositioning Property
Accesses YCbCrPositioning tag.
YCbCrSubSampling Property
Accesses YCbCrSubSampling tag.
YPosition Property
Accesses YPosition tag.
YResolution Property
Accesses YResolution tag.


Artist Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Artist tag. The tag specifies the person who created the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public string Artist { set; get; }

Value:

string value.


BitsPerSample Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the BitsPerSample tag. The tag specifies number of bits per image component.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ushort[] BitsPerSample { set; get; }

Value:

ushort[] value.


CellLength Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the CellLength tag. The tag specifies the length of the dithering or halftoning matrix used to create a dithered or halftoned bilevel file.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ushort? CellLength { set; get; }

Value:

Nullable (boxing) ushort value.


CellWidth Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the CellWidth tag. The tag specifies the width of the dithering or halftoning matrix used to create a dithered or halftoned bilevel file.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ushort? CellWidth { set; get; }

Value:

Nullable (boxing) ushort value.


ColorMap Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ColorMap tag. The tag specifies a color map for palette color images.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ushort[] ColorMap { set; get; }

Value:

Ushort array.


Compression Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Compression tag. The tag specifies the compression scheme used on the image data.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ImageGear.Formats.TIF.ImGearTIFFCompression? Compression { set; get; }

Value:

Nullable (boxing) ImGearTIFFCompression Enumeration value.

See Also:

ImGearTIFFCompression Enumeration


Copyright Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Copyright tag. The tag specifies the copyright notice for the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public string Copyright { set; get; }

Value:

String value.


DateTime Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the DateTime tag. The tag specifies the date and time of image creation.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public string DateTime { set; get; }

Value:

String value.


DocumentName Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the DocumentName tag. The tag specifies the name of the document from which this image was scanned.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public string DocumentName { set; get; }

Value:

String value.


DotRange Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the DotRange tag. The tag specifies the component values that correspond to a 0% dot and 100% dot. DotRange[0] corresponds to a 0% dot, and DotRange[1] corresponds to a 100% dot.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ushort[] DotRange { set; get; }

Value:

ushort[] array.


ExtraSamples Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ExtraSamples tag. The tag describes the usage of the image's extra components.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public byte[] ExtraSamples { set; get; }

Value:

Array of bytes.


FillOrder Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the FillOrder tag. The tag specifies the logical order of bits within a byte.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ImageGear.Formats.TIF.ImGearTIFFFillOrder? FillOrder { set; get; }

Value:

Nullable (boxing) ImGearTIFFFillOrder Enumeration value.

See Also:

ImGearTIFFFillOrder Enumeration


FreeByteCounts Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the FreeByteCounts tag. For each string of contiguous unused bytes in a TIFF file, the tag specifies the number of bytes in the string.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public uint[] FreeByteCounts { set; get; }

Value:

Array of uint.


FreeOffsets Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the FreeOffsets tag. For each string of contiguous unused bytes in a TIFF file, the tag specifies byte offset of the string.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public uint[] FreeOffsets { set; get; }

Value:

Uint array.


GrayResponseCurve Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GrayResponseCurve tag. For grayscale data, the tag specifies optical density of each possible pixel value.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ushort[] GrayResponseCurve { set; get; }

Value:

ushort[] array.


GrayResponseUnit Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the GrayResponseUnit tag. The tag specifies the precision of the information contained in the GrayResponseCurve.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ushort? GrayResponseUnit { set; get; }

Value:

Nullable (boxing) ushort value.


HalftoneHints Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the HalftoneHints tag. The purpose of the HalftoneHints tag is to convey to the halftone function the range of gray levels within a colorimetrically-specified image that should retain tonal detail.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ushort[] HalftoneHints { set; get; }

Value:

ushort array.


HostComputer Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the HostComputer tag. The tag specifies the computer and/or operating system in use at the time of image creation.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public string HostComputer { set; get; }

Value:

string value.


ImageLength Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ImageLength tag. The tag specifies the number of rows of pixels in the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public uint? ImageLength { set; get; }

Value:

Nullable (boxing) uint value.


ImageWidth Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ImageWidth tag. The tag specifies the number of columns in the image, i.e., the number of pixels per row.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public uint? ImageWidth { set; get; }

Value:

Nullable (boxing) uint value.


InkNames Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the InkNames tag. The tag specifies the name of each ink used in a separated (PhotometricInterpretation=5) image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public string[] InkNames { set; get; }

Value:

Array of strings.


InkSet Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the InkSet tag. The tag specifies the set of inks used in a separated (PhotometricInterpretation=5) image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ushort? InkSet { set; get; }

Value:

Nullable (boxing) ushort value.


JPEGACTables Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the JPEGACTables tag. The tag specifies the list of offsets to the Huffman AC tables, one per component.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public uint[] JPEGACTables { set; get; }

Value:

uint[] array.


JPEGDCTables Property

32-bit
64-bit
CF
P
P
P

Description:

This Field points to a list of offsets to the DC Huffman tables or the lossless Huffman tables, one per component.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public uint[] JPEGDCTables { set; get; }

Value:

uint[] array.


JPEGInterchangeFormat Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the JPEGInterchangeFormat tag. This Field indicates whether a JPEG interchange format bitstream is present in the TIFF file. If a JPEG interchange format bitstream is present, then this tag points to the Start of Image (SOI) marker code.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public uint? JPEGInterchangeFormat { set; get; }

Value:

Nullable (boxing) uint value.


JPEGInterchangeFormatLength Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the JPEGInterchangeFormatLength tag. This tag indicates the length in bytes of the JPEG interchange format bitstream.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public uint? JPEGInterchangeFormatLngth { set; get; }

Value:

Nullable (boxing) Uint value.


JPEGLosslessPredictors Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the JPEGLosslessPredictors tag. This tag points to a list of lossless predictor-selection values, one per component.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ushort? JPEGLosslessPredictors { set; get; }

Value:

Nullable (boxing) ushort value.


JPEGPointTransforms Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the JPEGPointTransforms tag. This Field points to a list of point transform values, one per component. This Field is relevant only for lossless processes.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ushort? JPEGPointTransforms { set; get; }

Value:

Nullable (boxing) ushort value.


JPEGProc Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the JPEGProc tag. This Tag indicates the JPEG process used to produce the compressed data. The values for this field are defined to be consistent with the numbering convention used in ISO DIS 10918-2. Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ushort? JPEGProc { set; get; }

Value:

Nullable (boxing) ushort value.


JPEGQTables Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the JPEGQTables tag. The tag points to a list of offsets to the quantization tables, one per component. Each table consists of 64 BYTES (one for each DCT coefficient in the 8x8 block).

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public uint[] JPEGQTables { set; get; }

Value:

uint[] array.


JPEGRestartInterval Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the JPEGRestartInterval tag. This Field indicates the length of the restart interval used in the compressed image data.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ushort? JPEGRestartInterval { set; get; }

Value:

Nullable (boxing) ushort value.


MaxSampleValue Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the MaxSampleValue tag. The tag specifies the maximum component value used in the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ushort[] MaxSampleValue { set; get; }

Value:

ushort[] array.


MinSampleValue Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the MinSampleValue tag. The tag specifies the minimum component value used in the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ushort[] MinSampleValue { set; get; }

Value:

ushort[] array.


NewSubfileType Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the NewSubfileType tag. The tag provides a general indication of the kind of data contained in this subfile.

The value is composed as a bitmask, using the members of ImGearTIFFNewSubFileTypeMasks enumeration.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ImageGear.Formats.TIF.ImGearTIFFNewSubFileTypeMasks? NewSubfileType { set; get; }

Value:

Nullable (boxing) ImGearTIFFNewSubFileTypeMasks Enumeration value.

See Also:

ImGearTIFFNewSubFileTypeMasks Enumeration


NumberOfInks Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the NumberOfInks tag. The tag specifies the number of inks. Usually equal to SamplesPerPixel, unless there are extra samples.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ushort? NumberOfInks { set; get; }

Value:

Nullable (boxing) ushort value.


Orientation Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Orientation tag. The tag specifies the orientation of the image with respect to the rows and columns.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearTIFFOrientation? Orientation { set; get; }

Value:

Nullable (boxing) ImGearTIFFOrientation Enumeration value.

See Also:

ImGearTIFFOrientation Enumeration


PageName Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the PageName tag. The tag specifies the name of the page from which this image was scanned.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public string PageName { set; get; }

Value:

string value.


PageNumber Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the PageNumber tag. The tag specifies the page number of the page from which this image was scanned. PageNumber[0] is the page number; PageNumber[1] is the total number of pages in the document. If PageNumber[1] is 0, the total number of pages in the document is not available.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

If the TIFF filter option "IncludePageNumber" is set to true, ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ushort[] PageNumber { set; get; }

Value:

ushort[] array.


PhotometricInterpretation Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the PhotometricInterpretation tag. This tag indicates the color space of the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearTIFFPhotoInterpretation? PhotometricInterpretation { set;
get; }

Value:

Nullable (boxing) ImGearTIFFPhotoInterpretation Enumeration value.

See Also:

ImGearTIFFPhotoInterpretation Enumeration


PlanarConfig Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the PlanarConfig tag. The tag specifies how the components of each pixel are stored.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearTIFFPlanarConfig? PlanarConfig { set; get; }

Value:

Nullable (boxing) ImGearTIFFPlanarConfig Enumeration value.

See Also:

ImGearTIFFPlanarConfig Enumeration


PredictorType Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the PredictorType tag. Predictor is a mathematical operator that is applied to the image data before an encoding scheme is applied. It greatly improves compression ratios for some images.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ImageGear.Formats.TIF.ImGearTIFFPredictorType? PredictorType { set; get; }

Value:

Nullable (boxing) ImGearTIFFPredictorType Enumeration value.

See Also:

ImGearTIFFPredictorType Enumeration


PrimaryChromaticities Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the PrimaryChromaticities tag. The tag specifies chromaticities of the primaries of the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt[] PrimaryChromaticities { set; get; }

Value:

ImGearRationalUInt Structure array.

See Also:

ImGearRationalUInt Structure


ResolutionUnit Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the ResolutionUnit tag. The tag specifies the unit of measurement for XResolution and YResolution.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ImageGear.Formats.ImGearTIFFResolutionUnit? ResolutionUnit { set; get; }

Value:

Nullable (boxing) ImGearTIFFResolutionUnit Enumeration value.

See Also:

ImGearTIFFResolutionUnit Enumeration


RowsPerStrip Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the RowsPerStrip tag. The tag specifies the number of rows per strip.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public uint? RowsPerStrip { set; get; }

Value:

Nullable (boxing) Uint value.


SampleFormat Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the SampleFormat tag. The tag specifies how to interpret each data sample in a pixel.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ushort[] SampleFormat { set; get; }

Value:

ushort[] array.


SamplesPerPixel Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the SamplesPerPixel tag. The tag specifies the number of components per pixel.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ushort? SamplesPerPixel { set; get; }

Value:

Nullable (boxing) Ushort value.


SMaxSampleValue Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the SMaxSampleValue tag. The tag specifies the maximum sample value.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public uint[] SMaxSampleValue { set; get; }

Value:

uint[] array.


SMinSampleValue Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the SMinSampleValue tag. The tag specifies the minimum sample value.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public uint[] SMinSampleValue { set; get; }

Value:

uint[] array.


Software Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Software tag. The tag specifies the name and version number of the software package(s) used to create the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public string Software { set; get; }

Value:

string value.


SubFileType Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the SubFileType tag. The tag specifies general indication of the kind of data contained in this subfile.

This tag is deprecated. The NewSubfileType Property tag should be used instead.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

.NET 2.0:

public ImageGear.Formats.TIF.ImGearTIFFSubFileType? SubFileType { set; get; }

.NET 2.0:

public ImageGear.Formats.TIF.ImGearTIFFSubFileTypeBoxing SubFileType { set; get; }

Value:

Nullable (boxing) ImGearTIFFSubFileType Enumeration value.

See Also:

ImGearTIFFSubFileType Enumeration


T4Options Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the T4Options tag. The tag specifies options for CCITT Group 3 compression.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public uint? T4Options { set; get; }

Value:

Nullable (boxing) uint value.


T6Options Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the T6Options tag. The tag specifies options for CCITT Group 4 compression.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public uint? T6Options { set; get; }

Value:

Nullable (boxing) uint value.


TargetPrinter Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the TargetPrinter tag. The tag specifies a description of the printing environment for which this separation is intended.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public string TargetPrinter { set; get; }

Value:

string value.


Threshholding Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the Threshholding tag. For black and white TIFF files that represent shades of gray, this tag specifies the technique used to convert from gray to black and white pixels.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

.NET 2.0:

public ushort? Threshholding { set; get; }

.NET 2.0:

public ushortBoxing Threshholding { set; get; }

Value:

Nullable (boxing) ushort value.


TileByteCounts Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the TileByteCounts tag. The tag specifies the number of (compressed) bytes in the tile, for each image tile.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public uint[] TileByteCounts { set; get; }

Value:

uint[] array.


TileLength Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the TileLength tag. The tag specifies the number of rows in each tile.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public uint? TileLength { set; get; }

Value:

Nullable (boxing) uint value.


TileOffsets Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the TileOffsets tag. The tag specifies the byte offsets of all image tiles, as compressed and stored on disk. The offset is specified with respect to the beginning of the TIFF file.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public uint[] TileOffsets { set; get; }

Value:

uint[] array.


TileWidth Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the TileWidth tag. The tag specifies the number of columns in each tile.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public uint? TileWidth { set; get; }

Value:

Nullable (boxing) uint value.


TransferFunction Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the TransferFunction tag. The tag describes a transfer function for the image in tabular style.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ushort[] TransferFunction { set; get; }

Value:

ushort[] array.


TransferRange Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the TransferRange tag. The tag expands the range of the TransferFunction.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ushort[] TransferRange { set; get; }

Value:

ushort[] array.


XPosition Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the XPosition tag. The tag specifies x position of the image.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt? XPosition { set; get; }

Value:

Nullable (boxing) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


XResolution Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the XResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageWidth (typically, horizontal - see Orientation) direction.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt? XResolution { set; get; }

Value:

Nullable (boxing) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


YCbCrCoefficients Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the YCbCrCoefficients tag. The tag specifies the transformation from RGB to YCbCr image data.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt[] YCbCrCoefficients { set; get; }

Value:

ImGearRationalUInt Structure array.

See Also:

ImGearRationalUInt Structure


YCbCrPositioning Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the YCbCrPositioning tag. The tag specifies the positioning of subsampled chrominance components relative to luminance samples.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ushort? YCbCrPositioning { set; get; }

Value:

Nullable (boxing) ushort value.


YPosition Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the YPosition tag. The tag specifies Y offset in ResolutionUnits of the top of the image, with respect to the top of the page. In the TIFF coordinate scheme, the positive Y direction is down, so that YPosition is always positive.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt? YPosition { set; get; }

Value:

Nullable (boxing) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


YResolution Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses the YResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageLength (typically, vertical) direction.

Get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Declaration:

public ImageGear.Core.ImGearRationalUInt? YResolution { set; get; }

Value:

Nullable (boxing) ImGearRationalUInt Structure value.

See Also:

ImGearRationalUInt Structure


ImageGear.Formats.TIF Namespace Enumerations

The ImageGear.Formats.TIF Namespace has the following enumeration members:

Enumerations:
Name
Description
ImGearPhotoInterpretations Enumeration
This enumeration specifies all the supported types of TIFF photometric interpretations.
ImGearStripModes Enumeration
This enumeration specifies all the supported strip and tile modes for TIFF image writing.
ImGearTIFFBitonalPaletteMode Enumeration
Specifies whether ImageGear shall fix strange looking palettes when reading bitonal TIFF images.
ImGearTIFFCompression Enumeration
Represents TIFF compressions.
ImGearTIFFFillOrder Enumeration
Represents TIFF fill orders.
ImGearTIFFNewSubFileTypeMasks Enumeration
Represents TIFF New Subfile Type masks.
ImGearTIFFOrientation Enumeration
Represents TIFF orientations.
ImGearTIFFPhotoInterpretation Enumeration
Represents TIFF photometric interpretations.
ImGearTIFFPlanarConfig Enumeration
Represents TIFF planar configurations.
ImGearTIFFPredictorType Enumeration
Represents TIFF predictor types.
ImGearTIFFResolutionUnit Enumeration
Represents TIFF resolution units.
ImGearTIFFSubFileType Enumeration
Represents TIFF subfile types.


ImGearPhotoInterpretations Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies all the supported types of TIFF photometric interpretations.

Declaration:

public enum ImGearPhotoInterpretations

Values:

Name
Value
Description
BLACKZERO
1
Bilevel or grayscale image, zero pixel value is displayed as black
CFA
-32733
Color Filter Array
CIELAB
8
CIE Lab (TIFF encoding)
CMYK
5
CMYK
PALETTE
3
Palette
RGB
2
RGB
TRANSPARENCY
4
Transparency
WHITEZERO
0
Bilevel or grayscale image, zero pixel value is displayed as white
YCBCR
6
YCbCr

See Also:

TIFF


ImGearStripModes Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies all the supported strip and tile modes for TIFF image writing.

Declaration:

public enum ImGearStripModes

Values:

Name
Value
Description
FIXED_BUFFER
1
Save image using strips not exceeding specified size.
FIXED_COUNT
0
Save image using specified number of strips.
TILED_FIXED_COUNT
17
Save image using specified number of tiles vertically and horizontally.
TILED_FIXED_SIZE
16
Save image using tiles of specified size.

See Also:

TIFF


ImGearTIFFBitonalPaletteMode Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies whether ImageGear shall fix strange looking palettes when reading bitonal TIFF images.

Declaration:

public enum ImGearTIFFBitonalPaletteMode

Values:

Name
Description
LEGACY
Keep ImageGear 16.0 behavior: read all 1-bit palettes as is. If palette is missing, assume increasing (blackzero) palette.
KEEP_AS_IS
Keep palette as is, even if it is all-black or red-green. If photometric interpretation is PALETTE_COLOR, but COLORMAP tag is absent, assume all-black palette.
FIX
Fix strange looking palettes, as follows: if (R0+G0+B0)/3 < (R1+G1+B1)/3 change palette to (black, white). Otherwise, change palette to (white, black). Specifically, constant palettes (all-black, all-white) are replaced with (white, black) palette.


ImGearTIFFCompression Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents TIFF compressions.

Declaration:

public enum ImGearTIFFCompression

Values:

Name
Value
Description
Uncompressed
1
Uncompressed
CCITT_1D
2
CCITT 1D
GROUP_3
3
CCITT Group 3
GROUP_4
4
CCITT Group 4
LZW
5
Lempel-Ziv & Welch
JPEG
6
JPEG (using TIFF 6.0 specification)
JPEG_2
7
JPEG (using TIFF Technical Note 2 specification)
Deflate
8
Deflate
DeflateObsolete
0x80b2
Legacy constant for Deflate compression
Packbits
32773
Packed Bits
Thunderscan
32809
Thunderscan RLE compression
ABIC_Concatenated
0x7D0A
ABIC concatenated image
ABIC_BW
0x8008
ABIC b/w image
ABIC_IOCA
0x8009
ABIC IOCA image
ABIC_GRAY
0x800A
ABIC gray image
JBIG
0x800C
JBIG


ImGearTIFFFillOrder Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents TIFF fill orders.

Declaration:

public enum ImGearTIFFFillOrder

Values:

Name
Value
Description
MostSignificantBitFirst
1
Pixels are arranged within a byte such that pixels with lower column values are stored in the higher-order bits of the byte.
LeastSignificantBitFirst
2
Pixels are arranged within a byte such that pixels with lower column values are stored in the lower-order bits of the byte.


ImGearTIFFNewSubFileTypeMasks Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents bit mask values for TIFF New Subfile Type tag.

Declaration:

public enum ImGearTIFFNewSubFileTypeMasks

Values:

Name
Value
Description
Thumbnail
0x01
The image is a reduced-resolution version of another image in this TIFF file.
PageOfMultipageImage
0x02
The image is a single page of a multi-page image.
Alpha
0x04
The image defines a transparency mask for another image in this TIFF file.


ImGearTIFFOrientation Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents TIFF image orientations.

Declaration:

public enum ImGearTIFFOrientation

Values:

Name
Value
Description
TopLeft
1
The 0th row represents the visual top of the image, and the 0th column represents the visual left-hand side.
TopRight
2
The 0th row represents the visual top of the image, and the 0th column represents the visual right-hand side.
BottomRight
3
The 0th row represents the visual bottom of the image, and the 0th column represents the visual right-hand side.
BottomLeft
4
The 0th row represents the visual bottom of the image, and the 0th column represents the visual left-hand side.
LeftTop
5
The 0th row represents the visual left-hand side of the image, and the 0th column represents the visual top.
RightTop
6
The 0th row represents the visual right-hand side of the image, and the 0th column represents the visual top.
RightBottom
7
The 0th row represents the visual right-hand side of the image, and the 0th column represents the visual bottom.
LeftBottom
8
The 0th row represents the visual left-hand side of the image, and the 0th column represents the visual bottom.


ImGearTIFFPhotoInterpretation Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents TIFF photometric interpretations.

Declaration:

public enum ImGearTIFFPhotoInterpretations

Values:

Name
Value
Description
Whitezero
0
White is zero. For bilevel and grayscale images: 0 is imaged as white. 2**BitsPerSample-1 is imaged as black.
Blackzero
1
Black is zero. For bilevel and grayscale images: 0 is imaged as black. 2**BitsPerSample-1 is imaged as white.
RGB
2
RGB
Palette
3
Palette color
Transparency
4
Transparency
CMYK
5
CMYK
YCbCb
6
YCbCr
CIELab
8
CIE Lab (using TIFF format for storing a and b values)
ICC_CIELab
9
CIE Lab (using ICC format for storing a and b values)
CFA
-32733
Color Filter Array


ImGearTIFFPlanarConfig Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents TIFF planar configurations.

Declaration:

public enum ImGearTIFFPlanarConfig

Values:

Name
Value
Description
Planar
2
Planar format. The components are stored in separate "component planes."
Chunky
1
Chunky format. The component values for each pixel are stored contiguously.


ImGearTIFFPredictorType Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents TIFF predictor types.

Declaration:

public enum ImGearTIFFPredictorType

Values:

Name
Value
Description
NONE
1
No prediction scheme used before coding.
HORIZ_DIFF
2
Horizontal differencing.


ImGearTIFFResolutionUnit Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents TIFF resolution units.

Declaration:

public enum ImGearTIFFResolutionUnit

Values:

Name
Value
Description
NoAbsoluteUnit
1
No absolute unit of measurement. Used for images that may have a non-square aspect ratio but no meaningful absolute dimensions.
Inch
2
Inch.
Centimeter
3
Centimeter.


ImGearTIFFSubFileType Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents TIFF subfile types.

Declaration:

public enum ImGearTIFFSubFileType

Values:

Name
Value
Description
FullResolutionImage
1
Full resolution image
Thumbnail
2
Thumbnail
PageOfMultipageImage
3
Page of a multipage image


ImageGear.Formats.U3D Namespace

ImageGear.Formats.U3D Namespace

32-bit
64-bit
CF
P
P

Description:

This namespace provides the API to create U3D vector format. To enable ImageGear.Formats.U3D namespace in your project, specify the following directive:

using ImageGear.Formats.U3D;

ImageGear U3D namespace provides read and write support for the following features of Universal 3D format: CLOD Progressive Mesh, Normals, Colors (diffuse and specular), Views, Lights, Textures, Transparency, Linesets, and Pointsets.

Declaration:

namespace ImageGear.Formats.U3D

Members:

Classes:
Name
Description
ImGearU3D Class
This class is used to create a U3D vector format.


ImageGear.Formats.U3D Namespace Classes

The ImageGear.Formats.U3D Namespace has the following class members:

Classes:
Name
Description
ImGearU3D Class
This class is used to create a U3D vector format.


ImGearU3D Class

32-bit
64-bit
CF
P
P

Description:

This class is used to create U3D vector format.

Declaration:

public sealed class ImGearU3D

Members:

Methods
Name
Description
CreateU3DFormat
Creates an instance of U3D format.
CreateU3DFormat
Creates an instance of U3D format.


ImGearPDEClip Methods

The ImGearU3D Class of the ImageGear.Formats.U3D Namespace has the following methods:

Methods
Name
Description
CreateU3DFormat
Creates an instance of U3D format.
CreateU3DFormat
Creates an instance of U3D format.


CreateU3DFormat

32-bit
64-bit
CF
P
P

Description:

This method creates an instance of U3D format.

Declaration:

public static ImageGear.Formats.IImGearFormat CreateU3DFormat()

Return Value:

The new instance of ImGearU3D Class object.

See Also:

ImGearU3D Class


CreateU3DFormat

32-bit
64-bit
CF
P
P

Description:

This method creates an instance of U3D format. The LibraryPath parameter specifies the path of the folder from which to load U3D and Vector native code libraries.

If LibraryPath is blank, then the current directory is used.

Declaration:

public static ImageGear.Formats.IImGearFormat CreateU3DFormat(string LibraryPath)

Parameters:

Name
Type
Description
LibraryPath
string
Path from which to load U3D and Vector native libraries.

Return Value:

The new instance of ImGearU3D Class object.

See Also:

ImGearU3D Class


ImageGear.Formats.XMP Namespace

ImageGear.Formats.XMP Namespace

32-bit
64-bit
CF
P
P
P

Description:

This namespace provides the API for XMP format.

Declaration:

namespace ImageGear.Formats.XMP

Members:

Classes:
Name
Description
ImGearXMPAlt Generic Class
Represents an array of XMP properties.
ImGearXMPArray Generic Class
Represents baseline features of an array of XMP properties.
ImGearXMPBag Generic Class
Represents an unordered array of XMP properties.
ImGearXMPBoolean Class
Represents a boolean XMP metadata property.
ImGearXMPColorant Class
Represents an XMP colorant structure.
ImGearXMPDate Class
Represents a Date XMP metadata type.
ImGearXMPDimensions Class
Represents an XMP Dimensions structure.
ImGearXMPEnum Generic Class
Represents an enumeration (closed choice of integer) XMP metadata property.
ImGearXMPFont Class
Represents an XMP Font structure.
ImGearXMPFormatMetadata Class
The base for XMP schema accessor classes.
ImGearXMPInteger Class
Represents an integer XMP metadata property.
ImGearXMPLangAlt Class
Represents a language alternative.
ImGearXMPMetadataRoot Class
Provides simplified access to XMP metadata.
ImGearXMPRational Class
Represents a rational XMP metadata property.
ImGearXMPReal Class
Represents a floating point XMP metadata property.
ImGearXMPSeq Generic Class
Represents an ordered array of XMP properties.
ImGearXMPString Class
Represents a string XMP metadata property.
ImGearXMPStructure Abstract Class
Specifies baseline features for XMP structures.
ImGearXMPThumbnail Class
Represents an XMP Thumbnail structure.
ImGearXMPValue Abstract Class
Specifies baseline features for an XMP property value

See Also:

ImageGear.Formats.XMP Namespace

ImageGear.Formats.XMP.AdobePDF Namespace

ImageGear.Formats.XMP.Basic Namespace

ImageGear.Formats.XMP.BasicJobTicket Namespace

ImageGear.Formats.XMP.CameraRaw Namespace

ImageGear.Formats.XMP.DublinCore Namespace

ImageGear.Formats.XMP.DynamicMedia Namespace

ImageGear.Formats.XMP.EXIF Namespace

ImageGear.Formats.XMP.EXIFAux Namespace

ImageGear.Formats.XMP.IPTC4XMPCore Namespace

ImageGear.Formats.XMP.MediaManagement Namespace

ImageGear.Formats.XMP.MicrosoftPhoto Namespace

ImageGear.Formats.XMP.PagedText Namespace

ImageGear.Formats.XMP.Photoshop Namespace

ImageGear.Formats.XMP.RightsManagement Namespace

ImageGear.Formats.XMP.TIFF Namespace


ImageGear.Formats.XMP Namespace Classes

The ImageGear.Formats.XMP Namespace has the following class members:

Classes:
Name
Description
ImGearXMPAlt Generic Class
Represents an array of XMP properties.
ImGearXMPArray Generic Class
Represents baseline features of an array of XMP properties.
ImGearXMPBag Generic Class
Represents an unordered array of XMP properties.
ImGearXMPBoolean Class
Represents a boolean XMP metadata property.
ImGearXMPColorant Class
Represents an XMP colorant structure.
ImGearXMPDate Class
Represents a Date XMP metadata type.
ImGearXMPDimensions Class
Represents an XMP Dimensions structure.
ImGearXMPEnum Generic Class
Represents an enumeration (closed choice of integer) XMP metadata property.
ImGearXMPFont Class
Represents an XMP Font structure.
ImGearXMPFormatMetadata Class
The base for XMP schema accessor classes.
ImGearXMPInteger Class
Represents an integer XMP metadata property.
ImGearXMPLangAlt Class
Represents a language alternative.
ImGearXMPMetadataRoot Class
Provides simplified access to XMP metadata.
ImGearXMPRational Class
Represents a rational XMP metadata property.
ImGearXMPReal Class
Represents a floating point XMP metadata property.
ImGearXMPSeq Generic Class
Represents an ordered array of XMP properties.
ImGearXMPString Class
Represents a string XMP metadata property.
ImGearXMPStructure Abstract Class
Specifies baseline features for XMP structures.
ImGearXMPThumbnail Class
Represents an XMP Thumbnail structure.
ImGearXMPValue Abstract Class
Specifies baseline features for an XMP property value

32-bit
64-bit
CF
P
P
P
32-bit
64-bit
CF
P
P
P
ImageGear.Formats.XMP Namespace > ImGearXMPAlt Generic Class


ImGearXMPAlt Generic Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an array of XMP properties, one of which should be chosen by the application or by the user. First item in the array is considered to be the default one.

Declaration:

public sealed class ImGearXMPAlt<T> : ImageGear.Formats.XMP.ImGearXMPArray<T>
    where T : new(), ImageGear.Formats.XMP.ImGearXMPValue

Members:

Constructors
Name
Description
ImGearXMPAlt Constructor
Creates an instance of ImGearXMPAlt Generic Class.
ImGearXMPAlt Constructor
Creates an instance of ImGearXMPAlt Generic Class and initializes it with values from the string array.


ImGearXMPAlt Generic Class Constructors

Constructors
Name
Description
ImGearXMPAlt Constructor
Creates an instance of ImGearXMPAlt Generic Class.
ImGearXMPAlt Constructor
Creates an instance of ImGearXMPAlt Generic Class and initializes it with values from the string array.

The ImGearXMPAlt Generic Class has the following constructors:


ImGearXMPAlt Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an empty instance of ImGearXMPAlt Generic Class.

Declaration:

public ImGearXMPAlt()

Return Value:

New instance of ImGearXMPAlt Generic Class object.


ImGearXMPAlt Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an instance of ImGearXMPAlt Generic Class and initializes it with values from the string array.

Declaration:

public ImGearXMPAlt(string[] values)

Return Value:

New instance of ImGearXMPAlt Generic Class object.


ImGearXMPArray Generic Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents baseline features of an array of XMP properties.

Declaration:

    public sealed class ImGearXMPArray<T> :
        IList<T>, ICollection<T>, IEnumerable<T>
        where T: ImGearXMPValue, new()

Members:

This class only contains inherited methods.


ImGearXMPBag Generic Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an unordered array of XMP properties.

Declaration:

public sealed class ImGearXMPBag<T> : ImageGear.Formats.XMP.ImGearXMPArray<T>
    where T : new(), ImageGear.Formats.XMP.ImGearXMPValue

Members:

Constructors:
Name
Description
ImGearXMPBag Constructor
Creates an instance of ImGearXMPBag Generic Class.
ImGearXMPBag Constructor
Creates an instance of ImGearXMPBag Generic Class and initializes it with values from the string array.


ImGearXMPBag Generic Class Constructors

The ImGearXMPBag Generic Class has the following constructors:

Constructors:
Name
Description
ImGearXMPBag Constructor
Creates an instance of ImGearXMPBag Generic Class.
ImGearXMPBag Constructor
Creates an instance of ImGearXMPBag Generic Class and initializes it with values from the string array.


ImGearXMPBag Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an empty instance of ImGearXMPBag Generic Class.

Declaration:

public ImGearXMPBag()

Return Value:

New instance of ImGearXMPBag Generic Class object.


ImGearXMPBag Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an instance of ImGearXMPBag Generic Class and initializes it with values from the string array.

Declaration:

public ImGearXMPBag(string[] values)

Return Value:

New instance of ImGearXMPBag Generic Class object.


ImGearXMPBoolean Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents a boolean XMP metadata property.

Declaration:

public class ImGearXMPBoolean : ImGearXMPValue

Members:

Constructors
Name
Description
ImGearXMPBoolean Constructor
Creates and initializes an instance of ImGearXMPBoolean Class with a default value.
ImGearXMPBoolean Constructor
Creates and initializes an instance of ImGearXMPBoolean Class with a bool value.

Properties
Name
Description
Value Property
Gets the boolean value.


ImGearXMPBoolean Class Constructors

The ImGearXMPBoolean Class has the following constructors:

Constructors
Name
Description
ImGearXMPBoolean Constructor
Creates and initializes an instance of ImGearXMPBoolean Class with a default value.
ImGearXMPBoolean Constructor
Creates and initializes an instance of ImGearXMPBoolean Class with a bool value.


ImGearXMPBoolean Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an instance of ImGearXMPBoolean Class and initializes it with a default value (false).

Declaration:

public ImGearXMPBoolean()

Return Value:

New instance of ImGearXMPBoolean Class object.


ImGearXMPBoolean Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPBoolean Class by using a bool value.

Declaration:

public ImGearXMPBoolean(bool value)

Parameters:

Name
Description
value
Boolean value.

Return Value:

New instance of ImGearXMPBoolean Class object.


ImGearXMPBoolean Class Properties

The ImGearXMPBoolean Class has the following properties:

Properties
Name
Description
Value Property
Gets the boolean value.


Value Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets the bool value of the ImGearXMPBoolean object.

Declaration:

public bool Value { get; }

Value:

bool value.


ImGearXMPColorant Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an XMP colorant structure.

This structure contains the characteristics of a colorant (swatch) used in a document.

See XMP specification for structure usage details.

Declaration:

public class ImGearXMPColorant : ImGearXMPStructure

Members:

Constructors
Name
Description
ImGearXMPColorant Constructor
Creates an instance of ImGearXMPColorant Class.

Properties
Name
Description
SwatchName Property
Name of the swatch.
Mode Property
The color space in which the color is defined.
Type Property
The type of color, one of PROCESS or SPOT.
Cyan Property
Cyan value when the mode is CMYK.
Magenta Property
Magenta value when the mode is CMYK.
Yellow Property
Yellow value when the mode is CMYK.
Black Property
Black value when the mode is CMYK.
Red Property
Red value when the mode is RGB.
Green Property
Green value when the mode is RGB.
Blue Property
Blue value when the mode is RGB.
L Property
L value when the mode is LAB.
A Property
A value when the mode is LAB.
B Property
B value when the mode is LAB.


ImGearXMPColorant Class Constructors

The ImGearXMPColorant Class has the following constructors:
Constructors
Name
Description
ImGearXMPColorant Constructor
Creates an instance of ImGearXMPColorant Class.


ImGearXMPColorant Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an instance of ImGearXMPColorant Class.

Declaration:

public ImGearXMPColorant()

Return Value:

New instance of ImGearXMPColorant Class object.


ImGearXMPColorant Class Properties

The ImGearXMPColorant Class has the following properties:

Properties
Name
Description
SwatchName Property
Name of the swatch.
Mode Property
The color space in which the color is defined.
Type Property
The type of color, one of PROCESS or SPOT.
Cyan Property
Cyan value when the mode is CMYK.
Magenta Property
Magenta value when the mode is CMYK.
Yellow Property
Yellow value when the mode is CMYK.
Black Property
Black value when the mode is CMYK.
Red Property
Red value when the mode is RGB.
Green Property
Green value when the mode is RGB.
Blue Property
Blue value when the mode is RGB.
L Property
L value when the mode is LAB.
A Property
A value when the mode is LAB.
B Property
B value when the mode is LAB.


SwatchName Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets the name of the swatch.

Declaration:

public ImGearXMPString SwatchName { get; set; }

Value:

ImGearXMPString Class value.


Mode Property

32-bit
64-bit
CF
P
P
P

Description:

The color space in which the color is defined.

Declaration:

public ImGearXMPString Mode {get; set;}

Value Property

ImGearXMPString Class value.


Type Property

32-bit
64-bit
CF
P
P
P

Description:

The type of color, one of PROCESS or SPOT.

Declaration:

public ImGearXMPString Type {get; set;}

Value:

ImGearXMPString Class value.


Cyan Property

32-bit
64-bit
CF
P
P
P

Description:

Cyan value when the mode is CMYK. Valid range is 0 ... 100.

Declaration:

public ImGearXMPReal Cyan {get; set;}

Value:

ImGearXMPReal Class value.


Magenta Property

32-bit
64-bit
CF
P
P
P

Description:

Magenta value when the mode is CMYK. Valid range is 0 ... 100.

Declaration:

public ImGearXMPReal Magenta {get; set;}

Value:

ImGearXMPReal Class value.


Yellow Property

32-bit
64-bit
CF
P
P
P

Description:

Yellow value when the mode is CMYK. Valid range is 0 ... 100.

Declaration:

public ImGearXMPReal Yellow {get; set;}

Value:

ImGearXMPReal Class value.


Black Property

32-bit
64-bit
CF
P
P
P

Description:

Black value when the mode is CMYK. Valid range is 0 ... 100.

Declaration:

public ImGearXMPReal Black {get; set;}

Value:

ImGearXMPReal Class value.


Red Property

32-bit
64-bit
CF
P
P
P

Description:

Red value when the mode is RGB. Valid range is 0..255.

Declaration:

public ImGearXMPInteger Red {get; set;}

Value:

ImGearXMPInteger Class value.


Green Property

32-bit
64-bit
CF
P
P
P

Description:

Green value when the mode is RGB. Valid range is 0..255.

Declaration:

public ImGearXMPInteger Green {get; set;}

Value:

ImGearXMPInteger Class value.


Blue Property

32-bit
64-bit
CF
P
P
P

Description:

Blue value when the mode is RGB. Valid range is 0..255.

Declaration:

public ImGearXMPInteger Blue {get; set;}

Value:

ImGearXMPInteger Class value.


L Property

32-bit
64-bit
CF
P
P
P

Description:

L value when the mode is LAB. Valid range is 0..100.

Declaration:

public ImGearXMPReal L {get; set;}

Value:

ImGearXMPReal Class value.


A Property

32-bit
64-bit
CF
P
P
P

Description:

A value when the mode is LAB. Valid range is -128..127.

Declaration:

public ImGearXMPInteger A {get; set;}

Value:

ImGearXMPInteger Class value.


B Property

32-bit
64-bit
CF
P
P
P

Description:

B value when the mode is LAB. Valid range is -128..127.

Declaration:

public ImGearXMPInteger B {get; set;}

Value:

ImGearXMPInteger Class value.


ImGearXMPDate Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents a Date XMP metadata type.

Declaration:

public class ImGearXMPDate : ImGearXMPValue

Members:

Constructors
Name
Description
ImGearXMPDate Constructor
Creates and initializes an instance of ImGearXMPDate Class.
ImGearXMPDate Constructor
Creates and initializes an instance of ImGearXMPDate Class.

Properties
Name
Description
Day Property
Represents the Day value.
Fraction Property
Represents the fraction of a second value.
Hour Property
Represents the Hour value.
Minute Property
Represents the Minute value.
Month Property
Represents the Month value.
Second Property
Represents the Second value.
Year Property
Represents the Year value.
ZoneOffsetHour Property
Represents the Zone Offset Hour value.
ZoneOffsetMinute Property
Represents the Zone Offset Minute value.

Methods
Name
Description
GetDateTime Method
Gets the System.DateTime value.


ImGearXMPDate Class Constructors

The ImGearXMPDate Class has the following constructors:
Constructors
Name
Description
ImGearXMPDate Constructor
Creates and initializes an instance of ImGearXMPDate Class.
ImGearXMPDate Constructor
Creates and initializes an instance of ImGearXMPDate Class.


ImGearXMPDate Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an instance of ImGearXMPDate Class and initializes its members to default values.

Declaration:

public ImGearXMPDate()

Return Value:

New instance of ImGearXMPDate Class object.


ImGearXMPDate Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPDate Class from a System.DateTime value. If the kind of DateTime value is Unspecified, the time zone offset (hour and minute) of the ImGearXMPDate Class instance are left uninitialized. If the kind of DateTime value is UTC, the time zone offset (hour and minute) ImGearXMPDate Class instance are initialized with zeroes. If the kind of DateTime value is Local, the time zone offset (hour and minute) ImGearXMPDate Class instance are initialized with local time zone offset.

Declaration:

public ImGearXMPDate(System.DateTime value)

Return Value:

New instance of ImGearXMPDate Class object.


ImGearXMPDate Class Properties

The ImGearXMPDate Class has the following properties:
Properties
Name
Description
Day Property
Represents the Day value.
Fraction Property
Represents the fraction of a second value.
Hour Property
Represents the Hour value.
Minute Property
Represents the Minute value.
Month Property
Represents the Month value.
Second Property
Represents the Second value.
Year Property
Represents the Year value.
ZoneOffsetHour Property
Represents the Zone Offset Hour value.
ZoneOffsetMinute Property
Represents the Zone Offset Minute value.


Day Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Day value. Valid range is 0..31.

Declaration:

public ImGearXMPInteger Day {get; set;}

Value:

ImGearXMPInteger Class value.


Fraction Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the fraction of a second value. The value must be positive.

Declaration:

public ImGearXMPInteger Fraction {get; }

Value:

ImGearXMPInteger Class value.


Hour Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Hour value. Valid range is 0..23.

Declaration:

public ImGearXMPInteger Hour {get; }

Value:

ImGearXMPInteger Class value.


Minute Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Minute value. Valid range is 0..59.

Declaration:

public ImGearXMPInteger Minute {get; }

Value:

ImGearXMPInteger Class value.


Month Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Month value. Valid range is 1..12.

Declaration:

public ImGearXMPInteger Month {get; }

Value:

ImGearXMPInteger Class value.


Second Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Second value. Valid range is 0..59.

Declaration:

public ImGearXMPInteger Second {get; }

Value:

ImGearXMPInteger Class value.


Year Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Year value. Valid range is 0..9999.

Declaration:

public ImGearXMPInteger Year {get; }

Value:

ImGearXMPInteger Class value.


ZoneOffsetHour Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Hour value of the Time Zone Offset. Valid range is -23..23. Negative values correspond to local time which is behind the Universal Coordinated Time (UTC); Positive values correspond to local time which is ahead of the UTC.

Declaration:

public ImGearXMPInteger ZoneOffsetHour {get; }

Value:

ImGearXMPInteger Class value.


ZoneOffsetMinute Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Zone Offset Minute value. Valid range is 0..59.

Declaration:

public ImGearXMPInteger ZoneOffsetMinute {get; }

Value:

ImGearXMPInteger Class value.


ImGearXMPDate Class Methods

The ImGearXMPDate Class has the following methods:
Methods
Name
Description
GetDateTime Method
Gets the System.DateTime value.


GetDateTime Method

32-bit
64-bit
CF
P
P
P

Description:

This method gets the System.DateTime value corresponding to the ImGearXMPDate Class. If the XMP date does not contain time zone designator, the method returns an DateTime value of an unspecified kind. If the XMP date contains time zone designator, the method returns an DateTime value of UTC kind.

Declaration:

public GetDateTime()

Return Value:

System.DateTime value.


ImGearXMPDimensions Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an XMP Dimensions structure.

This structure contains dimensions of a drawn object.

See XMP specification for structure usage details.

Declaration:

public class ImGearXMPDimensions : ImGearXMPStructure

Members:

Constructors
Name
Description
ImGearXMPDimensions Constructor
Creates an instance of ImGearXMPDimensions Class.

Properties
Name
Description
Height Property
Represents height.
Unit Property
Represents units.
Width Property
Represents width.


ImGearXMPDimensions Class Constructors

The ImGearXMPDimensions Class has the following constructors:
Constructors
Name
Description
ImGearXMPDimensions Constructor
Creates an instance of ImGearXMPDimensions Class.


ImGearXMPDimensions Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an instance of ImGearXMPDimensions Class.

Declaration:

public ImGearXMPDimensions()

Return Value:

New instance of ImGearXMPDimensions Class object.


ImGearXMPDimensions Class Properties

The ImGearXMPDimensions Class has the following properties:
Properties
Name
Description
Height Property
Represents height
Unit Property
Represents units.
Width Property
Represents width


Height Property

32-bit
64-bit
CF
P
P
P

Description:

Represents height.

Declaration:

public ImGearXMPReal Height {get; set; }

Value:

ImGearXMPReal Class value.


Unit Property

32-bit
64-bit
CF
P
P
P

Description:

Represents units. For example: inch, mm, pixel, pica, point.

Declaration:

public ImGearXMPString Unit {get; set; }

Value:

ImGearXMPString Class value.


Width Property

32-bit
64-bit
CF
P
P
P

Description:

Represents width.

Declaration:

public ImGearXMPReal Width {get; set; }

Value:

ImGearXMPReal Class value.


ImGearXMPEnum Generic Class

32-bit
64-bit
CF
P
P
P

Description:

This generic class represents an enumeration (closed choice of integer) XMP metadata property.

Declaration:

public class ImGearXMPEnum<T> : ImGearXMPValue
where T : struct, IComparable, IFormattable, IConvertible

Members:

Constructors
Name
Description
ImGearXMPEnum Constructor
Creates and initializes an instance of ImGearXMPEnum Generic Class.
ImGearXMPEnum Constructor
Creates and initializes an instance of ImGearXMPEnum Generic Class.

Properties
Name
Description
Value Property
Gets the enum value.


ImGearXMPEnum Generic Class Constructors

The ImGearXMPEnum Generic Class has the following constructors:
Constructors
Name
Description
ImGearXMPEnum Constructor
Creates and initializes an instance of ImGearXMPEnum Generic Class.
ImGearXMPEnum Constructor
Creates and initializes an instance of ImGearXMPEnum Generic Class.


ImGearXMPEnum Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an instance of ImGearXMPEnum Generic Class.

Declaration:

public ImGearXMPEnum()

Return Value:

New instance of ImGearXMPEnum Generic Class object.


ImGearXMPEnum Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPEnum Generic Class by using an enumeration value.

Declaration:

public ImGearXMPEnum(T value)

Parameters:

Name
Description
value
Enum value.

Return Value:

New instance of ImGearXMPEnum Generic Class object.


ImGearXMPEnum Generic Class Properties

The ImGearXMPEnum Generic Class has the following properties:
Properties
Name
Description
Value Property
Gets the enum value.


Value Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets the enumeration value of the ImGearXMPEnum Generic Class object.

Declaration:

public T Value { get; }

Value:

T value.


ImGearXMPFont Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an XMP Font structure.

This structure contains the characteristics of a font used in a document.

See XMP specification for structure usage details.

Declaration:

public class ImGearXMPFont : ImGearXMPStructure

Members:

Constructors
Name
Description
ImGearXMPFont Constructor
Creates an instance of ImGearXMPFont Class.

Properties
Name
Description
FontName Property
Represents postscript name of the font.
FontFamily Property
Represents the font family name.
FontFace Property
Represents the font face name.
FontType Property
Represents the font type
VersionString Property
Represents the version string
Composite Property
When true, specifies a composite font.
FontFileName Property
Represents the font file name (not a complete path).
ChildFontFiles Property
Represents the list of file names for the fonts that make up a composite font


ImGearXMPFont Class Constructors

The ImGearXMPFont Class has the following constructors:
Constructors
Name
Description
ImGearXMPFont Constructor
Creates an instance of ImGearXMPFont Class.


ImGearXMPFont Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an instance of ImGearXMPFont Class.

Declaration:

public ImGearXMPFont()

Return Value:

New instance of ImGearXMPFont Class object.


ImGearXMPFont Class Properties

The ImGearXMPFont Class has the following properties:
Properties
Name
Description
FontName Property
Represents postscript name of the font.
FontFamily Property
Represents the font family name.
FontFace Property
Represents the font face name.
FontType Property
Represents the font type
VersionString Property
Represents the version string
Composite Property
When true, specifies a composite font.
FontFileName Property
Represents the font file name (not a complete path).
ChildFontFiles Property
Represents the list of file names for the fonts that make up a composite font


FontName Property

32-bit
64-bit
CF
P
P
P

Description:

Represents postscript name of the font.

Declaration:

public ImGearXMPString FontName {get; set; }

Value:

ImGearXMPString Class value.


FontFamily Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the font family name.

Declaration:

public ImGearXMPString FontFamily {get; set; }

Value:

ImGearXMPString Class value.


FontFace Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the font face name.

Declaration:

public ImGearXMPString FontFace {get; set; }

Value:

ImGearXMPString Class value.


FontType Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the font type.

Declaration:

public ImGearXMPString FontType {get; set; }

Value:

ImGearXMPString Class value.


VersionString Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the version string.

Declaration:

public ImGearXMPString VersionString {get; set; }

Value:

ImGearXMPString Class value.


Composite Property

32-bit
64-bit
CF
P
P
P

Description:

When true, specifies a composite font.

Declaration:

public ImGearXMPBoolean Composite {get; set; }

Value:

ImGearXMPBoolean Class value.


FontFileName Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the font file name (not a complete path).

Declaration:

public ImGearXMPString FontFileName {get; set; }

Value:

ImGearXMPString Class value.


ChildFontFiles Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the list of file names for the fonts that make up a composite font.

Declaration:

public ImGearXMPSeq<ImGearXMPString> ChildFontFiles {get; set; }

Value:

ImGearXMPString Class value.


ImGearXMPFormatMetadata Class

32-bit
64-bit
CF
P
P
P

Description:

This class serves as the base for XMP schema accessor classes.

Declaration:

public class ImGearXMPFormatMetadata : ImGearFormatMetadata

Members:

This class does not have public members.


ImGearXMPInteger Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an integer XMP metadata property.

Declaration:

public class ImGearXMPInteger : ImGearXMPValue

Members:

Constructors
Name
Description
ImGearXMPInteger Constructor
Creates and initializes an instance of ImGearXMPInteger Class.
ImGearXMPInteger Constructor
Creates and initializes an instance of ImGearXMPInteger Class.

Properties
Name
Description
Value Property
Gets the integer value.


ImGearXMPInteger Class Constructors

The ImGearXMPInteger Class has the following constructors:
Constructors
Name
Description
ImGearXMPInteger Constructor
Creates and initializes an instance of ImGearXMPInteger Class.
ImGearXMPInteger Constructor
Creates and initializes an instance of ImGearXMPInteger Class.


ImGearXMPInteger Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an instance of ImGearXMPInteger Class.

Declaration:

public ImGearXMPInteger()

Return Value:

New instance of ImGearXMPInteger Class object.


ImGearXMPInteger Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPInteger Class by using an integer value.

Declaration:

public ImGearXMPInteger(int value)

Parameters:

Name
Description
value
Integer value.

Return Value:

New instance of ImGearXMPInteger Class object.


ImGearXMPInteger Class Properties

The ImGearXMPInteger Class has the following properties:
Properties
Name
Description
Value Property
Gets the integer value.


Value Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets the integer value of the ImGearXMPInteger Class object.

Declaration:

public int Value { get; }

Value:

int value.


ImGearXMPLangAlt Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents a language alternative. It contains the same logical text in multiple languages. The text in each specific language is available through properties of the ImGearXMPLangAlt object. If text in a specific language is does not exist in the object, corresponding property returns null. ImGearXMPLangAlt.Default property represents the default value for the language alternative.

Declaration:

public class ImGearXMPLangAlt

Members:

Constructors
Name
Description
ImGearXMPLangAlt Constructor
Creates and initializes an instance of ImGearXMPLangAlt class.

Properties
Name
Description
Afrikaans Property
Represents the Afrikaans text alternative.
Albanian Property
Represents the Albanian text alternative.
ArabicUnitedArabEmirates Property
Represents the Arabic - United Arab Emirates text alternative.
ArabicBahrain Property
Represents the Arabic - Bahrain text alternative.
ArabicAlgeria Property
Represents the Arabic - Algeria text alternative.
ArabicEgypt Property
Represents the Arabic - Egypt text alternative.
ArabicIraq Property
Represents the Arabic - Iraq text alternative.
ArabicJordan Property
Represents the Arabic - Jordan text alternative.
ArabicKuwait Property
Represents the Arabic - Kuwait text alternative.
ArabicLebanon Property
Represents the Arabic - Lebanon text alternative.
ArabicLibya Property
Represents the Arabic - Libya text alternative.
ArabicMorocco Property
Represents the Arabic - Morocco text alternative.
ArabicOman Property
Represents the Arabic - Oman text alternative.
ArabicQatar Property
Represents the Arabic - Qatar text alternative.
ArabicSaudiArabia Property
Represents the Arabic - Saudi Arabia text alternative.
ArabicSyria Property
Represents the Arabic - Syria text alternative.
ArabicTunisia Property
Represents the Arabic - Tunisia text alternative.
ArabicYemen Property
Represents the Arabic - Yemen text alternative.
Armenian Property
Represents the Armenian text alternative.
AzeriLatin Property
Represents the Azeri - Latin text alternative.
AzeriCyrillic Property
Represents the Azeri - Cyrillic text alternative.
Basque Property
Represents the Basque text alternative.
Belarusian Property
Represents the Belarusian text alternative.
Bulgarian Property
Represents the Bulgarian text alternative.
Catalan Property
Represents the Catalan text alternative.
ChineseChina Property
Represents the Chinese - China text alternative.
ChineseHongKongSAR Property
Represents the Chinese - Hong Kong SAR text alternative.
ChineseMacauSAR Property
Represents the Chinese - Macau SAR text alternative.
ChineseSingapore Property
Represents the Chinese - Singapore text alternative.
ChineseTaiwan Property
Represents the Chinese - Taiwan text alternative.
Croatian Property
Represents the Croatian text alternative.
Czech Property
Represents the Czech text alternative.
Danish Property
Represents the Danish text alternative.
Default Property
Represents the default text alternative.
DutchNetherlands Property
Represents the Dutch - Netherlands text alternative.
DutchBelgium Property
Represents the Dutch - Belgium text alternative.
EnglishAustralia Property
Represents the English - Australia text alternative.
EnglishBelize Property
Represents the English - Belize text alternative.
EnglishCanada Property
Represents the English - Canada text alternative.
EnglishCaribbean Property
Represents the English - Caribbean text alternative.
EnglishIreland Property
Represents the English - Ireland text alternative.
EnglishJamaica Property
Represents the English - Jamaica text alternative.
EnglishNewZealand Property
Represents the English - New Zealand text alternative.
EnglishPhillippines Property
Represents the English - Phillippines text alternative.
EnglishSouthAfrica Property
Represents the English - South Africa text alternative.
EnglishTrinidad Property
Represents the English - Trinidad text alternative.
EnglishUnitedKingdom Property
Represents the English - United Kingdom text alternative.
EnglishUnitedStates Property
Represents the English - United States text alternative.
Estonian Property
Represents the Estonian text alternative.
Farsi Property
Represents the Farsi text alternative.
Finnish Property
Represents the Finnish text alternative.
Faroese Property
Represents the Faroese text alternative.
FrenchFrance Property
Represents the French - France text alternative.
FrenchBelgium Property
Represents the French - Belgium text alternative.
FrenchCanada Property
Represents the French - Canada text alternative.
FrenchLuxembourg Property
Represents the French - Luxembourg text alternative.
FrenchSwitzerland Property
Represents the French - Switzerland text alternative.
GaelicIreland Property
Represents the Gaelic - Ireland text alternative.
GaelicScotland Property
Represents the Gaelic - Scotland text alternative.
GermanGermany Property
Represents the German - Germany text alternative.
GermanAustria Property
Represents the German - Austria text alternative.
GermanLiechtenstein Property
Represents the German - Liechtenstein text alternative.
GermanLuxembourg Property
Represents the German - Luxembourg text alternative.
GermanSwitzerland Property
Represents the German - Switzerland text alternative.
Greek Property
Represents the Greek text alternative.
Hebrew Property
Represents the Hebrew text alternative.
Hindi Property
Represents the Hindi text alternative.
Hungarian Property
Represents the Hungarian text alternative.
Icelandic Property
Represents the Icelandic text alternative.
Indonesian Property
Represents the Indonesian text alternative.
ItalianItaly Property
Represents the Italian - Italy text alternative.
ItalianSwitzerland Property
Represents the Italian - Switzerland text alternative.
Japanese Property
Represents the Japanese text alternative.
Korean Property
Represents the Korean text alternative.
Latvian Property
Represents the Latvian text alternative.
Lithuanian Property
Represents the Lithuanian text alternative.
MacedonianFYROM Property
Represents the Macedonian - FYROM text alternative.
MalayMalaysia Property
Represents the Malay - Malaysia text alternative.
MalayBrunei Property
Represents the Malay - Brunei text alternative.
Maltese Property
Represents the Maltese text alternative.
NorwegianBokml Property
Represents the Norwegian - Bokml text alternative.
NorwegianNynorsk Property
Represents the Norwegian - Nynorsk text alternative.
Polish Property
Represents the Polish text alternative.
PortuguesePortugal Property
Represents the Portuguese - Portugal text alternative.
PortugueseBrazil Property
Represents the Portuguese - Brazil text alternative.
RaetoRomance Property
Represents the Raeto - Romance text alternative.
RomanianRomania Property
Represents the Romanian - Romania text alternative.
RomanianMoldova Property
Represents the Romanian - Moldova text alternative.
Russian Property
Represents the Russian text alternative.
RussianMoldova Property
Represents the Russian - Moldova text alternative.
Sanskrit Property
Represents the Sanskrit text alternative.
SerbianCyrillic Property
Represents the Serbian - Cyrillic text alternative.
SerbianLatin Property
Represents the Serbian - Latin text alternative.
Setsuana Property
Represents the Setsuana text alternative.
Slovenian Property
Represents the Slovenian text alternative.
Slovak Property
Represents the Slovak text alternative.
Sorbian Property
Represents the Sorbian text alternative.
SpanishSpain Property
Represents the Spanish - Spain text alternative.
SpanishArgentina Property
Represents the Spanish - Argentina text alternative.
SpanishBolivia Property
Represents the Spanish - Bolivia text alternative.
SpanishChile Property
Represents the Spanish - Chile text alternative.
SpanishColombia Property
Represents the Spanish - Colombia text alternative.
SpanishCosta Property
Represents the Spanish - Costa text alternative.
SpanishDominican Property
Represents the Spanish - Dominican text alternative.
SpanishEcuador Property
Represents the Spanish - Ecuador text alternative.
SpanishGuatemala Property
Represents the Spanish - Guatemala text alternative.
SpanishHonduras Property
Represents the Spanish - Honduras text alternative.
SpanishMexico Property
Represents the Spanish - Mexico text alternative.
SpanishNicaragua Property
Represents the Spanish - Nicaragua text alternative.
SpanishPanama Property
Represents the Spanish - Panama text alternative.
SpanishPeru Property
Represents the Spanish - Peru text alternative.
SpanishPuertoRico Property
Represents the Spanish - Puerto Rico text alternative.
SpanishParaguay Property
Represents the Spanish - Paraguay text alternative.
SpanishElSalvador Property
Represents the Spanish - El Salvador text alternative.
SpanishUruguay Property
Represents the Spanish - Uruguay text alternative.
SpanishVenezuela Property
Represents the Spanish - Venezuela text alternative.
SouthernSotho Property
Represents the Southern Sotho text alternative.
Swahili Property
Represents the Swahili text alternative.
SwedishSweden Property
Represents the Swedish - Sweden text alternative.
SwedishFinland Property
Represents the Swedish - Finland text alternative.
Tamil Property
Represents the Tamil text alternative.
Tatar Property
Represents the Tatar text alternative.
Thai Property
Represents the Thai text alternative.
Turkish Property
Represents the Turkish text alternative.
Tsonga Property
Represents the Tsonga text alternative.
Ukrainian Property
Represents the Ukrainian text alternative.
Urdu Property
Represents the Urdu text alternative.
UzbekCyrillic Property
Represents the Uzbek - Cyrillic text alternative.
UzbekLatin Property
Represents the Uzbek - Latin text alternative.
Vietnamese Property
Represents the Vietnamese text alternative.
Xhosa Property
Represents the Xhosa text alternative.
Yiddish Property
Represents the Yiddish text alternative.
Zulu Property
Represents the Zulu text alternative.


ImGearXMPLangAlt Class Constructors

The ImGearXMPLangAlt Class has the following constructors:
Constructors
Name
Description
ImGearXMPLangAlt Constructor
Creates and initializes an instance of ImGearXMPLangAlt class.


ImGearXMPLangAlt Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an empty instance of ImGearXMPLangAlt Class. Use properties of the class to add language alternatives to the new object.

Declaration:

public ImGearXMPLangAlt()

Return value

New instance of ImGearXMPLangAlt Class object.


ImGearXMPLangAlt Class Properties

The ImGearXMPLangAlt Class has the following properties:

Properties
Name
Description
Afrikaans Property
Represents the Afrikaans text alternative.
Albanian Property
Represents the Albanian text alternative.
ArabicUnitedArabEmirates Property
Represents the Arabic - United Arab Emirates text alternative.
ArabicBahrain Property
Represents the Arabic - Bahrain text alternative.
ArabicAlgeria Property
Represents the Arabic - Algeria text alternative.
ArabicEgypt Property
Represents the Arabic - Egypt text alternative.
ArabicIraq Property
Represents the Arabic - Iraq text alternative.
ArabicJordan Property
Represents the Arabic - Jordan text alternative.
ArabicKuwait Property
Represents the Arabic - Kuwait text alternative.
ArabicLebanon Property
Represents the Arabic - Lebanon text alternative.
ArabicLibya Property
Represents the Arabic - Libya text alternative.
ArabicMorocco Property
Represents the Arabic - Morocco text alternative.
ArabicOman Property
Represents the Arabic - Oman text alternative.
ArabicQatar Property
Represents the Arabic - Qatar text alternative.
ArabicSaudiArabia Property
Represents the Arabic - Saudi Arabia text alternative.
ArabicSyria Property
Represents the Arabic - Syria text alternative.
ArabicTunisia Property
Represents the Arabic - Tunisia text alternative.
ArabicYemen Property
Represents the Arabic - Yemen text alternative.
Armenian Property
Represents the Armenian text alternative.
AzeriLatin Property
Represents the Azeri - Latin text alternative.
AzeriCyrillic Property
Represents the Azeri - Cyrillic text alternative.
Basque Property
Represents the Basque text alternative.
Belarusian Property
Represents the Belarusian text alternative.
Bulgarian Property
Represents the Bulgarian text alternative.
Catalan Property
Represents the Catalan text alternative.
ChineseChina Property
Represents the Chinese - China text alternative.
ChineseHongKongSAR Property
Represents the Chinese - Hong Kong SAR text alternative.
ChineseMacauSAR Property
Represents the Chinese - Macau SAR text alternative.
ChineseSingapore Property
Represents the Chinese - Singapore text alternative.
ChineseTaiwan Property
Represents the Chinese - Taiwan text alternative.
Croatian Property
Represents the Croatian text alternative.
Czech Property
Represents the Czech text alternative.
Danish Property
Represents the Danish text alternative.
Default Property
Represents the default text alternative.
DutchNetherlands Property
Represents the Dutch - Netherlands text alternative.
DutchBelgium Property
Represents the Dutch - Belgium text alternative.
EnglishAustralia Property
Represents the English - Australia text alternative.
EnglishBelize Property
Represents the English - Belize text alternative.
EnglishCanada Property
Represents the English - Canada text alternative.
EnglishCaribbean Property
Represents the English - Caribbean text alternative.
EnglishIreland Property
Represents the English - Ireland text alternative.
EnglishJamaica Property
Represents the English - Jamaica text alternative.
EnglishNewZealand Property
Represents the English - New Zealand text alternative.
EnglishPhillippines Property
Represents the English - Phillippines text alternative.
EnglishSouthAfrica Property
Represents the English - South Africa text alternative.
EnglishTrinidad Property
Represents the English - Trinidad text alternative.
EnglishUnitedKingdom Property
Represents the English - United Kingdom text alternative.
EnglishUnitedStates Property
Represents the English - United States text alternative.
Estonian Property
Represents the Estonian text alternative.
Farsi Property
Represents the Farsi text alternative.
Finnish Property
Represents the Finnish text alternative.
Faroese Property
Represents the Faroese text alternative.
FrenchFrance Property
Represents the French - France text alternative.
FrenchBelgium Property
Represents the French - Belgium text alternative.
FrenchCanada Property
Represents the French - Canada text alternative.
FrenchLuxembourg Property
Represents the French - Luxembourg text alternative.
FrenchSwitzerland Property
Represents the French - Switzerland text alternative.
GaelicIreland Property
Represents the Gaelic - Ireland text alternative.
GaelicScotland Property
Represents the Gaelic - Scotland text alternative.
GermanGermany Property
Represents the German - Germany text alternative.
GermanAustria Property
Represents the German - Austria text alternative.
GermanLiechtenstein Property
Represents the German - Liechtenstein text alternative.
GermanLuxembourg Property
Represents the German - Luxembourg text alternative.
GermanSwitzerland Property
Represents the German - Switzerland text alternative.
Greek Property
Represents the Greek text alternative.
Hebrew Property
Represents the Hebrew text alternative.
Hindi Property
Represents the Hindi text alternative.
Hungarian Property
Represents the Hungarian text alternative.
Icelandic Property
Represents the Icelandic text alternative.
Indonesian Property
Represents the Indonesian text alternative.
ItalianItaly Property
Represents the Italian - Italy text alternative.
ItalianSwitzerland Property
Represents the Italian - Switzerland text alternative.
Japanese Property
Represents the Japanese text alternative.
Korean Property
Represents the Korean text alternative.
Latvian Property
Represents the Latvian text alternative.
Lithuanian Property
Represents the Lithuanian text alternative.
MacedonianFYROM Property
Represents the Macedonian - FYROM text alternative.
MalayMalaysia Property
Represents the Malay - Malaysia text alternative.
MalayBrunei Property
Represents the Malay - Brunei text alternative.
Maltese Property
Represents the Maltese text alternative.
NorwegianBokml Property
Represents the Norwegian - Bokml text alternative.
NorwegianNynorsk Property
Represents the Norwegian - Nynorsk text alternative.
Polish Property
Represents the Polish text alternative.
PortuguesePortugal Property
Represents the Portuguese - Portugal text alternative.
PortugueseBrazil Property
Represents the Portuguese - Brazil text alternative.
RaetoRomance Property
Represents the Raeto - Romance text alternative.
RomanianRomania Property
Represents the Romanian - Romania text alternative.
RomanianMoldova Property
Represents the Romanian - Moldova text alternative.
Russian Property
Represents the Russian text alternative.
RussianMoldova Property
Represents the Russian - Moldova text alternative.
Sanskrit Property
Represents the Sanskrit text alternative.
SerbianCyrillic Property
Represents the Serbian - Cyrillic text alternative.
SerbianLatin Property
Represents the Serbian - Latin text alternative.
Setsuana Property
Represents the Setsuana text alternative.
Slovenian Property
Represents the Slovenian text alternative.
Slovak Property
Represents the Slovak text alternative.
Sorbian Property
Represents the Sorbian text alternative.
SpanishSpain Property
Represents the Spanish - Spain text alternative.
SpanishArgentina Property
Represents the Spanish - Argentina text alternative.
SpanishBolivia Property
Represents the Spanish - Bolivia text alternative.
SpanishChile Property
Represents the Spanish - Chile text alternative.
SpanishColombia Property
Represents the Spanish - Colombia text alternative.
SpanishCosta Property
Represents the Spanish - Costa text alternative.
SpanishDominican Property
Represents the Spanish - Dominican text alternative.
SpanishEcuador Property
Represents the Spanish - Ecuador text alternative.
SpanishGuatemala Property
Represents the Spanish - Guatemala text alternative.
SpanishHonduras Property
Represents the Spanish - Honduras text alternative.
SpanishMexico Property
Represents the Spanish - Mexico text alternative.
SpanishNicaragua Property
Represents the Spanish - Nicaragua text alternative.
SpanishPanama Property
Represents the Spanish - Panama text alternative.
SpanishPeru Property
Represents the Spanish - Peru text alternative.
SpanishPuertoRico Property
Represents the Spanish - Puerto Rico text alternative.
SpanishParaguay Property
Represents the Spanish - Paraguay text alternative.
SpanishElSalvador Property
Represents the Spanish - El Salvador text alternative.
SpanishUruguay Property
Represents the Spanish - Uruguay text alternative.
SpanishVenezuela Property
Represents the Spanish - Venezuela text alternative.
SouthernSotho Property
Represents the Southern Sotho text alternative.
Swahili Property
Represents the Swahili text alternative.
SwedishSweden Property
Represents the Swedish - Sweden text alternative.
SwedishFinland Property
Represents the Swedish - Finland text alternative.
Tamil Property
Represents the Tamil text alternative.
Tatar Property
Represents the Tatar text alternative.
Thai Property
Represents the Thai text alternative.
Turkish Property
Represents the Turkish text alternative.
Tsonga Property
Represents the Tsonga text alternative.
Ukrainian Property
Represents the Ukrainian text alternative.
Urdu Property
Represents the Urdu text alternative.
UzbekCyrillic Property
Represents the Uzbek - Cyrillic text alternative.
UzbekLatin Property
Represents the Uzbek - Latin text alternative.
Vietnamese Property
Represents the Vietnamese text alternative.
Xhosa Property
Represents the Xhosa text alternative.
Yiddish Property
Represents the Yiddish text alternative.
Zulu Property
Represents the Zulu text alternative.


Afrikaans Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Afrikaans text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Afrikaans {get; set; }

Value:

String value.


Albanian Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Albanian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Albanian {get; set; }

Value:

String value.


ArabicUnitedArabEmirates Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Arabic - United Arab Emirates text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string ArabicUnitedArabEmirates {get; set; }

Value:

String value.


ArabicBahrain Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Arabic - Bahrain text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string ArabicBahrain {get; set; }

Value:

String value.


ArabicAlgeria Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Arabic - Algeria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string ArabicAlgeria {get; set; }

Value:

String value.


ArabicEgypt Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Arabic - Egypt text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string ArabicEgypt {get; set; }

Value:

String value.


ArabicIraq Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Arabic - Iraq text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string ArabicIraq {get; set; }

Value:

String value.


ArabicJordan Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Arabic - Jordan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string ArabicJordan {get; set; }

Value:

String value.


ArabicKuwait Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Arabic - Kuwait text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string ArabicKuwait {get; set; }

Value:

String value.


ArabicLebanon Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Arabic - Lebanon text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string ArabicLebanon {get; set; }

Value:

String value.


ArabicLibya Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Arabic - Libya text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string ArabicLibya {get; set; }

Value:

String value.


ArabicMorocco Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Arabic - Morocco text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string ArabicMorocco {get; set; }

Value:

String value.


ArabicOman Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Arabic - Oman text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string ArabicOman {get; set; }

Value:

String value.


ArabicQatar Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Arabic - Qatar text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string ArabicQatar {get; set; }

Value:

String value.


ArabicSaudiArabia Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Arabic - Saudi Arabia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string ArabicSaudiArabia {get; set; }

Value:

String value.


ArabicSyria Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Arabic - Syria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string ArabicSyria {get; set; }

Value:

String value.


ArabicTunisia Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Arabic - Tunisia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string ArabicTunisia {get; set; }

Value:

String value.


ArabicYemen Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Arabic - Yemen text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string ArabicYemen {get; set; }

Value:

String value.


Armenian Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Armenian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Armenian {get; set; }

Value:

String value.


AzeriLatin Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Azeri - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string AzeriLatin {get; set; }

Value:

String value.


AzeriCyrillic Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Azeri - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string AzeriCyrillic {get; set; }

Value:

String value.


Basque Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Basque text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Basque {get; set; }

Value:

String value.


Belarusian Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Belarusian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Belarusian {get; set; }

Value:

String value.


Bulgarian Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Bulgarian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Bulgarian {get; set; }

Value:

String value.


Catalan Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Catalan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Catalan {get; set; }

Value:

String value.


ChineseChina Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Chinese - China text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string ChineseChina {get; set; }

Value:

String value.


ChineseHongKongSAR Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Chinese - Hong Kong SAR text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string ChineseHongKongSAR {get; set; }

Value:

String value.


ChineseMacauSAR Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Chinese - Macau SAR text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string ChineseMacauSAR {get; set; }

Value:

String value.


ChineseSingapore Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Chinese - Singapore text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string ChineseSingapore {get; set; }

Value:

String value.


ChineseTaiwan Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Chinese - Taiwan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string ChineseTaiwan {get; set; }

Value:

String value.


Croatian Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Croatian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Croatian {get; set; }

Value:

String value.


Czech Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Czech text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Czech {get; set; }

Value:

String value.


Danish Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Danish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Danish {get; set; }

Value:

String value.


Default Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the default text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Default {get; set; }

Value:

String value.


DutchNetherlands Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Dutch - Netherlands text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string DutchNetherlands {get; set; }

Value:

String value.


DutchBelgium Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Dutch - Belgium text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string DutchBelgium {get; set; }

Value:

String value.


EnglishAustralia Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the English - Australia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string EnglishAustralia {get; set; }

Value:

String value.


EnglishBelize Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the English - Belize text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string EnglishBelize {get; set; }

Value:

String value.


EnglishCanada Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the English - Canada text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string EnglishCanada {get; set; }

Value:

String value.


EnglishCaribbean Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the English - Caribbean text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string EnglishCaribbean {get; set; }

Value:

String value.


EnglishIreland Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the English - Ireland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string EnglishIreland {get; set; }

Value:

String value.


EnglishJamaica Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the English - Jamaica text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string EnglishJamaica {get; set; }

Value:

String value.


EnglishNewZealand Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the English - New Zealand text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string EnglishNewZealand {get; set; }

Value:

String value.


EnglishPhillippines Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the English - Phillippines text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string EnglishPhillippines {get; set; }

Value:

String value.


EnglishSouthAfrica Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the English - South Africa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string EnglishSouthAfrica {get; set; }

Value:

String value.


EnglishTrinidad Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the English - Trinidad text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string EnglishTrinidad {get; set; }

Value:

String value.


EnglishUnitedKingdom Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the English - United Kingdom text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string EnglishUnitedKingdom {get; set; }

Value:

String value.


EnglishUnitedStates Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the English - United States text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string EnglishUnitedStates {get; set; }

Value:

String value.


Estonian Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Estonian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Estonian {get; set; }

Value:

String value.


Farsi Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Farsi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Farsi {get; set; }

Value:

String value.


Finnish Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Finnish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Finnish {get; set; }

Value:

String value.


Faroese Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Faroese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Faroese {get; set; }

Value:

String value.


FrenchFrance Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the French - France text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string FrenchFrance {get; set; }

Value:

String value.


FrenchBelgium Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the French - Belgium text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string FrenchBelgium {get; set; }

Value:

String value.


FrenchCanada Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the French - Canada text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string FrenchCanada {get; set; }

Value:

String value.


FrenchLuxembourg Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the French - Luxembourg text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string FrenchLuxembourg {get; set; }

Value:

String value.


FrenchSwitzerland Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the French - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string FrenchSwitzerland {get; set; }

Value:

String value.


GaelicIreland Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Gaelic - Ireland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string GaelicIreland {get; set; }

Value:

String value.


GaelicScotland Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Gaelic - Scotland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string GaelicScotland {get; set; }

Value:

String value.


GermanGermany Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the German - Germany text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string GermanGermany {get; set; }

Value:

String value.


GermanAustria Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the German - Austria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string GermanAustria {get; set; }

Value:

String value.


GermanLiechtenstein Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the German - Liechtenstein text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string GermanLiechtenstein {get; set; }

Value:

String value.


GermanLuxembourg Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the German - Luxembourg text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string GermanLuxembourg {get; set; }

Value:

String value.


GermanSwitzerland Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the German - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string GermanSwitzerland {get; set; }

Value:

String value.


Greek Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Greek text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Greek {get; set; }

Value:

String value.


Hebrew Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Hebrew text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Hebrew {get; set; }

Value:

String value.


Hindi Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Hindi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Hindi {get; set; }

Value:

String value.


Hungarian Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Hungarian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Hungarian {get; set; }

Value:

String value.


Icelandic Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Icelandic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Icelandic {get; set; }

Value:

String value.


Indonesian Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Indonesian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Indonesian {get; set; }

Value:

String value.


ItalianItaly Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Italian - Italy text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string ItalianItaly {get; set; }

Value:

String value.


ItalianSwitzerland Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Italian - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string ItalianSwitzerland {get; set; }

Value:

String value.


Japanese Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Japanese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Japanese {get; set; }

Value:

String value.


Korean Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Korean text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Korean {get; set; }

Value:

String value.


Latvian Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Latvian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Latvian {get; set; }

Value:

String value.


Lithuanian Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Lithuanian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Lithuanian {get; set; }

Value:

String value.


MacedonianFYROM Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Macedonian - FYROM text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string MacedonianFYROM {get; set; }

Value:

String value.


MalayMalaysia Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Malay - Malaysia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string MalayMalaysia {get; set; }

Value:

String value.


MalayBrunei Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Malay - Brunei text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string MalayBrunei {get; set; }

Value:

String value.


Maltese Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Maltese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Maltese {get; set; }

Value:

String value.


NorwegianBokml Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Norwegian - Bokml text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string NorwegianBokml {get; set; }

Value:

String value.


NorwegianNynorsk Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Norwegian - Nynorsk text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string NorwegianNynorsk {get; set; }

Value:

String value.


Polish Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Polish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Polish {get; set; }

Value:

String value.


PortuguesePortugal Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Portuguese - Portugal text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string PortuguesePortugal {get; set; }

Value:

String value.


PortugueseBrazil Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Portuguese - Brazil text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string PortugueseBrazil {get; set; }

Value:

String value.


RaetoRomance Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Raeto - Romance text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string RaetoRomance {get; set; }

Value:

String value.


RomanianRomania Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Romanian - Romania text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string RomanianRomania {get; set; }

Value:

String value.


RomanianMoldova Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Romanian - Moldova text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string RomanianMoldova {get; set; }

Value:

String value.


Russian Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Russian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Russian {get; set; }

Value:

String value.


RussianMoldova Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Russian - Moldova text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string RussianMoldova {get; set; }

Value:

String value.


Sanskrit Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Sanskrit text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Sanskrit {get; set; }

Value:

String value.


SerbianCyrillic Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Serbian - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string SerbianCyrillic {get; set; }

Value:

String value.


SerbianLatin Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Serbian - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string SerbianLatin {get; set; }

Value:

String value.


Setsuana Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Setsuana text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Setsuana {get; set; }

Value:

String value.


Slovenian Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Slovenian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Slovenian {get; set; }

Value:

String value.


Slovak Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Slovak text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Slovak {get; set; }

Value:

String value.


Sorbian Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Sorbian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Sorbian {get; set; }

Value:

String value.


SpanishSpain Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Spanish - Spain text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string SpanishSpain {get; set; }

Value:

String value.


SpanishArgentina Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Spanish - Argentina text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string SpanishArgentina {get; set; }

Value:

String value.


SpanishBolivia Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Spanish - Bolivia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string SpanishBolivia {get; set; }

Value:

String value.


SpanishChile Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Spanish - Chile text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string SpanishChile {get; set; }

Value:

String value.


SpanishColombia Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Spanish - Colombia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string SpanishColombia {get; set; }

Value:

String value.


SpanishCosta Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Spanish - Costa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string SpanishCosta {get; set; }

Value:

String value.


SpanishDominican Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Spanish - Dominican text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string SpanishDominican {get; set; }

Value:

String value.


SpanishEcuador Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Spanish - Ecuador text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string SpanishEcuador {get; set; }

Value:

String value.


SpanishGuatemala Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Spanish - Guatemala text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string SpanishGuatemala {get; set; }

Value:

String value.


SpanishHonduras Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Spanish - Honduras text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string SpanishHonduras {get; set; }

Value:

String value.


SpanishMexico Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Spanish - Mexico text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string SpanishMexico {get; set; }

Value:

String value.


SpanishNicaragua Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Spanish - Nicaragua text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string SpanishNicaragua {get; set; }

Value:

String value.


SpanishPanama Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Spanish - Panama text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string SpanishPanama {get; set; }

Value:

String value.


SpanishPeru Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Spanish - Peru text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string SpanishPeru {get; set; }

Value:

String value.


SpanishPuertoRico Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Spanish - Puerto Rico text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string SpanishPuertoRico {get; set; }

Value:

String value.


SpanishParaguay Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Spanish - Paraguay text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string SpanishParaguay {get; set; }

Value:

String value.


SpanishElSalvador Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Spanish - El Salvador text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string SpanishElSalvador {get; set; }

Value:

String value.


SpanishUruguay Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Spanish - Uruguay text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string SpanishUruguay {get; set; }

Value:

String value.


SpanishVenezuela Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Spanish - Venezuela text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string SpanishVenezuela {get; set; }

Value:

String value.


SouthernSotho Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Southern Sotho text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string SouthernSotho {get; set; }

Value:

String value.


Swahili Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Swahili text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Swahili {get; set; }

Value:

String value.


SwedishSweden Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Swedish - Sweden text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string SwedishSweden {get; set; }

Value:

String value.


SwedishFinland Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Swedish - Finland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string SwedishFinland {get; set; }

Value:

String value.


Tamil Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Tamil text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Tamil {get; set; }

Value:

String value.


Tatar Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Tatar text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Tatar {get; set; }

Value:

String value.


Thai Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Thai text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Thai {get; set; }

Value:

String value.


Turkish Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Turkish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Turkish {get; set; }

Value:

String value.


Tsonga Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Tsonga text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Tsonga {get; set; }

Value:

String value.


Ukrainian Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Ukrainian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Ukrainian {get; set; }

Value:

String value.


Urdu Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Urdu text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Urdu {get; set; }

Value:

String value.


UzbekCyrillic Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Uzbek - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string UzbekCyrillic {get; set; }

Value:

String value.


UzbekLatin Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Uzbek - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string UzbekLatin {get; set; }

Value:

String value.


Vietnamese Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Vietnamese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Vietnamese {get; set; }

Value:

String value.


Xhosa Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Xhosa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Xhosa {get; set; }

Value:

String value.


Yiddish Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Yiddish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Yiddish {get; set; }

Value:

String value.


Zulu Property

32-bit
64-bit
CF
P
P
P

Description:

Represents the Zulu text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Declaration:

public string Zulu {get; set; }

Value:

String value.


ImGearXMPMetadataRoot Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides simplified access to XMP metadata. Properties of this class represent XMP schemas that are known to ImageGear.

Declaration:

public class ImGearXMPMetadataRoot : ImageGear.Formats.ImGearFormatMetadata

Members:

Constructors
Name
Description
ImGearXMPMetadataRoot Constructor
Creates and initializes an instance of ImGearXMPMetadataRoot Class.

Properties
Name
Description
AdobePDF Property
Provides simplified access to Adobe PDF XMP schema properties.
Basic Property
Provides simplified access to Basic XMP schema properties.
BasicJobTicket Property
Provides simplified access to Basic Job Ticket XMP schema properties.
CameraRaw Property
Provides simplified access to Camera Raw XMP schema properties.
DublinCore Property
Provides simplified access to Dublin Core XMP schema properties.
DynamicMedia Property
Provides simplified access to Dynamic Media XMP schema properties.
EXIF Property
Provides simplified access to EXIF XMP schema properties.
EXIFAux Property
Provides simplified access to EXIF Auxiliary XMP schema properties.
IPTC Property
Provides simplified access to IPTC XMP schema properties.
MediaManagement Property
Provides simplified access to Media Management XMP schema properties.
PagedText Property
Provides simplified access to Paged Text XMP schema properties.
Photoshop Property
Provides simplified access to Photoshop XMP schema properties.
RightsManagement Property
Provides simplified access to Rights Management XMP schema properties.
TIFF Property
Provides simplified access to TIFF XMP schema properties.


ImGearXMPMetadataRoot Class Constructors

The ImGearXMPMetadataRoot Class has the following constructors:
Constructors
Name
Description
ImGearXMPMetadataRoot Constructor
Creates and initializes an instance of ImGearXMPMetadataRoot Class.


ImGearXMPMetadataRoot Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an instance of ImGearXMPMetadataRoot Class.

Declaration:

public ImGearXMPMetadataRoot()

Return Value:

New instance of ImGearXMPMetadataRoot Class object.


ImGearXMPMetadataRoot Class Properties

The ImGearXMPMetadataRoot Class has the following properties:
Properties
Name
Description
AdobePDF Property
Provides simplified access to Adobe PDF XMP schema properties.
Basic Property
Provides simplified access to Basic XMP schema properties.
BasicJobTicket Property
Provides simplified access to Basic Job Ticket XMP schema properties.
CameraRaw Property
Provides simplified access to Camera Raw XMP schema properties.
DublinCore Property
Provides simplified access to Dublin Core XMP schema properties.
DynamicMedia Property
Provides simplified access to Dynamic Media XMP schema properties.
EXIF Property
Provides simplified access to EXIF XMP schema properties.
EXIFAux Property
Provides simplified access to EXIF Auxiliary XMP schema properties.
IPTC Property
Provides simplified access to IPTC XMP schema properties.
MediaManagement Property
Provides simplified access to Media Management XMP schema properties.
PagedText Property
Provides simplified access to Paged Text XMP schema properties.
Photoshop Property
Provides simplified access to Photoshop XMP schema properties.
RightsManagement Property
Provides simplified access to Rights Management XMP schema properties.
TIFF Property
Provides simplified access to TIFF XMP schema properties.


AdobePDF Property

32-bit
64-bit
CF
P
P
P

Description:

Provides simplified access to Adobe PDF XMP schema properties. If metadata does not contain XMP properties belonging to the Adobe XMP scheme, the property returns null.

If the metadata does not have Adobe PDF XMP properties, and you need to add such properties, create a new instance of the ImGearAdobePDFXMPMetadata Class, assign it to this property, and then add XMP properties using corresponding properties of the ImGearAdobePDFXMPMetadata Class.

If you need to remove Adobe PDF XMP schema properties from the metadata, set this property to null.

Declaration:

public ImGearAdobeXMPMetadata AdobePDF {get; set; }

Value:

ImGearAdobePDFXMPMetadata Class value.


Basic Property

32-bit
64-bit
CF
P
P
P

Description:

Provides simplified access to Basic XMP schema properties. If metadata does not contain XMP properties belonging to the Basic scheme, the property returns null.

If the metadata does not have Basic XMP properties, and you need to add such properties, create a new instance of the ImGearBasicXMPMetadata Class, assign it to this property, and then add XMP properties using corresponding properties of the ImGearBasicXMPMetadata Class.

If you need to remove Basic XMP schema properties from the metadata, set this property to null.

Declaration:

public ImGearBasicXMPMetadata Basic {get; set; }

Value:

ImGearBasicXMPMetadata Class value.


BasicJobTicket Property

32-bit
64-bit
CF
P
P
P

Description:

Provides simplified access to Basic Job Ticket XMP schema properties. If metadata does not contain XMP properties belonging to the Basic Job Ticket scheme, the property returns null.

If the metadata does not have Basic Job Ticket XMP properties, and you need to add such properties, create a new instance of the ImGearBasicJobTicketXMPMetadata Class, assign it to this property, and then add XMP properties using corresponding properties of the ImGearBasicJobTicketXMPMetadata Class.

If you need to remove Basic Job Ticket XMP schema properties from the metadata, set this property to null.

Declaration:

public ImGearBasicJobTicketXMPMetadata BasicJobTicket {get; set; }

Value:

ImGearBasicJobTicketXMPMetadata Class value.


CameraRaw Property

32-bit
64-bit
CF
P
P
P

Description:

Provides simplified access to Camera Raw XMP schema properties. If metadata does not contain XMP properties belonging to the Camera Raw scheme, the property returns null.

If the metadata does not have Camera Raw XMP properties, and you need to add such properties, create a new instance of the ImGearCameraRawXMPMetadata Class, assign it to this property, and then add XMP properties using corresponding properties of the ImGearCameraRawXMPMetadata Class.

If you need to remove Camera Raw XMP schema properties from the metadata, set this property to null.

Declaration:

public ImGearCameraRawXMPMetadata CameraRaw {get; set; }

Value:

ImGearCameraRawXMPMetadata Class value.


DublinCore Property

32-bit
64-bit
CF
P
P
P

Description:

Provides simplified access to Dublin Core XMP schema properties. If metadata does not contain XMP properties belonging to the Dublin Core scheme, the property returns null.

If the metadata does not have Dublin Core XMP properties, and you need to add such properties, create a new instance of the ImGearDublinCoreXMPMetadata Class, assign it to this property, and then add XMP properties using corresponding properties of the ImGearDublinCoreXMPMetadata Class.

If you need to remove Dublin Core XMP schema properties from the metadata, set this property to null.

Declaration:

public ImGearDublinCoreXMPMetadata DublinCore {get; set; }

Value:

ImGearDublinCoreXMPMetadata Class value.


DynamicMedia Property

32-bit
64-bit
CF
P
P
P

Description:

Provides simplified access to Dynamic Media XMP schema properties. If metadata does not contain XMP properties belonging to the Dynamic Media scheme, the property returns null.

If the metadata does not have Dynamic Media XMP properties, and you need to add such properties, create a new instance of the ImGearDynamicMediaXMPMetadata Class, assign it to this property, and then add XMP properties using corresponding properties of the ImGearDynamicMediaXMPMetadata Class.

If you need to remove Dynamic Media XMP schema properties from the metadata, set this property to null.

Declaration:

public ImGearDynamicMediaXMPMetadata DynamicMedia {get; set; }

Value:

ImGearDynamicMediaXMPMetadata Class value.


EXIF Property

32-bit
64-bit
CF
P
P
P

Description:

Provides simplified access to EXIF XMP schema properties. If metadata does not contain XMP properties belonging to the EXIF scheme, the property returns null.

If the metadata does not have EXIF XMP properties, and you need to add such properties, create a new instance of the ImGearDynamicMediaXMPMetadata Class, assign it to this property, and then add XMP properties using corresponding properties of the ImGearDynamicMediaXMPMetadata Class.

If you need to remove EXIF XMP schema properties from the metadata, set this property to null.

Declaration:

public ImGearEXIFXMPMetadata EXIF {get; set; }

Value:

ImGearEXIFXMPMetadata Class value.


EXIFAux Property

32-bit
64-bit
CF
P
P
P

Description:

Provides simplified access to EXIF Auxiliary XMP schema properties. If metadata does not contain XMP properties belonging to the EXIFAux scheme, the property returns null.

If the metadata does not have EXIF Auxiliary XMP properties, and you need to add such properties, create a new instance of the ImGearEXIFAuxXMPMetadata Class, assign it to this property, and then add XMP properties using corresponding properties of the ImGearEXIFAuxXMPMetadata Class.

If you need to remove EXIF Auxiliary XMP schema properties from the metadata, set this property to null.

Declaration:

public ImGearEXIFAuxXMPMetadata EXIFAux {get; set; }

Value:

ImGearEXIFAuxXMPMetadata Class value.


IPTC Property

32-bit
64-bit
CF
P
P
P

Description:

Provides simplified access to IPTC4XMPCore XMP schema properties. If metadata does not contain XMP properties belonging to the IPTC4XMPCore scheme, the property returns null.

If the metadata does not have IPTC4XMPCore XMP properties, and you need to add such properties, create a new instance of the ImGearIPTC4XMPCoreXMPMetadata Class, assign it to this property, and then add XMP properties using corresponding properties of the ImGearIPTC4XMPCoreXMPMetadata Class.

If you need to remove IPTC4XMPCore XMP schema properties from the metadata, set this property to null.

Declaration:

public ImGearIPTC4XMPCoreMetadata IPTC {get; set; }

Value:

ImGearIPTC4XMPCoreXMPMetadata Class value.


MediaManagement Property

32-bit
64-bit
CF
P
P
P

Description:

Provides simplified access to Media Management XMP schema properties. If metadata does not contain XMP properties belonging to the Media Management scheme, the property returns null.

If the metadata does not have Media Management XMP properties, and you need to add such properties, create a new instance of the ImGearMediaManagementXMPMetadata Class, assign it to this property, and then add XMP properties using corresponding properties of the ImGearMediaManagementXMPMetadata Class.

If you need to remove Media Management XMP schema properties from the metadata, set this property to null.

Declaration:

public ImGearMediaManagementXMPMetadata MediaManagement {get; set; }

Value:

ImGearMediaManagementXMPMetadata Class value.


PagedText Property

32-bit
64-bit
CF
P
P
P

Description:

Provides simplified access to Paged Text XMP schema properties. If metadata does not contain XMP properties belonging to the Paged Text scheme, the property returns null.

If the metadata does not have Paged Text XMP properties, and you need to add such properties, create a new instance of the ImGearPagedTextXMPMetadata Class, assign it to this property, and then add XMP properties using corresponding properties of the ImGearPagedTextXMPMetadata Class.

If you need to remove Paged Text XMP schema properties from the metadata, set this property to null.

Declaration:

public ImGearPagedTextXMPMetadata PagedText {get; set; }

Value:

ImGearPagedTextXMPMetadata Class value.


Photoshop Property

32-bit
64-bit
CF
P
P
P

Description:

Provides simplified access to Photoshop XMP schema properties. If metadata does not contain XMP properties belonging to the Photoshop scheme, the property returns null.

If the metadata does not have Photoshop XMP properties, and you need to add such properties, create a new instance of the ImGearPhotoshopXMPMetadata Class, assign it to this property, and then add XMP properties using corresponding properties of the ImGearPhotoshopXMPMetadata Class.

If you need to remove Photoshop XMP schema properties from the metadata, set this property to null.

Declaration:

public ImGearPhotoshopXMPMetadata Photoshop {get; set; }

Value:

ImGearPhotoshopXMPMetadata Class value.


RightsManagement Property

32-bit
64-bit
CF
P
P
P

Description:

Provides simplified access to Rights Management XMP schema properties. If metadata does not contain XMP properties belonging to the Rights Management scheme, the property returns null.

If the metadata does not have Rights Management XMP properties, and you need to add such properties, create a new instance of the ImGearRightsManagementXMPMetadata Class, assign it to this property, and then add XMP properties using corresponding properties of the ImGearRightsManagementXMPMetadata Class.

If you need to remove Rights Management XMP schema properties from the metadata, set this property to null.

Declaration:

public ImGearRightsManagementXMPMetadata RightsManagement {get; set; }

Value:

ImGearRightsManagementXMPMetadata Class value.


TIFF Property

32-bit
64-bit
CF
P
P
P

Description:

Provides simplified access to TIFF XMP schema properties. If metadata does not contain XMP properties belonging to the TIFF scheme, the property returns null.

If the metadata does not have TIFF XMP properties, and you need to add such properties, create a new instance of the ImGearTIFFXMPMetadata Class, assign it to this property, and then add XMP properties using corresponding properties of the ImGearTIFFXMPMetadata Class.

If you need to remove TIFF XMP schema properties from the metadata, set this property to null.

Declaration:

public ImGearTIFFXMPMetadata TIFF {get; set; }

Value:

ImGearTIFFXMPMetadata Class value.


ImGearXMPRational Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents a rational XMP metadata property.

Declaration:

public class ImGearXMPRational : ImGearXMPValue

Members:

Constructors
Name
Description
ImGearXMPRational Constructor
Creates and initializes an instance of ImGearXMPRational Class.
ImGearXMPRational Constructor
Creates and initializes an instance of ImGearXMPRational Class.

Properties
Name
Description
Value Property
Accesses the rational value.


ImGearXMPRational Class Constructors

The ImGearXMPRational Class has the following constructors:
Constructors
Name
Description
ImGearXMPRational Constructor
Creates and initializes an instance of ImGearXMPRational Class.
ImGearXMPRational Constructor
Creates and initializes an instance of ImGearXMPRational Class.


ImGearXMPRational Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an instance of ImGearXMPRational Class and initializes it with a default value.

Declaration:

public ImGearXMPRational()

Return Value:

New instance of ImGearXMPRational Class object.


ImGearXMPRational Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPRational Class by using a ImGearRationalInt Structure value.

Declaration:

public ImGearXMPRational(ImGearRationalInt value)

Parameters:

Name
Description
value
ImGearRationalInt Structure value.

Return Value:

New instance of ImGearXMPRational Class object.


ImGearXMPRational Class Properties

The ImGearXMPRational Class has the following properties:
Properties
Name
Description
Value Property
Accesses the rational value.


Value Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets the rational value of the ImGearXMPRational Class object.

Declaration:

public ImGearRationalInt Value { get; }

Value:

ImGearRationalInt Structure value.


ImGearXMPReal Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents a floating point XMP metadata property.

This property type has an optional qualifier that provides binary representation of the floating point value when an exact value is needed. The text of the qualifier is interpreted as:

std size,endian,hexadecimal_value

- std is the standard name ("IEEE754")

- size is S for 32-bit and D for 64-bit

- endian is L for little-endian, B for big-endian.

For example: "IEEE754D,L,3A4901F387D31108"

Declaration:

public class ImGearXMPReal : ImGearXMPValue

Members:

Constructors
Name
Description
ImGearXMPReal Constructor
Creates and initializes an instance of ImGearXMPReal Class.
ImGearXMPReal Constructor
Creates and initializes an instance of ImGearXMPReal Class.
ImGearXMPReal Constructor
Creates and initializes an instance of ImGearXMPReal Class.

Properties
Name
Description
Value Property
Gets the rational value.
BinaryRepQualifier Property
Gets the optional Binary Representation qualifier.


ImGearXMPReal Class Constructors

The ImGearXMPReal Class has the following constructors:
Constructors
Name
Description
ImGearXMPReal Constructor
Creates and initializes an instance of ImGearXMPReal Class.
ImGearXMPReal Constructor
Creates and initializes an instance of ImGearXMPReal Class.
ImGearXMPReal Constructor
Creates and initializes an instance of ImGearXMPReal Class.


ImGearXMPReal Constructor

Description

This constructor creates an instance of ImGearXMPReal Class and initializes it with a default value.

Declaration:

public ImGearXMPReal()

Return Value:

New instance of ImGearXMPReal Class object.


ImGearXMPReal Constructor

Description

This constructor creates and initializes an instance of ImGearXMPReal Class by using a double value.

Declaration:

public ImGearXMPReal(double value)

Parameters:

Name
Description
value
double value.

Return Value:

New instance of ImGearXMPReal Class object.


ImGearXMPReal Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPReal Class by using a double value and a binary representation qualifier.

Declaration:

public ImGearXMPReal(double value, string binRepQualifier)

Parameters:

Name
Description
value
double value.
value
binary representation qualifier value.

Return Value:

New instance of ImGearXMPReal Class object.


ImGearXMPReal Class Properties

The ImGearXMPReal Class has the following properties:
Properties
Name
Description
Value Property
Gets the rational value.
BinaryRepQualifier Property
Gets the optional Binary Representation qualifier.


BinaryRepQualifier Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets the optional Binary Representation qualifier. The qualifier provides binary representation of the floating point value when an exact value is needed. The text of the qualifier is interpreted as:

std size,endian,hexadecimal_value

- std is the standard name ("IEEE754")

- size is S for 32-bit and D for 64-bit

- endian is L for little-endian, B for big-endian.

For example: "IEEE754D,L,3A4901F387D31108"

Declaration:

public double BinaryRepQualifier { get; }

Value:

double value.


Value Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets the double value of the ImGearXMPReal Class object.

Declaration:

public double Value { get; }

Value:

double value.


ImGearXMPSeq Generic Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an ordered array of XMP properties.

Declaration:

public sealed class ImGearXMPSeq<T> : ImageGear.Formats.XMP.ImGearXMPArray<T>
    where T : new(), ImageGear.Formats.XMP.ImGearXMPValue

Members:

Constructors
Name
Description
ImGearXMPSeq Constructor
Creates an instance of ImGearXMPSeq Generic Class.
ImGearXMPSeq Constructor
Creates an instance of ImGearXMPSeq Generic Class.


ImGearXMPSeq Class Constructors

The ImGearXMPSeq Generic Class has the following constructors:
Constructors
Name
Description
ImGearXMPSeq Constructor
Creates an instance of ImGearXMPSeq Generic Class.
ImGearXMPSeq Constructor
Creates an instance of ImGearXMPSeq Generic Class.


ImGearXMPSeq Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an empty instance of ImGearXMPSeq Generic Class.

Declaration:

public ImGearXMPSeq()

Return Value:

New instance of ImGearXMPSeq Generic Class object.


ImGearXMPSeq Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an instance of ImGearXMPSeq Generic Class generic class and initializes it with values from the string array.

Declaration:

public ImGearXMPSeq(string[] values)

Return Value:

New instance of ImGearXMPSeq Generic Class object.


ImGearXMPString Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents a string XMP metadata property.

Declaration:

public class ImGearXMPString : ImGearXMPValue

Members:

Constructors
Name
Description
ImGearXMPString Constructor
Creates and initializes an instance of ImGearXMPString Class.
ImGearXMPString Constructor
Creates and initializes an instance of ImGearXMPString Class.

Properties
Name
Description
Value Property
Gets the string value.


ImGearXMPString Class Constructors

The ImGearXMPString Class has the following constructors:
Constructors
Name
Description
ImGearXMPString Constructor
Creates and initializes an instance of ImGearXMPString Class.
ImGearXMPString Constructor
Creates and initializes an instance of ImGearXMPString Class.


ImGearXMPString Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an instance of ImGearXMPString Class and initializes it with a default value.

Declaration:

public ImGearXMPString()

Return Value:

New instance of ImGearXMPString Class object.


ImGearXMPString Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPString Class by using a string value.

Declaration:

public ImGearXMPString(string value)

Parameters:

Name
Description
value
String value.

Return Value:

New instance of ImGearXMPString Class object.


ImGearXMPString Class Properties

The ImGearXMPString Class has the following properties:
Properties
Name
Description
Value Property
Gets the string value.


Value Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets the string value of the ImGearXMPString Class object.

Declaration:

public string Value { get; }

Value:

string value.


ImGearXMPStructure Abstract Class

32-bit
64-bit
CF
P
P
P

Description:

This abstract class specifies baseline features for XMP structures, such as ImGearXMPFont Class, ImGearXMPColorant Class, etc.

Declaration:

public abstract class ImGearXMPStructure : ImGearXMPValue

Members:

This class does not have public members.


ImGearXMPThumbnail Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an XMP Thumbnail structure.

Declaration:

public class ImGearXMPThumbnail : ImGearXMPValue

Members:

Constructors
Name
Description
ImGearXMPThumbnail Constructor
Creates an instance of ImGearXMPThumbnail Class.
ImGearXMPThumbnail Constructor
Creates an instance of ImGearXMPThumbnail Class.

Properties
Name
Description
Value Property
Gets thumbnail data as an ImGearPage Class object


ImGearXMPThumbnail Class Constructors

The ImGearXMPThumbnail Class has the following constructors:
Constructors
Name
Description
ImGearXMPThumbnail Constructor
Creates an instance of ImGearXMPThumbnail Class.
ImGearXMPThumbnail Constructor
Creates an instance of ImGearXMPThumbnail Class.


ImGearXMPThumbnail Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an empty instance of ImGearXMPThumbnail Class.

Declaration:

public ImGearXMPThumbnail()

Return Value:

New instance of ImGearXMPThumbnail Class object.


ImGearXMPThumbnail Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPThumbnail Class by using an ImGearPage Class object.

Declaration:

public ImGearXMPThumbnail(ImGearPage value)

Return Value:

New instance of ImGearXMPThumbnail Class object.


ImGearXMPThumbnail Class Properties

The ImGearXMPThumbnail Class has the following properties:
Properties
Name
Description
Value Property
Gets thumbnail data as an ImGearPage Class object


Value Property

32-bit
64-bit
CF
P
P
P

Description:

Gets thumbnail image as an ImGearPage Class object.

Declaration:

public ImGearPage Value {get; }

Value:

ImGearPage Class object.


ImGearXMPValue Abstract Class

32-bit
64-bit
CF
P
P
P

Description:

This abstract class specifies baseline features for an XMP property value.

Declaration:

public class ImGearXMPValue

Members:

This class does not have public members.


ImageGear.Formats.XMP.AdobePDF Namespace

ImageGear.Formats.XMP.AdobePDF Namespace

32-bit
64-bit
CF
P
P
P

Description:

This namespace provides the API for XMP.AdobePDF format.

Declaration:

namespace ImageGear.Formats.XMP.AdobePDF

Members:

Classes:
Name
Description
ImGearAdobePDFXMPMetadata Class
Provides simplified access to Adobe PDF XMP metadata scheme.

See Also:

ImageGear.Formats.XMP Namespace

ImageGear.Formats.XMP.AdobePDF Namespace

ImageGear.Formats.XMP.Basic Namespace

ImageGear.Formats.XMP.BasicJobTicket Namespace

ImageGear.Formats.XMP.CameraRaw Namespace

ImageGear.Formats.XMP.DublinCore Namespace

ImageGear.Formats.XMP.DynamicMedia Namespace

ImageGear.Formats.XMP.EXIF Namespace

ImageGear.Formats.XMP.EXIFAux Namespace

ImageGear.Formats.XMP.IPTC4XMPCore Namespace

ImageGear.Formats.XMP.MediaManagement Namespace

ImageGear.Formats.XMP.MicrosoftPhoto Namespace

ImageGear.Formats.XMP.PagedText Namespace

ImageGear.Formats.XMP.Photoshop Namespace

ImageGear.Formats.XMP.RightsManagement Namespace

ImageGear.Formats.XMP.TIFF Namespace


ImageGear.Formats.XMP.AdobePDF Classes

The ImageGear.Formats.XMP.AdobePDF Namespace has the following class members:

Classes:
Name
Description
ImGearAdobePDFXMPMetadata Class
Provides simplified access to Adobe PDF XMP metadata scheme.


ImGearAdobePDFXMPMetadata Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides simplified access to Adobe PDF XMP metadata scheme.

Declaration:

public class ImGearAdobePDFXMPMetadata : ImageGear.Formats.ImGearXMPFormatMetadata

Members:

Constructors
Name
Description
ImGearAdobePDFXMPMetadata Constructor
Creates and initializes an instance of ImGearAdobePDFXMPMetadata Class.

Properties
Name
Description
Keywords Property
Accesses Keywords property of the Adobe PDF schema.
PDFVersion Property
Accesses PDFVersion property of the Adobe PDF schema.
Producer Property
Accesses Producer property of the Adobe PDF schema.
Value Property
Accesses Value property of the Adobe PDF schema.


ImGearAdobePDFXMPMetadata Class Constructors

The ImGearAdobePDFXMPMetadata Class has the following constructors:
Constructors
Name
Description
ImGearAdobePDFXMPMetadata Constructor
Creates and initializes an instance of ImGearAdobePDFXMPMetadata Class.


ImGearAdobePDFXMPMetadata Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearAdobePDFXMPMetadata Class.

Declaration:

public ImGearAdobePDFXMPMetadata ()

Return Value:

New instance of ImGearAdobePDFXMPMetadata Class object.


ImGearAdobePDFXMPMetadata Class Properties

The ImGearAdobePDFXMPMetadata Class has the following properties:
Properties
Name
Description
Keywords Property
Accesses Keywords property of the Adobe PDF schema.
PDFVersion Property
Accesses PDFVersion property of the Adobe PDF schema.
Producer Property
Accesses Producer property of the Adobe PDF schema.
Value Property
Accesses Value property of the Adobe PDF schema.


Keywords Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Keywords property of the AdobePDF XMP schema.

Declaration:

public ImGearXMPString Keywords {get; set;}

Value:

ImGearXMPString Class value.


PDFVersion Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses PDFVersion property of the AdobePDF XMP schema. This XMP property specifies the PDF file version (for example: 1.0, 1.3, and so on).

Declaration:

public ImGearXMPString PDFVersion {get; set;}

Value:

ImGearXMPString Class value.


Producer Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Producer property of the AdobePDF XMP schema. This XMP property specifies the name of the tool that created the PDF document.

Declaration:

public ImGearXMPString Producer {get; set;}

Value:

ImGearXMPString Class value.


Value Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets the bool value of the ImGearXMPBoolean object.

Declaration:

public bool Value { get; }

Value:

Bool value.


ImageGear.Formats.XMP.Basic Namespace

ImageGear.Formats.XMP.Basic Namespace

32-bit
64-bit
CF
P
P
P

Description:

This namespace provides the API for XMP.Basic format.

Declaration:

namespace ImageGear.Formats.XMP.Basic

Members:

Classes:
Name
Description
ImGearBasicXMPIdentifier Class
Represents an Identifier property of the XMP Basic schema.
ImGearBasicXMPMetadata Class
Provides simplified access to XMP Basic metadata scheme.

See Also:

ImageGear.Formats.XMP Namespace

ImageGear.Formats.XMP.AdobePDF Namespace

ImageGear.Formats.XMP.Basic Namespace

ImageGear.Formats.XMP.BasicJobTicket Namespace

ImageGear.Formats.XMP.CameraRaw Namespace

ImageGear.Formats.XMP.DublinCore Namespace

ImageGear.Formats.XMP.DynamicMedia Namespace

ImageGear.Formats.XMP.EXIF Namespace

ImageGear.Formats.XMP.EXIFAux Namespace

ImageGear.Formats.XMP.IPTC4XMPCore Namespace

ImageGear.Formats.XMP.MediaManagement Namespace

ImageGear.Formats.XMP.MicrosoftPhoto Namespace

ImageGear.Formats.XMP.PagedText Namespace

ImageGear.Formats.XMP.Photoshop Namespace

ImageGear.Formats.XMP.RightsManagement Namespace

ImageGear.Formats.XMP.TIFF Namespace


ImageGear.Formats.XMP.Basic Classes

The ImageGear.Formats.XMP.Basic Namespace has the following class members:

Classes:
Name
Description
ImGearBasicXMPIdentifier Class
Represents an Identifier property of the XMP Basic schema.
ImGearBasicXMPMetadata Class
Provides simplified access to XMP Basic metadata scheme.


ImGearBasicXMPIdentifier Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an Identifier property of the XMP Basic schema. It contains a string qualified by an optional Schema qualifier.

Declaration:

public class ImGearBasicXMPIdentifier : ImageGear.Formats.ImGearXMPString

Members:

Constructors
Name
Description
ImGearBasicXMPIdentifier Constructor
Creates and initializes an instance of ImGearBasicXMPIdentifier Class.
ImGearBasicXMPIdentifier Constructor
Creates and initializes an instance of ImGearBasicXMPIdentifier Class.
ImGearBasicXMPIdentifier Constructor
Creates and initializes an instance of ImGearBasicXMPIdentifier Class.

Properties
Name
Description
SchemeQualifier Property
Accesses Scheme qualifier.


ImGearBasicXMPIdentifier Class Constructors

The ImGearBasicXMPIdentifier Class has the following constructors:
Constructors
Name
Description
ImGearBasicXMPIdentifier Constructor
Creates and initializes an instance of ImGearBasicXMPIdentifier Class.
ImGearBasicXMPIdentifier Constructor
Creates and initializes an instance of ImGearBasicXMPIdentifier Class.
ImGearBasicXMPIdentifier Constructor
Creates and initializes an instance of ImGearBasicXMPIdentifier Class.


ImGearBasicXMPIdentifier Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearBasicXMPIdentifier Class.

Declaration:

public ImGearBasicXMPIdentifier ()

Return Value:

New instance of ImGearBasicXMPIdentifier Class object.


ImGearBasicXMPIdentifier Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearBasicXMPIdentifier Class, using a string value.

Declaration:

public ImGearBasicXMPIdentifier (string value)

Parameters:

Name
Description
value
String value.

Return Value:

New instance of ImGearBasicXMPIdentifier Class object.


ImGearBasicXMPIdentifier Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearBasicXMPIdentifier Class, using the specified value and a scheme qualifier.

Declaration:

public ImGearBasicXMPIdentifier (string value, string schemeQualifier)

Parameters:

Name
Description
value
String value.
schemeQualifier
Scheme qualifier.

Return Value:

New instance of ImGearBasicXMPIdentifier Class object.


ImGearBasicXMPIdentifier Class Properties

The ImGearBasicXMPIdentifier Class has the following properties:
Properties
Name
Description
SchemeQualifier Property
Accesses Scheme qualifier.


SchemeQualifier Property

32-bit
64-bit
CF
P
P
P

Description:

Gets the Scheme qualifier.

Declaration:

public string SchemeQualifier {get; }

Value:

String value.


ImGearBasicXMPMetadata Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides simplified access to XMP Basic metadata scheme.

Declaration:

public class ImGearBasicXMPMetadata : ImageGear.Formats.ImGearXMPFormatMetadata

Members:

Constructors
Name
Description
ImGearBasicXMPMetadata Constructor
Creates and initializes an instance of ImGearBasicXMPMetadata Class.

Properties
Name
Description
Advisory Property
Accesses Advisory property of the XMP Basic schema.
BaseURL Property
Accesses BaseURL property of the XMP Basic schema.
CreateDate Property
Accesses CreateDate property of the XMP Basic schema.
CreatorTool Property
Accesses CreatorTool property of the XMP Basic schema.
Identifier Property
Accesses Identifier property of the XMP Basic schema.
Label Property
Accesses Label property of the XMP Basic schema.
MetadataDate Property
Accesses MetadataDate property of the XMP Basic schema.
ModifyDate Property
Accesses ModifyDate property of the XMP Basic schema.
Nickname Property
Accesses Nickname property of the XMP Basic schema.
Rating Property
Accesses Rating property of the XMP Basic schema.
Thumbnails Property
Accesses Thumbnails property of the XMP Basic schema.


ImGearBasicXMPMetadata Class Constructors

The ImGearBasicXMPMetadata Class has the following constructors:
Constructors
Name
Description
ImGearBasicXMPMetadata Constructor
Creates and initializes an instance of ImGearBasicXMPMetadata Class.


ImGearBasicXMPMetadata Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearBasicXMPMetadata Class.

Declaration:

public ImGearBasicXMPMetadata ()

Return Value:

New instance of ImGearBasicXMPMetadata Class object.


ImGearBasicXMPMetadata Class Properties

The ImGearBasicXMPMetadata Class has the following properties:
Properties
Name
Description
Advisory Property
Accesses Advisory property of the XMP Basic schema.
BaseURL Property
Accesses BaseURL property of the XMP Basic schema.
CreateDate Property
Accesses CreateDate property of the XMP Basic schema.
CreatorTool Property
Accesses CreatorTool property of the XMP Basic schema.
Identifier Property
Accesses Identifier property of the XMP Basic schema.
Label Property
Accesses Label property of the XMP Basic schema.
MetadataDate Property
Accesses MetadataDate property of the XMP Basic schema.
ModifyDate Property
Accesses ModifyDate property of the XMP Basic schema.
Nickname Property
Accesses Nickname property of the XMP Basic schema.
Rating Property
Accesses Rating property of the XMP Basic schema.
Thumbnails Property
Accesses Thumbnails property of the XMP Basic schema.


Advisory Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Advisory property of the XMP Basic schema. This XMP property contains an unordered array specifying properties that were edited outside the authoring application.

Declaration:

public ImGearXMPBag<ImGearXMPString> Advisory {get; set;}

Value:

ImGearXMPBag<ImGearXMPString Class> value.


BaseURL Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses BaseURL property of the XMP Basic schema. This XMP property specifies the base URL for relative URLs in the document content.

Declaration:

public ImGearXMPString BaseURL {get; set;}

Value:

ImGearXMPString Class value.


CreateDate Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses CreateDate property of the XMP Basic schema. This XMP property specifies the date and time the resource was originally created.

Declaration:

public ImGearXMPDate CreateDate {get; set;}

Value:

ImGearXMPDate Class value.


CreatorTool Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses CreatorTool property of the XMP Basic schema. This XMP property specifies name of the first known tool used to create the resource.

Declaration:

public ImGearXMPString CreatorTool {get; set;}

Value:

ImGearXMPString Class value.


Identifier Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Identifier property of the XMP Basic schema. This XMP property specifies an unordered array of text strings that unambiguously identify the resource within a given context. An array item may be qualified a Scheme qualifier to denote the formal identification system to which that identifier conforms.

Declaration:

public ImGearXMPBag<ImGearBasicXMPIdentifier> Identifier {get; set;}

Value:

ImGearXMPBag< ImGearBasicXMPIdentifier Class > value.


Label Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Label property of the XMP Basic schema. This XMP property specifies a word or short phrase that identifies a document as a member of a user-defined collection.

Declaration:

public ImGearXMPString Label {get; set;}

Value:

ImGearXMPString Class value.


MetadataDate Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses MetadataDate property of the XMP Basic schema. This XMP property specifies the date and time that any metadata for this resource was last changed. It should be the same as or more recent than ModifyDate.

Declaration:

public ImGearXMPDate MetadataDate {get; set;}

Value:

ImGearXMPDate Class value.


ModifyDate Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ModifyDate property of the XMP Basic schema. This XMP property specifies the date and time the resource was last modified.

Declaration:

public ImGearXMPDate ModifyDate {get; set;}

Value:

ImGearXMPDate Class value.


Nickname Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Nickname property of the XMP Basic schema. This XMP property specifies a short informal name for the resource.

Declaration:

public ImGearXMPString Nickname {get; set;}

Value:

ImGearXMPString Class value.


Rating Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Rating property of the XMP Basic schema. This XMP property specifies a number that indicates a document's status relative to other documents, used to organize documents in a file browser. Values are user-defined within an application defined range.

Declaration:

public ImGearXMPInteger Rating {get; set;}

Value:

ImGearXMPInteger Class value.


Thumbnails Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Thumbnails property of the XMP Basic schema. This XMP property specifies an alternative array of thumbnail images for a file, which can differ in characteristics such as size or image encoding.

Declaration:

public ImGearXMPAlt<ImGearXMPThumbnail> Thumbnails {get; set;}

Value:

ImGearXMPAlt<ImGearXMPThumbnail Class> value.


ImageGear.Formats.XMP.BasicJobTicket Namespace

ImageGear.Formats.XMP.BasicJobTicket Namespace

32-bit
64-bit
CF
P
P
P

Description:

This namespace provides the API for XMP.BasicJobTicket format.

Declaration:

namespace ImageGear.Formats.XMP.BasicJobTicket

Members:

Classes:
Name
Description
ImGearBasicJobTicketXMPMetadata Class
Provides simplified access to XMP Basic Job Ticket metadata scheme.
ImGearXMPJob Class
Represents an XMP Job structure.

See Also:

ImageGear.Formats.XMP Namespace

ImageGear.Formats.XMP.AdobePDF Namespace

ImageGear.Formats.XMP.Basic Namespace

ImageGear.Formats.XMP.BasicJobTicket Namespace

ImageGear.Formats.XMP.CameraRaw Namespace

ImageGear.Formats.XMP.DublinCore Namespace

ImageGear.Formats.XMP.DynamicMedia Namespace

ImageGear.Formats.XMP.EXIF Namespace

ImageGear.Formats.XMP.EXIFAux Namespace

ImageGear.Formats.XMP.IPTC4XMPCore Namespace

ImageGear.Formats.XMP.MediaManagement Namespace

ImageGear.Formats.XMP.MicrosoftPhoto Namespace

ImageGear.Formats.XMP.PagedText Namespace

ImageGear.Formats.XMP.Photoshop Namespace

ImageGear.Formats.XMP.RightsManagement Namespace

ImageGear.Formats.XMP.TIFF Namespace


ImageGear.Formats.XMP.BasicJobTicket Classes

The ImageGear.Formats.XMP.BasicJobTicket Namespace has the following class members:

Classes:
Name
Description
ImGearBasicJobTicketXMPMetadata Class
Provides simplified access to XMP Basic Job Ticket metadata scheme.
ImGearXMPJob Class
Represents an XMP Job structure.


ImGearBasicJobTicketXMPMetadata Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides simplified access to XMP Basic Job Ticket metadata scheme.

Declaration:

public class ImGearBasicJobTicketXMPMetadata : ImageGear.Formats.ImGearXMPFormatMetadata

Members:

Constructors
Name
Description
ImGearBasicJobTicketXMPMetadata Constructor
Creates and initializes an instance of ImGearBasicJobTicketXMPMetadata Class.
Properties
Name
Description
JobRef Property
Accesses JobRef property of the XMP Basic Job Ticket schema.


ImGearBasicJobTicketXMPMetadata Class Constructors

The ImGearBasicJobTicketXMPMetadata Class has the following constructors:
Constructors
Name
Description
ImGearBasicJobTicketXMPMetadata Constructor
Creates and initializes an instance of ImGearBasicJobTicketXMPMetadata Class.


ImGearBasicJobTicketXMPMetadata Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearBasicJobTicketXMPMetadata Class.

Declaration:

public ImGearBasicJobTicketXMPMetadata ()

Return Value:

New instance of ImGearBasicJobTicketXMPMetadata Class object.


ImGearBasicJobTicketXMPMetadata Class Properties

The ImGearBasicJobTicketXMPMetadata Class has the following properties:
Properties
Name
Description
JobRef Property
Accesses JobRef property of the XMP Basic Job Ticket schema.


JobRef Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses JobRef property of the XMP Basic schema. This XMP property references an external job management file for a job process in which the document is being used.

Declaration:

public ImGearXMPBag<ImGearXMPJob> JobRef {get; set;}

Value:

ImGearXMPBag<ImGearXMPJob Class> value.


ImGearXMPJob Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an XMP Job structure. This structure describes a job for a job-management system. See XMP specification for structure usage details.

Declaration:

public class ImGearXMPJob : ImGearXMPStructure

Members:

Constructors
Name
Description
ImGearXMPJob Constructor
Creates and initializes an instance of ImGearXMPJob Class.

Properties
Name
Description
Name Property
Accesses the Name field.
Id Property
Accesses the Id field.
URL Property
Accesses the URL field.


ImGearXMPJob Class Constructors

The ImGearXMPJob Class has the following constructors:
Constructors
Name
Description
ImGearXMPJob Constructor
Creates and initializes an instance of ImGearXMPJob Class.


ImGearXMPJob Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPJob Class.

Declaration:

public ImGearXMPJob()

Return Value:

New instance of ImGearXMPJob Class object.


ImGearXMPJob Class Properties

The ImGearXMPJob Class has the following properties:
Properties
Name
Description
Name Property
Accesses the Name field.
Id Property
Accesses the Id field.
URL Property
Accesses the URL field.


Name Property

32-bit
64-bit
CF
P
P
P

Description:

Informal name of job. This name is for user display and informal systems.

Declaration:

public ImGearXMPString Name {get; set; }

Value:

ImGearXMPString Class value.


Id Property

32-bit
64-bit
CF
P
P
P

Description:

Unique ID forthe job. This field is a reference into some external job management system.

Declaration:

public ImGearXMPString Id {get; set; }

Value:

ImGearXMPString Class value.


URL Property

32-bit
64-bit
CF
P
P
P

Description:

A file URL referencing an external job management file.

Declaration:

public ImGearXMPString URL {get; set; }

Value:

ImGearXMPString Class value.


ImageGear.Formats.XMP.CameraRaw Namespace

ImageGear.Formats.XMP.CameraRaw Namespace

32-bit
64-bit
CF
P
P
P

Description:

This namespace provides the API for XMP.CameraRaw format.

Declaration:

namespace ImageGear.Formats.XMP.CameraRaw

Members:

Classes:
Name
Description
ImGearCameraRawXMPMetadata Class
Provides simplified access to XMP Camera Raw metadata scheme.

See Also:

ImageGear.Formats.XMP Namespace

ImageGear.Formats.XMP.AdobePDF Namespace

ImageGear.Formats.XMP.Basic Namespace

ImageGear.Formats.XMP.BasicJobTicket Namespace

ImageGear.Formats.XMP.CameraRaw Namespace

ImageGear.Formats.XMP.DublinCore Namespace

ImageGear.Formats.XMP.DynamicMedia Namespace

ImageGear.Formats.XMP.EXIF Namespace

ImageGear.Formats.XMP.EXIFAux Namespace

ImageGear.Formats.XMP.IPTC4XMPCore Namespace

ImageGear.Formats.XMP.MediaManagement Namespace

ImageGear.Formats.XMP.MicrosoftPhoto Namespace

ImageGear.Formats.XMP.PagedText Namespace

ImageGear.Formats.XMP.Photoshop Namespace

ImageGear.Formats.XMP.RightsManagement Namespace

ImageGear.Formats.XMP.TIFF Namespace


ImageGear.Formats.XMP.CameraRaw Classes

The ImageGear.Formats.XMP.CameraRaw Namespace has the following class members:

Classes:
Name
Description
ImGearCameraRawXMPMetadata Class
Provides simplified access to XMP Camera Raw metadata scheme.


ImGearCameraRawXMPMetadata Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides simplified access to XMP Camera Raw metadata scheme.

Declaration:

public class ImGearCameraRawXMPMetadata : ImageGear.Formats.ImGearXMPFormatMetadata

Members:

Constructors
Name
Description
ImGearCameraRawXMPMetadata Constructor
Creates and initializes an instance of ImGearCameraRawXMPMetadata Class.

Properties
Name
Description
AutoBrightness Property
Accesses AutoBrightness property of the Camera Raw schema.
AutoContrast Property
Accesses AutoContrast property of the Camera Raw schema.
AutoExposure Property
Accesses AutoExposure property of the Camera Raw schema.
AutoShadows Property
Accesses AutoShadows property of the Camera Raw schema.
BlueHue Property
Accesses BlueHue property of the Camera Raw schema.
BlueSaturation Property
Accesses BlueSaturation property of the Camera Raw schema.
Brightness Property
Accesses Brightness property of the Camera Raw schema.
CameraProfile Property
Accesses CameraProfile property of the Camera Raw schema.
ChromaticAberrationB Property
Accesses ChromaticAberrationB property of the Camera Raw schema.
ChromaticAberrationR Property
Accesses ChromaticAberrationR property of the Camera Raw schema.
ColorNoiseReduction Property
Accesses ColorNoiseReduction property of the Camera Raw schema.
Contrast Property
Accesses Contrast property of the Camera Raw schema.
CropTop Property
Accesses CropTop property of the Camera Raw schema.
CropLeft Property
Accesses CropLeft property of the Camera Raw schema.
CropBottom Property
Accesses CropBottom property of the Camera Raw schema.
CropRight Property
Accesses CropRight property of the Camera Raw schema.
CropAngle Property
Accesses CropAngle property of the Camera Raw schema.
CropWidth Property
Accesses CropWidth property of the Camera Raw schema.
CropHeight Property
Accesses CropHeight property of the Camera Raw schema.
CropUnits Property
Accesses CropUnits property of the Camera Raw schema.
Exposure Property
Accesses Exposure property of the Camera Raw schema.
GreenHue Property
Accesses GreenHue property of the Camera Raw schema.
GreenSaturation Property
Accesses GreenSaturation property of the Camera Raw schema.
HasCrop Property
Accesses HasCrop property of the Camera Raw schema.
HasSettings Property
Accesses HasSettings property of the Camera Raw schema.
LuminanceSmoothing Property
Accesses LuminanceSmoothing property of the Camera Raw schema.
RawFileName Property
Accesses RawFileName property of the Camera Raw schema.
RedHue Property
Accesses RedHue property of the Camera Raw schema.
RedSaturation Property
Accesses RedSaturation property of the Camera Raw schema.
Saturation Property
Accesses Saturation property of the Camera Raw schema.
Shadows Property
Accesses Shadows property of the Camera Raw schema.
ShadowTint Property
Accesses ShadowTint property of the Camera Raw schema.
Sharpness Property
Accesses Sharpness property of the Camera Raw schema.
Temperature Property
Accesses Temperature property of the Camera Raw schema.
Tint Property
Accesses Tint property of the Camera Raw schema.
ToneCurveName Property
Accesses ToneCurveName property of the Camera Raw schema.
Version Property
Accesses Version property of the Camera Raw schema.
VignetteAmount Property
Accesses VignetteAmount property of the Camera Raw schema.
VignetteMidpoint Property
Accesses VignetteMidpoint property of the Camera Raw schema.
WhiteBalance Property
Accesses WhiteBalance property of the Camera Raw schema.


ImGearCameraRawXMPMetadata Class Constructors

The ImGearCameraRawXMPMetadata Class has the following constructors:
Constructors
Name
Description
ImGearCameraRawXMPMetadata Constructor
Creates and initializes an instance of ImGearCameraRawXMPMetadata Class.


ImGearCameraRawXMPMetadata Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearCameraRawXMPMetadata Class.

Declaration:

public ImGearCameraRawXMPMetadata ()

Return Value:

New instance of ImGearCameraRawXMPMetadata Class object.


ImGearCameraRawXMPMetadata Class Properties

The ImGearCameraRawXMPMetadata Class has the following properties:
Properties
Name
Description
AutoBrightness Property
Accesses AutoBrightness property of the Camera Raw schema.
AutoContrast Property
Accesses AutoContrast property of the Camera Raw schema.
AutoExposure Property
Accesses AutoExposure property of the Camera Raw schema.
AutoShadows Property
Accesses AutoShadows property of the Camera Raw schema.
BlueHue Property
Accesses BlueHue property of the Camera Raw schema.
BlueSaturation Property
Accesses BlueSaturation property of the Camera Raw schema.
Brightness Property
Accesses Brightness property of the Camera Raw schema.
CameraProfile Property
Accesses CameraProfile property of the Camera Raw schema.
ChromaticAberrationB Property
Accesses ChromaticAberrationB property of the Camera Raw schema.
ChromaticAberrationR Property
Accesses ChromaticAberrationR property of the Camera Raw schema.
ColorNoiseReduction Property
Accesses ColorNoiseReduction property of the Camera Raw schema.
Contrast Property
Accesses Contrast property of the Camera Raw schema.
CropTop Property
Accesses CropTop property of the Camera Raw schema.
CropLeft Property
Accesses CropLeft property of the Camera Raw schema.
CropBottom Property
Accesses CropBottom property of the Camera Raw schema.
CropRight Property
Accesses CropRight property of the Camera Raw schema.
CropAngle Property
Accesses CropAngle property of the Camera Raw schema.
CropWidth Property
Accesses CropWidth property of the Camera Raw schema.
CropHeight Property
Accesses CropHeight property of the Camera Raw schema.
CropUnits Property
Accesses CropUnits property of the Camera Raw schema.
Exposure Property
Accesses Exposure property of the Camera Raw schema.
GreenHue Property
Accesses GreenHue property of the Camera Raw schema.
GreenSaturation Property
Accesses GreenSaturation property of the Camera Raw schema.
HasCrop Property
Accesses HasCrop property of the Camera Raw schema.
HasSettings Property
Accesses HasSettings property of the Camera Raw schema.
LuminanceSmoothing Property
Accesses LuminanceSmoothing property of the Camera Raw schema.
RawFileName Property
Accesses RawFileName property of the Camera Raw schema.
RedHue Property
Accesses RedHue property of the Camera Raw schema.
RedSaturation Property
Accesses RedSaturation property of the Camera Raw schema.
Saturation Property
Accesses Saturation property of the Camera Raw schema.
Shadows Property
Accesses Shadows property of the Camera Raw schema.
ShadowTint Property
Accesses ShadowTint property of the Camera Raw schema.
Sharpness Property
Accesses Sharpness property of the Camera Raw schema.
Temperature Property
Accesses Temperature property of the Camera Raw schema.
Tint Property
Accesses Tint property of the Camera Raw schema.
ToneCurveName Property
Accesses ToneCurveName property of the Camera Raw schema.
Version Property
Accesses Version property of the Camera Raw schema.
VignetteAmount Property
Accesses VignetteAmount property of the Camera Raw schema.
VignetteMidpoint Property
Accesses VignetteMidpoint property of the Camera Raw schema.
WhiteBalance Property
Accesses WhiteBalance property of the Camera Raw schema.


AutoBrightness Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses AutoBrightness property of the XMP Camera Raw schema. Setting this XMP property to true specifies that "Brightness" is automatically adjusted.

Declaration:

public ImGearXMPBoolean AutoBrightness {get; set;}

Value:

ImGearXMPBoolean value.


AutoContrast Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses AutoContrast property of the XMP Camera Raw schema. Setting this XMP property to true specifies that "Contrast" is automatically adjusted.

Declaration:

public ImGearXMPBoolean AutoContrast {get; set;}

Value:

ImGearXMPBoolean value.


AutoExposure Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses AutoExposure property of the XMP Camera Raw schema. Setting this XMP property to true specifies that "Exposure" is automatically adjusted.

Declaration:

public ImGearXMPBoolean AutoExposure {get; set;}

Value:

ImGearXMPBoolean value.


AutoShadows Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses AutoShadows property of the XMP Camera Raw schema. Setting this XMP property to true specifies that "Shadows" is automatically adjusted.

Declaration:

public ImGearXMPBoolean AutoShadows {get; set;}

Value:

ImGearXMPBoolean value.


BlueHue Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses BlueHue property of the XMP Camera Raw schema. This XMP property specifies "Blue Hue" setting. Range is -100 to 100.

Declaration:

public ImGearXMPInteger BlueHue {get; set;}

Value:

ImGearXMPInteger Class value.


BlueSaturation Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses BlueSaturation property of the XMP Camera Raw schema. This XMP property specifies "Blue Saturation" setting. Range is -100 to +100.

Declaration:

public ImGearXMPInteger BlueSaturation {get; set;}

Value:

ImGearXMPInteger Class value.


Brightness Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Brightness property of the XMP Camera Raw schema. This XMP property specifies "Brightness" setting. Range is 0 to +150.

Declaration:

public ImGearXMPInteger Brightness {get; set;}

Value:

ImGearXMPInteger Class value.


CameraProfile Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses CameraProfile property of the XMP Camera Raw schema. This XMP property specifies "Camera Profile" setting.

Declaration:

public ImGearXMPString CameraProfile {get; set;}

Value:

ImGearXMPString Class value.


ChromaticAberrationB Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ChromaticAberrationB property of the XMP Camera Raw schema. This XMP property specifies "Chomatic Aberration, Fix Blue/Yellow Fringe" setting. Range is -100 to +100.

Declaration:

public ImGearXMPInteger ChromaticAberrationB {get; set;}

Value:

ImGearXMPInteger Class value.


ChromaticAberrationR Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ChromaticAberrationR property of the XMP Camera Raw schema. This XMP property specifies "Chomatic Aberration, Fix Red/Cyan Fringe" setting. Range is -100 to +100.

Declaration:

public ImGearXMPInteger ChromaticAberrationR {get; set;}

Value:

ImGearXMPInteger Class value.


ColorNoiseReduction Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ColorNoiseReduction property of the XMP Camera Raw schema. This XMP property specifies "Color Noise Reducton" setting. Range is 0 to +100.

Declaration:

public ImGearXMPInteger ColorNoiseReduction {get; set;}

Value:

ImGearXMPInteger Class value.


Contrast Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Contrast property of the XMP Camera Raw schema. This XMP property specifies "Contrast" setting. Range is -50 to +100.

Declaration:

public ImGearXMPInteger Contrast {get; set;}

Value:

ImGearXMPInteger Class value.


CropTop Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses CropTop property of the XMP Camera Raw schema. When HasCrop is true, this XMP property specifies top of crop rectangle

Declaration:

public ImGearXMPReal CropTop {get; set;}

Value:

ImGearXMPReal Class value.


CropLeft Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses CropLeft property of the XMP Camera Raw schema. When HasCrop is true, this XMP property specifies left of crop rectangle.

Declaration:

public ImGearXMPReal CropLeft {get; set;}

Value:

ImGearXMPReal Class value.


CropBottom Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses CropBottom property of the XMP Camera Raw schema. When HasCrop is true, this XMP property specifies bottom of crop rectangle.

Declaration:

public ImGearXMPReal CropBottom {get; set;}

Value:

ImGearXMPReal Class value.


CropRight Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses CropRight property of the XMP Camera Raw schema. When HasCrop is true, this XMP property specifies right of crop rectangle.

Declaration:

public ImGearXMPReal CropRight {get; set;}

Value:

ImGearXMPReal Class value.


CropAngle Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses CropAngle property of the XMP Camera Raw schema. When HasCrop is true, this XMP property specifies angle of crop rectangle.

Declaration:

public ImGearXMPReal CropAngle {get; set;}

Value:

ImGearXMPReal Class value.


CropWidth Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses CropWidth property of the XMP Camera Raw schema. This XMP property specifies width of resulting cropped image in CropUnits units.

Declaration:

public ImGearXMPReal CropWidth {get; set;}

Value:

ImGearXMPReal Class value.


CropHeight Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses CropHeight property of the XMP Camera Raw schema. This XMP property specifies height of resulting cropped image in CropUnits units.

Declaration:

public ImGearXMPReal CropHeight {get; set;}

Value:

ImGearXMPReal Class value.


CropUnits Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses CropUnits property of the XMP Camera Raw schema. This XMP property specifies units for CropWidth and CropHeight. One of: 0=pixels 1=inches 2=cm.

Declaration:

public ImGearXMPInteger CropUnits {get; set;}

Value:

ImGearXMPInteger Class value.


Exposure Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Exposure property of the XMP Camera Raw schema. This XMP property specifies "Exposure" setting. Range is -4.0 to +4.0.

Declaration:

public ImGearXMPReal Exposure {get; set;}

Value:

ImGearXMPReal Class value.


GreenHue Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GreenHue property of the XMP Camera Raw schema. This XMP property specifies "Green Hue" setting. Range is -100 to +100.

Declaration:

public ImGearXMPInteger GreenHue {get; set;}

Value:

ImGearXMPInteger Class value.


GreenSaturation Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GreenSaturation property of the XMP Camera Raw schema. This XMP property specifies "Green Saturation" setting. Range is -100 to +100.

Declaration:

public ImGearXMPInteger GreenSaturation {get; set;}

Value:

ImGearXMPInteger Class value.


HasCrop Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses HasCrop property of the XMP Camera Raw schema. Setting this XMP property to true specifies that image has a cropping rectangle.

Declaration:

public ImGearXMPBoolean HasCrop {get; set;}

Value:

ImGearXMPBoolean value.


HasSettings Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses HasSettings property of the XMP Camera Raw schema. Seting this XMP property to true specifies non-default camera raw settings.

Declaration:

public ImGearXMPBoolean HasSettings {get; set;}

Value:

ImGearXMPBoolean value.


LuminanceSmoothing Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses LuminanceSmoothing property of the XMP Camera Raw schema. This XMP property specifies "Luminance Smoothing" setting. Range is 0 to +100.

Declaration:

public ImGearXMPInteger LuminanceSmoothing {get; set;}

Value:

ImGearXMPInteger Class value.


RawFileName Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses RawFileName property of the XMP Camera Raw schema. This XMP property specifies file name for the raw file (not a complete path).

Declaration:

public ImGearXMPString RawFileName {get; set;}

Value:

ImGearXMPString Class value.


RedHue Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses RedHue property of the XMP Camera Raw schema. This XMP property specifies "Red Hue" setting. Range is -100 to +100.

Declaration:

public ImGearXMPInteger RedHue {get; set;}

Value:

ImGearXMPInteger Class value.


RedSaturation Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses RedSaturation property of the XMP Camera Raw schema. This XMP property specifies "Red Saturation" setting. Range is -100 to +100.

Declaration:

public ImGearXMPInteger RedSaturation {get; set;}

Value:

ImGearXMPInteger Class value.


Saturation Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Saturation property of the XMP Camera Raw schema. This XMP property specifies "Saturation" setting. Range is -100 to +100.

Declaration:

public ImGearXMPInteger Saturation {get; set;}

Value:

ImGearXMPInteger Class value.


Shadows Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Shadows property of the XMP Camera Raw schema. This XMP property specifies "Shadows" setting. Range is 0 to +100.

Declaration:

public ImGearXMPInteger Shadows {get; set;}

Value:

ImGearXMPInteger Class value.


ShadowTint Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ShadowTint property of the XMP Camera Raw schema. This XMP property specifies "Shadow Tint" setting. Range is -100 to +100.

Declaration:

public ImGearXMPInteger ShadowTint {get; set;}

Value:

ImGearXMPInteger Class value.


Sharpness Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Sharpness property of the XMP Camera Raw schema. This XMP property specifies "Sharpness" setting. Range is 0 to +100.

Declaration:

public ImGearXMPInteger Sharpness {get; set;}

Value:

ImGearXMPInteger Class value.


Temperature Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Temperature property of the XMP Camera Raw schema. This XMP property specifies "Temperature" setting. Range is 2000 to 50000.

Declaration:

public ImGearXMPInteger Temperature {get; set;}

Value:

ImGearXMPInteger Class value.


Tint Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Tint property of the XMP Camera Raw schema. This XMP property specifies "Tint" setting. Range is -150 to +150.

Declaration:

public ImGearXMPInteger Tint {get; set;}

Value:

ImGearXMPInteger Class value.


ToneCurveName Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ToneCurveName property of the XMP Camera Raw schema. This XMP property specifies the name of the Tone Curve described by ToneCurve. One of: "Linear", "Medium Contrast", "Strong Contrast", "Custom" or a user-defined preset name.

Declaration:

public ImGearXMPString ToneCurveName {get; set;}

Value:

ImGearXMPString Class value.


Version Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Version property of the XMP Camera Raw schema. This XMP property specifies version of Camera Raw plugin.

Declaration:

public ImGearXMPString Version {get; set;}

Value:

ImGearXMPString Class value.


VignetteAmount Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses VignetteAmount property of the XMP Camera Raw schema. This XMP property specifies "Vignetting Amount" setting. Range is -100 to +100.

Declaration:

public ImGearXMPInteger VignetteAmount {get; set;}

Value:

ImGearXMPInteger Class value.


VignetteMidpoint Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses VignetteMidpoint property of the XMP Camera Raw schema. This XMP property specifies "Vignetting Midpoint" setting. Range is 0 to +100.

Declaration:

public ImGearXMPInteger VignetteMidpoint {get; set;}

Value:

ImGearXMPInteger Class value.


WhiteBalance Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses WhiteBalance property of the XMP Camera Raw schema. This XMP property specifies "White Balance" setting. One of: "As Shot", "Auto", "Daylight", "Cloudy", "Shade", "Tungsten", "Fluorescent", "Flash", "Custom".

Declaration:

public ImGearXMPString WhiteBalance {get; set;}

Value:

ImGearXMPString Class value.


ImageGear.Formats.XMP.DublinCore Namespace

ImageGear.Formats.XMP.DublinCore Namespace

32-bit
64-bit
CF
P
P
P

Description:

This namespace provides the API for XMP.DublinCore format.

Declaration:

namespace ImageGear.Formats.XMP.DublinCore

Members:

Classes:
Name
Description
ImGearDublinCoreXMPMetadata Class
Provides simplified access to XMP Dublin Core metadata scheme.

See Also:

ImageGear.Formats.XMP Namespace

ImageGear.Formats.XMP.AdobePDF Namespace

ImageGear.Formats.XMP.Basic Namespace

ImageGear.Formats.XMP.BasicJobTicket Namespace

ImageGear.Formats.XMP.CameraRaw Namespace

ImageGear.Formats.XMP.DublinCore Namespace

ImageGear.Formats.XMP.DynamicMedia Namespace

ImageGear.Formats.XMP.EXIF Namespace

ImageGear.Formats.XMP.EXIFAux Namespace

ImageGear.Formats.XMP.IPTC4XMPCore Namespace

ImageGear.Formats.XMP.MediaManagement Namespace

ImageGear.Formats.XMP.MicrosoftPhoto Namespace

ImageGear.Formats.XMP.PagedText Namespace

ImageGear.Formats.XMP.Photoshop Namespace

ImageGear.Formats.XMP.RightsManagement Namespace

ImageGear.Formats.XMP.TIFF Namespace


ImageGear.Formats.XMP.DublinCore Classes

The ImageGear.Formats.XMP.DublinCore Namespace has the following class members:

Classes:
Name
Description
ImGearDublinCoreXMPMetadata Class
Provides simplified access to XMP Dublin Core metadata scheme.


ImGearDublinCoreXMPMetadata Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides simplified access to XMP Dublin Core metadata scheme.

Declaration:

public class ImGearDublinCoreXMPMetadata : ImageGear.Formats.ImGearXMPFormatMetadata

Members:

Constructors
Name
Description
ImGearDublinCoreXMPMetadata Constructor
Creates and initializes an instance of ImGearDublinCoreXMPMetadata Class.

Properties
Name
Description
Contributor Property
Accesses Contributor property of the Dublin Core schema.
Coverage Property
Accesses Coverage property of the Dublin Core schema.
Creator Property
Accesses Creator property of the Dublin Core schema.
Date Property
Accesses Date property of the Dublin Core schema.
Description Property
Accesses Description property of the Dublin Core schema.
Format Property
Accesses Format property of the Dublin Core schema.
Identifier Property
Accesses Identifier property of the Dublin Core schema.
Language Property
Accesses Language property of the Dublin Core schema.
Publisher Property
Accesses Publisher property of the Dublin Core schema.
Relation Property
Accesses Relation property of the Dublin Core schema.
Rights Property
Accesses Rights property of the Dublin Core schema.
Source Property
Accesses Source property of the Dublin Core schema.
Subject Property
Accesses Subject property of the Dublin Core schema.
Title Property
Accesses Title property of the Dublin Core schema.
Type Property
Accesses Type property of the Dublin Core schema.


ImGearDublinCoreXMPMetadata Class Constructors

The ImGearDublinCoreXMPMetadata Class has the following constructors:
Constructors
Name
Description
ImGearDublinCoreXMPMetadata Constructor
Creates and initializes an instance of ImGearDublinCoreXMPMetadata Class.


ImGearDublinCoreXMPMetadata Constructor

Description

This constructor creates and initializes an instance of ImGearDublinCoreXMPMetadata Class.

Declaration:

public ImGearDublinCoreXMPMetadata ()

Return Value:

New instance of ImGearDublinCoreXMPMetadata Class object.


ImGearDublinCoreXMPMetadata Class Properties

The ImGearDublinCoreXMPMetadata Class has the following properties:
Properties
Name
Description
Contributor Property
Accesses Contributor property of the Dublin Core schema.
Coverage Property
Accesses Coverage property of the Dublin Core schema.
Creator Property
Accesses Creator property of the Dublin Core schema.
Date Property
Accesses Date property of the Dublin Core schema.
Description Property
Accesses Description property of the Dublin Core schema.
Format Property
Accesses Format property of the Dublin Core schema.
Identifier Property
Accesses Identifier property of the Dublin Core schema.
Language Property
Accesses Language property of the Dublin Core schema.
Publisher Property
Accesses Publisher property of the Dublin Core schema.
Relation Property
Accesses Relation property of the Dublin Core schema.
Rights Property
Accesses Rights property of the Dublin Core schema.
Source Property
Accesses Source property of the Dublin Core schema.
Subject Property
Accesses Subject property of the Dublin Core schema.
Title Property
Accesses Title property of the Dublin Core schema.
Type Property
Accesses Type property of the Dublin Core schema.


Contributor Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Contributor property of the XMP Dublin Core schema. This XMP property specifies contributors to the resource (other than the authors).

Declaration:

public ImGearXMPBag<ImGearXMPString> Contributor {get; set;}

Value:

ImGearXMPBag<ImGearXMPString Class> value.


Coverage Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Coverage property of the XMP Dublin Core schema. This XMP property specifies the extent or scope of the resource.

Declaration:

public ImGearXMPString Coverage {get; set;}

Value:

ImGearXMPString Class value.


Creator Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Creator property of the XMP Dublin Core schema. This XMP property specifies the authors of the resource (listed in order of precedence, if significant).

Declaration:

public ImGearXMPSeq<ImGearXMPString> Creator {get; set;}

Value:

ImGearXMPSeq<ImGearXMPString Class> value.


Date Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Date property of the XMP Dublin Core schema. This XMP property specifies date(s) that something interesting happened to the resource.

Declaration:

public ImGearXMPSeq<ImGearXMPDate> Date {get; set;}

Value:

ImGearXMPSeq<ImGearXMPDate Class> value.


Description Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Description property of the XMP Dublin Core schema. This XMP property specifies a textual description of the content of the resource. Multiple values may be present for different languages.

Declaration:

public ImGearXMPLangAlt Description {get; set;}

Value:

ImGearXMPLangAlt Class value.


Format Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Format property of the XMP Dublin Core schema. This XMP property specifies the file format used when saving the resource. Tools and applications should set this property to the save format of the data.

Declaration:

public ImGearXMPString Format {get; set;}

Value:

ImGearXMPString Class value.


Identifier Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Identifier property of the XMP Dublin Core schema. This XMP property specifies unique identifier of the resource.

Declaration:

public ImGearXMPString Identifier {get; set;}

Value:

ImGearXMPString Class value.


Language Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Language property of the XMP Dublin Core schema. This XMP property specifies an unordered array specifying the languages used in the resource.

Declaration:

public ImGearXMPBag<ImGearXMPString> Language {get; set;}

Value:

ImGearXMPBag<ImGearXMPString Class> value.


Publisher Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Publisher property of the XMP Dublin Core schema. This XMP property specifies external Publishers.

Declaration:

public ImGearXMPBag<ImGearXMPString> Publisher {get; set;}

Value:

ImGearXMPBag<ImGearXMPString Class> value.


Relation Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Relation property of the XMP Dublin Core schema. This XMP property specifies relationships to other documents.

Declaration:

public ImGearXMPBag<ImGearXMPString> Relation {get; set;}

Value:

ImGearXMPBag<ImGearXMPString Class> value.


Rights Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Rights property of the XMP Dublin Core schema. This XMP property specifies informal rights statement, selected by language.

Declaration:

public ImGearXMPLangAlt Rights {get; set;}

Value:

ImGearXMPLangAlt Class value.


Source Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Source property of the XMP Dublin Core schema. This XMP property specifies unique identifier of the work from which this resource was derived.

Declaration:

public ImGearXMPString Source {get; set;}

Value:

ImGearXMPString Class value.


Subject Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Subject property of the XMP Dublin Core schema. This XMP property specifies an unordered array of descriptive phrases or keywords that specify the topic of the content of the resource.

Declaration:

public ImGearXMPBag<ImGearXMPString> Subject {get; set;}

Value:

ImGearXMPBag<ImGearXMPString Class> value.


Title Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Title property of the XMP Dublin Core schema. This XMP property specifies the title of the document, or the name given to the resource. Typically, it will be a name by which the resource is formally known.

Declaration:

public ImGearXMPLangAlt Title {get; set;}

Value:

ImGearXMPLangAlt Class value.


Type Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Type property of the XMP Dublin Core schema. This XMP property specifies a document type; for example, novel, poem, or working paper.

Declaration:

public ImGearXMPBag<ImGearXMPString> Type {get; set;}

Value:

ImGearXMPBag<ImGearXMPString Class> value.


ImageGear.Formats.XMP.DynamicMedia Namespace

ImageGear.Formats.XMP.DynamicMedia Namespace

32-bit
64-bit
CF
P
P
P

Description:

This namespace provides the API for XMP.DynamicMedia format.

Declaration:

namespace ImageGear.Formats.XMP.DynamicMedia

Members:

Classes:
Name
Description
ImGearDynamicMediaXMPMetadata Class
Provides simplified access to Dynamic Media XMP metadata scheme.
ImGearXMPBeatSpliceStretch Class
Represents an XMP BeatSpliceStretch structure.
ImGearXMPMarker Class
Represents an XMP Marker structure.
ImGearXMPMedia Class
Represents an XMP Media structure.
ImGearXMPProjectLink Class
Represents an XMP ProjectLink structure.
ImGearXMPResampleStretch Class
Represents an XMP ResampleStretch structure.
ImGearXMPTime Class
Represents an XMP Time structure.
ImGearXMPTimecode Class
Represents an XMP Timecode structure.
ImGearXMPTimeScaleStretch Class
Represents an XMP TimeScaleStretch structure.

See Also:

ImageGear.Formats.XMP Namespace

ImageGear.Formats.XMP.AdobePDF Namespace

ImageGear.Formats.XMP.Basic Namespace

ImageGear.Formats.XMP.BasicJobTicket Namespace

ImageGear.Formats.XMP.CameraRaw Namespace

ImageGear.Formats.XMP.DublinCore Namespace

ImageGear.Formats.XMP.DynamicMedia Namespace

ImageGear.Formats.XMP.EXIF Namespace

ImageGear.Formats.XMP.EXIFAux Namespace

ImageGear.Formats.XMP.IPTC4XMPCore Namespace

ImageGear.Formats.XMP.MediaManagement Namespace

ImageGear.Formats.XMP.MicrosoftPhoto Namespace

ImageGear.Formats.XMP.PagedText Namespace

ImageGear.Formats.XMP.Photoshop Namespace

ImageGear.Formats.XMP.RightsManagement Namespace

ImageGear.Formats.XMP.TIFF Namespace


ImageGear.Formats.XMP.DynamicMedia Classes

The ImageGear.Formats.XMP.DynamicMedia Namespace has the following class members:

Classes:
Name
Description
ImGearDynamicMediaXMPMetadata Class
Provides simplified access to Dynamic Media XMP metadata scheme.
ImGearXMPBeatSpliceStretch Class
Represents an XMP BeatSpliceStretch structure.
ImGearXMPMarker Class
Represents an XMP Marker structure.
ImGearXMPMedia Class
Represents an XMP Media structure.
ImGearXMPProjectLink Class
Represents an XMP ProjectLink structure.
ImGearXMPResampleStretch Class
Represents an XMP ResampleStretch structure.
ImGearXMPTime Class
Represents an XMP Time structure.
ImGearXMPTimecode Class
Represents an XMP Timecode structure.
ImGearXMPTimeScaleStretch Class
Represents an XMP TimeScaleStretch structure.


ImGearDynamicMediaXMPMetadata Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides simplified access to Dynamic Media XMP metadata scheme.

Declaration:

public class ImGearDynamicMediaXMPMetadata : ImageGear.Formats.ImGearXMPFormatMetadata

Members:

Constructors
Name
Description
ImGearDynamicMediaXMPMetadata Constructor
Creates and initializes an instance of ImGearDynamicMediaXMPMetadata class.

Properties
Name
Description
AbsPeakAudioFilePath Property
Accesses AbsPeakAudioFilePath property of the Dynamic Media schema.
Album Property
Accesses Album property of the Dynamic Media schema.
AltTapeName Property
Accesses AltTapeName property of the Dynamic Media schema.
AltTimecode Property
Accesses AltTimecode property of the Dynamic Media schema.
Artist Property
Accesses Artist property of the Dynamic Media schema.
AudioChannelType Property
Accesses AudioChannelType property of the Dynamic Media schema.
AudioCompressor Property
Accesses AudioCompressor property of the Dynamic Media schema.
AudioModDate Property
Accesses AudioModDate property of the Dynamic Media schema.
AudioSampleRate Property
Accesses AudioSampleRate property of the Dynamic Media schema.
AudioSampleType Property
Accesses AudioSampleType property of the Dynamic Media schema.
BeatSpliceParams Property
Accesses BeatSpliceParams property of the Dynamic Media schema.
Composer Property
Accesses Composer property of the Dynamic Media schema.
ContributedMedia Property
Accesses ContributedMedia property of the Dynamic Media schema.
Copyright Property
Accesses Copyright property of the Dynamic Media schema.
Duration Property
Accesses Duration property of the Dynamic Media schema.
Engineer Property
Accesses Engineer property of the Dynamic Media schema.
FileDataRate Property
Accesses FileDataRate property of the Dynamic Media schema.
Genre Property
Accesses Genre property of the Dynamic Media schema.
Instrument Property
Accesses Instrument property of the Dynamic Media schema.
IntroTime Property
Accesses IntroTime property of the Dynamic Media schema.
Key Property
Accesses Key property of the Dynamic Media schema.
LogComment Property
Accesses LogComment property of the Dynamic Media schema.
Loop Property
Accesses Loop property of the Dynamic Media schema.
Markers Property
Accesses Markers property of the Dynamic Media schema.
MetadataModDate Property
Accesses MetadataModDate property of the Dynamic Media schema.
NumberOfBeats Property
Accesses NumberOfBeats property of the Dynamic Media schema.
OutCue Property
Accesses OutCue property of the Dynamic Media schema.
ProjectRef Property
Accesses ProjectRef property of the Dynamic Media schema.
PullDown Property
Accesses PullDown property of the Dynamic Media schema.
RelativePeakAudioFilePath Property
Accesses RelativePeakAudioFilePath property of the Dynamic Media schema.
RelativeTimestamp Property
Accesses RelativeTimestamp property of the Dynamic Media schema.
ReleaseDate Property
Accesses ReleaseDate property of the Dynamic Media schema.
ResampleParams Property
Accesses ResampleParams property of the Dynamic Media schema.
ScaleType Property
Accesses ScaleType property of the Dynamic Media schema.
Scene Property
Accesses Scene property of the Dynamic Media schema.
ShotDate Property
Accesses ShotDate property of the Dynamic Media schema.
ShotLocation Property
Accesses ShotLocation property of the Dynamic Media schema.
ShotName Property
Accesses ShotName property of the Dynamic Media schema.
SpeakerPlacement Property
Accesses SpeakerPlacement property of the Dynamic Media schema.
StartTimecode Property
Accesses StartTimecode property of the Dynamic Media schema.
StretchMode Property
Accesses StretchMode property of the Dynamic Media schema.
TapeName Property
Accesses TapeName property of the Dynamic Media schema.
Tempo Property
Accesses Tempo property of the Dynamic Media schema.
TimeScaleParams Property
Accesses TimeScaleParams property of the Dynamic Media schema.
TimeSignature Property
Accesses TimeSignature property of the Dynamic Media schema.
TrackNumber Property
Accesses TrackNumber property of the Dynamic Media schema.
VideoAlphaMode Property
Accesses VideoAlphaMode property of the Dynamic Media schema.
VideoAlphaPremultipleColor Property
Accesses VideoAlphaPremultipleColor property of the Dynamic Media schema.
VideoAlphaUnityIsTransparent Property
Accesses VideoAlphaUnityIsTransparent property of the Dynamic Media schema.
VideoColorSpace Property
Accesses VideoColorSpace property of the Dynamic Media schema.
VideoCompressor Property
Accesses VideoCompressor property of the Dynamic Media schema.
VideoFieldOrder Property
Accesses VideoFieldOrder property of the Dynamic Media schema.
VideoFrameRate Property
Accesses VideoFrameRate property of the Dynamic Media schema.
VideoFrameSize Property
Accesses VideoFrameSize property of the Dynamic Media schema.
VideoModDate Property
Accesses VideoModDate property of the Dynamic Media schema.
VideoPixelAspectRatio Property
Accesses VideoPixelAspectRatio property of the Dynamic Media schema.
VideoPixelDepth Property
Accesses VideoPixelDepth property of the Dynamic Media schema.


ImGearDynamicMediaXMPMetadata Class Constructors

The ImGearDynamicMediaXMPMetadata Class has the following constructors:
Constructors
Name
Description
ImGearDynamicMediaXMPMetadata Constructor
Creates and initializes an instance of ImGearDynamicMediaXMPMetadata class.


ImGearDynamicMediaXMPMetadata Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearDynamicMediaXMPMetadata Class.

Declaration:

public ImGearDynamicMediaXMPMetadata ()

Return Value:

New instance of ImGearDynamicMediaXMPMetadata Class object.


ImGearDynamicMediaXMPMetadata Class Properties

The ImGearDynamicMediaXMPMetadata Class has the following properties:
Properties
Name
Description
AbsPeakAudioFilePath Property
Accesses AbsPeakAudioFilePath property of the Dynamic Media schema.
Album Property
Accesses Album property of the Dynamic Media schema.
AltTapeName Property
Accesses AltTapeName property of the Dynamic Media schema.
AltTimecode Property
Accesses AltTimecode property of the Dynamic Media schema.
Artist Property
Accesses Artist property of the Dynamic Media schema.
AudioChannelType Property
Accesses AudioChannelType property of the Dynamic Media schema.
AudioCompressor Property
Accesses AudioCompressor property of the Dynamic Media schema.
AudioModDate Property
Accesses AudioModDate property of the Dynamic Media schema.
AudioSampleRate Property
Accesses AudioSampleRate property of the Dynamic Media schema.
AudioSampleType Property
Accesses AudioSampleType property of the Dynamic Media schema.
BeatSpliceParams Property
Accesses BeatSpliceParams property of the Dynamic Media schema.
Composer Property
Accesses Composer property of the Dynamic Media schema.
ContributedMedia Property
Accesses ContributedMedia property of the Dynamic Media schema.
Copyright Property
Accesses Copyright property of the Dynamic Media schema.
Duration Property
Accesses Duration property of the Dynamic Media schema.
Engineer Property
Accesses Engineer property of the Dynamic Media schema.
FileDataRate Property
Accesses FileDataRate property of the Dynamic Media schema.
Genre Property
Accesses Genre property of the Dynamic Media schema.
Instrument Property
Accesses Instrument property of the Dynamic Media schema.
IntroTime Property
Accesses IntroTime property of the Dynamic Media schema.
Key Property
Accesses Key property of the Dynamic Media schema.
LogComment Property
Accesses LogComment property of the Dynamic Media schema.
Loop Property
Accesses Loop property of the Dynamic Media schema.
Markers Property
Accesses Markers property of the Dynamic Media schema.
MetadataModDate Property
Accesses MetadataModDate property of the Dynamic Media schema.
NumberOfBeats Property
Accesses NumberOfBeats property of the Dynamic Media schema.
OutCue Property
Accesses OutCue property of the Dynamic Media schema.
ProjectRef Property
Accesses ProjectRef property of the Dynamic Media schema.
PullDown Property
Accesses PullDown property of the Dynamic Media schema.
RelativePeakAudioFilePath Property
Accesses RelativePeakAudioFilePath property of the Dynamic Media schema.
RelativeTimestamp Property
Accesses RelativeTimestamp property of the Dynamic Media schema.
ReleaseDate Property
Accesses ReleaseDate property of the Dynamic Media schema.
ResampleParams Property
Accesses ResampleParams property of the Dynamic Media schema.
ScaleType Property
Accesses ScaleType property of the Dynamic Media schema.
Scene Property
Accesses Scene property of the Dynamic Media schema.
ShotDate Property
Accesses ShotDate property of the Dynamic Media schema.
ShotLocation Property
Accesses ShotLocation property of the Dynamic Media schema.
ShotName Property
Accesses ShotName property of the Dynamic Media schema.
SpeakerPlacement Property
Accesses SpeakerPlacement property of the Dynamic Media schema.
StartTimecode Property
Accesses StartTimecode property of the Dynamic Media schema.
StretchMode Property
Accesses StretchMode property of the Dynamic Media schema.
TapeName Property
Accesses TapeName property of the Dynamic Media schema.
Tempo Property
Accesses Tempo property of the Dynamic Media schema.
TimeScaleParams Property
Accesses TimeScaleParams property of the Dynamic Media schema.
TimeSignature Property
Accesses TimeSignature property of the Dynamic Media schema.
TrackNumber Property
Accesses TrackNumber property of the Dynamic Media schema.
VideoAlphaMode Property
Accesses VideoAlphaMode property of the Dynamic Media schema.
VideoAlphaPremultipleColor Property
Accesses VideoAlphaPremultipleColor property of the Dynamic Media schema.
VideoAlphaUnityIsTransparent Property
Accesses VideoAlphaUnityIsTransparent property of the Dynamic Media schema.
VideoColorSpace Property
Accesses VideoColorSpace property of the Dynamic Media schema.
VideoCompressor Property
Accesses VideoCompressor property of the Dynamic Media schema.
VideoFieldOrder Property
Accesses VideoFieldOrder property of the Dynamic Media schema.
VideoFrameRate Property
Accesses VideoFrameRate property of the Dynamic Media schema.
VideoFrameSize Property
Accesses VideoFrameSize property of the Dynamic Media schema.
VideoModDate Property
Accesses VideoModDate property of the Dynamic Media schema.
VideoPixelAspectRatio Property
Accesses VideoPixelAspectRatio property of the Dynamic Media schema.
VideoPixelDepth Property
Accesses VideoPixelDepth property of the Dynamic Media schema.


AbsPeakAudioFilePath Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses AbsPeakAudioFilePath property of the Dynamic Media XMP schema. This XMP property specifies absolute path to the file's peak audio file. If empty, no peak file exists.

Declaration:

public ImGearXMPString AbsPeakAudioFilePath   {get; set;}

Value:

ImGearXMPString Class value.


Album Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Album property of the Dynamic Media XMP schema. This XMP property specifies name of the album.

Declaration:

public ImGearXMPString Album   {get; set;}

Value:

ImGearXMPString Class value.


AltTapeName Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses AltTapeName property of the Dynamic Media XMP schema. This XMP property specifies alternative tape name, set via the project window or timecode dialog in Premiere. If an alternative name has been set and has not been reverted, that name is displayed.

Declaration:

public ImGearXMPString AltTapeName   {get; set;}

Value:

ImGearXMPString Class value.


AltTimecode Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses AltTimecode property of the Dynamic Media XMP schema. This XMP property specifies timecode set by the user. When specified, it is used instead of the startTimecode.

Declaration:

public ImGearXMPTimecode AltTimecode   {get; set;}

Value:

ImGearXMPTimecode Class value.


Artist Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Artist property of the Dynamic Media XMP schema. This XMP property specifies name of the artist or artists. /* Text External */

Declaration:

public ImGearXMPString Artist   {get; set;}

Value:

ImGearXMPString Class value.


AudioChannelType Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses AudioChannelType property of the Dynamic Media XMP schema. This XMP property specifies audio channel type. Allowed values are: "Mono", "Stereo", " 5.1", "7.1".

Declaration:

public ImGearXMPString AudioChannelType   {get; set;}

Value:

ImGearXMPString Class value.


AudioCompressor Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses AudioCompressor property of the Dynamic Media XMP schema. This XMP property specifies audio compression used. For example, MP3.

Declaration:

public ImGearXMPString AudioCompressor   {get; set;}

Value:

ImGearXMPString Class value.


AudioModDate Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses AudioModDate property of the Dynamic Media XMP schema. This XMP property specifies date and time when the audio was last modified.

Declaration:

public ImGearXMPDate AudioModDate   {get; set;}

Value:

ImGearXMPDate Class value.


AudioSampleRate Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses AudioSampleRate property of the Dynamic Media XMP schema. This XMP property specifies audio sample rate. Can be any value, but commonly 32000, 41100, or 48000.

Declaration:

public ImGearXMPInteger AudioSampleRate   {get; set;}

Value:

ImGearXMPInteger Class value.


AudioSampleType Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses AudioSampleType property of the Dynamic Media XMP schema. This XMP property specifies audio sample type. Allowed values are: "8Int", "16Int", "32Int", "32Float".

Declaration:

public ImGearXMPString AudioSampleType   {get; set;}

Value:

ImGearXMPString Class value.


BeatSpliceParams Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses BeatSpliceParams property of the Dynamic Media XMP schema. This XMP property specifies parameters for Beat Splice stretch mode. /* beatSpliceStretch Internal*/

Declaration:

public ImGearXMPBeatSpliceStretch BeatSpliceParams   {get; set;}

Value:

ImGearXMPBeatSpliceStretch Class value.


Composer Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Composer property of the Dynamic Media XMP schema. This XMP property specifies composer's name.

Declaration:

public ImGearXMPString Composer   {get; set;}

Value:

ImGearXMPString Class value.


ContributedMedia Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ContributedMedia property of the Dynamic Media XMP schema. This XMP property specifies unordered list of all media used to create this media. /* bag Media Internal*/

Declaration:

public ImGearXMPBag<ImGearXMPMedia> ContributedMedia   {get; set;}

Value:

ImGearXMPBag<ImGearXMPMedia Class> value.


Copyright Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Copyright property of the Dynamic Media XMP schema. This XMP property specifies copyright information.

Declaration:

public ImGearXMPString Copyright   {get; set;}

Value:

ImGearXMPString Class value.


Duration Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Duration property of the Dynamic Media XMP schema. This XMP property specifies duration of the media file.

Declaration:

public ImGearXMPTime Duration   {get; set;}

Value:

ImGearXMPTime Class value.


Engineer Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Engineer property of the Dynamic Media XMP schema. This XMP property specifies engineer's name.

Declaration:

public ImGearXMPString Engineer   {get; set;}

Value:

ImGearXMPString Class value.


FileDataRate Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses FileDataRate property of the Dynamic Media XMP schema. This XMP property specifies file data rate in megabytes per second. For example: "36/10" = 3.6 MB/sec.

Declaration:

public ImGearXMPRational FileDataRate   {get; set;}

Value:

ImGearXMPRational Class value.


Genre Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Genre property of the Dynamic Media XMP schema. This XMP property specifies name of the genre.

Declaration:

public ImGearXMPString Genre   {get; set;}

Value:

ImGearXMPString Class value.


Instrument Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Instrument property of the Dynamic Media XMP schema. This XMP property specifies musical instrument.

Declaration:

public ImGearXMPString Instrument   {get; set;}

Value:

ImGearXMPString Class value.


IntroTime Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses IntroTime property of the Dynamic Media XMP schema. This XMP property specifies duration of lead time for queuing music.

Declaration:

public ImGearXMPTime IntroTime   {get; set;}

Value:

ImGearXMPTime Class value.


Key Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Key property of the Dynamic Media XMP schema. This XMP property specifies audio's musical key. Allowed values are: "C", "C#", "D", "D#", "E", "F", "F#", "G", "G#", "A", "A#", "B"

Declaration:

public ImGearXMPString Key   {get; set;}

Value:

ImGearXMPString Class value.


LogComment Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses LogComment property of the Dynamic Media XMP schema. This XMP property specifies log comments.

Declaration:

public ImGearXMPString LogComment   {get; set;}

Value:

ImGearXMPString Class value.


Loop Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Loop property of the Dynamic Media XMP schema. This XMP property specifies true, the clip can be looped seemlessly.

Declaration:

public ImGearXMPBoolean Loop   {get; set;}

Value:

ImGearXMPBoolean Class value.


Markers Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Markers property of the Dynamic Media XMP schema. This XMP property specifies ordered list of markers.

Declaration:

public ImGearXMPSeq<ImGearXMPMarker> Markers   {get; set;}

Value:

ImGearXMPSeq<ImGearXMPMarker Class> value.


MetadataModDate Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses MetadataModDate property of the Dynamic Media XMP schema. This XMP property specifies date and time when the metadata was last modified.

Declaration:

public ImGearXMPDate MetadataModDate   {get; set;}

Value:

ImGearXMPDate Class value.


NumberOfBeats Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses NumberOfBeats property of the Dynamic Media XMP schema. This XMP property specifies number of beats.

Declaration:

public ImGearXMPReal NumberOfBeats   {get; set;}

Value:

ImGearXMPReal Class value.


OutCue Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses OutCue property of the Dynamic Media XMP schema. This XMP property specifies time at which to fade out.

Declaration:

public ImGearXMPTime OutCue   {get; set;}

Value:

ImGearXMPTime Class value.


ProjectRef Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ProjectRef property of the Dynamic Media XMP schema. This XMP property specifies reference to the project that created this file.

Declaration:

public ImGearXMPProjectLink ProjectRef   {get; set;}

Value:

ImGearXMPProjectLink Class value.


PullDown Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses PullDown property of the Dynamic Media XMP schema. This XMP property specifies sampling phase of film to be converted to video (pull-down). Allowed values are: "WSSWW", "SSWWW", "SWWWS", "WWWSS", "WWSSW", "WSSWW_24p", "SSWWW_24p", "SWWWS_24p", "WWWSS_24p", "WWSSW_24p".

Declaration:

public ImGearXMPString PullDown   {get; set;}

Value:

ImGearXMPString Class value.


RelativePeakAudioFilePath Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses RelativePeakAudioFilePath property of the Dynamic Media XMP schema. This XMP property specifies relative path to the file's peak audio file. If empty, no peak file exists.

Declaration:

public ImGearXMPString RelativePeakAudioFilePath   {get; set;}

Value:

ImGearXMPString Class value.


RelativeTimestamp Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses RelativeTimestamp property of the Dynamic Media XMP schema. This XMP property specifies start time of the media inside the audio project.

Declaration:

public ImGearXMPTime RelativeTimestamp   {get; set;}

Value:

ImGearXMPTime Class value.


ReleaseDate Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ReleaseDate property of the Dynamic Media XMP schema. This XMP property specifies date the title was released.

Declaration:

public ImGearXMPDate ReleaseDate   {get; set;}

Value:

ImGearXMPDate Class value.


ResampleParams Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ResampleParams property of the Dynamic Media XMP schema. This XMP property specifies parameters for Resample stretch mode.

Declaration:

public ImGearXMPResampleStretch ResampleParams   {get; set;}

Value:

ImGearXMPResampleStretch Class value.


ScaleType Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ScaleType property of the Dynamic Media XMP schema. This XMP property specifies musical scale used in the music. Allowed values are: "Major", "Minor", "Both", "Neither".

Declaration:

public ImGearXMPString ScaleType   {get; set;}

Value:

ImGearXMPString Class value.


Scene Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Scene property of the Dynamic Media XMP schema. This XMP property specifies name of the scene.

Declaration:

public ImGearXMPString Scene   {get; set;}

Value:

ImGearXMPString Class value.


ShotDate Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ShotDate property of the Dynamic Media XMP schema. This XMP property specifies date and time when the video was shot.

Declaration:

public ImGearXMPDate ShotDate   {get; set;}

Value:

ImGearXMPDate Class value.


ShotLocation Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ShotLocation property of the Dynamic Media XMP schema. This XMP property specifies name of the location where the video was shot. For example: "Oktoberfest, Munich Germany". For more accurate positioning, use the EXIF GPS values.

Declaration:

public ImGearXMPString ShotLocation   {get; set;}

Value:

ImGearXMPString Class value.


ShotName Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ShotName property of the Dynamic Media XMP schema. This XMP property specifies name of the shot or take.

Declaration:

public ImGearXMPString ShotName   {get; set;}

Value:

ImGearXMPString Class value.


SpeakerPlacement Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses SpeakerPlacement property of the Dynamic Media XMP schema. This XMP property specifies description of the speaker angles.

Declaration:

public ImGearXMPString SpeakerPlacement   {get; set;}

Value:

ImGearXMPString Class value.


StartTimecode Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses StartTimecode property of the Dynamic Media XMP schema. This XMP property specifies timecode of the first frame of video in the file, as obtained from the device control.

Declaration:

public ImGearXMPTimecode StartTimecode   {get; set;}

Value:

ImGearXMPTimecode Class value.


StretchMode Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses StretchMode property of the Dynamic Media XMP schema. This XMP property specifies audio stretch mode. Allowed values are: "Fixed length", "Time-Scale", "Resample", "Beat Splice", "Hybrid".

Declaration:

public ImGearXMPString StretchMode   {get; set;}

Value:

ImGearXMPString Class value.


TapeName Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses TapeName property of the Dynamic Media XMP schema. This XMP property specifies name of the tape from which the clip was captured, as set during the capture process.

Declaration:

public ImGearXMPString TapeName   {get; set;}

Value:

ImGearXMPString Class value.


Tempo Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Tempo property of the Dynamic Media XMP schema. This XMP property specifies audio's tempo.

Declaration:

public ImGearXMPReal Tempo   {get; set;}

Value:

ImGearXMPReal Class value.


TimeScaleParams Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses TimeScaleParams property of the Dynamic Media XMP schema. This XMP property specifies parameters for Time-Scale stretch mode.

Declaration:

public ImGearXMPTimeScaleStretch TimeScaleParams   {get; set;}

Value:

ImGearXMPTimeScaleStretch Class value.


TimeSignature Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses TimeSignature property of the Dynamic Media XMP schema. This XMP property specifies time signature of the music. Allowed values are: One of: "2/4", "3/4", "4/4", "5/4", "7/4", "6/8", "9/8", "12/8", "other".

Declaration:

public ImGearXMPString TimeSignature   {get; set;}

Value:

ImGearXMPString Class value.


TrackNumber Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses TrackNumber property of the Dynamic Media XMP schema. This XMP property specifies numeric value indicating the order of the audio file within its original recording.

Declaration:

public ImGearXMPInteger TrackNumber   {get; set;}

Value:

ImGearXMPInteger Class value.


VideoAlphaMode Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses VideoAlphaMode property of the Dynamic Media XMP schema. This XMP property specifies alpha mode. Allowed values are: "straight", "pre-multiplied".

Declaration:

public ImGearXMPString VideoAlphaMode {get; set;}

Value:

ImGearXMPString Class value.


VideoAlphaPremultipleColor Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses VideoAlphaPremultipleColor property of the Dynamic Media XMP schema. This XMP property specifies a color in CMYK or RGB to be used as the pre-multiple color when alpha mode is pre-multiplied.

Declaration:

public ImGearXMPColorant VideoAlphaPremultipleColor {get; set;}

Value:

ImGearXMPColorant Class value.


VideoAlphaUnityIsTransparent Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses VideoAlphaUnityIsTransparent property of the Dynamic Media XMP schema. This XMP property specifies true, unity is clear, when false, it is opaque.

Declaration:

public ImGearXMPBoolean VideoAlphaUnityIsTransparent   {get; set;}

Value:

ImGearXMPBoolean Class value.


VideoColorSpace Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses VideoColorSpace property of the Dynamic Media XMP schema. This XMP property specifies choice of The color space. Allowed values are: "sRGB" (used by Photoshop), "CCIR-601" (used for NTSC), "CCIR-709" (used for HD).

Declaration:

public ImGearXMPString VideoColorSpace {get; set;}

Value:

ImGearXMPString Class value.


VideoCompressor Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses VideoCompressor property of the Dynamic Media XMP schema. This XMP property specifies compression used. For example, jpeg.

Declaration:

public ImGearXMPString VideoCompressor   {get; set;}

Value:

ImGearXMPString Class value.


VideoFieldOrder Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses VideoFieldOrder property of the Dynamic Media XMP schema. This XMP property specifies field order for video. One of: "Upper", "Lower", "Progressive".

Declaration:

public ImGearXMPString VideoFieldOrder   {get; set;}

Value:

ImGearXMPString Class value.


VideoFrameRate Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses VideoFrameRate property of the Dynamic Media XMP schema. This XMP property specifies choice of The video frame rate. One of: "24", "NTSC", "PAL".

Declaration:

public ImGearXMPString VideoFrameRate {get; set;}

Value:

ImGearXMPString Class value.


VideoFrameSize Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses VideoFrameSize property of the Dynamic Media XMP schema. This XMP property specifies frame size. For example: w:720, h: 480, unit:pixels.

Declaration:

public ImGearXMPDimensions VideoFrameSize   {get; set;}

Value:

ImGearXMPDimensions Class value.


VideoModDate Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses VideoModDate property of the Dynamic Media XMP schema. This XMP property specifies date and time when the video was last modified.

Declaration:

public ImGearXMPDate VideoModDate   {get; set;}

Value:

ImGearXMPDate Class value.


VideoPixelAspectRatio Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses VideoPixelAspectRatio property of the Dynamic Media XMP schema. This XMP property specifies aspect ratio, expressed as ht/wd. For example: "648/720" = 0.9.

Declaration:

public ImGearXMPRational VideoPixelAspectRatio   {get; set;}

Value:

ImGearXMPRational Class value.


VideoPixelDepth Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses VideoPixelDepth property of the Dynamic Media XMP schema. This XMP property specifies choice of The size in bits of each color component of a pixel. Standard Windows 32-bit pixels have 8 bits per component. Allowed values are: "8Int", "16Int", "32Int", "32Float.

Declaration:

public ImGearXMPString VideoPixelDepth {get; set;}

Value:

ImGearXMPString Class value.


ImGearXMPBeatSpliceStretch Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an XMP BeatSpliceStretch structure. This structure contains a set of parameters used when stretching audio using the Beat Splice stretch mode.

Declaration:

public class ImGearXMPBeatSpliceStretch : ImGearXMPStructure

Members:

Constructors
Name
Description
ImGearXMPBeatSpliceStretch Constructor
Creates and initializes an instance of ImGearXMPBeatSpliceStretch Class.

Properties
Name
Description
UseFileBeatsMarker Property
Accesses the UseFileBeatsMarker field.
RiseInDecibel Property
Accesses the RiseInDecibel field.
RiseInTimeDuration Property
Accesses the RiseInTimeDuration field.


ImGearXMPBeatSpliceStretch Class Constructors

The ImGearXMPBeatSpliceStretch Class has the following constructors:
Constructors
Name
Description
ImGearXMPBeatSpliceStretch Constructor
Creates and initializes an instance of ImGearXMPBeatSpliceStretch Class.


ImGearXMPBeatSpliceStretch Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPBeatSpliceStretch Class.

Declaration:

public ImGearXMPBeatSpliceStretch()

Return Value:

New instance of ImGearXMPBeatSpliceStretch Class object.


ImGearXMPBeatSpliceStretch Class Properties

The ImGearXMPBeatSpliceStretch Class has the following properties
Properties
Name
Description
UseFileBeatsMarker Property
Accesses the UseFileBeatsMarker field.
RiseInDecibel Property
Accesses the RiseInDecibel field.
RiseInTimeDuration Property
Accesses the RiseInTimeDuration field.


UseFileBeatsMarker Property

32-bit
64-bit
CF
P
P
P

Description:

When true, the file beat markers are used for stretching. Otherwise the rise and duration fields are used to automatically locate the beats.

Declaration:

public ImGearXMPBoolean UseFileBeatsMarker {get; set;}

Value:

ImGearXMPBoolean Class value.


RiseInDecibel Property

32-bit
64-bit
CF
P
P
P

Description:

The amount sound must increase in amplitude to detect a beat.

Declaration:

public ImGearXMPreal RiseInDecibel {get; set;}

Value:

ImGearXMPReal Class value.


RiseInTimeDuration Property

32-bit
64-bit
CF
P
P
P

Description:

The duration of the sampling window used to measure the audio increase for locating beats.

Declaration:

public ImGearXMPTime RiseInTimeDuration {get; set;}

Value:

ImGearXMPTime Class value.


ImGearXMPMarker Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an XMP Marker structure. This structure is used to desribe an important location in a video sequence.

Declaration:

public class ImGearXMPMarker : ImGearXMPStructure

Members:

Constructors
Name
Description
ImGearXMPMarker Constructor
Creates and initializes an instance of ImGearXMPMarker Class.

Properties
Name
Description
StartTime Property
Accesses the StartTime field.
Duration Property
Accesses the Duration field.
Comment Property
Accesses the Comment field.
Name Property
Accesses the Name field.
Location Property
Accesses the Location field.
Target Property
Accesses the Target field.
Type Property
Accesses the Type field.


ImGearXMPMarker Class Constructors

The ImGearXMPMarker Class has the following constructors:
Constructors
Name
Description
ImGearXMPMarker Constructor
Creates and initializes an instance of ImGearXMPMarker Class.


ImGearXMPMarker Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPMarker Class.

Declaration:

public ImGearXMPMarker()

Return Value:

New instance of ImGearXMPMarker Class object.


ImGearXMPMarker Class Properties

The ImGearXMPMarker Class has the following properties:
Properties
Name
Description
StartTime Property
Accesses the StartTime field.
Duration Property
Accesses the Duration field.
Comment Property
Accesses the Comment field.
Name Property
Accesses the Name field.
Location Property
Accesses the Location field.
Target Property
Accesses the Target field.
Type Property
Accesses the Type field.


StartTime Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the timeline position of the marker.

Declaration:

public ImGearXMPTime StartTime {get; set;}

Value:

ImGearXMPTime Class value.


Duration Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the duration of the marker.

Declaration:

public ImGearXMPTime Duration {get; set;}

Value:

ImGearXMPTime Class value.


Comment Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies a descriptive comment.

Declaration:

public ImGearXMPString Comment {get; set;}

Value:

ImGearXMPString Class value.


Name Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the name of the marker. This becomes, for example, the name of a chapter in a DVD.

Declaration:

public ImGearXMPString Name {get; set;}

Value:

ImGearXMPString Class value.


Location Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the URL of the location to jump to.

Declaration:

public ImGearXMPString Location {get; set;}

Value:

ImGearXMPString Class value.


Target Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the part of the URL following the # sign. For example, in the URL http://ns.adobe.com/xmp#Start, the value is Start.

Declaration:

public ImGearXMPString Target {get; set;}

Value:

ImGearXMPString Class value.


Type Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the marker type. Allowed values are: "Chapter", "Cue", "Beat", "Track", "Index".

Declaration:

public ImGearXMPString Type {get; set;}

Value:

ImGearXMPString Class value.


ImGearXMPMedia Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an XMP Media structure. This structure specifies a reference to a media asset.

Declaration:

public class ImGearXMPMedia : ImGearXMPStructure

Members:

Constructors
Name
Description
ImGearXMPMedia Constructor
Creates and initializes an instance of ImGearXMPMedia Class.

Properties
Name
Description
Path Property
Accesses the Path field.
Track Property
Accesses the Track field.
StartTime Property
Accesses the StartTime field.
Duration Property
Accesses the Duration field.
Managed Property
Accesses the Managed field.
WebStatement Property
Accesses the WebStatement field.


ImGearXMPMedia Class Constructors

The ImGearXMPMedia Class has the following constructors:
Constructors
Name
Description
ImGearXMPMedia Constructor
Creates and initializes an instance of ImGearXMPMedia Class.


ImGearXMPMedia Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPMedia Class.

Declaration:

public ImGearXMPMedia()

Return Value:

New instance of ImGearXMPMedia Class object.


ImGearXMPMedia Class Properties

The ImGearXMPMedia Class has the following properties:
Properties
Name
Description
Path Property
Accesses the Path field.
Track Property
Accesses the Track field.
StartTime Property
Accesses the StartTime field.
Duration Property
Accesses the Duration field.
Managed Property
Accesses the Managed field.
WebStatement Property
Accesses the WebStatement field.


Path Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the location of the media.

Declaration:

public ImGearXMPString Path {get; set;}

Value:

ImGearXMPString Class value.


Track Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies an identifier for the track that contained this media. Could be a track name or a number.

Declaration:

public ImGearXMPString Track {get; set;}

Value:

ImGearXMPString Class value.


StartTime Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the timeline position of the start of the media. This can be used to locate the media with a track.

Declaration:

public ImGearXMPTime StartTime {get; set;}

Value:

ImGearXMPTime Class value.


Duration Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the duration of the media in the timeline.

Declaration:

public ImGearXMPTime Duration {get; set;}

Value:

ImGearXMPTime Class value.


Managed Property

32-bit
64-bit
CF
P
P
P

Description:

When this property is true, it specifies a rights-managed resource.

Declaration:

public ImGearXMPBoolean Managed {get; set;}

Value:

ImGearXMPBoolean Class value.


WebStatement Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the location of a web page describing the owner and/or rights statement for this resource.

Declaration:

public ImGearXMPString WebStatement {get; set;}

Value:

ImGearXMPString Class value.


ImGearXMPProjectLink Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an XMP ProjectLink structure. This structure specifies the type of a video file and path of the project that created it.

Declaration:

public class ImGearXMPProjectLink : ImGearXMPStructure

Members:

Constructors
Name
Description
ImGearXMPProjectLink Constructor
Creates and initializes an instance of ImGearXMPProjectLink Class.

Properties
Name
Description
Type Property
Accesses the Type field.
Path Property
Accesses the Path field.


ImGearXMPProjectLink Class Constructors

The ImGearXMPProjectLink Class has the following constructors:
Constructors
Name
Description
ImGearXMPProjectLink Constructor
Creates and initializes an instance of ImGearXMPProjectLink Class.


ImGearXMPProjectLink Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPProjectLink Class.

Declaration:

public ImGearXMPProjectLink()

Return Value:

New instance of ImGearXMPProjectLink Class object.


ImGearXMPProjectLink Class Properties

The ImGearXMPProjectLink Class has the following properties:
Properties
Name
Description
Type Property
Accesses the Type field.
Path Property
Accesses the Path field.


Type Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the file type. Allowed values are: "movie", "still", "audio", "custom".

Declaration:

public ImGearXMPString Type {get; set;}

Value:

ImGearXMPString Class value.


Path Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the full path to the project that created this file.

Declaration:

public ImGearXMPString Path {get; set;}

Value:

ImGearXMPString Class value.


ImGearXMPResampleStretch Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an XMP ResampleStretch structure. This structure contains a set of parameters used when stretching audio using the Resample stretch mode.

Declaration:

public class ImGearXMPResampleStretch : ImGearXMPStructure

Members:

Constructors
Name
Description
ImGearXMPResampleStretch Constructor
Creates and initializes an instance of ImGearXMPResampleStretch Class.

Properties
Name
Description
Quality Property
Accesses the Quality field.


ImGearXMPResampleStretch Class Constructors

The ImGearXMPResampleStretch Class has the following constructors:
Constructors
Name
Description
ImGearXMPResampleStretch Constructor
Creates and initializes an instance of ImGearXMPResampleStretch Class.


ImGearXMPResampleStretch Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPResampleStretch Class.

Declaration:

public ImGearXMPResampleStretch()

Return Value:

New instance of ImGearXMPResampleStretch Class object.


ImGearXMPResampleStretch Class Properties

The ImGearXMPResampleStretch Class has the following properties:
Properties
Name
Description
Quality Property
Accesses the Quality field.


Quality Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the resample quality. Allowed values are: "High", "Medium", "Low".

Declaration:

public ImGearXMPString Quality {get; set;}

Value:

ImGearXMPString Class value.


ImGearXMPTime Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an XMP Time structure. This structure provides a representation of a time value in seconds.

Declaration:

public class ImGearXMPTime : ImGearXMPStructure

Members:

Constructors
Name
Description
ImGearXMPTime Constructor
Creates and initializes an instance of ImGearXMPTime Class

Properties
Name
Description
Value Property
Accesses the Value field.
Scale Property
Accesses the Scale field.


ImGearXMPTime Class Constructors

The ImGearXMPTime Class has the following constructors:
Constructors
Name
Description
ImGearXMPTime Constructor
Creates and initializes an instance of ImGearXMPTime Class.


ImGearXMPTime Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPTime Class.

Declaration:

public ImGearXMPTime()

Return Value:

New instance of ImGearXMPTime Class object.


ImGearXMPTime Class Properties

The ImGearXMPTime Class has the following properties:
Properties
Name
Description
Value Property
Accesses the Value field.
Scale Property
Accesses the Scale field.


Value Property

32-bit
64-bit
CF
P
P
P

Description:

The time value in the specified scale.

Declaration:

public ImGearXMPInteger Value {get; set;}

Value:

ImGearXMPInteger Class value.


Scale Property

32-bit
64-bit
CF
P
P
P

Description:

The scale for the time value. For NTSC, use 1001/30000, or the less accurate 100/2997. For PAL, use 1/25.

Declaration:

public ImGearXMPRational Scale {get; set;}

Value:

ImGearXMPRational Class value.


ImGearXMPTimecode Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an XMP Timecode structure. This structure represents a time value in video.

Declaration:

public class ImGearXMPTimecode : ImGearXMPStructure

Members:

Constructors
Name
Description
ImGearXMPTimecode Constructor
Creates and initializes an instance of ImGearXMPTimecode Class.

Properties
Name
Description
TimeFormat Property
Accesses the TimeFormat field.
TimeValue Property
Accesses the TimeValue field.


ImGearXMPTimecode Class Constructors

The ImGearXMPTimecode Class has the following constructors:
Constructors
Name
Description
ImGearXMPTimecode Constructor
Creates and initializes an instance of ImGearXMPTimecode Class.


ImGearXMPTimecode Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPTimecode Class.

Declaration:

public ImGearXMPTimecode()

Return Value:

New instance of ImGearXMPTimecode Class object.


ImGearXMPTimecode Class Properties

The ImGearXMPTimecode Class has the following properties:
Properties
Name
Description
TimeFormat Property
Accesses the TimeFormat field.
TimeValue Property
Accesses the TimeValue field.


TimeFormat Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the format used in the TimeValue. Allowed values are: "24Timecode", "25Timecode", "2997DropTimecode" (semicolon delimiter), "2997NonDropTimecode", "30Timecode", "50Timecode", "5994DropTimecode", "5994NonDropTimecode", "60Timecode", "23976Timecode".

Declaration:

public ImGearXMPString TimeFormat {get; set;}

Value:

ImGearXMPString Class value.


TimeValue Property

32-bit
64-bit
CF
P
P
P

Description:

A time value in the specified format. Time values use a colon delimiter in all formats except 2997drop, which uses a semicolon. The four fields indicate hours, minutes, seconds, and frames: hh:mm:ss:ff. The actual duration in seconds depends on the format.

Declaration:

public ImGearXMPString TimeValue {get; set;}

Value:

ImGearXMPString Class value.


ImGearXMPTimeScaleStretch Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an XMP TimeScaleStretch structure. The structure contains a set of parameters used when stretching audio using the Time-Scale stretch mode.

Declaration:

public class ImGearXMPTimeScaleStretch : ImGearXMPStructure

Members:

Constructors
Name
Description
ImGearXMPTimeScaleStretch Constructor
Creates and initializes an instance of ImGearXMPTimeScaleStretch Class.

Properties
Name
Description
Quality Property
Accesses the Quality field.
FrameSize Property
Accesses the FrameSize field.
FrameOverlappingPercentage Property
Accesses the FrameOverlappingPercentage field.


ImGearXMPTimeScaleStretch Class Constructors

The ImGearXMPTimeScaleStretch Class has the following constructors:
Constructors
Name
Description
ImGearXMPTimeScaleStretch Constructor
Creates and initializes an instance of ImGearXMPTimeScaleStretch Class.


ImGearXMPTimeScaleStretch Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPTimeScaleStretch Class.

Declaration:

public ImGearXMPTimeScaleStretch()

Return Value:

New instance of ImGearXMPTimeScaleStretch Class object.


ImGearXMPTimeScaleStretch Class Properties

The ImGearXMPTimeScaleStretch Class has the following properties:
Properties
Name
Description
Quality Property
Accesses the Quality field.
FrameSize Property
Accesses the FrameSize field.
FrameOverlappingPercentage Property
Accesses the FrameOverlappingPercentage field.


Quality Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the stretch quality. Allowed values are: "High", "Medium", "Low".

Declaration:

public ImGearXMPString Quality {get; set;}

Value:

ImGearXMPString Class value.


FrameSize Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the number of splices per beat.

Declaration:

public ImGearXMPReal FrameSize {get; set;}

Value:

ImGearXMPReal Class value.


FrameOverlappingPercentage Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the percentage of overlap between frames.

Declaration:

public ImGearXMPReal FrameOverlappingPercentage {get; set;}

Value:

ImGearXMPReal Class value.


ImageGear.Formats.XMP.EXIF Namespace

ImageGear.Formats.XMP.EXIF Namespace

32-bit
64-bit
CF
P
P
P

Description:

This namespace provides the API for XMP.EXIF format.

Declaration:

namespace ImageGear.Formats.XMP.EXIF

Members:

Classes:
Name
Description
ImGearEXIFXMPMetadata Class
Provides simplified access to EXIF XMP metadata schema.
ImGearXMPCFAPattern Class
Represents an XMP CFAPattern structure.
ImGearXMPDeviceSettings Class
Represents an XMP DeviceSettings structure.
ImGearXMPFlash Class
Represents an XMP Flash structure.
ImGearXMPGPSCoordinate Class
Represents an XMP GPSCoordinate structure.
ImGearXMPOECFSFR Class
Represents an XMP OECFSFR (Opto-Electronic Conversion Function / Spatial Frequancy Response) structure.

Enumerations:
Name
Description
ImGearXMPGPSDirection Enumeration
Represents GPS directions, used in the EXIF XMP schema.

See Also:

ImageGear.Formats.XMP Namespace

ImageGear.Formats.XMP.AdobePDF Namespace

ImageGear.Formats.XMP.Basic Namespace

ImageGear.Formats.XMP.BasicJobTicket Namespace

ImageGear.Formats.XMP.CameraRaw Namespace

ImageGear.Formats.XMP.DublinCore Namespace

ImageGear.Formats.XMP.DynamicMedia Namespace

ImageGear.Formats.XMP.EXIF Namespace

ImageGear.Formats.XMP.EXIFAux Namespace

ImageGear.Formats.XMP.IPTC4XMPCore Namespace

ImageGear.Formats.XMP.MediaManagement Namespace

ImageGear.Formats.XMP.MicrosoftPhoto Namespace

ImageGear.Formats.XMP.PagedText Namespace

ImageGear.Formats.XMP.Photoshop Namespace

ImageGear.Formats.XMP.RightsManagement Namespace

ImageGear.Formats.XMP.TIFF Namespace


ImageGear.Formats.XMP.EXIF Classes

The ImageGear.Formats.XMP.EXIF Namespace has the following class members:

Classes:
Name
Description
ImGearEXIFXMPMetadata Class
Provides simplified access to EXIF XMP metadata schema.
ImGearXMPCFAPattern Class
Represents an XMP CFAPattern structure.
ImGearXMPDeviceSettings Class
Represents an XMP DeviceSettings structure.
ImGearXMPFlash Class
Represents an XMP Flash structure.
ImGearXMPGPSCoordinate Class
Represents an XMP GPSCoordinate structure.
ImGearXMPOECFSFR Class
Represents an XMP OECFSFR (Opto-Electronic Conversion Function / Spatial Frequancy Response) structure.


ImGearEXIFXMPMetadata Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides simplified access to EXIF XMP metadata schema. It includes the properties defined solely by the EXIF standard.

See also ImageGear.Formats.XMP.TIFF and ImageGear.Formats.XMP.EXIFAux namespaces.

Declaration:

public class ImGearEXIFXMPMetadata : ImageGear.Formats.ImGearXMPFormatMetadata

Members:

Constructors
Name
Description
ImGearEXIFXMPMetadata Constructor
Creates and initializes an instance of ImGearEXIFXMPMetadata Class.

Properties
Name
Description
ApertureValue Property
Accesses ApertureValue property of the EXIF XMP schema.
BrightnessValue Property
Accesses BrightnessValue property of the EXIF XMP schema.
CFAPattern Property
Accesses CFAPattern property of the EXIF XMP schema.
ColorSpace Property
Accesses ColorSpace property of the EXIF XMP schema.
ComponentsConfiguration Property
Accesses ComponentsConfiguration property of the EXIF XMP schema.
CompressedBitsPerPixel Property
Accesses CompressedBitsPerPixel property of the EXIF XMP schema.
Contrast Property
Accesses Contrast property of the EXIF XMP schema.
CustomRendered Property
Accesses CustomRendered property of the EXIF XMP schema.
DateTimeDigitized Property
Accesses DateTimeDigitized property of the EXIF XMP schema.
DateTimeOriginal Property
Accesses DateTimeOriginal property of the EXIF XMP schema.
DeviceSettingDescription Property
Accesses DeviceSettingDescription property of the EXIF XMP schema.
DigitalZoomRatio Property
Accesses DigitalZoomRatio property of the EXIF XMP schema.
ExifVersion Property
Accesses ExifVersion property of the EXIF XMP schema.
ExposureBiasValue Property
Accesses ExposureBiasValue property of the EXIF XMP schema.
ExposureIndex Property
Accesses ExposureIndex property of the EXIF XMP schema.
ExposureMode Property
Accesses ExposureMode property of the EXIF XMP schema.
ExposureProgram Property
Accesses ExposureProgram property of the EXIF XMP schema.
ExposureTime Property
Accesses ExposureTime property of the EXIF XMP schema.
FileSource Property
Accesses FileSource property of the EXIF XMP schema.
Flash Property
Accesses Flash property of the EXIF XMP schema.
FlashEnergy Property
Accesses FlashEnergy property of the EXIF XMP schema.
FlashpixVersion Property
Accesses FlashpixVersion property of the EXIF XMP schema.
FNumber Property
Accesses FNumber property of the EXIF XMP schema.
FocalLength Property
Accesses FocalLength property of the EXIF XMP schema.
FocalLengthIn35mmFilm Property
Accesses FocalLengthIn35mmFilm property of the EXIF XMP schema.
FocalPlaneResolutionUnit Property
Accesses FocalPlaneResolutionUnit property of the EXIF XMP schema.
FocalPlaneXResolution Property
Accesses FocalPlaneXResolution property of the EXIF XMP schema.
FocalPlaneYResolution Property
Accesses FocalPlaneYResolution property of the EXIF XMP schema.
GainControl Property
Accesses GainControl property of the EXIF XMP schema.
GPSAltitude Property
Accesses GPSAltitude property of the EXIF XMP schema.
GPSAltitudeRef Property
Accesses GPSAltitudeRef property of the EXIF XMP schema.
GPSAreaInformation Property
Accesses GPSAreaInformation property of the EXIF XMP schema.
GPSDestBearing Property
Accesses GPSDestBearing property of the EXIF XMP schema.
GPSDestBearingRef Property
Accesses GPSDestBearingRef property of the EXIF XMP schema.
GPSDestDistance Property
Accesses GPSDestDistance property of the EXIF XMP schema.
GPSDestDistanceRef Property
Accesses GPSDestDistanceRef property of the EXIF XMP schema.
GPSDestLatitude Property
Accesses GPSDestLatitude property of the EXIF XMP schema.
GPSDestLongitude Property
Accesses GPSDestLongitude property of the EXIF XMP schema.
GPSDifferential Property
Accesses GPSDifferential property of the EXIF XMP schema.
GPSDOP Property
Accesses GPSDOP property of the EXIF XMP schema.
GPSImgDirection Property
Accesses GPSImgDirection property of the EXIF XMP schema.
GPSImgDirectionRef Property
Accesses GPSImgDirectionRef property of the EXIF XMP schema.
GPSLatitude Property
Accesses GPSLatitude property of the EXIF XMP schema.
GPSLongitude Property
Accesses GPSLongitude property of the EXIF XMP schema.
GPSMapDatum Property
Accesses GPSMapDatum property of the EXIF XMP schema.
GPSMeasureMode Property
Accesses GPSMeasureMode property of the EXIF XMP schema.
GPSProcessingMethod Property
Accesses GPSProcessingMethod property of the EXIF XMP schema.
GPSSatellites Property
Accesses GPSSatellites property of the EXIF XMP schema.
GPSSpeed Property
Accesses GPSSpeed property of the EXIF XMP schema.
GPSSpeedRef Property
Accesses GPSSpeedRef property of the EXIF XMP schema.
GPSStatus Property
Accesses GPSStatus property of the EXIF XMP schema.
GPSTimeStamp Property
Accesses GPSTimeStamp property of the EXIF XMP schema.
GPSTrack Property
Accesses GPSTrack property of the EXIF XMP schema.
GPSTrackRef Property
Accesses GPSTrackRef property of the EXIF XMP schema.
GPSVersionID Property
Accesses GPSVersionID property of the EXIF XMP schema.
ImageUniqueID Property
Accesses ImageUniqueID property of the EXIF XMP schema.
ISOSpeedRatings Property
Accesses ISOSpeedRatings property of the EXIF XMP schema.
LightSource Property
Accesses LightSource property of the EXIF XMP schema.
MaxApertureValue Property
Accesses MaxApertureValue property of the EXIF XMP schema.
MeteringMode Property
Accesses MeteringMode property of the EXIF XMP schema.
OECF Property
Accesses OECF property of the EXIF XMP schema.
PixelXDimension Property
Accesses PixelXDimension property of the EXIF XMP schema.
PixelYDimension Property
Accesses PixelYDimension property of the EXIF XMP schema.
RelatedSoundFile Property
Accesses RelatedSoundFile property of the EXIF XMP schema.
Saturation Property
Accesses Saturation property of the EXIF XMP schema.
SceneCaptureType Property
Accesses SceneCaptureType property of the EXIF XMP schema.
SceneType Property
Accesses SceneType property of the EXIF XMP schema.
SensingMethod Property
Accesses SensingMethod property of the EXIF XMP schema.
Sharpness Property
Accesses Sharpness property of the EXIF XMP schema.
ShutterSpeedValue Property
Accesses ShutterSpeedValue property of the EXIF XMP schema.
SpatialFrequencyResponse Property
Accesses SpatialFrequencyResponse property of the EXIF XMP schema.
SpectralSensitivity Property
Accesses SpectralSensitivity property of the EXIF XMP schema.
SubjectArea Property
Accesses SubjectArea property of the EXIF XMP schema.
SubjectDistance Property
Accesses SubjectDistance property of the EXIF XMP schema.
SubjectDistanceRange Property
Accesses SubjectDistanceRange property of the EXIF XMP schema.
SubjectLocation Property
Accesses SubjectLocation property of the EXIF XMP schema.
UserComment Property
Accesses UserComment property of the EXIF XMP schema.
WhiteBalance Property
Accesses WhiteBalance property of the EXIF XMP schema.


ImGearEXIFXMPMetadata Class Constructors

The ImGearEXIFXMPMetadata Class has the following constructors:
Constructors
Name
Description
ImGearEXIFXMPMetadata Constructor
Creates and initializes an instance of ImGearEXIFXMPMetadata Class.


ImGearEXIFXMPMetadata Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearEXIFXMPMetadata Class.

Declaration:

public ImGearEXIFXMPMetadata ()

Return Value:

New instance of ImGearEXIFXMPMetadata Class object.


ImGearEXIFXMPMetadata Class Properties

The ImGearEXIFXMPMetadata Class has the following properties:
Properties
Name
Description
ApertureValue Property
Accesses ApertureValue property of the EXIF XMP schema.
BrightnessValue Property
Accesses BrightnessValue property of the EXIF XMP schema.
CFAPattern Property
Accesses CFAPattern property of the EXIF XMP schema.
ColorSpace Property
Accesses ColorSpace property of the EXIF XMP schema.
ComponentsConfiguration Property
Accesses ComponentsConfiguration property of the EXIF XMP schema.
CompressedBitsPerPixel Property
Accesses CompressedBitsPerPixel property of the EXIF XMP schema.
Contrast Property
Accesses Contrast property of the EXIF XMP schema.
CustomRendered Property
Accesses CustomRendered property of the EXIF XMP schema.
DateTimeDigitized Property
Accesses DateTimeDigitized property of the EXIF XMP schema.
DateTimeOriginal Property
Accesses DateTimeOriginal property of the EXIF XMP schema.
DeviceSettingDescription Property
Accesses DeviceSettingDescription property of the EXIF XMP schema.
DigitalZoomRatio Property
Accesses DigitalZoomRatio property of the EXIF XMP schema.
ExifVersion Property
Accesses ExifVersion property of the EXIF XMP schema.
ExposureBiasValue Property
Accesses ExposureBiasValue property of the EXIF XMP schema.
ExposureIndex Property
Accesses ExposureIndex property of the EXIF XMP schema.
ExposureMode Property
Accesses ExposureMode property of the EXIF XMP schema.
ExposureProgram Property
Accesses ExposureProgram property of the EXIF XMP schema.
ExposureTime Property
Accesses ExposureTime property of the EXIF XMP schema.
FileSource Property
Accesses FileSource property of the EXIF XMP schema.
Flash Property
Accesses Flash property of the EXIF XMP schema.
FlashEnergy Property
Accesses FlashEnergy property of the EXIF XMP schema.
FlashpixVersion Property
Accesses FlashpixVersion property of the EXIF XMP schema.
FNumber Property
Accesses FNumber property of the EXIF XMP schema.
FocalLength Property
Accesses FocalLength property of the EXIF XMP schema.
FocalLengthIn35mmFilm Property
Accesses FocalLengthIn35mmFilm property of the EXIF XMP schema.
FocalPlaneResolutionUnit Property
Accesses FocalPlaneResolutionUnit property of the EXIF XMP schema.
FocalPlaneXResolution Property
Accesses FocalPlaneXResolution property of the EXIF XMP schema.
FocalPlaneYResolution Property
Accesses FocalPlaneYResolution property of the EXIF XMP schema.
GainControl Property
Accesses GainControl property of the EXIF XMP schema.
GPSAltitude Property
Accesses GPSAltitude property of the EXIF XMP schema.
GPSAltitudeRef Property
Accesses GPSAltitudeRef property of the EXIF XMP schema.
GPSAreaInformation Property
Accesses GPSAreaInformation property of the EXIF XMP schema.
GPSDestBearing Property
Accesses GPSDestBearing property of the EXIF XMP schema.
GPSDestBearingRef Property
Accesses GPSDestBearingRef property of the EXIF XMP schema.
GPSDestDistance Property
Accesses GPSDestDistance property of the EXIF XMP schema.
GPSDestDistanceRef Property
Accesses GPSDestDistanceRef property of the EXIF XMP schema.
GPSDestLatitude Property
Accesses GPSDestLatitude property of the EXIF XMP schema.
GPSDestLongitude Property
Accesses GPSDestLongitude property of the EXIF XMP schema.
GPSDifferential Property
Accesses GPSDifferential property of the EXIF XMP schema.
GPSDOP Property
Accesses GPSDOP property of the EXIF XMP schema.
GPSImgDirection Property
Accesses GPSImgDirection property of the EXIF XMP schema.
GPSImgDirectionRef Property
Accesses GPSImgDirectionRef property of the EXIF XMP schema.
GPSLatitude Property
Accesses GPSLatitude property of the EXIF XMP schema.
GPSLongitude Property
Accesses GPSLongitude property of the EXIF XMP schema.
GPSMapDatum Property
Accesses GPSMapDatum property of the EXIF XMP schema.
GPSMeasureMode Property
Accesses GPSMeasureMode property of the EXIF XMP schema.
GPSProcessingMethod Property
Accesses GPSProcessingMethod property of the EXIF XMP schema.
GPSSatellites Property
Accesses GPSSatellites property of the EXIF XMP schema.
GPSSpeed Property
Accesses GPSSpeed property of the EXIF XMP schema.
GPSSpeedRef Property
Accesses GPSSpeedRef property of the EXIF XMP schema.
GPSStatus Property
Accesses GPSStatus property of the EXIF XMP schema.
GPSTimeStamp Property
Accesses GPSTimeStamp property of the EXIF XMP schema.
GPSTrack Property
Accesses GPSTrack property of the EXIF XMP schema.
GPSTrackRef Property
Accesses GPSTrackRef property of the EXIF XMP schema.
GPSVersionID Property
Accesses GPSVersionID property of the EXIF XMP schema.
ImageUniqueID Property
Accesses ImageUniqueID property of the EXIF XMP schema.
ISOSpeedRatings Property
Accesses ISOSpeedRatings property of the EXIF XMP schema.
LightSource Property
Accesses LightSource property of the EXIF XMP schema.
MaxApertureValue Property
Accesses MaxApertureValue property of the EXIF XMP schema.
MeteringMode Property
Accesses MeteringMode property of the EXIF XMP schema.
OECF Property
Accesses OECF property of the EXIF XMP schema.
PixelXDimension Property
Accesses PixelXDimension property of the EXIF XMP schema.
PixelYDimension Property
Accesses PixelYDimension property of the EXIF XMP schema.
RelatedSoundFile Property
Accesses RelatedSoundFile property of the EXIF XMP schema.
Saturation Property
Accesses Saturation property of the EXIF XMP schema.
SceneCaptureType Property
Accesses SceneCaptureType property of the EXIF XMP schema.
SceneType Property
Accesses SceneType property of the EXIF XMP schema.
SensingMethod Property
Accesses SensingMethod property of the EXIF XMP schema.
Sharpness Property
Accesses Sharpness property of the EXIF XMP schema.
ShutterSpeedValue Property
Accesses ShutterSpeedValue property of the EXIF XMP schema.
SpatialFrequencyResponse Property
Accesses SpatialFrequencyResponse property of the EXIF XMP schema.
SpectralSensitivity Property
Accesses SpectralSensitivity property of the EXIF XMP schema.
SubjectArea Property
Accesses SubjectArea property of the EXIF XMP schema.
SubjectDistance Property
Accesses SubjectDistance property of the EXIF XMP schema.
SubjectDistanceRange Property
Accesses SubjectDistanceRange property of the EXIF XMP schema.
SubjectLocation Property
Accesses SubjectLocation property of the EXIF XMP schema.
UserComment Property
Accesses UserComment property of the EXIF XMP schema.
WhiteBalance Property
Accesses WhiteBalance property of the EXIF XMP schema.


ApertureValue Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ApertureValue property of the EXIF XMP schema. This XMP property represents EXIF tag 37378 (0x9202) and specifies lens aperture in APEX units.

Declaration:

public ImGearXMPRational ApertureValue {get; set;}

Value:

ImGearXMPRational Class value.


BrightnessValue Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses BrightnessValue property of the EXIF XMP schema. This XMP property represents EXIF tag 37379 (0x9203) and specifies brightness, unit is APEX.

Declaration:

public ImGearXMPRational BrightnessValue {get; set;}

Value:

ImGearXMPRational Class value.


CFAPattern Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses CFAPattern property of the EXIF XMP schema. This XMP property represents EXIF tag 41730 (0xA302) and specifies color filter array geometric pattern of the image sense.

Declaration:

public ImGearXMPCFAPattern CFAPattern {get; set;}

Value:

ImGearXMPCFAPattern Class value.


ColorSpace Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ColorSpace property of the EXIF XMP schema. This XMP property represents EXIF tag 40961 (0xA001) and specifies color space information.

Declaration:

public ImGearXMPEnum< ImGearEXIFColorSpace> ColorSpace {get; set;}

Value:

ImGearXMPEnum Generic Class< ImGearEXIFColorSpace> value.


ComponentsConfiguration Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ComponentsConfiguration property of the EXIF XMP schema. This XMP property represents EXIF tag 37121 (0x9101) and specifies configuration of components in data.

Declaration:

public ImGearXMPSeq<ImGearXMPInteger> ComponentsConfiguration {get; set;}

Value:

ImGearXMPSeq<ImGearXMPInteger Class> value.


CompressedBitsPerPixel Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses CompressedBitsPerPixel property of the EXIF XMP schema. This XMP property represents EXIF tag 37122 (0x9102) and specifies compression mode used for a compressed image is indicated in unit bits per pixel.

Declaration:

public ImGearXMPRational CompressedBitsPerPixel {get; set;}

Value:

ImGearXMPRational Class value.


Contrast Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Contrast property of the EXIF XMP schema. This XMP property represents EXIF tag 41992 (0xA408) and indicates the direction of contrast processing applied by the camera.

Declaration:

public ImGearXMPEnum<ImGearEXIFContrastMode> Contrast {get; set;}

Value:

ImGearXMPEnum Generic Class<ImGearEXIFContrastMode> value.


CustomRendered Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses CustomRendered property of the EXIF XMP schema. This XMP property represents EXIF tag 41985 (0xA401) and indicates the use of special processing on image data.

Declaration:

public ImGearXMPEnum<ImGearEXIFCustomRendered> CustomRendered {get; set;}

Value:

ImGearXMPEnum Generic Class<ImGearEXIFCustomRendered> value.


DateTimeDigitized Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses DateTimeDigitized property of the EXIF XMP schema. This XMP property represents EXIF tag 36868, 0x9004 (primary) and 37522, 0x9292 (subseconds). It specifies date and time when image was stored as digital data, can be the same as DateTimeOriginal if originally stored in digital form.

Declaration:

public ImGearXMPDate DateTimeDigitized {get; set;}

Value:

ImGearXMPDate Class value.


DateTimeOriginal Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses DateTimeOriginal property of the EXIF XMP schema. This XMP property represents EXIF tags 36867, 0x9003 (primary) and 37521, 0x9291 (subseconds). It specidies date and time when original image was generated.

Declaration:

public ImGearXMPDate DateTimeOriginal {get; set;}

Value:

ImGearXMPDate Class value.


DeviceSettingDescription Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses DeviceSettingDescription property of the EXIF XMP schema. This XMP property represents EXIF tag 41995 (0xA40B) and indicates information on the picture-taking conditions of a particular camera model.

Declaration:

public ImGearXMPDeviceSettings DeviceSettingDescription {get; set;}

Value:

ImGearXMPDeviceSettings Class value.


DigitalZoomRatio Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses DigitalZoomRatio property of the EXIF XMP schema. This XMP property represents EXIF tag 41988 (0xA404) and indicates the digital zoom ratio when the image was shot.

Declaration:

public ImGearXMPRational DigitalZoomRatio {get; set;}

Value:

ImGearXMPRational Class value.


ExifVersion Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ExifVersion property of the EXIF XMP schema. This XMP property represents EXIF tag 36864 (0x9000) and specifies EXIF version number.

Declaration:

public ImGearXMPString ExifVersion {get; set;}

Value:

ImGearXMPString Class value.


ExposureBiasValue Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ExposureBiasValue property of the EXIF XMP schema. This XMP property represents EXIF tag 37380 (0x9204) and specifies exposure bias, unit is APEX.

Declaration:

public ImGearXMPRational ExposureBiasValue {get; set;}

Value:

ImGearXMPRational Class value.


ExposureIndex Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ExposureIndex property of the EXIF XMP schema. This XMP property represents EXIF tag 41493 (0xA215) and specifies exposure index of input device.

Declaration:

public ImGearXMPRational ExposureIndex {get; set;}

Value:

ImGearXMPRational Class value.


ExposureMode Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ExposureMode property of the EXIF XMP schema. This XMP property represents EXIF tag 41986 (0xA402) and indicates the exposure mode set when the image was shot.

Declaration:

public ImGearXMPEnum<ImGearEXIFExposureMode> ExposureMode {get; set;}

Value:

ImGearXMPEnum Generic Class<ImGearEXIFExposureMode> value.


ExposureProgram Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ExposureProgram property of the EXIF XMP schema. This XMP property represents EXIF tag 34850 (0x8822) and specifies class of program used for exposure.

Declaration:

public ImGearXMPEnum<ImGearEXIFExposureProgram> ExposureProgram {get; set;}

Value:

ImGearXMPEnum Generic Class<ImGearEXIFExposureProgram> value.


ExposureTime Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ExposureTime property of the EXIF XMP schema. This XMP property represents EXIF tag 33434 (0x829A) and specifies exposure time in seconds.

Declaration:

public ImGearXMPRational ExposureTime {get; set;}

Value:

ImGearXMPRational Class value.


FileSource Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses FileSource property of the EXIF XMP schema. This XMP property represents EXIF tag 41728 (0xA300) and indicates image source.

Declaration:

public ImGearXMPEnum<ImGearEXIFFileSource> FileSource {get; set;}

Value:

ImGearXMPEnum Generic Class<ImGearEXIFFileSource> value.


Flash Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Flash property of the EXIF XMP schema. This XMP property represents EXIF tag 37385 (0x9209) and specifies strobe light (flash) source data.

Declaration:

public ImGearXMPFlash Flash {get; set;}

Value:

ImGearXMPFlash Class value.


FlashEnergy Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses FlashEnergy property of the EXIF XMP schema. This XMP property represents EXIF tag 41483 (0xA20B) and specifies strobe energy during image capture.

Declaration:

public ImGearXMPRational FlashEnergy {get; set;}

Value:

ImGearXMPRational Class value.


FlashpixVersion Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses FlashpixVersion property of the EXIF XMP schema. This XMP property represents EXIF tag 40960 (0xA000) and specifies version of FlashPix.

Declaration:

public ImGearXMPString FlashpixVersion {get; set;}

Value:

ImGearXMPString Class value.


FNumber Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses FNumber property of the EXIF XMP schema. This XMP property represents EXIF tag 33437 (0x829D) and specifies F number.

Declaration:

public ImGearXMPRational FNumber {get; set;}

Value:

ImGearXMPRational Class value.


FocalLength Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses FocalLength property of the EXIF XMP schema. This XMP property represents EXIF tag 37386 (0x920A) and specifies focal length of the lens, in millimeters.

Declaration:

public ImGearXMPRational FocalLength {get; set;}

Value:

ImGearXMPRational Class value.


FocalLengthIn35mmFilm Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses FocalLengthIn35mmFilm property of the EXIF XMP schema. This XMP property represents EXIF tag 41989 (0xA405) and indicates the equivalent focal length assuming a 35mm film camera, in mm. A value of 0 means the focal length is unknown. Note that this tag differs from the FocalLength tag.

Declaration:

public ImGearXMPInteger FocalLengthIn35mmFilm {get; set;}

Value:

ImGearXMPInteger Class value.


FocalPlaneResolutionUnit Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses FocalPlaneResolutionUnit property of the EXIF XMP schema. This XMP property represents EXIF tag 41488 (0xA210) and specifies unit used for FocalPlaneXResolution and FocalPlaneYResolution.

Declaration:

public ImGearXMPEnum<ImGearTIFFResolutionUnit> FocalPlaneResolutionUnit {get; set;}

Value:

ImGearXMPEnum Generic Class<ImGearTIFFResolutionUnit> value.


FocalPlaneXResolution Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses FocalPlaneXResolution property of the EXIF XMP schema. This XMP property represents EXIF tag 41486 (0xA20E) and specifies horizontal focal resolution, measured pixels per unit.

Declaration:

public ImGearXMPRational FocalPlaneXResolution {get; set;}

Value:

ImGearXMPRational Class value.


FocalPlaneYResolution Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses FocalPlaneYResolution property of the EXIF XMP schema. This XMP property represents EXIF tag 41487 (0xA20F) and specifies vertical focal resolution, measured in pixels per unit.

Declaration:

public ImGearXMPRational FocalPlaneYResolution {get; set;}

Value:

ImGearXMPRational Class value.


GainControl Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GainControl property of the EXIF XMP schema. This XMP property represents EXIF tag 41991 (0xA407) and indicates the degree of overall image gain adjustment.

Declaration:

public ImGearXMPEnum<ImGearEXIFGainControl> GainControl {get; set;}

Value:

ImGearXMPEnum Generic Class<ImGearEXIFGainControl> value.


GPSAltitude Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GPSAltitude property of the EXIF XMP schema. This XMP property represents EXIF GPS tag 6 (0x06) and indicates altitude in meters.

Declaration:

public ImGearXMPRational GPSAltitude {get; set;}

Value:

ImGearXMPRational Class value.


GPSAltitudeRef Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GPSAltitudeRef property of the EXIF XMP schema. This XMP property represents EXIF GPS tag 5 (0x5) and indicates whether the altitude is above or below sea level.

Declaration:

public ImGearXMPEnum<ImGearEXIFGPSAltitudeReference> GPSAltitudeRef {get; set;}

Value:

ImGearXMPEnum Generic Class< ImGearEXIFGPSAltitudeReference> value.


GPSAreaInformation Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GPSAreaInformation property of the EXIF XMP schema. This XMP property represents EXIF GPS tag 28 (0x1C) and specifies a character string recording the name of the GPS area.

Declaration:

public ImGearXMPString GPSAreaInformation {get; set;}

Value:

ImGearXMPString Class value.


GPSDestBearing Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GPSDestBearing property of the EXIF XMP schema. This XMP property represents EXIF GPS tag 24 (0x18) and specifies destination bearing, values from 0 to 359.99.

Declaration:

public ImGearXMPRational GPSDestBearing {get; set;}

Value:

ImGearXMPRational Class value.


GPSDestBearingRef Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GPSDestBearingRef property of the EXIF XMP schema. This XMP property represents EXIF GPS tag 23 (0x17) and specifies reference for movement direction.

Declaration:

public ImGearXMPString GPSDestBearingRef {get; set;}

Value:

ImGearXMPString Class value.


GPSDestDistance Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GPSDestDistance property of the EXIF XMP schema. This XMP property represents EXIF GPS tag 26 (0x1A) and specifies distance to destination.

Declaration:

public ImGearXMPRational GPSDestDistance {get; set;}

Value:

ImGearXMPRational Class value.


GPSDestDistanceRef Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GPSDestDistanceRef property of the EXIF XMP schema. This XMP property represents EXIF GPS tag 25 (0x19) and specifies units used for speed measurement.

Declaration:

public ImGearXMPString GPSDestDistanceRef {get; set;}

Value:

ImGearXMPString Class value.


GPSDestLatitude Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GPSDestLatitude property of the EXIF XMP schema. This XMP property represents EXIF GPS tag 20, 0x14 (position) and 19, 0x13 (North/South). Indicates destination latitude.

Declaration:

public ImGearXMPGPSCoordinate GPSDestLatitude {get; set;}

Value:

ImGearXMPGPSCoordinate Class value.


GPSDestLongitude Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GPSDestLongitude property of the EXIF XMP schema. This XMP property represents EXIF GPS tag 22, 0x16 (position) and 21, 0x15 (East/West). Indicates destination longitude.

Declaration:

public ImGearXMPGPSCoordinate GPSDestLongitude {get; set;}

Value:

ImGearXMPGPSCoordinate Class value.


GPSDifferential Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GPSDifferential property of the EXIF XMP schema. This XMP property represents EXIF GPS tag 30 (0x1E) and indicates whether differential correction is applied to the GPS receiver.

Declaration:

public ImGearXMPEnum<ImGearEXIFGPSDifferential> GPSDifferential {get; set;}

Value:

ImGearXMPEnum Generic Class<ImGearEXIFGPSDifferential> value.


GPSDOP Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GPSDOP property of the EXIF XMP schema. This XMP property represents EXIF GPS tag 11 (0x0B) and specifies degree of precision for GPS data.

Declaration:

public ImGearXMPRational GPSDOP {get; set;}

Value:

ImGearXMPRational Class value.


GPSImgDirection Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GPSImgDirection property of the EXIF XMP schema. This XMP property represents EXIF GPS tag 17 (0x11) and specifies direction of image when captured, values range from 0 to 359.99.

Declaration:

public ImGearXMPRational GPSImgDirection {get; set;}

Value:

ImGearXMPRational Class value.


GPSImgDirectionRef Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GPSImgDirectionRef property of the EXIF XMP schema. This XMP property represents EXIF GPS tag 16 (0x10) and specifies reference for movement direction.

Declaration:

public ImGearXMPEnum<ImGearEXIFGPSDirectionReference> GPSImgDirectionRef {get; set;}

Value:

ImGearXMPEnum Generic Class<ImGearEXIFGPSDirectionReference> value.


GPSLatitude Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GPSLatitude property of the EXIF XMP schema. This XMP property represents EXIF GPS tag 2, 0x02 (position) and 1, 0x01 (North/South). Indicates latitude.

Declaration:

public ImGearXMPGPSCoordinate GPSLatitude {get; set;}

Value:

ImGearXMPGPSCoordinate Class value.


GPSLongitude Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GPSLongitude property of the EXIF XMP schema. This XMP property represents EXIF GPS tag 4, 0x04 (position) and 3, 0x03 (East/West). Indicates longitude.

Declaration:

public ImGearXMPGPSCoordinate GPSLongitude {get; set;}

Value:

ImGearXMPGPSCoordinate Class value.


GPSMapDatum Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GPSMapDatum property of the EXIF XMP schema. This XMP property represents EXIF GPS tag 18 (0x12) and specifies geodetic survey data.

Declaration:

public ImGearXMPString GPSMapDatum {get; set;}

Value:

ImGearXMPString Class value.


GPSMeasureMode Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GPSMeasureMode property of the EXIF XMP schema. This XMP property represents EXIF GPS tag 10 (0x0A) and specifies GPS measurement mode.

Declaration:

public ImGearXMPString GPSMeasureMode {get; set;}

Value:

ImGearXMPString Class value.


GPSProcessingMethod Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GPSProcessingMethod property of the EXIF XMP schema. This XMP property represents EXIF GPS tag 27 (0x1B) and specifies a character string recording the name of the method used for location finding.

Declaration:

public ImGearXMPString GPSProcessingMethod {get; set;}

Value:

ImGearXMPString Class value.


GPSSatellites Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GPSSatellites property of the EXIF XMP schema. This XMP property represents EXIF GPS tag 8 (0x08) and specifies satellite information, format is unspecified.

Declaration:

public ImGearXMPString GPSSatellites {get; set;}

Value:

ImGearXMPString Class value.


GPSSpeed Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GPSSpeed property of the EXIF XMP schema. This XMP property represents EXIF GPS tag 13 (0x0D) and specifies speed of GPS receiver movement.

Declaration:

public ImGearXMPRational GPSSpeed {get; set;}

Value:

ImGearXMPRational Class value.


GPSSpeedRef Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GPSSpeedRef property of the EXIF XMP schema. This XMP property represents EXIF GPS tag 12 (0x0C) and specifies units used to speed measurement.

Declaration:

public ImGearXMPString GPSSpeedRef {get; set;}

Value:

ImGearXMPString Class value.


GPSStatus Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GPSStatus property of the EXIF XMP schema. This XMP property represents EXIF GPS tag 9 (0x09) and specifies status of GPS receiver at image creation time.

Declaration:

public ImGearXMPString GPSStatus {get; set;}

Value:

ImGearXMPString Class value.


GPSTimeStamp Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GPSTimeStamp property of the EXIF XMP schema. This XMP property represents EXIF GPS tag 29 (date), 0x1D, and, and GPS tag 7 (time) (0x07) and specifies time stamp of GPS data, in Coordinated Universal Time.

Declaration:

public ImGearXMPDate GPSTimeStamp {get; set;}

Value:

ImGearXMPDate Class value.


GPSTrack Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GPSTrack property of the EXIF XMP schema. This XMP property represents EXIF GPS tag 15 (0x0F) and specifies direction of GPS movement, values range from 0 to 359.99.

Declaration:

public ImGearXMPRational GPSTrack {get; set;}

Value:

ImGearXMPRational Class value.


GPSTrackRef Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GPSTrackRef property of the EXIF XMP schema. This XMP property represents EXIF GPS tag 14 (0x0E) and specifies reference for movement direction.

Declaration:

public ImGearXMPString GPSTrackRef {get; set;}

Value:

ImGearXMPString Class value.


GPSVersionID Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses GPSVersionID property of the EXIF XMP schema. This XMP property represents EXIF GPS tag 0 (0x00) and specifies a decimal encoding of each of the four EXIF bytes with period separators. The current value is "2.0.0.0". /*Text Internal*/

Declaration:

public ImGearXMPString GPSVersionID {get; set;}

Value:

ImGearXMPString Class value.


ImageUniqueID Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ImageUniqueID property of the EXIF XMP schema. This XMP property represents EXIF tag 42016 (0xA420) and specifies an identifier assigned uniquely to each image. It is recorded as a 32 character ASCII string, equivalent to hexadecimal notation and 128-bit fixed length.

Declaration:

public ImGearXMPString ImageUniqueID {get; set;}

Value:

ImGearXMPString Class value.


ISOSpeedRatings Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ISOSpeedRatings property of the EXIF XMP schema. This XMP property represents EXIF tag 34855 (0x8827) and specifies ISO Speed and ISO Latitude of the input device as specified in ISO 12232.

Declaration:

public ImGearXMPSeq<ImGearXMPInteger> ISOSpeedRatings {get; set;}

Value:

ImGearXMPSeq<ImGearXMPInteger Class> value.


LightSource Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses LightSource property of the EXIF XMP schema. This XMP property represents EXIF tag 37384 (0x9208) and specifies light source.

Declaration:

public ImGearXMPEnum<ImGearEXIFLightSource> LightSource {get; set;}

Value:

ImGearXMPEnum Generic Class<ImGearEXIFLightSource> value.


MaxApertureValue Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses MaxApertureValue property of the EXIF XMP schema. This XMP property represents EXIF tag 37381 (0x9205) and specifies smallest F number of lens, in APEX.

Declaration:

public ImGearXMPRational MaxApertureValue {get; set;}

Value:

ImGearXMPRational Class value.


MeteringMode Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses MeteringMode property of the EXIF XMP schema. This XMP property represents EXIF tag 37383 (0x9207) and specifies image metering mode.

Declaration:

public ImGearXMPEnum<ImGearEXIFMeteringMode> MeteringMode {get; set;}

Value:

ImGearXMPEnum Generic Class<ImGearEXIFMeteringMode> value.


OECF Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses OECF property of the EXIF XMP schema. This XMP property represents EXIF tag 34856 (0x8828) and specifies Opto-Electronic Conversion Function as specified in ISO 14524.

Declaration:

public ImGearXMPOECFSFR OECF {get; set;}

Value:

ImGearXMPOECFSFR Class value.


PixelXDimension Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses PixelXDimension property of the EXIF XMP schema. This XMP property represents EXIF tag 40962 (0xA002) and specifies valid image width, in pixels.

Declaration:

public ImGearXMPInteger PixelXDimension {get; set;}

Value:

ImGearXMPInteger Class value.


PixelYDimension Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses PixelYDimension property of the EXIF XMP schema. This XMP property represents EXIF tag 40963 (0xA003) and specifies valid image height, in pixels.

Declaration:

public ImGearXMPInteger PixelYDimension {get; set;}

Value:

ImGearXMPInteger Class value.


RelatedSoundFile Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses RelatedSoundFile property of the EXIF XMP schema. This XMP property represents EXIF tag 40964 (0xA004) and specifies an "8.3" file name for the related sound file.

Declaration:

public ImGearXMPString RelatedSoundFile {get; set;}

Value:

ImGearXMPString Class value.


Saturation Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Saturation property of the EXIF XMP schema. This XMP property represents EXIF tag 41993 (0xA409) and indicates the direction of saturation processing applied by the camera.

Declaration:

public ImGearXMPEnum<ImGearEXIFSaturationMode> Saturation {get; set;}

Value:

ImGearXMPEnum Generic Class<ImGearEXIFSaturationMode> value.


SceneCaptureType Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses SceneCaptureType property of the EXIF XMP schema. This XMP property represents EXIF tag 41990 (0xA406) and indicates the type of scene that was shot.

Declaration:

public ImGearXMPEnum<ImGearEXIFSceneCaptureType> SceneCaptureType {get; set;}

Value:

ImGearXMPEnum Generic Class<ImGearEXIFSceneCaptureType> value.


SceneType Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses SceneType property of the EXIF XMP schema. This XMP property represents EXIF tag 41729 (0xA301) and indicates the type of scene.

Declaration:

public ImGearXMPEnum<ImGearEXIFSceneType> SceneType {get; set;}

Value:

ImGearXMPEnum Generic Class<ImGearEXIFSceneType> value.


SensingMethod Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses SensingMethod property of the EXIF XMP schema. This XMP property represents EXIF tag 41495 (0xA217) and specifies image sensor type on input device.

Declaration:

public ImGearXMPEnum<ImGearEXIFSensingMethod> SensingMethod {get; set;}

Value:

ImGearXMPEnum Generic Class<ImGearEXIFSensingMethod> value.


Sharpness Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Sharpness property of the EXIF XMP schema. This XMP property represents EXIF tag 41994 (0xA40A) and indicates the direction of sharpness processing applied by the camera.

Declaration:

public ImGearXMPEnum<ImGearEXIFSharpnessMode> Sharpness {get; set;}

Value:

ImGearXMPEnum Generic Class<ImGearEXIFSharpnessMode> value.


ShutterSpeedValue Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ShutterSpeedValue property of the EXIF XMP schema. This XMP property represents EXIF tag 37377 (0x9201) and specifies Shutter speed, unit is APEX. See Annex C of the EXIF specification.

Declaration:

public ImGearXMPRational ShutterSpeedValue {get; set;}

Value:

ImGearXMPRational Class value.


SpatialFrequencyResponse Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses SpatialFrequencyResponse property of the EXIF XMP schema. This XMP property represents EXIF tag 41484 (0xA20C) and specifies input device spatial frequency table and SFR values as specified in ISO 12233.

Declaration:

public ImGearXMPOECFSFR SpatialFrequencyResponse {get; set;}

Value:

ImGearXMPOECFSFR Class value.


SpectralSensitivity Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses SpectralSensitivity property of the EXIF XMP schema. This XMP property represents EXIF tag 34852 (0x8824) and specifies spectral sensitivity of each channel.

Declaration:

public ImGearXMPString SpectralSensitivity {get; set;}

Value:

ImGearXMPString Class value.


SubjectArea Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses SubjectArea property of the EXIF XMP schema. This XMP property represents EXIF tag 37396 (0x9214) and specifies the location and area of the main subject in the overall scene.

Declaration:

public ImGearXMPSeq<ImGearXMPInteger> SubjectArea {get; set;}

Value:

ImGearXMPSeq<ImGearXMPInteger Class> value.


SubjectDistance Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses SubjectDistance property of the EXIF XMP schema. This XMP property represents EXIF tag 37382 (0x9206) and specifies distance to subject, in meters.

Declaration:

public ImGearXMPRational SubjectDistance {get; set;}

Value:

ImGearXMPRational Class value.


SubjectDistanceRange Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses SubjectDistanceRange property of the EXIF XMP schema. This XMP property represents EXIF tag 41996 (0xA40C) and indicates the distance range to the subject.

Declaration:

public ImGearXMPEnum<ImGearEXIFDistanceRange> SubjectDistanceRange {get; set;}

Value:

ImGearXMPEnum Generic Class<ImGearEXIFDistanceRange> value.


SubjectLocation Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses SubjectLocation property of the EXIF XMP schema. This XMP property represents EXIF tag 41492 (0xA214) and specifies location of the main subject of the scene. The first value is the horizontal pixel and the second value is the vertical pixel at which the main subject appears.

Declaration:

public ImGearXMPSeq<ImGearXMPInteger> SubjectLocation {get; set;}

Value:

ImGearXMPString Class value.


UserComment Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses UserComment property of the EXIF XMP schema. This XMP property represents EXIF tag 37510 (0x9286) and specifies comments from user.

Declaration:

public ImGearXMPLangAlt UserComment {get; set;}

Value:

ImGearXMPLangAlt Class value.


WhiteBalance Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses WhiteBalance property of the EXIF XMP schema. This XMP property represents EXIF tag 41987 (0xA403) and indicates the white balance mode set when the image was shot.

Declaration:

public ImGearXMPEnum<ImGearEXIFWhiteBalanceMode> WhiteBalance {get; set;}

Value:

ImGearXMPEnum Generic Class<ImGearEXIFWhiteBalanceMode> value.


ImGearXMPCFAPattern Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an XMP CFAPattern structure.

Declaration:

public class ImGearXMPCFAPattern : ImGearXMPStructure

Members:

Constructor
Name
Description
ImGearXMPCFAPattern Constructor
Creates and initializes an instance of ImGearXMPCFAPattern Class.
ImGearXMPCFAPattern Constructor
Creates and initializes an instance of ImGearXMPCFAPattern Class.
Properties
Name
Description
Columns Property
Accesses the Columns field.
Rows Property
Accesses the Rows field.
Values Property
Accesses the Values field.


ImGearXMPCFAPattern Class Constructors

The ImGearXMPCFAPattern Class has the following constructors:
Constructor
Name
Description
ImGearXMPCFAPattern Constructor
Creates and initializes an instance of ImGearXMPCFAPattern Class.
ImGearXMPCFAPattern Constructor
Creates and initializes an instance of ImGearXMPCFAPattern Class.


ImGearXMPCFAPattern Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPCFAPattern Class.

Declaration:

public ImGearXMPCFAPattern()

Return Value:

New instance of ImGearXMPCFAPattern Class object.


ImGearXMPCFAPattern Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPCFAPattern Class.

Declaration:

public ImGearXMPCFAPattern(int columns, int rows, int[] values)

Return Value:

New instance of ImGearXMPCFAPattern Class object.


ImGearXMPCFAPattern Class Properties

The ImGearXMPCFAPattern Class has the following properties:
Properties
Name
Description
Columns Property
Accesses the Columns field.
Rows Property
Accesses the Rows field.
Values Property
Accesses the Values field.


Columns Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the number of columns, in the CFA pattern.

Declaration:

public ImGearXMPInteger Columns {get; set;}

Value:

ImGearXMPInteger Class value.


Rows Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the number of rows in the CFA pattern.

Declaration:

public ImGearXMPInteger Rows {get; set;}

Value:

ImGearXMPInteger Class value.


Values Property

32-bit
64-bit
CF
P
P
P

Description:

CFA values, ordered as follows:

value [0,0]
...
value [n - 1, 0]
value [0, m - 1]
...
value [n - 1, m - 1]

where n is number of columns, and m is number of rows.

Declaration:

public ImGearXMPSeq<ImGearXMPInt> Values {get; set;}

Value:

ImGearXMPSeq Generic Class<ImGearXMPInt> value.


ImGearXMPDeviceSettings Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an XMP DeviceSettings structure.

Declaration:

public class ImGearXMPDeviceSettings : ImGearXMPStructure

Members:

Constructors
Name
Description
ImGearXMPDeviceSettings Constructor
Creates and initializes an instance of ImGearXMPDeviceSettings Class.

Properties
Name
Description
Columns Property
Accesses the Columns field.
Rows Property
Accesses the Rows field.
Settings Property
Accesses the Settings field.


ImGearXMPDeviceSettings Class Constructors

The ImGearXMPDeviceSettings Class has the following constructors:
Constructors
Name
Description
ImGearXMPDeviceSettings Constructor
Creates and initializes an instance of ImGearXMPDeviceSettings Class.


ImGearXMPDeviceSettings Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPDeviceSettings Class.

Declaration:

public ImGearXMPDeviceSettings()

Return Value:

New instance of ImGearXMPDeviceSettings Class object.


ImGearXMPDeviceSettings Class Properties

The ImGearXMPDeviceSettings Class has the following properties:
Properties
Name
Description
Columns Property
Accesses the Columns field.
Rows Property
Accesses the Rows field.
Settings Property
Accesses the Settings field.


Columns Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the number of display columns.

Declaration:

public ImGearXMPInteger Columns {get; set;}

Value:

ImGearXMPInteger Class value.


Rows Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the number of display rows.

Declaration:

public ImGearXMPInteger Rows {get; set;}

Value:

ImGearXMPInteger Class value.


Settings Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies camera settings, in order.

Declaration:

public ImGearXMPSeq<ImGearXMPString> Settings {get; set;}

Value:

ImGearXMPSeq<ImGearXMPString Class> value.


ImGearXMPFlash Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an XMP Flash structure.

Declaration:

public class ImGearXMPFlash : ImGearXMPStructure

Members:

Constructors
Name
Description
ImGearXMPFlash Constructor
Creates and initializes an instance of ImGearXMPFlash Class.

Properties
Name
Description
Fired Property
Accesses the Fired field.
Return Property
Accesses the Return field.
Mode Property
Accesses the Mode field.
Function Property
Accesses the Function field.
RedEyeMode Property
Accesses the RedEyeMode field.


ImGearXMPFlash Class Constructors

The ImGearXMPFlash Class has the following constructors:
Constructors
Name
Description
ImGearXMPFlash Constructor
Creates and initializes an instance of ImGearXMPFlash Class.


ImGearXMPFlash Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPFlash Class.

Declaration:

public ImGearXMPFlash()

Return Value:

New instance of ImGearXMPFlash Class object.


ImGearXMPFlash Class Properties

The ImGearXMPFlash Class has the following properties:
Properties
Name
Description
Fired Property
Accesses the Fired field.
Return Property
Accesses the Return field.
Mode Property
Accesses the Mode field.
Function Property
Accesses the Function field.
RedEyeMode Property
Accesses the RedEyeMode field.


Fired Property

32-bit
64-bit
CF
P
P
P

Description:

This property tells if flash has fired.

Declaration:

public ImGearXMPBoolean Fired {get; set;}

Value:

ImGearXMPBoolean Class value.


Return Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies whether strobe return is supported and if supported, detected.

Declaration:

public ImGearXMPEnum<ImGearEXIFFlashReturn> Return {get; set;}

Value:

ImGearXMPEnum Generic Class<ImGearEXIFFlashReturn> value.


Mode Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the flash mode.

Declaration:

public ImGearXMPEnum<ImGearEXIFFlashMode> Mode {get; set;}

Value:

ImGearXMPEnum Generic Class<ImGearEXIFFlashMode> value.


Function Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies if flash function is present. True means that flash function is NOT present.

Declaration:

public ImGearXMPBoolean Function {get; set;}

Value:

ImGearXMPBoolean Class value.


RedEyeMode Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies if red-eye reduction is supported.

Declaration:

public ImGearXMPBoolean RedEyeMode {get; set;}

Value:

ImGearXMPBoolean Class value.


ImGearXMPGPSCoordinate Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an XMP GPSCoordinate structure.

A GPS coordinate in XMP may use either Second or MinuteFraction field, but not both.

Declaration:

public class ImGearXMPGPSCoordinate : ImGearXMPValue

Members:

Constructors
Name
Description
ImGearXMPGPSCoordinate Constructor
Creates and initializes an instance of ImGearXMPGPSCoordinate Class.
ImGearXMPGPSCoordinate Constructor
Creates and initializes an instance of ImGearXMPGPSCoordinate Class.
ImGearXMPGPSCoordinate Constructor
Creates and initializes an instance of ImGearXMPGPSCoordinate Class.

Properties
Name
Description
Degree Property
Gets the Degree of GPS Coordinate.
Minute Property
Gets the Minute of GPS Coordinate.
Second Property
Gets the Second of GPS Coordinate.
MinuteFraction Property
Gets the Fraction of minute of GPS Coordinate.
Direction Property
Gets the Direction of GPS Coordinate.


ImGearXMPGPSCoordinate Class Constructors

The ImGearXMPGPSCoordinate Class has the following constructors:
Constructors
Name
Description
ImGearXMPGPSCoordinate Constructor
Creates and initializes an instance of ImGearXMPGPSCoordinate Class.
ImGearXMPGPSCoordinate Constructor
Creates and initializes an instance of ImGearXMPGPSCoordinate Class.
ImGearXMPGPSCoordinate Constructor
Creates and initializes an instance of ImGearXMPGPSCoordinate Class.


ImGearXMPGPSCoordinate Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPGPSCoordinate Class.

Declaration:

public ImGearXMPGPSCoordinate()

Return Value:

New instance of ImGearXMPGPSCoordinate Class object.


ImGearXMPGPSCoordinate Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPGPSCoordinate Class, using Degree, Minute, Second and Direction.

Declaration:

public ImGearXMPGPSCoordinate(int degree, int minute, int second, ImGearXMPGPSDirection
direction);

Return Value:

New instance of ImGearXMPGPSCoordinate Class object.


ImGearXMPGPSCoordinate Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPGPSCoordinate Class, using Degree, Minute, Fraction of minute and Direction.

Declaration:

public ImGearXMPGPSCoordinate(int degree, int minute, int minuteFraction,
ImGearXMPGPSDirection direction);

Return Value:

New instance of ImGearXMPGPSCoordinate Class object.


ImGearXMPGPSCoordinate Class Properties

The ImGearXMPGPSCoordinate Class has the following properties:
Properties
Name
Description
Degree Property
Gets the Degree of GPS Coordinate.
Minute Property
Gets the Minute of GPS Coordinate.
Second Property
Gets the Second of GPS Coordinate.
MinuteFraction Property
Gets the Fraction of minute of GPS Coordinate.
Direction Property
Gets the Direction of GPS Coordinate.


Degree Property

32-bit
64-bit
CF
P
P
P

Description:

Gets the Degree of GPS Coordinate.

Declaration:

public ImGearXMPInteger Degree {get; }

Value:

ImGearXMPInteger Class value.


Minute Property

32-bit
64-bit
CF
P
P
P

Description:

Gets the Minute of GPS Coordinate.

Declaration:

public ImGearXMPInteger Minute {get; }

Value:

ImGearXMPInteger Class value.


Second Property

32-bit
64-bit
CF
P
P
P

Description:

Gets the Second of GPS Coordinate. If the GPS coordinate uses fraction of minutes instead of seconds, the property returns null.

Declaration:

public ImGearXMPInteger Second {get; }

Value:

ImGearXMPInteger Class value.


MinuteFraction Property

32-bit
64-bit
CF
P
P
P

Description:

Gets the Fraction of minute of GPS Coordinate. If the GPS coordinate seconds instead of fraction of minutes, the property returns null.

Declaration:

public ImGearXMPInteger MinuteFraction {get; }

Value:

ImGearXMPInteger Class value.


Direction Property

32-bit
64-bit
CF
P
P
P

Description:

Gets the Direction of GPS Coordinate.

Declaration:

public ImGearXMPEnum<ImGearXMPGPSDirection> Direction {get; set;}

Value:

ImGearXMPEnum Generic Class<ImGearXMPGPSDirection> value.


ImGearXMPOECFSFR Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an XMP OECFSFR (Opto-Electronic Conversion Function / Spatial Frequancy Response) structure.

Declaration:

public class ImGearXMPOECFSFR : ImGearXMPStructure

Members:

Constructors
Name
Description
ImGearXMPOECFSFR Constructor
Creates and initializes an instance of ImGearXMPOECFSFR Class.

Properties
Name
Description
Columns Property
Accesses the Columns field.
Rows Property
Accesses the Rows field.
Names Property
Accesses the Names field.
Values Property
Accesses the Values field.


ImGearXMPOECFSFR Class Constructors

The ImGearXMPOECFSFR Class has the following constructors:
Constructors
Name
Description
ImGearXMPOECFSFR Constructor
Creates and initializes an instance of ImGearXMPOECFSFR Class.


ImGearXMPOECFSFR Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPOECFSFR Class.

Declaration:

public ImGearXMPOECFSFR()

Return Value:

New instance of ImGearXMPOECFSFR Class object.


ImGearXMPOECFSFR Class Properties

The ImGearXMPOECFSFR Class has the following properties:
Properties
Name
Description
Columns Property
Accesses the Columns field.
Rows Property
Accesses the Rows field.
Names Property
Accesses the Names field.
Values Property
Accesses the Values field.


Columns Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the number of columns.

Declaration:

public ImGearXMPInteger Columns {get; set;}

Value:

ImGearXMPInteger Class value.


Rows Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the number of rows.

Declaration:

public ImGearXMPInteger Rows {get; set;}

Value:

ImGearXMPInteger Class value.


Names Property

32-bit
64-bit
CF
P
P
P

Description:

This property represents column item names.

Declaration:

public ImGearXMPSeq<ImGearXMPString> Names {get; set;}

Value:

ImGearXMPString Class value.


Values Property

32-bit
64-bit
CF
P
P
P

Description:

This property represents OECF/SFR values, ordered as follows:

value [0,0]
...
value [n - 1, 0]
value [0, m - 1]
...
value [n - 1, m - 1]

where n is number of columns, and m is number of rows.

Declaration:

public ImGearXMPSeq<ImGearXMPRational> Values {get; set;}

Value:

ImGearXMPSeq<ImGearXMPRational Class> value.


ImageGear.Formats.XMP.EXIF Enumerations

The ImageGear.Formats.XMP.EXIF Namespace has the following enumerations:

Enumerations:
Name
Description
ImGearXMPGPSDirection Enumeration
Represents GPS directions, used in the EXIF XMP schema.


ImGearXMPGPSDirection Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents GPS directions, used in the EXIF XMP schema.

Declaration:

public enum ImGearXMPGPSDirection

Members:

Name
Description
East
East direction
North
North direction
South
South direction
West
West direction


ImageGear.Formats.XMP.EXIFAux Namespace

ImageGear.Formats.XMP.EXIFAux Namespace

32-bit
64-bit
CF
P
P
P

Description:

This namespace provides the API for XMP.EXIFAux format.

Declaration:

namespace ImageGear.Formats.XMP.EXIFAux

Members:

Classes:
Name
Description
ImGearEXIFAuxXMPMetadata Class
Provides simplified access to EXIFAux XMP metadata schema.

See Also:

ImageGear.Formats.XMP Namespace

ImageGear.Formats.XMP.AdobePDF Namespace

ImageGear.Formats.XMP.Basic Namespace

ImageGear.Formats.XMP.BasicJobTicket Namespace

ImageGear.Formats.XMP.CameraRaw Namespace

ImageGear.Formats.XMP.DublinCore Namespace

ImageGear.Formats.XMP.DynamicMedia Namespace

ImageGear.Formats.XMP.EXIF Namespace

ImageGear.Formats.XMP.EXIFAux Namespace

ImageGear.Formats.XMP.IPTC4XMPCore Namespace

ImageGear.Formats.XMP.MediaManagement Namespace

ImageGear.Formats.XMP.MicrosoftPhoto Namespace

ImageGear.Formats.XMP.PagedText Namespace

ImageGear.Formats.XMP.Photoshop Namespace

ImageGear.Formats.XMP.RightsManagement Namespace

ImageGear.Formats.XMP.TIFF Namespace


ImageGear.Formats.XMP.EXIFAux Classes

The ImageGear.Formats.XMP.EXIFAux Namespace has the following class members:

Classes:
Name
Description
ImGearEXIFAuxXMPMetadata Class
Provides simplified access to EXIFAux XMP metadata schema.


ImGearEXIFAuxXMPMetadata Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides simplified access to EXIFAux XMP metadata schema. It includes additional properties that describe the equipment used to produce EXIF data.

Declaration:

public class ImGearEXIFAuxXMPMetadata : ImageGear.Formats.ImGearXMPFormatMetadata

Members:

Constructors
Name
Description
ImGearEXIFAuxXMPMetadata Constructor
Creates and initializes an instance of ImGearEXIFAuxXMPMetadata Class.

Properties
Name
Description
Lens Property
Accesses Lens property of the EXIF Aux XMP schema.
SerialNumber Property
Accesses SerialNumber property of the EXIF Aux XMP schema.


ImGearEXIFAuxXMPMetadata Class Constructors

The ImGearEXIFAuxXMPMetadata Class has the following constructors:
Constructors
Name
Description
ImGearEXIFAuxXMPMetadata Constructor
Creates and initializes an instance of ImGearEXIFAuxXMPMetadata Class.


ImGearEXIFAuxXMPMetadata Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearEXIFAuxXMPMetadata Class.

Declaration:

public ImGearEXIFAuxXMPMetadata ()

Return Value:

New instance of ImGearEXIFAuxXMPMetadata Class object.


ImGearEXIFAuxXMPMetadata Class Properties

The ImGearEXIFAuxXMPMetadata Class has the following properties:
Properties
Name
Description
Lens Property
Accesses Lens property of the EXIF Aux XMP schema.
SerialNumber Property
Accesses SerialNumber property of the EXIF Aux XMP schema.


Lens Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Lens property of the EXIF Aux XMP schema. This XMP property represents description of the lens used to take the photograph. For example, "70-200 mm f/2.8-4.0".

Declaration:

public ImGearXMPString Lens {get; set;}

Value:

ImGearXMPString Class value.


SerialNumber Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses SerialNumber property of the EXIF Aux XMP schema. This XMP property represents serial number of the camera or camera body used to take the photograph.

Declaration:

public ImGearXMPString SerialNumber {get; set;}

Value:

ImGearXMPString Class value.


ImageGear.Formats.XMP.IPTC4XMPCore Namespace

ImageGear.Formats.XMP.IPTC4XMPCore Namespace

32-bit
64-bit
CF
P
P
P

Description:

This namespace provides the API for XMP.IPTC4XMPCore format.

Declaration:

namespace ImageGear.Formats.XMP.IPTC4XMPCore

Members:

Classes:
Name
Description
ImGearIPTC4XMPCoreXMPMetadata Class
Provides simplified access to IPTC4XMPCore XMP metadata schema.
ImGearXMPContactInfo Class
Represents an XMP ContactInfo structure.

See Also:

ImageGear.Formats.XMP Namespace

ImageGear.Formats.XMP.AdobePDF Namespace

ImageGear.Formats.XMP.Basic Namespace

ImageGear.Formats.XMP.BasicJobTicket Namespace

ImageGear.Formats.XMP.CameraRaw Namespace

ImageGear.Formats.XMP.DublinCore Namespace

ImageGear.Formats.XMP.DynamicMedia Namespace

ImageGear.Formats.XMP.EXIF Namespace

ImageGear.Formats.XMP.EXIFAux Namespace

ImageGear.Formats.XMP.IPTC4XMPCore Namespace

ImageGear.Formats.XMP.MediaManagement Namespace

ImageGear.Formats.XMP.MicrosoftPhoto Namespace

ImageGear.Formats.XMP.PagedText Namespace

ImageGear.Formats.XMP.Photoshop Namespace

ImageGear.Formats.XMP.RightsManagement Namespace

ImageGear.Formats.XMP.TIFF Namespace


ImageGear.Formats.XMP.IPTC4XMPCore Classes

The ImageGear.Formats.XMP.IPTC4XMPCore Namespace has the following class members:

Classes:
Name
Description
ImGearIPTC4XMPCoreXMPMetadata Class
Provides simplified access to IPTC4XMPCore XMP metadata schema.
ImGearXMPContactInfo Class
Represents an XMP ContactInfo structure.


ImGearIPTC4XMPCoreXMPMetadata Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides simplified access to IPTC4XMPCore XMP metadata schema. It includes additional properties that describe the equipment used to produce EXIF data.

Declaration:

public class ImGearIPTC4XMPCoreXMPMetadata : ImageGear.Formats.ImGearXMPFormatMetadata

Members:

Constructors
Name
Description
ImGearIPTC4XMPCoreXMPMetadata Constructor
Creates and initializes an instance of ImGearIPTC4XMPCoreXMPMetadata Class.

Properties
Name
Description
CountryCode Property
Accesses CountryCode property of the IPTC4XMPCore XMP schema.
CreatorContactInfo Property
Accesses CreatorContactInfo property of the IPTC4XMPCore XMP schema.
IntellectualGenre Property
Accesses IntellectualGenre property of the IPTC4XMPCore XMP schema.
Location Property
Accesses Location property of the IPTC4XMPCore XMP schema.
Scene Property
Accesses Scene property of the IPTC4XMPCore XMP schema.
SubjectCode Property
Accesses SubjectCode property of the IPTC4XMPCore XMP schema.


ImGearIPTC4XMPCoreXMPMetadata Class Constructors

The ImGearIPTC4XMPCoreXMPMetadata Class has the following constructors:
Constructors
Name
Description
ImGearIPTC4XMPCoreXMPMetadata Constructor
Creates and initializes an instance of ImGearIPTC4XMPCoreXMPMetadata Class.


ImGearIPTC4XMPCoreXMPMetadata Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearIPTC4XMPCoreXMPMetadata Class.

Declaration:

public ImGearIPTC4XMPCoreXMPMetadata ()

Return Value:

New instance of ImGearIPTC4XMPCoreXMPMetadata Class object.


ImGearIPTC4XMPCoreXMPMetadata Class Properties

The ImGearIPTC4XMPCoreXMPMetadata Class has the following properties:
Properties
Name
Description
CountryCode Property
Accesses CountryCode property of the IPTC4XMPCore XMP schema.
CreatorContactInfo Property
Accesses CreatorContactInfo property of the IPTC4XMPCore XMP schema.
IntellectualGenre Property
Accesses IntellectualGenre property of the IPTC4XMPCore XMP schema.
Location Property
Accesses Location property of the IPTC4XMPCore XMP schema.
Scene Property
Accesses Scene property of the IPTC4XMPCore XMP schema.
SubjectCode Property
Accesses SubjectCode property of the IPTC4XMPCore XMP schema.


CountryCode Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses CountryCode property of the IPTC4XMPCORE XMP schema. This XMP property specifies the code of the country the content is focussing on -- either the country shown in visual media or referenced in text or audio media. This element is at the top/first level of a top-down geographical hierarchy. The code should be taken from ISO 3166 two or three letter code.

Declaration:

public ImGearXMPString CountryCode {get; set;}

Value:

ImGearXMPString Class value.


CreatorContactInfo Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses CreatorContactInfo property of the IPTC4XMPCORE XMP schema. This XMP property provides all necessary information to get in contact with the creator of this news object and comprises a set of sub-properties for proper addressing.

Declaration:

public ImGearXMPContactInfo CreatorContactInfo {get; set;}

Value:

ImGearXMPContactInfo Class value.


IntellectualGenre Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses IntellectualGenre property of the IPTC4XMPCORE XMP schema. This XMP property describes the nature, intellectual or journalistic characteristic of a news object, not specifically its content.

Declaration:

public ImGearXMPString IntellectualGenre {get; set;}

Value:

ImGearXMPString Class value.


Location Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Location property of the IPTC4XMPCORE XMP schema. This XMP property specifies the name of a location the content is focussing on -- either the location shown in visual media or referenced by text or audio media. This location name could either be the name of a sublocation to a city or the name of a well known location or (natural) monument outside a city. In the sense of a sublocation to a city this element is at the fourth level of a top-down geographical hierarchy.

Declaration:

public ImGearXMPString Location {get; set;}

Value:

ImGearXMPString Class value.


Scene Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Scene property of the IPTC4XMPCORE XMP schema. This XMP property describes the scene of a photo content. Specifies one ore more terms from the IPTC "Scene-NewsCodes". Each Scene is represented as a string of 6 digits in an unordered list.

Declaration:

public ImGearXMPBag<ImGearXMPString> Scene {get; set;}

Value:

ImGearXMPBag<ImGearXMPString Class> value.


SubjectCode Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses SubjectCode property of the IPTC4XMPCORE XMP schema. This XMP property specifies one or more Subjects from the IPTC "Subject-NewsCodes" taxonomy to categorize the content. Each Subject is represented as a string of 8 digits in an unordered list.

Declaration:

public ImgearXMPBag<ImGearXMPString> SubjectCode {get; set;}

Value:

ImGearXMPString Class value.


ImGearXMPContactInfo Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an XMP ContactInfo structure. This structure provides a basic set of information to get in contact with a person.

Declaration:

public class ImGearXMPContactInfo : ImGearXMPStructure

Members:

Constructors
Name
Description
ImGearXMPContactInfo Constructor
Creates and initializes an instance of ImGearXMPContactInfo Class.

Properties
Name
Description
CiAdrCity Property
Accesses the CiAdrCity field.
CiAdrCtry Property
Accesses the CiAdrCtry field.
CiAdrExtadr Property
Accesses the CiAdrExtadr field.
CiAdrPcode Property
Accesses the CiAdrPcode field.
CiAdrRegion Property
Accesses the CiAdrRegion field.
CiEmailWork Property
Accesses the CiEmailWork field.
CiTelWork Property
Accesses the CiTelWork field.
CiUrlWork Property
Accesses the CiUrlWork field.


ImGearXMPContactInfo Class Constructors

The ImGearXMPContactInfo Class has the following constructors:
Constructors
Name
Description
ImGearXMPContactInfo Constructor
Creates and initializes an instance of ImGearXMPContactInfo Class.


ImGearXMPContactInfo Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPContactInfo Class.

Declaration:

public ImGearXMPContactInfo()

Return Value:

New instance of ImGearXMPContactInfo Class object.


ImGearXMPContactInfo Class Properties

The ImGearXMPContactInfo Class has the following properties:
Properties
Name
Description
CiAdrCity Property
Accesses the CiAdrCity field.
CiAdrCtry Property
Accesses the CiAdrCtry field.
CiAdrExtadr Property
Accesses the CiAdrExtadr field.
CiAdrPcode Property
Accesses the CiAdrPcode field.
CiAdrRegion Property
Accesses the CiAdrRegion field.
CiEmailWork Property
Accesses the CiEmailWork field.
CiTelWork Property
Accesses the CiTelWork field.
CiUrlWork Property
Accesses the CiUrlWork field.


CiAdrCity Property

32-bit
64-bit
CF
P
P
P

Description:

This property represents the contact information city part.

Declaration:

public ImGearXMPString CiAdrCity {get; set;}

Value:

ImGearXMPString Class value.


CiAdrCtry Property

32-bit
64-bit
CF
P
P
P

Description:

This property represents the the contact information county part.

Declaration:

public ImGearXMPString CiAdrCtry {get; set;}

Value:

ImGearXMPString Class value.


CiAdrExtadr Property

32-bit
64-bit
CF
P
P
P

Description:

This property represents the contact information address part. It comprises an optional company name and all required information to locate the building or postbox to which mail should be sent. To that end, the address is a multiline field.

Declaration:

public ImGearXMPString CiAdrExtadr {get; set;}

Value:

ImGearXMPString Class value.


CiAdrPcode Property

32-bit
64-bit
CF
P
P
P

Description:

This property represents the contact information part denoting the local postal code.

Declaration:

public ImGearXMPString CiAdrPcode {get; set;}

Value:

ImGearXMPString Class value.


CiAdrRegion Property

32-bit
64-bit
CF
P
P
P

Description:

This property represents the contact information part denoting regional information like state or province.

Declaration:

public ImGearXMPString CiAdrRegion {get; set;}

Value:

ImGearXMPString Class value.


CiEmailWork Property

32-bit
64-bit
CF
P
P
P

Description:

This property represents the contact information email address part. Multiple email addresses can be given, separated by a comma.

Declaration:

public ImGearXMPString CiEmailWork {get; set;}

Value:

ImGearXMPString Class value.


CiTelWork Property

32-bit
64-bit
CF
P
P
P

Description:

This property represents the contact information phone number part. Multiple numbers can be given, separated by a comma.

Declaration:

public ImGearXMPString CiTelWork {get; set;}

Value:

ImGearXMPString Class value.


CiUrlWork Property

32-bit
64-bit
CF
P
P
P

Description:

This property represents the contact information web address part. Multiple addresses can be given, separated by a comma.

Declaration:

public ImGearXMPString CiUrlWork {get; set;}

Value:

ImGearXMPString Class value.


ImageGear.Formats.XMP.MediaManagement Namespace

ImageGear.Formats.XMP.MediaManagement Namespace

32-bit
64-bit
CF
P
P
P

Description:

This namespace provides the API for XMP.MediaManagement format.

Declaration:

namespace ImageGear.Formats.XMP.MediaManagement

Members:

Classes:
Name
Description
ImGearMediaManagementXMPMetadata Class
Provides simplified access to XMP Media Management metadata schema.
ImGearXMPResourceEvent Class
Represents an XMP ResourceEvent structure.
ImGearXMPResourceRef Class
Represents an XMP ResourceRef structure.
ImGearXMPVersion Class
Represents an XMP Version structure.

See Also:

ImageGear.Formats.XMP Namespace

ImageGear.Formats.XMP.AdobePDF Namespace

ImageGear.Formats.XMP.Basic Namespace

ImageGear.Formats.XMP.BasicJobTicket Namespace

ImageGear.Formats.XMP.CameraRaw Namespace

ImageGear.Formats.XMP.DublinCore Namespace

ImageGear.Formats.XMP.DynamicMedia Namespace

ImageGear.Formats.XMP.EXIF Namespace

ImageGear.Formats.XMP.EXIFAux Namespace

ImageGear.Formats.XMP.IPTC4XMPCore Namespace

ImageGear.Formats.XMP.MediaManagement Namespace

ImageGear.Formats.XMP.MicrosoftPhoto Namespace

ImageGear.Formats.XMP.PagedText Namespace

ImageGear.Formats.XMP.Photoshop Namespace

ImageGear.Formats.XMP.RightsManagement Namespace

ImageGear.Formats.XMP.TIFF Namespace


ImageGear.Formats.XMP.MediaManagement Classes

The ImageGear.Formats.XMP.MediaManagement Namespace has the following class members:

Classes:
Name
Description
ImGearMediaManagementXMPMetadata Class
Provides simplified access to XMP Media Management metadata schema.
ImGearXMPResourceEvent Class
Represents an XMP ResourceEvent structure.
ImGearXMPResourceRef Class
Represents an XMP ResourceRef structure.
ImGearXMPVersion Class
Represents an XMP Version structure.


ImGearMediaManagementXMPMetadata Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides simplified access to XMP Media Management metadata schema. This schema is primarily used by digital asset management (DAM) systems.

The following properties are "owned" by the DAM system and should be set by applications under their direction; they should not be used by unmanaged files: ManagedFrom, Manager, ManageTo, ManageUI, ManagerVariant.

The following properties are owned by the DAM system for managed files, but can also be used by applications for unmanaged files: DerivedFrom, DocumentID, RenditionClass, RenditionParams, VersionID, Versions.

The History property is always owned by the application.

Declaration:

public class ImGearMediaManagementXMPMetadata : ImageGear.Formats.ImGearXMPFormatMetadata

Members:

Constructors
Name
Description
ImGearMediaManagementXMPMetadata Constructor
Creates and initializes an instance of ImGearMediaManagementXMPMetadata Class.

Properties
Name
Description
DerivedFrom Property
Accesses DerivedFrom property of the Media Management schema.
DocumentID Property
Accesses DocumentID property of the Media Management schema.
History Property
Accesses History property of the Media Management schema.
InstanceID Property
Accesses InstanceID property of the Media Management schema.
ManagedFrom Property
Accesses ManagedFrom property of the Media Management schema.
Manager Property
Accesses Manager property of the Media Management schema.
ManageTo Property
Accesses ManageTo property of the Media Management schema.
ManageUI Property
Accesses ManageUI property of the Media Management schema.
ManagerVariant Property
Accesses ManagerVariant property of the Media Management schema.
RenditionClass Property
Accesses RenditionClass property of the Media Management schema.
RenditionParams Property
Accesses RenditionParams property of the Media Management schema.
VersionID Property
Accesses VersionID property of the Media Management schema.
Versions Property
Accesses Versions property of the Media Management schema.


ImGearMediaManagementXMPMetadata Class Constructors

The ImGearMediaManagementXMPMetadata Class has the following constructors:
Constructors
Name
Description
ImGearMediaManagementXMPMetadata Constructor
Creates and initializes an instance of ImGearMediaManagementXMPMetadata Class.


ImGearMediaManagementXMPMetadata Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearMediaManagementXMPMetadata Class.

Declaration:

public ImGearMediaManagementXMPMetadata ()

Return Value:

New instance of ImGearMediaManagementXMPMetadata Class object.


ImGearMediaManagementXMPMetadata Class Properties

The ImGearMediaManagementXMPMetadata Class has the following properties:
Properties
Name
Description
DerivedFrom Property
Accesses DerivedFrom property of the Media Management schema.
DocumentID Property
Accesses DocumentID property of the Media Management schema.
History Property
Accesses History property of the Media Management schema.
InstanceID Property
Accesses InstanceID property of the Media Management schema.
ManagedFrom Property
Accesses ManagedFrom property of the Media Management schema.
Manager Property
Accesses Manager property of the Media Management schema.
ManageTo Property
Accesses ManageTo property of the Media Management schema.
ManageUI Property
Accesses ManageUI property of the Media Management schema.
ManagerVariant Property
Accesses ManagerVariant property of the Media Management schema.
RenditionClass Property
Accesses RenditionClass property of the Media Management schema.
RenditionParams Property
Accesses RenditionParams property of the Media Management schema.
VersionID Property
Accesses VersionID property of the Media Management schema.
Versions Property
Accesses Versions property of the Media Management schema.


DerivedFrom Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses DerivedFrom property of the Media Management XMP schema. It specifies reference to the original document from which this one is derived.

Declaration:

public ImGearXMPResourceRef DerivedFrom {get; set;}

Value:

ImGearXMPResourceRef Class value.


DocumentID Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses DocumentID property of the Media Management XMP schema. It specifies common identifier for all versions and renditions of a document.

Declaration:

public ImGearXMPString DocumentID {get; set;}

Value:

ImGearXMPString Class value.


History Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses History property of the Media Management XMP schema. It specifies ordered array of high-level user actions that resulted in this resource.

Declaration:

public ImGearXMPSeq<ImGearXMPResourceEvent> History {get; set;}

Value:

ImGearXMPSeq<ImGearXMPResourceEvent Class> value.


InstanceID Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses InstanceID property of the Media Management XMP schema. It specifies identifier for a specific incarnation of a document, updated each time a file is saved.

Declaration:

public ImGearXMPString InstanceID {get; set;}

Value:

ImGearXMPString Class value.


ManagedFrom Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ManagedFrom property of the Media Management XMP schema. It specifies reference to the document as it was prior to becoming managed.

Declaration:

public ImGearXMPResourceRef ManagedFrom {get; set;}

Value:

ImGearXMPResourceRef Class value.


Manager Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Manager property of the Media Management XMP schema. It specifies name of the asset management system that manages this resource. The suggested convention is "vendor app version"-for example "Adobe Acrobat Distiller 5.0".

Declaration:

public ImGearXMPString Class Manager {get; set;}

Value:

ImGearXMPString Class value.


ManageTo Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ManageTo property of the Media Management XMP schema. It specifies uRI identifying the managed resource to the asset management system; the presence of this property is the formal indication that this resource is managed. The form and content of this URI is private to the asset management system.

Declaration:

public ImGearXMPString ManageTo {get; set;}

Value:

ImGearXMPString Class value.


ManageUI Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ManageUI property of the Media Management XMP schema. It specifies uRI that can be used to access information about the managed resource through a web browser. It might require a custom browser plugin.

Declaration:

public ImGearXMPString ManageUI {get; set;}

Value:

ImGearXMPString Class value.


ManagerVariant Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ManagerVariant property of the Media Management XMP schema. It specifies a particular variant of the asset management system. The format of this property is private to the specific asset management system.

Declaration:

public ImGearXMPString ManagerVariant {get; set;}

Value:

ImGearXMPString Class value.


RenditionClass Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses RenditionClass property of the Media Management XMP schema. It specifies rendition class name for this resource. See XMP specification for more details regarding this property.

Declaration:

public ImGearXMPString RenditionClass {get; set;}

Value:

ImGearXMPString Class value.


RenditionParams Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses RenditionParams property of the Media Management XMP schema. It is used to provide additional rendition parameters that are too complex or verbose to encode in RenditionClass.

Declaration:

public ImGearXMPString RenditionParams {get; set;}

Value:

ImGearXMPString Class value.


VersionID Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses VersionID property of the Media Management XMP schema. It specifies document version identifier for this resource.

Declaration:

public ImGearXMPString VersionID {get; set;}

Value:

ImGearXMPString Class value.


Versions Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Versions property of the Media Management XMP schema. It specifies version history associated with this resource. First entry is the oldest known version for this document, last entry is the most recent version.

Declaration:

public ImGearXMPSeq<ImGearXMPVersion> Versions {get; set;}

Value:

ImGearXMPSeq<ImGearXMPVersion Class> value.


ImGearXMPResourceEvent Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an XMP ResourceEvent structure. The structure specifies a high level event that occured in the processing of this document.

Declaration:

public class ImGearXMPResourceEvent : ImGearXMPStructure

Members:

Constructors
Name
Description
ImGearXMPResourceEvent Constructor
Creates and initializes an instance of ImGearXMPResourceEvent Class.

Properties
Name
Description
Action Property
Accesses the Action field.
InstanceID Property
Accesses the InstanceID field.
Parameters Property
Accesses the Parameters field.
SoftwareAgent Property
Accesses the SoftwareAgent field.
When Property
Accesses the When field.


ImGearXMPResourceEvent Class Constructors

The ImGearXMPResourceEvent Class has the following constructors:
Constructors
Name
Description
ImGearXMPResourceEvent Constructor
Creates and initializes an instance of ImGearXMPResourceEvent Class.


ImGearXMPResourceEvent Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPResourceEvent Class.

Declaration:

public ImGearXMPResourceEvent()

Return Value:

New instance of ImGearXMPResourceEvent Class object.


ImGearXMPResourceEvent Class Properties

The ImGearXMPResourceEvent Class has the following properties:
Properties
Name
Description
Action Property
Accesses the Action field.
InstanceID Property
Accesses the InstanceID field.
Parameters Property
Accesses the Parameters field.
SoftwareAgent Property
Accesses the SoftwareAgent field.
When Property
Accesses the When field.


Action Property

32-bit
64-bit
CF
P
P
P

Description:

The action that occurred. See XMP specification for defined values and usage details.

Declaration:

public ImGearXMPString Action {get; set;}

Value:

ImGearXMPString Class value.


InstanceID Property

32-bit
64-bit
CF
P
P
P

Description:

The instance ID of the modified resource.

Declaration:

public ImGearXMPString InstanceID {get; set;}

Value:

ImGearXMPString Class value.


Parameters Property

32-bit
64-bit
CF
P
P
P

Description:

Additional description of the action.

Declaration:

public ImGearXMPString Parameters {get; set;}

Value:

ImGearXMPString Class value.


SoftwareAgent Property

32-bit
64-bit
CF
P
P
P

Description:

The software agent that performed the action.

Declaration:

public ImGearXMPString SoftwareAgent {get; set;}

Value:

ImGearXMPString Class value.


When Property

32-bit
64-bit
CF
P
P
P

Description:

Optional timestamp of when the action occurred.

Declaration:

public ImGearXMPDate When {get; set;}

Value:

ImGearXMPDate Class value.


ImGearXMPResourceRef Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an XMP ResourceRef structure. The fields present in any specific reference depend on usage and on whether the referenced resource is managed. Except for instanceID, the fields are all properties from the referenced resource's Media Management schema.

Declaration:

public class ImGearXMPResourceRef : ImGearXMPStructure

Members:

Constructors
Name
Description
ImGearXMPResourceRef Constructor
Creates and initializes an instance of ImGearXMPResourceRef Class.

Properties
Name
Description
InstanceID Property
Accesses the InstanceID field.
DocumentID Property
Accesses the DocumentID field.
VersionID Property
Accesses the VersionID field.
RenditionClass Property
Accesses the RenditionClass field.
RenditionParams Property
Accesses the RenditionParams field.
Manager Property
Accesses the Manager field.
ManagerVariant Property
Accesses the ManagerVariant field.
ManageTo Property
Accesses the ManageTo field.
ManageUI Property
Accesses the ManageUI field.


ImGearXMPResourceRef Class Constructors

The ImGearXMPResourceRef Class has the following constructors:
Constructors
Name
Description
ImGearXMPResourceRef Constructor
Creates and initializes an instance of ImGearXMPResourceRef Class.


ImGearXMPResourceRef Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPResourceRef Class.

Declaration:

public ImGearXMPResourceRef()

Return Value:

New instance of ImGearXMPResourceRef Class object.


ImGearXMPResourceRef Class Properties

The ImGearXMPResourceRef Class has the following properties:
Properties
Name
Description
InstanceID Property
Accesses the InstanceID field.
DocumentID Property
Accesses the DocumentID field.
VersionID Property
Accesses the VersionID field.
RenditionClass Property
Accesses the RenditionClass field.
RenditionParams Property
Accesses the RenditionParams field.
Manager Property
Accesses the Manager field.
ManagerVariant Property
Accesses the ManagerVariant field.
ManageTo Property
Accesses the ManageTo field.
ManageUI Property
Accesses the ManageUI field.


InstanceID Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the referenced resource's instance ID.

Declaration:

public ImGearXMPString InstanceID {get; set;}

Value:

ImGearXMPString Class value.


DocumentID Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the referenced resource's xmpMM:DocumentID.

Declaration:

public ImGearXMPString DocumentID {get; set;}

Value:

ImGearXMPString Class value.


VersionID Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the referenced resource's xmpMM:VersionID.

Declaration:

public ImGearXMPString VersionID {get; set;}

Value:

ImGearXMPString Class value.


RenditionClass Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the referenced resource's xmpMM: RenditionClass.

Declaration:

public ImGearXMPString RenditionClass {get; set;}

Value:

ImGearXMPString Class value.


RenditionParams Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the referenced resource's xmpMM: RenditionParams.

Declaration:

public ImGearXMPString RenditionParams {get; set;}

Value:

ImGearXMPString Class value.


Manager Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the referenced resource's xmpMM:Manager.

Declaration:

public ImGearXMPString Manager {get; set;}

Value:

ImGearXMPString Class value.


ManagerVariant Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the referenced resource's xmpMM: ManagerVariant.

Declaration:

public ImGearXMPString ManagerVariant {get; set;}

Value:

ImGearXMPString Class value.


ManageTo Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the referenced resource's xmpMM:ManageTo.

Declaration:

public ImGearXMPString ManageTo {get; set;}

Value:

ImGearXMPString Class value.


ManageUI Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the referenced resource's xmpMM:ManageUI.

Declaration:

public ImGearXMPString ManageUI {get; set;}

Value:

ImGearXMPString Class value.


ImGearXMPVersion Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents an XMP Version structure. The structure describes one version of a document.

Declaration:

public class ImGearXMPVersion : ImGearXMPStructure

Members:

Constructor
Name
Description
ImGearXMPVersion Constructor
Creates and initializes an instance of ImGearXMPVersion Class.
Properties
Name
Description
Comments Property
Accesses the Comments field.
Event Property
Accesses the Event field.
ModifyDate Property
Accesses the ModifyDate field.
Modifier Property
Accesses the Modifier field.
Version Property
Accesses the Version field.


ImGearXMPVersion Class Constructors

The ImGearXMPVersion Class has the following constructors:
Constructor
Name
Description
ImGearXMPVersion Constructor
Creates and initializes an instance of ImGearXMPVersion Class.


ImGearXMPVersion Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearXMPVersion Class.

Declaration:

public ImGearXMPVersion()

Return Value:

New instance of ImGearXMPVersion Class object.


ImGearXMPVersion Class Properties

The ImGearXMPVersion Class has the following properties:
Properties
Name
Description
Comments Property
Accesses the Comments field.
Event Property
Accesses the Event field.
ModifyDate Property
Accesses the ModifyDate field.
Modifier Property
Accesses the Modifier field.
Version Property
Accesses the Version field.


Comments Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies comments concerning what was changed.

Declaration:

public ImGearXMPString Ñomments {get; set;}

Value:

ImGearXMPString Class value.


Event Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies high level, formal description of what operation the user performed.

Declaration:

public ImGearXMPResourceEvent Event {get; set;}

Value:

ImGearXMPResourceEvent Class value.


ModifyDate Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the date on which this version was checked in.

Declaration:

public ImGearXMPDate ModifyDate {get; set;}

Value:

ImGearXMPDate Class value.


Modifier Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the person who modified this version.

Declaration:

public ImGearXMPString Modifier {get; set;}

Value:

ImGearXMPString Class value.


Version Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the new version number.

Declaration:

public ImGearXMPString Version {get; set;}

Value:

ImGearXMPString Class value.


ImageGear.Formats.XMP.MicrosoftPhoto Namespace

ImageGear.Formats.XMP.MicrosoftPhoto Namespace

32-bit
64-bit
CF
P
P
P

Description:

This namespace provides the API for XMP.MicrosoftPhoto format.

Declaration:

namespace ImageGear.Formats.XMP.MicrosoftPhoto

Members:

Classes:
Name
Description
ImGearMicrosoftPhotoXMPMetadata Class
Provides simplified access to MicrosoftPhoto XMP metadata schema.

See Also:

ImageGear.Formats.XMP Namespace

ImageGear.Formats.XMP.AdobePDF Namespace

ImageGear.Formats.XMP.Basic Namespace

ImageGear.Formats.XMP.BasicJobTicket Namespace

ImageGear.Formats.XMP.CameraRaw Namespace

ImageGear.Formats.XMP.DublinCore Namespace

ImageGear.Formats.XMP.DynamicMedia Namespace

ImageGear.Formats.XMP.EXIF Namespace

ImageGear.Formats.XMP.EXIFAux Namespace

ImageGear.Formats.XMP.IPTC4XMPCore Namespace

ImageGear.Formats.XMP.MediaManagement Namespace

ImageGear.Formats.XMP.MicrosoftPhoto Namespace

ImageGear.Formats.XMP.PagedText Namespace

ImageGear.Formats.XMP.Photoshop Namespace

ImageGear.Formats.XMP.RightsManagement Namespace

ImageGear.Formats.XMP.TIFF Namespace


ImageGear.Formats.XMP.MicrosoftPhoto Classes

The ImageGear.Formats.XMP.MicrosoftPhoto Namespace has the following class members:

Classes:
Name
Description
ImGearMicrosoftPhotoXMPMetadata Class
Provides simplified access to MicrosoftPhoto XMP metadata schema.


ImGearMicrosoftPhotoXMPMetadata Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides simplified access to MicrosoftPhoto XMP metadata schema.

Declaration:

public class ImGearMicrosoftPhotoXMPMetadata : ImageGear.Formats.ImGearXMPFormatMetadata

Members:

Constructors
Name
Description
ImGearMicrosoftPhotoXMPMetadata Constructor
Creates and initializes an instance of ImGearMicrosoftPhotoXMPMetadata Class.

Properties
Name
Description
CameraSerialNumber Property
Accesses CameraSerialNumber property of the MicrosoftPhoto XMP schema.
DateAcquired Property
Accesses DateAcquired property of the MicrosoftPhoto XMP schema.
FlashManufacturer Property
Accesses FlashManufacturer property of the MicrosoftPhoto XMP schema.
FlashModel Property
Accesses FlashModel property of the MicrosoftPhoto XMP schema.
LastKeywordIPTC Property
Accesses LastKeywordIPTC property of the MicrosoftPhoto XMP schema.
LastKeywordXMP Property
Accesses LastKeywordXMP property of the MicrosoftPhoto XMP schema.
LensManufacturer Property
Accesses LensManufacturer property of the MicrosoftPhoto XMP schema.
LensModel Property
Accesses LensModel property of the MicrosoftPhoto XMP schema.
Rating Property
Accesses Rating property of the MicrosoftPhoto XMP schema.


ImGearMicrosoftPhotoXMPMetadata Class Constructors

The ImGearMicrosoftPhotoXMPMetadata Class has the following constructors:
Constructors
Name
Description
ImGearMicrosoftPhotoXMPMetadata Constructor
Creates and initializes an instance of ImGearMicrosoftPhotoXMPMetadata Class.


ImGearMicrosoftPhotoXMPMetadata Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearMicrosoftPhotoXMPMetadata Class.

Declaration:

public ImGearMicrosoftPhotoXMPMetadata ()

Return Value:

New instance of ImGearMicrosoftPhotoXMPMetadata Class object.


ImGearMicrosoftPhotoXMPMetadata Class Properties

The ImGearMicrosoftPhotoXMPMetadata Class has the following properties:
Properties
Name
Description
CameraSerialNumber Property
Accesses CameraSerialNumber property of the MicrosoftPhoto XMP schema.
DateAcquired Property
Accesses DateAcquired property of the MicrosoftPhoto XMP schema.
FlashManufacturer Property
Accesses FlashManufacturer property of the MicrosoftPhoto XMP schema.
FlashModel Property
Accesses FlashModel property of the MicrosoftPhoto XMP schema.
LastKeywordIPTC Property
Accesses LastKeywordIPTC property of the MicrosoftPhoto XMP schema.
LastKeywordXMP Property
Accesses LastKeywordXMP property of the MicrosoftPhoto XMP schema.
LensManufacturer Property
Accesses LensManufacturer property of the MicrosoftPhoto XMP schema.
LensModel Property
Accesses LensModel property of the MicrosoftPhoto XMP schema.
Rating Property
Accesses Rating property of the MicrosoftPhoto XMP schema.


CameraSerialNumber Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses CameraSerialNumber property of the MicrosoftPhoto XMP schema.

Declaration:

public ImGearXMPString CameraSerialNumber {get; set;}

Value:

ImGearXMPString Class value.


DateAcquired Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses DateAcquired property of the MicrosoftPhoto XMP schema.

Declaration:

public ImGearXMPDate DateAcquired {get; set;}

Value:

ImGearXMPDate Class value.


FlashManufacturer Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses FlashManufacturer property of the MicrosoftPhoto XMP schema.

Declaration:

public ImGearXMPString FlashManufacturer {get; set;}

Value:

ImGearXMPString Class value.


FlashModel Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses FlashModel property of the MicrosoftPhoto XMP schema.

Declaration:

public ImGearXMPString FlashModel {get; set;}

Value:

ImGearXMPString Class value.


LastKeywordIPTC Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses LastKeywordIPTC property of the MicrosoftPhoto XMP schema.

Declaration:

public ImGearXMPBag<ImGearXMPString> LastKeywordIPTC {get; set;}

Value:

ImGearXMPBag<ImGearXMPString Class> value.


LastKeywordXMP Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses LastKeywordXMP property of the MicrosoftPhoto XMP schema.

Declaration:

public ImGearXMPBag<ImGearXMPString> LastKeywordXMP {get; set;}

Value:

ImGearXMPBag<ImGearXMPString Class> value.


LensManufacturer Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses LensManufacturer property of the MicrosoftPhoto XMP schema.

Declaration:

public ImGearXMPString LensManufacturer {get; set;}

Value:

ImGearXMPString Class value.


LensModel Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses LensModel property of the MicrosoftPhoto XMP schema.

Declaration:

public ImGearXMPString LensModel {get; set;}

Value:

ImGearXMPString Class value.


Rating Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Rating property of the MicrosoftPhoto XMP schema. XMP Basic Rating values of 1,2,3,4 and 5 stars correspond to MicrosoftPhoto Rating values of 1,25,50,75 and 99 respectively.

Declaration:

public ImGearXMPInteger Rating {get; set;}

Value::

ImGearXMPInteger Class value.


ImageGear.Formats.XMP.PagedText Namespace

ImageGear.Formats.XMP.PagedText Namespace

32-bit
64-bit
CF
P
P
P

Description:

This namespace provides the API for XMP.PagedText format.

Declaration:

namespace ImageGear.Formats.XMP.PagedText

Members:

Classes:
Name
Description
ImGearPagedTextXMPMetadata Class
Provides simplified access to XMP Paged Text metadata schema.

See Also:

ImageGear.Formats.XMP Namespace

ImageGear.Formats.XMP.AdobePDF Namespace

ImageGear.Formats.XMP.Basic Namespace

ImageGear.Formats.XMP.BasicJobTicket Namespace

ImageGear.Formats.XMP.CameraRaw Namespace

ImageGear.Formats.XMP.DublinCore Namespace

ImageGear.Formats.XMP.DynamicMedia Namespace

ImageGear.Formats.XMP.MediaManagement Namespace

ImageGear.Formats.XMP.PagedText Namespace

ImageGear.Formats.XMP.Photoshop Namespace

ImageGear.Formats.XMP.RightsManagement Namespace

ImageGear.Formats.XMP.TIFF Namespace

ImageGear.Formats.XMP.EXIF Namespace

ImageGear.Formats.XMP.EXIFAux Namespace

ImageGear.Formats.XMP.IPTC4XMPCore Namespace

ImageGear.Formats.XMP.MicrosoftPhoto Namespace


ImageGear.Formats.XMP.PagedText Classes

The ImageGear.Formats.XMP.PagedText Namespace has the following class members:

Classes:
Name
Description
ImGearPagedTextXMPMetadata Class
Provides simplified access to XMP Paged Text metadata schema.


ImGearPagedTextXMPMetadata Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides simplified access to XMP Paged Text metadata schema. This schema is used for text appearing on a page in a document.

Declaration:

public class ImGearPagedTextXMPMetadata : ImageGear.Formats.ImGearXMPFormatMetadata

Members:

Constructors
Name
Description
ImGearPagedTextXMPMetadata Constructor
Creates and initializes an instance of ImGearPagedTextXMPMetadata Class.

Properties
Name
Description
MaxPageSize Property
Accesses MaxPageSize property of the Paged Text schema.
NPages Property
Accesses NPages property of the Paged Text schema.
Fonts Property
Accesses Fonts property of the Paged Text schema.
Colorants Property
Accesses Colorants property of the Paged Text schema.
PlateNames Property
Accesses PlateNames property of the Paged Text schema.


ImGearPagedTextXMPMetadata Class Constructors

The ImGearPagedTextXMPMetadata Class has the following constructors:
Constructors
Name
Description
ImGearPagedTextXMPMetadata Constructor
Creates and initializes an instance of ImGearPagedTextXMPMetadata Class.


ImGearPagedTextXMPMetadata Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearPagedTextXMPMetadata Class.

Declaration:

public ImGearPagedTextXMPMetadata ()

Return Value:

New instance of ImGearPagedTextXMPMetadata Class object.


ImGearPagedTextXMPMetadata Class Properties

The ImGearPagedTextXMPMetadata Class has the following properties:
Properties
Name
Description
MaxPageSize Property
Accesses MaxPageSize property of the Paged Text schema.
NPages Property
Accesses NPages property of the Paged Text schema.
Fonts Property
Accesses Fonts property of the Paged Text schema.
Colorants Property
Accesses Colorants property of the Paged Text schema.
PlateNames Property
Accesses PlateNames property of the Paged Text schema.


MaxPageSize Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses MaxPageSize property of the Paged Text XMP schema. This XMP property specifies size of the largest page in the document (including any in contained documents).

Declaration:

public ImGearXMPDimensions MaxPageSize {get; set;}

Value:

ImGearXMPDimensions Class value.


NPages Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses NPages property of the Paged Text XMP schema. This XMP property specifies number of pages in the document (including any in contained documents).

Declaration:

public ImGearXMPInteger NPages {get; set;}

Value:

ImGearXMPInteger Class value.


Fonts Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Fonts property of the Paged Text XMP schema. This XMP property specifies unordered array of fonts that are used in the document (including any in contained documents).

Declaration:

public ImGearXMPBag<ImGearXMPFont> Fonts {get; set;}

Value:

ImGearXMPBag<ImGearXMPFont Class> value.


Colorants Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Colorants property of the Paged Text XMP schema. This XMP property specifies ordered array of colorants (swatches) that are used in the document (including any in contained documents).

Declaration:

public ImGearXMPSeq<ImGearXMPColorant> Colorants {get; set;}

Value:

ImGearXMPSeq<ImGearXMPColorant Class> value.


PlateNames Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses PlateNames property of the Paged Text XMP schema. This XMP property specifies ordered array of plate names that are needed to print the document (including any in contained documents).

Declaration:

public ImGearXMPSeq<ImGearXMPString> PlateNames {get; set;}

Value:

ImGearXMPSeq<ImGearXMPString Class> value.


ImageGear.Formats.XMP.Photoshop Namespace

ImageGear.Formats.XMP.Photoshop Namespace

32-bit
64-bit
CF
P
P
P

Description:

This namespace provides the API for XMP.Photoshop format.

Declaration:

namespace ImageGear.Formats.XMP.Photoshop

Members:

Classes:
Name
Description
ImGearPhotoshopXMPMetadata Class
Provides simplified access to Photoshop XMP metadata schema.

See Also:

ImageGear.Formats.XMP Namespace

ImageGear.Formats.XMP.AdobePDF Namespace

ImageGear.Formats.XMP.Basic Namespace

ImageGear.Formats.XMP.BasicJobTicket Namespace

ImageGear.Formats.XMP.CameraRaw Namespace

ImageGear.Formats.XMP.DublinCore Namespace

ImageGear.Formats.XMP.DynamicMedia Namespace

ImageGear.Formats.XMP.MediaManagement Namespace

ImageGear.Formats.XMP.PagedText Namespace

ImageGear.Formats.XMP.Photoshop Namespace

ImageGear.Formats.XMP.RightsManagement Namespace

ImageGear.Formats.XMP.TIFF Namespace

ImageGear.Formats.XMP.EXIF Namespace

ImageGear.Formats.XMP.EXIFAux Namespace

ImageGear.Formats.XMP.IPTC4XMPCore Namespace

ImageGear.Formats.XMP.MicrosoftPhoto Namespace


ImageGear.Formats.XMP.Photoshop Classes

The ImageGear.Formats.XMP.Photoshop Namespace has the following class members:

Classes:
Name
Description
ImGearPhotoshopXMPMetadata Class
Provides simplified access to Photoshop XMP metadata schema.


ImGearPhotoshopXMPMetadata Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides simplified access to Photoshop XMP metadata schema. This schema specifies properties used by Adobe Photoshop.

Declaration:

public class ImGearPhotoshopXMPMetadata : ImageGear.Formats.ImGearXMPFormatMetadata

Members:

Constructors
Name
Description
ImGearPhotoshopXMPMetadata Constructor
Creates and initializes an instance of ImGearPhotoshopXMPMetadata Class.

Properties
Name
Description
AuthorsPosition Property
Accesses AuthorsPosition property of the Photoshop XMP schema.
CaptionWriter Property
Accesses CaptionWriter property of the Photoshop XMP schema.
Category Property
Accesses Category property of the Photoshop XMP schema.
City Property
Accesses City property of the Photoshop XMP schema.
Country Property
Accesses Country property of the Photoshop XMP schema.
Credit Property
Accesses Credit property of the Photoshop XMP schema.
DateCreated Property
Accesses DateCreated property of the Photoshop XMP schema.
Headline Property
Accesses Headline property of the Photoshop XMP schema.
Instructions Property
Accesses Instructions property of the Photoshop XMP schema.
Source Property
Accesses Source property of the Photoshop XMP schema.
State Property
Accesses State property of the Photoshop XMP schema.
SupplementalCategories Property
Accesses SupplementalCategories property of the Photoshop XMP schema.
TransmissionReference Property
Accesses TransmissionReference property of the Photoshop XMP schema.
Urgency Property
Accesses Urgency property of the Photoshop XMP schema.


ImGearPhotoshopXMPMetadata Class Constructors

The ImGearPhotoshopXMPMetadata Class has the following constructors:
Constructors
Name
Description
ImGearPhotoshopXMPMetadata Constructor
Creates and initializes an instance of ImGearPhotoshopXMPMetadata Class.


ImGearPhotoshopXMPMetadata Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearPhotoshopXMPMetadata Class.

Declaration:

public ImGearPhotoshopXMPMetadata ()

Return Value:

New instance of ImGearPhotoshopXMPMetadata Class object.


ImGearPhotoshopXMPMetadata Class Properties

The ImGearPhotoshopXMPMetadata Class has the following properties:
Properties
Name
Description
AuthorsPosition Property
Accesses AuthorsPosition property of the Photoshop XMP schema.
CaptionWriter Property
Accesses CaptionWriter property of the Photoshop XMP schema.
Category Property
Accesses Category property of the Photoshop XMP schema.
City Property
Accesses City property of the Photoshop XMP schema.
Country Property
Accesses Country property of the Photoshop XMP schema.
Credit Property
Accesses Credit property of the Photoshop XMP schema.
DateCreated Property
Accesses DateCreated property of the Photoshop XMP schema.
Headline Property
Accesses Headline property of the Photoshop XMP schema.
Instructions Property
Accesses Instructions property of the Photoshop XMP schema.
Source Property
Accesses Source property of the Photoshop XMP schema.
State Property
Accesses State property of the Photoshop XMP schema.
SupplementalCategories Property
Accesses SupplementalCategories property of the Photoshop XMP schema.
TransmissionReference Property
Accesses TransmissionReference property of the Photoshop XMP schema.
Urgency Property
Accesses Urgency property of the Photoshop XMP schema.


AuthorsPosition Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses AuthorsPosition property of the Photoshop XMP schema. This XMP property specifies by-line title.

Declaration:

public ImGearXMPString AuthorsPosition {get; set;}

Value:

ImGearXMPString Class value.


CaptionWriter Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses CaptionWriter property of the Photoshop XMP schema.

Declaration:

public ImGearXMPString CaptionWriter {get; set;}

Value:

ImGearXMPString Class value.


Category Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Category property of the Photoshop XMP schema. It is limited to 3 7-bit ASCII characters.

Declaration:

public ImGearXMPString Category {get; set;}

Value:

ImGearXMPString Class value.


City Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses City property of the Photoshop XMP schema.

Declaration:

public ImGearXMPString City {get; set;}

Value:

ImGearXMPString Class value.


Country Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Country property of the Photoshop XMP schema.

Declaration:

public ImGearXMPString Country {get; set;}

Value:

ImGearXMPString Class value.


Credit Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Credit property of the Photoshop XMP schema.

Declaration:

public ImGearXMPString Credit {get; set;}

Value:

ImGearXMPString Class value.


DateCreated Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses DateCreated property of the Photoshop XMP schema. This XMP property specifies the date the intellectual content of the document was created (rather than the creation date of the physical representation), following IIM conventions. For example, a photo taken during the American Civil War would have a creation date during that epoch (1861-1865) rather than the date the photo was digitized for archiving.

Declaration:

public ImGearXMPDate DateCreated {get; set;}

Value:

ImGearXMPDate Class value.


Headline Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Headline property of the Photoshop XMP schema.

Declaration:

public ImGearXMPString Headline {get; set;}

Value:

ImGearXMPString Class value.


Instructions Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Instructions property of the Photoshop XMP schema.

Declaration:

public ImGearXMPString Instructions {get; set;}

Value:

ImGearXMPString Class value.


Source Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Source property of the Photoshop XMP schema.

Declaration:

public ImGearXMPString Source {get; set;}

Value:

ImGearXMPString Class value.


State Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses State property of the Photoshop XMP schema.

Declaration:

public ImGearXMPString State {get; set;}

Value:

ImGearXMPString Class value.


SupplementalCategories Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses SupplementalCategories property of the Photoshop XMP schema.

Declaration:

public ImGearXMPBag<ImGearXMPString> SupplementalCategories {get; set;}

Value:

ImGearXMPBag<ImGearXMPString Class> value.


TransmissionReference Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses TransmissionReference property of the Photoshop XMP schema.

Declaration:

public ImGearXMPString TransmissionReference {get; set;}

Value:

ImGearXMPString Class value.


Urgency Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Urgency property of the Photoshop XMP schema. Valid range is 1-8.

Declaration:

public ImGearXMPInteger Urgency {get; set;}

Value:

ImGearXMPInteger Class value.


ImageGear.Formats.XMP.RightsManagement Namespace

ImageGear.Formats.XMP.RightsManagement Namespace

32-bit
64-bit
CF
P
P
P

Description:

This namespace provides the API for XMP.RightsManagement format.

Declaration:

namespace ImageGear.Formats.XMP.RightsManagement

Members:

Classes:
Name
Description
ImGearRightsManagementXMPMetadata Class
Provides simplified access to Rights Management XMP metadata schema.

See Also:

ImageGear.Formats.XMP Namespace

ImageGear.Formats.XMP.AdobePDF Namespace

ImageGear.Formats.XMP.Basic Namespace

ImageGear.Formats.XMP.BasicJobTicket Namespace

ImageGear.Formats.XMP.CameraRaw Namespace

ImageGear.Formats.XMP.DublinCore Namespace

ImageGear.Formats.XMP.DynamicMedia Namespace

ImageGear.Formats.XMP.MediaManagement Namespace

ImageGear.Formats.XMP.PagedText Namespace

ImageGear.Formats.XMP.Photoshop Namespace

ImageGear.Formats.XMP.RightsManagement Namespace

ImageGear.Formats.XMP.TIFF Namespace

ImageGear.Formats.XMP.EXIF Namespace

ImageGear.Formats.XMP.EXIFAux Namespace

ImageGear.Formats.XMP.IPTC4XMPCore Namespace

ImageGear.Formats.XMP.MicrosoftPhoto Namespace


ImageGear.Formats.XMP.RightsManagement Classes

The ImageGear.Formats.XMP.RightsManagement Namespace has the following class members:

Classes:
Name
Description
ImGearRightsManagementXMPMetadata Class
Provides simplified access to Rights Management XMP metadata schema.


ImGearRightsManagementXMPMetadata Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides simplified access to Rights Management XMP metadata schema. It includes properties related to rights management. These properties specify information regarding the legal restrictions associated with a resource.

Declaration:

public class ImGearRightsManagementXMPMetadata : ImageGear.Formats.ImGearXMPFormatMetadata

Members:

Constructors
Name
Description
ImGearRightsManagementXMPMetadata Constructor
Creates and initializes an instance of ImGearRightsManagementXMPMetadata Class.

Properties
Name
Description
Certificate Property
Accesses Certificate property of the XMP Rights Management schema.
Marked Property
Accesses Marked property of the XMP Rights Management schema.
Owner Property
Accesses Owner property of the XMP Rights Management schema.
UsageTerms Property
Accesses UsageTerms property of the XMP Rights Management schema.
WebStatement Property
Accesses WebStatement property of the XMP Rights Management schema.


ImGearRightsManagementXMPMetadata Class Constructors

The ImGearRightsManagementXMPMetadata Class has the following constructors:
Constructors
Name
Description
ImGearRightsManagementXMPMetadata Constructor
Creates and initializes an instance of ImGearRightsManagementXMPMetadata Class.


ImGearRightsManagementXMPMetadata Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearRightsManagementXMPMetadata Class.

Declaration:

public ImGearRightsManagementXMPMetadata ()

Return Value:

New instance of ImGearRightsManagementXMPMetadata Class object.


ImGearRightsManagementXMPMetadata Class Properties

The ImGearRightsManagementXMPMetadata Class has the following properties:
Properties
Name
Description
Certificate Property
Accesses Certificate property of the XMP Rights Management schema.
Marked Property
Accesses Marked property of the XMP Rights Management schema.
Owner Property
Accesses Owner property of the XMP Rights Management schema.
UsageTerms Property
Accesses UsageTerms property of the XMP Rights Management schema.
WebStatement Property
Accesses WebStatement property of the XMP Rights Management schema.


Certificate Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Certificate property of the XMP Rights Management schema. This XMP property specifies online rights management certificate.

Declaration:

public ImGearXMPString Certificate {get; set;}

Value:

ImGearXMPString Class value.


Marked Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Marked property of the XMP Rights Management schema. This XMP property indicates that this is a rights-managed resource.

Declaration:

public ImGearXMPBoolean Marked {get; set;}

Value:

ImGearXMPBoolean Class value.


Owner Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Owner property of the XMP Rights Management schema. This XMP property contains an unordered array specifying the legal owner(s) of a resource.

Declaration:

public ImGearXMPBag<ImGearXMPString> Owner {get; set;}

Value:

ImGearXMPBag<ImGearXMPString Class> value.


UsageTerms Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses UsageTerms property of the XMP Rights Management schema. This XMP property specifies instructions on how a resource can be legally used.

Declaration:

public ImGearXMPLangAlt UsageTerms {get; set;}

Value:

ImGearXMPLangAlt Class value.


WebStatement Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses WebStatement property of the XMP Rights Management schema. This XMP property specifies location of a web page describing the owner and/or rights statement for this resource.

Declaration:

public ImGearXMPString WebStatement {get; set;}

Value:

ImGearXMPString Class value.


ImageGear.Formats.XMP.TIFF Namespace

ImageGear.Formats.XMP.TIFF Namespace

32-bit
64-bit
CF
P
P
P

Description:

This namespace provides the API for XMP.TIFF format.

Declaration:

namespace ImageGear.Formats.XMP.TIFF

Members:

Classes:
Name
Description
ImGearTIFFXMPMetadata Class
Provides simplified access to TIFF XMP metadata schema.

See Also:

ImageGear.Formats.XMP Namespace

ImageGear.Formats.XMP.AdobePDF Namespace

ImageGear.Formats.XMP.Basic Namespace

ImageGear.Formats.XMP.BasicJobTicket Namespace

ImageGear.Formats.XMP.CameraRaw Namespace

ImageGear.Formats.XMP.DublinCore Namespace

ImageGear.Formats.XMP.DynamicMedia Namespace

ImageGear.Formats.XMP.MediaManagement Namespace

ImageGear.Formats.XMP.PagedText Namespace

ImageGear.Formats.XMP.Photoshop Namespace

ImageGear.Formats.XMP.RightsManagement Namespace

ImageGear.Formats.XMP.TIFF Namespace

ImageGear.Formats.XMP.EXIF Namespace

ImageGear.Formats.XMP.EXIFAux Namespace

ImageGear.Formats.XMP.IPTC4XMPCore Namespace

ImageGear.Formats.XMP.MicrosoftPhoto Namespace


ImageGear.Formats.XMP.TIFF Classes

The ImageGear.Formats.XMP.TIFF Namespace has the following class members:

Classes:
Name
Description
ImGearTIFFXMPMetadata Class
Provides simplified access to TIFF XMP metadata schema.


ImGearTIFFXMPMetadata Class

32-bit
64-bit
CF
P
P
P

Description:

This class provides simplified access to TIFF XMP metadata schema. It includes TIFF-derived data. Only those TIFF properties that are mentioned in the EXIF 2.2 specification are included in this schema.

Declaration:

public class ImGearTIFFXMPMetadata : ImageGear.Formats.ImGearXMPFormatMetadata

Members:

Constructors
Name
Description
ImGearTIFFXMPMetadata Constructor
Creates and initializes an instance of ImGearTIFFXMPMetadata Class.

Properties
Name
Description
Artist Property
Accesses Artist property of the TIFF XMP schema.
BitsPerSample Property
Accesses BitsPerSample property of the TIFF XMP schema.
Compression Property
Accesses Compression property of the TIFF XMP schema.
Copyright Property
Accesses Copyright property of the TIFF XMP schema.
DateTime Property
Accesses DateTime property of the TIFF XMP schema.
ImageDescription Property
Accesses ImageDescription property of the TIFF XMP schema.
ImageLength Property
Accesses ImageLength property of the TIFF XMP schema.
ImageWidth Property
Accesses ImageWidth property of the TIFF XMP schema.
Make Property
Accesses Make property of the TIFF XMP schema.
Model Property
Accesses Model property of the TIFF XMP schema.
Orientation Property
Accesses Orientation property of the TIFF XMP schema.
PhotometricInterpretation Property
Accesses PhotometricInterpretation property of the TIFF XMP schema.
PlanarConfiguration Property
Accesses PlanarConfiguration property of the TIFF XMP schema.
PrimaryChromaticities Property
Accesses PrimaryChromaticities property of the TIFF XMP schema.
ReferenceBlackWhite Property
Accesses ReferenceBlackWhite property of the TIFF XMP schema.
ResolutionUnit Property
Accesses ResolutionUnit property of the TIFF XMP schema.
SamplesPerPixel Property
Accesses SamplesPerPixel property of the TIFF XMP schema.
Software Property
Accesses Software property of the TIFF XMP schema.
TransferFunction Property
Accesses TransferFunction property of the TIFF XMP schema.
WhitePoint Property
Accesses WhitePoint property of the TIFF XMP schema.
XResolution Property
Accesses YResolution property of the TIFF XMP schema.
YCbCrCoefficients Property
Accesses YCbCrCoefficients property of the TIFF XMP schema.
YCbCrPositioning Property
Accesses YCbCrPositioning property of the TIFF XMP schema.
YCbCrSubSampling Property
Accesses YCbCrSubSampling property of the TIFF XMP schema.
YResolution Property
Accesses YResolution property of the TIFF XMP schema.


ImGearTIFFXMPMetadata Class Constructors

The ImGearTIFFXMPMetadata Class has the following constructors:
Constructors
Name
Description
ImGearTIFFXMPMetadata Constructor
Creates and initializes an instance of ImGearTIFFXMPMetadata Class.


ImGearTIFFXMPMetadata Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearTIFFXMPMetadata Class.

Declaration:

public ImGearTIFFXMPMetadata ()

Return Value:

New instance of ImGearTIFFXMPMetadata Class object.


ImGearTIFFXMPMetadata Class Properties

The ImGearTIFFXMPMetadata Class has the following properties:
Properties
Name
Description
Artist Property
Accesses Artist property of the TIFF XMP schema.
BitsPerSample Property
Accesses BitsPerSample property of the TIFF XMP schema.
Compression Property
Accesses Compression property of the TIFF XMP schema.
Copyright Property
Accesses Copyright property of the TIFF XMP schema.
DateTime Property
Accesses DateTime property of the TIFF XMP schema.
ImageDescription Property
Accesses ImageDescription property of the TIFF XMP schema.
ImageLength Property
Accesses ImageLength property of the TIFF XMP schema.
ImageWidth Property
Accesses ImageWidth property of the TIFF XMP schema.
Make Property
Accesses Make property of the TIFF XMP schema.
Model Property
Accesses Model property of the TIFF XMP schema.
Orientation Property
Accesses Orientation property of the TIFF XMP schema.
PhotometricInterpretation Property
Accesses PhotometricInterpretation property of the TIFF XMP schema.
PlanarConfiguration Property
Accesses PlanarConfiguration property of the TIFF XMP schema.
PrimaryChromaticities Property
Accesses PrimaryChromaticities property of the TIFF XMP schema.
ReferenceBlackWhite Property
Accesses ReferenceBlackWhite property of the TIFF XMP schema.
ResolutionUnit Property
Accesses ResolutionUnit property of the TIFF XMP schema.
SamplesPerPixel Property
Accesses SamplesPerPixel property of the TIFF XMP schema.
Software Property
Accesses Software property of the TIFF XMP schema.
TransferFunction Property
Accesses TransferFunction property of the TIFF XMP schema.
WhitePoint Property
Accesses WhitePoint property of the TIFF XMP schema.
XResolution Property
Accesses YResolution property of the TIFF XMP schema.
YCbCrCoefficients Property
Accesses YCbCrCoefficients property of the TIFF XMP schema.
YCbCrPositioning Property
Accesses YCbCrPositioning property of the TIFF XMP schema.
YCbCrSubSampling Property
Accesses YCbCrSubSampling property of the TIFF XMP schema.
YResolution Property
Accesses YResolution property of the TIFF XMP schema.


Artist Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Artist property of the TIFF XMP schema. This XMP property represents TIFF tag 315 (x13B) and specifies camera owner, photographer or image creator. NOTE: This property is stored in XMP as the first item in the dc:creator array.

Declaration:

public ImGearXMPString Artist {get; set;}

Value:

ImGearXMPString Class value.


BitsPerSample Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses BitsPerSample property of the TIFF XMP schema. This XMP property represents TIFF tag 258 (0x102) and specifies number of bits per component in each channel.

Declaration:

public ImGearXMPSeq<ImGearXMPInteger> BitsPerSample {get; set;}

Value:

ImGearXMPSeq<ImGearXMPInteger Class> value.


Compression Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Compression property of the TIFF XMP schema. This XMP property represents TIFF tag 259 (0x103) and specifies compression scheme: 1 = uncompressed; 6 = JPEG.

Declaration:

public ImGearXMPEnum<ImGearTIFFCompression> Compression {get; set;}

Value:

ImGearXMPEnum Generic Class<ImGearTIFFCompression> value.


Copyright Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Copyright property of the TIFF XMP schema. This XMP property represents TIFF tag 33432 (0x8298) and specifies copyright information. NOTE: This property is stored in XMP as dc:rights.

Declaration:

public ImGearXMPLangAlt Copyright {get; set;}

Value:

ImGearXMPLangAlt Class value.


DateTime Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses DateTime property of the TIFF XMP schema. This XMP property represents TIFF tag 306, 0x132 (primary) and EXIF tag 37520, 0x9290 (subseconds). NOTE: This property is stored in XMP as xmp:ModifyDate.

Declaration:

public ImGearXMPDate DateTime {get; set;}

Value:

ImGearXMPDate Class value.


ImageDescription Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ImageDescription property of the TIFF XMP schema. This XMP property represents TIFF tag 270 (0x10E) and specifies description of the image. NOTE: This property is stored in XMP as dc:description.

Declaration:

public ImGearXMPLangAlt ImageDescription {get; set;}

Value:

ImGearXMPLangAlt Class value.


ImageLength Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ImageLength property of the TIFF XMP schema. This XMP property represents TIFF tag 257 (0x101) and specifies image height in pixels.

Declaration:

public ImGearXMPInteger ImageLength {get; set;}

Value:

ImGearXMPInteger Class value.


ImageWidth Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ImageWidth property of the TIFF XMP schema. This XMP property represents TIFF tag 256 (0x100) and specifies image width in pixels.

Declaration:

public ImGearXMPInteger ImageWidth {get; set;}

Value:

ImGearXMPInteger Class value.


Make Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Make property of the TIFF XMP schema. This XMP property represents TIFF tag 271 (0x10F) and specifies manufacturer of recording equipment.

Declaration:

public ImGearXMPString Make {get; set;}

Value:

ImGearXMPString Class value.


Model Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Model property of the TIFF XMP schema. This XMP property represents TIFF tag 272 (0x110) and specifies model name or number of equipment.

Declaration:

public ImGearXMPString Model {get; set;}

Value:

ImGearXMPString Class value.


Orientation Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Orientation property of the TIFF XMP schema. This XMP property represents TIFF tag 274 (0x112) and specifies image orientation.

Declaration:

public ImGearXMPEnum<ImGearTIFFOrientation> Orientation {get; set;}

Value:

ImGearXMPEnum Generic Class<ImGearTIFFOrientation> value.


PhotometricInterpretation Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses PhotometricInterpretation property of the TIFF XMP schema. This XMP property represents TIFF tag 262 (0x106) and specifies pixel composition.

Declaration:

public ImGearXMPEnum<ImGearTIFFPhotoInterpretation> PhotometricInterpretation {get; set;}

Value:

ImGearXMPEnum Generic Class<ImGearTIFFPhotoInterpretation> value.


PlanarConfiguration Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses PlanarConfiguration property of the TIFF XMP schema. This XMP property represents TIFF tag 284 (0x11C) and specifies data layout.

Declaration:

public ImGearXMPEnum<ImGearTIFFPlanarConfig> PlanarConfiguration {get; set;}

Value:

ImGearXMPEnum Generic Class<ImGearTIFFPlanarConfig> value.


PrimaryChromaticities Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses PrimaryChromaticities property of the TIFF XMP schema. This XMP property represents TIFF tag 319 (0x13F) and specifies chromaticity of the three primary colors.

Declaration:

public ImGearXMPSeq<ImGearXMPRational> PrimaryChromaticities {get; set;}

Value:

ImGearXMPSeq<ImGearXMPRational Class> value.


ReferenceBlackWhite Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ReferenceBlackWhite property of the TIFF XMP schema. This XMP property represents TIFF tag 532 (0x214) and specifies reference black and white point values.

Declaration:

public ImGearXMPSeq<ImGearXMPRational> ReferenceBlackWhite {get; set;}

Value:

ImGearXMPSeq<ImGearXMPRational Class> value.


ResolutionUnit Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses ResolutionUnit property of the TIFF XMP schema. This XMP property represents TIFF tag 296 (0x128) and specifies the unit used for XResolution and YResolution.

Declaration:

public ImGearXMPEnum<ImGearTIFFResolutionUnit> ResolutionUnit {get; set;}

Value:

ImGearXMPEnum Generic Class<ImGearTIFFResolutionUnit> value.


SamplesPerPixel Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses SamplesPerPixel property of the TIFF XMP schema. This XMP property represents TIFF tag 277 (0x115) and specifies number of components per pixel.

Declaration:

public ImGearXMPInteger SamplesPerPixel {get; set;}

Value:

ImGearXMPInteger Class value.


Software Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses Software property of the TIFF XMP schema. This XMP property represents TIFF tag 305 (0x131) and specifies software or firmware used to generate image. NOTE: This property is stored in XMP as xmp:CreatorTool.

Declaration:

public ImGearXMPString Software {get; set;}

Value:

ImGearXMPString Class value.


TransferFunction Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses TransferFunction property of the TIFF XMP schema. This XMP property represents TIFF tag 301 (0x12D) and specifies transfer function for image described in tabular style with 3 * 256 entries.

Declaration:

public ImGearXMPSeq<ImGearXMPInteger> TransferFunction {get; set;}

Value:

ImGearXMPString Class value.


WhitePoint Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses WhitePoint property of the TIFF XMP schema. This XMP property represents TIFF tag 318 (0x13E) and specifies chromaticity of white point.

Declaration:

public ImGearXMPSeq<ImGearXMPRational> WhitePoint {get; set;}

Value:

ImGearXMPString Class value.


XResolution Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses XResolution property of the TIFF XMP schema. This XMP property represents TIFF tag 282 (0x11A) and specifies horizontal resolution in pixels per unit.

Declaration:

public ImGearXMPRational XResolution {get; set;}

Value:

ImGearXMPRational Class value.


YCbCrCoefficients Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses YCbCrCoefficients property of the TIFF XMP schema. This XMP property represents TIFF tag 529 (0x211) and specifies matrix coefficients for RGB to YCbCr transformation.

Declaration:

public ImGearXMPSeq<ImGearXMPRational> YCbCrCoefficients {get; set;}

Value:

ImGearXMPSeq<ImGearXMPRational Class> value.


YCbCrPositioning Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses YCbCrPositioning property of the TIFF XMP schema. This XMP property represents TIFF tag 531 (0x213) and specifies position of chrominance vs. luminance components: 1 = centered; 2 = co-sited.

Declaration:

public ImGearXMPInteger YCbCrPositioning {get; set;}

Value:

ImGearXMPInteger Class value.


YCbCrSubSampling Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses YCbCrSubSampling property of the TIFF XMP schema. This XMP property represents TIFF tag 530 (0x212) and specifies sampling ratio of chrominance components: [2, 1] = YCbCr4:2:2 [2, 2] = YCbCr4:2:0

Declaration:

public ImGearXMPSeq<ImGearXMPInteger> YCbCrSubSampling {get; set;}

Value:

ImGearXMPSeq<ImGearXMPInteger Class> value.


YResolution Property

32-bit
64-bit
CF
P
P
P

Description:

This property accesses YResolution property of the TIFF XMP schema. This XMP property represents TIFF tag 283 (0x11B) and specifies vertical resolution in pixels per unit.

Declaration:

public ImGearXMPRational YResolution {get; set;}

Value:

ImGearXMPRational Class value.


ImageGear.FreqIP Namespace

ImageGear.FreqIP Namespace

32-bit
64-bit
CF
P

Description:

This namespace provides public API functions for features related to image processing in frequency domain, such as Fourier Transform, Low Pass Filter, etc.

Function ImGearFrequencyProcessing.InitializeFFTW Method() must be called first to initialize the support for FFTW in order to use any of the frequency domain image processing functions. You can use ImGearFrequencyProcessing. IsFFTWInitialized Property to check whether FFTW support is currently initialized or not.

Members:

Classes:
Name
Description
ImGearComplexObject Class
Objects of this type can store both real and imaginary part of complex data, which is stored internally using double precision, rather than one of the integral types as in ImGearPage Class.
ImGearFrequencyProcessing Class
This is the main class for all frequency domain image processing operations.
ImGearFrequencyProcessingVerifier Class
This class contains static methods that check whether the ImGearFrequencyProcessing operation is applicable to the page or not.

Enumerations:
Name
Description
ImGearCoObjConvType Enumeration
Specifies the conversion types to convert an ImGearComplexObject Class object to an ImGearPage Class object.
ImGearFFTScalingMethods Enumeration
Defines the different scaling methods for the result of Fast Fourier Transform (FFT).
ImGearFreqIPFilterBrands Enumeration
Defines the different kind of filter brands available.


ImageGear.FreqIP Classes

The ImageGear.FreqIP Namespace has the following class members:

Classes:
Name
Description
ImGearComplexObject Class
Objects of this type can store both real and imaginary part of complex data, which is stored internally using double precision, rather than one of the integral types as in ImGearPage Class.
ImGearFrequencyProcessing Class
This is the main class for all frequency domain image processing operations.
ImGearFrequencyProcessingVerifier Class
This class contains static methods that check whether the ImGearFrequencyProcessing operation is applicable to the page or not.


ImGearComplexObject Class

32-bit
64-bit
CF
P

Description:

Objects of this type can store both real and imaginary part of complex data, which is stored internally using double precision, rather than one of the integral types as in ImGearPage Class.

Objects of this type can be used as input or output for frequency domain image processing functions so as to keep the precision of the data.

Declaration:

public sealed class ImGearComplexObject

Members:

Constructors
Name
Description
ImGearComplexObject Constructor
Creates a new object based on the given rePage and imPage.
ImGearComplexObject Constructor
Creates a new complex object with empty but allocated buffers, based on the given width and height.

Properties
Name
Description
Height Property
Height of the object.
Width Property
Width of the object.

Methods
Name
Description
GetImaginaryDataRaster Method
Gets an ImGearArrayRef to the imaginary buffer of the specified row.
GetRealDataRaster Method
Gets an ImGearArrayRef to the real buffer of the specified row.
IsValid Method
Checks whether an object is a valid ImGearComplexObject Class object.
ToImage Method
Converts a complex object to an ImGearPage Class object, using the conversion type specified by parameter nConvType.
ToImage Method
Converts a complex object to an ImGearPage Class object, using the conversion type specified by parameter nConvType.
WithImaginaryData Method
Checks whether a specific ImGearComplexObject Class has valid imaginary data


ImGearComplexObject Constructors

The ImGearComplexObject Class of the ImageGear.FreqIP Namespace has the following constructors:

Constructors
Name
Description
ImGearComplexObject Constructor
Creates a new object based on the given rePage and imPage.
ImGearComplexObject Constructor
Creates a new complex object with empty but allocated buffers, based on the given width and height.


ImGearComplexObject Constructor

32-bit
64-bit
CF
P

Description:

This constructor creates a new object based on the given rePage and imPage.

The dimension of the newly created object is determined by the width and height of rePage and imPage. If imPage is not NULL, this function requires rePage and imPage to have the same width and height; otherwise, the width and height of rePage is used.

Data from rePage and imPage is then used respectively to populate the real and imaginary buffer in the newly created object.

Note that rePage and imPage should only have one channel with bit depth being 8, 16 or 32.

Declaration:

public ImGearComplexObject(ImageGear.Core.ImGearPage rePage, ImageGear.Core.ImGearPage
imPage)

Parameters:

Name
Type
Description
rePage
ImGearPage Class
ImGearPage Class object to to be used as the real part of the newly created object.
imPage
ImGearPage Class
ImGearPage Class object to to be used as the imaginary part of the newly created object.

Return Value:

New ImGearComplexObject Class object.

See Also:

ImGearComplexObject Class

ImGearPage Class


ImGearComplexObject Constructor

32-bit
64-bit
CF
P

Description:

This constructor creates a new complex object with empty but allocated buffers, based on the given width and height. The buffers can be populated later by obtaining pointers to the buffers.

Declaration:

public ImGearComplexObject(int width, int height)

Parameters:

Name
Type
Description
width
int
Width of the object to be created.
height
int
Height of the object to be created.

Return Value:

New ImGearComplexObject Class object.

See Also:

ImGearComplexObject Class


ImGearComplexObject Properties

The ImGearComplexObject Class of the ImageGear.FreqIP Namespace has the following properties:

Properties
Name
Description
Height Property
Height of the object.
Width Property
Width of the object.


Height Property

32-bit
64-bit
CF
P

Description:

This property specifies the Height of the ImGearComplexObject Constructor object.

Declaration:

public int Height { get }

Value:

Any integer value.

See Also:

ImGearComplexObject Constructor


Width Property

32-bit
64-bit
CF
P

Description:

This property specifies the Width of the ImGearComplexObject Constructor object.

Declaration:

public int Width { get }

Value:

Any integer value.

See Also:

ImGearComplexObject Constructor


ImGearComplexObject Methods

The ImGearComplexObject Class of the ImageGear.FreqIP Namespace has the following methods:

Methods
Name
Description
GetImaginaryDataRaster Method
Gets an ImGearArrayRef to the imaginary buffer of the specified row.
GetRealDataRaster Method
Gets an ImGearArrayRef to the real buffer of the specified row.
IsValid Method
Checks whether an object is a valid ImGearComplexObject Class object.
ToImage Method
Converts a complex object to an ImGearPage Class object, using the conversion type specified by parameter nConvType.
ToImage Method
Converts a complex object to an ImGearPage Class object, using the conversion type specified by parameter nConvType.
WithImaginaryData Method
Checks whether a specific ImGearComplexObject Class has valid imaginary data


GetImaginaryDataRaster Method

32-bit
64-bit
CF
P

Description:

This method gets an ImGearArrayRef to the imaginary buffer of the specified row.

Declaration:

public ImageGear.Core.ImGearArrayRef GetImaginaryDataRaster(int rowNum)

Parameters:

Name
Type
Description
rowNum
int
Index of the row for which to get ImGearArrayRef Structure.

Return Value:

An ImGearArrayRef Structure to the imaginary buffer of the specified row

See Also:

ImGearArrayRef Structure


GetRealDataRaster Method

32-bit
64-bit
CF
P

Description:

This method gets an ImGearArrayRef Structure to the real buffer of the specified row.

Declaration:

public ImageGear.Core.ImGearArrayRef GetRealDataRaster(int rowNum)

Parameters:

Name
Type
Description
rowNum
int
Index of the row for which to get ImGearArrayRef Structure.

Return Value:

An ImGearArrayRef Structure to the real buffer of the specified row.

See Also:

ImGearArrayRef Structure


IsValid Method

32-bit
64-bit
CF
P

Description:

This function checks whether an object is a valid ImGearComplexObject Class object.

Declaration:

public bool IsValid()

Return Value:

true/false

See Also:

ImGearComplexObject Class


ToImage Method

32-bit
64-bit
CF
P

Description:

This function converts a complex object to an ImGearPage Class object, using the conversion type specified by parameter nConvType. A complex object should be converted to ImGearPage Class only for display purposes; otherwise, it should remain in its original format to retain the data accuracy.

As an ImGearComplexObject Class object contains both real and imaginary data, we need firstly to combine these two data sets into one in order to store the result in an ImGearPage Class object, using the option specified by the parameter nConvType. Options available include REAL, IMAGINARY, MAGNITUDE, etc. Please see ImGearCoObjConvType Enumeration.

The dimensions of the converted ImGearPage Class object are determined by those of the complex object, with width and height being the same. The depth of the ImGearPage Class object can be 8, 16 or 32, depending on the image size. If the image size is less than or equal to (1 << 8), then the depth will be 8bit; less than or equal to (1 << 16), then 16bit; otherwise, the depth will be 32bit. Of course, the ImGearPage Class object will only have one channel.

Once the bit depth is determined, data are then scaled linearly to occupy the entire range of that bit depth and copied to the buffer of ImGearPage Class.

Declaration:

public ImageGear.Core.ImGearPage ToImage(ImageGear.FreqIP.ImGearCoObjConvType nConvType)

Parameters:

Name
Type
Description
nConvType
ImGearCoObjConvType Enumeration
Conversion type used to convert the object to ImGearPage Class. See ImGearCoObjConvType Enumeration.

Return Value:

ImGearPage Class.

See Also:

ImGearPage Class

ImGearCoObjConvType Enumeration


ToImage Method

32-bit
64-bit
CF
P

Description:

This function converts a complex object to an ImGearPage Class object, using the conversion type specified by parameter nConvType. A complex object should be converted to ImGearPage Class only for display purposes; otherwise, it should remain in its original format to retain the data accuracy.

As an ImGearComplexObject Class object contains both real and imaginary data, we need firstly to combine these two data sets into one in order to store the result in an ImGearPage Class object, using the option specified by the parameter nConvType. Options available include REAL, IMAGINARY, MAGNITUDE, etc. Please see the help page for ImGearCoObjConvType Enumeration.

The dimensions of the converted ImGearPage Class object are determined by those of the complex object, with width and height being the same. The depth of the ImGearPage Class object can be 8, 16 or 32, depending on the image size. If the image size is less than or equal to (1 << 8), then the depth will be 8bit; less than or equal to (1 << 16), then 16bit; otherwise, the depth will be 32bit. Of course, the ImGearPage Class object will only have one channel.

Once the bit depth is determined, data are then scaled linearly to occupy the entire range of that bit depth and copied to the buffer of ImGearPage Class. Minimum value before scaling and scale factor can be returned through minimum and scale parameters if wanted, so as to provide a coarse way to reconstruct the data.

Declaration:

public ImageGear.Core.ImGearPage ToImage(ImageGear.FreqIP.ImGearCoObjConvType nConvType,
out double minimum, out double scale)

Parameters:

Name
Type
Description
nConvType
ImGearCoObjConvType Enumeration
Conversion type used to convert the object to ImGearPage Class. See ImGearCoObjConvType Enumeration.
minimum
double
Returns the minimum value of the data before scaling.
scale
double
Returns the scale factor.

Return Value:

ImGearPage Class.

See Also:

ImGearPage Class

ImGearCoObjConvType Enumeration


WithImaginaryData Method

32-bit
64-bit
CF
P

Description:

This method checks whether a specific ImGearComplexObject Class has valid imaginary data, by checking whether there is any non-zero value in the imaginary buffer. If yes, then we will assume imaginary data has been assigned; otherwise no. The reason we can use this comparison is that when any ImGearComplexObject Class is created, the constructor automatically clears the data buffer to be 0.

Declaration:

public bool WithImaginaryData()

Return Value:

true/false

See Also:

ImGearComplexObject Class


ImGearFrequencyProcessing Class

32-bit
64-bit
CF
P

Description:

This is the main class for all frequency domain image processing operations.

Declaration:

public sealed class ImGearFrequencyProcessing

Members:

Properties
Name
Description
IsFFTWInitialized Property
Indicates whether FFTW support is initialized.
Verifier Property
Allows you to call ImGearFrequencyProcessingVerifier class methods.

Methods
Name
Description
BandPassFilter Method
Filters the input image using a band-pass filter, with the specified parameters.
BandStopFilter Method
Filters the input image using a band-stop filter, with the specified parameters.
Convolve Method
Convolves an image with the given kernel matrix.
InitializeFFTW Method
initializes the FFTW algorithm.
InitializeFFTW Method
initializes the FFTW algorithm.
ForwardDCT Method
Computes the forward Discrete Cosine Transform (DCT) of the input data.
ForwardDCTFromImage Method
Computes the forward Discrete Cosine Transform (DCT) of the input image.
ForwardDST Method
Computes the forward Discrete Sine Transform (DST) of the input data.
ForwardDSTFromImage Method
Computes the forward Discrete Sine Transform (DST) of the input image.
ForwardFFT Method
Performs a forward Fast Fourier Transform.
ForwardFFTFromImage Method
Performs a forward Fast Fourier Transform of the input image.
HighPassFilter Method
Filters the input image using a high-pass filter, with the specified parameters.
InverseDCT Method
Computes the inverse Discrete Cosine Transform (IDCT) of the input data.
InverseDCTToImage Method
Computes the inverse Discrete Cosine Transform (IDCT) of the input data.
InverseDST Method
Computes the inverse Discrete Sine Transform (IDST) of the input data.
InverseDSTToImage Method
Computes the inverse Discrete Sine Transform (IDST) of the input data.
InverseFFT Method
Performs an inverse Fast Fourier Transform.
InverseFFTToImage Method
Performs an inverse Fast Fourier Transform.
InverseRestore Method
Performs image restoration using inverse filtering in the frequency domain.
LowPassFilter Method
Filters the input image using a low-pass filter, with the specified parameters.
WienerRestore Method
Performs image restoration using Wiener filtering in the frequency domain.

See Also:

ImGearFrequencyProcessingVerifier Class


ImGearFrequencyProcessing Properties

The ImGearFrequencyProcessing Class of the ImageGear.FreqIP Namespace has the following properties:

Properties
Name
Description
IsFFTWInitialized Property
Indicates whether FFTW support is initialized.
Verifier Property
Allows you to call ImGearFrequencyProcessingVerifier Class class methods.


IsFFTWInitialized Property

32-bit
64-bit
CF
P

Description:

This property indicates whether FFTW support is initialized.

Declaration:

public static bool IsFFTWInitialized { get; }

Value:

True - FFTW support is initialized, False - otherwise.

See Also:

ImGearFrequencyProcessing Class


Verifier Property

32-bit
64-bit
CF
P

Description:

Allows you to call ImGearFrequencyProcessingVerifier Class methods.

Declaration:

public static ImageGear.FreqIP.ImGearFrequencyProcessingVerifier Verifier { get }

Value:

ImGearFrequencyProcessingVerifier class.

See Also:

ImGearFrequencyProcessingVerifier Class


ImGearFrequencyProcessing Methods

The ImGearFrequencyProcessing Class of the ImageGear.FreqIP Namespace has the following methods:

Methods
Name
Description
BandPassFilter Method
Filters the input image using a band-pass filter, with the specified parameters.
BandStopFilter Method
Filters the input image using a band-stop filter, with the specified parameters.
Convolve Method
Convolves an image with the given kernel matrix.
InitializeFFTW Method
Initializes the FFTW algorithm.
InitializeFFTW Method
Initializes the FFTW algorithm.
ForwardDCT Method
Computes the forward Discrete Cosine Transform (DCT) of the input data.
ForwardDCTFromImage Method
Computes the forward Discrete Cosine Transform (DCT) of the input image.
ForwardDST Method
Computes the forward Discrete Sine Transform (DST) of the input data.
ForwardDSTFromImage Method
Computes the forward Discrete Sine Transform (DST) of the input image.
ForwardFFT Method
Performs a forward Fast Fourier Transform.
ForwardFFTFromImage Method
Performs a forward Fast Fourier Transform of the input image.
HighPassFilter Method
Filters the input image using a high-pass filter, with the specified parameters.
InverseDCT Method
Computes the inverse Discrete Cosine Transform (IDCT) of the input data.
InverseDCTToImage Method
Computes the inverse Discrete Cosine Transform (IDCT) of the input data.
InverseDST Method
Computes the inverse Discrete Sine Transform (IDST) of the input data.
InverseDSTToImage Method
Computes the inverse Discrete Sine Transform (IDST) of the input data.
InverseFFT Method
Performs an inverse Fast Fourier Transform.
InverseFFTToImage Method
Performs an inverse Fast Fourier Transform.
InverseRestore Method
Performs image restoration using inverse filtering in the frequency domain.
LowPassFilter Method
Filters the input image using a low-pass filter, with the specified parameters.
WienerRestore Method
Performs image restoration using Wiener filtering in the frequency domain.


BandPassFilter Method

32-bit
64-bit
CF
P

Description:

This method filters the input image using a band-pass filter, with the specified parameters.

Parameter nFilterBrand specifies the brand of filter to use, with available brands being Ideal, Butterworth, Gaussian, Chebyshev I, and Chebyshev II.

Parameters dCutoffFreqLow and dCutoffFreqHigh specify the lower and upper cutoff frequencies for the band-pass filter. The parameters should have value within the range of [0, 1], where 0 is DC and 1 is the Nyquist frequency.

Before using this function, like other frequency processing functions, ImGearFrequencyProcessing. InitializeFFTW Method must be called first to initialize the support for FFTW.

Can be applied only to 8bit grayscale images with one channel.

ImGearFrequencyProcessing.Verifier. CanApplyBandPassFilter Method can be called to check whether the operation can be performed or not.

Declaration:

public static void BandPassFilter(ImageGear.Core.ImGearRasterPage page,
ImageGear.FreqIP.ImGearFreqIPFilterBrands nFilterBrand, double dCutoffFreqLow, double
dCutoffFreqHigh, int nFilterOrder, double dRippleFactor)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearRasterPage Class object to be processed.
nFilterBrand
ImGearFreqIPFilterBrands Enumeration
Brand of the filter to use. Constants are listed in the ImGearFreqIPFilterBrands Enumeration.
dCutoffFreqLow
double
Lower cutoff frequency for the band-pass filter.
dCutoffFreqHigh
double
Higher cutoff frequency for the band-pass filter.
nFilterOrder
int
Filter order to use, applicable to all except Ideal filter.
dRippleFactor
double
A factor which determines the pass-band ripple for Chebyshev filters, with value between [0, 1].

Return Value:

None.

See Also:

ImGearRasterPage Class

ImGearFreqIPFilterBrands Enumeration


BandStopFilter Method

32-bit
64-bit
CF
P

Description:

This method filters the input image using a band-stop filter, with the specified parameters.

Parameter nFilterBrand specifies the brand of filter to use, with available brands being Ideal, Butterworth, Gaussian, Chebyshev I, and Chebyshev II.

Parameters dCutoffFreqLow and dCutoffFreqHigh specify the lower and upper cutoff frequencies for the band-stop filter. The parameters should have value within the range of [0, 1], where 0 is DC and 1 is the Nyquist frequency.

Before using this function, like other frequency processing functions, ImGearFrequencyProcessing.InitializeFFTW Method() must be called first to initialize the support for FFTW.

Can be applied only to 8bit grayscale images with one channel.

ImGearFrequencyProcessing.Verifier.CanApplyBandStopFilter Method can be called to check whether the operation can be performed or not.

Declaration:

public static void BandStopFilter(ImageGear.Core.ImGearRasterPage page,
ImageGear.FreqIP.ImGearFreqIPFilterBrands nFilterBrand, double dCutoffFreqLow, double
dCutoffFreqHigh, int nFilterOrder, double dRippleFactor)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearRasterPage Class object to be processed.
nFilterBrand
ImGearFreqIPFilterBrands Enumeration
Brand of the filter to use. Constants are listed in ImGearFreqIPFilterBrands Enumeration.
dCutoffFreqLow
double
Lower cutoff frequency for the band-pass filter
dCutoffFreqHigh
double
Higher cutoff frequency for the band-pass filter
nFilterOrder
int
Filter order to use, applicable to all except Ideal filter
dRippleFactor
double
A factor which determines the pass-band ripple for Chebyshev filters, with vaule between [0, 1].

Return Value:

None.

See Also:

ImGearRasterPage Class

ImGearFreqIPFilterBrands Enumeration


Convolve Method

32-bit
64-bit
CF
P

Description:

This method convolves an image with the given kernel matrix. The convolution is implemented using FFT, based on the Convolution Theorem, which provides improved performance for larger kernel matrix.

The result of the convolution is multiplied by dNormalizer to scale the data. For kernels that sum to zero, the normalizer is usually set to 1.0.

Before using this function, like other frequency processing functions, ImGearFrequencyProcessing.InitializeFFTW Method() must be called first to initialize the support for FFTW.

Can be applied only to 8, 16, or 32bit grayscale images with one channel.

ImGearFrequencyProcessing.Verifier.CanApplyConvolve Method can be called to check whether the operation can be performed or not.

Declaration:

public static void Convolve(ImageGear.Core.ImGearRasterPage page, int[ ] matrix, int
nMatrixWidth, int nMatrixHeight, double dNormalizer, bool bAddToOrigin)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearRasterPage Class object to be processed.
matrix
int
Array of kernel elements to convolve with.
nMatrixWidth
int
Width of kernel matrix.
nMatrixHeight
int
Height of kernel matrix.
dNormalizer
double
Normalizer of the result.
bAddToOrigin
bool
Whether to add the result of the convolution to the original pixel values, or replace the original pixel values.

Return Value:

None.

See Also:

ImGearRasterPage Class


InitializeFFTW Method

32-bit
64-bit
CF
P

Description:

This method initializes the FFTW algorithm used in ImageGear. Necessary license check will be performed to make sure FFTW is a licensed feature.

Note that this function searches for the library files using system default path.

Declaration:

public static bool InitializeFFTW()

Return Value:

True - FFTW algorithm is initialized, False - otherwise.

See Also:

InitializeFFTW Method

AccuSoft Corporation
 AccuSoft.com
sales@accusoft.com


InitializeFFTW Method

32-bit
64-bit
CF
P

Description:

This method initializes the FFTW algorithm used in ImageGear. Necessary license check will be performed to make sure FFTW is a licensed feature.

Note that this function searches for the library files using the specified path.

Declaration:

public static bool InitializeFFTW(string LibraryPath)

Parameters:

Name
Type
Description
LibraryPath
string
The path to search for needed library files to Initialize FFTW.

Return Value:

True - FFTW algorithm is Initialized, False - otherwise.

See Also:

InitializeFFTW Method

AccuSoft Corporation
 AccuSoft.com
sales@accusoft.com


ForwardDCT Method

32-bit
64-bit
CF
P

Description:

This method computes the forward Discrete Cosine Transform (DCT) of the input data.

Before using this function, like other frequency processing functions, ImGearFrequencyProcessing.InitializeFFTW Method() must be called first to Initialize the support for FFTW.

Can be applied only to valid ImGearComplexObject Class object.

ImGearFrequencyProcessing.Verifier.CanApplyForwardDCT Method can be called to check whether the operation can be performed or not.

Declaration:

public static ImageGear.FreqIP.ImGearComplexObject
ForwardDCT(ImageGear.FreqIP.ImGearComplexObject complexObj)

Parameters:

Name
Type
Description
complexObj
ImGearComplexObject Class
An ImGearComplexObject Class object to be transformed.

Return Value:

ImGearComplexObject Class.

See Also:

ImGearComplexObject Class


ForwardDCTFromImage Method

32-bit
64-bit
CF
P

Description:

This method computes the forward Discrete Cosine Transform (DCT) of the input image. The difference between this function and ForwardDCT Method is that this function takes an ImGearPage Class as the input.

Before using this function, like other frequency processing functions, ImGearFrequencyProcessing.InitializeFFTW Method() must be called first to Initialize the support for FFTW.

Can be applied only to 8, 16, or 32bit grayscale images with one channel.

ImGearFrequencyProcessing.Verifier.CanApplyForwardDCTFromImage Method can be called to check whether the operation can be performed or not.

Declaration:

public static ImageGear.FreqIP.ImGearComplexObject
ForwardDCTFromImage(ImageGear.Core.ImGearPage page)

Parameters:

Name
Type
Description
page
ImGearPage Class
An ImGearPage Class object to be transformed.

Return Value:

ImGearComplexObject Class.

See Also:

ImGearComplexObject Class

ImGearPage Class


ForwardDST Method

32-bit
64-bit
CF
P

Description:

This method computes the forward Discrete Sine Transform (DST) of the input data.

Before using this function, like other frequency processing functions, ImGearFrequencyProcessing.InitializeFFTW Method() must be called first to Initialize the support for FFTW.

Can be applied only to valid ImGearComplexObject Class object.

Method ImGearFrequencyProcessing.Verifier.CanApplyForwardDST Method can be called to check whether the operation can be performed or not.

Declaration:

public static ImageGear.FreqIP.ImGearComplexObject
ForwardDST(ImageGear.FreqIP.ImGearComplexObject complexObj)

Parameters:

Name
Type
Description
complexObj
ImGearComplexObject Class
An ImGearComplexObject Class object to be transformed.

Return Value:

ImGearComplexObject Class.

See Also:

ImGearComplexObject Class


ForwardDSTFromImage Method

32-bit
64-bit
CF
P

Description:

This method computes the forward Discrete Sine Transform (DST) of the input image. The difference between this function and ForwardDST Method() is that this function takes an ImGearPage Class as the input.

Declaration:

public static ImageGear.FreqIP.ImGearComplexObject
ForwardDSTFromImage(ImageGear.Core.ImGearPage page)

Parameters:

Name
Type
Description
page
ImGearPage Class
An ImGearPage Class object to be transformed.

Return Value:

ImGearComplexObject Class.

See Also:

ImGearComplexObject Class

ImGearPage Class


ForwardFFT Method

32-bit
64-bit
CF
P

Description:

This method performs a forward Fast Fourier Transform.

Note that the user must keep track how the transform is centered in the forward FFT in order to know how to de-center it during the inverse FFT, same goes for the scaling method.

Before using this function, like other frequency processing functions, ImGearFrequencyProcessing.InitializeFFTW Method() must be called first to Initialize the support for FFTW.

Can be applied only to valid ImGearComplexObject Class object.

ImGearFrequencyProcessing.Verifier.CanApplyForwardFFT Method can be called to check whether the operation can be performed or not.

Declaration:

public static ImageGear.FreqIP.ImGearComplexObject
ForwardFFT(ImageGear.FreqIP.ImGearComplexObject complexObj,
ImageGear.FreqIP.ImGearFFTScalingMethods nScalingMethod, bool bCenterTransform)

Parameters:

Name
Type
Description
complexObj
ImGearComplexObject Class
ImGearComplexObject Class object to be processed.
nScalingMethod
ImGearFFTScalingMethods Enumeration
Specifies the method of scaling the result data.
bCenterTransform
bool
Flag to indicate whether to center the transform.

Return Value:

ImGearComplexObject Class class.

See Also:

ImGearComplexObject Class

ImGearFFTScalingMethods Enumeration


ForwardFFTFromImage Method

32-bit
64-bit
CF
P

Description:

This method performs a forward Fast Fourier Transform of the input image. The difference between this function and ForwardFFT Method is that this function takes an ImGearPage Class as the input object.

Note that the user must keep track how the transform is centered in the forward FFT in order to know how to de-center it during the inverse FFT, same goes for the scaling method.

Before using this function, like other frequency processing functions, ImGearFrequencyProcessing.InitializeFFTW Method() must be called first to Initialize the support for FFTW.

Can be applied only to 8, 16, or 32bit grayscale images with one channel.

ImGearFrequencyProcessing.Verifier.CanApplyForwardFFTFromImage Method can be called to check whether the operation can be performed or not.

Declaration:

public static ImageGear.FreqIP.ImGearComplexObject
ForwardFFTFromImage(ImageGear.Core.ImGearPage page,
ImageGear.FreqIP.ImGearFFTScalingMethods nScalingMethod, bool bCenterTransform)

Parameters:

Name
Type
Description
page
ImGearPage Class
ImGearPage Class object to be processed.
nScalingMethod
ImGearFFTScalingMethods Enumeration
Specifies the method of scaling the result data.
bCenterTransform
bool
Flag to indicate whether to center the transform.

Return Value:

ImGearComplexObject Class.

See Also:

ImGearComplexObject Class

ImGearPage Class

ImGearFFTScalingMethods Enumeration


HighPassFilter Method

32-bit
64-bit
CF
P

Description:

This method filters the input image using a high-pass filter, with the specified parameters.

Parameter nFilterBrand specifies the brand of filter to use, with available brands being Ideal, Butterworth, Gaussian, Chebyshev I, and Chebyshev II.

Parameter dCutoffFreq specifies the cutoff frequency for the high-pass filter. This parameter should have value within the range of [0, 1], where 0 is DC and 1 is the Nyquist frequency.

Before using this function, like other frequency processing functions, ImGearFrequencyProcessing.InitializeFFTW Method() must be called first to Initialize the support for FFTW.

Can be applied only to 8bit grayscale images with one channel.

Method ImGearFrequencyProcessing.Verifier.CanApplyHighPassFilter Method can be called to check whether the operation can be performed or not.

Declaration:

public static void HighPassFilter(ImageGear.Core.ImGearRasterPage page,
ImageGear.FreqIP.ImGearFreqIPFilterBrands nFilterBrand, double dCutoffFreq, int
nFilterOrder, double dRippleFactor)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearRasterPage Class object to be processed.
nFilterBrand
ImGearFreqIPFilterBrands Enumeration
Brand of the filter to use. Constants are listed in ImGearFreqIPFilterBrands Enumeration
dCutoffFreq
double
Cutoff frequency for the low-pass filter
nFilterOrder
int
Filter order to use, applicable to all except Ideal filter
dRippleFactor
double
A factor which determines the pass-band ripple for Chebyshev filters, with vaule between [0, 1].

Return Value:

None.

See Also:

ImGearRasterPage Class

ImGearFreqIPFilterBrands Enumeration


InverseDCT Method

32-bit
64-bit
CF
P

Description:

This method computes the inverse Discrete Cosine Transform (IDCT) of the input data.

Before using this function, like other frequency processing functions, ImGearFrequencyProcessing.InitializeFFTW Method() must be called first to Initialize the support for FFTW.

Can be applied only to valid ImGearComplexObject Class object.

Method ImGearFrequencyProcessing.Verifier.CanApplyInverseDCT Method can be called to check whether the operation can be performed or not.

Declaration:

public static ImageGear.FreqIP.ImGearComplexObject
InverseDCT(ImageGear.FreqIP.ImGearComplexObject complexObj)

Parameters:

Name
Type
Description
complexObj
ImGearComplexObject Class
An ImGearComplexObject Class object to be transformed.

Return Value:

None.

See Also:

ImGearComplexObject Class


InverseDCTToImage Method

32-bit
64-bit
CF
P

Description:

This method computes the inverse Discrete Cosine Transform (IDCT) of the input data. The difference between this function and InverseDCT Method is that this function returns an ImGearPage Class as the result, using the default conversion type ImGearCoObjConvType.REAL.

Before using this function, like other frequency processing functions, ImGearFrequencyProcessing.InitializeFFTW Method() must be called first to initialize the support for FFTW.

Can be applied only to valid ImGearComplexObject Class object.

ImGearFrequencyProcessing.Verifier.CanApplyInverseDCTToImage Method can be called to check whether the operation can be performed or not.

Declaration:

public static ImageGear.Core.ImGearPage
InverseDCTToImage(ImageGear.FreqIP.ImGearComplexObject complexObj)

Parameters:

Name
Type
Description
complexObj
ImGearComplexObject Class
An ImGearComplexObject Class object to be transformed.

Return Value:

ImGearPage Class.

See Also:

ImGearComplexObject Class


InverseDST Method

32-bit
64-bit
CF
P

Description:

This method computes the inverse Discrete Sine Transform (IDST) of the input data.

Before using this function, like other frequency processing functions, ImGearFrequencyProcessing.InitializeFFTW Method() must be called first to initialize the support for FFTW.

Can be applied only to valid ImGearComplexObject Class object.

ImGearFrequencyProcessing.Verifier.CanApplyInverseDST Method can be called to check whether the operation can be performed or not.

Declaration:

public static ImageGear.FreqIP.ImGearComplexObject
InverseDST(ImageGear.FreqIP.ImGearComplexObject complexObj)

Parameters:

Name
Type
Description
complexObj
ImGearComplexObject Class
An ImGearComplexObject Class object to be transformed.

Return Value:

ImGearComplexObject Class.

See Also:

ImGearComplexObject Class


InverseDSTToImage Method

32-bit
64-bit
CF
P

Description:

This method computes the inverse Discrete Sine Transform (IDST) of the input data. The difference between this function and InverseDST Method is that this function returns an ImGearPage Class as the result, using the default conversion type ImGearCoObjConvType.REAL.

Before using this function, like other frequency processing functions, ImGearFrequencyProcessing.InitializeFFTW Method() must be called first to initialize the support for FFTW.

Can be applied only to valid ImGearComplexObject Class object.

ImGearFrequencyProcessing.Verifier.CanApplyInverseDSTToImage Method can be called to check whether the operation can be performed or not.

Declaration:

public static ImageGear.Core.ImGearPage
InverseDSTToImage(ImageGear.FreqIP.ImGearComplexObject complexObj)

Parameters:

Name
Type
Description
complexObj
ImGearComplexObject Class
An ImGearComplexObject Class object to be transformed.

Return Value:

ImGearPage Class class.

See Also:

ImGearComplexObject Class

ImGearPage Class


InverseFFT Method

32-bit
64-bit
CF
P

Description:

This method performs an inverse Fast Fourier Transform.

Before using this function, like other frequency processing functions, ImGearFrequencyProcessing.InitializeFFTW Method() must be called first to initialize the support for FFTW.

Can be applied only to valid ImGearComplexObject Class object.

ImGearFrequencyProcessing.Verifier.CanApplyInverseFFT Method can be called to check whether the operation can be performed or not.

Declaration:

public static ImageGear.FreqIP.ImGearComplexObject
InverseFFT(ImageGear.FreqIP.ImGearComplexObject complexObj,
ImageGear.FreqIP.ImGearFFTScalingMethods nScalingMethod, bool bCenterTransform)

Parameters:

Name
Type
Description
complexObj
ImGearComplexObject Class
ImGearComplexObject Class object to be processed.
nScalingMethod
ImGearFFTScalingMethods Enumeration
Specifies the method of scaling the result data.
bCenterTransform
bool
Flag to indicate whether to center the transform.

Return Value:

ImGearComplexObject Class.

See Also:

ImGearComplexObject Class

ImGearFFTScalingMethods Enumeration


InverseFFTToImage Method

32-bit
64-bit
CF
P

Description:

This method performs an inverse Fast Fourier Transform.

Before using this function, like other frequency processing functions, ImGearFrequencyProcessing.InitializeFFTW Method() must be called first to initialize the support for FFTW.

Can be applied only to valid ImGearComplexObject Class object.

ImGearFrequencyProcessing.Verifier. CanApplyInverseFFTToImage Method can be called to check whether the operation can be performed or not.

Declaration:

public static ImageGear.Core.ImGearPage
InverseFFTToImage(ImageGear.FreqIP.ImGearComplexObject complexObj,
ImageGear.FreqIP.ImGearFFTScalingMethods nScalingMethod, bool bCenterTransform)

Parameters:

Name
Type
Description
complexObj
ImGearComplexObject Class
ImGearComplexObject Class object to be processed.
nScalingMethod
ImGearFFTScalingMethods Enumeration
Specifies the method of scaling the result data.
bCenterTransform
bool
Flag to indicate whether to center the transform

Return Value:

ImGearPage Class.

See Also:

ImGearPage Class

ImGearComplexObject Class

ImGearFFTScalingMethods Enumeration


InverseRestore Method

32-bit
64-bit
CF
P

Description:

This method performs image restoration using inverse filtering in the frequency domain. The idea is to deconvolve PSF from the blurred data to extract the original image.

The deconvolution involves dividing the Fourier transform of the blurred image by the Fourier transform of PSF. If the transform of PSF has very small values, then the division result from those small values could easily dominate the entire result. The approach used to get around this issue is to limit the smallest value of the transform of PSF, thus we require a threshold value, dThreshold, to be passed in as a parameter. Ideally, this value will be just above the noise level in the image. This function places zeros in the output for those data points where the magnitude of PSF transform is below the threshold. In this respect, InverseRestore is actually an implementation of a pseudo-inverse filter.

Before using this function, like other frequency processing functions, ImGearFrequencyProcessing.InitializeFFTW Method() must be called first to initialize the support for FFTW.

Can be applied only to 8bit grayscale images with one channel.

Method ImGearFrequencyProcessing.Verifier.CanApplyInverseRestore Method can be called to check whether the operation can be performed or not.

Declaration:

public static void InverseRestore(ImageGear.Core.ImGearRasterPage page, double[ ]
dPSFVector, int nPSFSize, double dThreshold)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearRasterPage Class object to be processed.
dPSFVector
double
Vector which represents the Point Spread Function (PSF) in spatial domain, also called Degradation Function.
nPSFSize
int
Size of PSF passed in.
dThreshold
double
The threshold parameter for Inverse Filtering.

Return Value:

None.

See Also:

ImGearRasterPage Class


LowPassFilter Method

32-bit
64-bit
CF
P

Description:

This method filters the input image using a low-pass filter, with the specified parameters.

Parameter nFilterBrand specifies the brand of filter to use, with available brands being Ideal, Butterworth, Gaussian, Chebyshev I, and Chebyshev II.

Parameter dCutoffFreq specifies the cutoff frequency for the low-pass filter. This parameter should have value within the range of [0, 1], where 0 is DC and 1 is the Nyquist frequency.

Before using this function, like other frequency processing functions, ImGearFrequencyProcessing.InitializeFFTW Method() must be called first to initialize the support for FFTW.

Can be applied only to 8bit grayscale images with one channel.

ImGearFrequencyProcessing.Verifier.CanApplyLowPassFilter Method can be called to check whether the operation can be performed or not.

Declaration:

public static void LowPassFilter(ImageGear.Core.ImGearRasterPage page,
ImageGear.FreqIP.ImGearFreqIPFilterBrands nFilterBrand, double dCutoffFreq, int
nFilterOrder, double dRippleFactor)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearRasterPage Class object to be processed.
nFilterBrand
ImGearFreqIPFilterBrands Enumeration
Brand of the filter to use. Constants are listed in ImGearFreqIPFilterBrands Enumeration
dCutoffFreq
double
Cutoff frequency for the low-pass filter.
nFilterOrder
int
Filter order to use, applicable to all except Ideal filter.
dRippleFactor
double
A factor which determines the pass-band ripple for Chebyshev filters, with vaule between [0, 1].

Return Value:

None.

See Also:

ImGearRasterPage Class

ImGearFreqIPFilterBrands Enumeration


WienerRestore Method

32-bit
64-bit
CF
P

Description:

This method performs image restoration using Wiener filtering in the frequency domain. This filter is also commonly referred to as the minimum mean square error filter or the least square error filter.

Usually Wiener filtering can produce better results than inverse filtering.

Before using this function, like other frequency processing functions, ImGearFrequencyProcessing.InitializeFFTW Method() must be called first to initialize the support for FFTW.

Can be applied only to 8bit grayscale images with one channel.

Method ImGearFrequencyProcessing.Verifier.CanApplyWienerRestore Method can be called to check whether the operation can be performed or not.

Declaration:

public static void WienerRestore(ImageGear.Core.ImGearRasterPage page, double[ ]
dPSFVector, int nPSFSize, double dWienerConstant)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearRasterPage Class object to be processed.
dPSFVector
double
Vector which represents the Point Spread Function (PSF) in spatial domain, also called Degradation Function.
nPSFSize
int
Size of PSF passed in.
dWienerConstant
double
The constant for Wiener Filtering.

Return Value:

None.

See Also:

ImGearRasterPage Class


ImGearFrequencyProcessingVerifier Class

32-bit
64-bit
CF
P

Description:

This class contains static methods that check whether the ImGearFrequencyProcessing operation is applicable to the page or not.

Declaration:

public sealed class ImGearFrequencyProcessingVerifier

Members:

Methods
Name
Description
CanApplyBandPassFilter Method
Takes an ImGearRasterPage Class object and determines whether ImGearFrequencyProcessing.BandPassFilter can be applied to it.
CanApplyBandStopFilter Method
Takes an ImGearRasterPage Class object and determines whether ImGearFrequencyProcessing.BandStopFilter can be applied to it.
CanApplyConvolve Method
Takes an ImGearRasterPage Class object and determines whether ImGearFrequencyProcessing.Convolve can be applied to it.
CanApplyForwardDCT Method
Takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.ForwardDCT can be applied to it.
CanApplyForwardDCTFromImage Method
Takes an ImGearPage Class object and determines whether ImGearFrequencyProcessing.ForwardDCTFromImage can be applied to it.
CanApplyForwardDST Method
Takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.ForwardDST can be applied to it.
CanApplyForwardDSTFromImage Method
Takes an ImGearPage Class object and determines whether ImGearFrequencyProcessing.ForwardDSTFromImage can be applied to it.
CanApplyForwardFFT Method
Takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.ForwardFFT can be applied to it.
CanApplyForwardFFTFromImage Method
Takes an ImGearPage Class object and determines whether ImGearFrequencyProcessing.ForwardFFTFromImage can be applied to it.
CanApplyHighPassFilter Method
Takes an ImGearRasterPage Class object and determines whether ImGearFrequencyProcessing.HighPassFilter can be applied to it.
CanApplyInverseDCT Method
Takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.InverseDCT can be applied to it.
CanApplyInverseDCTToImage Method
Takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.InverseDCTToImage can be applied to it.
CanApplyInverseDST Method
Takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.InverseDST can be applied to it.
CanApplyInverseDSTToImage Method
Takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.InverseDSTToImage can be applied to it.
CanApplyInverseFFT Method
Takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.InverseFFT can be applied to it.
CanApplyInverseFFTToImage Method
Takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.InverseFFTToImage can be applied to it.
CanApplyInverseRestore Method
Takes an ImGearRasterPage Class object and determines whether ImGearFrequencyProcessing.InverseRestore can be applied to it.
CanApplyLowPassFilter Method
Takes an ImGearRasterPage Class object and determines whether ImGearFrequencyProcessing.LowPassFilter can be applied to it.
CanApplyWienerRestore Method
Takes an ImGearRasterPage Class object and determines whether ImGearFrequencyProcessing.WienerRestore can be applied to it.

See Also:

ImGearFrequencyProcessing Class


ImGearFrequencyProcessing Methods

The ImGearFrequencyProcessingVerifier Class of the ImageGear.FreqIP Namespace has the following methods:

Methods
Name
Description
CanApplyBandPassFilter Method
Takes an ImGearRasterPage Class object and determines whether ImGearFrequencyProcessing.BandPassFilter can be applied to it.
CanApplyBandStopFilter Method
Takes an ImGearRasterPage Class object and determines whether ImGearFrequencyProcessing.BandStopFilter can be applied to it.
CanApplyConvolve Method
Takes an ImGearRasterPage Class object and determines whether ImGearFrequencyProcessing.Convolve can be applied to it.
CanApplyForwardDCT Method
Takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.ForwardDCT can be applied to it.
CanApplyForwardDCTFromImage Method
Takes an ImGearPage Class object and determines whether ImGearFrequencyProcessing.ForwardDCTFromImage can be applied to it.
CanApplyForwardDST Method
Takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.ForwardDST can be applied to it.
CanApplyForwardDSTFromImage Method
Takes an ImGearPage Class object and determines whether ImGearFrequencyProcessing.ForwardDSTFromImage can be applied to it.
CanApplyForwardFFT Method
Takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.ForwardFFT can be applied to it.
CanApplyForwardFFTFromImage Method
Takes an ImGearPage Class object and determines whether ImGearFrequencyProcessing.ForwardFFTFromImage can be applied to it.
CanApplyHighPassFilter Method
Takes an ImGearRasterPage Class object and determines whether ImGearFrequencyProcessing.HighPassFilter can be applied to it.
CanApplyInverseDCT Method
Takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.InverseDCT can be applied to it.
CanApplyInverseDCTToImage Method
Takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.InverseDCTToImage can be applied to it.
CanApplyInverseDST Method
Takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.InverseDST can be applied to it.
CanApplyInverseDSTToImage Method
Takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.InverseDSTToImage can be applied to it.
CanApplyInverseFFT Method
Takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.InverseFFT can be applied to it.
CanApplyInverseFFTToImage Method
Takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.InverseFFTToImage can be applied to it.
CanApplyInverseRestore Method
Takes an ImGearRasterPage Class object and determines whether ImGearFrequencyProcessing.InverseRestore can be applied to it.
CanApplyLowPassFilter Method
Takes an ImGearRasterPage Class object and determines whether ImGearFrequencyProcessing.LowPassFilter can be applied to it.
CanApplyWienerRestore Method
Takes an ImGearRasterPage Class object and determines whether ImGearFrequencyProcessing.WienerRestore can be applied to it.


CanApplyBandPassFilter Method

32-bit
64-bit
CF
P

Description:

This method takes an ImGearRasterPage Class object and determines whether ImGearFrequencyProcessing.BandPassFilter Method can be applied to it.

Declaration:

public bool CanApplyBandPassFilter(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearRasterPage Class object to be processed.

Return Value:

true/false

See Also:

ImGearRasterPage Class

BandPassFilter Method


CanApplyBandStopFilter Method

32-bit
64-bit
CF
P

Description:

This method takes an ImGearRasterPage Class object and determines whether ImGearFrequencyProcessing.BandStopFilter Method can be applied to it.

Declaration:

public bool CanApplyBandStopFilter(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearRasterPage Class object to be processed.

Return Value:

true/false

See Also:

ImGearRasterPage Class

BandStopFilter Method


CanApplyConvolve Method

32-bit
64-bit
CF
P

Description:

This method takes an ImGearRasterPage Class object and determines whether ImGearFrequencyProcessing.Convolve Method can be applied to it.

Declaration:

public bool CanApplyConvolve(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearRasterPage Class object to be processed.

Return Value:

true/false

See Also:

ImGearRasterPage Class

Convolve Method


CanApplyForwardDCT Method

32-bit
64-bit
CF
P

Description:

This method takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.ForwardDCT Method can be applied to it.

Declaration:

public bool CanApplyForwardDCT(ImageGear.FreqIP.ImGearComplexObject complexObj)

Parameters:

Name
Type
Description
complexObj
ImGearComplexObject Class
The ImGearComplexObject Class object to determine whether ForwardDCT can be applied to.

Return Value:

true/false

See Also:

ImGearRasterPage Class

ForwardDCT Method

ImGearComplexObject Class


CanApplyForwardDCTFromImage Method

32-bit
64-bit
CF
P

Description:

This method takes an ImGearPage Class object and determines whether ImGearFrequencyProcessing.ForwardDCTFromImage Method can be applied to it.

Declaration:

public bool CanApplyForwardDCTFromImage(ImageGear.Core.ImGearPage page)

Parameters:

Name
Type
Description
page
ImGearPage Class
ImGearRasterPage Class object to be processed.

Return Value:

true/false

See Also:

ImGearPage Class

ForwardDCTFromImage Method


CanApplyForwardDST Method

32-bit
64-bit
CF
P

Description:

This method takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.ForwardDST Method can be applied to it.

Declaration:

public bool CanApplyForwardDST(ImageGear.FreqIP.ImGearComplexObject complexObj)

Parameters:

Name
Type
Description
complexObj
ImGearComplexObject Class
The ImGearComplexObject Class object to determine whether ForwardDST() can be applied to.

Return Value:

true/false

See Also:

ImGearComplexObject Class

ForwardDST Method


CanApplyForwardDSTFromImage Method

32-bit
64-bit
CF
P

Description:

This method takes an ImGearPage Class object and determines whether ImGearFrequencyProcessing.ForwardDSTFromImage Method can be applied to it.

Declaration:

public bool CanApplyForwardDSTFromImage(ImageGear.Core.ImGearPage page)

Parameters:

Name
Type
Description
page
ImGearPage Class
ImGearPage Class object to be processed.

Return Value:

true/false

See Also:

ForwardDSTFromImage Method


CanApplyForwardFFT Method

32-bit
64-bit
CF
P

Description:

This method takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.ForwardFFT Method can be applied to it.

Declaration:

public bool CanApplyForwardFFT(ImageGear.FreqIP.ImGearComplexObject complexObj)

Parameters:

Name
Type
Description
complexObj
ImGearComplexObject Class
The ImGearComplexObject Class object to determine whether ForwardFFT() can be applied to.

Return Value:

true/false

See Also:

ImGearComplexObject Class

ForwardFFT Method


CanApplyForwardFFTFromImage Method

32-bit
64-bit
CF
P

Description:

This method takes an ImGearPage Class object and determines whether ImGearFrequencyProcessing.ForwardFFTFromImage Method can be applied to it.

Declaration:

public bool CanApplyForwardFFTFromImage(ImageGear.Core.ImGearPage page)

Parameters:

Name
Type
Description
page
ImGearPage Class
ImGearPage Class object to be processed.

Return Value:

true/false

See Also:

ImGearPage Class

ForwardFFTFromImage Method


CanApplyHighPassFilter Method

32-bit
64-bit
CF
P

Description:

This method takes an ImGearRasterPage Class object and determines whether ImGearFrequencyProcessing.HighPassFilter Method can be applied to it.

Declaration:

public bool CanApplyHighPassFilter(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearRasterPage Class object to be processed.

Return Value:

true/false

See Also:

ImGearRasterPage Class

HighPassFilter Method


CanApplyInverseDCT Method

32-bit
64-bit
CF
P

Description:

This method takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.InverseDCT Method can be applied to it.

Declaration:

public bool CanApplyInverseDCT(ImageGear.FreqIP.ImGearComplexObject complexObj)

Parameters:

Name
Type
Description
complexObj
ImGearComplexObject Class
The ImGearComplexObject Class object to determine whether InverseDCT() can be applied to.

Return Value:

true/false

See Also:

ImGearComplexObject Class

InverseDCT Method


CanApplyInverseDCTToImage Method

32-bit
64-bit
CF
P

Description:

This method takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.InverseDCTToImage Method can be applied to it.

Declaration:

public bool CanApplyInverseDCTToImage(ImageGear.FreqIP.ImGearComplexObject complexObj)

Parameters:

Name
Type
Description
complexObj
ImGearComplexObject Class
The ImGearComplexObject Class object to determine whether InverseDCTToImage() can be applied to.

Return Value:

true/false

See Also:

ImGearComplexObject Class

InverseDCTToImage Method


CanApplyInverseDST Method

32-bit
64-bit
CF
P

Description:

This method takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.InverseDST Method can be applied to it.

Declaration:

public bool CanApplyInverseDST(ImageGear.FreqIP.ImGearComplexObject complexObj)

Parameters:

Name
Type
Description
complexObj
ImGearComplexObject Class
The ImGearComplexObject Class object to determine whether InverseDST can be applied to.

Return Value:

true/false

See Also:

ImGearComplexObject Class

InverseDST Method


CanApplyInverseDSTToImage Method

32-bit
64-bit
CF
P

Description:

This method takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.InverseDSTToImage Method can be applied to it.

Declaration:

public bool CanApplyInverseDSTToImage(ImageGear.FreqIP.ImGearComplexObject complexObj)

Parameters:

Name
Type
Description
complexObj
ImGearComplexObject Class
The ImGearComplexObject Class object to determine whether InverseDSTToImage() can be applied to.

Return Value:

true/false

See Also:

ImGearComplexObject Class

InverseDSTToImage Method


CanApplyInverseFFT Method

32-bit
64-bit
CF
P

Description:

This method takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.InverseFFT Method can be applied to it.

Declaration:

public bool CanApplyInverseFFT(ImageGear.FreqIP.ImGearComplexObject complexObj)

Parameters:

Name
Type
Description
complexObj
ImGearComplexObject Class
The ImGearComplexObject Class object to determine whether InverseFFT can be applied to.

Return Value:

true/false

See Also:

ImGearRasterPage Class

InverseFFT Method


CanApplyInverseFFTToImage Method

32-bit
64-bit
CF
P

Description:

This method takes an ImGearComplexObject Class object and determines whether ImGearFrequencyProcessing.InverseFFTToImage Method can be applied to it.

Declaration:

public bool CanApplyInverseFFTToImage(ImageGear.FreqIP.ImGearComplexObject complexObj)

Parameters:

Name
Type
Description
complexObj
ImGearComplexObject Class
The ImGearComplexObject Class object to determine whether InverseFFTToImage() can be applied to.

Return Value:

true/false

See Also:

ImGearComplexObject Class

InverseFFTToImage Method


CanApplyInverseRestore Method

32-bit
64-bit
CF
P

Description:

This method takes an ImGearRasterPage Class object and determines whether ImGearFrequencyProcessing.InverseRestore Method can be applied to it.

Declaration:

public bool CanApplyInverseRestore(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearRasterPage Class object to be processed.

Return Value:

true/false

See Also:

ImGearRasterPage Class

InverseRestore Method


CanApplyLowPassFilter Method

32-bit
64-bit
CF
P

Description:

This method takes an ImGearRasterPage Class object and determines whether ImGearFrequencyProcessing.LowPassFilter Method can be applied to it.

Declaration:

public bool CanApplyLowPassFilter(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearRasterPage Class object to be processed.

Return Value:

true/false

See Also:

ImGearRasterPage Class

LowPassFilter Method


CanApplyWienerRestore Method

32-bit
64-bit
CF
P

Description:

This method takes an ImGearRasterPage Class object and determines whether ImGearFrequencyProcessing.WienerRestore Method can be applied to it.

Declaration:

public bool CanApplyWienerRestore(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearRasterPage Class object to be processed.

Return Value:

true/false

See Also:

ImGearRasterPage Class

WienerRestore Method


ImageGear.FreqIP Namespace Enumerations

This section provides information about ImageGear.FreqIP Namespace enumerations. Currently there are the following enumerations:

Name
Description
ImGearCoObjConvType Enumeration
Specifies the conversion types to convert an ImGearComplexObject Class object to an ImGearPage Class object.
ImGearFFTScalingMethods Enumeration
Defines the different scaling methods for the result of Fast Fourier Transform (FFT).
ImGearFreqIPFilterBrands Enumeration
Defines the different kind of filter brands available.


ImGearCoObjConvType Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration specifies the conversion types to convert an ImGearComplexObject Class object to an ImGearPage Class object.

Declaration:

public enum ImGearCoObjConvType

Values:

Name
Value
Description
REAL
0
Use the real data.
IMAGINARY
1
Use the imaginary data.
MAGNITUDE
2
Use the magnitude data.
PHASE
3
Use the phase data.
LOGMAG
4
Use the logarithm (10) of the magnitude data.
LOGMAGP1
5
Use the logarithm (10) of (magnitude data + 1).
MAGSQ
6
Use the square of the magnitude.
LOGMAGSQ
7
Use the logarithm (10) of the square of the magnitude.
LOGMAGSQP1
8
Use the logarithm (10) of (square of the magnitude + 1).


ImGearFFTScalingMethods Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration defines the different scaling methods for the result of Fast Fourier Transform (FFT).

Declaration:

public enum ImGearFFTScalingMethods

Values:

Name
Value
Description
UNITY
0
Unity scaling, i.e., no scaling on the result.
N
1
Scale by 1/N on each dimension
SQRTN
2
Scale by 1/sqrt(N) on each dimension


ImGearFreqIPFilterBrands Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration defines the different kind of filter brands available.

Declaration:

public enum ImGearFreqIPFilterBrands

Values:

Name
Value
Description
IDEAL
0
Ideal Filter
BUTTERWORTH
1
Butterworth Filter
GAUSSIAN
2
Gaussian Filter
CHEBYSHEV_I
3
Type 1 Chebyshev Filter
CHEBYSHEV_II
4
Type 2 Chebyshev Filter


ImageGear.Processing Namespace

ImageGear.Processing Namespace

32-bit
64-bit
CF
P
P
P

Description:

This namespace represents the image and color processing API that allows you to promote or reduce colors using different interpolation algorithms. This API also allows you to rotate, flip, resize and crop images and provides image transformation methods such as remove red eye, perspective, solarize, warp, wave, etc.

Members:

Classes:
Name
Description
ImGearAverageInterpolationOptions Class
Identifies options for average interpolation.
ImGearBayerReductionOptions Class
Defines reduction options for Bayer reduction.
ImGearBicubicInterpolationOptions Class
Identifies options for bilinear interpolation.
ImGearBilinearInterpolationOptions Class
Identifies options for bilinear interpolation.
ImGearBitonalReductionOptions Class
Defines reduction options for bitonal reduction.
ImGearCameraRawProcessing Class
Contains methods for color reconstruction of digital camera RAW images.
ImGearColorInterpolationOptions Class
This is the class for color interpolation options.
ImGearContrastOptions Class
This is the class for contrast options.
ImGearDiffuseReductionOptions Class
Defines reduction options for diffuse reduction.
ImGearGrayScaleInterpolationOptions Class
Interpolation options class that defines a threshold of ScaleToGray interpolation. Derived from ImGearInterpolationOptions Class.
ImGearHalftoneReductionOptions Class
Defines reduction options for halftone reduction.
ImGearInterpolationOptions Class
Base class for all interpolation options passed to ResizeImage and CreateThumbnail methods.
ImGearMedianCutReductionOptions Class
Defines reduction options for median cut reduction.
ImGearMosaicBorderParams Class
Describes border characteristics of the Mosaic operation.
ImGearMosaicCellParams Class
Describes cell parameters of the Mosaic operation.
ImGearMosaicFillParams Class
Describes fill characteristics of the Mosaic operation.
ImGearMosaicShadowParams Class
Describes parameters of the shadow effect to be applied to an image after dividing on the cells.
ImGearNearestNeighborInterpolationOptions Class
Identifies options for nearestneighbor interpolation.
ImGearNoneInterpolationOptions Class
Implements ImGearNoneInterpolationOptions interface for the case when interpolation is not needed.
ImGearOctreeReductionOptions Class
Defines reduction options for octree reduction.
ImGearPicturizePreprocessedCollection Class
Preprocesses and stores a collection of cell images for Picturize effect.
ImGearPicturizeMatchingMatrix Class
Matches cell images to fragments of the image to which the Picturize effect will be applied.
ImGearPixelateBorderParams Class
Describes border characteristics of the Pixelate operation.
ImGearPixelateCellParams Class
Describes cell parameters of the Pixelate operation.
ImGearPixelateFillParams Class
Describes fill characteristics of the Pixelate operation.
ImGearPixelCheckerRedEyeRGB Class
Checks the RGB pixel using red-eye detection algorithm.
ImGearPixelCheckerThreshold Class
Checks the pixel using the initial pixel and the threshold.
ImGearPixelProcessorRedEyeRGB Class
Processes the RGB pixel using red-eye removal algorithm.
ImGearPopularityReductionOptions Class
Defines reduction options for popularity reduction.
ImGearPreserveBlackInterpolationOptions Class
Identifies options for interpolation with black color preservation.
ImGearPreserveWhiteInterpolationOptions Class
Identifies options for interpolation with white color preservation.
ImGearProcessing Class
Main class of the Processing component.
ImGearProcessingVerifier Class
Contains static methods that check whether the ImGearProcessing operation is applicable to the page or not.
ImGearRasterProcessing Class
Contains all IG raster processing methods.
ImGearRasterProcessingVerifier Class
Contains static methods that check whether the ImGearRasterProcessing operation is applicable to the page or not.
ImGearReductionOptions Class
Specifies options for performing color reduction using the Reduce Method.
ImGearScaleReductionOptions Class
Defines reduction options for scale reduction.
ImGearSpotlight Class
This class contains parameters of a spotlight that can be used to highlight an image.
ImGearWhiteBalance Class
Represents white balance as a pair of color temperature and tint.

Structures:
Name
Description
ImGearChannelRef Structure
Represents a particular image channel as an ImGearPage Class instance and number of channels in its image.
ImGearChannelStatistics Structure
Stores statistics for an image channel.
ImGearPicturizeDistributionSettings Structure
Stores cell image distribution settings for the Picturize effect.
ImGearPicturizeMatchingSettings Structure
Stores the settings that specify how the Picturize Method will match cell images to fragments of the source image.
ImGearPicturizeMixingSettings Structure
Stores the settings that specify how the Picturize Method can modify cell images for the Picturize effect.

Interfaces:
Name
Description
IImGearPixelChecker Interface
An implementation of this interface is passed to DetectArea method.
IImGearPixelProcessor Interface
An implementation of this interface is passed to ProcessArea method.

Enumerations:
Name
Description
ImGearBitonalReductionModes Enumeration
Specifies modes for the bitonal color reduction methods.
ImGearBrushType Enumeration
Specifies types of the brush for the Pointillist effect.
ImGearCFAColor Enumeration
Specifies the available colors for Color Filter Array encoded images.
ImGearChannelGroups Enumeration
Specifies constants for access to different groups of DIB channels.
ImGearContrastModes Enumeration
Specifies contrast processing modes.
ImGearConvolutionResults Enumeration
Specifies types of convolution result.
ImGearDirection Enumeration
Defines a direction of a shadow effect.
ImGearEdgeDetectionMethods Enumeration
Defines the edge detection methods available.
ImGearEdgeMapMethods Enumeration
Specifies types of edge map operation.
ImGearHalftoneReductionModes Enumeration
Specifies mode of halftone color reduction method.
ImGearIlluminant Enumeration
Lists standard illuminants.
ImGearInterpolations Enumeration
Specifies type of interpolation method.
ImGearLensFlareType Enumeration
Specifies types of lens flare.
ImGearMergeModes Enumeration
Identifies the type of arithmetic operation (merge method) that is performed on the values of all intersecting pixels resulting from the merge.
ImGearMonochromeFilmPreset
Identifies preset parameters for the MonochromeFilm Method.
ImGearMosaicType Enumeration
Defines a type of Mosaic effect.
ImGearNightVisionPresets Enumeration
This enumeration represents the preset Night Vision effects supported by ImageGear.
ImGearPixelateCellType Enumeration
Defines cell type for Pixelate operation.
ImGearPixelateFillMethod Enumeration
Defines fill method for Pixelate operation.
ImGearReductionMethods Enumeration
Specifies ImageGear color reduction methods.
ImGearRipplePattern Enumeration
Specifies predefined patterns for the Ripple effect.
ImGearRotationModes Enumeration
Specifies ImageGear rotation mode.
ImGearShearFillStyle Enumeration
Specifies Shear effect fill styles.
ImGearWhiteBalancePreset Enumeration
Lists constants for preset white balance values.


ImageGear.Processing Classes

The ImageGear.Processing Namespace has the following class members:

Classes:
Name
Description
ImGearAverageInterpolationOptions Class
Identifies options for average interpolation.
ImGearBayerReductionOptions Class
Defines reduction options for Bayer reduction.
ImGearBicubicInterpolationOptions Class
Identifies options for bilinear interpolation.
ImGearBilinearInterpolationOptions Class
Identifies options for bilinear interpolation.
ImGearBitonalReductionOptions Class
Defines reduction options for bitonal reduction.
ImGearCameraRawProcessing Class
Contains methods for color reconstruction of digital camera RAW images.
ImGearColorInterpolationOptions Class
This is the class for color interpolation options.
ImGearContrastOptions Class
This is the class for contrast options.
ImGearDiffuseReductionOptions Class
Defines reduction options for diffuse reduction.
ImGearGrayScaleInterpolationOptions Class
Interpolation options class that defines a threshold of ScaleToGray interpolation. Derived from ImGearInterpolationOptions Class.
ImGearHalftoneReductionOptions Class
Defines reduction options for halftone reduction.
ImGearInterpolationOptions Class
Base class for all interpolation options passed to ResizeImage and CreateThumbnail methods.
ImGearMedianCutReductionOptions Class
Defines reduction options for median cut reduction.
ImGearMosaicBorderParams Class
Describes border characteristics of the Mosaic operation.
ImGearMosaicCellParams Class
Describes cell parameters of the Mosaic operation.
ImGearMosaicFillParams Class
Describes fill characteristics of the Mosaic operation.
ImGearMosaicShadowParams Class
Describes parameters of the shadow effect to be applied to an image after dividing on the cells.
ImGearNearestNeighborInterpolationOptions Class
Identifies options for nearestneighbor interpolation.
ImGearNoneInterpolationOptions Class
Implements ImGearNoneInterpolationOptions interface for the case when interpolation is not needed.
ImGearOctreeReductionOptions Class
Defines reduction options for octree reduction.
ImGearPicturizePreprocessedCollection Class
Preprocesses and stores a collection of cell images for Picturize effect.
ImGearPicturizeMatchingMatrix Class
Matches cell images to fragments of the image to which the Picturize effect will be applied.
ImGearPixelateBorderParams Class
Describes border characteristics of the Pixelate operation.
ImGearPixelateCellParams Class
Describes cell parameters of the Pixelate operation.
ImGearPixelateFillParams Class
Describes fill characteristics of the Pixelate operation.
ImGearPixelCheckerRedEyeRGB Class
Checks the RGB pixel using red-eye detection algorithm.
ImGearPixelCheckerThreshold Class
Checks the pixel using the initial pixel and the threshold.
ImGearPixelProcessorRedEyeRGB Class
Processes the RGB pixel using red-eye removal algorithm.
ImGearPopularityReductionOptions Class
Defines reduction options for popularity reduction.
ImGearPreserveBlackInterpolationOptions Class
Identifies options for interpolation with black color preservation.
ImGearPreserveWhiteInterpolationOptions Class
Identifies options for interpolation with white color preservation.
ImGearProcessing Class
Main class of the Processing component.
ImGearProcessingVerifier Class
Contains static methods that check whether the ImGearProcessing operation is applicable to the page or not.
ImGearRasterProcessing Class
Contains all IG raster processing methods.
ImGearRasterProcessingVerifier Class
Contains static methods that check whether the ImGearRasterProcessing operation is applicable to the page or not.
ImGearReductionOptions Class
Specifies options for performing color reduction using the Reduce Method.
ImGearScaleReductionOptions Class
Defines reduction options for scale reduction.
ImGearSpotlight Class
This class contains parameters of a spotlight that can be used to highlight an image.
ImGearWhiteBalance Class
Represents white balance as a pair of color temperature and tint.


ImGearAverageInterpolationOptions Class

32-bit
64-bit
CF
P
P
P

Description:

Identifies options for average interpolation. This class has no public fields and methods and is used to identify average interpolation by itself in image processing functions.

Declaration:

public class ImGearAverageInterpolationOptions :
ImageGear.Processing.ImGearInterpolationOptions

Members:

Constructors
Name
Description
ImGearAverageInterpolationOptions Constructor
Initializes new instance of ImGearInterpolationOptions Class.

See Also:

ImGearInterpolationOptions Class


ImGearAverageInterpolationOptions Constructors

The ImGearAverageInterpolationOptions Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearAverageInterpolationOptions Constructor
Initializes new instance of ImGearInterpolationOptions Class.


ImGearAverageInterpolationOptions Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor initializes the new instance of ImGearAverageInterpolationOptions Class.

Declaration:

public ImGearAverageInterpolationOptions()

Return Value:

The new instance of ImGearAverageInterpolationOptions Class.

See Also:

ImGearAverageInterpolationOptions Class


ImGearBayerReductionOptions Class

32-bit
64-bit
CF
P
P
P

Description:

This class defines reduction options for Bayer reduction. A Bayer dithering algorithm is used to reduce the number of colors (or shades of gray) in the image. Note that setting the output channel depth to 1 will reduce the image to monochrome or black-and-white. Also, the output channel depth must be less than the input channel depth, or an error will result.

Declaration:

public class ImGearBayerReductionOptions

Members:

Constructors
Name
Description
ImGearBayerReductionOptions Constructor
Initializes new instance of ImGearBayerReductionOptions Class.

Fields
Name
Description
Palette Field
Palette with colors to use for output.


ImGearBayerReductionOptions Constructors

The ImGearBayerReductionOptions Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearBayerReductionOptions Constructor
Initializes new instance of ImGearBayerReductionOptions Class.


ImGearBayerReductionOptions Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor initializes the new instance of ImGearBayerReductionOptions Class.

Declaration:

public ImGearBayerReductionOptions()

Return Value:

The new instance of ImGearBayerReductionOptions Class.

See Also:

ImGearBayerReductionOptions Class


ImGearBayerReductionOptions Fields

The ImGearBayerReductionOptions Class of the ImageGear.Processing Namespace namespace has the following fields:

Fields
Name
Description
Palette Field
Palette with colors to use for output.


Palette Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you specify a palette containing the colors to use for the output image. It's only used when the output channel depth is 4. If no palette is specified, a default palette is used.

Declaration:

public ImageGear.Core.ImGearRGBQuad[] Palette

Value:

A 16-color palette, or NULL.

See Also:

ImGearRGBQuad Structure


ImGearBicubicInterpolationOptions Class

32-bit
64-bit
CF
P
P
P

Description:

This class defines interpolation options for bicubic interpolation. This class has no public fields and methods and is used to identify bilinear interpolation by itself in image processing functions.

Declaration:

public ImGearBicubicInterpolationOptions()

Class Members:

Constructors
Name
Description
ImGearBicubicInterpolationOptions Constructor
Initializes new instance of ImGearBicubicInterpolationOptions class.

Properties
Name
Description
Sharpness Property
Affects the sharpness of the resized image if the image is being scaled down.

Sample Code:

C#
// Resizes an image to 128 pixels wide maintaining aspect ratio using bicubic resizing.
int newHeight = 128 * igRasterPage.DIB.Height / igRasterPage.DIB.Width;
ImGearBicubicInterpolationOptions igBicubicInterpolationOptions = new ImGearBicubicInterpolationOptions();
igBicubicInterpolationOptions.Sharpness = 1.5;
ImGearProcessing.Resize(igRasterPage, 128, newHeight, igBicubicInterpolationOptions);

VB .NET
' Resizes an image to 128 pixels wide maintaining aspect ratio using bicubic resizing.
Dim newHeight As Integer = 128 * igRasterPage.DIB.Height / igRasterPage.DIB.Width
Dim igBicubicInterpolationOptions As New ImGearBicubicInterpolationOptions()
igBicubicInterpolationOptions.Sharpness = 1.5
ImGearProcessing.Resize(igRasterPage, 128, newHeight, igBicubicInterpolationOptions)

See Also:

ImGearBilinearInterpolationOptions Class


ImGearBicubicInterpolationOptions Constructors

The ImGearBicubicInterpolationOptions Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearBicubicInterpolationOptions Constructor
Initializes new instance of ImGearBicubicInterpolationOptions class


ImGearBicubicInterpolationOptions Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor initializes the instance of ImGearBicubicInterpolationOptions Class.

Declaration:

public ImGearBicubicInterpolationOptions()

Return Value:

The new instance of ImGearBicubicInterpolationOptions Class.

See Also:

ImGearBicubicInterpolationOptions Class


ImGearBicubicInterpolationOptions Properties

The ImGearBicubicInterpolationOptions Class of the ImageGear.Processing Namespace namespace has the following properties:

Properties
Name
Description
Sharpness Property
Affects the sharpness of the resized image if the image is being scaled down.


Sharpness Property

32-bit
64-bit
CF
P
P
P

Description:

This property affects the sharpness of the resized image if the image is being scaled down. Larger values result in a sharper image.

NOTE: A specific sharpness value (such as 1.0) does not necessarily yield the same sharpness when performing the same operation with bilinear versus bicubic interpolation.

Declaration:

public double Sharpness [ get, set ]

Value:

Any positive value.

Default Value:

1.35

See Also:

AccuSoft Corporation
 AccuSoft.com
sales@accusoft.com


ImGearBilinearInterpolationOptions Class

32-bit
64-bit
CF
P
P
P

Description:

This class defines interpolation options for bilinear interpolation. This class has no public fields and methods and is used to identify bilinear interpolation by itself in image processing functions.

Declaration:

public ImGearBilinearInterpolationOptions()

Members:

Constructors
Name
Description
ImGearBilinearInterpolationOptions Constructor
Initializes a new instance of ImGearBilinearInterpolationOptions class.

Properties
Name
Description
Sharpness Property
Affects the sharpness of the resized image if the image is being scaled down.

See Also:

ImGearBicubicInterpolationOptions Class


ImGearBilinearInterpolationOptions Constructors

The ImGearBilinearInterpolationOptions Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearBilinearInterpolationOptions Constructor
Initializes a new instance of ImGearBilinearInterpolationOptions class.


ImGearBilinearInterpolationOptions Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor initializes the new instance of ImGearBilinearInterpolationOptions Class.

Declaration:

public ImGearBilinearInterpolationOptions()

Return Value:

The new instance of ImGearBilinearInterpolationOptions Class.

See Also:

ImGearBilinearInterpolationOptions Class


ImGearBilinearInterpolationOptions Properties

The ImGearBilinearInterpolationOptions Class of the ImageGear.Processing Namespace namespace has the following properties:

Properties
Name
Description
Sharpness Property
Affects the sharpness of the resized image if the image is being scaled down.


Sharpness Property

32-bit
64-bit
CF
P
P
P

Description:

This property affects the sharpness of the resized image if the image is being scaled down. Larger values result in a sharper image.

NOTE: A specific sharpness value (such as 1.0) does not necessarily yield the same sharpness when performing the same operation with bilinear versus bicubic interpolation.

Declaration:

public double Sharpness [ get, set ]

Value:

Any positive value.

Default Value:

0.75

See Also:

AccuSoft Corporation
 AccuSoft.com
sales@accusoft.com


ImGearBitonalReductionOptions Class

32-bit
64-bit
CF
P
P
P

Description:

This class defines reduction options for bitonal reduction. Bitonal reduction reduces an image to black and white by comparing each pixel to a threshold value. Several modes, defined in ImGearBitonalReductionModes, are available for determining how the red, green, and blue color components of a pixel contribute to its brightness when compared to the threshold value.

If you set Mode to WEIGHTED, you may also set the values of Weight1, Weight2, and Weight3. These "weights" are used to determine how much influence the values of the red, green, or blue pixels will have on the reduction. For example, if Weight1 (red) = 255, Weight2 (green) = 0, Weight3 (blue) = 0, the whole reduction will depend on the value of the red pixels. The green and blue pixel values will have "no weight."

Setting Mode to GRAYSCALE gives the most weight to the value of green. This optimizes for the perception of the human eye, in which blue is the hardest color to see, and therefore requires the least weight.

A Mode of AVERAGE gives equal weight to all three pixel values.

Here are the formulas used by the three different reduction methods:

  • GRAYSCALE: value = (red*77 + green*151 + blue*28)/256;
  • AVERAGE: value = (red + green + blue)/3;
  • WEIGHTED: value = (red*w1 + green*w2 + blue*w3)/(w1 + w2 + w3);

Use the Threshold option to set the threshold value for converting pixels to black or white. If the value, as calculated by one of the above reduction methods, is less than Threshold, the pixels will be set to black; if it is greater than or equal to Threshold, the pixels will be set to white.

Declaration:

public class ImGearBitonalReductionOptions

Members:

Constructors
Name
Description
ImGearBitonalReductionOptions Constructor
Initializes new instance of ImGearBitonalReductionOptions class.

Properties
Name
Description
Mode Field
A mode to use for bitonal reduction which determines how color components of input pixels are weighted.
Threshold Field
An integer value that specifies which pixel values will be changed to black, and which pixel values will be changed to white. Pixels with values greater than Threshold will be changed to white, and pixels that have values less than Threshold will be changed to black.
Weight1 Field
Weight given to red color component. Only used if Mode is set to WEIGHTED. The range of values is 0 - 255. The default values are 255.
Weight2 Field
Weight given to green color component. Only used if Mode is set to WEIGHTED. The range of values is 0 - 255. The default values are 255.
Weight3 Field
Weight given to blue color component. Only used if Mode is set to WEIGHTED. The range of values is 0 - 255. The default values are 255.


ImGearBitonalReductionOptions Constructors

The ImGearBitonalReductionOptions Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearBitonalReductionOptions Constructor
Initializes new instance of ImGearBitonalReductionOptions class.


ImGearBitonalReductionOptions Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor initializes the new instance of ImGearBitonalReductionOptions Class.

Declaration:

public ImGearBitonalReductionOptions()

Return Value:

The new instance of ImGearBitonalReductionOptions Class.

See Also:

ImGearBitonalReductionOptions Class


ImGearBitonalReductionOptions Fields

The ImGearBitonalReductionOptions Class of the ImageGear.Processing Namespace namespace has the following fields:

Fields
Name
Description
Mode Field
A mode to use for bitonal reduction, which determines how color components of input pixels are weighted.
Threshold Field
An integer value that specifies which pixel values will be changed to black, and which pixel values will be changed to white. Pixels with values greater than Threshold will be changed to white, and pixels that have values less than Threshold will be changed to black.
Weight1 Field
Weight given to red color component. Only used if Mode is set to WEIGHTED. The range of values is 0 - 255. The default values are 255.
Weight2 Field
Weight given to green color component. Only used if Mode is set to WEIGHTED. The range of values is 0 - 255. The default values are 255.
Weight3 Field
Weight given to blue color component. Only used if Mode is set to WEIGHTED. The range of values is 0 - 255. The default values are 255.


Mode Field

32-bit
64-bit
CF
P
P
P

Description:

This option specifies a mode to use for bitonal reduction. This mode determines how the red, green, and blue color components of a pixel contribute to its brightness when compared to the threshold value.

If you set Mode to WEIGHTED, you may also set the values of Weight1, Weight2, and Weight3. These "weights" are used to determine how much influence the values of the red, green, or blue pixels will have on the reduction. For example, if Weight1 (red) = 255, Weight2 (green) = 0, Weight3 (blue) = 0, the whole reduction will depend on the value of the red pixels. The green and blue pixel values will have "no weight."

Setting Mode to GRAYSCALE gives the most weight to the value of green. This optimizes for the perception of the human eye, in which blue is the hardest color to see, and therefore requires the least weight.

A Mode of AVERAGE gives equal weight to all three pixel values.

Here are the formulas used by the three different reduction methods:

  • GRAYSCALE: value = (red*77 + green*151 + blue*28)/256;
  • AVERAGE: value = (red + green + blue)/3;
  • WEIGHTED: value = (red*w1 + green*w2 + blue*w3)/(w1 + w2 + w3);

Declaration:

public ImGearBitonalReductionModes Mode;

Value:

Value from ImGearBitonalReductionModes Enumeration.

Default:

ImGearBitonalReductionModes.GRAYSCALE


Threshold Field

32-bit
64-bit
CF
P
P
P

Description:

This option sets the threshold value for converting pixels to black or white. If the value of a pixel, as calculated by one of the reduction methods, is less than Threshold, the pixels will be set to black; if it is greater than or equal to Threshold, the pixels will be set to white. So, a smaller value for Threshold will make the output appear more black, while a larger value will make the output appear more white.

Declaration:

public int Threshold;

Value:

Integer in the range 0-255.

Default:

128


Weight1 Field

32-bit
64-bit
CF
P
P
P

Description:

This option specifies the weight given to the red color component when considering the value of an input pixel for comparison to the Threshold Field value. This option is only used if Mode Field is set to WEIGHTED.

Declaration:

public int Weight1;

Value:

Integer in the range 0-255.

Default:

255


Weight2 Field

32-bit
64-bit
CF
P
P
P

Description:

This option specifies the weight given to the green color component when considering the value of an input pixel for comparison to the Threshold Field value. This option is only used, if Mode Field is set to WEIGHTED.

Declaration:

public int Weight2;

Value:

Integer in the range 0-255.

Default:

255


Weight3 Field

32-bit
64-bit
CF
P
P
P

Description:

This option specifies the weight given to the blue color component when considering the value of an input pixel for comparison to the Threshold Field value. This option is only used if Mode Field is set to WEIGHTED.

Declaration:

public int Weight3;

Value:

Integer in the range 0-255.

Default:

255


ImGearCameraRawProcessing Class

32-bit
64-bit
CF
P
P
P

Description:

This class contains methods for color reconstruction of digital camera RAW images.

Declaration:

public class ImGearCameraRawProcessing

Members:

Methods
Name
Description
BuildSRGBGammaLUT Method
Builds sRGB Gamma LUT.
BuildToneLUT Method
Builds tone correction LUT.
CalculateCameraToRGBMatrix Method
Calculates the matrix for conversion from camera color space to linear sRGB color space.
CalculateWhitePoint Method
Calculates the white point corresponding to neutral color in camera color space.

See Also:

ImageGear Supported Digital Camera RAW Formats Reference


ImGearCameraRawProcessing Methods

The ImGearCameraRawProcessing Class of the ImageGear.Processing Namespace namespace has the following methods:

Methods
Name
Description
BuildSRGBGammaLUT Method
Builds sRGB Gamma LUT.
BuildToneLUT Method
Builds tone correction LUT.
CalculateCameraToRGBMatrix Method
Calculates matrix for conversion from camera color space to linear sRGB color space.
CalculateWhitePoint Method
Calculates the white point corresponding to neutral color in camera color space.


BuildSRGBGammaLUT Method

32-bit
64-bit
CF
P
P
P

Description:

Builds sRGB Gamma LUT, for conversion from "linear sRGB" to standard sRGB color space.

Declaration:

public static ImageGear.Core.ImGearLUT BuildSRGBGammaLUT(int channelDepth)

Parameters:

Name
Type
Description
channelDepth
int
Bit depth of the LUT.

Return Value:

ImGearLUT Class.

See Also:

ImGearLUT Class


BuildToneLUT Method

32-bit
64-bit
CF
P
P
P

Description:

Builds tone correction LUT.

The LUT moves image's black point by 1/1000 * shadows, and adjusts the white point, which gives similar results to modifying the camera exposure.

Declaration:

public static ImageGear.Core.ImGearLUT BuildToneLUT(int channelDepth, double shadows,
double exposure)

Parameters:

Name
Type
Description
channelDepth
int
Bit depth of the LUT.
shadows
double
Amount by which to move the black point
exposure
double
Exposure compensation, measured in f/stops.

Return Value:

ImGearLUT Class.

See Also:

ImGearLUT Class


CalculateCameraToRGBMatrix Method

32-bit
64-bit
CF
P
P
P

Description:

Calculates the matrix for conversion from camera color space to linear sRGB color space, based on two known color matrices corresponding to different light conditions, and a white point. By "linear sRGB color space" we assume a linear (Gamma = 1.0) RGB color space that uses sRGB primaries and reference white. This color space can be converted to sRGB by applying sRGB gamma correction function.

If only one color matrix is known, pass null to XYZToCam2.

Dimensions of XYZToCam1 and XYZToCam2 must be equal to (n, 3), where n is channel count of native camera color space (3 or 4). Result matrix dimensions are (3, n).

Declaration:

public static double[ , ] CalculateCameraToRGBMatrix(double[ , ] XYZToCam1,
ImageGear.Processing.ImGearIlluminant Illuminant1, double[ , ] XYZToCam2,
ImageGear.Processing.ImGearIlluminant Illuminant2, ImageGear.Core.ImGearDoublePoint
WhiteXY)

Parameters:

Name
Type
Description
XYZToCam1
double
XYZ to camera matrix under Illuminant 1.
Illuminant1
ImGearIlluminant Enumeration
Illuminant 1
XYZToCam2
double
XYZ to camera matrix under Illuminant 2.
Illuminant2
ImGearIlluminant Enumeration
Illuminant 2
WhiteXY
ImGearDoublePoint Structure
XY coordinates of camera white point.

Return Value:

Double array.

See Also:

ImGearIlluminant Enumeration

ImGearDoublePoint Structure


CalculateWhitePoint Method

32-bit
64-bit
CF
P
P
P

Description:

Calculates white point corresponding to neutral color in camera color space based on two known color matrices corresponding to different light conditions.

If only one color matrix is known, pass null to XYZToCam2.

Dimensions of XYZToCam1 and XYZToCam2 must be equal to (n, 3), where n is channel count of native camera color space (3 or 4).

Declaration:

public static ImageGear.Core.ImGearDoublePoint CalculateWhitePoint(double[ , ] XYZToCam1,
ImageGear.Processing.ImGearIlluminant Illuminant1, double[ , ] XYZToCam2,
ImageGear.Processing.ImGearIlluminant Illuminant2, double[ ] NeutralColor)

Parameters:

Name
Type
Description
XYZToCam1
double
XYZ to camera matrix under Illuminant 1.
Illuminant1
ImGearIlluminant Enumeration
Illuminant 1
XYZToCam2
double
XYZ to camera matrix under Illuminant 2.
Illuminant2
ImGearIlluminant Enumeration
Illuminant 2
NeutralColor
double
Normalized coordinates of a neutral color.

Return Value:

ImGearDoublePoint Structure.

See Also:

ImGearDoublePoint Structure

ImGearIlluminant Enumeration


ImGearColorInterpolationOptions Class

32-bit
64-bit
CF
P
P
P

Description:

This is the class for color interpolation options.

Declaration:

public class ImGearColorInterpolationOptions :
ImageGear.Processing.ImGearInterpolationOptions

Members:

Constructors
Name
Description
ImGearColorInterpolationOptions Constructor
Initializes new instance of ImGearColorInterpolationOptions class.

See Also:

ImGearInterpolationOptions Class


ImGearColorInterpolationOptions Constructors

The ImGearColorInterpolationOptions Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearColorInterpolationOptions Constructor
Initializes new instance of ImGearColorInterpolationOptions class.


ImGearColorInterpolationOptions Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor initializes the new instance of ImGearColorInterpolationOptions Class.

Declaration:

public ImGearColorInterpolationOptions()

Return Value:

The new instance of ImGearColorInterpolationOptions Class.

See Also:

ImGearColorInterpolationOptions Class


ImGearContrastOptions Class

32-bit
64-bit
CF
P
P
P

Description:

This is the class for contrast options.

Declaration:

public class ImGearContrastOptions

Members:

Constructors
Name
Description
ImGearContrastOptions Constructor
Initializes new instance of ImGearContrastOptions Class.

Fields
Name
Description
IgnoreDICOMDisplaySettings Field
Determines whether to ignore DICOM display settings or not.


ImGearContrastOptions Constructors

The ImGearContrastOptions Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearContrastOptions Constructor
Initializes new instance of ImGearContrastOptions Class.


ImGearContrastOptions Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor initializes the new instance of ImGearContrastOptions Class.

Declaration:

public ImGearContrastOptions()

Return Value:

The new instance of ImGearContrastOptions Class.

See Also:

ImGearContrastOptions Class


ImGearContrastOptions Fields

The ImGearContrastOptions Class of the ImageGear.Processing Namespace namespace has the following fields:

Fields
Name
Description
IgnoreDICOMDisplaySettings Field
Determines whether to ignore DICOM display settings or not.


IgnoreDICOMDisplaySettings Field

32-bit
64-bit
CF
P
P
P

Description:

This option determines whether to ignore DICOM display settings or not.

Declaration:

public bool IgnoreDICOMDisplaySettings

Value:

true - ignore DICOM display settings, false - otherwise.

See Also:

ImGearDICOMDisplaySettings Class


ImGearDiffuseReductionOptions Class

32-bit
64-bit
CF
P
P
P

Description:

This class defines reduction options for diffuse reduction. Diffuse reduction reduces an image to either black and white or 4bpp color by performing dithering according to a threshold. The type of dithering used is known as error diffusion, which attempts to spread out error (the difference in color between input and output pixels) across a two dimensional space in the output image.

A threshold value of 128 will produce an output image in which black and white are in equal proportion. A value greater than 128 would mean more bright than dark, and a value less than 128 would mean more dark than bright.

When reducing to 4bpp, a palette containing colors to use for the output image can optionally be specified. If this palette is not supplied, a default palette will be used.

Declaration:

public class ImGearDiffuseReductionOptions

Members:

Constructors
Name
Description
ImGearDiffuseReductionOptions Constructor
Initializes new instance of ImGearDiffuseReductionOptions class.

Fields
Name
Description
Threshold Field
Threshold value for dithering, 0-255.
Palette Field
Palette with colors to use for output.


ImGearDiffuseReductionOptions Constructors

The ImGearDiffuseReductionOptions Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearDiffuseReductionOptions Constructor
Initializes new instance of ImGearDiffuseReductionOptions Class.


ImGearDiffuseReductionOptions Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor initializes the new instance of ImGearDiffuseReductionOptions Class.

Declaration:

public ImGearDiffuseReductionOptions()

Return Value:

The new instance of ImGearDiffuseReductionOptions Class.

See Also:

ImGearDiffuseReductionOptions Class


ImGearDiffuseReductionOptions Fields

The ImGearDiffuseReductionOptions Class of the ImageGear.Processing Namespace namespace has the following fields:

Constructors
Name
Description
Threshold Field
Threshold value for dithering, 0-255.
Palette Field
Palette with colors to use for output.


Threshold Field

32-bit
64-bit
CF
P
P
P

Description:

This option sets the threshold value for dithering. A threshold value of 128 will produce an output image in which black and white are in equal proportion. A value greater than 128 would mean more bright than dark, and a value less than 128 would mean more dark than bright.

Declaration:

public int Threshold;

Value:

Integer in the range 0-255.

Default:

128


Palette Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you specify a palette containing the colors to use for the output image. It's only used when the output channel depth is 4. If no palette is specified, a default palette is used.

Declaration:

public ImGearRGBQuad[] Palette;

Value:

A 16-color palette, or NULL.

Default:

NULL

See Also:

ImGearRGBQuad Structure


ImGearGrayScaleInterpolationOptions Class

32-bit
64-bit
CF
P
P
P

Description:

This class defines interpolation options for scale-to-gray interpolation.

Declaration:

public class ImGearGrayScaleInterpolationOptions: ImGearInterpolationOptions

Members:

Constructors
Name
Description
ImGearGrayScaleInterpolationOptions Constructor
Initializes a new instance of ImGearGrayScaleInterpolationOptions class.

Fields
Name
Description
Threshold Field
ScaleToGray threshold in percents.

See Also:

ImGearInterpolationOptions Class


ImGearGrayScaleInterpolationOptions Constructors

The ImGearGrayScaleInterpolationOptions Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearGrayScaleInterpolationOptions Constructor
Initializes new instance of ImGearGrayScaleInterpolationOptions class.


ImGearGrayScaleInterpolationOptions Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor initializes the new instance of ImGearGrayScaleInterpolationOptions Class.

Declaration:

public ImGearGrayScaleInterpolationOptions(Int32 Threshold)

Parameters:

Name
Description
Threshold
Interpolation threshold.

Return Value:

New instance of ImGearGrayScaleInterpolationOptions Class.

See Also:

ImGearGrayScaleInterpolationOptions Class


ImGearGrayScaleInterpolationOptions Fields

The ImGearGrayScaleInterpolationOptions Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
Threshold Field
ScaleToGray threshold in percents.


Threshold Field

32-bit
64-bit
CF
P
P
P

Description:

This field provides ScaleToGray threshold in percents.

Declaration:

public Int32 Threshold;

Value:

Integer in the range 0-100.


ImGearHalftoneReductionOptions Class

32-bit
64-bit
CF
P
P
P

Description:

This class defines reduction options for halftone reduction. Halftone reduction reduces an image to black and white in such a way that it is suitable for half-toning. The resulting image will consist of small squares of varying sizes that will give the appearance of varying shades of gray.

Declaration:

public class ImGearHalftoneReductionOptions

Members:

Constructors
Name
Description
ImGearHalftoneReductionOptions Constructor
Initializes new instance of ImGearHalftoneReductionOptions class.

Fields
Name
Description
Mode Field
Mode to use for halftone reduction.


ImGearHalftoneReductionOptions Constructors

The ImGearHalftoneReductionOptions Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearGrayScaleInterpolationOptions Constructor
Initializes new instance of ImGearGrayScaleInterpolationOptions class.


ImGearHalftoneReductionOptions Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor initializes the new instance of ImGearHalftoneReductionOptions Class.

Declaration:

public ImGearHalftoneReductionOptions ()

Return Value:

New instance of ImGearHalftoneReductionOptions Class.

See Also:

ImGearHalftoneReductionOptions Class


ImGearHalftoneReductionOptions Fields

The ImGearHalftoneReductionOptions Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
Mode Field
Mode to use for halftone reduction.


Mode Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you specify a mode to use for halftone reduction. Possible modes are listed in the ImGearHalftoneReductionModes Enumeration. Currently the only mode is SQUARES.

Declaration:

public ImageGear.Processing.ImGearHalftoneReductionModes Mode

Value:

Value from ImGearHalftoneReductionModes Enumeration

Default:

ImGearHalftoneReductionModes.SQUARE

See Also:

ImGearHalftoneReductionModes Enumeration


ImGearInterpolationOptions Class

32-bit
64-bit
CF
P
P
P

Description:

This is the base class for all interpolation options passed to ResizeImage and CreateThumbnail methods.

Use the base class for interpolation modes that do not need additional options. Use derived classes to pass specific options. If a base class is passed for a mode that has a derived class, the default option values are used.

Declaration:

public class ImGearInterpolationOptions

Members:

Constructors
Name
Description
ImGearInterpolationOptions Constructor
Creates ImGearInterpolationOptions class instance.

Methods
Name
Description
GetDefault Method
Returns instance of options with most commonly used attributes for specified type of interpolation.


ImGearInterpolationOptions Constructors

The ImGearInterpolationOptions Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearInterpolationOptions Constructor
Initializes new instance of ImGearInterpolationOptions Class.


ImGearInterpolationOptions Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearInterpolationOptions Class.

Declaration:

protected ImGearInterpolationOptions(ImageGear.Processing.ImGearInterpolations
interpolationType)

Parameters:

Name
Type
Description
interpolationType
ImGearInterpolations Enumeration
Interpolation method.

Return Value:

The new instance of ImGearInterpolationOptions Class

See Also:

ImGearInterpolationOptions Class

ImGearInterpolations Enumeration


ImGearInterpolationOptions Methods

The ImGearInterpolationOptions Class of the ImageGear.Processing Namespace namespace has the following methods:

Methods
Name
Description
GetDefault Method
Returns instance of options with most commonly used attributes for specified type of interpolation.


GetDefault Method

32-bit
64-bit
CF
P
P
P

Description:

Returns instance of options with most commonly used attributes for specified type of interpolation.

Declaration:

public static ImageGear.Processing.ImGearInterpolationOptions
GetDefault(ImageGear.Processing.ImGearInterpolations interpolationType)

Parameters:

Name
Type
Description
interpolationType
ImGearInterpolations Enumeration
Interpolation method.

Return Value:

Instance of ImGearInterpolationOptions Class

Sample Code:

C#
// Creates a thumbnail 100 pixels wide maintaining aspect ratio.
// Determine appropriate height.
int newHeight = 100 * igPage.DIB.Height / igPage.DIB.Width;
// Set default interpolation to none.
ImGearInterpolations igInterpolations = ImGearInterpolations.NONE;
// If the image is 1-bit and larger than 100x100, use grayscale interpolation.
if (igPage is ImGearRasterPage &&
    1 == igPage.DIB.BitDepth &&
    igPage.DIB.Width >= 100 &&
    igPage.DIB.Height >= 100)
{
    igInterpolations = ImGearInterpolations.GRAYSCALE;
}
// Create the thumbnail using the default options for the chosen interpolation.
ImGearPage igPageThumbnail = ImGearProcessing.CreateThumbnail(igPage, 100, newHeight,
    ImGearInterpolationOptions.GetDefault(igInterpolations));

VB .NET
' Creates a thumbnail 100 pixels wide maintaining aspect ratio.
' Determine appropriate height.
Dim newHeight As Integer = 100 * igPage.DIB.Height / igPage.DIB.Width
' Set default interpolation to none.
Dim igInterpolations As ImGearInterpolations = ImGearInterpolations.NONE
' If the image is 1-bit and larger than 100x100, use grayscale interpolation.
If TypeOf igPage Is ImGearRasterPage AndAlso 1 = igPage.DIB.BitDepth AndAlso _
 igPage.DIB.Width >= 100 AndAlso igPage.DIB.Height >= 100 Then
    igInterpolations = ImGearInterpolations.GRAYSCALE
End If
' Create the thumbnail using the default options for the chosen interpolation.
Dim igPageThumbnail As ImGearPage
igPageThumbnail = ImGearProcessing.CreateThumbnail(igPage, 100, newHeight, _
 ImGearInterpolationOptions.GetDefault(igInterpolations))

See Also:

ImGearInterpolationOptions Class

ImGearInterpolations Enumeration


ImGearMedianCutReductionOptions Class

32-bit
64-bit
CF
P
P
P

Description:

This class defines reduction options for median cut reduction. Median cut reduction reduces an image to 8bpp by dividing it into a number of equally sized squares. The number of squares is equal to the number of desired output colors. The colors of the pixels in each square will be averaged to produce a resulting color. The resulting image will contain only these colors.

Declaration:

public class ImGearMedianCutReductionOptions

Members:

Constructors
Name
Description
ImGearMedianCutReductionOptions Constructor
Creates ImGearMedianCutReductionOptions class instance.

Fields
Name
Description
FastRemap Field
Set to true to optimize for speed, rather than quality.
MaxColors Field
Maximum number of colors used by the output image.


ImGearMedianCutReductionOptions Constructors

The ImGearMedianCutReductionOptions Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearMedianCutReductionOptions Constructor
Initializes new instance of ImGearMedianCutReductionOptions class.


ImGearMedianCutReductionOptions Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearMedianCutReductionOptions Class.

Declaration:

public ImGearMedianCutReductionOptions()

Return Value:

The new instance of ImGearMedianCutReductionOptions Class

See Also:

ImGearMedianCutReductionOptions Class


ImGearInterpolationOptions Fields

The ImGearMedianCutReductionOptions Class of the ImageGear.Processing Namespace namespace has the following fields:

Fields
Name
Description
FastRemap Field
Set to true to optimize for speed, rather than quality.
MaxColors Field
Maximum number of colors used by the output image.


FastRemap Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you optimize the median cut reduction for speed or quality. Set to true to optimize for speed, or false to optimize for quality.

Declaration:

public bool FastRemap;

Value:

True (optimize for speed) or false (optimize for quality).

Default:

False (optimize for quality).


MaxColors Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you specify the maximum number of colors in the output image. This can range from 16 to 256. Note that no matter how many colors are specified here, the output image will always be 8bpp indexed.

Declaration:

public int MaxColors;

Value:

Integer from 16 to 256

Default:

256


ImGearMosaicBorderParams Class

32-bit
64-bit
CF
P
P
P

Description:

This class describes border characteristics of the Mosaic operation.

Declaration:

public class ImGearMosaicBorderParams

Members:

Constructors
Name
Description
ImGearMosaicBorderParams Constructor
Creates ImGearMosaicBorderParams class instance.

Fields
Name
Description
Color Field
Color of the border.
Height Field
Height of the border.
Irregularity Field
Irregularity of the border.
Opacity Field
Border opacity.
Width Field
Width of the border.

Sample Code:

C#
// Applies a mosaic effect to an image.
// Parameter classes for Mosaic function.
ImGearMosaicFillParams igMosaicFillParams = new ImGearMosaicFillParams();
ImGearMosaicCellParams igMosaicCellParams = new ImGearMosaicCellParams();
ImGearMosaicBorderParams igMosaicBorderParams = new ImGearMosaicBorderParams();
ImGearMosaicShadowParams igMosaicShadowParams = new ImGearMosaicShadowParams();
//Color for fill and border.
ImGearPixel igPixel = new ImGearPixel(igRasterPage.DIB.ChannelCount, igRasterPage.DIB.BitsPerChannel);
//Set the color to a dark gray based on the bits per channel.
for (int i = 0; i < igPixel.ChannelCount; ++i)
    igPixel[i] = (int)Math.Pow(2, igRasterPage.DIB.BitsPerChannel) / 4;
// Cell parameters
igMosaicCellParams.Type = ImGearMosaicType.Cartesian;
igMosaicCellParams.Width = 32;
igMosaicCellParams.Height = 32;
igMosaicCellParams.PolarCenterX = 100;
igMosaicCellParams.PolarCenterY = 100;
// Fill parameters
igMosaicFillParams.Color = igPixel;
igMosaicFillParams.Opacity = (float)0.20;
// Border parameters
igMosaicBorderParams.Width = 0;
igMosaicBorderParams.Height = 0;
igMosaicBorderParams.Color = igPixel;
igMosaicBorderParams.Opacity = (float)0.30;
igMosaicBorderParams.Irregularity = 0;
// Shadow Parameters
igMosaicShadowParams.Enabled = true;
igMosaicShadowParams.Threshold = 0;
igMosaicShadowParams.Direction = ImGearDirection.SouthEast;
igMosaicShadowParams.HighResolution = false;
igMosaicShadowParams.Intensity = (float)1.0;
ImGearRasterProcessing.Mosaic(igRasterPage,
    igMosaicFillParams,
    igMosaicCellParams,
    igMosaicBorderParams,
    igMosaicShadowParams);

VB .NET
' Applies a mosaic effect to an image.
' Parameter classes for Mosaic function.
Dim igMosaicFillParams As New ImGearMosaicFillParams()
Dim igMosaicCellParams As New ImGearMosaicCellParams()
Dim igMosaicBorderParams As New ImGearMosaicBorderParams()
Dim igMosaicShadowParams As New ImGearMosaicShadowParams()
'Color for fill and border.
Dim igPixel As New ImGearPixel(igRasterPage.DIB.ChannelCount, igRasterPage.DIB.BitsPerChannel)
For i As Integer = 0 To igPixel.ChannelCount - 1
    igPixel(i) = CInt(Math.Pow(2, igRasterPage.DIB.BitsPerChannel)) / 4
Next
'Set the color to a dark gray based on the bits per channel.
' Cell parameters
igMosaicCellParams.Type = ImGearMosaicType.Cartesian
igMosaicCellParams.Width = 32
igMosaicCellParams.Height = 32
igMosaicCellParams.PolarCenterX = 100
igMosaicCellParams.PolarCenterY = 100
' Fill parameters
igMosaicFillParams.Color = igPixel
igMosaicFillParams.Opacity = CSng(0.2)
' Border parameters
igMosaicBorderParams.Width = 0
igMosaicBorderParams.Height = 0
igMosaicBorderParams.Color = igPixel
igMosaicBorderParams.Opacity = CSng(0.3)
igMosaicBorderParams.Irregularity = 0
' Shadow Parameters
igMosaicShadowParams.Enabled = True
igMosaicShadowParams.Threshold = 0
igMosaicShadowParams.Direction = ImGearDirection.SouthEast
igMosaicShadowParams.HighResolution = False
igMosaicShadowParams.Intensity = CSng(1)
ImGearRasterProcessing.Mosaic(igRasterPage, igMosaicFillParams, _
 igMosaicCellParams, igMosaicBorderParams, igMosaicShadowParams)


ImGearMosaicBorderParams Constructors

The ImGearMosaicBorderParams Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearMosaicBorderParams Constructor
Initializes new instance of ImGearMosaicBorderParams Class.


ImGearMosaicBorderParams Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearMosaicBorderParams Class.

Declaration:

public ImGearMosaicBorderParams()

Return Value:

The new instance of ImGearMosaicBorderParams Class

See Also:

ImGearMosaicBorderParams Class


ImGearMosaicBorderParams Fields

The ImGearMosaicBorderParams Class of the ImageGear.Processing Namespace namespace has the following fields:

Fields
Name
Description
Color Field
Color of the border.
Height Field
Height of the border.
Irregularity Field
Irregularity of the border.
Opacity Field
Border opacity.
Width Field
Width of the border.


Color Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you specify the color of the border.

Declaration:

public ImageGear.Core.ImGearPixel Color

Value:

ImGearPixel Class

Default:

N/A

See Also:

ImGearPixel Class


Height Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you specify the height of the border, in pixels.

Declaration:

public int Height

Value:

Any Integer value.

Default:

N/A


Irregularity Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you specify the irregularity of the border. This value must be greater than or equal to zero.

Declaration:

public int Irregularity

Value:

Any Integer value.

Default:

Null


Opacity Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you specify the border opacity, where 0.0 is transparent and 1.0 is opaque.

Declaration:

public float Opacity

Value:

Value range is 0...1

Default:

Null


Width Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you specify the width of the border, in pixels.

Declaration:

public int Width

Value:

Any Integer value.

Default:

N/A


ImGearMosaicCellParams Class

32-bit
64-bit
CF
P
P
P

Description:

This class describes cell parameters of the Mosaic operation.

Declaration:

public class ImGearMosaicCellParams

Members:

Constructors
Name
Description
ImGearMosaicCellParams Constructor
Creates ImGearMosaicCellParams class instance.

Fields
Name
Description
Height Field
Height of the cell.
PolarCenterX Field
X center of the coordinate system.
PolarCenterY Field
Y center of the coordinate system.
Type Field
Type of mosaic.
Width Field
Width of the cell.

Sample Code:

C#
// Applies a mosaic effect to an image.
// Parameter classes for Mosaic function.
ImGearMosaicFillParams igMosaicFillParams = new ImGearMosaicFillParams();
ImGearMosaicCellParams igMosaicCellParams = new ImGearMosaicCellParams();
ImGearMosaicBorderParams igMosaicBorderParams = new ImGearMosaicBorderParams();
ImGearMosaicShadowParams igMosaicShadowParams = new ImGearMosaicShadowParams();
//Color for fill and border.
ImGearPixel igPixel = new ImGearPixel(igRasterPage.DIB.ChannelCount, igRasterPage.DIB.BitsPerChannel);
//Set the color to a dark gray based on the bits per channel.
for (int i = 0; i < igPixel.ChannelCount; ++i)
    igPixel[i] = (int)Math.Pow(2, igRasterPage.DIB.BitsPerChannel) / 4;
// Cell parameters
igMosaicCellParams.Type = ImGearMosaicType.Cartesian;
igMosaicCellParams.Width = 32;
igMosaicCellParams.Height = 32;
igMosaicCellParams.PolarCenterX = 100;
igMosaicCellParams.PolarCenterY = 100;
// Fill parameters
igMosaicFillParams.Color = igPixel;
igMosaicFillParams.Opacity = (float)0.20;
// Border parameters
igMosaicBorderParams.Width = 0;
igMosaicBorderParams.Height = 0;
igMosaicBorderParams.Color = igPixel;
igMosaicBorderParams.Opacity = (float)0.30;
igMosaicBorderParams.Irregularity = 0;
// Shadow Parameters
igMosaicShadowParams.Enabled = true;
igMosaicShadowParams.Threshold = 0;
igMosaicShadowParams.Direction = ImGearDirection.SouthEast;
igMosaicShadowParams.HighResolution = false;
igMosaicShadowParams.Intensity = (float)1.0;
ImGearRasterProcessing.Mosaic(igRasterPage,
    igMosaicFillParams,
    igMosaicCellParams,
    igMosaicBorderParams,
    igMosaicShadowParams);

VB .NET
' Applies a mosaic effect to an image.
' Parameter classes for Mosaic function.
Dim igMosaicFillParams As New ImGearMosaicFillParams()
Dim igMosaicCellParams As New ImGearMosaicCellParams()
Dim igMosaicBorderParams As New ImGearMosaicBorderParams()
Dim igMosaicShadowParams As New ImGearMosaicShadowParams()
'Color for fill and border.
Dim igPixel As New ImGearPixel(igRasterPage.DIB.ChannelCount, igRasterPage.DIB.BitsPerChannel)
For i As Integer = 0 To igPixel.ChannelCount - 1
    igPixel(i) = CInt(Math.Pow(2, igRasterPage.DIB.BitsPerChannel)) / 4
Next
'Set the color to a dark gray based on the bits per channel.
' Cell parameters
igMosaicCellParams.Type = ImGearMosaicType.Cartesian
igMosaicCellParams.Width = 32
igMosaicCellParams.Height = 32
igMosaicCellParams.PolarCenterX = 100
igMosaicCellParams.PolarCenterY = 100
' Fill parameters
igMosaicFillParams.Color = igPixel
igMosaicFillParams.Opacity = CSng(0.2)
' Border parameters
igMosaicBorderParams.Width = 0
igMosaicBorderParams.Height = 0
igMosaicBorderParams.Color = igPixel
igMosaicBorderParams.Opacity = CSng(0.3)
igMosaicBorderParams.Irregularity = 0
' Shadow Parameters
igMosaicShadowParams.Enabled = True
igMosaicShadowParams.Threshold = 0
igMosaicShadowParams.Direction = ImGearDirection.SouthEast
igMosaicShadowParams.HighResolution = False
igMosaicShadowParams.Intensity = CSng(1)
ImGearRasterProcessing.Mosaic(igRasterPage, igMosaicFillParams, _
 igMosaicCellParams, igMosaicBorderParams, igMosaicShadowParams)


ImGearMosaicCellParams Constructors

The ImGearMosaicCellParams Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearMosaicCellParams Constructor
Creates ImGearMosaicCellParams Class instance.


ImGearMosaicCellParams Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearMosaicCellParams Class.

Declaration:

public ImGearMosaicCellParams()

Return Value:

The new instance of ImGearMosaicCellParams Class

See Also:

ImGearMosaicCellParams Class


ImGearMosaicCellParams Fields

The ImGearMosaicCellParams Class of the ImageGear.Processing Namespace namespace has the following fields:

Fields
Name
Description
Height Field
Height of the cell.
PolarCenterX Field
X center of the coordinate system.
PolarCenterY Field
Y center of the coordinate system.
Type Field
Type of mosaic.
Width Field
Width of the cell.


Height Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you specify the height of the cell, in pixels.

Declaration:

public int Height

Value:

Any integer value.

Default:

N/A

See Also:

N/A


PolarCenterX Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you specify the x center of the coordinate system, if Type Field is ImGearMosaicType.Polar or ImGearMosaicType.Spiderweb.

Declaration:

public int PolarCenterX

Value:

Any Integer value.

Default:

N/A

See Also:

ImGearMosaicType Enumeration

Type Field


PolarCenterY Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you specify the y center of the coordinate system, if Type Field is ImGearMosaicType.Polar or ImGearMosaicType.Spiderweb.

Declaration:

public int PolarCenterY

Value:

Any Integer value.

Default:

N/A

See Also:

ImGearMosaicType Enumeration

Type Field


Type Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you specify the type of mosaic. See ImGearMosaicType Enumeration for detail.

Declaration:

public ImageGear.Processing.ImGearMosaicType Type

Value:

ImGearMosaicType Enumeration value

Default:

N/A

See Also:

ImGearMosaicType Enumeration

PolarCenterX Field

PolarCenterY Field


Width Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you specify the width of the cell, in pixels.

Declaration:

public int Width

Value:

Any Integer value.

Default:

N/A


ImGearMosaicFillParams Class

32-bit
64-bit
CF
P
P
P

Description:

This class describes fill characteristics of the Mosaic operation.

Declaration:

public class ImGearMosaicFillParams

Members:

Constructors
Name
Description
ImGearMosaicFillParams Constructor
Creates ImGearMosaicFillParams class instance.

Fields
Name
Description
Color Field
Fill color.
Opacity Field
Opacity of the cell.

Sample Code:

C#
// Applies a mosaic effect to an image.
// Parameter classes for Mosaic function.
ImGearMosaicFillParams igMosaicFillParams = new ImGearMosaicFillParams();
ImGearMosaicCellParams igMosaicCellParams = new ImGearMosaicCellParams();
ImGearMosaicBorderParams igMosaicBorderParams = new ImGearMosaicBorderParams();
ImGearMosaicShadowParams igMosaicShadowParams = new ImGearMosaicShadowParams();
//Color for fill and border.
ImGearPixel igPixel = new ImGearPixel(igRasterPage.DIB.ChannelCount, igRasterPage.DIB.BitsPerChannel);
//Set the color to a dark gray based on the bits per channel.
for (int i = 0; i < igPixel.ChannelCount; ++i)
    igPixel[i] = (int)Math.Pow(2, igRasterPage.DIB.BitsPerChannel) / 4;
// Cell parameters
igMosaicCellParams.Type = ImGearMosaicType.Cartesian;
igMosaicCellParams.Width = 32;
igMosaicCellParams.Height = 32;
igMosaicCellParams.PolarCenterX = 100;
igMosaicCellParams.PolarCenterY = 100;
// Fill parameters
igMosaicFillParams.Color = igPixel;
igMosaicFillParams.Opacity = (float)0.20;
// Border parameters
igMosaicBorderParams.Width = 0;
igMosaicBorderParams.Height = 0;
igMosaicBorderParams.Color = igPixel;
igMosaicBorderParams.Opacity = (float)0.30;
igMosaicBorderParams.Irregularity = 0;
// Shadow Parameters
igMosaicShadowParams.Enabled = true;
igMosaicShadowParams.Threshold = 0;
igMosaicShadowParams.Direction = ImGearDirection.SouthEast;
igMosaicShadowParams.HighResolution = false;
igMosaicShadowParams.Intensity = (float)1.0;
ImGearRasterProcessing.Mosaic(igRasterPage,
    igMosaicFillParams,
    igMosaicCellParams,
    igMosaicBorderParams,
    igMosaicShadowParams);

VB .NET
' Applies a mosaic effect to an image.
' Parameter classes for Mosaic function.
Dim igMosaicFillParams As New ImGearMosaicFillParams()
Dim igMosaicCellParams As New ImGearMosaicCellParams()
Dim igMosaicBorderParams As New ImGearMosaicBorderParams()
Dim igMosaicShadowParams As New ImGearMosaicShadowParams()
'Color for fill and border.
Dim igPixel As New ImGearPixel(igRasterPage.DIB.ChannelCount, igRasterPage.DIB.BitsPerChannel)
For i As Integer = 0 To igPixel.ChannelCount - 1
    igPixel(i) = CInt(Math.Pow(2, igRasterPage.DIB.BitsPerChannel)) / 4
Next
'Set the color to a dark gray based on the bits per channel.
' Cell parameters
igMosaicCellParams.Type = ImGearMosaicType.Cartesian
igMosaicCellParams.Width = 32
igMosaicCellParams.Height = 32
igMosaicCellParams.PolarCenterX = 100
igMosaicCellParams.PolarCenterY = 100
' Fill parameters
igMosaicFillParams.Color = igPixel
igMosaicFillParams.Opacity = CSng(0.2)
' Border parameters
igMosaicBorderParams.Width = 0
igMosaicBorderParams.Height = 0
igMosaicBorderParams.Color = igPixel
igMosaicBorderParams.Opacity = CSng(0.3)
igMosaicBorderParams.Irregularity = 0
' Shadow Parameters
igMosaicShadowParams.Enabled = True
igMosaicShadowParams.Threshold = 0
igMosaicShadowParams.Direction = ImGearDirection.SouthEast
igMosaicShadowParams.HighResolution = False
igMosaicShadowParams.Intensity = CSng(1)
ImGearRasterProcessing.Mosaic(igRasterPage, igMosaicFillParams, _
 igMosaicCellParams, igMosaicBorderParams, igMosaicShadowParams)


ImGearMosaicFillParams Constructors

The ImGearMosaicFillParams Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearMosaicFillParams Constructor
Creates ImGearMosaicFillParams class instance.


ImGearMosaicFillParams Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearMosaicFillParams Class.

Declaration:

public ImGearMosaicFillParams()

Return Value:

The new instance of ImGearMosaicFillParams Class

See Also:

ImGearMosaicFillParams Class


ImGearMosaicFillParams Fields

The ImGearMosaicFillParams Class of the ImageGear.Processing Namespace namespace has the following fields:

Fields
Name
Description
Color Field
Fill color.
Opacity Field
Opacity of the cell.


Color Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you specify the fill color. This color is blended with the original cell color according to the Opacity Field.

Declaration:

public ImageGear.Core.ImGearPixel Color

Value:

ImGearPixel Class.

Default:

N/A

See Also:

Opacity Field

ImGearPixel Class


Opacity Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you specify the opacity of the cell, where 0.0 is transparent and 1.0 is opaque.

Declaration:

public float Opacity

Value:

Valid range is 0...1.

Default:

N/A

See Also:

Color Field


ImGearMosaicShadowParams Class

32-bit
64-bit
CF
P
P
P

Description:

This class describes parameters of the shadow effect to be applied to an image after dividing on the cells.

Declaration:

public class ImGearMosaicShadowParams

Members:

Constructors
Name
Description
ImGearMosaicShadowParams Constructor
Creates ImGearMosaicShadowParams class instance.

Fields
Name
Description
Direction Field
Location of the light source.
Enabled Field
Enables or disables shadow effect.
HighResolution Field
If this parameter is true then shadow effect is calculated using two neighbor pixels. This decreases 3D effect but gives the image more contrast. If false, three pixels are used for shadow effect.
Intensity Field
Shadow intensity.
Threshold Field
Minimum intensity of the pixel the shadow effect is applied to.

Sample Code:

C#
// Applies a mosaic effect to an image.
// Parameter classes for Mosaic function.
ImGearMosaicFillParams igMosaicFillParams = new ImGearMosaicFillParams();
ImGearMosaicCellParams igMosaicCellParams = new ImGearMosaicCellParams();
ImGearMosaicBorderParams igMosaicBorderParams = new ImGearMosaicBorderParams();
ImGearMosaicShadowParams igMosaicShadowParams = new ImGearMosaicShadowParams();
//Color for fill and border.
ImGearPixel igPixel = new ImGearPixel(igRasterPage.DIB.ChannelCount, igRasterPage.DIB.BitsPerChannel);
//Set the color to a dark gray based on the bits per channel.
for (int i = 0; i < igPixel.ChannelCount; ++i)
    igPixel[i] = (int)Math.Pow(2, igRasterPage.DIB.BitsPerChannel) / 4;
// Cell parameters
igMosaicCellParams.Type = ImGearMosaicType.Cartesian;
igMosaicCellParams.Width = 32;
igMosaicCellParams.Height = 32;
igMosaicCellParams.PolarCenterX = 100;
igMosaicCellParams.PolarCenterY = 100;
// Fill parameters
igMosaicFillParams.Color = igPixel;
igMosaicFillParams.Opacity = (float)0.20;
// Border parameters
igMosaicBorderParams.Width = 0;
igMosaicBorderParams.Height = 0;
igMosaicBorderParams.Color = igPixel;
igMosaicBorderParams.Opacity = (float)0.30;
igMosaicBorderParams.Irregularity = 0;
// Shadow Parameters
igMosaicShadowParams.Enabled = true;
igMosaicShadowParams.Threshold = 0;
igMosaicShadowParams.Direction = ImGearDirection.SouthEast;
igMosaicShadowParams.HighResolution = false;
igMosaicShadowParams.Intensity = (float)1.0;
ImGearRasterProcessing.Mosaic(igRasterPage,
    igMosaicFillParams,
    igMosaicCellParams,
    igMosaicBorderParams,
    igMosaicShadowParams);

VB .NET
' Applies a mosaic effect to an image.
' Parameter classes for Mosaic function.
Dim igMosaicFillParams As New ImGearMosaicFillParams()
Dim igMosaicCellParams As New ImGearMosaicCellParams()
Dim igMosaicBorderParams As New ImGearMosaicBorderParams()
Dim igMosaicShadowParams As New ImGearMosaicShadowParams()
'Color for fill and border.
Dim igPixel As New ImGearPixel(igRasterPage.DIB.ChannelCount, igRasterPage.DIB.BitsPerChannel)
For i As Integer = 0 To igPixel.ChannelCount - 1
    igPixel(i) = CInt(Math.Pow(2, igRasterPage.DIB.BitsPerChannel)) / 4
Next
'Set the color to a dark gray based on the bits per channel.
' Cell parameters
igMosaicCellParams.Type = ImGearMosaicType.Cartesian
igMosaicCellParams.Width = 32
igMosaicCellParams.Height = 32
igMosaicCellParams.PolarCenterX = 100
igMosaicCellParams.PolarCenterY = 100
' Fill parameters
igMosaicFillParams.Color = igPixel
igMosaicFillParams.Opacity = CSng(0.2)
' Border parameters
igMosaicBorderParams.Width = 0
igMosaicBorderParams.Height = 0
igMosaicBorderParams.Color = igPixel
igMosaicBorderParams.Opacity = CSng(0.3)
igMosaicBorderParams.Irregularity = 0
' Shadow Parameters
igMosaicShadowParams.Enabled = True
igMosaicShadowParams.Threshold = 0
igMosaicShadowParams.Direction = ImGearDirection.SouthEast
igMosaicShadowParams.HighResolution = False
igMosaicShadowParams.Intensity = CSng(1)
ImGearRasterProcessing.Mosaic(igRasterPage, igMosaicFillParams, _
 igMosaicCellParams, igMosaicBorderParams, igMosaicShadowParams)


ImGearMosaicShadowParams Constructors

The ImGearMosaicShadowParams Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearMosaicShadowParams Constructor
Creates ImGearMosaicShadowParams Class instance.


ImGearMosaicShadowParams Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearMosaicShadowParams Class.

Declaration:

public ImGearMosaicShadowParams()

Return Value:

The new instance of ImGearMosaicShadowParams Class

See Also:

ImGearMosaicShadowParams Class


ImGearMosaicShadowParams Fields

The ImGearMosaicShadowParams Class of the ImageGear.Processing Namespace namespace has the following fields:

Fields
Name
Description
Direction Field
Location of the light source.
Enabled Field
Enables or disables shadow effect.
HighResolution Field
If this parameter is true then shadow effect is calculated using two neighbor pixels. This decreases 3D effect but gives the image more contrast. If false, three pixels are used for shadow effect.
Intensity Field
Shadow intensity.
Threshold Field
Minimum intensity of the pixel the shadow effect is applied to.


Direction Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you specify the location of the light source.

Declaration:

public ImageGear.Processing.ImGearDirection Direction

Value:

ImGearDirection Enumeration value.

Default:

N/A

See Also:

ImGearDirection Enumeration


Enabled Field

32-bit
64-bit
CF
P
P
P

Description:

This field enables or disables shadow effect.

Declaration:

public bool Enabled

Value:

True, false.

Default:

N/A

See Also:

N/A


HighResolution Field

32-bit
64-bit
CF
P
P
P

Description:

If this parameter is true, then the shadow effect is calculated using two neighbor pixels. This decreases the 3D effect, but gives the image more contrast. If this parameter is false, three pixels are used for the shadow effect.

Declaration:

public bool HighResolution

Value:

True, false.

Default:

N/A

See Also:

N/A


Intensity Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you specify the shadow intensity.

Declaration:

public float Intensity

Value:

Must be greater than or equal to zero.

Default:

N/A

See Also:

N/A


Threshold Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you specify the minimum intensity of the pixel the shadow effect is applied to.

Declaration:

public int Threshold

Value:

Any Integer value.

Default:

N/A

See Also:

N/A


ImGearNearestNeighborInterpolationOptions Class

32-bit
64-bit
CF
P
P
P

Description:

Identifies options for nearest neighborhood interpolation. This class has no public fields and methods and is used to identify nearest neighborhood interpolation by itself in image processing functions.

Declaration:

public class ImGearNearestNeighborInterpolationOptions :
ImageGear.Processing.ImGearInterpolationOptions

Members:

Constructors
Name
Description
ImGearNearestNeighborInterpolationOptions Constructor
Initializes a new instance of ImGearNearestNeighborInterpolationOptions class.

See Also:

ImGearInterpolationOptions Class


ImGearNearestNeighborInterpolationOptions Constructors

The ImGearNearestNeighborInterpolationOptions Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearNearestNeighborInterpolationOptions Constructor
Initializes new instance of ImGearNearestNeighborInterpolationOptions Class.


ImGearNearestNeighborInterpolationOptions Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes the new instance of ImGearNearestNeighborInterpolationOptions Class.

Declaration:

public ImGearNearestNeighborInterpolationOptions()

Return Value:

New instance of ImGearNearestNeighborInterpolationOptions Class

See Also:

ImGearNearestNeighborInterpolationOptions Class


ImGearNoneInterpolationOptions Class

32-bit
64-bit
CF
P
P
P

Description:

Implements ImGearNoneInterpolationOptions interface for the case when interpolation is not needed. This class has no public fields and methods and is used to identify interpolation by itself in image processing functions.

Declaration:

public class ImGearNoneInterpolationOptions :
ImageGear.Processing.ImGearInterpolationOptions

Members:

Constructors
Name
Description
ImGearNoneInterpolationOptions Constructor
Initializes a new instance of ImGearNoneInterpolationOptions class.

See Also:

ImGearInterpolationOptions Class


ImGearNoneInterpolationOptions Constructors

The ImGearNoneInterpolationOptions Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearNoneInterpolationOptions Constructor
Initializes a new instance of ImGearNoneInterpolationOptions class.


ImGearNoneInterpolationOptions Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes the new instance of ImGearNoneInterpolationOptions Class.

Declaration:

public ImGearNoneInterpolationOptions()

Return Value:

The new instance of ImGearNoneInterpolationOptions Class.

See Also:

ImGearNoneInterpolationOptions Class


ImGearOctreeReductionOptions Class

32-bit
64-bit
CF
P
P
P

Description:

This class defines reduction options for octree reduction. Octree reduction reduces an image to 4bpp or 8bpp by repeatedly subdividing cubic representations of the RGB color space according to image content.

Declaration:

public class ImGearOctreeReductionOptions

Members:

Constructors
Name
Description
ImGearOctreeReductionOptions Constructor
Creates ImGearOctreeReductionOptions class instance.

Fields
Name
Description
FastRemap Field
Set to true to optimize for speed, rather than quality.
MaxColors Field
Maximum number of colors used by the output image.
ErrorDiffusion Field
Set to true to improve accuracy using error diffusion.
Palette Field
Palette with colors to use for output.
PaletteSize Field
Number of colors present in specified Palette.


ImGearOctreeReductionOptions Constructors

The ImGearOctreeReductionOptions Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearOctreeReductionOptions Constructor
Creates ImGearOctreeReductionOptions Class instance.


ImGearOctreeReductionOptions Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearOctreeReductionOptions Class.

Declaration:

public ImGearOctreeReductionOptions()

Return Value:

The new instance of ImGearOctreeReductionOptions Class

See Also:

ImGearOctreeReductionOptions Class


ImGearOctreeReductionOptions Fields

The ImGearOctreeReductionOptions Class of the ImageGear.Processing Namespace namespace has the following fields:

Fields
Name
Description
FastRemap Field
Set to true to optimize for speed, rather than quality.
MaxColors Field
Maximum number of colors used by the output image.
ErrorDiffusion Field
Set to true to improve accuracy using error diffusion.
Palette Field
Palette with colors to use for output.
PaletteSize Field
Number of colors present in specified Palette.


FastRemap Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you optimize the median cut reduction for speed or quality. Set to TRUE to optimize for speed, or FALSE to optimize for quality.

Declaration:

public bool FastRemap;

Value:

TRUE (optimize for speed) or false (optimize for quality).

Default:

FALSE (optimize for quality).


MaxColors Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you specify the maximum number of colors in the output image. This can range from 8 to 256. Note that if the number of colors is 16 or less, the output image will be 4bpp. Otherwise, the output image will be 8bpp.

Declaration:

public int MaxColors;

Value:

Integer from 8 to 256.

Default:

256


ErrorDiffusion Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you specify whether or not to perform error diffusion on the resulting image. Error diffusion attempts to spread out error (the difference in color between input and output pixels) across a two dimensional space in the output image. It increases overall accuracy, but can give the image a more speckled or dithered appearance. It also decreases the effectiveness of most compression algorithms since adjacent pixels are less likely to be the same color. Using octree reduction without error diffusion is sometimes known as "nearest color" reduction.

Declaration:

public bool ErrorDiffusion;

Value:

TRUE or FALSE.

Default:

TRUE


Palette Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you specify a palette containing the colors to use for the output image. If no palette is specified, an optimized palette is constructed based on the contents of the image.

Declaration:

public ImGearRGBQuad[] Palette;

Value:

A 16-256 color palette, or NULL.

Default:

NULL

See Also:

ImGearRGBQuad Structure


PaletteSize Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you specify the number of colors to use from the specified palette in the Palette Field option. If no palette is specified (Palette Field is NULL), this option is ignored and an optimized palette is automatically generated.

Declaration:

public int PaletteSize;

Value:

Integer from 8 to 256. If Palette Field is non-null, this must less than or equal to the number of colors in Palette Field, and greater than or equal to MaxColors Field.

Default:

256


ImGearPicturizePreprocessedCollection Class

32-bit
64-bit
CF
P
P
P

Description:

This class preprocesses and stores a collection of cell images for the Picturize effect.

Declaration:

public class ImGearPicturizePreprocessedCollection

Members:

Constructors
Name
Description
ImGearPicturizePreprocessedCollection Constructor
Creates the new instance of ImGearPicturizePreprocessedCollection Class.
ImGearPicturizePreprocessedCollection Constructor
Creates the new instance of ImGearPicturizePreprocessedCollection Class.

See Also:

ImGearPicturizeMatchingMatrix Class

Picturize Method


ImGearPicturizePreprocessedCollection Constructors

The ImGearPicturizePreprocessedCollection Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearPicturizePreprocessedCollection Constructor
Creates the new instance of ImGearPicturizePreprocessedCollection Class.
ImGearPicturizePreprocessedCollection Constructor
Creates the new instance of ImGearPicturizePreprocessedCollection Class.


ImGearPicturizePreprocessedCollection Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearPicturizePreprocessedCollection Class. It loads a collection of cell images, specified as a list of file names, preprocesses them and stores internally for later use in the Picturize Method.

Creation of this class serves as the first step in calculation of the Picturize effect. An instance of this class is passed to ImGearPicturizeMatchingMatrix Constructor, which in turn is passed to the Picturize method.

Declaration:

public ImGearPicturizePreprocessedCollection(ImGearRasterPage mainImage, int cellWidth,
int cellHeight, string[] cellFileNames);

Parameters:

Name
Type
Description
mainImage
ImGearRasterPage Class
Specifies the image to apply the Picturize effect to.
cellWidth
int
Specifies the width of cells in the main image that will be replaced with cell images.
cellHeight
int
Specifies the height of cells in the main image that will be replaced with cell images.
cellFileNames
string[]
Specifies the list of image file names that will be used for picturizing.

Return Value:

The new instance of ImGearPicturizePreprocessedCollection Class.

See Also:

ImGearPicturizePreprocessedCollection Class

ImGearPicturizeMatchingMatrix Class

Picturize Method


ImGearPicturizePreprocessedCollection Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearPicturizePreprocessedCollection Class. It loads a collection of cell images, specified as a list of ImGearRasterPage objects, preprocesses them and stores internally for later use in the Picturize Method.

Creation of this class serves as the first step in calculation of the Picturize effect. An instance of this class is passed to ImGearPicturizeMatchingMatrix Constructor, which in turn is passed to the Picturize method.

Declaration:

public ImGearPicturizePreprocessedCollection(ImGearRasterPage mainImage, int cellWidth,
int cellHeight, ImGearRasterPage[] cellImages);

Parameters:

Name
Type
Description
mainImage
ImGearRasterPage Class
Specifies the image to apply the Picturize effect to.
cellWidth
int
Specifies the width of cells in the main image that will be replaced with cell images.
cellHeight
int
Specifies the height of cells in the main image that will be replaced with cell images.
cellImages
ImGearRasterPage Class[]
Specifies the list of images that will be used for picturizing.

Return Value:

The new instance of ImGearPicturizePreprocessedCollection Class.

See Also:

ImGearRasterPage Class

ImGearPicturizePreprocessedCollection Class

ImGearPicturizeMatchingMatrix Class

Picturize Method


ImGearPicturizeMatchingMatrix Class

32-bit
64-bit
CF
P
P
P

Description:

This is an auxiliray class for the Picturize Method. It matches cell images to fragments of the image to which the Picturize effect will be applied.

Declaration:

public class ImGearPicturizeMatchingMatrix

Members:

Constructors
Name
Description
ImGearPicturizeMatchingMatrix Constructor
Creates the new instance of ImGearPicturizeMatchingMatrix Class.

See Also:

Picturize Method.


ImGearPicturizeMatchingMatrix Constructors

The ImGearPicturizeMatchingMatrix Class of the ImageGear.Processing Namespace has the following constructors:

Constructors
Name
Description
ImGearPicturizeMatchingMatrix Constructor
Creates the new instance of ImGearPicturizeMatchingMatrix Class.


ImGearPicturizeMatchingMatrix Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearPicturizeMatchingMatrix Class. It matches cell images to fragments of the image to which the Picturize effect will be applied.

Creation of this class serves as the second step in calculation of the Picturize effect. An instance of this class is passed to the Picturize Method.

Declaration:

public ImGearPicturizeMatchingMatrix(ImGearPicturizePreprocessedCollection
preprocessedCollection, ImGearPicturizeMatchingSettings matchingSettings);

Parameters:

Name
Type
Description
preprocessedCollection
ImGearPicturizePreprocessedCollection Class
Specifies the preprocessed collection of cell images.
matchingSettings
ImGearPicturizeMatchingSettings Structure
Specifies the settings that control how the cell images are matched to fragments of the source image.

Return Value:

The new instance of ImGearPicturizeMatchingMatrix Class.

See Also:

Picturize Method

ImGearPicturizeMatchingSettings Structure

ImGearPicturizePreprocessedCollection Class


ImGearPixelateBorderParams Class

32-bit
64-bit
CF
P
P
P

Description:

This class describes border characteristics of the Pixelate operation.

Declaration:

public class ImGearPixelateBorderParams

Members:

Constructors
Name
Description
ImGearPixelateBorderParams Constructor
Creates ImGearPixelateBorderParams class instance.

Fields
Name
Description
Color Field
Border color.
Height Field
Height of the border.
Opacity Field
Border opacity.
Width Field
Width of the border.

Sample Code:

C#
// Pixelate an image.
// Parameter classes for Pixelate function.
ImGearPixelateBorderParams igPixelateBorderParams = new ImGearPixelateBorderParams();
ImGearPixelateCellParams igPixelateCellParams = new ImGearPixelateCellParams();
ImGearPixelateFillParams igPixelateFillParams = new ImGearPixelateFillParams();
ImGearPixel igPixel = igRasterPage.DIB.GetPixelCopy(0, 0);
// cell parameters
igPixelateCellParams.Type = ImGearPixelateCellType.Rectangle;
igPixelateCellParams.Width = 8;
igPixelateCellParams.Height = 8;
// fill parameters
igPixelateFillParams.FillMethod = ImGearPixelateFillMethod.Average;
igPixelateFillParams.Color = igPixel;
igPixelateFillParams.Opacity = (float)1.00;
// Border parameters
igPixelateBorderParams.Width = 0;
igPixelateBorderParams.Height = 0;
igPixelateBorderParams.Color = igPixel;
igPixelateBorderParams.Opacity = (float)1.00;
ImGearRasterProcessing.Pixelate(igRasterPage,
        igPixelateFillParams,
        igPixelateCellParams,
        igPixelateBorderParams);

VB .NET
' Pixelate an image.
' Parameter classes for Pixelate function.
Dim igPixelateBorderParams As New ImGearPixelateBorderParams()
Dim igPixelateCellParams As New ImGearPixelateCellParams()
Dim igPixelateFillParams As New ImGearPixelateFillParams()
Dim igPixel As ImGearPixel = igRasterPage.DIB.GetPixelCopy(0, 0)
' cell parameters
igPixelateCellParams.Type = ImGearPixelateCellType.Rectangle
igPixelateCellParams.Width = 8
igPixelateCellParams.Height = 8
' fill parameters
igPixelateFillParams.FillMethod = ImGearPixelateFillMethod.Average
igPixelateFillParams.Color = igPixel
igPixelateFillParams.Opacity = CSng(1)
' Border parameters
igPixelateBorderParams.Width = 0
igPixelateBorderParams.Height = 0
igPixelateBorderParams.Color = igPixel
igPixelateBorderParams.Opacity = CSng(1)
ImGearRasterProcessing.Pixelate(igRasterPage, igPixelateFillParams, igPixelateCellParams, igPixelateBorderParams)


ImGearPixelateBorderParams Constructors

The ImGearPixelateBorderParams Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearPixelateBorderParams Constructor
Creates ImGearPixelateBorderParams class instance.


ImGearPixelateBorderParams Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearPixelateBorderParams Class.

Declaration:

public ImGearPixelateBorderParams()

Return Value:

The new instance of ImGearPixelateBorderParams Class

See Also:

ImGearPixelateBorderParams Class


ImGearPixelateBorderParams Fields

The ImGearPixelateBorderParams Class of the ImageGear.Processing Namespace namespace has the following fields:

Fields
Name
Description
Color Field
Border color.
Height Field
Height of the border.
Opacity Field
Border opacity.
Width Field
Width of the border.


Color Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you to specify the border color. Color format, that is, color space, channel count and bits per channel must correspond to the DIB color format.

Declaration:

public ImageGear.Core.ImGearPixel Color

Value:

ImGearPixel Class

Default:

N/A

See Also:

ImGearPixel Class


Height Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies the height of the border, in pixels.

Declaration:

public int Height

Value:

Any integer value.

Default:

N/A

See Also:

N/A


Opacity Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies the border opacity, where 0.0 is transparent and 1.0 is opaque.

Declaration:

public float Opacity

Value:

Value range is 0...1.

Default:

N/A

See Also:

N/A


Width Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you to specify the width of the border, in pixels.

Declaration:

public int Width

Value:

Any integer value.

Default:

N/A

See Also:

N/A


ImGearPixelateCellParams Class

32-bit
64-bit
CF
P
P
P

Description:

This class describes cell parameters of the Pixelate operation.

Declaration:

public class ImGearPixelateCellParams

Members:

Constructors
Name
Description
ImGearPixelateCellParams Constructor
Creates ImGearPixelateCellParams class instance.

Fields
Name
Description
CircleCenterX Field
X coordinate of the circle center.
CircleCenterY Field
Y coordinate of the circle center.
CircleRadius Field
Circle radius.
Height Field
Height of the cell.
RectBoundRadius Field
Round radius.
Type Field
Type of the cell.
Width Field
Width of the cell.

Sample Code:

C#
// Pixelate an image.
// Parameter classes for Pixelate function.
ImGearPixelateBorderParams igPixelateBorderParams = new ImGearPixelateBorderParams();
ImGearPixelateCellParams igPixelateCellParams = new ImGearPixelateCellParams();
ImGearPixelateFillParams igPixelateFillParams = new ImGearPixelateFillParams();
ImGearPixel igPixel = igRasterPage.DIB.GetPixelCopy(0, 0);
// cell parameters
igPixelateCellParams.Type = ImGearPixelateCellType.Rectangle;
igPixelateCellParams.Width = 8;
igPixelateCellParams.Height = 8;
// fill parameters
igPixelateFillParams.FillMethod = ImGearPixelateFillMethod.Average;
igPixelateFillParams.Color = igPixel;
igPixelateFillParams.Opacity = (float)1.00;
// Border parameters
igPixelateBorderParams.Width = 0;
igPixelateBorderParams.Height = 0;
igPixelateBorderParams.Color = igPixel;
igPixelateBorderParams.Opacity = (float)1.00;
ImGearRasterProcessing.Pixelate(igRasterPage,
        igPixelateFillParams,
        igPixelateCellParams,
        igPixelateBorderParams);

VB .NET
' Pixelate an image.
' Parameter classes for Pixelate function.
Dim igPixelateBorderParams As New ImGearPixelateBorderParams()
Dim igPixelateCellParams As New ImGearPixelateCellParams()
Dim igPixelateFillParams As New ImGearPixelateFillParams()
Dim igPixel As ImGearPixel = igRasterPage.DIB.GetPixelCopy(0, 0)
' cell parameters
igPixelateCellParams.Type = ImGearPixelateCellType.Rectangle
igPixelateCellParams.Width = 8
igPixelateCellParams.Height = 8
' fill parameters
igPixelateFillParams.FillMethod = ImGearPixelateFillMethod.Average
igPixelateFillParams.Color = igPixel
igPixelateFillParams.Opacity = CSng(1)
' Border parameters
igPixelateBorderParams.Width = 0
igPixelateBorderParams.Height = 0
igPixelateBorderParams.Color = igPixel
igPixelateBorderParams.Opacity = CSng(1)
ImGearRasterProcessing.Pixelate(igRasterPage, igPixelateFillParams, igPixelateCellParams, igPixelateBorderParams)


ImGearPixelateCellParams Constructors

The ImGearPixelateCellParams Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearPixelateCellParams Constructor
Creates ImGearPixelateCellParams Class instance.


ImGearPixelateCellParams Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearPixelateCellParams Class.

Declaration:

public ImGearPixelateCellParams()

Return Value:

The new instance of ImGearPixelateCellParams Class

See Also:

ImGearPixelateCellParams Class


ImGearPixelateCellParams Fields

The ImGearPixelateCellParams Class of the ImageGear.Processing Namespace namespace has the following fields:

Fields
Name
Description
CircleCenterX Field
X coordinate of the circle center.
CircleCenterY Field
Y coordinate of the circle center.
CircleRadius Field
Circle radius.
Height Field
Height of the cell.
RectBoundRadius Field
Round radius.
Type Field
Type of the cell.
Width Field
Width of the cell.


CircleCenterX Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you to specify the X coordinate of the circle center when Type Field == ImGearPixelateCellType.Circle .

Declaration:

public int CircleCenterX

Value:

Any integer value.

Default:

N/A

See Also:

ImGearPixelateCellType Enumeration


CircleCenterY Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies the Y coordinate of the circle center when Type Field == ImGearPixelateCellType.Circle.

Declaration:

public int CircleCenterY

Value:

Any integer value.

Default:

N/A

See Also:

ImGearPixelateCellType Enumeration


CircleRadius Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies the Circle radius when Type Field == ImGearPixelateCellType.Circle.

Declaration:

public int CircleRadius

Value:

Any integer value.

Default:

N/A

See Also:

ImGearPixelateCellType Enumeration


Height Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you to specify the height of the cell, in pixels.

Declaration:

public int Height

Value:

Any integer value.

Default:

N/A

See Also:

N/A


RectBoundRadius Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you to specify the round radius when Type Field == ImGearPixelateCellType.Rectangle.

Declaration:

public int RectBoundRadius

Value:

Any integer value.

Default:

N/A

See Also:

ImGearPixelateCellType Enumeration


Type Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you specify the type of the cell. See ImGearPixelateCellType Enumeration.

Declaration:

public ImageGear.Processing.ImGearPixelateCellType Type

Value:

ImGearPixelateCellType Enumeration value.

Default:

N/A

See Also:

ImGearPixelateCellType Enumeration


Width Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you specify the width of the cell, in pixels.

Declaration:

public int Width

Value:

Any integer value.

Default:

N/A

See Also:

N/A


ImGearPixelateFillParams Class

32-bit
64-bit
CF
P
P
P

Description:

This class describes fill characteristics of the Pixelate operation.

Declaration:

public class ImGearPixelateFillParams

Members:

Constructors
Name
Description
ImGearPixelateFillParams Constructor
Creates ImGearPixelateFillParams class instance.

Fields
Name
Description
Color Field
Fill color.
FillMethod Field
Fill method.
Opacity Field
Opacity of the cell.

Sample Code:

C#
// Pixelate an image.
// Parameter classes for Pixelate function.
ImGearPixelateBorderParams igPixelateBorderParams = new ImGearPixelateBorderParams();
ImGearPixelateCellParams igPixelateCellParams = new ImGearPixelateCellParams();
ImGearPixelateFillParams igPixelateFillParams = new ImGearPixelateFillParams();
ImGearPixel igPixel = igRasterPage.DIB.GetPixelCopy(0, 0);
// cell parameters
igPixelateCellParams.Type = ImGearPixelateCellType.Rectangle;
igPixelateCellParams.Width = 8;
igPixelateCellParams.Height = 8;
// fill parameters
igPixelateFillParams.FillMethod = ImGearPixelateFillMethod.Average;
igPixelateFillParams.Color = igPixel;
igPixelateFillParams.Opacity = (float)1.00;
// Border parameters
igPixelateBorderParams.Width = 0;
igPixelateBorderParams.Height = 0;
igPixelateBorderParams.Color = igPixel;
igPixelateBorderParams.Opacity = (float)1.00;
ImGearRasterProcessing.Pixelate(igRasterPage,
        igPixelateFillParams,
        igPixelateCellParams,
        igPixelateBorderParams);

VB .NET
' Pixelate an image.
' Parameter classes for Pixelate function.
Dim igPixelateBorderParams As New ImGearPixelateBorderParams()
Dim igPixelateCellParams As New ImGearPixelateCellParams()
Dim igPixelateFillParams As New ImGearPixelateFillParams()
Dim igPixel As ImGearPixel = igRasterPage.DIB.GetPixelCopy(0, 0)
' cell parameters
igPixelateCellParams.Type = ImGearPixelateCellType.Rectangle
igPixelateCellParams.Width = 8
igPixelateCellParams.Height = 8
' fill parameters
igPixelateFillParams.FillMethod = ImGearPixelateFillMethod.Average
igPixelateFillParams.Color = igPixel
igPixelateFillParams.Opacity = CSng(1)
' Border parameters
igPixelateBorderParams.Width = 0
igPixelateBorderParams.Height = 0
igPixelateBorderParams.Color = igPixel
igPixelateBorderParams.Opacity = CSng(1)
ImGearRasterProcessing.Pixelate(igRasterPage, igPixelateFillParams, igPixelateCellParams, igPixelateBorderParams)


ImGearPixelateFillParams Constructors

The ImGearPixelateFillParams Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearPixelateFillParams Constructor
Creates ImGearPixelateFillParams Class instance.


ImGearPixelateFillParams Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearPixelateFillParams Class.

Declaration:

public ImGearPixelateFillParams()

Return Value:

The new instance of ImGearPixelateFillParams Class

See Also:

ImGearPixelateFillParams Class


ImGearPixelateFillParams Fields

The ImGearPixelateFillParams Class of the ImageGear.Processing Namespace namespace has the following fields:

Fields
Name
Description
Color Field
Fill color.
FillMethod Field
Fill method.
Opacity Field
Opacity of the cell.


Color Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you specify fill color. This parameter is used if FillMethod Field is equal to ImGearPixelateFillMethod.Color.

Declaration:

public ImageGear.Core.ImGearPixel Color

Value:

ImGearPixel Class

Default:

N/A

See Also:

ImGearPixel Class


FillMethod Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies the fill method. See ImGearPixelateFillMethod Enumeration for details.

Declaration:

public ImageGear.Processing.ImGearPixelateFillMethod FillMethod

Value:

ImGearPixelateFillMethod Enumeration

Default:

N/A

See Also:

ImGearPixelateFillMethod Enumeration


Opacity Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies the opacity of the cell, where 0.0 is transparent and 1.0 is opaque.

Declaration:

public float Opacity

Value:

Valid range is 0...1.

Default:

N/A

See Also:

N/A


ImGearPixelCheckerRedEyeRGB Class

32-bit
64-bit
CF
P
P
P

Description:

CheckPixel method of this class checks the RGB pixel using red-eye detection algorithm.

Declaration:

public class ImGearPixelCheckerRedEyeRGB

Members:

Constructors
Name
Description
ImGearPixelCheckerRedEyeRGB Constructor
Creates ImGearPixelCheckerRedEyeRGB class instance.

Methods
Name
Description
CheckPixel Method
Checks if the pixel belongs to the area.

Sample Code:

C#
// Detect the red-eye area around a point and remove the red-eye effect.
// Location of a red-eye, can be obtained by a mouse click by user.
ImGearPoint igPoint = new ImGearPoint(204, 308);
// Detection class for red-eye area, threshold values from 0.5-2.0
ImGearPixelCheckerRedEyeRGB igPixelCheckerRedEyeRGB = new ImGearPixelCheckerRedEyeRGB(0.7);
// Detect the red-eye area around the target point.
ImGearRasterProcessing.DetectArea(igRasterPage, igPoint, igPixelCheckerRedEyeRGB);
// Remove red-eye effect with a threshold of 0.7 and brightness of 0.5
ImGearRasterProcessing.ProcessArea(igRasterPage,
    new ImGearPixelProcessorRedEyeRGB(igRasterPage.DIB, 0.7, 0.5));

VB .NET
' Detect the red-eye area around a point and remove the red-eye effect.
' Location of a red-eye, can be obtained by a mouse click by user.
Dim igPoint As New ImGearPoint(204, 308)
' Detection class for red-eye area, threshold values from 0.5-2.0
Dim igPixelCheckerRedEyeRGB As New ImGearPixelCheckerRedEyeRGB(0.7)
' Detect the red-eye area around the target point.
ImGearRasterProcessing.DetectArea(igRasterPage, igPoint, igPixelCheckerRedEyeRGB)
' Remove red-eye effect with a threshold of 0.7 and brightness of 0.5
ImGearRasterProcessing.ProcessArea(igRasterPage, New ImGearPixelProcessorRedEyeRGB(igRasterPage.DIB, 0.7, 0.5))


ImGearPixelCheckerRedEyeRGB Constructors

The ImGearPixelCheckerRedEyeRGB Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearPixelCheckerRedEyeRGB Constructor
Creates ImGearPixelCheckerRedEyeRGB Class instance.


ImGearPixelCheckerRedEyeRGB Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearPixelCheckerRedEyeRGB Class.

Declaration:

public ImGearPixelCheckerRedEyeRGB(double threshold)

Parameters:

Name
Type
Description
threshold
double
Value in the range 0.5..2 that specifies a part of the red component in the pixel color.

Return Value:

The new instance of ImGearPixelCheckerRedEyeRGB Class

See Also:

ImGearPixelCheckerRedEyeRGB Class


ImGearPixelCheckerRedEyeRGB Methods

The ImGearPixelCheckerRedEyeRGB Class of the ImageGear.Processing Namespace namespace has the following methods:

Methods
Name
Description
CheckPixel Method
Checks if the pixel belongs to the area.


CheckPixel Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if the pixel does not belong to the area (border found), and false otherwise.

Declaration:

public bool CheckPixel(ImageGear.Core.ImGearPixel pixel)

Parameters:

Name
Type
Description
pixel
ImGearPixel Class
ImGearPixel Class object that represents pixel to be tested.

Return Value:

True, false

See Also:

ImGearPixel Class


ImGearPixelCheckerThreshold Class

32-bit
64-bit
CF
P
P
P

Description:

CheckPixel method of this class checks the pixel using the initial pixel and the threshold. The pixel is supposed to be in the area if the following condition is true for all pixel channels:

pixel[i] >= initialPixel[i] - threshold && pixel[i] <= initialPixel[i] + threshold

Declaration:

public class ImGearPixelCheckerThreshold

Members:

Constructors
Name
Description
ImGearPixelCheckerThreshold Constructor
Creates ImGearPixelCheckerThreshold class instance.

Methods
Name
Description
CheckPixel Method
Checks if the pixel belongs to the area.

Sample Code:

C#
// Detect an area around a point in an image based upon a base pixel and threshold.
// Top left corner of image
ImGearPoint igPoint = new ImGearPoint(0, 0);
//Get the Pixel currently there.
ImGearPixel igPixel = igRasterPage.DIB.GetPixelCopy(0, 0);
// Detection class, threshold is difference in pixel channel values from specified pixel.
ImGearPixelCheckerThreshold igPixelCheckerThreshold = new ImGearPixelCheckerThreshold(igPixel, 100);
// Detect the region around target point within the threshold.
ImGearRasterProcessing.DetectArea(igRasterPage, igPoint, igPixelCheckerThreshold);
// Invert the contrast of the selected region to visible show the detected region.
ImGearRasterProcessing.InvertContrast(igRasterPage);

VB .NET
' Detect an area around a point in an image based upon a base pixel and threshold.
' Top left corner of image
Dim igPoint As New ImGearPoint(0, 0)
'Get the Pixel currently there.
Dim igPixel As ImGearPixel = igRasterPage.DIB.GetPixelCopy(0, 0)
' Detection class, threshold is difference in pixel channel values from specified pixel.
Dim igPixelCheckerThreshold As New ImGearPixelCheckerThreshold(igPixel, 100)
' Detect the region around target point within the threshold.
ImGearRasterProcessing.DetectArea(igRasterPage, igPoint, igPixelCheckerThreshold)
' Invert the contrast of the selected region to visible show the detected region.
ImGearRasterProcessing.InvertContrast(igRasterPage)


ImGearPixelCheckerRedEyeRGB Constructors

The ImGearPixelCheckerThreshold Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearPixelCheckerThreshold Constructor
Creates ImGearPixelCheckerThreshold class instance.


ImGearPixelCheckerThreshold Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearPixelCheckerThreshold Class.

Declaration:

public ImGearPixelCheckerThreshold(ImageGear.Core.ImGearPixel startPixel, int threshold)

Parameters:

Name
Type
Description
startPixel
ImGearPixel Class
Initial pixel.
threshold
int
Threshold.

Return Value:

The new instance of ImGearPixelCheckerThreshold Class

See Also:

ImGearPixelCheckerThreshold Class

ImGearPixel Class


ImGearPixelCheckerThreshold Methods

The ImGearPixelCheckerThreshold Class of the ImageGear.Processing Namespace namespace has the following methods:

Methods
Name
Description
CheckPixel Method
Checks if the pixel belongs to the area.


ImGearPixelProcessorRedEyeRGB Class

32-bit
64-bit
CF
P
P
P

Description:

ProcessPixel method of this class processes the RGB pixel using red-eye removal algorithm.

Declaration:

public class ImGearPixelProcessorRedEyeRGB

Members:

Constructors
Name
Description
ImGearPixelProcessorRedEyeRGB Constructor
Creates ImGearPixelProcessorRedEyeRGB class instance.

Methods
Name
Description
ProcessPixel Method
Returns the new pixel after processing.


ImGearPixelProcessorRedEyeRGB Constructors

The ImGearPixelProcessorRedEyeRGB Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearPixelProcessorRedEyeRGB Constructor
Creates ImGearPixelProcessorRedEyeRGB Class instance.


ImGearPixelProcessorRedEyeRGB Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearPixelProcessorRedEyeRGB Class.

Declaration:

public ImGearPixelProcessorRedEyeRGB(ImageGear.Core.ImGearDIB dib, double threshold,
double brightness)

Parameters:

Name
Type
Description
dib
ImGearDIB Class
DIB the pixel belongs to.
threshold
double
A value in the range 0.5..2 that specifies a part of the red component in the pixel color.
brightness
double
Brightness of the pixel after processing. The range is -1...1.

Return Value:

The new instance of ImGearPixelProcessorRedEyeRGB Class

See Also:

ImGearPixelProcessorRedEyeRGB Class

ImGearDIB Class


ImGearPixelProcessorRedEyeRGB Methods

The ImGearPixelProcessorRedEyeRGB Class of the ImageGear.Processing Namespace namespace has the following methods:

Methods
Name
Description
ProcessPixel Method
Returns the new pixel after processing.


ProcessPixel Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns the new pixel after processing.

Declaration:

public ImageGear.Core.ImGearPixel ProcessPixel(ImageGear.Core.ImGearPixel pixel)

Parameters:

Name
Type
Description
pixel
ImGearPixel Class
ImGearPixel Class object representing pixel to be processed.

Return Value:

ImGearPixel Class

See Also:

ImGearPixel Class


ImGearPopularityReductionOptions Class

32-bit
64-bit
CF
P
P
P

Description:

This class defines reduction options for popularity reduction. Popularity reduction reduces an image to 8bpp while retaining its most popular, or prevalent, colors. Use the MaxColors Field option to specify the maximum number of colors wanted in the result.

Declaration:

public class ImGearPopularityReductionOptions

Members:

Constructors
Name
Description
ImGearPopularityReductionOptions Constructor
Creates ImGearPopularityReductionOptions class instance.

Fields
Name
Description
MaxColors Field
Maximum number of colors used by the output image.


ImGearPopularityReductionOptions Constructors

The ImGearPopularityReductionOptions Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearPopularityReductionOptions Constructor
Creates ImGearPopularityReductionOptions class instance.


ImGearPopularityReductionOptions Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearPopularityReductionOptions Class.

Declaration:

public ImGearPopularityReductionOptions()

Return Value:

The new instance of ImGearPopularityReductionOptions Class

See Also:

ImGearPopularityReductionOptions Class


ImGearPopularityReductionOptions Fields

The ImGearPopularityReductionOptions Class of the ImageGear.Processing Namespace namespace has the following fields:

Fields
Name
Description
MaxColors Field
Specifies the maximum number of colors in the output image.


MaxColors Field

32-bit
64-bit
CF
P
P
P

Description:

This option lets you to specify the maximum number of colors in the output image. This can range from 8 to 256. Note that no matter what this value is, the output image will always be 8bpp.

Declaration:

public int MaxColors;

Value:

Integer from 8 to 256.

Default:

256


ImGearPreserveBlackInterpolationOptions Class

32-bit
64-bit
CF
P
P
P

Description:

Identifies options for interpolation with black color preservation. Threshold specifies limit value for the quantity of black pixels that will be transfered to black pixel of interpolated image. Used for binary images only.

Declaration:

public class ImGearPreserveBlackInterpolationOptions :
ImageGear.Processing.ImGearInterpolationOptions

Members:

Constructors
Name
Description
ImGearPreserveBlackInterpolationOptions Constructor
Initialized new intance of ImGearPreserveBlackInterpolationOptions class.

Fields
Name
Description
Threshold Field
Specifies limit value for the quantity of black pixels that will be transfered to black pixel of interpolated image.

See Also:

ImGearInterpolationOptions Class


ImGearPreserveBlackInterpolationOptions Constructors

The ImGearPreserveBlackInterpolationOptions Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearPreserveBlackInterpolationOptions Constructor
Initialized new intance of ImGearPreserveBlackInterpolationOptions class.


ImGearPreserveBlackInterpolationOptions Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearPreserveBlackInterpolationOptions Class.

Declaration:

public ImGearPreserveBlackInterpolationOptions(int threshold)

Parameters:

Name
Type
Description
threshold
int
Specifies limit value for the quantity of black pixels that will be transfered to black pixel of interpolated image.

Return Value:

The new instance of ImGearPreserveBlackInterpolationOptions Class

See Also:

ImGearPreserveBlackInterpolationOptions Class


ImGearPreserveBlackInterpolationOptions Fields

The ImGearPreserveBlackInterpolationOptions Class of the ImageGear.Processing Namespace namespace has the following fields:

Fields
Name
Description
Threshold Field
Specifies limit value for the quantity of black pixels that will be transfered to black pixel of interpolated image.


Threshold Field

32-bit
64-bit
CF
P
P
P

Description:

This option specifies limit value for the quantity of black pixels that will be transfered to black pixel of interpolated image.

Declaration:

public int Threshold

Value:

Any integer value.

Default:

N/A

See Also:

ImGearPreserveBlackInterpolationOptions Constructor


ImGearPreserveWhiteInterpolationOptions Class

32-bit
64-bit
CF
P
P
P

Description:

Identifies options for interpolation with white color preservation. Threshold specifies limit value for the quantity of white pixels that will be transfered to white pixel of interpolated image. Used for binary images only.

Declaration:

public class ImGearPreserveWhiteInterpolationOptions :
ImageGear.Processing.ImGearInterpolationOptions

Members:

Constructors
Name
Description
ImGearPreserveWhiteInterpolationOptions Constructor
Initializes new intance of ImGearPreserveWhiteInterpolationOptions class.

Fields
Name
Description
Threshold Field
Specifies limit value for the quantity of white pixels that will be transfered to white pixel of interpolated image.

See Also:

ImGearInterpolationOptions Class


ImGearPreserveWhiteInterpolationOptions Constructors

The ImGearPreserveWhiteInterpolationOptions Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearPreserveWhiteInterpolationOptions Constructor
Initializes new intance of ImGearPreserveWhiteInterpolationOptions Class.


ImGearPreserveWhiteInterpolationOptions Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates the new instance of ImGearPreserveWhiteInterpolationOptions Class.

Declaration:

public ImGearPreserveWhiteInterpolationOptions(int threshold)

Parameters:

Name
Type
Description
threshold
int
Specifies limit value for the quantity of white pixels that will be transfered to white pixel of interpolated image.

Return Value:

The new instance of ImGearPreserveWhiteInterpolationOptions Class

See Also:

ImGearPreserveWhiteInterpolationOptions Class


ImGearPreserveWhiteInterpolationOptions Fields

The ImGearPreserveWhiteInterpolationOptions Class of the ImageGear.Processing Namespace namespace has the following fields:

Fields
Name
Description
Threshold Field
Specifies limit value for the quantity of white pixels that will be transfered to white pixel of interpolated image.


Threshold Field

32-bit
64-bit
CF
P
P
P

Description:

This option specifies limit value for the quantity of white pixels that will be transfered to white pixel of interpolated image.

Declaration:

public int Threshold

Value:

Any integer value.

Default:

N/A

See Also:

ImGearPreserveWhiteInterpolationOptions Constructor


ImGearProcessing Class

32-bit
64-bit
CF
P
P
P

Description:

This is the main class for all image processing operations. It does not have a public constructor because all its functionality is implemented through static members.

Declaration:

public sealed class ImGearProcessing

Members:

Properties
Name
Description
Verifier Property
Allows you to call ImGearProcessingVerifier Class methods.

Methods
Name
Description
CreateThumbnail Method
Creates a thumbnail image according to the specified dimensions.
Crop Method
Crops an image according to the specified offsets and dimensions.
Flip Method
Flips an image in vertical or horizontal direction.
Resize Method
Resizes an image according to the specified dimensions.
Rotate Method
Rotates an image.
Rotate Method
Rotates `IGPage' 90, 180, or 270 degrees.
Rotate Method
Rotates an image using interpolation.

See Also:

ImGearProcessingVerifier Class


ImGearProcessing Properties

The ImGearProcessing Class of the ImageGear.Processing Namespace namespace has the following properties:

Properties
Name
Description
Verifier Property
Allows you to call ImGearProcessingVerifier Class methods.


Verifier Property

32-bit
64-bit
CF
P
P
P

Description:

Allows you to call ImGearProcessingVerifier Class methods.

Declaration:

public static ImageGear.Processing.ImGearProcessingVerifier Verifier { get; }

Value:

ImGearProcessingVerifier Class.

See Also:

ImGearProcessingVerifier Class


ImGearProcessing Methods

The ImGearProcessing Class of the ImageGear.Processing Namespace namespace has the following methods:

Methods
Name
Description
CreateThumbnail Method
Creates a thumbnail image according to the specified dimensions.
Crop Method
Crops an image according to the specified offsets and dimensions.
Flip Method
Flips an image in vertical or horizontal direction.
Resize Method
Resizes an image according to the specified dimensions.
Rotate Method
Rotates an image.
Rotate Method
Rotates `IGPage' 90, 180, or 270 degrees.
Rotate Method
Rotates an image using interpolation.


CreateThumbnail Method

32-bit
64-bit
CF
P
P
P

Description:

This method generates a thumbnail image from the source image. Processes all channels of the image.

Interpolation options depend on the color space and bit depth of the image. Grayscale, PreserveBlack and PreserveWhite interpolations are applicable only to 1 bit images.

Average and Bilinear interpolations are not applicable to 1 bit images nor to images having a non-gray palette. Also, Bilinear interpolation cannot be applied to the images if one of the dimensions is decreased.

CanApplyCreateThumbnail Method can be called to check whether the operation can be performed or not.

Declaration:

public static ImageGear.Core.ImGearPage CreateThumbnail(ImageGear.Core.ImGearPage page,
int width, int height, ImageGear.Processing.ImGearInterpolationOptions options)

Parameters:

Name
Type
Description
page
ImGearPage Class
Source image from which the thumbnail is created.
width
Int
Width of the thumbnail.
height
Int
Height of the thumbnail.
options
ImGearInterpolationOptions Class
Interpolation options.

Return Value:

New thumbnail image.

Sample Code:

C#
// Creates a thumbnail 100 pixels wide maintaining aspect ratio.
// Determine appropriate height.
int newHeight = 100 * igPage.DIB.Height / igPage.DIB.Width;
// Set default interpolation to none.
ImGearInterpolations igInterpolations = ImGearInterpolations.NONE;
// If the image is 1-bit and larger than 100x100, use grayscale interpolation.
if (igPage is ImGearRasterPage &&
    1 == igPage.DIB.BitDepth &&
    igPage.DIB.Width >= 100 &&
    igPage.DIB.Height >= 100)
{
    igInterpolations = ImGearInterpolations.GRAYSCALE;
}
// Create the thumbnail using the default options for the chosen interpolation.
ImGearPage igPageThumbnail = ImGearProcessing.CreateThumbnail(igPage, 100, newHeight,
    ImGearInterpolationOptions.GetDefault(igInterpolations));

VB .NET
' Creates a thumbnail 100 pixels wide maintaining aspect ratio.
' Determine appropriate height.
Dim newHeight As Integer = 100 * igPage.DIB.Height / igPage.DIB.Width
' Set default interpolation to none.
Dim igInterpolations As ImGearInterpolations = ImGearInterpolations.NONE
' If the image is 1-bit and larger than 100x100, use grayscale interpolation.
If TypeOf igPage Is ImGearRasterPage AndAlso 1 = igPage.DIB.BitDepth AndAlso _
 igPage.DIB.Width >= 100 AndAlso igPage.DIB.Height >= 100 Then
    igInterpolations = ImGearInterpolations.GRAYSCALE
End If
' Create the thumbnail using the default options for the chosen interpolation.
Dim igPageThumbnail As ImGearPage
igPageThumbnail = ImGearProcessing.CreateThumbnail(igPage, 100, newHeight, _
 ImGearInterpolationOptions.GetDefault(igInterpolations))

See Also:

ImGearRasterPage Class

ImGearInterpolationOptions Class

CanApplyCreateThumbnail Method

ImGearPage Class


Crop Method

32-bit
64-bit
CF
P
P
P

Description:

This method crops ImGearPage Class object. It processes all channels of the image. It may shift reference point of ROI, but does not crop it.

CanApplyCrop Method can be called to check whether the operation can be performed or not.

Declaration:

public static void Crop(ImageGear.Core.ImGearPage page, int left, int top, int width, int
height)

Parameters:

Name
Type
Description
page
ImGearPage Class
Image to crop.
left
Int
Left border of the new image.
top
Int
Top border of the new image.
width
Int
Width of the new image.
height
Int
Height of the new image.

Return Value:

N/A

Sample Code:

C#
// Crops 100 pixels off the top of an image.
ImGearProcessing.Crop(igRasterPage, 0, 100, igRasterPage.DIB.Width, igRasterPage.DIB.Height - 100);

VB .NET
' Crops 100 pixels off the top of an image.
ImGearProcessing.Crop(igRasterPage, 0, 100, igRasterPage.DIB.Width, igRasterPage.DIB.Height - 100)

See Also:

ImGearPage Class

CanApplyCrop Method


Flip Method

32-bit
64-bit
CF
P
P
P

Description:

This method flips ImGearPage Class object. Processes all channels of the image and ROI.

CanApplyFlip Method can be called to check whether the operation can be performed or not.

Declaration:

public static void Flip(ImageGear.Core.ImGearPage page, ImageGear.Core.ImGearFlipModes
mode)

Parameters:

Name
Type
Description
page
ImGearPage Class
Image to flip.
mode
ImGearFlipModes Enumeration
Constant defining flip direction. Possible values are ImGearFlipModes.HORIZONTAL and ImGearFlipModes.VERTICAL.

Return Value:

N/A

See Also:

ImGearPage Class

CanApplyFlip Method

ImGearFlipModes Enumeration


Resize Method

32-bit
64-bit
CF
P
P
P

Description:

This method resizes ImGearPage Class object. Processes all channels of the image and ROI.

Interpolation options depend on the color space and bit depth of the image. Grayscale, PreserveBlack and PreserveWhite interpolations are applicable only to 1-bit images.

Average, bilinear, and bicubic interpolations are not applicable either to 1-bit images or images having non-gray palette.

CanApplyResize Method can be called to check whether the operation can be performed or not.

Declaration:

public static void Resize(ImageGear.Core.ImGearPage page, int width, int height,
ImageGear.Processing.ImGearInterpolationOptions options)

Parameters:

Name
Type
Description
page
ImGearPage Class
Image to resize.
width
Int
New image width.
height
Int
New image height.
options
ImGearInterpolationOptions Class
Interpolation options.

Return Value:

N/A

Sample Code:

C#
// Resizes an image to 128 pixels wide maintaining aspect ratio using bicubic resizing.
int newHeight = 128 * igRasterPage.DIB.Height / igRasterPage.DIB.Width;
ImGearBicubicInterpolationOptions igBicubicInterpolationOptions = new ImGearBicubicInterpolationOptions();
igBicubicInterpolationOptions.Sharpness = 1.5;
ImGearProcessing.Resize(igRasterPage, 128, newHeight, igBicubicInterpolationOptions);

VB .NET
' Resizes an image to 128 pixels wide maintaining aspect ratio using bicubic resizing.
Dim newHeight As Integer = 128 * igRasterPage.DIB.Height / igRasterPage.DIB.Width
Dim igBicubicInterpolationOptions As New ImGearBicubicInterpolationOptions()
igBicubicInterpolationOptions.Sharpness = 1.5
ImGearProcessing.Resize(igRasterPage, 128, newHeight, igBicubicInterpolationOptions)

See Also:

ImGearPage Class , CanApplyResize Method , ImGearInterpolationOptions Class


Rotate Method

32-bit
64-bit
CF
P
P
P

Description:

This method rotates ImGearPage Class object. Processes all channels of the image and ROI. Background should be in the same color space as the Page, including Alpha and Extra channels.

Background must have the same channel count and bit depth as a DIB's color space.

CanApplyRotate Method can be called to check whether the operation can be performed or not.

Declaration:

public static void Rotate(ImageGear.Core.ImGearPage page, double angle,
ImageGear.Processing.ImGearRotationModes mode, ImageGear.Core.ImGearPixel background)

Parameters:

Name
Type
Description
page
ImGearPage Class
Image to rotate.
angle
double
Rotation angle in degrees.
mode
ImGearRotationModes Enumeration
One of the constants ImGearRotationModes.CLIP or ImGearRotationModes.EXPAND.
  • CLIP means that the image size is not changed during rotation and the part of picture out of image boundary is cut.
  • EXPAND changes the image size according to the new picture boundary.
background
ImGearPixel Class
Background color to fill the out of picture area. Can be null (Nothing in VB NET).

Return Value:

N/A

Sample Code:

C#
// Find the skew angle of an image.
double angle = ImGearRasterProcessing.FindSkewAngle(igRasterPage);
// Rotate image by the found skew angle.
ImGearProcessing.Rotate(igRasterPage,angle, ImGearRotationModes.CLIP, null);

VB .NET
' Find the skew angle of an image.
Dim angle As Double = ImGearRasterProcessing.FindSkewAngle(igRasterPage)
' Rotate image by the found skew angle.
ImGearProcessing.Rotate(igRasterPage, angle, ImGearRotationModes.CLIP, Nothing)

See Also:

ImGearPage Class

ImGearRotationModes Enumeration

ImGearPixel Class

CanApplyRotate Method


Rotate Method

32-bit
64-bit
CF
P
P
P

Description:

This method rotates ImGearPage Class object on 90, 180, or 270 degrees. Processes all channels of the image and ROI.

Rotation direction is clockwise (left coordinate system).

Rotation on 90 and 270 degrees change image dimensions.

CanApplyRotate Method can be called to check whether the operation can be performed or not.

Declaration:

public static void Rotate(ImageGear.Core.ImGearPage page,
ImageGear.Core.ImGearRotationValues rotationValue)

Parameters:

Name
Type
Description
page
ImGearPage Class
Image to rotate.
rotationvalue
ImGearRotationValues Enumeration
One of the following values:
  • ImGearRotationValues.VALUE_0 - no rotation
  • ImGearRotationValues.VALUE_90 - rotate on 90 degrees
  • ImGearRotationValues.VALUE_180 - rotate on 180 degrees
  • ImGearRotationValues.VALUE_270 - rotate on 270 degrees

Return Value:

N/A

See Also:

ImGearPage Class

CanApplyRotate Method

ImGearRotationValues Enumeration


Rotate Method

32-bit
64-bit
CF
P
P
P

Description:

This method rotates ImGearPage Class object. Processes all channels of the image and ROI. Background should be in the same color space as the Page, including Alpha and Extra channels.

Background must have the same channel count and bit depth as a DIB's color space.

CanApplyRotate Method can be called to check whether the operation can be performed or not.

The supported interpolations are BILINEAR and BICUBIC. For images with a palette, the palette must be a grayscale palette. Interpolation is not supported for 1bpp images.

Declaration:

public static void Rotate(ImageGear.Core.ImGearPage page, double angle,
ImageGear.Processing.ImGearRotationModes mode, ImageGear.Core.ImGearPixel background,
ImageGear.Processing.ImGearInterpolations interpolation)

Parameters:

Name
Type
Description
page
ImGearPage Class
Image to rotate.
angle
double
Rotation angle in degrees.
mode
ImGearRotationModes Enumeration
One of the constants ImGearRotationModes.CLIP or ImGearRotationModes.EXPAND.
  • CLIP means that the image size is not changed during rotation and the part of picture out of image boundary is cut.
  • EXPAND change the image size according to the new picture boundary.
background
ImGearPixel Class
Background color to fill the out of picture area. Can be null (Nothing in VB NET).
interpolation
ImGearInterpolations Enumeration
Interpolation to use for rotation.

Return Value:

N/A

See Also:

ImGearPage Class

ImGearRotationModes Enumeration

ImGearPixel Class

CanApplyRotate Method

ImGearInterpolations Enumeration


ImGearProcessingVerifier Class

32-bit
64-bit
CF
P
P
P

Description:

This class contains static methods that check whether the ImGearProcessing Class operation is applicable to the page or not.

NOTE: These methods should be used to distinguish a sub-set of pages for which a particular filter is applicable.

Declaration:

public sealed class ImGearProcessingVerifier

Members:

Methods
Name
Description
CanApplyCreateThumbnail Method
Verifies if ImGearProcessing.CreateThumbnail method can be applied to the Page.
CanApplyCrop Method
Verifies if ImGearProcessing.Crop method can be applied to the Page.
CanApplyFlip Method
Verifies if ImGearProcessing.Flip method can be applied to the Page.
CanApplyResize Method
Verifies if ImGearProcessing.Resize method can be applied to the Page.
CanApplyRotate Method
Verifies if ImGearProcessing.Rotate method can be applied to the Page.
CanApplyRotate Method
Verifies if ImGearProcessing.Rotate for 90 degrees angle method can be applied to the Page.
CanApplyRotate Method
Returns true if ImGearProcessing.Rotate Method can be applied to the specified page, with the specified interpolation, false otherwise.

See Also:

ImGearProcessing Class


ImGearProcessingVerifier Methods

The ImGearProcessingVerifier Class of the ImageGear.Processing Namespace namespace has the following methods:

Methods
Name
Description
CanApplyCreateThumbnail Method
Verifies if ImGearProcessing.CreateThumbnail method can be applied to the Page.
CanApplyCrop Method
Verifies if ImGearProcessing.Crop method can be applied to the Page.
CanApplyFlip Method
Verifies if ImGearProcessing.Flip method can be applied to the Page.
CanApplyResize Method
Verifies if ImGearProcessing.Resize method can be applied to the Page.
CanApplyRotate Method
Verifies if ImGearProcessing.Rotate method can be applied to the Page.
CanApplyRotate Method
Verifies if ImGearProcessing.Rotate for 90 degrees angle method can be applied to the Page.
CanApplyRotate Method
Returns true if ImGearProcessing.Rotate Method can be applied to the specified page, with the specified interpolation, false otherwise.


CanApplyCreateThumbnail Method

32-bit
64-bit
CF
P
P
P

Description:

Returns true if CreateThumbnail Method can be applied to the specified Page, with the specified dimensions and interpolation, false otherwise.

Declaration:

public bool CanApplyCreateThumbnail(ImGearPage Page, int width, int height,
ImGearInterpolationOptions Options)

Parameters:

Name
Type
Description
Page
ImGearPage Class
Page specified
width
int
Page width
height
int
Page height
Options
ImGearInterpolationOptions Class
Interpolation options

Return Value:

True, false.

See Also:

CreateThumbnail Method

ImGearPage Class

ImGearInterpolationOptions Class


CanApplyCrop Method

32-bit
64-bit
CF
P
P
P

Description:

Returns true if Crop Method can be applied to the specified Page, false otherwise.

Declaration:

public bool CanApplyCrop(ImGearPage Page)

Parameters:

Name
Type
Description
Page
ImGearPage Class
Page specified.

Return Value:

True, false.

See Also:

Crop Method

ImGearPage Class


CanApplyFlip Method

32-bit
64-bit
CF
P
P
P

Description:

Returns true if Flip Method can be applied to the specified Page, false otherwise.

Declaration:

public bool CanApplyFlip(ImGearPage Page)

Parameters:

Name
Type
Description
Page
ImGearPage Class
Page specified.

Return Value:

True, false.

See Also:

Flip Method

ImGearPage Class


CanApplyResize Method

32-bit
64-bit
CF
P
P
P

Description:

Returns true if Resize Method can be applied to the specified Page, with the specified dimensions and interpolation, false otherwise.

Declaration:

public bool CanApplyResize(ImGearPage Page, int width, int height,
ImGearInterpolationOptions Options)

Parameters:

Name
Type
Description
Page
ImGearPage Class
Page specified
width
int
Page width
height
int
Page height
Options
ImGearInterpolationOptions Class
Interpolation options

Return Value:

True, false.

See Also:

Resize Method

ImGearPage Class

ImGearInterpolationOptions Class


CanApplyRotate Method

32-bit
64-bit
CF
P
P
P

Description:

Returns true if the Rotate Method can be applied to the specified Page, with the specified rotationValue, false otherwise.

Declaration:

public bool CanApplyRotate(ImageGear.Core.ImGearPage page,
ImageGear.Core.ImGearRotationValues rotationValue)

Parameters:

Name
Type
Description
Page
ImGearPage Class
Page specified.
rotationValue
ImGearRotationValues Enumeration
Rotation value.

Return Value:

True, false.

See Also:

Rotate Method

ImGearPage Class

ImGearPixel Class


CanApplyRotate Method

32-bit
64-bit
CF
P
P
P

Description:

Returns true if the Rotate Method for 90 degrees angle can be applied to the specified Page, false otherwise.

Declaration:

public bool CanApplyRotate(ImageGear.Core.ImGearPage page,
ImageGear.Processing.ImGearRotationModes rotationMode)
public bool CanApplyRotate(ImGearPage Page)

Parameters:

Name
Type
Description
Page
ImGearPage Class
Page specified.
rotationMode
ImGearRotationModes Enumeration
Rotation mode

Return Value:

True, false.

See Also:

Rotate Method

ImGearPage Class


CanApplyRotate Method

32-bit
64-bit
CF
P
P
P

Description:

Returns true if ImGearProcessing.Rotate Method can be applied to the specified page, with the specified interpolation, false otherwise.

Declaration:

public bool CanApplyRotate(ImageGear.Core.ImGearPage page,
ImageGear.Processing.ImGearInterpolations interpolation)

Parameters:

Name
Type
Description
page
ImGearPage Class
Page specified
interpolation
ImGearInterpolations Enumeration
Specified interpolation.

Return Value:

True, false.

See Also:

Rotate Method

ImGearPage Class

ImGearInterpolations Enumeration


ImGearRasterProcessing Class

32-bit
64-bit
CF
P
P
P

Description:

This is the main class for all image raster processing operations.

Declaration:

public sealed class ImGearRasterProcessing

Members:

Properties
Name
Description
Verifier Property
Allows you to call ImGearRasterProcessingVerifier methods.

Methods
Name
Description
AddTilt Method
Adds a specified plane to the input image to correct for a tilt in the image luminance.
AdjustContrast Method
This method adjusts contrast, brightness, and gamma.
AdjustContrast Method
This method adjusts contrast, brightness, and gamma.
AdjustContrast Method
This method adjusts contrast, brightness, and gamma.
AdjustWhiteBalance Method
This method allows correction of white balance of the image.
AdjustWhiteBalance Method
This method allows correction of white balance of the image.
Aging Method
This method applies an aging effect to make an image look older.
Blend Method
This method blends 2 images based on percentages.
Blend Method
This method blends 2 images based on percentages.
BlendWithAlpha Method
This method blends 2 images with alpha.
Boost Method
This method increases saturation, brightness and contrast of the image.
CalculateStatistics Method
Calculates statistics for all channels of the image, separately for each channel.
ChangeChannelsDepths Method
This method changes bit depth of image channels.
ChangeChannelsDepths Method
This method changes bit depth of image channels.
Close Method
Applies closing effect to provided raster page using the specified structure element.
CombineChannels Method
Puts together image channels according to the specified color space.
ConvertColorSpace Method
Converts Page to new color space.
ConvertColorSpace Method
Converts Page to new color space.
ConvertColorSpace Method
Converts Page to new color space.
ConvertColorSpace Method
Converts an image's color space using the specified color profiles and rendering intent.
ConvertColorSpace Method
Converts an image's color space using the specified matrix.
ConvertColorSpace Method
Converts Page to new color space.
ConvertPixelFormat Method
This method converts a single pixel to color space and channel depths of the specified ImGearPage Class.
ConvertPixelFormat Method
This method converts a single pixel to new color space and channel depths.
Convolve Method
This method provides filtering on the base of 2-dimensional convolution matrix.
CreateChannelCopy Method
Creates copy of page image channel and returns it.
CreateChannelCopy Method
This method copies a channel to a new page.
Decrypt Method
Decrypts a specified page in the document.
Deskew Method
This method deskews an image page.
Despeckle Method
This method removes color noise from a binary (1-bit) image.
DetectArea Method
This method detects an area of pixels using a specified pixel checker. The area being detected is saved as the ROI of the page.
Dilate Method
Applies dilation effect to provided raster page using the specified structure element.
DirectionalLight Method
This method changes the colors of an image according to the pattern of a sine wave.
DirectionalWave Method
Provides a directional wave effect on the current raster page.
DropShadow Method
This method adds a drop shadow to an image.
Duotone Method
This method maps the darkest pixels of the image to color1, brightest pixels with color2, and other pixels to a linear combination of color1 and color2, depending on their brightness.
EdgeDetection Method
Performs the edge detection operation specified by the method argument.
EdgeMap Method
Performs the edge map operation specified by the Method argument. Processes a specified range of channels.
EdgeMap Method
Performs the edge map operation specified by the Method argument. Processes color channels only.
Encrypt Method
Encrypts a specified page in the document.
EnhanceLocal Method
Enhances an image using the local standard deviation and mean.
EqualizeContrast Method
Equalizes image contrast. If image is Indexed and not grayscale, modifies image's palette, otherwise modifies image's pixels. Processes only color channels.
EqualizeContrast Method
Equalizes image contrast. Processes specified range of channels.
Erode Method
Applies erosion effect to provided raster page using the specified structure element.
Export Method
Exports content of raster page to managed GDI+ image.
Export Method
Exports content of raster page to managed GDI+ image.
Export Method
Exports content of raster page to managed GDI+ image.
FilterWithMedian Method
This method removes color noise from the image.
FilterWithMedian Method
This method removes color noise from the image.
FilterWithUnsharpMask Method
This method provides UnsharpMask filtering.
FilterWithUnsharpMask Method
This method provides UnsharpMask filtering.
FindSkewAngle Method
This method determines skew angle.
FindTilt Method
Computes the least-squares best fit plane for an image.
Fragment Method
This method fragments an image into four blended images that move diagonally outward from the original image.
FreeDirectionalLight Method
This method changes the colors of an image according to the pattern of a sine wave.
FreeRadialLight Method
This method changes the colors of an image according to the pattern of a sine wave.
GaussianBlur Method
This method smoothes the images using Gaussian transform.
GaussianBlur Method
This method smoothes the images using Gaussian transform.
GeomDespeckle Method
This method is used to reduce speckle noise from an image by using the Crimmins algorithm.
GlowingEdges Method
This method applies "glowing edges" effect to the image.
HighDensityRangeEffect Method
This method makes the image look as if it was taken in a High Density Range mode, by adding bright colors to image edges.
HotWax Method
This method transforms the image so that it looks like it has been coated by hot wax.
ImageIsGray Method
This method returns True if either the image has GrayScale color space or its palette is gray or inverted gray.
InsertChannel Method
This method inserts a channel to the Page's DIB and changes color space.
InvertContrast Method
This method Inverts image contrast.
InvertContrast Method
This method Inverts image contrast.
InvertContrast Method
This method Inverts image contrast.
LensFlare Method
This method applies a lens flare effect to the image.
Merge Method
This method merges two images according to the specified merge mode.
Merge Method
This method merges two images according to the specified merge mode.
MonochromeFilm Method
This method applies a Monochrome Film effect on the image.
Mosaic Method
This method provides 3D mosaic effect on an image.
NightVision Method
This method applies "night vision" effect to the image.
Oilify Method
This method applies an effect to an image that makes it appear similar to an oil painting.
Open Method
Applies opening effect to provided raster page using the specified structure element.
Perspective Method
This method provides a perspective-like effect by image corners transformation.
Picturize Method
This method divides the image into rectangular cells, and replaces cells with small copies of images from the specified list.
Pinch Method
This method pinches a page toward or away from the pinch center.
Pixelate Method
This method divides an image into cells and fills every cell according to the cell and fill parameters.
Pointillist Method
This method applies an effect to an image that makes it appear to have been painted in the pointillism style of painting.
ProcessArea Method
This method processes all pixels in the ROI area using a specified pixel processor.
RadialLight Method
This method changes the colors of an image according to the pattern of a sine wave.
RadialWave Method
This method provides a radial wave effect on the current raster page.
Reduce Method
This method reduces the bit depth of an image using the specified reduction method.
RemoveChannel Method
This method removes the specified channel from the Page's DIB and shifts the remaining channels without transforming pixel data.
RemoveChromaticAberration Method
This method removes chromatic aberration artifacts from an image.
RemoveTilt Method
This method computes the best-fit plane for an image, and then subtracts that plane from the image to produce the output.
Ripple Method
This method provides the ripple effect on the image, as if it is looked at through a relief glass.
RippleFreeHand Method
This method provides the ripple effect on the image, as if it is looked at through a relief glass.
RippleTexture Method
This method provides the ripple effect on the image, as if it is looked at through a relief glass.
RoundCorners Method
This method rounds the corners of the image and fills them with a specified color.
SeparateChannels Method
This method creates an array of pages, where each page contains one channel with color space set to grayscale.
Sepia Method
This method applies the Sepia effect, making the image look like a tinted old black-and-white photograph.
Sharpen Method
This method sharpens an image according to the specified sharpen factor.
Sharpen Method
This method sharpens an image according to the specified sharpen factor.
Shear Method
This method applies a shearing effect to an image, moving the image rasters or columns according to the specified offsets.
Sketch Method
Applies a sketch effect on the image.
Smooth Method
This method provides smooth filtering.
Smooth Method
This method provides smooth filtering.
Solarize Method
This method inverts the colors of pixels whose lightness exceeds the specified threshold.
Solarize Method
This method inverts the colors of pixels whose lightness exceeds the specified threshold.
Solarize Method
This method inverts the colors of pixels whose lightness exceeds the specified threshold.
Spatter Method
This method applies a spatter effect to an image, making it look as if it was painted in the impressionist style of painting.
Spotlights Method
This method darkens the image and highlights selected areas as if they are illuminated with a spotlight or sunlight.
SpotlightsPreview Method
This method creates a reduced size preview for the Spotlights effect.
StretchContrast Method
Stretches image contrast. If image is Indexed and not grayscale, modifies image's palette, otherwise modifies image's pixels. Processes only color channels.
StretchContrast Method
Stretches image contrast. Processes specified range of channels.
SwapChannels Method
This method swaps two channels in Page's DIB.
TabulateHistogram Method
Tabulates histograms for all image channels.
ToyCamera Method
This method makes the image look as if it was taken by a toy camera.
TransformWithLUT Method
Applies look up tables to each channel of the image, optionally changing channel depths.
UpdateChannelFrom Method
This method copies channel from ChannelPage to a channel within Page.
Vignette Method
This method draws a shape on the image and fills interior or exterior of the shape with a specified color, using a smooth gradient at the edge of the shape.
WarpCylinder Method
This method provides warping around cylinder on the current raster page.
WarpParabolic Method
This method provides warping around paraboloid on the current raster page.
WarpSphere Method
This method provides warping around sphere on the current raster page.

See Also:

ImGearRasterProcessingVerifier Class


ImGearRasterProcessing Properties

The ImGearRasterProcessing Class of the ImageGear.Processing Namespace has the following properties:

Properties
Name
Description
Verifier Property
Allows you to call ImGearRasterProcessingVerifier methods.


Verifier Property

32-bit
64-bit
CF
P
P
P

Description:

Allows you to call ImGearRasterProcessingVerifier Class methods.

Declaration:

public ImGearRasterProcessingVerifier Verifier { get; }

Value:

ImGearRasterProcessingVerifier Class method.


ImGearRasterProcessing Methods

The ImGearRasterProcessing Class of the ImageGear.Processing Namespace has the following methods:

Methods
Name
Description
AddTilt Method
Adds a specified plane to the input image to correct for a tilt in the image luminance.
AdjustContrast Method
This method adjusts contrast, brightness, and gamma.
AdjustContrast Method
This method adjusts contrast, brightness, and gamma.
AdjustContrast Method
This method adjusts contrast, brightness, and gamma.
AdjustWhiteBalance Method
This method allows correction of white balance of the image.
AdjustWhiteBalance Method
This method allows correction of white balance of the image.
Aging Method
This method applies an aging effect to make an image look older.
Blend Method
This method blends 2 images based on percentages.
Blend Method
This method blends 2 images based on percentages.
BlendWithAlpha Method
This method blends 2 images with alpha.
Boost Method
This method increases saturation, brightness and contrast of the image.
CalculateStatistics Method
Calculates statistics for all channels of the image, separately for each channel.
ChangeChannelsDepths Method
This method changes bit depth of image channels.
ChangeChannelsDepths Method
This method changes bit depth of image channels.
Close Method
Applies closing effect to provided raster page using the specified structure element.
CombineChannels Method
Puts together image channels according to the specified color space.
ConvertColorSpace Method
Converts Page to new color space.
ConvertColorSpace Method
Converts Page to new color space.
ConvertColorSpace Method
Converts Page to new color space.
ConvertColorSpace Method
Converts an image's color space using the specified color profiles and rendering intent.
ConvertColorSpace Method
Converts an image's color space using the specified matrix.
ConvertColorSpace Method
Converts Page to new color space.
ConvertPixelFormat Method
This method converts a single pixel to color space and channel depths of the specified ImGearPage Class.
ConvertPixelFormat Method
This method converts a single pixel to new color space and channel depths.
Convolve Method
This method provides filtering on the base of 2-dimensional convolution matrix.
CreateChannelCopy Method
Creates copy of page image channel and returns it.
CreateChannelCopy Method
This method copies a channel to a new page.
Decrypt Method
Decrypts a specified page in the document.
Deskew Method
This method deskews an image page.
Despeckle Method
This method removes color noise from a binary (1-bit) image.
DetectArea Method
This method detects an area of pixels using a specified pixel checker. The area being detected is saved as the ROI of the page.
Dilate Method
Applies dilation effect to provided raster page using the specified structure element.
DirectionalLight Method
This method changes the colors of an image according to the pattern of a sine wave.
DirectionalWave Method
Provides a directional wave effect on the current raster page.
DropShadow Method
This method adds a drop shadow to an image.
Duotone Method
This method maps the darkest pixels of the image to color1, brightest pixels with color2, and other pixels to a linear combination of color1 and color2, depending on their brightness.
EdgeDetection Method
Performs the edge detection operation specified by the method argument.
EdgeMap Method
Performs the edge map operation specified by the Method argument. Processes a specified range of channels.
EdgeMap Method
Performs the edge map operation specified by the Method argument. Processes color channels only.
Encrypt Method
Encrypts a specified page in the document.
EnhanceLocal Method
Enhances an image using the local standard deviation and mean.
EqualizeContrast Method
Equalizes image contrast. If image is Indexed and not grayscale, modifies image's palette, otherwise modifies image's pixels. Processes only color channels.
EqualizeContrast Method
Equalizes image contrast. Processes specified range of channels.
Erode Method
Applies erosion effect to provided raster page using the specified structure element.
Export Method
Exports content of raster page to managed GDI+ image.
Export Method
Exports content of raster page to managed GDI+ image.
Export Method
Exports content of raster page to managed GDI+ image.
FilterWithMedian Method
This method removes color noise from the image.
FilterWithMedian Method
This method removes color noise from the image.
FilterWithUnsharpMask Method
This method provides UnsharpMask filtering.
FilterWithUnsharpMask Method
This method provides UnsharpMask filtering.
FindSkewAngle Method
This method determines skew angle.
FindTilt Method
Computes the least-squares best fit plane for an image.
Fragment Method
This method fragments an image into four blended images that move diagonally outward from the original image.
FreeDirectionalLight Method
This method changes the colors of an image according to the pattern of a sine wave.
FreeRadialLight Method
This method changes the colors of an image according to the pattern of a sine wave.
GaussianBlur Method
This method smoothes the images using Gaussian transform.
GaussianBlur Method
This method smoothes the images using Gaussian transform.
GeomDespeckle Method
This method is used to reduce speckle noise from an image by using the Crimmins algorithm.
GlowingEdges Method
This method applies "glowing edges" effect to the image.
HighDensityRangeEffect Method
This method makes the image look as if it was taken in a High Density Range mode, by adding bright colors to image edges.
HotWax Method
This method transforms the image so that it looks like it has been coated by hot wax.
ImageIsGray Method
This method returns True if either the image has GrayScale color space or its palette is gray or inverted gray.
InsertChannel Method
This method inserts a channel to the Page's DIB and changes color space.
InvertContrast Method
This method Inverts image contrast.
InvertContrast Method
This method Inverts image contrast.
InvertContrast Method
This method Inverts image contrast.
LensFlare Method
This method applies a lens flare effect to the image.
Merge Method
This method merges two images according to the specified merge mode.
Merge Method
This method merges two images according to the specified merge mode.
MonochromeFilm Method
This method applies a Monochrome Film effect on the image.
Mosaic Method
This method provides 3D mosaic effect on an image.
NightVision Method
This method applies "night vision" effect to the image.
Oilify Method
This method applies an effect to an image that makes it appear similar to an oil painting.
Open Method
Applies opening effect to provided raster page using the specified structure element.
Perspective Method
This method provides a perspective-like effect by image corners transformation.
Picturize Method
This method divides the image into rectangular cells, and replaces cells with small copies of images from the specified list.
Pinch Method
This method pinches a page toward or away from the pinch center.
Pixelate Method
This method divides an image into cells and fills every cell according to the cell and fill parameters.
Pointillist Method
This method applies an effect to an image that makes it appear to have been painted in the pointillism style of painting.
ProcessArea Method
This method processes all pixels in the ROI area using a specified pixel processor.
RadialLight Method
This method changes the colors of an image according to the pattern of a sine wave.
RadialWave Method
This method provides a radial wave effect on the current raster page.
Reduce Method
This method reduces the bit depth of an image using the specified reduction method.
RemoveChannel Method
This method removes the specified channel from the Page's DIB and shifts the remaining channels without transforming pixel data.
RemoveChromaticAberration Method
This method removes chromatic aberration artifacts from an image.
RemoveTilt Method
This method computes the best-fit plane for an image, and then subtracts that plane from the image to produce the output.
Ripple Method
This method provides the ripple effect on the image, as if it is looked at through a relief glass.
RippleFreeHand Method
This method provides the ripple effect on the image, as if it is looked at through a relief glass.
RippleTexture Method
This method provides the ripple effect on the image, as if it is looked at through a relief glass.
RoundCorners Method
This method rounds the corners of the image and fills them with a specified color.
SeparateChannels Method
This method creates an array of pages, where each page contains one channel with color space set to grayscale.
Sepia Method
This method applies the Sepia effect, making the image look like a tinted old black-and-white photograph.
Sharpen Method
This method sharpens an image according to the specified sharpen factor.
Sharpen Method
This method sharpens an image according to the specified sharpen factor.
Shear Method
This method applies a shearing effect to an image, moving the image rasters or columns according to the specified offsets.
Sketch Method
Applies a sketch effect on the image.
Smooth Method
This method provides smooth filtering.
Smooth Method
This method provides smooth filtering.
Solarize Method
This method inverts the colors of pixels whose lightness exceeds the specified threshold.
Solarize Method
This method inverts the colors of pixels whose lightness exceeds the specified threshold.
Solarize Method
This method inverts the colors of pixels whose lightness exceeds the specified threshold.
Spatter Method
This method applies a spatter effect to an image, making it look as if it was painted in the impressionist style of painting.
Spotlights Method
This method darkens the image and highlights selected areas as if they are illuminated with a spotlight or sunlight.
SpotlightsPreview Method
This method creates a reduced size preview for the Spotlights effect.
StretchContrast Method
Stretches image contrast. If image is Indexed and not grayscale, modifies image's palette, otherwise modifies image's pixels. Processes only color channels.
StretchContrast Method
Stretches image contrast. Processes specified range of channels.
SwapChannels Method
This method swaps two channels in Page's DIB.
TabulateHistogram Method
Tabulates histograms for all image channels.
ToyCamera Method
This method makes the image look as if it was taken by a toy camera.
TransformWithLUT Method
Applies look up tables to each channel of the image, optionally changing channel depths.
UpdateChannelFrom Method
This method copies channel from ChannelPage to a channel within Page.
Vignette Method
This method draws a shape on the image and fills interior or exterior of the shape with a specified color, using a smooth gradient at the edge of the shape.
WarpCylinder Method
This method provides warping around cylinder on the current raster page.
WarpParabolic Method
This method provides warping around paraboloid on the current raster page.
WarpSphere Method
This method provides warping around sphere on the current raster page.


AddTilt Method

32-bit
64-bit
CF
P
P
P

Description:

This method adds a specified plane to the input image to correct for a tilt in the image luminance. The plane has X and Y zero crossing at the center of the input image with dSlopeX and dSlopeY as specified in the arguments.

Declaration:

public static void AddTilt(ImageGear.Core.ImGearRasterPage page, double dSlopeX, double
dSlopeY)

Parameters:

Name
Type
Description
Page
ImGearRasterPage Class
An ImGearRasterPage Class object, in which the algorithm will be performed.
dSlopeX
double
Specifies the slope of the plane in X direction, in units per pixel.
dSlopeY
double
Specifies the slope of the plane in Y direction, in units per pixel.

Return Value:

None

Sample Code:

C#
// Find the tilt of an image.
double slopeX, slopeY, piston;
ImGearRasterProcessing.FindTilt(igRasterPage, out slopeX, out slopeY, out piston);
// Add the found tilt from the image, in effect removing it.
ImGearRasterProcessing.AddTilt(igRasterPage, slopeX, slopeY);

VB .NET
' Find the tilt of an image.
Dim slopeX As Double, slopeY As Double, piston As Double
ImGearRasterProcessing.FindTilt(igRasterPage, slopeX, slopeY, piston)
' Add the found tilt from the image, in effect removing it.
ImGearRasterProcessing.AddTilt(igRasterPage, slopeX, slopeY)

See Also:

ImGearRasterPage Class


AdjustContrast Method

32-bit
64-bit
CF
P
P
P

Description:

This method adjusts contrast, brightness and gamma. If the image is indexed and not grayscale, it modifies the image's palette, otherwise it modifies the image's pixels. Processes only color channels. Contrast mode is AUTO.

Average parameter range:

  • Contrast: -2 ... +2
    (negative means contrast inversion. In case of 1 no changes)
  • Brightness: -128...+128
  • Gamma: 0...10

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

Method ImGearRasterProcessing.Verifier.CanApplyAdjustContrast (ImGearPage page) can be called to check whether the operation can be performed or not.

Declaration:

public static void AdjustContrast(ImageGear.Core.ImGearRasterPage page, double contrast,
double brightness, double gamma)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to adjust contrast.
contrast
double
Contrast value.
brightness
double
Brightness value.
gamma
double
Gamma value.

Return Value:

None.

Sample Code:

C#
// Increases the contrast, lowers the brightness, and increases the gamma a little.
ImGearRasterProcessing.AdjustContrast(igRasterPage, 1.4, -40, 3.5);

VB .NET
' Increases the contrast, lowers the brightness, and increases the gamma a little.
ImGearRasterProcessing.AdjustContrast(igRasterPage, 1.4, -40, 3.5)

See Also:

AdjustContrast Method

AdjustContrast Method

ImGearRasterPage Class


AdjustContrast Method

32-bit
64-bit
CF
P
P
P

Description:

This method adjusts contrast, brightness, and gamma. Processes the specified range of channels.

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

If ContrastMode is equal to ImGearContrastModes.PALETTE, DIB must have a palette.

Method ImGearRasterProcessing.Verifier.CanApplyAdjustContrast (ImGearPage page, ImGearContrastModes ContrastMode) can be called to check whether the operation can be performed or not.

Declaration:

public static void AdjustContrast(ImageGear.Core.ImGearRasterPage page, double contrast,
double brightness, double gamma, ImageGear.Processing.ImGearContrastModes mode,
ImageGear.Core.ImGearChannelRange channels)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to adjust contrast
contrast
double
Contrast value
brightness
double
Brightness value
gamma
double
Gamma value
mode
ImGearContrastModes Enumeration
One of the following values:
  • ImGearContrastModes.PALETTE - image palette is adjusted. If the image does not have a palette then an exception will be generated
  • ImGearContrastMode.PIXEL - image pixels are adjusted
  • ImGearContrastMode.AUTO - adjust mode depends on the image color space
channels
ImGearChannelRange Structure
Structure that defines the channel range to process.

Return Value:

None.

See Also:

AdjustContrast Method

AdjustContrast Method

ImGearContrastOptions Class

ImGearContrastModes Enumeration

ImGearChannelRange Structure

ImGearRasterPage Class


AdjustContrast Method

32-bit
64-bit
CF
P
P
P

Description:

This method adjusts contrast, brightness, and gamma. Processes the specified range of channels.

Can be applied only to raster pages with standard (non Run-Ends) DIB.

If ContrastMode is equal to ImGearContrastModes.PALETTE, DIB must have a palette.

Method ImGearRasterProcessing.Verifier. CanApplyAdjustContrast Method (ImGearPage page, ImGearContrastModes ContrastMode) can be called to check whether the operation can be performed or not.

Declaration:

public static void AdjustContrast(ImageGear.Core.ImGearRasterPage page, double contrast,
double brightness, double gamma, ImageGear.Processing.ImGearContrastModes mode,
ImageGear.Core.ImGearChannelRange channels, ImageGear.Processing.ImGearContrastOptions
options)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to adjust contrast
contrast
double
Contrast value
brightness
double
Brightness value
gamma
double
Gamma value
mode
ImGearContrastModes Enumeration
One of the following values:
  • ImGearContrastModes.PALETTE - image palette is adjusted. If the image does not have palette then an exception will be generated
  • ImGearContrastMode.PIXEL - image pixels are adjusted
  • ImGearContrastMode.AUTO - adjust mode depends on the image color space
channels
ImGearChannelRange Structure
Structure that defines channel range to process.
options
ImGearContrastOptions Class
ImGearContrastOptions class.

Return Value:

None.

See Also:

AdjustContrast Method

AdjustContrast Method

ImGearContrastOptions Class

ImGearChannelRange Structure

ImGearContrastModes Enumeration

ImGearRasterPage Class


AdjustWhiteBalance Method

32-bit
64-bit
CF
P
P
P

Description:

This method allows to correct white balance of the image.

For example, if the image was taken in the daylight, but the camera white balance setting was set to Tungsten, white objects would display as blue. To correct this (make the white objects display white), use the AdjustWhiteBalance method, setting source white balance to Tungsten and destination white balance to Daylight.

This method can also be used to make image colors "cooler" or "warmer". To make the image look warmer, use a source white point corresponding to a higher color temperature, and a destination white point corresponding to a lower color temperature. To make the image look cooler, use a source white point corresponding to a lower color temperature, and a destination white point corresponding to a higher color temperature.

You can use ImGearWhiteBalance Class object to calculate a white point corresponding to a specific color temperature and tint, or to a preset value.

Declaration:

public static void AdjustWhiteBalance(ImGearRasterPage page, ImGearDoublePoint srcWhiteXY,
ImGearDoublePoint dstWhiteXY);

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to process.
srcWhiteXY
ImGearDoublePoint Structure
White point used when shooting the source picture
dstWhiteXY
ImGearDoublePoint Structure
Correct white point, matching actual shooting conditions better.

Return Value:

None

Availability:

All except bitonal, indexed, grayscale and colorspaces containing Alpha, Premultiplied Alpha and Extra channels.

See Also:

ImGearRasterPage Class

ImGearWhiteBalance Class


AdjustWhiteBalance Method

32-bit
64-bit
CF
P
P
P

Description:

This method allows to correct white balance of the image.

For example, if the image was taken in the daylight, but the camera white balance setting was set to Tungsten, white objects would display as blue. To correct this (make the white objects display white), use the AdjustWhiteBalance method, setting the source white balance to Tungsten and the destination white balance to Daylight.

Declaration:

public static void AdjustWhiteBalance(ImGearRasterPage page, ImGearWhiteBalancePreset
srcWhite, ImGearWhiteBalancePreset dstWhite);

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to process.
srcWhite
ImGearWhiteBalancePreset Enumeration
White balance preset value used when shooting the source picture.
dstWhite
ImGearWhiteBalancePreset Enumeration
Correct white balance preset value, matching actual shooting conditions better.

Return Value:

None

Availability:

All except bitonal, indexed, grayscale and colorspaces containing Alpha, Premultiplied Alpha and Extra channels.

See Also:

ImGearRasterPage Class


Aging Method

32-bit
64-bit
CF
P
P
P

Description:

This method applies an aging effect to make an image look older. The effect can adjust image saturation and contrast, and add noise and random vertical lines to the image.

Declaration:

public static void Aging(ImageGear.Core.ImGearRasterPage page, double saturation, double
deviation, double imageContrast, double lineContrast, int lineDensity, double[]
AgingColor)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to apply aging effect to.
saturation
double
Adjusts color saturation of the original image. The value should range from 0 to 1, where 0 removes all color from the image, and 1 does not adjust color saturation.
deviation
double
Amount of noise to add to the image. The value should range from 0 to 50.
imageContrast
double
Adjusts image contrast. The value should range from 0 to 1, where 0 is minimum contrast, and 1 does not adjust contrast. Values less than 0 produce inverted contrast.
lineContrast
double
Adjusts contrast of random vertical lines added to the image. The value should range from -1 to 1, where -1 is completely black lines, 0 is invisible lines, and 1 is completely white lines. Values between 0 and 1, for example, blend line color between original image pixel colors and white.
lineDensity
int
Adjusts density (quantity) of random vertical lines added to the image. The value should range from 0 to the width of the image in pixels, where 0 would add no lines, and the width of the image in pixels would fill the image with lines.
AgingColor
double[]
Adjusts color tint of the image. The color of the image will be tinted according to the values of the array. The array consists of three elements that represent color adjustment factors, corresponding to image colorspace. Each element ranges from -1 to 1, where a value of 0 represents no change to the image's color component, -1 represents complete change to the color component's minimum value, and 1 represents complete change to the color component's maximum value. Array length must be equal to number of image channels.

Return Value:

None

Availability:

Non bitonal RGB, grayscale and indexed with grayscale palette. Does not support grayscale with LUT.

See Also:

ImGearRasterPage Class


Blend Method

32-bit
64-bit
CF
P
P
P

Description:

This method blends two images. It does not provide any special handling for an Alpha channel. It processes color channels only.

Declaration:

public static void Blend(ImageGear.Core.ImGearRasterPage page, int left, int top,
ImageGear.Core.ImGearRasterPage pageToBlendWith, double weight,
ImageGear.Core.ImGearChannelRange channelsRange)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified
left
int
Left margin of blended image.
top
int
Top margin of blended image.
pageToBlendWith
ImGearRasterPage Class
Source image to be blended with page.
weight
double
A value from 0 to 100 defining the % weight of the image to be blended.
channelsRange
ImGearChannelRange Structure
Channels range structure

Return Value:

None.

See Also:

Blend Method

BlendWithAlpha Method

ImGearRasterPage Class

ImGearChannelRange Structure


Blend Method

32-bit
64-bit
CF
P
P
P

Description:

This method blends two images. It does not provide any special handling for an Alpha channel. It processes the specified group of channels.

Declaration:

public static void Blend(ImageGear.Core.ImGearRasterPage page, int left, int top,
ImageGear.Core.ImGearRasterPage pageToBlendWith, double weight)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified
left
int
Left margin of blended image.
top
int
Top margin of blended image.
pageToBlendWith
ImGearRasterPage Class
Source image to be blend with page.
weight
double
A value from 0 to 100 defining the % weight of the image to be blended.

Return Value:

None.

Sample Code:

C#
// Opens an image and blends it into an already open image.
using (FileStream file = new FileStream("photo.jpg",
                   FileMode.Open, FileAccess.Read, FileShare.Read))
{
    ImGearRasterPage igPageToBlend = (ImGearRasterPage)
        ImGearFileFormats.LoadPage(file, 0);
    // Blend the page with a weight of 25% starting from the point 100,100.
    ImGearRasterProcessing.Blend(igRasterPage, 100, 100, igPageToBlend, 25.0);
}

VB .NET
' Opens an image and blends it into an already open image.
Using file As New FileStream("photo.jpg", FileMode.Open, FileAccess.Read, FileShare.Read)
    Dim igPageToBlend As ImGearRasterPage = DirectCast(ImGearFileFormats.LoadPage(file, 0), ImGearRasterPage)
    ' Blend the page with a weight of 25% starting from the point 100,100.
    ImGearRasterProcessing.Blend(igRasterPage, 100, 100, igPageToBlend, 25)
End Using

See Also:

Blend Method

BlendWithAlpha Method

ImGearRasterPage Class


BlendWithAlpha Method

32-bit
64-bit
CF
P
P
P

Description:

This method blends two images with alpha. It blends Page2 over Page1 and stores the result in Page1.

Page2 should contain the Alpha channel, otherwise, an error is returned.

If Page1 does not contain an Alpha channel, Page2 is composited over it using Page1 as the background. The resulting image does not contain an Alpha channel. The following formulas are used:

    • If Page2 is not pre-multiplied,

I1 = I2 * A2 + I1 (1-A2)

    • If Page2 is pre-multiplied,

I1 = I2 + I1 (1-A2)

If Page2 contains an Alpha channel, Page1 and Page2 are blended together. The resulting image contains an alpha channel. Blending two images, both of which contain an Alpha channel, can be interpreted as placing one semi-transparent film over another semi-transparent film. The result of applying such combined images to some background is the same as applying one image over background and then applying another image to the result. Using pseudocode,

BlendWithAlpha(Page1, Page2)
BlendWithAlpha(BackPage, Page1)

produces the same result as

BlendWithAlpha(BackPage, Page1)
BlendWithAlpha(BackPage, Page2)

The following formulas are used:

if (A1=A2=0)

I1 = 0; A1 = 0;

else

    • If both Page1 and Page2 are not pre-multiplied,

I1 = (I2*A2 + I1*A1*(1-A2)) / (A1 + A2 - A1*A2)

A1 = A1 + A2 - A1*A2

Result is not pre-multiplied

    • If Page1 is not pre-multiplied, and Page2 is pre-multiplied:

I1 = (I2 + I1*A1*(1-A2)) / (A1 + A2 - A1*A2)

A1 = A1 + A2 - A1*A2

Result is not pre-multiplied

    • If Page1 is pre-multiplied, and Page2 is not:

I1 = I2*A2 + I1*(1-A2)

A1 = A1 + A2 - A1*A2

Result is pre-multiplied

    • If both Page1 and Page2 are pre-multiplied:

I1 = I2 + I1*(1-A2)

A1 = A1 + A2 - A1*A2

Result is pre-multiplied

Alpha values are mapped to a float value between 0.0 and 1.0, where 0.0 means full transparency and 1.0 means full opaquity. Alpha value of 0 corresponds to float value of 0.0 and alpha value of 2^n-1 (where n is alpha channel's bit depth) corresponds to float value of 1.0. Any ChannelDepths are allowed for color channels.

This method does not process Extra Channels.

Declaration:

public static void BlendWithAlpha(ImageGear.Core.ImGearRasterPage page, int left, int top,
ImageGear.Core.ImGearRasterPage alpha)
public static void BlendWithAlpha (ImGearDIB source, ImGearDIB alpha)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page 1
left
int
Left margin of blended image.
top
int
Top margin of blended image.
alpha
ImGearRasterPage Class
Page 2

Return Value:

None.

Sample Code:

C#
//Loads an image with an alpha channel and blends it with an already loaded image.
using (FileStream file = new FileStream("PNGTEST.png",
           FileMode.Open, FileAccess.Read, FileShare.Read))
{
    ImGearRasterPage igRasterPageAlpha = (ImGearRasterPage)
        ImGearFileFormats.LoadPage(file, 0);
    ImGearRasterProcessing.BlendWithAlpha(
        igRasterPage, 10, 10, igRasterPageAlpha);
}

VB .NET
'Loads an image with an alpha channel and blends it with an already loaded image.
Using file As New FileStream("PNGTEST.png", FileMode.Open, FileAccess.Read, FileShare.Read)
    Dim igRasterPageAlpha As ImGearRasterPage = DirectCast(ImGearFileFormats.LoadPage(file, 0), ImGearRasterPage)
    ImGearRasterProcessing.BlendWithAlpha(igRasterPage, 10, 10, igRasterPageAlpha)
End Using

See Also:

Blend Method

Blend Method

ImGearRasterPage Class


Boost Method

32-bit
64-bit
CF
P
P
P

Description:

This method increases saturation, brightness and contrast of the image. Use this method if you need a simple way to make old and faded images look more vivid.

Declaration:

public static void Boost(ImGearRasterPage page, double strength);

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to process.
strength
double
Amount by which to boost (or "unboost") colors in the image. 1.0 corresponds to no change, < 1.0 "decreases saturation and brightness, > 1.0 increases saturation and brightness.

Return Value:

None

Availability:

All except bitonal, indexed, Grayscale with LUT and colorspaces containing Alpha, Premultiplied Alpha and Extra channels.

See Also:

ImGearRasterPage Class


CalculateStatistics Method

32-bit
64-bit
CF
P
P
P

Description:

This method calculates statistics for all channels of the image, separately for each channel.

This method takes an image's Region of Interest (ROI) into account.

Declaration:

public static ImageGear.Processing.ImGearChannelStatistics[] CalculateStatistics (
ImageGear.Core.ImGearRasterPage page )

Parameters:

Name
Type
Description
Page
ImGearRasterPage Class
Page specified

Return Value:

ImGearChannelStatistics Structure.

Example:

ImGearChannelStatistics[] stats = ImGearRasterProcessing.CalculateStatistics(page)

Sample Code:

C#
// Calculate channel statistics.
string statistics = "Image Statistics:\n";
//Calculate the statistics for the image.
ImGearChannelStatistics[] igChannelStatistics = ImGearRasterProcessing.CalculateStatistics(igRasterPage);
// Build an output string using the statistics.
for (int i = 0; i < igChannelStatistics.Length; i++)
{
    statistics += "Channel " + i.ToString() + ": Min=" + igChannelStatistics[i].Min.ToString();
    statistics += ", Max=" + igChannelStatistics[i].Max.ToString();
    statistics += ", Average=" + igChannelStatistics[i].Average.ToString() + "\n";
}
MessageBox.Show(statistics, "Image Statistics");

VB .NET
' Calculate channel statistics.
Dim statistics As String = "Image Statistics:" & Chr(10) & ""
'Calculate the statistics for the image.
Dim igChannelStatistics As ImGearChannelStatistics() = ImGearRasterProcessing.CalculateStatistics(igRasterPage)
For i As Integer = 0 To igChannelStatistics.Length - 1
    ' Build an output string using the statistics.
    statistics += "Channel " + i.ToString() + ": Min=" + igChannelStatistics(i).Min.ToString()
    statistics += ", Max=" + igChannelStatistics(i).Max.ToString()
    statistics += ", Average=" + igChannelStatistics(i).Average.ToString() + "" & Chr(10) & ""
Next
MessageBox.Show(statistics, "Image Statistics")

See Also:

ImGearChannelStatistics Structure

ImGearRasterPage Class


ChangeChannelsDepths Method

32-bit
64-bit
CF
P
P
P

Description:

This method changes bit depth of image channels.

Declaration:

public static void ChangeChannelDepths(ImageGear.Core.ImGearRasterPage page, int[]
newChannelDepths)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified
newChannelDepths
int[ ]
Array with new channels depth.

Return Value:

None.

Sample Code:

C#
// Change the channel depths of 3 channel image to 3,3,2
ImGearRasterProcessing.ChangeChannelDepths(igRasterPage, new int[] { 3, 3, 2 });

VB .NET
' Change the channel depths of 3 channel image to 3,3,2
ImGearRasterProcessing.ChangeChannelDepths(igRasterPage, New Integer() {3, 3, 2})

See Also:

ChangeChannelsDepths Method

ImGearRasterPage Class


ChangeChannelsDepths Method

32-bit
64-bit
CF
P
P
P

Description:

This method changes bit depth of image channels. It does not change an image's color space, and can be applied to all colorspaces except indexed.

If dontScalePixels is False (default), pixel values are scaled according to new channel depth. Unused gaps should be filled with 0 when channel is reduced.

If dontScalePixels is True, channel depth is changed, but pixel values are not scaled. If the channel depth is increased, the pixel data is not changed. If the channel depth is decreased, the pixel value is not changed in the case when it can be accommodated within the new depth. Otherwise, it is set to the maximum value allowed by the new depth (0x0...01...1).

Declaration:

public static void ChangeChannelDepths(ImageGear.Core.ImGearRasterPage page, int[]
newChannelDepths, bool dontScalePixels)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.
newChannelDepths
Int[ ]
Array with new channel depth.
dontScalePixels
bool
Flags indicating whether or not to scale pixel values according to the new channel depth.

Return Value:

None.

See Also:

ChangeChannelsDepths Method

ImGearRasterPage Class


Close Method

32-bit
64-bit
CF
P
P
P

Description:

This method applies closing effect to provided raster page using the specified structure element. This method is applicable to any grayscale image (image with [Gy] color space).

Declaration:

public static void Close(ImageGear.Core.ImGearRasterPage page, int[,] matrix)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearPage object to apply effect to.
matrix
int
Matrix specifying a structuring element for the operation.

Return Value:

None.

See Also:

ImGearRasterPage Class

CanApplyClose Method


CombineChannels Method

32-bit
64-bit
CF
P
P
P

Description:

This method puts together image channels according to the destination color space specified by the space parameter. This function does not do any color space or pixel conversions, it merely merges pixel data from different channels together. The number of channel pages should be compatible with the destination color space. Each Page in ChannelPages array must have exactly one channel. All pages must have the same BitsPerChannel and dimensions.

Declaration:

public static ImageGear.Core.ImGearRasterPage
CombineChannels(ImageGear.Core.ImGearColorSpace space,
ImageGear.Processing.ImGearChannelRef[] channels)

Parameters:

Name
Type
Description
space
ImGearColorSpace Structure
Color space of the resulting multichannel page.
channels
ImGearChannelRef Structure
Array of channels reference to combine to multichannel page.

Return Value:

ImGearRasterPage Class.

Sample Code:

C#
// Separate original image into separate images for each channel.
ImGearChannelRef[] igChannelRefOriginal = ImGearRasterProcessing.SeparateChannels(igRasterPage);
// Save what the colorspace was of the image.
ImGearColorSpaceIDs igColorSpaceID = igRasterPage.DIB.ColorSpace.Value;
// Create a blank image with the same attributes as the original image.
ImGearRasterPage igRasterPageNew = new ImGearRasterPage(
    igRasterPage.DIB.Width, igRasterPage.DIB.Height,
    new ImGearColorSpace(igColorSpaceID),
    (int[])igRasterPage.DIB.ChannelDepths.Clone(), true);
// Separate new image into separate images for each channel.
ImGearChannelRef[] igChannelRefNew = ImGearRasterProcessing.SeparateChannels(igRasterPageNew);
// Update the first channel of the new image from the original image.
ImGearRasterProcessing.UpdateChannelFrom(igChannelRefNew[0], igChannelRefOriginal[0]);
// Combine channels back into new image.
igRasterPageNew = ImGearRasterProcessing.CombineChannels(
    new ImGearColorSpace(igColorSpaceID), igChannelRefNew);

VB .NET
' Separate original image into separate images for each channel.
Dim igChannelRefOriginal As ImGearChannelRef() = ImGearRasterProcessing.SeparateChannels(igRasterPage)
' Save what the colorspace was of the image.
Dim igColorSpaceID As ImGearColorSpaceIDs = igRasterPage.DIB.ColorSpace.Value
' Create a blank image with the same attributes as the original image.
Dim igRasterPageNew As New ImGearRasterPage( _
 igRasterPage.DIB.Width, igRasterPage.DIB.Height, New ImGearColorSpace(igColorSpaceID), _
 DirectCast(igRasterPage.DIB.ChannelDepths.Clone(), Integer()), True)
' Separate new image into separate images for each channel.
Dim igChannelRefNew As ImGearChannelRef() = ImGearRasterProcessing.SeparateChannels(igRasterPageNew)
' Update the first channel of the new image from the original image.
ImGearRasterProcessing.UpdateChannelFrom(igChannelRefNew(0), igChannelRefOriginal(0))
' Combine channels back into new image.
igRasterPageNew = ImGearRasterProcessing.CombineChannels(New ImGearColorSpace(igColorSpaceID), igChannelRefNew)

See Also:

ImGearRasterPage Class

ImGearColorSpace Structure

ImGearChannelRef Structure


ConvertColorSpace Method

32-bit
64-bit
CF
P
P
P

Description:

This method converts Page to new color space.

NOTE: Conversion to Grayscale colorspace takes into account the human eye's sensitivity to different parts of the light spectrum. ImageGear uses the following formula when converting from RGB to Grayscale: Gray = Red * 77 / 255 + Green * 151 / 255 + Blue * 28 / 255. If you need to convert an image to Grayscale using equal weights for Red, Green and Blue, or any other weights, use ConvertColorSpace(ImGearRasterPage, ImGearColorSpace, double[,])

Declaration:

public static void ConvertColorSpace(ImageGear.Core.ImGearRasterPage page,
ImageGear.Core.ImGearColorSpace newColorSpace)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to convert color space.
newColorSpace
ImGearColorSpace Structure
New color space.

Return Value:

None.

Sample Code:

C#
// Convert an image to grayscale and detect the edges in the image.
ImGearRasterProcessing.ConvertColorSpace(igRasterPage, new ImGearColorSpace(ImGearColorSpaceIDs.Gy));
ImGearRasterProcessing.EdgeDetection(igRasterPage, ImGearEdgeDetectionMethods.DIFF_RECURSIVE);

VB .NET
' Convert an image to grayscale and detect the edges in the image.
ImGearRasterProcessing.ConvertColorSpace(igRasterPage, New ImGearColorSpace(ImGearColorSpaceIDs.Gy))
ImGearRasterProcessing.EdgeDetection(igRasterPage, ImGearEdgeDetectionMethods.DIFF_RECURSIVE)

See Also:

ConvertColorSpace Method

ConvertColorSpace Method

ConvertColorSpace Method

ConvertColorSpace Method

ConvertColorSpace Method

ImGearRasterPage Class

ImGearColorSpace Structure


ConvertColorSpace Method

32-bit
64-bit
CF
P
P
P

Description:

This method Converts page to the newColorSpace. This method works in two modes:

  1. If dontScalePixels is false (default), the image's pixels are recalculated.

If the new color space differs from the old color space only by an alpha channel (add, remove, set to pre-multiplied/non-pre-multiplied), ChannelDepths of color channels are preserved. For example, 5-6-5-8 RGBA will be converted to 5-6-5 RGB. Otherwise, ChannelDepths of color channels are set to maximum of original channel depths. For example, 3-5-4 RGB will be converted to 5-5-5-5 CMYK.

Any conversions are supported, except for conversion into Indexed color space.

The following formula is used to burn alpha (i.e., to convert from RGBA/P to RGB):

If Page is not pre-multiplied:

I = I * A + B (1-A)

If Page is pre-multiplied:

I = I + B (1-A)

If the image contains extra channels and newColorSpace contains extra channels, the method does not change them.

  1. If dontScalePixels is true, the page's color space property is changed, but the pixels are not modified. The number of channels of newColorSpace should be the same as that of the original image. When converting from Indexed to Grayscale, the palette is removed. When converting from Grayscale to Indexed, a default palette is created.
NOTE: Conversion to Grayscale colorspace takes into account the human eye's sensitivity to different parts of the light spectrum. ImageGear uses the following formula when converting from RGB to Grayscale: Gray = Red * 77 / 255 + Green * 151 / 255 + Blue * 28 / 255. If you need to convert an image to Grayscale using equal weights for Red, Green and Blue, or any other weights, use ConvertColorSpace(ImGearRasterPage, ImGearColorSpace, double[,])

Declaration:

public static void ConvertColorSpace(ImageGear.Core.ImGearRasterPage page,
ImageGear.Core.ImGearColorSpace newColorSpace, bool dontScalePixels)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to convert.
newColorSpace
ImGearColorSpace Structure
New color space.
dontScalePixels
bool
Flag indicating whether or not to change pixel values according to the new color space.

Return Value:

None.

See Also:

ConvertColorSpace Method

ConvertColorSpace Method

ConvertColorSpace Method

ConvertColorSpace Method

ConvertColorSpace Method

ImGearRasterPage Class

ImGearColorSpace Structure


ConvertColorSpace Method

32-bit
64-bit
CF
P
P
P

Description:

This method converts a page to a new color space.

If the conversion removes the alpha channel from the image, the image is composited over a solid background specified by BackColor. Background should be in the same color space as the original image, but without the Alpha channel. For example, if the original image is in RGBA color space and newColorSpace is CMYK, background should have an RGB color space. The method will first transform the image into RGB and then to CMYK.

The following formula is used to burn alpha (i.e., to convert from RGBA/P to RGB):

If Page is not pre-multiplied:

I = I * A + B (1-A)

If Page is pre-multiplied:

I = I + B (1-A)

If the image contains extra channels, and newColorSpace contains extra channels, the method does not change them.

NOTE: Conversion to Grayscale colorspace takes into account human eye's sensitivity to different parts of the light spectrum. ImageGear uses the following formula when converting from RGB to Grayscale: Gray = Red * 77 / 255 + Green * 151 / 255 + Blue * 28 / 255. If you need to convert an image to Grayscale using equal weights for Red, Green and Blue, or any other weights, use ConvertColorSpace(ImGearRasterPage, ImGearColorSpace, double[,])

Declaration:

public static void ConvertColorSpace(ImageGear.Core.ImGearRasterPage page,
ImageGear.Core.ImGearColorSpace newColorSpace, ImageGear.Core.ImGearPixel background)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to change color space.
newColorSpace
ImGearColorSpace Structure
New color space.
background
ImGearPixel Class
Background to composite the image over when removing alpha channel.

Return Value:

None.

See Also:

ConvertColorSpace Method

ConvertColorSpace Method

ConvertColorSpace Method

ConvertColorSpace Method

ConvertColorSpace Method

ImGearRasterPage Class

ImGearColorSpace Structure


ConvertColorSpace Method

32-bit
64-bit
CF
P
P
P

Description:

This method converts an image's color space using the specified color profiles and rendering intent.

The image's pixel data is modified to conform to the new color space. This method does not concern itself with any of the settings of ImGearColorProfileManager Class. Instead, it allows immediate and explicit specification of color profiles to use for the conversion.

Declaration:

public static void ConvertColorSpace(ImageGear.Core.ImGearRasterPage page,
ImageGear.Core.ImGearColorSpace newColorSpace, ImageGear.Core.ImGearColorProfile
srcProfile, ImageGear.Core.ImGearColorProfile dstProfile,
ImageGear.Core.ImGearRenderingIntents renderingIntent)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to change color space.
newColorSpace
ImGearColorSpace Structure
New color space.
srcProfile
ImGearColorProfile Class
Initial color space profile.
dstProfile
ImGearColorProfile Class
The new color space profile.
renderingIntent
ImGearRenderingIntents Enumeration
Rendering intent.

Return Value:

None.

Sample Code:

C#
// Load color profiles and convert an image from CMYK into RGB color space.
// Get the base path for the running executable.
string exePath = Assembly.GetExecutingAssembly().Location;
Int32 nIndex = exePath.LastIndexOf("\\");
exePath = exePath.Remove(nIndex + 1, exePath.Length - nIndex - 1);
// Read color profiles from the executable's path.
using (FileStream fs = File.OpenRead(exePath + "ig_cmyk_profile.icm"))
    ImGearColorProfileManager.CmykProfile = new ImGearColorProfile(fs);
using (FileStream fs = File.OpenRead(exePath + "ig_rgb_profile.icm"))
    ImGearColorProfileManager.RgbProfile = new ImGearColorProfile(fs);
// Convert an opened CMYK image into the RGB colorspace using ImageGear color profiles.
ImGearRasterProcessing.ConvertColorSpace(igRasterPage,
    new ImGearColorSpace(ImGearColorSpaceIDs.RGB), ImGearColorProfileManager.CmykProfile,
    ImGearColorProfileManager.RgbProfile, ImGearRenderingIntents.PERCEPTUAL);

VB .NET
' Load color profiles and convert an image from CMYK into RGB color space.
' Get the base path for the running executable.
Dim exePath As String = Assembly.GetExecutingAssembly().Location
Dim nIndex As Int32 = exePath.LastIndexOf("\")
exePath = exePath.Remove(nIndex + 1, exePath.Length - nIndex - 1)
' Read color profiles from the executable's path.
Using fs As FileStream = File.OpenRead(exePath + "ig_cmyk_profile.icm")
    ImGearColorProfileManager.CmykProfile = New ImGearColorProfile(fs)
End Using
Using fs As FileStream = File.OpenRead(exePath + "ig_rgb_profile.icm")
    ImGearColorProfileManager.RgbProfile = New ImGearColorProfile(fs)
End Using
' Convert an opened CMYK image into the RGB colorspace using ImageGear color profiles.
ImGearRasterProcessing.ConvertColorSpace(igRasterPage, New ImGearColorSpace(ImGearColorSpaceIDs.RGB), _
 ImGearColorProfileManager.CmykProfile, ImGearColorProfileManager.RgbProfile, ImGearRenderingIntents.PERCEPTUAL)

See Also:

ConvertColorSpace Method

ConvertColorSpace Method

ConvertColorSpace Method

ConvertColorSpace Method

ConvertColorSpace Method

ImGearRasterPage Class

ImGearColorSpace Structure

ImGearColorProfile Class

ImGearRenderingIntents Enumeration


ConvertColorSpace Method

32-bit
64-bit
CF
P
P
P

Description:

Converts an image to a new color space using a conversion matrix. Destination pixels are calculated as Dst = M * Src, where M is conversion matrix. Number of channels after conversion will be equal to first of the conversionMatrix. Second dimension of conversionMatrix should be equal to number of channels in the source page.

NOTE: ImageGear provides this method for color reconstruction of Digital Camera Raw images.

Declaration:

public static void ConvertColorSpace(ImageGear.Core.ImGearRasterPage page,
ImageGear.Core.ImGearColorSpace resultColorSpace, double[,] conversionMatrix)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to change color space.
resultColorSpace
ImGearColorSpace Structure
New color space.
conversionMatrix
double[,]
Conversion matrix.

Return Value:

None.

Example:

C#
ImGearRasterProcessing.ConvertColorSpace(Page, new ImGearColorSpace(ImGearColorSpaceIDs.RGB), ConvMatrix);

Visual Basic
Dim ConvMatrix(3, 3) As Double
ImGearRasterProcessing.ConvertColorSpace(igPage, New ImGearColorSpace(ImGearColorSpaceIDs.RGB), ConvMatrix)

See Also:

ConvertColorSpace Method

ConvertColorSpace Method

ConvertColorSpace Method

ConvertColorSpace Method

ConvertColorSpace Method

ImGearRasterPage Class

ImGearColorSpace Structure

ImGearCameraRawProcessing Class

ImGearWhiteBalance Class


ConvertColorSpace Method

32-bit
64-bit
CF
P
P
P

Description:

This method converts a Page to a new color space.

If conversion removes the alpha channel from an image, the image is composited over a solid background specified by BackColor. BackColor should be in the same color space as the original image, but without the Alpha channel. For example, if original image is in RGBA color space and newColorSpace is CMYK, BackColor should have RGB color space. The method will first transform the image into RGB and then to CMYK.

The following formula is used to burn alpha (i.e., to convert from RGBA/P to RGB):

  • If Page is not pre-multiplied: I = I * A + B (1-A)
  • If Page is pre-multiplied: I = I + B (1-A)

If theimage contains extra channels, and newColorSpace contains extra channels, the method does not change them.

NOTE: Conversion to Grayscale colorspace takes into account the human eye's sensitivity to different parts of the light spectrum. ImageGear uses the following formula when converting from RGB to Grayscale: Gray = Gray = Red * 77 / 255 + Green * 151 / 255 + Blue * 28 / 255.

Declaration:

public static void ConvertColorSpace(ImGearRasterPage Page,
ImGearColorSpace newColorSpace, bool dontScalePixels,
ImGearPixel BackColor)

Parameters:

Name
Type
Description
Page
ImGearRasterPage Class
Image to change color space.
newColorSpace
ImGearColorSpace Structure
New color space.
dontScalePixels
bool
Flag indicating whether or not to change pixel values according to the new color space.
BackColor
ImGearPixel Class
Background to composite the image over when removing alpha channel.

Return Value:

None.

See Also:

ConvertColorSpace Method

ConvertColorSpace Method

ConvertColorSpace Method

ConvertColorSpace Method

ConvertColorSpace Method

ImGearRasterPage Class

ImGearColorSpace Structure

ImGearPixel Class


ConvertPixelFormat Method

32-bit
64-bit
CF
P
P
P

Description:

This method converts a single pixel to color space and channel depths of the specified ImGearPage Class.

Please note, using this function in a cycle for large array of pixels could be inefficient. Consider creating a temporary ImGearPage Class and converting its colorspace and channel depths in this case.

Declaration:

public static void ConvertPixelFormat(ImGearPixel pixel, ImGearColorSpace srcColorSpace,
int[] srcChannelDepths, ImGearRGBQuad[] srcPalette, ImGearPage pageToConvertFormatTo)

Parameters:

Name
Type
Description
pixel
ImGearPixel Class
Pixel to convert to the new format.
srcColorSpace
ImGearColorSpace Structure
Source colorspace of the pixel.
srcChannelDepths
int[]
Source channel depths of the pixel. Length of the channel depths array should correspond to the srcColorSpace parameter.
srcPalette
ImGearRGBQuad Structure
Source palette used by the pixel, if its colorspace is Indexed, or null otherwise.
pageToConvertFormatTo
ImGearPage Class
Page whose colorspace, channel depths, and palette will be used for destination format when converting the pixel.

Return Value:

None.


ConvertPixelFormat Method

32-bit
64-bit
CF
P
P
P

Description:

This method converts a single pixel to new color space and channel depths.

Please note, using this function in a cycle for a large array of pixels could be inefficient. Consider creating a temporary ImGearPage Class and converting its colorspace and channel depths in this case.

Declaration:

public static void ConvertPixelFormat(ImGearPixel pixel, ImGearColorSpace srcColorSpace,
int[] srcChannelDepths, ImGearRGBQuad[] srcPalette, ImGearColorSpace dstColorSpace,
int[] dstChannelDepths, ImGearRGBQuad[] dstPalette)

Parameters:

Name
Type
Description
pixel
ImGearPixel Class
Pixel to convert to the new format.
srcColorSpace
ImGearColorSpace Structure
Source colorspace of the pixel.
srcChannelDepths
int[]
Source channel depths of the pixel. Length of the array should correspond to the srcColorSpace parameter.
srcPalette
ImGearRGBQuad Structure
Source palette used by the pixel, if its colorspace is Indexed, or null otherwise.
dstColorSpace
ImGearColorSpace Structure
Colorspace to convert the pixel to.
dstChannelDepths
int[]
New channel depths for the pixel. Length of the array should correspond to the dstColorSpace parameter.
dstPalette
ImGearRGBQuad Structure
Destination palette for the pixel, if destination colorspace is Indexed, or null otherwise.

Return Value:

None.


Convolve Method

32-bit
64-bit
CF
P
P
P

Description:

This method provides filtering on the base of two-dimensional convolution matrix. It processes specified range of channels. Does not provide any special handling for Alpha channel.

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

Method ImGearRasterProcessing.Verifier.CanApplyConvolve can be called to check whether the operation can be performed or not.

Declaration:

public static void Convolve(ImageGear.Core.ImGearRasterPage page, int[,] mat, double
normalizer, ImageGear.Processing.ImGearConvolutionResults resultmode, bool addtoOrigin,
ImageGear.Core.ImGearChannelRange channels)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to convolve
mat
int[,]
Two-dimensional convolution matrix.
normalizer
double
Normalizer (i.e., denominator for every color component value).
resultmode
ImGearConvolutionResults Enumeration
Mode that defines how the resulting color component value interacts with the source:
  • ImGearConvolutionResults.RAW - the new color component replaces the old one. If the new value is component is negative then 0 is applied.
  • ImGearConvolutionResults.ABS the new color component replaces the old one. If the new color component is negative then its absolute value is applied.
  • ImGearConvolutionResults.SIGNED - the new color component replaces the old one. If the new color component is negative then it is added to the maximum value of the component range.
  • ImGearConvolutionResults.CENTERED - the new color component is added to the component range center and replaces the old one.
addtoOrigin
bool
If this flag is true then the new color component is added to the old one.
channels
ImGearChannelRange Structure
Range of the channels to convolve.

Return Value:

None.

Sample Code:

C#
// Convolve an image according to a matrix and normalizer.
// Convolution matrix:
int[,] matrix = new int[,] {
    {-1,1,1},
    {-1,0,1},
    {-1,-1,1}
};
// normalizer to be used as denominator for the matrix.
double normalizer = 6;
// Channel range to convolve on.
ImGearChannelRange igChannelRange = new ImGearChannelRange(0, igRasterPage.DIB.ChannelCount);
// Apply the convolution, in this case it has an emboss effect.
ImGearRasterProcessing.Convolve(igRasterPage, matrix, normalizer,
    ImGearConvolutionResults.RAW, true, igChannelRange);

VB .NET
' Convolve an image according to a matrix and normalizer.
' Convolution matrix:
Dim matrix As Integer(,) = New Integer(,) { _
 {-1, 1, 1}, _
 {-1, 0, 1}, _
 {-1, -1, 1}}
' normalizer to be used as denominator for the matrix.
Dim normalizer As Double = 6
' Channel range to convolve on.
Dim igChannelRange As New ImGearChannelRange(0, igRasterPage.DIB.ChannelCount)
' Apply the convolution, in this case it has an emboss effect.
ImGearRasterProcessing.Convolve(igRasterPage, matrix, normalizer, _
 ImGearConvolutionResults.RAW, True, igChannelRange)

See Also:

ImGearConvolutionResults Enumeration

ImGearRasterPage Class

ImGearChannelRange Structure


CreateChannelCopy Method

32-bit
64-bit
CF
P
P
P

Description:

Creates a copy of the page image channel and returns it. Content of returned ImGearChannelRef instance represents a standalone instance of ImGearRasterPage Class with grayscaled color space.

Declaration:

public static ImageGear.Processing.ImGearChannelRef
CreateChannelCopy(ImageGear.Processing.ImGearChannelRef channel)

Parameters:

Name
Type
Description
channel
ImGearChannelRef Structure
Channel to copy.

Return Value:

The copy of ImGearChannelRef Structure.

See Also:

ImGearChannelRef Structure

ImGearRasterPage Class


CreateChannelCopy Method

32-bit
64-bit
CF
P
P
P

Description:

This method copies a channel to a new page. channelNumber can be within the [0..ChannelCount-1] range.

Declaration:

public static ImageGear.Core.ImGearRasterPage
CreateChannelCopy(ImageGear.Core.ImGearRasterPage page, int channelNumber)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page from which the channel is obtained.
channelNumber
int
Channel number.

Return Value:

ImGearRasterPage Class containing a copy of the channel.

Sample Code:

C#
// Create a new image by copying the third channel of an existing image.
ImGearRasterPage igRasterPageNew = ImGearRasterProcessing.CreateChannelCopy(
    igRasterPage, 2);

VB .NET
' Create a new image by copying the third channel of an existing image.
Dim igRasterPageNew As ImGearRasterPage = ImGearRasterProcessing.CreateChannelCopy(igRasterPage, 2)

See Also:

ImGearRasterPage Class


Decrypt Method

32-bit
64-bit
CF
P
P
P

Description:

This method decrypts specified page in the document.

Declaration:

public static void Decrypt(ImageGear.Core.ImGearRasterPage page, string password)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to decrypt.
password
string
Decryption password.

Return Value:

None

Sample Code:

C#
// Decrypts an image using a pass-phrase.
ImGearRasterProcessing.Decrypt(igRasterPage, "abcdefg");

VB .NET
' Decrypts an image using a pass-phrase.
ImGearRasterProcessing.Decrypt(igRasterPage, "abcdefg")

See Also:

Encrypt Method

ImGearRasterPage Class


Deskew Method

32-bit
64-bit
CF
P
P
P

Description:

This method deskews a page image.

Declaration:

public static void Deskew(ImageGear.Core.ImGearRasterPage page, double angleThresh,
ImageGear.Processing.ImGearRotationModes mode, ImageGear.Core.ImGearPixel backgroundColor)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to deskew.
angleThresh
double
Deskew angle.
mode
ImGearRotationModes Enumeration
Deskew mode.
backgroundColor
ImGearPixel Class
background color.

Return Value:

None.

Sample Code:

C#
// Deskew an image if it is skewed by over 0.1 degrees.
ImGearRasterProcessing.Deskew(igRasterPage,
    0.1, ImGearRotationModes.CLIP, null);

VB .NET
' Deskew an image if it is skewed by over 0.1 degrees.
ImGearRasterProcessing.Deskew(igRasterPage, 0.1, ImGearRotationModes.CLIP, Nothing)

See Also:

ImGearRasterPage Class

ImGearRotationModes Enumeration

ImGearPixel Class


Despeckle Method

32-bit
64-bit
CF
P
P
P

Description:

Despeckle is used to help reduce the amount of noise in the image. Single pixels and pixel spurs on letters and graphics are removed while leaving the solid areas alone. It is typically used on 1-bit document images.

The despeckle operation performs a median filter on the image. For each pixel in the original image, a single pixel is produced in the output image. The output pixel is the median of the pixel values in the neighborhood area defined by neighborhoodWidth and neighborhoodHeight parameters.

Declaration:

public static void Despeckle(ImageGear.Core.ImGearRasterPage page, int neighborhoodWidth,
int neighborhoodHeight)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to filter.
neighborhoodWidth
int
Width of the square area.
neighborhoodHeight
int
Height of the square area.

Return Value:

None.

Sample Code:

C#
// Despeckle a 1-bit image using a 3x3 area.
ImGearRasterProcessing.Despeckle(igRasterPage, 3, 3);

VB .NET
' Despeckle a 1-bit image using a 3x3 area.
ImGearRasterProcessing.Despeckle(igRasterPage, 3, 3)

See Also:

ImGearRasterPage Class


DetectArea Method

32-bit
64-bit
CF
P
P
P

Description:

This method detects an area of pixels using a specified pixel checker. The area being detected is saved as the ROI of the page.

Declaration:

public static void DetectArea(ImageGear.Core.ImGearRasterPage page,
ImageGear.Core.ImGearPoint point, ImageGear.Processing.IImGearPixelChecker checker)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearRasterPage Class object.
point
ImGearPoint Structure
A point inside the area to be searched.
checker
IImGearPixelChecker Interface
Implementation of IImGearPixelChecker interface with the implemented method CheckPixel. See IImGearPixelChecker interface for more details.

Return Value:

None

Example:

ImGearRasterProcessing.DetectArea(page, new ImGearPoint(xPos, yPos), new
ImGearPixelCheckerRedEyeRGB(1));
NOTE: ImGearPixelCheckerRedEyeRGB Class is a predefined pixel checker here (see IImGearPixelChecker Interface).

Sample Code:

C#
// Detect an area around a point in an image based upon a base pixel and threshold.
// Top left corner of image
ImGearPoint igPoint = new ImGearPoint(0, 0);
//Get the Pixel currently there.
ImGearPixel igPixel = igRasterPage.DIB.GetPixelCopy(0, 0);
// Detection class, threshold is difference in pixel channel values from specified pixel.
ImGearPixelCheckerThreshold igPixelCheckerThreshold = new ImGearPixelCheckerThreshold(igPixel, 100);
// Detect the region around target point within the threshold.
ImGearRasterProcessing.DetectArea(igRasterPage, igPoint, igPixelCheckerThreshold);
// Invert the contrast of the selected region to visible show the detected region.
ImGearRasterProcessing.InvertContrast(igRasterPage);

VB .NET
' Detect an area around a point in an image based upon a base pixel and threshold.
' Top left corner of image
Dim igPoint As New ImGearPoint(0, 0)
'Get the Pixel currently there.
Dim igPixel As ImGearPixel = igRasterPage.DIB.GetPixelCopy(0, 0)
' Detection class, threshold is difference in pixel channel values from specified pixel.
Dim igPixelCheckerThreshold As New ImGearPixelCheckerThreshold(igPixel, 100)
' Detect the region around target point within the threshold.
ImGearRasterProcessing.DetectArea(igRasterPage, igPoint, igPixelCheckerThreshold)
' Invert the contrast of the selected region to visible show the detected region.
ImGearRasterProcessing.InvertContrast(igRasterPage)

See Also:

IImGearPixelChecker Interface

ImGearPixelCheckerRedEyeRGB Class

ImGearRasterPage Class

ImGearPoint Structure


Dilate Method

32-bit
64-bit
CF
P
P
P

Description:

This method applies dilation effect to provided raster page using the specified structure element. This method is applicable to any grayscale image (image with [Gy] color space).

Declaration:

public static void Dilate(ImageGear.Core.ImGearRasterPage page, int[,] matrix)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearPage object to apply effect to.
matrix
int
Matrix specifying a structuring element for the operation.

Return Value:

None.

See Also:

ImGearRasterPage Class

CanApplyDilate Method


DirectionalLight Method

32-bit
64-bit
CF
P
P
P

Description:

This method changes the colors of an image according to the pattern of a sine wave. The image will appear to have regularly spaced bars of light and shadow overlaid on top of it.

Declaration:

public static void DirectionalLight(ImageGear.Core.ImGearRasterPage page, float direction,
float[] amplitude, float frequency, float phase, float attenuation)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to apply direct light effect to.
direction
float
Direction to apply the effect across the image. The value is specified as an angle in degrees and ranges from 0 to 360.
amplitude
float[]
Controls the magnitude of color adjustment for each channel of the image. The number of elements of the array is typically set to the number of channels in the image. Each value should range from 0 to 2, although higher values are possible. 0 represents no change in the image color. Higher values represent more intense change. Color changes are clipped, so higher values result in a harder edge to the waveform.
frequency
float
Frequency of sine wave. The value should be from 0 to 0.5. The higher the frequency, the more bars will be visible.
phase
float
Phase of sine wave. The value should be from 0 to 2*PI (approximately 6.28). As the phase is changed, the alignment of the bars is changed. This can be used to line up the bars with image content or boundaries.
attenuation
float
Attenuation of sine wave. The value should be from -0.01 to 0.01. Attenuation adjusts how much the amplitude of the sine wave is decreased or increased as the sine wave proceeds. It can be used to cause the lighting to fade or intensify.

Return Value:

None

Availability:

All except bitonal, non-gray Indexed and Grayscale with LUT.

See Also:

ImGearRasterPage Class

CanApplyFunctionalLights Method


DirectionalWave Method

32-bit
64-bit
CF
P
P
P

Description:

This method provides a directional wave effect on the current raster page.

Declaration:

public static void DirectionalWave(ImageGear.Core.ImGearRasterPage page, float angle,
float amplitude, float frequency, float phase, float attenuation, bool interpolate,
ImageGear.Core.ImGearPixel color)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearRasterPage Class object.
angle
float
Wave angle, in radians.
amplitude
float
Wave amplitude. Measurement units - pixel / 100.
frequency
float
Wave frequency. The frequency is defined as 1 / T, where T is a wave period, in pixels.
phase
float
Wave phase, in radians.
attenuation
float
Wave attenuation. The attenuation factor of the wave is calculated as exp(-attenuation * r), where r is a distance from the wave center to the current wave point.
interpolate
bool
If this parameter is true then an interpolation is used during processing.
color
ImGearPixel Class
ImGearPixel Class color.

Return Value:

None

Availability:

All except bitonal if interpolation is off; all except bitonal, non-gray Indexed and Grayscale with LUT if interpolation is on.

Sample Code:

C#
// Warps the image with a wave at a 45 degree angle, an amplitude of 0.25, frequency of 50 pixels,
//  0 phase, and no attenuation. Interpolation is enabled, and no fill color is specified.
ImGearRasterProcessing.DirectionalWave(
    igRasterPage, (float)(45.0 / 180.0 * Math.PI), (float)(0.25), (float)(1.0 / 50.0),
    (float)(0.0), (float)(0.0), true, null);

VB .NET
' Warps the image with a wave at a 45 degree angle, an amplitude of 0.25, frequency of 50 pixels,
'  0 phase, and no attenuation. Interpolation is enabled, and no fill color is specified.
ImGearRasterProcessing.DirectionalWave(igRasterPage, CSng((45 / 180 * Math.PI)), CSng((0.25)), CSng((1 / 50)), _
 CSng((0)), CSng((0)), True, Nothing)

See Also:

CanApplyWave Method

ImGearRasterPage Class

ImGearPixel Class


DropShadow Method

32-bit
64-bit
CF
P
P
P

Description:

This method adds a drop shadow to an image. The image is enlarged to contain a background and shadowed area.

Declaration:

public static void DropShadow(ImageGear.Core.ImGearRasterPage page, int width, int
distance, int angle, ImageGear.Core.ImGearPixel insideColor, ImageGear.Core.ImGearPixel
outsideColor)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to apply drop shadow effect to.
width
int
Width of background and shadow area to add to the image.
distance
int
Distance to move image from shadow area.
angle
int
Angle (direction) of movement of image from shadow area.
insideColor
ImGearPixel Class
Color of shadow area.
outsideColor
ImGearPixel Class
Color of background.

Return Value:

None

Availability:

All except bitonal, non-gray Indexed and Grayscale with LUT.

See Also:

ImGearRasterPage Class

ImGearPixel Class


Duotone Method

32-bit
64-bit
CF
P
P
P

Description:

This method maps the darkest pixels of the image to color1, brightest pixels with color2, and other pixels to a linear combination of color1 and color2, depending on their brightness.

Declaration:

public static void Duotone(ImGearRasterPage page, ImGearPixel color1, ImGearPixel color2);

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearRasterPage Class object.
color1
ImGearPixel Class
Color to which to map the darkest areas of the source image.
color2
ImGearPixel Class
Color to which to map the lightest areas of the source image.

Return Value:

None

Availability:

All except bitonal, indexed, grayscale and colorspaces containing Alpha, Premultiplied Alpha and Extra channels.


EdgeDetection Method

32-bit
64-bit
CF
P
P
P

Description:

This method performs the edge detection operation specified by the method argument.

Can be applied only to 8bit grayscale images with one channel.

Method ImGearRasterProcessing.Verifier. CanApplyEdgeDetection Method can be called to check whether the operation can be performed or not.

Declaration:

public static void EdgeDetection(ImageGear.Core.ImGearRasterPage page,
ImageGear.Processing.ImGearEdgeDetectionMethods method)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
An ImGearRasterPage Class object on which the algorithm will be performed.
method
ImGearEdgeDetectionMethods Enumeration
Type of edge detection method to perform.

Return Value:

None.

Sample Code:

C#
// Convert an image to grayscale and detect the edges in the image.
ImGearRasterProcessing.ConvertColorSpace(igRasterPage, new ImGearColorSpace(ImGearColorSpaceIDs.Gy));
ImGearRasterProcessing.EdgeDetection(igRasterPage, ImGearEdgeDetectionMethods.DIFF_RECURSIVE);

VB .NET
' Convert an image to grayscale and detect the edges in the image.
ImGearRasterProcessing.ConvertColorSpace(igRasterPage, New ImGearColorSpace(ImGearColorSpaceIDs.Gy))
ImGearRasterProcessing.EdgeDetection(igRasterPage, ImGearEdgeDetectionMethods.DIFF_RECURSIVE)

See Also:

ImGearEdgeDetectionMethods Enumeration

ImGearRasterPage Class


EdgeMap Method

32-bit
64-bit
CF
P
P
P

Description:

This method performs the edge map operation specified by the Method argument. Processes the specified range of channels.

An edge map is an image that shows where there are changes in contrast in the original image. Where there are no changes, the resulting image is black. The stronger the contrast change, the brighter the resultant image. The different types of edge maps are slight variations of the algorithms used, and produce slightly different results.

This method takes into account the ROI settings of page object, that are accessible via the ImGearRasterPage Class .ROI property. By default ROI is set to the entire image.

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

Method ImGearRasterProcessing.Verifier. CanApplyEdgeMap Method can be called to check whether the operation can be performed or not.

Declaration:

public static void EdgeMap(ImageGear.Core.ImGearRasterPage page,
ImageGear.Processing.ImGearEdgeMapMethods method, ImageGear.Core.ImGearChannelRange
channels)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
An ImGearRasterPage Class object to detect edge map for.
method
ImGearEdgeMapMethods Enumeration
Type of edge map operation to perform.
channels
ImGearChannelRange Structure
Channel range to apply the operation.

Return Value:

None.

See Also:

ImGearEdgeMapMethods Enumeration

ImGearChannelRange Structure

ImGearRasterPage Class


EdgeMap Method

32-bit
64-bit
CF
P
P
P

Description:

This method performs the edge map operation specified by the Method argument. Processes color channels only.

An edge map is an image that shows where there are changes in contrast in the original image. Where there are no changes, the resulting image is black. The stronger the contrast change, the brighter the resultant image. The different types of edge maps are slight variations of the algorithms used, and produce slightly different results.

This method takes into account the ROI settings of page object that are accessible via the ImGearRasterPage Class .ROI property. By default ROI is set to the entire image.

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

Method ImGearRasterProcessing.Verifier. CanApplyEdgeMap Method can be called to check whether the operation can be performed or not.

Declaration:

public static void EdgeMap(ImageGear.Core.ImGearRasterPage page,
ImageGear.Processing.ImGearEdgeMapMethods method)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
An ImGearRasterPage Class object to detect edge map for.
method
ImGearEdgeMapMethods Enumeration
Type of edge map operation to perform.

Return Value:

None.

Sample Code:

C#
// Filters an image into an edge map.
ImGearRasterProcessing.EdgeMap(igRasterPage, ImGearEdgeMapMethods.PREWITT);

VB .NET
' Filters an image into an edge map.
ImGearRasterProcessing.EdgeMap(igRasterPage, ImGearEdgeMapMethods.PREWITT)

See Also:

ImGearEdgeMapMethods Enumeration

ImGearRasterPage Class


Encrypt Method

32-bit
64-bit
CF
P
P
P

Description:

This method encrypts specified page in the document.

Declaration:

public static void Encrypt(ImageGear.Core.ImGearRasterPage page, string password)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to encrypt.
password
string
Encryption password.

Return Value:

None

Sample Code:

C#
// Encrypts an image using a pass-phrase.
ImGearRasterProcessing.Encrypt(igRasterPage, "abcdefg");

VB .NET
' Encrypts an image using a pass-phrase.
ImGearRasterProcessing.Encrypt(igRasterPage, "abcdefg")

See Also:

ImGearRasterPage Class


EnhanceLocal Method

32-bit
64-bit
CF
P
P
P

Description:

This method enhances an image using the local standard deviation and mean.

It transforms the input image f(x, y) to a new image g(x, y) based on the following formula,

g(x, y) = A(x, y) * [f(x, y) - m(x, y)] + m(x, y)

where,

A(x, y) = k * M / sigma(x, y), with k being a scaling factor within the range [0, 1], m(x, y) and sigma(x, y) being the local mean and local standard deviation, and M being the global mean of the input image.

To avoid the problem of spikes caused by too small local standard deviation, a check against the minimum allowed standard deviation is performed. If the local standard deviation is too small, the minimum allowed instead will be used in the calculation.

Can be applied only to 8bit grayscale images with one channel.

Method ImGearRasterProcessing.Verifier. CanApplyEnhanceLocal Method can be called to check whether the operation can be performed or not.

Declaration:

public static void EnhanceLocal(ImageGear.Core.ImGearRasterPage page, int nWinWidth, int
nWinHeight, double dScaleFactor, double dMinStdDev)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
An ImGearRasterPage Class object to which algorithm will be performed.
nWinWidth
int
Width of the local window.
nWinHeight
int
Height of the local window.
dScaleFactor
double
Scaling factor.
dMinStdDev
double
Minimum allowed standard deviation.

Return Value:

None

Sample Code:

C#
// Enhance the image using EnhanceLocal using a 3x3 window,
//  0.5 scale factor, and 1.0 minimum standard deviation.
ImGearRasterProcessing.EnhanceLocal(igRasterPage, 3, 3, 0.5, 1.0);

VB .NET
' Enhance the image using EnhanceLocal using a 3x3 window,
'  0.5 scale factor, and 1.0 minimum standard deviation.
ImGearRasterProcessing.EnhanceLocal(igRasterPage, 3, 3, 0.5, 1)

See Also:

ImGearRasterPage Class


EqualizeContrast Method

32-bit
64-bit
CF
P
P
P

Description:

This method equalizes the image contrast. If the image is indexed and not grayscale, it modifies the image's palette, otherwise it modifies the image's pixels. It processes only color channels.

This method can be applied only to the raster pages with standard (non Run-Ends) DIB.

Method ImGearRasterProcessing.Verifier. CanApplyEqualizeContrast Method (ImGearPage page) can be called to check whether the operation can be performed or not.

Declaration:

public static void EqualizeContrast(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to equalize.

Return Value:

None

See Also:

ImGearRasterPage Class


EqualizeContrast Method

32-bit
64-bit
CF
P
P
P

Description:

This method equalizes the image contrast. It processes aspecified range of channels.

It can be applied only to raster pages with standard (non Run-Ends) DIB.

If ContrastMode is equal to ImGearContrastModes.PALETTE, DIB must have a palette.

Method ImGearRasterProcessing.Verifier. CanApplyEqualizeContrast Method (ImGearPage page, ImGearContrastModes ContrastMode) can be called to check whether the operation can be performed or not.

Declaration:

public static void EqualizeContrast(ImageGear.Core.ImGearRasterPage page,
ImageGear.Processing.ImGearContrastModes mode, ImageGear.Core.ImGearChannelRange channels)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to equalize
mode
ImGearContrastModes Enumeration
One of the contrast processing modes: PALETTE, PIXELS, AUTO. See ImGearContrastModes for description.
channels
ImGearChannelRange Structure
Channel range to apply EqualizeContrast

Return Value:

None.


Erode Method

32-bit
64-bit
CF
P
P
P

Description:

This method applies erosion effect to the provided raster page using the specified structure element. This method is applicable to any grayscale image (image with [Gy] color space).

Declaration:

public static void Erode(ImageGear.Core.ImGearRasterPage page, int[,] matrix)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearPage object to apply effect to.
matrix
int
Matrix specifying a structuring element for the operation.

Return Value:

None.

See Also:

ImGearRasterPage Class

CanApplyErode Method


Export Method

32-bit
64-bit
CF
P
P
P

Description:

Exports content of raster page to managed GDI+ image.

Since Bitmap stores pixels in RGB or Indexed format only, color space conversion is used to transfer image data.

Declaration:

public static System.Drawing.Bitmap Export(ImageGear.Core.ImGearRasterPage page, int ppmX,
int ppmY)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Raster page to be exported.
ppmX
int
Specifies horizontal resolution of resulting GDI+ bitmap object. Measurement unit is PPM, i.e., pixels per meter.
ppmY
int
Specifies vertical resolution of resulting GDI+ bitmap object. Measurement unit is PPM, i.e., pixels per meter.

Return Value:

Instance of System.Drawing.Bitmap.

Sample Code:

C#
// Source rectangle to export.
ImGearRectangle igRectangleSource = new ImGearRectangle(igRasterPage.DIB.Width, igRasterPage.DIB.Height);
// Destination rectangle to export.
ImGearRectangle igRectangleDestination = new ImGearRectangle(32, 32);
ImGearChannelRange igChannelRange = new ImGearChannelRange(0, igRasterPage.DIB.ChannelCount);
// Export the image to a bitmap and assign that to a standard picturebox.
Bitmap bitmapExport = ImGearRasterProcessing.Export(igRasterPage, 2834, 2834);
bitmapForm.pictureBox1.Image = bitmapExport;

VB .NET
' Source rectangle to export.
Dim igRectangleSource As New ImGearRectangle(igRasterPage.DIB.Width, igRasterPage.DIB.Height)
' Destination rectangle to export.
Dim igRectangleDestination As New ImGearRectangle(32, 32)
Dim igChannelRange As New ImGearChannelRange(0, igRasterPage.DIB.ChannelCount)
' Export the image to a bitmap and assign that to a standard picturebox.
Dim bitmapExport As Bitmap = ImGearRasterProcessing.Export(igRasterPage, 2834, 2834)
bitmapForm1.PictureBox1.Image = bitmapExport

See Also:

ImGearRasterPage Class


Export Method

32-bit
64-bit
CF
P
P
P

Description:

Exports an image of the page to GDI+ bitmap with the ability to specify the rectangular part of the image being exported and the interpolation method that should be used to resize the specified image part to device rectangle.

For more information see Displaying images topic.

Declaration:

public static System.Drawing.Bitmap Export(ImageGear.Core.ImGearRasterPage page,
ImageGear.Core.ImGearRectangle imageRect, ImageGear.Core.ImGearRectangle deviceRect,
ImageGear.Core.ImGearRectangle clipRect, ImageGear.Processing.ImGearInterpolationOptions
interpolationOptions, ImageGear.Core.ImGearRGBQuad backgroundColor, int ppmX, int ppmY)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to be exported.
imageRect
ImGearRectangle Structure
Part of image to export.
deviceRect
ImGearRectangle Structure
Output area onto which exported image part will be scaled.
clipRect
ImGearRectangle Structure
Interested part of device rectangle.
interpolationOptions
ImGearInterpolationOptions Class
Interpolation method used to resize from image rectangle to device.
backgroundColor
ImGearRGBQuad Structure
Background pixel to blend exporting page with. It's used only if the given page contains alpha or premultiplied alpha channel.
ppmX
int
Specifies horizontal resolution of resulting GDI+ bitmap object. Measurement unit is PPM, i.e., pixels per meter.
ppmY
int
Specifies vertical resolution of resulting GDI+ bitmap object. Measurement unit is PPM, i.e., pixels per meter.

Return Value:

Instance of System.Drawing.Bitmap class.

See Also:

ImGearRasterPage Class

ImGearRectangle Structure

ImGearInterpolationOptions Class

ImGearRGBQuad Structure


Export Method

32-bit
64-bit
CF
P
P
P

Description:

Exports an image of the given page to GDI+ image. If the incoming page contains an alpha or a premultiplied alpha channel, background pixel is used to blend the image with.

Since Bitmap stores pixels in RGB or Indexed format only, color space conversion is used to transfer image data.

Declaration:

public static System.Drawing.Bitmap Export(ImageGear.Core.ImGearRasterPage page,
ImageGear.Core.ImGearRGBQuad backgroundColor, int ppmX, int ppmY)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to be exported.
background
ImGearRGBQuad Structure
Background pixel to blend exporting page with. It's used only if given page contains alpha or premultiplied alpha channel.
ppmX
int
Specifies horizontal resolution of resulting GDI+ bitmap object. Measurement unit is PPM, i.e., pixels per meter.
ppmY
int
Specifies vertical resolution of resulting GDI+ bitmap object. Measurement unit is PPM, i.e., pixels per meter.

Return Value:

Instance of System.Drawing.Bitmap.

See Also:

ImGearRasterPage Class

ImGearRGBQuad Structure


FilterWithMedian Method

32-bit
64-bit
CF
P
P
P

Description:

This method removes color noise from the image. It looks for an average color value inside the square area near the pixel and replaces the pixel with this value. Processes color channels only.

Method ImGearRasterProcessing.Verifier. CanApplyFilterWithMedian Method can be called to check whether the operation can be performed or not.

Declaration:

public static void FilterWithMedian(ImageGear.Core.ImGearRasterPage page, int
neighborhoodWidth, int neighborhoodHeight)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to filter.
neighborhoodWidth
int
Width of the square area.
neighborhoodHeight
int
Height of the square area.

Return Value:

None

Sample Code:

C#
// Changes each pixel to the median of a 3x3 area around the pixel.
ImGearRasterProcessing.FilterWithMedian(igRasterPage, 3, 3);

VB .NET
' Changes each pixel to the median of a 3x3 area around the pixel.
ImGearRasterProcessing.FilterWithMedian(igRasterPage, 3, 3)

See also:

ImGearRasterPage Class


FilterWithMedian Method

32-bit
64-bit
CF
P
P
P

Description:

This method removes color noise from the image. It looks for an average color value inside the square area near the pixel and replaces the pixels with this value. Processes a specified range of channels.

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

Method ImGearRasterProcessing.Verifier. CanApplyFilterWithMedian Method can be called to check whether the operation can be performed or not.

Declaration:

public static void FilterWithMedian(ImageGear.Core.ImGearRasterPage page, int
neighborhoodWidth, int neighborhoodHeight, ImageGear.Core.ImGearChannelRange channels)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to filter.
neighborhoodWidth
int
Width of the square area.
neighborhoodHeight
int
Height of the square area.
channels
ImGearChannelRange Structure
Channel range.

Return Value:

None

See Also:

ImGearRasterPage Class

ImGearChannelRange Structure


FilterWithUnsharpMask Method

32-bit
64-bit
CF
P
P
P

Description:

This method provides UnsharpMask filtering. It processes color channels only.

Declaration:

public static void FilterWithUnsharpMask(ImageGear.Core.ImGearRasterPage page, double
radius, int amount, int threshold)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to filter.
radius
double
Radius of unsharp mask.
amount
int
Amount of unsharpening.
threshold
int
Unsharpening threshold.

Return Value:

None

See Also:

ImGearRasterPage Class


FilterWithUnsharpMask Method

32-bit
64-bit
CF
P
P
P

Description:

This method provides UnsharpMask filtering. It processes a specified range of channels.

Declaration:

public static void FilterWithUnsharpMask(ImageGear.Core.ImGearRasterPage page, double
radius, int amount, int threshold, ImageGear.Core.ImGearChannelRange channels)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to filter.
radius
double
Radius of unsharp mask.
amount
int
Amount of unsharpening.
threshold
int
Unsharpening threshold.
channels
ImGearChannelRange Structure
Channel range.

Return Value:

None

Sample Code:

C#
// Channel range to calculate.
ImGearChannelRange igChannelRange = new ImGearChannelRange(0, igRasterPage.DIB.ChannelCount);
// Apply an unsharp mask to the image with a radius of 7.5, strength of 100, and threshold of 30
ImGearRasterProcessing.FilterWithUnsharpMask(igRasterPage, 7.5, 100, 30, igChannelRange);

VB .NET
' Channel range to calculate.
Dim igChannelRange As New ImGearChannelRange(0, igRasterPage.DIB.ChannelCount)
' Apply an unsharp mask to the image with a radius of 7.5, strength of 100, and threshold of 30
ImGearRasterProcessing.FilterWithUnsharpMask(igRasterPage, 7.5, 100, 30, igChannelRange)

See Also:

ImGearRasterPage Class

ImGearChannelRange Structure


FindSkewAngle Method

32-bit
64-bit
CF
P
P
P

Description:

This method determines skew angle.

Declaration:

public static double FindSkewAngle(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to deskew.

Return Value:

Double value.

Sample Code:

C#
// Find the skew angle of an image.
double angle = ImGearRasterProcessing.FindSkewAngle(igRasterPage);
// Rotate image by the found skew angle.
ImGearProcessing.Rotate(igRasterPage,angle, ImGearRotationModes.CLIP, null);

VB .NET
' Find the skew angle of an image.
Dim angle As Double = ImGearRasterProcessing.FindSkewAngle(igRasterPage)
' Rotate image by the found skew angle.
ImGearProcessing.Rotate(igRasterPage, angle, ImGearRotationModes.CLIP, Nothing)

See Also:

ImGearRasterPage Class


FindTilt Method

32-bit
64-bit
CF
P
P
P

Description:

This method computes the least-squares best fit plane for an image. The plane will be given by formula:

f(x, y) = SlopeX * x + SlopeY * y + Piston.

Can be applied only to 8, 16 or 32bit grayscale images with one channel.

Method ImGearRasterProcessing.Verifier. CanApplyFindTilt Method can be called to check whether the operation can be performed or not.

Declaration:

public static void FindTilt(ImageGear.Core.ImGearRasterPage page, out double dSlopeX, out
double dSlopeY, out double dPiston)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
An ImGearRasterPage Class object in which algorithm will be performed.
dSlopeX
double
Returns the slope in the X direction of the tilt plane.
dSlopeY
double
Returns the slope in the Y direction of the tilt plane.
dPiston
double
Returns the piston of the tilt plane.

Return Value:

None.

Sample Code:

C#
// Find the tilt of an image.
double slopeX, slopeY, piston;
ImGearRasterProcessing.FindTilt(igRasterPage, out slopeX, out slopeY, out piston);
// Add the found tilt from the image, in effect removing it.
ImGearRasterProcessing.AddTilt(igRasterPage, slopeX, slopeY);

VB .NET
' Find the tilt of an image.
Dim slopeX As Double, slopeY As Double, piston As Double
ImGearRasterProcessing.FindTilt(igRasterPage, slopeX, slopeY, piston)
' Add the found tilt from the image, in effect removing it.
ImGearRasterProcessing.AddTilt(igRasterPage, slopeX, slopeY)

See Also:

ImGearRasterPage Class, CanApplyFindTilt Method


Fragment Method

32-bit
64-bit
CF
P
P
P

Description:

This method fragments an image into four blended images that move diagonally outward from the original image.

Declaration:

public static void Fragment(ImageGear.Core.ImGearRasterPage page, int displacement)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to apply fragment effect to.
displacement
int
Distance in pixels to move each blended image away from the original image.

Return Value:

None

Availability:

All except bitonal, non-gray Indexed and Grayscale with LUT.

See Also:

ImGearRasterPage Class


FreeDirectionalLight Method

32-bit
64-bit
CF
P
P
P

Description:

This method changes the colors of an image according to the pattern of a sine wave. The image will appear to have regularly spaced bars of light and/or shadow overlaid on top of it.

Declaration:

public static void FreeDirectionalLight(ImageGear.Core.ImGearRasterPage page, float
direction, float[] points, float[] amplitude, float frequency, float phase, float
attenuation)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to apply free directional light effect to.
direction
float
Direction to apply the effect across the image. The value is specified as an angle in degrees and ranges from 0 to 360.
points
float[]
Array of points containing relative light deviations along the period of the sine wave. Each value typically ranges from -1 to 1. The number of points is flexible and should be chosen based on the period length relative to the image size and desired resolution of the effect.
amplitude
float[]
Controls the magnitude of color adjustment for each channel of the image. The number of elements of the array is typically set to the number of channels in the image. Each value should range from 0 to 2, although higher values are possible. 0 represents no change in the image color. Higher values represent more intense change. Color changes are clipped, so higher values result in a harder edge to the waveform.
frequency
float
Frequency of sine wave. The value should be from 0 to 0.5. The higher the frequency, the more bars will be visible.
phase
float
Phase of sine wave. The value should be from 0 to 2*PI (approximately 6.28). As the phase is changed, the alignment of the bars is changed. This can be used to line up the bars with image content or boundaries.
attenuation
float
Attenuation of sine wave. The value should be from -0.01 to 0.01. Attenuation adjusts how much the amplitude of the sine wave is decreased or increased as the sine wave proceeds. It can be used to cause the lighting to fade or intensify.

Return Value:

None

Availability:

All except bitonal, non-gray Indexed and Grayscale with LUT.

See Also:

ImGearRasterPage Class

CanApplyFunctionalLights Method


FreeRadialLight Method

32-bit
64-bit
CF
P
P
P

Description:

This method changes the colors of an image according to the pattern of a sine wave. The image will appear to have regularly spaced bars of light and/or shadow overlaid on top of it in a radial pattern.

Declaration:

public static void FreeRadialLight(ImageGear.Core.ImGearRasterPage page,
ImageGear.Core.ImGearPoint center, float[] points, float[] amplitude, float frequency,
float phase, float attenuation)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to apply free radial light effect to.
center
ImGearPoint Structure
Center point in the image (in pixels) about which the effect is applied.
points
float[]
Array of points containing relative light deviations along the period of the sine wave. Each value typically ranges from -1 to 1. The number of points is flexible and should be chosen based on the period length relative to the image size and desired resolution of the effect.
amplitude
float[]
Controls the magnitude of color adjustment for each channel of the image. The number of elements of the array is typically set to the number of channels in the image. Each value should range from 0 to 2, although higher values are possible. 0 represents no change in the image color. Higher values represent more intense change. Color changes are clipped, so higher values result in a harder edge to the waveform.
frequency
float
Frequency of sine wave. The value should be from 0 to 0.5. The higher the frequency, the more bars will be visible.
phase
float
Phase of sine wave. The value should be from 0 to 2*PI (approximately 6.28). As the phase is changed, the alignment of the bars is changed. This can be used to line up the bars with image content or boundaries.
attenuation
float
Attenuation of sine wave. The value should be from -0.01 to 0.01. Attenuation adjusts how much the amplitude of the sine wave is decreased or increased as the sine wave proceeds. It can be used to cause the lighting to fade or intensify.

Return Value:

None

Availability:

All except bitonal, non-gray Indexed and Grayscale with LUT.

See Also:

ImGearRasterPage Class

ImGearPoint Structure

CanApplyFunctionalLights Method


GaussianBlur Method

32-bit
64-bit
CF
P
P
P

Description:

This method smoothes the images using Gaussian transform. It makes images look softer and out of focus.

The radius parameter corresponds to the Standard Deviation (Sigma) in Gaussian transform. It can range from 0.1 to 500. Typical values for high-resolution images range from 1.0 to 2.0. Larger values will cause greater softening. On the other hand, smaller values are faster. The width of the area considered for each pixel is approximately 6 * radius.

The method only blurs color channels of the image. If the image contains Alpha or Extra channels, the method does not blur them.

Declaration:

public static void GaussianBlur(ImGearRasterPage page, double radius);

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to process.
radius
double
Defines the neighborhood to be considered for each pixel.

Return Value:

None

See Also:

ImGearRasterPage Class


GaussianBlur Method

32-bit
64-bit
CF
P
P
P

Description:

This method smoothes the images using Gaussian transform. It makes images look softer and out of focus.

The radius parameter corresponds to the Standard Deviation (Sigma) in Gaussian transform. It can range from 0.1 to 500. Typical values for high-resolution images range from 1.0 to 2.0. Larger values will cause greater softening. On the other hand, smaller values are faster. The width of the area considered for each pixel is approximately 6 * radius.

The method allows to specify the range of channels to blur.

Declaration:

public static void GaussianBlur(ImGearRasterPage page, double radius, ImGearChannelRange
channels);

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to process.
radius
double
Defines the neighborhood to be considered for each pixel.
channels
ImGearChannelRange Structure
Defines image channels to apply the transform to.

Return Value:

None

See Also:

ImGearRasterPage Class

ImGearChannelRange Structure


GeomDespeckle Method

32-bit
64-bit
CF
P
P
P

Description:

This method is used to reduce speckle noise from an image by using the Crimmins algorithm.

It reduces the speckle index of an image by sending the image through a geometric filter, which uses the complementary hulling technique.

The method has the effect of reducing the undesired speckle noise while preserving the edges of the original image.

Can be applied only to 8bit grayscale images with one channel.

Method ImGearRasterProcessing.Verifier.CanApplyGeomDespeckle Method can be called to check whether the operation can be performed or not.

Declaration:

public static void GeomDespeckle(ImageGear.Core.ImGearRasterPage page, int nIterations)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
An ImGearRasterPage Class object on which algorithm will be performed.
nIterations
int
Number of iterations to apply the despeckle filter.

Return Value:

None

Sample Code:

C#
// Despeckle an 8-bit grayscale image with 3 iterations.
ImGearRasterProcessing.GeomDespeckle(igRasterPage, 3);

VB .NET
' Despeckle an 8-bit grayscale image with 3 iterations.
ImGearRasterProcessing.GeomDespeckle(igRasterPage, 3)

See Also:

ImGearRasterPage Class


GlowingEdges Method

32-bit
64-bit
CF
P
P
P

Description:

This method applies a Glowing Edges effect on the image. It highlights edges on the image with bright colors, and fills flat areas with black.

Declaration:

public static void GlowingEdges(ImGearRasterPage page, int Intensity, int Sharpness,
double Saturation);

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to process.
Intensity
int
Specifies intensity for the glowing edges. Useful range is 1...10
Sharpness
int
Removes dark pixels from result image, leaving only bright edges. Valid range is 0..255.
Saturation
double
Adjusts saturation of the result image. Useful range is 0.1...2.0; Set saturation to 1.0 to leave saturation unchanged.

Return Value:

None

Availability:

All except bitonal, indexed, Grayscale with LUT and colorspaces containing Alpha, Premultiplied Alpha and Extra channels.

See Also:

ImGearRasterPage Class


HighDensityRangeEffect Method

32-bit
64-bit
CF
P
P
P

Description:

This method applies a High Density Range effect on the image. It increases contrast separately in shadow, highlight, and midtone areas, imitating the human eye's ability to adapt for light conditions at the point of interest.

Declaration:

public static void HighDensityRangeEffect(ImGearRasterPage page, double shadowStart,
double shadowEnd, double shadowThreshold, double highlightStart, double highlightEnd,
double highlightThreshold, double midtoneStart, double midtoneEnd, double radius);

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to process.
shadowStart
double
Start intensity for the shadow range. Valid values are from 0.0 to shadowEnd. Set this parameter to a non-zero value if there are no black pixels in the image.
shadowEnd
double
End intensity for the shadow range. Valid values are from 0.0 to 1.0, but the typical range is between 0.0 and 0.5. ShadowStart and shadowEnd parameters define the range of pixels that will be brightened.
shadowThreshold
double
Maximum brightness for brightened shadow pixels, at which they will be included into the result image. Brighter pixels will be blended as semi-transparent with the result image.
highlightStart
double
Start intensity for the highlight range. Valid values are from 0.0 to 1.0, but the typical range is between 0.5 and 1.0. HighlightStart and highlightEnd parameters define the range of pixels that will be darkened.
highlightEnd
double
End intensity for the highlight range. Valid values are from highlightStart to 1.0. Set this parameter to a value that is less than 1.0 if there are no pixels with maximal brightness in the image.
highlightThreshold
double
Minimum brightness for darkened highlight pixels, at which they will be included into the result image. Darker pixels will be blended as semi-transparent with the result image.
midtoneStart
double
Start intensity for the midtone range. Valid values are from 0.0 to 1.0, but the typical range is between 0.0 and 0.5.
midtoneEnd
double
End intensity for the midtone range. Valid values are from 0.0 to 1.0, but the typical range is between 0.5 and 1.0. MidtoneStart and midtoneEnd parameters define increase contrast for the midtone range.
radius
double
Radius that defines the width of the edge between highlight and midtone areas. Smaller values make the details sharper, but may result in too frequent changes between shadow and highlight areas, actually reducing image contrast and resulting in possible artifacts. Greater values make shadow and highlight areas bigger and smoother, but may result in halos between the shadow and highlight areas. Greater values also result in longer processing. Useful values are in range from 1.0 to 1/4 of the image's smaller dimension.

Return Value:

None

Availability:

All except bitonal, indexed, Grayscale with LUT and colorspaces containing Alpha, Premultiplied Alpha and Extra channels.

See Also:

ImGearRasterPage Class


HotWax Method

32-bit
64-bit
CF
P
P
P

Description:

This method applies a HotWax effect on the image, making it look like it has been coated with wax.

Declaration:

public static void HotWax(ImGearRasterPage page, ImGearPixel color);

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to process.
color
ImGearPixel Class
Color that imitates the wax color. It is better to use light colors, to avoid overdarkening of the image.

Return Value:

None

Availability:

All except bitonal, indexed, Grayscale with LUT and colorspaces containing Alpha, Premultiplied Alpha and Extra channels.

See Also:

ImGearRasterPage Class

ImGearPixel Class


ImageIsGray Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if either of the two conditions are met:

  • Image has grayscale color space.
  • Image has indexed color space, and palette is either linear gray, or inverted gray.

Declaration:

public static bool ImageIsGray(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to test.

Return Value:

True or False

Sample Code:

C#
// Make sure the image is gray.
if (!ImGearRasterProcessing.ImageIsGray(igRasterPage))
    return;
// Create a LUT to convert image from 8bit to 4bit while also inverting.
ImGearMultichannelLUT igMultichannelLUT = new ImGearMultichannelLUT(
    igRasterPage.DIB.ChannelCount, 8, 4);
for (int i = 0; i < 255; ++i )
{
    igMultichannelLUT[0][i] = 15 - (i / 16);
}
// Transform the image with the LUT.
ImGearRasterProcessing.TransformWithLUT(igRasterPage,igMultichannelLUT);

VB .NET
' Make sure the image is gray.
If Not ImGearRasterProcessing.ImageIsGray(igRasterPage) Then
    Return
End If
' Create a LUT to convert image from 8bit to 4bit while also inverting.
Dim igMultichannelLUT As New ImGearMultichannelLUT(igRasterPage.DIB.ChannelCount, 8, 4)
For i As Integer = 0 To 254
    igMultichannelLUT(0)(i) = 15 - (i / 16)
Next
' Transform the image with the LUT.
ImGearRasterProcessing.TransformWithLUT(igRasterPage, igMultichannelLUT)

See Also:

ImGearRasterPage Class


InsertChannel Method

32-bit
64-bit
CF
P
P
P

Description:

This method inserts a channel to the Page's DIB and changes color space.

Declaration:

public static void InsertChannel(ImageGear.Core.ImGearRasterPage page, int newChannelPos,
ImageGear.Processing.ImGearChannelRef channel)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to insert channel.
newChannelPos
int
Position of the channel in the page.
channel
ImGearChannelRef Structure
Reference to the channel to be inserted.

Return Value:

None

Sample Code:

C#
// Separate image into separate images for each channel.
ImGearChannelRef[] igChannelRef = ImGearRasterProcessing.SeparateChannels(igRasterPage);
// Remove the alpha channel from an RGBA image.
ImGearRasterProcessing.RemoveChannel(igRasterPage, 3);
// Save the page out without the alpha channel.
using (FileStream localFile = new FileStream("withoutalpha.jpg", FileMode.Create))
{
    ImGearFileFormats.SavePage(igRasterPage,localFile, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.JPG);
}
//Set the colorspace to RGBA again.
ImGearRasterProcessing.ConvertColorSpace(
    igRasterPage, new ImGearColorSpace(ImGearColorSpaceIDs.RGBA));
// Add the alpha channel back to the image.
ImGearRasterProcessing.InsertChannel(igRasterPage, 3, igChannelRef[3]);
// Remove the alpha channel added by the colorspace conversion.
ImGearRasterProcessing.RemoveChannel(igRasterPage, 4);

VB .NET
' Separate image into separate images for each channel.
Dim igChannelRef As ImGearChannelRef() = ImGearRasterProcessing.SeparateChannels(igRasterPage)
' Remove the alpha channel from an RGBA image.
ImGearRasterProcessing.RemoveChannel(igRasterPage, 3)
' Save the page out without the alpha channel.
Using localFile As New FileStream("withoutalpha.jpg", FileMode.Create)
    ImGearFileFormats.SavePage(igRasterPage, localFile, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.JPG)
End Using
'Set the colorspace to RGBA again.
ImGearRasterProcessing.ConvertColorSpace(igRasterPage, New ImGearColorSpace(ImGearColorSpaceIDs.RGBA))
' Add the alpha channel back to the image.
ImGearRasterProcessing.InsertChannel(igRasterPage, 3, igChannelRef(3))
' Remove the alpha channel added by the colorspace conversion.
ImGearRasterProcessing.RemoveChannel(igRasterPage, 4)

See Also:

ImGearRasterPage Class

ImGearChannelRef Structure


InvertContrast Method

32-bit
64-bit
CF
P
P
P

Description:

This method inverts the image contrast. If the image is indexed and not grayscale, it modifies the image's palette, otherwise it modifies the image's pixels. Processes only color channels.

Method ImGearRasterProcessing.Verifier. CanApplyInvertContrast Method (ImGearPage page) can be called to check whether the operation can be performed or not.

Declaration:

public static void InvertContrast(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to invert contrast.

Return Value:

None

Sample Code:

C#
// Detect an area around a point in an image based upon a base pixel and threshold.
// Top left corner of image
ImGearPoint igPoint = new ImGearPoint(0, 0);
//Get the Pixel currently there.
ImGearPixel igPixel = igRasterPage.DIB.GetPixelCopy(0, 0);
// Detection class, threshold is difference in pixel channel values from specified pixel.
ImGearPixelCheckerThreshold igPixelCheckerThreshold = new ImGearPixelCheckerThreshold(igPixel, 100);
// Detect the region around target point within the threshold.
ImGearRasterProcessing.DetectArea(igRasterPage, igPoint, igPixelCheckerThreshold);
// Invert the contrast of the selected region to visible show the detected region.
ImGearRasterProcessing.InvertContrast(igRasterPage);

VB .NET
' Detect an area around a point in an image based upon a base pixel and threshold.
' Top left corner of image
Dim igPoint As New ImGearPoint(0, 0)
'Get the Pixel currently there.
Dim igPixel As ImGearPixel = igRasterPage.DIB.GetPixelCopy(0, 0)
' Detection class, threshold is difference in pixel channel values from specified pixel.
Dim igPixelCheckerThreshold As New ImGearPixelCheckerThreshold(igPixel, 100)
' Detect the region around target point within the threshold.
ImGearRasterProcessing.DetectArea(igRasterPage, igPoint, igPixelCheckerThreshold)
' Invert the contrast of the selected region to visible show the detected region.
ImGearRasterProcessing.InvertContrast(igRasterPage)

See Also:

ImGearRasterPage Class


InvertContrast Method

32-bit
64-bit
CF
P
P
P

Description:

This method inverts the image contrast. Processes specified range of channels.

If Mode is equal to ImGearContrastModes.PALETTE, DIB must have a palette.

Method ImGearRasterProcessing.Verifier. CanApplyInvertContrast Method (ImGearPage page, ImGearContrastModes ContrastMode) can be called to check whether the operation can be performed or not.

Declaration:

public static void InvertContrast(ImageGear.Core.ImGearRasterPage page,
ImageGear.Processing.ImGearContrastModes mode, ImageGear.Core.ImGearChannelRange channels)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to invert contrast.
mode
ImGearContrastModes Enumeration
One of the contrast processing modes: PALETTE, PIXELS, AUTO. See ImGearContrastModes for description.
channels
ImGearChannelRange Structure
Channel range to invert contrast.

Return Value:

None

See Also:

ImGearRasterPage Class

ImGearContrastModes Enumeration

ImGearChannelRange Structure

CanApplyInvertContrast Method


InvertContrast Method

32-bit
64-bit
CF
P
P
P

Description:

This method inverts the image contrast. Processes specified range of channels.

If Mode is equal to ImGearContrastModes.PALETTE, DIB must have a palette.

Method ImGearRasterProcessing.Verifier. CanApplyInvertContrast Method (ImGearPage page, ImGearContrastModes ContrastMode) can be called to check whether the operation can be performed or not.

Declaration:

public static void InvertContrast(ImageGear.Core.ImGearRasterPage page,
ImageGear.Processing.ImGearContrastModes mode, ImageGear.Core.ImGearChannelRange channels,
ImageGear.Processing.ImGearContrastOptions options)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to invert contrast.
mode
ImGearContrastModes Enumeration
One of the contrast processing modes: PALETTE, PIXELS, AUTO. See ImGearContrastModes for description.
channels
ImGearChannelRange Structure
Channel range to invert contrast.
options
ImGearContrastOptions Class
Contrast options. See ImGearContrastOptions Class.

Return Value:

None

See Also:

ImGearRasterPage Class

ImGearContrastModes Enumeration

ImGearChannelRange Structure

ImGearContrastOptions Class


LensFlare Method

32-bit
64-bit
CF
P
P
P

Description:

This method applies a lens flare effect to the image. The effect simulates a bright light, such as the sun, and some reflections within the lens. It is typically used to add a sense of drama or realism to a photographic image.

Declaration:

public static void LensFlare(ImageGear.Core.ImGearRasterPage page,
ImageGear.Core.ImGearPoint flareCenter, double primaryBrightness, double
secondaryBrightness, ImageGear.Processing.ImGearLensFlareType flareType)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to apply lens flare effect to.
flareCenter
ImGearPoint Structure
Position of the primary flare.
primaryBrightness
double
Brightness of the primary flare. This value should range from 0 to 1.
secondaryBrightness
double
Brightness of the secondary flare. This value should range from 0 to 1.
flareType
ImGearLensFlareType Enumeration
Predefined flare type to use. Determines the shape and appearance of the lens flare elements.

Return Value:

None

Availability:

RGB-based colorspaces only.

See Also:

ImGearRasterPage Class

ImGearLensFlareType Enumeration


Merge Method

32-bit
64-bit
CF
P
P
P

Description:

This method merges two images according to the specified merge mode. It processes color channels only.

Both page DIBs must have the same color space.

Method ImGearRasterProcessing.Verifier. CanApplyMerge Method can be called to check whether the operation can be performed or not.

If the images are paletted, the arithmetic operation is applied to the pixel values (indexes) rather than to the palette entries. This may result in unexpected effect with certain palettes, for example if the palette is reversed. In such cases, consider converting the image to a non-indexed colorspace, such as Grayscale or RGB, before applying the operation.

Declaration:

public static void Merge(ImageGear.Core.ImGearRasterPage page,
ImageGear.Core.ImGearRasterPage pageToMergeWith, int left, int top,
ImageGear.Processing.ImGearMergeModes mode)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
First image to merge. It will contain result image after merging.
pageToMergeWith
ImGearRasterPage Class
Second image to merge.
left
int
Left position ot the source image on the destination one.
top
int
Top position ot the source image on the destination one.
mode
ImGearMergeModes Enumeration
Merge mode constant. See ImGearMergeModes Enumeration.

Return Value:

None.

Sample Code:

C#
// Opens an image and merges it into an already open image.
using (FileStream file = new FileStream("photo.jpg",
                   FileMode.Open, FileAccess.Read, FileShare.Read))
{
    ImGearRasterPage igRasterPageToMerge = (ImGearRasterPage)
        ImGearFileFormats.LoadPage(file, 0);
    // Subtract the opened image from the existing image.
    ImGearRasterProcessing.Merge(igRasterPage, igRasterPageToMerge, 0, 0, ImGearMergeModes.SUB);
}

VB .NET
' Opens an image and merges it into an already open image.
Using file As New FileStream("photo.jpg", FileMode.Open, FileAccess.Read, FileShare.Read)
    Dim igRasterPageToMerge As ImGearRasterPage = DirectCast(ImGearFileFormats.LoadPage(file, 0), ImGearRasterPage)
    ' Subtract the opened image from the existing image.
    ImGearRasterProcessing.Merge(igRasterPage, igRasterPageToMerge, 0, 0, ImGearMergeModes.[SUB])
End Using

See Also:

ImGearRasterPage Class

ImGearMergeModes Enumeration


Merge Method

32-bit
64-bit
CF
P
P
P

Description:

This method merges two images according to the specified merge mode. Processes specified range of channels.

Both page DIBs must have the same color space.

Method ImGearRasterProcessing.Verifier. CanApplyMerge Method can be called to check whether the operation can be performed or not.

If the images are paletted, the arithmetic operation is applied to the pixel values (indexes) rather than to the palette entries. This may result in unexpected effect with certain palettes, for example if the palette is reversed. In such cases, consider converting the image to a non-indexed colorspace, such as Grayscale or RGB, before applying the operation.

Declaration:

public static void Merge(ImageGear.Core.ImGearRasterPage page,
ImageGear.Core.ImGearRasterPage pageToMergeWith, int left, int top,
ImageGear.Processing.ImGearMergeModes mode, ImageGear.Core.ImGearChannelRange channels)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
First image to merge. It will contain resultant image after merging.
pageToMergeWith
ImGearRasterPage Class
Second image to merge.
left
int
Left position of the source image on the destination one.
top
int
Top position of the source image on the destination one.
mode
ImGearMergeModes Enumeration
Merge mode.
channels
ImGearChannelRange Structure
Range of channels.

Return Value:

None.

See Also:

ImGearRasterPage Class

ImGearMergeModes Enumeration

ImGearChannelRange Structure


MonochromeFilm Method

32-bit
64-bit
CF
P
P
P

Description:

This method applies a Monochrome Film effect on the image, making it look like it has been taken with an analog camera, using monochrome film. The method takes a parameter specifying the settings, imitating particular film types.

Declaration:

public static void MonochromeFilm(ImGearRasterPage page, ImGearMonochromeFilmPreset
preset);

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to process.
preset
ImGearMonochromeFilmPreset Enumeration
Specifies the type of film to imitate.

Return Value:

None

Availability:

All except bitonal, indexed, grayscale and colorspaces containing Alpha, Premultiplied Alpha and Extra channels.

See Also:

ImGearRasterPage Class

ImGearMonochromeFilmPreset Enumeration


Mosaic Method

32-bit
64-bit
CF
P
P
P

Description:

This method provides a 3D mosaic effect on an image.

Declaration:

public static void Mosaic(ImageGear.Core.ImGearRasterPage page,
ImageGear.Processing.ImGearMosaicFillParams fillParameters,
ImageGear.Processing.ImGearMosaicCellParams cellParameters,
ImageGear.Processing.ImGearMosaicBorderParams borderParams,
ImageGear.Processing.ImGearMosaicShadowParams shadowParams)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearRasterPage Class object.
fillParameters
ImGearMosaicFillParams Class
Fill parameters for mosaic operation. See ImGearMosaicFillParams description.
cellParameters
ImGearMosaicCellParams Class
Parameters of the cell for mosaic operation. See ImGearMosaicCellParams description.
borderParams
ImGearMosaicBorderParams Class
Parameters of cell borders. See ImGearMosaicBorderParams description.
shadowParams
ImGearMosaicShadowParams Class
Parameters of the shadow effect. See ImGearMosaicShadowParams description.

Return Value:

None.

Availability:

All except bitonal, non-gray Indexed and Grayscale with LUT.

Sample Code:

C#
// Applies a mosaic effect to an image.
// Parameter classes for Mosaic function.
ImGearMosaicFillParams igMosaicFillParams = new ImGearMosaicFillParams();
ImGearMosaicCellParams igMosaicCellParams = new ImGearMosaicCellParams();
ImGearMosaicBorderParams igMosaicBorderParams = new ImGearMosaicBorderParams();
ImGearMosaicShadowParams igMosaicShadowParams = new ImGearMosaicShadowParams();
//Color for fill and border.
ImGearPixel igPixel = new ImGearPixel(igRasterPage.DIB.ChannelCount, igRasterPage.DIB.BitsPerChannel);
//Set the color to a dark gray based on the bits per channel.
for (int i = 0; i < igPixel.ChannelCount; ++i)
    igPixel[i] = (int)Math.Pow(2, igRasterPage.DIB.BitsPerChannel) / 4;
// Cell parameters
igMosaicCellParams.Type = ImGearMosaicType.Cartesian;
igMosaicCellParams.Width = 32;
igMosaicCellParams.Height = 32;
igMosaicCellParams.PolarCenterX = 100;
igMosaicCellParams.PolarCenterY = 100;
// Fill parameters
igMosaicFillParams.Color = igPixel;
igMosaicFillParams.Opacity = (float)0.20;
// Border parameters
igMosaicBorderParams.Width = 0;
igMosaicBorderParams.Height = 0;
igMosaicBorderParams.Color = igPixel;
igMosaicBorderParams.Opacity = (float)0.30;
igMosaicBorderParams.Irregularity = 0;
// Shadow Parameters
igMosaicShadowParams.Enabled = true;
igMosaicShadowParams.Threshold = 0;
igMosaicShadowParams.Direction = ImGearDirection.SouthEast;
igMosaicShadowParams.HighResolution = false;
igMosaicShadowParams.Intensity = (float)1.0;
ImGearRasterProcessing.Mosaic(igRasterPage,
    igMosaicFillParams,
    igMosaicCellParams,
    igMosaicBorderParams,
    igMosaicShadowParams);

VB .NET
' Applies a mosaic effect to an image.
' Parameter classes for Mosaic function.
Dim igMosaicFillParams As New ImGearMosaicFillParams()
Dim igMosaicCellParams As New ImGearMosaicCellParams()
Dim igMosaicBorderParams As New ImGearMosaicBorderParams()
Dim igMosaicShadowParams As New ImGearMosaicShadowParams()
'Color for fill and border.
Dim igPixel As New ImGearPixel(igRasterPage.DIB.ChannelCount, igRasterPage.DIB.BitsPerChannel)
For i As Integer = 0 To igPixel.ChannelCount - 1
    igPixel(i) = CInt(Math.Pow(2, igRasterPage.DIB.BitsPerChannel)) / 4
Next
'Set the color to a dark gray based on the bits per channel.
' Cell parameters
igMosaicCellParams.Type = ImGearMosaicType.Cartesian
igMosaicCellParams.Width = 32
igMosaicCellParams.Height = 32
igMosaicCellParams.PolarCenterX = 100
igMosaicCellParams.PolarCenterY = 100
' Fill parameters
igMosaicFillParams.Color = igPixel
igMosaicFillParams.Opacity = CSng(0.2)
' Border parameters
igMosaicBorderParams.Width = 0
igMosaicBorderParams.Height = 0
igMosaicBorderParams.Color = igPixel
igMosaicBorderParams.Opacity = CSng(0.3)
igMosaicBorderParams.Irregularity = 0
' Shadow Parameters
igMosaicShadowParams.Enabled = True
igMosaicShadowParams.Threshold = 0
igMosaicShadowParams.Direction = ImGearDirection.SouthEast
igMosaicShadowParams.HighResolution = False
igMosaicShadowParams.Intensity = CSng(1)
ImGearRasterProcessing.Mosaic(igRasterPage, igMosaicFillParams, _
 igMosaicCellParams, igMosaicBorderParams, igMosaicShadowParams)

See Also:

ImGearRasterPage Class

ImGearMosaicFillParams Class

ImGearMosaicCellParams Class

ImGearMosaicBorderParams Class

ImGearMosaicShadowParams Class


NightVision Method

32-bit
64-bit
CF
P
P
P

Description:

This method applies a "night vision" effect to the image.

Declaration:

public static void NightVision(ImGearRasterPage page, ImGearNightVisionPresets
presetScheme, int borderWidth, double noiseAmount)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearPage object to apply effect to.
presetScheme
ImGearNightVisionPresets Enumeration
One of the night vision preset schemes (Camera, Binocular, Sniper, SpyPhoto, Television, Marsian, Moonlight).
borderWidth
int
Width of the border.
noiseAmount
double
Amount of noise to add.

Return Value:

None.

Availability:

All except bitonal, indexed, Grayscale with LUT and colorspaces containing Alpha, Premultiplied Alpha and Extra channels.

See Also:

ImGearRasterPage Class

ImGearNightVisionPresets Enumeration


Oilify Method

32-bit
64-bit
CF
P
P
P

Description:

This method applies an effect to an image that makes it appear similar to an oil painting.

Declaration:

public static void Oilify(ImageGear.Core.ImGearRasterPage page, int brushSize)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to apply oilify effect to.
brushSize
int
Brush size in pixels. As the brush size is increased, less detail is visible in the image and the effect becomes more dramatic.

Return Value:

None

Availability:

All except bitonal, non-gray Indexed and Grayscale with LUT.

See Also:

ImGearRasterPage Class


Open Method

32-bit
64-bit
CF
P
P
P

Description:

This method applies opening effect to the provided raster page using the specified structure element. This method is applicable to any grayscale image (image with [Gy] color space).

Declaration:

public static void Open(ImageGear.Core.ImGearRasterPage page, int[,] matrix)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearPage object to apply effect to.
matrix
int
Matrix specifying a structuring element for the operation.

Return Value:

None.

See Also:

ImGearRasterPage Class

CanApplyOpen Method


Perspective Method

32-bit
64-bit
CF
P
P
P

Description:

This method provides a perspective-like effect by image corners transformation.

Declaration:

public static void Perspective(ImageGear.Core.ImGearRasterPage page,
ImageGear.Core.ImGearPoint point0, ImageGear.Core.ImGearPoint point1,
ImageGear.Core.ImGearPoint point2, ImageGear.Core.ImGearPoint point3,
ImageGear.Core.ImGearPixel color)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearRasterPage Class object.
point0
ImGearPoint Structure
New coordinates of left top image corner.
point1
ImGearPoint Structure
New coordinates of right top image corner.
point2
ImGearPoint Structure
New coordinates of left bottom image corner.
point3
ImGearPoint Structure
New coordinates of right bottom image corner.
color
ImGearPixel Class
Fill color for empty image part.

Return Value:

None.

Availability:

All except bitonal.

Sample Code:

C#
//Sample usage of Perspective function.
ImGearPoint igPointLeftTop, igPointRightTop, igPointLeftBottom, igPointRightBottom;
//New positions for the 4 corners of the image
igPointLeftTop = new ImGearPoint(igRasterPage.DIB.Width / 4, igRasterPage.DIB.Height / 4);
igPointRightTop = new ImGearPoint(igRasterPage.DIB.Width, 0);
igPointLeftBottom = new ImGearPoint(0, igRasterPage.DIB.Height);
igPointRightBottom = new ImGearPoint(3 * igRasterPage.DIB.Width / 4, 3 * igRasterPage.DIB.Height / 4);
//Background color to fill in after adjusting the corners of the image.
ImGearPixel igPixel = new ImGearPixel(igRasterPage.DIB.ChannelCount, igRasterPage.DIB.BitsPerChannel);
//Set the color to a dark gray based on the bits per channel.
for (int i = 0; i < igPixel.ChannelCount; ++i)
    igPixel[i] = (int)Math.Pow(2, igRasterPage.DIB.BitsPerChannel) / 4;
//Apply the perspective change.
ImGearRasterProcessing.Perspective(
    igRasterPage, igPointLeftTop, igPointRightTop,
    igPointLeftBottom, igPointRightBottom, igPixel);

VB .NET
'Sample usage of Perspective function.
Dim igPointLeftTop As ImGearPoint, igPointRightTop As ImGearPoint
Dim igPointLeftBottom As ImGearPoint, igPointRightBottom As ImGearPoint
'New positions for the 4 corners of the image
igPointLeftTop = New ImGearPoint(igRasterPage.DIB.Width / 4, igRasterPage.DIB.Height / 4)
igPointRightTop = New ImGearPoint(igRasterPage.DIB.Width, 0)
igPointLeftBottom = New ImGearPoint(0, igRasterPage.DIB.Height)
igPointRightBottom = New ImGearPoint(3 * igRasterPage.DIB.Width / 4, 3 * igRasterPage.DIB.Height / 4)
'Background color to fill in after adjusting the corners of the image.
Dim igPixel As New ImGearPixel(igRasterPage.DIB.ChannelCount, igRasterPage.DIB.BitsPerChannel)
For i As Integer = 0 To igPixel.ChannelCount - 1
    igPixel(i) = CInt(Math.Pow(2, igRasterPage.DIB.BitsPerChannel)) / 4
Next
'Set the color to a dark gray based on the bits per channel.
'Apply the perspective change.
ImGearRasterProcessing.Perspective(igRasterPage, igPointLeftTop, igPointRightTop, _
 igPointLeftBottom, igPointRightBottom, igPixel)

See Also:

ImGearRasterPage Class

ImGearPoint Structure

ImGearPixel Class


Picturize Method

32-bit
64-bit
CF
P
P
P

Description:

This method applies the Picturize effect on a raster image. The method divides the image into rectangular cells, and replaces each cell with an image from the specified image collection, attempting to select cell images such that they match colors of source image.

This method uses a significant amount of calculations, so it has been split into three stages:

  1. Loading and preprocessing cell images, scaling them to their destination size in the picturized image. This stage is done by creation of an ImGearPicturizePreprocessedCollection Class object.
  2. Matching cell images to fragments of the main image. This stage is done by creation of a ImGearPicturizeMatchingMatrix Class object, which takes ImGearPicturizePreprocessedCollection Class on input.
  3. Distributing the cell images over the source image, and adjusting their colors to match the main image better. This is done by calling the Picturize method.

The result of the Picturize method depends greatly on how similar the images in the cell image collection are relative to the source image. Also, for the best results, the number of images in the cell image collection should be greater than the number of cells in the picturized image.

Declaration:

public static ImGearRasterPage Picturize(ImGearPicturizeMatchingMatrix matchingMatrix,
ImGearPicturizeDistributionSettings distributionSettings, ImGearPicturizeMixingSettings
mixingSettings);

Parameters:

Name
Type
Description
matchingMatrix
ImGearPicturizeMatchingMatrix Class
Auxiliary object, containing result of matching the cell images against fragments of the source image.
distributionSettings
ImGearPicturizeDistributionSettings Structure
Specifies distribution settings for Picturize.
mixingSettings
ImGearPicturizeMixingSettings Structure
Specifies how the cell images will be adjusted before placing to the main image.

Return Value:

ImGearRasterPage Class

Availability:

All except bitonal, indexed, Grayscale with LUT and colorspaces containing Alpha, Premultiplied Alpha and Extra channels.

See Also:

ImGearRasterPage Class

ImGearPicturizeMatchingMatrix Class

ImGearPicturizeDistributionSettings Structure

ImGearPicturizeMixingSettings Structure


Pinch Method

32-bit
64-bit
CF
P
P
P

Description:

This method pinches a page toward or away from the pinch center.

Declaration:

public static void Pinch(ImageGear.Core.ImGearRasterPage page, ImageGear.Core.ImGearPoint
center, int radius, float strength, bool interpolate)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to pinch.
center
ImGearPoint Structure
Center of the pinch effect.
radius
int
Radius of the pinch effect.
strength
float
Pinch strength. Positive value means that the page is pinched away from the center.
interpolate
bool
If this parameter is true then an interpolation is used during processing.

Return Value:

None.

Availability:

All except bitonal if interpolation is off; all except bitonal, non-gray Indexed and Grayscale with LUT if interpolation is on.

Sample Code:

C#
// Pinches an image.
// Point at which to pinch, center of image.
ImGearPoint igPoint = new ImGearPoint();
igPoint.X = igRasterPage.DIB.Width / 2;
igPoint.Y = igRasterPage.DIB.Height / 2;
// Pinch using a 128 pixel radius and a strength of 5, interpolation on and no fill color.
ImGearRasterProcessing.Pinch(igRasterPage,igPoint, 128, (float)5.0, true, null);

VB .NET
' Pinches an image.
' Point at which to pinch, center of image.
Dim igPoint As New ImGearPoint()
igPoint.X = igRasterPage.DIB.Width / 2
igPoint.Y = igRasterPage.DIB.Height / 2
' Pinch using a 128 pixel radius and a strength of 5, interpolation on and no fill color.
ImGearRasterProcessing.Pinch(igRasterPage, igPoint, 128, CSng(5), True, Nothing)

See Also:

ImGearRasterPage Class

ImGearPoint Structure


Pixelate Method

32-bit
64-bit
CF
P
P
P

Description:

This method divides an image into cells and fills every cell according to the cell and fill parameters.

Declaration:

public static void Pixelate(ImageGear.Core.ImGearRasterPage page,
ImageGear.Processing.ImGearPixelateFillParams fillParameters,
ImageGear.Processing.ImGearPixelateCellParams cellParameters,
ImageGear.Processing.ImGearPixelateBorderParams borderParams)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to pixelate.
fillParameters
ImGearPixelateFillParams Class
Fill parameters for pixelate operation. See ImGearPixelateFillParams description.
cellParameters
ImGearPixelateCellParams Class
Parameters of the cell for pixelate operation. See ImGearPixelateCellParams description.
borderParams
ImGearPixelateBorderParams Class
Parameters of cell borders. See ImGearPixelateBorderParams description.

Return Value:

None.

Sample Code:

C#
// Pixelate an image.
// Parameter classes for Pixelate function.
ImGearPixelateBorderParams igPixelateBorderParams = new ImGearPixelateBorderParams();
ImGearPixelateCellParams igPixelateCellParams = new ImGearPixelateCellParams();
ImGearPixelateFillParams igPixelateFillParams = new ImGearPixelateFillParams();
ImGearPixel igPixel = igRasterPage.DIB.GetPixelCopy(0, 0);
// cell parameters
igPixelateCellParams.Type = ImGearPixelateCellType.Rectangle;
igPixelateCellParams.Width = 8;
igPixelateCellParams.Height = 8;
// fill parameters
igPixelateFillParams.FillMethod = ImGearPixelateFillMethod.Average;
igPixelateFillParams.Color = igPixel;
igPixelateFillParams.Opacity = (float)1.00;
// Border parameters
igPixelateBorderParams.Width = 0;
igPixelateBorderParams.Height = 0;
igPixelateBorderParams.Color = igPixel;
igPixelateBorderParams.Opacity = (float)1.00;
ImGearRasterProcessing.Pixelate(igRasterPage,
        igPixelateFillParams,
        igPixelateCellParams,
        igPixelateBorderParams);

VB .NET
' Pixelate an image.
' Parameter classes for Pixelate function.
Dim igPixelateBorderParams As New ImGearPixelateBorderParams()
Dim igPixelateCellParams As New ImGearPixelateCellParams()
Dim igPixelateFillParams As New ImGearPixelateFillParams()
Dim igPixel As ImGearPixel = igRasterPage.DIB.GetPixelCopy(0, 0)
' cell parameters
igPixelateCellParams.Type = ImGearPixelateCellType.Rectangle
igPixelateCellParams.Width = 8
igPixelateCellParams.Height = 8
' fill parameters
igPixelateFillParams.FillMethod = ImGearPixelateFillMethod.Average
igPixelateFillParams.Color = igPixel
igPixelateFillParams.Opacity = CSng(1)
' Border parameters
igPixelateBorderParams.Width = 0
igPixelateBorderParams.Height = 0
igPixelateBorderParams.Color = igPixel
igPixelateBorderParams.Opacity = CSng(1)
ImGearRasterProcessing.Pixelate(igRasterPage, igPixelateFillParams, igPixelateCellParams, igPixelateBorderParams)

See Also:

ImGearRasterPage Class

ImGearPixelateFillParams Class

ImGearPixelateCellParams Class

ImGearPixelateBorderParams Class


Pointillist Method

32-bit
64-bit
CF
P
P
P

Description:

This method applies an effect to an image that makes it appear to have been painted in the pointillism style of painting. The painted points are randomly generated, therefore, the resultant image is different each time the method is applied with the exact same settings.

Declaration:

public static void Pointillist(ImageGear.Core.ImGearRasterPage page, int pointSize,
ImageGear.Processing.ImGearBrushType pointType, int smoothness, ImageGear.Core.ImGearPixel
color)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to apply pointillist effect to.
pointSize
int
Average size of each point (in pixels).
pointType
ImGearBrushType Enumeration
Type of brush to use for each point. Determines the shape of the point.
smoothness
int
Smoothness factor for each point. This value typically ranges from 0 to 100.
color
ImGearPixel Class
Specifies a background color to use. If this parameter is null, all points fit together smoothly with no gaps. If this parameter specifies a background a color, there are some occasional gaps which are set to the specified background color.

Return Value:

None

Availability:

All except bitonal; if non-gray Indexed, smoothness parameter is ignored.

See Also:

ImGearRasterPage Class

ImGearBrushType Enumeration

ImGearPixel Class


ProcessArea Method

32-bit
64-bit
CF
P
P
P

Description:

This method processes all pixels in the ROI area using a specified pixel processor.

Declaration:

public static void ProcessArea(ImageGear.Core.ImGearRasterPage page,
ImageGear.Processing.IImGearPixelProcessor processor)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.
processor
IImGearPixelProcessor Interface
Implementation of IImGearPixelProcessor interface with the implemented method ProcessPixel. See IImGearPixelChecker interface for more details.

Return Value:

None.

Example:

ImGearRasterProcessing.ProcessArea(page, new ImGearPixelProcessorRedEyeRGB(page.DIB, 0.7,
0.5));
NOTE: ImGearPixelProcessorRedEyeRGB Class is a predefined pixel processor here (see IImGearPixelProcessor Interface).

Sample Code:

C#
// Detect the red-eye area around a point and remove the red-eye effect.
// Location of a red-eye, can be obtained by a mouse click by user.
ImGearPoint igPoint = new ImGearPoint(204, 308);
// Detection class for red-eye area, threshold values from 0.5-2.0
ImGearPixelCheckerRedEyeRGB igPixelCheckerRedEyeRGB = new ImGearPixelCheckerRedEyeRGB(0.7);
// Detect the red-eye area around the target point.
ImGearRasterProcessing.DetectArea(igRasterPage, igPoint, igPixelCheckerRedEyeRGB);
// Remove red-eye effect with a threshold of 0.7 and brightness of 0.5
ImGearRasterProcessing.ProcessArea(igRasterPage,
    new ImGearPixelProcessorRedEyeRGB(igRasterPage.DIB, 0.7, 0.5));

VB .NET
' Detect the red-eye area around a point and remove the red-eye effect.
' Location of a red-eye, can be obtained by a mouse click by user.
Dim igPoint As New ImGearPoint(204, 308)
' Detection class for red-eye area, threshold values from 0.5-2.0
Dim igPixelCheckerRedEyeRGB As New ImGearPixelCheckerRedEyeRGB(0.7)
' Detect the red-eye area around the target point.
ImGearRasterProcessing.DetectArea(igRasterPage, igPoint, igPixelCheckerRedEyeRGB)
' Remove red-eye effect with a threshold of 0.7 and brightness of 0.5
ImGearRasterProcessing.ProcessArea(igRasterPage, New ImGearPixelProcessorRedEyeRGB(igRasterPage.DIB, 0.7, 0.5))

See Also:

ImGearRasterPage Class

IImGearPixelProcessor Interface

ImGearPixelProcessorRedEyeRGB Class

CanApplyProcessArea Method


RadialLight Method

32-bit
64-bit
CF
P
P
P

Description:

This method changes the colors of an image according to the pattern of a sine wave. The image will appear to have regularly spaced bars of light and shadow overlaid on top of it in a radial pattern.

Declaration:

public static void RadialLight(ImageGear.Core.ImGearRasterPage page,
ImageGear.Core.ImGearPoint center, float[] amplitude, float frequency, float phase, float
attenuation)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to apply radial light effect to.
center
ImGearPoint Structure
Center point in the image (in pixels) about which the effect is applied.
amplitude
float[]
Controls the magnitude of color adjustment for each channel of the image. The number of elements of the array is typically set to the number of channels in the image. Each value should range from 0 to 2, although higher values are possible. 0 represents no change in the image color. Higher values represent more intense change. Color changes are clipped, so higher values result in a harder edge to the waveform.
frequency
float
Frequency of sine wave. The value should be from 0 to 0.5. The higher the frequency, the more bars will be visible.
phase
float
Phase of sine wave. The value should be from 0 to 2*PI (approximately 6.28). As the phase is changed, the alignment of the bars is changed. This can be used to align the bars with image content or boundaries.
attenuation
float
Attenuation of sine wave. The value should be from -0.01 to 0.01. Attenuation adjusts how much the amplitude of the sine wave is decreased or increased as the sine wave proceeds. It can be used to cause the lighting to fade or intensify.

Return Value:

None

Availability:

All except bitonal, non-gray Indexed and Grayscale with LUT.

See Also:

ImGearRasterPage Class

CanApplyFunctionalLights Method


RadialWave Method

32-bit
64-bit
CF
P
P
P

Description:

This method provides a radial wave effect on the current raster page.

Declaration:

public static void RadialWave(ImageGear.Core.ImGearRasterPage page,
ImageGear.Core.ImGearPoint center, float amplitude, float frequency, float phase, float
attenuation, bool interpolate, ImageGear.Core.ImGearPixel color)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.
center
ImGearPoint Structure
Center of the wave effect.
amplitude
float
Wave amplitude. Measurement units - pixel / 100.
frequency
float
Wave frequency. The frequency is defined as 1 / T, where T is a wave period, in pixels.
phase
float
Wave phase, in radians.
attenuation
float
Wave attenuation. The attenuation factor of the wave is calculated as exp(-attenuation * r), where r is a distance from the wave center to the current wave point.
interpolate
bool
If this parameter is true then an interpolation is used during processing.
color
ImGearPixel Class
ImGearPixel Class color.

Return Value:

None.

Availability:

All except bitonal if interpolation is off; all except bitonal, non-gray Indexed and Grayscale with LUT if interpolation is on.

Sample Code:

C#
// Distorts an image with a radial wave.
// Center point of the wave, set to center of image.
ImGearPoint igPoint = new ImGearPoint();
igPoint.X = igRasterPage.DIB.Width / 2;
igPoint.Y = igRasterPage.DIB.Height / 2;
// Warp the image with a radial wave with an amplitude of 0.25, frequency of 20 pixels,
//  0 phase, and slight attenuation. Interpolation is enabled, and no fill color is specified.
ImGearRasterProcessing.RadialWave(
        igRasterPage, igPoint, (float)(0.25), (float)(1.0 / 20.0),
        (float)(0.0), (float)(0.01), true, null);

VB .NET
' Distorts an image with a radial wave.
' Center point of the wave, set to center of image.
Dim igPoint As New ImGearPoint()
igPoint.X = igRasterPage.DIB.Width / 2
igPoint.Y = igRasterPage.DIB.Height / 2
' Warp the image with a radial wave with an amplitude of 0.25, frequency of 20 pixels,
'  0 phase, and slight attenuation. Interpolation is enabled, and no fill color is specified.
ImGearRasterProcessing.RadialWave(igRasterPage, igPoint, CSng((0.25)), CSng((1 / 20)), CSng((0)), CSng((0.01)), _
 True, Nothing)

See Also:

ImGearRasterPage Class

ImGearPoint Structure

ImGearPixel Class


Reduce Method

32-bit
64-bit
CF
P
P
P

Description:

This method reduces the bit depth of an image using the specified reduction method. All methods except for SCALE change the color space of the image to Indexed. SCALE does not change the image's color space, but only scales the channel depths. The different reduction methods have their own options, which can be set using the options parameter. See the example below for a description of how to set options.

For more information about a particular method, see its options. The following reduction methods are available in ImGearReductionMethods:

Method
Input color spaces and bit depths
Output color spaces and bit depths
Options
BAYER
RGB (24)
Grayscale (8)
Indexed (>1)
Indexed (1 or 4)
ImGearBayerReductionOptions
BITONAL
RGB (24)
Grayscale (8)
Indexed (>1)
Indexed (1)
ImGearBitonalReductionOptions
DIFFUSE
RGB (24)
Grayscale (8)
Indexed (>1)
Indexed (1 or 4)
ImGearDiffuseReductionOptions
HALFTONE
RGB (24)
Grayscale (8)
Indexed (>1)
Indexed (1)
ImGearHalftoneReductionOptions
MEDIAN
RGB (24)
Grayscale (8)
Indexed (8)
ImGearMedianCutReductionOptions
OCTREE
RGB (24)
Grayscale (8)
Indexed (4 or 8)
ImGearOctreeReductionOptions
POPULARITY
RGB (24)
Grayscale (8)
Indexed (8)
ImGearPopularityReductionOptions
SCALE
Any color space except Indexed
Same color space as input
ImGearScaleReductionOptions

Declaration:

public static void Reduce(ImageGear.Core.ImGearRasterPage page,
ImageGear.Core.ImGearColorSpace colorSpace, int[] channelDepths,
ImageGear.Processing.ImGearReductionMethods reductionMethod,
ImageGear.Processing.ImGearReductionOptions options)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to reduce bit depth.
colorSpace
ImGearColorSpace Structure
Color space to reduce image to.
channelDepths
int[]
Channel depths to reduce image to.
reductionMethod
ImGearReductionMethods Enumeration
Method to use for reducing bit depth.
options
ImGearReductionOptions Class
Options to use for reduction, or set to null to use defaults.

Return Value:

None.

Sample Code:

C#
// Reduce the bit depth of an image to 4 bit
// Create reduction options object and setup a few values for a 16 color 4-bit reduction.
ImGearReductionOptions igReductionOptions = new ImGearReductionOptions();
igReductionOptions.Octree.MaxColors = 16;
igReductionOptions.Octree.FastRemap = false;
igReductionOptions.Octree.ErrorDiffusion = true;
//Apply the reduction using Octree to get a 4-bit index image.
ImGearRasterProcessing.Reduce(igRasterPage, new ImGearColorSpace(ImGearColorSpaceIDs.I),
    new int[] { 4 }, ImGearReductionMethods.OCTREE, igReductionOptions);

VB .NET
' Reduce the bit depth of an image to 4 bit
' Create reduction options object and setup a few values for a 16 color 4-bit reduction.
Dim igReductionOptions As New ImGearReductionOptions()
igReductionOptions.Octree.MaxColors = 16
igReductionOptions.Octree.FastRemap = False
igReductionOptions.Octree.ErrorDiffusion = True
'Apply the reduction using Octree to get a 4-bit index image.
ImGearRasterProcessing.Reduce(igRasterPage, New ImGearColorSpace(ImGearColorSpaceIDs.I), New Integer() {4}, _
 ImGearReductionMethods.OCTREE, igReductionOptions)

See Also:

ImGearRasterPage Class

ImGearColorSpace Structure

ImGearReductionOptions Class

ImGearReductionMethods Enumeration


RemoveChannel Method

32-bit
64-bit
CF
P
P
P

Description:

This method removes the specified channel from the Page's DIB and shifts the remaining channels without transforming pixel data. channelNumber can be within the [0..ChannelCount-1] range.

Color Space is changed as follows:

  • If page has more than one Extra channel, color space is unchanged.
  • If page has one Extra channel, ExtraMask is cleared.
  • If page has Alpha channel and no Extra channels, AlphaMask and PremultAlphaMask are cleared.
  • If page has only color channels, color space is changed to Unknown, and all remaining channels are considered Extra channels.

Declaration:

public static void RemoveChannel(ImageGear.Core.ImGearRasterPage page, int channelNumber)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to remove channel.
channelNumber
int
Position of the channel to be removed.

Return Value:

None.

Sample Code:

C#
// Separate image into separate images for each channel.
ImGearChannelRef[] igChannelRef = ImGearRasterProcessing.SeparateChannels(igRasterPage);
// Remove the alpha channel from an RGBA image.
ImGearRasterProcessing.RemoveChannel(igRasterPage, 3);
// Save the page out without the alpha channel.
using (FileStream localFile = new FileStream("withoutalpha.jpg", FileMode.Create))
{
    ImGearFileFormats.SavePage(igRasterPage,localFile, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.JPG);
}
//Set the colorspace to RGBA again.
ImGearRasterProcessing.ConvertColorSpace(
    igRasterPage, new ImGearColorSpace(ImGearColorSpaceIDs.RGBA));
// Add the alpha channel back to the image.
ImGearRasterProcessing.InsertChannel(igRasterPage, 3, igChannelRef[3]);
// Remove the alpha channel added by the colorspace conversion.
ImGearRasterProcessing.RemoveChannel(igRasterPage, 4);

VB .NET
' Separate image into separate images for each channel.
Dim igChannelRef As ImGearChannelRef() = ImGearRasterProcessing.SeparateChannels(igRasterPage)
' Remove the alpha channel from an RGBA image.
ImGearRasterProcessing.RemoveChannel(igRasterPage, 3)
' Save the page out without the alpha channel.
Using localFile As New FileStream("withoutalpha.jpg", FileMode.Create)
    ImGearFileFormats.SavePage(igRasterPage, localFile, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.JPG)
End Using
'Set the colorspace to RGBA again.
ImGearRasterProcessing.ConvertColorSpace(igRasterPage, New ImGearColorSpace(ImGearColorSpaceIDs.RGBA))
' Add the alpha channel back to the image.
ImGearRasterProcessing.InsertChannel(igRasterPage, 3, igChannelRef(3))
' Remove the alpha channel added by the colorspace conversion.
ImGearRasterProcessing.RemoveChannel(igRasterPage, 4)

See Also:

ImGearRasterPage Class


RemoveChromaticAberration Method

32-bit
64-bit
CF
P
P
P

Description:

This method removes chromatic aberration artifacts from an image. Chromatic aberration is caused by differences in refraction of light components by the lens, and is seen as colored "fringes" around the image.

Declaration:

public static void RemoveChromaticAberration(ImGearRasterPage page, double redScale,
double blueScale, ImGearPoint centerPoint);

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to process.
redScale
double
Amount by which to scale the red component of the image. Valid range is 0.95...1.05.
blueScale
double
Amount by which to scale the blue component of the image. Valid range is 0.95...1.05.
centerPoint
ImGearPoint Structure
Center point.

Return Value:

None

Availability:

All except bitonal, indexed, grayscale and colorspaces containing Alpha, Premultiplied Alpha and Extra channels.

See Also:

ImGearRasterPage Class

ImGearPoint Structure


RemoveTilt Method

32-bit
64-bit
CF
P
P
P

Description:

This method computes the best-fit plane for an image, and then subtracts that plane from the image to produce the output. This is very handy for correcting illumination gradients in a poorly digitized image.

If bRemoveMean argument is set to true, then global mean is removed from the image as well.

Can be applied only to 8, 16 or 32-bpp grayscale images with one channel.

Method ImGearRasterProcessing.Verifier. CanApplyRemoveTilt Method can be called to check whether the operation can be performed or not.

Declaration:

public static void RemoveTilt(ImageGear.Core.ImGearRasterPage page, bool bRemoveMean)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
An ImGearRasterPage Class object, in which algorithm will be performed.
bRemoveMean
bool
Flag to indicate whether to remove the mean from the de-tilted image, giving it zero-mean statistics.

Return Value:

None.

Sample Code:

C#
// Remove the tilt of an image not including the global mean.
ImGearRasterProcessing.RemoveTilt(igRasterPage, false);

VB .NET
' Remove the tilt of an image not including the global mean.
ImGearRasterProcessing.RemoveTilt(igRasterPage, False)

See Also:

ImGearRasterPage Class

CanApplyRemoveTilt Method


Ripple Method

32-bit
64-bit
CF
P
P
P

Description:

This function provides the ripple effect on the image, as if it is looked at through a relief glass. The function uses one of the prefefined ripple patterns.

Declaration:

public static void Ripple(ImGearRasterPage page, float depth, int xPeriod, int yPeriod,
ImGearRipplePattern pattern, float smoothness, bool invert);

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to apply the effect to.
depth
float
Strength of the ripple effect.
xPeriod
int
X period of the ripple pattern, in pixels.
yPeriod
int
Y period of the ripple pattern, in pixels.
pattern
ImGearRipplePattern Enumeration
Identifies a predefined ripple pattern.
smoothness
float
Specifies how much the ripple pattern should be smoothed before applying.
invert
bool
Inverts the ripple pattern, effectifely swapping "convex" and "concave" areas.

Return Value:

None

Availability:

All.

See Also:

ImGearRasterPage Class

RippleFreeHand Method

RippleTexture Method

ImGearRipplePattern Enumeration

Ripple Effect


RippleFreeHand Method

32-bit
64-bit
CF
P
P
P

Description:

This function provides the ripple effect on the image, as if it is looked at through a relief glass. The function uses a custom ripple pattern, defined as two one-dimensional arrays containing light deviations in X and Y directions.

Declaration:

public static void RippleFreeHand(ImGearRasterPage page, float depth, float[]
xDistribution, float[] yDistribution, int xPeriod, int xPhase, int yPeriod, int yPhase,
float smoothness,  float angle);

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to apply the effect to.
depth
float
Strength of the Ripple effect
xDistribution
float[]
Array of points containing relative light deviations along the X axis in each cell. Each value typically ranges from -1 to 1. The number of points is flexible and should be chosen based on the period length relative to the image size and desired resolution of the effect.
yDistribution
float[]
Array of points containing relative light deviations along the Y axis in each cell. Each value typically ranges from -1 to 1. The number of points is flexible and should be chosen based on the period length relative to the image size and desired resolution of the effect.
xPeriod
int
Horizontal period of the repeating pattern. It corresponds to number of points from the xDistribution array that should be used in the transform, and does not have to be equal to the length of the array.
xPhase
int
Index of the first point in the xDistribution array to be used in the transform.
yPeriod
int
Vertical period of the repeating pattern. It corresponds to number of points from the yDistribution array, that should be used in the transform, and does not have to be equal to the length of the array.
yPhase
int
Index of the first point in the yDistribution array to be used in the transform.
smoothness
float
Specifies how much the ripple pattern should be smoothed before applying.
angle
float
Specifies the angle for the ripple pattern, in degrees. Valid range is from 0 to 360.

Return Value:

None

Availability:

All.

See Also:

ImGearRasterPage Class

Ripple Method

RippleTexture Method


RippleTexture Method

32-bit
64-bit
CF
P
P
P

Description:

This function provides the ripple effect on the image, as if it is looked at through a relief glass. The function uses an image as a ripple pattern. If the scaled ripple pattern image is smaller than the source image, or if offsets are greater than 0, pattern is repeated over the image.

Declaration:

public static void RippleTexture(ImGearRasterPage page, ImGearRasterPage texture, float
depth, float scale, int xOffset, int yOffset, float smoothness, bool invert);

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to apply the effect to.
Texture
ImGearRasterPage Class
Page to use as the ripple pattern.
Depth
float
Strength of the ripple effect.
Scale
float
Specifies the scaling factor for pattern image.
XOffset
int
Horizontal offset at which the upper left corner of the ripple texture shall be placed.
YOffset
int
Horizontal offset at which the upper left corner of the ripple texture shall be placed.
smoothness
float
Specifies how much the ripple pattern should be smoothed before applying.
invert
bool
Inverts the ripple pattern, effectifely swapping "convex" and "concave" areas.

Return Value:

None

Availability:

All for main image, non-bitonal for texture. The first channel of the texture is used as ripple mask.

See Also:

ImGearRasterPage Class

Ripple Method

RippleFreeHand Method


RoundCorners Method

32-bit
64-bit
CF
P
P
P

Description:

This method rounds the corners of the image and fills them with a specified color.

Declaration:

public static void RoundCorners(ImGearRasterPage page, int radius, ImGearPixel fillColor);

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to round the corners of.
radius
int
Specifies the radius for rounding.
fillColor
ImGearPixel Class
Specifies the fill color for the corners.

Return Value:

None.

Availability:

All except bitonal, indexed, Grayscale with LUT and colorspaces containing Premultiplied Alpha and Extra channels.


SeparateChannels Method

32-bit
64-bit
CF
P
P
P

Description:

This method creates an array of pages, where each page contains one channel with color space set to grayscale. This method does not do any of the color space or pixel conversions.

Declaration:

public static ImageGear.Processing.ImGearChannelRef[]
SeparateChannels(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Multichannel page to separate.

Return Value:

An array of channels reference - ImGearChannelRef Structure.

Sample Code:

C#
// Separate original image into separate images for each channel.
ImGearChannelRef[] igChannelRefOriginal = ImGearRasterProcessing.SeparateChannels(igRasterPage);
// Save what the colorspace was of the image.
ImGearColorSpaceIDs igColorSpaceID = igRasterPage.DIB.ColorSpace.Value;
// Create a blank image with the same attributes as the original image.
ImGearRasterPage igRasterPageNew = new ImGearRasterPage(
    igRasterPage.DIB.Width, igRasterPage.DIB.Height,
    new ImGearColorSpace(igColorSpaceID),
    (int[])igRasterPage.DIB.ChannelDepths.Clone(), true);
// Separate new image into separate images for each channel.
ImGearChannelRef[] igChannelRefNew = ImGearRasterProcessing.SeparateChannels(igRasterPageNew);
// Update the first channel of the new image from the original image.
ImGearRasterProcessing.UpdateChannelFrom(igChannelRefNew[0], igChannelRefOriginal[0]);
// Combine channels back into new image.
igRasterPageNew = ImGearRasterProcessing.CombineChannels(
    new ImGearColorSpace(igColorSpaceID), igChannelRefNew);

VB .NET
' Separate original image into separate images for each channel.
Dim igChannelRefOriginal As ImGearChannelRef() = ImGearRasterProcessing.SeparateChannels(igRasterPage)
' Save what the colorspace was of the image.
Dim igColorSpaceID As ImGearColorSpaceIDs = igRasterPage.DIB.ColorSpace.Value
' Create a blank image with the same attributes as the original image.
Dim igRasterPageNew As New ImGearRasterPage( _
 igRasterPage.DIB.Width, igRasterPage.DIB.Height, New ImGearColorSpace(igColorSpaceID), _
 DirectCast(igRasterPage.DIB.ChannelDepths.Clone(), Integer()), True)
' Separate new image into separate images for each channel.
Dim igChannelRefNew As ImGearChannelRef() = ImGearRasterProcessing.SeparateChannels(igRasterPageNew)
' Update the first channel of the new image from the original image.
ImGearRasterProcessing.UpdateChannelFrom(igChannelRefNew(0), igChannelRefOriginal(0))
' Combine channels back into new image.
igRasterPageNew = ImGearRasterProcessing.CombineChannels(New ImGearColorSpace(igColorSpaceID), igChannelRefNew)

See Also:

ImGearChannelRef Structure

ImGearRasterPage Class


Sepia Method

32-bit
64-bit
CF
P
P
P

Description:

This method applies the Sepia effect, making the image look like a tinted old black-and-white photograph.

Declaration:

public static void Sepia(ImGearRasterPage page, ImGearPixel sepiaColor);

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to apply the effect to.
sepiaColor
ImGearPixel Class
Sepia color.

Return Value:

None

Availability:

All except bitonal, indexed, grayscale and colorspaces containing Alpha, Premultiplied Alpha and Extra channels.

See Also:

ImGearRasterPage Class

ImGearPixel Class


Sharpen Method

32-bit
64-bit
CF
P
P
P

Description:

This method sharpens an image according to the specified sharpen factor. Processes color channels only.

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

Method ImGearRasterProcessingVerifier. CanApplySharpen Method can be called to check whether the operation can be performed or not.

Declaration:

public static void Sharpen(ImageGear.Core.ImGearRasterPage page, int factor)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to sharpen.
factor
int
Sharpen factor.

Return Value:

None.

See Also:

ImGearRasterPage Class

CanApplySharpen Method


Sharpen Method

32-bit
64-bit
CF
P
P
P

Description:

This method sharpens an image according to the specified sharpen factor. It processes a specified range of channels.

Can be applied only to raster pages with standard (non Run-Ends) DIB.

Method ImGearRasterProcessingVerifier. CanApplySharpen Method can be called to check whether the operation can be performed or not.

Declaration:

public static void Sharpen(ImageGear.Core.ImGearRasterPage page, int factor,
ImageGear.Core.ImGearChannelRange channels)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to sharpen.
factor
int
Sharpen factor.
channels
ImGearChannelRange Structure
Channel range to sharpen.

Return Value:

None

Sample Code:

C#
// Smooth the first channel of an image by a factor of 3.
ImGearRasterProcessing.Smooth(igRasterPage, 3, new ImGearChannelRange(0,1));

VB .NET
' Smooth the first channel of an image by a factor of 3.
ImGearRasterProcessing.Smooth(igRasterPage, 3, New ImGearChannelRange(0, 1))

See Also:

ImGearRasterPage Class

ImGearChannelRange Structure

CanApplySharpen Method


Shear Method

32-bit
64-bit
CF
P
P
P

Description:

This method applies a shearing effect to an image, moving the image rasters or columns according to the specified offsets.

Declaration:

public static void Shear(ImageGear.Core.ImGearRasterPage page, double[] curvePoints,
ImageGear.Processing.ImGearShearFillStyle fillStyle, bool interpolate, bool vertical,
ImageGear.Core.ImGearPixel color)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to apply shear effect to.
curvePoints
double
The array of offsets to move the image by. Every offset is in the range -1 to 1. Negative values shift the raster/column to the left, while positive values shift it to the right. The number of offsets is equal to the image width or height depending on the direction of movement (horizontal or vertical).
fillStyle
ImGearShearFillStyle Enumeration
Specifies how the empty image area is filled.
interpolate
bool
If true, interpolation is used to smooth shifted pixel values.
vertical
bool
If true, the direction of motion is vertical. Otherwise, the direction is horizontal.
color
ImGearPixel Class
Background color to use for filling empty image area. Only used if the specified fill style uses a fill color.

Return Value:

None

Availability:

All if interpolation is off; all except non-gray Indexed and Grayscale with LUT if interpolation is on.

See Also:

ImGearRasterPage Class

ImGearShearFillStyle Enumeration


Sketch Method

32-bit
64-bit
CF
P
P
P

Description:

This method applies Sketch effect on the image. It blends the source image with a texture image, making it look like painted by a pencil or charcoal.

The texture image can be scaled to imitate finer or thicker pencil strokes. If source image is larger than the texture, the texture is tiled over the image.

Declaration:

public static void Sketch(ImGearRasterPage page, ImGearRasterPage texture, double
scaling);

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to process.
texture
ImGearRasterPage Class
Page to use as a texture.
scaling
double
Scaling factor for resizing the texture image.

Return Value:

None

Availability:

All except bitonal, indexed, Grayscale with LUT and colorspaces containing Alpha, Premultiplied Alpha and Extra channels. For Texture image, all color spaces and bit depths are supported.

See Also:

ImGearRasterPage Class


Smooth Method

32-bit
64-bit
CF
P
P
P

Description:

This method provides smooth filtering. It processes color channels only.

Can be applied only to raster pages with standard (non Run-Ends) DIB.

Method ImGearRasterProcessingVerifier. CanApplySmooth Method can be called to check whether the operation can be performed or not.

Declaration:

public static void Smooth(ImageGear.Core.ImGearRasterPage page, int factor)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to process.
factor
int
Smooth factor.

Return Value:

None.

See Also:

ImGearRasterPage Class

CanApplySmooth Method


Smooth Method

32-bit
64-bit
CF
P
P
P

Description:

This method provides smooth filtering. Processes specified range of channels.

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

Method ImGearRasterProcessingVerifier. CanApplySmooth Method can be called to check whether the operation can be performed or not.

Declaration:

public static void Smooth(ImageGear.Core.ImGearRasterPage page, int factor,
ImageGear.Core.ImGearChannelRange channels)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to process.
factor
int
Smooth factor.
channels
ImGearChannelRange Structure
Channel range to process.

Return Value:

None.

Sample Code:

C#
// Sharpen the first channel of an image by a factor of 3.
ImGearRasterProcessing.Sharpen(igRasterPage, 3, new ImGearChannelRange(0, 1));

VB .NET
' Sharpen the first channel of an image by a factor of 3.
ImGearRasterProcessing.Sharpen(igRasterPage, 3, New ImGearChannelRange(0, 1))

See Also:

ImGearRasterPage Class

ImGearChannelRange Structure

CanApplySmooth Method


Solarize Method

32-bit
64-bit
CF
P
P
P

Description:

This method inverts the colors of pixels whose lightness exceeds the specified threshold. This method is not valid for use on 1-bit images.

The threshold is a value from 0 to the maximum value for a channel in the image. For example, if the image is 24bpp RGB, the threshold ranges from 0 to 255.

Declaration:

public static void Solarize(ImageGear.Core.ImGearRasterPage page, int threshold)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to process.
threshold
int
Lightness threshold above which colors of pixels are inverted.

Return Value:

None.

Availability:

All except bitonal, non-gray Indexed and Grayscale with LUT.

See Also:

ImGearRasterPage Class

CanApplySolarize Method


Solarize Method

32-bit
64-bit
CF
P
P
P

Description:

This method inverts the colors of pixels whose lightness exceeds the specified threshold. This method is not valid for use on 1-bit images.

The threshold is a value from 0 to the maximum value for a channel in the image. For example, if the image is 24bpp RGB, the threshold ranges from 0 to 255.

Declaration:

public static void Solarize(ImageGear.Core.ImGearRasterPage page, int threshold,
ImageGear.Processing.ImGearContrastModes mode, ImageGear.Core.ImGearChannelRange channels)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to process.
threshold
int
Lightness threshold above which colors of pixels are inverted.
mode
ImGearContrastModes Enumeration
One of the contrast processing modes: PALETTE, PIXELS, AUTO.
channels
ImGearChannelRange Structure
Channel range to solarize.

Availability:

All except bitonal, non-gray Indexed and Grayscale with LUT.

Return Value:

None.

Sample Code:

C#
// Channel range to adjust contrast.
ImGearChannelRange igChannelRange = new ImGearChannelRange(0, igRasterPage.DIB.ChannelCount);
// Solarize the image, inverting the contrast the contrast if above threshold.
ImGearRasterProcessing.Solarize(igRasterPage, 200,
    ImGearContrastModes.AUTO, igChannelRange);

VB .NET
' Channel range to adjust contrast.
Dim igChannelRange As New ImGearChannelRange(0, igRasterPage.DIB.ChannelCount)
' Solarize the image, inverting the contrast the contrast if above threshold.
ImGearRasterProcessing.Solarize(igRasterPage, 200, ImGearContrastModes.AUTO, igChannelRange)

See Also:

ImGearRasterPage Class

CanApplySolarize Method

ImGearChannelRange Structure

ImGearContrastModes Enumeration


Solarize Method

32-bit
64-bit
CF
P
P
P

Description:

This method inverts the colors of pixels whose lightness exceeds the specified threshold. This method is not valid for use on 1-bit images.

The threshold is a value from 0 to the maximum value for a channel in the image. For example, if the image is 24bpp RGB, the threshold ranges from 0 to 255.

Declaration:

public static void Solarize(ImageGear.Core.ImGearRasterPage page, int threshold,
ImageGear.Processing.ImGearContrastModes mode, ImageGear.Core.ImGearChannelRange channels,
ImageGear.Processing.ImGearContrastOptions options)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to process.
threshold
int
Lightness threshold above which colors of pixels are inverted.
mode
ImGearContrastModes Enumeration
One of the contrast processing modes: PALETTE, PIXELS, AUTO.
channels
ImGearChannelRange Structure
Channel range to solarize.
options
ImGearContrastOptions Class
Additional contrast options.

Return Value:

None.

Availability:

All except bitonal, non-gray Indexed and Grayscale with LUT.

See Also:

ImGearRasterPage Class

CanApplySolarize Method

ImGearChannelRange Structure

ImGearContrastModes Enumeration

ImGearContrastOptions Class


Spatter Method

32-bit
64-bit
CF
P
P
P

Description:

This method applies a spatter effect to an image, making it look as if it was painted in the impressionist style of painting. The painted points are randomly generated, therefore, the resultant image is different each time the method is applied with the exact same settings.

Declaration:

public static void Spatter(ImageGear.Core.ImGearRasterPage page, int diffusionHor, int
diffusionVert, int smoothness)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to apply spatter effect to.
diffusionHor
int
Factor of horizontal diffusion. The greater this value, the deeper the horizontal diffusion. Typical values range from 1 to 20.
diffusionVert
int
Factor of vertical diffusion. The greater this value, the deeper the vertical diffusion. Typical values range from 1 to 20.
smoothness
int
Smoothness factor of diffusion. Typical values range from 0 to 100.

Return Value:

None

Availability:

All.

See Also:

ImGearRasterPage Class


Spotlights Method

32-bit
64-bit
CF
P
P
P

Description:

This method darkens the image and highlights selected areas as if they are illuminated with a spotlight or sunlight.

Declaration:

public static void Spotlights(ImGearRasterPage page, ImGearSpotlight[] lights, double
darkenBy);

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to apply the effect to.
lights
ImGearSpotlight Class
Array of objects specifying spotlight parameters.
darkenBy
double
Amount to darken the unilluminated area by. Value of 0.0 results in no darkening; value of 1.0 makes unilluminated area black.

Return Value:

None.

Availability:

All except bitonal, indexed, Grayscale with LUT and colorspaces containing Alpha, Premultiplied Alpha and Extra channels.

See Also:

ImGearRasterPage Class

ImGearSpotlight Class


SpotlightsPreview Method

32-bit
64-bit
CF
P
P
P

Description:

This method creates a reduced size preview for the Spotlights Method effect. It accepts the same parameters you would use for the full size image, so you don't have to recalculate them to account for the reduced size of the preview.

The spotlights effect darkens the image and highlights selected areas as if they are illuminated with a spotlight or sunlight.

Declaration:

public static void SpotlightsPreview(ImGearRasterPage page, ImGearRasterPage previewPage,
ImGearSpotlight[] lights, double darkenBy);

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to apply the effect to.
previewPage
ImGearRasterPage Class
Page to apply preview of the effect to.
lights
ImGearSpotlight Class
Array of objects specifying spotlight parameters.
darkenBy
double
Amount to darken the unilluminated area by. Value of 0.0 results in no darkening; value of 1.0 makes unilluminated area black.

Return Value:

None.

Availability:

All except bitonal, indexed, Grayscale with LUT and colorspaces containing Alpha, Premultiplied Alpha and Extra channels.

See Also:

ImGearRasterPage Class

ImGearSpotlight Class

SpotlightsPreview Method

AccuSoft Corporation
 AccuSoft.com
sales@accusoft.com


StretchContrast Method

32-bit
64-bit
CF
P
P
P

Description:

This method stretches the image contrast. If the image is indexed and not grayscale, it modifies the image's palette. Otherwise, it modifies the image's pixels. Processes only color channels.

Can be applied only to raster pages with standard (non Run-Ends) DIB.

Method ImGearRasterProcessingVerifier. CanApplyStretchContrast Method can be called to check whether the operation can be performed or not.

Declaration:

public static void StretchContrast(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to process.

Return Value:

None.

See Also:

ImGearRasterPage Class

CanApplyStretchContrast Method


StretchContrast Method

32-bit
64-bit
CF
P
P
P

Description:

This method stretches the image contrast. It processes a specified range of channels.

Can be applied only to raster pages with standard (non Run-Ends) DIB.

If ContrastMode is equal to ImGearContrastModes.PALETTE, DIB must have a palette.

Method ImGearRasterProcessingVerifier. CanApplyStretchContrast Method can be called to check whether the operation can be performed or not.

Declaration:

public static void StretchContrast(ImageGear.Core.ImGearRasterPage page,
ImageGear.Processing.ImGearContrastModes mode, ImageGear.Core.ImGearChannelRange channels)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Image to process
mode
ImGearContrastModes Enumeration
One of the contrast processing modes: PALETTE, PIXELS, AUTO.
channels
ImGearChannelRange Structure
Channel range to process

Return Value:

None.

Sample Code:

C#
// Channel range to adjust contrast.
ImGearChannelRange igChannelRange = new ImGearChannelRange(0, igRasterPage.DIB.ChannelCount);
// Stretch the contrast.
ImGearRasterProcessing.StretchContrast(igRasterPage,
    ImGearContrastModes.AUTO, igChannelRange);

VB .NET
' Channel range to adjust contrast.
Dim igChannelRange As New ImGearChannelRange(0, igRasterPage.DIB.ChannelCount)
' Stretch the contrast.
ImGearRasterProcessing.StretchContrast(igRasterPage, ImGearContrastModes.AUTO, igChannelRange)

See Also:

ImGearRasterPage Class

ImGearContrastModes Enumeration

ImGearChannelRange Structure

CanApplyStretchContrast Method


SwapChannels Method

32-bit
64-bit
CF
P
P
P

Description:

This method swaps two channels in the Page's DIB.

Declaration:

public static void SwapChannels(ImageGear.Core.ImGearRasterPage page, int firstChannel,
int secondChannel)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to swap channels.
firstChannel
int
Position of the first channel to be swapped.
secondChannel
int
Position of the second channel to be swapped.

Return Value:

None:

Sample Code:

C#
// Swaps the first and third channels.  In an RGB image this swaps the red and blue channels.
ImGearRasterProcessing.SwapChannels(
    (ImGearRasterPage)igRasterPage, 0, 2);

VB .NET
' Swaps the first and third channels.  In an RGB image this swaps the red and blue channels.
ImGearRasterProcessing.SwapChannels(DirectCast(igRasterPage, ImGearRasterPage), 0, 2)

See Also:

ImGearRasterPage Class


TabulateHistogram Method

32-bit
64-bit
CF
P
P
P

Description:

This method tabulates histograms for all image channels.

This method supports images with channel depths ranging from 2 to 16.

Declaration:

public static void TabulateHistogram(ImageGear.Core.ImGearRasterPage page, int[,] Histo,
ImageGear.Core.ImGearChannelRange channels)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page for which to tabulate histogram.
Histo
int[,]
Two dimensional array that is filled with histogram data. It must be allocated prior to calling the function. First dimension corresponds to channel number, second dimension corresponds to histogram bin number.
channels
ImGearChannelRange Structure
Specifies image channels for which histogram shall be tabulated.

Return Value:

None.

Example:

ImGearChannelRange c=new ImGearChannelRange(0,1);
int[,] Histo =new int[1,65536];
ImageGear.Processing.ImGearRasterProcessing.TabulateHistogram(page,Histo,c);

Sample Code:

C#
// Calculate image histogram.
// Channel range to calculate.
ImGearChannelRange igChannelRange = new ImGearChannelRange(0, igRasterPage.DIB.ChannelCount);
// Integer array to hold histogram data
int[,] histogramData = new int[igRasterPage.DIB.ChannelCount,(int)Math.Pow(2,igRasterPage.DIB.BitsPerChannel)];
//Tabulate the histogram data.
ImGearRasterProcessing.TabulateHistogram(igRasterPage, histogramData, igChannelRange);
// Show a piece of the data.
MessageBox.Show(histogramData[0,0].ToString() + " pixels had the value 0 for the first channel.", "Histogram Data");

VB .NET
' Calculate image histogram.
' Channel range to calculate.
Dim igChannelRange As New ImGearChannelRange(0, igRasterPage.DIB.ChannelCount)
' Integer array to hold histogram data
Dim numberOfValues As Integer
numberOfValues = CInt(Math.Pow(2, igRasterPage.DIB.BitsPerChannel))
Dim histogramData As Integer(,) = New Integer(igRasterPage.DIB.ChannelCount - 1, numberOfValues - 1) {}
'Tabulate the histogram data.
ImGearRasterProcessing.TabulateHistogram(igRasterPage, histogramData, igChannelRange)
' Show a piece of the data.
MessageBox.Show(histogramData(0, 0).ToString() + " pixels had the value 0 for the first channel.", "Histogram Data")

See Also:

ImGearRasterPage Class

ImGearChannelRange Structure


ToyCamera Method

32-bit
64-bit
CF
P
P
P

Description:

This method makes the image look as if it was taken by a toy camera.

Declaration:

public static void ToyCamera(ImGearRasterPage page, int vignetteRadius, int vignetteWidth,
double vignetteDarkness, int vignetteBlur, double noiseAmount, double saturationAmount,
double fishEyeAmount);

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to apply effect to.
vignetteRadius
int
Radius of vignette to add around the image.
vignetteWidth
int
Width of vignette to add around the image.
vignetteDarkness
double
Amount by which to darken the vignette.
vignetteBlur
int
Amount by which to blur the vignette.
noiseAmount
double
Amount of noise to add to the image.
saturationAmount
double
Amount to saturate the image by.
fishEyeAmount
double
Amount of "fish eye" effect, to imitate geometric distortions caused by a cheap lens.

Return Value:

None.

Availability:

All except bitonal, indexed, Grayscale with LUT and colorspaces containing Alpha, Premultiplied Alpha and Extra channels.


TransformWithLUT Method

32-bit
64-bit
CF
P
P
P

Description:

This method applies a multichannel look up table to each channel of the image, optionally changing channel depths.

Number of single-channel LUTs in the multichannel LUT must match number of image channels. Input depth of each single-channel LUT must match the depth of corresponding channel. Depths of image channels after transform are determined by output depths of the coresponding single-channel LUTs.

Declaration:

public static void TransformWithLUT(ImageGear.Core.ImGearRasterPage page,
ImageGear.Core.ImGearMultichannelLUT LUT)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to apply the LUT to.
LUT
ImGearMultichannelLUT Class
Multichannel LUT that shall be applied.

Return Value:

None.

Sample Code:

C#
// Make sure the image is gray.
if (!ImGearRasterProcessing.ImageIsGray(igRasterPage))
    return;
// Create a LUT to convert image from 8bit to 4bit while also inverting.
ImGearMultichannelLUT igMultichannelLUT = new ImGearMultichannelLUT(
    igRasterPage.DIB.ChannelCount, 8, 4);
for (int i = 0; i < 255; ++i )
{
    igMultichannelLUT[0][i] = 15 - (i / 16);
}
// Transform the image with the LUT.
ImGearRasterProcessing.TransformWithLUT(igRasterPage,igMultichannelLUT);

VB .NET
' Make sure the image is gray.
If Not ImGearRasterProcessing.ImageIsGray(igRasterPage) Then
    Return
End If
' Create a LUT to convert image from 8bit to 4bit while also inverting.
Dim igMultichannelLUT As New ImGearMultichannelLUT(igRasterPage.DIB.ChannelCount, 8, 4)
For i As Integer = 0 To 254
    igMultichannelLUT(0)(i) = 15 - (i / 16)
Next
' Transform the image with the LUT.
ImGearRasterProcessing.TransformWithLUT(igRasterPage, igMultichannelLUT)

See Also:

ImGearRasterPage Class

ImGearMultichannelLUT Class


UpdateChannelFrom Method

32-bit
64-bit
CF
P
P
P

Description:

This method copies the channel referenced by channelUpdateWith to the channel referenced by channelToUpdate. The pages containing both channels must have the same width and height.

Declaration:

public static void UpdateChannelFrom(ImageGear.Processing.ImGearChannelRef
channelToUpdate, ImageGear.Processing.ImGearChannelRef channelUpdateWith)

Parameters:

Name
Type
Description
channelToUpdate
ImGearChannelRef Structure
Destination channel.
channelUpdateWith
ImGearChannelRef Structure
Source channel.

Return Value:

None.

Sample Code:

C#
// Separate original image into separate images for each channel.
ImGearChannelRef[] igChannelRefOriginal = ImGearRasterProcessing.SeparateChannels(igRasterPage);
// Save what the colorspace was of the image.
ImGearColorSpaceIDs igColorSpaceID = igRasterPage.DIB.ColorSpace.Value;
// Create a blank image with the same attributes as the original image.
ImGearRasterPage igRasterPageNew = new ImGearRasterPage(
    igRasterPage.DIB.Width, igRasterPage.DIB.Height,
    new ImGearColorSpace(igColorSpaceID),
    (int[])igRasterPage.DIB.ChannelDepths.Clone(), true);
// Separate new image into separate images for each channel.
ImGearChannelRef[] igChannelRefNew = ImGearRasterProcessing.SeparateChannels(igRasterPageNew);
// Update the first channel of the new image from the original image.
ImGearRasterProcessing.UpdateChannelFrom(igChannelRefNew[0], igChannelRefOriginal[0]);
// Combine channels back into new image.
igRasterPageNew = ImGearRasterProcessing.CombineChannels(
    new ImGearColorSpace(igColorSpaceID), igChannelRefNew);

VB .NET
' Separate original image into separate images for each channel.
Dim igChannelRefOriginal As ImGearChannelRef() = ImGearRasterProcessing.SeparateChannels(igRasterPage)
' Save what the colorspace was of the image.
Dim igColorSpaceID As ImGearColorSpaceIDs = igRasterPage.DIB.ColorSpace.Value
' Create a blank image with the same attributes as the original image.
Dim igRasterPageNew As New ImGearRasterPage( _
 igRasterPage.DIB.Width, igRasterPage.DIB.Height, New ImGearColorSpace(igColorSpaceID), _
 DirectCast(igRasterPage.DIB.ChannelDepths.Clone(), Integer()), True)
' Separate new image into separate images for each channel.
Dim igChannelRefNew As ImGearChannelRef() = ImGearRasterProcessing.SeparateChannels(igRasterPageNew)
' Update the first channel of the new image from the original image.
ImGearRasterProcessing.UpdateChannelFrom(igChannelRefNew(0), igChannelRefOriginal(0))
' Combine channels back into new image.
igRasterPageNew = ImGearRasterProcessing.CombineChannels(New ImGearColorSpace(igColorSpaceID), igChannelRefNew)

See Also:

ImGearChannelRef Structure


Vignette Method

32-bit
64-bit
CF
P
P
P

Description:

This method draws a shape on the image and fills the interior or exterior of the shape with a specified color, using a smooth gradient at the edge of the shape.

The behavior of this method depends on whether the image has an Alpha channel or not.

If the image does not have an Alpha channel, the method uses specified color to fill the shape. Use this mode to add a colored vignette to an image. In this mode, you will most likely set the fillInside parameter to false, to fill the borders of the image.

If the source image has an Alpha channel, the method only modifies the contents of the Alpha channel, and leaves color channels unchanged. It uses the alpha value of fillColor as the maximum opacity value for filling. Use this mode to create a semi-transparent vignette that can then be applied to other images. In this mode, you will most likely set the fillInside parameter to true, to make the interior transparent and leave the borders of the vignette opaque.

Declaration:

public static void Vignette(ImGearRasterPage page, IImGearShape shape, int smoothWidth,
double smoothFactor, ImGearPixel fillColor, bool fillInside);

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to add vignette to.
shape
IImGearShape
Specifies vignette shape and position. Supported shape types are ImGearRect Structure, ImGearEllipse Structure, and ImGearRoundedRectangle Structure.
smoothWidth
int
Specifies width of the smothing area. Smoothing area is located outside of the shape.
smoothFactor
double
Specifies the shape of the smoothing curve. The value of 0.5 corresponds to linear transition, smaller values result in smother transition at the transparent edge of the vignette, greater values result in stronger transition at the transparent edge of the vignette. The valid range is 0...1.
fillColor
ImGearPixel Class
If the image does not contain an Alpha channel, specifies fill color for the vignette. Otherwise, the Alpha value of fillColor specifies maximum opacity value for the vignette. Must correspond to the colorspace of the source image.
fillInside
boolean
Set to false to fill outside area of the shape (best for applying a colored vignette). Set to true to fill inside area of the shape (best for creating a vignette from an image).

Return Value:

None.

Availability:

All except bitonal, indexed, Grayscale with LUT and colorspaces containing Premultiplied Alpha and Extra channels.


WarpCylinder Method

32-bit
64-bit
CF
P
P
P

Description:

This method provides warping around a cylinder on the current raster page.

Declaration:

public static void WarpCylinder(ImageGear.Core.ImGearRasterPage page, int distance, int
radius, int height, bool horizontal, bool interpolate, ImageGear.Core.ImGearPixel color)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearRasterPage Class object.
distance
int
Distance to the cylinder axis, in pixels. It is measured from the left edge in the case of a vertical cylinder and from the top edge in the case of a horizontal one.
radius
int
Cylinder radius in pixels.
height
int
Height of the cylinder segment, in pixels. Height can be changed from (-radius) to (radius).
horizontal
bool
If this parameter is true then the cylinder is horizontal, otherwise it is vertical.
interpolate
bool
If this parameter is true then an interpolation is used during processing.
color
ImGearPixel Class
ImGearPixel Class color.

Return Value:

None.

Sample Code:

C#
// Warp the image around a vertical cylinder, 300 pixels from the left edge,
//  with a 200 pixel radius and 50 pixels below the image.
ImGearRasterProcessing.WarpCylinder(igRasterPage, 300, 200, -50, false, true, null);

VB .NET
' Warp the image around a vertical cylinder, 300 pixels from the left edge,
'  with a 200 pixel radius and 50 pixels below the image.
ImGearRasterProcessing.WarpCylinder(igRasterPage, 300, 200, -50, False, True, _
 Nothing)

Availability:

All except bitonal if interpolation is off; all except bitonal, non-gray Indexed and Grayscale with LUT if interpolation is on.

See Also:

ImGearRasterPage Class


WarpParabolic Method

32-bit
64-bit
CF
P
P
P

Description:

This method provides warping around a paraboloid on the current raster page.

Declaration:

public static void WarpParabolic(ImageGear.Core.ImGearRasterPage page,
ImageGear.Core.ImGearPoint center, float strength, int radiusX, int radiusY, bool
interpolate, ImageGear.Core.ImGearPixel color)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearRasterPage Class object.
center
ImGearPoint Structure
Center of the paraboloid, in pixels.
strength
float
Extrusion strength.
radiusX
int
Length of the effect in X direction, in pixels.
radiusY
int
Length of the effect in Y direction, in pixels.
interpolate
bool
If this parameter is true then an interpolation is used during processing.
color
ImGearPixel Class
ImGearPixel Class color.

Return Value:

None.

Availability:

All except bitonal if interpolation is off; all except bitonal, non-gray Indexed and Grayscale with LUT if interpolation is on.

Sample Code:

C#
// Warp the image around a parabola.
// Center point of the parabola, set to center of image.
ImGearPoint igPoint = new ImGearPoint();
igPoint.X = igRasterPage.DIB.Width / 2;
igPoint.Y = igRasterPage.DIB.Height / 2;
// Warp around the parabola with a strength of 50000, an x radius of 300, a y radius of 100,
//  interpolation on, and no fill color.
ImGearRasterProcessing.WarpParabolic(igRasterPage, igPoint, 50000, 300, 100, true, null);

VB .NET
' Warp the image around a parabola.
' Center point of the parabola, set to center of image.
Dim igPoint As New ImGearPoint()
igPoint.X = igRasterPage.DIB.Width / 2
igPoint.Y = igRasterPage.DIB.Height / 2
' Warp around the parabola with a strength of 50000, an x radius of 300, a y radius of 100,
'  interpolation on, and no fill color.
ImGearRasterProcessing.WarpParabolic(igRasterPage, igPoint, 50000, 300, 100, True, Nothing)

See Also:

ImGearRasterPage Class

ImGearPoint Structure


WarpSphere Method

32-bit
64-bit
CF
P
P
P

Description:

This method provides warping around a sphere on the current raster page.

Declaration:

public static void WarpSphere(ImageGear.Core.ImGearRasterPage page,
ImageGear.Core.ImGearPoint center, int radius, int height, bool interpolate,
ImageGear.Core.ImGearPixel color)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
ImGearRasterPage Class object.
center
ImGearPoint Structure
Center of the sphere, in pixels.
radius
int
Sphere radius, in pixels.
height
int
Height of the sphere segment, in pixels. Height can be changed from (-radius) to (radius).
interpolate
bool
If this parameter is true then an interpolation is used during processing.
color
ImGearPixel Class
ImGearPixel Class color.

Return Value:

None.

Availability:

All except bitonal if interpolation is off; all except bitonal, non-gray Indexed and Grayscale with LUT if interpolation is on.

Sample Code:

C#
// Warp the image around a sphere.
// Center point of the sphere, set to center of image.
ImGearPoint igPoint = new ImGearPoint();
igPoint.X = igRasterPage.DIB.Width / 2;
igPoint.Y = igRasterPage.DIB.Height / 2;
// Warp around the sphere with a radius of 200, height of -100, interpolation on, and no fill color.
ImGearRasterProcessing.WarpSphere(igRasterPage, igPoint, 200, -100, true, null);

VB .NET
' Warp the image around a sphere.
' Center point of the sphere, set to center of image.
Dim igPoint As New ImGearPoint()
igPoint.X = igRasterPage.DIB.Width / 2
igPoint.Y = igRasterPage.DIB.Height / 2
' Warp around the sphere with a radius of 200, height of -100, interpolation on, and no fill color.
ImGearRasterProcessing.WarpSphere(igRasterPage, igPoint, 200, -100, True, Nothing)

See Also:

ImGearRasterPage Class

ImGearPoint Structure


ImGearRasterProcessingVerifier Class

32-bit
64-bit
CF
P
P
P

Description:

This class contains static methods that check whether the ImGearRasterProcessing Class operation is applicable to the page or not.

NOTE: These methods should be used to distinguish a sub-set of pages for which particular filter is applicable; e.g., CanApplyDespeckle Method returns true only if incoming page image is binary, that is BitDepth == 1. Parameters of all IP functions are checked separately.

Declaration:

public sealed class ImGearRasterProcessingVerifier

Members:

Methods
Name
Description
CanApplyAddTilt Method
This method returns true if ImGearRasterProcessing.AddTilt method can be applied to the specified page.
CanApplyAdjustContrast Method
Verifies if ImGearRasterProcessing.AdjustContrast (ImGearPage Class Page) method can be applied to the specified Page.
CanApplyAdjustContrast Method
Verifies if ImGearRasterProcessing. AdjustContrast (ImGearPage Class Page, ImGearContrastModes Mode, ImGearChannelRange channels) method can be applied to the specified Page.
CanApplyAdjustWhiteBalance Method
Verifies if ImGearRasterProcessing.AdjustWhiteBalance method can be applied to the specified page.
CanApplyAging Method
Verifies if ImGearRasterProcessing.Aging method can be applied to the specified page.
CanApplyBlend Method
Verifies if ImGearRasterProcessing.Blend method can be applied to the specified Page.
CanApplyBlendWithAlpha Method
Verifies if ImGearRasterProcessing.BlendWithAlpha method can be applied to the specified Page.
CanApplyBoost Method
Verifies if ImGearRasterProcessing.Boost method can be applied to the specified page, false otherwise.
CanApplyCalculateStatistics Method
Checks whether ImGearRasterProcessing Class.CalculateStatistics Method method can be applied to the page.
CanApplyClose Method
Checks if ImGearRasterProcessing.Close method can be applied to the specified raster page.
CanApplyColorReduce Method
This method returns true if ImGearRasterProcessing.Reduce method can be applied to the specified Page, false otherwise.
CanApplyConvertColorSpace Method
Verifies if ImGearRasterProcessing.ConvertColorSpace method can be applied to the specified Page.
CanApplyConvolve Method
Verifies if ImGearRasterProcessing.Convolve method can be applied to the specified Page.
CanApplyCrypt Method
This method returns true if ImGearRasterProcessing.Encrypt method and Decrypt method can be applied to the specified page, false otherwise.
CanApplyCylinder Method
This method returns true if ImGearRasterProcessing.WarpCylinder method can be applied to the specified Page, false otherwise.
CanApplyDeskew Method
Verifies if ImGearRasterProcessing.Deskew method can be applied to the specified Page.
CanApplyDespeckle Method
Verifies if ImGearRasterProcessing.Despeckle method can be applied to the specified Page.
CanApplyDilate Method
Checks if ImGearRasterProcessing.Dilate method can be applied to the specified raster page.
CanApplyDropShadow Method
Verifies if ImGearRasterProcessing.DropShadow method can be applied to the specified page.
CanApplyDuotone Method
Returns true if Duotone method can be applied to the specified page, false otherwise.
CanApplyEdgeDetection Method
This method returns true if ImGearRasterProcessing.EdgeDetection method can be applied to the specified page, false otherwise.
CanApplyEdgeMap Method
This method returns true if ImGearRasterProcessing.EdgeMap method can be applied to the specified page, false otherwise.
CanApplyEnhanceLocal Method
This method returns true if ImGearRasterProcessing.EnhanceLocal method can be applied to the specified Page, false otherwise.
CanApplyEqualizeContrast Method
Verifies if ImGearRasterProcessing.EqualizeContrast (ImGearPage Class Page) method can be applied to the specified Page.
CanApplyEqualizeContrast Method
Verifies if ImGearRasterProcessing. EqualizeContrast (ImGearPage Class Page, ImGearContrastModes Mode, ImGearChannelRange channels) method can be applied to the specified Page.
CanApplyErode Method
Checks if ImGearRasterProcessing.Erode method can be applied to the specified raster page.
CanApplyFilterWithMedian Method
Verifies if ImGearRasterProcessing.FilterWithMedian method can be applied to the specified Page.
CanApplyFilterWithUnsharpMask Method
Verifies if ImGearRasterProcessing.FilterWithUnsharpMask method can be applied to the specified Page.
CanApplyFindSkewAngle Method
Verifies if ImGearRasterProcessing.FindSkewAngle method can be applied to the specified Page.
CanApplyFindTilt Method
This method returns true if ImGearRasterProcessing.FindTilt method can be applied to the specified Page, false otherwise.
CanApplyFragment Method
Verifies if ImGearRasterProcessing.Fragment method can be applied to the specified page
CanApplyFunctionalLights Method
Verifies if ImGearRasterProcessing.FreeRadialLight method, FreeDirectionalLight method, DirectionalLight method, or RadialLight method can be applied to the specified page.
CanApplyGaussianBlur Method
Verifies if ImGearRasterProcessing.GaussianBlur method can be applied to the specified page.
CanApplyGeomDespeckle Method
This method returns true if ImGearRasterProcessing.GeomDespeckle method can be applied to the specified Page, false otherwise.
CanApplyGlowingEdges Method
Verifies if ImGearRasterProcessing.GlowingEdges method can be applied to the Page.
CanApplyHighDensityRangeEffect Method
Verifies if ImGearRasterProcessing.HighDensityRangeEffect method can be applied to the Page.
CanApplyHotWax Method
Verifies if ImGearRasterProcessing.HotWax method can be applied to the Page.
CanApplyInvertContrast Method
Verifies if ImGearRasterProcessing.InvertContrast (ImGearPage Class Page) method can be applied to the specified Page.
CanApplyInvertContrast Method
Verifies if ImGearRasterProcessing.InvertContrast(ImGearPage Class Page, ImGearContrastModes Mode, ImGearChannelRange channels) method can be applied to the specified Page.
CanApplyLensFlare Method
Verifies if ImGearRasterProcessing.LensFlare method can be applied to the specified page.
CanApplyMerge Method
Verifies if ImGearRasterProcessing.Merge (ImGearPage Class Page) method can be applied to the specified Page.
CanApplyMonochromeFilm Method
Verifies if ImGearRasterProcessing.MonochromeFilm method can be applied to the Page.
CanApplyMosaic Method
This method returns true if ImGearRasterProcessing.Mosaic method can be applied to the specified page, false otherwise.
CanApplyNightVision Method
Returns true if NightVision method can be applied to the specified page, false otherwise.
CanApplyOilify Method
Verifies if ImGearRasterProcessing.Oilify method can be applied to the specified page.
CanApplyOpen Method
Checks if ImGearRasterProcessing.Open method can be applied to the specified raster page.
CanApplyParabola Method
This method returns true if ImGearRasterProcessing.WarpParabola method can be applied to the specified Page, false otherwise.
CanApplyPerspective Method
This method returns true if ImGearRasterProcessing.Perspective method can be applied to the specified Page, false otherwise.
CanApplyPicturize Method
This method returns true if ImGearRasterProcessing.Picturize method can be applied to the specified page, false otherwise.
CanApplyPinch Method
This method returns true if ImGearRasterProcessing.Pinch method can be applied to the specified Page, false otherwise.
CanApplyPixelate Method
This method returns true if ImGearRasterProcessing.Pixelate method can be applied to the specified Page, false otherwise.
CanApplyPointillist Method
Verifies if ImGearRasterProcessing.Pointillist method can be applied to the specified page.
CanApplyProcessArea Method
This method returns true if ImGearRasterProcessing.ProcessArea method can be applied to the specified Page, false otherwise.
CanApplyRemoveChromaticAberration Method
This method returns true if ImGearRasterProcessing.RemoveChromaticAberration method can be applied to the specified page, false otherwise.
CanApplyRemoveTilt Method
This method returns true if ImGearRasterProcessing.RemoveTilt method can be applied to the specified Page, false otherwise.
CanApplyRipple Method
This method returns if ImGearRasterProcessing.Ripple, ImGearProcessing.RippleFreeHand and ImGearProcessing.RippleTexture methods can be applied to the specified page, false otherwise.
CanApplyRoundCorners Method
Returns true if RoundCorners method can be applied to the specified page, false otherwise.
CanApplySepia Method
Returns true if Sepia method can be applied to the specified page, false otherwise.
CanApplySharpen Method
Verifies if ImGearRasterProcessing.Sharpen method can be applied to the specified Page.
CanApplyShear Method
Verifies if ImGearRasterProcessing.Shear method can be applied to the specified page.
CanApplySketch Method
Verifies if ImGearRasterProcessing.PencilSketch method can be applied to the Page.
CanApplySmooth Method
Verifies if ImGearRasterProcessing.Smooth method can be applied to the specified Page.
CanApplySolarize Method
This method returns true if ImGearRasterProcessing.Solarize method can be applied to the specified Page, false otherwise.
CanApplySpatter Method
Verifies if ImGearRasterProcessing.Spatter method can be applied to the specified page.
CanApplySphere Method
This method returns true if ImGearRasterProcessing.WarpSphere method can be applied to the specified Page, false otherwise.
CanApplySpotlights Method
Returns true if Spotlights method can be applied to the specified page, false otherwise.
CanApplySpotlightsPreview Method
Returns true if SpotlightsPreview method can be applied to the specified page, false otherwise.
CanApplyStretchContrast Method
Verifies if ImGearRasterProcessing.StretchContrast (ImGearPage Class Page) method can be applied to the specified Page.
CanApplyStretchContrast Method
Verifies if ImGearRasterProcessing.StretchContrast (ImGearPage Class Page, ImGearContrastModes Mode, ImGearChannelRange channels) method can be applied to the specified Page.
CanApplyTabulateHistogram Method
Checks whether ImGearRasterProcessing Class.TabulateHistogram Method method can be applied to the page.
CanApplyToyCamera Method
Returns true if ToyCamera method can be applied to the specified page, false otherwise.
CanApplyTransformWithLUT Method
Checks whether ImGearRasterProcessing Class.TransformWithLUT Method method can be applied to the page.
CanApplyVignette Method
Returns true if Vignette method can be applied to the specified page, false otherwise.
CanApplyWave Method
This method returns true if ImGearRasterProcessing.DirectionalWave and ImGearRasterProcessing.RadialWave methods can be applied to the specified Page, false otherwise.

See Also:

ImGearRasterProcessing Class


ImGearRasterProcessingVerifier Methods

The ImGearRasterProcessingVerifier Class of the ImageGear.Processing Namespace has the following methods:

Methods
Name
Description
CanApplyAddTilt Method
This method returns true if ImGearRasterProcessing.AddTilt method can be applied to the specified page.
CanApplyAdjustContrast Method
Verifies if ImGearRasterProcessing.AdjustContrast (ImGearPage Class Page) method can be applied to the specified Page.
CanApplyAdjustContrast Method
Verifies if ImGearRasterProcessing. AdjustContrast (ImGearPage Class Page, ImGearContrastModes Mode, ImGearChannelRange channels) method can be applied to the specified Page.
CanApplyAdjustWhiteBalance Method
Verifies if ImGearRasterProcessing.AdjustWhiteBalance method can be applied to the specified page.
CanApplyAging Method
Verifies if ImGearRasterProcessing.Aging method can be applied to the specified page.
CanApplyBlend Method
Verifies if ImGearRasterProcessing.Blend method can be applied to the specified Page.
CanApplyBlendWithAlpha Method
Verifies if ImGearRasterProcessing.BlendWithAlpha method can be applied to the specified Page.
CanApplyBoost Method
Verifies if ImGearRasterProcessing.Boost method can be applied to the specified page, false otherwise.
CanApplyCalculateStatistics Method
Checks whether ImGearRasterProcessing Class.CalculateStatistics Method method can be applied to the page.
CanApplyClose Method
Checks if ImGearRasterProcessing.Close method can be applied to the specified raster page.
CanApplyColorReduce Method
This method returns true if ImGearRasterProcessing.Reduce method can be applied to the specified Page, false otherwise.
CanApplyConvertColorSpace Method
Verifies if ImGearRasterProcessing.ConvertColorSpace method can be applied to the specified Page.
CanApplyConvolve Method
Verifies if ImGearRasterProcessing.Convolve method can be applied to the specified Page.
CanApplyCrypt Method
This method returns true if ImGearRasterProcessing.Encrypt method and Decrypt method can be applied to the specified page, false otherwise.
CanApplyCylinder Method
This method returns true if ImGearRasterProcessing.WarpCylinder method can be applied to the specified Page, false otherwise.
CanApplyDeskew Method
Verifies if ImGearRasterProcessing.Deskew method can be applied to the specified Page.
CanApplyDespeckle Method
Verifies if ImGearRasterProcessing.Despeckle method can be applied to the specified Page.
CanApplyDilate Method
Checks if ImGearRasterProcessing.Dilate method can be applied to the specified raster page.
CanApplyDropShadow Method
Verifies if ImGearRasterProcessing.DropShadow method can be applied to the specified page.
CanApplyDuotone Method
Returns true if Duotone method can be applied to the specified page, false otherwise.
CanApplyEdgeDetection Method
This method returns true if ImGearRasterProcessing.EdgeDetection method can be applied to the specified page, false otherwise.
CanApplyEdgeMap Method
This method returns true if ImGearRasterProcessing.EdgeMap method can be applied to the specified page, false otherwise.
CanApplyEnhanceLocal Method
This method returns true if ImGearRasterProcessing.EnhanceLocal method can be applied to the specified Page, false otherwise.
CanApplyEqualizeContrast Method
Verifies if ImGearRasterProcessing.EqualizeContrast (ImGearPage Class Page) method can be applied to the specified Page.
CanApplyEqualizeContrast Method
Verifies if ImGearRasterProcessing. EqualizeContrast (ImGearPage Class Page, ImGearContrastModes Mode, ImGearChannelRange channels) method can be applied to the specified Page.
CanApplyErode Method
Checks if ImGearRasterProcessing.Erode method can be applied to the specified raster page.
CanApplyFilterWithMedian Method
Verifies if ImGearRasterProcessing.FilterWithMedian method can be applied to the specified Page.
CanApplyFilterWithUnsharpMask Method
Verifies if ImGearRasterProcessing.FilterWithUnsharpMask method can be applied to the specified Page.
CanApplyFindSkewAngle Method
Verifies if ImGearRasterProcessing.FindSkewAngle method can be applied to the specified Page.
CanApplyFindTilt Method
This method returns true if ImGearRasterProcessing.FindTilt method can be applied to the specified Page, false otherwise.
CanApplyFragment Method
Verifies if ImGearRasterProcessing.Fragment method can be applied to the specified page
CanApplyFunctionalLights Method
Verifies if ImGearRasterProcessing.FreeRadialLight method, FreeDirectionalLight method, DirectionalLight method, or RadialLight method can be applied to the specified page.
CanApplyGaussianBlur Method
Verifies if ImGearRasterProcessing.GaussianBlur method can be applied to the specified page.
CanApplyGeomDespeckle Method
This method returns true if ImGearRasterProcessing.GeomDespeckle method can be applied to the specified Page, false otherwise.
CanApplyGlowingEdges Method
Verifies if ImGearRasterProcessing.GlowingEdges method can be applied to the Page.
CanApplyHighDensityRangeEffect Method
Verifies if ImGearRasterProcessing.HighDensityRangeEffect method can be applied to the Page.
CanApplyHotWax Method
Verifies if ImGearRasterProcessing.HotWax method can be applied to the Page.
CanApplyInvertContrast Method
Verifies if ImGearRasterProcessing.InvertContrast (ImGearPage Class Page) method can be applied to the specified Page.
CanApplyInvertContrast Method
Verifies if ImGearRasterProcessing.InvertContrast(ImGearPage Class Page, ImGearContrastModes Mode, ImGearChannelRange channels) method can be applied to the specified Page.
CanApplyLensFlare Method
Verifies if ImGearRasterProcessing.LensFlare method can be applied to the specified page.
CanApplyMerge Method
Verifies if ImGearRasterProcessing.Merge (ImGearPage Class Page) method can be applied to the specified Page.
CanApplyMonochromeFilm Method
Verifies if ImGearRasterProcessing.MonochromeFilm method can be applied to the Page.
CanApplyMosaic Method
This method returns true if ImGearRasterProcessing.Mosaic method can be applied to the specified page, false otherwise.
CanApplyNightVision Method
Returns true if NightVision method can be applied to the specified page, false otherwise.
CanApplyOilify Method
Verifies if ImGearRasterProcessing.Oilify method can be applied to the specified page.
CanApplyOpen Method
Checks if ImGearRasterProcessing.Open method can be applied to the specified raster page.
CanApplyParabola Method
This method returns true if ImGearRasterProcessing.WarpParabola method can be applied to the specified Page, false otherwise.
CanApplyPerspective Method
This method returns true if ImGearRasterProcessing.Perspective method can be applied to the specified Page, false otherwise.
CanApplyPicturize Method
This method returns true if ImGearRasterProcessing.Picturize method can be applied to the specified page, false otherwise.
CanApplyPinch Method
This method returns true if ImGearRasterProcessing.Pinch method can be applied to the specified Page, false otherwise.
CanApplyPixelate Method
This method returns true if ImGearRasterProcessing.Pixelate method can be applied to the specified Page, false otherwise.
CanApplyPointillist Method
Verifies if ImGearRasterProcessing.Pointillist method can be applied to the specified page.
CanApplyProcessArea Method
This method returns true if ImGearRasterProcessing.ProcessArea method can be applied to the specified Page, false otherwise.
CanApplyRemoveChromaticAberration Method
This method returns true if ImGearRasterProcessing.RemoveChromaticAberration method can be applied to the specified page, false otherwise.
CanApplyRemoveTilt Method
This method returns true if ImGearRasterProcessing.RemoveTilt method can be applied to the specified Page, false otherwise.
CanApplyRipple Method
This method returns if ImGearRasterProcessing.Ripple, ImGearProcessing.RippleFreeHand and ImGearProcessing.RippleTexture methods can be applied to the specified page, false otherwise.
CanApplyRoundCorners Method
Returns true if RoundCorners method can be applied to the specified page, false otherwise.
CanApplySepia Method
Returns true if Sepia method can be applied to the specified page, false otherwise.
CanApplySharpen Method
Verifies if ImGearRasterProcessing.Sharpen method can be applied to the specified Page.
CanApplyShear Method
Verifies if ImGearRasterProcessing.Shear method can be applied to the specified page.
CanApplySketch Method
Verifies if ImGearRasterProcessing.PencilSketch method can be applied to the Page.
CanApplySmooth Method
Verifies if ImGearRasterProcessing.Smooth method can be applied to the specified Page.
CanApplySolarize Method
This method returns true if ImGearRasterProcessing.Solarize method can be applied to the specified Page, false otherwise.
CanApplySpatter Method
Verifies if ImGearRasterProcessing.Spatter method can be applied to the specified page.
CanApplySphere Method
This method returns true if ImGearRasterProcessing.WarpSphere method can be applied to the specified Page, false otherwise.
CanApplySpotlights Method
Returns true if Spotlights method can be applied to the specified page, false otherwise.
CanApplySpotlightsPreview Method
Returns true if SpotlightsPreview method can be applied to the specified page, false otherwise.
CanApplyStretchContrast Method
Verifies if ImGearRasterProcessing.StretchContrast (ImGearPage Class Page) method can be applied to the specified Page.
CanApplyStretchContrast Method
Verifies if ImGearRasterProcessing.StretchContrast (ImGearPage Class Page, ImGearContrastModes Mode, ImGearChannelRange channels) method can be applied to the specified Page.
CanApplyTabulateHistogram Method
Checks whether ImGearRasterProcessing Class.TabulateHistogram Method method can be applied to the page.
CanApplyToyCamera Method
Returns true if ToyCamera method can be applied to the specified page, false otherwise.
CanApplyTransformWithLUT Method
Checks whether ImGearRasterProcessing Class.TransformWithLUT Method method can be applied to the page.
CanApplyVignette Method
Returns true if Vignette method can be applied to the specified page, false otherwise.
CanApplyWave Method
This method returns true if ImGearRasterProcessing.DirectionalWave and ImGearRasterProcessing.RadialWave methods can be applied to the specified Page, false otherwise.


CanApplyAddTilt Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.AddTilt method can be applied to the specified page.

Declaration:

public bool CanApplyAddTilt(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

AddTilt Method


CanApplyAdjustContrast Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.AdjustContrast method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplyAdjustContrast(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

AdjustContrast Method


CanApplyAdjustContrast Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true, if ImGearRasterProcessing. AdjustContrast method can be applied to the specified page with the specified contrast mode, false otherwise.

Declaration:

public bool CanApplyAdjustContrast(ImageGear.Core.ImGearRasterPage page,
ImageGear.Processing.ImGearContrastModes mode)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.
mode
ImGearContrastModes Enumeration
Contrast mode.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

ImGearContrastModes Enumeration

AdjustContrast Method


CanApplyAdjustWhiteBalance Method

32-bit
64-bit
CF
P
P
P

Description:

Returns true if ImGearProcessing.AdjustWhiteBalance method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplyAdjustWhiteBalance(ImageGear.Core.ImGearPage page)

Parameters:

Name
Type
Description
page
ImGearPage Class
Page specified

Return Value:

True, false.

See Also:

AdjustWhiteBalance Method


CanApplyAging Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.Aging method can be applied to the specified page.

Declaration:

public bool CanApplyAging(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

Aging Method


CanApplyBlend Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.Blend method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplyBlend(ImageGear.Core.ImGearRasterPage page,
ImageGear.Core.ImGearRasterPage pageToBlendWith)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.
pageToBlendWith
ImGearRasterPage Class
Page to blend with.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

Blend Method


CanApplyBlendWithAlpha Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.BlendWithAlpha method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplyBlendWithAlpha(ImageGear.Core.ImGearRasterPage page,
ImageGear.Core.ImGearRasterPage alpha)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.
alpha
ImGearRasterPage Class
Page to blend with.

Return Value:

True, False.

See Also:

ImGearRasterPage Class

BlendWithAlpha Method


CanApplyBoost Method

32-bit
64-bit
CF
P
P
P

Description:

Returns true if ImGearProcessing.Boost method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplyBoost(ImageGear.Core.ImGearPage page)

Parameters:

Name
Type
Description
page
ImGearPage Class
Page specified

Return Value:

True, false.

See Also:

Boost Method


CanApplyCalculateStatistics Method

32-bit
64-bit
CF
P
P
P

Description:

This method checks whether ImGearRasterProcessing Class.CalculateStatistics Method method can be applied to the page.

Declaration:

public bool CanApplyCalculateStatistics(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page for which statistics shall be calculated.

Return Value:

True, false.

Example:

bool CanApply = ImGearRasterProcessingVerifier.CanApplyCalculateStatistics(page)

See Also:

ImGearRasterPage Class

CalculateStatistics Method


CanApplyClose Method

32-bit
64-bit
CF
P
P
P

Description:

This method checks if ImGearRasterProcessing.Close method can be applied to the specified raster page.

Declaration:

public bool CanApplyClose(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
Page object
Raster page object to verify.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

Close Method


CanApplyColorReduce Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.Reduce method can be applied to the specified Page, false otherwise.

Declaration:

public bool CanApplyColorReduce(ImageGear.Core.ImGearRasterPage page, bool bAllowIndexed)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page for which statistics shall be calculated.
bAllowIndexed
bool
Allows consideration of images with indexed color space.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

Reduce Method


CanApplyConvertColorSpace Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.ConvertColorSpace method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplyConvertColorSpace(ImageGear.Core.ImGearRasterPage page,
ImageGear.Core.ImGearColorSpace space)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.
space
ConvertColorSpace Method
Color space.

Return Value:

True, false.

See Also:

ConvertColorSpace Method

ImGearRasterPage Class

ImGearColorSpace Structure


CanApplyConvolve Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.Convolve method can be applied to the specified Page, false otherwise.

Declaration:

public bool CanApplyConvolve(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

Convolve Method


CanApplyCrypt Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.Encrypt method and Decrypt method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplyCrypt(ImageGear.Core.ImGearRasterPage page, string password)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.
password
string
Password to Encrypt/Decrypt image.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

Decrypt Method

Encrypt Method


CanApplyCylinder Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.WarpCylinder method can be applied to the specified Page, false otherwise.

Declaration:

public bool CanApplyCylinder(ImageGear.Core.ImGearRasterPage page, bool interpolate)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.
interpolate
bool
Specify true if interpolation is to be used during processing, otherwise false.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

WarpCylinder Method


CanApplyDeskew Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true, if ImGearRasterProcessing.Deskew method can be applied to the specified Page, false otherwise.

Declaration:

public bool CanApplyDeskew(ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

Deskew Method


CanApplyDespeckle Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true, if ImGearRasterProcessing.Despeckle method can be applied to the specified Page, false otherwise.

Declaration:

public bool CanApplyDespeckle(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

Despeckle Method


CanApplyDilate Method

32-bit
64-bit
CF
P
P
P

Description:

This method checks if ImGearRasterProcessing.Dilate method can be applied to the specified raster page.

Declaration:

public bool CanApplyDilate(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
Page object
Raster page object to verify.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

Dilate Method


CanApplyDropShadow Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.DropShadow method can be applied to the specified page.

Declaration:

public bool CanApplyDropShadow(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

DropShadow Method


CanApplyDuotone Method

32-bit
64-bit
CF
P
P
P

Description:

Returns true if Duotone method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplyDuotone(ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to apply the method to.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

Duotone Method


CanApplyEdgeDetection Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true, if ImGearRasterProcessing.EdgeDetection method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplyEdgeDetection(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

EdgeDetection Method


CanApplyEdgeMap Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true, if ImGearRasterProcessing.EdgeMap method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplyEdgeMap(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

EdgeMap Method


CanApplyEnhanceLocal Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true, if ImGearRasterProcessing.EnhanceLocal method can be applied to the specified Page, false otherwise.

Declaration:

public bool CanApplyEnhanceLocal(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

EnhanceLocal Method


CanApplyEqualizeContrast Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true, if ImGearRasterProcessing.EqualizeContrast method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplyEqualizeContrast(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

EqualizeContrast Method


CanApplyEqualizeContrast Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true, if ImGearRasterProcessing.EqualizeContrast method can be applied to the specified Page and contrast mode, false otherwise.

Declaration:

public bool CanApplyEqualizeContrast(ImageGear.Core.ImGearRasterPage page,
ImageGear.Processing.ImGearContrastModes mode)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.
mode
ImGearContrastModes Enumeration
Contrast mode.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

ImGearContrastModes Enumeration

EqualizeContrast Method


CanApplyErode Method

32-bit
64-bit
CF
P
P
P

Description:

This method checks if ImGearRasterProcessing.Erode method can be applied to the specified raster page.

Declaration:

public bool CanApplyErode(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
Page object
Raster page object to verify.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

Erode Method


CanApplyFilterWithMedian Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true, if ImGearRasterProcessing.FilterWithMedian method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplyFilterWithMedian(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

FilterWithMedian Method


CanApplyFilterWithUnsharpMask Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.FilterWithUnsharpMask method can be applied to the specified Page, false otherwise.

Declaration:

public bool CanApplyFilterWithUnsharpMask(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

FilterWithUnsharpMask Method


CanApplyFindSkewAngle Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.FindSkewAngle method can be applied to the specified Page, false otherwise.

Declaration:

public bool CanApplyFindSkewAngle(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

FindSkewAngle Method


CanApplyFindTilt Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.FindTilt method can be applied to the specified Page, false otherwise.

Declaration:

public bool CanApplyFindTilt(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

FindTilt Method


CanApplyFragment Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.Fragment method can be applied to the specified page.

Declaration:

public bool CanApplyFragment(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

Fragment Method


CanApplyFunctionalLights Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing Class . FreeDirectionalLight Method, ImGearRasterProcessing Class . FreeRadialLight Method, ImGearRasterProcessing Class . DirectionalLight Method, or ImGearRasterProcessing Class . RadialLight Method can be applied to the specified page.

Declaration:

public bool CanApplyFunctionalLights(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

FreeDirectionalLight Method

FreeRadialLight Method

DirectionalLight Method

RadialLight Method


CanApplyGaussianBlur Method

32-bit
64-bit
CF
P
P
P

Description:

Returns true if ImGearProcessing.GausianBlur method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplyGaussianBlur(ImageGear.Core.ImGearPage page)

Parameters:

Name
Type
Description
page
ImGearPage Class
Page specified

Return Value:

True, false.

See Also:

GaussianBlur Method


CanApplyGeomDespeckle Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.GeomDespeckle method can be applied to the specified Page, false otherwise.

Declaration:

public bool CanApplyGeomDespeckle(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

GeomDespeckle Method


CanApplyGlowingEdges Method

32-bit
64-bit
CF
P
P
P

Description:

Returns true if ImGearProcessing.GlowingEdges Method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplyGlowingEdges(ImageGear.Core.ImGearPage page)

Parameters:

Name
Type
Description
page
ImGearPage Class
Page specified

Return Value:

True, false.

See Also:

GlowingEdges Method


CanApplyHighDensityRangeEffect Method

32-bit
64-bit
CF
P
P
P

Description:

Returns true if ImGearProcessing.HighDensityRangeEffect Method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplyHighDensityRangeEffect(ImageGear.Core.ImGearPage page)

Parameters:

Name
Type
Description
page
ImGearPage Class
Page specified

Return Value:

True, false.

See Also:

HighDensityRangeEffect Method


CanApplyHotWax Method

32-bit
64-bit
CF
P
P
P

Description:

Returns true if ImGearProcessing.HotWax Method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplyHotWax(ImageGear.Core.ImGearPage page)

Parameters:

Name
Type
Description
page
ImGearPage Class
Page specified

Return Value:

True, false.

See Also:

HotWax Method


CanApplyInvertContrast Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.InvertContrast method can be applied to the specified Page, false otherwise.

Declaration:

public bool CanApplyInvertContrast(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

InvertContrast Method


CanApplyInvertContrast Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.InvertContrast method can be applied to the specified page and specified contrast mode, false otherwise.

Declaration:

public bool CanApplyInvertContrast(ImageGear.Core.ImGearRasterPage page,
ImageGear.Processing.ImGearContrastModes mode)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.
mode
ImGearContrastModes Enumeration
Contrast mode.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

ImGearContrastModes Enumeration

InvertContrast Method


CanApplyLensFlare Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.LensFlare method can be applied to the specified page.

Declaration:

public bool CanApplyLensFlare(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

LensFlare Method

ImGearLensFlareType Enumeration


CanApplyMerge Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.Merge method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplyMerge(ImageGear.Core.ImGearRasterPage page,
ImageGear.Core.ImGearRasterPage pageToMergeWith)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.
pageToMergeWith
ImGearRasterPage Class
Page to merge.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

Merge Method


CanApplyMonochromeFilm Method

32-bit
64-bit
CF
P
P
P

Description:

Returns true if ImGearProcessing.MonochromeFilm Method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplyMonochromeFilm(ImageGear.Core.ImGearPage page)

Parameters:

Name
Type
Description
page
ImGearPage Class
Page specified

Return Value:

True, false.

See Also:

MonochromeFilm Method


CanApplyMosaic Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.Mosaic method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplyMosaic(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

Mosaic Method


CanApplyNightVision Method

32-bit
64-bit
CF
P
P
P

Description:

Returns true if NightVision method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplyNightVision(ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to apply the method to.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

NightVision Method


CanApplyOilify Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.Oilify method can be applied to the specified page.

Declaration:

public bool CanApplyOilify(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

Oilify Method


CanApplyOpen Method

32-bit
64-bit
CF
P
P
P

Description:

This method checks if ImGearRasterProcessing. Open Method can be applied to the specified raster page.

Declaration:

public bool CanApplyOpen(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Raster page object to verify.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

Open Method


CanApplyParabola Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.WarpParabola method can be applied to the specified Page, false otherwise.

Declaration:

public bool CanApplyParabola(ImageGear.Core.ImGearRasterPage page, bool interpolate)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.
interpolate
bool
Specify true if interpolation is to be used during processing, otherwise false.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

WarpParabolic Method


CanApplyPerspective Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.Perspective method can be applied to the specified Page, false otherwise.

Declaration:

public bool CanApplyPerspective(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

Perspective Method


CanApplyPicturize Method

32-bit
64-bit
CF
P
P
P

Description:

Returns true if ImGearProcessing.Picturize Method can be applied to the specified page, false otherwise.

Note that ImGearProcessing.Picturize method itself does not have a parameter of type ImGearRasterPage Class. Instead, it uses auxiliary classes, and constructor of one of these classes has an ImGearRasterPage parameter.

Declaration:

public bool CanApplyPicturize(ImageGear.Core.ImGearPage page)

Parameters:

Name
Type
Description
page
ImGearPage Class
Page specified

Return Value:

True, false.

See Also:

Picturize Method


CanApplyPinch Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing. Pinch Method can be applied to the specified Page, false otherwise.

Declaration:

public bool CanApplyPinch(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

Pinch Method


CanApplyPixelate Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.Pixelate method can be applied to the specified Page, false otherwise.

Declaration:

public bool CanApplyPixelate(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

Pixelate Method


CanApplyPointillist Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.Pointillist method can be applied to the specified page.

Declaration:

public bool CanApplyPointillist(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

Pointillist Method

ImGearBrushType Enumeration


CanApplyProcessArea Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing. ProcessArea Method method can be applied to the specified Page, false otherwise.

Declaration:

public bool CanApplyProcessAreaMethod(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

ProcessArea Method


CanApplyRemoveChromaticAberration Method

32-bit
64-bit
CF
P
P
P

Description:

Returns true if ImGearProcessing.RemoveChromaticAberration Method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplyRemoveChromaticAberration(ImageGear.Core.ImGearPage page)

Parameters:

Name
Type
Description
page
ImGearPage Class
Page specified

Return Value:

True, false.

See Also:

RemoveChromaticAberration Method


CanApplyRemoveTilt Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.RemoveTilt method can be applied to the specified Page, false otherwise.

Declaration:

public bool CanApplyRemoveTilt(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.
pageToMergeWith
ImGearRasterPage Class
Page to merge.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

RemoveTilt Method


CanApplyRipple Method

32-bit
64-bit
CF
P
P
P

Description:

Returns true if ImGearProcessing.Ripple, ImGearProcessing.RippleFreeHand and ImGearProcessing.RippleTexture methods can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplyRipple(ImageGear.Core.ImGearPage page)

Parameters:

Name
Type
Description
page
ImGearPage Class
Page specified

Return Value:

True, false.

See Also:

Ripple Method

RippleFreeHand Method

RippleTexture Method


CanApplyRoundCorners Method

32-bit
64-bit
CF
P
P
P

Description:

Returns true if RoundCorners method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplyRoundCorners(ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to apply the method to.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

RoundCorners Method


CanApplySepia Method

32-bit
64-bit
CF
P
P
P

Description:

Returns true if Sepia method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplySepia(ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to apply the method to.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

Sepia Method


CanApplySharpen Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.Sharpen method can be applied to the specified Page, false otherwise.

Declaration:

public bool CanApplySharpen(ImGearPage Page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

Sharpen Method


CanApplyShear Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.Shear method can be applied to the specified page.

Declaration:

public bool CanApplyShear(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

Shear Method

ImGearShearFillStyle Enumeration


CanApplySketch Method

32-bit
64-bit
CF
P
P
P

Description:

Returns true if ImGearProcessing.Sketch Method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplySketch(ImageGear.Core.ImGearPage page)

Parameters:

Name
Type
Description
page
ImGearPage Class
Page specified

Return Value:

True, false.

See Also:

Sketch Method


CanApplySmooth Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.Smooth method can be applied to the specified Page, false otherwise.

Declaration:

public bool CanApplySmooth(ImGearPage Page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

Smooth Method


CanApplySolarize Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.Solarize method can be applied to the specified Page, false otherwise.

Declaration:

public bool CanApplySolarize(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

Solarize Method


CanApplySpatter Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.Spatter method can be applied to the specified page.

Declaration:

public bool CanApplySpatter(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

Spatter Method


CanApplySphere Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.WarpSphere method can be applied to the specified Page, false otherwise.

Declaration:

public bool CanApplySphere(ImageGear.Core.ImGearRasterPage page, bool interpolate)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.
interpolate
bool
Specify true if interpolation is to be used during processing, otherwise false.

Return Value:

True, false.

See Also:

WarpSphere Method

ImGearRasterPage Class


CanApplySpotlights Method

32-bit
64-bit
CF
P
P
P

Description:

Returns true if Spotlights method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplySpotlights(ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to apply the method to.

Return Value:

True, false.

See Also:

Spotlights Method

ImGearRasterPage Class


CanApplySpotlightsPreview Method

32-bit
64-bit
CF
P
P
P

Description:

Returns true if SpotlightsPreview method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplySpotlightsPreview(ImGearRasterPage page, ImGearRasterPage previewPage)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to apply the method to.
previewPage
ImGearRasterPage Class
Preview page to apply the method to.

Return Value:

True, false.

See Also:

SpotlightsPreview Method

ImGearRasterPage Class


CanApplyStretchContrast Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.StretchContrast method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplyStretchContrast(ImageGear.Core.ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

StretchContrast Method


CanApplyStretchContrast Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true, if ImGearRasterProcessing.StretchContrast method can be applied to the specified Page with the specified contrast mode, false otherwise.

Declaration:

public bool CanApplyStretchContrast(ImageGear.Core.ImGearRasterPage page,
ImageGear.Processing.ImGearContrastModes mode)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.
mode
ImGearContrastModes Enumeration
Contrast mode.

Return Value:

True, false.

See Also:

ImGearRasterPage Class

ImGearContrastModes Enumeration

StretchContrast Method


CanApplyTabulateHistogram Method

32-bit
64-bit
CF
P
P
P

Description:

This method checks whether ImGearRasterProcessing Class.TabulateHistogram Method method can be applied to the page.

Declaration:

public System.Boolean CanApplyTabulateHistogram ( ImageGear.Core.ImGearRasterPage page )

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, False.

Example:

bool CanApply = ImGearRasterProcessingVerifier.CanApplyTabulateHistogram(page)

See Also:

ImGearRasterPage Class

TabulateHistogram Method


CanApplyToyCamera Method

32-bit
64-bit
CF
P
P
P

Description:

Returns true if the ToyCamera method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplyToyCamera(ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to apply the method to.

Return Value:

True, False.

See Also:

ImGearRasterPage Class

ToyCamera Method


CanApplyTransformWithLUT Method

32-bit
64-bit
CF
P
P
P

Description:

This method checks whether ImGearRasterProcessing Class.TransformWithLUT Method method can be applied to the page.

Declaration:

public System.Boolean CanApplyTransformWithLUT ( ImageGear.Core.ImGearRasterPage page )

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.

Return Value:

True, False.

Example:

bool CanApply = ImGearRasterProcessingVerifier.CanApplyCalculateStatistics(page)

See Also:

ImGearRasterPage Class

TransformWithLUT Method


CanApplyVignette Method

32-bit
64-bit
CF
P
P
P

Description:

Returns true if Vignette method can be applied to the specified page, false otherwise.

Declaration:

public bool CanApplyVignette(ImGearRasterPage page)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page to apply the method to.

Return Value:

True, False.

See Also:

ImGearRasterPage Class

Vignette Method


CanApplyWave Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns true if ImGearRasterProcessing.DirectionalWave and ImGearRasterProcessing.RadialWave methods can be applied to the specified Page, false otherwise.

Declaration:

public bool CanApplyWave(ImageGear.Core.ImGearRasterPage page, bool interpolate)

Parameters:

Name
Type
Description
page
ImGearRasterPage Class
Page specified.
interpolate
bool
Specify true if interpolation is to be used during processing, otherwise false.

Return Value:

True, False.

See Also:

DirectionalWave Method

RadialWave Method

ImGearRasterPage Class


ImGearReductionOptions Class

32-bit
64-bit
CF
P
P
P

Description:

This class is used to specify options for performing color reduction using the Reduce Method.

The only options used by the Reduce Method are the ones which correspond to the type of reduction as specified by the reductionMethod parameter of the Reduce Method.

Declaration:

public class ImGearReductionOptions

Members:

Constructors
Name
Description
ImGearReductionOptions Constructor
Initializes the instance of ImGearReductionOptions Class.

Fields
Name
Description
Bayer Field
Specifies ImGearBayerReductionOptions Class options for color reduction.
Bitonal Field
Specifies ImGearBitonalReductionOptions Class options for color reduction.
Diffuse Field
Specifies ImGearDiffuseReductionOptions Class options for color reduction.
Halftone Field
Specifies ImGearHalftoneReductionOptions Class options for color reduction.
Median Field
Specifies ImGearMedianCutReductionOptions Class options for color reduction.
Octree Field
Specifies ImGearOctreeReductionOptions Class options for color reduction.
Popularity Field
Specifies ImGearPopularityReductionOptions Class options for color reduction.
Scale Field
Specifies ImGearScaleReductionOptions Class options for color reduction.

Sample Code:

C#
// Reduce the bit depth of an image to 4 bit
// Create reduction options object and setup a few values for a 16 color 4-bit reduction.
ImGearReductionOptions igReductionOptions = new ImGearReductionOptions();
igReductionOptions.Octree.MaxColors = 16;
igReductionOptions.Octree.FastRemap = false;
igReductionOptions.Octree.ErrorDiffusion = true;
//Apply the reduction using Octree to get a 4-bit index image.
ImGearRasterProcessing.Reduce(igRasterPage, new ImGearColorSpace(ImGearColorSpaceIDs.I),
    new int[] { 4 }, ImGearReductionMethods.OCTREE, igReductionOptions);

VB .NET
' Reduce the bit depth of an image to 4 bit
' Create reduction options object and setup a few values for a 16 color 4-bit reduction.
Dim igReductionOptions As New ImGearReductionOptions()
igReductionOptions.Octree.MaxColors = 16
igReductionOptions.Octree.FastRemap = False
igReductionOptions.Octree.ErrorDiffusion = True
'Apply the reduction using Octree to get a 4-bit index image.
ImGearRasterProcessing.Reduce(igRasterPage, New ImGearColorSpace(ImGearColorSpaceIDs.I), New Integer() {4}, _
 ImGearReductionMethods.OCTREE, igReductionOptions)


ImGearReductionOptions Constructors

The ImGearReductionOptions Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearReductionOptions Constructor
Initializes the instance of ImGearReductionOptions Class.


ImGearReductionOptions Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor initializes the instance of ImGearReductionOptions Class.

Declaration:

public ImGearReductionOptions()

Return Value:

The new instance of ImGearReductionOptions Class.

See Also:

ImGearReductionOptions Class


ImGearReductionOptions Fields

The ImGearReductionOptions Class of the ImageGear.Processing Namespace namespace has the following fields:

Fields
Name
Description
Bayer Field
Specifies ImGearBayerReductionOptions Class options for color reduction.
Bitonal Field
Specifies ImGearBitonalReductionOptions Class options for color reduction.
Diffuse Field
Specifies ImGearDiffuseReductionOptions Class options for color reduction.
Halftone Field
Specifies ImGearHalftoneReductionOptions Class options for color reduction.
Median Field
Specifies ImGearMedianCutReductionOptions Class options for color reduction.
Octree Field
Specifies ImGearOctreeReductionOptions Class options for color reduction.
Popularity Field
Specifies ImGearPopularityReductionOptions Class options for color reduction.
Scale Field
Specifies ImGearScaleReductionOptions Class options for color reduction.


Bayer Field

32-bit
64-bit
CF
P
P
P

Description:

This option specifies ImGearBayerReductionOptions Class options for color reduction.

Declaration:

public ImageGear.Processing.ImGearBayerReductionOptions Bayer

Value:

ImGearBayerReductionOptions Class

See Also:

ImGearBayerReductionOptions Class


Bitonal Field

32-bit
64-bit
CF
P
P
P

Description:

This option specifies ImGearBitonalReductionOptions Class options for color reduction.

Declaration:

public ImageGear.Processing.ImGearBitonalReductionOptions Bitonal

Value:

ImGearBitonalReductionOptions Class

See Also:

ImGearBitonalReductionOptions Class


Diffuse Field

32-bit
64-bit
CF
P
P
P

Description:

This option specifies ImGearDiffuseReductionOptions Class options for color reduction.

Declaration:

public ImageGear.Processing.ImGearDiffuseReductionOptions Diffuse

Value:

ImGearDiffuseReductionOptions Class

See Also:

ImGearDiffuseReductionOptions Class


Halftone Field

32-bit
64-bit
CF
P
P
P

Description:

This option specifies ImGearHalftoneReductionOptions Class options for color reduction.

Declaration:

public ImageGear.Processing.ImGearHalftoneReductionOptions Halftone

Value:

ImGearHalftoneReductionOptions Class

See Also:

ImGearHalftoneReductionOptions Class


Median Field

32-bit
64-bit
CF
P
P
P

Description:

This option specifies ImGearMedianCutReductionOptions Class options for color reduction.

Declaration:

public ImageGear.Processing.ImGearMedianCutReductionOptions Median

Value:

ImGearMedianCutReductionOptions Class

See Also:

ImGearMedianCutReductionOptions Class


Octree Field

32-bit
64-bit
CF
P
P
P

Description:

This option specifies ImGearOctreeReductionOptions Class options for color reduction.

Declaration:

public ImageGear.Processing.ImGearOctreeReductionOptions Octree

Value:

ImGearOctreeReductionOptions Class

See Also:

ImGearOctreeReductionOptions Class


Popularity Field

32-bit
64-bit
CF
P
P
P

Description:

This option specifies ImGearPopularityReductionOptions Class options for color reduction.

Declaration:

public ImageGear.Processing.ImGearPopularityReductionOptions Popularity

Value:

ImGearPopularityReductionOptions Class

See Also:

ImGearPopularityReductionOptions Class


Scale Field

32-bit
64-bit
CF
P
P
P

Description:

This option specifies ImGearScaleReductionOptions Class options for color reduction.

Declaration:

public ImageGear.Processing.ImGearScaleReductionOptions Scale

Value:

ImGearScaleReductionOptions Class

See Also:

ImGearScaleReductionOptions Class


ImGearScaleReductionOptions Class

32-bit
64-bit
CF
P
P
P

Description:

This class defines reduction options for scale reduction. Scale reduction can be performed on an image whose color space is anything but indexed. The output image will always have the same color space as the input image. It works by linearly scaling the component values for each pixel to the desired output depths. For example, you could reduce a 24bpp (8-8-8) RGB image to 16bpp (5-6-5) RGB. Simply specify the desired output channel depths (and color space) in the parameters for the Reduce method.

Note that you can set the DontScalePixels option to true to avoid scaling the pixel values. In this case, the component values of each pixel will be preserved (within the limits of precision) even though their effective ranges may be different.

Declaration:

public class ImGearScaleReductionOptions

Members:

Constructors
Name
Description
ImGearScaleReductionOptions Constructor
Initializes the instance of ImGearScaleReductionOptions class.

Fields
Name
Description
DontScalePixels Field
Set to true to avoid scaling the pixel values.


ImGearScaleReductionOptions Constructors

The ImGearScaleReductionOptions Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearScaleReductionOptions Constructor
Initializes the instance of ImGearScaleReductionOptions class.


ImGearScaleReductionOptions Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor initializes the instance of ImGearScaleReductionOptions Class.

Declaration:

public ImGearScaleReductionOptions()

Return Value:

The new instance of ImGearScaleReductionOptions Class.

See Also:

ImGearScaleReductionOptions Class


ImGearScaleReductionOptions Fields

The ImGearScaleReductionOptions Class of the ImageGear.Processing Namespace namespace has the following fields:

Fields
Name
Description
DontScalePixels Field
Set to true to avoid scaling the pixel values.


DontScalePixels Field

32-bit
64-bit
CF
P
P
P

Description:

Set this option to true to avoid scaling the pixel values. In this case, the component values of each pixel will be preserved (within the limits of precision) even though their effective ranges may be different. For example, if you have a 16bpp grayscale image but each pixel value actually only ranges from 0-255, and you want 0 to represent black and 255 to represent white, it makes sense to set this option to true and avoid scaling the values. If scaling were used in such a case, the image would appear black since the brightest possible value (255) would be scaled down to almost nothing: (255/65535) * 255 = 1.

Declaration:

public bool DontScalePixels;

Value:

TRUE (don't scale pixels) or FALSE (scale pixels)

Default:

FALSE


ImGearSpotlight Class

32-bit
64-bit
CF
P
P
P

Description:

This class contains parameters of a spotlight that can be used to highlight an image.

Declaration:

public class ImGearSpotlight

Members:

Constructors
Name
Description
ImGearSpotlight Constructor
Creates and initializes an ImGearSpotlight instance.

Properties
Name
Description
Position Property
Coordinates of the light source.
DirectionAngle Property
Angle that specifies light direction in degrees, clockwise. Angle of 0.0 corresponds to "North" direction in the image plane.
OpeningAngle Property
Angle that specifies the width of the spotlight, measured between the edges of the light cone.
Color Property
Color of the light source.
BrightnessFactor Property
A multiplier allowing to highlight the image more, even if the light source is located far from the image border.
Smooth Property
Smoothing width for the light cone. Value of 0 corresponds to sharp edges, value of 1 corresponds to smoothing of the whole cone.
Fade Property
Value that specifies how soon the light fades, depending on the distance from the spotlight. Value of 0 corresponds to no fading, greater values result in sooner fading. Reasonable values are in range 0...4.
Radius Property
Radius of the spotlight, in pixels.
Description Property
Text description of the spotlight.


ImGearSpotlight Constructors

The ImGearSpotlight Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearSpotlight Constructor
Creates and initializes an ImGearSpotlight instance.


ImGearSpotlight Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an ImGearSpotlight instance and fills it with default values.

Declaration:

public ImGearSpotlight()

Return Value:

The new instance of ImGearSpotlight Class.

See Also:

ImGearSpotlight Class


ImGearSpotlight Properties

The ImGearSpotlight Class of the ImageGear.Processing Namespace namespace has the following fields:

Properties
Name
Description
Position Property
Coordinates of the light source.
DirectionAngle Property
Angle that specifies light direction in degrees, clockwise. Angle of 0.0 corresponds to "North" direction in the image plane.
OpeningAngle Property
Angle that specifies the width of the spotlight, measured between the edges of the light cone.
Color Property
Color of the light source.
BrightnessFactor Property
A multiplier allowing to highlight the image more, even if the light source is located far from the image border.
Smooth Property
Smoothing width for the light cone. Value of 0 corresponds to sharp edges, value of 1 corresponds to smoothing of the whole cone.
Fade Property
Value that specifies how soon the light fades, depending on the distance from the spotlight. Value of 0 corresponds to no fading, greater values result in sooner fading. Reasonable values are in range 0...4.
Radius Property
Radius of the spotlight, in pixels.
Description Property
Text description of the spotlight.


Position Property

32-bit
64-bit
CF
P
P
P

Description:

This property represents the coordinates of the light source.

Declaration:

public IImGearPoint Position {get; set;}

Value:

ImGearPoint Structure


DirectionAngle Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the light direction in degrees, clockwise. Angle of 0.0 corresponds to "North" direction in the image plane.

Declaration:

public double DirectionAngle {get; set;}

Value:

double value.


OpeningAngle Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the width of the spotlight, measured between the edges of the light cone.

Declaration:

public double OpeningAngle {get; set;}

Value:

double value.


Color Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the color of the light source.

Declaration:

public ImGearPixel Color {get; set;}

Value:

ImGearPixel Class


BrightnessFactor Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies a multiplier allowing to highlight the image more, even if the light source is located far from the image border.

Declaration:

public double BrightnessFactor {get; set;}

Value:

double value.


Smooth Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the smoothing width for the light cone. A value of 0 corresponds to sharp edges, value of 1 corresponds to smoothing of the whole cone.

Declaration:

public double Smooth {get; set;}

Value:

double value.


Fade Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies how soon the light fades, depending on the distance from the spotlight. A value of 0 corresponds to no fading, greater values result in earlier fading. Reasonable values are in the range 0...4.

Declaration:

public double Fade {get; set;}

Value:

double value.


Radius Property

32-bit
64-bit
CF
P
P
P

Description:

This property represents the radius of the spotlight, in pixels.

Declaration:

public int Radius {get; set;}

Value:

int value.


Description Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies text description of the spotlight.

Declaration:

public string Description {get; set;}

Value:

string value.


ImGearWhiteBalance Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents white balance as a pair of color temperature and tint.

Declaration:

public class ImGearWhiteBalance

Members:

Constuctors
Name
Description
ImGearWhiteBalance Constructor
Initializes the instance of ImGearWhiteBalance Class.
ImGearWhiteBalance Constructor
Initializes the instance of ImGearWhiteBalance Class.
ImGearWhiteBalance Constructor
Initializes the instance of ImGearWhiteBalance Class.

Methods
Name
Description
Temperature Property
Gets/sets the color temperature.
Tint Property
Gets/sets the tint.

Methods
Name
Description
GetWhiteXY Method
Returns XY coordinates of white point, corresponding to the color temperature.


ImGearWhiteBalance Constructors

The ImGearWhiteBalance Class of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearWhiteBalance Constructor
Initializes the instance of ImGearWhiteBalance Class.
ImGearWhiteBalance Constructor
Initializes the instance of ImGearWhiteBalance Class.
ImGearWhiteBalance Constructor
Initializes the instance of ImGearWhiteBalance Class.


ImGearWhiteBalance Constructor

32-bit
64-bit
CF
P
P
P

Description:

Creates an ImGearWhiteBalance Class instance from Temperature and Tint values.

Setting a greater temperature for an image results in more yellow color; lower temperature results in more blue color. Useful range for Temperature is between 2000 and 10000.

Setting a greater tint value for an image results in a more magenta color, lower tint values result in a greener color. Useful range for Tint is between -50 and 50.

Declaration:

public ImGearWhiteBalance(double Temperature, double Tint)

Parameters:

Name
Type
Description
Temperature
double
Color temperature in Kelvins.
Tint
double
Tint

Return Value:

The new instance of ImGearWhiteBalance Class.

See Also:

ImGearWhiteBalance Class


ImGearWhiteBalance Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an instance of ImGearWhiteBalance Class from XY coordinates of white point.

Declaration:

public ImGearWhiteBalance(ImageGear.Core.ImGearDoublePoint xy)

Parameters:

Name
Type
Description
xy
ImGearDoublePoint Structure
Coordinates of a white point.

Return Value:

The new instance of ImGearWhiteBalance Class.

See Also:

ImGearWhiteBalance Class

ImGearDoublePoint Structure


ImGearWhiteBalance Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an instance of ImGearWhiteBalance Class using preset values, such as Daylight, Tungsten, etc.

Declaration:

public ImGearWhiteBalance(ImageGear.Processing.ImGearWhiteBalancePreset preset)

Parameters:

Name
Type
Description
preset
ImGearWhiteBalancePreset Enumeration
Preset white balance identifier.

Return Value:

The new instance of ImGearWhiteBalance Class.

See Also:

ImGearWhiteBalance Class

ImGearWhiteBalancePreset Enumeration


ImGearWhiteBalance Properties

The ImGearWhiteBalance Class of the ImageGear.Processing Namespace namespace has the following properties:

Properties
Name
Description
Temperature Property
Gets/sets the color temperature.
Tint Property
Gets/sets the tint.


Temperature Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets/sets the color temperature.

Declaration:

public double Temperature [ get, set ]

Value:

Double value.

Default Value:

N/A

See Also:

ImGearWhiteBalance Constructor


Tint Property

32-bit
64-bit
CF
P
P
P

Description:

This property gets/sets the tint.

Declaration:

public double Tint [ get, set ]

Value:

Double value.

Default Value:

N/A

See Also:

ImGearWhiteBalance Constructor


ImGearWhiteBalance Methods

The ImGearWhiteBalance Class of the ImageGear.Processing Namespace namespace has the following methods:

Methods
Name
Description
GetWhiteXY Method
Returns XY coordinates of white point, corresponding to the color temperature.


GetWhiteXY Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns XY coordinates of white point, corresponding to the color temperature.

Declaration:

public ImageGear.Core.ImGearDoublePoint GetWhiteXY()

Return Value:

ImGearDoublePoint Structure.

See Also:

ImGearDoublePoint Structure

ImGearWhiteBalance Constructor


ImageGear.Processing Structures

The ImageGear.Processing Namespace has the following structure members:

Structures:
Name
Description
ImGearChannelRef Structure
Represents a particular image channel as an ImGearPage Class instance and number of channels in its image.
ImGearChannelStatistics Structure
Stores statistics for an image channel.
ImGearPicturizeDistributionSettings Structure
Stores cell image distribution settings for the Picturize effect.
ImGearPicturizeMatchingSettings Structure
Stores the settings that specify how the Picturize Method will match cell images to fragments of the source image.
ImGearPicturizeMixingSettings Structure
Stores the settings that specify how the Picturize Method can modify cell images for the Picturize effect.


ImGearChannelRef Structure

32-bit
64-bit
CF
P
P
P

Description:

Represents a particular image channel as an ImGearPage Class instance and number of channels in its image.

Declaration:

public struct ImGearChannelRef

Members:

Constuctors
Name
Description
ImGearChannelRef Constructor
Initializes the instance of ImGearChannelRef Structure.
ImGearChannelRef Constructor
Initializes the instance of ImGearChannelRef Structure.

Fields
Name
Description
Content Field
Sets the reference to page whose image contains channel data.
Number Field
Sets the number of channel in image represented by incoming page.


ImGearChannelRef Constructors

The ImGearChannelRef Structure of the ImageGear.Processing Namespace namespace has the following constructors:

Constructors
Name
Description
ImGearChannelRef Constructor
Initializes the instance of ImGearChannelRef Structure.
ImGearChannelRef Constructor
Initializes the instance of ImGearChannelRef Structure.


ImGearChannelRef Constructor

32-bit
64-bit
CF
P
P
P

Description:

Initializes a new instance of ImGearChannelRef Structure. Channel number initialized to zero.

Declaration:

public ImGearChannelRef(ImageGear.Core.ImGearRasterPage content)

Parameters:

Name
Description
content
Reference to page whose image contains channel data.

Return Value:

New instance of ImGearChannelRef Structure.

See Also:

ImGearChannelRef Structure

ImGearRasterPage Class


ImGearChannelRef Constructor

32-bit
64-bit
CF
P
P
P

Description:

Intitializes a new instance of ImGearChannelRef Structure.

Declaration:

public ImGearChannelRef(ImageGear.Core.ImGearRasterPage content, int number)

Parameters:

Name
Description
content
Reference to page whose image contains channel data.
number
Number of channel in image represented by incoming page.

Return Value:

New instance of ImGearChannelRef Structure.

See Also:

ImGearChannelRef Structure

ImGearRasterPage Class


ImGearChannelRef Fields

The ImGearChannelRef Structure of the ImageGear.Processing Namespace namespace has the following fields:

Fields
Name
Description
Content Field
Sets the reference to page whose image contains channel data.
Number Field
Sets the number of channel in image represented by incoming page.


Content Field

32-bit
64-bit
CF
P
P
P

Description:

This option sets the reference to page whose image contains the channel data.

Declaration:

public ImageGear.Core.ImGearRasterPage Content

Value:

ImGearRasterPage Class

See Also:

ImGearRasterPage Class

ImGearChannelRef Constructor

ImGearChannelRef Constructor


Number Field

32-bit
64-bit
CF
P
P
P

Description:

This option sets the number of channels in image represented by incoming page.

Declaration:

public int Number

Value:

Integer value.

See Also:

ImGearChannelRef Constructor


ImGearChannelStatistics Structure

32-bit
64-bit
CF
P
P
P

Description:

This structure stores statistics for an image channel.

Declaration:

public struct ImGearChannelStatistics

Members:

Fields
Name
Description
Average Field
Average value of the channel.
Max Field
Max value of the channel.
Min Field
Min value of the channel.


ImGearChannelStatistics Fields

The ImGearChannelStatistics Structure of the ImageGear.Processing Namespace namespace has the following fields:

Fields
Name
Description
Average Field
Average value of the channel.
Max Field
Max value of the channel.
Min Field
Min value of the channel.


Average Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies the average value of the image channel.

Declaration:

public double Average

Value:

Any double value.

Default value:

0.0


Max Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies the maximum value of the image channel.

Declaration:

public int Max

Value:

Integer number.

Default value:

0


Min Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies the minimum value of the image channel.

Declaration:

public int Min

Value:

Integer number.

Default value:

0


ImGearPicturizeDistributionSettings Structure

32-bit
64-bit
CF
P
P
P

Description:

This structure stores cell image distribution settings for the Picturize effect.

Declaration:

public struct ImGearPicturizeDistributionSettings

Members:

Fields
Name
Description
MaxRepeatCount Field
Specifies how many times a specific tile image may be used in the picturized image.


ImGearPicturizeDistributionSettings Fields

The ImGearPicturizeDistributionSettings Structure of the ImageGear.Processing Namespace namespace has the following fields:

Fields
Name
Description
MaxRepeatCount Field
Specifies how many times a specific tile image may be used in the picturized image.


MaxRepeatCount Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies how many times a specific tile image may be used in the picturized image.

If collection of cell images is large enough, so that number of cell images is greater than number of cells in the picturized image, set MaxRepeatCount to 1. If you don't have enough cell images, set MaxRepeatCount to a greater number to allow using the same cell image several times.

Declaration:

public int MaxRepeatCount;

Value:

Any positive integer value.

Default value:

1


ImGearPicturizeMatchingSettings Structure

32-bit
64-bit
CF
P
P
P

Description:

This structure stores the settings that specify how the Picturize Method will match cell images to fragments of the source image.

Declaration:

public struct ImGearPicturizeMatchingSettings

Members:

Fields
Name
Description
CompareSize Field
Specifies the dimension to which cell images will be scaled internally for finding matching locations in the source image.
ColorMatchingFactor Field
Specifies whether the Picturize Method shall pay more attention to matching colors, or to matching brightness.


ImGearPicturizeMatchingSettings Fields

The ImGearPicturizeMatchingSettings Structure of the ImageGear.Processing Namespace namespace has the following fields:

Fields
Name
Description
CompareSize Field
Specifies the dimension to which cell images will be scaled internally for finding matching locations in the source image.
ColorMatchingFactor Field
Specifies whether the Picturize Method shall pay more attention to matching colors, or to matching brightness.


CompareSize Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies the dimension to which cell images will be scaled internally for finding matching locations in the source image.

Smaller values result in faster processing, while larger values result in better matching quality, allowing to match finer details. Useful values are in range 2...10; larger values result in significantly slower processing without significant increase in quality.

Declaration:

public int CompareSize;

Value:

Any positive int value

Default value:

1


ColorMatchingFactor Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies whether the Picturize Method shall pay more attention to matching colors, or to matching brightness. Smaller values result in better matching brightness, while greater values result in better matching colors.

Declaration:

public double ColorMatchingFactor;

Value:

0.0...1.0

Default value:

0.0


ImGearPicturizeMixingSettings Structure

32-bit
64-bit
CF
P
P
P

Description:

This structure stores the settings that specify how the Picturize Method can modify cell images for the Picturize effect.

Declaration:

public struct ImGearPicturizeMixingSettings

Members:

Fields
Name
Description
AllowBrightnessChange Field
Specifies the amount by which cell image brightness can be adjusted to better match the corresponding fragment of the picturized image.
AllowColorChange Field
Specifies the amount by which cell image colors (tint) can be adjusted to better match the corresponding fragment of the picturized image.
AllowPixelsChange Field
Specifies the amount by which individual cell pixels can be adjusted to better match the corresponding fragment of the picturized image.


ImGearPicturizeMixingSettings Fields

The ImGearPicturizeMixingSettings Structure of the ImageGear.Processing Namespace namespace has the following fields:

Fields
Name
Description
AllowBrightnessChange Field
Specifies the amount by which cell image brightness can be adjusted to better match the corresponding fragment of the picturized image.
AllowColorChange Field
Specifies the amount by which cell image colors (tint) can be adjusted to better match the corresponding fragment of the picturized image.
AllowPixelsChange Field
Specifies the amount by which individual cell pixels can be adjusted to better match the corresponding fragment of the picturized image.


AllowBrightnessChange Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies the amount by which cell image brightness can be adjusted to better match the corresponding fragment of the picturized image.

Smaller values preserve colors of the cell images, while greater values make the picturized image more recognizable.

Declaration:

public double AllowBrightnessChange;

Value:

0.0...1.0.

Default value:

0.0


AllowColorChange Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies the amount by which cell image colors (tint) can be adjusted to better match the corresponding fragment of the picturized image.

Smaller values preserve colors of the cell images, while greater values make the picturized image more recognizable.

Declaration:

public double AllowColorChange;

Value:

0.0...1.0.

Default value:

0.0


AllowPixelsChange Field

32-bit
64-bit
CF
P
P
P

Description:

This field specifies the amount by which individual cell pixels can be adjusted to better match the corresponding fragment of the picturized image.

Smaller values preserve details of the cell images, while greater values make the picturized image more recognizable. Usually, setting this parameter to a relatively small value allows to "develop" details of the picturized image, but does not make any visible changes to the cell images.

Declaration:

public double AllowPixelsChange;

Value:

0.0...1.0.

Default value:

0.0


ImageGear.Processing Interfaces

The ImageGear.Processing Namespace has the following interface members:

Interfaces:
Name
Description
IImGearPixelChecker Interface
An implementation of this interface is passed to DetectArea Method.
IImGearPixelProcessor Interface
An implementation of this interface is passed to ProcessArea Method.


IImGearPixelChecker Interface

32-bit
64-bit
CF
P
P
P

Description:

An implementation of this interface is passed to DetectArea Method. The interface declares one CheckPixel Method that must be implemented by the user.

NOTE: ImageGear for .NET provides two predefined implementations of IImGearPixelChecker interface.

Declaration:

public interface IImGearPixelChecker

Members:

Methods
Name
Description
CheckPixel Method
The method must return true if the pixel does not belong to the area (border found) and false otherwise.


IImGearPixelChecker Methods

The IImGearPixelChecker Interface of the ImageGear.Processing Namespace namespace has the following methods:

Methods
Name
Description
CheckPixel Method
The method must return true if the pixel does not belong to the area (border found) and false otherwise.


CheckPixel Method

32-bit
64-bit
CF
P
P
P

Description:

The method must return true if the pixel does not belong to the area (border found) and false otherwise.

Declaration:

bool CheckPixel(ImageGear.Core.ImGearPixel pixel)

Parameters:

Name
Description
pixel
ImGearPixel Class object representing pixel to be tested.

Return Value:

True if the pixel does not belong to the area, false otherwise.

See Also:

ImGearPixel Class


IImGearPixelProcessor Interface

32-bit
64-bit
CF
P
P
P

Description:

An implementation of this interface is passed to ProcessArea Method. The interface declares one method, ProcessPixel Method, that must be implemented by the user.

NOTE: ImageGear for .NET provides one predefined implementation of IImGearPixelProcessor interface.

Declaration:

public interface IImGearPixelProcessor

Members:

Methods
Name
Description
ProcessPixel Method
The method must return the new pixel after processing.


IImGearPixelChecker Methods

The IImGearPixelChecker Interface of the ImageGear.Processing Namespace namespace has the following methods:

Methods
Name
Description
ProcessPixel Method
The method must return the new pixel after processing.


ProcessPixel Method

32-bit
64-bit
CF
P
P
P

Description:

The method must return the new pixel after processing.

Declaration:

ImageGear.Core.ImGearPixel ProcessPixel(ImageGear.Core.ImGearPixel pixel)

Parameters:

Name
Description
pixel
ImGearPixel Class object representing pixel to be processed

Return Value:

ImGearPixel Class.

See Also:

ImGearPixel Class


ImageGear.Processing Enumerations

The ImageGear.Processing Namespace has the following enumeration members:

Enumerations:
Name
Description
ImGearBitonalReductionModes Enumeration
Specifies modes for the bitonal color reduction methods.
ImGearBrushType Enumeration
Specifies types of the brush for the Pointillist effect.
ImGearCFAColor Enumeration
Specifies the available colors for Color Filter Array encoded images.
ImGearChannelGroups Enumeration
Specifies constants for access to different groups of DIB channels.
ImGearContrastModes Enumeration
Specifies contrast processing modes.
ImGearConvolutionResults Enumeration
Specifies types of convolution result.
ImGearDirection Enumeration
Defines a direction of a shadow effect.
ImGearEdgeDetectionMethods Enumeration
Defines the edge detection methods available.
ImGearEdgeMapMethods Enumeration
Specifies types of edge map operation.
ImGearHalftoneReductionModes Enumeration
Specifies mode of halftone color reduction method.
ImGearIlluminant Enumeration
Lists standard illuminants.
ImGearInterpolations Enumeration
Specifies type of interpolation method.
ImGearLensFlareType Enumeration
Specifies types of lens flare.
ImGearMergeModes Enumeration
Identifies the type of arithmetic operation (merge method) that is performed on the values of all intersecting pixels resulting from the merge.
ImGearMosaicType Enumeration
Defines a type of Mosaic effect.
ImGearNightVisionPresets Enumeration
This enumeration represents the preset Night Vision effects supported by ImageGear.
ImGearPixelateCellType Enumeration
Defines cell type for Pixelate operation.
ImGearPixelateFillMethod Enumeration
Defines fill method for Pixelate operation.
ImGearReductionMethods Enumeration
Specifies ImageGear color reduction methods.
ImGearRipplePattern Enumeration
Specifies predefined patterns for the Ripple effect.
ImGearRotationModes Enumeration
Specifies ImageGear rotation mode.
ImGearShearFillStyle Enumeration
Specifies Shear effect fill styles.
ImGearWhiteBalancePreset Enumeration
Lists constants for preset white balance values.


ImGearBitonalReductionModes Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies modes for the bitonal color reduction methods. Please see ImGearBitonalReductionOptions Class class reference.

Declaration:

public enum ImGearBitonalReductionModes

Values:

Name
Value
Description
GRAYSCALE
0
GRAYSCALE mode
AVERAGE
1
AVERAGE mode
WEIGHTED
2
WEIGHTED mode


ImGearBrushType Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies types of the brush for the Pointillist effect.

Declaration:

public enum ImGearBrushType

Values:

Name
Value
Description
Points
0
Each point is a randomly shaped polygon whose shape approximates a paint brush contacting the canvas.
Sticker
1
Each point is a circle.

See Also:

Pointillist Method


ImGearCFAColor Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies the available colors for Color Filter Array encoded images.

Declaration:

public enum ImGearCFAColor

Values:

Name
Value
Description
Red
0
Red color
Green
1
Green color
Blue
2
Blue color
Cyan
3
Cyan color
Magenta
4
Magenta color
Yellow
5
Yellow color
White
6
White color


ImGearChannelGroups Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies constants for access to different groups of DIB channels. These values are passed to the ImGearChannelRange Structure constructor.

Declaration:

public enum ImGearChannelGroups

Values:

Name
Value
Description
COLOR
0
Color channels
ALPHA
1
Alpha channel
EXTRA
2
Extra channels
COLOR_ALPHA
3
Color and alpha channels
ALPHA_EXTRA
4
Alpha and extra channels
ALL
5
All channels


ImGearContrastModes Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies contrast processing modes.

Declaration:

public enum ImGearContrastModes

Values:

Name
Value
Description
PIXEL
1
Contrast on pixels to apply.
PALETTE
0
Contrast on palette to apply. If DIB does not have a palette, an exception is generated.
AUTO
2
If image is Indexed and its palette is not grayscale, apply contrast on palette; otherwise apply contrast on pixels.


ImGearConvolutionResults Enumeration

32-bit
64-bit
CF
P
P
P

Description:

Specifies types of convolution result.

Declaration:

public enum ImGearConvolutionResults

Values:

Name
Value
Description
ABS
1
The absolute value of the signed result is stored.
CENTERED
0
The result is stored as 8-bit signed, but 0 is equal to 0x7F. Positive numbers are from 0x7E to 0x00. Negative numbers are from 0x80 to 0xFF. This is used for images that are to be used as background tiles or watermarks.
RAW
2
The result is stored as is.
SIGNED
The result is stored as 8-bit signed values.


ImGearDirection Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration defines a direction of a shadow effect. Every enumeration value defines the corresponding location of the light source.

Declaration:

public enum ImGearDirection

Values:

Name
Value
Description
North
3
North location
West
0
West location
South
7
South location
East
4
East location
NorthWest
2
NorthWest location
SouthWest
6
SouthWest location
SouthEast
5
SouthEast location
NorthEast
1
NorthEast location


ImGearEdgeDetectionMethods Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration defines the edge detection methods available.

Declaration:

public enum ImGearEdgeDetectionMethods

Values:

Name
Value
Description
MAXGRADIENT
0
Edge detection using the maxima of gradient, i.e., maxima of the first order derivative.
ZEROXC_DERIV2ND
1
Edge detection using the zero-crossings of second order derivative along the gradient.
DIFF_RECURSIVE
2
Edge detection using an optimal difference recursive filter.


ImGearEdgeMapMethods Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies types of edge map operation.

Declaration:

public enum ImGearEdgeMapMethods

Values:

Name
Value
Description
PREWITT
0
Prewitt
ROBERTS
1
Roberts
SOBEL
2
Sobel
LAPLACIAN
3
Laplacian
HORIZONTAL
4
Horizontal
VERTICAL
5
Vertical
DIAG_POS_45
6
Diagonal positive
DIAG_NEG_45
7
Diagonal negative
LOG
8
Laplacian of Gaussian


ImGearHalftoneReductionModes Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies mode of halftone color reduction method. Please see ImGearHalftoneReductionOptions Class class reference.

Declaration:

public enum ImGearHalftoneReductionModes

Values:

Name
Value
Description
SQUARES
0
SQUARES mode


ImGearIlluminant Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists standard illuminants.

Declaration:

public enum ImGearHalftoneReductionModes

Values:

Name
Value
Description
Unknown
0
Unknown illuminant
Daylight
1
Daylight illuminant
Fluorescent
2
Fluorescent illuminant
Tungsten
3
Tungsten illuminant
Flash
4
Flash illuminant
FineWeather
9
FineWeather illuminant
CloudyWeather
10
CloudyWeather illuminant
Shade
11
Shade illuminant
DaylightFluorescent
12
DaylightFluorescent illuminant
DayWhiteFluorescent
13
DayWhiteFluorescent illuminant
CoolWhiteFluorescent
14
CoolWhiteFluorescent illuminant
WhiteFluorescent
15
WhiteFluorescent illuminant
StandardA
17
StandardA illuminant
StandardB
18
StandardB illuminant
StandardC
19
StandardC illuminant
D55
20
D55 illuminant
D65
21
D65 illuminant
D75
22
D75 illuminant
D50
23
D50 illuminant
ISOStudioTungsten
24
ISOStudioTungsten illuminant
Other
255
Other illuminant

See Also:

ImGearCameraRawProcessing Class


ImGearInterpolations Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies type of interpolation method.

Declaration:

public enum ImGearInterpolations

Values:

Name
Value
Description
AVERAGE
1
average
BICUBIC
7
bicubic
BILINEAR
2
bilinear
GRAYSCALE
4
grayscale
NEAREST_NEIGHBOR
3
nearest neighborhood
NONE
0
none
PRESERVE_BLACK
6
preserves black color
PRESERVE_WHITE
5
preserves white color


ImGearLensFlareType Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies types of lens flare.

Declaration:

public enum ImGearLensFlareType

Values:

Name
Value
Description
Zoom50_300
0
50-300mm zoom lens
Digital
1
Digital camera lens
Rainbow
2
Rainbow halo effect
Prime35mm
3
35mm prime lens

See Also:

LensFlare Method


ImGearMergeModes Enumeration

32-bit
64-bit
CF
P
P
P

Description:

Identifies the type of arithmetic operation (merge method) that is performed on the values of all intersecting pixels resulting from the merge.

For example, if you set ARITH_ADD merge method, the resulting pixel values (of those pixels that intersected from the two images) equal the sum of the value of the pixel in the original image and the value of pixel in the image being merged.

Declaration:

public enum ImGearMergeModes

Values:

Name
Value
Description
ADD
0
Img1 = Img1 + Img2
ADD_SIGN_CENTERED
7
Img1 = Img1+ SC_Img2
AND
4
Img1 = Img1 & Img2
DIVIDE
3
Img1 = Img1 / Img2
MULT
2
Img1 = Img1 * Img2
NOT
8
Img1 = ~Img1
OR
5
Img1 = Img1 | Img2
OVER
9
Img1 = Img2
SUB
1
Img1 = Img1 - Img2
XOR
6
Img1 = Img1 ^ Img2


ImGearMonochromeFilmPreset Enumeration

32-bit
64-bit
CF
P
P
P

Description:

Identifies preset parameters for the MonochromeFilm Method. Members of this enumeration represent different types of monochrome film.

Declaration:

public enum ImGearMonochromeFilmPreset

Values:

Name
Value
Description
AgfaPanAPX
0
Imitates AgfaPanAPX film.
KodakTriX
3
Imitates Kodak TriX film.
Linear
4
Mixes colors linearly with equal weights.
IIfordDelta
1
Imitates IIford Delta film.
IIfordFP4
2
Imitates IIford FP4 film.
SilverHalide
5
Imitates non-sensitized silver halide film. Such film was used in early 1900s. It was mostly sensitive to ultraviolet and blue parts of the light spectrum, much less sensitive to green part, and non-sensitive to yellow and red parts of the spectrum.

See Also:

MonochromeFilm Method


ImGearMosaicType Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration defines a type of Mosaic effect.

Declaration:

public enum ImGearMosaicType

Values:

Name
Value
Description
Cartesian
0
Mosaic is drawn in Cartesian coordinate system.
Polar
1
Mosaic is drawn in Polar coordinate system.
Spiderweb
2
Mosaic is drawn in Polar coordinate system, but segments of circles between radial lines are straight.

See also:

ImGearMosaicBorderParams Class

ImGearMosaicCellParams Class

ImGearMosaicFillParams Class

ImGearMosaicShadowParams Class

Mosaic Method


ImGearNightVisionPresets Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration represents the preset Night Vision effects supported by ImageGear.

Declaration:

public enum ImGearNightVisionPresets : System.Enum

Values:

Name
Value
Description
Camera
0
Specifies a general night vision camera effect .
Binoculars
1
Specifies a night vision goggles effect.
Sniper
2
Specifies a night vision weapon sight effect.
SpyPhoto
3
Specifies a spy camera effect.
Television
4
Specifies an old television effect.
Martian
5
Specifies a "martian view" effect.
Moonlight
6
Specifies a "moon view" effect.

See also:

NightVision Method


ImGearPixelateCellType Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration defines cell type for Pixelate operation.

Declaration:

public enum ImGearPixelateCellType

Values:

Name
Value
Description
Rectangle
0
The cell is rounded or non-rounded rectangle.
Circle
1
The cell is a circle.

See also:

ImGearPixelateBorderParams Class

ImGearPixelateCellParams Class

ImGearPixelateFillParams Class

Pixelate Method


ImGearPixelateFillMethod Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration defines fill method for Pixelate operation.

Declaration:

public enum ImGearPixelateFillMethod

Values:

Name
Value
Description
Average
0
The cell is filled with an average color of the cell rectangle.
Minimum
1
The cell is filled with a minimum color of the cell rectangle.
Maximum
2
The cell is filled with a maximum color of the cell rectangle.
Center
3
The cell is filled with a color on the center of the cell rectangle.
Random
4
The cell is filled with a randomly chosen color of the cell rectangle.
Color
5
Every cell is filled with a specified color.

See also:

ImGearPixelateBorderParams Class

ImGearPixelateCellParams Class

ImGearPixelateFillParams Class

Pixelate Method


ImGearReductionMethods Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies ImageGear color reduction methods.

Declaration:

public enum ImGearReductionMethods

Values:

Name
Value
Description
BAYER
0
BAYER color reduction method.
BITONAL
1
BITONAL color reduction method.
DIFFUSE
2
DIFFUSE color reduction method.
HALFTONE
3
HALFTONE color reduction method.
MEDIAN
4
MEDIAN color reduction method.
OCTREE
5
OCTREE color reduction method.
POPULARITY
6
POPULARITY color reduction method.
SCALE
7
SCALE color reduction method.

See Also:

ImGearBitonalReductionOptions Class

ImGearDiffuseReductionOptions Class

ImGearHalftoneReductionOptions Class

ImGearMedianCutReductionOptions Class

ImGearOctreeReductionOptions Class

ImGearPopularityReductionOptions Class

ImGearReductionOptions Class


ImGearRipplePattern Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies predefined patterns for the Ripple effect. Please see Ripple Method and Ripple Effect for reference.

Declaration:

public enum ImGearRipplePattern

Values:

Name
Value
Description
Pattern0
0
Ripple 0: Sea ripple
Pattern1
1
Ripple 1: Crosshatch
Pattern2
2
Ripple 2: Tiles with convex border
Pattern3
3
Ripple 3: Tiles with concave center
Pattern4
4
Ripple 4: Flat tiles with bevel edges
Pattern5
5
Ripple 5: Diagonal flat tiles with bevel edges


ImGearRotationModes Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies ImageGear rotation mode.

Declaration:

public enum ImGearRotationModes

Values:

Name
Value
Description
CLIP
0
Clips the rotated image to keep the image bitmap the same size.
EXPAND
1
Expands the size of the bitmap if necessary to retain the entire rotated image.

See also:

ImGearProcessing Class

Rotate Method

Rotate Method


ImGearShearFillStyle Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies Shear effect fill styles.

Declaration:

public enum ImGearShearFillStyle

Values:

Name
Value
Description
FillColor
1
Empty area is filled with the specified color.
NoChange
0
Empty area remains unchanged.
RepeatEdge
2
Empty area is filled with the first or last raster color.
RepeatRaster
3
The raster is repeated periodically across the empty area.

See also:

Shear Method


ImGearWhiteBalancePreset Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists constants for preset white balance values.

Declaration:

public enum ImGearWhiteBalancePreset

Values:

Name
Value
Description
Daylight
0
Daylight balance
Cloudy
1
Cloudy balance
Shade
2
Shade balance
Tungsten
3
Tungsten balance
Fluorescent
4
Fluorescent balance
Flash
5
Flash balance

See also:

ImGearWhiteBalance Class

ImGearWhiteBalance Constructor


ImageGear.Processing.ImageClean Namespace

ImageGear.Processing.ImageClean Namespace

32-bit
64-bit
CF
P
P
P

Description:

This namespace contains classes to enhance bi-level image support. It includes the ability to check for "noise" of black pixels, clean borders, invert white text, auto-orient image, auto invert black text on the white background, and auto-crop. It now also includes the ability to remove punch holes, and broken, dotted, and solid lines, as well as perform image dilation and erosion.

Declaration:

namespace ImageGear.Processing.ImageClean

Members:

Classes:
Name
Description
ImGearIC Class
Main ImageClean class that contains an API to check for "noise" of black pixels, clean borders, invert white text, auto-orient image, auto invert black text on the white background, and auto-crop. The API also provides the ability to remove punch holes, and broken, dotted, and solid lines, as well as perform image dilation and erosion.
ImGearICBorderOptions Class
Specifies parameters for ImGearIC.CleanBorders method.
ImGearICVerifier Class
Validates applicability of ImageClean methods to ImGearPage object.
ImGearICPunchHoleOptions Class
Specifies parameters for ImGearIC.RemovePunchHoles method.
ImGearICDotLineOptions Class
Specifies parameters for ImGearIC.RemoveDotLines method.
ImGearICLineOptions Class
Specifies parameters for ImGearIC.RemoveLines method.

Enumerations:
Name
Description
ImGearICDocumentType Enumeration
Type of the input document's alignment used for ImGearIC.TextAutoOrientation method.
ImGearICUnits Enumeration
Type of the units of measure used in ImageClean. Used in the following classes: ImGearICPunchHoleOptions, ImGearICDotLineOptions, and ImGearICLineOptions.
ImGearICDirection Enumeration
Type of object orientations used in ImageClean. Used in the following classes: ImGearICDotLineOptions and ImGearICLineOptions.


ImageGear.Processing.ImageClean Classes

The ImageGear.Processing.ImageClean Namespace has the following class members:

Classes:
Name
Description
ImGearIC Class
Main ImageClean class that contains an API to check for "noise" of black pixels, clean borders, invert white text, auto-orient image, auto invert black text on the white background, and auto-crop.
ImGearICBorderOptions Class
Specifies parameters for ImGearIC.CleanBorders method.
ImGearICVerifier Class
Validates applicability of ImageClean methods to ImGearPage object.
ImGearICPunchHoleOptions Class
Specifies parameters for ImGearIC.RemovePunchHoles method.
ImGearICDotLineOptions Class
Specifies parameters for ImGearIC.RemoveDotLines method.
ImGearICLineOptions Class
Specifies parameters for ImGearIC.RemoveLines method.


ImGearIC Class

32-bit
64-bit
CF
P
P
P

Description:

This is the main ImageClean class that contains an API to check for "noise" of black pixels, clean borders, invert white text, auto-orient image, auto invert black text on the white background, and auto-crop. The API also provides the ability to remove punch holes, and broken, dotted, and solid lines, as well as perform image dilation and erosion.

Declaration:

public sealed class ImGearIC

Members:

Properties
Name
Description
Verifier Property
Validates applicability of ImageClean methods to ImGearPage object.

Methods
Name
Description
AutoCrop Method
Takes 1-bit ImGearPage and automatically detects the white border on all four sides and crops it from the page.
CheckForNoise Method
Takes 1-bit ImGearPage and a threshold int value specifying an object size and checks the page for the number of objects exceeding the size of the specified threshold value. Object here means a connected group of black pixels. The object size is a diagonal of the minimum circumscribed rectangle that contains the object.
CleanBorders Method
Detects and removes large black regions that are placed near the borders of the page using the characteristics provided by parameters.
InvertBlackImage Method
Takes 1-bit ImGearPage and a "percent of black pixels" parameter and inverts all the pixel values if the percentage of black pixels is higher than the specified parameter.
InvertWhiteText Method
Takes 1-bit ImGearPage and a set of parameters specifying a minimum width of the region to be considered, a minimum height of the region to be considered, a minimum "thickness" of spaces that fall in between sections of text that will be inverted, and the minimum and maximum sizes of the white letters to be inverted and automatically detects areas of white text on black backgrounds, and inverts them so that they become black text on white backgrounds.
TextAutoOrientation Method
Takes 1-bit ImGearPage and the input document's alignment, which is either standard, left aligned or right aligned, and automatically determines what the proper orientation should be and rotates the page to achieve that proper orientation.
RemovePunchHoles Method
Takes 1-bit ImGearPage and automatically detects and removes any punch holes.
RemoveDotLines Method
Takes 1-bit ImGearPage and automatically detects and removes any dotted lines.
RemoveLines Method
Takes 1-bit ImGearPage and automatically detects and removes horizontal and vertical lines.

See Also:

ImGearICBorderOptions Class

ImGearICVerifier Class

ImGearICPunchHoleOptions Class

ImGearICDotLineOptions Class

ImGearICLineOptions Class


ImGearIC Properties

The ImGearIC Class of the ImageGear.Processing.ImageClean Namespace namespace has the following properties:

Properties
Name
Description
Verifier Property
Validates applicability of ImageClean methods to ImGearPage object.


Verifier Property

32-bit
64-bit
CF
P
P
P

Description:

This property validates applicability of ImageClean methods to ImGearPage object.

Declaration:

public static ImageGear.Processing.ImageClean.ImGearICVerifier Verifier { get }

Value:

ImGearICVerifier Class

Example:

C#
if (ImGearIC.Verifier.CanApplyAutoCrop(imGearPage))
{
ImGearRasterPage page = (ImGearRasterPage)imGearPage;
ImGearIC.AutoCrop(page);
}

Visual Basic
If ImGearIC.Verifier.CanApplyAutoCrop(igPage) Then
    Dim page As ImGearRasterPage
    page = igPage
    ImGearIC.AutoCrop(page)
End If

See Also:

ImGearICVerifier Class


ImGearIC Methods

The ImGearIC Class of the ImageGear.Processing.ImageClean Namespace has the following methods:

Methods
Name
Description
AutoCrop Method
Takes 1-bit ImGearPage and automatically detects the white border on all four sides and crops it from the page.
CheckForNoise Method
Takes 1-bit ImGearPage and a threshold int value specifying an object size and checks the page for the number of objects exceeding the size of the specified threshold value. Object here means a connected group of black pixels. The object size is a diagonal of the minimum circumscribed rectangle that contains the object.
CleanBorders Method
Detects and removes large black regions that are placed near the borders of the page using the characteristics provided by parameters.
InvertBlackImage Method
Takes 1-bit ImGearPage and a "percent of black pixels" parameter and inverts all the pixel values if the percentage of black pixels is higher than the specified parameter.
InvertWhiteText Method
Takes 1-bit ImGearPage and a set of parameters specifying a minimum width of the region to be considered, a minimum height of the region to be considered, a minimum "thickness" of spaces that fall in between sections of text that will be inverted, and the minimum and maximum sizes of the white letters to be inverted and automatically detects areas of white text on black backgrounds, and inverts them so that they become black text on white backgrounds.
TextAutoOrientation Method
Takes 1-bit ImGearPage and the input document's alignment, which is either standard, left aligned or right aligned, and automatically determines what the proper orientation should be and rotates the page to achieve that proper orientation.
RemovePunchHoles Method
Takes a 1-bit image page and the set of advanced parameters specifying the location and diameter of punch holes, and automatically detects and removes the punch holes. It works for most common hole puncher standards including 2, 3, 4, and 5 hole puncher marks.
RemoveDotLines Method
Takes a 1-bit image page and the set of advanced parameters specifying the orientation of lines to detect and number and diameter of dots, and automatically detects and removes the dotted lines on the image.
RemoveLines Method
Takes a 1-bit image page and the set of advanced parameters specifying the orientation of lines to detect and its parameters and automatically detects and removes the horizontal and vertical lines such as frames and tables.


AutoCrop Method

32-bit
64-bit
CF
P
P
P

Description:

This method takes 1-bit ImGearPage and automatically crops any white borders from the page. The method automatically detects the white border on all four sides and crops accordingly. The page is not resized.

Declaration:

public static void AutoCrop ( ImageGear.Core.ImGearPage page )

Parameters:

Name
Type
Description
page
ImGearPage Class
1-bit ImGearPage object to apply auto-crop processing to.

Return Value:

N/A

Example:

C#
// Auto crop the document.
ImGearIC.AutoCrop(igPage);

VB .NET
' Auto crop the document.
ImGearIC.AutoCrop(igPage)

See Also:

ImGearPage Class


CheckForNoise Method

32-bit
64-bit
CF
P
P
P

Description:

This method takes a 1-bit ImGearPage and a threshold int value specifying an object size and checks the page for the number of objects exceeding the size of the specified threshold value. Object here means a connected group of black pixels. The object size is a diagonal of the minimum circumscribed rectangle that contains the object.

This method can be used to detect blank paper sheets in the scanner tray when the resulting image is almost clear and may contains only several black "noise" pixels.

Declaration:

public static int CheckForNoise(ImageGear.Core.ImGearPage page, int nObjectSize)

Parameters:

Name
Type
Description
page
ImGearPage Class
1-bit ImGearPage object to apply check for noise processing to.
nObjectSize
int
Object size threshold value.

Return Value:

int
The result number of objects.

Example:

C#
// Check the page for a pixel object exceeding size 12 to see if it is blank or not.
int objectCount = ImGearIC.CheckForNoise(igPage, 12);

VB .NET
' Check the page for a pixel object exceeding size 12 to see if it is blank or not.
Dim objectCount As Integer = ImGearIC.CheckForNoise(igPage, 12)

See Also:

ImGearPage Class


CleanBorders Method

32-bit
64-bit
CF
P
P
P

Description:

This method detects and removes large black regions that are placed near the borders of the page using the characteristics provided by parameters.

nLeftBorderSize, nRightBorderSize, nTopBorderSize and nBottomBorderSize parameters of ImGearICBorderOptions set maximum size of all borders. It means the pixels that lie outside of the borders will not be deleted. But it doesn't mean that all pixels in the borders will be deleted. nMinLinesNum and nMinLineWidth parameters of ImGearICBorderOptions inform the method which objects in the borders should be deleted - only the black objects that have more than or equal to the number of lines specified with width, not less than specified, will be deleted. As for the left and right borders, objects lines are actually parts of screen lines, but as for top and bottom borders those lines are screen columns.

If ImGearICBorderOptions parameter is null, then the method automatically detects and removes large black regions near the borders of the page. These black borders can result from scanning an image that was reproduced with a copier onto paper that was larger than the image itself.

Declaration:

public static void CleanBorders ( ImageGear.Core.ImGearPage page ,
ImageGear.Processing.ImageClean.ImGearICBorderOptions lpCBOpt )

Parameters:

Name
Type
Description
page
ImGearPage Class
1-bit ImGearPage object to apply clean borders processing to.
lpCBOpt
ImGearICBorderOptions Class
Clean borders parameters.

Return Value:

N/A

Example:

C#
// Sets options for border cleaning and then applies them.
ImGearICBorderOptions igICBorderOptions = new ImGearICBorderOptions();
igICBorderOptions.nBottomBorderSize = 100;
igICBorderOptions.nLeftBorderSize = 100;
igICBorderOptions.nRightBorderSize = 120;
igICBorderOptions.nTopBorderSize = 100;
igICBorderOptions.nMinLinesNum = 10;
igICBorderOptions.nMinLineWidth = 10;
// Clean the borders using the options.
ImGearIC.CleanBorders(igRasterPage, igICBorderOptions);

Visual Basic
' Sets options for border cleaning and then applies them.
Dim igICBorderOptions As New ImGearICBorderOptions()
igICBorderOptions.nBottomBorderSize = 100
igICBorderOptions.nLeftBorderSize = 100
igICBorderOptions.nRightBorderSize = 120
igICBorderOptions.nTopBorderSize = 100
igICBorderOptions.nMinLinesNum = 10
igICBorderOptions.nMinLineWidth = 10
' Clean the borders using the options.
ImGearIC.CleanBorders(igRasterPage, igICBorderOptions)

See Also:

ImGearPage Class

ImGearICBorderOptions Class


InvertBlackImage Method

32-bit
64-bit
CF
P
P
P

Description:

This method takes a 1-bit ImGearPage and a "percent of black pixels" parameter and inverts all the pixel values if the percentage of black pixels is higher than the specified parameter.

Declaration:

public static void InvertBlackImage ( ImageGear.Core.ImGearPage page , int nPercentOfBlack
)

Parameters:

Name
Type
Description
page
ImGearPage Class
1-bit ImGearPage object to apply invert black image processing to.
nPercentOfBlack
int
Minimum necessary percentage of black pixels on the image to trigger auto-inversion.

Return Value:

N/A

Example:

C#
// Invert the image if over 50% of the pixels are black.
ImGearIC.InvertBlackImage(igPage, 50);

Visual Basic
' Invert the image if over 50% of the pixels are black.
ImGearIC.InvertBlackImage(igPage, 50)

See Also:

ImGearPage Class


InvertWhiteText Method

32-bit
64-bit
CF
P
P
P

Description:

This method takes a 1-bit ImGearPage and a set of parameters specifying a minimum width of the region to be considered, a minimum height of the region to be considered, a minimum "thickness" of spaces that fall in between sections of text that will be inverted, and the minimum and maximum sizes of the white letters to be inverted, and automatically detects areas of white text on black backgrounds, and inverts them so that they become black text on white backgrounds. The letter size means the maximum value of width and height of the letter cell that is the minimum rectangle that completely covers the letter and the argument that sets a size of the maximum border around the letter that will be inverted along with the letter cell.

This method scans your entire image and makes adjustments to all areas of white text on black that fall within the scope of your settings.

Declaration:

public static void InvertWhiteText ( ImageGear.Core.ImGearPage page , int MinX , int MinY ,
int MinT , int MinLetterSize , int MaxLetterSize , int MaxBorder )

Parameters:

Name
Type
Description
page
ImGearPage Class
1-bit ImGearPage object to apply invert black image processing to.
MinX
int
Specifies the minimum width for areas that you would like to invert.
MinY
int
Specifies the minimum height for areas that you would like to invert. For example, if you set MinX = 60 and MinY = 20, ImageGear will only invert sections of white text on black background that have a minimum width of 60 pixels and a minimum height of 20 pixels.
MinT
int
Specifies the minimum "thickness" of spaces that fall between sections of text that will be inverted. This minimum value indicates those sections of text to be treated as one section based on how close they are to one another.
As an example, let's say you have three adjacent sections of white text on black backgrounds that contain the words, "There," "is," and "hope." If "There" and "hope" meet your minimum size requirements they will be inverted. If "is" is below your minimum size requirements, and you have not set MinT, "is" will note be inverted, resulting in "There" and "hope" looking normal, while "is" remains white text on black background. To prevent this (if desired), you would need to set MinT to a value small enough to include the spaces before and after the word "is." This way, all the words would be treated as one section and inverted together.
MinLetterSize
int
Specifies the minimum size of the white letters to be inverted.
MaxLetterSize
int
Specifies the maximum size of the white letters to be inverted.
MaxBorder
int
Specifies the size of the maximum border around the letter that will be inverted along with the letter cell. For example, if width and height of the letter cell are 20 and 30 respectively and MaxBorder = 10, then the width and the height of the rectangle that will be inverted are 40 (10+20+10) and 50 (10+30+10) respectively. Please be careful when setting this parameter. If it is very large, it is possible that incorrect image areas will be inverted.

Return Value:

N/A

Example:

C#
// Invert sections of white text on black background in the image using
// a minimum height of 10, width of 30, thickness of 10,
// minimum letter size of 10, maximum letter size of 100, and a maximum
// border of 5.
ImGearIC.InvertWhiteText(igPage, 40, 100, 10, 10, 100, 5);

Visual Basic
' Invert sections of white text on black background in the image using
' a minimum height of 10, width of 30, thickness of 10,
' minimum letter size of 10, maximum letter size of 100, and a maximum
' border of 5.
ImGearIC.InvertWhiteText(igPage, 40, 100, 10, 10, 100, 5)

See Also:

ImGearPage Class


TextAutoOrientation Method

32-bit
64-bit
CF
P
P
P

Description:

This method takes a 1-bit ImGearPage and the input document's alignment, which is either standard, left aligned or right aligned, automatically determines what the proper orientation should be, and rotates the page to achieve that proper orientation.

Declaration:

public static void TextAutoOrientation ( ImageGear.Core.ImGearPage page ,
ImageGear.Processing.ImageClean.ImGearICDocumentType nDocType )

Parameters:

Name
Type
Description
page
ImGearPage Class
1-bit ImGearPage object to apply invert black image processing to.
nDocType
ImGearICDocumentType Enumeration
Specifies type of the input document's alignment.

Return Value:

N/A

Example:

C#
// Auto Orientate an image of a left-aligned document.
ImGearIC.TextAutoOrientation(igPage, ImGearICDocumentType.LEFT_ALIGNED);

Visual Basic
' Auto Orientate an image of a left-aligned document.
ImGearIC.TextAutoOrientation(igPage, ImGearICDocumentType.LEFT_ALIGNED)

See Also:

ImGearICDocumentType Enumeration

ImGearPage Class


RemovePunchHoles Method

32-bit
64-bit
CF
P
P
P

Description:

This method automatically detects and removes the punch holes on the 1-bit scanned image. It works for most common hole puncher standards including 2, 3, 4 and 5 hole puncher marks. The method takes a 1-bit image page and the set of advanced parameters specifying the location and diameter of punch holes.

Declaration:

public static void RemovePunchHoles(ImageGear.Core.ImGearPage page,
ImageGear.Processing.ImageClean.ImGearICPunchHoleOptions options)

Parameters:

Name
Type
Description
page
ImGearPage Class
1-bit ImGearPage object to apply apply punch holes removal to.
options
ImGearICPunchHoleOptions Class
Method options.

Return Value:

N/A

See Also:

ImGearPage Class

ImGearICPunchHoleOptions Class


RemoveDotLines Method

32-bit
64-bit
CF
P
P
P

Description:

This method automatically detects and removes the dotted lines on the 1-bit scanned image. The method takes a 1-bit image page and the set of advanced parameters specifying the orientation of lines to detect and number and diameter of dots.

Declaration:

public static void RemoveDotLines(ImageGear.Core.ImGearPage page,
ImageGear.Processing.ImageClean.ImGearICDotLineOptions options)

Parameters:

Name
Type
Description
page
ImGearPage Class
1-bit ImGearPage object to apply dotted line removal to.
options
ImGearICDotLineOptions Class
Method options.

Return Value:

N/A

See Also:

ImGearPage Class

ImGearICDotLineOptions Class


RemoveLines Method

32-bit
64-bit
CF
P
P
P

Description:

This method automatically detects and removes the horizontal and vertical lines on the 1-bit scanned image such as frames and tables. The method takes a 1-bit image page and the set of advanced parameters specifying the orientation of lines to detect and its parameters.

Declaration:

public static void RemoveLines(ImageGear.Core.ImGearPage page,
ImageGear.Processing.ImageClean.ImGearICLineOptions options)

Parameters:

Name
Type
Description
page
ImGearPage Class
1-bit ImGearPage object to apply line removal to.
options
ImGearICLineOptions Class
Method options.

Return Value:

N/A

See Also:

ImGearPage Class

ImGearICLineOptions Class


ImGearICBorderOptions Class

32-bit
64-bit
CF
P
P
P

Description:

This class specifies parameters for CleanBorders Method.

Declaration:

public sealed class ImGearICBorderOptions

Members:

Constructors
Name
Description
ImGearICBorderOptions Constructor
Creates and initializes an instance of ImGearICBorderOptions class.

Properties
Name
Description
nBottomBorderSize Property
Specifies max size of the bottom border.
nLeftBorderSize Property
Specifies max size of the left border.
nMinLinesNum Property
Specifies min number of lines with width not less than nMinLineWidth in one border block.
nMinLineWidth Property
Specifies min width of lines in one border block. Those blocks that have not less than nMinLinesNum number of lines with nMinLineWidth width or wider will be removed from image.
nRightBorderSize Property
Specifies max size of the right border.
nTopBorderSize Property
Specifies max size of the top border.

Sample Code:

C#
// Sets options for border cleaning and then applies them.
ImGearICBorderOptions igICBorderOptions = new ImGearICBorderOptions();
igICBorderOptions.nBottomBorderSize = 100;
igICBorderOptions.nLeftBorderSize = 100;
igICBorderOptions.nRightBorderSize = 120;
igICBorderOptions.nTopBorderSize = 100;
igICBorderOptions.nMinLinesNum = 10;
igICBorderOptions.nMinLineWidth = 10;
// Clean the borders using the options.
ImGearIC.CleanBorders(igRasterPage, igICBorderOptions);

VB .NET
' Sets options for border cleaning and then applies them.
Dim igICBorderOptions As New ImGearICBorderOptions()
igICBorderOptions.nBottomBorderSize = 100
igICBorderOptions.nLeftBorderSize = 100
igICBorderOptions.nRightBorderSize = 120
igICBorderOptions.nTopBorderSize = 100
igICBorderOptions.nMinLinesNum = 10
igICBorderOptions.nMinLineWidth = 10
' Clean the borders using the options.
ImGearIC.CleanBorders(igRasterPage, igICBorderOptions)

See Also:

CleanBorders Method


ImGearICBorderOptions Constructors

The ImGearICBorderOptions Class of the ImageGear.Processing.ImageClean Namespace has the following constructors:

Constructors
Name
Description
ImGearICBorderOptions Constructor
Creates and initializes an instance of ImGearICBorderOptions class.


ImGearICBorderOptions Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearICBorderOptions Class class.

Declaration:

public ImGearICBorderOptions ( int nLeftBorderSize , int nRightBorderSize , int
nTopBorderSize , int nBottomBorderSize , int nMinLinesNum , int nMinLineWidth )

Parameters:

Name
Type
Description
nLeftBorderSize
int
Max size of the left border.
nRightBorderSize
int
Max size of the right border.
nTopBorderSize
int
Max size of the top border.
nBottomBorderSize
int
Max size of bottom border.
nMinLinesNum
int
Min number of lines with width not less than nMinLineWidth in one border block.
nMinLineWidth
int
Min width of lines in one border block. Those blocks that have not less than nMinLinesNum number of lines with nMinLineWidth width or wider will be removed from image.

Return Value:

N/A

Example:

C#
ImGearRasterPage page = (ImGearRasterPage)imGearPage;
ImGearICBorderOptions borderOptions = new ImGearICBorderOptions(100, 100, 100, 100, 10, 10);
ImGearIC.CleanBorders(page, borderOptions);

Visual Basic
Dim page As ImGearRasterPage
page = igPage
Dim borderOptions As ImGearICBorderOptions
borderOptions = New ImGearICBorderOptions(100, 100, 100, 100, 10, 10)
ImGearIC.CleanBorders(page, borderOptions)

See Also:

CleanBorders Method


ImGearICBorderOptions Properties

The ImGearICBorderOptions Class of the ImageGear.Processing.ImageClean Namespace namespace has the following properties:

Properties
Name
Description
nBottomBorderSize Property
Specifies max size of the bottom border.
nLeftBorderSize Property
Specifies max size of the left border.
nMinLinesNum Property
Specifies min number of lines with width not less than nMinLineWidth in one border block.
nMinLineWidth Property
Specifies min width of lines in one border block. Those blocks that have not less than nMinLinesNum number of lines with nMinLineWidth width or wider will be removed from image.
nRightBorderSize Property
Specifies max size of the right border.
nTopBorderSize Property
Specifies max size of the top border.


nBottomBorderSize Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies max size of the bottom border.

Declaration:

public int nBottomBorderSize { get; set}

Value:

Any integer value.

See Also:

ImGearICBorderOptions Constructor


nLeftBorderSize Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies max size of the left border.

Declaration:

public int nLeftBorderSize { get; set}

Value:

Any integer value.

See Also:

ImGearICBorderOptions Constructor


nMinLinesNum Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies min number of lines with width not less than nMinLineWidth in one border block.

Declaration:

public int nMinLinesNum { get; set}

Value:

Any integer value.

See Also:

ImGearICBorderOptions Constructor


nMinLineWidth Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies min width of lines in one border block. Those blocks that have not less than nMinLinesNum number of lines with nMinLineWidth width or wider will be removed from image.

Declaration:

public int nMinLineWidth { get; set}

Value:

Any integer value.

See Also:

ImGearICBorderOptions Constructor


nRightBorderSize Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies max size of the right border.

Declaration:

public int nRightBorderSize { get; set}

Value:

Any integer value.

See Also:

ImGearICBorderOptions Constructor


nTopBorderSize Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies max size of the top border.

Declaration:

public int nTopBorderSize { get; set}

Value:

Any integer value.

See Also:

ImGearICBorderOptions Constructor


ImGearICVerifier Class

32-bit
64-bit
CF
P
P
P

Description:

This class validates applicability of ImageClean methods to ImGearPage object.

Declaration:

public sealed class ImGearICVerifier

Members:

Methods
Name
Description
CanApplyAutoCrop Method
Checks if ImGearIC.AutoCrop method can be applied to ImGearPage.
CanApplyAutoOrient Method
Checks if ImGearIC.AutoOrient method can be applied to ImGearPage.
CanApplyCheckForNoise Method
Checks if ImGearIC.CheckForNoise method can be applied to ImGearPage.
CanApplyCleanBorders Method
Checks if ImGearIC.CleanBorders method can be applied to ImGearPage.
CanApplyInvertBlackImage Method
Checks if ImGearIC.InvertBlackImagemethod can be applied to ImGearPage.
CanApplyInvertWhiteText Method
Checks if ImGearIC.InvertWhiteTextmethod can be applied to ImGearPage.
CanApplyRemovePunchHoles Method
Checks if ImGearIC.RemovePunchHoles method can be applied to ImGearPage.
CanApplyRemoveDotLines Method
Checks if ImGearIC.RemoveDotLines method can be applied to ImGearPage.
CanApplyRemoveLines Method
Checks if ImGearIC.RemoveLines method can be applied to ImGearPage.

See Also:

ImGearIC Class

ImGearICBorderOptions Class


ImGearICVerifier Methods

The ImGearICVerifier Class of the ImageGear.Processing.ImageClean Namespace has the following methods:

Methods
Name
Description
CanApplyAutoCrop Method
Checks if ImGearIC.AutoCrop method can be applied to ImGearPage.
CanApplyAutoOrient Method
Checks if ImGearIC.AutoOrient method can be applied to ImGearPage.
CanApplyCheckForNoise Method
Checks if ImGearIC.CheckForNoise method can be applied to ImGearPage.
CanApplyCleanBorders Method
Checks if ImGearIC.CleanBorders method can be applied to ImGearPage.
CanApplyInvertBlackImage Method
Checks if ImGearIC.InvertBlackImagemethod can be applied to ImGearPage.
CanApplyInvertWhiteText Method
Checks if ImGearIC.InvertWhiteTextmethod can be applied to ImGearPage.
CanApplyRemovePunchHoles Method
Checks if ImGearIC.RemovePunchHoles method can be applied to ImGearPage.
CanApplyRemoveDotLines Method
Checks if ImGearIC.RemoveDotLines method can be applied to ImGearPage.
CanApplyRemoveLines Method
Checks if ImGearIC.RemoveLines method can be applied to ImGearPage.


CanApplyAutoCrop Method

32-bit
64-bit
CF
P
P
P

Description:

This method checks if ImGearIC.AutoCrop Method can be applied to ImGearPage.

Declaration:

public bool CanApplyAutoCrop ( ImageGear.Core.ImGearPage page )

Parameters:

Name
Type
Description
page
ImGearPage Class
ImGearPage object to verify.

Return Value:

True
ImGearIC.AutoCrop Method can be applied to the specified page.
False
ImGearIC.AutoCrop Method cannot be applied to the specified page.

Example:

C#
if (ImGearIC.Verifier.CanApplyAutoCrop(imGearPage))
{
    // The IC method can be applied to imGearPage.
    // Apply it here.
}

Visual Basic
If ImGearIC.Verifier.CanApplyAutoCrop(igPage) Then
    ' The IC method can be applied to imGearPage.
    ' Apply it here.
End If

See Also:

ImGearPage Class


CanApplyAutoOrient Method

32-bit
64-bit
CF
P
P
P

Description:

This method checks if ImGearIC.TextAutoOrientation Method can be applied to ImGearPage.

Declaration:

public bool CanApplyAutoOrient ( ImageGear.Core.ImGearPage page )

Parameters:

Name
Type
Description
page
ImGearPage Class
ImGearPage object to verify.

Return Value:

True
ImGearIC.TextAutoOrientation Method can be applied to the specified page.
False
ImGearIC.TextAutoOrientation Method cannot be applied to the specified page.

Example:

C#
if (ImGearIC.Verifier.CanApplyAutoOrient(imGearPage))
{
    // The IC method can be applied to imGearPage.
    // Apply it here.
}

Visual Basic
If ImGearIC.Verifier.CanApplyAutoOrient(igPage) Then
    ' The IC method can be applied to imGearPage.
    ' Apply it here.
End If

See Also:

ImGearPage Class


CanApplyCheckForNoise Method

32-bit
64-bit
CF
P
P
P

Description:

This method checks if ImGearIC.CheckForNoise Method method can be applied to ImGearPage.

Declaration:

public bool CanApplyCheckForNoise ( ImageGear.Core.ImGearPage page )

Parameters:

Name
Type
Description
page
ImGearPage Class
ImGearPage object to verify.

Return Value:

True
ImGearIC.CheckForNoise Method can be applied to the specified page.
False
ImGearIC.CheckForNoise Method cannot be applied to the specified page.

Example:

C#
if (ImGearIC.Verifier.CanApplyCheckForNoise(imGearPage))
{
    // The IC method can be applied to imGearPage.
    // Apply it here.
}

Visual Basic
If ImGearIC.Verifier.CanApplyCheckForNoise(igPage) Then
    ' The IC method can be applied to imGearPage.
    ' Apply it here.
End If

See Also:

ImGearPage Class


CanApplyCleanBorders Method

32-bit
64-bit
CF
P
P
P

Description:

This method checks if ImGearIC.CleanBorders Method can be applied to ImGearPage.

Declaration:

public bool CanApplyCleanBorders ( ImageGear.Core.ImGearPage page )

Parameters:

Name
Type
Description
page
ImGearPage Class
ImGearPage object to verify.

Return Value:

True
ImGearIC.CleanBorders Method can be applied to the specified page.
False
ImGearIC.CleanBorders Method cannot be applied to the specified page.

Example:

C#
if (ImGearIC.Verifier.CanApplyCleanBorders(imGearPage))
{
    // The IC method can be applied to imGearPage.
    // Apply it here.
}

Visual Basic
If ImGearIC.Verifier.CanApplyCleanBorders(igPage) Then
    ' The IC method can be applied to imGearPage.
    ' Apply it here.
End If

See Also:

ImGearPage Class


CanApplyInvertBlackImage Method

32-bit
64-bit
CF
P
P
P

Description:

This method checks if ImGearIC.InvertBlackImage Method can be applied to ImGearPage.

Declaration:

public bool CanApplyInvertBlackImage ( ImageGear.Core.ImGearPage page )

Parameters:

Name
Type
Description
page
ImGearPage Class
ImGearPage object to verify.

Return Value:

True
ImGearIC.InvertBlackImage Method can be applied to the specified page.
False
ImGearIC.InvertBlackImage Method cannot be applied to the specified page.

Example:

C#
if (ImGearIC.Verifier.CanApplyInvertBlackImage(imGearPage))
{
    // The IC method can be applied to imGearPage.
    // Apply it here.
}

Visual Basic
If ImGearIC.Verifier.CanApplyInvertBlackImage(igPage) Then
    ' The IC method can be applied to imGearPage.
    ' Apply it here.
End If

See Also:

ImGearPage Class


CanApplyInvertWhiteText Method

32-bit
64-bit
CF
P
P
P

Description:

This method checks if ImGearIC.InvertWhiteText Method method can be applied to ImGearPage.

Declaration:

public bool CanApplyInvertWhiteText ( ImageGear.Core.ImGearPage page )

Parameters:

Name
Type
Description
page
ImGearPage Class
ImGearPage object to verify.

Return Value:

True
ImGearIC.InvertWhiteText Method can be applied to the specified page.
False
ImGearIC.InvertWhiteText Method cannot be applied to the specified page.

Example:

C#
if (ImGearIC.Verifier.CanApplyInvertWhiteText(imGearPage))
{
    // The IC method can be applied to imGearPage.
    // Apply it here.
}

Visual Basic
If ImGearIC.Verifier.CanApplyInvertWhiteText(igPage) Then
    ' The IC method can be applied to imGearPage.
    ' Apply it here.
End If

See Also:

ImGearPage Class


CanApplyRemovePunchHoles Method

32-bit
64-bit
CF
P
P
P

Description:

This method checks if the ImGearIC.RemovePunchHoles method can be applied to ImGearPage Class.

Declaration:

public bool CanApplyRemovePunchHoles( ImageGear.Core.ImGearPage page )

Parameters:

Name
Type
Description
page
ImGearPage Class
ImGearPage object to verify.

Return Value:

True
ImGearIC.RemovePunchHoles Method can be applied to the specified page.
False
ImGearIC.RemovePunchHoles Method cannot be applied to the specified page.

Example:

C#
if (ImGearIC.Verifier.CanApplyRemovePunchHoles(imGearPage))
{
    // The IC method can be applied to imGearPage.
    // Apply it here.
}

Visual Basic
If ImGearIC.Verifier.CanApplyRemovePunchHoles(igPage) Then
    ' The IC method can be applied to imGearPage.
    ' Apply it here.
End If

See Also:

ImGearPage Class


CanApplyRemoveDotLines Method

32-bit
64-bit
CF
P
P
P

Description:

This method checks if the ImGearIC.RemoveDotLines method can be applied to ImGearPage Class.

Declaration:

public bool CanApplyRemoveDotLines( ImageGear.Core.ImGearPage page )

Parameters:

Name
Type
Description
page
ImGearPage Class
ImGearPage object to verify.

Return Value:

True
ImGearIC.RemoveDotLines Method can be applied to the specified page.
False
ImGearIC.RemoveDotLines Method cannot be applied to the specified page.

Example:

C#
if (ImGearIC.Verifier.CanApplyRemoveDotLines(imGearPage))
{
    // The IC method can be applied to imGearPage.
    // Apply it here.
}

Visual Basic
If ImGearIC.Verifier.CanApplyRemoveDotLines(igPage) Then
    ' The IC method can be applied to imGearPage.
    ' Apply it here.
End If

See Also:

ImGearPage Class


CanApplyRemoveLines Method

32-bit
64-bit
CF
P
P
P

Description:

This method checks if the ImGearIC.RemoveLinesLines method can be applied to ImGearPage Class.

Declaration:

public bool CanApplyRemoveLines( ImageGear.Core.ImGearPage page )

Parameters:

Name
Type
Description
page
ImGearPage Class
ImGearPage object to verify.

Return Value:

True
ImGearIC.RemoveLines Method can be applied to the specified page.
False
ImGearIC.RemoveLines Method cannot be applied to the specified page.

Example:

C#
if (ImGearIC.Verifier.CanApplyRemoveLines(imGearPage))
{
    // The IC method can be applied to imGearPage.
    // Apply it here.
}

Visual Basic
If ImGearIC.Verifier.CanApplyRemoveLines(igPage) Then
    ' The IC method can be applied to imGearPage.
    ' Apply it here.
End If

See Also:

ImGearPage Class


ImGearICPunchHoleOptions Class

32-bit
64-bit
CF
P
P
P

Description:

This class specifies parameters for ImGearIC.RemovePunchHoles Method.

Declaration:

public sealed class ImGearICPunchHoleOptions

Members:

Constructors
Name
Description
ImGearICPunchHoleOptions Constructor
Creates and initializes an instance of ImGearICPunchHoleOptions class.

Properties
Name
Description
Accuracy Property
Accuracy of the punch hole's detection, measured in percent (%).
MaxAspect Property
Maximum width/height ratio of object dimensions.
MaxDiameter Property
Maximum object size to remove; size considered as diameter respective circle.
MinAspect Property
Minimum width/height ratio of object dimensions.
MinDiameter Property
Minimum object size to remove; size considered as diameter respective circle.
Unit Property
Hole's size unit of measure.

See Also:

ImGearIC.RemovePunchHoles Method

ImGearIC Class


ImGearICPunchHoleOptions Constructors

The ImGearICPunchHoleOptions Class of the ImageGear.Processing.ImageClean Namespace has the following constructors:

Constructors
Name
Description
ImGearICPunchHoleOptions Constructor
Creates and initializes an instance of the ImGearICPunchHoleOptions Class.


ImGearICPunchHoleOptions Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearICPunchHoleOptions Class.

Declaration:

public ImGearICPunchHoleOptions ()

See Also:

ImGearICPunchHoleOptions Class

ImGearIC.RemovePunchHoles Method


ImGearICPunchHoleOptions Properties

The ImGearICPunchHoleOptions Class of the ImageGear.Processing.ImageClean Namespace has the following properties:

Properties
Name
Description
Accuracy Property
Accuracy of the punch hole's detection, measured in percent (%).
MaxAspect Property
Maximum width/height ratio of object dimensions.
MaxDiameter Property
Maximum object size to remove; size considered as diameter respective circle.
MinAspect Property
Minimum width/height ratio of object dimensions.
MinDiameter Property
Minimum object size to remove; size considered as diameter respective circle.
Unit Property
Hole's size unit of measure.


Accuracy Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the accuracy of the punch hole's detection, measured in percent (%). Default value is 80%.

Declaration:

public int Accuracy

Value:

int

See Also:

ImGearICPunchHoleOptions Class

ImGearIC.RemovePunchHoles Method


MaxAspect Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the maximum width/height ratio of object dimensions. Can be used to detect non-round holes. Default value is 1.05.

Declaration:

public double MaxAspect

Value:

double

See Also:

ImGearICPunchHoleOptions Class

ImGearIC.RemovePunchHoles Method


MaxDiameter Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the maximum object size to remove; size considered as diameter respective circle. The Unit of measure is set by the Unit Property. Default value is 8 mm.

Declaration:

public double MaxDiameter

Value:

double

See Also:

ImGearICPunchHoleOptions Class

ImGearIC.RemovePunchHoles Method


MinAspect Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the minimum width/height ratio of object dimensions. Can be used to detect non-round holes. Default value is 0.95.

Declaration:

public double MinAspect

Value:

double

See Also:

ImGearICPunchHoleOptions Class

ImGearIC.RemovePunchHoles Method


MinDiameter Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the minimum object size to remove; size considered as diameter respective circle. The unit of measure is set by the Unit Property. Default value is 4 mm.

Declaration:

public double MinDiameter

Value:

double

See Also:

ImGearICPunchHoleOptions Class

ImGearIC.RemovePunchHoles Method


Unit Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the hole's size unit of measure. Default value is mm.

Declaration:

public ImageGear.Processing.ImageClean.ImGearICUnits Unit

Value:

ImGearICUnits Enumeration

See Also:

ImGearICPunchHoleOptions Class

ImGearIC.RemovePunchHoles Method


ImGearICDotLineOptions Class

32-bit
64-bit
CF
P
P
P

Description:

This class specifies parameters for the ImGearIC.RemoveDotLines method.

Declaration:

public sealed class ImGearICDotLineOptions

Members:

Constructors
Name
Description
ImGearICDotLineOptions Constructor
Creates and initializes an instance of ImGearICDotLineOptions class.

Properties
Name
Description
MaxDiameter Property
Maximum size of dot in line, size considered as diameter of respective circle.
MinDiameter Property
Minimum size of dot in a line, size considered as diameter of respective circle.
MinNumber Property
Minimum number of dots in a line.
Direction Property
Direction of lines to detect.
Unit Property
Dot's size unit of measure.

See Also:

ImGearIC.RemoveDotLines Method

ImGearIC Class


ImGearICDotLineOptions Constructors

The ImGearICDotLineOptions Class of the ImageGear.Processing.ImageClean Namespace has the following constructors:

Constructors
Name
Description
ImGearICDotLineOptions Constructor
Creates and initializes an instance of ImGearICDotLineOptions Class.


ImGearICDotLineOptions Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearICDotLineOptions Class.

Declaration:

public ImGearICDotLineOptions ()

See Also:

ImGearIC.RemoveDotLines Method

ImGearICDotLineOptions Class


ImGearICDotLineOptions Properties

The ImGearICDotLineOptions Class of the ImageGear.Processing.ImageClean Namespace has the following properties:

Properties
Name
Description
MaxDiameter Property
Maximum size of dot in line, size considered as diameter of respective circle.
MinDiameter Property
Minimum size of dot in a line, size considered as diameter of respective circle.
MinNumber Property
Minimum number of dots in a line.
Direction Property
Direction of lines to detect.
Unit Property
Dot's size unit of measure.


MaxDiameter Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the maximum size of dot in line. Size is considered as diameter of respective circle. Unit of measure is set by the Unit Property. Default value is 3 mm.

Declaration:

public double MaxDiameter

Value:

double

See Also:

ImGearICDotLineOptions Class

ImGearIC.RemoveDotLines Method


MinDiameter Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the minimum size of dot in line. Size is considered as diameter of respective circle. Unit of measure is set by the Unit Property. Default value is 1 mm.

Declaration:

public double MinDiameter

Value:

double

See Also:

ImGearICDotLineOptions Class

ImGearIC.RemoveDotLines Method


MinNumber Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the minimum numbers of dots in a line. Default value is 4.

Declaration:

public int MinNumber

Value:

int

See Also:

ImGearICDotLineOptions Class

ImGearIC.RemoveDotLines Method


Direction Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the direction of line to be detected. The default value is ImGearICDirection.HORIZONTAL.

Declaration:

public ImGearICDirection Direction

Value:

ImGearICDirection Enumeration

See Also:

ImGearICDotLineOptions Class

ImGearIC.RemoveDotLines Method

ImGearICDirection Enumeration


Unit Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the dot's size unit of measure. Default value is mm.

Declaration:

public ImageGear.Processing.ImageClean.ImGearICUnits Unit

Value:

ImGearICUnits Enumeration

See Also:

ImGearICDotLineOptions Class

ImGearIC.RemoveDotLines Method

ImGearICUnits Enumeration


ImGearICLineOptions Class

32-bit
64-bit
CF
P
P
P

Description:

This class specifies parameters for the ImGearIC.RemoveLines method.

Declaration:

public sealed class ImGearICLineOptions

Members:

Constructors
Name
Description
ImGearICLineOptions Constructor
Creates and initializes an instance of ImGearICLineOptions class.

Properties
Name
Description
MaxBreak Property
Maximum distance between segments of a broken line.
MinLength Property
Minimum length of line segment.
MaxWidth Property
Maximum width of line segment.
Direction Property
Direction of lines to detect.
Unit Property
Line's size unit of measure.

See Also:

ImGearICLineOptions Class

ImGearIC.RemoveLines Method

ImGearIC Class


ImGearICLineOptions Constructors

The ImGearICLineOptions Class of the ImageGear.Processing.ImageClean Namespace has the following constructors:

Constructors
Name
Description
ImGearICLineOptions Constructor
Creates and initializes an instance of ImGearICLineOptions class.


ImGearICLineOptions Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearICLineOptions Class.

Declaration:

public ImGearICLineOptions ()

See Also:

ImGearIC.RemoveLines Method

ImGearICLineOptions Class


ImGearICLineOptions Properties

The ImGearICLineOptions Class of the ImageGear.Processing.ImageClean Namespace has the following properties:

Properties
Name
Description
MaxBreak Property
Maximum distance between segments of a broken line.
MinLength Property
Minimum length of line segment.
MaxWidth Property
Maximum width of line segment.
Direction Property
Direction of lines to detect.
Unit Property
Line's size unit of measure.


MaxBreak Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the maximum distance between segments of a broken line. The unit of measure is set by the Unit Property. Default value is 1 mm.

Declaration:

public double MaxBreak

Value:

double

See Also:

ImGearIC.RemoveLines Method

ImGearICLineOptions Class


MinLength Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the minimum length of a line segment. All lines that do not exceed this value are ignored. The unit of measure is set by the Unit Property. Default value is 10 mm.

Declaration:

public double MinLength

Value:

double

See Also:

ImGearIC.RemoveLines Method

ImGearICLineOptions Class


MaxWidth Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the maximum width of a line segment. All lines that exceed this value are ignored. The unit of measure is set by the Unit Property. Default value is 1 mm.

Declaration:

public double MaxWidth

Value:

double

See Also:

ImGearIC.RemoveLines Method

ImGearICLineOptions Class


Direction Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the direction of line to be detected. The default value is ImGearICDirection.HORIZONTAL.

Declaration:

public ImGearICDirection Direction

Value:

ImGearICDirection Enumeration

See Also:

ImGearIC.RemoveLines Method

ImGearICLineOptions Class

ImGearICDirection Enumeration


Unit Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the line's size unit of measure. Default value is mm.

Declaration:

public ImageGear.Processing.ImageClean.ImGearICUnits Unit

Value:

ImGearICUnits Enumeration

See Also:

ImGearIC.RemoveLines Method

ImGearICLineOptions Class

ImGearICUnits Enumeration


ImageGear.Processing.ImageClean Enumerations

This section provides information about ImageGear.Processing.ImageClean Namespace enumerations. Currently there are the following enumerations:

Name
Description
ImGearICDocumentType Enumeration
Specifies types of the input document's alignment used for ImGearIC.TextAutoOrientation Method.
ImGearICUnits Enumeration
Specifies the types of the input document's units of measure. Used in the following classes: ImGearICPunchHoleOptions Class, ImGearICDotLineOptions Class, and ImGearICLineOptions Class.
ImGearICDirection Enumeration
Specifies the types of the input document's object orientations. Used in the following classes: ImGearICDotLineOptions Class and ImGearICLineOptions Class.


ImGearICDocumentType Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies types of the input document's alignment used for ImGearIC.TextAutoOrientation Method.

Declaration:

public enum ImGearICDocumentType

Values:

Name
Value
Description
LEFT_ALIGNED
2
Left aligned document.
RIGHT_ALIGNED
3
Right aligned document.
STANDARD
1
Document alignment is unknown.

See Also:

TextAutoOrientation Method


ImGearICUnits Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies types of the input document's units of measure used in ImageClean.

Declaration:

public enum ImGearICUnits

Values:

Name
Description
INCH
Units set in inches.
MM
Units set in millimeters
PIXEL
Units set in pixels.

See Also:

ImGearICPunchHoleOptions Class

ImGearICDotLineOptions Class

ImGearICLineOptions Class


ImGearICDirection Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies the types of object orientations used in the ImageClean API.

Declaration:

public enum ImGearICDirection

Values:

Name
Description
HORIZONTAL
Specifies horizontal direction.
VERTICAL
Specifies vertical direction.

See Also:

ImGearICDotLineOptions Class

ImGearICLineOptions Class


ImageGear.Processing.Layers Namespace

ImageGear.Processing.Layers Namespace

32-bit
64-bit
CF
P
P
P

Description:

ImageGear.Processing.Layers namespace provides an API for creating and editing image layers. This namespace also introduces a new type of ImGearLayeredPage Class, which consists of two parts: raster composition image and array of layers.

ImageGear currently supports image layer types only.

To enable the Layers namespace in your project, specify the following directive:

using ImageGear.Processing.Layers;

Declaration:

namespace ImageGear.Processing.Layers

Members:

Classes:
Name
Description
ImGearLayer Class
Represents general attributes of the layer.
ImGearImageLayer Class
Represents the image layer and its attributes.
ImGearLayerArray Class
Defines composition of layers.
ImGearLayeredPage Class
Page with layers.

Enumerations:
Name
Description
ImGearLayerType Enumeration
Supported layer types.


ImageGear.Processing.Layers Classes

The ImageGear.Processing.Layers Namespace has the following class members:

Classes:
Name
Description
ImGearLayer Class
Generic layer.
ImGearImageLayer Class
Image layer.
ImGearLayerArray Class
Array of layers.
ImGearLayeredPage Class
Page with layers.


ImGearLayer Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents general attributes of the layer. ImageGear can currently read and write PSD layers. Users can manipulate generic layer attributes using the following API.

Declaration:

public class ImGearLayer

Members:

Properties:
Name
Description
Name Property
Specifies name of the layer.
Type Property
Specifies type of the layer.
Visible Property
Specifies visibility state of the layer.

Methods:
Name
Description
Clone Method
Clones the layer.


ImGearLayer Class Properties

The ImGearLayer Class of the ImageGear.Processing.Layers Namespace has the following properties:

Properties:
Name
Description
Name Property
Specifies name of the layer.
Type Property
Specifies type of the layer.
Visible Property
Specifies visibility state of the layer.


Name Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the name of the layer.

Declaration:

public string Name { set; get; }

Value:

string.


Type Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the type of the layer. It is read-only.

Declaration:

public ImageGear.Processing.Layers.ImGearLayerType Type { get; }

Value:

ImGearLayerType Enumeration


Visible Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the visibility state of the layer.

Declaration:

public bool Visible { set; get; }

Value:

Boolean.


ImGearLayer Class Methods

The ImGearLayer Class of the ImageGear.Processing.Layers Namespace has the following methods:

Methods:
Name
Description
Clone Method
Clones the layer.


Clone Method

32-bit
64-bit
CF
P
P
P

Description:

This method clones the layer.

Declaration:

public ImageGear.Processing.Layers.ImGearLayer Clone()

Return value:

Returns the layer's clone.

See Also:

ImGearLayer Class


ImGearImageLayer Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents the image layer and its attributes. Any PSD image can consist of multiple layers. Currently ImageGear can only read, write, and edit image layers, that is, layers represented by a raster image. Users can manipulate image layer attributes using the following API.

Declaration:

public class ImGearImageLayer : ImageGear.Processing.Layers.ImGearLayer

Members:

Constructors:
Name
Description
ImGearImageLayer Constructor
Creates a new image layer from the specified raster page.

Properties:
Name
Description
Image Property
Image specifying the layer.
Opacity Property
Level of opacity for the image layer.
Location Property
Rectangle specifying the location of the image layer.


ImGearImageLayer Constructors

The ImGearImageLayer Class of the ImageGear.Processing.Layers Namespace has the following constructors:

Constructors:
Name
Description
ImGearImageLayer
Creates a new image layer from the specified raster page.


ImGearImageLayer Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates a new image layer from the specified raster page.

Declaration:

public ImGearImageLayer(ImageGear.Core.ImGearPage page)

Parameters:

Name
Type
Description
page
ImGearPage Class
Raster page to create layer from.

See Also:

ImGearPage Class


ImGearImageLayer Properties

The ImGearImageLayer Class of the ImageGear.Processing.Layers Namespace has the following properties:

Properties:
Name
Description
Image Property
Image specying the layer.
Opacity Property
Level of opacity for the image layer.
Location Property
Rectangle specifying the location of the image layer.


Image Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the image to put in the layer. It is read-only.

Declaration:

public ImageGear.Core.ImGearPage Image { get; }

Value:

ImGearPage Class


Opacity Property

32-bit
64-bit
CF
P
P
P

Description:

Level of opacity for the image layer.

Declaration:

public int Opacity { set; get; }

Value:

int.


Location Property

32-bit
64-bit
CF
P
P
P

Description:

Rectangle specifying the location of the image layer.

Declaration:

public ImageGear.Core.ImGearPoint Location { set; get; }

Value:

ImGearPoint Structure


ImGearLayerArray Class

32-bit
64-bit
CF
P
P
P

Description:

This class defines the composition of layers. The composition of layers from a PSD image is stored in the array of layers associated with the ImGearLayeredPage. Users can manipulate the composition by creating new layers, and editing and deleting the existing ones using the following API.

Declaration:

public class ImGearLayerArray

Members:

Constructors:
Name
Description
ImGearLayerArray Constructor
Creates an empty layer array.

Properties:
Name
Description
Count Property
Number of layers in the array.
IsFixedSize Property
Specifies a value indicating if the ArrayList has a fixed size.
IsReadOnly Property
Specifies a value indicating if the ArrayList is read-only.
IsSynchronized Property
Specifies a value indicating if access to the ArrayList is synchronized.
SyncRoot Property
Specifies an object that can be used to synchronize an access to the ArrayList.
this Property
Specifies a reference to the indexed element of array.

Methods:
Name
Description
Add Method
Adds a new layer to the array.
Clear Method
Removes all of the layers from the array.
Clone Method
Clones the array of layers.
Contains Method
Checks if the array contains the specified layer.
CopyTo Method
Copies the current array of layers into the specified array at specified position.
GetEnumerator Method
Gets the IEnumerator interface.
IndexOf Method
Gets the index of the specified layer.
Insert Method
Insets the specified layer at the spefied position in the array.
Remove Method
Removes the specified layer from the array.
RemoveAt Method
Removes layer with the specified index from the array.


ImGearLayerArray Constructors

The ImGearLayerArray Class of the ImageGear.Processing.Layers Namespace has the following constructors:

Constructors:
Name
Description
ImGearLayerArray Constructor
Creates an empty layer array.


ImGearLayerArray Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an empty layer array.

Declaration:

public ImGearLayerArray()


ImGearLayerArray Properties

The ImGearLayerArray Class of the ImageGear.Processing.Layers Namespace has the following properties:

Properties:
Name
Description
Count Property
Number of layers in the array.
IsFixedSize Property
Specifies a value indicating if the ArrayList has a fixed size.
IsReadOnly Property
Specifies a value indicating if the ArrayList is read-only.
IsSynchronized Property
Specifies a value indicating if access to the ArrayList is synchronized.
SyncRoot Property
Specifies an object that can be used to synchronize an access to the ArrayList.
this Property
Specifies a reference to the indexed element of array.


Count Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the number of layers in the array. It is read-only.

Declaration:

public int Count { get; }

Value

int.


IsFixedSize Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies a value indicating whether the ArrayList has a fixed size. It is read-only.

Declaration:

public bool IsFixedSize { get; }

Value

Boolean.


IsReadOnly Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies a value indicating whether the ArrayList is read-only. It is read-only.

Declaration:

public bool IsReadOnly { get; }

Value

Boolean.


IsSynchronized Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies a value indicating whether access to the ArrayList is synchronized. It is read-only.

Declaration:

public bool IsSynchronized { get; }

Value

Boolean.


SyncRoot Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies an object that can be used to synchronize access to the ArrayList. It is read-only.

Declaration:

public object SyncRoot { get; }

Value

object.


this Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies a reference to the indexed element of the array.

Declaration:

public ImageGear.Processing.Layers.ImGearLayer this[int index] { set; get; }

Parameters:

Name
Type
Description
index
int
The indexed element.

Value:

ImGearLayer Class


ImGearLayerArray Methods

The ImGearLayerArray Class of the ImageGear.Processing.Layers Namespace has the following methods:

Methods:
Name
Description
Add Method
Adds a new layer to the array.
Clear Method
Removes all of the layers from the array.
Clone Method
Clones the array of layers.
Contains Method
Checks if the array contains the specified layer.
CopyTo Method
Copies the current array of layers into the specified array at specified position.
GetEnumerator Method
Gets the IEnumerator interface.
IndexOf Method
Gets the index of the specified layer.
Insert Method
Insets the specified layer at the spefied position in the array.
Remove Method
Removes the specified layer from the array.
RemoveAt Method
Removes layer with the specified index from the array.


Add Method

32-bit
64-bit
CF
P
P
P

Description:

This method adds a new layer to the array.

Declaration:

public virtual int Add(ImageGear.Processing.Layers.ImGearLayer layer)

Parameters:

Name
Type
Description
layer
ImGearLayer Class
New layer to add.

Return value:

int.

See Also:

ImGearLayer Class


Clear Method

32-bit
64-bit
CF
P
P
P

Description:

This method removes all of the layers from the array.

Declaration:

public virtual void Clear()

Return value:

None


Clone Method

32-bit
64-bit
CF
P
P
P

Description:

This method clones the array of layers.

Declaration:

public ImageGear.Processing.Layers.ImGearLayerArray Clone()

Return value:

ImGearLayerArray Class


Contains Method

32-bit
64-bit
CF
P
P
P

Description:

This method checks whether the array contains the specified layer.

Declaration:

public bool Contains(ImageGear.Processing.Layers.ImGearLayer value)

Parameters:

Name
Type
Description
value
ImGearLayer Class
Layer to check.

Return value:

Boolean.

See Also:

ImGearLayer Class


CopyTo Method

32-bit
64-bit
CF
P
P
P

Description:

This method copies the current array of layers into the specified array at the specified position.

Declaration:

public void CopyTo(System.Array array, int index)

Parameters:

Name
Type
Description
array
System.Array
Destination array.
index
int
Position in the destination array to copy to.

Return value:

None.


GetEnumerator Method

32-bit
64-bit
CF
P
P
P

Description:

This method gets the IEnumerator interface.

Declaration:

public System.Collections.IEnumerator GetEnumerator()

Return value:

System.Collections.IEnumerator


IndexOf Method

32-bit
64-bit
CF
P
P
P

Description:

This method gets the index of the specified layer.

Declaration:

public int IndexOf(ImageGear.Processing.Layers.ImGearLayer value)

Parameters:

Name
Type
Description
value
ImGearLayer Class
Layer to get index of.

Return value:

int.

See Also:

ImGearLayer Class


Insert Method

32-bit
64-bit
CF
P
P
P

Description:

This method inserts the specified layer at the specified position in the array.

Declaration:

public virtual void Insert(int index, ImageGear.Processing.Layers.ImGearLayer layer)

Parameters:

Name
Type
Description
index
int
Position in the current array to insert layer to.
layer
ImGearLayer Class
Layer to insert.

Return value:

None.

See Also:

ImGearLayer Class


Remove Method

32-bit
64-bit
CF
P
P
P

Description:

This method removes the specified layer from the array.

Declaration:

public void Remove(ImageGear.Processing.Layers.ImGearLayer value)

Parameters:

Name
Type
Description
value
ImGearLayer Class
Layer to remove from the array.

Return value:

None.


RemoveAt Method

32-bit
64-bit
CF
P
P
P

Description:

This method removes the layer with the specified index from the array.

Declaration:

public virtual void RemoveAt(int index)

Parameters:

Name
Type
Description
index
int
Layer index to remove from the array.

Return value:

None.

See Also:

ImGearLayer Class


ImGearLayeredPage Class

32-bit
64-bit
CF
P
P
P

Description:

This class defines a layered page object, which is a page with image layers.

Declaration:

public class ImGearLayeredPage : ImageGear.Core.ImGearRasterPage

Members:

Constructors:
Name
Description
ImGearLayeredPage Constructor
Creates a blank layered page from the specified attributes.
ImGearLayeredPage Constructor
Creates a blank layered page from the specified layers.
ImGearLayeredPage Constructor
Creates a layered page from the specified ImGearPage, by copying its DIB and Metadata, and creating an empty array of layers.

Properties:
Name
Description
Layers Property
Specifies the array of layers from the layered page.

Methods:
Name
Description
Clone Method
Clones the layered page object.
Flatten Method
This method renders all the visible layers into the raster composition DIB.


ImGearImageLayeredPage Constructors

The ImGearLayeredPage Class of the ImageGear.Processing.Layers Namespace has the following constructors:

Constructors:
Name
Description
ImGearLayeredPage Constructor
Creates a blank layered page from the specified attributes.
ImGearLayeredPage Constructor
Creates a blank layered page from the specified layers.
ImGearLayeredPage Constructor
Creates a layered page from the specified ImGearPage, by copying its DIB and Metadata, and creating an empty array of layers.


ImGearLayeredPage Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates a blank layered page from the specified attributes.

Declaration:

public ImGearLayeredPage(int width, int height, ImageGear.Core.ImGearColorSpace
colorSpace, int[] channelDepths, bool allocatePixels)

Parameters:

Name
Type
Description
width
int
Width of the page.
height
int
Height of the page.
colorSpace
ImGearColorSpace Structure
Color space of the page.
channelDepths
int[ ]
Channel depths of the page.
allocatePixels
Boolean
If true, allocate DIB pixels; false otherwise

See Also:

ImGearColorSpace Structure


ImGearLayeredPage Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates a blank layered page from the specified layers.

Declaration:

public ImGearLayeredPage(ImageGear.Processing.Layers.ImGearLayerArray Layers)

Parameters:

Name
Type
Description
layers
ImGearLayerArray Class
Array of layers.

See Also:

ImGearLayerArray Class


ImGearLayeredPage Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates a layered page from the specified ImGearPage Class, by copying its DIB and Metadata, and creating an empty array of layers.

Declaration:

public ImGearLayeredPage(ImGearPage page)

Parameters:

Name
Type
Description
page
ImGearPage Class
Page to copy DIB and Metadata from.


ImGearImageLayeredPage Properties

The ImGearLayeredPage Class of the ImageGear.Processing.Layers Namespace has the following properties:

Properties:
Name
Description
Layers Property
Specifies the array of layers from the layered page.


Layers Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the array of layers from the layered page. It is read-only.

Declaration:

public ImageGear.Processing.Layers.ImGearLayerArray Layers { get; }

Value

ImGearLayerArray Class

See Also:

ImGearLayerArray Class


ImGearImageLayeredPage Methods

The ImGearLayeredPage Class of the ImageGear.Processing.Layers Namespace has the following methods:

Methods:
Name
Description
Clone Method
Clones the layered page object.
Flatten Method
This method renders all the visible layers into the raster composition DIB.


Clone Method

32-bit
64-bit
CF
P
P
P

Description:

This method clones the layered page object.

Declaration:

public override ImageGear.Core.ImGearPage Clone()

Return value:

ImGearPage Class


Flatten Method

32-bit
64-bit
CF
P
P
P

Description:

This method renders all the visible layers into the raster composition DIB.

This method can be used to flatten the layered page into the raster page. As a result of this method, the base ImGearRasterPage Class object is regenerated and can be used to access the result of the flattening operation.

Declaration:

public void Flatten()

Return value:

None.

See Also:

ImGearRasterPage Class


ImageGear.Processing.Layers Enumerations

The ImageGear.Processing.Layers Namespace has the following enumerations:

Properties:
Name
Description
ImGearLayerType Enumeration
Lists the supported layer types.


ImGearLayerType Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration lists the supported layer types.

Declaration:

public enum ImGearLayerType

Values:

Name
Description
Image
Image layer type.
Unknown
Unknown (unrecognized by ImageGear) layer type.


ImageGear.TWAIN Namespace

ImageGear.TWAIN Namespace

32-bit
64-bit
CF
P

Description:

The ImageGear TWAIN namespace allows you to control any scanner, digital camera or capture card that has a TWAIN device driver.

Using ImageGear TWAIN namespace, your application can:

  • Create a custom interface to scan images, or use the default user interface included with the TWAIN driver.
  • Create a custom interface to select a TWAIN source, or use the default selection dialog provided by TWAIN source manager.
  • Get or set all TWAIN v1.9 capabilities that the device's TWAIN driver supports.
  • Use the Automated Document Feeder for scanning images.
  • Use native, buffered memory or file transfer modes when acquiring from a TWAIN device.
  • Capture multiple images using automatic capture.
  • Browse a device's file system and retrieve images from it.

With the ImageGear TWAIN support, you can do anything that your TWAIN v1.9 driver supports. If your TWAIN driver is not v1.9 or does not support the functionality listed above, then ImageGear will support all of the features that the driver has that are compatible with the TWAIN v1.9 specification.

To enable ImageGear.TWAIN namespace in your project specify the following directive:

  • For VB .NET:
   Imports ImageGear.TWAIN
  • For C#:
  using ImageGear.TWAIN;

This chapter uses the following terminology when discussing ImageGear scanning functionality:

  • Data Source - a shortened reference to the device driver of an Image Acquisition Device and will be used frequently.
  • Data Source Manager - the TWAIN manager for the device drivers.
  • Image Acquisition Device - all devices that acquire images using the TWAIN protocol, including scanners.
  • Scanner - sometimes used as an alternative for "Data Source" when the discussion is specific to scanners but is not relevant to all Image Acquisition Devices, or "Data Sources".
  • Scanning - refers in a general sense to all methods of TWAIN image acquisition.

Declaration:

namespace ImageGear.TWAIN

Members:

Classes:
Name
Description
ImGearCap Class
This is a base class for the TWAIN capability classes.
ImGearCapArray Class
This class describes a capability whose value resides in ImGearContainerType.ARRAY container.
ImGearCapEnumeration Class
This class describes a capability whose value resides in ImGearContainerType.ENUMERATION container.
ImGearCapOneValue Class
This class describes a capability whose value resides in ImGearContainerType.ONEVALUE container.
ImGearCapRange Class
This class describes a capability whose value resides in ImGearContainerType.RANGE container.
ImGearDataSources Class
This class holds information about TWAIN data sources.
ImGearFileInfo Class
This class holds information about TWAIN file system.
ImGearTWAIN Class
Core TWAIN class.
ImGearTWAINAfterPageEventArgs Class
Contains arguments for the AfterPage Event event.
ImGearTWAINBeforePageEventArgs Class
Contains arguments for the BeforePage Event event.

Delegates:
Name
Description
ImGearTWAINAfterPageEventHandler Delegate
This is the delegate used to pass AfterPage events on to an application event handler.
ImGearTWAINBeforePageEventHandler Delegate
This is the delegate used to pass BeforePage events on to an application event handler.

Enumerations:
Name
Description
ImGearAlarms Enumeration
ImGearCapabilities.CAP_ALARMS capability values.
ImGearAudioFormats Enumeration
ImGearCapabilities.ACAP_AUDIOFILEFORMAT capability values.
ImGearBarcodeRotation Enumeration
The bar code's orientation on the scanned image.
ImGearBarcodeSearchModes Enumeration
ImGearCapabilities.ICAP_BARCODESEARCHMODE capability values.
ImGearBarcodeType Enumeration
ImGearCapabilities.ICAP_SUPPORTEDBARCODETYPES capability values.
ImGearBitDepthReduction Enumeration
ImGearCapabilities.ICAP_BITDEPTHREDUCTION capability values.
ImGearBitOrder Enumeration
ImGearCapabilities.BITORDER capability values.
ImGearCapabilities Enumeration
Supported capabilities.
ImGearClearBuffers Enumeration
ImGearCapabilities.CAP_CLEARBUFFERS capability values.
ImGearColorDataFormats Enumeration
ImGearCapabilities.ICAP_PLANARCHUNKY capability values.
ImGearContainerType Enumeration
Capability container type.
ImGearCountries Enumeration
Country constants.
ImGearDeskewStatus Enumeration
Status of the deskew operation.
ImGearDeviceEvents Enumeration
ImGearCapabilities.CAP_DEVICEEVENT capability values.
ImGearDuplex Enumeration
ImGearCapabilities.CAP_DUPLEX capability values.
ImGearFeederAlignment Enumeration
ImGearCapabilities.CAP_FEEDERALIGNMENT capability values.
ImGearFeederOrder Enumeration
ImGearCapabilities.CAP_FEEDERORDER capability values.
ImGearFileSystem Enumeration
ImGearCapabilities.CAP_FILESYSTEM capability values.
ImGearFileType Enumeration
File types.
ImGearFilterType Enumeration
ImGearCapabilities.ICAP_FILTER capability values.
ImGearFlashUsed Enumeration
ImGearCapabilities.ICAP_FLASHUSED2 capability values.
ImGearFlipRotation Enumeration
ImGearCapabilities.ICAP_FLIPROTATION capability values.
ImGearJobControl Enumeration
ImGearCapabilities.CAP_JOBCONTROL capability values.
ImGearJPEGQuality Enumeration
ImGearCapabilities.ICAP_JPEGQUALITY capability values.
ImGearImageFilter Enumeration
ImGearCapabilities.ICAP_IMAGEFILTER capability values.
ImGearLanguages Enumeration
Language constants.
ImGearLightPath Enumeration
ImGearCapabilities.ICAP_LIGHTPATH capability values.
ImGearLightSource Enumeration
ImGearCapabilities.ICAP_LIGHTSOURCE capability values.
ImGearMessages Enumeration
Capability control messages.
ImGearNoiseFilter Enumeration
ImGearCapabilities.ICAP_NOISEFILTER capability values.
ImGearOrientation Enumeration
ImGearCapabilities.ICAP_ORIENTATION capability values.
ImGearOverscanModes Enumeration
ImGearCapabilities.ICAP_OVERSCAN capability values.
ImGearPatchCode Enumeration
Patch codes.
ImGearPixelFlavor Enumeration
ImGearCapabilities.ICAP_PIXELFLAVOR capability values.
ImGearPixelType Enumeration
ImGearCapabilities.ICAP_PIXELTYPE capability values.
ImGearPowerSupply Enumeration
ImGearCapabilities.CAP_POWERSUPPLY capability values.
ImGearPrinter Enumeration
ImGearCapabilities.CAP_PRINTER capability values.
ImGearPrinterModes Enumeration
ImGearCapabilities.CAP_PRINTERMODE capability values.
ImGearSupportedSizes Enumeration
ImGearCapabilities.ICAP_SUPPORTEDSIZES capability values.
ImGearUnits Enumeration
ImGearCapabilities.ICAP_UNITS capability values.
ImGearXferType Enumeration
ImGearCapabilities.ICAP_XFERMECH capability values.


ImageGear.TWAIN Namespace Classes

The ImageGear.TWAIN Namespace has the following class members:

Classes:
Name
Description
ImGearCap Class
This is a base class for the TWAIN capability classes.
ImGearCapArray Class
This class describes a capability which value resides in ImGearContainerType.ARRAY container.
ImGearCapEnumeration Class
This class describes a capability which value resides in ImGearContainerType.ENUMERATION container.
ImGearCapOneValue Class
This class describes a capability which value resides in ImGearContainerType.ONEVALUE container.
ImGearCapRange Class
This class describes a capability which value resides in ImGearContainerType.RANGE container.
ImGearDataSources Class
This class holds information about TWAIN data sources.
ImGearFileInfo Class
This class holds information about TWAIN file system.
ImGearTWAIN Class
Core TWAIN class.
ImGearTWAINAfterPageEventArgs Class
Contains arguments for the AfterPage Event event.
ImGearTWAINBeforePageEventArgs Class
Contains arguments for the BeforePage Event event.


ImGearCap Class

32-bit
64-bit
CF
P

Description:

This is a base class for the TWAIN capability classes.

Declaration:

public class ImGearCap

Members:

Constructors
Name
Description
ImGearCap Constructor
Creates the new instance of ImGearCap class.

Properties
Name
Description
ContainerType Property
This property gets the container type of the capability.
ID Property
This property gets the identifier of the capability.


ImGearCap Constructors

The ImGearCap Class of the ImageGear.TWAIN Namespace has the following constructors:

Constructors
Name
Description
ImGearCap Constructor
Creates the new instance of ImGearCap Class.


ImGearCap Constructor

32-bit
64-bit
CF
P

Description:

This constructor creates a new instance of ImGearCap Class. ImGearCap implements the IDisposable interface.

Declaration:

public class ImGearCap : IDisposable

Return Value:

The new instance of ImGearCap Class.

See Also:

ImGearCap Class


ImGearCap Properties

The ImGearCap Class of the ImageGear.TWAIN Namespace has the following properties:

Properties
Name
Description
ContainerType Property
This property gets the container type of the capability.
ID Property
This property gets the identifier of the capability.


ContainerType Property

32-bit
64-bit
CF
P

Description:

This property gets the container type of the capability.

Declaration:

public ImageGear.TWAIN.ImGearContainerType ContainerType { get; }

Value:

One of the ImGearContainerType Enumeration values.


ID Property

32-bit
64-bit
CF
P

Description:

This property gets the identifier of the capability.

Declaration:

public ImageGear.TWAIN.ImGearCapabilities ID { get; set }

Value:

One of the ImGearCapabilities Enumeration values.


ImGearCapArray Class

32-bit
64-bit
CF
P

Description:

This class describes a capability whose value resides in ImGearContainerType.ARRAY container.

This class inherits ImGearCap Class class.

Declaration:

public class ImGearCapArray : ImageGear.TWAIN.ImGearCap

Members:

Constructors
Name
Description
ImGearCapArray Constructor
Creates the new instance of ImGearCapArray Class.

Properties
Name
Description
Count Property
This property returns the number of elements in the array.
this Property
This property gets or sets an element in the array at the specified index.

Methods
Name
Description
Add Method
This method adds an object to the end of the array.
Clear Method
This method removes all elements from the array.

See Also:

ImGearCap Class


ImGearCapArray Constructors

The ImGearCapArray Class of the ImageGear.TWAIN Namespace has the following constructors:

Constructors
Name
Description
ImGearCapArray Constructor
Creates the new instance of ImGearCapArray Class.


ImGearCapArray Constructor

32-bit
64-bit
CF
P

Description:

This constructor creates the new instance of ImGearCapArray Class.

Declaration:

public ImGearCapArray(ImageGear.TWAIN.ImGearCapabilities CapID)

Parameters:

Name
Type
Description
CapID
ImGearCapabilities Enumeration
ImageGear TWAIN capability.

Return Value:

The new instance of ImGearCapArray Class.

See Also:

ImGearCapArray Class

ImGearCapabilities Enumeration


ImGearCapArray Properties

The ImGearCapArray Class of the ImageGear.TWAIN Namespace has the following properties:

Properties
Name
Description
Count Property
This property returns the number of elements in the array.
this Property
This property gets or sets an element in the array at the specified index.


Count Property

32-bit
64-bit
CF
P

Description

This property returns the number of elements in the array.

Declaration

public int Count { get }

Value

Integer value.


this Property

32-bit
64-bit
CF
P

Description

This property gets or sets an element in the array at the specified index.

Declaration

public const object this { get; set }

Value

One of the following types:

System.Boolean

System.Double

System.Int64

System.String

ImageGear.Core.ImGearDoubleRectangle Structure


ImGearCapArray Methods

The ImGearCapArray Class of the ImageGear.TWAIN Namespace has the following methods:

Methods
Name
Description
Add Method
This method adds an object to the end of the array.
Clear Method
This method removes all elements from the array.


Add Method

32-bit
64-bit
CF
P

Description:

This method adds an object to the end of the array.

The Value parameter can be of the following types:

  • System.Boolean
  • System.Double
  • System.Int64
  • System.String
  • ImageGear.Core.ImGearDoubleRectangle Structure

Declaration:

public void Add ( System.Object Value )

Parameters:

Name
Type
Description
Value
System.Object
The capability value to be added to the end of the array.

Return Value:

None

See Also:

ImGearDoubleRectangle Structure


Clear Method

32-bit
64-bit
CF
P

Description:

This method removes all elements from the array.

Declaration:

public void Clear ( )

Return Value:

None.


ImGearCapEnumeration Class

32-bit
64-bit
CF
P

Description:

This class describes a capability whose value resides in ImGearContainerType.ENUMERATION container.

This class inherits ImGearCapArray Class class.

Declaration:

public sealed class ImGearCapEnumeration : ImageGear.TWAIN.ImGearCapArray

Members:

Constructors
Name
Description
ImGearCapEnumeration Constructor
Creates the new instance of ImGearCapEnumeration Class.

Properties
Name
Description
CurrentValueIndex Property
This property gets or sets the index in the array of the current value.
DefaultValueIndex Property
This property gets or sets the index in the array of the default value.

See Also:

ImGearCapArray Class


ImGearCapEnumeration Constructors

The ImGearCapEnumeration Class of the ImageGear.TWAIN Namespace has the following constructors:

Constructors
Name
Description
ImGearCapEnumeration Constructor
Creates the new instance of ImGearCapEnumeration Class.


ImGearCapEnumeration Constructor

32-bit
64-bit
CF
P

Description:

This constructor creates the new instance of ImGearCapEnumeration Class.

Declaration:

public ImGearCapEnumeration(ImageGear.TWAIN.ImGearCapabilities CapID)

Parameters:

Name
Type
Description
CapID
ImGearCapabilities Enumeration
ImageGear TWAIN capability.

Return Value:

The new instance of ImGearCapEnumeration Class.

See Also:

ImGearCapEnumeration Class

ImGearCapabilities Enumeration


ImGearCapEnumeration Properties

The ImGearCapEnumeration Class of the ImageGear.TWAIN Namespace has the following properties:

Properties
Name
Description
CurrentValueIndex Property
This property gets or sets the index in the array of the current value.
DefaultValueIndex Property
This property gets or sets the index in the array of the default value.


CurrentValueIndex Property

32-bit
64-bit
CF
P

Description:

This property gets or sets the index in the array of the current value.

Declaration:

public int CurrentValueIndex { get; set }

Value:

Any integer value in the 0..Count range.


DefaultValueIndex Property

32-bit
64-bit
CF
P

Description:

This property gets or sets the index in the array of the default value.

Declaration:

public int DefaultValueIndex { get; set }

Value:

Any integer value in the 0..Count range.


ImGearCapOneValue Class

32-bit
64-bit
CF
P

Description:

This class describes a capability whose value resides in ImGearContainerType.ONEVALUE container.

This class inherits ImGearCap Class class.

Declaration:

public sealed class ImGearCapOneValue : ImageGear.TWAIN.ImGearCap

Members:

Constructors
Name
Description
ImGearCapOneValue Constructor
Creates the new instance of ImGearCapOneValue Class.

Properties
Name
Description
Value Property
This property gets or sets the value of the capability.

See Also:

ImGearCap Class


ImGearCapOneValue Constructors

The ImGearCapOneValue Class of the ImageGear.TWAIN Namespace has the following constructors:

Constructors
Name
Description
ImGearCapOneValue Constructor
Creates the new instance of ImGearCapOneValue Class.


ImGearCapOneValue Constructor

32-bit
64-bit
CF
P

Description:

This constructor creates the new instance of ImGearCapOneValue Class.

Declaration:

public ImGearCapOneValue(ImageGear.TWAIN.ImGearCapabilities CapID)

Parameters:

Name
Type
Description
CapID
ImGearCapabilities Enumeration
ImageGear TWAIN capability.

Return Value:

The new instance of ImGearCapOneValue Class.

See Also:

ImGearCapOneValue Class

ImGearCapabilities Enumeration


ImGearCapOneValue Properties

The ImGearCap Class of the ImageGear.TWAIN Namespace has the following properties:

Properties
Name
Description
Value Property
This property gets or sets the value of the capability.


Value Property

32-bit
64-bit
CF
P

Description:

This property gets or sets the value of the capability.

The value can be on of the following types:

  • System.Boolean,
  • System.Double,
  • System.Int64,
  • System.String,
  • ImageGear.Core.ImGearDoubleRectangle Structure.

Declaration:

public object Value { get; set }

See Also:

ImGearDoubleRectangle Structure


ImGearCapRange Class

32-bit
64-bit
CF
P

Description:

This class describes a capability which value resides in ImGearContainerType.RANGE container.

This class inherits ImGearCap Class class.

Declaration:

public sealed class ImGearCapRange : ImageGear.TWAIN.ImGearCap

Members:

Constructors
Name
Description
ImGearCapRange Constructor
Creates the new instance of ImGearCapRange Class.

Properties
Name
Description
CurrentValue Property
This property gets or sets the current value of the range.
DefaultValue Property
This property gets or sets the default value of the range.
MaxValue Property
This property gets or sets the maximum value of the range.
MinValue Property
This property gets or sets the minimum value of the range.
StepSize Property
This property gets or sets the step size of the range.

See Also:

ImGearCap Class


ImGearCapRange Constructors

The ImGearCapRange Class of the ImageGear.TWAIN Namespace has the following constructors:

Constructors
Name
Description
ImGearCapRange Constructor
Creates the new instance of ImGearCapRange Class.


ImGearCapRange Constructor

32-bit
64-bit
CF
P

Description:

This constructor creates the new instance of ImGearCapRange Class.

Declaration:

public ImGearCapRange(ImageGear.TWAIN.ImGearCapabilities CapID)

Parameters:

Name
Type
Description
CapID
ImGearCapabilities Enumeration
ImageGear TWAIN capability.

Return Value:

The new instance of ImGearCapRange Class.

See Also:

ImGearCapRange Class

ImGearCapabilities Enumeration


ImGearCapRange Properties

The ImGearCapRange Class of the ImageGear.TWAIN Namespace has the following properties:

Properties
Name
Description
CurrentValue Property
This property gets or sets the current value of the range.
DefaultValue Property
This property gets or sets the default value of the range.
MaxValue Property
This property gets or sets the maximum value of the range.
MinValue Property
This property gets or sets the minimum value of the range.
StepSize Property
This property gets or sets the step size of the range.


CurrentValue Property

32-bit
64-bit
CF
P

Description:

This property gets or sets the current value of the range.

Declaration:

public object CurrentValue { get; set }

Value:

The value can be of the following types:

  • System.Double
  • System.Int64


DefaultValue Property

32-bit
64-bit
CF
P

Description:

This property gets or sets the default value of the range.

Declaration:

public object DefaultValue { get; set }

Value:

The value can be of the following types:

  • System.Double
  • System.Int64


MaxValue Property

32-bit
64-bit
CF
P

Description:

This property gets or sets the maximum value of the range.

Declaration:

public object MaxValue { get; set }

Value:

The value can be of the following types:

  • System.Double
  • System.Int64


MinValue Property

32-bit
64-bit
CF
P

Description:

This property gets or sets the minimum value of the range.

Declaration:

public object MinValue { get; set }

Value:

The value can be of the following types:

  • System.Double
  • System.Int64


StepSize Property

32-bit
64-bit
CF
P

Description:

This property gets or sets the step size of the range.

Declaration:

public object StepSize { get; set }

Value:

The value can be of the following types:

  • System.Double
  • System.Int64


ImGearDataSources Class

32-bit
64-bit
CF
P

Description:

This class holds information about TWAIN data sources.

Declaration:

public class ImGearDataSources

Members:

Constructors
Name
Description
ImGearDataSources Constructor
Creates the new instance of ImGearDataSources Class.

Properties
Name
Description
Count Property
This property gets the number of data sources contained in the array.
DefaultIndex Property
This property gets the index in the array of the default data source.
this Property
This property gets the name of the specified data source.


ImGearDataSources Constructors

The ImGearDataSources Class of the ImageGear.TWAIN Namespace has the following constructors:

Constructors
Name
Description
ImGearDataSources Constructor
Creates the new instance of ImGearDataSources Class.


ImGearDataSources Constructor

32-bit
64-bit
CF
P

Description:

This constructor creates the new instance of ImGearDataSources Class.

Declaration:

public ImGearDataSources()

Return Value:

The new instance of ImGearDataSources Class.

See Also:

ImGearDataSources Class


ImGearDataSources Properties

The ImGearDataSources Class of the ImageGear.TWAIN Namespace has the following properties:

Properties
Name
Description
Count Property
This property gets the number of data sources contained in the array.
DefaultIndex Property
This property gets the index in the array of the default data source.
this Property
This property gets the name of the specified data source.


Count Property

32-bit
64-bit
CF
P

Description:

This property gets the number of data sources contained in the array.

Declaration:

public int Count { get; }

Value:

Any integer value.


DefaultIndex Property

32-bit
64-bit
CF
P

Description:

This property gets the index in the array of the default data source.

Declaration:

public int DefaultIndex { get; }

Value:

Any integer value.


this Property

32-bit
64-bit
CF
P

Description:

This property gets the name of the specified data source.

Declaration:

public const string this { get; }

Value:

String name of the data source.


ImGearFileInfo Class

32-bit
64-bit
CF
P

Description:

This class holds information about TWAIN file system.

Declaration:

public class ImGearFileInfo

Members:

Constructors
Name
Description
ImGearFileInfo Constructor
Creates the new instance of ImGearFileInfo Class.

Properties
Name
Description
CreateTimeDate Property
This property gets the creation date of the file.
DeviceGroupMask Property
This property is used to group cameras (e.g., front/rear bitonal, front/rear grayscale, etc.).
FreeSpace Property
This property gets bytes of free space on the current device.
ModifiedTimeDate Property
This property gets the last date the file was modified.
Name Property
This property gets the name of the file.
NewImageSize Property
This property gets an estimate of the amount of space a new image would take up.
NumberOfFiles Property
This property gets the number of files; depends on Type
NumberOfSnippets Property
This property gets the number of audio snippets.
Size Property
This property gets the size of current Type.
Type Property
This property gets the type of the file.


ImGearFileInfo Constructors

The ImGearFileInfo Class of the ImageGear.TWAIN Namespace has the following constructors:

Constructors
Name
Description
ImGearFileInfo Constructor
Creates the new instance of ImGearFileInfo Class.


ImGearFileInfo Constructor

32-bit
64-bit
CF
P

Description:

This constructor creates the new instance of ImGearFileInfo Class.

Declaration:

public ImGearFileInfo()

Return Value:

The new instance of ImGearFileInfo Class.

See Also:

ImGearFileInfo Class


ImGearFileInfo Properties

The ImGearFileInfo Class of the ImageGear.TWAIN Namespace has the following properties:

Properties
Name
Description
CreateTimeDate Property
This property gets the creation date of the file.
DeviceGroupMask Property
This property is used to group cameras (e.g., front/rear bitonal, front/rear grayscale, etc.).
FreeSpace Property
This property gets bytes of free space on the current device.
ModifiedTimeDate Property
This property gets the last date the file was modified.
Name Property
This property gets the name of the file.
NewImageSize Property
This property gets an estimate of the amount of space a new image would take up.
NumberOfFiles Property
This property gets the number of files; depends on Type
NumberOfSnippets Property
This property gets the number of audio snippets.
Size Property
This property gets the size of current Type.
Type Property
This property gets the type of the file.


CreateTimeDate Property

32-bit
64-bit
CF
P

Description:

This property gets the creation date of the file.

Declaration:

public string CreateTimeDate { get; }

Value:

String time data.


DeviceGroupMask Property

32-bit
64-bit
CF
P

Description:

This property is used to group cameras (e.g., front/rear bitonal, front/rear grayscale, etc.).

Declaration:

public int DeviceGroupMask { get; }

Value:

Any integer value.


FreeSpace Property

32-bit
64-bit
CF
P

Description:

This property gets bytes of free space on the current device.

Declaration:

public long FreeSpace { get; }

Value:

Long value.


ModifiedTimeDate Property

32-bit
64-bit
CF
P

Description:

This property gets the last date the file was modified.

Declaration:

public string ModifiedTimeDate { get; }

Value:

String date data.


Name Property

32-bit
64-bit
CF
P

Description:

This property gets the name of the file.

Declaration:

public string Name { get; }

Value:

String filename.


NewImageSize Property

32-bit
64-bit
CF
P

Description:

This property gets an estimate of the amount of space a new image would take up.

Declaration:

public long NewImageSize { get; }

Value:

Any long integer value.


NumberOfFiles Property

32-bit
64-bit
CF
P

Description:

This property gets the number of files, depends on Type.

Declaration:

public long NumberOfFiles { get; }

Value:

Any long integer value.


NumberOfSnippets Property

32-bit
64-bit
CF
P

Description:

This property gets the number of audio snippets.

Declaration:

public long NumberOfSnippets { get; }

Value:

Any long integer value.


Size Property

32-bit
64-bit
CF
P

Description:

This property gets the size of current Type.

Declaration:

public long Size { get; }

Value:

Any long integer value.


Type Property

32-bit
64-bit
CF
P

Description:

This property gets the type of the file.

Declaration:

public ImageGear.TWAIN.ImGearFileType Type { get; }

Value:

One of the ImGearFileType Enumeration values.


ImGearTWAIN Class

32-bit
64-bit
CF
P

Description:

Core TWAIN class.

Declaration:

public class ImGearTWAIN

Members:

Constructors
Name
Description
ImGearTWAIN Constructor
Creates the new instance of ImGearTWAIN Class.

Properties
Name
Description
ApplicationName Property
This property gets or sets the name of the application that uses TWAIN.
DataSources Property
The ImGearDataSources object lists the available TWAIN Data Sources and identifies the one that is the default Data Source.
DriverVersionBuild Property
This property gets the build part of the version number of the TWAIN Data Source Manager.
DriverVersionMajor Property
This property gets the major part of the version number of the TWAIN Data Source Manager.
DriverVersionMinor Property
This property gets the minor part of the version number of the TWAIN Data Source Manager.
ImageFileName Property
This property specifies the file name for a scanned image when Disk Transfer Mode is used.
UseUI Property
If set to true, then a call to AcquireToDoc, AcquireToFile, AcquireToPage will cause the TWAIN Data Source to display its settings dialog, so that the user can set the various capability values. If set to false, then a call to one of the AcquireXXX methods will result in the immediate acquisition of the image(s), using the current capability settings.
WindowHandle Property
This value is simply passed to the TWAIN Data Source when it is called by ImGearTWAIN. Your application should set this to the handle of the main window in the application.

Methods
Name
Description
Acquire Method
This method is used to scan multiple pages from a scanner equipped with an Automatic Document Feeder (ADF).
AcquireToDoc Method
This method is used to scan multiple pages from a scanner equipped with an Automatic Document Feeder (ADF).
AcquireToFile Method
This method is used to scan multiple pages from a scanner equipped with an Automatic Document Feeder (ADF).
AcquireToPage Method
This method causes the scanning of a single page through a TWAIN device.
ChangeDirectory Method
This method selects the current device within the Data Source (camera, storage, etc).
CloseFile Method
This method closes the file system context.
CloseSource Method
This method closes the currently opened Data Source.
CopyFile Method
This method copies the specified file from one directory to another.
CreateDirectory Method
This method creates a new directory within the current directory.
DeleteFile Method
This method deletes a file or directory on the device.
FormatMedia Method
This method formats the specified storage.
GetCapability Method
This method gets information about a capability.
GetCurrentImage Method
This method retrieves the image that the device's file system context currently points to.
GetFileInfo Method
This method gets information about the requested file.
GetFirstFile Method
This method gets the first filename in a directory, and returns information about that file (the same information that can be retrieved with GetFileInfo).
GetImageLayout Method
Gets the image layout of the selected TWAIN device.
GetNextFile Method
This method gets the next filename in a directory, and returns information about that file (the same information that can be retrieved with GetFileInfo).
LoadCustomDSData Method
This method loads the settings from the specified file, and sets the data source with these settings.
OpenSource Method
This method loads the specified Data Source into main memory and causes its initialization.
RenameFile Method
This method renames (and optionally moves) a file or directory. Absolute and relative path names are supported.
SaveCustomDSData Method
This method queries the data source for its current settings, and saves these settings to the specified file.
SetCapability Method
This method sets or resets the current value of a capability. Use OpenSource to select the desired Data Source, prior to calling this method.
SetImageLayout Method
Sets the image layout of the selected TWAIN device.
ShowSourceUI Method
This method shows the Data Source UI to allow the user to manipulate the source's current settings, but not acquire an image.

Events
Name
Description
AfterPage Event
This event is fired after each page is scanned using any of the scanning methods of ImGearTWAIN.
BeforePage Event
This event is fired before each page is scanned using any of the scanning methods of ImGearTWAIN.


ImGearTWAIN Constructors

The ImGearCap Class of the ImageGear.TWAIN Namespace has the following constructors:

Constructors
Name
Description
ImGearTWAIN Constructor
Creates the new instance of ImGearTWAIN Class.


ImGearTWAIN Constructor

32-bit
64-bit
CF
P

Description:

This constructor creates the new instance of ImGearTWAIN Class.

Declaration:

public ImGearTWAIN()

Return Value:

The new instance of ImGearTWAIN Class.

See Also:

ImGearTWAIN Class


ImGearTWAIN Properties

The ImGearTWAIN Class of the ImageGear.TWAIN Namespace has the following properties:

Properties
Name
Description
ApplicationName Property
This property gets or sets the name of the application that uses TWAIN.
DataSources Property
The ImGearDataSources object lists the available TWAIN Data Sources and identifies the one that is the default Data Source.
DriverVersionBuild Property
This property gets the build part of the version number of the TWAIN Data Source Manager.
DriverVersionMajor Property
This property gets the major part of the version number of the TWAIN Data Source Manager.
DriverVersionMinor Property
This property gets the minor part of the version number of the TWAIN Data Source Manager.
ImageFileName Property
This property specifies the file name for a scanned image when Disk Transfer Mode is used.
UseUI Property
If set to true, then a call to AcquireToDoc, AcquireToFile, AcquireToPage will cause the TWAIN Data Source to display its settings dialog, so that the user can set the various capability values. If set to false, then a call to one of the AcquireXXX methods will result in the immediate acquisition of the image(s), using the current capability settings.
WindowHandle Property
This value is simply passed to the TWAIN Data Source when it is called by ImGearTWAIN. Your application should set this to the handle of the main window in the application.


ApplicationName Property

32-bit
64-bit
CF
P

Description:

This property gets or sets the name of the application that uses TWAIN.

Declaration:

public string ApplicationName { get; set }

Value:

Any string value.


DataSources Property

32-bit
64-bit
CF
P

Description:

The ImGearDataSources Class object lists the available TWAIN Data Sources and identifies the one that is the default Data Source.

Declaration:

public ImageGear.TWAIN.ImGearDataSources DataSources { get; }

Value:

An ImGearDataSources Class containing information about the available TWAIN Data Sources.

See Also:

ImGearDataSources Class


DriverVersionBuild Property

32-bit
64-bit
CF
P

Description:

This property gets the build part of the version number of the TWAIN Data Source Manager.

Declaration:

public int DriverVersionBuild { get; }

Value:

Any integer value.


DriverVersionMajor Property

32-bit
64-bit
CF
P

Description:

This property gets the major part of the version number of the TWAIN Data Source Manager.

Declaration:

public int DriverVersionMajor { get; }

Value:

Any integer value.


DriverVersionMinor Property

32-bit
64-bit
CF
P

Description:

This property gets the minor part of the version number of the TWAIN Data Source Manager.

Declaration:

public int DriverVersionMinor { get; }

Value:

Any integer value.


ImageFileName Property

32-bit
64-bit
CF
P

Description:

This property specifies the file name for a scanned image when Disk Transfer Mode is used.

If ImageFileName specifies a directory, but not a file name, a separate file for each page will be created, using these names 0000001.tif, 00000002.tif, 00000003.tif, etc. If those files already exist, they will be deleted before being scanned into.

If ImageFileName specifies a filename, a separate file will be created for each page, but will use part of the name that you supplied. If the name you supplied was "ScanTest.bmp", your pages will be named ScanTest.bmp, ScanTest0.bmp, ScanTest1.bmp, ScanTest10.bmp, ScanTest11.bmp, etc. If these files already exist, they will be deleted before being scanned into.

Declaration:

public string ImageFileName { get; set }

Value:

File name string.


UseUI Property

32-bit
64-bit
CF
P

Description:

If set to true, then a call to AcquireToDoc, AcquireToFile, AcquireToPage will cause the TWAIN Data Source to display its settings dialog so that the user can set the various capability values. If set to false, then a call to one of the AcquireXXX methods will result in the immediate acquisition of the image(s), using the current capability settings.

Declaration:

public bool UseUI { get; set }

Value:

True, false.


WindowHandle Property

32-bit
64-bit
CF
P

Description:

This value is simply passed to the TWAIN Data Source when it is called by ImGearTWAIN. Your application should set this to the handle of the main window in the application.

Declaration:

public System.IntPtr WindowHandle { get; set }

Value:

The handle of the main window in the application.


ImGearTWAIN Methods

The ImGearTWAIN Class of the ImageGear.TWAIN Namespace has the following methods:

Methods
Name
Description
Acquire Method
This method is used to scan multiple pages from a scanner equipped with an Automatic Document Feeder (ADF).
AcquireToDoc Method
This method is used to scan multiple pages from a scanner equipped with an Automatic Document Feeder (ADF).
AcquireToFile Method
This method is used to scan multiple pages from a scanner equipped with an Automatic Document Feeder (ADF).
AcquireToPage Method
This method causes the scanning of a single page through a TWAIN device.
ChangeDirectory Method
This method selects the current device within the Data Source (camera, storage, etc).
CloseFile Method
This method closes the file system context.
CloseSource Method
This method closes the currently opened Data Source.
CopyFile Method
This method copies the specified file from one directory to another.
CreateDirectory Method
This method creates a new directory within the current directory.
DeleteFile Method
This method deletes a file or directory on the device.
FormatMedia Method
This method formats the specified storage.
GetCapability Method
This method gets information about a capability.
GetCurrentImage Method
This method retrieves the image that the device's file system context currently points to.
GetFileInfo Method
This method gets information about the requested file.
GetFirstFile Method
This method gets the first filename in a directory, and returns information about that file (the same information that can be retrieved with GetFileInfo).
GetImageLayout Method
Gets the image layout of the selected TWAIN device.
GetNextFile Method
This method gets the next filename in a directory, and returns information about that file (the same information that can be retrieved with GetFileInfo).
LoadCustomDSData Method
This method loads the settings from the specified file, and sets the data source with these settings.
OpenSource Method
This method loads the specified Data Source into main memory and causes its initialization.
RenameFile Method
This method renames (and optionally moves) a file or directory. Absolute and relative path names are supported.
SaveCustomDSData Method
This method queries the data source for its current settings, and saves these settings to the specified file.
SetCapability Method
This method sets or resets the current value of a capability. Use OpenSource to select the desired Data Source, prior to calling this method.
SetImageLayout Method
Sets the image layout of the selected TWAIN device.
ShowSourceUI Method
This method shows the Data Source UI to allow the user to manipulate the source's current settings, but not acquire an image.


Acquire Method

32-bit
64-bit
CF
P

Description:

This method is used to scan multiple pages from a scanner equipped with an Automatic Document Feeder (ADF).

Instead of accumulating the images in an ImGearDocument Class object, this method only makes them available through the AfterPage Event event.

Declaration:

public void Acquire(int PageCount)

Parameters:

Name
Type
Description
PageCount
int
Count of pages to scan. -1 scans all available pages.

Return Value:

None.

Remarks:

Use OpenSource Method to select the desired Data Source, and SetCapability Method to set desired capabilities values, prior to calling this method.

Also, set up event handlers for the BeforePage Event and/or AfterPage Event events. In the AfterPage Event event, the scanned page is made available as an ImGearPage Class object. The application can use this to do such things as performing processing, adding the page to an ImGearDocument Class, saving it to a file, and so on.


AcquireToDoc Method

32-bit
64-bit
CF
P

Description:

This method is used to scan multiple pages from a scanner equipped with an Automatic Document Feeder (ADF). The images are stored as separate pages in the created ImGearDocument Class.

Declaration:

public ImageGear.Core.ImGearDocument AcquireToDoc (int PageCount)

Parameters:

Name
Type
Description
PageCount
int
Count of pages to scan to the document.

Return Value:

An ImGearDocument Class containing the scanned images.

Remarks:

Use OpenSource to select the desired Data Source, and SetCapability to set desired capabilities values, prior to calling this method.

See Also:

ImGearDocument Class


AcquireToFile Method

32-bit
64-bit
CF
P

Description:

This method is used to scan multiple pages from a scanner equipped with an Automatic Document Feeder (ADF).

If FileName specifies only a directory but not a file name, a separate file for each page will be created, using the names 0000001.tif, 00000002.tif, 00000003.tif, etc. If those files already exist, they will be deleted before being scanned into.

If FileName specifies a filename and SavePagesSeparately is set to true, a separate file for each page will be created, but will use part of the name that you supplied. If the name you supplied was "ScanTest.bmp", your pages will be named as follows: ScanTest.bmp, ScanTest0.bmp, ScanTest1.bmp, ScanTest10.bmp, ScanTest11.bmp, etc. If these files already exist, they will be deleted before being scanned into.

If SavePagesSeparately is false and FileFormat is set to a format type that supports multiple pages, such as TIFF, DCX, or MO:DCA, the images are stored in one file identified by the FileName parameter.

Declaration:

public void AcquireToFile(string FileName, int PageCount,
ImageGear.Formats.ImGearSavingFormats FileFormat, bool SavePagesSeparately)

Parameters:

Name
Type
Description
FileName
string
The name of file
PageCount
int
The number of pages to scan in file
FileFormat
ImGearSavingFormats Enumeration
The format of the file to scan to
SavePagesSeparately
bool
Specifies whether every scanned page should be saved in the separate file or not.

Remarks:

Use OpenSource to select the desired Data Source, and SetCapability to set desired capabilities values, prior to calling this method.

Return Value:

None.

See Also:

ImGearSavingFormats Enumeration


AcquireToPage Method

32-bit
64-bit
CF
P

Description:

This causes the scanning of a single page through a TWAIN device. Use OpenSource to select the desired Data Source, and SetCapability to set desired capabilities values, prior to calling this method.

Declaration:

public ImageGear.Core.ImGearPage AcquireToPage ( )

Return Value:

An ImGearPage Class containig the scanned image.

Remarks:

Set UseUI to true, prior to calling this method, if you want ImageGear to obtain the capability settings from the end-user.

See Also:

ImGearPage Class


ChangeDirectory Method

32-bit
64-bit
CF
P

Description:

This method selects the current device within the Data Source (camera, storage, etc). If the device is a ImGearFileType.DOMAIN, then this command enters a directory that can contain ImGearFileType.HOST files. If the device is a ImGearFileType.HOST, then this command enters a directory that can contain ImGearFileType.DIRECTORY files. If the device is a ImGearFileType.DIRECTORY, then this command enters a directory that can contain ImGearFileType.DIRECTORY or ImGearFileType.IMAGE files.

Declaration:

public void ChangeDirectory ( String DirName )

Parameters:

Name
Type
Description
DirName
String
The name of directory.

Remarks:

Use OpenSource to select the desired Data Source, prior to calling this method.

Return Value:

None.


CloseFile Method

32-bit
64-bit
CF
P

Description:

This method closes the file system context associated with FileInfo. Every call to GetFirstFile must be matched by a call to CloseFile to release the file system context.

Declaration:

public void CloseFile (ImageGear.TWAIN.ImGearFileInfo FileInfo )

Parameters:

Name
Type
Description
FileInfo
ImGearFileInfo Class
File info.

Remarks:

Use OpenSource to select the desired Data Source, prior to calling this method.

Return Value:

None.

See Also:

ImGearFileInfo Class


CloseSource Method

32-bit
64-bit
CF
P

Description:

This method closes the currently opened Data Source. When an application is finished with a Data Source, it must formally close the session between them using this method. This is necessary in case the Data Source only supports connection with a single application (many desktop scanners will behave this way). A Data Source such as this cannot be accessed by other applications until its current session is terminated.

Declaration:

public void CloseSource ( )

Return Value:

None.

See also:

ImGearDataSources Class


CopyFile Method

32-bit
64-bit
CF
P

Description:

This method copies the specified file from one directory to another. If the Recursive flag is true and the file type specified is ImGearFileType.DIRECTORY, then that directory, and all the files and directories under it, are copied. The application cannot copy files into the root directory.

Declaration:

public void CopyFile(string SrcFileName, string DestFileName, bool Recursive)

Parameters:

Name
Type
Description
SrcFileName
string
The path to the source file/directory
DestFileName
string
The path to the destination file/directory
Recursive
bool
Specifies whether the copying is recursive or not.

Remarks:

Use OpenSource to select the desired Data Source, prior to calling this method.

Return Value:

None.


CreateDirectory Method

32-bit
64-bit
CF
P

Description:

This method creates a new directory within the current directory. Pathnames are not allowed, only the name of the new directory can be specified.

Declaration:

public void CreateDirectory(string DirName)

Parameters:

Name
Type
Description
DirName
string
The name of directory.

Remarks:

Use OpenSource to select the desired Data Source, prior to calling this method.

Return Value:

None.


DeleteFile Method

32-bit
64-bit
CF
P

Description:

This method deletes a file or directory on the device. Pathnames are not allowed, only the name of the file or directory to be deleted can be specified. Recursive deletion can be specified by setting the Recursive to true.

Declaration:

public void DeleteFile(string FileName, bool Recursive)

Parameters:

Name
Type
Description
FileName
string
The name of file to delete
Recursive
bool
Specifies whether it is recursive deleting or not.

Remarks:

Use OpenSource to select the desired Data Source, prior to calling this method.

Return Value:

None.


FormatMedia Method

32-bit
64-bit
CF
P

Description:

This method formats the specified storage. This operation destroys all images and subdirectories under the selected device. Use with caution!

Declaration:

public void FormatMedia (string DeviceName)

Parameters:

Name
Type
Description
DeviceName
string
The name of the scanning device.

Remarks:

Use OpenSource to select the desired Data Source, prior to calling this method.

Return Value:

None.


GetCapability Method

32-bit
64-bit
CF
P

Description:

This method gets information about a capability.

Declaration:

public ImageGear.TWAIN.ImGearCap GetCapability (ImageGear.TWAIN.ImGearCapabilities ID,
ImageGear.TWAIN.ImGearMessages Msg)

Parameters:

Name
Type
Description
ID
ImGearCapabilities Enumeration
ID of the capability
Msg
ImGearMessages Enumeration
Can be on of the following values:
ImGearMessages.GET - Get one or more capability values.
ImGearMessages.GETCURRENT - Get current capability value.
ImGearMessages.GETDEFAULT - Get default (e.g. power up) capability value.

Return Value:

One of the capability objects containing information about the requested capability.

Remarks:

Use OpenSource to select the desired Data Source, prior to calling this method.

See Also:

ImGearCap Class

ImGearCapabilities Enumeration

ImGearMessages Enumeration


GetCurrentImage Method

32-bit
64-bit
CF
P

Description:

This method retrieves the image that the device's file system context currently points to. Use GetFirstFile and GetNextFile to select the file you want to transfer from the device's file system.

Declaration:

public ImageGear.Core.ImGearPage GetCurrentImage ( )

Return Value:

An ImGearPage Class containing the requested image.

Remarks:

Use OpenSource to select the desired Data Source, prior to calling this method.

See Also:

ImGearPage Class


GetFileInfo Method

32-bit
64-bit
CF
P

Description:

This method gets information about the requested file.

Declaration:

public ImageGear.TWAIN.ImGearFileInfo GetFileInfo (string FileName)

Parameters:

Name
Type
Description
FileName
string
The name of file to get info about.

Return Value:

An ImGearFileInfo Class containing information about the requested file.

Remarks:

Use OpenSource to select the desired Data Source, prior to calling this method.

See Also:

ImGearFileInfo Class


GetFirstFile Method

32-bit
64-bit
CF
P

Description:

This method gets the first filename in a directory and returns information about that file (the same information that can be retrieved with GetFileInfo). The Data Source positions the file system context to point to the first filename. ImGearFileInfo.Name contains the absolute path and name of the file. If the Application calls GetCurrentImage, the current image will be transferred. Applications must not assume any ordering of the files delivered by the Data Source, with one exception: if GetFirstFile is called in the root directory, the operation must return an ImGearFileType.CAMERA device.

Declaration:

public ImageGear.TWAIN.ImGearFileInfo GetFirstFile ( )

Return Value:

An ImGearFileInfo Class containing information about the first file in a directory.

Remarks:

Use OpenSource to select the desired Data Source, prior to calling this method.

See Also:

ImGearFileInfo Class


GetImageLayout Method

32-bit
64-bit
CF
P

Description:

This method gets the image layout of the selected TWAIN device. You can use it to limit your capture region to a portion of the device total area. The units are in inches by default. You can set ICAP_UNITS capability to choose the different kind of units.

NOTE: TWAIN image layout is specified using the Left Property, Top Property, Right Property, and Bottom Property properties of ImGearDoubleRectangle Structure. The Width Property and Height Property properties should not be used, because they assume endpoint-inclusive semantics. Using endpoint-inclusive semantics, a rectangle with left, top, right, and bottom coordinates all equal to 0 is one pixel wide and one pixel tall. So, for example, the Width property is calculated as Right - Left + 1. This is not appropriate for a TWAIN image layout rectangle. Therefore, use only the Left Property, Top Property, Right Property, and Bottom Property properties.

Declaration:

public ImageGear.Core.ImGearDoubleRectangle GetImageLayout()

Return Value:

ImGearDoubleRectangle Structure that represents the physical bounding box of the region to be acquired.

Remarks:

Use OpenSource to select the desired Data Source prior to calling this method.

See Also:

ImGearDoubleRectangle Structure


GetNextFile Method

32-bit
64-bit
CF
P

Description:

This method gets the next filename in a directory, and returns information about that file (the same information that can be retrieved with GetFileInfo). The Data Source positions the file system context to point to the next filename. ImGearFileInfo.Name contains the absolute path and name of the file. If the Application calls GetCurrentImage, the current image will be transferred. A call to GetFirstFile must be issued on a given directory before the first call to GetNextFile.

Declaration:

public void GetNextFile(ImageGear.TWAIN.ImGearFileInfo FileInfo)

Parameters:

Name
Type
Description
FileInfo
ImGearFileInfo Class
The file information.

Remarks:

Use OpenSource to select the desired Data Source, prior to calling these methods.

Return Value:

None.

See Also:

ImGearFileInfo Class


LoadCustomDSData Method

32-bit
64-bit
CF
P

Description:

This method loads the settings from the specified file, and sets the data source with these settings.

This method throws exceptions if no data source is open, or the open data source doesn't support ImGearCapabilities Enumeration.CAP_CUSTOMDSDATA.

Declaration:

public void LoadCustomDSData(string filename)

Parameters:

Name
Type
Description
filename
string
Specifies the name of the file from which to load the settings.

Return Value:

None

See Also:

ImGearCapabilities Enumeration


OpenSource Method

32-bit
64-bit
CF
P

Description:

This method loads the specified Data Source into main memory and causes its initialization.

If SourceName is String.Empty and UseUI is set to true, a call to this method will cause Data Source Manager to display the default source selection dialog.

If SourceName is String.Empty and UseUI is set to false, the default Data Source will be opened.

If SourceName is a name of an existing Data Source, the specified Data Source will be opened.

Declaration:

public void OpenSource ( string SourceName )

Parameters:

Name
Type
Description
SourceName
string
Specifies the data source.

Remarks:

When an application is finished with the Data Source, call CloseSource to close the session between them.

Return Value:

None.


RenameFile Method

32-bit
64-bit
CF
P

Description:

This method renames (and optionally moves) a file or directory. Absolute and relative path names are supported. A file may not be overwritten with this command. If an Application wishes to do this, it must first delete the unwanted file, then issue the rename command. Filenames in the root directory cannot be moved or renamed.

Declaration:

public void RenameFile (string OldName , string NewName)

Parameters:

Name
Type
Description
OldName
string
The name of the file/directory to be renamed.
NewName
string
The new name of the file/directory.

Remarks:

Use OpenSource to select the desired Data Source, prior to calling this method.

Return Value:

None.


SaveCustomDSData Method

32-bit
64-bit
CF
P

Description:

This method queries the data source for its current settings, and saves these settings to the specified file.

This method throws exceptions if no data source is open, or the open data source doesn't support ImGearCapabilities Enumeration.CAP_CUSTOMDSDATA.

Declaration:

public void SaveCustomDSData(string filename)

Parameters:

Name
Type
Description
filename
string
Specifies the name of the file to which to save the settings.

Return Value:

None

See Also:

ImGearCapabilities Enumeration


SetCapability Method

32-bit
64-bit
CF
P

Description:

This method sets or resets the current value of a capability.

Declaration:

public void SetCapability (ImageGear.TWAIN.ImGearCap Cap , ImageGear.TWAIN.ImGearMessages
Msg)

Parameters:

Name
Type
Description
Cap
ImGearCap Class
Specifies the capability to change
Msg
ImGearMessages Enumeration
Can be one of the following values:
ImGearMessages.SET - Set one or more capability values.
ImGearMessages.RESET - Set current capability value to default value.

Remarks:

Use OpenSource to select the desired Data Source, prior to calling this method.

Return value:

None.

See Also:

ImGearCap Class

ImGearMessages Enumeration


SetImageLayout Method

32-bit
64-bit
CF
P

Description:

This method sets the image layout of the selected TWAIN device. You can use this to limit your capture region to a portion of the device's total area. The units are in inches by default. You can set ICAP_UNITS capability to choose the different kind of units.

NOTE: TWAIN image layout is specified using the Left Property, Top Property, Right Property, and Bottom Property properties of ImGearDoubleRectangle Structure. The Width Property and Height Property properties should not be used, because they assume endpoint-inclusive semantics. Using endpoint-inclusive semantics, a rectangle with left, top, right, and bottom coordinates all equal to 0 is one pixel wide and one pixel tall. So, for example, the Width property is calculated as Right - Left + 1. This is not appropriate for a TWAIN image layout rectangle. Therefore, use only the Left Property, Top Property, Right Property, and Bottom Property properties.

Declaration:

public void SetImageLayout(ImageGear.Core.ImGearDoubleRectangle ImageLayout)

Parameters:

Name
Type
Description
ImageLayout
ImGearDoubleRectangle Structure
Image layout of the selected TWAIN device.

Remarks:

Use OpenSource to select the desired Data Source prior to calling this method.

Return Value:

None.

See Also:

ImGearDoubleRectangle Structure


ShowSourceUI Method

32-bit
64-bit
CF
P

Description:

This method shows the Data Source UI to allow the user to manipulate the source's current settings, but not acquire an image.

This method throws exceptions if no data source is open, or the open data source doesn't support ImGearCapabilities Enumeration.CAP_ENABLEDSUIONLY.

Declaration:

public void ShowSourceUI()

Parameters:

None

Return Value:

None


ImGearTWAIN Events

The ImGearTWAIN Class of the ImageGear.TWAIN Namespace has the following events:

Events
Name
Description
AfterPage Event
This event is fired after each page is scanned using any of the scanning methods of ImGearTWAIN.
BeforePage Event
This event is fired before each page is scanned using any of the scanning methods of ImGearTWAIN.


AfterPage Event

32-bit
64-bit
CF
P

Description:

This event is fired after each page is scanned using any of the scanning methods of ImGearTWAIN.

It can be used by an application to monitor scanning progress (on a per-page basis) and access the image just scanned. It can also be used to cancel scanning, if the application's event handler sets the CancelScanning Property property of the event arguments object ImGearTWAINAfterPageEventArgs Class to true.

Methods and properties of ImGearTWAIN should not be accessed in the event handler for this event.

See the documentation for ImGearTWAINAfterPageEventHandler Delegate for an example of how to use this event.

Declaration:

public event ImGearTWAINAfterPageEventHandler AfterPage;

See Also:

ImGearTWAINAfterPageEventHandler Delegate


BeforePage Event

32-bit
64-bit
CF
P

Description:

This event is fired before each page is scanned using any of the scanning methods of ImGearTWAIN.

It can be used by an application to monitor scanning progress (on a per-page basis).

It can also be used to cancel scanning before scanning the next page, if the application's event handler sets the CancelScanning Property property of the event arguments object ImGearTWAINBeforePageEventArgs Class to TRUE.

Methods and properties of ImGearTWAIN should not be accessed in the event handler for this event.

See the documentation for ImGearTWAINBeforePageEventHandler Delegate for an example of how to use this event.

Declaration:

public event ImGearTWAINBeforePageEventHandler BeforePage;

See Also:

ImGearTWAINBeforePageEventHandler Delegate


ImGearTWAINAfterPageEventArgs Class

32-bit
64-bit
CF
P

Description:

Contains arguments for the AfterPage Event event.

Declaration:

public class ImGearTWAINAfterPageEventArgs : EventArgs

Members:

Properties
Name
Description
CancelScanning Property
Set this to true to cancel scanning.
Page Property
ImGearPage object containing the page just scanned.
PageNumber Property
Number of page just scanned. The first page is number 1.
PendCount Property
Number of pages remaining to be scanned. -1 if unknown.


ImGearTWAINAfterPageEventArgs Properties

The ImGearTWAINAfterPageEventArgs Class of the ImageGear.TWAIN Namespace has the following properties:

Properties
Name
Description
CancelScanning Property
Set this to true to cancel scanning.
Page Property
ImGearPage object containing the page just scanned.
PageNumber Property
Number of page just scanned. The first page is number 1.
PendCount Property
Number of pages remaining to be scanned. -1 if unknown.


CancelScanning Property

32-bit
64-bit
CF
P

Description:

Set this to TRUE to cancel scanning.

Declaration:

public boolean CancelScanning {get; set}

Value:

TRUE - cancel scanning, FALSE - otherwise.


Page Property

32-bit
64-bit
CF
P

Description:

ImGearPage Class object containing the page just scanned.

Declaration:

public ImageGear.Core.ImGearPage Page { get }

Value:

The new instance of ImGearPage Class object.

See Also:

ImGearPage Class


PageNumber Property

32-bit
64-bit
CF
P

Description:

Queries the number of page just scanned. The first page is number 1.

Declaration:

public int PageNumber { get }

Value:

Any integer value.


PendCount Property

32-bit
64-bit
CF
P

Description:

Number of pages remaining to be scanned. -1 if unknown.

Declaration:

public int PendCount { get; }

Value:

Any integer value.


ImGearTWAINBeforePageEventArgs Class

32-bit
64-bit
CF
P

Description:

Contains arguments for the BeforePage Event event.

Declaration:

public class ImGearTWAINBeforePageEventArgs : System.EventArgs

Members:

Properties
Name
Description
CancelScanning Property
Set this to true to cancel scanning.
PageNumber Property
Number of page about to be scanned. The first page is number 1.


ImGearTWAINBeforePageEventArgs Properties

The ImGearTWAINBeforePageEventArgs Class of the ImageGear.TWAIN Namespace has the following properties:

Properties
Name
Description
CancelScanning Property
Set this to true to cancel scanning.
PageNumber Property
Number of page about to be scanned. The first page is number 1.


CancelScanning Property

32-bit
64-bit
CF
P

Description:

Set this to TRUE to cancel scanning.

Declaration:

public bool CancelScanning {get; set}

Value:

TRUE - cancel scanning, FALSE - otherwise.


ImageGear.TWAIN Namespace Delegates

The ImageGear.TWAIN Namespace has the following delegate members:

Delegates:
Name
Description
ImGearTWAINAfterPageEventHandler Delegate
This is the delegate used to pass AfterPage events on to an application event handler.
ImGearTWAINBeforePageEventHandler Delegate
This is the delegate used to pass BeforePage events on to an application event handler.


ImGearTWAINAfterPageEventHandler Delegate

32-bit
64-bit
CF
P

Description:

This is the delegate used to pass AfterPage Event events on to an application event handler.

It follows the standard .NET event model. The AfterPage Event event occurs after scanning a page. It provides the page number to be scanned and gives an opportunity to cancel scanning.

Here's an example of typical AfterPage Event event registration and declaration:

ImGearTWAIN imGearTWAIN = new ImGearTWAIN();
...
imGearTWAIN.AfterPage += new ImGearTWAINAfterPageEventHandler(imGearTWAIN_AfterPage);
...
private void imGearTWAIN_AfterPage(object sender, ImGearTWAINAfterPageEventArgs e)
{
    // Access event arguments via ImGearTWAINAfterPageEventArgs e
}

Declaration:

public delegate ImGearTWAINAfterPageEventHandler(Object sender,
ImageGear.TWAIN.ImGearTWAINAfterPageEventArgs e)

See Also:

ImGearTWAINAfterPageEventArgs Class


ImGearTWAINBeforePageEventHandler Delegate

32-bit
64-bit
CF
P

Description:

This is the delegate used to pass BeforePage Event events on to an application event handler.

It follows the standard .NET event model. The BeforePage Event event occurs before scanning a page. It provides the page number to be scanned and gives an opportunity to cancel scanning.

Here's an example of typical BeforePage Event event registration and declaration:

ImGearTWAIN imGearTWAIN = new ImGearTWAIN();
...
imGearTWAIN.BeforePage += new ImGearTWAINBeforePageEventHandler(imGearTWAIN_BeforePage);
...
private void imGearTWAIN_BeforePage(object sender, ImGearTWAINBeforePageEventArgs e)
{
    // Access event arguments via ImGearTWAINBeforePageEventArgs e
}

Declaration:

public delegate ImGearTWAINBeforePageEventHandler(Object sender,
ImageGear.TWAIN.ImGearTWAINBeforePageEventArgs e)

See Also:

ImGearTWAINBeforePageEventArgs Class


ImageGear.TWAIN Namespace Enumerations

The ImageGear.TWAIN Namespace has the following enumeration members:

Enumerations:
Name
Description
ImGearAlarms Enumeration
ImGearCapabilities.CAP_ALARMS capability values.
ImGearAudioFormats Enumeration
ImGearCapabilities.ACAP_AUDIOFILEFORMAT capability values.
ImGearBarcodeRotation Enumeration
The bar code's orientation on the scanned image.
ImGearBarcodeSearchModes Enumeration
ImGearCapabilities.ICAP_BARCODESEARCHMODE capability values.
ImGearBarcodeType Enumeration
ImGearCapabilities.ICAP_SUPPORTEDBARCODETYPES capability values.
ImGearBitDepthReduction Enumeration
ImGearCapabilities.ICAP_BITDEPTHREDUCTION capability values.
ImGearBitOrder Enumeration
ImGearCapabilities.BITORDER capability values.
ImGearCapabilities Enumeration
Supported capabilities.
ImGearClearBuffers Enumeration
ImGearCapabilities.CAP_CLEARBUFFERS capability values.
ImGearColorDataFormats Enumeration
ImGearCapabilities.ICAP_PLANARCHUNKY capability values.
ImGearContainerType Enumeration
Capability container type.
ImGearCountries Enumeration
Country constants.
ImGearDeskewStatus Enumeration
Status of the deskew operation.
ImGearDeviceEvents Enumeration
ImGearCapabilities.CAP_DEVICEEVENT capability values.
ImGearDuplex Enumeration
ImGearCapabilities.CAP_DUPLEX capability values.
ImGearFeederAlignment Enumeration
ImGearCapabilities.CAP_FEEDERALIGNMENT capability values.
ImGearFeederOrder Enumeration
ImGearCapabilities.CAP_FEEDERORDER capability values.
ImGearFileSystem Enumeration
ImGearCapabilities.CAP_FILESYSTEM capability values.
ImGearFileType Enumeration
File types.
ImGearFilterType Enumeration
ImGearCapabilities.ICAP_FILTER capability values.
ImGearFlashUsed Enumeration
ImGearCapabilities.ICAP_FLASHUSED2 capability values.
ImGearFlipRotation Enumeration
ImGearCapabilities.ICAP_FLIPROTATION capability values.
ImGearJobControl Enumeration
ImGearCapabilities.CAP_JOBCONTROL capability values.
ImGearJPEGQuality Enumeration
ImGearCapabilities.ICAP_JPEGQUALITY capability values.
ImGearImageFilter Enumeration
ImGearCapabilities.ICAP_IMAGEFILTER capability values.
ImGearLanguages Enumeration
Language constants.
ImGearLightPath Enumeration
ImGearCapabilities.ICAP_LIGHTPATH capability values.
ImGearLightSource Enumeration
ImGearCapabilities.ICAP_LIGHTSOURCE capability values.
ImGearMessages Enumeration
Capability control messages.
ImGearNoiseFilter Enumeration
ImGearCapabilities.ICAP_NOISEFILTER capability values.
ImGearOrientation Enumeration
ImGearCapabilities.ICAP_ORIENTATION capability values.
ImGearOverscanModes Enumeration
ImGearCapabilities.ICAP_OVERSCAN capability values.
ImGearPatchCode Enumeration
Patch codes.
ImGearPixelFlavor Enumeration
ImGearCapabilities.ICAP_PIXELFLAVOR capability values.
ImGearPixelType Enumeration
ImGearCapabilities.ICAP_PIXELTYPE capability values.
ImGearPowerSupply Enumeration
ImGearCapabilities.CAP_POWERSUPPLY capability values.
ImGearPrinter Enumeration
ImGearCapabilities.CAP_PRINTER capability values.
ImGearPrinterModes Enumeration
ImGearCapabilities.CAP_PRINTERMODE capability values.
ImGearSupportedSizes Enumeration
ImGearCapabilities.ICAP_SUPPORTEDSIZES capability values.
ImGearUnits Enumeration
ImGearCapabilities.ICAP_UNITS capability values.
ImGearXferType Enumeration
ImGearCapabilities.ICAP_XFERMECH capability values.


ImGearAlarms Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration determines specific audible alarms.

ImGearCapabilities Enumeration.CAP_ALARMS capability values.

Declaration:

public enum ImGearAlarms

Values:

Name
Value
Description
ALARM
Catch-all for alarms not explicitly listed. It is also used where a device only provides control over a single, multi-use alarm.
BARCODE
Barcode alarm
DOUBLEFEED
Cover paper handling errors.
FEEDERERROR
Covers paper handling errors such as jams, double-feeds, skewing and the like; conditions that most likely stop scanning.
FEEDERWARNING
Covers non-fatal events, such as feeder empty.
JAM
Cover paper handling errors.
PATCHCODE
Patchcode alarm
POWER
Generates alarms for any changes in power to the device.
SKEW
Cover paper handling errors.


ImGearAudioFormats Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration determines which Audio file formats are supported.

ImGearCapabilities Enumeration.ACAP_AUDIOFILEFORMAT capability values.

Declaration:

public enum ImGearAudioFormats

Values:

Name
Value
Description
AIFF
1
AIFF format
AU
3
AU format
SND
4
SND format
WAV
0
WAV format


ImGearBarcodeRotation Enumeration

32-bit
64-bit
CF
P

Description:

The barcode's orientation on the scanned image.

Declaration:

public enum ImGearBarcodeRotation

Values:

Name
Value
Description
ROT0
0
No rotation
ROT90
1
Rotation on 90 degrees
ROT180
2
Rotation on 180 degrees
ROT270
3
Rotation on 270 degrees
ROTX
4
Rotation on 360 degrees


ImGearBarcodeSearchModes Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration restricts barcode searching to certain orientations, or prioritizes one orientation over the other.

ImGearCapabilities Enumeration.ICAP_BARCODESEARCHMODE capability values.

Declaration:

public enum ImGearBarcodeSearchModes
{
HORZ = 0,
VERT = 1,
HORZVERT = 2,
VERTHORZ = 3
}

Values:

Name
Value
Description
HORZ
0
Horizontal mode
HORZVERT
2
Horizontal/Vertical mode
VERT
1
Vertical mode
VERTHORZ
3
Vertical/Horizontal mode


ImGearBarcodeType Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration determines the type of bar code found on a page.

ImGearCapabilities Enumeration.ICAP_SUPPORTEDBARCODETYPES capability values.

Declaration:

public enum ImGearBarcodeType
{

Values:

Name
Value
Description
B3OF9
0
B3OF9
B2OF5INTERLEAVED
1
B2OF5INTERLEAVED
B2OF5NONINTERLEAVED
2
B2OF5NONINTERLEAVED
CODE93
3
CODE93
CODE128
4
CODE128
UCC128
5
UCC128
CODABAR
6
CODABAR
UPCA
7
UPCA
UPCE
8
UPCE
EAN8
9
EAN8
EAN13
10
EAN13
POSTNET
11
POSTNET
PDF417
12
PDF417
B2OF5INDUSTRIAL
13
B2OF5INDUSTRIAL
B2OF5MATRIX
14
B2OF5MATRIX
B2OF5DATALOGIC
15
B2OF5DATALOGIC
B2OF5IATA
16
B2OF5IATA
B3OF9FULLASCII
17
B3OF9FULLASCII
CODABARWITHSTARTSTOP
18
CODABARWITHSTARTSTOP
MAXICODE
19
MAXICODE


ImGearBitDepthReduction Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration specifies the Reduction Method the Source should use to reduce the bit depth of the data.

ImGearCapabilities Enumeration.ICAP_BITDEPTHREDUCTION capability values.

Declaration:

public enum ImGearBitDepthReduction
{
THRESHOLD = 0,
HALFTONE = 1,
CUSTHALFTONE = 2,
DIFFUSION = 3
}

Values:

Name
Value
Description
CUSTHALFTONE
2
Custom Halftone method
DIFFUSION
3
Diffusion method
HALFTONE
1
Halftone method
THRESHOLD
0
Threshold method


ImGearBitOrder Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration specifies how the bytes in an image are filled by the Source. MSBFIRST indicates that the leftmost bit in the byte (usually bit 7) is the byte's Most Significant Bit.

Declaration:

public enum ImGearBitOrder
{
LSBFIRST = 0,
MSBFIRST = 1
}

Values:

Name
Value
Description
LSBFIRST
0
LSB
MSBFIRST
1
MSB


ImGearCapabilities Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration specifies ImageGear TWAIN capabilities.

Declaration:

public enum ImGearCapabilities

Value:

Name
Value
Description
CAP_CUSTOMBASE
0x8000
Base of custom capabilities all data sources are REQUIRED to support these caps
CAP_XFERCOUNT
0x0001
image data sources are REQUIRED to support these caps
ICAP_COMPRESSION
0x0100
ICAP_PIXELTYPE
0x0101
ICAP_UNITS
0x0102
default is TWUN_INCHES
ICAP_XFERMECH
0x0103
all data sources MAY support these caps
CAP_AUTHOR
0x1000
CAP_CAPTION
0x1001
CAP_FEEDERENABLED
0x1002
CAP_FEEDERLOADED
0x1003
CAP_TIMEDATE
0x1004
CAP_SUPPORTEDCAPS
0x1005
CAP_EXTENDEDCAPS
0x1006
CAP_AUTOFEED
0x1007
CAP_CLEARPAGE
0x1008
CAP_FEEDPAGE
0x1009
CAP_REWINDPAGE
0x100a
CAP_INDICATORS
0x100b
Added 1.1
CAP_SUPPORTEDCAPSEXT
0x100c
Added 1.6
CAP_PAPERDETECTABLE
0x100d
Added 1.6
CAP_UICONTROLLABLE
0x100e
Added 1.6
CAP_DEVICEONLINE
0x100f
Added 1.6
CAP_AUTOSCAN
0x1010
Added 1.6
CAP_THUMBNAILSENABLED
0x1011
Added 1.7
CAP_DUPLEX
0x1012
Added 1.7
CAP_DUPLEXENABLED
0x1013
Added 1.7
CAP_ENABLEDSUIONLY
0x1014
Added 1.7
CAP_CUSTOMDSDATA
0x1015
Added 1.7
CAP_ENDORSER
0x1016
Added 1.7
CAP_JOBCONTROL
0x1017
Added 1.7
CAP_ALARMS
0x1018
Added 1.8
CAP_ALARMVOLUME
0x1019
Added 1.8
CAP_AUTOMATICCAPTURE
0x101a
Added 1.8
CAP_TIMEBEFOREFIRSTCAPTURE
0x101b
Added 1.8
CAP_TIMEBETWEENCAPTURES
0x101c
Added 1.8
CAP_CLEARBUFFERS
0x101d
Added 1.8
CAP_MAXBATCHBUFFERS
0x101e
Added 1.8
CAP_DEVICETIMEDATE
0x101f
Added 1.8
CAP_POWERSUPPLY
0x1020
Added 1.8
CAP_CAMERAPREVIEWUI
0x1021
Added 1.8
CAP_DEVICEEVENT
0x1022
Added 1.8
CAP_SERIALNUMBER
0x1024
Added 1.8
CAP_PRINTER
0x1026
Added 1.8
CAP_PRINTERENABLED
0x1027
Added 1.8
CAP_PRINTERINDEX
0x1028
Added 1.8
CAP_PRINTERMODE
0x1029
Added 1.8
CAP_PRINTERSTRING
0x102a
Added 1.8
CAP_PRINTERSUFFIX
0x102b
Added 1.8
CAP_LANGUAGE
0x102c
Added 1.8
CAP_FEEDERALIGNMENT
0x102d
Added 1.8
CAP_FEEDERORDER
0x102e
Added 1.8
CAP_REACQUIREALLOWED
0x1030
Added 1.8
CAP_BATTERYMINUTES
0x1032
Added 1.8
CAP_BATTERYPERCENTAGE
0x1033
Added 1.8
ICAP_AUTOBRIGHT
0x1100
ICAP_BRIGHTNESS
0x1101
ICAP_CONTRAST
0x1103
ICAP_CUSTHALFTONE
0x1104
ICAP_EXPOSURETIME
0x1105
ICAP_FILTER
0x1106
ICAP_FLASHUSED
0x1107
ICAP_GAMMA
0x1108
ICAP_HALFTONES
0x1109
ICAP_HIGHLIGHT
0x110a
ICAP_IMAGEFILEFORMAT
0x110c
ICAP_LAMPSTATE
0x110d
ICAP_LIGHTSOURCE
0x110e
ICAP_ORIENTATION
0x1110
ICAP_PHYSICALWIDTH
0x1111
ICAP_PHYSICALHEIGHT
0x1112
ICAP_SHADOW
0x1113
ICAP_FRAMES
0x1114
ICAP_XNATIVERESOLUTION
0x1116
ICAP_YNATIVERESOLUTION
0x1117
ICAP_XRESOLUTION
0x1118
ICAP_YRESOLUTION
0x1119
ICAP_MAXFRAMES
0x111a
ICAP_TILES
0x111b
ICAP_BITORDER
0x111c
ICAP_CCITTKFACTOR
0x111d
ICAP_LIGHTPATH
0x111e
ICAP_PIXELFLAVOR
0x111f
ICAP_PLANARCHUNKY
0x1120
ICAP_ROTATION
0x1121
ICAP_SUPPORTEDSIZES
0x1122
ICAP_THRESHOLD
0x1123
ICAP_XSCALING
0x1124
ICAP_YSCALING
0x1125
ICAP_BITORDERCODES
0x1126
ICAP_PIXELFLAVORCODES
0x1127
ICAP_JPEGPIXELTYPE
0x1128
ICAP_TIMEFILL
0x112a
ICAP_BITDEPTH
0x112b
ICAP_BITDEPTHREDUCTION
0x112c
Added 1.5
ICAP_UNDEFINEDIMAGESIZE
0x112d
Added 1.6
ICAP_IMAGEDATASET
0x112e
Added 1.7
ICAP_EXTIMAGEINFO
0x112f
Added 1.7
ICAP_MINIMUMHEIGHT
0x1130
Added 1.7
ICAP_MINIMUMWIDTH
0x1131
Added 1.7
ICAP_FLIPROTATION
0x1136
Added 1.8
ICAP_BARCODEDETECTIONENABLED
0x1137
Added 1.8
ICAP_SUPPORTEDBARCODETYPES
0x1138
Added 1.8
ICAP_BARCODEMAXSEARCHPRIORITIES
0x1139
Added 1.8
ICAP_BARCODESEARCHPRIORITIES
0x113a
Added 1.8
ICAP_BARCODESEARCHMODE
0x113b
Added 1.8
ICAP_BARCODEMAXRETRIES
0x113c
Added 1.8
ICAP_BARCODETIMEOUT
0x113d
Added 1.8
ICAP_ZOOMFACTOR
0x113e
Added 1.8
ICAP_PATCHCODEDETECTIONENABLED
0x113f
Added 1.8
ICAP_SUPPORTEDPATCHCODETYPES
0x1140
Added 1.8
ICAP_PATCHCODEMAXSEARCHPRIORITIES
0x1141
Added 1.8
ICAP_PATCHCODESEARCHPRIORITIES
0x1142
Added 1.8
ICAP_PATCHCODESEARCHMODE
0x1143
Added 1.8
ICAP_PATCHCODEMAXRETRIES
0x1144
Added 1.8
ICAP_PATCHCODETIMEOUT
0x1145
Added 1.8
ICAP_FLASHUSED2
0x1146
Added 1.8
ICAP_IMAGEFILTER
0x1147
Added 1.8
ICAP_NOISEFILTER
0x1148
Added 1.8
ICAP_OVERSCAN
0x1149
Added 1.8
ICAP_AUTOMATICBORDERDETECTION
0x1150
Added 1.8
ICAP_AUTOMATICDESKEW
0x1151
Added 1.8
ICAP_AUTOMATICROTATE
0x1152
Added 1.8
ICAP_JPEGQUALITY
0x1153
Added 1.9
ACAP_AUDIOFILEFORMAT
0x1201
Added 1.8


ImGearClearBuffers Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration determines the type of buffer clearing process.

ImGearCapabilities Enumeration.CAP_CLEARBUFFERS capability values.

Declaration:

public enum ImGearClearBuffers

Values:

Name
Value
Description
AUTO
0
Causes the Source to automatically clear the buffers
CLEAR
1
Causes the Source to immediately clear its buffers.
NOCLEAR
2
Causes the Source to preserve images in the buffers.


ImGearColorDataFormats Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration allows the application and Source to identify which color data formats are available.

There are two options, "planar" and "chunky."For example, planar RGB data is transferred with the entire red plane of data first, followed by the entire green plane, followed by the entire blue plane (typical for three-pass scanners). "Chunky" mode repetitively interlaces a pixel from each plane until all the data is transferred (R-G-B-R-G-B...) (typical for one-pass scanners).

ImGearCapabilities Enumeration.ICAP_PLANARCHUNKY capability values.

Declaration:

public enum ImGearColorDataFormats

Values:

Name
Value
Description
CHUNKY
0
Chunky mode
PLANAR
1
Planar mode


ImGearContainerType Enumeration

32-bit
64-bit
CF
P

Description:

Capability container type.

Declaration:

public enum ImGearContainerType

Values:

Name
Value
Description
ARRAY
3
Indicates Array container
ENUMERATION
4
Indicates Enumeration container
ONEVALUE
5
Indicates OneValue container
RANGE
6
Indicates Range container


ImGearCountries Enumeration

32-bit
64-bit
CF
P

Description:

Country constants.

Declaration:

public enum ImGearCountries

Values:

Name
Value
Description
AFGHANISTAN
1001
AFGHANISTAN
ALGERIA
213
ALGERIA
AMERICANSAMOA
684
AMERICANSAMOA
ANDORRA
033
ANDORRA
ANGOLA
1002
ANGOLA
ANGUILLA
8090
ANGUILLA
ANTIGUA
8091
ANTIGUA
ARGENTINA
54
ARGENTINA
ARUBA
297
ARUBA
ASCENSIONI
247
ASCENSIONI
AUSTRALIA
61
AUSTRALIA
AUSTRIA
43
AUSTRIA
BAHAMAS
8092
BAHAMAS
BAHRAIN
973
BAHRAIN
BANGLADESH
880
BANGLADESH
BARBADOS
8093
BARBADOS
BELGIUM
32
BELGIUM
BELIZE
501
BELIZE
BENIN
229
BENIN
BERMUDA
8094
BERMUDA
BHUTAN
1003
BHUTAN
BOLIVIA
591
BOLIVIA
BOTSWANA
267
BOTSWANA
BRITAIN
6
BRITAIN
BRITVIRGINIS
8095
BRITVIRGINIS
BRAZIL
55
BRAZIL
BRUNEI
673
BRUNEI
BULGARIA
359
BULGARIA
BURKINAFASO
1004
BURKINAFASO
BURMA
1005
BURMA
BURUNDI
1006
BURUNDI
CAMAROON
237
CAMAROON
CANADA
2
CANADA
CAPEVERDEIS
238
CAPEVERDEIS
CAYMANIS
8096
CAYMANIS
CENTRALAFREP
1007
CENTRALAFREP
CHAD
1008
CHAD
CHILE
56
CHILE
CHINA
86
CHINA
CHRISTMASIS
1009
CHRISTMASIS
COCOSIS
1009
COCOSIS
COLOMBIA
57
COLOMBIA
COMOROS
1010
COMOROS
CONGO
1011
CONGO
COOKIS
1012
COOKIS
COSTARICA
506
COSTARICA
CUBA
005
CUBA
CYPRUS
357
CYPRUS
CZECHOSLOVAKIA
42
CZECHOSLOVAKIA
DENMARK
45
DENMARK
DJIBOUTI
1013
DJIBOUTI
DOMINICA
8097
DOMINICA
DOMINCANREP
8098
DOMINCANREP
EASTERIS
1014
EASTERIS
ECUADOR
593
ECUADOR
EGYPT
20
EGYPT
ELSALVADOR
503
ELSALVADOR
EQGUINEA
1015
EQGUINEA
ETHIOPIA
251
ETHIOPIA
FALKLANDIS
1016
FALKLANDIS
FAEROEIS
298
FAEROEIS
FIJIISLANDS
679
FIJIISLANDS
FINLAND
358
FINLAND
FRANCE
33
FRANCE
FRANTILLES
596
FRANTILLES
FRGUIANA
594
FRGUIANA
FRPOLYNEISA
689
FRPOLYNEISA
FUTANAIS
1043
FUTANAIS
GABON
241
GABON
GAMBIA
220
GAMBIA
GERMANY
49
GERMANY
GHANA
233
GHANA
GIBRALTER
350
GIBRALTER
GREECE
30
GREECE
GREENLAND
299
GREENLAND
GRENADA
8099
GRENADA
GRENEDINES
8015
GRENEDINES
GUADELOUPE
590
GUADELOUPE
GUAM
671
GUAM
GUANTANAMOBAY
5399
GUANTANAMOBAY
GUATEMALA
502
GUATEMALA
GUINEA
224
GUINEA
GUINEABISSAU
1017
GUINEABISSAU
GUYANA
592
GUYANA
HAITI
509
HAITI
HONDURAS
504
HONDURAS
HONGKONG
852
HONGKONG
HUNGARY
36
HUNGARY
ICELAND
354
ICELAND
INDIA
91
INDIA
INDONESIA
62
INDONESIA
IRAN
98
IRAN
IRAQ
964
IRAQ
IRELAND
353
IRELAND
ISRAEL
972
ISRAEL
ITALY
39
ITALY
IVORYCOAST
225
IVORYCOAST
JAMAICA
8010
JAMAICA
JAPAN
81
JAPAN
JORDAN
962
JORDAN
KENYA
254
KENYA
KIRIBATI
1018
KIRIBATI
KOREA
82
KOREA
KUWAIT
965
KUWAIT
LAOS
1019
LAOS
LEBANON
1020
LEBANON
LIBERIA
231
LIBERIA
LIBYA
218
LIBYA
LIECHTENSTEIN
41
LIECHTENSTEIN
LUXENBOURG
352
LUXENBOURG
MACAO
853
MACAO
MADAGASCAR
1021
MADAGASCAR
MALAWI
265
MALAWI
MALAYSIA
60
MALAYSIA
MALDIVES
960
MALDIVES
MALI
1022
MALI
MALTA
356
MALTA
MARSHALLIS
692
MARSHALLIS
MAURITANIA
1023
MAURITANIA
MAURITIUS
230
MAURITIUS
MEXICO
3
MEXICO
MICRONESIA
691
MICRONESIA
MIQUELON
508
MIQUELON
MONACO
33
MONACO
MONGOLIA
1024
MONGOLIA
MONTSERRAT
8011
MONTSERRAT
MOROCCO
212
MOROCCO
MOZAMBIQUE
1025
MOZAMBIQUE
NAMIBIA
264
NAMIBIA
NAURU
1026
NAURU
NEPAL
977
NEPAL
NETHERLANDS
31
NETHERLANDS
NETHANTILLES
599
NETHANTILLES
NEVIS
8012
NEVIS
NEWCALEDONIA
687
NEWCALEDONIA
NEWZEALAND
64
NEWZEALAND
NICARAGUA
505
NICARAGUA
NIGER
227
NIGER
NIGERIA
234
NIGERIA
NIUE
1027
NIUE
NORFOLKI
1028
NORFOLKI
NORWAY
47
NORWAY
OMAN
968
OMAN
PAKISTAN
92
PAKISTAN
PALAU
1029
PALAU
PANAMA
507
PANAMA
PARAGUAY
595
PARAGUAY
PERU
51
PERU
PHILLIPPINES
63
PHILLIPPINES
PITCAIRNIS
1030
PITCAIRNIS
PNEWGUINEA
675
PNEWGUINEA
POLAND
48
POLAND
PORTUGAL
351
PORTUGAL
QATAR
974
QATAR
REUNIONI
1031
REUNIONI
ROMANIA
40
ROMANIA
RWANDA
250
RWANDA
SAIPAN
670
SAIPAN
SANMARINO
39
SANMARINO
SAOTOME
1033
SAOTOME
SAUDIARABIA
966
SAUDIARABIA
SENEGAL
221
SENEGAL
SEYCHELLESIS
1034
SEYCHELLESIS
SIERRALEONE
1035
SIERRALEONE
SINGAPORE
65
SINGAPORE
SOLOMONIS
1036
SOLOMONIS
SOMALI
1037
SOMALI
SOUTHAFRICA
27
SOUTHAFRICA
SPAIN
34
SPAIN
SRILANKA
94
SRILANKA
STHELENA
1032
STHELENA
STKITTS
8013
STKITTS
STLUCIA
8014
STLUCIA
STPIERRE
508
STPIERRE
STVINCENT
8015
STVINCENT
SUDAN
1038
SUDAN
SURINAME
597
SURINAME
SWAZILAND
268
SWAZILAND
SWEDEN
46
SWEDEN
SWITZERLAND
41
SWITZERLAND
SYRIA
1039
SYRIA
TAIWAN
886
TAIWAN
TANZANIA
255
TANZANIA
THAILAND
66
THAILAND
TOBAGO
8016
TOBAGO
TOGO
228
TOGO
TONGAIS
676
TONGAIS
TRINIDAD
8016
TRINIDAD
TUNISIA
216
TUNISIA
TURKEY
90
TURKEY
TURKSCAICOS
8017
TURKSCAICOS
TUVALU
1040
TUVALU
UGANDA
256
UGANDA
USSR
7
USSR
UAEMIRATES
971
UAEMIRATES
UNITEDKINGDOM
44
UNITEDKINGDOM
USA
1
USA
URUGUAY
598
URUGUAY
VANUATU
1041
VANUATU
VATICANCITY
39
VATICANCITY
VENEZUELA
58
VENEZUELA
WAKE
104
WAKE
WALLISIS
1043
WALLISIS
WESTERNSAHARA
1044
WESTERNSAHARA
WESTERNSAMOA
1045
WESTERNSAMOA
YEMEN
1046
YEMEN
YUGOSLAVIA
38
YUGOSLAVIA
ZAIRE
243
ZAIRE
ZAMBIA
260
ZAMBIA
ZIMBABWE
263
ZIMBABWE
ALBANIA
355
ALBANIA
ARMENIA
374
ARMENIA
AZERBAIJAN
994
AZERBAIJAN
BELARUS
375
BELARUS
BOSNIAHERZGO
387
BOSNIAHERZGO
CAMBODIA
855
CAMBODIA
CROATIA
385
CROATIA
CZECHREPUBLIC
420
CZECHREPUBLIC
DIEGOGARCIA
246
DIEGOGARCIA
ERITREA
291
ERITREA
ESTONIA
372
ESTONIA
GEORGIA
995
GEORGIA
LATVIA
371
LATVIA
LESOTHO
266
LESOTHO
LITHUANIA
370
LITHUANIA
MACEDONIA
389
MACEDONIA
MAYOTTEIS
269
MAYOTTEIS
MOLDOVA
373
MOLDOVA
MYANMAR
95
MYANMAR
NORTHKOREA
850
NORTHKOREA
PUERTORICO
787
PUERTORICO
RUSSIA
7
RUSSIA
SERBIA
381
SERBIA
SLOVAKIA
421
SLOVAKIA
SLOVENIA
386
SLOVENIA
SOUTHKOREA
82
SOUTHKOREA
UKRAINE
380
UKRAINE
USVIRGINIS
340
USVIRGINIS
VIETNAM
84
VIETNAM


ImGearDeskewStatus Enumeration

32-bit
64-bit
CF
P

Description:

Status of the deskew operation.

Declaration:

public enum ImGearDeskewStatus

Values:

Name
Value
Description
DISABLED
3
Deskew engine not enabled
FAIL
2
Deskew failed
REPORTONLY
1
Deskew information only
SUCCESS
0
Image successfully deskewed


ImGearDeviceEvents Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration determines the device event.

Declaration:

public enum ImGearDeviceEvents

Values:

Name
Value
Description
CHECKAUTOMATICCAPTURE
0
The automatic capture settings on the device have been changed by the user.
CHECKBATTERY
1
The status of the battery has changed.
CHECKDEVICEONLINE
2
The device has been turned off and on.
CHECKFLASH
3
The flash setting on the device has been changed by the user.
CHECKPOWERSUPPLY
4
The power supply has been changed
CHECKRESOLUTION
5
The x/y resolution setting on the device has been changed by the user.
CUSTOMEVENTS
0x8000
Baseline for events specific to a given Source.
DEVICEADDED
6
The user has added a device (for instance a memory card in a digital camera).
DEVICEOFFLINE
7
A device has become unavailable, but has not been removed.
DEVICEREADY
8
The device is ready to capture an image.
DEVICEREMOVED
9
The user has removed a device.
IMAGECAPTURED
10
The user has captured an image to the device's internal storage.
IMAGEDELETED
11
The user has removed an image from the device's internal storage.
LAMPFAILURE
12
The device's light source has failed.
PAPERDOUBLEFEED
13
Two or more sheets of paper have been fed together.
PAPERJAM
14
The device's document feeder has jammed.
POWERSAVE
15
The device has powered down to save energy.
POWERSAVENOTIFY
16
The device is about to power down to save energy.


ImGearDuplex Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration determines whether the scanner supports duplex.

Declaration:

public enum ImGearDuplex

Values:

Name
Value
Description
ONEPASSDUPLEX
1
One duplex is supported.
TWOPASSDUPLEX
2
Two duplex is supported.
NONE
0
No duplex support


ImGearFeederAlignment Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration determines which special actions application may need to take when negotiating frames with the Source.

Declaration:

public enum ImGearFeederAlignment

Values:

Name
Value
Description
CENTER
2
The alignment is centered. This means that the paper will be fed in the middle of the ICAP_PHYSICALWIDTH of the device.
LEFT
1
The alignment is to the left.
NONE
0
The alignment is free-floating.
RIGHT
3
The alignment is to the right.


ImGearFeederOrder Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration determines the order of scanning.

Declaration:

public enum ImGearFeederOrder

Values:

Name
Value
Description
FIRSTPAGEFIRST
0
Feeder starts with the top of the first page.
LASTPAGEFIRST
1
Feeder starts with the top of the last page.


ImGearFileSystem Enumeration

32-bit
64-bit
CF
P

Description:

ImGearCapabilities Enumeration.CAP_FILESYSTEM capability values.

Declaration:

public enum ImGearFileSystem

Values:

Name
Value
Description
FILESYSTEM
0
RECURSIVEDELETE
1


ImGearFileType Enumeration

32-bit
64-bit
CF
P

Description:

File types in the device's file system.

Declaration:

public enum ImGearFileType

Values:

Name
Value
Description
CAMERA
0
CAMERATOP
1
CAMERABOTTOM
2
CAMERAPREVIEW
3
DOMAIN
4
HOST
5
DIRECTORY
6
IMAGE
7
UNKNOWN
8


ImGearFilterType Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration determines the color characteristic of the subtractive filter applied to the image data.

Declaration:

public enum ImGearFilterType
{

Values:

Name
Value
Description
FT_RED
0
Red
FT_GREEN
1
Green
FT_BLUE
2
Blue
FT_NONE
3
None
FT_WHITE
4
White
FT_CYAN
5
Cyan
FT_MAGENTA
6
Magenta
FT_YELLOW
7
Yellow
FT_BLACK
8
Black


ImGearFlashUsed Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration determines which flash the image was acquired to use.

Declaration:

public enum ImGearFlashUsed

Values:

Name
Value
Description
AUTO
3
Auto flash
NONE
0
No flash
OFF
1
Flash is off
ON
2
Flash is on
REDEYE
4
Redeye flash


ImGearFlipRotation Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration determines the orientation of images that flip orientation of every other image.

Declaration:

public enum ImGearFlipRotation

Values:

Name
Value
Description
BOOK
0
The images to be scanned are viewed in book form, flipping each page from left to right or right to left.
FANFOLD
1
The images to be scanned are viewed in fanfold paper style, flipping each page up or down.


ImGearJobControl Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration determines how the job can be processed.

Declaration:

public enum ImGearJobControl

Values:

Name
Value
Description
JSIC
1
Detect and include job separator and continue scanning.
JSIS
2
Detect and include job separator and stop scanning.
JSXC
3
Detect and exclude job separator and continue scanning.
JSXS
4
Detect and exclude job separator and stop scanning.
NONE
0
No job control.


ImGearJPEGQuality Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration specifies the kind of JPEG quantization tables that tradeoff quality versus compressed image size.

Declaration:

public enum ImGearJPEGQuality

Values:

Name
Value
Description
HIGH
-1
Write-only; implies high quality; the images display the maximum quality that produces any kind of meaningful compression. Note that images at this setting are still considered to be lossy.
LOW
-3
Write-only; implies low quality; the images are at the maximum compression recommended by the Source.
MEDIUM
-2
Write-only; implies medium quality; the images are at the balance point between good compression and good images. This is an arbitrary setting on the part of the Source writer that is expected to best represent their device. This is the value that Applications are most encouraged to use.
UNKNOWN
-4
Read-only; must be the setting for this capability if the user sets the JPEG compression tables using DAT_JPEGCOMPRESSION, and the Source is not able to map the
selected tables to a specific percentage of quality.


ImGearImageFilter Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration determines the algorithm used to improve the quality of the image.

ImGearCapabilities Enumeration.ICAP_IMAGEFILTER capability values.

Declaration:

public enum ImGearImageFilter

Values:

Name
Value
Description
AUTO
1
Auto
BANDPASS
3
Bandpass algorithm. Good for improving text.
FINELINE
4
Fineline algorithm.
HIGHPASS
4
Highpass algorithm. Good for improving fine lines.
LOWPASS
2
Lowpass algorithm. Good for halftone images.
NONE
0
No algorithm
TEXT
3
Text algorithm.


ImGearLanguages Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration specifies language of the scanned document.

Declaration:

public enum ImGearLanguages

Values:

Name
Value
Description
DAN
0
Danish
DUT
1
Dutch
ENG
2
International English
FCF
3
French Canadian
FIN
4
Finnish
FRN
5
French
GER
6
German
ICE
7
Icelandic
ITN
8
Italian
NOR
9
Norwegian
POR
10
Portuguese
SPA
11
Spanish
SWE
12
Swedish
USA
13
U.S. English
USERLOCALE
-1
AFRIKAANS
14
ALBANIA
15
ARABIC
16
ARABIC_ALGERIA
17
ARABIC_BAHRAIN
18
ARABIC_EGYPT
19
ARABIC_IRAQ
20
ARABIC_JORDAN
21
ARABIC_KUWAIT
22
ARABIC_LEBANON
23
ARABIC_LIBYA
24
ARABIC_MOROCCO
25
ARABIC_OMAN
26
ARABIC_QATAR
27
ARABIC_SAUDIARABIA
28
ARABIC_SYRIA
29
ARABIC_TUNISIA
30
ARABIC_UAE
31
United Arabic Emirates
ARABIC_YEMEN
32
BASQUE
33
BYELORUSSIAN
34
BULGARIAN
35
CATALAN
36
CHINESE
37
CHINESE_HONGKONG
38
CHINESE_PRC
39
People's Republic of China
CHINESE_SINGAPORE
40
CHINESE_SIMPLIFIED
41
CHINESE_TAIWAN
42
CHINESE_TRADITIONAL
43
CROATIA
44
CZECH
45
DUTCH_BELGIAN
46
ENGLISH
ENG
ENGLISH_AUSTRALIAN
47
ENGLISH_CANADIAN
48
ENGLISH_IRELAND
49
ENGLISH_NEWZEALAND
50
ENGLISH_SOUTHAFRICA
51
ENGLISH_UK
52
ENGLISH_USA
USA
ESTONIAN
53
FAEROESE
54
FARSI
55
FINNISH
FIN
FRENCH
FRN
FRENCH_BELGIAN
56
FRENCH_CANADIAN
FCF
FRENCH_LUXEMBOURG
57
FRENCH_SWISS
58
GERMAN
GER
GERMAN_AUSTRIAN
59
GERMAN_LUXEMBOURG
60
GERMAN_LIECHTENSTEIN
61
GERMAN_SWISS
62
GREEK
63
HEBREW
64
HUNGARIAN
65
ICELANDIC
ICE
INDONESIAN
66
ITALIAN
ITN
ITALIAN_SWISS
67
JAPANESE
68
KOREAN
69
KOREAN_JOHAB
70
LATVIAN
71
LITHUANIAN
72
NORWEGIAN
NOR
NORWEGIAN_BOKMAL
73
NORWEGIAN_NYNORSK
74
POLISH
75
PORTUGUESE
POR
PORTUGUESE_BRAZIL
76
ROMANIAN
77
RUSSIAN
78
SERBIAN_LATIN
79
SLOVAK
80
SLOVENIAN
81
SPANISH
SPA
SPANISH_MEXICAN
82
SPANISH_MODERN
83
SWEDISH
SWE
THAI
84
TURKISH
85
UKRANIAN
86
ASSAMESE
87
BENGALI
88
BIHARI
89
BODO
90
DOGRI
91
GUJARATI
92
HARYANVI
93
HINDI
94
KANNADA
95
KASHMIRI
96
MALAYALAM
97
MARATHI
98
MARWARI
99
MEGHALAYAN
100
MIZO
101
NAGA
102
ORISSI
103
PUNJABI
104
PUSHTU
105
SERBIAN_CYRILLIC
106
SIKKIMI
107
SWEDISH_FINLAND
108
TAMIL
109
TELUGU
110
TRIPURI
111
URDU
112
VIETNAMESE
113


ImGearLightPath Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration determines whether the image is captured transmissively or reflectively.

Declaration:

public enum ImGearLightPath

Values:

Name
Value
Description
REFLECTIVE
0
Reflective capture
TRANSMISSIVE
1
Transmissive capture


ImGearLightSource Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration determines the general color characteristic of the light source used to acquire the image.

Declaration:

public enum ImGearLightSource

Values:

Name
Value
Description
BLUE
2
Blue
GREEN
1
Green
IR
6
IR
NONE
3
None
RED
0
Red
UV
5
UV
WHITE
4
White


ImGearMessages Enumeration

32-bit
64-bit
CF
P

Description:

Capability control messages.

Declaration:

public enum ImGearMessages

Values:

Name
Value
Description
GET
0x0001
Get one or more values
GETCURRENT
0x0002
Get current value
GETDEFAULT
0x0003
Get default (e.g., power up) value
SET
0x0006
Set one or more values
RESET
0x0007
Set current value to default value


ImGearNoiseFilter Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration selects the algorithm used to remove noise. ImGearCapabilities.ICAP_NOISEFILTER capability values.

Declaration:

public enum ImGearNoiseFilter

Values:

Name
Value
Description
AUTO
1
Auto
LONEPIXEL
2
Lonepixel
MAJORITYRULE
3
Majority rule
NONE
0
None


ImGearOrientation Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration determines which edge of the "paper" the image's "top" is aligned with. ImGearCapabilities Enumeration.ICAP_ORIENTATION capability values.

Declaration:

public enum ImGearOrientation

Values:

Name
Value
Description
LANDSCAPE
3
equals ROT270
PORTRAIT
0
equals ROT0
ROT0
0
normal orientation
ROT180
2
Rotated 180 degrees clockwise
ROT270
3
Rotated 270 degrees clockwise
ROT90
1
Rotated 90 degrees clockwise


ImGearOverscanModes Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration determines the overscanning mode. ImGearCapabilities.ICAP_OVERSCAN capability values.

Declaration:

public enum ImGearOverscanModes

Values:

Name
Value
Description
ALL
4
Overscan all
AUTO
1
Auto mode
LEFTRIGHT
3
Left-Right mode
NONE
0
None
TOPBOTTOM
2
Top-Bottom mode


ImGearPatchCode Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration determines prioritized list of patch code types dictating the order in which patch codes will be sought.

Declaration:

public enum ImGearPatchCode

Values:

Name
Value
Description
PATCH1
0
Patch 1
PATCH2
1
Patch 2
PATCH3
2
Patch 3
PATCH4
3
Patch 4
PATCH6
4
Patch 6
PATCHT
5
Patch T


ImGearPixelFlavor Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration correctly describes the sense of the pixel whose numeric value is zero (minimum data value). ImGearCapabilities Enumeration.ICAP_PIXELFLAVOR capability values.

Declaration:

public enum ImGearPixelFlavor

Values:

Name
Value
Description
CHOCOLATE
0
Zero pixel represents darkest shade
VANILLA
1
Zero pixel represents lightest shade


ImGearPixelType Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration specifies the type of pixel data that a Source is capable of acquiring (for example, black and white, gray, RGB, etc.). ImGearCapabilities Enumeration.ICAP_PIXELTYPE capability values.

Declaration:

public enum ImGearPixelType

Values:

Name
Value
Description
BW
0
Black and white
CIEXYZ
8
CIEXYZ
CMY
4
CMY
CMYK
5
CMYK
GRAY
1
GRAY
PALETTE
3
PALETTE
RGB
2
RGB
YUV
6
YUV
YUVK
7
YUVK


ImGearPowerSupply Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration reports the kinds of power available to the device. ImGearCapabilities Enumeration.CAP_POWERSUPPLY capability values.

Declaration:

public enum ImGearPowerSupply

Values:

Name
Value
Description
EXTERNAL
0
External supply
BATTERY
1
Battery supply


ImGearPrinter Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration determines the printer devices being used by application.

Imprinters are used to print data on documents at the time of scanning, and may be used for any purpose. Endorsers are more specific in nature, stamping some kind of proof of scanning on the document.

Top/Bottom refer to duplex devices, and indicate if the printer is writing on the top or the bottom of the sheet of paper. Simplex devices use the top settings.

Before/After indicates whether printing occurs before or after the sheet of paper has been scanned.

ImGearCapabilities Enumeration.CAP_PRINTER capability values.

Declaration:

public enum ImGearPrinter

Values:

Name
Value
Description
ENDORSERBOTTOMAFTER
7
Endorser bottom/after
ENDORSERBOTTOMBEFORE
6
Endorser bottom/before
ENDORSERTOPAFTER
5
Endorser top/after
ENDORSERTOPBEFORE
4
Endorser top/before
IMPRINTERBOTTOMAFTER
3
Imprinter bottom/after
IMPRINTERBOTTOMBEFORE
2
Imprinter bottom/before
IMPRINTERTOPAFTER
1
Imprinter top/after
IMPRINTERTOPBEFORE
0
Imprinter top/before


ImGearPrinterModes Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration specifies current printer mode. ImGearCapabilities Enumeration.CAP_PRINTERMODE capability values.

Declaration:

public enum ImGearPrinterModes
{
SINGLESTRING = 0,
MULTISTRING = 1,
COMPOUNDSTRING = 2
}

Values:

Name
Value
Description
COMPOUNDSTRING
2
The printed string will consist of a compound of a String followed by a value followed by a suffix string.
MULTISTRING
1
The printed text will consist of an enumerated list of strings to be printed in order.
SINGLESTRING
0
The printed text will consist of a single string.


ImGearSupportedSizes Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration specifies the size(s) the Source can/should use to acquire image data.

ImGearCapabilities Enumeration.ICAP_SUPPORTEDSIZES capability values.

Declaration:

public enum ImGearSupportedSizes

Values:

Name
Value
Description
NONE
0
NONE
A4LETTER
1
A4LETTER
B5LETTER
2
B5LETTER
USLETTER
3
USLETTER
USLEGAL
4
USLEGAL
A5
5
A5
B4
6
B4
B6
7
B6
USLEDGER
9
USLEDGER
USEXECUTIVE
10
USEXECUTIVE
A3
11
A3
B3
12
B3
A6
13
A6
C4
14
C4
C5
15
C5
C6
16
C6
A04
17
A04
A02
18
A02
A0
19
A0
A1
20
A1
A2
21
A2
A4
A4LETTER
A4
A7
22
A7
A8
23
A8
A9
24
A9
A10
25
A10
ISOB0
26
ISOB0
ISOB1
27
ISOB1
ISOB2
28
ISOB2
ISOB3
B3
ISOB3
ISOB4
B4
ISOB4
ISOB5
29
ISOB5
ISOB6
B6
ISOB6
ISOB7
30
ISOB7
ISOB8
31
ISOB8
ISOB9
32
ISOB9
ISOB10
33
ISOB10
JISB0
34
JISB0
JISB1
35
JISB1
JISB2
36
JISB2
JISB3
37
JISB3
JISB4
38
JISB4
JISB5
B5LETTER
JISB5
JISB6
39
JISB6
JISB7
40
JISB7
JISB8
41
JISB8
JISB9
42
JISB9
JISB10
43
JISB10
C0
44
C0
C1
45
C1
C2
46
C2
C3
47
C3
C7
48
C7
C8
49
C8
C9
50
C9
C10
51
C10
USSTATEMENT
52
USSTATEMENT
BUSINESSCARD
53
BUSINESSCARD


ImGearUnits Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration determines the unit of measure for all quantities.

ImGearCapabilities Enumeration.ICAP_UNITS capability values.

Declaration:

public enum ImGearUnits

Values:

Name
Value
Description
CENTIMETERS
1
Centimeters
INCHES
0
Inches
PICAS
2
Picas
PIXELS
5
Pixels
POINTS
3
Points
TWIPS
4
Twips


ImGearXferType Enumeration

32-bit
64-bit
CF
P

Description:

This enumeration determines which type of transfer mechanisms the application and Source have in common.

ImGearCapabilities Enumeration.ICAP_XFERMECH capability values.

Declaration:

public enum ImGearXferType

Values:

Name
Value
Description
FILE
1
File type
FILE2
3
File to File type
MEMORY
2
Memory type
NATIVE
0
Native type


ImageGear.Vector Namespace

ImageGear.Vector Namespace

32-bit
64-bit
CF
P
P

Description:

ImageGear.Vector namespace provides objects and methods for displaying, rasterizing, and manipulating vector drawings. Such drawings can be loaded from vector files such as DWF, DWG/DXF, DGN, CGM, HPGL, and U3D.

Declaration:

namespace ImageGear.Vector

Members:

Classes:
Name
Description
ImGear3DVisualization Class
Generates isosurface for 3D visualization.
ImGear3DVisualizationVerifier Class
Provides a function CanApplyGenerateIsosurface() to determine whether an ImGearDocument Class can be used to calculate isosurface from.
ImGearIsosurfaceOptions Class
Collection of parameters for the isosurface algorithm.
ImGearVectorData Class
Collection of vector entities, layers, and views
ImGearVectorEntity Class
This object represents the base class for all entities.
ImGearVectorEntityArc Class
This entity represents an elliptical arc that is defined by radii and angles.
ImGearVectorEntityBeziercurve Class
This object represents a Bezier curve that is defined by control points and curve degree.
ImGearVectorEntityBeziersurface Class
This entity represents a Bezier surface.
ImGearVectorEntityBlock Class
This entity includes a container with other entities.
ImGearVectorEntityConnection Class
This is a special entity that is used to connect end and start points of neighboring entities in the figure entity container.
ImGearVectorEntityCont Class
This object represents an entity container.
ImGearVectorEntityEasyline Class
This entity represents a line specified by start and end points.
ImGearVectorEntityEasysurface Class
This entity represents a surface that is drawn exactly by its control points.
ImGearVectorEntityEllipse Class
This entity represents an ellipse.
ImGearVectorEntityFigure Class
This entity can contain several regions.
ImGearVectorEntityGeometry Class
Represents a set of drawing primitives such as points, independent line segments, connected line segments, independent and connected triangles, independent and connected quadrilaterals, polygons.
ImGearVectorEntityNURBScurve Class
This entity represents a non-uniform rational B-spline curve.
ImGearVectorEntityNURBSsurface Class
This entity represents a non-uniform rational B-spline surface.
ImGearVectorEntityPolyline Class
This entity represents a polyline.
ImGearVectorEntityPolylineEx Class
This entity represents an extended polyline.
ImGearVectorEntityRaster Class
This object represents a non-rectangular raster image.
ImGearVectorEntityText Class
This entity represents a text string.
ImGearVectorEntityViewport Class
This entity represents a viewport, that is, rectangular or non-rectangular window where the viewport content is displayed with the specified layout.
ImGearVectorFilltype Class
This object represents the fill type for drawing filled objects.
ImGearVectorFloatCont Class
This object represents the container for floating point values.
ImGearVectorFont Class
This object represents a font used for text drawing.
ImGearVectorGradient Class
This class is used as the base for particular gradient filling classes.
ImGearVectorGradientLinear Class
This class represents a linear gradient object.
ImGearVectorGradientRadial Class
This class represents a radial gradient object.
ImGearVectorHatch Class
This object represents a vector hatch.
ImGearVectorHatchline Class
This object represents a line segment for a vector hatch.
ImGearVectorLayer Class
This object contains drawing attributes that can be applied to multiple entities.
ImGearVectorLightSource Class
This object implements a light source.
ImGearVectorLinetype Class
This object represents a line type.
ImGearVectorObject Class
Base class for all vector objects.
ImGearVectorRotation Class
This object provides rotation operations for entities.
ImGearVectorTextObject Class
This object is used by ImGearVectorEntityText entity to keep parts of the text string with the same font attributes such as font width, height, char base angle, color and so on.
ImGearVectorVertexCont Class
This object represents a vertex container.
ImGearVectorView Class
vector view - point of view to the set of entities
ImGearVectPage Class
vector page with background and associated ImGearVectData vector drawing

Structures:
Name
Description
ImGearVectorColor Structure
RGBA color for vector drawing
ImGearVectorColorEx Structure
Indexed color value for vector drawing
ImGearVectorMinMax Structure
min and max coordinates of views and entities
ImGearVectorPoint2D Structure
2D point structure
ImGearVectorPoint3D Structure
3D point structure
ImGearVectorPoint3DEx Structure
Declares an extended three-dimentional point.
ImGearVectorVertex Structure
vertex (3D point with flags)

Enumerations:
Name
Description
ImGearVectAlignment Enumeration
Text alignment
ImGearVectArcCloseType Enumeration
How an arc is closed
ImGearVectAttrib Enumeration
Common entity attributes
ImGearVectAttrSource Enumeration
Source of the attribute
ImGearVectCullFace Enumeration
Specifies face culling modes.
ImGearVectDir Enumeration
Direction of rotate operations
ImGearVectEntities Enumeration
Vector entity types
ImGearVectFillMode Enumeration
Specifies the winding rule for the complete polygons.
ImGearVectFillPattern Enumeration
Fill style and pattern
ImGearVectGeometryType Enumeration
Specifies the type of geometry primitives.
ImGearVectGradientSpreadMethod Enumeration
Defines gradient spread methods.
ImGearVectGradientType Enumeration
Defines the types of gradient filling.
ImGearVectGraphics Enumeration
A graphics tool for vector data drawing
ImGearVectMeasurementUnits Enumeration
Contains measurement units used by vector drawings.
ImGearVectNURBSFlags Enumeration
Non-uniform rational Bi-spline flags
ImGearVectObjType Enumeration
Vector object types
ImGearVectTxtFlags Enumeration
Additional effects when drawing a text object
ImGearVectVertexData Enumeration
Vertex data constants

See Also:

Using ImageGear.Vector Namespace


ImageGear.Vector Namespace Classes

The ImageGear.Vector Namespace has the following class members:

Classes:
Name
Description
ImGear3DVisualization Class
Generates isosurface for 3D visualization.
ImGear3DVisualizationVerifier Class
Provides a function CanApplyGenerateIsosurface() to determine whether an ImGearDocument Class can be used to calculate isosurface from.
ImGearIsosurfaceOptions Class
Collection of parameters for the isosurface algorithm.
ImGearVectorData Class
Collection of vector entities, layers, and views
ImGearVectorEntity Class
This object represents the base class for all entities.
ImGearVectorEntityArc Class
This entity represents an elliptical arc that is defined by radii and angles.
ImGearVectorEntityBeziercurve Class
This object represents a Bezier curve that is defined by control points and curve degree.
ImGearVectorEntityBeziersurface Class
This entity represents a Bezier surface.
ImGearVectorEntityBlock Class
This entity includes a container with other entities.
ImGearVectorEntityConnection Class
This is a special entity that is used to connect end and start points of neighboring entities in the figure entity container.
ImGearVectorEntityCont Class
This object represents an entity container.
ImGearVectorEntityEasyline Class
This entity represents a line specified by start and end points.
ImGearVectorEntityEasysurface Class
This entity represents a surface that is drawn exactly by its control points.
ImGearVectorEntityEllipse Class
This entity represents an ellipse.
ImGearVectorEntityFigure Class
This entity can contain several regions.
ImGearVectorEntityGeometry Class
Represents a set of drawing primitives such as points, independent line segments, connected line segments, independent and connected triangles, independent and connected quadrilaterals, polygons.
ImGearVectorEntityNURBScurve Class
This entity represents a non-uniform rational B-spline curve.
ImGearVectorEntityNURBSsurface Class
This entity represents a non-uniform rational B-spline surface.
ImGearVectorEntityPolyline Class
This entity represents a polyline.
ImGearVectorEntityPolylineEx Class
This entity represents an extended polyline.
ImGearVectorEntityRaster Class
This object represents a non-rectangular raster image.
ImGearVectorEntityText Class
This entity represents a text string.
ImGearVectorEntityViewport Class
This entity represents a viewport, that is, rectangular or non-rectangular window where the viewport content is displayed with the specified layout.
ImGearVectorFilltype Class
This object represents the fill type for drawing filled objects.
ImGearVectorFloatCont Class
This object represents the container for floating point values.
ImGearVectorFont Class
This object represents a font used for text drawing.
ImGearVectorGradient Class
This class is used as the base for particular gradient filling classes.
ImGearVectorGradientLinear Class
Represents a linear gradient object.
ImGearVectorGradientRadial Class
Represents a radial gradient object.
ImGearVectorHatch Class
This object represents a vector hatch.
ImGearVectorHatchline Class
This object represents a line segment for a vector hatch.
ImGearVectorLayer Class
This object contains drawing attributes that can be applied to multiple entities.
ImGearVectorLightSource Class
This object implements a light source.
ImGearVectorLinetype Class
This object represents a line type.
ImGearVectorObject Class
Base class for all vector objects.
ImGearVectorRotation Class
This object provides rotation operations for entities.
ImGearVectorTextObject Class
This object is used by ImGearVectorEntityText entity to keep parts of the text string with the same font attributes such as font width, height, char base angle, color and so on.
ImGearVectorVertexCont Class
This object represents a vertex container.
ImGearVectorView Class
vector view - point of view to the set of entities
ImGearVectPage Class
vector page with background and associated ImGearVectData vector drawing


ImGear3DVisualization Class

32-bit
64-bit
CF
P
P

Description:

This object represents API to generate isosurface for 3D visualization.

Declaration:

public sealed class ImGear3DVisualization

Members:

Properties
Name
Description
Verifier Property
An object of type ImGear3DVisualizationVerifier.

Methods
Name
Description
GenerateIsosurface Method
This static function generates an isosurface for a 3D object.


ImGear3DVisualization Properties

The ImGear3DVisualization Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
Verifier Property
An object of type ImGear3DVisualizationVerifier.


Verifier Property

32-bit
64-bit
CF
P
P

Description:

This property represents an object of type ImGear3DVisualizationVerifier Class. This object can be used to verify whether an ImGearDocument Class can be used to calculate isosurface from.

Declaration:

public static ImageGear.Vector.ImGear3DVisualizationVerifier Verifier { get; }

Value:

N/A

Default value:

N/A

See Also:

ImGear3DVisualizationVerifier Class


ImGear3DVisualization Methods

The ImGear3DVisualization Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
GenerateIsosurface Method
This static function generates an isosurface for a 3D object.


GenerateIsosurface Method

32-bit
64-bit
CF
P
P

Description:

This method takes an ImGearDocument Class object and extracts the 3D surface into a vector page, based on the options specified by isoOptions.

Declaration:

public static ImageGear.Vector.ImGearVectPage
GenerateIsosurface(ImageGear.Core.ImGearDocument igDocument,
ImageGear.Vector.ImGearIsosurfaceOptions isoOptions)

Parameters:

Name
Type
Description
igDocument
ImGearDocument Class
An ImGearDocument Class object, which has slices of images in a 3D series stacked together in the desired order.
isoOptions
ImGearIsosurfaceOptions Class
An ImGearIsosurfaceOptions Class object, which has all the calculation options for isosurface algorithm.

Return value:

Returns an ImGearVectPage Class object, which contains data for the resulted isosurface.

See Also:

ImGearDocument Class

ImGearIsosurfaceOptions Class

ImGearVectPage Class


ImGear3DVisualizationVerifier Class

32-bit
64-bit
CF
P
P

Description:

This object provides a function CanApplyGenerateIsosurface Method () to determine whether an ImGearDocument Class can be used to calculate isosurface from.

Declaration:

public sealed class ImGear3DVisualizationVerifier

Members:

Methods
Name
Description
CanApplyGenerateIsosurface Method
Determines whether an ImGearDocument Class can be used to calculate isosurface from.


ImGear3DVisualizationVerifier Methods

The ImGear3DVisualizationVerifier Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
CanApplyGenerateIsosurface Method
Determines whether an ImGearDocument Class can be used to calculate isosurface from.


CanApplyGenerateIsosurface Method

32-bit
64-bit
CF
P
P

Description:

This method takes an ImGearDocument Class object and determines whether GenerateIsosurface Method can be applied to it to calculate an isosurface.

It checks to make sure the following are all satisfied:

  • The ImGearDocument Class object is valid.
  • There is more than one page in the ImGearDocument Class object.
  • The pages in the ImGearDocument Class object all have the same width and height.
  • The pages in the ImGearDocument Class object all have the same color space.
  • The pages in the ImGearDocument Class object all have the same bits per channel.
  • The "bits per channel" in the pages is one of the supported depths, i.e., 8, 16, or 32.

Declaration:

public bool CanApplyGenerateIsosurface(ImageGear.Core.ImGearDocument igDocument)

Parameters:

Name
Type
Description
igDocument
ImGearDocument Class
The ImGearDocument Class object to determine whether GenerateIsosurface Method () can be applied to.

Return value:

True if GenerateIsosurface Method () can be applied, False - otherwise.

See Also:

ImGearDocument Class


ImGearIsosurfaceOptions Class

32-bit
64-bit
CF
P
P

Description:

This object is a collection of parameters for the isosurface algorithm.

Declaration:

public sealed class ImGearIsosurfaceOptions

Members:

Constructors
Name
Description
ImGearIsosurfaceOptions Constructor
Initializes a new instance of the ImGearIsoSurfaceOptions class.

Properties
Name
Description
HighExcluRange Property
Upper limit of exclusion region.
IsAddCoverSlices Property
Flag for adding cover-up slices at the ends.
IsDecimateY Property
Flag for decimating Y direction when considering surface depth, in effect only if IsLimitDepth is true.
IsDecimateZ Property
Flag for decimating Z direction when considering surface depth, in effect only if IsLimitDepth is true.
IsDoNorms Property
Flag for calculating normals along with vertices.
IsFlipNorms Property
Flag for flipping normals after calculation.
IsLimitDepth Property
Flag for limiting surface depth.
IsoValue Property
Intensity value of pixels on the isosurface.
LowExcluRange Property
Lower limit of exclusion region.
SurfaceDepth Property
Depth of the surface, in effect only if IsLimitDepth is true.
YDecimFactor Property
Decimation factor in Y direction, in effect only if both IsLimitDepth and IsDecimateY are true.
ZDecimFactor Property
Decimation factor in Z direction, in effect only if both IsLimitDepth and IsDecimateZ are true.


ImGearIsosurfaceOptions Constructors

The ImGearIsosurfaceOptions Class of the ImageGear.Vector Namespace has the following constructors:

Constructors
Name
Description
ImGearIsosurfaceOptions Constructor
Initializes a new instance of the ImGearIsosurfaceOptions Class class.


ImGearIsosurfaceOptions Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor initializes a new instance of the ImGearIsosurfaceOptions Class class, with default values set for all the properties of the class.

Declaration:

public ImGearIsosurfaceOptions()

Return Value:

A new instance of the ImGearIsosurfaceOptions Class class.

See Also:

ImGearIsosurfaceOptions Class


ImGearIsosurfaceOptions Properties

The ImGearIsosurfaceOptions Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
HighExcluRange Property
Upper limit of exclusion region.
IsAddCoverSlices Property
Flag for adding cover-up slices at the ends.
IsDecimateY Property
Flag for decimating Y direction when considering surface depth, in effect only if IsLimitDepth is true.
IsDecimateZ Property
Flag for decimating Z direction when considering surface depth, in effect only if IsLimitDepth is true.
IsDoNorms Property
Flag for calculating normals along with vertices.
IsFlipNorms Property
Flag for flipping normals after calculation.
IsLimitDepth Property
Flag for limiting surface depth.
IsoValue Property
Intensity value of pixels on the isosurface.
LowExcluRange Property
Lower limit of exclusion region.
SurfaceDepth Property
Depth of the surface, in effect only if IsLimitDepth is true.
YDecimFactor Property
Decimation factor in Y direction, in effect only if both IsLimitDepth and IsDecimateY are true.
ZDecimFactor Property
Decimation factor in Z direction, in effect only if both IsLimitDepth and IsDecimateZ are true.


HighExcluRange Property

32-bit
64-bit
CF
P
P

Description:

This property represents an upper limit of the exclusion range.

Declaration:

public int HighExcluRange { set; get; }

Value:

Any valid integer value.

Default value:

0


IsAddCoverSlices Property

32-bit
64-bit
CF
P
P

Description:

This property represents the flag to indicate whether to add cover-up slices at the ends.

Declaration:

public bool IsAddCoverSlices { get; set; }

Value:

True, False

Default value:

True


IsDecimateY Property

32-bit
64-bit
CF
P
P

Description:

This property represents the flag to indicate whether to decimate in Y direction when considering surface depth.

NOTE: In effect only if IsLimitDepth Property property of the same ImGearIsosurfaceOptions Class object is True.

Declaration:

public bool IsDecimateY { get; set; }

Value:

True, False

Default value:

False


IsDecimateZ Property

32-bit
64-bit
CF
P
P

Description:

This property represents the flag to indicate whether to decimate in Z direction when considering surface depth.

NOTE: In effect only if IsLimitDepth Property property of the same ImGearIsosurfaceOptions Class object is True.

Declaration:

public bool IsDecimateZ { get; set; }

Value:

True, False

Default value:

False


IsDoNorms Property

32-bit
64-bit
CF
P
P

Description:

This property represents the flag to indicate whether to calculate normals along with vertices.

Declaration:

public bool IsDoNorms { get; set; }

Value:

True, False

Default value:

True


IsFlipNorms Property

32-bit
64-bit
CF
P
P

Description:

This property represents the flag to indicate whether to flip normals after calculation.

Declaration:

public bool IsFlipNorms { get; set; }

Value:

True, False

Default value:

False


IsLimitDepth Property

32-bit
64-bit
CF
P
P

Description:

This property represents the flag to indicate whether to limit the surface depth.

Declaration:

public bool IsLimitDepth { get; set; }

Value:

True, False

Default value:

False


IsoValue Property

32-bit
64-bit
CF
P
P

Description:

This property represents intensity value of pixels on the isosurface.

Declaration:

public double IsoValue { get; set; }

Value:

Any valid double value.

Default value:

120.0


LowExcluRange Property

32-bit
64-bit
CF
P
P

Description:

This property represents the lower limit of the exclusion range.

Declaration:

public int LowExcluRange { get; set; }

Value:

Any valid integer value.

Default value:

0


SurfaceDepth Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the depth of the isosurface.

NOTE: In effect only if IsLimitDepth Property property of the same ImGearIsosurfaceOptions Class object is True.

Declaration:

public int SurfaceDepth { get; set; }

Value:

Any integer value.

Default value:

20


YDecimFactor Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the decimation factor in Y direction.

NOTE: In effect only if both IsLimitDepth Property and IsDecimateY Property properties of the same ImGearIsosurfaceOptions Class object are True.

Declaration:

public int YDecimFactor { get; set; }

Value:

Any integer value.

Default value:

1


ZDecimFactor Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the decimation factor in Z direction.

NOTE: In effect only if both IsLimitDepth Property and IsDecimateZ Property properties of the same ImGearIsosurfaceOptions Class object are True.

Declaration:

public int ZDecimFactor { get; set; }

Value:

Any integer value.

Default value:

1


ImGearVectorData Class

32-bit
64-bit
CF
P
P

Description:

This object represents a collection of vector entities, layers, and views. Vector data is created when reading vector files such as DWG/DXF, DGN, CGM, HPGL, and U3D. Vector data is attached to ImGearVectPage Class and draws its content itself during display operations.

Declaration:

public class ImGearVectorData

Members:

Constructors
Name
Description
ImGearVectorData Constructor
Initializes a new instance of the ImGearVectorData Class class

Properties
Name
Description
ActiveViewIndex Property
Gets/sets index of the active view.
FilltypeCount Property
Returns a count of fill types in the fill type container.
FontCount Property
Returns total count of fonts in the internal container.
GraphicsType Property
Gets/sets type of graphics used for displaying vector objects.
LayerCount Property
Returns total count of layers in the internal container.
LinetypeCount Property
Returns total count of line types in the internal line type container.
SelectionThickness Property
Gets/sets thickness used for displaying entities that are selected.
Transparency Property
Gets/sets a flag showing whether or not transparency is enabled.
Units Property
Gets/sets measurement units used by the vector drawing.
UnitsFactor Property
Gets/sets units factor.
ViewCount Property
Gets total count of views in the drawing.

Methods
Name
Description
CreateEntity Method
Creates an entity of the specified type.
CreateFont Method
Creates a font by typeface and weight.
CreateGradientFilltype Method
Creates new fill type with the gradient object specified by gradient name and type.
CreateLayer Method
Creates a new layer.
CreateView Method
Creates a new view and adds it to the end of the view container.
DeleteView Method
Removes the specified view from the internal view container and destroys it.
Dispose Method
This is a standard .NET Dispose method.
FindEntityIndex Method
Looks for an entity with the specified ID.
FindFont Method
Looks for the font with the specified typeface, weight and vector flag.
FindLayer Method
Looks for the layer by the name.
GetActualGraphics Method
Returns type of graphics used for displaying vector objects.
GetContent Method
Returns main content of the drawing.
GetEntity Method
Returns an entity from the specified position in the internal container.
GetFilltype Method
Returns fill type by its position in the internal container.
GetFilltypeIndex Method
Returns index of the fill type in the internal container by fill pattern.
GetFont Method
Returns font by its position in the internal container.
GetFontIndex Method
Returns index of the font in the internal font container.
GetGradientFilltypeIndex Method
Returns index of the fill type associated with the specified gradient object.
GetHatchFilltypeIndex Method
Returns index of hatch fill type by the hatch name.
GetLayer Method
Returns layer by its position in the internal container.
GetLinetype Method
Returns line type by its position in the internal container.
GetLinetypeIndex Method
Returns index of the fill type in the internal container by the line pattern and pattern length.
GetSelection Method
Looks for the entity that corresponds to the device coordinates x and y.
GetSelectionColor Method
Returns color that is used for displaying entities being selected.
GetView Method
Returns view from the specified index.
Init Method
Initializes vector content to an empty drawing.
SetSelectionColor Method
Sets color used for displaying entities that are selected.


ImGearVectorData Constructors

The ImGearVectorData Class of the ImageGear.Vector Namespace has the following constructors:

Constructors
Name
Description
ImGearVectorData Constructor
Initializes a new instance of the ImGearVectorData Class class


ImGearVectorData Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor initializes a new instance of the ImGearVectorData Class class.

Declaration:

public ImGearVectorData()

Return Value:

A new instance of the ImGearVectorData Class class.

See Also:

ImGearVectorData Class


ImGearVectorData Properties

The ImGearVectorData Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
ActiveViewIndex Property
Gets/sets index of the active view.
FilltypeCount Property
Returns a count of fill types in the fill type container.
FontCount Property
Returns total count of fonts in the internal container.
GraphicsType Property
Gets/sets type of graphics used for displaying vector objects.
LayerCount Property
Returns total count of layers in the internal container.
LinetypeCount Property
Returns total count of line types in the internal line type container.
SelectionThickness Property
Gets/sets thickness used for displaying entities that are selected.
Transparency Property
Gets/sets a flag showing whether or not transparency is enabled.
Units Property
Gets/sets measurement units used by the vector drawing.
UnitsFactor Property
Gets/sets units factor.
ViewCount Property
Gets total count of views in the drawing.


ActiveViewIndex Property

32-bit
64-bit
CF
P
P

Description:

This property provides the index of the active view. Several views can exist but only the active one is used for display.

Declaration:

public int ActiveViewIndex { get; set }

Value:

Any positive integer value.

Default value:

0


FilltypeCount Property

32-bit
64-bit
CF
P
P

Description:

This property returns the total count of fill types in the internal filltype container.

Declaration:

public int FilltypeCount { get }

Value:

Non-negative integer value.

Default value:

N/A


FontCount Property

32-bit
64-bit
CF
P
P

Description:

This property returns the total count of fonts in the internal container.

Declaration:

public int FontCount { get }

Value:

Non-negative integer number.

Default value:

N/A


GraphicsType Property

32-bit
64-bit
CF
P
P

Description:

This property provides the type of graphics used for displaying vector objects.

Declaration:

public ImageGear.Vector.ImGearVectGraphics GraphicsType { set; get; }

Value:

Any value of ImGearVectGraphics Enumeration.

Default value:

AUTO (uses OpenGL if possible, otherwise WinAPI)

See Also:

ImGearVectGraphics Enumeration


LayerCount Property

32-bit
64-bit
CF
P
P

Description:

This property returns the total count of layers in the internal container.

Declaration:

public int LayerCount { get }

Value:

Any integer number.

Default value:

N/A


LinetypeCount Property

32-bit
64-bit
CF
P
P

Description:

This property returns the total line type count in the internal line type container.

Declaration:

public int LinetypeCount { get }

Value:

Non-negative integer value.

Default value:

N/A


SelectionThickness Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the thickness that is used for displaying selected entities.

Declaration:

public float SelectionThickness { get, set }

Value:

Non-negative floating-point value

Default value:

0


Transparency Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets a flag showing whether or not transparency is enabled. If transparency is enabled, all non-transparent objects are drawn first.

Declaration:

public bool Transparency{ get, set }

Value:

True - transparency is enabled, False - otherwise.

Default value:

False


Units Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets measurement units used by the vector drawing. Can be useful in determining physical size of objects in the drawing. Many vector files do not define measurement units, so this property will return UNKNOWN.

Declaration:

public ImageGear.Vector.ImGearVectMeasurementUnits Units { set; get; }

Value:

ImGearVectMeasurementUnits Enumeration value.

See Also:

ImGearVectMeasurementUnits Enumeration


UnitsFactor Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets units factor, a multiplier of unit values used for informational purposes.

Declaration:

public double UnitsFactor { set; get; }

Value:

Any double value.


ViewCount Property

32-bit
64-bit
CF
P
P

Description:

This property provides the total count of views in the drawing.

Declaration:

public int ViewCount { get }

Value:

Non-negative integer value.


ImGearVectorData Methods

The ImGearVectorData Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
CreateEntity Method
Creates an entity of the specified type.
CreateFont Method
Creates a font by typeface and weight.
CreateGradientFilltype Method
Creates new fill type with the gradient object specified by gradient name and type.
CreateLayer Method
Creates a new layer.
CreateView Method
Creates a new view and adds it to the end of the view container.
DeleteView Method
Removes the specified view from the internal view container and destroys it.
Dispose Method
This is a standard .NET Dispose method.
FindEntityIndex Method
Looks for an entity with the specified ID.
FindFont Method
Looks for the font with the specified typeface, weight and vector flag.
FindLayer Method
Looks for the layer by the name.
GetActualGraphics Method
Returns type of graphics used for displaying vector objects.
GetContent Method
Returns main content of the drawing.
GetEntity Method
Returns an entity from the specified position in the internal container.
GetFilltype Method
Returns fill type by its position in the internal container.
GetFilltypeIndex Method
Returns index of the fill type in the internal container by fill pattern.
GetFont Method
Returns font by its position in the internal container.
GetFontIndex Method
Returns index of the font in the internal font container.
GetGradientFilltypeIndex Method
Returns index of the fill type associated with the specified gradient object.
GetHatchFilltypeIndex Method
Returns index of hatch fill type by the hatch name.
GetLayer Method
Returns layer by its position in the internal container.
GetLinetype Method
Returns line type by its position in the internal container.
GetLinetypeIndex Method
Returns index of the fill type in the internal container by the line pattern and pattern length.
GetSelection Method
Looks for the entity that corresponds to the device coordinates x and y.
GetSelectionColor Method
Returns color that is used for displaying entities being selected.
GetView Method
Returns view from the specified index.
Init Method
Initializes vector content to an empty drawing.
SetSelectionColor Method
Sets color used for displaying entities that are selected.


CreateEntity Method

32-bit
64-bit
CF
P
P

Description:

This method creates an entity of the specified type.

Declaration:

public ImageGear.Vector.ImGearVectorEntity
CreateEntity(ImageGear.Vector.ImGearVectEntities Type)

Parameters:

Name
Type
Description
Type
ImGearVectEntities Enumeration
Type of the entity to be created.

Return value:

The new instance of ImGearVectorEntity Class.

See Also:

ImGearVectorEntity Class

ImGearVectEntities Enumeration


CreateFont Method

32-bit
64-bit
CF
P
P

Description:

This method creates a font by typeface and weight. If IsVector is true then an empty vector font is created. The user is responsible for creating every glyph of such a font. Otherwise, a complete TrueType font is created.

Declaration:

public ImageGear.Vector.ImGearVectorFont CreateFont(string Typeface, int Weight, bool
IsVector)

Parameters:

Name
Type
Description
Typeface
string
Typeface of the font.
Weight
int
Font weight
IsVector
bool
Flag that tells whether Vector or TrueType font is to be created.

Return value:

The new instance of ImGearVectorFont Class.

See Also:

ImGearVectorFont Class


CreateGradientFilltype Method

32-bit
64-bit
CF
P
P

Description:

Creates new fill type with the gradient object specified by gradient name and type. Returns an index of newly created fill type.

Declaration:

public Int32 CreateGradientFilltype(string GradientName, ImGearVectGradientType
GradientType)

Parameters:

Name
Type
Description
GradientName
string
Name of the gradient fill type to be created.
GradientType
ImGearVectGradientType Enumeration
Gradient fill type.

Return value:

Index of the new gradient fill type.


CreateLayer Method

32-bit
64-bit
CF
P
P

Description:

This method creates a new layer.

Declaration:

public ImageGear.Vector.ImGearVectorLayer CreateLayer(string LayerName)

Parameters:

Name
Type
Description
LayerName
string
The name of the newly created layer.

Return value:

A new instance of ImGearVectorLayer Class object.


CreateView Method

32-bit
64-bit
CF
P
P

Description:

This method creates a new View and adds it to the end of the view container.

Declaration:

public ImageGear.Vector.ImGearVectorView CreateView()

Return value:

The new instance of ImGearVectorView Class.

See Also:

DeleteView Method


DeleteView Method

32-bit
64-bit
CF
P
P

Description:

This method removes the specified View from the internal view container and destroys it.

Declaration:

public void DeleteView(int Index)

Parameters:

Name
Type
Description
Index
int
Index of View to be removed.

Return value:

None.

See Also:

CreateView Method

ImGearVectorView Class


Dispose Method

32-bit
64-bit
CF
P
P

Description:

This is a standard .NET Dispose method. To minimize memory usage, it should be called before the vector page content is replaced or deleted.

Declaration:

public void Dispose()

Return value:

None.


FindEntityIndex Method

32-bit
64-bit
CF
P
P

Description:

This method looks for an entity with the specified ID.

Declaration:

public int FindEntityIndex(string ID, int StartIndex)

Parameters:

Name
Type
Description
ID
string
ID of the entity to find.
StartIndex
int
Start index in the internal container.

Return value:

Index of the entity found, or -1 if no entity could be found.


FindFont Method

32-bit
64-bit
CF
P
P

Description:

This method looks for the font with the specified typeface, weight and vector flag.

Declaration:

public ImageGear.Vector.ImGearVectorFont FindFont(string Typeface, int Weight, bool
IsVector)

Parameters:

Name
Type
Description
Typeface
string
Typeface of the font
Weight
int
Font weight
IsVector
bool
Flag that tells whether font to look for is Vector or TrueType

Return value:

Newly created ImGearVectorFont Class object or NULL.


FindLayer Method

32-bit
64-bit
CF
P
P

Description:

This method looks for a layer by name.

Declaration:

public ImageGear.Vector.ImGearVectorLayer FindLayer(string LayerName)

Parameters:

Name
Type
Description
LayerName
string
Name of the layer to be looked for.

Return value:

The new instance of ImGearVectorLayer Class.


GetActualGraphics Method

32-bit
64-bit
CF
P
P

Description:

This method returns the type of graphics used for displaying vector objects. The following graphics types are available:

  • OPENGL - OpenGL graphics is used.
  • WINAPI - Windows GDI graphics is used.
  • AUTO - the type of graphics (OpenGL or Windows GDI) is defined according to the device context features.

Declaration:

public ImageGear.Vector.ImGearVectGraphics GetActualGraphics(System.IntPtr hContext)

Parameters:

Name
Type
Description
hContext
System.IntPtr
Device context the actual graphics is determined for.

Return value:

Any value of ImGearVectGraphics Enumeration.


GetContent Method

32-bit
64-bit
CF
P
P

Description:

This method returns the main content of the drawing. This is always a block.

Declaration:

public ImageGear.Vector.ImGearVectorEntity GetContent()

Return value:

The new instance of ImGearVectorEntity Class.


GetEntity Method

32-bit
64-bit
CF
P
P

Description:

This method returns an entity from the specified position in the internal container.

Declaration:

public ImageGear.Vector.ImGearVectorEntity GetEntity(int Index)

Parameters:

Name
Type
Description
Index
int
Position of the entity to be returned.

Return value:

The new instance of ImGearVectorEntity Class.


GetFilltype Method

32-bit
64-bit
CF
P
P

Description:

This method returns fill type by its position in the internal container.

Declaration:

public ImageGear.Vector.ImGearVectorFilltype GetFilltype(int Index)

Parameters:

Name
Type
Description
Index
int
Fill type index.

Return value:

Any value of ImGearVectorFilltype Class.


GetFilltypeIndex Method

32-bit
64-bit
CF
P
P

Description:

This method returns an index of the fill type in the internal container by fill pattern. If a fill type with such attributes does not exist, it is created.

Declaration:

public int GetFilltypeIndex(ImageGear.Vector.ImGearVectFillPattern Pattern)

Parameters:

Name
Type
Description
Pattern
ImGearVectFillPattern Enumeration
Fill pattern.

Return value:

Any integer number.

See Also:

ImGearVectFillPattern Enumeration


GetFont Method

32-bit
64-bit
CF
P
P

Description:

This method returns a font by its position in the internal conatiner.

Declaration:

public ImageGear.Vector.ImGearVectorFont GetFont(int Index)

Parameters:

Name
Type
Description
Index
int
Position of the font.

Return value:

New instance of ImGearVectorFont Class.


GetFontIndex Method

32-bit
64-bit
CF
P
P

Description:

This method returns an index of the specified font in the internal font container.

Declaration:

public int GetFontIndex(ImageGear.Vector.ImGearVectorFont Font)

Parameters:

Name
Type
Description
Font
ImGearVectorFont Class
Font object the index is looked for

Return value:

Integer value

See Also:

ImGearVectorFont Class


GetGradientFilltypeIndex Method

32-bit
64-bit
CF
P
P

Description:

Returns index of the fill type associated with the specified gradient object.

Declaration:

public Int32 GetGradientFilltypeIndex(string GradientName)

Parameters:

Name
Type
Description
GradientName
string
Name of the fill type.

Return value:

Index of the fill type.


GetHatchFilltypeIndex Method

32-bit
64-bit
CF
P
P

Description:

This method returns an index of the hatch fill type by the hatch name.

Declaration:

public int GetHatchFilltypeIndex(string HatchName)

Parameters:

Name
Type
Description
HatchName
string
Name of the hatch.

Return value:

Integer value.


GetLayer Method

32-bit
64-bit
CF
P
P

Description:

This method returns a layer by its position in the internal container.

Declaration:

public ImageGear.Vector.ImGearVectorLayer GetLayer(int Index)

Parameters:

Name
Type
Description
Index
int
Index of the layer.

Return value:

The new instance of ImGearVectorLayer Class.


GetLinetype Method

32-bit
64-bit
CF
P
P

Description:

This method returns a line type by its position in the internal container.

Declaration:

public ImageGear.Vector.ImGearVectorLinetype GetLinetype(int Index)

Parameters:

Name
Type
Description
Index
int
Index of the line type to be returned.

Return value:

New instance of ImGearVectorLinetype Class object.


GetLinetypeIndex Method

32-bit
64-bit
CF
P
P

Description:

This method returns the index of the line type in the internal container by the line pattern and pattern length. If a line type with such attributes does not exist, it is created.

Declaration:

public int GetLinetypeIndex(int Pattern, float Patternlen)

Parameters:

Name
Type
Description
Pattern
int
Fill pattern
Patternlen
float
Absolute length of the pattern

Return value:

Any integer value.


GetSelection Method

32-bit
64-bit
CF
P
P

Description:

This method looks for the entity that corresponds to the device coordinates x and y. If the entity has been found, it is placed in the returned entity container together with all including blocks. If no entity has been found, the returned entity container is empty.

Declaration:

public ImageGear.Vector.ImGearVectorEntityCont GetSelection(int x, int y)

Parameters:

Name
Type
Description
x
int
X device coordinate
y
int
Y device coordinate

Return value:

The new instance of ImGearVectorEntityCont Class.


GetSelectionColor Method

32-bit
64-bit
CF
P
P

Description:

This method returns the color that is used for displaying entities being selected.

Declaration:

public ImageGear.Vector.ImGearVectorColor GetSelectionColor()

Return value:

New instance of ImGearVectorColor Structure object.


GetView Method

32-bit
64-bit
CF
P
P

Description:

This method returns a view from the specified index.

Declaration:

public ImageGear.Vector.ImGearVectorView GetView(int Index)

Parameters:

Name
Type
Description
Index
int
Index of view to be returned.

Return value:

ImGearVectorView Class object representing the view at the specified index.


Init Method

32-bit
64-bit
CF
P
P

Description:

This method initializes vector content to an empty drawing, discarding any vector entities if they are present.

Declaration:

public void Init()

Return value:

None.


SetSelectionColor Method

32-bit
64-bit
CF
P
P

Description:

This method sets the color that is used for displaying selected entities.

Declaration:

public void SetSelectionColor(ImageGear.Vector.ImGearVectorColor SelectionColor)

Parameters:

Name
Type
Description
SelectionColor
ImGearVectorColor Structure
Selection color.

Return value:

None.

See Also:

ImGearVectorColor Structure


ImGearVectorEntity Class

32-bit
64-bit
CF
P
P

Description:

This object represents the base class for all entities. It provides access to the common entity features.

Declaration:

public class ImGearVectorEntity : ImageGear.Vector.ImGearVectorObject

Members:

Properties
Name
Description
AttribFlags Property
Returns flags indicating which optional attributes are presented for the entity.
Deleted Property
Gets/sets a flag specifying whether or not an entity is marked as deleted.
Id Property
Returns an entity identifier.
Layer Property
Gets/sets a handle to the layer attached to the entity.
Selected Property
Gets/sets a flag indicating whether an entity is selected or not.
Type Property
Returns a type of the entity.

Methods
Name
Description
CopyTo Method
Copies one entity to another. hEntitySrc and hEntityDst must be valid entity handles.
GetDrawColor Method
Returns draw color of the entity if the corresponding attribute flag is set
GetFillColor Method
Returns fill color of the entity if the corresponding attribute flag is set
GetFilltypeIndex Method
Returns index of the entity fill type if the corresponding attribute flag is set
GetLineThickness Method
Returns entity line thickness if the corresponding attribute flag is set
GetLinetypeIndex Method
Returns index of the entity line type if the corresponding attribute flag is set
GetMatrix Method
Returns a transformation matrix of the entity
GetMinMax Method
Calculates a cube completely including an entity.
Move Method
Moves the entity according to the specified vector
RemoveAttrib Method
Removes and destroys an attribute.
Rotate Method
Rotates the entity about to the specified vector on the specified angle.
Scale Method
Scales the entity according to the specified scale factors
SetDirty Method
Marks an entity as dirty.
SetDrawColor Method
Sets an entity draw color
SetFillColor Method
Sets an entity fill color
SetFilltypeIndex Method
Sets an entity fill type index
SetLineThickness Method
Sets an entity line thickness
SetLinetypeIndex Method
Sets an entity line type index
SetMatrix Method
Sets a transformation matrix of the entity

See Also:

ImGearVectorObject Class


ImGearVectorEntity Properties

The ImGearVectorEntity Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
AttribFlags Property
Returns flags indicating which optional attributes are presented for the entity.
Deleted Property
Gets/sets a flag specifying whether or not an entity is marked as deleted.
Id Property
Returns an entity identifier.
Layer Property
Gets/sets a handle to the layer attached to the entity.
Selected Property
Gets/sets a flag indicating whether an entity is selected or not.
Type Property
Returns a type of the entity.


AttribFlags Property

32-bit
64-bit
CF
P
P

Description:

This property returns flags indicating which optional attributes are present for the entity. An entity may have different optional attributes such as draw color, fill color, line type, fill type, offset, rotation, scale and position. These attributes do not exist until they are created.

Declaration:

public int AttribFlags{ get }

Value:

"Or" combination of ImGearVectAttrib Enumeration values or 0.

Default value:

N/A


Deleted Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets a flag specifying whether or not the entity is marked as deleted. When an entity is marked as deleted, it is not actually removed but becomes invisible. The user can query all entities and undo delete operation. Deleted entities are not saved in files.

Declaration:

public bool Deleted { get, set }

Value:

True, False.

Default value:

False


Id Property

32-bit
64-bit
CF
P
P

Description:

This property returns the identifier of the entity. This identifier is always unique inside the same vector data object.

Declaration:

public string Id{ get, set }

Value:

Any string Id.

Default value:

N/A


Layer Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets a layer attached to the entity (that is, the layer the entity belongs to). If there is no layer associated with the entity, the property is set to null.

Declaration:

public ImGearVectorLayer Layer{ get, set }

Value:

The new instance of ImGearVectorLayer Class object.


Selected Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets a flag indicating whether or not the entity is selected. A selected entity is displayed in the color that is set as selection color for the vector data object.

Declaration:

public bool Selected{ get, set }

Value:

True - entity is selected, False - otherwise.


Type Property

32-bit
64-bit
CF
P
P

Description:

This property returns the type of the entity.

Declaration:

public ImGearVectEntities Type{ get }

Value:

Any value of ImGearVectEntities Enumeration.

Default value:

N/A


ImGearVectorEntity Methods

The ImGearVectorEntity Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
CopyTo Method
Copies one entity to another. hEntitySrc and hEntityDst must be valid entity handles.
GetDrawColor Method
Returns draw color of the entity if the corresponding attribute flag is set
GetFillColor Method
Returns fill color of the entity if the corresponding attribute flag is set
GetFilltypeIndex Method
Returns index of the entity fill type if the corresponding attribute flag is set
GetLineThickness Method
Returns entity line thickness if the corresponding attribute flag is set
GetLinetypeIndex Method
Returns index of the entity line type if the corresponding attribute flag is set
GetMatrix Method
Returns a transformation matrix of the entity
GetMinMax Method
Calculates a cube completely including an entity.
Move Method
Moves the entity according to the specified vector
RemoveAttrib Method
Removes and destroys an attribute.
Rotate Method
Rotates the entity about to the specified vector on the specified angle.
Scale Method
Scales the entity according to the specified scale factors
SetDirty Method
Marks an entity as dirty.
SetDrawColor Method
Sets an entity draw color
SetFillColor Method
Sets an entity fill color
SetFilltypeIndex Method
Sets an entity fill type index
SetLineThickness Method
Sets an entity line thickness
SetLinetypeIndex Method
Sets an entity line type index
SetMatrix Method
Sets a transformation matrix of the entity


CopyTo Method

32-bit
64-bit
CF
P
P

Description:

This method copies one entity to another. Dest must be a valid entity. It may belong to a different vector data object.

Declaration:

public void CopyTo(ImageGear.Vector.ImGearVectorEntity Dest)

Parameters:

Name
Type
Description
Dest
ImGearVectorEntity Class
The destination entity to copy to.

Return value:

None.

See Also:

ImGearVectorEntity Class


GetDrawColor Method

32-bit
64-bit
CF
P
P

Description:

This method returns the draw color of the entity. If the m_flags field of the returned extended color object is -3, the actual color is defined by the entity layer. In case of -2 it is obtained from the block. Otherwise, the actual m_color value is used.

Declaration:

public ImageGear.Vector.ImGearVectorColorEx GetDrawColor()

Return value:

Newly created ImGearVectorColorEx Structure object or NULL.


GetFillColor Method

32-bit
64-bit
CF
P
P

Description:

This method returns the fill color of the entity. If the m_flags field of the returned extended color object is -3, the actual color is defined by the entity layer. In case of -2 it is obtained from the block. Otherwise, the actual m_color value is used.

Declaration:

public ImageGear.Vector.ImGearVectorColorEx GetFillColor()

Return value:

Newly created ImGearVectorColorEx Structure object or NULL.


GetFilltypeIndex Method

32-bit
64-bit
CF
P
P

Description:

This method returns the fill type index of the entity. If this value is equal to -3, then the actual fill type index is defined by the entity layer. In case of -2 the index should be obtained from the block. Othervise, the value is used as actual fill type index.

Actual fill type can be retrieved by the index from the vectdata.GetFillType method, where vectdata is a vector data object.

Declaration:

public int GetFilltypeIndex()

Return value:

-3,-2 or non-negative value.


GetLineThickness Method

32-bit
64-bit
CF
P
P

Description:

This method returns the line thickness used when drawing the entity.

Declaration:

public float GetLineThickness()

Return value:

Non-negative floating-point value


GetLinetypeIndex Method

32-bit
64-bit
CF
P
P

Description:

This method returns the line type index of the entity. If this value is equal to -3, then the actual line type index is defined by the entity layer. In case of -2 the index should be obtained from the block. Othervise, the value is used as actual line type index.

Actual line type can be retrieved by the index from the vectdata.GetLineType method, where vectdata is a vector data object.

Declaration:

public int GetLinetypeIndex()

Return value:

-3,-2 or non-negative value

See Also:

SetLinetypeIndex Method


GetMatrix Method

32-bit
64-bit
CF
P
P

Description:

This method returns a transformation matrix of the entity. The matrix consists of 16 floating-point values and aligned by columns, that is:

a11 a21 a31 a41

a12 a22 a32 a42

a13 a23 a33 a43

a14 a24 a34 a44

Declaration:

public float[] GetMatrix()

Return value:

An array with 16 floating-point values.


GetMinMax Method

32-bit
64-bit
CF
P
P

Description:

This method calculates a bounding box which completely includes the entity.

Declaration:

public ImageGear.Vector.ImGearVectorMinMax GetMinMax()

Return value:

The new instance of ImGearVectorMinMax Structure object.


Move Method

32-bit
64-bit
CF
P
P

Description:

This method moves the entity according to the specified vector. If bBefore parameter is True then moving is performed before other transformations (that is, the current matrix is multiplied by the move matrix). Otherwise, the move matrix is multiplied by the current matrix.

Declaration:

public void Move(float fX, float fY, float fZ, bool bBefore)

Parameters:

Name
Type
Description
fX
float
X offset
fY
float
Y offset
fZ
float
Z offset
bBefore
bool
Flag that defines an order of transformation (see description for details)

Return value:

None.


RemoveAttrib Method

32-bit
64-bit
CF
P
P

Description:

This method removes and destroys an attribute.

Declaration:

public void RemoveAttrib(ImageGear.Vector.ImGearVectAttrib nAttrib)

Parameters:

Name
Type
Description
nAttrib
ImGearVectAttrib Enumeration
Attribute being removed

Return value:

None.

See Also:

ImGearVectAttrib Enumeration


Rotate Method

32-bit
64-bit
CF
P
P

Description:

This method rotates the entity about to the specified vector on the specified angle. If bBefore parameter is True then rotation is performed before other transformations (that is, the current matrix is multiplied by the rotation matrix). Otherwise, the rotation matrix is multiplied by the current matrix.

Declaration:

public void Rotate(float fAngle, float fX, float fY, float fZ, bool bBefore)

Parameters:

Name
Type
Description
fAngle
float
Rotation angle in radians
fX
float
X coordinate of the rotation vector
fY
float
Y coordinate of the rotation vector
fZ
float
Z coordinate of the rotation vector
bBefore
bool
Flag that defines an order of transformation (see description for details)

Return value:

None.


Scale Method

32-bit
64-bit
CF
P
P

Description:

This method scales the entity according to the specified scale vector. If bBefore parameter is True then scaling is performed before other transformations (that is, the current matrix is multiplied by the scale matrix). Otherwise, the scale matrix is multiplied by the current matrix.

Declaration:

public void Scale(float fX, float fY, float fZ, bool bBefore)

Parameters:

Name
Type
Description
fX
float
X scale factor
fY
float
Y scale factor
fZ
float
Z scale factor
bBefore
bool
Flag that defines an order of transformation (see description for details)

Return value:

None.


SetDirty Method

32-bit
64-bit
CF
P
P

Description:

This method marks the entity as dirty. Some entities contain intermediate data which is calculated only once and used directly for entity drawing. This is done for high performance. The user must call this function every time when any changes in the entity are done.

Declaration:

public void SetDirty()

Return value:

None.


SetDrawColor Method

32-bit
64-bit
CF
P
P

Description:

This method sets draw color for the entity. See GetDrawColor Method for possible flag values.

Declaration:

public void SetDrawColor(ImageGear.Vector.ImGearVectorColorEx color)

Parameters:

Name
Type
Description
color
ImGearVectorColorEx Structure
New draw color to be set.

Return value:

None.

See Also:

ImGearVectorColorEx Structure


SetFillColor Method

32-bit
64-bit
CF
P
P

Description:

This method sets the fill color for the entity. See GetFillColor Method for possible flag values.

Declaration:

public void SetFillColor(ImageGear.Vector.ImGearVectorColorEx color)

Parameters:

Name
Type
Description
color
ImGearVectorColorEx Structure
New fill color to be set.

Return value:

None.

See Also:

ImGearVectorColorEx Structure


SetFilltypeIndex Method

32-bit
64-bit
CF
P
P

Description:

This method sets the fill type index for an entity. See GetFilltypeIndex Method for possible values.

Declaration:

public void SetFilltypeIndex(int index)

Parameters:

Name
Type
Description
index
int
New fill type index to be set.

Return value:

None.


SetLineThickness Method

32-bit
64-bit
CF
P
P

Description:

This method sets the line thickness for an entity.

Declaration:

public void SetLineThickness(float thickness)

Parameters:

Name
Type
Description
thickness
float
New thickness to be set.

Return value:

None.


SetLinetypeIndex Method

32-bit
64-bit
CF
P
P

Description:

This method sets the line type index for an entity. See GetLineIndex for possible values.

Declaration:

public void SetLinetypeIndex(int index)

Parameters:

Name
Type
Description
index
int
New line type index to be set.

Return value:

None.


SetMatrix Method

32-bit
64-bit
CF
P
P

Description:

This method sets a transformation matrix of the entity. The matrix consists of 16 floating-point values and aligned by columns, that is:

a11 a21 a31 a41

a12 a22 a32 a42

a13 a23 a33 a43

a14 a24 a34 a44

Declaration:

public void SetMatrix(float[] Matrix)

Parameters:

Name
Type
Description
Matrix
float[]
Matrix to be set.

Return value:

None.


ImGearVectorEntityArc Class

32-bit
64-bit
CF
P
P

Description:

This entity represents an elliptical arc that is defined by radii and angles.

Declaration:

public class ImGearVectorEntityArc : ImageGear.Vector.ImGearVectorEntity

Members:

Properties
Name
Description
CloseType Property
Gets/sets an arc close type.
Clockwise Property
Gets/sets drawing direction of the elliptical arc.
EndAngle Property
Gets/sets an end angle of the elliptical arc.
RadiusX Property
Gets/sets a radius of the elliptical arc along the x-axis.
RadiusY Property
Gets/sets a radius of the elliptical arc along the y-axis.
StartAngle Property
Gets/sets a start angle of the elliptical arc.

See Also:

ImGearVectorEntity Class


ImGearVectorEntityArc Properties

The ImGearVectorEntityArc Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
CloseType Property
Gets/sets an arc close type.
Clockwise Property
Gets/sets drawing direction of the elliptical arc.
EndAngle Property
Gets/sets an end angle of the elliptical arc.
RadiusX Property
Gets/sets a radius of the elliptical arc along the x-axis.
RadiusY Property
Gets/sets a radius of the elliptical arc along the y-axis.
StartAngle Property
Gets/sets a start angle of the elliptical arc.


CloseType Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets an arc close type. Arc can be unclosed, closed like sector and closed like segment.

Declaration:

public ImageGear.Vector.ImGearVectArcCloseType CloseType { set; get; }

Value:

Any value of ImGearVectArcCloseType Enumeration.

Default value:

N/A


Clockwise Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets drawing direction of the elliptical arc.

Declaration:

public bool Clockwise { get, set }

Value:

If Clockwise = True then drawing direction is clockwise, if False then counter clockwise.

Default value:

True


EndAngle Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets an end angle of the elliptical arc, in radians.

Declaration:

public float EndAngle { get, set }

Value:

Any floating-point value.

Default value:

N/A


RadiusX Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets a radius of the elliptical arc along the x-axis.

Declaration:

public float RadiusX { get, set }

Value:

Any positive value.

Default value:

N/A


RadiusY Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets a radius of the elliptical arc along the y-axis.

Declaration:

public float RadiusY { get, set }

Value:

Any positive value.

Default value:

N/A


StartAngle Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets a start angle of the elliptical arc in radians.

Declaration:

public float StartAngle { get, set }

Value:

Any value.

Default value:

N/A


ImGearVectorEntityBeziercurve Class

32-bit
64-bit
CF
P
P

Description:

This object represents a Bezier curve that is defined by control points and curve degree.

Declaration:

public class ImGearVectorEntityBeziercurve : ImageGear.Vector.ImGearVectorEntity

Members:

Properties
Name
Description
Degree Property
Gets/sets a degree of the Bezier interpolation.
Flags Property
Gets/sets different flags of the interpolated curve. If the curve is closed, the only possible flag is ImGearVectNURBSFlags Enumeration.MCLOSED.
PointCount Property
Returns the number of control points in the Bezier curve.
Step Property
Gets/sets the step of the Bezier interpolation.

Methods
Name
Description
AddPoint Method
Adds a point to the specified position on the curve.
GetPoint Method
Returns the specified point from the specified position on the curve.
GetVertexCont Method
Returns a Vertex Container with control points describing the Bezier curve.
SetPoint Method
Sets the specified point to the specified position on the curve.

See Also:

ImGearVectorEntity Class


ImGearVectorEntityBeziercurve Properties

The ImGearVectorEntityBeziercurve Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
Degree Property
Gets/sets a degree of the Bezier interpolation.
Flags Property
Gets/sets different flags of the interpolated curve. If the curve is closed, the only possible flag is ImGearVectNURBSFlags Enumeration.MCLOSED.
PointCount Property
Returns the number of control points in the Bezier curve.
Step Property
Gets/sets the step of the Bezier interpolation.


Degree Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets a degree of the Bezier interpolation.

Declaration:

public int Degree

Value:

2, 3, 4, ...

Default value:

3


Flags Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets different flags of the interpolated curve. If the curve is closed, the only possible flag is ImGearVectNURBSFlags Enumeration .MCLOSED.

Declaration:

public int Flags

Value:

Combination of ImGearVectNURBSFlags Enumeration values or 0.

Default value:

0


PointCount Property

32-bit
64-bit
CF
P
P

Description:

This property returns the number of control points in the Bezier curve.

Declaration:

public int PointCount { get; }

Value:

Any integer value.


Step Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the step of the Bezier interpolation.

Declaration:

public float Step

Value:

A value in the range 0..1.

Default value:

0.2


ImGearVectorEntityBeziercurve Methods

The ImGearVectorEntityBeziercurve Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
AddPoint Method
Adds a point to the specified position on the curve.
GetPoint Method
Returns the specified point from the specified position on the curve.
GetVertexCont Method
Returns a Vertex Container with control points describing the Bezier curve.
SetPoint Method
Sets the specified point to the specified position on the curve.


AddPoint Method

32-bit
64-bit
CF
P
P

Description:

This method adds a point to the specified position on the curve.

Declaration:

public void AddPoint(ImageGear.Vector.ImGearVectorPoint3D Point)

Parameters:

Name
Type
Description
Point
ImGearVectorPoint3D Structure
ImGearVectorPoint3D object with point coordinates.

Return value:

None

See Also:

ImGearVectorPoint3D Structure


GetPoint Method

32-bit
64-bit
CF
P
P

Description:

This method returns the specified point from the specified position on the curve.

Declaration:

public ImageGear.Vector.ImGearVectorPoint3D GetPoint(int Index)

Parameters:

Name
Type
Description
Index
int
Index of the point to be returned.

Return value:

ImGearVectorPoint3D Structure.

See Also:

ImGearVectorPoint3D Structure


GetVertexCont Method

32-bit
64-bit
CF
P
P

Description:

This method returns a Vertex Container with control points describing the Bezier curve.

Declaration:

public ImageGear.Vector.ImGearVectorVertexCont GetVertexCont()

Return value:

The new instance of ImGearVectorVertexCont Class.


SetPoint Method

32-bit
64-bit
CF
P
P

Description:

This method sets the specified point to the specified position on the curve.

Declaration:

public void SetPoint(int Index, ImageGear.Vector.ImGearVectorPoint3D Point)

Parameters:

Name
Type
Description
Index
int
Index of the point to be set.
Point
ImGearVectorPoint3D Structure
ImGearVectorPoint3D object with new point coordinates.

Return value:

None.

See Also:

ImGearVectorPoint3D Structure


ImGearVectorEntityBeziersurface Class

32-bit
64-bit
CF
P
P

Description:

This entity represents a Bezier surface.

Declaration:

public class ImGearVectorEntityBeziersurface :
ImageGear.Vector.ImGearVectorEntitySplinesurface

Members:

Properties
Name
Description
Flags Property
Gets/sets different surface flags
MDegree Property
Returns surface degree in M direction
MDimension Property
Returns surface dimension in M direction
MStep Property
Gets/sets interpolation step in M direction
NDegree Property
Returns surface degree in N direction
NDimension Property
Returns surface dimension in N direction
NStep Property
Gets/sets interpolation step in N direction

Methods
Name
Description
GetVertexCont Method
Returns a vertex container with control points
Init Method
Initializes the surface

See Also:

ImGearVectorEntity Class


ImGearVectorEntityBeziersurface Properties

The ImGearVectorEntityBeziersurface Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
Flags Property
Gets/sets different surface flags
MDegree Property
Returns surface degree in M direction
MDimension Property
Returns surface dimension in M direction
MStep Property
Gets/sets interpolation step in M direction
NDegree Property
Returns surface degree in N direction
NDimension Property
Returns surface dimension in N direction
NStep Property
Gets/sets interpolation step in N direction


Flags Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets different surface flags.

Declaration:

public int Flags { get, set }

Value:

Combination of ImGearVectNURBSFlags Enumeration or 0.

Default value:

0


MDegree Property

32-bit
64-bit
CF
P
P

Description:

This property returns the surface degree in M direction.

Declaration:

public int NDegree { get }

Value:

2, 3, 4...

Default value:

N/A


MDimension Property

32-bit
64-bit
CF
P
P

Description:

This property returns number of control points in M direction.

Declaration:

public int MDimension { get }

Value:

Non-negative integer value.

Default value:

N/A


MStep Property

32-bit
64-bit
CF
P
P

Description:

This property gets or sets interpolation step in M direction.

Declaration:

public float MStep { get, set }

Value:

Value in the range 0..1

Default value:

0.2


NDegree Property

32-bit
64-bit
CF
P
P

Description:

This property returns the surface degree in N direction.

Declaration:

public int NDegree { get }

Value:

2, 3, 4...

Default value:

N/A


NDimension Property

32-bit
64-bit
CF
P
P

Description:

This property returns number of control points in N direction.

Declaration:

public int NDimension { get }

Value:

Non-negative integer value

Default value:

N/A


NStep Property

32-bit
64-bit
CF
P
P

Description:

This property returns an interpolation step in N direction.

Declaration:

public override float NStep { set; get; }

Value:

Value in the range 0..1

Default value:

0.2


ImGearVectorEntityBeziersurface Methods

The ImGearVectorEntityBeziersurface Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
GetVertexCont Method
Returns a vertex container with control points
Init Method
Initializes the surface


GetVertexCont Method

32-bit
64-bit
CF
P
P

Description:

This method returns a row of control points.

Declaration:

public override ImageGear.Vector.ImGearVectorVertexCont GetVertexCont(int MColumn)

Parameters:

Name
Type
Description
MColumn
int
Row number to be returned.

Return value:

ImGearVectorVertexCont Class object with the row control points.


Init Method

32-bit
64-bit
CF
P
P

Description:

This method initializes the surface with the specified dimensions and specified degrees.

Declaration:

public override void Init(int mDimension, int nDimension, int mDegree, int nDegree)

Parameters:

Name
Type
Description
MDimension
int
Number of control points in M direction
NDimension
int
Number of control points in N direction
MDegree
int
Surface degree in M direction
Degree
int
Surface degree in N direction

Return value:

None.


ImGearVectorEntityBlock Class

32-bit
64-bit
CF
P
P

Description:

This entity includes a container with other entities.

Declaration:

public class ImGearVectorEntityBlock : ImageGear.Vector.ImGearVectorEntity

Members:

Properties
Name
Description
Name Property
Gets/sets block name.

Methods
Name
Description
GetEntityCont Method
Returns entity container with other entities.

See Also:

ImGearVectorEntity Class


ImGearVectorEntityBlock Properties

The ImGearVectorEntityBlock Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
Name Property
Gets/sets block name.


Name Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets block name.

Declaration:

public string Name { get, set }

Value:

Any string value.

Default value:

N/A


ImGearVectorEntityBlock Methods

The ImGearVectorEntityBlock Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
GetEntityCont Method
Returns entity container with other entities.


GetEntityCont Method

32-bit
64-bit
CF
P
P

Description:

This method returns the entity container for the block.

Declaration:

public ImGearVectorEntityCont GetEntityCont()

Return value:

The new instance of ImGearVectorEntityCont Class object.


ImGearVectorEntityConnection Class

32-bit
64-bit
CF
P
P

Description:

This is a special entity that is used to connect end and start points of neighboring entities in the figure entity container. It has no API.

Declaration:

public class ImGearVectorEntityConnection : ImageGear.Vector.ImGearVectorEntity

Members:

N/A

See Also:

ImGearVectorEntity Class


ImGearVectorEntityCont Class

32-bit
64-bit
CF
P
P

Description:

This object is used by blocks and figures to keep its entities. Entity container does not own entities, it only stores pointers to the entity objects.

Declaration:

public class ImGearVectorEntityCont : ImageGear.Vector.ImGearVectorObject

Members:

Properties
Name
Description
Count Property
Returns a count of entities in the entity container.

Methods
Name
Description
AddEntity Method
Adds an entity to the entity container.
GetEntity Method
Returns an entity specified by nIndex.
GetEntityIndex Method
Looks for the index by the entity handle.
RemoveEntity Method
Removes an entity specified by nIndex from the container.

See also:

ImGearVectorObject Class


ImGearVectorEntityCont Properties

The ImGearVectorEntityCont Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
Count Property
Returns a count of entities in the entity container.


Count Property

32-bit
64-bit
CF
P
P

Description:

This property returns a count of entities in the entity container.

Declaration:

public int Count{ get }

Value:

Any integer value.

Default value:

N/A


ImGearVectorEntityCont Methods

The ImGearVectorEntityCont Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
AddEntity Method
Adds an entity to the entity container.
GetEntity Method
Returns an entity specified by nIndex.
GetEntityIndex Method
Looks for the index by the entity handle.
RemoveEntity Method
Removes an entity specified by nIndex from the container.


AddEntity Method

32-bit
64-bit
CF
P
P

Description:

This method adds an entity to the entity container.

Declaration:

public void AddEntity(ImageGear.Vector.ImGearVectorEntity Entity)

Parameters:

Name
Type
Description
Entity
ImGearVectorEntity Class
Entity being added at the tail of the container.

Return value:

None.

See Also:

ImGearVectorEntity Class


GetEntity Method

32-bit
64-bit
CF
P
P

Description:

This method returns an entity specified by Index.

Declaration:

public ImageGear.Vector.ImGearVectorEntity GetEntity(int Index)

Parameters:

Name
Type
Description
Index
int
Index of entity to be returned.

Return value:

The new instance of ImGearVectorEntity Class object.


GetEntityIndex Method

32-bit
64-bit
CF
P
P

Description:

This method looks for the index by the entity object.

Declaration:

public int GetEntityIndex(ImageGear.Vector.ImGearVectorEntity Entity)

Parameters:

Name
Type
Description
Entity
ImGearVectorEntity Class
Entity being found in the container.

Return value:

Any integer value.

See Also:

ImGearVectorEntity Class


RemoveEntity Method

32-bit
64-bit
CF
P
P

Description:

This method removes an entity specified by index from the container.

Declaration:

public void RemoveEntity(int Index)

Parameters:

Name
Type
Description
Index
int
Index of the entity being removed.

Return value:

None.


ImGearVectorEntityEasyline Class

32-bit
64-bit
CF
P
P

Description:

This entity represent a line specified by start and end point.

Declaration:

public class ImGearVectorEntityEasyline : ImageGear.Vector.ImGearVectorEntity

Members:

Methods
Name
Description
GetEndPoint Method
Returns an end point of the line.
GetStartPoint Method
Returns a start point of the line.
SetEndPoint Method
Sets an end point of the line.
SetStartPoint Method
Sets start point of the line.

See Also:

ImGearVectorEntity Class


ImGearVectorEntityEasyline Methods

The ImGearVectorEntityEasyline Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
GetEndPoint Method
Returns an end point of the line.
GetStartPoint Method
Returns a start point of the line.
SetEndPoint Method
Sets an end point of the line.
SetStartPoint Method
Sets start point of the line.


GetEndPoint Method

32-bit
64-bit
CF
P
P

Description:

This method returns the end point of the line.

Declaration:

public ImageGear.Vector.ImGearVectorPoint3D GetEndPoint()

Return value:

The new instance of ImGearVectorPoint3D Structure object.


GetStartPoint Method

32-bit
64-bit
CF
P
P

Description:

This method returns the start point of the line.

Declaration:

public ImageGear.Vector.ImGearVectorPoint3D GetStartPoint()

Return value:

The new instance of ImGearVectorPoint3D Structure object.


SetEndPoint Method

32-bit
64-bit
CF
P
P

Description:

This method sets the end point of the line.

Declaration:

public void SetEndPoint(ImageGear.Vector.ImGearVectorPoint3D EndPoint)

Parameters:

Name
Type
Description
EndPoint
ImGearVectorPoint3D Structure
An end point of the line.

Return value:

None.

See Also:

ImGearVectorPoint3D Structure


SetStartPoint Method

32-bit
64-bit
CF
P
P

Description:

This method sets the start point of the line.

Declaration:

public void SetStartPoint(ImageGear.Vector.ImGearVectorPoint3D StartPoint)

Parameters:

Name
Type
Description
StartPoint
ImGearVectorPoint3D Structure
A start point of the line.

Return value:

None.

See Also:

ImGearVectorPoint3D Structure


ImGearVectorEntityEasysurface Class

32-bit
64-bit
CF
P
P

Description:

This entity represents a surface that is drawn exactly by its control points.

Declaration:

public class ImGearVectorEntityEasysurface : ImageGear.Vector.ImGearVectorEntity

Members:

Properties
Name
Description
Flags Property
Gets/sets different surface flags.
MDimension Property
Returns count of points in M direction.
NDimension Property
Returns count of points in N direction.

Methods
Name
Description
GetPoint Method
Returns a point on the crossection row m and column n.
Init Method
Sets initial size of the meshes in M and N direction.
SetPoint Method
Sets a point on the crossection the row m and column n.

See Also:

ImGearVectorEntity Class


ImGearVectorEntityEasysurface Properties

The ImGearVectorEntityEasysurface Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
Flags Property
Gets/sets different surface flags.
MDimension Property
Returns count of points in M direction.
NDimension Property
Returns count of points in N direction.


Flags Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets different surface flags such as closing in M or/and N direction.

Declaration:

public int Flags {get, set }

Value:

Surface flags.

Default value:

N/A


MDimension Property

32-bit
64-bit
CF
P
P

Description:

This property returns count of points in M direction.

Declaration:

public int MDimension { get }

Value:

Non-negative integer value.

Default value:

N/A


NDimension Property

32-bit
64-bit
CF
P
P

Description:

This property returns count of points in N direction.

Declaration:

public int NDimension { get }

Value:

Non-negative integer value.

Default value:

N/A


ImGearVectorEntityEasysurface Methods

The ImGearVectorEntityEasysurface Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
GetPoint Method
Returns a point on the crossection row m and column n.
Init Method
Sets initial size of the meshes in M and N direction.
SetPoint Method
Sets a point on the crossection the row m and column n.


GetPoint Method

32-bit
64-bit
CF
P
P

Description:

This method returns a point on the crossection the row m and column n.

Declaration:

public ImageGear.Vector.ImGearVectorPoint3D GetPoint(int m, int n)

Parameters:

Name
Type
Description
m
int
The row which the point belongs to.
n
int
The column which the point belongs to.

Return value:

The new instance of ImGearVectorPoint3D Structure.


Init Method

32-bit
64-bit
CF
P
P

Description:

This method sets initial size of the meshes in M and N direction.

Declaration:

public void Init(int mDimension, int nDimension)

Parameters:

Name
Type
Description
mDimension
int
New size of the meshes in M direction.
nDimension
int
New size of the meshes in N direction.

Return value:

None.


SetPoint Method

32-bit
64-bit
CF
P
P

Description:

This method sets a point on the crossection the row m and column n.

Declaration:

public void SetPoint(int m, int n, ImageGear.Vector.ImGearVectorPoint3D Point)

Parameters:

Name
Type
Description
m
int
The row to which the point belongs
n
int
The column to which the point belongs
Point
ImGearVectorPoint3D Structure
The point value to be set.

Return value:

None.

See Also:

ImGearVectorPoint3D Structure


ImGearVectorEntityEllipse Class

32-bit
64-bit
CF
P
P

Description:

This entity represents an ellipse.

Declaration:

public class ImGearVectorEntityEllipse : ImageGear.Vector.ImGearVectorEntity

Members:

Properties
Name
Description
RadiusX Property
Gets/sets a radius of the ellipse along the x-axis.
RadiusY Property
Gets/sets a radius of the ellipse along the y-axis.

See Also:

ImGearVectorEntity Class


ImGearVectorEntityEllipse Properties

The ImGearVectorEntityEllipse Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
RadiusX Property
Gets/sets a radius of the ellipse along the x-axis.
RadiusY Property
Gets/sets a radius of the ellipse along the y-axis.


RadiusX Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the radius of the ellipse along the x-axis.

Declaration:

public float RadiusX { get, set }

Value:

Any positive value.

Default value:

N/A


RadiusY Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets a radius of the ellipse along the y-axis.

Declaration:

public float RadiusY { get, set }

Value:

Any positive value.

Default value:

N/A


ImGearVectorEntityFigure Class

32-bit
64-bit
CF
P
P

Description:

This entity can contain several regions. Any region can include other entities such as lines, polylines, arcs and other entities.

Declaration:

public class ImGearVectorEntityFigure : ImageGear.Vector.ImGearVectorEntity

Members:

Properties
Name
Description
RegionCount Property
Returns a total count of regions in the figure.

Methods
Name
Description
GetEntityCont Method
Returns an entity container defining the current region.
SetRegion Method
Sets the current region.

See Also:

ImGearVectorEntity Class


ImGearVectorEntityFigure Properties

The ImGearVectorEntityFigure Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
RegionCount Property
Returns a total count of regions in the figure.


RegionCount Property

32-bit
64-bit
CF
P
P

Description:

This property returns the total count of regions in the figure.

Declaration:

public int RegionCount{ get }

Value:

Any integer value.

Default value:

N/A


ImGearVectorEntityFigure Methods

The ImGearVectorEntityFigure Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
GetEntityCont Method
Returns an entity container defining the current region.
SetRegion Method
Sets the current region.


GetEntityCont Method

32-bit
64-bit
CF
P
P

Description:

This method returns an entity container defining the current region. The current region is set by the SetRegion Method method.

Declaration:

public ImageGear.Vector.ImGearVectorEntityCont GetEntityCont()

Return value:

The new instance of ImGearVectorEntityCont Class object.


SetRegion Method

32-bit
64-bit
CF
P
P

Description:

This method sets the current region.

Declaration:

public void SetRegion(int Region)

Parameters:

Name
Type
Description
Region
int
Current region being set.

Return value:

None.


ImGearVectorEntityGeometry Class

32-bit
64-bit
CF
P
P

Description:

This entity represents a set of drawing primitives such as points, independent line segments, connected line segments, independent and connected triangles, independent and connected quadrilaterals, polygons. The primitives are specified with vertex array. Normals for any vertex can be specified as well.

Declaration:

public class ImGearVectorEntityGeometry : ImageGear.Vector.ImGearVectorEntity

Members:

Properties
Name
Description
ColorAlign Property
Returns the byte offset between consecutive colors in the color array.
GeometryType Property
Returns the type of geometry contained by the geometry entity.
PointCount Property
Returns a point count in the geometry.
UseColors Property
Tells whether or not the color array is used.
UseNormals Property
Tells whether or not the normals are used.

Methods
Name
Description
GetColors Method
Returns the geometry colors on the specified range.
GetNormals Method
Returns the geometry normals on the specified range.
GetPoints Method
Returns the geometry vertices on the specified range.
Init Method
Initializes the geometry.
SetColors Method
Sets the geometry colors on the specified range.
SetNormals Method
Sets the geometry normals on the specified range.
SetPoints Method
Sets the geometry vertices on the specified range.

See Also:

ImGearVectorEntity Class


ImGearVectorEntityGeometry Properties

The ImGearVectorEntityGeometry Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
ColorAlign Property
Returns the byte offset between consecutive colors in the color array.
GeometryType Property
Returns the type of geometry contained by the geometry entity.
PointCount Property
Returns a point count in the geometry.
UseColors Property
Tells whether or not the color array is used.
UseNormals Property
Tells whether or not the normals are used.


ColorAlign Property

32-bit
64-bit
CF
P
P

Description:

This property returns the byte offset between consecutive colors in the color array. It makes sense only if UseColors Property is True. Color alignment is initially set by Init Method method.

Declaration:

public int ColorAlign { get }

Value:

Usually 3 or 4 (rgb, rgba).

Default value:

N/A


GeometryType Property

32-bit
64-bit
CF
P
P

Description:

This property returns the type of geometry contained by the geometry entity. See ImGearVectGeometryType Enumeration for more information.

Declaration:

public ImageGear.Vector.ImGearVectGeometryType GeometryType { get; }

Value:

ImGearVectGeometryType Enumeration value.

See Also:

ImGearVectGeometryType Enumeration


PointCount Property

32-bit
64-bit
CF
P
P

Description:

This property returns the point count in the entity. Point count is initially set by Init Method method.

Declaration:

public int PointCount { get }

Value:

Any non-negative value.

Default value:

N/A


UseColors Property

32-bit
64-bit
CF
P
P

Description:

This property tells whether or not the local colors are used when drawing the geometry. If it is False then the color array is not used and the geometry is drawn with the current color. Initially this property is set by the bUseColors parameter in the Init Method method.

Declaration:

public bool UseColors { get }

Value:

True or False.

Default value:

N/A


UseNormals Property

32-bit
64-bit
CF
P
P

Description:

This property tells whether or not the normals are used when drawing the geometry. If it is False then the normal array is not used. Initially this property is set by the bUseNormals parameter in Init Method method.

Declaration:

public bool UseNormals { get }

Value:

True or False.

Default value:

N/A


ImGearVectorEntityGeometry Methods

The ImGearVectorEntityGeometry Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
GetColors Method
Returns the geometry colors on the specified range.
GetNormals Method
Returns the geometry normals on the specified range.
GetPoints Method
Returns the geometry vertices on the specified range.
Init Method
Initializes the geometry.
SetColors Method
Sets the geometry colors on the specified range.
SetNormals Method
Sets the geometry normals on the specified range.
SetPoints Method
Sets the geometry vertices on the specified range.


GetColors Method

32-bit
64-bit
CF
P
P

Description:

This method returns the geometry colors on the specified range.

Declaration:

public void GetColors(byte[] lpColors, int nStart, int nEnd)

Parameters:

Name
Type
Description
lpColors
byte[]
Buffer for the colors. The buffer must be long enough to receive the colors from nStart to nEnd taking into account the color alignment.
nStart
int
The start position of the color to be returned.
nEnd
int
The end position of the color to be returned.

Return value:

None.


GetNormals Method

32-bit
64-bit
CF
P
P

Description:

This method returns the geometry normals on the specified range.

Declaration:

public void GetNormals(float[] lpNormals, int nStart, int nEnd)

Parameters:

Name
Type
Description
lpNormals
float[]
Buffer for the normals. The buffer must be long enough to receive the normals from nStart to nEnd taking into account the normal size (three floating-point values).
nStart
int
The start position of the normal to be returned.
nEnd
int
The end position of the normal to be returned.

Return value:

None.


GetPoints Method

32-bit
64-bit
CF
P
P

Description:

This method returns the geometry points on the specified range.

Declaration:

public void GetPoints(float[] lpPoints, int nStart, int nEnd)

Parameters:

Name
Type
Description
lpPoints
float[]
Buffer for the points. The buffer must be long enough to receive the points from nStart to nEnd taking into account the point size (three floating-point values).
nStart
int
The start position of the normal to be returned.
nEnd
int
The end position of the normal to be returned.

Return value:

None.


Init Method

32-bit
64-bit
CF
P
P

Description:

This method initializes the geometry with the geometry type, point count, color alignment and flags of using colors and normals. This method must be called before any other geometry properties and methods.

Declaration:

public void Init(ImageGear.Vector.ImGearVectGeometryType nType, int nPointCount, int
nColorAlign, bool bUseNormals, bool bUseColors)

Parameters:

Name
Type
Description
nType
ImGearVectGeometryType Enumeration
Type of the geometry primitives. See enumeration ImGearVectGeometryType Enumeration for possible values.
nPointCount
int
Count of vertices in the geometry. Point, normal and color arrays must have the same amount of elements in case of usage.
nColorAlign
int
Color alignment in the color array. Has sense only if bUseColors is True.
bUseNormals
bool
If True than the normals are taken into account when displaying the geometry. Normals must be set before displaying in this case.
bUseColors
bool
If True then the local colors are taken into account when displaying the geometry. Colors must be set before displaying in this case.

Return value:

None.

See Also:

ImGearVectGeometryType Enumeration


SetColors Method

32-bit
64-bit
CF
P
P

Description:

This method sets the geometry colors on the specified range.

Declaration:

public void SetColors(byte[] lpColors, int nStart, int nEnd)

Parameters:

Name
Type
Description
lpColors
byte[]
Buffer with the new colors.
nStart
int
The start position of the color to be set.
nEnd
int
The end position of the color to be set.

Return value:

None.


SetNormals Method

32-bit
64-bit
CF
P
P

Description:

This method sets the geometry normals on the specified range.

Declaration:

public void SetNormals(float[] lpNormals, int nStart, int nEnd)

Parameters:

Name
Type
Description
lpNormals
float[]
Buffer with the new normals.
nStart
int
The start position of the normal to be set.
nEnd
int
The end position of the normal to be set.

Return value:

None.


SetPoints Method

32-bit
64-bit
CF
P
P

Description:

This method sets the geometry points on the specified range.

Declaration:

public void SetPoints(float[] lpPoints, int nStart, int nEnd)

Parameters:

Name
Type
Description
lpPoints
floa[]t
Buffer with the new points.
nStart
int
The start index of the point to be set.
nEnd
int
The end index of the point to be set.

Return value:

None.


ImGearVectorEntityInsertion Class

32-bit
64-bit
CF
P
P

Description:

This entity represents a transformation wrapper for the block. The block should be added to the other blocks using insertion.

It is not recommended to add the blocks to the entity container directly, as well as to change the transformation matrix of the block.

Declaration:

public class ImGearVectorEntityInsertion : ImageGear.Vector.ImGearVectorEntity

Members:

Properties
Name
Description
BlockRef Property
Gets/sets the block reference for the insertion.

See Also:

ImGearVectorEntity Class


ImGearVectorEntityInsertion Properties

The ImGearVectorEntityInsertion Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
BlockRef Property
Gets/sets the block reference for the insertion.


BlockRef Property

32-bit
64-bit
CF
P
P

Description:

This property gets or sets the block reference for the insertion

Declaration:

public ImageGear.Vector.ImGearVectorEntity BlockRef { set; get; }

Value:

ImGearVectorEntity Class object.

Default value:

N/A


ImGearVectorEntityNURBScurve Class

32-bit
64-bit
CF
P
P

Description:

This entity represents non-uniform rational Bi-spline curve. NURBS curve is defined by control points, spline degree and knot vector. Also, any control point can have additional weights.

Declaration:

public class ImGearVectorEntityNURBScurve : ImageGear.Vector.ImGearVectorEntity

Members:

Properties
Name
Description
Degree Property
Gets/sets degree of the NURBS curve.
Flags Property
Gets/sets different NURBS flags.
Step Property
Gets/sets an interpolation step.

Methods
Name
Description
GetKnots Method
Returns a container of the NURBS curve knot vector.
GetVertexCont Method
Returns a Vertex Container with the control points of the NURBS curve.

See Also:

ImGearVectorEntity Class


ImGearVectorEntityNURBScurve Properties

The ImGearVectorEntityNURBScurve Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
Degree Property
Gets/sets degree of the NURBS curve.
Flags Property
Gets/sets different NURBS flags.
Step Property
Gets/sets an interpolation step.


Degree Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the degree of the NURBS curve. Usually count of knots equals to control_point_count + degree + 1. If this is not so then knot vector is corrected.

Declaration:

public int Degree { get, set }

Value:

2, 3, 4 ...

Default value:

3


Flags Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets different NURBS flags.

Declaration:

public int Flags { get, set }

Value:

Combination of ImGearVectNURBSFlags Enumeration or 0.

Default value:

0


Step Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets an interpolation step.

Declaration:

public float Step { get, set }

Value:

Any value in the interval 0..1.

Default value:

0.2


ImGearVectorEntityNURBScurve Methods

The ImGearVectorEntityNURBScurve Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
GetKnots Method
Returns a container of the NURBS curve knot vector.
GetVertexCont Method
Returns a Vertex Container with the control points of the NURBS curve.


GetKnots Method

32-bit
64-bit
CF
P
P

Description:

This method returns a container of the NURBS curve knot vector. If knot vector is empty then the standard knot vector is calculated.

Declaration:

public ImageGear.Vector.ImGearVectorFloatCont GetKnots()

Return value:

ImGearVectorFloatCont Class object or NULL.


GetVertexCont Method

32-bit
64-bit
CF
P
P

Description:

This method returns a Vertex Container with the control points of the NURBS curve.

Declaration:

public ImageGear.Vector.ImGearVectorVertexCont GetVertexCont()

Return value:

The new instance of ImGearVectorVertexCont Class.


ImGearVectorEntityNURBSsurface Class

32-bit
64-bit
CF
P
P

Description:

This entity represents a non-uniform rational B-spline surface.

Declaration:

public class ImGearVectorEntityNURBSsurface :
ImageGear.Vector.ImGearVectorEntitySplinesurface

Members:

Properties
Name
Description
Flags Property
Gets/sets different NURBS surface flags.
MDegree Property
Gets a degree of the surface in m direction.
MDimension Property
Gets the count of control points in M direction.
MStep Property
Gets/sets interpolation step in m direction.
NDegree Property
Gets a degree of the surface in n direction.
NDimension Property
Gets the count of control points in N direction.
NStep Property
Gets/sets interpolation step in n direction.

Methods
Name
Description
GetMKnots Method
Returns container with knot vector in m direction.
GetNKnots Method
Returns container with knot vector in n direction.
GetPoint Method
Returns a surface point from the specified position.
GetVertexCont Method
Returns vertex container with control points that belong to the row m.
Init Method
Sets initial dimensions and degrees of the NURBS surface.
SetPoint Method
Sets a point to the specified position of the surface.

See Also:

AccuSoft Corporation
 AccuSoft.com
sales@accusoft.com


ImGearVectorEntityNURBSsurface Properties

The ImGearVectorEntityNURBSsurface Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
Flags Property
Gets/sets different NURBS surface flags.
MDegree Property
Gets a degree of the surface in m direction.
MDimension Property
Gets the count of control points in M direction.
MStep Property
Gets/sets interpolation step in m direction.
NDegree Property
Gets a degree of the surface in n direction.
NDimension Property
Gets the count of control points in N direction.
NStep Property
Gets/sets interpolation step in n direction.


Flags Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets different NURBS surface flags.

Declaration:

public int Flags { get, set }

Value:

Combination of ImGearVectNURBSFlags Enumeration or 0.

Default value:

0


MDegree Property

32-bit
64-bit
CF
P
P

Description:

This property gets the degree of the NURBS surface in M direction.

Declaration:

public int MDegree { get }

Value:

2, 3, 4...

Default value:

N/A


MDimension Property

32-bit
64-bit
CF
P
P

Description:

This property gets the count of control points in M direction.

Declaration:

public int MDimension { get }

Value:

Non-negative integer value

Default value:

N/A


MStep Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets interpolation step in M direction.

Declaration:

public float MStep { get, set }

Value:

Value in interval 0..1.

Default value:

0.2


NDegree Property

32-bit
64-bit
CF
P
P

Description:

This property gets the degree of the NURBS surface in N direction.

Declaration:

public int NDegree { get }

Value:

2, 3, 4...

Default value:

N/A


NDimension Property

32-bit
64-bit
CF
P
P

Description:

This property gets the count of control points in N direction.

Declaration:

public int NDimension { get }

Value:

Non-negative integer value

Default value:

N/A


NStep Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets interpolation step in N direction.

Declaration:

public float NStep { get, set }

Value:

Value in interval 0..1.

Default value:

0.2


ImGearVectorEntityNURBSsurface Methods

The ImGearVectorEntityNURBSsurface Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
GetMKnots Method
Returns container with knot vector in m direction.
GetNKnots Method
Returns container with knot vector in n direction.
GetPoint Method
Returns a surface point from the specified position.
GetVertexCont Method
Returns vertex container with control points that belong to the row m.
Init Method
Sets initial dimensions and degrees of the NURBS surface.
SetPoint Method
Sets a point to the specified position of the surface.


GetMKnots Method

32-bit
64-bit
CF
P
P

Description:

This method returns a container with knot vector in m direction. If this container is empty then the standard knot vector is calculated.

Declaration:

public ImageGear.Vector.ImGearVectorFloatCont GetMKnots()

Return value:

The new instance of ImGearVectorFloatCont Class.


GetNKnots Method

32-bit
64-bit
CF
P
P

Description:

This method returns a container with knot vector in n direction. If this container is empty then the standard knot vector is calculated.

Declaration:

public ImageGear.Vector.ImGearVectorFloatCont GetNKnots()

Return value:

The new instance of ImGearVectorFloatCont Class.


GetPoint Method

32-bit
64-bit
CF
P
P

Description:

This method returns a surface point from the specified position.

Declaration:

public ImageGear.Vector.ImGearVectorPoint3DEx GetPoint(int m, int n)

Parameters:

Name
Type
Description
m
int
Position of the point in m direction
n
int
Position of the point int n direction

Return value:

The new instance of ImGearVectorPoint3DEx Structure.


GetVertexCont Method

32-bit
64-bit
CF
P
P

Description:

This method returns a vertex container with control points that belong to the specified row.

Declaration:

public override ImageGear.Vector.ImGearVectorVertexCont GetVertexCont(int MColumn)

Parameters:

Name
Type
Description
Row
int
Vertex Container number ( surface row)

Return value:

The new instance of ImGearVectorVertexCont Class.


Init Method

32-bit
64-bit
CF
P
P

Description:

This method sets initial dimensions and degrees of the NURBS surface.

Declaration:

public override void Init(int mDimension, int nDimension, int mDegree, int nDegree)

Parameters:

Name
Type
Description
MDimension
int
Count of control points in M direction.
NDimension
int
Count of control points in N direction.
MDegree
int
Surface degree in M direction
NDegree
int
Surface degree in N direction

Return value:

None.


SetPoint Method

32-bit
64-bit
CF
P
P

Description:

This method sets a point to the specified position of the surface.

Declaration:

public void SetPoint(int m, int n, ImageGear.Vector.ImGearVectorPoint3DEx lpPoint)

Parameters:

Name
Type
Description
m
int
Position of the point in m direction
n
int
Position of the point int n direction
lpPoint
ImGearVectorPoint3DEx Structure
ImGearVectorPoint3D object with new point coordinates

Return value:

None.

See Also:

ImGearVectorPoint3DEx Structure


ImGearVectorEntityPolyline Class

32-bit
64-bit
CF
P
P

Description:

This entity represents polyline.

Declaration:

public class ImGearVectorEntityPolyline : ImageGear.Vector.ImGearVectorEntity

Members:

Methods
Name
Description
GetVertexCont Method
Returns a vertex container with polyline vertices.

See Also:

ImGearVectorEntity Class


ImGearVectorEntityPolyline Methods

The ImGearVectorEntityPolyline Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
GetVertexCont Method
Returns a vertex container with polyline vertices.


GetVertexCont Method

32-bit
64-bit
CF
P
P

Description:

This method returns a vertex container with the polyline vertices.

Declaration:

public ImageGear.Vector.ImGearVectorVertexCont GetVertexCont()

Return value:

The new instance of ImGearVectorVertexCont Class.


ImGearVectorEntityPolylineEx Class

32-bit
64-bit
CF
P
P

Description:

This entity represents the extended polyline. It can have more than one disjointed contour.

Declaration:

public class ImGearVectorEntityPolylineEx : ImageGear.Vector.ImGearVectorEntity

Members:

Properties
Name
Description
ContourCount Property
Provides a total count of the contours in the extended polyline.

Methods
Name
Description
GetVertexCont Method
Returns a vertex container describing one of the contours of the extended polyline.
SetContour Method
Sets the number of the active contour.

See Also:

ImGearVectorEntity Class


ImGearVectorEntityPolylineEx Properties

The ImGearVectorEntityPolylineEx Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
ContourCount Property
Provides a total count of the contours in the extended polyline.


ContourCount Property

32-bit
64-bit
CF
P
P

Description:

This property provides a total count of the contours in the extended polyline.

Declaration:

public int ContourCount { get }

Value:

Non-negative integer value.

Default value:

N/A


ImGearVectorEntityPolylineEx Methods

The ImGearVectorEntityPolylineEx Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
GetVertexCont Method
Returns a vertex container describing one of the contours of the extended polyline.
SetContour Method
Sets the number of the active contour.


GetVertexCont Method

32-bit
64-bit
CF
P
P

Description:

This method returns a vertex container describing one of the contours of the extended polyline.

Declaration:

public ImageGear.Vector.ImGearVectorVertexCont GetVertexCont()

Return value:

The new instance of ImGearVectorVertexCont Class.


SetContour Method

32-bit
64-bit
CF
P
P

Description:

This method sets the number of the active contour.

Declaration:

public void SetContour(int Contour)

Parameters:

Name
Type
Description
Contour
int
Number of the active contour being set.

Return value:

None.


ImGearVectorEntityRaster Class

32-bit
64-bit
CF
P
P

Description:

This object represents a non-rectangular raster image. The image shape is defined by three points - left top, right bottom, right top.

Declaration:

public class ImGearVectorEntityRaster : ImageGear.Vector.ImGearVectorEntity

Members:

Properties
Name
Description
Height Property
Gets image height, in pixels
Width Property
Gets image width, in pixels

Methods
Name
Description
GetData Method
Returns a copy of image color data
GetLeftBottom Method
This method returns the left bottom point of the raster.
GetLeftTop Method
Returns left bottom point of the raster
GetRightBottom Method
Returns right bottom point of the raster
GetRightTop Method
Returns right top point of the raster
Init Method
Initializes the raster with new width and height
SetData Method
Updates image data with new values
SetLeftBottom Method
Sets a new left bottom point for the raster.
SetLeftTop Method
Sets left bottom point of the raster
SetRightBottom Method
Sets right bottom point of the raster
SetRightTop Method
Sets right top point of the raster

See Also:

ImGearVectorEntity Class


ImGearVectorEntityRaster Properties

The ImGearVectorEntityRaster Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
Height Property
Gets image height, in pixels
Width Property
Gets image width, in pixels


Height Property

32-bit
64-bit
CF
P
P

Description:

This property returns the height of the image in pixels.

Declaration:

public int Height { get }

Value:

Positive integer value.

Default value:

N/A


Width Property

32-bit
64-bit
CF
P
P

Description:

This property returns the raster width in pixels.

Declaration:

public int Width { get }

Value:

Positive integer value.

Default value:

N/A


ImGearVectorEntityRaster Methods

The ImGearVectorEntityRaster Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
GetData Method
Returns a copy of image color data
GetLeftBottom Method
This method returns the left bottom point of the raster.
GetLeftTop Method
Returns left bottom point of the raster
GetRightBottom Method
Returns right bottom point of the raster
GetRightTop Method
Returns right top point of the raster
Init Method
Initializes the raster with new width and height
SetData Method
Updates image data with new values
SetLeftBottom Method
Sets a new left bottom point for the raster.
SetLeftTop Method
Sets left bottom point of the raster
SetRightBottom Method
Sets right bottom point of the raster
SetRightTop Method
Sets right top point of the raster


GetData Method

32-bit
64-bit
CF
P
P

Description:

This method returns a copy of the image color data.

Declaration:

public ImageGear.Vector.ImGearVectorColor[] GetData()

Return value:

ImGearVectorColor Structure[] data.


GetLeftBottom Method

32-bit
64-bit
CF
P
P

Description:

This method returns the left bottom point of the raster.

Declaration:

public ImageGear.Vector.ImGearVectorPoint3D GetLeftBottom()

Return value:

ImGearVectorPoint3D Structure object.


GetLeftTop Method

32-bit
64-bit
CF
P
P

Description:

This method returns the left top point of the raster.

Declaration:

public ImageGear.Vector.ImGearVectorPoint3D GetLeftTop()

Return value:

ImGearVectorPoint3D Structure object.


GetRightBottom Method

32-bit
64-bit
CF
P
P

Description:

This method returns the right bottom point of the raster.

Declaration:

public ImageGear.Vector.ImGearVectorPoint3D GetRightBottom()

Return value:

ImGearVectorPoint3D Structure object.


GetRightTop Method

32-bit
64-bit
CF
P
P

Description:

This method returns the right top point of the raster.

Declaration:

public ImageGear.Vector.ImGearVectorPoint3D GetRightTop()

Return value:

ImGearVectorPoint3D Structure object.


Init Method

32-bit
64-bit
CF
P
P

Description:

This method initializes a raster with new width and height.

Declaration:

public void Init(int Width, int Height)

Parameters:

Name
Type
Description
Width
int
new width of the raster
Height
int
new height of the raster

Return value:

None


SetData Method

32-bit
64-bit
CF
P
P

Description:

This method replaces image data with new color values.

Declaration:

public void SetData(ImageGear.Vector.ImGearVectorColor[] Data)

Parameters:

Name
Type
Description
Data
ImGearVectorColor Structure []
New color data

Return value:

None.

See Also:

ImGearVectorColor Structure


SetLeftBottom Method

32-bit
64-bit
CF
P
P

Description:

This method sets a new left bottom point for the raster.

Declaration:

public void SetLeftBottom(ImageGear.Vector.ImGearVectorPoint3D LeftBottom)

Parameters:

Name
Type
Description
LeftTop
ImGearVectorPoint3D Structure
New left top point

Return value:

None

See Also:

ImGearVectorPoint3D Structure


SetLeftTop Method

32-bit
64-bit
CF
P
P

Description:

This method sets a new left top point for the raster.

Declaration:

public void SetLeftTop(ImageGear.Vector.ImGearVectorPoint3D LeftTop)

Parameters:

Name
Type
Description
LeftTop
ImGearVectorPoint3D Structure
New left top point

Return value:

None

See Also:

ImGearVectorPoint3D Structure


SetRightBottom Method

32-bit
64-bit
CF
P
P

Description:

This method sets a new right bottom point for the raster.

Declaration:

public void SetRightBottom(ImageGear.Vector.ImGearVectorPoint3D RightBottom)

Parameters:

Name
Type
Description
RightBottom
ImGearVectorPoint3D Structure
New right bottom point.

Return value:

None

See Also:

ImGearVectorPoint3D Structure


SetRightTop Method

32-bit
64-bit
CF
P
P

Description:

This method sets a new right top point for the raster.

Declaration:

public void SetRightTop(ImageGear.Vector.ImGearVectorPoint3D RightTop)

Parameters:

Name
Type
Description
RightTop
ImGearVectorPoint3D Structure
New right top point

Return value:

None

See Also:

ImGearVectorPoint3D Structure


ImGearVectorEntitySolid Class

32-bit
64-bit
CF
P
P

Description:

This entity represents a quadrangle.

Declaration:

public class ImGearVectorEntitySolid : ImageGear.Vector.ImGearVectorEntity

Members:

Methods
Name
Description
GetPoint Method
Returns the coordinates of the specified corner.
SetPoint Method
Sets the coordinates of the specified corner.

See Also:

ImGearVectorEntity Class


ImGearVectorEntitySolid Methods

The ImGearVectorEntitySolid Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
GetPoint Method
Returns the coordinates of the specified corner.
SetPoint Method
Sets the coordinates of the specified corner.


GetPoint Method

32-bit
64-bit
CF
P
P

Description:

This method returns the coordinates of the specified corner.

Declaration:

public ImageGear.Vector.ImGearVectorPoint3D GetPoint(int nIndex)

Parameters:

Name
Type
Description
Index
int
Index of the corner.

Return value:

ImGearVectorPoint3D Structure structure representing the coordinates of the corner specified by Index.


SetPoint Method

32-bit
64-bit
CF
P
P

Description:

This method sets the coordinates of the specified corner.

Declaration:

public void SetPoint(int nIndex, ref ImageGear.Vector.ImGearVectorPoint3D point)

Parameters:

Name
Type
Description
Index
int
Index of the corner.
Point
ImGearVectorPoint3D Structure
New corner coordinates.

Return value:

None.

See Also:

ImGearVectorPoint3D Structure


ImGearVectorEntityText Class

32-bit
64-bit
CF
P
P

Description:

This entity represents a text string. Different parts of the text string can have different settings such as color, font, effects, but all the string has the same alignment and base line angle.

Declaration:

public class ImGearVectorEntityText : ImageGear.Vector.ImGearVectorEntity

Members:

Properties
Name
Description
Alignment Property
Gets/sets flags defining an alignment of the text string.
BaseLine Property
Gets/sets a base line angle for the whole text string.
TextObjectCount Property
Returns the total count of Text Objects in the chain.

Methods
Name
Description
CopySettingsFrom Method
Copies all common text settings from one text entity to another.
CreateTextObject Method
Creates new text object and inserted it at Index position in the Text Object chain.
DeleteTextObject Method
Removes the Text Object from the position Index and destroys it.
GetAlignPoint Method
Returns an additional alignment point.
GetRestrictPoint Method
Returns an additional point defining restriction width and height.
GetTextObject Method
Returns the text object with the index nIndex in the Text Object chain.
SetAlignPoint Method
Sets an additional alignment point.
SetRestrictPoint Method
Sets an additional point defining restriction width and height.

See Also:

ImGearVectorEntity Class


ImGearVectorEntityText Properties

The ImGearVectorEntityText Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
Alignment Property
Gets/sets flags defining an alignment of the text string.
BaseLine Property
Gets/sets a base line angle for the whole text string.
TextObjectCount Property
Returns the total count of Text Objects in the chain.


Alignment Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets flags defining the alignment of the text string.

Declaration:

public int Alignment { get, set }

Value:

Combination of ImGearVectAlignment Enumeration values

Default value:

ImGearVectAlignment Enumeration .NONE


BaseLine Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the base line angle for the whole text string.

Declaration:

public float BaseLine { get, set }

Value:

Any value in the range of -2*PI ... 2*PI

Default value:

N/A


TextObjectCount Property

32-bit
64-bit
CF
P
P

Description:

This property returns the total count of Text Objects in the chain.

Declaration:

public int TextObjectCount { get }

Value:

Non-negative integer value.

Default value:

N/A


ImGearVectorEntityText Methods

The ImGearVectorEntityText Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
CopySettingsFrom Method
Copies all common text settings from one text entity to another.
CreateTextObject Method
Creates new text object and inserted it at Index position in the Text Object chain.
DeleteTextObject Method
Removes the Text Object from the position Index and destroys it.
GetAlignPoint Method
Returns an additional alignment point.
GetRestrictPoint Method
Returns an additional point defining restriction width and height.
GetTextObject Method
Returns the text object with the index nIndex in the Text Object chain.
SetAlignPoint Method
Sets an additional alignment point.
SetRestrictPoint Method
Sets an additional point defining restriction width and height.


CopySettingsFrom Method

32-bit
64-bit
CF
P
P

Description:

This method copies all common text settings from one text entity to another. This is convenient when creating a new text string with almost the same settings as an existing one.

Declaration:

public void CopySettingsFrom(ImageGear.Vector.ImGearVectorEntityText Text)

Parameters:

Name
Type
Description
Text
ImGearVectorEntityText Class
The source text Entity.

Return value:

None.

See also:

ImGearVectorEntityText Class


CreateTextObject Method

32-bit
64-bit
CF
P
P

Description:

This method creates a new text object and inserts it at Index position in the Text Object chain.

Declaration:

public ImageGear.Vector.ImGearVectorTextObject CreateTextObject(int Index)

Parameters:

Name
Type
Description
Index
int
Index at which the created text object is to be inserted.

Return value:

The new instance of ImGearVectorTextObject Class object.


DeleteTextObject Method

32-bit
64-bit
CF
P
P

Description:

This method removes the Text Object from the position Index and destroys it.

Declaration:

public void DeleteTextObject(int Index)

Parameters:

Name
Type
Description
Index
int
Position of the text object to be removed.

Return value:

None.


GetAlignPoint Method

32-bit
64-bit
CF
P
P

Description:

This method returns an additional alignment point. Alignment point is taken into account if CONTINUOUSX or CONTINUOUSY alignment flags are set.

Declaration:

public ImageGear.Vector.ImGearVectorPoint2D GetAlignPoint()

Return value:

The new instance of ImGearVectorPoint2D Structure object.


GetRestrictPoint Method

32-bit
64-bit
CF
P
P

Description:

This method returns an additional point defining restriction width and height. Restriction is taken into account if any RESTRICT_... alignment flag is set.

Declaration:

public ImageGear.Vector.ImGearVectorPoint2D GetRestrictPoint()

Return value:

The new instance of ImGearVectorPoint2D Structure object.


GetTextObject Method

32-bit
64-bit
CF
P
P

Description:

This method returns the text object in the Index position in the Text Object chain.

Declaration:

public ImageGear.Vector.ImGearVectorTextObject GetTextObject(int Index)

Parameters:

Name
Type
Description
Index
int
Index of the text object to be returned.

Return value:

The new instance of ImGearVectorTextObject Class object.


SetAlignPoint Method

32-bit
64-bit
CF
P
P

Description:

This method sets an additional alignment point.

Declaration:

public void SetAlignPoint(ImageGear.Vector.ImGearVectorPoint2D AlignPoint)

Parameters:

Name
Type
Description
AlignPoint
ImGearVectorPoint2D Structure
An alignment point to be set.

Return value:

None.

See also:

ImGearVectorPoint2D Structure


SetRestrictPoint Method

32-bit
64-bit
CF
P
P

Description:

This method sets an additional point defining restriction width and height.

Declaration:

public void SetRestrictPoint(ImageGear.Vector.ImGearVectorPoint2D RestrictPoint)

Parameters:

Name
Type
Description
RestrictPoint
ImGearVectorPoint2D Structure
The restriction point to be set.

Return value:

None.

See Also:

ImGearVectorPoint2D Structure


ImGearVectorEntityViewport Class

32-bit
64-bit
CF
P
P

Description:

This entity represents a viewport, that is, rectangular or non-rectangular window where the viewport content is displayed with the specified layout.

Declaration:

public class ImGearVectorEntityViewport : ImageGear.Vector.ImGearVectorEntity

Members:

Methods
Name
Description
GetBoundary Method
Gets an entity that bounds the viewport.
GetContent Method
Returns the viewport content.
GetViewMax Method
Returns a point with maximum coordinates of the view being mapped to the viewport.
GetViewMin Method
Returns a point with minimum coordinates of the view being mapped to the viewport.
GetViewportRotation Method
Returns a rotation of the view being mapped.
GetVPMax Method
Returns a point with maximum coordinates of the viewport.
GetVPMin Method
Returns a point with minimum coordinates of the viewport.
SetBoundary Method
Sets bounding entity for the viewport.
SetContent Method
Sets viewport content.
SetViewMax Method
Sets maximum coordinates of the view to be mapped to the viewport.
SetViewMin Method
Sets minimum coordinates of the view to be mapped to the viewport.
SetVPMax Method
Sets maximum viewport coordinates.
SetVPMin Method
Sets minimum viewport coordinates.

See Also:

ImGearVectorEntity Class


ImGearVectorEntityViewport Methods

The ImGearVectorEntityViewport Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
GetBoundary Method
Gets an entity that bounds the viewport.
GetContent Method
Returns the viewport content.
GetViewMax Method
Returns a point with maximum coordinates of the view being mapped to the viewport.
GetViewMin Method
Returns a point with minimum coordinates of the view being mapped to the viewport.
GetViewportRotation Method
Returns a rotation of the view being mapped.
GetVPMax Method
Returns a point with maximum coordinates of the viewport.
GetVPMin Method
Returns a point with minimum coordinates of the viewport.
SetBoundary Method
Sets bounding entity for the viewport.
SetContent Method
Sets viewport content.
SetViewMax Method
Sets maximum coordinates of the view to be mapped to the viewport.
SetViewMin Method
Sets minimum coordinates of the view to be mapped to the viewport.
SetVPMax Method
Sets maximum viewport coordinates.
SetVPMin Method
Sets minimum viewport coordinates.


GetBoundary Method

32-bit
64-bit
CF
P
P

Description:

This method gets an entity that bounds the viewport. This can be a rectangle, polyline, ellipse or other entities. If the boundary is not set, the viewport is bounded by the values specified by the VPMin and VPMax properties.

Declaration:

public ImageGear.Vector.ImGearVectorEntity GetBoundary()

Return value:

The new instance of ImGearVectorEntity Class.

See Also:

GetVPMax Method

GetVPMin Method

SetVPMax Method

SetVPMin Method


GetContent Method

32-bit
64-bit
CF
P
P

Description:

This method returns the viewport content. Usually this is a block containing some other entities.

Declaration:

public ImageGear.Vector.ImGearVectorEntity GetContent()

Return value:

The new instance of ImGearVectorEntity Class.


GetViewMax Method

32-bit
64-bit
CF
P
P

Description:

This method returns a point with maximum coordinates of the view being mapped to the viewport.

Declaration:

public ImageGear.Vector.ImGearVectorPoint3D GetViewMax()

Return value:

The new instance of ImGearVectorPoint3D Structure.


GetViewMin Method

32-bit
64-bit
CF
P
P

Description:

This method returns a point with minimum coordinates of the view being mapped to the viewport.

Declaration:

public ImageGear.Vector.ImGearVectorPoint3D GetViewMin()

Return value:

The new instance of ImGearVectorPoint3D Structure.


GetViewportRotation Method

32-bit
64-bit
CF
P
P

Description:

This method returns a rotation of the view being mapped.

Declaration:

public ImageGear.Vector.ImGearVectorRotation GetViewportRotation()

Return value:

The new instance of ImGearVectorRotation Class.


GetVPMax Method

32-bit
64-bit
CF
P
P

Description:

This method returns a point with maximum coordinates of the viewport.

Declaration:

public ImageGear.Vector.ImGearVectorPoint3D GetVPMax()

Return value:

The new instance of ImGearVectorPoint3D Structure.


GetVPMin Method

32-bit
64-bit
CF
P
P

Description:

This method returns a point with minimum coordinates of the viewport.

Declaration:

public ImageGear.Vector.ImGearVectorPoint3D GetVPMin()

Return value:

The new instance of ImGearVectorPoint3D Structure.


SetBoundary Method

32-bit
64-bit
CF
P
P

Description:

This method sets the bounding entity for the viewport.

Declaration:

public void SetBoundary(ImageGear.Vector.ImGearVectorEntity Boundary)

Parameters:

Name
Type
Description
Boundary
ImGearVectorEntity Class
bounding entity beinng set.

Return value:

None.

See also:

ImGearVectorEntity Class


SetContent Method

32-bit
64-bit
CF
P
P

Description:

This method sets the viewport content. Usually this is a block containing some other entities.

Declaration:

public void SetContent(ImageGear.Vector.ImGearVectorEntity Content)

Parameters:

Name
Type
Description
Content
ImGearVectorEntity Class
An entity being set as Viewport content.

Return value:

None.

See also:

ImGearVectorEntity Class


SetViewMax Method

32-bit
64-bit
CF
P
P

Description:

This method sets new maximum view coordinates.

Declaration:

public void SetViewMax(ImageGear.Vector.ImGearVectorPoint3D MaxPoint)

Parameters:

Name
Type
Description
MaxPoint
ImGearVectorPoint3D Structure
new coordinates of the view

Return value:

None.

See also;

ImGearVectorPoint3D Structure


SetViewMin Method

32-bit
64-bit
CF
P
P

Description:

This method sets new minimum coordinates of the view.

Declaration:

public void SetViewMin(ImageGear.Vector.ImGearVectorPoint3D MinPoint)

Parameters:

Name
Type
Description
MinPoint
ImGearVectorPoint3D Structure
New minimum coordinates of the view

Return value:

None.

See also;

ImGearVectorPoint3D Structure


SetVPMax Method

32-bit
64-bit
CF
P
P

Description:

This method sets new viewport maximum coordinates.

Declaration:

public void SetVPMax(ImageGear.Vector.ImGearVectorPoint3D MaxPoint)

Parameters:

Name
Type
Description
MaxPoint
ImGearVectorPoint3D Structure
New viewport maximum coordinates

Return value:

None.

See also;

ImGearVectorPoint3D Structure


SetVPMin Method

32-bit
64-bit
CF
P
P

Description:

This method sets new viewport minimum coordinates.

Declaration:

public void SetVPMin(ImageGear.Vector.ImGearVectorPoint3D MinPoint)

Parameters:

Name
Type
Description
MinPoint
ImGearVectorPoint3D Structure
New viewport minimum coordinates

Return value:

None.

See also;

ImGearVectorPoint3D Structure


ImGearVectorFilltype Class

32-bit
64-bit
CF
P
P

Description:

This object represents the fill type for drawing filled objects. The style of the fill type object is specified by Pattern property. The fill pattern can be solid, predefined, shadow and vector (hatch).

Declaration:

public class ImGearVectorFilltype : ImageGear.Vector.ImGearVectorObject

Members:

Properties
Name
Description
Pattern Property
Provides a constant defining of a fill pattern.

Methods
Name
Description
GetGradient Method
Returns gradient object associated with the fill type.
GetHatch Method
Returns the hatch object associated with fill type

See Also:

ImGearVectorObject Class


ImGearVectorFilltype Properties

The ImGearVectorFilltype Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
Pattern Property
Provides a constant defining of a fill pattern.


Pattern Property

32-bit
64-bit
CF
P
P

Description:

This property provides a constant defining a fill pattern. See ImGearVectFillPattern Enumeration for possible values.

Declaration:

public ImageGear.Vector.ImGearVectFillPattern Pattern { get; }

Value:

Any value of ImGearVectFillPattern Enumeration.

Default value:

N/A

See Also:

ImGearVectFillPattern Enumeration


ImGearVectorFilltype Methods

The ImGearVectorFilltype Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
GetGradient Method
Returns gradient object associated with the fill type.
GetHatch Method
Returns the hatch object associated with fill type


GetGradient Method

32-bit
64-bit
CF
P
P

DDescription:

Returns gradient object associated with the fill type.

Declaration:

public ImGearVectorGradient GetGradient();

Return value:

ImGearVectorGradient Class object.


GetHatch Method

32-bit
64-bit
CF
P
P

Description:

This method returns the hatch object associated with the fill type in case the Pattern is IG_VECT_FP_HATCH_VECTOR.

Declaration:

public ImageGear.Vector.ImGearVectorHatch GetHatch()

Return value:

The new instance of ImGearVectorHatch Class object.


ImGearVectorFloatCont Class

32-bit
64-bit
CF
P
P

Description:

This object represents the container for floating point values. It is used to keep the pattern for hatch line and the knots for spline curves and surfaces.

Declaration:

public class ImGearVectorFloatCont : ImageGear.Vector.ImGearVectorObject

Members:

Properties
Name
Description
Count Property
Returns a count of values in the container.

Methods
Name
Description
AddValue Method
Adds new value at the end of the container.
Clear Method
Clears the container.
GetValue Method
Returns a value specified by the Position.
InsertValue Method
Inserts a value at the specified position.
RemoveValue Method
Removes a value specified by the Position.
SetValue Method
Sets a value at the specified position.

See Also:

ImGearVectorObject Class


ImGearVectorFloatCont Properties

The ImGearVectorFloatCont Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
Count Property
Returns a count of values in the container.


Count Property

32-bit
64-bit
CF
P
P

Description:

This property returns a count of values in the container.

Declaration:

public int Count { get }

Value:

Non-negative integer value.

Default value:

N/A


ImGearVectorFloatCont Methods

The ImGearVectorFloatCont Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
AddValue Method
Adds new value at the end of the container.
Clear Method
Clears the container.
GetValue Method
Returns a value specified by the Position.
InsertValue Method
Inserts a value at the specified position.
RemoveValue Method
Removes a value specified by the Position.
SetValue Method
Sets a value at the specified position.


AddValue Method

32-bit
64-bit
CF
P
P

Description:

This method adds new value at the end of the container.

Declaration:

public void AddValue(float Value)

Parameters:

Name
Type
Description
Value
float
Value to be added at the container

Return value:

None


Clear Method

32-bit
64-bit
CF
P
P

Description:

This method clears the container.

Declaration:

public void Clear()

Return value:

None


GetValue Method

32-bit
64-bit
CF
P
P

Description:

This method returns a value specified by the Position.

Declaration:

public float GetValue(int Position)

Parameters:

Name
Type
Description
Position
int
Position of the value in the container.

Return value:

A float value specified by the Position.


InsertValue Method

32-bit
64-bit
CF
P
P

Description:

This method inserts a value to the specified position.

Declaration:

public void InsertValue(int Position, float Value)

Parameters:

Name
Type
Description
Position
int
Position where the value is inserted.
Value
float
Value being inserted

Return value:

None.


RemoveValue Method

32-bit
64-bit
CF
P
P

Description:

This method removes a value specified by the Position.

Declaration:

public void RemoveValue(int Position)

Parameters:

Name
Type
Description
Position
int
Position of the value being removed.

Return value:

None.


SetValue Method

32-bit
64-bit
CF
P
P

Description:

This method sets specified value to the specified position.

Declaration:

public void SetValue(int Position, float Value)

Parameters:

Name
Type
Description
Position
int
Position where the value is set
Value
float
Value being set

Return value:

None.


ImGearVectorFont Class

32-bit
64-bit
CF
P
P

Description:

This object represents the font for the text drawing. The Font can be Vector and TrueType. Every letter (glyph) of the Vector font is defined by vertex container. The customer is completely responsible for creating any glyph of the vector font. TrueType font is created from the corresponding system font and is not modified. Font is created with vector data object by such parameters as type face, weight, "is Vector" and saved in the internal font container.

Declaration:

public class ImGearVectorFont : ImageGear.Vector.ImGearVectorObject

Members:

Properties
Name
Description
GlyphCount Property
Gets/sets the number of glyphs in the vector font.
IsVector Property
Tells whether the font is vector or TrueType.
Typeface Property
Returns the font typeface.
Weight Property
Returns the font weight.

Methods
Name
Description
GetGlyph Method
Returns Vertex Container for access to the Vector glyph.

See Also:

ImGearVectorObject Class


ImGearVectorFont Properties

The ImGearVectorFont Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
GlyphCount Property
Gets/sets the number of glyphs in the vector font.
IsVector Property
Tells whether the font is vector or TrueType.
Typeface Property
Returns the font typeface.
Weight Property
Returns the font weight.


GlyphCount Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets the number of glyphs in the vector font. Does nothing for TrueType font.

Declaration:

public int GlyphCount{ get; set }

Value:

Non-negative integer value.

Default value:

N/A


IsVector Property

32-bit
64-bit
CF
P
P

Description:

This property tells whether the font is vector (true) or TrueType (false).

Declaration:

public bool IsVector { get }

Value:

True, False

Default value:

True


Typeface Property

32-bit
64-bit
CF
P
P

Description:

This property returns the font typeface.

Declaration:

public string Typeface { get }

Value:

The string name of the font type.

Default value:

""


Weight Property

32-bit
64-bit
CF
P
P

Description:

This property returns the TrueType font weight. Weight has the same meaning as the corresponding Windows font parameter: 300 means light, 400 - normal, 700 - bold and so on.

Declaration:

public int Weight { get }

Value:

Integer value of font weight.

Default value:

N/A


ImGearVectorFont Methods

The ImGearVectorFont Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
GetGlyph Method
Returns Vertex Container for access to the Vector glyph.


GetGlyph Method

32-bit
64-bit
CF
P
P

Description:

This method returns Vertex Container for access to the Vector glyph. The customer can fill and modify any vector glyph. This method returns null for non-vector font.

Declaration:

public ImageGear.Vector.ImGearVectorVertexCont GetGlyph(int Index)

Parameters:

Name
Type
Description
Index
int
Index of the glyph to be returned.

Return value:

The new instance of ImGearVectorVertexCont Class object in case of the font is Vector and null for TrueType font.


ImGearVectorGradient Class

32-bit
64-bit
CF
P
P

Description:

This class is used as the base for particular gradient filling classes.

There are two types of gradient filllings: linear and radial. They are represented by ImGearVectorGradientLinear Class and ImGearVectorGradientRadial Class, correspondingly.

The color of the gradient is defined by an array of stops. A stop is a pair of offset and color. Stop offsets are relative to gradient coordinates. 0.0 corresponds to the start point, 1.0 corresponds to the end points, in the case of a linear gradient, or to a point at the outer circle, in the case of a radial gradient. If first stop offset is greater than 0.0, or the last stop offset is less than 1.0, the gradient is expanded according to its Spread method. Gradient color is linearly interpolated between the stops.

Gradient filling can be transformed with an affine matrix.

Declaration:

public abstract class ImGearVectorGradient : ImGearVectorObject

Members:

Properties
Name
Description
SpreadMethod Property
Specifies spread method of the gradient object.

Methods
Name
Description
AddStop Method
Adds a stop to the gradient object.
GetMatrix Method
Returns transformation matrix of the gradient object.
GetName Method
Returns the name of the gradient object.
GetStopColor Method
Returns color of the specified stop.
GetStopCount Method
Returns the number of stops in the gradient object.
GetStopOffset Method
Returns offset of the specified stop.
RemoveStop Method
Removes a stop from the gradient object.
SetMatrix Method
Sets transformation matrix of the gradient object.
SetStopColor Method
Sets color of the specified stop.
SetStopOffset Method
Sets offset of the specified stop.


ImGearVectorGradient Properties

The ImGearVectorGradient Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
SpreadMethod Property
Specifies spread method of the gradient object.


SpreadMethod Property

32-bit
64-bit
CF
P
P

Description:

Specifies spread method for the gradient object. Spread method specifies how the gradient is expanded. See ImGearVectGradientSpreadMethod Enumeration for the list of available spread methods.

Declaration:

public ImGearVectGradientSpreadMethod SpreadMethod { get; set; }

Value:

ImGearVectGradientSpreadMethod


ImGearVectorGradient Methods

The ImGearVectorGradient Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
AddStop Method
Adds a stop to the gradient object.
GetMatrix Method
Returns transformation matrix of the gradient object.
GetName Method
Returns the name of the gradient object.
GetStopColor Method
Returns color of the specified stop.
GetStopCount Method
Returns the number of stops in the gradient object.
GetStopOffset Method
Returns offset of the specified stop.
RemoveStop Method
Removes a stop from the gradient object.
SetMatrix Method
Sets transformation matrix of the gradient object.
SetStopColor Method
Sets color of the specified stop.
SetStopOffset Method
Sets offset of the specified stop.


AddStop Method

32-bit
64-bit
CF
P
P

Description:

Adds new stop to the gradient. A stop is defined by its offset and color.

Declaration:

public void AddStop(float fStopOffset,ImGearVectorColorEx StopColor)

Parameters:

Name
Type
Description
fStopOffset
float
Offset of the new gradient stop.
StopColor
ImGearVectorColorEx Structure
Color of the new gradient stop.

Return value:

None


GetMatrix Method

32-bit
64-bit
CF
P
P

Description:

Returns the current transformation matrix of the gradient object. The matrix consists of 16 floating-point values and is aligned by columns, that is:

a11 a21 a31 a41

a12 a22 a32 a42

a13 a23 a33 a43

a14 a24 a34 a44

Use the SetMatrix Method to set the transformation matrix of the gradient object.

Declaration:

public float[] GetMatrix()

Return value:

Array of 16 floating-point values.


GetName Method

32-bit
64-bit
CF
P
P

Description:

Returns the name of the gradient object.

Declaration:

public string GetName()

Return value:

Name of the gradient object.


GetStopColor Method

32-bit
64-bit
CF
P
P

Description:

Returns color of the specified stop.

Declaration:

public ImGearVectorColorEx GetStopColor(Int32 nStopIndex)

Parameters:

Name
Type
Description
nStopIndex
Int32
Stop index.

Return value:

Color of the specified stop.


GetStopCount Method

32-bit
64-bit
CF
P
P

32-bit
64-bit
CF
P
P

Description:

Returns the number of stops in the gradient object.

Declaration:

public Int32 GetStopCount()

Return value:

Number of stops in the gradient object.


GetStopOffset Method

32-bit
64-bit
CF
P
P

32-bit
64-bit
CF
P
P

Description:

Returns offset of the specified stop.

Declaration:

public float GetStopOffset(Int32 nStopIndex)

Parameters:

Name
Type
Description
nStopIndex
Int32
Stop index.

Return value:

Offset of the specified stop.


RemoveStop Method

32-bit
64-bit
CF
P
P

32-bit
64-bit
CF
P
P

Description:

Removes the specified stop from the gradient.

Declaration:

public void RemoveStop(Int32 nStopIndex)

Parameters:

Name
Type
Description
nStopIndex
Int32
Index of the stop to remove.

Return value:

None


SetMatrix Method

32-bit
64-bit
CF
P
P

32-bit
64-bit
CF
P
P

Description:

Sets transformation matrix of the gradient object. The matrix consists of 16 floating-point values and is aligned by columns, that is:

a11 a21 a31 a41

a12 a22 a32 a42

a13 a23 a33 a43

a14 a24 a34 a44

Declaration:

public void SetMatrix(float[] Mat)

Parameters:

Name
Type
Description
Mat
float [ }
New transformation matrix.

Return value:

None

See Also:

GetMatrix Method


SetStopColor Method

32-bit
64-bit
CF
P
P

Description:

Sets new color for the specified stop.

Declaration:

public void SetStopColor(Int32 nStopIndex, ImGearVectorColorEx StopColor)

Parameters:

Name
Type
Description
nStopIndex
Int32
Stop index.
StopColor
ImGearVectorColorEx Structure
New color for the stop.

Return value:

None


SetStopOffset Method

32-bit
64-bit
CF
P
P

Description:

Sets new offset for the specified stop.

Declaration:

public void SetStopOffset(Int32 nStopIndex, float fOffset)

Parameters:

Name
Type
Description
nStopIndex
Int32
Stop index.
fOffset
float
New offset for the specified stop.

Return value:

None


ImGearVectorGradientLinear Class

32-bit
64-bit
CF
P
P

Description:

Represents a linear gradient object. Geometric layout of a linear gradient object is defined by its vector (start and end points).

Declaration:

public class ImGearVectorGradientLinear : ImGearVectorGradient

Members:

Methods
Name
Description
GetVector Method
Returns the vector that specifies geometric layout of the linear gradient object.
SetVector Method
Sets the vector that specifies geometric layout of the linear gradient object.


ImGearVectorGradientLinear Methods

The ImGearVectorGradientLinear Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
GetVector Method
Returns the vector that specifies geometric layout of the linear gradient object.
SetVector Method
Sets the vector that specifies geometric layout of the linear gradient object.


GetVector Method

32-bit
64-bit
CF
P
P

Description:

Returns the vector that specifies geometric layout of the linear gradient object.

Declaration:

public void GetVector(ref ImGearVectorPoint3D lpPt1, ref ImGearVectorPoint3D lpPt2,ref
bool lpbAbsolute)

Parameters:

Name
Type
Description
lpPt1
ImGearVectorPoint3D Structure
Returns gradient start point.
lpPt2
ImGearVectorPoint3D Structure
Returns gradient end point.
lpbAbsolute
bool
Returns a flag indicating whether the start and end point coordinates are relative or absolute.

Return value:

None


SetVector Method

32-bit
64-bit
CF
P
P

Description:

Returns the vector that specifies geometric layout of the linear gradient object.

Declaration:

public void GetVector(ref ImGearVectorPoint3D lpPt1, ref ImGearVectorPoint3D lpPt2,ref
bool lpbAbsolute)

Parameters:

Name
Type
Description
lpPt1
ImGearVectorPoint3D Structure
Returns gradient start point.
lpPt2
ImGearVectorPoint3D Structure
Returns gradient end point.
lpbAbsolute
bool
Returns a flag indicating whether the start and end point coordinates are relative or absolute.

Return value:

None


ImGearVectorGradientRadial Class

32-bit
64-bit
CF
P
P

Description:

Represents a radial gradient object. Geometric layout of a linear gradient object is defined by its inner point, and center and radius of the outer circle. Start point should be located inside the outer circle, but not necessarily in its center.

Declaration:

public class ImGearVectorGradientRadial : ImGearVectorGradient

Members:

Methods
Name
Description
GetVector Method
Returns geometric layout of the radial gradient object.
SetVector Method
Sets geometric layout of the radial gradient object.


ImGearVectorGradientRadial Methods

The ImGearVectorGradientRadial Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
GetVector Method
Returns geometric layout of the radial gradient object.
SetVector Method
Sets geometric layout of the radial gradient object.


GetVector Method

32-bit
64-bit
CF
P
P

Description:

Returns geometric layout of the radial gradient object.

Declaration:

public void GetVector(ref ImGearVectorPoint3D lpPt1,ref ImGearVectorPoint3D lpPt2, ref
float lpfRadius, ref bool lpbAbsolute)

Parameters:

Name
Type
Description
lpPt1
ImGearVectorPoint3D Structure
Returns coordinates of the inner point.
lpPt2
ImGearVectorPoint3D Structure
Returns coordinates of the center of the outer circle.
lpfRadius
float
Returns radius of the outer circle.
lpbAbsolute
bool
Returns a flag indicating whether the coordinates and radius are relative or absolute.

Return value:

None


SetVector Method

32-bit
64-bit
CF
P
P

Description:

Sets geometric layout of the radial gradient object.

Declaration:

public void SetVector(ImGearVectorPoint3D Pt1, ImGearVectorPoint3D Pt2, float fRadius,
bool bAbsolute)

Parameters:

Name
Type
Description
Pt1
ImGearVectorPoint3D Structure
Coordinates of the inner point.
Pt2
ImGearVectorPoint3D Structure
Coordinates of the center of the outer circle.
fRadius
float
Radius of the outer circle.
bAbsolute
bool
Specifies whether coordinates and radius are relative or absolute.

Return value:

None


ImGearVectorHatch Class

32-bit
64-bit
CF
P
P

Description:

This object represents a vector hatch. The vector hatch is an especial kind of the fill type. It is defined by the set of lines with corresponding patterns, offsets and angles

Declaration:

public class ImGearVectorHatch : ImageGear.Vector.ImGearVectorObject

Members:

Properties
Name
Description
LineCount Property
Provides the total line count in the hatch.

Methods
Name
Description
CreateLine Method
Creates a new hatch line and adds it to the hatch.
DeleteLine Method
Removes the hatch line specified with Index from the hatch and destroys it.
GetLine Method
Allows you to get the hatch line specified by the Index.

See Also:

ImGearVectorObject Class


ImGearVectorHatch Properties

The ImGearVectorHatch Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
LineCount Property
Provides the total line count in the hatch.


LineCount Property

32-bit
64-bit
CF
P
P

Description:

This property provides the total line count in the hatch.

Declaration:

public int LineCount { get }

Value:

Non-negative integer number.

Default value:

N/A


ImGearVectorHatch Methods

The ImGearVectorHatch Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
CreateLine Method
Creates a new hatch line and adds it to the hatch.
DeleteLine Method
Removes the hatch line specified with Index from the hatch and destroys it.
GetLine Method
Allows you to get the hatch line specified by the Index.


CreateLine Method

32-bit
64-bit
CF
P
P

Description:

This method creates a new hatch line and adds it to the hatch.

Declaration:

public ImageGear.Vector.ImGearVectorHatchline CreateLine()

Return value:

New instance of ImGearVectorHatchline Class object.


DeleteLine Method

32-bit
64-bit
CF
P
P

Description:

This method removes the hatch line specified with Index from the hatch and destroys it.

Declaration:

public void DeleteLine(int Index)

Parameters:

Name
Type
Description
Index
int
Index of the line to be deleted.

Return value:

None.


GetLine Method

32-bit
64-bit
CF
P
P

Description:

This method gets the handle of the hatch line specified by the Index.

Declaration:

public ImageGear.Vector.ImGearVectorHatchline GetLine(int Index)

Parameters:

Name
Type
Description
Index
int
Index of the line in the hatch.

Return value:

New instance of ImGearVectorHatchline Class object.


ImGearVectorHatchline Class

32-bit
64-bit
CF
P
P

Description:

This object represents the line segment for the vector hatch. The vector hatch is an especial kind of the fill type. It is defined by the set of lines with corresponding patterns, offsets and angles. Hatch line pattern is a floating point array, not a bit mask as for line type pattern.

Declaration:

public class ImGearVectorHatchline : ImageGear.Vector.ImGearVectorObject

Members:

Properties
Name
Description
LineAngle Property
Allows you to get/set the angle of the specified hatch line in radians.

Methods
Name
Description
GetBasePoint Method
Returns the base point of the hatch line.
GetOffset Method
Returns the hatch line offset.
GetPattern Method
Returns a container with floating point values specifying the hatch line pattern.
SetBasePoint Method
Sets the base point of the hatch line.
SetOffset Method
Sets the hatch line offset.

See Also:

ImGearVectorObject Class


ImGearVectorHatchline Properties

The ImGearVectorHatchline Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
LineAngle Property
Allows you to get/set the angle of the specified hatch line in radians.


LineAngle Property

32-bit
64-bit
CF
P
P

Description:

This property allows you to get/set the angle of the specified hatch line in radians.

Declaration:

public float LineAngle { get, set }

Value:

Any positive value in the range of 0 - 360.

Default value:

N/A


ImGearVectorHatchline Methods

The ImGearVectorHatchline Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
GetBasePoint Method
Returns the base point of the hatch line.
GetOffset Method
Returns the hatch line offset.
GetPattern Method
Returns a container with floating point values specifying the hatch line pattern.
SetBasePoint Method
Sets the base point of the hatch line.
SetOffset Method
Sets the hatch line offset.


GetBasePoint Method

32-bit
64-bit
CF
P
P

Description:

This method gets the base point of the hatch line. The base point is the starting point of the first line in the hatch.

Declaration:

public ImageGear.Vector.ImGearVectorPoint2D GetBasePoint()

Return value:

New instance of ImGearVectorPoint2D Structure object.


GetOffset Method

32-bit
64-bit
CF
P
P

Description:

This method returns the hatch line offset. X and Y offset coordinates specify the distance between lines in the hatch.

Declaration:

public ImageGear.Vector.ImGearVectorPoint2D GetOffset()

Return value:

New instance of ImGearVectorPoint2D Structure object.


GetPattern Method

32-bit
64-bit
CF
P
P

Description:

This method returns a container with floating point values specifying the hatch line pattern. The first value in the container corresponds to "pen down", second to "pen up", and so on.

Declaration:

public ImageGear.Vector.ImGearVectorFloatCont GetPattern()

Return value:

New instance of ImGearVectorFloatCont Class object.


SetBasePoint Method

32-bit
64-bit
CF
P
P

Description:

This method sets the base point of the hatch line. The base point is a start point of the first line in the the hatch.

Declaration:

public void SetBasePoint(ImageGear.Vector.ImGearVectorPoint2D Point)

Parameters:

Name
Type
Description
Point
ImGearVectorPoint2D Structure
Base point being set.

Return value:

None.

See also:

ImGearVectorPoint2D Structure


SetOffset Method

32-bit
64-bit
CF
P
P

Description:

This method sets the hatch line offset. X and Y offset coordinates specify distance between lines in the hatch.

Declaration:

public void SetOffset(ImageGear.Vector.ImGearVectorPoint2D Offset)

Parameters:

Name
Type
Description
Offset
ImGearVectorPoint2D Structure
Hatch line offset point to be set.

Return value:

None.

See also:

ImGearVectorPoint2D Structure


ImGearVectorLayer Class

32-bit
64-bit
CF
P
P

Description:

This object contains drawing attributes that can be applied to several entities. The layer is created by vector data object and can be attached to any entity.

Declaration:

public class ImGearVectorLayer : ImageGear.Vector.ImGearVectorObject

Members:

Properties
Name
Description
FilltypeIndex Property
Represents an index of the fill type attribute of the layer.
LineThickness Property
Represents the line thickness attribute of the layer.
LinetypeIndex Property
Represents an index of the line type attribute of the layer.
Name Property
Represents the name of the layer.

Methods
Name
Description
CopyTo Method
Copies the layer settings to another layer.
GetDrawColor Method
Gets the draw color of the layer.
GetFillColor Method
Gets the fill color of the layer.
SetDrawColor Method
Sets the draw color of the layer.
SetFillColor Method
Sets the fill color of the layer.

See Also:

ImGearVectorObject Class


ImGearVectorLayer Properties

The ImGearVectorLayer Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
FilltypeIndex Property
Represents an index of the fill type attribute of the layer.
LineThickness Property
Represents the line thickness attribute of the layer.
LinetypeIndex Property
Represents an index of the line type attribute of the layer.
Name Property
Represents the name of the layer.


FilltypeIndex Property

32-bit
64-bit
CF
P
P

Description:

This property represents an index of the fill type attribute of the layer. Actual fill types are contained in the fill types container of the vector data object.

Declaration:

public int FilltypeIndex { get; set }

Value:

An integer value between 0 and (vectdata.FilltypeCount - 1), where vectdata is ImGearVectorData Class object the layer belongs to.

Default value:

0


LineThickness Property

32-bit
64-bit
CF
P
P

Description:

This property represents the line thickness attribute of the layer. Zero thickness means that the line is always drawn with a width of one pixel.

Declaration:

public float LineThickness { get; set }

Value:

Any non-negative value.

Default value:

0


LinetypeIndex Property

32-bit
64-bit
CF
P
P

Description:

This property represents an index of the line type attribute of the layer. Actual line types are contained in the line types container of the vector data object.

Declaration:

public int LinetypeIndex { get; set }

Value:

An integer value between 0 and (vectdata.LinetypeCount - 1), where vectdata is ImGearVectorData Class object the layer belongs to.

Default value:

0


Name Property

32-bit
64-bit
CF
P
P

Description:

This property represents the name of the layer.

Declaration:

public string Name { get; set }

Value:

Any string value that is unique for the given vector data object.

Default value:

Empty string.


ImGearVectorLayer Methods

The ImGearVectorLayer Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
CopyTo Method
Copies the layer settings to another layer.
GetDrawColor Method
Gets the draw color of the layer.
GetFillColor Method
Gets the fill color of the layer.
SetDrawColor Method
Sets the draw color of the layer.
SetFillColor Method
Sets the fill color of the layer.


CopyTo Method

32-bit
64-bit
CF
P
P

Description:

This method copies the layer settings to another layer.

Declaration:

public void CopyTo(ImageGear.Vector.ImGearVectorLayer hDestLayer)

Parameters:

Name
Type
Description
hDestLayer
ImGearVectorLayer Class
Destination layer to copy the settings.

Return value:

None.

See Also:

ImGearVectorLayer Class


GetDrawColor Method

32-bit
64-bit
CF
P
P

Description:

This method gets the draw color of the layer.

Declaration:

public ImageGear.Vector.ImGearVectorColorEx GetDrawColor()

Return value:

The new instance of ImGearVectorColorEx Structure object.


GetFillColor Method

32-bit
64-bit
CF
P
P

Description:

This method gets the fill color of the layer.

Declaration:

public ImageGear.Vector.ImGearVectorColorEx GetFillColor()

Return value:

The new instance of ImGearVectorColorEx Structure object.


SetDrawColor Method

32-bit
64-bit
CF
P
P

Description:

This method sets the draw color of the layer.

Declaration:

public void SetDrawColor(ImageGear.Vector.ImGearVectorColorEx color)

Parameters:

Name
Type
Description
color
ImGearVectorColorEx Structure
The draw color of the layer.

Return value:

None.

See Also:

ImGearVectorColorEx Structure


SetFillColor Method

32-bit
64-bit
CF
P
P

Description:

This method sets the fill color of the layer.

Declaration:

public void SetFillColor(ImageGear.Vector.ImGearVectorColorEx color)

Parameters:

Name
Type
Description
color
ImGearVectorColorEx Structure
The fill color of the layer.

Return value:

None.

See Also:

ImGearVectorColorEx Structure


ImGearVectorLightSource Class

32-bit
64-bit
CF
P
P

Description:

This object implements a light source.

Declaration:

public class ImGearVectorLightSource : ImageGear.Vector.ImGearVectorObject

Members:

Properties
Name
Description
AmbientColor Property
Gets or sets an ambient color of the light source.
CutoffAngle Property
Gets or sets a cutoff angle of the light source.
DiffuseColor Property
Gets or sets a diffuse color of the light source.
Direction Property
Gets or sets the light source direction.
Enabled Property
Enables or disables the light source.
Exponent Property
Gets or sets a spotlight exponent of the light source.
Position Property
Gets or sets the light source position.
SpecularColor Property
Gets or sets a specular color of the light source.

Methods
Name
Description
GetAttenuation Method
Returns constant, linear and quadratic attenuation factors of the light source
SetAttenuation Method
Sets constant, linear and quadratic attenuation factors of the light source

See Also:

ImGearVectorObject Class


ImGearVectorLightSource Properties

The ImGearVectorLightSource Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
AmbientColor Property
Gets or sets an ambient color of the light source.
CutoffAngle Property
Gets or sets a cutoff angle of the light source.
DiffuseColor Property
Gets or sets a diffuse color of the light source.
Direction Property
Gets or sets the light source direction.
Enabled Property
Enables or disables the light source.
Exponent Property
Gets or sets a spotlight exponent of the light source.
Position Property
Gets or sets the light source position.
SpecularColor Property
Gets or sets a specular color of the light source.


AmbientColor Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets an ambient color of light source. The color is presented as an array of four color components (red, green, blue, alpha). Usually the component belongs to the range 0...1, but can be greater than 1.

Declaration:

public float[] AmbientColor { get; set }

Value:

An array of 4 color components - red, green, blue and alpha.

Default value:

(0.5, 0.5, 0.5, 1)


CutoffAngle Property

32-bit
64-bit
CF
P
P

Description:

This property gets or sets a spotlight angle of the light source.

Declaration:

public float CutoffAngle { get; set }

Value:

Floating-point value in the range of 0...90 or 180. 180 means that the light is distributed uniformly.

Default value:

180


DiffuseColor Property

32-bit
64-bit
CF
P
P

Description:

This property gets or sets a diffuse color of light source. The color is presented as an array of four color components (red, green, blue, alpha). Usually the component belongs to the range 0...1, put can be greater than 1

Declaration:

public float[] DiffuseColor { get; set }

Value:

An array of four color components - red, green, blue and alpha.

Default value:

(0, 0, 0, 1)


Direction Property

32-bit
64-bit
CF
P
P

Description:

This property gets or sets the light source direction. The direction is presented as an array of three direction components (x, y, z).

Declaration:

public float[] Direction { get; set }

Value:

An array of three vector components - x, y and z.

Default value:

(0, 0, 1)


Enabled Property

32-bit
64-bit
CF
P
P

Description:

This property enables or disables the light source.

Declaration:

public bool Enabled { get; set }

Value:

True means that the light source is on, False turns the light off.

Default value:

False


Exponent Property

32-bit
64-bit
CF
P
P

Description:

This property gets or sets a spotlight exponent of the light source.

Declaration:

public float Exponent { get; set }

Value:

Floating-point value in the range of 0...128.

Default value:

128


Position Property

32-bit
64-bit
CF
P
P

Description:

This property gets or sets the light source position. The position is presented as a vector of three coordinates (x, y, z).

Declaration:

public float[] Position { get; set }

Value:

An array of three point coordinates - x, y and z.

Default value:

(0, 0, 0)


SpecularColor Property

32-bit
64-bit
CF
P
P

Description:

This property gets or sets a specular color of light source. The color is presented as an array of four color components (red, green, blue, alpha). Usually the component belongs to the range 0...1, but can be greater than 1.

Declaration:

public float[] SpecularColor { get; set }

Value:

An array of four color components - red, green, blue and alpha.

Default value:

(0, 0, 0, 1)


ImGearVectorLightSource Methods

The ImGearVectorLightSource Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
GetAttenuation Method
Returns constant, linear and quadratic attenuation factors of the light source
SetAttenuation Method
Sets constant, linear and quadratic attenuation factors of the light source


GetAttenuation Method

32-bit
64-bit
CF
P
P

Description:

This method returns constant, linear and quadratic attenuation factors of the light source.

Declaration:

public void GetAttenuation(ref float fConstant, ref float fLinear, ref float fQuadratic)

Parameters:

Name
Type
Description
fConstant
float
A buffer for the constant attenuation factor.
fLinear
float
A buffer for the linear attenuation factor.
fQuadratic
float
A buffer for the quadratic attenuation factor

Return value:

None.


SetAttenuation Method

Group: Method

Description:

This method sets constant, linear and quadratic attenuation factors of the light source.

Declaration:

public void SetAttenuation(float fConstant, float fLinear, float fQuadratic)

Parameters:

Name
Type
Description
fConstant
float
New constant attenuation factor.
fLinear
float
New linear attenuation factor.
fQuadratic
float
New quadratic attenuation factor

Return value:

None.


ImGearVectorLinetype Class

32-bit
64-bit
CF
P
P

Description:

This object represents the line type. A line can be drawn as solid or with pattern such as dotted, dashed and so on. Pattern is defined by bit mask and pattern length.

Declaration:

public class ImGearVectorLinetype : ImageGear.Vector.ImGearVectorObject

Members:

Properties
Name
Description
Pattern Property
Provides line type pattern.
Patternlen Property
Provides an absolute length of the pattern.

See Also:

ImGearVectorObject Class


ImGearVectorLinetype Properties

The ImGearVectorLinetype Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
Pattern Property
Provides line type pattern.
Patternlen Property
Provides an absolute length of the pattern.


Pattern Property

32-bit
64-bit
CF
P
P

Description:

This property provides the line type pattern. The pattern is a 32-bit mask. A line segment is drawn if the corresponding bit is 1. The bit mask 0xFFFFFFFF corresponds to a solid line.

Declaration:

public int Pattern { get }

Value:

Any integer number.

Default value:

N/A


Patternlen Property

32-bit
64-bit
CF
P
P

Description:

This property provides the absolute length of the pattern. The pattern is stretched according to this value and repeated periodically when drawing the line.

Declaration:

public float Patternlen { get }

Value:

Any positive value.

Default value:

N/A


ImGearVectorObject Class

32-bit
64-bit
CF
P
P

Description:

Base class for all vector objects. It implements one read/only property Handle Property that returns an internal handle of the object.

Declaration:

public class ImGearVectorObject

Members:

Properties
Name
Description
Handle Property
Returns an internal handle of the object.


ImGearVectorObject Properties

The ImGearVectorObject Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
Handle Property
Returns an internal handle of the object.


Handle Property

32-bit
64-bit
CF
P
P

Description:

This property returns an internal handle of the object. This handle can be used as an unique identifier of the vector object.

Declaration:

public IntPtr Handle { get; }

Value:

IntPtr handle.

Default value:

N/A


ImGearVectorRotation Class

32-bit
64-bit
CF
P
P

Description:

This object provides rotation operations for entities. It uses 3x3 row-aligned rotation matrix internally.

Declaration:

public class ImGearVectorRotation : ImageGear.Vector.ImGearVectorObject

Members:

Methods
Name
Description
AddMatrix Method
Adds a 3x3 matrix to the rotation.
GetMatrix Method
Returns a copy of 3x3 rotation matrix.
Rotate Method
Provides rotation around the specified axis on the specified angle.
SetMatrix Method
Replaces the rotation matrix.

See Also:

ImGearVectorObject Class


ImGearVectorRotation Methods

The ImGearVectorRotation Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
AddMatrix Method
Adds a 3x3 matrix to the rotation.
GetMatrix Method
Returns a copy of 3x3 rotation matrix.
Rotate Method
Provides rotation around the specified axis on the specified angle.
SetMatrix Method
Replaces the rotation matrix.


AddMatrix Method

32-bit
64-bit
CF
P
P

Description:

This method adds a 3x3 matrix to the rotation.

Declaration:

public void AddMatrix(float[] Mat)

Parameters:

Name
Type
Description
Mat
float[]
3x3 matrix being added.

Return value:

None


GetMatrix Method

32-bit
64-bit
CF
P
P

Description:

This method returns a copy of the 3x3 rotation matrix.

Declaration:

public float[] GetMatrix()

Return value:

A float[] copy of the 3x3 rotation matrix.


Rotate Method

32-bit
64-bit
CF
P
P

Description:

This method performs a counterclockwise rotation of angle radians around the vector from the origin through the point (x, y, z). The following example provides rotation in XY plane on PI/2 radians:

rotation.Rotate((float)(Math.PI / 2), 0, 0, 1);

Declaration:

public void Rotate(float Angle, float x, float y, float z)

Parameters:

Name
Type
Description
Angle
float
Rotation angle in radians
x
float
x-coordinate of the rotation vector
y
float
y-coordinate of the rotation vector
z
float
z-coordinate of the rotation vector

Return value:

None.


SetMatrix Method

32-bit
64-bit
CF
P
P

Description:

This method replaces the rotation matrix.

Declaration:

public void SetMatrix(float[] Mat)

Parameters:

Name
Type
Description
Mat
float[]
3x3 rotation matrix being set.

Return value:

None.


ImGearVectorTextObject Class

32-bit
64-bit
CF
P
P

Description:

This object is used by ImGearVectorEntityText Class entity to keep parts of the text string with the same font attributes such as font width, height, char base angle, color and so on.

Declaration:

public class ImGearVectorTextObject : ImageGear.Vector.ImGearVectorObject

Members:

Properties
Name
Description
CharBase Property
Gets/sets char base angle of the text object.
CharSpacing Property
Gets/sets char spacing of the text object.
CharUp Property
Gets/sets char up angle of the text object.
Flags Property
Gets/sets flags describing different effects for the Text Object such as Subscript, Superscript, Struck, Double Struck, Underlined.
Font Property
Gets/sets a font handle assigned to the text object.
FontHeight Property
Gets/sets font height of the text object.
FontWidth Property
Gets/sets font width of the text object.
Text Property
Gets/sets a text string assigned to the text object.

Methods
Name
Description
CopySettingsFrom Method
Copies all settings from one text object to another except text string.
GetTextColor Method
Returns a color of the text object.
GetTextWidth Method
Calculates the actual width of the text string taken into account the current Text Object settings.
SetTextColor Method
Sets a color for the text object.

See Also:

ImGearVectorObject Class


ImGearVectorTextObject Properties

The ImGearVectorTextObject Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
CharBase Property
Gets/sets char base angle of the text object.
CharSpacing Property
Gets/sets char spacing of the text object.
CharUp Property
Gets/sets char up angle of the text object.
Flags Property
Gets/sets flags describing different effects for the Text Object such as Subscript, Superscript, Struck, Double Struck, Underlined.
Font Property
Gets/sets a font handle assigned to the text object.
FontHeight Property
Gets/sets font height of the text object.
FontWidth Property
Gets/sets font width of the text object.
Text Property
Gets/sets a text string assigned to the text object.


CharBase Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets char base angle of the text characters.

Declaration:

public float CharBase { get, set }

Value:

Any value in the range of -2*PI...2*PI

Default value:

N/A


CharSpacing Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets char spacing of the text object. The normal char spacing is 1.

Declaration:

public float CharSpacing { get, set }

Value:

Any value.

Default value:

1


CharUp Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets char up angle of the text characters.

Declaration:

public float CharUp { get, set }

Value:

Any value in the range of -2*PI... 2*PI

Default value:

N/A


Flags Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets flags describing different effects for the Text Object such as Subscript, Superscript, Struck, Double Struck, Underlined.

Declaration:

public int Flags { get, set }

Value:

"Or" combination of ImGearVectTxtFlags Enumeration values or 0.

Default value:

0


Font Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets a font handle assigned to the text object.

Declaration:

public ImageGear.Vector.ImGearVectorFont Font { set; get; }

Value:

ImGearVectorFont Class object.


FontHeight Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets font height of the text object.

Declaration:

public float FontHeight { get, set }

Value:

Any positive value.

Default value:

N/A


FontWidth Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets font width of the text object.

Declaration:

public float FontWidth { get, set }

Value:

Any positive value.

Default value:

N/A


Text Property

32-bit
64-bit
CF
P
P

Description:

This property gets/sets a text string assigned to the text object.

Declaration:

public string Text { get, set }

Value:

Any text string.

Default value:

N/A


ImGearVectorTextObject Methods

The ImGearVectorTextObject Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
CopySettingsFrom Method
Copies all settings from one text object to another except text string.
GetTextColor Method
Returns a color of the text object.
GetTextWidth Method
Calculates the actual width of the text string taken into account the current Text Object settings.
SetTextColor Method
Sets a color for the text object.


CopySettingsFrom Method

32-bit
64-bit
CF
P
P

Description:

This method copies all settings from one text object to another except text string. This can be helpful when creating a new text object with almost the same settings as an existing one.

Declaration:

public void CopySettingsFrom(ImageGear.Vector.ImGearVectorTextObject Object)

Parameters:

Name
Type
Description
Object
ImGearVectorTextObject Class
The source Text Object

Return value:

None.

See Also:

ImGearVectorTextObject Class


GetTextColor Method

32-bit
64-bit
CF
P
P

Description:

This method returns the color of the text object.

Declaration:

public ImageGear.Vector.ImGearVectorColorEx GetTextColor()

Return value:

ImGearVectorColorEx Structure object.


GetTextWidth Method

32-bit
64-bit
CF
P
P

Description:

This method calculates the actual width of a text string, taking into account the current Text Object settings.

Declaration:

public float GetTextWidth(string text)

Parameters:

Name
Type
Description
text
string
Text string whose actual width is to be calculated. If this parameter is NULL, then the width is calculated for the text assigned to the text object.

Return value:

Any positive value.


SetTextColor Method

32-bit
64-bit
CF
P
P

Description:

This method sets a color for the text object.

Declaration:

public void SetTextColor(ImageGear.Vector.ImGearVectorColorEx Color)

Parameters:

Name
Type
Description
Color
ImGearVectorColorEx Structure
Text object color being set.

Return value:

None.

See Also:

ImGearVectorColorEx Structure


ImGearVectorVertexCont Class

32-bit
64-bit
CF
P
P

Description:

This object represents Vertex container class. The vertex container is used by polylines, spline curves and surfaces. The vertex contains point coordinates and visibility flag. It also can have attribute such as bulge, weight (for splines). Vertex container owns the vertices, so, the customer should not take care of they destroying.

Declaration:

public class ImGearVectorVertexCont : ImageGear.Vector.ImGearVectorObject

Members:

Properties
Name
Description
Count Property
Returns total count of the vertices in the vertex container.

Methods
Name
Description
Clear Method
Removes al vertices from the container and destroys them.
CreateVertex Method
Creates a vertex and adds it at the end of the container.
GetAttribType Method
Returns the type of vertex attribute if presented.
GetAttribValue Method
Returns the value of vertex attribute if presented.
GetHidden Method
Returns a flag showing whether the vertex is hidden or not.
GetVertex Method
Returns the vertex object at the specified position.
Init Method
Sets initial size of the vertex container.
SetAttrib Method
Sets an attribute for the vertex.
SetHidden Method
Sets the hidden flag for the vertex.
SetVertex Method
Sets the value for the vertex specified by Index.

See Also:

ImGearVectorObject Class


ImGearVectorVertexCont Properties

The ImGearVectorVertexCont Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
Count Property
Returns total count of the vertices in the vertex container.


Count Property

32-bit
64-bit
CF
P
P

Description:

This property returns total count of the vertices in the vertex container.

Declaration:

public int Count { get }

Value:

Non-negative integer value.

Default value:

N/A


ImGearVectorVertexCont Methods

The ImGearVectorVertexCont Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
Clear Method
Removes al vertices from the container and destroys them.
CreateVertex Method
Creates a vertex and adds it at the end of the container.
GetAttribType Method
Returns the type of vertex attribute if presented.
GetAttribValue Method
Returns the value of vertex attribute if presented.
GetHidden Method
Returns a flag showing whether the vertex is hidden or not.
GetVertex Method
Returns the vertex object at the specified position.
Init Method
Sets initial size of the vertex container.
SetAttrib Method
Sets an attribute for the vertex.
SetHidden Method
Sets the hidden flag for the vertex.
SetVertex Method
Sets the value for the vertex specified by Index.


Clear Method

32-bit
64-bit
CF
P
P

Description:

This method removes all vertices from the container and destroys them.

Declaration:

public void Clear()

Return value:

None.


CreateVertex Method

32-bit
64-bit
CF
P
P

Description:

This method creates a vertex and adds it at the end of the container.

Declaration:

public int CreateVertex()

Return value:

Index of the newly created vertex.


GetAttribType Method

32-bit
64-bit
CF
P
P

Description:

This method returns the type of vertex attribute if present.

Declaration:

public ImageGear.Vector.ImGearVectVertexData GetAttribType(int VertexIndex)

Parameters:

Name
Type
Description
VertexIndex
int
Vertex position in the container.

Return value:

The ImGearVectVertexData Enumeration constant specifying a type of the vertex attribute.


GetAttribValue Method

32-bit
64-bit
CF
P
P

Description:

This method returns the value of vertex attribute if present.

Declaration:

public float GetAttribValue(int VertexIndex)

Parameters:

Name
Type
Description
VertexIndex
int
Vertex position in the container.

Return value:

The floating point value of the attribute (if any).


GetHidden Method

32-bit
64-bit
CF
P
P

Description:

This method returns a flag showing whether the vertex is hidden or not.

Declaration:

public bool GetHidden(int VertexIndex)

Parameters:

Name
Type
Description
VertexIndex
int
Vertex position in the container.

Return value:

True - vertex is hidden, False - otherwise.


GetVertex Method

32-bit
64-bit
CF
P
P

Description:

This method returns the vertex object at the specified position.

Declaration:

public ImageGear.Vector.ImGearVectorVertex GetVertex(int Index)

Parameters:

Name
Type
Description
Index
int
Index of the vertex to be returned.

Return value:

The new instance of ImGearVectorVertex Structure object.


Init Method

32-bit
64-bit
CF
P
P

Description:

This method sets the initial size of the vertex container. This is convenient when vertex count is known in advance.

Declaration:

public void Init(int Count)

Parameters:

Name
Type
Description
Count
int
Initial size of the vertex container.

Return value:

None.


SetAttrib Method

32-bit
64-bit
CF
P
P

Description:

This method sets an attribute (value and type) for the vertex. The vertex can have only one attribute, so, the previous attribute is not saved.

Declaration:

public void SetAttrib(int VertexIndex, ImageGear.Vector.ImGearVectVertexData nAttribType,
float Attrib)

Parameters:

Name
Type
Description
VertexIndex
int
Position of the vertex in container.
nAttribType
ImGearVectVertexData Enumeration
The type of vertex attribute.
Attrib
float
The value of the vertex attribute.

Return value:

None.

See Also:

ImGearVectVertexData Enumeration


SetHidden Method

32-bit
64-bit
CF
P
P

Description:

This method sets the hidden flag for the vertex.

Declaration:

public void SetHidden(int VertexIndex, bool Hidden)

Parameters:

Name
Type
Description
VertexIndex
int
Position of the vertex in the container.
Hidden
bool
Hidden flag being set. True means that outgoing line is hidden. The vertex is not hidden by default.

Return value:

None.


SetVertex Method

32-bit
64-bit
CF
P
P

Description:

This method sets the value for the vertex specified by Index.

Declaration:

public void SetVertex(int Index, ImageGear.Vector.ImGearVectorVertex Vertex)

Parameters:

Name
Type
Description
Index
int
Position of the vertex in the container.
Vertex
ImGearVectorVertex Structure
Vertex value to be set.

Return value:

None.

See Also:

ImGearVectorVertex Structure


ImGearVectorView Class

32-bit
64-bit
CF
P
P

Description:

This object represents a camera and lighting model for displaying the vector content.

Declaration:

public class ImGearVectorView : ImageGear.Vector.ImGearVectorObject

Members:

Properties
Name
Description
AmbientColor Property
Provides an access to the ambient color of the view.
Content Property
Provides an access to the View content.
CullFace Property
Gets or sets face culling mode for the view.
DisplayHiddenLayers Property
Controls displaying the layers that are marked as hidden.
Focus Property
Defines the view lens focus.
LightingEnabled Property
Enables or disables lighting for the view.
MaxLights Property
Returns the number of the available light sources.

Methods
Name
Description
Adjust Method
Adjusts the view bounding box to match the bounding box of the vector data.
GetBkGnd Method
Returns the current background color of the view.
GetLightSource Method
Returns the light source with the specified index.
GetLookPoint Method
Returns the point in 3D space that the view's camera is looking at.
GetMinMax Method
Returns the bounding parallelepiped of the view.
GetName Method
Returns the name of the view.
GetMatrix Method
Returns the current transformation matrix of the view.
Move Method
Moves the camera according to the specified offsets.
Rotate Method
Rotates a camera on the specified angle about the specified vector.
Scale Method
Scales the camera according to the specified scale factors.
SetBkGnd Method
Sets the current background color of the view.
SetLookPoint Method
Sets the point in 3D space that the view's camera is looking at.
SetMatrix Method
Sets the current transformation matrix of the view.
SetMinMax Method
Sets the bounding parallelepiped of the view.
SetName Method
Sets the name of the view.
ToScreen
Converts 3D world coordinates to screen coordinates for the current view.

See Also:

ImGearVectorObject Class


ImGearVectorView Properties

The ImGearVectorView Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
AmbientColor Property
Provides an access to the ambient color of the view.
Content Property
Provides an access to the View content.
CullFace Property
Gets or sets face culling mode for the view.
DisplayHiddenLayers Property
Controls displaying the layers that are marked as hidden.
Focus Property
Defines the view lens focus.
LightingEnabled Property
Enables or disables lighting for the view.
MaxLights Property
Returns the number of the available light sources.


AmbientColor Property

32-bit
64-bit
CF
P
P

Description:

This property provides an access to the ambient color of the view. The ambient color is presented by the array of four floating point values - red, green, blue and alpha. Usually the floating-point color component belongs to the range of 0...1, but can be greater than 1. Ambient color is taken into account only if LightingEnabled Property property is set to True.

Declaration:

public float[] AmbientColor { get; set }

Value:

An array of four floating-point color components.

Default value:

N/A


Content Property

32-bit
64-bit
CF
P
P

Description:

This property provides an access to the view content. The content is usually a block, but can be any entity.

Declaration:

public ImageGear.Vector.ImGearVectorEntity Content { set; get; }

Value:

ImGearVectorEntity Class.

Default value:

N/A


CullFace Property

32-bit
64-bit
CF
P
P

Description:

This property gets or sets face culling mode for the view. Face culling mode specifies whether to render both front- and back-facing facets, only front-facing or only back-facing ones.

Declaration:

public ImGearVectCullFace CullFace{ get; set }

Value:

ImGearVectCullFace Enumeration

Default Value:

ImGearVectCullFace Enumeration.NONE


DisplayHiddenLayers Property

32-bit
64-bit
CF
P
P

Description:

This property enables or disables displaying the layers that are marked as hidden. So, if the hidden layer is attached to the entity and this property is set to False, then the entity is not displayed.

Declaration:

public bool DisplayHiddenLayers { get; set }

Value:

True or False.

Default value:

False


Focus Property

32-bit
64-bit
CF
P
P

Description:

This property defines a lens focus of the view.

Declaration:

public float Focus { get; set }

Value:

Any non-negative floating point value.

Default value:

0


LightingEnabled Property

32-bit
64-bit
CF
P
P

Description:

This property enables or disables lighting. If lighting is enabled then view ambient color and light sources are taken into account when displaying the view content.

Declaration:

public bool LightingEnabled { get; set }

Value:

True or False.

Default value:

False


MaxLights Property

32-bit
64-bit
CF
P
P

Description:

This property returns the total number of the available light sources.

Declaration:

public int MaxLights { get }

Value:

The number of available light sources.

Default value:

N/A


ImGearVectorView Methods

The ImGearVectorView Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
Adjust Method
Adjusts the view bounding box to match the bounding box of the vector data.
GetBkGnd Method
Returns the current background color of the view.
GetLightSource Method
Returns the light source with the specified index.
GetLookPoint Method
Returns the point in 3D space that the view's camera is looking at.
GetMinMax Method
Returns the bounding parallelepiped of the view.
GetName Method
Returns the name of the view.
GetMatrix Method
Returns the current transformation matrix of the view.
Move Method
Moves the camera according to the specified offsets.
Rotate Method
Rotates a camera on the specified angle about the specified vector.
Scale Method
Scales the camera according to the specified scale factors.
SetBkGnd Method
Sets the current background color of the view.
SetLookPoint Method
Sets the point in 3D space that the view's camera is looking at.
SetMatrix Method
Sets the current transformation matrix of the view.
SetMinMax Method
Sets the bounding parallelepiped of the view.
SetName Method
Sets the name of the view.
ToScreen
Converts 3D world coordinates to screen coordinates for the current view.


Adjust Method

32-bit
64-bit
CF
P
P

Description:

This method adjusts the view bounding box to match the bounding box of the vector data. Calling this method prior to rasterization is an easy way to ensure that all of the vector data will be included in the rasterized area after the view or vector data has undergone transformations.

Declaration:

public void Adjust()

Return value:

None.

See Also:

Rasterize Method


GetBkGnd Method

32-bit
64-bit
CF
P
P

Description:

This method returns the current background color of the view.

Declaration:

public ImageGear.Vector.ImGearVectorColor GetBkGnd()

Parameters:

None

Return value:

Current background color of the view.

See Also:

ImGearVectorColor Structure


GetLightSource Method

32-bit
64-bit
CF
P
P

Description:

This method returns the light source with the specified index.

Declaration:

public ImageGear.Vector.ImGearVectorLightSource GetLightSource(int Index)

Parameters:

Name
Type
Description
Index
int
An index of the light source. Must be on the range of (0..MaxLights - 1)

Return value:

ImGearVectorLightSource Class object.


GetLookPoint Method

32-bit
64-bit
CF
P
P

Description:

This method returns the point in 3D space that the view's camera is looking at. See corresponding method SetLookPoint for more information.

Declaration:

public ImageGear.Vector.ImGearVectorPoint3D GetLookPoint()

Return value:

ImGearVectorPoint3D Structure object.

See Also:

ImGearVectorPoint3D Structure


GetMatrix Method

32-bit
64-bit
CF
P
P

Description:

This method returns the current transformation matrix of the view. The matrix consists of 16 floating-point values and is aligned by columns, that is:

a11 a21 a31 a41

a12 a22 a32 a42

a13 a23 a33 a43

a14 a24 a34 a44

Declaration:

public float[] GetMatrix()

Parameters:

None

Return value:

Array of 16 floating-point values.


GetMinMax Method

32-bit
64-bit
CF
P
P

Description:

This method returns the bounding parallelepiped of the view.

Declaration:

public ImageGear.Vector.ImGearVectorMinMax GetMinMax()

Parameters:

None

Return value:

Bounding parallelepiped of the view.

See Also:

ImGearVectorMinMax Structure


GetName Method

32-bit
64-bit
CF
P
P

Description:

This method returns the name of the view.

Declaration:

public string GetName()

Parameters:

None

Return value:

String with the view name.


Move Method

32-bit
64-bit
CF
P
P

Description:

This method moves the camera according to the specified offsets.

Declaration:

public void Move(float fX, float fY, float fZ)

Parameters:

Name
Type
Description
fX
float
Moving distance in X direction.
fY
float
Moving distance in Y direction.
fZ
float
Moving distance in Z direction.

Return value:

None.


Rotate Method

32-bit
64-bit
CF
P
P

Description:

This method rotates the camera on the specified angle about the specified vector.

Declaration:

public void Rotate(float angle, float i, float j, float k, bool bLookPoint)

Parameters:

Name
Type
Description
angle
float
Rotation angle, radians.
i
float
X coordinate of the rotation vector.
j
float
Y coordinate of the rotation vector.
k
float
Z coordinate of the rotation vector.
bLookPoint
bool

Return value:

None.


Scale Method

32-bit
64-bit
CF
P
P

Description:

This method scales the camera according to the specified scale factors.

Declaration:

public void Scale(float fX, float fY, float fZ)

Parameters:

Name
Type
Description
fX
float
X scale factor.
fY
float
Y scale factor.
fZ
float
Z scale factor.

Return value:

None.


SetBkGnd Method

32-bit
64-bit
CF
P
P

Description:

This method sets the current background color of the view.

Declaration:

public void SetBkGnd(ImageGear.Vector.ImGearVectorColor color)

Parameters:

Name
Type
Description
color
ImGearVectorColor Structure
New background color for the View.

Return value:

None

See Also:

ImGearVectorColor Structure


SetLookPoint Method

32-bit
64-bit
CF
P
P

Description:

This method sets the point in 3D space that the view's camera is looking at. By setting a look point with this method, and using the Move method to position the camera, the position and orientation of the camera can easily be defined. Also, the Rotate method can optionally take into account the look point.

Declaration:

public void SetLookPoint(ImageGear.Vector.ImGearVectorPoint3D lookPoint)

Parameters:

Name
Type
Description
lookPoint
ImGearVectorPoint3D Structure
The point in 3D space that the view's camera is looking at.

Return value:

None.

See Also:

ImGearVectorPoint3D Structure


SetMatrix Method

32-bit
64-bit
CF
P
P

Description:

This method sets the current transformation matrix of the view. The matrix consists of 16 floating-point values and is aligned by columns, that is:

a11 a21 a31 a41

a12 a22 a32 a42

a13 a23 a33 a43

a14 a24 a34 a44

Declaration:

public void SetMatrix(float[] Matrix)

Parameters:

Name
Type
Description
Matrix
float[]
New transformation matrix for the View.

Return value:

None.


SetMinMax Method

32-bit
64-bit
CF
P
P

Description:

This method sets the bounding parallelepiped of the view.

Declaration:

public void SetMinMax(ImageGear.Vector.ImGearVectorMinMax minmax)

Parameters:

Name
Type
Description
minmax
ImGearVectorMinMax Structure
New bounding parallelepiped for the View.

Return value:

None.

See Also:

ImGearVectorMinMax Structure


SetName Method

32-bit
64-bit
CF
P
P

Description:

This method sets the new name for the view.

Declaration:

public void SetName(string name)

Parameters:

Name
Type
Description
name
string
New Name for the View.

Return value:

None.


ToScreen

32-bit
64-bit
CF
P
P

Description:

This method converts 3D world coordinates to screen coordinates for the current view.

Declaration:

public Point[] ToScreen(ImGearVectorPoint3D[] worldCoord)

Parameters:

Name
Type
Description
worldCoord
ImGearVectorPoint3D Structure
world coordinates to be converted

Return Value:

An array of screen coordinates.

See Also:

ImGearVectorPoint3D Structure


ImGearVectPage Class

32-bit
64-bit
CF
P
P

Description:

This object represents a vector page which has a background and an ImGearVectorData vector drawing. Operations such as resize and rotate can be performed on this kind of page the same way they are performed on the other pages such as ImGearRasterPage. You can also rasterize a vector page to obtain an ImGearRasterPage from the ImGearVectPage.

Declaration:

public sealed class ImGearVectPage : ImageGear.Core.ImGearVectorPage

Members:

Constructors
Name
Description
ImGearVectPage Constructor
Constructor initializes a new instance of the ImGearVectPage Class class.

Properties
Name
Description
VectorData Property
underlying vector data (drawing) for the page

Methods
Name
Description
Clone Method
Returns a clone of the ImGearVectPage object
Rasterize Method
Returns ImGearRasterPage with rasterized vector data

See Also:

ImGearVectorPage Class


ImGearVectPage Constructors

The ImGearVectPage Class of the ImageGear.Vector Namespace has the following constructors:

Constructors
Name
Description
ImGearVectPage Constructor
Constructor initializes a new instance of the ImGearVectPage Class class.


ImGearVectPage Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor initializes a new instance of the ImGearVectPage Class.

Declaration:

public ImGearVectPage(int width, int height, ImageGear.Core.ImGearColorSpace colorSpace,
int[] channelDepths)

Parameters:

Name
Type
Description
width
int
The width of the page..
height
int
The height of the page.
colorSpace
ImGearColorSpace Structure
The color space of the page.
channelDepths
int[]
The channel depth of the page.

Return Value:

A new instance of the ImGearVectPage Class.

See Also:

ImGearVectPage Class

ImGearColorSpace Structure


ImGearVectPage Properties

The ImGearVectPage Class of the ImageGear.Vector Namespace has the following properties:

Properties
Name
Description
VectorData Property
underlying vector data (drawing) for the page


VectorData Property

32-bit
64-bit
CF
P
P

Description:

This property provides access to the underlying vector data (drawing) for the page.

Declaration:

public ImageGear.Vector.ImGearVectorData VectorData { get; }

Value:

ImGearVectorData Class with vector data.


ImGearVectPage Methods

The ImGearVectPage Class of the ImageGear.Vector Namespace has the following methods:

Methods
Name
Description
Clone Method
Returns a clone of the ImGearVectPage object
Rasterize Method
Returns ImGearRasterPage with rasterized vector data


Clone Method

32-bit
64-bit
CF
P
P

Description:

This method clones the ImGearVectPage Class. It will return a deep copy of the object, so the underlying vector data will be duplicated.

Declaration:

public override ImageGear.Core.ImGearPage Clone()

Return value:

The clone of ImGearVectPage Class object.

See Also:

ImGearPage Class

ImGearVectPage Class


Rasterize Method

32-bit
64-bit
CF
P
P

Description:

This method rasterizes (converts to pixels) the vector data.

Declaration:

public override ImageGear.Core.ImGearRasterPage Rasterize()

Return value:

ImGearRasterPage Class with rasterized vector data.


ImageGear.Vector Namespace Structures

The ImageGear.Vector Namespace has the following structure members:

Structures:
Name
Description
ImGearVectorColor Structure
RGBA color for vector drawing
ImGearVectorColorEx Structure
Indexed color value for vector drawing
ImGearVectorMinMax Structure
min and max coordinates of views and entities
ImGearVectorPoint2D Structure
2D point structure
ImGearVectorPoint3D Structure
3D point structure
ImGearVectorPoint3DEx Structure
Declares an extended three-dimentional point.
ImGearVectorVertex Structure
vertex (3D point with flags)


ImGearVectorColor Structure

32-bit
64-bit
CF
P
P

Description:

This structure declares a color. The color consists of four components - red, green, blue and alpha.

Declaration:

public struct ImGearVectorColor

Members:

Fields
Name
Type
Description
m_r
byte
red color component
m_g
byte
green color component
m_b
byte
blue color component.
m_a
byte
alpha color component. m_a with a value of 255 means fully opaque, m_a with value 0 means fully transparent.


ImGearVectorColorEx Structure

32-bit
64-bit
CF
P
P

Description:

This structure declares an extended color. The extended color has an additional flag showing the source of the color.

Declaration:

public struct ImGearVectorColorEx

Members:

Fields
Name
Type
Description
m_color
ImGearVectorColor Structure
The color value if m_flags is equal to ImGearVectAttrSource Enumeration.ACTUAL.
m_flags
int
Flag showing the actual color source. See ImGearVectAttrSource Enumeration enum for possible values.


ImGearVectorMinMax Structure

32-bit
64-bit
CF
P
P

Description:

This structure declares a bounding parallelepiped of the object.

Declaration:

public struct ImGearVectorMinMax

Members:

Fields
Name
Type
Description
m_xmin
float
Minimum x coordinate
m_xmax
float
Maximum x coordinate
m_ymin
float
Minimum y coordinate.
m_ymax
float
Maximum ycoordinate
m_zmin
float
Minimum z coordinate
m_zmax
float
Maximum z coordinate


ImGearVectorPoint2D Structure

32-bit
64-bit
CF
P
P

Description:

This structure declares a two-dimentional point.

Declaration:

public struct ImGearVectorPoint2D

Members:

Fields
Name
Type
Description
m_x
float
X coordinate of the point.
m_y
float
Y coordinate of the point.


ImGearVectorPoint3D Structure

32-bit
64-bit
CF
P
P

Description:

This structure declares a three-dimentional point.

Declaration:

public struct ImGearVectorPoint3D

Members:

Fields
Name
Type
Description
m_x
float
X coordinate of the point
m_y
float
Y coordinate of the point
m_z
float
Z coordinate of the point


ImGearVectorPoint3DEx Structure

32-bit
64-bit
CF
P
P

Description:

This structure declares an extended three-dimentional point. The extended point contains one additional field that is used as a weight for NURBS surfaces.

Declaration:

public struct ImGearVectorPoint3D

Members:

Fields
Name
Type
Description
m_x
float
X coordinate of the point
m_y
float
Y coordinate of the point
m_z
float
Z coordinate of the point
m_w
float
Weight of the point


ImGearVectorVertex Structure

32-bit
64-bit
CF
P
P

Description:

This structure declares a vertex. The vertex contains the point coordinates and the flags that define some additional vertex attributes, such as bulge, thickness, weight, visibility. These attributes are controlled by the owner vertex container.

Declaration:

public struct ImGearVectorVertex

Members:

Fields
Name
Type
Description
m_flags
uint
Additional flags. This field is completely controlled by the vertex container and must not be changed manually.
m_point
ImGearVectorPoint3D Structure
Actual point coordinates.


ImageGear.Vector Namespace Enumerations

The ImageGear.Vector Namespace has the following enumeration members:

Enumerations:
Name
Description
ImGearVectAlignment Enumeration
Text alignment
ImGearVectArcCloseType Enumeration
How an arc is closed
ImGearVectAttrib Enumeration
Common entity attributes
ImGearVectAttrSource Enumeration
Source of the attribute
ImGearVectCullFace Enumeration
Specifies face culling modes.
ImGearVectDir Enumeration
Direction of rotate operations
ImGearVectEntities Enumeration
Vector entity types
ImGearVectFillMode Enumeration
Specifies the winding rule for the complete polygons.
ImGearVectFillPattern Enumeration
Fill style and pattern
ImGearVectGeometryType Enumeration
Specifies the type of geometry primitives.
ImGearVectGradientSpreadMethod Enumeration
Defines gradient spread methods.
ImGearVectGradientType Enumeration
Defines the types of gradient filling.
ImGearVectGraphics Enumeration
A graphics tool for vector data drawing
ImGearVectMeasurementUnits Enumeration
Contains measurement units used by vector drawings.
ImGearVectNURBSFlags Enumeration
Non-uniform rational Bi-spline flags
ImGearVectObjType Enumeration
Vector object types
ImGearVectTxtFlags Enumeration
Additional effects when drawing a text object
ImGearVectVertexData Enumeration
Vertex data constants


ImGearVectAlignment Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration specifies the text alignment.

Declaration:

public enum ImGearVectAlignment

Values:

Name
Value
Description
NONE
No alighnment (default alignment)
X_LEFT
Text is left-aligned in x direction
X_CENTER
Text is centered in x directiont
X_RIGHT
Text is right-aligned in x direction
Y_TOP
Text is top-aligned in y direction
Y_CENTER
Text is centered in y direction
Y_BOTTOM
Text is bottom-aligned in y direction
Y_BASELINE
Text is base line aligned
CONTINUOUSX
The additional align poiont is used for alignment along x direction
CONTINUOUSY
The additional align poiont is used for alignment along y direction
RESTRICT
The text is restricted
RESTRICT_BASIS
The text is exactly restricted in the restrict box by the base line
RESTRICT_BOXED_CAP
The text is exactly restricted in the restrict box by the bottom
RESTRICT_BOXED_ALL
The same as RESTRICT_BASIS at the moment
RESTRICT_ISOTROPIC_CAP
Isotropic restriction in the restrict box by the bottom
RESTRICT_ISOTROPIC_ALL
Isotropic restriction in the restrict box by the base line
RESTRICT_JUSTIFIED
The text is justified inside the restriction box using variable spacing


ImGearVectArcCloseType Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration specifies the arc closing type.

Declaration:

public enum ImGearVectArcClose

Values:

Name
Value
Description
NONE
The arc is not closed
SECTOR
The arc is closed as a sector.
SEGMENT
The arc is closed as a segment


ImGearVectAttrib Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration specifies different entity attributes.

Declaration:

public enum ImGearVectAttrib

Values:

Name
Value
Description
DRAWCOLOR
Specifies a drawing color
FILLCOLOR
Specifies a filling color.
LINETYPEINDEX
Specifies a line type index
THICKNESS
Specifies a line thickness
FILLTYPEINDEX
TSpecifies a fill type index
OFFSET
Is no longer in use
ROTATION
Is no longer in use
SCALE
Is no longer in use
POSITION
Is no longer in use


ImGearVectAttrSource Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration specifies sources of the entity attributes. Attribute sources are applicable to the draw color, fill color, line type, fill type and thickness.

Declaration:

public enum ImGearVectAttrSource

Values:

Name
Value
Description
ACTUAL
The actual value of attribute is used.
NONE
The same as ACTUAL
BLOCK
The attribue value is defined by the parent block.
LAYER
The attribute value is defined by the layer


ImGearVectCullFace Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration specifies face culling modes.

Declaration:

public enum ImGearVectCullFace

Values:

Name
Value
Description
NONE
0
No facets are culled (both front and back facing faces are rendered)
BACK
1
Back-facing facets are culled (only front-facing faces are rendered)
FRONT
2
Front-facing facets are culled (only back-facing faces are rendered)


ImGearVectDir Enumeration

32-bit
64-bit
CF
P
P

Description:

These constants define a direction of rotate operations.

Declaration:

public enum ImGearVectDir

Values:

Name
Value
Description
XY
rotation in XY direction
YZ
rotation in YZ direction
XZ
rotation in XZ direction


ImGearVectEntities Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration specifies the type of the entity.

Declaration:

public enum ImGearVectEntities

Values:

Name
Value
Description
ARC
The entity is an elliptical arc
BEZIER_CURVE
The entity is a Bezier curve
BEZIER_SURFACE
The entity is a Bezier surface
BLOCK
The entity is a block
CONNECTION
The entity is a connection edge
EASY_SURFACE
The entity is an easy surface
EASYLINE
The entity is an easy line.
ELLIPSE
The entity is an ellipse
FIGURE
The entity is a figure
GEOMETRY
The entity is a geometry
INSERTION
The entity is an insertion
NURBS_CURVE
The entity is a NURBS curve
NURBS_SURFACE
The entity is a NURBS surface
POLYLINE
The entity is a polyline
POLYLINEEX
The entity is an extended polyline
RASTER
The entity is a raster
SHELL
The entity is a shell
SHELLEX
The entity is an extended shell
SOLID
The entity is a solid
TEXT
The entity is a text
UNKNOWN
Unknow entity.
VIEWPORT
The entity is a viewport


ImGearVectFillMode Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration specifies the winding rule for the complete polygons.

Declaration:

public enum ImGearVectFillMode

Values:

Name
Value
Description
ODD
"odd" rule is used
NONZERO
"nonzero" rule is used.
POSITIVE
This operation is useful for polygon CSG (computational solid geometry) operations
NEGATIVE
This operation is useful for polygon CSG (computational solid geometry) operations
ABS_GEQ_TWO
This operation is useful for polygon CSG (computational solid geometry) operations


ImGearVectFillPattern Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration specifies constants describing different fill patterns.

Declaration:

public enum ImGearVectFillPattern

Values:

Name
Value
Description
SOLID
solid filling
HATCH_BDIAGONAL
right-to-left diagonal filling
HATCH_CROSS
cross filling
HATCH_DIAGCROSS
diagonal cross filling
HATCH_FDIAGONAL
left-to-right diagonal filling
HATCH_HORIZONTAL
horizontal line filling
HATCH_VERTICAL
vertical line filling
HATCH_MASK
mask that allow detection and selection the hatch fill type
SHADOW_MASK
mask that allows setting the shadow fill pattern. Shadow pattern is created by right-shifting the shadow level (1-100) on 4 bits and adding to the shadow mask
HATCH_VECTOR
vector hatch pattern


ImGearVectGeometryType Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration specifies the type of geometry primitives.

Declaration:

public enum ImGearVectGeometryType

Values:

Name
Value
Description
POINTS
Each vertex is a single point.
LINES
each pair of vertices is an independent line segment
LINE_LOOP
Vertices define a connected group of line segments from the first vertex to the last
LINE_STRIP
Vertices define a connected group of line segments from the first vertex to the last, then back to the first
TRIANGLES
Each triplet of vertices is an independent triangle
TRIANGLE_STRIP
Vertices define a connected group of triangles. One triangle is defined for each vertex presented after the first two vertices. For odd n, vertices n, n + 1, and n + 2 define triangle n. For even n, vertices n + 1, n, and n + 2 define triangle n. N 2 triangles are drawn
TRIANGLE_FAN
Vertices define a connected group of triangles. One triangle is defined for each vertex presented after the first two vertices. Vertices 1, n + 1, and n + 2 define triangle n. N 2 triangles are drawn
QUADS
Each group of four vertices is an independent quadrilateral
QUAD_STRIP
Vertices define a connected group of quadrilaterals. One quadrilateral is defined for each pair of vertices presented after the first pair. Vertices 2n 1, 2n, 2n + 2, and 2n + 1 define quadrilateral n. N quadrilaterals are drawn
POLYGON
Vertices define a single, convex polygon


ImGearVectGradientSpreadMethod Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration defines gradient spread methods. Spread method specifies how the gradient is expanded.

Declaration:

public enum ImGearVectGradientSpreadMethod

Values:

Name
Description
Pad
Expand the first or last color.
Reflect
Repeat the gradient with reflection.
Repeat
Repeat the gradient periodically.


ImGearVectGradientType Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration defines the types of gradient filling.

Declaration:

public enum ImGearVectGradientType

Values:

Name
Description
Linear
Linear gradient.
Radial
Radial gradient.


ImGearVectGraphics Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration specifies the type of the vector graphics to be used for displaying vector data.

Declaration:

public enum ImGearVectGraphics

Values:

Name
Value
Description
AUTO
The graphics type is defined automatically
OPENGL
OpenGL graphics is used
WINAPI
Windows GDI graphics is used.
DIRECT3D
Direct3D graphics is used.


ImGearVectMeasurementUnits Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration contains measurement units used by vector drawings.

Declaration:

public enum ImGearVectMeasurementUnits

Values:

Name
Value
Description
UNKNOWN
unknown units
MM
millimeters
CM
centimeters
M
meters
INCHES
inches
PLTS
plot units (1/40 mm)
TWIPS
twips (1/1440 inch)


ImGearVectNURBSFlags Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration specifies different flags for NURBS curve and surface.

Declaration:

public enum ImGearVectNURBSFlags

Values:

Name
Value
Description
UNIFORM
The NURBS curve or surface is uniform
RATIONAL
The NURBS curve or surface is rational.
MCLOSED
The NURBS curve or surface is closed in M direction
NCLOSED
The NURBS surface is closed in N direction
MINTERPOLATE
Not in use
NINTERPOLATE
Not in use
MFIT
The curve or surface is interpolated by qubic spline in M direction
NFIT
The surface is interpolated by qubic spline in N direction


ImGearVectObjType Enumeration

32-bit
64-bit
CF
P
P

Description:

These constants define vector object types.

Declaration:

public enum ImGearVectObjType

Values:

Name
Value
Description
UNKNOWN
unknown object type
ENTITY
vector entity
DRWNG
vector drawing
VIEW
vector view
FONT
font
VERTEXCONT
vertex container
DBLCONT
double precision container
ROTATION
rotation
LINETYPE
line type
FILLTYPE
fill type
LAYER
drawing layer
LAYERCONT
layer container
ENTITYCONT
entity container
TEXTOBJ
text
VECTORHATCH
hatch pattern definition
HATCHLINE
hatch line definition


ImGearVectTxtFlags Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration specifies different text object effects.

Declaration:

public enum ImGearVectTxtFlags

Values:

Name
Value
Description
UNDERLINED
The text object is underlined
STRUCK
The text object is struck.
DBLSTRUCK
The text object is struck with two lines
SUPERSCRIPT
The text object is a superscript
SUBSCRIPT
The text object is a subscript


ImGearVectVertexData Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration specifies the type of additional data associated with the vertex.

Declaration:

public enum ImGearVectVertexData

Values:

Name
Value
Description
NONE
The vertex doesn't have any additional attributes
BULGE
The outgoing line segment is bulged
THICKNESS
The outgoing line segment has the local thickness.
WEIGHT
The vertex has weight. Used in the rational B-splines


ImageGear.Web.Forms Namespace

ImageGear.Web.Forms Namespace

32-bit
64-bit
CF
P
P

Description:

ImageGear.Web.Forms namespace provides you with objects that provide the ability to view and process images through the internet. Here is the reference of public Web-Forms namespace API.

Declaration:

namespace ImageGear.Web.Forms

Members:

Classes:
Name
Description
ImGearSelectEventArgs Class
Provides data for the Select event.
ImGearWebPageView Class
Provides the ability to display images in an internet browser window.

Delegates:
Name
Description
SelectEventHandler Delegate
Represents the method that will handle Select event of a ImGearWebPageView object.

Enumerations:
Name
Description
ImGearSelectionMode Enumeration
Specifies selection mode.


ImageGear.Web.Forms Namespace Classes

The ImageGear.Web.Forms Namespace has the following class members:

Classes:
Name
Description
ImGearSelectEventArgs Class
Provides data for the Select event.
ImGearWebPageView Class
Provides the ability to display images in an internet browser window.


ImGearSelectEventArgs Class

32-bit
64-bit
CF
P
P

Description:

This class provides data for the Select Event of a ImGearWebPageView Class control.

Declaration:

public class ImGearSelectEventArgs : System.EventArgs

Members:

Constructors
Name
Description
ImGearSelectEventArgs Constructor
Creates instance of ImGearSelectEventArgs Class object.

Properties
Name
Description
SelectionRectangle Property
Specifies selected rectangle.


ImGearSelectEventArgs Constructors

The ImGearSelectEventArgs Class of the ImageGear.Web.Forms Namespace has the following constructors:

Constructors
Name
Description
ImGearSelectEventArgs Constructor
Creates instance of ImGearSelectEventArgs Class object.


ImGearSelectEventArgs Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates an instance of ImGearSelectEventArgs Class object.

Declaration:

public ImGearSelectEventArgs ( ImageGear.Core.ImGearRectangle rect )

Parameters:

Name
Type
Description
rect
ImGearRectangle Structure
Specifies selected rectangle.

Return Value:

New instance of ImGearSelectEventArgs Class object.

See Also:

ImGearSelectEventArgs Class

ImGearRectangle Structure


ImGearSelectEventArgs Properties

The ImGearSelectEventArgs Class of the ImageGear.Web.Forms Namespace has the following properties:

Properties
Name
Description
SelectionRectangle Property
Specifies selected rectangle.


SelectionRectangle Property

32-bit
64-bit
CF
P
P

Description:

This property specifies the selected rectangle. Rectangle uses client screen coordinates, relative to the upper left corner of the ImGearWebPageView Class control.

Declaration:

public ImageGear.Core.ImGearRectangle SelectionRectangle { get, set }

Value:

ImGearRectangle Structure object.

Default value:

N/A

See Also:

ImGearRectangle Structure


ImGearWebPageView Class

32-bit
64-bit
CF
P
P

Description:

This class provides the ability to display images in an internet browser window.

Declaration:

public sealed class ImGearWebPageView : System.Web.UI.WebControls.WebControl

Members:

Constructors
Name
Description
ImGearWebPageView Constructor
Creates an instance of ImGearWebPageView Class.

Properties
Name
Description
CacheCleanupTimeout Property
Specifies timeout, in minutes, for deletion of temporary files on the server.
ClientRectangle Property
Returns dimensions of the whole client area.
ImagePage Property
Gets or sets ImGearPage object associated with the control.
PageDisplay Property
Provides access to display settings of the control.
SelectionMode Property
Specifies selection mode.

Methods
Name
Description
ConvertCoordinates Method
Translates coordinates between image and device coordinate systems.
Dispose Method
Releases the resources used by the object.
GetScrollBarDimensions Method
Returns scrollbar dimensions.
GetScrollParams Method
Returns scrolling parameters.
IsScrollBarVisible Method
Returns visibility attribute of scroll bar.
SetScrollParams Method
Updates scroll bar attributes.
ShowScrollBar Method
Shows or hides scrollbars.

Events
Name
Description
Select Event
Occurs when the user selects a rectangle on the client computer.


ImGearWebPageView Constructors

The ImGearSelectEventArgs Class of the ImageGear.Web.Forms Namespace has the following constructors:

Constructors
Name
Description
ImGearWebPageView Constructor
Creates an instance of ImGearWebPageView Class.


ImGearWebPageView Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates an instance ot ImGearWebPageView Class object.

Declaration:

public ImGearWebPageView (  )

Return Value:

New instance of ImGearWebPageView Class object.

See Also:

ImGearWebPageView Class


ImGearWebPageView Properties

The ImGearWebPageView Class of the ImageGear.Web.Forms Namespace has the following properties:

Properties
Name
Description
CacheCleanupTimeout Property
Specifies timeout, in minutes, for deletion of temporary files on the server.
ClientRectangle Property
Returns dimensions of the whole client area.
ImagePage Property
Gets or sets ImGearPage object associated with the control.
PageDisplay Property
Provides access to display settings of the control.
SelectionMode Property
Specifies selection mode.


CacheCleanupTimeout Property

32-bit
64-bit
CF
P
P

Description:

This property specifies timeout, in minutes, for deletion of temporary files on the server. Every time the control loads on the server (upon every postback), it deletes all temporary images that are older than CacheCleanupTimeout minutes.

Temporary images reside in the following folders:

  • ImGearWebPageView\Cache
  • ImGearWebPageView\Tmp

Declaration:

public int CacheCleanupTimeout {  get,  set }

Default value:

60


ClientRectangle Property

32-bit
64-bit
CF
P
P

Description:

This property returns the rectangle ImageGear display code that should be used as the client area rectangle.

Declaration:

public ImageGear.Core.ImGearRectangle ClientRectangle { get; }

Value:

ImGearRectangle Structure

See Also:

ImGearRectangle Structure


ImagePage Property

32-bit
64-bit
CF
P
P

Description:

This property gets or sets ImGearPage Class object associated with the control. The image set by this property will be displayed on the client computer.

If ImagePage is NULL, no image will be shown on the client computer; client area of the control will be filled with background color, according to display settings.

Declaration:

public ImageGear.Core.ImGearPage ImagePage { get, set }

Value:

ImGearPage Class object.

Default value:

NULL

See Also:

ImGearPage Class


PageDisplay Property

32-bit
64-bit
CF
P
P

Description:

This property provides access to display settings of the ImGearWebPageView Class object.

If ImGearWebPageView Class is NULL, default display settings are used.

Declaration:

public ImageGear.Display.ImGearPageDisplay PageDisplay { get, set }

Value:

ImGearPageDisplay Class object.

Default value:

NULL

See Also:

ImGearPageDisplay Class


SelectionMode Property

32-bit
64-bit
CF
P
P

Description:

This property specifies selection mode for the ImGearWebPageView Class object. If SelectionMode is set to Fire or FireAndZoom, the user can draw a selection rectangle over the image. When the user finishes drawing the rectangle, Select event is raised on the server. Coordinates of selected rectangle are passed with the event parameters.

When SelectionMode is set to FireAndZoom, ImGearWebPageView Class zooms the image into selected rectangle.

Declaration:

public ImageGear.Web.Forms.ImGearSelectionModes SelectionMode { get, set }

Value:

ImGearSelectionMode Enumeration enum value.

Default value:

ImGearSelectionMode Enumeration.None

See Also:

ImGearSelectionMode Enumeration


ImGearWebPageView Methods

The ImGearWebPageView Class of the ImageGear.Web.Forms Namespace has the following methods:

Methods
Name
Description
ConvertCoordinates Method
Translates coordinates between image and device coordinate systems.
Dispose Method
Releases the resources used by the object.
GetScrollBarDimensions Method
Returns scrollbar dimensions.
GetScrollParams Method
Returns scrolling parameters.
IsScrollBarVisible Method
Returns visibility attribute of scroll bar.
SetScrollParams Method
Updates scroll bar attributes.
ShowScrollBar Method
Shows or hides scrollbars.


ConvertCoordinates Method

32-bit
64-bit
CF
P
P

Description:

This method translates coordinates between image and device coordinate systems (depending on the value of the `Mode' parameter).

Declaration:

public void ConvertCoordinates(ImageGear.Display.ImGearCoordConvModes Mode,
ImageGear.Core.ImGearPoint[] PointsToConvert)

Parameters:

Name
Type
Description
Mode
ImGearCoordConvModes Enumeration
Specifies translation direction; either IMAGE_TO_DEVICE or DEVICE_TO_IMAGE
PointsToConvert
ImGearPoint[]
ImGearPoint Structure array with point coordinates.

Return Value:

None.

See Also:

ImGearCoordConvModes Enumeration

ImGearPoint Structure


Dispose Method

32-bit
64-bit
CF
P
P

Description:

This method releases resources used by the ImGearWebPageView Class object.

Declaration:

public override void Dispose (  )

Return Value:

None.


GetScrollBarDimensions Method

32-bit
64-bit
CF
P
P

Description:

This method returns width and height dimensions of the windows scroll bar.

Declaration:

public ImageGear.Core.ImGearSize GetScrollBarDimensions
(ImageGear.Core.ImGearScrollBarType sbType)

Parameters:

Name
Type
Description
sbType
ImGearScrollBarType Enumeration
Specifies the scrollbar whose attributes are requested.

Return Value:

New instance of ImGearSize Structure object.

Remarks:

See ImGearPageView Class implementation.

See Also:

ImGearSize Structure

ImGearScrollBarType Enumeration

ImGearPageView Class


GetScrollParams Method

32-bit
64-bit
CF
P
P

Description:

This method obtains the attributes of the scrollbar specified.

Declaration:

public void GetScrollParams (ImageGear.Core.ImGearScrollBarType sbType, ref
ImageGear.Core.ImGearScrollInfo SI)

Parameters:

Name
Type
Description
sbType
ImGearScrollBarType Enumeration
Specifies the scrollbar whose attributes are requested
SI
ImGearScrollInfo Structure
Output parameter; horizontal or vertical field of this parameter is updated with requested information

Remarks:

See ImGearPageView Class implementation.

Return Value:

None.

See Also:

ImGearScrollBarType Enumeration

ImGearScrollInfo Structure

ImGearPageView Class


IsScrollBarVisible Method

32-bit
64-bit
CF
P
P

Description:

This method returns visibility state of the scrollbar specified.

Declaration:

public System.Boolean IsScrollBarVisible (ImageGear.Core.ImGearScrollBarType sbType)

Parameters:

Name
Type
Description
sbType
ImGearScrollBarType Enumeration
Specifies the scrollbar whose attributes are requested.

Return Value:

True or False.

See Also:

ImGearScrollBarType Enumeration


SetScrollParams Method

32-bit
64-bit
CF
P
P

Description:

This method updates the state of specified scrollbar with new values.

Declaration:

public void SetScrollParams (ImageGear.Core.ImGearScrollBarType sbType,
ImageGear.Core.ImGearScrollInfo SI, bool bReadraw)

Parameters:

Name
Type
Description
sbType
ImGearScrollBarType Enumeration
Specifies the scrollbar whose attributes are requested
SI
ImGearScrollInfo Structure
New scrollbar state
bReadraw
bool
Specifies whether or not to redraw image in window

Remarks:

See ImGearPageView Class implementation.

Return Value:

None.

See Also:

ImGearScrollBarType Enumeration

ImGearZoomInfo Structure

ImGearPageView Class

ImGearScrollInfo Structure


ShowScrollBar Method

32-bit
64-bit
CF
P
P

Description:

Change visibility state of scrollbars associated with window.

Declaration:

public void ShowScrollBar (ImageGear.Core.ImGearScrollBarType sbType, bool bState)

Parameters:

Name
Type
Description
sbType
ImGearScrollBarType Enumeration
Specifies the scrollbar whose attributes are requested
bState
bool
Show (true) or hide (false) scrollbar

Remarks:

See ImGearPageView Class implementation.

Return Value:

None.

See Also:

ImGearScrollBarType Enumeration

ImGearPageView Class


ImGearWebPageView Events

The ImGearWebPageView Class of the ImageGear.Web.Forms Namespace has the following events:

Events
Name
Description
Select Event
Occurs when the user selects a rectangle on the client computer.


Select Event

32-bit
64-bit
CF
P
P

Description:

This event is fired when the user selects a rectangle on the client computer.

Declaration:

public event ImageGear.Web.Forms.SelectEventHandler Select;

See Also:

SelectEventHandler Delegate


ImageGear.Web.Forms Namespace Delegates

The ImageGear.Web.Forms Namespace has the following delegate members:

Delegates:
Name
Description
SelectEventHandler Delegate
Represents the method that will handle Select event of a ImGearWebPageView object.


SelectEventHandler Delegate

32-bit
64-bit
CF
P
P

Description:

Represents the method that will handle Select Event of a ImGearWebPageView Class object.

Declaration:

public delegate void SelectEventHandler(object sender,
ImageGear.Web.Forms.ImGearSelectEventArgs e)

Parameters:

Name
Type
Description
sender
object
The source of the event.
e
ImGearSelectEventArgs Class
A ImGearSelectEventArgs Class object that contains the event data.

See Also:

ImGearSelectEventArgs Class


ImageGear.Web.Forms Namespace Enumerations

The ImageGear.Web.Forms Namespace has the following enumeration members:

Enumerations:
Name
Description
ImGearSelectionMode Enumeration
Specifies selection mode.


ImGearSelectionMode Enumeration

32-bit
64-bit
CF
P
P

Description:

Specifies selection modes for the ImGearWebPageView Class.

Declaration:

public sealed enum ImGearSelectionMode

Values:

Name
Value
Description
Fire
1
Fire an event when the user has selected a rectangle
FireAndZoom
2
Fire an event and zoom image into selected rectangle when the user has selected a rectangle.
None
0
Disable rectangle selection.


ImageGear.Windows.Forms Namespace

ImageGear.Windows.Forms Namespace

32-bit
64-bit
CF
P
P
P

Description:

The ImageGear.WinForms namespace provides common GUI functionality that can simplify development of Windows Forms based applications. This functionality is implemented in a separate assembly, using only public ImageGear API, with source code provided to enable modifications.

NOTE: ImGearARTLoadingSelection Class and ImGearARTSavingSelection Class are not available in ImageGear .NET CF edition.

Declaration:

namespace ImageGear.Windows.Forms

Members:

Classes:
Name
Description
IGWarningInfoBox Class
A window for displaying ImageGear warnings.
ImGearARTLoadingSelection Class
Identifies a file and format selected in an open file dialog for ART annotations.
ImGearARTSavingSelection Class
Identifies a file and format selected in a save file dialog for ART annotations.
ImGearColorBookProperties Class
GUI dialog class for accessing color book properties.
ImGearColorBookSettings Class
GUI dialog class for accessing the available color books.
ImGearColorProfileSettings Class
GUI dialog class for ICC setting.
ImGearExtraChannelColorChoice Class
GUI dialog class for choosing a color for the specified extra channel.
ImGearExtraChannelsSwitching Class
GUI dialog class for enabling and disabling color channels for display.
ImGearFile Class
Identifies a file and its location.
ImGearLayerProperties Class
GUI dialog for accessing and changing the image layer's properties.
ImGearLayersSwitching Class
GUI dialog for turning on and off the layers of the layered page, and flattening them into the raster output page.
ImGearLoadingSelection Class
Identifies a file and format selected in an open file dialog.
ImGearLoadingSelectionEx Class
This class identifies a file, format and page index selected in the open file dialog with preview shown by the SelectLocalFileToLoadEx Method.
ImGearLocalFile Class
Represents a file on a local file system.
ImGearMagnifier Class
Provides interactive magnifying glass style user interface for displayed images.
ImGearPageView Class
A control for displaying an image within a form.
ImGearRemoteFile Class
Represents a file on a remote file system.
ImGearSavingSelection Class
Identifies a file and format selected in a save file dialog.
ImGearSpotColorsMissingBox Class
GUI dialog class for processing missing spot colors.
ImGearWinForms Class
Provides methods for using common dialogs and error handling infrastructure.
InputBox Class
A window for prompting the user for an input string.

Enumerations:
Name
Description
ImGearColorProfileActivationMode Enumeration
Specifies color profile activation modes.
ImGearMagnifierShapeType Enumeration
Specifies the shape type of magnifier.


ImageGear.Windows.Forms Classes

The ImageGear.Windows.Forms Namespace has the following class members:

Classes:
Name
Description
IGWarningInfoBox Class
A window for displaying ImageGear warnings.
ImGearARTLoadingSelection Class
Identifies a file and format selected in an open file dialog for ART annotations.
ImGearARTSavingSelection Class
Identifies a file and format selected in a save file dialog for ART annotations.
ImGearColorBookProperties Class
GUI dialog class for accessing color book properties.
ImGearColorBookSettings Class
GUI dialog class for accessing the available color books.
ImGearColorProfileSettings Class
GUI dialog class for ICC setting.
ImGearExtraChannelColorChoice Class
GUI dialog class for choosing a color for the specified extra channel.
ImGearExtraChannelsSwitching Class
GUI dialog class for enabling and disabling color channels for display.
ImGearFile Class
Identifies a file and its location.
ImGearLoadingSelection Class
Identifies a file and format selected in an open file dialog.
ImGearLoadingSelectionEx Class
This class identifies a file, format and page index selected in the open file dialog with preview shown by the SelectLocalFileToLoadEx Method.
ImGearLocalFile Class
Represents a file on a local file system.
ImGearMagnifier Class
Provides interactive magnifying glass style user interface for displayed images.
ImGearPageView Class
A control for displaying an image within a form.
ImGearRemoteFile Class
Represents a file on a remote file system.
ImGearSavingSelection Class
Identifies a file and format selected in a save file dialog.
ImGearSpotColorsMissingBox Class
GUI dialog class for processing missing spot colors.
ImGearWinForms Class
Provides methods for using common dialogs and error handling infrastructure.
InputBox Class
A window for prompting the user for an input string.


IGWarningInfoBox Class

32-bit
64-bit
CF
P
P
P

32-bit
64-bit
CF
P
P
P

Description:

This class provides a window for displaying ImageGear warning messages.

Declaration:

public class IGWarningInfoBox : System.Windows.Forms.Form

Members:

Constructors
Name
Description
IGWarningInfoBox Constructor
Creates and initializes an instance of IGWarningInfoBox class.

Methods
Name
Description
AddWarning Method
Adds a warning to the list of displayed warnings.
ClearWarnings Method
Clears the list of displayed warnings.


IGWarningInfoBox Constructors

The IGWarningInfoBox Class of the ImageGear.Windows.Forms Namespace has the following constructors:

Constructors
Name
Description
IGWarningInfoBox Constructor
Creates and initializes an instance of IGWarningInfoBox class.


IGWarningInfoBox Constructor

32-bit
64-bit
CF
P
P
P

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of IGWarningInfoBox Class.

Declaration:

public sub IGWarningInfoBox()

Return Value:

N/A

See Also:

IGWarningInfoBox Class


IGWarningInfoBox Methods

The IGWarningInfoBox Class of the ImageGear.Windows.Forms Namespace has the following methods:

Methods
Name
Description
AddWarning Method
Adds a warning to the list of displayed warnings.
ClearWarnings Method
Clears the list of displayed warnings.


AddWarning Method

32-bit
64-bit
CF
P
P
P

Description:

This method adds a warning to the list of displayed warnings.

Declaration:

public void AddWarning(ImageGear.Core.ImGearWarning warning)

Parameters:

Name
Type
Description
warning
ImGearWarning Class
Warning to add.

Return Value:

N/A

See Also:

ImGearWarning Class


ClearWarnings Method

32-bit
64-bit
CF
P
P
P

Description:

This method clears the list of displayed warnings.

Declaration:

public void ClearWarnings ( )

Return Value:

N/A


ImGearAfterDrawEventArgs Class

32-bit
64-bit
CF
P
P
P

Description:

Event arguments class for ImGearPageView Class . AfterDrawEvent Event.

Declaration:

public class ImGearAfterDrawEventArgs : EventArgs

Members:

Constructors
Name
Description
ImGearAfterDrawEventArgs Constructor
Creates and initializes an instance of the ImGearAfterDrawEventArgs Class with a Graphics object.

Properties
Name
Description
graphics Property
Graphics object used for painting on the ImGearPageView Class for which the event was triggered.


ImGearAfterDrawEventArgs Constructors

The ImGearAfterDrawEventArgs Class of the ImageGear.Windows.Forms Namespace has the following constructors:

Constructors
Name
Description
ImGearAfterDrawEventArgs Constructor
Creates and initializes an instance of the ImGearAfterDrawEventArgs Class with a Graphics object.


ImGearAfterDrawEventArgs Constructor

32-bit
64-bit
CF
P
P
P

Description:

Creates and initializes an instance of the ImGearAfterDrawEventArgs Class with a Graphics object.

Declaration:

public ImGearAfterDrawEventArgs(System.Drawing.Graphics gr)

Return Value:

The new instance of ImGearAfterDrawEventArgs Class.

See Also:

ImGearPageView Class . AfterDrawEvent Event


ImGearAfterDrawEventArgs Properties

The ImGearAfterDrawEventArgs Class of the ImageGear.Windows.Forms Namespace has the following properties:

Properties
Name
Description
graphics Property
Graphics object used for painting on the ImGearPageView Class for which the event was triggered.


graphics Property

32-bit
64-bit
CF
P
P
P

Description:

Graphics object used for painting on the ImGearPageView Class for which the event was triggered.

Declaration:

public System.Drawing.Graphics graphics[ get]

See Also:

ImGearPageView Class . AfterDrawEvent Event


ImGearARTLoadingSelection Class

32-bit
64-bit
CF
P
P

Description:

This class identifies a file and format selected in an open file dialog for ART annotations.

Declaration:

public class ImGearARTLoadingSelection : System.Object

Members:

Properties
Name
Description
File Property
File selected in the open file dialog.
Format Property
Format selected in the open file dialog.


ImGearARTLoadingSelection Properties

The ImGearARTLoadingSelection Class of the ImageGear.Windows.Forms Namespace has the following properties:

Properties
Name
Description
File Property
File selected in the open file dialog.
Format Property
Format selected in the open file dialog.


File Property

32-bit
64-bit
CF
P
P

Description:

This property identifies the file selected in the open file dialog.

Declaration:

public ImageGear.Windows.Forms.ImGearFile File { get }

Value:

ImGearFile Class.

See Also:

ImGearFile Class


Format Property

32-bit
64-bit
CF
P
P

Description:

This property identifies the format selected in the open file dialog.

Declaration:

public readonly ImageGear.ART.ImGearARTSaveType Format { get }

Value:

ImGearARTSaveType Enumeration enumeration.

See Also:

ImGearARTSaveType Enumeration


ImGearARTSavingSelection Class

32-bit
64-bit
CF
P
P

Description:

This class identifies a file and format selected in a save file dialog for ART annotations.

Declaration:

public class ImGearARTSavingSelection : System.Object

Members:

Properties
Name
Description
File Property
File selected in the save file dialog.
Format Property
Format selected in the save file dialog.


ImGearARTSavingSelection Properties

The ImGearARTSavingSelection Class of the ImageGear.Windows.Forms Namespace has the following properties:

Properties
Name
Description
File Property
File selected in the save file dialog.
Format Property
Format selected in the save file dialog.


File Property

32-bit
64-bit
CF
P
P

Description:

This property identifies the file selected in the save file dialog.

Declaration:

public ImageGear.Windows.Forms.ImGearFile File { get }

Value:

ImGearFile Class

See Also:

ImGearFile Class


Format Property

32-bit
64-bit
CF
P
P

Description:

This property identifies the format selected in the save file dialog.

Declaration:

public readonly ImageGear.ART.ImGearARTSaveType Format { get }

Value:

ImGearARTSaveType Enumeration

See Also:

ImGearARTSaveType Enumeration


ImGearColorBookProperties Class

32-bit
64-bit
CF
P
P
P

Description:

This a GUI dialog class for accessing color book properties.

Declaration:

public class ImGearColorBookProperties : System.Windows.Forms.Form

Members:

Constructors:
Name
Description
ImGearColorBookProperties Constructor
Creates and initializes an instance of ImGearColorBookProperties Class.

Sample Code:

C#
    if (curBook != null)
    {
        using (ImGearColorBookProperties dlg = new ImGearColorBookProperties(curBook))
        {
            dlg.ShowDialog(this);
}
}

VB .NET
    If Not curBook Is Nothing Then
        Dim dlg As ImGearColorBookProperties = New ImGearColorBookProperties(curBook)
        dlg.ShowDialog(Me)
    End If

See Also:

ImGearColorBook Class


ImGearColorBookProperties Constructors

The ImGearColorBookProperties Class of the ImageGear.Windows.Forms Namespace has the following constructors:

Constructors
Name
Description
ImGearColorBookProperties Constructor
Creates and initializes an instance of ImGearColorBookProperties Class.


ImGearColorBookProperties Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearColorBookProperties Class.

Declaration:

public ImGearColorBookProperties(ImageGear.Core.ImGearColorBook ColorBook)

Parameters:

Name
Type
Description
ColorBook
ImGearColorBook Class
Reference to color book object.

Return Value:

An instance of ImGearColorBookProperties Class GUI dialog.

Sample Code:

C#
    if (curBook != null)
    {
        using (ImGearColorBookProperties dlg = new ImGearColorBookProperties(curBook))
        {
            dlg.ShowDialog(this);
        }
    }

VB .NET
    If Not curBook Is Nothing Then
        Dim dlg As ImGearColorBookProperties = New ImGearColorBookProperties(curBook)
        dlg.ShowDialog(Me)
    End If

See Also:

ImGearColorBookProperties Class

ImGearColorBook Class


ImGearColorBookSettings Class

32-bit
64-bit
CF
P
P
P

Description:

This a GUI dialog class for accessing the available color books.

Declaration:

public class ImGearColorBookSettings : System.Windows.Forms.Form

Members:

Constructors:
Name
Description
ImGearColorBookSettings Constructor
Creates an instance of ImGearColorBookSettings GUI dialog.

Methods:
Name
Description
CheckForSpotColors Method
Checks the specified page for spot colors.

Sample Code:

C#
using (ImGearColorBookSettings dlg = new ImGearColorBookSettings(imGearPageView))
    {
        dlg.ShowDialog(this);
    }

VB .NET
Dim dlg As (ImGearColorBookSettings = New ImGearColorBookSettings(imGearPageView)
    dlg.ShowDialog(Me)

See Also:

ImGearPageView Class


ImGearColorBookSettings Constructors

The ImGearColorBookSettings Class of the ImageGear.Windows.Forms Namespace has the following constructors:

Constructors
Name
Description
ImGearColorBookSettings Constructor
Creates an instance of ImGearColorBookSettings GUI dialog.


ImGearColorBookSettings Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an instance of ImGearColorBookSettings Class GUI dialog. .

Declaration:

public ImGearColorBookSettings(ImageGear.Windows.Forms.ImGearPageView PageView)

Parameters:

Name
Type
Description
PageView
ImGearPageView Class
Reference to the page view object.

Return Value:

An instance of ImGearColorBookSettings Class GUI dialog.

Sample Code:

C#
using (ImGearColorBookSettings dlg = new ImGearColorBookSettings(imGearPageView))
    {
        dlg.ShowDialog(this);
    }

VB .NET
Dim dlg As (ImGearColorBookSettings = New ImGearColorBookSettings(imGearPageView)
    dlg.ShowDialog(Me)

See Also:

ImGearColorBookSettings Class

ImGearPageView Class


ImGearColorBookSettings Methods

The ImGearColorBookSettings Class of the ImageGear.Windows.Forms Namespace has the following methods:

Methods
Name
Description
CheckForSpotColors Method
Checks the specified page for spot colors.


CheckForSpotColors Method

32-bit
64-bit
CF
P
P
P

Description:

This method checks the specified page for spot colors.

Declaration:

public static bool CheckForSpotColors(ImageGear.Core.ImGearPage Page)

Parameters:

Name
Type
Description
Page
ImGearPage Class
Reference to page to check.

Return Value:

Returns true if the specified page contains spot colors, false - otherwise.

Sample Code:

C#
ImGearColorBookSettings.CheckForSpotColors(page);

VB .NET
ImGearColorBookSettings.CheckForSpotColors(page)

See Also:

ImGearPage Class


ImGearColorProfileSettings Class

32-bit
64-bit
CF
P
P
P

Description:

This a GUI dialog class for ICC setting.

Declaration:

public class ImGearColorProfileSettings : System.Windows.Forms.Form

Members:

Constructors:
Name
Description
ImGearColorProfileSettings Constructor
Creates an instance of ICC Settings GUI dialog.

Methods:
Name
Description
CheckColorMismatch Method
Checks if the image is of non-RGB color format or it has an embedded color profile.
GetActivationMode Method
Returns Color Profile activation mode.
InitializeAndEnableProfiles Method
Enables Color Profile support and initializes it with default settings.
SetActivationMode Method
Sets Color Profile activation mode.

Sample Code:

C#
using (ImGearColorProfileSettings dlg = new ImGearColorProfileSettings(imGearPageView))
    {
        dlg.ShowDialog(this);
    }

VB .NET
Dim dlg As ImGearColorProfileSettings = New ImGearColorProfileSettings(imGearPageView)
    dlg.ShowDialog(Me)


ImGearColorProfileSettings Constructors

The ImGearColorProfileSettings Class of the ImageGear.Windows.Forms Namespace has the following constructors:

Constructors
Name
Description
ImGearColorProfileSettings Constructor
Creates an instance of ICC Settings GUI dialog.


ImGearColorProfileSettings Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an instance of ImGearColorProfileSettings Class GUI dialog. .

Declaration:

public ImGearColorProfileSettings(ImageGear.Windows.Forms.ImGearPageView PageView)

Parameters:

Name
Type
Description
PageView
ImGearPageView Class
Reference to pageview to refresh its content when the settings are applied.

Return Value:

An instance of ImGearColorProfileSettings Class GUI dialog.

Sample Code:

C#
using (ImGearColorProfileSettings dlg = new ImGearColorProfileSettings(imGearPageView))
    {
        dlg.ShowDialog(this);
    }

VB .NET
Dim dlg As ImGearColorProfileSettings = New ImGearColorProfileSettings(imGearPageView)
    dlg.ShowDialog(Me)

See Also:

ImGearColorProfileSettings Class

ImGearPageView Class


ImGearColorProfileSettings Methods

The ImGearColorProfileSettings Class of the ImageGear.Windows.Forms Namespace has the following methods:

Methods
Name
Description
CheckColorMismatch Method
Checks if the image is of non-RGB color format or it has an embedded color profile.
GetActivationMode Method
Returns Color Profile activation mode.
InitializeAndEnableProfiles Method
Enables Color Profile support and initializes it with default settings.
SetActivationMode Method
Sets Color Profile activation mode.


CheckColorMismatch Method

32-bit
64-bit
CF
P
P
P

Description:

This method checks if the image is of non-RGB color format or it has an embedded color profile. Generates a message box when it is recommended to enable ICC support.

Declaration:

public static void CheckColorMismatch(ImageGear.Core.ImGearPage Page)

Parameters:

Name
Type
Description
Page
ImGearPage Class
ImGearPage object to check for color mismatch.

Return Value:

None.

Sample Code:

C#
ImGearColorProfileSettings.CheckColorMismatch(page);

VB .NET
ImGearColorProfileSettings.CheckColorMismatch(page)

See Also:

ImGearPage Class


GetActivationMode Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns Color Profile activation mode. Activation mode is stored in the Windows registry, which allows you to remember user preference between ImageGear sample sessions.

Declaration:

public static ImageGear.Windows.Forms.ImGearColorProfileActivationMode GetActivationMode()

Return Value:

ImGearColorProfileActivationMode Enumeration value.

See Also:

ImGearColorProfileActivationMode Enumeration


InitializeAndEnableProfiles Method

32-bit
64-bit
CF
P
P
P

Description:

This method enables Color Profile support and initializes it with default settings: loads global color profiles, sets default rendering intent for color space conversions.

Declaration:

public static void InitializeAndEnableProfiles()

Return Value:

None.


SetActivationMode Method

32-bit
64-bit
CF
P
P
P

Description:

This method sets Color Profile activation mode. Activation mode is stored in the Windows registry, which allows it to remember user preference between ImageGear sample sessions.

Declaration:

public static void
SetActivationMode(ImageGear.Windows.Forms.ImGearColorProfileActivationMode mode)

Parameters:

Name
Type
Description
mode
ImGearColorProfileActivationMode Enumeration
Color profile activation mode.

Return Value:

None.

See Also:

ImGearColorProfileActivationMode Enumeration


ImGearExtraChannelColorChoice Class

32-bit
64-bit
CF
P
P
P

Description:

This a GUI dialog class for choosing a color for the specified extra channel.

Declaration:

public class ImGearExtraChannelColorChoice : System.Windows.Forms.Form

Members:

Constructors:
Name
Description
ImGearExtraChannelColorChoice Constructor
Creates an instance of ImGearExtraChannelColorChoice GUI dialog.

Sample Code:

C#
ImGearExtraChannelColorChoice dlg = new ImGearExtraChannelColorChoice(m_PageView, m_PageView.Page.DIB.ExtraChannelInfo,
        checkedListBoxExtraChannels.SelectedIndex);
    dlg.ShowDialog();

VB .NET
Dim dlg As ImGearExtraChannelColorChoice = New ImGearExtraChannelColorChoice(m_PageView, m_PageView.Page.DIB.ExtraChannelInfo,
        checkedListBoxExtraChannels.SelectedIndex)
    dlg.ShowDialog()

See Also:

ImGearPageView Class

ImGearExtraChannelInfo Class


ImGearExtraChannelColorChoice Constructors

The ImGearExtraChannelColorChoice Class of the ImageGear.Windows.Forms Namespace has the following constructors:

Constructors
Name
Description
ImGearExtraChannelColorChoice Constructor
Creates an instance of ImGearExtraChannelColorChoice GUI dialog.


ImGearExtraChannelColorChoice Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an instance of ImGearExtraChannelColorChoice Class GUI dialog.

Declaration:

public ImGearExtraChannelColorChoice(ImageGear.Windows.Forms.ImGearPageView PageView,
ImageGear.Core.ImGearExtraChannelInfo[] ChannelsInfo, int ChannelNumber)

Parameters:

Name
Type
Description
PageView
ImGearPageView Class
Reference to the page view object.
ChannelsInfo
ImGearExtraChannelInfo Class
Array of extra channels.
ChannelNumber
int
Index of the extra channel in array to work with.

Return Value:

An instance of ImGearExtraChannelColorChoice Class GUI dialog.

Sample Code:

C#
ImGearExtraChannelColorChoice dlg = new ImGearExtraChannelColorChoice(m_PageView, m_PageView.Page.DIB.ExtraChannelInfo,
        checkedListBoxExtraChannels.SelectedIndex);
    dlg.ShowDialog();

VB .NET
Dim dlg As ImGearExtraChannelColorChoice = New ImGearExtraChannelColorChoice(m_PageView, m_PageView.Page.DIB.ExtraChannelInfo,
        checkedListBoxExtraChannels.SelectedIndex)
    dlg.ShowDialog()

See Also:

ImGearExtraChannelColorChoice Class

ImGearPageView Class

ImGearExtraChannelInfo Class


ImGearExtraChannelsSwitching Class

32-bit
64-bit
CF
P
P
P

Description:

This a GUI dialog class for enabling and disabling color channels for display.

Declaration:

public class ImGearExtraChannelsSwitching : System.Windows.Forms.Form

Members:

Constructors:
Name
Description
ImGearExtraChannelsSwitching Constructor
Creates an instance of ImGearExtraChannelsSwitching GUI dialog.

Sample Code:

C#
using (ImGearExtraChannelsSwitching dlg = new ImGearExtraChannelsSwitching(imGearPageView))
    {
        dlg.ShowDialog();
    }

VB .NET
Dim dlg As ImGearExtraChannelsSwitching = New ImGearExtraChannelsSwitching(imGearPageView)
    dlg.ShowDialog()

See Also:

ImGearPageView Class


ImGearExtraChannelsSwitching Constructors

The ImGearExtraChannelsSwitching Class of the ImageGear.Windows.Forms Namespace has the following constructors:

Constructors
Name
Description
ImGearExtraChannelsSwitching Constructor
Creates an instance of ImGearExtraChannelsSwitching GUI dialog.


ImGearExtraChannelsSwitching Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an instance of ImGearExtraChannelsSwitching Class GUI dialog.

Declaration:

public ImGearExtraChannelsSwitching(ImageGear.Windows.Forms.ImGearPageView PageView)

Parameters:

Name
Type
Description
PageView
ImGearPageView Class
Reference to the page view object.

Return Value:

An instance of ImGearExtraChannelsSwitching Class GUI dialog.

Sample Code:

C#
using (ImGearExtraChannelsSwitching dlg = new ImGearExtraChannelsSwitching(imGearPageView))
    {
        dlg.ShowDialog();
    }

VB .NET
Dim dlg As ImGearExtraChannelsSwitching = New ImGearExtraChannelsSwitching(imGearPageView)
    dlg.ShowDialog()

See Also:

ImGearExtraChannelsSwitching Class

ImGearPageView Class


ImGearFile Class

32-bit
64-bit
CF
P
P
P

Description:

This class identifies a file and its location.

Declaration:

public class ImGearFile : System.Object

Members:

Constructors:
Name
Description
ImGearFile Constructor
Creates and initializes an instance of ImGearFile class.

Properties
Name
Description
Path Property
Name of the file with complete path.


ImGearFile Constructors

The ImGearFile Class of the ImageGear.Windows.Forms Namespace has the following constructors:

Constructors
Name
Description
ImGearFile Constructor
Creates and initializes an instance of ImGearFile class.


ImGearFile Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearFile Class.

Declaration:

protected ImGearFile ( System.String path )

Parameters:

Name
Type
Description
path
String
Name of the file with complete path.

Return Value:

N/A


ImGearFile Properties

The ImGearFile Class of the ImageGear.Windows.Forms Namespace has the following properties:

Properties
Name
Description
Path Property
Name of the file with complete path.


Path Property

32-bit
64-bit
CF
P
P
P

Description:

This property contains the name of the file with complete path.

Declaration:

public System.String Path { get; set }

Value:

Any string.


ImGearLayerProperties Class

32-bit
64-bit
CF
P
P
P

Description:

This class defines a GUI dialog allowing user to access and change the image layer's properties.

Declaration:

public class ImGearLayerProperties : System.Windows.Forms.Form

Members:

Constructors:
Name
Description
ImGearLayerProperties Constructor
Creates a GUI dialog allowing user to access and change the image layer's properties.


ImGearLayerProperties Constructors

The ImGearLayerProperties Class of the ImageGear.Windows.Forms Namespace has the following constructors:

Constructors:
Name
Description
ImGearLayerProperties Constructor
Creates a GUI dialog allowing user to access and change the image layer's properties.


ImGearLayerProperties Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates a GUI dialog allowing user to access and change the image layer's properties.

Declaration:

public ImGearLayerProperties(ImageGear.Processing.Layers.ImGearLayeredPage page,
ImageGear.Processing.Layers.ImGearLayer imgLayer)

Parameters:

Name
Type
Description
page
ImGearLayeredPage Class
Reference to the layered page whose image layer is accessed.
imgLayer
ImGearLayer Class
Reference to the layer to edit.

Return Value:

N/A

See Also:

ImGearLayeredPage Class

ImGearLayer Class


ImGearLayersSwitching Class

32-bit
64-bit
CF
P
P
P

Description:

This class defines a GUI dialog allowing the user to turn on and off the layers of the layered page, and flatten them into the raster output page.

Declaration:

public class ImGearLayersSwitching : System.Windows.Forms.Form

Members:

Constructors:
Name
Description
ImGearLayersSwitching Constructor
Creates a GUI dialog allowing user to turn on and off the layers of the layered page as well as flatten them.


ImGearLayersSwitching Constructors

The ImGearLayersSwitching Class of the ImageGear.Windows.Forms Namespace has the following constructors:

Constructors:
Name
Description
ImGearLayersSwitching Constructor
Creates a GUI dialog allowing user to turn on and off the layers of the layered page as well as flatten them.


ImGearLayersSwitching Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates a GUI dialog allowing user to turn on and off the layers of the layered page as well as flatten them.

Declaration:

public ImGearLayersSwitching(ImageGear.Windows.Forms.ImGearPageView PageView)

Parameters:

Name
Type
Description
PageView
ImGearPageView Class
ImGearPageView control

Return Value:

N/A

See Also:

ImGearPageView Class


ImGearLoadingSelection Class

32-bit
64-bit
CF
P
P
P

Description:

This class identifies a file and format selected in an open file dialog.

Declaration:

public class ImGearLoadingSelection : System.Object

Members:

Properties
Name
Description
File Property
File selected in the open file dialog.
Format Property
Format selected in the open file dialog.


ImGearLoadingSelection Properties

The ImGearLoadingSelection Class of the ImageGear.Windows.Forms Namespace has the following properties:

Properties
Name
Description
File Property
File selected in the open file dialog.
Format Property
Format selected in the open file dialog.


File Property

32-bit
64-bit
CF
P
P
P

Description:

This property identifies the file selected in the open file dialog.

Declaration:

public ImageGear.Windows.Forms.ImGearFile File { get }

Value:

ImGearFile Class

See Also:

ImGearFile Class


Format Property

32-bit
64-bit
CF
P
P
P

Description:

This property identifies the format selected in the open file dialog.

Declaration:

public ImageGear.Formats.ImGearFormats Format { get }

Value:

ImGearFormats Enumeration value.

See Also:

ImGearFormats Enumeration


ImGearLoadingSelectionEx Class

32-bit
64-bit
CF
P
P
P

Description:

This class identifies a file, format and page index selected in the open file dialog with preview shown by the SelectLocalFileToLoadEx Method.

Declaration:

public class ImGearLoadingSelectionEx : ImGearLoadingSelection

Members:

Properties
Name
Description
PageIndex Property
The 0 based index of the page selected from a multipage file.

See Also:

ImGearLoadingSelection Class


ImGearLoadingSelectionEx Properties

The ImGearLoadingSelectionEx Class of the ImageGear.Windows.Forms Namespace has the following properties:

Properties
Name
Description
PageIndex Property
The 0 based index of the page selected from a multipage file.


PageIndex Property

32-bit
64-bit
CF
P
P
P

Description:

This property returns the 0 based page index selected when using the FileOpenDialog launched by SelectLocalFileToLoadEx Method.

Declaration:

public int PageIndex { get }

Value:

Integer value


ImGearLocalFile Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents a file on a local file system.

Declaration:

public class ImGearLocalFile : ImageGear.Windows.Forms.ImGearFile

Members:

Constructors
Name
Description
ImGearLocalFile Constructor
Creates and initializes an instance of ImGearLocalFile class.
ImGearLocalFile Constructor
Creates and initializes an instance of ImGearLocalFile class.

Methods
Name
Description
OpenToRead Method
Opens a local file for reading.
OpenToWrite Method
Opens a local file for writing.


ImGearLocalFile Constructors

The ImGearLocalFile Class of the ImageGear.Windows.Forms Namespace has the following constructors:

Properties
Name
Description
ImGearLocalFile Constructor
Creates and initializes an instance of ImGearLocalFile class.
ImGearLocalFile Constructor
Creates and initializes an instance of ImGearLocalFile class.


ImGearLocalFile Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearLocalFile Class.

Declaration:

public ImGearLocalFile ( System.String path )

Parameters:

Name
Type
Description
path
String
Name of file with full path.

Return Value:

N/A

See Also:

ImGearLocalFile Class


ImGearLocalFile Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearLocalFile Class.

Declaration:

public ImGearLocalFile ( )

Return Value:

N/A

See Also:

ImGearLocalFile Class


ImGearLocalFile Methods

The ImGearLocalFile Class of the ImageGear.Windows.Forms Namespace has the following methods:

Methods
Name
Description
OpenToRead Method
Opens a local file for reading.
OpenToWrite Method
Opens a local file for writing.


OpenToRead Method

32-bit
64-bit
CF
P
P
P

Description:

This method opens the local file specified by the Path property for reading.

Declaration:

public System.IO.FileStream OpenToRead (  )

Return Value:

FileStream object for opened file.


OpenToWrite Method

32-bit
64-bit
CF
P
P
P

Description:

This method opens the local file specified by the Path property for writing.

Declaration:

public System.IO.FileStream OpenToWrite (  )

Return Value:

FileStream object for opened file.


ImGearMagnifier Class

32-bit
64-bit
CF
P
P
P

Description:

This is the GUI Magnifier control class which provides a magnified view of a portion of the image in ImGearPageView Class control. It appears either in a separate, stationary window, or as a popup area within the ImGearPageView window. When the GUI Magnifier control is active, and the user drags the mouse within the ImGearPageView Class control, the magnified display of the image tracks the location of the mouse. If the popup view is used, the magnified display of the image tracks the mouse within the ImGearPageView Class control. If the separate, stationary window is used, the area of the image that is displayed in the floating window is displayed in reverse video in the ImGearPageView Class control. The programmer can set the magnification factor, and can optionally expose that capability to the end user.

Declaration:

public class ImGearMagnifier : System.ComponentModel.Component

Members:

Constructors
Name
Description
ImGearMagnifier Constructor
Creates and initializes an instance of ImGearMagnifier class.
ImGearMagnifier Constructor
Creates and initializes an instance of ImGearMagnifier class.

Properties
Name
Description
Cursor Property
Specifies cursor used while magnifying page area.
DestinationView Property
Specifies ImGearPageView object used for displaying the magnified area.
IsPopUp Property
If this property is True, magnifier window shows right under mouse pointer, otherwise magnified area sends into DestinationView.
PopupHeight Property
Specifies height of the popup magnifier window.
PopupWidth Property
Specifies width of the popup magnifier window.
ShapeType Property
Specifies shape of the popup magnifier window.
SourceView Property
Specifies ImGearPageView object to be magnified.
Zoom Property
Specifies zoom factor.

See Also:

ImGearPageView Class


ImGearMagnifier Constructors

The ImGearMagnifier Class of the ImageGear.Windows.Forms Namespace has the following constructors:

Constructors
Name
Description
ImGearMagnifier Constructor
Creates and initializes an instance of ImGearMagnifier class.
ImGearMagnifier Constructor
Creates and initializes an instance of ImGearMagnifier class.


ImGearMagnifier Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearMagnifier Class.

Declaration:

public ImGearMagnifier (  )

Return Value:

The new instance of ImGearMagnifier Class.

See Also:

ImGearMagnifier Class


ImGearMagnifier Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearMagnifier Class.

Declaration:

public ImGearMagnifier ( System.ComponentModel.IContainer container )

Parameters:

Name
Type
Description
container
IContainer
A collection of IComponent objects that represents all the components in the IContainer. Use this.components when initializing in the Windows Form Designer.

Return Value:

The new instance of ImGearMagnifier Class.

Sample Code:

C#
internal ImageGear.Windows.Forms.ImGearMagnifier magnifier1;
this.magnifier1 = new ImageGear.Windows.Forms.ImGearMagnifier(Me.components);

VB .NET
Private magnifier1 As ImageGear.Windows.Forms.ImGearMagnifier
Me.magnifier1 = New ImageGear.Windows.Forms.ImGearMagnifier(Me.components)

See Also:

ImGearMagnifier Class


ImGearMagnifier Properties

The ImGearMagnifier Class of the ImageGear.Windows.Forms Namespace has the following properties:

Properties
Name
Description
Cursor Property
Specifies cursor used while magnifying page area.
DestinationView Property
Specifies ImGearPageView object used for displaying the magnified area.
IsPopUp Property
If this property is True, magnifier window shows right under mouse pointer, otherwise magnified area sends into DestinationView.
PopupHeight Property
Specifies height of the popup magnifier window.
PopupWidth Property
Specifies width of the popup magnifier window.
ShapeType Property
Specifies shape of the popup magnifier window.
SourceView Property
Specifies ImGearPageView object to be magnified.
Zoom Property
Specifies zoom factor.


Cursor Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies cursor used while magnifying page area.

Declaration:

public System.Windows.Forms.Cursor Cursor [  get,  set ]

Value:

System.Windows.Forms.Cursor class.

Sample Code:

C#
this.magnifier1.Cursor = System.Windows.Forms.Cursors.NoMoveHoriz;

VB .NET
Me.magnifier1.Cursor = System.Windows.Forms.Cursors.NoMoveHoriz


DestinationView Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies ImGearPageView object used for displaying the magnified area. If IsPopUp Property is true, DestinationView could be empty.

Declaration:

public ImageGear.Windows.Forms.ImGearPageView DestinationView [  get,  set ]

Value:

ImGearPageView Class.

Sample Code:

C#
this.magnifier1.DestinationView = this.imGearPageView;

VB .NET
Me.magnifier1.DestinationView = Me.ImGearPageView1

See Also:

IsPopUp Property

ImGearPageView Class


IsPopUp Property

32-bit
64-bit
CF
P
P
P

Description:

If this property is True, magnifier window shows right under mouse pointer, otherwise magnified area sends into DestinationView. Default value is True.

Declaration:

public bool IsPopUp [  get,  set ]

Value:

True, False.

Sample Code:

C#
this.magnifier1.IsPopUp = false;

VB .NET
Me.magnifier1.IsPopUp = False

See Also:

DestinationView Property


PopupHeight Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies height of the popup magnifier window.

Declaration:

public int PopupHeight [  get,  set ]

Value:

Any integer value.

Sample Code:

C#
this.magnifier1.PopupHeight = 200;

VB .NET
Me.magnifier1.PopupHeight = 200

See Also:

PopupWidth Property


PopupWidth Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies width of the popup magnifier window.

Declaration:

public int PopupWidth [  get,  set ]

Value:

Any integer value.

Sample Code:

C#
this.magnifier1.PopupWidth = 200;

VB .NET
Me.magnifier1.PopupWidth = 200

See Also:

PopupHeight Property


ShapeType Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies shape of the popup magnifier window. It can be either rectangle or ellipse. Default value is rectangle.

Declaration:

public ImageGear.Windows.Forms.ImGearMagnifierShapeType ShapeType [  get,  set ]

Value:

ImGearMagnifierShapeType Enumeration value.

Sample Code:

C#
this.magnifier1.ShapeType = ImageGear.Windows.Forms.ImGearMagnifierShapeType.Ellipse;

VB .NET
Me.magnifier1.ShapeType = ImGearMagnifierShapeType.Ellipse

See Also:

ImGearMagnifierShapeType Enumeration


SourceView Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies ImGearPageView object to be magnified.

Declaration:

public ImageGear.Windows.Forms.ImGearPageView SourceView [  get,  set ]

Value:

ImGearPageView Class.

Sample Code:

C#
this.magnifier1.SourceView = this.imGearPageView;

VB .NET
Me.magnifier1.SourceView = Me.ImGearPageView1

See Also:

ImGearPageView Class


Zoom Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies zoom factor.

Declaration:

public float Zoom [  get,  set ]

Value:

Any float value.

Sample Code:

C#
this.magnifier1.Zoom = 3F;

VB .NET
Me.magnifier1.Zoom = 3


ImGearPageView Class

32-bit
64-bit
CF
P
P
P

Description:

This is the page view control, used for displaying an image within a form. It encapsulates paint handling, although it offers some ways to customize the painting process.

Declaration:

public class ImGearPageView : System.Windows.Forms.UserControl

Members:

Constructors
Name
Description
ImGearPageView Constructor
Creates and initializes an instance of ImGearPageView class.

Properties
Name
Description
BindArrowKeyScrolling Property
Indicates whether or not the ImGearPageView control will handle the Arrow keys.
Display Property
ImGearPageDisplay object associated with the control, representing the image and display parameters.
HorizontalArrowIncrement Property
The Horizontal amount to scroll when using the left or right arrow keys.
NotifyPageDown Property
This property specifies a reference to DelegatePageCalculate delegate.
NotifyPageUp Property
This property specifies a reference to DelegatePageCaluclate delegate.
Page Property
Page associated with the control - automatically mapped to the Page property of the associated ImGearPageDisplay object
VerticalArrowIncrement Property
The vertical amount to scroll when using the up or down arrow keys.

Methods
Name
Description
OnPaint Method
Derived classes can implement this method to handle paint events themselves.
RegisterAfterDraw Method
Registers a method to be called after default painting has been performed.
Update Method
Invalidates the control's area, causing its contents to be repainted.

Events
Name
Description
AfterDrawEvent Event
This event is called after default painting has been performed.

Delegates
Name
Description
AfterDraw Delegate
Delegate for method registered with RegisterAfterDraw method, to be called after default painting has been performed.
DelegatePageCalculate Delegate
This delegate, if registered, is automatically called from the ImGearPageView Class when the user presses Page Up or Page Down.


ImGearPageView Constructors

The ImGearPageView Class of the ImageGear.Windows.Forms Namespace has the following constructors:

Constructors
Name
Description
ImGearPageView Constructor
Creates and initializes an instance of ImGearPageView class.


ImGearPageView Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearPageView Class.

Declaration:

public ImGearPageView (  )

Return Value:

The new instance of ImGearPageView Class.

See Also:

ImGearPageView Class


ImGearPageView Properties

The ImGearPageView Class of the ImageGear.Windows.Forms Namespace has the following properties:

Properties
Name
Description
BindArrowKeyScrolling Property
Indicates whether or not the ImGearPageView control will handle the Arrow keys.
Display Property
ImGearPageDisplay object associated with the control, representing the image and display parameters.
HorizontalArrowIncrement Property
The Horizontal amount to scroll when using the left or right arrow keys.
NotifyPageDown Property
This property specifies a reference to DelegatePageCalculate delegate.
NotifyPageUp Property
This property specifies a reference to DelegatePageCaluclate delegate.
Page Property
Page associated with the control - automatically mapped to the Page property of the associated ImGearPageDisplay object
VerticalArrowIncrement Property
The vertical amount to scroll when using the up or down arrow keys.


BindArrowKeyScrolling Property

32-bit
64-bit
CF
P
P
P

Description:

This property indicates whether or not the ImGearPageView Class control will handle the Arrow keys.

Declaration:

public bool BindArrowKeyScrolling [  get,  set ]

Value:

Boolean value

Default:

False


Display Property

32-bit
64-bit
CF
P
P
P

Description:

This property contains a reference to the ImGearPageDisplay Class object associated with the control. This ImGearPageDisplay Class object represents the image and parameters used to display it.

Declaration:

public ImageGear.Display.ImGearPageDisplay Display [  get,  set ]

Value:

ImGearPageDisplay Class.

See Also:

ImGearPageDisplay Class


HorizontalArrowIncrement Property

32-bit
64-bit
CF
P
P
P

Description:

The Horizontal amount to scroll when using the left or right arrow keys.

Declaration:

public int HorizontalArrowIncrement [  get,  set ]

Value:

Integer value

Default:

1


NotifyPageDown Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies a reference to DelegatePageCalculate Delegate. If registered it is called when the Page Down key is pressed and will be used to calculate the amount of scrolling desired. If none is registered the ImGearPageView Class control does not handle the Page Down.

Declaration:

public DelegatePageCalculate NotifyPageDown [  get,  set ]

Value:

DelegatePageCalculate Delegate

Default:

Null

See Also:

DelegatePageCalculate Delegate


NotifyPageUp Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies a reference to DelegatePageCalculate Delegate. If registered it is called when the Page Up key is pressed and will be used to calculate the amount of scrolling desired. If none is registered the ImGearPageView Class control does not handle Page Up.

Declaration:

public DelegatePageCalculate NotifyPageUp [  get,  set ]

Value:

DelegatePageCalculate Delegate

Default:

Null

See Also:

DelegatePageCalculate Delegate


Page Property

32-bit
64-bit
CF
P
P
P

Description:

This property represents the ImGearPage Class associated with the control. This property is automatically connected to the Display property. It will always refer to the same ImGearPage Class object as the Page property of that ImGearDisplay object. Note that if ImGearPageView Class Page property is set, its Display property will automatically also be set, and vice versa.

Declaration:

public ImageGear.Core.ImGearPage Page [  get,  set ]

Value:

ImGearPage Class.

See Also:

ImGearPage Class


VerticalArrowIncrement Property

32-bit
64-bit
CF
P
P
P

Description:

The vertical amount to scroll when using the up or down arrow keys.

Declaration:

public int VerticalArrowIncrement [  get,  set ]

Value:

Integer value

Default:

1


ImGearPageView Methods

The ImGearPageView Class of the ImageGear.Windows.Forms Namespace has the following methods:

Methods
Name
Description
OnPaint Method
Derived classes can implement this method to handle paint events themselves.
RegisterAfterDraw Method
Registers a method to be called after default painting has been performed.
Update Method
Invalidates the control's area, causing its contents to be repainted.


OnPaint Method

32-bit
64-bit
CF
P
P
P

Description:

This method is called when the control is required to paint its contents. An application does not call this method directly. Derived classes can implement this method to handle paint events themselves.

Declaration:

protected override void OnPaint ( System.Windows.Forms.PaintEventArgs pe )

Parameters:

Name
Type
Description
pe
PaintEventArgs
PaintEventArgs object containing event data.

Return Value:

N/A

See Also:

Control.OnPaint method (in .NET Framework Class Library documentation, System.Windows.Forms namespace)


RegisterAfterDraw Method

32-bit
64-bit
CF
P
P
P

Description:

This method registers a method to be called after default painting has been performed. This method can be used by an application to perform additional painting, such as painting overlaid on top of the image. It is recommended that the AfterDrawEvent Event be used instead of this method.

Declaration:

public void RegisterAfterDraw ( ImageGear.Windows.Forms.ImGearPageView.AfterDraw Func )

Parameters:

Name
Type
Description
Func
ImGearPageView Class.AfterDraw Delegate
Method to be called after default painting.

Return Value:

N/A

See Also:

ImGearPageView Class

AfterDrawEvent Event


Update Method

32-bit
64-bit
CF
P
P
P

Description:

This method invalidates the control's area, causing its contents to be repainted. When changes are made to the image being displayed, this method is typically called immediately afterwards to make those changes visible.

Declaration:

public void Update (  )

Return Value:

N/A


ImGearPageView Events

The ImGearPageView Class of the ImageGear.Windows.Forms Namespace has the following events:

Events
Name
Description
AfterDrawEvent Event
This event is called after default painting has been performed.


AfterDrawEvent Event

32-bit
64-bit
CF
P
P
P

Description:

This event is called after default painting has been performed. This event can be used by an application to perform additional painting, such as painting overlaid on top of the image.

Declaration:

public event EventHandler<ImGearAfterDrawEventArgs> AfterDrawEvent;

See Also:

ImGearAfterDrawEventArgs Class


ImGearPageView Delegates

The ImGearPageView Class of the ImageGear.Windows.Forms Namespace has the following delegates:

Delegates
Name
Description
AfterDraw Delegate
Delegate for method to be called after default painting, registered by RegisterAfterDraw method.
DelegatePageCalculate Delegate
This delegate, if registered, is automatically called from the ImGearPageView Class when the user presses Page Up or Page Down.


AfterDraw Delegate

32-bit
64-bit
CF
P
P
P

Description:

This is the delegate for a method to be called after default painting, registered by RegisterAfterDraw method.

Declaration:

public delegate void AfterDraw(System.Drawing.Graphics gr);

Parameters:

Name
Type
Description
gr
System.Drawing.Graphics
Graphics object used for painting.

Return Value:

N/A


DelegatePageCalculate Delegate

32-bit
64-bit
CF
P
P
P

Description:

This delegate, if registered, is automatically called from the ImGearPageView Class when the user presses Page Up or Page Down. This increment is not standardized, and so its calculation is left in the hands of the user.

Declaration:

public delegate void DelegatePageCalculate(ref ImGearScrollInfo si);

Parameters:

Name
Type
Description
si
ImGearScrollInfo structure by reference
In/out parameter. ImGearScrollInfo object with current attributes for vertical and horizontal scrollbars passed by reference.

Return Value:

N/A

See Also:

ImGearScrollInfo Structure


ImGearPan Class

32-bit
64-bit
CF
P
P
P

Description:

This is the GUI Pan Control that allows the visible portion of an image displayed in the ImGearPageView Class control to be moved by dragging the mouse around in the image. Optionally, a floating window can be used to display the complete image, scaled to fit within the floating window. By dragging the mouse within this floating window, the image in the ImGearPageView Class control is repositioned. The portion of the image that is visible in the ImGearPageView Class control is displayed within the floating window in reverse video.

Declaration:

public class ImGearPan : System.ComponentModel.Component

Members:

Constructors
Name
Description
ImGearPan Constructor
Creates and initializes an instance of ImGearPan class.

Properties
Name
Description
Cursor Property
Specifies cursor used while panning page area.
DestinationView Property
Specifies ImGearPageView object used for displaying the panning area.
PanButton Property
Specifies mouse button used for panning.
SourceView Property
Specifies ImGearPageView object to apply panning functionality to.


ImGearPan Constructors

The ImGearPan Class of the ImageGear.Windows.Forms Namespace has the following constructors:

Constructors
Name
Description
ImGearPan Constructor
Creates and initializes an instance of ImGearPan class.


ImGearPan Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearPan Class.

Declaration:

public ImGearPan (System.ComponentModel.IContainer container)

Parameters:

Name
Type
Description
container
IContainer
A collection of IComponent objects that represents all the components in the IContainer. Use this component when initializing in the Windows Form Designer.

Return Value:

New instance of ImGearPan Class object.

Example:

C#
internal ImageGear.Windows.Forms.ImGearPan pan1;
this.pan1 = new ImageGear.Windows.Forms.ImGearPan(this.components);

Visual Basic
Private pan1 As ImageGear.Windows.Forms.ImGearPan
Me.pan1 = New ImageGear.Windows.Forms.ImGearPan(Me.components)


ImGearPan Properties

The ImGearPan Class of the ImageGear.Windows.Forms Namespace has the following properties:

Properties
Name
Description
Cursor Property
Specifies cursor used while panning page area.
DestinationView Property
Specifies ImGearPageView object used for displaying the panning area.
PanButton Property
Specifies mouse button used for panning.
SourceView Property
Specifies ImGearPageView object to apply panning functionality to.


Cursor Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies cursor used while panning page area.

Declaration:

public System.Windows.Forms.Cursor Cursor { set; get; }

Value:

System.Windows.Forms.Cursor class.

Example:

C#
this.pan1.Cursor = System.Windows.Forms.Cursors.Hand;

Visual Basic
Me.magnifier1.Cursor = System.Windows.Forms.Cursors.Hand


DestinationView Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies ImGearPageView Class object used for displaying the panning area.

Declaration:

public ImageGear.Windows.Forms.ImGearPageView DestinationView { set; get; }

Value:

ImGearPageView Class

Example:

C#
this.pan1.DestinationView = this.imGearPageView;

Visual Basic
Me.pan1.DestinationView = Me.ImGearPageView1


PanButton Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies mouse button used for panning. Default value is Left.

Declaration:

public System.Windows.Forms.MouseButtons PanButton { set; get; }

Value:

System.Windows.Forms.MouseButtons value.

Example:

C#
this.pan1.PanButton = MouseButtons.Left;

Visual Basic
Me.pan1.PanButton = MouseButtons.Left


SourceView Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies ImGearPageView Class object to apply panning functionality to.

Declaration:

public ImageGear.Windows.Forms.ImGearPageView SourceView { set; get; }

Value:

ImGearPageView Class.

Example:

C#
this.pan1.SourceView = this.imGearPageView;

Visual Basic
Me.pan1.SourceView = Me.ImGearPageView1


ImGearRemoteFile Class

32-bit
64-bit
CF
P
P
P

Description:

This class represents a file on a remote file system, such as a web server.

Declaration:

public class ImGearRemoteFile : ImageGear.Windows.Forms.ImGearFile

Members:

Constructors
Name
Description
ImGearRemoteFile Constructor
Creates and initializes an instance of ImGearRemoteFile class.
ImGearRemoteFile Constructor
Creates and initializes an instance of ImGearRemoteFile class.

Properties
Name
Description
Domain Property
Domain of user account (part of credentials to access file)
Password Property
Password (part of credentials to access file)
ProxyAddress Property
Address of proxy server to use.
ProxyPort Property
Port number of proxy server to use.
UseImGearWebStream Property
Specifies whether or not to use ImGearWebStream (preferred for multi-page files)
UseProxy Property
Specifies whether or not to use a proxy server.
UserName Property
Username (part of credentials to access file)

Methods
Name
Description
CreateRequest Method
Creates .NET WebRequest to access file.
CreateWebStream Method
Creates ImGearWebStream to access file.
Download Method
Downloads contents of requested file.
Upload Method
Uploads local content to remote resource.


ImGearRemoteFile Constructors

The ImGearRemoteFile Class of the ImageGear.Windows.Forms Namespace has the following constructors:

Constructors
Name
Description
ImGearRemoteFile Constructor
Creates and initializes an instance of ImGearRemoteFile class using a specified URL.
ImGearRemoteFile Constructor
Creates and initializes an instance of ImGearRemoteFile class.


ImGearRemoteFile Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearRemoteFile Class using a specified URL.

Declaration:

public ImGearRemoteFile ( System.String url )

Parameters:

Name
Type
Description
url
String
URL of remote resource to access.

Return Value:

The new instance of ImGearRemoteFile Class.

See Also:

ImGearRemoteFile Class


ImGearRemoteFile Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearRemoteFile Class.

Declaration:

public ImGearRemoteFile ( )

Return Value:

The new instance of ImGearRemoteFile Class.

See Also:

ImGearRemoteFile Class


ImGearRemoteFile Properties

The ImGearRemoteFile Class of the ImageGear.Windows.Forms Namespace has the following properties:

Properties
Name
Description
Domain Property
Domain of user account (part of credentials to access file)
Password Property
Password (part of credentials to access file)
ProxyAddress Property
Address of proxy server to use.
ProxyPort Property
Port number of proxy server to use.
UseImGearWebStream Property
Specifies whether or not to use ImGearWebStream (preferred for multi-page files)
UseProxy Property
Specifies whether or not to use a proxy server.
UserName Property
Username (part of credentials to access file)


Domain Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the domain of user account to use as part of the credentials to access a remote resource.

Declaration:

public System.String Domain [  get,  set ]

Value:

Any string value.

See Also:

Password Property

UserName Property


Password Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the password to use as part of the credentials to access a remote resource.

Declaration:

public System.String Password [  get,  set ]

Value:

Any string value.

See Also:

UserName Property

Domain Property


ProxyAddress Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the address of a proxy server to use.

Declaration:

public System.String ProxyAddress [  get,  set ]

Value:

Any string value.

See Also:

ProxyPort Property

UseProxy Property


ProxyPort Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the port number of a proxy server to use.

Declaration:

public int ProxyPort [  get,  set ]

Value:

Any integer value.

See Also:

ProxyAddress Property

UseProxy Property


UseImGearWebStream Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies whether or not to use ImGearWebStream Class, a specialized stream for loading of images from the Internet. It is most useful for loading of multipage images, because it downloads only the necessary portions of the remote file.

Declaration:

public System.Boolean UseImGearWebStream [  get,  set ]

Value:

True, False

See Also:

ImGearWebStream Class


UseProxy Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies whether or not to use a proxy server.

Declaration:

public System.Boolean UseProxy [  get,  set ]

Value:

True, False

See Also:

ProxyAddress Property

ProxyPort Property


UserName Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the username to use as part of the credentials to access a remote resource.

Declaration:

public System.String UserName [  get,  set ]

Value:

Any string value.

See Also:

Password Property

Domain Property


ImGearRemoteFile Methods

The ImGearRemoteFile Class of the ImageGear.Windows.Forms Namespace has the following methods:

Methods
Name
Description
CreateRequest Method
Creates .NET WebRequest to access file.
CreateWebStream Method
Creates ImGearWebStream to access file.
Download Method
Downloads contents of requested file.
Upload Method
Uploads local content to remote resource.


CreateRequest Method

32-bit
64-bit
CF
P
P
P

Description:

This method creates a .NET WebRequest using the parameters defined by the properties of the ImGearRemoteFile Class object.

Declaration:

public System.Net.WebRequest CreateRequest (  )

Return Value:

WebRequest class.

See Also:

System.Net.WebRequest (in .NET Framework Class Library)

ImGearRemoteFile Class


CreateWebStream Method

32-bit
64-bit
CF
P
P
P

Description:

This method creates an ImGearWebStream Class using the parameters defined by the properties of the ImGearRemoteFile Class object.

Declaration:

public System.IO.Stream CreateWebStream (  )

Return Value:

System.IO.Stream class.

ImGearRemoteFile Class

ImGearWebStream Class


Download Method

32-bit
64-bit
CF
P
P
P

Description:

This method downloads the contents of the requested file. It uses its own WebRequest object to do this, so it's not necessary to create one with the CreateRequest method before calling this method.

Declaration:

public System.IO.MemoryStream Download (  )

Return Value:

System.IO.MemoryStream class.


Upload Method

32-bit
64-bit
CF
P
P
P

Description:

This method uploads local content to a remote resource. It uses its own WebRequest object to do this, so it's not necessary to create one with the CreateRequest method before calling this method.

Declaration:

public void Upload ( System.IO.Stream localContent )

Parameters:

Name
Type
Description
localContent
System.IO.Stream
Content to upload to the remote resource.

Return Value:

N/A


ImGearSavingSelection Class

32-bit
64-bit
CF
P
P
P

Description:

This class identifies a file and format selected in a save file dialog.

Declaration:

public class ImGearSavingSelection : System.Object

Members:

Properties
Name
Description
File Property
File selected in the save file dialog.
Format Property
Format selected in the save file dialog.


ImGearSavingSelection Properties

The ImGearSavingSelection Class of the ImageGear.Windows.Forms Namespace has the following properties:

Properties
Name
Description
File Property
File selected in the save file dialog.
Format Property
Format selected in the save file dialog.


File Property

32-bit
64-bit
CF
P
P
P

Description:

This property identifies the file selected in the save file dialog.

Declaration:

public ImageGear.Windows.Forms.ImGearFile File { get }

Value:

ImGearFile Class.

See Also:

ImGearFile Class


Format Property

32-bit
64-bit
CF
P
P
P

Description:

This property identifies the format selected in the save file dialog.

Declaration:

public ImageGear.Formats.ImGearSavingFormats Format { get }

Value:

ImGearSavingFormats Enumeration.

See Also:

ImGearSavingFormats Enumeration


ImGearSpotColorsMissingBox Class

32-bit
64-bit
CF
P
P
P

Description:

This a GUI dialog class for processing missing spot colors. Pops up to define how to display the spot colors.

Declaration:

public class ImGearSpotColorsMissingBox : System.Windows.Forms.Form

Members:

Constructors:
Name
Description
ImGearSpotColorsMissingBox Constructor
Creates an instance of ImGearSpotColorsMissingBox GUI dialog.

Sample Code:

C#
using (ImGearSpotColorsMissingBox dlg = new ImGearSpotColorsMissingBox(SpotColorList))
    {
        dlg.ShowDialog();
    }

VB .NET
Dim dlg As ImGearSpotColorsMissingBox = New ImGearSpotColorsMissingBox(SpotColorList)
    dlg.ShowDialog()

See Also:

ImGearSpotChannelInfo Class


ImGearSpotColorsMissingBox Constructors

The ImGearSpotColorsMissingBox Class of the ImageGear.Windows.Forms Namespace has the following constructors:

Constructors
Name
Description
ImGearSpotColorsMissingBox Constructor
Creates an instance of ImGearSpotColorsMissingBox GUI dialog.


ImGearSpotColorsMissingBox Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates an instance of ImGearSpotColorsMissingBox Class GUI dialog.

Declaration:

public ImGearSpotColorsMissingBox(System.Collections.ArrayList spotColors)

Parameters:

Name
Type
Description
spotColors
ArrayList
Array of spot colors.

Return Value:

An instance of ImGearSpotColorsMissingBox Class GUI dialog.

Sample Code:

C#
using (ImGearSpotColorsMissingBox dlg = new ImGearSpotColorsMissingBox(SpotColorList))
    {
        dlg.ShowDialog();
    }

VB .NET
Dim dlg As ImGearSpotColorsMissingBox = New ImGearSpotColorsMissingBox(SpotColorList)
    dlg.ShowDialog()

See Also:

ImGearSpotColorsMissingBox Class


ImGearWinForms Class

32-bit
64-bit
CF
P
P
P

Description:

Provides methods for using common dialogs and error handling infrastructure.

Declaration:

public sealed class ImGearWinForms : System.Object

Members:

Methods
Name
Description
AddWarning Method
Adds a warning to the list of warnings displayed by the warning window.
ClearWarnings Method
Clears the list of warnings displayed by the warning window.
LoadPage Method
Loads a page, using a file open dialog to prompt the user for the location of the page.
ManageFiltersControlParams Method
Shows dialog box with ability to modify filters behavior, with the specified filter selected.
ManageFiltersControlParams Method
Shows dialog box with ability to modify filters behavior.
ManageMetadata Method
Shows dialog box with metadata tree.
PreflightReport Method
Shows preflight report dialog box.
RegisterExceptionHandler Method
Registers an exception handler for the entire application, used to display ImageGear error information.
SavePage Method
Save a page, using a file save dialog to prompt the user for the format and destination.
SelectFileToLoad Method
Shows dialog box allowing the user to select a local or remote file to load.
SelectFileToSave Method
Shows dialog box allowing the user to select a format and destination to save to.
SelectFileToSave Method
Shows dialog box allowing the user to select a format and destination to save to.
SelectFileToSave Method
Shows a dialog box allowing the user to select a format and destination using the raster conversion option to save a page to.
SelectLocalARTFileToLoad Method
Shows ART file open dialog with filtering for all known ART formats.
SelectLocalARTFileToSave Method
Shows ART file save dialog with filtering for all known ART formats.
SelectLocalFileToLoad Method
Shows dialog box allowing the user to select a local file to load.
SelectLocalFileToLoadEx Method
Shows a dialog box allowing the user to select a local file to load.
SelectLocalFileToSave Method
Shows dialog box allowing the user to select a format and local file to save to.
SelectLocalFileToSave Method
Shows dialog box allowing the user to select a format and local file to save to.
SelectLocalFileToSave Method
Shows a dialog box allowing the user to select a format and local file using the raster conversion option to save a page to.
SelectRemoteFileToLoad Method
Shows dialog box allowing the user to select a remote file to load.
SelectRemoteFileToSave Method
Shows dialog box allowing the user to select a format and remote destination to save to.
ShowAboutBox Method
Shows an About box with ImageGear version information.
ShowDocumentInfo Method
Shows a window with information about an ImGearDocument Class.
ShowExceptionInfo Method
Shows a window with information about an exception.
ShowFileInfo Method
Shows a window with information about a file.
ShowPageInfo Method
Shows a window with information about a page.
ShowWarningInfo Method
Shows a window with a list of ImageGear warnings.
UnRegisterExceptionHandler Method
Unregisters an exception handler for the entire application, used to display ImageGear error information.


ImGearWinForms Methods

The ImGearWinForms class of the ImageGear.Windows.Forms Namespace has the following methods:

Methods
Name
Description
AddWarning Method
Adds a warning to the list of warnings displayed by the warning window.
ClearWarnings Method
Clears the list of warnings displayed by the warning window.
LoadPage Method
Loads a page, using a file open dialog to prompt the user for the location of the page.
ManageFiltersControlParams Method
Shows dialog box with ability to modify filters behavior, with the specified filter selected.
ManageFiltersControlParams Method
Shows dialog box with ability to modify filters behavior.
ManageMetadata Method
Shows dialog box with metadata tree.
PreflightReport Method
Shows preflight report dialog box.
RegisterExceptionHandler Method
Registers an exception handler for the entire application, used to display ImageGear error information.
SavePage Method
Save a page, using a file save dialog to prompt the user for the format and destination.
SelectFileToLoad Method
Shows dialog box allowing the user to select a local or remote file to load.
SelectFileToSave Method
Shows dialog box allowing the user to select a format and destination to save to.
SelectFileToSave Method
Shows dialog box allowing the user to select a format and destination to save to.
SelectFileToSave Method
Shows a dialog box allowing the user to select a format and destination using the raster conversion option to save a page to.
SelectLocalARTFileToLoad Method
Shows ART file open dialog with filtering for all known ART formats.
SelectLocalARTFileToSave Method
Shows ART file save dialog with filtering for all known ART formats.
SelectLocalFileToLoad Method
Shows dialog box allowing the user to select a local file to load.
SelectLocalFileToLoadEx Method
Shows a dialog box allowing the user to select a local file to load.
SelectLocalFileToSave Method
Shows dialog box allowing the user to select a format and local file to save to.
SelectLocalFileToSave Method
Shows dialog box allowing the user to select a format and local file to save to.
SelectLocalFileToSave Method
Shows a dialog box allowing the user to select a format and local file using the raster conversion option to save a page to.
SelectRemoteFileToLoad Method
Shows dialog box allowing the user to select a remote file to load.
SelectRemoteFileToSave Method
Shows dialog box allowing the user to select a format and remote destination to save to.
ShowAboutBox Method
Shows an About box with ImageGear version information.
ShowDocumentInfo Method
Shows a window with information about an ImGearDocument Class.
ShowExceptionInfo Method
Shows a window with information about an exception.
ShowFileInfo Method
Shows a window with information about a file.
ShowPageInfo Method
Shows a window with information about a page.
ShowWarningInfo Method
Shows a window with a list of ImageGear warnings.
UnRegisterExceptionHandler Method
Unregisters an exception handler for the entire application, used to display ImageGear error information.


AddWarning Method

32-bit
64-bit
CF
P
P
P

Description:

This method adds a warning to the list of warnings displayed by the warning window.

Declaration:

public static void AddWarning ( ImageGear.Core.ImGearWarning warning )

Parameters:

Name
Type
Description
warning
ImGearWarning Class
Warning to add to the list of warnings.

Return Value:

N/A

See Also:

ImGearWarning Class


ClearWarnings Method

32-bit
64-bit
CF
P
P
P

Description:

This method clears the list of warnings displayed by the warning window.

Declaration:

public static void ClearWarnings (  )

Return Value:

N/A


LoadPage Method

32-bit
64-bit
CF
P
P
P

Description:

This method loads a page, using a file open dialog to prompt the user for the location of the page.

Declaration:

public static ImageGear.Core.ImGearPage LoadPage ( System.Windows.Forms.IWin32Window owner
)

Parameters:

Name
Type
Description
owner
IWin32Window
Handle of window to use as parent for dialog box.

Return Value:

ImGearPage Class.

See Also:

ImGearPage Class


ManageFiltersControlParams Method

32-bit
64-bit
CF
P
P
P

Description:

This method shows a dialog box which allows the user to modify format filter behavior. The selected filter in the dialog box is set to the format specified in the formatToSelect parameter.

Declaration:

public static void ManageFiltersControlParams ( System.Windows.Forms.IWin32Window owner,
ImageGear.Formats.ImGearFormats formatToSelect )

Parameters:

Name
Type
Description
owner
IWin32Window
Handle of window to use as parent for dialog box.
formatToSelect
ImGearFormats Enumeration
Format to select upon opening the dialog box.

Return Value:

N/A

See Also:

ImGearFormats Enumeration


ManageFiltersControlParams Method

32-bit
64-bit
CF
P
P
P

Description:

This method shows a dialog box that allows the user to modify format filter behavior.

Declaration:

public static void ManageFiltersControlParams ( System.Windows.Forms.IWin32Window owner )

Parameters:

Name
Type
Description
owner
IWin32Window
Handle of window to use as parent for dialog box.

Return Value:

N/A


ManageMetadata Method

32-bit
64-bit
CF
P
P
P

Description:

This method show a dialog box displaying the specified metadata tree.

Declaration:

public static void ManageMetadata ( System.Windows.Forms.IWin32Window owner,
ImageGear.Core.ImGearMetadataHead metadata )

Parameters:

Name
Type
Description
owner
IWin32Window
Handle of window to use as parent for dialog box.
metadata
ImGearMetadataHead Class
Metadata to display in dialog box.

Return Value:

N/A

See Also:

ImGearMetadataHead Class


PreflightReport Method

32-bit
64-bit
CF
P
P
P

Description:

This method creates and displays a PDF preflight report dialog box.

Declaration:

public static void PreflightReport(System.Windows.Forms.IWin32Window owner,
ImageGear.Formats.PDF.ImGearPDFPreflightProfile profile,
ImageGear.Formats.PDF.ImGearPDFPreflightReport report)

Parameters:

Name
Type
Description
owner
IWin32Window
Reference to the owner window.
profile
ImGearPDFPreflightProfile Enumeration
Type of profile the report was created for.
report
ImGearPDFPreflightReport Class
Reference to PDF preflight report object.

See Also:

ImGearPDFPreflightReport Class

ImGearPDFPreflightProfile Enumeration


RegisterExceptionHandler Method

32-bit
64-bit
CF
P
P
P

Description:

This method registers an exception handler for the entire application, used to display ImageGear error information. This exception handler can catch and display information for any type of exception that occurs, allowing the application to continue executing. This method must be called for every thread in the application for which exceptions are to be handled.

Declaration:

public static void RegisterExceptionHandler (  )

Return Value:

N/A

See Also:

UnRegisterExceptionHandler


SavePage Method

32-bit
64-bit
CF
P
P
P

Description:

This method saves a page, using a file save dialog to prompt the user for the format and destination.

Declaration:

public static System.Boolean SavePage ( System.Windows.Forms.IWin32Window owner,
ImageGear.Core.ImGearPage page )

Parameters:

Name
Type
Description
owner
IWin32Window
Handle of window to use as parent for dialog box.
page
ImGearPage Class
Page to save.

Return Value:

True
Page was saved successfully.
False
Page was not saved because user clicked Cancel in dialog box.

See Also:

ImGearPage Class


SelectFileToLoad Method

32-bit
64-bit
CF
P
P
P

Description:

This method shows a dialog box allowing the user to select a local or remote file to load. Nothing is loaded by this method. It only allows the user to make a selection and returns information about that selection.

Declaration:

public static ImageGear.Windows.Forms.ImGearLoadingSelection SelectFileToLoad (
System.Windows.Forms.IWin32Window owner, System.String title, System.Boolean selectRemote
)

Parameters:

Name
Type
Description
owner
IWin32Window
Handle of window to use as parent for dialog box.
title
String
Window title to use for dialog box.
selectRemote
Boolean
Allow selecting remote files.

Return Value:

ImGearLoadingSelection Class.

See Also:

ImGearLoadingSelection Class


SelectFileToSave Method

32-bit
64-bit
CF
P
P
P

Description:

This method shows a dialog box allowing the user to select a format and destination to save a document to. Nothing is saved by this method. It only allows the user to make a selection and returns information about that selection.

Declaration:

public static ImageGear.Windows.Forms.ImGearSavingSelection SelectFileToSave (
System.Windows.Forms.IWin32Window owner, System.String title,
ImageGear.Core.ImGearDocument doc )

Parameters:

Name
Type
Description
owner
IWin32Window
Handle of window to use as parent for dialog box.
title
String
Window title to use for dialog box.
doc
ImGearDocument Class
Document to be saved (but not during this method call)

Return Value:

ImGearSavingSelection Class

See Also:

ImGearDocument Class

ImGearSavingSelection Class


SelectFileToSave Method

32-bit
64-bit
CF
P
P
P

Description:

This method shows a dialog box allowing the user to select a format and destination to save a page to. Nothing is saved by this method. It only allows the user to make a selection and returns information about that selection.

Declaration:

public static ImageGear.Windows.Forms.ImGearSavingSelection SelectFileToSave (
System.Windows.Forms.IWin32Window owner, System.String title, ImageGear.Core.ImGearPage
page, System.Boolean selectRemote )

Parameters:

Name
Type
Description
owner
IWin32Window
Handle of window to use as parent for dialog box.
title
String
Window title to use for dialog box.
page
ImGearPage Class
Page to be saved (but not during this method call)
selectRemote
Boolean
Allow selecting remote files.

Return Value:

ImGearSavingSelection Class

See Also:

ImGearPage Class

ImGearSavingSelection Class


SelectFileToSave Method

32-bit
64-bit
CF
P
P
P

Description:

This method shows a dialog box allowing the user to select a format and destination using the raster conversion option to save a page to. Nothing is saved by this method. It only allows the user to make a selection and returns information about that selection.

Declaration:

public static ImageGear.Windows.Forms.ImGearSavingSelection SelectFileToSave (
System.Windows.Forms.IWin32Window owner, System.String title, ImageGear.Core.ImGearPage
page, System.Boolean selectRemote, , ImageGear.Formats.ImGearRasterConversionModes
rasterConversionMode )

Parameters:

Name
Type
Description
owner
IWin32Window
Handle of window to use as parent for dialog box.
title
String
Window title to use for dialog box.
page
ImGearPage Class
Page to be saved (but not during this method call)
selectRemote
Boolean
Allow selecting remote files.
rasterConversionMode
ImGearRasterConversionModes Enumeration
Ratster converter mode applicable for saving parameters.

Return Value:

ImGearSavingSelection Class

See Also:

ImGearSavingSelection Class

ImGearRasterConversionModes Enumeration

ImGearPage Class


SelectLocalARTFileToLoad Method

32-bit
64-bit
CF
P
P
P

Description:

This method shows an ART file open dialog with filtering for all known ART formats. Nothing is loaded by this method. It only allows the user to make a selection and returns information about that selection.

Declaration:

public static ImageGear.Windows.Forms.ImGearARTLoadingSelection SelectLocalARTFileToLoad (
System.Windows.Forms.IWin32Window owner, System.String dialogTitle )

Parameters:

Name
Type
Description
owner
IWin32Window
Handle of window to use as parent for dialog box.
dialogTitle
String
Window title to use for dialog box.

Return Value:

ImGearARTLoadingSelection Class.

See Also:

ImGearARTLoadingSelection Class


SelectLocalARTFileToSave Method

32-bit
64-bit
CF
P
P
P

Description:

This method shows an ART file save dialog with filtering for all known ART formats. Nothing is saved by this method. It only allows the user to make a selection and returns information about that selection.

Declaration:

public static ImageGear.Windows.Forms.ImGearARTSavingSelection SelectLocalARTFileToSave (
System.Windows.Forms.IWin32Window owner , System.String title )

Parameters:

Name
Type
Description
owner
IWin32Window
Handle of window to use as parent for dialog box.
title
String
Window title to use for dialog box.

Return Value:

ImGearARTSavingSelection Class

See Also:

ImGearARTSavingSelection Class


SelectLocalFileToLoad Method

32-bit
64-bit
CF
P
P
P

Description:

This method shows a dialog box allowing the user to select a local file to load. Nothing is loaded by this method. It only allows the user to make a selection and returns information about that selection.

Declaration:

public static ImageGear.Windows.Forms.ImGearLoadingSelection SelectLocalFileToLoad (
System.Windows.Forms.IWin32Window owner, System.String dialogTitle )

Parameters:

Name
Type
Description
owner
IWin32Window
Handle of window to use as parent for dialog box.
dialogTitle
String
Window title to use for dialog box.

Return Value:

ImGearLoadingSelection Class

See Also:

ImGearLoadingSelection Class


SelectLocalFileToLoadEx Method

32-bit
64-bit
CF
P
P
P

Description:

This method shows a dialog box allowing the user to select a local file to load. Nothing is loaded by this method. It only allows the user to make a selection and returns information about that selection. Unlike the FileOpenDialog shown by SelectLocalFileToLoad Method, this dialog gives the user the option to view an image preview and file/image information as well as the ability to select and preview a specific page from a multi page file.

Declaration:

public static ImageGear.Windows.Forms.ImGearLoadingSelectionEx SelectLocalFileToLoadEx (
System.Windows.Forms.IWin32Window owner )

Parameters:

Name
Type
Description
owner
IWin32Window
Handle of window to use as parent for dialog box.

Return Value:

ImGearLoadingSelectionEx Class

See Also:

ImGearLoadingSelectionEx Class

SelectLocalFileToLoad Method


SelectLocalFileToSave Method

32-bit
64-bit
CF
P
P
P

Description:

This method shows a dialog box allowing the user to select a format and local file to save a document to. Nothing is saved by this method. It only allows the user to make a selection and returns information about that selection.

Declaration:

public static ImageGear.Windows.Forms.ImGearSavingSelection SelectLocalFileToSave (
System.Windows.Forms.IWin32Window owner, System.String title,
ImageGear.Core.ImGearDocument doc )

Parameters:

Name
Type
Description
owner
IWin32Window
Handle of window to use as parent for dialog box.
title
String
Window title to use for dialog box.
doc
ImGearDocument Class
Document to be saved (but not during this method call)

Return Value:

ImGearSavingSelection Class

See Also:

ImGearDocument Class

ImGearSavingSelection Class


SelectLocalFileToSave Method

32-bit
64-bit
CF
P
P
P

Description:

This method shows a dialog box allowing the user to select a format and local file to save a page to. Nothing is saved by this method. It only allows the user to make a selection and returns information about that selection.

Declaration:

public static ImageGear.Windows.Forms.ImGearSavingSelection SelectLocalFileToSave (
System.Windows.Forms.IWin32Window owner, System.String title, ImageGear.Core.ImGearPage
page )

Parameters:

Name
Type
Description
owner
IWin32Window
Handle of window to use as parent for dialog box.
title
String
Window title to use for dialog box.
page
ImGearPage Class
Page to be saved (but not during this method call)

Return Value:

ImGearSavingSelection Class

See Also:

ImGearPage Class

ImGearSavingSelection Class


SelectLocalFileToSave Method

32-bit
64-bit
CF
P
P
P

Description:

This method shows a dialog box allowing the user to select a format and local file using the raster conversion option to save a page to. Nothing is saved by this method. It only allows the user to make a selection and returns information about that selection.

Declaration:

public static ImageGear.Windows.Forms.ImGearSavingSelection SelectLocalFileToSave (
System.Windows.Forms.IWin32Window owner, System.String title, ImageGear.Core.ImGearPage
page, ImageGear.Formats.ImGearRasterConversionModes conversionMode )

Parameters:

Name
Type
Description
owner
IWin32Window
Handle of window to use as parent for dialog box.
title
String
Window title to use for dialog box.
page
ImGearPage Class
Page to be saved (but not during this method call)
conversionMode
ImGearRasterConversionModes Enumeration
Ratster converter mode applicable for saving parameters.

Return Value:

ImGearSavingSelection Class

See Also:

ImGearSavingSelection Class

ImGearRasterConversionModes Enumeration

ImGearPage Class


SelectRemoteFileToLoad Method

32-bit
64-bit
CF
P
P
P

Description:

This method shows a dialog box allowing the user to select a remote file to load. Nothing is loaded by this method. It only allows the user to make a selection and returns information about that selection.

Declaration:

public static ImageGear.Windows.Forms.ImGearLoadingSelection SelectRemoteFileToLoad (
System.Windows.Forms.IWin32Window owner, System.String dialogTitle )

Parameters:

Name
Type
Description
owner
IWin32Window
Handle of window to use as parent for dialog box.
dialogTitle
String
Window title to use for dialog box.

Return Value:

ImGearLoadingSelection Class

See Also:

ImGearLoadingSelection Class


SelectRemoteFileToSave Method

32-bit
64-bit
CF
P
P
P

Description:

This method shows a dialog box allowing the user to select a format and remote destination to save to. Nothing is saved by this method. It only allows the user to make a selection and returns information about that selection.

Declaration:

public static ImageGear.Windows.Forms.ImGearSavingSelection SelectRemoteFileToSave (
System.Windows.Forms.IWin32Window owner, System.String title, ImageGear.Core.ImGearPage
page )

Parameters:

Name
Type
Description
owner
IWin32Window
Handle of window to use as parent for dialog box.
title
String
Window title to use for dialog box.
page
ImGearPage Class
Page to be saved (but not actually saved in this method call)

Return Value:

ImGearSavingSelection Class

See Also:

ImGearPage Class

ImGearSavingSelection Class


ShowAboutBox Method

32-bit
64-bit
CF
P
P
P

Description:

This method shows an About box with ImageGear version information. It's meant to be used by ImageGear samples, but could also be used as part of an application.

Declaration:

public static void ShowAboutBox ( System.Windows.Forms.IWin32Window owner, System.String
sampleName )

Parameters:

Name
Type
Description
owner
IWin32Window
Handle of window to use as parent for dialog box.
sampleName
String
Name of sample (or application) to display in dialog box.

Return Value:

N/A


ShowDocumentInfo Method

32-bit
64-bit
CF
P
P
P

Description:

This method shows a window with information about an ImGearDocument Class.

Declaration:

public static void ShowDocumentInfo ( System.Windows.Forms.IWin32Window owner,
ImageGear.Core.ImGearDocument document )

Parameters:

Name
Type
Description
owner
IWin32Window
Handle of window to use as parent for dialog box.
document
ImGearDocument Class
Document to show information about.

Return Value:

N/A

See Also:

ShowPageInfo Method

ShowFileInfo Method

ImGearDocument Class


ShowExceptionInfo Method

32-bit
64-bit
CF
P
P
P

Description:

This method shows a window with information about the given exception. This method is typically called in the outermost catch block of a thread for which RegisterExceptionHandler was called. But, it can be used any time an exception occurs.

Declaration:

public static void ShowExceptionInfo ( System.Windows.Forms.IWin32Window owner,
System.Exception exception )

Parameters:

Name
Type
Description
owner
IWin32Window
Handle of window to use as parent for dialog box.
exception
Exception
Exception to show information about.

Return Value:

N/A


ShowFileInfo Method

32-bit
64-bit
CF
P
P
P

Description:

This method shows a window with information about an image file.

Declaration:

public static void ShowFileInfo ( System.Windows.Forms.IWin32Window owner, System.String
filePath )

Parameters:

Name
Type
Description
owner
IWin32Window
Handle of window to use as parent for dialog box.
filePath
String
File to show information about.

Return Value:

N/A

See Also:

ShowPageInfo Method

ShowDocumentInfo Method


ShowPageInfo Method

32-bit
64-bit
CF
P
P
P

Description:

This method shows a window with information about an ImGearPage.

Declaration:

public static void ShowPageInfo ( System.Windows.Forms.IWin32Window owner,
ImageGear.Core.ImGearPage page )

Parameters:

Name
Type
Description
owner
IWin32Window
Handle of window to use as parent for dialog box.
page
ImGearPage Class
Page to show information about.

Return Value:

N/A

See Also:

ImGearPage Class


ShowWarningInfo Method

32-bit
64-bit
CF
P
P
P

Description:

This method shows a window with a list of ImageGear warnings that have been added using the AddWarning method.

Declaration:

public static void ShowWarningInfo ( System.Windows.Forms.IWin32Window owner )

Parameters:

Name
Type
Description
owner
IWin32Window
Handle of window to use as parent for dialog box.

Return Value:

N/A

See Also:

AddWarning Method


UnRegisterExceptionHandler Method

32-bit
64-bit
CF
P
P
P

Description:

This method unregisters an exception handler for the entire application, used to display ImageGear error information. This method must only be called in a thread in which the RegisterExceptionHandler method was previously called.

Declaration:

public static void UnRegisterExceptionHandler (  )

Return Value:

N/A

See Also:

RegisterExceptionHandler Method


InputBox Class

32-bit
64-bit
CF
P
P
P

32-bit
64-bit
CF
P
P
P

Description:

The InputBox is a window used to prompt the user for a single input string. It can be used to gather simple text or numeric input from the user without the need for creating a custom window.

It can also provide a search interface if the appropriate constructor used. In this case, a Find button is shown instead of an OK button. When the Find button is clicked, the given FindProc method is called and the window is not closed.

Declaration:

public class InputBox : System.Windows.Forms.Form

Members:

Constructors
Name
Description
InputBox Constructor
This constructor creates and initializes an instance of InputBox Class to act as a search interface.
InputBox Constructor
This constructor creates and initializes an instance of InputBox Class to allow the user to input a string.

Properties
Name
Description
DlgText Property
Contents of the edit box where the user can enter a string.

Delegates
Name
Description
FindProc Delegate
Method called when Find button is clicked.


InputBox Constructors

The InputBox Class of the ImageGear.Windows.Forms Namespace has the following constructors:

Constructors
Name
Description
InputBox Constructor
This constructor creates and initializes an instance of InputBox Class to act as a search interface.
InputBox Constructor
This constructor creates and initializes an instance of InputBox Class to allow the user to input a string.


InputBox Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of InputBox Class to act as a search interface. When this constructor is used, a Find button is shown instead of an OK button. When the Find button is clicked, the given FindProc method is called and the window is not closed.

Declaration:

public InputBox ( System.String Title, System.String Caption, System.String FindText,
ImageGear.Windows.Forms.InputBox.FindProc FindProc, System.Int32 StartPos )

Parameters:

Name
Type
Description
Title
String
Window title.
Caption
String
Explanatory text shown at top of window.
FindText
String
Initial text to populate edit box with.
FindProc
InputBox Class.FindProc Delegate
Method to call when Find button is clicked.
StartPos
Int32
An integer passed to FindProc, used to provide context for a search operation.

Return Value:

The new instance of InputBox Class.

See Also:

InputBox Class


InputBox Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of InputBox Class to allow the user to input a string.

Declaration:

public InputBox ( System.String Title, System.String Caption, System.String Text,
System.Boolean IsPassword )

Parameters:

Name
Type
Description
Title
String
Window title.
Caption
String
Explanatory text shown at top of window.
Text
String
Initial text to populate edit box with.
IsPassword
Boolean
If true, the edit box is used to enter a password with its contents obscured during text entry.

Return Value:

The new instance of InputBox Class.

See Also:

InputBox Class


InputBox Properties

The InputBox Class of the ImageGear.Windows.Forms Namespace has the following properties:

Properties
Name
Description
DlgText Property
Contents of the edit box where the user can enter a string.


DlgText Property

32-bit
64-bit
CF
P
P
P

Description:

This property retrieves the contents of the edit box where the user can enter a string.

Declaration:

public string DlgText [ get ]

Value:

Any string.


InputBox Delegates

The InputBox Class of the ImageGear.Windows.Forms Namespace has the following delegates:

Delegates
Name
Description
FindProc Delegate
Delegate used for method called when Find button is clicked.


FindProc Delegate

32-bit
64-bit
CF
P
P
P

Description:

This delegate is used for the method called when the Find button is clicked, when the InputBox is being used for search purposes. This method is passed an integer initially provided in the constructor, and then from subsequent calls to FindProc. This integer is used to provide context for the search operation - for example, the index of a current position in a string.

Declaration:

public delegate int FindProc(InputBox Dlg, int StartPos);

Return Value:

The value to pass for the StartPos parameter for the next call to FindProc.

See Also:

InputBox Class


ImageGear.Windows.Forms Enumerations

The ImageGear.Windows.Forms Namespace has the following enumeration members:

Enumerations:
Name
Description
ImGearColorProfileActivationMode Enumeration
Specifies color profile activation modes.
ImGearMagnifierShapeType Enumeration
Specifies the shape type of magnifier.


ImGearColorProfileActivationMode Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies color profile activation modes.

Declaration:

public enum ImGearColorProfileActivationMode

Values:

Name
Value
Description
Undefined
ImageGear samples start with color profile support being disabled. As soon as an image that does not follow the standard RGB color space is loaded, the sample opens a dialog suggesting to enable color profiles.
Disable
ImageGear samples start with color profile support being disabled, and does not check image color space and color profiles after image loading.
Enable
ImageGear samples start with color profile support being enabled.


ImGearMagnifierShapeType Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies the shape type of magnifier.

Declaration:

public enum ImGearMagnifierShapeType

Values:

Name
Value
Description
Ellipse
Ellipse magnifier.
Rectangle
Rectangle magnifier.


ImageGear.Windows.Forms.Thumbnail Namespace

ImageGear.Windows.Forms.Thumbnail Namespace

32-bit
64-bit
CF
P
P
P

Description:

This namespace provides GUI Thumbnail control API.

Declaration:

namespace ImageGear.Windows.Forms.Thumbnails

Members:

Classes:
Name
Description
ImGearThumbnailAfterLoadEventArgs Class
This class specifies a list of arguments for ImGearThumbnailAfterLoadEventHandler delegate.
ImGearThumbnailBeforeLoadEventArgs Class
Specifies a list of arguments for ImGearThumbnailBeforeLoadEventHandler delegate.
ImGearThumbnailCtl Class
Controls operations with thumbnail items.
ImGearThumbnailItem Class
Represents one of the thumbnail items displayed on the thumbnail browser.
ImGearThumbnailItemEventArgs Class
Specifies a list of arguments for ImGearThumbnailItemEventHandler delegate.

Delegates:
Name
Description
ImGearThumbnailAfterLoadEventHandler Delegate
Used for declaring ItemAfterLoad event.
ImGearThumbnailBeforeLoadEventHandler Delegate
Used for declaring ItemBeforeLoad event.
ImGearThumbnailItemEventHandler Delegate
Used for declaring ItemAfterCreate, ItemBeforeDelete, ItemClicked and ItemDoubleClicked events.

Enumerations:
Name
Description
ImGearDragDropOptions Enumeration
Specifies drag and drop actions that are allowed in the thumbnail control.
ImGearSortOptions Enumeration
Specifies what sorting is used when a new item is added.


ImageGear.Windows.Forms.Thumbnail Classes

The ImageGear.Windows.Forms.Thumbnail Namespace has the following class members:

Classes:
Name
Description
ImGearThumbnailAfterLoadEventArgs Class
This class specifies a list of arguments for ImGearThumbnailAfterLoadEventHandler delegate.
ImGearThumbnailBeforeLoadEventArgs Class
Specifies a list of arguments for ImGearThumbnailBeforeLoadEventHandler delegate.
ImGearThumbnailCtl Class
Controls operations with thumbnail items.
ImGearThumbnailItem Class
Represents one of the thumbnail items displayed on the thumbnail browser.
ImGearThumbnailItemEventArgs Class
Specifies a list of arguments for ImGearThumbnailItemEventHandler delegate.


ImGearThumbnailAfterLoadEventArgs Class

32-bit
64-bit
CF
P
P
P

Description:

This class specifies a list of arguments for ImGearThumbnailAfterLoadEventHandler delegate.

Declaration:

public class ImGearThumbnailAfterLoadEventArgs : System.EventArgs

Members:

Constructors
Name
Description
ImGearThumbnailAfterLoadEventArgs Constructor
Creates and initializes an instance of ImGearThumbnailAfterLoadEventArgs class.

Properties
Name
Description
Page Property
Specifies ImGearPage Class object containing full-sized picture that was used to create a thumbnail.
Skip Property
Specifies flag indicating whether or not to load thumbnail into a control.


ImGearThumbnailAfterLoadEventArgs Constructors

The ImGearThumbnailAfterLoadEventArgs Class of the ImageGear.Windows.Forms.Thumbnail Namespace has the following constructors:

Constructors
Name
Description
ImGearThumbnailAfterLoadEventArgs Constructor
Creates and initializes an instance of ImGearThumbnailAfterLoadEventArgs class.


ImGearThumbnailAfterLoadEventArgs Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearThumbnailAfterLoadEventArgs Class.

Declaration:

public ImGearThumbnailAfterLoadEventArgs(ImageGear.Core.ImGearPage page, bool skip)

Parameters:

Name
Type
Description
page
ImGearPage Class
ImGearPage Class object containing full-sized picture that was used to create a thumbnail.
skip
bool
Flag indicating whether or not to load thumbnail into a control.

Return Value:

New instance of ImGearThumbnailAfterLoadEventArgs Class.

Sample Code:

C#
ImGearThumbnailAfterLoadEventArgs afterLoadArgs =
new ImGearThumbnailAfterLoadEventArgs(PageToAppend, false);

VB .NET
Dim afterLoadArgs As ImGearThumbnailAfterLoadEventArgs
afterLoadArgs = New ImGearThumbnailAfterLoadEventArgs(PageToAppend, false)

See Also:

ImGearThumbnailAfterLoadEventArgs Class

ImGearPage Class


ImGearThumbnailAfterLoadEventArgs Properties

The ImGearThumbnailAfterLoadEventArgs Class of the ImageGear.Windows.Forms.Thumbnail Namespace has the following properties:

Properties
Name
Description
Page Property
Specifies ImGearPage Class object containing full-sized picture that was used to create a thumbnail.
Skip Property
Specifies flag indicating whether or not to load thumbnail into a control.


Page Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies ImGearPage Class object containing full-sized picture that was used to create a thumbnail.

Declaration:

public ImageGear.Core.ImGearPage Page { get }

Value:

ImGearPage Class.

Sample Code:

C#
ImGearPage page = afterLoadArgs.Page;

VB .NET
Dim page As ImGearPage
page = afterLoadArgs.Page

See Also:

ImGearPage Class


Skip Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies a flag indicating whether or not to load thumbnail into a control. Client should set this to true if there is no need to load thumbnail into a control.

Declaration:

public bool Skip { get; set }

Value:

true, false

Sample Code:

C#
afterLoadArgs.Skip = true;

VB .NET
afterLoadArgs.Skip = true


ImGearThumbnailBeforeLoadEventArgs Class

32-bit
64-bit
CF
P
P
P

Description:

This class specifies a list of arguments for ImGearThumbnailBeforeLoadEventHandler delegate.

Declaration:

public class ImGearThumbnailBeforeLoadEventArgs : System.EventArgs

Members:

Constructors
Name
Description
ImGearThumbnailBeforeLoadEventArgs Constructor
Creates and initializes an instance of ImGearThumbnailBeforeLoadEventArgs class.

Properties
Name
Description
Page Property
Specifies ImGearPage Class object containing full-sized picture that was used to create a thumbnail.
PageNumber Property
Specifies page number of the currently loaded thumbnail.
Skip Property
Specifies flag indicating whether or not to load thumbnail into a control.
Source Property
Specifies path and format of the currently loaded thumbnail.


ImGearThumbnailBeforeLoadEventArgs Constructors

The ImGearThumbnailBeforeLoadEventArgs Class of the ImageGear.Windows.Forms.Thumbnail Namespace has the following constructors:

Constructors
Name
Description
ImGearThumbnailBeforeLoadEventArgs Constructor
Creates and initializes an instance of ImGearThumbnailBeforeLoadEventArgs class.


ImGearThumbnailBeforeLoadEventArgs Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearThumbnailBeforeLoadEventArgs Class.

Declaration:

public
ImGearThumbnailBeforeLoadEventArgs(ImageGear.Windows.Forms.ImGearLoadingSelection
source, ImageGear.Core.ImGearPage page, int pageNumber, bool skip)

Parameters:

Name
Type
Description
source
ImGearLoadingSelection Class
Path and format of the currently loaded thumbnail.
page
ImGearPage Class
ImGearPage Class object containing full-sized picture that was used to create a thumbnail.
pageNumber
int
Page number of the currently loaded thumbnail.
skip
bool
Flag indicating whether or not to load thumbnail into a control.

Return Value:

New instance of ImGearThumbnailBeforeLoadEventArgs Class.

Sample Code:

C#
ImGearThumbnailBeforeLoadEventArgs beforeLoadArgs =
new ImGearThumbnailBeforeLoadEventArgs(source, PageToAppend, PageIndex, false);

VB .NET
Dim beforeLoadArgs As ImGearThumbnailBeforeLoadEventArgs
beforeLoadArgs = New ImGearThumbnailBeforeLoadEventArgs(source, PageToAppend, PageIndex, false)

See Also:

ImGearThumbnailBeforeLoadEventArgs Class

ImGearPage Class

ImGearLoadingSelection Class


ImGearThumbnailBeforeLoadEventArgs Properties

The ImGearThumbnailBeforeLoadEventArgs Class of the ImageGear.Windows.Forms.Thumbnail Namespace has the following properties:

Properties
Name
Description
Page Property
Specifies ImGearPage Class object containing full-sized picture that was used to create a thumbnail.
PageNumber Property
Specifies page number of the currently loaded thumbnail.
Skip Property
Specifies flag indicating whether or not to load thumbnail into a control.
Source Property
Specifies path and format of the currently loaded thumbnail.


Page Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies ImGearPage Class object containing full-sized picture that was used to create a thumbnail.

Declaration:

public ImageGear.Core.ImGearPage Page { get }

Value:

ImGearPage Class.

Sample Code:

C#
ImGearPage page = beforeLoadArgs.Page;

VB .NET
Dim page As ImGearPage
page = beforeLoadArgs.Page

See Also:

ImGearPage Class


PageNumber Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies page number of the currently loaded thumbnail.

Declaration:

public int PageNumber { get }

Value:

Any integer value.

Sample Code:

C#
int pageNum = beforeLoadArgs.PageNumber;

VB .NET
Dim pageNum As Integer
pageNum = beforeLoadArgs.PageNumber


Skip Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies a flag indicating whether or not to load thumbnail into a control. Client should set this to true if there is no need to load thumbnail into a control.

Declaration:

public bool Skip { get; set }

Value:

true, false

Sample Code:

C#
beforeLoadArgs.Skip = true;

VB .NET
beforeLoadArgs.Skip = true


Source Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies path and format of the currently loaded thumbnail.

Declaration:

public ImageGear.Windows.Forms.ImGearLoadingSelection Source { get; set }

Value:

ImGearLoadingSelection Class.

Sample Code:

C#
ImGearLoadingSelection source = beforeLoadArgs.Source;

VB .NET
Dim source As ImGearLoadingSelection
source = beforeLoadArgs.Source

See Also:

ImGearLoadingSelection Class


ImGearThumbnailCtl Class

32-bit
64-bit
CF
P
P
P

Description:

This class controls operations with thumbnail items.

Declaration:

public class ImGearThumbnailCtl : System.Windows.Forms.UserControl

Members:

Constructors
Name
Description
ImGearThumbnailCtl Constructor
Creates and initializes an instance of ImGearThumbnailCtl class.

Properties
Name
Description
AllPages Property
Controls whether all pages of a multi-page image (e.g., a multi-frame GIF or TIFF file) will be loaded into thumbnails, or whether only the first page will be loaded.
AutoFocus Property
Allows setting focus mode for the Thumbnail control. If it is set to true, then the thumbnail browser gets focus when the mouse cursor is on the window. Otherwise mouse click is required.
AutoScroll Property
Specifies whether or not the vertical scrollbar appears when all the items don't fit into the Thumbnail control.
BackColor Property
Specifies the background color of the Thumbnail control.
BorderStyle Property
Specifies border style of the Thumbnail control.
BorderWidth Property
Specifies border width in pixels around the thumbnail. The border is drawn with the color specified by ForeColor.
Count Property
Specifies the number of items within the Thumbnail control, and thus also the number of ImGearThumbnailItem objects available for Item method.
DragDropOptions Property
Specifies whether the thumbnail browser can be a Drag source, Drop target or both.
Flat Property
Specifies whether the thumbnail item will appear flat or three dimensional.
Font Property
Specifies the font used for rendering titles under the thumbnail items.
ForeColor Property
Specifies color to use for rendering titles under those thumbnail items that are neither selected nor highlighted.
HighlightBackColor Property
The titles of some thumbnail items can be shown with a different text background color (whenever Highlighted = true). This property specifies the color to use.
HighlightForeColor Property
The titles of some thumbnail items can be shown with a different text color (whenever Highlighted = true). This property specifies the color to use.
Interior Property
Specifies the amount of extra space in pixels to place around the thumbnail item image inside the "button".
ItemHeight Property
Specifies item height in pixels of the image to be drawn in each thumbnail item.
ItemWidth Property
Specifies item width in pixels of the image to be drawn in each thumbnail item.
LeftMargin Property
Specifies the amount of extra space, in pixels, to leave between the left edge of the control and the left-most item drawn inside the control.
MultiSelect Property
True means that the user can select multiple thumbnail items at the same time (shift-left-click to select a range of items, ctrl-left-click to select multiple individual items). false means that only one item can be selected - selecting one will automatically de-select any other that is selected.
SelectionBackColor Property
One (or more, if MultiSelect = true) thumbnails can be selected by clicking them with the mouse. When selected, the border around the button is changed from BackColor to SelectionBackColor.
SelectionForeColor Property
One (or more, if MultiSelect = true) thumbnails can be selected by clicking them with the mouse. When selected, the text is changed from ForeColor to SelectionForeColor.
ShadowWidth Property
Specifies the width of the 3D appearance for every item if the Flat property is set to true.
ShowMagnify Property
The user may opt to see a larger popup image for the thumbnail by pressing the right-mouse-button down. This property enables/disables this behavior.
ShowTitles Property
A title may be shown for each thumbnail, below the button. This property specifies whether or not to show the titles.
Sort Property
Specifies what sorting (none, title ascending, title descending, user-defined) is used when a new item is added.
SortComparer Property
Used when Sort property is set to "UserSort". User should provide a class implementing IComparer interface to make his own sorting.
TopMargin Property
Specifies the amount of extra space, in pixels, to leave between the top edge of the control and the top-most item drawn inside the control.
XSpacing Property
Specifies the amount of horizontal space between thumbnails displayed on the control, in pixels.
YSpacing Property
Specifies the amount of vertical space between thumbnails displayed on the control, in pixels.
ZoomFactor Property
Only used when ShowMagnify = true. Specifies the amount of zoom-in to use when displaying the magnified popup image (value must be 1.0 or greater).

Methods
Name
Description
DeleteAllItems Method
Removes all the items from the Thumbnail control.
DeleteItem Method
Removes specified item from the Thumbnail control.
DirectoryAppend Method
Creates a series of thumbnail items (either one per file, or one per page per file), by scanning through the specified directory and selecting all of the files matching the specifying filters.
DocumentAppend Method
Appends ImageGear document to the Thumbnail control.
FileAppend Method
Appends a file specified by selection to the Thumbnail control.
Item Method
Returns ImGearThumbnailItem object by given index.
PageAppend Method
Appends ImGearPage Class object to the Thumbnail control.
ReloadAll Method
Reloads all thumbnails in the Thumbnail control.
ReloadItem Method
Reloads thumbnail picture in the specified thumbnail item.

Events
Name
Description
ItemAfterCreate Event
Called after a new thumbnail item is added to the Thumbnail control.
ItemAfterLoad Event
Called during the process of creating a thumbnail item. This event is raised after the image has been loaded into ImGearPage Class object.
ItemBeforeDelete Event
Called as each thumbnail item is removed from the control, before the item is removed from the items collection.
ItemBeforeLoad Event
Called during the process of creating a thumbnail item. This event is raised before the image has been loaded into ImGearPage Class object.
ItemClicked Event
Called to indicate that the user clicked somewhere within the thumbnail control.
ItemDoubleClicked Event
Called to indicate that the user double-clicked somewhere within the thumbnail control.


ImGearThumbnailCtl Constructors

The ImGearThumbnailCtl Class of the ImageGear.Windows.Forms.Thumbnail Namespace has the following constructors:

Constructors
Name
Description
ImGearThumbnailCtl Constructor
Creates and initializes an instance of ImGearThumbnailCtl class.


ImGearThumbnailCtl Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearThumbnailCtl Class.

Declaration:

public ImGearThumbnailCtl()

Return Value:

New instance of ImGearThumbnailCtl Class.

Sample Code:

C#
this.thumbnailCtl1 = new ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailCtl();

VB .NET
Me.thumbnailCtl1 = New ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailCtl()

See Also:

ImGearThumbnailCtl Class


ImGearThumbnailCtl Properties

The ImGearThumbnailCtl Class of the ImageGear.Windows.Forms.Thumbnail Namespace has the following properties:

Properties
Name
Description
AllPages Property
Controls whether all pages of a multi-page image (e.g., a multi-frame GIF or TIFF file) will be loaded into thumbnails, or whether only the first page will be loaded.
AutoFocus Property
Allows setting focus mode for the Thumbnail control. If it is set to true, then the thumbnail browser gets focus when the mouse cursor is on the window. Otherwise mouse click is required.
AutoScroll Property
Specifies whether or not the vertical scrollbar appears when all the items don't fit into the Thumbnail control.
BackColor Property
Specifies the background color of the Thumbnail control.
BorderStyle Property
Specifies border style of the Thumbnail control.
BorderWidth Property
Specifies border width in pixels around the thumbnail. The border is drawn with the color specified by ForeColor.
Count Property
Specifies the number of items within the Thumbnail control, and thus also the number of ImGearThumbnailItem objects available for Item method.
DragDropOptions Property
Specifies whether the thumbnail browser can be a Drag source, Drop target or both.
Flat Property
Specifies whether the thumbnail item will appear flat or three dimensional.
Font Property
Specifies the font used for rendering titles under the thumbnail items.
ForeColor Property
Specifies color to use for rendering titles under those thumbnail items that are neither selected nor highlighted.
HighlightBackColor Property
The titles of some thumbnail items can be shown with a different text background color (whenever Highlighted = true). This property specifies the color to use.
HighlightForeColor Property
The titles of some thumbnail items can be shown with a different text color (whenever Highlighted = true). This property specifies the color to use.
Interior Property
Specifies the amount of extra space in pixels to place around the thumbnail item image inside the "button".
ItemHeight Property
Specifies item height in pixels of the image to be drawn in each thumbnail item.
ItemWidth Property
Specifies item width in pixels of the image to be drawn in each thumbnail item.
LeftMargin Property
Specifies the amount of extra space, in pixels, to leave between the left edge of the control and the left-most item drawn inside the control.
MultiSelect Property
true means that the user can select multiple thumbnail items at the same time (shift-left-click to select a range of items, ctrl-left-click to select multiple individual items). false means that only one item can be selected - selecting one will automatically de-select any other that is selected.
SelectionBackColor Property
One (or more, if MultiSelect = true) thumbnails can be selected by clicking them with the mouse. When selected, the border around the button is changed from BackColor to SelectionBackColor.
SelectionForeColor Property
One (or more, if MultiSelect = true) thumbnails can be selected by clicking them with the mouse. When selected, the text is changed from ForeColor to SelectionForeColor.
ShadowWidth Property
Specifies the width of the 3D appearance for every item if the Flat property is set to true.
ShowMagnify Property
The user may opt to see a larger popup image for the thumbnail by pressing the right-mouse-button down. This property enables/disables this behavior.
ShowTitles Property
A title may be shown for each thumbnail, below the button. This property specifies whether or not to show the titles.
Sort Property
Specifies what sorting (none, title ascending, title descending, user-defined) is used when a new item is added.
SortComparer Property
Used when Sort property is set to "UserSort". User should provide a class implementing IComparer interface to make his own sorting.
TopMargin Property
Specifies the amount of extra space, in pixels, to leave between the top edge of the control and the top-most item drawn inside the control.
XSpacing Property
Specifies the amount of horizontal space between thumbnails displayed on the control, in pixels.
YSpacing Property
Specifies the amount of vertical space between thumbnails displayed on the control, in pixels.
ZoomFactor Property
Only used when ShowMagnify = true. Specifies the amount of zoom-in to use when displaying the magnified popup image (value must be 1.0 or greater).


AllPages Property

32-bit
64-bit
CF
P
P
P

Description:

This property controls whether all pages of a multi-page image (e.g., a multi-frame GIF or TIFF file) will be loaded into thumbnails, or whether only the first page will be loaded.

Declaration:

public bool AllPages { get; set }

Value:

true, false

Sample Code:

C#
thumbnailCtl1.AllPages = false;

VB .NET
thumbnailCtl1.AllPages = False


AutoFocus Property

32-bit
64-bit
CF
P
P
P

Description:

This property allows setting focus mode for the Thumbnail control. If it is set to true, then the thumbnail browser gets focus when the mouse cursor is on the window. Otherwise mouse click is required.

Declaration:

public bool AutoFocus { get; set }

Value:

true, false

Sample Code:

C#
thumbnailCtl1.AutoFocus = false;

VB .NET
thumbnailCtl1.AutoFocus = False


AutoScroll Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies whether or not the vertical scrollbar appears when all the items don't fit into the Thumbnail control.

Declaration:

public override bool AutoScroll { get; set }

Value:

true, false

Sample Code:

C#
thumbnailCtl1.AutoScroll = false;

VB .NET
thumbnailCtl1.AutoScroll = False


BackColor Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies background color of the Thumbnail control.

Declaration:

public override System.Drawing.Color BackColor { get; set }

Value:

System.Drawing.Color value.

Sample Code:

C#
thumbnailCtl1.BackColor = bkgColor;

VB .NET
thumbnailCtl1.BackColor = bkgColor


BorderStyle Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies border style of the Thumbnail control.

Declaration:

public System.Windows.Forms.BorderStyle BorderStyle { get; set }

Value:

System.Windows.Forms.BorderStyle value.

Sample Code:

C#
thumbnailCtl1.BorderStyle = brdStyle;

VB .NET
thumbnailCtl1.BorderStyle = brdStyle


BorderWidth Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies border width in pixels around the thumbnail. The border is drawn with the color specified by ForeColor.

Declaration:

public int BorderWidth { get; set }

Value:

Integer value.

Sample Code:

C#
thumbnailCtl1.BorderWidth = 1;

VB .NET
thumbnailCtl1.BorderWidth = 1


Count Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the number of items within the Thumbnail control, and thus also the number of ImGearThumbnailItem objects available for Item method.

Declaration:

public int Count { get }

Value:

Integer value

Sample Code:

C#
if (thumbnailCtl1.Count > 0)
{
...
}

VB .NET
if thumbnailCtl1.Count > 0 Then
...
EndIf


DragDropOptions Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies whether the thumbnail browser can be a Drag source, Drop target or both.

Declaration:

public ImageGear.Windows.Forms.Thumbnails.ImGearDragDropOptions DragDropOptions { get; set
}

Value:

ImGearDragDropOptions Enumeration value.

Sample Code:

C#
thumbnailCtl1.DragDropOptions = ImGearDragDropOptions.DragDrop;

VB .NET
thumbnailCtl1.DragDropOptions = ImGearDragDropOptions.DragDrop

See Also:

ImGearDragDropOptions Enumeration


Flat Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies whether the thumbnail item will appear flat or three dimensional.

Declaration:

public bool Flat { get; set }

Value:

true, false

Sample Code:

C#
thumbnailCtl1.Flat = false;

VB .NET
thumbnailCtl1.Flat = False


Font Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies font used for rendering titles under the thumbnail items.

Declaration:

public override System.Drawing.Font Font { get; set }

Value:

System.Drawing.Font value.

Sample Code:

C#
thumbnailCtl1.Font = font;

VB .NET
thumbnailCtl1.Font = font


ForeColor Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies color to use for rendering titles under those thumbnail items that are neither selected nor highlighted.

Declaration:

public override System.Drawing.Color ForeColor { get; set }

Value:

System.Drawing.Color value.

Sample Code:

C#
thumbnailCtl1.ForeColor = foreColor;

VB .NET
thumbnailCtl1.ForeColor = foreColor


HighlightBackColor Property

32-bit
64-bit
CF
P
P
P

Description:

The titles of some thumbnail items can be shown with a different text background color (whenever Highlighted = true). This property specifies the color to use.

Declaration:

public System.Drawing.Color HighlightBackColor { get; set }

Value:

System.Drawing.Color value.

Sample Code:

C#
thumbnailCtl1.HighlightBackColor = hbColor;

VB .NET
thumbnailCtl1.HighlightBackColor = hbColor


HighlightForeColor Property

32-bit
64-bit
CF
P
P
P

Description:

The titles of some thumbnail items can be shown with a different text color (whenever Highlighted = true). This property specifies the color to use.

Declaration:

public System.Drawing.Color HighlightForeColor { get; set }

Value:

System.Drawing.Color value.

Sample Code:

C#
thumbnailCtl1.HighlightForeColor = hfColor;

VB .NET
thumbnailCtl1.HighlightForeColor = hfColor


Interior Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the amount of extra space, in pixels, to place around the thumbnail item image inside the "button".

Declaration:

public int Interior { get; set }

Value:

Integer value.

Sample Code:

C#
thumbnailCtl1.Interior = 3;

VB .NET
thumbnailCtl1.Interior = 3


ItemHeight Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies item height in pixels of the image to be drawn in each thumbnail item.

Declaration:

public int ItemHeight { get; set }

Value:

Integer value.

Sample Code:

C#
thumbnailCtl1.ItemHeight = 100;

VB .NET
thumbnailCtl1.ItemHeight = 100


ItemWidth Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies item width in pixels of the image to be drawn in each thumbnail item.

Declaration:

public int ItemWidth { get; set }

Value:

Integer value.

Sample Code:

C#
thumbnailCtl1.ItemWidth = 100;

VB .NET
thumbnailCtl1.ItemWidth = 100


LeftMargin Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the amount of extra space, in pixels, to leave between the left edge of the control and the left-most item drawn inside the control. Note that the Thumbnail control is resizable, so the amount of margin on the right side is determined automatically.

Declaration:

public int LeftMargin { get; set }

Value:

Integer value.

Sample Code:

C#
thumbnailCtl1.LeftMargin = 10;

VB .NET
thumbnailCtl1.LeftMargin = 10


MultiSelect Property

32-bit
64-bit
CF
P
P
P

Description:

If this property is true that means that the user can select multiple thumbnail items at the same time (shift-left-click to select a range of items, ctrl-left-click to select multiple individual items). If it is false, only one item can be selected - selecting one will automatically de-select any other that is selected.

Declaration:

public bool MultiSelect { get; set }

Value:

true, false

Sample Code:

C#
thumbnailCtl1.MultiSelect = true;

VB .NET
thumbnailCtl1.MultiSelect = True


SelectionBackColor Property

32-bit
64-bit
CF
P
P
P

Description:

One (or more, if MultiSelect = true) thumbnails can be selected by clicking them with the mouse. When selected, the border around the button is changed from BackColor to SelectionBackColor.

Declaration:

public System.Drawing.Color SelectionBackColor { get; set }

Value:

System.Drawing.Color value.

Sample Code:

C#
thumbnailCtl1.SelectionBackColor = sbColor;

VB .NET
thumbnailCtl1.SelectionBackColor = sbColor


SelectionForeColor Property

32-bit
64-bit
CF
P
P
P

Description:

One (or more, if MultiSelect = true) thumbnails can be selected by clicking them with the mouse. When selected, the text is changed from ForeColor to SelectionForeColor.

Declaration:

public System.Drawing.Color SelectionForeColor { get; set }

Value:

System.Drawing.Color value.

Sample Code:

C#
thumbnailCtl1.SelectionForeColor = sfColor;

VB .NET
thumbnailCtl1.SelectionForeColor = sfColor


ShadowWidth Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the width of the 3D appearance for every item if the Flat property is set to true.

Declaration:

public int ShadowWidth { get; set }

Value:

Integer value.

Sample Code:

C#
thumbnailCtl1.ShadowWidth = 2;

VB .NET
thumbnailCtl1.ShadowWidth = 2


ShowMagnify Property

32-bit
64-bit
CF
P
P
P

Description:

The user may opt to see a larger popup image for the thumbnail by pressing the right-mouse-button down. This property enables/disables this behavior.

Declaration:

public bool ShowMagnify { get; set }

Value:

true, false.

Sample Code:

C#
thumbnailCtl1.ShowMagnify = true;

VB .NET
thumbnailCtl1.ShowMagnify = True


ShowTitles Property

32-bit
64-bit
CF
P
P
P

Description:

A title may be shown for each thumbnail, below the button. This property specifies whether or not to show the titles.

Declaration:

public bool ShowTitles { get; set }

Value:

true, false

Sample Code:

C#
thumbnailCtl1.ShowTitles = true;

VB .NET
thumbnailCtl1.ShowTitles = True


Sort Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies what sorting (none, title ascending, title descending, user-defined) is used when a new item is added.

Declaration:

public ImageGear.Windows.Forms.Thumbnails.ImGearSortOptions Sort { get; set }

Value:

ImGearSortOptions Enumeration values.

Sample Code:

C#
thumbnailCtl1.Sort = ImGearSortOptions.TitleAscending;

VB .NET
thumbnailCtl1.Sort = ImGearSortOptions.TitleAscending

See Also:

ImGearSortOptions Enumeration


SortComparer Property

32-bit
64-bit
CF
P
P
P

Description:

This property is used when Sort property is set to "UserSort". User should provide a class implementing IComparer interface to make his own sorting.

Declaration:

public System.Collections.IComparer SortComparer { get; set }

Value:

System.Collections.IComparer value.

Sample Code:

C#
thumbnailCtl1.SortComparer = userSorter;

VB .NET
thumbnailCtl1.SortComparer = userSorter


TopMargin Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the amount of extra space, in pixels, to leave between the top edge of the control and the top-most item drawn inside the control. Note that Thumbnail control is resizable, so the amount of margin on the bottom side is determined automatically.

Declaration:

public int TopMargin { get; set }

Value:

Integer value.

Sample Code:

C#
thumbnailCtl1.TopMargin = 10;

VB .NET
thumbnailCtl1.TopMargin = 10


XSpacing Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the amount of horizontal space between thumbnails displayed on the control, in pixels. When set to (-1) it will use the default spacing that Windows uses for icons.

Declaration:

public int XSpacing { get; set }

Value:

Integer value.

Sample Code:

C#
thumbnailCtl1.XSpacing = 10;

VB .NET
thumbnailCtl1.XSpacing = 10


YSpacing Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies the amount of vertical space between thumbnails displayed on the control, in pixels. When set to (-1) it will use the default spacing that Windows uses for icons. When ShowTitles = true, the YSpacing measures the distance from the bottom of a title to the top of the item below it. When ShowTitles = false, the YSpacing measures the distance from the bottom of the item to the top of the one below it.

Declaration:

public int YSpacing { get; set }

Value:

Integer value.

Sample Code:

C#
thumbnailCtl1.YSpacing = 10;

VB .NET
thumbnailCtl1.YSpacing = 10


ZoomFactor Property

32-bit
64-bit
CF
P
P
P

Description:

This property only used when ShowMagnify = true. Specifies the amount of zoom-in to use when displaying the magnified popup image (value must be 1.0 or greater).

Declaration:

public float ZoomFactor { get; set }

Value:

Float value.

Sample Code:

C#
thumbnailCtl1.ZoomFactor = 2.0;

VB .NET
thumbnailCtl1.ZoomFactor = 2.0


ImGearThumbnailCtl Methods

The ImGearThumbnailCtl Class of the ImageGear.Windows.Forms.Thumbnail Namespace has the following methods:

Methods
Name
Description
DeleteAllItems Method
Removes all the items from the Thumbnail control.
DeleteItem Method
Removes specified item from the Thumbnail control.
DirectoryAppend Method
Creates a series of thumbnail items (either one per file, or one per page per file), by scanning through the specified directory and selecting all of the files matching the specifying filters.
DocumentAppend Method
Appends ImageGear document to the Thumbnail control.
FileAppend Method
Appends a file specified by selection to the Thumbnail control.
Item Method
Returns ImGearThumbnailItem object by given index.
PageAppend Method
Appends ImGearPage Class object to the Thumbnail control.
ReloadAll Method
Reloads all thumbnails in the Thumbnail control.
ReloadItem Method
Reloads thumbnail picture in the specified thumbnail item.


DeleteAllItems Method

32-bit
64-bit
CF
P
P
P

Description:

This method removes all the items from the Thumbnail control.

Declaration:

public void DeleteAllItems()

Return Value:

N/A

Sample Code:

C#
thumbnailCtl1.DeleteAllItems();

VB .NET
thumbnailCtl1.DeleteAllItems()


DeleteItem Method

32-bit
64-bit
CF
P
P
P

Description:

This method removes specified item from the Thumbnail control.

Declaration:

public void DeleteItem(ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailItem item)

Parameters:

Name
Type
Description
item
ImGearThumbnailItem Class
Item to be removed.

Return Value:

N/A

Sample Code:

C#
if (item.Selected)
{
    thumbnailCtl1.DeleteItem(item);
}

VB .NET
if item.Selected Then
    thumbnailCtl1.DeleteItem(item)
Endif

See Also:

ImGearThumbnailItem Class


DirectoryAppend Method

32-bit
64-bit
CF
P
P
P

Description:

This method creates a series of thumbnail items (either one per file, or one per page per file), by scanning through the specified directory and selecting all of the files matching the Filters parameter.

Declaration:

public void DirectoryAppend (string Dir, string Filters)

Parameters:

Name
Type
Description
Dir
string
Can either be specified as a DOS file path (e.g., with a drive-letter), or as a Windows file path (e.g., a UNC file path like "\\server\sharename\directory").
Filters
string
A standard Windows file-filter string: "*.*" means all files, "*.bmp" means all BMP files, "*.JPG;*.BMP" means all BMP and JPG files.

Return Value:

N/A

Sample Code:

C#
thumbnailForm.thumbnailCtl1.DirectoryAppend(browsePath, browseFilters);

VB .NET
thumbnailForm.thumbnailCtl1.DirectoryAppend(browsePath, browseFilters)


DocumentAppend Method

32-bit
64-bit
CF
P
P
P

Description:

This method appends ImGearDocument Class object to the Thumbnail control.

Declaration:

public void DocumentAppend(ImageGear.Core.ImGearDocument DocumentToAppend, string Name)

Parameters:

Name
Type
Description
DocumentToAppend
ImGearDocument Class
Document to be appended.
Name
string
Title for new items.

Return Value:

N/A

Sample Code:

C#
thumbnailForm.thumbnailCtl1.DocumentAppend(docToLoad, "Loaded document");

VB .NET
thumbnailForm.thumbnailCtl1.DocumentAppend(docToLoad, "Loaded document")

See Also:

ImGearDocument Class


FileAppend Method

32-bit
64-bit
CF
P
P
P

Description:

This method appends a file specified by selection to the Thumbnail control.

Declaration:

public void FileAppend(ImageGear.Windows.Forms.ImGearLoadingSelection Selection)

Parameters:

Name
Type
Description
Selection
ImGearLoadingSelection Class
Selection specifying a path and a type of the file to be appended.

Return Value:

N/A

Sample Code:

C#
thumbnailForm.thumbnailCtl1.FileAppend(selection);

VB .NET
thumbnailForm.thumbnailCtl1.FileAppend(selection)

See Also:

ImGearLoadingSelection Class


Item Method

32-bit
64-bit
CF
P
P
P

Description:

This method returns ImGearThumbnailItem object by given index.

Declaration:

public ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailItem Item (int Index)

Parameters:

Name
Type
Description
Index
int
Index of the requested thumbnail.

Return Value:

ImGearThumbnailItem Class

Sample Code:

C#
ImGearThumbnailItem item = thumbnailForm.thumbnailCtl1.Item(i);

VB .NET
Dim item As ImGearThumbnailItem
item = thumbnailForm.thumbnailCtl1.Item(i)

See Also:

ImGearThumbnailItem Class


PageAppend Method

32-bit
64-bit
CF
P
P
P

Description:

This method appends ImGearPage Class object to the Thumbnail control.

Declaration:

public void PageAppend (ImageGear.Core.ImGearPage PageToAppend, string Name)

Parameters:

Name
Type
Description
PageToAppend
ImGearPage Class
ImGearPage Class object to be appended.
Name
string
Title for new item.

Return Value:

N/A

Sample Code:

C#
thumbnailForm.thumbnailCtl1.PageAppend(pageToLoad, "Loaded page");

VB .NET
thumbnailForm.thumbnailCtl1.PageAppend(pageToLoad, "Loaded page")

See Also:

ImGearPage Class


ReloadAll Method

32-bit
64-bit
CF
P
P
P

Description:

This method reloads all thumbnails in the Thumbnail control.

Declaration:

public void ReloadAll()

Return Value:

N/A

Sample Code:

C#
thumbnailCtl1.ReloadAll();

VB .NET
thumbnailCtl1.ReloadAll()


ReloadItem Method

32-bit
64-bit
CF
P
P
P

Description:

This method reloads thumbnail picture in the specified thumbnail item.

Declaration:

public void ReloadItem(ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailItem Item)

Parameters:

Name
Type
Description
Item
ImGearThumbnailItem Class
Item to be reloaded.

Return Value:

N/A

Sample Code:

C#
thumbnailCtl1.ReloadItem(item);

VB .NET
thumbnailCtl1.ReloadItem(item)

See Also:

ImGearThumbnailItem Class


ImGearThumbnailCtl Events

The ImGearThumbnailCtl Class of the ImageGear.Windows.Forms.Thumbnail Namespace has the following events:

Events
Name
Description
ItemAfterCreate Event
Called after a new thumbnail item is added to the Thumbnail control.
ItemAfterLoad Event
Called during the process of creating a thumbnail item. This event is raised after the image has been loaded into ImGearPage Class object.
ItemBeforeDelete Event
Called as each thumbnail item is removed from the control, before the item is removed from the items collection.
ItemBeforeLoad Event
Called during the process of creating a thumbnail item. This event is raised before the image has been loaded into ImGearPage Class object.
ItemClicked Event
Called to indicate that the user clicked somewhere within the thumbnail control.
ItemDoubleClicked Event
Called to indicate that the user double-clicked somewhere within the thumbnail control.


ItemAfterCreate Event

32-bit
64-bit
CF
P
P
P

Description:

This event is called after a new thumbnail item is added to the Thumbnail control. During thumbnail item creation, the sequence of events is ItemBeforeLoad, then ItemAfterLoad, then ItemAfterCreate.

Declaration:

public event ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailItemEventHandler
ItemAfterCreate

Return Value:

ImGearThumbnailItemEventHandler Delegate.

See Also:

ImGearThumbnailItemEventHandler Delegate


ItemAfterLoad Event

32-bit
64-bit
CF
P
P
P

Description:

This event is called during the process of creating a thumbnail item. This event is raised after the image has been loaded into ImGearPage Class object, but before the thumbnail item is created. Your application can implement this event handler if it needs to restrict the thumbnail items based on the file attributes.

Declaration:

public event ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailAfterLoadEventHandler
ItemAfterLoad

Return Value:

ImGearThumbnailItemEventHandler Delegate.

See Also:

ImGearThumbnailItemEventHandler Delegate

ImGearPage Class


ItemBeforeDelete Event

32-bit
64-bit
CF
P
P
P

Description:

This event is called as each thumbnail item is removed from the control, before the item is removed from the items collection.

Declaration:

public event ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailItemEventHandler
ItemBeforeDelete

Return Value:

ImGearThumbnailItemEventHandler Delegate.

See Also:

ImGearThumbnailItemEventHandler Delegate


ItemBeforeLoad Event

32-bit
64-bit
CF
P
P
P

Description:

This event is called during the process of creating a thumbnail item. This event is raised before the image has been loaded into ImGearPage Class object. Your application can use this event to set the ImageGear file load handling (e.g., load scaled JPEG image) and the thumbnail image generation handling (e.g., aliasing, interpolation).

Declaration:

public event ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailBeforeLoadEventHandler
ItemBeforeLoad

Return Value:

ImGearThumbnailItemEventHandler Delegate.

See Also:

ImGearThumbnailItemEventHandler Delegate


ItemClicked Event

32-bit
64-bit
CF
P
P
P

Description:

This event is called to indicate that the user clicked somewhere within the thumbnail control.

Declaration:

public event ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailItemEventHandler
ItemClicked

Return Value:

ImGearThumbnailItemEventHandler Delegate.

See Also:

ImGearThumbnailItemEventHandler Delegate


ItemDoubleClicked Event

32-bit
64-bit
CF
P
P
P

Description:

This event is called to indicate that the user double-clicked somewhere within the thumbnail control.

Declaration:

public event ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailItemEventHandler
ItemDoubleClicked

Return Value:

ImGearThumbnailItemEventHandler Delegate.

See Also:

ImGearThumbnailItemEventHandler Delegate


ImGearThumbnailItem Class

32-bit
64-bit
CF
P
P
P

Description:

Each ImGearThumbnailItem object represents one of the thumbnail items displayed on the thumbnail browser. Your application can iterate through the collection of ImGearThumbnailItem using the Item method and Count property of ImGearThumbnailCtl. Some of the event handlers are using ImGearThumbnailItem objects (for instance, when someone clicks on a particular thumbnail item).

Declaration:

public class ImGearThumbnailItem : System.Windows.Forms.UserControl

Members:

Constructors
Name
Description
ImGearThumbnailItem Constructor
Creates and initializes an instance of ImGearThumbnailItem class.
ImGearThumbnailItem Constructor
Creates and initializes an instance of ImGearThumbnailItem class.

Properties
Name
Description
BitDepth Property
Original image bit depth
Format Property
Original image format.
Height Property
Item's height.
HighlightBackColor Property
Title's back color of the highlighted item.
Highlighted Property
Highlighted state of the item.
HighlightForeColor Property
Title's fore color of the highlighted item.
ImageSize Property
Original image size.
Page Property
ImGearPage Class object referencing to the original image.
PageNumber Property
Page number.
PrivateData Property
User data associated with the item.
Selected Property
Selection state of the item.
Source Property
ImGearLoadingSelection object containing path and format of the original file.
Thumbnail Property
Thumbnail bitmap representing an image.
Title Property
Item's title.
Width Property
Item's width.

Methods
Name
Description
Reload Method
Reloads item's picture.


ImGearThumbnailItem Constructors

The ImGearThumbnailItem Class of the ImageGear.Windows.Forms.Thumbnail Namespace has the following constructors:

Constructors
Name
Description
ImGearThumbnailItem Constructor
Creates and initializes an instance of ImGearThumbnailItem class.
ImGearThumbnailItem Constructor
Creates and initializes an instance of ImGearThumbnailItem class.


ImGearThumbnailItem Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearThumbnailItem Class.

Declaration:

public ImGearThumbnailItem(ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailCtl
parent, ImageGear.Core.ImGearPage pageToLoad, string title, int pageNumber,
ImageGear.Formats.ImGearFormats format)

Parameters:

Name
Type
Description
parent
ImGearThumbnailCtl Class
Reference to the parent ImGearThumbnailCtl object.
pageToLoad
ImGearPage Class
Reference to ImGearPage Class object that contains original image.
title
string
Thumbnail item's title.
pageNumber
int
Page number.
format
ImGearFormats Enumeration
Original image format.

Return Value:

New instance of ImGearThumbnailItem Class.

Sample Code:

C#
ImGearThumbnailItem item = new ImGearThumbnailItem(this, PageToAppend, Name, PageIndex, Format);

VB .NET
Dim item As ImGearThumbnailItem
item = New ImGearThumbnailItem(Me, PageToAppend, Name, PageIndex, Format)

See Also:

ImGearThumbnailItem Class

ImGearFormats Enumeration

ImGearPage Class

ImGearThumbnailCtl Class


ImGearThumbnailItem Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearThumbnailItem Class.

Declaration:

public ImGearThumbnailItem(ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailCtl
parent, ImageGear.Windows.Forms.ImGearLoadingSelection loadingSelection, string title,
int pageNumber)

Parameters:

Name
Type
Description
parent
ImGearThumbnailCtl Class
Reference to the parent ImGearThumbnailCtl object.
loadingSelection
ImGearLoadingSelection Class
Reference to ImGearLoadingSelection object containing path and format of the original file.
title
string
Thumbnail item's title.
pageNumber
int
Page number.

Return Value:

New instance of ImGearThumbnailItem Class.

Sample Code:

C#
ImGearThumbnailItem item = new ImGearThumbnailItem(this, Selection, Selection.File.Path, PageIndex);

VB .NET
Dim item As ImGearThumbnailItem
item = New ImGearThumbnailItem(Me, Selection, Selection.File.Path, PageIndex)

See Also:

ImGearThumbnailItem Class

ImGearThumbnailCtl Class

ImGearLoadingSelection Class


ImGearThumbnailItem Properties

The ImGearThumbnailItem Class of the ImageGear.Windows.Forms.Thumbnail Namespace has the following properties:

Properties
Name
Description
BitDepth Property
Original image bit depth
Format Property
Original image format.
Height Property
Item's height.
HighlightBackColor Property
Title's back color of the highlighted item.
Highlighted Property
Highlighted state of the item.
HighlightForeColor Property
Title's fore color of the highlighted item.
ImageSize Property
Original image size.
Page Property
ImGearPage Class object referencing to the original image.
PageNumber Property
Page number.
PrivateData Property
User data associated with the item.
Selected Property
Selection state of the item.
Source Property
ImGearLoadingSelection object containing path and format of the original file.
Thumbnail Property
Thumbnail bitmap representing an image.
Title Property
Item's title.
Width Property
Item's width.


BitDepth Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies original image bit depth.

Declaration:

public int BitDepth { get }

Value:

Integer value.

Sample Code:

C#
int bitDepth = item.BitDepth;

VB .NET
Dim bitDepth As Integer
bitDepth = item.BitDepth


Format Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies original image format.

Declaration:

public ImageGear.Formats.ImGearFormats Format { get }

Value:

ImGearFormats Enumeration value.

Sample Code:

C#
ImGearFormats format = item.Format;

VB .NET
Dim format As ImGearFormats
format = item.Format

See Also:

ImGearFormats Enumeration


Height Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies item's height.

Declaration:

public int Height { get; set }

Value:

Integer value.

Sample Code:

C#
item.Height = 100;

VB .NET
item.Height = 100;


HighlightBackColor Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies title's back color of the highlighted item. If it is not set, HighlightBackColor from thumbnail control is used.

Declaration:

public System.Drawing.Color HighlightBackColor { get; set }

Value:

System.Drawing.Color value.

Sample Code:

C#
item.HighlightBackColor = value;

VB .NET
item.HighlightBackColor = value


Highlighted Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies highlighted state of the item.

Declaration:

public bool Highlighted { get; set }

Value:

true, false

Sample Code:

C#
item.Highlighted = true;

VB .NET
item.Highlighted = true


HighlightForeColor Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies title's fore color of the highlighted item. If it is not set, HighlightForeColor from thumbnail control is used.

Declaration:

public System.Drawing.Color HighlightForeColor { get; set }

Value:

System.Drawing.Color value.

Sample Code:

C#
item.HighlightForeColor = value;

VB .NET
item.HighlightForeColor = value


ImageSize Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies original image size.

Declaration:

public int ImageSize { get }

Value:

Integer value.

Sample Code:

C#
int size = item.ImageSize;

VB .NET
Dim size As Integer
size = item.ImageSize


Page Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies ImGearPage Class object referencing to the original image.

Declaration:

public ImageGear.Core.ImGearPage Page { get }

Value:

ImGearPage Class.

Sample Code:

C#
ImGearPage page = item.Page;

VB .NET
Dim page As ImGearPage
page = item.Page

See Also:

ImGearPage Class


PageNumber Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies page number.

Declaration:

public int PageNumber { get }

Value:

Integer value.

Sample Code:

C#
int pageNum = item.PageNumber;

VB .NET
Dim pageNum As Integer
pageNum = item.PageNumber


PrivateData Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies user data associated with the item.

Declaration:

public object PrivateData { get; set }

Value:

Object

Sample Code:

C#
item.PrivateData = userData;

VB .NET
item.PrivateData = userData


Selected Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies selection state of the item. Default value is false.

Declaration:

public bool Selected { get; set }

Value:

true, false

Sample Code:

C#
item.Selected = true;

VB .NET
item.Selected = true


Source Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies ImGearLoadingSelection object containing path and format of the original file.

Declaration:

public ImageGear.Windows.Forms.ImGearLoadingSelection Source { get }

Value:

ImGearLoadingSelection Class.

Sample Code:

C#
ImGearLoadingSelection source = item.Source;

VB .NET
Dim source As ImGearLoadingSelection
source = item.Source

See Also:

ImGearLoadingSelection Class


Thumbnail Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies a thumbnail bitmap representing an image.

Declaration:

public System.Drawing.Image Thumbnail { get }

Value:

System.Drawing.Image class.

Sample Code:

C#
Image thumbnail = item.Thumbnail;

VB .NET
Dim thumbnail As Image
thumbnail = item.Thumbnail


Title Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies item's title.

Declaration:

public string Title { get; set }

Value:

String value.

Sample Code:

C#
string title = item.Title;

VB .NET
Dim title As String
title = item.Title


Width Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies item's width.

Declaration:

public int Width { get; set }

Value:

Integer value.

Sample Code:

C#
item.Width = 100;

VB .NET
item.Width = 100


ImGearThumbnailItem Methods

The ImGearThumbnailItem Class of the ImageGear.Windows.Forms.Thumbnail Namespace has the following methods:

Methods
Name
Description
Reload Method
Reloads item's picture.


Reload Method

32-bit
64-bit
CF
P
P
P

Description:

This method reloads item's picture.

Declaration:

public void Reload()

Return Value:

N/A

Sample Code:

C#
foreach (ImGearThumbnailItem item in items)
    item.Reload();

VB .NET
item.Reload()


ImGearThumbnailItemEventArgs Class

32-bit
64-bit
CF
P
P
P

Description:

This class specifies a list of arguments for ImGearThumbnailItemEventHandler delegate.

Declaration:

public class ImGearThumbnailItemEventArgs : System.EventArgs

Members:

Constructors
Name
Description
ImGearThumbnailItemEventArgs Constructor
Creates and initializes an instance of ImGearThumbnailItemEventArgs class.

Properties
Name
Description
Item Property
Specifies ImGearThumbnailItem object that generated event.


ImGearThumbnailItemEventArgs Constructors

The ImGearThumbnailItemEventArgs Class of the ImageGear.Windows.Forms.Thumbnail Namespace has the following constructors:

Constructors
Name
Description
ImGearThumbnailItemEventArgs Constructor
Creates and initializes an instance of ImGearThumbnailItemEventArgs class.


ImGearThumbnailItemEventArgs Constructor

32-bit
64-bit
CF
P
P
P

Description:

This constructor creates and initializes an instance of ImGearThumbnailItemEventArgs Class.

Declaration:

public
ImGearThumbnailItemEventArgs(ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailItem
item)

Parameters:

Name
Type
Description
item
ImGearThumbnailItem Class
Item that generated event.

Return Value:

New instance of ImGearThumbnailItemEventArgs Class.

Sample Code:

C#
OnItemAfterCreate(this, new ImGearThumbnailItemEventArgs(item));

VB .NET
OnItemAfterCreate(Me, New ImGearThumbnailItemEventArgs(item))

See Also:

ImGearThumbnailItemEventArgs Class

ImGearThumbnailItem Class


ImGearThumbnailItemEventArgs Properties

The ImGearThumbnailItemEventArgs Class of the ImageGear.Windows.Forms.Thumbnail Namespace has the following properties:

Properties
Name
Description
Item Property
Specifies ImGearThumbnailItem object that generated event.


Item Property

32-bit
64-bit
CF
P
P
P

Description:

This property specifies ImGearThumbnailItem object that generated event.

Declaration:

public ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailItem Item { get }

Value:

ImGearThumbnailItem Class class.

Sample Code:

C#
ImGearThumbnailItem item = itemArgs.Item;

VB .NET
Dim item As ImGearThumbnailItem
item = itemArgs.Item

See Also:

ImGearThumbnailItem Class


ImageGear.Windows.Forms.Thumbnail Delegates

The ImageGear.Windows.Forms.Thumbnail Namespace has the following delegate members:

Classes:
Name
Description
ImGearThumbnailAfterLoadEventHandler Delegate
Used for declaring ItemAfterLoad event.
ImGearThumbnailBeforeLoadEventHandler Delegate
Used for declaring ItemBeforeLoad event.
ImGearThumbnailItemEventHandler Delegate
Used for declaring ItemAfterCreate, ItemBeforeDelete, ItemClicked and ItemDoubleClicked events.


ImGearThumbnailAfterLoadEventHandler Delegate

32-bit
64-bit
CF
P
P
P

Description:

This delegate is used for declaring ItemAfterLoad event.

Declaration:

public delegate void ImGearThumbnailAfterLoadEventHandler(object sender,
ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailAfterLoadEventArgs e)

Parameters:

Name
Type
Description
sender
object
The source of the event.
e
ImGearThumbnailAfterLoadEventHandler Delegate
ImGearThumbnailAfterLoadEventArgs object that contains the event data.

Sample Code:

C#
ImGearThumbnailAfterLoadEventArgs afterLoadArgs =
    new ImGearThumbnailAfterLoadEventArgs(PageToAppend, false);
OnItemAfterLoad(this, afterLoadArgs);

VB .NET
Dim afterLoadArgs As ImGearThumbnailAfterLoadEventArgs
afterLoadArgs = New ImGearThumbnailAfterLoadEventArgs(PageToAppend, false)
OnItemAfterLoad(Me, afterLoadArgs)

See Also:

ItemAfterLoad Event

ImGearThumbnailAfterLoadEventHandler Delegate

AccuSoft Corporation
 AccuSoft.com
sales@accusoft.com


ImGearThumbnailBeforeLoadEventHandler Delegate

32-bit
64-bit
CF
P
P
P

Description:

This delegate is used for declaring ItemBeforeLoad event.

Declaration:

public delegate void ImGearThumbnailBeforeLoadEventHandler(object sender,
ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailBeforeLoadEventArgs e)

Parameters:

Name
Type
Description
sender
object
The source of the event.
e
ImGearThumbnailBeforeLoadEventHandler Delegate
ImGearThumbnailBeforeLoadEventArgs object that contains the event data.

Sample Code:

C#
ImGearThumbnailBeforeLoadEventArgs beforeLoadArgs =
    new ImGearThumbnailBeforeLoadEventArgs(source, PageToAppend, PageIndex, false);
OnItemBeforeLoad(this, beforeLoadArgs);

VB .NET
Dim beforeLoadArgs As ImGearThumbnailBeforeLoadEventArgs
beforeLoadArgs = New ImGearThumbnailBeforeLoadEventArgs(source, PageToAppend, PageIndex, false)
OnItemBeforeLoad(Me, beforeLoadArgs)

See Also:

ItemBeforeLoad Event

ImGearThumbnailBeforeLoadEventHandler Delegate

AccuSoft Corporation
 AccuSoft.com
sales@accusoft.com


ImGearThumbnailItemEventHandler Delegate

32-bit
64-bit
CF
P
P
P

Description:

This delegate is used for declaring ItemAfterCreate Event, ItemBeforeDelete Event, ItemClicked Event and ItemDoubleClicked Event.

Declaration:

public delegate void ImGearThumbnailItemEventHandler(object sender,
ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailItemEventArgs e)

Parameters:

Name
Type
Description
sender
object
The source of the event.
e
ImGearThumbnailItemEventArgs Class
ImGearThumbnailItemEventArgs object that contains the event data.

Sample Code:

C#
OnItemAfterCreate(this, new ImGearThumbnailItemEventArgs(item));

VB .NET
OnItemAfterCreate(Me, New ImGearThumbnailItemEventArgs(item))

See Also:

ItemAfterCreate Event

ItemBeforeDelete Event

ItemClicked Event

ItemDoubleClicked Event

ImGearThumbnailItemEventArgs Class


ImageGear.Windows.Forms.Thumbnail Enumerations

The ImageGear.Windows.Forms.Thumbnail Namespace has the following delegate members:

Classes:
Name
Description
ImGearDragDropOptions Enumeration
Specifies drag and drop actions are allowed in the thumbnail control.
ImGearSortOptions Enumeration
Specifies what sorting is used when a new item is added.


ImGearDragDropOptions Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies drag and drop actions are allowed in the thumbnail control.

Declaration:

public enum ImGearDragDropOptions

Values:

Name
Value
Description
Disable
No drag and drop actions are allowed.
Drag
Drag action is allowed.
DragDrop
Both drag and drop actions are allowed
Drop
Drop action is allowed.

See Also:

ImGearThumbnailCtl Class


ImGearSortOptions Enumeration

32-bit
64-bit
CF
P
P
P

Description:

This enumeration specifies what sorting is used when a new item is added.

Declaration:

public enum ImGearSortOptions

Values:

Name
Value
Description
NoSort
Unsorted mode.
TitleAscending
Title ascending sorting mode.
TitleDescending
Title descending sorting mode.
UserSort
User defined sorting mode.

See Also:

ImGearThumbnailCtl Class


ImageGear.WPF Namespace

ImageGear.WPF Namespace

32-bit
64-bit
CF
P
P

Description:

ImageGear.WPF namespace provides functionality for compatibility with the Windows Presentation Foundation framework, which is a new user interface subsystem and API based on XML and vector graphics available on Windows Vista. The following are the major parts of the ImageGear.WPF namespace:

  • WPF BitmapSource interface
  • HD Photo format support
  • The XAML configurable GUI controls
NOTE: This namespace requires the final released version of Windows Workflow Foundation Runtime Components, Microsoft Windows Vista, or the .NET Framework 3.0 Runtime Components.

Declaration:

namespace ImageGear.WPF

Members:

Classes:
Name
Description
ImGearBitmapSourceConverter Class
Provides static methods to convert between WPF BitmapSource and ImGearPage objects.
ImGearFilterAttribute Class
Used for filtering properties available in the PropertyGrid.
ImGearHDPhoto Class
Provides a method for initializing HD Photo format.
ImGearMagnifierCtl Class
Provides a magnified view of a portion of the image in ImGearPageView control.
ImGearMagnifierPopUpCtl Class
Contains magnified image.
ImGearPanCtl Class
Allows the visible portion of an image displayed in the ImGearPageView Class control to be moved by dragging the mouse around in the image.
ImGearThumbnailAfterLoadEventArgs Class
Specifies a list of arguments for ImGearThumbnailAfterLoadEventHandler delegate.
ImGearThumbnailBeforeLoadEventArgs Class
Specifies a list of arguments for ImGearThumbnailBeforeLoadEventHandler delegate.
ImGearThumbnailCtl Class
Works with thumbnail images displayed in the thumbnail browser window.
ImGearThumbnailItem Class
Represents one of the thumbnail items displayed on the thumbnail browser.
ImGearThumbnailItemEventArgs Class
Specifies a list of arguments for ImGearThumbnailItemEventHandler delegate.
ImGearThumbnailMagnifierCtl Class
Provides interaction logic for ThumbnailMagnifierCtl.xaml.

Delegates:
Name
Description
ImGearThumbnailAfterLoadEventHandler Delegate
Used for declaring ItemAfterLoad event.
ImGearThumbnailBeforeLoadEventHandler Delegate
Used for declaring ItemBeforeLoad event.
ImGearThumbnailItemEventHandler Delegate
Used for declaring ItemAfterCreate, ItemBeforeDelete, ItemClicked and ItemDoubleClicked events.

Enumerations:
Name
Description
ImGearMagnifierShapeType Enumeration
Specifies popup magnifier shape.


ImageGear.WPF Classes

The ImageGear.WPF Namespace has the following class members:

Classes:
Name
Description
ImGearBitmapSourceConverter Class
Provides static methods to convert between WPF BitmapSource and ImGearPage objects.
ImGearFilterAttribute Class
Used for filtering properties available in the PropertyGrid.
ImGearHDPhoto Class
Provides a method for initializing HD Photo format.
ImGearMagnifierCtl Class
Provides a magnified view of a portion of the image in ImGearPageView control.
ImGearMagnifierPopUpCtl Class
Contains magnified image.
ImGearPanCtl Class
Allows the visible portion of an image displayed in the ImGearPageView Class control to be moved by dragging the mouse around in the image.
ImGearThumbnailAfterLoadEventArgs Class
Specifies a list of arguments for ImGearThumbnailAfterLoadEventHandler delegate.
ImGearThumbnailBeforeLoadEventArgs Class
Specifies a list of arguments for ImGearThumbnailBeforeLoadEventHandler delegate.
ImGearThumbnailCtl Class
Works with thumbnail images displayed in the thumbnail browser window.
ImGearThumbnailItem Class
Represents one of the thumbnail items displayed on the thumbnail browser.
ImGearThumbnailItemEventArgs Class
Specifies a list of arguments for ImGearThumbnailItemEventHandler delegate.
ImGearThumbnailMagnifierCtl Class
Provides interaction logic for ThumbnailMagnifierCtl.xaml.


ImGearBitmapSourceConverter Class

32-bit
64-bit
CF
P
P

Description:

This class provides methods to convert between WPF BitmapSource and ImGearPage Class objects.

Declaration:

public class ImGearBitmapSourceConverter

Members:

Constructors
Name
Description
ImGearBitmapSourceConverter Constructor
Creates a new instance of ImGearBitmapSourceConverter object.

Methods
Name
Description
BitmapSourceFromBitmap Method
Converts System.Drawing.Bitmap to System.Windows.Media.Imaging.BitmapSource.
BitmapSourceFromImGearPage Method
Converts ImGearPage to System.Windows.Media.Imaging.BitmapSource.
ImGearPageFromBitmapSource Method
Converts System.Windows.Media.Imaging.BitmapSource to ImGearPage.
ThumbnailFromImGearPage Method
Produces new resized System.Windows.Media.Imaging.BitmapSource from the given ImGearPage.


ImGearBitmapSourceConverter Constructors

The ImGearBitmapSourceConverter Class of the ImageGear.WPF Namespace has the following constructors:

Constructors
Name
Description
ImGearBitmapSourceConverter Constructor
Creates a new instance of ImGearBitmapSourceConverter object.


ImGearBitmapSourceConverter Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates and initializes an instance of ImGearBitmapSourceConverter Class object.

Declaration:

public ImGearBitmapSourceConverter()

Parameters:

Name
Type
Description
Filter
string
The string.

Return Value:

New instance of ImGearBitmapSourceConverter Class object.

See Also:

ImGearBitmapSourceConverter Class


ImGearBitmapSourceConverter Methods

The ImGearBitmapSourceConverter Class of the ImageGear.WPF Namespace has the following methods:

Methods
Name
Description
BitmapSourceFromBitmap Method
Converts System.Drawing.Bitmap to System.Windows.Media.Imaging.BitmapSource.
BitmapSourceFromImGearPage Method
Converts ImGearPage to System.Windows.Media.Imaging.BitmapSource.
ImGearPageFromBitmapSource Method
Converts System.Windows.Media.Imaging.BitmapSource to ImGearPage.
ThumbnailFromImGearPage Method
Produces new resized System.Windows.Media.Imaging.BitmapSource from the given ImGearPage.


BitmapSourceFromBitmap Method

32-bit
64-bit
CF
P
P

Description:

This method converts System.Drawing.Bitmap to System.Windows.Media.Imaging.BitmapSource.

Declaration:

public System.Windows.Media.Imaging.BitmapSource
BitmapSourceFromBitmap(System.Drawing.Bitmap bitmap)

Parameters:

Name
Type
Description
bitmap
Bitmap
System.Drawing.Bitmap object to be converted.

Return Value:

System.Windows.Media.Imaging.BitmapSource object.

Sample Code:

C#
bitmapSource = ImGearBitmapSourceConverter.BitmapSourceFromBitmap(bitmap);

VB .NET
bitmapSource = ImGearBitmapSourceConverter.BitmapSourceFromBitmap(bitmap)


BitmapSourceFromImGearPage Method

32-bit
64-bit
CF
P
P

Description:

This method converts ImGearPage to System.Windows.Media.Imaging.BitmapSource.

Declaration:

public System.Windows.Media.Imaging.BitmapSource
BitmapSourceFromImGearPage(ImageGear.Core.ImGearPage page)

Parameters:

Name
Type
Description
page
ImGearPage Class
ImGearPage object to be converted.

Return Value:

System.Windows.Media.Imaging.BitmapSource object.

Sample Code:

C#
bitmapSource = ImGearBitmapSourceConverter.BitmapSourceFromImGearPage(page);

VB .NET
bitmapSource = ImGearBitmapSourceConverter.BitmapSourceFromImGearPage(page);

See Also:

ImGearPage Class

ImGearInterpolationOptions Class


ImGearPageFromBitmapSource Method

32-bit
64-bit
CF
P
P

Description:

This method converts System.Windows.Media.Imaging.BitmapSource to ImGearPage.

Declaration:

public ImageGear.Core.ImGearPage
ImGearPageFromBitmapSource(System.Windows.Media.Imaging.BitmapSource bitmapSource)

Parameters:

Name
Type
Description
BitmapSource
unknown-type
System.Windows.Media.Imaging.BitmapSource object to be converted.

Return Value:

ImGearPage Class object.

Sample Code:

C#
page = ImGearBitmapSourceConverter.ImGearPageFromBitmapSource(bitmapSource);

VB .NET
page = ImGearBitmapSourceConverter.ImGearPageFromBitmapSource(bitmapSource)

See Also:

ImGearPage Class


ThumbnailFromImGearPage Method

32-bit
64-bit
CF
P
P

Description:

This method produces new resized System.Windows.Media.Imaging.BitmapSource from the given ImGearPage.

Declaration:

public System.Windows.Media.Imaging.BitmapSource
ThumbnailFromImGearPage(ImageGear.Core.ImGearPage page, int thumbnailWidth, int
thumbnailHeight, System.Windows.Media.Color color, int ppmX, int ppmY,
ImageGear.Processing.ImGearInterpolationOptions interpolation)

Parameters:

Name
Type
Description
page
ImGearPage Class
ImGearPage object to be converted.
thumbnailWidth
int
Maximum thumbnail width.
thumbnailHeight
int
Maximum thumbnail height.
color
Color
Background color for thumbnail.
ppmX
int
Horizontal image resolution used for conversion.
ppmY
int
Vertical image resolution used for conversion.
interpolation
ImGearInterpolationOptions Class
Interpolation options used for conversion.

Return Value:

System.Windows.Media.Imaging.BitmapSource object.

Sample Code:

C#
bitmapSource = ImGearBitmapSourceConverter.BitmapSourceFromImGearPage(page, width, height, color, ppmX, ppmY, interpolation);

VB .NET
bitmapSource = ImGearBitmapSourceConverter.BitmapSourceFromImGearPage(page, width, height, color, ppmX, ppmY, interpolation)

See Also:

ImGearPage Class

ImGearInterpolationOptions Class


ImGearFilterAttribute Class

32-bit
64-bit
CF
P
P

Description:

This class used for filtering properties available in the PropertyGrid.

Declaration:

public class ImGearFilterAttribute : System.Attribute

Members:

Constructors
Name
Description
ImGearFilterAttribute Constructor
Creates and initializes an instance of ImGearFilterAttribute class.


ImGearFilterAttribute Constructors

The ImGearFilterAttribute Class of the ImageGear.WPF Namespace has the following constructors:

Constructors
Name
Description
ImGearFilterAttribute Constructor
Creates and initializes an instance of ImGearFilterAttribute class.


ImGearFilterAttribute Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates and initializes an instance of ImGearFilterAttribute Class.

Declaration:

public ImGearFilterAttribute(string Filter)

Parameters:

Name
Type
Description
Filter
string
The string.

Return Value:

New instance of ImGearFilterAttribute Class.

See Also:

ImGearFilterAttribute Class


ImGearHDPhoto Class

32-bit
64-bit
CF
P
P

Description:

This class provides a method for initializing HD Photo format.

NOTE: HD Photo format when registered should be inserted before TIFF format because TIFF 2-bytes signature is a part of HD Photo format signature. See CreateHDPhotoFormat Method for details.

Declaration:

public sealed class ImGearHDPhoto

Members:

Method
Name
Description
CreateHDPhotoFormat Method
Creates an instance of HP Photo format that can be added to the collection of registered formats.


ImGearHDPhoto Methods

The ImGearHDPhoto Class of the ImageGear.WPF Namespace has the following methods:

Methods
Name
Description
CreateHDPhotoFormat Method
Creates an instance of HP Photo format that can be added to the collection of registered formats.


CreateHDPhotoFormat Method

32-bit
64-bit
CF
P
P

Description:

This method creates an instance of HP Photo format that can be added to the collection of registered formats.

NOTE: HD Photo format when registered should be inserted before TIFF format because TIFF 2-bytes signature is a part of HD Photo format signature.

Declaration:

public static ImageGear.Formats.IImGearFormat CreateHDPhotoFormat()

Return Value:

ImageGear.Formats. IImGearFormat Interface object.

Sample Code:

C#
// HD Photo format should be inserted before TIFF format
// (TIFF 2-byte signature is a part of WPD signature).
ImGearFileFormats.Filters.Insert(0, ImGearHDPhoto.CreateHDPhotoFormat());

VB .NET
` HD Photo format should be inserted before TIFF format
` (TIFF 2-byte signature is a part of WPD signature).
ImGearFileFormats.Filters.Insert(0, ImGearHDPhoto.CreateHDPhotoFormat())

See Also:

ImGearHDPhoto Class

IImGearFormat Interface


ImGearMagnifierCtl Class

32-bit
64-bit
CF
P
P

Description:

This is the GUI Magnifier control class which provides a magnified view of a portion of the image in ImGearPageView control. It appears either in a separate, stationary window, or as a popup area within the ImGearPageView window. When the GUI Magnifier control is active, and the user drags the mouse within the ImGearPageView control, the magnified display of the image tracks the location of the mouse. If the popup view is used, the magnified display of the image tracks the mouse within the ImGearPageView control. If the separate, stationary window is used, the area of the image that is displayed in the floating window is displayed in reverse video in the ImGearPageView control. The programmer can set the magnification factor, and can optionally expose that capability to the end user.

Declaration:

public class ImGearMagnifierCtl : System.Windows.Controls.Control

Members:

Constructors
Name
Description
ImGearMagnifierCtl Constructor
Creates and initializes an instance of ImGearMagnifierCtl Class.

Properties
Name
Description
BorderWidth Property
Specifies width of the popup window border.
DestinationView Property
Specifies ImGearPageView object used for displaying the magnified area.
IsPopUp Property
If this property is true, magnifier window shows right under mouse pointer.
MagnifiedImage Property
Specifies the magnified area.
PopupHeight Property
Specifies height of the popup magnifier window.
PopupWidth Property
Specifies width of the popup magnifier window.
ShapeType Property
Specifies shape of the popup magnifier window.
SourceView Property
Specifies ImGearPageView object to be magnified.
SourceViewHost Property
Specifies UIElement that hosts SourceView ImGearPageView object to be magnified.
Zoom Property
Specifies zoom factor.


ImGearMagnifierCtl Constructors

The ImGearMagnifierCtl Class of the ImageGear.WPF Namespace has the following constructors:

Constructors
Name
Description
ImGearMagnifierCtl Constructor
Creates and initializes an instance of ImGearMagnifierCtl Class.


ImGearMagnifierCtl Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates and initializes an instance of ImGearMagnifierCtl Class.

Declaration:

public ImGearMagnifierCtl()

Return Value:

New instance of ImGearMagnifierCtl Class.

Sample Code:

C#
internal ImageGear.Windows.Forms.ImGearMagnifier magnifier1;
this.magnifier1 = new ImageGear.Windows.Forms.ImGearMagnifier(Me.components);

VB .NET
Private magnifier1 As ImageGear.Windows.Forms.ImGearMagnifier
Me.magnifier1 = New ImageGear.Windows.Forms.ImGearMagnifier(Me.components)

See Also:

ImGearMagnifierCtl Class


ImGearMagnifierCtl Properties

The ImGearMagnifierCtl Class of the ImageGear.WPF Namespace has the following properties:

Properties
Name
Description
BorderWidth Property
Specifies width of the popup window border.
DestinationView Property
Specifies ImGearPageView object used for displaying the magnified area.
IsPopUp Property
If this property is true, magnifier window shows right under mouse pointer.
MagnifiedImage Property
Specifies the magnified area.
PopupHeight Property
Specifies height of the popup magnifier window.
PopupWidth Property
Specifies width of the popup magnifier window.
ShapeType Property
Specifies shape of the popup magnifier window.
SourceView Property
Specifies ImGearPageView object to be magnified.
SourceViewHost Property
Specifies UIElement that hosts SourceView ImGearPageView object to be magnified.
Zoom Property
Specifies zoom factor.


BorderWidth Property

32-bit
64-bit
CF
P
P

Description:

This property specifies width of the popup window border.

Declaration:

public double BorderWidth { get;  set; }

Value:

Double value.

Sample Code:

C#
this.magnifier1.BorderWidth = 2;

VB .NET
Me.magnifier1. BorderWidth = 2


DestinationView Property

32-bit
64-bit
CF
P
P

Description:

This property specifies ImGearPageView object used for displaying the magnified area. If IsPopUp is true, DestinationView could be empty.

Declaration:

public ImageGear.Windows.Forms.ImGearPageView DestinationView { get;  set; }

Value:

ImGearPageView Class.

Sample Code:

C#
this.magnifier1.DestinationView = this.imGearPageView;

VB .NET
Me.magnifier1.DestinationView = Me.ImGearPageView1

See Also:

IsPopUp Property.

ImGearPageView Class


IsPopUp Property

32-bit
64-bit
CF
P
P

Description:

If this property is true, magnifier window shows right under mouse pointer, otherwise magnified area sends into DestinationView. Default value is true.

Declaration:

public bool IsPopUp { get;  set; }

Value:

true, false.

Sample Code:

C#
this.magnifier1.IsPopUp = false;

VB .NET
Me.magnifier1.IsPopUp = False

See Also:

DestinationView Property.


MagnifiedImage Property

32-bit
64-bit
CF
P
P

Description:

This property specifies the magnified area.

Declaration:

public System.Windows.Media.Imaging.BitmapSource MagnifiedImage { get;  set; }

Value:

System.Windows.Media.Imaging.BitmapSource object.

Sample Code:

C#
bitmapSource = this.magnifier1.MagnifiedImage;

VB .NET
bitmapSource = Me.magnifier1.MagnifiedImage


PopupHeight Property

32-bit
64-bit
CF
P
P

Description:

This property specifies height of the popup magnifier window.

Declaration:

public int PopupHeight { get;  set; }

Value:

Integer value.

Sample Code:

C#
this.magnifier1.PopupHeight = 200;

VB .NET
Me.magnifier1.PopupHeight = 200

See Also:

PopupWidth Property.


PopupWidth Property

32-bit
64-bit
CF
P
P

Description:

This property specifies width of the popup magnifier window.

Declaration:

public int PopupWidth { get;  set; }

Value:

Integer value.

Sample Code:

C#
this.magnifier1.PopupWidth = 200;

VB .NET
Me.magnifier1.PopupWidth = 200

See Also:

PopupHeight Property


ShapeType Property

32-bit
64-bit
CF
P
P

Description:

This property specifies shape of the popup magnifier window. It can be either rectangle or ellipse. Default value is rectangle.

Declaration:

public ImageGear.WPF.ImGearMagnifierShapeType ShapeType { get;  set; }

Value:

ImGearMagnifierShapeType Enumeration value.

Sample Code:

C#
this.magnifier1.ShapeType = ImageGear.Windows.Forms.ImGearMagnifierShapeType.Ellipse;

VB .NET
Me.magnifier1.ShapeType = ImGearMagnifierShapeType.Ellipse

See Also:

ImGearMagnifierShapeType Enumeration


SourceView Property

32-bit
64-bit
CF
P
P

Description:

This property specifies ImGearPageView object to be magnified.

Declaration:

public ImageGear.Windows.Forms.ImGearPageView SourceView { get;  set; }

Value:

ImGearPageView Class class.

Sample Code:

C#
this.magnifier1.SourceView = this.imGearPageView;

VB .NET
Me.magnifier1.SourceView = Me.ImGearPageView1

See Also:

ImGearPageView Class


SourceViewHost Property

32-bit
64-bit
CF
P
P

Description:

This property specifies UIElement that hosts SourceView ImGearPageView object to be magnified. It is required to create popup window.

Declaration:

public System.Windows.UIElement SourceViewHost { set; get; }

Value:

System.Windows.UIElement object.

Sample Code:

C#
uiElement = this.magnifier1.SourceViewHost;

VB .NET
uiElement = Me.magnifier1.SourceViewHost


Zoom Property

32-bit
64-bit
CF
P
P

Description:

This property specifies zoom factor.

Declaration:

public double Zoom { get;  set; }

Value:

Double value.

Sample Code:

C#
this.magnifier1.Zoom = 3F;

VB .NET
Me.magnifier1.Zoom = 3


ImGearMagnifierPopUpCtl Class

32-bit
64-bit
CF
P
P

Description:

This is the Magnifier control that contains magnified image.

Declaration:

public class ImGearMagnifierPopUpCtl : System.Windows.Controls.Control

Members:

Constructors
Name
Description
ImGearMagnifierPopUpCtl Constructor
Creates and initializes an instance of ImGearMagnifierPopUpCtl Class.

Properties
Name
Description
Center Property
Specifies popup center point.
ImageRadius Property
Specifies horizontal and vertical radius of the ellipse.
ParentCtl Property
Specifies a reference to ImGearMagnifierCtl that contains magnifier parameters.


ImGearMagnifierPopUpCtl Constructors

The ImGearMagnifierPopUpCtl Class of the ImageGear.WPF Namespace has the following constructors:

Constructors
Name
Description
ImGearMagnifierPopUpCtl Constructor
Creates and initializes an instance of ImGearMagnifierPopUpCtl Class.


ImGearMagnifierPopUpCtl Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates and initializes an instance of ImGearMagnifierPopUpCtl Class.

Declaration:

public ImGearMagnifierPopUpCtl(ImageGear.WPF.ImGearMagnifierCtl parent)

Parameters:

Name
Type
Description
parent
ImGearMagnifierCtl Class
Reference to ImGearMagnifierCtl that contains magnifier parameters

Return Value:

New instance of ImGearMagnifierPopUpCtl Class.

Sample Code:

C#
_control = new ImGearMagnifierPopUpCtl(parent);

VB .NET
_control = new ImGearMagnifierPopUpCtl(parent)

See Also:

ImGearMagnifierCtl Class


ImGearMagnifierPopUpCtl Properties

The ImGearMagnifierPopUpCtl Class of the ImageGear.WPF Namespace has the following properties:

Properties
Name
Description
Center Property
Specifies popup center point.
ImageRadius Property
Specifies horizontal and vertical radius of the ellipse.
ParentCtl Property
Specifies a reference to ImGearMagnifierCtl that contains magnifier parameters.


Center Property

32-bit
64-bit
CF
P
P

Description:

This property specifies popup center point. It is required to build geometric path in XAML file.

Declaration:

public System.Windows.Point Center { get; }

Value:

System.Windows.Point value.

Sample Code:

C#
centerPoint = _control.Center;

VB .NET
centerPoint = _control.Center


ImageRadius Property

32-bit
64-bit
CF
P
P

Description:

This property specifies horizontal and vertical radius of the ellipse. It is required to build geometric path in XAML file.

Declaration:

public System.Windows.Size ImageRadius { get; }

Value:

System.Windows.Size value.

Sample Code:

C#
radius = _control.ImageRadius;

VB .NET
radius = _control.ImageRadius


ParentCtl Property

32-bit
64-bit
CF
P
P

Description:

This property specifies a reference to ImGearMagnifierCtl that contains magnifier parameters.

Declaration:

public ImageGear.WPF.ImGearMagnifierCtl ParentCtl { get; }

Value:

ImGearMagnifierCtl Class object.

Sample Code:

C#
magnifierCtl = _control.ParentCtl;

VB .NET
magnifierCtl = _control.ParentCtl

See Also:

ImGearMagnifierCtl Class


ImGearPanCtl Class

32-bit
64-bit
CF
P
P

Description:

This is the GUI Pan control class that allows the visible portion of an image displayed in the ImGearPageView Class control to be moved by dragging the mouse around in the image. Optionally, a floating window can be used to display the complete image, scaled to fit within the floating window. By dragging the mouse within this floating window, the image in the ImGearPageView Class control is repositioned. The portion of the image that is visible in the ImGearPageView Class control is displayed within the floating window in reverse video.

Declaration:

public class ImGearPanCtl : System.Windows.Controls.Control

Members:

Constructors
Name
Description
ImGearPanCtl Constructor
Creates and initializes an instance of ImGearPanCtl class.

Properties
Name
Description
Cursor Property
Specifies cursor used while panning the page area.
DestinationView Property
Specifies ImGearPageView Class object used for displaying the panning area.
PanButton Property
Specifies the mouse button used for panning.
SourceView Property
Specifies ImGearPageView Class object to apply panning functionality to.


ImGearPanCtl Constructors

The ImGearPanCtl Class of the ImageGear.WPF Namespace has the following constructors:

Constructors
Name
Description
ImGearPanCtl Constructor
Creates and initializes an instance of ImGearPanCtl class.


ImGearPanCtl Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates and initializes an instance of ImGearPanCtl Class.

Declaration:

public ImGearPanCtl()

Return Value:

New instance of ImGearPanCtl Class object


ImGearPanCtl Properties

The ImGearPanCtl Class of the ImageGear.WPF Namespace has the following properties:

Properties
Name
Description
Cursor Property
Specifies cursor used while panning the page area.
DestinationView Property
Specifies ImGearPageView Class object used for displaying the panning area.
PanButton Property
Specifies the mouse button used for panning.
SourceView Property
Specifies ImGearPageView Class object to apply panning functionality to.


Cursor Property

32-bit
64-bit
CF
P
P

Description:

This property specifies cursor used while panning page area.

Declaration:

public System.Windows.Forms.Cursor Cursor { set; get; }

Value:

System.Windows.Forms.Cursor value

See Also:

ImGearPanCtl Class


DestinationView Property

32-bit
64-bit
CF
P
P

Description:

This property specifies the ImGearPageView Class object used for displaying the panning area.

Declaration:

public ImageGear.Windows.Forms.ImGearPageView DestinationView { set; get; }

Value:

ImGearPageView Class

See Also:

ImGearPanCtl Class


PanButton Property

32-bit
64-bit
CF
P
P

Description:

This property specifies the mouse button used for panning. Default value is MouseButtons.Left.

Declaration:

public System.Windows.Forms.MouseButtons PanButton { set; get; }

Value:

System.Windows.Forms.MouseButtons

See Also:

ImGearPanCtl Class


SourceView Property

32-bit
64-bit
CF
P
P

Description:

This property specifies ImGearPageView Class object to apply panning functionality to.

Declaration:

public ImageGear.Windows.Forms.ImGearPageView SourceView { set; get; }

Value:

ImGearPageView Class

See Also:

ImGearPanCtl Class


ImGearThumbnailAfterLoadEventArgs Class

32-bit
64-bit
CF
P
P

Description:

This class specifies a list of arguments for ImGearThumbnailAfterLoadEventHandler delegate.

Declaration:

public class ImGearThumbnailAfterLoadEventArgs : System.Windows.RoutedEventArgs

Members:

Constructors
Name
Description
ImGearMagnifierPopUpCtl Constructor
Creates and initializes an instance of ImGearThumbnailAfterLoadEventArgs Class.

Properties
Name
Description
Page Property
Specifies ImGearPage object containing full-sized picture that was used to create a thumbnail.
Skip Property
Specifies a flag indicating whether or not to load thumbnail into a control.

See Also:

ImGearThumbnailAfterLoadEventHandler Delegate


ImGearThumbnailAfterLoadEventArgs Constructors

The ImGearThumbnailAfterLoadEventArgs Class of the ImageGear.WPF Namespace has the following constructors:

Constructors
Name
Description
ImGearMagnifierPopUpCtl Constructor
Creates and initializes an instance of ImGearThumbnailAfterLoadEventArgs Class.


ImGearThumbnailAfterLoadEventArgs Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates and initializes an instance of ImGearThumbnailAfterLoadEventArgs Class.

Declaration:

public ImGearThumbnailAfterLoadEventArgs(System.Windows.RoutedEvent evt,
ImageGear.Core.ImGearPage page, bool skip)

Parameters:

Name
Type
Description
evt
System.Windows.RoutedEvent
Reference to event object.
page
ImGearPage Class
ImGearPage object containing full-sized picture that was used to create a thumbnail.
skip
bool
Flag indicating whether or not to load thumbnail into a control.

Return Value:

New instance of ImGearThumbnailAfterLoadEventArgs Class.

Sample Code:

C#
ImGearThumbnailAfterLoadEventArgs afterLoadArgs =
new ImGearThumbnailAfterLoadEventArgs( ImGearThumbnailCtl.ItemAfterLoadEvent, PageToAppend, false);

VB .NET
Dim afterLoadArgs As ImGearThumbnailAfterLoadEventArgs
afterLoadArgs = New ImGearThumbnailAfterLoadEventArgs(ImGearThumbnailCtl.ItemAfterLoadEvent, PageToAppend, false)

See Also:

ImGearThumbnailAfterLoadEventArgs Class

ImGearPage Class


ImGearThumbnailAfterLoadEventArgs Properties

The ImGearThumbnailAfterLoadEventArgs Class of the ImageGear.WPF Namespace has the following properties:

Properties
Name
Description
Page Property
Specifies ImGearPage object containing full-sized picture that was used to create a thumbnail.
Skip Property
Specifies a flag indicating whether or not to load thumbnail into a control.


Page Property

32-bit
64-bit
CF
P
P

Description:

This property specifies ImGearPage object containing full-sized picture that was used to create a thumbnail.

Declaration:

public ImageGear.Core.ImGearPage Page { get; }

Value:

ImGearPage Class

Sample Code:

C#
ImGearPage page = afterLoadArgs.Page;

VB .NET
Dim page As ImGearPage
page = afterLoadArgs.Page

See Also:

ImGearPage Class


Skip Property

32-bit
64-bit
CF
P
P

Description:

This property specifies a flag indicating whether or not to load thumbnail into a control. Client should set this to true if there is no need to load thumbnail into a control.

Declaration:

public bool Skip { get;  set; }

Value:

true/false.

Sample Code:

C#
afterLoadArgs.Skip = true;

VB .NET
afterLoadArgs.Skip = true


ImGearThumbnailBeforeLoadEventArgs Class

32-bit
64-bit
CF
P
P

Description:

This class specifies a list of arguments for ImGearThumbnailBeforeLoadEventHandler delegate.

Declaration:

public class ImGearThumbnailBeforeLoadEventArgs : System.Windows.RoutedEventArgs

Members:

Constructors
Name
Description
ImGearThumbnailBeforeLoadEventArgs Constructor
Creates and initializes an instance of ImGearThumbnailBeforeLoadEventArgs Class.

Properties
Name
Description
Page Property
Specifies ImGearPage object containing full-sized picture that was used to create a thumbnail.
PageNumber Property
Specifies page number of the currently loaded thumbnail.
Skip Property
Specifies a flag indicating whether or not to load thumbnail into a control.
ThumbnailSource Property
Specifies path and format of the currently loaded thumbnail.

See Also:

ImGearThumbnailBeforeLoadEventHandler Delegate.


ImGearThumbnailBeforeLoadEventArgs Constructors

The ImGearThumbnailBeforeLoadEventArgs Class of the ImageGear.WPF Namespace has the following constructors:

Constructors
Name
Description
ImGearThumbnailBeforeLoadEventArgs Constructor
Creates and initializes an instance of ImGearThumbnailBeforeLoadEventArgs Class.


ImGearThumbnailBeforeLoadEventArgs Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates and initializes an instance of ImGearThumbnailBeforeLoadEventArgs Class.

Declaration:

public ImGearThumbnailBeforeLoadEventArgs(System.Windows.RoutedEvent evt,
ImageGear.Windows.Forms.ImGearLoadingSelection source, ImageGear.Core.ImGearPage page,
int pageNumber, bool skip)

Parameters:

Name
Type
Description
evt
System.Windows.RoutedEvent
Reference to event object.
source
ImGearLoadingSelection Class
Path and format of the currently loaded thumbnail.
page
ImGearPage Class
ImGearPage object containing full-sized picture that was used to create a thumbnail.
pageNumber
int
Page number of the currently loaded thumbnail.
skip
bool
Flag indicating whether or not to load thumbnail into a control.

Return Value:

New instance of ImGearThumbnailBeforeLoadEventArgs Class.

Sample Code:

C#
ImGearThumbnailBeforeLoadEventArgs beforeLoadArgs =
new ImGearThumbnailBeforeLoadEventArgs( ImGearThumbnailCtl.ItemBeforeLoadEvent, source, PageToAppend, PageIndex, false);

VB .NET
Dim beforeLoadArgs As ImGearThumbnailBeforeLoadEventArgs
beforeLoadArgs = New ImGearThumbnailBeforeLoadEventArgs(ImGearThumbnailCtl.ItemBeforeLoadEvent, source, PageToAppend, PageIndex,
false)

See Also:

ImGearThumbnailBeforeLoadEventArgs Class

ImGearPage Class

ImGearLoadingSelection Class


ImGearThumbnailBeforeLoadEventArgs Properties

The ImGearThumbnailBeforeLoadEventArgs Class of the ImageGear.WPF Namespace has the following properties:

Properties
Name
Description
Page Property
Specifies ImGearPage object containing full-sized picture that was used to create a thumbnail.
PageNumber Property
Specifies page number of the currently loaded thumbnail.
Skip Property
Specifies a flag indicating whether or not to load thumbnail into a control.
ThumbnailSource Property
Specifies path and format of the currently loaded thumbnail.


Page Property

32-bit
64-bit
CF
P
P

Description:

This property specifies ImGearPage object containing full-sized picture that was used to create a thumbnail.

Declaration:

public ImageGear.Core.ImGearPage Page { get; }

Value:

ImGearPage Class.

Sample Code:

C#
ImGearPage page = beforeLoadArgs.Page;

VB .NET
Dim page As ImGearPage
page = beforeLoadArgs.Page

See Also:

ImGearPage Class


PageNumber Property

32-bit
64-bit
CF
P
P

Description:

This property specifies page number of the currently loaded thumbnail.

Declaration:

public int PageNumber { get; }

Value:

Integer value.

Sample Code:

C#
int pageNum = beforeLoadArgs.PageNumber;

VB .NET
Dim pageNum As Integer
pageNum = beforeLoadArgs.PageNumber


Skip Property

32-bit
64-bit
CF
P
P

Description:

This property specifies a flag indicating whether or not to load thumbnail into a control. Client should set this to true if there is no need to load thumbnail into a control.

Declaration:

public bool Skip { get;  set; }

Value:

true/false.

Sample Code:

C#
beforeLoadArgs.Skip = true;

VB .NET
beforeLoadArgs.Skip = true


ThumbnailSource Property

32-bit
64-bit
CF
P
P

Description:

This property specifies path and format of the currently loaded thumbnail.

Declaration:

public ImageGear.Windows.Forms.ImGearLoadingSelection ThumbnailSource { get; }

Value:

ImGearLoadingSelection Class.

Sample Code:

C#
ImGearLoadingSelection source = beforeLoadArgs.ThumbnailSource;

VB .NET
Dim source As ImGearLoadingSelection
source = beforeLoadArgs.ThumbnailSource

See Also:

ImGearLoadingSelection Class


ImGearThumbnailCtl Class

32-bit
64-bit
CF
P
P

Description:

This is the GUI Thumbnail control that works with thumbnail images displayed in the thumbnail browser window. Every thumbnail is associated with the ImGearThumbnailItem object containing full Information about the image. The collection of ImGearThumbnailItem objects is implemented within the Thumbnail control.

Declaration:

public class ImGearThumbnailCtl : System.Windows.Controls.Control

Members:

Constructors
Name
Description
ImGearThumbnailCtl Constructor
Creates and initializes an instance of ImGearThumbnailCtl Class.

Properties
Name
Description
AllPages Property
Controls whether all pages of a multi-page image will be loaded into thumbnails.
AutoFocus Property
Allows setting focus mode for the Thumbnail control.
BorderWidth Property
Specifies border width in pixels around the thumbnail.
CellSize Property
Specifies full thumbnail item size, including size of item itself and spacing.
Count Property
Specifies the number of items within the Thumbnail control.
DragDropOptions Property
Specifies whether the thumbnail browser can be a Drag source, Drop target or both.
HighlightBackColor Property
Specifies the color to use.
HighlightForeColor Property
Specifies the color to use.
ImageSize Property
Specifies thumbnail image size.
Interior Property
Specifies the amount of extra space.
ItemHeight Property
Specifies item height in pixels of the image to be drawn in each thumbnail item.
ItemWidth Property
Specifies item width in pixels of the image to be drawn in each thumbnail item.
Margin Property
Specifies the amount of extra space, in pixels, to leave between the left edge of the control and the left-most item drawn inside the control.
SelectionBackColor Property
Default background color for selected items.
SelectionForeColor Property
Default foreground color for selected items.
SelectionMode Property
Specifies items selection mode.
ShadowsVisibility Property
Specifies items shadow visibility.
ShadowWidth Property
Specifies width of item's shadow.
ShowMagnify Property
Enables/disables a larger popup image for the thumbnail by pressing the right-mouse-button down
Sort Property
Specifies what sorting (none, title ascending, title descending, user-defined) is used when a new item is added.
SortComparer Property
Used when Sort property is set to "UserSort".
Thumbnails Property
Specifies all items as collection.
TitlesVisibility Property
Specifies thumbnails title visibility.
VerticalScrollBarVisibility Property
Specifies if vertical scrollbar should appear when all items do not fit in the control.
XSpacing Property
Specifies the amount of horizontal space between thumbnails displayed on the control, in pixels.
YSpacing Property
Specifies the amount of vertical space between thumbnails displayed on the control, in pixels.
ZoomFactor Property
Specifies the amount of zoom-in to use when displaying the magnified popup image.

Methods
Name
Description
DeleteAllItems Method
Removes all the items from the Thumbnail control.
DeleteItem Method
Removes specified item from the Thumbnail control.
DirectoryAppend Method
Creates a series of thumbnail items.
DocumentAppend Method
Appends ImGearDocument Class object to the Thumbnail control.
FileAppend Method
Appends a file specified by selection to the Thumbnail control.
PageAppend Method
Appends ImGearPage object to the Thumbnail control.
ReloadAll Method
Reloads all thumbnails in the Thumbnail control.
ReloadItem Method
Reloads thumbnail picture in the specified thumbnail item.

Events
Name
Description
ItemAfterCreate Event
This event is called after a new thumbnail item is added to the Thumbnail control.
ItemAfterLoad Event
This event is called during the process of creating a thumbnail item.
ItemBeforeDelete Event
This event is called as each thumbnail item is removed from the control, before the item is removed from the items collection.
ItemBeforeLoad Event
This event is called during the process of creating a thumbnail item.
ItemClicked Event
This event is called to indicate that the user clicked somewhere within the thumbnail control.
ItemDoubleClicked Event
This event is called to indicate that the user double-clicked somewhere within the thumbnail control.


ImGearThumbnailCtl Constructors

The ImGearThumbnailCtl Class of the ImageGear.WPF Namespace has the following constructors:

Constructors
Name
Description
ImGearThumbnailCtl Constructor
Creates and initializes an instance of ImGearThumbnailCtl Class.


ImGearThumbnailCtl Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates and initializes an instance of ImGearThumbnailCtl Class.

Declaration:

public ImGearThumbnailCtl()

Return Value:

New instance of ImGearThumbnailCtl Class.

Sample Code:

C#
this.thumbnailCtl1 = new ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailCtl();

VB .NET
Me.thumbnailCtl1 = New ImageGear.Windows.Forms.Thumbnails.ImGearThumbnailCtl()

See Also:

ImGearThumbnailCtl Class


ImGearThumbnailCtl Properties

The ImGearThumbnailCtl Class of the ImageGear.WPF Namespace has the following properties:

Properties
Name
Description
AllPages Property
Controls whether all pages of a multi-page image will be loaded into thumbnails.
AutoFocus Property
Allows setting focus mode for the Thumbnail control.
BorderWidth Property
Specifies border width in pixels around the thumbnail.
CellSize Property
Specifies full thumbnail item size, including size of item itself and spacing.
Count Property
Specifies the number of items within the Thumbnail control.
DragDropOptions Property
Specifies whether the thumbnail browser can be a Drag source, Drop target or both.
HighlightBackColor Property
Specifies the color to use.
HighlightForeColor Property
Specifies the color to use.
ImageSize Property
Specifies thumbnail image size.
Interior Property
Specifies the amount of extra space.
ItemHeight Property
Specifies item height in pixels of the image to be drawn in each thumbnail item.
ItemWidth Property
Specifies item width in pixels of the image to be drawn in each thumbnail item.
Margin Property
Specifies the amount of extra space, in pixels, to leave between the left edge of the control and the left-most item drawn inside the control.
SelectionBackColor Property
Default background color for selected items.
SelectionForeColor Property
Default foreground color for selected items.
SelectionMode Property
Specifies items selection mode.
ShadowsVisibility Property
Specifies items shadow visibility.
ShadowWidth Property
Specifies width of item's shadow.
ShowMagnify Property
Enables/disables a larger popup image for the thumbnail by pressing the right-mouse-button down
Sort Property
Specifies what sorting (none, title ascending, title descending, user-defined) is used when a new item is added.
SortComparer Property
Used when Sort property is set to "UserSort".
Thumbnails Property
Specifies all items as collection.
TitlesVisibility Property
Specifies thumbnails title visibility.
VerticalScrollBarVisibility Property
Specifies if vertical scrollbar should appear when all items do not fit in the control.
XSpacing Property
Specifies the amount of horizontal space between thumbnails displayed on the control, in pixels.
YSpacing Property
Specifies the amount of vertical space between thumbnails displayed on the control, in pixels.
ZoomFactor Property
Specifies the amount of zoom-in to use when displaying the magnified popup image.


AllPages Property

32-bit
64-bit
CF
P
P

Description:

This property controls whether all pages of a multi-page image (e.g., a multi-frame GIF or TIFF file) will be loaded into thumbnails, or whether only the first page will be loaded.

Declaration:

public bool AllPages { get;  set; }

Value:

true/false.

Sample Code:

C#
thumbnailCtl1.AllPages = false;

VB .NET
thumbnailCtl1.AllPages = False


AutoFocus Property

32-bit
64-bit
CF
P
P

Description:

This property allows setting focus mode for the Thumbnail control. If it is set to true, then the thumbnail browser gets focus when the mouse cursor is on the window. Otherwise mouse click is required.

Declaration:

public bool AutoFocus { get;  set; }

Value:

true/false.

Sample Code:

C#
thumbnailCtl1.AutoFocus = false;

VB .NET
thumbnailCtl1.AutoFocus = False


BorderWidth Property

32-bit
64-bit
CF
P
P

Description:

This property specifies border width in pixels around the thumbnail.

Declaration:

public int BorderWidth { get;  set; }

Value:

Integer value.

Sample Code:

C#
thumbnailCtl1.BorderWidth = 1;

VB .NET
thumbnailCtl1.BorderWidth = 1


CellSize Property

32-bit
64-bit
CF
P
P

Description:

This property specifies full thumbnail item size, including size of item itself and spacing. It is used in XAML.

Declaration:

public System.Windows.Size CellSize { get; }

Value:

System.Windows.Size value.

Sample Code:

C#
size = thumbnailCtl1.CellSize;

VB .NET
size = thumbnailCtl1.CellSize


Count Property

32-bit
64-bit
CF
P
P

Description:

This property specifies the number of items within the Thumbnail control, and thus also the number of ImGearThumbnailItem objects available for Item method.

Declaration:

public int Count { get; }

Value:

Integer value.

Sample Code:

C#
if (thumbnailCtl1.Count > 0)
{
...
}

VB .NET
if thumbnailCtl1.Count > 0 Then
...
EndIf


DragDropOptions Property

32-bit
64-bit
CF
P
P

Description:

This property specifies whether the thumbnail browser can be a Drag source, Drop target or both.

Declaration:

public ImageGear.Windows.Forms.Thumbnails.ImGearDragDropOptions DragDropOptions { get;
set; }

Value:

ImGearDragDropOptions Enumeration value.

Sample Code:

C#
thumbnailCtl1.DragDropOptions = ImGearDragDropOptions.DragDrop;

VB .NET
thumbnailCtl1.DragDropOptions = ImGearDragDropOptions.DragDrop

See Also:

ImGearDragDropOptions Enumeration


HighlightBackColor Property

32-bit
64-bit
CF
P
P

Description:

The titles of some thumbnail items can be shown with a different text background color (whenever Highlighted = true). This property specifies the color to use.

Declaration:

public System.Drawing.Color HighlightBackColor { set; get; }

Value:

System.Drawing.Color value.

Sample Code:

C#
thumbnailCtl1.HighlightBackColor = hbColor;

VB .NET
thumbnailCtl1.HighlightBackColor = hbColor


HighlightForeColor Property

32-bit
64-bit
CF
P
P

Description:

The titles of some thumbnail items can be shown with a different text color (whenever Highlighted = true). This property specifies the color to use.

Declaration:

public System.Drawing.Color HighlightForeColor { set; get; }

Value:

System.Drawing.Color value.

Sample Code:

C#
thumbnailCtl1.HighlightForeColor = hfColor;

VB .NET
thumbnailCtl1.HighlightForeColor = hfColor


ImageSize Property

32-bit
64-bit
CF
P
P

Description:

This property specifies thumbnail image size. It is used in XAML the color to use.

Declaration:

public System.Windows.Size ImageSize { get; }

Value:

System.Windows.Size value.

Sample Code:

C#
size = thumbnailCtl1.ImageSize;

VB .NET
size = thumbnailCtl1.ImageSize


Interior Property

32-bit
64-bit
CF
P
P

Description:

This property specifies the amount of extra space, in pixels, to place around the thumbnail item image inside the "button".

Declaration:

public int Interior { get;  set; }

Value:

Integer value.

Sample Code:

C#
thumbnailCtl1.Interior = 3;

VB .NET
thumbnailCtl1.Interior = 3


ItemHeight Property

32-bit
64-bit
CF
P
P

Description:

This property specifies item height in pixels of the image to be drawn in each thumbnail item.

Declaration:

public int ItemHeight { get;  set; }

Value:

Integer value.

Sample Code:

C#
thumbnailCtl1.ItemHeight = 100;

VB .NET
thumbnailCtl1.ItemHeight = 100


ItemWidth Property

32-bit
64-bit
CF
P
P

Description:

This property specifies item width in pixels of the image to be drawn in each thumbnail item.

Declaration:

public int ItemWidth { get;  set; }

Value:

Integer value.

Sample Code:

C#
thumbnailCtl1.ItemWidth = 100;

VB .NET
thumbnailCtl1.ItemWidth = 100


Margin Property

32-bit
64-bit
CF
P
P

Description:

This property specifies the amount of extra space, in pixels, to leave between the left edge of the control and the left-most item drawn inside the control. Note that the Thumbnail control is resizable, so the amount of margin on the right side is determined automatically.

Declaration:

public System.Windows.Thickness Margin { set; get; }

Value:

System.Windows.Thickness value.

Sample Code:

C#
margin = thumbnailCtl1.Margin;

VB .NET
margin = thumbnailCtl1.Margin


SelectionBackColor Property

32-bit
64-bit
CF
P
P

Description:

This property used as default background color for selected items.

Declaration:

public System.Drawing.Color SelectionBackColor { set; get; }

Value:

System.Drawing.Color value.

Sample Code:

C#
thumbnailCtl1.SelectionBackColor = sbColor;

VB .NET
thumbnailCtl1.SelectionBackColor = sbColor


SelectionForeColor Property

32-bit
64-bit
CF
P
P

Description:

This property used as default foreground color for selected items.

Declaration:

public System.Drawing.Color SelectionForeColor { set; get; }

Value:

System.Drawing.Color value.

Sample Code:

C#
thumbnailCtl1.SelectionForeColor = sfColor;

VB .NET
thumbnailCtl1.SelectionForeColor = sfColor


SelectionMode Property

32-bit
64-bit
CF
P
P

Description:

This property specifies items selection mode. Extended is by default.

Declaration:

public System.Windows.Controls.SelectionMode SelectionMode { set; get; }

Value:

System.Windows.Controls.SelectionMode value.

Sample Code:

C#
thumbnailCtl1.SelectionMode = SelectionMode.Single;

VB .NET
thumbnailCtl1.SelectionMode = SelectionMode.Single


ShadowsVisibility Property

32-bit
64-bit
CF
P
P

Description:

This property specifies items shadow visibility. If Hidden, no item shadow appears. Visible is by default.

Declaration:

public System.Windows.Visibility ShadowsVisibility { set; get; }

Value:

System.Windows.Visibility value.

Sample Code:

C#
thumbnailCtl1.ShadowsVisibility = Visibility.Hidden;

VB .NET
thumbnailCtl1.ShadowsVisibility = Visibility.Hidden


ShadowWidth Property

32-bit
64-bit
CF
P
P

Description:

This property specifies width of item's shadow.

Declaration:

public int ShadowWidth { get;  set; }

Value:

Integer value.

Sample Code:

C#
thumbnailCtl1.ShadowWidth = 2;

VB .NET
thumbnailCtl1.ShadowWidth = 2


ShowMagnify Property

32-bit
64-bit
CF
P
P

Description:

The user may opt to see a larger popup image for the thumbnail by pressing the right-mouse-button down. This property enables/disables this behavior.

Declaration:

public bool ShowMagnify { get;  set; }

Value:

true/false.

Sample Code:

C#
thumbnailCtl1.ShowMagnify = true;

VB .NET
thumbnailCtl1.ShowMagnify = True


Sort Property

32-bit
64-bit
CF
P
P

Description:

This property specifies what sorting (none, title ascending, title descending, user-defined) is used when a new item is added.

Declaration:

public ImageGear.Windows.Forms.Thumbnails.ImGearSortOptions Sort { get;  set; }

Value:

ImGearSortOptions Enumeration value.

Sample Code:

C#
thumbnailCtl1.Sort = ImGearSortOptions.TitleAscending;

VB .NET
thumbnailCtl1.Sort = ImGearSortOptions.TitleAscending

See Also:

ImGearSortOptions Enumeration


SortComparer Property

32-bit
64-bit
CF
P
P

Description:

This property is used when Sort property is set to "UserSort". User should provide a class implementing IComparer interface to make his own sorting.

Declaration:

public System.Collections.IComparer SortComparer { set; get; }

Value:

System.Collections.IComparer value.

Sample Code:

C#
thumbnailCtl1.SortComparer = userSorter;

VB .NET
thumbnailCtl1.SortComparer = userSorter


Thumbnails Property

32-bit
64-bit
CF
P
P

Description:

This property specifies all items as collection.

Declaration:

public System.Collections.ObjectModel.ObservableCollection<ImGearThumbnailItem> Thumbnails
{ get; }

Value:

System.Collections.ObjectModel.ObservableCollection.

Sample Code:

C#
thumbnails = thumbnailCtl1.Thumbnails;

VB .NET
thumbnails = thumbnailCtl1.Thumbnails

See Also:

ImGearThumbnailItem Class


TitlesVisibility Property

32-bit
64-bit
CF
P
P

Description:

This property specifies thumbnails title visibility. If Hidden, no visible titles appear, but layout reserved; if Collapsed, no titles at all.

Declaration:

public System.Windows.Visibility TitlesVisibility { set; get; }

Value:

System.Windows.Visibility value.

Sample Code:

C#
thumbnailCtl1.TitlesVisibility = Visibility.Hidden;

VB .NET
thumbnailCtl1.TitlesVisibility = Visibility.Hidden


VerticalScrollBarVisibility Property

32-bit
64-bit
CF
P
P

Description:

This property specifies if vertical scrollbar should appear when all items do not fit in the control. Auto is by default.

Declaration:

public System.Windows.Controls.ScrollBarVisibility VerticalScrollBarVisibility { set; get;
}

Value:

System.Windows.Controls.ScrollBarVisibility value.

Sample Code:

C#
thumbnailCtl1.VerticalScrollBarVisibility = ScrollBarVisibility.Hidden;

VB .NET
thumbnailCtl1.VerticalScrollBarVisibility = ScrollBarVisibility.Hidden


XSpacing Property

32-bit
64-bit
CF
P
P

Description:

This property specifies the amount of horizontal space between thumbnails displayed on the control, in pixels. When set to (-1) it will use the default spacing that Windows uses for icons.

Declaration:

public int XSpacing { set; get; }

Value:

Integer value.

Sample Code:

C#
thumbnailCtl1.XSpacing = 10;

VB .NET
thumbnailCtl1.XSpacing = 10


YSpacing Property

32-bit
64-bit
CF
P
P

Description:

This property specifies the amount of vertical space between thumbnails displayed on the control, in pixels. When set to (-1) it will use the default spacing that Windows uses for icons. When ShowTitles = true, the YSpacing measures the distance from the bottom of a title to the top of the item below it. When ShowTitles = false, the YSpacing measures the distance from the bottom of the item to the top of the one below it.

Declaration:

public int YSpacing { get;  set; }

Value:

Integer value.

Sample Code:

C#
thumbnailCtl1.YSpacing = 10;

VB .NET
thumbnailCtl1.YSpacing = 10


ZoomFactor Property

32-bit
64-bit
CF
P
P

Description:

This property only used when ShowMagnify = true. Specifies the amount of zoom-in to use when displaying the magnified popup image (value must be 1.0 or greater).

Declaration:

public double ZoomFactor { get;  set; }

Value:

Double value.

Sample Code:

C#
thumbnailCtl1.ZoomFactor = 2.0;

VB .NET
thumbnailCtl1.ZoomFactor = 2.0


ImGearThumbnailCtl Methods

The ImGearThumbnailCtl Class of the ImageGear.WPF Namespace has the following methods:

Methods
Name
Description
DeleteAllItems Method
Removes all the items from the Thumbnail control.
DeleteItem Method
Removes specified item from the Thumbnail control.
DirectoryAppend Method
Creates a series of thumbnail items.
DocumentAppend Method
Appends ImGearDocument Class object to the Thumbnail control.
FileAppend Method
Appends a file specified by selection to the Thumbnail control.
PageAppend Method
Appends ImGearPage object to the Thumbnail control.
ReloadAll Method
Reloads all thumbnails in the Thumbnail control.
ReloadItem Method
Reloads thumbnail picture in the specified thumbnail item.


DeleteAllItems Method

32-bit
64-bit
CF
P
P

Description:

This method removes all the items from the Thumbnail control.

Declaration:

public void DeleteAllItems()

Return Value:

None.

Sample Code:

C#
thumbnailCtl1.DeleteAllItems();

VB .NET
thumbnailCtl1.DeleteAllItems()


DeleteItem Method

32-bit
64-bit
CF
P
P

Description:

This method removes specified item from the Thumbnail control.

Declaration:

public void DeleteItem(ImageGear.WPF.ImGearThumbnailItem item)

Parameters:

Name
Type
Description
item
ImGearThumbnailItem Class
Item to be removed.

Return Value:

None.

Sample Code:

C#
if (item.Selected)
{
    thumbnailCtl1.DeleteItem(item);
}

VB .NET
if item.Selected Then
    thumbnailCtl1.DeleteItem(item)
Endif

See Also:

ImGearThumbnailItem Class


DirectoryAppend Method

32-bit
64-bit
CF
P
P

Description:

This method creates a series of thumbnail items (either one per file, or one per page per file), by scanning through the specified directory and selecting all of the files matching the Filters parameter.

Declaration:

public void DirectoryAppend(string dir, string filters)

Parameters:

Name
Type
Description
dir
string
Can either be specified as a DOS file path (e.g., with a drive-letter), or as a Windows file path (e.g., a UNC file path like "\\server\sharename\directory").
filters
string
A standard Windows file-filter string: "*.*" means all files, "*.bmp" means all BMP files, "*.JPG;*.BMP" means all BMP and JPG files.

Return Value:

None.

Sample Code:

C#
thumbnailForm.thumbnailCtl1.DirectoryAppend(browsePath, browseFilters);

VB .NET
thumbnailForm.thumbnailCtl1.DirectoryAppend(browsePath, browseFilters)


DocumentAppend Method

32-bit
64-bit
CF
P
P

Description:

This method appends ImGearDocument Class object to the Thumbnail control.

Declaration:

public void DocumentAppend(ImageGear.Core.ImGearDocument DocumentToAppend, string Name)

Parameters:

Name
Type
Description
DocumentToAppend
ImGearDocument Class
Document to be appended.
Name
string
Title for new items.

Return Value:

None.

Sample Code:

C#
thumbnailForm.thumbnailCtl1.DocumentAppend(docToLoad, "Loaded document");

VB .NET
thumbnailForm.thumbnailCtl1.DocumentAppend(docToLoad, "Loaded document")

See Also:

ImGearDocument Class


FileAppend Method

32-bit
64-bit
CF
P
P

Description:

This method appends a file specified by selection to the Thumbnail control.

Declaration:

public void FileAppend(ImageGear.Windows.Forms.ImGearLoadingSelection Selection)

Parameters:

Name
Type
Description
Selection
ImGearLoadingSelection Class
Selection specifying a path and a type of the file to be appended.

Return Value:

None.

Sample Code:

C#
thumbnailForm.thumbnailCtl1.FileAppend(selection);

VB .NET
thumbnailForm.thumbnailCtl1.FileAppend(selection)

See Also:

ImGearLoadingSelection Class


PageAppend Method

32-bit
64-bit
CF
P
P

Description:

This method appends ImGearPage object to the Thumbnail control.

Declaration:

public void PageAppend(ImageGear.Core.ImGearPage PageToAppend, string Name)

Parameters:

Name
Type
Description
PageToAppend
ImGearPage Class
ImGearPage object to be appended.
Name
string
Title for new item.

Return Value:

None.

Sample Code:

C#
thumbnailForm.thumbnailCtl1.PageAppend(pageToLoad, "Loaded page");

VB .NET
thumbnailForm.thumbnailCtl1.PageAppend(pageToLoad, "Loaded page")

See Also:

ImGearPage Class


ReloadAll Method

32-bit
64-bit
CF
P
P

Description:

This method reloads all thumbnails in the Thumbnail control.

Declaration:

public void ReloadAll()

Return Value:

None.

Sample Code:

C#
thumbnailCtl1.ReloadAll();

VB .NET
thumbnailCtl1.ReloadAll()


ReloadItem Method

32-bit
64-bit
CF
P
P

Description:

This method reloads thumbnail picture in the specified thumbnail item.

Declaration:

public void ReloadItem(ImageGear.WPF.ImGearThumbnailItem Item)

Parameters:

Name
Type
Description
Item
ImGearThumbnailItem Class
Item to be reloaded.

Return Value:

None.

Sample Code:

C#
thumbnailCtl1.ReloadItem(item);

VB .NET
thumbnailCtl1.ReloadItem(item)

See Also:

ImGearThumbnailItem Class


ImGearThumbnailCtl Events

The ImGearThumbnailCtl Class of the ImageGear.WPF Namespace has the following events:

Events
Name
Description
ItemAfterCreate Event
This event is called after a new thumbnail item is added to the Thumbnail control.
ItemAfterLoad Event
This event is called during the process of creating a thumbnail item.
ItemBeforeDelete Event
This event is called as each thumbnail item is removed from the control, before the item is removed from the items collection.
ItemBeforeLoad Event
This event is called during the process of creating a thumbnail item.
ItemClicked Event
This event is called to indicate that the user clicked somewhere within the thumbnail control.
ItemDoubleClicked Event
This event is called to indicate that the user double-clicked somewhere within the thumbnail control.


ItemAfterCreate Event

32-bit
64-bit
CF
P
P

Description:

This event is called after a new thumbnail item is added to the Thumbnail control. During thumbnail item creation, the sequence of events is ItemBeforeLoad, then ItemAfterLoad, then ItemAfterCreate.

Declaration:

public event ImageGear.WPF.ImGearThumbnailItemEventHandler ItemAfterCreate

See Also:

ImGearThumbnailItemEventHandler Delegate.


ItemAfterLoad Event

32-bit
64-bit
CF
P
P

Description:

This event is called during the process of creating a thumbnail item. This event is raised after the image has been loaded into ImGearPage object, but before the thumbnail item is created. Your application can implement this event handler if it needs to restrict the thumbnail items based on the file attributes.

Declaration:

public event ImageGear.WPF.ImGearThumbnailAfterLoadEventHandler ItemAfterLoad

See Also:

ImGearThumbnailAfterLoadEventHandler Delegate


ItemBeforeDelete Event

32-bit
64-bit
CF
P
P

Description:

This event is called as each thumbnail item is removed from the control, before the item is removed from the items collection.

Declaration:

public event ImageGear.WPF.ImGearThumbnailItemEventHandler ItemBeforeDelete

See Also:

ImGearThumbnailItemEventHandler Delegate


ItemBeforeLoad Event

32-bit
64-bit
CF
P
P

Description:

This event is called during the process of creating a thumbnail item. This event is raised before the image has been loaded into ImGearPage object. Your application can use this event to set the ImageGear file load handling (e.g., load scaled JPEG image) and the thumbnail image generation handling (e.g., aliasing, interpolation).

Declaration:

public event ImageGear.WPF.ImGearThumbnailBeforeLoadEventHandler ItemBeforeLoad

See Also:

ImGearThumbnailBeforeLoadEventHandler Delegate


ItemClicked Event

32-bit
64-bit
CF
P
P

Description:

This event is called to indicate that the user clicked somewhere within the thumbnail control.

Declaration:

public event ImageGear.WPF.ImGearThumbnailItemEventHandler ItemClicked

See Also:

ImGearThumbnailItemEventHandler Delegate


ItemDoubleClicked Event

32-bit
64-bit
CF
P
P

Description:

This event is called to indicate that the user double-clicked somewhere within the thumbnail control.

Declaration:

public event ImageGear.WPF.ImGearThumbnailItemEventHandler ItemDoubleClicked

See Also:

ImGearThumbnailItemEventHandler Delegate


ImGearThumbnailItem Class

32-bit
64-bit
CF
P
P

Description:

Each ImGearThumbnailItem object represents one of the thumbnail items displayed on the thumbnail browser. Your application can iterate through the collection of ImGearThumbnailItem using the Thumbnail property and Count property of ImGearThumbnailCtl. Some of the event handlers are using ImGearThumbnailItem objects (for instance, when someone clicks on a particular thumbnail item).

Declaration:

public class ImGearThumbnailItem : System.Windows.DependencyObject

Members:

Constructors
Name
Description
ImGearThumbnailItem Constructor
Creates and initializes an instance of ImGearThumbnailItem Class.
ImGearThumbnailItem Constructor
Creates and initializes an instance of ImGearThumbnailItem Class.

Properties
Name
Description
BitDepth Property
Specifies original image bit depth.
CurrentBackground Property
Specifies current background color.
CurrentForeground Property
Specifies current foreground color.
Format Property
Specifies original image format.
HighlightBackColor Property
Specifies title's back color of the highlighted item.
Highlighted Property
Specifies highlighted state of the item.
HighlightForeColor Property
Specifies title's fore color of the highlighted item.
Image Property
Specifies scaled thumbnail image.
ImageSize Property
Specifies original image size.
Page Property
Specifies ImGearPage object referencing to the original image.
PageNumber Property
Specifies page number.
ParentCtl Property
Specifies reference to the parent ImGearThumbnailCtl control.
PrivateData Property
Specifies user data associated with the item.
Selected Property
Specifies selection state of the item.
Source Property
Specifies ImGearLoadingSelection object containing path and format of the original file
Title Property
Specifies item's title.

Methods
Name
Description
Reload Method
Reloads item's picture.


ImGearThumbnailItem Constructors

The ImGearThumbnailItem Class of the ImageGear.WPF Namespace has the following constructors:

Constructors
Name
Description
ImGearThumbnailItem Constructor
Creates and initializes an instance of ImGearThumbnailItem Class.
ImGearThumbnailItem Constructor
Creates and initializes an instance of ImGearThumbnailItem Class.


ImGearThumbnailItem Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates and initializes an instance of ImGearThumbnailItem Class.

Declaration:

public ImGearThumbnailItem(ImageGear.WPF.ImGearThumbnailCtl parent,
ImageGear.Core.ImGearPage pageToLoad, string title, int pageNumber,
ImageGear.Formats.ImGearFormats format)

Parameters:

Name
Type
Description
parent
ImGearThumbnailCtl Class
Reference to the parent ImGearThumbnailCtl object.
pageToLoad
ImGearPage Class
Reference to ImGearPage object that contains original image.
title
string
Thumbnail item's title.
pageNumber
int
Page number.
format
ImGearFormats Enumeration
Original image format.

Return Value:

New instance of ImGearThumbnailItem Class.

Sample Code:

C#
ImGearThumbnailItem item = new ImGearThumbnailItem(this, PageToAppend, Name, PageIndex, Format);

VB .NET
Dim item As ImGearThumbnailItem
item = New ImGearThumbnailItem(Me, PageToAppend, Name, PageIndex, Format)

See Also:

ImGearThumbnailItem Class

ImGearThumbnailCtl Class

ImGearPage Class

ImGearFormats Enumeration


ImGearThumbnailItem Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates and initializes an instance of ImGearThumbnailItem Class.

Declaration:

public ImGearThumbnailItem(ImageGear.WPF.ImGearThumbnailCtl parent,
ImageGear.Windows.Forms.ImGearLoadingSelection loadingSelection, string title, int
pageNumber)

Parameters:

Name
Type
Description
parent
ImGearThumbnailCtl Class
Reference to the parent ImGearThumbnailCtl object.
loadingSelection
ImGearLoadingSelection Class
Reference to ImGearLoadingSelection object containing path and format of the original file.
title
string
Thumbnail item's title.
pageNumber
int
Page number.

Return Value:

New instance of ImGearThumbnailItem Class.

Sample Code:

C#
ImGearThumbnailItem item = new ImGearThumbnailItem(this, Selection, Selection.File.Path, PageIndex);

VB .NET
Dim item As ImGearThumbnailItem
item = New ImGearThumbnailItem(Me, Selection, Selection.File.Path, PageIndex)

See Also:

ImGearThumbnailItem Class

ImGearThumbnailCtl Class

ImGearLoadingSelection Class


ImGearThumbnailItem Properties

The ImGearThumbnailItem Class of the ImageGear.WPF Namespace has the following properties:

Properties
Name
Description
BitDepth Property
Specifies original image bit depth.
CurrentBackground Property
Specifies current background color.
CurrentForeground Property
Specifies current foreground color.
Format Property
Specifies original image format.
HighlightBackColor Property
Specifies title's back color of the highlighted item.
Highlighted Property
Specifies highlighted state of the item.
HighlightForeColor Property
Specifies title's fore color of the highlighted item.
Image Property
Specifies scaled thumbnail image.
ImageSize Property
Specifies original image size.
Page Property
Specifies ImGearPage object referencing to the original image.
PageNumber Property
Specifies page number.
ParentCtl Property
Specifies reference to the parent ImGearThumbnailCtl control.
PrivateData Property
Specifies user data associated with the item.
Selected Property
Specifies selection state of the item.
Source Property
Specifies ImGearLoadingSelection object containing path and format of the original file
Title Property
Specifies item's title.


BitDepth Property

32-bit
64-bit
CF
P
P

Description:

This property specifies original image bit depth.

Declaration:

public int BitDepth { get; }

Value:

Integer value.

Sample Code:

C#
int bitDepth = item.BitDepth;

VB .NET
Dim bitDepth As Integer
bitDepth = item.BitDepth


CurrentBackground Property

32-bit
64-bit
CF
P
P

Description:

This property specifies current background color (depending on item select, highlight state and colors that are set in Item itself or in parent control). It is used in XAML.

Declaration:

public System.Windows.Media.Brush CurrentBackground { get; }

Value:

System.Windows.Media.Brush value.

Sample Code:

C#
brush = item.CurrentBackground;

VB .NET
brush = item.CurrentBackground


CurrentForeground Property

32-bit
64-bit
CF
P
P

Description:

This property specifies current foreground color (depending on item select, highlight state and colors that are set in Item itself or in parent control). It is used in XAML.

Declaration:

public System.Windows.Media.Brush CurrentForeground { get; }

Value:

System.Windows.Media.Brush value.

Sample Code:

C#
brush = item.CurrentForeground;

VB .NET
brush = item.CurrentForeground


Format Property

32-bit
64-bit
CF
P
P

Description:

This property specifies original image format.

Declaration:

public ImageGear.Formats.ImGearFormats Format { get; }

Value:

ImGearFormats Enumeration value.

Sample Code:

C#
ImGearFormats format = item.Format;

VB .NET
Dim format As ImGearFormats
format = item.Format

See Also:

ImGearFormats Enumeration


HighlightBackColor Property

32-bit
64-bit
CF
P
P

Description:

This property specifies title's back color of the highlighted item. If it is not set, HighlightBackColor from thumbnail control is used.

Declaration:

public System.Drawing.Color HighlightBackColor { set; get; }

Value:

System.Drawing.Color structure.

Sample Code:

C#
item.HighlightBackColor = value;

VB .NET
item.HighlightBackColor = value


Highlighted Property

32-bit
64-bit
CF
P
P

Description:

This property specifies highlighted state of the item.

Declaration:

public bool Highlighted { get;  set; }

Value:

true/false

Sample Code:

C#
item.Highlighted = true;

VB .NET
item.Highlighted = true


HighlightForeColor Property

32-bit
64-bit
CF
P
P

Description:

This property specifies title's fore color of the highlighted item. If it is not set, HighlightForeColor from thumbnail control is used.

Declaration:

public System.Drawing.Color HighlightForeColor { set; get; }

Value:

System.Drawing.Color structure.

Sample Code:

C#
item.HighlightForeColor = value;

VB .NET
item.HighlightForeColor = value


Image Property

32-bit
64-bit
CF
P
P

Description:

This property specifies scaled thumbnail image. It is used in XAML.

Declaration:

public System.Windows.Media.Imaging.BitmapSource Image { get; }

Value:

System.Windows.Media.Imaging.BitmapSource value.

Sample Code:

C#
bitmapSource = item.Image;

VB .NET
bitmapSource = item.Image


ImageSize Property

32-bit
64-bit
CF
P
P

Description:

This property specifies original image size.

Declaration:

public int ImageSize { get; }

Value:

Integer value.

Sample Code:

C#
int size = item.ImageSize;

VB .NET
Dim size As Integer
size = item.ImageSize


Page Property

32-bit
64-bit
CF
P
P

Description:

This property specifies ImGearPage Class object referencing to the original image.

Declaration:

public ImageGear.Core.ImGearPage Page { get; }

Value:

ImGearPage Class.

Sample Code:

C#
ImGearPage page = item.Page;

VB .NET
Dim page As ImGearPage
page = item.Page

See Also:

ImGearPage Class


PageNumber Property

32-bit
64-bit
CF
P
P

Description:

This property specifies page number.

Declaration:

public int PageNumber { get; }

Value:

Integer value.

Sample Code:

C#
int pageNum = item.PageNumber;

VB .NET
Dim pageNum As Integer
pageNum = item.PageNumber


ParentCtl Property

32-bit
64-bit
CF
P
P

Description:

This property specifies reference to the parent ImGearThumbnailCtl control.

Declaration:

public ImageGear.WPF.ImGearThumbnailCtl ParentCtl { get; }

Value:

ImGearThumbnailCtl Class.

Sample Code:

C#
thumbnailCtl = item.ParentCtl;

VB .NET
thumbnailCtl = item.ParentCtl

See Also:

ImGearThumbnailCtl Class


PrivateData Property

32-bit
64-bit
CF
P
P

Description:

This property specifies user data associated with the item.

Declaration:

public object PrivateData { get;  set; }

Value:

object.

Sample Code:

C#
item.PrivateData = userData;

VB .NET
item.PrivateData = userData


Selected Property

32-bit
64-bit
CF
P
P

Description:

This property specifies selection state of the item. Default values is false.

Declaration:

public bool Selected { get;  set; }

Value:

true/false.

Sample Code:

C#
item.Selected = true;

VB .NET
item.Selected = true


Source Property

32-bit
64-bit
CF
P
P

Description:

This property specifies ImGearLoadingSelection Class object containing path and format of the original file.

Declaration:

public ImageGear.Windows.Forms.ImGearLoadingSelection Source { get; }

Value:

ImGearLoadingSelection Class.

Sample Code:

C#
ImGearLoadingSelection source = item.Source;

VB .NET
Dim source As ImGearLoadingSelection
source = item.Source

See Also:

ImGearLoadingSelection Class


Title Property

32-bit
64-bit
CF
P
P

Description:

This property specifies item's title.

Declaration:

public string Title { get;  set; }

Value:

String value.

Sample Code:

C#
string title = item.Title;

VB .NET
Dim title As String
title = item.Title


ImGearThumbnailItem Methods

The ImGearThumbnailItem Class of the ImageGear.WPF Namespace has the following methods:

Methods
Name
Description
Reload Method
Reloads item's picture.


Reload Method

32-bit
64-bit
CF
P
P

Description:

This method reloads item's picture.

Declaration:

public void Reload()

Return Value:

None.

Sample Code:

C#
foreach (ImGearThumbnailItem item in items)
    item.Reload();

VB .NET
item.Reload()

See Also:

ImGearThumbnailItem Class


ImGearThumbnailItemEventArgs Class

32-bit
64-bit
CF
P
P

Description:

This class specifies a list of arguments for ImGearThumbnailItemEventHandler Delegate.

Declaration:

public class ImGearThumbnailItemEventArgs : System.Windows.RoutedEventArgs

Members:

Constructors
Name
Description
ImGearThumbnailItemEventArgs Constructor
Creates and initializes an instance of ImGearThumbnailItemEventArgs Class.

Properties
Name
Description
Item Property
Specifies ImGearThumbnailItem object that generated event.


ImGearThumbnailItemEventArgs Constructors

The ImGearThumbnailItemEventArgs Class of the ImageGear.WPF Namespace has the following constructors:

Constructors
Name
Description
ImGearThumbnailItemEventArgs Constructor
Creates and initializes an instance of ImGearThumbnailItemEventArgs Class.


ImGearThumbnailItemEventArgs Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates and initializes an instance of ImGearThumbnailItemEventArgs Class.

Declaration:

public ImGearThumbnailItemEventArgs(System.Windows.RoutedEvent evt,
ImageGear.WPF.ImGearThumbnailItem item)

Parameters:

Name
Type
Description
evt
System.Windows.RoutedEvent
Reference to event object.
item
ImGearThumbnailItem Class
Item that generated event.

Return Value:

New instance of ImGearThumbnailItemEventArgs Class.

Sample Code:

C#
RaiseEvent(new ImGearThumbnailItemEventArgs(
ImGearThumbnailCtl.ItemAfterCreateEvent, item));

VB .NET
RaiseEvent(New ImGearThumbnailItemEventArgs(
ImGearThumbnailCtl.ItemAfterCreateEvent, item))

See Also:

ImGearThumbnailItemEventArgs Class

ImGearThumbnailItem Class


ImGearThumbnailItemEventArgs Properties

The ImGearThumbnailItemEventArgs Class of the ImageGear.WPF Namespace has the following properties:

Properties
Name
Description
Item Property
Specifies ImGearThumbnailItem object that generated event.


Item Property

32-bit
64-bit
CF
P
P

Description:

This property specifies ImGearThumbnailItem Class object that generated event.

Declaration:

public ImageGear.WPF.ImGearThumbnailItem Item { get; }

Value:

ImGearThumbnailItem Class.

Sample Code:

C#
ImGearThumbnailItem item = itemArgs.Item;

VB .NET
Dim item As ImGearThumbnailItem
item = itemArgs.Item

See Also:

ImGearThumbnailItem Class


ImGearThumbnailMagnifierCtl Class

32-bit
64-bit
CF
P
P

Description:

This class provides interaction logic for ThumbnailMagnifierCtl.xaml.

Declaration:

public class ImGearThumbnailMagnifierCtl : System.Windows.Controls.UserControl

Members:

Constructors
Name
Description
ImGearThumbnailMagnifierCtl Constructor
Creates and initializes an instance of ImGearThumbnailMagnifierCtl Class.

Properties
Name
Description
Image Property
Specifies image that is displayed in popup window.


ImGearThumbnailMagnifierCtl Constructors

The ImGearThumbnailMagnifierCtl Class of the ImageGear.WPF Namespace has the following constructors:

Constructors
Name
Description
ImGearThumbnailMagnifierCtl Constructor
Creates and initializes an instance of ImGearThumbnailMagnifierCtl Class.


ImGearThumbnailMagnifierCtl Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates and initializes an instance of ImGearThumbnailMagnifierCtl Class.

Declaration:

public ImGearThumbnailMagnifierCtl(System.Windows.Media.Imaging.BitmapSource image)

Parameters:

Name
Type
Description
image
System.Windows.Media.Imaging.BitmapSource
BitmapSource object to display in popup window.

Return Value:

New instance of ImGearThumbnailMagnifierCtl Class.

Sample Code:

C#
contextMenu.Items.Add(new ImGearThumbnailMagnifierCtl(bitmapSource));

VB .NET
contextMenu.Items.Add(New ImGearThumbnailMagnifierCtl(bitmapSource));

See Also:

ImGearThumbnailMagnifierCtl Class


ImGearThumbnailItemEventArgs Properties

The ImGearThumbnailItemEventArgs Class of the ImageGear.WPF Namespace has the following properties:

Properties
Name
Description
Image Property
Specifies image that is displayed in popup window.


Image Property

32-bit
64-bit
CF
P
P

Description:

This property specifies image that is displayed in popup window. It is used in XAML.

Declaration:

public System.Windows.Media.Imaging.BitmapSource Image { get; }

Value:

System.Windows.Media.Imaging.BitmapSource value.

Sample Code:

C#
bitmapSource = thumbnailMagnifierCtl.Image;

VB .NET
bitmapSource = thumbnailMagnifierCtl.Image


ImageGear.WPF Delegates

The ImageGear.WPF Namespace has the following delegates members:

Delegates:
Name
Description
ImGearThumbnailAfterLoadEventHandler Delegate
Used for declaring ItemAfterLoad event.
ImGearThumbnailBeforeLoadEventHandler Delegate
Used for declaring ItemBeforeLoad event.
ImGearThumbnailItemEventHandler Delegate
Used for declaring ItemAfterCreate, ItemBeforeDelete, ItemClicked and ItemDoubleClicked events.


ImGearThumbnailAfterLoadEventHandler Delegate

32-bit
64-bit
CF
P
P

Description:

This delegate is used for declaring ItemAfterLoad Event.

Declaration:

public delegate void ImGearThumbnailAfterLoadEventHandler(object sender,
ImageGear.WPF.ImGearThumbnailAfterLoadEventArgs e)

Parameters:

Name
Type
Description
sender
object
The source of the event.
e
ImGearThumbnailAfterLoadEventArgs Class
ImGearThumbnailAfterLoadEventArgs object that contains the event data.

Return Value:

None.

Sample Code:

C#
ImGearThumbnailAfterLoadEventArgs afterLoadArgs =
new ImGearThumbnailAfterLoadEventArgs( ImGearThumbnailCtl.ItemAfterLoadEvent, PageToAppend, false);
RaiseEvent(afterLoadArgs);

VB .NET
Dim afterLoadArgs As ImGearThumbnailAfterLoadEventArgs
afterLoadArgs = New ImGearThumbnailAfterLoadEventArgs(PageToAppend, false)
RaiseEvent(afterLoadArgs)

See Also:

ImGearThumbnailAfterLoadEventArgs Class

ItemAfterLoad Event.


ImGearThumbnailBeforeLoadEventHandler Delegate

32-bit
64-bit
CF
P
P

Description:

This delegate is used for declaring ItemBeforeLoad Event.

Declaration:

public delegate void ImGearThumbnailBeforeLoadEventHandler(object sender,
ImageGear.WPF.ImGearThumbnailBeforeLoadEventArgs e)

Parameters:

Name
Type
Description
sender
object
The source of the event.
e
ImGearThumbnailBeforeLoadEventArgs Class
ImGearThumbnailBeforeLoadEventArgs object that contains the event data.

Return Value:

None.

Sample Code:

C#
ImGearThumbnailBeforeLoadEventArgs beforeLoadArgs =
new ImGearThumbnailBeforeLoadEventArgs( ImGearThumbnailCtl.ItemBeforeLoadEvent, source, PageToAppend, PageIndex, false);
RaiseEvent(beforeLoadArgs);

VB .NET
Dim beforeLoadArgs As ImGearThumbnailBeforeLoadEventArgs
beforeLoadArgs = New ImGearThumbnailBeforeLoadEventArgs(ImGearThumbnailCtl.ItemBeforeLoadEvent, source, PageToAppend, PageIndex,
false)
RaiseEvent(beforeLoadArgs)

See Also:

ImGearThumbnailBeforeLoadEventArgs Class

ItemBeforeLoad Event.


ImGearThumbnailItemEventHandler Delegate

32-bit
64-bit
CF
P
P

Description:

This delegate is used for declaring ItemAfterCreate Event, ItemBeforeDelete Event, ItemClicked Event and ItemDoubleClicked Event events.

Declaration:

public delegate void ImGearThumbnailItemEventHandler(object sender,
ImageGear.WPF.ImGearThumbnailItemEventArgs e)

Parameters:

Name
Type
Description
sender
object
The source of the event.
e
ImGearThumbnailItemEventArgs Class
ImGearThumbnailItemEventArgs object that contains the event data.

Return Value:

None.

Sample Code:

C#
RaiseEvent(new ImGearThumbnailItemEventArgs(
ImGearThumbnailCtl.ItemAfterCreateEvent, item));

VB .NET
RaiseEvent(New ImGearThumbnailItemEventArgs(
ImGearThumbnailCtl.ItemAfterCreateEvent, item))

See Also:

ItemAfterCreate Event

ItemBeforeDelete Event

ItemClicked Event

ItemDoubleClicked Event

ImGearThumbnailItemEventArgs Class


ImageGear.WPF Enumerations

The ImageGear.WPF Namespace has the following enumerations members:

Enumerations
Name
Description
ImGearMagnifierShapeType Enumeration
Specifies popup magnifier shape.


ImGearMagnifierShapeType Enumeration

32-bit
64-bit
CF
P
P

Description:

This enumeration specifies popup magnifier shape.

Declaration:

public enum ImGearMagnifierShapeType

Values:

Name
Value
Description
Ellipse
1
Ellipsoid shape.
Rectangle
0
Rectangular shape.

See Also:

ImGearMagnifierCtl.ShapeType Property.


ImageGear.WPF.XPS Namespace

ImageGear.WPF.XPS Namespace

32-bit
64-bit
CF
P
P

Description:

ImageGear XPS namespace provides full multi-page reading, writing and printing support for XPS documents and pages. You can detect, read, write, append, insert, replace, delete and print specified pages in the XPS document as well as convert raster images to XPS.

To enable ImageGear.WPF.XPS namespace in your project specify the following directive:

using ImageGear.WPF.XPS;

Declaration:

namespace ImageGear.WPF.XPS

Members:

Classes:
Name
Description
ImGearXPS Class
Core XPS class is used to create an instance of the XPS format.
ImGearXPSDocument Class
XPS document class is used to work with XPS documents.
ImGearXPSPage Class
XPS page class is used to work with XPS pages.
ImGearXPSPrintOptions Class
This class specifies options for the native XPS printing.


ImageGear.WPF.XPS Classes

The ImageGear.WPF.XPS Namespace has the following class members:

Classes:
Name
Description
ImGearXPS Class
Core XPS class is used to create an instance of the XPS format.
ImGearXPSDocument Class
XPS document class is used to work with XPS documents.
ImGearXPSPage Class
XPS page class is used to work with XPS pages.
ImGearXPSPrintOptions Class
This class specifies options for the native XPS printing.


ImGearXPS Class

32-bit
64-bit
CF
P
P

Description:

This Core XPS class is used to create an instance of the XPS format.

Declaration:

public sealed class ImGearXPS

Members:

Methods
Name
Description
CreateXPSFormat Method
Creates an instance of XPS format to support XPS document files.


ImGearXPS Class Methods

The ImGearXPS Class of the ImageGear.WPF.XPS Namespace has the following methods:

Methods
Name
Description
CreateXPSFormat Method
Creates an instance of XPS format to support XPS document files.


CreateXPSFormat Method

32-bit
64-bit
CF
P
P

Description:

Creates an instance of XPS format to support XPS document files.

Declaration:

public static ImGearFormat CreateXPSFormat()

Declaration:

An instance of XPS format.


ImGearXPSDocument Class

32-bit
64-bit
CF
P
P

Description:

The XPSDocument class is used to work with XPS documents.

Declaration:

public class ImGearXPSDocument : ImageGear.Core.ImGearDocument

Members:

Constructors:
Name
Description
ImGearXPSDocument Constructor
Creates a blank XPS document.

Properties:
Name
Description
Pages Property
Returns a list of pages available in the document.

Methods:
Name
Description
Clone Method
Clones the document.
InsertPage Method
Inserts any ImageGear page into the XPS document.
Print Method
Prints the document using native XPS printing.


ImGearXPSDocument Class Constructors

The ImGearXPSDocument Class of the ImageGear.WPF.XPS Namespace has the following constructors:

Constructors:
Name
Description
ImGearXPSDocument Constructor
Creates a blank XPS document.


ImGearXPSDocument Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor creates a blank XPS document.

Declaration:

public ImGearXPSDocument()

Return Value:

New instance of ImGearXPSDocument Class


ImGearXPSDocument Class Properties

The ImGearXPSDocument Class of the ImageGear.WPF.XPS Namespace has the following properties:

Properties:
Name
Description
Pages Property
Returns a list of pages available in the document.


Pages Property

32-bit
64-bit
CF
P
P

Description:

This property returns a list of pages available in the document.

Declaration:

public override ImGearDocumentPageArray Pages

Value:

ImGearDocumentPageArray Class


ImGearXPSDocument Class Methods

The ImGearXPSDocument Class of the ImageGear.WPF.XPS Namespace has the following methods:

Methods:
Name
Description
Clone Method
Clones the document.
InsertPage Method
Inserts any ImageGear page into the XPS document.
Print Method
Prints the document using native XPS printing.


Clone Method

32-bit
64-bit
CF
P
P

Description:

This method clones the document.

Declaration:

public override ImGearDocument Clone()

Return Value:

The cloned ImGearDocument Class.


InsertPage Method

32-bit
64-bit
CF
P
P

Description:

Inserts any ImageGear page into XPS document.

Declaration:

public int InsertPage(int Index, ImGearPage page, int Width, int Height)

Parameters:

Name
Type
Description
Index
int
Position where page is to be inserted. If it is less than 0 or more than total page count, it is appended after the last page.
Page
ImGearPage Class
ImageGear page to be inserted.
Width
int
Width of page, in 1/100 inches.
Height
int
Height of page, in 1/100 inches.

Return Value:

Position of the newly inserted page.

See Also:

ImGearPage Class


Print Method

32-bit
64-bit
CF
P
P

Description:

Prints the document using native XPS printing.

Declaration:

public void Print(ImGearXPSPrintOptions PrintOptions)

Parameters:

Name
Type
Description
PrintOptions
ImGearXPSPrintOptions Class
ImGearXPSPrintOptions object specifing printing options.

Return Value:

None

See Also:

ImGearXPSPrintOptions Class


ImGearXPSPage Class

32-bit
64-bit
CF
P
P

Description:

The XPSPage class is used to work with XPS pages.

Declaration:

public class ImGearXPSPage : ImageGear.Core.ImGearVectorPage

Members:

Methods:
Name
Description
Clone Method
Returns cloned XPS page.
Rasterize Method
Rasterizes the XPS page returning the output raster page.


ImGearXPSPage Class Methods

The ImGearXPSPage Class of the ImageGear.WPF.XPS Namespace has the following methods:

Methods:
Name
Description
Clone Method
Returns cloned XPS page.
Rasterize Method
Rasterizes the XPS page returning the output raster page.


Clone Method

32-bit
64-bit
CF
P
P

Description:

This method clones the page.

Declaration:

public override ImGearPage Clone()

Return Value:

Returns cloned page.

See Also:

ImGearPage Class


Rasterize Method

32-bit
64-bit
CF
P
P

Description:

Rasterizes the XPS page returning the output raster page.

Declaration:

public override ImGearRasterPage Rasterize()

Return Value:

Returns XPS content converted into the raster page.

See Also:

ImGearRasterPage Class


ImGearXPSPrintOptions Class

32-bit
64-bit
CF
P
P

Description:

This class specifies options for native XPS printing.

Declaration:

public sealed class ImGearXPSPrintOptions

Members:

Constructors:
Name
Description
ImGearXPSPrintOptions Constructor
This constructor initializes an instance of the ImGearXPSPrintOptions class.

Properties:
Name
Description
PrintTicket Property
Returns a list of pages available in the document.
PageRange Property
Returns a range of pages to be printed.
PrintQueue Property
Print queue to use to print the document.


ImGearXPSPrintOptions Class Constructors

The ImGearXPSPrintOptions Class of the ImageGear.WPF.XPS Namespace has the following constructors:

Constructors:
Name
Description
ImGearXPSPrintOptions Constructor
This constructor initializes an instance of ImGearXPSPrintOptions Class.


ImGearXPSPrintOptions Constructor

32-bit
64-bit
CF
P
P

Description:

This constructor initializes an instance of ImGearXPSPrintOptions Class.

Declaration:

public ImGearXPSPrintOptions(PrintQueue PrintQueue, PrintTicket PrintTicket,
PageRange PageRange)

Parameters:

Name
Type
Description
PrintQueue
PrintQueue
Print queue to use to print the document.
PrintTicket
PrintTicket
Settings for the print job.
PageRange
PageRange
The range of pages to print.

Return Value:

An instance of ImGearXPSPrintOptions Class.

See Also:

ImGearXPSPrintOptions Class


ImGearXPSPrintOptions Class Properties

The ImGearXPSPrintOptions Class of the ImageGear.WPF.XPS Namespace has the following properties:

Properties:
Name
Description
PrintTicket Property
Returns a list of pages available in the document.
PageRange Property
Returns a range of pages to be printed.
PrintQueue Property
Print queue to use to print the document.


PrintTicket Property

32-bit
64-bit
CF
P
P

Description:

This property specifies the print job settings (read-only).

Declaration:

public PrintTicket PrintTicket
{ get; }

Value:

PrintTicket


PageRange Property

32-bit
64-bit
CF
P
P

Description:

This property specifies the range of pages to print (read-only).

Declaration:

public PageRange PageRange
{ get; }

Value:

PageRange


PrintQueue Property

32-bit
64-bit
CF
P
P

Description:

This property specifies the queue to use to print the document (read-only).

Declaration:

public PrintQueue PrintQueue
{ get; }

Value:

PrintQueue


ImageGear Imaging Formats Reference

ImageGear Imaging Formats Reference

This chapter provides information about the image formats that ImageGear supports. Before you begin, please refer to the Encoding vs. Compressing section below to familiarize yourself with the terms used in this Chapter.

The Format Suitability at a Glance section briefly delineates which formats best support various types of images. This section provides you with a starting point for deciding which file formats to use in your application.

The section ImageGear Support for Graphics File Formats describes the types of imaging file formats supported by ImageGear and provides useful information about support for some specific formats:

  • Support for Adobe PDF/PS Formats
  • Support for CAD/Vector Formats
  • Support for DICOM File Format
  • Support for JPEG2000 File Formats
  • Support for Metafile Formats
  • Support for Multi-Page File Formats

ImageGear Supported Bit Depths section describes the bit depths, and the read/write capabilities of the supported formats. Using this table, you can easily find out whether an image can be converted to a particular format.

If you are going to use ImageGear alpha channels support, please review the section ImageGear Alpha Channel Support.

Detailed information about every ImageGear supported imaging file format or compression can be found in the following sections:

  • ImageGear Supported Compressions Reference - here you will find information for every ImageGear supported imaging compression.
  • ImageGear Supported File Formats Reference - provides detailed information about every ImageGear supported format, its ID, versions, encoding type, multi-page and alpha channel support, supported compressions, color spaces and bit depths for read and write, as well as information about ImageGear supported features and filter control parameters.
  • ImageGear Supported Digital Camera RAW Formats Reference - provides detailed information about every ImageGear supported format, its ID, versions, encoding type, multi-page and alpha channel support, supported compressions, color spaces and bit depths for read and write, as well as information about ImageGear supported features and filter control parameters. The subsection Particular Cameras Supported DC RAW Formats provides information about the level of ImageGear support for particular digital cameras formats.

The section ImageGear Supported Non-Image Data provides detailed information about ImageGear supported metadata.

Encoding vs. Compressing

These two words are often used interchangeably in discussions of graphics file formats. Encoding is actually a broad term under which compression falls. For the sake of clarity, use these terms separately with the following intended meanings:

  • Encoding - The manner that data is stored when uncompressed (binary, ASCII, etc.), how it is packed (e.g., 4-bit pixels may be packed at a rate of two pixels per byte), and the unique set of symbols used to represent the range of data items.
  • Compressing - A "physical" rewriting of the graphics data so that it is represented by a smaller set of data.


Format Suitability at a Glance

The following table contains the formats that AccuSoft considers most practical for the listed type of data, and can be used as a starting point. You can use a format with the appropriate character depth and one that provides either the most efficient use of space, or the fastest loading and saving capabilities.

Bear in mind that the following table represents recommendations only. To make an informed choice, read about each format in more detail in the section ImageGear Supported File Formats Reference.

Image type
Recommended
Colors
JPEG, JPEG2000, TIFF, PNG
grayscale/many shades
TGA, TIFF, JPEG, DICOM
Monochrome / high resolution
TIFF (CCITT Group 3 Compression ), TIFF (CCITT Group 4 Compression )
Banking data
IBM IOCA
Noisy
Color: PNG, TIFF, JPEG
Lossless
GIF, TIFF, PNG, JPEG (Lossless JPEG Compression )
Lossy
TIFF (JPEG Compression ), JPEG
Extra data to store
TIFF
Iconic images
ICO
Multimedia
PNG, GIF, JPEG
Photographic images
Adobe PSB , Adobe PSD, PCD, JPEG
Internet images
GIF, JPEG, PNG, JPEG2000, WBMP
PC paint programs and/or graphics arts
PCX, GEM, WMF, TIFF, BMP
X Windows
XBM, XPM, XWD
Medical data
DICOM
CAD/Vector
WMF, DWG, DWF, DXF , CGM , DGN , HPGL , U3D
Document processing
TIFF, Adobe PDF, Adobe PS, PTOCA , XPS


ImageGear Support for Graphics File Formats

Every application that deals with images has specific kinds of data to store and interchange, from icons to photographs. The various hardware devices used to record and store the graphics data, and the hardware intended to display or print the data also affect the design of the format. This leads to a diversity of file formats. To add to this diversity, different groups of people have different ideas about how to structure and access an image, and what kind of additional information should be stored with an image. Even formats designed to store the same kind of data can differ. Other factors that affect the outcome of the design include memory considerations, storage size, accuracy, and portability.

National and international standardization organizations, such as the American National Standards Institute (ANSI) and the International Standards Organization (ISO), seek to create standards of storage for graphics data. One example is the Joint Photographic Experts Group's (JPEG) creation of the JPEG file format. Some of its intended goals were good image quality, user-chosen compression ratio, and cross-platform flexibility. When an image is called a JPEG, it is assumed to precisely follow the standardized JPEG format.

Formats known as "de facto standards" are those that begin as proprietary formats, but by the forces of the market and sometimes by good quality, become widely supported. Some examples of de facto standards are BMP, GIF, and PCD.

A third group of file formats falls somewhere between officially recognized standards and the strictly proprietary formats. These formats are created by groups of individuals with a common interest who come together to form a more unofficial standards organization. These formats are usually intended to provide an end-all industry standard so that data with the same or similar origins can be shared across different applications or platforms. One example is the TIFF format. TIFF was designed by eight computer technology companies (headed by Aldus Corporation) with the common goal of providing a standard format for storing scanned images.

ImageGear supports graphics file formats from all of these genres, providing you with a complete range of imaging capabilities, including the capture and processing of scanned images.

In addition, ImageGear functionality enable you to exchange data easily from one format to another, and to make improvements in images using powerful image-processing API.

ImageGear list of supported formats includes all of the popular formats, including recognized standards that best utilize the latest imaging technologies.

See Also:

ImageGear Supported Compressions Reference

ImageGear Supported File Formats Reference


Support for Adobe PDF/PS Formats

ImageGear provides comprehensive support for Adobe PDF and Adobe PS formats using its ImageGear.Formats.PDF Namespace.

To use support for PDF and PostScript formats, as well as manipulate and transform PDF/PS images, ImageGear.Formats.PDF Namespace must be attached to Core ImageGear.

See Also:

Using ImageGear.Formats.PDF Namespace

ImageGear.Formats.PDF Namespace


Support for CAD/Vector Formats

ImageGear provides support for the following CAD/Vector formats:

  • CGM
  • DGN
  • DWF
  • DWG
  • DXF
  • HPGL (HPGL/2)
  • U3D

To work with these formats, initialize the following ImageGear namespaces:

  • ImageGear.Formats.CGM Namespace
  • ImageGear.Formats.DGN Namespace
  • ImageGear.Formats.CAD Namespace
  • ImageGear.Formats.HPGL Namespace
  • ImageGear.Formats.U3D Namespace

To manipulate and process CAD/Vector images ImageGear.Vector Namespace should be initialized.

See Also:

Using ImageGear.Vector Namespace


Support for DICOM File Format

ImageGear provides comprehensive support for DICOM formats using its ImageGear.Formats.DICOM Namespace.

To use the support for DICOM format as well as manipulate, transform and process DICOM images ImageGear.Formats.DICOM Namespace should be initialized.

See Also:

ImageGear.Formats.DICOM Namespace

Using ImageGear.Formats.DICOM Namespace


Support for JPEG2000 File Formats

ImageGear provides support for the following CAD/Vector formats:

  • JPEG2000
  • JPX
  • Motion JPEG2000

To use the support for JPEG2000 formats as well as efficiently and dynamically stream portions of a JPEG2000-compressed image over a network ImageGear.Formats.JPEG2K Namespace should be initialized.

See Also:

ImageGear.Formats.JPEG2K Namespace

Using ImageGear.Formats.JPEG2K Namespace


Support for Metafile Formats

Metafiles contain vector (or geometric) specifications and bitmap pixel data. Vectors, in the realm of computer graphics, define shapes and location of shapes in terms of their relative location within the page.

ImageGear supports the following formats that contain vector data:

  • WMF
  • WPG

For all formats, except WMF, the vector data is ignored; only the bitmap data is read and/or written.

NOTE: When ImageGear loads a Windows Metafile (WMF), it automatically converts each vector specification to bitmap data. The shapes and lines declared by the vector specifications appear in the image, but the original vector instructions are not saved.


Support for Multi-Page File Formats

ImageGear provides multi-page support for the following file formats:

  • Adobe PDF
  • Adobe PS
  • Adobe PSB
  • Adobe PSD
  • BMP (OS/2 BMP only)
  • CGM
  • CUR
  • DCX
  • DICOM
  • DWF
  • GIF
  • HPGL
  • IBM IOCA
  • IBM MO:DCA
  • ICO
  • IFF
  • PCD
  • PTOCA
  • TIFF
  • XPS
NOTE: It is important to note that ImageGear treats the first page of a multi-page file as page number 1 (not 0).


ImageGear Supported Bit Depths

You may want to convert a file from one format to another. You can do this by saving the original file to its desired format by setting the nFormatType parameter to the appropriate value in the saving function. For more information on converting issues, see the section Loading/Saving Pages and Documents.

When saving a file to another format, remember to ensure that the desired file format is supported for that image. For example, you cannot convert an 8-bit DCX file to an 8-bit CAL file, because the CAL format does not support 8-bit files.

In the tables on the following pages, the columns underneath the numbers indicated size in bits that can actually be saved (written). The columns underneath the letters "R" and "W" indicate that the ImageGear reads and writes, respectively, the corresponding file format.

Format
R
W
1
4
8
9-16G
24
32
36
48
64
Adobe DNG
+
+
+
Adobe PDF
+
+
+
+
+
+
+
Adobe PS
+
+
+
+
+
+
+
Adobe PSB 1
+
+
+
+
+
+
+
+
+
+
Adobe PSD 2
+
+
+
+
+
+
+
+
+
+
BMP
+
+
+
+
+
+
+
+3
BTR
+
+
+
CAL
+
+
+
CGM
+
+
CLP
+
+
+
+
+
+
CR2
+
+
+
CRW
+
+
+
CUR 4
+
+
+
+
+
+
CUT
+
+
+
DCRAW
+
+
+
DCX
+
+
+
+
+
+
DGN
+
DIB
+
+
+
+
+
+5
+
+6
DICOM
+
+
+
+
+
+
+
+
DWF
+
+
DWG
+
+
DXF
+
+
GEM
+
+
+
+
GIF
+
+
+
+
+
HD Photo
+
+
+
+
+
+
+
+
+
Headerless Camera Raw
+
+
+
HPGL
+
IBM IOCA
+
+7
+
+
+
+
IBM MO:DCA
+
+8
+
+
+
+
ICO
+
+
+
+
+
+
IFF
+
+
+
+
+
+
Imacon Raw
+
+
+
IMG
+
+
+
IMR
+
+
IMT
+
+
+
JPEG
+
+
+9
+
+
+
+
+
JPEG2000
+
+
+
+
+
+
+
+
+
JPX
+
+
+
+
+
+
+
+
+
KFX
+
+
KodakRAW
+
+
+
LeicaRAW
+
+
+
LV
+
+
MEF
+
+
+
MOS
+
+
+
Motion JPEG2000
+
+
+
+
+
+
+
MRW
+
+
+
MSP
+
+
NCR
+
+
+
+10
NEF
+
+
+
ORF
+
+
+
PBM
+
+
+
+
+
+
+
PCD
+
+
PCX
+
+
+
+
+
+
PEF
+
+
+
PGM 11
+
+
+
+
PNG 12
+
+
+
+
+
+
+
+
+
+
PNM 13
+
+
+
+
+
+
+
PPM
+
+
+
+
PTOCA
+
+
RAF
+
+
+
RAS
+
+
+
+14
+
+
Scitex CT 15
+
+
+
SGI
+
+
+
+
+
+
SonyRaw
+
+
+
TGA
+
+
+
+
+
+
+
TIFF 16
+
+
+
+
+
+
+
+
+
+
+
U3D
+
+
WBMP
+
+
+
WMF
+
+
+
+
+
+
WPG
+
+
+
+
XBM
+
+
+
XPM
+
+
+
+
+
+17
XPS
+
+
+
+
+
+
+
+
+
XWD
+
+
+
+
+
+

148- and 64-bit images support is Read only.

248- and 64-bit images support is Read only.

3Read only support.

4Supports Extra ((1, 3, 4, 8)*2)-bit images also.

5Read only support.

6Read only support.

7Write support for 1-bit images only.

8Write support for 1-bit images only.

98-bit grayscale.

10Read only.

11Supports 16-bit grayscale images also.

12Supports 48(RGB)- and 64(RGB+alpha)-bit images.

13Supports 16-bit grayscale and 48-bit color images also.

14Read only support.

15The native format is CMYK. With full CMYK support enabled, you can use 32-bit images.

16Read only supports also 3- and 6 bpp for RGB and LAB color spaces for Deflate Compression, LZW (Lempel-Ziv-Welch) Compression, Packbits Compression compressions and uncompressed.

1724-bit has Read only support


ImageGear Alpha Channel Support

ImageGear provides alpha channel support for the following file format filters:

Format
Support
Adobe PSB
Supports single Alpha channel for Read only. Supports aditional Alpha channels as ImageGear Extra channels for Read only.
Adobe PSD
Supports single Alpha channel for Read only. Supports aditional Alpha channels as ImageGear Extra channels for Read only.
CUR
Supports single 8-bit alpha channel for read/write. Supports single 1-bit alpha channel for read only.
ICO
Supports single 8-bit alpha channel for read/write. Supports single 1-bit alpha channel for read only.
JPEG
Supports single Alpha channel for Read/write.
JPEG2000
Supports single Alpha channel for read/write, for Grayscale and RGB images.
JPX
Supports single Alpha channel for read/write, for Grayscale and RGB images. Supports additional Alpha channels as ImageGear Extra channels for read/write.
Motion JPEG2000
Supports single Alpha channel for read only, for Grayscale and RGB images.
PNG
Suports single Alpha channel for read/write.
SGI
Supports single alpha channel for read and write.
TGA
Supports single alpha channel for read and write.
TIFF
Supports single Alpha channel for read and write. Supports additional Alpha channels as ImageGear Extra channels for read and write.The following compressions are supported with alpha channel:
  • Uncompressed
  • Packed Bits
  • LZW
  • Deflate


ImageGear Supported Compressions Reference

All imaging files compressions can be divided on three basic types:

  • One-dimensional compression - the raster data is treated as one continuous data stream. Each byte read is compared to the previous byte. This compression method is not concerned with delineating lines of data.
  • 2D compression can be thought of as "Differencing Compression", where the data stored is a representation of the differences in data values from previous data values. In 2-D compression, the encoding of one line is determined by the contents of the previous line. This method of compression is best used for black-and-white images where the black pixels tend to fall into groups.
  • 3D compression is a new branch of data compression aimed at the 3D models and other geometric datasets used in computer graphics, virtual reality, video games, CAD/CAM, and many scientific, engineering, and medical applications.

Existing 3D compression algorithms use both techniques adapted from the 1D and 2D cases (like wavelets, entropy coding, and predictive coding), and completely different approaches that take advantage of the properties of 3D surfaces (like Edgebreaker, Subdivision Surfaces, and triangle strips).

ImageGear supports the following compressions:

  • ABIC Compression
  • ASCII Compression
  • CCITT Group 3 Compression
  • CCITT Group 3 2D Compression
  • CCITT Group 4 Compression
  • Deflate Compression
  • HD Photo Compression
  • Huffman Compression
  • IBM MMR Compression
  • JBIG Compression
  • JBIG2 Compression
  • JPEG Compression
  • JPEG2000 Compression
  • Lossless JPEG Compression
  • LZW (Lempel-Ziv-Welch) Compression
  • Packbits Compression
  • Progressive JPEG Compression
  • RAW Compression
  • RLE Compression


ABIC Compression

This is a proprietary compression scheme (owned by IBM) used on IOCA/MO:DCA. Not supported by ImageGear for .NET.


ASCII Compression

Full Name
American Standard Code for Information Interchange (ASCII)
Compression ID
ImGearCompressions.ASCII = 23
IG Component
Core
Bit Depth
Gray level: 1, 8, 16 bpp; RGB 24, 48 bpp
File Formats
PBM, PGM, PNM, PPM
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, Silverlight, MAC

Comments:

Acronym for the American Standard Code for Information Interchange. ASCII is a code for representing English characters as numbers, with each letter assigned a number from 0 to 127. For example, the ASCII code for uppercase M is 77. Most computers use ASCII codes to represent text, which makes it possible to transfer data from one computer to another.

Text files stored in ASCII format are sometimes called ASCII files. Text editors and word processors are usually capable of storing data in ASCII format, although ASCII format is not always the default storage format. Most data files, particularly if they contain numeric data, are not stored in ASCII format. Executable programs are never stored in ASCII format.


CCITT Group 3 Compression

Full Name
CCITT Group 3
Compression ID
ImGearCompressions.CCITT_G3 = 3
IG Component
Core
Bit Depth
1
File Formats
BTR, IBM IOCA, IBM MO:DCA, IMT,
LV, NCR, Adobe PDF, Adobe PS, TIFF
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, Silverlight, Photo Editing, MAC

Comments:

This is a 1-D version of the CCITT Group 3 compression scheme. It uses a static table of values to assign codes to run lengths. Frequently occurring run lengths are given smaller codes. (The most frequent are usually black runs of 2 or 4 pixels).


CCITT Group 3 2D Compression

Full Name
CCITT Group 3 2D
Compression ID
ImGearCompressions.CCITT_G32D = 5
IG Component
Core
Bit Depth
1
File Formats
BTR, IBM IOCA, IBM MO:DCA,
Adobe PDF, Adobe PS, TIFF
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, Silverlight, Photo Editing, MAC

Comments:

This is a 2-D version of the CCITT Group 3 compression scheme. It includes an error recovery algorithm for error transmissions; an error in one line does not translate to garbage output for the rest of the file. All modern fax machines support this format.


CCITT Group 4 Compression

Full Name
CCITT Group 4
Compression ID
ImGearCompressions.CCITT_G4 = 4
IG Component
Core
Bit Depth
1
File Formats
CAL, IBM IOCA, IBM MO:DCA, IMR,
IMT, KFX, LV, NCR, Adobe PDF, Adobe PS, TIFF
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, Silverlight, Photo Editing, MAC

Comments:

The G4 compression is two-dimensional by default. It is very similar to the G3 2D compression, but it can produce compressed images that are half the size of a G3-compressed file.

It is slower, however, and does not have the same error recovery built in that the G3 format has. The decrease in speed occurs because G4 was designed specifically for encoding disk data. For this reason, it may be advisable to use the G3-Fax compression scheme if final compression size is not crucial, but speed is.


Deflate Compression

Full Name
Deflate compression
Compression ID
ImGearCompressions.DEFLATE = 14
IG Component
Core
Bit Depth
1, 2, 4, 8, 16 bpc
File Formats
Adobe PDF, PNG, Adobe PS, TIFF
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, Silverlight, Photo Editing, MAC

Comments:

"Zip-in-TIFF" compression. Deflate compression, sometime known as "zip" compression, uses another variant of the LZW compression method and so gives similar results, but is not restricted by any licenses.


HD Photo Compression

Full Name
Microsoft HD Photo
Compression ID
IG_COMPRESSION_HDP = 26
IG Component
HD Photo
Bit Depth
Grayscale: 1, 8, 16 bpp; RGB: 24, 48 bpp; RGBA: 32, 64 bpp;
RGBPA: 32, 64 bpp; CMYK: 32, 64 bpp; CMYKEx: 40, 80 bpp;
Extra: 3...9 channels x 8, 16 bpp;
File Formats
HD Photo
IG Platforms Support
WIN32, .NET, Photo Editing

Comments:

Compression scheme used in the HD Photo (also known as WM Photo) image file format. HD Photo delivers a lightweight, high performance algorithm with a small memory footprint that enables practical, in-device encoding and decoding. It delivers compression quality comparable with JPEG-2000 and more than twice the quality of JPEG.

You need ImageGear.WPF Namespace to use this compression.


Huffman Compression

Full Name
Huffman encoding
Compression ID
ImGearCompressions.HUFFMAN = 2
IG Component
Core
Bit Depth
Any
File Formats
NCR, PCD, TIFF , KodakRAW, NEF, PEF
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, Silverlight, Photo Editing, MAC

Comments:

Developed in 1952 by David Huffman, this is one of the older compression methods. The encoding and decoding processes are complex relative to today's standards, but the compression ratio can be high if the image contains many repeat data values. It is best used for images with little or no pixel noise, e.g. cartoons or drawings with large areas of the same color and intensity (like a monotone sky). This compression scheme is often used by other compression algorithms for extra compression.

The Huffman method uses a conversion table to assign codes for each value, based on frequency of occurrence. The file is scanned for all of its values, with the values and their frequency of occurrence tallied. Using a binary tree, values are paired off by frequency of occurrence, beginning with the least frequent values. As the tree progresses upward, the least occurring values at the bottom of the tree continue to be incremented a bit at a time, with one bit added for each new branch added to the tree. In the end, the values that occur the most (at the top of the tree) have the shortest codes.

A potential problem with this compression method is decoding; the file's variable-length codes can cause the dropping or adding of a bit to the end of a line, thereby throwing off subsequent lines of data.


IBM MMR Compression

Full Name
IBM Modified Modified Read
Compression ID
ImGearCompressions.IBM_MMR = 15
IG Component
Core
Bit Depth
1
File Formats
IBM IOCA, IBM MO:DCA
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, Silverlight, MAC

Comments:

Compression for black and white documents, similar to CCITT Group 4.


JBIG Compression

JBIG compression scheme, used for bitonal images. Not supported by ImageGear for .NET.


JBIG2 Compression

JBIG compression scheme, used for bitonal images. Not supported by ImageGear for .NET.


JPEG Compression

Full Name
JPEG compression
Compression ID
ImGearCompressions.JPEG = 6
IG Component
Core
Bit Depth
Gray level: 8, 16 bpp; RGB: 24, 36 bpp; CMYK: 32 bpp; RGB+Alpha: 32 bpp
File Formats
JPEG, DICOM, Adobe DNG, Adobe PDF, Adobe PS, TIFF
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, Silverlight, Photo Editing, MAC

Comments:

This file compression method obtains a high compression ratio when used with detailed photographic images (its intended use). It is not a good compression choice for images with a small number of colors and high contrast edges, or for color-mapped data. Part of JPEGs success in high compression is due to the fact that it is a "lossy" compression method, meaning that the compression results in the loss of some data that is determined to be unimportant or unnecessary. This does not necessarily result in a visible reduction of image quality.

JPEG is highly flexible - it allows you to make a "quality" setting that determines the amount of loss that occurs and affects the size of the resulting compressed file.

The JPEG algorithm takes into account that the human eye is more sensitive to changes in brightness than to number of colors. Rather than saving the color data from each pixel in an image, it saves information on the rate of change of color, or "frequency information." More loss is allowed in the color data than in the brightness data. Some of the compression of the color is achieved by converting the RGB values to YCbCr color scheme. ImageGear supports two other JPEG compression modes--Lossless JPEG and Progressive JPEG.

See also: JPEG Lossless, JPEG Progressive.


JPEG2000 Compression

Full Name
JPEG 2000 wavelet compression
Compression ID
ImGearCompressions.JPEG2K = 25
IG Component
JPEG2K
Bit Depth
1..16 bpc, various colorspaces (depends on file format)
File Formats
JPEG2000, JPX, Motion JPEG2000, DICOM,
Adobe PDF, Adobe PS
IG Platforms Support
WIN32, WIN64, .NET, .NET64

Comments:

The JPEG2000 compression technique is based on two main processes: Tiling and Discrete Wavelet Transform (DWT).

Tiling

The term `tiling' refers to the partition of the original (source) image into rectangular non-overlapping blocks (tiles), which are compressed independently as though they were entirely distinct images. All operations, including component mixing, wavelet transform, quantization and entropy coding are performed independently on the image tiles. Tiling reduces memory requirements, and since they are also reconstructed independently, they can be used for decoding specific parts of the image rather than the entire image.

All tiles have exactly the same dimensions, except for those at the right and lower boundary of the image. Arbitrary tile sizes are allowed, up to and including the entire image (i.e., the whole image is regarded as one tile). Components with different sub-sampling factors are tiled with respect to a high-resolution grid, which ensures spatial consistency on the resulting tile components. Smaller tiles create more tiling artifacts compared to larger tiles.

Discrete Wavelet Transform (DWT)

The Discrete Wavelet Transform (DWT) is very similar to the Discrete Fourier Transform (DFT), but does not use the sine and cosine functions for analyzing the image data. The basic functions are called scaling functions and wavelets. These functions combine the fundamental feature of orthogonality (allowing the transformation and the identical reconstruction) and compact representation. This allows the analysis of image data without the windowing effects, which result from the need to handle the infinite sine function on finite image data using the DFT.

Images can be seen as two dimensional signals. They can be transformed using a two dimensional transformation. Two dimensional transformations can be achieved by separately applying one dimensional transformations to the lines and columns of an image. The DWT method splits the image into four new images in the wavelet domain; one image contains the low-pass information and the others contain high-pass information of horizontal, vertical and diagonal orientation. The transformation then applies itself recursively to the low-pass image. This can be continued until the last low-pass image contains only a single pixel.

The tile components of JPEG2000 images are decomposed into different decomposition levels using Discrete Wavelet Transform. These decomposition levels contain a number of subbands, which consist of coefficients that describe the horizontal and vertical spatial frequency characteristics of the original tile component. Power of two decompositions are allowed in the form of dyadic decomposition (in Part I).

To perform the forward DWT, the standard uses a one dimensional subband decomposition of a one dimensional set of samples into low-pass samples and high-pass samples. Low-pass samples represent a downsampled low-resolution version of the original set. High-pass samples represent a downsampled residual version of the original set, needed for the perfect reconstruction of the original set from the low-pass set.

The DWT can be irreversible or reversible. The default irreversible transform is implemented by means of the Daubechies 9-tap/7-tap filter. The default reversible transformation is implemented by means of the 5-tap/3-tap filter.

The standard supports two filtering modes: a convolution-based mode and a lifting-based mode. For both modes to be implemented, the signal should first be extended periodically. This periodic symmetric extension is used to ensure that for the filtering operations that take place at both boundaries of the signal, one signal sample exists and spatially corresponds to each coefficient of the filter mask. The number of additional samples required at the boundaries of the signal is, therefore, filter-length dependent.

Convolution-based filtering performs a series of dot products between the two filter masks and the extended one dimensional signal. Lifting-based filtering consists of a sequence of very simple filtering operations for which alternately odd sample values of the signal are updated with a weighted sum of even sample values. Even sample values are updated with a weighted sum of odd sample values. For the reverse (lossless) case, the results are rounded to integer values.

The 5/3 filter allows repetitive encoding and decoding of an image without any additional loss. This is true when the decompressed image values are not clipped when they fall outside the full dynamic range (i.e. 0-255 for an 8-bpp image).


Lossless JPEG Compression

Full Name
Lossless JPEG compression
Compression ID
ImGearCompressions.JPEG = 6
IG Component
Core
Bit Depth
Gray level: 8, 16 bpp; RGB: 24, 48 bpp
File Formats
DICOM, JPEG, TIFF
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, Silverlight, Photo Editing, MAC

Comments:

Lossless JPEG is an extension to the normal JPEG standard. One of the main algorithmic differences between the two is that the lossless JPEG does not apply a Discrete Cosine Transform. Rather, it uses a Predictive scheme. For each pixel, the values of one or several neighboring pixels are added to the value of the original pixel and then subtracted from the value of the original pixel. This method yields smaller values that require fewer bits per pixel to store.

ImageGear allows you to set the number of neighboring pixels to use in calculating the "predictor value".


LZW (Lempel-Ziv-Welch) Compression

Full Name
Lempel-Zif-Welch (LZW) compression
Compression ID
ImGearCompressions.LZW = 8
IG Component
GIF/TIFF-LZW
Bit Depth
1, 4, 8, 16 bpc
File Formats
GIF, Adobe PDF, Adobe PS, TIFF
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, Silverlight, Photo Editing, MAC

Comments:

LZW compression works by finding patterns of data and assigning codes. It works best on highly-patterned images. Images with irregular patterning, or "noise," are not good candidates for this type of compression.

This compression scheme is "dictionary-based". This refers to the array of codes that identify each data pattern found in the image. The "dictionary" begins with a table that contains a code for each possible value in the image. If LZW compression is used on 8-bit images, a LZW "dictionary" is initialized with codes for 256 (28) values. As the file data is read, new values are added to the table for each unique pattern of data found. In the interest of saving space, the dictionary is not saved with the compressed file. The same dictionary is actually rebuilt when the data is decoded.


Packbits Compression

Full Name
Packed bits compression
Compression ID
ImGearCompressions.PACKED_BITS = 1
IG Component
Core
Bit Depth
1, 4, 8, 16 bpc
File Formats
Adobe PSD, TIFF
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, Silverlight, Photo Editing, MAC

Comments:

Packbits compression seeks repeated data values. Packbits is considered an RLE (run-length encoding) compression scheme because it looks for "runs" or repeated values, and tallies their number, or "length". While its name implies that runs of bits are "packed" together, it is actually runs of bytes. It is very similar to the Macintosh Packbits compression used by Macpaint, except that the Packbits compression used for a TIFF allows the dimensions of the image to vary.

Packbits works by reducing repeated strings of the same characters into two components: the "run count" and the "run value". The count and value are stored in one byte each. Each two-byte grouping is referred to as an RLE packet. It is not a good compression scheme for images with large color ranges, as these do not tend to have many runs of the same color.


Progressive JPEG Compression

Full Name
Progressive JPEG compression
Compression ID
IG_COMPRESSION_PROGRESSIVE = 17
IG Component
Core
Bit Depth
Gray level: 8, 16 bpp; RGB: 24, 36 bpp; CMYK: 32 bpp; RGB+Alpha: 32 bpp
File Formats
JPEG
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, Silverlight, Photo Editing, MAC

Comments:

Progressive JPEG is considered an extension to the JPEG standard. It produces the same kind of lossy compression as normal JPEG compression (see above), except that it saves multiple copies of the same image using different levels of quality. There is no hard limit on the number of "scans" that may be stored.

When a Progressive JPEG-compressed image is decompressed, the filter decompresses the lowest quality image first. This can be helpful for quickly displaying a version of the image that you are loading. The benefit of this compression is the fast display of an image that is recognizable. The downside is that a JPEG decompression is performed more than once.


RAW Compression

Full Name
RAW compression (Uncompressed binary compression)
Compression ID
ImGearCompressions.RAW = 2
IG Component
Core
Bit Depth
Gray level: 1, 8, 16 bpp; RGB 24, 48 bpp
File Formats
PBM, PGM, PNM, PPM
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, Silverlight, MAC

Comments:

Uncompressed binary compression. PBM/PGM/PNM/PPM formats use the term "RAW" for uncompressed binary compression, as opposed to ASCII compression.


RLE Compression

Full Name
Run length encoding compression
Compression ID
ImGearCompressions.RLE = 7
IG Component
Core
Bit Depth
1, 4, 8, 16 bpc
File Formats
BMP, CLP, CUT, DCX, DICOM, GEM, IFF, MSP,
PCX, Adobe PDF, Adobe PS, RAS, SGI, TGA, WMF, WPG
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, Silverlight, Photo Editing, MAC

Comments:

RLE (Run Length Encoding) is normally a 1-dimensional compression scheme. Working sequentially from left to right and top to bottom, it compares the value of each byte with the value of the previous byte. Each data value is recorded into a "packet" of two bytes where the first byte contains the number of times the value is repeated, and the second packet contains the actual value. The bytes in the pocket are called the "run count" and the "run value". When an image contains many repeat values, the compression ratio is very high (for example, if every byte in a 100 byte image were the same, its size could be reduced to 2 bytes giving a 50:1 ratio). A very noisy image, or a plain ASCII text file typically does not compress well, and in fact could become larger for example, if all bytes in image are different from the ones next to them, the image doubles, because 2 bytes are used to store each byte in the image.


ImageGear Supported File Formats Reference

This section represents the reference for every imaging file format supported by ImageGear.

The following are the characteristic features for file format description:

  • Full Name - Full name of the File Format
  • Format ID - ImageGear constant that determines the File Format ID used for loading this file in ImageGear-based application.
  • File Extension(s) - The used extensions of the File Format
  • Data Type - The type of the File Format (raster, vector, metafile)
  • Data Encoding - The type of data encoding. Please see the section Encoding vs. Compressing.
  • IG Multipage Support - Shows if ImageGear supports the File Format as multipage or singlepage. Please see also the section Support for Multi-Page File Formats.
  • IG Alpha Channel Support - Shows if ImageGear supports the alpha channel for the File Format or not. Please see also the section ImageGear Alpha Channel Support.
  • IG Platforms Support - Shows ImageGear platform versions that support the File Format.
  • ImageGear Supported versions - Shows the versions of the File Format supported by ImageGear.
  • ImageGear Supported Features - Shows the ImageGear Format Filter features supported by ImageGear for this format.
  • ImageGear Read Support - Provides all compressions, color spaces, channels and bit depths supported by ImageGear for the file format reading.
  • ImageGear Write Support - Provides all compressions, color spaces, channels and bit depths supported by ImageGear for the file format writing.
  • ImageGear Filter Control Parameters - Provides all filter control parameters supported by ImageGear for this format filter.
  • Comments - Some general information about format encoding and compression structure.
  • References Used - References to the information sources for the File Format.

Currently ImageGear supports the following File Formats:

Format
Read/Write
Description
Adobe DNG
Read
Digital Negative file format
Adobe PDF
Read/Write
Adobe PDF file format. Requires ImageGear.Formats.PDF Namespace.
Adobe PS
Read/Write
Adobe PostScript file format. Requires ImageGear.Formats.PDF Namespace.
Adobe PSB
Read/Write
Adobe Photoshop Big
Adobe PSD
Read/Write
Adobe Photoshop
BMP
Read/Write
Standard Windows format including OS/2 bitmap format
BTR
Read/Write
Brooktrout FAX format, Group III or Group III 2D or 301
CAL
Read/Write
CALS raster, Type I
CGM
Read/Write
Computer Graphics Metafile. Requires ImageGear.Formats.CGM Namespace.
CLP
Read/Write
Windows Clipboard format for raster images
CUR
Read/Write
For reading Windows 3.x and Windows95 mouse cursor display.
CUT
Read/Write
Dr. Halo CUT format
DCRAW
Read
Digital Camera RAW format
DCX
Read/Write
Intel multi-page FAX format
DGN
Read
MicroStation Drawing (Drawing format used by MicroStation construction design software). Requires ImageGear.Formats.DGN Namespace.
DIB
Read/Write
DIB (Microsoft Windows Device Independent Bitmap).
DICOM
Read/Write
DICOM is a public standard that provides a flexible and expandable means for storing, sharing, and transporting digital medical images. Requires ImageGear.Formats.DICOM Namespace .
DWF
Read
Used for publishing 2D and 3D CAD drawings so they can be easily viewed without requiring the use of CAD software. Requires ImageGear.Formats.DWF namespace. Requires ImageGear.Vector Namespace .
DWG
Read/Write
DWG (AutoDesk AutoCAD) format. Requires ImageGear.Formats.CAD Namespace.
DXF
Read/Write
DXF (AutoDesk AutoCAD) format. Requires ImageGear.Formats.CAD Namespace.
GEM
Read
GEM Paint Raster format
GIF
Read/Write
Graphic Image Format developed originally in accommodate the transmission of images via a modem; uses LZW compression algorithm.
HD Photo
Read/Write
HD Photo (Windows Media Photo).
HPGL
Read
Hewlett-Packard Graphics Language format. Requires ImageGear.Formats.HPGL Namespace.
IBM IOCA
Read/Write
Image Object Content Architecture, Group III, Group III 2D, Group IV, IBM MMR, uncompressed.
IBM MO:DCA
Read/Write
Mixed Object Document Content Architecture format, Group III, Group III 2D, Group IV, IBM MMR, uncompressed.
ICO
Read/Write
Windows ICON format.
IFF
Read/Write
Electronic Arts format.
IMG
Read
Xerox raster format, Group IV
IMR
Read
IMRS-Raster image format.
IMT
Read
IMNET format, Groups III and IV.
JPEG
Read/Write
ANSI-standard, full-color image format; IG supports all aspects of this format including lossless and progressive; JFIF - industry standard header for JPEG compressed images
JPEG2000
Read/Write
New JPEG 2000 standard, based on the EBCOT (Embedded Block Coding with Optimized Truncation of the embedded bitstreams) algorithm; requires ImageGear.Formats.JPEG2K Namespace
JPX
Read/Write
JPX file format is an extension to JPEG 2000 file format. Requires ImageGear.Formats.JPEG2K Namespace.
KFX
Read
Kofax format, Group IV
LV
Read
LaserView, LaserData, Group IV
MEF
Read
Mamiya digital camera RAW format
Motion JPEG2000
Read
Motion JPEG2000 file format is designed to contain one or more motion sequences of JPEG2000 images. Requires ImageGear.Formats.JPEG2K Namespace.
MSP
Read
Microsoft Paint format
NCR
Read/Write
NCR Group IV format.
PBM
Read/Write
Portable BitMap (UNIX graphic file format)
PCD
Read
Kodak format for high resolution photographs
PCX
Read/Write
PC Paintbrush format
PGM
Read/Write
Portable BitMap (UNIX graphic file format)
PNG
Read/Write
Portable Network Graphics, intended as successor to GIF
PNM
Read/Write
Portable BitMap (UNIX graphic file format)
PPM
Read/Write
Portable BitMap (UNIX graphic file format)
PTOCA
Read
Presentation Text Object Content Architecture support for IBM's AFP printer architecture.
RAS
Read/Write
SUN raster format
Scitex CT
Read/Write
For electronic pre-press and visual communications systems, part of the HandShake Foreign File Transfer Protocol, a standard for defining storage formats and data interchange protocols
SGI
Read/Write
Silicon Graphics raster format
TGA
Read/Write
Targa file format. ImageGear supports many aspects of this format including alpha channel
TIFF
Read/Write
Tagged Image File Format; IG supports every aspect of this format
U3D
Read/Write
Universal 3D format. Requires ImageGear.Formats.U3D Namespace.
WBMP
Read/Write
Optimized to support mobile computing devices that use the Wireless Application Protocol (WAP).
WMF
Read/Write
Windows Metafile Format
WPG
Read
Wordperfect Graphic Format. IG reads bitmaps stored in this format
XBM
Read/Write
X Windows Bitmap format
XPM
Read/Write
X Windows Pixmap format
XPS
Read/Write
Vector image (XML Paper Specification)
XWD
Read/Write
X Windows Dump format

See Also:

ImageGear Supported Digital Camera RAW Formats Reference

Particular Cameras Supported DC RAW Formats


Adobe DNG

Full Name
Digital Negative file format
Format ID
ImGearFormats.DNG
File Extension(s)
*.dng
Data Type
Bitmap (2D raster)
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64, Silverlight, Photo Editing

ImageGear Supported versions:

  • Version 1.0.0.0
  • Version 1.1.0.0 - fixed incompatibility in JPEG Lossless compression, added new tags

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

  • ImGearCompressions.NONE
    • Without color reconstruction: Grayscale - 16 bpp;
    • With color reconstruction: RGB - 24, 48 bpp*
  • ImGearCompressions.JPEG
    • Without color reconstruction: Grayscale - 16 bpp;
    • With color reconstruction: RGB - 24, 48 bpp*

* 8bpc DNG loading has been enabled via promoting the image to 16bpc before loading.

ImageGear Write Support:

None.

ImageGear Filter Control Parameters:

See DCRAW Filter Control Parameters.

Comments:

This file format was developed by Adobe as a non-proprietory format for unified storage of "raw" images from digital cameras. DNG image stores unprocessed pixel data obtained from camera's sensor, and keeps information about color, contrast and brightness adjustments, sharpening, as well as many other parameters, in its tags. This provides greater possibilities for image correction and enhancement, compared to commonly used formats such as JPEG, EXIF or TIFF.

The fact that the format is non-proprietary allows software vendors to provide support for DNG in their applications, with complete control over the image reconstruction process.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

DNG extends TIFF/EP format. It adds a set of new tags for parameters that control reconstruction of full color image from the raw data.

References used

ADOBE SYSTEMS INCORPORATED. Digital Negative (DNG) specification.


Adobe PDF

Full Name
Adobe PDF (Adobe Portable Document Format)
Format ID
ImGearFormats.PDF
File Extension(s)
*.pdf
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
Yes
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, MAC, .NET

NOTE: PDF format requires ImageGear.Formats.PDF Namespace.

ImageGear Supported versions:

  • Adobe® PDF version 1.7
  • Adobe® PDF version 1.6
  • Adobe® PDF version 1.5

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing
  • IGFilterFormatFlags.MPAGEWRITEPSUPPORT - multipage file writing
  • IGFilterFormatFlags.PAGEDELETESUPPORT - page deleting from multi-page file
  • IGFilterFormatFlags.PAGESWAPSUPPORT - page swaping in multi-page files

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32 bpp
  • ImGearCompressions.DEFLATE:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32 bpp
  • ImGearCompressions.CCITT_G3:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G4:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G32D:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.JPEG:
    • Grayscale: 8 bpp;
    • Indexed RGB: 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32 bpp
  • ImGearCompressions.JPEG2K:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32 bpp
  • IG_COMPRESSION_JBIG2:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.LZW:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8 bpp;

ImageGear Write Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32 bpp
  • ImGearCompressions.DEFLATE:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32 bpp
  • ImGearCompressions.CCITT_G3:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G4:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G32D:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.JPEG:
    • Grayscale: 8 bpp;
    • Indexed RGB: 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32 bpp
  • ImGearCompressions.JPEG2K:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32 bpp
  • IG_COMPRESSION_JBIG2:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.LZW:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8 bpp

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
DefaultCompression
ImGearCompressions Enumeration
ImGearCompressions Enumeration.NONE
Any ImGearCompressions Enumeration value
This parameter specifes a compression used for encoding a raster page added/inserted into the PDF document by using ImGearDocument Class.Pages methods.
Depth
Int32
24
1, 8, 24
This parameter specifies bit depth in bits-per-pixel during the PDF document conversion into the raster image. The greater this value, the higher the quality of the raster image you get and the more memory required for rasterization. The DIB of the output raster image has this value as a bit count
DrawMode
ImGearPDFPageDrawMode Enumeration
ImGearPDFPageDrawMode Enumeration.ENTIRE_PAGE
One of the ImGearPDFPageDrawMode Enumeration values
This parameter specifes default PDF rendering method used by the ImageGear PDF component to draw PDF page content.
IndependentPagesize
Bool
false
true, false
If this parameter is false, when saving araster image into the PDF document, the width and height of the newly created page is set to the width and height of the previous page from the PDF document. If the previous page does not exist, the width and height are calculated from the image resolution and size as follows:
Width = <width of the raster image> * 72 / <X DPI of the raster image>
Height = < height of the raster image> * 72 / <Y DPI of the raster image>
If the image resolution is not defined, the width and height are set to the width and height of the A4 page, which is 612 x 792. If this parameter is true, the following parameters are used to set the page size:
PageHeight
PageWidth
IncRend
Bool
False
True, False
This parameter specifies the way of drawing rendering. The true value sets incremental (stripe by stripe) rendering mode, the false value sets rendering as a single bitmap.
PageHeight
Int32
0
Any non-negative value
This parameter sets the height of the page (in 1/72 inches). If this option is 0, the height is calculated from the image resolution and size as follows:
Height = < height of the raster image> * 72 / <Y DPI of the raster image>
If the image resolution is not defined, the height is set to the height of the A4 page, which is 792. This parameter is not used if IndependentPagesize is false.
PageWidth
Int32
0
Any non-negative value
This parameter sets the width of the page (in 1/72 inches). If this option is 0, the width is calculated from the image resolution and size as follows:
Width = <width of the raster image> * 72 / <X DPI of the raster image>
If the image resolution is not defined, the width is set to the width of the A4 page, which is 612. This parameter is not used if IndependentPagesize is false.
Password
String
""
Any string
This parameter specifies password string for password protected PDF documents.
PrintDepth
Int32
8
1, 8, 24
This parameter specifies bit depth in bits-per-pixel during the PDF document printing. The greater this value, the higher the quality of the raster image you get and the more memory required for printing.
PrintResolutionX
Int32
300
Any
This parameter specifies the horizontal resolution in dots-per-inch during PDF document printing. The greater this value, the higher the quality of the printed image.
PrintResolutionY
Int32
300
Any
This parameter specifies the vertical resolution in dots per inch during the PDF document printing. The more this value the more quality image is printed.
Resolution3D
UInt
72
Any, except zero
This parameter specifies the resolution in dots per inch used for generating a pre-rendered bitmap of the default view of the 3D artwork. Producers should provide bitmaps of appropriate resolution for all intended uses of the document; i.e., a high-resolution bitmap for high-quality printing, and a default screen-resolution bitmap for on-screen viewing.
ResolutionX
Int32
72
Any
This parameter specifies the horizontal resolution in dots-per-inch during the PDF document conversion into a raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image has this value as an X resolution.
ResolutionY
Int32
72
Any
This parameter specifies the vertical resolution in dots-per-inch during the PDF document conversion into the raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image has this value as an Y resolution.
SaveFlags
ImGearPDFSaveFlags Enumeration
ImGearPDFSaveFlags Enumeration.FULL | ImGearPDFSaveFlags Enumeration.COLLECT_GARBAGE
A bit composition of an OR of ImGearPDFSaveFlags Enumeration values
This parameter specifes an option for saving a PDF file, which allows you to remove unreferenced objects, often reducing file size as well as to write a linearized file for page-served remote (network) access.
SaveMajor
Int32
0
1
Specifies major PDF version number of the document for saving. If major equals 0, both major and minor are ignored and the document is saved to the library's default version. Make sure that the document conforms to the version number you are setting.
SaveMinor
Int32
0
6, 5, 4, etc.
Specifies minor PDF version number of the document for saving. Make sure that the document conforms to the version number you are setting.
SmoothFlags
ImGearPDFSmoothFlags Enumeration
ImGearPDFSmoothFlags Enumeration.SMOOTH_IMAGE | ImGearPDFSmoothFlags Enumeration.SMOOTH_TEXT
A bit composition of an OR of ImGearPDFSmoothFlags Enumeration values
This parameter specifes smooth settings for PDF rasterization.
TextEncoding
ImGearPDFTextEncoding Enumeration
ImGearPDFTextEncoding Enumeration.ASCII_85
Any ImGearPDFTextEncoding Enumeration value
This parameter specifies which encoding scheme should be used to convert binary image data to the text format when saving raster image into the PDF document.

Comments:

Please see the section ImageGear.Formats.PDF Namespace.


Adobe PS

Full Name
Adobe PS (Adobe PostScript)
Format ID
ImGearFormats.PS
File Extension(s)
*.ps, *.eps
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
Yes
IG Alpha Channel Support
No
IG Platforms Support
WIN32, Unix, MAC, .NET

NOTE: PS format requires ImageGear.Formats.PDF Namespace.

ImageGear Supported versions:

  • Adobe® PS v3

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing
  • IGFilterFormatFlags.MPAGEWRITEPSUPPORT - multipage file writing
  • IGFilterFormatFlags.PAGEDELETESUPPORT - page deleting from multi-page file
  • IGFilterFormatFlags.PAGESWAPSUPPORT - page swaping in multi-page files

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1,4,8 bpp;
    • Grayscale - 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32bpp
  • ImGearCompressions.DEFLATE:
    • Indexed RGB: 1,4,8 bpp;
    • Grayscale - 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 1,4,8 bpp;
    • Grayscale - 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32bpp
  • ImGearCompressions.CCITT_G3:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G4:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G32D:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.JPEG:
    • Indexed RGB: 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32bpp
  • ImGearCompressions.JPEG2K:
    • Indexed RGB: 1,4,8 bpp;
    • Grayscale - 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32bpp
  • IG_COMPRESSION_JBIG2:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.LZW:
    • Indexed RGB: 1,4,8 bpp;
    • Grayscale - 8 bpp

ImageGear Write Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1,4,8 bpp;
    • Grayscale - 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32bpp
  • ImGearCompressions.DEFLATE:
    • Indexed RGB: 1,4,8 bpp;
    • Grayscale - 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 1,4,8 bpp;
    • Grayscale - 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32bpp
  • ImGearCompressions.CCITT_G3:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G4:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G32D:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.JPEG:
    • Indexed RGB: 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32bpp
  • ImGearCompressions.JPEG2K:
    • Indexed RGB: 1,4,8 bpp;
    • Grayscale - 8 bpp;
    • RGB: 24 bpp;
    • CMYK: 32bpp
  • IG_COMPRESSION_JBIG2:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.LZW:
    • Indexed RGB: 1,4,8 bpp;
    • Grayscale - 8 bpp

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
Depth
Int32
24
1, 8, 24
This parameter specifies bit depth in bits-per-pixel during the PostScript document conversion into the raster image. The greater this value, the higher the quality of the raster image you get and the more memory is required for rasterization. The DIB of the output raster image has this value as a bit count.
Height
Int32
0
Any non-negative value.
This parameter sets the height of the page (in 1/72 inches). This parameter is used on loading a PostScript page. When this parameter is set to 0, the height is read from PostScript bounding box. If bounding box is not defined in PostScript, the height is set to 792.
IndependentPagesize
Bool
false
true, false
If this parameter is false, when saving raster image into the PDF document, the width and height of the newly created page is set to the width and height of the previous page from the PDF document. If the previous page does not exist, the width and height are calculated from the image resolution and size as follows:
Width = <width of the raster image> * 72 / <X DPI of the raster image>
Height = < height of the raster image> * 72 / <Y DPI of the raster image>
If the image resolution is not defined, the width and height are set to the width and height of the A4 page, which is 612x792. If this parameter is true the following parameters are used to set the page size:
PageHeight
PageWidth
Level
ImGearPSLevel Enumeration
ImGearPSLevel Enumeration.LEVEL_3
Any ImGearPSLevel Enumeration value
This parameter specifies a language level of the output PostScript 3.0 document when saving to PostScript.
PageHeight
Int32
0
Any non-negative value
This parameter sets the height of the page (in 1/72 inches). If this option is 0, the height is calculated from the image resolution and size as follows:
Height = < height of the raster image> * 72 / <Y DPI of the raster image>
If the image resolution is not defined, the height is set to the height of the A4 page, which is 792. This parameter is not used if IndependentPagesize is false.
PageWidth
Int32
0
Any non-negative value
This parameter sets the width of the page (in 1/72 inches). If this option is 0, the width is calculated from the image resolution and size as follows:
Width = <width of the raster image> * 72 / <X DPI of the raster image>
If the image resolution is not defined, the width is set to the width of the A4 page, which is 612. This parameter is not used if IndependentPagesize is false.
ResolutionX
Int32
72
Any
This parameter specifies the horizontal resolution in dots-per-nch during the PostScript document conversion into the raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image has this value as an X resolution.
ResolutionY
Int32
72
Any
This parameter specifies the vertical resolution in dots-per-inch during the PostScript document conversion into the raster image. The greater this value, the higher the quality of the raster image you get after rasterization. The DIB of the output raster image has this value as an Y resolution.
SmoothFlags
ImGearPDFSmoothFlags Enumeration
ImGearPDFSmoothFlags Enumeration.SMOOTH_IMAGE | ImGearPDFSmoothFlags Enumeration.SMOOTH_TEXT
A bit composition of an OR of ImGearPDFSmoothFlags Enumeration values
This parameter specifes smooth settings for PostScript rasterization.
TextEncoding
ImGearPDFTextEncoding Enumeration
ImGearPDFTextEncoding Enumeration.ASCII_85
Any ImGearPDFTextEncoding Enumeration value
This parameter specifies which encoding scheme should be used to convert binary image data to the text format when saving raster image into the PostScript document.
Type
ImGearPSType Enumeration
ImGearPSType Enumeration.POSTSCRIPT
Any ImGearPSType Enumeration value
This parameter specifies a type of the output PostScript document when saving to PostScript.
Width
Int32
0
Any non-negative value
This parameter sets the width of the page (in 1/72 inches). This parameter is used on loading a PostScript page. When this parameter is set to 0, the width is read from PostScript bounding box. If bounding box is not defined in PostScript, the width is set to 612.
AutoPosition
Bool
true
true, false
This parameter enables/disables AutoPositionEPSFiles option for reading PS/EPS file format.
JobOptionsFile
String
""
Any
This parameter specifies a path to Adobe job options file name.

Comments:

Please see the section ImageGear.Formats.PDF Namespace.


Adobe PSB

Full Name
PSB (Adobe Photoshop Big)
Format ID
ImGearFormats.PSB
File Extension(s)
*.psb
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
Yes
IG Alpha Channel Support
Supports pre-multiplied Alpha and aditional Alpha mask channels as ImageGear Extra channels.
IG Platforms Support
.NET, .NET64, .NET Compact Framework, Silverlight, Photo Editing

ImageGear Supported versions:

  • Version 2.0
  • Version 2.5
  • Version 3.0
  • Version 8.0

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 8 bpp;
    • Grayscale: 8, 16 bpp;
    • Grayscale + Alpha: 8, 16 bpp;
    • RGB: 24, 48 bpp;
    • RGB + Alpha: 32, 64 bpp;
    • RGB + Alpha + Extra: 8, 16 bpc;
    • RGB + Extra: 8, 16 bpc;
    • CMYK: 32, 64 bpp;
    • CMYK + Alpha: 40, 80 bpp;
    • CMYK + Alpha + Extra: 8, 16 bpc;
    • CMYK + Extra: 8, 16 bpc;
    • LAB + Alpha: 32, 64 bpp;
    • Lab + Alpha + Extra: 8, 16 bpc;
    • Lab + Extra: 8, 16 bpc;
    • HSL + Alpha: 32, 64 bpp;
    • HSL + Alpha + Extra: 8, 16 bpc;
    • HSL + Extra: 8, 16 bpc;
  • ImGearCompressions.PACKED_BITS:
    • Indexed RGB: 1, 8 bpp;
    • Grayscale: 8, 16 bpp;
    • Grayscale + Alpha: 8, 16 bpp;
    • RGB: 24, 48 bpp;
    • RGB + Alpha: 32, 64 bpp;
    • RGB + Alpha: + Extra 8, 16 bpc;
    • RGB + Extra: 8, 16 bpc;
    • CMYK: 32, 64 bpp;
    • CMYK + Alpha: 40, 80 bpp;
    • CMYK + Alpha + Extra: 8, 16 bpc;
    • CMYK + Extra: 8, 16 bpc;
    • LAB + Alpha: 32, 64 bpp;
    • Lab + Alpha + Extra: 8, 16 bpc;
    • Lab + Extra: 8, 16 bpc;
    • HSL + Alpha: 32, 64 bpp;
    • HSL + Alpha + Extra: 8, 16 bpc;
    • HSL + Extra: 8, 16 bpc;

ImageGear Write Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 8 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp;
    • RGB + Extra: 8, 16 bpc;
    • CMYK: 32, 64 bpp;
    • CMYK + Extra: 8, 16 bpc;
    • Lab: 24, 48 bpp
    • Lab + Extra: 8, 16 bpc;
  • ImGearCompressions.PACKED_BITS:
    • Indexed RGB: 1, 8 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp;
    • RGB + Extra: 8, 16 bpc;
    • CMYK: 32, 64 bpp;
    • CMYK + Extra: 8, 16 bpc;
    • Lab: 24, 48 bpp
    • Lab + Extra: 8, 16 bpc;

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
LoadFirstExtraChannelAsAlpha
bool
false
false, true
This parameter specifies how ImageGear should load the first extra channel of a PSB image. If false, ImageGear loads all extra channels according to their descriptors in the file header. If the channel contains transparency information, ImageGear loads it as Alpha channel. Otherwise IG loads it as Extra channel.
If true, IG loads first extra channel as Alpha channel. This mode provides backward compatibility with previous versions of ImageGear.
ReadLayerIndex
int
-1
Any integer, but no more than number of layers
When > -1 specifies a zero based index of layer mask image to load, otherwise reads the composition image.

Non-Image Data Structure:

Adobe PSB/PSD file format has different non-image data that can be stored before and after an image data. The Adobe PSB/PSD metadata design allows reading and writing the following non-image data (exactly like in System.Windows.Media.Imaging.BitmapMetadata; strings by default):

Tag name
Tag ID
Description
Signature
ImGearPSBTagIDs.SIGNATURE
Adobe Photoshop Signature: always equal to '8BPS'.
Version
ImGearPSBTagIDs.VERSION
Version: always equal to 1.
Rows
ImGearPSBTagIDs.ROWS
The height of the image in pixels. Supported range is 1 to 30,000.
Cols
ImGearPSBTagIDs.COLS
The width of the image in pixels. Supported range is 1 to 30,000.
Depth
ImGearPSBTagIDs.DEPTH
Depth: the number of bits per channel. Supported values are 1, 8, and 16.
ColorMode
ImGearPSBTagIDs.MODE
The color mode of the file. Supported values are: Bitmap = 0; Grayscale = 1; Indexed = 2; RGB = 3; CMYK = 4; Multichannel = 7; Duotone = 8; Lab = 9.
ColorModeLength
ImGearPSBTagIDs.MODE_LEN
The length of the following color data provided by tag ColorData.
ColorData
ImGearPSBTagIDs.COLOR_DATA
The color data.
PhotoshopResources
ImGearPSBTagIDs.PHOTOSHOP_RESOURCES
Photoshop Image Resource metadata group. Image resources are used to store non-pixel data associated with images.
Layers
ImGearPSBTagIDs.LAYERS
Photoshop Image Layer Info metadata group. Represents high-level organization of the layers information.
LayerCount
ImGearPSBTagIDs.LAYER_COUNT
Number of layers in the Photoshop Image.
Header
ImGearPSBTagIDs.HEADER
This section contains the basic properties of the image.
RESERVED_HDR
ImGearPSBTagIDs.RESERVED_HDR
Reserved: must be zero.
Channels
ImGearPSBTagIDs.CHANNELS
The number of channels in the image, including any alpha channels. Supported range is 1 to 56.
IPTC_NAA
ImGearPSBTagIDs.IPTC_NAA
File information (IPTC-NAA record 2).

Comments:

The PSB (Photoshop Big), or Large Document format, is a newer version of PSD designed for files over 2 gigabytes, supporting up to 300,000 pixels in any dimension. The PSB format is identical to the Photoshop native format (PSD) in many ways.

The PSB/PSD file is considered by many in the computer graphics arts community as an industry standard.

The PSB/PSD is organized into 5 major segments of data: the header, 3 informational blocks, and the bitmap data. The short header always contains a "signature" of 8PPS, as well as these fields: width, height, and bit depth of the bitmap.

The first block of informational data is called the "Color Mode Data Block". It begins with a value for the length of the block. If the image has a palette, it is located here.

The next block is called the "Image Resources Block". Like the previous block, it first gives the length of the block. An ID field is filled with one of many possible values that indicate the structure where the data is stored. It may contain such parameters as resolution.

The last informational block is called the "Layer and Mask Instruction Block". After a value for the length of the block, it tells how many "layer records" follow. There is a record for each layer in the image. Each record begins with a channel ID and the length of the data in the record. After the records, a "Layer Mask" section may be stored, if applicable.

The bitmap data represents the last segment of a PSB/PSD file.

References used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats, 2d ed. Sebastopol, CA: O'Reilly & Associates, Inc., 1996.


Adobe PSD

Full Name
PSD (Adobe Photoshop)
Format ID
ImGearFormats.PSD
File Extension(s)
*.psd
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
Yes
IG Alpha Channel Support
Supports pre-multiplied Alpha and aditional Alpha mask channels as ImageGear Extra channels.
IG Platforms Support
.NET, .NET64, .NET Compact Framework, Silverlight, Photo Editing

ImageGear Supported versions:

  • Version 2.0
  • Version 2.5
  • Version 3.0
  • Version 8.0

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 8 bpp;
    • Grayscale: 8, 16 bpp;
    • Grayscale + Alpha: 8, 16 bpp;
    • RGB: 24, 48 bpp;
    • RGB + Alpha: 32, 64 bpp;
    • RGB + Alpha + Extra: 8, 16 bpc;
    • RGB + Extra: 8, 16 bpc;
    • CMYK: 32, 64 bpp;
    • CMYK + Alpha: 40, 80 bpp;
    • CMYK + Alpha + Extra: 8, 16 bpc;
    • CMYK + Extra: 8, 16 bpc;
    • LAB + Alpha: 32, 64 bpp;
    • Lab + Alpha + Extra: 8, 16 bpc;
    • Lab + Extra: 8, 16 bpc;
    • HSL + Alpha: 32, 64 bpp;
    • HSL + Alpha + Extra: 8, 16 bpc;
    • HSL + Extra: 8, 16 bpc;
  • ImGearCompressions.PACKED_BITS:
    • Indexed RGB: 1, 8 bpp;
    • Grayscale: 8, 16 bpp;
    • Grayscale + Alpha: 8, 16 bpp;
    • RGB: 24, 48 bpp;
    • RGB + Alpha: 32, 64 bpp;
    • RGB + Alpha: + Extra 8, 16 bpc;
    • RGB + Extra: 8, 16 bpc;
    • CMYK: 32, 64 bpp;
    • CMYK + Alpha: 40, 80 bpp;
    • CMYK + Alpha + Extra: 8, 16 bpc;
    • CMYK + Extra: 8, 16 bpc;
    • LAB + Alpha: 32, 64 bpp;
    • Lab + Alpha + Extra: 8, 16 bpc;
    • Lab + Extra: 8, 16 bpc;
    • HSL + Alpha: 32, 64 bpp;
    • HSL + Alpha + Extra: 8, 16 bpc;
    • HSL + Extra: 8, 16 bpc;

ImageGear Write Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 8 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp;
    • RGB + Extra: 8, 16 bpc;
    • CMYK: 32, 64 bpp;
    • CMYK + Extra: 8, 16 bpc;
    • Lab: 24, 48 bpp
    • Lab + Extra: 8, 16 bpc;
  • ImGearCompressions.PACKED_BITS:
    • Indexed RGB: 1, 8 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp;
    • RGB + Extra: 8, 16 bpc;
    • CMYK: 32, 64 bpp;
    • CMYK + Extra: 8, 16 bpc;
    • Lab: 24, 48 bpp
    • Lab + Extra: 8, 16 bpc;

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
LoadFirstExtraChannelAsAlpha
bool
false
false, true
This parameter specifies how ImageGear should load the first extra channel of a PSD image. If false, ImageGear loads all extra channels according to their descriptors in the file header. If the channel contains transparency information, ImageGear loads it as Alpha channel. Otherwise IG loads it as Extra channel.
If true, IG loads first extra channel as Alpha channel. This mode provides backward compatibility with previous versions of ImageGear.
ReadLayerIndex
int
-1
Any integer, but no more than number of layers
When > -1 specifies a zero based index of layer mask image to load, otherwise reads the composition image.

Non-Image Data Structure:

Adobe PSD file format has different non-image data that can be stored before and after an image data. The Adobe PSD metadata design allows reading and writing the following non-image data (exactly like in System.Windows.Media.Imaging.BitmapMetadata; strings by default):

Tag name
Tag ID
Description
Signature
ImGearPSDTagIDs.SIGNATURE
Adobe Photoshop Signature: always equal to '8BPS'.
Version
ImGearPSDTagIDs.VERSION
Version: always equal to 1.
Rows
ImGearPSDTagIDs.ROWS
The height of the image in pixels. Supported range is 1 to 30,000.
Cols
ImGearPSDTagIDs.COLS
The width of the image in pixels. Supported range is 1 to 30,000.
Depth
ImGearPSDTagIDs.DEPTH
Depth: the number of bits per channel. Supported values are 1, 8, and 16.
ColorMode
ImGearPSDTagIDs.MODE
The color mode of the file. Supported values are: Bitmap = 0; Grayscale = 1; Indexed = 2; RGB = 3; CMYK = 4; Multichannel = 7; Duotone = 8; Lab = 9.
ColorModeLength
ImGearPSDTagIDs.MODE_LEN
The length of the following color data provided by tag ColorData.
ColorData
ImGearPSDTagIDs.COLOR_DATA
The color data.
PhotoshopResources
ImGearPSDTagIDs.PHOTOSHOP_RESOURCES
Photoshop Image Resource metadata group. Image resources are used to store non-pixel data associated with images.
Layers
ImGearPSDTagIDs.LAYERS
Photoshop Image Layer Info metadata group. Represents high-level organization of the layers information.
LayerCount
ImGearPSDTagIDs.LAYER_COUNT
Number of layers in the Photoshop Image.
Header
ImGearPSDTagIDs.HEADER
This section contains the basic properties of the image.
RESERVED_HDR
ImGearPSDTagIDs.RESERVED_HDR
Reserved: must be zero.
Channels
ImGearPSDTagIDs.CHANNELS
The number of channels in the image, including any alpha channels. Supported range is 1 to 56.
IPTC_NAA
ImGearPSDTagIDs.IPTC_NAA
File information (IPTC-NAA record 2).

Comments:

The PSD file is considered by many in the computer graphics arts community as an industry standard.

The PSD is organized into 5 major segments of data: the header, 3 informational blocks, and the bitmap data. The short header always contains a "signature" of 8PPS, as well as these fields: width, height, and bit depth of the bitmap.

The first block of informational data is called the "Color Mode Data Block". It begins with a value for the length of the block. If the image has a palette, it is located here.

The next block is called the "Image Resources Block". Like the previous block, it first gives the length of the block. An ID field is filled with one of many possible values that indicate the structure where the data is stored. It may contain such parameters as resolution.

The last informational block is called the "Layer and Mask Instruction Block". After a value for the length of the block, it tells how many "layer records" follow. There is a record for each layer in the image. Each record begins with a channel ID and the length of the data in the record. After the records, a "Layer Mask" section may be stored, if applicable.

The bitmap data represents the last segment of a PSD file.

References used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats, 2d ed. Sebastopol, CA: O'Reilly & Associates, Inc., 1996.


BMP

Full Name
Microsoft Windows Bitmap
Format ID
ImGearFormats.BMP
File Extension(s)
*.bmp, *dib
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
Only for OS/2 BMP
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64, Java, Silverlight, Photo Editing

ImageGear Supported versions:

  • Windows Bitmap version 5 (created for Windows 98, Windows 2000)
  • Windows Bitmap version 4 (created for Windows 95, Windows NT 4.0)
  • Windows Bitmap version 3 (created for Windows 3.x)
  • Windows Bitmap version 2 (created for Windows 2.x)
  • OS/2 Bitmap version 2
  • OS/2 Bitmap version 1

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 15, 16, 24 bpp;
    • RGB + Alpha: 32 bpp.
  • ImGearCompressions.RLE:
    • Indexed RGB: 4, 8 bpp

ImageGear Write Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 15, 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 4, 8 bpp

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
UpsideDown
bool
false
false, true
If true then the images will be saved upside-down
Type
int
1 (BMI, MS Windows format)
0 (BMC, OS/2 1.x format),
1 (BMI, MS Windows format),
2 (BMI2, OS/2 2.x format).
BMP type to use for saving.
Scanner16GrayEnabbled
bool
false
false, true
Vidar 12-bit scanner options
Scanner16GrayType
int
0
0, 1
Vidar 12-bit scanner options. See ImGearGrayScannerType for reference.

Comments:

The BMP format for versions 2.x - 4.x contains two headers. All Windows bitmap files begin with the same first header. They proceed with a data structure containing image information (the Bitmap Information Header), and end with the actual image data. If there is a palette (1, 4, 8-bit images), it is located between the bitmap information and the bitmap image data.

The first header identifies the format as BMP, and stores the file size and the address of the image. Two additional fields, Reserved1 and Reserved2, are not used and are set to 0.

The second header, known as the "bitmap information header", varies across the versions of Windows bitmaps. The second header for all bitmaps from version 2.x to 5.x have in common the following basic set of information: size of the secondary header in bytes, height and width of the image in pixels, the number of bit planes, the number of bits per pixel, compression scheme (0 = uncompressed, 1 = 4-bit RLE compression, 2 = 8-bit RLE compression, 3 = bitfields encoding was used), size of image in bytes, horizontal and vertical resolution in pixels per meter, the number of colors in the image, and the minimum number of important colors.

If the image is 16 or 32-bits per pixel in resolution, the compression field equals 3, and following the header are values for RedMask, GreenMask and BlueMask, rather than a palette. If the file is 4.x, there are values for an alpha component, color space type, x and y coordinates of red, green or blue endpoints, and gamma values for red, green, and blue coordinate scale values. The "ColorsImportant" field accommodates hardware that supports fewer colors than are contained by the image palette. The most significant colors are determined by counting their frequency of appearance. A value of zero means that all the colors in the image are significant.

The palette, or color table, varies in size depending on the number of colors in the image. This value is stored in the "ColorsUsed" field of the Bitmap Information Header. In the BMP format v. 3, the palette's structure is in "RGBQUAD" format. See the section entitled "Palettes" in for more information. 24-bit images do not use a palette, but rather store the color information directly in the image data.

References used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1996.


BTR

Full Name
Brooktrout
Format ID
ImGearFormats.BRK
File Extension(s)
*.brk, *.301,
Data Type
Raster image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64, Silverlight

ImageGear Supported versions:

Version 1

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetect
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.CCITT_G3 - Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G32D - Indexed RGB: 1 bpp

ImageGear Write Support:

  • ImGearCompressions.CCITT_G3 - Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G32D - Indexed RGB: 1 bpp
NOTE: When saving an image, the image must have horizontal resolution of 200 DPI and vertical resolution of 100 or 200 DPI.

ImageGear Filter Control Parameters:

N/A

Comments:

A Brooktrout file consists of a CCITT Group 3 (G3) compressed file with a 128-byte header designed by Brooktrout Technology. The header fields include a constant that identifies the file as Brooktrout, a version number, the horizontal and vertical resolutions of the image in dots/mm, the number of bits per pixel, and the number of pixels per line.


CAL

Full Name
CALS Raster
Format ID
ImGearFormats.CAL
File Extension(s)
*.cal, *.ras, *.cals
Data Type
Raster image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64, Java, Silverlight

ImageGear Supported versions:

  • Type II (Tiles made possible)
  • Type I

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

ImGearCompressions.CCITT_G4 - Indexed RGB : 1 bpp

ImageGear Write Support:

ImGearCompressions.CCITT_G4 - Indexed RGB : 1 bpp

ImageGear Filter Control Parameters:

No

Comments:

The CALS file format was created as a graphics format specification by The Department of Defense to standardize the data exchange of logistics support operations across the military branches and military contractors. It is mandatory for most military document-handling applications. It is no longer used solely by the military and its contractors; other government agencies and commercial businesses have also adopted this format, including the aerospace, commercial computer, and medical industries.

There are two types of CALS files: Type I, and a newer, significantly more complicated Type II. Type II supports the use of tiles. Sometimes it acts a repository for a group of Type I files. Whether or not a Type II contains Type I images determines what kind of compression scheme is used. Type I is supported by ImageGear.

Type I and Type II files begin with a header that has the same format and size. It includes information about the source and destination documents, as well as image characteristics data. The data storage units under the header are each 128 bytes in length, and are referred to as records. These are written with 7-bit ASCII characters, making it more "human-readable" than most file format headers.

The image data follows the header. In a Type II file, if the data is a series of Type I images, the images are encoded with CCITT Group 4 compression. If they are Type II files, the data may either be uncompressed or encoded with CCITT Group 4. In addition, Type II data may be stored in tiles, wherein some, all, or none of the tiles may be compressed.

The Type II file contains several more substructures than Type I. Between the header and the image data are three groups of document formatting data. Other data preceding each image (or images), are "layout information" and a "Tile Index", that contains the address of each tile stored for the image.

References used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


CGM

Full Name
Computer Graphics Metafile
Format ID
ImGearFormats.CGM
File Extension(s)
*.cgm
Data Type
Metafile Vector Image
Data Encoding
Character-based, Binary, Clear-text encoded
IG Multipage Support
Yes
IG Alpha Channel Support
No
IG Platforms Support
Win32, Win64, .NET, .NET64

NOTE: CGM format requires ImageGear.Vector Namespace.

ImageGear Supported versions:

  • Version 1 (1987 standard)
  • Version 2
  • Version 3 (1992 standard)

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing
  • IGFilterFormatFlags.IG_FLTR_MPAGEREADSUPPORT - multi-page file reading

ImageGear Read Support:

  • ImGearCompressions.NONE - Vector/CAD data

ImageGear Write Support:

  • ImGearCompressions.NONE - Vector/CAD data

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
Width
Long
512
Any positive value
Defines the DIB width of the loaded image. The DIB height is calculated using the file's scale factors.

Comments:

This is standardized platform-independent format used for the interchange of bitmap and vector data.

CGM is a very feature-rich format which attempts to support the graphic needs of many general fields (graphic arts, technical illustration, cartography, visualization, electronic publishing, and so on). While the CGM format is rich in features (many graphical primitives and attributes), it is less complex than PostScript, produces much smaller (more compact) files, and allows the interchange of very sophisticated and artistic images.

Computer Graphics Metafile was developed by experts working on committees under the auspices of the International Standards Organization (ISO) and the American Standards National Institute (ANSI). It was specifically designed as a common format for the platform-independent interchange of bitmap and vector data, and for use in conjunction with a variety of input and output devices. Although CGM incorporates extensions designed to support bitmap (called raster in the CGM specification) data storage, files in CGM format are used primarily to store vector information. CGM files typically contain either bitmap or vector data, but rarely both.


CLP

Full Name
Windows Clipboard
Format ID
ImGearFormats.CLP
File Extension(s)
*.clp
Data Type
Raster image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64, Silverlight, Photo Editing

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 4, 8 bpp

ImageGear Write Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 4, 8 bpp

ImageGear Filter Control Parameters:

No

Comments:

The CLP file format represents a subset of a file format called Pictor PC Paint. The use for PC Paint format is to display images created by the PC Paint application to IBM display hardware (CGA, EGA, VGA, etc.).

The header of a CLP file is fairly short and simple, containing the file size (in bytes), and the height, width, and address of the image. The image data may be compressed or uncompressed. If it is compressed, the header contains two additional fields to give the number of bits per pixel of the packed data, and the address of the beginning of the packed run.

References used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


CUR

Full Name
Windows cursor
Format ID
ImGearFormats.CUR
File Extension(s)
*.cur
Data Type
Raster image
Data Encoding
Binary
IG Multipage Support
Yes
IG Alpha Channel Support
Single alpha channel for read/write (see Comments).
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight, Photo Editing

ImageGear Supported versions:

Windows 3.x

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.MPAGEREADSUPPORT - multi-page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Indexed + Extra: 1+1, 4+1, 8+1 bpp;
    • RGB + Alpha: 32 bpp
  • ImGearCompressions.RLE:
    • Indexed + Extra: 4+1, 8+1 bpp

ImageGear Write Support:

  • ImGearCompressions.NONE:
    • Indexed + Extra: 1+1, 4+1, 8+1 bpp;
    • RGB + Alpha: 32 bpp

ImageGear Filter Control Parameters:

None.

Comments:

Cursor files consist of a file header (that is repeated several times), info headers, and cursor data. Cursor data contains an XOR mask bitmap and a monochrome AND mask bitmap. Whenever Windows draws a cursor, the AND bitmap is applied to whatever is on the screen. After that, the XOR bitmap is applied.

READ_AS_RGBA control parameter determines how ImageGear reads the 1-bit AND masks. If READ_AS_RGBA is False, ImageGear reads AND mask into "Extra" channel. This mode preserves unchanged pixel values from the file. However, in this mode ImageGear displays only the XOR mask and ignores AND mask (Extra channel) during display, i.e. display is not transparent. If READ_AS_RGBA is TRUE, ImageGear reads CUR files as 32 bpp RGB + Alpha. This allows transparent display. Files must be 255x255 pixels or less.

References used:

© Jörn Daub EDV-Beratung - Glashütter Weg 105 - D-22889 Tangstedt

fileformats@daubnet.com


CUT

Full Name
Dr. Halo
Format ID
ImGearFormats.CUT
File Extension(s)
*.cut, *.pal (for the separately stored palette)
Data Type
Raster image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, .NET, .NET64, Unix, Unix64, MAC, Silverlight

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

ImGearCompressions.RLE - Indexed RGB: 8 bpp

ImageGear Write Support:

ImGearCompressions.RLE - Indexed RGB: 8 bpp

ImageGear Filter Control Parameters:

No

Comments:

The Dr. Halo file format is associated with the HALO Image File Format Library, the Dr. Halo III paint program, and other applications created by Media Cybernetics.

This format consists of two separate files, one with an extension of .CUT and the other with an extension of .PAL. The .CUT file contains the image data and the .PAL file contains the color palette.

The .CUT file begins with a simple header of just three data fields: width and height of the image data (pixels by scan lines), and a reserved field intended for use with any future expansions of the header. The image data is always RLE-encoded and follows the header.

The palette file (.PAL) contains a header, with information about the type of palette used, and the size and maximum values of the Red, Green, and Blue components. The palette can be hardware-specific, in which case it contains additional data.

When a CUT image is loaded into ImageGear, the palette is initialized to a grayscale ramp. In order to achieve the original colors of the palette (PAL file), it must be loaded separately into the HIGEAR image.

When saving an image into the Dr. Halo format, ImageGear creates a .CUT file. In order to save the palette (PAL file), it must be saved separately.

See the section RLE Compression for more information.

NOTE: Auto-detection of CUT format (Dr. Halo CUT) is disabled by default. The format is not popular and has unreliable detection. An application can enable auto-detection of the format if needed, using IImGearFormat Interface.DetectionEnabled Property.

References used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


DCRAW

Full Name
Digital camera RAW format
Format ID
ImGearFormats.DCRAW
File Extension(s)
*.*
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, .NET, .NET64, Unix, Unix64, MAC, Silverlight, Photo Editing

ImageGear Supported versions:

Please see the sections ImageGear Supported Digital Camera RAW Formats Reference and Particular Cameras Supported DC RAW Formats.

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Gray level: 10..16 bpp;
    • RGB: 48 bpp

ImageGear Write Support:

No

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
ApplyColorspaceConversion
bool
true
false, true
Set to true to convert raw image to linear sRGB colorspace during loading. Has effect only if RECONSTRUCT_COLORS is true.
ApplyLowLevelProcessing
bool
true
false, true
If true, ImageGear applies initial processing stages on the Raw image. If false, ImageGear loads Raw image without any post-processing. See also ApplyColorspaceConversion and ApplyToneCorrection parameters.
ApplyToneCorrection
bool
true
false, true
Set to true to automatically adjust image tone and apply sRGB gamma correction during loading. Has effect only if both RECONSTRUCT_COLORS and ApplyColorspaceConversion are true.

Comments:

Please see the section Using ImageGear Digital Camera RAW Formats.


DCX

Full Name
Paintbrush (Intel multi-page FAX format)
Format ID
ImGearFormats.DCX
File Extension(s)
*.dcx
Data Type
Raster image
Data Encoding
Binary
IG Multipage Support
Yes
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing
  • IGFilterFormatFlags.MPAGEWRITEPSUPPORT - multipage file writing

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp

ImageGear Write Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp

ImageGear Filter Control Parameters:

N/A

Comments:

This file format was designed to allow multiple PCX files to be stored in one file. This is especially desirable for multi-page faxes (for which the PCX format is often used). Up to 1024 PCX images can be stored in one DCX file.

The DCX construct begins with a simple header, then the PCX files are simply stored end-to-end, complete with their individual headers and palettes. An array in the header called "Pagetable" contains offsets to each PCX. The one piece of vital information not stored with the PCX files under a DCX is their original filenames. See the PCX section of this manual for more about PCX files.

References used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


DGN

Full Name
MicroStation Drawing (Drawing format used by MicroStation construction design software)
Format ID
ImGearFormats.DGN
File Extension(s)
*.dgn
Data Type
Vector image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
Win32, Win64, .NET, .NET64

NOTE: DGN format requires ImageGear.Vector Namespace.

ImageGear Supported versions:

  • DGN_VERSION_UNKNOWN
  • DGN_VERSION_DGN2
  • DGN_VERSION_DGN1_2D
  • DGN_VERSION_DGN1_3D
  • DGN_VERSION_CEL1_2D
  • DGN_VERSION_CEL1_3D

ImageGear Supported Features:

IGFilterFormatFlags.DETECTSUPPORT - autodetection

IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

ImGearCompressions.NONE - Vector/CAD data

ImageGear Write Support:

No

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
Backcolor
Long
0
Any positive value
This parameter is used to set background color. If nBackGroundColor=0, then a black background color is set, otherwise a white background color is set.
Width
Long
512
Any positive value
Defines the DIB width of the loaded image. The DIB height is calculated using the file's scale factors.

Comments:

DGN is a CAD file format used by Intergraph IGDS CAD software. It is not as commonly used as some other CAD file formats, but it has an open specification.


DIB

Full Name
DIB (Microsoft Windows Device Independent Bitmap)
Format ID
ImGearFormats.DIB
File Extension(s)
*.dib
Data Type
Raster image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, .NET, .NET64, Silverlight, Photo Editing

ImageGear Supported versions:

See BMP format description.

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 15, 16, 24 bpp;
    • RGB + Alpha: 32 bpp.
  • ImGearCompressions.RLE:
    • Indexed RGB: 4, 8 bpp

ImageGear Write Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 15, 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 4, 8 bpp

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
UpsideDown
bool
false
false, true
If true then the images will be saved upside-down
Type
int
1 (BMI, MS Windows format)
0 (BMC, OS/2 1.x format),
1 (BMI, MS Windows format),
2 (BMI2, OS/2 2.x format).
BMP type to use for saving.
Scanner16GrayEnabled
bool
false
false, true
Vidar 12-bit scanner options
Scanner16GrayType
int
0
0, 1
Vidar 12-bit scanner options. See ImGearGrayScannerType for reference.

Comments:

DIB is a synonym for the BMP format.


DICOM

Full Name
DICOM (Digital Imaging & Communication in Medicine)
Format ID
IG_FOMRAT_DCM = 48
File Extension(s)
*.dicm, *.dcm
Data Type
Raster or vector image
Data Encoding
Binary
IG Multipage Support
Yes
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix (Linux), .NET, .NET64, Silverlight

NOTE: To support DICOM format, attach the ImageGear.Formats.DICOM Namespace to Core ImageGear.

ImageGear Supported versions:

  • DICOM 3.0, 1991 - 2006

ImageGear Supported Features:

  • IG_FLTR_DETECTSUPPORT - autodetection
  • IG_FLTR_PAGEREADSUPPORT - single page file reading
  • IG_FLTR_PAGEINSERTSUPPORT - single-page file writing
  • IG_FLTR_PAGEDELETESUPPORT - page deleting from multi-page file (only deletion of the last page is supported)
  • IG_FLTR_MPAGEWRITEPSUPPORT - multipage file writing

ImageGear Read Support:

  • IG_COMPRESSION_NONE:
    • Grayscale: 1, 8, 9-16, 32 bpp;
    • Indexed RGB: 8 bpp, 16 bpp (converted to 24-bit RGB during loading);
    • RGB: 24 bpp
    • Vector/waveform data
  • IG_COMPRESSION_JPEG (lossy):
    • Grayscale: 8, 9-12 bpp;
    • RGB: 24 bpp
  • IG_COMPRESSION_JPEG (lossless):
    • Grayscale: 8, 9-16 bpp;
    • RGB: 24 bpp
  • IG_COMPRESSION_JPEG2K:
    • Grayscale: 8, 9-16 bpp;
    • RGB: 24 bpp
  • IG_COMPRESSION_RLE:
    • Grayscale: 8, 9-16 bpp;
    • Indexed RGB: 8 bpp, 16 bpp (converted to 24-bit RGB during loading);
    • RGB: 24 bpp

ImageGear also supports reading of Adobe PDF documents, encapsulated in DICOM files. See the Adobe PDF description for information on supported Adobe PDF features.

ImageGear Write Support:

  • IG_COMPRESSION_NONE:
    • Grayscale: 8, 9-16, 32 bpp;
    • Indexed RGB: 8 bpp;
    • RGB: 24 bpp
  • IG_COMPRESSION_JPEG (lossy - baseline / process 1):
    • Grayscale: 8 bpp;
    • RGB: 24 bpp
  • IG_COMPRESSION_JPEG (lossy - extended / process 2&4):
    • Grayscale: 8, 9-12 bpp;
    • RGB: 24 bpp
  • IG_COMPRESSION_JPEG (lossless):
    • Grayscale: 8, 9-16 bpp;
    • RGB: 24 bpp
  • IG_COMPRESSION_JPEG2K - 8, 9-16, 24, 48 bpp
  • IG_COMPRESSION_RLE:
    • Grayscale: 8, 9-16 bpp;
    • Indexed RGB: 8 bpp;
    • RGB: 24 bpp
NOTE: To use the JPEG2000 Compression scheme, attach ImageGear.Formats.JPEG2K Namespace.

To be able to load an encapsulate Adobe PDF document, attach ImageGear.Formats.PDF Namespace.

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
DetectContinuousRLE
bool
true
false, true
Set to true for ImageGear to detect and load images where RLE runs across row boundaries. This parameter specifies what to do with RLE compressed images where RLE runs across row boundaries. If it is set to true, ImageGear tries to detect and load images where RLE runs across row boundaries. Otherwise, ImageGear truncates any row overruns and decodes each row separately. This parameter does not affect the loading of properly encoded images, where each row is encoded separately.
LoadConcatenateRepeatedDE
bool
false
false, true
Set to true to concatenate repeated data elements into one data element during loading. **
LoadDetectSkipDIMSE
bool
false
false, true
Set to false if files may contain DIMSE commands - that could throw off the format detection
LoadSavePixdataTag
bool
false
false, true
Set to false to allow loading and saving pixel data to/from the metadata tree rather than to/from ImageGear DIB.
LoadSyntax
ImGearDICOMTransferSyntaxes
MED_DCM_TS_AUTODETECT
See ImGearDICOMTransferSyntaxes
Transfer Syntax to load DCM image with.
LoadWithoutDetection
bool
false
true,
false
Set to true to skip detection phase before loading a DICOM image.*
SaveAsPart10
bool
true
true,
false
true will cause the Header to be saved
SaveGroupLengths
int
true
true,
false
true=include false=exclude
SavePlanarConfig
ImGearDICOMPlanarConfigurations
PIXEL_BY_PIXEL
ImGearDICOMPlanarConfigurations
Planar configuration for image saving.
SaveSyntax
ImGearDICOMTransferSyntaxes
DEFAULT
ImGearDICOMTransferSyntaxes
Transfer Syntax to save DCM image with.

*) LoadWithoutDetection parameter affects loading of DICOM images that do not have File Meta Info (Part10) header. If false (default), the DICOM filter checks that the first several Data Elements are well formed, and if they are not, stops the reading. If true, the filter skips checking the first tags, and attempts to read the image, using the Transfer Syntax specified in the LoadSyntax parameter. LoadSyntax parameter should be set to a specific syntax, rather than AUTODETECT, PART10 or UNKNOWN. When loading the file, set loadOptions.Format to ImGearFileFormats.DICOM. Use this mode if you know for sure the file is a DICOM, and you know its transfer syntax.

**) Parameter LoadConcatenateRepeatedDE allows you to load incompliant DICOM images where some data elements are cut into several repeated data elements. Instead of one data element containing an array of values, the data set contains several data elements, with the same group/element numbers pair, containing portions of the array. Specifically, there are images with look up tables and palettes stored in this way. Set LOAD_CONCAT_REPEATED_DE parameter to TRUE to concatenate repeated data elements into one data element during loading. Otherwise (default), ImageGear loads all of the repeated elements in the same way as they are located in the file. Note that ImageGear does not allow saving of repeated data elements. If a data set contains repeated data elements, ImageGear will only write the first repeated element to the file.

Comments:

DICOM is a public standard created to provide a flexible and expandable means for storing, sharing, and transporting digital medical images. Today DICOM is the standard for medical imaging throughout the world.

DICOM image (alternately called Data Set) contains an ordered collection of attributes referred to as "Data Elements" that are related to one or more images. Each Data Element (DE) describes a single attribute of the image, patient, or study. The images themselves are also stored in DEs.

Each DICOM Data Set is transported through the Network, and consequently, stored in a file, using one of the defined Transfer Syntaxes. The Transfer Syntax of the DICOM file indicates whether the file uses Big Endian or Little Endian byte order, whether the image data is compressed or uncompressed, and if the DICOM Data Set uses Explicit or Implicit Value Representation (VR).

The Data Element (DE) is made up of the following parts:

  • Tag
  • Value Representation (optional)
  • Value Lenth
  • Value

Tag field identifies the type of information that is contained in the Value field (where the actual data is stored). The DICOM Data Dictionary (Part 6 of the specification) defines all possible public Data Element Tags that may be used. DICOM also allows applications to define and use private Tags and thus define their own Data Elements. Value Representation (VR) specifies the format of the Data Element Value, such as UL (unsigned long), ST (Short Text) or PN (Person Name). If Implicit Transfer Syntax is used, the VR field is omitted. It can be obtained from the standard or private Data Dictionary. Value Lenth is the lenth (in bytes) of the Data field.

DICOM also allows embedding (nesting) Data Sets within Data Sets. Nested Data Sets are implemented using a "Sequence of Items" (SQ), which is a special type of Data Element.

A special group of tags at the beginning of the file allows application to recognize the file as a DICOM image file, and includes information needed to decode the file (Transfer Syntax), and serial numbers to help locate and keep track of each field. This header is referred to as "File Meta Information Header", or "Part 10 Header" (since it is defined in Part 10 of the DICOM standard). While the standard clearly states that all DICOM image files must include a Part 10 Header, in reality one finds that many do not. Instead, the average DICOM image file is a simple data stream capture of the data into a file. This is called a "Raw Data" DICOM image file. In order to read a Raw DICOM the Transfer Syntax must be guessed at using a Transfer Syntax detection algorithm.

The actual pixel data for a DICOM image is stored in a Data Element, just like any other DICOM information. Image parameters, such as dimensions, bit depth, photometric interpretation etc., are also stored in Data Elements. The Tag for Pixel Data is called "Pixel Data" and has the Tag Number 7FE0, 0010. The Data Field in this Data Element contains all pixels for the image. Depending on the image's Transfer Syntax, the Pixel Data can be compressed or uncompressed.

References Used

Digital Imaging and Communication in Medicine (DICOM). Published by: National Electrical Manufacturers Association: http://medical.nema.org/dicom.html.


DWF

Full Name
DWF (Design Web Format)
Format ID
ImGearFormats.DWF
File Extension(s)
*.dwf, *.w2d, *.w3d
Data Type
Vector/CAD image
Data Encoding
Binary
IG Multipage Support
Yes
IG Alpha Channel Support
No
IG Platforms Support
Win32, .NET

NOTE: DWF format requires ImageGear.Vector Namespace.

ImageGear Supported versions:

  • Up to version 6.20

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.NONE - Vector/CAD data

ImageGear Write Support:

  • ImGearCompressions.NONE - Vector/CAD data

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
Width
Long
512
Any positive value
Defines the DIB width of the loaded image. The DIB height is calculated using the file's scale factors.

Comments

DWF is an open format developed by AutoDesk (Design Web Format). Unlike DWG and DXF, DWF is focused on viewing only. It is intended to be used for publishing 2D and 3D CAD drawings so they can be easily viewed without requiring the use of CAD software.


DWG

Full Name
DWG (AutoDesk AutoCAD)
Format ID
ImGearFormats.DWG
File Extension(s)
*.dwg
Data Type
Vector/CAD image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
Win32, Win64, .NET, .NET64

NOTE: DWG format requires ImageGear.Vector Namespace.

ImageGear Supported versions:

  • Read: Versions 2.5 through 2007
  • Write: Versions 12 through 2007

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

ImGearCompressions.NONE - Vector/CAD data

ImageGear Write Support:

ImGearCompressions.NONE - Vector/CAD data

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
BackColor
Long
0
Any positive value
This parameter is used to set background color. If nBackGroundColor=0, then a black background color is set, otherwise a white background color is set.
Width
Long
512
Any positive value
Defines the DIB width of the loaded image. The DIB height is calculated using the file's scale factors.
FontPath
String
""
Any string up to 262 characters
Defines a path to the vector font files. Format - <Path1>;< Path2>;... .
Password
String
""
Any string up to 262 characters
Used to set password for encrypted files before reading.
Version
String
ACAD2004
ACAD12 ACAD13 ACAD14 ACAD2000 ACAD2004 ACAD2007
Used to specify version to save the file as.
ShowHidden
Boolean
False
True, False
If true, hidden layers are shown by default.

Comments

DWG, short for "DraWinG", is a CAD file format which serves as the native file format for drawings created in AutoCAD.


DXF

Full Name
DXF (AutoDesk AutoCAD)
Format ID
ImGearFormats.DXF
File Extension(s)
*.dxf
Data Type
Vector/CAD image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
Win32, Win64, .NET, .NET64

NOTE: DXF format requires ImageGear.Vector Namespace.

ImageGear Supported versions:

  • Read: Versions 2.5 through 2007
  • Write: Versions 12 through 2007

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.NONE - Vector/CAD data

ImageGear Write Support:

  • ImGearCompressions.NONE - Vector/CAD data

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
BackColor
Long
0
Any positive value
This parameter is used to set background color. If nBackGroundColor=0, then a black background color is set, otherwise a white background color is set.
Width
Long
512
Any positive value
Defines the DIB width of the loaded image. The DIB height is calculated using the file's scale factors.
FontPath
String
""
Any string up to 262 characters
Defines a path to the vector font files. Format - <Path1>;< Path2>;... .
Password
String
""
Any string up to 262 characters
Used to set password for encrypted files before reading.
Version
String
ACAD2004
ACAD12 ACAD13 ACAD14 ACAD2000 ACAD2004 ACAD2007
Used to specify version to save the file as.
ShowHidden
Boolean
False
True, False
If true, hidden layers are shown by default.

Comments

DXF is an AutoDesk graphics format (Drawing eXchange Format). Most CAD programs (PC-based) support this format. Compared to DWG, it is simpler and more broadly supported among different software.


GEM

Full Name
GEM Raster
Format ID
ImGearFormats.GEM
File Extension(s)
*.gem
Data Type
Raster image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

ImGearCompressions.RLE - 1, 4, 8 bpp

ImageGear Write Support:

No

ImageGear Filter Control Parameters:

No

Comments

A deal with the creators of Ventura Publisher made this a significant format in the desktop publishing arena. It was also distributed by PC systems manufacturers and was the native bitmap format of the Atari ST system.

The structure of a GEM Raster image file begins with a fixed-length header and is followed by the bitmap data.

The data fields of the header include the version number (always 1), image width (in pixels), and image height (in scan lines). A field named "Headerlength" contains a value of either 8 or 9, where 9 indicates that an optional field appears at the end, called "BitImageFlag". This field is directly tied with a "NumberOfPlanes" field. If "NumberOfPlanes" is greater than 1, the BitImageFlag indicates whether the image is color or grayscale. (BitImageFlag = 0 = color, BitImageFlag = 1 = grayscale).

Two fields in the header that are a little unusual among bitmap formats are the width and height of the pixels (in microns), and a field called "PatternLength". PatternLength is the length of any pattern that will be decoded. It is used by the RLE compression scheme, which assigns one of four different kind of codes to store each of the four different types of repeat data in the image. The "pattern code" indicates that a pattern is available. The pattern and repeat count are decoded while reading the file.

For more on RLE Compression compression, see the ImageGear Supported Compressions Reference section in this chapter.

References used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


GIF

Full Name
CompuServe Graphics Interchange Format (GIF)
Format ID
ImGearFormats.GIF
File Extension(s)
*.gif
Data Type
Raster image
Data Encoding
Binary
IG Multipage Support
Yes
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight, Photo Editing

ImageGear Supported versions:

  • Version 89a, 1989: added ability to store both text and graphics in same file.
  • Version 87a, 1987: first version; still read by major applications supporting GIF.

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading
  • IGFilterFormatFlags.MPAGEWRITEPSUPPORT - multipage file writing

ImageGear Read Support:

ImGearCompressions.LZW - Indexed RGB: 1, 4, 8 bpp

ImageGear Write Support:

ImGearCompressions.LZW - Indexed RGB: 1, 4, 8 bpp

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
Version
int
89
87; 89
Sets version of GIF file to be saved.
Interlace
bool
false
true, false
Sets GIF interlace mode to be used on saving.

Comments

This is a very popular format for storing graphics images on Web pages. It is also supported by most applications that handle graphical image data.

Unisys, the owner of the LZW compression used on all GIF files, declared at the end of 1995 that it will charge a royalty fee to all developers wishing to use this compression scheme. (This drove many developers to search for a replacement file format. A new file format called PNG ("Ping") was created. The PNG format is supported by ImageGear; see the PNG section of this chapter for more information.) However, worldwide GIF-related patents expired in 2004 and the format is once again free to use without the need to pay royalties to Unisys.

While the GIF format is designed to store multiple images, few GIF format viewers support this. For this reason, it is not advisable to store more than one image in a GIF file.

The GIF layout is fairly complex; it can include several categories of "blocks" under which subcategories of blocks may occur. For both the 89a and 87a versions, the first three blocks are the header, the Logical Source Descriptor, and the Global Color Table. The header simply identifies the file as a GIF and gives the version number. The Logical Source Descriptor is very similar to a header, and is sometimes stored within the header. It contains information about the display screen and color table.

GIFs contain two kinds of color tables: a "Global Color Table" and "Local Color Table." The Global Color Table is used as a table for the pixel values of all images contained within the GIF file. Optionally, the Local Color Table block that is provided for each image can contain data specific to an individual image.

In addition to a local color table, each image is associated with another block of data, the Local Image Descriptor, provides the size and location of the image, and data about its color table.

GIF89a is equipped with four new types of blocks called "Control Extensions". The most significant group of these are the "Graphics Control Extension Blocks" that enable the simultaneous storing and displaying of textual and graphical data, including multiple images, resulting in a "multimedia presentation". The functions provided by these blocks include setting the transparency or opacity of the images, restoring or deleting images, and overlaying captions (that are not part of the actual bitmap) on images.

GIF image data is always stored in LZW-compressed form. The data may also be interlaced. Interlacing helps the appearance of an image as it displays while being decompressed, so that it "fades in". In a non-interlaced file, the presentation of the image data begins with row 1 and works downward to the last row of data. This method of display does not allow a quick preview of the whole image. When the data is interlaced, the lines are saved and displayed out of sequence. Every fourth row is displayed first and then filled in with every remaining fourth row, until all of the lines are displayed. This allows the eye to perceive the basic subject of the whole image before it is completely displayed.

See also:

GIF Non-image Data Structure

References used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


HD Photo

Full Name
HD Photo (Windows Media Photo)
Format ID
ImGearFormats.HDPHOTO
File Extension(s)
*.wdp
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
Yes
IG Platforms Support
Win32 (DLL only), Win64, .NET, .NET64, Photo Editing

ImageGear Supported Versions:

  • Version 1.0 - First public release.

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.AUTO:
    • Indexed RGB: 1 bpp;
    • Grayscale: 1, 8, 16 bpp;
    • RGB: 24, 48 bpp
    • RGBA: 32, 64 bpp
    • RGBPA: 32, 64 bpp;
    • CMYK: 32, 64 bpp;
    • CMYKEx: 40, 80 bpp

ImageGear Write Support:

  • ImGearCompressions.AUTO:
    • Indexed RGB: 1 bpp;
    • Grayscale: 1, 8, 16 bpp;
    • RGB: 24, 48 bpp;
    • RGBA: 32, 64 bpp;
    • RGBPA: 32, 64 bpp;
    • CMYK: 32 bpp

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
Lossless
Boolean
False
False,
True
Set to True to use lossless compression during save.
ImageQuality
Single
0.9
0 to 1.0
Image quality level. 1.0 represents lossless compression.
UseAdvancedParameters
Boolean
False
False, True
When true, QualityLevel, OverlapLevel, and SubsamplingLevel are used in place of the ImageQualityLevel. When false, QualityLevel, OverlapLevel, and SubsamplingLevel are set based on ImageQualityLevel
Advanced.Quality
Byte
1
0..255
Controls quantization of the main image. A value of 1 sets lossless mode (no quantization). Increasing values result in greater quantization and thus greater compression ratios and lower image quality. This parameter is tightly related with Advanced.Subsampling and Advanced.Overlap parameters, and its behavior may differ depending on source image content. If the application needs a single parameter to control image quailty, the use of the basic ImageQuality parameter is recommended.
Advanced.Overlap
Byte
1
0,1,2
0 - No overlap processing is enabled;
1 - One level of overlap processing is enabled. Encoded values of 4x4 blocks are modified based on the values of neighboring blocks;
2 - Two levels of overlap processing are enabled. In addition to the first level of processing, encoded values of 16x16 macro blocks are modified based on the values of neighboring macro blocks.
Advanced.Subsampling
Byte
3
0, 1, 2, 3
0 - 4:0:0 encoding. Chroma content is discarded, luminance is preserved.
1 - 4:2:0 encoding. Chroma resolution is reduced by 1/4 of luminance resolution.
2 - 4:2:2 encoding. Chroma resolution is reduced to 1/2 of luminance resolution.
3 - 4:4:4 encoding. Chroma resolution is preserved.
Advanced.HorizontalTileSlices
Short
0
0..4095
The number of horizontal divisions to use during compression encoding.
Advanced.VerticalTileSlices
Short
0
0..4095
The number of vertical divisions to use during compression encoding.
Advanced.FrequencyOrder
Boolean
True
False,
True
True to encode the image in frequency order; False to encode the image by its spatial orientation.
Advanced.InterleavedAlpha
Boolean
False
False,
True
True if the image is to be encoded with an additional interleaved alpha channel; False if planar alpha channel is to be used.
Advanced.AlphaQuality
Byte
1
0..255
The compression quality for a planar alpha channel image. A value of 1 is considered lossless.
Advanced.CompressedDomainTranscode
Boolean
True
False,
True
True if compressed domain operations can be used.
Advanced.ImageDataDiscard
Byte
1
0, 1, 2, 3
0 - No image frequency data is discarded.
1 - FlexBits are discarded. The image quality of the image is reduced without changing the effective resolution of the image.
2 - HighPass frequency data band is discarded. The image's effective resolution is reduced by a factor of 4 in both dimensions.
3 - HighPass and LowPass frequency data bands are discarded. The image's effective resolution is reduced by a factor of 16 in both dimensions
Advanced.AlphaDataDiscard
Byte
1
0..4
0 - No image frequency data is discarded.
1 - FlexBits are discarded. The image quality of the image is reduced without changing the effective resolution of the image.
2 - HighPass frequency data band is discarded. The image's effective resolution is reduced by a factor of 4 in both dimensions.
3 - HighPass and LowPass frequency data bands are discarded. The image's effective resolution is reduced by a factor of 16 in both dimensions.
4 - The alpha channel is completely discarded. The pixel format is changed to reflect the removal of the alpha channel.
Advanced.IgnoreOverlap
Boolean
False
False,
True
True if overlap is ignored. This value is only valid when CompressedDomainTranscode is true and a sub-region encode is requested.

Non-Image Data Structure:

HD Photo file format has different non-image data that can be stored before and after an image data. The HD Photo metadata design allows reading and writing the following non-image data (exactly like in System.Windows.Media.Imaging.BitmapMetadata; strings by default):

Tag name
Tag ID
Description
ApplicationName
ImGearHDPhotoTagIDs.APPLICATION_NAME
Gets or sets a value that identifies the name of the application that was used to construct or alter an image file.
Author (collection of strings)
ImGearHDPhotoTagIDs.AUTHORS Single author is ImGearHDPhotoTagIDs.AUTHOR
Gets or sets a value that represents the author of an image.
CameraManufacturer
ImGearHDPhotoTagIDs.CAMERA_MANUFACTURER
Gets or sets a value that identifies the camera manufacturer that is associated with an image.
CameraModel
ImGearHDPhotoTagIDs.CAMERA_MODEL
Gets or sets a value that identifies the camera model that was used to capture the image.
Comment
ImGearHDPhotoTagIDs.COMMENT
Gets or sets a value that represents a comment that is associated with the image file.
Copyright
ImGearHDPhotoTagIDs.COPYRIGHT
Gets or sets a value that indicates copyright information that is associated with the image file.
DateTaken
ImGearHDPhotoTagIDs.DATE_TAKEN
Gets or sets a value that indicates the date that the image was taken.
Keywords (collection of strings )
ImGearHDPhotoTagIDs.KEYWORDS
Single keyword is ImGearHDPhotoTagIDs.KEYWORD
Gets or sets a collection of keywords that describe the bitmap image.
Rating (integer 0 to 5)
ImGearHDPhotoTagIDs.RATING
Gets or sets a value that identifies the image rating.
Subject
ImGearHDPhotoTagIDs.SUBJECT
Gets or sets a value that indicates the subject matter of the bitmap image.
Title
ImGearHDPhotoTagIDs.TITLE
Gets or sets a value that identifies the title of an image file.

Comments

HD Photo, also known as Windows Media Photo (WMPhoto), is a new file format for continuous-tone still images, developed by Microsoft as a part of the Windows Media family that surpasses the limitations of existing image formats. HD Photo supports a wide range of features, including:

  • Multiple color formats for display or print.
  • Fixed or floating point high dynamic range, wide gamut image encoding.
  • Lossless or high-quality lossy compression.
  • Extremely efficient decoding for multiple resolutions and sub-regions.
  • Minimal overhead for format conversion or transformations during decode.

HD Photo delivers a lightweight, high performance algorithm with a small memory footprint that enables practical, in-device encoding and decoding. HD Photo delivers image quality that is comparable to JPEG-2000 and more than twice the quality of JPEG.


HPGL

Full Name
HPGL
Format ID
ImGearFormats.HPGL
File Extension(s)
*.hpgl
Data Type
Vector image
Data Encoding
Binary
IG Multipage Support
Yes
IG Alpha Channel Support
No
IG Platforms Support
Win32, Win64, .NET, .NET64

NOTE: HPGL format requires ImageGear.Vector Namespace.

ImageGear Supported versions:

HPGL, HPGL/2

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading

ImageGear Read Support:

ImGearCompressions.NONE - Vector/CAD data

ImageGear Write Support:

No

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
BackColor
Long
0
Any positive value
This parameter is used to set background color. If nBackGroundColor=0, then a black background color is set, otherwise a white background color is set.
Width
Long
512
Any positive value
Defines the DIB width of the loaded image. The DIB height is calculated using the file's scale factors.

Comments

HPGL ("Hewlett Packard Graphics Language") is a vector graphics language used to output vector/CAD drawings to plotters. Due to widespread support among CAD software, it is sometimes used as a vector/CAD interchange format.


IBM IOCA

Full Name
IBM IOCA (Image Object Content Architecture)
Format ID
ImGearFormats.ICA
File Extension(s)
*.ica, *.mod
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
Yes
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.CCITT_G3:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G4:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.IBM_MMR:
    • Indexed RGB: 1 bpp

ImageGear Write Support:

  • ImGearCompressions.CCITT_G3:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G4:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.IBM_MMR:
    • Indexed RGB: 1 bpp

ImageGear Filter Control Parameters:

None

Comments:

IOCA files are most often used for document storage. They are not so unusual from most file formats, except for their naming conventions, which tend to be IBM-specific.

The general structure of an IOCA image file includes a "beginning segment", an "end segment", a header component called "Image Data Parameters", a palette, and the actual image data. Most IOCA images (less than 24-bit) contain a palette. The elements of the bitmap image are referred to as Image Data Elements (IDEs), that are called pixels by most other formats. The "Object Content" refers to the combination of the header and the image data.

IBM uses fields in the header called "self-defining fields". They each contain a type code, the length of the parameter, and then the actual parameter data. They include information as resolution, size, encoding scheme, and bit depth.

There are many optional parameters. Subsets of IOCA parameters are referred to as "function sets" and define different flavors of the IOCA, one being the MO:DCA, also supported by ImageGear. Examples of optional parameters include a tiling parameter, if the image is tiled, and a Band Image parameter, which signifies that the image is saved in "bands" ("bit planes" in other formats).

References used

Image Object Content Architecture Reference, 2d ed., copyright International Business Machines Corporation, August 1991.


IBM MO:DCA

Full Name
IBM MO:DCA (Mixed Object Document Content Architecture)
Format ID
ImGearFormats.MOD
File Extension(s)
*.mod, *.ica
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
Yes
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64, Silverlight

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading
  • IGFilterFormatFlags.MPAGEWRITEPSUPPORT - multipage file writing
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.CCITT_G3:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G4:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.IBM_MMR:
    • Indexed RGB: 1 bpp

ImageGear Write Support:

  • ImGearCompressions.CCITT_G3:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G4:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.IBM_MMR:
    • Indexed RGB: 1 bpp

ImageGear Filter Control Parameters:

None

Comments:

The MO:DCA header allows the storage of multiple IOCA images in one file. The MO:DCA format is an IOCA "wrapper". It is considered by IBM to be a "data stream controlling environment" for a group of IOCA images.

There are many optional parameters. Subsets of IOCA parameters are referred to as "function sets" and define different flavors of the IOCA, for example, the MO:DCA. The MO:DCA incorporates function sets "10" and "11".

Please see the description of IBM IOCA in this chapter for further description.

References used

Image Object Content Architecture Reference, 2d ed., copyright International Business Machines Corporation, August 1991.


ICO

Full Name
ICO (Windows icon)
Format ID
ImGearFormats.ICO
File Extension(s)
*.ico
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
Yes
IG Alpha Channel Support
Single alpha channel for read/write (see Comments).
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight, Photo Editing

ImageGear Supported versions:

  • Windows 3.1
  • Windows NT/95

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Indexed + Extra: 1+1, 4+1, 8+1 bpp;
    • RGB + Alpha: 32 bpp
  • ImGearCompressions.RLE:
    • Indexed + Extra: 4+1, 8+1 bpp

ImageGear Write Support:

  • ImGearCompressions.NONE:
    • Indexed + Extra: 1+1, 4+1, 8+1 bpp;
    • RGB + Alpha: 32 bpp

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
ReadAsRGBA
bool
false
true, false
If true, ImageGear reads ICO format as RGBA (RGB with alpha channel).

Comments:

More than one representation of the icon bitmap is stored in order to offer a choice of icons; the version most compatible to the output device is used. Support for read-write transparency masks has been added to the ICO filter. Transparency masks are placed into an alpha channel when the image is created. These masks can subsequently be set and applied to the main image.

The structure of an ICO file consists of four data sections: the header, the Resource Descriptor, and two representations of the image data per each icon (the color bitmap and the 1-bit masking bitmap).

The header identifies the file as an ICO and stores the number of icon images that are stored in the file.

The Resource Descriptor stores the image width and height, the number of colors used, and the offset from the beginning of the file to the image data.

The 1-bit masking bitmap defines the transparent portion of the bitmap.

ReadAsRGBA control parameter determines how ImageGear reads the 1-bit AND masks. If ReadAsRGBA is False, ImageGear reads AND mask into "Extra" channel. This mode preserves unchanged pixel values from the file. However, in this mode ImageGear displays only the XOR mask and ignores AND mask (Extra channel) during display, i.e., display is not transparent. If ReadAsRGBA is TRUE, ImageGear reads ICO files as 32 bpp RGB + Alpha. This allows transparent display.

References used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.


IFF

Full Name
Interchange File Format
Format ID
ImGearFormats.IFF
File Extension(s)
*.iff
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
Yes
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight

ImageGear Supported versions:

  • Version 1, 1985

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp

ImageGear Write Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp

ImageGear Filter Control Parameters:

None

Comments

This type of file format is referred to as a "wrapper" because it can include any type of data that is encoded in any manner.

The basic organization of the IFF file format utilizes storage structures known as "chunks". A chunk is a block of data that contains its own header (that identifies the chunk size and type). This makes it easy for an IFF viewer to identify chunks and to skip over the ones that are not necessary.

The Header Chunk contains 17 fields, including the size of the header chunk, the identification of the chunk as a header, the size and origin of the image, data encoding (yes or no), and aspect ratio.

A "CMG Chunk" may follow, containing data specific to Amiga display hardware.

A "CMAP Chunk" contains the RGB palette for the image.

The "Body Chunk" (also called the ILBM or "interleaved bitmap"), is the image data itself. It is stored in an "interleaved" format, by bit plane. Interleaving allows for data with different resolutions to be neatly stored together. The data may be uncompressed or compressed using an RLE scheme. See RLE Compression section at the beginning of this chapter for more information.

References used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. Windcrest Books, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


IMG

Full Name
Xerox 9700 graphic image (IMG)
Format ID
ImGearFormats.IMG
File Extension(s)
*.img
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight, Photo Editing

ImageGear Supported versions:

Version 1.0

Version 2.0

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

  • ImGearCompressions.NONE - Indexed RGB: 1, 8 bpp

ImageGear Write Support:

No

ImageGear Filter Control Parameters:

None

Comments

The IMG header contains the width, height and resolution of the image. Following the header is compressed data. The sample values of a binary image are compressed and then encoded into a sequence of bits. Compression is achieved by predicting a pixel value based on pixel values that have already been computed. For example, the predicted value of a pixel may be that of the corresponding pixel on the previous scan line. Up to fifteen different compression techniques are used, each designed to remove redundancy from a certain kind of image - text characters, line art, and halftones of various screen frequencies. The algorithm adapts to the properties of the image by selecting the technique that will perform the best.

References Used

Xerox System Integration Standard. Raster Encoding Standard. Xerox, XNSS 178506, June 1990.


IMR

Full Name
IMRS-Raster image
Format ID
ImGearFormats.IMR
File Extension(s)
*.ima
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

ImGearCompressions.CCITT_G4 - Indexed RGB: 1 bpp

ImageGear Write Support:

No

ImageGear Filter Control Parameters:

None

Comments

The IMG header contains the width, height and resolution of the image. Following the header is compressed data. The sample values of a binary image are compressed and then encoded into a sequence of bits. Compression is achieved by predicting a pixel value based on pixel values that have already been computed. For example, the predicted value of a pixel may be that of the corresponding pixel on the previous scan line. Up to fifteen different compression techniques are used, each designed to remove redundancy from a certain kind of image - text characters, line art, and halftones of various screen frequencies. The algorithm adapts to the properties of the image by selecting the technique that will perform the best.

References Used

Xerox System Integration Standard. Raster Encoding Standard. Xerox, XNSS 178506, June 1990.


IMT

Full Name
IMNET (Medical Image Format)
Format ID
ImGearFormats.IMT
File Extension(s)
*.imt
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.CCITT_G3 - Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G4 - Indexed RGB: 1 bpp

ImageGear Write Support:

  • ImGearCompressions.CCITT_G4 - Indexed RGB: 1 bpp
NOTE: The width of an image being saved must be a multiple of 8.

ImageGear Filter Control Parameters:

None


JPEG

Full Name
JPEG File Interchange Format
Format ID
ImGearFormats.JPG
File Extension(s)
*.ipg, *jpeg
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
Read/write
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Java, Silverlight, Photo Editing

ImageGear Supported versions:

  • Version 1.01 - 1991
  • Version 1.02 - Added ability for thumbnails to be color-mapped and JPEG compressed.

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.JPEG (Lossy):
    • Grayscale: 8, 12 bpp;
    • RGB: 24, 36 bpp;
    • CMYK: 32 bpp;
    • RGB + Alpha: 32 bpp
  • ImGearCompressions.JPEG (Lossless):
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp;
    • CMYK: 32 bpp;
    • RGB + Alpha: 32 bpp
  • ImGearCompressions.JPEG (Progressive JPEG):
    • Grayscale: 8, 12 bpp;
    • RGB: 24 bpp;
    • CMYK: 32 bpp;
    • RGB + Alpha: 32 bpp

ImageGear Write Support:

  • ImGearCompressions.JPEG (Lossy):
    • Grayscale: 8, 12 bpp;
    • RGB: 24, 36 bpp;
    • RGB + Alpha: 32 bpp1
    • CMYK: 32 bpp2
  • IG_COMPRESSION_JPEG (Lossless):
    • Grayscale: 8, 16 bpp;
    • RGB: 24 bpp;

1) RGBA saving is disabled by default. Set AllowRGBASaving control parameter to true to enable it.

2) CMYK saving is enabled by default. You can disable it by setting AllowCMYKSaving control parameter to false.

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
AllowLossy12bpcSaving
bool
true
true, false
Controls the saving to Lossy JPEG format. If True, saving of 12 bits per channel Lossy JPEG is allowed. This is the maximum channel depth supported by Lossy JPEG format. If source image's depth is more than 8 bits per channel, it will be saved to a 12 bpc JPEG. For example, 48-bit RGB image will be saved to 36-bit JPEG. Note that many viewers do not support 12 bpc JPEG. If False, all images are saved to 8 bpc JPEG, regardless of their channel depth.
AllowRGBASaving
bool
true
true, false
Set this parameter to true to enable RGBA JPEG saving. Note, that there is no official standard for RGBA JPEG. This format is recognized as CMYK rather than RGBA by most third-party software.
Quality
int
70
Possible value in range [1,100]
Gets/Sets quality value for Lossy and Progressive JPEG compression. See JPEG Quality Section for details.
DecimationType
ImGearDICOMTransferSyntaxes
Decim_2x2_1x1_1x1
See ImGearDecimationTypes Enumeration Section.
Get/Set decimation value. For all available values see ImGearDecimationTypes Enumeration.
Predictor
int
1
Gets/Sets predictor for lossless JPEG. See Lossless JPEG Predictor Settings Section for details.
SaveType
int
0 (Lossy compression)
0 (Lossy compression),
1 (Lossless compression),
2 (Progressive compression)
Get/Set type for output JPEG format. See Loading and Saving JPEG-Compressed Images Section for details.
AllowCMYKSaving
bool
true
true, false
Set to true (default) to allow saving JPEG CMYK images. Set to false to save CMYK images to JPEG as RGB.
SaveEXIFMetadata
bool
false
true,
false
If true. EXIF metadata is saved.
SaveExistingEXIFMetadata
bool
true
true, false
This parameter controls the saving of existing EXIF metadata.
By default (SaveEXIFMetadata = False, SaveExistingEXIFMetadata = True), ImageGear saves EXIF metadata if it exists in the source page, and does not save EXIF metadata if it does not exist in the source page.

SaveExistingEXIFMetadata works in combination with SaveEXIFMetadata parameter, as shown in the table below:

SaveEXIFMetadata
SaveExistingEXIFMetadata
Source Page has EXIF metadata
ImageGear action
False
False
No
Does not save EXIF metadata
False
False
Yes
Does not save EXIF metadata
False
True
No
Does not save EXIF metadata
False
True
Yes
Saves existing EXIF metadata
True
False
No
Saves default EXIF metadata
True
False
Yes
Ignores existing and saves default EXIF metadata
True
True
No
Saves default EXIF metadata
True
True
Yes
Saves existing EXIF metadata

Comments:

JPEG is normally associated with the JPEG compression scheme, but it is also implemented into the JFIF file format. This format was developed to store JPEG-encoded data, and to exchange it between applications or operating systems that are normally incompatible.

NOTE: The JPEG compression scheme was developed by the Joint Photographic Experts Group (created by the joining of a subgroup of the International Standards Organizations, called PEG (Photographic Experts Group) and a subgroup of the CCITT). Their common goal was to produce a standard for the transmission of graphics image data over networks and through color facsimile systems.

The header of the JFIF contains the version number, the image dots per inch (DPI), or dots per centimeter, and an optional thumbnail (miniature) RGB representation of the main image. Version 1.02 handles thumbnails differently by storing them separately, rather than in the identification marker of the header.

The raw JPEG data is surrounded by two markers, an "SOI" (start of image) marker, and an "EOI" (end of image) marker. See the section entitled Compression Schemes in this chapter for more about JPEG compression.

JFIF is considered a non-proprietary file format. Many proprietary file formats contain JPEG data, incorporating their own application-specific data structures. Another non-proprietary format that uses JPEG-encoded data is TIFF file format, version 6.0.

Loading and Saving JPEG-Compressed Images

ImageGear supports the reading and writing of three types of JPEG compression: baseline JPEG (Lossy), Progressive JPEG, and Lossless JPEG. When you load a JPEG-compressed file, ImageGear detects the type of JPEG compression and decompress the image automatically. But if you want to save an image with a JPEG compression scheme other than baseline JPEG, you must use the "SAVE_TYPE" parameter to specify the type of JPEG compression.

JPEG Thumbnails

The JPEG format can store thumbnails, which are small representations of the original image. These images are stored in uncompressed form and can significantly decrease your overall compression ratio. (Uncompressed thumbnails sometimes occupy more space than the original JPEG image when compressed). Use this option carefully.

NOTE: The JPEG format does not allow the storage of "large" thumbnails. This is due to the marker segment length, which cannot be greater than 65,536 bytes. The maximum size of a color thumbnail is about 100x200 or 200x100 pixels, and the maximum size of a grayscale thumbnail is about 300x200 or 200x300 pixels.

Lossless JPEG Predictor Settings

The Lossless JPEG scheme is "predictive" in nature-it uses the values of surrounding pixels in addition to the value of the original pixel to calculate a predictor value, which it then subtracts from the value of the original pixel. The resulting pixel value will be reduced such that it can be compressed more than the original value. The higher the number of neighboring pixels used, the higher the compression will be.

Regardless of the predictor value setting, the quality of the image will remain the same. The difference is that if you choose to optimize for space by setting a high predictor value, you will have to give up some speed, as the decompression will take longer to perform.

ImageGear lets you set the predictor value using "PREDICTOR" control parameter. The ImageGear default for this setting is 1. The allowed range is 1-7. The graphic below shows a predictor (x) and three reconstructed samples (a,b,c) immediately to the left, immediately above, and diagonally to the left of the current sample

Lossless JPEG does not apply DCT for an image as per the Lossy JPEG compression. Instead, it uses a DPCM difference coding, which can be carried out with any one of seven different prediction modes. Correspondingly, the IG_CONTROL_JPG_PREDICTOR control parameter can be set to a value between 0 and 7. In Table 4, you will see what algorithm your setting of 1-7 will use, where Pr Px is the predictor, and Ra, Rb, and Rc are the reconstructed samples:

Value
JPEG DIS Prediction
0
no prediction
1
Px = Ra
2
Px = Rb
3
Px = Rc
4
Px = Ra + Rb - Rc
5
Px = Ra + ((Rb-Rc)/2)
6
Px = Rb + ((Ra-Rc)/2)
7
Px = (Ra + Rb)/2

JPEG Quality

The baseline JPEG specification calls for a quality setting. The lower the setting, the greater the number of original pixels lost, and therefore the smaller the resulting compressed file will be. ImageGear lets you set the quality of compression with values of type INT between 1-100, where 100 provides the highest retention of original pixel values. A setting of 100 does not mean that the image includes 100% of all original pixel values. With Lossy JPEG, there is no such thing as "no loss". Control parameter for setting Lossy JPEG quality is "QUALITY".

JPEG Entropy Optimization

Entropy optimization is relevant only to standard Lossy JPEG compression. If you set the parameter to true, the default Huffman tables are not used. Instead, optimal Huffman tables are created for each component. This can bring a higher compression ratio but it takes more time for the compression.

References used:

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. Windcrest Books, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


JPEG2000

Full Name
JPEG2000
Format ID
ImGearFormats.JPEG2K
File Extension(s)
*.jp2, *.jpc, *.j2k, *.j2c
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
Read/write
IG Platforms Support
WIN32, WIN64, .NET, .NET64

NOTE: JPEG2000 format requires ImageGear.Formats.JPEG2K Namespace.

ImageGear Supported versions:

ISO/IEC 15444-1:2000

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.JPEG2K:
    • Indexed RGB: 1..8 bpp;
    • Grayscale: 1..16 bpc
    • RGB: 1..16 bpc
    • Grayscale + Alpha: 1..16 bpc
    • RGB + Alpha: 1..16 bpc

ImageGear Write Support:

  • ImGearCompressions.JPEG2K:
    • Indexed RGB: 1..8 bpp;
    • Grayscale: 1..16 bpc
    • RGB: 1..16 bpc
    • Grayscale + Alpha: 1..16 bpc
    • RGB + Alpha: 1..16 bpc

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
CodeBlockSize
Int
64
Powers of 2 and no less than 4.
Nominal code-block dimension. Actual dimension is the subject to precinct, tile and image dimensions.
CodeBlockStyle
ImGearJPEG2KCodeBlockStyles
ImGearJPEG2KCodeBlockStyles.ALL_OFF
Any combination of values from ImGearJPEG2KCodeBlockStyles.
Block coder mode switches.
DiscardLevels
Int
0
From 0 to max value depending on DWT levels in compressed JPEG 2000 image.
This parameter affects the decompression process. It allows you to load reduced version of image, which takes less time then loading of the whole image.
It This parameter indicates the number of highest resolution DWT levels which will not appear at the output image. Image dimensions are essentially divided by 2 to the power of this number. If specified number exceeds the number of DWT levels then it will be set to the maximal possible value.
To allow using DiscardLevels parameter on images saved by ImageGear you must save images with WaveletLevels parameter set to more then one level.
FileFormat
ImGearJPEG2KType
ImGearJPEG2KType.FILE_FORMAT
Any ImGearJPEG2KType value
This parameter specifies whether the result file will be a JP2-compatible file or a raw JPEG2000 code-stream. Fully JP2/JPX compatible file contains various metadata such as resolution, color space, palette, XML, etc. Raw code-stream does not store any metadata.
Mode
ImGearJPEG2KModes
ImGearJPEG2KModes.FAST
Any ImGearJPEG2KModes value.
This parameter specifies a mode of the reading process.
ImGearJPEG2KModes.FAST - Fast mode is used by default. In this case, compliance is assumed and checking is minimized; there is no attempt to recover from any errors.
ImGearJPEG2KModes.FUSSY - In fussy mode, the code-stream management machinery makes a serious attempt to identify compliance violations and generates an appropriate terminal error message if it finds one.
ImGearJPEG2KModes.RESILIENT - In esilient mode, the code-stream management machinery makes a serious attempt to both detect and recover from errors in the code-stream. We attempt to guarantee that decompression will not fail, so long as the main header is not corrupted and there is only one tile with one tile-part.
ProgressionOrder
ImGearJPEG2KProgressionOrders
ImGearJPEG2KProgressionOrders.LRCP
Any ImGearJPEG2KProgressionOrders value
This parameter specifies progression order.
QualityLayers
Int
Double[]
Array of one or more double values, or null.
This parameter represents more powerful variant of RateBytes control parameter. Its value is an array of one or more bit-rates, expressed in terms of the ratio between the total number of compressed bits (including headers) and the largest horizontal and vertical image component dimensions. The number of elements in array represents the number of quality layers. If parameter is null, then RateBytes parameter is used to limit the output codestream.
QuantizationStep
Double
1.0 / 256.0
Any double value.
This parameter specifies a quantization step parameter. Lossless compression method is achieved through a quantization step size of 1.
RateBytes
Int
0
0 - (2^32 - 1)
This parameter sets required size of the compressed data (in bytes). If zero, the lossless compression method is used.
StitchTiles
Boolean
True
False, True
This parameter specifies the way tiled images should de loaded. If true then all tiles are stitched into image. If false, then the single tile can be loaded.
TileHeight
Int
0
0 - (2^32 - 1)
This parameter specifies the height of one tile in the reference grid. A zero value indicates the image's height.
TileWidth
Int
0
0 - (2^32 - 1)
This parameter specifies the width of one tile in reference grid. A zero value indicates the image's width.
ViewHeight
Int
0
0 - (2^32 - 1)
This parameter is used for loading reduced copies of big images. A zero value indicates the initial image's height.
ViewWidth
Int
0
0 - (2^32 - 1)
This parameter is used for loading reduced copies of big images. A zero value indicates the initial image's width.
WaveletFilter
ImGearJPEG2KFilters
ImGearJPEG2KFilters.AUTO
Any ImGearJPEG2KFilters value.
Specifies the type of Wavelet filter to be used for Wavelet Discrete Transform:
ImGearJPEG2KFilters.AUTO automatically selects the best transform depending on image type. It selects irreversible transform for true color and grayscale images, and reversible transform for paletted images.
ImGearJPEG2KFilters.REVERSIBLE is a reversible transform based on 5\3 filter. This mode allows saving JP2 filter as lossless.
ImGearJPEG2KFilters.IRREVERSIBLE is an irreversible transform based on Daubechies 9\7 filter. It allows JP2 filter to apply lossy compression. The amount of loss and compression ratio are defined by other parameters, such as RateBytes and QualityLayers.
Selecting the ImGearJPEG2KFilters.REVERSIBLE filter does not guarantee that image will be saved without loss of quality. To save the image in lossless mode, set RateBytes to 0.
Applying irreversible transform to paletted images may result in significant degradation of image quality, because small changes in pixel values may result in significant visual difference after application of palette. Consider using reversible transform for paletted images, or promote images to true color and then use reversible transform.
WaveletLevels
Int
1
0 - 16
Specifies quantity of decomposition levels (stages) for image being saved. Main purpose of each level is to provide ability to faster decompress reduced in size version of original image. Level number defines size of reduced image: level[0] allows you to get whole image, level[1] lets get original image reduced in two times by each dimension, level[2] - allows get into four times and etc.
The default value for this parameter is '-1', which tells ImageGear to select the value automatically depending on image type. In this mode, ImageGear uses 0 for paletted images and 5 for other cases.

Non-image Data Structure:

ImageGear JPEG2K format filter allows you to work with non-image data stored in supported file formats. It provides metadata tags that make possible manipulating with such kinds of non-image information:

  • XML & IPR information,
  • alpha channels mapping,
  • format type information,
  • Type of compression (loss, lossless).

There are the following metadata tags you can use to work with JP2 files:

"AlphaMapping"

This tag establishes the relationship, if any, between color channels and alpha (and/or pre-multiplied) alpha channels. Each element of array specifies number of alpha channel associated with regular (color) channel. Zero or negative value means absence of alpha mapping for particular color channel. For example:

"AlphaMapping" with {1, 1, 1, -1} as value means that all red, green and blue channels of image are mapped to single (first) alpha channel, which available under 0-index for current image through ImageGear API. {-1, 2, 1, -1} value means availability of two different alpha channels for green and blue channels and absence of alpha channel for red channel.

Addinional information about available alpha channels can be accessed through "Alpha1", "Alpha2", "Alpha3" and "Alpha4" tags.

"Alpha1", "Alpha2", "Alpha3", "Alpha4"

Each of these tags represents information about alpha channels. Valid value for each tag is array with three integer elements. First element represents index of codestream (-1 or non-negative value), in which alpha channel is (or "should be" in case of write) resided. Second - index of component in which alpha is stored (-1 or non-negative value). Last element specifies whether alpha is regular (0) or pre-multiplied (1). For example:

"Alpha1" with {0, 3, 0} as value means that first alpha channel is regular and located in fourth component of the first codestream. {1, 0, 1} value represents pre-multiplied alpha in first component of second codestream in JPX layer.

"XML"

This tag serves for getting and setting some specific information written in XML language. Please note that only JPEG2000 format is able to store XML data. It must be set as a text string.

"IPR"

This tag serves for getting and setting IPR (Intellectual Property Rights) information. The IPR metadata defines metadata to either protect the rights of the owner of the image or provide further information to request permission to use it. It is important for developers and users to properly protect the rights of the owner of the image data.

Please note that only JPEG2000 format is able to store IPR data. It must be set as a text string.

"Format"

This tag serves for getting format of JPEG2K file. Its possible values are:

  • IG_JPEG2K_FORMAT_CODESTREAM = 0
  • IG_JPEG2K_FORMAT_JP2 = 1
"CompressionType"

This tag serves for getting a compression type of JPEG2K image. Its possible values are:

  • IG_JPEG2K_TYPE_LOSSY = 0
  • IG_JPEG2K_TYPE_LOSSLESS = 1

JPEG2K sets one of these values depending on the type of the image. This tag is not used in JPEG2K writing.

Comments:

JPEG 2000 standard defines a compression scheme and a file format for interchange of JPEG2000 compressed data.

The compression scheme is based on a discrete wavelet transform, and supports both lossy and lossless modes. JPEG 2000 compression is similar to JPEG in that it supports lossy compression. However, JPEG2000 allows achieving much higher compression ratios while preserving good image quality.

JPEG2000 file format defines a basic set of features that allow interchange of JPEG2000 compressed images.


JPX

Full Name
JPEG2000 Extensions
Format ID
ImGearFormats.JPX
File Extension(s)
*.jpx
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
Yes
IG Platforms Support
WIN32, WIN64, .NET, .NET64

NOTE: JPX format requires ImageGear.Formats.JPEG2K Namespace.

ImageGear Supported versions:

ISO/IEC 15444-2:2000

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.JPEG2K:
    • Indexed RGB: 1..8 bpp;
    • Grayscale: 1..16 bpc
    • RGB: 1..16 bpc
    • YCbCr: 1..16 bpc
    • Lab: 1..16 bpc
    • CMY: 1..16 bpc
    • CMYK: 1..16 bpc
    • Grayscale + Alpha: 1..16 bpc
    • RGB + Alpha: 1..16 bpc

ImageGear Write Support:

  • ImGearCompressions.JPEG2K:
    • Indexed RGB: 1..8 bpp;
    • Grayscale: 1..16 bpc
    • RGB: 1..16 bpc
    • YCbCr: 1..16 bpc
    • Lab: 1..16 bpc
    • CMY: 1..16 bpc
    • CMYK: 1..16 bpc
    • Grayscale + Alpha: 1..16 bpc
    • RGB + Alpha: 1..16 bpc

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
CodeBlockSize
Int
64
Powers of 2 and no less than 4.
Nominal code-block dimension. Actual dimension is the subject to precinct, tile and image dimensions.
CodeBlockStyle
ImGearJPEG2KCodeBlockStyles
ImGearJPEG2KCodeBlockStyles.ALL_OFF
Any combination of values from ImGearJPEG2KCodeBlockStyles.
Block coder mode switches.
DiscardLevels
Int
0
From 0 to max value depending on DWT levels in compressed JPEG 2000 image.
This parameter affects the decompression process. It allows you to load reduced version of image, which takes less time then loading of the whole image.
It This parameter indicates the number of highest resolution DWT levels which will not appear at the output image. Image dimensions are essentially divided by 2 to the power of this number. If specified number exceeds the number of DWT levels then it will be set to the maximal possible value.
To allow using DiscardLevels parameter on images saved by ImageGear you must save images with WaveletLevels parameter set to more then one level.
FileFormat
ImGearJPEG2KType
ImGearJPEG2KType.FILE_FORMAT
Any ImGearJPEG2KType value
This parameter specifies whether the result file will be a JP2-compatible file or a raw JPEG2000 code-stream. Fully JP2/JPX compatible file contains various metadata such as resolution, color space, palette, XML, etc. Raw code-stream does not store any metadata.
LoadComposition
Boolean
False
False, True
This parameters affects JPX filter only and allows switching between loading of single layer and loading result composition of all available layers according to composition rules, resided within JPX file.
Mode
ImGearJPEG2KModes
ImGearJPEG2KModes.FAST
Any ImGearJPEG2KModes value.
This parameter specifies a mode of the reading process.
ImGearJPEG2KModes.FAST - Fast mode is used by default. In this case, compliance is assumed and checking is minimized; there is no attempt to recover from any errors.
ImGearJPEG2KModes.FUSSY - In fussy mode, the code-stream management machinery makes a serious attempt to identify compliance violations and generates an appropriate terminal error message if it finds one.
ImGearJPEG2KModes.RESILIENT - In esilient mode, the code-stream management machinery makes a serious attempt to both detect and recover from errors in the code-stream. We attempt to guarantee that decompression will not fail, so long as the main header is not corrupted and there is only one tile with one tile-part.
ProgressionOrder
ImGearJPEG2KProgressionOrders
ImGearJPEG2KProgressionOrders.LRCP
Any ImGearJPEG2KProgressionOrders value
This parameter specifies progression order.
QualityLayers
Int
Double[]
Array of one or more double values, or null.
This parameter represents more powerful variant of RateBytes control parameter. Its value is an array of one or more bit-rates, expressed in terms of the ratio between the total number of compressed bits (including headers) and the largest horizontal and vertical image component dimensions. The number of elements in array represents the number of quality layers. If parameter is null, then RateBytes parameter is used to limit the output codestream.
QuantizationStep
Double
1.0 / 256.0
Any double value.
This parameter specifies a quantization step parameter. Lossless compression method is achieved through a quantization step size of 1.
RateBytes
Int
0
0 - (2^32 - 1)
This parameter sets required size of the compressed data (in bytes). If zero, the lossless compression method is used.
StitchTiles
Boolean
True
False, True
This parameter specifies the way tiled images should de loaded. If true then all tiles are stitched into image. If false, then the single tile can be loaded.
TileHeight
Int
0
0 - (2^32 - 1)
This parameter specifies the height of one tile in the reference grid. A zero value indicates the image's height.
TileWidth
Int
0
0 - (2^32 - 1)
This parameter specifies the width of one tile in reference grid. A zero value indicates the image's width.
ViewHeight
Int
0
0 - (2^32 - 1)
This parameter is used for loading reduced copies of big images. A zero value indicates the initial image's height.
ViewWidth
Int
0
0 - (2^32 - 1)
This parameter is used for loading reduced copies of big images. A zero value indicates the initial image's width.
WaveletFilter
ImGearJPEG2KFilters
ImGearJPEG2KFilters.AUTO
Any ImGearJPEG2KFilters value.
Specifies the type of Wavelet filter to be used for Wavelet Discrete Transform:
ImGearJPEG2KFilters.AUTO automatically selects the best transform depending on image type. It selects irreversible transform for true color and grayscale images, and reversible transform for paletted images.
ImGearJPEG2KFilters.REVERSIBLE is a reversible transform based on 5\3 filter. This mode allows saving JP2 filter as lossless.
ImGearJPEG2KFilters.IRREVERSIBLE is an irreversible transform based on Daubechies 9\7 filter. It allows JP2 filter to apply lossy compression. The amount of loss and compression ratio are defined by other parameters, such as RateBytes and QualityLayers.
Selecting the ImGearJPEG2KFilters.REVERSIBLE filter does not guarantee that image will be saved without loss of quality. To save the image in lossless mode, set RateBytes to 0.
Applying irreversible transform to paletted images may result in significant degradation of image quality, because small changes in pixel values may result in significant visual difference after application of palette. Consider using reversible transform for paletted images, or promote images to true color and then use reversible transform.
WaveletLevels
Int
1
0 - 16
Specifies quantity of decomposition levels (stages) for image being saved. Main purpose of each level is to provide ability to faster decompress reduced in size version of original image. Level number defines size of reduced image: level[0] allows you to get whole image, level[1] lets get original image reduced in two times by each dimension, level[2] - allows get into four times and etc.
The default value for this parameter is '-1', which tells ImageGear to select the value automatically depending on image type. In this mode, ImageGear uses 0 for paletted images and 5 for other cases.

Non-image Data Structure:

ImageGear JPX format filter allows you to work with non-image data stored in supported file formats. It provides metadata tags that make possible manipulating with such kinds of non-image information:

  • XML & IPR information,
  • alpha channels mapping,
  • chroma keys,
  • composition layers,

There are the following metadata tags you can use to work with JPX files:

"AlphaMapping"

This tag establishes the relationship, if any, between color channels and alpha (and/or pre-multiplied) alpha channels. Each element of array specifies number of alpha channel associated with regular (color) channel. Zero or negative value means absence of alpha mapping for particular color channel. For example:

"AlphaMapping" with {1, 1, 1, -1} as value means that all red, green and blue channels of image are mapped to single (first) alpha channel, which available under 0-index for current image through ImageGear API. {-1, 2, 1, -1} value means availability of two different alpha channels for green and blue channels and absence of alpha channel for red channel.

Addinional information about available alpha channels can be accessed through "Alpha1", "Alpha2", "Alpha3" and "Alpha4" tags.

"Alpha1", "Alpha2", "Alpha3", "Alpha4"

Each of these tags represents information about alpha channels. Valid value for each tag is array with three integer elements. First element represents index of codestream (-1 or non-negative value), in which alpha channel is (or "should be" in case of write) resided. Second - index of component in which alpha is stored (-1 or non-negative value). Last element specifies whether alpha is regular (0) or pre-multiplied (1). For example:

"Alpha1" with {0, 3, 0} as value means that first alpha channel is regular and located in fourth component of the first codestream. {1, 0, 1} value represents pre-multiplied alpha in first component of second codestream in JPX layer.

NOTE: For JP2 and MJ2 file formats value of the first element (codestream index) is restricted to {-1, 0} set. Only for JPX files it's allowed to store alpha channels in separate codestream.
"Chroma"

This tag contains array of values each of which is treated as fully-transparent for particular channel. Negative value of any element means absence of chroma-key.

"ComposedLayersQty"

This tag specifies number of composed layers involved into loaded composition. It appears only for images loaded by JPX filter with value of LoadComposition control parameter set to True.

"XML"

This tag serves for getting and setting some specific information written in XML language. Please note that only JPEG2000 format is able to store XML data. It must be set as a text string.

"IPR"

This tag serves for getting and setting IPR (Intellectual Property Rights) information. The IPR metadata defines metadata to either protect the rights of the owner of the image or provide further information to request permission to use it. It is important for developers and users to properly protect the rights of the owner of the image data.

Please note that only JPEG2000 format is able to store IPR data. It must be set as a text string.

Comments:

JPX file format is an extension to JPEG 2000 file format. It normally uses JPEG 2000 compression, but allows other compressions as well, such as JBIG, CCITT Group3, CCITT Group4, etc. The format provides advanced features such as multiple layers for an image, various colorspaces, opacity (alpha channel) and fragmented codestreams.


KFX

Full Name
KFX (Kofax Group4 image)
Format ID
ImGearFormats.KFX
File Extension(s)
*.kfx
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight

ImageGear Supported versions:

  • Version 3

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

  • ImGearCompressions.CCITT_G4 - 1bpp

ImageGear Write Support:

No

ImageGear Filter Control Parameters:

None

Comments:

N/A


LV

Full Name
LV (Lazer View format)
Format ID
ImGearFormats.LV
File Extension(s)
*.lv
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

  • ImGearCompressions.CCITT_G3 - 1bpp
  • ImGearCompressions.CCITT_G4 - 1bpp

ImageGear Write Support:

No

ImageGear Filter Control Parameters:

None

Comments:

N/A


Motion JPEG2000

Full Name
Motion JPEG2000
Format ID
ImGearFormats.MJ2
File Extension(s)
*.mj2
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
Read only
IG Platforms Support
WIN32, WIN64, .NET, .NET64

NOTE: Motion JPEG2000 format requires ImageGear.Formats.JPEG2K Namespace.

ImageGear Supported versions:

ISO/IEC 15444-3:2002

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

  • ImGearCompressions.JPEG2K:
    • Indexed RGB: 1..8 bpp;
    • Grayscale: 1..16 bpc
    • RGB: 1..16 bpc
    • Grayscale + Alpha: 1..16 bpc
    • RGB + Alpha: 1..16 bpc

ImageGear Write Support:

No

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
CodeBlockSize
Int
64
Powers of 2 and no less than 4.
Nominal code-block dimension. Actual dimension is the subject to precinct, tile and image dimensions.
CodeBlockStyle
ImGearJPEG2KCodeBlockStyles
ImGearJPEG2KCodeBlockStyles.ALL_OFF
Any combination of values from ImGearJPEG2KCodeBlockStyles.
Block coder mode switches.
DiscardLevels
Int
0
From 0 to max value depending on DWT levels in compressed JPEG 2000 image.
This parameter affects the decompression process. It allows you to load reduced version of image, which takes less time then loading of the whole image.
It This parameter indicates the number of highest resolution DWT levels which will not appear at the output image. Image dimensions are essentially divided by 2 to the power of this number. If specified number exceeds the number of DWT levels then it will be set to the maximal possible value.
To allow using DiscardLevels parameter on images saved by ImageGear you must save images with WaveletLevels parameter set to more then one level.
FileFormat
ImGearJPEG2KType
ImGearJPEG2KType.FILE_FORMAT
Any ImGearJPEG2KType value
This parameter specifies whether the result file will be a JP2-compatible file or a raw JPEG2000 code-stream. Fully JP2/JPX compatible file contains various metadata such as resolution, color space, palette, XML, etc. Raw code-stream does not store any metadata.
Mode
ImGearJPEG2KModes
ImGearJPEG2KModes.FAST
Any ImGearJPEG2KModes value.
This parameter specifies a mode of the reading process.
ImGearJPEG2KModes.FAST - Fast mode is used by default. In this case, compliance is assumed and checking is minimized; there is no attempt to recover from any errors.
ImGearJPEG2KModes.FUSSY - In fussy mode, the code-stream management machinery makes a serious attempt to identify compliance violations and generates an appropriate terminal error message if it finds one.
ImGearJPEG2KModes.RESILIENT - In esilient mode, the code-stream management machinery makes a serious attempt to both detect and recover from errors in the code-stream. We attempt to guarantee that decompression will not fail, so long as the main header is not corrupted and there is only one tile with one tile-part.
ProgressionOrder
ImGearJPEG2KProgressionOrders
ImGearJPEG2KProgressionOrders.LRCP
Any ImGearJPEG2KProgressionOrders value
This parameter specifies progression order.
QualityLayers
Int
Double[]
Array of one or more double values, or null.
This parameter represents more powerful variant of RateBytes control parameter. Its value is an array of one or more bit-rates, expressed in terms of the ratio between the total number of compressed bits (including headers) and the largest horizontal and vertical image component dimensions. The number of elements in array represents the number of quality layers. If parameter is null, then RateBytes parameter is used to limit the output codestream.
QuantizationStep
Double
1.0 / 256.0
Any double value.
This parameter specifies a quantization step parameter. Lossless compression method is achieved through a quantization step size of 1.
RateBytes
Int
0
0 - (2^32 - 1)
This parameter sets required size of the compressed data (in bytes). If zero, the lossless compression method is used.
StitchTiles
Boolean
True
False, True
This parameter specifies the way tiled images should de loaded. If true then all tiles are stitched into image. If false, then the single tile can be loaded.
TileHeight
Int
0
0 - (2^32 - 1)
This parameter specifies the height of one tile in the reference grid. A zero value indicates the image's height.
TileWidth
Int
0
0 - (2^32 - 1)
This parameter specifies the width of one tile in reference grid. A zero value indicates the image's width.
VideoTrack
Int
1
Any non-zero value
This parameter is available for Motion JPEG2000 filter and specifies video tracks from which frame should be loaded.
ViewHeight
Int
0
0 - (2^32 - 1)
This parameter is used for loading reduced copies of big images. A zero value indicates the initial image's height.
ViewWidth
Int
0
0 - (2^32 - 1)
This parameter is used for loading reduced copies of big images. A zero value indicates the initial image's width.
WaveletFilter
ImGearJPEG2KFilters
ImGearJPEG2KFilters.AUTO
Any ImGearJPEG2KFilters value.
Specifies the type of Wavelet filter to be used for Wavelet Discrete Transform:
ImGearJPEG2KFilters.AUTO automatically selects the best transform depending on image type. It selects irreversible transform for true color and grayscale images, and reversible transform for paletted images.
ImGearJPEG2KFilters.REVERSIBLE is a reversible transform based on 5\3 filter. This mode allows saving JP2 filter as lossless.
ImGearJPEG2KFilters.IRREVERSIBLE is an irreversible transform based on Daubechies 9\7 filter. It allows JP2 filter to apply lossy compression. The amount of loss and compression ratio are defined by other parameters, such as RateBytes and QualityLayers.
Selecting the ImGearJPEG2KFilters.REVERSIBLE filter does not guarantee that image will be saved without loss of quality. To save the image in lossless mode, set RateBytes to 0.
Applying irreversible transform to paletted images may result in significant degradation of image quality, because small changes in pixel values may result in significant visual difference after application of palette. Consider using reversible transform for paletted images, or promote images to true color and then use reversible transform.
WaveletLevels
Int
1
0 - 16
Specifies quantity of decomposition levels (stages) for image being saved. Main purpose of each level is to provide ability to faster decompress reduced in size version of original image. Level number defines size of reduced image: level[0] allows you to get whole image, level[1] lets get original image reduced in two times by each dimension, level[2] - allows get into four times and etc.
The default value for this parameter is '-1', which tells ImageGear to select the value automatically depending on image type. In this mode, ImageGear uses 0 for paletted images and 5 for other cases.

Non-image Data Structure:

ImageGear MJ2 format filter allows you to work with non-image data stored in supported file formats. It provides metadata tags that make possible manipulating with such kinds of non-image information:

  • alpha channels mapping,

There are the following metadata tags you can use to work with MJ2 files:

"AlphaMapping"

This tag establishes the relationship, if any, between color channels and alpha (and/or pre-multiplied) alpha channels. Each element of array specifies number of alpha channel associated with regular (color) channel. Zero or negative value means absence of alpha mapping for particular color channel. For example:

"AlphaMapping" with {1, 1, 1, -1} as value means that all red, green and blue channels of image are mapped to single (first) alpha channel, which available under 0-index for current image through ImageGear API. {-1, 2, 1, -1} value means availability of two different alpha channels for green and blue channels and absence of alpha channel for red channel.

Addinional information about available alpha channels can be accessed through "Alpha1", "Alpha2", "Alpha3" and "Alpha4" tags.

"Alpha1", "Alpha2", "Alpha3"

Each of these tags represents information about alpha channels. Valid value for each tag is array with three integer elements. First element represents index of codestream (-1 or non-negative value), in which alpha channel is (or "should be" in case of write) resided. Second - index of component in which alpha is stored (-1 or non-negative value). Last element specifies whether alpha is regular (0) or pre-multiplied (1). For example:

"Alpha1" with {0, 3, 0} as value means that first alpha channel is regular and located in fourth component of the first codestream. {1, 0, 1} value represents pre-multiplied alpha in first component of second codestream in JPX layer.

NOTE: For JP2 and MJ2 file formats value of the first element (codestream index) is restricted to {-1, 0} set. Only for JPX files it's allowed to store alpha channels in separate codestream.

Comments:

Motion JPEG2000 file format is designed to contain one or more motion sequences of JPEG2000 images, with their timing, and also optional audio annotations, all composed into an overall presentation.


MSP

Full Name
MSP (MS Paint)
Format ID
ImGearFormats.MSP
File Extension(s)
*.msp
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight

ImageGear Supported versions:

  • Version 2.0
  • Version 1.0

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

  • ImGearCompressions.NONE: Indexed RGB: 1 bpp
  • ImGearCompressions.RLE: Indexed RGB: 1 bpp

ImageGear Write Support:

No

ImageGear Filter Control Parameters:

None

Comments:

This was a popular format for storing line drawing and clip art images created with Windows applications, but has recently begun to be replaced by the Windows bitmap format (also supported by ImageGear see BMP).

For versions earlier than 2.0, the format begins with a 32-byte header and immediately proceeds with the bitmap data. The header information includes: the version of the file, the size and aspect ratio of the bitmap, and the width and height and aspect ratio (in pixels) of the output device used to render the bitmapped image. The bitmap data is uncompressed.

Files made with Version 2.0 and later always use RLE compression. In these files a "scan-line map" follows the header and precedes the data. It gives offsets to each scan line for instances when a particular scan line needs to be examined. All previous lines can remain compressed, while the needed line is located.

See RLE Compression Compression under the ImageGear Supported Compressions Reference section of this chapter for more information.

References used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


NCR

Full Name
NCR
Format ID
ImGearFormats.NCR
File Extension(s)
*.ncr
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.CCITT_G4 - Indexed RGB: 1 bpp
  • ImGearCompressions.NONE - Indexed RGB: 1, 4 bpp

ImageGear Write Support:

  • ImGearCompressions.CCITT_G4 - Indexed RGB: 1 bpp

ImageGear Filter Control Parameters:

None.

Comments:

NCR is the black and white image compression format.


PBM

Full Name
PBM (Portable Bitmap File Format)
Format ID
ImGearFormats.PBM
File Extension(s)
*.pbm
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight

ImageGear Supported versions:

October 1991 - last release

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.RAW:
    • Indexed RGB: 1 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp
  • ImGearCompressions.ASCII:
    • Indexed RGB: 1 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp

ImageGear Write Support:

  • ImGearCompressions.RAW:
    • Indexed RGB: 1 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp
  • ImGearCompressions.ASCII:
    • Indexed RGB: 1 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp

ImageGear Filter Control Parameters:

None

Comments:

This is useful for quick and easy transfer of monochrome bitmap images, although the encoding scheme is not efficient in terms of storage space. This format, as well as the PGM, PNM, and PPM formats, are at the core of a set of utility programs also written by Jef Poskanzer. Among other things, these formats serve as intermediary storage methods for the conversion of other file formats.

The Portable Bitmap File Format structure is very simple. It begins with a short ASCII header that contains the file type identifier (magic number), the width and height of the image, and perhaps a comment line identifying the filename. Following white space (usually a carriage return) is the bitmap data. The number of bits is equal to the width * height. A pixel value of 0 indicates white, and a value of 1 indicates black.

The magic number of the header can have one of two values: either P1 or P4. P1 indicates that the bitmap data are to be read as ASCII decimal values. P4 indicates that the bitmap data are stored as plain bytes. Because 8 pixel values (1 bit each) are stored in one byte, the file is 8 times smaller than in the ASCII decimal format. White spaces are permitted in the P1 format but not permitted in the P4 format.

NOTE: Note: ImageGear uses IG_FORMAT_PBM filter to handle the whole family of formats: PBM (1-bit), PGM (grayscale), PPM (truecolor) and PNM (collective name for all of above). When saving image as IG_FORMAT_PBM format, ImageGear chooses particular format (PBM, PGM, PNM or PPM) depending on image bit depth.
See Also:

PGM, PPM, PNM

References used

Kay, David C. and John R. Levine. Graphics File Formats, 2nd ed. Windcrest /McGraw-Hill, 1995.

PBM Specification by Jef Poskanzer, copyright © 1989, 1991.


PCD

Full Name
PCD (Kodak Photo CD)
Format ID
ImGearFormats.PCD
File Extension(s)
*.pcd
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight

ImageGear Supported versions:

All valid PCD files in 5 different resolutions:

  • Resolution 1: 768x512
  • Resolution 2: 384x256
  • Resolution 3: 192x128
  • Resolution 4: 1536x1024
  • Resolution 5: 3072x2048

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading

ImageGear Read Support:

  • ImGearCompressions.NONE - RGB: 24 bpp
  • ImGearCompressions.HUFFMAN - RGB: 24 bpp

ImageGear Write Support:

No

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
Resolution
int
0
0..4
Resolution level to load:
  • 0 = load last (largest) resolution (Resolution 5: 3072x2048)
  • 1 = load second to last resolution (Resolution 4: 1536x1024)
  • 2 = load middle resolution (Resolution 3: 192x128)
  • 3 = load second resolution (Resolution 2: 384x256)
  • 4 or higher = load first (smallest) resolution (Resolution 1: 768x512)

Comments:

"Photo CD" is the informally adopted name for files created using the Photo CD-ROM-based storage and retrieval system created by Kodak. The images are digitized versions of photographic images. Using a Photo CD player, images can be viewed on television. Although intended for photographic images, the data source does not necessarily have to be film. Due to the large storage capacity of the CD medium, this format supports very large and/or intricate images.

Images and their associated information are stored in groups called "sessions". Originally, they were stored at the rate of one session per CD, but later versions allowed multiple sessions per disc.

For each stored image, there are up to 5 bitmaps, each representing the image at a different resolution. The bitmaps at the lowest resolution are intended for such purposes as displaying thumbnails and previewing an image.

To find out the number of resolutions in a PCD image, load image header using ImGearFileFilters Class . LoadPageHeader Method, and then check ImGearPage Class.Metadata.Common.ResolutionLayersCount property.

Note that resolutions in a PCD image are not ordered by size. See the list of resolutions and their sizes in the format description above.

References used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


PCX

Full Name
PCX (PC Paintbrush File Format)
Format ID
ImGearFormats.PCX
File Extension(s)
*.pcx
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight

ImageGear Supported versions:

  • Version 5.0 1991, Supports 24-bit RGB
  • Version 3.0
  • Version 2.8 Included color palette
  • Version 2.5

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp

ImageGear Write Support:

  • ImGearCompressions.RLE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp

ImageGear Filter Control Parameters:

None.

Comments:

PCX is one of the oldest PC-based bitmap formats. It became well-known when Microsoft used it for their Paintbrush for Windows application and distributed it with every copy of Windows. This format is popular for fax documents because it allows them to be viewed within many popular paint and image display programs. If multiple images are desired in a PCX format, the format known as DCX, designed for this purpose, (and supported by ImageGear), may be used. Please see DCX file format for more information.

The main components of the PCX file format are the fixed length header, the image data, and if it is written for VGA display technology, the palette for the image (this appears as the last structure in the file). The header includes fields including the PCX version, the image size, resolution and position, and an encoding field that always has a value of 1; PCX data is always RLE. (For complex images, this may actually cause the bitmap data to increase in size).

The size and location of the palette associated with the image depends on the version of the PCX. When it was first developed, the limitations of the EGA card led to a palette that contained just 16 colors. PCX also supported CGA, so that the palette contained only 4 colors. Both of these palettes were stored in the palette array structure of the header. When the PCX was modified to display VGA, there was not enough room to store the palette in the header; subsequently, it was located at the end of the file.

References used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. Windcrest Books, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


PGM

Full Name
PGM (Portable Graymap File Format)
Format ID
ImGearFormats.PBM (see the Note below)
File Extension(s)
*.pgm
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight, Photo Editing

NOTE: ImageGear supports PGM file format via its IG_FORMAT_PBM format filter. Use IG_FORMAT_PBM to save grayscale images to PGM format.

ImageGear Supported versions:

October 1991 - last release

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.RAW - Grayscale: 8, 16 bpp
  • ImGearCompressions.ASCII - Grayscale: 8, 16 bpp

ImageGear Write Support:

  • ImGearCompressions.RAW - Grayscale: 8, 16 bpp
  • ImGearCompressions.ASCII - Grayscale: 8, 16 bpp

ImageGear Filter Control Parameters:

None

Comments:

This format quickly and easily transfers grayscale bitmap images. This format, as well as PBM, PNM, and PPM, are at the core of a set of utility programs also written by Jef Poskanzer. These formats serve as an intermediary storage methods for the conversion of other file formats.

The Portable Graymap File Format structure is very simple. It begins with a short ASCII header that contains the file type identifier (magic number), the width and height of the image, a "maximum gray value", and perhaps a comment line identifying the filename. The bitmap data follows white space (usually a carriage return). The number of pixels is equal to width * height. A pixel value of 0 indicates black, and a "maximum gray value" is equivalent to white.

The magic number of the header can have one of two values: either P2 or P5. P2 indicates that the bitmap data is read as ASCII decimal values. P5 indicates that the bitmap data is stored as plain bytes. This makes for a smaller and faster-to-read file.

If the maximum gray value does not exceed 255 (28 = 256 gray values from 0 to 255), each pixel is represented by a 8-bit sample. ImageGear loads such images as 8-bit grayscale. Otherwise, each pixel is represented by a 16-bit sample. ImageGear loads these images as 16-bit grayscale.

See Also:

PPM, PBM, PNM

References used

Kay, David C. and John R. Levine. Graphics File Formats, 2nd ed. Windcrest /McGraw-Hill, 1995.

PGM Specification by Jef Poskanzer, copyright © 1989, 1991.


PNG

Full Name
PNG (Portable Network Graphics)
Format ID
ImGearFormats.PNG
File Extension(s)
*.png
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
Supports single alpha channel for read/write.
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight, Photo Editing

ImageGear Supported versions:

  • 10th draft (future drafts will be backward-compatible)
  • PNG v2

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.DEFLATE:
    • Indexed RGB: 1, 2, 4, 8 bpp;
    • Grayscale: 1, 2, 4, 8, 16 bpp;
    • Grayscale + Alpha: 8, 16 bpp;
    • RGB: 24, 48 bpp;
    • RGB + Alpha: 32, 64 bpp

ImageGear Write Support:

  • ImGearCompressions.DEFLATE:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8, 16 bpp;
    • Grayscale + Alpha: 16, 32 bpp;
    • RGB: 24, 48 bpp;
    • RGB + Alpha: 32, 64 bpp

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
StripConfig
int
0 (fixed count)
0 (fixed count),
1 (fixed buffer)
Format of PNG strip, see ImGearPNGStrip constants
BufferSize
int
0
Any int value
Size of the buffer for strip if StripConfig is 1 (fixed buffer)
StripCount
int
0
Any int value
Number of lines in one strip if StripConfig is 0 (fixed count)
CompLevel
int
6 (default compression)
Any integer in range 0..9
Compression level. It must be between 0 (No compression) and 9 (max compression). Better compression takes more time for compression. See ImGearPNGCompLevel
KeepAlpha
bool
true
true,
false
When loading: if this parameter is True, then alpha channel is loaded into Alpha DIB. Otherwise, the image is transformed into RGB, by compositing over the background supplied in the bKGD chunk, if it is present, or over the default background.
When saving:
if this parameter is True, and alpha DIB is present, it will be written to the file.

Comments:

The PNG (pronounced "Ping") format was created out of reaction to Unisys's announcement that it would begin requiring royalty fees for use of its LZW compression scheme. This was the compression scheme for the widely-used GIF format (found in Web pages and online library images).

Thomas Boutell and a host of other programmers began working to devise a new file format to eliminate the need for payment of royalty fees. The result was a file format that offers better compression than GIF, and adds features GIF doesn't offer, including truecolor, and full alpha channel and gamma correction.

The basic organization of the PNG file format utilizes storage structures known as "chunks". A chunk is a block of data that contains its own header (identifying the chunk size and type). This makes it easy for a PNG viewer to identify chunks and to skip over the ones that are not necessary.

The first entry in a PNG file is the "PNG signature" that identifies the format as PNG. The file then proceeds with a series of chunks.

The IHDR Image Header, or IHDR Chunk, contains a number of fields including the height, width, depth, color type, and compression type of the image. The only valid compression value is 0, which indicates the PNG's custom compression scheme, a deflate/inflate compression with a 32k sliding window. This is a derivative of ZZ77, the precursor to LZW. ZZ77 is the compression scheme used by pkzip software.

The "PLTE Palette Chunk" contains 1 to 256 palette entries. This is present if the type field of the header chunk is set to 3. The number of colors cannot exceed the range provided by the bit depth.

The image data is stored in "IDAT Image Data Chunks". These are subdivided into chunks whose size is usually determined by the size of the encoder's buffer. The data may be stored in "interlaced order" allowing the image to be "faded in". The data may also be interlaced. Interlacing helps the appearance of an image as it displays while being decompressed, so that it "fades in". In a non-interlaced file, the presentation of the image data begins with row 1 and works downward to the last row of data. This method of display does not allow a quick preview of the whole image. When the data is interlaced, the lines are saved and displayed out of sequence. Every fourth row is displayed first and then filled in with every remaining fourth row, until all of the lines are displayed. This allows the eye to perceive the basic subject of the whole image before it is completely displayed.

"Ancillary Chunks" are optional. They must appear before the first IDAT and after the PLTE. One chunk is the "bKGD chunk" that sets the default background color for the image. Two of the other ancillary chunks are the "hHist Chunk" or histogram chunk, and the "tEXt" chunk. The histogram chunk appears if there is a palette. It stores the frequency of each color of the palette as it occurs in the image data. If the application doesn't support all of the colors in the palette, the histogram can be used to choose a subset of colors. There may be any number of text chunks. They can vary in length from 0 to the maximum chunk size. They include the image author, copyright information, and any desired comments.

Questions about PNG can be e-mailed to: png-info@uunet.uu.net

References used:

Murray, James D. "Graphic Image Format FAQ 3-4". James D. Murray, 1994-1996.

PNG (Portable Network Graphics), tenth draft. Page 5, copyright Thomas Boutell, May 1995.

Wegner, Tim. "Coding for PNG Graphics", "PC Techniques", Feb/Mar 1996, pp 32-38.


PNM

Full Name
PNM (Portable Any-Map File Format)
Format ID
ImGearFormats.PBM (See the Note below)
File Extension(s)
*.pnm
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight, Photo Editing

NOTE: ImageGear supports PNM file format via its IG_FORMAT_PBM format filter. Use IG_FORMAT_PBM to save images to PNM format.

ImageGear Supported versions:

October 1991 - last release

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.RAW:
    • Indexed RGB: 1 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp
  • ImGearCompressions.ASCII:
    • Indexed RGB: 1 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp

ImageGear Write Support:

  • ImGearCompressions.RAW:
    • Indexed RGB: 1 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp
  • ImGearCompressions.ASCII:
    • Indexed RGB: 1 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp

ImageGear Filter Control Parameters:

None

Comments:

The PNM format is useful for quick and easy transfer of uncomplicated monochrome, grayscale, or color bitmap images. This format, as well as the PBM, PGM, and PPM formats, are at the core of a set of utility programs also written by Jef Poskanzer. These formats serve as intermediary storage methods for the conversion of other file formats. For example, a function called gifftoppm translates a GIF file to a PPM, from where it can be then translated to a TIFF using the pnmtotiff.

The Portable Anymap File Format structure is very simple. The "Anymap" portion of its name refers to the fact that it can be one of three types of UNIX bitmap file formats: the Portable Bitmap File Format (PBM), the Portable Graymap File Format (PGM), or the Portable Pixelmap File Format (PPM). A PNM begins with a short ASCII header that contains the file type identifier (magic number), the width and height of the image, a "maximum color-component value" if it is a PPM, a "maximum gray value" if it is a PGM, and perhaps a comment line identifying the filename. Following white space (usually a carriage return) is the bitmap data. For PGM and PPM files, the number of pixels is equal to width * height (whereas, in a PBM file, this calculation gives you the number of bits).

The magic number of the header can have one of six values depending on whether the bitmap is in PBM, PGM, or PPM format. Each format can have one of two magic numbers depending on whether the pixel data is stored in ASCII decimal or plain bytes. See the descriptions for the individual formats (these are all supported by ImageGear) for more details.

References used

Kay, David C. and John R. Levine. Graphics File Formats, 2nd ed. Windcrest /McGraw-Hill, 1995.

PBM, PGM, PPM, PNM Specifications by Jef Poskanzer, copyright © 1989, 1991.


PPM

Full Name
PPM (Portable Pixmap File Format)
Format ID
ImGearFormats.PBM (See the Note below)
File Extension(s)
*.ppm
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight, Photo Editing

NOTE: ImageGear supports PPM file format via its IG_FORMAT_PBM format filter. Use IG_FORMAT_PBM to save truecolor images to PPM format.

ImageGear Supported versions:

October 1991 - last release

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.RAW - RGB: 24, 48 bpp
  • ImGearCompressions.ASCII - RGB: 24, 48 bpp

ImageGear Write Support:

  • ImGearCompressions.RAW - RGB: 24, 48 bpp
  • ImGearCompressions.ASCII - RGB: 24, 48 bpp

ImageGear Filter Control Parameters:

None

Comments:

The PPM format is useful for quick and easy transfer of color bitmap images. This format, as well as the PBM, PGM, and PNM formats, are at the core of a set of utility programs also written by Jef Poskanzer. These formats serve as intermediary storage methods for the conversion of other file formats. For example, a function called gifftoppm translates a GIF file to a PPM, where it can translate to a TIFF using the pnmtotiff.

The Portable Pixmap File Format structure is very simple. It begins with a short ASCII header that contains the file type identifier (magic number), the width and height of the image, a "maximum color-component value", and perhaps a comment line identifying the filename. Following white space (usually a carriage return) is the bitmap data. The number of pixels is equal to width * height, with each pixel being represented by three bytes: one each for Red, Green, and Blue color components, respectively.

The magic number of the header can have one of two values: either P3 or P6. P3 indicates that the bitmap data is read as ASCII decimal values. P6 indicates that the bitmap data is stored as plain bytes. This makes for a smaller and faster-to-read file.

If the maximum gray value exceeds 255 (28 = 256 gray values from 0 to 255), each pixel is represented by three 16-bit RGB samples, making a total of 48 bits per pixel. ImageGear loads such images to 24-bit RGB.

See Also:

PGM, PBM, PNM

References used:

Kay, David C. and John R. Levine. Graphics File Formats, 2nd ed. Windcrest /McGraw-Hill, 1995.

PPM Specification by Jef Poskanzer, copyright © 1989, 1991.


PTOCA

Full Name
PTOCA (Presentation Text Object Content Architecture)
Format ID
ImGearFormats.PTOCA
File Extension(s)
*.pto, *.mod
Data Type
Metafile
Data Encoding
Binary
IG Multipage Support
Yes
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, .NET, .NET64

ImageGear Supported versions:

  • Format 2

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading

ImageGear Read Support:

  • ImGearCompressions.NONE - Indexed RGB: 8 bpp

ImageGear Write Support:

No

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
Factor
DOUBLE
1.0
Linear DIB size Factor.

Comments:

ImageGear can read PTOCA files as content of multi- and single-page MOD:CA files, ensuring better compatibility with IBM's AFP (Advanced Function Presentation) printer architecture.

The PT object structure starts with the "Begin Presentation Text" structure field and finishes with the "End Presentation Text" structure field. Text data is placed between these fields and consists of graphic characters and control sequences that describe how the text will be shown on the presentation surface. The PT object can include some other optional structured fields that define initial presentation text values. If PTOCA is included in the MOD:CA content, some presentation text parameters (like code page, font, an initial values) can be defined on the MOD:CA level.

References used:

IBM BookManager BookServer, Copyright 1989, 1999, IBM Corporation.


RAS

Full Name
RAS (Sun Raster Data Format)
Format ID
ImGearFormats.RAS
File Extension(s)
*.ras
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp

ImageGear Write Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 1, 8 bpp;
    • RGB: 24 bpp

ImageGear Filter Control Parameters:

None.

Comments:

Bitmap images used under the SunOS system and UNIX imaging applications are usually stored in Sun Raster form.

The Sun Raster header contains image data (size and type), and the type and size of the colormap, if present. It also contains a Sun Raster identifying tag called "MagicNumber," which always contains the same value. A type field identifies the version of Sun Raster, the most common are called "Old" and "Standard". These are actually the same format and indicate that the image is not compressed. Other possible versions of Sun Raster files include TIFF and IFF, meaning that the image data was converted from one of these formats.

Following the header is a colormap, if applicable. Most 24 or 32-bit raster images do not use a colormap, but rather store the color values directly with the image data. This is known as "truecolor".

The last element of the Sun Raster file is the image data itself. It is usually in 2D raster format.

References used:

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. Windcrest Books, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


Scitex CT

Full Name
SciTex (Scitex CT)
Format ID
ImGearFormats.SCI
File Extension(s)
*.sct
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.NONE - CMYK: 32 bpp

ImageGear Write Support:

  • ImGearCompressions.NONE - CMYK: 32 bpp

ImageGear Filter Control Parameters:

None.

Comments:

ImageGear has read and write support for Scitex HandShake Continuous Tone Picture files. This is the native format used by Scitex scanners and printers for high-end image processing and color separation.

Scitex CT files store uncompressed, CMYK true-color raster data. They contain a Control Block, a Parameters Block, and the image data. Scitex CT images are typically four-color separation, CMYK, line-interleaved raster data. The separations are always stored by scan line and in the order C-M-Y-K (cyan-magenta-yellow-black). A color pixel value have up to 16 separations (128 bits) in size. Separations 1 through 4 are defined in order (C-M-Y-K). Separations 5 through 16 are reserved for future expansion of the format, as shown below.

Each row or Scitex CT image data is stored in separated color. The first separation's row data is followed by the second, and so forth, up to the number of separations specified by NumColorSeparations. Only the data for the separations defined by the SeparationsBitMask field is actually stored in the CT file. Each pixel can contain up to 16 separation components and each component is one byte in size. A CMYK pixel contains four components and is of a 32-bit size. Remember that the data is not stored by pixel, but by separation. If rows contain odd numbers of bytes, the zero padding byte will be added to the end of each separation to preserve word alignment.

Note: You can set ImageGear CMYK Support level to IG_CONVERT_TO_RGB to convert CMYK images to 24-bit RGB during loading. However, use of this mode is deprecated. We recommend to load the image in its native format, and then convert to desired color space if needed.

References used

Copyright© 1994, 1996, O'Reilly & Associates, Inc.


SGI

Full Name
SGI (Silicon Graphics Image)
Format ID
ImGearFormats.SGI
File Extension(s)
*.sgi, *.bw, *.rgb, *.rgba
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
Supports single alpha channel for read and write.
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Grayscale: 8 bpp;
    • RGB: 24 bpp;
    • Grayscale + Alpha: 16 bpp;
    • RGB + Alpha: 32 bpp
  • ImGearCompressions.RLE:
    • Grayscale: 8 bpp;
    • RGB: 24 bpp;
    • Grayscale + Alpha: 16 bpp;
    • RGB + Alpha: 32 bpp

ImageGear Write Support:

  • ImGearCompressions.NONE:
    • Grayscale: 8 bpp;
    • RGB: 24 bpp;
    • Grayscale + Alpha: 16 bpp;
    • RGB + Alpha: 32 bpp

ImageGear Filter Control Parameters:

None

Comments:

This format was developed for use with the SGI image library included on most Silicon Graphics computers. Most SGI images are black and white.

The major components of an SGI file are the 512-byte header, a "scan-line offset table", and the bitmap header. SGI is one of the few formats to use a scan-line offset table.

The fields of the header structure include a compression flag (1 = compressed), the height and width (in pixels) of the image, the number of bit planes, the highest pixel value and the lowest pixel value, the name of the image, and pixel format. Pixel format can indicate the number of color channels, whether the image is dithered to a single channel, and whether the bitmap image is actually a color map for other images.

The bitmap data is stored up-side-down-the first scan line is at the bottom of the bitmap. If the data is RLE, a scan-line offset table is present, following the header and preceding the bitmap. This increases compression further by allowing repeated offsets to the same scan line, if several scan lines have the same value. A grayscale image may even refer to the same scan line from three different bit fields. For this reason, and because SGI data that is compressed can be stored in any scan-line order, the offset table must not be ignored.

References used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats, 2d ed. Sebastopol, CA: O'Reilly & Associates, Inc., 1996.


TGA

Full Name
TGA (Truevision Targa)
Format ID
ImGearFormats.TGA
File Extension(s)
*.tga, *.tpic
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
Single alpha channel for read/write
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight

ImageGear Supported versions:

  • Version 2.0, 1991
  • Version 1.0, 1984

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Grayscale: 1 bpp;
    • Indexed RGB: 8 bpp;
    • RGB: 15, 24 bpp;
    • RGB 15 bpp + Alpha 1 bpp;
    • RGB 24 bpp + Alpha 8 bpp;
    • RGB 15 bpp + Premultiplied Alpha 1 bpp;
    • RGB 24 bpp + Premultiplied Alpha 8 bpp;
    • RGB 15 bpp + Extra 1 bpp;
    • RGB 24 bpp + Extra 8 bpp;
  • ImGearCompressions.RLE:
    • Grayscale: 1 bpp;
    • Indexed RGB: 8 bpp;
    • RGB: 15, 24 bpp;
    • RGB 15 bpp + Alpha 1 bpp;
    • RGB 24 bpp + Alpha 8 bpp;
    • RGB 15 bpp + Premultiplied Alpha 1 bpp;
    • RGB 24 bpp + Premultiplied Alpha 8 bpp;
    • RGB 15 bpp + Extra 1 bpp;
    • RGB 24 bpp + Extra 8 bpp;

ImageGear Write Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 8 bpp;
    • RGB: 15, 24 bpp;
    • RGB 15 bpp + Alpha 1 bpp;
    • RGB 24 bpp + Alpha 8 bpp;
    • RGB 15 bpp + Extra 1 bpp;
    • RGB 24 bpp + Extra 8 bpp;
  • ImGearCompressions.RLE:
    • Indexed RGB: 8 bpp;
    • RGB: 15, 24 bpp;
    • RGB 15 bpp + Alpha 1 bpp;
    • RGB 24 bpp + Alpha 8 bpp;
    • RGB 15 bpp + Extra 1 bpp;
    • RGB 24 bpp + Extra 8 bpp;

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
ImageID
byte[]
Empty array
Image ID

Comments:

This file format was originally developed by AT&T for use with its image capture boards. The format was taken over by Truevision when it acquired the product line from AT&T. It is now commonly used for digitized images and also for high-quality images produced by ray tracers and other graphics applications.

It became a popular file format mainly because it was the first 24-bit truecolor format to come to the PC market. There are several varieties of Targa files; the most commonly used are the Targa 16, Targa 24, and Targa 32. The names are derived from the type of hardware used to create them.

The fixed-sized header information of the Targa format includes: the existence (or not) and colormap, location, size, pixel depth, image location, colormap (if it exists), and finally the image data itself.

Version 2.0 introduced a file footer that identifies it as the newest version and contains pointers to additional fields in two main structures: the "extension area" and the "developer directory". The extension area contains the addresses of many optional fields, one of the most popular being the "postage stamp image" (miniature of the main image).

The developer directory can be used to store proprietary information. Developers can register their own private fields with Truevision. A null-terminated ASCII string containing "TRUEVISION-XFILE.", and positioned at the end of the file, indicates that the footer is valid.

Targa defines 3 color methods: pseudo color, direct color, and truecolor. Pseudo color uses an index to a color palette. Direct color is like pseudo color except that the RGB components are looked up separately. In truecolor files, the color information is stored directly in the image data. The palettes used by Targa files are variable in size; they do not necessarily correlate to the bit depth of the image. The presence of a palette does not always mean that it is used to display the image.

References used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. Windcrest Books, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


TIFF

Full Name
TIFF (Tagged Image File Format)
Format ID
ImGearFormats.TIF
File Extension(s)
*.tif, *.tiff
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
Yes
IG Alpha Channel Support
Yes
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight, Photo Editing

ImageGear Supported versions:

  • Version 6.0 - Added support for CMYK and YCbCr color images, and JPEG compression. Ability to store pixels in "tiles"
  • Version 5.0 - Added ability to store palette color images and support for LZW compression. This version featured TIFF "classes."
  • Version 4.0 - Added support for uncompressed RGB color images.
  • Version 3.0 - First public release.

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.MPAGEREADPSUPPORT - multi-page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing
  • IGFilterFormatFlags.MPAGEWRITEPSUPPORT - multipage file writing
  • IGFilterFormatFlags.PAGEDELETESUPPORT - page deleting from multi-page file
  • IGFilterFormatFlags.PAGESWAPSUPPORT - page swaping in multi-page files
  • IGFilterFormatFlags.MPDATASUPPORT - faster multi-page access by storing private format data (used only with IG_mpi_... and IG_mpf_... API)

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Indexed RGB - 1, 2, 4, 8 bpp;
    • Grayscale - 1, 2, 4, 8, 12, 16, 32 bpp;
    • RGB: 3, 6, 12, 24, 36, 48 bpp;
    • Lab: 3, 6, 12, 24, 36, 48 bpp;
    • CMYK: 4, 8, 16, 32, 48, 64 bpp;
    • Grayscale + Premultiplied Alpha: 2, 4, 8, 12, 16, 32 bpp;
    • RGB + Premultiplied Alpha: 4, 8, 16, 32, 48, 64 bpp;
    • Indexed RGB + Extra: 1, 2, 4, 8 bpc;
    • Lab + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • CMYK + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • Grayscale + Premultiplied Alpha + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • RGB + Premultiplied Alpha + Extra: 1, 2, 4, 8, 12, 16 bpc.
  • ImGearCompressions.PACKED_BITS:
    • Indexed RGB - 1, 2, 4, 8 bpp;
    • Grayscale - 1, 2, 4, 8, 12, 16, 32 bpp;
    • RGB: 3, 6, 12, 24, 36, 48 bpp;
    • Lab: 3, 6, 12, 24, 36, 48 bpp;
    • CMYK: 4, 8, 16, 32, 48, 64 bpp;
    • Grayscale + Premultiplied Alpha: 2, 4, 8, 12, 16, 32 bpp;
    • RGB + Premultiplied Alpha: 4, 8, 16, 32, 48, 64 bpp;
    • Indexed RGB + Extra: 1, 2, 4, 8 bpc;
    • Lab + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • CMYK + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • Grayscale + Premultiplied Alpha + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • RGB + Premultiplied Alpha + Extra: 1, 2, 4, 8, 12, 16 bpc.
  • ImGearCompressions.HUFFMAN:
    • Indexed RGB: 1 bpp;
    • Grayscale: 1 bpp;
  • ImGearCompressions.CCITT_G3:
    • Indexed RGB: 1 bpp;
    • Grayscale: 1 bpp;
  • ImGearCompressions.CCITT_G4:
    • Indexed RGB: 1 bpp;
    • Grayscale: 1 bpp;
  • ImGearCompressions.CCITT_G32D:
    • Indexed RGB: 1 bpp;
    • Grayscale: 1 bpp;
  • ImGearCompressions.JPEG:
    • Grayscale: 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.DEFLATE:
    • Indexed RGB - 1, 2, 4, 8 bpp;
    • Grayscale - 1, 2, 4, 8, 12, 16, 32 bpp;
    • RGB: 3, 6, 12, 24, 36, 48 bpp;
    • Lab: 3, 6, 12, 24, 36, 48 bpp;
    • CMYK: 4, 8, 16, 32, 48, 64 bpp;
    • Grayscale + Premultiplied Alpha: 2, 4, 8, 12, 16, 32 bpp;
    • RGB + Premultiplied Alpha: 4, 8, 16, 32, 48, 64 bpp;
    • Indexed RGB + Extra: 1, 2, 4, 8 bpc;
    • Lab + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • CMYK + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • Grayscale + Premultiplied Alpha + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • RGB + Premultiplied Alpha + Extra: 1, 2, 4, 8, 12, 16 bpc.
  • ImGearCompressions.LZW:
    • Indexed RGB - 1, 2, 4, 8 bpp;
    • Grayscale - 1, 2, 4, 8, 12, 16, 32 bpp;
    • RGB: 3, 6, 12, 24, 36, 48 bpp;
    • Lab: 3, 6, 12, 24, 36, 48 bpp;
    • CMYK: 4, 8, 16, 32, 48, 64 bpp;
    • Grayscale + Premultiplied Alpha: 2, 4, 8, 12, 16, 32 bpp;
    • RGB + Premultiplied Alpha: 4, 8, 16, 32, 48, 64 bpp;
    • Indexed RGB + Extra: 1, 2, 4, 8 bpc;
    • Lab + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • CMYK + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • Grayscale + Premultiplied Alpha + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • RGB + Premultiplied Alpha + Extra: 1, 2, 4, 8, 12, 16 bpc.
NOTE: To use LZW (Lempel-Ziv-Welch) Compression compression scheme ImageGear.Formats Namespace should be attached.

ImageGear Write Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8, 12, 16, 32 bpp;
    • RGB: 24, 36, 48 bpp;
    • Lab: 24, 36, 48 bpp;
    • CMYK: 4, 32, 48, 64 bpp;
    • Grayscale + Premultiplied Alpha: 16, 24, 32, 64 bpp;
    • RGB + Premultiplied Alpha: 32, 48, 64 bpp;
    • Lab + Extra: 8, 12, 16 bpc;
    • CMYK + Extra: 8, 12, 16 bpc;
    • Grayscale + Premultiplied Alpha + Extra: 8, 12, 16 bpc;
    • RGB + Premultiplied Alpha + Extra: 8, 12, 16 bpc;
  • ImGearCompressions.PACKED_BITS:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8, 12, 16, 32 bpp;
    • RGB: 24, 36, 48 bpp;
    • Lab: 24, 36, 48 bpp;
    • CMYK: 4, 32, 48, 64 bpp;
    • Grayscale + Premultiplied Alpha: 16, 24, 32, 64 bpp;
    • RGB + Premultiplied Alpha: 32, 48, 64 bpp;
    • Lab + Extra: 8, 12, 16 bpc;
    • CMYK + Extra: 8, 12, 16 bpc;
    • Grayscale + Premultiplied Alpha + Extra: 8, 12, 16 bpc;
    • RGB + Premultiplied Alpha + Extra: 8, 12, 16 bpc;
  • ImGearCompressions.HUFFMAN:
    • Indexed RGB: 1 bpp;
  • ImGearCompressions.CCITT_G3:
    • Indexed RGB: 1 bpp;
  • ImGearCompressions.CCITT_G4:
    • Indexed RGB: 1 bpp;
  • ImGearCompressions.CCITT_G32D:
    • Indexed RGB: 1 bpp;
  • ImGearCompressions.JPEG (Lossy, Progressive):
    • Grayscale: 8, 12 bpp;
    • RGB: 24, 36 bpp;
    • Lab: 24, 36 bpp;
    • CMYK: 32, 48 bpp;
  • ImGearCompressions.JPEG (Lossless):
    • Grayscale: 8, 16 bpp;
    • RGB: 24 bpp;
  • ImGearCompressions.DEFLATE:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8, 12, 16, 32 bpp;
    • RGB: 24, 36, 48 bpp;
    • Lab: 24, 36, 48 bpp;
    • CMYK: 4, 32, 48, 64 bpp;
    • Grayscale + Premultiplied Alpha: 16, 24, 32, 64 bpp;
    • RGB + Premultiplied Alpha: 32, 48, 64 bpp;
    • Lab + Extra: 8, 12, 16 bpc;
    • CMYK + Extra: 8, 12, 16 bpc;
    • Grayscale + Premultiplied Alpha + Extra: 8, 12, 16 bpc;
    • RGB + Premultiplied Alpha + Extra: 8, 12, 16 bpc;
  • ImGearCompressions.LZW:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8, 12, 16, 32 bpp;
    • RGB: 24, 36, 48 bpp;
    • Lab: 24, 36, 48 bpp;
    • CMYK: 4, 32, 48, 64 bpp;
    • Grayscale + Premultiplied Alpha: 16, 24, 32, 64 bpp;
    • RGB + Premultiplied Alpha: 32, 48, 64 bpp;
    • Lab + Extra: 8, 12, 16 bpc;
    • CMYK + Extra: 8, 12, 16 bpc;
    • Grayscale + Premultiplied Alpha + Extra: 8, 12, 16 bpc;
    • RGB + Premultiplied Alpha + Extra: 8, 12, 16 bpc;

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
BigEndian
bool
false
false,
true
If true, big endian order is used for write operation ("MM"), in other case little endian is used("II").
BitonalPaletteMode
ImGearTIFFBitonalPaletteMode Enumeration
LEGACY
An ImGearTIFFBitonalPaletteMode Enumeration value
Specifies whether ImageGear shall fix strange looking palettes when reading bitonal TIFF images.
FillOrder
ImGearFillOrder Enumeration
MSB
An ImGearFillOrder Enumeration value
Specifies fill order (most significant bit first, less significant bit first) to use for writing the TIFF file.
ImageBeforeIFD
bool
false
false,
true
This flag specifies physical location of raster data inside TIFF file relatively to IFD record. If this value is true then image data is to be written before IFD record.
IncludePageNumber
bool
true
false,
true
If this parameter is true then include tag 297 into TIFF image with real value of page number.
LoadFirstUnknownChannelAsPAlpha
bool
true
true, false
This parameter specifies how to load first extra channel if ExtraSamples tag is missing. If LoadFirstUnknownChannelAsPAlpha is True, IG loads first extra channel as Premultiplied Alpha channel. This mode provides support for RGBPA TIFF images written by earlier versions of ImageGear. If LoadFirstUnknownChannelAsPAlpha is False, IG loads all extra channels as extra channels.
MissingCompression
ImGearCompressions Enumeration
AUTO
An ImGearCompressions Enumeration value
Compression to use for image loading, if compression tag is missing in the image.
Save70
bool
true
false,
true
If this value is true then output TIFF-JPEG image will be produced in TIFF 7.0 compatible format but in other case it will be compatible with TIFF 6.0.
SaveClassF
bool
false
false,
true
If this value is true then image to be written in TIFF format compatible with class F requirements.
SaveEXIFMetadata
bool
false
true, false
If this parameter is true EXIF metadata is saved with TIFF file.
SaveExistingEXIFMetadata
bool
true
true, false
This parameter controls the saving of existing EXIF metadata.
By default (SaveEXIFMetadata = False, SaveExistingEXIFMetadata = True), ImageGear saves EXIF metadata if it exists in the source page, and does not save EXIF metadata if it does not exist in the source page.
SavePlanar
bool
false
false,
true
Specifies tag value 284 for output image.
StripBufferSize
int
32768
Any positive value
If StripMode equals ImGearStripModes.FIXED_BUFFER, specifies the buffer size to be used for writing of each strip.
StripCount
int
1
Any positive int value, not greater than image height
If StripModeequals ImGearStripModes.FIXED_COUNT, specifies the number of strips for saving the TIFF image.
StripMode
ImGearStripModes Enumeration
FIXED_COUNT
An ImGearStripModes Enumeration value
Specifies strip or tile saving mode for the TIFF image. By default, ImageGear saves TIFF files with one strip.
SubIFDPath
string
Empty string
Any string value
Path of the SubIFD to load the image from. If set to empty string (default), load image from root IFD. See "Camera Raw Image support" section for more detail.
TileHCount
int
10
Any positive int value, not greater than image width
If StripMode equals ImGearStripModes.TILED_FIXED_COUNT, specifies the number of tiles in horizontal dimension.
TileHeight
int
64
Any positive int value, not greater than image height
If StripMode equals ImGearStripModes.TILED_FIXED_SIZE, specifies the height of each tile.
TileVCount
int
10
Any positive int value, not greater than image height
If StripMode equals ImGearStripModes.TILED_FIXED_COUNT, specifies the number of tiles in vertical dimension.
TileWidth
int
64
Any positive int value, not greater than image width
If StripMode equals ImGearStripModes.TILED_FIXED_SIZE, specifies the width of each tile.

SaveExistingEXIFMetadata works in combination with SaveEXIFMetadata parameter, as shown in the table below:

SaveEXIFMetadata
SaveExistingEXIFMetadata
Source Page has EXIF metadata
ImageGear action
False
False
No
Does not save EXIF metadata
False
False
Yes
Does not save EXIF metadata
False
True
No
Does not save EXIF metadata
False
True
Yes
Saves existing EXIF metadata
True
False
No
Saves default EXIF metadata
True
False
Yes
Ignores existing and saves default EXIF metadata
True
True
No
Saves default EXIF metadata
True
True
Yes
Saves existing EXIF metadata

Comments:

TIFF was developed for use in storing black-and-white images from scanners and desktop publishing applications. Now, in its fourth release (version 6.0), it is one of the most detailed and versatile bitmap formats in use. It is supported by most art, imaging, and word-processing applications. It supports several compression schemes. Aside from saving image data in bitmap form, it can also contain vector or text-based images.

Containing just three fields, the TIFF header is simple and one of the shortest of all the graphics file format headers. But, the structure of a TIFF is complicated, with variable length fields, variable number of fields, and the ability to store information (other than the header) in any order desired.

The other two major components of the TIFF format are "Image File Directories" (IFDs) and the image or images themselves. There is one IFD per image stored. The combination of an IFD and an image is referred to as a "subfile". The header contains an offset pointer to the first IFD. If there are multiple IFDs, each contains an offset to the next. The last IFD contains a value that signifies the end of the file.

IFDs closely resemble a header structure, and the information stored in them is often referred to as "TIFF Header Information". Unlike a header, however, they contain a variable number of "tags" (pointers or fields). In addition, each tag can point to data with a variable length. TIFFs are notorious for the number of tags that they can contain, up to a maximum of 65,535 tags of nearly 100 different types (version 6.0). Tags are listed in order by code number so that a TIFF reader can easily determine what fields are present. While ImageGear reads and stores all TIFF tags, it utilizes a subset of all of the possible tags. See note on previous page.

In version 5.0, the presence of certain subgroups of tags determined what "class" the TIFF belonged to. The classes are: TIFF-B-monochrome, TIFF-F-fascimile, TIFF-G-grayscale, TIFF-P-palette based, TIFF-R-RGB color, TIFF-X-any class, TIFF-Y-can use JPEG compression. Version 6.0 uses tags to divide the TIFF type into different file configurations, leaving behind the class concept. Version 6.0 configurations are: Bilevel, palette color, RGB, grayscale, YCbCr, and Class F (fascimile).

TIFF bitmap data can be stored in one of two configurations: strips or tiles. Strips are groups of adjoining rows of bitmap data, and can be found in version 5.0 and 6.0 files. Tiles were new to TIFF version 6.0. They are rectangular or square sections of bitmap data. The method of storage is determined in part by what kind of compression (if any) is used. JPEG compression can handle tiled images. Due to the need for padding with tile storage, tiling is not usually efficient for small images.

ImageGear supports the following compression schemes for TIFF:

    • Uncompressed
    • CCITT Group 3 Compression
    • CCITT Group 3 2D Compression
    • CCITT Group 4 Compression
    • Huffman Compression
    • JPEG Compression
    • Lossless JPEG Compression
    • LZW (Lempel-Ziv-Welch) Compression
    • Packbits Compression
    • Progressive JPEG Compression
    • Deflate Compression (both the `normal' deflate compression and the Planar/Adobe-style deflate compression are supported)

See the ImageGear Supported Compressions Reference for descriptions of these compression types. The compression tag of the IFD tells whether the image is compressed, and by what method. (Not all TIFF files can use JPEG compression. It is supported by version 6.0, but in version 5.0, only a "Y" class TIFF can use JPEG).

TIFF/EP

TIFF/EP format was designed to provide a means for storing "raw" (unprocessed) image from digital camera's sensor.

TIFF/EP allows you to store several versions of the same image in one file. Typically, TIFF/EP image includes a small preview and a raw image. It can also include a larger or full-size preview, or some other variations of the image.

TIFF/EP uses IFD trees for storing different versions of image. This is different from IFD chains that are used in baseline TIFF to store multiple pages.

ImageGear does not detect TIFF/EP as a separate file format. If Raw detection is enabled, and ImageGear can recognize TIFF/EP file as a known Raw format, it detects and loads the file as DCRAW. Otherwise it detects TIFF/EP as TIFF. One of well known extensions to TIFF/EP is Adobe DNG format. ImageGear detects it as a separate file format.

Most of digital cameras store pixels in "mosaic" format. At a given pixel location either a Red, Green, Blue, Cyan, or some other color sample value is recorded. Such images are referred to as "Color Filter Array" type. TIFF/EP format uses a two-dimensional matrix called "Color Filter Array pattern" to describe positions of pixels of particular color in the mosaic image. In order to recreate the full color values in each pixel, it is necessary to interpolate intensities of neighbouring pixels.

To enable loading images from TIFF SubIFDs, a new control parameter is added to TIFF filter: "SUBIFD_PATH". This parameter has the type of String, and its default value is "" (empty string). By default, ImageGear loads the image in the root IFD (thumbnail). If "SUBIFD_PATH" string begins with a number, then ImageGear loads the image from the corresponding SubIFD of the root IFD. For example, if SUBIFD_PATH is set to "3", ImageGear will load the image from the 3rd SubIFD.

SUBIFD_PATH parameter also affects metadata reading. Metadata is loaded starting from the IFD specified by SUBIFD_PATH.

NOTE: ImageGear does not support color reconstruction of TIFF/EP images, unless they are detected to be a Adobe DNG or a DCRAW image supported by ImageGear.

References used:

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. Windcrest Books, 1992.

Murray, James D. "Graphic Image Format FAQ 3-4". James D. Murray, 1994-1996.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


U3D

Full Name
U3D (Universal 3D)
Format ID
ImGearFormats.U3D
File Extension(s)
*.u3d
Data Type
Vector Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, .NET, .NET64

ImageGear Supported versions:

  • U3D v. 1.0

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.NONE - Universal 3D vector data

ImageGear Write Support:

  • ImGearCompressions.NONE - Universal 3D vector data

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
BackColor
Int 32
0
Any positive value
This parameter is used to set background color. If BackColor = 0, then the black background color is set, otherwise the white background color is set.
Width
Int 32
512
Any positive value
Defines the DIB width of the loaded image. The DIB height is calculated using the file's scale factors.

Comments:

U3D file format, short for "Universal 3D", is a universal vector standard for storing three-dimensional data of all kinds to facilitate data exchange. The specification for this format is the document ECMA-363: Universal 3D File Format. The latest edition of this specification is available at the ECMA web site:

http://www.ecma-international.org/

The U3D format is natively supported by the PDF. 3D objects in U3D format can be inserted into PDF document files and interactively visualized by PDF viewers.


WBMP

Full Name
WBMP (Wireless Bit-Map)
Format ID
ImGearFormats.WBMP
File Extension(s)
*.wbmp,
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight

ImageGear Supported versions:

  • Version 1.1

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.NONE - Indexed RGB: 1 bpp

ImageGear Write Support:

  • ImGearCompressions.NONE - Indexed RGB: 1 bpp

ImageGear Filter Control Parameters:

No

Comments

The WBMP (Wireless Bit-Map) read/write format is optimized to support mobile computing devices that use the Wireless Application Protocol (WAP).

File contains small header with image parameters and array or pixels in uncompressed form.

References used:

WAP WAE Specification Version, 24 May 1999.


WMF

Full Name
WMF (Windows Metafile Format)
Format ID
IG_FORMAT_WMF = 44
File Extension(s)
*.wmf,
Data Type
Metafile Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix (read raster portion only). MAC (read raster portion only)

ImageGear Supported versions:

  • Version 1 Metafiles prior to Windows 3.0
  • Version 2 Metafiles for Windows 3.0 and later

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 4, 8 bpp

ImageGear Write Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 4, 8 bpp

ImageGear Filter Control Parameters:

Filter Control Parameter
Type
Default Value
Available Values
Description
UPSIDE_DOWN
BOOL
TRUE,
FALSE
If TRUE then images will be saved upside-down
TYPE
UINT
BMP_TYPE_BMC,
BMP_TYPE_BMI,
BMP_TYPE_BMI2
Type of the BMP file to be saved as part of WMF.
COMPRESSION
DWORD
BMP_COMP_RLE4,
BMP_COMP_RLE8,
BMP_COMP_RGB
Type of compression of BMP file.
TRUE_METAFILE
BOOL
TRUE (for Windows)
FALSE(otherwise)
TRUE,
FALSE
TRUE means executing of metafile commands (playing of metafile). Can be TRUE only for Windows.
RESOLUTION_X
DWORD
NULL
X resolution. 0 for actual resolution
RESOLUTION_Y
DWORD
NULL
Y resolution. 0 for actual resolution
DEPTH
DWORD
NULL
Bit Depth. 0 for actual depth

NOTE: If the TRUE_METAFILE parameter tis set to TRUE, the image will be opened as an RGB DIB for use with the GDI functions, which produce the image output. This causes the image to look like it is 24-bit per pixel, and 1024x1024 in dimensions. If the TRUE_METAFILE parameter is set to FALSE, then ImageGear will open the image according to its correct bit depth and dimensions.

Comments

A Microsoft Windows Metafile holds vector and bitmap graphics data in memory or on disk. Although it was developed for use with Windows applications, it is now used by many non-Windows-based applications, allowing data to be transferred to and from Windows applications. Due to the great success of the Microsoft Windows interface, the Windows Metafile format is found in nearly all graphical applications. Metafiles use much less space and are more device-independent than bitmaps.

See also the section Support for Metafile Formats.

The Windows metafile begins with a short header and is followed by one or more records of data. The header describes the record data. A "placement" header can also be added before the file header; it contains information needed to move the metafile between applications. Each record corresponds to a binary-encoded Windows graphics device interface (GDI) call, and contains the size of the record, the unique function number for the GDI and an array of parameters. The GDI is used by Windows to perform all image output. When the metafile is "played", (this Microsoft term is a companion term to the Windows function named "PlayMetaFile"), each record makes a call to the appropriate function call for displaying each object in the image. The last record in the file contains a function number of zero to indicate that the end of the record data has been reached.

References used:

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. Windcrest Books, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.

Petzold, Charles. Programming Windows: The Microsoft Guide to writing applications for Windows 3. Redmond, WA: Microsoft Press, 1990.


WPG

Full Name
WPG (WordPerfect Graphics Metafile)
Format ID
ImGearFormats.WPG
File Extension(s)
*.wpg
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight

ImageGear Supported versions:

  • WPG for WP 5.1 and up can store bitmap and vector graphics in the same file.
  • WPG for WP 5.0 and prior can store only bitmap or vector graphic, but not both in same file.

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

  • ImGearCompressions.RLE - Indexed RGB: 1, 4, 8 bpp

ImageGear Write Support:

No

ImageGear Filter Control Parameters:

No

Comments

This format was created specifically for use with WordPerfect software products. WPG files for WordPerfect versions 5.1 and up can store both bitmap and vector image data in the same file.

The WordPerfect Graphics Metafile contains a short header or "prefix" (as WordPerfect Corporation referred to it). The header is followed by a record area, that is a sequence of objects and their attributes. The first record is called the "Start WPG Data" record and contains information on the size of the images and the version number of the .WPG file. The next record is usually a color map, unless the image is black and white. The next record is a bitmap record. If there are multiple images, there is a bitmap record for each image. The last record in a .WPG file contains a NULL body to signify the end of the file. These files may also contain Encapsulated PostScript (EPS) data.

References used

Murray, James D. "Graphic Image Format FAQ 3-4". James D. Murray, 1994-1996.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


XBM

Full Name
XBM (X BitMap)
Format ID
ImGearFormats.XBM
File Extension(s)
*.xbm
Data Type
Raster Image
Data Encoding
ASCII
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight

ImageGear Supported versions:

  • Version 11, data stored as 1-byte character, 1986
  • Version 10, data stored as 2-byte "short" integers

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.ASCII - Indexed RGB: 1 bpp

ImageGear Write Support:

  • ImGearCompressions.ASCII - Indexed RGB: 1 bpp

ImageGear Filter Control Parameters:

No

Comments

The XBM format is intended as a convenient storage method for small monochrome images, for example, cursor and icon bitmaps. It can, however, support images of any size, but since it supports no native compression scheme, an exterior compression program is used when compacting is desired. The bitmap data is stored as ASCII data with C language syntax, making the file easy to insert into C program code. XBM data can be stored as a standalone graphics file, or within a C program header file. See also XPM, XWD.

XBM files begin with two to four #define statements in substitution of a header. These identify the image width and height, and optionally, the coordinates of a Hotspot, if one exists.

The image data follows and is more free-form than the other bitmap data formats described in this chapter. It consists of one variable-length static array of pixel values. Each value (in version 11) consists of one byte of data, and therefore represents 8 1-bit pixels. The first pixel (0,0) is represented by the high bit of the first byte in the array. Due to this one-array format, there is nothing in the data that explicitly marks the rows of the bitmap.

References used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. Windcrest Books, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


XPM

Full Name
XPM (X PixMap)
Format ID
ImGearFormats.XPM
File Extension(s)
*.xpm
Data Type
Raster Image
Data Encoding
ASCII (in C language syntax)
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight

ImageGear Supported versions:

  • Version 3.2g, April 1993

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp

ImageGear Write Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp

ImageGear Filter Control Parameters:

No

Comments

The XPM format was created as an extended version of the XBM file format. It is the informal standard for storing X Window pixmap data, including Hotspot information for cursor bitmaps. The image data is stored in ASCII text characters that are formatted as a standard C array of character strings. It is intended to be human-readable, is readily inserted into C/C++ program code, and can contain any number of comment lines. It therefore does not support a native compression scheme. If compacting is desired, an external compression program may be used. See also XBM, XWD.

All XPM files begin with a C language comment line containing "XPM". Following this are three sections of data: values, colors, and pixels, and an optional fourth section: extensions. The "values" section is the equivalent of the header structure typically found in a graphics file. It gives the size of the pixmap, as well as its number of colors, characters per pixel, the location of the Hotspot (if any), and an indicator of whether the file contains an extension section. Each section is set off with a comment-line title.

The colors section contains codes for the pixmap data characters. All pixels that make up the pixmap are assigned to one or more ASCII characters and one or more colors. (e.g. the character "X" may be assigned to the color red). There are several different conventions for identifying a color. If the string "None" appears as the color to be applied to a specific character, the character(s) symbolizes a transparent pixel.

The "pixels" section contains the bitmap data that appear as an array of character strings, where one row of bitmap data is represented by one array element. Each row is a group of characters set off by quotation marks. Each character is defined in the previous "colors" section.

If indicated by the values section, an extension section appears. It can contain one or more subsections that conform to one of two syntactical formats. An "XPMENDEXT" marker is always used to mark the end of the extension section.

References used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


XPS

Full Name
XPS (XML Paper Specification)
Format ID
ImGearFormats.XPS
File Extension(s)
*.xps
Data Type
Vector Image
Data Encoding
Binary
IG Multipage Support
Yes
IG Alpha Channel Support
No
IG Platforms Support
.NET, .NET64, Silverlight, Photo Editing

ImageGear Supported Versions:

  • XPS v. 1.0

ImageGear Supported Features:

  • Autodetection
  • Single/multiple page file reading
  • Single/multiple page file writing

ImageGear Read Support:

  • XPS files conformed to XML Paper Specification v. 1.0

ImageGear Write Support:

Raster:

  • Grayscale: 1, 8, 16 bpp;
  • RGB: 24, 48 bpp;
  • RGBA: 32, 64 bpp;
  • RGBPA: 32, 64 bpp;
  • CMYK: 32 bpp;

ImageGear Filter Control Parameters:

Name
Type
Default
Description
ResolutionX
int
96
This parameter specifies the horizontal resolution, in dots-per-inch, during the XPS document conversion into a raster image. The greater this value, the higher the quality of the raster image after rasterization. The DIB of the output raster image has this value as an X resolution.
ResolutionY
int
96
This parameter specifies the vertical resolution, in dots-per-inch, during the XPS document conversion into a raster image. The greater this value, the higher the quality of the raster image after rasterization. The DIB of the output raster image has this value as an Y resolution.

Non-Image Data Structure:

The XML Paper Specification file format has different nonimage data that can be stored in a package as XML or as resources. The XML Paper Specification metadata design allows reading and writing the following nonimage data (the same as in System.IO.Packaging.PackageProperties; all are strings):

Tag Name
Tag ID
Description
Category
ImGearXPSTagIDs.CATEGORY
The category of the content that is contained in the file.
ContentStatus
ImGearXPSTagIDs.CONTENT_STATUS
Example ContentStatus values include "Draft", "Reviewed", and "Final".
ContentType
ImGearXPSTagIDs.CONTENT_TYPE
Example ContentType values include "Whitepaper", "Security Bulletin", and "Exam".
Created
ImGearXPSTagIDs.CREATED
The date and time the file was initially created.
Creator
ImGearXPSTagIDs.CREATOR
The individual or entity that created the file and its content.
Description
ImGearXPSTagIDs.DESCRIPTION
The Description may include, but is not limited to: an abstract, table of contents, reference to a graphical representation of content, or a free-text account of the content.
Identifier
ImGearXPSTagIDs.IDENTIFIER
A value that unambiguously identifies the file and its content.
Keywords
ImGearXPSTagIDs.KEYWORDS
A delimited set of keywords to support searching and indexing the Package and content.The Keywords property typically contains a list of terms that are not available elsewhere in file metadata.
Language
ImGearXPSTagIDs.LANGUAGE
A value that identifies the file content language.
LastModifiedBy
ImGearXPSTagIDs.LAST_MODIFIED_BY
The user who last modified the file content.
LastPrinted
ImGearXPSTagIDs.LAST_PRINTED
The date and time the file content was last printed.
Modified
ImGearXPSTagIDs.MODIFIED
The date and time the file was last changed.
Revision
ImGearXPSTagIDs.REVISION
The revision number of the file. The Revision property indicates the number of changed saves or revisions. The application is responsible for updating the Revision property value after each revision.
Subject
ImGearXPSTagIDs.SUBJECT
The topic of the file content.
Title
ImGearXPSTagIDs.TITLE
The name given to the file and its content.
Version
ImGearXPSTagIDs.VERSION
The version number of the file.

Comments

The XPS Document format represents a set of related pages with a fixed layout, which are organized as one or more documents, in the traditional meaning of the word. A file that implements this format includes everything necessary to fully render those documents on a display device or physical medium (for example, paper). This includes all resources, such as fonts and images, that might be required to render individual page markings.

In addition, the format includes optional components that build on the minimal set of components required to render a set of pages. This includes the ability to specify print job control instructions, to organize the minimal page markings into larger semantic blocks, such as paragraphs, and to physically rearrange the contents of the format for easy consumption in a streaming manner, among others.

The XPS format supports HD Photo images natively for raster images.

The XPS format concept is similar to Adobe PDF. It is a fixed-layout document format designed to preserve document fidelity, so that documents look the same and as they are intended on any device. While Adobe PDF is based on PostScript the XPS format is based on XML. Adobe PDF, however, includes some dynamic capabilities not supported by the XPS format, and cannot be fully replaced by XPS.

Finally, the XPS Document format implements the common package features, specified by the Open Packaging Conventions specification, that support digital signatures and core properties. An XPS file is a ZIP archive conforming to the Open Packaging Convention.

The XPS format is intended as the replacement for the EMF print spooler format. The format serves as the page description language for printers. For printers supporting XPS, this eliminates an intermediate conversion to a printer-specific language, increasing the reliability and fidelity of the printed output.


XWD

Full Name
XWD (X Window Dump)
Format ID
ImGearFormats.XWD
File Extension(s)
*.xwd, *.wd (for Unix)
Data Type
Raster Image
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, .NET, .NET64, MAC, Silverlight

ImageGear Supported versions:

  • Version 7 for X11, June 1987 (X10 grayscale and palette only)

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp

ImageGear Write Support:

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp

ImageGear Filter Control Parameters:

No

Comments

An XWD file can contain a representation of the window, the background, or the entire screen display. It has been designed to be a very versatile, device-independent format. See also XBM, XPM.

The general structure of the XWD graphics format begins with a long header, that is sometimes followed by a palette and contains the bitmap data. The header contains integer data and stores the header size, the XWD version, the size and location of the bitmap, the window size, location, and border width. A ByteOrder field indicates whether the bytes are stored in big-endian or little-endian order.

In the interest of making this format device-independent, the XWD supports six "visual classes" and three image formats. The visual class code is stored in the visual_class field of the header, and represents the following categories:

    • Static Gray, for most monochrome screens and using a fixed device-dependent color map;
    • GrayScale, for monochrome screens and using a software-supplied palette;
    • StaticColor, which uses a fixed device-dependent palette;
    • Pseudocolor, which uses a software-supplied palette and is intended for VGA screens;
    • TrueColor, with fixed device-dependent mapping of RGB values to screen colors;
    • DirectColor, with software-supplied mapping of RGB values to screen values.

The image-format categories, whose codes are stored in the pixmap_format field of the header, are called XYBitmap (1-bit), XYPixmap (single plane), and ZPixmap (two or more planes).

Where the value of pixmap_format indicates GrayScale, PseudoColor or DirectColor, a palette follows the header.

The image data is the last structure in the file. The bytes are stored in rows with groupings called "units", whose lengths are determined by the bitmap_unit field of the header.

If the pixmap_format field is 1, indicating an XYPixmap, there are multiple representations of the bitmap data, one for each color plane, where the first bitmap represents the highest bit of the data; the second bitmap represents the second-highest bit, and so on. An image with a bit depth of 4 yields a file with four bitmaps.

References used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. Windcrest Books, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


ImageGear Supported Digital Camera RAW Formats Reference

This section represents the reference for every imaging file format supported by ImageGear.

The following are the characteristic features for file format description:

  • Full Name - Full name of the File Format
  • Format ID - ImageGear constant that determines the File Format ID used for loading this file in ImageGear-based application.
  • File Extensoin(s) - The used extensions of the File Format
  • Data Type - The type of the File Format (raster, vector, metafile)
  • Data Encoding - The type of data encoding. Please see the section Encoding vs. Compressing.
  • IG Multipage Support - Shows if ImageGear supports the File Format as multipage or singlepage. Please see also the section Support for Multi-Page File Formats.
  • IG Alpha Channel Support - Shows if ImageGear supports the alpha channel for the File Format or not. Please see also the section ImageGear Alpha Channel Support.
  • IG Platforms Support - Shows ImageGear platform versions that support the File Format.
  • ImageGear Supported versions - Shows the versions of the File Format supported by ImageGear.
  • ImageGear Supported Features - Shows the ImageGear Format Filter features supported by ImageGear for this format.
  • ImageGear Read Support - Provides all compressions, color spaces, channels and bit depths supported by ImageGear for the file format reading.
  • ImageGear Write Support - Provides all compressions, color spaces, channels and bit depths supported by ImageGear for the file format writing.
  • ImageGear Filter Control Parameters - Provides all filter control parameters supported by ImageGear for this format filter.
  • Comments - Some general information about format encoding and compression structure.
  • References Used - References to the information sources for the File Format.

Currently ImageGear supports the following Digital Camera RAW Formats:

Format
Read/Write
Description
CR2
Read
Canon CR2 digital camera RAW format
CRW
Read
Canon CRW digital camera RAW format
Headerless Camera Raw
Read
Headerless digital camera RAW format
Imacon Raw
Read
Imacon digital camera RAW format
KodakRAW
Read
Kodak digital camera RAW format
LeicaRAW
Read
Leica/Panasonic digital camera RAW format
MEF
Read
Mamiya digital camera RAW format
MOS
Read
Leaf digital camera RAW format
MRW
Read
Konica-Minolta digital camera RAW format
NEF
Read
Nikon digital camera RAW format
ORF
Read
Olympus digital camera RAW format
PEF
Read
Pentax/Samsung digital camera RAW format
RAF
Read
FujiFilm digital camera RAW format
SonyRaw
Read
Sony digital camera RAW format

See Also:

Particular Cameras Supported DC RAW Formats


CR2

Full Name
Canon CR2 Camera Raw Format
Format ID
ImGearFormats.CR2
File Extension(s)
*.cr2, *.tif
Data Type
Bitmap
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64, Silverlight, Photo Editing

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

  • ImGearCompressions.JPEG
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support:

None.

ImageGear Filter Control Parameters:

See DCRAW Filter Control Parameters.

Comments:

This is one of the two main formats that Canon digital cameras use to store Raw images.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Canon CR2 format uses EXIF file structure as the base. CR2 images contain a preview in the root IFD. This allows applications that do not support CR2 format, load the preview as a valid TIFF-EXIF image. Actual raw data is stored in the EXIF makernote tag. Raw data is encoded using JPEG lossless compression.


CRW

Full Name
Canon CRW Camera Raw Format
Format ID
ImGearFormats.CRW
File Extension(s)
*.crw
Data Type
Bitmap
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64, Silverlight, Photo Editing

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

  • Proprietary Canon compression:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support:

None.

ImageGear Filter Control Parameters:

See DCRAW Filter Control Parameters.

Comments:

This is one of the two main formats that Canon digital cameras use to store Raw images.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Canon CRW format uses CIFF file structure as the base. CIFF file format is similar to TIFF in many aspects, but is not compatible with it. Raw data is encoded using Canon proprietary compression.


Headerless Camera Raw

Full Name
Headerless Camera Raw Format
Format ID
ImGearFormats.HeaderlessRaw
File Extension(s)
*.*
Data Type
Bitmap
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64, Silverlight, Photo Editing

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

  • ImGearCompressions.NONE
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support:

None.

ImageGear Filter Control Parameters:

See DCRAW Filter Control Parameters.

Comments:

Headerless Digital Camera file filter provides support for Digital Camera Raw images that only contain pixel data and no header. This filter supports raw images from cameras of various manufacturers. Camera model and manufacturer of particular image can be obtained from Common section of the Camera Raw metadata.

Because of absence of a header, such files can't be detected reliably. ImageGear uses low detection priority for these images, and by default, detection of this filter is disabled. Also, since these files do not contain any metadata describing color reconstruction, ImageGear support level for them is limited to "S2" - pixel decoding only.


Imacon Raw

Full Name
Imacon Camera Raw Format
Format ID
ImGearFormats.ImaconRaw
File Extension(s)
*.fff
Data Type
Bitmap
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64, Silverlight, Photo Editing

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support:

None.

ImageGear Filter Control Parameters:

See DCRAW Filter Control Parameters.

Comments:

Imacon digital cameras use this format for storing Raw images.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Imacon Raw format uses TIFF file structure as the base. However, it is not fully compliant with TIFF, so it can't be processed by a regular TIFF viewer. Raw image is stored in the root TIFF IFD uncompressed, as a binary TIFF tag.


KodakRAW

Full Name
Kodak Camera Raw Format
Format ID
ImGearFormats.KDC
File Extension(s)
*.dcr, *.kdc
Data Type
Bitmap
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64, Silverlight, Photo Editing

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

  • Proprietary Kodak compression:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support:

None.

ImageGear Filter Control Parameters:

See DCRAW Filter Control Parameters.

Comments:

Kodak digital cameras use this format for storing Raw images.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Kodak Raw format uses TIFF/EXIF file structure as the base, but is not fully compliant with TIFF, so it can't be processed by a regular TIFF viewer. Raw image is stored using proprietary compression. Raw data in some cameras is stored in 3-channel YUV format than in mosaic grayscale.


LeicaRAW

Full Name
Leica/Panasonic Camera Raw Format
Format ID
ImGearFormats.LeicaRaw
File Extension(s)
*.raw
Data Type
Bitmap
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64, Silverlight, Photo Editing

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support:

None.

ImageGear Filter Control Parameters:

See DCRAW Filter Control Parameters.

Comments:

Leica and Panasonic digital cameras use this format for storing Raw images.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Leica/Panasonic Raw format uses TIFF/EXIF file structure as the base, but is not fully compliant with TIFF, so it can't be processed by a regular TIFF viewer. Raw image is stored in the root TIFF IFD as uncompressed grayscale image.


MEF

Full Name
Mamiya Camera Raw Format
Format ID
ImGearFormats.MEF
File Extension(s)
*.mef
Data Type
Bitmap
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64, Silverlight, Photo Editing

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support:

None.

ImageGear Filter Control Parameters:

See DCRAW Filter Control Parameters.

Comments:

Mamiya digital cameras use this format for storing Raw images.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Mamiya Raw format uses TIFF/EXIF file structure. Raw image is stored uncompressed.


MOS

Full Name
Leaf Camera Raw Format
Format ID
ImGearFormats.MOS
File Extension(s)
*.mos
Data Type
Bitmap
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64, Silverlight, Photo Editing

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support:

None.

ImageGear Filter Control Parameters:

See DCRAW Filter Control Parameters.

Comments:

Leaf digital cameras use this format for storing Raw images.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Leica/Panasonic Raw format uses TIFF file structure as the base, but is not fully compliant with TIFF. Raw image is stored in the root TIFF IFD as uncompressed grayscale image.


MRW

Full Name
Konica Minolta Camera Raw Format
Format ID
ImGearFormats.MRW
File Extension(s)
*.mrw
Data Type
Bitmap
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64, Silverlight, Photo Editing

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

  • ImGearCompressions.NONE
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support:

None.

ImageGear Filter Control Parameters:

See DCRAW Filter Control Parameters.

Comments:

Konica Minolta digital cameras use this format for storing Raw images.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Konica Minolta Raw files use a proprietary format, that contains a hierarchy of segments. One of the segments contains EXIF metadata tree. Raw data is stored uncompressed.


NEF

Full Name
Nikon Camera Raw Format
Format ID
ImGearFormats.NEF
File Extension(s)
*.nef
Data Type
Bitmap
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64, Silverlight, Photo Editing

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.
  • ImGearCompressions.HUFFMAN:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support:

None.

ImageGear Filter Control Parameters:

See DCRAW Filter Control Parameters.

Comments:

Nikon digital cameras use this format for storing Raw images.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Nikon Raw files are compliant with TIFF/EP standard, and include EXIF metadata. They store a small color preview in the root IFD. An application that does not support NEF can read the root IFD as a regular TIFF image. Raw data is stored in a SubIFD, uncompressed or using huffman compression.


ORF

Full Name
Olympus Camera Raw Format
Format ID
ImGearFormats.ORF
File Extension(s)
*.orf
Data Type
Bitmap
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64, Silverlight, Photo Editing

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

  • ImGearCompressions.NONE
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support:

None.

ImageGear Filter Control Parameters:

See DCRAW Filter Control Parameters.

Comments:

Olympus digital cameras use this format for storing Raw images.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Olympus Raw format uses TIFF/EXIF file structure as the base. However, it is not fully compliant with TIFF, so it can't be processed by a regular TIFF viewer. Raw image is stored in the root TIFF IFD as uncompressed grayscale image.


PEF

Full Name
Pentax/Samsung Camera Raw Format
Format ID
ImGearFormats.PEF
File Extension(s)
*.pef
Data Type
Bitmap
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64, Silverlight, Photo Editing

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.
  • ImGearCompressions.HUFFMAN:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support:

None.

ImageGear Filter Control Parameters:

See DCRAW Filter Control Parameters.

Comments:

Pentax and Samsung digital cameras use this format for storing Raw images.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Pentax/Samsung Raw format uses TIFF/EXIF file structure as the base. However, it is not fully compliant with TIFF, so it can't be processed by a regular TIFF viewer. Raw image is stored in the root TIFF IFD uncompressed, or using Huffman compression.


RAF

Full Name
Fujifilm Camera Raw Format
Format ID
ImGearFormats.RAF
File Extension(s)
*.raf
Data Type
Bitmap
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64, Silverlight, Photo Editing

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support:

None.

ImageGear Filter Control Parameters:

See DCRAW Filter Control Parameters.

Comments:

Fujifilm digital cameras use this format for storing Raw images.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Fujifilm Raw format uses a proprietary prefix followed by TIFF/EXIF file structure. Raw image is stored uncompressed. CCD sensor in many Fujifilm cameras is rotated by 45 degrees, to improve quality of vertically and horizontally oriented objects in the picture. ImageGear automatically rotates these images during the "Low level processing" step of Camera Raw color reconstruction.


SonyRaw

Full Name
Sony Camera Raw Format
Format ID
ImGearFormats.SonyRaw
File Extension(s)
*.srf
Data Type
Bitmap
Data Encoding
Binary
IG Multipage Support
No
IG Alpha Channel Support
No
IG Platforms Support
WIN32, WIN64, Unix, Unix64, MAC, .NET, .NET64, Silverlight, Photo Editing

ImageGear Supported versions:

N/A

ImageGear Supported Features:

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading

ImageGear Read Support:

  • ImGearCompressions.NONE:
    • Without color reconstruction: Grayscale - 10..16 bpp;
    • With color reconstruction: RGB - 48 bpp.

ImageGear Write Support:

None.

ImageGear Filter Control Parameters:

See DCRAW Filter Control Parameters.

Comments:

Sony digital cameras use this format for storing Raw images.

By default, ImageGear automatically reconstructs colors in raw images during loading. You can disable one or more stages in the automatic color reconstruction, and reconstruct the images programmatically by using ImageGear Processing API. Use filter control parameters to disable specific stages of color reconstruction.

Sony Raw format uses TIFF/EXIF file structure as the base. However, it is not fully compliant with TIFF, so it can't be processed by a regular TIFF viewer. Raw image is stored in the root TIFF IFD uncompressed, some cameras use predictor.


Particular Cameras Supported DC RAW Formats

Camera manufacturers do not publish specifications on their raw formats. ImageGear attempts to reconstruct color images correctly where it is possible. For some cameras, however, not all of the color balance data is available. The application may need to apply additional processing to such images. This table lists the level of support that ImageGear provides for particular cameras.

The table uses the following notation:

  • S2 - ImageGear loads non-demosaiced image, basic metadata, and exif metadata if available. Reconstructed image can have incorrect colors.
  • S3 - Same as S2 plus correct white balance, black level tags. Display can be slightly different from native viewer, due to lack of info on camera color space.
  • S4 - Displays with colors very close to native viewer
  • S5 - Displays with colors and contrast very close to native viewer

    • Manufacturer
    Model
    Level of Support
    Canon
    EOS 10D
    S5
    Canon
    EOS 1D
    S2
    Canon
    EOS 1D Mark II
    S5
    Canon
    EOS 1D Mark II N
    S5
    Canon
    EOS 1D Mark III
    S5
    Canon
    EOS 1Ds
    S2
    Canon
    EOS 1Ds Mark II
    S5
    Canon
    EOS 1Ds Mark III
    S5
    Canon
    EOS 20D
    S3
    Canon
    EOS 20Da
    S3
    Canon
    EOS 300D
    S5
    Canon
    EOS 30D
    S4
    Canon
    EOS 350D
    S5
    Canon
    EOS 400D
    S4
    Canon
    EOS 40D
    S5
    Canon
    EOS 5D
    S4
    Canon
    EOS D30
    S2
    Canon
    EOS D60
    S5
    Canon
    EOS Digital Rebel
    S5
    Canon
    EOS Digital Rebel XT
    S5
    Canon
    EOS Digital Rebel Xti
    S4
    Canon
    EOS Kiss Digital
    S5
    Canon
    EOS Kiss N Digital
    S5
    Canon
    EOS Kiss X Digital
    S4
    Canon
    PowerShot 600
    S2
    Canon
    PowerShot A5
    S2
    Canon
    PowerShot A5 Zoom
    S5
    Canon
    PowerShot A50
    S2
    Canon
    PowerShot A4601
    S2
    Canon
    PowerShot A6101
    S2
    Canon
    PowerShot A6201
    S2
    Canon
    PowerShot A6301
    S2
    Canon
    PowerShot A6401
    S2
    Canon
    PowerShot A7101
    S2
    Canon
    PowerShot A7201
    S2
    Canon
    PowerShot G1
    S5
    Canon
    PowerShot G2
    S5
    Canon
    PowerShot G3
    S3
    Canon
    PowerShot G5
    S2
    Canon
    PowerShot G6
    S2
    Canon
    PowerShot G71
    S2
    Canon
    PowerShot G9
    S5
    Canon
    PowerShot Pro1
    S5
    Canon
    PowerShot Pro70
    S2
    Canon
    PowerShot Pro90 IS
    S2
    Canon
    PowerShot S2 IS1
    S2
    Canon
    PowerShot S3 IS1
    S2
    Canon
    PowerShot S30
    S2
    Canon
    PowerShot S40
    S5
    Canon
    PowerShot S45
    S2
    Canon
    PowerShot S5 IS1
    S2
    Canon
    PowerShot S50
    S4
    Canon
    PowerShot S60
    S2
    Canon
    PowerShot S70
    S2
    Casio
    Exlim Pro 5051
    S2
    Casio
    Exlim Pro 6001
    S2
    Casio
    Exlim Pro 7001
    S2
    Casio
    EX-S1001
    S2
    Casio
    EX-Z501
    S2
    Casio
    EX-Z551
    S2
    Casio
    QV-R511
    S2
    Fujifilm
    FinePix E550
    S5
    Fujifilm
    FinePix E900
    S5
    Fujifilm
    FinePix F700
    S2
    Fujifilm
    FinePix F710
    S2
    Fujifilm
    FinePix S2 Pro
    S2
    Fujifilm
    FinePix S20 Pro
    S2
    Fujifilm
    FinePix S3 Pro
    S5
    Fujifilm
    FinePix S5 Pro
    S5
    Fujifilm
    FinePix S5000 Z
    S2
    Fujifilm
    FinePix S5100
    S5
    Fujifilm
    FinePix S5200
    S5
    Fujifilm
    FinePix S5500
    S5
    Fujifilm
    FinePix S5600
    S5
    Fujifilm
    FinePix S6000fd
    S5
    Fujifilm
    FinePix S6500fd
    S5
    Fujifilm
    FinePix S7000 Z
    S2
    Fujifilm
    FinePix S9000
    S5
    Fujifilm
    FinePix S9100
    S5
    Fujifilm
    FinePix S9500
    S5
    Fujifilm
    FinePix S9600
    S5
    Kodak
    DCS 720x
    S2
    Kodak
    DCS 760C
    S4
    Kodak
    DCS 760M (monochrome)
    S2
    Kodak
    DCS PRO 14n (13.5 MegaPixel)
    S2
    Kodak
    DCS PRO 14n (3.2 MegaPixel)
    S2
    Kodak
    DCS PRO 14n (6 MegaPixel)
    S2
    Kodak
    DCS PRO 14n (YUV)
    S2
    Kodak
    DCS PRO 14nx
    S2
    Kodak
    DCS Pro SLR/c
    S2
    Kodak
    DCS Pro SLR/c (YUV)
    S2
    Kodak
    DCS Pro SLR/n (13.5 MegaPixel)
    S2
    Kodak
    DCS Pro SLR/n (3.2 MegaPixel)
    S2
    Kodak
    DCS Pro SLR/n (6 MegaPixel)
    S2
    Kodak
    DCS Pro SLR/n (YUV)
    S2
    Kodak
    EasyShare P850
    S2
    Kodak
    EasyShare P880
    S2
    Konica Minolta
    Alpha Sweet
    S5
    Konica Minolta
    DiMAGE 5
    S5
    Konica Minolta
    DiMAGE 7
    S5
    Konica Minolta
    DiMAGE 7Hi
    S5
    Konica Minolta
    DiMAGE 7i
    S4
    Konica Minolta
    DiMAGE A1
    S5
    Konica Minolta
    DiMAGE A2
    S5
    Konica Minolta
    DYNAX/MAXXUM 5D
    S5
    Konica Minolta
    DYNAX/MAXXUM/ALPHA 7D
    S5
    Leaf
    Aptus 22
    S5
    Leaf
    Aptus 54S
    S5
    Leaf
    Aptus 65
    S5
    Leaf
    Aptus 75
    S5
    Leaf
    Aptus 75S
    S5
    Leaf
    CMost
    S5
    Leaf
    Valeo 11
    S5
    Leaf
    Valeo 17
    S5
    Leaf
    Valeo 22
    S5
    Leaf
    Valeo 6
    S5
    Leica
    Digilux 2
    S5
    Leica
    Digilux 3
    S5
    Leica
    D-LUX2
    S5
    Leica
    D-LUX3
    S5
    Leica
    V-LUX1
    S5
    Mamiya
    ZD
    S2
    Nikon
    Coolpix 5000
    S2
    Nikon
    Coolpix 5400
    S5
    Nikon
    Coolpix 5700
    S5
    Nikon
    Coolpix 8400
    S5
    Nikon
    Coolpix 8700
    S5
    Nikon
    Coolpix 8800
    S5
    Nikon
    D1
    S5
    Nikon
    D100
    S5
    Nikon
    D1H
    S5
    Nikon
    D1X
    S5
    Nikon
    D200
    S5
    Nikon
    D2H
    S5
    Nikon
    D2Hs
    S5
    Nikon
    D2X
    S5
    Nikon
    D2Xs
    S5
    Nikon
    D3
    S5
    Nikon
    D300
    S5
    Nikon
    D40
    S5
    Nikon
    D40s
    S5
    Nikon
    D40x
    S5
    Nikon
    D50
    S5
    Nikon
    D50s
    S5
    Nikon
    D60
    S5
    Nikon
    D70
    S5
    Nikon
    D70s
    S5
    Nikon
    D80
    S4
    Olympus
    C-5050 Zoom
    S5
    Olympus
    C-5060 Zoom
    S5
    Olympus
    C-7070 Zoom
    S5
    Olympus
    C-7000 Zoom
    S5
    Olympus
    C-70Z
    S5
    Olympus
    C-8080
    S5
    Olympus
    E-1
    S5
    Olympus
    E-10
    S5
    Olympus
    E-20
    S5
    Olympus
    E-3
    S5
    Olympus
    E-300
    S5
    Olympus
    E-330
    S5
    Olympus
    E-400
    S5
    Olympus
    E-410
    S4
    Olympus
    E-500
    S5
    Olympus
    E-510
    S4
    Olympus
    SP350
    S5
    Olympus
    SP500UZ
    S5
    Olympus
    SP510UZ
    S5
    Olympus
    SP550UZ
    S5
    Olympus
    SP560UZ
    S5
    Panasonic
    DMC-FZ18
    S5
    Panasonic
    DMC-FZ30
    S5
    Panasonic
    DMC-FZ50
    S5
    Panasonic
    DMC-FZ8
    S5
    Panasonic
    DMC-L1
    S5
    Panasonic
    DMC-L10
    S5
    Panasonic
    DMC-LC1
    S5
    Panasonic
    DMC-LX1
    S5
    Panasonic
    DMC-LX2
    S5
    Pentax
    *ist D
    S5
    Pentax
    *ist DL
    S5
    Pentax
    *ist DL2
    S4
    Pentax
    *ist DS
    S5
    Pentax
    *ist DS2
    S5
    Pentax
    K100D
    S4
    Pentax
    K100D Super
    S5
    Pentax
    K10D
    S5
    Pentax
    K110D
    S4
    Samsung
    GX-10
    S5
    Samsung
    GX-1S
    S5
    Sony
    DSC-F828
    S2
    Sony
    DSC-R1
    S3
    Sony
    DSC-V3
    S2
    Sony
    DSLR-A100
    S5
    Sony
    DSLR-A700
    S2

1) Headerless Camera Raw file. Detection is disabled by default.


ImageGear Supported Non-Image Data

This section provides you with the detailed information about the following structures of supported by ImageGear for .NET metadata:

  • TIFF Non-Image Data Structure
  • Photoshop Image Resource metadata structure
  • JPEG Non-Image Data Structure
  • EXIF Non-Image Data Structure
  • IPTC Non-Image Data Structure
  • PNG Non-Image Data Structure
  • GIF Non-image Data Structure
  • DICOM Non-Image Data Structure
  • Camera Raw Non-Image Data Structure
  • CIFF Non-Image Data Structure
  • XMP Non-Image Data Structure


TIFF Non-Image Data Structure

As with all multipage image formats, ImageGear for .NET uses separate metadata trees for TIFF document-level metadata and TIFF page-level metadata:

  • Document level metadata:
    Name
    Id
    Type
    Value Type
    Value
    Value Length
    Ignored on save
    ByteOrder
    59936
    Leaf
    UINT16
    0x4949 or
    0x4D4D
    1
    TRUE
    Identifier
    59937
    Leaf
    UINT16
    42
    1
    TRUE
  • Page level metadata:

TIFF page level metadata corresponds to a TIFF IFD.

Tags

Most of TIFF tags are passed through metadata callback as

Name
Id
Type
Value Type
Value
Value Length
Ignored on save
<TagName>
<TagId>
VALUE_ITEM
<ValueType>
<TagValue>
<TagCount>
<R.o.>

The valid values of <TagName>, <TagId> and "Read Only" attributes are available in Description of TIFF tags (ImGearTIFTagIDs) Table.

See Also:

TIFF Complex Data Tags

NOTE: It is possible to use tag identifier and value of nonstandard tag (user defined tag).

The <TagCount> is real tag count value that is read/written in file.

The < ValueType > value is the metadata type constant that matches TIFF tag type as described in the table below:

TIFF tag type
Metadata type (ImGearNativeDataTypes)
BYTE
AM_TID_META_UINT8
SBYTE
AM_TID_META_INT8
SHORT
AM_TID_META_UINT16
SSHORT
AM_TID_META_INT16
LONG
AM_TID_META_UINT32
SLONG
AM_TID_META_INT32
RATIONAL
AM_TID_META_RATIONAL_UINT32
SRATIONAL
AM_TID_META_RATIONAL_INT32
FLOAT
AM_TID_META_FLOAT
DOUBLE
AM_TID_META_DOUBLE
ASCII
AM_TID_META_STRING
UNDEFINED
AM_TID_RAW_DATA

Description of TIFF tags (ImGearTIFTagIDs)

Item Name
Item Id
Ignored on save
"NewSubfileType"
254
TRUE
"SubfileType"
255
TRUE
"ImageWidth"
256
TRUE
"ImageLength"
257
TRUE
"BitsPerSample"
258
TRUE
"Compression"
259
TRUE
"PhotometricInterpretation"
262
TRUE
"Threshholding"
263
FALSE
"CellWidth"
264
TRUE
"CellLength"
265
TRUE
"FillOrder"
266
FALSE
"DocumentName"
269
FALSE
"ImageDescription"
270
FALSE
"Make"
271
FALSE
"Model"
272
FALSE
"StripOffsets"
273
TRUE
"Orientation"
274
FALSE
"SamplesPerPixel"
277
TRUE
"RowsPerStrip"
278
TRUE
"StripByteCounts"
279
TRUE
"MinSampleValue"
280
FALSE
"MaxSampleValue"
281
FALSE
"XResolution"
282
FALSE
"YResolution"
283
FALSE
"PlanarConfiguration"
284
TRUE
"PageName"
285
FALSE
"XPosition"
286
FALSE
"YPosition"
287
FALSE
"FreeOffsets"
288
TRUE
"FreeByteCounts"
289
TRUE
"GrayResponseUnit"
290
FALSE
"GrayResponseCurve"
291
FALSE
"T4Options"
292
TRUE
"T6Options"
293
TRUE
"ResolutionUnit"
296
FALSE
"PageNumber"
297
TRUE
"TransferFunction"
301
FALSE
"Software"
305
FALSE
"DateTime"
306
FALSE
"Artist"
315
FALSE
"HostComputer"
316
FALSE
"Predictor"
317
TRUE
"WhitePoint"
318
FALSE
"PrimaryChromaticities"
319
FALSE
"ColorMap"
320
TRUE
"HalftoneHints"
321
FALSE
"TileWidth"
322
TRUE
"TileLength"
323
TRUE
"TileOffsets"
324
TRUE
"TileByteCounts"
325
TRUE
"InkSet"
332
FALSE
"InkNames"
333
FALSE
"NumberOfInks"
334
FALSE
"DotRange"
336
FALSE
"TargetPrinter"
337
FALSE
"ExtraSamples"
338
TRUE
"SampleFormat"
339
FALSE
"SMinSampleValue"
340
FALSE
"SMaxSampleValue"
341
FALSE
"TransferRange"
342
FALSE
"JPEGTables"
347
TRUE
"JPEGProc"
512
TRUE
"JPEGInterchangeFormat"
513
TRUE
"JPEGInterchangeFormatLngth"
514
TRUE
"JPEGRestartInterval"
515
TRUE
"JPEGLosslessPredictors"
517
TRUE
"JPEGPointTransforms"
518
TRUE
"JPEGQTables"
519
TRUE
"JPEGDCTables"
520
TRUE
"JPEGACTables"
521
TRUE
"YCbCrCoefficients"
529
FALSE
"YCbCrSubSampling"
530
TRUE
"YCbCrPositioning"
531
FALSE
"ReferenceBlackWhite"
532
FALSE
"Copyright"
33432
FALSE
"PhotoshopResources"
34377
FALSE
"ExifIFDPointer"
34665
TRUE
"GPSInfoIFDPointer"
34675
TRUE

NOTE: Please see file ImGearTIFTagIDs enum for the full list of TIFF Metadata Item Id constants.

TIFF Complex Data Tags

Some tags, which value is a complex data, can be passed in parsed form as a tree. In this case, a single metadata item is replaced with a tree that uses one of the specialized metadata formats, such as Photoshop (PhotoshopImageResources) or IPTC.

EXIF metadata

ExifIFDPointer tag in a TIFF file points to an IFD which contains tags defined in the EXIF image file format specification. ImageGear replaces this tag with EXIF metadata tree.

EXIF metadata usually contains nested IFDs as well.

SubIFDs

TIFF images can contain "SubIFDs" - nested sets of tags. A SubIFD usually contains a special version of image, such as a thumbnail, or a Raw image taken from a digital camera sensor.

ImageGear represents SubIFDs as subtrees of the root TIFF IFD.


Photoshop Image Resource metadata structure

PhotoshopResources level

This level can contain arbitrary number of PhotoshopImageResource subtrees:

Name
Id
Type
Value Type
Value
Value Length
Ignored on save
PhotoshopImageResource
<Res. Id>
Tree
N/A
N/A
N/A
N/A
Or in case the data is parsed
ResolutionInfo
ImGearPHOTOSHOPTagIDs.ResolutionInfo
Tree
N/A
N/A
N/A
N/A
AlphaNames
ImGearPHOTOSHOPTagIDs.AlphaNames
Tree
N/A
N/A
N/A
N/A
DisplayInfo
ImGearPHOTOSHOPTagIDs.DisplayInfo
Tree
N/A
N/A
N/A
N/A
Caption
ImGearPHOTOSHOPTagIDs.Caption
Tree
N/A
N/A
N/A
N/A
IPTC
ImGearPHOTOSHOPTagIDs.IPTC
Tree
N/A
N/A
N/A
N/A
Thumbnail
ImGearPHOTOSHOPTagIDs.Thumbnail
Tree
N/A
N/A
N/A
N/A
ICCProfile
ImGearPHOTOSHOPTagIDs.ICCProfile
Tree
N/A
N/A
N/A
N/A
UnicodeAlphaNames
ImGearPHOTOSHOPTagIDs.UnicodeAlphaNames
Tree
N/A
N/A
N/A
N/A
TransparencyIndex
ImGearPHOTOSHOPTagIDs.TransparencyIndex
Tree
N/A
N/A
N/A
N/A
AlphaIdentifiers
ImGearPHOTOSHOPTagIDs.AlphaIdentifiers
Tree
N/A
N/A
N/A
N/A
VersionInfo
ImGearPHOTOSHOPTagIDs.VersionInfo
Tree
N/A
N/A
N/A
N/A

PhotoShopImageResource level

Name
Id
Type
Value Type
Value
Value Length
Ignored on save
"PhotoshopImageResourceSize"
<Res. Id>
Leaf
UINT16
1
True
Resource data
"Data"
ImGearPHOTOSHOPTagID s.SEGMENTDATA
Leaf
RAW_DATA
False
Or in case the data are parsed (currently it happens only for IPTC data)
"ResolutionInfo"
ImGearPHOTOSHOPTagIDs.ResolutionInfo
Tree
N/A
N/A
N/A
False
"AlphaNames"
ImGearPHOTOSHOPTagIDs.AlphaNames
Tree
N/A
N/A
N/A
False
DisplayInfo"
ImGearPHOTOSHOPTagIDs.DisplayInfo
Tree
N/A
N/A
N/A
False
"Caption"
ImGearPHOTOSHOPTagIDs.Caption
Tree
N/A
N/A
N/A
False
"IPTC"
ImGearPHOTOSHOPTagIDs.IPTC
Tree
N/A
N/A
N/A
False
"Thumbnail"
ImGearPHOTOSHOPTagIDs.Thumbnail
Tree
N/A
N/A
N/A
False
"ICCProfile"
ImGearPHOTOSHOPTagIDs.ICCProfile
Tree
N/A
N/A
N/A
False
"UnicodeAlphaNames"
ImGearPHOTOSHOPTagIDs.UnicodeAlphaNames
Tree
N/A
N/A
N/A
False
"TransparencyIndex"
ImGearPHOTOSHOPTagIDs.TransparencyIndex
Tree
N/A
N/A
N/A
False
"AlphaIdentifiers"
ImGearPHOTOSHOPTagIDs.AlphaIdentifiers
Tree
N/A
N/A
N/A
False
"VersionInfo"
ImGearPHOTOSHOPTagIDs.VersionInfo
Tree
N/A
N/A
N/A
False


JPEG Non-Image Data Structure

JPEG metadata structure is framed in several levels:

  • JPEG level containing all JPEG metadata,
  • JPEG marker segment levels containing metadata of each particular JPEG marker segment.

JPEG level

Name
Id
Type
Value Type
Value
Value Length
Ignored on save
"JPEG-JFIF"
ImGearFormats.JPG
Tree
JPEG marker segment levels

JPEG marker segment levels

The following JPEG marker segments metadata are supported:

  • Frame marker segment level - SOF0, SOF1, SOF2 and SOF3 (read only)
  • Frame component level
  • Scan marker segment level - SOS (read only)
  • Scan component level
  • Define-quantization-table marker segment level - DQT (read only)
  • Define-quantization-table table level
  • Define-Huffman-tables marker segment level - DHT (read only)
  • Define-Huffman-table table level
  • Comment marker segment level - COM (read/write),
  • Application marker segment level - APP0-APP15 (read/write).

Segment level markers are described in the tables below.

Frame marker segment level

Name
Id
Type
Value Type
Value
Value Length
Ignored on save
"Precision"
ImGearJPEGTagIDs. FRAME_PRECISION
Leaf
UINT8
1
TRUE
"Lines"
ImGearJPEGTagIDs. FRAME_LINES
Leaf
UINT16
1
TRUE
"SamplesPerLine"
ImGearJPEGTagIDs. FRAME_SAMPLES_PER_LINE
Leaf
UINT16
1
TRUE
"NumberOfComponents"
ImGearJPEGTagIDs. FRAME_NUMBER_OF_COMPONENTS
Leaf
UINT8
<n>
1
TRUE
Frame component level 1
ImGearJPEGTagIDs. FRAME_COMPONENT_SPEC
Tree
...
Frame component level <n>
ImGearJPEGTagIDs. FRAME_COMPONENT_SPEC
Tree

Frame component level

Name
Id
Type
Value Type
Value
Value Length
Ignored on save
"Identifier"
ImGearJPEGTagIDs. FRAME_COMPONENT_ID
Leaf
UINT
<Component No.>
1
TRUE
HVSamplingFactors
ImGearJPEGTagIDs. FRAME_COMPONENT_HV_SAMPLING
Leaf
UINT
1
TRUE
"QuantizationNumber"
ImGearJPEGTagIDs. FRAME_COMPONENT_QUANT_SELECTOR
Leaf
UINT
1
TRUE

NOTE: <Component No.> is frame component identifier of appropriate component.

Scan marker segment level

Name
Id
Type
Value Type
Value
Value Length
Ignored on save
"ComponentNumber"
ImGearJPEGTagIDs. SCAN_COMPONENT_NUMBER
Leaf
UINT8
<n>
1
TRUE
Scan component level 1
ImGearJPEGTagIDs.SCAN_COMPONENT
Tree
Scan component level <n>
ImGearJPEGTagIDs.SCAN_COMPONENT
Tree
"SpectralStart"
ImGearJPEGTagIDs.SCAN_SP_START
Leaf
UINT8
1
TRUE
"SpectralEnd"
ImGearJPEGTagIDs.SCAN_SP_END
Leaf
UINT8
TRUE
"AH_AL"
ImGearJPEGTagIDs.SCAN_AH_AL
Leaf
UINT8
TRUE

Scan component level

Name
Id
Type
Value Type
Value
Value Length
Ignored on save
"Selector"
ImGearJPEGTagIDs. SCAN_SELECTOR
Leaf
UINT8
1
TRUE
"DC_AC"
ImGearJPEGTagIDs. SCAN_DC_AC
Leaf
UINT8
1
TRUE

Define-quantization-table marker segment level

Name
Id
Type
Value Type
Value
Value Length
Ignored on save
"QuantizationTable"
ImGearJPEGTagIDs.QUANT_TABLE
Tree
"QuantizationTable"
ImGearJPEGTagIDs.QUANT_TABLE
Tree

Define-quantization-table table level

Name
Id
Type
Value Type
Value
Value Length
Ignored on save
"Descriptor"
ImGearJPEGTagIDs. QUANT_TABLE_DESCRIPTOR
Leaf
UINT8
TRUE
"Elements"
ImGearJPEGTagIDs. QUANT_TABLE_ELEMENTS
Leaf
UINT8 or UINT16
TRUE

Define-Huffman-tables marker segment level

Name
Id
Type
Value Type
Value
Value Length
Ignored on save
"HuffmanTable"
ImGearJPEGTagIDs.HUFFMAN_TABLE
Tree
"HuffmanTable"
ImGearJPEGTagIDs.HUFFMAN_TABLE
Tree

Define-Huffman-table table level

Name
Id
Type
Value Type
Value
Value Length
Ignored on save
"Descriptor"
ImGearJPEGTagIDs. HUFFMAN_TABLE_DESCRIPTOR
Leaf
UINT8
TRUE
"Lengths"
ImGearJPEGTagIDs. HUFFMAN_TABLE_LENGTH
Leaf
UINT8
TRUE
"Values"
ImGearJPEGTagIDs. HUFFMAN_TABLE_VALUES
Leaf
UINT8
TRUE
"Values"
ImGearJPEGTagIDs. HUFFMAN_TABLE_VALUES
Leaf
UINT8
TRUE

Comment marker segment level

Name
Id
Type
Value Type
Value
Value Length
Ignored on save
"Comment"
ImGearJPEGTagIDs. COMMENT
Leaf
STRING
<ValueSize>
FALSE

Application marker segment level

There are several application marker segments, which data structure is well known. These segments are parsed and their data are passed in special format.

These marker segments are:

  • JFIF APP0 segment
  • JFIF extension (JFXX) APP0 segment (read only)
  • EXIF APP1 segment
  • Photoshop Image Resource APP13 marker segment(it includes some IPTC data and another Photoshop Image Resource metadata structure)
  • Other application marker segment levels

JFIF APP0 segment

Name
Id
Type
Value Type
Value
Value Length
Ignored on save
"JFIF_HEADER"
ImGearJPEGTagIDs. JFIF_ID
Leaf
STRING
JFIF
5
TRUE
"Version"
ImGearJPEGTagIDs. JFIF_VERSION
Leaf
UINT16
1
FALSE
"ResolutionUnits"
ImGearJPEGTagIDs. JFIF_UNITS
Leaf
UINT8
1
FALSE
"ResolutionX"
ImGearJPEGTagIDs. JFIF_X_RES
Leaf
UINT16
1
FALSE
"ResolutionY"
ImGearJPEGTagIDs. JFIF_Y_RES
Leaf
UINT16
1
FALSE
"ThumbnailWidth"1
ImGearJPEGTagIDs. JFIF_THUMB_WIDTH
Leaf
UINT8
1
TRUE
"ThumbnailHeight"2
ImGearJPEGTagIDs. JFIF_THUMB_HEIGHT
Leaf
UINT8
1
TRUE
1The thumbnail width tags are present only if the thumbnail is stored to JFIF segment.
2The thumbnail width tags are present only if the thumbnail is stored to JFIF segment.

Photoshop Image Resource APP13 marker segment

Name
Id
Type
Value Type
Value
Value Length
Ignored on save
"PHOTOSHOP_HEADER"
ImGearJPEGTagIDs. PHOTOSHOP_HEADER
Leaf
STRING
"Photoshop 3.0"
14
FALSE
Photoshop Image Resource level 1
...
Photoshop Image Resource level n

NOTE: For "Photoshop Image Resource" metadata structure see Photoshop Image Resource metadata structure Table.

Other application marker segment levels

Name
Id
Type
Value Type
Value
Value Length
Ignored on save
"DATA"
ImGearJPEGTagIDs. BINARY_DATA
Leaf
RAW_DATA
<ValueSize>
FALSE


EXIF Non-Image Data Structure

ImageGear for .NET processes EXIF as a metadata format, rather than as a separate image file format.

EXIF level metadata

EXIF level metadata uses the following structure.

Name
Id
Type
Value Type
Value
Value Length
Ignored on save
<EXIF subIFD tags>
<EXIF subIFD tag ids>
"Interoperability"
ImGearMetadataFormats.INTEROPERABILITYIFD
Tree
"GPS"
ImGearMetadataFormats.INTEROPERABILITYIFD
Tree

Interoperability and GPS IFDs are optional.

See Exif subIFD tags for the list of Exif subIFD tag names and Ids.

EXIF GPS Level metadata

EXIF GPS level metadata uses the following structure:

Name
Id
Type
Value Type
Value
Value Length
Ignored on save
<EXIF GPS tags>
<EXIF GPS tag ids>

See GPS subIFD tags for the list of EXIF GPS tag names and Ids.

EXIF Interoperability Level metadata

EXIF Interoperability level metadata uses the following structure:

Name
Id
Type
Value Type
Value
Value Length
Ignored on save
<EXIF Interoperability tags>
<EXIF Interoperability tag ids>

See Interoperability subIFD tags for the list of EXIF Interoperability tag names and Ids.

Description of tags used in EXIF

The following types of EXIF tags are described below:

  • Exif subIFD tags
  • GPS subIFD tags
  • Interoperability subIFD tags

Exif subIFD tags

Item Name
Item Id
Ignored on save
"ExposureTime"
33434
FALSE
"Fnumber"
33437
FALSE
"ExposureProgram"
34850
FALSE
"SpectralSensitivity"
34852
FALSE
"ISOSpeedRatings"
34855
FALSE
"OECF"
34856
FALSE
"ExifVersion"
36864
FALSE
"DateTimeOriginal"
36867
FALSE
"DateTimeDigitized"
36868
FALSE
"ComponentsConfiguration"
37121
FALSE
"CompressedBitsPerPixel"
37122
FALSE
"ShutterSpeedValue"
37377
FALSE
"ApertureValue"
37378
FALSE
"BrightnessValue"
37379
FALSE
"ExposureBiasValue"
37380
FALSE
"MaxApertureValue"
37381
FALSE
"SubjectDistance"
37382
FALSE
"MeteringMode"
37383
FALSE
"LightSource"
37384
FALSE
"Flash"
37385
FALSE
"FocalLength"
37386
FALSE
"SubjectArea"
37396
FALSE
"MakerNote"
37500
FALSE
"UserComment"
37510
FALSE
"SubSecTime"
37520
FALSE
"SubSecTimeOriginal"
37521
FALSE
"SubSecTimeDigitized"
37522
FALSE
"FlashPixVersion"
40960
FALSE
"ColorSpace"
40961
FALSE
"PixelXDimension"
40962
TRUE
"PixelYDimension"
40963
TRUE
"RelatedSoundFile"
40964
FALSE
"InteroperabilityIFDPointer"
40965
TRUE
"FlashEnergy"
41483
FALSE
"SpatialFrequencyResponse"
41484
FALSE
"FocalPlaneXResolution"
41486
FALSE
"FocalPlaneYResolution"
41487
FALSE
"FocalPlaneResolutionUnit"
41488
FALSE
"SubjectLocation"
41492
FALSE
"ExposureIndex"
41493
FALSE
"SensingMethod"
41495
FALSE
"FileSource"
41728
FALSE
"SceneType"
41729
FALSE
"CFAPattern"
41730
FALSE
"CustomRendered"
41985
FALSE
"ExposureMode"
41986
FALSE
"WhiteBalance"
41987
FALSE
"DigitalZoomRatio"
41988
FALSE
"FocalLengthIn35mmFilm"
41989
FALSE
"SceneCaptureType"
41990
FALSE
"GainControl"
41991
FALSE
"Contrast"
41992
FALSE
"Saturation"
41993
FALSE
"Sharpness"
41994
FALSE
"DeviceSettingDescription"
41995
FALSE
"SubjectDistanceRange"
41996
FALSE
"ImageUniqueID"
42016
FALSE

GPS subIFD tags

Item Name
Item Id
Ignored on save
"GPSVersionID"
0
FALSE
"GPSLatitudeRef"
1
FALSE
"GPSLatitude"
2
FALSE
"GPSLongitudeRef"
3
FALSE
"GPSLongitude"
4
FALSE
"GPSAltitudeRef"
5
FALSE
"GPSAltitude"
6
FALSE
"GPSTimeStamp"
7
FALSE
"GPSSatellites"
8
FALSE
"GPSStatus"
9
FALSE
"GPSMeasureMode"
10
FALSE
"GPSDOP"
11
FALSE
"GPSSpeedRef"
12
FALSE
"GPSSpeed"
13
FALSE
"GPSTrackRef"
14
FALSE
"GPSTrack"
15
FALSE
"GPSImgDirectionRef"
16
FALSE
"GPSImgDirection"
17
FALSE
"GPSMapDatum"
18
FALSE
"GPSDestLatitudeRef"
19
FALSE
"GPSDestLatitude"
20
FALSE
"GPSDestLongitudeRef"
21
FALSE
"GPSDestLongitude"
22
FALSE
"GPSDestBearingRef"
23
FALSE
"GPSDestBearing"
24
FALSE
"GPSDestDistanceRef"
25
FALSE
"GPSDestDistance"
26
FALSE
"GPSProcessingMethod"
27
FALSE
"GPSAreaInformation"
28
FALSE
"GPSDateStamp"
29
FALSE
"GPSDifferential"
30
FALSE

Interoperability subIFD tags

Item Name
Item Id
Read Only
"InteroperabilityIndex "
1
FALSE
"InteroperabilityVersion "
2
FALSE
"RelatedImageFileFormat"
4096
FALSE
"RelatedImageWidth "
4097
FALSE
"RelatedImageLength"
4098
FALSE


IPTC Non-Image Data Structure

International Press and Telecommunications Council Standards (IPTC) have been created for exchanging different type of information.

IPTC is a metadata format rather than a image file format. It can be stored within JPEG and TIFF image files as Adobe Photoshop Image Resource (see Photoshop Image Resource metadata structure). In TIFF files the IPTC data is stored in TIFF tag with Id = 34377 (see TIFF Non-Image Data Structure for metadata structure of the tag). In JPEG files the IPTC data is stored in Photoshop Image Resource APP13 marker segment (see JPEG Non-Image Data Structure).

ImageGear IPTC metadata structure is framed in two levels:

  • IPTC level containing all IPTC data
  • Record level containing value items of a record.

IPTC level

Name
Id
Type
Value Type
Value
Value Length
Ignored on save
Record level 1
<Record#>
Tree
Record level n
<Record#>
Tree

The <Record#> is identifier of IPTC record. Its value is the number of appropriate IPTC record described in IPTC - NAA IIM4 specification. Record levels must follow in numerical order within IPTC level.

Record level

Name
Id
Type
Value Type
Value
Value Length
Ignored on save
Dataset value item
<DataSet ID>
Leaf
<Value Type>
<Data>
<Item Count>
FALSE
Dataset value item
<DataSet ID>
Leaf
<Value Type>
<Data>
<Item Count>
FALSE

The available <Dataset name>, <Dataset Id>, <Item Count> and <Value Type> values are described below for each IPTC record according to IPTC-NAA IIM4 specification. Dataset value item can follow in any order within appropriate record level.

In the tables below, last column lists maximum item count for non-string types, and string length for string types. Item count for string types in IPTC metadata is always 1.

Dataset value items description for IPTC Envelope Record (Record #1)

Item Identifier
Item Name
Value Type
Max. Value Length
(for String last NULL is not counted)
0
"ModelVersion"
UINT16
1
5
"Destination"
STRING
1024
20
"FileFormat"
UINT16
1
22
"FileFormatVersion"
UINT16
1
30
"ServiceIdentifier"
STRING
10
40
"EnvelopeNumber"
STRING
8
50
"ProductID"
STRING
32
60
"EnvelopePriority"
STRING
1
70
"DateSent"
STRING
8
80
"TimeSent"
STRING
11
90
"CodedCharacterSet"
STRING
32
100
"UNO"
STRING
80
120
"ARMIdentifier"
UINT16
1
122
"ARMVersion"
UINT16
1

Dataset value items description for IPTC Application Record (Record #2)

Item Identifier
Item Name
Value Type
Max. Value Length
(for String last NULL is not counted)
0
"RecordVersion"
UINT16
1
3
"ObjectTypeReference"
STRING
67
4
"ObjectAttributeReference"
STRING
68
5
"ObjectName"
STRING
64
7
"EditStatus"
STRING
64
8
"EditorialUpdate"
STRING
2
10
"Urgency"
STRING
1
12
"SubjectReference"
STRING
236
15
"Category"
STRING
3
20
"SupplementalCategory"
STRING
32
22
"FixtureIdentifier"
STRING
32
25
"Keywords"
STRING
64
26
"ContentLocationCode"
STRING
3
27
"ContentLocationName"
STRING
64
30
"ReleaseDate"
STRING
8
35
"ReleaseTime"
STRING
11
37
"ExpirationDate"
STRING
8
38
"ExpirationTime"
STRING
11
40
"SpecialInstructions"
STRING
256
42
"ActionAdvised"
STRING
2
45
"ReferenceService"
STRING
10
47
"ReferenceDate"
STRING
8
50
"ReferenceNumber"
STRING
8
55
"DateCreated"
STRING
8
60
"TimeCreated"
STRING
11
62
"DigitalCreationDate"
STRING
8
63
"DigitalCreationTime"
STRING
11
65
"OriginatingProgram"
STRING
32
70
"ProgramVersion"
STRING
10
75
"ObjectCycle"
STRING
1
80
"By-line"
STRING
32
85
"By-lineTitle"
STRING
32
90
"City"
STRING
32
92
"Sublocation"
STRING
32
95
"Province/State"
STRING
32
100
"Country/
PrimaryLocationCode"
STRING
3
101
"Country/
PrimaryLocationName"
STRING
64
103
"OriginalTransmission
Reference"
STRING
32
105
"Headline"
STRING
256
110
"Credit"
STRING
32
115
"Source"
STRING
32
116
"CopyrightNotice"
STRING
128
118
"Contact"
STRING
128
120
"Caption/Abstract"
STRING
2000
122
"Writer/Editor"
STRING
32
125
"RasterizedCaption"
UINT8
7360
130
"ImageType"
STRING
2
131
"ImageOrientation"
STRING
1
135
"LanguageIdentifier"
STRING
3
150
"AudioType"
STRING
2
151
"AudioSamplingRate"
STRING
6
152
"AudioSamplingResolution"
STRING
2
153
"AudioDuration"
STRING
6
154
"AudioOutcue"
STRING
64
200
"ObjectDataPreview
FileFormat"
UINT16
1
201
"ObjectDataPreview
FileFormatVersion"
UINT16
1
202
"ObjectDataPreviewData"
UINT8
Undefined

Dataset value items description for IPTC Digital News Photo Parameter Record (Record #3)

Item Identifier
Item Name
Value Type
Max. Value Length (for String last NULL is not counted)
0
"RecordVersion"
UINT16
1
10
"PictureNumber"
RAW_DATA
16
20
"PixelsPerLine"
UINT16
1
30
"NumberOfLine"
UINT16
1
40
"PixelSizeInScanningDirection"
UINT16
1
50
"PixelSizePerpendicularTo
ScanningDirection"
UINT16
1
55
"SupplementType"
UINT8
1
60
"ColourRepresentation"
UINT8
2
64
"InterchangeColourSpace"
UINT8
1
65
"ColourSequence"
UINT8
4
66
"ICCInputColourProfile"
RAW_DATA
Undefined
70
"ColourCalibrationMatrixTable"
RAW_DATA
Undefined
80
"LookupTable"
RAW_DATA
131072
84
"NumberOfIndexEntries"
UINT16
1
85
"ColourPalette"
RAW_DATA
Undefined
86
"NumberOfBitsPerSample"
UINT8
1
90
"SamplingStructure"
UINT8
1
100
"ScanningDirection"
UINT8
1
102
"ImageRotation"
UINT8
1
110
"DataCompressionMethod"
RAW_DATA
4
120
"QuantisationMethod"
UINT8
1
125
"EndPoints"
UINT8
Undefined
130
"ExcursionTolerance"
UINT8
1
135
"BitsPerComponent"
UINT8
Undefined
140
"MaximumDensityRange"
UINT16
1
145
"GammaCompensatedValue"
UINT16
1

Dataset value items description for IPTC Pre-Object Descriptor Record (Record #7)

Item Identifier
Item Name
Value Type
Max. Value Length (for String last NULL is not counted)
10
"SizeMode"
UINT8
1
20
"MaxSubfileSize"
UINT8 or
UINT16 or
UINT32
1
90
"ObjectDataSizeAnnounced"
UINT8 or
UINT16 or
UINT32
1
95
"MaximumObjectDataSize"
UINT8 or
UINT16 or
UINT32
1

Dataset value items description for IPTC Object Record (Record #8)

Item Identifier
Item Name
Value Type
Max. Value Length (for String last NULL is not counted)
10
"Subfile"
RAW_DATA
Undefined

Dataset value items description for IPTC Post-Object Descriptor Record (Record #9)

Item Identifier
Item Name
Value Type
Max. Value Length (for String last NULL is not counted)
10
"ConfirmedObjectDataSize"
UINT8 or
UINT16 or
UINT32
1


PNG Non-Image Data Structure

PNG format groups non-image data in "Chunks". ImageGear represents simpler chunks by single metadata items, and more complex chunks by subtrees. Thus, there are two main PNG metadata levels in ImageGear:

  • PNG metadata level
  • PNG chunks metadata level

PNG metadata level

Name
Id
Type
Value Type
Value
Value Length
Ignored on save
<PNG chunk names>
<PNG chunk ids>
<PNG chunk type>

For <PNG chunk names >, <PNG chunk ids> and <PNG Chunk types> see PNG chunks metadata level section.

PNG chunks metadata level

The following PNG non-image chunk levels are supported by ImageGear Professional:

  • PNG header chunk metadata
  • Physical dimension chunk metadata
  • Transparency chunk metadata
  • Gamma chunk metadata
  • Primary chromaticities chunk metadata
  • sRGB chunk metadata
  • ICC profile chunk metadata
  • Background chunk metadata
  • Significant bits chunk metadata
  • Suggested palette chunk metadata
  • Palette histogram chunk metadata
  • Modified time chunk metadata
  • Text chunk metadata
  • Compressed textual data chunk metadata
  • International textual data chunk metadata
  • Calibration of pixel values chunk metadata
  • Physical scale chunk metadata
  • GIF application extension chunk metadata
  • GIF Graphic Control Extension chunk metadata
  • Image offset chunk metadata
  • The rest chunk metadata

PNG header chunk metadata

PNG level

Name
Id
Type
Value Type
Value
Value Length
Ignored on save
"IHDR"
0x49484452
Tree

Header chunk level

Name
Id
Type
Value Type
Value
Value Length
Ignored on save
"Width"
0x49484452
Leaf
UINT32
1
TRUE
"Height"
0x49484452
Leaf
UINT32
1
TRUE
"BitDepth"
0x49484452
Leaf
UINT8
1
TRUE
"ColorType"
0x49484452
Leaf
UINT8
1
TRUE
"CompressionType"
0x49484452
Leaf
UINT8
1
TRUE
"FilterType"
0x49484452
Leaf
UINT8
1
TRUE
"InterlaceType"
0x49484452
Leaf
UINT8
1
TRUE

Physical dimension chunk metadata

PNG level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"pHYs"
0x70485973
Tree

Physical dimension chunk level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"XAxis"
0x70485973
Leaf
UINT32
1
FALSE
"YAxis"
0x70485973
Leaf
UINT32
1
FALSE
"UnitSpecifier"
0x70485973
Leaf
UINT8
1
FALSE

Transparency chunk metadata

PNG level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"tRNS"
0x74524e53
Leaf
UINT8 or
UINT16
Variable
FALSE

Gamma chunk metadata

PNG level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"gAMA"
0x67414d41
Leaf
UINT32
1
FALSE

Primary chromaticities chunk metadata

PNG level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"cHRM"
0x6348524d
Tree

Primary chromaticities chunk level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"WhitePoint"
0x6348524d
Tree
"x"
0x6348524d
Leaf
UINT32
1
FALSE
"y"
0x6348524d
Leaf
UINT32
1
FALSE
"Red"
0x6348524d
Tree
"x"
0x6348524d
Leaf
UINT32
1
FALSE
"y"
0x6348524d
Leaf
UINT32
1
FALSE
"Green"
0x6348524d
Tree
"x"
0x6348524d
Leaf
UINT32
1
FALSE
"y"
0x6348524d
Leaf
UINT32
1
FALSE
"Blue"
0x6348524d
Tree
"x"
0x6348524d
Leaf
UINT32
1
FALSE
"y"
0x6348524d
Leaf
UINT32
1
FALSE

sRGB chunk metadata

PNG level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"sRGB"
0x73524742
Leaf
UINT32
1
FALSE

ICC profile chunk metadata

PNG level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"iCCP"
0x70485973
Tree

ICC profile chunk level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"ProfileName"
0x70485973
Leaf
STRING
Variable
FALSE
"ProfileData"
0x70485973
Leaf
RAW_DATA
Variable
FALSE

Background chunk metadata

PNG level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"bKGD"
0x624b4744
Leaf
UINT8 or UINT16
Variable
FALSE

Significant bits chunk metadata

PNG level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"sBIT"
0x73424954
Leaf
UINT8
Variable
FALSE

Suggested palette chunk metadata

PNG level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"sPLT"
0x73504c54
Tree

Suggested palette chunk level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"PaletteName"
0x73504c54
Leaf
STRING
Variable
TRUE
"SampleDepth"
0x73504c54
Leaf
UINT8
1
FALSE
"PaletteEntryCount"
0x73504c54
Leaf
UINT16
<N>
1
FALSE
Palette entry level 0
<Entry No.>
Tree
...
Palette entry level n
<Entry No.>
Tree

Palette entry level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"Red"
<Entry No.>
Leaf
UINT8 or UINT16
1
FALSE
"Green"
<Entry No.>
Leaf
UINT8 or UINT16
1
FALSE
"Blue"
<Entry No.>
Leaf
UINT8 or UINT16
1
FALSE
"Alpha"
<Entry No.>
Leaf
UINT8 or UINT16
1
FALSE
"Frequency"
<Entry No.>
Leaf
UINT16
1
FALSE

Palette histogram chunk metadata

PNG level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"hIST"
0x68495354
Leaf
UINT16
Variable
FALSE

Modified time chunk metadata

PNG level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"tIME"
0x74494d45
Tree

Modified time chunk level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"Year"
0x74494d45
Leaf
UINT16
1
FALSE
"Month"
0x74494d45
Leaf
UINT8
1
FALSE
"Day"
0x74494d45
Leaf
UINT8
1
FALSE
"Hour"
0x74494d45
Leaf
UINT8
1
FALSE
"Minute"
0x74494d45
Leaf
UINT8
1
FALSE
"Second"
0x74494d45
Leaf
UINT8
1
FALSE

Text chunk metadata

PNG level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"tEXt"
0x74455874
Tree

Text chunk level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"Keyword"
0x74455874
Leaf
STRING
Variable
FALSE
"Text"
0x74455874
Leaf
STRING
Variable
FALSE

Compressed textual data chunk metadata

PNG level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"zTXt"
0x7a545874
Tree

Compressed textual data chunk level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"Keyword"
0x7a545874
Leaf
STRING
Variable
FALSE
"CompressionMethod"
0x7a545874
Leaf
UINT8
1
FALSE
"Text"
0x7a545874
Leaf
STRING
Variable
FALSE

International textual data chunk metadata

PNG level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"zTXt"
0x69545874
Tree

International textual data chunk level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"Keyword"
0x69545874
Leaf
STRING
Variable
FALSE
"CompressionFlag"
0x69545874
Leaf
BOOL
"CompressionMethod"
0x69545874
Leaf
UINT8
1
FALSE
"LanguageTag"
0x69545874
Leaf
STRING
"TranslatedKeyword"
0x69545874
Leaf
RAW_DATA
"Text"
0x69545874
Leaf
RAW_DATA
Variable
FALSE

Calibration of pixel values chunk metadata

PNG level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"pCAL"
0x7043414c
Tree

Calibration of pixel values chunk level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"CalibrationName"
0x7043414c
Leaf
STRING
Variable
FALSE
"OriginalZero(x0)"
0x7043414c
Leaf
INT32
1
FALSE
"OriginalMax(x1)"
0x7043414c
Leaf
INT32
1
FALSE
"EquationType"
0x7043414c
Leaf
UINT8
1
FALSE
"NumberOfParameters"
0x7043414c
Leaf
UINT8
<N>
Variable
FALSE
"UnitName"
0x7043414c
Leaf
STRING
Variable
FALSE
"CalibrationParameter"
0
Leaf
STRING
Variable
FALSE
...
"CalibrationParameter"
<N> - 1
Leaf
STRING
Variable
FALSE

Physical scale chunk metadata

PNG level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"sCAL"
0x7343414c
Tree

Physical scale chunk level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"UnitSpecifier"
0x7343414c
Leaf
UINT8
1
FALSE
"PixelWidth"
0x7343414c
Leaf
STRING
Variable
FALSE
"PixelHeigt"
0x7343414c
Leaf
STRING
Variable
FALSE

GIF application extension chunk metadata

PNG level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"gIFx"
0x67494678
Tree

GIF application extension chunk level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"ApplicationIdentifier"
0x67494678
Leaf
STRING
Variable
FALSE
"AuthenticationCode"
0x67494678
Leaf
UINT8
1
FALSE
"ApplicationData"
0x67494678
Leaf
RAW_DATA
Variable
FALSE

GIF Graphic Control Extension chunk metadata

PNG level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"gIFg"
0x67494674
Tree

GIF Graphic Control Extension chunk level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"DisposalMethod"
0x67494674
Leaf
UINT8
1
FALSE
"UserInputFlag"
0x67494674
Leaf
UINT8
1
FALSE
"DelayTime"
0x67494674
Leaf
UINT16
1
FALSE

Image offset chunk metadata

PNG level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"oFFs"
0x6f464673
Tree

Image offset chunk level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"XPosition"
0x6f464673
Leaf
UINT32
1
FALSE
"YPosition"
0x6f464673
Leaf
UINT32
1
FALSE
"UnitSpecifier"
0x6f464673
Leaf
UINT8
1
FALSE

The rest chunk metadata

The rest chunk data are passed as raw data

PNG level

Name
Id
Type
Value Type
Value
Value Length
Read Only
<Chunk Name>
<Chunk ID>
Leaf
RAW_DATA
Variable
FALSE

<Chunk Name> is a string representation of the chunk type value.

<Chunk ID> is a binary representation of the chunk type value.


GIF Non-image Data Structure

GIF file format is complex and has different non-image data that can be stored before and after an image data. The GIF metadata design allows you to read/write any GIF non-image data and prevents from misunderstanding with GIF extensions storing order.

The following metadata are always saved before an image data:

  • GIF Logical Screen Descriptor metadata level
  • GIF Image Descriptor metadata level
  • GIF Global Color Table metadata level
  • GIF Local Color Table metadata level

All other GIF Extensions Metadata are saved before an image data.

ImageGear represents simpler GIF metadata by single metadata items, and more complex metadata by subtrees. Thus, there are two main GIF metadata levels in ImageGear:

  • GIF metadata level
  • GIF Extensions Metadata

GIF metadata level

Name
Id
Type
Value Type
Value
Value Length
Read Only
GIF header level
GIF Logical Screen Descriptor level
GIF Image Descriptor level
optional Global and/or Local Color Tables and
optional GIF Extensions levels (extensions before image)

GIF header metadata

GIF metadata level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"GIFHeader"
0x10
Tree
0
NULL
0
TRUE

GIF header level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"Signature"
0x101
Leaf
STRING
"GIF"
3
TRUE
"Version"
0x102
Leaf
STRING
3
TRUE

GIF Logical Screen Descriptor metadata

GIF metadata level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"LogicalScreenDescriptor"
0x20
Tree

GIF Logical Screen Descriptor level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"LogicalScreenWidth"
0x201
Leaf
UINT16
1
FALSE
"LogicalScreenHeight"
0x202
Leaf
UINT16
1
FALSE
"Fields"
0x205
Tree
"GlobalColorTableFlag"
0x206
Leaf
BOOL
1
FALSE
"ColorResolution"
0x207
Leaf
UINT8
1
FALSE
"SortFlag"
0x208
Leaf
BOOL
1
FALSE
"GlobalColorTableSize"
0x209
Leaf
UINT8
1
FALSE
"Fields"
0x205
Tree
"BackgroundColorIndex"
0x203
Leaf
UINT8
FALSE
"PixelAspectRatio"
0x204
Leaf
UINT8
FALSE

GIF Global Color Table metadata

Name
Id
Type
Value Type
Value
Value Length
Read Only
"GlobalColorTable"
0x30
Leaf
RAW_DATA
Variable
TRUE

GIF Image Descriptor metadata

GIF metadata level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"ImageDescriptor"
0x2C
Tree

GIF Image Descriptor level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"ImageLeftPosi tion"
0x2C1
Leaf
UINT16
1
FALSE
"ImageTopPosition"
0x2C2
Leaf
UINT16
1
FALSE
"ImageWidth"
0x2C3
Leaf
1
FALSE
"ImageHeight"
0x2C4
Leaf
1
FALSE
"Fields"
0x2C5
Tree

GIF Image Descriptor Fields level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"LocalColorTableFlag"
0x2C6
Leaf
BOOL
1
FALSE
"InterlaceFlag"
0x2C7
Leaf
BOOL
1
FALSE
"SortFlag"
0x2C8
Leaf
BOOL
1
FALSE
"LocalColorTableSize"
0x2C9
Leaf
UINT8
1
FALSE

GIF Local Color Table metadata

Name
Id
Type
Value Type
Value
Value Length
Read Only
"LocalColorTable"
0x40
Leaf
RAW_DATA
Variable
TRUE

GIF Extensions Metadata

GIF Graphic Control Extension metadata

GIF metadata level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"GraphicControlExtension"
0xF9
Tree

GIF Graphic Control Extension level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"Fields"
0xF91
Tree
"DisposalMethod"
0xF92
Leaf
UINT8
1
FALSE
"UserInputFlag"
0xF93
Leaf
BOOL
1
FALSE
"TransparentColorFlag"
0xF94
Leaf
BOOL
1
FALSE
"Fields"
0xF91
Tree
"DelayTime"
0xF95
Leaf
UINT16
1
FALSE
"TransparentColorIndex"
0xF96
Leaf
UINT8
1
FALSE

GIF Comment Extension metadata

Name
Id
Type
Value Type
Value
Value Length
Read Only
"CommentExtension"
0xFE
Leaf
STRING
Variable
TRUE

GIF Application Extension metadata

GIF metadata level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"ApplicationExtension"
0xFF
Tree

GIF Application Extension level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"ApplicationIdentifier"
0xFF1
Leaf
STRING
8
FALSE
"Appl.AuthenticationCode"
0xFF2
Leaf
UINT8
4
FALSE
"ApplicationData"
0xFF3
Leaf
RAW_DATA
Variable
FALSE

GIF Plain Text Extension metadata

GIF metadata level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"PlainTextExtension"
0x01
Tree
0
NULL
0
TRUE

GIF Plain Text Extension level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"TextGridLeftPosition"
0x11
Leaf
UINT16
1
FALSE
"TextGridTopPosition"
0x12
Leaf
UINT16
1
FALSE
"TextGridWidth"
0x13
Leaf
UINT16
1
FALSE
"TextGridHeight"
0x14
Leaf
UINT16
1
FALSE
"CharacterCellWidth"
0x15
Leaf
UINT8
1
FALSE
"CharacterCellHeight"
0x16
Leaf
UINT8
1
FALSE
"TextForegroundColorIndex"
0x17
Leaf
UINT8
1
FALSE
"TextBackgroundColorIndex"
0x18
Leaf
UINT8
1
FALSE
"PlainTextData"
0x19
Leaf
STRING
Variable
FALSE

GIF Extensions After Image metadata

GIF metadata level

Name
Id
Type
Value Type
Value
Value Length
Read Only
"AfterImageExtensions"
0xFFF
Tree

GIF Extensions After Image level

Name
Id
Type
Value Type
Value
Value Length
Read Only
One or more GIF extension levels


DICOM Non-Image Data Structure

DICOM files contain one header and zero, one or several image pages. Image header applies to all pages in the image. ImageGear.Net loads the same metadata tree for each page in the image, and attaches this tree to the corresponding page. ImageGear for .NET does not put any tags to document level metadata for DICOM images.

DICOM Metadata root level

Name
Id
Type
Value Type
Value
Value Length
Read Only
Preamble
Preamble
Leaf
Byte[]
128
No
MetaInfoHeader
MetaInfoHeader
Tree
DataSet
DataSet
Tree

MetaInfoHeader level

Name
Id
Type
Value Type
Value
Value Length
Read Only
<tag name>
<tag id>
Leaf

DataSet may contain subtrees, corresponding to DICOM tags that have "Sequence" (SQ) type. Sequences can non contain normal tags (leafs). Instead, each Sequence contains one or more "Items". Items can contain normal tags including Sequences. All items within one Sequence must have the same set of tags, but tag values can be different.

DataSet level

Name
Id
Type
Value Type
Value
Value Length
Read Only
<tag name>
<tag id>
Leaf
...
<SQ tag name>
<SQ tag id>
Tree
...

Sequence level

Name
Id
Type
Value Type
Value
Value Length
Read Only
Item
Item
Tree
...

Item level

Name
Id
Type
Value Type
Value
Value Length
Read Only
<tag name>
<tag id>
Leaf
...
<SQ tag name>
<SQ tag id>
Tree
...

When ImageGear saves images, it overwrites the following tags:

Id
Location
Type
FileMetaInformationVersion
MetaInfoHeader
Leaf
TransferSyntaxUID
MetaInfoHeader
Leaf
SamplesPerPixel
DataSet
Leaf
PhotometricInterpretation
DataSet
Leaf
Rows
DataSet
Leaf
Columns
DataSet
Leaf
BitsAllocated
DataSet
Leaf
BitsStored
DataSet
Leaf
HighBit
DataSet
Leaf
PixelRepresentation
DataSet
Leaf
PlanarConfiguration
DataSet
Leaf
Red Palette Color Look Up Table Descriptor
DataSet
Leaf
Green Palette Color Look Up Table Descriptor
DataSet
Leaf
Blue Palette Color Look Up Table Descriptor
DataSet
Leaf
Red Palette Color Look Up Table Data
DataSet
Leaf
Green Palette Color Look Up Table Data
DataSet
Leaf
Blue Palette Color Look Up Table Data
DataSet
Leaf
PixelData
DataSet
Leaf


Camera Raw Non-Image Data Structure

Camera Raw image metadata structure consists of three sections, which are represented by subtrees:

  • Common section
  • Format-specific level
  • Statistics

Common section

The Common sub-tree contains values that are common or useful for all raw files.

All values in the Common sub-tree have Type = VALUE_ITEM and are Read Only.

Name
Id
Native Type
Value count
Description
ImageWidth
ImGearDCRAWTagIDs.IMAGEWIDTH
UINT32
1
Image width after that masked pixels were trimmed out
ImageHeight
ImGearDCRAWTagIDs.IMAGEHEIGHT
UINT32
1
Image height after that masked pixels were trimmed out
BitsPerSample
ImGearDCRAWTagIDs.BITSPERSAMPLE
UINT32
1..3
Bits per sample in the original raw image (before reconstruction)
PhotometricInterpretation
ImGearDCRAWTagIDs.PHOTOMETRICINTERPRETATION
UINT32
1
Photometric interpretation of the original raw image
RawLeft
ImGearDCRAWTagIDs.RAWLEFT
UINT32
1
X coordinate of first column of non-masked pixels
RawTop
ImGearDCRAWTagIDs.RAWTOP
UINT32
1
Y coordinate of first row of non-masked pixels
RawWidth
ImGearDCRAWTagIDs.RAWWIDTH
UINT32
1
Raw Image Width, including masked pixels
RawHeight
ImGearDCRAWTagIDs.RAWHEIGHT
UINT32
1
Raw Image Height, including masked pixels
ColorPlanes
ImGearDCRAWTagIDs.COLORPLANES
UINT32
1
Number of colors in the CFA pattern
SamplesPerPixel
ImGearDCRAWTagIDs.SAMPLESPERPIXEL
UINT32
1
Number of samples per pixel in the original image, before reconstruction
Make
ImGearDCRAWTagIDs.MAKE
STRING
1
Name of the camera manufacturer
Model
ImGearDCRAWTagIDs.MODEL
STRING
1
Name of the camera model
UniqueCameraModel
ImGearDCRAWTagIDs.UNIQUECAMERAMODEL
STRING
1
Unique, non-localized name for the camera model that created the image in the raw file.
TimeStamp
ImGearDCRAWTagIDs.TIMESTAMP
STRING
1
Time stamp
CFARepeatPatternDim
ImGearDCRAWTagIDs.CFAREPEATPATTERNDIM
UINT16
2
This tag encodes the number of pixels horizontally and vertically that are needed to uniquely define the repeat pattern of the color filter array.
CFAPattern
ImGearDCRAWTagIDs.CFAPATTERN
INT8
CFARepeatPatternDim[0] * CFARepeatPatternDim[1]
This tag encodes the actual color filter array geometric pattern of the image sensor used to capture the single sensor color image.
AsShotNeutral
ImGearDCRAWTagIDs.ASSHOTNEUTRAL
RATIONAL_INT32
ColorPlanes
Specifies the selected white balance at time of capture, encoded as the coordinates of a perfectly neutral color in linear reference space values.
WhiteLevel
ImGearDCRAWTagIDs.WHITELEVEL
RATIONAL_INT32
1
Image pixel value that corresponds to fully saturated encoding level.
CalibrationIlluminant1
ImGearDCRAWTagIDs.CALIBRATIONILLUMINANT1
UINT16
1
The illuminant used for ColorMatrix1 color conversion matrix. Allowed values are the same as allowed values for LightSource EXIF tag (see Exif specification).
CalibrationIlluminant2
ImGearDCRAWTagIDs.CALIBRATIONILLUMINANT1
UINT16
1
The illuminant used for ColorMatrix2 color conversion matrix. Allowed values are the same as allowed values for LightSource EXIF tag (see Exif specification).
ColorMatrix1
ImGearDCRAWTagIDs.COLORMATRIX1
RATIONAL_INT32
ColorPlanes * 3
Conversion matrix from XYZ to camera color space, for illuminant specified by CalibrationIlluminant1 tag. Matrix is stored in row scan order.
ColorMatrix2
ImGearDCRAWTagIDs.COLORMATRIX2
RATIONAL_INT32
ColorPlanes * 3
Conversion matrix from XYZ to camera color space, for illuminant specified by CalibrationIlluminant2 tag. Matrix is stored in row scan order.
BaselineExposure
ImGearDCRAWTagIDs.BASELINEEXPOSURE
RATIONAL_INT32
1
Specifies baseline exposure of the camera, in EV units. Application may use this value to adjust exposure compensation for particular camera model.

Format-specific level

This level includes format-specific metadata that is found in the image (EXIF, TIFF or CIFF). See corresponding sections for structure of metadata for these formats.

Statistics

This section contains data which is collected during image loading, rather than obtained from image's header or metadata. ImGearFileFormats.LoadPage creates this section, but ImGearFileFormats.LoadPageHeader does not, because it does not load pixel data.

For some cameras ImageGear uses predefined values for BlackLevel, so they are not calculated from pixel data. In this case, ImageGear also places BlackLevel tag to Statistics section, rather than in Common section, for uniformity reasons.

The following tags can be present in the Statistics section:

Name
ID
Native Type
Value Count
Description
BlackLevelRepeatDim
ImGearDCRAWTagIDs.BLACKLEVELREPEATDIM
UINT16
2
This tag specifies repeat pattern size for the "BlackLevel" tag.
BlackLevel
ImGearDCRAWTagIDs.BLACKLEVEL
UINT32
BlackLevelRepeatDim[0] * BlackLevelRepeatDim[1]
This tag specifies the zero light (a.k.a. thermal black or black current) encoding level. It is calculated during image loading by averaging pixel values in the masked areas of the image.


CIFF Non-Image Data Structure

CIFF metadata uses multiple nested IFDs, structured as a tree.

Brief information on CIFF metadata levels is provided in the set of tables below.

CIFF level

Name
Id
Type
ImageProps level
ImGearCIFFTagIDs.IMAGE_PROPS
Tree
CIFF root tags
<Tag ID>
Leaf

ImageProps level

Name
Id
Type
ImageInfo level
ImGearCIFFTagIDs.IMAGE_INFO
Tree
ImageDescription level
ImGearCIFFTagIDs.IMAGE_DESCRIPTION
Tree
CameraObject level
ImGearCIFFTagIDs.CAMERA_OBJECT
Tree
ShootingRecord level
ImGearCIFFTagIDs.SHOOTING_RECORD
Tree
MeasuredInfo level
ImGearCIFFTagIDs.MEASURED_INFO
Tree
ExifInformation level
ImGearCIFFTagIDs.EXIF_INFORMATION
Tree
ImageProps tags
<Tag ID>
Leaf

ImageInfo level

Name
Id
Type
ImageInfo tags
<Tag ID>
Leaf

ImageDescription level

Name
Id
Type
ImageDescription tags
<Tag ID>
Leaf

CameraObject level

Name
Id
Type
CameraSpecification level
ImGearCIFFTagIDs.CAMERA_SPECIFICATION
Tree
CameraObject tags
<Tag ID>
Leaf

ShootingRecord level

Name
Id
Type
ShootingRecord tags
<Tag ID>
Leaf

MeasuredInfo level

Name
Id
Type
MeasuredInfo tags
<Tag ID>
Leaf

ExifInformation level

Name
Id
Type
FocalLength level
ImGearCIFFTagIDs.FOCAL_LENGTH
Tree
CanonShotInfo level
ImGearCIFFTagIDs.CANON_SHOT_INFO
Tree
CanonCameraSettings level
ImGearCIFFTagIDs.CANON_CAMERA_SETTINGS
Tree
SensorInfo level
ImGearCIFFTagIDs.SENSOR_INFO
Tree
CanonCustomFunctions level
ImGearCIFFTagIDs.CANON_CUSTOM_FUNCTIONS
Tree
CanonPictureInfo level
ImGearCIFFTagIDs.CANON_PICTURE_INFO
Tree
ExifInformation tags
<Tag ID>
Leaf

CameraSpecification level

Name
Id
Type
CameraSpecification tags
<Tag ID>
Leaf

FocalLength level

Name
Id
Type
FocalLength tags
<Tag ID>
Leaf

CanonShotInfo level

Name
Id
Type
CanonShotInfo tags
<Tag ID>
Leaf

CanonCameraSettings level

Name
Id
Type
CanonCameraSettings tags
<Tag ID>
Leaf

SensorInfo level

Name
Id
Type
SensorInfo tags
<Tag ID>
Leaf

CanonCustomFunctions level

Name
Id
Type
CanonCustomFunctions tags
<Tag ID>
Leaf

CanonPictureInfo level

Name
Id
Type
CanonPictureInfo tags
<Tag ID>
Leaf


XMP Non-Image Data Structure

XMP Root level

Name
Id
Type
Level Type
Value Type
<Schema namespace URI 1>
ImGearXMPTagIDs.Description
Tree
XMP Schema
N/A
<Schema namespace URI 1>
ImGearXMPTagIDs.Description
Tree
XMP Schema
N/A
...

XMP Schema level

Name
Id
Type
Level Type
Value Type
About
ImGearXMPTagIDs.About
Leaf
N/A
String
Namespace
ImGearXMPCommonTagIDs. Namespace
Tree
XMP Namespace
N/A
Namespace URI
ImGearXMPCommonTagIDs.NamespaceURI
Leaf
N/A
String
Properties
ImGearXMPCommonTagIDs.Properties
Tree
XMP Property Collection
N/A

XMP Namespace level

Name
Id
Type
Level Type
Value Type
Prefix
ImGearXMPTagIDs.Prefix
Leaf
N/A
String
URI
ImGearXMPTagIDs.URI
Leaf
N/A
String

XMP Property Collection level

Name
Id
Type
Level Type
Value Type
<Property 1 name>
ImGearXMPTagIDs.Property
Tree
XMP Simple Property / XMP Array / XMP Structure
N/A
<Property 2 name>
ImGearXMPTagIDs.Property
Tree
XMP Simple Property, XMP Array/Structure property
N/A
...

XMP Simple Property level

Name
Id
Type
Level Type
Value Type
Value
ImGearXMPropertyTagIDs.Value
Leaf
N/A
<Value type>
Qualifiers
ImGearXMPropertyTagIDs.Qualifiers
Tree
XMP Qualifiers collection
N/A

XMP Array level

Name
Id
Type
Level Type
Value Type
Bag / Seq / Alt
ImGearXMPropertyTagIDs.Bag / ImGearXMPropertyTagIDs.Seq / ImGearXMPropertyTagIDs.Alt
Tree
XMP Array items level
N/A

XMP Array Items level

Name
Id
Type
Level Type
Value Type
Item
ImGearXMPropertyTagIDs.Item
Tree
XMP Simple Property / XMP Language Alternative Property / XMP Structure
<N/A>
Item
ImGearXMPropertyTagIDs.Item
Tree
XMP Simple Property / XMP Language Alternative Property / XMP Structure
<N/A>
...

XMP Language Alternative Property level

Name
Id
Type
Level Type
Value Type
Value
ImGearXMPropertyTagIDs.Value
Leaf
N/A
<Value type>
Lang
ImGearXMPropertyTagIDs.Lang
Leaf
N/A
String

XMP Structure level

Name
Id
Type
Level Type
Value Type
Struct
ImGearXMPropertyTagIDs.Struct
Tree
XMP Structure items level
N/A

XMP Structure Items level

Name
Id
Type
Level Type
Value Type
<Field 1 name 1>
ImGearXMPropertyTagIDs.Property
Tree
XMP Simple Property
<N/A>
<Field 2 name>
ImGearXMPropertyTagIDs. Property
Tree
XMP Simple Property
<N/A>
...

XMP Qualifiers level

Name
Id
Type
Level Type
Value Type
<Qualifier 1 name>
ImGearXMPropertyTagIDs. Qualifier
Tree
XMP Qualifier
<N/A>
<Qualifier 2 name>
ImGearXMPropertyTagIDs. Qualifier
Tree
XMP Qualifier
<N/A>
...

XMP Qualifier level

Name
Id
Type
Level Type
Value Type
Value
ImGearXMPCommonTagIDs.
Value
Leaf
N/A
<Value type>