What is The ImagXpress Product Family?

ImagXpress® Version 9 is Pegasus Imaging Corporation’s comprehensive image processing toolkit designed for document imaging, medical imaging, and photo imaging application development. The ImagXpress v9 Product Family includes the following Components:

  • ImagXpress v9 – image compression, decompression, viewing, and processing
  • NotateXpress™ v9 – image annotation support
  • ThumbnailXpress™ v2 – thumbnail image support
  • TwainPRO™ v5 – TWAIN image acquisition support
  • PrintPRO™ v4 – image printing support

ImagXpress Editions: The components within the ImagXpress v9 Product Family are available in four editions, designed to meet specific imaging needs:

  • Photo: includes ImagXpress, NotateXpress, TwainPRO, PrintPRO, and ThumbnailXpress
  • Document: includes ImagXpress, NotateXpress, TwainPRO, PrintPRO, and ThumbnailXpress
  • View: Includes ImagXpress, NotateXpress, PrintPRO, and ThumbnailXpress
  • Standard: Includes ImagXpress and TwainPRO

Additional Pegasus Imaging Components: Additional components are available for purchase separately, and integrate easily with to provide a comprehensive imaging solution:

  • PDFXpress™ – PDF creation, viewing, and annotating
  • OCRXpress™ – full page OCR
  • Barcode Xpress™ – recognize barcodes
  • ScanFix Xpress™ – advanced image cleanup
  • FormFix™ – form ID, dropout, and OMR
  • SmartZone™ ICR / OCR – character recognition

See www.PegasusImaging.com for product packaging and sales information.

See Also

Getting Support and Samples | License Agreement | Operating Requirements

© 2008, Pegasus Imaging Corporation, All Rights Reserved.


What is the ImagXpress Component?

The ImagXpress® Version 9 Component is the flagship of the ImagXpress v9 Product Family, offering the core imaging functionality of compression, decompression, viewing, and processing.

New Features in Version 9 of the Component Include:

Additional File Format Support

  • AutoCAD 2000 - DWG, DXF, DXB, DWF
  • HD Photo (JPEG XR) - HDP, WDP
  • More Camera RAW Formats
  • PTOCA – IBM’s AFP format with Presentation Text
  • ABIC– IBM compression format for check images
  • IPTC metadata support within TIFF and JPEG files
  • TIFF with intrinsic orientation (the file itself contains a rotation angle that can be interpreted during display)
  • JPEG 2000 images within PDFs
  • Compress to PSNR value in JPEG 2000 (to specify the amount of compression by quality rather than by target file size)
  • JPEG 2000 multithreading support for faster compression & decompression

Included in the Component, Previously Available Only as Add-ons

ImagXpress licensing has been simplified. File formats that were previously available only with add-on licensing are now available as part of the component. See www.PegasusImaging.com for more information on formats supported in each edition. File formats include:

  • JPEG2000,
  • JPEGLS,
  • Lossless JPEG,
  • JBIG2, and
  • WSQ

Improved Rendering

  • Enhanced ability to load and process large images and files
  • Improved viewing of large PDF or CAD images

Query from Memory

  • Query image data (e.g. tags) from memory buffer or IO.Stream without loading the entire image
  • Save image data (e.g. tags) to memory buffer or IO.Stream without saving the entire image

Improved Unicode Support

  • File names
  • Text

New User Interface Features

  • Smooth scroll
  • Mouse wheel support
  • Custom cursors


Getting Support and Samples

Benefits of Registering your Development Kit

Purchasers of development kits need to register with Pegasus in order to be notified of updates and receive support now or in the future. Registration is automatic when purchased directly from the Pegasus web site. If purchased through a Pegasus re-seller, please register your purchase by filling out the form at www.PegasusImaging.com/registration.htm.

Vehicles for Support

Samples

Samples are included in the downloaded installation.

The product installation program installs a common sample folder accessible via the Start Menu.

Samples for the .NET framework:

  • Microsoft VisualBasic.Net
  • Microsoft C#

Access the Samples

  • Through the Windows Start menu: Start | Programs | Pegasus Imaging | ImagXpress 9.0 | Samples
  • Sample image files install in your Program Files directory: Pegasus Imaging\Common\Images

Sample Newsgroups

Customers create samples of great benefit to other developers, so we created a Sample Code Newsgroup. This is a newsgroup for our customers and potential customers. They post and receive sample code from our development team and other developers to expedite their development. Go online at: www.PegasusImaging.com/samplecode.htm

Web Support

Visit the Pegasus Imaging web site frequently asked questions page www.PegasusImaging.com/faq.htm for the fastest answers to common questions. The web site also provides other support options that are accessible at www.PegasusImaging.com/supportagree.htm.

E-mail Support

Both pre-sale and post-sale e-mail support is offered free of charge. Questions are answered on a First-Come-First-Served basis. Support@JPG.com responds instantly to e-mail received with a helpful set of locations to find additional information on Pegasus products including FAQ's, sample code, newsgroup locations and other current information pertaining to the use of the products. The support request is then added to the queue of outstanding requests. The goal of the support team to respond to each e-mail within 1 business day.

The sales team is always available as a backup to the support team. If you feel you have an urgent support or sales issue please contact Sales@JPG.com . They will assist you promptly.

Newsgroup Support

The Publicly accessible NNTP news groups located at News.PegasusImaging.com are available for each of the Controls as well as advanced imaging technology and a sample code group. We expect that the development community will freely access and search these newsgroups to find common questions and answers regarding specific uses of the controls.

On-Demand Phone Support

On-demand priority phone support can be purchased in 15 minute increments with a credit card via the Pegasus Imaging Corporation web site Support, General Info page. If you decide to purchase "on-demand" phone support, instructions will immediately be e-mailed upon receipt of your purchase.

Additionally, Pegasus offers three support plans for those customers whose commercial products or projects are sensitive or critical in nature, where immediate response and 'latest release' code are important.

1. Chariot Support

All Pegasus Imaging customers are given the opportunity to purchase a Chariot Support agreement. This is a maintenance and upgrade agreement that entitles customers to priority e-mail service, direct phone support from the support and development staff and free product upgrades for the covered products. Since upgrades are included for Chariot customers at no additional charge, Chariot customers can frequently save money, plus obtain the benefits of phone and expedited support. Pegasus Imaging reserves the right to change the terms of this service at any renewal period. Contact Sales via the web at www.PegausImaging.com/contactform.htm.

2. Galleon Support

Customers are given the opportunity to purchase Galleon Support for Pegasus Imaging products that are applications and for products that require Run Time licensing. Galleon Support includes licensing of product upgrades for deployed installations at no additional license fee cost.Pegasus Imaging reserves the right to change the terms of this service at any renewal period. Contact Sales via the web at www.PegausImaging.com/contactform.htm.

3. Atlas Support

All Pegasus Imaging customers are given the opportunity to purchase an Atlas Support agreement on currently supported products. This is an agreement that entitles customers to priority e-mail service and direct phone support from the support and development staff. It differs from Chariot Support in that it does not include version upgrades free of charge. Pegasus Imaging reserves the right to change the terms of this service at any renewal period. Contact Sales via the web at www.PegausImaging.com/contactform.htm.

For the latest and most up-to-date support information, access www.PegasusImaging.com/contact.htm

See Also

Operating Requirements | Trial Mode | Installing on a Development Machine


Pegasus Imaging Corporation

Pegasus Imaging is uniquely positioned to serve as your leading imaging technology supplier. A full suite of document imaging toolkits, forms processing technology, medical image compression SDKs, photo editing and compression libraries, browser-based image viewers, and video codecs provide advanced technology designed to enhance imaging software solutions. Fully functional trial downloads and customer-acclaimed support allow you to be certain your requirements will be met before purchase. Work with the best. Choose Pegasus Imaging for all your imaging needs.

Visit www.PegasusImaging.com for full product descriptions, FAQ's, downloads, demos, and contact information.

Pegasus Imaging

4001 North Riverside Drive

Tampa, FL 33603

Sales: 813-875-7575

Copyrights & Trademarks

Pegasus and the Pegasus Horse Logo are registered marks (®) of Pegasus Imaging Corporation.

Barcode Xpress, CapturePRO, FilePrinter, FormAssist, FormDirector, FormSuite, ISIS Xpress, The JPEG Wizard, MedXpress, NotateXpress, OCR Xpress, PDF Xpress, PICTools, ePIC, PICVideo, PrintPRO, SmartScan Xpress, SmartZone, ThumbnailXpress, and TwainPRO are trademarks (™) of Pegasus Imaging Corporation.

ImagXpress, FormFix, ScanFix, Prizm, ColorDrop, ColorEnhance, ColorFind, ColorForms, CompressDirector, Digital Mark Recognition (DMR), Image Detergent, ViewDirector and Virtual Scoring Center (VSC) by assignment are trademarks (™) or registered trademarks (®) of Pegasus Imaging Corporation.

Pegasus Imaging and/or its agents use these marks and brand names in connection with its goods and/or services, in the United States and other countries. Information in this document is subject to change without notice. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Pegasus Imaging Corporation.

Microsoft, Microsoft.NET, Visual Basic, Visual Studio and Visual Studio.NET are trademarks of Microsoft Corporation in the USA and/or other countries. All other product and brand names are the property of their respective owners.

See Also

What is the ImagXpress Component? | What is The ImagXpress Product Family?


Operating Requirements

Operating Systems

ImagXpress® runs on 32-bit Microsoft Windows operating systems: Vista, 2000 Professional and Server, XP Home and Professional, Server 2003 and Server 2008. It works with 32-bit Windows versions running on 32 and 64-bit processors. It runs in 32-bit executables running under 64-bit Windows 2000 Server, 2003 Server and Windows Server 2008.

Threading

ImagXpress is a synchronous or asynchronous multi-threaded control.

Development Environment

Microsoft .NET Framework 2.0, 3.0

Microsoft Visual Studio 2005

Microsoft Visual Studio 2008

See Also

Getting Support and Samples | Installing on a Development Machine | Run Time Licensing


Installing on a Development Machine

To Install ImagXpress® Component

Run the downloaded setup program which installs the development kit on your development machine.

The downloaded development kit includes code samples for supported platforms. Samples are available through the Start|Programs|Pegasus Imaging|ImagXpress menu.

By default this will register trial licensing which allows you to develop applications but not to distribute them. The trial license allows testing of all the functions and features.

Please see the section 'Distributing Applications and Deployment' to understand the limits and details to convert licensing editions.
In order to distribute your finished application you must purchase and install a fully paid license from Pegasus Imaging Corporation. The paid licenses override trial licenses.

To Use ImagXpress Help Files

Stand-alone Help file "PegasusImaging.WinForms.ImagXpress9.chm"

Access the ImagXpress stand-alone help through the Windows Start menu: Start | Programs | Pegasus Imaging | ImagXpress 9.0

The stand-alone file is created with MS Help system version 1. To view stand-alone help files, you must have:

  • Windows 2000 or higher (to view the file via the Windows HTML Help Viewer)
  • Internet Explorer 6.0 or higher
  • MS HTML Help Viewer

From within your Visual Studio Development Environment, Compiled Collection Help File "PegasusImaging.WinForms.ImagXpress9.hxs"

Help 2 collection files install into Visual Studio.NET (VS). To view Help 2 files, you must have:

  • Windows 2000 or higher
  • Internet Explorer 6.0 or higher
  • Visual Studio .NET 2002 or higher
  • MS Help version 2

When ImagXpress installs, if the system installation requirements for Help 2 files are met, the Help 2 file is included on the Start shortcut menu. If the installation requirements for Help 2 files are not met, then the Help 1 file installs on the Start shortcut.

Plugging ImagXpress Help into Visual Studio

ImagXpress Help 2 files integrate within the Help system in Visual Studio .NET. To access ImagXpress Help within Visual Studio, do the following:

  • Ensure that the MSDN Library is installed in your Visual Studio environment. If it is not installed, re-install it from your VS.NET disc.
  • Ensure that MS Help Integration Kit is installed in your Visual Studio environment. If you do not have it installed:

1. Download the Help Integration kit from MSDN

2. Close Visual Studio.

  • Re-open Visual Studio, select the Help Menu and the Contents submenu. Verify Help files for Pegasus Imaging controls are listed.

If Pegasus Help is not listed:

  1. Search for "VSCC" in Visual Studio Help, leaving the "Filtered by:" list box blank. Select the "Visual Studio .NET Combined Help Collection Manager" topic.
  2. Select the Help 2 collections available on your PC under the heading "Collections available for inclusion in VSCC."
  3. Take care when excluding Help collections from the default VSCC collection. These collections may be necessary to view required documentation. Instead, use the "Filtered by:" field on the Contents tab of the Help panel to focus searches on Pegasus Imaging topics. Leave the "Filtered by:" list box empty to view the entire Pegasus Imaging Help files.
  4. Select the Update VSCC button.
  5. Close all instances of Visual Studio and Microsoft Document Explorer. When you restart Visual Studio, the VSCC Help collection revises with your changes. (Note: this may take several minutes.)
  6. Check the Visual Studio Help/Contents tab again to see the Help collections available to you.
  • Select the ImagXpress Help file to view Help content.
See Also

Operating Requirements | Run Time Licensing | Development Mode | License Agreement | Distributing with Your .NET Application


Add ImagXpress to Your Project

Add ImagXpress® Functionality to Your Project

  1. Select an ImagXpress component from the toolbox and add to your project. The ImagXpress component manages licensing for the control and is required to enable all ImagXpress functionality. Add one and only one ImagXpress component to the project.
    You must have an ImagXpress component in your project to use ImagXpress v9. The ImagXpress component should be added before any other components in the ImagXpress family are added.
  2. Select an ImageXView component from the toolbox and add it to your project. The ImageXView component manages the interface to devices, such as monitors and printers and to other controls, such as NotateXpress™ and ThumbnailXpress™. ImageXView component is required to view, print, or annotate an image. Multiple ImageXView components can be added to the project to facilitate viewing and annotating multiple images, or multiple views of the same image.
  3. Select a Processor component from the toolbox and add it to your project. The Processor component manages all image processing. Multiple Processor components can be added to the project to facilitate parallel processing, within the constraints of your system.

Add Functionality from other Controls in the ImagXpress Family

  1. To enable annotation capability, add NotateXpress to your project. One NotateXpress component must be added for each ImageXView component in which annotation is required.
  2. To enable thumbnail capability, add ThumbnailXpress to your project. One ThumbnailXpress component must be added for each ImageXView component in which thumbnail capability is required.
  3. To enable TWAIN scanning, add TwainPRO™ to your project.
  4. To create a custom printer interface, add PrintPRO™ to your project.
See Also

Query Image Files


Trial Mode

Default Installation

The default installation installs Trial Mode licensing, which allows you to test features and functions and develop applications but not distribute them. Installing ImagXpress® in trial mode provides you with access to all features and functionality of the ImagXpress product family. E-mail support is available with the trial license.

When using the trial version of ImagXpress, an evaluation dialog box displays periodically.

Applications built with a trial license can only be run on a computer that has ImagXpress Licensing installed on it.

Changing Trial Mode Behavior

You have the flexibility to change the behavior of ImagXpress in evaluation mode as follows:

  • To facilitate server/service mode evaluations choose to permanently watermark every image written in lieu of displaying an evaluation dialog box periodically. This is the Watermark setting for the Licensing.EvaluationMode property.

Changing ImagXpress Edition

Downloading ImagXpress in Trial Mode enables you to try out all the editions associated with ImagXpress, by setting the Licensing.LicenseEditionChoice property. Any edition for which you do not have paid licensing will display the evaluation dialog box or watermark. For example, if you have paid licensing for the ImagXpress Standard and you would like to evaluate ImagXpress Document, you can change Licensing.LicenseEditionChoice property from Standard to Document and use the functionality of Document with evaluation dialog boxes displayed periodically.

See Also

Development Mode | Run Time Licensing | License Agreement | Getting Support and Samples


Development Mode

To suppress the evaluation dialog box and deploy your application, or attain technical support (beyond e-mail), as well as future product updates and upgrade notifications, you must update from a trial version to a paid version of the ImagXpress® development kit.

1. Purchase Development Kit(s)

To purchase licensing of the ImagXpress development kit, use one of the following options:

  • Purchase online at www.PegasusImaging.com.
  • Contact Sales via the web at www.PegausImaging.com/contactform.htm.
  • Contact a Pegasus Imaging Corporation reseller.

When the development kit is purchased, we e-mail a serial number & registration code to you. You need these codes to upgrade from trial to paid licensing.

2. Register the ImagXpress Product

When you purchase ImagXpress online or via Sales at www.PegasusImaging.com/contactform.htm, your product ownership is automatically registered.

To register products purchased through a reseller, use the form found at www.PegasusImaging.com/registration.htm.

See Getting Support and Samples for a discussion of benefits to providing your name to Pegasus Imaging. We never sell our customer information.

If your registration information should change, visit www.PegasusImaging.com/contact.htm for forms to update registration information.

3. Update Your ImagXpress Product Version from Trial to Paid Licensing

Updating your ImagXpress from trial to paid licensing will suppress the evaluation dialog box or watermark.

To Update Components from Trial to Paid Licensing:

  • Enter your new license codes using one of the following options:
    • Enter licensing information (serial number, registration code and personal registration information) during component installation while downloading the latest release from www.PegasusImaging.com (the recommended approach).
    • Alternatively, licensing information (serial number, registration code and personal registration information) can be entered through the Visual Development Environment in response to the dialog display.

For more information on Run Time licensing, see the Pegasus Imaging website for more detailed information regarding Run Times and Deployment Licensing.

See Also

Trial Mode | Run Time Licensing | License Agreement | Getting Support and Samples


Run Time Licensing

Run Time & Deployment Licensing

All copyrights to Pegasus Imaging development kits and software are retained by Pegasus Imaging Corporation. ALL RIGHTS RESERVED. Your use of any of Pegasus Imaging software or run-times created with Pegasus Imaging software is allowed under license terms granted by Pegasus Imaging. It is the Licensee's responsibility to honor the terms of such license grants.

Locking Mechanism

ImagXpress® contains a locking mechanism that does not permit you to distribute applications created with evaluation versions of ImagXpress. Prior to distributing an application that utilizes ImagXpress, you must purchase and enable run-time licensing. If the application will be delivered on the web, you must also enable web application licensing.

To Unlock Run Times

Unlock run times for the ImagXpress component first, then any other components included in your edition (e.g. ThumbnailXpress™, TwainPRO™, PrintPRO™).

Enable Run Time Licensing

Enable run-time licensing by calling UnlockRuntime when the application begins, and pass the 4 unlock codes as the parameters to the method. If you do not have the unlock codes please contact Sales via the web at www.PegasusImaging.com/contactform.htm.

Web

If deploying to a web application, enable Web Licensing by calling UnlockWeb when the application begins, supplying your web license string. If you do not have a web license string, please contact Sales via the web at www.PegasusImaging.com/contactform.htm.

Obtaining Appropriate Licensing

The Licensee is required to purchase one copy of our development kit(s) for each developer in addition to obtaining the appropriate license agreement prior to deploying applications which contain Pegasus code.

Pegasus Imaging software applications and development tools are limited for use on a single CPU. Any run times or copies created must be granted by a direct license from Pegasus Imaging Corporation. These "end user" licenses provide the terms and limits of number and usage.

All prospective customers have every opportunity to evaluate Pegasus Imaging's products prior to purchasing. Product licensing is priced to cover what is considered to be normal (and even high) use. In addition, Pegasus Imaging fully supports and warrants its code and pricing reflects those costs as well. The larger and more valuable an application deployment is, the higher the support and warranty risk is for Pegasus.

Review the licensing categories, and select the one that matches your deployment. Special circumstances should be discussed with a Pegasus Imaging representative.

For more information on Run Time licensing, see the Pegasus Imaging website for more detailed information regarding Run Times and Deployment Licensing.

See Also

www.PegasusImaging.com | Getting Support and Samples | Development Mode | License Agreement | Distributing with Your .NET Application


License Agreement

Pegasus Imaging Corporation

SOFTWARE LICENSE AGREEMENT

GRANT OF LICENSE

This Pegasus Imaging Corporation ("PEGASUS") Agreement ("License") permits Licensee ("LICENSEE") the right to use one copy of a properly registered Pegasus Development Toolkit ("TOOLKIT") for development purposes on any single computer, provided the TOOLKIT is in use on only one computer at any time. TOOLKIT is "in-use" on a computer when it loads into temporary memory (that is, RAM) or installed into the permanent memory (that is, hard disk, CD-ROM, or other storage device) of that computer.

REDISTRIBUTION OF THE TOOLKIT RUNTIMES

PEGASUS does NOT grant any Run Time licenses with the TOOLKIT purchase, except by specific exemptions described on our licensing web pages. For Run Time Licensing information, please visit our web site www.PegasusImaging.com/licensing.htm, or contact our sales staff. Any rights to distribute TOOLKIT run times as part of the LICENSEE's software application or derivative works ("PRODUCT"), require you to acknowledge and uphold this License Agreement and agree to notify PEGASUS immediately of any changes in status or violations. In cases where PEGASUS grants the LICENSEE a right to use, reproduce, display or otherwise distribute or transfer copies of TOOLKIT run times, LICENSEE agrees and affirms the following:

a) LICENSEE is not using PEGASUS' name, logo, or trademarks to market PRODUCT without prior written approval of PEGASUS.

b) LICENSEE agrees to indemnify, hold harmless and defend PEGASUS from and against any claims or lawsuits, including attorney's fees, that arise or result from the use or distribution of PRODUCT.

c) Only the TOOLKIT run times can be distributed. Distribution of the TOOLKIT development kit, documentation, source code, or the distribution unlock codes, is a violation of this agreement.

d) LICENSEE includes a statement substantially similar to the following within derivative work's documentation and about box: "This product contains portions of imaging code owned by Pegasus Imaging Corporation, Tampa, FL, (www.PegasusImaging.com). ALL RIGHTS RESERVED."

If ANY of the above terms are not applicable to LICENSEE's situation, or any of the above cannot be complied with, or LICENSEE needs modifications to this license, for any reason; then LICENSEE shall obtain an expanded direct license from PEGASUS for derivative works, (available by phone at: 813-875-7575, x321, by e-mail at: Sales@JPG.com.

PEGASUS reserves the right to charge the LICENSEE up to ten times the normal license price for the use of each unlicensed copy of PRODUCT. The license granted herein and all of your rights to use or maintain possession of TOOLKIT shall terminate immediately upon breach of any material provisions of this Agreement.

This license grants rights to LICENSEE for only the PEGASUS code (TOOLKIT) mentioned above and does not convey any other rights of use or distribution to PEGASUS technology.

COPYRIGHT

The Software is owned by PEGASUS or Pegasus Imaging Corporation and is protected by United States copyright laws and international treaty provisions. LICENSEE may not remove or alter the copyright notice from any copy of the Software or any copy of the written materials, accompanying the Software.

OTHER RESTRICTIONS

This PEGASUS License Agreement is LICENSEE's proof of license to exercise the rights granted herein and must be retained by LICENSEE. LICENSEE may not rent, lease or transfer TOOLKIT or parts thereof. LICENSEE may not reverse engineer, decompile or disassemble TOOLKIT.

NO WARRANTY

ANY USE BY LICENSEE OF THE SOFTWARE IS AT THE LICENSEE'S OWN RISK. THE SOFTWARE IS PROVIDED FOR USE ONLY WITH WINDOWS PRODUCTS AND RELATED APPLICATION SOFTWARE AND/OR HARDWARE PRODUCTS. THE SOFTWARE IS PROVIDED FOR USE "AS IS" WITHOUT WARRANTY OF ANY KIND. TO THE MAXIMUM EXTENT PERMITTED BY LAW, PEGASUS DISCLAIMS ALL WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. PEGASUS IS NOT OBLIGATED TO PROVIDE ANY UPDATES TO THE SOFTWARE.

NO LIABILITY FOR CONSEQUENTIAL DAMAGES

In no event shall PEGASUS be liable for any damages whatsoever (including, without limitation, incidental, direct, indirect and consequential damages, damages for loss of business profits, business interruption, loss of business information, or other pecuniary loss) arising out of the use or inability to use this PEGASUS product, even if PEGASUS has been advised of the possibility of such damages. Because some states/countries do not allow the exclusion or limitation of liability for consequential or incidental damages, the above limitation may not apply to LICENSEE.

INDEMNIFICATION BY LICENSEE

If LICENSEE distributes TOOLKIT in violation of this Agreement, LICENSEE agrees to indemnify, hold harmless and defend PEGASUS and its suppliers from and against any claims or lawsuits, including attorney's fees that arise or result from the use or distribution of TOOLKIT in violation of this Agreement.

This Agreement is governed by the laws of the State of Florida. The program and data contained in this TOOLKIT Product are provided with Restricted Rights. Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set forth in FAR 52.227-14 (Alternate III) or subparagraph (c)(1)(II) of the rights in technical data and computer software clause at 252.227-7013. Manufacturer is Pegasus Imaging Corporation, 4001 Riverside Drive, Tampa, FL, 33603.

For questions concerning this Agreement, or to contact PEGASUS for any reason, please contact Pegasus Imaging Corporation by phone 1-813-875-7575 x321 or e-mail Sales@JPG.com.

See Also

Trial Mode | Development Mode | Run Time Licensing | Distributing with Your .NET Application


Verify You're Using the Latest Service Pack

Service pack updates will not overwrite paid licensing. Your paid licensing will continue to work and you will not be required to re-enter your purchased registration codes. Service pack updates do not include any changes that might "break" previously developed and/or deployed code.

Verify Latest Development Components

To verify you are using the latest version of a Pegasus Imaging Development Component or Components, please use the PegConnect utility program. Please note that a Help File for each product may be found on the Start Bar under Pegasus, or in C:\Windows\Help.

PegConnect is installed by all component product installers and is accessible through the Windows Start menu:

Start | Programs | Pegasus Imaging | Pegasus Imaging | Common | Utilities

PegConnect Allows You To:

  1. Check with Pegasus Imaging via online connection and verify that the installed version of the component includes all the most recent updates.
  2. Update to the latest version automatically with your permission.
  3. Determine if a control is registered or unregistered on the machine.
  4. Easily change the registration status from registered to non-registered, or non-registered to registered.

Alternatively, you can see the currently released product build numbers at www.PegasusImaging.com/latestbuilds.htm.

If you require further assistance or have questions or comments, please see the section Getting Support for more detailed information.

See Also

Getting Support and Samples | Installing on a Development Machine


Distributing with Your .NET Application

Distributing ImagXpress®

Check for Proper Licensing and Unlock Codes

ImagXpress contains a locking mechanism that does not permit you to distribute applications created with evaluation versions of ImagXpress. Prior to distributing an application that utilizes ImagXpress v9, you must purchase and enable run-time licensing. If the application will be delivered on the web, you must also enable web application licensing.

DLL Files to Distribute

Distribute the appropriate assembly DLL files with applications using the ImagXpress product:

  • PegasusImaging.WinForms.ImagXpress9.dll
  • PegasusImaging.WinForms.NotateXpress9.dll
  • PegasusImaging.WinForms.ThumbnailXpress2.dll

  • PegasusImaging.WinForms.TwainPro5.dll
  • PegasusImaging.WinForms.PrintPro4.dll
See Also

Getting Support and Samples | Installing on a Development Machine | Development Mode | Run Time Licensing | License Agreement | Verify You're Using the Latest Service Pack


Overview of ImagXpress

ImagXpress® capabilities are encapsulated for the user in a set of powerful classes:

ImagXpress

The ImagXpress class provides methods and properties to manage licensing of the control. One (and only one) ImagXpress control is required per project.

ImageXView

The ImageXView class provides methods and properties to manage the interface to devices, such as monitors and printers and to other controls, such as NotateXpress™ and ThumbnailXpress™. ImageXView is required to view, print, or annotate an image.

There may be more than one viewer (ImageXView object) associated with a project:

  • To enable multiple views of the same image, create multiple ImageXView objects and assign the same image (ImageX object) to each.
  • To enable viewing multiple images, create multiple ImageXView objects and assign each to a different image (ImageX object).

Processor

The Processor class provides the properties, methods and events necessary to perform image processing on an image. There may be one or more processors associated with a project. Each processor can act on only one image at a time. The Processor class manages all image processing. Multiple Processor components can be added to the project to facilitate parallel processing, within the constraints of your system.

ImageX

The ImageX class provides the properties, methods and events necessary to load an image into ImagXpress, query image data and save the image. ImageX class objects are created during run time. Each ImageX object represents one image that is available in ImagXpress. Multiple ImageX objects can be created.

See Also

ImagXpress Class | ImageXView Class | Processor Class | ImageX Class


Supported File Formats

ImagXpress® supports the following file formats:

BMP (Microsoft Windows Bitmap)

  • Reads 1, 4, 8, 16, 24 and 32-bit BMP.
  • Reads 1, 4 and 8-bit RLE compressed BMP.
  • Writes 1, 4, 8 and 24-bit BMP.
  • 16 and 32-bit BMP files are converted to 24-bit.

CALS (type 1)

  • Reads 1-bit CALS-1 TypeI.
  • Writes 1-bit CALS-1 TypeI.

Camera Raw

  • Reads most vendor specific camera raw formats.

DCX (PC Paintbrush Multiple Page File Format)

  • Reads 1, 4, 8 and 24-bit DCX.
  • Writes 1, 4, 8 and 24-bit DCX.

DIB (Microsoft Windows Device Independent Bitmap)

  • Reads 1, 4, 8, 16, 24 and 32-bit DIB.
  • Writes 1, 4, 8 and 24-bit DIB as BMPs.
  • 16 and 32-bit DIB files are converted to 24-bit.

DWF (AutoCAD Design Web Format)

  • Reads DWF.

DWG (AutoCAD Drawing Database)

  • Reads DWG versions 2.5 through 2007.

DXF (AutoCAD Drawing Interchange Format)

  • Reads DXF.

EMF (Microsoft Enhanced Metafile Format - also known as WMF)

  • Reads Windows Metafiles.
  • EMF may be displayed in Metafile format or optionally converted to device dependent bitmaps for display.

GIF (CompuServe Graphics Interchange Format)

  • Reads 1 through 8-bit GIF.
  • Writes 1, 4 and 8-bit GIF.
  • Reads and writes GIF89a and GIF87a formats.
  • Reads and writes interlaced and non-interlaced formats.
  • Reads and writes GIF with a transparent color.
  • Internally, 2 & 3-bit GIFs are converted to 4-bit, and 5, 6, and 7-bit GIFs are converted to 8-bit.

HDP (Microsoft Windows Media Photo – also known as WDP)

  • Reads 8 bit and 16 bit gray, RGB or RGBA (8 bits per channel unsigned integer).
  • Writes 8 bit and 16 bit gray, RGB or RGBA (8 bits per channel unsigned integer).

ICO (Microsoft Windows Icon)

  • Reads 1, 4, 8, 16, 24, and 32-bit ICO. Single and multiple image.
  • Writes 1, 4, 8, and 24-bit ICO. Single and multiple image.
  • 16 and 32-bit ICO files are converted to 24-bit.
  • Reading and writing a transparent color is supported.

JLS (JPEG LS Format)

  • Reads 2 through 16-bit grayscale and 24-bit color JLS.
  • Writes 2 through 16-bit grayscale and 24-bit color JLS.

JP2, J2K (JPEG 2000 Format)

  • Reads 2 through 16-bit grayscale and 24-bit color JP2, J2K.
  • Writes 2 through 16-bit grayscale and 24-bit color JP2.
  • Supports lossless and lossy compression and decompression.

JPEG, JIF (JPEG File Interchange Format)

  • Reads 8 and 12-bit grayscale and 24-bit JPEG.
  • Writes 8 and 12-bit grayscale and 24-bit JPEG.
  • Reads and writes JFIF compliant JPEG and Progressive JPEG formats.
  • Also reads and writes EXIF compliant JPEGs.
  • Document and Photo Edition can read and write EXIF tags with thumbnail.

LJP (Lossless JPEG)

  • Reads 8 through 16-bit and 4-bit grayscale, and 24-bit color lossless JPEG.
  • Writes 8 through 16-bit and 4-bit grayscale, and 24-bit color lossless JPEG.
  • Supports RGB and YCBCR compression, and decompression.

MO:DCA

  • Reads 1-bit MOD:CA.
  • Writes 1-bit MOD:CA.
  • Reads PTOCA and IOCA:
    o 1 bpp IBM MMR, 1 bpp G4, 1 bpp ABIC, 4 bpp Concatenated ABIC (Grayscale).
    o PTOCA Fonts: C0CHz00p0.
    o Codepages: Default to EBCIDIC codepages but also support codepage ‘T1001252’ for ASCII data.
    o Support internal overlays.

PBM (Portable Bitmap)

  • Reads 1-bit PBM (ASCII and binary formats).
  • Writes 1-bit PBM (ASCII and binary formats).

PCX (PC Paintbrush File Format)

  • Reads 1, 4, 8 and 24-bit PCX.
  • Writes 1, 4, 8 and 24-bit PCX.

PDF (Image-only)

  • Writes 1, 8 and 24 bit uncompressed image streams. Single and multiple page.
  • Writes 8, 24 bit and CMYK JPEG compressed image streams. Single and multiple page.
  • Writes 1 bit G3-1D, G3-2D, G4 and JBIG2 compressed image streams. Single and multiple page.
  • Reads 1, 8 and 24 bit uncompressed image streams. Single and multiple page.
  • Reads 8, 24 bit and CMYK JPEG compressed image streams. Single and multiple page.
  • Reads 1 bit G3-1D, G3-2D, G4 and JBIG2 compressed image streams. Single and multiple page.

PGM (Portable Graymap)

  • Reads 8-bit grayscale PGM (ASCII and binary formats).
  • Writes 8-bit grayscale PGM (ASCII and binary formats).

PIC, ePIC (Pegasus Enhanced PIC)

  • Reads 8-bit grayscale and 24-bit ePIC format.
  • Writes 8-bit grayscale and 24-bit ePIC format.
  • Reads and writes 24-bit ePIC.
  • Supports password image protection.

PNG (Portable Network Graphics)

  • Reads 1, 4, 8, 16 and 24-bit PNG.
  • Writes 1, 4, 8 and 24-bit PNG.
  • Reads and writes interlaced and non-interlaced formats.
  • 16-bit PNG files are decompressed to 24-bit.

PPM (Portable Pixmap)

  • Reads 24-bit PPM (ASCII and binary formats).
  • Writes 24-bit PPM (ASCII and binary formats).
  • RLE (Run-Length Encoded Bitmap).
  • Reads 1, 4 and 8-bit RLE.

RAW (Raw Image Data)

  • Reads 8 through 16-bit grayscale and 24-bit color.
  • Writes 1 through 16-bit grayscale and 24-bit color.
  • Supports RGB, RGB555, RGB565, RGBA, ARGB, BGR, BGRA, ABGR, CMYK, YUV, YUYV, UYVY, and YCBCR in both "big endian" and "little endian" formats.

TGA (Truevision Targa)

  • Reads 1, 8, 16, 24 and 32-bit TGA.
  • Writes 1, 8 and 24-bit TGA.
  • 16 and 32-bit TGA files are converted to 24-bit.
  • Reads compressed and uncompressed TGA.
  • Writes uncompressed TGA.

TIFF (Tag Image File Format)

  • Reads 1, 4, 8, 16, 24 and 32-bit uncompressed TIFF.
  • Writes 1, 4, 8 and 24-bit uncompressed TIFF.
  • Reads and writes CCITT RLE, Group 3, and Group 4 compressed TIFF.
  • Reads and writes 1, 4, 8 and 24-bit Pack Bits TIFF.
  • Reads and writes 1, 4, 8 and 24-bit LZW TIFF.
  • Reads and writes 8-bit grayscale and 24-bit color (JPEG 6 and JPEG 7) TIFF.
  • Reads and writes 1, 4, 8 and 24-bit deflate TIFF.
  • Reads and writes multiple page TIFF.
  • 16 and 32-bit TIFF files are converted to 24-bit.
  • Reads CMYK TIFF.
  • Reads 9 to 16 bit gray scale TIFF.
  • Handles either "big endian" or "little endian" byte ordering.
  • Read tiled TIFF with LZW, JPEG, and G4 compression types.

WBMP (Wireless Bitmap)

  • Reads 1-bit WBMP.
  • Writes 1-bit WBMP.

WDP (Microsoft Windows Media Photo – also known as HDP)

  • Reads 8-bit and 16-bit gray, RGB or RGBA (8-bits per channel unsigned integer).
  • Writes 8-bit and 16-bit gray, RGB or RGBA (8-bits per channel unsigned integer).

WMF (Windows Metafile - also known as EMF)

  • Reads Windows Metafiles.
  • WMF may be displayed in Metafile format or optionally converted to device dependent bitmaps for display.

WSQ (WSQ Fingerprint File Format)

  • Reads 8-bit grayscale WSQ (included in all editions of ImagXpress).
  • Writes 8-bit grayscale WSQ.


Query Image Files

ImagXpress® provides the ability to query and modify images without loading them into ImagXpress.

The images may be remote or local, but may not have an HTTP or FTP address.

Query Image from File, Buffer, or Stream

Querying enables the user to gain information about the file before choosing to load or process it using ImagXpress. For example, the user may decide to load only images that are smaller than a threshold size, or images that are of a specified type. Querying is accomplished using methods within the ImageX class.

The QueryFile methods enable the user to obtain information about a specified page in a TIFF file. These methods return the ImageXData associated with the file. To query from buffer or stream, use the QueryBuffer or QueryFromStream methods.

The NumPages method enables the user to query a multiple page PDF, TIFF or DCX file to determine the number of pages in the file. This enables a user to query multiple pages, by iterating the page number in the ImageX.QueryFile methods.

Modify Image Files

Using ImagXpress (ImageX class), the user can make page-level modifications to TIFF files without loading the file. This enables the user to clean up or reduce the image size prior to loading.

  • The CompactFile method removes unused pages from the specified TIFF file.
  • The DeletePage and InsertPage methods delete/insert a specified page in the specified TIFF file.
  • The NumPages method enables the user to query a multiple page TIFF or DCX file to determine the number of pages in the file. This enables a user to delete or insert multiple pages in a TIFF file, by iterating the page number in the ImageX.DeletePage and ImageX.InsertPage methods.
  • ImagXpress enables users to set and get tags for TIFF and EXIF images without loading the image data, using the GetTags and SetTags methods.

Once an image is loaded into an ImageX object, the GetTags and SetTags methods do NOT update the ImageX object's image. Only the image at the specified filename is modified. To modify tags of an image loaded in an ImageX object, use the ImageX.Tags property.

These methods are only applicable to images stored in file, not for images in buffer or stream.

See Also

Add ImagXpress to Your Project


Specify Load Options

Load options (LoadOptions) can be used, if desired, to provide specific instructions when loading an image from file or from stream. If no load options are specified, ImagXpress® uses default values when loading the image.

General Load Options

  • The offset in the file or memory buffer where ImagXpress will begin reading image data (ImageOffset property).
  • Whether alpha channel data is to be loaded (LoadAlphaChannel).
  • Whether the image should be loaded as a thumbnail and the size of the desired thumbnail (ThumbnailSize).
  • Whether the image is scaled to gray when LoadResize is used to load the image. (ScaleToGray).
  • Whether preserve black will be applied to the image when loaded to increase readability. (PreserveBlack).
  • Whether the image will be cropped, resized and/or rotated upon loading (the ImageX object will get a modified version of the original image, based on the requested operations).
LoadCrop, LoadResize and LoadRotate are not supported when loading an image from a stream as the entire image must be loaded before the ImageX object can be modified.

When more than one of these operations is requested, the order is:

1) LoadCrop

Image is cropped to the dimensions specified in CropRectangle. If the dimensions specified are all zeros or null, then no crop occurs when loading.

2) LoadResize

Whether the image resizes when loading (Resize). If the parameters are all zeros or null, then no resize occurs when loading. Whether the image aspect ratio will be preserved when loading an image (MaintainAspectRatio).

3) LoadRotate

Whether image is rotated upon loading (Rotation property).

Image Color Management Loading Options

When loading an image into an ImageX object, you can specify how color management is applied.

  • To avoid color management when loading, set UseEmbeddedColorManagement = False.
  • To perform color management using the color profile specified in the image metadata:
    1. Set LoadOptions.UseEmbeddedColorManagement = True
    2. Specify how profiles should be applied, by setting the ColorRenderIntent property (for example, Picture, Graphics, Business or Colorimetric interpretation.)
    3. The image is modified to reflect the color profile, then loaded.

  • To perform color management using a color profile specified in a file:
    1. Set LoadOptions.UseEmbeddedColorManagement = False.
    2. Specify how profiles should be applied, by setting the ColorRenderIntent property (for example, Picture, Graphics, Business or Colorimetric interpretation.)
    3. Set the SourceProfileName to the name of the color profile you wish to apply to the image being loaded
    4. The image is modified to reflect the color profile, then loaded.

FTP Loading Options

If username/passwords and proxy settings are needed, set InternetOptions.

Image Format-Specific Load Options

CAD (LoadOptionsCad)

  • Layers: The Layer method specifies the layer of the CAD drawing to load. LayoutToRender specifies the layout of the CAD drawing to load.
  • Rendering: The PaperBitDepth, PaperResolutionX, PaperResolutionY, PaperWidth, PaperHeight, and PaperResolutionUnits all specify how the CAD image should be rendered when loaded.

HDPhoto (LoadOptionsHdPhoto)

  • Filter: the PostProcessingFilter property specifies the post processing filter to be used when loading the image.

JBIG2 (LoadOptionsJbig2)

  • Swap Black and White: SwapBlackandWhite property specifies if the values for black and white use industry default or not.

JPEG (LoadOptionsJpeg)

  • Cosited: The Cosited property indicates whether image was compressed with cosited sub-sampling.
  • Enhanced: The Enhanced property specifies whether the JPEG decoder should use the Pegasus enhanced decomposition method.

PIC (LoadOptionsPic)

  • Password: Password to protect the .PIC file

Metafile (LoadOptionsMetafile)

  • Convert to DIB: The ConvertToDib property specifies whether a Windows Metafile converts to DIB at load time
  • Resolution: the Resolution property specifies the resolution to which the image is loaded.

PDF (LoadOptionsPdf)

  • Swap Black and White: When SwapBlackandWhite is set, the PDF file will be loaded with black and white pixels swapped.

TIFF (LoadOptionsTiff)

  • Offset: The IFDOffset in the source file or memory buffer where ImagXpress will begin reading image data.
  • Special: Whether this is a banking-vendor specific application requiring special tiff handling (SpecialHandling).

Raw Image Format Load Options

To enable loading of images that are in a camera raw format, do one of the following:

Explicitly specify that image data should be treated as a raw format when loading.

If the application expects the image to be in a camera raw format, and knows the specific camera raw format, then LoadOptionsRaw can be explicitly set to accurately interpret the raw image data:

  1. Set LoadOptions.LoadMode to raw, in order to treat the image data as a raw format when loading.
  2. Use the remaining properties within the LoadOptionsRaw class to specify how data loads from the raw data format.
  3. When the image is loaded, the data will be interpreted using the LoadOptionsRaw properties.

OR

Inspect the image when loading, to automatically determine whether it is in a Camera Raw format.

The ImagXpress control has the ability to inspect an image when loading to determine that an image is in a camera raw format, identify the specific camera raw format of the image, and load the image using that format.

  1. Set LoadOptions.LoadMode to Normal, in order to inspect the image data when loading to determine format.
  2. Set LoadOptions.CameraRawEnabled = True to specify that the image should be examined on loading to see if the data is in a camera raw format, and to identify the raw format.
  3. Load the image, using one of the load methods (e.g. FromFile). The image will be inspected to see if it is in a CameraRaw format as part of the loading process. The image will be decoded using the specific camera raw format detected.

To optimize performance, set CameraRawEnabled to False when it is not needed.

When CameraRawEnabled = True, the image can only be loaded from a file. Loading from a stream is not supported as the entire image must be loaded before the raw format can be recognized.
See Also

Load Image from File | Load Image from Stream | Load Image from another ImageX Object | Load Image from Bitmap or DIB | Get Loaded Image Information


Load Image from File

Prior to loading an image, set the LoadOptions to provide specific instructions for loading the image. If no load options are specified, ImagXpress uses default values when loading the image.

Load from a Local Disk File

To load an image from a file, use the ImageX.FromFile methods. When called, the FromFile methods store a copy of the original image in the ImageX object. ImagXpress® looks at the file extension of the specified filename parameter to recognize the filetype.

The ImageStatusEvent and ProgressEvent events are raised to provide feedback on the status of the loading process. Once loading is complete, the image is available in the ImageX object.

Load from an FTP, HTTP, or HTTPs Location

ImagXpress supports loading of image files from FTP, HTTP, and HTTP/S locations, as follows:

1. To specify passwords or proxy settings, set the Internet property within LoadOptions

2. Call one of the following:

FromFile(ImagXpress,String,LoadOptions)

FromFile(ImagXpress,String,Int32,LoadOptions)

Make sure that the String parameter specifies the full internet path and file name

3. A copy of the original image is stored in the ImageX object

Load a Multi-page Image From File

ImagXpress® supports the following multi-page image formats: TIFF, PDF, ICO and DCX. The NumPages method provides the number of pages in the file.

To load the entire multi-page file into one ImageX object, call either of the following:

FromFile(ImagXpress,String)

FromFile(ImagXpress,String,LoadOptions)

To load only one specified page of a multi-page file into the ImageX object, call one of the following:

FromFile(ImagXpress,String,Int32)

FromFile(ImagXpress,String,Int32,LoadOptions)

Multi-page images can be read (decompressed and loaded) in the View, Document and Photo editions. The Standard edition can read (decompress and load) only the first page of a multi-page image.

See Also

Load Image from Stream | Specify Load Options | Load Image from another ImageX Object | Load Image from Bitmap or DIB | Get Loaded Image Information


Load Image from Stream

Prior to loading an image, set the LoadOptions to provide specific instructions for loading the image. If no load options are specified, ImagXpress® uses default values when loading the image.

Load from Stream

To load an image from a memory or file stream, use the ImageX.FromStream methods. When called, the FromStream methods store a copy of the original image in the ImageX object.

The ImageStatusEvent and ProgressEvent events are raised to provide feedback on the status of the loading process. Once loading is complete, the image is available in the ImageX object.

To load a BLOB (Binary Large Object), use the ImageX.FromStream method.
To load a file from an internet stream, use the ImageX.FromFile method, specifying the full internet path and file name, NOT the FromStream method.

Load a Multi-page Image From Stream

ImagXpress supports the following multi-page image formats: TIFF, PDF, ICO and DCX. The NumPages method provides the number of pages in the file.

To load the entire multi-page file into an ImageX object, call either of the following:

FromStream(ImagXpress,Stream)

FromStream(ImagXpress,Stream,LoadOptions)

To load only one specified page of a multi-page image into the ImageX object, call one of the following:

FromStream(ImagXpress,Stream,Int32)

FromStream(ImagXpress,Stream,Int32,LoadOptions)

Multi-page images can be read (decompressed and loaded) in the View, Document and Photo editions. The Standard edition can read (decompress and load) only the first page of a multi-page image.

See Also

Load Image from File | Specify Load Options | Load Image from another ImageX Object | Load Image from Bitmap or DIB | Get Loaded Image Information


Load Image from Bitmap or DIB

Load an Image from HBitmap

If the image to load is a bitmap (device dependent), call ImageX.FromHbitmap or ImageX.FromBitmap methods to load the image into the ImageX object. A copy of the source image loads into the ImageX object.

The ImageX.ImageStatusEvent event is raised to provide feedback on the status of the loading process. Once loading is complete, the image is available in the ImageX object.

Load an Image from HDIB

If the image to load is a DIB, call ImageX.FromHdib method to load the image into the ImageX object.

  • To directly take control of the Hdib, set the ownDib parameter to true, for example: ImageX1.FromHdib(thehdib, true)
  • To make a copy of the DIB, prior to loading, set ownDib to false. (Default = false if not specified). For example: ImageX1.FromHdib(thehdib, false)
See Also

Load Image from File | Load Image from Stream | Specify Load Options | Load Image from another ImageX Object | Get Loaded Image Information


Load Image from another ImageX Object

An ImageX object can be loaded with a copy of a different ImageX object:

C# Example:

// This code demonstrates how an ImageX object can be loaded with a copy of a different ImageX object

targetImageX = sourceImageX.Copy();

See Also

Load Image from File | Load Image from Stream | Specify Load Options | Load Image from Bitmap or DIB | Get Loaded Image Information


Cancel

The ImageX.Cancel method cancels the loading, decompression, compression, or saving of the ImageX image.

See Also

Undo a Processing Action | Save Image to File | Save Image to Bitmap or DIB | Save Image to Stream


Get Loaded Image Information

Once an image has been loaded into an ImageX object, information about the image is available through the properties and methods of the ImageX object.

Get Image Data

Number of Pages: To get the number of pages in the image, use ImageX.PageCount (read-only property).

The PageCount will not be valid if the image was loaded FromStream, since page count information is not available when streaming.

Current Page: To get or set the page to be viewed or processed, use the ImageX.Page property.

Resolution: Use one of the following to get the resolution of the image:

  • ImageX.Resolution (read only property) provides the image dimensions and resolution unit of measure.
  • ImageXData.Resolution (read only property) provides the image dimensions and resolution unit of measure. (Same as ImageX.Resolution)
  • ImageX.HorizontalResolution method and ImageX.VerticalResolution method provide the horizontal and vertical resolution, in the units specified by ImageX.ResolutionUnits methods.

Tags: To get the tag collection associated with the ImageX object, use the ImageX.Tags property.

Color Palette: To get the color palette used for the ImageX image, use the ImageX.Palette property.

Load Options Used: To get information on how the image was loaded, use ImageX.LoadOptions (read only property).

Image Data: To get other data about the image, such as bit depth, color space, compression of original image, file format and size, use the read-only properties in ImageXData

Monitoring the Status of an ImageX Object

The ImageX.ImageStatusEvent and ImageX.ProgressEvent events raise to provide feedback on the status of the image as it is viewed, processed, or saved.

See Also

Load Image from File | Load Image from Stream | Specify Load Options | Load Image from another ImageX Object | Load Image from Bitmap or DIB


Modify Tags and Comments

Modify TIFF Tags without Loading the Image

Tags can be modified without loading the image, using the ImageX.GetTags and ImageX.SetTags methods. (See Query Images).

Modify TIFF Tags in a Loaded Image

Once a TIFF image has been loaded into an ImageX object, the tags can be modified by accessing the tag collection associated with the ImageX object (Tags).

Please see the TIFF and EXIF file specification for more information about tags.

Modify JPEG Comments

JPEG, JPEG2000, JLS, or WSQ files may have a list of comments. ImagXpress® enables you to modify comments of an image loaded into ImageX, as follows:

  • Count the comments: The JPEGCommentCount property returns the number of comments contained in the file.
  • Get the comment: The ReturnJpegComment method returns the text associated with a specified comment.
  • Add a comment: The AddJpegComment method adds a comment to the comment list.
  • Delete a comment: The DeleteJpegComment method deletes a comment from the comment list.
Undo does not undo changes to TIFF tags or JPEG Comments. Undo only applies to processing actions.

See Also

Modify the Image Palette


Modify the Image Palette

The ImageX.Palette property gets or sets the color palette associated with the ImageX image (if the image is 8 bpp or less). The ImageX.CreateColorPalette method can be used to create a new color palette, which can be assigned to the ImageX image.

C# Example:

// This code demonstrates how to modify the first entry in the palette to red

System.Drawing.Imaging.ColorPalette palette;

palette = imageX.Palette;

if (palette.Entries.Length > 0)

{

palette.Entries[0] = System.Drawing.Color.Red;

imageX.Palette = palette;

}

The ImageX.Palette property cannot be modified on the fly. The following code will NOT change the first entry in the ImageX.Palette:

C# Example:

// This code demonstrates what does not work

imageX.Palette.Entries[0] = System.Drawing.Color.Red

Undo does not undo changes to palette. Undo only applies to processing actions.

See Also

Modify Tags and Comments


Draw on the Image

To utilize the System.Drawing.Graphics capabilities to draw on an image:

  1. Call ImageX. GetGraphics method to get a System.Drawing.Graphics object and associate it with the ImageX image.
  2. The returned graphics object can be drawn upon using the standard System.Drawing.Graphics drawing methods.
  3. When drawing is complete and the graphics object is no longer needed, do one of the following:
  • Call ImageX. ReleaseGraphics method, to update the ImageX object with the image in the Graphics object, then release the memory associated with the graphics object.
  • Call ImageX.ReleaseGraphics(True) to update the ImageX object with the image in the graphics object, then release the memory associated with the graphics object.
  • Call ImageX.ReleaseGraphics(False), to release the memory associated with the graphics object without updating the ImageX object.

Undo does not undo Drawing actions. Undo only applies to processing actions.

See Also

Print an Image | Create a Viewer | Free the Controls' Resources | Annotate an Image


Create a Viewer

To create a viewer, define a New ImageXView object:

C# Example:

// This code demonstrates that a viewer has been created

New ImageXView(ImageXpress);

More than one ImageXView may be defined, to view different images, or different views of the same image. See Display Image for more information.
See Also

Print an Image | Free the Controls' Resources | Annotate an Image | Draw on the Image


Set the View Window Size and Appearance

The ImageXView class inherits the System.Window.Forms.Control class, which provides capability to define a control window.

In addition to the inherited properties and methods, the ImageXView provides a specialized property to specify the BorderStyle, to provide ImagXpress®-specific border options.

See Also

Set Toolbar and Cursors | Set Context Menus | Set Image Display Palette | Set Color Management | Enable Medical Viewing | Enable Progressive Viewing | Set Alpha Blending


Set Toolbar and Cursors

Defining Tools and Toolbars

Each ImageXView object (Viewer) supports one toolbar, which enables application end-users to access ImagXpress® capabilities. Toolbar attributes can be modified using the Toolbar properties and methods, or via ImageXView methods: ToolSet, ToolGet, ToolSetAttribute, ToolGetAttribute.

Using Custom Cursors

By default, the toolbar will use the ImagXpress supplied built-in cursors for each tool. Alternatively, custom cursors may be specified for each tool, using the SetToolCursor method.

See Also

Set the View Window Size and Appearance | Set Context Menus | Set Image Display Palette | Set Color Management | Enable Medical Viewing | Enable Progressive Viewing | Set Alpha Blending


Set Context Menus

Viewer Context Menu

Each ImageXView object can have one associated context menu, which provides options to the user within the control window. To define a context menu for the viewer, call ImageXView.ContextMenu. The ContextMenu property inherits from System.Windows.Forms.Control.

Toolbar Context Menu

Each ImageXView object also has one associated toolbar (Toolbar). The toolbar has an associated context menu, which provides application end-users with options for accessing each of the tools. The toolbar context menu is defined using the methods within the ImageXView.Toolbar.ContextMenu.

See Also

Set the View Window Size and Appearance | Set Toolbar and Cursors | Set Image Display Palette | Set Color Management | Enable Medical Viewing | Enable Progressive Viewing | Set Alpha Blending


Set Scrolling and MouseWheel Behavior

The ImageXView class inherits the System.Window.Forms.Control class, which provides capability to define scrolling and mousewheel behavior.

In addition to the inherited properties, the ImageXView provides specialized properties:

  • Scrollbars turns on and off the scrollbars.
  • MouseWheelCapture turns on and off capturing mousewheel even when the control does not have focus.
See Also

Set the View Window Size and Appearance | Set Toolbar and Cursors | Set Context Menus


Glossary Item Box

Zoom Image in Window | Enable Progressive Viewing | Enable Medical Viewing | Set Color Management | Set Image Display Palette | Set Display Bit Depth | Set Alpha Blending | Change Image Display Rendering

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Align Image in Window

The ImageXView.AlignHorizontal and ImageXView.AlignVertical properties are set to specify the horizontal and vertical alignment of the image being viewed.

See Also

Zoom Image in Window | Enable Progressive Viewing | Enable Medical Viewing | Set Color Management | Set Image Display Palette | Set Display Bit Depth | Set Alpha Blending | Change Image Display Rendering


Glossary Item Box

Align Image in Window | Enable Progressive Viewing | Enable Medical Viewing | Set Color Management | Set Image Display Palette | Set Display Bit Depth | Set Alpha Blending | Change Image Display Rendering

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Zoom Image in Window

The ImageXView methods modify only the image view, not the image itself. To modify the image, use the Processor.Resize methods.

AutoResize

The ImageXView.AutoResize property defines how an image will be sized and positioned within the display window each time the control paints. The ImageXView.Maximum and ImageXView.Minimum properties define the maximum and minimum dimensions that the control can be resized to when ImageXView.AutoResize specifies that the control should be resized to fit the image.

Zoom To Fit

Call the ImageXView.ZoomToFit method to fit the width and/or height of the displayed image to the control window. The image, the aspect ratio of the displayed image and the aspect ratio of the image's pixels remain unchanged.

Set the Zoom Factor

Zoom the displayed image, by setting the ImageXView.ZoomFactor property to the desired value. Zooming the image has no effect on the image, or the aspect ratio of the displayed image.

If the ImageXView.AutoResize property is set to 'BestFit' then the ImageXView. ZoomFactor property will be locked.

Change the Aspect Ratio

Change the aspect ratio of the displayed image by setting the ImageXView.AspectX and AspectY properties. Setting these properties defines the shape of each pixel in the display. This will change the aspect ratio of the displayed image, but will have no effect on the image itself.

To translate between the coordinates on the displayed image and the coordinates in the image, use the ImageXView.Translate method.

See Also

Align Image in Window | Enable Progressive Viewing | Enable Medical Viewing | Set Color Management | Set Image Display Palette | Set Display Bit Depth | Set Alpha Blending | Change Image Display Rendering


Enable Progressive Viewing

Progressive viewing can be useful if loading is expected to take a long time (for example, remote loading of a large, highly compressed file). Set ImageXView.Progressive to specify whether or not images are displayed progressively.

See Also

Set the View Window Size and Appearance | Set Toolbar and Cursors | Set Context Menus | Set Image Display Palette | Set Color Management | Enable Medical Viewing | Set Alpha Blending


Enable Medical Viewing

If the image to display is a medical image, set ImageXView.Medical to specify parameters specific to medical viewing.

See Also

Set the View Window Size and Appearance | Set Toolbar and Cursors | Set Context Menus | Set Image Display Palette | Set Color Management | Enable Progressive Viewing | Set Alpha Blending


Glossary Item Box

Zoom Image in Window | Enable Progressive Viewing | Enable Medical Viewing | Set Image Display Palette | Set Display Bit Depth | Set Alpha Blending | Change Image Display Rendering | Align Image in Window

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Set Color Management

Image Color Management (ICM) is performed to ensure that the image has a very similar appearance, regardless of the device on which it is displayed or printed. When displaying an image, the image must be converted to the device-specific color space of the specified monitor. This conversion can be done at a number of different points in the process:

  • Prior to loading the image into ImagXpress®
  • By ImagXpress
  • By the display device

To perform color management within ImagXpress:

1. Ensure that ImageXView.IcmEnabled is set to True.

2. Specify how to apply profiles, by setting the ImageXView.ColorRenderIntent property (for example, Picture, Graphics, Business or Colorimetric interpretation.)

3. Specify the color profile to be used when performing ICM on an image to be displayed (ImageXView.MonitorProfileName property).

Setting MonitorProfileName doesn't change the profile name stored with the monitor device context - it simply specifies the color profile ImagXpress uses when performing Image Color Management.

4. Color management will be applied when the image paints.

See Also

Zoom Image in Window | Enable Progressive Viewing | Enable Medical Viewing | Set Image Display Palette | Set Display Bit Depth | Set Alpha Blending | Change Image Display Rendering | Align Image in Window


Set Image Display Palette

When the ImageXView.Image has a bit depth of 8 bits or less, the image's palette is realized by the display device. In other words, the image's palette combines with the display device's logical palette and is used to display the image.

You can specify a different behavior by setting the ImageXView.PaletteType property.

Setting the PaletteType property does not change the palette stored with the ImageXView.Image, but does change the palette realized by the display device.

If PaletteType is set to:

  • Null, then use the image's palette when displaying.
  • UserDefined, then use the ImageXView.GetPaletteColor and SetPaletteColor methods to define and access a user-defined palette.
  • PalFile, then use the ImageXView.PaletteFilename property to set and get the source for the palette.
  • Gray, then a fixed gray palette is used.
  • Fixed, then an ImageXView internally defined palette is used.
  • Optimized, then the image is analyzed and the best palette is used.
See Also

Set the View Window Size and Appearance | Set Toolbar and Cursors | Set Context Menus | Set Color Management | Enable Medical Viewing | Enable Progressive Viewing | Set Alpha Blending


Glossary Item Box

Align Image in Window | Zoom Image in Window | Enable Progressive Viewing | Enable Medical Viewing | Set Color Management | Set Image Display Palette | Set Alpha Blending | Change Image Display Rendering

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Set Display Bit Depth

If the ImageXView.Image property has a greater bit depth than the monitor supports, then the ImageXView object will down sample the image when sending it to the display device.

In some cases, it may be necessary for the application programmer to artificially set the display device to a lower bit depth than the hardware supports (for example, to simulate the application's performance and appearance on a VGA monitor). Use the ImageXView.DisplayMode property to get and set the maximum color depth to use on the display device:

  • If ImageXView.DisplayMode is set to TrueColor, 24-bit images can be rendered to display.
  • If DisplayMode is set to PaletteColor, 8-bit images can be rendered.
  • If DisplayMode is set to VGAColor, 4-bit images can be rendered.
See Also

Align Image in Window | Zoom Image in Window | Enable Progressive Viewing | Enable Medical Viewing | Set Color Management | Set Image Display Palette | Set Alpha Blending | Change Image Display Rendering


Set Alpha Blending

Setting ImageXView.AlphaBlend property to True specifies that an image with an alpha channel should be blended to the background of the control when displayed.

See Also

Set the View Window Size and Appearance | Set Toolbar and Cursors | Set Context Menus | Set Image Display Palette | Set Color Management | Enable Medical Viewing | Enable Progressive Viewing


Change Image Display Rendering

The ImagXpress® control provides advanced image display features. The following properties will alter the display of an image after it loads, without changing the image itself. These operations are faster than actually changing the image data and not permanent. They are particularly useful when using multiple views of one image. In that case, an operation on the image data would affect all views of that image buffer, while these operations will only affect one view.

The ImageXView methods modify only the image view, not the image itself. To modify the image, use the Processor methods.

Anti-Aliasing Effect

The ImageXView.Antialias property enables or disables the anti-alias effect. When the logical size of an image is reduced to less than the actual size of the image, then some of that image’s pixels will be lost. When Antialias is enabled, the pixels that would occupy the same area are averaged together; turning them into a level of gray for black and white images. For color images, all of the pixels are averaged. This prevents fine lines from being lost and allows a full page of printed text to be read clearly.

Brightness

The ImageXView.Brightness property sets the brightness level for the image. It allows the user to adjust the brightness of the displayed image.

Contrast

The ImageXView.Contrast property sets the contrast level for the image. It allows the user to adjust the contrast of the displayed image.

Gray Mode

The ImageXView.GrayMode property specifies whether a grayscale image should be displayed using a medical grayscale transform or a simple linear transform.

Smoothing

The ImageXView.Smoothing property enables or disables the view smoothing effect. When the logical size of an image is increased to more than the actual size of the image, the image starts to look boxy. When Smoothing is enabled, ImagXpress performs a leveling algorithm that evens out square edges.

Dithering

The ImageXView.Dithered property enables or disables the use of dithering.

PreserveBlack

The ImageXView.PreserveBlack property enables or disables the preserve black features, which enhances black objects (such as lines) to increase readability.

See Also

Select a Section of the Displayed Image | Display Image


Display Image

Display an Image in the Viewer

To display an image in the viewer,

  1. Ensure that ImageXView.AllowUpdate property is set to True. AllowUpdate specifies that the viewer (ImageXView object) will update whenever there is a request to paint.
  2. Verify that ImageX.AutoInvalidate property is True. AutoInvalidate specifies that the image (ImageX object) will notify any ImageXView objects actively displaying the ImageX image to perform a repaint whenever there is a change to the image.
  3. Then assign ImageXView.Image property to an ImageX object. This image displays when the control window next paints.

Display a Part of an Image in the Viewer

To display a part of an image in the viewer, set the ClipRectangle property to the portion of the image to be displayed. The ClipRectangle property defines the portion of the image accessible to the viewer. If the ClipRectangle is smaller than the image, then the viewed image crops to the dimensions specified by ClipRectangle. This cropped image is then available in the viewer to be zoomed, scrolled, etc.

Display Different Images within one Viewer

To display a different image within a View window, assign ImageXView.Image to a different ImageX object. This image displays when the control window next paints.

Display Multiple Simultaneous Views of the Same Image

Each ImageXView object can display only one image at a time. Sometimes it is necessary to display multiple views of the same image. A typical use would be to display a "before" and "after" view (with some image rendering options changed) of an image.

To view the same image using multiple ImageXView objects, set the Image property within both ImageXView objects to the same image.

Display Image Information in the Control Window

To display a dialog box with information about the image being displayed, call the ImageXView.ShowImageInfo method. This method displays ImageXData characteristics for the image currently assigned to the ImageXView object.

See Also

Select a Section of the Displayed Image | Change Image Display Rendering


Capture an Image from Screen

Capture the Screen Area Bounded by the ImageXView Window and Save to an ImageX Object

The following example illustrates how to capture the screen area bounded by the ImageXView Window:

C# Example:

// This code demonstrates how to assign the image object to a viewer

ImageXView1.Image = targetImageX;

// capture the screen area within the viewer and save it to the target image object

ImageXView1.CaptureControl();

// targetImageX now contains the image in the screen area bounded by the control.

Capture the Entire Screen Area within a Specified Window

The following example illustrates how to capture the entire screen area within a specified window:

C# Example:

// This code demonstrates how to assign the image object to a viewer

ImageXView1.Image = targetImageX;

// capture the screen area within the viewer and save it to the target image object

// if only a part of the window's screen area should be captured, specify a captureRectangle

ImageXView1.CaptureWindow(hWnd, captureRectangle);

// targetImageX now contains the image in the screen area bounded by the control.

See Also

Copy and Paste Image Using the Clipboard


Copy and Paste Image Using the Clipboard

Copy an ImageX Object to the Clipboard

The following example illustrates how to copy an image to the clipboard:

C# Example:

// This code demonstrates how to assign an image object to a viewer

ImageXView1.Image = sourceImageX;

// copy the image to the clipboard

ImageXView1.CopyToClipboard();

// the clipboard now contains a copy of the sourceImageX object.

Paste an Object from the Clipboard to an ImageX Object

The following example illustrates how to paste an object from the clipboard to an ImageX object:

C# Example:

// This code demonstrates how to assign an image object to a viewer

ImageXView1.Image = targetImageX;

// paste the image from the clipboard

ImageXView1.PasteFromClipboard();

// the targetImageX object now has the image from the clipboard.

See Also

Capture an Image from Screen


Select a Section of the Displayed Image

To select a section of the image, use a Rubberband or a Sprite:

Select with Rubberband

ImagXpress® enables the user to select a rectangular section of the image being viewed. This section, referred to as a Rubberband, can then be used to specify a region to process.

To use a rubberband:

  • Enable the rubberband capability by setting ImageXView.Rubberband.Enabled to True.
  • Define and modify a rubberband area, by calling ImageXView.Rubberband methods: Start, Stop, Update, and Clear.
  • Copy the content framed by the rubberband to an ImageX object using the Rubberband Copy method.

Select with Sprite

The ImageXView class provides capability to create and use a sprite. A sprite is created by copying a part of the displayed image into a transparent window. This window can be moved or pasted within the image view. To create and use a sprite:

  • Define a part of the displayed image to copy. (This can be done either by defining a Rubberband, Region, Area, or a graphics path.)
  • Create the sprite, by calling the Sprite Create method
  • Move the sprite, by calling the Sprite Move method
  • To permanently paste the sprite to the ImageX object, call the Sprite Paste method.
Even if the viewer is assigned a different image to display, the sprite remains in effect and can be moved or pasted in the new image being viewed. Therefore, sprites can be used to merge images.
  • Delete the sprite and free up its resources, by calling the Sprite Delete method.
Deleting the sprite does not result in any changes to the image being viewed.

See Also

Change Image Display Rendering | Display Image


Glossary Item Box

Zoom Image in Window | Enable Progressive Viewing | Enable Medical Viewing | Set Color Management | Set Image Display Palette | Set Display Bit Depth | Set Alpha Blending | Change Image Display Rendering | Set Toolbar and Cursors | Set Context Menus | Set Image Display Palette | Set Color Management

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Manage End-User Viewing Events

ImageXView inherits events from System.Windows.Forms.UserControl and System.Windows.Forms.Control to monitor end-user actions and display changes, including mouse and keyboard actions. ImagXpress® also provides a few specialized events to provide additional information to the application:

  • When the AutoResize property is modified, the AutoResizeChanged event provides additional information on the new and old values of the AutoResize property.
  • When the ZoomFactor property is modified, the ZoomFactorChanged event provides additional information on the new and old values of the ZoomFactor property.
  • When the control is resized, the Resized event provides the new size of the control.
  • When an image paints, the PaintImage event provides information on the graphics, logical rectangle, user data, view rectangle, and zoom factor.
  • When the end-user scrolls, the ScrollEvent event provides information on the new location within the scroll range, the type of scroll event that occurred, and which scrollbar the event pertains to.

ImagXpress Toolbar Events

In addition to standard Control events, ImageXView offers specialized events to notify the application about end-user interaction with the ImagXpress toolbar.

  • When a tool is selected the ToolbarEvent event raises to tell the application which tool was selected.
  • When a tool is being used, a ToolEvent event raises to notify the application when the tool is clicked, when the tool is in action and when the tool is no longer in use.
  • When the toolbar window opens, the ToolbarOpenEvent raises.
  • When the toolbar window closes, the ToolbarCloseEvent raises.
  • When a menu item is selected, a ToolbarContextMenuSelectEvent raises to notify the application of the selection made. The menu ID is provided to the event handler when this event is raised.
See Also

Zoom Image in Window | Enable Progressive Viewing | Enable Medical Viewing | Set Color Management | Set Image Display Palette | Set Display Bit Depth | Set Alpha Blending | Change Image Display Rendering | Set Toolbar and Cursors | Set Context Menus | Set Image Display Palette | Set Color Management


Create a Processor

To create a processor, and assign an image to be processed, define a New Processor, or set Processor.Image property to the desired ImageX object.

C# Example:

// This code demonstrates how to define a processor

New Processor(ImageXpress);

// This code demonstrates how to assign an image to be processed

Processor.Image = ImageX;

See Also

Select an Area or Region to Process | Modify Image Size and Orientation | Apply Image Effects | Merge Images | Modify Alpha Channel | Correct Color and Contrast | Cleanup Images | Remove Redeye


Select an Area or Region to Process

Prior to performing image processing on an image, you must specify whether the entire image, or a section of the image, should be processed. The Processor class provides two vehicles for specifying a section of the image to be processed:

  • Area (Limited to a rectangular area), and
  • Region (not limited to a rectangular area).

If both an Area and a Region are enabled and defined, then the last one to be set will be used in processing.

If neither Area or Region are enabled and defined, then the entire image will be processed.

Region

To process a region of an image:

  1. Define a part of the image to process, by specifying a graphics path, rectangle, ellipse, or polygon.
  2. Create a region, by calling the Processor.SetRegion method. Since only one region can be defined for each Processor, calling SetRegion deletes the previous region.
  3. Specify that the region should be used for processing, by setting the Processor EnableRegion property.
  4. When the region is no longer needed, call the Processor DeleteRegion method to delete the object and free up the associated memory.
A Rubberband can be created to define a rectangular region on the display. The resulting Rectangle can then be passed as a parameter in Processor.SetRegion.
Deleting a region has no impact on the source (ImageX) image.

Area

To process an area of an image:

  1. Create an area by calling the Processor SetArea method, with a specified rectangular bounding area. Since only one area can be defined for each Processor, calling SetArea will delete the previous area.
  2. Specify that the area should be used for processing, by setting the Processor EnableArea property. When the area has been enabled, all image processing methods act on the area instead of the entire image. Calling SetArea will replace the current area with a newly defined area.
A Rubberband can be created to define a rectangular area on the display. First select a rubberband area, then pass the resulting rectangle to Processor.SetArea.
There is no need to delete an area, as there are no resources to free.

The Processor methods: RemoveRedeye, RemoveDust, and RemoveScratches methods require that an area be set to specify the area to process. For all other methods and properties, setting an area is optional.

See Also

Modify Image Size and Orientation | Apply Image Effects | Merge Images | Modify Alpha Channel | Correct Color and Contrast | Cleanup Images | Create a Processor | Remove Redeye


Modify Image Size and Orientation

Image size and orientation can be modified in several ways using ImagXpress®:

  • Modify the size or orientation of an image during loading of the image into ImagXpress (see Specify Load Options). In this case, the image in the ImageX object is modified to the specified size and orientation, but the source image is not modified.
  • Modify the size or orientation of an image during saving of the image (See Specify Save Options). In this case, the image in the ImageX object is not modified, but the target image is modified.
  • Modify the size or orientation of an image in ImagXpress. In this case, the image in the ImageX object is modified to the specified size and orientation, but the source image is not modified.

Modify the Size or Orientation of an Image in ImagXpress

The size and orientation of an imageX object can be modified by assigning it to the processor, then invoking processor methods:

Resize: The Resize method resizes the image (in pixels) according to the specified algorithm (ResizeType enumeration).

Crop: The Crop method crops the current image to the specified size.

The AutoCrop and CropBorder methods also provide capability to crop a border from an image. These are generally used primarily to clean up the image, rather than resize it.

Flip: The Flip method vertically flips the image.

Mirror: The Mirror method horizontally mirrors the image.

Rotate: The Rotate method rotates the image by the specified angle.

See Also

Select an Area or Region to Process | Apply Image Effects | Merge Images | Modify Alpha Channel | Correct Color and Contrast | Cleanup Images | Create a Processor | Remove Redeye


Glossary Item Box

Create a Processor | Select an Area or Region to Process | Modify Image Size and Orientation | Correct Color and Contrast | Cleanup Images | Remove Redeye | Apply Image Effects | Modify Alpha Channel | Merge Images | Undo a Processing Action

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Modify Image Bit Depth

The following Processor methods all can be used to reduce the bit depth of an image:

Change Color Depth

The ColorDepth method changes the bits per pixel of the current image.

The UniqueColors method returns the number of unique colors in the current image or region. This can be useful for determining if there is an opportunity to reduce the bit depth of the pixels without degrading the image.
If an image bit depth is modified from an image that is greater than 16 bits to an image that is 8 bits or less in depth, then a palette is associated with the image, as specified by the paletteType parameter when calling the ColorDepth method.

Reduce GrayScale Bit Depth

It may be advantageous to reduce the bit depth of a gray image, as most humans can only discern 256 shades of gray. To level an 8 through 16-bit image to an 8-bit gray image, call the ApplyGrayscaleTransform method to modify the image (permanently). To apply the DICOM standard transformation method to level a medical image, call ApplyGrayscaleTransform(Medical). To apply a simple linear method to level the image, call ApplyGrayscaleTransform(Int32,Int32).

Binarize

The Binarize method operates on 1-bit and 24-bit input images, permanently modifying the image to a 1-bit or 8-bit grayscale DIB of the same dimensions.

This is often done to clean up an image or apply an image effect.

See Also

Create a Processor | Select an Area or Region to Process | Modify Image Size and Orientation | Correct Color and Contrast | Cleanup Images | Remove Redeye | Apply Image Effects | Modify Alpha Channel | Merge Images | Undo a Processing Action


Glossary Item Box

Create a Processor | Select an Area or Region to Process | Modify Image Size and Orientation | Modify Image Bit Depth | Cleanup Images | Remove Redeye | Apply Image Effects | Modify Alpha Channel | Merge Images | Undo a Processing Action

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Correct Color and Contrast

ImagXpress® provides a suite of methods and properties that enable adjustment of image color. The color of each pixel in an image can be characterized using various color spaces. The Processor class enables the user to modify the color balance within an image by specifying either of the following color spaces:

  • RGB specifies the red, green and blue values within the pixel.
  • HSL specifies the hue (color tone), saturation (grayness), and luminance (intensity of light).

Modify RGB Levels: To change the levels of red, green and blue in the image, call AdjustRGB method, specifying the amount of change to the red, green and blue components of each pixel (in units or by percentage). Use the RGBColorCount method to identify the red, green, and blue color intensities of the image. This is useful in determining how to set parameters.

Modify HSL Levels: To change the levels of hue, saturation and luminance in the image, call AdjustHSL, specifying the amount of change to the hue, saturation and luminance components of each pixel (in units or by percentage).

Modify Luminance/Brightness: The Brightness method uniformly brightens the current image, by the percent specified. A brightened image has pixels with higher luminance values (in HSL color space), or higher RGB values (in RGB color space) than the original image.

Automatic Color Balance: The Processor object provides two alternative automatic color balance methods. Each uses a different algorithm to correct color balance. The user has the flexibility to use whichever method works best for the application and image:

  • To balance automatically, call AutoColorBalance. To override the default parameters used in the AutoColorBalance algorithm, call AdjustColorBalance instead of AutoColorBalance. The RGBColorCount method can be used to identify the red, green and blue color intensities of the image. This may be useful in determining how to set parameters specified in AdjustColorBalance.
  • To color balance automatically using an alternative algorithm, call AutoLevel.

Automatic Contrast Correction: The Processor class provides three alternative automatic contrast correction methods. Each uses a different algorithm to correct contrast within the image. The user has the flexibility to use whichever method works best for the application and image:

  • The AutoLightness method assesses and adjusts contrast in light and dark regions of the image separately. This can be especially useful for bringing more detail into the shadowy areas of the image, without washing out the light regions. To override the default parameters used in the AutoLightness algorithm, call AdjustLightness instead of AutoLightness.
  • The AutoContrast method adjusts the overall contrast of the image. To adjust the automatic contrast correction by a specified amount, call Contrast instead of AutoContrast.
  • The Equalize method adjusts contrast without changing the brightness range of the image. If the brightness values of the image were represented in a histogram, the Equalize method would have the effect of redistributing the brightness values within the image's brightness range, so that "clumps" of brightness values are spread out more evenly. For example, if an image has many pixels that have similar brightness, the Equalize method will introduce greater difference in brightness between these pixels, without changing the least bright or most bright pixels. The effect is that greater detail can be seen in areas that previously had very similar brightness.

Modify Gamma: Unfortunately, monitors may output pixel brightness in a non-linear fashion, so that when the image is displayed, the image brightness is not accurately portrayed. Adjusting gamma enables the user to adjust pixel brightness to compensate for the limitations of the display device. The gamma value represents the ratio of input vs. output brightness.

A gamma of one represents a linear relationship between input and output brightness - no change is made to the image. A gamma other than one represents a parabolic relationship between input and output brightness. Applying a gamma greater than one brightens the image, with mid-brightness levels increased more than extremely dark or light pixels. A gamma less than one darkens the image, with mid-brightness levels decreased more than extremely dark or light pixels.

The Gamma method adjusts the brightness of the image based on a parabolic transform, defined by the gamma value. A Gamma value that is greater than one will result in a convex parabolic transform, with the mid-range brightened more than high and low end. A Gamma value that is less than one will result in a concave parabolic transform, with the mid-range darkened more than the high and low end.

Join or Split RGB Values: The Processor class also provides the capability to split or join the RGB values of the pixels in the image. To separate the color components of the image, call ColorSeparation. To join the color components of the image, call ColorJoin.

You must free the resources associated with each color plane bitmap after it is no longer needed. Call ImageX.DisposeHbitmap to release the resources associated with the handles after use.

Count Colors: The ColorCount method returns the number of pixels of a specified color within the current image or region. This can be useful, for example, in determining whether a check box on a form is filled.

See Also

Create a Processor | Select an Area or Region to Process | Modify Image Size and Orientation | Modify Image Bit Depth | Cleanup Images | Remove Redeye | Apply Image Effects | Modify Alpha Channel | Merge Images | Undo a Processing Action


Cleanup Images

ImagXpress® provides methods and properties to support cleanup of photo and document images, using the Processor methods and properties:

Binarize

To facilitate cleanup or image recognition, it may be useful to convert an image to a 1-bit or 8-bit grayscale image. The Binarize method operates on 1-bit and 24-bit input DIB's, permanently modifying it to a 1-bit or 8-bit grayscale DIB of the same dimensions.

Deskew

To adjust the rotation of the page to remove skew, use one of the following:

  • The Deskew method provides the option of specifying how the deskew performs (for example, whether the rotated image is cropped to original dimensions, or whether the image size adjusts based on the deskew).
  • If the image is a black and white document, you may wish to use the DocumentDeskew method, which has been optimized for 1-bit images and which provides feedback on confidence in the result (Confidence property) and rotation angle required to correct the skew (RotationAngle property.

Shear

To adjust the rotation of the body of the image in a document, use the DocumentShear method to correct rotation within the body of the image text. (For example, if an image, like a page of a book, was not flat when scanned, the resulting digital image text may be skewed. The Deskew method will correct rotation of the entire page, but will not address skew within the text body of the image. In this instance DocumentShear may be a more useful method.)

Remove Specks or Blobs

To eliminate small specks or larger black objects, use one of the following:

  • The Despeckle method removes black specks from an image.
  • To remove small specks from a black and white document, use the DocumentDespeckle method, which has been optimized for 1-bit images and which provides feedback on the number of specks found (CountOfSpecsFound).
  • To remove larger black objects from a black and white document, such as binder punch holes, use the DocumentBlobRemoval method. This method sets the CountOfObjectsFound property.
  • If the image is a photo, you may wish to use the RemoveDust method, which has been optimized to remove black or white specks from color images. (Note: You must define an area to be processed, using the SetArea method prior to using the RemoveDust method.)

Remove Lines or Scratches

To eliminate lines or scratches from the image, use one of the following:

  • If the image is a black and white document, use the DocumentLineRemoval method. This method sets the CountOfLinesFound property.
  • If the image is a photo, use the RemoveScratches method to remove scratches from the image. (Note: You must define an area to be processed, using the SetArea method prior to using the RemoveScratches method.)

Identify Blank Pages

To identify blank pages in a document, call the DocumentBlankPageDetect method. The BlankPageDetected and Confidence properties are set with the results of the DocumentBlankPageDetect method.

Clarify Letters and Lines

ImagXpress offers a number of methods, aimed at clarifying and smoothing letters and lines:

Dilate: To enhance/fill in divots in black letters and lines, use Dilate. If the image is black and white, you can use the DocumentDilate method, which has been enhanced for black and white images.

Erode: To reduce/erase protrusions from black letters and lines, use Erode. If the image is black and white, you can use the DocumentErode method, which has been enhanced for black and white images.

Smooth: If the image is black and white, you can use the DocumentZoomSmooth method. This method smooths letters and lines, by first doubling their width and height, then dilating and eroding as required.

Remove Edges or Borders

To remove borders of an image, use one of the following methods:

  • Crop borders using the CropBorder method, specifying the type of crop (cropType) and threshold for recognizing the border (percentToCrop).
  • Automatically crop edge space from an image, using the AutoCrop method.
  • If the image is black and white, the DocumentBorderCrop method can be used to automatically crop the borders of the document. This method has been enhanced for black and white images and sets the Confidence property to indicate the confidence of the DocumentBorderCrop result.
See Also

Select an Area or Region to Process | Modify Image Size and Orientation | Apply Image Effects | Merge Images | Modify Alpha Channel | Correct Color and Contrast | Create a Processor | Remove Redeye


Remove Redeye

To reduce the red reflection of the flash seen in the eyes of people in color flash photo images, use one of the following Processor methods:

Manual Red Eye Removal

Manually remove redeye from eyes in the image, using the RemoveRedeye method. (Note: You must define an area to be processed, using the SetArea method prior to using the RemoveRedeye method.)

Automatic Red Eye Removal

Automatically remove redeye from eyes in the image, using the AutoRemoveRedeye method.

The AutoRemoveRedeye method will accurately correct red eyes without modifying elements in the photo which are not eyes, in most cases without any intervention.

Optimized Red Eye Removal

As with any algorithm, there is a potential for false positives (modifications of areas that are not eyes), or red eyes that are not corrected in some images.

To provide the application with maximum control over this behavior, the AutoRemoveRedeye method returns all areas that have been corrected as a collection of rectangles. The rectangles identify areas in which red-eyes were detected and corrected and a value indicating the confidence that the area corrected was a red eye. This enables the application to set an acceptable level of false positives and optimize red-eye correction.

For example, an application could do the following:

(1) Enable the undo method by setting ImageX.UndoEnabled = True.

(2) Correct redeyes, by calling Processor.AutoRemoveRedeye, specifying desired eyeshade, desired eye glare and setting UseEditRectangles to False. (When UseEditRectangles is True, previously detected rectangles will be used to correct red eyes. When UseEditRectangles is False, existing rectangles are ignored.) The AutoRemoveRedeye method removes red eyes from the image and sets the rectangles property to the collection of rectangles in which red eyes were detected and corrected.

To correct redeyes without displaying the results, disable paint by setting ImageX.AutoInvalidate = False prior to calling Processor.AutoRemoveRedeye.

(3) Search and reverse any false positives

A. Enumerate through the collection of rectangles, starting at "1" through Processor.Redeyes.Count.

B. Determine if a rectangle erroneously identified an area as containing red eyes, either by visual inspection or by determining that confidence values are below the desired threshold.

This threshold could be set by either the application end-user or the application programmer.
              • If the goal is to minimize false positives (modification of areas that aren't red eyes), keep only rectangles that have a very high confidence level. This will result in fewer red-eyes that are corrected, but may reduce the false positives.
              • If the goal is to maximize the number of red-eyes corrected, keep rectangles with a lower confidence level as well. This will result in more red-eyes corrected, but may increase the false positives.

C. Call Processor.Redeyes.RemoveRectangle to delete rectangles associated with any regions that should NOT be corrected.

(4) Add red eyes that were not automatically corrected, if any, as follows:

A. Identify any remaining red eyes (visually).

B. Draw a rectangle around the remaining eyes. (Use rubberband, region, or area).

C. Add the rectangle to the rectangle collection, by calling Processor.Redeyes.

(5) Modify redeye regions size or position, using the properties within the RedeyeRectangle class.

(6) Correct red-eyes and display the image as follows:

A. Undo the previous AutoRemoveRedeye by calling Processor.ImageX.Undo.

B. Enable painting, by setting ImageX.AutoInvalidate = True

C. Correct redeyes, by calling Processor.AutoRemoveRedeye, setting UseEditRectangles to True.

See Also

Select an Area or Region to Process | Modify Image Size and Orientation | Apply Image Effects | Merge Images | Modify Alpha Channel | Correct Color and Contrast | Cleanup Images | Create a Processor


Apply Image Effects

ImagXpress® provides methods and properties to support a variety of image processing effects, using the methods within the Processor class:

Color & Lightness Effects

Binarize - The Binarize method operates on 1-bit and 24-bit input DIB's, permanently modifying it to a 1-bit or 8-bit grayscale DIB of the same dimensions.

Negate - The Negate method creates a color negative of the image.

Solarize - The Solarize method negates the colors beyond the threshold value.

ReplaceColors - The ReplaceColors method replaces a range of colors in the current image.

Posterize - The Posterize method reduces the number of colors in the image, to give the effect of contours in the image.

Emboss - The Emboss method transforms the image to give it a raised metallic-like look.

Parabolic - The Parabolic method adjusts the brightness of the image based on either a convex or concave parabolic transform, as specified. The convex parabolic transform darkens the pixels at the high and low range of the image's brightness spectrum and brightens the pixels in the middle range. The concave parabolic transform brightens the pixels at the high and low range of the image's brightness spectrum and darkens pixels in the mid-range.

Blending Effects

Blend -The Blend method blends each pixel in the image with its neighboring pixels.

Diffuse - The Diffuse method replaces each pixel in the image with a randomly selected neighboring pixel.

Median - The Median method uses a 3x3 median filter to blend in the current image.

Sharpness Effects

Blur - The Blur method blurs the image to give it an 'out of focus' appearance.

MotionBlur - The MotionBlur method creates a motion blur effect in the image.

Sharpen - The Sharpen method sharpens the image by applying a high pass convolution filter.

Soften - The Soften method softens the image by applying a low pass convolution filter.

Unsharpen - The Unsharpen method sharpens edges within the image, but softens other areas.

Special Effects

Perspective - The Perspective method changes the aspect for each row and column of pixels to give the effect of an altered perspective.

Swirl - The Swirl method transforms the image, making it look as if it were swirled from the center.

Twist - The Twist method transforms the image, by dividing the image into square blocks and rotating each block.

Ripple - The Ripple method produces a wave-like ripple effect in the image.

Pinch - The Pinch method transforms the image to make it appear "pinched" in the center.

PolynomialWarp - The PolynomialWarp method resizes and warps the image based on four defined points within the image.

Buttonize - The Buttonize method transforms the image to make it look like a 3D button by adding translucent bevels to the edges of the image.

Outline - The Outline method enhances the edges in an image so that objects appear outlined.

Tile - The Tile method tiles the image.

Mosaic - The Mosaic method creates a pixelated version of the image.

Noise - The Noise method adds noise to the image.

See Also

Select an Area or Region to Process | Modify Image Size and Orientation | Merge Images | Modify Alpha Channel | Correct Color and Contrast | Cleanup Images | Create a Processor | Remove Redeye


Modify Alpha Channel

ImagXpress® supports processing alpha channel information to manage transparency in images. Alpha channels are supported for PNG, Targa, and TIFF files. While not typical, ImagXpress also supports alpha channel for BMP and ICO files. If the image is saved to a format which does not support alpha channel, the alpha channel will be dropped.

Adding Alpha Channel to an Image

To add an alpha channel to a 24-bit image, call Processor.AlphaAdd, specifying an hBitmap or bitmap with the desired alpha channel information. The Processor.Image property converts to a 32 bit image, including the new alpha channel.

The Processor.Image must be 24-bit prior to calling Processor.AlphaAdd, or an exception is thrown.

Removing an Alpha Channel from an Image

To remove an alpha channel from a 32 bit image, call Processor.AlphaRemove method, which converts the Processor.Image to a 24-bit image without an alpha channel. The alpha channel information is not saved.

The Processor.Image must be a 32 bit image including alpha information prior to calling Processor.AlphaRemove, or an exception is thrown.

Flattening an Alpha Channel Image

Call Processor.AlphaFlatten to blend the 32 bit alpha channel plane with a specified color to create a blended 24-bit image. The resulting image has transparency information stored in the specified color within the 24-bit color spectrum.

The Processor.Image must be a 32 bit image including alpha information prior to calling Processor.AlphaFlatten, or an exception is thrown.

Reading Alpha Channel Information

To get the alpha value at a specified X and Y location in the image, call Processor.AlphaGet.

To get the entire alpha channel plane associated with the image, call Processor.AlphaBitmapReturn. The alpha plane stores to a bitmap or HBitmap, as specified.

Modifying Alpha Channel Information

To set an alpha value at a specified X and Y location in the image, call Processor.AlphaSet.

To modify transparency levels across the image, select one of the following options:

  • Call Processor.AlphaInvert to invert the alpha values throughout the image, so that what was opaque becomes transparent and vice versa.
  • Call Processor.AlphaFill to fill a specified region within the alpha image with a specified value.
    If no region is specified, the entire alpha channel is set with the specified value.
See Also

Select an Area or Region to Process | Modify Image Size and Orientation | Apply Image Effects | Merge Images | Correct Color and Contrast | Cleanup Images | Create a Processor | Remove Redeye


Glossary Item Box

Create a Processor | Select an Area or Region to Process | Modify Image Size and Orientation | Modify Image Bit Depth | Correct Color and Contrast | Cleanup Images | Remove Redeye | Apply Image Effects | Modify Alpha Channel | Undo a Processing Action

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Merge Images

Merging is the operation of combining the current image being processed (Processor.Image property), with another ImageX image. The resulting merged image is stored in Processor.Image.

To merge images, call Processor.Merge.

If either of the images being merged has a bit depth of less than 24-bits, then both images are converted to 24-bit images, then merged.
If either of the images being merged has an associated color profile, then each image's profile is applied, then the images are merged. No color profile is retained.
Using Sprite offers limited capability of merging a part of an image with another one.

See Also

Create a Processor | Select an Area or Region to Process | Modify Image Size and Orientation | Modify Image Bit Depth | Correct Color and Contrast | Cleanup Images | Remove Redeye | Apply Image Effects | Modify Alpha Channel | Undo a Processing Action


Undo a Processing Action

You can check Processor.ImageWasModified property at any time to determine whether the image was modified by the last processing action. (If an error occurs during processing, the processing action is discontinued and the image is not modified.)

Enable Undo Capability

The Undo capability enables you to undo the action of a processing method. To use the Undo capability, make sure ImageX.UndoEnabled property is set to True. This enables the undo feature for a specific image, prior to performing image processing.

When ImageX.UndoEnabled is True, additional memory is required to store the undo image.

If Undo is not needed, set ImageX.UndoEnabled to False, to reduce memory usage.

Undo a Processing Action

To undo the image processing action, call the ImageX.Undo method. The current image is replaced with the Undo image, restoring the image to its original state.

Only image processing actions can be undone. Changes to ICM, loading and saving cannot be undone.

See Also

Save Image to File | Save Image to Bitmap or DIB | Cancel | Save Image to Stream


Annotate an Image

Once an image has been loaded into ImagXpress®, it can be annotated using the NotateXpress™ control.

See Also

Print an Image | Create a Viewer | Free the Controls' Resources | Draw on the Image


Print an Image

ImagXpress® enables you to print an image, using either ImagXpress or PrintPRO™:

Print the Image Using ImagXpress

The image is sent to a specified Graphics object, which is associated with a printer device context.

C# Example:

// This code demonstrates how to print the image from ImagXView

ImageXView.Print

Color Management while Printing an Image Using ImageXpress

Image Color Management (ICM) is performed to ensure that the image has a very similar appearance, regardless of the device on which it is displayed or printed. When printing an image, the image must be converted to the device-specific color space of the specified printer. This conversion can be done at a number of different points in the process:

  • Prior to loading the image into ImagXpress
  • By ImagXpress
  • By PrintPRO
  • By the printing device

To perform color management within ImagXpress:

  1. Ensure that ImageXView.IcmEnabled is set to True.
  2. Specify how to apply profiles, by setting the ImageXView.ColorRenderIntent property (for example, Picture, Graphics, Business or Colorimetric interpretation.)
  3. Enable color management of an image to be proofed, by setting ImageXView.ICMProofingEnabled to True.
  4. Set the ImageXView.TargetProfileName to the profile to use when proofing the image. When ICMProofingEnabled is True, this profile overrides the ImageXView.PrinterProfileName property. This can be helpful if proofing occurs on a printer or ink different from the destination printer.
  5. Specify the color profile to use when performing ICM on an image to be printed (PrinterProfileName). Setting PrinterProfileName doesn't change the profile name stored with the printer device context - it simply specifies the color profile ImagXpress uses with ICM.
  6. Send the image to the specified device, or PrintPRO, for printing.

Print the Image Using PrintPRO

The ImageXView.Print method requires a graphics object. However, in some containers, this may not be available. In this case, PrintPRO provides a vehicle to print to a selected printing device. PrintPRO may also provide the best solution if you require a customized printer interface and programmatic control over printing functions.

To save the image using PrintPRO, pass the image from ImagXView to PrintPRO. Use PrintPRO to compose the printed page, select a printing device and print to that device.

See Also

Create a Viewer | Annotate an Image | Draw on the Image


Specify Save Options

Prior to saving an image, specify the image's save options, by setting the properties below. Save options specify critical image saving information, including:

General Saving Options

  • The SaveOptions.Format property specifies the type (format) of the saved file.

Image Color Management Saving Options

  • To perform no color management when saving, set SaveOptions. UseEmbeddedColorManagement = False.
  • To perform color management using the color profile specified in the ImageX image metadata:
    1. Set SaveOptions.UseEmbeddedColorManagement = True
    2. Specify how profiles should be applied, by setting the SaveOptions. ColorRenderIntent property (for example, Picture, Graphics, Business or Colorimetric interpretation.)
    3. The image is modified, to reflect the color profile, then saved.

To perform color management using a color profile specified in a file:

  1. Set SaveOptions.UseEmbeddedColorManagement = False.
  2. Specify how profiles should be applied, by setting the SaveOptions.ColorRenderIntent property (for example, Picture, Graphics, Business or Colorimetric interpretation.)
  3. Set the SaveOptions. TargetProfileName to the name of the color profile you wish to apply to the image being saved
  4. The image is modified to reflect the color profile, then saved.

FTP Saving Options:

To enable saving to a remote location, set the SaveOptions. Internet property as needed, to specify network credentials and proxy settings.

Annotation Saving Options:

  • The SaveOptionsAnnotations.Save property specifies whether annotations should be saved when the image is saved.
  • The SaveOptionsAnnotations.View property specifies which view of the annotations should be saved (the annotations associated with the ImageXView object at a point in time). If View is null, the most recent ImageXView annotations are saved.

Image Format-Specific Save Options:

EXIF (SaveOptionsExif)

  • Thumbnail Size: The ThumbnailSize specifies the size (in pixels) of the thumbnail to be saved.

DCX (SaveOptionsDcx)

  • Multi page file: The MultiPage property specifies that the image is being saved to a multi-page file.

HDPhoto

  • ChromaSubSampling:
  • FrequencyOrder:
  • Quantization:

Icon (SaveOptionsIcon)

  • Multi page file: The MultiPage property specifies that the image is being saved to a multi-page file.

PIC (SaveOptionsPic)

  • Password: The Password property specifies the password for an ePIC (.PIC) format file.

PDF (SaveOptionsPdf)

  • Compression type: The Compression property specifies the PDF compression type for saving a PDF file.
  • Black and white: The SwapBlackAndWhite property indicates whether a pixel value of 0 is used to represent black in the saved image (standard), or whether a pixel value of 1 is used to represent black in the saved image.
  • Color space: The ColorSpace property specifies the color space of the image (rgb, cmyk)
  • Multi page file: The MultiPage property specifies that the image is being saved to a multi-page file.

PNG (SaveOptionsPng)

  • Format type: The Interlaced property specifies whether a PNG file is to be saved in the interlaced format.
  • Transparency: The TransparencyColor specifies the color used to represent transparency. The TransparencyMatch specifies how to match image pixels to the transparency color. Transparency can be applied on pixels that are an exact match to the TransparencyColor, the closest match to the TransparencyColor, or not at all.

PBM, PGM, PPM (SaveOptionsPortable)

  • Format type: The Type property specifies whether the file is to be stored in binary or ASCII format.

GIF (SaveOptionsGif)

  • Format type: The Type property specifies the GIF format for saving a GIF file.
  • Transparency: The TransparencyMatch and SaveOptionsGif.TransparencyColor properties specify how transparency information will be saved in the file.
  • Interlaced: The Interlaced property indicates whether the GIF file is saved in the interlaced format.

TIFF (SaveOptionsTiff)

  • Byte order: The .ByteOrder property indicates the byte order for saving a TIFF file.
  • Compression type: The Compression property specifies the TIFF compression type for saving a TIFF file.
  • Rows: The RowsPerStrip property specifies the number of rows to save in each strip of a TIFF file.
  • Color space: The ColorSpace specifies the color space of the image being saved.
  • Multipage: The MultiPage property specifies whether the image is being saved to a multi-page file.

JBIG2(SaveOptionsJbig2)

  • Encoding mode: The EncodeModeCompression property specifies the encoding mode to use when creating the JBIG2 file.
  • File organization: The FileOrganization property specifies the file organization of the JBIG2 bit stream.
  • Invert bits: The InvertedRegion property specifies whether the bits should be inverted prior to symbol analysis.
  • Looseness: The LoosenessCompression property specifies how loose to be when matching symbols and compressing text using either of the lossy text region encode modes.

JPEG, TIFF-JPEG and ePIC files (SaveOptionsJpeg)

  • Quality Level: The Chrominance property specifies the chrominance quality setting. The Luminance property specifies the luminance quality setting to use when saving the file. The SubSampling property specifies the sub-sampling type (which affects color sharpness).

For higher quality and lower compression, set Luminance and Chrominance in the low teens and set SubSampling to 1:1:1 compression.

For higher compression and lower quality, set Luminance and Chrominance in the low 20’s and set SubSampling to 4:1:1 compression
  • Gray Scale: The Grayscale property specifies whether the file is saved as a gray scale file. The SaveOptionsJpeg.Cosited property specifies whether the image is compressed with cosited subsampling when saved. The SaveOptionsJpeg.Progressive property specifies whether JPEG files are to be saved as standard or progressive files.
  • Color Space: The ColorSpace property specifies the image's color space.

Lossless JPEG (SaveOptionsLjp)

  • The Type property specifies the type of compression used for saving a lossless JPEG file (Rgb, Ycbcr).

JLS (SaveOptionsJls)

  • Interleave Mode: The Interleave property specifies the interleave mode for JLS compression.
  • Point Transform: The Point property specifies that an optional point transform should be applied to the image data for compressing JPEG-LS files.
  • Near: The Near property specifies the error tolerance for near-lossless compression.
  • MaxValue: The MaxValue property enables you to specify the desired setting for the MaxValue parameter used in compression.

JPEG 2000 (SaveOptionsJp2)

  • Compression Type: The Type property specifies whether the compression is lossy or lossless.
  • Compressed Size: The CompressSize property specifies the desired size of the target file.
  • Progression Order: The Order specifies the progression order of the saved JPEG2000 file.
  • Tile Dimensions: The TileSize specifies the tile dimensions for the saved image.
  • Grayscale: The Grayscale property specifies whether the saved image will be grayscale or color.

WSQ (SaveOptionsWsq)

  • Black and White Levels: The Black and White properties specify the level of black and white used in the compression of the saved WSQ file.
  • Quantization: The Quantization property specifies the quantization of the saved WSQ file.


Save Image to File

Prior to saving an image, set the SaveOptions to provide specific instructions for saving the image. If no save options are specified, ImagXpress® uses default values when saving the image.

Save to a Local Disk File

To save an image to a file, use the ImageX.Save methods. ImagXpress converts and compresses the image to the file format specified, and saves it to the target location. While ImagXpress is compressing and saving the image, the ImageX.ImageStatus and Progress events provide information on the status of the operations.

Save to an FTP Location

ImagXpress supports saving image files to an FTP locations, as follows:

1. To specify passwords or proxy settings, set the Internet property within SaveOptions

2. Call one of the following:

ImageX.Save(String,SaveOptions)

ImageX.Save(String)

Make sure that the String parameter specifies the full internet path and file name.

3. A copy of the ImageX image is stored in the target location.

Save a Multi-Page Image

ImagXpress supports the following multi-page image formats: TIFF, PDF, ICO and DCX. Multi-page images can be compressed and saved in the Document and Photo editions.

C# Example:

// This code demonstrates saving a multi-page image

SaveOptions soOpts = new SaveOptions();
soOpts.Format = ImageXFormat.Tiff;
soOpts.Tiff.Compression = Compression.Group4;
soOpts.Tiff.MultiPage = true;
ImgX.Image = ImageX.FromFile(strFileName);
for (int i = 1; i <=ImgX.Image.PageCount; i++)
{
ImgX.Image.Page = i;
ImgX.Image.Save("c:\\multipagetest.tif",Opts);
}

ImagXpress does not support saving to a multipage image at an HTTP or FTP location.
See Also

Undo a Processing Action | Save Image to Bitmap or DIB | Cancel | Save Image to Stream


Save Image to Stream

Prior to saving an image, set the SaveOptions to provide specific instructions for saving the image. If no save options are specified, ImagXpress® uses default values when saving the image.

Save to Stream

To save an image to a memory or file stream, call ImageX.SaveStream. The ImageStatusEvent and ProgressEvent events are raised to provide feedback on the status of the saving process.

To save to a BLOB (Binary Large Object), use the ImageX.SaveStream method.
To save a file to an internet stream, use the ImageX.Save method, specifying the full internet path and file name, NOT the SaveStream method.

Saving a Multi-page Image To Stream

ImagXpress® uses the standard Windows WinInit API to retrieve and store image streams from HTTP/HTTPS (read only) and FTP sites (read and write).

To save an ImageX image to stream,

  1. Create a stream object, derived from the System.IO.Stream
  2. Call the ImageX.SaveStream method.

C# Example:

// This code demonstrates saving a multi-page image to stream

SaveOptions soOpts = new SaveOptions();
soOpts.Format = ImageXFormat.Tiff;
soOpts.Tiff.Compression = Compression.Group4;
soOpts.Tiff.MultiPage = true;
ImgX.Image = ImageX.FromFile(strFileName);
for (int i = 1; i <=ImgX.Image.PageCount; i++)
{
ImgX.Image.Page = i;
ImgX.Image.Save("c:\\multipagetest.tif",Opts);
}

Images can be compressed and saved in the Document and Photo editions.
See Also

Undo a Processing Action | Save Image to File | Save Image to Bitmap or DIB | Cancel


Save Image to Bitmap or DIB

Images can be saved from ImagXpress® to a bitmap or DIB as follows:

  • Call the ImageX.ToBitmap method to save to a bitmap.
  • Call the ImageX.ToHbitmap method to save to a bitmap handle.
  • Call the ImageX.ToHdib method to transfer ownership of a DIB handle.

When calling these methods, you must specify whether the ImageX object retains ownership of the image or releases it.

  • If the release parameter is set to True, the image is deleted from the ImageX object. The ImageX object remains, but is empty.
  • If the release parameter is set to False, then the ImageX object continues to contain the image. A copy of the image is made and returned by the methods above.
See Also

Undo a Processing Action | Save Image to File | Cancel | Save Image to Stream


Free the Controls' Resources

Because ImagXpress® encapsulates unmanaged resources, the Dispose method must be called for each instance of each component, to allow the release of all resources. A recommended approach is to dispose these objects when their container is disposed. To do this, call the Dispose method from the container. Since some of the components within the ImagXpress Product Family have dependencies on the ImagXpress component, you should dispose the ImagXpress objects last.

C# Example:

// This code demonstrates that in all .NET Windows Forms applications, you will find a generated call to Dispose, which can be modified as follows:

protected override void Dispose (bool disposing)

{

if (disposing)

{

if (components != NULL)

{

components.Dispose();

}

// added for ImagXpress,

// dispose the ImagXpress control last.

// The application developer is not required to call Dispose at this location. The Developer can make the call to clean up these resources at any time during the container's lifetime.

PrintPRO.Dispose();

TwainPRO.Dispose();

NotateXpress.Dispose();

ThumbnailXpress.Dispose();

ImageXView.Dispose();

Processor.Dispose();

ImagXpress.Dispose();

}

base.Disposing(disposing);

}

In addition, any objects that are created dynamically at run time (e.g. ImageX), must call their Dispose method to allow resources to be released when the object is no longer needed.

C# Example:

// When ColorSeparation is called with handles specified for each of the color planes,

// call ImageX.DisposeHbitmap to release the resources associated with the handles after use.

// When the ImageX object is not longer needed, Dispose it.

See Also

Print an Image | Create a Viewer | Annotate an Image | Draw on the Image | ImageX Class | Dispose Method


Debug

To generate a debug log file, set Debug to true. The log file is kept at the location specified by DebugLogFile. Set the DebugErrorLevel to Development or Detailed to indicate the level of detail logged.

To view Error Codes, go to Enumerations.Result.

See Also

Getting Support and Samples | Debug Property | DebugLogFile Property | DebugErrorLevel Property | Result Enumeration


See Also

PegasusImaging.WinForms.ImagXpress9 Assembly

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PegasusImaging.WinForms.ImagXpress9 Namespace

Inheritance Hierarchy

Classes

Class | Description
AutoResizeChangedEventArgs | This class implements event data for AutoResizeChanged events.
CadLayer | This class contains information about a layer in a CAD file.
CadLayout | This class describes one Layout within a given CAD Data File.
IcmException | This class implements exceptions for the Icm objects.
ImageCalsCollection | This class implements a collection of ImageCalsTag objects.
ImageCalsTag | This class implements methods and properties for the Cals tag data.
ImageStatusEventArgs | This class contains object data for Image Status events.
ImageX | This class implements basic operating functionality for the ImagXpress component.
ImageXData | Implements image information pertaining to the current image.
ImageXException | This class implements exceptions for the ImageX objects.
ImageXIptcCollection | A collection for Iptc meta-data.
ImageXIptcData | A class for IPTC meta-data information.
ImageXTag | This class holds TIFF and EXIF tags.
ImageXTagCollection | A collection of ImageXTag objects.
ImageXView | Implements the properties, methods and events for the viewer control.
ImageXViewException | This class implements exceptions for the ImageXView objects.
ImagXpress | Implements methods and properties for the ImagXpress component.
ImagXpressDefaultContextMenu | Summary description for ImagXpressDefaultContextMenu.
ImagXpressException | This class implements handling errors and exceptions for ImagXpress objects.
InternetException | This class implements exceptions for the Internet objects.
InternetOptions | This class implements functionality for Internet options.
Licensing | The Licensing class determines the license edition, add-on licensing, behavior, and unlock methods.
LoadOptions | The LoadOptions class includes various formats and image types to load into ImagXpress.
LoadOptionsCad | This class contains the CAD data objects options when loading CAD files.
LoadOptionsHdPhoto | This class implements load options for the HD Photo file format.
LoadOptionsJbig2 | This class implements load options for the Jbig2 file format.
LoadOptionsJpeg | This class implements load options for the JPEG file format.
LoadOptionsMetafile | This class implements load options for metafiles.
LoadOptionsPdf | This class implements load options for PDF files.
LoadOptionsPic | This class implements the load options for the Pegasus Imaging Corporation file format.
LoadOptionsRaw | This class specifies image information that cannot be detected when loading a RAW image format.
LoadOptionsTiff | This class implements the load options for TIFF files.
LookupTable | A class for specifying a lookup table to be used with the Medical class.
Medical | The Medical class is an encapsulation of the properties needed to do a DICOM (Digital Imaging and Communications in Medicine) grayscale transformation.
PaintImageEventArgs | Provides data for the ImageXView.PaintImage event.
PrintImageEventArgs | Provides data for the ImageXView.PaintImage Event.
Processor | This class implements methods and properties to enhance, edit and modify images.
ProcessorException | This class implements exceptions for the Processor objects.
ProgressEventArgs
RedeyeCollection | Summary description for RedeyeCollection.
RedeyeRectangle | Summary description for RedeyeRectangle. AutoRemoveRedeye generates rectangle areas of objects thought to be redeyes and have been corrected (red removed). Because some objects looking like redeyes but are not are identified and corrected (false positives) and some redeyes not looking like what they are and are not corrected (missed negatives), a list of rectangles is automatically generated. These rectangles are available to the user (application) for analysis and corrective action. The user can redo the correction by editing the rectangle list, reload the picture and apply the AutoRemoveRedeye method again but indicating the method to use the existing list. Each RedeyeRectangle has five members describing the area of the redeye found and the likelyhood that the object was correctly identified. The X and Y position indicate the top left corner of the rectangle and The Width and Height denote the rectangle dimensions. The Confidence parameter indicates how likely the area identified is indeed a redeye object.
ResizedEventArgs | This class implements event data for Resized events.
Resolution | This class contains properties and methods for the resoluion of an image.
Rubberband | This class implements methods and properties for part or all of an image to be selected within a dashed rectangular area.
SaveOptions | This class implements file writing of image formats.
SaveOptionsAnnotations | This class implements options required to save annotations with the image.
SaveOptionsDcx | This class implements the SaveOptions for the DCX file format.
SaveOptionsExif | This class implements the SaveOptions for the EXIF file format.
SaveOptionsGif | This class implements the SaveOptions for the GIF file format.
SaveOptionsHdp | This class implements SaveOptions for the Hdp file format.
SaveOptionsIcon | This class implements SaveOptions for the Icon file format.
SaveOptionsJbig2 | This class implements SaveOptions for the Jbig2 file format.
SaveOptionsJls | This class implements SaveOptions for the JLS file format.
SaveOptionsJp2 | This class implements SaveOptions for the JP2 file format.
SaveOptionsJpeg | This class implements SaveOptions for the JPEG file format.
SaveOptionsLjp | This class implements the SaveOptions for the LJP file format.
SaveOptionsPdf | This class implements the SaveOptions for PDF files.
SaveOptionsPic | This class implements SaveOptions for the PIC (Pegasus Imaging Corporation) file format.
SaveOptionsPng | This class implements SaveOptions for the PNG file format.
SaveOptionsPortable | This class implements SaveOptions for Portable graphics.
SaveOptionsTiff | This class implements the SaveOptions for TIFF formats.
SaveOptionsWsq | Implements the SaveOptions for the WSQ file format.
ScrollbarVisibleChangedEventArgs | This class implements event data for ScrollbarVisibleChanged events.
ScrollEventArgs | This class implements event data for scroll events.
Sprite | This class implements a temporary image area.
Toolbar | This class implements toolbar functionality.
ToolbarCloseEventArgs | This class contains information associated with a ToolbarCloseEvent.
ToolbarContextMenu | This class implements the context menu associated with the ImagXpress toolbar.
ToolbarContextMenuEventArgs | This class implements the event arguments for when a ToolbarContextMenuSelect event is fired.
ToolbarEventArgs | This class implements event data for toolbar events.
ToolbarOpenEventArgs | This class implements information associated with a ToolbarOpenEvent.
ToolEventArgs | This class implements event data for tool events.
WorkerImports | Summary description for WorkerImports.
ZoomFactorChangedEventArgs | This class implements event data for ZoomFactorChanged events.

Enumerations

Enumeration | Description
AdjustType | Option values used to indicate the adjustment type.
AlignHorizontal | Option values indicating the horizontal alignment setting.
AlignVertical | Option values indicating the vertical alignment setting.
AreaRegionOption | Option values which determine the area and region settings.
AutoResizeType | Option values for use with the ImageXView.AutoResize property.
BinarizeBlur | Option values used to determine what type of blur functionality to use during the Processor.Binarize method.
BinarizeMode | Option values used to determine what Processor.Binarize functionality to use.
BorderType | Option values for use with the ImageXView.BorderType property.
ButtonStyle | Option values to indicate button display style.
ByteOrder | Option values used to specify the TIFF file byte order.
CadFileType | Option values which determine the CAD file type.
CadUnit | Option values which determine the CAD (Computer Aided Design) units of measure.
CadVersion | Option values which determine the CAD version.
ClipboardFormat | Option values of possible formats to use with the clipboard.
ColorSpace | Option values which designate the color space.
Compression | Option values which determine the image compression type.
ContrastMethod | Option values used to determine which Processor.ContrastMethod property value to use.
CropType | Option values which indicate what type of crop to perform.
DebugErrorLevel | Option value which determine the error level of items to place into the debug log.
DefectType | Option values to indicate the defect type to process.
DeskewType | Option values to indicate deskew settings for image correction.
DisplayMode | Option values indicating the maximum color depth used to render an image.
DitherType | Option values used to determine the dither type to perform.
EnhancementDirection | Option values used to determine enhancement direction.
EvaluationMode | Option values that indicate ImagXpress behavior when installed on a development machine when in evaluation mode.
FtpMode | Option values used for FTP (File Transfer Protocol) mode.
GifType | Option values for GIF file format.
GrayMode | Option values to indicate the type of Gray Mode to utilize.
HdpPostProcessFilter | Open option filtering on Hdp files
HdpSubSampling | Option values for subsampling type for a Hdp file format.
ImageStatus | Option values which specify the status of an image.
ImageXFormat | Option values which specify the file format.
ImageXPixelFormat | Option values which determine the pixel formats currently being used.
ImageXViewBorderStyle | Option values for use with the ImageXView.BorderStyle property.
Jbig2EncodeModeCompression | Option values used to specify the encoding mode to use when creating the Jbig2 file.
Jbig2FileOrganization | Option values used to specify the file organization of the Jbig2 bit stream.
JoinType | Option values used to determine what type of Processor.ColorJoin(JoinType,IntPtr,IntPtr,IntPtr,IntPtr) method to use.
Jp2Type | Option values used to determine JP2 file types.
LicenseEditionType | Options used to determine what type of user license agreement under which ImagXpress is operating.
LicenseStatus | Options for the status of the license.
LjpMethod | Lossless Jpeg Compression Method
LjpType | Option values used to specify the type of compression used for saving a lossless JPEG file.
LoadMode | Option values used to indicate the LoadOptions.LoadMode property.
MedicalPhotometricInterpretation | Option values used to determines whether a zero in the image data is black or white.
MergeSize | An enumeration used to determine the area/size the merge image is to be.
MergeStyle | Option values used to specify the style of the merge.
MouseWheelAction | Option values used in determining what type of mouse wheel action to perform.
MouseWheelAttribute | Option values used to manipulate the mouse wheel.
Operation | Option values used in determining what type of image operation to perform.
PaletteType | Option values used to set the palette type of the Processor.ColorDepth method.
ParabolicType | Option values used to determine the type of parabolic transform to perform.
PerspectiveType | Option values used to determine the type of perspective filter to apply.
PortableType | Option values to determine the type of file save format.
PrintType | Option values to determine the type of the print.
ProgressionOrder | Option values used to determine the progression order of a JPEG 2000 file being saved.
RedeyeGlare | Option values used in the Processor.RemoveRedeye method.
RedeyePrecision | Option values used as parameters in the Processor.RemoveRedeye method.
RedeyeShade | Option values used as parameters in the Processor.RemoveRedeye method.
RegionType | Option values that determine the type of shape a region takes.
RenderIntent | Option values for rendering colors by relative scale of spatial distnces, saturation, colors closest to inside values and distance to white point.
ResizeType | Option values used to determine what type of resize method to perform.
ResolutionUnits | Option values which determine the unit of measure for image reslution.
Result | Option values returned from image processing methods.
RippleDirection | Option values used with the Processor.Ripple method.
RotateAngle | Option values to determine what type of rotation, mirror, or image flipping functionality to invoke.
SeparationType | Option values used to determine what type of Processor.ColorSeparation(SeparationType,IntPtr,IntPtr,IntPtr,IntPtr) functionality.
SharpenFilter | Option values used in determining which type of Sharpen Filter to use.
ShearType | Option values used to determine the document shear direction.
SoftenFilter | Option values used in determining which type of Soften Filter to employ.
SubSampling | Option values for subsampling type for a JPEG, TIFF-JPEG or ePIC file format.
TagTypes | Option values which determine the type of TIFF tag.
ThumbnailSize | Option values used to determine the thumbnail size.
Tool | Option values used to determine the tool selected.
ToolAction | Option values used to determine what type of tool event has occurred.
ToolAttribute | Option values used to determine a tool's attribute value.
ToolCursor | Option values which determines the tool cursor to change.
TranslateType | Option values used in determing what type of translation to perform.
TransparencyMatch | Option values used to determine the type of TransparencyMatch property to invoke.
TwistRotation | Option values used in evaluating the rotation angle.
UnsharpenFilter | Option values used in determining what type of Processor.Unsharpen(Int32) method to apply.
ZoomToFitType | Option values to determine if the image fit is within the ImagXpress viewer control.

Delegates

Delegate | Description
ImageXView.AutoResizeChangedEventHandler | A handler for the auto resize changed event.
ImageXView.PaintImageEventHandler | A handler for the paint event.
ImageXView.PrintImageEventHandler | Handler for the print image event.
ImageXView.ResizedEventHandler | A handler for the resized event.
ImageXView.ScrollbarVisibleChangedEventHandler | Fires when the scrollbar visible changed event occurs.
ImageXView.ScrollEventHandler | A handler for the scroll event.
ImageXView.ToolbarCloseEventHandler | Handler for the toolbar close event.
ImageXView.ToolbarContextMenuSelectEventHandler | A handler for the toolbar context menu select event.
ImageXView.ToolbarEventHandler | Handler for the toolbar event.
ImageXView.ToolbarOpenEventHandler | Handler for the toolbar open event.
ImageXView.ToolEventHandler | Handler for the tool event.
ImageXView.ZoomFactorChangedEventHandler | A handler for the zoom factor event.
ImagXpress.ImageStatusEventHandler | Fires when there are image status events.
ImagXpress.ProgressEventHandler | Fires when there is a progress event.
Processor.ProgressEventHandler | A handler for the progress events.

See Also

PegasusImaging.WinForms.ImagXpress9 Assembly


AutoResizeChangedEventArgs Class

AutoResizeChangedEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AutoResizeChangedEventArgs Class

PegasusImaging.WinForms.ImagXpress9 Namespace : AutoResizeChangedEventArgs Class

This class implements event data for AutoResizeChanged events.

For a list of all members of this type, see AutoResizeChangedEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.ImagXpress9.AutoResizeChangedEventArgs

Syntax

[Visual Basic]
Public Class AutoResizeChangedEventArgs
   Inherits EventArgs
[C#]
public class AutoResizeChangedEventArgs : EventArgs
[C++]
public __gc class AutoResizeChangedEventArgs : public EventArgs
[C++/CLI]
public ref class AutoResizeChangedEventArgs : public EventArgs

See Also

AutoResizeChangedEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace


AutoResizeChangedEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AutoResizeChangedEventArgs Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : AutoResizeChangedEventArgs Class

AutoResizeChangedEventArgs overview

Public Constructors

Public Constructor AutoResizeChangedEventArgs Constructor The main constructor which initializes a new instance of the AutoResizeChangedEventArgs class.

Public Properties

Public Property NewValue | Gets the new value for the AutoResize property.
Public Property OldValue | Gets the old value for the AutoResize property.

See Also

AutoResizeChangedEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


AutoResizeChangedEventArgs Constructor

AutoResizeChangedEventArgs Class | AutoResizeChangedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AutoResizeChangedEventArgs Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > AutoResizeChangedEventArgs Class : AutoResizeChangedEventArgs Constructor (AutoResizeChangedEventArgs)

The main constructor which initializes a new instance of the AutoResizeChangedEventArgs class.

[Visual Basic]
Public Function New()
[C#]
public AutoResizeChangedEventArgs();
[C++]
public: AutoResizeChangedEventArgs();
[C++/CLI]
public:
AutoResizeChangedEventArgs();

See Also

AutoResizeChangedEventArgs Class | AutoResizeChangedEventArgs Members


AutoResizeChangedEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AutoResizeChangedEventArgs Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : AutoResizeChangedEventArgs Class

For a list of all members of this type, see AutoResizeChangedEventArgs members.

Public Properties

Public Property NewValue | Gets the new value for the AutoResize property.
Public Property OldValue | Gets the old value for the AutoResize property.

See Also

AutoResizeChangedEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


NewValue Property

AutoResizeChangedEventArgs Class | AutoResizeChangedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

NewValue Property

PegasusImaging.WinForms.ImagXpress9 Namespace > AutoResizeChangedEventArgs Class : NewValue Property (AutoResizeChangedEventArgs)

Gets the new value for the AutoResize property.

[Visual Basic]
Public ReadOnly Property NewValue As AutoResizeType
[C#]
public AutoResizeType NewValue {get;}
[C++]
public: __property AutoResizeType get_NewValue();
[C++/CLI]
public:
property AutoResizeType NewValue {
   AutoResizeType get();
}

Return Type

An AutoResizeType enumeration value.

Remarks

Note: Available in all editions.

See Also

AutoResizeChangedEventArgs Class | AutoResizeChangedEventArgs Members


OldValue Property

AutoResizeChangedEventArgs Class | AutoResizeChangedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

OldValue Property

PegasusImaging.WinForms.ImagXpress9 Namespace > AutoResizeChangedEventArgs Class : OldValue Property (AutoResizeChangedEventArgs)

Gets the old value for the AutoResize property.

[Visual Basic]
Public ReadOnly Property OldValue As AutoResizeType
[C#]
public AutoResizeType OldValue {get;}
[C++]
public: __property AutoResizeType get_OldValue();
[C++/CLI]
public:
property AutoResizeType OldValue {
   AutoResizeType get();
}

Return Type

An AutoResizeType enumeration value.

Remarks

Note: Available in all editions.

See Also

AutoResizeChangedEventArgs Class | AutoResizeChangedEventArgs Members


CadLayer Class

CadLayer Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CadLayer Class

PegasusImaging.WinForms.ImagXpress9 Namespace : CadLayer Class

This class contains information about a layer in a CAD file.

For a list of all members of this type, see CadLayer members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.CadLayer

Syntax

[Visual Basic]
Public Class CadLayer
   Implements IDisposable
[C#]
public class CadLayer : IDisposable
[C++]
public __gc class CadLayer : public IDisposable
[C++/CLI]
public ref class CadLayer : public IDisposable

See Also

CadLayer Members | PegasusImaging.WinForms.ImagXpress9 Namespace


CadLayer Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CadLayer Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : CadLayer Class

CadLayer overview

Public Properties

Public Property Frozen | Gets and indicator if the CAD File Layer is frozen by the author.
Public Property InUse | Gets an indicator if the CAD file layer is in use at the time it was saved.
Public Property LayerDescription | Gets the CAD layer description.
Public Property LayerName | Gets the CAD layer name.
Public Property LayerNumber | Gets and sets this layer's level.
Public Property LayerOn | Gets and sets an indicator if the CAD layer is on thus rendered (viewable).
Public Property Locked | Gets an indicator if the author has left the CAD layer locked.
Public Property Plottable | Gets an indicator if the CAD layer is plottable.

Public Methods

Public Method Dispose Releases all resources used by this object.

See Also

CadLayer Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Dispose Method

CadLayer Class | CadLayer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.ImagXpress9 Namespace > CadLayer Class : Dispose Method (CadLayer)

Releases all resources used by this object.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

See Also

CadLayer Class | CadLayer Members


CadLayer Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CadLayer Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : CadLayer Class

For a list of all members of this type, see CadLayer members.

Public Properties

Public Property Frozen | Gets and indicator if the CAD File Layer is frozen by the author.
Public Property InUse | Gets an indicator if the CAD file layer is in use at the time it was saved.
Public Property LayerDescription | Gets the CAD layer description.
Public Property LayerName | Gets the CAD layer name.
Public Property LayerNumber | Gets and sets this layer's level.
Public Property LayerOn | Gets and sets an indicator if the CAD layer is on thus rendered (viewable).
Public Property Locked | Gets an indicator if the author has left the CAD layer locked.
Public Property Plottable | Gets an indicator if the CAD layer is plottable.

See Also

CadLayer Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Frozen Property

CadLayer Class | CadLayer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Frozen Property

PegasusImaging.WinForms.ImagXpress9 Namespace > CadLayer Class : Frozen Property

Gets and indicator if the CAD File Layer is frozen by the author.

[Visual Basic]
Public ReadOnly Property Frozen As Boolean
[C#]
public bool Frozen {get;}
[C++]
public: __property bool get_Frozen();
[C++/CLI]
public:
property bool Frozen {
   bool get();
}

Return Type

A boolean value which is true if the CAD layer is frozen. Otherwise, false is returned.

Remarks

The default value is false.

See Also

CadLayer Class | CadLayer Members


InUse Property

CadLayer Class | CadLayer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

InUse Property

PegasusImaging.WinForms.ImagXpress9 Namespace > CadLayer Class : InUse Property

Gets an indicator if the CAD file layer is in use at the time it was saved.

[Visual Basic]
Public ReadOnly Property InUse As Boolean
[C#]
public bool InUse {get;}
[C++]
public: __property bool get_InUse();
[C++/CLI]
public:
property bool InUse {
   bool get();
}

Return Type

A boolean value which is true when the CAD layer is in use. Otherwise, false is returned.

Remarks

The default value is false.

See Also

CadLayer Class | CadLayer Members


LayerDescription Property

CadLayer Class | CadLayer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LayerDescription Property

PegasusImaging.WinForms.ImagXpress9 Namespace > CadLayer Class : LayerDescription Property

Gets the CAD layer description.

[Visual Basic]
Public ReadOnly Property LayerDescription As String
[C#]
public string LayerDescription {get;}
[C++]
public: __property string* get_LayerDescription();
[C++/CLI]
public:
property String^ LayerDescription {
   String^ get();
}

Return Type

A string value which represents the CAD layer description.

Remarks

The default value is an empty string "".

See Also

CadLayer Class | CadLayer Members


LayerName Property

CadLayer Class | CadLayer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LayerName Property

PegasusImaging.WinForms.ImagXpress9 Namespace > CadLayer Class : LayerName Property

Gets the CAD layer name.

[Visual Basic]
Public ReadOnly Property LayerName As String
[C#]
public string LayerName {get;}
[C++]
public: __property string* get_LayerName();
[C++/CLI]
public:
property String^ LayerName {
   String^ get();
}

Return Type

A string value which represents the name of the CAD layer.

Remarks

The default value is an empty string "".

See Also

CadLayer Class | CadLayer Members


LayerNumber Property

CadLayer Class | CadLayer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LayerNumber Property

PegasusImaging.WinForms.ImagXpress9 Namespace > CadLayer Class : LayerNumber Property

Gets and sets this layer's level.

[Visual Basic]
Public ReadOnly Property LayerNumber As Integer
[C#]
public int LayerNumber {get;}
[C++]
public: __property int get_LayerNumber();
[C++/CLI]
public:
property int LayerNumber {
   int get();
}

Return Type

An integer value which represents this layer's level.

Remarks

The default value is 0.

See Also

CadLayer Class | CadLayer Members


LayerOn Property

CadLayer Class | CadLayer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LayerOn Property

PegasusImaging.WinForms.ImagXpress9 Namespace > CadLayer Class : LayerOn Property

Gets and sets an indicator if the CAD layer is on thus rendered (viewable).

[Visual Basic]
Public Property LayerOn As Boolean
[C#]
public bool LayerOn {get; set;}
[C++]
public: __property bool get_LayerOn();
public: __property void set_LayerOn(
   bool value
);
[C++/CLI]
public:
property bool LayerOn {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true if the CAD layer is on. Otherwise, false is used.

Remarks

The default value is false.

See Also

CadLayer Class | CadLayer Members


Locked Property

CadLayer Class | CadLayer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Locked Property

PegasusImaging.WinForms.ImagXpress9 Namespace > CadLayer Class : Locked Property

Gets an indicator if the author has left the CAD layer locked.

[Visual Basic]
Public ReadOnly Property Locked As Boolean
[C#]
public bool Locked {get;}
[C++]
public: __property bool get_Locked();
[C++/CLI]
public:
property bool Locked {
   bool get();
}

Return Type

A boolean value which is true if the CAD layer is locked. Otherwise, false is returned.

Remarks

The default value is false.

See Also

CadLayer Class | CadLayer Members


Plottable Property

CadLayer Class | CadLayer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Plottable Property

PegasusImaging.WinForms.ImagXpress9 Namespace > CadLayer Class : Plottable Property

Gets an indicator if the CAD layer is plottable.

[Visual Basic]
Public ReadOnly Property Plottable As Boolean
[C#]
public bool Plottable {get;}
[C++]
public: __property bool get_Plottable();
[C++/CLI]
public:
property bool Plottable {
   bool get();
}

Return Type

A boolean value which is true if the CAD layer is plottable. Otherwise, false is returned.

Remarks

The default value is false.

See Also

CadLayer Class | CadLayer Members


CadLayout Class

CadLayout Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CadLayout Class

PegasusImaging.WinForms.ImagXpress9 Namespace : CadLayout Class

This class describes one Layout within a given CAD Data File.

For a list of all members of this type, see CadLayout members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.CadLayout

Syntax

[Visual Basic]
Public Class CadLayout
[C#]
public class CadLayout
[C++]
public __gc class CadLayout
[C++/CLI]
public ref class CadLayout

Remarks

It contains the name, width and height of the layout in terms of the layout CAD unit.

See Also

CadLayout Members | PegasusImaging.WinForms.ImagXpress9 Namespace


CadLayout Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CadLayout Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : CadLayout Class

CadLayout overview

Public Properties

Public Property Height | Gets the height of the CAD layout in CAD units.
Public Property LayoutNumber | Gets the number designated for the CAD layout.
Public Property Name | Gets the name of the CAD layout.
Public Property Unit | Gets the units of measurement for the CAD layout.
Public Property Width | Gets the width of the CAD layout in cad units.

See Also

CadLayout Class | PegasusImaging.WinForms.ImagXpress9 Namespace


CadLayout Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CadLayout Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : CadLayout Class

For a list of all members of this type, see CadLayout members.

Public Properties

Public Property Height | Gets the height of the CAD layout in CAD units.
Public Property LayoutNumber | Gets the number designated for the CAD layout.
Public Property Name | Gets the name of the CAD layout.
Public Property Unit | Gets the units of measurement for the CAD layout.
Public Property Width | Gets the width of the CAD layout in cad units.

See Also

CadLayout Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Height Property

CadLayout Class | CadLayout Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Height Property

PegasusImaging.WinForms.ImagXpress9 Namespace > CadLayout Class : Height Property (CadLayout)

Gets the height of the CAD layout in CAD units.

[Visual Basic]
Public ReadOnly Property Height As Double
[C#]
public double Height {get;}
[C++]
public: __property double get_Height();
[C++/CLI]
public:
property double Height {
   double get();
}

Return Type

A double value which represents the height.

See Also

CadLayout Class | CadLayout Members


LayoutNumber Property

CadLayout Class | CadLayout Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LayoutNumber Property

PegasusImaging.WinForms.ImagXpress9 Namespace > CadLayout Class : LayoutNumber Property

Gets the number designated for the CAD layout.

[Visual Basic]
Public ReadOnly Property LayoutNumber As Integer
[C#]
public int LayoutNumber {get;}
[C++]
public: __property int get_LayoutNumber();
[C++/CLI]
public:
property int LayoutNumber {
   int get();
}

See Also

CadLayout Class | CadLayout Members


Name Property

CadLayout Class | CadLayout Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Name Property

PegasusImaging.WinForms.ImagXpress9 Namespace > CadLayout Class : Name Property

Gets the name of the CAD layout.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property string* get_Name();
[C++/CLI]
public:
property String^ Name {
   String^ get();
}

Return Type

A string which represents the name of the CAD layout.

See Also

CadLayout Class | CadLayout Members


Unit Property

CadLayout Class | CadLayout Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Unit Property

PegasusImaging.WinForms.ImagXpress9 Namespace > CadLayout Class : Unit Property

Gets the units of measurement for the CAD layout.

[Visual Basic]
Public ReadOnly Property Unit As CadUnit
[C#]
public CadUnit Unit {get;}
[C++]
public: __property CadUnit get_Unit();
[C++/CLI]
public:
property CadUnit Unit {
   CadUnit get();
}

Return Type

The CadUnit enumeration value set for the CAD unit.

See Also

CadLayout Class | CadLayout Members


Width Property

CadLayout Class | CadLayout Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Width Property

PegasusImaging.WinForms.ImagXpress9 Namespace > CadLayout Class : Width Property (CadLayout)

Gets the width of the CAD layout in cad units.

[Visual Basic]
Public ReadOnly Property Width As Double
[C#]
public double Width {get;}
[C++]
public: __property double get_Width();
[C++/CLI]
public:
property double Width {
   double get();
}

Return Type

A double value which represents the width.

See Also

CadLayout Class | CadLayout Members


IcmException Class

IcmException Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

IcmException Class

PegasusImaging.WinForms.ImagXpress9 Namespace : IcmException Class

This class implements exceptions for the Icm objects.

For a list of all members of this type, see IcmException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.ImagXpress9.ImagXpressException
PegasusImaging.WinForms.ImagXpress9.IcmException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class IcmException
   Inherits ImagXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class IcmException : ImagXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class IcmException : public ImagXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class IcmException sealed : public ImagXpressException, ISerializable, _Exception

See Also

IcmException Members | PegasusImaging.WinForms.ImagXpress9 Namespace


IcmException Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

IcmException Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : IcmException Class

IcmException overview

Public Constructors

Public Constructor IcmException Constructor Overloaded. The main constructor for the IcmException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from ImagXpressException) | Gets the numerical equivalent for enumerated exception result.
Public Property Result (Inherited from ImagXpressException) | Gets the enumerated exception result that has occurred.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

IcmException Class | PegasusImaging.WinForms.ImagXpress9 Namespace


IcmException Constructor

IcmException Class | IcmException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

IcmException Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > IcmException Class : IcmException Constructor (IcmException)

The main constructor for the IcmException class.

Overload List

The main constructor for the IcmException class.

[Visual Basic] Public Sub New()

[C#] public IcmException();

[C++] public IcmException();

[C++/CLI] public IcmException();

Constructor which allows passing in a result for the exception.

[Visual Basic] Public Sub New(Result)

[C#] public IcmException(Result);

[C++] public IcmException(Result);

[C++/CLI] public IcmException(Result);

Constructor which allows passing in a message for the exception.

[Visual Basic] Public Sub New(String)

[C#] public IcmException(string);

[C++] public IcmException(string*);

[C++/CLI] public IcmException(String^);

Constructor which allows passing in a result and message for the exception.

[Visual Basic] Public Sub New(Result,String)

[C#] public IcmException(Result,string);

[C++] public IcmException(Result,string*);

[C++/CLI] public IcmException(Result,String^);

Constructor which allows passing in a message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public IcmException(string,Exception);

[C++] public IcmException(string*,Exception*);

[C++/CLI] public IcmException(String^,Exception^);

Constructor which allows passing in a result, message and inner exception.

[Visual Basic] Public Sub New(Result,String,Exception)

[C#] public IcmException(Result,string,Exception);

[C++] public IcmException(Result,string*,Exception*);

[C++/CLI] public IcmException(Result,String^,Exception^);

See Also

IcmException Class | IcmException Members


IcmException Constructor()

IcmException Class | IcmException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

IcmException Constructor()

PegasusImaging.WinForms.ImagXpress9 Namespace > IcmException Class > IcmException Constructor : IcmException Constructor()

The main constructor for the IcmException class.

[Visual Basic]
Public Function New()
[C#]
public IcmException();
[C++]
public: IcmException();
[C++/CLI]
public:
IcmException();

See Also

IcmException Class | IcmException Members | Overload List


IcmException Constructor(Result)

IcmException Class | IcmException Members | Overload List | Result Enumeration

Language

Visual Basic

C#

C++

C++/CLI

Show All

result
A Result enumeration value.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

IcmException Constructor(Result)

PegasusImaging.WinForms.ImagXpress9 Namespace > IcmException Class > IcmException Constructor : IcmException Constructor(Result)

Constructor which allows passing in a result for the exception.

[Visual Basic]
Public Function New( _
   ByVal result As Result _
)
[C#]
public IcmException(
   Result result
);
[C++]
public: IcmException(
   Result result
)
[C++/CLI]
public:
IcmException(
   Result result
)

Parameters

result
A Result enumeration value.

See Also

IcmException Class | IcmException Members | Overload List | Result Enumeration


IcmException Constructor(Result,String)

IcmException Class | IcmException Members | Overload List | Result Enumeration

Language

Visual Basic

C#

C++

C++/CLI

Show All

result
A Result enumeration value.
message
A string value which represents the error message.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

IcmException Constructor(Result,String)

PegasusImaging.WinForms.ImagXpress9 Namespace > IcmException Class > IcmException Constructor : IcmException Constructor(Result,String)

Constructor which allows passing in a result and message for the exception.

[Visual Basic]
Public Function New( _
   ByVal result As Result, _
   ByVal message As String _
)
[C#]
public IcmException(
   Result result,
   string message
);
[C++]
public: IcmException(
   Result result,
   string* message
)
[C++/CLI]
public:
IcmException(
   Result result,
   String^ message
)

Parameters

result
A Result enumeration value.
message
A string value which represents the error message.

See Also

IcmException Class | IcmException Members | Overload List | Result Enumeration


IcmException Constructor(Result,String,Exception)

IcmException Class | IcmException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

result
A Result enumeration value.
message
A string value which represents the error message.
innerException
An Exception value.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

IcmException Constructor(Result,String,Exception)

PegasusImaging.WinForms.ImagXpress9 Namespace > IcmException Class > IcmException Constructor : IcmException Constructor(Result,String,Exception)

Constructor which allows passing in a result, message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal result As Result, _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public IcmException(
   Result result,
   string message,
   Exception innerException
);
[C++]
public: IcmException(
   Result result,
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
IcmException(
   Result result,
   String^ message,
   Exception^ innerException
)

Parameters

result
A Result enumeration value.
message
A string value which represents the error message.
innerException
An Exception value.

See Also

IcmException Class | IcmException Members | Overload List


IcmException Constructor(String)

IcmException Class | IcmException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string value which represents the error message.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

IcmException Constructor(String)

PegasusImaging.WinForms.ImagXpress9 Namespace > IcmException Class > IcmException Constructor : IcmException Constructor(String)

Constructor which allows passing in a message for the exception.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public IcmException(
   string message
);
[C++]
public: IcmException(
   string* message
)
[C++/CLI]
public:
IcmException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

IcmException Class | IcmException Members | Overload List


IcmException Constructor(String,Exception)

IcmException Class | IcmException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string value which represents the error message.
innerException
An Exception value.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

IcmException Constructor(String,Exception)

PegasusImaging.WinForms.ImagXpress9 Namespace > IcmException Class > IcmException Constructor : IcmException Constructor(String,Exception)

Constructor which allows passing in a message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public IcmException(
   string message,
   Exception innerException
);
[C++]
public: IcmException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
IcmException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
An Exception value.

See Also

IcmException Class | IcmException Members | Overload List


ImageCalsCollection Class

ImageCalsCollection Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageCalsCollection Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageCalsCollection Class

This class implements a collection of ImageCalsTag objects.

For a list of all members of this type, see ImageCalsCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<ImageCalsTag>
PegasusImaging.WinForms.ImagXpress9.ImageCalsCollection

Syntax

[Visual Basic]
Public Class ImageCalsCollection
   Inherits Collection(Of ImageCalsTag)
   Implements IList<ImageCalsTag>, ICollection<ImageCalsTag>, IEnumerable<ImageCalsTag>, IEnumerable, IList, ICollection
[C#]
public class ImageCalsCollection : Collection<ImageCalsTag>, IList<ImageCalsTag>, ICollection<ImageCalsTag>, IEnumerable<ImageCalsTag>, IEnumerable, IList, ICollection
[C++]
public __gc class ImageCalsCollection : public Collection<ImageCalsTag>, IList<ImageCalsTag>, ICollection<ImageCalsTag>, IEnumerable<ImageCalsTag>, IEnumerable, IList, ICollection
[C++/CLI]
public ref class ImageCalsCollection : public Collection<ImageCalsTag>, IList<ImageCalsTag>, ICollection<ImageCalsTag>, IEnumerable<ImageCalsTag>, IEnumerable, IList, ICollection

See Also

ImageCalsCollection Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageCalsCollection Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageCalsCollection Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageCalsCollection Class

ImageCalsCollection overview

Public Constructors

Public Constructor ImageCalsCollection Constructor

Public Properties

Public Property Count (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Property Item (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)

Public Methods

Public Method Add (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method Clear (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method Contains (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method CopyTo (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method GetEnumerator (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method IndexOf (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method Insert (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method Remove (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method RemoveAt (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)

See Also

ImageCalsCollection Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageCalsCollection Constructor

ImageCalsCollection Class | ImageCalsCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageCalsCollection Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageCalsCollection Class : ImageCalsCollection Constructor (ImageCalsCollection)
[Visual Basic]
Public Function New()
[C#]
public ImageCalsCollection();
[C++]
public: ImageCalsCollection();
[C++/CLI]
public:
ImageCalsCollection();

See Also

ImageCalsCollection Class | ImageCalsCollection Members


ImageCalsTag Class

ImageCalsTag Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageCalsTag Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageCalsTag Class

This class implements methods and properties for the Cals tag data.

For a list of all members of this type, see ImageCalsTag members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.ImageCalsTag

Syntax

[Visual Basic]
Public Class ImageCalsTag
   Implements IComparable
[C#]
public class ImageCalsTag : IComparable
[C++]
public __gc class ImageCalsTag : public IComparable
[C++/CLI]
public ref class ImageCalsTag : public IComparable

See Also

ImageCalsTag Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageCalsTag Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageCalsTag Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageCalsTag Class

ImageCalsTag overview

Public Constructors

Public Constructor ImageCalsTag Constructor Initializes a new instance of the ImageCalsTag class.

Public Properties

Public Property CalsData | Gets or sets the Cals data.
Public Property CalsId | Gets or sets the Cals id.

Public Methods

Public Method CompareTo Compares the current instance with another object of the same type.

See Also

ImageCalsTag Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageCalsTag Constructor

ImageCalsTag Class | ImageCalsTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

CalsId
A string value which represents the Cals ID.
CalsData
A string value which represents the Cals data.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageCalsTag Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageCalsTag Class : ImageCalsTag Constructor (ImageCalsTag)

Initializes a new instance of the ImageCalsTag class.

[Visual Basic]
Public Function New( _
   ByVal CalsId As String, _
   ByVal CalsData As String _
)
[C#]
public ImageCalsTag(
   string CalsId,
   string CalsData
);
[C++]
public: ImageCalsTag(
   string* CalsId,
   string* CalsData
)
[C++/CLI]
public:
ImageCalsTag(
   String^ CalsId,
   String^ CalsData
)

Parameters

CalsId
A string value which represents the Cals ID.
CalsData
A string value which represents the Cals data.

See Also

ImageCalsTag Class | ImageCalsTag Members


CompareTo Method

ImageCalsTag Class | ImageCalsTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

obj
An object to compare with this instance.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CompareTo Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageCalsTag Class : CompareTo Method (ImageCalsTag)

Compares the current instance with another object of the same type.

[Visual Basic]
Public Function CompareTo( _
   ByVal obj As Object _
) As Integer
[C#]
public int CompareTo(
   object obj
);
[C++]
public: int CompareTo(
   Object* obj
)
[C++/CLI]
public:
int CompareTo(
   Object^ obj
)

Parameters

obj
An object to compare with this instance.

Return Type

A 32-bit signed integer that indicates the relative order of the objects being compared. The return value has these meanings: Value Meaning Less than zero This instance is less than obj. Zero This instance is equal to obj. Greater than zero This instance is greater than obj.

Exceptions

Exception | Description
ArgumentException | obj is not the same type as this instance.

See Also

ImageCalsTag Class | ImageCalsTag Members


ImageCalsTag Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageCalsTag Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageCalsTag Class

For a list of all members of this type, see ImageCalsTag members.

Public Properties

Public Property CalsData | Gets or sets the Cals data.
Public Property CalsId | Gets or sets the Cals id.

See Also

ImageCalsTag Class | PegasusImaging.WinForms.ImagXpress9 Namespace


CalsData Property

ImageCalsTag Class | ImageCalsTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CalsData Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageCalsTag Class : CalsData Property

Gets or sets the Cals data.

[Visual Basic]
Public Property CalsData As String
[C#]
public string CalsData {get; set;}
[C++]
public: __property string* get_CalsData();
public: __property void set_CalsData(
   string* value
);
[C++/CLI]
public:
property String^ CalsData {
   String^ get();
   void set (String^ value);
}

Return Type

A string value which represents the Cals data.

See Also

ImageCalsTag Class | ImageCalsTag Members


CalsId Property

ImageCalsTag Class | ImageCalsTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CalsId Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageCalsTag Class : CalsId Property

Gets or sets the Cals id.

[Visual Basic]
Public Property CalsId As String
[C#]
public string CalsId {get; set;}
[C++]
public: __property string* get_CalsId();
public: __property void set_CalsId(
   string* value
);
[C++/CLI]
public:
property String^ CalsId {
   String^ get();
   void set (String^ value);
}

Return Type

A string value which represents the Cals ID.

See Also

ImageCalsTag Class | ImageCalsTag Members


ImageStatusEventArgs Class

ImageStatusEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageStatusEventArgs Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageStatusEventArgs Class

This class contains object data for Image Status events.

For a list of all members of this type, see ImageStatusEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.ImagXpress9.ImageStatusEventArgs

Syntax

[Visual Basic]
Public Class ImageStatusEventArgs
   Inherits EventArgs
[C#]
public class ImageStatusEventArgs : EventArgs
[C++]
public __gc class ImageStatusEventArgs : public EventArgs
[C++/CLI]
public ref class ImageStatusEventArgs : public EventArgs

See Also

ImageStatusEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageStatusEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageStatusEventArgs Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageStatusEventArgs Class

ImageStatusEventArgs overview

Public Constructors

Public Constructor ImageStatusEventArgs Constructor The main constructor for the ImageStatusEventArgs class.

Public Properties

Public Property Operation | Gets the current image operation.
Public Property Status | Gets the status of the current image.

See Also

ImageStatusEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageStatusEventArgs Constructor

ImageStatusEventArgs Class | ImageStatusEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageStatusEventArgs Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageStatusEventArgs Class : ImageStatusEventArgs Constructor (ImageStatusEventArgs)

The main constructor for the ImageStatusEventArgs class.

[Visual Basic]
Public Function New()
[C#]
public ImageStatusEventArgs();
[C++]
public: ImageStatusEventArgs();
[C++/CLI]
public:
ImageStatusEventArgs();

See Also

ImageStatusEventArgs Class | ImageStatusEventArgs Members


ImageStatusEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageStatusEventArgs Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageStatusEventArgs Class

For a list of all members of this type, see ImageStatusEventArgs members.

Public Properties

Public Property Operation | Gets the current image operation.
Public Property Status | Gets the status of the current image.

See Also

ImageStatusEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Operation Property

ImageStatusEventArgs Class | ImageStatusEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Operation Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageStatusEventArgs Class : Operation Property (ImageStatusEventArgs)

Gets the current image operation.

[Visual Basic]
Public ReadOnly Property Operation As Operation
[C#]
public Operation Operation {get;}
[C++]
public: __property Operation get_Operation();
[C++/CLI]
public:
property Operation Operation {
   Operation get();
}

Return Type

An Operation enumeration value.

See Also

ImageStatusEventArgs Class | ImageStatusEventArgs Members


Status Property

ImageStatusEventArgs Class | ImageStatusEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Status Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageStatusEventArgs Class : Status Property

Gets the status of the current image.

[Visual Basic]
Public ReadOnly Property Status As ImageStatus
[C#]
public ImageStatus Status {get;}
[C++]
public: __property ImageStatus get_Status();
[C++/CLI]
public:
property ImageStatus Status {
   ImageStatus get();
}

Return Type

An ImageStatus enumeration value.

See Also

ImageStatusEventArgs Class | ImageStatusEventArgs Members


ImageX Class

ImageX Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageX Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageX Class

This class implements basic operating functionality for the ImagXpress component.

For a list of all members of this type, see ImageX members.

Object Model

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
PegasusImaging.WinForms.ImagXpress9.ImageX

Syntax

[Visual Basic]
Public Class ImageX
   Inherits MarshalByRefObject
   Implements IDisposable
[C#]
public class ImageX : MarshalByRefObject, IDisposable
[C++]
public __gc class ImageX : public MarshalByRefObject, IDisposable
[C++/CLI]
public ref class ImageX : public MarshalByRefObject, IDisposable

See Also

ImageX Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageX Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageX Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageX Class

ImageX overview

Public Constructors

Public Constructor ImageX Constructor Overloaded. To initialize a new instance of the ImagXpress object.

Public Properties

Public Property AutoInvalidate | Gets and sets if the ImageXView object repaints whenever a change is made to the ImageX object.
Public Property CalTags | Get and sets the String pair Modca/Cals Tags Cal Tags can only be obtainds from Modca/Cals images open by Load methods Presently, there is no way to edit Cal tags without loading and saving the image.
Public Property ImageXData | Gets the ImageXData of the ImageX object.
Public Property IptcDataSet | Gets or sets the iptc data set.
Public Property JpegCommentCount | After opening a JPEG file, this property gets the number of JPEG App markers comments discovered.
Public Property LoadOptions | Gets the additional load options from this ImageX object.
Public Property Page | Gets and sets the page to be viewed or processed.
Public Property PageCount | Gets the number of pages in the image beginning at 1.
Public Property Palette | Gets or sets the color palette used for this ImageX object.
Public Property Resolution | Gets the resolution of the ImageX image.
Public Property Tags | Gets and sets the tag collection associated with this ImageX image.
Public Property UndoEnabled | Gets and sets the ability to perform the Undo method.

Public Methods

Public Method AddJpegComment | Adds a new comment from an opened JPEG file or a comment for a file to be saved as a JPEG file. The comment will when the current image is written out (saved) as a JPEG file;
Public Method CadFileClose | Closes the CAD file.
Public Method static (Shared in Visual Basic) CadFileOpen | Overloaded. Opens the CAD file for repeated renderings of differently selected layers and layouts.
Public Method CadFileView | Overloaded. The CAD file view.
Public Method Cancel | Cancels current loading, decompression, compression, or saving operations.
Public Method static (Shared in Visual Basic) CompactFile | Compacts a multiple page file by removing unused pages.
Public Method Copy | This method copies the current ImageX object into a newly created ImageX object.
Public Method static (Shared in Visual Basic) CreateColorPalette | Overloaded. Creates a System.Drawing.Imaging.ColorPalette object based on the number of bits per pixel.
Public Method CreateObjRef (Inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Public Method DeleteJpegComment | Deletes an existing JPEG comment string at the index specified.
Public Method static (Shared in Visual Basic) DeletePage | Deletes a page from a multi-page document.
Public Method Dispose | Releases all resources used by this PegasusImaging.WinForms.ImagXpress9.ImageX object
Public Method static (Shared in Visual Basic) DisposeHbitmap | Disposes an Hbitmap object.
Public Method static (Shared in Visual Basic) FromBitmap | Creates an ImageX object from the given Bitmap object.
Public Method static (Shared in Visual Basic) FromFile | Overloaded. This method allows the loading of a specific file.
Public Method static (Shared in Visual Basic) FromHbitmap | Overloaded. Creates an ImageX object from the given Hbitmap object.
Public Method static (Shared in Visual Basic) FromHdib | Overloaded. Creates an ImagX object from the given hdib object.
Public Method static (Shared in Visual Basic) FromStream | Overloaded. Returns an ImageX object from the given ImagXpress instance and stream
Public Method GetGraphics | Gets a System.Drawing.Graphics object with the image selected into it for drawing on the image.
Public Method GetLifetimeService (Inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Public Method static (Shared in Visual Basic) GetTags | Returns the ImageXTagCollection for the file and page requested without loading the image. This method is being deprecated because there are other meta-data items in an image. Please use ReadAllMetaData() which returns an ImageX object containing Tiff/Exif and Iptc tags The Tiff tags can be obtained by ImageX.Tags property and the Iptc meta-data similarly with ImageX.Iptc. Future Meta-data can be obtained in a like manner.
Public Method HorizontalResolution | Returns the horizontal resolution of this ImageX image.
Public Method InitializeLifetimeService (Inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Public Method static (Shared in Visual Basic) InsertPage | Inserts a new page into a multi-page document.
Public Method static (Shared in Visual Basic) NumPages | Returns the number of image pages from the given multiple page PDF, TIFF or DCX file.
Public Method static (Shared in Visual Basic) QueryBuffer | Overloaded. Query buffer for image information such as width, height, bitdepth and image data type.
Public Method static (Shared in Visual Basic) QueryFile | Overloaded. Returns information about an image file without loading the image into ImagXpress.
Public Method static (Shared in Visual Basic) QueryFromStream | Overloaded. Query buffer stream for image information such as width, height, bitdepth and image data type.
Public Method static (Shared in Visual Basic) ReadAllMetaData | Perferred method for obtaining all Meta-data items. Simply fetch the tag collections with ImageX.IptcDataSet and ImageX.Tags; Later that object can be passed to the SaveAllMetaData to save all edits
Public Method ReleaseGraphics | Overloaded. Releases the previously received System.Drawing.Graphics object.
Public Method ResolutionUnits | Returns the graphics units in which resolution information is specified.
Public Method ReturnJpegComment | Returns a JPEG String from the loaded JPEG file if one exists.
Public Method Save | Overloaded. Save the image to a given filename.
Public Method static (Shared in Visual Basic) SaveAllMetaData | The preferred method for saving Tif, Exif, and Iptc meta-data.
Public Method SaveStream | Overloaded. Saves the current ImageX object to a stream object in the specified file format.
Public Method static (Shared in Visual Basic) SetTags | Sets the tags of the specified page of the specified file, without loading the image. Warning! This call does not support Iptc data and will cause Iptc data sets to be removed!! Please use the ReadAllMetaData() and SaveAllMetaData() schemes so any data that is not edited will be preserved naturally
Public Method ToBitmap | Gets a System.Drawing.Bitmap object from the ImageX object
Public Method ToHbitmap | Gets a handle to a bitmap.
Public Method ToHdib | Gets a handle to an DIB (Device Independent Bitmap).
Public Method Undo | Undoes the action of the previous image processing method if the UndoEnabled property was set true prior to performing this method.
Public Method VerticalResolution | Returns the vertical resolution of the ImageX image.

See Also

ImageX Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageX Constructor

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageX Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : ImageX Constructor (ImageX)

To initialize a new instance of the ImagXpress object.

Overload List

To initialize a new instance of the ImagXpress object.

[Visual Basic] Public Sub New(ImagXpress)

[C#] public ImageX(ImagXpress);

[C++] public ImageX(ImagXpress*);

[C++/CLI] public ImageX(ImagXpress^);

Initializes a new instance of the ImageX class.

[Visual Basic] Public Sub New(ImagXpress,Integer,Integer,Integer,Color)

[C#] public ImageX(ImagXpress,int,int,int,Color);

[C++] public ImageX(ImagXpress*,int,int,int,Color);

[C++/CLI] public ImageX(ImagXpress^,int,int,int,Color);

Initializes a new instance of the ImageX class.

[Visual Basic] Public Sub New(ImagXpress,Integer,Integer,Integer,Color,Resolution,Boolean)

[C#] public ImageX(ImagXpress,int,int,int,Color,Resolution,bool);

[C++] public ImageX(ImagXpress*,int,int,int,Color,Resolution*,bool);

[C++/CLI] public ImageX(ImagXpress^,int,int,int,Color,Resolution^,bool);

See Also

ImageX Class | ImageX Members


ImageX Constructor(ImagXpress)

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
A new ImagXpress object to initialize.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageX Constructor(ImagXpress)

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > ImageX Constructor : ImageX Constructor(ImagXpress)

To initialize a new instance of the ImagXpress object.

[Visual Basic]
Public Function New( _
   ByVal imagXpress As ImagXpress _
)
[C#]
public ImageX(
   ImagXpress imagXpress
);
[C++]
public: ImageX(
   ImagXpress* imagXpress
)
[C++/CLI]
public:
ImageX(
   ImagXpress^ imagXpress
)

Parameters

imagXpress
A new ImagXpress object to initialize.

See Also

ImageX Class | ImageX Members | Overload List


ImageX Constructor(ImagXpress,Int32,Int32,Int32,Color)

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An ImagXpress workspace component.
width
An integer which represents the width.
height
An integer which represents the height.
bitsPerPixel
An integer which represents the bits per pixel.
backColor
Color of the background.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageX Constructor(ImagXpress,Int32,Int32,Int32,Color)

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > ImageX Constructor : ImageX Constructor(ImagXpress,Int32,Int32,Int32,Color)

Initializes a new instance of the ImageX class.

[Visual Basic]
Public Function New( _
   ByVal imagXpress As ImagXpress, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal bitsPerPixel As Integer, _
   ByVal backColor As Color _
)
[C#]
public ImageX(
   ImagXpress imagXpress,
   int width,
   int height,
   int bitsPerPixel,
   Color backColor
);
[C++]
public: ImageX(
   ImagXpress* imagXpress,
   int width,
   int height,
   int bitsPerPixel,
   Color backColor
)
[C++/CLI]
public:
ImageX(
   ImagXpress^ imagXpress,
   int width,
   int height,
   int bitsPerPixel,
   Color backColor
)

Parameters

imagXpress
An ImagXpress workspace component.
width
An integer which represents the width.
height
An integer which represents the height.
bitsPerPixel
An integer which represents the bits per pixel.
backColor
Color of the background.

See Also

ImageX Class | ImageX Members | Overload List


ImageX Constructor(ImagXpress,Int32,Int32,Int32,Color,Resolution,Boolean)

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An ImagXpress workspace component.
width
An integer which represents the width.
height
An integer which represents the height.
bitsPerPixel
An integer which represents the bits per pixel.
backColor
Color of the back.
resolution
The resolution.
virtualImage
A boolean value which, if set to true is a virtual image [virtual image]. Otherwise, false should be set.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageX Constructor(ImagXpress,Int32,Int32,Int32,Color,Resolution,Boolean)

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > ImageX Constructor : ImageX Constructor(ImagXpress,Int32,Int32,Int32,Color,Resolution,Boolean)

Initializes a new instance of the ImageX class.

[Visual Basic]
Public Function New( _
   ByVal imagXpress As ImagXpress, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal bitsPerPixel As Integer, _
   ByVal backColor As Color, _
   ByVal resolution As Resolution, _
   ByVal virtualImage As Boolean _
)
[C#]
public ImageX(
   ImagXpress imagXpress,
   int width,
   int height,
   int bitsPerPixel,
   Color backColor,
   Resolution resolution,
   bool virtualImage
);
[C++]
public: ImageX(
   ImagXpress* imagXpress,
   int width,
   int height,
   int bitsPerPixel,
   Color backColor,
   Resolution* resolution,
   bool virtualImage
)
[C++/CLI]
public:
ImageX(
   ImagXpress^ imagXpress,
   int width,
   int height,
   int bitsPerPixel,
   Color backColor,
   Resolution^ resolution,
   bool virtualImage
)

Parameters

imagXpress
An ImagXpress workspace component.
width
An integer which represents the width.
height
An integer which represents the height.
bitsPerPixel
An integer which represents the bits per pixel.
backColor
Color of the back.
resolution
The resolution.
virtualImage
A boolean value which, if set to true is a virtual image [virtual image]. Otherwise, false should be set.

See Also

ImageX Class | ImageX Members | Overload List


AddJpegComment Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

Index
An integer value which represents the index at which the comment is added.
comment
A string value which represents the comment to be added to the list.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AddJpegComment Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : AddJpegComment Method

Adds a new comment from an opened JPEG file or a comment for a file to be saved as a JPEG file. The comment will when the current image is written out (saved) as a JPEG file;

[Visual Basic]
Public Sub AddJpegComment( _
   ByVal Index As Integer, _
   ByVal comment As String _
)
[C#]
public void AddJpegComment(
   int Index,
   string comment
);
[C++]
public: void AddJpegComment(
   int Index,
   string* comment
)
[C++/CLI]
public:
void AddJpegComment(
   int Index,
   String^ comment
)

Parameters

Index
An integer value which represents the index at which the comment is added.
comment
A string value which represents the comment to be added to the list.

Remarks

Note: Available in all editions.

See Also

ImageX Class | ImageX Members


CadFileClose Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CadFileClose Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : CadFileClose Method

Closes the CAD file.

[Visual Basic]
Public Sub CadFileClose()
[C#]
public void CadFileClose();
[C++]
public: void CadFileClose();
[C++/CLI]
public:
void CadFileClose();

Remarks

Must be called after a CadFileOpen has been invoked to close the CAD file when finished viewing the various renderings from CadFileView.

See Also

ImageX Class | ImageX Members


CadFileOpen Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CadFileOpen Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : CadFileOpen Method

Opens the CAD file for repeated renderings of differently selected layers and layouts.

Overload List

Opens the CAD file for repeated renderings of differently selected layers and layouts.

[Visual Basic] Overloads Public Shared Function CadFileOpen(ImagXpress,String) As ImageX

[C#] public static ImageX CadFileOpen(ImagXpress,string);

[C++] public static ImageX* CadFileOpen(ImagXpress*,string*);

[C++/CLI] public static ImageX^ CadFileOpen(ImagXpress^,String^);

Opens the CAD file for repeated renderings of differently selected layers and layouts.

[Visual Basic] Overloads Public Shared Function CadFileOpen(ImagXpress,String,LoadOptions) As ImageX

[C#] public static ImageX CadFileOpen(ImagXpress,string,LoadOptions);

[C++] public static ImageX* CadFileOpen(ImagXpress*,string*,LoadOptions*);

[C++/CLI] public static ImageX^ CadFileOpen(ImagXpress^,String^,LoadOptions^);

See Also

ImageX Class | ImageX Members


CadFileOpen(ImagXpress,String) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
The ImagXpress workspace component.
filename
The filename.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CadFileOpen(ImagXpress,String) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > CadFileOpen Method : CadFileOpen(ImagXpress,String) Method

Opens the CAD file for repeated renderings of differently selected layers and layouts.

[Visual Basic]
Overloads Public Shared Function CadFileOpen( _
   ByVal imagXpress As ImagXpress, _
   ByVal filename As String _
) As ImageX
[C#]
public static ImageX CadFileOpen(
   ImagXpress imagXpress,
   string filename
);
[C++]
public: static ImageX* CadFileOpen(
   ImagXpress* imagXpress,
   string* filename
)
[C++/CLI]
public:
static ImageX^ CadFileOpen(
   ImagXpress^ imagXpress,
   String^ filename
)

Parameters

imagXpress
The ImagXpress workspace component.
filename
The filename.

Return Type

An ImageX object containing a representation of the CAD file.

Remarks

Typically, application call to the FromFile method to open a file but CAD files have many different perspective views depending on the selectiom of layouts and layers.

While FromFile works with CAD files, it is very inefficient because subsequent requests must rebuild internal data tables on each evocation. This method keeps the internal tables and reference objects available for subsequent viewing by CadFileView. Without any CAD loadoptions selected, the default layout and layers are rendered at the default paper size and resolution.

To terminate the viewing and remove the tables, call the CadFileClose method.

Note: This method does not support asynchronous operations nor support of annotations for adding or viewing.

See Also

ImageX Class | ImageX Members | Overload List


CadFileOpen(ImagXpress,String,LoadOptions) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
The ImagXpress workspace component.
filename
A string value which represents the filename.
loadOptions
The load options.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CadFileOpen(ImagXpress,String,LoadOptions) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > CadFileOpen Method : CadFileOpen(ImagXpress,String,LoadOptions) Method

Opens the CAD file for repeated renderings of differently selected layers and layouts.

[Visual Basic]
Overloads Public Shared Function CadFileOpen( _
   ByVal imagXpress As ImagXpress, _
   ByVal filename As String, _
   ByVal loadOptions As LoadOptions _
) As ImageX
[C#]
public static ImageX CadFileOpen(
   ImagXpress imagXpress,
   string filename,
   LoadOptions loadOptions
);
[C++]
public: static ImageX* CadFileOpen(
   ImagXpress* imagXpress,
   string* filename,
   LoadOptions* loadOptions
)
[C++/CLI]
public:
static ImageX^ CadFileOpen(
   ImagXpress^ imagXpress,
   String^ filename,
   LoadOptions^ loadOptions
)

Parameters

imagXpress
The ImagXpress workspace component.
filename
A string value which represents the filename.
loadOptions
The load options.

Return Type

An ImageX object containing a representation of the CAD file.

Remarks

Typically, application call to the FromFile method to open a file but CAD files have many different perspective views depending on the selectiom of layouts and layers.

While FromFile works with CAD files, it is very inefficient because subsequent requests must rebuild internal data tables on each evocation. This method keeps the internal tables and reference objects available for subsequent viewing by CadFileView. Without any CAD loadoptions selected, the default layout and layers are rendered at the default paper size and resolution.

To terminate the viewing and remove the tables, call the CadFileClose method.

Note: This method does not support asynchronous operaions nor support of annotations for adding or viewing.

See Also

ImageX Class | ImageX Members | Overload List


CadFileView Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CadFileView Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : CadFileView Method

The CAD file view.

Overload List

The CAD file view.

[Visual Basic] Overloads Public Sub CadFileView()

[C#] public void CadFileView();

[C++] public void CadFileView()

[C++/CLI] public void CadFileView()

Changes the CAD file view.

[Visual Basic] Overloads Public Sub CadFileView(LoadOptions)

[C#] public void CadFileView(LoadOptions);

[C++] public void CadFileView(LoadOptions*);

[C++/CLI] public void CadFileView(LoadOptions^);

See Also

ImageX Class | ImageX Members


CadFileView() Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CadFileView() Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > CadFileView Method : CadFileView() Method

The CAD file view.

[Visual Basic]
Overloads Public Sub CadFileView()
[C#]
public void CadFileView();
[C++]
public: void CadFileView();
[C++/CLI]
public:
void CadFileView();

Remarks

The loadoptions selects the layout and layers to be rendered. The paper size options determine the image width and height along with the crop parameters which select what portion of the image to render.

This method must have been preceded by calling the CadFileOpen method before it is called for the first time. It may be called multiple times since CadFileOpen but eventually succeeded with a CadFileClose method.

Note: This method does not support asynchronous operaions nor support of annotations for adding or viewing.

See Also

ImageX Class | ImageX Members | Overload List


CadFileView(LoadOptions) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

loadOptions
The load options.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CadFileView(LoadOptions) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > CadFileView Method : CadFileView(LoadOptions) Method

Changes the CAD file view.

[Visual Basic]
Overloads Public Sub CadFileView( _
   ByVal loadOptions As LoadOptions _
)
[C#]
public void CadFileView(
   LoadOptions loadOptions
);
[C++]
public: void CadFileView(
   LoadOptions* loadOptions
)
[C++/CLI]
public:
void CadFileView(
   LoadOptions^ loadOptions
)

Parameters

loadOptions
The load options.

Remarks

The loadoptions selects the layout and layers to be rendered. The paper size options determine the image width and height along with the crop parameters which select what portion of the image to render.

This method must have been preceded by calling the CadFileOpen method before it is called for the first time. It may be called multiple times since CadFileOpen but eventually succeeded with a CadFileClose method.

Note: This method does not support asynchronous operaions nor support of annotations for adding or viewing.

See Also

ImageX Class | ImageX Members | Overload List


Cancel Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Cancel Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : Cancel Method

Cancels current loading, decompression, compression, or saving operations.

[Visual Basic]
Public Sub Cancel()
[C#]
public void Cancel();
[C++]
public: void Cancel();
[C++/CLI]
public:
void Cancel();

See Also

ImageX Class | ImageX Members


CompactFile Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An imagXpress workspace instance.
srcFileName
The source file, which is examined for unused pages.
dstFileName
The destination file, which will get the compacted file.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CompactFile Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : CompactFile Method

Compacts a multiple page file by removing unused pages.

[Visual Basic]
Public Shared Sub CompactFile( _
   ByVal imagXpress As ImagXpress, _
   ByVal srcFileName As String, _
   ByVal dstFileName As String _
)
[C#]
public static void CompactFile(
   ImagXpress imagXpress,
   string srcFileName,
   string dstFileName
);
[C++]
public: static void CompactFile(
   ImagXpress* imagXpress,
   string* srcFileName,
   string* dstFileName
)
[C++/CLI]
public:
static void CompactFile(
   ImagXpress^ imagXpress,
   String^ srcFileName,
   String^ dstFileName
)

Parameters

imagXpress
An imagXpress workspace instance.
srcFileName
The source file, which is examined for unused pages.
dstFileName
The destination file, which will get the compacted file.

See Also

ImageX Class | ImageX Members


Copy Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Copy Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : Copy Method (ImageX)

This method copies the current ImageX object into a newly created ImageX object.

[Visual Basic]
Public Function Copy() As ImageX
[C#]
public ImageX Copy();
[C++]
public: ImageX* Copy();
[C++/CLI]
public:
ImageX^ Copy();

Return Type

A new ImageX object that is a copy of the given ImageX object.

See Also

ImageX Class | ImageX Members


CreateColorPalette Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CreateColorPalette Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : CreateColorPalette Method

Creates a System.Drawing.Imaging.ColorPalette object based on the number of bits per pixel.

Overload List

Creates a System.Drawing.Imaging.ColorPalette object based on the number of bits per pixel.

[Visual Basic] Overloads Public Shared Function CreateColorPalette(Integer) As ColorPalette

[C#] public static ColorPalette CreateColorPalette(int);

[C++] public static ColorPalette* CreateColorPalette(int);

[C++/CLI] public static ColorPalette^ CreateColorPalette(int);

Creates a ColorPalette object based on the pixel format specified.

[Visual Basic] Overloads Public Shared Function CreateColorPalette(PixelFormat) As ColorPalette

[C#] public static ColorPalette CreateColorPalette(PixelFormat);

[C++] public static ColorPalette* CreateColorPalette(PixelFormat);

[C++/CLI] public static ColorPalette^ CreateColorPalette(PixelFormat);

See Also

ImageX Class | ImageX Members


CreateColorPalette(Int32) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

bitsPerPixel
An integer which represents the bits per pixel.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CreateColorPalette(Int32) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > CreateColorPalette Method : CreateColorPalette(Int32) Method

Creates a System.Drawing.Imaging.ColorPalette object based on the number of bits per pixel.

[Visual Basic]
Overloads Public Shared Function CreateColorPalette( _
   ByVal bitsPerPixel As Integer _
) As ColorPalette
[C#]
public static ColorPalette CreateColorPalette(
   int bitsPerPixel
);
[C++]
public: static ColorPalette* CreateColorPalette(
   int bitsPerPixel
)
[C++/CLI]
public:
static ColorPalette^ CreateColorPalette(
   int bitsPerPixel
)

Parameters

bitsPerPixel
An integer which represents the bits per pixel.

Return Type

A ColorPalette object.

Remarks

This helper function is for convenience and can be used as a class factory for the ColorPalette class since it is a sealed class that does not allow it to be dynamically created with a new.

If the bitsPerPixel is either 1, 4 or 8, then a ColorPalette is created with 2, 16, and 256 entries respectively. Any other value will return an empty ColorPalette with zero entries.

See Also

ImageX Class | ImageX Members | Overload List


CreateColorPalette(PixelFormat) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

pixelFormat
A PixelFormat to specify for the color palette.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CreateColorPalette(PixelFormat) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > CreateColorPalette Method : CreateColorPalette(PixelFormat) Method

Creates a ColorPalette object based on the pixel format specified.

[Visual Basic]
Overloads Public Shared Function CreateColorPalette( _
   ByVal pixelFormat As PixelFormat _
) As ColorPalette
[C#]
public static ColorPalette CreateColorPalette(
   PixelFormat pixelFormat
);
[C++]
public: static ColorPalette* CreateColorPalette(
   PixelFormat pixelFormat
)
[C++/CLI]
public:
static ColorPalette^ CreateColorPalette(
   PixelFormat pixelFormat
)

Parameters

pixelFormat
A PixelFormat to specify for the color palette.

Return Type

A ColorPalette object.

Remarks

This helper function is for convenience and can be used as a class factory for the ColorPalette class since it is a sealed class that does not allow it to be dynamically created with a new.

See Also

ImageX Class | ImageX Members | Overload List


DeleteJpegComment Method

ImageX Class | ImageX Members | ReturnJpegComment Method | JpegCommentCount Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

Index
An integer value which represents the index for the comment to delete.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DeleteJpegComment Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : DeleteJpegComment Method

Deletes an existing JPEG comment string at the index specified.

[Visual Basic]
Public Sub DeleteJpegComment( _
   ByVal Index As Integer _
)
[C#]
public void DeleteJpegComment(
   int Index
);
[C++]
public: void DeleteJpegComment(
   int Index
)
[C++/CLI]
public:
void DeleteJpegComment(
   int Index
)

Parameters

Index
An integer value which represents the index for the comment to delete.

Remarks

Note: Available in all editions.

See Also

ImageX Class | ImageX Members | ReturnJpegComment Method | JpegCommentCount Property


DeletePage Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An ImagXpress workspace instance.
filename
A string which represents the file name.
pageNumber
An integer value which represents the page to delete.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DeletePage Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : DeletePage Method

Deletes a page from a multi-page document.

[Visual Basic]
Public Shared Sub DeletePage( _
   ByVal imagXpress As ImagXpress, _
   ByVal filename As String, _
   ByVal pageNumber As Integer _
)
[C#]
public static void DeletePage(
   ImagXpress imagXpress,
   string filename,
   int pageNumber
);
[C++]
public: static void DeletePage(
   ImagXpress* imagXpress,
   string* filename,
   int pageNumber
)
[C++/CLI]
public:
static void DeletePage(
   ImagXpress^ imagXpress,
   String^ filename,
   int pageNumber
)

Parameters

imagXpress
An ImagXpress workspace instance.
filename
A string which represents the file name.
pageNumber
An integer value which represents the page to delete.

Remarks

This method is for TIFF and EXIF file formats. It does not physically delete the image page from the file. It adjusts the pointers in the TIFF IFDs to point around the deleted image.

This operation will leave unused images in the file and therefore wasted space in the file. Use the CompactFile method to physically remove all unused pages in a file.

Note: Available in Document and Photo editions.

See Also

ImageX Class | ImageX Members


Dispose Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : Dispose Method (ImageX)

Releases all resources used by this PegasusImaging.WinForms.ImagXpress9.ImageX object

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

See Also

ImageX Class | ImageX Members


DisposeHbitmap Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

hbitmap
A System.IntPtr handle to an hbitmap object to free.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DisposeHbitmap Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : DisposeHbitmap Method

Disposes an Hbitmap object.

[Visual Basic]
Public Shared Sub DisposeHbitmap( _
   ByVal hbitmap As IntPtr _
)
[C#]
public static void DisposeHbitmap(
   IntPtr hbitmap
);
[C++]
public: static void DisposeHbitmap(
   IntPtr hbitmap
)
[C++/CLI]
public:
static void DisposeHbitmap(
   IntPtr hbitmap
)

Parameters

hbitmap
A System.IntPtr handle to an hbitmap object to free.

Remarks

This static function is a helper function so that the developer can use this function to free an hbitmap instead of having to call DeleteObject in gdi32.dll.

See Also

ImageX Class | ImageX Members


FromBitmap Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
bitmap
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

FromBitmap Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : FromBitmap Method

Creates an ImageX object from the given Bitmap object.

[Visual Basic]
Public Shared Function FromBitmap( _
   ByVal imagXpress As ImagXpress, _
   ByVal bitmap As Bitmap _
) As ImageX
[C#]
public static ImageX FromBitmap(
   ImagXpress imagXpress,
   Bitmap bitmap
);
[C++]
public: static ImageX* FromBitmap(
   ImagXpress* imagXpress,
   Bitmap* bitmap
)
[C++/CLI]
public:
static ImageX^ FromBitmap(
   ImagXpress^ imagXpress,
   Bitmap^ bitmap
)

Parameters

imagXpress
bitmap

Return Type

The newly created ImageX object.

Remarks

See Also

ImageX Class | ImageX Members


FromFile Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

FromFile Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : FromFile Method

This method allows the loading of a specific file.

Overload List

This method allows the loading of a specific file.

[Visual Basic] Overloads Public Shared Function FromFile(ImagXpress,String) As ImageX

[C#] public static ImageX FromFile(ImagXpress,string);

[C++] public static ImageX* FromFile(ImagXpress*,string*);

[C++/CLI] public static ImageX^ FromFile(ImagXpress^,String^);

Loads an Image from the specified file.

[Visual Basic] Overloads Public Shared Function FromFile(ImagXpress,String,Integer) As ImageX

[C#] public static ImageX FromFile(ImagXpress,string,int);

[C++] public static ImageX* FromFile(ImagXpress*,string*,int);

[C++/CLI] public static ImageX^ FromFile(ImagXpress^,String^,int);

Loads from a file, additional loading options can be specified.

[Visual Basic] Overloads Public Shared Function FromFile(ImagXpress,String,LoadOptions) As ImageX

[C#] public static ImageX FromFile(ImagXpress,string,LoadOptions);

[C++] public static ImageX* FromFile(ImagXpress*,string*,LoadOptions*);

[C++/CLI] public static ImageX^ FromFile(ImagXpress^,String^,LoadOptions^);

Loads from the given file and specified load options creating a new ImagXpress workspace component.

[Visual Basic] Overloads Public Shared Function FromFile(ImagXpress,String,Integer,LoadOptions) As ImageX

[C#] public static ImageX FromFile(ImagXpress,string,int,LoadOptions);

[C++] public static ImageX* FromFile(ImagXpress*,string*,int,LoadOptions*);

[C++/CLI] public static ImageX^ FromFile(ImagXpress^,String^,int,LoadOptions^);

See Also

ImageX Class | ImageX Members


FromFile(ImagXpress,String) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
The ImagXpress workspace component.
filename
String value that evaluates to a valid Windows file path.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

FromFile(ImagXpress,String) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > FromFile Method : FromFile(ImagXpress,String) Method

This method allows the loading of a specific file.

[Visual Basic]
Overloads Public Shared Function FromFile( _
   ByVal imagXpress As ImagXpress, _
   ByVal filename As String _
) As ImageX
[C#]
public static ImageX FromFile(
   ImagXpress imagXpress,
   string filename
);
[C++]
public: static ImageX* FromFile(
   ImagXpress* imagXpress,
   string* filename
)
[C++/CLI]
public:
static ImageX^ FromFile(
   ImagXpress^ imagXpress,
   String^ filename
)

Parameters

imagXpress
The ImagXpress workspace component.
filename
String value that evaluates to a valid Windows file path.

Return Type

A newly created ImageX object.

Remarks

The decompressed image is stored in the ImageX object.

See Also

ImageX Class | ImageX Members | Overload List


FromFile(ImagXpress,String,Int32) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
The ImagXpress workspace component.
filename
A string which represents the filename.
pageNumber
An integer value which represents the page number.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

FromFile(ImagXpress,String,Int32) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > FromFile Method : FromFile(ImagXpress,String,Int32) Method

Loads an Image from the specified file.

[Visual Basic]
Overloads Public Shared Function FromFile( _
   ByVal imagXpress As ImagXpress, _
   ByVal filename As String, _
   ByVal pageNumber As Integer _
) As ImageX
[C#]
public static ImageX FromFile(
   ImagXpress imagXpress,
   string filename,
   int pageNumber
);
[C++]
public: static ImageX* FromFile(
   ImagXpress* imagXpress,
   string* filename,
   int pageNumber
)
[C++/CLI]
public:
static ImageX^ FromFile(
   ImagXpress^ imagXpress,
   String^ filename,
   int pageNumber
)

Parameters

imagXpress
The ImagXpress workspace component.
filename
A string which represents the filename.
pageNumber
An integer value which represents the page number.

Return Type

The newly created ImageX object.

Remarks

The decompressed image is stored in the ImageX object.

See Also

ImageX Class | ImageX Members | Overload List


FromFile(ImagXpress,String,LoadOptions) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An ImagXpress workspace component.
filename
A string value that evaluates to a valid Windows file path.
loadOptions
Additional loading options as they pertain to the different file formats.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

FromFile(ImagXpress,String,LoadOptions) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > FromFile Method : FromFile(ImagXpress,String,LoadOptions) Method

Loads from a file, additional loading options can be specified.

[Visual Basic]
Overloads Public Shared Function FromFile( _
   ByVal imagXpress As ImagXpress, _
   ByVal filename As String, _
   ByVal loadOptions As LoadOptions _
) As ImageX
[C#]
public static ImageX FromFile(
   ImagXpress imagXpress,
   string filename,
   LoadOptions loadOptions
);
[C++]
public: static ImageX* FromFile(
   ImagXpress* imagXpress,
   string* filename,
   LoadOptions* loadOptions
)
[C++/CLI]
public:
static ImageX^ FromFile(
   ImagXpress^ imagXpress,
   String^ filename,
   LoadOptions^ loadOptions
)

Parameters

imagXpress
An ImagXpress workspace component.
filename
A string value that evaluates to a valid Windows file path.
loadOptions
Additional loading options as they pertain to the different file formats.

Return Type

A newly created ImageX object.

Remarks

The decompressed image is stored in the ImageX object.

See Also

ImageX Class | ImageX Members | Overload List


FromFile(ImagXpress,String,Int32,LoadOptions) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An ImagXpress workspace component.
filename
A string value that represents the filename.
pageNumber
An integer which represents the page number from the file.
loadOptions
Additional loading options as they pertain to the different file for formats.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

FromFile(ImagXpress,String,Int32,LoadOptions) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > FromFile Method : FromFile(ImagXpress,String,Int32,LoadOptions) Method

Loads from the given file and specified load options creating a new ImagXpress workspace component.

[Visual Basic]
Overloads Public Shared Function FromFile( _
   ByVal imagXpress As ImagXpress, _
   ByVal filename As String, _
   ByVal pageNumber As Integer, _
   ByVal loadOptions As LoadOptions _
) As ImageX
[C#]
public static ImageX FromFile(
   ImagXpress imagXpress,
   string filename,
   int pageNumber,
   LoadOptions loadOptions
);
[C++]
public: static ImageX* FromFile(
   ImagXpress* imagXpress,
   string* filename,
   int pageNumber,
   LoadOptions* loadOptions
)
[C++/CLI]
public:
static ImageX^ FromFile(
   ImagXpress^ imagXpress,
   String^ filename,
   int pageNumber,
   LoadOptions^ loadOptions
)

Parameters

imagXpress
An ImagXpress workspace component.
filename
A string value that represents the filename.
pageNumber
An integer which represents the page number from the file.
loadOptions
Additional loading options as they pertain to the different file for formats.

Return Type

A newly created ImageX object.

Remarks

The decompressed image is stored in the ImageX object.

See Also

ImageX Class | ImageX Members | Overload List


FromHbitmap Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

FromHbitmap Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : FromHbitmap Method

Creates an ImageX object from the given Hbitmap object.

Overload List

Creates an ImageX object from the given Hbitmap object.

[Visual Basic] Overloads Public Shared Function FromHbitmap(ImagXpress,IntPtr) As ImageX

[C#] public static ImageX FromHbitmap(ImagXpress,IntPtr);

[C++] public static ImageX* FromHbitmap(ImagXpress*,IntPtr);

[C++/CLI] public static ImageX^ FromHbitmap(ImagXpress^,IntPtr);

Creates an ImageX object from the given Hbitmap object.

[Visual Basic] Overloads Public Shared Function FromHbitmap(ImagXpress,IntPtr,IntPtr) As ImageX

[C#] public static ImageX FromHbitmap(ImagXpress,IntPtr,IntPtr);

[C++] public static ImageX* FromHbitmap(ImagXpress*,IntPtr,IntPtr);

[C++/CLI] public static ImageX^ FromHbitmap(ImagXpress^,IntPtr,IntPtr);

See Also

ImageX Class | ImageX Members


FromHbitmap(ImagXpress,IntPtr) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An ImagXpress workspace instance.
Hbitmap
An IntPtr which represents the bitmap handle.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

FromHbitmap(ImagXpress,IntPtr) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > FromHbitmap Method : FromHbitmap(ImagXpress,IntPtr) Method

Creates an ImageX object from the given Hbitmap object.

[Visual Basic]
Overloads Public Shared Function FromHbitmap( _
   ByVal imagXpress As ImagXpress, _
   ByVal Hbitmap As IntPtr _
) As ImageX
[C#]
public static ImageX FromHbitmap(
   ImagXpress imagXpress,
   IntPtr Hbitmap
);
[C++]
public: static ImageX* FromHbitmap(
   ImagXpress* imagXpress,
   IntPtr Hbitmap
)
[C++/CLI]
public:
static ImageX^ FromHbitmap(
   ImagXpress^ imagXpress,
   IntPtr Hbitmap
)

Parameters

imagXpress
An ImagXpress workspace instance.
Hbitmap
An IntPtr which represents the bitmap handle.

Return Type

The newly created ImageX object.

See Also

ImageX Class | ImageX Members | Overload List


FromHbitmap(ImagXpress,IntPtr,IntPtr) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An ImagXpress workspace instance.
Hbitmap
An intptr which represents the bitmap handle.
Hpalette
An intptr which represents the palette handle.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

FromHbitmap(ImagXpress,IntPtr,IntPtr) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > FromHbitmap Method : FromHbitmap(ImagXpress,IntPtr,IntPtr) Method

Creates an ImageX object from the given Hbitmap object.

[Visual Basic]
Overloads Public Shared Function FromHbitmap( _
   ByVal imagXpress As ImagXpress, _
   ByVal Hbitmap As IntPtr, _
   ByVal Hpalette As IntPtr _
) As ImageX
[C#]
public static ImageX FromHbitmap(
   ImagXpress imagXpress,
   IntPtr Hbitmap,
   IntPtr Hpalette
);
[C++]
public: static ImageX* FromHbitmap(
   ImagXpress* imagXpress,
   IntPtr Hbitmap,
   IntPtr Hpalette
)
[C++/CLI]
public:
static ImageX^ FromHbitmap(
   ImagXpress^ imagXpress,
   IntPtr Hbitmap,
   IntPtr Hpalette
)

Parameters

imagXpress
An ImagXpress workspace instance.
Hbitmap
An intptr which represents the bitmap handle.
Hpalette
An intptr which represents the palette handle.

Return Type

The newly created ImageX object.

See Also

ImageX Class | ImageX Members | Overload List


FromHdib Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

FromHdib Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : FromHdib Method

Creates an ImagX object from the given hdib object.

Overload List

Creates an ImagX object from the given hdib object.

[Visual Basic] Overloads Public Shared Function FromHdib(ImagXpress,IntPtr) As ImageX

[C#] public static ImageX FromHdib(ImagXpress,IntPtr);

[C++] public static ImageX* FromHdib(ImagXpress*,IntPtr);

[C++/CLI] public static ImageX^ FromHdib(ImagXpress^,IntPtr);

Creates an ImageX object from a handle to a DIB( Device Independent Bitmap ).

[Visual Basic] Overloads Public Shared Function FromHdib(ImagXpress,IntPtr,Boolean) As ImageX

[C#] public static ImageX FromHdib(ImagXpress,IntPtr,bool);

[C++] public static ImageX* FromHdib(ImagXpress*,IntPtr,bool);

[C++/CLI] public static ImageX^ FromHdib(ImagXpress^,IntPtr,bool);

See Also

ImageX Class | ImageX Members


FromHdib(ImagXpress,IntPtr) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An imagXpress workspace instance.
hdib
An handle to a DIB (Device Independent Bitmap).
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

FromHdib(ImagXpress,IntPtr) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > FromHdib Method : FromHdib(ImagXpress,IntPtr) Method

Creates an ImagX object from the given hdib object.

[Visual Basic]
Overloads Public Shared Function FromHdib( _
   ByVal imagXpress As ImagXpress, _
   ByVal hdib As IntPtr _
) As ImageX
[C#]
public static ImageX FromHdib(
   ImagXpress imagXpress,
   IntPtr hdib
);
[C++]
public: static ImageX* FromHdib(
   ImagXpress* imagXpress,
   IntPtr hdib
)
[C++/CLI]
public:
static ImageX^ FromHdib(
   ImagXpress^ imagXpress,
   IntPtr hdib
)

Parameters

imagXpress
An imagXpress workspace instance.
hdib
An handle to a DIB (Device Independent Bitmap).

Return Type

The ImageX object that receives the given image.

Remarks

A copy of the original image is stored in the ImageX object.

See Also

ImageX Class | ImageX Members | Overload List


FromHdib(ImagXpress,IntPtr,Boolean) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An ImagXpress workspace component
hdib
A handle to a DIB
ownDib
Controls whether the Dib is owned by the ImageX object and can be freed at will or if the user would like to maintain ownership of the Dib.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

FromHdib(ImagXpress,IntPtr,Boolean) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > FromHdib Method : FromHdib(ImagXpress,IntPtr,Boolean) Method

Creates an ImageX object from a handle to a DIB( Device Independent Bitmap ).

[Visual Basic]
Overloads Public Shared Function FromHdib( _
   ByVal imagXpress As ImagXpress, _
   ByVal hdib As IntPtr, _
   ByVal ownDib As Boolean _
) As ImageX
[C#]
public static ImageX FromHdib(
   ImagXpress imagXpress,
   IntPtr hdib,
   bool ownDib
);
[C++]
public: static ImageX* FromHdib(
   ImagXpress* imagXpress,
   IntPtr hdib,
   bool ownDib
)
[C++/CLI]
public:
static ImageX^ FromHdib(
   ImagXpress^ imagXpress,
   IntPtr hdib,
   bool ownDib
)

Parameters

imagXpress
An ImagXpress workspace component
hdib
A handle to a DIB
ownDib
Controls whether the Dib is owned by the ImageX object and can be freed at will or if the user would like to maintain ownership of the Dib.

Return Type

An ImageX object

See Also

ImageX Class | ImageX Members | Overload List


FromStream Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

FromStream Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : FromStream Method

Returns an ImageX object from the given ImagXpress instance and stream

Overload List

Returns an ImageX object from the given ImagXpress instance and stream

[Visual Basic] Overloads Public Shared Function FromStream(ImagXpress,Stream) As ImageX

[C#] public static ImageX FromStream(ImagXpress,Stream);

[C++] public static ImageX* FromStream(ImagXpress*,Stream*);

[C++/CLI] public static ImageX^ FromStream(ImagXpress^,Stream^);

Returns an ImageX object from the given ImagXpress instance, stream and page number.

[Visual Basic] Overloads Public Shared Function FromStream(ImagXpress,Stream,Integer) As ImageX

[C#] public static ImageX FromStream(ImagXpress,Stream,int);

[C++] public static ImageX* FromStream(ImagXpress*,Stream*,int);

[C++/CLI] public static ImageX^ FromStream(ImagXpress^,Stream^,int);

Returns an ImageX object from the given ImagXpress instance, stream and load options.

[Visual Basic] Overloads Public Shared Function FromStream(ImagXpress,Stream,LoadOptions) As ImageX

[C#] public static ImageX FromStream(ImagXpress,Stream,LoadOptions);

[C++] public static ImageX* FromStream(ImagXpress*,Stream*,LoadOptions*);

[C++/CLI] public static ImageX^ FromStream(ImagXpress^,Stream^,LoadOptions^);

Returns an ImageX object from the given ImagXpress instance, stream, page number and load options.

[Visual Basic] Overloads Public Shared Function FromStream(ImagXpress,Stream,Integer,LoadOptions) As ImageX

[C#] public static ImageX FromStream(ImagXpress,Stream,int,LoadOptions);

[C++] public static ImageX* FromStream(ImagXpress*,Stream*,int,LoadOptions*);

[C++/CLI] public static ImageX^ FromStream(ImagXpress^,Stream^,int,LoadOptions^);

See Also

ImageX Class | ImageX Members


FromStream(ImagXpress,Stream) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An ImagXpress workspace component.
stream
A stream to obtain the image from.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

FromStream(ImagXpress,Stream) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > FromStream Method : FromStream(ImagXpress,Stream) Method

Returns an ImageX object from the given ImagXpress instance and stream

[Visual Basic]
Overloads Public Shared Function FromStream( _
   ByVal imagXpress As ImagXpress, _
   ByVal stream As Stream _
) As ImageX
[C#]
public static ImageX FromStream(
   ImagXpress imagXpress,
   Stream stream
);
[C++]
public: static ImageX* FromStream(
   ImagXpress* imagXpress,
   Stream* stream
)
[C++/CLI]
public:
static ImageX^ FromStream(
   ImagXpress^ imagXpress,
   Stream^ stream
)

Parameters

imagXpress
An ImagXpress workspace component.
stream
A stream to obtain the image from.

Return Type

The newly created ImageX object.

See Also

ImageX Class | ImageX Members | Overload List


FromStream(ImagXpress,Stream,Int32) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An ImagXpress workspace component.
stream
A stream to obtain the image from.
pageNumber
An integer which represents the page number.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

FromStream(ImagXpress,Stream,Int32) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > FromStream Method : FromStream(ImagXpress,Stream,Int32) Method

Returns an ImageX object from the given ImagXpress instance, stream and page number.

[Visual Basic]
Overloads Public Shared Function FromStream( _
   ByVal imagXpress As ImagXpress, _
   ByVal stream As Stream, _
   ByVal pageNumber As Integer _
) As ImageX
[C#]
public static ImageX FromStream(
   ImagXpress imagXpress,
   Stream stream,
   int pageNumber
);
[C++]
public: static ImageX* FromStream(
   ImagXpress* imagXpress,
   Stream* stream,
   int pageNumber
)
[C++/CLI]
public:
static ImageX^ FromStream(
   ImagXpress^ imagXpress,
   Stream^ stream,
   int pageNumber
)

Parameters

imagXpress
An ImagXpress workspace component.
stream
A stream to obtain the image from.
pageNumber
An integer which represents the page number.

Return Type

The newly created ImageX object.

See Also

ImageX Class | ImageX Members | Overload List


FromStream(ImagXpress,Stream,LoadOptions) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An ImagXpress workspace component.
stream
A stream to obtain the image from.
loadOptions
Additional load options that pertain to the image.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

FromStream(ImagXpress,Stream,LoadOptions) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > FromStream Method : FromStream(ImagXpress,Stream,LoadOptions) Method

Returns an ImageX object from the given ImagXpress instance, stream and load options.

[Visual Basic]
Overloads Public Shared Function FromStream( _
   ByVal imagXpress As ImagXpress, _
   ByVal stream As Stream, _
   ByVal loadOptions As LoadOptions _
) As ImageX
[C#]
public static ImageX FromStream(
   ImagXpress imagXpress,
   Stream stream,
   LoadOptions loadOptions
);
[C++]
public: static ImageX* FromStream(
   ImagXpress* imagXpress,
   Stream* stream,
   LoadOptions* loadOptions
)
[C++/CLI]
public:
static ImageX^ FromStream(
   ImagXpress^ imagXpress,
   Stream^ stream,
   LoadOptions^ loadOptions
)

Parameters

imagXpress
An ImagXpress workspace component.
stream
A stream to obtain the image from.
loadOptions
Additional load options that pertain to the image.

Return Type

The newly created ImageX object.

See Also

ImageX Class | ImageX Members | Overload List


FromStream(ImagXpress,Stream,Int32,LoadOptions) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An ImagXpress workspace component.
stream
A stream to obtain the image from.
pageNumber
An integer which represents the page number.
loadOptions
Additional load options that pertain to the image.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

FromStream(ImagXpress,Stream,Int32,LoadOptions) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > FromStream Method : FromStream(ImagXpress,Stream,Int32,LoadOptions) Method

Returns an ImageX object from the given ImagXpress instance, stream, page number and load options.

[Visual Basic]
Overloads Public Shared Function FromStream( _
   ByVal imagXpress As ImagXpress, _
   ByVal stream As Stream, _
   ByVal pageNumber As Integer, _
   ByVal loadOptions As LoadOptions _
) As ImageX
[C#]
public static ImageX FromStream(
   ImagXpress imagXpress,
   Stream stream,
   int pageNumber,
   LoadOptions loadOptions
);
[C++]
public: static ImageX* FromStream(
   ImagXpress* imagXpress,
   Stream* stream,
   int pageNumber,
   LoadOptions* loadOptions
)
[C++/CLI]
public:
static ImageX^ FromStream(
   ImagXpress^ imagXpress,
   Stream^ stream,
   int pageNumber,
   LoadOptions^ loadOptions
)

Parameters

imagXpress
An ImagXpress workspace component.
stream
A stream to obtain the image from.
pageNumber
An integer which represents the page number.
loadOptions
Additional load options that pertain to the image.

Return Type

The newly created ImageX object.

See Also

ImageX Class | ImageX Members | Overload List


GetGraphics Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GetGraphics Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : GetGraphics Method

Gets a System.Drawing.Graphics object with the image selected into it for drawing on the image.

[Visual Basic]
Public Function GetGraphics() As Graphics
[C#]
public Graphics GetGraphics();
[C++]
public: Graphics* GetGraphics();
[C++/CLI]
public:
Graphics^ GetGraphics();

Return Type

A System.Drawing.Graphics object

Remarks

This routine gets a System.Drawing.Graphics object with the image selected into it. The graphics object may then be drawn upon using the standard System.Drawing.Graphics drawing methods. Do not call Dispose on this Graphics object directly but instead call the ReleaseGraphics method. An exception will be generated if more than one call to GetGraphics is done without a ReleaseGraphics being called. The ImageX object may have a new bit depth after a GetGraphics/ReleaseGraphics set of calls.

See Also

ImageX Class | ImageX Members


GetTags Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An imagXpress workspace instance.
filename
A string value which represents the filename.
pageNumber
An integer value which represents the page number.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GetTags Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : GetTags Method

Returns the ImageXTagCollection for the file and page requested without loading the image. This method is being deprecated because there are other meta-data items in an image. Please use ReadAllMetaData() which returns an ImageX object containing Tiff/Exif and Iptc tags The Tiff tags can be obtained by ImageX.Tags property and the Iptc meta-data similarly with ImageX.Iptc. Future Meta-data can be obtained in a like manner.

[Visual Basic]
<ObsoleteAttribute("Please use ReadAllMetaData() instead")>
Public Shared Function GetTags( _
   ByVal imagXpress As ImagXpress, _
   ByVal filename As String, _
   ByVal pageNumber As Integer _
) As ImageXTagCollection
[C#]
[ObsoleteAttribute("Please use ReadAllMetaData() instead")]
public static ImageXTagCollection GetTags(
   ImagXpress imagXpress,
   string filename,
   int pageNumber
);
[C++]
[ObsoleteAttribute("Please use ReadAllMetaData() instead")]
public: static ImageXTagCollection* GetTags(
   ImagXpress* imagXpress,
   string* filename,
   int pageNumber
)
[C++/CLI]
[ObsoleteAttribute("Please use ReadAllMetaData() instead")]
public:
static ImageXTagCollection^ GetTags(
   ImagXpress^ imagXpress,
   String^ filename,
   int pageNumber
)

Parameters

imagXpress
An imagXpress workspace instance.
filename
A string value which represents the filename.
pageNumber
An integer value which represents the page number.

Return Type

The collection of meta-tags in the specified file and page.

Remarks

Upon completion of this method, meta-the tags in the ImageXTagCollection are populated with the tags from the file.

Note: Available in View and Document editions.

See Also

ImageX Class | ImageX Members


HorizontalResolution Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

HorizontalResolution Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : HorizontalResolution Method

Returns the horizontal resolution of this ImageX image.

[Visual Basic]
Public Function HorizontalResolution() As Single
[C#]
public float HorizontalResolution();
[C++]
public: float HorizontalResolution();
[C++/CLI]
public:
float HorizontalResolution();

Remarks

Applies to TIFF, PCX and BMP images only.

Note: Available in all editions.

See Also

ImageX Class | ImageX Members


InsertPage Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An imagXpress workspace instance.
srcFileName
A string which represents the file containing a page to be inserted into the TIFF file.
dstFileName
The destination file, which includes the inserted page.
pageNumber
The position in the destination file at which the page is added.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

InsertPage Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : InsertPage Method

Inserts a new page into a multi-page document.

[Visual Basic]
Public Shared Sub InsertPage( _
   ByVal imagXpress As ImagXpress, _
   ByVal srcFileName As String, _
   ByVal dstFileName As String, _
   ByVal pageNumber As Integer _
)
[C#]
public static void InsertPage(
   ImagXpress imagXpress,
   string srcFileName,
   string dstFileName,
   int pageNumber
);
[C++]
public: static void InsertPage(
   ImagXpress* imagXpress,
   string* srcFileName,
   string* dstFileName,
   int pageNumber
)
[C++/CLI]
public:
static void InsertPage(
   ImagXpress^ imagXpress,
   String^ srcFileName,
   String^ dstFileName,
   int pageNumber
)

Parameters

imagXpress
An imagXpress workspace instance.
srcFileName
A string which represents the file containing a page to be inserted into the TIFF file.
dstFileName
The destination file, which includes the inserted page.
pageNumber
The position in the destination file at which the page is added.

Remarks

This method is for TIFF and EXIF file formats. This method is available in ImagXpress Document and Photo versions.

See Also

ImageX Class | ImageX Members


NumPages Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An imagXpress workspace instance.
fileName
A string which represents the filename.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

NumPages Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : NumPages Method

Returns the number of image pages from the given multiple page PDF, TIFF or DCX file.

[Visual Basic]
Public Shared Function NumPages( _
   ByVal imagXpress As ImagXpress, _
   ByVal fileName As String _
) As Integer
[C#]
public static int NumPages(
   ImagXpress imagXpress,
   string fileName
);
[C++]
public: static int NumPages(
   ImagXpress* imagXpress,
   string* fileName
)
[C++/CLI]
public:
static int NumPages(
   ImagXpress^ imagXpress,
   String^ fileName
)

Parameters

imagXpress
An imagXpress workspace instance.
fileName
A string which represents the filename.

Return Type

Returns the number of image pages in the given multiple page PDF, TIFF or DCX file starting at 1.

Remarks

If an error occurs, ImagXpress throws an exception message, otherwise it returns this properties value.

See Also

ImageX Class | ImageX Members


QueryBuffer Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

QueryBuffer Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : QueryBuffer Method

Query buffer for image information such as width, height, bitdepth and image data type.

Overload List

Query buffer for image information such as width, height, bitdepth and image data type.

[Visual Basic] Overloads Public Shared Function QueryBuffer(ImagXpress,Byte(),Integer,LoadOptions) As ImageXData

[C#] public static ImageXData QueryBuffer(ImagXpress,byte[],int,LoadOptions);

[C++] public static ImageXData* QueryBuffer(ImagXpress*,byte[]*,int,LoadOptions*);

[C++/CLI] public static ImageXData^ QueryBuffer(ImagXpress^,bytearray<buffer>^,int,LoadOptions^);

Query buffer for image information such as width, height, bitdepth and image data type.

[Visual Basic] Overloads Public Shared Function QueryBuffer(ImagXpress,Byte(),Integer) As ImageXData

[C#] public static ImageXData QueryBuffer(ImagXpress,byte[],int);

[C++] public static ImageXData* QueryBuffer(ImagXpress*,byte[]*,int);

[C++/CLI] public static ImageXData^ QueryBuffer(ImagXpress^,bytearray<buffer>^,int);

See Also

ImageX Class | ImageX Members


QueryBuffer(ImagXpress,Byte[],Int32,LoadOptions) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An imagXpress workspace instance.
buffer
A byte array which contains image information.
pageNumber
An integer value which represents the page number.
loadOptions
Additional load options which contain information about loading the image.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

QueryBuffer(ImagXpress,Byte[],Int32,LoadOptions) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > QueryBuffer Method : QueryBuffer(ImagXpress,Byte[],Int32,LoadOptions) Method

Query buffer for image information such as width, height, bitdepth and image data type.

[Visual Basic]
Overloads Public Shared Function QueryBuffer( _
   ByVal imagXpress As ImagXpress, _
   ByVal buffer() As Byte, _
   ByVal pageNumber As Integer, _
   ByVal loadOptions As LoadOptions _
) As ImageXData
[C#]
public static ImageXData QueryBuffer(
   ImagXpress imagXpress,
   byte[] buffer,
   int pageNumber,
   LoadOptions loadOptions
);
[C++]
public: static ImageXData* QueryBuffer(
   ImagXpress* imagXpress,
   byte[]* buffer,
   int pageNumber,
   LoadOptions* loadOptions
)
[C++/CLI]
public:
static ImageXData^ QueryBuffer(
   ImagXpress^ imagXpress,
   bytearray<buffer>^ buffer,
   int pageNumber,
   LoadOptions^ loadOptions
)

Parameters

imagXpress
An imagXpress workspace instance.
buffer
A byte array which contains image information.
pageNumber
An integer value which represents the page number.
loadOptions
Additional load options which contain information about loading the image.

Return Type

An ImageXData object containing information about the image being queried.

Remarks

Options can select to query for other options constraints.

See Also

ImageX Class | ImageX Members | Overload List


QueryBuffer(ImagXpress,Byte[],Int32) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An imagXpress workspace instance.
buffer
A byte array which contains image information.
pageNumber
An integer value which represents a page number.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

QueryBuffer(ImagXpress,Byte[],Int32) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > QueryBuffer Method : QueryBuffer(ImagXpress,Byte[],Int32) Method

Query buffer for image information such as width, height, bitdepth and image data type.

[Visual Basic]
Overloads Public Shared Function QueryBuffer( _
   ByVal imagXpress As ImagXpress, _
   ByVal buffer() As Byte, _
   ByVal pageNumber As Integer _
) As ImageXData
[C#]
public static ImageXData QueryBuffer(
   ImagXpress imagXpress,
   byte[] buffer,
   int pageNumber
);
[C++]
public: static ImageXData* QueryBuffer(
   ImagXpress* imagXpress,
   byte[]* buffer,
   int pageNumber
)
[C++/CLI]
public:
static ImageXData^ QueryBuffer(
   ImagXpress^ imagXpress,
   bytearray<buffer>^ buffer,
   int pageNumber
)

Parameters

imagXpress
An imagXpress workspace instance.
buffer
A byte array which contains image information.
pageNumber
An integer value which represents a page number.

Return Type

Options can select to query for other options constraints.

See Also

ImageX Class | ImageX Members | Overload List


QueryFile Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

QueryFile Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : QueryFile Method

Returns information about an image file without loading the image into ImagXpress.

Overload List

Returns information about an image file without loading the image into ImagXpress.

[Visual Basic] Overloads Public Shared Function QueryFile(ImagXpress,String) As ImageXData

[C#] public static ImageXData QueryFile(ImagXpress,string);

[C++] public static ImageXData* QueryFile(ImagXpress*,string*);

[C++/CLI] public static ImageXData^ QueryFile(ImagXpress^,String^);

Returns information about an image file from the given filename and page number.

[Visual Basic] Overloads Public Shared Function QueryFile(ImagXpress,String,Integer) As ImageXData

[C#] public static ImageXData QueryFile(ImagXpress,string,int);

[C++] public static ImageXData* QueryFile(ImagXpress*,string*,int);

[C++/CLI] public static ImageXData^ QueryFile(ImagXpress^,String^,int);

Returns an ImageXData object from the given filename, page number and load options.

[Visual Basic] Overloads Public Shared Function QueryFile(ImagXpress,String,Integer,LoadOptions) As ImageXData

[C#] public static ImageXData QueryFile(ImagXpress,string,int,LoadOptions);

[C++] public static ImageXData* QueryFile(ImagXpress*,string*,int,LoadOptions*);

[C++/CLI] public static ImageXData^ QueryFile(ImagXpress^,String^,int,LoadOptions^);

See Also

ImageX Class | ImageX Members


QueryFile(ImagXpress,String) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An imagXpress workspace instance.
filename
A string which represents the file name.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

QueryFile(ImagXpress,String) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > QueryFile Method : QueryFile(ImagXpress,String) Method

Returns information about an image file without loading the image into ImagXpress.

[Visual Basic]
Overloads Public Shared Function QueryFile( _
   ByVal imagXpress As ImagXpress, _
   ByVal filename As String _
) As ImageXData
[C#]
public static ImageXData QueryFile(
   ImagXpress imagXpress,
   string filename
);
[C++]
public: static ImageXData* QueryFile(
   ImagXpress* imagXpress,
   string* filename
)
[C++/CLI]
public:
static ImageXData^ QueryFile(
   ImagXpress^ imagXpress,
   String^ filename
)

Parameters

imagXpress
An imagXpress workspace instance.
filename
A string which represents the file name.

Return Type

An ImageXData object containing information about the image being queried.

See Also

ImageX Class | ImageX Members | Overload List


QueryFile(ImagXpress,String,Int32) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An imagXpress workspace instance.
filename
A string which represents the file name.
pageNumber
An integer which represents the page number within the file.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

QueryFile(ImagXpress,String,Int32) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > QueryFile Method : QueryFile(ImagXpress,String,Int32) Method

Returns information about an image file from the given filename and page number.

[Visual Basic]
Overloads Public Shared Function QueryFile( _
   ByVal imagXpress As ImagXpress, _
   ByVal filename As String, _
   ByVal pageNumber As Integer _
) As ImageXData
[C#]
public static ImageXData QueryFile(
   ImagXpress imagXpress,
   string filename,
   int pageNumber
);
[C++]
public: static ImageXData* QueryFile(
   ImagXpress* imagXpress,
   string* filename,
   int pageNumber
)
[C++/CLI]
public:
static ImageXData^ QueryFile(
   ImagXpress^ imagXpress,
   String^ filename,
   int pageNumber
)

Parameters

imagXpress
An imagXpress workspace instance.
filename
A string which represents the file name.
pageNumber
An integer which represents the page number within the file.

Return Type

An ImageXData object containing information about the image being queried.

See Also

ImageX Class | ImageX Members | Overload List


QueryFile(ImagXpress,String,Int32,LoadOptions) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An imagXpress workspace instance.
filename
A string value which represents the file name.
pageNumber
An integer which represents the page number.
loadOptions
Load options associated with the given image.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

QueryFile(ImagXpress,String,Int32,LoadOptions) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > QueryFile Method : QueryFile(ImagXpress,String,Int32,LoadOptions) Method

Returns an ImageXData object from the given filename, page number and load options.

[Visual Basic]
Overloads Public Shared Function QueryFile( _
   ByVal imagXpress As ImagXpress, _
   ByVal filename As String, _
   ByVal pageNumber As Integer, _
   ByVal loadOptions As LoadOptions _
) As ImageXData
[C#]
public static ImageXData QueryFile(
   ImagXpress imagXpress,
   string filename,
   int pageNumber,
   LoadOptions loadOptions
);
[C++]
public: static ImageXData* QueryFile(
   ImagXpress* imagXpress,
   string* filename,
   int pageNumber,
   LoadOptions* loadOptions
)
[C++/CLI]
public:
static ImageXData^ QueryFile(
   ImagXpress^ imagXpress,
   String^ filename,
   int pageNumber,
   LoadOptions^ loadOptions
)

Parameters

imagXpress
An imagXpress workspace instance.
filename
A string value which represents the file name.
pageNumber
An integer which represents the page number.
loadOptions
Load options associated with the given image.

Return Type

An ImageXData object containing information about the image being queried.

See Also

ImageX Class | ImageX Members | Overload List


QueryFromStream Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

QueryFromStream Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : QueryFromStream Method

Query buffer stream for image information such as width, height, bitdepth and image data type.

Overload List

Query buffer stream for image information such as width, height, bitdepth and image data type.

[Visual Basic] Overloads Public Shared Function QueryFromStream(ImagXpress,Stream,Integer) As ImageXData

[C#] public static ImageXData QueryFromStream(ImagXpress,Stream,int);

[C++] public static ImageXData* QueryFromStream(ImagXpress*,Stream*,int);

[C++/CLI] public static ImageXData^ QueryFromStream(ImagXpress^,Stream^,int);

Query buffer stream for image information such as width, height, bitdepth and image data type. Options can select to query for other options constraints.

[Visual Basic] Overloads Public Shared Function QueryFromStream(ImagXpress,Stream,Integer,LoadOptions) As ImageXData

[C#] public static ImageXData QueryFromStream(ImagXpress,Stream,int,LoadOptions);

[C++] public static ImageXData* QueryFromStream(ImagXpress*,Stream*,int,LoadOptions*);

[C++/CLI] public static ImageXData^ QueryFromStream(ImagXpress^,Stream^,int,LoadOptions^);

See Also

ImageX Class | ImageX Members


QueryFromStream(ImagXpress,Stream,Int32) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An imagXpress workspace instance.
stream
A stream which contains image information.
pageNumber
An integer value which represents the page number.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

QueryFromStream(ImagXpress,Stream,Int32) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > QueryFromStream Method : QueryFromStream(ImagXpress,Stream,Int32) Method

Query buffer stream for image information such as width, height, bitdepth and image data type.

[Visual Basic]
Overloads Public Shared Function QueryFromStream( _
   ByVal imagXpress As ImagXpress, _
   ByVal stream As Stream, _
   ByVal pageNumber As Integer _
) As ImageXData
[C#]
public static ImageXData QueryFromStream(
   ImagXpress imagXpress,
   Stream stream,
   int pageNumber
);
[C++]
public: static ImageXData* QueryFromStream(
   ImagXpress* imagXpress,
   Stream* stream,
   int pageNumber
)
[C++/CLI]
public:
static ImageXData^ QueryFromStream(
   ImagXpress^ imagXpress,
   Stream^ stream,
   int pageNumber
)

Parameters

imagXpress
An imagXpress workspace instance.
stream
A stream which contains image information.
pageNumber
An integer value which represents the page number.

Return Type

An ImageXData object containing information about the image being queried.

See Also

ImageX Class | ImageX Members | Overload List


QueryFromStream(ImagXpress,Stream,Int32,LoadOptions) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An imagXpress workspace instance.
stream
A stream which contains image information.
pageNumber
An integer value which represents the page number.
loadOptions
Additional load options which contain data for loading the image.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

QueryFromStream(ImagXpress,Stream,Int32,LoadOptions) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > QueryFromStream Method : QueryFromStream(ImagXpress,Stream,Int32,LoadOptions) Method

Query buffer stream for image information such as width, height, bitdepth and image data type. Options can select to query for other options constraints.

[Visual Basic]
Overloads Public Shared Function QueryFromStream( _
   ByVal imagXpress As ImagXpress, _
   ByVal stream As Stream, _
   ByVal pageNumber As Integer, _
   ByVal loadOptions As LoadOptions _
) As ImageXData
[C#]
public static ImageXData QueryFromStream(
   ImagXpress imagXpress,
   Stream stream,
   int pageNumber,
   LoadOptions loadOptions
);
[C++]
public: static ImageXData* QueryFromStream(
   ImagXpress* imagXpress,
   Stream* stream,
   int pageNumber,
   LoadOptions* loadOptions
)
[C++/CLI]
public:
static ImageXData^ QueryFromStream(
   ImagXpress^ imagXpress,
   Stream^ stream,
   int pageNumber,
   LoadOptions^ loadOptions
)

Parameters

imagXpress
An imagXpress workspace instance.
stream
A stream which contains image information.
pageNumber
An integer value which represents the page number.
loadOptions
Additional load options which contain data for loading the image.

Return Type

An ImageXData object containing information about the image being queried.

See Also

ImageX Class | ImageX Members | Overload List


ReadAllMetaData Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
The ImagXpress workspace component.
filename
The filename.
pageNumber
The page number.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ReadAllMetaData Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : ReadAllMetaData Method

Perferred method for obtaining all Meta-data items. Simply fetch the tag collections with ImageX.IptcDataSet and ImageX.Tags; Later that object can be passed to the SaveAllMetaData to save all edits

[Visual Basic]
Public Shared Function ReadAllMetaData( _
   ByVal imagXpress As ImagXpress, _
   ByVal filename As String, _
   ByVal pageNumber As Integer _
) As ImageX
[C#]
public static ImageX ReadAllMetaData(
   ImagXpress imagXpress,
   string filename,
   int pageNumber
);
[C++]
public: static ImageX* ReadAllMetaData(
   ImagXpress* imagXpress,
   string* filename,
   int pageNumber
)
[C++/CLI]
public:
static ImageX^ ReadAllMetaData(
   ImagXpress^ imagXpress,
   String^ filename,
   int pageNumber
)

Parameters

imagXpress
The ImagXpress workspace component.
filename
The filename.
pageNumber
The page number.

See Also

ImageX Class | ImageX Members


ReleaseGraphics Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ReleaseGraphics Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : ReleaseGraphics Method

Releases the previously received System.Drawing.Graphics object.

Overload List

Releases the previously received System.Drawing.Graphics object.

[Visual Basic] Overloads Public Sub ReleaseGraphics()

[C#] public void ReleaseGraphics();

[C++] public void ReleaseGraphics()

[C++/CLI] public void ReleaseGraphics()

Releases the previously received System.Drawing.Graphics object.

[Visual Basic] Overloads Public Sub ReleaseGraphics(Boolean)

[C#] public void ReleaseGraphics(bool);

[C++] public void ReleaseGraphics(bool);

[C++/CLI] public void ReleaseGraphics(bool);

See Also

ImageX Class | ImageX Members


ReleaseGraphics() Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ReleaseGraphics() Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > ReleaseGraphics Method : ReleaseGraphics() Method

Releases the previously received System.Drawing.Graphics object.

[Visual Basic]
Overloads Public Sub ReleaseGraphics()
[C#]
public void ReleaseGraphics();
[C++]
public: void ReleaseGraphics();
[C++/CLI]
public:
void ReleaseGraphics();

Return Type

void

Remarks

Releases the previously received Graphics object and updates the ImageX object with the image in the Graphics object. The ImageX object may have a new bit depth after a GetGraphics/ReleaseGraphics set of calls. The previously returned Graphics object is Disposed and should no longer be used. An exception will be generated if this routine is called without a matching GetGraphics call. The ImageX object may have a new bit depth after a GetGraphics/ReleaseGraphics set of calls.

See Also

ImageX Class | ImageX Members | Overload List


ReleaseGraphics(Boolean) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

update
Controls whether the current image is updated with the image that has been drawn upon in the graphics object.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ReleaseGraphics(Boolean) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > ReleaseGraphics Method : ReleaseGraphics(Boolean) Method

Releases the previously received System.Drawing.Graphics object.

[Visual Basic]
Overloads Public Sub ReleaseGraphics( _
   ByVal update As Boolean _
)
[C#]
public void ReleaseGraphics(
   bool update
);
[C++]
public: void ReleaseGraphics(
   bool update
)
[C++/CLI]
public:
void ReleaseGraphics(
   bool update
)

Parameters

update
Controls whether the current image is updated with the image that has been drawn upon in the graphics object.

Return Type

void

Remarks

If the update parameter is true then the ImageX object is update to the image in the previously returned Graphics object. If the update parameter is false then the ImageX object is not updated. In either case, the previously returned Graphics object is Disposed and should no longer be used. The ImageX object may have a new bit depth after a GetGraphics/ReleaseGraphics set of calls. An exception will be generated if this routine is called without a matching GetGraphics call. The ImageX object may have a new bit depth after a GetGraphics/ReleaseGraphics set of calls.

See Also

ImageX Class | ImageX Members | Overload List


ResolutionUnits Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ResolutionUnits Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : ResolutionUnits Method (ImageX)

Returns the graphics units in which resolution information is specified.

[Visual Basic]
Public Function ResolutionUnits() As GraphicsUnit
[C#]
public GraphicsUnit ResolutionUnits();
[C++]
public: GraphicsUnit ResolutionUnits();
[C++/CLI]
public:
GraphicsUnit ResolutionUnits();

Return Type

The unit of measure for the ImageX image resolution.

Remarks

Applies to resolution information provided by VerticalResoluion, HorizontalResulution and Resolution.

Note: Available in all editions.

See Also

ImageX Class | ImageX Members


ReturnJpegComment Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

Index
An integer which represents the index within the JPEG comment list for which the comment text is returned.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ReturnJpegComment Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : ReturnJpegComment Method

Returns a JPEG String from the loaded JPEG file if one exists.

[Visual Basic]
Public Function ReturnJpegComment( _
   ByVal Index As Integer _
) As String
[C#]
public string ReturnJpegComment(
   int Index
);
[C++]
public: string* ReturnJpegComment(
   int Index
)
[C++/CLI]
public:
String^ ReturnJpegComment(
   int Index
)

Parameters

Index
An integer which represents the index within the JPEG comment list for which the comment text is returned.

Return Type

A string value which represents the text associated with the given comment in the JPEG comment list.

Remarks

First, get the JpegCommentCount to determine how many JPEG comment strings were found.

The index parameter begins at 1 (if any exist) and ends at count found.

See Also

ImageX Class | ImageX Members


Save Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Save Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : Save Method (ImageX)

Save the image to a given filename.

Overload List

Save the image to a given filename.

[Visual Basic] Overloads Public Sub Save(String)

[C#] public void Save(string);

[C++] public void Save(string*);

[C++/CLI] public void Save(String^);

Save the image to a file giving various saving options.

[Visual Basic] Overloads Public Sub Save(String,SaveOptions)

[C#] public void Save(string,SaveOptions);

[C++] public void Save(string*,SaveOptions*);

[C++/CLI] public void Save(String^,SaveOptions^);

See Also

ImageX Class | ImageX Members


Save(String) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

filename
A string value which represents the file name to save the image to.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Save(String) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > Save Method : Save(String) Method

Save the image to a given filename.

[Visual Basic]
Overloads Public Sub Save( _
   ByVal filename As String _
)
[C#]
public void Save(
   string filename
);
[C++]
public: void Save(
   string* filename
)
[C++/CLI]
public:
void Save(
   String^ filename
)

Parameters

filename
A string value which represents the file name to save the image to.

Remarks

To save an image over the intenet, you must use SaveOptions

See Also

ImageX Class | ImageX Members | Overload List


Save(String,SaveOptions) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

filename
A string value which represents the file name to save the image to.
saveOptions
Save options which contain information about saving the image.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Save(String,SaveOptions) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > Save Method : Save(String,SaveOptions) Method

Save the image to a file giving various saving options.

[Visual Basic]
Overloads Public Sub Save( _
   ByVal filename As String, _
   ByVal saveOptions As SaveOptions _
)
[C#]
public void Save(
   string filename,
   SaveOptions saveOptions
);
[C++]
public: void Save(
   string* filename,
   SaveOptions* saveOptions
)
[C++/CLI]
public:
void Save(
   String^ filename,
   SaveOptions^ saveOptions
)

Parameters

filename
A string value which represents the file name to save the image to.
saveOptions
Save options which contain information about saving the image.

See Also

ImageX Class | ImageX Members | Overload List


SaveAllMetaData Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
The ImagXpress workspace component.
dataCollection
The meta-data collection.
filename
The filename.
pageNumber
The page number.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveAllMetaData Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : SaveAllMetaData Method

The preferred method for saving Tif, Exif, and Iptc meta-data.

[Visual Basic]
Public Shared Sub SaveAllMetaData( _
   ByVal imagXpress As ImagXpress, _
   ByVal dataCollection As ImageX, _
   ByVal filename As String, _
   ByVal pageNumber As Integer _
)
[C#]
public static void SaveAllMetaData(
   ImagXpress imagXpress,
   ImageX dataCollection,
   string filename,
   int pageNumber
);
[C++]
public: static void SaveAllMetaData(
   ImagXpress* imagXpress,
   ImageX* dataCollection,
   string* filename,
   int pageNumber
)
[C++/CLI]
public:
static void SaveAllMetaData(
   ImagXpress^ imagXpress,
   ImageX^ dataCollection,
   String^ filename,
   int pageNumber
)

Parameters

imagXpress
The ImagXpress workspace component.
dataCollection
The meta-data collection.
filename
The filename.
pageNumber
The page number.

Remarks

You should have used ReadAllMetaData to get the ImageX object housing all the meta-data elements.

See Also

ImageX Class | ImageX Members


SaveStream Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveStream Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : SaveStream Method

Saves the current ImageX object to a stream object in the specified file format.

Overload List

Saves the current ImageX object to a stream object in the specified file format.

[Visual Basic] Overloads Public Sub SaveStream(Stream,ImageXFormat)

[C#] public void SaveStream(Stream,ImageXFormat);

[C++] public void SaveStream(Stream*,ImageXFormat);

[C++/CLI] public void SaveStream(Stream^,ImageXFormat);

Saves the current ImageX object to a stream object using the SaveOptions class to specify format and the format's specific parameters.

[Visual Basic] Overloads Public Sub SaveStream(Stream,SaveOptions)

[C#] public void SaveStream(Stream,SaveOptions);

[C++] public void SaveStream(Stream*,SaveOptions*);

[C++/CLI] public void SaveStream(Stream^,SaveOptions^);

See Also

ImageX Class | ImageX Members


SaveStream(Stream,ImageXFormat) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

stream
An opened and writable System.IO.stream derived stream object
format
The image file format to save the ImageX object as
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveStream(Stream,ImageXFormat) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > SaveStream Method : SaveStream(Stream,ImageXFormat) Method

Saves the current ImageX object to a stream object in the specified file format.

[Visual Basic]
Overloads Public Sub SaveStream( _
   ByVal stream As Stream, _
   ByVal format As ImageXFormat _
)
[C#]
public void SaveStream(
   Stream stream,
   ImageXFormat format
);
[C++]
public: void SaveStream(
   Stream* stream,
   ImageXFormat format
)
[C++/CLI]
public:
void SaveStream(
   Stream^ stream,
   ImageXFormat format
)

Parameters

stream
An opened and writable System.IO.stream derived stream object
format
The image file format to save the ImageX object as

Remarks

The stream passed can be any stream derived System.IO.Stream. The stream should be opened be calling this method. The stream should also allow writes.

Example

[C#]

// assume that an ImageX object has been created and is valid
// create a memory stream that will grow as needed.
System.IO.MemoryStream memoryStream = new System.IO.MemoryStream( );
// Save an ImageX object to jpg format with default parameters
imageX.SaveStream( memoryStream, PegasusImaging.WinForms.ImagXpress9.ImageXFormat.Jpeg );
memoryStream.Close( );

See Also

ImageX Class | ImageX Members | Overload List


SaveStream(Stream,SaveOptions) Method

ImageX Class | ImageX Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

stream
An opened and writable System.IO.stream derived stream object
saveOptions
A PegausImaging.Winforms.ImagXpress9.SaveOptions object that specifies the format as well as the format's specific parameters
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveStream(Stream,SaveOptions) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class > SaveStream Method : SaveStream(Stream,SaveOptions) Method

Saves the current ImageX object to a stream object using the SaveOptions class to specify format and the format's specific parameters.

[Visual Basic]
Overloads Public Sub SaveStream( _
   ByVal stream As Stream, _
   ByVal saveOptions As SaveOptions _
)
[C#]
public void SaveStream(
   Stream stream,
   SaveOptions saveOptions
);
[C++]
public: void SaveStream(
   Stream* stream,
   SaveOptions* saveOptions
)
[C++/CLI]
public:
void SaveStream(
   Stream^ stream,
   SaveOptions^ saveOptions
)

Parameters

stream
An opened and writable System.IO.stream derived stream object
saveOptions
A PegausImaging.Winforms.ImagXpress9.SaveOptions object that specifies the format as well as the format's specific parameters

Remarks

The stream passed can be any stream derived System.IO.Stream. The stream should be opened be calling this method. The stream should also allow writes.

Example

[C#]

// assume that an ImageX object has been created and is valid
// create a SaveOptions object to specify format and other parameters
PegasusImaging.WinForms.ImagXpress9.SaveOptions saveOptions
= new PegasusImaging.WinForms.ImagXpress9.SaveOptions( );
// create a memory
stream that will grow as needed.
System.IO.MemoryStream memoryStream = new System.IO.MemoryStream( );
// set the format as well as specific parameters for the format
saveOptions.Format = PegasusImaging.WinForms.ImagXpress9.ImageXFormat.Jpeg;
saveOptions.Jpeg.Luminance = 24;
saveOptions.Jpeg.Chrominance = 30;
// Save an ImageX object to jpg format with luminance and chrominance
imageX.SaveStream( memoryStream, saveOptions );
memoryStream.Close( );

See Also

ImageX Class | ImageX Members | Overload List


SetTags Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An imagXpress workspace instance.
tagCollection
An ImageXTagCollection that contains the tags to be copied to the given file.
filename
A string which represents the file name to copy the tags to.
pageNumber
An integer which represents the page number where the tags are copied.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetTags Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : SetTags Method

Sets the tags of the specified page of the specified file, without loading the image. Warning! This call does not support Iptc data and will cause Iptc data sets to be removed!! Please use the ReadAllMetaData() and SaveAllMetaData() schemes so any data that is not edited will be preserved naturally

[Visual Basic]
<ObsoleteAttribute("Please use SaveAllMetaData() instead")>
Public Shared Sub SetTags( _
   ByVal imagXpress As ImagXpress, _
   ByVal tagCollection As ImageXTagCollection, _
   ByVal filename As String, _
   ByVal pageNumber As Integer _
)
[C#]
[ObsoleteAttribute("Please use SaveAllMetaData() instead")]
public static void SetTags(
   ImagXpress imagXpress,
   ImageXTagCollection tagCollection,
   string filename,
   int pageNumber
);
[C++]
[ObsoleteAttribute("Please use SaveAllMetaData() instead")]
public: static void SetTags(
   ImagXpress* imagXpress,
   ImageXTagCollection* tagCollection,
   string* filename,
   int pageNumber
)
[C++/CLI]
[ObsoleteAttribute("Please use SaveAllMetaData() instead")]
public:
static void SetTags(
   ImagXpress^ imagXpress,
   ImageXTagCollection^ tagCollection,
   String^ filename,
   int pageNumber
)

Parameters

imagXpress
An imagXpress workspace instance.
tagCollection
An ImageXTagCollection that contains the tags to be copied to the given file.
filename
A string which represents the file name to copy the tags to.
pageNumber
An integer which represents the page number where the tags are copied.

Remarks

Note: Available in Document and Photo editions.

See Also

ImageX Class | ImageX Members


ToBitmap Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

release
Controls whether the current image is released from the ImageX object
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToBitmap Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : ToBitmap Method

Gets a System.Drawing.Bitmap object from the ImageX object

[Visual Basic]
Public Function ToBitmap( _
   ByVal release As Boolean _
) As Bitmap
[C#]
public Bitmap ToBitmap(
   bool release
);
[C++]
public: Bitmap* ToBitmap(
   bool release
)
[C++/CLI]
public:
Bitmap^ ToBitmap(
   bool release
)

Parameters

release
Controls whether the current image is released from the ImageX object

Return Type

A System.Drawing.Bitmap object

Remarks

If the release parameter is true then the ImageX object no longer will have a underlying image. It will be an empty image.

See Also

ImageX Class | ImageX Members


ToHbitmap Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

release
A boolean value which controls whether the current image is released from the ImageX object.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToHbitmap Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : ToHbitmap Method

Gets a handle to a bitmap.

[Visual Basic]
Public Function ToHbitmap( _
   ByVal release As Boolean _
) As IntPtr
[C#]
public IntPtr ToHbitmap(
   bool release
);
[C++]
public: IntPtr ToHbitmap(
   bool release
)
[C++/CLI]
public:
IntPtr ToHbitmap(
   bool release
)

Parameters

release
A boolean value which controls whether the current image is released from the ImageX object.

Return Type

An HBITMAP.

Remarks

If the release parameter is true, then the ImageX object no longer has an underlying image. It will be an empty image.

See Also

ImageX Class | ImageX Members


ToHdib Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

release
A boolean value which controls whether the current image is released from the ImageX object.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToHdib Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : ToHdib Method

Gets a handle to an DIB (Device Independent Bitmap).

[Visual Basic]
Public Function ToHdib( _
   ByVal release As Boolean _
) As IntPtr
[C#]
public IntPtr ToHdib(
   bool release
);
[C++]
public: IntPtr ToHdib(
   bool release
)
[C++/CLI]
public:
IntPtr ToHdib(
   bool release
)

Parameters

release
A boolean value which controls whether the current image is released from the ImageX object.

Return Type

An HDIB

Remarks

If the release parameter is true, then the ImageX object no longer has an underlying image. It will be an empty image. Otherwise, false should be set.

See Also

ImageX Class | ImageX Members


Undo Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Undo Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : Undo Method

Undoes the action of the previous image processing method if the UndoEnabled property was set true prior to performing this method.

[Visual Basic]
Public Sub Undo()
[C#]
public void Undo();
[C++]
public: void Undo();
[C++/CLI]
public:
void Undo();

Remarks

Undoes the action of the previous image processing method if the UndoEnabled property was set t true prior to performing the method.

See Also

ImageX Class | ImageX Members


VerticalResolution Method

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

VerticalResolution Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : VerticalResolution Method

Returns the vertical resolution of the ImageX image.

[Visual Basic]
Public Function VerticalResolution() As Single
[C#]
public float VerticalResolution();
[C++]
public: float VerticalResolution();
[C++/CLI]
public:
float VerticalResolution();

Remarks

Applies to TIFF, PCX and BMP image only.

See Also

ImageX Class | ImageX Members


ImageX Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageX Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageX Class

For a list of all members of this type, see ImageX members.

Public Properties

Public Property AutoInvalidate | Gets and sets if the ImageXView object repaints whenever a change is made to the ImageX object.
Public Property CalTags | Get and sets the String pair Modca/Cals Tags Cal Tags can only be obtainds from Modca/Cals images open by Load methods Presently, there is no way to edit Cal tags without loading and saving the image.
Public Property ImageXData | Gets the ImageXData of the ImageX object.
Public Property IptcDataSet | Gets or sets the iptc data set.
Public Property JpegCommentCount | After opening a JPEG file, this property gets the number of JPEG App markers comments discovered.
Public Property LoadOptions | Gets the additional load options from this ImageX object.
Public Property Page | Gets and sets the page to be viewed or processed.
Public Property PageCount | Gets the number of pages in the image beginning at 1.
Public Property Palette | Gets or sets the color palette used for this ImageX object.
Public Property Resolution | Gets the resolution of the ImageX image.
Public Property Tags | Gets and sets the tag collection associated with this ImageX image.
Public Property UndoEnabled | Gets and sets the ability to perform the Undo method.

See Also

ImageX Class | PegasusImaging.WinForms.ImagXpress9 Namespace


AutoInvalidate Property

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AutoInvalidate Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : AutoInvalidate Property

Gets and sets if the ImageXView object repaints whenever a change is made to the ImageX object.

[Visual Basic]
Public Property AutoInvalidate As Boolean
[C#]
public bool AutoInvalidate {get; set;}
[C++]
public: __property bool get_AutoInvalidate();
public: __property void set_AutoInvalidate(
   bool value
);
[C++/CLI]
public:
property bool AutoInvalidate {
   bool get();
   void set (bool value);
}

See Also

ImageX Class | ImageX Members


CalTags Property

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CalTags Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : CalTags Property

Get and sets the String pair Modca/Cals Tags Cal Tags can only be obtainds from Modca/Cals images open by Load methods Presently, there is no way to edit Cal tags without loading and saving the image.

[Visual Basic]
Public Property CalTags As ImageCalsCollection
[C#]
public ImageCalsCollection CalTags {get; set;}
[C++]
public: __property ImageCalsCollection* get_CalTags();
public: __property void set_CalTags(
   ImageCalsCollection* value
);
[C++/CLI]
public:
property ImageCalsCollection^ CalTags {
   ImageCalsCollection^ get();
   void set (ImageCalsCollection^ value);
}

Return Type

The Cals tags.

See Also

ImageX Class | ImageX Members


ImageXData Property

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXData Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : ImageXData Property (ImageX)

Gets the ImageXData of the ImageX object.

[Visual Basic]
Public ReadOnly Property ImageXData As ImageXData
[C#]
public ImageXData ImageXData {get;}
[C++]
public: __property ImageXData* get_ImageXData();
[C++/CLI]
public:
property ImageXData^ ImageXData {
   ImageXData^ get();
}

Remarks

Note: Available in all editions.

See Also

ImageX Class | ImageX Members


IptcDataSet Property

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

IptcDataSet Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : IptcDataSet Property

Gets or sets the iptc data set.

[Visual Basic]
Public Property IptcDataSet As ImageXIptcCollection
[C#]
public ImageXIptcCollection IptcDataSet {get; set;}
[C++]
public: __property ImageXIptcCollection* get_IptcDataSet();
public: __property void set_IptcDataSet(
   ImageXIptcCollection* value
);
[C++/CLI]
public:
property ImageXIptcCollection^ IptcDataSet {
   ImageXIptcCollection^ get();
   void set (ImageXIptcCollection^ value);
}

Return Type

The iptc data set.

See Also

ImageX Class | ImageX Members


JpegCommentCount Property

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

JpegCommentCount Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : JpegCommentCount Property

After opening a JPEG file, this property gets the number of JPEG App markers comments discovered.

[Visual Basic]
Public ReadOnly Property JpegCommentCount As Integer
[C#]
public int JpegCommentCount {get;}
[C++]
public: __property int get_JpegCommentCount();
[C++/CLI]
public:
property int JpegCommentCount {
   int get();
}

Return Type

The JPEG comment count.

See Also

ImageX Class | ImageX Members


LoadOptions Property

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptions Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : LoadOptions Property (ImageX)

Gets the additional load options from this ImageX object.

[Visual Basic]
Public ReadOnly Property LoadOptions As LoadOptions
[C#]
public LoadOptions LoadOptions {get;}
[C++]
public: __property LoadOptions* get_LoadOptions();
[C++/CLI]
public:
property LoadOptions^ LoadOptions {
   LoadOptions^ get();
}

Remarks

Note: Available in all editions.

See Also

ImageX Class | ImageX Members


Page Property

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Page Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : Page Property

Gets and sets the page to be viewed or processed.

[Visual Basic]
Public Property Page As Integer
[C#]
public int Page {get; set;}
[C++]
public: __property int get_Page();
public: __property void set_Page(
   int value
);
[C++/CLI]
public:
property int Page {
   int get();
   void set (int value);
}

Remarks

This property is supported in multi-page file formats including: TIFF, ICO, MODCA, DCX and PDF.

Note: Available in Document or Photo editions.

See Also

ImageX Class | ImageX Members


PageCount Property

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PageCount Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : PageCount Property

Gets the number of pages in the image beginning at 1.

[Visual Basic]
Public ReadOnly Property PageCount As Integer
[C#]
public int PageCount {get;}
[C++]
public: __property int get_PageCount();
[C++/CLI]
public:
property int PageCount {
   int get();
}

Remarks

The default value is -1.

Note: The number of pages cannot be determined when an image is loaded using the FromStream method. This property becomes invalid in this case.

Note: Available in all editions.

See Also

ImageX Class | ImageX Members


Palette Property

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Palette Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : Palette Property

Gets or sets the color palette used for this ImageX object.

[Visual Basic]
Public Property Palette As ColorPalette
[C#]
public ColorPalette Palette {get; set;}
[C++]
public: __property ColorPalette* get_Palette();
public: __property void set_Palette(
   ColorPalette* value
);
[C++/CLI]
public:
property ColorPalette^ Palette {
   ColorPalette^ get();
   void set (ColorPalette^ value);
}

Remarks

If the ImageX does not have a palette then an empty palette is returned.

The Palette property returns and sets a palette in one operation. Like the System.Drawing.Bitmap class, the Palette can not be modified on the fly.

Example

For instance, the following code does not change the first entry in ImageX's palette to Red.

The following code is the correct way to modify the first entry to Red.

[C#]

imageX.Palette.Entries[0] = System.Drawing.Color.Red;

[C#]

System.Drawing.Imaging.ColorPalette palette;
palette = imageX.Palette;
if ( palette.Entries.Length &gt; 0 )
{
   palette.Entries[0] = System.Drawing.Color.Red;
   imageX.Palette = palette;
}

See Also

ImageX Class | ImageX Members


Resolution Property

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Resolution Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : Resolution Property (ImageX)

Gets the resolution of the ImageX image.

[Visual Basic]
Public ReadOnly Property Resolution As Resolution
[C#]
public Resolution Resolution {get;}
[C++]
public: __property Resolution* get_Resolution();
[C++/CLI]
public:
property Resolution^ Resolution {
   Resolution^ get();
}

Remarks

Note: Available in all editions.

See Also

ImageX Class | ImageX Members


Tags Property

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Tags Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : Tags Property

Gets and sets the tag collection associated with this ImageX image.

[Visual Basic]
Public Property Tags As ImageXTagCollection
[C#]
public ImageXTagCollection Tags {get; set;}
[C++]
public: __property ImageXTagCollection* get_Tags();
public: __property void set_Tags(
   ImageXTagCollection* value
);
[C++/CLI]
public:
property ImageXTagCollection^ Tags {
   ImageXTagCollection^ get();
   void set (ImageXTagCollection^ value);
}

See Also

ImageX Class | ImageX Members


UndoEnabled Property

ImageX Class | ImageX Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

UndoEnabled Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageX Class : UndoEnabled Property

Gets and sets the ability to perform the Undo method.

[Visual Basic]
Public Property UndoEnabled As Boolean
[C#]
public bool UndoEnabled {get; set;}
[C++]
public: __property bool get_UndoEnabled();
public: __property void set_UndoEnabled(
   bool value
);
[C++/CLI]
public:
property bool UndoEnabled {
   bool get();
   void set (bool value);
}

Remarks

This property control the ability to perform the Undo method. The Undo method undoes the results of an image processing method.

True — When an image processing method is invoked, the current undo image is deleted and replaced by the current image. The current image is replaced by the image resulting from the image processing method.

False — When an image processing method is invoked, the current image is deleted and replaced by the image resulting from the image processing method.

Note: Available in Standard, Document and Photo editions.

See Also

ImageX Class | ImageX Members


ImageXData Class

ImageXData Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXData Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXData Class (PegasusImaging.WinForms.ImagXpress9)

Implements image information pertaining to the current image.

For a list of all members of this type, see ImageXData members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.ImageXData

Syntax

[Visual Basic]
Public Class ImageXData
   Implements IDisposable
[C#]
public class ImageXData : IDisposable
[C++]
public __gc class ImageXData : public IDisposable
[C++/CLI]
public ref class ImageXData : public IDisposable

See Also

ImageXData Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXData Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXData Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXData Class (PegasusImaging.WinForms.ImagXpress9)

ImageXData overview

Public Constructors

Public Constructor ImageXData Constructor Overloaded. Initializes a new instance of the ImageXData class.

Public Properties

Public Property BitsPerPixel | Gets the number of bits per pixel.
Public Property ColorSpace | Gets the color space of the current image.
Public Property Compression | Gets the compression employed on the current image.
Public Property Format | Gets the file format of the current image.
Public Property Height | Gets the height value of the current image.
Public Property Progressive | Gets an indicator which determines if the current image is a progressive scan image.
Public Property Resolution | Gets the resolution for the current image.
Public Property Size | Gets the size of the current image.
Public Property Stride | Gets the number of bytes needed to advance from the beginning of one row in an image to the beginning of the next row.
Public Property Width | Gets the width value of the current image.

Public Methods

Public Method Dispose | Releases all resources used by this ImageXData object.
Public Method Layer | Returns information for a specific layer.
Public Method Layout | Returns CAD Layout information.
Public Method QueryCadFormat | Returns general information on number of cad layouts, layers, version and filetype.

See Also

ImageXData Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXData Constructor

ImageXData Class | ImageXData Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXData Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXData Class : ImageXData Constructor (ImageXData)

Initializes a new instance of the ImageXData class.

Overload List

Initializes a new instance of the ImageXData class.

[Visual Basic] Public Sub New()

[C#] public ImageXData();

[C++] public ImageXData();

[C++/CLI] public ImageXData();

Initializes a new instance of the ImageXData object passing in an image ID and image pointer.

[Visual Basic] Public Sub New(Integer,IntPtr)

[C#] public ImageXData(int,IntPtr);

[C++] public ImageXData(int,IntPtr);

[C++/CLI] public ImageXData(int,IntPtr);

See Also

ImageXData Class | ImageXData Members


ImageXData Constructor()

ImageXData Class | ImageXData Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXData Constructor()

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXData Class > ImageXData Constructor : ImageXData Constructor()

Initializes a new instance of the ImageXData class.

[Visual Basic]
Public Function New()
[C#]
public ImageXData();
[C++]
public: ImageXData();
[C++/CLI]
public:
ImageXData();

See Also

ImageXData Class | ImageXData Members | Overload List


ImageXData Constructor(Int32,IntPtr)

ImageXData Class | ImageXData Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imageId
An integer value which represents a unique identifier of the current image.
imagePointer
An integer pointer which represents a location in memory corresponding to the current image.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXData Constructor(Int32,IntPtr)

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXData Class > ImageXData Constructor : ImageXData Constructor(Int32,IntPtr)

Initializes a new instance of the ImageXData object passing in an image ID and image pointer.

[Visual Basic]
Public Function New( _
   ByVal imageId As Integer, _
   ByVal imagePointer As IntPtr _
)
[C#]
public ImageXData(
   int imageId,
   IntPtr imagePointer
);
[C++]
public: ImageXData(
   int imageId,
   IntPtr imagePointer
)
[C++/CLI]
public:
ImageXData(
   int imageId,
   IntPtr imagePointer
)

Parameters

imageId
An integer value which represents a unique identifier of the current image.
imagePointer
An integer pointer which represents a location in memory corresponding to the current image.

See Also

ImageXData Class | ImageXData Members | Overload List


Dispose Method

ImageXData Class | ImageXData Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXData Class : Dispose Method (ImageXData)

Releases all resources used by this ImageXData object.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

See Also

ImageXData Class | ImageXData Members


Layer Method

ImageXData Class | ImageXData Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

LayerIndex
An integer which represents the index of the layer.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Layer Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXData Class : Layer Method

Returns information for a specific layer.

[Visual Basic]
Public Function Layer( _
   ByVal LayerIndex As Integer _
) As CadLayer
[C#]
public CadLayer Layer(
   int LayerIndex
);
[C++]
public: CadLayer* Layer(
   int LayerIndex
)
[C++/CLI]
public:
CadLayer^ Layer(
   int LayerIndex
)

Parameters

LayerIndex
An integer which represents the index of the layer.

Return Type

A CadLayer object.

Remarks

Any layer can be loaded into the LoadOptionsCad class and all changes to all layers applied will take affect.

See Also

ImageXData Class | ImageXData Members


Layout Method

ImageXData Class | ImageXData Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

LayoutIndex
Index of the layout.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Layout Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXData Class : Layout Method

Returns CAD Layout information.

[Visual Basic]
Public Function Layout( _
   ByVal LayoutIndex As Integer _
) As CadLayout
[C#]
public CadLayout Layout(
   int LayoutIndex
);
[C++]
public: CadLayout* Layout(
   int LayoutIndex
)
[C++/CLI]
public:
CadLayout^ Layout(
   int LayoutIndex
)

Parameters

LayoutIndex
Index of the layout.

Return Type

A CadLayout object.

Remarks

Note: QueryCadFormat must be called before this method.

See Also

ImageXData Class | ImageXData Members


QueryCadFormat Method

ImageXData Class | ImageXData Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

cadFileType
The CadFileType which represents the type of CAD file.
cadVersion
The CadVersion.
layerCount
An integer value which represents the layer count.
layoutCount
An integer value which represents the layout count.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

QueryCadFormat Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXData Class : QueryCadFormat Method

Returns general information on number of cad layouts, layers, version and filetype.

[Visual Basic]
Public Sub QueryCadFormat( _
   ByRef cadFileType As CadFileType, _
   ByRef cadVersion As CadVersion, _
   ByRef layerCount As Integer, _
   ByRef layoutCount As Integer _
)
[C#]
public void QueryCadFormat(
   out CadFileType cadFileType,
   out CadVersion cadVersion,
   out int layerCount,
   out int layoutCount
);
[C++]
public: void QueryCadFormat(
   [PARAMFLAG::Out] CadFileType cadFileType,
   [PARAMFLAG::Out] CadVersion cadVersion,
   [PARAMFLAG::Out] int layerCount,
   [PARAMFLAG::Out] int layoutCount
)
[C++/CLI]
public:
void QueryCadFormat(
   [Out] CadFileType cadFileType,
   [Out] CadVersion cadVersion,
   [Out] int layerCount,
   [Out] int layoutCount
)

Parameters

cadFileType
The CadFileType which represents the type of CAD file.
cadVersion
The CadVersion.
layerCount
An integer value which represents the layer count.
layoutCount
An integer value which represents the layout count.

Remarks

This object must have been returned from QueryFile, QueryFromStream or QueryBuffer and the format PegasusImaging.WinForms.ImagXpress9.ImageXFormat.Cad.

See Also

ImageXData Class | ImageXData Members


ImageXData Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXData Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXData Class (PegasusImaging.WinForms.ImagXpress9)

For a list of all members of this type, see ImageXData members.

Public Properties

Public Property BitsPerPixel | Gets the number of bits per pixel.
Public Property ColorSpace | Gets the color space of the current image.
Public Property Compression | Gets the compression employed on the current image.
Public Property Format | Gets the file format of the current image.
Public Property Height | Gets the height value of the current image.
Public Property Progressive | Gets an indicator which determines if the current image is a progressive scan image.
Public Property Resolution | Gets the resolution for the current image.
Public Property Size | Gets the size of the current image.
Public Property Stride | Gets the number of bytes needed to advance from the beginning of one row in an image to the beginning of the next row.
Public Property Width | Gets the width value of the current image.

See Also

ImageXData Class | PegasusImaging.WinForms.ImagXpress9 Namespace


BitsPerPixel Property

ImageXData Class | ImageXData Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

BitsPerPixel Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXData Class : BitsPerPixel Property (ImageXData)

Gets the number of bits per pixel.

[Visual Basic]
Public ReadOnly Property BitsPerPixel As Integer
[C#]
public int BitsPerPixel {get;}
[C++]
public: __property int get_BitsPerPixel();
[C++/CLI]
public:
property int BitsPerPixel {
   int get();
}

Return Type

An integer value which represents the number of bits per pixel.

See Also

ImageXData Class | ImageXData Members


ColorSpace Property

ImageXData Class | ImageXData Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ColorSpace Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXData Class : ColorSpace Property (ImageXData)

Gets the color space of the current image.

[Visual Basic]
Public ReadOnly Property ColorSpace As ColorSpace
[C#]
public ColorSpace ColorSpace {get;}
[C++]
public: __property ColorSpace get_ColorSpace();
[C++/CLI]
public:
property ColorSpace ColorSpace {
   ColorSpace get();
}

Return Type

The ColorSpace enumeration value set.

Remarks

Note: Available in all editions.

See Also

ImageXData Class | ImageXData Members


Compression Property

ImageXData Class | ImageXData Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Compression Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXData Class : Compression Property (ImageXData)

Gets the compression employed on the current image.

[Visual Basic]
Public ReadOnly Property Compression As Compression
[C#]
public Compression Compression {get;}
[C++]
public: __property Compression get_Compression();
[C++/CLI]
public:
property Compression Compression {
   Compression get();
}

Return Type

The Compression enumeration value set.

Remarks

Note: Available in Document and Photo editions.

See Also

ImageXData Class | ImageXData Members


Format Property

ImageXData Class | ImageXData Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Format Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXData Class : Format Property (ImageXData)

Gets the file format of the current image.

[Visual Basic]
Public ReadOnly Property Format As ImageXFormat
[C#]
public ImageXFormat Format {get;}
[C++]
public: __property ImageXFormat get_Format();
[C++/CLI]
public:
property ImageXFormat Format {
   ImageXFormat get();
}

Return Type

The ImageXFormat enumeration value set.

Remarks

Note: Available in all editions.

See Also

ImageXData Class | ImageXData Members


Height Property

ImageXData Class | ImageXData Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Height Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXData Class : Height Property (ImageXData)

Gets the height value of the current image.

[Visual Basic]
Public ReadOnly Property Height As Integer
[C#]
public int Height {get;}
[C++]
public: __property int get_Height();
[C++/CLI]
public:
property int Height {
   int get();
}

Return Type

An integer value which represents the height.

Remarks

Note: Available in all editions.

See Also

ImageXData Class | ImageXData Members


Progressive Property

ImageXData Class | ImageXData Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Progressive Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXData Class : Progressive Property (ImageXData)

Gets an indicator which determines if the current image is a progressive scan image.

[Visual Basic]
Public ReadOnly Property Progressive As Boolean
[C#]
public bool Progressive {get;}
[C++]
public: __property bool get_Progressive();
[C++/CLI]
public:
property bool Progressive {
   bool get();
}

Return Type

A boolean value which is true if the current image is progressive. Otherwise, false is returned.

See Also

ImageXData Class | ImageXData Members


Resolution Property

ImageXData Class | ImageXData Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Resolution Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXData Class : Resolution Property (ImageXData)

Gets the resolution for the current image.

[Visual Basic]
Public ReadOnly Property Resolution As Resolution
[C#]
public Resolution Resolution {get;}
[C++]
public: __property Resolution* get_Resolution();
[C++/CLI]
public:
property Resolution^ Resolution {
   Resolution^ get();
}

Return Type

The Resolution value set for the current image.

See Also

ImageXData Class | ImageXData Members


Size Property

ImageXData Class | ImageXData Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Size Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXData Class : Size Property

Gets the size of the current image.

[Visual Basic]
Public ReadOnly Property Size As Integer
[C#]
public int Size {get;}
[C++]
public: __property int get_Size();
[C++/CLI]
public:
property int Size {
   int get();
}

Return Type

An integer value which represents the size of the current image.

Remarks

Note: Available in all editions.

See Also

ImageXData Class | ImageXData Members


Stride Property

ImageXData Class | ImageXData Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Stride Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXData Class : Stride Property (ImageXData)

Gets the number of bytes needed to advance from the beginning of one row in an image to the beginning of the next row.

[Visual Basic]
Public ReadOnly Property Stride As Integer
[C#]
public int Stride {get;}
[C++]
public: __property int get_Stride();
[C++/CLI]
public:
property int Stride {
   int get();
}

Return Type

An integer value which represents the number of bytes needed to advance.

Remarks

When a (GDI) Graphical Display Interface allocates a memory buffer for bitmaps, it may pad each row of pixels with extra bytes, in order to align them on some boundary. The width of the image, in bytes, plus the width of the extra padding, is called the stride.

See Also

ImageXData Class | ImageXData Members


Width Property

ImageXData Class | ImageXData Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Width Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXData Class : Width Property (ImageXData)

Gets the width value of the current image.

[Visual Basic]
Public ReadOnly Property Width As Integer
[C#]
public int Width {get;}
[C++]
public: __property int get_Width();
[C++/CLI]
public:
property int Width {
   int get();
}

Return Type

An integer value which represents the width.

Remarks

Note: Available in all editions.

See Also

ImageXData Class | ImageXData Members


ImageXException Class

ImageXException Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXException Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXException Class

This class implements exceptions for the ImageX objects.

For a list of all members of this type, see ImageXException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.ImagXpress9.ImagXpressException
PegasusImaging.WinForms.ImagXpress9.ImageXException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class ImageXException
   Inherits ImagXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class ImageXException : ImagXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class ImageXException : public ImagXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class ImageXException sealed : public ImagXpressException, ISerializable, _Exception

See Also

ImageXException Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXException Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXException Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXException Class

ImageXException overview

Public Constructors

Public Constructor ImageXException Constructor Overloaded. The main constructor for the ImageXException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from ImagXpressException) | Gets the numerical equivalent for enumerated exception result.
Public Property Result (Inherited from ImagXpressException) | Gets the enumerated exception result that has occurred.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ImageXException Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXException Constructor

ImageXException Class | ImageXException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXException Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXException Class : ImageXException Constructor (ImageXException)

The main constructor for the ImageXException class.

Overload List

The main constructor for the ImageXException class.

[Visual Basic] Public Sub New()

[C#] public ImageXException();

[C++] public ImageXException();

[C++/CLI] public ImageXException();

Constructor which allows passing in a result for the ImageX exceptions.

[Visual Basic] Public Sub New(Result)

[C#] public ImageXException(Result);

[C++] public ImageXException(Result);

[C++/CLI] public ImageXException(Result);

Constructor which allows passing in a message for the ImageX exceptions.

[Visual Basic] Public Sub New(String)

[C#] public ImageXException(string);

[C++] public ImageXException(string*);

[C++/CLI] public ImageXException(String^);

Constructor which allows passing in a result and message for the ImageX exception.

[Visual Basic] Public Sub New(Result,String)

[C#] public ImageXException(Result,string);

[C++] public ImageXException(Result,string*);

[C++/CLI] public ImageXException(Result,String^);

Constructor which allows passing in a message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public ImageXException(string,Exception);

[C++] public ImageXException(string*,Exception*);

[C++/CLI] public ImageXException(String^,Exception^);

Constructor which allows passing in a result, message and inner exception.

[Visual Basic] Public Sub New(Result,String,Exception)

[C#] public ImageXException(Result,string,Exception);

[C++] public ImageXException(Result,string*,Exception*);

[C++/CLI] public ImageXException(Result,String^,Exception^);

See Also

ImageXException Class | ImageXException Members


ImageXException Constructor()

ImageXException Class | ImageXException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXException Constructor()

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXException Class > ImageXException Constructor : ImageXException Constructor()

The main constructor for the ImageXException class.

[Visual Basic]
Public Function New()
[C#]
public ImageXException();
[C++]
public: ImageXException();
[C++/CLI]
public:
ImageXException();

See Also

ImageXException Class | ImageXException Members | Overload List


ImageXException Constructor(Result)

ImageXException Class | ImageXException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

result
A Result enumeration value.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXException Constructor(Result)

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXException Class > ImageXException Constructor : ImageXException Constructor(Result)

Constructor which allows passing in a result for the ImageX exceptions.

[Visual Basic]
Public Function New( _
   ByVal result As Result _
)
[C#]
public ImageXException(
   Result result
);
[C++]
public: ImageXException(
   Result result
)
[C++/CLI]
public:
ImageXException(
   Result result
)

Parameters

result
A Result enumeration value.

See Also

ImageXException Class | ImageXException Members | Overload List


ImageXException Constructor(Result,String)

ImageXException Class | ImageXException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

result
A Result enumeration value.
message
A string value which represents the error message for the exception.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXException Constructor(Result,String)

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXException Class > ImageXException Constructor : ImageXException Constructor(Result,String)

Constructor which allows passing in a result and message for the ImageX exception.

[Visual Basic]
Public Function New( _
   ByVal result As Result, _
   ByVal message As String _
)
[C#]
public ImageXException(
   Result result,
   string message
);
[C++]
public: ImageXException(
   Result result,
   string* message
)
[C++/CLI]
public:
ImageXException(
   Result result,
   String^ message
)

Parameters

result
A Result enumeration value.
message
A string value which represents the error message for the exception.

See Also

ImageXException Class | ImageXException Members | Overload List


ImageXException Constructor(Result,String,Exception)

ImageXException Class | ImageXException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

result
A Result enumeration value.
message
A string value which represents the error message.
innerException
A Exception
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXException Constructor(Result,String,Exception)

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXException Class > ImageXException Constructor : ImageXException Constructor(Result,String,Exception)

Constructor which allows passing in a result, message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal result As Result, _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public ImageXException(
   Result result,
   string message,
   Exception innerException
);
[C++]
public: ImageXException(
   Result result,
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
ImageXException(
   Result result,
   String^ message,
   Exception^ innerException
)

Parameters

result
A Result enumeration value.
message
A string value which represents the error message.
innerException
A Exception

See Also

ImageXException Class | ImageXException Members | Overload List


ImageXException Constructor(String)

ImageXException Class | ImageXException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string value which represents the error message for the exception.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXException Constructor(String)

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXException Class > ImageXException Constructor : ImageXException Constructor(String)

Constructor which allows passing in a message for the ImageX exceptions.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public ImageXException(
   string message
);
[C++]
public: ImageXException(
   string* message
)
[C++/CLI]
public:
ImageXException(
   String^ message
)

Parameters

message
A string value which represents the error message for the exception.

See Also

ImageXException Class | ImageXException Members | Overload List


ImageXException Constructor(String,Exception)

ImageXException Class | ImageXException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string value which represents the error message.
innerException
A Exception.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXException Constructor(String,Exception)

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXException Class > ImageXException Constructor : ImageXException Constructor(String,Exception)

Constructor which allows passing in a message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public ImageXException(
   string message,
   Exception innerException
);
[C++]
public: ImageXException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
ImageXException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
A Exception.

See Also

ImageXException Class | ImageXException Members | Overload List


ImageXIptcCollection Class

ImageXIptcCollection Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXIptcCollection Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXIptcCollection Class

A collection for Iptc meta-data.

For a list of all members of this type, see ImageXIptcCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<ImageXIptcData>
PegasusImaging.WinForms.ImagXpress9.ImageXIptcCollection

Syntax

[Visual Basic]
<SerializableAttribute()>
Public Class ImageXIptcCollection
   Inherits Collection(Of ImageXIptcData)
   Implements IList<ImageXIptcData>, ICollection<ImageXIptcData>, IEnumerable<ImageXIptcData>, IEnumerable, IList, ICollection
[C#]
[SerializableAttribute()]
public class ImageXIptcCollection : Collection<ImageXIptcData>, IList<ImageXIptcData>, ICollection<ImageXIptcData>, IEnumerable<ImageXIptcData>, IEnumerable, IList, ICollection
[C++]
[SerializableAttribute()]
public __gc class ImageXIptcCollection : public Collection<ImageXIptcData>, IList<ImageXIptcData>, ICollection<ImageXIptcData>, IEnumerable<ImageXIptcData>, IEnumerable, IList, ICollection
[C++/CLI]
[SerializableAttribute()]
public ref class ImageXIptcCollection : public Collection<ImageXIptcData>, IList<ImageXIptcData>, ICollection<ImageXIptcData>, IEnumerable<ImageXIptcData>, IEnumerable, IList, ICollection

See Also

ImageXIptcCollection Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXIptcCollection Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXIptcCollection Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXIptcCollection Class

ImageXIptcCollection overview

Public Constructors

Public Constructor ImageXIptcCollection Constructor Overloaded. Initializes a new instance of the ImageXIptcCollection class.

Public Properties

Public Property Count (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Property Item (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)

Public Methods

Public Method Add (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method Clear (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method Contains (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method CopyTo (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method GetEnumerator (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method IndexOf (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method Insert (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method Remove (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method RemoveAt (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)

See Also

ImageXIptcCollection Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXIptcCollection Constructor

ImageXIptcCollection Class | ImageXIptcCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXIptcCollection Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXIptcCollection Class : ImageXIptcCollection Constructor (ImageXIptcCollection)

Initializes a new instance of the ImageXIptcCollection class.

Overload List

Initializes a new instance of the ImageXIptcCollection class.

[Visual Basic] Public Sub New()

[C#] public ImageXIptcCollection();

[C++] public ImageXIptcCollection();

[C++/CLI] public ImageXIptcCollection();

Initializes a new instance of the ImageXIptcCollection class.

[Visual Basic] Public Sub New(ImageXIptcCollection)

[C#] public ImageXIptcCollection(ImageXIptcCollection);

[C++] public ImageXIptcCollection(ImageXIptcCollection*);

[C++/CLI] public ImageXIptcCollection(ImageXIptcCollection^);

See Also

ImageXIptcCollection Class | ImageXIptcCollection Members


ImageXIptcCollection Constructor()

ImageXIptcCollection Class | ImageXIptcCollection Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXIptcCollection Constructor()

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXIptcCollection Class > ImageXIptcCollection Constructor : ImageXIptcCollection Constructor()

Initializes a new instance of the ImageXIptcCollection class.

[Visual Basic]
Public Function New()
[C#]
public ImageXIptcCollection();
[C++]
public: ImageXIptcCollection();
[C++/CLI]
public:
ImageXIptcCollection();

See Also

ImageXIptcCollection Class | ImageXIptcCollection Members | Overload List


ImageXIptcCollection Constructor(ImageXIptcCollection)

ImageXIptcCollection Class | ImageXIptcCollection Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

copytag
The copytag.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXIptcCollection Constructor(ImageXIptcCollection)

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXIptcCollection Class > ImageXIptcCollection Constructor : ImageXIptcCollection Constructor(ImageXIptcCollection)

Initializes a new instance of the ImageXIptcCollection class.

[Visual Basic]
Public Function New( _
   ByVal copytag As ImageXIptcCollection _
)
[C#]
public ImageXIptcCollection(
   ImageXIptcCollection copytag
);
[C++]
public: ImageXIptcCollection(
   ImageXIptcCollection* copytag
)
[C++/CLI]
public:
ImageXIptcCollection(
   ImageXIptcCollection^ copytag
)

Parameters

copytag
The copytag.

See Also

ImageXIptcCollection Class | ImageXIptcCollection Members | Overload List


ImageXIptcData Class

ImageXIptcData Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXIptcData Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXIptcData Class

A class for IPTC meta-data information.

For a list of all members of this type, see ImageXIptcData members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.ImageXIptcData

Syntax

[Visual Basic]
Public Class ImageXIptcData
   Implements IComparable
[C#]
public class ImageXIptcData : IComparable
[C++]
public __gc class ImageXIptcData : public IComparable
[C++/CLI]
public ref class ImageXIptcData : public IComparable

See Also

ImageXIptcData Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXIptcData Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXIptcData Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXIptcData Class

ImageXIptcData overview

Public Constructors

Public Constructor ImageXIptcData Constructor Initializes a new instance of the ImageXIptcData class.

Public Properties

Public Property DataField | Gets or sets the data field.
Public Property DataFieldString | Gets or sets the data field string.
Public Property DataSet | Gets or sets the data set.
Public Property DataSetLength | Gets the length of the data set.
Public Property DataSetType | Gets or sets the type of the data set.
Public Property Record | Gets or sets the record.

Public Methods

Public Method CompareTo Compares the current instance with another object of the same type.

See Also

ImageXIptcData Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXIptcData Constructor

ImageXIptcData Class | ImageXIptcData Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

record
A byte value which represents the record.
dataSet
A byte value which represents the data set.
dataSetType
An integer which represents the type of data set.
dataSetLength
An integer value which represents the length of the data set.
data
An object which contains the data.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXIptcData Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXIptcData Class : ImageXIptcData Constructor (ImageXIptcData)

Initializes a new instance of the ImageXIptcData class.

[Visual Basic]
Public Function New( _
   ByVal record As Byte, _
   ByVal dataSet As Byte, _
   ByVal dataSetType As Long, _
   ByVal dataSetLength As Long, _
   ByVal data As Object _
)
[C#]
public ImageXIptcData(
   byte record,
   byte dataSet,
   long dataSetType,
   long dataSetLength,
   object data
);
[C++]
public: ImageXIptcData(
   byte record,
   byte dataSet,
   long dataSetType,
   long dataSetLength,
   Object* data
)
[C++/CLI]
public:
ImageXIptcData(
   byte record,
   byte dataSet,
   long long dataSetType,
   long long dataSetLength,
   Object^ data
)

Parameters

record
A byte value which represents the record.
dataSet
A byte value which represents the data set.
dataSetType
An integer which represents the type of data set.
dataSetLength
An integer value which represents the length of the data set.
data
An object which contains the data.

See Also

ImageXIptcData Class | ImageXIptcData Members


CompareTo Method

ImageXIptcData Class | ImageXIptcData Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

obj
An object to compare with this instance.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CompareTo Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXIptcData Class : CompareTo Method (ImageXIptcData)

Compares the current instance with another object of the same type.

[Visual Basic]
Public Function CompareTo( _
   ByVal obj As Object _
) As Integer
[C#]
public int CompareTo(
   object obj
);
[C++]
public: int CompareTo(
   Object* obj
)
[C++/CLI]
public:
int CompareTo(
   Object^ obj
)

Parameters

obj
An object to compare with this instance.

Return Type

A 32-bit signed integer that indicates the relative order of the objects being compared. The return value has these meanings: Value Meaning Less than zero This instance is less than obj. Zero This instance is equal to obj. Greater than zero: This instance is greater than obj.

Exceptions

Exception | Description
ArgumentException | obj is not the same type as this instance.

See Also

ImageXIptcData Class | ImageXIptcData Members


ImageXIptcData Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXIptcData Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXIptcData Class

For a list of all members of this type, see ImageXIptcData members.

Public Properties

Public Property DataField | Gets or sets the data field.
Public Property DataFieldString | Gets or sets the data field string.
Public Property DataSet | Gets or sets the data set.
Public Property DataSetLength | Gets the length of the data set.
Public Property DataSetType | Gets or sets the type of the data set.
Public Property Record | Gets or sets the record.

See Also

ImageXIptcData Class | PegasusImaging.WinForms.ImagXpress9 Namespace


DataField Property

ImageXIptcData Class | ImageXIptcData Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DataField Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXIptcData Class : DataField Property

Gets or sets the data field.

[Visual Basic]
Public Property DataField As Byte()
[C#]
public byte[] DataField {get; set;}
[C++]
public: __property byte[]* get_DataField();
public: __property void set_DataField(
   byte[]* value
);
[C++/CLI]
public:
property array<byte>^ DataField {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Type

A byte value which represents the data field.

See Also

ImageXIptcData Class | ImageXIptcData Members


DataFieldString Property

ImageXIptcData Class | ImageXIptcData Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DataFieldString Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXIptcData Class : DataFieldString Property

Gets or sets the data field string.

[Visual Basic]
Public Property DataFieldString As String
[C#]
public string DataFieldString {get; set;}
[C++]
public: __property string* get_DataFieldString();
public: __property void set_DataFieldString(
   string* value
);
[C++/CLI]
public:
property String^ DataFieldString {
   String^ get();
   void set (String^ value);
}

Return Type

A string value which represents the data field string.

See Also

ImageXIptcData Class | ImageXIptcData Members


DataSet Property

ImageXIptcData Class | ImageXIptcData Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DataSet Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXIptcData Class : DataSet Property

Gets or sets the data set.

[Visual Basic]
Public Property DataSet As Byte
[C#]
public byte DataSet {get; set;}
[C++]
public: __property byte get_DataSet();
public: __property void set_DataSet(
   byte value
);
[C++/CLI]
public:
property byte DataSet {
   byte get();
   void set (byte value);
}

Return Type

A byte value which represents the data set.

See Also

ImageXIptcData Class | ImageXIptcData Members


DataSetLength Property

ImageXIptcData Class | ImageXIptcData Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DataSetLength Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXIptcData Class : DataSetLength Property

Gets the length of the data set.

[Visual Basic]
Public ReadOnly Property DataSetLength As Long
[C#]
public long DataSetLength {get;}
[C++]
public: __property long get_DataSetLength();
[C++/CLI]
public:
property long long DataSetLength {
   long long get();
}

Return Type

An integer value which represents the length of the data set.

See Also

ImageXIptcData Class | ImageXIptcData Members


DataSetType Property

ImageXIptcData Class | ImageXIptcData Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DataSetType Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXIptcData Class : DataSetType Property

Gets or sets the type of the data set.

[Visual Basic]
Public Property DataSetType As Long
[C#]
public long DataSetType {get; set;}
[C++]
public: __property long get_DataSetType();
public: __property void set_DataSetType(
   long value
);
[C++/CLI]
public:
property long long DataSetType {
   long long get();
   void set (long long value);
}

Return Type

An integer value which represents the type of the data set.

See Also

ImageXIptcData Class | ImageXIptcData Members


Record Property

ImageXIptcData Class | ImageXIptcData Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Record Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXIptcData Class : Record Property

Gets or sets the record.

[Visual Basic]
Public Property Record As Byte
[C#]
public byte Record {get; set;}
[C++]
public: __property byte get_Record();
public: __property void set_Record(
   byte value
);
[C++/CLI]
public:
property byte Record {
   byte get();
   void set (byte value);
}

Return Type

A byte value which represents the record.

See Also

ImageXIptcData Class | ImageXIptcData Members


ImageXTag Class

ImageXTag Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXTag Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXTag Class

This class holds TIFF and EXIF tags.

For a list of all members of this type, see ImageXTag members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.ImageXTag

Syntax

[Visual Basic]
Public Class ImageXTag
[C#]
public class ImageXTag
[C++]
public __gc class ImageXTag
[C++/CLI]
public ref class ImageXTag

Remarks

This class can be used to extract information contained within a specific tag entity as well as edit tage entity values. While tags can be bytes, short, long, rational, floats and doubles, they can also be signed or unsigned which is a problem with CLS compliance. Data is passed as CLS compliant data, but the TagType property indicates intent. That is, there are types indicating that the data should be considered signed or unsigned.

Note: The public "get" and "set" methods of the ImageXTag class obtain tags only of the appropriate types.

See Also

ImageXTag Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXTag Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXTag Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXTag Class

ImageXTag overview

Public Constructors

Public Constructor ImageXTag Constructor Overloaded. Initializes a new instance of the ImageXTag class.

Public Properties

Public Property TagElementsCount | Gets and sets the number of data items in the tag.
Public Property TagLevel | Gets and sets the nesting level at which the tag resides. Tag Level can be 0 - 4.
Public Property TagNumber | Gets and sets the Tag ID Number.
Public Property TagType | Gets and sets the type of data within the tag.

Public Methods

Public Method GetTagBytes | Gets tag data that are of the type Bytes.
Public Method GetTagDouble | Gets tag data of type Double.
Public Method GetTagFloat | Retrieves a float array of values contained within the ImageXTag.
Public Method GetTagInt16 | Retrieves a short array of values contained within ImageXTag.
Public Method GetTagInt32 | Gets tag data of type long or int32.
Public Method GetTagRational | Gets Tag Rational data.
Public Method GetTagSBytes | Retrieves signed short array of values contained within the ImageXTag.
Public Method GetTagSRational | Gets tag SRational data.
Public Method GetTagUInt16 | Retrieves a short array of values contained within the ImageXTag.
Public Method GetTagUInt32 | Gets tag data of type unsigned long or UInt32.
Public Method SetTagBytes | Sets Tag Data of based on byte array input.
Public Method SetTagDouble | Sets tag data of type Double.
Public Method SetTagFloat | Set Tag Data of type Float or Single.
Public Method SetTagInt16 | Sets the ImageXTag data based on the short array input.
Public Method SetTagInt32 | Overloaded. Sets Tag Data of type long or int32
Public Method SetTagRational | Sets Tag Rational Data.
Public Method SetTagSBytes | Sets Tag Data based on the byte array input.
Public Method SetTagSRational | Sets Tag Rational Data.
Public Method SetTagUInt16 | Sets tag data of type UInt16.
Public Method SetTagUInt32 | Sets tag data of type unsigned long or UInt32.

See Also

ImageXTag Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXTag Constructor

ImageXTag Class | ImageXTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXTag Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class : ImageXTag Constructor (ImageXTag)

Initializes a new instance of the ImageXTag class.

Overload List

Initializes a new instance of the ImageXTag class.

[Visual Basic] Public Sub New()

[C#] public ImageXTag();

[C++] public ImageXTag();

[C++/CLI] public ImageXTag();

Can construct a fully qualified Tag from the constructor.

[Visual Basic] Public Sub New(Integer,Byte,Object,TagTypes)

[C#] public ImageXTag(int,byte,object,TagTypes);

[C++] public ImageXTag(int,byte,Object*,TagTypes);

[C++/CLI] public ImageXTag(int,byte,Object^,TagTypes);

See Also

ImageXTag Class | ImageXTag Members


ImageXTag Constructor()

ImageXTag Class | ImageXTag Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXTag Constructor()

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class > ImageXTag Constructor : ImageXTag Constructor()

Initializes a new instance of the ImageXTag class.

[Visual Basic]
Public Function New()
[C#]
public ImageXTag();
[C++]
public: ImageXTag();
[C++/CLI]
public:
ImageXTag();

See Also

ImageXTag Class | ImageXTag Members | Overload List


ImageXTag Constructor(Int32,Byte,Object,TagTypes)

ImageXTag Class | ImageXTag Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

TagNumber
An integer which represents the tag number.
TagLevel
A byte which represents the tag level.
Data
A data object.
TagType
The TagTypes enumeration value set.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXTag Constructor(Int32,Byte,Object,TagTypes)

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class > ImageXTag Constructor : ImageXTag Constructor(Int32,Byte,Object,TagTypes)

Can construct a fully qualified Tag from the constructor.

[Visual Basic]
Public Function New( _
   ByVal TagNumber As Integer, _
   ByVal TagLevel As Byte, _
   ByVal Data As Object, _
   ByVal TagType As TagTypes _
)
[C#]
public ImageXTag(
   int TagNumber,
   byte TagLevel,
   object Data,
   TagTypes TagType
);
[C++]
public: ImageXTag(
   int TagNumber,
   byte TagLevel,
   Object* Data,
   TagTypes TagType
)
[C++/CLI]
public:
ImageXTag(
   int TagNumber,
   byte TagLevel,
   Object^ Data,
   TagTypes TagType
)

Parameters

TagNumber
An integer which represents the tag number.
TagLevel
A byte which represents the tag level.
Data
A data object.
TagType
The TagTypes enumeration value set.

See Also

ImageXTag Class | ImageXTag Members | Overload List


GetTagBytes Method

ImageXTag Class | ImageXTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GetTagBytes Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class : GetTagBytes Method

Gets tag data that are of the type Bytes.

[Visual Basic]
Public Function GetTagBytes() As Byte()
[C#]
public byte[] GetTagBytes();
[C++]
public: byte[]* GetTagBytes();
[C++/CLI]
public:
array<byte>^ GetTagBytes();

Return Type

A byte array which contains the tag data.

Remarks

Note: The public "get" and "set" methods of the ImageXTag class only get or obtain tags of the appropriate types.

Note: Available in View, Document and Photo editions.

See Also

ImageXTag Class | ImageXTag Members


GetTagDouble Method

ImageXTag Class | ImageXTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GetTagDouble Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class : GetTagDouble Method

Gets tag data of type Double.

[Visual Basic]
Public Function GetTagDouble() As Double()
[C#]
public double[] GetTagDouble();
[C++]
public: double[]* GetTagDouble();
[C++/CLI]
public:
array<double>^ GetTagDouble();

Return Type

A double-precision floating point value which represents the tag data.

See Also

ImageXTag Class | ImageXTag Members


GetTagFloat Method

ImageXTag Class | ImageXTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GetTagFloat Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class : GetTagFloat Method

Retrieves a float array of values contained within the ImageXTag.

[Visual Basic]
Public Function GetTagFloat() As Single()
[C#]
public float[] GetTagFloat();
[C++]
public: float[]* GetTagFloat();
[C++/CLI]
public:
array<float>^ GetTagFloat();

Return Type

A signed float array of values contained within the ImageXTag.

Remarks

Get tag data of type float or single.

Note: The public "get" and "set" methods of the ImageXTag class only get or obtain tags of the appropriate types.

Note: Available in View, Document and Photo editions.

See Also

ImageXTag Class | ImageXTag Members


GetTagInt16 Method

ImageXTag Class | ImageXTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GetTagInt16 Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class : GetTagInt16 Method

Retrieves a short array of values contained within ImageXTag.

[Visual Basic]
Public Function GetTagInt16() As Short()
[C#]
public short[] GetTagInt16();
[C++]
public: short[]* GetTagInt16();
[C++/CLI]
public:
array<short>^ GetTagInt16();

Return Type

Note: A short array of signed values contained within the ImageXTag.

Remarks

Get tag data of type short or int16 SByte data is returned as int16 as well because SByte is not CLS compliant.

Note: The public "get" and "set" methods of the ImageXTag class only get or obtain tags of the appropriate types.

Tag data of type short or int16. SByte data is returned as int16 as well because SByte is not CLS compliant.

Note: Available in View, Document and Photo editions.

See Also

ImageXTag Class | ImageXTag Members


GetTagInt32 Method

ImageXTag Class | ImageXTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GetTagInt32 Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class : GetTagInt32 Method

Gets tag data of type long or int32.

[Visual Basic]
Public Function GetTagInt32() As Integer()
[C#]
public int[] GetTagInt32();
[C++]
public: int[]* GetTagInt32();
[C++/CLI]
public:
array<int>^ GetTagInt32();

Return Type

An integer 32 which represents the tag data converted from UInt16.

Remarks

Note: Tag type UInt16 (Tag_Short) is returned at Int32[] because UInt16 is not CLS complaint.

See Also

ImageXTag Class | ImageXTag Members


GetTagRational Method

ImageXTag Class | ImageXTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GetTagRational Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class : GetTagRational Method

Gets Tag Rational data.

[Visual Basic]
Public Function GetTagRational() As Long()
[C#]
public long[] GetTagRational();
[C++]
public: long[]* GetTagRational();
[C++/CLI]
public:
array<long long>^ GetTagRational();

Remarks

Rational is unsigned int32 but that is not CLS compliant. So, data is returned in the next highest compliant size to keep is positve and effectively unsigned. So data is returned long-long or Int64.

See Also

ImageXTag Class | ImageXTag Members


GetTagSBytes Method

ImageXTag Class | ImageXTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GetTagSBytes Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class : GetTagSBytes Method

Retrieves signed short array of values contained within the ImageXTag.

[Visual Basic]
Public Function GetTagSBytes() As Short()
[C#]
public short[] GetTagSBytes();
[C++]
public: short[]* GetTagSBytes();
[C++/CLI]
public:
array<short>^ GetTagSBytes();

Return Type

A signed short array which contains values within the ImageXTag.

Remarks

Note: The public "get" and "set" methods of the ImageXTag class only get or obtain tags of the apropriate types.

Note: Available in View, Document and Phoo editions.

See Also

ImageXTag Class | ImageXTag Members


GetTagSRational Method

ImageXTag Class | ImageXTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GetTagSRational Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class : GetTagSRational Method

Gets tag SRational data.

[Visual Basic]
Public Function GetTagSRational() As Integer()
[C#]
public int[] GetTagSRational();
[C++]
public: int[]* GetTagSRational();
[C++/CLI]
public:
array<int>^ GetTagSRational();

Return Type

An integer value which represents tag SRational data.

Remarks

SRational data are pairs of long or int32.

See Also

ImageXTag Class | ImageXTag Members


GetTagUInt16 Method

ImageXTag Class | ImageXTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GetTagUInt16 Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class : GetTagUInt16 Method

Retrieves a short array of values contained within the ImageXTag.

[Visual Basic]
Public Function GetTagUInt16() As Integer()
[C#]
public int[] GetTagUInt16();
[C++]
public: int[]* GetTagUInt16();
[C++/CLI]
public:
array<int>^ GetTagUInt16();

Return Type

A signed short array of values contained within the ImageXTag.

Remarks

Gets tag data of type short or int16 sbyte data is returned as int16 as well because sbyte is not CLS compliant.

Note: The public "get" and "set" methods of the ImageXTag class only get or obtain tags of the appropriate types.

Note: UInt16 is not CLS Compliant so it must be returned as Int32 data. The data is moved from UInt16 to Int32 internally so it remains positive and hence unsigned.

Note: Available in View, Document and Photo editions.

See Also

ImageXTag Class | ImageXTag Members


GetTagUInt32 Method

ImageXTag Class | ImageXTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GetTagUInt32 Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class : GetTagUInt32 Method

Gets tag data of type unsigned long or UInt32.

[Visual Basic]
Public Function GetTagUInt32() As Long()
[C#]
public long[] GetTagUInt32();
[C++]
public: long[]* GetTagUInt32();
[C++/CLI]
public:
array<long long>^ GetTagUInt32();

Return Type

An integer 64 which represents the tag data.

Remarks

Note: Because UInt32 is not CLS compliant, it must be passed in the next largest type which is In64. It will be moved from UInt32 to Int64 internally.

See Also

ImageXTag Class | ImageXTag Members


SetTagBytes Method

ImageXTag Class | ImageXTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

TagData
An unsigned byte array which represents the tag data.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetTagBytes Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class : SetTagBytes Method

Sets Tag Data of based on byte array input.

[Visual Basic]
Public Sub SetTagBytes( _
   ByVal TagData() As Byte _
)
[C#]
public void SetTagBytes(
   byte[] TagData
);
[C++]
public: void SetTagBytes(
   byte[]* TagData
)
[C++/CLI]
public:
void SetTagBytes(
   bytearray<TagData>^ TagData
)

Parameters

TagData
An unsigned byte array which represents the tag data.

Remarks

Note: The public "get" and "set" methods of the ImageXTag class only get or obtain tags of the appropriate types.

Note: Available in Document and Photo editions.

See Also

ImageXTag Class | ImageXTag Members


SetTagDouble Method

ImageXTag Class | ImageXTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

TagData
A double-precision floating point value which represents the tag data.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetTagDouble Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class : SetTagDouble Method

Sets tag data of type Double.

[Visual Basic]
Public Sub SetTagDouble( _
   ByVal TagData() As Double _
)
[C#]
public void SetTagDouble(
   double[] TagData
);
[C++]
public: void SetTagDouble(
   double[]* TagData
)
[C++/CLI]
public:
void SetTagDouble(
   doublearray<TagData>^ TagData
)

Parameters

TagData
A double-precision floating point value which represents the tag data.

See Also

ImageXTag Class | ImageXTag Members


SetTagFloat Method

ImageXTag Class | ImageXTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

TagData
A single-precision floating point value which represents tag data.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetTagFloat Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class : SetTagFloat Method

Set Tag Data of type Float or Single.

[Visual Basic]
Public Sub SetTagFloat( _
   ByVal TagData() As Single _
)
[C#]
public void SetTagFloat(
   float[] TagData
);
[C++]
public: void SetTagFloat(
   float[]* TagData
)
[C++/CLI]
public:
void SetTagFloat(
   floatarray<TagData>^ TagData
)

Parameters

TagData
A single-precision floating point value which represents tag data.

See Also

ImageXTag Class | ImageXTag Members


SetTagInt16 Method

ImageXTag Class | ImageXTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

TagData
A signed short array consisting of values that the ImageXTag is to contain.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetTagInt16 Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class : SetTagInt16 Method

Sets the ImageXTag data based on the short array input.

[Visual Basic]
Public Sub SetTagInt16( _
   ByVal TagData() As Short _
)
[C#]
public void SetTagInt16(
   short[] TagData
);
[C++]
public: void SetTagInt16(
   short[]* TagData
)
[C++/CLI]
public:
void SetTagInt16(
   shortarray<TagData>^ TagData
)

Parameters

TagData
A signed short array consisting of values that the ImageXTag is to contain.

Remarks

The sbyte data is contained in the int16 arrays because it is not CLS compliant. If the tag type is sbyte, the int16 array is converted down to an sbyte array.

Note: The public "get" and "set" methods of the ImageXTag class only get or obtain tags of the appropriate types.

Note: Available in Document and Photo editions.

See Also

ImageXTag Class | ImageXTag Members


SetTagInt32 Method

ImageXTag Class | ImageXTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetTagInt32 Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class : SetTagInt32 Method

Sets Tag Data of type long or int32

Overload List

Sets Tag Data of type long or int32

[Visual Basic] Overloads Public Sub SetTagInt32(Integer())

[C#] public void SetTagInt32(int[]);

[C++] public void SetTagInt32(int[]*);

[C++/CLI] public void SetTagInt32(intarray<TagData>^);

Sets tag data of type Float or Single.

[Visual Basic] Overloads Public Sub SetTagInt32(Single())

[C#] public void SetTagInt32(float[]);

[C++] public void SetTagInt32(float[]*);

[C++/CLI] public void SetTagInt32(floatarray<TagData>^);

Sets tag data of type Double.

[Visual Basic] Overloads Public Sub SetTagInt32(Double())

[C#] public void SetTagInt32(double[]);

[C++] public void SetTagInt32(double[]*);

[C++/CLI] public void SetTagInt32(doublearray<TagData>^);

See Also

ImageXTag Class | ImageXTag Members


SetTagInt32(Int32[]) Method

ImageXTag Class | ImageXTag Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

TagData
An integer 32 which represents the tag data.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetTagInt32(Int32[]) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class > SetTagInt32 Method : SetTagInt32(Int32[]) Method

Sets Tag Data of type long or int32

[Visual Basic]
Overloads Public Sub SetTagInt32( _
   ByVal TagData() As Integer _
)
[C#]
public void SetTagInt32(
   int[] TagData
);
[C++]
public: void SetTagInt32(
   int[]* TagData
)
[C++/CLI]
public:
void SetTagInt32(
   intarray<TagData>^ TagData
)

Parameters

TagData
An integer 32 which represents the tag data.

Remarks

Note: Tag type UInt16 (Tag_Short) is returned at Int32[] because UInt16 is not CLS complaint.

See Also

ImageXTag Class | ImageXTag Members | Overload List


SetTagInt32(Single[]) Method

ImageXTag Class | ImageXTag Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

TagData
A single-precision floating point value which represents tag data.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetTagInt32(Single[]) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class > SetTagInt32 Method : SetTagInt32(Single[]) Method

Sets tag data of type Float or Single.

[Visual Basic]
Overloads Public Sub SetTagInt32( _
   ByVal TagData() As Single _
)
[C#]
public void SetTagInt32(
   float[] TagData
);
[C++]
public: void SetTagInt32(
   float[]* TagData
)
[C++/CLI]
public:
void SetTagInt32(
   floatarray<TagData>^ TagData
)

Parameters

TagData
A single-precision floating point value which represents tag data.

See Also

ImageXTag Class | ImageXTag Members | Overload List


SetTagInt32(Double[]) Method

ImageXTag Class | ImageXTag Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

TagData
A double-precision floating point value which represents the tag data.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetTagInt32(Double[]) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class > SetTagInt32 Method : SetTagInt32(Double[]) Method

Sets tag data of type Double.

[Visual Basic]
Overloads Public Sub SetTagInt32( _
   ByVal TagData() As Double _
)
[C#]
public void SetTagInt32(
   double[] TagData
);
[C++]
public: void SetTagInt32(
   double[]* TagData
)
[C++/CLI]
public:
void SetTagInt32(
   doublearray<TagData>^ TagData
)

Parameters

TagData
A double-precision floating point value which represents the tag data.

See Also

ImageXTag Class | ImageXTag Members | Overload List


SetTagRational Method

ImageXTag Class | ImageXTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

TagData
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetTagRational Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class : SetTagRational Method

Sets Tag Rational Data.

[Visual Basic]
Public Sub SetTagRational( _
   ByVal TagData() As Long _
)
[C#]
public void SetTagRational(
   long[] TagData
);
[C++]
public: void SetTagRational(
   long[]* TagData
)
[C++/CLI]
public:
void SetTagRational(
   long longarray<TagData>^ TagData
)

Parameters

TagData

Remarks

Data must be in pairs of long-long or int64. Because UInt32 is not CLS compliant and Rational is really unsigned, the data is returned in the next largest compliant form to remain positive and effectively unsigned.

See Also

ImageXTag Class | ImageXTag Members


SetTagSBytes Method

ImageXTag Class | ImageXTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

TagData
An unsigned byte array consisting of values ImageXTag contains.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetTagSBytes Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class : SetTagSBytes Method

Sets Tag Data based on the byte array input.

[Visual Basic]
Public Sub SetTagSBytes( _
   ByVal TagData() As Short _
)
[C#]
public void SetTagSBytes(
   short[] TagData
);
[C++]
public: void SetTagSBytes(
   short[]* TagData
)
[C++/CLI]
public:
void SetTagSBytes(
   shortarray<TagData>^ TagData
)

Parameters

TagData
An unsigned byte array consisting of values ImageXTag contains.

Remarks

Note: The public "get" and "set" methods of the ImageXTag class only get or obtain tags of the appropriate types.

Note: Available in Document and Photo editions.

See Also

ImageXTag Class | ImageXTag Members


SetTagSRational Method

ImageXTag Class | ImageXTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

TagData
An integer value which represents tag SRational data.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetTagSRational Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class : SetTagSRational Method

Sets Tag Rational Data.

[Visual Basic]
Public Sub SetTagSRational( _
   ByVal TagData() As Integer _
)
[C#]
public void SetTagSRational(
   int[] TagData
);
[C++]
public: void SetTagSRational(
   int[]* TagData
)
[C++/CLI]
public:
void SetTagSRational(
   intarray<TagData>^ TagData
)

Parameters

TagData
An integer value which represents tag SRational data.

Remarks

SRational data are pairs of long or int32.

See Also

ImageXTag Class | ImageXTag Members


SetTagUInt16 Method

ImageXTag Class | ImageXTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

TagData
An int32 which represents the tag data.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetTagUInt16 Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class : SetTagUInt16 Method

Sets tag data of type UInt16.

[Visual Basic]
Public Sub SetTagUInt16( _
   ByVal TagData() As Integer _
)
[C#]
public void SetTagUInt16(
   int[] TagData
);
[C++]
public: void SetTagUInt16(
   int[]* TagData
)
[C++/CLI]
public:
void SetTagUInt16(
   intarray<TagData>^ TagData
)

Parameters

TagData
An int32 which represents the tag data.

Remarks

Note: UInt16 is not CLS Compliant so it must be passed in Int32 and internally converted to UInt16.

See Also

ImageXTag Class | ImageXTag Members


SetTagUInt32 Method

ImageXTag Class | ImageXTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

TagData
An integer 64 which represents tag data.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetTagUInt32 Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class : SetTagUInt32 Method

Sets tag data of type unsigned long or UInt32.

[Visual Basic]
Public Sub SetTagUInt32( _
   ByVal TagData() As Long _
)
[C#]
public void SetTagUInt32(
   long[] TagData
);
[C++]
public: void SetTagUInt32(
   long[]* TagData
)
[C++/CLI]
public:
void SetTagUInt32(
   long longarray<TagData>^ TagData
)

Parameters

TagData
An integer 64 which represents tag data.

Remarks

Because UInt32 is not CLS compliant, it must be passed in the next largest type which is In64. It will be moved to UInt32 internally.

See Also

ImageXTag Class | ImageXTag Members


ImageXTag Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXTag Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXTag Class

For a list of all members of this type, see ImageXTag members.

Public Properties

Public Property TagElementsCount | Gets and sets the number of data items in the tag.
Public Property TagLevel | Gets and sets the nesting level at which the tag resides. Tag Level can be 0 - 4.
Public Property TagNumber | Gets and sets the Tag ID Number.
Public Property TagType | Gets and sets the type of data within the tag.

See Also

ImageXTag Class | PegasusImaging.WinForms.ImagXpress9 Namespace


TagElementsCount Property

ImageXTag Class | ImageXTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

TagElementsCount Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class : TagElementsCount Property

Gets and sets the number of data items in the tag.

[Visual Basic]
Public Property TagElementsCount As Integer
[C#]
public int TagElementsCount {get; set;}
[C++]
public: __property int get_TagElementsCount();
public: __property void set_TagElementsCount(
   int value
);
[C++/CLI]
public:
property int TagElementsCount {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the number of data items in the tag.

Remarks

For more information on querying and modifying tags, see the Modify Tags topic.

See Also

ImageXTag Class | ImageXTag Members


TagLevel Property

ImageXTag Class | ImageXTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

TagLevel Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class : TagLevel Property

Gets and sets the nesting level at which the tag resides. Tag Level can be 0 - 4.

[Visual Basic]
Public Property TagLevel As Byte
[C#]
public byte TagLevel {get; set;}
[C++]
public: __property byte get_TagLevel();
public: __property void set_TagLevel(
   byte value
);
[C++/CLI]
public:
property byte TagLevel {
   byte get();
   void set (byte value);
}

Return Type

A byte value which represents the level.

Remarks

Valid values are 0 - 4.

For TIFF tags, the tag level should be = 0.

Some file formats have the ability to store metadata that includes sub-levels. For these file formats, the tag level provides access to these multiple levels.

Note: Available in View, Document and Photo editions.

See Also

ImageXTag Class | ImageXTag Members


TagNumber Property

ImageXTag Class | ImageXTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

TagNumber Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class : TagNumber Property

Gets and sets the Tag ID Number.

[Visual Basic]
Public Property TagNumber As Integer
[C#]
public int TagNumber {get; set;}
[C++]
public: __property int get_TagNumber();
public: __property void set_TagNumber(
   int value
);
[C++/CLI]
public:
property int TagNumber {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the tag ID number.

Remarks

Each tag in a TIFF or EXIF file has a corresponding number which identifies the information stored there. This property is a unique identifier of the tag within the tag collection.

See Also

ImageXTag Class | ImageXTag Members


TagType Property

ImageXTag Class | ImageXTag Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

TagType Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTag Class : TagType Property

Gets and sets the type of data within the tag.

[Visual Basic]
Public Property TagType As TagTypes
[C#]
public TagTypes TagType {get; set;}
[C++]
public: __property TagTypes get_TagType();
public: __property void set_TagType(
   TagTypes value
);
[C++/CLI]
public:
property TagTypes TagType {
   TagTypes get();
   void set (TagTypes value);
}

Return Type

The TagTypes enumeration value set.

Remarks

The Tag Type can be byte, short, long, rational and signed or unsigned.

See Also

ImageXTag Class | ImageXTag Members


ImageXTagCollection Class

ImageXTagCollection Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXTagCollection Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXTagCollection Class

A collection of ImageXTag objects.

For a list of all members of this type, see ImageXTagCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PegasusImaging.WinForms.ImagXpress9.ImageXTagCollection

Syntax

[Visual Basic]
<DefaultMemberAttribute("Item")>
Public Class ImageXTagCollection
   Inherits CollectionBase
   Implements IList, ICollection, IEnumerable, IDisposable
[C#]
[DefaultMemberAttribute("Item")]
public class ImageXTagCollection : CollectionBase, IList, ICollection, IEnumerable, IDisposable
[C++]
[DefaultMemberAttribute("Item")]
public __gc class ImageXTagCollection : public CollectionBase, IList, ICollection, IEnumerable, IDisposable
[C++/CLI]
[DefaultMemberAttribute("Item")]
public ref class ImageXTagCollection : public CollectionBase, IList, ICollection, IEnumerable, IDisposable

Remarks

This collection is designed for use with the TIFF and EXIF file formats. This collection class can be used to add, copy, remove and insert tag entities into a loaded image.

See Also

ImageXTagCollection Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXTagCollection Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXTagCollection Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXTagCollection Class

ImageXTagCollection overview

Public Constructors

Public Constructor ImageXTagCollection Constructor Overloaded. The base constructor for the ImageXTagCollection class.

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property Item | Gets and sets the index values within the collection.

Public Methods

Public Method Add | Adds an ImageXTag to the ImageXTagCollection.
Public Method Clear | Clears the entire collection as well as calls the Clear function of the base class.
Public Method Contains | Determines if the collection contains the specified ImageXTag.
Public Method CopyTo | Copies the entire collection to an array, starting at index of the target array.
Public Method Dispose | Releases all resources used by this PegasusImaging.WinForms.ImagXpress9.ImageXTagCollection object.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method GetTag | Retrieves the ImageXTag object from the ImageXTagCollection.
Public Method IndexOf | Searches for the specified ImageXTag and returns the zero-based index of the first occurrence within the entire collection.
Public Method Insert | Inserts an ImageXTag at the specified index.
Public Method Remove | Removes the ImageXTag from the collection.
Public Method RemoveAt | Removes the specified ImageXTag from the collection.
Public Method RemoveTag | Removes an ImageXTag from the ImageXTagCollection.

See Also

ImageXTagCollection Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXTagCollection Constructor

ImageXTagCollection Class | ImageXTagCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXTagCollection Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTagCollection Class : ImageXTagCollection Constructor (ImageXTagCollection)

The base constructor for the ImageXTagCollection class.

Overload List

The base constructor for the ImageXTagCollection class.

[Visual Basic] Public Sub New()

[C#] public ImageXTagCollection();

[C++] public ImageXTagCollection();

[C++/CLI] public ImageXTagCollection();

Initializes a new instance of the ImageXTagCollection class.

[Visual Basic] Public Sub New(ImageXTagCollection)

[C#] public ImageXTagCollection(ImageXTagCollection);

[C++] public ImageXTagCollection(ImageXTagCollection*);

[C++/CLI] public ImageXTagCollection(ImageXTagCollection^);

See Also

ImageXTagCollection Class | ImageXTagCollection Members


ImageXTagCollection Constructor()

ImageXTagCollection Class | ImageXTagCollection Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXTagCollection Constructor()

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTagCollection Class > ImageXTagCollection Constructor : ImageXTagCollection Constructor()

The base constructor for the ImageXTagCollection class.

[Visual Basic]
Public Function New()
[C#]
public ImageXTagCollection();
[C++]
public: ImageXTagCollection();
[C++/CLI]
public:
ImageXTagCollection();

See Also

ImageXTagCollection Class | ImageXTagCollection Members | Overload List


ImageXTagCollection Constructor(ImageXTagCollection)

ImageXTagCollection Class | ImageXTagCollection Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

copytag
The ImageXTagCollection from which to create a copy.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXTagCollection Constructor(ImageXTagCollection)

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTagCollection Class > ImageXTagCollection Constructor : ImageXTagCollection Constructor(ImageXTagCollection)

Initializes a new instance of the ImageXTagCollection class.

[Visual Basic]
Public Function New( _
   ByVal copytag As ImageXTagCollection _
)
[C#]
public ImageXTagCollection(
   ImageXTagCollection copytag
);
[C++]
public: ImageXTagCollection(
   ImageXTagCollection* copytag
)
[C++/CLI]
public:
ImageXTagCollection(
   ImageXTagCollection^ copytag
)

Parameters

copytag
The ImageXTagCollection from which to create a copy.

See Also

ImageXTagCollection Class | ImageXTagCollection Members | Overload List


Add Method

ImageXTagCollection Class | ImageXTagCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tag
An ImageXTag object.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Add Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTagCollection Class : Add Method (ImageXTagCollection)

Adds an ImageXTag to the ImageXTagCollection.

[Visual Basic]
Public Function Add( _
   ByVal tag As ImageXTag _
) As Integer
[C#]
public int Add(
   ImageXTag tag
);
[C++]
public: int Add(
   ImageXTag* tag
)
[C++/CLI]
public:
int Add(
   ImageXTag^ tag
)

Parameters

tag
An ImageXTag object.

Return Type

An integer value which represents the index value within the list of the newly added ImageXTag.

Remarks

Note: Available in View, Document and Photo editions.

See Also

ImageXTagCollection Class | ImageXTagCollection Members


Clear Method

ImageXTagCollection Class | ImageXTagCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Clear Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTagCollection Class : Clear Method (ImageXTagCollection)

Clears the entire collection as well as calls the Clear function of the base class.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[C++/CLI]
public:
void Clear();

See Also

ImageXTagCollection Class | ImageXTagCollection Members


Contains Method

ImageXTagCollection Class | ImageXTagCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tag
The ImageXTag to locate.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Contains Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTagCollection Class : Contains Method (ImageXTagCollection)

Determines if the collection contains the specified ImageXTag.

[Visual Basic]
Public Function Contains( _
   ByVal tag As ImageXTag _
) As Boolean
[C#]
public bool Contains(
   ImageXTag tag
);
[C++]
public: bool Contains(
   ImageXTag* tag
)
[C++/CLI]
public:
bool Contains(
   ImageXTag^ tag
)

Parameters

tag
The ImageXTag to locate.

Return Type

A boolean value which is true if the collection contains the specified ImageXTag. Otherwise, false is returned.

See Also

ImageXTagCollection Class | ImageXTagCollection Members


CopyTo Method

ImageXTagCollection Class | ImageXTagCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

array
The one-dimensional Array that is the destination of the elements copied from ImageXTagCollection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CopyTo Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTagCollection Class : CopyTo Method (ImageXTagCollection)

Copies the entire collection to an array, starting at index of the target array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As ImageXTag, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   ImageXTag[] array,
   int index
);
[C++]
public: void CopyTo(
   ImageXTag*[]* array,
   int index
)
[C++/CLI]
public:
void CopyTo(
   ImageXTag^array<array>^ array,
   int index
)

Parameters

array
The one-dimensional Array that is the destination of the elements copied from ImageXTagCollection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

ImageXTagCollection Class | ImageXTagCollection Members


Dispose Method

ImageXTagCollection Class | ImageXTagCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTagCollection Class : Dispose Method (ImageXTagCollection)

Releases all resources used by this PegasusImaging.WinForms.ImagXpress9.ImageXTagCollection object.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

See Also

ImageXTagCollection Class | ImageXTagCollection Members


GetTag Method

ImageXTagCollection Class | ImageXTagCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

TagNumber
An integer value which represents the tag number to receive.
level
A byte which represents the tag level at which the requested tag resides.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GetTag Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTagCollection Class : GetTag Method

Retrieves the ImageXTag object from the ImageXTagCollection.

[Visual Basic]
Public Function GetTag( _
   ByVal TagNumber As Integer, _
   ByVal level As Byte _
) As ImageXTag
[C#]
public ImageXTag GetTag(
   int TagNumber,
   byte level
);
[C++]
public: ImageXTag* GetTag(
   int TagNumber,
   byte level
)
[C++/CLI]
public:
ImageXTag^ GetTag(
   int TagNumber,
   byte level
)

Parameters

TagNumber
An integer value which represents the tag number to receive.
level
A byte which represents the tag level at which the requested tag resides.

Return Type

An ImageXTag object.

Remarks

This method is for multipage document formats such as TIFF and EXIF.

Note: Available in View, Document and Photo editions.

See Also

ImageXTagCollection Class | ImageXTagCollection Members


IndexOf Method

ImageXTagCollection Class | ImageXTagCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The ImageXTag to locate in the collection.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

IndexOf Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTagCollection Class : IndexOf Method (ImageXTagCollection)

Searches for the specified ImageXTag and returns the zero-based index of the first occurrence within the entire collection.

[Visual Basic]
Public Function IndexOf( _
   ByVal value As ImageXTag _
) As Integer
[C#]
public int IndexOf(
   ImageXTag value
);
[C++]
public: int IndexOf(
   ImageXTag* value
)
[C++/CLI]
public:
int IndexOf(
   ImageXTag^ value
)

Parameters

value
The ImageXTag to locate in the collection.

Return Type

An integer value which represents the index of the first matching ImageXTag that was found.

See Also

ImageXTagCollection Class | ImageXTagCollection Members


Insert Method

ImageXTagCollection Class | ImageXTagCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
The zero-based index at which the ImageXTag should be inserted.
tag
The ImageXTag to be inserted.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Insert Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTagCollection Class : Insert Method (ImageXTagCollection)

Inserts an ImageXTag at the specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal tag As ImageXTag _
)
[C#]
public void Insert(
   int index,
   ImageXTag tag
);
[C++]
public: void Insert(
   int index,
   ImageXTag* tag
)
[C++/CLI]
public:
void Insert(
   int index,
   ImageXTag^ tag
)

Parameters

index
The zero-based index at which the ImageXTag should be inserted.
tag
The ImageXTag to be inserted.

See Also

ImageXTagCollection Class | ImageXTagCollection Members


Remove Method

ImageXTagCollection Class | ImageXTagCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tag
The ImageXTag to be removed.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Remove Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTagCollection Class : Remove Method (ImageXTagCollection)

Removes the ImageXTag from the collection.

[Visual Basic]
Public Sub Remove( _
   ByVal tag As ImageXTag _
)
[C#]
public void Remove(
   ImageXTag tag
);
[C++]
public: void Remove(
   ImageXTag* tag
)
[C++/CLI]
public:
void Remove(
   ImageXTag^ tag
)

Parameters

tag
The ImageXTag to be removed.

See Also

ImageXTagCollection Class | ImageXTagCollection Members


RemoveAt Method

ImageXTagCollection Class | ImageXTagCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
An integer value which represents the index which matches the ImageXTag object to remove from the collection.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RemoveAt Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTagCollection Class : RemoveAt Method (ImageXTagCollection)

Removes the specified ImageXTag from the collection.

[Visual Basic]
Public Sub RemoveAt( _
   ByVal index As Integer _
)
[C#]
public void RemoveAt(
   int index
);
[C++]
public: void RemoveAt(
   int index
)
[C++/CLI]
public:
void RemoveAt(
   int index
)

Parameters

index
An integer value which represents the index which matches the ImageXTag object to remove from the collection.

Remarks

Call the ImageXTag destructor to free the ImageXTag then remove the ImageXTag from the collection.

See Also

ImageXTagCollection Class | ImageXTagCollection Members


RemoveTag Method

ImageXTagCollection Class | ImageXTagCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

TagNumber
An integer value which represents the number of the tag.
level
A byte value which represents the tag level at which the requested tag resides.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RemoveTag Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTagCollection Class : RemoveTag Method

Removes an ImageXTag from the ImageXTagCollection.

[Visual Basic]
Public Sub RemoveTag( _
   ByVal TagNumber As Integer, _
   ByVal level As Byte _
)
[C#]
public void RemoveTag(
   int TagNumber,
   byte level
);
[C++]
public: void RemoveTag(
   int TagNumber,
   byte level
)
[C++/CLI]
public:
void RemoveTag(
   int TagNumber,
   byte level
)

Parameters

TagNumber
An integer value which represents the number of the tag.
level
A byte value which represents the tag level at which the requested tag resides.

Remarks

This method is for multipage document formats such as TIFF and EXIF.

Note: Available in View, Document and Photo edtiions.

See Also

ImageXTagCollection Class | ImageXTagCollection Members


ImageXTagCollection Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXTagCollection Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXTagCollection Class

For a list of all members of this type, see ImageXTagCollection members.

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property Item | Gets and sets the index values within the collection.

See Also

ImageXTagCollection Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Item Property

ImageXTagCollection Class | ImageXTagCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Item Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXTagCollection Class : Item Property (ImageXTagCollection)

Gets and sets the index values within the collection.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As ImageXTag
[C#]
public ImageXTag this[
   int index
]; {get; set;}
[C++]
public: __property ImageXTag* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   ImageXTag* value
);
[C++/CLI]
public:
 property ImageXTag^ default [int] {
   ImageXTag^ get(int index);
   void set (int index, ImageXTag^ value);
}

Parameters

index

Return Type

An ImageXTag object to index.

See Also

ImageXTagCollection Class | ImageXTagCollection Members


ImageXView Class

ImageXView Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXView Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXView Class

Implements the properties, methods and events for the viewer control.

For a list of all members of this type, see ImageXView members.

Object Model

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
PegasusImaging.WinForms.ImagXpress9.ImageXView

Syntax

[Visual Basic]
<DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="System.Windows.Forms.Design.ParentControlDesigner,System.Design")>
<ToolboxBitmapAttribute()>
Public Class ImageXView
   Inherits UserControl
   Implements IComponent, IDisposable, UnsafeNativeMethods.IOleControl, UnsafeNativeMethods.IOleObject, UnsafeNativeMethods.IOleInPlaceObject, UnsafeNativeMethods.IOleInPlaceActiveObject, UnsafeNativeMethods.IOleWindow, UnsafeNativeMethods.IViewObject, UnsafeNativeMethods.IViewObject2, UnsafeNativeMethods.IPersist, UnsafeNativeMethods.IPersistStreamInit, UnsafeNativeMethods.IPersistPropertyBag, UnsafeNativeMethods.IPersistStorage, UnsafeNativeMethods.IQuickActivate, ISupportOleDropSource, IDropTarget, ISynchronizeInvoke, IWin32Window, IArrangedElement, IBindableComponent, IContainerControl
[C#]
[DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="System.Windows.Forms.Design.ParentControlDesigner,System.Design")]
[ToolboxBitmapAttribute()]
public class ImageXView : UserControl, IComponent, IDisposable, UnsafeNativeMethods.IOleControl, UnsafeNativeMethods.IOleObject, UnsafeNativeMethods.IOleInPlaceObject, UnsafeNativeMethods.IOleInPlaceActiveObject, UnsafeNativeMethods.IOleWindow, UnsafeNativeMethods.IViewObject, UnsafeNativeMethods.IViewObject2, UnsafeNativeMethods.IPersist, UnsafeNativeMethods.IPersistStreamInit, UnsafeNativeMethods.IPersistPropertyBag, UnsafeNativeMethods.IPersistStorage, UnsafeNativeMethods.IQuickActivate, ISupportOleDropSource, IDropTarget, ISynchronizeInvoke, IWin32Window, IArrangedElement, IBindableComponent, IContainerControl
[C++]
[DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="System.Windows.Forms.Design.ParentControlDesigner,System.Design")]
[ToolboxBitmapAttribute()]
public __gc class ImageXView : public UserControl, IComponent, IDisposable, UnsafeNativeMethods.IOleControl, UnsafeNativeMethods.IOleObject, UnsafeNativeMethods.IOleInPlaceObject, UnsafeNativeMethods.IOleInPlaceActiveObject, UnsafeNativeMethods.IOleWindow, UnsafeNativeMethods.IViewObject, UnsafeNativeMethods.IViewObject2, UnsafeNativeMethods.IPersist, UnsafeNativeMethods.IPersistStreamInit, UnsafeNativeMethods.IPersistPropertyBag, UnsafeNativeMethods.IPersistStorage, UnsafeNativeMethods.IQuickActivate, ISupportOleDropSource, IDropTarget, ISynchronizeInvoke, IWin32Window, IArrangedElement, IBindableComponent, IContainerControl
[C++/CLI]
[DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="System.Windows.Forms.Design.ParentControlDesigner,System.Design")]
[ToolboxBitmapAttribute()]
public ref class ImageXView : public UserControl, IComponent, IDisposable, UnsafeNativeMethods.IOleControl, UnsafeNativeMethods.IOleObject, UnsafeNativeMethods.IOleInPlaceObject, UnsafeNativeMethods.IOleInPlaceActiveObject, UnsafeNativeMethods.IOleWindow, UnsafeNativeMethods.IViewObject, UnsafeNativeMethods.IViewObject2, UnsafeNativeMethods.IPersist, UnsafeNativeMethods.IPersistStreamInit, UnsafeNativeMethods.IPersistPropertyBag, UnsafeNativeMethods.IPersistStorage, UnsafeNativeMethods.IQuickActivate, ISupportOleDropSource, IDropTarget, ISynchronizeInvoke, IWin32Window, IArrangedElement, IBindableComponent, IContainerControl

Remarks

This class contains functionality for modifying an image's appearance as it is displayed in the viewer control.

See Also

ImageXView Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXView Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXView Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXView Class

ImageXView overview

Public Constructors

Public Constructor ImageXView Constructor Overloaded. Initializes a new instance of the ImageXView class.

Public Properties

Public Property AccessibilityObject (Inherited from System.Windows.Forms.Control) | Gets the AccessibleObject assigned to the control.
Public Property AccessibleDefaultActionDescription (Inherited from System.Windows.Forms.Control) | Gets or sets the default action description of the control for use by accessibility client applications.
Public Property AccessibleDescription (Inherited from System.Windows.Forms.Control) | Gets or sets the description of the control used by accessibility client applications.
Public Property AccessibleName (Inherited from System.Windows.Forms.Control) | Gets or sets the name of the control used by accessibility client applications.
Public Property AccessibleRole (Inherited from System.Windows.Forms.Control) | Gets or sets the accessible role of the control
Public Property ActiveControl (Inherited from System.Windows.Forms.ContainerControl) | Gets or sets the active control on the container control.
Public Property AlignHorizontal | Gets and sets the horizontal alignment of the image being viewed.
Public Property AlignVertical | Gets and sets the vertical alignment of the image being viewed.
Public Property AllowDrop (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Public Property AllowUpdate | Gets and sets an indicator which determines if updates allow the control to be repainted.
Public Property AlphaBlend | Gets and sets an indication of alpha blending an image to the background of the control when an alpha channel is present in the image.
Public Property Anchor (Inherited from System.Windows.Forms.Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Public Property Antialias | Gets and sets the anti-alias effect.
Public Property AspectX | Gets and sets the horizontal aspect ratio of the current image.
Public Property AspectY | Gets and sets the vertical aspect ratio of the current image.
Public Property AutoImageDispose | Gets and sets enabling the ImageXView's Dispose method to automatically call the ImageX's Dispose method.
Public Property AutoResize | Gets and sets how the image is sized and positioned for display when painted.
Public Property AutoScaleDimensions (Inherited from System.Windows.Forms.ContainerControl) | Gets or sets the dimensions that the control was designed to.
Public Property AutoScaleMode (Inherited from System.Windows.Forms.ContainerControl) | Gets or sets the automatic scaling mode of the control.
Public Property AutoScroll (Inherited from System.Windows.Forms.ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
Public Property AutoScrollMargin (Inherited from System.Windows.Forms.ScrollableControl) | Gets or sets the size of the auto-scroll margin.
Public Property AutoScrollMinSize (Inherited from System.Windows.Forms.ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
Public Property AutoScrollOffset (Inherited from System.Windows.Forms.Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
Public Property AutoScrollPosition (Inherited from System.Windows.Forms.ScrollableControl) | Gets or sets the location of the auto-scroll position.
Public Property AutoSize (Inherited from System.Windows.Forms.UserControl) |
Public Property AutoSizeMode (Inherited from System.Windows.Forms.UserControl) | Gets or sets how the control will resize itself.
Public Property AutoValidate (Inherited from System.Windows.Forms.UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
Public Property BackColor | Overridden. Sets the background color of the view window.
Public Property BackgroundImage (Inherited from System.Windows.Forms.Control) | Gets or sets the background image displayed in the control.
Public Property BackgroundImageLayout (Inherited from System.Windows.Forms.Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
Public Property BindingContext (Inherited from System.Windows.Forms.ContainerControl) |
Public Property BorderStyle | Gets and sets the border type of the ImageXView object.
Public Property BorderType | Gets and sets the border type of the ImageXView object.
Public Property Bottom (Inherited from System.Windows.Forms.Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Public Property Bounds (Inherited from System.Windows.Forms.Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
Public Property Brightness | Gets and sets the change of brightness of the current image.
Public Property CanFocus (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control can receive focus.
Public Property CanSelect (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control can be selected.
Public Property Capture (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether the control has captured the mouse.
Public Property CausesValidation (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
Public Property ClientRectangle (Inherited from System.Windows.Forms.Control) | Gets the rectangle that represents the client area of the control.
Public Property ClientSize (Inherited from System.Windows.Forms.Control) | Gets or sets the height and width of the client area of the control.
Public Property ClipRectangle | Gets and sets the rectangular portion of the image that is accessible to the viewer.
Public Property ColorRenderIntent | Gets and sets how the color profiles should be applied.
Public Property CompanyName (Inherited from System.Windows.Forms.Control) | Gets the name of the company or creator of the application containing the control.
Public Property Container (Inherited from System.ComponentModel.Component) | Gets the IContainer that contains the Component.
Public Property ContainsFocus (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
Public Property ContextMenu (Inherited from System.Windows.Forms.Control) | Gets or sets the shortcut menu associated with the control.
Public Property ContextMenuStrip (Inherited from System.Windows.Forms.Control) | Gets or sets the ContextMenuStrip associated with this control.
Public Property Contrast | Gets and sets the change of contrast level for the displayed image.
Public Property Controls (Inherited from System.Windows.Forms.Control) | Gets the collection of controls contained within the control.
Public Property Created (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control has been created.
Public Property CurrentAutoScaleDimensions (Inherited from System.Windows.Forms.ContainerControl) | Gets the current run-time dimensions of the screen.
Public Property Cursor (Inherited from System.Windows.Forms.Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Public Property CursorPosition | Gets the coordinates of the cursor position in the view window.
Public Property DataBindings (Inherited from System.Windows.Forms.Control) | Gets the data bindings for the control.
Public Property DisplayMode | Returns or sets a value indicating the maximum color depth used to render an image.
Public Property DisplayRectangle (Inherited from System.Windows.Forms.ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Public Property Disposing (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Public Property Dithered | Gets and sets a dithered indicator on the current image.
Public Property Dock (Inherited from System.Windows.Forms.Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
Public Property Enabled (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Public Property Focused (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control has input focus.
Public Property Font (Inherited from System.Windows.Forms.Control) | Gets or sets the font of the text displayed by the control.
Public Property ForeColor (Inherited from System.Windows.Forms.Control) | Gets or sets the foreground color of the control.
Public Property GrayMode | Gets and sets the mode of gray used to display a grayscale image.
Public Property Handle (Inherited from System.Windows.Forms.Control) | Gets the window handle that the control is bound to.
Public Property HasChildren (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control contains one or more child controls.
Public Property Height (Inherited from System.Windows.Forms.Control) | Gets or sets the height of the control.
Public Property HorizontalScroll (Inherited from System.Windows.Forms.ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Public Property IcmEnabled | Gets and sets an enabled indicator for the color management.
Public Property IcmProofingEnabled | Gets and sets an enabled indicator of the ICM target proofing.
Public Property Image | Gets and sets the current image view.
Public Property ImageCursorPosition | Gets the point at which the cursor is located within the image, in pixels.
Public Property ImeMode (Inherited from System.Windows.Forms.Control) | Gets or sets the Input Method Editor (IME) mode of the control.
Public Property InvokeRequired (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
Public Property IsAccessible (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
Public Property IsDisposed (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control has been disposed of.
Public Property IsHandleCreated (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control has a handle associated with it.
Public Property IsMirrored (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control is mirrored.
Public Property LayoutEngine (Inherited from System.Windows.Forms.Control) | Gets a cached instance of the control's layout engine.
Public Property Left (Inherited from System.Windows.Forms.Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Public Property Location (Inherited from System.Windows.Forms.Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Public Property Margin (Inherited from System.Windows.Forms.Control) | Gets or sets the space between controls.
Public Property Maximum | Gets and sets the maximum dimensions the viewer control can obtain.
Public Property MaximumSize (Inherited from System.Windows.Forms.Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
Public Property Medical | Gets and sets information required to display medical images.
Public Property Minimum | Gets and sets the minimum dimensions the viewer control can obtain.
Public Property MinimumSize (Inherited from System.Windows.Forms.Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Public Property MonitorProfileName | Gets and sets the monitor’s color management profile.
Public Property MouseWheelCapture | Gets and sets capturing the mousewheel even when the control does not have focus.
Public Property Name (Inherited from System.Windows.Forms.Control) | Gets or sets the name of the control.
Public Property Padding (Inherited from System.Windows.Forms.Control) | Gets or sets padding within the control.
Public Property PaletteFilename | Specifies the filename that contains the palette for the control.
Public Property PaletteType | Gets and sets the image display palette type.
Public Property Parent (Inherited from System.Windows.Forms.Control) | Gets or sets the parent container of the control.
Public Property ParentForm (Inherited from System.Windows.Forms.ContainerControl) | Gets the form that the container control is assigned to.
Public Property PixelColor | Gets the color of the pixel within the client area of the view control at which the cursor is currently positioned.
Public Property PreferredSize (Inherited from System.Windows.Forms.Control) | Gets the size of a rectangular area into which the control can fit.
Public Property PreserveBlack | Gets and sets an indicator if black should be preserved and applied when viewing the image.
Public Property PrinterProfileName | Gets and sets the printer’s profile filename.
Public Property ProductName (Inherited from System.Windows.Forms.Control) | Gets the product name of the assembly containing the control.
Public Property ProductVersion (Inherited from System.Windows.Forms.Control) | Gets the version of the assembly containing the control.
Public Property Progressive | Gets and sets an indication if images are displayed progressively.
Public Property RecreatingHandle (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control is currently re-creating its handle.
Public Property Region (Inherited from System.Windows.Forms.Control) | Gets or sets the window region associated with the control.
Public Property Right (Inherited from System.Windows.Forms.Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
Public Property RightToLeft (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Public Property Rubberband | Gets the current Rubberband object.
Public Property ScrollBars | Gets or sets the type of scroll bars to display in the ImagXView control.
Public Property ScrollPosition | Gets and sets the current scrolling position of the cursor on the scrollbar.
Public Property Site (Inherited from System.Windows.Forms.Control) | Gets or sets the site of the control.
Public Property Size (Inherited from System.Windows.Forms.Control) | Gets or sets the height and width of the control.
Public Property Smoothing | Gets and sets an indicator for the smoothing effect on the current image.
Public Property Sprite | Gets the Sprite object.
Public Property TabIndex (Inherited from System.Windows.Forms.Control) | Gets or sets the tab order of the control within its container.
Public Property TabStop (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Public Property Tag (Inherited from System.Windows.Forms.Control) | Gets or sets the object that contains data about the control.
Public Property TargetProfileName | Gets and sets the target profile’s filename.
Public Property ToolActive | Gets the currently active tool.
Public Property Toolbar | Gets the current Toolbar object.
Public Property Top (Inherited from System.Windows.Forms.Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
Public Property TopLevelControl (Inherited from System.Windows.Forms.Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Public Property UseWaitCursor (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Public Property VerticalScroll (Inherited from System.Windows.Forms.ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Public Property Visible (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether the control is displayed.
Public Property Width (Inherited from System.Windows.Forms.Control) | Gets or sets the width of the control.
Public Property ZoomFactor | Gets and sets the zoom factor display for the current image.

Public Methods

Public Method BeginInvoke (Inherited from System.Windows.Forms.Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
Public Method BringToFront (Inherited from System.Windows.Forms.Control) | Brings the control to the front of the z-order.
Public Method CaptureControl | Captures the screen area bounded by the control and saves it to the current image.
Public Method CaptureWindow | Overloaded. Captures the screen area within the specified Window and saves it to the current Image.
Public Method Contains (Inherited from System.Windows.Forms.Control) | Retrieves a value indicating whether the specified control is a child of the control.
Public Method CopyToClipboard | Overloaded. Copies the current image to the clipboard.
Public Method CreateControl (Inherited from System.Windows.Forms.Control) | Forces the creation of the control, including the creation of the handle and any child controls.
Public Method CreateGraphics (Inherited from System.Windows.Forms.Control) | Creates the Graphics for the control.
Public Method CreateObjRef (Inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Public Method Dispose (Inherited from System.ComponentModel.Component) | Releases all resources used by the Component.
Public Method DoDragDrop (Inherited from System.Windows.Forms.Control) | Begins a drag-and-drop operation.
Public Method DrawToBitmap (Inherited from System.Windows.Forms.Control) | Supports rendering to the specified bitmap.
Public Method EndInvoke (Inherited from System.Windows.Forms.Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Public Method FindForm (Inherited from System.Windows.Forms.Control) | Retrieves the form that the control is on.
Public Method Focus (Inherited from System.Windows.Forms.Control) | Sets input focus to the control.
Public Method GetChildAtPoint (Inherited from System.Windows.Forms.Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
Public Method GetContainerControl (Inherited from System.Windows.Forms.Control) | Returns the next ContainerControl up the control's chain of parent controls.
Public Method GetLifetimeService (Inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Public Method GetNextControl (Inherited from System.Windows.Forms.Control) | Retrieves the next control forward or back in the tab order of child controls.
Public Method GetPaletteColor | Retrieves the colors for a user defined palette for the control.
Public Method GetPreferredSize (Inherited from System.Windows.Forms.Control) | Retrieves the size of a rectangular area into which a control can be fitted.
Public Method Hide (Inherited from System.Windows.Forms.Control) | Conceals the control from the user.
Public Method InitializeLifetimeService (Inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Public Method Invalidate (Inherited from System.Windows.Forms.Control) | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn.
Public Method Invoke (Inherited from System.Windows.Forms.Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
Public Method IsToolCursorBuiltin | Determines if the current cursor for a tool is the built-in default cursor.
Public Method MouseWheelGet | Retrieves which MouseWheelAction is assigned to a given mousewheel/shift combination.
Public Method MouseWheelGetAttribute | Retrieves the value of a specific mousewheel action's attribute.
Public Method MouseWheelSet | Assigns a MouseWheelAction to a particular shift/mousewheel combination.
Public Method MouseWheelSetAttribute | Sets the value of a specific mousewheel action's attribute.
Public Method PasteFromClipboard | Pastes the image from the clipboard to the current image.
Public Method PerformAutoScale (Inherited from System.Windows.Forms.ContainerControl) | Performs scaling of the container control and its children.
Public Method PerformLayout (Inherited from System.Windows.Forms.Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
Public Method PointToClient (Inherited from System.Windows.Forms.Control) | Computes the location of the specified screen point into client coordinates.
Public Method PointToScreen (Inherited from System.Windows.Forms.Control) | Computes the location of the specified client point into screen coordinates.
Public Method PreProcessControlMessage (Inherited from System.Windows.Forms.Control) |
Public Method PreProcessMessage (Inherited from System.Windows.Forms.Control) |
Public Method Print | Overloaded. Prints an image to the current graphics object given graphics and rectangle values.
Public Method RectangleToClient (Inherited from System.Windows.Forms.Control) | Computes the size and location of the specified screen rectangle in client coordinates.
Public Method RectangleToScreen (Inherited from System.Windows.Forms.Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Public Method Refresh (Inherited from System.Windows.Forms.Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
Public Method ResetText (Inherited from System.Windows.Forms.Control) | Resets the Text property to its default value.
Public Method ResetToolCursor | Resets the cursor for a specific tool cursor type back to the built-in default cursor.
Public Method ResumeLayout (Inherited from System.Windows.Forms.Control) | Overloaded. Resumes usual layout logic.
Public Method ScrollControlIntoView (Inherited from System.Windows.Forms.ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Public Method Select (Inherited from System.Windows.Forms.Control) | Activates the control.
Public Method SelectNextControl (Inherited from System.Windows.Forms.Control) | Activates the next control.
Public Method SendToBack (Inherited from System.Windows.Forms.Control) | Sends the control to the back of the z-order.
Public Method SetAutoScrollMargin (Inherited from System.Windows.Forms.ScrollableControl) | Sets the size of the auto-scroll margins.
Public Method SetBounds (Inherited from System.Windows.Forms.Control) | Overloaded. Sets the specified bounds of the control to the specified location and size.
Public Method SetPaletteColor | Specifies the colors for a user defined palette for the control.
Public Method SetToolCursor | Sets the cursor for a specific tool cursor type.
Public Method Show (Inherited from System.Windows.Forms.Control) | Displays the control to the user.
Public Method ShowImageInfo | Invokes a dialog box displaying image information.
Public Method SuspendLayout (Inherited from System.Windows.Forms.Control) | Temporarily suspends the layout logic for the control.
Public Method ToolGet | Retrieves which tool is assigned to a given mouse/shift combination.
Public Method ToolGetAttribute | Retrieves the value of a specific tool's attribute.
Public Method ToolSet | Assigns a tool to a particular shift/mouse combination.
Public Method ToolSetAttribute | Sets the value of a specific tool's attribute.
Public Method ToString (Inherited from System.ComponentModel.Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Public Method Translate | Translates values from one coordinate system to the other.
Public Method Update (Inherited from System.Windows.Forms.Control) | Causes the control to redraw the invalidated regions within its client area.
Public Method Validate (Inherited from System.Windows.Forms.ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
Public Method ValidateChildren (Inherited from System.Windows.Forms.UserControl) | Overloaded.
Public Method ZoomToFit | Zoom the image display to fit within the ImageXView control.

Public Events

Public Event AutoResizeChanged | Thrown when the AutoResize property changes.
Public Event AutoSizeChanged (Inherited from System.Windows.Forms.UserControl) |
Public Event AutoValidateChanged (Inherited from System.Windows.Forms.UserControl) | Occurs when the AutoValidate property changes.
Public Event BackColorChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the BackColor property changes.
Public Event BackgroundImageChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the BackgroundImage property changes.
Public Event BackgroundImageLayoutChanged (Inherited from System.Windows.Forms.Control) | Occurs when the BackgroundImageLayout property changes.
Public Event BindingContextChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the BindingContext property changes.
Public Event CausesValidationChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the CausesValidation property changes.
Public Event ChangeUICues (Inherited from System.Windows.Forms.Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Public Event Click (Inherited from System.Windows.Forms.Control) | Occurs when the control is clicked.
Public Event ClientSizeChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the ClientSize property changes.
Public Event ContextMenuChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the ContextMenu property changes.
Public Event ContextMenuStripChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the ContextMenuStrip property changes.
Public Event ControlAdded (Inherited from System.Windows.Forms.Control) | Occurs when a new control is added to the ControlCollection.
Public Event ControlRemoved (Inherited from System.Windows.Forms.Control) | Occurs when a control is removed from the ControlCollection.
Public Event CursorChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the Cursor property changes.
Public Event Disposed (Inherited from System.ComponentModel.Component) | Adds an event handler to listen to the Disposed event on the component.
Public Event DockChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the Dock property changes.
Public Event DoubleClick (Inherited from System.Windows.Forms.Control) | Occurs when the control is double-clicked.
Public Event DragDrop (Inherited from System.Windows.Forms.Control) | Occurs when a drag-and-drop operation is completed.
Public Event DragEnter (Inherited from System.Windows.Forms.Control) | Occurs when an object is dragged into the control's bounds.
Public Event DragLeave (Inherited from System.Windows.Forms.Control) | Occurs when an object is dragged out of the control's bounds.
Public Event DragOver (Inherited from System.Windows.Forms.Control) | Occurs when an object is dragged over the control's bounds.
Public Event EnabledChanged (Inherited from System.Windows.Forms.Control) | Occurs when the Enabled property value has changed.
Public Event Enter (Inherited from System.Windows.Forms.Control) | Occurs when the control is entered.
Public Event FontChanged (Inherited from System.Windows.Forms.Control) | Occurs when the Font property value changes.
Public Event ForeColorChanged (Inherited from System.Windows.Forms.Control) | Occurs when the ForeColor property value changes.
Public Event GiveFeedback (Inherited from System.Windows.Forms.Control) | Occurs during a drag operation.
Public Event GotFocus (Inherited from System.Windows.Forms.Control) | Occurs when the control receives focus.
Public Event HandleCreated (Inherited from System.Windows.Forms.Control) | Occurs when a handle is created for the control.
Public Event HandleDestroyed (Inherited from System.Windows.Forms.Control) | Occurs when the control's handle is in the process of being destroyed.
Public Event HelpRequested (Inherited from System.Windows.Forms.Control) | Occurs when the user requests help for a control.
Public Event ImeModeChanged (Inherited from System.Windows.Forms.Control) | Occurs when the ImeMode property has changed.
Public Event Invalidated (Inherited from System.Windows.Forms.Control) | Occurs when a control's display requires redrawing.
Public Event KeyDown (Inherited from System.Windows.Forms.Control) | Occurs when a key is pressed while the control has focus.
Public Event KeyPress (Inherited from System.Windows.Forms.Control) | Occurs when a key is pressed while the control has focus.
Public Event KeyUp (Inherited from System.Windows.Forms.Control) | Occurs when a key is released while the control has focus.
Public Event Layout (Inherited from System.Windows.Forms.Control) | Occurs when a control should reposition its child controls.
Public Event Leave (Inherited from System.Windows.Forms.Control) | Occurs when the input focus leaves the control.
Public Event Load (Inherited from System.Windows.Forms.UserControl) | Occurs before the control becomes visible for the first time.
Public Event LocationChanged (Inherited from System.Windows.Forms.Control) | Occurs when the Location property value has changed.
Public Event LostFocus (Inherited from System.Windows.Forms.Control) | Occurs when the control loses focus.
Public Event MarginChanged (Inherited from System.Windows.Forms.Control) | Occurs when the control's margin changes.
Public Event MouseCaptureChanged (Inherited from System.Windows.Forms.Control) | Occurs when the control loses mouse capture.
Public Event MouseClick (Inherited from System.Windows.Forms.Control) | Occurs when the control is clicked by the mouse.
Public Event MouseDoubleClick (Inherited from System.Windows.Forms.Control) | Occurs when the control is double clicked by the mouse.
Public Event MouseDown (Inherited from System.Windows.Forms.Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
Public Event MouseEnter (Inherited from System.Windows.Forms.Control) | Occurs when the mouse pointer enters the control.
Public Event MouseHover (Inherited from System.Windows.Forms.Control) | Occurs when the mouse pointer rests on the control.
Public Event MouseLeave (Inherited from System.Windows.Forms.Control) | Occurs when the mouse pointer leaves the control.
Public Event MouseMove (Inherited from System.Windows.Forms.Control) | Occurs when the mouse pointer is moved over the control.
Public Event MouseUp (Inherited from System.Windows.Forms.Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Public Event MouseWheel (Inherited from System.Windows.Forms.Control) | Occurs when the mouse wheel moves while the control has focus.
Public Event Move (Inherited from System.Windows.Forms.Control) | Occurs when the control is moved.
Public Event PaddingChanged (Inherited from System.Windows.Forms.Control) | Occurs when the control's padding changes.
Public Event Paint (Inherited from System.Windows.Forms.Control) | Occurs when the control is redrawn.
Public Event PaintImage | Thrown when the image is painted onto the screen.
Public Event ParentChanged (Inherited from System.Windows.Forms.Control) | Occurs when the Parent property value changes.
Public Event PreviewKeyDown (Inherited from System.Windows.Forms.Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
Public Event PrintImage | Thrown when the image is printed onto the paper.
Public Event QueryAccessibilityHelp (Inherited from System.Windows.Forms.Control) | Occurs when AccessibleObject is providing help to accessibility applications.
Public Event QueryContinueDrag (Inherited from System.Windows.Forms.Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
Public Event RegionChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the Region property changes.
Public Event Resize (Inherited from System.Windows.Forms.Control) | Occurs when the control is resized.
Public Event Resized | Thrown after the control has been completely resized.
Public Event RightToLeftChanged (Inherited from System.Windows.Forms.Control) | Occurs when the RightToLeft property value changes.
Public Event Scroll (Inherited from System.Windows.Forms.ScrollableControl) | Occurs when the user or code scrolls through the client area.
Public Event ScrollbarVisibleChanged | Thrown when one or more scrollbars changes its visibility.
Public Event ScrollEvent | Thrown during a scroll event.
Public Event SizeChanged (Inherited from System.Windows.Forms.Control) | Occurs when the Size property value changes.
Public Event StyleChanged (Inherited from System.Windows.Forms.Control) | Occurs when the control style changes.
Public Event SystemColorsChanged (Inherited from System.Windows.Forms.Control) | Occurs when the system colors change.
Public Event TabIndexChanged (Inherited from System.Windows.Forms.Control) | Occurs when the TabIndex property value changes.
Public Event TabStopChanged (Inherited from System.Windows.Forms.Control) | Occurs when the TabStop property value changes.
Public Event ToolbarCloseEvent | Thrown when a toolbar close event occurs.
Public Event ToolbarContextMenuSelectEvent | Thrown when the toolbar context menu is selected.
Public Event ToolbarEvent | Thrown when a toolbar event occurs.
Public Event ToolbarOpenEvent | Thrown when a toolbar open event occurs.
Public Event ToolEvent | Thrown when a tool event occurs.
Public Event Validated (Inherited from System.Windows.Forms.Control) | Occurs when the control is finished validating.
Public Event Validating (Inherited from System.Windows.Forms.Control) | Occurs when the control is validating.
Public Event VisibleChanged (Inherited from System.Windows.Forms.Control) | Occurs when the Visible property value changes.
Public Event ZoomFactorChanged | Thrown when the ZoomFactor property changes.

See Also

ImageXView Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXView Constructor

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXView Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : ImageXView Constructor (ImageXView)

Initializes a new instance of the ImageXView class.

Overload List

Initializes a new instance of the ImageXView class.

[Visual Basic] Public Sub New(IContainer)

[C#] public ImageXView(IContainer);

[C++] public ImageXView(IContainer*);

[C++/CLI] public ImageXView(IContainer^);

Initializes a new instance of the ImageXView class.

[Visual Basic] Public Sub New(ImagXpress)

[C#] public ImageXView(ImagXpress);

[C++] public ImageXView(ImagXpress*);

[C++/CLI] public ImageXView(ImagXpress^);

Initializes a new instance of the ImageXView class.

[Visual Basic] Public Sub New(IContainer,ImagXpress)

[C#] public ImageXView(IContainer,ImagXpress);

[C++] public ImageXView(IContainer*,ImagXpress*);

[C++/CLI] public ImageXView(IContainer^,ImagXpress^);

See Also

ImageXView Class | ImageXView Members


ImageXView Constructor(IContainer)

ImageXView Class | ImageXView Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

container
The container that implements the IContainer interface which will contain this component.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXView Constructor(IContainer)

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class > ImageXView Constructor : ImageXView Constructor(IContainer)

Initializes a new instance of the ImageXView class.

[Visual Basic]
Public Function New( _
   ByVal container As IContainer _
)
[C#]
public ImageXView(
   IContainer container
);
[C++]
public: ImageXView(
   IContainer* container
)
[C++/CLI]
public:
ImageXView(
   IContainer^ container
)

Parameters

container
The container that implements the IContainer interface which will contain this component.

See Also

ImageXView Class | ImageXView Members | Overload List


ImageXView Constructor(IContainer,ImagXpress)

ImageXView Class | ImageXView Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

container
The container that implements the IContainer interface which will contain this control.
imagXpress
An ImagXpress workspace component.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXView Constructor(IContainer,ImagXpress)

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class > ImageXView Constructor : ImageXView Constructor(IContainer,ImagXpress)

Initializes a new instance of the ImageXView class.

[Visual Basic]
Public Function New( _
   ByVal container As IContainer, _
   ByVal imagXpress As ImagXpress _
)
[C#]
public ImageXView(
   IContainer container,
   ImagXpress imagXpress
);
[C++]
public: ImageXView(
   IContainer* container,
   ImagXpress* imagXpress
)
[C++/CLI]
public:
ImageXView(
   IContainer^ container,
   ImagXpress^ imagXpress
)

Parameters

container
The container that implements the IContainer interface which will contain this control.
imagXpress
An ImagXpress workspace component.

See Also

ImageXView Class | ImageXView Members | Overload List


ImageXView Constructor(ImagXpress)

ImageXView Class | ImageXView Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An ImagXpress workspace component.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXView Constructor(ImagXpress)

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class > ImageXView Constructor : ImageXView Constructor(ImagXpress)

Initializes a new instance of the ImageXView class.

[Visual Basic]
Public Function New( _
   ByVal imagXpress As ImagXpress _
)
[C#]
public ImageXView(
   ImagXpress imagXpress
);
[C++]
public: ImageXView(
   ImagXpress* imagXpress
)
[C++/CLI]
public:
ImageXView(
   ImagXpress^ imagXpress
)

Parameters

imagXpress
An ImagXpress workspace component.

See Also

ImageXView Class | ImageXView Members | Overload List


CaptureControl Method

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CaptureControl Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : CaptureControl Method

Captures the screen area bounded by the control and saves it to the current image.

[Visual Basic]
Public Sub CaptureControl()
[C#]
public void CaptureControl();
[C++]
public: void CaptureControl();
[C++/CLI]
public:
void CaptureControl();

Remarks

This method captures the image data within the screen area bounded by the control and saved to ImageXView.Image.

See Also

ImageXView Class | ImageXView Members


CaptureWindow Method

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CaptureWindow Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : CaptureWindow Method

Captures the screen area within the specified Window and saves it to the current Image.

Overload List

Captures the screen area within the specified Window and saves it to the current Image.

[Visual Basic] Overloads Public Sub CaptureWindow(IntPtr)

[C#] public void CaptureWindow(IntPtr);

[C++] public void CaptureWindow(IntPtr);

[C++/CLI] public void CaptureWindow(IntPtr);

Captures the screen area within the specified Window and saves it to the current Image.

[Visual Basic] Overloads Public Sub CaptureWindow(IntPtr,Rectangle)

[C#] public void CaptureWindow(IntPtr,Rectangle);

[C++] public void CaptureWindow(IntPtr,Rectangle);

[C++/CLI] public void CaptureWindow(IntPtr,Rectangle);

See Also

ImageXView Class | ImageXView Members


CaptureWindow(IntPtr) Method

ImageXView Class | ImageXView Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

hWnd
A value that evaluates to a Window handle.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CaptureWindow(IntPtr) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class > CaptureWindow Method : CaptureWindow(IntPtr) Method

Captures the screen area within the specified Window and saves it to the current Image.

[Visual Basic]
Overloads Public Sub CaptureWindow( _
   ByVal hWnd As IntPtr _
)
[C#]
public void CaptureWindow(
   IntPtr hWnd
);
[C++]
public: void CaptureWindow(
   IntPtr hWnd
)
[C++/CLI]
public:
void CaptureWindow(
   IntPtr hWnd
)

Parameters

hWnd
A value that evaluates to a Window handle.

Remarks

The image data within the specified window is saved to ImageXView.Image.

See Also

ImageXView Class | ImageXView Members | Overload List


CaptureWindow(IntPtr,Rectangle) Method

ImageXView Class | ImageXView Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

hWnd
A value that evaluates to a Window handle.
captureRectangle
A Rectangle area in pixels within the specified window.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CaptureWindow(IntPtr,Rectangle) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class > CaptureWindow Method : CaptureWindow(IntPtr,Rectangle) Method

Captures the screen area within the specified Window and saves it to the current Image.

[Visual Basic]
Overloads Public Sub CaptureWindow( _
   ByVal hWnd As IntPtr, _
   ByVal captureRectangle As Rectangle _
)
[C#]
public void CaptureWindow(
   IntPtr hWnd,
   Rectangle captureRectangle
);
[C++]
public: void CaptureWindow(
   IntPtr hWnd,
   Rectangle captureRectangle
)
[C++/CLI]
public:
void CaptureWindow(
   IntPtr hWnd,
   Rectangle captureRectangle
)

Parameters

hWnd
A value that evaluates to a Window handle.
captureRectangle
A Rectangle area in pixels within the specified window.

Remarks

The image data within the specified window is saved to ImageXView.Image.

See Also

ImageXView Class | ImageXView Members | Overload List


CopyToClipboard Method

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CopyToClipboard Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : CopyToClipboard Method

Copies the current image to the clipboard.

Overload List

Copies the current image to the clipboard.

[Visual Basic] Overloads Public Sub CopyToClipboard()

[C#] public void CopyToClipboard();

[C++] public void CopyToClipboard()

[C++/CLI] public void CopyToClipboard()

Copies the current image to the clipboard in the format specified.

[Visual Basic] Overloads Public Sub CopyToClipboard(ClipboardFormat)

[C#] public void CopyToClipboard(ClipboardFormat);

[C++] public void CopyToClipboard(ClipboardFormat);

[C++/CLI] public void CopyToClipboard(ClipboardFormat);

See Also

ImageXView Class | ImageXView Members


CopyToClipboard() Method

ImageXView Class | ImageXView Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CopyToClipboard() Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class > CopyToClipboard Method : CopyToClipboard() Method

Copies the current image to the clipboard.

[Visual Basic]
Overloads Public Sub CopyToClipboard()
[C#]
public void CopyToClipboard();
[C++]
public: void CopyToClipboard();
[C++/CLI]
public:
void CopyToClipboard();

Remarks

This method makes a copy of the Image in DIB format and places it on the clipboard.

See Also

ImageXView Class | ImageXView Members | Overload List


CopyToClipboard(ClipboardFormat) Method

ImageXView Class | ImageXView Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

format
The format you wish to have placed in the clipboard.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CopyToClipboard(ClipboardFormat) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class > CopyToClipboard Method : CopyToClipboard(ClipboardFormat) Method

Copies the current image to the clipboard in the format specified.

[Visual Basic]
Overloads Public Sub CopyToClipboard( _
   ByVal format As ClipboardFormat _
)
[C#]
public void CopyToClipboard(
   ClipboardFormat format
);
[C++]
public: void CopyToClipboard(
   ClipboardFormat format
)
[C++/CLI]
public:
void CopyToClipboard(
   ClipboardFormat format
)

Parameters

format
The format you wish to have placed in the clipboard.

Remarks

This method makes a copy of the Image in the format you specify and places it on the clipboard.

See Also

ImageXView Class | ImageXView Members | Overload List


GetPaletteColor Method

ImageXView Class | ImageXView Members | UserDefined Field

Language

Visual Basic

C#

C++

C++/CLI

Show All

Index
An integer value which represents the index into the palette table. The minimum index is 0, the maximum Index is 255.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GetPaletteColor Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : GetPaletteColor Method

Retrieves the colors for a user defined palette for the control.

[Visual Basic]
Public Function GetPaletteColor( _
   ByVal Index As Integer _
) As Color
[C#]
public Color GetPaletteColor(
   int Index
);
[C++]
public: Color GetPaletteColor(
   int Index
)
[C++/CLI]
public:
Color GetPaletteColor(
   int Index
)

Parameters

Index
An integer value which represents the index into the palette table. The minimum index is 0, the maximum Index is 255.

Return Type

A Color value for that palette location.

Remarks

When the ImageXView.PaletteType property is set to PaletteType.UserDefined, images displayed during palettized display use the palette defined by this method.

Valid values are 0 to 255.

See Also

ImageXView Class | ImageXView Members | UserDefined Field


IsToolCursorBuiltin Method

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

cursorType
Tool cursor type to check.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

IsToolCursorBuiltin Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : IsToolCursorBuiltin Method

Determines if the current cursor for a tool is the built-in default cursor.

[Visual Basic]
Public Function IsToolCursorBuiltin( _
   ByVal cursorType As ToolCursor _
) As Boolean
[C#]
public bool IsToolCursorBuiltin(
   ToolCursor cursorType
);
[C++]
public: bool IsToolCursorBuiltin(
   ToolCursor cursorType
)
[C++/CLI]
public:
bool IsToolCursorBuiltin(
   ToolCursor cursorType
)

Parameters

cursorType
Tool cursor type to check.

Return Type

A Boolean value for the built-in status of the tool cursor.

See Also

ImageXView Class | ImageXView Members


MouseWheelGet Method

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

key
The Keys value which represents the shift key to be pressed. Currently the only supported keys are shift, control, and alt key values.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

MouseWheelGet Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : MouseWheelGet Method

Retrieves which MouseWheelAction is assigned to a given mousewheel/shift combination.

[Visual Basic]
Public Function MouseWheelGet( _
   ByVal key As Keys _
) As MouseWheelAction
[C#]
public MouseWheelAction MouseWheelGet(
   Keys key
);
[C++]
public: MouseWheelAction MouseWheelGet(
   Keys key
)
[C++/CLI]
public:
MouseWheelAction MouseWheelGet(
   Keys key
)

Parameters

key
The Keys value which represents the shift key to be pressed. Currently the only supported keys are shift, control, and alt key values.

Return Type

The MouseWheelAction assigned to mousewheel/shift combination.

See Also

ImageXView Class | ImageXView Members


MouseWheelGetAttribute Method

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

attribute
Specific attribute to get the value from.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

MouseWheelGetAttribute Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : MouseWheelGetAttribute Method

Retrieves the value of a specific mousewheel action's attribute.

[Visual Basic]
Public Function MouseWheelGetAttribute( _
   ByVal attribute As MouseWheelAttribute _
) As Integer
[C#]
public int MouseWheelGetAttribute(
   MouseWheelAttribute attribute
);
[C++]
public: int MouseWheelGetAttribute(
   MouseWheelAttribute attribute
)
[C++/CLI]
public:
int MouseWheelGetAttribute(
   MouseWheelAttribute attribute
)

Parameters

attribute
Specific attribute to get the value from.

Return Type

An integer value for that tool's attribute.

See Also

ImageXView Class | ImageXView Members


MouseWheelSet Method

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

action
The MouseWheelAction to assign.
key
The Keys value which represents the shift key to be pressed. Currently the only supported keys are shift, control, and alt key values.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

MouseWheelSet Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : MouseWheelSet Method

Assigns a MouseWheelAction to a particular shift/mousewheel combination.

[Visual Basic]
Public Sub MouseWheelSet( _
   ByVal action As MouseWheelAction, _
   ByVal key As Keys _
)
[C#]
public void MouseWheelSet(
   MouseWheelAction action,
   Keys key
);
[C++]
public: void MouseWheelSet(
   MouseWheelAction action,
   Keys key
)
[C++/CLI]
public:
void MouseWheelSet(
   MouseWheelAction action,
   Keys key
)

Parameters

action
The MouseWheelAction to assign.
key
The Keys value which represents the shift key to be pressed. Currently the only supported keys are shift, control, and alt key values.

See Also

ImageXView Class | ImageXView Members


MouseWheelSetAttribute Method

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

attribute
Specific attribute to set the value on.
newValue
An integer value which represents the new attribute value.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

MouseWheelSetAttribute Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : MouseWheelSetAttribute Method

Sets the value of a specific mousewheel action's attribute.

[Visual Basic]
Public Sub MouseWheelSetAttribute( _
   ByVal attribute As MouseWheelAttribute, _
   ByVal newValue As Integer _
)
[C#]
public void MouseWheelSetAttribute(
   MouseWheelAttribute attribute,
   int newValue
);
[C++]
public: void MouseWheelSetAttribute(
   MouseWheelAttribute attribute,
   int newValue
)
[C++/CLI]
public:
void MouseWheelSetAttribute(
   MouseWheelAttribute attribute,
   int newValue
)

Parameters

attribute
Specific attribute to set the value on.
newValue
An integer value which represents the new attribute value.

See Also

ImageXView Class | ImageXView Members


PasteFromClipboard Method

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PasteFromClipboard Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : PasteFromClipboard Method

Pastes the image from the clipboard to the current image.

[Visual Basic]
Public Sub PasteFromClipboard()
[C#]
public void PasteFromClipboard();
[C++]
public: void PasteFromClipboard();
[C++/CLI]
public:
void PasteFromClipboard();

Remarks

The image on the clipboard is pasted into an Image, overwriting any existing data in the Image object.

Note: Available in all editions.

See Also

ImageXView Class | ImageXView Members


Print Method

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Print Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : Print Method

Prints an image to the current graphics object given graphics and rectangle values.

Overload List

Prints an image to the current graphics object given graphics and rectangle values.

[Visual Basic] Overloads Public Sub Print(Graphics,Rectangle)

[C#] public void Print(Graphics,Rectangle);

[C++] public void Print(Graphics*,Rectangle);

[C++/CLI] public void Print(Graphics^,Rectangle);

Prints an image to the current graphics object given graphics and dimensions.

[Visual Basic] Overloads Public Sub Print(Graphics,RectangleF)

[C#] public void Print(Graphics,RectangleF);

[C++] public void Print(Graphics*,RectangleF);

[C++/CLI] public void Print(Graphics^,RectangleF);

Prints an image to the current graphics object given graphics, dimensions and type of print.

[Visual Basic] Overloads Public Sub Print(Graphics,Rectangle,PrintType)

[C#] public void Print(Graphics,Rectangle,PrintType);

[C++] public void Print(Graphics*,Rectangle,PrintType);

[C++/CLI] public void Print(Graphics^,Rectangle,PrintType);

Prints an image to the current graphics object given graphics, dimensions and type of print.

[Visual Basic] Overloads Public Sub Print(Graphics,RectangleF,PrintType)

[C#] public void Print(Graphics,RectangleF,PrintType);

[C++] public void Print(Graphics*,RectangleF,PrintType);

[C++/CLI] public void Print(Graphics^,RectangleF,PrintType);

See Also

ImageXView Class | ImageXView Members


Print(Graphics,Rectangle) Method

ImageXView Class | ImageXView Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

graphics
A Graphics object.
dimensions
A Rectangle object.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Print(Graphics,Rectangle) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class > Print Method : Print(Graphics,Rectangle) Method

Prints an image to the current graphics object given graphics and rectangle values.

[Visual Basic]
Overloads Public Sub Print( _
   ByVal graphics As Graphics, _
   ByVal dimensions As Rectangle _
)
[C#]
public void Print(
   Graphics graphics,
   Rectangle dimensions
);
[C++]
public: void Print(
   Graphics* graphics,
   Rectangle dimensions
)
[C++/CLI]
public:
void Print(
   Graphics^ graphics,
   Rectangle dimensions
)

Parameters

graphics
A Graphics object.
dimensions
A Rectangle object.

See Also

ImageXView Class | ImageXView Members | Overload List


Print(Graphics,RectangleF) Method

ImageXView Class | ImageXView Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

graphics
A Graphics object.
dimensions
A RectangleF object.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Print(Graphics,RectangleF) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class > Print Method : Print(Graphics,RectangleF) Method

Prints an image to the current graphics object given graphics and dimensions.

[Visual Basic]
Overloads Public Sub Print( _
   ByVal graphics As Graphics, _
   ByVal dimensions As RectangleF _
)
[C#]
public void Print(
   Graphics graphics,
   RectangleF dimensions
);
[C++]
public: void Print(
   Graphics* graphics,
   RectangleF dimensions
)
[C++/CLI]
public:
void Print(
   Graphics^ graphics,
   RectangleF dimensions
)

Parameters

graphics
A Graphics object.
dimensions
A RectangleF object.

See Also

ImageXView Class | ImageXView Members | Overload List


Print(Graphics,Rectangle,PrintType) Method

ImageXView Class | ImageXView Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

graphics
A Graphics object.
dimensions
A Rectangle object.
printType
A PrintType value.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Print(Graphics,Rectangle,PrintType) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class > Print Method : Print(Graphics,Rectangle,PrintType) Method

Prints an image to the current graphics object given graphics, dimensions and type of print.

[Visual Basic]
Overloads Public Sub Print( _
   ByVal graphics As Graphics, _
   ByVal dimensions As Rectangle, _
   ByVal printType As PrintType _
)
[C#]
public void Print(
   Graphics graphics,
   Rectangle dimensions,
   PrintType printType
);
[C++]
public: void Print(
   Graphics* graphics,
   Rectangle dimensions,
   PrintType printType
)
[C++/CLI]
public:
void Print(
   Graphics^ graphics,
   Rectangle dimensions,
   PrintType printType
)

Parameters

graphics
A Graphics object.
dimensions
A Rectangle object.
printType
A PrintType value.

See Also

ImageXView Class | ImageXView Members | Overload List


Print(Graphics,RectangleF,PrintType) Method

ImageXView Class | ImageXView Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

graphics
A Graphics object.
dimensions
A RectangleF object.
printType
A PrintType value.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Print(Graphics,RectangleF,PrintType) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class > Print Method : Print(Graphics,RectangleF,PrintType) Method

Prints an image to the current graphics object given graphics, dimensions and type of print.

[Visual Basic]
Overloads Public Sub Print( _
   ByVal graphics As Graphics, _
   ByVal dimensions As RectangleF, _
   ByVal printType As PrintType _
)
[C#]
public void Print(
   Graphics graphics,
   RectangleF dimensions,
   PrintType printType
);
[C++]
public: void Print(
   Graphics* graphics,
   RectangleF dimensions,
   PrintType printType
)
[C++/CLI]
public:
void Print(
   Graphics^ graphics,
   RectangleF dimensions,
   PrintType printType
)

Parameters

graphics
A Graphics object.
dimensions
A RectangleF object.
printType
A PrintType value.

See Also

ImageXView Class | ImageXView Members | Overload List


ResetToolCursor Method

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

cursorType
Tool cursor type to reset.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ResetToolCursor Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : ResetToolCursor Method

Resets the cursor for a specific tool cursor type back to the built-in default cursor.

[Visual Basic]
Public Sub ResetToolCursor( _
   ByVal cursorType As ToolCursor _
)
[C#]
public void ResetToolCursor(
   ToolCursor cursorType
);
[C++]
public: void ResetToolCursor(
   ToolCursor cursorType
)
[C++/CLI]
public:
void ResetToolCursor(
   ToolCursor cursorType
)

Parameters

cursorType
Tool cursor type to reset.

See Also

ImageXView Class | ImageXView Members


SetPaletteColor Method

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

Index
An integer value which represents the index into the palette table. The minimum index is 0 and the maximum index is 255.
color
A Color value for that palette location.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetPaletteColor Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : SetPaletteColor Method

Specifies the colors for a user defined palette for the control.

[Visual Basic]
Public Sub SetPaletteColor( _
   ByVal Index As Integer, _
   ByVal color As Color _
)
[C#]
public void SetPaletteColor(
   int Index,
   Color color
);
[C++]
public: void SetPaletteColor(
   int Index,
   Color color
)
[C++/CLI]
public:
void SetPaletteColor(
   int Index,
   Color color
)

Parameters

Index
An integer value which represents the index into the palette table. The minimum index is 0 and the maximum index is 255.
color
A Color value for that palette location.

Remarks

When the ImageXView.PaletteType property is set as PaletteType.UserDefined, images displayed during palettized display will use the palette defined by this method.

See Also

ImageXView Class | ImageXView Members


SetToolCursor Method

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

cursorType
Tool cursor type to set.
cursor
New cursor.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetToolCursor Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : SetToolCursor Method

Sets the cursor for a specific tool cursor type.

[Visual Basic]
Public Sub SetToolCursor( _
   ByVal cursorType As ToolCursor, _
   ByVal cursor As Cursor _
)
[C#]
public void SetToolCursor(
   ToolCursor cursorType,
   Cursor cursor
);
[C++]
public: void SetToolCursor(
   ToolCursor cursorType,
   Cursor* cursor
)
[C++/CLI]
public:
void SetToolCursor(
   ToolCursor cursorType,
   Cursor^ cursor
)

Parameters

cursorType
Tool cursor type to set.
cursor
New cursor.

See Also

ImageXView Class | ImageXView Members


ShowImageInfo Method

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ShowImageInfo Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : ShowImageInfo Method

Invokes a dialog box displaying image information.

[Visual Basic]
Public Sub ShowImageInfo()
[C#]
public void ShowImageInfo();
[C++]
public: void ShowImageInfo();
[C++/CLI]
public:
void ShowImageInfo();

See Also

ImageXView Class | ImageXView Members


ToolGet Method

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

mouseButton
Mouse button to be pressed, currently only supports left, middle and right mouse buttons.
key
The Keys value which represents the shift key to be pressed. Currently, the only supported keys are shift, control, and alt key values.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolGet Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : ToolGet Method

Retrieves which tool is assigned to a given mouse/shift combination.

[Visual Basic]
Public Function ToolGet( _
   ByVal mouseButton As MouseButtons, _
   ByVal key As Keys _
) As Tool
[C#]
public Tool ToolGet(
   MouseButtons mouseButton,
   Keys key
);
[C++]
public: Tool ToolGet(
   MouseButtons mouseButton,
   Keys key
)
[C++/CLI]
public:
Tool ToolGet(
   MouseButtons mouseButton,
   Keys key
)

Parameters

mouseButton
Mouse button to be pressed, currently only supports left, middle and right mouse buttons.
key
The Keys value which represents the shift key to be pressed. Currently, the only supported keys are shift, control, and alt key values.

Return Type

Tool assigned to mouse/shift combination.

See Also

ImageXView Class | ImageXView Members


ToolGetAttribute Method

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
Tool to get the specific attribute from.
attribute
Specific attribute to get the value from.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolGetAttribute Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : ToolGetAttribute Method

Retrieves the value of a specific tool's attribute.

[Visual Basic]
Public Function ToolGetAttribute( _
   ByVal tool As Tool, _
   ByVal attribute As ToolAttribute _
) As Integer
[C#]
public int ToolGetAttribute(
   Tool tool,
   ToolAttribute attribute
);
[C++]
public: int ToolGetAttribute(
   Tool tool,
   ToolAttribute attribute
)
[C++/CLI]
public:
int ToolGetAttribute(
   Tool tool,
   ToolAttribute attribute
)

Parameters

tool
Tool to get the specific attribute from.
attribute
Specific attribute to get the value from.

Return Type

Value for that tool's attribute.

See Also

ImageXView Class | ImageXView Members


ToolSet Method

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
The Tool to assign.
mouseButton
The MouseButtons to be pressed. Currently this only supports left, middle and right mouse buttons.
key
The Keys value which represents the shift key to be pressed, currently only supports shift, control and alt key values.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolSet Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : ToolSet Method

Assigns a tool to a particular shift/mouse combination.

[Visual Basic]
Public Sub ToolSet( _
   ByVal tool As Tool, _
   ByVal mouseButton As MouseButtons, _
   ByVal key As Keys _
)
[C#]
public void ToolSet(
   Tool tool,
   MouseButtons mouseButton,
   Keys key
);
[C++]
public: void ToolSet(
   Tool tool,
   MouseButtons mouseButton,
   Keys key
)
[C++/CLI]
public:
void ToolSet(
   Tool tool,
   MouseButtons mouseButton,
   Keys key
)

Parameters

tool
The Tool to assign.
mouseButton
The MouseButtons to be pressed. Currently this only supports left, middle and right mouse buttons.
key
The Keys value which represents the shift key to be pressed, currently only supports shift, control and alt key values.

See Also

ImageXView Class | ImageXView Members


ToolSetAttribute Method

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
The Tool to set the specific attribute on.
attribute
Specific attribute to set the value on.
newValue
An integer value which represents the new tool's attribute value.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolSetAttribute Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : ToolSetAttribute Method

Sets the value of a specific tool's attribute.

[Visual Basic]
Public Sub ToolSetAttribute( _
   ByVal tool As Tool, _
   ByVal attribute As ToolAttribute, _
   ByVal newValue As Integer _
)
[C#]
public void ToolSetAttribute(
   Tool tool,
   ToolAttribute attribute,
   int newValue
);
[C++]
public: void ToolSetAttribute(
   Tool tool,
   ToolAttribute attribute,
   int newValue
)
[C++/CLI]
public:
void ToolSetAttribute(
   Tool tool,
   ToolAttribute attribute,
   int newValue
)

Parameters

tool
The Tool to set the specific attribute on.
attribute
Specific attribute to set the value on.
newValue
An integer value which represents the new tool's attribute value.

See Also

ImageXView Class | ImageXView Members


Translate Method

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

point
A Point value which represents the value to translate.
translationType
A TranslateType enumeration value which represents the type of translation.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Translate Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : Translate Method

Translates values from one coordinate system to the other.

[Visual Basic]
Public Function Translate( _
   ByVal point As PointF, _
   ByVal translationType As TranslateType _
) As PointF
[C#]
public PointF Translate(
   PointF point,
   TranslateType translationType
);
[C++]
public: PointF Translate(
   PointF point,
   TranslateType translationType
)
[C++/CLI]
public:
PointF Translate(
   PointF point,
   TranslateType translationType
)

Parameters

point
A Point value which represents the value to translate.
translationType
A TranslateType enumeration value which represents the type of translation.

Return Type

A Point value which represents the translated value.

Remarks

Note: Available in all editions.

See Also

ImageXView Class | ImageXView Members


ZoomToFit Method

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

zoomToFitType
A ZoomToFitType option.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ZoomToFit Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : ZoomToFit Method

Zoom the image display to fit within the ImageXView control.

[Visual Basic]
Public Sub ZoomToFit( _
   ByVal zoomToFitType As ZoomToFitType _
)
[C#]
public void ZoomToFit(
   ZoomToFitType zoomToFitType
);
[C++]
public: void ZoomToFit(
   ZoomToFitType zoomToFitType
)
[C++/CLI]
public:
void ZoomToFit(
   ZoomToFitType zoomToFitType
)

Parameters

zoomToFitType
A ZoomToFitType option.

Remarks

This is a one time zoom unlike some of the AutoResize property settings which will repeatedly set the ZoomFactor.

See Also

ImageXView Class | ImageXView Members


ImageXView Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXView Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXView Class

For a list of all members of this type, see ImageXView members.

Public Properties

Public Property AccessibilityObject (Inherited from System.Windows.Forms.Control) | Gets the AccessibleObject assigned to the control.
Public Property AccessibleDefaultActionDescription (Inherited from System.Windows.Forms.Control) | Gets or sets the default action description of the control for use by accessibility client applications.
Public Property AccessibleDescription (Inherited from System.Windows.Forms.Control) | Gets or sets the description of the control used by accessibility client applications.
Public Property AccessibleName (Inherited from System.Windows.Forms.Control) | Gets or sets the name of the control used by accessibility client applications.
Public Property AccessibleRole (Inherited from System.Windows.Forms.Control) | Gets or sets the accessible role of the control
Public Property ActiveControl (Inherited from System.Windows.Forms.ContainerControl) | Gets or sets the active control on the container control.
Public Property AlignHorizontal | Gets and sets the horizontal alignment of the image being viewed.
Public Property AlignVertical | Gets and sets the vertical alignment of the image being viewed.
Public Property AllowDrop (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Public Property AllowUpdate | Gets and sets an indicator which determines if updates allow the control to be repainted.
Public Property AlphaBlend | Gets and sets an indication of alpha blending an image to the background of the control when an alpha channel is present in the image.
Public Property Anchor (Inherited from System.Windows.Forms.Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Public Property Antialias | Gets and sets the anti-alias effect.
Public Property AspectX | Gets and sets the horizontal aspect ratio of the current image.
Public Property AspectY | Gets and sets the vertical aspect ratio of the current image.
Public Property AutoImageDispose | Gets and sets enabling the ImageXView's Dispose method to automatically call the ImageX's Dispose method.
Public Property AutoResize | Gets and sets how the image is sized and positioned for display when painted.
Public Property AutoScaleDimensions (Inherited from System.Windows.Forms.ContainerControl) | Gets or sets the dimensions that the control was designed to.
Public Property AutoScaleMode (Inherited from System.Windows.Forms.ContainerControl) | Gets or sets the automatic scaling mode of the control.
Public Property AutoScroll (Inherited from System.Windows.Forms.ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
Public Property AutoScrollMargin (Inherited from System.Windows.Forms.ScrollableControl) | Gets or sets the size of the auto-scroll margin.
Public Property AutoScrollMinSize (Inherited from System.Windows.Forms.ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
Public Property AutoScrollOffset (Inherited from System.Windows.Forms.Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
Public Property AutoScrollPosition (Inherited from System.Windows.Forms.ScrollableControl) | Gets or sets the location of the auto-scroll position.
Public Property AutoSize (Inherited from System.Windows.Forms.UserControl) |
Public Property AutoSizeMode (Inherited from System.Windows.Forms.UserControl) | Gets or sets how the control will resize itself.
Public Property AutoValidate (Inherited from System.Windows.Forms.UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
Public Property BackColor | Overridden. Sets the background color of the view window.
Public Property BackgroundImage (Inherited from System.Windows.Forms.Control) | Gets or sets the background image displayed in the control.
Public Property BackgroundImageLayout (Inherited from System.Windows.Forms.Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
Public Property BindingContext (Inherited from System.Windows.Forms.ContainerControl) |
Public Property BorderStyle | Gets and sets the border type of the ImageXView object.
Public Property BorderType | Gets and sets the border type of the ImageXView object.
Public Property Bottom (Inherited from System.Windows.Forms.Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Public Property Bounds (Inherited from System.Windows.Forms.Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
Public Property Brightness | Gets and sets the change of brightness of the current image.
Public Property CanFocus (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control can receive focus.
Public Property CanSelect (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control can be selected.
Public Property Capture (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether the control has captured the mouse.
Public Property CausesValidation (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
Public Property ClientRectangle (Inherited from System.Windows.Forms.Control) | Gets the rectangle that represents the client area of the control.
Public Property ClientSize (Inherited from System.Windows.Forms.Control) | Gets or sets the height and width of the client area of the control.
Public Property ClipRectangle | Gets and sets the rectangular portion of the image that is accessible to the viewer.
Public Property ColorRenderIntent | Gets and sets how the color profiles should be applied.
Public Property CompanyName (Inherited from System.Windows.Forms.Control) | Gets the name of the company or creator of the application containing the control.
Public Property Container (Inherited from System.ComponentModel.Component) | Gets the IContainer that contains the Component.
Public Property ContainsFocus (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
Public Property ContextMenu (Inherited from System.Windows.Forms.Control) | Gets or sets the shortcut menu associated with the control.
Public Property ContextMenuStrip (Inherited from System.Windows.Forms.Control) | Gets or sets the ContextMenuStrip associated with this control.
Public Property Contrast | Gets and sets the change of contrast level for the displayed image.
Public Property Controls (Inherited from System.Windows.Forms.Control) | Gets the collection of controls contained within the control.
Public Property Created (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control has been created.
Public Property CurrentAutoScaleDimensions (Inherited from System.Windows.Forms.ContainerControl) | Gets the current run-time dimensions of the screen.
Public Property Cursor (Inherited from System.Windows.Forms.Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Public Property CursorPosition | Gets the coordinates of the cursor position in the view window.
Public Property DataBindings (Inherited from System.Windows.Forms.Control) | Gets the data bindings for the control.
Public Property DisplayMode | Returns or sets a value indicating the maximum color depth used to render an image.
Public Property DisplayRectangle (Inherited from System.Windows.Forms.ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Public Property Disposing (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Public Property Dithered | Gets and sets a dithered indicator on the current image.
Public Property Dock (Inherited from System.Windows.Forms.Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
Public Property Enabled (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Public Property Focused (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control has input focus.
Public Property Font (Inherited from System.Windows.Forms.Control) | Gets or sets the font of the text displayed by the control.
Public Property ForeColor (Inherited from System.Windows.Forms.Control) | Gets or sets the foreground color of the control.
Public Property GrayMode | Gets and sets the mode of gray used to display a grayscale image.
Public Property Handle (Inherited from System.Windows.Forms.Control) | Gets the window handle that the control is bound to.
Public Property HasChildren (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control contains one or more child controls.
Public Property Height (Inherited from System.Windows.Forms.Control) | Gets or sets the height of the control.
Public Property HorizontalScroll (Inherited from System.Windows.Forms.ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Public Property IcmEnabled | Gets and sets an enabled indicator for the color management.
Public Property IcmProofingEnabled | Gets and sets an enabled indicator of the ICM target proofing.
Public Property Image | Gets and sets the current image view.
Public Property ImageCursorPosition | Gets the point at which the cursor is located within the image, in pixels.
Public Property ImeMode (Inherited from System.Windows.Forms.Control) | Gets or sets the Input Method Editor (IME) mode of the control.
Public Property InvokeRequired (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
Public Property IsAccessible (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
Public Property IsDisposed (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control has been disposed of.
Public Property IsHandleCreated (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control has a handle associated with it.
Public Property IsMirrored (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control is mirrored.
Public Property LayoutEngine (Inherited from System.Windows.Forms.Control) | Gets a cached instance of the control's layout engine.
Public Property Left (Inherited from System.Windows.Forms.Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Public Property Location (Inherited from System.Windows.Forms.Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Public Property Margin (Inherited from System.Windows.Forms.Control) | Gets or sets the space between controls.
Public Property Maximum | Gets and sets the maximum dimensions the viewer control can obtain.
Public Property MaximumSize (Inherited from System.Windows.Forms.Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
Public Property Medical | Gets and sets information required to display medical images.
Public Property Minimum | Gets and sets the minimum dimensions the viewer control can obtain.
Public Property MinimumSize (Inherited from System.Windows.Forms.Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Public Property MonitorProfileName | Gets and sets the monitor’s color management profile.
Public Property MouseWheelCapture | Gets and sets capturing the mousewheel even when the control does not have focus.
Public Property Name (Inherited from System.Windows.Forms.Control) | Gets or sets the name of the control.
Public Property Padding (Inherited from System.Windows.Forms.Control) | Gets or sets padding within the control.
Public Property PaletteFilename | Specifies the filename that contains the palette for the control.
Public Property PaletteType | Gets and sets the image display palette type.
Public Property Parent (Inherited from System.Windows.Forms.Control) | Gets or sets the parent container of the control.
Public Property ParentForm (Inherited from System.Windows.Forms.ContainerControl) | Gets the form that the container control is assigned to.
Public Property PixelColor | Gets the color of the pixel within the client area of the view control at which the cursor is currently positioned.
Public Property PreferredSize (Inherited from System.Windows.Forms.Control) | Gets the size of a rectangular area into which the control can fit.
Public Property PreserveBlack | Gets and sets an indicator if black should be preserved and applied when viewing the image.
Public Property PrinterProfileName | Gets and sets the printer’s profile filename.
Public Property ProductName (Inherited from System.Windows.Forms.Control) | Gets the product name of the assembly containing the control.
Public Property ProductVersion (Inherited from System.Windows.Forms.Control) | Gets the version of the assembly containing the control.
Public Property Progressive | Gets and sets an indication if images are displayed progressively.
Public Property RecreatingHandle (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control is currently re-creating its handle.
Public Property Region (Inherited from System.Windows.Forms.Control) | Gets or sets the window region associated with the control.
Public Property Right (Inherited from System.Windows.Forms.Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
Public Property RightToLeft (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Public Property Rubberband | Gets the current Rubberband object.
Public Property ScrollBars | Gets or sets the type of scroll bars to display in the ImagXView control.
Public Property ScrollPosition | Gets and sets the current scrolling position of the cursor on the scrollbar.
Public Property Site (Inherited from System.Windows.Forms.Control) | Gets or sets the site of the control.
Public Property Size (Inherited from System.Windows.Forms.Control) | Gets or sets the height and width of the control.
Public Property Smoothing | Gets and sets an indicator for the smoothing effect on the current image.
Public Property Sprite | Gets the Sprite object.
Public Property TabIndex (Inherited from System.Windows.Forms.Control) | Gets or sets the tab order of the control within its container.
Public Property TabStop (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Public Property Tag (Inherited from System.Windows.Forms.Control) | Gets or sets the object that contains data about the control.
Public Property TargetProfileName | Gets and sets the target profile’s filename.
Public Property ToolActive | Gets the currently active tool.
Public Property Toolbar | Gets the current Toolbar object.
Public Property Top (Inherited from System.Windows.Forms.Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
Public Property TopLevelControl (Inherited from System.Windows.Forms.Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Public Property UseWaitCursor (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Public Property VerticalScroll (Inherited from System.Windows.Forms.ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Public Property Visible (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether the control is displayed.
Public Property Width (Inherited from System.Windows.Forms.Control) | Gets or sets the width of the control.
Public Property ZoomFactor | Gets and sets the zoom factor display for the current image.

See Also

ImageXView Class | PegasusImaging.WinForms.ImagXpress9 Namespace


AlignHorizontal Property

ImageXView Class | ImageXView Members | AlignHorizontal Enumeration

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AlignHorizontal Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : AlignHorizontal Property (ImageXView)

Gets and sets the horizontal alignment of the image being viewed.

[Visual Basic]
<BrowsableAttribute(True)>
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
<DescriptionAttribute("The horizontal alignment of the image.")>
Public Property AlignHorizontal As AlignHorizontal
[C#]
[BrowsableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("The horizontal alignment of the image.")]
public AlignHorizontal AlignHorizontal {get; set;}
[C++]
[BrowsableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("The horizontal alignment of the image.")]
public: __property AlignHorizontal get_AlignHorizontal();
public: __property void set_AlignHorizontal(
   AlignHorizontal value
);
[C++/CLI]
[BrowsableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("The horizontal alignment of the image.")]
public:
property AlignHorizontal AlignHorizontal {
   AlignHorizontal get();
   void set (AlignHorizontal value);
}

Return Type

The AlignHorizontal enumeration value set.

Remarks

The default value is AlignHorizontal.Center.

When the displayed image is smaller than the viewing window, the image is horizontally aligned according to this setting.

See Also

ImageXView Class | ImageXView Members | AlignHorizontal Enumeration


AlignVertical Property

ImageXView Class | ImageXView Members | AlignVertical Enumeration

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AlignVertical Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : AlignVertical Property (ImageXView)

Gets and sets the vertical alignment of the image being viewed.

[Visual Basic]
<BrowsableAttribute(True)>
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("The vertical alignment of the image.")>
<DefaultValueAttribute()>
Public Property AlignVertical As AlignVertical
[C#]
[BrowsableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("The vertical alignment of the image.")]
[DefaultValueAttribute()]
public AlignVertical AlignVertical {get; set;}
[C++]
[BrowsableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("The vertical alignment of the image.")]
[DefaultValueAttribute()]
public: __property AlignVertical get_AlignVertical();
public: __property void set_AlignVertical(
   AlignVertical value
);
[C++/CLI]
[BrowsableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("The vertical alignment of the image.")]
[DefaultValueAttribute()]
public:
property AlignVertical AlignVertical {
   AlignVertical get();
   void set (AlignVertical value);
}

Return Type

The AlignVertical enumeration value set.

Remarks

The default value is AlignVertical.Center.

When the displayed image is smaller than the viewing window, then image is vertically aligned according to this setting.

See Also

ImageXView Class | ImageXView Members | AlignVertical Enumeration


AllowUpdate Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AllowUpdate Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : AllowUpdate Property

Gets and sets an indicator which determines if updates allow the control to be repainted.

[Visual Basic]
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<DescriptionAttribute("Property that determines whether updates allow the control to be repainted.")>
<DesignerSerializationVisibilityAttribute()>
Public Property AllowUpdate As Boolean
[C#]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Property that determines whether updates allow the control to be repainted.")]
[DesignerSerializationVisibilityAttribute()]
public bool AllowUpdate {get; set;}
[C++]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Property that determines whether updates allow the control to be repainted.")]
[DesignerSerializationVisibilityAttribute()]
public: __property bool get_AllowUpdate();
public: __property void set_AllowUpdate(
   bool value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Property that determines whether updates allow the control to be repainted.")]
[DesignerSerializationVisibilityAttribute()]
public:
property bool AllowUpdate {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to allow a repaint on updates. Otherwise, false is returned.

Remarks

If you set this property to false, then the control does not repaint when it needs updating.

See Also

ImageXView Class | ImageXView Members


AlphaBlend Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AlphaBlend Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : AlphaBlend Property

Gets and sets an indication of alpha blending an image to the background of the control when an alpha channel is present in the image.

[Visual Basic]
<DescriptionAttribute("Enables/disables alpha blending an image to the background of the control when an alpha channel is present in the image.")>
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<DesignerSerializationVisibilityAttribute()>
Public Property AlphaBlend As Boolean
[C#]
[DescriptionAttribute("Enables/disables alpha blending an image to the background of the control when an alpha channel is present in the image.")]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
public bool AlphaBlend {get; set;}
[C++]
[DescriptionAttribute("Enables/disables alpha blending an image to the background of the control when an alpha channel is present in the image.")]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
public: __property bool get_AlphaBlend();
public: __property void set_AlphaBlend(
   bool value
);
[C++/CLI]
[DescriptionAttribute("Enables/disables alpha blending an image to the background of the control when an alpha channel is present in the image.")]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
public:
property bool AlphaBlend {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to alpha blend the image to the background of the control. Otherwise, false is returned.

Remarks

The default value is false.

See Also

ImageXView Class | ImageXView Members


Antialias Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Antialias Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : Antialias Property

Gets and sets the anti-alias effect.

[Visual Basic]
<BrowsableAttribute(True)>
<DescriptionAttribute("Enables/disables antialiasing when resizing the image to the view.")>
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
Public Property Antialias As Boolean
[C#]
[BrowsableAttribute(true)]
[DescriptionAttribute("Enables/disables antialiasing when resizing the image to the view.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public bool Antialias {get; set;}
[C++]
[BrowsableAttribute(true)]
[DescriptionAttribute("Enables/disables antialiasing when resizing the image to the view.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public: __property bool get_Antialias();
public: __property void set_Antialias(
   bool value
);
[C++/CLI]
[BrowsableAttribute(true)]
[DescriptionAttribute("Enables/disables antialiasing when resizing the image to the view.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public:
property bool Antialias {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true if antialias is enabled. Otherwise, false is returned.

Remarks

The default value is true.

When the logical size of an image is reduced to less than the actual size of the image, then some of that image's pixels get lost. When antialias is set to true, all of the pixels that would occupy the same area are averaged together turning them into a level of gray for black and white images. For color images, all of the pixels are averaged. This prevents fine lines from being lost, and allows a full page of printed text to be read clearly.

Note: Changing this property does not permanently affect the image loaded in memory.

See Also

ImageXView Class | ImageXView Members


AspectX Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AspectX Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : AspectX Property

Gets and sets the horizontal aspect ratio of the current image.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property AspectX As Integer
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public int AspectX {get; set;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property int get_AspectX();
public: __property void set_AspectX(
   int value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property int AspectX {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the horizontal aspect ratio of the image.

Remarks

The default value is 1.

The aspect ratio defines how many horizontal pixels are equal in size to a certain number of vertical pixels. Changing the aspect ratio of the image will change the appearance.

This function is useful when you are viewing a fax document in which the aspect ratio was incorrectly encoded. For example low-resolution fax images are scanned in at 200 horizontal and 100 dpi vertical. But the PCX file format does not provide aspect size information, so when the image is displayed, it appears squashed. By doubling the horizontal aspect, the image displays correctly.

Setting these properties defines the shape of each pixel in the display. This changes the aspect ratio of the displayed image, but has no effect on the image itself.

See Also

ImageXView Class | ImageXView Members


AspectY Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AspectY Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : AspectY Property

Gets and sets the vertical aspect ratio of the current image.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property AspectY As Integer
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public int AspectY {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property int get_AspectY();
public: __property void set_AspectY(
   int value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property int AspectY {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the vertical aspect ratio.

Remarks

The default value is 1.

The aspect ratio defines how many horizontal pixels are equal in size to a certain number of vertical pixels. Changing the aspect ratio of an image changes the image's appearance.

This function is useful when you are viewing a fax document, where the aspect ratio is incorrectly encoded. For example, low-resolution faxes scan in at 200 dpi horizontal pixels to vertical ones is 2:1. Increasing he vertical aspect lowers the ratio and improves the fax appearance. The PCX file format does not provide aspect size information, so when the image displays, it appears squashed. By doubling the vertical aspect, the image displays correctly.

See Also

ImageXView Class | ImageXView Members


AutoImageDispose Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AutoImageDispose Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : AutoImageDispose Property

Gets and sets enabling the ImageXView's Dispose method to automatically call the ImageX's Dispose method.

[Visual Basic]
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<DescriptionAttribute("Enables or disables Dispose calling the current Image's Dispose method")>
<DesignerSerializationVisibilityAttribute()>
Public Property AutoImageDispose As Boolean
[C#]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Enables or disables Dispose calling the current Image's Dispose method")]
[DesignerSerializationVisibilityAttribute()]
public bool AutoImageDispose {get; set;}
[C++]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Enables or disables Dispose calling the current Image's Dispose method")]
[DesignerSerializationVisibilityAttribute()]
public: __property bool get_AutoImageDispose();
public: __property void set_AutoImageDispose(
   bool value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Enables or disables Dispose calling the current Image's Dispose method")]
[DesignerSerializationVisibilityAttribute()]
public:
property bool AutoImageDispose {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to turn on auto image dispose. Otherwise, false is used.

Remarks

The default value is false.

Because the default value is false, it is the programmer's responsiblity to call the Dispose method for the ImageX object after the ImageXView's Dispose method is called. Set this property to true if you would like ImageX's object connected to the ImageXView to be disposed of automatically when the ImageXView is disposed.

This is useful if you tend to tie one and only one image to a view.

See Also

ImageXView Class | ImageXView Members


AutoResize Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AutoResize Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : AutoResize Property

Gets and sets how the image is sized and positioned for display when painted.

[Visual Basic]
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("Determines the method of viewing/sizing of the image to the control.")>
Public Property AutoResize As AutoResizeType
[C#]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Determines the method of viewing/sizing of the image to the control.")]
public AutoResizeType AutoResize {get; set;}
[C++]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Determines the method of viewing/sizing of the image to the control.")]
public: __property AutoResizeType get_AutoResize();
public: __property void set_AutoResize(
   AutoResizeType value
);
[C++/CLI]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Determines the method of viewing/sizing of the image to the control.")]
public:
property AutoResizeType AutoResize {
   AutoResizeType get();
   void set (AutoResizeType value);
}

Return Type

The AutoResizeType set.

Remarks

The default value is AutoResizeType.CropImage (5).

See the maximum and minimum for the range of dimensions that the control can be resized to when AutoSize specifies that the control should be resized to fit the image.

Note: AutoResize changes how the image is displayed. The image itself is not modified. To modify the image, see the Processor.Resize(Size,ResizeType) method. If the AutoResize property is set to BestFit, FitWidth, FitHeight or ResizeImage, then the ZoomFactor property becomes read-only.

See Also

ImageXView Class | ImageXView Members


BackColor Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

BackColor Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : BackColor Property

Sets the background color of the view window.

[Visual Basic]
Overrides Public WriteOnly Property BackColor As Color
[C#]
public override Color BackColor {set;}
[C++]
public: __property void set_BackColor(
   Color value
)override ;
[C++/CLI]
public:
property Color BackColor override {
   void set (Color value);
}

Return Type

A Color value which represents the background color.

See Also

ImageXView Class | ImageXView Members


BorderStyle Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

BorderStyle Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : BorderStyle Property

Gets and sets the border type of the ImageXView object.

[Visual Basic]
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
<DescriptionAttribute("Selects the window border style for the control.")>
<DesignerSerializationVisibilityAttribute()>
Public Property BorderStyle As ImageXViewBorderStyle
[C#]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[DescriptionAttribute("Selects the window border style for the control.")]
[DesignerSerializationVisibilityAttribute()]
public ImageXViewBorderStyle BorderStyle {get; set;}
[C++]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[DescriptionAttribute("Selects the window border style for the control.")]
[DesignerSerializationVisibilityAttribute()]
public: __property ImageXViewBorderStyle get_BorderStyle();
public: __property void set_BorderStyle(
   ImageXViewBorderStyle value
);
[C++/CLI]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[DescriptionAttribute("Selects the window border style for the control.")]
[DesignerSerializationVisibilityAttribute()]
public:
property ImageXViewBorderStyle BorderStyle {
   ImageXViewBorderStyle get();
   void set (ImageXViewBorderStyle value);
}

Return Type

The ImageXViewBorderStyle enumeration value set.

Remarks

The default value is ImageXViewBorderStyle.Fixed3D.

See Also

ImageXView Class | ImageXView Members


BorderType Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

BorderType Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : BorderType Property (ImageXView)

Gets and sets the border type of the ImageXView object.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<ObsoleteAttribute()>
<DescriptionAttribute("Selects the window border type for the control.")>
<DefaultValueAttribute()>
Public Property BorderType As BorderType
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[ObsoleteAttribute()]
[DescriptionAttribute("Selects the window border type for the control.")]
[DefaultValueAttribute()]
public BorderType BorderType {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[ObsoleteAttribute()]
[DescriptionAttribute("Selects the window border type for the control.")]
[DefaultValueAttribute()]
public: __property BorderType get_BorderType();
public: __property void set_BorderType(
   BorderType value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[ObsoleteAttribute()]
[DescriptionAttribute("Selects the window border type for the control.")]
[DefaultValueAttribute()]
public:
property BorderType BorderType {
   BorderType get();
   void set (BorderType value);
}

Return Type

The BorderType enumeration value set.

Remarks

The default value is BorderType.Inset.

See Also

ImageXView Class | ImageXView Members


Brightness Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Brightness Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : Brightness Property (ImageXView)

Gets and sets the change of brightness of the current image.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property Brightness As Integer
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public int Brightness {get; set;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property int get_Brightness();
public: __property void set_Brightness(
   int value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property int Brightness {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the brightness of the image.

Remarks

The default value is 0.

Higher brightness values result in brighter images. Negative values darken images. This allows the user to adjust the brightness of the displayed image.

See Also

ImageXView Class | ImageXView Members


ClipRectangle Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ClipRectangle Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : ClipRectangle Property

Gets and sets the rectangular portion of the image that is accessible to the viewer.

[Visual Basic]
<DescriptionAttribute("Selects the clipping rectangle for the image.")>
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
Public Property ClipRectangle As Rectangle
[C#]
[DescriptionAttribute("Selects the clipping rectangle for the image.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public Rectangle ClipRectangle {get; set;}
[C++]
[DescriptionAttribute("Selects the clipping rectangle for the image.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public: __property Rectangle get_ClipRectangle();
public: __property void set_ClipRectangle(
   Rectangle value
);
[C++/CLI]
[DescriptionAttribute("Selects the clipping rectangle for the image.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public:
property Rectangle ClipRectangle {
   Rectangle get();
   void set (Rectangle value);
}

Return Type

A Rectangle area set.

Remarks

The default value is 0,0,0,0.

If the ClipRectangle is smaller than the image, then the viewed image is cropped to the dimensions specified by this property. This cropped image is then available in the viewer to be zoomed, scrolled, ect.

Note: There is no impact to the ImageX object - the image remains unchanged. Only the displayed image is cropped.

See Also

ImageXView Class | ImageXView Members


ColorRenderIntent Property

ImageXView Class | ImageXView Members | RenderIntent Enumeration

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ColorRenderIntent Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : ColorRenderIntent Property (ImageXView)

Gets and sets how the color profiles should be applied.

[Visual Basic]
<DescriptionAttribute("This property specifies how the color profiles should be applied.")>
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property ColorRenderIntent As RenderIntent
[C#]
[DescriptionAttribute("This property specifies how the color profiles should be applied.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public RenderIntent ColorRenderIntent {get; set;}
[C++]
[DescriptionAttribute("This property specifies how the color profiles should be applied.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property RenderIntent get_ColorRenderIntent();
public: __property void set_ColorRenderIntent(
   RenderIntent value
);
[C++/CLI]
[DescriptionAttribute("This property specifies how the color profiles should be applied.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property RenderIntent ColorRenderIntent {
   RenderIntent get();
   void set (RenderIntent value);
}

Return Type

A RenderIntent enumeration value.

Remarks

The default value is RenderIntent.Images.

See Also

ImageXView Class | ImageXView Members | RenderIntent Enumeration


Contrast Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Contrast Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : Contrast Property (ImageXView)

Gets and sets the change of contrast level for the displayed image.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property Contrast As Integer
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public int Contrast {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property int get_Contrast();
public: __property void set_Contrast(
   int value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property int Contrast {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the contrast level.

Remarks

The default value is 0.

Valid values are -100 to 100.

Higher values result in images with higher contrast.

This property allows adjustment of the contrast for the displayed image.

See Also

ImageXView Class | ImageXView Members


CursorPosition Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CursorPosition Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : CursorPosition Property

Gets the coordinates of the cursor position in the view window.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property CursorPosition As Point
[C#]
[BrowsableAttribute(false)]
public Point CursorPosition {get;}
[C++]
[BrowsableAttribute(false)]
public: __property Point get_CursorPosition();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property Point CursorPosition {
   Point get();
}

Return Type

A Point value which represents the cursor position in the view window.

See Also

ImageXView Class | ImageXView Members


DisplayMode Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DisplayMode Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : DisplayMode Property (ImageXView)

Returns or sets a value indicating the maximum color depth used to render an image.

[Visual Basic]
<DescriptionAttribute("Returns or sets a value indicating the maximum color depth used to render an image.")>
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
Public Property DisplayMode As DisplayMode
[C#]
[DescriptionAttribute("Returns or sets a value indicating the maximum color depth used to render an image.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public DisplayMode DisplayMode {get; set;}
[C++]
[DescriptionAttribute("Returns or sets a value indicating the maximum color depth used to render an image.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public: __property DisplayMode get_DisplayMode();
public: __property void set_DisplayMode(
   DisplayMode value
);
[C++/CLI]
[DescriptionAttribute("Returns or sets a value indicating the maximum color depth used to render an image.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public:
property DisplayMode DisplayMode {
   DisplayMode get();
   void set (DisplayMode value);
}

Return Type

An DisplayMode enumeration value which represents the maximum color depth used to render the image.

See Also

ImageXView Class | ImageXView Members


Dithered Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Dithered Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : Dithered Property

Gets and sets a dithered indicator on the current image.

[Visual Basic]
<DescriptionAttribute("Enables/disables dithering an the display image.")>
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
Public Property Dithered As Boolean
[C#]
[DescriptionAttribute("Enables/disables dithering an the display image.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public bool Dithered {get; set;}
[C++]
[DescriptionAttribute("Enables/disables dithering an the display image.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public: __property bool get_Dithered();
public: __property void set_Dithered(
   bool value
);
[C++/CLI]
[DescriptionAttribute("Enables/disables dithering an the display image.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public:
property bool Dithered {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true if the current image is dithered. Otherwise, false is returned.

Remarks

The default value is true.

See Also

ImageXView Class | ImageXView Members


GrayMode Property

ImageXView Class | ImageXView Members | GrayMode Enumeration

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GrayMode Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : GrayMode Property (ImageXView)

Gets and sets the mode of gray used to display a grayscale image.

[Visual Basic]
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("The high grayscale transformation method.")>
<DesignerSerializationVisibilityAttribute()>
Public Property GrayMode As GrayMode
[C#]
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("The high grayscale transformation method.")]
[DesignerSerializationVisibilityAttribute()]
public GrayMode GrayMode {get; set;}
[C++]
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("The high grayscale transformation method.")]
[DesignerSerializationVisibilityAttribute()]
public: __property GrayMode get_GrayMode();
public: __property void set_GrayMode(
   GrayMode value
);
[C++/CLI]
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("The high grayscale transformation method.")]
[DesignerSerializationVisibilityAttribute()]
public:
property GrayMode GrayMode {
   GrayMode get();
   void set (GrayMode value);
}

Return Type

A GrayMode enumeration value.

Remarks

The default value is GrayMode.Standard.

See Also

ImageXView Class | ImageXView Members | GrayMode Enumeration


IcmEnabled Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

IcmEnabled Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : IcmEnabled Property

Gets and sets an enabled indicator for the color management.

[Visual Basic]
<DescriptionAttribute("This is the property that enables/disables color management.")>
<DefaultValueAttribute()>
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property IcmEnabled As Boolean
[C#]
[DescriptionAttribute("This is the property that enables/disables color management.")]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public bool IcmEnabled {get; set;}
[C++]
[DescriptionAttribute("This is the property that enables/disables color management.")]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property bool get_IcmEnabled();
public: __property void set_IcmEnabled(
   bool value
);
[C++/CLI]
[DescriptionAttribute("This is the property that enables/disables color management.")]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property bool IcmEnabled {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to enable color management. Otherwise, false is used.

Remarks

The default value is false.

No other ICM operation will take place until this property has been set to true.

See Also

ImageXView Class | ImageXView Members


IcmProofingEnabled Property

ImageXView Class | ImageXView Members | IcmEnabled Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

IcmProofingEnabled Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : IcmProofingEnabled Property

Gets and sets an enabled indicator of the ICM target proofing.

[Visual Basic]
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<DescriptionAttribute("This property enables/disables ICM target proofing.")>
<DesignerSerializationVisibilityAttribute()>
Public Property IcmProofingEnabled As Boolean
[C#]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("This property enables/disables ICM target proofing.")]
[DesignerSerializationVisibilityAttribute()]
public bool IcmProofingEnabled {get; set;}
[C++]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("This property enables/disables ICM target proofing.")]
[DesignerSerializationVisibilityAttribute()]
public: __property bool get_IcmProofingEnabled();
public: __property void set_IcmProofingEnabled(
   bool value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("This property enables/disables ICM target proofing.")]
[DesignerSerializationVisibilityAttribute()]
public:
property bool IcmProofingEnabled {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to enable ICM target proofing.

Remarks

This property has no immediate affect unless the IcmEnabled property is also set to true.

See Also

ImageXView Class | ImageXView Members | IcmEnabled Property


Image Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Image Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : Image Property (ImageXView)

Gets and sets the current image view.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property Image As ImageX
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public ImageX Image {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property ImageX* get_Image();
public: __property void set_Image(
   ImageX* value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property ImageX^ Image {
   ImageX^ get();
   void set (ImageX^ value);
}

Return Type

An ImageX object.

See Also

ImageXView Class | ImageXView Members


ImageCursorPosition Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageCursorPosition Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : ImageCursorPosition Property

Gets the point at which the cursor is located within the image, in pixels.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property ImageCursorPosition As Point
[C#]
[BrowsableAttribute(false)]
public Point ImageCursorPosition {get;}
[C++]
[BrowsableAttribute(false)]
public: __property Point get_ImageCursorPosition();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property Point ImageCursorPosition {
   Point get();
}

Return Type

A Point value which represents the cursor current location within the image.

See Also

ImageXView Class | ImageXView Members


Maximum Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Maximum Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : Maximum Property

Gets and sets the maximum dimensions the viewer control can obtain.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
<DescriptionAttribute("The maximum bounding size of the control.")>
<BrowsableAttribute(True)>
Public Property Maximum As Size
[C#]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("The maximum bounding size of the control.")]
[BrowsableAttribute(true)]
public Size Maximum {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("The maximum bounding size of the control.")]
[BrowsableAttribute(true)]
public: __property Size get_Maximum();
public: __property void set_Maximum(
   Size value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("The maximum bounding size of the control.")]
[BrowsableAttribute(true)]
public:
property Size Maximum {
   Size get();
   void set (Size value);
}

Return Type

The Size which represents the maximum the viewer control can obtain.

Remarks

The default value is 0,0.

See Also

ImageXView Class | ImageXView Members


Medical Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Medical Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : Medical Property (ImageXView)

Gets and sets information required to display medical images.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property Medical As Medical
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public Medical Medical {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property Medical* get_Medical();
public: __property void set_Medical(
   Medical* value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property Medical^ Medical {
   Medical^ get();
   void set (Medical^ value);
}

Return Type

A Medical object.

See Also

ImageXView Class | ImageXView Members


Minimum Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Minimum Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : Minimum Property

Gets and sets the minimum dimensions the viewer control can obtain.

[Visual Basic]
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
<DescriptionAttribute("The minimum bounding size of the control.")>
<DesignerSerializationVisibilityAttribute()>
Public Property Minimum As Size
[C#]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[DescriptionAttribute("The minimum bounding size of the control.")]
[DesignerSerializationVisibilityAttribute()]
public Size Minimum {get; set;}
[C++]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[DescriptionAttribute("The minimum bounding size of the control.")]
[DesignerSerializationVisibilityAttribute()]
public: __property Size get_Minimum();
public: __property void set_Minimum(
   Size value
);
[C++/CLI]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[DescriptionAttribute("The minimum bounding size of the control.")]
[DesignerSerializationVisibilityAttribute()]
public:
property Size Minimum {
   Size get();
   void set (Size value);
}

Return Type

A Size value which is the minimum the viewer control can obtain.

Remarks

The default value is 1.

See Also

ImageXView Class | ImageXView Members


MonitorProfileName Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

MonitorProfileName Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : MonitorProfileName Property

Gets and sets the monitor’s color management profile.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
<DescriptionAttribute("This property supplies the monitor’s profile filename.")>
<BrowsableAttribute(False)>
Public Property MonitorProfileName As String
[C#]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("This property supplies the monitor’s profile filename.")]
[BrowsableAttribute(false)]
public string MonitorProfileName {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("This property supplies the monitor’s profile filename.")]
[BrowsableAttribute(false)]
public: __property string* get_MonitorProfileName();
public: __property void set_MonitorProfileName(
   string* value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("This property supplies the monitor’s profile filename.")]
[BrowsableAttribute(false)]
public:
property String^ MonitorProfileName {
   String^ get();
   void set (String^ value);
}

Return Type

A string value which represents the color profile.

Remarks

The default value is an empty string "".

See Also

ImageXView Class | ImageXView Members


MouseWheelCapture Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

MouseWheelCapture Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : MouseWheelCapture Property

Gets and sets capturing the mousewheel even when the control does not have focus.

[Visual Basic]
Public Property MouseWheelCapture As Boolean
[C#]
public bool MouseWheelCapture {get; set;}
[C++]
public: __property bool get_MouseWheelCapture();
public: __property void set_MouseWheelCapture(
   bool value
);
[C++/CLI]
public:
property bool MouseWheelCapture {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to capture the mousewheel. Otherwise, false should be used.

Remarks

The default value is false.

See Also

ImageXView Class | ImageXView Members


PaletteFilename Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PaletteFilename Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : PaletteFilename Property

Specifies the filename that contains the palette for the control.

[Visual Basic]
<DescriptionAttribute("Specifies the filename that contains the palette for the control.")>
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
Public Property PaletteFilename As String
[C#]
[DescriptionAttribute("Specifies the filename that contains the palette for the control.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public string PaletteFilename {get; set;}
[C++]
[DescriptionAttribute("Specifies the filename that contains the palette for the control.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public: __property string* get_PaletteFilename();
public: __property void set_PaletteFilename(
   string* value
);
[C++/CLI]
[DescriptionAttribute("Specifies the filename that contains the palette for the control.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public:
property String^ PaletteFilename {
   String^ get();
   void set (String^ value);
}

Return Type

A string value which represents the filename.

Remarks

Note: Palette file formats can be DIB, BMP, or PAL files.

When the ImageXView.PaletteType property is set as PaletteType.PalFile, images will be displayed during palettized display using the palette loaded from this property.

See Also

ImageXView Class | ImageXView Members


PaletteType Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PaletteType Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : PaletteType Property (ImageXView)

Gets and sets the image display palette type.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property PaletteType As PaletteType
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public PaletteType PaletteType {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property PaletteType get_PaletteType();
public: __property void set_PaletteType(
   PaletteType value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property PaletteType PaletteType {
   PaletteType get();
   void set (PaletteType value);
}

Remarks

This property setting will only be valid if the current image is displayed using a palette.

When the Image has a bit depth of 8 bits or less, the image's palette will be realized by the display device. In other words, the image's palette is combined with the display device's logical palette and used to display the image.

You can specify a different behavior by modifying this property. Setting this property does not change the palette stored with the Image, but does change the palette that is realized by the display device.

  • If the PaletteType is set to null, then use the image's palette when displaying.
  • If the PaletteType is set to UserDefined, then use the GetPaletteColor and SetPaletteColor methods to define and access a user-defined palette.
  • If the PaletteType is set to PalFile, then use the PaletteFilename property to get and set the source for the palette.
  • If the PaletteType is set to Gray, a fixed gray palette is used.
  • If the PaletteType is set to Fixed, then an ImageXView internally defined palette is used.
  • If the PaletteType is set to Optimized, then the image is analyzed, and the best palette is used.

See Also

ImageXView Class | ImageXView Members


PixelColor Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PixelColor Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : PixelColor Property

Gets the color of the pixel within the client area of the view control at which the cursor is currently positioned.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property PixelColor As Color
[C#]
[BrowsableAttribute(false)]
public Color PixelColor {get;}
[C++]
[BrowsableAttribute(false)]
public: __property Color get_PixelColor();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property Color PixelColor {
   Color get();
}

Return Type

A Color value which represents the color of the pixel within the client area of the view control.

See Also

ImageXView Class | ImageXView Members


PreserveBlack Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PreserveBlack Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : PreserveBlack Property (ImageXView)

Gets and sets an indicator if black should be preserved and applied when viewing the image.

[Visual Basic]
<DescriptionAttribute("Enables/disables preserving black pixels when resizing a black and white image to the view.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
Public Property PreserveBlack As Boolean
[C#]
[DescriptionAttribute("Enables/disables preserving black pixels when resizing a black and white image to the view.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public bool PreserveBlack {get; set;}
[C++]
[DescriptionAttribute("Enables/disables preserving black pixels when resizing a black and white image to the view.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public: __property bool get_PreserveBlack();
public: __property void set_PreserveBlack(
   bool value
);
[C++/CLI]
[DescriptionAttribute("Enables/disables preserving black pixels when resizing a black and white image to the view.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public:
property bool PreserveBlack {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true for black objects (such as lines) to be enhanced to increase readability. Otherwise, false is returned and no enhancement of black objects is applied.

Remarks

The default value is false.

This property is useful to maintain readability of images when the display size is very small and zoom is applied where dark pixels can be subsampled away.

Note: This property does not modify the image in memory.

See Also

ImageXView Class | ImageXView Members


PrinterProfileName Property

ImageXView Class | ImageXView Members | TargetProfileName Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PrinterProfileName Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : PrinterProfileName Property

Gets and sets the printer’s profile filename.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("This property supplies the printer’s profile filename.")>
<DefaultValueAttribute()>
Public Property PrinterProfileName As String
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("This property supplies the printer’s profile filename.")]
[DefaultValueAttribute()]
public string PrinterProfileName {get; set;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("This property supplies the printer’s profile filename.")]
[DefaultValueAttribute()]
public: __property string* get_PrinterProfileName();
public: __property void set_PrinterProfileName(
   string* value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("This property supplies the printer’s profile filename.")]
[DefaultValueAttribute()]
public:
property String^ PrinterProfileName {
   String^ get();
   void set (String^ value);
}

Return Type

A string value which represents the printer's profile filename.

Remarks

The default value is an empty string "".

This property is overwriten by the TargetProfileName property in rendering the image with the intent that the caller desires proofing against a particular printer/ink that is different from his selected printer.

See Also

ImageXView Class | ImageXView Members | TargetProfileName Property


Progressive Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Progressive Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : Progressive Property (ImageXView)

Gets and sets an indication if images are displayed progressively.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<DescriptionAttribute("Enables/disables viewing an image progressively.")>
<DefaultValueAttribute()>
Public Property Progressive As Boolean
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Enables/disables viewing an image progressively.")]
[DefaultValueAttribute()]
public bool Progressive {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Enables/disables viewing an image progressively.")]
[DefaultValueAttribute()]
public: __property bool get_Progressive();
public: __property void set_Progressive(
   bool value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Enables/disables viewing an image progressively.")]
[DefaultValueAttribute()]
public:
property bool Progressive {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true when the image is displayed progressively. Otherwise, false is returned.

Remarks

The default value is false.

Progressive viewing can be useful if loading is expected to take a long time (e.g. remote loading of a large, highly compressed file).

See Also

ImageXView Class | ImageXView Members


Rubberband Property

ImageXView Class | ImageXView Members | Rubberband Class

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Rubberband Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : Rubberband Property (ImageXView)

Gets the current Rubberband object.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property Rubberband As Rubberband
[C#]
[BrowsableAttribute(false)]
public Rubberband Rubberband {get;}
[C++]
[BrowsableAttribute(false)]
public: __property Rubberband* get_Rubberband();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property Rubberband^ Rubberband {
   Rubberband^ get();
}

Return Type

The Rubberband object set.

See Also

ImageXView Class | ImageXView Members | Rubberband Class


ScrollBars Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ScrollBars Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : ScrollBars Property

Gets or sets the type of scroll bars to display in the ImagXView control.

[Visual Basic]
<DescriptionAttribute("Defines the behavior of the scroll bars of the control.")>
<DefaultValueAttribute()>
Public Property ScrollBars As ScrollBars
[C#]
[DescriptionAttribute("Defines the behavior of the scroll bars of the control.")]
[DefaultValueAttribute()]
public ScrollBars ScrollBars {get; set;}
[C++]
[DescriptionAttribute("Defines the behavior of the scroll bars of the control.")]
[DefaultValueAttribute()]
public: __property ScrollBars get_ScrollBars();
public: __property void set_ScrollBars(
   ScrollBars value
);
[C++/CLI]
[DescriptionAttribute("Defines the behavior of the scroll bars of the control.")]
[DefaultValueAttribute()]
public:
property ScrollBars ScrollBars {
   ScrollBars get();
   void set (ScrollBars value);
}

Return Type

One of the ScrollBars values. The default is ScrollBars.Both.

Remarks

This property enables you to provide horizontal and vertical scroll bars to the user of the ImageXView control to enable scrolling the image within the control that is outside of the physical dimensions of the control. You can also use this property to remove scroll bars from the control to restrict scrolling the contents of the control.

Note: Scroll bars will not be shown at all if the ImageXView.AutoResize property is set to AutoResizeType.BestFit, regardless of the ScrollBars property. Horizontal scroll bars will not be shown if the ImageXView.AutoResize property is set to AutoResizeType.FitWidth. Vertical scroll bars will not be shown if the ImageXView.AutoResize property is set to AutoResizeType.FitHeight.

See Also

ImageXView Class | ImageXView Members


ScrollPosition Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ScrollPosition Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : ScrollPosition Property

Gets and sets the current scrolling position of the cursor on the scrollbar.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("Property that determines whether updates allow the control to be repainted.")>
<BrowsableAttribute(False)>
Public Property ScrollPosition As Point
[C#]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Property that determines whether updates allow the control to be repainted.")]
[BrowsableAttribute(false)]
public Point ScrollPosition {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Property that determines whether updates allow the control to be repainted.")]
[BrowsableAttribute(false)]
public: __property Point get_ScrollPosition();
public: __property void set_ScrollPosition(
   Point value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Property that determines whether updates allow the control to be repainted.")]
[BrowsableAttribute(false)]
public:
property Point ScrollPosition {
   Point get();
   void set (Point value);
}

Return Type

A Point value which represents the scrolling position of the cursor on the scrollbar.

See Also

ImageXView Class | ImageXView Members


Smoothing Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Smoothing Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : Smoothing Property

Gets and sets an indicator for the smoothing effect on the current image.

[Visual Basic]
<DescriptionAttribute("Enables/disables the smoothing effect for the display image.")>
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
Public Property Smoothing As Boolean
[C#]
[DescriptionAttribute("Enables/disables the smoothing effect for the display image.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public bool Smoothing {get; set;}
[C++]
[DescriptionAttribute("Enables/disables the smoothing effect for the display image.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public: __property bool get_Smoothing();
public: __property void set_Smoothing(
   bool value
);
[C++/CLI]
[DescriptionAttribute("Enables/disables the smoothing effect for the display image.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public:
property bool Smoothing {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true when the smoothing effect is on the current image. Otherwise, false is returned.

Remarks

The default value is true.

When the logical size of an image is increased to more than the actual size of the image, the image starts to look boxy. When Smoothing is enabled, ImagXpress performs an algorithm that smoothes out the square edges.

This property affects how the image is displayed, but does not modify the image in memory.

See Also

ImageXView Class | ImageXView Members


Sprite Property

ImageXView Class | ImageXView Members | Sprite Class

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Sprite Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : Sprite Property (ImageXView)

Gets the Sprite object.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property Sprite As Sprite
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public Sprite Sprite {get;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property Sprite* get_Sprite();
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property Sprite^ Sprite {
   Sprite^ get();
}

Return Type

The Sprite object set.

See Also

ImageXView Class | ImageXView Members | Sprite Class


TargetProfileName Property

ImageXView Class | ImageXView Members | PrinterProfileName Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

TargetProfileName Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : TargetProfileName Property (ImageXView)

Gets and sets the target profile’s filename.

[Visual Basic]
<DescriptionAttribute("This property supplies the target profile’s filename.")>
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property TargetProfileName As String
[C#]
[DescriptionAttribute("This property supplies the target profile’s filename.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public string TargetProfileName {get; set;}
[C++]
[DescriptionAttribute("This property supplies the target profile’s filename.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property string* get_TargetProfileName();
public: __property void set_TargetProfileName(
   string* value
);
[C++/CLI]
[DescriptionAttribute("This property supplies the target profile’s filename.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property String^ TargetProfileName {
   String^ get();
   void set (String^ value);
}

Return Type

A string value which represents the target profile's filename.

Remarks

This property overrides the PrinterProfileName property in rendering the image with the intent that the caller desires proofing against a particular printer/ink that is different from his selected printer.

See Also

ImageXView Class | ImageXView Members | PrinterProfileName Property


ToolActive Property

ImageXView Class | ImageXView Members | Tool Enumeration

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolActive Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : ToolActive Property

Gets the currently active tool.

[Visual Basic]
<BrowsableAttribute(False)>
<DescriptionAttribute("Retrieves the currently active tool.")>
Public ReadOnly Property ToolActive As Tool
[C#]
[BrowsableAttribute(false)]
[DescriptionAttribute("Retrieves the currently active tool.")]
public Tool ToolActive {get;}
[C++]
[BrowsableAttribute(false)]
[DescriptionAttribute("Retrieves the currently active tool.")]
public: __property Tool get_ToolActive();
[C++/CLI]
[BrowsableAttribute(false)]
[DescriptionAttribute("Retrieves the currently active tool.")]
public:
property Tool ToolActive {
   Tool get();
}

Return Type

The Tool enumeration value set.

Remarks

The default value is Tool.None.

See Also

ImageXView Class | ImageXView Members | Tool Enumeration


Toolbar Property

ImageXView Class | ImageXView Members | Toolbar Class

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Toolbar Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : Toolbar Property (ImageXView)

Gets the current Toolbar object.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property Toolbar As Toolbar
[C#]
[BrowsableAttribute(false)]
public Toolbar Toolbar {get;}
[C++]
[BrowsableAttribute(false)]
public: __property Toolbar* get_Toolbar();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property Toolbar^ Toolbar {
   Toolbar^ get();
}

Return Type

The Toolbar object set.

See Also

ImageXView Class | ImageXView Members | Toolbar Class


ZoomFactor Property

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ZoomFactor Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : ZoomFactor Property (ImageXView)

Gets and sets the zoom factor display for the current image.

[Visual Basic]
<DescriptionAttribute("The zooming factor for the image to be displayed at.")>
<BrowsableAttribute(True)>
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
Public Property ZoomFactor As Double
[C#]
[DescriptionAttribute("The zooming factor for the image to be displayed at.")]
[BrowsableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public double ZoomFactor {get; set;}
[C++]
[DescriptionAttribute("The zooming factor for the image to be displayed at.")]
[BrowsableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public: __property double get_ZoomFactor();
public: __property void set_ZoomFactor(
   double value
);
[C++/CLI]
[DescriptionAttribute("The zooming factor for the image to be displayed at.")]
[BrowsableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public:
property double ZoomFactor {
   double get();
   void set (double value);
}

Return Type

A double value which represents the zoom for the display of the image.

Remarks

The default value is 1.

Values greater than 1 result in the display image being enlarged. For example, a ZoomFactor = 2 doubles the display image height and width.

Values less than 1 result in the display image being reduced. For example, a ZoomFactor = .5 reduces the display image height and width by 50.

Anything past the thousandth place (.001) is ignored.

Zooming has no affect on the stored image, the aspect ratio of the displayed image, or the aspect ratio of the image's pixels.

Note: If the ImageXView.AutoResize property is set to BestFit, FitWidth, FitHeight or ResizeImage, then the ZoomFactor property is read-only.

See Also

ImageXView Class | ImageXView Members


ImageXView Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXView Class Events

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXView Class

For a list of all members of this type, see ImageXView members.

Public Events

Public Event AutoResizeChanged | Thrown when the AutoResize property changes.
Public Event AutoSizeChanged (Inherited from System.Windows.Forms.UserControl) |
Public Event AutoValidateChanged (Inherited from System.Windows.Forms.UserControl) | Occurs when the AutoValidate property changes.
Public Event BackColorChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the BackColor property changes.
Public Event BackgroundImageChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the BackgroundImage property changes.
Public Event BackgroundImageLayoutChanged (Inherited from System.Windows.Forms.Control) | Occurs when the BackgroundImageLayout property changes.
Public Event BindingContextChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the BindingContext property changes.
Public Event CausesValidationChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the CausesValidation property changes.
Public Event ChangeUICues (Inherited from System.Windows.Forms.Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Public Event Click (Inherited from System.Windows.Forms.Control) | Occurs when the control is clicked.
Public Event ClientSizeChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the ClientSize property changes.
Public Event ContextMenuChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the ContextMenu property changes.
Public Event ContextMenuStripChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the ContextMenuStrip property changes.
Public Event ControlAdded (Inherited from System.Windows.Forms.Control) | Occurs when a new control is added to the ControlCollection.
Public Event ControlRemoved (Inherited from System.Windows.Forms.Control) | Occurs when a control is removed from the ControlCollection.
Public Event CursorChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the Cursor property changes.
Public Event Disposed (Inherited from System.ComponentModel.Component) | Adds an event handler to listen to the Disposed event on the component.
Public Event DockChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the Dock property changes.
Public Event DoubleClick (Inherited from System.Windows.Forms.Control) | Occurs when the control is double-clicked.
Public Event DragDrop (Inherited from System.Windows.Forms.Control) | Occurs when a drag-and-drop operation is completed.
Public Event DragEnter (Inherited from System.Windows.Forms.Control) | Occurs when an object is dragged into the control's bounds.
Public Event DragLeave (Inherited from System.Windows.Forms.Control) | Occurs when an object is dragged out of the control's bounds.
Public Event DragOver (Inherited from System.Windows.Forms.Control) | Occurs when an object is dragged over the control's bounds.
Public Event EnabledChanged (Inherited from System.Windows.Forms.Control) | Occurs when the Enabled property value has changed.
Public Event Enter (Inherited from System.Windows.Forms.Control) | Occurs when the control is entered.
Public Event FontChanged (Inherited from System.Windows.Forms.Control) | Occurs when the Font property value changes.
Public Event ForeColorChanged (Inherited from System.Windows.Forms.Control) | Occurs when the ForeColor property value changes.
Public Event GiveFeedback (Inherited from System.Windows.Forms.Control) | Occurs during a drag operation.
Public Event GotFocus (Inherited from System.Windows.Forms.Control) | Occurs when the control receives focus.
Public Event HandleCreated (Inherited from System.Windows.Forms.Control) | Occurs when a handle is created for the control.
Public Event HandleDestroyed (Inherited from System.Windows.Forms.Control) | Occurs when the control's handle is in the process of being destroyed.
Public Event HelpRequested (Inherited from System.Windows.Forms.Control) | Occurs when the user requests help for a control.
Public Event ImeModeChanged (Inherited from System.Windows.Forms.Control) | Occurs when the ImeMode property has changed.
Public Event Invalidated (Inherited from System.Windows.Forms.Control) | Occurs when a control's display requires redrawing.
Public Event KeyDown (Inherited from System.Windows.Forms.Control) | Occurs when a key is pressed while the control has focus.
Public Event KeyPress (Inherited from System.Windows.Forms.Control) | Occurs when a key is pressed while the control has focus.
Public Event KeyUp (Inherited from System.Windows.Forms.Control) | Occurs when a key is released while the control has focus.
Public Event Layout (Inherited from System.Windows.Forms.Control) | Occurs when a control should reposition its child controls.
Public Event Leave (Inherited from System.Windows.Forms.Control) | Occurs when the input focus leaves the control.
Public Event Load (Inherited from System.Windows.Forms.UserControl) | Occurs before the control becomes visible for the first time.
Public Event LocationChanged (Inherited from System.Windows.Forms.Control) | Occurs when the Location property value has changed.
Public Event LostFocus (Inherited from System.Windows.Forms.Control) | Occurs when the control loses focus.
Public Event MarginChanged (Inherited from System.Windows.Forms.Control) | Occurs when the control's margin changes.
Public Event MouseCaptureChanged (Inherited from System.Windows.Forms.Control) | Occurs when the control loses mouse capture.
Public Event MouseClick (Inherited from System.Windows.Forms.Control) | Occurs when the control is clicked by the mouse.
Public Event MouseDoubleClick (Inherited from System.Windows.Forms.Control) | Occurs when the control is double clicked by the mouse.
Public Event MouseDown (Inherited from System.Windows.Forms.Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
Public Event MouseEnter (Inherited from System.Windows.Forms.Control) | Occurs when the mouse pointer enters the control.
Public Event MouseHover (Inherited from System.Windows.Forms.Control) | Occurs when the mouse pointer rests on the control.
Public Event MouseLeave (Inherited from System.Windows.Forms.Control) | Occurs when the mouse pointer leaves the control.
Public Event MouseMove (Inherited from System.Windows.Forms.Control) | Occurs when the mouse pointer is moved over the control.
Public Event MouseUp (Inherited from System.Windows.Forms.Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Public Event MouseWheel (Inherited from System.Windows.Forms.Control) | Occurs when the mouse wheel moves while the control has focus.
Public Event Move (Inherited from System.Windows.Forms.Control) | Occurs when the control is moved.
Public Event PaddingChanged (Inherited from System.Windows.Forms.Control) | Occurs when the control's padding changes.
Public Event Paint (Inherited from System.Windows.Forms.Control) | Occurs when the control is redrawn.
Public Event PaintImage | Thrown when the image is painted onto the screen.
Public Event ParentChanged (Inherited from System.Windows.Forms.Control) | Occurs when the Parent property value changes.
Public Event PreviewKeyDown (Inherited from System.Windows.Forms.Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
Public Event PrintImage | Thrown when the image is printed onto the paper.
Public Event QueryAccessibilityHelp (Inherited from System.Windows.Forms.Control) | Occurs when AccessibleObject is providing help to accessibility applications.
Public Event QueryContinueDrag (Inherited from System.Windows.Forms.Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
Public Event RegionChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the Region property changes.
Public Event Resize (Inherited from System.Windows.Forms.Control) | Occurs when the control is resized.
Public Event Resized | Thrown after the control has been completely resized.
Public Event RightToLeftChanged (Inherited from System.Windows.Forms.Control) | Occurs when the RightToLeft property value changes.
Public Event Scroll (Inherited from System.Windows.Forms.ScrollableControl) | Occurs when the user or code scrolls through the client area.
Public Event ScrollbarVisibleChanged | Thrown when one or more scrollbars changes its visibility.
Public Event ScrollEvent | Thrown during a scroll event.
Public Event SizeChanged (Inherited from System.Windows.Forms.Control) | Occurs when the Size property value changes.
Public Event StyleChanged (Inherited from System.Windows.Forms.Control) | Occurs when the control style changes.
Public Event SystemColorsChanged (Inherited from System.Windows.Forms.Control) | Occurs when the system colors change.
Public Event TabIndexChanged (Inherited from System.Windows.Forms.Control) | Occurs when the TabIndex property value changes.
Public Event TabStopChanged (Inherited from System.Windows.Forms.Control) | Occurs when the TabStop property value changes.
Public Event ToolbarCloseEvent | Thrown when a toolbar close event occurs.
Public Event ToolbarContextMenuSelectEvent | Thrown when the toolbar context menu is selected.
Public Event ToolbarEvent | Thrown when a toolbar event occurs.
Public Event ToolbarOpenEvent | Thrown when a toolbar open event occurs.
Public Event ToolEvent | Thrown when a tool event occurs.
Public Event Validated (Inherited from System.Windows.Forms.Control) | Occurs when the control is finished validating.
Public Event Validating (Inherited from System.Windows.Forms.Control) | Occurs when the control is validating.
Public Event VisibleChanged (Inherited from System.Windows.Forms.Control) | Occurs when the Visible property value changes.
Public Event ZoomFactorChanged | Thrown when the ZoomFactor property changes.

See Also

ImageXView Class | PegasusImaging.WinForms.ImagXpress9 Namespace


AutoResizeChanged Event

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AutoResizeChanged Event

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : AutoResizeChanged Event

Thrown when the AutoResize property changes.

[Visual Basic]
Public Event AutoResizeChanged() As ImageXView.AutoResizeChangedEventHandler
[C#]
public event ImageXView.AutoResizeChangedEventHandler AutoResizeChanged();
[C++]
public: __event ImageXView.AutoResizeChangedEventHandler* AutoResizeChanged();
[C++/CLI]
public:
event ImageXView::AutoResizeChangedEventHandler^ AutoResizeChanged();

Event Data

The event handler receives an argument of type AutoResizeChangedEventArgs containing data related to this event. The following AutoResizeChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the new value for the AutoResize property.
OldValue | Gets the old value for the AutoResize property.

See Also

ImageXView Class | ImageXView Members


PaintImage Event

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PaintImage Event

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : PaintImage Event

Thrown when the image is painted onto the screen.

[Visual Basic]
Public Event PaintImage() As ImageXView.PaintImageEventHandler
[C#]
public event ImageXView.PaintImageEventHandler PaintImage();
[C++]
public: __event ImageXView.PaintImageEventHandler* PaintImage();
[C++/CLI]
public:
event ImageXView::PaintImageEventHandler^ PaintImage();

Event Data

The event handler receives an argument of type PaintImageEventArgs containing data related to this event. The following PaintImageEventArgs properties provide information specific to this event.

Property | Description
Graphics | Gets the Graphics object.
LogicalRectangle | Gets the logical rectangle.
UpdateRectangle | Gets the update rectangle.
ViewRectangle | Gets the view's rectangle.
ZoomFactor | Gets the zoom factor.

See Also

ImageXView Class | ImageXView Members


PrintImage Event

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PrintImage Event

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : PrintImage Event

Thrown when the image is printed onto the paper.

[Visual Basic]
Public Event PrintImage() As ImageXView.PrintImageEventHandler
[C#]
public event ImageXView.PrintImageEventHandler PrintImage();
[C++]
public: __event ImageXView.PrintImageEventHandler* PrintImage();
[C++/CLI]
public:
event ImageXView::PrintImageEventHandler^ PrintImage();

Event Data

The event handler receives an argument of type PrintImageEventArgs containing data related to this event. The following PrintImageEventArgs properties provide information specific to this event.

Property | Description
Graphics | Gets the Graphics object.
GraphicsUnit | Gets the graphics unit.
ImageRectangle | Gets the image's rectangle.
PrintRectangle | Gets the printer's rectangle.
PrintType | Gets the type of the print that was performed.

See Also

ImageXView Class | ImageXView Members


Resized Event

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Resized Event

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : Resized Event

Thrown after the control has been completely resized.

[Visual Basic]
Public Event Resized() As ImageXView.ResizedEventHandler
[C#]
public event ImageXView.ResizedEventHandler Resized();
[C++]
public: __event ImageXView.ResizedEventHandler* Resized();
[C++/CLI]
public:
event ImageXView::ResizedEventHandler^ Resized();

Event Data

The event handler receives an argument of type ResizedEventArgs containing data related to this event. The following ResizedEventArgs properties provide information specific to this event.

Property | Description
NewSize | Gets the new size of the control.

See Also

ImageXView Class | ImageXView Members


ScrollbarVisibleChanged Event

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ScrollbarVisibleChanged Event

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : ScrollbarVisibleChanged Event

Thrown when one or more scrollbars changes its visibility.

[Visual Basic]
Public Event ScrollbarVisibleChanged() As ImageXView.ScrollbarVisibleChangedEventHandler
[C#]
public event ImageXView.ScrollbarVisibleChangedEventHandler ScrollbarVisibleChanged();
[C++]
public: __event ImageXView.ScrollbarVisibleChangedEventHandler* ScrollbarVisibleChanged();
[C++/CLI]
public:
event ImageXView::ScrollbarVisibleChangedEventHandler^ ScrollbarVisibleChanged();

Event Data

The event handler receives an argument of type ScrollbarVisibleChangedEventArgs containing data related to this event. The following ScrollbarVisibleChangedEventArgs properties provide information specific to this event.

Property | Description
ScrollBar | Gets which scrollbar the event pertains to.
Visible | Gets the visibility of the Scrollbar.

See Also

ImageXView Class | ImageXView Members


ScrollEvent Event

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ScrollEvent Event

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : ScrollEvent Event

Thrown during a scroll event.

[Visual Basic]
Public Event ScrollEvent() As ImageXView.ScrollEventHandler
[C#]
public event ImageXView.ScrollEventHandler ScrollEvent();
[C++]
public: __event ImageXView.ScrollEventHandler* ScrollEvent();
[C++/CLI]
public:
event ImageXView::ScrollEventHandler^ ScrollEvent();

Event Data

The event handler receives an argument of type ScrollEventArgs containing data related to this event. The following ScrollEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the new location within the scroll range.
ScrollBar | Gets which scrollbar the event pertains to.
Type | Gets the type of scroll event that occurred.

See Also

ImageXView Class | ImageXView Members


ToolbarCloseEvent Event

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolbarCloseEvent Event

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : ToolbarCloseEvent Event

Thrown when a toolbar close event occurs.

[Visual Basic]
Public Event ToolbarCloseEvent() As ImageXView.ToolbarCloseEventHandler
[C#]
public event ImageXView.ToolbarCloseEventHandler ToolbarCloseEvent();
[C++]
public: __event ImageXView.ToolbarCloseEventHandler* ToolbarCloseEvent();
[C++/CLI]
public:
event ImageXView::ToolbarCloseEventHandler^ ToolbarCloseEvent();

See Also

ImageXView Class | ImageXView Members


ToolbarContextMenuSelectEvent Event

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolbarContextMenuSelectEvent Event

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : ToolbarContextMenuSelectEvent Event

Thrown when the toolbar context menu is selected.

[Visual Basic]
Public Event ToolbarContextMenuSelectEvent() As ImageXView.ToolbarContextMenuSelectEventHandler
[C#]
public event ImageXView.ToolbarContextMenuSelectEventHandler ToolbarContextMenuSelectEvent();
[C++]
public: __event ImageXView.ToolbarContextMenuSelectEventHandler* ToolbarContextMenuSelectEvent();
[C++/CLI]
public:
event ImageXView::ToolbarContextMenuSelectEventHandler^ ToolbarContextMenuSelectEvent();

Event Data

The event handler receives an argument of type ToolbarContextMenuEventArgs containing data related to this event. The following ToolbarContextMenuEventArgs properties provide information specific to this event.

Property | Description
SubMenuId | Gets the sub-level menu ID for this menu item.
Tool | Gets the Tool associated with the context menu that fired the event.
TopMenuId | Gets the top-level menu ID for this menu ID.
User1 | Gets the first of two user-supplied values set when the menu was created.
User2 | Gets the second of two user-supplied values set when the menu was created.

See Also

ImageXView Class | ImageXView Members


ToolbarEvent Event

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolbarEvent Event

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : ToolbarEvent Event

Thrown when a toolbar event occurs.

[Visual Basic]
Public Event ToolbarEvent() As ImageXView.ToolbarEventHandler
[C#]
public event ImageXView.ToolbarEventHandler ToolbarEvent();
[C++]
public: __event ImageXView.ToolbarEventHandler* ToolbarEvent();
[C++/CLI]
public:
event ImageXView::ToolbarEventHandler^ ToolbarEvent();

Event Data

The event handler receives an argument of type ToolbarEventArgs containing data related to this event. The following ToolbarEventArgs properties provide information specific to this event.

Property | Description
Tool | Gets the selected tool.
User1 | Gets the numerical value associated with the Tool.
User2 | Gets the numerical value associated with the Tool.

See Also

ImageXView Class | ImageXView Members


ToolbarOpenEvent Event

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolbarOpenEvent Event

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : ToolbarOpenEvent Event

Thrown when a toolbar open event occurs.

[Visual Basic]
Public Event ToolbarOpenEvent() As ImageXView.ToolbarOpenEventHandler
[C#]
public event ImageXView.ToolbarOpenEventHandler ToolbarOpenEvent();
[C++]
public: __event ImageXView.ToolbarOpenEventHandler* ToolbarOpenEvent();
[C++/CLI]
public:
event ImageXView::ToolbarOpenEventHandler^ ToolbarOpenEvent();

Event Data

The event handler receives an argument of type ToolbarOpenEventArgs containing data related to this event. The following ToolbarOpenEventArgs properties provide information specific to this event.

Property | Description
Handle | Gets the handle of the toolbar.

See Also

ImageXView Class | ImageXView Members


ToolEvent Event

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolEvent Event

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : ToolEvent Event

Thrown when a tool event occurs.

[Visual Basic]
Public Event ToolEvent() As ImageXView.ToolEventHandler
[C#]
public event ImageXView.ToolEventHandler ToolEvent();
[C++]
public: __event ImageXView.ToolEventHandler* ToolEvent();
[C++/CLI]
public:
event ImageXView::ToolEventHandler^ ToolEvent();

Event Data

The event handler receives an argument of type ToolEventArgs containing data related to this event. The following ToolEventArgs properties provide information specific to this event.

Property | Description
Action | Gets the value of the action the tool performed.
Location | Gets the location at which the tool action was performed.
Tool | Gets the tool being used.

See Also

ImageXView Class | ImageXView Members


ZoomFactorChanged Event

ImageXView Class | ImageXView Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ZoomFactorChanged Event

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXView Class : ZoomFactorChanged Event

Thrown when the ZoomFactor property changes.

[Visual Basic]
Public Event ZoomFactorChanged() As ImageXView.ZoomFactorChangedEventHandler
[C#]
public event ImageXView.ZoomFactorChangedEventHandler ZoomFactorChanged();
[C++]
public: __event ImageXView.ZoomFactorChangedEventHandler* ZoomFactorChanged();
[C++/CLI]
public:
event ImageXView::ZoomFactorChangedEventHandler^ ZoomFactorChanged();

Event Data

The event handler receives an argument of type ZoomFactorChangedEventArgs containing data related to this event. The following ZoomFactorChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the new value for the ZoomFactor property
OldValue | Gets the old value for the ZoomFactor property.

See Also

ImageXView Class | ImageXView Members


ImageXViewException Class

ImageXViewException Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXViewException Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXViewException Class

This class implements exceptions for the ImageXView objects.

For a list of all members of this type, see ImageXViewException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.ImagXpress9.ImagXpressException
PegasusImaging.WinForms.ImagXpress9.ImageXViewException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class ImageXViewException
   Inherits ImagXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class ImageXViewException : ImagXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class ImageXViewException : public ImagXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class ImageXViewException sealed : public ImagXpressException, ISerializable, _Exception

See Also

ImageXViewException Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXViewException Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXViewException Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXViewException Class

ImageXViewException overview

Public Constructors

Public Constructor ImageXViewException Constructor Overloaded. The main constructor for ImageXView exceptions.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from ImagXpressException) | Gets the numerical equivalent for enumerated exception result.
Public Property Result (Inherited from ImagXpressException) | Gets the enumerated exception result that has occurred.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ImageXViewException Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXViewException Constructor

ImageXViewException Class | ImageXViewException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXViewException Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXViewException Class : ImageXViewException Constructor (ImageXViewException)

The main constructor for ImageXView exceptions.

Overload List

The main constructor for ImageXView exceptions.

[Visual Basic] Public Sub New()

[C#] public ImageXViewException();

[C++] public ImageXViewException();

[C++/CLI] public ImageXViewException();

Constructor which allows passing in a result for the exception.

[Visual Basic] Public Sub New(Result)

[C#] public ImageXViewException(Result);

[C++] public ImageXViewException(Result);

[C++/CLI] public ImageXViewException(Result);

Constructor which allows passing in a message for the exception.

[Visual Basic] Public Sub New(String)

[C#] public ImageXViewException(string);

[C++] public ImageXViewException(string*);

[C++/CLI] public ImageXViewException(String^);

Constructor which allows passing in a result and message.

[Visual Basic] Public Sub New(Result,String)

[C#] public ImageXViewException(Result,string);

[C++] public ImageXViewException(Result,string*);

[C++/CLI] public ImageXViewException(Result,String^);

Constructor which allows passing in a message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public ImageXViewException(string,Exception);

[C++] public ImageXViewException(string*,Exception*);

[C++/CLI] public ImageXViewException(String^,Exception^);

Constructor which allows passing in a result, message and inner exception.

[Visual Basic] Public Sub New(Result,String,Exception)

[C#] public ImageXViewException(Result,string,Exception);

[C++] public ImageXViewException(Result,string*,Exception*);

[C++/CLI] public ImageXViewException(Result,String^,Exception^);

See Also

ImageXViewException Class | ImageXViewException Members


ImageXViewException Constructor()

ImageXViewException Class | ImageXViewException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXViewException Constructor()

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXViewException Class > ImageXViewException Constructor : ImageXViewException Constructor()

The main constructor for ImageXView exceptions.

[Visual Basic]
Public Function New()
[C#]
public ImageXViewException();
[C++]
public: ImageXViewException();
[C++/CLI]
public:
ImageXViewException();

See Also

ImageXViewException Class | ImageXViewException Members | Overload List


ImageXViewException Constructor(Result)

ImageXViewException Class | ImageXViewException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

result
A Result enumeration value.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXViewException Constructor(Result)

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXViewException Class > ImageXViewException Constructor : ImageXViewException Constructor(Result)

Constructor which allows passing in a result for the exception.

[Visual Basic]
Public Function New( _
   ByVal result As Result _
)
[C#]
public ImageXViewException(
   Result result
);
[C++]
public: ImageXViewException(
   Result result
)
[C++/CLI]
public:
ImageXViewException(
   Result result
)

Parameters

result
A Result enumeration value.

See Also

ImageXViewException Class | ImageXViewException Members | Overload List


ImageXViewException Constructor(Result,String)

ImageXViewException Class | ImageXViewException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

result
A Result enumeration value.
message
A string value which represents the error message.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXViewException Constructor(Result,String)

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXViewException Class > ImageXViewException Constructor : ImageXViewException Constructor(Result,String)

Constructor which allows passing in a result and message.

[Visual Basic]
Public Function New( _
   ByVal result As Result, _
   ByVal message As String _
)
[C#]
public ImageXViewException(
   Result result,
   string message
);
[C++]
public: ImageXViewException(
   Result result,
   string* message
)
[C++/CLI]
public:
ImageXViewException(
   Result result,
   String^ message
)

Parameters

result
A Result enumeration value.
message
A string value which represents the error message.

See Also

ImageXViewException Class | ImageXViewException Members | Overload List


ImageXViewException Constructor(Result,String,Exception)

ImageXViewException Class | ImageXViewException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

result
A Result enumeration value.
message
A string value which represents the error message.
innerException
An Exception.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXViewException Constructor(Result,String,Exception)

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXViewException Class > ImageXViewException Constructor : ImageXViewException Constructor(Result,String,Exception)

Constructor which allows passing in a result, message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal result As Result, _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public ImageXViewException(
   Result result,
   string message,
   Exception innerException
);
[C++]
public: ImageXViewException(
   Result result,
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
ImageXViewException(
   Result result,
   String^ message,
   Exception^ innerException
)

Parameters

result
A Result enumeration value.
message
A string value which represents the error message.
innerException
An Exception.

See Also

ImageXViewException Class | ImageXViewException Members | Overload List


ImageXViewException Constructor(String)

ImageXViewException Class | ImageXViewException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string value which represents the error message.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXViewException Constructor(String)

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXViewException Class > ImageXViewException Constructor : ImageXViewException Constructor(String)

Constructor which allows passing in a message for the exception.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public ImageXViewException(
   string message
);
[C++]
public: ImageXViewException(
   string* message
)
[C++/CLI]
public:
ImageXViewException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

ImageXViewException Class | ImageXViewException Members | Overload List


ImageXViewException Constructor(String,Exception)

ImageXViewException Class | ImageXViewException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string value which represents the error message.
innerException
A Exception value.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXViewException Constructor(String,Exception)

PegasusImaging.WinForms.ImagXpress9 Namespace > ImageXViewException Class > ImageXViewException Constructor : ImageXViewException Constructor(String,Exception)

Constructor which allows passing in a message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public ImageXViewException(
   string message,
   Exception innerException
);
[C++]
public: ImageXViewException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
ImageXViewException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
A Exception value.

See Also

ImageXViewException Class | ImageXViewException Members | Overload List


ImagXpress Class

ImagXpress Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpress Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ImagXpress Class

Implements methods and properties for the ImagXpress component.

For a list of all members of this type, see ImagXpress members.

Object Model

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
PegasusImaging.WinForms.ImagXpress9.ImagXpress

Syntax

[Visual Basic]
<ToolboxBitmapAttribute()>
<ComVisibleAttribute(True)>
Public Class ImagXpress
   Inherits Component
   Implements IComponent, IDisposable
[C#]
[ToolboxBitmapAttribute()]
[ComVisibleAttribute(true)]
public class ImagXpress : Component, IComponent, IDisposable
[C++]
[ToolboxBitmapAttribute()]
[ComVisibleAttribute(true)]
public __gc class ImagXpress : public Component, IComponent, IDisposable
[C++/CLI]
[ToolboxBitmapAttribute()]
[ComVisibleAttribute(true)]
public ref class ImagXpress : public Component, IComponent, IDisposable

See Also

ImagXpress Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ImagXpress Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpress Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ImagXpress Class

ImagXpress overview

Public Constructors

Public Constructor ImagXpress Constructor Overloaded. Initializes a new instance of the ImagXpress class.

Public Properties

Public Property Container (Inherited from System.ComponentModel.Component) | Gets the IContainer that contains the Component.
Public Property Debug | Gets and sets a flag to indicate if debug information is sent to a debug file.
Public Property DebugErrorLevel | The error level of items to be written to the debug log file.
Public Property DebugLogFile | The filename and path of the debug log file.
Public Property Licensing | Gets the licensing information for the ImagXpress component.
Public Property ProgressPercent | Gets or sets the progress percent.
Public Property Site (Inherited from System.ComponentModel.Component) | Gets or sets the ISite of the Component.

Public Methods

Public Method AboutBox | Displays a dialog box containing ImagXpress version and copyright information.
Public Method CreateObjRef (Inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Public Method Dispose (Inherited from System.ComponentModel.Component) | Releases all resources used by the Component.
Public Method GetLifetimeService (Inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Public Method InitializeLifetimeService (Inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Public Method ToString (Inherited from System.ComponentModel.Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

Public Events

Public Event Disposed (Inherited from System.ComponentModel.Component) | Adds an event handler to listen to the Disposed event on the component.
Public Event ImageStatusEvent | Thrown when the event handler receives data from ImageStatusEventArgs.
Public Event ProgressEvent | Fires during progress events.

See Also

ImagXpress Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImagXpress Constructor

ImagXpress Class | ImagXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpress Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ImagXpress Class : ImagXpress Constructor (ImagXpress)

Initializes a new instance of the ImagXpress class.

Overload List

Initializes a new instance of the ImagXpress class.

[Visual Basic] Public Sub New()

[C#] public ImagXpress();

[C++] public ImagXpress();

[C++/CLI] public ImagXpress();

Initializes a new instance of the ImagXpress class.

[Visual Basic] Public Sub New(IContainer)

[C#] public ImagXpress(IContainer);

[C++] public ImagXpress(IContainer*);

[C++/CLI] public ImagXpress(IContainer^);

See Also

ImagXpress Class | ImagXpress Members


ImagXpress Constructor()

ImagXpress Class | ImagXpress Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpress Constructor()

PegasusImaging.WinForms.ImagXpress9 Namespace > ImagXpress Class > ImagXpress Constructor : ImagXpress Constructor()

Initializes a new instance of the ImagXpress class.

[Visual Basic]
Public Function New()
[C#]
public ImagXpress();
[C++]
public: ImagXpress();
[C++/CLI]
public:
ImagXpress();

See Also

ImagXpress Class | ImagXpress Members | Overload List


ImagXpress Constructor(IContainer)

ImagXpress Class | ImagXpress Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

container
The container that implements the IContainer interface which will contain this component.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpress Constructor(IContainer)

PegasusImaging.WinForms.ImagXpress9 Namespace > ImagXpress Class > ImagXpress Constructor : ImagXpress Constructor(IContainer)

Initializes a new instance of the ImagXpress class.

[Visual Basic]
Public Function New( _
   ByVal container As IContainer _
)
[C#]
public ImagXpress(
   IContainer container
);
[C++]
public: ImagXpress(
   IContainer* container
)
[C++/CLI]
public:
ImagXpress(
   IContainer^ container
)

Parameters

container
The container that implements the IContainer interface which will contain this component.

See Also

ImagXpress Class | ImagXpress Members | Overload List


AboutBox Method

ImagXpress Class | ImagXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AboutBox Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ImagXpress Class : AboutBox Method

Displays a dialog box containing ImagXpress version and copyright information.

[Visual Basic]
Public Sub AboutBox()
[C#]
public void AboutBox();
[C++]
public: void AboutBox();
[C++/CLI]
public:
void AboutBox();

See Also

ImagXpress Class | ImagXpress Members


ImagXpress Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpress Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : ImagXpress Class

For a list of all members of this type, see ImagXpress members.

Public Properties

Public Property Container (Inherited from System.ComponentModel.Component) | Gets the IContainer that contains the Component.
Public Property Debug | Gets and sets a flag to indicate if debug information is sent to a debug file.
Public Property DebugErrorLevel | The error level of items to be written to the debug log file.
Public Property DebugLogFile | The filename and path of the debug log file.
Public Property Licensing | Gets the licensing information for the ImagXpress component.
Public Property ProgressPercent | Gets or sets the progress percent.
Public Property Site (Inherited from System.ComponentModel.Component) | Gets or sets the ISite of the Component.

See Also

ImagXpress Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Debug Property

ImagXpress Class | ImagXpress Members | DebugLogFile Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Debug Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImagXpress Class : Debug Property

Gets and sets a flag to indicate if debug information is sent to a debug file.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property Debug As Boolean
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public bool Debug {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property bool get_Debug();
public: __property void set_Debug(
   bool value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property bool Debug {
   bool get();
   void set (bool value);
}

Remarks

The default value is false.

This property allows you to turn the debug log file on or off without changing any of the other debug settings. When this is true, the toolkit will write items to the debug log file, as specified by the DebugLogFile and ImagXpress.DebugErrorLevel properties.

See Also

ImagXpress Class | ImagXpress Members | DebugLogFile Property


DebugErrorLevel Property

ImagXpress Class | ImagXpress Members | Debug Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DebugErrorLevel Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImagXpress Class : DebugErrorLevel Property (ImagXpress)

The error level of items to be written to the debug log file.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property DebugErrorLevel As DebugErrorLevel
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public DebugErrorLevel DebugErrorLevel {get; set;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property DebugErrorLevel get_DebugErrorLevel();
public: __property void set_DebugErrorLevel(
   DebugErrorLevel value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property DebugErrorLevel DebugErrorLevel {
   DebugErrorLevel get();
   void set (DebugErrorLevel value);
}

Remarks

The default value is Production.

Valid values are from the DebugErrorLevel enumeration which include Production, Development and Detailed..

This property allows you to control the amount of information that witten into the DebugLogFile.

Note: Since it takes some amount of time to generate and write debug log items, you should set this to write the least amount of information that you will find useful.

Note: This property will have no effect if you set the Debug property to false.

See Also

ImagXpress Class | ImagXpress Members | Debug Property


DebugLogFile Property

ImagXpress Class | ImagXpress Members | Debug Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DebugLogFile Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImagXpress Class : DebugLogFile Property

The filename and path of the debug log file.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property DebugLogFile As String
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public string DebugLogFile {get; set;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property string* get_DebugLogFile();
public: __property void set_DebugLogFile(
   string* value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property String^ DebugLogFile {
   String^ get();
   void set (String^ value);
}

Remarks

This property allows you to control the location of the debug log file.

The default value is "[Temp Files]\ImagXpress9.log".

Valid values are any valid filename.

The default value for this property is suitable for interactive use. If you are using the component in a service or other type of system that runs in the background, you should set the filename to a more suitable value.

Note: This property will have no effect if you set the Debug property to false.

See Also

ImagXpress Class | ImagXpress Members | Debug Property


Licensing Property

ImagXpress Class | ImagXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Licensing Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImagXpress Class : Licensing Property (ImagXpress)

Gets the licensing information for the ImagXpress component.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property Licensing As Licensing
[C#]
[BrowsableAttribute(false)]
public Licensing Licensing {get;}
[C++]
[BrowsableAttribute(false)]
public: __property Licensing* get_Licensing();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property Licensing^ Licensing {
   Licensing^ get();
}

Return Type

The Licensing information.

See Also

ImagXpress Class | ImagXpress Members


ProgressPercent Property

ImagXpress Class | ImagXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ProgressPercent Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImagXpress Class : ProgressPercent Property (ImagXpress)

Gets or sets the progress percent.

[Visual Basic]
<BrowsableAttribute(True)>
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets how often the progress event will fire.")>
Public Property ProgressPercent As Integer
[C#]
[BrowsableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets how often the progress event will fire.")]
public int ProgressPercent {get; set;}
[C++]
[BrowsableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets how often the progress event will fire.")]
public: __property int get_ProgressPercent();
public: __property void set_ProgressPercent(
   int value
);
[C++/CLI]
[BrowsableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets how often the progress event will fire.")]
public:
property int ProgressPercent {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the progress percent.

Remarks

The default value is 10.

See Also

ImagXpress Class | ImagXpress Members


ImagXpress Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpress Class Events

PegasusImaging.WinForms.ImagXpress9 Namespace : ImagXpress Class

For a list of all members of this type, see ImagXpress members.

Public Events

Public Event Disposed (Inherited from System.ComponentModel.Component) | Adds an event handler to listen to the Disposed event on the component.
Public Event ImageStatusEvent | Thrown when the event handler receives data from ImageStatusEventArgs.
Public Event ProgressEvent | Fires during progress events.

See Also

ImagXpress Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageStatusEvent Event

ImagXpress Class | ImagXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageStatusEvent Event

PegasusImaging.WinForms.ImagXpress9 Namespace > ImagXpress Class : ImageStatusEvent Event

Thrown when the event handler receives data from ImageStatusEventArgs.

[Visual Basic]
Public Event ImageStatusEvent() As ImagXpress.ImageStatusEventHandler
[C#]
public event ImagXpress.ImageStatusEventHandler ImageStatusEvent();
[C++]
public: __event ImagXpress.ImageStatusEventHandler* ImageStatusEvent();
[C++/CLI]
public:
event ImagXpress::ImageStatusEventHandler^ ImageStatusEvent();

Event Data

The event handler receives an argument of type ImageStatusEventArgs containing data related to this event. The following ImageStatusEventArgs properties provide information specific to this event.

Property | Description
Operation | Gets the current image operation.
Status | Gets the status of the current image.

Remarks

This event replaces the static ImageStatusEvent that was in the ImageX class.

See Also

ImagXpress Class | ImagXpress Members


ProgressEvent Event

ImagXpress Class | ImagXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ProgressEvent Event

PegasusImaging.WinForms.ImagXpress9 Namespace > ImagXpress Class : ProgressEvent Event (ImagXpress)

Fires during progress events.

[Visual Basic]
Public Event ProgressEvent() As ImagXpress.ProgressEventHandler
[C#]
public event ImagXpress.ProgressEventHandler ProgressEvent();
[C++]
public: __event ImagXpress.ProgressEventHandler* ProgressEvent();
[C++/CLI]
public:
event ImagXpress::ProgressEventHandler^ ProgressEvent();

Event Data

The event handler receives an argument of type ProgressEventArgs containing data related to this event. The following ProgressEventArgs properties provide information specific to this event.

Property | Description
BytesProcessed |
IsAsync |
IsComplete |
Operation |
PercentDone |
Result |
TotalBytes |

Remarks

This event replaces the static ProgressEvent that was in the ImageX class.

See Also

ImagXpress Class | ImagXpress Members


ImagXpressDefaultContextMenu Class

ImagXpressDefaultContextMenu Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpressDefaultContextMenu Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ImagXpressDefaultContextMenu Class

Summary description for ImagXpressDefaultContextMenu.

For a list of all members of this type, see ImagXpressDefaultContextMenu members.

Object Model

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Menu
System.Windows.Forms.ContextMenu
PegasusImaging.WinForms.ImagXpress9.ImagXpressDefaultContextMenu

Syntax

[Visual Basic]
<DesignTimeVisibleAttribute()>
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
Public Class ImagXpressDefaultContextMenu
   Inherits ContextMenu
   Implements IComponent, IDisposable
[C#]
[DesignTimeVisibleAttribute()]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public class ImagXpressDefaultContextMenu : ContextMenu, IComponent, IDisposable
[C++]
[DesignTimeVisibleAttribute()]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public __gc class ImagXpressDefaultContextMenu : public ContextMenu, IComponent, IDisposable
[C++/CLI]
[DesignTimeVisibleAttribute()]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public ref class ImagXpressDefaultContextMenu : public ContextMenu, IComponent, IDisposable

Example

...

/// Create a new ContextMenu to work with

ContextMenu = new ImagXpressDefaultContextMenu();

...

See Also

ImagXpressDefaultContextMenu Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ImagXpressDefaultContextMenu Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpressDefaultContextMenu Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ImagXpressDefaultContextMenu Class

ImagXpressDefaultContextMenu overview

Public Constructors

Public Constructor ImagXpressDefaultContextMenu Constructor

Public Properties

Public Property Container (Inherited from System.ComponentModel.Component) | Gets the IContainer that contains the Component.
Public Property Handle (Inherited from System.Windows.Forms.Menu) | Gets a value representing the window handle for the menu.
Public Property IsParent (Inherited from System.Windows.Forms.Menu) | Gets a value indicating whether this menu contains any menu items. This property is read-only.
Public Property MdiListItem (Inherited from System.Windows.Forms.Menu) | Gets a value indicating the MenuItem that is used to display a list of multiple document interface (MDI) child forms.
Public Property MenuItems (Inherited from System.Windows.Forms.Menu) | Gets a value indicating the collection of MenuItem objects associated with the menu.
Public Property Name (Inherited from System.Windows.Forms.Menu) | Gets or sets the name of the Menu.
Public Property RightToLeft (Inherited from System.Windows.Forms.ContextMenu) | Gets or sets a value indicating whether text displayed by the control is displayed from right to left.
Public Property Site (Inherited from System.ComponentModel.Component) | Gets or sets the ISite of the Component.
Public Property SourceControl (Inherited from System.Windows.Forms.ContextMenu) | Gets the control that is displaying the shortcut menu.
Public Property Tag (Inherited from System.Windows.Forms.Menu) | Gets or sets user-defined data associated with the control.

Public Methods

Public Method CreateObjRef (Inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Public Method Dispose (Inherited from System.ComponentModel.Component) | Releases all resources used by the Component.
Public Method FindMenuItem (Inherited from System.Windows.Forms.Menu) | Gets the MenuItem that contains the value specified.
Public Method GetContextMenu (Inherited from System.Windows.Forms.Menu) | Gets the ContextMenu that contains this menu.
Public Method GetLifetimeService (Inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Public Method GetMainMenu (Inherited from System.Windows.Forms.Menu) | Gets the MainMenu that contains this menu.
Public Method InitializeLifetimeService (Inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Public Method MergeMenu (Inherited from System.Windows.Forms.Menu) | Merges the MenuItem objects of one menu with the current menu.
Public Method Show (Inherited from System.Windows.Forms.ContextMenu) | Overloaded. Displays the shortcut menu at the specified position.
Public Method ToString (Inherited from System.Windows.Forms.Menu) | Returns a String that represents the Menu control.

Public Events

Public Event Collapse (Inherited from System.Windows.Forms.ContextMenu) | Occurs when the shortcut menu collapses.
Public Event Disposed (Inherited from System.ComponentModel.Component) | Adds an event handler to listen to the Disposed event on the component.
Public Event Popup (Inherited from System.Windows.Forms.ContextMenu) | Occurs before the shortcut menu is displayed.

See Also

ImagXpressDefaultContextMenu Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImagXpressDefaultContextMenu Constructor

ImagXpressDefaultContextMenu Class | ImagXpressDefaultContextMenu Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpressDefaultContextMenu Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ImagXpressDefaultContextMenu Class : ImagXpressDefaultContextMenu Constructor (ImagXpressDefaultContextMenu)
[Visual Basic]
Public Function New()
[C#]
public ImagXpressDefaultContextMenu();
[C++]
public: ImagXpressDefaultContextMenu();
[C++/CLI]
public:
ImagXpressDefaultContextMenu();

See Also

ImagXpressDefaultContextMenu Class | ImagXpressDefaultContextMenu Members


ImagXpressException Class

ImagXpressException Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpressException Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ImagXpressException Class

This class implements handling errors and exceptions for ImagXpress objects.

For a list of all members of this type, see ImagXpressException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.ImagXpress9.ImagXpressException
PegasusImaging.WinForms.ImagXpress9.IcmException
PegasusImaging.WinForms.ImagXpress9.ImageXException
PegasusImaging.WinForms.ImagXpress9.ImageXViewException
PegasusImaging.WinForms.ImagXpress9.InternetException
PegasusImaging.WinForms.ImagXpress9.ProcessorException

Syntax

[Visual Basic]
Public Class ImagXpressException
   Inherits ApplicationException
   Implements ISerializable, _Exception
[C#]
public class ImagXpressException : ApplicationException, ISerializable, _Exception
[C++]
public __gc class ImagXpressException : public ApplicationException, ISerializable, _Exception
[C++/CLI]
public ref class ImagXpressException : public ApplicationException, ISerializable, _Exception

See Also

ImagXpressException Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ImagXpressException Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpressException Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ImagXpressException Class

ImagXpressException overview

Public Constructors

Public Constructor ImagXpressException Constructor Overloaded. The main constructor which initializes a new instance of the ImagXpressException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number | Gets the numerical equivalent for enumerated exception result.
Public Property Result | Gets the enumerated exception result that has occurred.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ImagXpressException Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImagXpressException Constructor

ImagXpressException Class | ImagXpressException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpressException Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ImagXpressException Class : ImagXpressException Constructor (ImagXpressException)

The main constructor which initializes a new instance of the ImagXpressException class.

Overload List

The main constructor which initializes a new instance of the ImagXpressException class.

[Visual Basic] Public Sub New()

[C#] public ImagXpressException();

[C++] public ImagXpressException();

[C++/CLI] public ImagXpressException();

Constructor which allows passing in a result for ImagXpress exceptions.

[Visual Basic] Public Sub New(Result)

[C#] public ImagXpressException(Result);

[C++] public ImagXpressException(Result);

[C++/CLI] public ImagXpressException(Result);

Constructor which allows passing in a message for ImagXpress exceptions.

[Visual Basic] Public Sub New(String)

[C#] public ImagXpressException(string);

[C++] public ImagXpressException(string*);

[C++/CLI] public ImagXpressException(String^);

Constructor which allows passing in a result and a message for ImagXpress exceptions.

[Visual Basic] Public Sub New(Result,String)

[C#] public ImagXpressException(Result,string);

[C++] public ImagXpressException(Result,string*);

[C++/CLI] public ImagXpressException(Result,String^);

Constructor which allows passing in a message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public ImagXpressException(string,Exception);

[C++] public ImagXpressException(string*,Exception*);

[C++/CLI] public ImagXpressException(String^,Exception^);

Constructor which allows passing in a result, message and inner exception.

[Visual Basic] Public Sub New(Result,String,Exception)

[C#] public ImagXpressException(Result,string,Exception);

[C++] public ImagXpressException(Result,string*,Exception*);

[C++/CLI] public ImagXpressException(Result,String^,Exception^);

See Also

ImagXpressException Class | ImagXpressException Members


ImagXpressException Constructor()

ImagXpressException Class | ImagXpressException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpressException Constructor()

PegasusImaging.WinForms.ImagXpress9 Namespace > ImagXpressException Class > ImagXpressException Constructor : ImagXpressException Constructor()

The main constructor which initializes a new instance of the ImagXpressException class.

[Visual Basic]
Public Function New()
[C#]
public ImagXpressException();
[C++]
public: ImagXpressException();
[C++/CLI]
public:
ImagXpressException();

See Also

ImagXpressException Class | ImagXpressException Members | Overload List


ImagXpressException Constructor(Result)

ImagXpressException Class | ImagXpressException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

result
A Result enumeration value.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpressException Constructor(Result)

PegasusImaging.WinForms.ImagXpress9 Namespace > ImagXpressException Class > ImagXpressException Constructor : ImagXpressException Constructor(Result)

Constructor which allows passing in a result for ImagXpress exceptions.

[Visual Basic]
Public Function New( _
   ByVal result As Result _
)
[C#]
public ImagXpressException(
   Result result
);
[C++]
public: ImagXpressException(
   Result result
)
[C++/CLI]
public:
ImagXpressException(
   Result result
)

Parameters

result
A Result enumeration value.

See Also

ImagXpressException Class | ImagXpressException Members | Overload List


ImagXpressException Constructor(Result,String)

ImagXpressException Class | ImagXpressException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

result
An Result enumeration value.
message
A string which represents the error message for the exception.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpressException Constructor(Result,String)

PegasusImaging.WinForms.ImagXpress9 Namespace > ImagXpressException Class > ImagXpressException Constructor : ImagXpressException Constructor(Result,String)

Constructor which allows passing in a result and a message for ImagXpress exceptions.

[Visual Basic]
Public Function New( _
   ByVal result As Result, _
   ByVal message As String _
)
[C#]
public ImagXpressException(
   Result result,
   string message
);
[C++]
public: ImagXpressException(
   Result result,
   string* message
)
[C++/CLI]
public:
ImagXpressException(
   Result result,
   String^ message
)

Parameters

result
An Result enumeration value.
message
A string which represents the error message for the exception.

See Also

ImagXpressException Class | ImagXpressException Members | Overload List


ImagXpressException Constructor(Result,String,Exception)

ImagXpressException Class | ImagXpressException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

result
A Result enumeration value.
message
A string value which represents the error message.
innerException
An inner Exception.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpressException Constructor(Result,String,Exception)

PegasusImaging.WinForms.ImagXpress9 Namespace > ImagXpressException Class > ImagXpressException Constructor : ImagXpressException Constructor(Result,String,Exception)

Constructor which allows passing in a result, message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal result As Result, _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public ImagXpressException(
   Result result,
   string message,
   Exception innerException
);
[C++]
public: ImagXpressException(
   Result result,
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
ImagXpressException(
   Result result,
   String^ message,
   Exception^ innerException
)

Parameters

result
A Result enumeration value.
message
A string value which represents the error message.
innerException
An inner Exception.

See Also

ImagXpressException Class | ImagXpressException Members | Overload List


ImagXpressException Constructor(String)

ImagXpressException Class | ImagXpressException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string value which represents the error message for the exception.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpressException Constructor(String)

PegasusImaging.WinForms.ImagXpress9 Namespace > ImagXpressException Class > ImagXpressException Constructor : ImagXpressException Constructor(String)

Constructor which allows passing in a message for ImagXpress exceptions.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public ImagXpressException(
   string message
);
[C++]
public: ImagXpressException(
   string* message
)
[C++/CLI]
public:
ImagXpressException(
   String^ message
)

Parameters

message
A string value which represents the error message for the exception.

See Also

ImagXpressException Class | ImagXpressException Members | Overload List


ImagXpressException Constructor(String,Exception)

ImagXpressException Class | ImagXpressException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string value which represents the error message for the exception.
innerException
An Exception.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpressException Constructor(String,Exception)

PegasusImaging.WinForms.ImagXpress9 Namespace > ImagXpressException Class > ImagXpressException Constructor : ImagXpressException Constructor(String,Exception)

Constructor which allows passing in a message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public ImagXpressException(
   string message,
   Exception innerException
);
[C++]
public: ImagXpressException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
ImagXpressException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message for the exception.
innerException
An Exception.

See Also

ImagXpressException Class | ImagXpressException Members | Overload List


ImagXpressException Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpressException Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : ImagXpressException Class

For a list of all members of this type, see ImagXpressException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number | Gets the numerical equivalent for enumerated exception result.
Public Property Result | Gets the enumerated exception result that has occurred.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

ImagXpressException Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Number Property

ImagXpressException Class | ImagXpressException Members | Result Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Number Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImagXpressException Class : Number Property

Gets the numerical equivalent for enumerated exception result.

[Visual Basic]
Public ReadOnly Property Number As Integer
[C#]
public int Number {get;}
[C++]
public: __property int get_Number();
[C++/CLI]
public:
property int Number {
   int get();
}

Return Type

An integer value which represents the error number for the exception.

Remarks

To get the result of the exception, use the Result property.

See Also

ImagXpressException Class | ImagXpressException Members | Result Property


Result Property

ImagXpressException Class | ImagXpressException Members | Number Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Result Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ImagXpressException Class : Result Property (ImagXpressException)

Gets the enumerated exception result that has occurred.

[Visual Basic]
Public ReadOnly Property Result As Result
[C#]
public Result Result {get;}
[C++]
public: __property Result get_Result();
[C++/CLI]
public:
property Result Result {
   Result get();
}

Return Type

A Result enumeration value for the exception.

Remarks

To get the error number for the exception, use the Number property.

See Also

ImagXpressException Class | ImagXpressException Members | Number Property


InternetException Class

InternetException Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

InternetException Class

PegasusImaging.WinForms.ImagXpress9 Namespace : InternetException Class

This class implements exceptions for the Internet objects.

For a list of all members of this type, see InternetException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.ImagXpress9.ImagXpressException
PegasusImaging.WinForms.ImagXpress9.InternetException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InternetException
   Inherits ImagXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class InternetException : ImagXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class InternetException : public ImagXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class InternetException sealed : public ImagXpressException, ISerializable, _Exception

See Also

InternetException Members | PegasusImaging.WinForms.ImagXpress9 Namespace


InternetException Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

InternetException Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : InternetException Class

InternetException overview

Public Constructors

Public Constructor InternetException Constructor Overloaded. The main constructor for the InternetException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from ImagXpressException) | Gets the numerical equivalent for enumerated exception result.
Public Property Result (Inherited from ImagXpressException) | Gets the enumerated exception result that has occurred.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InternetException Class | PegasusImaging.WinForms.ImagXpress9 Namespace


InternetException Constructor

InternetException Class | InternetException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

InternetException Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > InternetException Class : InternetException Constructor (InternetException)

The main constructor for the InternetException class.

Overload List

The main constructor for the InternetException class.

[Visual Basic] Public Sub New()

[C#] public InternetException();

[C++] public InternetException();

[C++/CLI] public InternetException();

Constructor which allows passing in a result for the exception.

[Visual Basic] Public Sub New(Result)

[C#] public InternetException(Result);

[C++] public InternetException(Result);

[C++/CLI] public InternetException(Result);

Constructor which allows passing in a message for the exception.

[Visual Basic] Public Sub New(String)

[C#] public InternetException(string);

[C++] public InternetException(string*);

[C++/CLI] public InternetException(String^);

Constructor which allows passing in a result and message for the exception.

[Visual Basic] Public Sub New(Result,String)

[C#] public InternetException(Result,string);

[C++] public InternetException(Result,string*);

[C++/CLI] public InternetException(Result,String^);

Constructor which allows passing in a message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InternetException(string,Exception);

[C++] public InternetException(string*,Exception*);

[C++/CLI] public InternetException(String^,Exception^);

Constructor which allows passing in a result, message and inner exception.

[Visual Basic] Public Sub New(Result,String,Exception)

[C#] public InternetException(Result,string,Exception);

[C++] public InternetException(Result,string*,Exception*);

[C++/CLI] public InternetException(Result,String^,Exception^);

See Also

InternetException Class | InternetException Members


InternetException Constructor()

InternetException Class | InternetException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

InternetException Constructor()

PegasusImaging.WinForms.ImagXpress9 Namespace > InternetException Class > InternetException Constructor : InternetException Constructor()

The main constructor for the InternetException class.

[Visual Basic]
Public Function New()
[C#]
public InternetException();
[C++]
public: InternetException();
[C++/CLI]
public:
InternetException();

See Also

InternetException Class | InternetException Members | Overload List


InternetException Constructor(Result)

InternetException Class | InternetException Members | Overload List | Result Enumeration

Language

Visual Basic

C#

C++

C++/CLI

Show All

result
A Result enumeration value.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

InternetException Constructor(Result)

PegasusImaging.WinForms.ImagXpress9 Namespace > InternetException Class > InternetException Constructor : InternetException Constructor(Result)

Constructor which allows passing in a result for the exception.

[Visual Basic]
Public Function New( _
   ByVal result As Result _
)
[C#]
public InternetException(
   Result result
);
[C++]
public: InternetException(
   Result result
)
[C++/CLI]
public:
InternetException(
   Result result
)

Parameters

result
A Result enumeration value.

See Also

InternetException Class | InternetException Members | Overload List | Result Enumeration


InternetException Constructor(Result,String)

InternetException Class | InternetException Members | Overload List | Result Enumeration

Language

Visual Basic

C#

C++

C++/CLI

Show All

result
A Result enumeration value.
message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

InternetException Constructor(Result,String)

PegasusImaging.WinForms.ImagXpress9 Namespace > InternetException Class > InternetException Constructor : InternetException Constructor(Result,String)

Constructor which allows passing in a result and message for the exception.

[Visual Basic]
Public Function New( _
   ByVal result As Result, _
   ByVal message As String _
)
[C#]
public InternetException(
   Result result,
   string message
);
[C++]
public: InternetException(
   Result result,
   string* message
)
[C++/CLI]
public:
InternetException(
   Result result,
   String^ message
)

Parameters

result
A Result enumeration value.
message
A string which represents the error message.

See Also

InternetException Class | InternetException Members | Overload List | Result Enumeration


InternetException Constructor(Result,String,Exception)

InternetException Class | InternetException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

result
A Result enumeration value.
message
A string which represents the error message.
innerException
An Exception value.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

InternetException Constructor(Result,String,Exception)

PegasusImaging.WinForms.ImagXpress9 Namespace > InternetException Class > InternetException Constructor : InternetException Constructor(Result,String,Exception)

Constructor which allows passing in a result, message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal result As Result, _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InternetException(
   Result result,
   string message,
   Exception innerException
);
[C++]
public: InternetException(
   Result result,
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InternetException(
   Result result,
   String^ message,
   Exception^ innerException
)

Parameters

result
A Result enumeration value.
message
A string which represents the error message.
innerException
An Exception value.

See Also

InternetException Class | InternetException Members | Overload List


InternetException Constructor(String)

InternetException Class | InternetException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

InternetException Constructor(String)

PegasusImaging.WinForms.ImagXpress9 Namespace > InternetException Class > InternetException Constructor : InternetException Constructor(String)

Constructor which allows passing in a message for the exception.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InternetException(
   string message
);
[C++]
public: InternetException(
   string* message
)
[C++/CLI]
public:
InternetException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

InternetException Class | InternetException Members | Overload List


InternetException Constructor(String,Exception)

InternetException Class | InternetException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
innerException
An Exception value.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

InternetException Constructor(String,Exception)

PegasusImaging.WinForms.ImagXpress9 Namespace > InternetException Class > InternetException Constructor : InternetException Constructor(String,Exception)

Constructor which allows passing in a message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InternetException(
   string message,
   Exception innerException
);
[C++]
public: InternetException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InternetException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the error message.
innerException
An Exception value.

See Also

InternetException Class | InternetException Members | Overload List


InternetOptions Class

InternetOptions Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

InternetOptions Class

PegasusImaging.WinForms.ImagXpress9 Namespace : InternetOptions Class

This class implements functionality for Internet options.

For a list of all members of this type, see InternetOptions members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.InternetOptions

Syntax

[Visual Basic]
Public Class InternetOptions
[C#]
public class InternetOptions
[C++]
public __gc class InternetOptions
[C++/CLI]
public ref class InternetOptions

See Also

InternetOptions Members | PegasusImaging.WinForms.ImagXpress9 Namespace


InternetOptions Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

InternetOptions Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : InternetOptions Class

InternetOptions overview

Public Constructors

Public Constructor InternetOptions Constructor The main constructor which intializes a new instance of the InternetOptions class.

Public Properties

Public Property FtpMode | Gets and sets the ftp mode value.
Public Property NetworkCredentials | Gets and sets the credentials for the password based authentication.
Public Property ProxySettings | Gets and sets the proxy server name or ID.

See Also

InternetOptions Class | PegasusImaging.WinForms.ImagXpress9 Namespace


InternetOptions Constructor

InternetOptions Class | InternetOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

InternetOptions Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > InternetOptions Class : InternetOptions Constructor (InternetOptions)

The main constructor which intializes a new instance of the InternetOptions class.

[Visual Basic]
Public Function New()
[C#]
public InternetOptions();
[C++]
public: InternetOptions();
[C++/CLI]
public:
InternetOptions();

See Also

InternetOptions Class | InternetOptions Members


InternetOptions Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

InternetOptions Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : InternetOptions Class

For a list of all members of this type, see InternetOptions members.

Public Properties

Public Property FtpMode | Gets and sets the ftp mode value.
Public Property NetworkCredentials | Gets and sets the credentials for the password based authentication.
Public Property ProxySettings | Gets and sets the proxy server name or ID.

See Also

InternetOptions Class | PegasusImaging.WinForms.ImagXpress9 Namespace


FtpMode Property

InternetOptions Class | InternetOptions Members | FtpMode Enumeration

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

FtpMode Property

PegasusImaging.WinForms.ImagXpress9 Namespace > InternetOptions Class : FtpMode Property (InternetOptions)

Gets and sets the ftp mode value.

[Visual Basic]
Public Property FtpMode As FtpMode
[C#]
public FtpMode FtpMode {get; set;}
[C++]
public: __property FtpMode get_FtpMode();
public: __property void set_FtpMode(
   FtpMode value
);
[C++/CLI]
public:
property FtpMode FtpMode {
   FtpMode get();
   void set (FtpMode value);
}

Return Type

The FtpMode enumeration value set.

See Also

InternetOptions Class | InternetOptions Members | FtpMode Enumeration


NetworkCredentials Property

InternetOptions Class | InternetOptions Members | NetworkCredential

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

NetworkCredentials Property

PegasusImaging.WinForms.ImagXpress9 Namespace > InternetOptions Class : NetworkCredentials Property

Gets and sets the credentials for the password based authentication.

[Visual Basic]
Public Property NetworkCredentials As NetworkCredential
[C#]
public NetworkCredential NetworkCredentials {get; set;}
[C++]
public: __property NetworkCredential* get_NetworkCredentials();
public: __property void set_NetworkCredentials(
   NetworkCredential* value
);
[C++/CLI]
public:
property NetworkCredential^ NetworkCredentials {
   NetworkCredential^ get();
   void set (NetworkCredential^ value);
}

Return Type

The NetworkCredential

See Also

InternetOptions Class | InternetOptions Members | NetworkCredential


ProxySettings Property

InternetOptions Class | InternetOptions Members | WebProxy

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ProxySettings Property

PegasusImaging.WinForms.ImagXpress9 Namespace > InternetOptions Class : ProxySettings Property

Gets and sets the proxy server name or ID.

[Visual Basic]
Public Property ProxySettings As WebProxy
[C#]
public WebProxy ProxySettings {get; set;}
[C++]
public: __property WebProxy* get_ProxySettings();
public: __property void set_ProxySettings(
   WebProxy* value
);
[C++/CLI]
public:
property WebProxy^ ProxySettings {
   WebProxy^ get();
   void set (WebProxy^ value);
}

Return Type

The WebProxy set.

See Also

InternetOptions Class | InternetOptions Members | WebProxy


Licensing Class

Licensing Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Licensing Class

PegasusImaging.WinForms.ImagXpress9 Namespace : Licensing Class (PegasusImaging.WinForms.ImagXpress9)

The Licensing class determines the license edition, add-on licensing, behavior, and unlock methods.

For a list of all members of this type, see Licensing members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.Licensing

Syntax

[Visual Basic]
Public Class Licensing
[C#]
public class Licensing
[C++]
public __gc class Licensing
[C++/CLI]
public ref class Licensing

See Also

Licensing Members | PegasusImaging.WinForms.ImagXpress9 Namespace


Licensing Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Licensing Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : Licensing Class (PegasusImaging.WinForms.ImagXpress9)

Licensing overview

Public Constructors

Public Constructor Licensing Constructor The initial constructor for the licensing class passing in a workspace ID.

Public Properties

Public Property AddOnBehavior | This property has been deprecated.
Public Property EvaluationMode | Gets and sets a watermark or dialog box to be displayed periodically.
Public Property LicenseEditionChoice | Gets and sets which edition of ImagXpress to use.
Public Property LicenseStatus | Gets the current license status of the component.

Public Methods

Public Method AddOnLicense | This method has been deprecated.
Public Method UnlockRuntime | Enable run-time licensing.
Public Method UnlockWeb | Enable web licensing when deploying to a web application.

See Also

Licensing Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Licensing Constructor

Licensing Class | Licensing Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

pWorkId
An ImagXpress workspace ID.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Licensing Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > Licensing Class : Licensing Constructor (Licensing)

The initial constructor for the licensing class passing in a workspace ID.

[Visual Basic]
Public Function New( _
   ByVal pWorkId As IntPtr _
)
[C#]
public Licensing(
   IntPtr pWorkId
);
[C++]
public: Licensing(
   IntPtr pWorkId
)
[C++/CLI]
public:
Licensing(
   IntPtr pWorkId
)

Parameters

pWorkId
An ImagXpress workspace ID.

See Also

Licensing Class | Licensing Members


AddOnLicense Method

Licensing Class | Licensing Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

UnlockAddOn
A string which represents a unique licensing text provided by Pegasus Imaging when add-on licenses are purchased.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AddOnLicense Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Licensing Class : AddOnLicense Method

This method has been deprecated.

[Visual Basic]
<ObsoleteAttribute()>
Public Sub AddOnLicense( _
   ByVal UnlockAddOn As String _
)
[C#]
[ObsoleteAttribute()]
public void AddOnLicense(
   string UnlockAddOn
);
[C++]
[ObsoleteAttribute()]
public: void AddOnLicense(
   string* UnlockAddOn
)
[C++/CLI]
[ObsoleteAttribute()]
public:
void AddOnLicense(
   String^ UnlockAddOn
)

Parameters

UnlockAddOn
A string which represents a unique licensing text provided by Pegasus Imaging when add-on licenses are purchased.

Remarks

Call this method when the application begins to enable runtime use of the add-ons purchased.

Note: Available in all editions.

See Also

Licensing Class | Licensing Members


UnlockRuntime Method

Licensing Class | Licensing Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

code1
A string which represents a unique licensing code, provided by Pegasus Imaging when runtime licenses are purchased.
code2
string which represents a unique licensing code, provided by Pegasus Imaging when runtime licenses are purchased.
code3
string which represents a unique licensing code, provided by Pegasus Imaging when runtime licenses are purchased.
code4
string which represents a unique licensing code, provided by Pegasus Imaging when runtime licenses are purchased.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

UnlockRuntime Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Licensing Class : UnlockRuntime Method

Enable run-time licensing.

[Visual Basic]
Public Sub UnlockRuntime( _
   ByVal code1 As Integer, _
   ByVal code2 As Integer, _
   ByVal code3 As Integer, _
   ByVal code4 As Integer _
)
[C#]
public void UnlockRuntime(
   int code1,
   int code2,
   int code3,
   int code4
);
[C++]
public: void UnlockRuntime(
   int code1,
   int code2,
   int code3,
   int code4
)
[C++/CLI]
public:
void UnlockRuntime(
   int code1,
   int code2,
   int code3,
   int code4
)

Parameters

code1
A string which represents a unique licensing code, provided by Pegasus Imaging when runtime licenses are purchased.
code2
string which represents a unique licensing code, provided by Pegasus Imaging when runtime licenses are purchased.
code3
string which represents a unique licensing code, provided by Pegasus Imaging when runtime licenses are purchased.
code4
string which represents a unique licensing code, provided by Pegasus Imaging when runtime licenses are purchased.

See Also

Licensing Class | Licensing Members


UnlockWeb Method

Licensing Class | Licensing Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

unlockString
A string which represents a unique licensing string, provided by Pegasus Imaging when web licensing is purchased.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

UnlockWeb Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Licensing Class : UnlockWeb Method

Enable web licensing when deploying to a web application.

[Visual Basic]
Public Sub UnlockWeb( _
   ByVal unlockString As String _
)
[C#]
public void UnlockWeb(
   string unlockString
);
[C++]
public: void UnlockWeb(
   string* unlockString
)
[C++/CLI]
public:
void UnlockWeb(
   String^ unlockString
)

Parameters

unlockString
A string which represents a unique licensing string, provided by Pegasus Imaging when web licensing is purchased.

Remarks

Call this method when the application begins to enable runtime use of the control in a web application.

See Also

Licensing Class | Licensing Members


Licensing Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Licensing Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : Licensing Class (PegasusImaging.WinForms.ImagXpress9)

For a list of all members of this type, see Licensing members.

Public Properties

Public Property AddOnBehavior | This property has been deprecated.
Public Property EvaluationMode | Gets and sets a watermark or dialog box to be displayed periodically.
Public Property LicenseEditionChoice | Gets and sets which edition of ImagXpress to use.
Public Property LicenseStatus | Gets the current license status of the component.

See Also

Licensing Class | PegasusImaging.WinForms.ImagXpress9 Namespace


AddOnBehavior Property

Licensing Class | Licensing Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AddOnBehavior Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Licensing Class : AddOnBehavior Property

This property has been deprecated.

[Visual Basic]
<ObsoleteAttribute()>
Public Property AddOnBehavior As AddOnBehaviorType
[C#]
[ObsoleteAttribute()]
public AddOnBehaviorType AddOnBehavior {get; set;}
[C++]
[ObsoleteAttribute()]
public: __property AddOnBehaviorType get_AddOnBehavior();
public: __property void set_AddOnBehavior(
   AddOnBehaviorType value
);
[C++/CLI]
[ObsoleteAttribute()]
public:
property AddOnBehaviorType AddOnBehavior {
   AddOnBehaviorType get();
   void set (AddOnBehaviorType value);
}

Return Type

The AddOnBehaviorType set.

Remarks

The default value for this property is ShowEvaluationDialog.

This will display the Pegasus Imaging evaluation dialog box for add ons which are not unlocked. To not display this dialog box and instead return an error for add on type images, set this property to FailWithError.

See Also

Licensing Class | Licensing Members


EvaluationMode Property

Licensing Class | Licensing Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

EvaluationMode Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Licensing Class : EvaluationMode Property (Licensing)

Gets and sets a watermark or dialog box to be displayed periodically.

[Visual Basic]
Public Property EvaluationMode As EvaluationMode
[C#]
public EvaluationMode EvaluationMode {get; set;}
[C++]
public: __property EvaluationMode get_EvaluationMode();
public: __property void set_EvaluationMode(
   EvaluationMode value
);
[C++/CLI]
public:
property EvaluationMode EvaluationMode {
   EvaluationMode get();
   void set (EvaluationMode value);
}

Return Type

The EvaluationMode value set.

See Also

Licensing Class | Licensing Members


LicenseEditionChoice Property

Licensing Class | Licensing Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LicenseEditionChoice Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Licensing Class : LicenseEditionChoice Property

Gets and sets which edition of ImagXpress to use.

[Visual Basic]
Public Property LicenseEditionChoice As LicenseEditionType
[C#]
public LicenseEditionType LicenseEditionChoice {get; set;}
[C++]
public: __property LicenseEditionType get_LicenseEditionChoice();
public: __property void set_LicenseEditionChoice(
   LicenseEditionType value
);
[C++/CLI]
public:
property LicenseEditionType LicenseEditionChoice {
   LicenseEditionType get();
   void set (LicenseEditionType value);
}

Return Type

The LicenseEditionChoice set.

Remarks

If the edition has not been licensed, then the control runs in evaluation mode and a dialog box or watermark displays.

Setting this property can override the default license determination, enabling users to try other editions of the control. For example, if you have a paid license of the Standard edition of ImagXpress, and would like to try the Photo edition, you need to set the Edition to Photo and ImagXpress will then run the Photo edition in trial mode.

Note: All distributed applications created are subject to any limitations imposed by the license Edition requested.

See Also

Licensing Class | Licensing Members


LicenseStatus Property

Licensing Class | Licensing Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LicenseStatus Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Licensing Class : LicenseStatus Property (Licensing)

Gets the current license status of the component.

[Visual Basic]
Public ReadOnly Property LicenseStatus As LicenseStatus
[C#]
public LicenseStatus LicenseStatus {get;}
[C++]
public: __property LicenseStatus get_LicenseStatus();
[C++/CLI]
public:
property LicenseStatus LicenseStatus {
   LicenseStatus get();
}

Return Type

The current LicenseStatus.

See Also

Licensing Class | Licensing Members


LoadOptions Class

LoadOptions Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptions Class

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptions Class (PegasusImaging.WinForms.ImagXpress9)

The LoadOptions class includes various formats and image types to load into ImagXpress.

For a list of all members of this type, see LoadOptions members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.LoadOptions

Syntax

[Visual Basic]
Public Class LoadOptions
[C#]
public class LoadOptions
[C++]
public __gc class LoadOptions
[C++/CLI]
public ref class LoadOptions

See Also

LoadOptions Members | PegasusImaging.WinForms.ImagXpress9 Namespace


LoadOptions Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptions Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptions Class (PegasusImaging.WinForms.ImagXpress9)

LoadOptions overview

Public Constructors

Public Constructor LoadOptions Constructor Initial constructor for the LoadOptions class.

Public Properties

Public Property Cad | Gets and sets the CAD load options for the image.
Public Property CameraRawEnabled | Gets and sets support for Camera RAW file format.
Public Property ColorRenderIntent | Gets and sets how the color profiles should be applied.
Public Property CropRectangle | Gets and sets the dimensions to which the image should be cropped when loaded.
Public Property HdPhoto | Gets and sets the HD Photo load options for the image.
Public Property ImageOffset | Gets and sets the offset in the file or memory buffer where ImagXpress begins reading the image data.
Public Property Internet | Gets and sets the InternetOptions settings.
Public Property Jbig2 | Gets and sets the specific LoadOptionsJbig2 applicable to a Jbig2 file format.
Public Property Jpeg | Gets and sets the specific LoadOptionsJpeg applicable to a JPEG file format.
Public Property LibraryNumberOfThreadsAllowed | Gets or sets the library number of threads allowed.
Public Property LoadAlphaChannel | Gets and sets if the alpha channel data is loaded.
Public Property LoadMode | Gets and sets a load mode for how image data is interpreted as a raw image format or a standard format.
Public Property LoadResizeAntiAlias | Gets or sets a value indicating whether anti-aliasing is enabled during a load resize.
Public Property MaintainAspectRatio | Gets and sets the option to preserve image aspect ratio when resizing an image during the loading of the ImageX object.
Public Property Metafile | Gets and sets the specific LoadOptionsMetafile applicable to a metafile.
Public Property Pdf | Gets and sets the specific LoadOptionsPdf applicable to a PDF file format.
Public Property Pic | Gets and sets the specific LoadOptionsPic applicable to a PIC (Pegasus Imaging Corporation) file format.
Public Property PreserveBlack | Gets and sets an indicator that preserve black should be applied to the image when it is loaded.
Public Property Raw | Gets and sets the specific LoadOptionsRaw applicable to a RAW file.
Public Property Resize | Gets and sets the image height and width to which the image should be resized to when loading into an ImageX object.
Public Property Rotation | Gets and sets the angle of rotation to apply to the image being loaded into the ImageX object.
Public Property ScaleToGray | Gets and sets an indicator if anti-aliasing/conversion to grayscale for 1 bpp images during a resizing load operation is enabled.
Public Property SourceProfileName | Gets and sets the name of the color profile to apply to the image being loaded.
Public Property ThumbnailSize | Gets and sets if the image is loaded as a thumbnail with the thumbnail size.
Public Property Tiff | Gets and sets the specific LoadOptionsTiff applicable to a TIFF file format.
Public Property UseEmbeddedColorManagement | Gets and sets the color profile included in the image metadata applied when loading the image.

See Also

LoadOptions Class | PegasusImaging.WinForms.ImagXpress9 Namespace


LoadOptions Constructor

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptions Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : LoadOptions Constructor (LoadOptions)

Initial constructor for the LoadOptions class.

[Visual Basic]
Public Function New()
[C#]
public LoadOptions();
[C++]
public: LoadOptions();
[C++/CLI]
public:
LoadOptions();

See Also

LoadOptions Class | LoadOptions Members


LoadOptions Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptions Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptions Class (PegasusImaging.WinForms.ImagXpress9)

For a list of all members of this type, see LoadOptions members.

Public Properties

Public Property Cad | Gets and sets the CAD load options for the image.
Public Property CameraRawEnabled | Gets and sets support for Camera RAW file format.
Public Property ColorRenderIntent | Gets and sets how the color profiles should be applied.
Public Property CropRectangle | Gets and sets the dimensions to which the image should be cropped when loaded.
Public Property HdPhoto | Gets and sets the HD Photo load options for the image.
Public Property ImageOffset | Gets and sets the offset in the file or memory buffer where ImagXpress begins reading the image data.
Public Property Internet | Gets and sets the InternetOptions settings.
Public Property Jbig2 | Gets and sets the specific LoadOptionsJbig2 applicable to a Jbig2 file format.
Public Property Jpeg | Gets and sets the specific LoadOptionsJpeg applicable to a JPEG file format.
Public Property LibraryNumberOfThreadsAllowed | Gets or sets the library number of threads allowed.
Public Property LoadAlphaChannel | Gets and sets if the alpha channel data is loaded.
Public Property LoadMode | Gets and sets a load mode for how image data is interpreted as a raw image format or a standard format.
Public Property LoadResizeAntiAlias | Gets or sets a value indicating whether anti-aliasing is enabled during a load resize.
Public Property MaintainAspectRatio | Gets and sets the option to preserve image aspect ratio when resizing an image during the loading of the ImageX object.
Public Property Metafile | Gets and sets the specific LoadOptionsMetafile applicable to a metafile.
Public Property Pdf | Gets and sets the specific LoadOptionsPdf applicable to a PDF file format.
Public Property Pic | Gets and sets the specific LoadOptionsPic applicable to a PIC (Pegasus Imaging Corporation) file format.
Public Property PreserveBlack | Gets and sets an indicator that preserve black should be applied to the image when it is loaded.
Public Property Raw | Gets and sets the specific LoadOptionsRaw applicable to a RAW file.
Public Property Resize | Gets and sets the image height and width to which the image should be resized to when loading into an ImageX object.
Public Property Rotation | Gets and sets the angle of rotation to apply to the image being loaded into the ImageX object.
Public Property ScaleToGray | Gets and sets an indicator if anti-aliasing/conversion to grayscale for 1 bpp images during a resizing load operation is enabled.
Public Property SourceProfileName | Gets and sets the name of the color profile to apply to the image being loaded.
Public Property ThumbnailSize | Gets and sets if the image is loaded as a thumbnail with the thumbnail size.
Public Property Tiff | Gets and sets the specific LoadOptionsTiff applicable to a TIFF file format.
Public Property UseEmbeddedColorManagement | Gets and sets the color profile included in the image metadata applied when loading the image.

See Also

LoadOptions Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Cad Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Cad Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : Cad Property

Gets and sets the CAD load options for the image.

[Visual Basic]
Public Property Cad As LoadOptionsCad
[C#]
public LoadOptionsCad Cad {get; set;}
[C++]
public: __property LoadOptionsCad* get_Cad();
public: __property void set_Cad(
   LoadOptionsCad* value
);
[C++/CLI]
public:
property LoadOptionsCad^ Cad {
   LoadOptionsCad^ get();
   void set (LoadOptionsCad^ value);
}

See Also

LoadOptions Class | LoadOptions Members


CameraRawEnabled Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CameraRawEnabled Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : CameraRawEnabled Property

Gets and sets support for Camera RAW file format.

[Visual Basic]
Public Property CameraRawEnabled As Boolean
[C#]
public bool CameraRawEnabled {get; set;}
[C++]
public: __property bool get_CameraRawEnabled();
public: __property void set_CameraRawEnabled(
   bool value
);
[C++/CLI]
public:
property bool CameraRawEnabled {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to check the loaded image for Camera RAW format. Otherwise, false should be set.

Remarks

When this property is set to true, the image is examined on loading to see if it is in Camera RAW format, and to identify the RAW format.

Note: When this property is set to true, the LoadOptions.LoadMode property is ignored.

To optimize performance, this property should be set to false so the image is not examined on loading to inspect for RAW formats unnecessarily.

Note: Available in View, Document and Photo editions.

See Also

LoadOptions Class | LoadOptions Members


ColorRenderIntent Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ColorRenderIntent Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : ColorRenderIntent Property (LoadOptions)

Gets and sets how the color profiles should be applied.

[Visual Basic]
Public Property ColorRenderIntent As RenderIntent
[C#]
public RenderIntent ColorRenderIntent {get; set;}
[C++]
public: __property RenderIntent get_ColorRenderIntent();
public: __property void set_ColorRenderIntent(
   RenderIntent value
);
[C++/CLI]
public:
property RenderIntent ColorRenderIntent {
   RenderIntent get();
   void set (RenderIntent value);
}

Return Type

The RenderIntent value set.

Remarks

This property specifies how color profiles are applied when performing Image Color Management.

Note: This property is only available with the Photo edition. If you are licensed for other editions and attemp to set this property, the change will not occur and an exception is thrown.

See Also

LoadOptions Class | LoadOptions Members


CropRectangle Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CropRectangle Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : CropRectangle Property

Gets and sets the dimensions to which the image should be cropped when loaded.

[Visual Basic]
Public Property CropRectangle As Rectangle
[C#]
public Rectangle CropRectangle {get; set;}
[C++]
public: __property Rectangle get_CropRectangle();
public: __property void set_CropRectangle(
   Rectangle value
);
[C++/CLI]
public:
property Rectangle CropRectangle {
   Rectangle get();
   void set (Rectangle value);
}

Return Type

The Rectangle values set.

Remarks

Note: If the dimensions specified are all zeros or null, then no cropping occurs when loading.

Note: CameraRAW images can only be loaded from a filename. Loading from a stream is not supported as the entire image must be loaded before the raw format can be recognized.

See Also

LoadOptions Class | LoadOptions Members


HdPhoto Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

HdPhoto Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : HdPhoto Property

Gets and sets the HD Photo load options for the image.

[Visual Basic]
Public Property HdPhoto As LoadOptionsHdPhoto
[C#]
public LoadOptionsHdPhoto HdPhoto {get; set;}
[C++]
public: __property LoadOptionsHdPhoto* get_HdPhoto();
public: __property void set_HdPhoto(
   LoadOptionsHdPhoto* value
);
[C++/CLI]
public:
property LoadOptionsHdPhoto^ HdPhoto {
   LoadOptionsHdPhoto^ get();
   void set (LoadOptionsHdPhoto^ value);
}

Return Type

The LoadOptionsHdPhoto options.

See Also

LoadOptions Class | LoadOptions Members


ImageOffset Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageOffset Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : ImageOffset Property

Gets and sets the offset in the file or memory buffer where ImagXpress begins reading the image data.

[Visual Basic]
Public Property ImageOffset As Integer
[C#]
public int ImageOffset {get; set;}
[C++]
public: __property int get_ImageOffset();
public: __property void set_ImageOffset(
   int value
);
[C++/CLI]
public:
property int ImageOffset {
   int get();
   void set (int value);
}

Return Type

An integer which represents the offset value.

See Also

LoadOptions Class | LoadOptions Members


Internet Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Internet Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : Internet Property (LoadOptions)

Gets and sets the InternetOptions settings.

[Visual Basic]
Public Property Internet As InternetOptions
[C#]
public InternetOptions Internet {get; set;}
[C++]
public: __property InternetOptions* get_Internet();
public: __property void set_Internet(
   InternetOptions* value
);
[C++/CLI]
public:
property InternetOptions^ Internet {
   InternetOptions^ get();
   void set (InternetOptions^ value);
}

Return Type

The InternetOptions values set.

See Also

LoadOptions Class | LoadOptions Members


Jbig2 Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Jbig2 Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : Jbig2 Property (LoadOptions)

Gets and sets the specific LoadOptionsJbig2 applicable to a Jbig2 file format.

[Visual Basic]
Public Property Jbig2 As LoadOptionsJbig2
[C#]
public LoadOptionsJbig2 Jbig2 {get; set;}
[C++]
public: __property LoadOptionsJbig2* get_Jbig2();
public: __property void set_Jbig2(
   LoadOptionsJbig2* value
);
[C++/CLI]
public:
property LoadOptionsJbig2^ Jbig2 {
   LoadOptionsJbig2^ get();
   void set (LoadOptionsJbig2^ value);
}

Return Type

The LoadOptionsJbig2 values set.

See Also

LoadOptions Class | LoadOptions Members


Jpeg Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Jpeg Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : Jpeg Property (LoadOptions)

Gets and sets the specific LoadOptionsJpeg applicable to a JPEG file format.

[Visual Basic]
Public Property Jpeg As LoadOptionsJpeg
[C#]
public LoadOptionsJpeg Jpeg {get; set;}
[C++]
public: __property LoadOptionsJpeg* get_Jpeg();
public: __property void set_Jpeg(
   LoadOptionsJpeg* value
);
[C++/CLI]
public:
property LoadOptionsJpeg^ Jpeg {
   LoadOptionsJpeg^ get();
   void set (LoadOptionsJpeg^ value);
}

Return Type

The LoadOptionsJpeg values set.

See Also

LoadOptions Class | LoadOptions Members


LibraryNumberOfThreadsAllowed Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LibraryNumberOfThreadsAllowed Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : LibraryNumberOfThreadsAllowed Property (LoadOptions)

Gets or sets the library number of threads allowed.

[Visual Basic]
Public Property LibraryNumberOfThreadsAllowed As Integer
[C#]
public int LibraryNumberOfThreadsAllowed {get; set;}
[C++]
public: __property int get_LibraryNumberOfThreadsAllowed();
public: __property void set_LibraryNumberOfThreadsAllowed(
   int value
);
[C++/CLI]
public:
property int LibraryNumberOfThreadsAllowed {
   int get();
   void set (int value);
}

Return Type

The library number of threads allowed.

Remarks

This value is specific to the lower level libraries that ImagXpress uses. This value may or may not be honored depending on the image type. For instance, JPEG2000 images do currently support this feature.

See Also

LoadOptions Class | LoadOptions Members


LoadAlphaChannel Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadAlphaChannel Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : LoadAlphaChannel Property

Gets and sets if the alpha channel data is loaded.

[Visual Basic]
Public Property LoadAlphaChannel As Boolean
[C#]
public bool LoadAlphaChannel {get; set;}
[C++]
public: __property bool get_LoadAlphaChannel();
public: __property void set_LoadAlphaChannel(
   bool value
);
[C++/CLI]
public:
property bool LoadAlphaChannel {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to enable loading the alpha channel data. Otherwise, false is returned.

Remarks

Note: Available in all editions.

See Also

LoadOptions Class | LoadOptions Members


LoadMode Property

LoadOptions Class | LoadOptions Members | LoadMode Enumeration

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadMode Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : LoadMode Property (LoadOptions)

Gets and sets a load mode for how image data is interpreted as a raw image format or a standard format.

[Visual Basic]
Public Property LoadMode As LoadMode
[C#]
public LoadMode LoadMode {get; set;}
[C++]
public: __property LoadMode get_LoadMode();
public: __property void set_LoadMode(
   LoadMode value
);
[C++/CLI]
public:
property LoadMode LoadMode {
   LoadMode get();
   void set (LoadMode value);
}

Return Type

The LoadMode enumeration value set.

Remarks

When this property is set to Normal, the image is interpreted as having a standard image format, and image data is captured from the image upon loading into ImagXpress.

When this property is set to Raw, the image is interpreted as a raw image format when loading. The specific raw format is not detected automatically by ImagXpress. The application must specify additional information required to interpret the raw data.

Note: To specify that ImagXpress should examine the data and automatically detect the camera raw file format when loading an image, set the CameraRawEnabled property. This property is only used if the CameraRawEnabled property is set to false.

See Also

LoadOptions Class | LoadOptions Members | LoadMode Enumeration


LoadResizeAntiAlias Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadResizeAntiAlias Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : LoadResizeAntiAlias Property

Gets or sets a value indicating whether anti-aliasing is enabled during a load resize.

[Visual Basic]
Public Property LoadResizeAntiAlias As Boolean
[C#]
public bool LoadResizeAntiAlias {get; set;}
[C++]
public: __property bool get_LoadResizeAntiAlias();
public: __property void set_LoadResizeAntiAlias(
   bool value
);
[C++/CLI]
public:
property bool LoadResizeAntiAlias {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true if anti-alias enabled during a load resize; otherwise, false.

See Also

LoadOptions Class | LoadOptions Members


MaintainAspectRatio Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

MaintainAspectRatio Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : MaintainAspectRatio Property

Gets and sets the option to preserve image aspect ratio when resizing an image during the loading of the ImageX object.

[Visual Basic]
Public Property MaintainAspectRatio As Boolean
[C#]
public bool MaintainAspectRatio {get; set;}
[C++]
public: __property bool get_MaintainAspectRatio();
public: __property void set_MaintainAspectRatio(
   bool value
);
[C++/CLI]
public:
property bool MaintainAspectRatio {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to preserve the image aspect ratio when resizing the image during the loading of the ImageX object.

See Also

LoadOptions Class | LoadOptions Members


Metafile Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Metafile Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : Metafile Property

Gets and sets the specific LoadOptionsMetafile applicable to a metafile.

[Visual Basic]
Public Property Metafile As LoadOptionsMetafile
[C#]
public LoadOptionsMetafile Metafile {get; set;}
[C++]
public: __property LoadOptionsMetafile* get_Metafile();
public: __property void set_Metafile(
   LoadOptionsMetafile* value
);
[C++/CLI]
public:
property LoadOptionsMetafile^ Metafile {
   LoadOptionsMetafile^ get();
   void set (LoadOptionsMetafile^ value);
}

Return Type

The LoadOptionsMetafile values set.

See Also

LoadOptions Class | LoadOptions Members


Pdf Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Pdf Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : Pdf Property (LoadOptions)

Gets and sets the specific LoadOptionsPdf applicable to a PDF file format.

[Visual Basic]
Public Property Pdf As LoadOptionsPdf
[C#]
public LoadOptionsPdf Pdf {get; set;}
[C++]
public: __property LoadOptionsPdf* get_Pdf();
public: __property void set_Pdf(
   LoadOptionsPdf* value
);
[C++/CLI]
public:
property LoadOptionsPdf^ Pdf {
   LoadOptionsPdf^ get();
   void set (LoadOptionsPdf^ value);
}

Return Type

The LoadOptionsPdf values set.

See Also

LoadOptions Class | LoadOptions Members


Pic Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Pic Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : Pic Property (LoadOptions)

Gets and sets the specific LoadOptionsPic applicable to a PIC (Pegasus Imaging Corporation) file format.

[Visual Basic]
Public Property Pic As LoadOptionsPic
[C#]
public LoadOptionsPic Pic {get; set;}
[C++]
public: __property LoadOptionsPic* get_Pic();
public: __property void set_Pic(
   LoadOptionsPic* value
);
[C++/CLI]
public:
property LoadOptionsPic^ Pic {
   LoadOptionsPic^ get();
   void set (LoadOptionsPic^ value);
}

Return Type

The LoadOptionsPic values set.

See Also

LoadOptions Class | LoadOptions Members


PreserveBlack Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PreserveBlack Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : PreserveBlack Property (LoadOptions)

Gets and sets an indicator that preserve black should be applied to the image when it is loaded.

[Visual Basic]
Public Property PreserveBlack As Boolean
[C#]
public bool PreserveBlack {get; set;}
[C++]
public: __property bool get_PreserveBlack();
public: __property void set_PreserveBlack(
   bool value
);
[C++/CLI]
public:
property bool PreserveBlack {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true for black objects (such as lines) are to be enhanced to increase readability. Otherwise, false is returned and no black objects are applied.

Remarks

When this property is set to true, it enhances the black objects within an image to increase readability when zoom is applied.

Note: This property permanently modifies the image stored in the ImageX object.

Note: Available in all editions.

See Also

LoadOptions Class | LoadOptions Members


Raw Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Raw Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : Raw Property

Gets and sets the specific LoadOptionsRaw applicable to a RAW file.

[Visual Basic]
Public Property Raw As LoadOptionsRaw
[C#]
public LoadOptionsRaw Raw {get; set;}
[C++]
public: __property LoadOptionsRaw* get_Raw();
public: __property void set_Raw(
   LoadOptionsRaw* value
);
[C++/CLI]
public:
property LoadOptionsRaw^ Raw {
   LoadOptionsRaw^ get();
   void set (LoadOptionsRaw^ value);
}

Return Type

The LoadOptionsRaw values set.

Remarks

Note: Available in View, Document and Photo editions.

See Also

LoadOptions Class | LoadOptions Members


Resize Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Resize Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : Resize Property (LoadOptions)

Gets and sets the image height and width to which the image should be resized to when loading into an ImageX object.

[Visual Basic]
Public Property Resize As Size
[C#]
public Size Resize {get; set;}
[C++]
public: __property Size get_Resize();
public: __property void set_Resize(
   Size value
);
[C++/CLI]
public:
property Size Resize {
   Size get();
   void set (Size value);
}

Return Type

The Size set.

Remarks

Note: If the dimensions specified are all zeros or null, then no resizing occurs when loading.

Note: CameraRAW images can only be loaded from a filename. Loading from a stream is not supported as the entire image must be loaded before the raw format can be recognized.

See Also

LoadOptions Class | LoadOptions Members


Rotation Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Rotation Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : Rotation Property

Gets and sets the angle of rotation to apply to the image being loaded into the ImageX object.

[Visual Basic]
Public Property Rotation As RotateAngle
[C#]
public RotateAngle Rotation {get; set;}
[C++]
public: __property RotateAngle get_Rotation();
public: __property void set_Rotation(
   RotateAngle value
);
[C++/CLI]
public:
property RotateAngle Rotation {
   RotateAngle get();
   void set (RotateAngle value);
}

Return Type

The RotateAngle enumeration value set.

Remarks

If the rotation is set to 0 or null, then the image will not be rotated when loaded.

Note: CameraRAW images can only be loaded from a filename. Loading from a stream is not supported as the entire image must be loaded before the raw format can be recognized.

See Also

LoadOptions Class | LoadOptions Members


ScaleToGray Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ScaleToGray Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : ScaleToGray Property

Gets and sets an indicator if anti-aliasing/conversion to grayscale for 1 bpp images during a resizing load operation is enabled.

[Visual Basic]
Public Property ScaleToGray As Boolean
[C#]
public bool ScaleToGray {get; set;}
[C++]
public: __property bool get_ScaleToGray();
public: __property void set_ScaleToGray(
   bool value
);
[C++/CLI]
public:
property bool ScaleToGray {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to enable. Otherwise, false is returned.

Remarks

When this property is set to true, and the image is a 1 bit per pixel (black and white), the image is scaled to gray. The resulting image is an 8-bit per pixel grayscale image. Using this property is particularly useful when attempting to create a thumbnail image of the original that is visually pleasing.

Note: Available in View, Document and Photo editions.

See Also

LoadOptions Class | LoadOptions Members


SourceProfileName Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SourceProfileName Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : SourceProfileName Property

Gets and sets the name of the color profile to apply to the image being loaded.

[Visual Basic]
Public Property SourceProfileName As String
[C#]
public string SourceProfileName {get; set;}
[C++]
public: __property string* get_SourceProfileName();
public: __property void set_SourceProfileName(
   string* value
);
[C++/CLI]
public:
property String^ SourceProfileName {
   String^ get();
   void set (String^ value);
}

Return Type

A string which represents the source profile name.

Remarks

If the UseEmbeddedColorManagement property is set to false, then the source profile name specifies the file name of the color profile to apply to the image being loaded. If this property is null, and the UseEmbeddedColorManagement property is false, then no color management is performed when loading the image.

Note: This property is only available using the ImagXpress Photo edition. If you are licensed for Document, Standard or View editions and attempt to use this property, the operation does not execute and ImagXpress throws an exception. This property is useful to obtain a profile from a graphics device context if one is supported for the device.

See Also

LoadOptions Class | LoadOptions Members


ThumbnailSize Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ThumbnailSize Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : ThumbnailSize Property (LoadOptions)

Gets and sets if the image is loaded as a thumbnail with the thumbnail size.

[Visual Basic]
Public Property ThumbnailSize As ThumbnailSize
[C#]
public ThumbnailSize ThumbnailSize {get; set;}
[C++]
public: __property ThumbnailSize get_ThumbnailSize();
public: __property void set_ThumbnailSize(
   ThumbnailSize value
);
[C++/CLI]
public:
property ThumbnailSize ThumbnailSize {
   ThumbnailSize get();
   void set (ThumbnailSize value);
}

Return Type

The ThumbnailSize enumeration value set.

Remarks

In all cases the aspect ratio of the original image is maintained.

Note: Available in Standard, Document and Photo editions.

See Also

LoadOptions Class | LoadOptions Members


Tiff Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Tiff Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : Tiff Property (LoadOptions)

Gets and sets the specific LoadOptionsTiff applicable to a TIFF file format.

[Visual Basic]
Public Property Tiff As LoadOptionsTiff
[C#]
public LoadOptionsTiff Tiff {get; set;}
[C++]
public: __property LoadOptionsTiff* get_Tiff();
public: __property void set_Tiff(
   LoadOptionsTiff* value
);
[C++/CLI]
public:
property LoadOptionsTiff^ Tiff {
   LoadOptionsTiff^ get();
   void set (LoadOptionsTiff^ value);
}

Return Type

The LoadOptionsTiff values set.

See Also

LoadOptions Class | LoadOptions Members


UseEmbeddedColorManagement Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

UseEmbeddedColorManagement Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptions Class : UseEmbeddedColorManagement Property (LoadOptions)

Gets and sets the color profile included in the image metadata applied when loading the image.

[Visual Basic]
Public Property UseEmbeddedColorManagement As Boolean
[C#]
public bool UseEmbeddedColorManagement {get; set;}
[C++]
public: __property bool get_UseEmbeddedColorManagement();
public: __property void set_UseEmbeddedColorManagement(
   bool value
);
[C++/CLI]
public:
property bool UseEmbeddedColorManagement {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true when the color profile specified in the image's metadata is applied to the image when the image is loaded. Otherwise, false is returned.

Remarks

When this property is set to true, the color profile specified in the image's matadata is applied to the image when the image is loaded. Set this property to false to not include the color profile specified in the image's metadata.

See Also

LoadOptions Class | LoadOptions Members


LoadOptionsCad Class

LoadOptionsCad Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsCad Class

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsCad Class

This class contains the CAD data objects options when loading CAD files.

For a list of all members of this type, see LoadOptionsCad members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.LoadOptionsCad

Syntax

[Visual Basic]
Public Class LoadOptionsCad
[C#]
public class LoadOptionsCad
[C++]
public __gc class LoadOptionsCad
[C++/CLI]
public ref class LoadOptionsCad

See Also

LoadOptionsCad Members | PegasusImaging.WinForms.ImagXpress9 Namespace


LoadOptionsCad Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsCad Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsCad Class

LoadOptionsCad overview

Public Constructors

Public Constructor LoadOptionsCad Constructor The main constructor for the LoadOptionsCad class.

Public Properties

Public Property CadData | Gets and sets worker metadata information exchange.
Public Property LayoutToRender | Gets and sets the CAD layout to render.
Public Property PaperBitDepth | Gets and sets the CAD paper bit depth.
Public Property PaperHeight | Gets and sets the paper height for the CAD file.
Public Property PaperResolutionUnits | Gets and sets the paper resolution unit type (inches or centimeters).
Public Property PaperResolutionX | Gets and sets the dots per unit (inch, cm, etc.) for the paper horizontally.
Public Property PaperResolutionY | Gets and sets the dots per unit (inch or cm) for the paper vertically.
Public Property PaperWidth | Gets and sets the paper width for the CAD file.

See Also

LoadOptionsCad Class | PegasusImaging.WinForms.ImagXpress9 Namespace


LoadOptionsCad Constructor

LoadOptionsCad Class | LoadOptionsCad Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsCad Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsCad Class : LoadOptionsCad Constructor (LoadOptionsCad)

The main constructor for the LoadOptionsCad class.

[Visual Basic]
Public Function New()
[C#]
public LoadOptionsCad();
[C++]
public: LoadOptionsCad();
[C++/CLI]
public:
LoadOptionsCad();

See Also

LoadOptionsCad Class | LoadOptionsCad Members


LoadOptionsCad Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsCad Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsCad Class

For a list of all members of this type, see LoadOptionsCad members.

Public Properties

Public Property CadData | Gets and sets worker metadata information exchange.
Public Property LayoutToRender | Gets and sets the CAD layout to render.
Public Property PaperBitDepth | Gets and sets the CAD paper bit depth.
Public Property PaperHeight | Gets and sets the paper height for the CAD file.
Public Property PaperResolutionUnits | Gets and sets the paper resolution unit type (inches or centimeters).
Public Property PaperResolutionX | Gets and sets the dots per unit (inch, cm, etc.) for the paper horizontally.
Public Property PaperResolutionY | Gets and sets the dots per unit (inch or cm) for the paper vertically.
Public Property PaperWidth | Gets and sets the paper width for the CAD file.

See Also

LoadOptionsCad Class | PegasusImaging.WinForms.ImagXpress9 Namespace


CadData Property

LoadOptionsCad Class | LoadOptionsCad Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CadData Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsCad Class : CadData Property

Gets and sets worker metadata information exchange.

[Visual Basic]
Public Property CadData As ImageXData
[C#]
public ImageXData CadData {get; set;}
[C++]
public: __property ImageXData* get_CadData();
public: __property void set_CadData(
   ImageXData* value
);
[C++/CLI]
public:
property ImageXData^ CadData {
   ImageXData^ get();
   void set (ImageXData^ value);
}

Return Type

A ImageXData which contains metadata information.

Remarks

The DataObject from ImagX houses MetaData for Tiff, Exif and files with Iptc data.

See Also

LoadOptionsCad Class | LoadOptionsCad Members


LayoutToRender Property

LoadOptionsCad Class | LoadOptionsCad Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LayoutToRender Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsCad Class : LayoutToRender Property

Gets and sets the CAD layout to render.

[Visual Basic]
Public Property LayoutToRender As Integer
[C#]
public int LayoutToRender {get; set;}
[C++]
public: __property int get_LayoutToRender();
public: __property void set_LayoutToRender(
   int value
);
[C++/CLI]
public:
property int LayoutToRender {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the CAD layout.

Remarks

CAD files present different objects or portions of objects and structures to render by layouts. This value should not exceed the total number of layouts within the CAD file.

See Also

LoadOptionsCad Class | LoadOptionsCad Members


PaperBitDepth Property

LoadOptionsCad Class | LoadOptionsCad Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PaperBitDepth Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsCad Class : PaperBitDepth Property

Gets and sets the CAD paper bit depth.

[Visual Basic]
Public Property PaperBitDepth As Integer
[C#]
public int PaperBitDepth {get; set;}
[C++]
public: __property int get_PaperBitDepth();
public: __property void set_PaperBitDepth(
   int value
);
[C++/CLI]
public:
property int PaperBitDepth {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the CAD paper bit depth.

Remarks

Bitdepth affects image size and the maximum possible number of colors. Typically, 8 bit per color is sufficient for many 2D CAD drawings.

See Also

LoadOptionsCad Class | LoadOptionsCad Members


PaperHeight Property

LoadOptionsCad Class | LoadOptionsCad Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PaperHeight Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsCad Class : PaperHeight Property

Gets and sets the paper height for the CAD file.

[Visual Basic]
Public Property PaperHeight As Double
[C#]
public double PaperHeight {get; set;}
[C++]
public: __property double get_PaperHeight();
public: __property void set_PaperHeight(
   double value
);
[C++/CLI]
public:
property double PaperHeight {
   double get();
   void set (double value);
}

Return Type

A double value which represents the height of the paper.

Remarks

Works in conjunction with PaperResolutionY to set the image canvas neight in pixels.

See Also

LoadOptionsCad Class | LoadOptionsCad Members


PaperResolutionUnits Property

LoadOptionsCad Class | LoadOptionsCad Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PaperResolutionUnits Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsCad Class : PaperResolutionUnits Property

Gets and sets the paper resolution unit type (inches or centimeters).

[Visual Basic]
Public Property PaperResolutionUnits As ResolutionUnits
[C#]
public ResolutionUnits PaperResolutionUnits {get; set;}
[C++]
public: __property ResolutionUnits get_PaperResolutionUnits();
public: __property void set_PaperResolutionUnits(
   ResolutionUnits value
);
[C++/CLI]
public:
property ResolutionUnits PaperResolutionUnits {
   ResolutionUnits get();
   void set (ResolutionUnits value);
}

Return Type

A ResolutionUnits enumeration value which represents the units type.

See Also

LoadOptionsCad Class | LoadOptionsCad Members


PaperResolutionX Property

LoadOptionsCad Class | LoadOptionsCad Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PaperResolutionX Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsCad Class : PaperResolutionX Property

Gets and sets the dots per unit (inch, cm, etc.) for the paper horizontally.

[Visual Basic]
Public Property PaperResolutionX As Double
[C#]
public double PaperResolutionX {get; set;}
[C++]
public: __property double get_PaperResolutionX();
public: __property void set_PaperResolutionX(
   double value
);
[C++/CLI]
public:
property double PaperResolutionX {
   double get();
   void set (double value);
}

Return Type

A double value which represents the x coordinate for the CAD paper.

Remarks

Works in conjunction with PaperWidth to set the image canvas width in pixels.

See Also

LoadOptionsCad Class | LoadOptionsCad Members


PaperResolutionY Property

LoadOptionsCad Class | LoadOptionsCad Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PaperResolutionY Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsCad Class : PaperResolutionY Property

Gets and sets the dots per unit (inch or cm) for the paper vertically.

[Visual Basic]
Public Property PaperResolutionY As Double
[C#]
public double PaperResolutionY {get; set;}
[C++]
public: __property double get_PaperResolutionY();
public: __property void set_PaperResolutionY(
   double value
);
[C++/CLI]
public:
property double PaperResolutionY {
   double get();
   void set (double value);
}

Return Type

A double value which represents the y coordinate for the CAD paper.

Remarks

Works in conjunction with PaperHeight to set the image canvas width in pixels.

See Also

LoadOptionsCad Class | LoadOptionsCad Members


PaperWidth Property

LoadOptionsCad Class | LoadOptionsCad Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PaperWidth Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsCad Class : PaperWidth Property

Gets and sets the paper width for the CAD file.

[Visual Basic]
Public Property PaperWidth As Double
[C#]
public double PaperWidth {get; set;}
[C++]
public: __property double get_PaperWidth();
public: __property void set_PaperWidth(
   double value
);
[C++/CLI]
public:
property double PaperWidth {
   double get();
   void set (double value);
}

Return Type

A double value which represents the width of the paper.

Remarks

Works in conjunction with PaperResolutionX to set the image canvas width in pixels.

See Also

LoadOptionsCad Class | LoadOptionsCad Members


LoadOptionsHdPhoto Class

LoadOptionsHdPhoto Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsHdPhoto Class

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsHdPhoto Class

This class implements load options for the HD Photo file format.

For a list of all members of this type, see LoadOptionsHdPhoto members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.LoadOptionsHdPhoto

Syntax

[Visual Basic]
Public Class LoadOptionsHdPhoto
[C#]
public class LoadOptionsHdPhoto
[C++]
public __gc class LoadOptionsHdPhoto
[C++/CLI]
public ref class LoadOptionsHdPhoto

See Also

LoadOptionsHdPhoto Members | PegasusImaging.WinForms.ImagXpress9 Namespace


LoadOptionsHdPhoto Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsHdPhoto Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsHdPhoto Class

LoadOptionsHdPhoto overview

Public Constructors

Public Constructor LoadOptionsHdPhoto Constructor The main constructor for the LoadOptionsHdPhoto class.

Public Properties

Public Property PostProcessingFilter Gets or sets the post processing filter.

See Also

LoadOptionsHdPhoto Class | PegasusImaging.WinForms.ImagXpress9 Namespace


LoadOptionsHdPhoto Constructor

LoadOptionsHdPhoto Class | LoadOptionsHdPhoto Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsHdPhoto Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsHdPhoto Class : LoadOptionsHdPhoto Constructor (LoadOptionsHdPhoto)

The main constructor for the LoadOptionsHdPhoto class.

[Visual Basic]
Public Function New()
[C#]
public LoadOptionsHdPhoto();
[C++]
public: LoadOptionsHdPhoto();
[C++/CLI]
public:
LoadOptionsHdPhoto();

See Also

LoadOptionsHdPhoto Class | LoadOptionsHdPhoto Members


LoadOptionsHdPhoto Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsHdPhoto Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsHdPhoto Class

For a list of all members of this type, see LoadOptionsHdPhoto members.

Public Properties

Public Property PostProcessingFilter Gets or sets the post processing filter.

See Also

LoadOptionsHdPhoto Class | PegasusImaging.WinForms.ImagXpress9 Namespace


PostProcessingFilter Property

LoadOptionsHdPhoto Class | LoadOptionsHdPhoto Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PostProcessingFilter Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsHdPhoto Class : PostProcessingFilter Property

Gets or sets the post processing filter.

[Visual Basic]
Public Property PostProcessingFilter As HdpPostProcessFilter
[C#]
public HdpPostProcessFilter PostProcessingFilter {get; set;}
[C++]
public: __property HdpPostProcessFilter get_PostProcessingFilter();
public: __property void set_PostProcessingFilter(
   HdpPostProcessFilter value
);
[C++/CLI]
public:
property HdpPostProcessFilter PostProcessingFilter {
   HdpPostProcessFilter get();
   void set (HdpPostProcessFilter value);
}

Return Type

The HdpPostProcessFilter which represents the post processing filter.

See Also

LoadOptionsHdPhoto Class | LoadOptionsHdPhoto Members


LoadOptionsJbig2 Class

LoadOptionsJbig2 Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsJbig2 Class

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsJbig2 Class

This class implements load options for the Jbig2 file format.

For a list of all members of this type, see LoadOptionsJbig2 members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.LoadOptionsJbig2

Syntax

[Visual Basic]
Public Class LoadOptionsJbig2
[C#]
public class LoadOptionsJbig2
[C++]
public __gc class LoadOptionsJbig2
[C++/CLI]
public ref class LoadOptionsJbig2

See Also

LoadOptionsJbig2 Members | PegasusImaging.WinForms.ImagXpress9 Namespace


LoadOptionsJbig2 Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsJbig2 Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsJbig2 Class

LoadOptionsJbig2 overview

Public Constructors

Public Constructor LoadOptionsJbig2 Constructor The main constructor to initialize the LoadOptionsJbig2 object.

Public Properties

Public Property SwapBlackAndWhite Gets and sets an indicator which determines to use industry black and white defaults.

See Also

LoadOptionsJbig2 Class | PegasusImaging.WinForms.ImagXpress9 Namespace


LoadOptionsJbig2 Constructor

LoadOptionsJbig2 Class | LoadOptionsJbig2 Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsJbig2 Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsJbig2 Class : LoadOptionsJbig2 Constructor (LoadOptionsJbig2)

The main constructor to initialize the LoadOptionsJbig2 object.

[Visual Basic]
Public Function New()
[C#]
public LoadOptionsJbig2();
[C++]
public: LoadOptionsJbig2();
[C++/CLI]
public:
LoadOptionsJbig2();

See Also

LoadOptionsJbig2 Class | LoadOptionsJbig2 Members


LoadOptionsJbig2 Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsJbig2 Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsJbig2 Class

For a list of all members of this type, see LoadOptionsJbig2 members.

Public Properties

Public Property SwapBlackAndWhite Gets and sets an indicator which determines to use industry black and white defaults.

See Also

LoadOptionsJbig2 Class | PegasusImaging.WinForms.ImagXpress9 Namespace


SwapBlackAndWhite Property

LoadOptionsJbig2 Class | LoadOptionsJbig2 Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SwapBlackAndWhite Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsJbig2 Class : SwapBlackAndWhite Property (LoadOptionsJbig2)

Gets and sets an indicator which determines to use industry black and white defaults.

[Visual Basic]
Public Property SwapBlackAndWhite As Boolean
[C#]
public bool SwapBlackAndWhite {get; set;}
[C++]
public: __property bool get_SwapBlackAndWhite();
public: __property void set_SwapBlackAndWhite(
   bool value
);
[C++/CLI]
public:
property bool SwapBlackAndWhite {
   bool get();
   void set (bool value);
}

Remarks

The default value is false.

false (0) - Black is zero and white is one.

true (1) - White is zero and black is one.

See Also

LoadOptionsJbig2 Class | LoadOptionsJbig2 Members


LoadOptionsJpeg Class

LoadOptionsJpeg Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsJpeg Class

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsJpeg Class

This class implements load options for the JPEG file format.

For a list of all members of this type, see LoadOptionsJpeg members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.LoadOptionsJpeg

Syntax

[Visual Basic]
Public Class LoadOptionsJpeg
[C#]
public class LoadOptionsJpeg
[C++]
public __gc class LoadOptionsJpeg
[C++/CLI]
public ref class LoadOptionsJpeg

See Also

LoadOptionsJpeg Members | PegasusImaging.WinForms.ImagXpress9 Namespace


LoadOptionsJpeg Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsJpeg Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsJpeg Class

LoadOptionsJpeg overview

Public Constructors

Public Constructor LoadOptionsJpeg Constructor The main constructor for the LoadOptionsJpeg class.

Public Properties

Public Property Cosited | Gets and sets if the image was compressed with cosited subsampling.
Public Property Enhanced | Gets and sets the JPEG enhanced decompression flag indicating whether to use standard decoding or Pegasus enhanced decoding.

See Also

LoadOptionsJpeg Class | PegasusImaging.WinForms.ImagXpress9 Namespace


LoadOptionsJpeg Constructor

LoadOptionsJpeg Class | LoadOptionsJpeg Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsJpeg Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsJpeg Class : LoadOptionsJpeg Constructor (LoadOptionsJpeg)

The main constructor for the LoadOptionsJpeg class.

[Visual Basic]
Public Function New()
[C#]
public LoadOptionsJpeg();
[C++]
public: LoadOptionsJpeg();
[C++/CLI]
public:
LoadOptionsJpeg();

See Also

LoadOptionsJpeg Class | LoadOptionsJpeg Members


LoadOptionsJpeg Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsJpeg Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsJpeg Class

For a list of all members of this type, see LoadOptionsJpeg members.

Public Properties

Public Property Cosited | Gets and sets if the image was compressed with cosited subsampling.
Public Property Enhanced | Gets and sets the JPEG enhanced decompression flag indicating whether to use standard decoding or Pegasus enhanced decoding.

See Also

LoadOptionsJpeg Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Cosited Property

LoadOptionsJpeg Class | LoadOptionsJpeg Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Cosited Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsJpeg Class : Cosited Property (LoadOptionsJpeg)

Gets and sets if the image was compressed with cosited subsampling.

[Visual Basic]
Public Property Cosited As Boolean
[C#]
public bool Cosited {get; set;}
[C++]
public: __property bool get_Cosited();
public: __property void set_Cosited(
   bool value
);
[C++/CLI]
public:
property bool Cosited {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true if the image was compressed with cosited subsampling. Otherwise, false is returned.

Remarks

There is no flag in JPEG files to indicate compression with cosited (2-1-1) subsampling. Therefore, this fact must be determined independently by the application performing the file load method.

Note: Available in all editions.

See Also

LoadOptionsJpeg Class | LoadOptionsJpeg Members


Enhanced Property

LoadOptionsJpeg Class | LoadOptionsJpeg Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Enhanced Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsJpeg Class : Enhanced Property

Gets and sets the JPEG enhanced decompression flag indicating whether to use standard decoding or Pegasus enhanced decoding.

[Visual Basic]
Public Property Enhanced As Boolean
[C#]
public bool Enhanced {get; set;}
[C++]
public: __property bool get_Enhanced();
public: __property void set_Enhanced(
   bool value
);
[C++/CLI]
public:
property bool Enhanced {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true for the JPEG decoder to use the enhanced method to give a smoother image. If false is set, the JPEG decoder uses the standard method to decode the JPEG image.

Remarks

This property enables advanced Pegasus Imaging technology that provides significantly better image viewing for highly compressed sequential JPEG images.

The following features are enabled:

  • Reduce Contouring
  • Reduce Artifacts
  • Reduce Block Edge Artifacts

Note: Available in all editions.

See Also

LoadOptionsJpeg Class | LoadOptionsJpeg Members


LoadOptionsMetafile Class

LoadOptionsMetafile Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsMetafile Class

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsMetafile Class

This class implements load options for metafiles.

For a list of all members of this type, see LoadOptionsMetafile members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.LoadOptionsMetafile

Syntax

[Visual Basic]
Public Class LoadOptionsMetafile
[C#]
public class LoadOptionsMetafile
[C++]
public __gc class LoadOptionsMetafile
[C++/CLI]
public ref class LoadOptionsMetafile

See Also

LoadOptionsMetafile Members | PegasusImaging.WinForms.ImagXpress9 Namespace


LoadOptionsMetafile Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsMetafile Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsMetafile Class

LoadOptionsMetafile overview

Public Constructors

Public Constructor LoadOptionsMetafile Constructor The main constructor for initializing the LoadOptionsMetafile class.

Public Fields

Public Field static (Shared in Visual Basic) DefaultHoriztonalResolution
Public Field static (Shared in Visual Basic) DefaultUnits
Public Field static (Shared in Visual Basic) DefaultVerticalResolution

Public Properties

Public Property ConvertToDib | Gets and sets an indicator if the image being loaded is to be converted to a DIB and stored in the ImageX object.
Public Property Resolution | Gets and sets the resolution at which to load the image.

See Also

LoadOptionsMetafile Class | PegasusImaging.WinForms.ImagXpress9 Namespace


LoadOptionsMetafile Constructor

LoadOptionsMetafile Class | LoadOptionsMetafile Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsMetafile Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsMetafile Class : LoadOptionsMetafile Constructor (LoadOptionsMetafile)

The main constructor for initializing the LoadOptionsMetafile class.

[Visual Basic]
Public Function New()
[C#]
public LoadOptionsMetafile();
[C++]
public: LoadOptionsMetafile();
[C++/CLI]
public:
LoadOptionsMetafile();

See Also

LoadOptionsMetafile Class | LoadOptionsMetafile Members


LoadOptionsMetafile Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsMetafile Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsMetafile Class

For a list of all members of this type, see LoadOptionsMetafile members.

Public Properties

Public Property ConvertToDib | Gets and sets an indicator if the image being loaded is to be converted to a DIB and stored in the ImageX object.
Public Property Resolution | Gets and sets the resolution at which to load the image.

See Also

LoadOptionsMetafile Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ConvertToDib Property

LoadOptionsMetafile Class | LoadOptionsMetafile Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ConvertToDib Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsMetafile Class : ConvertToDib Property

Gets and sets an indicator if the image being loaded is to be converted to a DIB and stored in the ImageX object.

[Visual Basic]
Public Property ConvertToDib As Boolean
[C#]
public bool ConvertToDib {get; set;}
[C++]
public: __property bool get_ConvertToDib();
public: __property void set_ConvertToDib(
   bool value
);
[C++/CLI]
public:
property bool ConvertToDib {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true if the image loaded is to be converted to a DIB. Otherwise, false is returned.

See Also

LoadOptionsMetafile Class | LoadOptionsMetafile Members


Resolution Property

LoadOptionsMetafile Class | LoadOptionsMetafile Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Resolution Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsMetafile Class : Resolution Property (LoadOptionsMetafile)

Gets and sets the resolution at which to load the image.

[Visual Basic]
Public Property Resolution As Resolution
[C#]
public Resolution Resolution {get; set;}
[C++]
public: __property Resolution* get_Resolution();
public: __property void set_Resolution(
   Resolution* value
);
[C++/CLI]
public:
property Resolution^ Resolution {
   Resolution^ get();
   void set (Resolution^ value);
}

Return Type

The Resolution for loading the image.

See Also

LoadOptionsMetafile Class | LoadOptionsMetafile Members


LoadOptionsMetafile Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsMetafile Class Fields

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsMetafile Class

For a list of all members of this type, see LoadOptionsMetafile members.

Public Fields

Public Field static (Shared in Visual Basic) DefaultHoriztonalResolution
Public Field static (Shared in Visual Basic) DefaultUnits
Public Field static (Shared in Visual Basic) DefaultVerticalResolution

See Also

LoadOptionsMetafile Class | PegasusImaging.WinForms.ImagXpress9 Namespace


DefaultHoriztonalResolution Field

LoadOptionsMetafile Class | LoadOptionsMetafile Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DefaultHoriztonalResolution Field

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsMetafile Class : DefaultHoriztonalResolution Field
[Visual Basic]
Public Shared DefaultHoriztonalResolution As Single
[C#]
public static float DefaultHoriztonalResolution
[C++]
public: static float DefaultHoriztonalResolution
[C++/CLI]
public:
static float DefaultHoriztonalResolution

See Also

LoadOptionsMetafile Class | LoadOptionsMetafile Members


DefaultUnits Field

LoadOptionsMetafile Class | LoadOptionsMetafile Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DefaultUnits Field

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsMetafile Class : DefaultUnits Field
[Visual Basic]
Public Shared DefaultUnits As GraphicsUnit
[C#]
public static GraphicsUnit DefaultUnits
[C++]
public: static GraphicsUnit DefaultUnits
[C++/CLI]
public:
static GraphicsUnit DefaultUnits

See Also

LoadOptionsMetafile Class | LoadOptionsMetafile Members


DefaultVerticalResolution Field

LoadOptionsMetafile Class | LoadOptionsMetafile Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DefaultVerticalResolution Field

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsMetafile Class : DefaultVerticalResolution Field
[Visual Basic]
Public Shared DefaultVerticalResolution As Single
[C#]
public static float DefaultVerticalResolution
[C++]
public: static float DefaultVerticalResolution
[C++/CLI]
public:
static float DefaultVerticalResolution

See Also

LoadOptionsMetafile Class | LoadOptionsMetafile Members


LoadOptionsPdf Class

LoadOptionsPdf Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsPdf Class

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsPdf Class

This class implements load options for PDF files.

For a list of all members of this type, see LoadOptionsPdf members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.LoadOptionsPdf

Syntax

[Visual Basic]
Public Class LoadOptionsPdf
[C#]
public class LoadOptionsPdf
[C++]
public __gc class LoadOptionsPdf
[C++/CLI]
public ref class LoadOptionsPdf

See Also

LoadOptionsPdf Members | PegasusImaging.WinForms.ImagXpress9 Namespace


LoadOptionsPdf Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsPdf Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsPdf Class

LoadOptionsPdf overview

Public Constructors

Public Constructor LoadOptionsPdf Constructor The main constructor for the LoadOptionsPdf class.

Public Properties

Public Property SwapBlackAndWhite Gets and sets a pixel value of zero to black or white.

See Also

LoadOptionsPdf Class | PegasusImaging.WinForms.ImagXpress9 Namespace


LoadOptionsPdf Constructor

LoadOptionsPdf Class | LoadOptionsPdf Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsPdf Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsPdf Class : LoadOptionsPdf Constructor (LoadOptionsPdf)

The main constructor for the LoadOptionsPdf class.

[Visual Basic]
Public Function New()
[C#]
public LoadOptionsPdf();
[C++]
public: LoadOptionsPdf();
[C++/CLI]
public:
LoadOptionsPdf();

See Also

LoadOptionsPdf Class | LoadOptionsPdf Members


LoadOptionsPdf Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsPdf Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsPdf Class

For a list of all members of this type, see LoadOptionsPdf members.

Public Properties

Public Property SwapBlackAndWhite Gets and sets a pixel value of zero to black or white.

See Also

LoadOptionsPdf Class | PegasusImaging.WinForms.ImagXpress9 Namespace


SwapBlackAndWhite Property

LoadOptionsPdf Class | LoadOptionsPdf Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SwapBlackAndWhite Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsPdf Class : SwapBlackAndWhite Property (LoadOptionsPdf)

Gets and sets a pixel value of zero to black or white.

[Visual Basic]
Public Property SwapBlackAndWhite As Boolean
[C#]
public bool SwapBlackAndWhite {get; set;}
[C++]
public: __property bool get_SwapBlackAndWhite();
public: __property void set_SwapBlackAndWhite(
   bool value
);
[C++/CLI]
public:
property bool SwapBlackAndWhite {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true when the definition of black and white are reversed when loading the image: 1 = black and 0 = white. Otherwise, false is returned.

Remarks

This property pertains only to the G4 (CCITT fax protocol) compression type.

See Also

LoadOptionsPdf Class | LoadOptionsPdf Members


LoadOptionsPic Class

LoadOptionsPic Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsPic Class

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsPic Class

This class implements the load options for the Pegasus Imaging Corporation file format.

For a list of all members of this type, see LoadOptionsPic members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.LoadOptionsPic

Syntax

[Visual Basic]
Public Class LoadOptionsPic
[C#]
public class LoadOptionsPic
[C++]
public __gc class LoadOptionsPic
[C++/CLI]
public ref class LoadOptionsPic

Remarks

Use this class for PIC specific file reading functionality.

See Also

LoadOptionsPic Members | PegasusImaging.WinForms.ImagXpress9 Namespace


LoadOptionsPic Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsPic Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsPic Class

LoadOptionsPic overview

Public Constructors

Public Constructor LoadOptionsPic Constructor The main constructor initializing the LoadOptionsPic class.

Public Properties

Public Property Password Gets and sets the password for an encrypted Pegasus Imaging Corporation (ePIC) file format.

See Also

LoadOptionsPic Class | PegasusImaging.WinForms.ImagXpress9 Namespace


LoadOptionsPic Constructor

LoadOptionsPic Class | LoadOptionsPic Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsPic Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsPic Class : LoadOptionsPic Constructor (LoadOptionsPic)

The main constructor initializing the LoadOptionsPic class.

[Visual Basic]
Public Function New()
[C#]
public LoadOptionsPic();
[C++]
public: LoadOptionsPic();
[C++/CLI]
public:
LoadOptionsPic();

See Also

LoadOptionsPic Class | LoadOptionsPic Members


LoadOptionsPic Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsPic Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsPic Class

For a list of all members of this type, see LoadOptionsPic members.

Public Properties

Public Property Password Gets and sets the password for an encrypted Pegasus Imaging Corporation (ePIC) file format.

See Also

LoadOptionsPic Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Password Property

LoadOptionsPic Class | LoadOptionsPic Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Password Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsPic Class : Password Property (LoadOptionsPic)

Gets and sets the password for an encrypted Pegasus Imaging Corporation (ePIC) file format.

[Visual Basic]
Public Property Password As String
[C#]
public string Password {get; set;}
[C++]
public: __property string* get_Password();
public: __property void set_Password(
   string* value
);
[C++/CLI]
public:
property String^ Password {
   String^ get();
   void set (String^ value);
}

Return Type

A string value which represents the password.

See Also

LoadOptionsPic Class | LoadOptionsPic Members


LoadOptionsRaw Class

LoadOptionsRaw Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsRaw Class

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsRaw Class

This class specifies image information that cannot be detected when loading a RAW image format.

For a list of all members of this type, see LoadOptionsRaw members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.LoadOptionsRaw

Syntax

[Visual Basic]
Public Class LoadOptionsRaw
[C#]
public class LoadOptionsRaw
[C++]
public __gc class LoadOptionsRaw
[C++/CLI]
public ref class LoadOptionsRaw

Remarks

When the LoadOptions.LoadMode is set to Raw to indicate that the image being loaded is in a raw file format, the application must specify a bit depth, size, and pixel format to use when interpreting the image data, as these attributes are not available from the raw image file.

See Also

LoadOptionsRaw Members | PegasusImaging.WinForms.ImagXpress9 Namespace


LoadOptionsRaw Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsRaw Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsRaw Class

LoadOptionsRaw overview

Public Constructors

Public Constructor LoadOptionsRaw Constructor The main constructor to initialize the class.

Public Properties

Public Property BitsPerPixel | Gets and sets the bit depth of the image being loaded.
Public Property BytesPerPixel | Gets and sets the number of bytes in the image utilized to represent a single pixel.
Public Property Height | Gets and sets the height, in pixels, of the image being loaded.
Public Property HighBitIndex | Gets and sets the number of bits to process.
Public Property PixelFormat | Gets and sets the type of pixel system employed with the current image.
Public Property Stride | Gets and sets the length (in bytes) of a scan line of the image to be loaded.
Public Property Width | Gets and sets the width, in pixels, of the image being loaded.

See Also

LoadOptionsRaw Class | PegasusImaging.WinForms.ImagXpress9 Namespace


LoadOptionsRaw Constructor

LoadOptionsRaw Class | LoadOptionsRaw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsRaw Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsRaw Class : LoadOptionsRaw Constructor (LoadOptionsRaw)

The main constructor to initialize the class.

[Visual Basic]
Public Function New()
[C#]
public LoadOptionsRaw();
[C++]
public: LoadOptionsRaw();
[C++/CLI]
public:
LoadOptionsRaw();

See Also

LoadOptionsRaw Class | LoadOptionsRaw Members


LoadOptionsRaw Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsRaw Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsRaw Class

For a list of all members of this type, see LoadOptionsRaw members.

Public Properties

Public Property BitsPerPixel | Gets and sets the bit depth of the image being loaded.
Public Property BytesPerPixel | Gets and sets the number of bytes in the image utilized to represent a single pixel.
Public Property Height | Gets and sets the height, in pixels, of the image being loaded.
Public Property HighBitIndex | Gets and sets the number of bits to process.
Public Property PixelFormat | Gets and sets the type of pixel system employed with the current image.
Public Property Stride | Gets and sets the length (in bytes) of a scan line of the image to be loaded.
Public Property Width | Gets and sets the width, in pixels, of the image being loaded.

See Also

LoadOptionsRaw Class | PegasusImaging.WinForms.ImagXpress9 Namespace


BitsPerPixel Property

LoadOptionsRaw Class | LoadOptionsRaw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

BitsPerPixel Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsRaw Class : BitsPerPixel Property (LoadOptionsRaw)

Gets and sets the bit depth of the image being loaded.

[Visual Basic]
Public Property BitsPerPixel As Integer
[C#]
public int BitsPerPixel {get; set;}
[C++]
public: __property int get_BitsPerPixel();
public: __property void set_BitsPerPixel(
   int value
);
[C++/CLI]
public:
property int BitsPerPixel {
   int get();
   void set (int value);
}

Return Type

An integer which represents the bit depth of the image being loaded.

See Also

LoadOptionsRaw Class | LoadOptionsRaw Members


BytesPerPixel Property

LoadOptionsRaw Class | LoadOptionsRaw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

BytesPerPixel Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsRaw Class : BytesPerPixel Property

Gets and sets the number of bytes in the image utilized to represent a single pixel.

[Visual Basic]
Public Property BytesPerPixel As Integer
[C#]
public int BytesPerPixel {get; set;}
[C++]
public: __property int get_BytesPerPixel();
public: __property void set_BytesPerPixel(
   int value
);
[C++/CLI]
public:
property int BytesPerPixel {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the number of bytes in the image utilized to represent a single pixel.

See Also

LoadOptionsRaw Class | LoadOptionsRaw Members


Height Property

LoadOptionsRaw Class | LoadOptionsRaw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Height Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsRaw Class : Height Property (LoadOptionsRaw)

Gets and sets the height, in pixels, of the image being loaded.

[Visual Basic]
Public Property Height As Integer
[C#]
public int Height {get; set;}
[C++]
public: __property int get_Height();
public: __property void set_Height(
   int value
);
[C++/CLI]
public:
property int Height {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the height of the image being loaded.

See Also

LoadOptionsRaw Class | LoadOptionsRaw Members


HighBitIndex Property

LoadOptionsRaw Class | LoadOptionsRaw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

HighBitIndex Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsRaw Class : HighBitIndex Property

Gets and sets the number of bits to process.

[Visual Basic]
Public Property HighBitIndex As Integer
[C#]
public int HighBitIndex {get; set;}
[C++]
public: __property int get_HighBitIndex();
public: __property void set_HighBitIndex(
   int value
);
[C++/CLI]
public:
property int HighBitIndex {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the number of bits to process.

Remarks

Valid values are 0 to 15.

When zero (0) is set, all bits are used. Any other value restricts the number of bits to interpret.

See Also

LoadOptionsRaw Class | LoadOptionsRaw Members


PixelFormat Property

LoadOptionsRaw Class | LoadOptionsRaw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PixelFormat Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsRaw Class : PixelFormat Property

Gets and sets the type of pixel system employed with the current image.

[Visual Basic]
Public Property PixelFormat As ImageXPixelFormat
[C#]
public ImageXPixelFormat PixelFormat {get; set;}
[C++]
public: __property ImageXPixelFormat get_PixelFormat();
public: __property void set_PixelFormat(
   ImageXPixelFormat value
);
[C++/CLI]
public:
property ImageXPixelFormat PixelFormat {
   ImageXPixelFormat get();
   void set (ImageXPixelFormat value);
}

Return Type

The ImageXPixelFormat enumeration option value set.

See Also

LoadOptionsRaw Class | LoadOptionsRaw Members


Stride Property

LoadOptionsRaw Class | LoadOptionsRaw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Stride Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsRaw Class : Stride Property (LoadOptionsRaw)

Gets and sets the length (in bytes) of a scan line of the image to be loaded.

[Visual Basic]
Public Property Stride As Integer
[C#]
public int Stride {get; set;}
[C++]
public: __property int get_Stride();
public: __property void set_Stride(
   int value
);
[C++/CLI]
public:
property int Stride {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the length of a scan line of the image being loaded.

See Also

LoadOptionsRaw Class | LoadOptionsRaw Members


Width Property

LoadOptionsRaw Class | LoadOptionsRaw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Width Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsRaw Class : Width Property (LoadOptionsRaw)

Gets and sets the width, in pixels, of the image being loaded.

[Visual Basic]
Public Property Width As Integer
[C#]
public int Width {get; set;}
[C++]
public: __property int get_Width();
public: __property void set_Width(
   int value
);
[C++/CLI]
public:
property int Width {
   int get();
   void set (int value);
}

Return Type

An integer which represents the width of the image being loaded.

See Also

LoadOptionsRaw Class | LoadOptionsRaw Members


LoadOptionsTiff Class

LoadOptionsTiff Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsTiff Class

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsTiff Class

This class implements the load options for TIFF files.

For a list of all members of this type, see LoadOptionsTiff members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.LoadOptionsTiff

Syntax

[Visual Basic]
Public Class LoadOptionsTiff
[C#]
public class LoadOptionsTiff
[C++]
public __gc class LoadOptionsTiff
[C++/CLI]
public ref class LoadOptionsTiff

Remarks

Use this class for TIFF specific file reading functionality.

See Also

LoadOptionsTiff Members | PegasusImaging.WinForms.ImagXpress9 Namespace


LoadOptionsTiff Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsTiff Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsTiff Class

LoadOptionsTiff overview

Public Constructors

Public Constructor LoadOptionsTiff Constructor The main constructor to initialize a new instance of the LoadOptionsTiff class.

Public Properties

Public Property IFDOffset | Gets and sets the number of bytes preceding the IFD (Image File Directory).
Public Property SpecialHandling | Gets and sets an indicator if the image being loaded is an abnormally formatted TIFF file.

See Also

LoadOptionsTiff Class | PegasusImaging.WinForms.ImagXpress9 Namespace


LoadOptionsTiff Constructor

LoadOptionsTiff Class | LoadOptionsTiff Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsTiff Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsTiff Class : LoadOptionsTiff Constructor (LoadOptionsTiff)

The main constructor to initialize a new instance of the LoadOptionsTiff class.

[Visual Basic]
Public Function New()
[C#]
public LoadOptionsTiff();
[C++]
public: LoadOptionsTiff();
[C++/CLI]
public:
LoadOptionsTiff();

See Also

LoadOptionsTiff Class | LoadOptionsTiff Members


LoadOptionsTiff Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadOptionsTiff Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadOptionsTiff Class

For a list of all members of this type, see LoadOptionsTiff members.

Public Properties

Public Property IFDOffset | Gets and sets the number of bytes preceding the IFD (Image File Directory).
Public Property SpecialHandling | Gets and sets an indicator if the image being loaded is an abnormally formatted TIFF file.

See Also

LoadOptionsTiff Class | PegasusImaging.WinForms.ImagXpress9 Namespace


IFDOffset Property

LoadOptionsTiff Class | LoadOptionsTiff Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

IFDOffset Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsTiff Class : IFDOffset Property (LoadOptionsTiff)

Gets and sets the number of bytes preceding the IFD (Image File Directory).

[Visual Basic]
Public Property IFDOffset As Integer
[C#]
public int IFDOffset {get; set;}
[C++]
public: __property int get_IFDOffset();
public: __property void set_IFDOffset(
   int value
);
[C++/CLI]
public:
property int IFDOffset {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the number of bytes preceding the IFD.

Remarks

This property specifies where ImagXpress begins reading image data within the TIFF image file.

See Also

LoadOptionsTiff Class | LoadOptionsTiff Members


SpecialHandling Property

LoadOptionsTiff Class | LoadOptionsTiff Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SpecialHandling Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LoadOptionsTiff Class : SpecialHandling Property

Gets and sets an indicator if the image being loaded is an abnormally formatted TIFF file.

[Visual Basic]
Public Property SpecialHandling As Boolean
[C#]
public bool SpecialHandling {get; set;}
[C++]
public: __property bool get_SpecialHandling();
public: __property void set_SpecialHandling(
   bool value
);
[C++/CLI]
public:
property bool SpecialHandling {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true if special handling is required. Otherwise, false.

See Also

LoadOptionsTiff Class | LoadOptionsTiff Members


LookupTable Class

LookupTable Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LookupTable Class

PegasusImaging.WinForms.ImagXpress9 Namespace : LookupTable Class

A class for specifying a lookup table to be used with the Medical class.

For a list of all members of this type, see LookupTable members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.LookupTable

Syntax

[Visual Basic]
Public Class LookupTable
[C#]
public class LookupTable
[C++]
public __gc class LookupTable
[C++/CLI]
public ref class LookupTable

Remarks

The lookup table contains an array of Bytes for the actual Table and also members to determine how that Table is to be interpreted.

See Also

LookupTable Members | PegasusImaging.WinForms.ImagXpress9 Namespace


LookupTable Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LookupTable Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : LookupTable Class

LookupTable overview

Public Constructors

Public Constructor LookupTable Constructor The main constructor to initialize a new instance of the LookupTable class.

Public Properties

Public Property Enabled | Gets and sets a value to specify whether the Lookup Table should be used for non-linear conversion or wherever the properties should be used for a linear conversion.
Public Property FirstValueMapped | Gets and sets the stored pixel value mapped to the first entry in the Lookup Table.
Public Property NumberOfBits | Gets and sets the number of bits allocated for each entry in the lookup table.
Public Property Table | Gets and set the look up table itself which is an array of bytes.

See Also

LookupTable Class | PegasusImaging.WinForms.ImagXpress9 Namespace


LookupTable Constructor

LookupTable Class | LookupTable Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LookupTable Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > LookupTable Class : LookupTable Constructor (LookupTable)

The main constructor to initialize a new instance of the LookupTable class.

[Visual Basic]
Public Function New()
[C#]
public LookupTable();
[C++]
public: LookupTable();
[C++/CLI]
public:
LookupTable();

See Also

LookupTable Class | LookupTable Members


LookupTable Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LookupTable Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : LookupTable Class

For a list of all members of this type, see LookupTable members.

Public Properties

Public Property Enabled | Gets and sets a value to specify whether the Lookup Table should be used for non-linear conversion or wherever the properties should be used for a linear conversion.
Public Property FirstValueMapped | Gets and sets the stored pixel value mapped to the first entry in the Lookup Table.
Public Property NumberOfBits | Gets and sets the number of bits allocated for each entry in the lookup table.
Public Property Table | Gets and set the look up table itself which is an array of bytes.

See Also

LookupTable Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Enabled Property

LookupTable Class | LookupTable Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Enabled Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LookupTable Class : Enabled Property (LookupTable)

Gets and sets a value to specify whether the Lookup Table should be used for non-linear conversion or wherever the properties should be used for a linear conversion.

[Visual Basic]
Public Property Enabled As Boolean
[C#]
public bool Enabled {get; set;}
[C++]
public: __property bool get_Enabled();
public: __property void set_Enabled(
   bool value
);
[C++/CLI]
public:
property bool Enabled {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to enable the lookup table. Otherwise, false is returned.

See Also

LookupTable Class | LookupTable Members


FirstValueMapped Property

LookupTable Class | LookupTable Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

FirstValueMapped Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LookupTable Class : FirstValueMapped Property

Gets and sets the stored pixel value mapped to the first entry in the Lookup Table.

[Visual Basic]
Public Property FirstValueMapped As Integer
[C#]
public int FirstValueMapped {get; set;}
[C++]
public: __property int get_FirstValueMapped();
public: __property void set_FirstValueMapped(
   int value
);
[C++/CLI]
public:
property int FirstValueMapped {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the pixel value mapped to the first entry in the Lookup Table.

Remarks

All values less than this pixel value are also mapped to the first entry.

This value corresponds to the second value found in the LUT Descriptor (0028, 3002).

See Also

LookupTable Class | LookupTable Members


NumberOfBits Property

LookupTable Class | LookupTable Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

NumberOfBits Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LookupTable Class : NumberOfBits Property

Gets and sets the number of bits allocated for each entry in the lookup table.

[Visual Basic]
Public Property NumberOfBits As Integer
[C#]
public int NumberOfBits {get; set;}
[C++]
public: __property int get_NumberOfBits();
public: __property void set_NumberOfBits(
   int value
);
[C++/CLI]
public:
property int NumberOfBits {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the number of bits allocated for each entry in the lookup table.

Remarks

Valid values are 8 or 16.

This value corresponds with the third value in the LUT (Look UP Table) Descriptor (0028, 3002).

See Also

LookupTable Class | LookupTable Members


Table Property

LookupTable Class | LookupTable Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Table Property

PegasusImaging.WinForms.ImagXpress9 Namespace > LookupTable Class : Table Property

Gets and set the look up table itself which is an array of bytes.

[Visual Basic]
Public Property Table As Byte()
[C#]
public byte[] Table {get; set;}
[C++]
public: __property byte[]* get_Table();
public: __property void set_Table(
   byte[]* value
);
[C++/CLI]
public:
property array<byte>^ Table {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Type

A byte array which corresponds with the values found in the LUT Descriptor.

Remarks

LUT (Look Up Table) Data corresponding with DICOM tag (0028, 3006). Create an array of bytes with the number of entries which corresponds with the first value found in the LUT Descriptor (0028, 3002). If the NumberOfBits property is 16, then the array of bytes should be sized to twice the number of entries.

See Also

LookupTable Class | LookupTable Members


Medical Class

Medical Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Medical Class

PegasusImaging.WinForms.ImagXpress9 Namespace : Medical Class (PegasusImaging.WinForms.ImagXpress9)

The Medical class is an encapsulation of the properties needed to do a DICOM (Digital Imaging and Communications in Medicine) grayscale transformation.

For a list of all members of this type, see Medical members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.Medical

Syntax

[Visual Basic]
Public Class Medical
[C#]
public class Medical
[C++]
public __gc class Medical
[C++/CLI]
public ref class Medical

Remarks

They can be used both for viewing and for applying the transformation permanently.

See Also

Medical Members | PegasusImaging.WinForms.ImagXpress9 Namespace


Medical Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Medical Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : Medical Class (PegasusImaging.WinForms.ImagXpress9)

Medical overview

Public Constructors

Public Constructor Medical Constructor The main constructor to initialize a new instance of the Medical class.

Public Properties

Public Property ModalityLookupTable | Gets and sets a DICOM Modality Look Up Table.
Public Property PhotometricInterpretation | Gets and sets whether a zero in the image data is black or white.
Public Property RescaleIntercept | Gets and sets the intercept used to specify a linear conversion of pixel data in the DICOM grayscale transformation.
Public Property RescaleSlope | Gets and sets the slope used to specify a linear conversion of pixel data in the DICOM grayscale transformation.
Public Property ValuesOfInterestLookupTable | Gets and sets (VOI) Values of Interest for the DICOM Lookup Table.
Public Property WindowCenter | Gets and sets the center value used to specify a linear conversion from stored pixel values to values to be displayed after any Modality LUT or Rescale Slope and Intercept conversions have been applied.
Public Property WindowWidth | Gets and sets the width value used to specify a linear conversion from stored pixel values to values to be displayed after any Modality LUT or Rescale Slope and Intercept conversions have been applied.

See Also

Medical Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Medical Constructor

Medical Class | Medical Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Medical Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > Medical Class : Medical Constructor (Medical)

The main constructor to initialize a new instance of the Medical class.

[Visual Basic]
Public Function New()
[C#]
public Medical();
[C++]
public: Medical();
[C++/CLI]
public:
Medical();

See Also

Medical Class | Medical Members


Medical Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Medical Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : Medical Class (PegasusImaging.WinForms.ImagXpress9)

For a list of all members of this type, see Medical members.

Public Properties

Public Property ModalityLookupTable | Gets and sets a DICOM Modality Look Up Table.
Public Property PhotometricInterpretation | Gets and sets whether a zero in the image data is black or white.
Public Property RescaleIntercept | Gets and sets the intercept used to specify a linear conversion of pixel data in the DICOM grayscale transformation.
Public Property RescaleSlope | Gets and sets the slope used to specify a linear conversion of pixel data in the DICOM grayscale transformation.
Public Property ValuesOfInterestLookupTable | Gets and sets (VOI) Values of Interest for the DICOM Lookup Table.
Public Property WindowCenter | Gets and sets the center value used to specify a linear conversion from stored pixel values to values to be displayed after any Modality LUT or Rescale Slope and Intercept conversions have been applied.
Public Property WindowWidth | Gets and sets the width value used to specify a linear conversion from stored pixel values to values to be displayed after any Modality LUT or Rescale Slope and Intercept conversions have been applied.

See Also

Medical Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ModalityLookupTable Property

Medical Class | Medical Members | LookupTable Class

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ModalityLookupTable Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Medical Class : ModalityLookupTable Property

Gets and sets a DICOM Modality Look Up Table.

[Visual Basic]
Public Property ModalityLookupTable As LookupTable
[C#]
public LookupTable ModalityLookupTable {get; set;}
[C++]
public: __property LookupTable* get_ModalityLookupTable();
public: __property void set_ModalityLookupTable(
   LookupTable* value
);
[C++/CLI]
public:
property LookupTable^ ModalityLookupTable {
   LookupTable^ get();
   void set (LookupTable^ value);
}

Return Type

The LookupTable value set.

Remarks

This property allows you to set the Modality LUT information specified in the DICOM Modality LUT Sequence (0028, 3000) attribute.

See Also

Medical Class | Medical Members | LookupTable Class


PhotometricInterpretation Property

Medical Class | Medical Members | PhotometricInterpretation Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PhotometricInterpretation Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Medical Class : PhotometricInterpretation Property

Gets and sets whether a zero in the image data is black or white.

[Visual Basic]
Public Property PhotometricInterpretation As MedicalPhotometricInterpretation
[C#]
public MedicalPhotometricInterpretation PhotometricInterpretation {get; set;}
[C++]
public: __property MedicalPhotometricInterpretation get_PhotometricInterpretation();
public: __property void set_PhotometricInterpretation(
   MedicalPhotometricInterpretation value
);
[C++/CLI]
public:
property MedicalPhotometricInterpretation PhotometricInterpretation {
   MedicalPhotometricInterpretation get();
   void set (MedicalPhotometricInterpretation value);
}

Return Type

The PhotometricInterpretation enumeration value set.

Remarks

Note: This property should only be used when DICOM specific information is available.

See Also

Medical Class | Medical Members | PhotometricInterpretation Property


RescaleIntercept Property

Medical Class | Medical Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RescaleIntercept Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Medical Class : RescaleIntercept Property

Gets and sets the intercept used to specify a linear conversion of pixel data in the DICOM grayscale transformation.

[Visual Basic]
Public Property RescaleIntercept As Double
[C#]
public double RescaleIntercept {get; set;}
[C++]
public: __property double get_RescaleIntercept();
public: __property void set_RescaleIntercept(
   double value
);
[C++/CLI]
public:
property double RescaleIntercept {
   double get();
   void set (double value);
}

Return Type

A double value which represents pixel data in the DICOM grayscale transformation.

Remarks

This value corresponds to DICOM attribute (0028, 1052).

This property specifies the intercept value (b) to be used in the equation: Output units = m * SV + b where SV is the stored values (pixel data) and the value m corresponds to the Where SV is the stored values (pixel data) and the value m corresponds to the slope specified using the RescaleSlope property. Both values are used together to specify the linear conversion of pixel data.

This property is only valid when the ModalityLookupTable property is set to False.

This property should only be used when DICOM specific information is available.

See Also

Medical Class | Medical Members


RescaleSlope Property

Medical Class | Medical Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RescaleSlope Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Medical Class : RescaleSlope Property

Gets and sets the slope used to specify a linear conversion of pixel data in the DICOM grayscale transformation.

[Visual Basic]
Public Property RescaleSlope As Double
[C#]
public double RescaleSlope {get; set;}
[C++]
public: __property double get_RescaleSlope();
public: __property void set_RescaleSlope(
   double value
);
[C++/CLI]
public:
property double RescaleSlope {
   double get();
   void set (double value);
}

Return Type

A double value which represents pixel data in the DICOM grayscale transformation.

Remarks

This value corresponds to DICOM attribute (0028, 1053).

This property specifies the slope value (m) to be used in the equation: Output units = m * SV + b Where SV is the stored values (pixel data) and the value b corresponds to the intercept specified using the RescaleIntercept property. Both values are used together to specify the linear conversion of pixel data.

This property is only valid when ModalityLookupTable.Enabled is set to False.

This property should only be used when DICOM specific information is available.

See Also

Medical Class | Medical Members


ValuesOfInterestLookupTable Property

Medical Class | Medical Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ValuesOfInterestLookupTable Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Medical Class : ValuesOfInterestLookupTable Property

Gets and sets (VOI) Values of Interest for the DICOM Lookup Table.

[Visual Basic]
Public Property ValuesOfInterestLookupTable As LookupTable
[C#]
public LookupTable ValuesOfInterestLookupTable {get; set;}
[C++]
public: __property LookupTable* get_ValuesOfInterestLookupTable();
public: __property void set_ValuesOfInterestLookupTable(
   LookupTable* value
);
[C++/CLI]
public:
property LookupTable^ ValuesOfInterestLookupTable {
   LookupTable^ get();
   void set (LookupTable^ value);
}

Return Type

The LookupTable object.

Remarks

Sets the Values of Interest (VOI) LUT information specified in the DICOM VOI LUT Sequence (0028, 3010) attribute.

See Also

Medical Class | Medical Members


WindowCenter Property

Medical Class | Medical Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

WindowCenter Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Medical Class : WindowCenter Property

Gets and sets the center value used to specify a linear conversion from stored pixel values to values to be displayed after any Modality LUT or Rescale Slope and Intercept conversions have been applied.

[Visual Basic]
Public Property WindowCenter As Double
[C#]
public double WindowCenter {get; set;}
[C++]
public: __property double get_WindowCenter();
public: __property void set_WindowCenter(
   double value
);
[C++/CLI]
public:
property double WindowCenter {
   double get();
   void set (double value);
}

Return Type

A double value which represents the window center.

Remarks

This value corresponds to DICOM attribute (0028, 1050).

WindowCenter is used along with WindowWidth to specify the linear conversion of pixel data during the VOI step of DICOM grayscale transformation. For more information see Part 3, Annex C.11.2.1.2 of the DICOM standard.

This property is only valid when ValuesOfInterestLookupTable is set to false.

Note: This property should only be used when DICOM specific information is available. To set both the Center and Width parameters simultaneously use the Processor.ApplyGrayscaleTransform(Int32,Int32) method.

See Also

Medical Class | Medical Members


WindowWidth Property

Medical Class | Medical Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

WindowWidth Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Medical Class : WindowWidth Property

Gets and sets the width value used to specify a linear conversion from stored pixel values to values to be displayed after any Modality LUT or Rescale Slope and Intercept conversions have been applied.

[Visual Basic]
Public Property WindowWidth As Double
[C#]
public double WindowWidth {get; set;}
[C++]
public: __property double get_WindowWidth();
public: __property void set_WindowWidth(
   double value
);
[C++/CLI]
public:
property double WindowWidth {
   double get();
   void set (double value);
}

Return Type

A double value which represents the window width.

Remarks

WindowWidth contains the width of the window and shall always be greater than or equal to 1. When this value is greater than 1, WindowWidth and WindowCenter specify that range of input values to be mapped to the range of the output device. If DWindowWidth is equal to 1, WindowWidth and WindowCenter specify a value where input values below this value should be displayed as the minimum output value. For more information see Part 3, Annex C.11.2.1.2 of the DICOM standard.

This property is only valid when ValuesOfInterestLookupTable is set to false.

This property should only be used when DICOM specific information is available.

To set both the Center and Width parameters simultaneously use the Processor.ApplyGrayscaleTransform(Int32,Int32) method.

See Also

Medical Class | Medical Members


PaintImageEventArgs Class

PaintImageEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PaintImageEventArgs Class

PegasusImaging.WinForms.ImagXpress9 Namespace : PaintImageEventArgs Class

Provides data for the ImageXView.PaintImage event.

For a list of all members of this type, see PaintImageEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.ImagXpress9.PaintImageEventArgs

Syntax

[Visual Basic]
Public Class PaintImageEventArgs
   Inherits EventArgs
[C#]
public class PaintImageEventArgs : EventArgs
[C++]
public __gc class PaintImageEventArgs : public EventArgs
[C++/CLI]
public ref class PaintImageEventArgs : public EventArgs

See Also

PaintImageEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace


PaintImageEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PaintImageEventArgs Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : PaintImageEventArgs Class

PaintImageEventArgs overview

Public Constructors

Public Constructor PaintImageEventArgs Constructor

Public Properties

Public Property Graphics | Gets the Graphics object.
Public Property LogicalRectangle | Gets the logical rectangle.
Public Property UpdateRectangle | Gets the update rectangle.
Public Property ViewRectangle | Gets the view's rectangle.
Public Property ZoomFactor | Gets the zoom factor.

See Also

PaintImageEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


PaintImageEventArgs Constructor

PaintImageEventArgs Class | PaintImageEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PaintImageEventArgs Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > PaintImageEventArgs Class : PaintImageEventArgs Constructor (PaintImageEventArgs)
[Visual Basic]
Public Function New()
[C#]
public PaintImageEventArgs();
[C++]
public: PaintImageEventArgs();
[C++/CLI]
public:
PaintImageEventArgs();

See Also

PaintImageEventArgs Class | PaintImageEventArgs Members


PaintImageEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PaintImageEventArgs Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : PaintImageEventArgs Class

For a list of all members of this type, see PaintImageEventArgs members.

Public Properties

Public Property Graphics | Gets the Graphics object.
Public Property LogicalRectangle | Gets the logical rectangle.
Public Property UpdateRectangle | Gets the update rectangle.
Public Property ViewRectangle | Gets the view's rectangle.
Public Property ZoomFactor | Gets the zoom factor.

See Also

PaintImageEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Graphics Property

PaintImageEventArgs Class | PaintImageEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Graphics Property

PegasusImaging.WinForms.ImagXpress9 Namespace > PaintImageEventArgs Class : Graphics Property (PaintImageEventArgs)

Gets the Graphics object.

[Visual Basic]
Public ReadOnly Property Graphics As Graphics
[C#]
public Graphics Graphics {get;}
[C++]
public: __property Graphics* get_Graphics();
[C++/CLI]
public:
property Graphics^ Graphics {
   Graphics^ get();
}

Return Type

The Graphics object.

See Also

PaintImageEventArgs Class | PaintImageEventArgs Members


LogicalRectangle Property

PaintImageEventArgs Class | PaintImageEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LogicalRectangle Property

PegasusImaging.WinForms.ImagXpress9 Namespace > PaintImageEventArgs Class : LogicalRectangle Property

Gets the logical rectangle.

[Visual Basic]
Public ReadOnly Property LogicalRectangle As Rectangle
[C#]
public Rectangle LogicalRectangle {get;}
[C++]
public: __property Rectangle get_LogicalRectangle();
[C++/CLI]
public:
property Rectangle LogicalRectangle {
   Rectangle get();
}

Return Type

The logical Rectangle.

See Also

PaintImageEventArgs Class | PaintImageEventArgs Members


UpdateRectangle Property

PaintImageEventArgs Class | PaintImageEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

UpdateRectangle Property

PegasusImaging.WinForms.ImagXpress9 Namespace > PaintImageEventArgs Class : UpdateRectangle Property

Gets the update rectangle.

[Visual Basic]
Public ReadOnly Property UpdateRectangle As Rectangle
[C#]
public Rectangle UpdateRectangle {get;}
[C++]
public: __property Rectangle get_UpdateRectangle();
[C++/CLI]
public:
property Rectangle UpdateRectangle {
   Rectangle get();
}

Return Type

The update Rectangle.

See Also

PaintImageEventArgs Class | PaintImageEventArgs Members


ViewRectangle Property

PaintImageEventArgs Class | PaintImageEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ViewRectangle Property

PegasusImaging.WinForms.ImagXpress9 Namespace > PaintImageEventArgs Class : ViewRectangle Property

Gets the view's rectangle.

[Visual Basic]
Public ReadOnly Property ViewRectangle As Rectangle
[C#]
public Rectangle ViewRectangle {get;}
[C++]
public: __property Rectangle get_ViewRectangle();
[C++/CLI]
public:
property Rectangle ViewRectangle {
   Rectangle get();
}

Return Type

The view Rectangle.

See Also

PaintImageEventArgs Class | PaintImageEventArgs Members


ZoomFactor Property

PaintImageEventArgs Class | PaintImageEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ZoomFactor Property

PegasusImaging.WinForms.ImagXpress9 Namespace > PaintImageEventArgs Class : ZoomFactor Property (PaintImageEventArgs)

Gets the zoom factor.

[Visual Basic]
Public ReadOnly Property ZoomFactor As Double
[C#]
public double ZoomFactor {get;}
[C++]
public: __property double get_ZoomFactor();
[C++/CLI]
public:
property double ZoomFactor {
   double get();
}

Return Type

The zoom factor.

See Also

PaintImageEventArgs Class | PaintImageEventArgs Members


PrintImageEventArgs Class

PrintImageEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PrintImageEventArgs Class

PegasusImaging.WinForms.ImagXpress9 Namespace : PrintImageEventArgs Class

Provides data for the ImageXView.PaintImage Event.

For a list of all members of this type, see PrintImageEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.ImagXpress9.PrintImageEventArgs

Syntax

[Visual Basic]
Public Class PrintImageEventArgs
   Inherits EventArgs
[C#]
public class PrintImageEventArgs : EventArgs
[C++]
public __gc class PrintImageEventArgs : public EventArgs
[C++/CLI]
public ref class PrintImageEventArgs : public EventArgs

See Also

PrintImageEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace


PrintImageEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PrintImageEventArgs Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : PrintImageEventArgs Class

PrintImageEventArgs overview

Public Constructors

Public Constructor PrintImageEventArgs Constructor

Public Properties

Public Property Graphics | Gets the Graphics object.
Public Property GraphicsUnit | Gets the graphics unit.
Public Property ImageRectangle | Gets the image's rectangle.
Public Property PrintRectangle | Gets the printer's rectangle.
Public Property PrintType | Gets the type of the print that was performed.

See Also

PrintImageEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


PrintImageEventArgs Constructor

PrintImageEventArgs Class | PrintImageEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PrintImageEventArgs Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > PrintImageEventArgs Class : PrintImageEventArgs Constructor (PrintImageEventArgs)
[Visual Basic]
Public Function New()
[C#]
public PrintImageEventArgs();
[C++]
public: PrintImageEventArgs();
[C++/CLI]
public:
PrintImageEventArgs();

See Also

PrintImageEventArgs Class | PrintImageEventArgs Members


PrintImageEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PrintImageEventArgs Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : PrintImageEventArgs Class

For a list of all members of this type, see PrintImageEventArgs members.

Public Properties

Public Property Graphics | Gets the Graphics object.
Public Property GraphicsUnit | Gets the graphics unit.
Public Property ImageRectangle | Gets the image's rectangle.
Public Property PrintRectangle | Gets the printer's rectangle.
Public Property PrintType | Gets the type of the print that was performed.

See Also

PrintImageEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Graphics Property

PrintImageEventArgs Class | PrintImageEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Graphics Property

PegasusImaging.WinForms.ImagXpress9 Namespace > PrintImageEventArgs Class : Graphics Property (PrintImageEventArgs)

Gets the Graphics object.

[Visual Basic]
Public ReadOnly Property Graphics As Graphics
[C#]
public Graphics Graphics {get;}
[C++]
public: __property Graphics* get_Graphics();
[C++/CLI]
public:
property Graphics^ Graphics {
   Graphics^ get();
}

Return Type

The Graphics object.

See Also

PrintImageEventArgs Class | PrintImageEventArgs Members


GraphicsUnit Property

PrintImageEventArgs Class | PrintImageEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GraphicsUnit Property

PegasusImaging.WinForms.ImagXpress9 Namespace > PrintImageEventArgs Class : GraphicsUnit Property

Gets the graphics unit.

[Visual Basic]
Public ReadOnly Property GraphicsUnit As GraphicsUnit
[C#]
public GraphicsUnit GraphicsUnit {get;}
[C++]
public: __property GraphicsUnit get_GraphicsUnit();
[C++/CLI]
public:
property GraphicsUnit GraphicsUnit {
   GraphicsUnit get();
}

Return Type

The GraphicsUnit.

See Also

PrintImageEventArgs Class | PrintImageEventArgs Members


ImageRectangle Property

PrintImageEventArgs Class | PrintImageEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageRectangle Property

PegasusImaging.WinForms.ImagXpress9 Namespace > PrintImageEventArgs Class : ImageRectangle Property

Gets the image's rectangle.

[Visual Basic]
Public ReadOnly Property ImageRectangle As Rectangle
[C#]
public Rectangle ImageRectangle {get;}
[C++]
public: __property Rectangle get_ImageRectangle();
[C++/CLI]
public:
property Rectangle ImageRectangle {
   Rectangle get();
}

Return Type

The image's Rectangle.

See Also

PrintImageEventArgs Class | PrintImageEventArgs Members


PrintRectangle Property

PrintImageEventArgs Class | PrintImageEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PrintRectangle Property

PegasusImaging.WinForms.ImagXpress9 Namespace > PrintImageEventArgs Class : PrintRectangle Property

Gets the printer's rectangle.

[Visual Basic]
Public ReadOnly Property PrintRectangle As Rectangle
[C#]
public Rectangle PrintRectangle {get;}
[C++]
public: __property Rectangle get_PrintRectangle();
[C++/CLI]
public:
property Rectangle PrintRectangle {
   Rectangle get();
}

Return Type

The view Rectangle.

See Also

PrintImageEventArgs Class | PrintImageEventArgs Members


PrintType Property

PrintImageEventArgs Class | PrintImageEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PrintType Property

PegasusImaging.WinForms.ImagXpress9 Namespace > PrintImageEventArgs Class : PrintType Property (PrintImageEventArgs)

Gets the type of the print that was performed.

[Visual Basic]
Public ReadOnly Property PrintType As PrintType
[C#]
public PrintType PrintType {get;}
[C++]
public: __property PrintType get_PrintType();
[C++/CLI]
public:
property PrintType PrintType {
   PrintType get();
}

Return Type

The PrintType.

See Also

PrintImageEventArgs Class | PrintImageEventArgs Members


Processor Class

Processor Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Processor Class

PegasusImaging.WinForms.ImagXpress9 Namespace : Processor Class

This class implements methods and properties to enhance, edit and modify images.

For a list of all members of this type, see Processor members.

Object Model

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
PegasusImaging.WinForms.ImagXpress9.Processor

Syntax

[Visual Basic]
<ToolboxBitmapAttribute()>
Public Class Processor
   Inherits Component
   Implements IComponent, IDisposable
[C#]
[ToolboxBitmapAttribute()]
public class Processor : Component, IComponent, IDisposable
[C++]
[ToolboxBitmapAttribute()]
public __gc class Processor : public Component, IComponent, IDisposable
[C++/CLI]
[ToolboxBitmapAttribute()]
public ref class Processor : public Component, IComponent, IDisposable

Remarks

This class is the workhorse of ImagXpress. From redeye removal to image resizing, the Processor class contains many image processing methods for modifying the current image.

See Also

Processor Members | PegasusImaging.WinForms.ImagXpress9 Namespace


Processor Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Processor Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : Processor Class

Processor overview

Public Constructors

Public Constructor Processor Constructor Overloaded. Initializes a new instance of the Processor class.

Public Properties

Public Property BackgroundColor | Gets and sets the background color.
Public Property BlankPageDetected | Gets an indicator if a blank page is detected.
Public Property Confidence | Gets the confidence.
Public Property Container (Inherited from System.ComponentModel.Component) | Gets the IContainer that contains the Component.
Public Property ContrastMethod | Gets and sets the contrast method to use.
Public Property CountOfLinesFound | Gets the number of lines found.
Public Property CountOfObjectsFound | Gets the number of objects found.
Public Property CountOfSpecsFound | Gets the number of specs found.
Public Property EnableArea | Gets and sets whether the area is enabled.
Public Property EnableRegion | Gets and sets whether access to the region is enabled.
Public Property Image | Gets and sets the image to be processed.
Public Property ImageWasModified | Gets an indicator if the image was modified.
Public Property LogPalette | Gets and sets the palette for use when the Processor.ColorDepth method is called.
Public Property ProgressPercent | Gets and sets the ProgressEvent frequency.
Public Property Redeyes | Gets and sets the redeye collection.
Public Property RotationAngle | Gets the rotation angle.
Public Property Site | Overridden. Gets and sets the site value.
Public Property Variation | Gets the variation.

Public Methods

Public Method AdjustColorBalance | Overrides the default parameters when auto color balancing the image.
Public Method AdjustHSL | Adjusts the hue, saturation, and luninance components of the current image.
Public Method AdjustLightness | Automatically balances contrast in the image, adjusting the results of the auto lightness algorithm by a specified amount.
Public Method AdjustRGB | Adjusts the red, green, and blue components of the current image.
Public Method AlphaAdd | Overloaded. Adds a user created 8 bit alpha channel to an existing 24 bit channel thus promoting the image to 32 bits.
Public Method AlphaBitmapReturn | Overloaded. Returns an 8 bit handle to an image.
Public Method AlphaFill | Fills the alpha channel with the value specified.
Public Method AlphaFlatten | Overloaded. A 32 bit image with an alpha channel (ARGB) will merge (alpha channel applied) to the specified background color resulting in a 24 bit RGB image.
Public Method AlphaGet | Returns the Alpha value specified by the x and y location.
Public Method AlphaInvert | Inverts the alpha values throughout the current image, regions, or area.
Public Method AlphaRemove | Strips an ARGB 32 bit image to just a 24 bit RGB image.
Public Method AlphaSet | Allows the modification of an individual alpha value at the specified x and y coordinates.
Public Method ApplyGrayscaleTransform | Overloaded. Permanently levels an 8 through 16-bit gray image to and 8-bit gray image.
Public Method AutoColorBalance | Overrides the default parameters when auto color balances the image.
Public Method AutoContrast | Adjusts the contrast in the current image.
Public Method AutoCrop | Automatically crops the border space from an image.
Public Method AutoLevel | Restores and balances color quality within an image.
Public Method AutoLightness | Automatically assesses the adjusts contrast in light or dark regions of the image.
Public Method AutoRemoveRedeye | Automatically reduces the red reflection of the flash seen in the eyes of people in color flash photo images.
Public Method Binarize | Operates on 1-bit and 24-bit DIBs creating a 1-bit or 8-bit grayscale output image, respectively, of the same dimensions.
Public Method Blend | Blends each pixel in the current image with its neighboring pixels.
Public Method Blur | Blurs the current image by averaging each pixel with each of its neighboring pixels giving it an 'out of focus' appearance.
Public Method Brightness | Uniformly brightens the current image.
Public Method Buttonize | Adds translucent bevels to the edges of the current image to give it the appearance of a 3D button.
Public Method ColorCount | Returns the number of pixels of a specified color within the current image or image area.
Public Method ColorDepth | Changes the bits per pixel of the current image.
Public Method ColorJoin | Overloaded. Joins the colors as specified by the given parameters.
Public Method ColorSeparation | Overloaded. Separates the color based on the given parameters.
Public Method Contrast | Adjusts the contrast of the image.
Public Method CreateObjRef (Inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Public Method Crop | Crops the current image to the specified size.
Public Method CropBorder | Performs border removal by automatically cropping the edges of the current image.
Public Method DeleteRegion | Deletes the region of the image.
Public Method Deskew | Overloaded. Deskews the image using the specified DeskewType.
Public Method Despeckle | Filters the image using a filter that attempts to eliminate noise in the image.
Public Method Diffuse | Diffuses the current image by replacing each pixel with a randomly selected neighboring pixel.
Public Method Dilate | Enlarges the boundaries of regions of foreground pixels in the current image using a 3x3 maximum filter.
Public Method Dispose (Inherited from System.ComponentModel.Component) | Releases all resources used by the Component.
Public Method DocumentBlankPageDetect | Examines a rectangle on an image, determining if the page is considered blank, based on the amont of data on the page.
Public Method DocumentBlobRemoval | Locates and removes large black objects in images such as binder punch holes.
Public Method DocumentBorderCrop | Crops the borders of documents.
Public Method DocumentDeskew | Overloaded. Automatically detects and removes skew from current 1-bit depth images.
Public Method DocumentDespeckle | Detects and removes specks from the current image.
Public Method DocumentDilate | Examines pixels in the current image and expands the black ones by the given amount in a given direction.
Public Method DocumentErode | Removes the black pixels in the current image by the given amount in the given direction.
Public Method DocumentLineRemoval | Automatically detects and removes lines from the current image.
Public Method DocumentShear | Shears current image clockwise or counter-clockwise.
Public Method DocumentZoomSmooth | Replaces the current 1 bit-per-pixel image with an image whose width and height have been doubled and whose pixels have been smoothed.
Public Method Emboss | Performs an emboss on the image causing it to look embellished with metal or embroidered look.
Public Method Equalize | Equalizes the image by spreading its values across the full image.
Public Method Erode | Erodes the image by eroding away the boundaries using a 3x3 minimum filter.
Public Method Flip | Flips the current image from top to bottom.
Public Method Gamma | Specifies the gamma correction.
Public Method GetLifetimeService (Inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Public Method InitializeLifetimeService (Inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Public Method Matrix | Modifies the image using a 3x3 consolution matrix filter.
Public Method Median | Reduces noise on an image by using a 3x3 median filter.
Public Method Merge | Merges two images together such that the source image is merged with the current image specified in the processor. This method also specifies the type of merging.
Public Method Mirror | Rotates the current DIB (Device Independent Bitmap) 180 degrees, then flips it to create a mirror image.
Public Method Mosaic | Creates tiles or cells to represents the image.
Public Method MotionBlur | Streaks or blurs objects on the image to display them as moving using the specified parameters.
Public Method Negate | Creates a color negative of the current image.
Public Method Noise |
Public Method Outline | Outlines the outter edges of the image by enhancing the edges.
Public Method Parabolic | Modifies the image by the given ParabolicType.
Public Method Perspective | Modifies the image using the given PerspectiveType and percent.
Public Method Pinch | Modifies the image to look like it was pinched in the center using the given intensity.
Public Method PolynomialWarp | Modifies and warps the image to the given points.
Public Method Posterize | Reduces the number of colors to give it the effect of contours in the image.
Public Method RemoveDust | Removes what appears to be dust on the image by the given parameters.
Public Method RemoveRedeye | Removes what appears as red eye's in an image using the given parameters.
Public Method RemoveScratches | Removes what appear to be scratches from the image using the given parameters.
Public Method ReplaceColors | Replaces a range of colors in the current image.
Public Method Resize | Overloaded.
Public Method RGBColorCount | Returns three arrays, each containing 256 elements, which equate to a count of the red, green, and blue color intensities of the image.
Public Method Ripple | Modifies the image to create a ripple effect as per the given parameters.
Public Method Rotate | Rotates the current image.
Public Method SetArea | Sets the area.
Public Method SetRegion | Overloaded. Sets the given region for the image.
Public Method Sharpen | Overloaded. Sharpens the image by the given intensity.
Public Method Soften | Overloaded. Softens the image by the given intensity.
Public Method Solarize | Modifies the image by inverting the pixel values to negative.
Public Method Swirl | Modifies the image to appear in a swirl based on the given degrees.
Public Method Tile | Modifies the image to appear in tiles based on the given tile size.
Public Method ToString (Inherited from System.ComponentModel.Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Public Method Twist | Modifies the image to appear in a twist by the given block size and rotation.
Public Method UniqueColors | Returns a count of unique colors in the current image.
Public Method Unsharpen | Overloaded. Modifies the image to appear not as detailed based on the given intensity.

Public Events

Public Event Disposed (Inherited from System.ComponentModel.Component) | Adds an event handler to listen to the Disposed event on the component.
Public Event ProgressEvent | Notifies a change in progress status.

See Also

Processor Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Processor Constructor

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Processor Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Processor Constructor (Processor)

Initializes a new instance of the Processor class.

Overload List

Initializes a new instance of the Processor class.

[Visual Basic] Public Sub New(IContainer)

[C#] public Processor(IContainer);

[C++] public Processor(IContainer*);

[C++/CLI] public Processor(IContainer^);

Initializes a new instance of the Processor class.

[Visual Basic] Public Sub New(ImagXpress)

[C#] public Processor(ImagXpress);

[C++] public Processor(ImagXpress*);

[C++/CLI] public Processor(ImagXpress^);

Initializes a new instance of the Processor class.

[Visual Basic] Public Sub New(ImagXpress,ImageX)

[C#] public Processor(ImagXpress,ImageX);

[C++] public Processor(ImagXpress*,ImageX*);

[C++/CLI] public Processor(ImagXpress^,ImageX^);

Initializes a new instance of the Processor class.

[Visual Basic] Public Sub New(IContainer,ImagXpress)

[C#] public Processor(IContainer,ImagXpress);

[C++] public Processor(IContainer*,ImagXpress*);

[C++/CLI] public Processor(IContainer^,ImagXpress^);

Initializes a new instance of the Processor class.

[Visual Basic] Public Sub New(IContainer,ImagXpress,ImageX)

[C#] public Processor(IContainer,ImagXpress,ImageX);

[C++] public Processor(IContainer*,ImagXpress*,ImageX*);

[C++/CLI] public Processor(IContainer^,ImagXpress^,ImageX^);

See Also

Processor Class | Processor Members


Processor Constructor(IContainer)

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

container
The container that implements the IContainer interface which will contain this component.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Processor Constructor(IContainer)

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > Processor Constructor : Processor Constructor(IContainer)

Initializes a new instance of the Processor class.

[Visual Basic]
Public Function New( _
   ByVal container As IContainer _
)
[C#]
public Processor(
   IContainer container
);
[C++]
public: Processor(
   IContainer* container
)
[C++/CLI]
public:
Processor(
   IContainer^ container
)

Parameters

container
The container that implements the IContainer interface which will contain this component.

See Also

Processor Class | Processor Members | Overload List


Processor Constructor(IContainer,ImagXpress)

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

container
A container.
imagXpress
An ImagXpress workspace component.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Processor Constructor(IContainer,ImagXpress)

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > Processor Constructor : Processor Constructor(IContainer,ImagXpress)

Initializes a new instance of the Processor class.

[Visual Basic]
Public Function New( _
   ByVal container As IContainer, _
   ByVal imagXpress As ImagXpress _
)
[C#]
public Processor(
   IContainer container,
   ImagXpress imagXpress
);
[C++]
public: Processor(
   IContainer* container,
   ImagXpress* imagXpress
)
[C++/CLI]
public:
Processor(
   IContainer^ container,
   ImagXpress^ imagXpress
)

Parameters

container
A container.
imagXpress
An ImagXpress workspace component.

See Also

Processor Class | Processor Members | Overload List


Processor Constructor(IContainer,ImagXpress,ImageX)

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

container
A container.
imagXpress
An ImagXpress workspace component.
Image
An ImageX class object.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Processor Constructor(IContainer,ImagXpress,ImageX)

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > Processor Constructor : Processor Constructor(IContainer,ImagXpress,ImageX)

Initializes a new instance of the Processor class.

[Visual Basic]
Public Function New( _
   ByVal container As IContainer, _
   ByVal imagXpress As ImagXpress, _
   ByVal Image As ImageX _
)
[C#]
public Processor(
   IContainer container,
   ImagXpress imagXpress,
   ImageX Image
);
[C++]
public: Processor(
   IContainer* container,
   ImagXpress* imagXpress,
   ImageX* Image
)
[C++/CLI]
public:
Processor(
   IContainer^ container,
   ImagXpress^ imagXpress,
   ImageX^ Image
)

Parameters

container
A container.
imagXpress
An ImagXpress workspace component.
Image
An ImageX class object.

See Also

Processor Class | Processor Members | Overload List


Processor Constructor(ImagXpress)

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An ImagXpress workspace component.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Processor Constructor(ImagXpress)

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > Processor Constructor : Processor Constructor(ImagXpress)

Initializes a new instance of the Processor class.

[Visual Basic]
Public Function New( _
   ByVal imagXpress As ImagXpress _
)
[C#]
public Processor(
   ImagXpress imagXpress
);
[C++]
public: Processor(
   ImagXpress* imagXpress
)
[C++/CLI]
public:
Processor(
   ImagXpress^ imagXpress
)

Parameters

imagXpress
An ImagXpress workspace component.

See Also

Processor Class | Processor Members | Overload List


Processor Constructor(ImagXpress,ImageX)

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

imagXpress
An ImagXpress workspace component.
image
The ImageX class object.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Processor Constructor(ImagXpress,ImageX)

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > Processor Constructor : Processor Constructor(ImagXpress,ImageX)

Initializes a new instance of the Processor class.

[Visual Basic]
Public Function New( _
   ByVal imagXpress As ImagXpress, _
   ByVal image As ImageX _
)
[C#]
public Processor(
   ImagXpress imagXpress,
   ImageX image
);
[C++]
public: Processor(
   ImagXpress* imagXpress,
   ImageX* image
)
[C++/CLI]
public:
Processor(
   ImagXpress^ imagXpress,
   ImageX^ image
)

Parameters

imagXpress
An ImagXpress workspace component.
image
The ImageX class object.

See Also

Processor Class | Processor Members | Overload List


AdjustColorBalance Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

color

An integer value which represents the color to balance.

The range is 0 - 100.

0 indicates no correction of the image.

Values greater than zero increase the amount of correction performed.

red

An integer which represents the red color of the auto color balance algorithm result.

0 indicates no change to the red component of the image. (Red component will be the same as in the original image.)

Values less than zero decrease the red component of the image.

Values greater than zero increase the red component of the image.

green

An integer which represents the green color of the auto color balance algorithm result.

0 indicates no change to the green component of the image. (Green component will be the same as in the original image.)

Values less than zero decrease the green component of the image.

Values greater than zero increase the green component of the image.

blue

An integer which represents the blue color of the auto color balance algorithm result.

0 indicates no change to the blue component of the image. (Blue component will be the same as in the original image.)

Values less than zero decrease the blue component of the image.

Values greater than zero increase the blue component of the image.

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AdjustColorBalance Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : AdjustColorBalance Method

Overrides the default parameters when auto color balancing the image.

[Visual Basic]
Public Sub AdjustColorBalance( _
   ByVal color As Short, _
   ByVal red As Short, _
   ByVal green As Short, _
   ByVal blue As Short _
)
[C#]
public void AdjustColorBalance(
   short color,
   short red,
   short green,
   short blue
);
[C++]
public: void AdjustColorBalance(
   short color,
   short red,
   short green,
   short blue
)
[C++/CLI]
public:
void AdjustColorBalance(
   short color,
   short red,
   short green,
   short blue
)

Parameters

color

An integer value which represents the color to balance.

The range is 0 - 100.

0 indicates no correction of the image.

Values greater than zero increase the amount of correction performed.

red

An integer which represents the red color of the auto color balance algorithm result.

0 indicates no change to the red component of the image. (Red component will be the same as in the original image.)

Values less than zero decrease the red component of the image.

Values greater than zero increase the red component of the image.

green

An integer which represents the green color of the auto color balance algorithm result.

0 indicates no change to the green component of the image. (Green component will be the same as in the original image.)

Values less than zero decrease the green component of the image.

Values greater than zero increase the green component of the image.

blue

An integer which represents the blue color of the auto color balance algorithm result.

0 indicates no change to the blue component of the image. (Blue component will be the same as in the original image.)

Values less than zero decrease the blue component of the image.

Values greater than zero increase the blue component of the image.

Remarks

This method applies the same algorithm as the AutoColorBalance method to automatically balance color in the image, but enables the user to override the default parameters of the algorithm.

Since pixel values must fall within the range of 0 - 255, resulting pixel values less than 0 are set to 0 and resulting pixel values greater than 255 are set to 255.

See Also

Processor Class | Processor Members


AdjustHSL Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

adjustType
The AdjustType enumeration value set.
hue
An integer value which represents the adjustment to the hue of the current image.

For adjustType = AsPercent (0), the valid range is -100 to 100 (percent).

For adjustType = InUnits (1), the valid range is -360 to 360 (units).

saturation

An integer value which represents the saturation of the current image.

For adjustType = AsPercent (0), the valid value range is -100 to 100 (percent).

For adjustType = InUnits (1), the valid range is -360 to 360 (units).

luminance

An integer value which represents the luminance of the current image.

For adjustType = AsPercent (0), the valid value range is -100 to 100 (percent).

For adjustType = InUnits (1), the valid value range is -360 to 360 (units).

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AdjustHSL Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : AdjustHSL Method

Adjusts the hue, saturation, and luninance components of the current image.

[Visual Basic]
Public Sub AdjustHSL( _
   ByVal adjustType As AdjustType, _
   ByVal hue As Integer, _
   ByVal saturation As Integer, _
   ByVal luminance As Integer _
)
[C#]
public void AdjustHSL(
   AdjustType adjustType,
   int hue,
   int saturation,
   int luminance
);
[C++]
public: void AdjustHSL(
   AdjustType adjustType,
   int hue,
   int saturation,
   int luminance
)
[C++/CLI]
public:
void AdjustHSL(
   AdjustType adjustType,
   int hue,
   int saturation,
   int luminance
)

Parameters

adjustType
The AdjustType enumeration value set.
hue
An integer value which represents the adjustment to the hue of the current image.

For adjustType = AsPercent (0), the valid range is -100 to 100 (percent).

For adjustType = InUnits (1), the valid range is -360 to 360 (units).

saturation

An integer value which represents the saturation of the current image.

For adjustType = AsPercent (0), the valid value range is -100 to 100 (percent).

For adjustType = InUnits (1), the valid range is -360 to 360 (units).

luminance

An integer value which represents the luminance of the current image.

For adjustType = AsPercent (0), the valid value range is -100 to 100 (percent).

For adjustType = InUnits (1), the valid value range is -360 to 360 (units).

Remarks

Note: Available in all editions.

See Also

Processor Class | Processor Members


AdjustLightness Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

shadows

An integer value which represents the amount of brightening that is applied to shadowed image area.

The range for this parameter is 0 - 100.

A value of 0 results in no brightening. Higher values indicate a greater increase of brightness to be applied to the highlighted image area.

highlights

An integer value which repesents the amount of brightness decreasing that is applied to the highlighted image areas.

The range for this parameter is 0 - 100

A value of 0 results in no decrease in brightness. Higher values indicate a greater decrease of brightness in shadowed image areas.

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AdjustLightness Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : AdjustLightness Method

Automatically balances contrast in the image, adjusting the results of the auto lightness algorithm by a specified amount.

[Visual Basic]
Public Sub AdjustLightness( _
   ByVal shadows As Short, _
   ByVal highlights As Short _
)
[C#]
public void AdjustLightness(
   short shadows,
   short highlights
);
[C++]
public: void AdjustLightness(
   short shadows,
   short highlights
)
[C++/CLI]
public:
void AdjustLightness(
   short shadows,
   short highlights
)

Parameters

shadows

An integer value which represents the amount of brightening that is applied to shadowed image area.

The range for this parameter is 0 - 100.

A value of 0 results in no brightening. Higher values indicate a greater increase of brightness to be applied to the highlighted image area.

highlights

An integer value which repesents the amount of brightness decreasing that is applied to the highlighted image areas.

The range for this parameter is 0 - 100

A value of 0 results in no decrease in brightness. Higher values indicate a greater decrease of brightness in shadowed image areas.

Remarks

This method applies the same algorithm as the AutoLightness method to automatically balance color in the image, but enables the user to adjust the results of the algorithm by a specified amount.

See Also

Processor Class | Processor Members


AdjustRGB Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

adjustType
The AdjustType enumeration value set. The AdjustType indicates whether the red, green, and blue parameters are specified in units or by percentage.
red
An integer value which represents the smount of adjustment to apply to the red color component.
green
An integer value which represents the amount of adjustment to apply to the green color component.
blue
An integer value which represents the amount of adjustment to apply to the blue color component.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AdjustRGB Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : AdjustRGB Method

Adjusts the red, green, and blue components of the current image.

[Visual Basic]
Public Sub AdjustRGB( _
   ByVal adjustType As AdjustType, _
   ByVal red As Integer, _
   ByVal green As Integer, _
   ByVal blue As Integer _
)
[C#]
public void AdjustRGB(
   AdjustType adjustType,
   int red,
   int green,
   int blue
);
[C++]
public: void AdjustRGB(
   AdjustType adjustType,
   int red,
   int green,
   int blue
)
[C++/CLI]
public:
void AdjustRGB(
   AdjustType adjustType,
   int red,
   int green,
   int blue
)

Parameters

adjustType
The AdjustType enumeration value set. The AdjustType indicates whether the red, green, and blue parameters are specified in units or by percentage.
red
An integer value which represents the smount of adjustment to apply to the red color component.
green
An integer value which represents the amount of adjustment to apply to the green color component.
blue
An integer value which represents the amount of adjustment to apply to the blue color component.

Remarks

When adjustType = AsPercent (0), valid red, green, and blue values are between -100 and 100 (percent).

When adjustType = InUnits (1), valid RGB values are between -255 and 255 (units). Since pixel values must fall within the range 0-255, resulting pixel values less than 0 are set to 0 and resulting pixel values greater than 255 are set to 255.

Note: Available in all editions.

See Also

Processor Class | Processor Members


AlphaAdd Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AlphaAdd Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : AlphaAdd Method

Adds a user created 8 bit alpha channel to an existing 24 bit channel thus promoting the image to 32 bits.

Overload List

Adds a user created 8 bit alpha channel to an existing 24 bit channel thus promoting the image to 32 bits.

[Visual Basic] Overloads Public Sub AlphaAdd(IntPtr)

[C#] public void AlphaAdd(IntPtr);

[C++] public void AlphaAdd(IntPtr);

[C++/CLI] public void AlphaAdd(IntPtr);

Adds alpha channel information to an image.

[Visual Basic] Overloads Public Sub AlphaAdd(Bitmap)

[C#] public void AlphaAdd(Bitmap);

[C++] public void AlphaAdd(Bitmap*);

[C++/CLI] public void AlphaAdd(Bitmap^);

See Also

Processor Class | Processor Members


AlphaAdd(IntPtr) Method

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

hPlane
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AlphaAdd(IntPtr) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > AlphaAdd Method : AlphaAdd(IntPtr) Method

Adds a user created 8 bit alpha channel to an existing 24 bit channel thus promoting the image to 32 bits.

[Visual Basic]
Overloads Public Sub AlphaAdd( _
   ByVal hPlane As IntPtr _
)
[C#]
public void AlphaAdd(
   IntPtr hPlane
);
[C++]
public: void AlphaAdd(
   IntPtr hPlane
)
[C++/CLI]
public:
void AlphaAdd(
   IntPtr hPlane
)

Parameters

hPlane

Remarks

The Bitmap handle must be an 8 bit gray scaled handle hPlane is a Bitmap handle and must be of the same dimensions of width and height to the image being modified

If the image is not 24 bit than an error is thrown.

See Also

Processor Class | Processor Members | Overload List


AlphaAdd(Bitmap) Method

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

Plane

A Bitmap which represents the plane to add.

This plane should be the same width and height of the image it is being added to. It must be an 9 bit gray scale type with a uniform grayscale palette.

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AlphaAdd(Bitmap) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > AlphaAdd Method : AlphaAdd(Bitmap) Method

Adds alpha channel information to an image.

[Visual Basic]
Overloads Public Sub AlphaAdd( _
   ByVal Plane As Bitmap _
)
[C#]
public void AlphaAdd(
   Bitmap Plane
);
[C++]
public: void AlphaAdd(
   Bitmap* Plane
)
[C++/CLI]
public:
void AlphaAdd(
   Bitmap^ Plane
)

Parameters

Plane

A Bitmap which represents the plane to add.

This plane should be the same width and height of the image it is being added to. It must be an 9 bit gray scale type with a uniform grayscale palette.

Remarks

Note: The image bitmap should be of Format8bppIndexed.

If the original image is not a 24-bit, an error is thrown.

See Also

Processor Class | Processor Members | Overload List


AlphaBitmapReturn Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AlphaBitmapReturn Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : AlphaBitmapReturn Method

Returns an 8 bit handle to an image.

Overload List

Returns an 8 bit handle to an image.

[Visual Basic] Overloads Public Sub AlphaBitmapReturn(IntPtr)

[C#] public void AlphaBitmapReturn(IntPtr);

[C++] public void AlphaBitmapReturn(IntPtr);

[C++/CLI] public void AlphaBitmapReturn(IntPtr);

Returns a bitmap object of type Format8bppIndexed which is an 8 bit gray scale image depicting the alpha channel data layer.

[Visual Basic] Overloads Public Sub AlphaBitmapReturn(Bitmap)

[C#] public void AlphaBitmapReturn(Bitmap);

[C++] public void AlphaBitmapReturn(Bitmap*);

[C++/CLI] public void AlphaBitmapReturn(Bitmap^);

See Also

Processor Class | Processor Members


AlphaBitmapReturn(IntPtr) Method

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

hPlane
An integer pointer which is a bitmap handle to a plane which is similar to an 8 bit gray scaled image.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AlphaBitmapReturn(IntPtr) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > AlphaBitmapReturn Method : AlphaBitmapReturn(IntPtr) Method

Returns an 8 bit handle to an image.

[Visual Basic]
Overloads Public Sub AlphaBitmapReturn( _
   ByRef hPlane As IntPtr _
)
[C#]
public void AlphaBitmapReturn(
   out IntPtr hPlane
);
[C++]
public: void AlphaBitmapReturn(
   [PARAMFLAG::Out] IntPtr hPlane
)
[C++/CLI]
public:
void AlphaBitmapReturn(
   [Out] IntPtr hPlane
)

Parameters

hPlane
An integer pointer which is a bitmap handle to a plane which is similar to an 8 bit gray scaled image.

Remarks

Returning the handle implicitly reduces the image down to 24 bit. The alpha layer may be modified and restored via the AlphaAdd method.

The original image must be a 32 bit image where 8 bits are the alpha layer and 24 bits are rgb layer.

See Also

Processor Class | Processor Members | Overload List


AlphaBitmapReturn(Bitmap) Method

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

ReturnBitmap
A Bitmap value which represents the returned bitmap.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AlphaBitmapReturn(Bitmap) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > AlphaBitmapReturn Method : AlphaBitmapReturn(Bitmap) Method

Returns a bitmap object of type Format8bppIndexed which is an 8 bit gray scale image depicting the alpha channel data layer.

[Visual Basic]
Overloads Public Sub AlphaBitmapReturn( _
   ByRef ReturnBitmap As Bitmap _
)
[C#]
public void AlphaBitmapReturn(
   out Bitmap ReturnBitmap
);
[C++]
public: void AlphaBitmapReturn(
   [PARAMFLAG::Out] Bitmap* ReturnBitmap
)
[C++/CLI]
public:
void AlphaBitmapReturn(
   [Out] Bitmap^ ReturnBitmap
)

Parameters

ReturnBitmap
A Bitmap value which represents the returned bitmap.

Remarks

The original image must be a 32 bit image where 8 bits are the alpha layer and 24 bits are rgb color layer.

Returning the handle implicitly reduces the image down to 24 bit. The alpha object may be modified and restored via the AlphaAdd method.

See Also

Processor Class | Processor Members | Overload List


AlphaFill Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

AlphaValue
A Byte which represents the alpha information to fill.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AlphaFill Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : AlphaFill Method

Fills the alpha channel with the value specified.

[Visual Basic]
Public Sub AlphaFill( _
   ByVal AlphaValue As Byte _
)
[C#]
public void AlphaFill(
   byte AlphaValue
);
[C++]
public: void AlphaFill(
   byte AlphaValue
)
[C++/CLI]
public:
void AlphaFill(
   byte AlphaValue
)

Parameters

AlphaValue
A Byte which represents the alpha information to fill.

Remarks

If the region or area is set prior to this method, only that region or area will be filled with the value specified.

See Also

Processor Class | Processor Members


AlphaFlatten Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AlphaFlatten Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : AlphaFlatten Method

A 32 bit image with an alpha channel (ARGB) will merge (alpha channel applied) to the specified background color resulting in a 24 bit RGB image.

Overload List

A 32 bit image with an alpha channel (ARGB) will merge (alpha channel applied) to the specified background color resulting in a 24 bit RGB image.

[Visual Basic] Overloads Public Sub AlphaFlatten(Integer)

[C#] public void AlphaFlatten(int);

[C++] public void AlphaFlatten(int);

[C++/CLI] public void AlphaFlatten(int);

A 32 bit image with an alpha channel (ARGB) will merge (alpha channel applied) to the specified background color resulting in a 24 bit RGB image.

[Visual Basic] Overloads Public Sub AlphaFlatten(Color)

[C#] public void AlphaFlatten(Color);

[C++] public void AlphaFlatten(Color);

[C++/CLI] public void AlphaFlatten(Color);

See Also

Processor Class | Processor Members


AlphaFlatten(Int32) Method

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

clrColor
An integer value which represents the 24-bit color spectrum which will display as transparency.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AlphaFlatten(Int32) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > AlphaFlatten Method : AlphaFlatten(Int32) Method

A 32 bit image with an alpha channel (ARGB) will merge (alpha channel applied) to the specified background color resulting in a 24 bit RGB image.

[Visual Basic]
<ObsoleteAttribute()>
Overloads Public Sub AlphaFlatten( _
   ByVal clrColor As Integer _
)
[C#]
[ObsoleteAttribute()]
public void AlphaFlatten(
   int clrColor
);
[C++]
[ObsoleteAttribute()]
public: void AlphaFlatten(
   int clrColor
)
[C++/CLI]
[ObsoleteAttribute()]
public:
void AlphaFlatten(
   int clrColor
)

Parameters

clrColor
An integer value which represents the 24-bit color spectrum which will display as transparency.

Remarks

The color is an RGB specifed color where 0 is black and 0xFFFFFF is white.

The image must be a 32 bit image including alpha channel prior to calling this method, or an exception is thrown.

Note: Available in all editions.

See Also

Processor Class | Processor Members | Overload List


AlphaFlatten(Color) Method

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

color
A Color value which represents the 24-bit color spectrum which will display as transparency.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AlphaFlatten(Color) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > AlphaFlatten Method : AlphaFlatten(Color) Method

A 32 bit image with an alpha channel (ARGB) will merge (alpha channel applied) to the specified background color resulting in a 24 bit RGB image.

[Visual Basic]
Overloads Public Sub AlphaFlatten( _
   ByVal color As Color _
)
[C#]
public void AlphaFlatten(
   Color color
);
[C++]
public: void AlphaFlatten(
   Color color
)
[C++/CLI]
public:
void AlphaFlatten(
   Color color
)

Parameters

color
A Color value which represents the 24-bit color spectrum which will display as transparency.

Remarks

The image must be a 32 bit image including alpha channel prior to calling this method, or an exception is thrown.

Note: Available in all editions.

See Also

Processor Class | Processor Members | Overload List


AlphaGet Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

x
An integer value which represents the horizontal coordinate of the pixel to be modified within the image.
y
An integer value which represents the vertical coordinate of the pixel to be modified within the image.
pAlphaValue
A Byte which represents the alpha value returned.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AlphaGet Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : AlphaGet Method

Returns the Alpha value specified by the x and y location.

[Visual Basic]
Public Sub AlphaGet( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByRef pAlphaValue As Byte _
)
[C#]
public void AlphaGet(
   int x,
   int y,
   out byte pAlphaValue
);
[C++]
public: void AlphaGet(
   int x,
   int y,
   [PARAMFLAG::Out] byte pAlphaValue
)
[C++/CLI]
public:
void AlphaGet(
   int x,
   int y,
   [Out] byte pAlphaValue
)

Parameters

x
An integer value which represents the horizontal coordinate of the pixel to be modified within the image.
y
An integer value which represents the vertical coordinate of the pixel to be modified within the image.
pAlphaValue
A Byte which represents the alpha value returned.

Remarks

The value range is from 0 to 255.

The x and y coordinates must stay with the width and height dimensions of the image.

See Also

Processor Class | Processor Members


AlphaInvert Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AlphaInvert Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : AlphaInvert Method

Inverts the alpha values throughout the current image, regions, or area.

[Visual Basic]
Public Sub AlphaInvert()
[C#]
public void AlphaInvert();
[C++]
public: void AlphaInvert();
[C++/CLI]
public:
void AlphaInvert();

Remarks

A set region or area will confine the operation to just that area.

See Also

Processor Class | Processor Members


AlphaRemove Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AlphaRemove Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : AlphaRemove Method

Strips an ARGB 32 bit image to just a 24 bit RGB image.

[Visual Basic]
Public Sub AlphaRemove()
[C#]
public void AlphaRemove();
[C++]
public: void AlphaRemove();
[C++/CLI]
public:
void AlphaRemove();

Remarks

The alpha channel is removed from a 32 bit image, to create a 24-bit image without an alpha channel. The alpha channel information is not saved.

Note: The current image must be a signed 32 bit image including alpha information prior to calling this method, or an exception is thrown.

Note: Available in all editions.

See Also

Processor Class | Processor Members


AlphaSet Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

x
An integer value which represents the horizontal coordinate of the pixel to be modified within the image.
y
An integer value which represents the vertical coordinate of the pixel to be modified within the image.
AlphaValue
A Byte which represents the alpha value to apply to the specified pixel.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AlphaSet Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : AlphaSet Method

Allows the modification of an individual alpha value at the specified x and y coordinates.

[Visual Basic]
Public Sub AlphaSet( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal AlphaValue As Byte _
)
[C#]
public void AlphaSet(
   int x,
   int y,
   byte AlphaValue
);
[C++]
public: void AlphaSet(
   int x,
   int y,
   byte AlphaValue
)
[C++/CLI]
public:
void AlphaSet(
   int x,
   int y,
   byte AlphaValue
)

Parameters

x
An integer value which represents the horizontal coordinate of the pixel to be modified within the image.
y
An integer value which represents the vertical coordinate of the pixel to be modified within the image.
AlphaValue
A Byte which represents the alpha value to apply to the specified pixel.

Remarks

The value ranges from 0 to 255.

The x and y coordinates must stay with the width and height dimensions of the image.

Note: Available in all editions.

See Also

Processor Class | Processor Members


ApplyGrayscaleTransform Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ApplyGrayscaleTransform Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : ApplyGrayscaleTransform Method

Permanently levels an 8 through 16-bit gray image to and 8-bit gray image.

Overload List

Permanently levels an 8 through 16-bit gray image to and 8-bit gray image.

[Visual Basic] Overloads Public Sub ApplyGrayscaleTransform(Integer,Integer)

[C#] public void ApplyGrayscaleTransform(int,int);

[C++] public void ApplyGrayscaleTransform(int,int);

[C++/CLI] public void ApplyGrayscaleTransform(int,int);

Permanently levels an 8 through 16-bit gray image to and 8-bit gray image in a manner consistent to the DICOM specification.

[Visual Basic] Overloads Public Sub ApplyGrayscaleTransform(Medical)

[C#] public void ApplyGrayscaleTransform(Medical);

[C++] public void ApplyGrayscaleTransform(Medical*);

[C++/CLI] public void ApplyGrayscaleTransform(Medical^);

See Also

Processor Class | Processor Members


ApplyGrayscaleTransform(Int32,Int32) Method

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

brightness
The brightness intensity from -100 to 100.
contrast
The contrast intensity from -100 to 100.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ApplyGrayscaleTransform(Int32,Int32) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > ApplyGrayscaleTransform Method : ApplyGrayscaleTransform(Int32,Int32) Method

Permanently levels an 8 through 16-bit gray image to and 8-bit gray image.

[Visual Basic]
Overloads Public Sub ApplyGrayscaleTransform( _
   ByVal brightness As Integer, _
   ByVal contrast As Integer _
)
[C#]
public void ApplyGrayscaleTransform(
   int brightness,
   int contrast
);
[C++]
public: void ApplyGrayscaleTransform(
   int brightness,
   int contrast
)
[C++/CLI]
public:
void ApplyGrayscaleTransform(
   int brightness,
   int contrast
)

Parameters

brightness
The brightness intensity from -100 to 100.
contrast
The contrast intensity from -100 to 100.

Exceptions

Exception | Description
ProcessorException | A Processor exception.

Remarks

Some images describe more shades of gray than the human eye can discriminate. It is widely held that 256 shades are discernable. This method calculates a factor to multiply the values by to convert the selected range of grays to 256.

Example

[C#]

// create the processor class
PegasusImaging.WinForms.ImagXpress9.Processor processor = new PegasusImaging.WinForms.ImagXpress9.Processor( );
// associate it with a 8 to 16 bit per pixel image
processor.Image = highGrayImageX;
// apply the standard grayscale transform making the image brighter and enhancing the contrast
processor.ApplyGrayscaleTransform( 30, 10 );

See Also

Processor Class | Processor Members | Overload List


ApplyGrayscaleTransform(Medical) Method

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

medical
A medical object that contains the necessary information to perform the grayscale transformation with regard to the DICOM specification.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ApplyGrayscaleTransform(Medical) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > ApplyGrayscaleTransform Method : ApplyGrayscaleTransform(Medical) Method

Permanently levels an 8 through 16-bit gray image to and 8-bit gray image in a manner consistent to the DICOM specification.

[Visual Basic]
Overloads Public Sub ApplyGrayscaleTransform( _
   ByVal medical As Medical _
)
[C#]
public void ApplyGrayscaleTransform(
   Medical medical
);
[C++]
public: void ApplyGrayscaleTransform(
   Medical* medical
)
[C++/CLI]
public:
void ApplyGrayscaleTransform(
   Medical^ medical
)

Parameters

medical
A medical object that contains the necessary information to perform the grayscale transformation with regard to the DICOM specification.

Exceptions

Exception | Description
ProcessorException | A processor exception.

Remarks

Some images describe more shades of gray than the human eye can discriminate. It is widely held that 256 shades are discernable. This method uses a range and area of values you are interested in to select the 256 grays.

This method should only be used when the DICOM specific information is available.

Example

[C#]

// create the processor class
PegasusImaging.WinForms.ImagXpress9.Processor processor =
new PegasusImaging.WinForms.ImagXpress9.Processor( );
// associate it with a 8 to
16 bit per pixel image
processor.Image = highGrayImageX;
// create a medical object and fill in the
DICOM information explicitly
PegasusImaging.WinForms.ImagXpress9.Medical medical = new
PegasusImaging.WinForms.ImagXpress9.Medical( );
medical.WindowWidth = 128.0;
medical.WindowCenter = 128.0;
// apply the medical grayscale transform
processor.ApplyGrayscaleTransform( medical );

See Also

Processor Class | Processor Members | Overload List


AutoColorBalance Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AutoColorBalance Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : AutoColorBalance Method

Overrides the default parameters when auto color balances the image.

[Visual Basic]
Public Sub AutoColorBalance()
[C#]
public void AutoColorBalance();
[C++]
public: void AutoColorBalance();
[C++/CLI]
public:
void AutoColorBalance();

See Also

Processor Class | Processor Members


AutoContrast Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AutoContrast Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : AutoContrast Method

Adjusts the contrast in the current image.

[Visual Basic]
Public Sub AutoContrast()
[C#]
public void AutoContrast();
[C++]
public: void AutoContrast();
[C++/CLI]
public:
void AutoContrast();

Remarks

To override the default parameters used in the auto-contrast algorithm, call the Contrast method.

Note: Available in all editions.

See Also

Processor Class | Processor Members


AutoCrop Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

percentCrop

A float value which represents the percentage of pixels that indicate that the inner edge of the border has been reached.

Valid values are 0.0 to 100.0

This value may be adjusted to compensate for noise that is typically found in scanned documents.

border
A Point value which represent the upper left coordinates of the image body.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AutoCrop Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : AutoCrop Method

Automatically crops the border space from an image.

[Visual Basic]
Public Sub AutoCrop( _
   ByVal percentCrop As Single, _
   ByVal border As Point _
)
[C#]
public void AutoCrop(
   float percentCrop,
   Point border
);
[C++]
public: void AutoCrop(
   float percentCrop,
   Point border
)
[C++/CLI]
public:
void AutoCrop(
   float percentCrop,
   Point border
)

Parameters

percentCrop

A float value which represents the percentage of pixels that indicate that the inner edge of the border has been reached.

Valid values are 0.0 to 100.0

This value may be adjusted to compensate for noise that is typically found in scanned documents.

border
A Point value which represent the upper left coordinates of the image body.

Remarks

Beginning with the top row, each row is examined for black pixels. If the percentage of black pixels in that row is less than the given percentCrop, the row is eliminated and the next row is examined. The process continues until the number of black pixels exceeds the percentCrop, or until the border is reached. The same process is applied for rows from bottom to top and from the leftmost column to right and from the rightmost column to the left.

Note: Available in all editions.

See Also

Processor Class | Processor Members


AutoLevel Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AutoLevel Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : AutoLevel Method

Restores and balances color quality within an image.

[Visual Basic]
Public Sub AutoLevel()
[C#]
public void AutoLevel();
[C++]
public: void AutoLevel();
[C++/CLI]
public:
void AutoLevel();

Remarks

This method functions by centering the median of the Cb (of YCbCr which is related to blue minus luminance) component histogram.

The AutoColorBalance method also restores and balance color quality, but uses a different algorithm.

Note: Available in Photo edition.

See Also

Processor Class | Processor Members


AutoLightness Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AutoLightness Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : AutoLightness Method

Automatically assesses the adjusts contrast in light or dark regions of the image.

[Visual Basic]
Public Sub AutoLightness()
[C#]
public void AutoLightness();
[C++]
public: void AutoLightness();
[C++/CLI]
public:
void AutoLightness();

Remarks

This method can be useful for bringing more detail into shadowy areas of the image, without washing out the light regions, or correcting photos with silhouetted images due to strong backlighting.

Similar to the AutoContrast method, but uses a different algorithm to treat light and dark regions independently.

See the AdjustLightness method to override the default parameters of this method.

Note: Available in Photo Edition.

See Also

Processor Class | Processor Members


AutoRemoveRedeye Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

eyeShade

A RedeyeShade enumeration value to modify the shade of the red eye.

eyeGlare
A RedeyeGlare enumeration value to modify the glare of the red eye.
bUseRedeyeRectangles
A boolean value set to true to use redeye rectangles. Otherwise, use false.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AutoRemoveRedeye Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : AutoRemoveRedeye Method

Automatically reduces the red reflection of the flash seen in the eyes of people in color flash photo images.

[Visual Basic]
Public Sub AutoRemoveRedeye( _
   ByVal eyeShade As RedeyeShade, _
   ByVal eyeGlare As RedeyeGlare, _
   ByVal bUseRedeyeRectangles As Boolean _
)
[C#]
public void AutoRemoveRedeye(
   RedeyeShade eyeShade,
   RedeyeGlare eyeGlare,
   bool bUseRedeyeRectangles
);
[C++]
public: void AutoRemoveRedeye(
   RedeyeShade eyeShade,
   RedeyeGlare eyeGlare,
   bool bUseRedeyeRectangles
)
[C++/CLI]
public:
void AutoRemoveRedeye(
   RedeyeShade eyeShade,
   RedeyeGlare eyeGlare,
   bool bUseRedeyeRectangles
)

Parameters

eyeShade

A RedeyeShade enumeration value to modify the shade of the red eye.

eyeGlare
A RedeyeGlare enumeration value to modify the glare of the red eye.
bUseRedeyeRectangles
A boolean value set to true to use redeye rectangles. Otherwise, use false.

Remarks

The algorithm searches for rectangles containing red eyes and corrects them.

This method accurately corrects the red eyes without modifying non-eyes in most cases without any intervention. However, as with any algorithm, there is a potential for false postivies (modification of areas that are not eyes), or red eyes that are not corrected in some images.

To provide the application with maximum control over this behavior, this method stores in the Redeyes property all areas that have been corrected as a collection of rectangles with corresponding correction information. The rectangles identify areas in which red-eyes were detected and corrected, and a value indicating the confidence that the area corrected was a red eye. This enables the application to set an acceptable level of false positives, and optimize red-eye correction.

Note: Available in photo edition only.

See Also

Processor Class | Processor Members


Binarize Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

mode
A BinarizeMode which represents the mode to use to binarize the image.
lowThreshold

An integer value which represents the low threshold which controls background sensitivity.

The range is from 0 to 255.

This value should generally be as high as possible without exceeding the brightness of any part of the background.

Black noise appearing in the background can generally be eliminated by lowering this value.

highThreshold

An integer value which represents the high threshold which controls letter and figure thickness.

A suggested value for this parameter is (lowThreshold + 255)2. Letters and figures that render too thick can generally be improved by lowering this value. Letters and figures that render too thin can generally be improved by raising this value.

The range is from lowThreshold to 255.

gridAngle

An integer value which represents the orientation of the halftone grid from the horizontal, measured in degrees clockwise.

The range is from 0 to 360.

gridPitch

An integer value which represents the distance from the center of a black dot in the halftone grid to the nearest white dot, measured in pixels.

The range is from 1 to 32.

eccentricity

An integer value which represents the shape of the halftone grid.

The range is from -255 to 255. At the extreme values, -255 and 255, the grid becomes linear. At the midpoint, 0, the grid consists of circles/squares.

Intermediate values give intermediately shaped elliptical grid dots.

lceFactor

An integer value which represents the local contrast enhancement.

The range is from 0 to 255. Setting this value to 0 and local contrast is not performed.

Values from 1 to 255 control the sensitivity of local contrast enhancement to faint features; lower values yield less sensitivity.

This pre-processing operation increases the contrast in each region of the image. When used as a prelude to binarization, usually by setting Mode = QuickText, it increases the sensitivity of the binarization to detail in all regions of the image.

blur
A BinarizeBlur value which determines the type of blur to invoke duing the binarize method.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Binarize Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Binarize Method

Operates on 1-bit and 24-bit DIBs creating a 1-bit or 8-bit grayscale output image, respectively, of the same dimensions.

[Visual Basic]
Public Sub Binarize( _
   ByVal mode As BinarizeMode, _
   ByVal lowThreshold As Integer, _
   ByVal highThreshold As Integer, _
   ByVal gridAngle As Integer, _
   ByVal gridPitch As Integer, _
   ByVal eccentricity As Integer, _
   ByVal lceFactor As Integer, _
   ByVal blur As BinarizeBlur _
)
[C#]
public void Binarize(
   BinarizeMode mode,
   int lowThreshold,
   int highThreshold,
   int gridAngle,
   int gridPitch,
   int eccentricity,
   int lceFactor,
   BinarizeBlur blur
);
[C++]
public: void Binarize(
   BinarizeMode mode,
   int lowThreshold,
   int highThreshold,
   int gridAngle,
   int gridPitch,
   int eccentricity,
   int lceFactor,
   BinarizeBlur blur
)
[C++/CLI]
public:
void Binarize(
   BinarizeMode mode,
   int lowThreshold,
   int highThreshold,
   int gridAngle,
   int gridPitch,
   int eccentricity,
   int lceFactor,
   BinarizeBlur blur
)

Parameters

mode
A BinarizeMode which represents the mode to use to binarize the image.
lowThreshold

An integer value which represents the low threshold which controls background sensitivity.

The range is from 0 to 255.

This value should generally be as high as possible without exceeding the brightness of any part of the background.

Black noise appearing in the background can generally be eliminated by lowering this value.

highThreshold

An integer value which represents the high threshold which controls letter and figure thickness.

A suggested value for this parameter is (lowThreshold + 255)2. Letters and figures that render too thick can generally be improved by lowering this value. Letters and figures that render too thin can generally be improved by raising this value.

The range is from lowThreshold to 255.

gridAngle

An integer value which represents the orientation of the halftone grid from the horizontal, measured in degrees clockwise.

The range is from 0 to 360.

gridPitch

An integer value which represents the distance from the center of a black dot in the halftone grid to the nearest white dot, measured in pixels.

The range is from 1 to 32.

eccentricity

An integer value which represents the shape of the halftone grid.

The range is from -255 to 255. At the extreme values, -255 and 255, the grid becomes linear. At the midpoint, 0, the grid consists of circles/squares.

Intermediate values give intermediately shaped elliptical grid dots.

lceFactor

An integer value which represents the local contrast enhancement.

The range is from 0 to 255. Setting this value to 0 and local contrast is not performed.

Values from 1 to 255 control the sensitivity of local contrast enhancement to faint features; lower values yield less sensitivity.

This pre-processing operation increases the contrast in each region of the image. When used as a prelude to binarization, usually by setting Mode = QuickText, it increases the sensitivity of the binarization to detail in all regions of the image.

blur
A BinarizeBlur value which determines the type of blur to invoke duing the binarize method.

Remarks

For 1-bit output, this method modifies the color palette associated with the image, setting it to two colors, with black as color 0 and white as color 1.

Binarize is often done to clean up an image (e.g. in preparation for OCR), or to create an image effect.

Note: Available in Document and Photo editions.

See Also

Processor Class | Processor Members


Blend Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

blendPercent
An integer value which represents the percentage of pixel blending to perform. Valid values are 0 to 100.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Blend Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Blend Method

Blends each pixel in the current image with its neighboring pixels.

[Visual Basic]
Public Sub Blend( _
   ByVal blendPercent As Integer _
)
[C#]
public void Blend(
   int blendPercent
);
[C++]
public: void Blend(
   int blendPercent
)
[C++/CLI]
public:
void Blend(
   int blendPercent
)

Parameters

blendPercent
An integer value which represents the percentage of pixel blending to perform. Valid values are 0 to 100.

Remarks

Note: Available in all editions.

See Also

Processor Class | Processor Members


Blur Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Blur Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Blur Method

Blurs the current image by averaging each pixel with each of its neighboring pixels giving it an 'out of focus' appearance.

[Visual Basic]
Public Sub Blur()
[C#]
public void Blur();
[C++]
public: void Blur();
[C++/CLI]
public:
void Blur();

Remarks

Note: Available in all editions.

See Also

Processor Class | Processor Members


Brightness Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

intensity

A short integer which represents the brightness level.

The range is from -100 to 100.

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Brightness Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Brightness Method (Processor)

Uniformly brightens the current image.

[Visual Basic]
Public Sub Brightness( _
   ByVal intensity As Short _
)
[C#]
public void Brightness(
   short intensity
);
[C++]
public: void Brightness(
   short intensity
)
[C++/CLI]
public:
void Brightness(
   short intensity
)

Parameters

intensity

A short integer which represents the brightness level.

The range is from -100 to 100.

Remarks

Higher intensities result in brighter images. Negative intensities darken images.

An image that has been brightened has pixels that have higher luminance values (in the HSL color space), or higher RGB values (in RGB color space) than the original image.

Note: Available in all editions.

See Also

Processor Class | Processor Members


Buttonize Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

style
A ButtonStyle enumeration value.
bevelWidth
An integer value which represents the width of the bevels. Valid values are 0 to 32768.
bevelIntensity
An integer value which represents the percent of intensity of the bevels. Higher values result in more opaque bevels while lower percentages result in more translucent bevels. Valid values are 1 to 100.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Buttonize Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Buttonize Method

Adds translucent bevels to the edges of the current image to give it the appearance of a 3D button.

[Visual Basic]
Public Sub Buttonize( _
   ByVal style As ButtonStyle, _
   ByVal bevelWidth As Integer, _
   ByVal bevelIntensity As Integer _
)
[C#]
public void Buttonize(
   ButtonStyle style,
   int bevelWidth,
   int bevelIntensity
);
[C++]
public: void Buttonize(
   ButtonStyle style,
   int bevelWidth,
   int bevelIntensity
)
[C++/CLI]
public:
void Buttonize(
   ButtonStyle style,
   int bevelWidth,
   int bevelIntensity
)

Parameters

style
A ButtonStyle enumeration value.
bevelWidth
An integer value which represents the width of the bevels. Valid values are 0 to 32768.
bevelIntensity
An integer value which represents the percent of intensity of the bevels. Higher values result in more opaque bevels while lower percentages result in more translucent bevels. Valid values are 1 to 100.

Remarks

Note: Available in all editions.

See Also

Processor Class | Processor Members


ColorCount Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

color
A Color specified. This parameter stores four, 8-bit components: alpha, red, green, and blue, respectively.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ColorCount Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : ColorCount Method

Returns the number of pixels of a specified color within the current image or image area.

[Visual Basic]
Public Function ColorCount( _
   ByVal color As Color _
) As Long
[C#]
public long ColorCount(
   Color color
);
[C++]
public: long ColorCount(
   Color color
)
[C++/CLI]
public:
long long ColorCount(
   Color color
)

Parameters

color
A Color specified. This parameter stores four, 8-bit components: alpha, red, green, and blue, respectively.

Remarks

This method can be used to determine if a check box on a document image is filled or if a specific field on a form is filled.

Note: Available in all editions.

See Also

Processor Class | Processor Members


ColorDepth Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

bitsPerPixel
An integer value which represents the bits per pixel.
paletteType
The PaletteType enumeration value set.
ditherType
The DitherType enumeration value set.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ColorDepth Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : ColorDepth Method

Changes the bits per pixel of the current image.

[Visual Basic]
Public Sub ColorDepth( _
   ByVal bitsPerPixel As Integer, _
   ByVal paletteType As PaletteType, _
   ByVal ditherType As DitherType _
)
[C#]
public void ColorDepth(
   int bitsPerPixel,
   PaletteType paletteType,
   DitherType ditherType
);
[C++]
public: void ColorDepth(
   int bitsPerPixel,
   PaletteType paletteType,
   DitherType ditherType
)
[C++/CLI]
public:
void ColorDepth(
   int bitsPerPixel,
   PaletteType paletteType,
   DitherType ditherType
)

Parameters

bitsPerPixel
An integer value which represents the bits per pixel.
paletteType
The PaletteType enumeration value set.
ditherType
The DitherType enumeration value set.

Remarks

Note: Available in all editions.

See Also

Processor Class | Processor Members


ColorJoin Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ColorJoin Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : ColorJoin Method

Joins the colors as specified by the given parameters.

Overload List

Joins the colors as specified by the given parameters.

[Visual Basic] Overloads Public Sub ColorJoin(JoinType,IntPtr,IntPtr,IntPtr,IntPtr)

[C#] public void ColorJoin(JoinType,IntPtr,IntPtr,IntPtr,IntPtr);

[C++] public void ColorJoin(JoinType,IntPtr,IntPtr,IntPtr,IntPtr);

[C++/CLI] public void ColorJoin(JoinType,IntPtr,IntPtr,IntPtr,IntPtr);

Joins the colors as specified by the given parameters.

[Visual Basic] Overloads Public Sub ColorJoin(JoinType,Bitmap,Bitmap,Bitmap,Bitmap)

[C#] public void ColorJoin(JoinType,Bitmap,Bitmap,Bitmap,Bitmap);

[C++] public void ColorJoin(JoinType,Bitmap*,Bitmap*,Bitmap*,Bitmap*);

[C++/CLI] public void ColorJoin(JoinType,Bitmap^,Bitmap^,Bitmap^,Bitmap^);

See Also

Processor Class | Processor Members


ColorJoin(JoinType,IntPtr,IntPtr,IntPtr,IntPtr) Method

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

nJoinType
A JoinType value which represents the join type to use to modify the image.
hPlane1
An integer which represents the resulting red, hue, or cyan component of the separated image, depending on the JoinType value.
hPlane2
An integer which represents the resulting green, saturation, or magenta component of the separated image, depending on the JoinType.
hPlane3
An integer which represents the resulting blue, luminance, or yellow component of the separated image, depending on the JoinType.
hPlane4
An integer which represents the resulting black component of the separated image. If the separation type is CMYK, or the Alpha component of the separated image, the separation type is RGBA. Otherwise, this value is null.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ColorJoin(JoinType,IntPtr,IntPtr,IntPtr,IntPtr) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > ColorJoin Method : ColorJoin(JoinType,IntPtr,IntPtr,IntPtr,IntPtr) Method

Joins the colors as specified by the given parameters.

[Visual Basic]
Overloads Public Sub ColorJoin( _
   ByVal nJoinType As JoinType, _
   ByVal hPlane1 As IntPtr, _
   ByVal hPlane2 As IntPtr, _
   ByVal hPlane3 As IntPtr, _
   ByVal hPlane4 As IntPtr _
)
[C#]
public void ColorJoin(
   JoinType nJoinType,
   IntPtr hPlane1,
   IntPtr hPlane2,
   IntPtr hPlane3,
   IntPtr hPlane4
);
[C++]
public: void ColorJoin(
   JoinType nJoinType,
   IntPtr hPlane1,
   IntPtr hPlane2,
   IntPtr hPlane3,
   IntPtr hPlane4
)
[C++/CLI]
public:
void ColorJoin(
   JoinType nJoinType,
   IntPtr hPlane1,
   IntPtr hPlane2,
   IntPtr hPlane3,
   IntPtr hPlane4
)

Parameters

nJoinType
A JoinType value which represents the join type to use to modify the image.
hPlane1
An integer which represents the resulting red, hue, or cyan component of the separated image, depending on the JoinType value.
hPlane2
An integer which represents the resulting green, saturation, or magenta component of the separated image, depending on the JoinType.
hPlane3
An integer which represents the resulting blue, luminance, or yellow component of the separated image, depending on the JoinType.
hPlane4
An integer which represents the resulting black component of the separated image. If the separation type is CMYK, or the Alpha component of the separated image, the separation type is RGBA. Otherwise, this value is null.

See Also

Processor Class | Processor Members | Overload List


ColorJoin(JoinType,Bitmap,Bitmap,Bitmap,Bitmap) Method

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

nJoinType
A JoinType value which represents the join type to use to modify the image.
bitmap1
A bitmap which represents the resulting red, hue, or cyan component of the separated image, depending on the JoinType value.
bitmap2
A bitmap which represents the resulting green, saturation, or magenta component of the separated image, depending on the JoinType.
bitmap3
A bitmap which represents the resulting blue, luminance, or yellow component of the separated image, depending on the JoinType.
bitmap4
A bitmap which represents the resulting black component of the separated image. If the separation type is CMYK, or the Alpha component of the separated image, the separation type is RGBA. Otherwise, this value is null.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ColorJoin(JoinType,Bitmap,Bitmap,Bitmap,Bitmap) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > ColorJoin Method : ColorJoin(JoinType,Bitmap,Bitmap,Bitmap,Bitmap) Method

Joins the colors as specified by the given parameters.

[Visual Basic]
Overloads Public Sub ColorJoin( _
   ByVal nJoinType As JoinType, _
   ByVal bitmap1 As Bitmap, _
   ByVal bitmap2 As Bitmap, _
   ByVal bitmap3 As Bitmap, _
   ByVal bitmap4 As Bitmap _
)
[C#]
public void ColorJoin(
   JoinType nJoinType,
   Bitmap bitmap1,
   Bitmap bitmap2,
   Bitmap bitmap3,
   Bitmap bitmap4
);
[C++]
public: void ColorJoin(
   JoinType nJoinType,
   Bitmap* bitmap1,
   Bitmap* bitmap2,
   Bitmap* bitmap3,
   Bitmap* bitmap4
)
[C++/CLI]
public:
void ColorJoin(
   JoinType nJoinType,
   Bitmap^ bitmap1,
   Bitmap^ bitmap2,
   Bitmap^ bitmap3,
   Bitmap^ bitmap4
)

Parameters

nJoinType
A JoinType value which represents the join type to use to modify the image.
bitmap1
A bitmap which represents the resulting red, hue, or cyan component of the separated image, depending on the JoinType value.
bitmap2
A bitmap which represents the resulting green, saturation, or magenta component of the separated image, depending on the JoinType.
bitmap3
A bitmap which represents the resulting blue, luminance, or yellow component of the separated image, depending on the JoinType.
bitmap4
A bitmap which represents the resulting black component of the separated image. If the separation type is CMYK, or the Alpha component of the separated image, the separation type is RGBA. Otherwise, this value is null.

See Also

Processor Class | Processor Members | Overload List


ColorSeparation Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ColorSeparation Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : ColorSeparation Method

Separates the color based on the given parameters.

Overload List

Separates the color based on the given parameters.

[Visual Basic] Overloads Public Sub ColorSeparation(SeparationType,IntPtr,IntPtr,IntPtr,IntPtr)

[C#] public void ColorSeparation(SeparationType,IntPtr,IntPtr,IntPtr,IntPtr);

[C++] public void ColorSeparation(SeparationType,IntPtr,IntPtr,IntPtr,IntPtr);

[C++/CLI] public void ColorSeparation(SeparationType,IntPtr,IntPtr,IntPtr,IntPtr);

Separates the color based on the given parameters.

[Visual Basic] Overloads Public Sub ColorSeparation(SeparationType,Bitmap,Bitmap,Bitmap,Bitmap)

[C#] public void ColorSeparation(SeparationType,Bitmap,Bitmap,Bitmap,Bitmap);

[C++] public void ColorSeparation(SeparationType,Bitmap*,Bitmap*,Bitmap*,Bitmap*);

[C++/CLI] public void ColorSeparation(SeparationType,Bitmap^,Bitmap^,Bitmap^,Bitmap^);

See Also

Processor Class | Processor Members


ColorSeparation(SeparationType,IntPtr,IntPtr,IntPtr,IntPtr) Method

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

enumIPSeparationType
A SeparationType value which represents the type of separation to perform on the image.
hPlane1
An integer which represents the resulting red, hue, or cyan component of the separated image, depending on the SeparationType value.
hPlane2
An integer which represents the resulting green, saturation, or magenta component of the separated image, depending on the SeparationType.
hPlane3
An integer which represents the resulting blue, luminance, or yellow component of the separated image, depending on the SeparationType.
hPlane4
An integer which represents the resulting black component of the separated image. If the separation type is CMYK, or the Alpha component of the separated image, the separation type is RGBA. Otherwise, this value is null.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ColorSeparation(SeparationType,IntPtr,IntPtr,IntPtr,IntPtr) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > ColorSeparation Method : ColorSeparation(SeparationType,IntPtr,IntPtr,IntPtr,IntPtr) Method

Separates the color based on the given parameters.

[Visual Basic]
Overloads Public Sub ColorSeparation( _
   ByVal enumIPSeparationType As SeparationType, _
   ByRef hPlane1 As IntPtr, _
   ByRef hPlane2 As IntPtr, _
   ByRef hPlane3 As IntPtr, _
   ByRef hPlane4 As IntPtr _
)
[C#]
public void ColorSeparation(
   SeparationType enumIPSeparationType,
   out IntPtr hPlane1,
   out IntPtr hPlane2,
   out IntPtr hPlane3,
   out IntPtr hPlane4
);
[C++]
public: void ColorSeparation(
   SeparationType enumIPSeparationType,
   [PARAMFLAG::Out] IntPtr hPlane1,
   [PARAMFLAG::Out] IntPtr hPlane2,
   [PARAMFLAG::Out] IntPtr hPlane3,
   [PARAMFLAG::Out] IntPtr hPlane4
)
[C++/CLI]
public:
void ColorSeparation(
   SeparationType enumIPSeparationType,
   [Out] IntPtr hPlane1,
   [Out] IntPtr hPlane2,
   [Out] IntPtr hPlane3,
   [Out] IntPtr hPlane4
)

Parameters

enumIPSeparationType
A SeparationType value which represents the type of separation to perform on the image.
hPlane1
An integer which represents the resulting red, hue, or cyan component of the separated image, depending on the SeparationType value.
hPlane2
An integer which represents the resulting green, saturation, or magenta component of the separated image, depending on the SeparationType.
hPlane3
An integer which represents the resulting blue, luminance, or yellow component of the separated image, depending on the SeparationType.
hPlane4
An integer which represents the resulting black component of the separated image. If the separation type is CMYK, or the Alpha component of the separated image, the separation type is RGBA. Otherwise, this value is null.

See Also

Processor Class | Processor Members | Overload List


ColorSeparation(SeparationType,Bitmap,Bitmap,Bitmap,Bitmap) Method

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

enumIPSeparationType
A SeparationType value which represents the type of separation to perform on the image.
bitmap1
A bitmap which represents the resulting red, hue, or cyan component of the separated image, depending on the SeparationType value.
bitmap2
A bitmap which represents the resulting green, saturation, or magenta component of the separated image, depending on the SeparationType.
bitmap3
A bitmap which represents the resulting blue, luminance, or yellow component of the separated image, depending on the SeparationType.
bitmap4
A bitmap which represents the resulting black component of the separated image. If the separation type is CMYK, or the Alpha component of the separated image, the separation type is RGBA. Otherwise, this value is null.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ColorSeparation(SeparationType,Bitmap,Bitmap,Bitmap,Bitmap) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > ColorSeparation Method : ColorSeparation(SeparationType,Bitmap,Bitmap,Bitmap,Bitmap) Method

Separates the color based on the given parameters.

[Visual Basic]
Overloads Public Sub ColorSeparation( _
   ByVal enumIPSeparationType As SeparationType, _
   ByRef bitmap1 As Bitmap, _
   ByRef bitmap2 As Bitmap, _
   ByRef bitmap3 As Bitmap, _
   ByRef bitmap4 As Bitmap _
)
[C#]
public void ColorSeparation(
   SeparationType enumIPSeparationType,
   out Bitmap bitmap1,
   out Bitmap bitmap2,
   out Bitmap bitmap3,
   out Bitmap bitmap4
);
[C++]
public: void ColorSeparation(
   SeparationType enumIPSeparationType,
   [PARAMFLAG::Out] Bitmap* bitmap1,
   [PARAMFLAG::Out] Bitmap* bitmap2,
   [PARAMFLAG::Out] Bitmap* bitmap3,
   [PARAMFLAG::Out] Bitmap* bitmap4
)
[C++/CLI]
public:
void ColorSeparation(
   SeparationType enumIPSeparationType,
   [Out] Bitmap^ bitmap1,
   [Out] Bitmap^ bitmap2,
   [Out] Bitmap^ bitmap3,
   [Out] Bitmap^ bitmap4
)

Parameters

enumIPSeparationType
A SeparationType value which represents the type of separation to perform on the image.
bitmap1
A bitmap which represents the resulting red, hue, or cyan component of the separated image, depending on the SeparationType value.
bitmap2
A bitmap which represents the resulting green, saturation, or magenta component of the separated image, depending on the SeparationType.
bitmap3
A bitmap which represents the resulting blue, luminance, or yellow component of the separated image, depending on the SeparationType.
bitmap4
A bitmap which represents the resulting black component of the separated image. If the separation type is CMYK, or the Alpha component of the separated image, the separation type is RGBA. Otherwise, this value is null.

See Also

Processor Class | Processor Members | Overload List


Contrast Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

intensity

A short value which represents the intensity.

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Contrast Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Contrast Method (Processor)

Adjusts the contrast of the image.

[Visual Basic]
Public Sub Contrast( _
   ByVal intensity As Short _
)
[C#]
public void Contrast(
   short intensity
);
[C++]
public: void Contrast(
   short intensity
)
[C++/CLI]
public:
void Contrast(
   short intensity
)

Parameters

intensity

A short value which represents the intensity.

Remarks

Valid values are -100 to 100.

The value of 0 indicates that the contrast remains the same as in the original image.

Values greater than zero increase the contrast in the image. Values less than zero decrease the contrast in the image.

This method uses the same algorithm as AutoContrast, but enables the user to adjust the results of the algorithm by a specified percentage.

See Also

Processor Class | Processor Members


Crop Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

cropRectangle
A Rectangle coordinates which represent the cropping rectangle to use.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Crop Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Crop Method

Crops the current image to the specified size.

[Visual Basic]
Public Sub Crop( _
   ByVal cropRectangle As Rectangle _
)
[C#]
public void Crop(
   Rectangle cropRectangle
);
[C++]
public: void Crop(
   Rectangle cropRectangle
)
[C++/CLI]
public:
void Crop(
   Rectangle cropRectangle
)

Parameters

cropRectangle
A Rectangle coordinates which represent the cropping rectangle to use.

Remarks

If the area defined by the crop parameters does not fall within the boundaries of the image, the image is not cropped and ImagXpress generates a ProcessorException message.

Note: Available in all editions.

See Also

Processor Class | Processor Members


CropBorder Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

percentToCrop
A float value which represents the percent to crop.
cropType
A CropType enumeration value which represents the type of crop to perform.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CropBorder Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : CropBorder Method

Performs border removal by automatically cropping the edges of the current image.

[Visual Basic]
Public Sub CropBorder( _
   ByVal percentToCrop As Single, _
   ByVal cropType As CropType _
)
[C#]
public void CropBorder(
   float percentToCrop,
   CropType cropType
);
[C++]
public: void CropBorder(
   float percentToCrop,
   CropType cropType
)
[C++/CLI]
public:
void CropBorder(
   float percentToCrop,
   CropType cropType
)

Parameters

percentToCrop
A float value which represents the percent to crop.
cropType
A CropType enumeration value which represents the type of crop to perform.

Remarks

Occassionally, scanned images possess edges where the selected scan area falls outside the scanned page. Use this method to remove these edges.

Use the DocumentBorderCrop method to trim these edges from documents.

Beginning with the top row, ImagXpress examines each row for pixels containing the boder color. If the percentage pixels containing the border color in that row and its adjacent row is greater than the given percentToCrop, the row is eliminated and the next row is examined. The process continues until the number of pixels containing the border color is less than the percentToCrop.

The same process applies for rows from bottom to top, the leftmost column to the right and the rightmost column to the left. The specified percentToCrop argument can be adjusted to compensate for noise that is typically found in scanned documents.

    Note: Available in all editions.

    See Also

    Processor Class | Processor Members


DeleteRegion Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DeleteRegion Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : DeleteRegion Method

Deletes the region of the image.

[Visual Basic]
Public Sub DeleteRegion()
[C#]
public void DeleteRegion();
[C++]
public: void DeleteRegion();
[C++/CLI]
public:
void DeleteRegion();

See Also

Processor Class | Processor Members


Deskew Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Deskew Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Deskew Method

Deskews the image using the specified DeskewType.

Overload List

Deskews the image using the specified DeskewType.

[Visual Basic] Overloads Public Sub Deskew(DeskewType)

[C#] public void Deskew(DeskewType);

[C++] public void Deskew(DeskewType);

[C++/CLI] public void Deskew(DeskewType);

Deskews the image using the default DeskewType.Normal.

[Visual Basic] Overloads Public Sub Deskew()

[C#] public void Deskew();

[C++] public void Deskew()

[C++/CLI] public void Deskew()

See Also

Processor Class | Processor Members


Deskew(DeskewType) Method

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

deskewType
The DeskewType to use to deskew.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Deskew(DeskewType) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > Deskew Method : Deskew(DeskewType) Method

Deskews the image using the specified DeskewType.

[Visual Basic]
Overloads Public Sub Deskew( _
   ByVal deskewType As DeskewType _
)
[C#]
public void Deskew(
   DeskewType deskewType
);
[C++]
public: void Deskew(
   DeskewType deskewType
)
[C++/CLI]
public:
void Deskew(
   DeskewType deskewType
)

Parameters

deskewType
The DeskewType to use to deskew.

Remarks

Use this method on images with a bit depth greater than one.

For bitonal (1-bit) images, use the DocumentDeskew method.

Note: Available in View, Document and Photo editions.

See Also

Processor Class | Processor Members | Overload List


Deskew() Method

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Deskew() Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > Deskew Method : Deskew() Method

Deskews the image using the default DeskewType.Normal.

[Visual Basic]
Overloads Public Sub Deskew()
[C#]
public void Deskew();
[C++]
public: void Deskew();
[C++/CLI]
public:
void Deskew();

Remarks

Use this method on images with a bit depth greater than one.

For bitonal (1-bit) images, use the DocumentDeskew method.

Note: Available in View, Document and Photo editions.

See Also

Processor Class | Processor Members | Overload List


Despeckle Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Despeckle Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Despeckle Method

Filters the image using a filter that attempts to eliminate noise in the image.

[Visual Basic]
Public Sub Despeckle()
[C#]
public void Despeckle();
[C++]
public: void Despeckle();
[C++/CLI]
public:
void Despeckle();

Remarks

The most typical use of this method is to eliminate noise or small black areas in an image. These areas are typically caused when the image is printed on a fax machine

See Also

Processor Class | Processor Members


Diffuse Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Diffuse Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Diffuse Method

Diffuses the current image by replacing each pixel with a randomly selected neighboring pixel.

[Visual Basic]
Public Sub Diffuse()
[C#]
public void Diffuse();
[C++]
public: void Diffuse();
[C++/CLI]
public:
void Diffuse();

Remarks

Note: Available in all editions.

See Also

Processor Class | Processor Members


Dilate Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Dilate Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Dilate Method

Enlarges the boundaries of regions of foreground pixels in the current image using a 3x3 maximum filter.

[Visual Basic]
Public Sub Dilate()
[C#]
public void Dilate();
[C++]
public: void Dilate();
[C++/CLI]
public:
void Dilate();

Remarks

This method enhances/fills in divets in black letters and lines on an image.

Use this method on images with a bit depth greater than 1. Use the DocumentDilate method for bitonal images.

Note: Available in all editions.

See Also

Processor Class | Processor Members


DocumentBlankPageDetect Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

Margin
An integer value which represents the number of rows of pixels to ignore on the edges (top, left, right and bottom) of the image. If IgnoreBorder is set to false, this margin applies to the sides of the original image. If IgnoreBorder is true, this margin is applied to the sides of the page, inside the detected border.
MinObjectDimension
An integer value which represents the minimum width or height of a black object considered non-blank. Set it higher to ignore larger objects (causing more pages to be considered blank) or lower to notice smaller objects (causing more pages to be considered non-blank).
GapFill
An integer value which represents the maximum spacing between black objects considered connected. Set it higher to cause broken objects to be considered as two parts of a larger object (causing more pages to be considered non-blank) or lower to cause neighboring black objects to be treated separately (causing more pages to be considered blank).
IgnoreBorder
A boolean value which is true to do a quick search for over scan in the border, then moves the detection area inside the detected over scanned border.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DocumentBlankPageDetect Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : DocumentBlankPageDetect Method

Examines a rectangle on an image, determining if the page is considered blank, based on the amont of data on the page.

[Visual Basic]
Public Sub DocumentBlankPageDetect( _
   ByVal Margin As Integer, _
   ByVal MinObjectDimension As Integer, _
   ByVal GapFill As Integer, _
   ByVal IgnoreBorder As Boolean _
)
[C#]
public void DocumentBlankPageDetect(
   int Margin,
   int MinObjectDimension,
   int GapFill,
   bool IgnoreBorder
);
[C++]
public: void DocumentBlankPageDetect(
   int Margin,
   int MinObjectDimension,
   int GapFill,
   bool IgnoreBorder
)
[C++/CLI]
public:
void DocumentBlankPageDetect(
   int Margin,
   int MinObjectDimension,
   int GapFill,
   bool IgnoreBorder
)

Parameters

Margin
An integer value which represents the number of rows of pixels to ignore on the edges (top, left, right and bottom) of the image. If IgnoreBorder is set to false, this margin applies to the sides of the original image. If IgnoreBorder is true, this margin is applied to the sides of the page, inside the detected border.
MinObjectDimension
An integer value which represents the minimum width or height of a black object considered non-blank. Set it higher to ignore larger objects (causing more pages to be considered blank) or lower to notice smaller objects (causing more pages to be considered non-blank).
GapFill
An integer value which represents the maximum spacing between black objects considered connected. Set it higher to cause broken objects to be considered as two parts of a larger object (causing more pages to be considered non-blank) or lower to cause neighboring black objects to be treated separately (causing more pages to be considered blank).
IgnoreBorder
A boolean value which is true to do a quick search for over scan in the border, then moves the detection area inside the detected over scanned border.

Remarks

ImagXpress examines an image and determines if it is blank or not, using parameters provided. The current image remains unchanged.

See Also

Processor Class | Processor Members


DocumentBlobRemoval Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

Area
A Rectangle which represents the area to remove blobs from.
MinPixelCount
An integer value which represents the minimum number of pixels for an object to be considered a blob for removal purposes.
MaxPixelCount
An integer value which represents the maximum number of pixels for an objet to be considered a blob for removal purposes.
MinDensity
An integer value which represents the ratio of black pixels to all pixels within the convex (outward angle) hull of an object. Convex hull is the smallest non concave polygon that can be made around an object.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DocumentBlobRemoval Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : DocumentBlobRemoval Method

Locates and removes large black objects in images such as binder punch holes.

[Visual Basic]
Public Sub DocumentBlobRemoval( _
   ByVal Area As Rectangle, _
   ByVal MinPixelCount As Integer, _
   ByVal MaxPixelCount As Integer, _
   ByVal MinDensity As Short _
)
[C#]
public void DocumentBlobRemoval(
   Rectangle Area,
   int MinPixelCount,
   int MaxPixelCount,
   short MinDensity
);
[C++]
public: void DocumentBlobRemoval(
   Rectangle Area,
   int MinPixelCount,
   int MaxPixelCount,
   short MinDensity
)
[C++/CLI]
public:
void DocumentBlobRemoval(
   Rectangle Area,
   int MinPixelCount,
   int MaxPixelCount,
   short MinDensity
)

Parameters

Area
A Rectangle which represents the area to remove blobs from.
MinPixelCount
An integer value which represents the minimum number of pixels for an object to be considered a blob for removal purposes.
MaxPixelCount
An integer value which represents the maximum number of pixels for an objet to be considered a blob for removal purposes.
MinDensity
An integer value which represents the ratio of black pixels to all pixels within the convex (outward angle) hull of an object. Convex hull is the smallest non concave polygon that can be made around an object.

Remarks

ImagXpress removes only black images on a white image. To remove white pixels on a black image requires prior processing, to negate the bitonal image. You can specify a subset of the image to speed processing time and limit unwanted blob removal.

The mage is examined for the blobs, such as the black holes left on copies by binder hole punches in the original image. Blobs within the specified region are removed from the current image.

ImagXpress finds black blobs meeting the specified minimum pixel count and yet not exceeding the specified maximum pixel count. The removed blobs are replaced with white pixels. Without a set detection area, the entire image is examined and updated if it meets the criteria. If a blob is detected on the boundaries of a sub-image, only the portion of the blob within the boundaries is removed.

See Also

Processor Class | Processor Members


DocumentBorderCrop Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DocumentBorderCrop Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : DocumentBorderCrop Method

Crops the borders of documents.

[Visual Basic]
Public Sub DocumentBorderCrop()
[C#]
public void DocumentBorderCrop();
[C++]
public: void DocumentBorderCrop();
[C++/CLI]
public:
void DocumentBorderCrop();

Remarks

This method is the process of detecting and removing vertical and horizontal lines from the outside rim of a document. The method examines the current document to find dark exterior lines along the outside edge, modifying it to remove them. If the area defined by the crop parameters does not fall within the boundaries of the document, the document is not cropped and an error generates.

See Also

Processor Class | Processor Members


DocumentDeskew Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DocumentDeskew Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : DocumentDeskew Method

Automatically detects and removes skew from current 1-bit depth images.

Overload List

Automatically detects and removes skew from current 1-bit depth images.

[Visual Basic] Overloads Public Sub DocumentDeskew(Double,Short,Integer,Boolean,Short)

[C#] public void DocumentDeskew(double,short,int,bool,short);

[C++] public void DocumentDeskew(double,short,int,bool,short);

[C++/CLI] public void DocumentDeskew(double,short,int,bool,short);

Automatically detects and removes skew from current 1-bit depth images.

[Visual Basic] Overloads Public Sub DocumentDeskew(Double,Short,Color,Boolean,Short)

[C#] public void DocumentDeskew(double,short,Color,bool,short);

[C++] public void DocumentDeskew(double,short,Color,bool,short);

[C++/CLI] public void DocumentDeskew(double,short,Color,bool,short);

See Also

Processor Class | Processor Members


DocumentDeskew(Double,Int16,Int32,Boolean,Int16) Method

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

MinimumAngle
A double value which represents the minimum angle, in degrees, to deskew. This allows you to keep images with small amounts os skew untouched potentially increasing performance in batch operations where some skew is acceptable. Angles less than or equal to this amount will not be corrected.
MinimumConfidence
An integer value which represents the minimum detection confidence required before correction will proceed.
PadColor
An integer value which represents the pad color.
MaintainOriginalSize
A boolean value which is true to maintain the original size. Otherwise, false should be used.
Quality
An integer value which indicates the amount of effort to expend analyzing the image to determine the correct skew. Set to a high value to insure the most accurate possible result and to a low value for fastest operation.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DocumentDeskew(Double,Int16,Int32,Boolean,Int16) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > DocumentDeskew Method : DocumentDeskew(Double,Int16,Int32,Boolean,Int16) Method

Automatically detects and removes skew from current 1-bit depth images.

[Visual Basic]
<ObsoleteAttribute()>
Overloads Public Sub DocumentDeskew( _
   ByVal MinimumAngle As Double, _
   ByVal MinimumConfidence As Short, _
   ByVal PadColor As Integer, _
   ByVal MaintainOriginalSize As Boolean, _
   ByVal Quality As Short _
)
[C#]
[ObsoleteAttribute()]
public void DocumentDeskew(
   double MinimumAngle,
   short MinimumConfidence,
   int PadColor,
   bool MaintainOriginalSize,
   short Quality
);
[C++]
[ObsoleteAttribute()]
public: void DocumentDeskew(
   double MinimumAngle,
   short MinimumConfidence,
   int PadColor,
   bool MaintainOriginalSize,
   short Quality
)
[C++/CLI]
[ObsoleteAttribute()]
public:
void DocumentDeskew(
   double MinimumAngle,
   short MinimumConfidence,
   int PadColor,
   bool MaintainOriginalSize,
   short Quality
)

Parameters

MinimumAngle
A double value which represents the minimum angle, in degrees, to deskew. This allows you to keep images with small amounts os skew untouched potentially increasing performance in batch operations where some skew is acceptable. Angles less than or equal to this amount will not be corrected.
MinimumConfidence
An integer value which represents the minimum detection confidence required before correction will proceed.
PadColor
An integer value which represents the pad color.
MaintainOriginalSize
A boolean value which is true to maintain the original size. Otherwise, false should be used.
Quality
An integer value which indicates the amount of effort to expend analyzing the image to determine the correct skew. Set to a high value to insure the most accurate possible result and to a low value for fastest operation.

Remarks

Deskew is the process of straightening an image by examining it and determining the appropriate amount of rotation needed for correct alignment.

The detection process focuses on the content of the image, such as text and drawings, rather than the border. Deskew adjusts along the vertical and horizontal axes, optimizing each to provide the best image.

If no image is present, an error is indicated. ImagXpress validates the input, detects the skew, corrects the skew (if necessary) and returns results from the process.

This method is only corrected if the detection confidence is greater than or equal to the MinimumConfidence input and the skew angle is greater than the MinimumAngle input.

If the skew is corrected and MaintainOriginalSize is False, then the previous current image is released and a new DIB is created to hold the new current image. No error is returned if the previous current image could not be released. If the operation fails, the current image is unchanged.

See Also

Processor Class | Processor Members | Overload List


DocumentDeskew(Double,Int16,Color,Boolean,Int16) Method

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

MinimumAngle
A double value which represents the minimum angle, in degrees, to deskew. This allows you to keep images with small amounts os skew untouched potentially increasing performance in batch operations where some skew is acceptable. Angles less than or equal to this amount will not be corrected.
MinimumConfidence
An integer value which represents the minimum detection confidence required before correction will proceed.
PadColor
A Color value for the padding. Valid values are only Color.Black and Color.White.
MaintainOriginalSize
A boolean value which is true to maintain the original size. Otherwise, false should be used.
Quality
An integer value which indicates the amount of effort to expend analyzing the image to determine the correct skew. Set to a high value to insure the most accurate possible result and to a low value for fastest operation.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DocumentDeskew(Double,Int16,Color,Boolean,Int16) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > DocumentDeskew Method : DocumentDeskew(Double,Int16,Color,Boolean,Int16) Method

Automatically detects and removes skew from current 1-bit depth images.

[Visual Basic]
Overloads Public Sub DocumentDeskew( _
   ByVal MinimumAngle As Double, _
   ByVal MinimumConfidence As Short, _
   ByVal PadColor As Color, _
   ByVal MaintainOriginalSize As Boolean, _
   ByVal Quality As Short _
)
[C#]
public void DocumentDeskew(
   double MinimumAngle,
   short MinimumConfidence,
   Color PadColor,
   bool MaintainOriginalSize,
   short Quality
);
[C++]
public: void DocumentDeskew(
   double MinimumAngle,
   short MinimumConfidence,
   Color PadColor,
   bool MaintainOriginalSize,
   short Quality
)
[C++/CLI]
public:
void DocumentDeskew(
   double MinimumAngle,
   short MinimumConfidence,
   Color PadColor,
   bool MaintainOriginalSize,
   short Quality
)

Parameters

MinimumAngle
A double value which represents the minimum angle, in degrees, to deskew. This allows you to keep images with small amounts os skew untouched potentially increasing performance in batch operations where some skew is acceptable. Angles less than or equal to this amount will not be corrected.
MinimumConfidence
An integer value which represents the minimum detection confidence required before correction will proceed.
PadColor
A Color value for the padding. Valid values are only Color.Black and Color.White.
MaintainOriginalSize
A boolean value which is true to maintain the original size. Otherwise, false should be used.
Quality
An integer value which indicates the amount of effort to expend analyzing the image to determine the correct skew. Set to a high value to insure the most accurate possible result and to a low value for fastest operation.

Remarks

Deskew is the process of straightening an image by examining it and determining the appropriate amount of rotation needed for correct alignment.

The detection process focuses on the content of the image, such as text and drawings, rather than the border. Deskew adjusts along the vertical and horizontal axes, optimizing each to provide the best image.

If no image is present, an error is indicated. ImagXpress validates the input, detects the skew, corrects the skew (if necessary) and returns results from the process.

This method is only corrected if the detection confidence is greater than or equal to the MinimumConfidence input and the skew angle is greater than the MinimumAngle input.

If the skew is corrected and MaintainOriginalSize is False, then the previous current image is released and a new DIB is created to hold the new current image. No error is returned if the previous current image could not be released. If the operation fails, the current image is unchanged.

See Also

Processor Class | Processor Members | Overload List


DocumentDespeckle Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

SpeckWidth
An integer value which represents the maximum width an object is considered a speck.
SpeckHeight
An integer value which represents the maximum height an object is considered a speck.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DocumentDespeckle Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : DocumentDespeckle Method

Detects and removes specks from the current image.

[Visual Basic]
Public Sub DocumentDespeckle( _
   ByVal SpeckWidth As Short, _
   ByVal SpeckHeight As Short _
)
[C#]
public void DocumentDespeckle(
   short SpeckWidth,
   short SpeckHeight
);
[C++]
public: void DocumentDespeckle(
   short SpeckWidth,
   short SpeckHeight
)
[C++/CLI]
public:
void DocumentDespeckle(
   short SpeckWidth,
   short SpeckHeight
)

Parameters

SpeckWidth
An integer value which represents the maximum width an object is considered a speck.
SpeckHeight
An integer value which represents the maximum height an object is considered a speck.

Remarks

Despeckle is the process of removing random specks of noise from an image. The DocumentDespeckle method examines the current image to find objects meeting the current criteria for specks and then removes them. If no parameters are provided, the defaults are used.

See Also

Processor Class | Processor Members


DocumentDilate Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

Amount
An integer which represents the the distance, in pixels, to extend the black pixels.
Direction
A EnhancementDirection value which determines the direction to apply the dilation. Black pixels are expanded in this direction. Typically, this is set to a single direction, a pair of directions, or all direction.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DocumentDilate Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : DocumentDilate Method

Examines pixels in the current image and expands the black ones by the given amount in a given direction.

[Visual Basic]
Public Sub DocumentDilate( _
   ByVal Amount As Short, _
   ByVal Direction As EnhancementDirection _
)
[C#]
public void DocumentDilate(
   short Amount,
   EnhancementDirection Direction
);
[C++]
public: void DocumentDilate(
   short Amount,
   EnhancementDirection Direction
)
[C++/CLI]
public:
void DocumentDilate(
   short Amount,
   EnhancementDirection Direction
)

Parameters

Amount
An integer which represents the the distance, in pixels, to extend the black pixels.
Direction
A EnhancementDirection value which determines the direction to apply the dilation. Black pixels are expanded in this direction. Typically, this is set to a single direction, a pair of directions, or all direction.

Remarks

This method validates the input, examines the pixels, expands the black pixels, and returns results from the detection and correction process.

The Dilate object contains parameters that control the dilate process. If no parameters are provided, the current image has its black pixels expanded by one in all directions.

See Also

Processor Class | Processor Members


DocumentErode Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

Amount
The distance to reduce the black pixels.
Direction
An EnhancementDirection which determines the direction to apply the erosion. Black pixels are removed in this direction. Typically, this is set to a single direction, a pair of directions, or all direction.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DocumentErode Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : DocumentErode Method

Removes the black pixels in the current image by the given amount in the given direction.

[Visual Basic]
Public Sub DocumentErode( _
   ByVal Amount As Short, _
   ByVal Direction As EnhancementDirection _
)
[C#]
public void DocumentErode(
   short Amount,
   EnhancementDirection Direction
);
[C++]
public: void DocumentErode(
   short Amount,
   EnhancementDirection Direction
)
[C++/CLI]
public:
void DocumentErode(
   short Amount,
   EnhancementDirection Direction
)

Parameters

Amount
The distance to reduce the black pixels.
Direction
An EnhancementDirection which determines the direction to apply the erosion. Black pixels are removed in this direction. Typically, this is set to a single direction, a pair of directions, or all direction.

Remarks

Erosion is the process of removing the specified number of black pixels from the existing black pixels on the specified edge or edges of an image.

Note: Available in Document and Photo Editions.

See Also

Processor Class | Processor Members


DocumentLineRemoval Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

MinLength
An integer which represents the minimum pixel length of a line to meet removal criteria.
MaxThickness
An integer which represents the maximum pixel thickness of a line meeting the removal criteria.
MinAspectRatio
A double value which represents the ratio of the line length to the line width. Lines below this aspect ratio are removed. The ratio range is any floating point number between 1 and 1000. The typical value is 12. This provides a ratio of 120 pixels in length for every 10 pixels in width.
MaxGap
An integer value which represents the maximum allowed gap in a line for the line to still be considered one object. This value should be an integer from 1 to 20.
MaxCharRepairSize
An integer value which represents the maximum character size to reconstruct intersected characters within the given size after performing line removal. This value should be a positive integer including zero. The default value is 20.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DocumentLineRemoval Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : DocumentLineRemoval Method

Automatically detects and removes lines from the current image.

[Visual Basic]
Public Sub DocumentLineRemoval( _
   ByVal MinLength As Integer, _
   ByVal MaxThickness As Short, _
   ByVal MinAspectRatio As Double, _
   ByVal MaxGap As Short, _
   ByVal MaxCharRepairSize As Short _
)
[C#]
public void DocumentLineRemoval(
   int MinLength,
   short MaxThickness,
   double MinAspectRatio,
   short MaxGap,
   short MaxCharRepairSize
);
[C++]
public: void DocumentLineRemoval(
   int MinLength,
   short MaxThickness,
   double MinAspectRatio,
   short MaxGap,
   short MaxCharRepairSize
)
[C++/CLI]
public:
void DocumentLineRemoval(
   int MinLength,
   short MaxThickness,
   double MinAspectRatio,
   short MaxGap,
   short MaxCharRepairSize
)

Parameters

MinLength
An integer which represents the minimum pixel length of a line to meet removal criteria.
MaxThickness
An integer which represents the maximum pixel thickness of a line meeting the removal criteria.
MinAspectRatio
A double value which represents the ratio of the line length to the line width. Lines below this aspect ratio are removed. The ratio range is any floating point number between 1 and 1000. The typical value is 12. This provides a ratio of 120 pixels in length for every 10 pixels in width.
MaxGap
An integer value which represents the maximum allowed gap in a line for the line to still be considered one object. This value should be an integer from 1 to 20.
MaxCharRepairSize
An integer value which represents the maximum character size to reconstruct intersected characters within the given size after performing line removal. This value should be a positive integer including zero. The default value is 20.

Remarks

Line removal is the process of detecting and removing vertical and horizontal lines from an image. This method examines the current image to find lines and modifies the image to remove them. If no parameters are provided, defaults are used.

See Also

Processor Class | Processor Members


DocumentShear Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

ShearAngle
A double value which represents the shear angle at which the image is sheared in degrees. Positive values shear counter-clockwise, while negative values shear clockwise.
PadColor
A long value which represents the pad color. The default value is white.
ShearType
A ShearType value which determines the type of shear to modify the image with.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DocumentShear Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : DocumentShear Method

Shears current image clockwise or counter-clockwise.

[Visual Basic]
Public Sub DocumentShear( _
   ByVal ShearAngle As Double, _
   ByVal PadColor As Integer, _
   ByVal ShearType As ShearType _
)
[C#]
public void DocumentShear(
   double ShearAngle,
   int PadColor,
   ShearType ShearType
);
[C++]
public: void DocumentShear(
   double ShearAngle,
   int PadColor,
   ShearType ShearType
)
[C++/CLI]
public:
void DocumentShear(
   double ShearAngle,
   int PadColor,
   ShearType ShearType
)

Parameters

ShearAngle
A double value which represents the shear angle at which the image is sheared in degrees. Positive values shear counter-clockwise, while negative values shear clockwise.
PadColor
A long value which represents the pad color. The default value is white.
ShearType
A ShearType value which determines the type of shear to modify the image with.

See Also

Processor Class | Processor Members


DocumentZoomSmooth Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DocumentZoomSmooth Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : DocumentZoomSmooth Method

Replaces the current 1 bit-per-pixel image with an image whose width and height have been doubled and whose pixels have been smoothed.

[Visual Basic]
Public Sub DocumentZoomSmooth()
[C#]
public void DocumentZoomSmooth();
[C++]
public: void DocumentZoomSmooth();
[C++/CLI]
public:
void DocumentZoomSmooth();

Remarks

This method smooths letters and lines, by first doubling their width and height, then dilating and eroding as required. The result is a larger image, with clearer letters and lines.

See Also

Processor Class | Processor Members


Emboss Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Emboss Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Emboss Method

Performs an emboss on the image causing it to look embellished with metal or embroidered look.

[Visual Basic]
Public Sub Emboss()
[C#]
public void Emboss();
[C++]
public: void Emboss();
[C++/CLI]
public:
void Emboss();

Remarks

Note: Available in all editions.

See Also

Processor Class | Processor Members


Equalize Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Equalize Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Equalize Method

Equalizes the image by spreading its values across the full image.

[Visual Basic]
Public Sub Equalize()
[C#]
public void Equalize();
[C++]
public: void Equalize();
[C++/CLI]
public:
void Equalize();

Remarks

This method adjusts contrast without changing the brightness range of the image. If the brightness values of the image were represented in a histogram, the Equalize method would have the effect of redistributing the brightness values within the image's brightness range, so that blumps of brightness values are spread out more evenly.

For example, if an image has many pixels that have similar brightness, the Equalize method introduces greater difference in brightness between these pixels, without changing the least bright or most bright pixels.

The effect is that greater detail can be seen in areas that previously had very similar brightness.

Note: Available in all editions.

See Also

Processor Class | Processor Members


Erode Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Erode Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Erode Method

Erodes the image by eroding away the boundaries using a 3x3 minimum filter.

[Visual Basic]
Public Sub Erode()
[C#]
public void Erode();
[C++]
public: void Erode();
[C++/CLI]
public:
void Erode();

Remarks

Reduces and/or erases protrusions from black letters and lines.

Use this method with images that are greater than 1 bit.

For bitonal images, use the DocumentErode method.

Note: Available in all editions.

See Also

Processor Class | Processor Members


Flip Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Flip Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Flip Method

Flips the current image from top to bottom.

[Visual Basic]
Public Sub Flip()
[C#]
public void Flip();
[C++]
public: void Flip();
[C++/CLI]
public:
void Flip();

Remarks

Note: Available in all editions.

See Also

Processor Class | Processor Members


Gamma Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

gamma
A float value which represents a single value that determines the magnitude of the gamma correction.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Gamma Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Gamma Method

Specifies the gamma correction.

[Visual Basic]
Public Sub Gamma( _
   ByVal gamma As Single _
)
[C#]
public void Gamma(
   float gamma
);
[C++]
public: void Gamma(
   float gamma
)
[C++/CLI]
public:
void Gamma(
   float gamma
)

Parameters

gamma
A float value which represents a single value that determines the magnitude of the gamma correction.

Remarks

Valid values are between 0.1 and 10.0.

Because monitors output pixel brightness in a non-linear fashion, the image brightness is not accurately portrayed. Adjusting the gamma enables you to adjust pixel brightness to compensate for the linitations of the display device. The gamma value represents the ratio of input vs. output brightness. A gamma of one represents a linear relationship between input and output brightness - no change is made to the image. A gamma other than one represents a parabolic relationship between input and output brightness.

Applying a gamma = 1 results in no change to the image.

Applying a gamma greater than one results in brightening the image, with mid-brightness levels increased more than extremely dark or light pixels.

Applying a gamma less than one results in darkening the image, with mid-brightness levels decreased more than extremely dark or light pixels.

Note: Available in all editions.

See Also

Processor Class | Processor Members


Matrix Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

nIPMatrixV
An integer 16 which represents a simple array or short with 9 elements.

The range is from -32767 to 32767.

The nIPMatrixV is mapped to a 3x3 array used for filtering the image.

nIPMatrixD

An integer 16 which represents the divisor of the matrix filter values.

The range is from -999 to 999.

Note: An exception is thrown if 0 is used as it is not divisable by 0.

nIPMatrixI

An integer 16 which represents the intensity of the matrix.

The range is from 0 to 255.

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Matrix Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Matrix Method

Modifies the image using a 3x3 consolution matrix filter.

[Visual Basic]
Public Sub Matrix( _
   ByVal nIPMatrixV() As Short, _
   ByVal nIPMatrixD As Short, _
   ByVal nIPMatrixI As Short _
)
[C#]
public void Matrix(
   short[] nIPMatrixV,
   short nIPMatrixD,
   short nIPMatrixI
);
[C++]
public: void Matrix(
   short[]* nIPMatrixV,
   short nIPMatrixD,
   short nIPMatrixI
)
[C++/CLI]
public:
void Matrix(
   shortarray<nIPMatrixV>^ nIPMatrixV,
   short nIPMatrixD,
   short nIPMatrixI
)

Parameters

nIPMatrixV
An integer 16 which represents a simple array or short with 9 elements.

The range is from -32767 to 32767.

The nIPMatrixV is mapped to a 3x3 array used for filtering the image.

nIPMatrixD

An integer 16 which represents the divisor of the matrix filter values.

The range is from -999 to 999.

Note: An exception is thrown if 0 is used as it is not divisable by 0.

nIPMatrixI

An integer 16 which represents the intensity of the matrix.

The range is from 0 to 255.

Remarks

The matrix filter alters each pixel's color based on its current color and the colors of any neighboring pixels. The array of nIPMatrixV matrix values are coefficients. When a pixel is processed, its color value is multiplied by the coefficient in the arry's center and any pixels within the 3x3 grid are multiplied by the corresponding coefficients in the array. The sum of the products becomes the target pixel's new value.

The nIPMatrixD parameter is the coefficient denominator. Each coefficient in the filter matrix is divided by the divisor before being applied to a pixel.

The nIPMatrixI parameter is added to the product of the matrix calculation and the divisor to shift the value of each pixel by a fixed amount.

See Also

Processor Class | Processor Members


Median Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Median Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Median Method

Reduces noise on an image by using a 3x3 median filter.

[Visual Basic]
Public Sub Median()
[C#]
public void Median();
[C++]
public: void Median();
[C++/CLI]
public:
void Median();

Remarks

Note: Available in Standard, Document and Photo editions.

See Also

Processor Class | Processor Members


Merge Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

sourceImage
The image that is to be merged with the image in the processor
mergeSize
The area/size the image is to be merged
mergeStyle
The style of merge that is to be performed
transparent
Merging occurs with transparency or none
transparentColor
The color that is to be the transparent color if transparency is enabled
mergePercentHigh
Determines the upper range of the superimpose intensity when the MergeStyle is a superimpose style
mergePercentLow
Determines the lower range of the superimpose intenisty when the MergeStyle is a superimpose style
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Merge Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Merge Method

Merges two images together such that the source image is merged with the current image specified in the processor. This method also specifies the type of merging.

[Visual Basic]
Public Sub Merge( _
   ByRef sourceImage As ImageX, _
   ByVal mergeSize As MergeSize, _
   ByVal mergeStyle As MergeStyle, _
   ByVal transparent As Boolean, _
   ByVal transparentColor As Color, _
   ByVal mergePercentHigh As Integer, _
   ByVal mergePercentLow As Integer _
)
[C#]
public void Merge(
   ref ImageX sourceImage,
   MergeSize mergeSize,
   MergeStyle mergeStyle,
   bool transparent,
   Color transparentColor,
   int mergePercentHigh,
   int mergePercentLow
);
[C++]
public: void Merge(
   ref ImageX* sourceImage,
   MergeSize mergeSize,
   MergeStyle mergeStyle,
   bool transparent,
   Color transparentColor,
   int mergePercentHigh,
   int mergePercentLow
)
[C++/CLI]
public:
void Merge(
   % ImageX^ sourceImage,
   MergeSize mergeSize,
   MergeStyle mergeStyle,
   bool transparent,
   Color transparentColor,
   int mergePercentHigh,
   int mergePercentLow
)

Parameters

sourceImage
The image that is to be merged with the image in the processor
mergeSize
The area/size the image is to be merged
mergeStyle
The style of merge that is to be performed
transparent
Merging occurs with transparency or none
transparentColor
The color that is to be the transparent color if transparency is enabled
mergePercentHigh
Determines the upper range of the superimpose intensity when the MergeStyle is a superimpose style
mergePercentLow
Determines the lower range of the superimpose intenisty when the MergeStyle is a superimpose style

Remarks

Merging combines the current image being processed with another specified ImageX image. The resulting merged image is stored in Image.

If an area or region is active when the Merge method is called, then the source image is merged with the active region or area on the target image.

When the images being merged are both TIFF files that have tags, ensure that the tags are saved when merging, by first capturing the tags, then merging, then applying the tags again.

If either of the images being merged has a bit depth of less than 24 bits, then both images are converted to 24-bit images, then merged.

If either of the images being merged has an associated color profile, then each image's profile is applied, then the images are merged. No color is retained.

Note: Sprites also offer the capability of merging a part of an image with another one, but it is more limited in capability.

Note: Available in Standard, Document and Photo editions.

See Also

Processor Class | Processor Members


Mirror Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Mirror Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Mirror Method

Rotates the current DIB (Device Independent Bitmap) 180 degrees, then flips it to create a mirror image.

[Visual Basic]
Public Sub Mirror()
[C#]
public void Mirror();
[C++]
public: void Mirror();
[C++/CLI]
public:
void Mirror();

Remarks

Note: Available in Standard, Document and Photo editions.

See Also

Processor Class | Processor Members


Mosaic Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

blockSize

An integer value which represents the block size.

The range is from 1 to 63.

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Mosaic Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Mosaic Method

Creates tiles or cells to represents the image.

[Visual Basic]
Public Sub Mosaic( _
   ByVal blockSize As Integer _
)
[C#]
public void Mosaic(
   int blockSize
);
[C++]
public: void Mosaic(
   int blockSize
)
[C++/CLI]
public:
void Mosaic(
   int blockSize
)

Parameters

blockSize

An integer value which represents the block size.

The range is from 1 to 63.

Remarks

Note: Available in Standard, Document and Photo editions.

See Also

Processor Class | Processor Members


MotionBlur Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

intensity

An integer which represents the intensity of the blur.

The range is from 1 to 25.

Larger values result in a larger blurring result.

velocityX

An integer which represents the horizontal velocity.

The range is from -10 to 10.

Negaive values blur from right to left; postitive values blur from left to right.

velocityY

An integer which represents the vertical velocity.

The range is from -10 to 10.

Negative values blur from bottom to top; positive values blur from top to bottom.

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

MotionBlur Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : MotionBlur Method

Streaks or blurs objects on the image to display them as moving using the specified parameters.

[Visual Basic]
Public Sub MotionBlur( _
   ByVal intensity As Integer, _
   ByVal velocityX As Integer, _
   ByVal velocityY As Integer _
)
[C#]
public void MotionBlur(
   int intensity,
   int velocityX,
   int velocityY
);
[C++]
public: void MotionBlur(
   int intensity,
   int velocityX,
   int velocityY
)
[C++/CLI]
public:
void MotionBlur(
   int intensity,
   int velocityX,
   int velocityY
)

Parameters

intensity

An integer which represents the intensity of the blur.

The range is from 1 to 25.

Larger values result in a larger blurring result.

velocityX

An integer which represents the horizontal velocity.

The range is from -10 to 10.

Negaive values blur from right to left; postitive values blur from left to right.

velocityY

An integer which represents the vertical velocity.

The range is from -10 to 10.

Negative values blur from bottom to top; positive values blur from top to bottom.

Remarks

Note: Available in all editions.

See Also

Processor Class | Processor Members


Negate Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Negate Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Negate Method (Processor)

Creates a color negative of the current image.

[Visual Basic]
Public Sub Negate()
[C#]
public void Negate();
[C++]
public: void Negate();
[C++/CLI]
public:
void Negate();

Remarks

Note: Available in Standard, Document and Photo editions.

See Also

Processor Class | Processor Members


Noise Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

frequency
intensity
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Noise Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Noise Method
[Visual Basic]
Public Sub Noise( _
   ByVal frequency As Integer, _
   ByVal intensity As Integer _
)
[C#]
public void Noise(
   int frequency,
   int intensity
);
[C++]
public: void Noise(
   int frequency,
   int intensity
)
[C++/CLI]
public:
void Noise(
   int frequency,
   int intensity
)

Parameters

frequency
intensity

See Also

Processor Class | Processor Members


Outline Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Outline Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Outline Method

Outlines the outter edges of the image by enhancing the edges.

[Visual Basic]
Public Sub Outline()
[C#]
public void Outline();
[C++]
public: void Outline();
[C++/CLI]
public:
void Outline();

Remarks

Note: Available in all editions.

See Also

Processor Class | Processor Members


Parabolic Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

type
The ParabolicType to use to transform the image.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Parabolic Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Parabolic Method

Modifies the image by the given ParabolicType.

[Visual Basic]
Public Sub Parabolic( _
   ByVal type As ParabolicType _
)
[C#]
public void Parabolic(
   ParabolicType type
);
[C++]
public: void Parabolic(
   ParabolicType type
)
[C++/CLI]
public:
void Parabolic(
   ParabolicType type
)

Parameters

type
The ParabolicType to use to transform the image.

Remarks

The Parabolic method adjusts the brightness of the image based on either a convex or concave parabolic transform, as specified. The convex parabolic transform darkens the pixels at the high and low range of the image's brightness spectrum, and brightens the pixels in the middle range. The concave parabolic transform brightens the pixels at the high and low range of the image's brightness spectrum, and darkens pixels in the mid-range.

Note: Available in all editions.

See Also

Processor Class | Processor Members


Perspective Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

perspectiveType
The ParabolicType to use.
percent

An integer which represents the percentage to modify the image.

The range is from 0 to 100.

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Perspective Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Perspective Method

Modifies the image using the given PerspectiveType and percent.

[Visual Basic]
Public Sub Perspective( _
   ByVal perspectiveType As PerspectiveType, _
   ByVal percent As Integer _
)
[C#]
public void Perspective(
   PerspectiveType perspectiveType,
   int percent
);
[C++]
public: void Perspective(
   PerspectiveType perspectiveType,
   int percent
)
[C++/CLI]
public:
void Perspective(
   PerspectiveType perspectiveType,
   int percent
)

Parameters

perspectiveType
The ParabolicType to use.
percent

An integer which represents the percentage to modify the image.

The range is from 0 to 100.

Remarks

This method gives the effect of an altered perspective.

Note: Available in all editions.

See Also

Processor Class | Processor Members


Pinch Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

intensity

An integer value which represents the intensity of the pinch.

The range is from -100 to 100.

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Pinch Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Pinch Method

Modifies the image to look like it was pinched in the center using the given intensity.

[Visual Basic]
Public Sub Pinch( _
   ByVal intensity As Integer _
)
[C#]
public void Pinch(
   int intensity
);
[C++]
public: void Pinch(
   int intensity
)
[C++/CLI]
public:
void Pinch(
   int intensity
)

Parameters

intensity

An integer value which represents the intensity of the pinch.

The range is from -100 to 100.

Remarks

Positive intensity values give the current image an appearance of being pinched in the center. Negative values give the image an appearance of stretching from the center.

Note: Available in all editions.

See Also

Processor Class | Processor Members


PolynomialWarp Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingPoint1
A point value which represents the first bounding point.
boundingPoint2
A point value which represents the second bounding point.
boundingPoint3
A point value which represents the third bounding point.
boundingPoint4
A point value which represents the fourth bounding point.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PolynomialWarp Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : PolynomialWarp Method

Modifies and warps the image to the given points.

[Visual Basic]
Public Sub PolynomialWarp( _
   ByVal boundingPoint1 As Point, _
   ByVal boundingPoint2 As Point, _
   ByVal boundingPoint3 As Point, _
   ByVal boundingPoint4 As Point _
)
[C#]
public void PolynomialWarp(
   Point boundingPoint1,
   Point boundingPoint2,
   Point boundingPoint3,
   Point boundingPoint4
);
[C++]
public: void PolynomialWarp(
   Point boundingPoint1,
   Point boundingPoint2,
   Point boundingPoint3,
   Point boundingPoint4
)
[C++/CLI]
public:
void PolynomialWarp(
   Point boundingPoint1,
   Point boundingPoint2,
   Point boundingPoint3,
   Point boundingPoint4
)

Parameters

boundingPoint1
A point value which represents the first bounding point.
boundingPoint2
A point value which represents the second bounding point.
boundingPoint3
A point value which represents the third bounding point.
boundingPoint4
A point value which represents the fourth bounding point.

Remarks

The parameters affix coordinate points to boundary areas to warp the image.

Note: Available in all editions.

See Also

Processor Class | Processor Members


Posterize Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

numberOfLevels
An integer value which represents the number of levels to posterize.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Posterize Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Posterize Method

Reduces the number of colors to give it the effect of contours in the image.

[Visual Basic]
Public Sub Posterize( _
   ByVal numberOfLevels As Integer _
)
[C#]
public void Posterize(
   int numberOfLevels
);
[C++]
public: void Posterize(
   int numberOfLevels
)
[C++/CLI]
public:
void Posterize(
   int numberOfLevels
)

Parameters

numberOfLevels
An integer value which represents the number of levels to posterize.

Remarks

Valid values are between 2 and 255.

This method has the effect of creating posterized contours in the image. For example, a value of 3 indicates 3 levels or red, 3 levels of green, and 3 levels of blue.

Note: Available in all editions.

See Also

Processor Class | Processor Members


RemoveDust Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

defectThreshold

An integer value which represents the defect threshold.

The range is from -255 to 255.

defectFilterAdjustment

An integer value which represents the defect filter adjustment.

The range is from -6 to 2.

defectSmoothingAdjustment

An integer value which represents the defect smoothing adjustment.

The range is from -5 o 100.

defectType
A DefectType.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RemoveDust Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : RemoveDust Method

Removes what appears to be dust on the image by the given parameters.

[Visual Basic]
Public Sub RemoveDust( _
   ByVal defectThreshold As Integer, _
   ByVal defectFilterAdjustment As Integer, _
   ByVal defectSmoothingAdjustment As Integer, _
   ByVal defectType As DefectType _
)
[C#]
public void RemoveDust(
   int defectThreshold,
   int defectFilterAdjustment,
   int defectSmoothingAdjustment,
   DefectType defectType
);
[C++]
public: void RemoveDust(
   int defectThreshold,
   int defectFilterAdjustment,
   int defectSmoothingAdjustment,
   DefectType defectType
)
[C++/CLI]
public:
void RemoveDust(
   int defectThreshold,
   int defectFilterAdjustment,
   int defectSmoothingAdjustment,
   DefectType defectType
)

Parameters

defectThreshold

An integer value which represents the defect threshold.

The range is from -255 to 255.

defectFilterAdjustment

An integer value which represents the defect filter adjustment.

The range is from -6 to 2.

defectSmoothingAdjustment

An integer value which represents the defect smoothing adjustment.

The range is from -5 o 100.

defectType
A DefectType.

Remarks

Before calling this method you must set an area using the Processor.SetArea method.

Note: Available in Photo edition.

See Also

Processor Class | Processor Members


RemoveRedeye Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

precision
A RedeyePrecision value to modify the image.
eyeShade
A RedeyeShade to use to modify the shade of the eye.
eyeGlare
A RedeyeGlare to modify the glare of the eye.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RemoveRedeye Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : RemoveRedeye Method

Removes what appears as red eye's in an image using the given parameters.

[Visual Basic]
Public Sub RemoveRedeye( _
   ByVal precision As RedeyePrecision, _
   ByVal eyeShade As RedeyeShade, _
   ByVal eyeGlare As RedeyeGlare _
)
[C#]
public void RemoveRedeye(
   RedeyePrecision precision,
   RedeyeShade eyeShade,
   RedeyeGlare eyeGlare
);
[C++]
public: void RemoveRedeye(
   RedeyePrecision precision,
   RedeyeShade eyeShade,
   RedeyeGlare eyeGlare
)
[C++/CLI]
public:
void RemoveRedeye(
   RedeyePrecision precision,
   RedeyeShade eyeShade,
   RedeyeGlare eyeGlare
)

Parameters

precision
A RedeyePrecision value to modify the image.
eyeShade
A RedeyeShade to use to modify the shade of the eye.
eyeGlare
A RedeyeGlare to modify the glare of the eye.

Remarks

Before calling this method you must set an area using the Processor.SetArea method.

Note: Available in Photo edition.

See Also

Processor Class | Processor Members


RemoveScratches Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

scratchStartingPoint
A point value which represents the scratch starting point.
scratchEndingPoint
A point value which represents the scratch ending point.
scratchLineWidth
An integer value which represents the scratch line width.
scratchThreshold
An integer value which represents the scratch threshold.
scratchFilterAdjustment
An integer value which represents the scratch filter adjustment.
scratchSmoothingAdjustment
An integer value which represents the scratch smoothing adjustment.
scratchType
The DefectType.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RemoveScratches Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : RemoveScratches Method

Removes what appear to be scratches from the image using the given parameters.

[Visual Basic]
Public Sub RemoveScratches( _
   ByVal scratchStartingPoint As Point, _
   ByVal scratchEndingPoint As Point, _
   ByVal scratchLineWidth As Integer, _
   ByVal scratchThreshold As Integer, _
   ByVal scratchFilterAdjustment As Integer, _
   ByVal scratchSmoothingAdjustment As Integer, _
   ByVal scratchType As DefectType _
)
[C#]
public void RemoveScratches(
   Point scratchStartingPoint,
   Point scratchEndingPoint,
   int scratchLineWidth,
   int scratchThreshold,
   int scratchFilterAdjustment,
   int scratchSmoothingAdjustment,
   DefectType scratchType
);
[C++]
public: void RemoveScratches(
   Point scratchStartingPoint,
   Point scratchEndingPoint,
   int scratchLineWidth,
   int scratchThreshold,
   int scratchFilterAdjustment,
   int scratchSmoothingAdjustment,
   DefectType scratchType
)
[C++/CLI]
public:
void RemoveScratches(
   Point scratchStartingPoint,
   Point scratchEndingPoint,
   int scratchLineWidth,
   int scratchThreshold,
   int scratchFilterAdjustment,
   int scratchSmoothingAdjustment,
   DefectType scratchType
)

Parameters

scratchStartingPoint
A point value which represents the scratch starting point.
scratchEndingPoint
A point value which represents the scratch ending point.
scratchLineWidth
An integer value which represents the scratch line width.
scratchThreshold
An integer value which represents the scratch threshold.
scratchFilterAdjustment
An integer value which represents the scratch filter adjustment.
scratchSmoothingAdjustment
An integer value which represents the scratch smoothing adjustment.
scratchType
The DefectType.

Remarks

Before calling this method you must set an area using the Processor.SetArea method.

Note: Available in Photo edition.

See Also

Processor Class | Processor Members


ReplaceColors Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

fromColor
The Color that evaluates to the beginning color range.
toColor
The Color that evaluates to the ending color range.
replacementColor
The Color that evaluates to the replacement color.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ReplaceColors Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : ReplaceColors Method

Replaces a range of colors in the current image.

[Visual Basic]
Public Sub ReplaceColors( _
   ByVal fromColor As Color, _
   ByVal toColor As Color, _
   ByVal replacementColor As Color _
)
[C#]
public void ReplaceColors(
   Color fromColor,
   Color toColor,
   Color replacementColor
);
[C++]
public: void ReplaceColors(
   Color fromColor,
   Color toColor,
   Color replacementColor
)
[C++/CLI]
public:
void ReplaceColors(
   Color fromColor,
   Color toColor,
   Color replacementColor
)

Parameters

fromColor
The Color that evaluates to the beginning color range.
toColor
The Color that evaluates to the ending color range.
replacementColor
The Color that evaluates to the replacement color.

Remarks

Note: Available in Standard, Document and Photo editions.

See Also

Processor Class | Processor Members


Resize Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Resize Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Resize Method (Processor)

Overload List

Resizes the current image allowing passing in a new size and resize type.

[Visual Basic] Overloads Public Sub Resize(Size,ResizeType)

[C#] public void Resize(Size,ResizeType);

[C++] public void Resize(Size,ResizeType);

[C++/CLI] public void Resize(Size,ResizeType);

Resizes the current image allowing passing in a new size, resize type, scale to gray and scale preserve black values.

[Visual Basic] Overloads Public Sub Resize(Size,ResizeType,Boolean,Boolean)

[C#] public void Resize(Size,ResizeType,bool,bool);

[C++] public void Resize(Size,ResizeType,bool,bool);

[C++/CLI] public void Resize(Size,ResizeType,bool,bool);

Remarks

Note: Resize is not supported for Camera Raw formats.

See Also

Processor Class | Processor Members


Resize(Size,ResizeType) Method

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

newSize
Size values which the image is resized to in twips.
resizeType
A ResizeType enumeration value used to determine what type of resize method to perform during resizing.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Resize(Size,ResizeType) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > Resize Method : Resize(Size,ResizeType) Method

Resizes the current image allowing passing in a new size and resize type.

[Visual Basic]
Overloads Public Sub Resize( _
   ByVal newSize As Size, _
   ByVal resizeType As ResizeType _
)
[C#]
public void Resize(
   Size newSize,
   ResizeType resizeType
);
[C++]
public: void Resize(
   Size newSize,
   ResizeType resizeType
)
[C++/CLI]
public:
void Resize(
   Size newSize,
   ResizeType resizeType
)

Parameters

newSize
Size values which the image is resized to in twips.
resizeType
A ResizeType enumeration value used to determine what type of resize method to perform during resizing.

Remarks

Note: Resize is not supported for Camera Raw formats.

See Also

Processor Class | Processor Members | Overload List


Resize(Size,ResizeType,Boolean,Boolean) Method

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

newSize
Size values which the image is resized to in twips.
resizeType
A ResizeType enumeration value used to determine what type of resize method to perform during resizing.
scaleResizeToGray
A boolean value to set to true to scale to gray when resized. Otherwise, false should be set.
scaleResizePreserveBlack
A boolean value to set to true to enhance dark lines in the image when the image is resized. Otherwise, false should be set and dark lines are not enhanced.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Resize(Size,ResizeType,Boolean,Boolean) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > Resize Method : Resize(Size,ResizeType,Boolean,Boolean) Method

Resizes the current image allowing passing in a new size, resize type, scale to gray and scale preserve black values.

[Visual Basic]
Overloads Public Sub Resize( _
   ByVal newSize As Size, _
   ByVal resizeType As ResizeType, _
   ByVal scaleResizeToGray As Boolean, _
   ByVal scaleResizePreserveBlack As Boolean _
)
[C#]
public void Resize(
   Size newSize,
   ResizeType resizeType,
   bool scaleResizeToGray,
   bool scaleResizePreserveBlack
);
[C++]
public: void Resize(
   Size newSize,
   ResizeType resizeType,
   bool scaleResizeToGray,
   bool scaleResizePreserveBlack
)
[C++/CLI]
public:
void Resize(
   Size newSize,
   ResizeType resizeType,
   bool scaleResizeToGray,
   bool scaleResizePreserveBlack
)

Parameters

newSize
Size values which the image is resized to in twips.
resizeType
A ResizeType enumeration value used to determine what type of resize method to perform during resizing.
scaleResizeToGray
A boolean value to set to true to scale to gray when resized. Otherwise, false should be set.
scaleResizePreserveBlack
A boolean value to set to true to enhance dark lines in the image when the image is resized. Otherwise, false should be set and dark lines are not enhanced.

Remarks

Note: Resize is not supported for Camera Raw formats.

See Also

Processor Class | Processor Members | Overload List


RGBColorCount Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

redCounts
An integer array of red counts.
greenCounts
An integer array of green counts.
blueCounts
An integer array of blue counts.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RGBColorCount Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : RGBColorCount Method

Returns three arrays, each containing 256 elements, which equate to a count of the red, green, and blue color intensities of the image.

[Visual Basic]
Public Sub RGBColorCount( _
   ByRef redCounts As Integer, _
   ByRef greenCounts As Integer, _
   ByRef blueCounts As Integer _
)
[C#]
public void RGBColorCount(
   out int redCounts,
   out int greenCounts,
   out int blueCounts
);
[C++]
public: void RGBColorCount(
   [PARAMFLAG::Out] int redCounts,
   [PARAMFLAG::Out] int greenCounts,
   [PARAMFLAG::Out] int blueCounts
)
[C++/CLI]
public:
void RGBColorCount(
   [Out] int redCounts,
   [Out] int greenCounts,
   [Out] int blueCounts
)

Parameters

redCounts
An integer array of red counts.
greenCounts
An integer array of green counts.
blueCounts
An integer array of blue counts.

Remarks

The returned arrays contain a histogram of intensity values for each of the red, green, and blue components of the current image.

Note: Available in all editions.

Example

[C#]

int[] redCounts;
int[] greenCounts;
int[] blueCounts;
using (Processor processor = new Processor(imagXpress1, imageXView1.Image))
{
   processor.RGBColorCount(out redCounts, out greenCounts, out blueCounts);
}

See Also

Processor Class | Processor Members


Ripple Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

frequency

An integer value which represents the frequency.

The range is from 1 to 100.

Larger values result in more ripples.

intensity

An integer value which represents the intensity.

The range is from -100 to 100.

Larger values result in more intense ripples.

direction
A RippleDirection enumeration value which determines the direction of the ripple.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Ripple Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Ripple Method

Modifies the image to create a ripple effect as per the given parameters.

[Visual Basic]
Public Sub Ripple( _
   ByVal frequency As Integer, _
   ByVal intensity As Integer, _
   ByVal direction As RippleDirection _
)
[C#]
public void Ripple(
   int frequency,
   int intensity,
   RippleDirection direction
);
[C++]
public: void Ripple(
   int frequency,
   int intensity,
   RippleDirection direction
)
[C++/CLI]
public:
void Ripple(
   int frequency,
   int intensity,
   RippleDirection direction
)

Parameters

frequency

An integer value which represents the frequency.

The range is from 1 to 100.

Larger values result in more ripples.

intensity

An integer value which represents the intensity.

The range is from -100 to 100.

Larger values result in more intense ripples.

direction
A RippleDirection enumeration value which determines the direction of the ripple.

Remarks

Note: Available in Standard, Document and Photo editions.

See Also

Processor Class | Processor Members


Rotate Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

rotationAngle
A double value that represents the angle by which the image will be rotated. Valid values are -360 to 360 degrees.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Rotate Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Rotate Method

Rotates the current image.

[Visual Basic]
Public Sub Rotate( _
   ByVal rotationAngle As Double _
)
[C#]
public void Rotate(
   double rotationAngle
);
[C++]
public: void Rotate(
   double rotationAngle
)
[C++/CLI]
public:
void Rotate(
   double rotationAngle
)

Parameters

rotationAngle
A double value that represents the angle by which the image will be rotated. Valid values are -360 to 360 degrees.

Remarks

Note: Rotation is counter-clockwise.

Note: Available in all editions.

See Also

Processor Class | Processor Members


SetArea Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingArea
The RectangleF to set as the bounding area for the image.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetArea Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : SetArea Method

Sets the area.

[Visual Basic]
Public Sub SetArea( _
   ByVal boundingArea As RectangleF _
)
[C#]
public void SetArea(
   RectangleF boundingArea
);
[C++]
public: void SetArea(
   RectangleF boundingArea
)
[C++/CLI]
public:
void SetArea(
   RectangleF boundingArea
)

Parameters

boundingArea
The RectangleF to set as the bounding area for the image.

Remarks

There are two ways to specify a portion of the image to process: Region or Area.

There can only be one region, and one area specified per processor.

When EnableRegion is set to true, and a region has been defined using this method, all image processing actions apply to the region only.

When EnableArea has been set to true, and an area is defined using SetArea, all image processing actions apply to the area only.

When both a region and an area have been enabled and defined, image processing actions apply to whichever was most recently set.

When neither a region nor an area have been enabled and defined, image processing actions are applied to the entire image.

See Also

Processor Class | Processor Members


SetRegion Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetRegion Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : SetRegion Method

Sets the given region for the image.

Overload List

Sets the given region for the image.

[Visual Basic] Overloads Public Sub SetRegion(GraphicsPath)

[C#] public void SetRegion(GraphicsPath);

[C++] public void SetRegion(GraphicsPath*);

[C++/CLI] public void SetRegion(GraphicsPath^);

Sets the region using the given parameters.

[Visual Basic] Overloads Public Sub SetRegion(RectangleF,RegionType)

[C#] public void SetRegion(RectangleF,RegionType);

[C++] public void SetRegion(RectangleF,RegionType);

[C++/CLI] public void SetRegion(RectangleF,RegionType);

See Also

Processor Class | Processor Members


SetRegion(GraphicsPath) Method

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

region
The GraphicsPath value which represents the region to set.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetRegion(GraphicsPath) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > SetRegion Method : SetRegion(GraphicsPath) Method

Sets the given region for the image.

[Visual Basic]
Overloads Public Sub SetRegion( _
   ByVal region As GraphicsPath _
)
[C#]
public void SetRegion(
   GraphicsPath region
);
[C++]
public: void SetRegion(
   GraphicsPath* region
)
[C++/CLI]
public:
void SetRegion(
   GraphicsPath^ region
)

Parameters

region
The GraphicsPath value which represents the region to set.

Remarks

There are two ways to specify a portion of the image to process: Region or Area.

There can only be one region, and one area specified per processor.

When EnableRegion is set to true, and a region has been defined using this method, all image processing actions apply to the region only.

When EnableArea has been set to true, and an area is defined using Processor.SetArea, all image processing actions apply to the area only.

When both a region and an area have been enabled and defined, image processing actions apply to whichever was most recently set.

When neither a region nor an area have been enabled and defined, image processing actions are applied to the entire image.

See Also

Processor Class | Processor Members | Overload List


SetRegion(RectangleF,RegionType) Method

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingArea
A RectangleF value which represents the bounding area.
regionType
A RegionType value which determines the region type to use when setting the region.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetRegion(RectangleF,RegionType) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > SetRegion Method : SetRegion(RectangleF,RegionType) Method

Sets the region using the given parameters.

[Visual Basic]
Overloads Public Sub SetRegion( _
   ByVal boundingArea As RectangleF, _
   ByVal regionType As RegionType _
)
[C#]
public void SetRegion(
   RectangleF boundingArea,
   RegionType regionType
);
[C++]
public: void SetRegion(
   RectangleF boundingArea,
   RegionType regionType
)
[C++/CLI]
public:
void SetRegion(
   RectangleF boundingArea,
   RegionType regionType
)

Parameters

boundingArea
A RectangleF value which represents the bounding area.
regionType
A RegionType value which determines the region type to use when setting the region.

Remarks

There are two ways to specify a portion of the image to process: Region or Area.

There can only be one region, and one area specified per processor.

When EnableRegion is set to true, and a region has been defined using this method, all image processing actions apply to the region only.

When EnableArea has been set to true, and an area is defined using Processor.SetArea, all image processing actions apply to the area only.

When both a region and an area have been enabled and defined, image processing actions apply to whichever was most recently set.

When neither a region nor an area have been enabled and defined, image processing actions are applied to the entire image.

See Also

Processor Class | Processor Members | Overload List


Sharpen Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Sharpen Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Sharpen Method

Sharpens the image by the given intensity.

Overload List

Sharpens the image by the given intensity.

[Visual Basic] Overloads Public Sub Sharpen(Integer)

[C#] public void Sharpen(int);

[C++] public void Sharpen(int);

[C++/CLI] public void Sharpen(int);

Sharpens the image by the given intensity and filter.

[Visual Basic] Overloads Public Sub Sharpen(Integer,SharpenFilter)

[C#] public void Sharpen(int,SharpenFilter);

[C++] public void Sharpen(int,SharpenFilter);

[C++/CLI] public void Sharpen(int,SharpenFilter);

See Also

Processor Class | Processor Members


Sharpen(Int32) Method

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

intensity

An integer value which represents the intensity.

The range is from 1 to 10.

Higher values result in sharper images.

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Sharpen(Int32) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > Sharpen Method : Sharpen(Int32) Method

Sharpens the image by the given intensity.

[Visual Basic]
Overloads Public Sub Sharpen( _
   ByVal intensity As Integer _
)
[C#]
public void Sharpen(
   int intensity
);
[C++]
public: void Sharpen(
   int intensity
)
[C++/CLI]
public:
void Sharpen(
   int intensity
)

Parameters

intensity

An integer value which represents the intensity.

The range is from 1 to 10.

Higher values result in sharper images.

See Also

Processor Class | Processor Members | Overload List


Sharpen(Int32,SharpenFilter) Method

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

intensity

An integer value which represents the intensity.

The range is from 1 to 10.

Higher values result in sharper images.

filter
A SharpenFilter value which represents the type of filter to use to sharpen the image.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Sharpen(Int32,SharpenFilter) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > Sharpen Method : Sharpen(Int32,SharpenFilter) Method

Sharpens the image by the given intensity and filter.

[Visual Basic]
Overloads Public Sub Sharpen( _
   ByVal intensity As Integer, _
   ByVal filter As SharpenFilter _
)
[C#]
public void Sharpen(
   int intensity,
   SharpenFilter filter
);
[C++]
public: void Sharpen(
   int intensity,
   SharpenFilter filter
)
[C++/CLI]
public:
void Sharpen(
   int intensity,
   SharpenFilter filter
)

Parameters

intensity

An integer value which represents the intensity.

The range is from 1 to 10.

Higher values result in sharper images.

filter
A SharpenFilter value which represents the type of filter to use to sharpen the image.

See Also

Processor Class | Processor Members | Overload List


Soften Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Soften Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Soften Method

Softens the image by the given intensity.

Overload List

Softens the image by the given intensity.

[Visual Basic] Overloads Public Sub Soften(Integer)

[C#] public void Soften(int);

[C++] public void Soften(int);

[C++/CLI] public void Soften(int);

Softens the image by the given intensity and filter.

[Visual Basic] Overloads Public Sub Soften(Integer,SoftenFilter)

[C#] public void Soften(int,SoftenFilter);

[C++] public void Soften(int,SoftenFilter);

[C++/CLI] public void Soften(int,SoftenFilter);

See Also

Processor Class | Processor Members


Soften(Int32) Method

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

intensity

An integer value which represents the intensity.

The range is from 1 to 10.

Higher values result in softer images.

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Soften(Int32) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > Soften Method : Soften(Int32) Method

Softens the image by the given intensity.

[Visual Basic]
Overloads Public Sub Soften( _
   ByVal intensity As Integer _
)
[C#]
public void Soften(
   int intensity
);
[C++]
public: void Soften(
   int intensity
)
[C++/CLI]
public:
void Soften(
   int intensity
)

Parameters

intensity

An integer value which represents the intensity.

The range is from 1 to 10.

Higher values result in softer images.

See Also

Processor Class | Processor Members | Overload List


Soften(Int32,SoftenFilter) Method

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

intensity

An integer value which represents the intensity.

The range is from 1 to 10.

Higher values result in softer images.

filter
A SoftenFilter which determines the soften filter to apply to the image.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Soften(Int32,SoftenFilter) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > Soften Method : Soften(Int32,SoftenFilter) Method

Softens the image by the given intensity and filter.

[Visual Basic]
Overloads Public Sub Soften( _
   ByVal intensity As Integer, _
   ByVal filter As SoftenFilter _
)
[C#]
public void Soften(
   int intensity,
   SoftenFilter filter
);
[C++]
public: void Soften(
   int intensity,
   SoftenFilter filter
)
[C++/CLI]
public:
void Soften(
   int intensity,
   SoftenFilter filter
)

Parameters

intensity

An integer value which represents the intensity.

The range is from 1 to 10.

Higher values result in softer images.

filter
A SoftenFilter which determines the soften filter to apply to the image.

See Also

Processor Class | Processor Members | Overload List


Solarize Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

threshold

An integer value which represents the threshold value to use to solarize the image.

The range is from 0 to 255.

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Solarize Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Solarize Method

Modifies the image by inverting the pixel values to negative.

[Visual Basic]
Public Sub Solarize( _
   ByVal threshold As Integer _
)
[C#]
public void Solarize(
   int threshold
);
[C++]
public: void Solarize(
   int threshold
)
[C++/CLI]
public:
void Solarize(
   int threshold
)

Parameters

threshold

An integer value which represents the threshold value to use to solarize the image.

The range is from 0 to 255.

Remarks

Note: Available in all editions.

See Also

Processor Class | Processor Members


Swirl Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

degrees

A double value which represents the degrees to swirl.

The range is from 0 to 360 (degrees).

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Swirl Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Swirl Method

Modifies the image to appear in a swirl based on the given degrees.

[Visual Basic]
Public Sub Swirl( _
   ByVal degrees As Double _
)
[C#]
public void Swirl(
   double degrees
);
[C++]
public: void Swirl(
   double degrees
)
[C++/CLI]
public:
void Swirl(
   double degrees
)

Parameters

degrees

A double value which represents the degrees to swirl.

The range is from 0 to 360 (degrees).

Remarks

Note: Available in all editions.

See Also

Processor Class | Processor Members


Tile Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tileSize
A Size value which represents the tile size.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Tile Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Tile Method

Modifies the image to appear in tiles based on the given tile size.

[Visual Basic]
Public Sub Tile( _
   ByVal tileSize As Size _
)
[C#]
public void Tile(
   Size tileSize
);
[C++]
public: void Tile(
   Size tileSize
)
[C++/CLI]
public:
void Tile(
   Size tileSize
)

Parameters

tileSize
A Size value which represents the tile size.

Remarks

Entering large values in tileSize can create a large image and may increase processing time considerably.

See Also

Processor Class | Processor Members


Twist Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

blockSize
An integer value which represents the block size of the twist.
rotation
A TwistRotation which determines the type of twist to use to modify the image.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Twist Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Twist Method

Modifies the image to appear in a twist by the given block size and rotation.

[Visual Basic]
Public Sub Twist( _
   ByVal blockSize As Integer, _
   ByVal rotation As TwistRotation _
)
[C#]
public void Twist(
   int blockSize,
   TwistRotation rotation
);
[C++]
public: void Twist(
   int blockSize,
   TwistRotation rotation
)
[C++/CLI]
public:
void Twist(
   int blockSize,
   TwistRotation rotation
)

Parameters

blockSize
An integer value which represents the block size of the twist.
rotation
A TwistRotation which determines the type of twist to use to modify the image.

Remarks

Note: Available in all editions.

See Also

Processor Class | Processor Members


UniqueColors Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

UniqueColors Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : UniqueColors Method

Returns a count of unique colors in the current image.

[Visual Basic]
Public Function UniqueColors() As Long
[C#]
public long UniqueColors();
[C++]
public: long UniqueColors();
[C++/CLI]
public:
long long UniqueColors();

Return Type

A long value which represents the number of unique colors contained in the current image.

Remarks

Note: Available in all editions.

See Also

Processor Class | Processor Members


Unsharpen Method

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Unsharpen Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Unsharpen Method

Modifies the image to appear not as detailed based on the given intensity.

Overload List

Modifies the image to appear not as detailed based on the given intensity.

[Visual Basic] Overloads Public Sub Unsharpen(Integer)

[C#] public void Unsharpen(int);

[C++] public void Unsharpen(int);

[C++/CLI] public void Unsharpen(int);

Modifies the image to appear not as detailed based on the given intensity and filter.

[Visual Basic] Overloads Public Sub Unsharpen(Integer,UnsharpenFilter)

[C#] public void Unsharpen(int,UnsharpenFilter);

[C++] public void Unsharpen(int,UnsharpenFilter);

[C++/CLI] public void Unsharpen(int,UnsharpenFilter);

See Also

Processor Class | Processor Members


Unsharpen(Int32) Method

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

intensity

An integer value which represents the intensity.

The range is from 1 to 10.

Higher values result in a larger magnitude of filter processing.

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Unsharpen(Int32) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > Unsharpen Method : Unsharpen(Int32) Method

Modifies the image to appear not as detailed based on the given intensity.

[Visual Basic]
Overloads Public Sub Unsharpen( _
   ByVal intensity As Integer _
)
[C#]
public void Unsharpen(
   int intensity
);
[C++]
public: void Unsharpen(
   int intensity
)
[C++/CLI]
public:
void Unsharpen(
   int intensity
)

Parameters

intensity

An integer value which represents the intensity.

The range is from 1 to 10.

Higher values result in a larger magnitude of filter processing.

Remarks

Edges within the image are sharpened, while othes areas are softened.

Note: Available in Photo edition only.

See Also

Processor Class | Processor Members | Overload List


Unsharpen(Int32,UnsharpenFilter) Method

Processor Class | Processor Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

intensity

An integer value which represents the intensity.

The range is from 1 to 10.

Higher values result in a larger magnitude of filter processing.

filter
A UnsharpenFilter value which determines the type of unsharpen to use on the image.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Unsharpen(Int32,UnsharpenFilter) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class > Unsharpen Method : Unsharpen(Int32,UnsharpenFilter) Method

Modifies the image to appear not as detailed based on the given intensity and filter.

[Visual Basic]
Overloads Public Sub Unsharpen( _
   ByVal intensity As Integer, _
   ByVal filter As UnsharpenFilter _
)
[C#]
public void Unsharpen(
   int intensity,
   UnsharpenFilter filter
);
[C++]
public: void Unsharpen(
   int intensity,
   UnsharpenFilter filter
)
[C++/CLI]
public:
void Unsharpen(
   int intensity,
   UnsharpenFilter filter
)

Parameters

intensity

An integer value which represents the intensity.

The range is from 1 to 10.

Higher values result in a larger magnitude of filter processing.

filter
A UnsharpenFilter value which determines the type of unsharpen to use on the image.

See Also

Processor Class | Processor Members | Overload List


Processor Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Processor Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : Processor Class

For a list of all members of this type, see Processor members.

Public Properties

Public Property BackgroundColor | Gets and sets the background color.
Public Property BlankPageDetected | Gets an indicator if a blank page is detected.
Public Property Confidence | Gets the confidence.
Public Property Container (Inherited from System.ComponentModel.Component) | Gets the IContainer that contains the Component.
Public Property ContrastMethod | Gets and sets the contrast method to use.
Public Property CountOfLinesFound | Gets the number of lines found.
Public Property CountOfObjectsFound | Gets the number of objects found.
Public Property CountOfSpecsFound | Gets the number of specs found.
Public Property EnableArea | Gets and sets whether the area is enabled.
Public Property EnableRegion | Gets and sets whether access to the region is enabled.
Public Property Image | Gets and sets the image to be processed.
Public Property ImageWasModified | Gets an indicator if the image was modified.
Public Property LogPalette | Gets and sets the palette for use when the Processor.ColorDepth method is called.
Public Property ProgressPercent | Gets and sets the ProgressEvent frequency.
Public Property Redeyes | Gets and sets the redeye collection.
Public Property RotationAngle | Gets the rotation angle.
Public Property Site | Overridden. Gets and sets the site value.
Public Property Variation | Gets the variation.

See Also

Processor Class | PegasusImaging.WinForms.ImagXpress9 Namespace


BackgroundColor Property

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

BackgroundColor Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : BackgroundColor Property

Gets and sets the background color.

[Visual Basic]
Public Property BackgroundColor As Color
[C#]
public Color BackgroundColor {get; set;}
[C++]
public: __property Color get_BackgroundColor();
public: __property void set_BackgroundColor(
   Color value
);
[C++/CLI]
public:
property Color BackgroundColor {
   Color get();
   void set (Color value);
}

Return Type

A Color which represents the background color to use.

Remarks

When deskew is performed, regions of the image background are expanded when the document is straightened. This property provides the default color for the expanded background area.

See Also

Processor Class | Processor Members


BlankPageDetected Property

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

BlankPageDetected Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : BlankPageDetected Property

Gets an indicator if a blank page is detected.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property BlankPageDetected As Boolean
[C#]
[BrowsableAttribute(false)]
public bool BlankPageDetected {get;}
[C++]
[BrowsableAttribute(false)]
public: __property bool get_BlankPageDetected();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property bool BlankPageDetected {
   bool get();
}

Return Type

A boolean value which is true if a blank page is detected. Otherwise, false is returned.

Remarks

Note: Use this property for documents only.

See Also

Processor Class | Processor Members


Confidence Property

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Confidence Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Confidence Property (Processor)

Gets the confidence.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property Confidence As Short
[C#]
[BrowsableAttribute(false)]
public short Confidence {get;}
[C++]
[BrowsableAttribute(false)]
public: __property short get_Confidence();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property short Confidence {
   short get();
}

Return Type

An int16 which represents the confidence value.

Remarks

This property provides confidence levels from 1 to 100 of success of the operation.

Set by using the DocumentDeskew, DocumentBlankPageDetect, and DocumentBorderCrop methods.

Note: Use this property for documents only.

See Also

Processor Class | Processor Members


ContrastMethod Property

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ContrastMethod Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : ContrastMethod Property (Processor)

Gets and sets the contrast method to use.

[Visual Basic]
Public Property ContrastMethod As ContrastMethod
[C#]
public ContrastMethod ContrastMethod {get; set;}
[C++]
public: __property ContrastMethod get_ContrastMethod();
public: __property void set_ContrastMethod(
   ContrastMethod value
);
[C++/CLI]
public:
property ContrastMethod ContrastMethod {
   ContrastMethod get();
   void set (ContrastMethod value);
}

Return Type

A ContrastMethod value which determines the method of contrast for the current image.

Remarks

The default value is ContrastMethod.DefaultContrast.

If this property is set to ViewCompatibleContrast, then the ImageXView.Contrast property is invoked. This ensures backward compatibility with existing users. It also allows the application to get and save the same image in the viewer when contrast is applied.

See Also

Processor Class | Processor Members


CountOfLinesFound Property

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CountOfLinesFound Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : CountOfLinesFound Property

Gets the number of lines found.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property CountOfLinesFound As Integer
[C#]
[BrowsableAttribute(false)]
public int CountOfLinesFound {get;}
[C++]
[BrowsableAttribute(false)]
public: __property int get_CountOfLinesFound();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property int CountOfLinesFound {
   int get();
}

Return Type

An integer value which represents the number of lines found.

See Also

Processor Class | Processor Members


CountOfObjectsFound Property

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CountOfObjectsFound Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : CountOfObjectsFound Property

Gets the number of objects found.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property CountOfObjectsFound As Integer
[C#]
[BrowsableAttribute(false)]
public int CountOfObjectsFound {get;}
[C++]
[BrowsableAttribute(false)]
public: __property int get_CountOfObjectsFound();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property int CountOfObjectsFound {
   int get();
}

Return Type

An integer value which represents the number of objects found.

See Also

Processor Class | Processor Members


CountOfSpecsFound Property

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CountOfSpecsFound Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : CountOfSpecsFound Property

Gets the number of specs found.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property CountOfSpecsFound As Integer
[C#]
[BrowsableAttribute(false)]
public int CountOfSpecsFound {get;}
[C++]
[BrowsableAttribute(false)]
public: __property int get_CountOfSpecsFound();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property int CountOfSpecsFound {
   int get();
}

Return Type

An integer value which represents the number of specs found.

Remarks

A speck is a small dot, mark or discoloration on an image.

Note: Use this property for documents only.

See Also

Processor Class | Processor Members


EnableArea Property

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

EnableArea Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : EnableArea Property

Gets and sets whether the area is enabled.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property EnableArea As Boolean
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public bool EnableArea {get; set;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property bool get_EnableArea();
public: __property void set_EnableArea(
   bool value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property bool EnableArea {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to enable to the area. Otherwise, false should be used.

Remarks

There are two ways to specify a portion of the image to process: Region or Area.

There can only be one region, and one area specified per processor.

When EnableRegion is set to true, and a region has been defined using this method, all image processing actions apply to the region only.

When EnableArea has been set to true, and an area is defined using Processor.SetArea, all image processing actions apply to the area only.

When both a region and an area have been enabled and defined, image processing actions apply to whichever was most recently set.

When neither a region nor an area have been enabled and defined, image processing actions are applied to the entire image.

See Also

Processor Class | Processor Members


EnableRegion Property

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

EnableRegion Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : EnableRegion Property

Gets and sets whether access to the region is enabled.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property EnableRegion As Boolean
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public bool EnableRegion {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property bool get_EnableRegion();
public: __property void set_EnableRegion(
   bool value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property bool EnableRegion {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to enable to the region. Otherwise, false should be used.

Remarks

There are two ways to specify a portion of the image to process: Region or Area.

There can only be one region, and one area specified per processor.

When EnableRegion is set to true, and a region has been defined using this method, all image processing actions apply to the region only.

When EnableArea has been set to true, and an area is defined using Processor.SetArea, all image processing actions apply to the area only.

When both a region and an area have been enabled and defined, image processing actions apply to whichever was most recently set.

When neither a region nor an area have been enabled and defined, image processing actions are applied to the entire image.

See Also

Processor Class | Processor Members


Image Property

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Image Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Image Property (Processor)

Gets and sets the image to be processed.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property Image As ImageX
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public ImageX Image {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property ImageX* get_Image();
public: __property void set_Image(
   ImageX* value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property ImageX^ Image {
   ImageX^ get();
   void set (ImageX^ value);
}

See Also

Processor Class | Processor Members


ImageWasModified Property

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageWasModified Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : ImageWasModified Property

Gets an indicator if the image was modified.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property ImageWasModified As Boolean
[C#]
[BrowsableAttribute(false)]
public bool ImageWasModified {get;}
[C++]
[BrowsableAttribute(false)]
public: __property bool get_ImageWasModified();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property bool ImageWasModified {
   bool get();
}

Return Type

A boolean value which is true if the image was modified. Otherwise, false is returned.

Remarks

Note: Use this method for documents only.

See Also

Processor Class | Processor Members


LogPalette Property

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LogPalette Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : LogPalette Property

Gets and sets the palette for use when the Processor.ColorDepth method is called.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property LogPalette As IntPtr
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public IntPtr LogPalette {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property IntPtr get_LogPalette();
public: __property void set_LogPalette(
   IntPtr value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property IntPtr LogPalette {
   IntPtr get();
   void set (IntPtr value);
}

Return Type

An integer pointer which represents the log palette.

Remarks

When the Processor.ColorDepth method is called with paletteType = UserDefined, or PalFile, this property is used to display the image.

See Also

Processor Class | Processor Members


ProgressPercent Property

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ProgressPercent Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : ProgressPercent Property (Processor)

Gets and sets the ProgressEvent frequency.

[Visual Basic]
Public Property ProgressPercent As Integer
[C#]
public int ProgressPercent {get; set;}
[C++]
public: __property int get_ProgressPercent();
public: __property void set_ProgressPercent(
   int value
);
[C++/CLI]
public:
property int ProgressPercent {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the frequency of the ProgressEvent event.

Remarks

Valid values are 1 to 100.

Lower values indicate more frequent events and higher value indicate less frequent events.

This property specifies the frequency at which the ProgressEvent fires and yields occur based on the percentage of completion of the load, save, or image processing operation.

For example; when this property is set to a value of 25, the control yields and issues a Progress event when the operation achieves:

  • 0 completion
  • at least 25 completion
  • at least 50 completion
  • at least 75 completion
  • and, at 100% completion

Depending upon the process ran, the Progress Event's pctDone parameter may start at a value other than zero, for example, one or two. And due to rounding errors, the increment may not be exactly the value of ProgressPct. For example, if ProgressPct is 10, the increments may be eleven or twelve.

See Also

Processor Class | Processor Members


Redeyes Property

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Redeyes Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Redeyes Property

Gets and sets the redeye collection.

[Visual Basic]
Public Property Redeyes As RedeyeCollection
[C#]
public RedeyeCollection Redeyes {get; set;}
[C++]
public: __property RedeyeCollection* get_Redeyes();
public: __property void set_Redeyes(
   RedeyeCollection* value
);
[C++/CLI]
public:
property RedeyeCollection^ Redeyes {
   RedeyeCollection^ get();
   void set (RedeyeCollection^ value);
}

Return Type

The RedeyeCollection which contains redeye information.

Remarks

The AutoRemoveRedeye method detects and corrects red eyes within the image. One rectangle and corresponding correction information is generated for each corrected eye, and the collection of this information is stored in this property.

Note: This property is generally called after calling AutoRemoveRedeye.

See Also

Processor Class | Processor Members


RotationAngle Property

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RotationAngle Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : RotationAngle Property

Gets the rotation angle.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property RotationAngle As Double
[C#]
[BrowsableAttribute(false)]
public double RotationAngle {get;}
[C++]
[BrowsableAttribute(false)]
public: __property double get_RotationAngle();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property double RotationAngle {
   double get();
}

Return Type

A double value which represents the rotation angle to get.

Remarks

Valid values are between -20 and 20.

Note: This property may be set to a value other than 0, even if the image is not modified. The image may not be modified if the detection Confidence property is less than minimum, or if the rotation angle is less than or equal to the minimum acceptable angle.

This property stores the angle of rotation required to correct skew using the DocumentDeskew method.

See Also

Processor Class | Processor Members


Site Property

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Site Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Site Property

Gets and sets the site value.

[Visual Basic]
Overrides Public Property Site As ISite
[C#]
public override ISite Site {get; set;}
[C++]
public: __property ISite* get_Site()override ;
public: __property void set_Site(
   ISite* value
)override ;
[C++/CLI]
public:
property ISite^ Site override {
   ISite^ get();
   void set (ISite^ value);
}

Return Type

The ISite associated with the Component, or null if the Component is not encapsulated in an IContainer, the Component does not have an ISite associated with it, or the Component is removed from its IContainer.

See Also

Processor Class | Processor Members


Variation Property

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Variation Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : Variation Property

Gets the variation.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property Variation As Short
[C#]
[BrowsableAttribute(false)]
public short Variation {get;}
[C++]
[BrowsableAttribute(false)]
public: __property short get_Variation();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property short Variation {
   short get();
}

Return Type

An int16 value which represents the variation.

Remarks

Valid values are between 0 and 100.

Sets this property using the DocumentDeskew method.

Higher values indicate greater skew variation. This value is typically high if the horizontal and vertical skews do not match or if different parts of the image are skewed by different amounts.

Note: Use this property for documents only.

See Also

Processor Class | Processor Members


Processor Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Processor Class Events

PegasusImaging.WinForms.ImagXpress9 Namespace : Processor Class

For a list of all members of this type, see Processor members.

Public Events

Public Event Disposed (Inherited from System.ComponentModel.Component) | Adds an event handler to listen to the Disposed event on the component.
Public Event ProgressEvent | Notifies a change in progress status.

See Also

Processor Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ProgressEvent Event

Processor Class | Processor Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ProgressEvent Event

PegasusImaging.WinForms.ImagXpress9 Namespace > Processor Class : ProgressEvent Event (Processor)

Notifies a change in progress status.

[Visual Basic]
Public Event ProgressEvent() As Processor.ProgressEventHandler
[C#]
public event Processor.ProgressEventHandler ProgressEvent();
[C++]
public: __event Processor.ProgressEventHandler* ProgressEvent();
[C++/CLI]
public:
event Processor::ProgressEventHandler^ ProgressEvent();

Event Data

The event handler receives an argument of type ProgressEventArgs containing data related to this event. The following ProgressEventArgs properties provide information specific to this event.

Property | Description
BytesProcessed |
IsAsync |
IsComplete |
Operation |
PercentDone |
Result |
TotalBytes |

See Also

Processor Class | Processor Members


ProcessorException Class

ProcessorException Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ProcessorException Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ProcessorException Class

This class implements exceptions for the Processor objects.

For a list of all members of this type, see ProcessorException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.ImagXpress9.ImagXpressException
PegasusImaging.WinForms.ImagXpress9.ProcessorException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class ProcessorException
   Inherits ImagXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class ProcessorException : ImagXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class ProcessorException : public ImagXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class ProcessorException sealed : public ImagXpressException, ISerializable, _Exception

See Also

ProcessorException Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ProcessorException Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ProcessorException Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ProcessorException Class

ProcessorException overview

Public Constructors

Public Constructor ProcessorException Constructor Overloaded. The main constructor for the ProcessorException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from ImagXpressException) | Gets the numerical equivalent for enumerated exception result.
Public Property Result (Inherited from ImagXpressException) | Gets the enumerated exception result that has occurred.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ProcessorException Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ProcessorException Constructor

ProcessorException Class | ProcessorException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ProcessorException Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ProcessorException Class : ProcessorException Constructor (ProcessorException)

The main constructor for the ProcessorException class.

Overload List

The main constructor for the ProcessorException class.

[Visual Basic] Public Sub New()

[C#] public ProcessorException();

[C++] public ProcessorException();

[C++/CLI] public ProcessorException();

Constructor which allows passing in a result for the exception.

[Visual Basic] Public Sub New(Result)

[C#] public ProcessorException(Result);

[C++] public ProcessorException(Result);

[C++/CLI] public ProcessorException(Result);

Constructor which allows passing in a message for the exception.

[Visual Basic] Public Sub New(String)

[C#] public ProcessorException(string);

[C++] public ProcessorException(string*);

[C++/CLI] public ProcessorException(String^);

Constructor which allows passing in a result and message for the exception.

[Visual Basic] Public Sub New(Result,String)

[C#] public ProcessorException(Result,string);

[C++] public ProcessorException(Result,string*);

[C++/CLI] public ProcessorException(Result,String^);

Constructor which allows passing in a message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public ProcessorException(string,Exception);

[C++] public ProcessorException(string*,Exception*);

[C++/CLI] public ProcessorException(String^,Exception^);

Constructor which allows passing in a result, message and inner exception.

[Visual Basic] Public Sub New(Result,String,Exception)

[C#] public ProcessorException(Result,string,Exception);

[C++] public ProcessorException(Result,string*,Exception*);

[C++/CLI] public ProcessorException(Result,String^,Exception^);

See Also

ProcessorException Class | ProcessorException Members


ProcessorException Constructor()

ProcessorException Class | ProcessorException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ProcessorException Constructor()

PegasusImaging.WinForms.ImagXpress9 Namespace > ProcessorException Class > ProcessorException Constructor : ProcessorException Constructor()

The main constructor for the ProcessorException class.

[Visual Basic]
Public Function New()
[C#]
public ProcessorException();
[C++]
public: ProcessorException();
[C++/CLI]
public:
ProcessorException();

See Also

ProcessorException Class | ProcessorException Members | Overload List


ProcessorException Constructor(Result)

ProcessorException Class | ProcessorException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

result
A Result enumeration value.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ProcessorException Constructor(Result)

PegasusImaging.WinForms.ImagXpress9 Namespace > ProcessorException Class > ProcessorException Constructor : ProcessorException Constructor(Result)

Constructor which allows passing in a result for the exception.

[Visual Basic]
Public Function New( _
   ByVal result As Result _
)
[C#]
public ProcessorException(
   Result result
);
[C++]
public: ProcessorException(
   Result result
)
[C++/CLI]
public:
ProcessorException(
   Result result
)

Parameters

result
A Result enumeration value.

See Also

ProcessorException Class | ProcessorException Members | Overload List


ProcessorException Constructor(Result,String)

ProcessorException Class | ProcessorException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

result
A Result enumeration value.
message
A string value which represents the message.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ProcessorException Constructor(Result,String)

PegasusImaging.WinForms.ImagXpress9 Namespace > ProcessorException Class > ProcessorException Constructor : ProcessorException Constructor(Result,String)

Constructor which allows passing in a result and message for the exception.

[Visual Basic]
Public Function New( _
   ByVal result As Result, _
   ByVal message As String _
)
[C#]
public ProcessorException(
   Result result,
   string message
);
[C++]
public: ProcessorException(
   Result result,
   string* message
)
[C++/CLI]
public:
ProcessorException(
   Result result,
   String^ message
)

Parameters

result
A Result enumeration value.
message
A string value which represents the message.

See Also

ProcessorException Class | ProcessorException Members | Overload List


ProcessorException Constructor(Result,String,Exception)

ProcessorException Class | ProcessorException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

result
A Result enumeration value.
message
A string value which represents the error message.
innerException
An Exception.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ProcessorException Constructor(Result,String,Exception)

PegasusImaging.WinForms.ImagXpress9 Namespace > ProcessorException Class > ProcessorException Constructor : ProcessorException Constructor(Result,String,Exception)

Constructor which allows passing in a result, message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal result As Result, _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public ProcessorException(
   Result result,
   string message,
   Exception innerException
);
[C++]
public: ProcessorException(
   Result result,
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
ProcessorException(
   Result result,
   String^ message,
   Exception^ innerException
)

Parameters

result
A Result enumeration value.
message
A string value which represents the error message.
innerException
An Exception.

See Also

ProcessorException Class | ProcessorException Members | Overload List


ProcessorException Constructor(String)

ProcessorException Class | ProcessorException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string value which represents the message.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ProcessorException Constructor(String)

PegasusImaging.WinForms.ImagXpress9 Namespace > ProcessorException Class > ProcessorException Constructor : ProcessorException Constructor(String)

Constructor which allows passing in a message for the exception.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public ProcessorException(
   string message
);
[C++]
public: ProcessorException(
   string* message
)
[C++/CLI]
public:
ProcessorException(
   String^ message
)

Parameters

message
A string value which represents the message.

See Also

ProcessorException Class | ProcessorException Members | Overload List


ProcessorException Constructor(String,Exception)

ProcessorException Class | ProcessorException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string value which represents the error message.
innerException
An Exception.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ProcessorException Constructor(String,Exception)

PegasusImaging.WinForms.ImagXpress9 Namespace > ProcessorException Class > ProcessorException Constructor : ProcessorException Constructor(String,Exception)

Constructor which allows passing in a message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public ProcessorException(
   string message,
   Exception innerException
);
[C++]
public: ProcessorException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
ProcessorException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
An Exception.

See Also

ProcessorException Class | ProcessorException Members | Overload List


ProgressEventArgs Class

ProgressEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ProgressEventArgs Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ProgressEventArgs Class

For a list of all members of this type, see ProgressEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.ImagXpress9.ProgressEventArgs

Syntax

[Visual Basic]
Public Class ProgressEventArgs
   Inherits EventArgs
[C#]
public class ProgressEventArgs : EventArgs
[C++]
public __gc class ProgressEventArgs : public EventArgs
[C++/CLI]
public ref class ProgressEventArgs : public EventArgs

See Also

ProgressEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ProgressEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ProgressEventArgs Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ProgressEventArgs Class

ProgressEventArgs overview

Public Constructors

Public Constructor ProgressEventArgs Constructor

Public Properties

Public Property BytesProcessed
Public Property IsAsync
Public Property IsComplete
Public Property Operation
Public Property PercentDone
Public Property Result
Public Property TotalBytes

See Also

ProgressEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ProgressEventArgs Constructor

ProgressEventArgs Class | ProgressEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ProgressEventArgs Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ProgressEventArgs Class : ProgressEventArgs Constructor (ProgressEventArgs)
[Visual Basic]
Public Function New()
[C#]
public ProgressEventArgs();
[C++]
public: ProgressEventArgs();
[C++/CLI]
public:
ProgressEventArgs();

See Also

ProgressEventArgs Class | ProgressEventArgs Members


ProgressEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ProgressEventArgs Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : ProgressEventArgs Class

For a list of all members of this type, see ProgressEventArgs members.

Public Properties

Public Property BytesProcessed
Public Property IsAsync
Public Property IsComplete
Public Property Operation
Public Property PercentDone
Public Property Result
Public Property TotalBytes

See Also

ProgressEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


BytesProcessed Property

ProgressEventArgs Class | ProgressEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

BytesProcessed Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ProgressEventArgs Class : BytesProcessed Property
[Visual Basic]
Public ReadOnly Property BytesProcessed As Integer
[C#]
public int BytesProcessed {get;}
[C++]
public: __property int get_BytesProcessed();
[C++/CLI]
public:
property int BytesProcessed {
   int get();
}

See Also

ProgressEventArgs Class | ProgressEventArgs Members


IsAsync Property

ProgressEventArgs Class | ProgressEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

IsAsync Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ProgressEventArgs Class : IsAsync Property
[Visual Basic]
Public ReadOnly Property IsAsync As Boolean
[C#]
public bool IsAsync {get;}
[C++]
public: __property bool get_IsAsync();
[C++/CLI]
public:
property bool IsAsync {
   bool get();
}

See Also

ProgressEventArgs Class | ProgressEventArgs Members


IsComplete Property

ProgressEventArgs Class | ProgressEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

IsComplete Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ProgressEventArgs Class : IsComplete Property
[Visual Basic]
Public ReadOnly Property IsComplete As Boolean
[C#]
public bool IsComplete {get;}
[C++]
public: __property bool get_IsComplete();
[C++/CLI]
public:
property bool IsComplete {
   bool get();
}

See Also

ProgressEventArgs Class | ProgressEventArgs Members


Operation Property

ProgressEventArgs Class | ProgressEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Operation Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ProgressEventArgs Class : Operation Property (ProgressEventArgs)
[Visual Basic]
Public ReadOnly Property Operation As Operation
[C#]
public Operation Operation {get;}
[C++]
public: __property Operation get_Operation();
[C++/CLI]
public:
property Operation Operation {
   Operation get();
}

See Also

ProgressEventArgs Class | ProgressEventArgs Members


PercentDone Property

ProgressEventArgs Class | ProgressEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PercentDone Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ProgressEventArgs Class : PercentDone Property
[Visual Basic]
Public ReadOnly Property PercentDone As Integer
[C#]
public int PercentDone {get;}
[C++]
public: __property int get_PercentDone();
[C++/CLI]
public:
property int PercentDone {
   int get();
}

See Also

ProgressEventArgs Class | ProgressEventArgs Members


Result Property

ProgressEventArgs Class | ProgressEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Result Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ProgressEventArgs Class : Result Property (ProgressEventArgs)
[Visual Basic]
Public ReadOnly Property Result As Integer
[C#]
public int Result {get;}
[C++]
public: __property int get_Result();
[C++/CLI]
public:
property int Result {
   int get();
}

See Also

ProgressEventArgs Class | ProgressEventArgs Members


TotalBytes Property

ProgressEventArgs Class | ProgressEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

TotalBytes Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ProgressEventArgs Class : TotalBytes Property
[Visual Basic]
Public ReadOnly Property TotalBytes As Integer
[C#]
public int TotalBytes {get;}
[C++]
public: __property int get_TotalBytes();
[C++/CLI]
public:
property int TotalBytes {
   int get();
}

See Also

ProgressEventArgs Class | ProgressEventArgs Members


RedeyeCollection Class

RedeyeCollection Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RedeyeCollection Class

PegasusImaging.WinForms.ImagXpress9 Namespace : RedeyeCollection Class

Summary description for RedeyeCollection.

For a list of all members of this type, see RedeyeCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PegasusImaging.WinForms.ImagXpress9.RedeyeCollection

Syntax

[Visual Basic]
<DefaultMemberAttribute("Item")>
Public Class RedeyeCollection
   Inherits CollectionBase
   Implements IList, ICollection, IEnumerable, IDisposable
[C#]
[DefaultMemberAttribute("Item")]
public class RedeyeCollection : CollectionBase, IList, ICollection, IEnumerable, IDisposable
[C++]
[DefaultMemberAttribute("Item")]
public __gc class RedeyeCollection : public CollectionBase, IList, ICollection, IEnumerable, IDisposable
[C++/CLI]
[DefaultMemberAttribute("Item")]
public ref class RedeyeCollection : public CollectionBase, IList, ICollection, IEnumerable, IDisposable

See Also

RedeyeCollection Members | PegasusImaging.WinForms.ImagXpress9 Namespace


RedeyeCollection Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RedeyeCollection Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : RedeyeCollection Class

RedeyeCollection overview

Public Constructors

Public Constructor RedeyeCollection Constructor

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property Item |

Public Methods

Public Method Add |
Public Method Clear | Clears the entire collection as well as calls the Clear function of the base class.
Public Method Contains | Determines if the collection contains this RedeyeRectangle.
Public Method CopyTo | Copies the entire collection to an array, starting at index of the target array.
Public Method Dispose | Releases all resources used by this PegasusImaging.WinForms.ImagXpress9.RedeyeCollection object.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method GetRedeyeRectangle |
Public Method IndexOf | Searches for the specified Object and returns the zero-based index of the first occurrence within the entire PageCollection.
Public Method Insert | Inserts a RedeyeRectangle at the specified index.
Public Method Remove | Removes the RedeyeRectangle from the collection.
Public Method RemoveAt | Remove operation for the RedeyeRectangle collection. Call the RedeyeRectangle destructor to free the RedeyeRectangle then remove the RedeyeRectangle from the collection.
Public Method RemoveRectangle |

See Also

RedeyeCollection Class | PegasusImaging.WinForms.ImagXpress9 Namespace


RedeyeCollection Constructor

RedeyeCollection Class | RedeyeCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RedeyeCollection Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > RedeyeCollection Class : RedeyeCollection Constructor (RedeyeCollection)
[Visual Basic]
Public Function New()
[C#]
public RedeyeCollection();
[C++]
public: RedeyeCollection();
[C++/CLI]
public:
RedeyeCollection();

See Also

RedeyeCollection Class | RedeyeCollection Members


Add Method

RedeyeCollection Class | RedeyeCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

rectangleItem
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Add Method

PegasusImaging.WinForms.ImagXpress9 Namespace > RedeyeCollection Class : Add Method (RedeyeCollection)
[Visual Basic]
Public Function Add( _
   ByVal rectangleItem As RedeyeRectangle _
) As Integer
[C#]
public int Add(
   RedeyeRectangle rectangleItem
);
[C++]
public: int Add(
   RedeyeRectangle* rectangleItem
)
[C++/CLI]
public:
int Add(
   RedeyeRectangle^ rectangleItem
)

Parameters

rectangleItem

See Also

RedeyeCollection Class | RedeyeCollection Members


Clear Method

RedeyeCollection Class | RedeyeCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Clear Method

PegasusImaging.WinForms.ImagXpress9 Namespace > RedeyeCollection Class : Clear Method (RedeyeCollection)

Clears the entire collection as well as calls the Clear function of the base class.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[C++/CLI]
public:
void Clear();

See Also

RedeyeCollection Class | RedeyeCollection Members


Contains Method

RedeyeCollection Class | RedeyeCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

rectangleItem
The RedeyeRectangle to locate.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Contains Method

PegasusImaging.WinForms.ImagXpress9 Namespace > RedeyeCollection Class : Contains Method (RedeyeCollection)

Determines if the collection contains this RedeyeRectangle.

[Visual Basic]
Public Function Contains( _
   ByVal rectangleItem As RedeyeRectangle _
) As Boolean
[C#]
public bool Contains(
   RedeyeRectangle rectangleItem
);
[C++]
public: bool Contains(
   RedeyeRectangle* rectangleItem
)
[C++/CLI]
public:
bool Contains(
   RedeyeRectangle^ rectangleItem
)

Parameters

rectangleItem
The RedeyeRectangle to locate.

Return Type

true if the collection contains the specified RedeyeRectangle; otherwise, false. Implements

See Also

RedeyeCollection Class | RedeyeCollection Members


CopyTo Method

RedeyeCollection Class | RedeyeCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

array
The one-dimensional Array that is the destination of the elements copied from RedeyeRectangleCollection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CopyTo Method

PegasusImaging.WinForms.ImagXpress9 Namespace > RedeyeCollection Class : CopyTo Method (RedeyeCollection)

Copies the entire collection to an array, starting at index of the target array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As RedeyeRectangle, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   RedeyeRectangle[] array,
   int index
);
[C++]
public: void CopyTo(
   RedeyeRectangle*[]* array,
   int index
)
[C++/CLI]
public:
void CopyTo(
   RedeyeRectangle^array<array>^ array,
   int index
)

Parameters

array
The one-dimensional Array that is the destination of the elements copied from RedeyeRectangleCollection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

RedeyeCollection Class | RedeyeCollection Members


Dispose Method

RedeyeCollection Class | RedeyeCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.ImagXpress9 Namespace > RedeyeCollection Class : Dispose Method (RedeyeCollection)

Releases all resources used by this PegasusImaging.WinForms.ImagXpress9.RedeyeCollection object.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

See Also

RedeyeCollection Class | RedeyeCollection Members


GetRedeyeRectangle Method

RedeyeCollection Class | RedeyeCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

rectangleID
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GetRedeyeRectangle Method

PegasusImaging.WinForms.ImagXpress9 Namespace > RedeyeCollection Class : GetRedeyeRectangle Method
[Visual Basic]
Public Function GetRedeyeRectangle( _
   ByVal rectangleID As Integer _
) As RedeyeRectangle
[C#]
public RedeyeRectangle GetRedeyeRectangle(
   int rectangleID
);
[C++]
public: RedeyeRectangle* GetRedeyeRectangle(
   int rectangleID
)
[C++/CLI]
public:
RedeyeRectangle^ GetRedeyeRectangle(
   int rectangleID
)

Parameters

rectangleID

See Also

RedeyeCollection Class | RedeyeCollection Members


IndexOf Method

RedeyeCollection Class | RedeyeCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
Object to locate in the collection.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

IndexOf Method

PegasusImaging.WinForms.ImagXpress9 Namespace > RedeyeCollection Class : IndexOf Method (RedeyeCollection)

Searches for the specified Object and returns the zero-based index of the first occurrence within the entire PageCollection.

[Visual Basic]
Public Function IndexOf( _
   ByVal value As RedeyeRectangle _
) As Integer
[C#]
public int IndexOf(
   RedeyeRectangle value
);
[C++]
public: int IndexOf(
   RedeyeRectangle* value
)
[C++/CLI]
public:
int IndexOf(
   RedeyeRectangle^ value
)

Parameters

value
Object to locate in the collection.

See Also

RedeyeCollection Class | RedeyeCollection Members


Insert Method

RedeyeCollection Class | RedeyeCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
The zero-based index at which the RedeyeRectangle should be inserted.
rectangleItem
The RedeyeRectangle to be inserted.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Insert Method

PegasusImaging.WinForms.ImagXpress9 Namespace > RedeyeCollection Class : Insert Method (RedeyeCollection)

Inserts a RedeyeRectangle at the specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal rectangleItem As RedeyeRectangle _
)
[C#]
public void Insert(
   int index,
   RedeyeRectangle rectangleItem
);
[C++]
public: void Insert(
   int index,
   RedeyeRectangle* rectangleItem
)
[C++/CLI]
public:
void Insert(
   int index,
   RedeyeRectangle^ rectangleItem
)

Parameters

index
The zero-based index at which the RedeyeRectangle should be inserted.
rectangleItem
The RedeyeRectangle to be inserted.

See Also

RedeyeCollection Class | RedeyeCollection Members


Remove Method

RedeyeCollection Class | RedeyeCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

rectangleItem
The RedeyeRectangle to be removed.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Remove Method

PegasusImaging.WinForms.ImagXpress9 Namespace > RedeyeCollection Class : Remove Method (RedeyeCollection)

Removes the RedeyeRectangle from the collection.

[Visual Basic]
Public Sub Remove( _
   ByVal rectangleItem As RedeyeRectangle _
)
[C#]
public void Remove(
   RedeyeRectangle rectangleItem
);
[C++]
public: void Remove(
   RedeyeRectangle* rectangleItem
)
[C++/CLI]
public:
void Remove(
   RedeyeRectangle^ rectangleItem
)

Parameters

rectangleItem
The RedeyeRectangle to be removed.

See Also

RedeyeCollection Class | RedeyeCollection Members


RemoveAt Method

RedeyeCollection Class | RedeyeCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RemoveAt Method

PegasusImaging.WinForms.ImagXpress9 Namespace > RedeyeCollection Class : RemoveAt Method (RedeyeCollection)

Remove operation for the RedeyeRectangle collection. Call the RedeyeRectangle destructor to free the RedeyeRectangle then remove the RedeyeRectangle from the collection.

[Visual Basic]
Public Sub RemoveAt( _
   ByVal index As Integer _
)
[C#]
public void RemoveAt(
   int index
);
[C++]
public: void RemoveAt(
   int index
)
[C++/CLI]
public:
void RemoveAt(
   int index
)

Parameters

index

See Also

RedeyeCollection Class | RedeyeCollection Members


RemoveRectangle Method

RedeyeCollection Class | RedeyeCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

rectangleID
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RemoveRectangle Method

PegasusImaging.WinForms.ImagXpress9 Namespace > RedeyeCollection Class : RemoveRectangle Method
[Visual Basic]
Public Sub RemoveRectangle( _
   ByVal rectangleID As Integer _
)
[C#]
public void RemoveRectangle(
   int rectangleID
);
[C++]
public: void RemoveRectangle(
   int rectangleID
)
[C++/CLI]
public:
void RemoveRectangle(
   int rectangleID
)

Parameters

rectangleID

See Also

RedeyeCollection Class | RedeyeCollection Members


RedeyeCollection Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RedeyeCollection Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : RedeyeCollection Class

For a list of all members of this type, see RedeyeCollection members.

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property Item |

See Also

RedeyeCollection Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Item Property

RedeyeCollection Class | RedeyeCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Item Property

PegasusImaging.WinForms.ImagXpress9 Namespace > RedeyeCollection Class : Item Property (RedeyeCollection)
[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As RedeyeRectangle
[C#]
public RedeyeRectangle this[
   int index
]; {get; set;}
[C++]
public: __property RedeyeRectangle* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   RedeyeRectangle* value
);
[C++/CLI]
public:
 property RedeyeRectangle^ default [int] {
   RedeyeRectangle^ get(int index);
   void set (int index, RedeyeRectangle^ value);
}

Parameters

index

See Also

RedeyeCollection Class | RedeyeCollection Members


RedeyeRectangle Class

RedeyeRectangle Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RedeyeRectangle Class

PegasusImaging.WinForms.ImagXpress9 Namespace : RedeyeRectangle Class

Summary description for RedeyeRectangle. AutoRemoveRedeye generates rectangle areas of objects thought to be redeyes and have been corrected (red removed). Because some objects looking like redeyes but are not are identified and corrected (false positives) and some redeyes not looking like what they are and are not corrected (missed negatives), a list of rectangles is automatically generated. These rectangles are available to the user (application) for analysis and corrective action. The user can redo the correction by editing the rectangle list, reload the picture and apply the AutoRemoveRedeye method again but indicating the method to use the existing list. Each RedeyeRectangle has five members describing the area of the redeye found and the likelyhood that the object was correctly identified. The X and Y position indicate the top left corner of the rectangle and The Width and Height denote the rectangle dimensions. The Confidence parameter indicates how likely the area identified is indeed a redeye object.

For a list of all members of this type, see RedeyeRectangle members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.RedeyeRectangle

Syntax

[Visual Basic]
Public Class RedeyeRectangle
[C#]
public class RedeyeRectangle
[C++]
public __gc class RedeyeRectangle
[C++/CLI]
public ref class RedeyeRectangle

See Also

RedeyeRectangle Members | PegasusImaging.WinForms.ImagXpress9 Namespace


RedeyeRectangle Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RedeyeRectangle Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : RedeyeRectangle Class

RedeyeRectangle overview

Public Constructors

Public Constructor RedeyeRectangle Constructor

Public Properties

Public Property Confidence
Public Property Height
Public Property Width
Public Property Xposition
Public Property Yposition

See Also

RedeyeRectangle Class | PegasusImaging.WinForms.ImagXpress9 Namespace


RedeyeRectangle Constructor

RedeyeRectangle Class | RedeyeRectangle Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RedeyeRectangle Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > RedeyeRectangle Class : RedeyeRectangle Constructor (RedeyeRectangle)
[Visual Basic]
Public Function New()
[C#]
public RedeyeRectangle();
[C++]
public: RedeyeRectangle();
[C++/CLI]
public:
RedeyeRectangle();

See Also

RedeyeRectangle Class | RedeyeRectangle Members


RedeyeRectangle Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RedeyeRectangle Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : RedeyeRectangle Class

For a list of all members of this type, see RedeyeRectangle members.

Public Properties

Public Property Confidence
Public Property Height
Public Property Width
Public Property Xposition
Public Property Yposition

See Also

RedeyeRectangle Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Confidence Property

RedeyeRectangle Class | RedeyeRectangle Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Confidence Property

PegasusImaging.WinForms.ImagXpress9 Namespace > RedeyeRectangle Class : Confidence Property (RedeyeRectangle)
[Visual Basic]
Public Property Confidence As Integer
[C#]
public int Confidence {get; set;}
[C++]
public: __property int get_Confidence();
public: __property void set_Confidence(
   int value
);
[C++/CLI]
public:
property int Confidence {
   int get();
   void set (int value);
}

See Also

RedeyeRectangle Class | RedeyeRectangle Members


Height Property

RedeyeRectangle Class | RedeyeRectangle Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Height Property

PegasusImaging.WinForms.ImagXpress9 Namespace > RedeyeRectangle Class : Height Property (RedeyeRectangle)
[Visual Basic]
Public Property Height As Integer
[C#]
public int Height {get; set;}
[C++]
public: __property int get_Height();
public: __property void set_Height(
   int value
);
[C++/CLI]
public:
property int Height {
   int get();
   void set (int value);
}

See Also

RedeyeRectangle Class | RedeyeRectangle Members


Width Property

RedeyeRectangle Class | RedeyeRectangle Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Width Property

PegasusImaging.WinForms.ImagXpress9 Namespace > RedeyeRectangle Class : Width Property (RedeyeRectangle)
[Visual Basic]
Public Property Width As Integer
[C#]
public int Width {get; set;}
[C++]
public: __property int get_Width();
public: __property void set_Width(
   int value
);
[C++/CLI]
public:
property int Width {
   int get();
   void set (int value);
}

See Also

RedeyeRectangle Class | RedeyeRectangle Members


Xposition Property

RedeyeRectangle Class | RedeyeRectangle Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Xposition Property

PegasusImaging.WinForms.ImagXpress9 Namespace > RedeyeRectangle Class : Xposition Property
[Visual Basic]
Public Property Xposition As Integer
[C#]
public int Xposition {get; set;}
[C++]
public: __property int get_Xposition();
public: __property void set_Xposition(
   int value
);
[C++/CLI]
public:
property int Xposition {
   int get();
   void set (int value);
}

See Also

RedeyeRectangle Class | RedeyeRectangle Members


Yposition Property

RedeyeRectangle Class | RedeyeRectangle Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Yposition Property

PegasusImaging.WinForms.ImagXpress9 Namespace > RedeyeRectangle Class : Yposition Property
[Visual Basic]
Public Property Yposition As Integer
[C#]
public int Yposition {get; set;}
[C++]
public: __property int get_Yposition();
public: __property void set_Yposition(
   int value
);
[C++/CLI]
public:
property int Yposition {
   int get();
   void set (int value);
}

See Also

RedeyeRectangle Class | RedeyeRectangle Members


ResizedEventArgs Class

ResizedEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ResizedEventArgs Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ResizedEventArgs Class

This class implements event data for Resized events.

For a list of all members of this type, see ResizedEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.ImagXpress9.ResizedEventArgs

Syntax

[Visual Basic]
Public Class ResizedEventArgs
   Inherits EventArgs
[C#]
public class ResizedEventArgs : EventArgs
[C++]
public __gc class ResizedEventArgs : public EventArgs
[C++/CLI]
public ref class ResizedEventArgs : public EventArgs

Remarks

Note: Resize is not supported for Camera Raw formats.

See Also

ResizedEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ResizedEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ResizedEventArgs Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ResizedEventArgs Class

ResizedEventArgs overview

Public Constructors

Public Constructor ResizedEventArgs Constructor The main constructor which initializes a new instance of the ResizedEventArgs class.

Public Properties

Public Property NewSize Gets the new size of the control.

See Also

ResizedEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ResizedEventArgs Constructor

ResizedEventArgs Class | ResizedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ResizedEventArgs Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ResizedEventArgs Class : ResizedEventArgs Constructor (ResizedEventArgs)

The main constructor which initializes a new instance of the ResizedEventArgs class.

[Visual Basic]
Public Function New()
[C#]
public ResizedEventArgs();
[C++]
public: ResizedEventArgs();
[C++/CLI]
public:
ResizedEventArgs();

See Also

ResizedEventArgs Class | ResizedEventArgs Members


ResizedEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ResizedEventArgs Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : ResizedEventArgs Class

For a list of all members of this type, see ResizedEventArgs members.

Public Properties

Public Property NewSize Gets the new size of the control.

See Also

ResizedEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


NewSize Property

ResizedEventArgs Class | ResizedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

NewSize Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ResizedEventArgs Class : NewSize Property

Gets the new size of the control.

[Visual Basic]
Public ReadOnly Property NewSize As Size
[C#]
public Size NewSize {get;}
[C++]
public: __property Size get_NewSize();
[C++/CLI]
public:
property Size NewSize {
   Size get();
}

Return Type

A Size value from the .NET Framework Class Library.

Remarks

Note: Available in all editions.

See Also

ResizedEventArgs Class | ResizedEventArgs Members


Resolution Class

Resolution Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Resolution Class

PegasusImaging.WinForms.ImagXpress9 Namespace : Resolution Class (PegasusImaging.WinForms.ImagXpress9)

This class contains properties and methods for the resoluion of an image.

For a list of all members of this type, see Resolution members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.Resolution

Syntax

[Visual Basic]
Public Class Resolution
[C#]
public class Resolution
[C++]
public __gc class Resolution
[C++/CLI]
public ref class Resolution

See Also

Resolution Members | PegasusImaging.WinForms.ImagXpress9 Namespace


Resolution Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Resolution Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : Resolution Class (PegasusImaging.WinForms.ImagXpress9)

Resolution overview

Public Constructors

Public Constructor Resolution Constructor Overloaded. The main constructor for the Resolution class.

Public Properties

Public Property Dimensions | Gets and sets the dimensions of the image.
Public Property Units | Gets and sets the unit of measure in which the resolution dimensions are expressed.

See Also

Resolution Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Resolution Constructor

Resolution Class | Resolution Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Resolution Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > Resolution Class : Resolution Constructor (Resolution)

The main constructor for the Resolution class.

Overload List

The main constructor for the Resolution class.

[Visual Basic] Public Sub New()

[C#] public Resolution();

[C++] public Resolution();

[C++/CLI] public Resolution();

Initializes a new instance of the Resolution class from the specified width, height and units.

[Visual Basic] Public Sub New(SizeF,GraphicsUnit)

[C#] public Resolution(SizeF,GraphicsUnit);

[C++] public Resolution(SizeF,GraphicsUnit);

[C++/CLI] public Resolution(SizeF,GraphicsUnit);

Initializes a new instance of the Resolution class from the specified width, height and units.

[Visual Basic] Public Sub New(Single,Single,GraphicsUnit)

[C#] public Resolution(float,float,GraphicsUnit);

[C++] public Resolution(float,float,GraphicsUnit);

[C++/CLI] public Resolution(float,float,GraphicsUnit);

See Also

Resolution Class | Resolution Members


Resolution Constructor()

Resolution Class | Resolution Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Resolution Constructor()

PegasusImaging.WinForms.ImagXpress9 Namespace > Resolution Class > Resolution Constructor : Resolution Constructor()

The main constructor for the Resolution class.

[Visual Basic]
Public Function New()
[C#]
public Resolution();
[C++]
public: Resolution();
[C++/CLI]
public:
Resolution();

See Also

Resolution Class | Resolution Members | Overload List


Resolution Constructor(Single,Single,GraphicsUnit)

Resolution Class | Resolution Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

width
A float value which represents the width of the current image.
height
A float value which represents the height of the current image.
units
A GraphicsUnit enumeration value which represents the unit of measure of the current image.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Resolution Constructor(Single,Single,GraphicsUnit)

PegasusImaging.WinForms.ImagXpress9 Namespace > Resolution Class > Resolution Constructor : Resolution Constructor(Single,Single,GraphicsUnit)

Initializes a new instance of the Resolution class from the specified width, height and units.

[Visual Basic]
Public Function New( _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal units As GraphicsUnit _
)
[C#]
public Resolution(
   float width,
   float height,
   GraphicsUnit units
);
[C++]
public: Resolution(
   float width,
   float height,
   GraphicsUnit units
)
[C++/CLI]
public:
Resolution(
   float width,
   float height,
   GraphicsUnit units
)

Parameters

width
A float value which represents the width of the current image.
height
A float value which represents the height of the current image.
units
A GraphicsUnit enumeration value which represents the unit of measure of the current image.

See Also

Resolution Class | Resolution Members | Overload List


Resolution Constructor(SizeF,GraphicsUnit)

Resolution Class | Resolution Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

dimensions
A SizeF structure which evauluates to the region associated with the current image.
units
A GraphicsUnit enumeration value which represents the unit of measure of the current image.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Resolution Constructor(SizeF,GraphicsUnit)

PegasusImaging.WinForms.ImagXpress9 Namespace > Resolution Class > Resolution Constructor : Resolution Constructor(SizeF,GraphicsUnit)

Initializes a new instance of the Resolution class from the specified width, height and units.

[Visual Basic]
Public Function New( _
   ByVal dimensions As SizeF, _
   ByVal units As GraphicsUnit _
)
[C#]
public Resolution(
   SizeF dimensions,
   GraphicsUnit units
);
[C++]
public: Resolution(
   SizeF dimensions,
   GraphicsUnit units
)
[C++/CLI]
public:
Resolution(
   SizeF dimensions,
   GraphicsUnit units
)

Parameters

dimensions
A SizeF structure which evauluates to the region associated with the current image.
units
A GraphicsUnit enumeration value which represents the unit of measure of the current image.

See Also

Resolution Class | Resolution Members | Overload List


Resolution Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Resolution Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : Resolution Class (PegasusImaging.WinForms.ImagXpress9)

For a list of all members of this type, see Resolution members.

Public Properties

Public Property Dimensions | Gets and sets the dimensions of the image.
Public Property Units | Gets and sets the unit of measure in which the resolution dimensions are expressed.

See Also

Resolution Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Dimensions Property

Resolution Class | Resolution Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Dimensions Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Resolution Class : Dimensions Property (Resolution)

Gets and sets the dimensions of the image.

[Visual Basic]
Public Property Dimensions As SizeF
[C#]
public SizeF Dimensions {get; set;}
[C++]
public: __property SizeF get_Dimensions();
public: __property void set_Dimensions(
   SizeF value
);
[C++/CLI]
public:
property SizeF Dimensions {
   SizeF get();
   void set (SizeF value);
}

Return Type

The SizeF value set.

See Also

Resolution Class | Resolution Members


Units Property

Resolution Class | Resolution Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Units Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Resolution Class : Units Property

Gets and sets the unit of measure in which the resolution dimensions are expressed.

[Visual Basic]
Public Property Units As GraphicsUnit
[C#]
public GraphicsUnit Units {get; set;}
[C++]
public: __property GraphicsUnit get_Units();
public: __property void set_Units(
   GraphicsUnit value
);
[C++/CLI]
public:
property GraphicsUnit Units {
   GraphicsUnit get();
   void set (GraphicsUnit value);
}

Return Type

The GraphicsUnit value set.

See Also

Resolution Class | Resolution Members


Rubberband Class

Rubberband Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Rubberband Class

PegasusImaging.WinForms.ImagXpress9 Namespace : Rubberband Class (PegasusImaging.WinForms.ImagXpress9)

This class implements methods and properties for part or all of an image to be selected within a dashed rectangular area.

For a list of all members of this type, see Rubberband members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.Rubberband

Syntax

[Visual Basic]
Public Class Rubberband
[C#]
public class Rubberband
[C++]
public __gc class Rubberband
[C++/CLI]
public ref class Rubberband

See Also

Rubberband Members | PegasusImaging.WinForms.ImagXpress9 Namespace


Rubberband Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Rubberband Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : Rubberband Class (PegasusImaging.WinForms.ImagXpress9)

Rubberband overview

Public Properties

Public Property Dimensions | Gets the Rubberband location and dimensions.
Public Property Enabled | Gets and sets an indicator if the rubberband is enabled.
Public Property Negate | Gets and sets an indicator if the Rubberband displays the area as a negative of the original.

Public Methods

Public Method Clear | Deletes the Rubberband and frees the memory associated with it.
Public Method Copy | Copies the current rubber band area into a new ImageX object.
Public Method Start | Overloaded. Sets the starting point for the Rubberband object.
Public Method Stop | Stops (disables) the rubberband.
Public Method Update | Updates the current rubber band ending point.

See Also

Rubberband Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Clear Method

Rubberband Class | Rubberband Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Clear Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Rubberband Class : Clear Method (Rubberband)

Deletes the Rubberband and frees the memory associated with it.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[C++/CLI]
public:
void Clear();

Remarks

There is no impact to the displayed image, or the image in memory.

See Also

Rubberband Class | Rubberband Members


Copy Method

Rubberband Class | Rubberband Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Copy Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Rubberband Class : Copy Method (Rubberband)

Copies the current rubber band area into a new ImageX object.

[Visual Basic]
Public Function Copy() As ImageX
[C#]
public ImageX Copy();
[C++]
public: ImageX* Copy();
[C++/CLI]
public:
ImageX^ Copy();

Return Type

An ImageX object.

Remarks

Note: Available in all editions.

See Also

Rubberband Class | Rubberband Members


Start Method

Rubberband Class | Rubberband Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Start Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Rubberband Class : Start Method

Sets the starting point for the Rubberband object.

Overload List

Sets the starting point for the Rubberband object.

[Visual Basic] Overloads Public Sub Start(Point)

[C#] public void Start(Point);

[C++] public void Start(Point);

[C++/CLI] public void Start(Point);

Sets the starting point for the Rubberband object.

[Visual Basic] Overloads Public Sub Start(Point,Boolean)

[C#] public void Start(Point,bool);

[C++] public void Start(Point,bool);

[C++/CLI] public void Start(Point,bool);

See Also

Rubberband Class | Rubberband Members


Start(Point) Method

Rubberband Class | Rubberband Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

screenStartPoint
A Point value which represents the starting point corner for the rubberband.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Start(Point) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Rubberband Class > Start Method : Start(Point) Method

Sets the starting point for the Rubberband object.

[Visual Basic]
Overloads Public Sub Start( _
   ByVal screenStartPoint As Point _
)
[C#]
public void Start(
   Point screenStartPoint
);
[C++]
public: void Start(
   Point screenStartPoint
)
[C++/CLI]
public:
void Start(
   Point screenStartPoint
)

Parameters

screenStartPoint
A Point value which represents the starting point corner for the rubberband.

See Also

Rubberband Class | Rubberband Members | Overload List


Start(Point,Boolean) Method

Rubberband Class | Rubberband Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

screenStartPoint
A Point value which represents the starting point corner for the rubberband.
negate
A boolean value which is true to display the rubberband area as a negative of the original.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Start(Point,Boolean) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Rubberband Class > Start Method : Start(Point,Boolean) Method

Sets the starting point for the Rubberband object.

[Visual Basic]
Overloads Public Sub Start( _
   ByVal screenStartPoint As Point, _
   ByVal negate As Boolean _
)
[C#]
public void Start(
   Point screenStartPoint,
   bool negate
);
[C++]
public: void Start(
   Point screenStartPoint,
   bool negate
)
[C++/CLI]
public:
void Start(
   Point screenStartPoint,
   bool negate
)

Parameters

screenStartPoint
A Point value which represents the starting point corner for the rubberband.
negate
A boolean value which is true to display the rubberband area as a negative of the original.

See Also

Rubberband Class | Rubberband Members | Overload List


Stop Method

Rubberband Class | Rubberband Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Stop Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Rubberband Class : Stop Method

Stops (disables) the rubberband.

[Visual Basic]
Public Sub Stop()
[C#]
public void Stop();
[C++]
public: void Stop();
[C++/CLI]
public:
void Stop();

See Also

Rubberband Class | Rubberband Members


Update Method

Rubberband Class | Rubberband Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

screenUpdatePoint
A Point value to represent the current ending point of the Rubberband.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Update Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Rubberband Class : Update Method

Updates the current rubber band ending point.

[Visual Basic]
Public Sub Update( _
   ByVal screenUpdatePoint As Point _
)
[C#]
public void Update(
   Point screenUpdatePoint
);
[C++]
public: void Update(
   Point screenUpdatePoint
)
[C++/CLI]
public:
void Update(
   Point screenUpdatePoint
)

Parameters

screenUpdatePoint
A Point value to represent the current ending point of the Rubberband.

See Also

Rubberband Class | Rubberband Members


Rubberband Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Rubberband Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : Rubberband Class (PegasusImaging.WinForms.ImagXpress9)

For a list of all members of this type, see Rubberband members.

Public Properties

Public Property Dimensions | Gets the Rubberband location and dimensions.
Public Property Enabled | Gets and sets an indicator if the rubberband is enabled.
Public Property Negate | Gets and sets an indicator if the Rubberband displays the area as a negative of the original.

See Also

Rubberband Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Dimensions Property

Rubberband Class | Rubberband Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Dimensions Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Rubberband Class : Dimensions Property (Rubberband)

Gets the Rubberband location and dimensions.

[Visual Basic]
Public ReadOnly Property Dimensions As Rectangle
[C#]
public Rectangle Dimensions {get;}
[C++]
public: __property Rectangle get_Dimensions();
[C++/CLI]
public:
property Rectangle Dimensions {
   Rectangle get();
}

Return Type

A Rectangle value which represents the location and dimensions.

Remarks

Note: Available in all editions.

See Also

Rubberband Class | Rubberband Members


Enabled Property

Rubberband Class | Rubberband Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Enabled Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Rubberband Class : Enabled Property (Rubberband)

Gets and sets an indicator if the rubberband is enabled.

[Visual Basic]
Public Property Enabled As Boolean
[C#]
public bool Enabled {get; set;}
[C++]
public: __property bool get_Enabled();
public: __property void set_Enabled(
   bool value
);
[C++/CLI]
public:
property bool Enabled {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true when the rubberband is enabled. Otherwise, false is used to disable rubberbanding.

Remarks

Note: Available in all editions.

See Also

Rubberband Class | Rubberband Members


Negate Property

Rubberband Class | Rubberband Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Negate Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Rubberband Class : Negate Property (Rubberband)

Gets and sets an indicator if the Rubberband displays the area as a negative of the original.

[Visual Basic]
Public Property Negate As Boolean
[C#]
public bool Negate {get; set;}
[C++]
public: __property bool get_Negate();
public: __property void set_Negate(
   bool value
);
[C++/CLI]
public:
property bool Negate {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true.

Remarks

Note: Available in all editions.

See Also

Rubberband Class | Rubberband Members


SaveOptions Class

SaveOptions Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptions Class

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptions Class

This class implements file writing of image formats.

For a list of all members of this type, see SaveOptions members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.SaveOptions

Syntax

[Visual Basic]
Public Class SaveOptions
[C#]
public class SaveOptions
[C++]
public __gc class SaveOptions
[C++/CLI]
public ref class SaveOptions

See Also

SaveOptions Members | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptions Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptions Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptions Class

SaveOptions overview

Public Constructors

Public Constructor SaveOptions Constructor Initializes a new instance of the SaveOptions class.

Public Properties

Public Property Annotations | Gets the save options for annotations.
Public Property BufferFtp |
Public Property ColorRenderIntent | Gets and sets how the color profiles should be applied.
Public Property Dcx | Gets the SaveOptionsDcx settings.
Public Property Exif | Gets the SaveOptionsExif settings.
Public Property Format | Gets and sets the format of the saved file.
Public Property Gif | Gets the SaveOptionsGif settings.
Public Property Hdp | Gets the SaveOptionsHdp settings.
Public Property Icon | Gets the SaveOptionsIcon settings.
Public Property Internet | Gets the InternetOptions object settings.
Public Property Jbig2 | Gets the SaveOptionsJbig2 settings.
Public Property Jls | Gets the SaveOptionsJls object settings.
Public Property Jp2 | Gets the SaveOptionsJp2 settings.
Public Property Jpeg | Gets the SaveOptionsJpeg settings.
Public Property LibraryNumberOfThreadsAllowed | Gets and sets the number of threads allowed.
Public Property Ljp | Gets the SaveOptionsLjp settings.
Public Property Pdf | Gets the SaveOptionsPdf settings.
Public Property Pic | Gets the SaveOptionsPic settings.
Public Property Png | Gets the SaveOptionsPng settings.
Public Property Portable | Gets the SaveOptionsPortable settings.
Public Property TargetProfileName | Gets and sets the target profile’s filename.
Public Property Tiff | Gets the SaveOptionsTiff settings.
Public Property UseEmbeddedColorManagement | Gets and sets an indicator if color management is used during saving.
Public Property Wsq | Gets the SaveOptionsWsq settings.

See Also

SaveOptions Class | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptions Constructor

SaveOptions Class | SaveOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptions Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptions Class : SaveOptions Constructor (SaveOptions)

Initializes a new instance of the SaveOptions class.

[Visual Basic]
Public Function New()
[C#]
public SaveOptions();
[C++]
public: SaveOptions();
[C++/CLI]
public:
SaveOptions();

See Also

SaveOptions Class | SaveOptions Members


SaveOptions Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptions Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptions Class

For a list of all members of this type, see SaveOptions members.

Public Properties

Public Property Annotations | Gets the save options for annotations.
Public Property BufferFtp |
Public Property ColorRenderIntent | Gets and sets how the color profiles should be applied.
Public Property Dcx | Gets the SaveOptionsDcx settings.
Public Property Exif | Gets the SaveOptionsExif settings.
Public Property Format | Gets and sets the format of the saved file.
Public Property Gif | Gets the SaveOptionsGif settings.
Public Property Hdp | Gets the SaveOptionsHdp settings.
Public Property Icon | Gets the SaveOptionsIcon settings.
Public Property Internet | Gets the InternetOptions object settings.
Public Property Jbig2 | Gets the SaveOptionsJbig2 settings.
Public Property Jls | Gets the SaveOptionsJls object settings.
Public Property Jp2 | Gets the SaveOptionsJp2 settings.
Public Property Jpeg | Gets the SaveOptionsJpeg settings.
Public Property LibraryNumberOfThreadsAllowed | Gets and sets the number of threads allowed.
Public Property Ljp | Gets the SaveOptionsLjp settings.
Public Property Pdf | Gets the SaveOptionsPdf settings.
Public Property Pic | Gets the SaveOptionsPic settings.
Public Property Png | Gets the SaveOptionsPng settings.
Public Property Portable | Gets the SaveOptionsPortable settings.
Public Property TargetProfileName | Gets and sets the target profile’s filename.
Public Property Tiff | Gets the SaveOptionsTiff settings.
Public Property UseEmbeddedColorManagement | Gets and sets an indicator if color management is used during saving.
Public Property Wsq | Gets the SaveOptionsWsq settings.

See Also

SaveOptions Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Annotations Property

SaveOptions Class | SaveOptions Members | SaveOptionsAnnotations Class

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Annotations Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptions Class : Annotations Property

Gets the save options for annotations.

[Visual Basic]
Public ReadOnly Property Annotations As SaveOptionsAnnotations
[C#]
public SaveOptionsAnnotations Annotations {get;}
[C++]
public: __property SaveOptionsAnnotations* get_Annotations();
[C++/CLI]
public:
property SaveOptionsAnnotations^ Annotations {
   SaveOptionsAnnotations^ get();
}

Return Type

A SaveOptionsAnnotations object which contains information for saving the annotations.

See Also

SaveOptions Class | SaveOptions Members | SaveOptionsAnnotations Class


BufferFtp Property

SaveOptions Class | SaveOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

BufferFtp Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptions Class : BufferFtp Property
[Visual Basic]
Public Property BufferFtp As Boolean
[C#]
public bool BufferFtp {get; set;}
[C++]
public: __property bool get_BufferFtp();
public: __property void set_BufferFtp(
   bool value
);
[C++/CLI]
public:
property bool BufferFtp {
   bool get();
   void set (bool value);
}

See Also

SaveOptions Class | SaveOptions Members


ColorRenderIntent Property

SaveOptions Class | SaveOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ColorRenderIntent Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptions Class : ColorRenderIntent Property (SaveOptions)

Gets and sets how the color profiles should be applied.

[Visual Basic]
Public Property ColorRenderIntent As RenderIntent
[C#]
public RenderIntent ColorRenderIntent {get; set;}
[C++]
public: __property RenderIntent get_ColorRenderIntent();
public: __property void set_ColorRenderIntent(
   RenderIntent value
);
[C++/CLI]
public:
property RenderIntent ColorRenderIntent {
   RenderIntent get();
   void set (RenderIntent value);
}

See Also

SaveOptions Class | SaveOptions Members


Dcx Property

SaveOptions Class | SaveOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Dcx Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptions Class : Dcx Property

Gets the SaveOptionsDcx settings.

[Visual Basic]
Public ReadOnly Property Dcx As SaveOptionsDcx
[C#]
public SaveOptionsDcx Dcx {get;}
[C++]
public: __property SaveOptionsDcx* get_Dcx();
[C++/CLI]
public:
property SaveOptionsDcx^ Dcx {
   SaveOptionsDcx^ get();
}

Return Type

A SaveOptionsDcx object which contains the image settings.

See Also

SaveOptions Class | SaveOptions Members


Exif Property

SaveOptions Class | SaveOptions Members | SaveOptionsExif Class

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Exif Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptions Class : Exif Property

Gets the SaveOptionsExif settings.

[Visual Basic]
Public ReadOnly Property Exif As SaveOptionsExif
[C#]
public SaveOptionsExif Exif {get;}
[C++]
public: __property SaveOptionsExif* get_Exif();
[C++/CLI]
public:
property SaveOptionsExif^ Exif {
   SaveOptionsExif^ get();
}

Return Type

A SaveOptionsExif object which contains the image settings.

See Also

SaveOptions Class | SaveOptions Members | SaveOptionsExif Class


Format Property

SaveOptions Class | SaveOptions Members | ImageXFormat Enumeration

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Format Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptions Class : Format Property (SaveOptions)

Gets and sets the format of the saved file.

[Visual Basic]
Public Property Format As ImageXFormat
[C#]
public ImageXFormat Format {get; set;}
[C++]
public: __property ImageXFormat get_Format();
public: __property void set_Format(
   ImageXFormat value
);
[C++/CLI]
public:
property ImageXFormat Format {
   ImageXFormat get();
   void set (ImageXFormat value);
}

Return Type

A ImageXFormat enumeration value which determines the format.

See Also

SaveOptions Class | SaveOptions Members | ImageXFormat Enumeration


Gif Property

SaveOptions Class | SaveOptions Members | SaveOptionsGif Class

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Gif Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptions Class : Gif Property

Gets the SaveOptionsGif settings.

[Visual Basic]
Public ReadOnly Property Gif As SaveOptionsGif
[C#]
public SaveOptionsGif Gif {get;}
[C++]
public: __property SaveOptionsGif* get_Gif();
[C++/CLI]
public:
property SaveOptionsGif^ Gif {
   SaveOptionsGif^ get();
}

Return Type

A SaveOptionsGif object which contains the image settings.

See Also

SaveOptions Class | SaveOptions Members | SaveOptionsGif Class


Hdp Property

SaveOptions Class | SaveOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Hdp Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptions Class : Hdp Property

Gets the SaveOptionsHdp settings.

[Visual Basic]
Public ReadOnly Property Hdp As SaveOptionsHdp
[C#]
public SaveOptionsHdp Hdp {get;}
[C++]
public: __property SaveOptionsHdp* get_Hdp();
[C++/CLI]
public:
property SaveOptionsHdp^ Hdp {
   SaveOptionsHdp^ get();
}

Return Type

A SaveOptionsHdp object which contains the image settings.

See Also

SaveOptions Class | SaveOptions Members


Icon Property

SaveOptions Class | SaveOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Icon Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptions Class : Icon Property

Gets the SaveOptionsIcon settings.

[Visual Basic]
Public ReadOnly Property Icon As SaveOptionsIcon
[C#]
public SaveOptionsIcon Icon {get;}
[C++]
public: __property SaveOptionsIcon* get_Icon();
[C++/CLI]
public:
property SaveOptionsIcon^ Icon {
   SaveOptionsIcon^ get();
}

Return Type

A SaveOptionsIcon object which contains the image settings.

See Also

SaveOptions Class | SaveOptions Members


Internet Property

SaveOptions Class | SaveOptions Members | InternetOptions Class

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Internet Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptions Class : Internet Property (SaveOptions)

Gets the InternetOptions object settings.

[Visual Basic]
Public ReadOnly Property Internet As InternetOptions
[C#]
public InternetOptions Internet {get;}
[C++]
public: __property InternetOptions* get_Internet();
[C++/CLI]
public:
property InternetOptions^ Internet {
   InternetOptions^ get();
}

Return Type

InternetOptions settings.

See Also

SaveOptions Class | SaveOptions Members | InternetOptions Class


Jbig2 Property

SaveOptions Class | SaveOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Jbig2 Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptions Class : Jbig2 Property (SaveOptions)

Gets the SaveOptionsJbig2 settings.

[Visual Basic]
Public ReadOnly Property Jbig2 As SaveOptionsJbig2
[C#]
public SaveOptionsJbig2 Jbig2 {get;}
[C++]
public: __property SaveOptionsJbig2* get_Jbig2();
[C++/CLI]
public:
property SaveOptionsJbig2^ Jbig2 {
   SaveOptionsJbig2^ get();
}

Return Type

A SaveOptionsJbig2 object which contains the image settings.

See Also

SaveOptions Class | SaveOptions Members


Jls Property

SaveOptions Class | SaveOptions Members | SaveOptionsJls Class

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Jls Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptions Class : Jls Property

Gets the SaveOptionsJls object settings.

[Visual Basic]
Public ReadOnly Property Jls As SaveOptionsJls
[C#]
public SaveOptionsJls Jls {get;}
[C++]
public: __property SaveOptionsJls* get_Jls();
[C++/CLI]
public:
property SaveOptionsJls^ Jls {
   SaveOptionsJls^ get();
}

Return Type

A SaveOptionsJls object which contains the image settings.

See Also

SaveOptions Class | SaveOptions Members | SaveOptionsJls Class


Jp2 Property

SaveOptions Class | SaveOptions Members | SaveOptionsJp2 Class

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Jp2 Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptions Class : Jp2 Property

Gets the SaveOptionsJp2 settings.

[Visual Basic]
Public ReadOnly Property Jp2 As SaveOptionsJp2
[C#]
public SaveOptionsJp2 Jp2 {get;}
[C++]
public: __property SaveOptionsJp2* get_Jp2();
[C++/CLI]
public:
property SaveOptionsJp2^ Jp2 {
   SaveOptionsJp2^ get();
}

Return Type

A SaveOptionsJp2 object which contains the image settings.

See Also

SaveOptions Class | SaveOptions Members | SaveOptionsJp2 Class


Jpeg Property

SaveOptions Class | SaveOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Jpeg Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptions Class : Jpeg Property (SaveOptions)

Gets the SaveOptionsJpeg settings.

[Visual Basic]
Public ReadOnly Property Jpeg As SaveOptionsJpeg
[C#]
public SaveOptionsJpeg Jpeg {get;}
[C++]
public: __property SaveOptionsJpeg* get_Jpeg();
[C++/CLI]
public:
property SaveOptionsJpeg^ Jpeg {
   SaveOptionsJpeg^ get();
}

Return Type

A SaveOptionsJpeg object which contains the image settings.

See Also

SaveOptions Class | SaveOptions Members


LibraryNumberOfThreadsAllowed Property

SaveOptions Class | SaveOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LibraryNumberOfThreadsAllowed Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptions Class : LibraryNumberOfThreadsAllowed Property (SaveOptions)

Gets and sets the number of threads allowed.

[Visual Basic]
Public Property LibraryNumberOfThreadsAllowed As Integer
[C#]
public int LibraryNumberOfThreadsAllowed {get; set;}
[C++]
public: __property int get_LibraryNumberOfThreadsAllowed();
public: __property void set_LibraryNumberOfThreadsAllowed(
   int value
);
[C++/CLI]
public:
property int LibraryNumberOfThreadsAllowed {
   int get();
   void set (int value);
}

See Also

SaveOptions Class | SaveOptions Members


Ljp Property

SaveOptions Class | SaveOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Ljp Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptions Class : Ljp Property

Gets the SaveOptionsLjp settings.

[Visual Basic]
Public ReadOnly Property Ljp As SaveOptionsLjp
[C#]
public SaveOptionsLjp Ljp {get;}
[C++]
public: __property SaveOptionsLjp* get_Ljp();
[C++/CLI]
public:
property SaveOptionsLjp^ Ljp {
   SaveOptionsLjp^ get();
}

Return Type

A SaveOptionsLjp object which contains the image settings.

See Also

SaveOptions Class | SaveOptions Members


Pdf Property

SaveOptions Class | SaveOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Pdf Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptions Class : Pdf Property (SaveOptions)

Gets the SaveOptionsPdf settings.

[Visual Basic]
Public ReadOnly Property Pdf As SaveOptionsPdf
[C#]
public SaveOptionsPdf Pdf {get;}
[C++]
public: __property SaveOptionsPdf* get_Pdf();
[C++/CLI]
public:
property SaveOptionsPdf^ Pdf {
   SaveOptionsPdf^ get();
}

Return Type

A SaveOptionsPdf object which contains the image settings.

See Also

SaveOptions Class | SaveOptions Members


Pic Property

SaveOptions Class | SaveOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Pic Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptions Class : Pic Property (SaveOptions)

Gets the SaveOptionsPic settings.

[Visual Basic]
Public ReadOnly Property Pic As SaveOptionsPic
[C#]
public SaveOptionsPic Pic {get;}
[C++]
public: __property SaveOptionsPic* get_Pic();
[C++/CLI]
public:
property SaveOptionsPic^ Pic {
   SaveOptionsPic^ get();
}

Return Type

A SaveOptionsPic object which contains the image settings.

See Also

SaveOptions Class | SaveOptions Members


Png Property

SaveOptions Class | SaveOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Png Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptions Class : Png Property

Gets the SaveOptionsPng settings.

[Visual Basic]
Public ReadOnly Property Png As SaveOptionsPng
[C#]
public SaveOptionsPng Png {get;}
[C++]
public: __property SaveOptionsPng* get_Png();
[C++/CLI]
public:
property SaveOptionsPng^ Png {
   SaveOptionsPng^ get();
}

Return Type

A SaveOptionsPng object which contains the image settings.

See Also

SaveOptions Class | SaveOptions Members


Portable Property

SaveOptions Class | SaveOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Portable Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptions Class : Portable Property

Gets the SaveOptionsPortable settings.

[Visual Basic]
Public ReadOnly Property Portable As SaveOptionsPortable
[C#]
public SaveOptionsPortable Portable {get;}
[C++]
public: __property SaveOptionsPortable* get_Portable();
[C++/CLI]
public:
property SaveOptionsPortable^ Portable {
   SaveOptionsPortable^ get();
}

Return Type

A SaveOptionsPortable object which contains the image settings.

See Also

SaveOptions Class | SaveOptions Members


TargetProfileName Property

SaveOptions Class | SaveOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

TargetProfileName Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptions Class : TargetProfileName Property (SaveOptions)

Gets and sets the target profile’s filename.

[Visual Basic]
Public Property TargetProfileName As String
[C#]
public string TargetProfileName {get; set;}
[C++]
public: __property string* get_TargetProfileName();
public: __property void set_TargetProfileName(
   string* value
);
[C++/CLI]
public:
property String^ TargetProfileName {
   String^ get();
   void set (String^ value);
}

Return Type

A string value which represents the target profile's filename.

Remarks

When the image is saved, the specified profile is applied to the image, and the resulting converted image is saved.

Note: This property is available only in the ImagXpress Photo edition. If you are licensed for Document, Standard or view and attempt to set this property, the change will not occur and an exception returns.

See Also

SaveOptions Class | SaveOptions Members


Tiff Property

SaveOptions Class | SaveOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Tiff Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptions Class : Tiff Property (SaveOptions)

Gets the SaveOptionsTiff settings.

[Visual Basic]
Public ReadOnly Property Tiff As SaveOptionsTiff
[C#]
public SaveOptionsTiff Tiff {get;}
[C++]
public: __property SaveOptionsTiff* get_Tiff();
[C++/CLI]
public:
property SaveOptionsTiff^ Tiff {
   SaveOptionsTiff^ get();
}

Return Type

A SaveOptionsTiff object which contains the image settings.

See Also

SaveOptions Class | SaveOptions Members


UseEmbeddedColorManagement Property

SaveOptions Class | SaveOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

UseEmbeddedColorManagement Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptions Class : UseEmbeddedColorManagement Property (SaveOptions)

Gets and sets an indicator if color management is used during saving.

[Visual Basic]
Public Property UseEmbeddedColorManagement As Boolean
[C#]
public bool UseEmbeddedColorManagement {get; set;}
[C++]
public: __property bool get_UseEmbeddedColorManagement();
public: __property void set_UseEmbeddedColorManagement(
   bool value
);
[C++/CLI]
public:
property bool UseEmbeddedColorManagement {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to apply the color profile associated with the imageX image to the saved image. Otherwise, set to false to not apply the color profile to the saved image.

See Also

SaveOptions Class | SaveOptions Members


Wsq Property

SaveOptions Class | SaveOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Wsq Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptions Class : Wsq Property

Gets the SaveOptionsWsq settings.

[Visual Basic]
Public ReadOnly Property Wsq As SaveOptionsWsq
[C#]
public SaveOptionsWsq Wsq {get;}
[C++]
public: __property SaveOptionsWsq* get_Wsq();
[C++/CLI]
public:
property SaveOptionsWsq^ Wsq {
   SaveOptionsWsq^ get();
}

Return Type

A SaveOptionsWsq object which contains the image settings.

See Also

SaveOptions Class | SaveOptions Members


SaveOptionsAnnotations Class

SaveOptionsAnnotations Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsAnnotations Class

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsAnnotations Class

This class implements options required to save annotations with the image.

For a list of all members of this type, see SaveOptionsAnnotations members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.SaveOptionsAnnotations

Syntax

[Visual Basic]
Public Class SaveOptionsAnnotations
[C#]
public class SaveOptionsAnnotations
[C++]
public __gc class SaveOptionsAnnotations
[C++/CLI]
public ref class SaveOptionsAnnotations

See Also

SaveOptionsAnnotations Members | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsAnnotations Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsAnnotations Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsAnnotations Class

SaveOptionsAnnotations overview

Public Constructors

Public Constructor SaveOptionsAnnotations Constructor Initializes a new instance of the SaveOptionsAnnotations class.

Public Properties

Public Property Save | Gets and sets an indicator to save annotations with the image or not.
Public Property View | Gets and sets the specific set of annotations to save with the image.

See Also

SaveOptionsAnnotations Class | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsAnnotations Constructor

SaveOptionsAnnotations Class | SaveOptionsAnnotations Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsAnnotations Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsAnnotations Class : SaveOptionsAnnotations Constructor (SaveOptionsAnnotations)

Initializes a new instance of the SaveOptionsAnnotations class.

[Visual Basic]
Public Function New()
[C#]
public SaveOptionsAnnotations();
[C++]
public: SaveOptionsAnnotations();
[C++/CLI]
public:
SaveOptionsAnnotations();

See Also

SaveOptionsAnnotations Class | SaveOptionsAnnotations Members


SaveOptionsAnnotations Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsAnnotations Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsAnnotations Class

For a list of all members of this type, see SaveOptionsAnnotations members.

Public Properties

Public Property Save | Gets and sets an indicator to save annotations with the image or not.
Public Property View | Gets and sets the specific set of annotations to save with the image.

See Also

SaveOptionsAnnotations Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Save Property

SaveOptionsAnnotations Class | SaveOptionsAnnotations Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Save Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsAnnotations Class : Save Property (SaveOptionsAnnotations)

Gets and sets an indicator to save annotations with the image or not.

[Visual Basic]
Public Property Save As Boolean
[C#]
public bool Save {get; set;}
[C++]
public: __property bool get_Save();
public: __property void set_Save(
   bool value
);
[C++/CLI]
public:
property bool Save {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to save the annotations with the image. Otherwise, false should be used.

Remarks

The default value is true.

See Also

SaveOptionsAnnotations Class | SaveOptionsAnnotations Members


View Property

SaveOptionsAnnotations Class | SaveOptionsAnnotations Members | Save Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

View Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsAnnotations Class : View Property

Gets and sets the specific set of annotations to save with the image.

[Visual Basic]
Public Property View As ImageXView
[C#]
public ImageXView View {get; set;}
[C++]
public: __property ImageXView* get_View();
public: __property void set_View(
   ImageXView* value
);
[C++/CLI]
public:
property ImageXView^ View {
   ImageXView^ get();
   void set (ImageXView^ value);
}

Return Type

An ImageXView object.

Remarks

If the Save property is set to true , then annotations are saved with the image.

This property specifies the set of annotations to save with the image. If this property is null, the last set of annotations that was active in the view is saved.

See Also

SaveOptionsAnnotations Class | SaveOptionsAnnotations Members | Save Property


SaveOptionsDcx Class

SaveOptionsDcx Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsDcx Class

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsDcx Class

This class implements the SaveOptions for the DCX file format.

For a list of all members of this type, see SaveOptionsDcx members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.SaveOptionsDcx

Syntax

[Visual Basic]
Public Class SaveOptionsDcx
[C#]
public class SaveOptionsDcx
[C++]
public __gc class SaveOptionsDcx
[C++/CLI]
public ref class SaveOptionsDcx

See Also

SaveOptionsDcx Members | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsDcx Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsDcx Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsDcx Class

SaveOptionsDcx overview

Public Constructors

Public Constructor SaveOptionsDcx Constructor Initializes a new instance of the SaveOptionsDcs class.

Public Properties

Public Property MultiPage Gets and sets an indicator if the image is saved to a multi-page file.

See Also

SaveOptionsDcx Class | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsDcx Constructor

SaveOptionsDcx Class | SaveOptionsDcx Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsDcx Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsDcx Class : SaveOptionsDcx Constructor (SaveOptionsDcx)

Initializes a new instance of the SaveOptionsDcs class.

[Visual Basic]
Public Function New()
[C#]
public SaveOptionsDcx();
[C++]
public: SaveOptionsDcx();
[C++/CLI]
public:
SaveOptionsDcx();

See Also

SaveOptionsDcx Class | SaveOptionsDcx Members


SaveOptionsDcx Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsDcx Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsDcx Class

For a list of all members of this type, see SaveOptionsDcx members.

Public Properties

Public Property MultiPage Gets and sets an indicator if the image is saved to a multi-page file.

See Also

SaveOptionsDcx Class | PegasusImaging.WinForms.ImagXpress9 Namespace


MultiPage Property

SaveOptionsDcx Class | SaveOptionsDcx Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

MultiPage Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsDcx Class : MultiPage Property (SaveOptionsDcx)

Gets and sets an indicator if the image is saved to a multi-page file.

[Visual Basic]
Public Property MultiPage As Boolean
[C#]
public bool MultiPage {get; set;}
[C++]
public: __property bool get_MultiPage();
public: __property void set_MultiPage(
   bool value
);
[C++/CLI]
public:
property bool MultiPage {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true if the image is saved to a multi-page file. Otherwise, false should be used.

See Also

SaveOptionsDcx Class | SaveOptionsDcx Members


SaveOptionsExif Class

SaveOptionsExif Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsExif Class

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsExif Class

This class implements the SaveOptions for the EXIF file format.

For a list of all members of this type, see SaveOptionsExif members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.SaveOptionsExif

Syntax

[Visual Basic]
Public Class SaveOptionsExif
[C#]
public class SaveOptionsExif
[C++]
public __gc class SaveOptionsExif
[C++/CLI]
public ref class SaveOptionsExif

See Also

SaveOptionsExif Members | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsExif Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsExif Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsExif Class

SaveOptionsExif overview

Public Constructors

Public Constructor SaveOptionsExif Constructor Initializes a new instance of the SaveOptionsExif class.

Public Properties

Public Property ThumbnailSize Gets and sets the size of the thumbnail image (in pixels) to be saved.

See Also

SaveOptionsExif Class | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsExif Constructor

SaveOptionsExif Class | SaveOptionsExif Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsExif Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsExif Class : SaveOptionsExif Constructor (SaveOptionsExif)

Initializes a new instance of the SaveOptionsExif class.

[Visual Basic]
Public Function New()
[C#]
public SaveOptionsExif();
[C++]
public: SaveOptionsExif();
[C++/CLI]
public:
SaveOptionsExif();

See Also

SaveOptionsExif Class | SaveOptionsExif Members


SaveOptionsExif Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsExif Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsExif Class

For a list of all members of this type, see SaveOptionsExif members.

Public Properties

Public Property ThumbnailSize Gets and sets the size of the thumbnail image (in pixels) to be saved.

See Also

SaveOptionsExif Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ThumbnailSize Property

SaveOptionsExif Class | SaveOptionsExif Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ThumbnailSize Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsExif Class : ThumbnailSize Property (SaveOptionsExif)

Gets and sets the size of the thumbnail image (in pixels) to be saved.

[Visual Basic]
Public Property ThumbnailSize As Integer
[C#]
public int ThumbnailSize {get; set;}
[C++]
public: __property int get_ThumbnailSize();
public: __property void set_ThumbnailSize(
   int value
);
[C++/CLI]
public:
property int ThumbnailSize {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the size of the thumbnail image in pixels.

See Also

SaveOptionsExif Class | SaveOptionsExif Members


SaveOptionsGif Class

SaveOptionsGif Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsGif Class

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsGif Class

This class implements the SaveOptions for the GIF file format.

For a list of all members of this type, see SaveOptionsGif members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.SaveOptionsGif

Syntax

[Visual Basic]
Public Class SaveOptionsGif
[C#]
public class SaveOptionsGif
[C++]
public __gc class SaveOptionsGif
[C++/CLI]
public ref class SaveOptionsGif

See Also

SaveOptionsGif Members | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsGif Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsGif Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsGif Class

SaveOptionsGif overview

Public Constructors

Public Constructor SaveOptionsGif Constructor Initializes a new instance of the SaveOptionsGifData class.

Public Properties

Public Property Interlaced | Gets and sets an indicator if the image is saved to a GIF file with interlaced format.
Public Property TransparencyColor | Gets and sets the color value used to represent transparency in the saved image.
Public Property TransparencyMatch | Gets and sets the type of transparency match to perform.
Public Property Type | Gets and sets the type of GIF file format.

See Also

SaveOptionsGif Class | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsGif Constructor

SaveOptionsGif Class | SaveOptionsGif Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsGif Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsGif Class : SaveOptionsGif Constructor (SaveOptionsGif)

Initializes a new instance of the SaveOptionsGifData class.

[Visual Basic]
Public Function New()
[C#]
public SaveOptionsGif();
[C++]
public: SaveOptionsGif();
[C++/CLI]
public:
SaveOptionsGif();

See Also

SaveOptionsGif Class | SaveOptionsGif Members


SaveOptionsGif Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsGif Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsGif Class

For a list of all members of this type, see SaveOptionsGif members.

Public Properties

Public Property Interlaced | Gets and sets an indicator if the image is saved to a GIF file with interlaced format.
Public Property TransparencyColor | Gets and sets the color value used to represent transparency in the saved image.
Public Property TransparencyMatch | Gets and sets the type of transparency match to perform.
Public Property Type | Gets and sets the type of GIF file format.

See Also

SaveOptionsGif Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Interlaced Property

SaveOptionsGif Class | SaveOptionsGif Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Interlaced Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsGif Class : Interlaced Property (SaveOptionsGif)

Gets and sets an indicator if the image is saved to a GIF file with interlaced format.

[Visual Basic]
Public Property Interlaced As Boolean
[C#]
public bool Interlaced {get; set;}
[C++]
public: __property bool get_Interlaced();
public: __property void set_Interlaced(
   bool value
);
[C++/CLI]
public:
property bool Interlaced {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to save the image to a GIF file with interlaced format.

See Also

SaveOptionsGif Class | SaveOptionsGif Members


TransparencyColor Property

SaveOptionsGif Class | SaveOptionsGif Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

TransparencyColor Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsGif Class : TransparencyColor Property (SaveOptionsGif)

Gets and sets the color value used to represent transparency in the saved image.

[Visual Basic]
Public Property TransparencyColor As Color
[C#]
public Color TransparencyColor {get; set;}
[C++]
public: __property Color get_TransparencyColor();
public: __property void set_TransparencyColor(
   Color value
);
[C++/CLI]
public:
property Color TransparencyColor {
   Color get();
   void set (Color value);
}

Return Type

A Color value which represents transparency in the saved image.

See Also

SaveOptionsGif Class | SaveOptionsGif Members


TransparencyMatch Property

SaveOptionsGif Class | SaveOptionsGif Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

TransparencyMatch Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsGif Class : TransparencyMatch Property (SaveOptionsGif)

Gets and sets the type of transparency match to perform.

[Visual Basic]
Public Property TransparencyMatch As TransparencyMatch
[C#]
public TransparencyMatch TransparencyMatch {get; set;}
[C++]
public: __property TransparencyMatch get_TransparencyMatch();
public: __property void set_TransparencyMatch(
   TransparencyMatch value
);
[C++/CLI]
public:
property TransparencyMatch TransparencyMatch {
   TransparencyMatch get();
   void set (TransparencyMatch value);
}

Return Type

A TransparencyMatch enumeration value.

See Also

SaveOptionsGif Class | SaveOptionsGif Members


Type Property

SaveOptionsGif Class | SaveOptionsGif Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Type Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsGif Class : Type Property (SaveOptionsGif)

Gets and sets the type of GIF file format.

[Visual Basic]
Public Property Type As GifType
[C#]
public GifType Type {get; set;}
[C++]
public: __property GifType get_Type();
public: __property void set_Type(
   GifType value
);
[C++/CLI]
public:
property GifType Type {
   GifType get();
   void set (GifType value);
}

Return Type

A GifType enumeration value.

See Also

SaveOptionsGif Class | SaveOptionsGif Members


SaveOptionsHdp Class

SaveOptionsHdp Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsHdp Class

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsHdp Class

This class implements SaveOptions for the Hdp file format.

For a list of all members of this type, see SaveOptionsHdp members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.SaveOptionsHdp

Syntax

[Visual Basic]
Public Class SaveOptionsHdp
[C#]
public class SaveOptionsHdp
[C++]
public __gc class SaveOptionsHdp
[C++/CLI]
public ref class SaveOptionsHdp

See Also

SaveOptionsHdp Members | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsHdp Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsHdp Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsHdp Class

SaveOptionsHdp overview

Public Constructors

Public Constructor SaveOptionsHdp Constructor Initializes a new instance of the SaveOptionsHdpData class.

Public Properties

Public Property ChromaSubSampling | Gets or sets the chroma sub sampling.
Public Property FrequencyOrder | Gets or sets the frequency order.
Public Property Quantization | Gets or sets the quantization.

See Also

SaveOptionsHdp Class | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsHdp Constructor

SaveOptionsHdp Class | SaveOptionsHdp Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsHdp Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsHdp Class : SaveOptionsHdp Constructor (SaveOptionsHdp)

Initializes a new instance of the SaveOptionsHdpData class.

[Visual Basic]
Public Function New()
[C#]
public SaveOptionsHdp();
[C++]
public: SaveOptionsHdp();
[C++/CLI]
public:
SaveOptionsHdp();

See Also

SaveOptionsHdp Class | SaveOptionsHdp Members


SaveOptionsHdp Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsHdp Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsHdp Class

For a list of all members of this type, see SaveOptionsHdp members.

Public Properties

Public Property ChromaSubSampling | Gets or sets the chroma sub sampling.
Public Property FrequencyOrder | Gets or sets the frequency order.
Public Property Quantization | Gets or sets the quantization.

See Also

SaveOptionsHdp Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ChromaSubSampling Property

SaveOptionsHdp Class | SaveOptionsHdp Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ChromaSubSampling Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsHdp Class : ChromaSubSampling Property

Gets or sets the chroma sub sampling.

[Visual Basic]
Public Property ChromaSubSampling As HdpSubSampling
[C#]
public HdpSubSampling ChromaSubSampling {get; set;}
[C++]
public: __property HdpSubSampling get_ChromaSubSampling();
public: __property void set_ChromaSubSampling(
   HdpSubSampling value
);
[C++/CLI]
public:
property HdpSubSampling ChromaSubSampling {
   HdpSubSampling get();
   void set (HdpSubSampling value);
}

Return Type

The chroma sub sampling.

See Also

SaveOptionsHdp Class | SaveOptionsHdp Members


FrequencyOrder Property

SaveOptionsHdp Class | SaveOptionsHdp Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

FrequencyOrder Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsHdp Class : FrequencyOrder Property

Gets or sets the frequency order.

[Visual Basic]
Public Property FrequencyOrder As Integer
[C#]
public int FrequencyOrder {get; set;}
[C++]
public: __property int get_FrequencyOrder();
public: __property void set_FrequencyOrder(
   int value
);
[C++/CLI]
public:
property int FrequencyOrder {
   int get();
   void set (int value);
}

Return Type

The frequency order.

See Also

SaveOptionsHdp Class | SaveOptionsHdp Members


Quantization Property

SaveOptionsHdp Class | SaveOptionsHdp Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Quantization Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsHdp Class : Quantization Property (SaveOptionsHdp)

Gets or sets the quantization.

[Visual Basic]
Public Property Quantization As Integer
[C#]
public int Quantization {get; set;}
[C++]
public: __property int get_Quantization();
public: __property void set_Quantization(
   int value
);
[C++/CLI]
public:
property int Quantization {
   int get();
   void set (int value);
}

Return Type

The quantization.

See Also

SaveOptionsHdp Class | SaveOptionsHdp Members


SaveOptionsIcon Class

SaveOptionsIcon Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsIcon Class

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsIcon Class

This class implements SaveOptions for the Icon file format.

For a list of all members of this type, see SaveOptionsIcon members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.SaveOptionsIcon

Syntax

[Visual Basic]
Public Class SaveOptionsIcon
[C#]
public class SaveOptionsIcon
[C++]
public __gc class SaveOptionsIcon
[C++/CLI]
public ref class SaveOptionsIcon

See Also

SaveOptionsIcon Members | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsIcon Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsIcon Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsIcon Class

SaveOptionsIcon overview

Public Constructors

Public Constructor SaveOptionsIcon Constructor Initializes a new instance of the SaveOptionsIconData class.

Public Properties

Public Property MultiPage Gets and sets an indicator if the image is being saved to a multi-page file.

See Also

SaveOptionsIcon Class | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsIcon Constructor

SaveOptionsIcon Class | SaveOptionsIcon Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsIcon Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsIcon Class : SaveOptionsIcon Constructor (SaveOptionsIcon)

Initializes a new instance of the SaveOptionsIconData class.

[Visual Basic]
Public Function New()
[C#]
public SaveOptionsIcon();
[C++]
public: SaveOptionsIcon();
[C++/CLI]
public:
SaveOptionsIcon();

See Also

SaveOptionsIcon Class | SaveOptionsIcon Members


SaveOptionsIcon Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsIcon Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsIcon Class

For a list of all members of this type, see SaveOptionsIcon members.

Public Properties

Public Property MultiPage Gets and sets an indicator if the image is being saved to a multi-page file.

See Also

SaveOptionsIcon Class | PegasusImaging.WinForms.ImagXpress9 Namespace


MultiPage Property

SaveOptionsIcon Class | SaveOptionsIcon Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

MultiPage Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsIcon Class : MultiPage Property (SaveOptionsIcon)

Gets and sets an indicator if the image is being saved to a multi-page file.

[Visual Basic]
Public Property MultiPage As Boolean
[C#]
public bool MultiPage {get; set;}
[C++]
public: __property bool get_MultiPage();
public: __property void set_MultiPage(
   bool value
);
[C++/CLI]
public:
property bool MultiPage {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to save the image to a multi-page file.

See Also

SaveOptionsIcon Class | SaveOptionsIcon Members


SaveOptionsJbig2 Class

SaveOptionsJbig2 Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsJbig2 Class

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsJbig2 Class

This class implements SaveOptions for the Jbig2 file format.

For a list of all members of this type, see SaveOptionsJbig2 members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.SaveOptionsJbig2

Syntax

[Visual Basic]
Public Class SaveOptionsJbig2
[C#]
public class SaveOptionsJbig2
[C++]
public __gc class SaveOptionsJbig2
[C++/CLI]
public ref class SaveOptionsJbig2

See Also

SaveOptionsJbig2 Members | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsJbig2 Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsJbig2 Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsJbig2 Class

SaveOptionsJbig2 overview

Public Constructors

Public Constructor SaveOptionsJbig2 Constructor The main constructor which intializes a new instance of the SaveOptionsJbig2 class.

Public Properties

Public Property EncodeModeCompression | Gets and sets the encoding mode to use when creating the JBIG2 file.
Public Property FileOrganization | Gets and sets the file organization of the JBIG2 bitstream.
Public Property InvertedRegion | Gets and sets whether the bits should be inverted prior to symbol analysis.
Public Property LoosenessCompression | Gets and sets how loose to be when matching symbols and compressing text using either of the lossy text region encode modes.

See Also

SaveOptionsJbig2 Class | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsJbig2 Constructor

SaveOptionsJbig2 Class | SaveOptionsJbig2 Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsJbig2 Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsJbig2 Class : SaveOptionsJbig2 Constructor (SaveOptionsJbig2)

The main constructor which intializes a new instance of the SaveOptionsJbig2 class.

[Visual Basic]
Public Function New()
[C#]
public SaveOptionsJbig2();
[C++]
public: SaveOptionsJbig2();
[C++/CLI]
public:
SaveOptionsJbig2();

See Also

SaveOptionsJbig2 Class | SaveOptionsJbig2 Members


SaveOptionsJbig2 Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsJbig2 Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsJbig2 Class

For a list of all members of this type, see SaveOptionsJbig2 members.

Public Properties

Public Property EncodeModeCompression | Gets and sets the encoding mode to use when creating the JBIG2 file.
Public Property FileOrganization | Gets and sets the file organization of the JBIG2 bitstream.
Public Property InvertedRegion | Gets and sets whether the bits should be inverted prior to symbol analysis.
Public Property LoosenessCompression | Gets and sets how loose to be when matching symbols and compressing text using either of the lossy text region encode modes.

See Also

SaveOptionsJbig2 Class | PegasusImaging.WinForms.ImagXpress9 Namespace


EncodeModeCompression Property

SaveOptionsJbig2 Class | SaveOptionsJbig2 Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

EncodeModeCompression Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsJbig2 Class : EncodeModeCompression Property

Gets and sets the encoding mode to use when creating the JBIG2 file.

[Visual Basic]
Public Property EncodeModeCompression As Jbig2EncodeModeCompression
[C#]
public Jbig2EncodeModeCompression EncodeModeCompression {get; set;}
[C++]
public: __property Jbig2EncodeModeCompression get_EncodeModeCompression();
public: __property void set_EncodeModeCompression(
   Jbig2EncodeModeCompression value
);
[C++/CLI]
public:
property Jbig2EncodeModeCompression EncodeModeCompression {
   Jbig2EncodeModeCompression get();
   void set (Jbig2EncodeModeCompression value);
}

Return Type

A Jbig2EncodeModeCompression enumeration value.

Remarks

Text regions can be encoded as lossless or as lossy according to the encoding mode specified. The lossy modes use the value in LoosenessCompression to control how loose to be when matching symbols and thereby increase compression and reduce file size. Compression means loss, however, and a consequence of higher compression is an increased risk of errors in the reconstructed image. Specify a larger value of looseness to reduce the compressed file size; use a smaller value to reduce the errors, if any.

Halftone regions can be encoded lossy by specifying one of the lossy halftone encoding modes. Alternatively, they can be encoded lossless by using the lossless generic encoding mode.

See Also

SaveOptionsJbig2 Class | SaveOptionsJbig2 Members


FileOrganization Property

SaveOptionsJbig2 Class | SaveOptionsJbig2 Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

FileOrganization Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsJbig2 Class : FileOrganization Property

Gets and sets the file organization of the JBIG2 bitstream.

[Visual Basic]
Public Property FileOrganization As Jbig2FileOrganization
[C#]
public Jbig2FileOrganization FileOrganization {get; set;}
[C++]
public: __property Jbig2FileOrganization get_FileOrganization();
public: __property void set_FileOrganization(
   Jbig2FileOrganization value
);
[C++/CLI]
public:
property Jbig2FileOrganization FileOrganization {
   Jbig2FileOrganization get();
   void set (Jbig2FileOrganization value);
}

Return Type

A Jbig2FileOrganization enumeration value.

Remarks

A JBIG2 file may be organized in two ways: for sequential access or for random access. Sequential organization is intended for streaming applications, where the decoder reads and decodes the file in order as the data is received.

Random access organization permits the decoder to know the entire file structure without having to read the entire file and then use that information to access the required data in a random-access fashion; this would be useful for applications such as decoding only odd-number pages, for example.

See Also

SaveOptionsJbig2 Class | SaveOptionsJbig2 Members


InvertedRegion Property

SaveOptionsJbig2 Class | SaveOptionsJbig2 Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

InvertedRegion Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsJbig2 Class : InvertedRegion Property

Gets and sets whether the bits should be inverted prior to symbol analysis.

[Visual Basic]
Public Property InvertedRegion As Boolean
[C#]
public bool InvertedRegion {get; set;}
[C++]
public: __property bool get_InvertedRegion();
public: __property void set_InvertedRegion(
   bool value
);
[C++/CLI]
public:
property bool InvertedRegion {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to invert the bits prior to symbol analysis.

Remarks

Inverting the bits prior to symbol analysis may provide better compression if the text is represented as light bits against a dark background instead of the opposite. This setting is only used by the text encode modes.

See Also

SaveOptionsJbig2 Class | SaveOptionsJbig2 Members


LoosenessCompression Property

SaveOptionsJbig2 Class | SaveOptionsJbig2 Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoosenessCompression Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsJbig2 Class : LoosenessCompression Property

Gets and sets how loose to be when matching symbols and compressing text using either of the lossy text region encode modes.

[Visual Basic]
Public Property LoosenessCompression As Integer
[C#]
public int LoosenessCompression {get; set;}
[C++]
public: __property int get_LoosenessCompression();
public: __property void set_LoosenessCompression(
   int value
);
[C++/CLI]
public:
property int LoosenessCompression {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the looseness of matching sybmols and compressing text.

Remarks

The default results in the lossless compression.

This property provides the ability to set how loose to be when matching symbols and compressing text using either of the lossy text region encoding modes. The larger the number, the greater the compression and the greater the risk of introducing errors.

Set to 50 for a reasonably small file size and low risk of error.

If set to 0, the compression will be lossless.

See Also

SaveOptionsJbig2 Class | SaveOptionsJbig2 Members


SaveOptionsJls Class

SaveOptionsJls Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsJls Class

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsJls Class

This class implements SaveOptions for the JLS file format.

For a list of all members of this type, see SaveOptionsJls members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.SaveOptionsJls

Syntax

[Visual Basic]
Public Class SaveOptionsJls
[C#]
public class SaveOptionsJls
[C++]
public __gc class SaveOptionsJls
[C++/CLI]
public ref class SaveOptionsJls

See Also

SaveOptionsJls Members | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsJls Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsJls Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsJls Class

SaveOptionsJls overview

Public Constructors

Public Constructor SaveOptionsJls Constructor The main constructor which initializes a new instance of the SaveOptionsJls class.

Public Properties

Public Property Interleave | Gets and sets the interleave mode for multi-component images.
Public Property MaxValue | Gets and sets the maximum value of the Near argument.
Public Property Near | Gets and sets the error tolerance for near-lossless compression.
Public Property Point | Gets and sets the precision of the point transform.

See Also

SaveOptionsJls Class | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsJls Constructor

SaveOptionsJls Class | SaveOptionsJls Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsJls Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsJls Class : SaveOptionsJls Constructor (SaveOptionsJls)

The main constructor which initializes a new instance of the SaveOptionsJls class.

[Visual Basic]
Public Function New()
[C#]
public SaveOptionsJls();
[C++]
public: SaveOptionsJls();
[C++/CLI]
public:
SaveOptionsJls();

See Also

SaveOptionsJls Class | SaveOptionsJls Members


SaveOptionsJls Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsJls Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsJls Class

For a list of all members of this type, see SaveOptionsJls members.

Public Properties

Public Property Interleave | Gets and sets the interleave mode for multi-component images.
Public Property MaxValue | Gets and sets the maximum value of the Near argument.
Public Property Near | Gets and sets the error tolerance for near-lossless compression.
Public Property Point | Gets and sets the precision of the point transform.

See Also

SaveOptionsJls Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Interleave Property

SaveOptionsJls Class | SaveOptionsJls Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Interleave Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsJls Class : Interleave Property

Gets and sets the interleave mode for multi-component images.

[Visual Basic]
Public Property Interleave As Integer
[C#]
public int Interleave {get; set;}
[C++]
public: __property int get_Interleave();
public: __property void set_Interleave(
   int value
);
[C++/CLI]
public:
property int Interleave {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the mode for images.

Remarks

    Typical settings for an RGB image for Interleave are 0 or 1.

    When Interleave = 2 it is a specialized and intended for synthetic graphics or computer-generated compound documents (i.el, images likely to contain large flat areas that are common to all the components).

    When compression is lossless (the Near parameter is zero), all three modes decompress to the same image.

    When compression is near-lossless (the Near property is nonzero), all three modes meet the error tolerance for all reconstructed samples but will not decompress to identical binary images.

    See Also

    SaveOptionsJls Class | SaveOptionsJls Members


MaxValue Property

SaveOptionsJls Class | SaveOptionsJls Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

MaxValue Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsJls Class : MaxValue Property

Gets and sets the maximum value of the Near argument.

[Visual Basic]
Public Property MaxValue As Integer
[C#]
public int MaxValue {get; set;}
[C++]
public: __property int get_MaxValue();
public: __property void set_MaxValue(
   int value
);
[C++/CLI]
public:
property int MaxValue {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the maximum value.

Remarks

Note: This property affects the maximum value of the Near argument.

The default value is 0 which sets the compression to (2 ^Bits-Per-Channel) -1.

Valid values are 0 to (2 ^ Bits-Per-Channel) -1.

A 24-bit RGB image is 8 bits for each channel (Red, Green, and Blue each being separate channels). Images with less than 24-bit per pixel are converted to 24-bit if they are color, 4 or 8 bit grayscale otherwise.

See Also

SaveOptionsJls Class | SaveOptionsJls Members


Near Property

SaveOptionsJls Class | SaveOptionsJls Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Near Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsJls Class : Near Property

Gets and sets the error tolerance for near-lossless compression.

[Visual Basic]
Public Property Near As Integer
[C#]
public int Near {get; set;}
[C++]
public: __property int get_Near();
public: __property void set_Near(
   int value
);
[C++/CLI]
public:
property int Near {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the error tolerance.

Remarks

The Near parameter defines the error tolerance for near-lossless compression.

    Valid values is zero (lossless), one (near lossless) to 255 (very lossy).

    Generally, Near should be set to zero or a small positive number, perhaps 4 or 5 with higher numbers leading to ugly streaking artifacts.

    Note: The value of MaxValue affects the maximum value of Near which is either 255 or MaxValue/2 (rounded up) whichever is lower.

    See Also

    SaveOptionsJls Class | SaveOptionsJls Members


Point Property

SaveOptionsJls Class | SaveOptionsJls Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Point Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsJls Class : Point Property

Gets and sets the precision of the point transform.

[Visual Basic]
Public Property Point As Integer
[C#]
public int Point {get; set;}
[C++]
public: __property int get_Point();
public: __property void set_Point(
   int value
);
[C++/CLI]
public:
property int Point {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the precision of the point transform.

Remarks

The point transform is the number of least significant bits truncated from each input sample prior to compression. A point transform is another way to use the JPEG-LS algorithm in a near-lossless mode. Non-zero values denote near-lossless compression; the source image no longer is reconstructed exactly from the compressed image. The allowed range for Point is zero (default value) or 2 to 16. The JPEG-LS standard allows input samples to range from 2 to 16 bits (called the Precision), hence the allowed range for Point.

Precision is the number of bits used for each sample in an image. For example, a 24-bit image uses 8 bits for each red, green and blue sample in each pixel. Point should be no greater than the actual Precision of the input samples. This affects the bits per channel of an image. So if you had a 24-bit RGB image, it has 8-bits per R, G, and B channel. For example, if Point = 2, then the image is effectively 6-bits per channel (8 - 2 = 6). This affects the calculations for MaxValue and therefore the maximum value for Near.

See Also

SaveOptionsJls Class | SaveOptionsJls Members


SaveOptionsJp2 Class

SaveOptionsJp2 Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsJp2 Class

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsJp2 Class

This class implements SaveOptions for the JP2 file format.

For a list of all members of this type, see SaveOptionsJp2 members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.SaveOptionsJp2

Syntax

[Visual Basic]
Public Class SaveOptionsJp2
[C#]
public class SaveOptionsJp2
[C++]
public __gc class SaveOptionsJp2
[C++/CLI]
public ref class SaveOptionsJp2

See Also

SaveOptionsJp2 Members | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsJp2 Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsJp2 Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsJp2 Class

SaveOptionsJp2 overview

Public Constructors

Public Constructor SaveOptionsJp2 Constructor The main constructor which initializes a new SaveOptionsJp2 instance.

Public Properties

Public Property CompressSize | Gets and sets the desired file size in bytes.
Public Property Grayscale | Gets and sets if the image is saved as grayscale or color.
Public Property Order | Gets and sets the progression order.
Public Property PeakSignalToNoiseRatio | Gets and sets the peak signal to noise ratio.
Public Property TileSize | Gets and sets the tile size.
Public Property Type | Gets and sets the format of the file.

See Also

SaveOptionsJp2 Class | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsJp2 Constructor

SaveOptionsJp2 Class | SaveOptionsJp2 Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsJp2 Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsJp2 Class : SaveOptionsJp2 Constructor (SaveOptionsJp2)

The main constructor which initializes a new SaveOptionsJp2 instance.

[Visual Basic]
Public Function New()
[C#]
public SaveOptionsJp2();
[C++]
public: SaveOptionsJp2();
[C++/CLI]
public:
SaveOptionsJp2();

See Also

SaveOptionsJp2 Class | SaveOptionsJp2 Members


SaveOptionsJp2 Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsJp2 Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsJp2 Class

For a list of all members of this type, see SaveOptionsJp2 members.

Public Properties

Public Property CompressSize | Gets and sets the desired file size in bytes.
Public Property Grayscale | Gets and sets if the image is saved as grayscale or color.
Public Property Order | Gets and sets the progression order.
Public Property PeakSignalToNoiseRatio | Gets and sets the peak signal to noise ratio.
Public Property TileSize | Gets and sets the tile size.
Public Property Type | Gets and sets the format of the file.

See Also

SaveOptionsJp2 Class | PegasusImaging.WinForms.ImagXpress9 Namespace


CompressSize Property

SaveOptionsJp2 Class | SaveOptionsJp2 Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CompressSize Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsJp2 Class : CompressSize Property

Gets and sets the desired file size in bytes.

[Visual Basic]
Public Property CompressSize As Integer
[C#]
public int CompressSize {get; set;}
[C++]
public: __property int get_CompressSize();
public: __property void set_CompressSize(
   int value
);
[C++/CLI]
public:
property int CompressSize {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the desired file size in bytes.

Remarks

This property is only a request for a specific size when the Type = Lossy (0).

See Also

SaveOptionsJp2 Class | SaveOptionsJp2 Members


Grayscale Property

SaveOptionsJp2 Class | SaveOptionsJp2 Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Grayscale Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsJp2 Class : Grayscale Property (SaveOptionsJp2)

Gets and sets if the image is saved as grayscale or color.

[Visual Basic]
Public Property Grayscale As Boolean
[C#]
public bool Grayscale {get; set;}
[C++]
public: __property bool get_Grayscale();
public: __property void set_Grayscale(
   bool value
);
[C++/CLI]
public:
property bool Grayscale {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to save the image as grayscale. Otherwise, false should be used.

See Also

SaveOptionsJp2 Class | SaveOptionsJp2 Members


Order Property

SaveOptionsJp2 Class | SaveOptionsJp2 Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Order Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsJp2 Class : Order Property (SaveOptionsJp2)

Gets and sets the progression order.

[Visual Basic]
Public Property Order As ProgressionOrder
[C#]
public ProgressionOrder Order {get; set;}
[C++]
public: __property ProgressionOrder get_Order();
public: __property void set_Order(
   ProgressionOrder value
);
[C++/CLI]
public:
property ProgressionOrder Order {
   ProgressionOrder get();
   void set (ProgressionOrder value);
}

Return Type

A ProgressionOrder enumeration value.

Remarks

The progression order of the saved JPEG 2000 file is the order of the compressed image data for the layer, the component, the resolution and the position.

See Also

SaveOptionsJp2 Class | SaveOptionsJp2 Members


PeakSignalToNoiseRatio Property

SaveOptionsJp2 Class | SaveOptionsJp2 Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PeakSignalToNoiseRatio Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsJp2 Class : PeakSignalToNoiseRatio Property

Gets and sets the peak signal to noise ratio.

[Visual Basic]
Public Property PeakSignalToNoiseRatio As Double
[C#]
public double PeakSignalToNoiseRatio {get; set;}
[C++]
public: __property double get_PeakSignalToNoiseRatio();
public: __property void set_PeakSignalToNoiseRatio(
   double value
);
[C++/CLI]
public:
property double PeakSignalToNoiseRatio {
   double get();
   void set (double value);
}

Return Type

A double value which represents the peak signal to noise ratio.

See Also

SaveOptionsJp2 Class | SaveOptionsJp2 Members


TileSize Property

SaveOptionsJp2 Class | SaveOptionsJp2 Members | Size

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

TileSize Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsJp2 Class : TileSize Property

Gets and sets the tile size.

[Visual Basic]
Public Property TileSize As Size
[C#]
public Size TileSize {get; set;}
[C++]
public: __property Size get_TileSize();
public: __property void set_TileSize(
   Size value
);
[C++/CLI]
public:
property Size TileSize {
   Size get();
   void set (Size value);
}

Return Type

A Size value which represents the tile size.

Remarks

The default value is zero.

The recommended non-zero setting is 64, with the width and height arguments of the Size property usually being equal.

See Also

SaveOptionsJp2 Class | SaveOptionsJp2 Members | Size


Type Property

SaveOptionsJp2 Class | SaveOptionsJp2 Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Type Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsJp2 Class : Type Property (SaveOptionsJp2)

Gets and sets the format of the file.

[Visual Basic]
Public Property Type As Jp2Type
[C#]
public Jp2Type Type {get; set;}
[C++]
public: __property Jp2Type get_Type();
public: __property void set_Type(
   Jp2Type value
);
[C++/CLI]
public:
property Jp2Type Type {
   Jp2Type get();
   void set (Jp2Type value);
}

Return Type

A Jp2Type enumeration value.

See Also

SaveOptionsJp2 Class | SaveOptionsJp2 Members


SaveOptionsJpeg Class

SaveOptionsJpeg Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsJpeg Class

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsJpeg Class

This class implements SaveOptions for the JPEG file format.

For a list of all members of this type, see SaveOptionsJpeg members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.SaveOptionsJpeg

Syntax

[Visual Basic]
Public Class SaveOptionsJpeg
[C#]
public class SaveOptionsJpeg
[C++]
public __gc class SaveOptionsJpeg
[C++/CLI]
public ref class SaveOptionsJpeg

See Also

SaveOptionsJpeg Members | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsJpeg Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsJpeg Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsJpeg Class

SaveOptionsJpeg overview

Public Constructors

Public Constructor SaveOptionsJpeg Constructor The main constructor which initializes a new instance of the SaveOptionsJpeg class.

Public Properties

Public Property Chrominance | Gets and sets the chrominance quality setting for saving JPEG, TIFF-JPEG, and ePIC files.
Public Property ColorSpace | Gets and sets the color space of the image being saved.
Public Property Cosited | Gets and sets if the image should be compressed with cosited subsampling when saving.
Public Property Grayscale | Gets and sets if the image is saved as a gray scale file.
Public Property Luminance | Gets and sets the luminance quality.
Public Property Progressive | Gets and sets if an image file is saved in standard or progressive format.
Public Property SubSampling | Gets and sets the sub-sampling type.

See Also

SaveOptionsJpeg Class | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsJpeg Constructor

SaveOptionsJpeg Class | SaveOptionsJpeg Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsJpeg Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsJpeg Class : SaveOptionsJpeg Constructor (SaveOptionsJpeg)

The main constructor which initializes a new instance of the SaveOptionsJpeg class.

[Visual Basic]
Public Function New()
[C#]
public SaveOptionsJpeg();
[C++]
public: SaveOptionsJpeg();
[C++/CLI]
public:
SaveOptionsJpeg();

See Also

SaveOptionsJpeg Class | SaveOptionsJpeg Members


SaveOptionsJpeg Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsJpeg Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsJpeg Class

For a list of all members of this type, see SaveOptionsJpeg members.

Public Properties

Public Property Chrominance | Gets and sets the chrominance quality setting for saving JPEG, TIFF-JPEG, and ePIC files.
Public Property ColorSpace | Gets and sets the color space of the image being saved.
Public Property Cosited | Gets and sets if the image should be compressed with cosited subsampling when saving.
Public Property Grayscale | Gets and sets if the image is saved as a gray scale file.
Public Property Luminance | Gets and sets the luminance quality.
Public Property Progressive | Gets and sets if an image file is saved in standard or progressive format.
Public Property SubSampling | Gets and sets the sub-sampling type.

See Also

SaveOptionsJpeg Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Chrominance Property

SaveOptionsJpeg Class | SaveOptionsJpeg Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Chrominance Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsJpeg Class : Chrominance Property

Gets and sets the chrominance quality setting for saving JPEG, TIFF-JPEG, and ePIC files.

[Visual Basic]
Public Property Chrominance As Integer
[C#]
public int Chrominance {get; set;}
[C++]
public: __property int get_Chrominance();
public: __property void set_Chrominance(
   int value
);
[C++/CLI]
public:
property int Chrominance {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the chrominance quality setting.

Remarks

The default value is 10.

Valid Chrominance values range from 0 to 255.

A value of zero meaning no compression (maximum color quality) 255 means maximum image color compression (minimal image color quality.

JPEG and ePIC images are stored in a compressed format. Compression is lossy which means when saving JPEG or ePIC files, there is always data loss. Data loss is the result of JPEG and ePICs ability to achieve high compression ratios. Higher quality settings result in less compresion, while lower quality settings result in higher compression. Quality versus compression is a tradeoff. The image compression ratio can be adjusted by setting the Luminance and Chrominance properties.

The Lunimance property adjusts the luninance or grayscale quality and the Chrominance property adjusts the chrominance or color quality. Lower settings for these properties result in higher quality images with less compression. Higher settings for these properties result in lower quality images wit more compression.

For general use photographic type images, setting Luminance = 24 and Chrominance = 30 provides about a 12:1 image compression ratio with minimal data loss. Compression ratios and perceived image quality will vary depending on the image.

Note: Chrominance should always have a value equal or higher than Luminance.

See Also

SaveOptionsJpeg Class | SaveOptionsJpeg Members


ColorSpace Property

SaveOptionsJpeg Class | SaveOptionsJpeg Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ColorSpace Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsJpeg Class : ColorSpace Property (SaveOptionsJpeg)

Gets and sets the color space of the image being saved.

[Visual Basic]
Public Property ColorSpace As ColorSpace
[C#]
public ColorSpace ColorSpace {get; set;}
[C++]
public: __property ColorSpace get_ColorSpace();
public: __property void set_ColorSpace(
   ColorSpace value
);
[C++/CLI]
public:
property ColorSpace ColorSpace {
   ColorSpace get();
   void set (ColorSpace value);
}

Return Type

A ColorSpace enumeration value.

See Also

SaveOptionsJpeg Class | SaveOptionsJpeg Members


Cosited Property

SaveOptionsJpeg Class | SaveOptionsJpeg Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Cosited Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsJpeg Class : Cosited Property (SaveOptionsJpeg)

Gets and sets if the image should be compressed with cosited subsampling when saving.

[Visual Basic]
Public Property Cosited As Boolean
[C#]
public bool Cosited {get; set;}
[C++]
public: __property bool get_Cosited();
public: __property void set_Cosited(
   bool value
);
[C++/CLI]
public:
property bool Cosited {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true if the image should be compressed with cosited subsampling when saving. Otherwise, false should be set.

Remarks

The default value is false.

See Also

SaveOptionsJpeg Class | SaveOptionsJpeg Members


Grayscale Property

SaveOptionsJpeg Class | SaveOptionsJpeg Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Grayscale Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsJpeg Class : Grayscale Property (SaveOptionsJpeg)

Gets and sets if the image is saved as a gray scale file.

[Visual Basic]
Public Property Grayscale As Boolean
[C#]
public bool Grayscale {get; set;}
[C++]
public: __property bool get_Grayscale();
public: __property void set_Grayscale(
   bool value
);
[C++/CLI]
public:
property bool Grayscale {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to save the image as a gray scale file. Otherwise, false is used.

See Also

SaveOptionsJpeg Class | SaveOptionsJpeg Members


Luminance Property

SaveOptionsJpeg Class | SaveOptionsJpeg Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Luminance Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsJpeg Class : Luminance Property

Gets and sets the luminance quality.

[Visual Basic]
Public Property Luminance As Integer
[C#]
public int Luminance {get; set;}
[C++]
public: __property int get_Luminance();
public: __property void set_Luminance(
   int value
);
[C++/CLI]
public:
property int Luminance {
   int get();
   void set (int value);
}

Return Type

An integer value that represents the luminance quality.

Remarks

Valid values range from 0 to 255.

JPEG and ePIC images are stored in a compresed format. Compression is lossy which means when saving JPEG or ePIC files, there will be data loss. Data loss is the results of JPEG and ePICs ability to achieve high compression ratios. Higher quality settings result in less compression, while lower quality settings result in higher compression. Quality versus compression is a tradeoff. The image compression ratio can be adjused by setting the Luminance and Chrominance properties.

The Luminance property adjusts the luminance or gray scale quality and the Chrominance property adjusts the chrominance or color quality. Lower settings for these properties result in higher quality images with less compression. Higher settins for these properties result in lower quality images with more compression.

For general use photographic type images, the settings of Luminance = 24 and Chrominance = 30 provides about a 12:1 image copression ratio with minimal data loss. Compression ratios and perceived image quality varies depending on the image.

Note: As a rule, Chrominance should always have a value equal or higher than Luminance.

See Also

SaveOptionsJpeg Class | SaveOptionsJpeg Members


Progressive Property

SaveOptionsJpeg Class | SaveOptionsJpeg Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Progressive Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsJpeg Class : Progressive Property (SaveOptionsJpeg)

Gets and sets if an image file is saved in standard or progressive format.

[Visual Basic]
Public Property Progressive As Boolean
[C#]
public bool Progressive {get; set;}
[C++]
public: __property bool get_Progressive();
public: __property void set_Progressive(
   bool value
);
[C++/CLI]
public:
property bool Progressive {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to save in progressive format. Otherwise, false should be used.

See Also

SaveOptionsJpeg Class | SaveOptionsJpeg Members


SubSampling Property

SaveOptionsJpeg Class | SaveOptionsJpeg Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SubSampling Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsJpeg Class : SubSampling Property (SaveOptionsJpeg)

Gets and sets the sub-sampling type.

[Visual Basic]
Public Property SubSampling As SubSampling
[C#]
public SubSampling SubSampling {get; set;}
[C++]
public: __property SubSampling get_SubSampling();
public: __property void set_SubSampling(
   SubSampling value
);
[C++/CLI]
public:
property SubSampling SubSampling {
   SubSampling get();
   void set (SubSampling value);
}

Return Type

A SubSampling enumeration value.

Remarks

This applies to JPEG, TIFF-JPEG, and ePIC files. This property is used in conjunction with the Chrominance and Luminance properties to control the compression ratio and the compressed image quality.

For higher quality and lower compression, set Luminance and Chrominance in the low teens and set SubSampling to 1:1:1 compression.

For higher compression and lower quality, set Luminance and Chrominance in the low 20's and set SubSampling to 4:1:1 compression.

See Also

SaveOptionsJpeg Class | SaveOptionsJpeg Members


SaveOptionsLjp Class

SaveOptionsLjp Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsLjp Class

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsLjp Class

This class implements the SaveOptions for the LJP file format.

For a list of all members of this type, see SaveOptionsLjp members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.SaveOptionsLjp

Syntax

[Visual Basic]
Public Class SaveOptionsLjp
[C#]
public class SaveOptionsLjp
[C++]
public __gc class SaveOptionsLjp
[C++/CLI]
public ref class SaveOptionsLjp

See Also

SaveOptionsLjp Members | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsLjp Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsLjp Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsLjp Class

SaveOptionsLjp overview

Public Constructors

Public Constructor SaveOptionsLjp Constructor The main constructor for initializing a new instance of the SaveOptionsLjp class.

Public Properties

Public Property Method |
Public Property Order |
Public Property Predictor |
Public Property Type | Gets and sets the type of compression for lossless JPEG.

See Also

SaveOptionsLjp Class | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsLjp Constructor

SaveOptionsLjp Class | SaveOptionsLjp Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsLjp Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsLjp Class : SaveOptionsLjp Constructor (SaveOptionsLjp)

The main constructor for initializing a new instance of the SaveOptionsLjp class.

[Visual Basic]
Public Function New()
[C#]
public SaveOptionsLjp();
[C++]
public: SaveOptionsLjp();
[C++/CLI]
public:
SaveOptionsLjp();

See Also

SaveOptionsLjp Class | SaveOptionsLjp Members


SaveOptionsLjp Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsLjp Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsLjp Class

For a list of all members of this type, see SaveOptionsLjp members.

Public Properties

Public Property Method |
Public Property Order |
Public Property Predictor |
Public Property Type | Gets and sets the type of compression for lossless JPEG.

See Also

SaveOptionsLjp Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Method Property

SaveOptionsLjp Class | SaveOptionsLjp Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Method Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsLjp Class : Method Property
[Visual Basic]
Public Property Method As LjpMethod
[C#]
public LjpMethod Method {get; set;}
[C++]
public: __property LjpMethod get_Method();
public: __property void set_Method(
   LjpMethod value
);
[C++/CLI]
public:
property LjpMethod Method {
   LjpMethod get();
   void set (LjpMethod value);
}

See Also

SaveOptionsLjp Class | SaveOptionsLjp Members


Order Property

SaveOptionsLjp Class | SaveOptionsLjp Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Order Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsLjp Class : Order Property (SaveOptionsLjp)
[Visual Basic]
Public Property Order As Integer
[C#]
public int Order {get; set;}
[C++]
public: __property int get_Order();
public: __property void set_Order(
   int value
);
[C++/CLI]
public:
property int Order {
   int get();
   void set (int value);
}

See Also

SaveOptionsLjp Class | SaveOptionsLjp Members


Predictor Property

SaveOptionsLjp Class | SaveOptionsLjp Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Predictor Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsLjp Class : Predictor Property
[Visual Basic]
Public Property Predictor As Integer
[C#]
public int Predictor {get; set;}
[C++]
public: __property int get_Predictor();
public: __property void set_Predictor(
   int value
);
[C++/CLI]
public:
property int Predictor {
   int get();
   void set (int value);
}

See Also

SaveOptionsLjp Class | SaveOptionsLjp Members


Type Property

SaveOptionsLjp Class | SaveOptionsLjp Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Type Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsLjp Class : Type Property (SaveOptionsLjp)

Gets and sets the type of compression for lossless JPEG.

[Visual Basic]
Public Property Type As LjpType
[C#]
public LjpType Type {get; set;}
[C++]
public: __property LjpType get_Type();
public: __property void set_Type(
   LjpType value
);
[C++/CLI]
public:
property LjpType Type {
   LjpType get();
   void set (LjpType value);
}

Return Type

A LjpType enumeration value.

See Also

SaveOptionsLjp Class | SaveOptionsLjp Members


SaveOptionsPdf Class

SaveOptionsPdf Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsPdf Class

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsPdf Class

This class implements the SaveOptions for PDF files.

For a list of all members of this type, see SaveOptionsPdf members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.SaveOptionsPdf

Syntax

[Visual Basic]
Public Class SaveOptionsPdf
[C#]
public class SaveOptionsPdf
[C++]
public __gc class SaveOptionsPdf
[C++/CLI]
public ref class SaveOptionsPdf

See Also

SaveOptionsPdf Members | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsPdf Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsPdf Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsPdf Class

SaveOptionsPdf overview

Public Constructors

Public Constructor SaveOptionsPdf Constructor The main constructor which initializes a new instance of the SaveOptionsPdf class.

Public Properties

Public Property ColorSpace | Gets and sets the color space of the PDF image being saved.
Public Property Compression | Gets and sets the compression type employed for saving a PDF file.
Public Property MultiPage | Gets and sets if the image is saved to a multi-page file.
Public Property SwapBlackAndWhite | Gets and sets a pixel value of zero to black or white.

See Also

SaveOptionsPdf Class | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsPdf Constructor

SaveOptionsPdf Class | SaveOptionsPdf Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsPdf Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsPdf Class : SaveOptionsPdf Constructor (SaveOptionsPdf)

The main constructor which initializes a new instance of the SaveOptionsPdf class.

[Visual Basic]
Public Function New()
[C#]
public SaveOptionsPdf();
[C++]
public: SaveOptionsPdf();
[C++/CLI]
public:
SaveOptionsPdf();

See Also

SaveOptionsPdf Class | SaveOptionsPdf Members


SaveOptionsPdf Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsPdf Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsPdf Class

For a list of all members of this type, see SaveOptionsPdf members.

Public Properties

Public Property ColorSpace | Gets and sets the color space of the PDF image being saved.
Public Property Compression | Gets and sets the compression type employed for saving a PDF file.
Public Property MultiPage | Gets and sets if the image is saved to a multi-page file.
Public Property SwapBlackAndWhite | Gets and sets a pixel value of zero to black or white.

See Also

SaveOptionsPdf Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ColorSpace Property

SaveOptionsPdf Class | SaveOptionsPdf Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ColorSpace Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsPdf Class : ColorSpace Property (SaveOptionsPdf)

Gets and sets the color space of the PDF image being saved.

[Visual Basic]
Public Property ColorSpace As ColorSpace
[C#]
public ColorSpace ColorSpace {get; set;}
[C++]
public: __property ColorSpace get_ColorSpace();
public: __property void set_ColorSpace(
   ColorSpace value
);
[C++/CLI]
public:
property ColorSpace ColorSpace {
   ColorSpace get();
   void set (ColorSpace value);
}

Return Type

A ColorSpace enumeration value.

See Also

SaveOptionsPdf Class | SaveOptionsPdf Members


Compression Property

SaveOptionsPdf Class | SaveOptionsPdf Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Compression Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsPdf Class : Compression Property (SaveOptionsPdf)

Gets and sets the compression type employed for saving a PDF file.

[Visual Basic]
Public Property Compression As Compression
[C#]
public Compression Compression {get; set;}
[C++]
public: __property Compression get_Compression();
public: __property void set_Compression(
   Compression value
);
[C++/CLI]
public:
property Compression Compression {
   Compression get();
   void set (Compression value);
}

Return Type

A Compression enumeration value.

See Also

SaveOptionsPdf Class | SaveOptionsPdf Members


MultiPage Property

SaveOptionsPdf Class | SaveOptionsPdf Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

MultiPage Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsPdf Class : MultiPage Property (SaveOptionsPdf)

Gets and sets if the image is saved to a multi-page file.

[Visual Basic]
Public Property MultiPage As Boolean
[C#]
public bool MultiPage {get; set;}
[C++]
public: __property bool get_MultiPage();
public: __property void set_MultiPage(
   bool value
);
[C++/CLI]
public:
property bool MultiPage {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true if the image is saved to a multi-page file. Otherwise, false is used.

See Also

SaveOptionsPdf Class | SaveOptionsPdf Members


SwapBlackAndWhite Property

SaveOptionsPdf Class | SaveOptionsPdf Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SwapBlackAndWhite Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsPdf Class : SwapBlackAndWhite Property (SaveOptionsPdf)

Gets and sets a pixel value of zero to black or white.

[Visual Basic]
Public Property SwapBlackAndWhite As Boolean
[C#]
public bool SwapBlackAndWhite {get; set;}
[C++]
public: __property bool get_SwapBlackAndWhite();
public: __property void set_SwapBlackAndWhite(
   bool value
);
[C++/CLI]
public:
property bool SwapBlackAndWhite {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to define black = 1 and white = 0. Otherwise, false determines that white = 1 and black = 0.

Remarks

Note: This property pertains only to G4 Compression types.

See Also

SaveOptionsPdf Class | SaveOptionsPdf Members


SaveOptionsPic Class

SaveOptionsPic Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsPic Class

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsPic Class

This class implements SaveOptions for the PIC (Pegasus Imaging Corporation) file format.

For a list of all members of this type, see SaveOptionsPic members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.SaveOptionsPic

Syntax

[Visual Basic]
Public Class SaveOptionsPic
[C#]
public class SaveOptionsPic
[C++]
public __gc class SaveOptionsPic
[C++/CLI]
public ref class SaveOptionsPic

See Also

SaveOptionsPic Members | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsPic Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsPic Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsPic Class

SaveOptionsPic overview

Public Constructors

Public Constructor SaveOptionsPic Constructor The main constructor which initializes a new instance of the SaveOptionsPic class.

Public Properties

Public Property Password Gets and sets the password for the destination ePIC (.PIC) file format.

See Also

SaveOptionsPic Class | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsPic Constructor

SaveOptionsPic Class | SaveOptionsPic Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsPic Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsPic Class : SaveOptionsPic Constructor (SaveOptionsPic)

The main constructor which initializes a new instance of the SaveOptionsPic class.

[Visual Basic]
Public Function New()
[C#]
public SaveOptionsPic();
[C++]
public: SaveOptionsPic();
[C++/CLI]
public:
SaveOptionsPic();

See Also

SaveOptionsPic Class | SaveOptionsPic Members


SaveOptionsPic Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsPic Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsPic Class

For a list of all members of this type, see SaveOptionsPic members.

Public Properties

Public Property Password Gets and sets the password for the destination ePIC (.PIC) file format.

See Also

SaveOptionsPic Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Password Property

SaveOptionsPic Class | SaveOptionsPic Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Password Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsPic Class : Password Property (SaveOptionsPic)

Gets and sets the password for the destination ePIC (.PIC) file format.

[Visual Basic]
Public Property Password As String
[C#]
public string Password {get; set;}
[C++]
public: __property string* get_Password();
public: __property void set_Password(
   string* value
);
[C++/CLI]
public:
property String^ Password {
   String^ get();
   void set (String^ value);
}

Return Type

A string value which represents the password for the destination PIC file.

See Also

SaveOptionsPic Class | SaveOptionsPic Members


SaveOptionsPng Class

SaveOptionsPng Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsPng Class

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsPng Class

This class implements SaveOptions for the PNG file format.

For a list of all members of this type, see SaveOptionsPng members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.SaveOptionsPng

Syntax

[Visual Basic]
Public Class SaveOptionsPng
[C#]
public class SaveOptionsPng
[C++]
public __gc class SaveOptionsPng
[C++/CLI]
public ref class SaveOptionsPng

See Also

SaveOptionsPng Members | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsPng Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsPng Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsPng Class

SaveOptionsPng overview

Public Constructors

Public Constructor SaveOptionsPng Constructor The main constructor which initializes a new instance of the SaveOptionsPng class.

Public Properties

Public Property Interlaced | Gets and sets if the image is saved in an interlaced or non-interlaced format.
Public Property TransparencyColor | Gets and sets the color to be used to represent transparency in the stored image.
Public Property TransparencyMatch | Gets and sets the type of TransparencyMatch to employ.

See Also

SaveOptionsPng Class | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsPng Constructor

SaveOptionsPng Class | SaveOptionsPng Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsPng Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsPng Class : SaveOptionsPng Constructor (SaveOptionsPng)

The main constructor which initializes a new instance of the SaveOptionsPng class.

[Visual Basic]
Public Function New()
[C#]
public SaveOptionsPng();
[C++]
public: SaveOptionsPng();
[C++/CLI]
public:
SaveOptionsPng();

See Also

SaveOptionsPng Class | SaveOptionsPng Members


SaveOptionsPng Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsPng Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsPng Class

For a list of all members of this type, see SaveOptionsPng members.

Public Properties

Public Property Interlaced | Gets and sets if the image is saved in an interlaced or non-interlaced format.
Public Property TransparencyColor | Gets and sets the color to be used to represent transparency in the stored image.
Public Property TransparencyMatch | Gets and sets the type of TransparencyMatch to employ.

See Also

SaveOptionsPng Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Interlaced Property

SaveOptionsPng Class | SaveOptionsPng Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Interlaced Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsPng Class : Interlaced Property (SaveOptionsPng)

Gets and sets if the image is saved in an interlaced or non-interlaced format.

[Visual Basic]
Public Property Interlaced As Boolean
[C#]
public bool Interlaced {get; set;}
[C++]
public: __property bool get_Interlaced();
public: __property void set_Interlaced(
   bool value
);
[C++/CLI]
public:
property bool Interlaced {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to save the image in an interlaced format. Otherwise, false is used.

See Also

SaveOptionsPng Class | SaveOptionsPng Members


TransparencyColor Property

SaveOptionsPng Class | SaveOptionsPng Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

TransparencyColor Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsPng Class : TransparencyColor Property (SaveOptionsPng)

Gets and sets the color to be used to represent transparency in the stored image.

[Visual Basic]
Public Property TransparencyColor As Color
[C#]
public Color TransparencyColor {get; set;}
[C++]
public: __property Color get_TransparencyColor();
public: __property void set_TransparencyColor(
   Color value
);
[C++/CLI]
public:
property Color TransparencyColor {
   Color get();
   void set (Color value);
}

Return Type

A Color value.

See Also

SaveOptionsPng Class | SaveOptionsPng Members


TransparencyMatch Property

SaveOptionsPng Class | SaveOptionsPng Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

TransparencyMatch Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsPng Class : TransparencyMatch Property (SaveOptionsPng)

Gets and sets the type of TransparencyMatch to employ.

[Visual Basic]
Public Property TransparencyMatch As TransparencyMatch
[C#]
public TransparencyMatch TransparencyMatch {get; set;}
[C++]
public: __property TransparencyMatch get_TransparencyMatch();
public: __property void set_TransparencyMatch(
   TransparencyMatch value
);
[C++/CLI]
public:
property TransparencyMatch TransparencyMatch {
   TransparencyMatch get();
   void set (TransparencyMatch value);
}

Return Type

A TransparencyMatch enumeration value.

Remarks

The TransparencyMatch specifies how to match image pixels to the transparency color. Transparency can be applied on pixels that are an exact match to the TransparencyColor, the closest match to the TransparencyColor, or not at all.

See Also

SaveOptionsPng Class | SaveOptionsPng Members


SaveOptionsPortable Class

SaveOptionsPortable Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsPortable Class

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsPortable Class

This class implements SaveOptions for Portable graphics.

For a list of all members of this type, see SaveOptionsPortable members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.SaveOptionsPortable

Syntax

[Visual Basic]
Public Class SaveOptionsPortable
[C#]
public class SaveOptionsPortable
[C++]
public __gc class SaveOptionsPortable
[C++/CLI]
public ref class SaveOptionsPortable

See Also

SaveOptionsPortable Members | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsPortable Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsPortable Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsPortable Class

SaveOptionsPortable overview

Public Constructors

Public Constructor SaveOptionsPortable Constructor The main constructor which initializes a new instance of the SaveOptionsPortable class.

Public Properties

Public Property Type Gets and sets if the file is stored in binary or ASCII format.

See Also

SaveOptionsPortable Class | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsPortable Constructor

SaveOptionsPortable Class | SaveOptionsPortable Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsPortable Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsPortable Class : SaveOptionsPortable Constructor (SaveOptionsPortable)

The main constructor which initializes a new instance of the SaveOptionsPortable class.

[Visual Basic]
Public Function New()
[C#]
public SaveOptionsPortable();
[C++]
public: SaveOptionsPortable();
[C++/CLI]
public:
SaveOptionsPortable();

See Also

SaveOptionsPortable Class | SaveOptionsPortable Members


SaveOptionsPortable Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsPortable Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsPortable Class

For a list of all members of this type, see SaveOptionsPortable members.

Public Properties

Public Property Type Gets and sets if the file is stored in binary or ASCII format.

See Also

SaveOptionsPortable Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Type Property

SaveOptionsPortable Class | SaveOptionsPortable Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Type Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsPortable Class : Type Property (SaveOptionsPortable)

Gets and sets if the file is stored in binary or ASCII format.

[Visual Basic]
Public Property Type As PortableType
[C#]
public PortableType Type {get; set;}
[C++]
public: __property PortableType get_Type();
public: __property void set_Type(
   PortableType value
);
[C++/CLI]
public:
property PortableType Type {
   PortableType get();
   void set (PortableType value);
}

Return Type

A PortableType enumeration value.

See Also

SaveOptionsPortable Class | SaveOptionsPortable Members


SaveOptionsTiff Class

SaveOptionsTiff Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsTiff Class

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsTiff Class

This class implements the SaveOptions for TIFF formats.

For a list of all members of this type, see SaveOptionsTiff members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.SaveOptionsTiff

Syntax

[Visual Basic]
Public Class SaveOptionsTiff
[C#]
public class SaveOptionsTiff
[C++]
public __gc class SaveOptionsTiff
[C++/CLI]
public ref class SaveOptionsTiff

See Also

SaveOptionsTiff Members | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsTiff Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsTiff Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsTiff Class

SaveOptionsTiff overview

Public Constructors

Public Constructor SaveOptionsTiff Constructor The main constructor which initializes a new instance of the SaveOptionsTiff class.

Public Properties

Public Property ByteOrder | Gets and sets the TIFF byte order to use when saving the image to a TIFF file.
Public Property ColorSpace | Gets and sets the color space of the TIFF image being saved.
Public Property Compression | Gets and sets the compression for the TIFF file being saved.
Public Property IFDOffset | Gets and sets the location to append the next TIFF page when the UseIFDOffset property is set to true.
Public Property MultiPage | Gets and sets if the image is being saved to a multi-page file.
Public Property RowsPerStrip | Gets and sets the number of rows to save in each strip of a TIFF file.
Public Property UseIFDOffset | Gets and sets if TIFF files are set for fast saving of multi-page files.

See Also

SaveOptionsTiff Class | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsTiff Constructor

SaveOptionsTiff Class | SaveOptionsTiff Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsTiff Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsTiff Class : SaveOptionsTiff Constructor (SaveOptionsTiff)

The main constructor which initializes a new instance of the SaveOptionsTiff class.

[Visual Basic]
Public Function New()
[C#]
public SaveOptionsTiff();
[C++]
public: SaveOptionsTiff();
[C++/CLI]
public:
SaveOptionsTiff();

See Also

SaveOptionsTiff Class | SaveOptionsTiff Members


SaveOptionsTiff Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsTiff Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsTiff Class

For a list of all members of this type, see SaveOptionsTiff members.

Public Properties

Public Property ByteOrder | Gets and sets the TIFF byte order to use when saving the image to a TIFF file.
Public Property ColorSpace | Gets and sets the color space of the TIFF image being saved.
Public Property Compression | Gets and sets the compression for the TIFF file being saved.
Public Property IFDOffset | Gets and sets the location to append the next TIFF page when the UseIFDOffset property is set to true.
Public Property MultiPage | Gets and sets if the image is being saved to a multi-page file.
Public Property RowsPerStrip | Gets and sets the number of rows to save in each strip of a TIFF file.
Public Property UseIFDOffset | Gets and sets if TIFF files are set for fast saving of multi-page files.

See Also

SaveOptionsTiff Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ByteOrder Property

SaveOptionsTiff Class | SaveOptionsTiff Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ByteOrder Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsTiff Class : ByteOrder Property (SaveOptionsTiff)

Gets and sets the TIFF byte order to use when saving the image to a TIFF file.

[Visual Basic]
Public Property ByteOrder As ByteOrder
[C#]
public ByteOrder ByteOrder {get; set;}
[C++]
public: __property ByteOrder get_ByteOrder();
public: __property void set_ByteOrder(
   ByteOrder value
);
[C++/CLI]
public:
property ByteOrder ByteOrder {
   ByteOrder get();
   void set (ByteOrder value);
}

Return Type

A ByteOrder enumeration value.

See Also

SaveOptionsTiff Class | SaveOptionsTiff Members


ColorSpace Property

SaveOptionsTiff Class | SaveOptionsTiff Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ColorSpace Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsTiff Class : ColorSpace Property (SaveOptionsTiff)

Gets and sets the color space of the TIFF image being saved.

[Visual Basic]
Public Property ColorSpace As ColorSpace
[C#]
public ColorSpace ColorSpace {get; set;}
[C++]
public: __property ColorSpace get_ColorSpace();
public: __property void set_ColorSpace(
   ColorSpace value
);
[C++/CLI]
public:
property ColorSpace ColorSpace {
   ColorSpace get();
   void set (ColorSpace value);
}

Return Type

A ColorSpace enumeration value.

See Also

SaveOptionsTiff Class | SaveOptionsTiff Members


Compression Property

SaveOptionsTiff Class | SaveOptionsTiff Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Compression Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsTiff Class : Compression Property (SaveOptionsTiff)

Gets and sets the compression for the TIFF file being saved.

[Visual Basic]
Public Property Compression As Compression
[C#]
public Compression Compression {get; set;}
[C++]
public: __property Compression get_Compression();
public: __property void set_Compression(
   Compression value
);
[C++/CLI]
public:
property Compression Compression {
   Compression get();
   void set (Compression value);
}

Return Type

A Compression enumeration value.

See Also

SaveOptionsTiff Class | SaveOptionsTiff Members


IFDOffset Property

SaveOptionsTiff Class | SaveOptionsTiff Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

IFDOffset Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsTiff Class : IFDOffset Property (SaveOptionsTiff)

Gets and sets the location to append the next TIFF page when the UseIFDOffset property is set to true.

[Visual Basic]
Public Property IFDOffset As Integer
[C#]
public int IFDOffset {get; set;}
[C++]
public: __property int get_IFDOffset();
public: __property void set_IFDOffset(
   int value
);
[C++/CLI]
public:
property int IFDOffset {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the TIFF page to append to.

See Also

SaveOptionsTiff Class | SaveOptionsTiff Members


MultiPage Property

SaveOptionsTiff Class | SaveOptionsTiff Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

MultiPage Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsTiff Class : MultiPage Property (SaveOptionsTiff)

Gets and sets if the image is being saved to a multi-page file.

[Visual Basic]
Public Property MultiPage As Boolean
[C#]
public bool MultiPage {get; set;}
[C++]
public: __property bool get_MultiPage();
public: __property void set_MultiPage(
   bool value
);
[C++/CLI]
public:
property bool MultiPage {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to save the TIFF file to a multi-page file. Otherwise, false is used.

See Also

SaveOptionsTiff Class | SaveOptionsTiff Members


RowsPerStrip Property

SaveOptionsTiff Class | SaveOptionsTiff Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RowsPerStrip Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsTiff Class : RowsPerStrip Property

Gets and sets the number of rows to save in each strip of a TIFF file.

[Visual Basic]
Public Property RowsPerStrip As Integer
[C#]
public int RowsPerStrip {get; set;}
[C++]
public: __property int get_RowsPerStrip();
public: __property void set_RowsPerStrip(
   int value
);
[C++/CLI]
public:
property int RowsPerStrip {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the number of rows.

See Also

SaveOptionsTiff Class | SaveOptionsTiff Members


UseIFDOffset Property

SaveOptionsTiff Class | SaveOptionsTiff Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

UseIFDOffset Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsTiff Class : UseIFDOffset Property

Gets and sets if TIFF files are set for fast saving of multi-page files.

[Visual Basic]
Public Property UseIFDOffset As Boolean
[C#]
public bool UseIFDOffset {get; set;}
[C++]
public: __property bool get_UseIFDOffset();
public: __property void set_UseIFDOffset(
   bool value
);
[C++/CLI]
public:
property bool UseIFDOffset {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to use IFDOffset. Otherwise, false is used.

Remarks

Note: IFDOffset must be set explicitly after this property is set.

See Also

SaveOptionsTiff Class | SaveOptionsTiff Members


SaveOptionsWsq Class

SaveOptionsWsq Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsWsq Class

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsWsq Class

Implements the SaveOptions for the WSQ file format.

For a list of all members of this type, see SaveOptionsWsq members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.SaveOptionsWsq

Syntax

[Visual Basic]
Public Class SaveOptionsWsq
[C#]
public class SaveOptionsWsq
[C++]
public __gc class SaveOptionsWsq
[C++/CLI]
public ref class SaveOptionsWsq

See Also

SaveOptionsWsq Members | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsWsq Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsWsq Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsWsq Class

SaveOptionsWsq overview

Public Constructors

Public Constructor SaveOptionsWsq Constructor The main constructor which initializes a new instance of the SaveOptionsWsq class.

Public Properties

Public Property Black | Gets and sets the level of black used in the WSQ file compression.
Public Property Quantization | Gets and sets the quantization of the saved WSQ file.
Public Property White | Gets and sets the level of white used in the WSQ file compression.

See Also

SaveOptionsWsq Class | PegasusImaging.WinForms.ImagXpress9 Namespace


SaveOptionsWsq Constructor

SaveOptionsWsq Class | SaveOptionsWsq Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsWsq Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsWsq Class : SaveOptionsWsq Constructor (SaveOptionsWsq)

The main constructor which initializes a new instance of the SaveOptionsWsq class.

[Visual Basic]
Public Function New()
[C#]
public SaveOptionsWsq();
[C++]
public: SaveOptionsWsq();
[C++/CLI]
public:
SaveOptionsWsq();

See Also

SaveOptionsWsq Class | SaveOptionsWsq Members


SaveOptionsWsq Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SaveOptionsWsq Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : SaveOptionsWsq Class

For a list of all members of this type, see SaveOptionsWsq members.

Public Properties

Public Property Black | Gets and sets the level of black used in the WSQ file compression.
Public Property Quantization | Gets and sets the quantization of the saved WSQ file.
Public Property White | Gets and sets the level of white used in the WSQ file compression.

See Also

SaveOptionsWsq Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Black Property

SaveOptionsWsq Class | SaveOptionsWsq Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Black Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsWsq Class : Black Property

Gets and sets the level of black used in the WSQ file compression.

[Visual Basic]
Public Property Black As Integer
[C#]
public int Black {get; set;}
[C++]
public: __property int get_Black();
public: __property void set_Black(
   int value
);
[C++/CLI]
public:
property int Black {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the level of black used.

Remarks

The default value is 0.

Valid values are 0 to 255..

See Also

SaveOptionsWsq Class | SaveOptionsWsq Members


Quantization Property

SaveOptionsWsq Class | SaveOptionsWsq Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Quantization Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsWsq Class : Quantization Property (SaveOptionsWsq)

Gets and sets the quantization of the saved WSQ file.

[Visual Basic]
Public Property Quantization As Double
[C#]
public double Quantization {get; set;}
[C++]
public: __property double get_Quantization();
public: __property void set_Quantization(
   double value
);
[C++/CLI]
public:
property double Quantization {
   double get();
   void set (double value);
}

Return Type

A double value which represents the quantization of the saved WSQ file.

Remarks

The default value is 0.75.

Valid values are 0.1 to 8.0.

See Also

SaveOptionsWsq Class | SaveOptionsWsq Members


White Property

SaveOptionsWsq Class | SaveOptionsWsq Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

White Property

PegasusImaging.WinForms.ImagXpress9 Namespace > SaveOptionsWsq Class : White Property

Gets and sets the level of white used in the WSQ file compression.

[Visual Basic]
Public Property White As Integer
[C#]
public int White {get; set;}
[C++]
public: __property int get_White();
public: __property void set_White(
   int value
);
[C++/CLI]
public:
property int White {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the level of white used.

Remarks

The default value is 255.

Valid values are 0 to 255..

See Also

SaveOptionsWsq Class | SaveOptionsWsq Members


ScrollbarVisibleChangedEventArgs Class

ScrollbarVisibleChangedEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ScrollbarVisibleChangedEventArgs Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ScrollbarVisibleChangedEventArgs Class

This class implements event data for ScrollbarVisibleChanged events.

For a list of all members of this type, see ScrollbarVisibleChangedEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.ImagXpress9.ScrollbarVisibleChangedEventArgs

Syntax

[Visual Basic]
Public Class ScrollbarVisibleChangedEventArgs
   Inherits EventArgs
[C#]
public class ScrollbarVisibleChangedEventArgs : EventArgs
[C++]
public __gc class ScrollbarVisibleChangedEventArgs : public EventArgs
[C++/CLI]
public ref class ScrollbarVisibleChangedEventArgs : public EventArgs

See Also

ScrollbarVisibleChangedEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ScrollbarVisibleChangedEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ScrollbarVisibleChangedEventArgs Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ScrollbarVisibleChangedEventArgs Class

ScrollbarVisibleChangedEventArgs overview

Public Constructors

Public Constructor ScrollbarVisibleChangedEventArgs Constructor The main constructor which initializes a new instance of the ScrollbarVisibleChangedEventArgs class.

Public Properties

Public Property ScrollBar | Gets which scrollbar the event pertains to.
Public Property Visible | Gets the visibility of the Scrollbar.

See Also

ScrollbarVisibleChangedEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ScrollbarVisibleChangedEventArgs Constructor

ScrollbarVisibleChangedEventArgs Class | ScrollbarVisibleChangedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ScrollbarVisibleChangedEventArgs Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ScrollbarVisibleChangedEventArgs Class : ScrollbarVisibleChangedEventArgs Constructor (ScrollbarVisibleChangedEventArgs)

The main constructor which initializes a new instance of the ScrollbarVisibleChangedEventArgs class.

[Visual Basic]
Public Function New()
[C#]
public ScrollbarVisibleChangedEventArgs();
[C++]
public: ScrollbarVisibleChangedEventArgs();
[C++/CLI]
public:
ScrollbarVisibleChangedEventArgs();

See Also

ScrollbarVisibleChangedEventArgs Class | ScrollbarVisibleChangedEventArgs Members


ScrollbarVisibleChangedEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ScrollbarVisibleChangedEventArgs Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : ScrollbarVisibleChangedEventArgs Class

For a list of all members of this type, see ScrollbarVisibleChangedEventArgs members.

Public Properties

Public Property ScrollBar | Gets which scrollbar the event pertains to.
Public Property Visible | Gets the visibility of the Scrollbar.

See Also

ScrollbarVisibleChangedEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ScrollBar Property

ScrollbarVisibleChangedEventArgs Class | ScrollbarVisibleChangedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ScrollBar Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ScrollbarVisibleChangedEventArgs Class : ScrollBar Property (ScrollbarVisibleChangedEventArgs)

Gets which scrollbar the event pertains to.

[Visual Basic]
Public ReadOnly Property ScrollBar As ScrollBars
[C#]
public ScrollBars ScrollBar {get;}
[C++]
public: __property ScrollBars get_ScrollBar();
[C++/CLI]
public:
property ScrollBars ScrollBar {
   ScrollBars get();
}

Return Type

A ScrollBars enumeration value.

Remarks

Note: Available in all editions.

See Also

ScrollbarVisibleChangedEventArgs Class | ScrollbarVisibleChangedEventArgs Members


Visible Property

ScrollbarVisibleChangedEventArgs Class | ScrollbarVisibleChangedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Visible Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ScrollbarVisibleChangedEventArgs Class : Visible Property (ScrollbarVisibleChangedEventArgs)

Gets the visibility of the Scrollbar.

[Visual Basic]
Public ReadOnly Property Visible As Boolean
[C#]
public bool Visible {get;}
[C++]
public: __property bool get_Visible();
[C++/CLI]
public:
property bool Visible {
   bool get();
}

Return Type

A Boolean value from the .NET Framework Class Library.

Remarks

Note: Available in all editions.

See Also

ScrollbarVisibleChangedEventArgs Class | ScrollbarVisibleChangedEventArgs Members


ScrollEventArgs Class

ScrollEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ScrollEventArgs Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ScrollEventArgs Class

This class implements event data for scroll events.

For a list of all members of this type, see ScrollEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.ImagXpress9.ScrollEventArgs

Syntax

[Visual Basic]
Public Class ScrollEventArgs
   Inherits EventArgs
[C#]
public class ScrollEventArgs : EventArgs
[C++]
public __gc class ScrollEventArgs : public EventArgs
[C++/CLI]
public ref class ScrollEventArgs : public EventArgs

See Also

ScrollEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ScrollEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ScrollEventArgs Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ScrollEventArgs Class

ScrollEventArgs overview

Public Constructors

Public Constructor ScrollEventArgs Constructor The main constructor which initializes a new instance of the ScrollEventArgs class.

Public Properties

Public Property NewValue | Gets the new location within the scroll range.
Public Property ScrollBar | Gets which scrollbar the event pertains to.
Public Property Type | Gets the type of scroll event that occurred.

See Also

ScrollEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ScrollEventArgs Constructor

ScrollEventArgs Class | ScrollEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ScrollEventArgs Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ScrollEventArgs Class : ScrollEventArgs Constructor (ScrollEventArgs)

The main constructor which initializes a new instance of the ScrollEventArgs class.

[Visual Basic]
Public Function New()
[C#]
public ScrollEventArgs();
[C++]
public: ScrollEventArgs();
[C++/CLI]
public:
ScrollEventArgs();

See Also

ScrollEventArgs Class | ScrollEventArgs Members


ScrollEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ScrollEventArgs Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : ScrollEventArgs Class

For a list of all members of this type, see ScrollEventArgs members.

Public Properties

Public Property NewValue | Gets the new location within the scroll range.
Public Property ScrollBar | Gets which scrollbar the event pertains to.
Public Property Type | Gets the type of scroll event that occurred.

See Also

ScrollEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


NewValue Property

ScrollEventArgs Class | ScrollEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

NewValue Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ScrollEventArgs Class : NewValue Property (ScrollEventArgs)

Gets the new location within the scroll range.

[Visual Basic]
Public ReadOnly Property NewValue As Point
[C#]
public Point NewValue {get;}
[C++]
public: __property Point get_NewValue();
[C++/CLI]
public:
property Point NewValue {
   Point get();
}

Return Type

A Point value.

See Also

ScrollEventArgs Class | ScrollEventArgs Members


ScrollBar Property

ScrollEventArgs Class | ScrollEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ScrollBar Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ScrollEventArgs Class : ScrollBar Property (ScrollEventArgs)

Gets which scrollbar the event pertains to.

[Visual Basic]
Public ReadOnly Property ScrollBar As ScrollBars
[C#]
public ScrollBars ScrollBar {get;}
[C++]
public: __property ScrollBars get_ScrollBar();
[C++/CLI]
public:
property ScrollBars ScrollBar {
   ScrollBars get();
}

Return Type

A ScrollBars enumeration value.

Remarks

Note: Available in all editions.

See Also

ScrollEventArgs Class | ScrollEventArgs Members


Type Property

ScrollEventArgs Class | ScrollEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Type Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ScrollEventArgs Class : Type Property (ScrollEventArgs)

Gets the type of scroll event that occurred.

[Visual Basic]
Public ReadOnly Property Type As ScrollEventType
[C#]
public ScrollEventType Type {get;}
[C++]
public: __property ScrollEventType get_Type();
[C++/CLI]
public:
property ScrollEventType Type {
   ScrollEventType get();
}

Return Type

A ScrollEventType value from the .NET Framework Class Library.

Remarks

Note: Available in all editions.

See Also

ScrollEventArgs Class | ScrollEventArgs Members


Sprite Class

Sprite Members | PegasusImaging.WinForms.ImagXpress9 Namespace | Create Method | Move Method | Paste Method

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Sprite Class

PegasusImaging.WinForms.ImagXpress9 Namespace : Sprite Class (PegasusImaging.WinForms.ImagXpress9)

This class implements a temporary image area.

For a list of all members of this type, see Sprite members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.Sprite

Syntax

[Visual Basic]
Public Class Sprite
[C#]
public class Sprite
[C++]
public __gc class Sprite
[C++/CLI]
public ref class Sprite

Remarks

This class allows you to implement temporary image regions, separate from the image region displayed in the viewer control. The region is the viewer content, not image pixel content. It is a rubberband area for the case where a Create is not specified. The sprite can be moved ver the current image by invoking the Move method and can be pasted into the current image by invoking the Paste method.

Note: This method fails if there is no current region defined.

Note: Available in Standard, Document and Photo editions.

See Also

Sprite Members | PegasusImaging.WinForms.ImagXpress9 Namespace | Create Method | Move Method | Paste Method


Sprite Class | PegasusImaging.WinForms.ImagXpress9 Namespace | Create Method | Move Method | Paste Method

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Sprite Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : Sprite Class (PegasusImaging.WinForms.ImagXpress9)

Sprite overview

Public Methods

Public Method Create | Overloaded. Creates a copy of the current region in a transparent window that can be moved or pasted into the image.
Public Method Delete | Deletes the current sprite.
Public Method Move | Moves the current sprite to a new position within the image.
Public Method Paste | Pastes the current sprite into the image.

See Also

Sprite Class | PegasusImaging.WinForms.ImagXpress9 Namespace | Create Method | Move Method | Paste Method


Create Method

Sprite Class | Sprite Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Create Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Sprite Class : Create Method

Creates a copy of the current region in a transparent window that can be moved or pasted into the image.

Overload List

Creates a copy of the current region in a transparent window that can be moved or pasted into the image.

[Visual Basic] Overloads Public Function Create() As Boolean

[C#] public bool Create();

[C++] public bool Create()

[C++/CLI] public bool Create()

Creates a copy of the passed in path which it uses to create the current region in a transparent window that can be moved or pasted into the image.

[Visual Basic] Overloads Public Function Create(GraphicsPath) As Boolean

[C#] public bool Create(GraphicsPath);

[C++] public bool Create(GraphicsPath*);

[C++/CLI] public bool Create(GraphicsPath^);

See Also

Sprite Class | Sprite Members


Create() Method

Sprite Class | Sprite Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Create() Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Sprite Class > Create Method : Create() Method

Creates a copy of the current region in a transparent window that can be moved or pasted into the image.

[Visual Basic]
Overloads Public Function Create() As Boolean
[C#]
public bool Create();
[C++]
public: bool Create();
[C++/CLI]
public:
bool Create();

Return Type

A boolean value which represents whether the sprite was created or not.

Remarks

Note: This method fails if there is no current region.

See Also

Sprite Class | Sprite Members | Overload List


Create(GraphicsPath) Method

Sprite Class | Sprite Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

path
A GraphicsPath value to convert to the current region.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Create(GraphicsPath) Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Sprite Class > Create Method : Create(GraphicsPath) Method

Creates a copy of the passed in path which it uses to create the current region in a transparent window that can be moved or pasted into the image.

[Visual Basic]
Overloads Public Function Create( _
   ByVal path As GraphicsPath _
) As Boolean
[C#]
public bool Create(
   GraphicsPath path
);
[C++]
public: bool Create(
   GraphicsPath* path
)
[C++/CLI]
public:
bool Create(
   GraphicsPath^ path
)

Parameters

path
A GraphicsPath value to convert to the current region.

Return Type

A boolean value which is true if the sprite was created. Otherwise, false is returned.

See Also

Sprite Class | Sprite Members | Overload List


Delete Method

Sprite Class | Sprite Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Delete Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Sprite Class : Delete Method

Deletes the current sprite.

[Visual Basic]
Public Function Delete() As Boolean
[C#]
public bool Delete();
[C++]
public: bool Delete();
[C++/CLI]
public:
bool Delete();

Return Type

A boolean value which is true if the sprite was deleted. Otherwise, false is returned.

Remarks

This method deletes the current sprite but not the current region.

Note: This method fails if there is no current sprite.

See Also

Sprite Class | Sprite Members


Move Method

Sprite Class | Sprite Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

point
A Point value which represents the top-left position of the sprite within the image.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Move Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Sprite Class : Move Method

Moves the current sprite to a new position within the image.

[Visual Basic]
Public Sub Move( _
   ByVal point As Point _
)
[C#]
public void Move(
   Point point
);
[C++]
public: void Move(
   Point point
)
[C++/CLI]
public:
void Move(
   Point point
)

Parameters

point
A Point value which represents the top-left position of the sprite within the image.

Remarks

The point is in pixels and are relative to the image. Because a sprite may be a non rectangular region, the point is the top and left coordinates of a rectangle which bounds the sprite.

Note: This method fails if there is no current sprite.

See Also

Sprite Class | Sprite Members


Paste Method

Sprite Class | Sprite Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

point
A Point value which represents the top-left position of the sprite within the image.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Paste Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Sprite Class : Paste Method

Pastes the current sprite into the image.

[Visual Basic]
Public Sub Paste( _
   ByVal point As Point _
)
[C#]
public void Paste(
   Point point
);
[C++]
public: void Paste(
   Point point
)
[C++/CLI]
public:
void Paste(
   Point point
)

Parameters

point
A Point value which represents the top-left position of the sprite within the image.

Remarks

This method pastes a copy of the current sprite into the image. The current sprite is not deleted.

Note: This method fails if there is no current sprite.

See Also

Sprite Class | Sprite Members


Toolbar Class

Toolbar Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Toolbar Class

PegasusImaging.WinForms.ImagXpress9 Namespace : Toolbar Class (PegasusImaging.WinForms.ImagXpress9)

This class implements toolbar functionality.

For a list of all members of this type, see Toolbar members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.Toolbar

Syntax

[Visual Basic]
Public Class Toolbar
[C#]
public class Toolbar
[C++]
public __gc class Toolbar
[C++/CLI]
public ref class Toolbar

Remarks

The functionality enables the developer to create toolbars for use with the viewer control.

See Also

Toolbar Members | PegasusImaging.WinForms.ImagXpress9 Namespace


Toolbar Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Toolbar Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : Toolbar Class (PegasusImaging.WinForms.ImagXpress9)

Toolbar overview

Public Constructors

Public Constructor Toolbar Constructor The main constructor which initializes a new instance of the Toolbar class.

Public Properties

Public Property Activated | Gets and sets if the toolbar is created and ready for use.
Public Property ContextMenu | Gets the context menu for the toolbar.
Public Property Enabled | Gets and sets if the toolbar is enabled.
Public Property Height | Gets and sets the height of a toolbar in icons.
Public Property Hwnd | Gets the windows handle of the toolbar.
Public Property LargeIcons | Gets and sets the toolbar large icon size.
Public Property Visible | Gets and sets the toolbar visibility.
Public Property Width | Gets and sets the width of the toolbar in icons.

Public Methods

Public Method DeleteTool | Deletes the specified tool from the toolbar.
Public Method GetToolEnabled | Gets the enabled value of the given tool.
Public Method GetToolTip | Gets the informational tip that is displayed to the end-user when the mouse is dragged over the given tool.
Public Method GetToolVisible | Gets the tools visibility.
Public Method SetToolEnabled | Enables the given tool.
Public Method SetToolTip | Sets the given informational tip that displays to the end-user when the mouse is dragged over the specified tool.
Public Method SetToolVisible | Sets the tools visibility.

See Also

Toolbar Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Toolbar Constructor

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Toolbar Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > Toolbar Class : Toolbar Constructor (Toolbar)

The main constructor which initializes a new instance of the Toolbar class.

[Visual Basic]
Public Function New()
[C#]
public Toolbar();
[C++]
public: Toolbar();
[C++/CLI]
public:
Toolbar();

See Also

Toolbar Class | Toolbar Members


DeleteTool Method

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
A Tool enumeration tool to delete from the toolbar.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DeleteTool Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Toolbar Class : DeleteTool Method

Deletes the specified tool from the toolbar.

[Visual Basic]
Public Sub DeleteTool( _
   ByVal tool As Tool _
)
[C#]
public void DeleteTool(
   Tool tool
);
[C++]
public: void DeleteTool(
   Tool tool
)
[C++/CLI]
public:
void DeleteTool(
   Tool tool
)

Parameters

tool
A Tool enumeration tool to delete from the toolbar.

Remarks

Note: Once a tool is deleted, it no longer appears in the toolbar.

See Also

Toolbar Class | Toolbar Members


GetToolEnabled Method

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
A Tool enumeration value which represents the tool to get the value of.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GetToolEnabled Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Toolbar Class : GetToolEnabled Method

Gets the enabled value of the given tool.

[Visual Basic]
Public Function GetToolEnabled( _
   ByVal tool As Tool _
) As Boolean
[C#]
public bool GetToolEnabled(
   Tool tool
);
[C++]
public: bool GetToolEnabled(
   Tool tool
)
[C++/CLI]
public:
bool GetToolEnabled(
   Tool tool
)

Parameters

tool
A Tool enumeration value which represents the tool to get the value of.

Return Type

A boolean value which is true if the given tool is enabled. Otherwise, false is returned.

Remarks

Note: When a tool is enabled, the application end-user can then select it.

Note: Available in all editions.

See Also

Toolbar Class | Toolbar Members


GetToolTip Method

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
The Tool enumeration value which represents the tool to get the tip of.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GetToolTip Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Toolbar Class : GetToolTip Method

Gets the informational tip that is displayed to the end-user when the mouse is dragged over the given tool.

[Visual Basic]
Public Function GetToolTip( _
   ByVal tool As Tool _
) As String
[C#]
public string GetToolTip(
   Tool tool
);
[C++]
public: string* GetToolTip(
   Tool tool
)
[C++/CLI]
public:
String^ GetToolTip(
   Tool tool
)

Parameters

tool
The Tool enumeration value which represents the tool to get the tip of.

Return Type

The string which represents the tip of the specified tool.

See Also

Toolbar Class | Toolbar Members


GetToolVisible Method

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
A Tool enumeration value which represents the tool to get the visibility on.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GetToolVisible Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Toolbar Class : GetToolVisible Method

Gets the tools visibility.

[Visual Basic]
Public Function GetToolVisible( _
   ByVal tool As Tool _
) As Boolean
[C#]
public bool GetToolVisible(
   Tool tool
);
[C++]
public: bool GetToolVisible(
   Tool tool
)
[C++/CLI]
public:
bool GetToolVisible(
   Tool tool
)

Parameters

tool
A Tool enumeration value which represents the tool to get the visibility on.

Return Type

A boolean value which is true if the given tool is visible. Otherwise, false is returned.

Remarks

When a tool is visible, it displays in the toolbar.

Note: Available in all editions.

See Also

Toolbar Class | Toolbar Members


SetToolEnabled Method

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
A Tool enumeration value which represents the tool to enable.
enabled
A boolean value which is true to enable the given tool. Otherwise, false should be set.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetToolEnabled Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Toolbar Class : SetToolEnabled Method

Enables the given tool.

[Visual Basic]
Public Sub SetToolEnabled( _
   ByVal tool As Tool, _
   ByVal enabled As Boolean _
)
[C#]
public void SetToolEnabled(
   Tool tool,
   bool enabled
);
[C++]
public: void SetToolEnabled(
   Tool tool,
   bool enabled
)
[C++/CLI]
public:
void SetToolEnabled(
   Tool tool,
   bool enabled
)

Parameters

tool
A Tool enumeration value which represents the tool to enable.
enabled
A boolean value which is true to enable the given tool. Otherwise, false should be set.

Remarks

Note: When a tool is enabled, the application end-user can then select it.

See Also

Toolbar Class | Toolbar Members


SetToolTip Method

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
The Tool enumeration value which represents the tool to set the tip on.
tipText
A string value which represents the information tip to display.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetToolTip Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Toolbar Class : SetToolTip Method

Sets the given informational tip that displays to the end-user when the mouse is dragged over the specified tool.

[Visual Basic]
Public Sub SetToolTip( _
   ByVal tool As Tool, _
   ByVal tipText As String _
)
[C#]
public void SetToolTip(
   Tool tool,
   string tipText
);
[C++]
public: void SetToolTip(
   Tool tool,
   string* tipText
)
[C++/CLI]
public:
void SetToolTip(
   Tool tool,
   String^ tipText
)

Parameters

tool
The Tool enumeration value which represents the tool to set the tip on.
tipText
A string value which represents the information tip to display.

Remarks

Note: Available in all editions.

See Also

Toolbar Class | Toolbar Members


SetToolVisible Method

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
The Tool enumeration value which represents the tool to set the visibility on.
visible
A boolean value which is true to set the given tool to visible. Otherwise, false should be set.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetToolVisible Method

PegasusImaging.WinForms.ImagXpress9 Namespace > Toolbar Class : SetToolVisible Method

Sets the tools visibility.

[Visual Basic]
Public Sub SetToolVisible( _
   ByVal tool As Tool, _
   ByVal visible As Boolean _
)
[C#]
public void SetToolVisible(
   Tool tool,
   bool visible
);
[C++]
public: void SetToolVisible(
   Tool tool,
   bool visible
)
[C++/CLI]
public:
void SetToolVisible(
   Tool tool,
   bool visible
)

Parameters

tool
The Tool enumeration value which represents the tool to set the visibility on.
visible
A boolean value which is true to set the given tool to visible. Otherwise, false should be set.

Remarks

Note: When a tool is visible, it displays on the toolbar.

Note: Available in all editions.

See Also

Toolbar Class | Toolbar Members


Toolbar Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Toolbar Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : Toolbar Class (PegasusImaging.WinForms.ImagXpress9)

For a list of all members of this type, see Toolbar members.

Public Properties

Public Property Activated | Gets and sets if the toolbar is created and ready for use.
Public Property ContextMenu | Gets the context menu for the toolbar.
Public Property Enabled | Gets and sets if the toolbar is enabled.
Public Property Height | Gets and sets the height of a toolbar in icons.
Public Property Hwnd | Gets the windows handle of the toolbar.
Public Property LargeIcons | Gets and sets the toolbar large icon size.
Public Property Visible | Gets and sets the toolbar visibility.
Public Property Width | Gets and sets the width of the toolbar in icons.

See Also

Toolbar Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Activated Property

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Activated Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Toolbar Class : Activated Property

Gets and sets if the toolbar is created and ready for use.

[Visual Basic]
Public Property Activated As Boolean
[C#]
public bool Activated {get; set;}
[C++]
public: __property bool get_Activated();
public: __property void set_Activated(
   bool value
);
[C++/CLI]
public:
property bool Activated {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true if the toolbar is created and ready for use. Otherwise, false is used.

Remarks

Note: Available in all editions.

See Also

Toolbar Class | Toolbar Members


ContextMenu Property

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ContextMenu Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Toolbar Class : ContextMenu Property

Gets the context menu for the toolbar.

[Visual Basic]
Public ReadOnly Property ContextMenu As ToolbarContextMenu
[C#]
public ToolbarContextMenu ContextMenu {get;}
[C++]
public: __property ToolbarContextMenu* get_ContextMenu();
[C++/CLI]
public:
property ToolbarContextMenu^ ContextMenu {
   ToolbarContextMenu^ get();
}

Return Type

The ToolbarContextMenu object which contains the context menu data.

See Also

Toolbar Class | Toolbar Members


Enabled Property

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Enabled Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Toolbar Class : Enabled Property (Toolbar)

Gets and sets if the toolbar is enabled.

[Visual Basic]
Public Property Enabled As Boolean
[C#]
public bool Enabled {get; set;}
[C++]
public: __property bool get_Enabled();
public: __property void set_Enabled(
   bool value
);
[C++/CLI]
public:
property bool Enabled {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true when the toolbar is enabled. Otherwise, false is used.

Remarks

Note: Available in all editions.

See Also

Toolbar Class | Toolbar Members


Height Property

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Height Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Toolbar Class : Height Property (Toolbar)

Gets and sets the height of a toolbar in icons.

[Visual Basic]
Public Property Height As Integer
[C#]
public int Height {get; set;}
[C++]
public: __property int get_Height();
public: __property void set_Height(
   int value
);
[C++/CLI]
public:
property int Height {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the height of the toolbar in icons.

Remarks

Note: Available in all editions.

See Also

Toolbar Class | Toolbar Members


Hwnd Property

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Hwnd Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Toolbar Class : Hwnd Property

Gets the windows handle of the toolbar.

[Visual Basic]
Public ReadOnly Property Hwnd As IntPtr
[C#]
public IntPtr Hwnd {get;}
[C++]
public: __property IntPtr get_Hwnd();
[C++/CLI]
public:
property IntPtr Hwnd {
   IntPtr get();
}

Return Type

An IntPtr value which represents the handle for the toolbar.

Remarks

Note: Available in all editions.

See Also

Toolbar Class | Toolbar Members


LargeIcons Property

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LargeIcons Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Toolbar Class : LargeIcons Property

Gets and sets the toolbar large icon size.

[Visual Basic]
Public Property LargeIcons As Boolean
[C#]
public bool LargeIcons {get; set;}
[C++]
public: __property bool get_LargeIcons();
public: __property void set_LargeIcons(
   bool value
);
[C++/CLI]
public:
property bool LargeIcons {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true when the toolbar icons are large. Otherwise, false is used.

Remarks

When the toolbar icon size is large, it uses a 32x32 icon size for each toolbar button.

When the toolbar icon size is NOT large, it uses a 24x24 icon size for each toolbar button.

Note: Available in all editions.

See Also

Toolbar Class | Toolbar Members


Visible Property

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Visible Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Toolbar Class : Visible Property (Toolbar)

Gets and sets the toolbar visibility.

[Visual Basic]
Public Property Visible As Boolean
[C#]
public bool Visible {get; set;}
[C++]
public: __property bool get_Visible();
public: __property void set_Visible(
   bool value
);
[C++/CLI]
public:
property bool Visible {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true when the toolbar is visible. Otherwise, false is used.

Remarks

When the toolbar is visible, it appears in a display window.

Note: Available in all editions.

See Also

Toolbar Class | Toolbar Members


Width Property

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Width Property

PegasusImaging.WinForms.ImagXpress9 Namespace > Toolbar Class : Width Property (Toolbar)

Gets and sets the width of the toolbar in icons.

[Visual Basic]
Public Property Width As Integer
[C#]
public int Width {get; set;}
[C++]
public: __property int get_Width();
public: __property void set_Width(
   int value
);
[C++/CLI]
public:
property int Width {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the width of the toolbar in icons.

Remarks

Note: Available in all editions.

See Also

Toolbar Class | Toolbar Members


ToolbarCloseEventArgs Class

ToolbarCloseEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolbarCloseEventArgs Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ToolbarCloseEventArgs Class

This class contains information associated with a ToolbarCloseEvent.

For a list of all members of this type, see ToolbarCloseEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.ImagXpress9.ToolbarCloseEventArgs

Syntax

[Visual Basic]
Public Class ToolbarCloseEventArgs
   Inherits EventArgs
[C#]
public class ToolbarCloseEventArgs : EventArgs
[C++]
public __gc class ToolbarCloseEventArgs : public EventArgs
[C++/CLI]
public ref class ToolbarCloseEventArgs : public EventArgs

Remarks

A ImageXView.ToolbarCloseEvent occurs when the ImagXpress toolbar window closes.

See Also

ToolbarCloseEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ToolbarCloseEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolbarCloseEventArgs Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ToolbarCloseEventArgs Class

ToolbarCloseEventArgs overview

Public Constructors

Public Constructor ToolbarCloseEventArgs Constructor The main constructor which initializes a new instance of the ToolbarCloseEventArgs class.

See Also

ToolbarCloseEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ToolbarCloseEventArgs Constructor

ToolbarCloseEventArgs Class | ToolbarCloseEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolbarCloseEventArgs Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarCloseEventArgs Class : ToolbarCloseEventArgs Constructor (ToolbarCloseEventArgs)

The main constructor which initializes a new instance of the ToolbarCloseEventArgs class.

[Visual Basic]
Public Function New()
[C#]
public ToolbarCloseEventArgs();
[C++]
public: ToolbarCloseEventArgs();
[C++/CLI]
public:
ToolbarCloseEventArgs();

See Also

ToolbarCloseEventArgs Class | ToolbarCloseEventArgs Members


ToolbarContextMenu Class

ToolbarContextMenu Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolbarContextMenu Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ToolbarContextMenu Class

This class implements the context menu associated with the ImagXpress toolbar.

For a list of all members of this type, see ToolbarContextMenu members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.ToolbarContextMenu

Syntax

[Visual Basic]
Public Class ToolbarContextMenu
[C#]
public class ToolbarContextMenu
[C++]
public __gc class ToolbarContextMenu
[C++/CLI]
public ref class ToolbarContextMenu

See Also

ToolbarContextMenu Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ToolbarContextMenu Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolbarContextMenu Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ToolbarContextMenu Class

ToolbarContextMenu overview

Public Constructors

Public Constructor ToolbarContextMenu Constructor The main constructor which initializes a new instance of the ToolbarContextMenu class.

Public Methods

Public Method AddItem | Adds an item to the specified menu.
Public Method ChangeItem | Changes the text title of the specified menu item.
Public Method DeleteItem | Deletes an item from the specified menu.
Public Method GetEnabled | Gets the enabled value of the menu associated with the given tool.
Public Method GetFirstItemId | Gets the topMenuId and subMenuId of the first item in the menu associated with the specified tool.
Public Method GetItem | Gets the title of the menu item specified.
Public Method GetItemChecked | Gets the checked status of the specified menu item.
Public Method GetItemEnabled | Gets the enabled status of the specified menu item.
Public Method GetItemVisible | Gets the visible status of the specified menu item.
Public Method GetNextItemId | Gets the topMenuId and subMenuId of the next item in the menu associated with the specified tool.
Public Method SetEnabled | Sets the enabled value of the menu associated with the given tool.
Public Method SetItemChecked | Sets if a menu item should have a checkmark visible next to the item.
Public Method SetItemEnabled | Sets if a menu item is enabled.
Public Method SetItemVisible | Sets if a menu item should be visible when the menu is displayed.

See Also

ToolbarContextMenu Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ToolbarContextMenu Constructor

ToolbarContextMenu Class | ToolbarContextMenu Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolbarContextMenu Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarContextMenu Class : ToolbarContextMenu Constructor (ToolbarContextMenu)

The main constructor which initializes a new instance of the ToolbarContextMenu class.

[Visual Basic]
Public Function New()
[C#]
public ToolbarContextMenu();
[C++]
public: ToolbarContextMenu();
[C++/CLI]
public:
ToolbarContextMenu();

See Also

ToolbarContextMenu Class | ToolbarContextMenu Members


AddItem Method

ToolbarContextMenu Class | ToolbarContextMenu Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
The Tool enumeration value which represents the tool which the menu is associated.
topMenuId
An integer value which represents the top menu ID.
subMenuId
An intger value which represents the sub menu ID.
menuText
A string value which represents the menu text.
user1
An integer value which represents a user defined field.
user2
An integer value which represents a user defined field.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AddItem Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarContextMenu Class : AddItem Method

Adds an item to the specified menu.

[Visual Basic]
Public Sub AddItem( _
   ByVal tool As Tool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer, _
   ByVal menuText As String, _
   ByVal user1 As Integer, _
   ByVal user2 As Integer _
)
[C#]
public void AddItem(
   Tool tool,
   int topMenuId,
   int subMenuId,
   string menuText,
   int user1,
   int user2
);
[C++]
public: void AddItem(
   Tool tool,
   int topMenuId,
   int subMenuId,
   string* menuText,
   int user1,
   int user2
)
[C++/CLI]
public:
void AddItem(
   Tool tool,
   int topMenuId,
   int subMenuId,
   String^ menuText,
   int user1,
   int user2
)

Parameters

tool
The Tool enumeration value which represents the tool which the menu is associated.
topMenuId
An integer value which represents the top menu ID.
subMenuId
An intger value which represents the sub menu ID.
menuText
A string value which represents the menu text.
user1
An integer value which represents a user defined field.
user2
An integer value which represents a user defined field.

Remarks

This method adds a new menu item to the specified menu. If the Menu is Toolbar, ten the Tool parameter is the Tool ID that the menu is associated with.

If the Menu is Context, the Tool parameter has no meaning and can be any value.

If the menu item is to be a top-level menu item, then the subMenuId should be 0. A subMenuID menu item can only be added when a topMenuId has been added with a previous subMenuId set to 0.

Note: Available in all editions.

See Also

ToolbarContextMenu Class | ToolbarContextMenu Members


ChangeItem Method

ToolbarContextMenu Class | ToolbarContextMenu Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
A Tool enumeration value which represents the tool that the menu item is associated to.
topMenuId
An integer value which represents the top-level menu in which the menu item resides.
subMenuId
An integer value which represents the sub-level menu in which the menu item resides.
menuText
A string value which represents the text to change the menu item to.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ChangeItem Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarContextMenu Class : ChangeItem Method

Changes the text title of the specified menu item.

[Visual Basic]
Public Function ChangeItem( _
   ByVal tool As Tool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer, _
   ByVal menuText As String _
) As Boolean
[C#]
public bool ChangeItem(
   Tool tool,
   int topMenuId,
   int subMenuId,
   string menuText
);
[C++]
public: bool ChangeItem(
   Tool tool,
   int topMenuId,
   int subMenuId,
   string* menuText
)
[C++/CLI]
public:
bool ChangeItem(
   Tool tool,
   int topMenuId,
   int subMenuId,
   String^ menuText
)

Parameters

tool
A Tool enumeration value which represents the tool that the menu item is associated to.
topMenuId
An integer value which represents the top-level menu in which the menu item resides.
subMenuId
An integer value which represents the sub-level menu in which the menu item resides.
menuText
A string value which represents the text to change the menu item to.

Return Type

A boolean value which is true if the menu item text was changed. Otherwise, false is returned.

Remarks

Note: Available in all editions.

See Also

ToolbarContextMenu Class | ToolbarContextMenu Members


DeleteItem Method

ToolbarContextMenu Class | ToolbarContextMenu Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
The Tool enumeration value which represents the tool that the menu is associated with.
topMenuId
An integer value which represents the top menu ID.
subMenuId
An intger value which represents the sub menu ID.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DeleteItem Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarContextMenu Class : DeleteItem Method

Deletes an item from the specified menu.

[Visual Basic]
Public Function DeleteItem( _
   ByVal tool As Tool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer _
) As Boolean
[C#]
public bool DeleteItem(
   Tool tool,
   int topMenuId,
   int subMenuId
);
[C++]
public: bool DeleteItem(
   Tool tool,
   int topMenuId,
   int subMenuId
)
[C++/CLI]
public:
bool DeleteItem(
   Tool tool,
   int topMenuId,
   int subMenuId
)

Parameters

tool
The Tool enumeration value which represents the tool that the menu is associated with.
topMenuId
An integer value which represents the top menu ID.
subMenuId
An intger value which represents the sub menu ID.

Return Type

A boolean value which is true if the menu item text was deleted. Otherwise, false is returned.

Remarks

If the menu item is to be a top-level menu item, then the subMenuId should be 0. However, this will delete all sub-level menu items as well for that top-level menu item.

If the topMenuId and subLevelId are both 0, then the entire menu is cleared.

See Also

ToolbarContextMenu Class | ToolbarContextMenu Members


GetEnabled Method

ToolbarContextMenu Class | ToolbarContextMenu Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
The Tool enumeration value which represents the tool to get the enabled value of.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GetEnabled Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarContextMenu Class : GetEnabled Method

Gets the enabled value of the menu associated with the given tool.

[Visual Basic]
Public Function GetEnabled( _
   ByVal tool As Tool _
) As Boolean
[C#]
public bool GetEnabled(
   Tool tool
);
[C++]
public: bool GetEnabled(
   Tool tool
)
[C++/CLI]
public:
bool GetEnabled(
   Tool tool
)

Parameters

tool
The Tool enumeration value which represents the tool to get the enabled value of.

Return Type

A boolean value which is true if the given tool menu is enabled. Otherwise, false is returned.

See Also

ToolbarContextMenu Class | ToolbarContextMenu Members


GetFirstItemId Method

ToolbarContextMenu Class | ToolbarContextMenu Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
A Tool enumeration value which represents the tool associated with the menu item.
topMenuId
An integer value which represents the top-level menu ID of the first item in the menu. A returned value of 0 indicates there are no menu items.
subMenuId
An integer value which represents the sub-level menu ID of the first item in the menu.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GetFirstItemId Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarContextMenu Class : GetFirstItemId Method

Gets the topMenuId and subMenuId of the first item in the menu associated with the specified tool.

[Visual Basic]
Public Sub GetFirstItemId( _
   ByVal tool As Tool, _
   ByRef topMenuId As Integer, _
   ByRef subMenuId As Integer _
)
[C#]
public void GetFirstItemId(
   Tool tool,
   out int topMenuId,
   out int subMenuId
);
[C++]
public: void GetFirstItemId(
   Tool tool,
   [PARAMFLAG::Out] int topMenuId,
   [PARAMFLAG::Out] int subMenuId
)
[C++/CLI]
public:
void GetFirstItemId(
   Tool tool,
   [Out] int topMenuId,
   [Out] int subMenuId
)

Parameters

tool
A Tool enumeration value which represents the tool associated with the menu item.
topMenuId
An integer value which represents the top-level menu ID of the first item in the menu. A returned value of 0 indicates there are no menu items.
subMenuId
An integer value which represents the sub-level menu ID of the first item in the menu.

Remarks

Use this method and the GetNextItemId method to iterate through the available menu items.

Note: Available in all editions.

See Also

ToolbarContextMenu Class | ToolbarContextMenu Members


GetItem Method

ToolbarContextMenu Class | ToolbarContextMenu Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
A Tool enumeration value which represents the tool associated with the menu item.
topMenuId
An integer value which represents the identifier of the top-level menu in which the menu item resides.
subMenuId
An integer value which represents the identifier of the sub-level menu in which the menu item resides.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GetItem Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarContextMenu Class : GetItem Method

Gets the title of the menu item specified.

[Visual Basic]
Public Function GetItem( _
   ByVal tool As Tool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer _
) As String
[C#]
public string GetItem(
   Tool tool,
   int topMenuId,
   int subMenuId
);
[C++]
public: string* GetItem(
   Tool tool,
   int topMenuId,
   int subMenuId
)
[C++/CLI]
public:
String^ GetItem(
   Tool tool,
   int topMenuId,
   int subMenuId
)

Parameters

tool
A Tool enumeration value which represents the tool associated with the menu item.
topMenuId
An integer value which represents the identifier of the top-level menu in which the menu item resides.
subMenuId
An integer value which represents the identifier of the sub-level menu in which the menu item resides.

Return Type

A string which represents the title of the menu item specified.

Remarks

Note: Available in all editions.

See Also

ToolbarContextMenu Class | ToolbarContextMenu Members


GetItemChecked Method

ToolbarContextMenu Class | ToolbarContextMenu Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
A Tool enumeration value associated with the menu.
topMenuId
An integer value which represents the top-level menu ID.
subMenuId
An integer value which represents the sub-level menu ID.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GetItemChecked Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarContextMenu Class : GetItemChecked Method

Gets the checked status of the specified menu item.

[Visual Basic]
Public Function GetItemChecked( _
   ByVal tool As Tool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer _
) As Boolean
[C#]
public bool GetItemChecked(
   Tool tool,
   int topMenuId,
   int subMenuId
);
[C++]
public: bool GetItemChecked(
   Tool tool,
   int topMenuId,
   int subMenuId
)
[C++/CLI]
public:
bool GetItemChecked(
   Tool tool,
   int topMenuId,
   int subMenuId
)

Parameters

tool
A Tool enumeration value associated with the menu.
topMenuId
An integer value which represents the top-level menu ID.
subMenuId
An integer value which represents the sub-level menu ID.

Return Type

A boolean value which is true if the given item is checked. Otherwise, false is returned.

Remarks

If an item is checked, a check-mark is visible next to the item.

Note: Available in all editions.

See Also

ToolbarContextMenu Class | ToolbarContextMenu Members


GetItemEnabled Method

ToolbarContextMenu Class | ToolbarContextMenu Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
A Tool enumeration value associated with the menu item.
topMenuId
An integer value which represents the top-level menu ID.
subMenuId
An integer value which represents the sub-level menu ID.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GetItemEnabled Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarContextMenu Class : GetItemEnabled Method

Gets the enabled status of the specified menu item.

[Visual Basic]
Public Function GetItemEnabled( _
   ByVal tool As Tool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer _
) As Boolean
[C#]
public bool GetItemEnabled(
   Tool tool,
   int topMenuId,
   int subMenuId
);
[C++]
public: bool GetItemEnabled(
   Tool tool,
   int topMenuId,
   int subMenuId
)
[C++/CLI]
public:
bool GetItemEnabled(
   Tool tool,
   int topMenuId,
   int subMenuId
)

Parameters

tool
A Tool enumeration value associated with the menu item.
topMenuId
An integer value which represents the top-level menu ID.
subMenuId
An integer value which represents the sub-level menu ID.

Return Type

A boolean value which is true when the menu item is enabled. Otherwise, false is returned.

Remarks

When a menu item is enabled, the application end-user can select the menu item. Items that are enabled appear in dark print. Items that are not enabled are grayed out.

Note: Available in all editions.

See Also

ToolbarContextMenu Class | ToolbarContextMenu Members


GetItemVisible Method

ToolbarContextMenu Class | ToolbarContextMenu Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
A Tool enumeration value associated with the menu item.
topMenuId
An integer value which represents the top-level menu in which the menu item resides.
subMenuId
An integer value which represents the sub-level menu in which the menu item resides.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GetItemVisible Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarContextMenu Class : GetItemVisible Method

Gets the visible status of the specified menu item.

[Visual Basic]
Public Function GetItemVisible( _
   ByVal tool As Tool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer _
) As Boolean
[C#]
public bool GetItemVisible(
   Tool tool,
   int topMenuId,
   int subMenuId
);
[C++]
public: bool GetItemVisible(
   Tool tool,
   int topMenuId,
   int subMenuId
)
[C++/CLI]
public:
bool GetItemVisible(
   Tool tool,
   int topMenuId,
   int subMenuId
)

Parameters

tool
A Tool enumeration value associated with the menu item.
topMenuId
An integer value which represents the top-level menu in which the menu item resides.
subMenuId
An integer value which represents the sub-level menu in which the menu item resides.

Return Type

A boolean value which is true if the given menu item is visible. Otherwise, false is returned.

Remarks

Note: Available in all editions.

See Also

ToolbarContextMenu Class | ToolbarContextMenu Members


GetNextItemId Method

ToolbarContextMenu Class | ToolbarContextMenu Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
A Tool enumeration value with which the menu is associated.
topMenuId
An integer value which represents the top-level menu ID of the first item in the menu.
subMenuId
An integer value which represents the sub-level menu ID of the first item in the menu.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GetNextItemId Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarContextMenu Class : GetNextItemId Method

Gets the topMenuId and subMenuId of the next item in the menu associated with the specified tool.

[Visual Basic]
Public Sub GetNextItemId( _
   ByVal tool As Tool, _
   ByRef topMenuId As Integer, _
   ByRef subMenuId As Integer _
)
[C#]
public void GetNextItemId(
   Tool tool,
   out int topMenuId,
   out int subMenuId
);
[C++]
public: void GetNextItemId(
   Tool tool,
   [PARAMFLAG::Out] int topMenuId,
   [PARAMFLAG::Out] int subMenuId
)
[C++/CLI]
public:
void GetNextItemId(
   Tool tool,
   [Out] int topMenuId,
   [Out] int subMenuId
)

Parameters

tool
A Tool enumeration value with which the menu is associated.
topMenuId
An integer value which represents the top-level menu ID of the first item in the menu.
subMenuId
An integer value which represents the sub-level menu ID of the first item in the menu.

Remarks

Use this method and the GetFirstItemId method to iterate through the available menu items.

See Also

ToolbarContextMenu Class | ToolbarContextMenu Members


SetEnabled Method

ToolbarContextMenu Class | ToolbarContextMenu Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
The Tool enumeration value which represents the tool to set the enabled value of.
enabled
A boolean value which should be set to true to enable the menu of the given tool. Otherwise, false should be set.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetEnabled Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarContextMenu Class : SetEnabled Method

Sets the enabled value of the menu associated with the given tool.

[Visual Basic]
Public Sub SetEnabled( _
   ByVal tool As Tool, _
   ByVal enabled As Boolean _
)
[C#]
public void SetEnabled(
   Tool tool,
   bool enabled
);
[C++]
public: void SetEnabled(
   Tool tool,
   bool enabled
)
[C++/CLI]
public:
void SetEnabled(
   Tool tool,
   bool enabled
)

Parameters

tool
The Tool enumeration value which represents the tool to set the enabled value of.
enabled
A boolean value which should be set to true to enable the menu of the given tool. Otherwise, false should be set.

Remarks

Note: Available in all editions.

See Also

ToolbarContextMenu Class | ToolbarContextMenu Members


SetItemChecked Method

ToolbarContextMenu Class | ToolbarContextMenu Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
A Tool enumeration value associated to the menu.
topMenuId
An integer value which represents the top-level menu ID.
subMenuId
An integer value which represents the sub-level menu ID.
isChecked
A boolean value which is true to check visible next to the item and false to not have a check visible next to the item.
exclusive
A boolean value which is true when the item is checked and all other items on the same menu level are not checked. If this parameter is false and the item is checked, the other items on the same menu level can be checked as well.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetItemChecked Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarContextMenu Class : SetItemChecked Method

Sets if a menu item should have a checkmark visible next to the item.

[Visual Basic]
Public Sub SetItemChecked( _
   ByVal tool As Tool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer, _
   ByVal isChecked As Boolean, _
   ByVal exclusive As Boolean _
)
[C#]
public void SetItemChecked(
   Tool tool,
   int topMenuId,
   int subMenuId,
   bool isChecked,
   bool exclusive
);
[C++]
public: void SetItemChecked(
   Tool tool,
   int topMenuId,
   int subMenuId,
   bool isChecked,
   bool exclusive
)
[C++/CLI]
public:
void SetItemChecked(
   Tool tool,
   int topMenuId,
   int subMenuId,
   bool isChecked,
   bool exclusive
)

Parameters

tool
A Tool enumeration value associated to the menu.
topMenuId
An integer value which represents the top-level menu ID.
subMenuId
An integer value which represents the sub-level menu ID.
isChecked
A boolean value which is true to check visible next to the item and false to not have a check visible next to the item.
exclusive
A boolean value which is true when the item is checked and all other items on the same menu level are not checked. If this parameter is false and the item is checked, the other items on the same menu level can be checked as well.

Remarks

Note: Available in all editions.

See Also

ToolbarContextMenu Class | ToolbarContextMenu Members


SetItemEnabled Method

ToolbarContextMenu Class | ToolbarContextMenu Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
A Tool enumeration value associated with the menu item.
topMenuId
An integer value which represents the top-level menu ID.
subMenuId
An integer value which represents the sub-level menu ID.
enabled
A boolean value which is true to enable the menu item. Otherwise, false should be set.
exclusive
A boolean value which is true when the menu item is enabled and all other menu items on the same menu level are disabled. Otherwise, use false when the menu item is enabled and all other menu items on the same menu level do not have to be disabled.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetItemEnabled Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarContextMenu Class : SetItemEnabled Method

Sets if a menu item is enabled.

[Visual Basic]
Public Sub SetItemEnabled( _
   ByVal tool As Tool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer, _
   ByVal enabled As Boolean, _
   ByVal exclusive As Boolean _
)
[C#]
public void SetItemEnabled(
   Tool tool,
   int topMenuId,
   int subMenuId,
   bool enabled,
   bool exclusive
);
[C++]
public: void SetItemEnabled(
   Tool tool,
   int topMenuId,
   int subMenuId,
   bool enabled,
   bool exclusive
)
[C++/CLI]
public:
void SetItemEnabled(
   Tool tool,
   int topMenuId,
   int subMenuId,
   bool enabled,
   bool exclusive
)

Parameters

tool
A Tool enumeration value associated with the menu item.
topMenuId
An integer value which represents the top-level menu ID.
subMenuId
An integer value which represents the sub-level menu ID.
enabled
A boolean value which is true to enable the menu item. Otherwise, false should be set.
exclusive
A boolean value which is true when the menu item is enabled and all other menu items on the same menu level are disabled. Otherwise, use false when the menu item is enabled and all other menu items on the same menu level do not have to be disabled.

Remarks

When a menu item is enabled, the application end-user can select the menu item. Items that are enabled appear in dark print. Items that are not enabled are grayed out.

Note: Available in all editions.

See Also

ToolbarContextMenu Class | ToolbarContextMenu Members


SetItemVisible Method

ToolbarContextMenu Class | ToolbarContextMenu Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
A Tool enumeration value associated with the menu item.
topMenuId
An integer value which represents the top-level menu ID.
subMenuId
An integer value which represents the sub-level menu ID.
visible
A boolean value which is true to set the given menu item to visible. Otherwise, false should be set.
exclusive
A boolean value which is true to set all other menu items on the same menu level as hidden. Otherwise, false should be set.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SetItemVisible Method

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarContextMenu Class : SetItemVisible Method

Sets if a menu item should be visible when the menu is displayed.

[Visual Basic]
Public Sub SetItemVisible( _
   ByVal tool As Tool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer, _
   ByVal visible As Boolean, _
   ByVal exclusive As Boolean _
)
[C#]
public void SetItemVisible(
   Tool tool,
   int topMenuId,
   int subMenuId,
   bool visible,
   bool exclusive
);
[C++]
public: void SetItemVisible(
   Tool tool,
   int topMenuId,
   int subMenuId,
   bool visible,
   bool exclusive
)
[C++/CLI]
public:
void SetItemVisible(
   Tool tool,
   int topMenuId,
   int subMenuId,
   bool visible,
   bool exclusive
)

Parameters

tool
A Tool enumeration value associated with the menu item.
topMenuId
An integer value which represents the top-level menu ID.
subMenuId
An integer value which represents the sub-level menu ID.
visible
A boolean value which is true to set the given menu item to visible. Otherwise, false should be set.
exclusive
A boolean value which is true to set all other menu items on the same menu level as hidden. Otherwise, false should be set.

Remarks

Note: Available in all editions.

See Also

ToolbarContextMenu Class | ToolbarContextMenu Members


ToolbarContextMenuEventArgs Class

ToolbarContextMenuEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolbarContextMenuEventArgs Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ToolbarContextMenuEventArgs Class

This class implements the event arguments for when a ToolbarContextMenuSelect event is fired.

For a list of all members of this type, see ToolbarContextMenuEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.ImagXpress9.ToolbarContextMenuEventArgs

Syntax

[Visual Basic]
Public Class ToolbarContextMenuEventArgs
   Inherits EventArgs
[C#]
public class ToolbarContextMenuEventArgs : EventArgs
[C++]
public __gc class ToolbarContextMenuEventArgs : public EventArgs
[C++/CLI]
public ref class ToolbarContextMenuEventArgs : public EventArgs

See Also

ToolbarContextMenuEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ToolbarContextMenuEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolbarContextMenuEventArgs Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ToolbarContextMenuEventArgs Class

ToolbarContextMenuEventArgs overview

Public Constructors

Public Constructor ToolbarContextMenuEventArgs Constructor The main constructor which initializes a new instance of the ToolbarContextMenuArgs class

Public Properties

Public Property SubMenuId | Gets the sub-level menu ID for this menu item.
Public Property Tool | Gets the Tool associated with the context menu that fired the event.
Public Property TopMenuId | Gets the top-level menu ID for this menu ID.
Public Property User1 | Gets the first of two user-supplied values set when the menu was created.
Public Property User2 | Gets the second of two user-supplied values set when the menu was created.

See Also

ToolbarContextMenuEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ToolbarContextMenuEventArgs Constructor

ToolbarContextMenuEventArgs Class | ToolbarContextMenuEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolbarContextMenuEventArgs Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarContextMenuEventArgs Class : ToolbarContextMenuEventArgs Constructor (ToolbarContextMenuEventArgs)

The main constructor which initializes a new instance of the ToolbarContextMenuArgs class

[Visual Basic]
Public Function New()
[C#]
public ToolbarContextMenuEventArgs();
[C++]
public: ToolbarContextMenuEventArgs();
[C++/CLI]
public:
ToolbarContextMenuEventArgs();

See Also

ToolbarContextMenuEventArgs Class | ToolbarContextMenuEventArgs Members


ToolbarContextMenuEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolbarContextMenuEventArgs Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : ToolbarContextMenuEventArgs Class

For a list of all members of this type, see ToolbarContextMenuEventArgs members.

Public Properties

Public Property SubMenuId | Gets the sub-level menu ID for this menu item.
Public Property Tool | Gets the Tool associated with the context menu that fired the event.
Public Property TopMenuId | Gets the top-level menu ID for this menu ID.
Public Property User1 | Gets the first of two user-supplied values set when the menu was created.
Public Property User2 | Gets the second of two user-supplied values set when the menu was created.

See Also

ToolbarContextMenuEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


SubMenuId Property

ToolbarContextMenuEventArgs Class | ToolbarContextMenuEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SubMenuId Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarContextMenuEventArgs Class : SubMenuId Property

Gets the sub-level menu ID for this menu item.

[Visual Basic]
Public ReadOnly Property SubMenuId As Integer
[C#]
public int SubMenuId {get;}
[C++]
public: __property int get_SubMenuId();
[C++/CLI]
public:
property int SubMenuId {
   int get();
}

Return Type

An integer value which represents the sub-level menu ID.

Remarks

This property will be 0 if the menu item was a top-level menu item.

Note: Available in all editions.

See Also

ToolbarContextMenuEventArgs Class | ToolbarContextMenuEventArgs Members


Tool Property

ToolbarContextMenuEventArgs Class | ToolbarContextMenuEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Tool Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarContextMenuEventArgs Class : Tool Property (ToolbarContextMenuEventArgs)

Gets the Tool associated with the context menu that fired the event.

[Visual Basic]
Public ReadOnly Property Tool As Tool
[C#]
public Tool Tool {get;}
[C++]
public: __property Tool get_Tool();
[C++/CLI]
public:
property Tool Tool {
   Tool get();
}

Return Type

A Tool enumeration value associated with the event.

Remarks

Note: Available in all editions.

See Also

ToolbarContextMenuEventArgs Class | ToolbarContextMenuEventArgs Members


TopMenuId Property

ToolbarContextMenuEventArgs Class | ToolbarContextMenuEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

TopMenuId Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarContextMenuEventArgs Class : TopMenuId Property

Gets the top-level menu ID for this menu ID.

[Visual Basic]
Public ReadOnly Property TopMenuId As Integer
[C#]
public int TopMenuId {get;}
[C++]
public: __property int get_TopMenuId();
[C++/CLI]
public:
property int TopMenuId {
   int get();
}

Return Type

An integer value which represents the top-level menu ID.

Remarks

A menu ID of 4100-4200 is reserved for adding a menu separator bar.

Note: Available in all editions.

See Also

ToolbarContextMenuEventArgs Class | ToolbarContextMenuEventArgs Members


User1 Property

ToolbarContextMenuEventArgs Class | ToolbarContextMenuEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

User1 Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarContextMenuEventArgs Class : User1 Property (ToolbarContextMenuEventArgs)

Gets the first of two user-supplied values set when the menu was created.

[Visual Basic]
Public ReadOnly Property User1 As Integer
[C#]
public int User1 {get;}
[C++]
public: __property int get_User1();
[C++/CLI]
public:
property int User1 {
   int get();
}

Return Type

An integer value which represents the user-supplied values.

Remarks

Note: Available in all editions.

See Also

ToolbarContextMenuEventArgs Class | ToolbarContextMenuEventArgs Members


User2 Property

ToolbarContextMenuEventArgs Class | ToolbarContextMenuEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

User2 Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarContextMenuEventArgs Class : User2 Property (ToolbarContextMenuEventArgs)

Gets the second of two user-supplied values set when the menu was created.

[Visual Basic]
Public ReadOnly Property User2 As Integer
[C#]
public int User2 {get;}
[C++]
public: __property int get_User2();
[C++/CLI]
public:
property int User2 {
   int get();
}

Return Type

An integer value which represents the user-supplied values.

Remarks

Note: Available in all editions.

See Also

ToolbarContextMenuEventArgs Class | ToolbarContextMenuEventArgs Members


ToolbarEventArgs Class

ToolbarEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolbarEventArgs Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ToolbarEventArgs Class

This class implements event data for toolbar events.

For a list of all members of this type, see ToolbarEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.ImagXpress9.ToolbarEventArgs

Syntax

[Visual Basic]
Public Class ToolbarEventArgs
   Inherits EventArgs
[C#]
public class ToolbarEventArgs : EventArgs
[C++]
public __gc class ToolbarEventArgs : public EventArgs
[C++/CLI]
public ref class ToolbarEventArgs : public EventArgs

See Also

ToolbarEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ToolbarEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolbarEventArgs Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ToolbarEventArgs Class

ToolbarEventArgs overview

Public Constructors

Public Constructor ToolbarEventArgs Constructor The main constructor which intializes a new instance of the ToolbarEventArgs class.

Public Properties

Public Property Tool | Gets the selected tool.
Public Property User1 | Gets the numerical value associated with the Tool.
Public Property User2 | Gets the numerical value associated with the Tool.

See Also

ToolbarEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ToolbarEventArgs Constructor

ToolbarEventArgs Class | ToolbarEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolbarEventArgs Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarEventArgs Class : ToolbarEventArgs Constructor (ToolbarEventArgs)

The main constructor which intializes a new instance of the ToolbarEventArgs class.

[Visual Basic]
Public Function New()
[C#]
public ToolbarEventArgs();
[C++]
public: ToolbarEventArgs();
[C++/CLI]
public:
ToolbarEventArgs();

See Also

ToolbarEventArgs Class | ToolbarEventArgs Members


ToolbarEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolbarEventArgs Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : ToolbarEventArgs Class

For a list of all members of this type, see ToolbarEventArgs members.

Public Properties

Public Property Tool | Gets the selected tool.
Public Property User1 | Gets the numerical value associated with the Tool.
Public Property User2 | Gets the numerical value associated with the Tool.

See Also

ToolbarEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Tool Property

ToolbarEventArgs Class | ToolbarEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Tool Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarEventArgs Class : Tool Property (ToolbarEventArgs)

Gets the selected tool.

[Visual Basic]
Public ReadOnly Property Tool As Tool
[C#]
public Tool Tool {get;}
[C++]
public: __property Tool get_Tool();
[C++/CLI]
public:
property Tool Tool {
   Tool get();
}

Return Type

A Tool enumeration value associated to the event.

Remarks

Note: Available in all editions.

See Also

ToolbarEventArgs Class | ToolbarEventArgs Members


User1 Property

ToolbarEventArgs Class | ToolbarEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

User1 Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarEventArgs Class : User1 Property (ToolbarEventArgs)

Gets the numerical value associated with the Tool.

[Visual Basic]
Public ReadOnly Property User1 As Integer
[C#]
public int User1 {get;}
[C++]
public: __property int get_User1();
[C++/CLI]
public:
property int User1 {
   int get();
}

Return Type

An integer value which represents the Tool ID.

Remarks

Note: Available in all editions.

See Also

ToolbarEventArgs Class | ToolbarEventArgs Members


User2 Property

ToolbarEventArgs Class | ToolbarEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

User2 Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarEventArgs Class : User2 Property (ToolbarEventArgs)

Gets the numerical value associated with the Tool.

[Visual Basic]
Public ReadOnly Property User2 As Integer
[C#]
public int User2 {get;}
[C++]
public: __property int get_User2();
[C++/CLI]
public:
property int User2 {
   int get();
}

Return Type

An integer value which represents the Tool ID.

Remarks

Note: Available in all editions.

See Also

ToolbarEventArgs Class | ToolbarEventArgs Members


ToolbarOpenEventArgs Class

ToolbarOpenEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolbarOpenEventArgs Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ToolbarOpenEventArgs Class

This class implements information associated with a ToolbarOpenEvent.

For a list of all members of this type, see ToolbarOpenEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.ImagXpress9.ToolbarOpenEventArgs

Syntax

[Visual Basic]
Public Class ToolbarOpenEventArgs
   Inherits EventArgs
[C#]
public class ToolbarOpenEventArgs : EventArgs
[C++]
public __gc class ToolbarOpenEventArgs : public EventArgs
[C++/CLI]
public ref class ToolbarOpenEventArgs : public EventArgs

See Also

ToolbarOpenEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ToolbarOpenEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolbarOpenEventArgs Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ToolbarOpenEventArgs Class

ToolbarOpenEventArgs overview

Public Constructors

Public Constructor ToolbarOpenEventArgs Constructor The main constructor which initializes a new instance of the ToolbarOpenEventArgs class.

Public Properties

Public Property Handle Gets the handle of the toolbar.

See Also

ToolbarOpenEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ToolbarOpenEventArgs Constructor

ToolbarOpenEventArgs Class | ToolbarOpenEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolbarOpenEventArgs Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarOpenEventArgs Class : ToolbarOpenEventArgs Constructor (ToolbarOpenEventArgs)

The main constructor which initializes a new instance of the ToolbarOpenEventArgs class.

[Visual Basic]
Public Function New()
[C#]
public ToolbarOpenEventArgs();
[C++]
public: ToolbarOpenEventArgs();
[C++/CLI]
public:
ToolbarOpenEventArgs();

See Also

ToolbarOpenEventArgs Class | ToolbarOpenEventArgs Members


ToolbarOpenEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolbarOpenEventArgs Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : ToolbarOpenEventArgs Class

For a list of all members of this type, see ToolbarOpenEventArgs members.

Public Properties

Public Property Handle Gets the handle of the toolbar.

See Also

ToolbarOpenEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Handle Property

ToolbarOpenEventArgs Class | ToolbarOpenEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Handle Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolbarOpenEventArgs Class : Handle Property

Gets the handle of the toolbar.

[Visual Basic]
Public ReadOnly Property Handle As IntPtr
[C#]
public IntPtr Handle {get;}
[C++]
public: __property IntPtr get_Handle();
[C++/CLI]
public:
property IntPtr Handle {
   IntPtr get();
}

Return Type

An IntPtr which represents the handle of the toolbar.

Remarks

Note: Available in all editions.

See Also

ToolbarOpenEventArgs Class | ToolbarOpenEventArgs Members


ToolEventArgs Class

ToolEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolEventArgs Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ToolEventArgs Class

This class implements event data for tool events.

For a list of all members of this type, see ToolEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.ImagXpress9.ToolEventArgs

Syntax

[Visual Basic]
Public Class ToolEventArgs
   Inherits EventArgs
[C#]
public class ToolEventArgs : EventArgs
[C++]
public __gc class ToolEventArgs : public EventArgs
[C++/CLI]
public ref class ToolEventArgs : public EventArgs

See Also

ToolEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ToolEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolEventArgs Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ToolEventArgs Class

ToolEventArgs overview

Public Constructors

Public Constructor ToolEventArgs Constructor The main constructor which intializes a new instance of the ToolEventArgs class.

Public Properties

Public Property Action | Gets the value of the action the tool performed.
Public Property Location | Gets the location at which the tool action was performed.
Public Property Tool | Gets the tool being used.

See Also

ToolEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ToolEventArgs Constructor

ToolEventArgs Class | ToolEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolEventArgs Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolEventArgs Class : ToolEventArgs Constructor (ToolEventArgs)

The main constructor which intializes a new instance of the ToolEventArgs class.

[Visual Basic]
Public Function New()
[C#]
public ToolEventArgs();
[C++]
public: ToolEventArgs();
[C++/CLI]
public:
ToolEventArgs();

See Also

ToolEventArgs Class | ToolEventArgs Members


ToolEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolEventArgs Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : ToolEventArgs Class

For a list of all members of this type, see ToolEventArgs members.

Public Properties

Public Property Action | Gets the value of the action the tool performed.
Public Property Location | Gets the location at which the tool action was performed.
Public Property Tool | Gets the tool being used.

See Also

ToolEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Action Property

ToolEventArgs Class | ToolEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Action Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolEventArgs Class : Action Property

Gets the value of the action the tool performed.

[Visual Basic]
Public ReadOnly Property Action As ToolAction
[C#]
public ToolAction Action {get;}
[C++]
public: __property ToolAction get_Action();
[C++/CLI]
public:
property ToolAction Action {
   ToolAction get();
}

Return Type

A ToolAction enumeration value.

Remarks

Note: Available in all editions.

See Also

ToolEventArgs Class | ToolEventArgs Members


Location Property

ToolEventArgs Class | ToolEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Location Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolEventArgs Class : Location Property

Gets the location at which the tool action was performed.

[Visual Basic]
Public ReadOnly Property Location As Point
[C#]
public Point Location {get;}
[C++]
public: __property Point get_Location();
[C++/CLI]
public:
property Point Location {
   Point get();
}

Return Type

A Point value which represents the location.

Remarks

Note: Available in all editions.

See Also

ToolEventArgs Class | ToolEventArgs Members


Tool Property

ToolEventArgs Class | ToolEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Tool Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ToolEventArgs Class : Tool Property (ToolEventArgs)

Gets the tool being used.

[Visual Basic]
Public ReadOnly Property Tool As Tool
[C#]
public Tool Tool {get;}
[C++]
public: __property Tool get_Tool();
[C++/CLI]
public:
property Tool Tool {
   Tool get();
}

Return Type

A Tool enumeration value associated to the event.

Remarks

Note: Available in all editions.

See Also

ToolEventArgs Class | ToolEventArgs Members


WorkerImports Class

WorkerImports Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

WorkerImports Class

PegasusImaging.WinForms.ImagXpress9 Namespace : WorkerImports Class

Summary description for WorkerImports.

For a list of all members of this type, see WorkerImports members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.WorkerImports

Syntax

[Visual Basic]
<SuppressUnmanagedCodeSecurityAttribute()>
Public Class WorkerImports
[C#]
[SuppressUnmanagedCodeSecurityAttribute()]
public class WorkerImports
[C++]
[SuppressUnmanagedCodeSecurityAttribute()]
public __gc class WorkerImports
[C++/CLI]
[SuppressUnmanagedCodeSecurityAttribute()]
public ref class WorkerImports

See Also

WorkerImports Members | PegasusImaging.WinForms.ImagXpress9 Namespace


WorkerImports Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

WorkerImports Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : WorkerImports Class

WorkerImports overview

Public Constructors

Public Constructor WorkerImports Constructor

See Also

WorkerImports Class | PegasusImaging.WinForms.ImagXpress9 Namespace


WorkerImports Constructor

WorkerImports Class | WorkerImports Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

WorkerImports Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > WorkerImports Class : WorkerImports Constructor (WorkerImports)
[Visual Basic]
Public Function New()
[C#]
public WorkerImports();
[C++]
public: WorkerImports();
[C++/CLI]
public:
WorkerImports();

See Also

WorkerImports Class | WorkerImports Members


ZoomFactorChangedEventArgs Class

ZoomFactorChangedEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ZoomFactorChangedEventArgs Class

PegasusImaging.WinForms.ImagXpress9 Namespace : ZoomFactorChangedEventArgs Class

This class implements event data for ZoomFactorChanged events.

For a list of all members of this type, see ZoomFactorChangedEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.ImagXpress9.ZoomFactorChangedEventArgs

Syntax

[Visual Basic]
Public Class ZoomFactorChangedEventArgs
   Inherits EventArgs
[C#]
public class ZoomFactorChangedEventArgs : EventArgs
[C++]
public __gc class ZoomFactorChangedEventArgs : public EventArgs
[C++/CLI]
public ref class ZoomFactorChangedEventArgs : public EventArgs

See Also

ZoomFactorChangedEventArgs Members | PegasusImaging.WinForms.ImagXpress9 Namespace


ZoomFactorChangedEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ZoomFactorChangedEventArgs Class Members

PegasusImaging.WinForms.ImagXpress9 Namespace : ZoomFactorChangedEventArgs Class

ZoomFactorChangedEventArgs overview

Public Constructors

Public Constructor ZoomFactorChangedEventArgs Constructor The main constructor which initializes a new instance of the ZoomFactorChangedEventArgs class.

Public Properties

Public Property NewValue | Gets the new value for the ZoomFactor property
Public Property OldValue | Gets the old value for the ZoomFactor property.

See Also

ZoomFactorChangedEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ZoomFactorChangedEventArgs Constructor

ZoomFactorChangedEventArgs Class | ZoomFactorChangedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ZoomFactorChangedEventArgs Constructor

PegasusImaging.WinForms.ImagXpress9 Namespace > ZoomFactorChangedEventArgs Class : ZoomFactorChangedEventArgs Constructor (ZoomFactorChangedEventArgs)

The main constructor which initializes a new instance of the ZoomFactorChangedEventArgs class.

[Visual Basic]
Public Function New()
[C#]
public ZoomFactorChangedEventArgs();
[C++]
public: ZoomFactorChangedEventArgs();
[C++/CLI]
public:
ZoomFactorChangedEventArgs();

See Also

ZoomFactorChangedEventArgs Class | ZoomFactorChangedEventArgs Members


ZoomFactorChangedEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ZoomFactorChangedEventArgs Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : ZoomFactorChangedEventArgs Class

For a list of all members of this type, see ZoomFactorChangedEventArgs members.

Public Properties

Public Property NewValue | Gets the new value for the ZoomFactor property
Public Property OldValue | Gets the old value for the ZoomFactor property.

See Also

ZoomFactorChangedEventArgs Class | PegasusImaging.WinForms.ImagXpress9 Namespace


NewValue Property

ZoomFactorChangedEventArgs Class | ZoomFactorChangedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

NewValue Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ZoomFactorChangedEventArgs Class : NewValue Property (ZoomFactorChangedEventArgs)

Gets the new value for the ZoomFactor property

[Visual Basic]
Public ReadOnly Property NewValue As Double
[C#]
public double NewValue {get;}
[C++]
public: __property double get_NewValue();
[C++/CLI]
public:
property double NewValue {
   double get();
}

Return Type

A Double value from the .NET Framework Class Library.

Remarks

Note: Available in all editions.

See Also

ZoomFactorChangedEventArgs Class | ZoomFactorChangedEventArgs Members


OldValue Property

ZoomFactorChangedEventArgs Class | ZoomFactorChangedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

OldValue Property

PegasusImaging.WinForms.ImagXpress9 Namespace > ZoomFactorChangedEventArgs Class : OldValue Property (ZoomFactorChangedEventArgs)

Gets the old value for the ZoomFactor property.

[Visual Basic]
Public ReadOnly Property OldValue As Double
[C#]
public double OldValue {get;}
[C++]
public: __property double get_OldValue();
[C++/CLI]
public:
property double OldValue {
   double get();
}

Return Type

A Double value from the .NET Framework Class Library.

Remarks

Note: Available in all editions.

See Also

ZoomFactorChangedEventArgs Class | ZoomFactorChangedEventArgs Members


AdjustType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AdjustType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : AdjustType Enumeration

Option values used to indicate the adjustment type.

Members

Member | Description
AsPercent | 0 - Adjustments made as percentage values.
InUnits | 1 - Adjustments made in units.

Remarks

Note: Available in all editions.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


AlignHorizontal Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AlignHorizontal Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : AlignHorizontal Enumeration (PegasusImaging.WinForms.ImagXpress9)

Option values indicating the horizontal alignment setting.

Members

Member | Description
Left | 0 - Align horizontally to the left edge of the view.
Center | 1 - Align horizontally to the center of the view.
Right | 2 - Align horizontally to the right edge of the view.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


AlignVertical Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AlignVertical Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : AlignVertical Enumeration (PegasusImaging.WinForms.ImagXpress9)

Option values indicating the vertical alignment setting.

Members

Member | Description
Top | 0 - Align vertically to the top edge of the view.
Center | 1 - Align vertically to the center of the view.
Bottom | 2 - Align vertically to the bottom edge of the view.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


AreaRegionOption Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AreaRegionOption Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : AreaRegionOption Enumeration

Option values which determine the area and region settings.

Members

Member | Description
None | 0 - No active area or region.
Area | 1 - Area active.
Region | 2 - Region active.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


AutoResizeType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

AutoResizeType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : AutoResizeType Enumeration

Option values for use with the ImageXView.AutoResize property.

Members

Member | Description
CropImageToControl | 0 - The image is cropped to the control size. Note: If the control size is larger than the image, the control is resized to the image.
ResizeControl | 1 - The control is resized to fit the image.
ResizeImage | 2 - The image is resized to fit the control.
TileImage | 3 - The image is tiled to fit the control.
BestFit | 4 - The image is resized to fit the control and the aspect ratio is preserved.
CropImage | 5 - The image is cropped to the control size. Note: If the control size is larger than the image, the control is not resized to the image.
FitWidth | 6 - Resize the image to fit the image width within the viewer control.
FitHeight | 7 - Resize the image to fit the image height within the viewer control.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


BinarizeBlur Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

BinarizeBlur Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : BinarizeBlur Enumeration

Option values used to determine what type of blur functionality to use during the Processor.Binarize method.

Members

Member | Description
NoBlur | 0 - Don't blur.
Gaussian | 1 - Blur the image before local contrast enhancement/binarize.
Smart | 2 - Remove dither-like artifacts introduced into many images already binarized to 1-bit by other software of hardware operations.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


BinarizeMode Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

BinarizeMode Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : BinarizeMode Enumeration

Option values used to determine what Processor.Binarize functionality to use.

Members

Member | Description
QuickText | 0 - Produces a clean 1-bit image for viewing and storage. This is generally used for document type images consisting of dark text and lines on a white or gray background. The result of the operation is to replace the text and lines in the image by black and the background by white. The controlling parameters for this mode are: LowThreshold, HighThreshold, LCEFactor, and Blur.
PhotoHalftone | 1 - The goal of this mode is to generate a 1-bit image from color or grayscale photographic-type images, reproducing the shades of gray in the image by black and white dots of various sizes. The angle and pitch of the halftone grid are controllable.
Gray | 2 - The goal of this mode is to generate an 8-bit grayscale image from the input. Useful for scaling to gray before another Binarize call with more options.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


BorderType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

BorderType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : BorderType Enumeration (PegasusImaging.WinForms.ImagXpress9)

Option values for use with the ImageXView.BorderType property.

Members

Member | Description
None | 0 - None
Inset | 1 - Inset: sets the border to a 2-pixel wide inset border.
Raised | 2 - Raised border
Flat | 3 - Flat: sets the border to a 2-pixel wide black border.
RaisedResizer | 4 - Raised resizer handles.
InsetResizer | 5 - Inset resizer handles.
InsetThickResizer | 6 - Thick inset resizer handles.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ButtonStyle Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ButtonStyle Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : ButtonStyle Enumeration

Option values to indicate button display style.

Members

Member | Description
Inset | 0 - The button appear inset.
Raised | 1 - The button appears raised.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ByteOrder Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ByteOrder Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : ByteOrder Enumeration (PegasusImaging.WinForms.ImagXpress9)

Option values used to specify the TIFF file byte order.

Members

Member | Description
Default | 0 - The byte order from the original image if it was a TIFF format.
Intel |
Motorola |

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


CadFileType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CadFileType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : CadFileType Enumeration

Option values which determine the CAD file type.

Members

Member | Description
Filetype_Unknown | -1 - Unknown file type.
FiletypeDwg | 0 - DWG (AutoCAD drawing) file type.
FiletypeDxf | 1 - DXF (AutoCAD Data Exchange File) file type.
FiletypeDxb | 2 - DXB (AutoCAD Database) file type.
FiletypeDwf | 3 - DWF (AutoCAD) file type.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


CadUnit Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CadUnit Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : CadUnit Enumeration

Option values which determine the CAD (Computer Aided Design) units of measure.

Members

Member | Description
Undefined | 0 - Undefined.
Inches | 1 - Inches.
Feet | 2 - Feet.
Miles | 3 - Miles.
Millimeters | 4 - Millimeters.
Centimeters | 5 - Centimeters.
Meters | 6 - Meters.
Kilometers | 7 - Kilometers.
Microinches | 8 - Microinches.
Mils | 9 - Mils.
Yards | 10 - Yards.
Angstroms | 11 - Angstroms.
Nanometers | 12 - Nanometers.
Microns | 13 - Microns.
Decimeters | 14 - Decimeters.
Dekameters | 15 - Dekameters.
Hectometers | 16 - Hectometers.
Gigameters | 17 - Gigameters.
Astronomical | 18 - Astronomical.
LightYears | 19 - Light years.
Parsecs | 20 - Parsecs.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


CadVersion Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CadVersion Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : CadVersion Enumeration

Option values which determine the CAD version.

Members

Member | Description
Version0v0 | 0 - No version.
Version1v2 | 1 - 1v2
Version1v40 | 2 - Version 1v40.
Version1v50 | 3 - Version 1v50.
Version2v20 | 4 - Version 2v20.
Version2v10 | 5 - Version 2v10.
Version2v21 | 6 - Version 2v21.
Version2v22 | 7 - Version 2v22.
Version1001 | 8 - Version 1001.
Version1002 | 9 - Version 1002.
Version1003 | 10 - Version 1003.
Version1004 | 11 - Version 1004.
Version1005 | 12 - Version 1005.
Version1006 | 13 - Version 1006.
Version1007 | 14 - Version 1007.
Version1008 | 15 - Version 1008.
Version1009 | 16 - Version 1009.
Version1010 | 17 - Version 1010.
Version1011 | 18 - Version 1011.
Version1012 | 19 - Version 1012.
Version1013 | 20 - Version 1013.
Version1014 | 21 - Version 1014.
Version1500 | 22 - Version 1500.
Version1015 | 23 - Version 1015.
Version1800a | 24 - Version 1800a.
Version1800 | 25 - Version 1800.
Version2100a | 26 - Version 2100a.
Version1021 | 27 - Version 1021.
VersionUnknown | 32766 - Version unknown.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ClipboardFormat Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ClipboardFormat Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : ClipboardFormat Enumeration

Option values of possible formats to use with the clipboard.

Members

Member | Description
Dib | 0 - DIB (Device Independant Bitmap) format.
Bitmap | 1 - GDI HBitmap format.
All | 2 - Both the HBitmap and DIB formats.

Remarks

The default value is Dib.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ColorSpace Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ColorSpace Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : ColorSpace Enumeration (PegasusImaging.WinForms.ImagXpress9)

Option values which designate the color space.

Members

Member | Description
Rgb | 0 - Red, Green, Blue (RGB) color space.
Cmyk | 1 - Cyan, Magenta, Yellow, Black (CMYB) color space.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


Compression Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Compression Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : Compression Enumeration (PegasusImaging.WinForms.ImagXpress9)

Option values which determine the image compression type.

Members

Member | Description
Unknown | -1 - Unknown compression format.
NoCompression | 0 - No compression.
Native | 0 - Native file compression format.
Rle | 1 - Run length encoding.
Lzw | 2 - Lempel, Ziv, Welch compression algorithm.
PackBits | 3 - Apple Macintosh PackBits compression.
Deflate | 4 - Lossless compression standard derived from LZ77.
Group3Fax1d | 5 - CCITT Group 3 one-dimensional fax compression.
Group3Fax2d | 6 - CCITT Group 3 two-dimensional standard fax compression.
Group4 | 7 - CCITT Group 4 fax compression.
Jpeg | 8 - JPEG compression format.
Jpeg7 | 9 - JPEG7 compression format.
Jbig2 | 10 - JBIG2 compression format.
Jpeg2000 | 11 - JPEG2000 compression format.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ContrastMethod Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ContrastMethod Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : ContrastMethod Enumeration (PegasusImaging.WinForms.ImagXpress9)

Option values used to determine which Processor.ContrastMethod property value to use.

Members

Member | Description
DefaultContrast | 0 - Use the Processor.ContrastMethod property.
ViewCompatibleContrast | 1 - Use the Processor.ContrastMethod property setting.

Remarks

The default value is DefaultContrast.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


CropType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CropType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : CropType Enumeration

Option values which indicate what type of crop to perform.

Members

Member | Description
CropBorderBackgroundColor | 0 - Crop borders that are the same color as the image background.
CropBorderForegroundColor | 1 - Crop borders that are the same color as the image foreground.
CropBorderBlackColor | 2 - Crop black borders.
CropBorderWhiteColor | 3 - Crop white borders.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


DebugErrorLevel Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace | DebugErrorLevel Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DebugErrorLevel Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : DebugErrorLevel Enumeration (PegasusImaging.WinForms.ImagXpress9)

Option value which determine the error level of items to place into the debug log.

Members

Member | Description
Production | Place minimal information into the debug log file.
Development | Place information into the debug log file that is useful during normal development using this toolkit.
Detailed | Place as much information into the debug log file as possible. You should use this option when you are tracking down a problem.

Remarks

The default value is Production.

This enumeration allows you to specify the amount of detail to place into the debug log file.

Use these values with the ImagXpress.DebugErrorLevel property.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace | DebugErrorLevel Property


DefectType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DefectType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : DefectType Enumeration

Option values to indicate the defect type to process.

Members

Member | Description
LightDefect | 0 - A light defect is to be removed.
DarkDefect | 1 - A dark defect is to be removed.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


DeskewType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DeskewType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : DeskewType Enumeration

Option values to indicate deskew settings for image correction.

Members

Member | Description
Normal | 0 - Normal
AdjustSize | 1 - The image size grows or shrinks.
PreserveCrop | 2 - The image stays the same size, a rotated image is cropped to original dimensions.
PreserveResize | 3 - The image stays the same size, a rotated image is resized to the original dimensions using the version of the Processor.Resize(Size,ResizeType) method that favors speed.
PreserveResample | 4 - The image stays the same size, a rotated image is resized to the original dimensions using a resampling method.
PreserveResizeQuality | 5 - The image stays the same size, a rotated image is resized to the original dimensions using the version of Processor.Resize(Size,ResizeType) method that favors quality.
PhotoCrop | 6 - A special deskew routine specifically for color images.

Remarks

The default value is Normal.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


DisplayMode Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DisplayMode Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : DisplayMode Enumeration (PegasusImaging.WinForms.ImagXpress9)

Option values indicating the maximum color depth used to render an image.

Members

Member | Description
TrueColor | 0 - 24-bit images rendered at the maximum color depth supported by the current display setting.
PaletteColor | 1 - 256 color (8-bit) images rendered using 256 colors, unless the current display setting is 16 colors.
VgaColor | 2 - 16 color (4-bit) images rendered using 16 colors.

Remarks

The default value is TrueColor.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


DitherType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

DitherType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : DitherType Enumeration

Option values used to determine the dither type to perform.

Members

Member | Description
NoDither | 0 - None
Floyd | 1 - Floyd-Steinberg
Ordered | 2 - Ordered
Pegasus | 3 - Pegasus
BinarizeQuickText | 4 - Binarize quick text
BinarizePhotoHalftone | 5 - Binzarize photo halftone

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


EnhancementDirection Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

EnhancementDirection Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : EnhancementDirection Enumeration

Option values used to determine enhancement direction.

Members

Member | Description
All | 0 - Enhance all directions.
Left | 1 - Enhance left.
Right | 2 - Enhance right.
Up | 3 - Enhance up.
Down | 4 - Enhance down.
LeftUp | 5 - Enhance left and up.
LeftDown | 6 - Enhance left and down.
RightUp | 7 - Enhance right and up.
RightDown | 8 - Enhance right and down.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


EvaluationMode Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

EvaluationMode Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : EvaluationMode Enumeration (PegasusImaging.WinForms.ImagXpress9)

Option values that indicate ImagXpress behavior when installed on a development machine when in evaluation mode.

Members

Member | Description
Automatic | 0 - When running under an IIS server, a watermark and all images passed through the component are watermarked, otherwise, the component regularly displays a dialog box stating it is in Trial Licensing mode.
Watermark | 1 - All images opened in ImagXpress are permanently watermarked with the words Pegasus Imaging.

Remarks

The default value is Automatic.

In order to test the component in an application running as a service or other environments where the component does not have permissions to create a window, the application sets the EvaluationMode to Watermark. The component does not attempt to create the Evaluation Mode dialog window, but permanently watermarks all image data passed through it.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


FtpMode Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

FtpMode Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : FtpMode Enumeration (PegasusImaging.WinForms.ImagXpress9)

Option values used for FTP (File Transfer Protocol) mode.

Members

Member | Description
Active | 0 - Active mode
Passive | 1 - Passive mode

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


GifType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GifType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : GifType Enumeration

Option values for GIF file format.

Members

Member | Description
Gif89a | 0 - GIF89a format.
Gif87a | 1 - GIF87a format.

Remarks

The version number identifies the minimum set of capabilities necessary to a decoder to fully process the contents of the data stream. Version numbers refer to dates: "87a" - May 1987, "89a" - July 1989. GIF89a format contains text, which is not part of the actual graphics in the GIF data stream.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


GrayMode Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

GrayMode Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : GrayMode Enumeration (PegasusImaging.WinForms.ImagXpress9)

Option values to indicate the type of Gray Mode to utilize.

Members

Member | Description
Standard | 0 - Use the simple linear method to level the image.
Medical | 1 - Use the DICOM standard method to level the image.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


HdpPostProcessFilter Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

HdpPostProcessFilter Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : HdpPostProcessFilter Enumeration

Open option filtering on Hdp files

Members

Member | Description
None | 0 - No Filter
Light | 1 - Light Filter
Medium | 2- Medium Filter
Strong | 3 - Strong Filter
VeryStrong | 3 - Very Strong Filter

Remarks

The default value is None

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


HdpSubSampling Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

HdpSubSampling Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : HdpSubSampling Enumeration

Option values for subsampling type for a Hdp file format.

Members

Member | Description
ChromaSubSampling400 | 1 - No Color.
ChromaSubSampling420 | 2 - 2 to 1 vertical subsampling.
ChromaSubSampling422 | 3 - 2 to 1 horizontal subsampling.
ChromaSubSampling444 | 4 - No subsampling.

Remarks

The default value is ChromaSubSampling444.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ImageStatus Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageStatus Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageStatus Enumeration

Option values which specify the status of an image.

Members

Member | Description
Empty | 0 - No image.
Defined | 1 - Image file set.
Opened | 2 - Image file opened.
Decoded | 4 - Image decoded.
Decoding | 8 - Image being decoded.
Error | 268435456 - Image error.
Wait | 16 - Operation in process.
Canceled | 32 - Image process is cancelled.
Shutdown | 64 - Application shutdown.
ImageProcessing | 256 - The image is being processed.
ImageProcessed | 512 - The image process is complete.
Saving | 1024 - The image is being saved.
Saved | 2048 - The image save is complete.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXFormat Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXFormat Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXFormat Enumeration

Option values which specify the file format.

Members

Member | Description
Unknown | 0 - Unknown format.
Default | 0 - Default file format.
Bmp | 1 - OS/2 or Windows Bitmap.
Tiff | 2 - Tagged image file format (Tiff).
Pdf | 3 - Portable Document format.
Jpeg | 4 - JPG, JIF Compliant JPEG format.
Exif | 5 - JPG, EXIF format.
Modca | 6 - MOD:CA format
Cals | 7 - Computer Aided Acquisition and Logistics Support Raster format.
LosslessJpeg | 8 - Lossless JPEG (LJP file extension).
JpegLs | 9 - JPEG-LS format.
Pic | 10 - Pegasus Imaging Corporation (PIC) format.
Epic | 11 - Pegasus enhanced format.
Gif | 12 - CompuServe Graphics Interchange Format.
Png | 13 - Portable Network Graphics format.
Tga | 14 - Truevision Targa format.
Pcx | 15 - ZSoft format.
Dcx | 16 - ZSoft multiple page file format.
Dib | 17 - Device Independent Bitmap (DIB) format.
Wpg | 18 - WordPerfect Graphic file format.
Wmf | 19 - Windows Metafile format.
Emf | 20 - Microsoft Enhanced Metafile format.
Jpeg2000 | 21 - JPEG 2000 format.
Jpeg2000Headless | 22 - JPEG 2000 without header.
WirelessBmp | 23 - Wireless Bitmap (WBMP extension).
Ico | 24 - Windows icon.
Ppm | 25 - Portable Pixmap.
Pgm | 26 - Portable Graymap.
Pbm | 27 - Portable Bitmap.
Eps | 28 - Encapsulated Image.
Wavelett | 29 - WVF file.
Wsq | WSQ fingerprint file.
Pcd | 31 - Kodak photo CD format.
Raw | 32 - RAW file format.
Jbig2 | 33 - JBig2 file format.
CameraRaw | 34 - Camera Raw format.
Cad | 35 - Computer Aided Design format.
HdPhoto | 36 - Microsoft Hd Photo format
Ioca | 37 - IOCA format - like MODCA but compact data. Note: When performing a 'Save As' with this format, a MODCA is written which is a wrapper around the IOCA format.

Remarks

The default value is Default.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXPixelFormat Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXPixelFormat Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXPixelFormat Enumeration

Option values which determine the pixel formats currently being used.

Members

Member | Description
Dib | 0x00000001 - Device independent bitmap.
Raw | 0x00000002 - RAW image format.
BigEndian | 0x00000004 - Motorola byte order format.
TopDown | 0x00000008 - Top down bitmap format.
Signed | 0x00000010 - Signed byte order format.
Gray | 0x00000020 - Grey scale image.
HighGray | 0x00000040 - DICOM Medical standard grey scale image format.
Alpha | 0x00000080 - Alpha channel.
Rgb | 0x00000100 - Red, Green, Blue byte order format.
Rgb555 | 0x00000400 - RGB555 byte order format.
Rgb565 | 0x00000800 - RGB565 byte order format.
Argb | 0x00001000 - Alpha, red, green, blue byte order format.
ColorMapped | 0x00010000 - 8 bit colormapped format.
Cmyk | 0x00020000 - Cyan, yellow, magenta, black color format
Compressed | 0x00100000 - Compressed image format.
NonInterleaved | 0x00200000 - Non-interleaved image format.
NoDibPad | 0x00400000 - DIB without padding.

Remarks

These values may be combined.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXViewBorderStyle Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXViewBorderStyle Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXViewBorderStyle Enumeration

Option values for use with the ImageXView.BorderStyle property.

Members

Member | Description
None | 0 - None: No border.
FixedSingle | 1 - FixedSingle: A single-line border.
Fixed3D | 2 - Fixed3D: A three-dimensional border.
Fixed3DRaised | 3 - Fixed3DRaised: A three-dimensional raised border.
Size3D | 4 - Size3D: A three-dimensional border that can be sized.
Size3DRaised | 5 - Sized3DRaised: A three-dimensional raised border that can be sized.
Size3DThick | 6 - Size3DThick: A thicker three-dimensional border.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


Jbig2EncodeModeCompression Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Jbig2EncodeModeCompression Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : Jbig2EncodeModeCompression Enumeration

Option values used to specify the encoding mode to use when creating the Jbig2 file.

Members

Member | Description
AutoDetect | 0 - Lossless Generic_MQ
LosslessGenericMq | 1 - Fast, great lossless compression which uses MQ arithmetic coding. Use this option for any content.
LosslessGenericMmr | 2 - Fast, very good lossless compression similar to G4 coding, uses Huffman/MMRcoding. Use this option for any content.
LosslessTextMq | 3 - Great lossless compression possible which uses MQ arithmetic coding. Use this option for text or symbols.
LosslessTextMmr | 4 - Very good lossless compression which uses Huffman/MMR coding. Use this option for text or symbols.
LosslessTextSpmMq | 5 - The best lossless compression for text and symbols. This option uses MQ arithmetic coding.
LosslessTextSpmMmr | 6 - The best lossless compression for text and symbols. This option uses Huffman/MMR coding plus MQ arithmetic coding.
LossyTextMq | 7 - Great lossy compression for text or symbols. This option uses MQ arithmetic coding.
LossyTextMmr | 8 - Very good lossy compression for text or symbols. This option uses Huffman/MMR coding.
LossyHalftoneMq | 9 - Good lossy compression for halftones. This option uses MQ arithmetic coding.
LossyHalftoneMmr | 10 - Good lossy compression for halftones. This option uses Huffman/MMR coding.

Remarks

The default value is AutoDetect.

Text regions can be encoded as lossless or as lossy according to the encodin mode specified. The lossy modes use the value in the Compression enumeration to control how loose to be when matching symbols and thereby increase compression and reduce file size. Compression means loss and a higher consequence of higher compression is an increased risk of errors in the reconstructed image.

Specify a larger value of looseness to reduce the compressed file size; use a smaller value to reduce the errors, if any. Halftone regions can be encoded lossy by specifying one of the lossy halftone encoding modes. Alternatively, they can be encoded lossless by using the lossless generic encoding mode.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


Jbig2FileOrganization Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Jbig2FileOrganization Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : Jbig2FileOrganization Enumeration

Option values used to specify the file organization of the Jbig2 bit stream.

Members

Member | Description
Default | 0 - Default, sequential organization.
Sequential | 1 - Sequential organization.
RandomAccess | 2 - Random access organization.

Remarks

The default value is Default.

A JBIG2 file may be organized in two ways: sequential or random access. Sequential organization is intended for streaming applications, where the decoder reads and decodes the file in order as the data is received. Random access organization permits the decoder to know the entire file structure, without having to read the entire file, and then uses that information to access the required data in a random-access fashion. This organization is useful for applications such as decoding only odd-number pages.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


JoinType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

JoinType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : JoinType Enumeration

Option values used to determine what type of Processor.ColorJoin(JoinType,IntPtr,IntPtr,IntPtr,IntPtr) method to use.

Members

Member | Description
Rgb | 0 - Join red, green, and blue image components.
Hsl | 1 - Join hue, saturation, and luminance image components.
Cmy | 2 - Join cyan, magenta, and yellow image components.
Cmyk | 3 - Join cyan, magenta, yellow, and black image components.
Argb | 4 - Join alpha, red, green, and blue image components.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


Jp2Type Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Jp2Type Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : Jp2Type Enumeration

Option values used to determine JP2 file types.

Members

Member | Description
Lossy | 0 - Lossy image compression format.
Lossless | 1 - Lossless image compression format.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


LicenseEditionType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace | LicenseEditionChoice Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LicenseEditionType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : LicenseEditionType Enumeration

Options used to determine what type of user license agreement under which ImagXpress is operating.

Members

Member | Description
ImagXpressStandard | Standard edition license
ImagXpressView | View edition license
ImagXpressDocument | Document edition license
ImagXpressPhoto | Photo edition license

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace | LicenseEditionChoice Property


LicenseStatus Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LicenseStatus Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : LicenseStatus Enumeration (PegasusImaging.WinForms.ImagXpress9)

Options for the status of the license.

Members

Member | Description
NoLicense | 0 - No license
EvaluationLicense | 1 - Evaluation license
LegalLicense | 2 - Legal license

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


LjpMethod Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LjpMethod Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : LjpMethod Enumeration

Lossless Jpeg Compression Method

Members

Member | Description
Jpeg | 0 - Image data is compressed in Jpeg
Loco | 1 - Image data is compressed in favor of Continuous Tones format.
Ppmd | 2 - IMSTAR Compression

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


LjpType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LjpType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : LjpType Enumeration

Option values used to specify the type of compression used for saving a lossless JPEG file.

Members

Member | Description
Rgb | 0 - Image data is compressed in RGB (Red Green Blue) format.
Ycbcr | 1 - Image data is compressed in YCBCR format.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


LoadMode Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

LoadMode Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : LoadMode Enumeration (PegasusImaging.WinForms.ImagXpress9)

Option values used to indicate the LoadOptions.LoadMode property.

Members

Member | Description
Normal | 0 - Standard image format.
Raw | 1 - RAW image format.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


MedicalPhotometricInterpretation Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

MedicalPhotometricInterpretation Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : MedicalPhotometricInterpretation Enumeration

Option values used to determines whether a zero in the image data is black or white.

Members

Member | Description
Monochrome1 | 0 - Positive image, 0 is white.
Monochrome2 | 1 - Negative image, 0 is black.

Remarks

Use the Medical.PhotometricInterpretation property only when DICOM specific information is available. Also, the GrayMode enumeration value must be set to Medical.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


MergeSize Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

MergeSize Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : MergeSize Enumeration

An enumeration used to determine the area/size the merge image is to be.

Members

Member | Description
Crop | 0 - The merge image is cropped to the size of the existing image or to the area specified by the Processor.SetArea method.
ResizeArea | 1 - The merge area is resized to the size of the merge image.
ResizeImage | 2 - The merge image is resized to the size of the current image or to the area specified by the Processor.SetArea method.
TileImage | 3 - The merge image is tiled to the size of the current image or to the area specified by the Processor.SetArea method.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


MergeStyle Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

MergeStyle Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : MergeStyle Enumeration

Option values used to specify the style of the merge.

Members

Member | Description
Normal | 0 - Pixels are merged with the existing image.
IfDarker | 1 - Merges only pixels darker than the ones in the existing image.
IfLighter | 2 - Merges only pixels lighter than the ones in the existing image.
Additive | 3 - Pixel values are added to the pixels in the existing image.
Subtractive | 4 - Pixel values are subtracted from the pixels in the existing image.
Superimpose | 5 - The image is superimposed onto the existing image. High merge superimposed image is lighter than the right side. The high or low merge percentage determines the intensity range of the superimposition.
SuperimposeLeftToRight | 6 - This produces a fading effect where the left side of the superimposed image is lighter than the right side. The high or low merge percentage determines the intensity range of the superimposition.
SuperimposeRightToLeft | 7 - This produces a fading effect where the right side of the superimposed image is lighter than the left side. The high or low merge percentage determines the intensity range of the superimposition.
SuperimposeVerticalToCenter | 8 - This produces a fading effect where the right and left sides of the superimposed image are lighter than the center. Merge percentage determines the intensity range of the superimposition.
SuperimposeVerticalFromCenter | 9 - This produces a fading effect where the center of the superimposed image is lighter than the right and left sides. Merge percentage determines the intensity of superimposition.
SuperimposeTopToBottom | 10 - This produces a fading effect where the top of the superimposed image is lighter than the bottom. merge percentage determines intensity of superimposition.
SuperimposeBottomToTop | 11 - This produces a fading effect where the bottom of the superimposed image is lighter than the top. Here too, the merge percentage determines intensity superimposition.
SuperimposeHorizFromCenter | 11 - This produces a fading effect where the bottom of the superimposed image is lighter than the top. Here too, the merge percentage determines the intensity of superimposition.
SuperimposeHorizToCenter | 12 - This produces a fading effect where the top and bottom of the superimposed image is lighter than the top. Here too, the merge percentage determines the intensity of the superimposition.
AlphaForeGroundOverBackGround | 13 - This produces a fading effect where the center of the superimposed image is lighter than the top and bottom. High or low merge percentage determines the intensity range f the superimposition.
AlphaBackGroundOverForeGround | 14 - The normal way of viewing a merged alpha image. The alpha channel in the foreground image is used to blend the two image together. The alpha channel contains information as to which pixels are opaque and which pixels are transparent in the image, and the degree of transparency. An opaque pixel in the foreground hides the pixel in the background image. Likewise, a transparent pixel in the foreground image lets the background pixel show through.
AlphaMostOpaque |
AlphaLeastOpaque |

Remarks

Each option contains a set of named constants to superimpose the image onto the existing image: with only dark or light pixels, by adding or subtracting pixels, by percentage, by fading from one direction or another; including from or to the center of the image.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


MouseWheelAction Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

MouseWheelAction Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : MouseWheelAction Enumeration

Option values used in determining what type of mouse wheel action to perform.

Members

Member | Description
None | 0 - No mouse wheel action.
VerticalScroll | 1 - Vertical scroll.
HorizontalScroll | 2 - Horizontal scroll.
Zoom | 3 - Zoom.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


MouseWheelAttribute Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

MouseWheelAttribute Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : MouseWheelAttribute Enumeration

Option values used to manipulate the mouse wheel.

Members

Member | Description
VerticalScroll | 0 - Vertical scroll.
HorizontalScroll | 1 - Horizontal scroll.
ZoomPercent | 2 - Zoom percent.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


Operation Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Operation Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : Operation Enumeration (PegasusImaging.WinForms.ImagXpress9)

Option values used in determining what type of image operation to perform.

Members

Member | Description
None | 0 - No operation is performed.
Flip | 1 - Flip the image vertically.
Mirror | 2 - Flip the image horizontally.
Rotate90 | 3 - Rotate the image clockwise 90 degrees.
Rotate180 | 4 - Rotate the image clockwise 180 degrees.
Rotate270 | 5 - Rotate the image clockwise 270 degrees.
Negative | 6 - Negative image.
ColorDepth24 | 7 - Color depth set to 24.
ColorDepth8 | 8 - Color depth set to 8.
ColorDepth4 | 9 - Color depth set to 4.
ColorDepth1 | 10 - Color depth set to 1.
Sharpen | 11 - Sharpen by focusing blurred regions by increasing the contrast of adjacent pixels.
Soften | 12 - Soften the image edges.
Tile | 13 - Break the image up into a series of tiles, creating an offset between the selection and the original position.
RotateAngle | 14 - Rotate the image by a specified angle.
LoadImage | 15 - Load the image.
SaveImage | 16 - Save the image.
Outline | 17 - Apply the outline effect to the image.
Mosaic | 18 - Apply mosaic effect which clumps pixels into square blocks.
Equalize | 19 - Apply the equalize effect to the image.
Median | 20 - Apply a median effect to the image.
Brightness | 21 - Apply brightness on the image.
Contrast | 22 - Apply image contrast.
Resize | 23 - Resize the image.
Crop | 24 - Crop the specified region of the image. Cropping is the process of removing portions of an image to create focus or strengthen the compostion.
Emboss | 25 - Apply an emboss effect to the image. Emboss makes a selection appear raised or stamped by converting it's fill color to gray.
Ripple | 26 - The image has an undulating pattern on a selection, like ripples on the surface of a pond.
Noise | 27 - Adds noise (pixels with randomly distributed color levels. This helps to blend a selection into the surrounding pixels.
Twist | 28 - Distort the image in a twisting motion.
MotionBlur | 29 - Blur the image in the specified direction.
ReplColors | 30 - Replicate the colors on the image.
Matrix | 31 - Apply 3x3 convolution matrix filter added.
Zoom | 32 - Modify the image to fit the ImagXpress control.
Perspective | 33 - The image has had the aspect changed for each row or column of pixels.
AdjustRgb | 34 - Adjust the color image.
Merge | 35 - Merge image with other loaded images.
Copy | 36 - Copy the specified region or image.
AdjustHsl | 37 - Adjust the image hue, saturation and luminance components.
Gamma | 38 - Lighten or darken the image depending on the specified value given.
Resample | 39 - Change the image pixel dimensions (and therefore display size).
AutoContrast | 40 - Automatically adjust the image contrast uniformly.
Solarize | 41 - A negative and a positive image blended together.
Posterize | 42 - Apply a specified number of brightness values altered. This is useful for creating special effects, such as large, flat areas in a photograph.
Parabolic | 43 - Brightness is adjusted based on either a convex or concave transform as specified.
Blend | 44 - Blend with underlying pixels in the image.
Blur | 45 - Noise eliminated where significant color transitions occur. The blur filters smooth transitions by averaging the pixels next to the hard edges of defined lines and shaded areas.
Diffuse | 46 - The image displays as though it were viewed through a soft diffusion filter.
PolynomialWarp | 47 - Distort the image to conform to a specified shape.
Swirl | 48 - Transform the image from a swirling pattern from the center of the image.
Buttonize | 49 - Add translucent bevels to the edges of it to give it the appearance of a 3D button.
Pinch | 50 - Apply pinch to the image which squeezes a selection.
Dilate | 51 - Enhance and/or fill in divets in black letters and lines.
Erode | 52 - Reduce or erase protrusions from black letters and lines.
Separate | 53 - Perform color separation on an image.
PicResize | 54 - Resize the picture.
Despeckle | 55 - Blur the selection on the image except those edges. This blurring removes noise while preserving detail.
Deskew | 56 - Correct skewing of an image.
AutoCrop | 57 - Crop the border space automatically.
CropBorder | 58 - Crop the image borders.
ColorCount | 59 - Color count.
Binarize | 60 - Modify the color palette associated with the image, setting it to two colors.
ColorJoin | 61 - Joins the color components into a full image.
RgbColorCount | 62 - Gives 3 array sets each containing 256 elements which equate to a count of red, green and blue color intensities of the image.
CreateColorImage | 63 - Create a color image from a non-color one.
CountUniqueColors | 64 - Count of the unique colors.
ApplyGrayscaleTransform | 65 - Permanently levels an 8 through 16-bit gray image to an 8-bit gray image.
RemoveRedeye | 66 - Reduces the red reflection displayed in the eyes of people from which a color flash photo image was taken.
AutoLevel | 67 - Restores and balances color quality within an image.
Unsharpen | 68 - Combines a noise-cleaning filter with a sharpening filter applied to the image.
RemoveNoise | 69 - Removes noise (pixels with randomly distributed color levels.
RemoveDust | 70 - Removes specks within color images.
RemoveScratches | 71 - Removes scratches within color images along a line.
SharpenEx | 72 - Sharpens the current DIB by applying a high pass 3x3 convolution filter selected by the user.
UnsharpenEx | Subtracts the low resolution image from a normal resolution image to create a masked image.
SoftenEx | 74 - Softens the current DIB by applying a low pass 3x3 convolution filter.
DocumentDeskew | 75 - Automatically detects and removes skew from current 1-bt depth images.
DocumentDespeckle | 76 - Detects and removes specks from the current image.
DocumentLineRemoval | 77 - Automatically detects and removes lines from the current image.
DocumentDilate | 78 - Examines pixels in the current image and expands the black ones by a given amount in a given direction.
DocumentErode | 79 - Removes the black pixels in the current image by the given amount in the given direction.
DocumentZoomSmooth | 80 - Replaces current 1-bit per pixel image with an image whose width and height have been doubled and whose pixels have been smoothed.
DocumentShear | 81 - Shears current image clockwise or counter-clockwise.
DocumentBlobRemoval | 82 - Locates and removes large black objects in images such as binder punch holes.
DocumentBlankPageDetect | 83 - Examines a rectangle on an image, determining if the page is considered blank, based on the amount of data on the page.
DocumentBorderCrop | 84 - Crops borders of documents.
AdjustColorBalance | 85 - Correct clor balance as specified.
AdjustLightness | 86 - Adjust the image lightness as specified.
AutoColorBalance | 87 - Correct the image color balance automatically.
AutoLightness | 88 - Adjust the contrast in light and dark regions of the image separately. This is useful to bring more detail into the shadowy areas of the image, without washing out the light regions.
AutoRemoveRedeye | 89 - Remove red eye on an image.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


PaletteType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PaletteType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : PaletteType Enumeration (PegasusImaging.WinForms.ImagXpress9)

Option values used to set the palette type of the Processor.ColorDepth method.

Members

Member | Description
Optimized | 0 - The image is displayed using the best possible palette for each image.
Fixed | 1 - The image is displayed using an internal fixed palette.
Gray | 2 - The image is displayed using a gray scale palette.
PalFile | 3 - The image is displayed using a palette file.
UserDefined | 4 - The image is displayed using a user defined palette.

Remarks

When the ImageXView.PaletteType property is either PalFile or UserDefined, the Processor.LogPalette is used.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ParabolicType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ParabolicType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : ParabolicType Enumeration

Option values used to determine the type of parabolic transform to perform.

Members

Member | Description
Convex | 0 - Darkens the pixels at the high and low range of the current image's brightness spectrum. Brightens the pixels in the middle range of the current image's brightness spectrum.
Concave | 1 - Brightens the pixels at the high and low range of the current DIB's brightness spectrum. Darkens the pixels in the middle range of the current DIB's brightness spectrum.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


PerspectiveType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PerspectiveType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : PerspectiveType Enumeration

Option values used to determine the type of perspective filter to apply.

Members

Member | Description
TopToBottom | 0 - Top to bottom.
BottomToTop | 1 - Bottom to top.
LeftToRight | 2 - Left to right.
RightToLeft | 3 - Right to left.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


PortableType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PortableType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : PortableType Enumeration

Option values to determine the type of file save format.

Members

Member | Description
Binary | 0 - Files are saved in binary format.
Ascii | 1 - Files are saved in ASCII format.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


PrintType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PrintType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : PrintType Enumeration (PegasusImaging.WinForms.ImagXpress9)

Option values to determine the type of the print.

Members

Member | Description
FullImage | 0 - Print the Full Image
ViewCroppedImage | 1 - Print the image that is cropped by the ImageXView's crop rectangle
Rubberband | 2 - Print the image that is inside of the Rubberband

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ProgressionOrder Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ProgressionOrder Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : ProgressionOrder Enumeration

Option values used to determine the progression order of a JPEG 2000 file being saved.

Members

Member | Description
Default | 0 - Default progression order.
LayerResolutionComponentPosition | 1 - Layer, resolution, component, position progression order.
ResolutionLayerComponentPosition | 2 - Resolution, layer, component, position progression order.
ResolutionPositionComponentLayer | 3 - Resolution, layer, component, position progression order.
PositionComponentResolutionLayer | 4 - Position, component, resolution, layer progression order.
ComponentPositionResolutionLayer | 5 - Component, position, resolution, layer progression order.

Remarks

The progression order of the saved JPEG 2000 file is the order of the compressed image data for the layer, the component, the resolution and the position.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


RedeyeGlare Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RedeyeGlare Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : RedeyeGlare Enumeration

Option values used in the Processor.RemoveRedeye method.

Members

Member | Description
None | 0 - No glare.
Slight | 1 - Slight image glare.
Full | 2 - Strong image glare.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


RedeyePrecision Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RedeyePrecision Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : RedeyePrecision Enumeration

Option values used as parameters in the Processor.RemoveRedeye method.

Members

Member | Description
Precise | 0 - Use the precise region to reduce the red color.
Imprecise | 1 - Search the region for the specified red pixels.
ImpreciseRuddy | 2 - Search the region for the specified red pixels. Use this value if the subject's face has a rosy complexion.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


RedeyeShade Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RedeyeShade Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : RedeyeShade Enumeration

Option values used as parameters in the Processor.RemoveRedeye method.

Members

Member | Description
Normal | 0 - Normal shade.
Light | 1 - Light eye shading.
Dark | 2 - Dark eye shading.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


RegionType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RegionType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : RegionType Enumeration

Option values that determine the type of shape a region takes.

Members

Member | Description
Rectangle | 0 - Rectangular region.
Elliptical | 1 - Elliptical region.
Polygon | 2 - Polygon region.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


RenderIntent Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RenderIntent Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : RenderIntent Enumeration

Option values for rendering colors by relative scale of spatial distnces, saturation, colors closest to inside values and distance to white point.

Members

Member | Description
Images | 0 - Gamut of image fits, shrinks or expands, and fills the destination device gamut. Spatial distances of colors are relatively scaled for all color to fit within the gamut of the device
Business | 1 - Only colors outside of gamut moved to the closest
Graphics | 2 - Preserve the color saturation at the expense of hue and lightness. Vibrant but not accurate color is produced.
AbsoluteColormetric | 3 - Similar to Business, but white point is preserved. Spatial color distance to white point changes but not the white point itself. This is an accurate view, but potentially less pleasing one.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ResizeType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ResizeType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : ResizeType Enumeration

Option values used to determine what type of resize method to perform.

Members

Member | Description
Quality | 0 - Slower but faster resampling.
Fast | 1 - Faster but slower resampling.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ResolutionUnits Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ResolutionUnits Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : ResolutionUnits Enumeration (PegasusImaging.WinForms.ImagXpress9)

Option values which determine the unit of measure for image reslution.

Members

Member | Description
NotAvailable | 0 - No absolute unit of measurement.
None | 1 - None.
Inch | 2 - Inches.
Cm | 3 - Centimeters.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


Result Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Result Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : Result Enumeration (PegasusImaging.WinForms.ImagXpress9)

Option values returned from image processing methods.

Members

Member | Description
Ok | 0 - No error.
ErrorNone | 0 - No error.
ErrorFileOpen | 1000 - Cannot find or cannot open the image file.
ErrorFormatUnknown | 1001 - The image file type is unknown or unable to read the image file type.
ErrorMemoryLock | 1002 - Cannot lock memory.
ErrorFileRead | 1003 - Error reading the file.
ErrorMemoryAlloc | 1004 - Cannot allocate memory for the image.
ErrorCreateFile | 1005 - Cannot create file.
ErrorFileWrite | 1006 - Error writing file.
ErrorNoImage | 1007 - The operation failed because the control does not have an image.
ErrorInvalidFormat | 1008 - Invalid image format.
ErrorInvalidOption | 1009 - Invalid option.
ErrorCanceled | 1010 - Image load or decompression was cancelled.
ErrorInvalidPaletteFile | 1011 - Invalid palette file.
ErrorPaletteIndexOutOfRange | 1012 - The specified palette index does not lie within the number of palette entries for the current image.
ErrorClipboardPaste | 1013 - Error pasting from clipboard.
ErrorClipboardCopy | 1014 - Error copying image to the clipboard.
ErrorInvalidPicPassword | 1015 - Attempting to read a password protected PIC file and the password in the PICPassword property does not match the password on file.
ErrorBadAngle | 1016 - The operation failed because an invalid angle was specified.
ErrorBadRadius | 1017 - The operation failed because an invalid radius was specified.
ErrorInvalidCrop | 1018 - Loading an image failed because the crop dimensions are out of range for the specified image.
ErrorInvalidPropertyValue | 1019 - Invalid property value.
ErrorInvalidFileName | 1020 - Invalid file name.
ErrorCaptureFailed | 1021 - Capture failed.
ErrorInvalidLicense | 1022 - Invalid license. Attempting to access functionality that is not covered under the license in effect.
ErrorNoLicense | 1023 - License not found.
ErrorInvalidWebIntegratorLicense | 1024 - Invalid web license.
ErrorLoadWatermarkImage | 1026 - Unable to load watermark image.
ErrorUnableToCrop | 1027 - Unable to crop.
ErrorNoWindow | 1028 - No window handle.
ErrorJpegCommentNotFound | 1029 - JPEG comment not found. The requested comment does not exist.
ErrorJpegCommentAddFailure | 1030 - Unable to add a JPEG comment.
ErrorTagNotFound | 1031 - Tag not found.
ErrorTagItemNotFound | 1032 - Tag item not found.
ErrorInvalidHandle | 1033 - Invalid window handle.
ErrorInvalidPointer | 1034 - Invalid pointer.
ErrorInvalidAreaOrRegion | 1035 - Invalid region or area.
ErrorInvalidImageId | 1036 - Invalid image ID.
ErrorNoCurrentBuffer | 1037 - No current image buffer found.
ErrorImageAccessTimeout | 1038 - Unable to access requested image.
ErrorResumeThreadFailure | 1039 - Resume thread failure.
ErrorShutdown | 1040 - Windows is shutting down.
ErrorOperationNotApplicableForRawImages | 1041 - Invalid image operation on RAW image formats.
ErrorInternalFailure | 1042 - Internal failure.
ErrorBufferAccessTimeout | 1043 - Unable to access image buffer.
ErrorEventResponse | 1044 - Event handler error.
ErrorThreadCreation | 1045 - Unable to create thread.
ErrorImageHasTasksPending | 1046 - Tasks currently in process must complete.
ErrorLoadLibraryFailForWinInet | 1047 - Library failed to load.
ErrorFtp | 1048 - FTP (File Transfer Protocol) error.
ErrorInternetInValidCA | 1049 - Invalid Internet certificate.
ErrorInternetPostIsNonSecure | 1050 - Invalid post to unsecure HTTP address.
ErrorInternetSecurityCertificateCNInvalid | 1051 - Invalid security certificate.
ErrorInternetSecurityCertificateDateInvalid | 1052 - Invalid security certificate date.
ErrorInternetHttpToHttpsOnRedirect | 1053 - Invalid HTTP to HTTPS redirect.
InternetHTTPNoConnection | 1054 - No Internet connection.
ErrorInvalidIcmProfile | 1055 - Invalid image color management profile.
ErrorMissingOrBadCmykProfile | 1056 - CMYK profile missing or corrupt.
ErrorIcmNotEnabled | 1057 - Image color management not enabled.
ErrorNoResources | 1058 - Image capture failed.
ErrorPrintNotSupported | 1059 - Printer does not support the requested function.
ErrorPrintOutOfRange | 1060 - Cannot print outside the valid printer area.
TiffTagAddError | 1061 - Unable to add tiff tag.
UnsupportedPDF | 1062 - PDF not supported.
InvalidBitDepth | 1063 - The bit depth provided is invalid.
ErrorUnableToGetAnnotations | 1064 - Unable to get annotations.
ErrorOperationNotApplicableForVirtualImages | 1065 - The operation is not applicable for virtual images.
ErrorCadFileOpenNotCalled | 1066 - Operation not valid unless CadFileOpen is first called.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


RippleDirection Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RippleDirection Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : RippleDirection Enumeration

Option values used with the Processor.Ripple method.

Members

Member | Description
Horizontal | 0 - Horizontal ripple effect.
Vertical | 1 - Vertical ripple effect.
Both | 2 - Horizontal and vertical ripple effect.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


RotateAngle Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RotateAngle Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : RotateAngle Enumeration

Option values to determine what type of rotation, mirror, or image flipping functionality to invoke.

Members

Member | Description
Rotate0 | 0 - No rotation.
Rotate90 | 1 - Rotate clockwise 90 degrees.
Rotate180 | 2 - Rotate clockwise 90 degrees.
Rotate270 | 3 - Rotate clockwise 90 degrees.
RotateFlip | 4 - Flip the image.
RotateMirror | 5 - Mirror the image.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


SeparationType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SeparationType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : SeparationType Enumeration

Option values used to determine what type of Processor.ColorSeparation(SeparationType,IntPtr,IntPtr,IntPtr,IntPtr) functionality.

Members

Member | Description
Rgb | 0 - Separate the red, green, and blue image components.
Hsl | 1 - Separate the hue, saturation, and luminance image components.
Cmy | 2 - Separate the cyan, magenta, and yellow image components.
Cmyk | 3 - Separate the cyan, magenta, yellow, and black image components.
Rgba | 4 - Separate the red, green, blue and alpha image components.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


SharpenFilter Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SharpenFilter Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : SharpenFilter Enumeration

Option values used in determining which type of Sharpen Filter to use.

Members

Member | Description
SharpenFilter1 | 0 - Sharpen filter 1.
SharpenFilter2 | 1 - Sharpen filter 2.
SharpenFilter3 | 2 - Sharpen filter 3.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ShearType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ShearType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : ShearType Enumeration

Option values used to determine the document shear direction.

Members

Member | Description
Vertical | 0 - Vertical shearing.
Horizontal | 1 - Horizontal shearing.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


SoftenFilter Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SoftenFilter Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : SoftenFilter Enumeration

Option values used in determining which type of Soften Filter to employ.

Members

Member | Description
SoftenFilter0 | 0 - Soften filter 0.
SoftenFilter1 | 1 - Soften filter 1.
SoftenFilter2 | 2 - Soften filter 2.
SoftenFilter3 | 3 - Soften filter 3.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


SubSampling Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

SubSampling Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : SubSampling Enumeration (PegasusImaging.WinForms.ImagXpress9)

Option values for subsampling type for a JPEG, TIFF-JPEG or ePIC file format.

Members

Member | Description
SubSampling111 | 0 - 1:1:1 - No subsampling.
SubSampling211 | 1 - 2:1:1 - 2 to 1 horizontal subsampling.
SubSampling411 | 2 - 4:1:1 - 2 to 1 horizontal and vertical subsampling.
SubSampling211v | 3 - 2:1:1 Vertical only - 2 to 1 vertical subsampling.

Remarks

The default value is SubSampling411.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


TagTypes Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

TagTypes Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : TagTypes Enumeration

Option values which determine the type of TIFF tag.

Members

Member | Description
Byte | 1 - Byte
Ascii | 2 - ASCII character
Short | 3 - Short
Long | 4 - Long
Rational | 5 - Rational
Sbyte | 6 - Signed byte
Undefine | 7 - 8 bit byte
Sshort | 8 - Signed short
Slong | 9 - Signed long
Srational | 10 - Signed rational
Float | 11 - Float (4 bytes)
Double | 12 - Double (8 bytes)

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ThumbnailSize Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ThumbnailSize Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : ThumbnailSize Enumeration (PegasusImaging.WinForms.ImagXpress9)

Option values used to determine the thumbnail size.

Members

Member | Description
None | 0 - None - The image is normal size.
OneQuarter | 1 - 1/4 - The image is 1/4 its normal size.
OneSixteenth | 2 - 1/16 - The image is 1/16 its normal size.
OneSixtyFourth | 3 - 1/64 - The image is 1/64 its normal size.

Remarks

The default valueis None.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


Tool Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Tool Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : Tool Enumeration (PegasusImaging.WinForms.ImagXpress9)

Option values used to determine the tool selected.

Members

Member | Description
None | 0 - No tool is selected.
ZoomIn | 1 - Zoom in tool.
ZoomOut | 2 - Zoom out tool.
ZoomRect | 3 - Zoom rectangle tool.
Hand | 4 - Image panning tool.
Magnify | 5 - Magnifying window.
Select | 6 - Window selection tool.
Pan | 7 - Panning tool.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ToolAction Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolAction Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : ToolAction Enumeration

Option values used to determine what type of tool event has occurred.

Members

Member | Description
Clicked | 0 - The tool was clicked (activated).
Begin | 1 - Begin the tool operation.
End | 2 - The tool operation is complete.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ToolAttribute Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolAttribute Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : ToolAttribute Enumeration

Option values used to determine a tool's attribute value.

Members

Member | Description
ZoomInFactor | 0 - Zoom in factor.
ZoomOutFactor | 1 - Zoom out factor.
MagFactor | 2 - Magnification factor.
MagWidth | 3 - Magnifier width value.
MagHeight | 4 - Magnifier height value.
MagShape | 5 - Magnifier shape.
MagBitmask | 6 - Magnifier bit mask.
SelectShape | 7 - Select region shape.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ToolCursor Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolCursor Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : ToolCursor Enumeration

Option values which determines the tool cursor to change.

Members

Member | Description
ToolZoomIn | 0 - ZoomIn tool cursor
ToolZoomOut | 1 - ZoomOut tool cursor
ToolZoomRect | 2 - ZoomRect tool cursor
ToolHandOpen | 3 - Hand tool open handed cursor
ToolHandClose | 4 - Hand tool close handed cursor
ToolMagnifier | 5 - Magnifier tool cursor
ToolSelect | 6 - Select tool cursor
ToolPanNorth | 7 - Pan tool North cursor
ToolPanNorthwest | 8 - Pan tool Northwest cursor
ToolPanNortheast | 9 - Pan tool Northeast cursor
ToolPanSouth | 10 - Pan tool South cursor
ToolPanSoutheast | 11 - Pan tool Southeast cursor
ToolPanSouthwest | 12 - Pan tool Southwest cursor
ToolPanEast | 13 - Pan tool Eest cursor
ToolPanWest | 14 - Pan tool West cursor
ToolPanDefault | 15 - Pan tool default cursor

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


TranslateType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

TranslateType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : TranslateType Enumeration

Option values used in determing what type of translation to perform.

Members

Member | Description
ViewToPixel | 0 - View units of measure to pixels.
PixelToView | 1 - Pixels to view units of measure.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


TransparencyMatch Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

TransparencyMatch Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : TransparencyMatch Enumeration (PegasusImaging.WinForms.ImagXpress9)

Option values used to determine the type of TransparencyMatch property to invoke.

Members

Member | Description
None | 0 - No transparent color.
Closest | 1 - Use the color in the image that is the closest match to the one specified in the SaveOptions class.
Exact | 2 - Use the color specified in the SaveOptions class.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


TwistRotation Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

TwistRotation Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : TwistRotation Enumeration

Option values used in evaluating the rotation angle.

Members

Member | Description
Rotate90 | 0 - Rotate block 90 degrees.
Rotate180 | 1 - Rotate block 180 degrees.
Rotate270 | 2 - Rotate block 270 degrees.
RotateRandom | 3 - Rotate block randomly.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


UnsharpenFilter Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

UnsharpenFilter Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : UnsharpenFilter Enumeration

Option values used in determining what type of Processor.Unsharpen(Int32) method to apply.

Members

Member | Description
UnsharpenFilter1 | 0 - Unsharpen filter 1.
UnsharpenFilter2 | 1 - Unsharpen filter 2.
UnsharpenFilter3 | 2 - Unsharpen filter 3.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ZoomToFitType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ZoomToFitType Enumeration

PegasusImaging.WinForms.ImagXpress9 Namespace : ZoomToFitType Enumeration

Option values to determine if the image fit is within the ImagXpress viewer control.

Members

Member | Description
FitWidth | 0 - Fit to the width of the control.
FitHeight | 1 - Fit to the height of the control.
FitBest | 2 - Fit such that the entire image appears within the control.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXView.AutoResizeChangedEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
A Object that fired the event.
e
The ZoomFactorChangedEventArgs which contains information about the event.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXView.AutoResizeChangedEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXView.AutoResizeChangedEventHandler Delegate

A handler for the auto resize changed event.

[Visual Basic]
Public Delegate Sub ImageXView.AutoResizeChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As AutoResizeChangedEventArgs _
)
[C#]
public delegate void ImageXView.AutoResizeChangedEventHandler(
   object sender,
   AutoResizeChangedEventArgs e
);
[C++]
public: __gc __delegate void ImageXView.AutoResizeChangedEventHandler(
   Object* sender,
   AutoResizeChangedEventArgs* e
)
[C++/CLI]
public delegate void ImageXView.AutoResizeChangedEventHandler(
   Object^ sender,
   AutoResizeChangedEventArgs^ e
)

Parameters

sender
A Object that fired the event.
e
The ZoomFactorChangedEventArgs which contains information about the event.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXView.PaintImageEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
A Object that fired the event.
e
The PaintImageEventArgs which contains information about the event.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXView.PaintImageEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXView.PaintImageEventHandler Delegate

A handler for the paint event.

[Visual Basic]
Public Delegate Sub ImageXView.PaintImageEventHandler( _
   ByVal sender As Object, _
   ByVal e As PaintImageEventArgs _
)
[C#]
public delegate void ImageXView.PaintImageEventHandler(
   object sender,
   PaintImageEventArgs e
);
[C++]
public: __gc __delegate void ImageXView.PaintImageEventHandler(
   Object* sender,
   PaintImageEventArgs* e
)
[C++/CLI]
public delegate void ImageXView.PaintImageEventHandler(
   Object^ sender,
   PaintImageEventArgs^ e
)

Parameters

sender
A Object that fired the event.
e
The PaintImageEventArgs which contains information about the event.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXView.PrintImageEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
A Object that fired the event.
e
The PrintImageEventArgs which contains information about the event.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXView.PrintImageEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXView.PrintImageEventHandler Delegate

Handler for the print image event.

[Visual Basic]
Public Delegate Sub ImageXView.PrintImageEventHandler( _
   ByVal sender As Object, _
   ByVal e As PrintImageEventArgs _
)
[C#]
public delegate void ImageXView.PrintImageEventHandler(
   object sender,
   PrintImageEventArgs e
);
[C++]
public: __gc __delegate void ImageXView.PrintImageEventHandler(
   Object* sender,
   PrintImageEventArgs* e
)
[C++/CLI]
public delegate void ImageXView.PrintImageEventHandler(
   Object^ sender,
   PrintImageEventArgs^ e
)

Parameters

sender
A Object that fired the event.
e
The PrintImageEventArgs which contains information about the event.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXView.ResizedEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
A Object that fired the event.
e
The ResizedEventArgs which contains information about the event.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXView.ResizedEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXView.ResizedEventHandler Delegate

A handler for the resized event.

[Visual Basic]
Public Delegate Sub ImageXView.ResizedEventHandler( _
   ByVal sender As Object, _
   ByVal e As ResizedEventArgs _
)
[C#]
public delegate void ImageXView.ResizedEventHandler(
   object sender,
   ResizedEventArgs e
);
[C++]
public: __gc __delegate void ImageXView.ResizedEventHandler(
   Object* sender,
   ResizedEventArgs* e
)
[C++/CLI]
public delegate void ImageXView.ResizedEventHandler(
   Object^ sender,
   ResizedEventArgs^ e
)

Parameters

sender
A Object that fired the event.
e
The ResizedEventArgs which contains information about the event.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXView.ScrollbarVisibleChangedEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
A Object that fired the event.
e
The ScrollbarVisibleChangedEventArgs which contains information about the event.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXView.ScrollbarVisibleChangedEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXView.ScrollbarVisibleChangedEventHandler Delegate

Fires when the scrollbar visible changed event occurs.

[Visual Basic]
Public Delegate Sub ImageXView.ScrollbarVisibleChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As ScrollbarVisibleChangedEventArgs _
)
[C#]
public delegate void ImageXView.ScrollbarVisibleChangedEventHandler(
   object sender,
   ScrollbarVisibleChangedEventArgs e
);
[C++]
public: __gc __delegate void ImageXView.ScrollbarVisibleChangedEventHandler(
   Object* sender,
   ScrollbarVisibleChangedEventArgs* e
)
[C++/CLI]
public delegate void ImageXView.ScrollbarVisibleChangedEventHandler(
   Object^ sender,
   ScrollbarVisibleChangedEventArgs^ e
)

Parameters

sender
A Object that fired the event.
e
The ScrollbarVisibleChangedEventArgs which contains information about the event.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXView.ScrollEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
A Object that fired the event.
e
The ScrollEventArgs which contains information about the event.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXView.ScrollEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXView.ScrollEventHandler Delegate

A handler for the scroll event.

[Visual Basic]
Public Delegate Sub ImageXView.ScrollEventHandler( _
   ByVal sender As Object, _
   ByVal e As ScrollEventArgs _
)
[C#]
public delegate void ImageXView.ScrollEventHandler(
   object sender,
   ScrollEventArgs e
);
[C++]
public: __gc __delegate void ImageXView.ScrollEventHandler(
   Object* sender,
   ScrollEventArgs* e
)
[C++/CLI]
public delegate void ImageXView.ScrollEventHandler(
   Object^ sender,
   ScrollEventArgs^ e
)

Parameters

sender
A Object that fired the event.
e
The ScrollEventArgs which contains information about the event.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXView.ToolbarCloseEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
A Object that fired the event.
e
The ToolbarCloseEventArgs which contains information about the event.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXView.ToolbarCloseEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXView.ToolbarCloseEventHandler Delegate

Handler for the toolbar close event.

[Visual Basic]
Public Delegate Sub ImageXView.ToolbarCloseEventHandler( _
   ByVal sender As Object, _
   ByVal e As ToolbarCloseEventArgs _
)
[C#]
public delegate void ImageXView.ToolbarCloseEventHandler(
   object sender,
   ToolbarCloseEventArgs e
);
[C++]
public: __gc __delegate void ImageXView.ToolbarCloseEventHandler(
   Object* sender,
   ToolbarCloseEventArgs* e
)
[C++/CLI]
public delegate void ImageXView.ToolbarCloseEventHandler(
   Object^ sender,
   ToolbarCloseEventArgs^ e
)

Parameters

sender
A Object that fired the event.
e
The ToolbarCloseEventArgs which contains information about the event.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXView.ToolbarContextMenuSelectEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
A Object that fired the event.
e
The ToolbarContextMenuEventArgs which contains information about the event.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXView.ToolbarContextMenuSelectEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXView.ToolbarContextMenuSelectEventHandler Delegate

A handler for the toolbar context menu select event.

[Visual Basic]
Public Delegate Sub ImageXView.ToolbarContextMenuSelectEventHandler( _
   ByVal sender As Object, _
   ByVal e As ToolbarContextMenuEventArgs _
)
[C#]
public delegate void ImageXView.ToolbarContextMenuSelectEventHandler(
   object sender,
   ToolbarContextMenuEventArgs e
);
[C++]
public: __gc __delegate void ImageXView.ToolbarContextMenuSelectEventHandler(
   Object* sender,
   ToolbarContextMenuEventArgs* e
)
[C++/CLI]
public delegate void ImageXView.ToolbarContextMenuSelectEventHandler(
   Object^ sender,
   ToolbarContextMenuEventArgs^ e
)

Parameters

sender
A Object that fired the event.
e
The ToolbarContextMenuEventArgs which contains information about the event.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXView.ToolbarEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
A Object that fired the event.
e
The ToolbarEventArgs which contains information about the event.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXView.ToolbarEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXView.ToolbarEventHandler Delegate

Handler for the toolbar event.

[Visual Basic]
Public Delegate Sub ImageXView.ToolbarEventHandler( _
   ByVal sender As Object, _
   ByVal e As ToolbarEventArgs _
)
[C#]
public delegate void ImageXView.ToolbarEventHandler(
   object sender,
   ToolbarEventArgs e
);
[C++]
public: __gc __delegate void ImageXView.ToolbarEventHandler(
   Object* sender,
   ToolbarEventArgs* e
)
[C++/CLI]
public delegate void ImageXView.ToolbarEventHandler(
   Object^ sender,
   ToolbarEventArgs^ e
)

Parameters

sender
A Object that fired the event.
e
The ToolbarEventArgs which contains information about the event.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXView.ToolbarOpenEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
A Object that fired the event.
e
The ToolbarOpenEventArgs which contains information about the event.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXView.ToolbarOpenEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXView.ToolbarOpenEventHandler Delegate

Handler for the toolbar open event.

[Visual Basic]
Public Delegate Sub ImageXView.ToolbarOpenEventHandler( _
   ByVal sender As Object, _
   ByVal e As ToolbarOpenEventArgs _
)
[C#]
public delegate void ImageXView.ToolbarOpenEventHandler(
   object sender,
   ToolbarOpenEventArgs e
);
[C++]
public: __gc __delegate void ImageXView.ToolbarOpenEventHandler(
   Object* sender,
   ToolbarOpenEventArgs* e
)
[C++/CLI]
public delegate void ImageXView.ToolbarOpenEventHandler(
   Object^ sender,
   ToolbarOpenEventArgs^ e
)

Parameters

sender
A Object that fired the event.
e
The ToolbarOpenEventArgs which contains information about the event.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXView.ToolEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
A Object that fired the event.
e
The ToolEventArgs which contains information about the event.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXView.ToolEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXView.ToolEventHandler Delegate

Handler for the tool event.

[Visual Basic]
Public Delegate Sub ImageXView.ToolEventHandler( _
   ByVal sender As Object, _
   ByVal e As ToolEventArgs _
)
[C#]
public delegate void ImageXView.ToolEventHandler(
   object sender,
   ToolEventArgs e
);
[C++]
public: __gc __delegate void ImageXView.ToolEventHandler(
   Object* sender,
   ToolEventArgs* e
)
[C++/CLI]
public delegate void ImageXView.ToolEventHandler(
   Object^ sender,
   ToolEventArgs^ e
)

Parameters

sender
A Object that fired the event.
e
The ToolEventArgs which contains information about the event.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXView.ZoomFactorChangedEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
A Object that fired the event.
e
The ZoomFactorChangedEventArgs which contains information about the event.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXView.ZoomFactorChangedEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXView.ZoomFactorChangedEventHandler Delegate

A handler for the zoom factor event.

[Visual Basic]
Public Delegate Sub ImageXView.ZoomFactorChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As ZoomFactorChangedEventArgs _
)
[C#]
public delegate void ImageXView.ZoomFactorChangedEventHandler(
   object sender,
   ZoomFactorChangedEventArgs e
);
[C++]
public: __gc __delegate void ImageXView.ZoomFactorChangedEventHandler(
   Object* sender,
   ZoomFactorChangedEventArgs* e
)
[C++/CLI]
public delegate void ImageXView.ZoomFactorChangedEventHandler(
   Object^ sender,
   ZoomFactorChangedEventArgs^ e
)

Parameters

sender
A Object that fired the event.
e
The ZoomFactorChangedEventArgs which contains information about the event.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ImagXpress.ImageStatusEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
A Object that fires the event.
e
A ImageStatusEventArgs object.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpress.ImageStatusEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace : ImagXpress.ImageStatusEventHandler Delegate

Fires when there are image status events.

[Visual Basic]
Public Delegate Sub ImagXpress.ImageStatusEventHandler( _
   ByVal sender As Object, _
   ByVal e As ImageStatusEventArgs _
)
[C#]
public delegate void ImagXpress.ImageStatusEventHandler(
   object sender,
   ImageStatusEventArgs e
);
[C++]
public: __gc __delegate void ImagXpress.ImageStatusEventHandler(
   Object* sender,
   ImageStatusEventArgs* e
)
[C++/CLI]
public delegate void ImagXpress.ImageStatusEventHandler(
   Object^ sender,
   ImageStatusEventArgs^ e
)

Parameters

sender
A Object that fires the event.
e
A ImageStatusEventArgs object.

Remarks

This event handler replaces the static ImageStatusEventHandler that was in the ImageX class.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


ImagXpress.ProgressEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
A Object that fires the event.
e
A ProgressEventArgs object which contains information about the event that fired.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpress.ProgressEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace : ImagXpress.ProgressEventHandler Delegate

Fires when there is a progress event.

[Visual Basic]
Public Delegate Sub ImagXpress.ProgressEventHandler( _
   ByVal sender As Object, _
   ByVal e As ProgressEventArgs _
)
[C#]
public delegate void ImagXpress.ProgressEventHandler(
   object sender,
   ProgressEventArgs e
);
[C++]
public: __gc __delegate void ImagXpress.ProgressEventHandler(
   Object* sender,
   ProgressEventArgs* e
)
[C++/CLI]
public delegate void ImagXpress.ProgressEventHandler(
   Object^ sender,
   ProgressEventArgs^ e
)

Parameters

sender
A Object that fires the event.
e
A ProgressEventArgs object which contains information about the event that fired.

Remarks

This event handler replaces the static ProgressEventHandler that was in the ImageX class.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


Processor.ProgressEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
A Object that fired the event.
e
The ProgressEventArgs that contains information about the event.
See Also Languages PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Processor.ProgressEventHandler Delegate

PegasusImaging.WinForms.ImagXpress9 Namespace : Processor.ProgressEventHandler Delegate

A handler for the progress events.

[Visual Basic]
Public Delegate Sub Processor.ProgressEventHandler( _
   ByVal sender As Object, _
   ByVal e As ProgressEventArgs _
)
[C#]
public delegate void Processor.ProgressEventHandler(
   object sender,
   ProgressEventArgs e
);
[C++]
public: __gc __delegate void Processor.ProgressEventHandler(
   Object* sender,
   ProgressEventArgs* e
)
[C++/CLI]
public delegate void Processor.ProgressEventHandler(
   Object^ sender,
   ProgressEventArgs^ e
)

Parameters

sender
A Object that fired the event.
e
The ProgressEventArgs that contains information about the event.

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace


Glossary

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

A

Aspect Ratio
There are two kinds of aspect ratio that you need to be aware of when working with 2D images; the image aspect ratio and the pixel aspect ratio.The image aspect ratio is the ratio of the width of the image to the height of the image. It's important when resizing an image to keep this ratio as close to unchanged as possible or the image may become distorted.The pixel aspect ratio is the shape of the pixels in the image. For computers this is normally square (1:1) or close to it depending on the monitor settings. For some video sources, however, the pixels may be slightly rectangular.

B

Black on Edge
The minimum or maximum number of pixels on the vertical or horizontal edge of an image or document.

BMP
The Microsoft Windows Bitmap file format is based on the Microsoft Windows internal bitmap data structures. The BMP format is very widely used and it is quick and easy to read. Although most BMP files are uncompressed, a type of run length encoding is supported.

BPP
Bits per pixel

Brightness
A Pegasus Imaging method that enhances the brightness attributes of the pixels in the bitmap. Positive settings produce brighter pixels while negative settings produce darker pixels.

C

CAD

CAD Layer

CAD Layout

CCITT
CCITT is the most widely used compression scheme for transmitting binary (black and white) image data. CCITT was established by the International Telegraph and Telephone Consultative Committee. The Group 3 and Group 4 CCITT compression standards are widely used for transmitting fax data. CCITT compressed images are typically stored in the TIFF image format.

CIELAB
Three dimensional color space defined by the Commission Internationale de L'Eclairage, or CIE. L describes relative lightness; A represents relative redness-greenness,and B represents relative yellowness-blueness.

Container
Gets the container for the component. An object implementing the IContainer interface that represents the component's container, or a null reference (Nothing in Visual Basic) if the component does not have a site.

Contrast
An Pegasus Imaging method that enhances the contrast attributes of the pixels in the bitmap. Positive settings produce a higher contrast image while negative settings produce a lower contrast image. Images with a higher contrast have a higher frequency of pixel intensities near the ends of the intensity spectrum while images with a lower contrast have a higher frequency of pixels near the middle of the intensity spectrum.

Cosited
Specifies horizontally coincident positioning of sub-sampled chrominance components relative to luminance sample.

CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

D

DCOM
Microsoft's extension of their Component Object Model (COM) to support objects distributed across a network. DCOM is currently implemented only by Microsoft for Microsoft Windows; and by Software AG, under the name "EntireX", for Unix and IBM mainframes. DCOM serves the same purpose as IBM's DSOM protocol. DCOM is an object model, but has no provisions for inheritance.

DCX
An image format containing multiple PCX images. A DCX file can contain a maximum of 1024 images.

DDB
Microsoft Device Dependent Bitmap. The actual in-memory information used to display an image.

DEP
Data Execution Prevention (computer security)

Despeckle
A modified median filter primarily used for reducing noise in document images. Despeckling divides the image into pixel groups and uses the brightness value to adjust brightness spikes. This filter will reduce noise in a black and white document image with minimal distortion of document text.

Device Context
A device context is a structure that defines a set of graphic objects and their associated attributes, as well as the graphic modes that affect output. The graphic objects include a pen for line drawing, a brush for painting and filling, a bitmap for copying or scrolling parts of the screen, a palette for defining the set of available colors, a region for clipping and other operations, and a path for painting and drawing operations.

DIB
Microsoft Device Independent Bitmap. An alternative file extension used by the Microsoft Windows Bitmap.

DICOM
Digital Imaging and Communication, a standard for handling digital medical images.

Dispose
Releases the resources used by the Component.

Disposed
Adds an event handler to listen to the Disposed event on the component. When you create a Disposed delegate, you identify the method that handles the event.

Dithering
A technique used in computer graphics to create the illusion of varying shades of gray on a monochrome display or printer, or additional colors on a color display or printer. Dithering relies on treating areas of an image as groups of dots that are colored in different patterns. Akin to the print images called halftones, dithering takes advantage of the eye’s tendency to blur spots of different colors by averaging their effects and merging them into a single perceived shade or color. Depending on the ratio of black dots to white dots within a given area, the overall effect is of a particular shade of gray. Dithering is used to add realism to computer graphics and to soften jagged edges in curves and diagonal lines at low resolutions.

E

Emboss
A Pegasus Imaging method that causes the foreground of an image to appear raised from background. Embossing gives the image a raised metallic-like look

ePIC
Pegasus Imaging enhanced PIC image format. This high performance image compression combines the patented ELS arithmetic coder with the high performance Pegasus JPEG libraries. The result is a new and unbeatable compression technology. The ePIC compression has significant advantages over standard JPEG. Most importantly it produces smaller file sizes and decompresses extremely quickly. ePIC images can be password encrypted. These images can also be 'zoomed' or scaled to larger, arbitrary sizes.

Equalize
An Pegasus Imaging method that is a point process used for adjusting the contrast of an image. A frequency histogram of the colors of the image is computed and adjusted to equalize the colors across the full spectrum of intensity values. The equalized colors are applied to each pixel in the image.

EXIF
EXchangeable Image File format (Japan Electronic Industry Development Association, JEIDA), compressed image format used in digital cameras.

F

Flate
The lossless deflate compression algorithm is based on two other compression algorithms: huffman encoding and LZ77 compression.

Float
Denotes a simple type that stores 32-bit floating-point values.

G

Gamma
A non-linear brightness transform. Gamma values greater than 0 and less that 1.0 generate exponential curves that dim and image. Gamma values greater than 1.0 generate exponential curves that brighten an image.

Gamut
In graphics, the gamut of a monitor is the range of colours it can display. There are some colours which can't be made up of a mixture of red, green and blue phosphor emissions and so can't be displayed by any monitor.

GDI
Acronym for Graphical Device Interface. In Windows, a graphics display system used by applications to display or print bitmapped text (TrueType fonts), images, and other graphical elements. The GDI is responsible for drawing dialog boxes, buttons, and other elements in a consistent style on screen by calling the appropriate screen drivers and passing them the information on the item to be drawn. The GDI also works with GDI printers, which have limited ability to prepare a page for printing. Instead, the GDI handles that task by calling the appropriate printer drivers and moving the image or document directly to the printer, rather than reformatting the image or document in PostScript or another printer language.

GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.

GIF
Graphical Interchange File, originally developed by CompuServe as a machine independent format. GIF is one of the most popular image formats for storing 8-bit digitized images. GIF files are typically smaller than uncompressed formats like BMP due to the LZW compression algorithm that GIF uses.

Greyscale
If the pixels of a grey-scale image have N bits, they may take values from zero, representing black up to 2^N-1, representing white with intermediate values representing increasingly light shades of grey. If N=1, the image is not called grey-scale, but could be called monochrome.

H

Halftone
Pertaining to pictures in which gradation of tone in the photograph is reproduced by a graduated system of dotted and checkered spots, usually nearly invisible to the unaided eye, produced by the interposition between the camera and the object of a screen. The name alludes to the fact that this process was the first that was practically successful in reproducing the half tones of the photograph.

hDIB
Handle to a Device Independent Bitmap. An operation affecting the image may cause the hDIB before the operation to become invalid.

Hue
One of the 3 components of the HSL (Hue, Saturation and Luminance ) color space. The hue component controls the overall color space of an image. Adjusting the hue of the image adjusts the color spectrum from red through yellow, green, blue, and violet.

I

ICO
Microsoft Windows Icon file format.

Inverse
To reverse something or change it to its opposite. For example, to invert the colors on a monochrome display means to change light to dark and dark to light. In a digital electrical signal, to replace a high level by a low level and vice versa. This type of operation is the electronic equivalent of a Boolean NOT operation.

IOD
Information Object Definition.

J

JIF
An alternative image file extension used for a JFIF compliant JPEG file. Because many early versions of JPEG contained a JPG extension but did not adhere to the JFIF specifications, the JIF extension was created to identify JPEG files that are JFIF compliant. As the popularity of JPEG grew, JFIF compliance became synonymous with the JPG extension and thus the JIF extension is rarely used.

JPEG
The JPEG (Joint Photographic Experts Group) standard is one of the most important image data compression standards. It is widely used in many industries including graphic arts, desktop publishing, medical imaging, and many more. It is also becoming one of the most widely used image formats on the Internet. Although JPEG supports a lossless mode, it most commonly uses lossy compression. This allows JPEG to achieve very high compression ratios. JPEG compression uses several compression modes. First, an image is transformed to the frequency domain using the discrete cosine transform. The smaller valued frequency components are discarded leaving only the larger valued components. The remaining components are DPCM coded and then Huffman coded. Fortunately, ImagXpress® handles all of this for you! The compression level is adjustable. Higher quality settings produce a larger image file size with higher image quality. Lower quality settings produce a smaller image file size with lower image quality. Typically, we have found that compression ratios of 10:1 or 15:1 (A 640x480x24-bit image is 921,600 bytes; a 15:1 compressed image would compress to only 61k) produce generally acceptable image quality for photographic type images. Images compressed at higher ratios begin to show more noticeable and sometimes objectionable artifacts and clarity loss. JPEG is a 24-bit format and works only with 24-bit images. If you compress an 8-bit image, ImagXpress® automatically converts it to 24-bit to do the compression, however, you will obtain better quality when the source image is 24-bit because 8-bit images only contain 256 colors. JPEG works best with photographic type images. It does not work well with solid colors, 16-color images, cartoon like images, or drawings. Progressive JPEG is a multiple-scan sequential JPEG format that is becoming popular on the Internet for the ability to display images in progressively clearer segments.

L

Little-endian
Describes a computer architecture in which, within a given 16- or 32-bit word, bytes at lower addresses have lower significance (the word is stored "little-end-first"). The PDP-11/VAX families of computers, Intel microprocessors, plus a lot of communications and networking hardware, are little-endian. The term is sometimes used to describe the ordering of units other than bytes; most often, bits within a byte.

Lock
A lock, represented by the Visual Basic keyword "SyncLock Statement," or the C# keyword "lock Statement", allows a single thread of execution to obtain exclusive execution rights on an object. Although using locks will guarantee that multiple threads do not simultaneously access an object, they can cause significant performance degradation.

Luminance
One of the 3 components of the HSL (Hue, Saturation and Luminance) color space. Luminance controls the overall brightness (energy/whiteness) of an image.

LUT
Look Up Table.

LZW
Lempel-Ziv-Welch (algorithm)

M

Matrix
A matrix filter, also called convolution, alters each pixel's color based on its current color and the colors of any neighboring pixels. The ImagXpress® Matrix method uses a 3x3 matrix. The numbers in the matrix are coefficients. When a pixel is processed, its color value is multiplied by the coefficient in the center of the matrix, and any pixels within the 3x3 grid are multiplied by the corresponding coefficients in the matrix. The sum of the products becomes the target pixel's new value. The Divisor is simply the coefficient denominator. The matrix method is typically used for sharpening, softening, and edge enhancement.

Mosaic
A mosaic divides the bitmap into tiles of a specified size. All of the pixels in each tile are averaged and changed to the average color.

Multithreading
Multithreading, or free threading, refers to the ability of a program to execute multiple threads of operation simultaneously. In a single-threaded application, a user might spend idle time waiting for the calculations or database updates to finish. In a multithreaded application, these processes can proceed in the background so user time is not wasted. An example of a multithreaded application might be a program that receives user input on one thread, performs a variety of complex calculations on a second thread, and updates a database on a third thread. In a single-threaded application, a user might spend idle time waiting for the calculations or database updates to finish. In a multithreaded application, these processes can proceed in the background so user time is not wasted. Multithreading can be a powerful tool to use in component programming. By writing multithreaded components, you can create components that perform complex calculations in the background while leaving the user interface free to respond to user input. Although multithreading can be a powerful tool, it can also be difficult to apply correctly. Improperly implemented multithreaded code can degrade application performance, or even cause frozen applications. (See MSDN)

N

Negate
An ImagXpress® method that creates a color negative of an image.

Noise
An ImagXpress® method that adds random pixels to the bitmap.

O

Orthogonal
Used loosely to mean mutually independent or well separated. It describes sets of primitives or capabilities that, like linearly independent vectors in geometry, span the entire "capability space" and are in some sense non-overlapping or mutually independent. For example, in logic, the set of operators "not" and "or" is described as orthogonal, but the set "and", "or", and "not" is not (because any one of these can be expressed in terms of the others).

P

PBM
Portable bitmap image format, a very simple uncompressed 1-bit (black and white) image format. Data can be stored in either binary or ASCII format.

PGM
Portable Graymap image format. PGM is a very simple uncompressed 8-bit grayscale image format. Data can be stored in either binary or ASCII format.

Pica
A printer's unit of type size, equal to 12 points or about 1/6 of an inch. An equivalent unit of composition measurement used in determining the dimensions of lines, illustrations, or printed pages. A type size for typewriters, providing ten characters to the inch. (Probably from Medieval Latin "pica," a list of church services (perhaps from the typeface used to print it).

PNG
Portable Network Graphics (pronounced "ping") provides a portable, legally unencumbered (royalty-free), well-compressed, well-specified standard for lossless bitmapped image files. The initial motivation for developing PNG was to provide a royalty-free alternative to GIF. The design retains many of the features of GIF that make it an attractive format for transmission of images, such as lossless compression and progressive display capabilities. Additionally, it provides several advantages including 24-bit image support and generally better compression, although decompression is typically somewhat slower than GIF. PNG's success will be ultimately determined by its acceptability on the Internet. At the time of this writing, however, PNG has not been incorporated as part of the major Internet browsers.

PPM
Portable Pixmap image format, a very simple uncompressed 24-bit image format. Data is stored in RGB triplets and can be stored in either binary or ASCII format.

R

RGB
Red, Green Blue. Bitmapped images are most generally stored as RGB data. Each pixel or data point in a True color (24-bit) image contains 3 components, red, green and blue, that describe the color of the pixel. Each of the components can have a value between 0 and 255, 0 being the darkest shade of color and 255 being the lightest shade of color. Since each component can be stored in one byte (8-bits), the 3 components take up 3 bytes or 24-bits per pixel. 8-bit images contain one byte (8-bit) indexes for each pixel that map to a color table called a palette which contains a maximum of 256 RGB entries. Likewise, 4-bit images contain 4-bit indexes for each pixel that map to a palette which contains a maximum of 16 RGB entries. 1-bit images contain 1-bit per pixel. Each bit in a 1-bit image represents either black or white.

RLE
RLE stands for Run Length Encoding. It is a lossless algorithm that only offers decent compression ratios in specific types of data.

S

Saturation
One of the 3 components of the HSL (Hue, Saturation, and Luminance) color space. Saturation controls the purity of a color. Higher saturations result in richer, deeper colors. Lower saturations result in paler colors.

Scalar
In programming, any data type that stores a single value (a number or Boolean), as opposed to an aggregate data type that has many elements. A string is regarded as a scalar in some languages (PERL) and a vector of characters in others (C).

Sharpen
An ImagXpress® method that is used to sharpen an image. The sharpen filter uses a high-pass convolution matrix filter to accentuate high frequency detail in the image.

Single
Value type represents a single-precision 32-bit number with values ranging from negative 3.402823e38 to positive 3.402823e38, as well as positive or negative zero, PositiveInfinity, NegativeInfinity, and not a number (NaN).

Soften
An ImagXpress® method that is used to soften an image. The soften filter uses a low-pass convolution matrix filter to accentuate low frequency detail in the image.

Sprite
A small bitmap image, often used in animated games but also sometimes used as a synonym for icon.

sRGB
In 1996, Hewlett-Packard and Microsoft proposed a standard color space, sRGB, within Microsoft operating systems, HP products, the Internet, and all other interested vendors.

T

TGA
Targa Image File) format was developed by TrueVision for its Targa line of products. TGA is one of the earliest image formats and was the first popular format to support 24-bit color. TGA supports uncompressed and RLE compressed formats.

TIFF
Tag Image File Format, originally released by Aldus Corporation is a standard file format found in most paint, imaging, and desktop publishing programs. TIFF is extremely powerful, flexible, and extensible. However, because of its many nuances and its wide scope, TIFF can be a difficult format to understand as well as a difficult format to support. ImagXpress® supports a wide range of TIFF 6.0 formats including uncompressed, CCITT RLE, CCITT Group 3 Fax, CCITT Group 4 Fax, LZW, Pack Bits, JPEG, and deflate compression types. ImagXpress® supports black and white, RGB, and RGB palette images but it does not support transparency mask, CMYK, YCbCr, or CIELab.

TWAIN
TWAIN (Technology Without An Interesting Name) is a standard for controlling and acquiring image data from raster-generating devices such as scanners, digital cameras, and video digitizers. Manufacturers write the TWAIN driver (called the Source) for their device. Applications that are TWAIN compliant can be used with any TWAIN compliant Source. Likewise, a TWAIN compliant Source can be used with any TWAIN compliant application. Applications that you build with ImagXpress® can be used to interface TWAIN compliant Sources to acquire image data. TWAIN compliant applications should provide the following: The capability to select the Source. This is required because you may have more than one TWAIN device connected to a computer. Use the TWAINSelect method to select the source. The ability to acquire image data. Use the TWAINAcquire method to acquire the image data. If Pegasus' TWAIN Acquire method is successful, the image data is converted to a DIB and the control's hDIB property is set to the resulting DIB handle. Once the image is acquired, you may use any of the image processing methods to alter or save the DIB. The TWAIN sample in the SAMPLES directory and the ImagXpress® Demo application demonstrate how easy it is to add TWAIN support to your applications.

twip
Twips describe the sizes of characters produced by dot matrix printers, which were constrained to multiples of either 12 or 10 dots per inch.

V

VCL
A application framework library for Microsoft Windows and Borland Software Corp.'s Delphi and C++Builder rapid application development software. VCL was originally designed for Delphi but is now also used for C++Builder. This replaces Object Windows Library (OWL) as Borland's Windows C++ framework of choice. VCL encapsulates the C-based Win32 API into a much easier to use, object-oriented form. Like its direct rival, Microsoft Foundation Class Library (MFC), VCL includes classes to create Windows programs. The VCL component class can be inherited to create new VCL components, which are the building blocks of Delphi and C++Builder applications. VCL components compete somewhat with ActiveX controls, though a VCL wrapper can be created to make an ActiveX control seem like a VCL component.

Virtual Image

VOI
Value Of Interest

Void structure
Indicates a method that does not return a value; that is, the method has the void return type.

W

Wintel
A term describing the combination of Microsoft Windows operating system running on PCs with Intel or compatible processors. Dominance of the wintel platform began with MS-DOS on PCs with Intel's 8-bit 8088 processors in 1979.

WMF
The Microsoft Windows Metafile format is used to store vector and bitmap image data. Because of its popularity and wide use, many Windows and non-Windows applications support WMF.

WSQ
Wavelet Scalar Quantization (WSQ) Gray-Scale Fingerprint Image Compression Specification based on the results of the NIST (National Institute of Standards and Technology) review. The benefit of WSQ fingerprint-specific compression is reduced file size. A sample fingerprint with a resolution of 589 pixels by 605 pixels, 8-bit grayscale results in a file size of 325 KB when compressed with the standard lossless compression technology LZW.

WYSIWYG
What You See Is What You Get; realistic display of final print or screen image

X

XP
Microsoft says the Windows "XP" designation originates from the word "experience". Windows XP brings many features previously available only in the server- and workstation-oriented Windows NT and Windows 2000 families, such as greater stability and efficiency due to its pure 32-bit kernel, instead of the hybrid 16-bit/32-bit kernel in prior consumer versions of Windows. (The version number of Windows XP is 5.1 just as Windows 2000 was version 5.0, to denote two OS as descendants of Windows NT 4.0.)

Y

YCbCr
Family of color spaces used in video systems. Y is the luma component; Cb and Cr are the chroma components. YCbCr is often confused with the YUV color space; typically the terms YCbCr and YUV are used interchangeably, leading to confusion. In fact, digital signals, the term "YUV" probably really means "YCbCr. The term YCbCr is sometimes abbreviated to YCC. YCbCr signals (prior to scaling and offsets to place the signals into digital form) are created from the corresponding gamma-adjusted RGB (red, green and blue).


Assembly Overview

Namespaces

Namespace | Description
PegasusImaging.WinForms.ImagXpress9 |


Getting Started - PegasusImaging.WinForms.ImagXpress9

PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Getting Started

© 2008, Pegasus Imaging Corporation, All Rights Reserved.


Introduction - PegasusImaging.WinForms.ImagXpress9

PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Introduction

© 2008, Pegasus Imaging Corporation, All Rights Reserved.


CadLayer Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

CadLayer Class Methods

PegasusImaging.WinForms.ImagXpress9 Namespace : CadLayer Class

For a list of all members of this type, see CadLayer members.

Public Methods

Public Method Dispose Releases all resources used by this object.

See Also

CadLayer Class | PegasusImaging.WinForms.ImagXpress9 Namespace


IcmException Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

IcmException Class Methods

PegasusImaging.WinForms.ImagXpress9 Namespace : IcmException Class

For a list of all members of this type, see IcmException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

IcmException Class | PegasusImaging.WinForms.ImagXpress9 Namespace


IcmException Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

IcmException Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : IcmException Class

For a list of all members of this type, see IcmException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from ImagXpressException) | Gets the numerical equivalent for enumerated exception result.
Public Property Result (Inherited from ImagXpressException) | Gets the enumerated exception result that has occurred.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

IcmException Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageCalsCollection Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageCalsCollection Class Methods

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageCalsCollection Class

For a list of all members of this type, see ImageCalsCollection members.

Public Methods

Public Method Add (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method Clear (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method Contains (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method CopyTo (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method GetEnumerator (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method IndexOf (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method Insert (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method Remove (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method RemoveAt (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)

See Also

ImageCalsCollection Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageCalsCollection Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageCalsCollection Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageCalsCollection Class

For a list of all members of this type, see ImageCalsCollection members.

Public Properties

Public Property Count (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Property Item (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)

See Also

ImageCalsCollection Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageCalsTag Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageCalsTag Class Methods

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageCalsTag Class

For a list of all members of this type, see ImageCalsTag members.

Public Methods

Public Method CompareTo Compares the current instance with another object of the same type.

See Also

ImageCalsTag Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageX Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageX Class Methods

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageX Class

For a list of all members of this type, see ImageX members.

Public Methods

Public Method AddJpegComment | Adds a new comment from an opened JPEG file or a comment for a file to be saved as a JPEG file. The comment will when the current image is written out (saved) as a JPEG file;
Public Method CadFileClose | Closes the CAD file.
Public Method static (Shared in Visual Basic) CadFileOpen | Overloaded. Opens the CAD file for repeated renderings of differently selected layers and layouts.
Public Method CadFileView | Overloaded. The CAD file view.
Public Method Cancel | Cancels current loading, decompression, compression, or saving operations.
Public Method static (Shared in Visual Basic) CompactFile | Compacts a multiple page file by removing unused pages.
Public Method Copy | This method copies the current ImageX object into a newly created ImageX object.
Public Method static (Shared in Visual Basic) CreateColorPalette | Overloaded. Creates a System.Drawing.Imaging.ColorPalette object based on the number of bits per pixel.
Public Method CreateObjRef (Inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Public Method DeleteJpegComment | Deletes an existing JPEG comment string at the index specified.
Public Method static (Shared in Visual Basic) DeletePage | Deletes a page from a multi-page document.
Public Method Dispose | Releases all resources used by this PegasusImaging.WinForms.ImagXpress9.ImageX object
Public Method static (Shared in Visual Basic) DisposeHbitmap | Disposes an Hbitmap object.
Public Method static (Shared in Visual Basic) FromBitmap | Creates an ImageX object from the given Bitmap object.
Public Method static (Shared in Visual Basic) FromFile | Overloaded. This method allows the loading of a specific file.
Public Method static (Shared in Visual Basic) FromHbitmap | Overloaded. Creates an ImageX object from the given Hbitmap object.
Public Method static (Shared in Visual Basic) FromHdib | Overloaded. Creates an ImagX object from the given hdib object.
Public Method static (Shared in Visual Basic) FromStream | Overloaded. Returns an ImageX object from the given ImagXpress instance and stream
Public Method GetGraphics | Gets a System.Drawing.Graphics object with the image selected into it for drawing on the image.
Public Method GetLifetimeService (Inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Public Method static (Shared in Visual Basic) GetTags | Returns the ImageXTagCollection for the file and page requested without loading the image. This method is being deprecated because there are other meta-data items in an image. Please use ReadAllMetaData() which returns an ImageX object containing Tiff/Exif and Iptc tags The Tiff tags can be obtained by ImageX.Tags property and the Iptc meta-data similarly with ImageX.Iptc. Future Meta-data can be obtained in a like manner.
Public Method HorizontalResolution | Returns the horizontal resolution of this ImageX image.
Public Method InitializeLifetimeService (Inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Public Method static (Shared in Visual Basic) InsertPage | Inserts a new page into a multi-page document.
Public Method static (Shared in Visual Basic) NumPages | Returns the number of image pages from the given multiple page PDF, TIFF or DCX file.
Public Method static (Shared in Visual Basic) QueryBuffer | Overloaded. Query buffer for image information such as width, height, bitdepth and image data type.
Public Method static (Shared in Visual Basic) QueryFile | Overloaded. Returns information about an image file without loading the image into ImagXpress.
Public Method static (Shared in Visual Basic) QueryFromStream | Overloaded. Query buffer stream for image information such as width, height, bitdepth and image data type.
Public Method static (Shared in Visual Basic) ReadAllMetaData | Perferred method for obtaining all Meta-data items. Simply fetch the tag collections with ImageX.IptcDataSet and ImageX.Tags; Later that object can be passed to the SaveAllMetaData to save all edits
Public Method ReleaseGraphics | Overloaded. Releases the previously received System.Drawing.Graphics object.
Public Method ResolutionUnits | Returns the graphics units in which resolution information is specified.
Public Method ReturnJpegComment | Returns a JPEG String from the loaded JPEG file if one exists.
Public Method Save | Overloaded. Save the image to a given filename.
Public Method static (Shared in Visual Basic) SaveAllMetaData | The preferred method for saving Tif, Exif, and Iptc meta-data.
Public Method SaveStream | Overloaded. Saves the current ImageX object to a stream object in the specified file format.
Public Method static (Shared in Visual Basic) SetTags | Sets the tags of the specified page of the specified file, without loading the image. Warning! This call does not support Iptc data and will cause Iptc data sets to be removed!! Please use the ReadAllMetaData() and SaveAllMetaData() schemes so any data that is not edited will be preserved naturally
Public Method ToBitmap | Gets a System.Drawing.Bitmap object from the ImageX object
Public Method ToHbitmap | Gets a handle to a bitmap.
Public Method ToHdib | Gets a handle to an DIB (Device Independent Bitmap).
Public Method Undo | Undoes the action of the previous image processing method if the UndoEnabled property was set true prior to performing this method.
Public Method VerticalResolution | Returns the vertical resolution of the ImageX image.

See Also

ImageX Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXData Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXData Class Methods

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXData Class (PegasusImaging.WinForms.ImagXpress9)

For a list of all members of this type, see ImageXData members.

Public Methods

Public Method Dispose | Releases all resources used by this ImageXData object.
Public Method Layer | Returns information for a specific layer.
Public Method Layout | Returns CAD Layout information.
Public Method QueryCadFormat | Returns general information on number of cad layouts, layers, version and filetype.

See Also

ImageXData Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXException Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXException Class Methods

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXException Class

For a list of all members of this type, see ImageXException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ImageXException Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXException Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXException Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXException Class

For a list of all members of this type, see ImageXException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from ImagXpressException) | Gets the numerical equivalent for enumerated exception result.
Public Property Result (Inherited from ImagXpressException) | Gets the enumerated exception result that has occurred.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

ImageXException Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXIptcCollection Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXIptcCollection Class Methods

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXIptcCollection Class

For a list of all members of this type, see ImageXIptcCollection members.

Public Methods

Public Method Add (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method Clear (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method Contains (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method CopyTo (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method GetEnumerator (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method IndexOf (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method Insert (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method Remove (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method RemoveAt (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)

See Also

ImageXIptcCollection Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXIptcCollection Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXIptcCollection Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXIptcCollection Class

For a list of all members of this type, see ImageXIptcCollection members.

Public Properties

Public Property Count (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Property Item (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)

See Also

ImageXIptcCollection Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXIptcData Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXIptcData Class Methods

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXIptcData Class

For a list of all members of this type, see ImageXIptcData members.

Public Methods

Public Method CompareTo Compares the current instance with another object of the same type.

See Also

ImageXIptcData Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXTag Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXTag Class Methods

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXTag Class

For a list of all members of this type, see ImageXTag members.

Public Methods

Public Method GetTagBytes | Gets tag data that are of the type Bytes.
Public Method GetTagDouble | Gets tag data of type Double.
Public Method GetTagFloat | Retrieves a float array of values contained within the ImageXTag.
Public Method GetTagInt16 | Retrieves a short array of values contained within ImageXTag.
Public Method GetTagInt32 | Gets tag data of type long or int32.
Public Method GetTagRational | Gets Tag Rational data.
Public Method GetTagSBytes | Retrieves signed short array of values contained within the ImageXTag.
Public Method GetTagSRational | Gets tag SRational data.
Public Method GetTagUInt16 | Retrieves a short array of values contained within the ImageXTag.
Public Method GetTagUInt32 | Gets tag data of type unsigned long or UInt32.
Public Method SetTagBytes | Sets Tag Data of based on byte array input.
Public Method SetTagDouble | Sets tag data of type Double.
Public Method SetTagFloat | Set Tag Data of type Float or Single.
Public Method SetTagInt16 | Sets the ImageXTag data based on the short array input.
Public Method SetTagInt32 | Overloaded. Sets Tag Data of type long or int32
Public Method SetTagRational | Sets Tag Rational Data.
Public Method SetTagSBytes | Sets Tag Data based on the byte array input.
Public Method SetTagSRational | Sets Tag Rational Data.
Public Method SetTagUInt16 | Sets tag data of type UInt16.
Public Method SetTagUInt32 | Sets tag data of type unsigned long or UInt32.

See Also

ImageXTag Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXTagCollection Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXTagCollection Class Methods

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXTagCollection Class

For a list of all members of this type, see ImageXTagCollection members.

Public Methods

Public Method Add | Adds an ImageXTag to the ImageXTagCollection.
Public Method Clear | Clears the entire collection as well as calls the Clear function of the base class.
Public Method Contains | Determines if the collection contains the specified ImageXTag.
Public Method CopyTo | Copies the entire collection to an array, starting at index of the target array.
Public Method Dispose | Releases all resources used by this PegasusImaging.WinForms.ImagXpress9.ImageXTagCollection object.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method GetTag | Retrieves the ImageXTag object from the ImageXTagCollection.
Public Method IndexOf | Searches for the specified ImageXTag and returns the zero-based index of the first occurrence within the entire collection.
Public Method Insert | Inserts an ImageXTag at the specified index.
Public Method Remove | Removes the ImageXTag from the collection.
Public Method RemoveAt | Removes the specified ImageXTag from the collection.
Public Method RemoveTag | Removes an ImageXTag from the ImageXTagCollection.

See Also

ImageXTagCollection Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXView Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXView Class Methods

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXView Class

For a list of all members of this type, see ImageXView members.

Public Methods

Public Method BeginInvoke (Inherited from System.Windows.Forms.Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
Public Method BringToFront (Inherited from System.Windows.Forms.Control) | Brings the control to the front of the z-order.
Public Method CaptureControl | Captures the screen area bounded by the control and saves it to the current image.
Public Method CaptureWindow | Overloaded. Captures the screen area within the specified Window and saves it to the current Image.
Public Method Contains (Inherited from System.Windows.Forms.Control) | Retrieves a value indicating whether the specified control is a child of the control.
Public Method CopyToClipboard | Overloaded. Copies the current image to the clipboard.
Public Method CreateControl (Inherited from System.Windows.Forms.Control) | Forces the creation of the control, including the creation of the handle and any child controls.
Public Method CreateGraphics (Inherited from System.Windows.Forms.Control) | Creates the Graphics for the control.
Public Method CreateObjRef (Inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Public Method Dispose (Inherited from System.ComponentModel.Component) | Releases all resources used by the Component.
Public Method DoDragDrop (Inherited from System.Windows.Forms.Control) | Begins a drag-and-drop operation.
Public Method DrawToBitmap (Inherited from System.Windows.Forms.Control) | Supports rendering to the specified bitmap.
Public Method EndInvoke (Inherited from System.Windows.Forms.Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Public Method FindForm (Inherited from System.Windows.Forms.Control) | Retrieves the form that the control is on.
Public Method Focus (Inherited from System.Windows.Forms.Control) | Sets input focus to the control.
Public Method GetChildAtPoint (Inherited from System.Windows.Forms.Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
Public Method GetContainerControl (Inherited from System.Windows.Forms.Control) | Returns the next ContainerControl up the control's chain of parent controls.
Public Method GetLifetimeService (Inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Public Method GetNextControl (Inherited from System.Windows.Forms.Control) | Retrieves the next control forward or back in the tab order of child controls.
Public Method GetPaletteColor | Retrieves the colors for a user defined palette for the control.
Public Method GetPreferredSize (Inherited from System.Windows.Forms.Control) | Retrieves the size of a rectangular area into which a control can be fitted.
Public Method Hide (Inherited from System.Windows.Forms.Control) | Conceals the control from the user.
Public Method InitializeLifetimeService (Inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Public Method Invalidate (Inherited from System.Windows.Forms.Control) | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn.
Public Method Invoke (Inherited from System.Windows.Forms.Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
Public Method IsToolCursorBuiltin | Determines if the current cursor for a tool is the built-in default cursor.
Public Method MouseWheelGet | Retrieves which MouseWheelAction is assigned to a given mousewheel/shift combination.
Public Method MouseWheelGetAttribute | Retrieves the value of a specific mousewheel action's attribute.
Public Method MouseWheelSet | Assigns a MouseWheelAction to a particular shift/mousewheel combination.
Public Method MouseWheelSetAttribute | Sets the value of a specific mousewheel action's attribute.
Public Method PasteFromClipboard | Pastes the image from the clipboard to the current image.
Public Method PerformAutoScale (Inherited from System.Windows.Forms.ContainerControl) | Performs scaling of the container control and its children.
Public Method PerformLayout (Inherited from System.Windows.Forms.Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
Public Method PointToClient (Inherited from System.Windows.Forms.Control) | Computes the location of the specified screen point into client coordinates.
Public Method PointToScreen (Inherited from System.Windows.Forms.Control) | Computes the location of the specified client point into screen coordinates.
Public Method PreProcessControlMessage (Inherited from System.Windows.Forms.Control) |
Public Method PreProcessMessage (Inherited from System.Windows.Forms.Control) |
Public Method Print | Overloaded. Prints an image to the current graphics object given graphics and rectangle values.
Public Method RectangleToClient (Inherited from System.Windows.Forms.Control) | Computes the size and location of the specified screen rectangle in client coordinates.
Public Method RectangleToScreen (Inherited from System.Windows.Forms.Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Public Method Refresh (Inherited from System.Windows.Forms.Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
Public Method ResetText (Inherited from System.Windows.Forms.Control) | Resets the Text property to its default value.
Public Method ResetToolCursor | Resets the cursor for a specific tool cursor type back to the built-in default cursor.
Public Method ResumeLayout (Inherited from System.Windows.Forms.Control) | Overloaded. Resumes usual layout logic.
Public Method ScrollControlIntoView (Inherited from System.Windows.Forms.ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Public Method Select (Inherited from System.Windows.Forms.Control) | Activates the control.
Public Method SelectNextControl (Inherited from System.Windows.Forms.Control) | Activates the next control.
Public Method SendToBack (Inherited from System.Windows.Forms.Control) | Sends the control to the back of the z-order.
Public Method SetAutoScrollMargin (Inherited from System.Windows.Forms.ScrollableControl) | Sets the size of the auto-scroll margins.
Public Method SetBounds (Inherited from System.Windows.Forms.Control) | Overloaded. Sets the specified bounds of the control to the specified location and size.
Public Method SetPaletteColor | Specifies the colors for a user defined palette for the control.
Public Method SetToolCursor | Sets the cursor for a specific tool cursor type.
Public Method Show (Inherited from System.Windows.Forms.Control) | Displays the control to the user.
Public Method ShowImageInfo | Invokes a dialog box displaying image information.
Public Method SuspendLayout (Inherited from System.Windows.Forms.Control) | Temporarily suspends the layout logic for the control.
Public Method ToolGet | Retrieves which tool is assigned to a given mouse/shift combination.
Public Method ToolGetAttribute | Retrieves the value of a specific tool's attribute.
Public Method ToolSet | Assigns a tool to a particular shift/mouse combination.
Public Method ToolSetAttribute | Sets the value of a specific tool's attribute.
Public Method ToString (Inherited from System.ComponentModel.Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Public Method Translate | Translates values from one coordinate system to the other.
Public Method Update (Inherited from System.Windows.Forms.Control) | Causes the control to redraw the invalidated regions within its client area.
Public Method Validate (Inherited from System.Windows.Forms.ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
Public Method ValidateChildren (Inherited from System.Windows.Forms.UserControl) | Overloaded.
Public Method ZoomToFit | Zoom the image display to fit within the ImageXView control.

See Also

ImageXView Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXViewException Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXViewException Class Methods

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXViewException Class

For a list of all members of this type, see ImageXViewException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ImageXViewException Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImageXViewException Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImageXViewException Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : ImageXViewException Class

For a list of all members of this type, see ImageXViewException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from ImagXpressException) | Gets the numerical equivalent for enumerated exception result.
Public Property Result (Inherited from ImagXpressException) | Gets the enumerated exception result that has occurred.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

ImageXViewException Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImagXpress Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpress Class Methods

PegasusImaging.WinForms.ImagXpress9 Namespace : ImagXpress Class

For a list of all members of this type, see ImagXpress members.

Public Methods

Public Method AboutBox | Displays a dialog box containing ImagXpress version and copyright information.
Public Method CreateObjRef (Inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Public Method Dispose (Inherited from System.ComponentModel.Component) | Releases all resources used by the Component.
Public Method GetLifetimeService (Inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Public Method InitializeLifetimeService (Inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Public Method ToString (Inherited from System.ComponentModel.Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

See Also

ImagXpress Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImagXpressDefaultContextMenu Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpressDefaultContextMenu Class Events

PegasusImaging.WinForms.ImagXpress9 Namespace : ImagXpressDefaultContextMenu Class

For a list of all members of this type, see ImagXpressDefaultContextMenu members.

Public Events

Public Event Collapse (Inherited from System.Windows.Forms.ContextMenu) | Occurs when the shortcut menu collapses.
Public Event Disposed (Inherited from System.ComponentModel.Component) | Adds an event handler to listen to the Disposed event on the component.
Public Event Popup (Inherited from System.Windows.Forms.ContextMenu) | Occurs before the shortcut menu is displayed.

See Also

ImagXpressDefaultContextMenu Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImagXpressDefaultContextMenu Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpressDefaultContextMenu Class Methods

PegasusImaging.WinForms.ImagXpress9 Namespace : ImagXpressDefaultContextMenu Class

For a list of all members of this type, see ImagXpressDefaultContextMenu members.

Public Methods

Public Method CreateObjRef (Inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Public Method Dispose (Inherited from System.ComponentModel.Component) | Releases all resources used by the Component.
Public Method FindMenuItem (Inherited from System.Windows.Forms.Menu) | Gets the MenuItem that contains the value specified.
Public Method GetContextMenu (Inherited from System.Windows.Forms.Menu) | Gets the ContextMenu that contains this menu.
Public Method GetLifetimeService (Inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Public Method GetMainMenu (Inherited from System.Windows.Forms.Menu) | Gets the MainMenu that contains this menu.
Public Method InitializeLifetimeService (Inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Public Method MergeMenu (Inherited from System.Windows.Forms.Menu) | Merges the MenuItem objects of one menu with the current menu.
Public Method Show (Inherited from System.Windows.Forms.ContextMenu) | Overloaded. Displays the shortcut menu at the specified position.
Public Method ToString (Inherited from System.Windows.Forms.Menu) | Returns a String that represents the Menu control.

See Also

ImagXpressDefaultContextMenu Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImagXpressDefaultContextMenu Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpressDefaultContextMenu Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : ImagXpressDefaultContextMenu Class

For a list of all members of this type, see ImagXpressDefaultContextMenu members.

Public Properties

Public Property Container (Inherited from System.ComponentModel.Component) | Gets the IContainer that contains the Component.
Public Property Handle (Inherited from System.Windows.Forms.Menu) | Gets a value representing the window handle for the menu.
Public Property IsParent (Inherited from System.Windows.Forms.Menu) | Gets a value indicating whether this menu contains any menu items. This property is read-only.
Public Property MdiListItem (Inherited from System.Windows.Forms.Menu) | Gets a value indicating the MenuItem that is used to display a list of multiple document interface (MDI) child forms.
Public Property MenuItems (Inherited from System.Windows.Forms.Menu) | Gets a value indicating the collection of MenuItem objects associated with the menu.
Public Property Name (Inherited from System.Windows.Forms.Menu) | Gets or sets the name of the Menu.
Public Property RightToLeft (Inherited from System.Windows.Forms.ContextMenu) | Gets or sets a value indicating whether text displayed by the control is displayed from right to left.
Public Property Site (Inherited from System.ComponentModel.Component) | Gets or sets the ISite of the Component.
Public Property SourceControl (Inherited from System.Windows.Forms.ContextMenu) | Gets the control that is displaying the shortcut menu.
Public Property Tag (Inherited from System.Windows.Forms.Menu) | Gets or sets user-defined data associated with the control.

See Also

ImagXpressDefaultContextMenu Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ImagXpressException Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ImagXpressException Class Methods

PegasusImaging.WinForms.ImagXpress9 Namespace : ImagXpressException Class

For a list of all members of this type, see ImagXpressException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ImagXpressException Class | PegasusImaging.WinForms.ImagXpress9 Namespace


InternetException Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

InternetException Class Methods

PegasusImaging.WinForms.ImagXpress9 Namespace : InternetException Class

For a list of all members of this type, see InternetException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InternetException Class | PegasusImaging.WinForms.ImagXpress9 Namespace


InternetException Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

InternetException Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : InternetException Class

For a list of all members of this type, see InternetException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from ImagXpressException) | Gets the numerical equivalent for enumerated exception result.
Public Property Result (Inherited from ImagXpressException) | Gets the enumerated exception result that has occurred.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InternetException Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Licensing Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Licensing Class Methods

PegasusImaging.WinForms.ImagXpress9 Namespace : Licensing Class (PegasusImaging.WinForms.ImagXpress9)

For a list of all members of this type, see Licensing members.

Public Methods

Public Method AddOnLicense | This method has been deprecated.
Public Method UnlockRuntime | Enable run-time licensing.
Public Method UnlockWeb | Enable web licensing when deploying to a web application.

See Also

Licensing Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Processor Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Processor Class Methods

PegasusImaging.WinForms.ImagXpress9 Namespace : Processor Class

For a list of all members of this type, see Processor members.

Public Methods

Public Method AdjustColorBalance | Overrides the default parameters when auto color balancing the image.
Public Method AdjustHSL | Adjusts the hue, saturation, and luninance components of the current image.
Public Method AdjustLightness | Automatically balances contrast in the image, adjusting the results of the auto lightness algorithm by a specified amount.
Public Method AdjustRGB | Adjusts the red, green, and blue components of the current image.
Public Method AlphaAdd | Overloaded. Adds a user created 8 bit alpha channel to an existing 24 bit channel thus promoting the image to 32 bits.
Public Method AlphaBitmapReturn | Overloaded. Returns an 8 bit handle to an image.
Public Method AlphaFill | Fills the alpha channel with the value specified.
Public Method AlphaFlatten | Overloaded. A 32 bit image with an alpha channel (ARGB) will merge (alpha channel applied) to the specified background color resulting in a 24 bit RGB image.
Public Method AlphaGet | Returns the Alpha value specified by the x and y location.
Public Method AlphaInvert | Inverts the alpha values throughout the current image, regions, or area.
Public Method AlphaRemove | Strips an ARGB 32 bit image to just a 24 bit RGB image.
Public Method AlphaSet | Allows the modification of an individual alpha value at the specified x and y coordinates.
Public Method ApplyGrayscaleTransform | Overloaded. Permanently levels an 8 through 16-bit gray image to and 8-bit gray image.
Public Method AutoColorBalance | Overrides the default parameters when auto color balances the image.
Public Method AutoContrast | Adjusts the contrast in the current image.
Public Method AutoCrop | Automatically crops the border space from an image.
Public Method AutoLevel | Restores and balances color quality within an image.
Public Method AutoLightness | Automatically assesses the adjusts contrast in light or dark regions of the image.
Public Method AutoRemoveRedeye | Automatically reduces the red reflection of the flash seen in the eyes of people in color flash photo images.
Public Method Binarize | Operates on 1-bit and 24-bit DIBs creating a 1-bit or 8-bit grayscale output image, respectively, of the same dimensions.
Public Method Blend | Blends each pixel in the current image with its neighboring pixels.
Public Method Blur | Blurs the current image by averaging each pixel with each of its neighboring pixels giving it an 'out of focus' appearance.
Public Method Brightness | Uniformly brightens the current image.
Public Method Buttonize | Adds translucent bevels to the edges of the current image to give it the appearance of a 3D button.
Public Method ColorCount | Returns the number of pixels of a specified color within the current image or image area.
Public Method ColorDepth | Changes the bits per pixel of the current image.
Public Method ColorJoin | Overloaded. Joins the colors as specified by the given parameters.
Public Method ColorSeparation | Overloaded. Separates the color based on the given parameters.
Public Method Contrast | Adjusts the contrast of the image.
Public Method CreateObjRef (Inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Public Method Crop | Crops the current image to the specified size.
Public Method CropBorder | Performs border removal by automatically cropping the edges of the current image.
Public Method DeleteRegion | Deletes the region of the image.
Public Method Deskew | Overloaded. Deskews the image using the specified DeskewType.
Public Method Despeckle | Filters the image using a filter that attempts to eliminate noise in the image.
Public Method Diffuse | Diffuses the current image by replacing each pixel with a randomly selected neighboring pixel.
Public Method Dilate | Enlarges the boundaries of regions of foreground pixels in the current image using a 3x3 maximum filter.
Public Method Dispose (Inherited from System.ComponentModel.Component) | Releases all resources used by the Component.
Public Method DocumentBlankPageDetect | Examines a rectangle on an image, determining if the page is considered blank, based on the amont of data on the page.
Public Method DocumentBlobRemoval | Locates and removes large black objects in images such as binder punch holes.
Public Method DocumentBorderCrop | Crops the borders of documents.
Public Method DocumentDeskew | Overloaded. Automatically detects and removes skew from current 1-bit depth images.
Public Method DocumentDespeckle | Detects and removes specks from the current image.
Public Method DocumentDilate | Examines pixels in the current image and expands the black ones by the given amount in a given direction.
Public Method DocumentErode | Removes the black pixels in the current image by the given amount in the given direction.
Public Method DocumentLineRemoval | Automatically detects and removes lines from the current image.
Public Method DocumentShear | Shears current image clockwise or counter-clockwise.
Public Method DocumentZoomSmooth | Replaces the current 1 bit-per-pixel image with an image whose width and height have been doubled and whose pixels have been smoothed.
Public Method Emboss | Performs an emboss on the image causing it to look embellished with metal or embroidered look.
Public Method Equalize | Equalizes the image by spreading its values across the full image.
Public Method Erode | Erodes the image by eroding away the boundaries using a 3x3 minimum filter.
Public Method Flip | Flips the current image from top to bottom.
Public Method Gamma | Specifies the gamma correction.
Public Method GetLifetimeService (Inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Public Method InitializeLifetimeService (Inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Public Method Matrix | Modifies the image using a 3x3 consolution matrix filter.
Public Method Median | Reduces noise on an image by using a 3x3 median filter.
Public Method Merge | Merges two images together such that the source image is merged with the current image specified in the processor. This method also specifies the type of merging.
Public Method Mirror | Rotates the current DIB (Device Independent Bitmap) 180 degrees, then flips it to create a mirror image.
Public Method Mosaic | Creates tiles or cells to represents the image.
Public Method MotionBlur | Streaks or blurs objects on the image to display them as moving using the specified parameters.
Public Method Negate | Creates a color negative of the current image.
Public Method Noise |
Public Method Outline | Outlines the outter edges of the image by enhancing the edges.
Public Method Parabolic | Modifies the image by the given ParabolicType.
Public Method Perspective | Modifies the image using the given PerspectiveType and percent.
Public Method Pinch | Modifies the image to look like it was pinched in the center using the given intensity.
Public Method PolynomialWarp | Modifies and warps the image to the given points.
Public Method Posterize | Reduces the number of colors to give it the effect of contours in the image.
Public Method RemoveDust | Removes what appears to be dust on the image by the given parameters.
Public Method RemoveRedeye | Removes what appears as red eye's in an image using the given parameters.
Public Method RemoveScratches | Removes what appear to be scratches from the image using the given parameters.
Public Method ReplaceColors | Replaces a range of colors in the current image.
Public Method Resize | Overloaded.
Public Method RGBColorCount | Returns three arrays, each containing 256 elements, which equate to a count of the red, green, and blue color intensities of the image.
Public Method Ripple | Modifies the image to create a ripple effect as per the given parameters.
Public Method Rotate | Rotates the current image.
Public Method SetArea | Sets the area.
Public Method SetRegion | Overloaded. Sets the given region for the image.
Public Method Sharpen | Overloaded. Sharpens the image by the given intensity.
Public Method Soften | Overloaded. Softens the image by the given intensity.
Public Method Solarize | Modifies the image by inverting the pixel values to negative.
Public Method Swirl | Modifies the image to appear in a swirl based on the given degrees.
Public Method Tile | Modifies the image to appear in tiles based on the given tile size.
Public Method ToString (Inherited from System.ComponentModel.Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Public Method Twist | Modifies the image to appear in a twist by the given block size and rotation.
Public Method UniqueColors | Returns a count of unique colors in the current image.
Public Method Unsharpen | Overloaded. Modifies the image to appear not as detailed based on the given intensity.

See Also

Processor Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ProcessorException Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ProcessorException Class Methods

PegasusImaging.WinForms.ImagXpress9 Namespace : ProcessorException Class

For a list of all members of this type, see ProcessorException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ProcessorException Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ProcessorException Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ProcessorException Class Properties

PegasusImaging.WinForms.ImagXpress9 Namespace : ProcessorException Class

For a list of all members of this type, see ProcessorException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from ImagXpressException) | Gets the numerical equivalent for enumerated exception result.
Public Property Result (Inherited from ImagXpressException) | Gets the enumerated exception result that has occurred.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

ProcessorException Class | PegasusImaging.WinForms.ImagXpress9 Namespace


RedeyeCollection Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

RedeyeCollection Class Methods

PegasusImaging.WinForms.ImagXpress9 Namespace : RedeyeCollection Class

For a list of all members of this type, see RedeyeCollection members.

Public Methods

Public Method Add |
Public Method Clear | Clears the entire collection as well as calls the Clear function of the base class.
Public Method Contains | Determines if the collection contains this RedeyeRectangle.
Public Method CopyTo | Copies the entire collection to an array, starting at index of the target array.
Public Method Dispose | Releases all resources used by this PegasusImaging.WinForms.ImagXpress9.RedeyeCollection object.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method GetRedeyeRectangle |
Public Method IndexOf | Searches for the specified Object and returns the zero-based index of the first occurrence within the entire PageCollection.
Public Method Insert | Inserts a RedeyeRectangle at the specified index.
Public Method Remove | Removes the RedeyeRectangle from the collection.
Public Method RemoveAt | Remove operation for the RedeyeRectangle collection. Call the RedeyeRectangle destructor to free the RedeyeRectangle then remove the RedeyeRectangle from the collection.
Public Method RemoveRectangle |

See Also

RedeyeCollection Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Rubberband Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Rubberband Class Methods

PegasusImaging.WinForms.ImagXpress9 Namespace : Rubberband Class (PegasusImaging.WinForms.ImagXpress9)

For a list of all members of this type, see Rubberband members.

Public Methods

Public Method Clear | Deletes the Rubberband and frees the memory associated with it.
Public Method Copy | Copies the current rubber band area into a new ImageX object.
Public Method Start | Overloaded. Sets the starting point for the Rubberband object.
Public Method Stop | Stops (disables) the rubberband.
Public Method Update | Updates the current rubber band ending point.

See Also

Rubberband Class | PegasusImaging.WinForms.ImagXpress9 Namespace


Sprite Class | PegasusImaging.WinForms.ImagXpress9 Namespace | Create Method | Move Method | Paste Method

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Sprite Class Methods

PegasusImaging.WinForms.ImagXpress9 Namespace : Sprite Class (PegasusImaging.WinForms.ImagXpress9)

For a list of all members of this type, see Sprite members.

Public Methods

Public Method Create | Overloaded. Creates a copy of the current region in a transparent window that can be moved or pasted into the image.
Public Method Delete | Deletes the current sprite.
Public Method Move | Moves the current sprite to a new position within the image.
Public Method Paste | Pastes the current sprite into the image.

See Also

Sprite Class | PegasusImaging.WinForms.ImagXpress9 Namespace | Create Method | Move Method | Paste Method


Toolbar Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

Toolbar Class Methods

PegasusImaging.WinForms.ImagXpress9 Namespace : Toolbar Class (PegasusImaging.WinForms.ImagXpress9)

For a list of all members of this type, see Toolbar members.

Public Methods

Public Method DeleteTool | Deletes the specified tool from the toolbar.
Public Method GetToolEnabled | Gets the enabled value of the given tool.
Public Method GetToolTip | Gets the informational tip that is displayed to the end-user when the mouse is dragged over the given tool.
Public Method GetToolVisible | Gets the tools visibility.
Public Method SetToolEnabled | Enables the given tool.
Public Method SetToolTip | Sets the given informational tip that displays to the end-user when the mouse is dragged over the specified tool.
Public Method SetToolVisible | Sets the tools visibility.

See Also

Toolbar Class | PegasusImaging.WinForms.ImagXpress9 Namespace


ToolbarContextMenu Class | PegasusImaging.WinForms.ImagXpress9 Namespace

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

ToolbarContextMenu Class Methods

PegasusImaging.WinForms.ImagXpress9 Namespace : ToolbarContextMenu Class

For a list of all members of this type, see ToolbarContextMenu members.

Public Methods

Public Method AddItem | Adds an item to the specified menu.
Public Method ChangeItem | Changes the text title of the specified menu item.
Public Method DeleteItem | Deletes an item from the specified menu.
Public Method GetEnabled | Gets the enabled value of the menu associated with the given tool.
Public Method GetFirstItemId | Gets the topMenuId and subMenuId of the first item in the menu associated with the specified tool.
Public Method GetItem | Gets the title of the menu item specified.
Public Method GetItemChecked | Gets the checked status of the specified menu item.
Public Method GetItemEnabled | Gets the enabled status of the specified menu item.
Public Method GetItemVisible | Gets the visible status of the specified menu item.
Public Method GetNextItemId | Gets the topMenuId and subMenuId of the next item in the menu associated with the specified tool.
Public Method SetEnabled | Sets the enabled value of the menu associated with the given tool.
Public Method SetItemChecked | Sets if a menu item should have a checkmark visible next to the item.
Public Method SetItemEnabled | Sets if a menu item is enabled.
Public Method SetItemVisible | Sets if a menu item should be visible when the menu is displayed.

See Also

ToolbarContextMenu Class | PegasusImaging.WinForms.ImagXpress9 Namespace


PegasusImaging.WinForms.ImagXpress9 Assembly

See Also PegasusImaging.WinForms.ImagXpress9 Send comments on this topic.

PegasusImaging.WinForms.ImagXpress9 Namespace Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ImagXpress9.CadLayer
PegasusImaging.WinForms.ImagXpress9.CadLayout
PegasusImaging.WinForms.ImagXpress9.ImageCalsTag
PegasusImaging.WinForms.ImagXpress9.ImageXData
PegasusImaging.WinForms.ImagXpress9.ImageXIptcData
PegasusImaging.WinForms.ImagXpress9.ImageXTag
PegasusImaging.WinForms.ImagXpress9.InternetOptions
PegasusImaging.WinForms.ImagXpress9.Licensing
PegasusImaging.WinForms.ImagXpress9.LoadOptions
PegasusImaging.WinForms.ImagXpress9.LoadOptionsCad
PegasusImaging.WinForms.ImagXpress9.LoadOptionsHdPhoto
PegasusImaging.WinForms.ImagXpress9.LoadOptionsJbig2
PegasusImaging.WinForms.ImagXpress9.LoadOptionsJpeg
PegasusImaging.WinForms.ImagXpress9.LoadOptionsMetafile
PegasusImaging.WinForms.ImagXpress9.LoadOptionsPdf
PegasusImaging.WinForms.ImagXpress9.LoadOptionsPic
PegasusImaging.WinForms.ImagXpress9.LoadOptionsRaw
PegasusImaging.WinForms.ImagXpress9.LoadOptionsTiff
PegasusImaging.WinForms.ImagXpress9.LookupTable
PegasusImaging.WinForms.ImagXpress9.Medical
PegasusImaging.WinForms.ImagXpress9.RedeyeRectangle
PegasusImaging.WinForms.ImagXpress9.Resolution
PegasusImaging.WinForms.ImagXpress9.Rubberband
PegasusImaging.WinForms.ImagXpress9.SaveOptions
PegasusImaging.WinForms.ImagXpress9.SaveOptionsAnnotations
PegasusImaging.WinForms.ImagXpress9.SaveOptionsDcx
PegasusImaging.WinForms.ImagXpress9.SaveOptionsExif
PegasusImaging.WinForms.ImagXpress9.SaveOptionsGif
PegasusImaging.WinForms.ImagXpress9.SaveOptionsHdp
PegasusImaging.WinForms.ImagXpress9.SaveOptionsIcon
PegasusImaging.WinForms.ImagXpress9.SaveOptionsJbig2
PegasusImaging.WinForms.ImagXpress9.SaveOptionsJls
PegasusImaging.WinForms.ImagXpress9.SaveOptionsJp2
PegasusImaging.WinForms.ImagXpress9.SaveOptionsJpeg
PegasusImaging.WinForms.ImagXpress9.SaveOptionsLjp
PegasusImaging.WinForms.ImagXpress9.SaveOptionsPdf
PegasusImaging.WinForms.ImagXpress9.SaveOptionsPic
PegasusImaging.WinForms.ImagXpress9.SaveOptionsPng
PegasusImaging.WinForms.ImagXpress9.SaveOptionsPortable
PegasusImaging.WinForms.ImagXpress9.SaveOptionsTiff
PegasusImaging.WinForms.ImagXpress9.SaveOptionsWsq
PegasusImaging.WinForms.ImagXpress9.Sprite
PegasusImaging.WinForms.ImagXpress9.Toolbar
PegasusImaging.WinForms.ImagXpress9.ToolbarContextMenu
PegasusImaging.WinForms.ImagXpress9.WorkerImports
System.Collections.CollectionBase
PegasusImaging.WinForms.ImagXpress9.ImageXTagCollection
PegasusImaging.WinForms.ImagXpress9.RedeyeCollection
System.Collections.ObjectModel.Collection<ImageCalsTag>
PegasusImaging.WinForms.ImagXpress9.ImageCalsCollection
System.Collections.ObjectModel.Collection<ImageXIptcData>
PegasusImaging.WinForms.ImagXpress9.ImageXIptcCollection
System.EventArgs
PegasusImaging.WinForms.ImagXpress9.AutoResizeChangedEventArgs
PegasusImaging.WinForms.ImagXpress9.ImageStatusEventArgs
PegasusImaging.WinForms.ImagXpress9.PaintImageEventArgs
PegasusImaging.WinForms.ImagXpress9.PrintImageEventArgs
PegasusImaging.WinForms.ImagXpress9.ProgressEventArgs
PegasusImaging.WinForms.ImagXpress9.ResizedEventArgs
PegasusImaging.WinForms.ImagXpress9.ScrollbarVisibleChangedEventArgs
PegasusImaging.WinForms.ImagXpress9.ScrollEventArgs
PegasusImaging.WinForms.ImagXpress9.ToolbarCloseEventArgs
PegasusImaging.WinForms.ImagXpress9.ToolbarContextMenuEventArgs
PegasusImaging.WinForms.ImagXpress9.ToolbarEventArgs
PegasusImaging.WinForms.ImagXpress9.ToolbarOpenEventArgs
PegasusImaging.WinForms.ImagXpress9.ToolEventArgs
PegasusImaging.WinForms.ImagXpress9.ZoomFactorChangedEventArgs
System.Exception
System.ApplicationException
PegasusImaging.WinForms.ImagXpress9.ImagXpressException
PegasusImaging.WinForms.ImagXpress9.IcmException
PegasusImaging.WinForms.ImagXpress9.ImageXException
PegasusImaging.WinForms.ImagXpress9.ImageXViewException
PegasusImaging.WinForms.ImagXpress9.InternetException
PegasusImaging.WinForms.ImagXpress9.ProcessorException
System.MarshalByRefObject
PegasusImaging.WinForms.ImagXpress9.ImageX
System.ComponentModel.Component
PegasusImaging.WinForms.ImagXpress9.ImagXpress
PegasusImaging.WinForms.ImagXpress9.Processor
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
PegasusImaging.WinForms.ImagXpress9.ImageXView
System.Windows.Forms.Menu
System.Windows.Forms.ContextMenu
PegasusImaging.WinForms.ImagXpress9.ImagXpressDefaultContextMenu

See Also

PegasusImaging.WinForms.ImagXpress9 Namespace | PegasusImaging.WinForms.ImagXpress9 Assembly