What is ThumbnailXpress?

ThumbnailXpress™, Version 2 provides support for the generation and display of thumbnail images.

New Features in Version 2

  • Directory drill down
  • Drag and drop thumbnails
  • Programmatic scrolling
  • Mousewheel support
  • Keyboard navigation
  • Load thumbnails from memory buffer or IO.Stream
  • Save thumbnail image as Bitmap, HBitmap, or Picture object
  • Set component, cell, text back color
  • Associate user-defined data with thumbnail images
  • Generate thumbnails of CAD images

Primary Features Include

  • Input single image files, folders of images, and individual pages of multi-page images

  • Generates thumbnail images of all image types supported in ImagXpress

  • Integrate seamlessly with Pegasus Imaging PDFXpress™ for displaying thumbnail images of PDF files

  • Provides fast sizing and filtering of input files

  • Provides control of display features including thumbnail size, spacing, border lines, and selection

  • Provides control over sophisticated asynchronous threading capabilities for rapid generation of thumbnail images from source images
  • Optimized thumbnail caching for fast scrolling through thumbnail lists

  • Provide custom or various 'stock' labels for thumbnail items

  • Develop powerful image thumbnailing applications for Windows
See Also

Getting Support and Samples | License Agreement | Operating Requirements

© 2008, Pegasus Imaging Corporation, All Rights Reserved.


What is The ImagXpress Product Family?

ImagXpress® Version 9 is Pegasus Imaging Corporation’s comprehensive image processing toolkit designed for document imaging, medical imaging, and photo imaging application development. The ImagXpress v9 Product Family includes the following Components:

  • ImagXpress v9 – image compression, decompression, viewing, and processing
  • NotateXpress™ v9 – image annotation support
  • ThumbnailXpress™ v2 – thumbnail image support
  • TwainPRO™ v5 – TWAIN image acquisition support
  • PrintPRO™ v4 – image printing support

ImagXpress Editions: The components within the ImagXpress v9 Product Family are available in four editions, designed to meet specific imaging needs:

  • Photo: includes ImagXpress, NotateXpress, TwainPRO, PrintPRO, and ThumbnailXpress
  • Document: includes ImagXpress, NotateXpress, TwainPRO, PrintPRO, and ThumbnailXpress
  • View: Includes ImagXpress, NotateXpress, PrintPRO, and ThumbnailXpress
  • Standard: Includes ImagXpress and TwainPRO

Additional Pegasus Imaging Components: Additional components are available for purchase separately, and integrate easily with to provide a comprehensive imaging solution:

  • PDFXpress™ – PDF creation, viewing, and annotating
  • OCRXpress™ – full page OCR
  • Barcode Xpress™ – recognize barcodes
  • ScanFix Xpress™ – advanced image cleanup
  • FormFix™ – form ID, dropout, and OMR
  • SmartZone™ ICR / OCR – character recognition

See www.PegasusImaging.com for product packaging and sales information.

See Also

Getting Support and Samples | License Agreement | Operating Requirements


Getting Support and Samples

Benefits of Registering your Pegasus Development Kit

Purchasers of development kits need to register with Pegasus in order to be notified of updates and receive support now or in the future. Registration is automatic when purchased directly from the Pegasus web site. If purchased through a Pegasus reseller, please register your purchase by filling out the form at www.PegasusImaging.com/registration.htm.

Vehicles for Support

Samples

Samples are included in the downloaded installation.

The product installation program installs a common sample folder accessible via the Start Menu.

Samples for the .NET framework:

  • Microsoft VisualBasic.Net
  • Microsoft C#

Access the samples

  • Through the Windows Start menu: Start | Programs | Pegasus Imaging | ThumbnailXpress | Samples
  • Sample image files included

Sample Code Newsgroups

Customers create samples of great benefit to other developers, so we created a Sample Code Newsgroup. This is a newsgroup for our customers and potential customers. They post and receive sample code from our development team and other developers to expedite their development. Go online at: http://www.PegasusImaging.com/samplecode.htm.

Web Support

Visit the Pegasus Imaging web site frequently asked questions page www.PegasusImaging.com/faq.htm for the fastest answers to common questions. The web site also provides other support options that are accessible at www.PegasusImaging.com/supportagree.htm.

E-mail Support

Both pre-sale and post-sale e-mail support is offered free of charge. Questions are answered on a First-Come-First-Served basis. Support@JPG.com responds instantly to e-mail received with a helpful set of locations to find additional information on Pegasus products including FAQ's, sample code, newsgroup locations and other current information pertaining to the use of the products. The support request is then added to the queue of outstanding requests. The goal of the support team to respond to each e-mail within 1 business day.

The sales team is always available as a backup to the support team. If you feel you have an urgent support or sales issue please contact Sales@JPG.com . They will assist you promptly.

Newsgroup Support

The Publicly accessible NNTP news groups located at News.PegasusImaging.com are available for each of the Controls as well as advanced imaging technology and a sample code group. We expect that the development community will freely access and search these newsgroups to find common questions and answers regarding specific uses of the controls.

On-Demand Phone Support

On-demand priority phone support can be purchased in 15 minute increments with a credit card via the Pegasus Imaging Corporation web site Support, General Info page. If you decide to purchase "on-demand" phone support, instructions will immediately be e-mailed upon receipt of your purchase.

Additionally, Pegasus offers three support plans for those customers whose commercial products or projects are sensitive or critical in nature, where immediate response and 'latest release' code are important.

1. Chariot Support

All Pegasus Imaging customers are given the opportunity to purchase a Chariot Support agreement. This is a maintenance and upgrade agreement that entitles customers to priority e-mail service, direct phone support from the support and development staff and free product upgrades for the covered products. Since upgrades are included for Chariot customers at no additional charge, Chariot customers can frequently save money, plus obtain the benefits of phone and expedited support. Pegasus Imaging reserves the right to change the terms of this service at any renewal period. Contact Sales via the web at www.PegasusImaging.com/contactform.htm for more information.

2. Galleon Support

Customers are given the opportunity to purchase Galleon Support for Pegasus Imaging products that are applications and for products that require Run Time licensing. Galleon Support includes licensing of product upgrades for deployed installations at no additional license fee cost. Pegasus Imaging reserves the right to change the terms of this service at any renewal period. Contact Sales via the web at www.PegasusImaging.com/contactform.htm for more information.

3. Atlas Support

All Pegasus Imaging customers are given the opportunity to purchase an Atlas Support agreement on currently supported products. This is an agreement that entitles customers to priority e-mail service and direct phone support from the support and development staff. It differs from Chariot Support in that it does not include version upgrades free of charge. Pegasus Imaging reserves the right to change the terms of this service at any renewal period. Contact Sales via the web at www.PegasusImaging.com/contactform.htm for more information.

For the latest and most up-to-date support information, access www.PegasusImaging.com/contact.htm

See Also

Operating Requirements | Trial Mode | Installing on a Development Machine


Pegasus Imaging Corporation

Pegasus Imaging is uniquely positioned to serve as your leading imaging technology supplier. A full suite of document imaging toolkits, forms processing technology, medical image compression SDKs, photo editing and compression libraries, browser-based image viewers, and video codecs provide advanced technology designed to enhance imaging software solutions. Fully functional trial downloads and customer-acclaimed support allow you to be certain your requirements will be met before purchase. Work with the best. Choose Pegasus Imaging for all your imaging needs.

Visit www.PegasusImaging.com for full product descriptions, FAQ's, downloads, demos, and contact information.

Pegasus Imaging

4001 North Riverside Drive

Tampa, FL 33603

Sales: 813-875-7575

Copyrights & Trademarks

Pegasus and the Pegasus Horse Logo are registered marks (®) of Pegasus Imaging Corporation.

Barcode Xpress, CapturePRO, FilePrinter, FormAssist, FormDirector, FormSuite, ISIS Xpress, The JPEG Wizard, MedXpress, NotateXpress, OCR Xpress, PDF Xpress, PICTools, ePIC, PICVideo, PrintPRO, SmartScan Xpress, SmartZone, ThumbnailXpress, and TwainPRO are trademarks (™) of Pegasus Imaging Corporation.

ImagXPress, FormFix, ScanFix, Prizm, ColorDrop, ColorEnhance, ColorFind, ColorForms, CompressDirector, Digital Mark Recognition (DMR), Image Detergent, ViewDirector and Virtual Scoring Center (VSC) by assignment are trademarks (™) or registered trademarks (®) of Pegasus Imaging Corporation.

Pegasus Imaging and/or its agents use these marks and brand names in connection with its goods and/or services, in the United States and other countries. Information in this document is subject to change without notice. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Pegasus Imaging Corporation.

Microsoft, Microsoft.NET, Visual Basic, Visual Studio and Visual Studio.NET are trademarks of Microsoft Corporation in the USA and/or other countries. All other product and brand names are the property of their respective owners.
See Also

License Agreement


Operating Requirements

Operating Systems

ThumbnailXpress™ runs on 32-bit Microsoft Windows operating systems: Vista, 2000 Professional and Server, XP Home and Professional and Server 2003. It works with 32-bit Windows versions running on 32 and 64-bit processors. It runs in 32-bit executables running under 64-bit Windows 2000 Server and 2003 Server. Although it may run, it is not supported on previous Windows versions (for example, Windows 95 and Windows 98).

Threading

Pegasus considers thread-safe to be when an application using this component can use multiple controls running in the same process, where they don't interfere with each other. The thread creating the control owns the control and is the only thread that can interact with it.

Development Environment

Microsoft .NET Framework 2.0, 3.0

Microsoft Visual Studio 2005

Microsoft Visual Studio 2008

Caching Data and Memory Usage

During normal operation ThumbnailXpress caches data to temporary files on the hard drive. The size of the image and the amount of text on an image dictate how much hard drive space each page uses. Each page added to a document also increases the amount of hard drive space needed. To ensure effective operation, there should be 7 to 8 MB of hard drive space for each 8 1/2 by 11 inch 300dpi 24bpp page of full text at 12pt font size.

See Also

Getting Support and Samples | Installing on a Development Machine | Run Time Licensing


Installing on a Development Machine

To Install ThumbnailXpress™ Component

Run the downloaded setup program which installs the development kit on your development machine. The downloaded development kit includes code samples for supported platforms. Samples are available through:

Start | Programs | Pegasus Imaging | ThumbnailXpress v2.0 menu.

By default this will register trial licensing which allows you to develop applications but not to distribute them. The trial license allows testing of all the functions and features.

Please see the topic 'Distributing with Your .NET Application' to understand the limits and details to converting licensing editions.
In order to distribute your finished application you must purchase and install a fully paid license from Pegasus Imaging Corporation. The paid licenses override trial licenses.

To Use ThumbnailXpress Help Files

Stand-alone Help File "PegasusImaging.WinForms.ThumbnailXpress2.chm"

Access the ThumbnailXpress stand-alone help through the Windows Start menu: Start | Programs | Pegasus Imaging | ThumbnailXpress v2.0

The stand-alone complied Help chm file is created with MS Help system version 1. To view Help 1 files, you must have:

  • Windows 2000 or higher (to view the file via the Windows HTML Help Viewer)
  • Internet Explorer 6.x or 7.0
  • MS HTML Help Viewer

From Within your Visual Studio Development Environment, Compiled Collection Help File "PegasusImaging.WinForms.ThumbnailXpress2.hxs"

Help 2 collection files install into Visual Studio.NET (VS). To view Help 2 files, you must have:

  • Windows 2000 or higher
  • Internet Explorer 6 or higher
  • Visual Studio .NET 2002 or higher
  • MS Help version 2

When ThumbnailXpress installs, if the system installation requirements for Help 2 files are met, the Help 2 file is included on the Start shortcut menu. If the installation requirements for Help 2 files are not met, then the Help 1 file installs on the Start shortcut.

Plugging ThumbnailXpress Help into Visual Studio

ThumbnailXpress Help 2 files integrate within the Help system in Visual Studio .NET. To access ThumbnailXpress Help within Visual Studio, do the following:

  • Ensure that the MSDN Library is installed in your Visual Studio environment. If it is not installed, re-install it from your VS.NET disc.
  • Ensure that MS Help Integration Kit is installed in your Visual Studio environment. If you do not have it installed:

1. Download the Help Integration kit from MSDN

2. Close Visual Studio.

  • Re-open Visual Studio, select the Help Menu and the Contents submenu. Verify Help files for Pegasus Imaging controls are listed.

If Pegasus Help is not listed:

  1. Search for "VSCC" in Visual Studio Help, leaving the "Filtered by:" list box blank. Select the "Visual Studio .NET Combined Help Collection Manager" topic.
  2. Select the Help 2 collections available on your PC under the heading "Collections available for inclusion in VSCC."
  3. Take care when excluding Help collections from the default VSCC collection. These collections may be necessary to view required documentation. Instead, use the "Filtered by:" field on the Contents tab of the Help panel to focus searches on Pegasus Imaging topics. Leave the "Filtered by:" list box empty to view the entire Pegasus Imaging Help files.
  4. Select the Update VSCC button.
  5. Close all instances of Visual Studio and Microsoft Document Explorer. When you restart Visual Studio, the VSCC Help collection revises with your changes. (Note: this may take several minutes.)
  6. Check the Visual Studio Help/Contents tab again to see the Help collections available to you.
  • Select the ThumbnailXpress Help file to view Help content.
See Also

Operating Requirements | Run Time Licensing | Development Mode | License Agreement | Distributing with Your .NET Application


Trial Mode

Default Installation

The default installation installs Trial Mode licensing. This allows you to test features and functions and develop applications but not distribute them. Installing ThumbnailXpress™ in trial mode provides you with access to all features and functionality of the ThumbnailXpress product. E-mail support is available with the trial license.

When using the trial version of ThumbnailXpress, an evaluation dialog box displays periodically.

Applications built with a trial license can only be run on a computer that has ThumbnailXpress Licensing installed on it.

Changing Trial Mode Behavior

You have the flexibility to change the behavior of ThumbnailXpress in evaluation mode as follows:

  • To facilitate server/service mode evaluations, you can choose to halt the component processing after 5 minutes in lieu of displaying an evaluation dialog box periodically. This is the TimeOut setting for the EvaluationMode property.

Changing ThumbnailXpress Edition

Installing ThumbnailXpress in trial mode enables you to try out all the editions associated with ThumbnailXpress, by setting the IXLicenseEdition property. Any edition for which you do not have paid licensing will display the evaluation dialog box or timeout. For example, if you have paid for and installed the licensing strings for ImagXpress Standard and you would like to evaluate ThumbnailXpress using ImagXpress Professional, you can change the IXLicenseEdition property within ThumbnailXpress from Standard to Professional. The component will then run in Professional mode with trial behavior, including the periodic display of dialog boxes.

See Also

Development Mode | Run Time Licensing | License Agreement | Getting Support and Samples


Development Mode

To suppress the evaluation dialog box and deploy your application, or attain technical support (beyond e-mail), as well as future product updates and upgrade notifications, you must update from a trial version to a paid version of the ThumbnailXpress™ development kit.

1. Purchase Development Kit(s)

To purchase licensing of the ThumbnailXpress development kit, use one of the following options:

  • Purchase online at www.PegasusImaging.com.
  • Contact Sales via the web at www.PegasusImaging.com/contactform.htm for more information.
  • Contact a Pegasus Imaging Corporation reseller.

When the development kit is purchased, we e-mail a serial number & registration code to you. You need these codes to upgrade from trial to paid licensing.

2. Register the ThumbnailXpress Product

When you purchase ThumbnailXpress online or through Sales@jpg.com, your product ownership is automatically registered.

To register products purchased through a reseller, use the form found at www.PegasusImaging.com/registration.htm.

See Getting Support and Samples for a discussion of benefits to providing your name to Pegasus Imaging. We never sell our customer information.

If your registration information should change, visit www.PegasusImaging.com/contact.htm for forms to update registration information.

3. Update Your ThumbnailXpress Product Version from Trial to Paid Licensing

Updating your ThumbnailXpress from trial to paid licensing will suppress the trial behavior, including the evaluation dialog box or timeout.

To update components from trial to paid licensing:

  • Enter your new license codes using one of the following options:
    • Enter licensing information (serial number, registration code and personal registration information) during component installation while downloading the latest release from www.PegasusImaging.com (the recommended approach).
    • Alternatively, licensing information (serial number, registration code and personal registration information) can be entered through the Visual Development Environment in response to the dialog display.

For more information on Run Time licensing, see the Pegasus Imaging website for more detailed information regarding Run Times and Deployment Licensing.

See Also

Trial Mode | Run Time Licensing | License Agreement | Getting Support and Samples


Run Time Licensing

Run Time & Deployment Licensing

All copyrights to Pegasus Imaging development kits and software are retained by Pegasus Imaging Corporation. ALL RIGHTS RESERVED. Your use of any of Pegasus Imaging software or run-times created with Pegasus Imaging software is allowed under license terms granted by Pegasus Imaging. It is the Licensee's responsibility to honor the terms of such license grants.

Locking Mechanism

ThunbnailXpress™ contains a locking mechanism that does not permit you to distribute applications created with evaluation versions of ThunbnailXpress. Prior to distributing an application that utilizes ThumbnailXpress, you must purchase and enable run-time licensing. If the application will be delivered on the web, you must also purchase and enable web application licensing.

Obtaining Appropriate Licensing

The Licensee is required to purchase one copy of our development kit(s) for each developer in addition to obtaining the appropriate license agreement prior to deploying applications which contain Pegasus code.

Pegasus Imaging software applications and development tools are limited for use on a single CPU. Any run times or copies created must be granted by a direct license from Pegasus Imaging Corporation. These "end user" licenses provide the terms and limits of number and usage.

All prospective customers have every opportunity to evaluate Pegasus Imaging's products prior to purchasing. Product licensing is priced to cover what is considered to be normal (and even high) use. In addition, Pegasus Imaging fully supports and warrants its code and pricing reflects those costs as well. The larger and more valuable an application deployment is, the higher the support and warranty risk is for Pegasus.

Review the licensing categories, and select the one that matches your deployment. Special circumstances should be discussed with a Pegasus Imaging representative.

For more information on Run Time licensing, see the Pegasus Imaging website for more detailed information regarding Run Times and Deployment Licensing.

See Also

www.PegasusImaging.com | Getting Support and Samples | Development Mode | License Agreement | Distributing with Your .NET Application


License Agreement

Pegasus Imaging Corporation

SOFTWARE LICENSE AGREEMENT

GRANT OF LICENSE

This Pegasus Imaging Corporation ("PEGASUS") Agreement ("License") permits Licensee ("LICENSEE") the right to use one copy of a properly registered Pegasus Development Toolkit ("TOOLKIT") for development purposes on any single computer, provided the TOOLKIT is in use on only one computer at any time. TOOLKIT is "in-use" on a computer when it loads into temporary memory (that is, RAM) or installed into the permanent memory (that is, hard disk, CD-ROM, or other storage device) of that computer.

REDISTRIBUTION OF THE TOOLKIT RUNTIMES

PEGASUS does NOT grant any Run Time licenses with the TOOLKIT purchase, except by specific exemptions described on our licensing web pages. For Run Time Licensing information, please visit our web site (www.PegasusImaging.com/licensing.htm), or contact our sales staff. Any rights to distribute TOOLKIT run times as part of the LICENSEE's software application or derivative works ("PRODUCT"), require you to acknowledge and uphold this License Agreement and agree to notify PEGASUS immediately of any changes in status or violations. In cases where PEGASUS grants the LICENSEE a right to use, reproduce, display or otherwise distribute or transfer copies of TOOLKIT run times, LICENSEE agrees and affirms the following:

a) LICENSEE is not using PEGASUS' name, logo, or trademarks to market PRODUCT without prior written approval of PEGASUS.

b) LICENSEE agrees to indemnify, hold harmless and defend PEGASUS from and against any claims or lawsuits, including attorney's fees, that arise or result from the use or distribution of PRODUCT.

c) Only the TOOLKIT run times can be distributed. Distribution of the TOOLKIT development kit, documentation, source code, or the distribution unlock codes, is a violation of this agreement.

d) LICENSEE includes a statement substantially similar to the following within derivative work's documentation and about box: "This product contains portions of imaging code owned by Pegasus Imaging Corporation, Tampa, FL, (www.PegasusImaging.com). ALL RIGHTS RESERVED."

If ANY of the above terms are not applicable to LICENSEE'S situation, or any of the above cannot be complied with, or LICENSEE needs modifications to this license, for any reason; then LICENSEE shall obtain an expanded direct license from PEGASUS for derivative works, (available by phone at: 813-875-7575, x321, by e-mail at: Sales@jpg.com.

PEGASUS reserves the right to charge the LICENSEE up to ten times the normal license price for the use of each unlicensed copy of PRODUCT. The license granted herein and all of your rights to use or maintain possession of TOOLKIT shall terminate immediately upon breach of any material provisions of this Agreement.

This license grants rights to LICENSEE for only the PEGASUS code (TOOLKIT) mentioned above and does not convey any other rights of use or distribution to PEGASUS technology.

COPYRIGHT

The Software is owned by PEGASUS or Pegasus Imaging Corporation and is protected by United States copyright laws and international treaty provisions. LICENSEE may not remove or alter the copyright notice from any copy of the Software or any copy of the written materials, accompanying the Software.

OTHER RESTRICTIONS

This PEGASUS License Agreement is LICENSEE's proof of license to exercise the rights granted herein and must be retained by LICENSEE. LICENSEE may not rent, lease or transfer TOOLKIT or parts thereof. LICENSEE may not reverse engineer, decompile or disassemble TOOLKIT.

NO WARRANTY

ANY USE BY LICENSEE OF THE SOFTWARE IS AT THE LICENSEE'S OWN RISK. THE SOFTWARE IS PROVIDED FOR USE ONLY WITH WINDOWS PRODUCTS AND RELATED APPLICATION SOFTWARE AND/OR HARDWARE PRODUCTS. THE SOFTWARE IS PROVIDED FOR USE "AS IS" WITHOUT WARRANTY OF ANY KIND. TO THE MAXIMUM EXTENT PERMITTED BY LAW, PEGASUS DISCLAIMS ALL WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. PEGASUS IS NOT OBVLIGATED TO PROVIDE ANY UPDATES TO THE SOFTWARE.

NO LIABILITY FOR CONSEQUENTIAL DAMAGES

In no event shall PEGASUS be liable for any damages whatsoever (including, without limitation, incidental, direct, indirect and consequential damages, damages for loss of business profits, business interruption, loss of business information, or other pecuniary loss) arising out of the use or inability to use this PEGASUS product, even if PEGASUS has been advised of the possibility of such damages. Because some states/countries do not allow the exclusion or limitation of liability for consequential or incidental damages, the above limitation may not apply to LICENSEE.

INDEMNIFICATION BY LICENSEE

If LICENSEE distributes TOOLKIT in violation of this Agreement, LICENSEE agrees to indemnify, hold harmless and defend PEGASUS and its suppliers from and against any claims or lawsuits, including attorney's fees that arise or result from the use or distribution of TOOLKIT in violation of this Agreement.

This Agreement is governed by the laws of the State of Florida. The program and data contained in this TOOLKIT Product are provided with Restricted Rights. Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set forth in FAR 52.227-14 (Alternate III) or subparagraph (c)(1)(II) of the rights in technical data and computer software clause at 252.227-7013. Manufacturer is Pegasus Imaging Corporation, 4001 Riverside Drive, Tampa, FL, 33603.

For questions concerning this Agreement, or to contact PEGASUS for any reason, please contact Pegasus Imaging Corporation by phone at 1-813-875-7575 x321 or email Sales@JPG.com.

See Also

Trial Mode | Development Mode | Run Time Licensing | Distributing with Your .NET Application


Verify You Are Using the Latest Service Pack

Service pack updates will not overwrite paid licensing. Your paid licensing will continue to work and you will not be required to re-enter your purchased registration codes. Service pack updates do not include any changes that might "break" previously developed and/or deployed code.

Verify Latest Development Components

To verify you are using the latest version of a Pegasus Imaging Development Component or Components, please use the PegConnect utility program. Please note that a Help File for each product may be found on the Start Bar under Pegasus, or in C:\Windows\Help.

PegConnect is installed by all component product installers and is accessible through the Windows Start menu:

Start | Programs | Pegasus Imaging | Common | Utilities

PegConnect Allows You To:

  1. Check with Pegasus Imaging via online connection and verify that the installed version of the component includes all the most recent updates
  2. Update to the latest version automatically with your permission
  3. Determine if a control is registered or unregistered on the machine
  4. Easily change the registration status from registered to non-registered, or non-registered to registered

Alternatively, you can see the currently released product build numbers at www.PegasusImaging.com/latestbuilds.htm.

If you require further assistance or have questions or comments, please see the topic on Getting Support for more detailed information.

See Also

Getting Support and Samples | Installing on a Development Machine


Distributing with Your .NET Application

Distributing ThumbnailXpress™

Check for Proper Licensing and Unlock Codes

ThumbnailXpress contains a locking mechanism that does not permit you to distribute applications created with evaluation versions of ThumbnailXpress. Prior to distributing an application that utilizes ThumbnailXpress, you must purchase and enable run-time licensing. If the application will be delivered on the web, you must also enable web application licensing.

DLL Files to Distribute

Required

  • Distribute the appropriate assembly DLL file with applications using the ThumbnailXpress Product:

PegasusImaging.WinForms.ThumbnailXpress2.dll - .NET component - .NET Control for thumbnail creation

Optional

  • The following files are optional and are only required if you are using other Pegasus Imaging products for image processing and/or image acquisition:

PegasusImaging.WinForms.ImagXpress9.dll - .NET component (Only required if ImageXpress® is used for image processing in your application)

PegasusImaging.WinForms.PDFXpress2.dll - .NET component (Only required if PDF Xpress™ is used for image acquisition in your application).

See Also

Getting Support and Samples | Installing on a Development Machine | Development Mode | Run Time Licensing | License Agreement | Verify You Are Using the Latest Service Pack


Definitions, Acronyms and Abbreviations

Pegasus Imaging Definitions, Acronyms, and Abbreviations

PIC: Pegasus Imaging Corporation

Thread-safe: An application using this component can use multiple controls running in the same process, where they don't interfere with each other. The thread creating the control owns the control and is the only thread that can interact with it.

Industry Definitions, Acronyms, and Abbreviations

BLOB: Binary Large Object


Set Cache Behavior

All thumbnail images are generated with unique IDs and are cached for rapid display access purposes. The application defines and manages desired caching behavior using a ThumbnailCache.

  • The CacheFile and CacheFilePath properties return the name and location of the cache file.
  • The CacheDiskLimit and CacheMemoryLimit properties specify the maximum size of the cache.
  • To empty the Thumbnail Cache, call the CacheClear method.
  • To flush the cache to disk, call the CacheFlushMemory method.
See Also

ThumbnailCache Class | CacheFile Property | CacheFilePath Property | CacheDiskLimit Property | CacheMemoryLimit Property | CacheClear Method | CacheFlushMemory Method


Set Threading Behavior

Threading in Image Generation

ThumbnailXpress™ uses background image generation threads to improve responsiveness. At component start-up, ThumbnailXpress determines an initial count of background threads based on the host computer's capabilities. To keep operation responsive, ThumbnailXpress monitors the time consumed by a background thread and will start an additional thread when it has determined that a particular thread's image retrieval/generation time has exceeded the user settable ThreadStartThreshold property value.

By default, the value of this property is 3000 milliseconds (3 seconds). Additionally, ThumbnailXpress will abandon a thread, and free up its resources, if its retrieval/generation time has exceeded the ThreadHungThreshold property value. By default, the value of this property is 9000 milliseconds (9 seconds). As noted, when needed, ThumbnailXpress will create additional threads but will not allow the count of concurrent background threads to exceed the value specified by the MaximumThreadCount property.

The default value for the MaximumThreadCount property is 2 times the calculated initial count of background threads. The allowable value range for this property is 1 thru 32. Too many background threads quickly degrade performance and a good rule of thumb for all these threading properties is to leave them at the default values. For applications that don’t want an image loading attempt to be abandoned and want to allow, for example, the potential of very slow internet access for retrieving images, set the ThreadHungThreshold property to a higher value.

Multiple ThumbnailXpress Instances

It's important not to run one instance of the control from multiple application threads, instead, create a separate instance of the control for each application thread. For a well-presented primer on threading, see Microsoft's "What Every Dev Must Know About Multithreaded Apps" at the Visual Studio.NET Developer Center (08/05, msdn.microsoft.com/msdnmag/)

The Performance tab in the Microsoft Windows Task Manager dialog box (hold Ctrl, Alt and Delete) displays multiple CPU Usage History boxes for both logical and physical CPUs. The image below shows a single CPU with two logical CPU's.

See Also

ThreadStartThreshold Property | ThreadHungThreshold Property | MaximumThreadCount Property


Set Thumbnail Appearance

The application controls the appearance of thumbnails in the display using properties in ThumbnailXpress™.

ThumbnailXpress Control Window Appearance

The appearance of the ThumbnailXpress control window is controlled as follows:

  • The background color for the control (BackColor)
  • The foreground color for the control (ForeColor)
  • The style of the border of the control (BorderStyle)
  • The margins of the control (BottomMargin, TopMargin, RightMargin, LeftMargin)
  • Scrollbar visibility (ShowScrollbar)
  • The scrollbar direction (ScrollDirection)

Thumbnail Cell Appearance

The appearance of each individual thumbnail is defined using the "Cell" properties. The following can be specified:

  • The thumbnail border color and width (CellBorderColor, CellBorderWidth)
  • The dimensions of each thumbnail (CellHeight, CellWidth)
  • The spacing between each thumbnail (CellHorizontalSpacing, CellVerticalSpacing)
  • The color of the fill between thumbnails (CellSpacingColor)
  • The background color of selected thumbnails (SelectBackColor)
  • Whether a placeholder image is drawn while waiting for the thumbnail to be generated (ShowImagePlaceholders)

Thumbnail Descriptor Appearance

The appearance of each thumbnail's descriptor is specified using the "Descriptor" properties:

  • The alignment of the descriptor (DescriptorAlignment)
  • The background color of the text in the descriptor (TextBackColor)
  • The font used for the text (Font)
  • The format of the descriptor (DescriptorDisplayMethod)

Set Icon Display Appearance

ThumbnailXpress provides the application with the option to display a pre-image generation "placeholder" icon while the image is being loaded and the thumbnail generated. When ShowImagePlaceholders is set to true, a placeholder image is drawn while waiting for the thumbnail to be generated and a cancel icon is displayed if the generation is cancelled.

The thumbnail image is being generated. Once generated, this icon is replaced with the thumbnail image.

The thumbnail image loading was cancelled.

The application can also specify the desired action to take when an error occurs during image loading or thumbnail generation. ThumbnailXpress can either display an error icon to indicate that the thumbnail did not load, or simply abort the loading process without displaying any icon in the control window. When ErrorAction is set to UseErrorIcon, the following icons are displayed, depending on the error encountered:

The thumbnail image was not loaded, due to an error.

The thumbnail image was not loaded, because the image file type is not supported by ThumbnailXpress.

The thumbnail image was not loaded, because the image file type was unknown to ThumbnailXpress.

The thumbnail image was not loaded, because the required software is not licensed by the application.

See Also

ThumbnailXpress Class


Glossary Item Box

Enabled Property | ThumbnailXpress Class | SelectionMode Enumeration | IntraComponentThumbnailDragDropEnabled Property | InterComponentThumbnailDragDropEnabled Property | EnableAsDragSourceForExternalDragDrop Property | EnableAsDropTargetForExternalDragDrop Property | DblClickDirectoryDrillDown Property

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Set User Interaction Behavior

The application end-user can navigate, select, and move thumbnails within the ThumbnailXpress™ control, between multiple ThumbnailXpress controls, and between multiple applications. The application establishes how the user will interact with the control, by setting the following ThumbnailXpress properties:

Enable User Interaction

ThumbnailXpress v2 enables end-user navigation of thumbnails via user-generated events. To enable the ThumbnailXpress control to handle user-generated events, set the Enabled property.

Set Selection Behavior

The SelectionMode property specifies the behavior that is desired when an end-user selects a thumbnail.

Set Drag and Drop Behavior

To enable the end-user to drag and drop thumbnails within the ThumbnailXpress component, set IntraComponentThumbnailDragDropEnabled.

To enable the end-user to drag and drop thumbnails between multiple ThumbnailXpress controls, set InterComponentThumbnailDragDropEnabled.

To enable the end-user to drag thumbnails from the ThumbnailXpress component to another application, set EnableAsDragSourceForExternalDragDrop.

To enable the end-user to drag thumbnails from other applications into the ThumbnailXpress component, set EnableAsDropTargetForExternalDragDrop.

Set Directory Drill Down Behavior

If DblClickDirectoryDrillDown is enabled within the ThumbnailXpress object, then when the end-user double clicks on a folder icon in the ThumbnailXpress component, the thumbnails of images within the directory will be displayed. This enables the end user to navigate through folder structures to locate thumbnails of interest.

See Also

Enabled Property | ThumbnailXpress Class | SelectionMode Enumeration | IntraComponentThumbnailDragDropEnabled Property | InterComponentThumbnailDragDropEnabled Property | EnableAsDragSourceForExternalDragDrop Property | EnableAsDropTargetForExternalDragDrop Property | DblClickDirectoryDrillDown Property


Specify Loading and Rendering Options

Before loading any images, specify desired loading and rendering behavior for thumbnails as follows:

  • Set PreserveBlack, if desired, to darken lines in the thumbnail image. This is useful to improve readability / recognizability of the thumbnail image to the end-user.
  • Set CameraRaw, if desired, to specify whether the control will examine the image on loading to determine if the image data is in a camera raw format, and to identify that format. To optimize performance, CameraRaw should be set to false when not needed.
CameraRaw is only applied when the images are loaded from a local file.

See Also

ThumbnailXpress Class | PreserveBlack Property | CameraRaw Property


Glossary Item Box

ThumbnailItemCollection Class | ThumbnailItem Class | AddItemsFromFile Method | Insert Method | Add Method | Filename Property | Page Property | CadLayoutNumber Property | Descriptor Property | UserTag Property

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Generate Thumbnails from File

ThumbnailXpress™ provides the user with the ability to generate thumbnails from one or more pages of a local or remote file.

Call ThumbnailItemCollection AddItemsFromFile to load and generate thumbnails from one or more pages of a file. When the ExpandMultiPage parameter is set to true, a thumbnail will be generated for each page in a multi-page file. When the ExpandMultiPage parameter is set to false, only the first page is generated, and the thumbnail icon will show a "+" to indicate that the thumbnail is the first page of a multi-page file.

Alternatively, a thumbnail can be added or inserted into the collection by defining a ThumbnailItem, then calling a ThumbnailItemCollection Insert or Add method. If the Verify parameter is included and set to true, ThumbnailXpress will check to make sure that the local file specified in the supplied ThumbnailItem has a valid file name (e.g. it exists and can be understood by the control).

If the file name indicates a remote path, the Verify parameter is ignored.

When defining a ThumbnailItem, the application can specify the Filename, Page, and if CAD, the CadLayoutNumber to access. The application provides the Descriptor to be displayed with the thumbnail, and a UserTag to record application-specific information about the thumbnail.

See Also

ThumbnailItemCollection Class | ThumbnailItem Class | AddItemsFromFile Method | Insert Method | Add Method | Filename Property | Page Property | CadLayoutNumber Property | Descriptor Property | UserTag Property


Generate Thumbnails from Directory

ThumbnailXpress™ v2 enables loading of images from a local or remote directory, based on specified filter criteria. One or more filters can be defined, enabling customized search and display of thumbnail images. ThumbnailXpress keeps a list of filters that have been defined, and applies all enabled filters when loading images from a directory.

Add or Delete a Filter

To add a filter, first define a Filter object, specifying the filter criteria. For example, directory items can be filtered based on FileSize, Type, and FileDate. The filter can be modified at any time by accessing the properties within the Filter. Next, add the filter by calling FilterCollection Add. An index is returned, uniquely identifying the filter in the list.

Generate Thumbnails from Files within a Directory

Filters are applied when loading images from a directory into the ThumbnailXpress control. All Enabled filters will be applied to determine which images to load. If no filters are enabled, then all folders and files will be loaded.

Call ThumbnailItemCollection AddItemsFromDirectory to load images and generate thumbnails from all files that meet filter criteria in the specified directory. When the control paints, the thumbnail images are displayed.

If the directory contains multi-page files, only the first page of the file is loaded. The thumbnail icon will show a "+" to indicate that the thumbnail is the first page in a multi-page file. Thumbnails of additional pages within the file can be added by calling AddItemsFromFile.

See Also

Filter Class | FilterCollection Class | ThumbnailItemCollection Class


Generate Thumbnails from PDF File

When PDF Xpress™ is installed, ThumbnailXpress™ can generate thumbnails from PDF files, locally stored in a file or directory. ThumbnailXpress v2 works seamlessly with either PDF Xpress v1 or PDF Xpress v2. When a request to generate a thumbnail is made by calling ThumbnailItemCollection methods: Add, AddItemsFromDirectory, AddItemsFromFile, or Insert, if the specified file is a PDF, then ThumbnailXpress will look for and use the most recent installed version of PDF Xpress to render the PDF.

PDF files must be located in a local file or directory to enable thumbnail generation.

See Also

ThumbnailItemCollection Class


Generate Thumbnails from Stream

A thumbnail can be added or inserted into the collection by defining a ThumbnailItem, and then using the FromStream method to specify a stream from which to acquire the image data. Then call the ThumbnailItemCollection methods InsertItemFromStream or AddItemFromStream.

The ThumbnailItemCollection Add method cannot be used to add an item from stream.
See Also

ThumbnailItem Class | ThumbnailItemCollection Class


Get Thumbnail Information

All thumbnail images are generated with unique IDs and are cached for rapid display access purposes. Access the properties within the ThumbnailItem for information about the thumbnail, including the name of the file from which the thumbnail was generated (Filename), and the page within the file that the thumbnail represents (Page).

The thumbnail image can be acquired as an Hbitmap, Hdib, or Bitmap.

Note: Information about the thumbnail will not be available until generation of the thumbnail is complete. Use the ItemComplete event to ensure that generation is complete prior to checking thumbnail information.

See Also

ThumbnailItem Class | Filename Property | Page Property | Hbitmap Property | Hdib Property | Bitmap Property | ItemComplete Event


Display Thumbnails

The control will update on each paint, to reflect the current state of the thumbnails. When adding multiple thumbnails, it may be beneficial to disable painting to reduce redraw flicker. To disable paint, call BeginUpdate prior to loading any images. Then, load images and generate thumbnails. You can query the status of the thumbnail by accessing the ThumbnailItem Status. When all thumbnails have been generated and are ready for display, call EndUpdate. Painting will resume, displaying all the generated thumbnails (or error icons, if generation failed).

See Also

ThumbnailXpress Class | ThumbnailItem Class


Delete Thumbnails

A thumbnail can be removed from the ThumbnailItemCollection by calling Remove, RemoveAt, or Clear. The removed thumbnails will not be displayed on the next paint.

If the Thumbnail was generated with an Hbitmap that was obtained through Hbitmap, the application must call DisposeHbitmap to free all resources associated with the Hbitmap.
See Also

ThumbnailItem Class | ThumbnailItemCollection Class


Modify Thumbnails

Modify Thumbnail Properties

A thumbnail's properties can be modified, to include a different Descriptor or user UserTag.

Modify the Thumbnail Image

If the thumbnail image was loaded from file, the thumbnail image can be replaced by a different page in the file by updating the Page property of the ThumbnailItem. A new image is generated for the ThumbnailItem, and display is updated on the next paint.

If the thumbnail image was loaded from file, the thumbnail image can be replaced by a page in a different file by updating the Filename property of the ThumbnailItem. A new image is generated for the ThumbnailItem, and display is updated on the next paint.

If the thumbnail represents a page in a CAD file, the thumbnail image can be replaced by a different layout in the file by updating the CadLayoutNumber property of the ThumbnailItem. A new image is generated for the ThumbnailItem, and display is updated on the next paint.

If the thumbnail image was loaded FromStream, the thumbnail image can be replaced by an image from a different stream by calling FromStream. A new image is generated for the ThumbnailItem, and display is updated on the next paint.

See Also

ThumbnailItem Class


Manage End User Navigation

ThumbnailXpress™ v2 enables end-user navigation of thumbnails via standard Windows control events within the ThumbnailXpress object. To specify how the ThumbnailXpress control interprets end-user actions, be sure to set user interaction behavior.

Verify that the Enabled property has been set, to enable the ThumbnailXpress control to handle user-generated events.

End-User Scrolling

The application end-user can scroll through thumbnails in the thumbnail control window, using the supplied scrollbars. Alternatively, the end-user may use the arrow, page up/down, home, and end keys to navigate thumbnails within the control window.

End-User Selecting

The SelectionMode property specifies the behavior that is desired when an end-user selects a thumbnail. The application end-user selects thumbnail items using a combination of mouse click with control and shift keys.

End-User Drag and Drop

The application end-user can drag and drop thumbnails within the ThumbnailXpress control, between multiple ThumbnailXpress controls, and between the ThumbnailXpress control and other applications, by holding the mouse down over a thumbnail, moving the mouse, then releasing the mouse in the desired location. Set the user interaction behavior to specify desired support for these features.

End-User Directory Drill Down

If DblClickDirectoryDrillDown is enabled within the ThumbnailXpress object, then when the end-user double clicks on a folder icon in the ThumbnailXpress component, the thumbnails of images within the directory will be displayed. This enables the end user to navigate through folder structures to locate thumbnails of interest.

See Also

Filter Class | ThumbnailXpress Class


Navigate Programmatically

Scrolling

Scrolling the thumbnail control can be controlled programmatically by calling the ScrollItems method to specify the scrolling action and magnitude. The view changes to reflect the requested scrolling. Alternatively, call EnsureVisible to programmatically scroll the thumbnail control until a specified thumbnail is in view.

Selecting

Individual thumbnails can be selected programmatically by calling the Items method and specifying the thumbnail to select. The SelectedThumbnailItemCollection reflects the number of thumbnails that have been selected, both programmatically as well as by end-user.

See Also

ThumbnailXpress Class | SelectedThumbnailItemCollection Class


Save Thumbnails

ThumbnailXpress™ has no saving capabilities; only ImagXpress® can be used to save thumbnail images.


Print Thumbnails

ThumbnailXpress™ has no printing capabilities; only ImagXpress® and PrintPRO™ can be used to print thumbnail images.


Debug

Generate a Debug Log

To generate a debug log file, set Debug to true. The log file is kept at the location specified by DebugLogFile. Set the DebugErrorLevel to Development or Detailed to indicate the level of detail to be logged.

Errors

16000 - PegasusImaging.WinForms.ThumbnailXpress2.ThumbnailXpressException
16001 - PegasusImaging.WinForms.ThumbnailXpress2.ThumbnailXpressException
16002 - System.ArgumentException
16003 - System.ArgumentOutOfRangeException
16004 - System.SystemException
16005 - System.IO.IOException
16006 - PegasusImaging.WinForms.ThumbnailXpress2.ThumbnailXpressException
16007 - PegasusImaging.WinForms.ThumbnailXpress2.ThumbnailXpressException
16008 - PegasusImaging.WinForms.ThumbnailXpress2.ThumbnailXpressException
16009 - PegasusImaging.WinForms.ThumbnailXpress2.ThumbnailXpressException
16010 - System.InvalidOperationException
16011 - System.InvalidOperationException

See Also

Getting Support and Samples | ThumbnailXpress Class | ThumbnailXpressException Class


See Also

PegasusImaging.WinForms.ThumbnailXpress2 Assembly

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Inheritance Hierarchy

Classes

Class | Description
ErrorEventArgs | ErrorEventArgs is the argument information for the ThumbnailXpress.Error event.
Filter | This class exposes methods and properties for specifying match and comparison image file criteria that may be imposed when thumbnail images are loaded from a file system directory using the ThumbnailItemCollection.AddItemsFromDirectory method.
FilterCollection | This class provides access and manipulation functionality for one or more filter objects. Filtering criteria for all enabled filter objects in the collection are applied to all image files that are specified by a ThumbnailItemCollection.AddItemsFromDirectory method call.
FilterCollectionEnumerator | The FilterCollectionEnumerator class provides a lockable IEnumerator interface for the FilterCollection class. When locked, the FilterCollectionEnumerator provides thread-safe read-only access to the FilterCollection.
ItemCompleteEventArgs | ItemCompleteEventArgs is the argument information for the ThumbnailXpress.ItemComplete event.
Licensing | The Licensing class provides ThumbnailXpress licensing methods and properties access.
LoadFromStreamEventArgs | LoadFromStreamEventArgs is the argument information for the ThumbnailXpress.LoadFromStream event.
SelectedThumbnailItemCollection | SelectedThumbnailItemCollection class provides selected Thumbnail Item manipulation functionality. The collection provides access to the selected thumbnail items in the list display. Adding or Removing selected items will cause the list display to update if appropriate
SelectedThumbnailItemCollectionEnumerator | SelectedThumbnailItemCollectionEnumerator class provides a lockable IEnumerator interface for the SelectedThumbnailItemCollection class.
ThumbnailCache | This class exposes to the user properties and methods to access the memory and file caching parameters for ThumbnailXpress.
ThumbnailItem | ThumbnailItem class exposes properties for accessing individual thumbnail item data, including image filename, item type, page number, bitmap, page count, and processing status
ThumbnailItemCollection | ThumbnailItemCollection class provides thumbnail item manipulation and image presentation functionality.
ThumbnailItemCollectionEnumerator | ThumbnailItemCollectionEnumerator class provides a lockable IEnumerator interface for the ThumbnailItemCollection class.
ThumbnailXpress | The Thumbnail User Control provides displaying of supported image types as thumbnails inside individual cells in a scrollable collection.
ThumbnailXpressEvents | This class implements the ThumbnailXpress events.
ThumbnailXpressException | Summary description for ThumbnailXpressException.

Enumerations

Enumeration | Description
DebugErrorLevel | Option value which determine the amount of logging detail to be sent to the log file.
DescriptorAlignments | Option values which determine the alignment of the descriptor text display.
DescriptorDisplayMethods | Option value which determine the source of descriptor text.
ErrorAction | Option values which determine the action taken if thumbnail processing error are encountered.
EvaluationMode | Option values which determine the evaluation modes available for use.
FilterComparison | Option values which specify the desired oomparison outcome for a file date or size filter.
FilterType | Option values which determine the thumbnail image file parameter that is to be compared or matched by a filter.
IXLicenseEdition | Option values which control the ImagXpress Edition that the ThumbnailXpress control uses.
ScrollDirection | Option values which determine the direction the thumbnails will scroll in the control.
ScrollItemsType | Option values which specify the incremental amount or whether a positional programmatic scroll operation is desired.
SelectionMode | Option values which determine the Thumbnail Item selection mode for the control.
ThumbnailStatus | Option values which determine the Thumbnail item image data validation and generation status.
ThumbnailType | Option values which specify the type of thumbnail (image, directory, etc.) for a thumbnail item.

See Also

PegasusImaging.WinForms.ThumbnailXpress2 Assembly


ErrorEventArgs Class

ErrorEventArgs Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ErrorEventArgs Class

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ErrorEventArgs Class

ErrorEventArgs is the argument information for the ThumbnailXpress.Error event.

For a list of all members of this type, see ErrorEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.ThumbnailXpress2.ErrorEventArgs

Syntax

[Visual Basic]
Public Class ErrorEventArgs
   Inherits EventArgs
[C#]
public class ErrorEventArgs : EventArgs
[C++]
public __gc class ErrorEventArgs : public EventArgs
[C++/CLI]
public ref class ErrorEventArgs : public EventArgs

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

ErrorEventArgs Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ErrorEventArgs Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ErrorEventArgs Class Members

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ErrorEventArgs Class

ErrorEventArgs overview

Public Properties

Public Property ItemIndex | Gets and sets the index for the Thumbnail Item collection member which incurred an error during thumbnail generation.
Public Property Message | Gets and sets the error message for the Thumbnail item collection member which incurred an error during thumbnail generation.
Public Property Number | Gets and sets the error number for the Thumbnail Item collection member which incurred an error during thumbnail generation.

See Also

ErrorEventArgs Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ItemIndex Property

ErrorEventArgs Class | ErrorEventArgs Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ItemIndex Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ErrorEventArgs Class : ItemIndex Property (ErrorEventArgs)

Gets and sets the index for the Thumbnail Item collection member which incurred an error during thumbnail generation.

[Visual Basic]
Public Property ItemIndex As Integer
[C#]
public int ItemIndex {get; set;}
[C++]
public: __property int get_ItemIndex();
public: __property void set_ItemIndex(
   int value
);
[C++/CLI]
public:
property int ItemIndex {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the zero-based index of the thumbnail.

Remarks

This index only be valid if there are no additions or deletions to the thumbnail item collection prior to use of this index value.

Requirements

Platforms: See Distribution Requirements

See Also

ErrorEventArgs Class | ErrorEventArgs Members


Message Property

ErrorEventArgs Class | ErrorEventArgs Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Message Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ErrorEventArgs Class : Message Property

Gets and sets the error message for the Thumbnail item collection member which incurred an error during thumbnail generation.

[Visual Basic]
Public Property Message As String
[C#]
public string Message {get; set;}
[C++]
public: __property string* get_Message();
public: __property void set_Message(
   string* value
);
[C++/CLI]
public:
property String^ Message {
   String^ get();
   void set (String^ value);
}

Return Type

An integer value which represents the error message.

Remarks

This message can provide additional information about the error.

Requirements

Platforms: See Distribution Requirements

See Also

ErrorEventArgs Class | ErrorEventArgs Members


Number Property

ErrorEventArgs Class | ErrorEventArgs Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Number Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ErrorEventArgs Class : Number Property (ErrorEventArgs)

Gets and sets the error number for the Thumbnail Item collection member which incurred an error during thumbnail generation.

[Visual Basic]
Public Property Number As Integer
[C#]
public int Number {get; set;}
[C++]
public: __property int get_Number();
public: __property void set_Number(
   int value
);
[C++/CLI]
public:
property int Number {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the error number.

Remarks

This number can provide additional information about the error.

Requirements

Platforms: See Distribution Requirements

See Also

ErrorEventArgs Class | ErrorEventArgs Members


Filter Class

Filter Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Filter Class

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : Filter Class

This class exposes methods and properties for specifying match and comparison image file criteria that may be imposed when thumbnail images are loaded from a file system directory using the ThumbnailItemCollection.AddItemsFromDirectory method.

For a list of all members of this type, see Filter members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ThumbnailXpress2.Filter

Syntax

[Visual Basic]
Public Class Filter
[C#]
public class Filter
[C++]
public __gc class Filter
[C++/CLI]
public ref class Filter

Remarks

Note: A Filter instance must be added to the FilterCollection and be enabled in order for its filtering criteria to be active.

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

Filter Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


Filter Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Filter Class Members

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : Filter Class

Filter overview

Public Properties

Public Property CaseSensitive | Gets and sets an indicator if the filter file name matching case sensitivity is enabled.
Public Property Comparison | Gets and sets the filter comparison outcome criteria.
Public Property Enabled | Gets and sets an indicator to enable the filter status.
Public Property FileDate | Gets and sets the filter file date comparison value.
Public Property FilenamePattern | Gets and sets the filter filename matching pattern.
Public Property FileSize | Gets and sets the filter file size comparison value.
Public Property FilterName | Gets and sets the name of the filter.
Public Property IncludeHidden | Gets and sets the filter hidden files inclusion flag.
Public Property IncludeParentDirectory | Gets and sets the filter parent directory inclusion flag.
Public Property IncludeSubDirectory | Gets and sets the filter sub-directory inclusion flag.
Public Property MatchAppliesToDirectory | Gets and sets the filters match applies to directory flag.
Public Property Type | Gets and sets access to the filter type.

See Also

Filter Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


CaseSensitive Property

Filter Class | Filter Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

CaseSensitive Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > Filter Class : CaseSensitive Property

Gets and sets an indicator if the filter file name matching case sensitivity is enabled.

[Visual Basic]
Public Property CaseSensitive As Boolean
[C#]
public bool CaseSensitive {get; set;}
[C++]
public: __property bool get_CaseSensitive();
public: __property void set_CaseSensitive(
   bool value
);
[C++/CLI]
public:
property bool CaseSensitive {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true for the pattern specified must match in a case sensitive manner. Otherwise, false is used.

Remarks

The default value is false.

This flag is only relevant for a filter type of: Filename.

Requirements

Platforms: See Distribution Requirements

See Also

Filter Class | Filter Members


Comparison Property

Filter Class | Filter Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Comparison Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > Filter Class : Comparison Property

Gets and sets the filter comparison outcome criteria.

[Visual Basic]
Public Property Comparison As FilterComparison
[C#]
public FilterComparison Comparison {get; set;}
[C++]
public: __property FilterComparison get_Comparison();
public: __property void set_Comparison(
   FilterComparison value
);
[C++/CLI]
public:
property FilterComparison Comparison {
   FilterComparison get();
   void set (FilterComparison value);
}

Return Type

A FilterComparison enumeration value which determines the filter comparison outcome criteria.

Remarks

The default value is Equal.

This property is only relevant for filter types of: FileCreationDate, FileModificationDate, or FileSize.

Requirements

Platforms: See Distribution Requirements

See Also

Filter Class | Filter Members


Enabled Property

Filter Class | Filter Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Enabled Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > Filter Class : Enabled Property

Gets and sets an indicator to enable the filter status.

[Visual Basic]
Public Property Enabled As Boolean
[C#]
public bool Enabled {get; set;}
[C++]
public: __property bool get_Enabled();
public: __property void set_Enabled(
   bool value
);
[C++/CLI]
public:
property bool Enabled {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to enable the filter status. Otherwise, false is used.

Remarks

The default value is true..

Requirements

Platforms: See Distribution Requirements

See Also

Filter Class | Filter Members


FileDate Property

Filter Class | Filter Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

FileDate Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > Filter Class : FileDate Property

Gets and sets the filter file date comparison value.

[Visual Basic]
Public Property FileDate As Date
[C#]
public DateTime FileDate {get; set;}
[C++]
public: __property DateTime get_FileDate();
public: __property void set_FileDate(
   DateTime value
);
[C++/CLI]
public:
property DateTime FileDate {
   DateTime get();
   void set (DateTime value);
}

Return Type

A DateTime object value.

Remarks

The default value is the current date.

This property is only relevant for filter types of: FileCreationDate or FileModificationDate. Only the year, month and day values present in the DateTime data type are used.

Requirements

Platforms: See Distribution Requirements

See Also

Filter Class | Filter Members


FilenamePattern Property

Filter Class | Filter Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

FilenamePattern Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > Filter Class : FilenamePattern Property

Gets and sets the filter filename matching pattern.

[Visual Basic]
Public Property FilenamePattern As String
[C#]
public string FilenamePattern {get; set;}
[C++]
public: __property string* get_FilenamePattern();
public: __property void set_FilenamePattern(
   string* value
);
[C++/CLI]
public:
property String^ FilenamePattern {
   String^ get();
   void set (String^ value);
}

Return Type

A string value which represents the filename matching pattern.

Remarks

The default value is an empty string "".

Wildcard characters ? and * may be used in the pattern.

This property is only relevant for a filter type of: Filename.

Requirements

Platforms: See Distribution Requirements

See Also

Filter Class | Filter Members


FileSize Property

Filter Class | Filter Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

FileSize Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > Filter Class : FileSize Property

Gets and sets the filter file size comparison value.

[Visual Basic]
Public Property FileSize As Integer
[C#]
public int FileSize {get; set;}
[C++]
public: __property int get_FileSize();
public: __property void set_FileSize(
   int value
);
[C++/CLI]
public:
property int FileSize {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the file size comparison value.

Remarks

The default value is 0.

This property is only relevant for a filter type of: FileSize.

Requirements

Platforms: See Distribution Requirements

See Also

Filter Class | Filter Members


FilterName Property

Filter Class | Filter Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

FilterName Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > Filter Class : FilterName Property

Gets and sets the name of the filter.

[Visual Basic]
Public Property FilterName As String
[C#]
public string FilterName {get; set;}
[C++]
public: __property string* get_FilterName();
public: __property void set_FilterName(
   string* value
);
[C++/CLI]
public:
property String^ FilterName {
   String^ get();
   void set (String^ value);
}

Return Type

A string value which represents the name of the filter.

Requirements

Platforms: See Distribution Requirements

See Also

Filter Class | Filter Members


IncludeHidden Property

Filter Class | Filter Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

IncludeHidden Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > Filter Class : IncludeHidden Property

Gets and sets the filter hidden files inclusion flag.

[Visual Basic]
Public Property IncludeHidden As Boolean
[C#]
public bool IncludeHidden {get; set;}
[C++]
public: __property bool get_IncludeHidden();
public: __property void set_IncludeHidden(
   bool value
);
[C++/CLI]
public:
property bool IncludeHidden {
   bool get();
   void set (bool value);
}

Remarks

The default value is false.

This flag is only relevant for a filter type of: FileAttributes.

Requirements

Platforms: See Distribution Requirements

See Also

Filter Class | Filter Members


IncludeParentDirectory Property

Filter Class | Filter Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

IncludeParentDirectory Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > Filter Class : IncludeParentDirectory Property

Gets and sets the filter parent directory inclusion flag.

[Visual Basic]
Public Property IncludeParentDirectory As Boolean
[C#]
public bool IncludeParentDirectory {get; set;}
[C++]
public: __property bool get_IncludeParentDirectory();
public: __property void set_IncludeParentDirectory(
   bool value
);
[C++/CLI]
public:
property bool IncludeParentDirectory {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to include the parent directory. Otherwise, false is used.

Remarks

The default value is false.

This flag is only relevant for a filter type of: FileAttributes.

Requirements

Platforms: See Distribution Requirements

See Also

Filter Class | Filter Members


IncludeSubDirectory Property

Filter Class | Filter Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

IncludeSubDirectory Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > Filter Class : IncludeSubDirectory Property

Gets and sets the filter sub-directory inclusion flag.

[Visual Basic]
Public Property IncludeSubDirectory As Boolean
[C#]
public bool IncludeSubDirectory {get; set;}
[C++]
public: __property bool get_IncludeSubDirectory();
public: __property void set_IncludeSubDirectory(
   bool value
);
[C++/CLI]
public:
property bool IncludeSubDirectory {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to include the sub-directory. Otherwise, false is used.

Remarks

The default value is true.

This flag is only relevant for a filter type of: FileAttributes.

Requirements

Platforms: See Distribution Requirements

See Also

Filter Class | Filter Members


MatchAppliesToDirectory Property

Filter Class | Filter Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

MatchAppliesToDirectory Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > Filter Class : MatchAppliesToDirectory Property

Gets and sets the filters match applies to directory flag.

[Visual Basic]
Public Property MatchAppliesToDirectory As Boolean
[C#]
public bool MatchAppliesToDirectory {get; set;}
[C++]
public: __property bool get_MatchAppliesToDirectory();
public: __property void set_MatchAppliesToDirectory(
   bool value
);
[C++/CLI]
public:
property bool MatchAppliesToDirectory {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to include a directory. Otherwise, false is used.

Remarks

The default value is false.

This flag is only relevant for a filter type of: Filename.

A value of true means that for a directory to be included in the collection, it's name must match the pattern criteria specified in the FilenamePattern property.

Requirements

Platforms: See Distribution Requirements

See Also

Filter Class | Filter Members


Type Property

Filter Class | Filter Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Type Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > Filter Class : Type Property (Filter)

Gets and sets access to the filter type.

[Visual Basic]
Public Property Type As FilterType
[C#]
public FilterType Type {get; set;}
[C++]
public: __property FilterType get_Type();
public: __property void set_Type(
   FilterType value
);
[C++/CLI]
public:
property FilterType Type {
   FilterType get();
   void set (FilterType value);
}

Return Type

A FilterType object which determines the filter type.

Remarks

The default value is Filename.

Requirements

Platforms: See Distribution Requirements

See Also

Filter Class | Filter Members


FilterCollection Class

FilterCollection Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

FilterCollection Class

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : FilterCollection Class

This class provides access and manipulation functionality for one or more filter objects. Filtering criteria for all enabled filter objects in the collection are applied to all image files that are specified by a ThumbnailItemCollection.AddItemsFromDirectory method call.

For a list of all members of this type, see FilterCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PegasusImaging.WinForms.ThumbnailXpress2.FilterCollection

Syntax

[Visual Basic]
<DefaultMemberAttribute("Item")>
Public Class FilterCollection
   Inherits CollectionBase
[C#]
[DefaultMemberAttribute("Item")]
public class FilterCollection : CollectionBase
[C++]
[DefaultMemberAttribute("Item")]
public __gc class FilterCollection : public CollectionBase
[C++/CLI]
[DefaultMemberAttribute("Item")]
public ref class FilterCollection : public CollectionBase

Remarks

Filtering criteria for multiple enabled filters are applied in a logical manner such that an image file must meet the criteria of all the filters.

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

FilterCollection Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


FilterCollection Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

FilterCollection Class Members

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : FilterCollection Class

FilterCollection overview

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count | Gets the number of filters in the collection.
Public Property IsFixedSize | Gets an indicator if the collection is a fixed size.
Public Property IsReadOnly | Gets an indicator if the collection access is read-only.
Public Property IsSynchronized | Gets an indicator whether synchronized (thread-safe) read-write access to the collection is available.
Public Property Item | Gets the filter object for the given collection index.
Public Property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

Public Method Add | Adds the provided filter item to the end of the collection.
Public Method Clear | This method clears all filters out of the collection.
Public Method Contains | Provides an indication as to whether the collection contains the given filter. The matching criteria is based on the filter name.
Public Method CopyTo | Copy the collection to an array of Filters.
Public Method GetEnumerator | Gets an enumerator for traversing the filters collection.
Public Method IndexOf | Returns the index of the given filter in the collection.
Public Method Insert | Inserts the provided filter item into the collection at the given index.
Public Method Remove | Removes the provided filter from the collection.
Public Method RemoveAt | Removes the filter at the given location in the collection.

See Also

FilterCollection Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


Add Method

FilterCollection Class | FilterCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

item
An integer which represents the filter to add.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Add Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > FilterCollection Class : Add Method (FilterCollection)

Adds the provided filter item to the end of the collection.

[Visual Basic]
Public Overridable Function Add( _
   ByVal item As Filter _
) As Integer
[C#]
public virtual int Add(
   Filter item
);
[C++]
public: virtual int Add(
   Filter* item
)
[C++/CLI]
public:
virtual int Add(
   Filter^ item
)

Parameters

item
An integer which represents the filter to add.

Return Type

An integer which represents the new count of total filters.

Remarks

If the filter is enabled, its criteria will be applied against subequent calls to ThumbnailItemCollection.AddItemsFromDirectory

Requirements

Platforms: See Distribution Requirements

See Also

FilterCollection Class | FilterCollection Members


Clear Method

FilterCollection Class | FilterCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Clear Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > FilterCollection Class : Clear Method (FilterCollection)

This method clears all filters out of the collection.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[C++/CLI]
public:
void Clear();

Requirements

Platforms: See Distribution Requirements

See Also

FilterCollection Class | FilterCollection Members


Contains Method

FilterCollection Class | FilterCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

item
The filter to look for in the collection.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Contains Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > FilterCollection Class : Contains Method (FilterCollection)

Provides an indication as to whether the collection contains the given filter. The matching criteria is based on the filter name.

[Visual Basic]
Public Overridable Function Contains( _
   ByVal item As Filter _
) As Boolean
[C#]
public virtual bool Contains(
   Filter item
);
[C++]
public: virtual bool Contains(
   Filter* item
)
[C++/CLI]
public:
virtual bool Contains(
   Filter^ item
)

Parameters

item
The filter to look for in the collection.

Return Type

True if the filter exists in the collection; false if not.

Requirements

Platforms: See Distribution Requirements

See Also

FilterCollection Class | FilterCollection Members


CopyTo Method

FilterCollection Class | FilterCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

array
The destination array.
index
The index in the array in which to start adding the Filters.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

CopyTo Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > FilterCollection Class : CopyTo Method (FilterCollection)

Copy the collection to an array of Filters.

[Visual Basic]
Public Overridable Sub CopyTo( _
   ByVal array() As Filter, _
   ByVal index As Integer _
)
[C#]
public virtual void CopyTo(
   Filter[] array,
   int index
);
[C++]
public: virtual void CopyTo(
   Filter*[]* array,
   int index
)
[C++/CLI]
public:
virtual void CopyTo(
   Filter^array<array>^ array,
   int index
)

Parameters

array
The destination array.
index
The index in the array in which to start adding the Filters.

Requirements

Platforms: See Distribution Requirements

See Also

FilterCollection Class | FilterCollection Members


GetEnumerator Method

FilterCollection Class | FilterCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

GetEnumerator Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > FilterCollection Class : GetEnumerator Method (FilterCollection)

Gets an enumerator for traversing the filters collection.

[Visual Basic]
Public Overridable Function GetEnumerator() As FilterCollectionEnumerator
[C#]
public virtual FilterCollectionEnumerator GetEnumerator();
[C++]
public: virtual FilterCollectionEnumerator* GetEnumerator();
[C++/CLI]
public:
virtual FilterCollectionEnumerator^ GetEnumerator();

Return Type

An enumerator for traversing the filters collection.

Requirements

Platforms: See Distribution Requirements

See Also

FilterCollection Class | FilterCollection Members


IndexOf Method

FilterCollection Class | FilterCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

item
An integer which represents the filter item to look for in the collection.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

IndexOf Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > FilterCollection Class : IndexOf Method (FilterCollection)

Returns the index of the given filter in the collection.

[Visual Basic]
Public Overridable Function IndexOf( _
   ByVal item As Filter _
) As Integer
[C#]
public virtual int IndexOf(
   Filter item
);
[C++]
public: virtual int IndexOf(
   Filter* item
)
[C++/CLI]
public:
virtual int IndexOf(
   Filter^ item
)

Parameters

item
An integer which represents the filter item to look for in the collection.

Return Type

The index of the filter item or -1 if not in the collection

Remarks

The matching criteria is based on the filter name.

Requirements

Platforms: See Distribution Requirements

See Also

FilterCollection Class | FilterCollection Members


Insert Method

FilterCollection Class | FilterCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

collectionIndex
The index position to add the given filter.
item
The Filter to insert into the collection.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Insert Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > FilterCollection Class : Insert Method (FilterCollection)

Inserts the provided filter item into the collection at the given index.

[Visual Basic]
Public Overridable Sub Insert( _
   ByVal collectionIndex As Integer, _
   ByVal item As Filter _
)
[C#]
public virtual void Insert(
   int collectionIndex,
   Filter item
);
[C++]
public: virtual void Insert(
   int collectionIndex,
   Filter* item
)
[C++/CLI]
public:
virtual void Insert(
   int collectionIndex,
   Filter^ item
)

Parameters

collectionIndex
The index position to add the given filter.
item
The Filter to insert into the collection.

Remarks

If the filter is enabled, its criteria will be applied against subequent calls to ThumbnailItemCollection.AddItemsFromDirectory

Requirements

Platforms: See Distribution Requirements

See Also

FilterCollection Class | FilterCollection Members


Remove Method

FilterCollection Class | FilterCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

item
The Filter to remove.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Remove Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > FilterCollection Class : Remove Method (FilterCollection)

Removes the provided filter from the collection.

[Visual Basic]
Public Overridable Sub Remove( _
   ByVal item As Filter _
)
[C#]
public virtual void Remove(
   Filter item
);
[C++]
public: virtual void Remove(
   Filter* item
)
[C++/CLI]
public:
virtual void Remove(
   Filter^ item
)

Parameters

item
The Filter to remove.

Remarks

The matching criteria is based on the filter name.

If the filter was enabled, it will no longer be applied against subequent calls to AddItemsFromDirectory

Requirements

Platforms: See Distribution Requirements

See Also

FilterCollection Class | FilterCollection Members


RemoveAt Method

FilterCollection Class | FilterCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

collectionIndex
An integer which represents the position of the filter to remove.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

RemoveAt Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > FilterCollection Class : RemoveAt Method (FilterCollection)

Removes the filter at the given location in the collection.

[Visual Basic]
Public Overridable Sub RemoveAt( _
   ByVal collectionIndex As Integer _
)
[C#]
public virtual void RemoveAt(
   int collectionIndex
);
[C++]
public: virtual void RemoveAt(
   int collectionIndex
)
[C++/CLI]
public:
virtual void RemoveAt(
   int collectionIndex
)

Parameters

collectionIndex
An integer which represents the position of the filter to remove.

Remarks

If the filter was enabled, its criteria will no longer be applied against subequent calls to ThumbnailItemCollection.AddItemsFromDirectory

Requirements

Platforms: See Distribution Requirements

See Also

FilterCollection Class | FilterCollection Members


Count Property

FilterCollection Class | FilterCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Count Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > FilterCollection Class : Count Property (FilterCollection)

Gets the number of filters in the collection.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[C++/CLI]
public:
property int Count {
   int get();
}

Requirements

Platforms: See Distribution Requirements

See Also

FilterCollection Class | FilterCollection Members


IsFixedSize Property

FilterCollection Class | FilterCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

IsFixedSize Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > FilterCollection Class : IsFixedSize Property (FilterCollection)

Gets an indicator if the collection is a fixed size.

[Visual Basic]
Public Overridable ReadOnly Property IsFixedSize As Boolean
[C#]
public virtual bool IsFixedSize {get;}
[C++]
public: __property virtual bool get_IsFixedSize();
[C++/CLI]
public:
virtual property bool IsFixedSize {
   bool get();
}

Return Type

A boolean value which is true if the collection is a fixed size. Otherwise, false is returned.

Requirements

Platforms: See Distribution Requirements

See Also

FilterCollection Class | FilterCollection Members


IsReadOnly Property

FilterCollection Class | FilterCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

IsReadOnly Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > FilterCollection Class : IsReadOnly Property (FilterCollection)

Gets an indicator if the collection access is read-only.

[Visual Basic]
Public Overridable ReadOnly Property IsReadOnly As Boolean
[C#]
public virtual bool IsReadOnly {get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[C++/CLI]
public:
virtual property bool IsReadOnly {
   bool get();
}

Return Type

A boolean value which is true if the collection access is read-only. Otherwise, false is returned.

Requirements

Platforms: See Distribution Requirements

See Also

FilterCollection Class | FilterCollection Members


IsSynchronized Property

FilterCollection Class | FilterCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

IsSynchronized Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > FilterCollection Class : IsSynchronized Property (FilterCollection)

Gets an indicator whether synchronized (thread-safe) read-write access to the collection is available.

[Visual Basic]
Public Overridable ReadOnly Property IsSynchronized As Boolean
[C#]
public virtual bool IsSynchronized {get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[C++/CLI]
public:
virtual property bool IsSynchronized {
   bool get();
}

Remarks

Note: This property always returns false.

Use the FilterCollectionEnumerator and it's FilterCollectionEnumerator.Lock method to access the FilterCollection in a read-only thread safe manner.

Requirements

Platforms: See Distribution Requirements

See Also

FilterCollection Class | FilterCollection Members


Item Property

FilterCollection Class | FilterCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

collectionIndex
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Item Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > FilterCollection Class : Item Property (FilterCollection)

Gets the filter object for the given collection index.

[Visual Basic]
Public Overridable ReadOnly Default Property Item( _
   ByVal collectionIndex As Integer _
) As Filter
[C#]
public virtual Filter this[
   int collectionIndex
]; {get;}
[C++]
public: __property virtual Filter* get_Item(
   int collectionIndex
);
[C++/CLI]
public:
virtual  property Filter^ default [int] {
   Filter^ get(int collectionIndex);
}

Parameters

collectionIndex

Return Type

A Filter object.

Requirements

Platforms: See Distribution Requirements

See Also

FilterCollection Class | FilterCollection Members


SyncRoot Property

FilterCollection Class | FilterCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

SyncRoot Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > FilterCollection Class : SyncRoot Property (FilterCollection)

Gets an object that can be used to synchronize access to the collection.

[Visual Basic]
Public Overridable ReadOnly Property SyncRoot As Object
[C#]
public virtual object SyncRoot {get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[C++/CLI]
public:
virtual property Object^ SyncRoot {
   Object^ get();
}

Requirements

Platforms: See Distribution Requirements

See Also

FilterCollection Class | FilterCollection Members


FilterCollectionEnumerator Class

FilterCollectionEnumerator Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

FilterCollectionEnumerator Class

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : FilterCollectionEnumerator Class

The FilterCollectionEnumerator class provides a lockable IEnumerator interface for the FilterCollection class. When locked, the FilterCollectionEnumerator provides thread-safe read-only access to the FilterCollection.

For a list of all members of this type, see FilterCollectionEnumerator members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ThumbnailXpress2.FilterCollectionEnumerator

Syntax

[Visual Basic]
Public Class FilterCollectionEnumerator
[C#]
public class FilterCollectionEnumerator
[C++]
public __gc class FilterCollectionEnumerator
[C++/CLI]
public ref class FilterCollectionEnumerator

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

FilterCollectionEnumerator Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


FilterCollectionEnumerator Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

FilterCollectionEnumerator Class Members

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : FilterCollectionEnumerator Class

FilterCollectionEnumerator overview

Public Properties

Public Property Current Gets the Filter at the current enumerator position/index.

Public Methods

Public Method Lock | Locks the collection.
Public Method MoveNext | Moves the collection enumerator position/index by one if not at the end of the collection.
Public Method Reset | Resets the collection enumerator position/index to before the start of the collection.
Public Method Unlock | Unlocks the collection.

See Also

FilterCollectionEnumerator Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


Lock Method

FilterCollectionEnumerator Class | FilterCollectionEnumerator Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Lock Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > FilterCollectionEnumerator Class : Lock Method (FilterCollectionEnumerator)

Locks the collection.

[Visual Basic]
Public Sub Lock()
[C#]
public void Lock();
[C++]
public: void Lock();
[C++/CLI]
public:
void Lock();

Remarks

The collection must be locked before calling Current, MoveNext, or Reset.

Requirements

Platforms: See Distribution Requirements

See Also

FilterCollectionEnumerator Class | FilterCollectionEnumerator Members


MoveNext Method

FilterCollectionEnumerator Class | FilterCollectionEnumerator Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

MoveNext Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > FilterCollectionEnumerator Class : MoveNext Method (FilterCollectionEnumerator)

Moves the collection enumerator position/index by one if not at the end of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();
[C++]
public: bool MoveNext();
[C++/CLI]
public:
bool MoveNext();

Return Type

A boolean value which is true if the position is moved. Otherwise, false is returned.

Remarks

The collection must be locked before accessing this method.

Requirements

Platforms: See Distribution Requirements

See Also

FilterCollectionEnumerator Class | FilterCollectionEnumerator Members


Reset Method

FilterCollectionEnumerator Class | FilterCollectionEnumerator Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Reset Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > FilterCollectionEnumerator Class : Reset Method (FilterCollectionEnumerator)

Resets the collection enumerator position/index to before the start of the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();
[C++]
public: void Reset();
[C++/CLI]
public:
void Reset();

Remarks

The collection must be locked before accessing this property.

Requirements

Platforms: See Distribution Requirements

See Also

FilterCollectionEnumerator Class | FilterCollectionEnumerator Members


Unlock Method

FilterCollectionEnumerator Class | FilterCollectionEnumerator Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Unlock Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > FilterCollectionEnumerator Class : Unlock Method (FilterCollectionEnumerator)

Unlocks the collection.

[Visual Basic]
Public Sub Unlock()
[C#]
public void Unlock();
[C++]
public: void Unlock();
[C++/CLI]
public:
void Unlock();

Requirements

Platforms: See Distribution Requirements

See Also

FilterCollectionEnumerator Class | FilterCollectionEnumerator Members


Current Property

FilterCollectionEnumerator Class | FilterCollectionEnumerator Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Current Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > FilterCollectionEnumerator Class : Current Property (FilterCollectionEnumerator)

Gets the Filter at the current enumerator position/index.

[Visual Basic]
Public ReadOnly Property Current As Filter
[C#]
public Filter Current {get;}
[C++]
public: __property Filter* get_Current();
[C++/CLI]
public:
property Filter^ Current {
   Filter^ get();
}

Remarks

Note: The collection must be locked before accessing this property.

Returns the Filter at the current enumerator position/index.

Requirements

Platforms: See Distribution Requirements

See Also

FilterCollectionEnumerator Class | FilterCollectionEnumerator Members


ItemCompleteEventArgs Class

ItemCompleteEventArgs Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ItemCompleteEventArgs Class

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ItemCompleteEventArgs Class

ItemCompleteEventArgs is the argument information for the ThumbnailXpress.ItemComplete event.

For a list of all members of this type, see ItemCompleteEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.ThumbnailXpress2.ItemCompleteEventArgs

Syntax

[Visual Basic]
Public Class ItemCompleteEventArgs
   Inherits EventArgs
[C#]
public class ItemCompleteEventArgs : EventArgs
[C++]
public __gc class ItemCompleteEventArgs : public EventArgs
[C++/CLI]
public ref class ItemCompleteEventArgs : public EventArgs

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

ItemCompleteEventArgs Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ItemCompleteEventArgs Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ItemCompleteEventArgs Class Members

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ItemCompleteEventArgs Class

ItemCompleteEventArgs overview

Public Properties

Public Property ItemIndex Gets and sets the index of the ThumbnailItemCollection member for which the thumbnail image generation has just completed.

See Also

ItemCompleteEventArgs Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ItemIndex Property

ItemCompleteEventArgs Class | ItemCompleteEventArgs Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ItemIndex Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ItemCompleteEventArgs Class : ItemIndex Property (ItemCompleteEventArgs)

Gets and sets the index of the ThumbnailItemCollection member for which the thumbnail image generation has just completed.

[Visual Basic]
Public Property ItemIndex As Integer
[C#]
public int ItemIndex {get; set;}
[C++]
public: __property int get_ItemIndex();
public: __property void set_ItemIndex(
   int value
);
[C++/CLI]
public:
property int ItemIndex {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the index of the thumbnail.

Remarks

This index only be valid if there are no additions or deletions to the thumbnail item collection prior to use of this index value.

Requirements

Platforms: See Distribution Requirements

See Also

ItemCompleteEventArgs Class | ItemCompleteEventArgs Members


Licensing Class

Licensing Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Licensing Class

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : Licensing Class (PegasusImaging.WinForms.ThumbnailXpress2)

The Licensing class provides ThumbnailXpress licensing methods and properties access.

For a list of all members of this type, see Licensing members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ThumbnailXpress2.Licensing

Syntax

[Visual Basic]
Public Class Licensing
[C#]
public class Licensing
[C++]
public __gc class Licensing
[C++/CLI]
public ref class Licensing

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

Licensing Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


Licensing Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Licensing Class Members

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : Licensing Class (PegasusImaging.WinForms.ThumbnailXpress2)

Licensing overview

Public Properties

Public Property EvaluationMode | Gets and sets the licensing trial/evaluation mode behavior.
Public Property IXLicenseEdition | Gets and sets the License Edition for the ImagXpress control used by ThumbnailXpress.

Public Methods

Public Method AccessPdfXpress | Overloaded. Method to find and load PDFXpress v1.x. This method should be used on a development machine that a PDFXpress v1.x development kit has been installed on.
Public Method AccessPdfXpress2 | Finds and loads PDF Xpress v2.x.
Public Method UnlockIXAddOn | This function has been deprecated.
Public Method UnlockIXRuntime | Unlocks the ImageXpress control for an instance of the ThumbnailXpress control in runtime environments.
Public Method UnlockPdfXpressRuntime | Unlocks the license for PDF Xpress v1.x or v2.x at runtime for use in distributed environments.
Public Method UnlockRuntime | Unlocks an instance of the ThumbnailXpress control for use in runtime environments.
Public Method UnlockWeb | Unlocks an instance of the ThumbnailXpress control for use on a web page for a specific URL.

See Also

Licensing Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


AccessPdfXpress Method

Licensing Class | Licensing Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

AccessPdfXpress Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > Licensing Class : AccessPdfXpress Method

Method to find and load PDFXpress v1.x. This method should be used on a development machine that a PDFXpress v1.x development kit has been installed on.

Overload List

Method to find and load PDFXpress v1.x. This method should be used on a development machine that a PDFXpress v1.x development kit has been installed on.

[Visual Basic] Overloads Public Sub AccessPdfXpress()

[C#] public void AccessPdfXpress();

[C++] public void AccessPdfXpress()

[C++/CLI] public void AccessPdfXpress()

Finds and loads PDF Xpress v1.x.

[Visual Basic] Overloads Public Sub AccessPdfXpress(Integer,Integer,Integer,Integer)

[C#] public void AccessPdfXpress(int,int,int,int);

[C++] public void AccessPdfXpress(int,int,int,int);

[C++/CLI] public void AccessPdfXpress(int,int,int,int);

Requirements

Platforms: See Distribution Requirements

See Also

Licensing Class | Licensing Members


AccessPdfXpress() Method

Licensing Class | Licensing Members | Overload List

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

AccessPdfXpress() Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > Licensing Class > AccessPdfXpress Method : AccessPdfXpress() Method

Method to find and load PDFXpress v1.x. This method should be used on a development machine that a PDFXpress v1.x development kit has been installed on.

[Visual Basic]
Overloads Public Sub AccessPdfXpress()
[C#]
public void AccessPdfXpress();
[C++]
public: void AccessPdfXpress();
[C++/CLI]
public:
void AccessPdfXpress();

Requirements

Platforms: See Distribution Requirements

See Also

Licensing Class | Licensing Members | Overload List


AccessPdfXpress(Int32,Int32,Int32,Int32) Method

Licensing Class | Licensing Members | Overload List

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

code1
Unlock code 1.
code2
Unlock code 2.
code3
Unlock code 3.
code4
Unlock code 4.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

AccessPdfXpress(Int32,Int32,Int32,Int32) Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > Licensing Class > AccessPdfXpress Method : AccessPdfXpress(Int32,Int32,Int32,Int32) Method

Finds and loads PDF Xpress v1.x.

[Visual Basic]
Overloads Public Sub AccessPdfXpress( _
   ByVal code1 As Integer, _
   ByVal code2 As Integer, _
   ByVal code3 As Integer, _
   ByVal code4 As Integer _
)
[C#]
public void AccessPdfXpress(
   int code1,
   int code2,
   int code3,
   int code4
);
[C++]
public: void AccessPdfXpress(
   int code1,
   int code2,
   int code3,
   int code4
)
[C++/CLI]
public:
void AccessPdfXpress(
   int code1,
   int code2,
   int code3,
   int code4
)

Parameters

code1
Unlock code 1.
code2
Unlock code 2.
code3
Unlock code 3.
code4
Unlock code 4.

Remarks

This method can be used on a development machine but must be used in distributed environments. The unlock code parameters are provided by Pegasus Imaging upon purchase of a PDF Xpress license.

Requirements

Platforms: See Distribution Requirements

See Also

Licensing Class | Licensing Members | Overload List


AccessPdfXpress2 Method

Licensing Class | Licensing Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

AccessPdfXpress2 Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > Licensing Class : AccessPdfXpress2 Method

Finds and loads PDF Xpress v2.x.

[Visual Basic]
Public Sub AccessPdfXpress2()
[C#]
public void AccessPdfXpress2();
[C++]
public: void AccessPdfXpress2();
[C++/CLI]
public:
void AccessPdfXpress2();

Remarks

Unlike PDFXpress v1.x, no unlock codes are required at load time in distributed environments.

Requirements

Platforms: See Distribution Requirements

See Also

Licensing Class | Licensing Members


UnlockIXAddOn Method

Licensing Class | Licensing Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

addOnLicense
Add-on license string.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

UnlockIXAddOn Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > Licensing Class : UnlockIXAddOn Method

This function has been deprecated.

[Visual Basic]
<ObsoleteAttribute("This function will be removed in ThumbnailXpress v3")>
Public Function UnlockIXAddOn( _
   ByVal addOnLicense As String _
) As Boolean
[C#]
[ObsoleteAttribute("This function will be removed in ThumbnailXpress v3")]
public bool UnlockIXAddOn(
   string addOnLicense
);
[C++]
[ObsoleteAttribute("This function will be removed in ThumbnailXpress v3")]
public: bool UnlockIXAddOn(
   string* addOnLicense
)
[C++/CLI]
[ObsoleteAttribute("This function will be removed in ThumbnailXpress v3")]
public:
bool UnlockIXAddOn(
   String^ addOnLicense
)

Parameters

addOnLicense
Add-on license string.

Return Type

This will always return true, as it is obsolete.

Remarks

The functionality is now built into the control for free. There is no reason to call UnlockIXAddOn.

Requirements

Platforms: See Distribution Requirements

See Also

Licensing Class | Licensing Members


UnlockIXRuntime Method

Licensing Class | Licensing Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

code1
An integer value which represents the unlock code 1.
code2
An integer value which represents the unlock code 2.
code3
An integer value which represents the unlock code 3.
code4
An integer value which represents the unlock code 4.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

UnlockIXRuntime Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > Licensing Class : UnlockIXRuntime Method

Unlocks the ImageXpress control for an instance of the ThumbnailXpress control in runtime environments.

[Visual Basic]
Public Function UnlockIXRuntime( _
   ByVal code1 As Integer, _
   ByVal code2 As Integer, _
   ByVal code3 As Integer, _
   ByVal code4 As Integer _
) As Boolean
[C#]
public bool UnlockIXRuntime(
   int code1,
   int code2,
   int code3,
   int code4
);
[C++]
public: bool UnlockIXRuntime(
   int code1,
   int code2,
   int code3,
   int code4
)
[C++/CLI]
public:
bool UnlockIXRuntime(
   int code1,
   int code2,
   int code3,
   int code4
)

Parameters

code1
An integer value which represents the unlock code 1.
code2
An integer value which represents the unlock code 2.
code3
An integer value which represents the unlock code 3.
code4
An integer value which represents the unlock code 4.

Return Type

A boolean value which is true if ImagXpress runtime license was unlocked. Otherwise, false is returned.

Requirements

Platforms: See Distribution Requirements

See Also

Licensing Class | Licensing Members


UnlockPdfXpressRuntime Method

Licensing Class | Licensing Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

code1
Unlock code 1.
code2
Unlock code 2.
code3
Unlock code 3.
code4
Unlock code 4.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

UnlockPdfXpressRuntime Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > Licensing Class : UnlockPdfXpressRuntime Method

Unlocks the license for PDF Xpress v1.x or v2.x at runtime for use in distributed environments.

[Visual Basic]
Public Function UnlockPdfXpressRuntime( _
   ByVal code1 As Integer, _
   ByVal code2 As Integer, _
   ByVal code3 As Integer, _
   ByVal code4 As Integer _
) As Boolean
[C#]
public bool UnlockPdfXpressRuntime(
   int code1,
   int code2,
   int code3,
   int code4
);
[C++]
public: bool UnlockPdfXpressRuntime(
   int code1,
   int code2,
   int code3,
   int code4
)
[C++/CLI]
public:
bool UnlockPdfXpressRuntime(
   int code1,
   int code2,
   int code3,
   int code4
)

Parameters

code1
Unlock code 1.
code2
Unlock code 2.
code3
Unlock code 3.
code4
Unlock code 4.

Return Type

A boolean value which is true if PDFXpress runtime license was unlocked. Otherwise, false is returned.

Remarks

The unlock code parameters are provided by Pegasus Imaging upon purchase of a PDF Xpress license.

Note: AccessPdfXpress or AccessPdfXpress2 must be successfully called before calling UnlockPdfXpressRuntime.

Requirements

Platforms: See Distribution Requirements

See Also

Licensing Class | Licensing Members


UnlockRuntime Method

Licensing Class | Licensing Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

code1
An integer which represents the unlock code 1.
code2
An integer which represents the unlock code 2.
code3
An integer which represents the unlock code 3.
code4
An integer which represents the unlock code 4.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

UnlockRuntime Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > Licensing Class : UnlockRuntime Method

Unlocks an instance of the ThumbnailXpress control for use in runtime environments.

[Visual Basic]
Public Function UnlockRuntime( _
   ByVal code1 As Integer, _
   ByVal code2 As Integer, _
   ByVal code3 As Integer, _
   ByVal code4 As Integer _
) As Boolean
[C#]
public bool UnlockRuntime(
   int code1,
   int code2,
   int code3,
   int code4
);
[C++]
public: bool UnlockRuntime(
   int code1,
   int code2,
   int code3,
   int code4
)
[C++/CLI]
public:
bool UnlockRuntime(
   int code1,
   int code2,
   int code3,
   int code4
)

Parameters

code1
An integer which represents the unlock code 1.
code2
An integer which represents the unlock code 2.
code3
An integer which represents the unlock code 3.
code4
An integer which represents the unlock code 4.

Return Type

A boolean value which is true if the ThumbnailXpress runtime license was unlocked. Otherwise, false is returned.

Requirements

Platforms: See Distribution Requirements

See Also

Licensing Class | Licensing Members


UnlockWeb Method

Licensing Class | Licensing Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

webUnlockKey
A string value which represents the Uniform Resource Locator Unlock text.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

UnlockWeb Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > Licensing Class : UnlockWeb Method

Unlocks an instance of the ThumbnailXpress control for use on a web page for a specific URL.

[Visual Basic]
Public Function UnlockWeb( _
   ByVal webUnlockKey As String _
) As Boolean
[C#]
public bool UnlockWeb(
   string webUnlockKey
);
[C++]
public: bool UnlockWeb(
   string* webUnlockKey
)
[C++/CLI]
public:
bool UnlockWeb(
   String^ webUnlockKey
)

Parameters

webUnlockKey
A string value which represents the Uniform Resource Locator Unlock text.

Return Type

A boolean value which is true if ThumbnailXpress was successfully licensed for the web page URL. Otherwise, false is returned.

Requirements

Platforms: See Distribution Requirements

See Also

Licensing Class | Licensing Members


EvaluationMode Property

Licensing Class | Licensing Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

EvaluationMode Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > Licensing Class : EvaluationMode Property (Licensing)

Gets and sets the licensing trial/evaluation mode behavior.

[Visual Basic]
Public Property EvaluationMode As EvaluationMode
[C#]
public EvaluationMode EvaluationMode {get; set;}
[C++]
public: __property EvaluationMode get_EvaluationMode();
public: __property void set_EvaluationMode(
   EvaluationMode value
);
[C++/CLI]
public:
property EvaluationMode EvaluationMode {
   EvaluationMode get();
   void set (EvaluationMode value);
}

Return Type

An EvaluationMode enumeration value.

Requirements

Platforms: See Distribution Requirements

See Also

Licensing Class | Licensing Members


IXLicenseEdition Property

Licensing Class | Licensing Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

IXLicenseEdition Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > Licensing Class : IXLicenseEdition Property (Licensing)

Gets and sets the License Edition for the ImagXpress control used by ThumbnailXpress.

[Visual Basic]
Public Property IXLicenseEdition As IXLicenseEdition
[C#]
public IXLicenseEdition IXLicenseEdition {get; set;}
[C++]
public: __property IXLicenseEdition get_IXLicenseEdition();
public: __property void set_IXLicenseEdition(
   IXLicenseEdition value
);
[C++/CLI]
public:
property IXLicenseEdition IXLicenseEdition {
   IXLicenseEdition get();
   void set (IXLicenseEdition value);
}

Return Type

An IXLicenseEdition enumeration value.

Requirements

Platforms: See Distribution Requirements

See Also

Licensing Class | Licensing Members


LoadFromStreamEventArgs Class

LoadFromStreamEventArgs Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace | Item Property

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

LoadFromStreamEventArgs Class

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : LoadFromStreamEventArgs Class

LoadFromStreamEventArgs is the argument information for the ThumbnailXpress.LoadFromStream event.

For a list of all members of this type, see LoadFromStreamEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.ThumbnailXpress2.LoadFromStreamEventArgs

Syntax

[Visual Basic]
Public Class LoadFromStreamEventArgs
   Inherits EventArgs
[C#]
public class LoadFromStreamEventArgs : EventArgs
[C++]
public __gc class LoadFromStreamEventArgs : public EventArgs
[C++/CLI]
public ref class LoadFromStreamEventArgs : public EventArgs

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

LoadFromStreamEventArgs Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace | Item Property


LoadFromStreamEventArgs Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace | Item Property

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

LoadFromStreamEventArgs Class Members

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : LoadFromStreamEventArgs Class

LoadFromStreamEventArgs overview

Public Properties

Public Property Item Gets the ThumbnailItem object whose image data is to be loaded using a Stream.

See Also

LoadFromStreamEventArgs Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace | Item Property


Item Property

LoadFromStreamEventArgs Class | LoadFromStreamEventArgs Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Item Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > LoadFromStreamEventArgs Class : Item Property (LoadFromStreamEventArgs)

Gets the ThumbnailItem object whose image data is to be loaded using a Stream.

[Visual Basic]
Public ReadOnly Property Item As ThumbnailItem
[C#]
public ThumbnailItem Item {get;}
[C++]
public: __property ThumbnailItem* get_Item();
[C++/CLI]
public:
property ThumbnailItem^ Item {
   ThumbnailItem^ get();
}

Return Type

A ThumbnailItem.

Remarks

When handling the event, use the ThumbnailItem.UserTag property to identify the appropriate stream and then use the ThumbnailItem.FromStream method to associate the stream to the item.

Requirements

Platforms: See Distribution Requirements

See Also

LoadFromStreamEventArgs Class | LoadFromStreamEventArgs Members


SelectedThumbnailItemCollection Class

SelectedThumbnailItemCollection Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

SelectedThumbnailItemCollection Class

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : SelectedThumbnailItemCollection Class

SelectedThumbnailItemCollection class provides selected Thumbnail Item manipulation functionality. The collection provides access to the selected thumbnail items in the list display. Adding or Removing selected items will cause the list display to update if appropriate

For a list of all members of this type, see SelectedThumbnailItemCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PegasusImaging.WinForms.ThumbnailXpress2.SelectedThumbnailItemCollection

Syntax

[Visual Basic]
<DefaultMemberAttribute("Item")>
Public Class SelectedThumbnailItemCollection
   Inherits CollectionBase
[C#]
[DefaultMemberAttribute("Item")]
public class SelectedThumbnailItemCollection : CollectionBase
[C++]
[DefaultMemberAttribute("Item")]
public __gc class SelectedThumbnailItemCollection : public CollectionBase
[C++/CLI]
[DefaultMemberAttribute("Item")]
public ref class SelectedThumbnailItemCollection : public CollectionBase

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

SelectedThumbnailItemCollection Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


SelectedThumbnailItemCollection Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

SelectedThumbnailItemCollection Class Members

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : SelectedThumbnailItemCollection Class

SelectedThumbnailItemCollection overview

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count | Read-only property returning the number of items in the selected item collection.
Public Property IsFixedSize | Read-only property returning whether the collection is a fixed size.
Public Property IsReadOnly | Read-only property returning whether the collection access is read-only.
Public Property IsSynchronized | Read only property returning whether synchronized (thread-safe) read-write access to the Collection is available. Will always return false. Use the SelectedThumbnailItemCollectionEnumerator and its Lock method to access the SelectedThumbnailItemCollection in a read-only thread safe manner.
Public Property Item | Read-only property returning the thumbnail item object from the given selected item collection index.
Public Property SyncRoot | Read-only property returning an object that can be used to synchronize access to the collection.

Public Methods

Public Method Add | This method adds a new thumbnail item to the selected item collection. The display is updated if appropriate
Public Method Clear | This method clears all thumbnails out of the selected item collection. The display is updated if appropriate
Public Method Contains | This method provides an indication as to whether the selected item collection contains the given thumbnail. The matching criteria is based on the filename / pagenumber information.
Public Method CopyTo | Method to copy the selected item collection to an array of ThumbnailItems.
Public Method GetEnumerator | This method returns an enumerator for traversing the selected item collection.
Public Method IndexOf | This method returns the index of the given thumbnail in the selected item collection. The matching criteria is based on the filename / pagenumber information.
Public Method Insert | This method inserts the provided thumbnail item into the selected item collection at the given index. The display is updated if appropriate
Public Method Remove | This method removes the provided thumbnail from the selected item collection. The matching criteria is based on the filename / pagenumber information. The display is updated if appropriate
Public Method RemoveAt | This method removes the thumbnail at the given location in the selected item collection. The display is updated if appropriate

See Also

SelectedThumbnailItemCollection Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


Add Method

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

item
The thumbnail item to add.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Add Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > SelectedThumbnailItemCollection Class : Add Method (SelectedThumbnailItemCollection)

This method adds a new thumbnail item to the selected item collection. The display is updated if appropriate

[Visual Basic]
Public Overridable Function Add( _
   ByVal item As ThumbnailItem _
) As Integer
[C#]
public virtual int Add(
   ThumbnailItem item
);
[C++]
public: virtual int Add(
   ThumbnailItem* item
)
[C++/CLI]
public:
virtual int Add(
   ThumbnailItem^ item
)

Parameters

item
The thumbnail item to add.

Return Type

Returns the new count of total selected thumbnail items.

Requirements

Platforms: See Distribution Requirements

See Also

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members


Clear Method

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Clear Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > SelectedThumbnailItemCollection Class : Clear Method (SelectedThumbnailItemCollection)

This method clears all thumbnails out of the selected item collection. The display is updated if appropriate

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[C++/CLI]
public:
void Clear();

Requirements

Platforms: See Distribution Requirements

See Also

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members


Contains Method

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

item
The thumbnail to look for in the collection.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Contains Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > SelectedThumbnailItemCollection Class : Contains Method (SelectedThumbnailItemCollection)

This method provides an indication as to whether the selected item collection contains the given thumbnail. The matching criteria is based on the filename / pagenumber information.

[Visual Basic]
Public Overridable Function Contains( _
   ByVal item As ThumbnailItem _
) As Boolean
[C#]
public virtual bool Contains(
   ThumbnailItem item
);
[C++]
public: virtual bool Contains(
   ThumbnailItem* item
)
[C++/CLI]
public:
virtual bool Contains(
   ThumbnailItem^ item
)

Parameters

item
The thumbnail to look for in the collection.

Return Type

True if the thumbnail exists in the selected item collection; false if not.

Requirements

Platforms: See Distribution Requirements

See Also

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members


CopyTo Method

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

array
The destination ThumbnailItem array.
index
The index in the array in which to start adding the ThumbnailItems.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

CopyTo Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > SelectedThumbnailItemCollection Class : CopyTo Method (SelectedThumbnailItemCollection)

Method to copy the selected item collection to an array of ThumbnailItems.

[Visual Basic]
Public Overridable Sub CopyTo( _
   ByVal array() As ThumbnailItem, _
   ByVal index As Integer _
)
[C#]
public virtual void CopyTo(
   ThumbnailItem[] array,
   int index
);
[C++]
public: virtual void CopyTo(
   ThumbnailItem*[]* array,
   int index
)
[C++/CLI]
public:
virtual void CopyTo(
   ThumbnailItem^array<array>^ array,
   int index
)

Parameters

array
The destination ThumbnailItem array.
index
The index in the array in which to start adding the ThumbnailItems.

Requirements

Platforms: See Distribution Requirements

See Also

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members


GetEnumerator Method

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

GetEnumerator Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > SelectedThumbnailItemCollection Class : GetEnumerator Method (SelectedThumbnailItemCollection)

This method returns an enumerator for traversing the selected item collection.

[Visual Basic]
Public Overridable Function GetEnumerator() As SelectedThumbnailItemCollectionEnumerator
[C#]
public virtual SelectedThumbnailItemCollectionEnumerator GetEnumerator();
[C++]
public: virtual SelectedThumbnailItemCollectionEnumerator* GetEnumerator();
[C++/CLI]
public:
virtual SelectedThumbnailItemCollectionEnumerator^ GetEnumerator();

Requirements

Platforms: See Distribution Requirements

See Also

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members


IndexOf Method

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

item
The thumbnail item to look for in the selected item collection.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

IndexOf Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > SelectedThumbnailItemCollection Class : IndexOf Method (SelectedThumbnailItemCollection)

This method returns the index of the given thumbnail in the selected item collection. The matching criteria is based on the filename / pagenumber information.

[Visual Basic]
Public Overridable Function IndexOf( _
   ByVal item As ThumbnailItem _
) As Integer
[C#]
public virtual int IndexOf(
   ThumbnailItem item
);
[C++]
public: virtual int IndexOf(
   ThumbnailItem* item
)
[C++/CLI]
public:
virtual int IndexOf(
   ThumbnailItem^ item
)

Parameters

item
The thumbnail item to look for in the selected item collection.

Return Type

The index of the thumbnail item or -1 if not in the selected item collection

Requirements

Platforms: See Distribution Requirements

See Also

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members


Insert Method

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

collectionIndex
The index position in the selected item collection to add the given thumbnail.
item
The thumbnail to add to the collection.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Insert Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > SelectedThumbnailItemCollection Class : Insert Method (SelectedThumbnailItemCollection)

This method inserts the provided thumbnail item into the selected item collection at the given index. The display is updated if appropriate

[Visual Basic]
Public Overridable Sub Insert( _
   ByVal collectionIndex As Integer, _
   ByVal item As ThumbnailItem _
)
[C#]
public virtual void Insert(
   int collectionIndex,
   ThumbnailItem item
);
[C++]
public: virtual void Insert(
   int collectionIndex,
   ThumbnailItem* item
)
[C++/CLI]
public:
virtual void Insert(
   int collectionIndex,
   ThumbnailItem^ item
)

Parameters

collectionIndex
The index position in the selected item collection to add the given thumbnail.
item
The thumbnail to add to the collection.

Requirements

Platforms: See Distribution Requirements

See Also

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members


Remove Method

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

item
The thumbnail item to remove.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Remove Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > SelectedThumbnailItemCollection Class : Remove Method (SelectedThumbnailItemCollection)

This method removes the provided thumbnail from the selected item collection. The matching criteria is based on the filename / pagenumber information. The display is updated if appropriate

[Visual Basic]
Public Overridable Sub Remove( _
   ByVal item As ThumbnailItem _
)
[C#]
public virtual void Remove(
   ThumbnailItem item
);
[C++]
public: virtual void Remove(
   ThumbnailItem* item
)
[C++/CLI]
public:
virtual void Remove(
   ThumbnailItem^ item
)

Parameters

item
The thumbnail item to remove.

Requirements

Platforms: See Distribution Requirements

See Also

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members


RemoveAt Method

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

collectionIndex
Position in the selected item collection of the thumbnail to remove.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

RemoveAt Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > SelectedThumbnailItemCollection Class : RemoveAt Method (SelectedThumbnailItemCollection)

This method removes the thumbnail at the given location in the selected item collection. The display is updated if appropriate

[Visual Basic]
Public Overridable Sub RemoveAt( _
   ByVal collectionIndex As Integer _
)
[C#]
public virtual void RemoveAt(
   int collectionIndex
);
[C++]
public: virtual void RemoveAt(
   int collectionIndex
)
[C++/CLI]
public:
virtual void RemoveAt(
   int collectionIndex
)

Parameters

collectionIndex
Position in the selected item collection of the thumbnail to remove.

Requirements

Platforms: See Distribution Requirements

See Also

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members


Count Property

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Count Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > SelectedThumbnailItemCollection Class : Count Property (SelectedThumbnailItemCollection)

Read-only property returning the number of items in the selected item collection.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[C++/CLI]
public:
property int Count {
   int get();
}

Requirements

Platforms: See Distribution Requirements

See Also

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members


IsFixedSize Property

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

IsFixedSize Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > SelectedThumbnailItemCollection Class : IsFixedSize Property (SelectedThumbnailItemCollection)

Read-only property returning whether the collection is a fixed size.

[Visual Basic]
Public Overridable ReadOnly Property IsFixedSize As Boolean
[C#]
public virtual bool IsFixedSize {get;}
[C++]
public: __property virtual bool get_IsFixedSize();
[C++/CLI]
public:
virtual property bool IsFixedSize {
   bool get();
}

Requirements

Platforms: See Distribution Requirements

See Also

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members


IsReadOnly Property

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

IsReadOnly Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > SelectedThumbnailItemCollection Class : IsReadOnly Property (SelectedThumbnailItemCollection)

Read-only property returning whether the collection access is read-only.

[Visual Basic]
Public Overridable ReadOnly Property IsReadOnly As Boolean
[C#]
public virtual bool IsReadOnly {get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[C++/CLI]
public:
virtual property bool IsReadOnly {
   bool get();
}

Requirements

Platforms: See Distribution Requirements

See Also

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members


IsSynchronized Property

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

IsSynchronized Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > SelectedThumbnailItemCollection Class : IsSynchronized Property (SelectedThumbnailItemCollection)

Read only property returning whether synchronized (thread-safe) read-write access to the Collection is available. Will always return false. Use the SelectedThumbnailItemCollectionEnumerator and its Lock method to access the SelectedThumbnailItemCollection in a read-only thread safe manner.

[Visual Basic]
Public Overridable ReadOnly Property IsSynchronized As Boolean
[C#]
public virtual bool IsSynchronized {get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[C++/CLI]
public:
virtual property bool IsSynchronized {
   bool get();
}

Return Type

Will always return false

Requirements

Platforms: See Distribution Requirements

See Also

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members


Item Property

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

collectionIndex
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Item Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > SelectedThumbnailItemCollection Class : Item Property (SelectedThumbnailItemCollection)

Read-only property returning the thumbnail item object from the given selected item collection index.

[Visual Basic]
Public Overridable ReadOnly Default Property Item( _
   ByVal collectionIndex As Integer _
) As ThumbnailItem
[C#]
public virtual ThumbnailItem this[
   int collectionIndex
]; {get;}
[C++]
public: __property virtual ThumbnailItem* get_Item(
   int collectionIndex
);
[C++/CLI]
public:
virtual  property ThumbnailItem^ default [int] {
   ThumbnailItem^ get(int collectionIndex);
}

Parameters

collectionIndex

Requirements

Platforms: See Distribution Requirements

See Also

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members


SyncRoot Property

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

SyncRoot Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > SelectedThumbnailItemCollection Class : SyncRoot Property (SelectedThumbnailItemCollection)

Read-only property returning an object that can be used to synchronize access to the collection.

[Visual Basic]
Public Overridable ReadOnly Property SyncRoot As Object
[C#]
public virtual object SyncRoot {get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[C++/CLI]
public:
virtual property Object^ SyncRoot {
   Object^ get();
}

Requirements

Platforms: See Distribution Requirements

See Also

SelectedThumbnailItemCollection Class | SelectedThumbnailItemCollection Members


SelectedThumbnailItemCollectionEnumerator Class

SelectedThumbnailItemCollectionEnumerator Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

SelectedThumbnailItemCollectionEnumerator Class

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : SelectedThumbnailItemCollectionEnumerator Class

SelectedThumbnailItemCollectionEnumerator class provides a lockable IEnumerator interface for the SelectedThumbnailItemCollection class.

For a list of all members of this type, see SelectedThumbnailItemCollectionEnumerator members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ThumbnailXpress2.SelectedThumbnailItemCollectionEnumerator

Syntax

[Visual Basic]
Public Class SelectedThumbnailItemCollectionEnumerator
[C#]
public class SelectedThumbnailItemCollectionEnumerator
[C++]
public __gc class SelectedThumbnailItemCollectionEnumerator
[C++/CLI]
public ref class SelectedThumbnailItemCollectionEnumerator

Remarks

The default value is false.

When locked, the SelectedThumbnailItemCollectionEnumerator provides thread-safe read-only access to the SelectedThumbnailItemCollection.

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

SelectedThumbnailItemCollectionEnumerator Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


SelectedThumbnailItemCollectionEnumerator Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

SelectedThumbnailItemCollectionEnumerator Class Members

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : SelectedThumbnailItemCollectionEnumerator Class

SelectedThumbnailItemCollectionEnumerator overview

Public Properties

Public Property Current Gets the selected ThumbnailItem at the current position within the index.

Public Methods

Public Method Lock | Locks the selected item collection.
Public Method MoveNext | Advances the selected item collection enumerator position within the index by one if not at the end of the collection.
Public Method Reset | Resets the selected item collection position within the index to before the start of the collection.
Public Method Unlock | This method unlocks the selected item collection.

See Also

SelectedThumbnailItemCollectionEnumerator Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


Lock Method

SelectedThumbnailItemCollectionEnumerator Class | SelectedThumbnailItemCollectionEnumerator Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Lock Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > SelectedThumbnailItemCollectionEnumerator Class : Lock Method (SelectedThumbnailItemCollectionEnumerator)

Locks the selected item collection.

[Visual Basic]
Public Sub Lock()
[C#]
public void Lock();
[C++]
public: void Lock();
[C++/CLI]
public:
void Lock();

Remarks

The collection must be locked before calling Current, MoveNext, or Reset

Requirements

Platforms: See Distribution Requirements

See Also

SelectedThumbnailItemCollectionEnumerator Class | SelectedThumbnailItemCollectionEnumerator Members


MoveNext Method

SelectedThumbnailItemCollectionEnumerator Class | SelectedThumbnailItemCollectionEnumerator Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

MoveNext Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > SelectedThumbnailItemCollectionEnumerator Class : MoveNext Method (SelectedThumbnailItemCollectionEnumerator)

Advances the selected item collection enumerator position within the index by one if not at the end of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();
[C++]
public: bool MoveNext();
[C++/CLI]
public:
bool MoveNext();

Remarks

Note: The selected item collection must be locked before accessing this method.

Requirements

Platforms: See Distribution Requirements

See Also

SelectedThumbnailItemCollectionEnumerator Class | SelectedThumbnailItemCollectionEnumerator Members


Reset Method

SelectedThumbnailItemCollectionEnumerator Class | SelectedThumbnailItemCollectionEnumerator Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Reset Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > SelectedThumbnailItemCollectionEnumerator Class : Reset Method (SelectedThumbnailItemCollectionEnumerator)

Resets the selected item collection position within the index to before the start of the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();
[C++]
public: void Reset();
[C++/CLI]
public:
void Reset();

Remarks

Note: The selected item collection must be locked before accessing this property.

Requirements

Platforms: See Distribution Requirements

See Also

SelectedThumbnailItemCollectionEnumerator Class | SelectedThumbnailItemCollectionEnumerator Members


Unlock Method

SelectedThumbnailItemCollectionEnumerator Class | SelectedThumbnailItemCollectionEnumerator Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Unlock Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > SelectedThumbnailItemCollectionEnumerator Class : Unlock Method (SelectedThumbnailItemCollectionEnumerator)

This method unlocks the selected item collection.

[Visual Basic]
Public Sub Unlock()
[C#]
public void Unlock();
[C++]
public: void Unlock();
[C++/CLI]
public:
void Unlock();

Requirements

Platforms: See Distribution Requirements

See Also

SelectedThumbnailItemCollectionEnumerator Class | SelectedThumbnailItemCollectionEnumerator Members


Current Property

SelectedThumbnailItemCollectionEnumerator Class | SelectedThumbnailItemCollectionEnumerator Members | ThumbnailItem Class

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Current Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > SelectedThumbnailItemCollectionEnumerator Class : Current Property (SelectedThumbnailItemCollectionEnumerator)

Gets the selected ThumbnailItem at the current position within the index.

[Visual Basic]
Public ReadOnly Property Current As ThumbnailItem
[C#]
public ThumbnailItem Current {get;}
[C++]
public: __property ThumbnailItem* get_Current();
[C++/CLI]
public:
property ThumbnailItem^ Current {
   ThumbnailItem^ get();
}

Return Type

Returns the selected ThumbnailItem at the current position within the index.

Remarks

Note: The selected item collection must be locked before accessing this property.

Requirements

Platforms: See Distribution Requirements

See Also

SelectedThumbnailItemCollectionEnumerator Class | SelectedThumbnailItemCollectionEnumerator Members | ThumbnailItem Class


ThumbnailCache Class

ThumbnailCache Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailCache Class

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailCache Class (PegasusImaging.WinForms.ThumbnailXpress2)

This class exposes to the user properties and methods to access the memory and file caching parameters for ThumbnailXpress.

For a list of all members of this type, see ThumbnailCache members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ThumbnailXpress2.ThumbnailCache

Syntax

[Visual Basic]
Public Class ThumbnailCache
[C#]
public class ThumbnailCache
[C++]
public __gc class ThumbnailCache
[C++/CLI]
public ref class ThumbnailCache

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

ThumbnailCache Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ThumbnailCache Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailCache Class Members

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailCache Class (PegasusImaging.WinForms.ThumbnailXpress2)

ThumbnailCache overview

Public Properties

Public Property CacheDiskLimit | Gets or sets the disk cache limit.
Public Property CacheFile | Read only property exposing access to the name of the cache file.
Public Property CacheFilePath | Gets or sets the path of the cache file.
Public Property CacheMemoryLimit | Gets or sets the memory cache limit.

Public Methods

Public Method CacheClear | Clears all items from the memory and disk cache.
Public Method CacheFlushMemory | Flushes all items from the memory cache to disk cache.

See Also

ThumbnailCache Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


CacheClear Method

ThumbnailCache Class | ThumbnailCache Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

CacheClear Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailCache Class : CacheClear Method

Clears all items from the memory and disk cache.

[Visual Basic]
Public Sub CacheClear()
[C#]
public void CacheClear();
[C++]
public: void CacheClear();
[C++/CLI]
public:
void CacheClear();

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailCache Class | ThumbnailCache Members


CacheFlushMemory Method

ThumbnailCache Class | ThumbnailCache Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

CacheFlushMemory Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailCache Class : CacheFlushMemory Method

Flushes all items from the memory cache to disk cache.

[Visual Basic]
Public Sub CacheFlushMemory()
[C#]
public void CacheFlushMemory();
[C++]
public: void CacheFlushMemory();
[C++/CLI]
public:
void CacheFlushMemory();

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailCache Class | ThumbnailCache Members


CacheDiskLimit Property

ThumbnailCache Class | ThumbnailCache Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

CacheDiskLimit Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailCache Class : CacheDiskLimit Property

Gets or sets the disk cache limit.

[Visual Basic]
Public Property CacheDiskLimit As Integer
[C#]
public int CacheDiskLimit {get; set;}
[C++]
public: __property int get_CacheDiskLimit();
public: __property void set_CacheDiskLimit(
   int value
);
[C++/CLI]
public:
property int CacheDiskLimit {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the cache disk limit.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailCache Class | ThumbnailCache Members


CacheFile Property

ThumbnailCache Class | ThumbnailCache Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

CacheFile Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailCache Class : CacheFile Property

Read only property exposing access to the name of the cache file.

[Visual Basic]
Public ReadOnly Property CacheFile As String
[C#]
public string CacheFile {get;}
[C++]
public: __property string* get_CacheFile();
[C++/CLI]
public:
property String^ CacheFile {
   String^ get();
}

Return Type

A string value which represents the cache file.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailCache Class | ThumbnailCache Members


CacheFilePath Property

ThumbnailCache Class | ThumbnailCache Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

CacheFilePath Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailCache Class : CacheFilePath Property

Gets or sets the path of the cache file.

[Visual Basic]
Public Property CacheFilePath As String
[C#]
public string CacheFilePath {get; set;}
[C++]
public: __property string* get_CacheFilePath();
public: __property void set_CacheFilePath(
   string* value
);
[C++/CLI]
public:
property String^ CacheFilePath {
   String^ get();
   void set (String^ value);
}

Return Type

A string value which represents the location and name of the cache file path.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailCache Class | ThumbnailCache Members


CacheMemoryLimit Property

ThumbnailCache Class | ThumbnailCache Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

CacheMemoryLimit Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailCache Class : CacheMemoryLimit Property

Gets or sets the memory cache limit.

[Visual Basic]
Public Property CacheMemoryLimit As Integer
[C#]
public int CacheMemoryLimit {get; set;}
[C++]
public: __property int get_CacheMemoryLimit();
public: __property void set_CacheMemoryLimit(
   int value
);
[C++/CLI]
public:
property int CacheMemoryLimit {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the cache memory limit.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailCache Class | ThumbnailCache Members


ThumbnailItem Class

ThumbnailItem Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailItem Class

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailItem Class

ThumbnailItem class exposes properties for accessing individual thumbnail item data, including image filename, item type, page number, bitmap, page count, and processing status

For a list of all members of this type, see ThumbnailItem members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ThumbnailXpress2.ThumbnailItem

Syntax

[Visual Basic]
Public Class ThumbnailItem
[C#]
public class ThumbnailItem
[C++]
public __gc class ThumbnailItem
[C++/CLI]
public ref class ThumbnailItem

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

ThumbnailItem Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ThumbnailItem Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailItem Class Members

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailItem Class

ThumbnailItem overview

Public Properties

Public Property Bitmap | Read-only property returning an System.Drawing.Bitmap object of the thumbnail image. Returns null if item is a directory.
Public Property CadLayoutCount | Read-only property returning the number of layouts contained in a CAD image file represented by the thumbnail item.
Public Property CadLayoutNumber | Read/Write property accessing the layout number in a CAD image file that the thumbnail item represents.
Public Property Descriptor | Read/write property accessing the descriptor text of the thumbnail item.
Public Property ErrorDescription | Read-only property potentially containing an error descripton string that may be associated with the thumbnail item.
Public Property ErrorNumber | Read-only property potentially returning an error number that may be associated with the thumbnail item. This value is 0 for no error
Public Property Filename | Read/write property accessing the file name and path or URL of the thumbnail item.
Public Property Hbitmap | Read-only property returning a handle to a device dependent bitmap copy of the thumbnail image. Returns null if item is a directory.
Public Property Hdib | Read-only property returning a handle to a device independent bitmap copy of the thumbnail image. Returns null if item is a directory.
Public Property MultiPage | Read-only property indicating whether the image file represented by the thumbnail item is a PDF, TIFF, ICO, Modca, or DCX image file that has been determined to contain multiple image pages.
Public Property Page | Read/Write property accessing the page number in a multi-page image file that the thumbnail item represents.
Public Property PageCount | Read-only property returning the number of image pages contained in the image file that the thumbnail item represents. Note that only PDF, TIFF, ICO, Modca, or DCX image files are able to have page counts greater than 1.
Public Property Status | Read-only property returning the status of the thumbnail item.
Public Property Type | Read-only property returning the image type or directory folder type of the thumbnail item.
Public Property UserTag | Read/Write property accessing an object that contains additional or associated data for this object.

Public Methods

Public Method DisposeHbitmap | Object method for the disposal of device dependent bitmap thumbnail images
Public Method FromStream | Object method allowing a Stream containing image data to be associated with the thumbnail item in place of specifying a filename/path containing the image data.
Public Method ToString | Overridden. Overridden object method returning a string value for the thumbnail item in the format of "ThumbnailItem[ item.Filename : item.PageNum ]"

See Also

ThumbnailItem Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


DisposeHbitmap Method

ThumbnailItem Class | ThumbnailItem Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

hbitmap
Handle to a device dependent bitmap obtained through Hbitmap.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

DisposeHbitmap Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItem Class : DisposeHbitmap Method

Object method for the disposal of device dependent bitmap thumbnail images

[Visual Basic]
Public Sub DisposeHbitmap( _
   ByVal hbitmap As IntPtr _
)
[C#]
public void DisposeHbitmap(
   IntPtr hbitmap
);
[C++]
public: void DisposeHbitmap(
   IntPtr hbitmap
)
[C++/CLI]
public:
void DisposeHbitmap(
   IntPtr hbitmap
)

Parameters

hbitmap
Handle to a device dependent bitmap obtained through Hbitmap.

Remarks

This helper function is provided so that the developer can free all resources associated with an Hbitmap that was obtained through Hbitmap. After disposal the HBitmap handle is invalid and must not be used again.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItem Class | ThumbnailItem Members


FromStream Method

ThumbnailItem Class | ThumbnailItem Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

stream
Stream containing caller supplied image data.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

FromStream Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItem Class : FromStream Method

Object method allowing a Stream containing image data to be associated with the thumbnail item in place of specifying a filename/path containing the image data.

[Visual Basic]
Public Sub FromStream( _
   ByVal stream As Stream _
)
[C#]
public void FromStream(
   Stream stream
);
[C++]
public: void FromStream(
   Stream* stream
)
[C++/CLI]
public:
void FromStream(
   Stream^ stream
)

Parameters

stream
Stream containing caller supplied image data.

Remarks

This method must be called during the processing of the ThumbnailXpressEvents+EventType.LoadFromStream event and may optionally be called before the thumbnail item is first added to the ThumbnailItemCollection thru the ThumbnailItemCollection.AddItemFromStream or ThumbnailItemCollection.InsertItemFromStream methods

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItem Class | ThumbnailItem Members


ToString Method

ThumbnailItem Class | ThumbnailItem Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItem Class : ToString Method

Overridden object method returning a string value for the thumbnail item in the format of "ThumbnailItem[ item.Filename : item.PageNum ]"

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: string* ToString(); override
[C++/CLI]
public:
String^ ToString(); override

Return Type

A String that represents the current thumbnail item.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItem Class | ThumbnailItem Members


Bitmap Property

ThumbnailItem Class | ThumbnailItem Members | Hdib Property | Hbitmap Property

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Bitmap Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItem Class : Bitmap Property

Read-only property returning an System.Drawing.Bitmap object of the thumbnail image. Returns null if item is a directory.

[Visual Basic]
Public ReadOnly Property Bitmap As Bitmap
[C#]
public Bitmap Bitmap {get;}
[C++]
public: __property Bitmap* get_Bitmap();
[C++/CLI]
public:
property Bitmap^ Bitmap {
   Bitmap^ get();
}

Return Type

The bitmap.

Remarks

Attempting to access this property for an item whose image is currently being generated due to the item having been added to or inserted into the ThumbnailItemCollection will invoke a InvalidOperationException. In this situation, use the __Delegates.ThumbnailXpressEvents+ItemCompleteEventHandler event to determine when an item's image has completed being generated before attempting to access its image data

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItem Class | ThumbnailItem Members | Hdib Property | Hbitmap Property


CadLayoutCount Property

ThumbnailItem Class | ThumbnailItem Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

CadLayoutCount Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItem Class : CadLayoutCount Property

Read-only property returning the number of layouts contained in a CAD image file represented by the thumbnail item.

[Visual Basic]
Public ReadOnly Property CadLayoutCount As Integer
[C#]
public int CadLayoutCount {get;}
[C++]
public: __property int get_CadLayoutCount();
[C++/CLI]
public:
property int CadLayoutCount {
   int get();
}

Return Type

The cad layout count.

Remarks

A layout count of 0 means the item is not of type ThumbnailType.Cad.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItem Class | ThumbnailItem Members


CadLayoutNumber Property

ThumbnailItem Class | ThumbnailItem Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

CadLayoutNumber Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItem Class : CadLayoutNumber Property

Read/Write property accessing the layout number in a CAD image file that the thumbnail item represents.

[Visual Basic]
Public Property CadLayoutNumber As Integer
[C#]
public int CadLayoutNumber {get; set;}
[C++]
public: __property int get_CadLayoutNumber();
public: __property void set_CadLayoutNumber(
   int value
);
[C++/CLI]
public:
property int CadLayoutNumber {
   int get();
   void set (int value);
}

Return Type

The cad layout number.

Remarks

Attempting to access the layout number for an item that is not of ThumbnailType.Cad invokes a InvalidOperationException. A layout number equal to zero denotes the default layout for the CAD image file

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItem Class | ThumbnailItem Members


Descriptor Property

ThumbnailItem Class | ThumbnailItem Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Descriptor Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItem Class : Descriptor Property

Read/write property accessing the descriptor text of the thumbnail item.

[Visual Basic]
Public Property Descriptor As String
[C#]
public string Descriptor {get; set;}
[C++]
public: __property string* get_Descriptor();
public: __property void set_Descriptor(
   string* value
);
[C++/CLI]
public:
property String^ Descriptor {
   String^ get();
   void set (String^ value);
}

Return Type

The descriptor.

Remarks

Items of type ThumbnailType.Cad will automatically have the descriptor text set to the CAD layout name when the thumbnail image is generated if no descriptor text was specified by the user.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItem Class | ThumbnailItem Members


ErrorDescription Property

ThumbnailItem Class | ThumbnailItem Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ErrorDescription Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItem Class : ErrorDescription Property

Read-only property potentially containing an error descripton string that may be associated with the thumbnail item.

[Visual Basic]
Public ReadOnly Property ErrorDescription As String
[C#]
public string ErrorDescription {get;}
[C++]
public: __property string* get_ErrorDescription();
[C++/CLI]
public:
property String^ ErrorDescription {
   String^ get();
}

Return Type

The error description.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItem Class | ThumbnailItem Members


ErrorNumber Property

ThumbnailItem Class | ThumbnailItem Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ErrorNumber Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItem Class : ErrorNumber Property

Read-only property potentially returning an error number that may be associated with the thumbnail item. This value is 0 for no error

[Visual Basic]
Public ReadOnly Property ErrorNumber As Integer
[C#]
public int ErrorNumber {get;}
[C++]
public: __property int get_ErrorNumber();
[C++/CLI]
public:
property int ErrorNumber {
   int get();
}

Return Type

The error number.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItem Class | ThumbnailItem Members


Filename Property

ThumbnailItem Class | ThumbnailItem Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Filename Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItem Class : Filename Property

Read/write property accessing the file name and path or URL of the thumbnail item.

[Visual Basic]
Public Property Filename As String
[C#]
public string Filename {get; set;}
[C++]
public: __property string* get_Filename();
public: __property void set_Filename(
   string* value
);
[C++/CLI]
public:
property String^ Filename {
   String^ get();
   void set (String^ value);
}

Return Type

The filename.

Remarks

Changing the file name for an item that is resident in the ThumbnailItemCollection will cause a new image to be generated for the item and the display to be updated if appropriate.

Attempting to change the filename for an item that is currently being generated, that is having a Status of ThumbnailStatus.BeingGenerated will invoke a InvalidOperationException

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItem Class | ThumbnailItem Members


Hbitmap Property

ThumbnailItem Class | ThumbnailItem Members | Hdib Property | Bitmap Property

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Hbitmap Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItem Class : Hbitmap Property

Read-only property returning a handle to a device dependent bitmap copy of the thumbnail image. Returns null if item is a directory.

[Visual Basic]
Public ReadOnly Property Hbitmap As IntPtr
[C#]
public IntPtr Hbitmap {get;}
[C++]
public: __property IntPtr get_Hbitmap();
[C++/CLI]
public:
property IntPtr Hbitmap {
   IntPtr get();
}

Return Type

The hbitmap.

Remarks

A device dependent bitmap is also referred to as a GDI bitmap in some documentation sources.

It is the callers responsibility to free the HBitmap. The member function DisposeHbitmap has been provided for this purpose

Attempting to access this property for an item whose image is currently being generated due to the item having been added to or inserted into the ThumbnailItemCollection will invoke a InvalidOperationException. In this situation, use the __Delegates.ThumbnailXpressEvents+ItemCompleteEventHandler event to determine when an item's image has completed being generated before attempting to access its image data

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItem Class | ThumbnailItem Members | Hdib Property | Bitmap Property


Hdib Property

ThumbnailItem Class | ThumbnailItem Members | Bitmap Property | Hbitmap Property

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Hdib Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItem Class : Hdib Property

Read-only property returning a handle to a device independent bitmap copy of the thumbnail image. Returns null if item is a directory.

[Visual Basic]
Public ReadOnly Property Hdib As IntPtr
[C#]
public IntPtr Hdib {get;}
[C++]
public: __property IntPtr get_Hdib();
[C++/CLI]
public:
property IntPtr Hdib {
   IntPtr get();
}

Return Type

The hdib.

Remarks

It is the callers responsibility to free the hDib.

Attempting to access this property for an item whose image is currently being generated due to the item having been added to or inserted into the ThumbnailItemCollection will invoke a InvalidOperationException. In this situation, use the __Delegates.ThumbnailXpressEvents+ItemCompleteEventHandler event to determine when an item's image has completed being generated before attempting to access its image data

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItem Class | ThumbnailItem Members | Bitmap Property | Hbitmap Property


MultiPage Property

ThumbnailItem Class | ThumbnailItem Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

MultiPage Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItem Class : MultiPage Property

Read-only property indicating whether the image file represented by the thumbnail item is a PDF, TIFF, ICO, Modca, or DCX image file that has been determined to contain multiple image pages.

[Visual Basic]
Public ReadOnly Property MultiPage As Boolean
[C#]
public bool MultiPage {get;}
[C++]
public: __property bool get_MultiPage();
[C++/CLI]
public:
property bool MultiPage {
   bool get();
}

Return Type

true if MultiPage otherwise, false.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItem Class | ThumbnailItem Members


Page Property

ThumbnailItem Class | ThumbnailItem Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Page Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItem Class : Page Property

Read/Write property accessing the page number in a multi-page image file that the thumbnail item represents.

[Visual Basic]
Public Property Page As Integer
[C#]
public int Page {get; set;}
[C++]
public: __property int get_Page();
public: __property void set_Page(
   int value
);
[C++/CLI]
public:
property int Page {
   int get();
   void set (int value);
}

Return Type

The page.

Remarks

Attempting to set the page number for an item that is a directory invokes a InvalidOperationException

The Page property is ignored for internet resident image files and only the first page image of a multi-page image file is generated for these.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItem Class | ThumbnailItem Members


PageCount Property

ThumbnailItem Class | ThumbnailItem Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

PageCount Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItem Class : PageCount Property

Read-only property returning the number of image pages contained in the image file that the thumbnail item represents. Note that only PDF, TIFF, ICO, Modca, or DCX image files are able to have page counts greater than 1.

[Visual Basic]
Public ReadOnly Property PageCount As Integer
[C#]
public int PageCount {get;}
[C++]
public: __property int get_PageCount();
[C++/CLI]
public:
property int PageCount {
   int get();
}

Return Type

The page count.

Remarks

A directory item always reflects a page count value of 0

A page count for multi-page internet resident image files is unable to be determined. The representing thumbnail item(s) for these always reflect a page count value of 1.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItem Class | ThumbnailItem Members


Status Property

ThumbnailItem Class | ThumbnailItem Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Status Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItem Class : Status Property

Read-only property returning the status of the thumbnail item.

[Visual Basic]
Public ReadOnly Property Status As ThumbnailStatus
[C#]
public ThumbnailStatus Status {get;}
[C++]
public: __property ThumbnailStatus get_Status();
[C++/CLI]
public:
property ThumbnailStatus Status {
   ThumbnailStatus get();
}

Return Type

The status.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItem Class | ThumbnailItem Members


Type Property

ThumbnailItem Class | ThumbnailItem Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Type Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItem Class : Type Property (ThumbnailItem)

Read-only property returning the image type or directory folder type of the thumbnail item.

[Visual Basic]
Public ReadOnly Property Type As ThumbnailType
[C#]
public ThumbnailType Type {get;}
[C++]
public: __property ThumbnailType get_Type();
[C++/CLI]
public:
property ThumbnailType Type {
   ThumbnailType get();
}

Return Type

The Thumbnail Type.

Remarks

A type of ThumbnailType.Internet indicates the image data resides on the internet and a thumbnail image has not yet attempted to be generated for this item. Internet resident files are subject to the following restrictions: Thumbnail images for image resident PDF files cannot be generated by PdfXpress. The image data type can not be determined until is thumbnail image is attempted to be generated. For multi-page image files, a page count is not determined and the PageCount property value is always set to 1. The Page property value is ignored and only the first page is generated.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItem Class | ThumbnailItem Members


UserTag Property

ThumbnailItem Class | ThumbnailItem Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

UserTag Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItem Class : UserTag Property

Read/Write property accessing an object that contains additional or associated data for this object.

[Visual Basic]
Public Property UserTag As Object
[C#]
public object UserTag {get; set;}
[C++]
public: __property Object* get_UserTag();
public: __property void set_UserTag(
   Object* value
);
[C++/CLI]
public:
property Object^ UserTag {
   Object^ get();
   void set (Object^ value);
}

Return Type

The user tag.

Remarks

You can assign any Object derived type to this property. This component does not access it and you can use it for any purpose you see fit. It is important to note that when adding or inserting items into the ThumbnailItemCollection via a stream that the UserTag value should be used for determining the source of the stream data that you will supply

Valid value: A reference to any object. You can store values, such as integers and strings, in this property using .NET's boxing facility.

Default value: null

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItem Class | ThumbnailItem Members


ThumbnailItemCollection Class

ThumbnailItemCollection Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailItemCollection Class

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailItemCollection Class

ThumbnailItemCollection class provides thumbnail item manipulation and image presentation functionality.

For a list of all members of this type, see ThumbnailItemCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PegasusImaging.WinForms.ThumbnailXpress2.ThumbnailItemCollection

Syntax

[Visual Basic]
<DefaultMemberAttribute("Item")>
Public Class ThumbnailItemCollection
   Inherits CollectionBase
[C#]
[DefaultMemberAttribute("Item")]
public class ThumbnailItemCollection : CollectionBase
[C++]
[DefaultMemberAttribute("Item")]
public __gc class ThumbnailItemCollection : public CollectionBase
[C++/CLI]
[DefaultMemberAttribute("Item")]
public ref class ThumbnailItemCollection : public CollectionBase

Remarks

The collection provides the access to the scrollable thumbnail list display. Adding or removing items will cause the list display to update if appropriate.

Thumbnail item images are generated when they are first brought into visible view in the display. The generated images are cached to facilitate a more responsive display. Caching parameters can be configured though the ThumbnailCache object accessed through the ThumbnailXpress.ThumbnailCache property.

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

ThumbnailItemCollection Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ThumbnailItemCollection Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailItemCollection Class Members

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailItemCollection Class

ThumbnailItemCollection overview

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count | Gets the number of items in the collection.
Public Property IsFixedSize | Read-only property returning whether the collection is a fixed size.
Public Property IsReadOnly | Read-only property returning whether the collection access is read-only.
Public Property IsSynchronized | Read only property returning whether synchronized (thread-safe) read-write access to the Collection is available. Will always return false. Use the ThumbnailItemCollectionEnumerator and its Lock method to access the ThumbnailItemCollection in a read-only thread safe manner.
Public Property Item | Read-only property returning the ThumbnailItem object from the given collection index.
Public Property SyncRoot | Read-only property returning an object that can be used to synchronize access to the collection.

Public Methods

Public Method Add | Overloaded. This method adds the provided ThumbnailItem to the end of the collection. The display is updated if appropriate. This menthod throws an exception if item is not a directory and item.Filename specifies an invalid, unsupported, or non-existent file.
Public Method AddItemFromStream | Adds the provided ThumbnailItem to the end of the collection. The display is updated if appropriate. Rather than obtaining its image data from a supplied filename/path, the image data will be expected to be provided by a Stream object.
Public Method AddItemsFromDirectory | Adds thumbnail items to the collection from the provided directory.
Public Method AddItemsFromFile | Adds a thumbnail item from a single-page image or optionally multiple items (one per page) from a multi-page image to the collection from the provided image file.
Public Method Clear | This method clears all thumbnails out of the collection. The display is updated.
Public Method Contains | This method provides an indication as to whether the collection contains the given ThumbnailItem. The matching criteria is based on the filename / pagenumber information.
Public Method CopyTo | Copy the collection to an array of ThumbnailItems.
Public Method GetEnumerator | Returns an enumerator for traversing the collection.
Public Method IndexOf | This method returns the index of the given ThumbnailItem in the collection. The matching criteria is based on the filename / pagenumber information.
Public Method Insert | Overloaded. This method inserts the provided ThumbnailItem into the collection at the given index. The display is updated if appropriate. This menthod throws an exception if item is not a directory and item.Filename specifies an invalid, unsupported, or non-existent file.
Public Method InsertItemFromStream | This method inserts the provided ThumbnailItem into the collection at the given index. The display is updated if appropriate. Rather than obtaining its image data from a supplied filename/path, the image data will be expected to be provided by a Stream object.
Public Method Refresh | This method Refreshes the contents of the thumbnail collection. When the contents of a directory or multi-page image file have changed, Refresh can be used to update the items in the thumbnail collection. Refresh is limited in that it can only be used when a collection is created from a directory or a multi-page image file
Public Method Remove | This method removes the provided ThumbnailItem from the collection. The matching criteria is based on the filename / pagenumber information. The display is updated if appropriate
Public Method RemoveAt | This method removes the thumbnail item at the given location in the collection. The display is updated if appropriate

See Also

ThumbnailItemCollection Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


Add Method

ThumbnailItemCollection Class | ThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Add Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollection Class : Add Method (ThumbnailItemCollection)

This method adds the provided ThumbnailItem to the end of the collection. The display is updated if appropriate. This menthod throws an exception if item is not a directory and item.Filename specifies an invalid, unsupported, or non-existent file.

Overload List

This method adds the provided ThumbnailItem to the end of the collection. The display is updated if appropriate. This menthod throws an exception if item is not a directory and item.Filename specifies an invalid, unsupported, or non-existent file.

[Visual Basic] Overloads Public Overridable Function Add(ThumbnailItem) As Integer

[C#] public virtual int Add(ThumbnailItem);

[C++] public virtual int Add(ThumbnailItem*);

[C++/CLI] public virtual int Add(ThumbnailItem^);

This method adds the provided ThumbnailItem to the end of the collection. The display is updated if appropriate. This menthod throws an exception if item is not a directory and item.Filename specifies an invalid, unsupported, or non-existent file.

[Visual Basic] Overloads Public Function Add(ThumbnailItem,Boolean) As Integer

[C#] public int Add(ThumbnailItem,bool);

[C++] public int Add(ThumbnailItem*,bool);

[C++/CLI] public int Add(ThumbnailItem^,bool);

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollection Class | ThumbnailItemCollection Members


Add(ThumbnailItem) Method

ThumbnailItemCollection Class | ThumbnailItemCollection Members | Overload List

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

item
The thumbnail to add.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Add(ThumbnailItem) Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollection Class > Add Method : Add(ThumbnailItem) Method

This method adds the provided ThumbnailItem to the end of the collection. The display is updated if appropriate. This menthod throws an exception if item is not a directory and item.Filename specifies an invalid, unsupported, or non-existent file.

[Visual Basic]
Overloads Public Overridable Function Add( _
   ByVal item As ThumbnailItem _
) As Integer
[C#]
public virtual int Add(
   ThumbnailItem item
);
[C++]
public: virtual int Add(
   ThumbnailItem* item
)
[C++/CLI]
public:
virtual int Add(
   ThumbnailItem^ item
)

Parameters

item
The thumbnail to add.

Return Type

Returns the new count of total thumbnails.

Remarks

This method does not wait for an image to be generated before returning. The thumbnail image is generated in the background. This means a thumbnail's image data (for example, it's bitmap) is likely not available immediately after this method returns. Use the ThumbnailXpress.ItemComplete event to determine when an item's image has completed being generated before attempting to programmaticaly access its image data

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollection Class | ThumbnailItemCollection Members | Overload List


Add(ThumbnailItem,Boolean) Method

ThumbnailItemCollection Class | ThumbnailItemCollection Members | Overload List

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

item
The thumbnail to add.
verify
Validate the file name specified in item.FileName if the item is not a directory. This menthod throws an exception if item.Filename specifies an invalid, unsupported, or non-existent file.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Add(ThumbnailItem,Boolean) Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollection Class > Add Method : Add(ThumbnailItem,Boolean) Method

This method adds the provided ThumbnailItem to the end of the collection. The display is updated if appropriate. This menthod throws an exception if item is not a directory and item.Filename specifies an invalid, unsupported, or non-existent file.

[Visual Basic]
Overloads Public Function Add( _
   ByVal item As ThumbnailItem, _
   ByVal verify As Boolean _
) As Integer
[C#]
public int Add(
   ThumbnailItem item,
   bool verify
);
[C++]
public: int Add(
   ThumbnailItem* item,
   bool verify
)
[C++/CLI]
public:
int Add(
   ThumbnailItem^ item,
   bool verify
)

Parameters

item
The thumbnail to add.
verify
Validate the file name specified in item.FileName if the item is not a directory. This menthod throws an exception if item.Filename specifies an invalid, unsupported, or non-existent file.

Return Type

Returns the new count of total thumbnails.

Remarks

This method does not wait for an image to be generated before returning. The thumbnail image is generated in the background. This means a thumbnail's image data (for example, it's bitmap) is likely not available immediately after this method returns. Use the ThumbnailXpress.ItemComplete event to determine when an item's image has completed being generated before attempting to programmaticaly access its image data

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollection Class | ThumbnailItemCollection Members | Overload List


AddItemFromStream Method

ThumbnailItemCollection Class | ThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

item
The thumbnail to add.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

AddItemFromStream Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollection Class : AddItemFromStream Method

Adds the provided ThumbnailItem to the end of the collection. The display is updated if appropriate. Rather than obtaining its image data from a supplied filename/path, the image data will be expected to be provided by a Stream object.

[Visual Basic]
Public Function AddItemFromStream( _
   ByVal item As ThumbnailItem _
) As Integer
[C#]
public int AddItemFromStream(
   ThumbnailItem item
);
[C++]
public: int AddItemFromStream(
   ThumbnailItem* item
)
[C++/CLI]
public:
int AddItemFromStream(
   ThumbnailItem^ item
)

Parameters

item
The thumbnail to add.

Return Type

Returns the new count of total thumbnails.

Remarks

The Stream object may optionally be associated with the ThumbnailItem using its ThumbnailItem.FromStream method before AddItemFromStream is called. However, a __Delegates.ThumbnailXpressEvents+LoadFromStreamEventHandler must be supplied by the application and a stream object cotaining the image data must be supplied during processing of the event handler. Note that the event must be handled because at any time a stream-supplied thumbnail image can be scrolled out of the ThumbnailXpress image chache, and to redisplay, the component needs to re-obtain from the application the image data stream. Additionally, the ThumbnailItem passed to AddItemFromStream must contain a valid ThumbnailItem.UserTag object that allows the application to identify the stream object that will provide the image data for the item.

This method does not wait for images to be generated before returning. The thumbnail images are generated in the background. This means a thumbnail's image data (for example, it's bitmap) is likely not available immediately after this method returns. Use the ThumbnailXpress.ItemComplete event to determine when an item's image has completed being generated before attempting to programmaticaly access its image data

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollection Class | ThumbnailItemCollection Members


AddItemsFromDirectory Method

ThumbnailItemCollection Class | ThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

directory
A string value which represents the directory used as the source of the images.
collectionIndex
An integer value which represents the index into the collection where the item should be added. -1 indicates to append to the end of the collection.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

AddItemsFromDirectory Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollection Class : AddItemsFromDirectory Method

Adds thumbnail items to the collection from the provided directory.

[Visual Basic]
Public Function AddItemsFromDirectory( _
   ByVal directory As String, _
   ByVal collectionIndex As Integer _
) As Integer
[C#]
public int AddItemsFromDirectory(
   string directory,
   int collectionIndex
);
[C++]
public: int AddItemsFromDirectory(
   string* directory,
   int collectionIndex
)
[C++/CLI]
public:
int AddItemsFromDirectory(
   String^ directory,
   int collectionIndex
)

Parameters

directory
A string value which represents the directory used as the source of the images.
collectionIndex
An integer value which represents the index into the collection where the item should be added. -1 indicates to append to the end of the collection.

Return Type

An integer which represents the number of images this method added to the collection.

Remarks

Only the first page of multi-page images are added.

This method does not wait for images to be generated before returning. The thumbnail images are generated in the background. This means a thumbnail's image data (for example, it's bitmap) is likely not available immediately after this method returns. Use the ThumbnailXpress.ItemComplete event to determine when an item's image has completed being generated before attempting to programmaticaly access its image data.

Note: When a path is passed to this method without a final trailing slash, the parent of the path is used as the directory.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollection Class | ThumbnailItemCollection Members


AddItemsFromFile Method

ThumbnailItemCollection Class | ThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

filename
The name and path of the image file. Note that the path may specify an internet address such as "http://www.somesite.com/test.jpg" or "ftp://..../test.jpg" with two limitations. PdfXpress (if used) cannot access internet resident files and internet resident multi-page files of any type cannot be expanded
collectionIndex
The index into the collection where the item(s) should be added/inserted. -1 indicates to append to the end of the collection.
expandMultiPage
Flag indicating whether to use all pages in a multi-page image or not.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

AddItemsFromFile Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollection Class : AddItemsFromFile Method

Adds a thumbnail item from a single-page image or optionally multiple items (one per page) from a multi-page image to the collection from the provided image file.

[Visual Basic]
Public Function AddItemsFromFile( _
   ByVal filename As String, _
   ByVal collectionIndex As Integer, _
   ByVal expandMultiPage As Boolean _
) As Integer
[C#]
public int AddItemsFromFile(
   string filename,
   int collectionIndex,
   bool expandMultiPage
);
[C++]
public: int AddItemsFromFile(
   string* filename,
   int collectionIndex,
   bool expandMultiPage
)
[C++/CLI]
public:
int AddItemsFromFile(
   String^ filename,
   int collectionIndex,
   bool expandMultiPage
)

Parameters

filename
The name and path of the image file. Note that the path may specify an internet address such as "http://www.somesite.com/test.jpg" or "ftp://..../test.jpg" with two limitations. PdfXpress (if used) cannot access internet resident files and internet resident multi-page files of any type cannot be expanded
collectionIndex
The index into the collection where the item(s) should be added/inserted. -1 indicates to append to the end of the collection.
expandMultiPage
Flag indicating whether to use all pages in a multi-page image or not.

Return Type

The number of items this method added to the collection.

Remarks

This method does not wait for images to be generated before returning. The thumbnail images are generated in the background. This means a thumbnail's image data (for example, it's bitmap) is likely not available immediately after this method returns. Use the ThumbnailXpress.ItemComplete event to determine when an item's image has completed being generated before attempting to programmaticaly access its image data

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollection Class | ThumbnailItemCollection Members


Clear Method

ThumbnailItemCollection Class | ThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Clear Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollection Class : Clear Method (ThumbnailItemCollection)

This method clears all thumbnails out of the collection. The display is updated.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[C++/CLI]
public:
void Clear();

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollection Class | ThumbnailItemCollection Members


Contains Method

ThumbnailItemCollection Class | ThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

item
The thumbnail to look for in the collection.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Contains Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollection Class : Contains Method (ThumbnailItemCollection)

This method provides an indication as to whether the collection contains the given ThumbnailItem. The matching criteria is based on the filename / pagenumber information.

[Visual Basic]
Public Overridable Function Contains( _
   ByVal item As ThumbnailItem _
) As Boolean
[C#]
public virtual bool Contains(
   ThumbnailItem item
);
[C++]
public: virtual bool Contains(
   ThumbnailItem* item
)
[C++/CLI]
public:
virtual bool Contains(
   ThumbnailItem^ item
)

Parameters

item
The thumbnail to look for in the collection.

Return Type

True if the thumbnail exists in the collection; false if not.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollection Class | ThumbnailItemCollection Members


CopyTo Method

ThumbnailItemCollection Class | ThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

array
The destination array.
index
The index in the array in which to start adding the ThumbnailItems.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

CopyTo Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollection Class : CopyTo Method (ThumbnailItemCollection)

Copy the collection to an array of ThumbnailItems.

[Visual Basic]
Public Overridable Sub CopyTo( _
   ByVal array() As ThumbnailItem, _
   ByVal index As Integer _
)
[C#]
public virtual void CopyTo(
   ThumbnailItem[] array,
   int index
);
[C++]
public: virtual void CopyTo(
   ThumbnailItem*[]* array,
   int index
)
[C++/CLI]
public:
virtual void CopyTo(
   ThumbnailItem^array<array>^ array,
   int index
)

Parameters

array
The destination array.
index
The index in the array in which to start adding the ThumbnailItems.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollection Class | ThumbnailItemCollection Members


GetEnumerator Method

ThumbnailItemCollection Class | ThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

GetEnumerator Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollection Class : GetEnumerator Method (ThumbnailItemCollection)

Returns an enumerator for traversing the collection.

[Visual Basic]
Public Overridable Function GetEnumerator() As ThumbnailItemCollectionEnumerator
[C#]
public virtual ThumbnailItemCollectionEnumerator GetEnumerator();
[C++]
public: virtual ThumbnailItemCollectionEnumerator* GetEnumerator();
[C++/CLI]
public:
virtual ThumbnailItemCollectionEnumerator^ GetEnumerator();

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollection Class | ThumbnailItemCollection Members


IndexOf Method

ThumbnailItemCollection Class | ThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

item
The thumbnail item to look for in the collection.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

IndexOf Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollection Class : IndexOf Method (ThumbnailItemCollection)

This method returns the index of the given ThumbnailItem in the collection. The matching criteria is based on the filename / pagenumber information.

[Visual Basic]
Public Overridable Function IndexOf( _
   ByVal item As ThumbnailItem _
) As Integer
[C#]
public virtual int IndexOf(
   ThumbnailItem item
);
[C++]
public: virtual int IndexOf(
   ThumbnailItem* item
)
[C++/CLI]
public:
virtual int IndexOf(
   ThumbnailItem^ item
)

Parameters

item
The thumbnail item to look for in the collection.

Return Type

The index of the thumbnail item or -1 if not in the collection

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollection Class | ThumbnailItemCollection Members


Insert Method

ThumbnailItemCollection Class | ThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Insert Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollection Class : Insert Method (ThumbnailItemCollection)

This method inserts the provided ThumbnailItem into the collection at the given index. The display is updated if appropriate. This menthod throws an exception if item is not a directory and item.Filename specifies an invalid, unsupported, or non-existent file.

Overload List

This method inserts the provided ThumbnailItem into the collection at the given index. The display is updated if appropriate. This menthod throws an exception if item is not a directory and item.Filename specifies an invalid, unsupported, or non-existent file.

[Visual Basic] Overloads Public Overridable Sub Insert(Integer,ThumbnailItem)

[C#] public virtual void Insert(int,ThumbnailItem);

[C++] public virtual void Insert(int,ThumbnailItem*);

[C++/CLI] public virtual void Insert(int,ThumbnailItem^);

This method inserts the provided ThumbnailItem into the collection at the given index. The display is updated if appropriate

[Visual Basic] Overloads Public Sub Insert(Integer,ThumbnailItem,Boolean)

[C#] public void Insert(int,ThumbnailItem,bool);

[C++] public void Insert(int,ThumbnailItem*,bool);

[C++/CLI] public void Insert(int,ThumbnailItem^,bool);

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollection Class | ThumbnailItemCollection Members


Insert(Int32,ThumbnailItem) Method

ThumbnailItemCollection Class | ThumbnailItemCollection Members | Overload List

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

collectionIndex
The index position to add the given thumbnail.
item
The thumbnail to insert into the collection.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Insert(Int32,ThumbnailItem) Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollection Class > Insert Method : Insert(Int32,ThumbnailItem) Method

This method inserts the provided ThumbnailItem into the collection at the given index. The display is updated if appropriate. This menthod throws an exception if item is not a directory and item.Filename specifies an invalid, unsupported, or non-existent file.

[Visual Basic]
Overloads Public Overridable Sub Insert( _
   ByVal collectionIndex As Integer, _
   ByVal item As ThumbnailItem _
)
[C#]
public virtual void Insert(
   int collectionIndex,
   ThumbnailItem item
);
[C++]
public: virtual void Insert(
   int collectionIndex,
   ThumbnailItem* item
)
[C++/CLI]
public:
virtual void Insert(
   int collectionIndex,
   ThumbnailItem^ item
)

Parameters

collectionIndex
The index position to add the given thumbnail.
item
The thumbnail to insert into the collection.

Remarks

This method does not wait for an image to be generated before returning. The thumbnail image is generated in the background. This means a thumbnail's image data (for example, it's bitmap) is likely not available immediately after this method returns. Use the ThumbnailXpress.ItemComplete event to determine when an item's image has completed being generated before attempting to programmaticaly access its image data

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollection Class | ThumbnailItemCollection Members | Overload List


Insert(Int32,ThumbnailItem,Boolean) Method

ThumbnailItemCollection Class | ThumbnailItemCollection Members | Overload List

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

collectionIndex
The index position to add the given thumbnail.
item
The thumbnail to insert into the collection.
verify
Validate the file name specified in item.FileName if the item is not a directory. This menthod throws an exception if item.Filename specifies an invalid, unsupported, or non-existent file.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Insert(Int32,ThumbnailItem,Boolean) Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollection Class > Insert Method : Insert(Int32,ThumbnailItem,Boolean) Method

This method inserts the provided ThumbnailItem into the collection at the given index. The display is updated if appropriate

[Visual Basic]
Overloads Public Sub Insert( _
   ByVal collectionIndex As Integer, _
   ByVal item As ThumbnailItem, _
   ByVal verify As Boolean _
)
[C#]
public void Insert(
   int collectionIndex,
   ThumbnailItem item,
   bool verify
);
[C++]
public: void Insert(
   int collectionIndex,
   ThumbnailItem* item,
   bool verify
)
[C++/CLI]
public:
void Insert(
   int collectionIndex,
   ThumbnailItem^ item,
   bool verify
)

Parameters

collectionIndex
The index position to add the given thumbnail.
item
The thumbnail to insert into the collection.
verify
Validate the file name specified in item.FileName if the item is not a directory. This menthod throws an exception if item.Filename specifies an invalid, unsupported, or non-existent file.

Remarks

This method does not wait for an image to be generated before returning. The thumbnail image is generated in the background. This means a thumbnail's image data (for example, it's bitmap) is likely not available immediately after this method returns. Use the ThumbnailXpress.ItemComplete event to determine when an item's image has completed being generated before attempting to programmaticaly access its image data

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollection Class | ThumbnailItemCollection Members | Overload List


InsertItemFromStream Method

ThumbnailItemCollection Class | ThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

collectionIndex
The index position to add the given thumbnail.
item
The thumbnail to add.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

InsertItemFromStream Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollection Class : InsertItemFromStream Method

This method inserts the provided ThumbnailItem into the collection at the given index. The display is updated if appropriate. Rather than obtaining its image data from a supplied filename/path, the image data will be expected to be provided by a Stream object.

[Visual Basic]
Public Sub InsertItemFromStream( _
   ByVal collectionIndex As Integer, _
   ByVal item As ThumbnailItem _
)
[C#]
public void InsertItemFromStream(
   int collectionIndex,
   ThumbnailItem item
);
[C++]
public: void InsertItemFromStream(
   int collectionIndex,
   ThumbnailItem* item
)
[C++/CLI]
public:
void InsertItemFromStream(
   int collectionIndex,
   ThumbnailItem^ item
)

Parameters

collectionIndex
The index position to add the given thumbnail.
item
The thumbnail to add.

Remarks

The Stream object may optionally be associated with the ThumbnailItem using its ThumbnailItem.FromStream method before InsertItemFromStream is called. However, a __Delegates.ThumbnailXpressEvents+LoadFromStreamEventHandler must be supplied by the application and a stream object cotaining the image data must be supplied during processing of the event handler. Note that the event must be handled because at any time a stream-supplied thumbnail image can be scrolled out of the ThumbnailXpress image chache, and to redisplay, the component needs to re-obtain from the application the image data stream. Additionally, the ThumbnailItem passed to InsertItemFromStream must contain a valid ThumbnailItem.UserTag object that allows the application to identify the stream object that will provide the image data for the item.

This method does not wait for images to be generated before returning. The thumbnail images are generated in the background. This means a thumbnail's image data (for example, it's bitmap) is likely not available immediately after this method returns. Use the ThumbnailXpress.ItemComplete event to determine when an item's image has completed being generated before attempting to programmaticaly access its image data

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollection Class | ThumbnailItemCollection Members


Refresh Method

ThumbnailItemCollection Class | ThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Refresh Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollection Class : Refresh Method

This method Refreshes the contents of the thumbnail collection. When the contents of a directory or multi-page image file have changed, Refresh can be used to update the items in the thumbnail collection. Refresh is limited in that it can only be used when a collection is created from a directory or a multi-page image file

[Visual Basic]
Public Sub Refresh()
[C#]
public void Refresh();
[C++]
public: void Refresh();
[C++/CLI]
public:
void Refresh();

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollection Class | ThumbnailItemCollection Members


Remove Method

ThumbnailItemCollection Class | ThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

item
The thumbnail item to remove.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Remove Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollection Class : Remove Method (ThumbnailItemCollection)

This method removes the provided ThumbnailItem from the collection. The matching criteria is based on the filename / pagenumber information. The display is updated if appropriate

[Visual Basic]
Public Overridable Sub Remove( _
   ByVal item As ThumbnailItem _
)
[C#]
public virtual void Remove(
   ThumbnailItem item
);
[C++]
public: virtual void Remove(
   ThumbnailItem* item
)
[C++/CLI]
public:
virtual void Remove(
   ThumbnailItem^ item
)

Parameters

item
The thumbnail item to remove.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollection Class | ThumbnailItemCollection Members


RemoveAt Method

ThumbnailItemCollection Class | ThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

collectionIndex
Position of the thumbnail to remove.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

RemoveAt Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollection Class : RemoveAt Method (ThumbnailItemCollection)

This method removes the thumbnail item at the given location in the collection. The display is updated if appropriate

[Visual Basic]
Public Overridable Sub RemoveAt( _
   ByVal collectionIndex As Integer _
)
[C#]
public virtual void RemoveAt(
   int collectionIndex
);
[C++]
public: virtual void RemoveAt(
   int collectionIndex
)
[C++/CLI]
public:
virtual void RemoveAt(
   int collectionIndex
)

Parameters

collectionIndex
Position of the thumbnail to remove.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollection Class | ThumbnailItemCollection Members


Count Property

ThumbnailItemCollection Class | ThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Count Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollection Class : Count Property (ThumbnailItemCollection)

Gets the number of items in the collection.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[C++/CLI]
public:
property int Count {
   int get();
}

Return Type

The number of elements contained in the collection.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollection Class | ThumbnailItemCollection Members


IsFixedSize Property

ThumbnailItemCollection Class | ThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

IsFixedSize Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollection Class : IsFixedSize Property (ThumbnailItemCollection)

Read-only property returning whether the collection is a fixed size.

[Visual Basic]
Public Overridable ReadOnly Property IsFixedSize As Boolean
[C#]
public virtual bool IsFixedSize {get;}
[C++]
public: __property virtual bool get_IsFixedSize();
[C++/CLI]
public:
virtual property bool IsFixedSize {
   bool get();
}

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollection Class | ThumbnailItemCollection Members


IsReadOnly Property

ThumbnailItemCollection Class | ThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

IsReadOnly Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollection Class : IsReadOnly Property (ThumbnailItemCollection)

Read-only property returning whether the collection access is read-only.

[Visual Basic]
Public Overridable ReadOnly Property IsReadOnly As Boolean
[C#]
public virtual bool IsReadOnly {get;}
[C++]
public: __property virtual bool get_IsReadOnly();
[C++/CLI]
public:
virtual property bool IsReadOnly {
   bool get();
}

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollection Class | ThumbnailItemCollection Members


IsSynchronized Property

ThumbnailItemCollection Class | ThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

IsSynchronized Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollection Class : IsSynchronized Property (ThumbnailItemCollection)

Read only property returning whether synchronized (thread-safe) read-write access to the Collection is available. Will always return false. Use the ThumbnailItemCollectionEnumerator and its Lock method to access the ThumbnailItemCollection in a read-only thread safe manner.

[Visual Basic]
Public Overridable ReadOnly Property IsSynchronized As Boolean
[C#]
public virtual bool IsSynchronized {get;}
[C++]
public: __property virtual bool get_IsSynchronized();
[C++/CLI]
public:
virtual property bool IsSynchronized {
   bool get();
}

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollection Class | ThumbnailItemCollection Members


Item Property

ThumbnailItemCollection Class | ThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

collectionIndex
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Item Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollection Class : Item Property (ThumbnailItemCollection)

Read-only property returning the ThumbnailItem object from the given collection index.

[Visual Basic]
Public Overridable ReadOnly Default Property Item( _
   ByVal collectionIndex As Integer _
) As ThumbnailItem
[C#]
public virtual ThumbnailItem this[
   int collectionIndex
]; {get;}
[C++]
public: __property virtual ThumbnailItem* get_Item(
   int collectionIndex
);
[C++/CLI]
public:
virtual  property ThumbnailItem^ default [int] {
   ThumbnailItem^ get(int collectionIndex);
}

Parameters

collectionIndex

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollection Class | ThumbnailItemCollection Members


SyncRoot Property

ThumbnailItemCollection Class | ThumbnailItemCollection Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

SyncRoot Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollection Class : SyncRoot Property (ThumbnailItemCollection)

Read-only property returning an object that can be used to synchronize access to the collection.

[Visual Basic]
Public Overridable ReadOnly Property SyncRoot As Object
[C#]
public virtual object SyncRoot {get;}
[C++]
public: __property virtual Object* get_SyncRoot();
[C++/CLI]
public:
virtual property Object^ SyncRoot {
   Object^ get();
}

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollection Class | ThumbnailItemCollection Members


ThumbnailItemCollectionEnumerator Class

ThumbnailItemCollectionEnumerator Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailItemCollectionEnumerator Class

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailItemCollectionEnumerator Class

ThumbnailItemCollectionEnumerator class provides a lockable IEnumerator interface for the ThumbnailItemCollection class.

For a list of all members of this type, see ThumbnailItemCollectionEnumerator members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ThumbnailXpress2.ThumbnailItemCollectionEnumerator

Syntax

[Visual Basic]
Public Class ThumbnailItemCollectionEnumerator
[C#]
public class ThumbnailItemCollectionEnumerator
[C++]
public __gc class ThumbnailItemCollectionEnumerator
[C++/CLI]
public ref class ThumbnailItemCollectionEnumerator

Remarks

When locked, the ThumbnailItemCollectionEnumerator provides thread-safe read-only access to the ThumbnailItemCollection.

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

ThumbnailItemCollectionEnumerator Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ThumbnailItemCollectionEnumerator Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailItemCollectionEnumerator Class Members

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailItemCollectionEnumerator Class

ThumbnailItemCollectionEnumerator overview

Public Properties

Public Property Current Gets the ThumbnailItem at the current enumerator index.

Public Methods

Public Method Lock | Locks the collection.
Public Method MoveNext | This method advances the collection enumerator position/index by one if not at the end of the collection.
Public Method Reset | Resets the collection index to before the start of the collection.
Public Method Unlock | Unlocks the collection.

See Also

ThumbnailItemCollectionEnumerator Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


Lock Method

ThumbnailItemCollectionEnumerator Class | ThumbnailItemCollectionEnumerator Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Lock Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollectionEnumerator Class : Lock Method (ThumbnailItemCollectionEnumerator)

Locks the collection.

[Visual Basic]
Public Sub Lock()
[C#]
public void Lock();
[C++]
public: void Lock();
[C++/CLI]
public:
void Lock();

Remarks

The collection must be locked before calling Current, MoveNext, or Reset.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollectionEnumerator Class | ThumbnailItemCollectionEnumerator Members


MoveNext Method

ThumbnailItemCollectionEnumerator Class | ThumbnailItemCollectionEnumerator Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

MoveNext Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollectionEnumerator Class : MoveNext Method (ThumbnailItemCollectionEnumerator)

This method advances the collection enumerator position/index by one if not at the end of the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();
[C++]
public: bool MoveNext();
[C++/CLI]
public:
bool MoveNext();

Return Type

A boolean value which is true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Remarks

The collection must be locked before accessing this method.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollectionEnumerator Class | ThumbnailItemCollectionEnumerator Members


Reset Method

ThumbnailItemCollectionEnumerator Class | ThumbnailItemCollectionEnumerator Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Reset Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollectionEnumerator Class : Reset Method (ThumbnailItemCollectionEnumerator)

Resets the collection index to before the start of the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();
[C++]
public: void Reset();
[C++/CLI]
public:
void Reset();

Remarks

The collection must be locked before accessing this property.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollectionEnumerator Class | ThumbnailItemCollectionEnumerator Members


Unlock Method

ThumbnailItemCollectionEnumerator Class | ThumbnailItemCollectionEnumerator Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Unlock Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollectionEnumerator Class : Unlock Method (ThumbnailItemCollectionEnumerator)

Unlocks the collection.

[Visual Basic]
Public Sub Unlock()
[C#]
public void Unlock();
[C++]
public: void Unlock();
[C++/CLI]
public:
void Unlock();

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollectionEnumerator Class | ThumbnailItemCollectionEnumerator Members


Current Property

ThumbnailItemCollectionEnumerator Class | ThumbnailItemCollectionEnumerator Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Current Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailItemCollectionEnumerator Class : Current Property (ThumbnailItemCollectionEnumerator)

Gets the ThumbnailItem at the current enumerator index.

[Visual Basic]
Public ReadOnly Property Current As ThumbnailItem
[C#]
public ThumbnailItem Current {get;}
[C++]
public: __property ThumbnailItem* get_Current();
[C++/CLI]
public:
property ThumbnailItem^ Current {
   ThumbnailItem^ get();
}

Return Type

Returns the ThumbnailItem at the current enumerator index.

Remarks

The collection must be locked before accessing this property.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailItemCollectionEnumerator Class | ThumbnailItemCollectionEnumerator Members


ThumbnailXpress Class

ThumbnailXpress Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailXpress Class

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailXpress Class

The Thumbnail User Control provides displaying of supported image types as thumbnails inside individual cells in a scrollable collection.

For a list of all members of this type, see ThumbnailXpress members.

Object Model

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
PegasusImaging.WinForms.ThumbnailXpress2.ThumbnailXpress

Syntax

[Visual Basic]
<ToolboxBitmapAttribute()>
Public Class ThumbnailXpress
   Inherits UserControl
[C#]
[ToolboxBitmapAttribute()]
public class ThumbnailXpress : UserControl
[C++]
[ToolboxBitmapAttribute()]
public __gc class ThumbnailXpress : public UserControl
[C++/CLI]
[ToolboxBitmapAttribute()]
public ref class ThumbnailXpress : public UserControl

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

ThumbnailXpress Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ThumbnailXpress Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailXpress Class Members

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailXpress Class

ThumbnailXpress overview

Public Constructors

Public Constructor ThumbnailXpress Constructor The main ThumbnailXpress constructor.

Public Properties

Public Property AccessibilityObject (Inherited from System.Windows.Forms.Control) | Gets the AccessibleObject assigned to the control.
Public Property AccessibleDefaultActionDescription (Inherited from System.Windows.Forms.Control) | Gets or sets the default action description of the control for use by accessibility client applications.
Public Property AccessibleDescription (Inherited from System.Windows.Forms.Control) | Gets or sets the description of the control used by accessibility client applications.
Public Property AccessibleName (Inherited from System.Windows.Forms.Control) | Gets or sets the name of the control used by accessibility client applications.
Public Property AccessibleRole (Inherited from System.Windows.Forms.Control) | Gets or sets the accessible role of the control
Public Property ActiveControl (Inherited from System.Windows.Forms.ContainerControl) | Gets or sets the active control on the container control.
Public Property AllowDrop | This generic control property has been replaced by four new properties specific to ThumbnailXpress2 that allow a finer granularity of control over the types of drag/drop operations the control will allow. The new properties are: IntraComponentThumbnailDragDropEnabled, InterComponentThumbnailDragDropEnabled, EnableAsDragSourceForExternalDragDrop, and EnableAsDropTargetForExternalDragDrop
Public Property Anchor (Inherited from System.Windows.Forms.Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Public Property AutoScaleDimensions (Inherited from System.Windows.Forms.ContainerControl) | Gets or sets the dimensions that the control was designed to.
Public Property AutoScaleMode (Inherited from System.Windows.Forms.ContainerControl) | Gets or sets the automatic scaling mode of the control.
Public Property AutoScroll (Inherited from System.Windows.Forms.ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
Public Property AutoScrollMargin (Inherited from System.Windows.Forms.ScrollableControl) | Gets or sets the size of the auto-scroll margin.
Public Property AutoScrollMinSize (Inherited from System.Windows.Forms.ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
Public Property AutoScrollOffset (Inherited from System.Windows.Forms.Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
Public Property AutoScrollPosition (Inherited from System.Windows.Forms.ScrollableControl) | Gets or sets the location of the auto-scroll position.
Public Property AutoSize (Inherited from System.Windows.Forms.UserControl) |
Public Property AutoSizeMode (Inherited from System.Windows.Forms.UserControl) | Gets or sets how the control will resize itself.
Public Property AutoValidate (Inherited from System.Windows.Forms.UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
Public Property BackColor | Overridden. Gets and sets the controls unselected items cell background color.
Public Property BackgroundImage (Inherited from System.Windows.Forms.Control) | Gets or sets the background image displayed in the control.
Public Property BackgroundImageLayout (Inherited from System.Windows.Forms.Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
Public Property BindingContext (Inherited from System.Windows.Forms.ContainerControl) |
Public Property BorderStyle | Gets and sets the control's border style.
Public Property Bottom (Inherited from System.Windows.Forms.Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Public Property BottomMargin | Gets and sets the margin on the bottom most side of the control.
Public Property Bounds (Inherited from System.Windows.Forms.Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
Public Property CameraRaw | Gets and sets enabling or disabling of the camera raw image type detection algorithms during thumbnail image generation.
Public Property CanFocus (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control can receive focus.
Public Property CanSelect (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control can be selected.
Public Property Capture (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether the control has captured the mouse.
Public Property CausesValidation (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
Public Property CellBorderColor | Gets and sets the border color of the cells in the control.
Public Property CellBorderWidth | Gets and sets the width of the cells in the control.
Public Property CellHeight | Gets and sets the height of the cells in the control.
Public Property CellHorizontalSpacing | Gets and sets the spacing between columns.
Public Property CellSpacingColor | Gets and sets the controls cell spacing color.
Public Property CellVerticalSpacing | Gets and sets the spacing between the rows in the control.
Public Property CellWidth | Gets and sets the width of the cells in the control.
Public Property ClientRectangle (Inherited from System.Windows.Forms.Control) | Gets the rectangle that represents the client area of the control.
Public Property ClientSize (Inherited from System.Windows.Forms.Control) | Gets or sets the height and width of the client area of the control.
Public Property CompanyName (Inherited from System.Windows.Forms.Control) | Gets the name of the company or creator of the application containing the control.
Public Property Container (Inherited from System.ComponentModel.Component) | Gets the IContainer that contains the Component.
Public Property ContainsFocus (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
Public Property ContextMenu (Inherited from System.Windows.Forms.Control) | Gets or sets the shortcut menu associated with the control.
Public Property ContextMenuStrip (Inherited from System.Windows.Forms.Control) | Gets or sets the ContextMenuStrip associated with this control.
Public Property Controls (Inherited from System.Windows.Forms.Control) | Gets the collection of controls contained within the control.
Public Property Created (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control has been created.
Public Property CurrentAutoScaleDimensions (Inherited from System.Windows.Forms.ContainerControl) | Gets the current run-time dimensions of the screen.
Public Property Cursor (Inherited from System.Windows.Forms.Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Public Property DataBindings (Inherited from System.Windows.Forms.Control) | Gets the data bindings for the control.
Public Property DblClickDirectoryDrillDown | Gets and sets enabling or disabling directory navigation initiated by double-clicking on directory place holder thumbnail images.
Public Property Debug | Gets and sets the on/off state of the logging system.
Public Property DebugErrorLevel | Gets and sets the level of detail written to the error log.
Public Property DebugLogFile | Gets and sets the log file location.
Public Property DescriptorAlignment | Gets and sets the alignment of the descriptor text.
Public Property DescriptorDisplayMethod | Gets and sets the method allowing selection of the source of the descriptor text content.
Public Property DisplayRectangle | Overridden. Gets the current area being displayed.
Public Property Disposing (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Public Property Dock (Inherited from System.Windows.Forms.Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
Public Property EnableAsDragSourceForExternalDragDrop | Gets and sets enabling or disabling the component acting as a drag source for dragging thumbnail images to other applications. Any application that supports acting as a drop target for the CF_DIB clipboard/drag-drop format can be a thumnbnail image drop recipient.
Public Property EnableAsDropTargetForExternalDragDrop | Gets and sets enabling or disabling the component acting as a drop target for other applications to drag files onto the component to display those files as thumbnail images.
Public Property Enabled (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Public Property ErrorAction |
Public Property ErrorLevel | Gets and sets the level of detail written to the error log.
Public Property Filters | Gets the FilterCollection object to access a collection of filters.
Public Property Focused (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control has input focus.
Public Property Font | Overridden. Gets and sets the thumbnail descriptor font.
Public Property ForeColor | Overridden. Gets and sets the controls foreground color.
Public Property FtpPassword | Gets and sets the FTP password.
Public Property FtpUserName | Gets and sets the FTP user name.
Public Property Handle (Inherited from System.Windows.Forms.Control) | Gets the window handle that the control is bound to.
Public Property HasChildren (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control contains one or more child controls.
Public Property Height (Inherited from System.Windows.Forms.Control) | Gets or sets the height of the control.
Public Property HorizontalScroll (Inherited from System.Windows.Forms.ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Public Property ImeMode (Inherited from System.Windows.Forms.Control) | Gets or sets the Input Method Editor (IME) mode of the control.
Public Property InterComponentThumbnailDragDropEnabled | Gets and sets enabling or disabling the component acting as a drag source or drop target for thumbnail image drag and drop operations between other instances of the ThumbnailXpress component.
Public Property IntraComponentThumbnailDragDropEnabled | Gets and sets enabling or disabling support of drag and drop move operations amongst thumbnail images in the same instance of a ThumbnailXpress component.
Public Property InvokeRequired (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
Public Property IsAccessible (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
Public Property IsDisposed (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control has been disposed of.
Public Property IsHandleCreated (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control has a handle associated with it.
Public Property IsMirrored (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control is mirrored.
Public Property Items | Gets the ThumbnailItemCollection object to access a collection of thumbnail items.
Public Property LayoutEngine (Inherited from System.Windows.Forms.Control) | Gets a cached instance of the control's layout engine.
Public Property Left (Inherited from System.Windows.Forms.Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Public Property LeftMargin | Gets and sets the margin on the left most side of the control.
Public Property Licensing | Gets the Licensing object to allow user to license ThumbnailXpress.
Public Property Location (Inherited from System.Windows.Forms.Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Public Property Margin (Inherited from System.Windows.Forms.Control) | Gets or sets the space between controls.
Public Property MaximumSize (Inherited from System.Windows.Forms.Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
Public Property MaximumThreadCount | Gets and sets the maximum number of concurrent worker threads allowed for thumbnail bitmap generation.
Public Property MaximumThumbnailBitDepth | Gets and sets the maximum bit-depth allowed for the thumbnails.
Public Property MinimumSize (Inherited from System.Windows.Forms.Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Public Property Name (Inherited from System.Windows.Forms.Control) | Gets or sets the name of the control.
Public Property Padding (Inherited from System.Windows.Forms.Control) | Gets or sets padding within the control.
Public Property Parent (Inherited from System.Windows.Forms.Control) | Gets or sets the parent container of the control.
Public Property ParentForm (Inherited from System.Windows.Forms.ContainerControl) | Gets the form that the container control is assigned to.
Public Property PreferredSize (Inherited from System.Windows.Forms.Control) | Gets the size of a rectangular area into which the control can fit.
Public Property PreserveBlack | Gets and sets enabling or disabling the PreserveBlack algorithms during thumbnail image generation.
Public Property ProductName (Inherited from System.Windows.Forms.Control) | Gets the product name of the assembly containing the control.
Public Property ProductVersion (Inherited from System.Windows.Forms.Control) | Gets the version of the assembly containing the control.
Public Property ProxyServer | Gets and sets the name or IP address of an optional proxy server.
Public Property RecreatingHandle (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control is currently re-creating its handle.
Public Property Region (Inherited from System.Windows.Forms.Control) | Gets or sets the window region associated with the control.
Public Property Right (Inherited from System.Windows.Forms.Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
Public Property RightMargin | Gets and sets the margin on the right most side of the control.
Public Property RightToLeft (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Public Property ScrollDirection | Gets and sets the current direction of scrolling.
Public Property SelectBackColor | Gets and sets the controls selected items cell background color.
Public Property SelectedItems | Gets the SelectedThumbnailItemCollection object to access a collection of selected thumbnail items.
Public Property SelectionMode | Gets and sets the controls items selection modes.
Public Property ShowHourglass | Gets and sets the displaying of an hourglass cursor when thumbnail images are being loaded from a directory or file.
Public Property ShowImagePlaceholders | Gets and sets the display of a pre-image-generation 'placeholder' icon.
Public Property Site (Inherited from System.Windows.Forms.Control) | Gets or sets the site of the control.
Public Property Size (Inherited from System.Windows.Forms.Control) | Gets or sets the height and width of the control.
Public Property TabIndex (Inherited from System.Windows.Forms.Control) | Gets or sets the tab order of the control within its container.
Public Property TabStop (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Public Property Tag (Inherited from System.Windows.Forms.Control) | Gets or sets the object that contains data about the control.
Public Property TextBackColor | Gets and sets the controls descriptor text background color.
Public Property ThreadHungThreshold | Gets and sets the elapsed time threshold (in milleseconds) beyond which a request to obtain a thumbnail should be abandoned.
Public Property ThreadStartThreshold | Gets and sets the elapsed time threshold (in milleseconds) beyond which a request to obtain a thumbnail should be considered of "extended duration".
Public Property ThumbnailCache | Gets and sets the thumbnail cache object to adjust cache settings.
Public Property Top (Inherited from System.Windows.Forms.Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
Public Property TopLevelControl (Inherited from System.Windows.Forms.Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Public Property TopMargin | Gets and sets the margin on the top most side of the control.
Public Property TopVisibleItem | Gets the thumbnail item of the top-most visible thumbnail item.
Public Property UseWaitCursor (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Public Property VerticalScroll (Inherited from System.Windows.Forms.ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Public Property Visible (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether the control is displayed.
Public Property VisibleColumnCount | Gets the number of visible thumbnail columns.
Public Property VisibleRowCount | Gets the number of visible thumbnail rows.
Public Property Width (Inherited from System.Windows.Forms.Control) | Gets or sets the width of the control.

Public Methods

Public Method AboutBox | Displays an AboutBox showing general information about this component.
Public Method BeginInvoke (Inherited from System.Windows.Forms.Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
Public Method BeginUpdate | This method disables control repainting.
Public Method BringToFront (Inherited from System.Windows.Forms.Control) | Brings the control to the front of the z-order.
Public Method Cancel | Cancels all pending thumbnail item image generation requests.
Public Method Contains (Inherited from System.Windows.Forms.Control) | Retrieves a value indicating whether the specified control is a child of the control.
Public Method CreateControl (Inherited from System.Windows.Forms.Control) | Forces the creation of the control, including the creation of the handle and any child controls.
Public Method CreateFilter | This is the method that a user would use to create a new uninitialized filter.
Public Method CreateGraphics (Inherited from System.Windows.Forms.Control) | Creates the Graphics for the control.
Public Method CreateObjRef (Inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Public Method CreateThumbnailItem | Creates a thumbnail and adds it to the collection of thumbnail items.
Public Method Dispose (Inherited from System.ComponentModel.Component) | Releases all resources used by the Component.
Public Method DoDragDrop (Inherited from System.Windows.Forms.Control) | Begins a drag-and-drop operation.
Public Method DrawToBitmap (Inherited from System.Windows.Forms.Control) | Supports rendering to the specified bitmap.
Public Method EndInvoke (Inherited from System.Windows.Forms.Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Public Method EndUpdate | Enables control repainting and is used in conjunction with the BeginUpdate method.
Public Method EnsureVisible | Adjusts the display so that the thumbnail of the given index is visible.
Public Method FindForm (Inherited from System.Windows.Forms.Control) | Retrieves the form that the control is on.
Public Method Focus (Inherited from System.Windows.Forms.Control) | Sets input focus to the control.
Public Method GetChildAtPoint (Inherited from System.Windows.Forms.Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
Public Method GetContainerControl (Inherited from System.Windows.Forms.Control) | Returns the next ContainerControl up the control's chain of parent controls.
Public Method GetItemFromPoint | Overloaded. Returns the thumbnail item containing the window point provided.
Public Method GetItemRectangle | Returns the rectangle of the Thumbnail identified by the provided index.
Public Method GetLifetimeService (Inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Public Method GetNextControl (Inherited from System.Windows.Forms.Control) | Retrieves the next control forward or back in the tab order of child controls.
Public Method GetPreferredSize (Inherited from System.Windows.Forms.Control) | Retrieves the size of a rectangular area into which a control can be fitted.
Public Method Hide (Inherited from System.Windows.Forms.Control) | Conceals the control from the user.
Public Method InitializeLifetimeService (Inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Public Method Invalidate (Inherited from System.Windows.Forms.Control) | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn.
Public Method Invoke (Inherited from System.Windows.Forms.Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
Public Method PerformAutoScale (Inherited from System.Windows.Forms.ContainerControl) | Performs scaling of the container control and its children.
Public Method PerformLayout (Inherited from System.Windows.Forms.Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
Public Method PointToClient (Inherited from System.Windows.Forms.Control) | Computes the location of the specified screen point into client coordinates.
Public Method PointToScreen (Inherited from System.Windows.Forms.Control) | Computes the location of the specified client point into screen coordinates.
Public Method PostInitialize | This function is Obsolete, there is no value of calling it. This will be removed in ThumbnailXpress v3.
Public Method PreProcessControlMessage (Inherited from System.Windows.Forms.Control) |
Public Method PreProcessMessage (Inherited from System.Windows.Forms.Control) |
Public Method RectangleToClient (Inherited from System.Windows.Forms.Control) | Computes the size and location of the specified screen rectangle in client coordinates.
Public Method RectangleToScreen (Inherited from System.Windows.Forms.Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Public Method Refresh (Inherited from System.Windows.Forms.Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
Public Method ResetAllCanceledItems | Resets the status for all items in the thumbnail collection whose image generation requests were canceled by the user.
Public Method ResetCanceledItem | Resets the status for an item in the thumbnail collection whose image generation request was canceled by the user.
Public Method ResetText (Inherited from System.Windows.Forms.Control) | Resets the Text property to its default value.
Public Method ResumeLayout (Inherited from System.Windows.Forms.Control) | Overloaded. Resumes usual layout logic.
Public Method ScrollControlIntoView (Inherited from System.Windows.Forms.ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Public Method ScrollItems | Provides programmatic scrolling of the display.
Public Method Select (Inherited from System.Windows.Forms.Control) | Activates the control.
Public Method SelectNextControl (Inherited from System.Windows.Forms.Control) | Activates the next control.
Public Method SendToBack (Inherited from System.Windows.Forms.Control) | Sends the control to the back of the z-order.
Public Method SetAutoScrollMargin (Inherited from System.Windows.Forms.ScrollableControl) | Sets the size of the auto-scroll margins.
Public Method SetBounds (Inherited from System.Windows.Forms.Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Public Method Show (Inherited from System.Windows.Forms.Control) | Displays the control to the user.
Public Method ShowScrollBar | Shows or hides the scrollbar.
Public Method SuspendLayout (Inherited from System.Windows.Forms.Control) | Temporarily suspends the layout logic for the control.
Public Method ToString (Inherited from System.ComponentModel.Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Public Method Update (Inherited from System.Windows.Forms.Control) | Causes the control to redraw the invalidated regions within its client area.
Public Method Validate (Inherited from System.Windows.Forms.ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
Public Method ValidateChildren (Inherited from System.Windows.Forms.UserControl) | Overloaded.

Public Events

Public Event AutoSizeChanged (Inherited from System.Windows.Forms.UserControl) |
Public Event AutoValidateChanged (Inherited from System.Windows.Forms.UserControl) | Occurs when the AutoValidate property changes.
Public Event BackColorChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the BackColor property changes.
Public Event BackgroundImageChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the BackgroundImage property changes.
Public Event BackgroundImageLayoutChanged (Inherited from System.Windows.Forms.Control) | Occurs when the BackgroundImageLayout property changes.
Public Event BindingContextChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the BindingContext property changes.
Public Event CausesValidationChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the CausesValidation property changes.
Public Event ChangeUICues (Inherited from System.Windows.Forms.Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Public Event Click (Inherited from System.Windows.Forms.Control) | Occurs when the control is clicked.
Public Event ClientSizeChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the ClientSize property changes.
Public Event ContextMenuChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the ContextMenu property changes.
Public Event ContextMenuStripChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the ContextMenuStrip property changes.
Public Event ControlAdded (Inherited from System.Windows.Forms.Control) | Occurs when a new control is added to the ControlCollection.
Public Event ControlRemoved (Inherited from System.Windows.Forms.Control) | Occurs when a control is removed from the ControlCollection.
Public Event CursorChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the Cursor property changes.
Public Event Disposed (Inherited from System.ComponentModel.Component) | Adds an event handler to listen to the Disposed event on the component.
Public Event DockChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the Dock property changes.
Public Event DoubleClick (Inherited from System.Windows.Forms.Control) | Occurs when the control is double-clicked.
Public Event DragDrop (Inherited from System.Windows.Forms.Control) | Occurs when a drag-and-drop operation is completed.
Public Event DragEnter (Inherited from System.Windows.Forms.Control) | Occurs when an object is dragged into the control's bounds.
Public Event DragLeave (Inherited from System.Windows.Forms.Control) | Occurs when an object is dragged out of the control's bounds.
Public Event DragOver (Inherited from System.Windows.Forms.Control) | Occurs when an object is dragged over the control's bounds.
Public Event EnabledChanged (Inherited from System.Windows.Forms.Control) | Occurs when the Enabled property value has changed.
Public Event Enter (Inherited from System.Windows.Forms.Control) | Occurs when the control is entered.
Public Event Error | Event which is called when an error occurs during generation or painting of a thumbnail item.
Public Event FontChanged (Inherited from System.Windows.Forms.Control) | Occurs when the Font property value changes.
Public Event ForeColorChanged (Inherited from System.Windows.Forms.Control) | Occurs when the ForeColor property value changes.
Public Event GiveFeedback (Inherited from System.Windows.Forms.Control) | Occurs during a drag operation.
Public Event GotFocus (Inherited from System.Windows.Forms.Control) | Occurs when the control receives focus.
Public Event HandleCreated (Inherited from System.Windows.Forms.Control) | Occurs when a handle is created for the control.
Public Event HandleDestroyed (Inherited from System.Windows.Forms.Control) | Occurs when the control's handle is in the process of being destroyed.
Public Event HelpRequested (Inherited from System.Windows.Forms.Control) | Occurs when the user requests help for a control.
Public Event ImeModeChanged (Inherited from System.Windows.Forms.Control) | Occurs when the ImeMode property has changed.
Public Event Invalidated (Inherited from System.Windows.Forms.Control) | Occurs when a control's display requires redrawing.
Public Event ItemComplete | Event which is called when a thumbnail item's asynchronous image generation has been completed. Review the the thumbnail item collection information about how thumbnail items are added to the collection, where the items are generated asynchronously.
Public Event KeyDown (Inherited from System.Windows.Forms.Control) | Occurs when a key is pressed while the control has focus.
Public Event KeyPress (Inherited from System.Windows.Forms.Control) | Occurs when a key is pressed while the control has focus.
Public Event KeyUp (Inherited from System.Windows.Forms.Control) | Occurs when a key is released while the control has focus.
Public Event Layout (Inherited from System.Windows.Forms.Control) | Occurs when a control should reposition its child controls.
Public Event Leave (Inherited from System.Windows.Forms.Control) | Occurs when the input focus leaves the control.
Public Event Load (Inherited from System.Windows.Forms.UserControl) | Occurs before the control becomes visible for the first time.
Public Event LoadFromStream | This event is called when the component requires the application to provide a Stream object containing image data for a thumbnail item.
Public Event LocationChanged (Inherited from System.Windows.Forms.Control) | Occurs when the Location property value has changed.
Public Event LostFocus (Inherited from System.Windows.Forms.Control) | Occurs when the control loses focus.
Public Event MarginChanged (Inherited from System.Windows.Forms.Control) | Occurs when the control's margin changes.
Public Event MouseCaptureChanged (Inherited from System.Windows.Forms.Control) | Occurs when the control loses mouse capture.
Public Event MouseClick (Inherited from System.Windows.Forms.Control) | Occurs when the control is clicked by the mouse.
Public Event MouseDoubleClick (Inherited from System.Windows.Forms.Control) | Occurs when the control is double clicked by the mouse.
Public Event MouseDown (Inherited from System.Windows.Forms.Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
Public Event MouseEnter (Inherited from System.Windows.Forms.Control) | Occurs when the mouse pointer enters the control.
Public Event MouseHover (Inherited from System.Windows.Forms.Control) | Occurs when the mouse pointer rests on the control.
Public Event MouseLeave (Inherited from System.Windows.Forms.Control) | Occurs when the mouse pointer leaves the control.
Public Event MouseMove (Inherited from System.Windows.Forms.Control) | Occurs when the mouse pointer is moved over the control.
Public Event MouseUp (Inherited from System.Windows.Forms.Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Public Event MouseWheel (Inherited from System.Windows.Forms.Control) | Occurs when the mouse wheel moves while the control has focus.
Public Event Move (Inherited from System.Windows.Forms.Control) | Occurs when the control is moved.
Public Event PaddingChanged (Inherited from System.Windows.Forms.Control) | Occurs when the control's padding changes.
Public Event Paint (Inherited from System.Windows.Forms.Control) | Occurs when the control is redrawn.
Public Event ParentChanged (Inherited from System.Windows.Forms.Control) | Occurs when the Parent property value changes.
Public Event PreviewKeyDown (Inherited from System.Windows.Forms.Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
Public Event QueryAccessibilityHelp (Inherited from System.Windows.Forms.Control) | Occurs when AccessibleObject is providing help to accessibility applications.
Public Event QueryContinueDrag (Inherited from System.Windows.Forms.Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
Public Event RegionChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the Region property changes.
Public Event Resize (Inherited from System.Windows.Forms.Control) | Occurs when the control is resized.
Public Event RightToLeftChanged (Inherited from System.Windows.Forms.Control) | Occurs when the RightToLeft property value changes.
Public Event Scroll (Inherited from System.Windows.Forms.ScrollableControl) | Occurs when the user or code scrolls through the client area.
Public Event SelectedIndexChanged | Event which is called when a thumbnail item is selected using the user interface.
Public Event SizeChanged (Inherited from System.Windows.Forms.Control) | Occurs when the Size property value changes.
Public Event StyleChanged (Inherited from System.Windows.Forms.Control) | Occurs when the control style changes.
Public Event SystemColorsChanged (Inherited from System.Windows.Forms.Control) | Occurs when the system colors change.
Public Event TabIndexChanged (Inherited from System.Windows.Forms.Control) | Occurs when the TabIndex property value changes.
Public Event TabStopChanged (Inherited from System.Windows.Forms.Control) | Occurs when the TabStop property value changes.
Public Event Validated (Inherited from System.Windows.Forms.Control) | Occurs when the control is finished validating.
Public Event Validating (Inherited from System.Windows.Forms.Control) | Occurs when the control is validating.
Public Event VisibleChanged (Inherited from System.Windows.Forms.Control) | Occurs when the Visible property value changes.

See Also

ThumbnailXpress Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ThumbnailXpress Constructor

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailXpress Constructor

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : ThumbnailXpress Constructor (ThumbnailXpress)

The main ThumbnailXpress constructor.

[Visual Basic]
Public Function New()
[C#]
public ThumbnailXpress();
[C++]
public: ThumbnailXpress();
[C++/CLI]
public:
ThumbnailXpress();

Remarks

Keep in mind that there can be multiple ThumbnailXpress controls instantiated in one AppDomain/Process-space. The controls can be on the same or different threads.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


AboutBox Method

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

AboutBox Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : AboutBox Method

Displays an AboutBox showing general information about this component.

[Visual Basic]
Public Sub AboutBox()
[C#]
public void AboutBox();
[C++]
public: void AboutBox();
[C++/CLI]
public:
void AboutBox();

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


BeginUpdate Method

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

BeginUpdate Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : BeginUpdate Method

This method disables control repainting.

[Visual Basic]
Public Sub BeginUpdate()
[C#]
public void BeginUpdate();
[C++]
public: void BeginUpdate();
[C++/CLI]
public:
void BeginUpdate();

Remarks

Call this method before adding multiple items to the list to reduce redraw flicker. Call the EndUpdate method to enable repainting after the items have been added.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


Cancel Method

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Cancel Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : Cancel Method

Cancels all pending thumbnail item image generation requests.

[Visual Basic]
Public Sub Cancel()
[C#]
public void Cancel();
[C++]
public: void Cancel();
[C++/CLI]
public:
void Cancel();

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


CreateFilter Method

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

name
A string value that represents the name of the filter.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

CreateFilter Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : CreateFilter Method

This is the method that a user would use to create a new uninitialized filter.

[Visual Basic]
Public Function CreateFilter( _
   ByVal name As String _
) As Filter
[C#]
public Filter CreateFilter(
   string name
);
[C++]
public: Filter* CreateFilter(
   string* name
)
[C++/CLI]
public:
Filter^ CreateFilter(
   String^ name
)

Parameters

name
A string value that represents the name of the filter.

Return Type

A Filter created.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


CreateThumbnailItem Method

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

filename
A string value which represents the file containing the thumbnail.
pageNumber
An integer value which represents the page in the image file for the current thumbnail.
type
A ThumbnailType which represents the type of thumbnail. If a parent or sub directory is specified, the PageNumber parameter is ignored and the Filename parameter should contain the directory path.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

CreateThumbnailItem Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : CreateThumbnailItem Method

Creates a thumbnail and adds it to the collection of thumbnail items.

[Visual Basic]
Public Function CreateThumbnailItem( _
   ByVal filename As String, _
   ByVal pageNumber As Integer, _
   ByVal type As ThumbnailType _
) As ThumbnailItem
[C#]
public ThumbnailItem CreateThumbnailItem(
   string filename,
   int pageNumber,
   ThumbnailType type
);
[C++]
public: ThumbnailItem* CreateThumbnailItem(
   string* filename,
   int pageNumber,
   ThumbnailType type
)
[C++/CLI]
public:
ThumbnailItem^ CreateThumbnailItem(
   String^ filename,
   int pageNumber,
   ThumbnailType type
)

Parameters

filename
A string value which represents the file containing the thumbnail.
pageNumber
An integer value which represents the page in the image file for the current thumbnail.
type
A ThumbnailType which represents the type of thumbnail. If a parent or sub directory is specified, the PageNumber parameter is ignored and the Filename parameter should contain the directory path.

Return Type

The created thumbnail item.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


EndUpdate Method

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

EndUpdate Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : EndUpdate Method

Enables control repainting and is used in conjunction with the BeginUpdate method.

[Visual Basic]
Public Sub EndUpdate()
[C#]
public void EndUpdate();
[C++]
public: void EndUpdate();
[C++/CLI]
public:
void EndUpdate();

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


EnsureVisible Method

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
An integer value which represents the zero-based index of the thumbnail the user wants to be visible.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

EnsureVisible Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : EnsureVisible Method

Adjusts the display so that the thumbnail of the given index is visible.

[Visual Basic]
Public Sub EnsureVisible( _
   ByVal index As Integer _
)
[C#]
public void EnsureVisible(
   int index
);
[C++]
public: void EnsureVisible(
   int index
)
[C++/CLI]
public:
void EnsureVisible(
   int index
)

Parameters

index
An integer value which represents the zero-based index of the thumbnail the user wants to be visible.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


GetItemFromPoint Method

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

GetItemFromPoint Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : GetItemFromPoint Method

Returns the thumbnail item containing the window point provided.

Overload List

Returns the thumbnail item containing the window point provided.

[Visual Basic] Overloads Public Function GetItemFromPoint(Point) As ThumbnailItem

[C#] public ThumbnailItem GetItemFromPoint(Point);

[C++] public ThumbnailItem* GetItemFromPoint(Point);

[C++/CLI] public ThumbnailItem^ GetItemFromPoint(Point);

Returns the thumbnail item containing the window point provided.

[Visual Basic] Overloads Public Function GetItemFromPoint(PointF) As ThumbnailItem

[C#] public ThumbnailItem GetItemFromPoint(PointF);

[C++] public ThumbnailItem* GetItemFromPoint(PointF);

[C++/CLI] public ThumbnailItem^ GetItemFromPoint(PointF);

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


GetItemFromPoint(Point) Method

ThumbnailXpress Class | ThumbnailXpress Members | Overload List

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

point
A Point which represents the location of a point in the control. The point values should be in client coordinates.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

GetItemFromPoint(Point) Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class > GetItemFromPoint Method : GetItemFromPoint(Point) Method

Returns the thumbnail item containing the window point provided.

[Visual Basic]
Overloads Public Function GetItemFromPoint( _
   ByVal point As Point _
) As ThumbnailItem
[C#]
public ThumbnailItem GetItemFromPoint(
   Point point
);
[C++]
public: ThumbnailItem* GetItemFromPoint(
   Point point
)
[C++/CLI]
public:
ThumbnailItem^ GetItemFromPoint(
   Point point
)

Parameters

point
A Point which represents the location of a point in the control. The point values should be in client coordinates.

Return Type

A ThumbnailItem containing the provided point. Returns null if point is not over an image.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members | Overload List


GetItemFromPoint(PointF) Method

ThumbnailXpress Class | ThumbnailXpress Members | Overload List

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

point
A PointF which represents the location of a point in the control. The point values should be in client coordinates.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

GetItemFromPoint(PointF) Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class > GetItemFromPoint Method : GetItemFromPoint(PointF) Method

Returns the thumbnail item containing the window point provided.

[Visual Basic]
Overloads Public Function GetItemFromPoint( _
   ByVal point As PointF _
) As ThumbnailItem
[C#]
public ThumbnailItem GetItemFromPoint(
   PointF point
);
[C++]
public: ThumbnailItem* GetItemFromPoint(
   PointF point
)
[C++/CLI]
public:
ThumbnailItem^ GetItemFromPoint(
   PointF point
)

Parameters

point
A PointF which represents the location of a point in the control. The point values should be in client coordinates.

Return Type

Thumbnail item containing the provided point. Returns null if point is not over an image.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members | Overload List


GetItemRectangle Method

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
An integer value which represents the zero-based index of the thumbnail which displays the rectangle for.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

GetItemRectangle Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : GetItemRectangle Method

Returns the rectangle of the Thumbnail identified by the provided index.

[Visual Basic]
Public Function GetItemRectangle( _
   ByVal index As Integer _
) As Rectangle
[C#]
public Rectangle GetItemRectangle(
   int index
);
[C++]
public: Rectangle GetItemRectangle(
   int index
)
[C++/CLI]
public:
Rectangle GetItemRectangle(
   int index
)

Parameters

index
An integer value which represents the zero-based index of the thumbnail which displays the rectangle for.

Return Type

A Rectangle for the thumbnail identified by the given index.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


PostInitialize Method

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

PostInitialize Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : PostInitialize Method

This function is Obsolete, there is no value of calling it. This will be removed in ThumbnailXpress v3.

[Visual Basic]
<ObsoleteAttribute("This function will be removed in ThumbnailXpress v3")>
Public Sub PostInitialize()
[C#]
[ObsoleteAttribute("This function will be removed in ThumbnailXpress v3")]
public void PostInitialize();
[C++]
[ObsoleteAttribute("This function will be removed in ThumbnailXpress v3")]
public: void PostInitialize();
[C++/CLI]
[ObsoleteAttribute("This function will be removed in ThumbnailXpress v3")]
public:
void PostInitialize();

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


ResetAllCanceledItems Method

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ResetAllCanceledItems Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : ResetAllCanceledItems Method

Resets the status for all items in the thumbnail collection whose image generation requests were canceled by the user.

[Visual Basic]
Public Sub ResetAllCanceledItems()
[C#]
public void ResetAllCanceledItems();
[C++]
public: void ResetAllCanceledItems();
[C++/CLI]
public:
void ResetAllCanceledItems();

Remarks

This allows those items images to again be attempted to be generated.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


ResetCanceledItem Method

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

item
A ThumbnailItem which represents the item.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ResetCanceledItem Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : ResetCanceledItem Method

Resets the status for an item in the thumbnail collection whose image generation request was canceled by the user.

[Visual Basic]
Public Sub ResetCanceledItem( _
   ByVal item As ThumbnailItem _
)
[C#]
public void ResetCanceledItem(
   ThumbnailItem item
);
[C++]
public: void ResetCanceledItem(
   ThumbnailItem* item
)
[C++/CLI]
public:
void ResetCanceledItem(
   ThumbnailItem^ item
)

Parameters

item
A ThumbnailItem which represents the item.

Remarks

This allows the item image to again be attempted to be generated.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


ScrollItems Method

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

scrollType
Specifies the incremental amount or whether a positional scroll operation is desired.
value
If ScrollType is equal to ThumbPosition, value specifies a thumb position to be scrolled to. If ScrollType is equal to ItemIndex, value specifies item index to be scrolled to.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ScrollItems Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : ScrollItems Method

Provides programmatic scrolling of the display.

[Visual Basic]
Public Sub ScrollItems( _
   ByVal scrollType As ScrollItemsType, _
   ByVal value As Integer _
)
[C#]
public void ScrollItems(
   ScrollItemsType scrollType,
   int value
);
[C++]
public: void ScrollItems(
   ScrollItemsType scrollType,
   int value
)
[C++/CLI]
public:
void ScrollItems(
   ScrollItemsType scrollType,
   int value
)

Parameters

scrollType
Specifies the incremental amount or whether a positional scroll operation is desired.
value
If ScrollType is equal to ThumbPosition, value specifies a thumb position to be scrolled to. If ScrollType is equal to ItemIndex, value specifies item index to be scrolled to.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


ShowScrollBar Method

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

bShow
A boolean value which is true to show or hide the scrollbar. Otherwise, false is used.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ShowScrollBar Method

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : ShowScrollBar Method

Shows or hides the scrollbar.

[Visual Basic]
Public Sub ShowScrollBar( _
   ByVal bShow As Boolean _
)
[C#]
public void ShowScrollBar(
   bool bShow
);
[C++]
public: void ShowScrollBar(
   bool bShow
)
[C++/CLI]
public:
void ShowScrollBar(
   bool bShow
)

Parameters

bShow
A boolean value which is true to show or hide the scrollbar. Otherwise, false is used.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


AllowDrop Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

AllowDrop Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : AllowDrop Property

This generic control property has been replaced by four new properties specific to ThumbnailXpress2 that allow a finer granularity of control over the types of drag/drop operations the control will allow. The new properties are: IntraComponentThumbnailDragDropEnabled, InterComponentThumbnailDragDropEnabled, EnableAsDragSourceForExternalDragDrop, and EnableAsDropTargetForExternalDragDrop

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property AllowDrop As Boolean
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public bool AllowDrop {get; set;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property bool get_AllowDrop();
public: __property void set_AllowDrop(
   bool value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property bool AllowDrop {
   bool get();
   void set (bool value);
}

Return Type

true if drag-and-drop operations are allowed in the control; otherwise, false. The default is false.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


BackColor Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

BackColor Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : BackColor Property

Gets and sets the controls unselected items cell background color.

[Visual Basic]
<BrowsableAttribute(True)>
<DescriptionAttribute("Inidciates the controls unselected items cell background color")>
<CategoryAttribute("ThumbnailXpress")>
Overrides Public Property BackColor As Color
[C#]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the controls unselected items cell background color")]
[CategoryAttribute("ThumbnailXpress")]
public override Color BackColor {get; set;}
[C++]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the controls unselected items cell background color")]
[CategoryAttribute("ThumbnailXpress")]
public: __property Color get_BackColor()override ;
public: __property void set_BackColor(
   Color value
)override ;
[C++/CLI]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the controls unselected items cell background color")]
[CategoryAttribute("ThumbnailXpress")]
public:
property Color BackColor override {
   Color get();
   void set (Color value);
}

Return Type

The Color value.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


BorderStyle Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

BorderStyle Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : BorderStyle Property

Gets and sets the control's border style.

[Visual Basic]
<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
<DescriptionAttribute("Inidciates whether controls should have a border.")>
Public Property BorderStyle As BorderStyle
[C#]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates whether controls should have a border.")]
public BorderStyle BorderStyle {get; set;}
[C++]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates whether controls should have a border.")]
public: __property BorderStyle get_BorderStyle();
public: __property void set_BorderStyle(
   BorderStyle value
);
[C++/CLI]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates whether controls should have a border.")]
public:
property BorderStyle BorderStyle {
   BorderStyle get();
   void set (BorderStyle value);
}

Return Type

The border style

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


BottomMargin Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

BottomMargin Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : BottomMargin Property

Gets and sets the margin on the bottom most side of the control.

[Visual Basic]
<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
<DescriptionAttribute("Inidciates the margin on the bottom most side of the control.")>
Public Property BottomMargin As Integer
[C#]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the margin on the bottom most side of the control.")]
public int BottomMargin {get; set;}
[C++]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the margin on the bottom most side of the control.")]
public: __property int get_BottomMargin();
public: __property void set_BottomMargin(
   int value
);
[C++/CLI]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the margin on the bottom most side of the control.")]
public:
property int BottomMargin {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the bottom margin.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


CameraRaw Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

CameraRaw Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : CameraRaw Property

Gets and sets enabling or disabling of the camera raw image type detection algorithms during thumbnail image generation.

[Visual Basic]
<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
<DescriptionAttribute("Inidciates digital camera manufacturer proprietary raw image formats detection.")>
Public Property CameraRaw As Boolean
[C#]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates digital camera manufacturer proprietary raw image formats detection.")]
public bool CameraRaw {get; set;}
[C++]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates digital camera manufacturer proprietary raw image formats detection.")]
public: __property bool get_CameraRaw();
public: __property void set_CameraRaw(
   bool value
);
[C++/CLI]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates digital camera manufacturer proprietary raw image formats detection.")]
public:
property bool CameraRaw {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is trueto enable camera raw support. Otherwise, false is used and camera raw is not supported.

Remarks

Note: Setting this to true will slow down thumbnail generation.

Enabling CameraRaw invokes digital camera manufacturer proprietary raw image formats detection algorithms during thumnbnail image generation but at the cost of some speed.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


CellBorderColor Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

CellBorderColor Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : CellBorderColor Property

Gets and sets the border color of the cells in the control.

[Visual Basic]
<BrowsableAttribute(True)>
<CategoryAttribute("ThumbnailXpress")>
<DescriptionAttribute("Inidciates the border color of the cells in the control.")>
Public Property CellBorderColor As Color
[C#]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the border color of the cells in the control.")]
public Color CellBorderColor {get; set;}
[C++]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the border color of the cells in the control.")]
public: __property Color get_CellBorderColor();
public: __property void set_CellBorderColor(
   Color value
);
[C++/CLI]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the border color of the cells in the control.")]
public:
property Color CellBorderColor {
   Color get();
   void set (Color value);
}

Return Type

A Color value which represents the border color of the cells.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


CellBorderWidth Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

CellBorderWidth Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : CellBorderWidth Property

Gets and sets the width of the cells in the control.

[Visual Basic]
<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
<DescriptionAttribute("Inidciates the width of the cells in the control.")>
Public Property CellBorderWidth As Integer
[C#]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the width of the cells in the control.")]
public int CellBorderWidth {get; set;}
[C++]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the width of the cells in the control.")]
public: __property int get_CellBorderWidth();
public: __property void set_CellBorderWidth(
   int value
);
[C++/CLI]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the width of the cells in the control.")]
public:
property int CellBorderWidth {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the cell border width.

Remarks

The default value is 0.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


CellHeight Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

CellHeight Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : CellHeight Property

Gets and sets the height of the cells in the control.

[Visual Basic]
<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
<DescriptionAttribute("Inidciates the height of the cells in the control.")>
Public Property CellHeight As Integer
[C#]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the height of the cells in the control.")]
public int CellHeight {get; set;}
[C++]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the height of the cells in the control.")]
public: __property int get_CellHeight();
public: __property void set_CellHeight(
   int value
);
[C++/CLI]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the height of the cells in the control.")]
public:
property int CellHeight {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the cell height.

Remarks

The default valueis 0.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


CellHorizontalSpacing Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

CellHorizontalSpacing Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : CellHorizontalSpacing Property

Gets and sets the spacing between columns.

[Visual Basic]
<BrowsableAttribute(True)>
<CategoryAttribute("ThumbnailXpress")>
<DescriptionAttribute("Inidciates the spacing between columns in the control.")>
Public Property CellHorizontalSpacing As Integer
[C#]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the spacing between columns in the control.")]
public int CellHorizontalSpacing {get; set;}
[C++]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the spacing between columns in the control.")]
public: __property int get_CellHorizontalSpacing();
public: __property void set_CellHorizontalSpacing(
   int value
);
[C++/CLI]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the spacing between columns in the control.")]
public:
property int CellHorizontalSpacing {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the cell horizontal spacing between columns.

Remarks

The default value is 0.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


CellSpacingColor Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

CellSpacingColor Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : CellSpacingColor Property

Gets and sets the controls cell spacing color.

[Visual Basic]
<BrowsableAttribute(True)>
<CategoryAttribute("ThumbnailXpress")>
<DescriptionAttribute("Inidciates the controls controls cell spacing color.")>
Public Property CellSpacingColor As Color
[C#]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the controls controls cell spacing color.")]
public Color CellSpacingColor {get; set;}
[C++]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the controls controls cell spacing color.")]
public: __property Color get_CellSpacingColor();
public: __property void set_CellSpacingColor(
   Color value
);
[C++/CLI]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the controls controls cell spacing color.")]
public:
property Color CellSpacingColor {
   Color get();
   void set (Color value);
}

Return Type

The Color value.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


CellVerticalSpacing Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

CellVerticalSpacing Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : CellVerticalSpacing Property

Gets and sets the spacing between the rows in the control.

[Visual Basic]
<BrowsableAttribute(True)>
<CategoryAttribute("ThumbnailXpress")>
<DescriptionAttribute("Inidciates the spacing between the rows in the control.")>
Public Property CellVerticalSpacing As Integer
[C#]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the spacing between the rows in the control.")]
public int CellVerticalSpacing {get; set;}
[C++]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the spacing between the rows in the control.")]
public: __property int get_CellVerticalSpacing();
public: __property void set_CellVerticalSpacing(
   int value
);
[C++/CLI]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the spacing between the rows in the control.")]
public:
property int CellVerticalSpacing {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the cell vertical spacing between the rows in the control.

Remarks

The default value is 0.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


CellWidth Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

CellWidth Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : CellWidth Property

Gets and sets the width of the cells in the control.

[Visual Basic]
<CategoryAttribute("ThumbnailXpress")>
<DescriptionAttribute("Inidciates the width of the cells in the control.")>
<BrowsableAttribute(True)>
Public Property CellWidth As Integer
[C#]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the width of the cells in the control.")]
[BrowsableAttribute(true)]
public int CellWidth {get; set;}
[C++]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the width of the cells in the control.")]
[BrowsableAttribute(true)]
public: __property int get_CellWidth();
public: __property void set_CellWidth(
   int value
);
[C++/CLI]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the width of the cells in the control.")]
[BrowsableAttribute(true)]
public:
property int CellWidth {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the cell width.

Remarks

The default value is 0.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


DblClickDirectoryDrillDown Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

DblClickDirectoryDrillDown Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : DblClickDirectoryDrillDown Property

Gets and sets enabling or disabling directory navigation initiated by double-clicking on directory place holder thumbnail images.

[Visual Basic]
<BrowsableAttribute(True)>
<DescriptionAttribute("Inidciates directory navigation initiated by double-clicking on directory place holder thumbnail images.")>
<CategoryAttribute("ThumbnailXpress")>
Public Property DblClickDirectoryDrillDown As Boolean
[C#]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates directory navigation initiated by double-clicking on directory place holder thumbnail images.")]
[CategoryAttribute("ThumbnailXpress")]
public bool DblClickDirectoryDrillDown {get; set;}
[C++]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates directory navigation initiated by double-clicking on directory place holder thumbnail images.")]
[CategoryAttribute("ThumbnailXpress")]
public: __property bool get_DblClickDirectoryDrillDown();
public: __property void set_DblClickDirectoryDrillDown(
   bool value
);
[C++/CLI]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates directory navigation initiated by double-clicking on directory place holder thumbnail images.")]
[CategoryAttribute("ThumbnailXpress")]
public:
property bool DblClickDirectoryDrillDown {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true if double click directory drill down. Otherwise, false is used.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


Debug Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Debug Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : Debug Property

Gets and sets the on/off state of the logging system.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property Debug As Boolean
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public bool Debug {get; set;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property bool get_Debug();
public: __property void set_Debug(
   bool value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property bool Debug {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to turn on the logging system. Otherwise, false is used.

Remarks

The default valueis false.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


DebugErrorLevel Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

DebugErrorLevel Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : DebugErrorLevel Property (ThumbnailXpress)

Gets and sets the level of detail written to the error log.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property DebugErrorLevel As DebugErrorLevel
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public DebugErrorLevel DebugErrorLevel {get; set;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property DebugErrorLevel get_DebugErrorLevel();
public: __property void set_DebugErrorLevel(
   DebugErrorLevel value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property DebugErrorLevel DebugErrorLevel {
   DebugErrorLevel get();
   void set (DebugErrorLevel value);
}

Return Type

A DebugErrorLevel enumeration value which determines the level of error logging to write to the DebugLogFile.

Remarks

The default value is Production.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


DebugLogFile Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

DebugLogFile Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : DebugLogFile Property

Gets and sets the log file location.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property DebugLogFile As String
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public string DebugLogFile {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property string* get_DebugLogFile();
public: __property void set_DebugLogFile(
   string* value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property String^ DebugLogFile {
   String^ get();
   void set (String^ value);
}

Return Type

A string value which represents the directory where the log file is written to.

Remarks

The default value is an empty string "".

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


DescriptorAlignment Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

DescriptorAlignment Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : DescriptorAlignment Property

Gets and sets the alignment of the descriptor text.

[Visual Basic]
<DescriptionAttribute("Inidciates the alignment of the descriptor text.")>
<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
Public Property DescriptorAlignment As DescriptorAlignments
[C#]
[DescriptionAttribute("Inidciates the alignment of the descriptor text.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public DescriptorAlignments DescriptorAlignment {get; set;}
[C++]
[DescriptionAttribute("Inidciates the alignment of the descriptor text.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public: __property DescriptorAlignments get_DescriptorAlignment();
public: __property void set_DescriptorAlignment(
   DescriptorAlignments value
);
[C++/CLI]
[DescriptionAttribute("Inidciates the alignment of the descriptor text.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public:
property DescriptorAlignments DescriptorAlignment {
   DescriptorAlignments get();
   void set (DescriptorAlignments value);
}

Return Type

An DescriptorAlignments enumeration value.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


DescriptorDisplayMethod Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

DescriptorDisplayMethod Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : DescriptorDisplayMethod Property

Gets and sets the method allowing selection of the source of the descriptor text content.

[Visual Basic]
<BrowsableAttribute(True)>
<CategoryAttribute("ThumbnailXpress")>
<DescriptionAttribute("Inidciates the source of the descriptor text content.")>
Public Property DescriptorDisplayMethod As DescriptorDisplayMethods
[C#]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the source of the descriptor text content.")]
public DescriptorDisplayMethods DescriptorDisplayMethod {get; set;}
[C++]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the source of the descriptor text content.")]
public: __property DescriptorDisplayMethods get_DescriptorDisplayMethod();
public: __property void set_DescriptorDisplayMethod(
   DescriptorDisplayMethods value
);
[C++/CLI]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the source of the descriptor text content.")]
public:
property DescriptorDisplayMethods DescriptorDisplayMethod {
   DescriptorDisplayMethods get();
   void set (DescriptorDisplayMethods value);
}

Return Type

The DescriptorDisplayMethods which allow selection of the source of the descriptor text content.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


DisplayRectangle Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

DisplayRectangle Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : DisplayRectangle Property

Gets the current area being displayed.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<EditorBrowsableAttribute()>
Overrides Public ReadOnly Property DisplayRectangle As Rectangle
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute()]
public override Rectangle DisplayRectangle {get;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute()]
public: __property Rectangle get_DisplayRectangle()override ;
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute()]
public:
property Rectangle DisplayRectangle override {
   Rectangle get();
}

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


EnableAsDragSourceForExternalDragDrop Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

EnableAsDragSourceForExternalDragDrop Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : EnableAsDragSourceForExternalDragDrop Property

Gets and sets enabling or disabling the component acting as a drag source for dragging thumbnail images to other applications. Any application that supports acting as a drop target for the CF_DIB clipboard/drag-drop format can be a thumnbnail image drop recipient.

[Visual Basic]
<DescriptionAttribute("Inidciates drag and drop for dragging thumbnail images to other applications.")>
<BrowsableAttribute(True)>
<CategoryAttribute("ThumbnailXpress")>
Public Property EnableAsDragSourceForExternalDragDrop As Boolean
[C#]
[DescriptionAttribute("Inidciates drag and drop for dragging thumbnail images to other applications.")]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
public bool EnableAsDragSourceForExternalDragDrop {get; set;}
[C++]
[DescriptionAttribute("Inidciates drag and drop for dragging thumbnail images to other applications.")]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
public: __property bool get_EnableAsDragSourceForExternalDragDrop();
public: __property void set_EnableAsDragSourceForExternalDragDrop(
   bool value
);
[C++/CLI]
[DescriptionAttribute("Inidciates drag and drop for dragging thumbnail images to other applications.")]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
public:
property bool EnableAsDragSourceForExternalDragDrop {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to support drag and drop as a source. Otherwise, false should be used.

Remarks

Both copy and move operations are supported.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


EnableAsDropTargetForExternalDragDrop Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

EnableAsDropTargetForExternalDragDrop Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : EnableAsDropTargetForExternalDragDrop Property

Gets and sets enabling or disabling the component acting as a drop target for other applications to drag files onto the component to display those files as thumbnail images.

[Visual Basic]
<CategoryAttribute("ThumbnailXpress")>
<DescriptionAttribute("Inidciates drop target for dragging thumbnail images to other applications.")>
<BrowsableAttribute(True)>
Public Property EnableAsDropTargetForExternalDragDrop As Boolean
[C#]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates drop target for dragging thumbnail images to other applications.")]
[BrowsableAttribute(true)]
public bool EnableAsDropTargetForExternalDragDrop {get; set;}
[C++]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates drop target for dragging thumbnail images to other applications.")]
[BrowsableAttribute(true)]
public: __property bool get_EnableAsDropTargetForExternalDragDrop();
public: __property void set_EnableAsDropTargetForExternalDragDrop(
   bool value
);
[C++/CLI]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates drop target for dragging thumbnail images to other applications.")]
[BrowsableAttribute(true)]
public:
property bool EnableAsDropTargetForExternalDragDrop {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to support drag and drop as a target. Otherwise, false should be used.

Remarks

Both copy and move operations are supported.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


ErrorAction Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ErrorAction Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : ErrorAction Property (ThumbnailXpress)
[Visual Basic]
<CategoryAttribute("ThumbnailXpress")>
<DescriptionAttribute("Inidciates the type of display action taken when a thumbnail generation error occurs.")>
<BrowsableAttribute(True)>
Public Property ErrorAction As ErrorAction
[C#]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the type of display action taken when a thumbnail generation error occurs.")]
[BrowsableAttribute(true)]
public ErrorAction ErrorAction {get; set;}
[C++]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the type of display action taken when a thumbnail generation error occurs.")]
[BrowsableAttribute(true)]
public: __property ErrorAction get_ErrorAction();
public: __property void set_ErrorAction(
   ErrorAction value
);
[C++/CLI]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the type of display action taken when a thumbnail generation error occurs.")]
[BrowsableAttribute(true)]
public:
property ErrorAction ErrorAction {
   ErrorAction get();
   void set (ErrorAction value);
}

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


ErrorLevel Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ErrorLevel Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : ErrorLevel Property

Gets and sets the level of detail written to the error log.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<ObsoleteAttribute("Please use DebugErrorLevel instead")>
Public Property ErrorLevel As DebugErrorLevel
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[ObsoleteAttribute("Please use DebugErrorLevel instead")]
public DebugErrorLevel ErrorLevel {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[ObsoleteAttribute("Please use DebugErrorLevel instead")]
public: __property DebugErrorLevel get_ErrorLevel();
public: __property void set_ErrorLevel(
   DebugErrorLevel value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[ObsoleteAttribute("Please use DebugErrorLevel instead")]
public:
property DebugErrorLevel ErrorLevel {
   DebugErrorLevel get();
   void set (DebugErrorLevel value);
}

Return Type

A DebugErrorLevel.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


Filters Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Filters Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : Filters Property

Gets the FilterCollection object to access a collection of filters.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property Filters As FilterCollection
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public FilterCollection Filters {get;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property FilterCollection* get_Filters();
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property FilterCollection^ Filters {
   FilterCollection^ get();
}

Return Type

The FilterCollection object.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


Font Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Font Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : Font Property

Gets and sets the thumbnail descriptor font.

[Visual Basic]
<DescriptionAttribute("Inidciates the controls descriptor font.")>
<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
Overrides Public Property Font As Font
[C#]
[DescriptionAttribute("Inidciates the controls descriptor font.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public override Font Font {get; set;}
[C++]
[DescriptionAttribute("Inidciates the controls descriptor font.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public: __property Font* get_Font()override ;
public: __property void set_Font(
   Font* value
)override ;
[C++/CLI]
[DescriptionAttribute("Inidciates the controls descriptor font.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public:
property Font^ Font override {
   Font^ get();
   void set (Font^ value);
}

Return Type

The Font value.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


ForeColor Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ForeColor Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : ForeColor Property

Gets and sets the controls foreground color.

[Visual Basic]
<DescriptionAttribute("Inidciates the controls color of any descriptor text")>
<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
Overrides Public Property ForeColor As Color
[C#]
[DescriptionAttribute("Inidciates the controls color of any descriptor text")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public override Color ForeColor {get; set;}
[C++]
[DescriptionAttribute("Inidciates the controls color of any descriptor text")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public: __property Color get_ForeColor()override ;
public: __property void set_ForeColor(
   Color value
)override ;
[C++/CLI]
[DescriptionAttribute("Inidciates the controls color of any descriptor text")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public:
property Color ForeColor override {
   Color get();
   void set (Color value);
}

Return Type

The Color value.

Remarks

This is the color of any descriptor text.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


FtpPassword Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

FtpPassword Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : FtpPassword Property

Gets and sets the FTP password.

[Visual Basic]
<DescriptionAttribute("Inidciates the password for accesing secured FTP files on the internet.")>
<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
Public Property FtpPassword As String
[C#]
[DescriptionAttribute("Inidciates the password for accesing secured FTP files on the internet.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public string FtpPassword {get; set;}
[C++]
[DescriptionAttribute("Inidciates the password for accesing secured FTP files on the internet.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public: __property string* get_FtpPassword();
public: __property void set_FtpPassword(
   string* value
);
[C++/CLI]
[DescriptionAttribute("Inidciates the password for accesing secured FTP files on the internet.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public:
property String^ FtpPassword {
   String^ get();
   void set (String^ value);
}

Return Type

A string value which represents the FTP password.

Remarks

This operates for individual files.

The FTP password is used for accessing files on the Internet when a thumbnail item's Filename property is set to an ftp or http address.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


FtpUserName Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

FtpUserName Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : FtpUserName Property

Gets and sets the FTP user name.

[Visual Basic]
<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
<DescriptionAttribute("Inidciates the username for accesing secured FTP files on the internet.")>
Public Property FtpUserName As String
[C#]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the username for accesing secured FTP files on the internet.")]
public string FtpUserName {get; set;}
[C++]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the username for accesing secured FTP files on the internet.")]
public: __property string* get_FtpUserName();
public: __property void set_FtpUserName(
   string* value
);
[C++/CLI]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the username for accesing secured FTP files on the internet.")]
public:
property String^ FtpUserName {
   String^ get();
   void set (String^ value);
}

Return Type

A string value which represents the FTP username.

Remarks

This operates for individual files

The FTP user name is used for accessing files on the Internet when a thumbnail item's Filename property is set to an ftp or http address.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


InterComponentThumbnailDragDropEnabled Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

InterComponentThumbnailDragDropEnabled Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : InterComponentThumbnailDragDropEnabled Property

Gets and sets enabling or disabling the component acting as a drag source or drop target for thumbnail image drag and drop operations between other instances of the ThumbnailXpress component.

[Visual Basic]
<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
<DescriptionAttribute("Inidciates drag and drop move operations between other instances.")>
Public Property InterComponentThumbnailDragDropEnabled As Boolean
[C#]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates drag and drop move operations between other instances.")]
public bool InterComponentThumbnailDragDropEnabled {get; set;}
[C++]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates drag and drop move operations between other instances.")]
public: __property bool get_InterComponentThumbnailDragDropEnabled();
public: __property void set_InterComponentThumbnailDragDropEnabled(
   bool value
);
[C++/CLI]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates drag and drop move operations between other instances.")]
public:
property bool InterComponentThumbnailDragDropEnabled {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to support drag and drop as a target. Otherwise, false should be used.

Remarks

Both copy and move operations are supported.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


IntraComponentThumbnailDragDropEnabled Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

IntraComponentThumbnailDragDropEnabled Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : IntraComponentThumbnailDragDropEnabled Property

Gets and sets enabling or disabling support of drag and drop move operations amongst thumbnail images in the same instance of a ThumbnailXpress component.

[Visual Basic]
<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
<DescriptionAttribute("Inidciates drag and drop move operations amongst thumbnail images in the same instance.")>
Public Property IntraComponentThumbnailDragDropEnabled As Boolean
[C#]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates drag and drop move operations amongst thumbnail images in the same instance.")]
public bool IntraComponentThumbnailDragDropEnabled {get; set;}
[C++]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates drag and drop move operations amongst thumbnail images in the same instance.")]
public: __property bool get_IntraComponentThumbnailDragDropEnabled();
public: __property void set_IntraComponentThumbnailDragDropEnabled(
   bool value
);
[C++/CLI]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates drag and drop move operations amongst thumbnail images in the same instance.")]
public:
property bool IntraComponentThumbnailDragDropEnabled {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to support drag and drop within the same instance of a ThumbnailXpress component. Otherwise, false is used.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


Items Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Items Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : Items Property

Gets the ThumbnailItemCollection object to access a collection of thumbnail items.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property Items As ThumbnailItemCollection
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public ThumbnailItemCollection Items {get;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property ThumbnailItemCollection* get_Items();
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property ThumbnailItemCollection^ Items {
   ThumbnailItemCollection^ get();
}

Return Type

The ThumbnailItemCollection object which contains a collection of thumbnail items.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


LeftMargin Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

LeftMargin Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : LeftMargin Property

Gets and sets the margin on the left most side of the control.

[Visual Basic]
<BrowsableAttribute(True)>
<DescriptionAttribute("Inidciates the margin on the left most side of the control.")>
<CategoryAttribute("ThumbnailXpress")>
Public Property LeftMargin As Integer
[C#]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the margin on the left most side of the control.")]
[CategoryAttribute("ThumbnailXpress")]
public int LeftMargin {get; set;}
[C++]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the margin on the left most side of the control.")]
[CategoryAttribute("ThumbnailXpress")]
public: __property int get_LeftMargin();
public: __property void set_LeftMargin(
   int value
);
[C++/CLI]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the margin on the left most side of the control.")]
[CategoryAttribute("ThumbnailXpress")]
public:
property int LeftMargin {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the left margin.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


Licensing Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Licensing Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : Licensing Property (ThumbnailXpress)

Gets the Licensing object to allow user to license ThumbnailXpress.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property Licensing As Licensing
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public Licensing Licensing {get;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property Licensing* get_Licensing();
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property Licensing^ Licensing {
   Licensing^ get();
}

Return Type

The Licensing object value set.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


MaximumThreadCount Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

MaximumThreadCount Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : MaximumThreadCount Property

Gets and sets the maximum number of concurrent worker threads allowed for thumbnail bitmap generation.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property MaximumThreadCount As Integer
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public int MaximumThreadCount {get; set;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property int get_MaximumThreadCount();
public: __property void set_MaximumThreadCount(
   int value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property int MaximumThreadCount {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the maximum thread count.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


MaximumThumbnailBitDepth Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

MaximumThumbnailBitDepth Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : MaximumThumbnailBitDepth Property

Gets and sets the maximum bit-depth allowed for the thumbnails.

[Visual Basic]
<BrowsableAttribute(True)>
<CategoryAttribute("ThumbnailXpress")>
<DescriptionAttribute("Inidciates the maximum bit depth allowed for the thumbnails.")>
Public Property MaximumThumbnailBitDepth As Integer
[C#]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the maximum bit depth allowed for the thumbnails.")]
public int MaximumThumbnailBitDepth {get; set;}
[C++]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the maximum bit depth allowed for the thumbnails.")]
public: __property int get_MaximumThumbnailBitDepth();
public: __property void set_MaximumThumbnailBitDepth(
   int value
);
[C++/CLI]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the maximum bit depth allowed for the thumbnails.")]
public:
property int MaximumThumbnailBitDepth {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the maximum thumbnail bit-depth.

Remarks

The default value is 0.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


PreserveBlack Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

PreserveBlack Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : PreserveBlack Property

Gets and sets enabling or disabling the PreserveBlack algorithms during thumbnail image generation.

[Visual Basic]
<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
<DescriptionAttribute("Inidciates preservation of black details (like lines) when reducing black on white images to thumbnail size.")>
Public Property PreserveBlack As Boolean
[C#]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates preservation of black details (like lines) when reducing black on white images to thumbnail size.")]
public bool PreserveBlack {get; set;}
[C++]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates preservation of black details (like lines) when reducing black on white images to thumbnail size.")]
public: __property bool get_PreserveBlack();
public: __property void set_PreserveBlack(
   bool value
);
[C++/CLI]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates preservation of black details (like lines) when reducing black on white images to thumbnail size.")]
public:
property bool PreserveBlack {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to preserve black fine lines. Otherwise, false is used and black lines are not preserved during thumbnail generation.

Remarks

Enabling this property enhances preservation of black details (like lines) when reducing black on white images to thumbnail size.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


ProxyServer Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ProxyServer Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : ProxyServer Property

Gets and sets the name or IP address of an optional proxy server.

[Visual Basic]
<DescriptionAttribute("Inidciates the proxy server.")>
<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
Public Property ProxyServer As String
[C#]
[DescriptionAttribute("Inidciates the proxy server.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public string ProxyServer {get; set;}
[C++]
[DescriptionAttribute("Inidciates the proxy server.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public: __property string* get_ProxyServer();
public: __property void set_ProxyServer(
   string* value
);
[C++/CLI]
[DescriptionAttribute("Inidciates the proxy server.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public:
property String^ ProxyServer {
   String^ get();
   void set (String^ value);
}

Return Type

A string value which represents the proxy server.

Remarks

The ProxyServer property applies only when reading image files from an http or ftp address. Many organizations use a proxy server to allow individual computers to access the Internet through their local area network (LAN). The ProxyServer property specifies the name of the proxy server, which can be a word such as "MyProxyServer," or an Internet Protocol address such as "192.68.112.56".

If the computer uses a direct connection such as Dial-Up Networking, the computer does not use a proxy server and this property should not be set.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


RightMargin Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

RightMargin Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : RightMargin Property

Gets and sets the margin on the right most side of the control.

[Visual Basic]
<DescriptionAttribute("Inidciates the margin on the right most side of the control.")>
<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
Public Property RightMargin As Integer
[C#]
[DescriptionAttribute("Inidciates the margin on the right most side of the control.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public int RightMargin {get; set;}
[C++]
[DescriptionAttribute("Inidciates the margin on the right most side of the control.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public: __property int get_RightMargin();
public: __property void set_RightMargin(
   int value
);
[C++/CLI]
[DescriptionAttribute("Inidciates the margin on the right most side of the control.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public:
property int RightMargin {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the right margin.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


ScrollDirection Property

ThumbnailXpress Class | ThumbnailXpress Members | ScrollDirection Enumeration

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ScrollDirection Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : ScrollDirection Property (ThumbnailXpress)

Gets and sets the current direction of scrolling.

[Visual Basic]
<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
<DescriptionAttribute("Inidciates the current direction of scrolling.")>
Public Property ScrollDirection As ScrollDirection
[C#]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the current direction of scrolling.")]
public ScrollDirection ScrollDirection {get; set;}
[C++]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the current direction of scrolling.")]
public: __property ScrollDirection get_ScrollDirection();
public: __property void set_ScrollDirection(
   ScrollDirection value
);
[C++/CLI]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the current direction of scrolling.")]
public:
property ScrollDirection ScrollDirection {
   ScrollDirection get();
   void set (ScrollDirection value);
}

Return Type

A ScrollDirection enumeration value which represents the scroll direction.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members | ScrollDirection Enumeration


SelectBackColor Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

SelectBackColor Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : SelectBackColor Property

Gets and sets the controls selected items cell background color.

[Visual Basic]
<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
<DescriptionAttribute("Inidciates the controls selected items cell background color.")>
Public Property SelectBackColor As Color
[C#]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the controls selected items cell background color.")]
public Color SelectBackColor {get; set;}
[C++]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the controls selected items cell background color.")]
public: __property Color get_SelectBackColor();
public: __property void set_SelectBackColor(
   Color value
);
[C++/CLI]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the controls selected items cell background color.")]
public:
property Color SelectBackColor {
   Color get();
   void set (Color value);
}

Return Type

The Color value.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


SelectedItems Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

SelectedItems Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : SelectedItems Property

Gets the SelectedThumbnailItemCollection object to access a collection of selected thumbnail items.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public ReadOnly Property SelectedItems As SelectedThumbnailItemCollection
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public SelectedThumbnailItemCollection SelectedItems {get;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property SelectedThumbnailItemCollection* get_SelectedItems();
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property SelectedThumbnailItemCollection^ SelectedItems {
   SelectedThumbnailItemCollection^ get();
}

Return Type

The SelectedThumbnailItemCollection object.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


SelectionMode Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

SelectionMode Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : SelectionMode Property (ThumbnailXpress)

Gets and sets the controls items selection modes.

[Visual Basic]
<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
<DescriptionAttribute("Inidciates the controls items selection modes.")>
Public Property SelectionMode As SelectionMode
[C#]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the controls items selection modes.")]
public SelectionMode SelectionMode {get; set;}
[C++]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the controls items selection modes.")]
public: __property SelectionMode get_SelectionMode();
public: __property void set_SelectionMode(
   SelectionMode value
);
[C++/CLI]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the controls items selection modes.")]
public:
property SelectionMode SelectionMode {
   SelectionMode get();
   void set (SelectionMode value);
}

Return Type

The SelectionMode enumeration value.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


ShowHourglass Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ShowHourglass Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : ShowHourglass Property

Gets and sets the displaying of an hourglass cursor when thumbnail images are being loaded from a directory or file.

[Visual Basic]
<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
<DescriptionAttribute("Inidciates the displaying of an hourglass cursor when thumbnail images are being loaded from a directory or file")>
Public Property ShowHourglass As Boolean
[C#]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the displaying of an hourglass cursor when thumbnail images are being loaded from a directory or file")]
public bool ShowHourglass {get; set;}
[C++]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the displaying of an hourglass cursor when thumbnail images are being loaded from a directory or file")]
public: __property bool get_ShowHourglass();
public: __property void set_ShowHourglass(
   bool value
);
[C++/CLI]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the displaying of an hourglass cursor when thumbnail images are being loaded from a directory or file")]
public:
property bool ShowHourglass {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to display an hourglass when thumbnail images are being loaded. Otherwise, false should be used.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


ShowImagePlaceholders Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ShowImagePlaceholders Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : ShowImagePlaceholders Property

Gets and sets the display of a pre-image-generation 'placeholder' icon.

[Visual Basic]
<BrowsableAttribute(True)>
<CategoryAttribute("ThumbnailXpress")>
<DescriptionAttribute("Inidciates the displaying of a pre-image-generation 'placeholder' icon.")>
Public Property ShowImagePlaceholders As Boolean
[C#]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the displaying of a pre-image-generation 'placeholder' icon.")]
public bool ShowImagePlaceholders {get; set;}
[C++]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the displaying of a pre-image-generation 'placeholder' icon.")]
public: __property bool get_ShowImagePlaceholders();
public: __property void set_ShowImagePlaceholders(
   bool value
);
[C++/CLI]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the displaying of a pre-image-generation 'placeholder' icon.")]
public:
property bool ShowImagePlaceholders {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true to display placeholders. Otherwise, false is used.

Remarks

The default value is false.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


TextBackColor Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

TextBackColor Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : TextBackColor Property

Gets and sets the controls descriptor text background color.

[Visual Basic]
<BrowsableAttribute(True)>
<CategoryAttribute("ThumbnailXpress")>
<DescriptionAttribute("Inidciates the controls controls descriptor text background color.")>
Public Property TextBackColor As Color
[C#]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the controls controls descriptor text background color.")]
public Color TextBackColor {get; set;}
[C++]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the controls controls descriptor text background color.")]
public: __property Color get_TextBackColor();
public: __property void set_TextBackColor(
   Color value
);
[C++/CLI]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the controls controls descriptor text background color.")]
public:
property Color TextBackColor {
   Color get();
   void set (Color value);
}

Return Type

The Color value.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


ThreadHungThreshold Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThreadHungThreshold Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : ThreadHungThreshold Property

Gets and sets the elapsed time threshold (in milleseconds) beyond which a request to obtain a thumbnail should be abandoned.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property ThreadHungThreshold As Integer
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public int ThreadHungThreshold {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property int get_ThreadHungThreshold();
public: __property void set_ThreadHungThreshold(
   int value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property int ThreadHungThreshold {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the thread hung threshold.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


ThreadStartThreshold Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThreadStartThreshold Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : ThreadStartThreshold Property

Gets and sets the elapsed time threshold (in milleseconds) beyond which a request to obtain a thumbnail should be considered of "extended duration".

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property ThreadStartThreshold As Integer
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public int ThreadStartThreshold {get; set;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property int get_ThreadStartThreshold();
public: __property void set_ThreadStartThreshold(
   int value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property int ThreadStartThreshold {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the thread start threshold.

Remarks

ThumbnailXpress adjusts for "extended duration" requests by starting additional retrieval threads if other thumnails were requested to attempt to keep the control display responsive.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


ThumbnailCache Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailCache Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : ThumbnailCache Property (ThumbnailXpress)

Gets and sets the thumbnail cache object to adjust cache settings.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property ThumbnailCache As ThumbnailCache
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public ThumbnailCache ThumbnailCache {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property ThumbnailCache* get_ThumbnailCache();
public: __property void set_ThumbnailCache(
   ThumbnailCache* value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property ThumbnailCache^ ThumbnailCache {
   ThumbnailCache^ get();
   void set (ThumbnailCache^ value);
}

Return Type

The ThumbnailCache to adjust cache settings.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


TopMargin Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

TopMargin Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : TopMargin Property

Gets and sets the margin on the top most side of the control.

[Visual Basic]
<CategoryAttribute("ThumbnailXpress")>
<DescriptionAttribute("Inidciates the margin on the top most side of the control.")>
<BrowsableAttribute(True)>
Public Property TopMargin As Integer
[C#]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the margin on the top most side of the control.")]
[BrowsableAttribute(true)]
public int TopMargin {get; set;}
[C++]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the margin on the top most side of the control.")]
[BrowsableAttribute(true)]
public: __property int get_TopMargin();
public: __property void set_TopMargin(
   int value
);
[C++/CLI]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Inidciates the margin on the top most side of the control.")]
[BrowsableAttribute(true)]
public:
property int TopMargin {
   int get();
   void set (int value);
}

Return Type

An integer value which represents the top margin.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


TopVisibleItem Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

TopVisibleItem Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : TopVisibleItem Property

Gets the thumbnail item of the top-most visible thumbnail item.

[Visual Basic]
<EditorBrowsableAttribute()>
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public ReadOnly Property TopVisibleItem As ThumbnailItem
[C#]
[EditorBrowsableAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public ThumbnailItem TopVisibleItem {get;}
[C++]
[EditorBrowsableAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property ThumbnailItem* get_TopVisibleItem();
[C++/CLI]
[EditorBrowsableAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property ThumbnailItem^ TopVisibleItem {
   ThumbnailItem^ get();
}

Return Type

A ThumbnailItem which represents the top-most visible item.

Remarks

If no top visible item exists this property will return null.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


VisibleColumnCount Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

VisibleColumnCount Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : VisibleColumnCount Property

Gets the number of visible thumbnail columns.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<EditorBrowsableAttribute()>
<BrowsableAttribute(False)>
Public ReadOnly Property VisibleColumnCount As Integer
[C#]
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute()]
[BrowsableAttribute(false)]
public int VisibleColumnCount {get;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute()]
[BrowsableAttribute(false)]
public: __property int get_VisibleColumnCount();
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute()]
[BrowsableAttribute(false)]
public:
property int VisibleColumnCount {
   int get();
}

Return Type

The visible column count.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


VisibleRowCount Property

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

VisibleRowCount Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : VisibleRowCount Property

Gets the number of visible thumbnail rows.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<EditorBrowsableAttribute()>
Public ReadOnly Property VisibleRowCount As Integer
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute()]
public int VisibleRowCount {get;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute()]
public: __property int get_VisibleRowCount();
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute()]
public:
property int VisibleRowCount {
   int get();
}

Return Type

The visible row count.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


Error Event

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Error Event

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : Error Event

Event which is called when an error occurs during generation or painting of a thumbnail item.

[Visual Basic]
Public Event Error() As ThumbnailXpressEvents.ErrorEventHandler
[C#]
public event ThumbnailXpressEvents.ErrorEventHandler Error();
[C++]
public: __event ThumbnailXpressEvents.ErrorEventHandler* Error();
[C++/CLI]
public:
event ThumbnailXpressEvents::ErrorEventHandler^ Error();

Event Data

The event handler receives an argument of type ErrorEventArgs containing data related to this event. The following ErrorEventArgs properties provide information specific to this event.

Property | Description
ItemIndex | Gets and sets the index for the Thumbnail Item collection member which incurred an error during thumbnail generation.
Message | Gets and sets the error message for the Thumbnail item collection member which incurred an error during thumbnail generation.
Number | Gets and sets the error number for the Thumbnail Item collection member which incurred an error during thumbnail generation.

Remarks

The error could be due to generation errors like an unsupported or corrupt file, or various painting errors.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


ItemComplete Event

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ItemComplete Event

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : ItemComplete Event

Event which is called when a thumbnail item's asynchronous image generation has been completed. Review the the thumbnail item collection information about how thumbnail items are added to the collection, where the items are generated asynchronously.

[Visual Basic]
Public Event ItemComplete() As ThumbnailXpressEvents.ItemCompleteEventHandler
[C#]
public event ThumbnailXpressEvents.ItemCompleteEventHandler ItemComplete();
[C++]
public: __event ThumbnailXpressEvents.ItemCompleteEventHandler* ItemComplete();
[C++/CLI]
public:
event ThumbnailXpressEvents::ItemCompleteEventHandler^ ItemComplete();

Event Data

The event handler receives an argument of type ItemCompleteEventArgs containing data related to this event. The following ItemCompleteEventArgs properties provide information specific to this event.

Property | Description
ItemIndex | Gets and sets the index of the ThumbnailItemCollection member for which the thumbnail image generation has just completed.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


LoadFromStream Event

ThumbnailXpress Class | ThumbnailXpress Members | LoadFromStreamEventArgs Class

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

LoadFromStream Event

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : LoadFromStream Event

This event is called when the component requires the application to provide a Stream object containing image data for a thumbnail item.

[Visual Basic]
Public Event LoadFromStream() As ThumbnailXpressEvents.LoadFromStreamEventHandler
[C#]
public event ThumbnailXpressEvents.LoadFromStreamEventHandler LoadFromStream();
[C++]
public: __event ThumbnailXpressEvents.LoadFromStreamEventHandler* LoadFromStream();
[C++/CLI]
public:
event ThumbnailXpressEvents::LoadFromStreamEventHandler^ LoadFromStream();

Event Data

The event handler receives an argument of type LoadFromStreamEventArgs containing data related to this event. The following LoadFromStreamEventArgs properties provide information specific to this event.

Property | Description
Item | Gets the ThumbnailItem object whose image data is to be loaded using a Stream.

Remarks

A handler for this event must be supplied by the application if items are added to the ThumbnailItemCollection using the collection's ThumbnailItemCollection.InsertItemFromStream or ThumbnailItemCollection.AddItemFromStream methods.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members | LoadFromStreamEventArgs Class


SelectedIndexChanged Event

ThumbnailXpress Class | ThumbnailXpress Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

SelectedIndexChanged Event

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpress Class : SelectedIndexChanged Event

Event which is called when a thumbnail item is selected using the user interface.

[Visual Basic]
Public Event SelectedIndexChanged() As ThumbnailXpressEvents.SelectedIndexChangedEventHandler
[C#]
public event ThumbnailXpressEvents.SelectedIndexChangedEventHandler SelectedIndexChanged();
[C++]
public: __event ThumbnailXpressEvents.SelectedIndexChangedEventHandler* SelectedIndexChanged();
[C++/CLI]
public:
event ThumbnailXpressEvents::SelectedIndexChangedEventHandler^ SelectedIndexChanged();

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpress Class | ThumbnailXpress Members


ThumbnailXpressEvents Class

ThumbnailXpressEvents Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailXpressEvents Class

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailXpressEvents Class

This class implements the ThumbnailXpress events.

For a list of all members of this type, see ThumbnailXpressEvents members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ThumbnailXpress2.ThumbnailXpressEvents

Syntax

[Visual Basic]
Public Class ThumbnailXpressEvents
[C#]
public class ThumbnailXpressEvents
[C++]
public __gc class ThumbnailXpressEvents
[C++/CLI]
public ref class ThumbnailXpressEvents

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

ThumbnailXpressEvents Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ThumbnailXpressEvents Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailXpressEvents Class Members

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailXpressEvents Class

ThumbnailXpressEvents overview

See Also

ThumbnailXpressEvents Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ThumbnailXpressException Class

ThumbnailXpressException Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailXpressException Class

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailXpressException Class

Summary description for ThumbnailXpressException.

For a list of all members of this type, see ThumbnailXpressException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
PegasusImaging.WinForms.ThumbnailXpress2.ThumbnailXpressException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public Class ThumbnailXpressException
   Inherits Exception
[C#]
[SerializableAttribute()]
public class ThumbnailXpressException : Exception
[C++]
[SerializableAttribute()]
public __gc class ThumbnailXpressException : public Exception
[C++/CLI]
[SerializableAttribute()]
public ref class ThumbnailXpressException : public Exception

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

ThumbnailXpressException Members | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ThumbnailXpressException Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailXpressException Class Members

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailXpressException Class

ThumbnailXpressException overview

Public Constructors

Public Constructor ThumbnailXpressException Constructor Overloaded. The main constructor for the ThumbnailXpressException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number | Gets the error number from the last call.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ThumbnailXpressException Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ThumbnailXpressException Constructor

ThumbnailXpressException Class | ThumbnailXpressException Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailXpressException Constructor

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpressException Class : ThumbnailXpressException Constructor (ThumbnailXpressException)

The main constructor for the ThumbnailXpressException class.

Overload List

The main constructor for the ThumbnailXpressException class.

[Visual Basic] Public Sub New()

[C#] public ThumbnailXpressException();

[C++] public ThumbnailXpressException();

[C++/CLI] public ThumbnailXpressException();

Exception for ThumbnailXpress errors with an error message.

[Visual Basic] Public Sub New(String)

[C#] public ThumbnailXpressException(string);

[C++] public ThumbnailXpressException(string*);

[C++/CLI] public ThumbnailXpressException(String^);

Exception for ThumbnailXpress errors with a message and error number.

[Visual Basic] Public Sub New(String,Integer)

[C#] public ThumbnailXpressException(string,int);

[C++] public ThumbnailXpressException(string*,int);

[C++/CLI] public ThumbnailXpressException(String^,int);

Exception for ThumbnailXpress errors with a message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public ThumbnailXpressException(string,Exception);

[C++] public ThumbnailXpressException(string*,Exception*);

[C++/CLI] public ThumbnailXpressException(String^,Exception^);

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpressException Class | ThumbnailXpressException Members


ThumbnailXpressException Constructor()

ThumbnailXpressException Class | ThumbnailXpressException Members | Overload List

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailXpressException Constructor()

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpressException Class > ThumbnailXpressException Constructor : ThumbnailXpressException Constructor()

The main constructor for the ThumbnailXpressException class.

[Visual Basic]
Public Function New()
[C#]
public ThumbnailXpressException();
[C++]
public: ThumbnailXpressException();
[C++/CLI]
public:
ThumbnailXpressException();

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpressException Class | ThumbnailXpressException Members | Overload List


ThumbnailXpressException Constructor(String)

ThumbnailXpressException Class | ThumbnailXpressException Members | Overload List

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string value which represents the error message.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailXpressException Constructor(String)

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpressException Class > ThumbnailXpressException Constructor : ThumbnailXpressException Constructor(String)

Exception for ThumbnailXpress errors with an error message.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public ThumbnailXpressException(
   string message
);
[C++]
public: ThumbnailXpressException(
   string* message
)
[C++/CLI]
public:
ThumbnailXpressException(
   String^ message
)

Parameters

message
A string value which represents the error message.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpressException Class | ThumbnailXpressException Members | Overload List


ThumbnailXpressException Constructor(String,Exception)

ThumbnailXpressException Class | ThumbnailXpressException Members | Overload List

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string value which represents the error message.
innerException
A Exception which represents an inner exception.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailXpressException Constructor(String,Exception)

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpressException Class > ThumbnailXpressException Constructor : ThumbnailXpressException Constructor(String,Exception)

Exception for ThumbnailXpress errors with a message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public ThumbnailXpressException(
   string message,
   Exception innerException
);
[C++]
public: ThumbnailXpressException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
ThumbnailXpressException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
A Exception which represents an inner exception.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpressException Class | ThumbnailXpressException Members | Overload List


ThumbnailXpressException Constructor(String,Int32)

ThumbnailXpressException Class | ThumbnailXpressException Members | Overload List

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string value which represents the error message.
number
An integer value which represents the error number.
See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailXpressException Constructor(String,Int32)

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpressException Class > ThumbnailXpressException Constructor : ThumbnailXpressException Constructor(String,Int32)

Exception for ThumbnailXpress errors with a message and error number.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal number As Integer _
)
[C#]
public ThumbnailXpressException(
   string message,
   int number
);
[C++]
public: ThumbnailXpressException(
   string* message,
   int number
)
[C++/CLI]
public:
ThumbnailXpressException(
   String^ message,
   int number
)

Parameters

message
A string value which represents the error message.
number
An integer value which represents the error number.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpressException Class | ThumbnailXpressException Members | Overload List


Number Property

ThumbnailXpressException Class | ThumbnailXpressException Members

Requirements

Platforms: See Distribution Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Number Property

PegasusImaging.WinForms.ThumbnailXpress2 Namespace > ThumbnailXpressException Class : Number Property (ThumbnailXpressException)

Gets the error number from the last call.

[Visual Basic]
Public ReadOnly Property Number As Integer
[C#]
public int Number {get;}
[C++]
public: __property int get_Number();
[C++/CLI]
public:
property int Number {
   int get();
}

Return Type

An integer value which represents the error number.

Requirements

Platforms: See Distribution Requirements

See Also

ThumbnailXpressException Class | ThumbnailXpressException Members


DebugErrorLevel Enumeration

PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

DebugErrorLevel Enumeration

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : DebugErrorLevel Enumeration (PegasusImaging.WinForms.ThumbnailXpress2)

Option value which determine the amount of logging detail to be sent to the log file.

Members

Member | Description
Production | 0 - This value is for logging in production mode and has the least amount of detail in the log.
Development | 1 - This value is for logging in development mode and has some additional amount of detail in the log.
Detailed | 2 - This value is for debugging and has the highest level of detail in the log.

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

PegasusImaging.WinForms.ThumbnailXpress2 Namespace


DescriptorAlignments Enumeration

PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

DescriptorAlignments Enumeration

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : DescriptorAlignments Enumeration

Option values which determine the alignment of the descriptor text display.

Members

Member | Description
AlignCenter | 1 - Descriptor text is horizontally centered.
AlignLeft | 2 - Descriptor text is left justified.
AlignRight | 4 - Descriptor text is right justified.
AlignTop | 8 - Descriptor text is top justified.
AlignVCenter | 16 - Descriptor text is vertically centered.
AlignBottom | 32 - Descriptor text is bottom justified.

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

PegasusImaging.WinForms.ThumbnailXpress2 Namespace


DescriptorDisplayMethods Enumeration

PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

DescriptorDisplayMethods Enumeration

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : DescriptorDisplayMethods Enumeration

Option value which determine the source of descriptor text.

Members

Member | Description
None | 0 - Do not display a descriptor.
Default | 1 - Use the thumbnail item descriptor property if present, or short filename otherwise.
LongFilename | 2 - Automatic; based on full filename.
ShortFilename | 4 - Automatic; based on filename only.
IncludePage | 8 - Include page number information when not using descriptor string.
Custom | 16 - Display what is in the thumbnail item descriptor property.

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ErrorAction Enumeration

PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ErrorAction Enumeration

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ErrorAction Enumeration (PegasusImaging.WinForms.ThumbnailXpress2)

Option values which determine the action taken if thumbnail processing error are encountered.

Members

Member | Description
UseErrorIcon | 0 - Default value. Display error icon when unsupported or error thumbnails encountered
Abort | 1 - Stop display of thumbnails

Remarks

The default value is UseErrorIcon.

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

PegasusImaging.WinForms.ThumbnailXpress2 Namespace


EvaluationMode Enumeration

PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

EvaluationMode Enumeration

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : EvaluationMode Enumeration (PegasusImaging.WinForms.ThumbnailXpress2)

Option values which determine the evaluation modes available for use.

Members

Member | Description
TrialDialog | 0 - Default value. TrialDialog specifies that a dialog box should be used during evaluation.
Timeout | 1 - Timeout specifies that after a period of time, the control will stop processing during evaluation.

Remarks

The default value is TrialDialog.

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

PegasusImaging.WinForms.ThumbnailXpress2 Namespace


FilterComparison Enumeration

PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

FilterComparison Enumeration

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : FilterComparison Enumeration

Option values which specify the desired oomparison outcome for a file date or size filter.

Members

Member | Description
LessThan | 0 - Image file value less than the value specified in the filter
LessThanEquals | 1 - Image file value less than or equal to the value specified in the filter
Equal | 2 - Image file value equal to the value specified in the filter
GreaterThanEquals | 3 - Image file value greater than or equal to the value specified in the filter
GreaterThan | 4 - Image file value greater than the value specified in the filter

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

PegasusImaging.WinForms.ThumbnailXpress2 Namespace


FilterType Enumeration

PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

FilterType Enumeration

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : FilterType Enumeration

Option values which determine the thumbnail image file parameter that is to be compared or matched by a filter.

Members

Member | Description
Filename | 0 - Matching on filename, incorporates case sensitivite logic
FileAttributes | 1 - Matching on parent directory, sub directory, and hidden file attributes
FileCreationDate | 2 - Comparison on image file creation date
FileModificationDate | 3 - Comparison on image file modification date
FileSize | 4 - Comparison on image file size
SupportedFileType | 5 - Image file is supported by IX

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

PegasusImaging.WinForms.ThumbnailXpress2 Namespace


IXLicenseEdition Enumeration

PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

IXLicenseEdition Enumeration

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : IXLicenseEdition Enumeration (PegasusImaging.WinForms.ThumbnailXpress2)

Option values which control the ImagXpress Edition that the ThumbnailXpress control uses.

Members

Member | Description
Standard | 54 - ImagXpress Standard Edition.
View | 55 - ImagXpress View Edition.
Document | 56 - ImagXpress Document Edition.
Photo | 66 - ImagXpress Photo Edition.

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ScrollDirection Enumeration

PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ScrollDirection Enumeration

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ScrollDirection Enumeration (PegasusImaging.WinForms.ThumbnailXpress2)

Option values which determine the direction the thumbnails will scroll in the control.

Members

Member | Description
Horizontal | 0 - Thumbnails scroll in a horizontal direction.
Vertical | 1 - Thumbnails scroll in a vertical direction.

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ScrollItemsType Enumeration

PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ScrollItemsType Enumeration

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ScrollItemsType Enumeration

Option values which specify the incremental amount or whether a positional programmatic scroll operation is desired.

Members

Member | Description
LargeDecrease | 0 - Thumbnails are to be scrolled backward one page.
SmallDecrease | 1 - Thumbnails are to be scrolled backward one row or column.
LargeIncrease | 2 - Thumbnails are to be scrolled forward one page.
SmallIncrease | 3 - Thumbnails are to be scrolled forward one row or column.
ThumbPosition | 4 - Thumbnails are to be scrolled to a specified thumb position.
ItemIndex | 5 - Thumbnails are to be scrolled to a specified item index position.

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

PegasusImaging.WinForms.ThumbnailXpress2 Namespace


SelectionMode Enumeration

PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

SelectionMode Enumeration

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : SelectionMode Enumeration (PegasusImaging.WinForms.ThumbnailXpress2)

Option values which determine the Thumbnail Item selection mode for the control.

Members

Member | Description
None | 0 - Only one Thumbnail item may be selected. If a second item is selected the selected state is removed from any previously selected item.
Single | 1 - Only one Thumbnail item may be selected. If a second item is selected the selected state is removed from any previously selected item.
MultiSimple | 2 - Multiple Thumbnail items may be selected, the control and shift keys do not modify the items selected operation
MultiExtended | 3 - Multiple Thumbnail items may be selected, the control and shift keys modify the items selected operation

Remarks

The default value is MultiExtended.

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ThumbnailStatus Enumeration

PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailStatus Enumeration

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailStatus Enumeration

Option values which determine the Thumbnail item image data validation and generation status.

Members

Member | Description
NotValidated | Item image data has not been validated and it is yet to be determined if a thumbnail image can be generated from the data.
Validated | Item image data has been validated and it is believed a thumbnail image can be generated for the item
BeingGenerated | A thumbnail image is in the process of being generated from the item image data.
Generated | A thumbnail image has been successfully generated for the item.
FailedWithError | Thumbnail image generation incurred an error.
FailedWithTimeout | Failed to generate a thumbnail image within time threshold limits. See the ThumbnailXpress ThreadHungThreshold property ThumbnailXpress.ThreadHungThreshold
Canceled | The thumbnail image generation was canceled by the user before completion.

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ThumbnailType Enumeration

PegasusImaging.WinForms.ThumbnailXpress2 Namespace

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailType Enumeration

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailType Enumeration

Option values which specify the type of thumbnail (image, directory, etc.) for a thumbnail item.

Members

Member | Description
Unknown | 0 - Have not tried any operations which allow us to know the type.
Internet | 1 - Similar to Unknown type except the image data resides on the internet.
Unsupported | 2 - Non-image data or unsupported image data.
Image | 3 - Supported image data.
Pdf | 4 - Supported PDF image data.
Cad | 5 - Supported CAD image data.
ParentDirectory | 6 - Parent directory folder.
SubDirectory | 7 - Sub-directory folder.

Requirements

Namespace: PegasusImaging.WinForms.ThumbnailXpress2

Platforms: See Distribution Requirements page

Assembly: PegasusImaging.WinForms.ThumbnailXpress2.dll

See Also

PegasusImaging.WinForms.ThumbnailXpress2 Namespace


Glossary

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

A

Aspect Ratio
There are two kinds of aspect ratio that you need to be aware of when working with 2D images; the image aspect ratio and the pixel aspect ratio.The image aspect ratio is the ratio of the width of the image to the height of the image. It's important when resizing an image to keep this ratio as close to unchanged as possible or the image may become distorted.The pixel aspect ratio is the shape of the pixels in the image. For computers this is normally square (1:1) or close to it depending on the monitor settings. For some video sources, however, the pixels may be slightly rectangular.

B

Black on Edge
The minimum or maximum number of pixels on the vertical or horizontal edge of an image or document.

BMP
The Microsoft Windows Bitmap file format is based on the Microsoft Windows internal bitmap data structures. The BMP format is very widely used and it is quick and easy to read. Although most BMP files are uncompressed, a type of run length encoding is supported.

BPP
Bits per pixel

Brightness
A Pegasus Imaging method that enhances the brightness attributes of the pixels in the bitmap. Positive settings produce brighter pixels while negative settings produce darker pixels.

C

CCITT
CCITT is the most widely used compression scheme for transmitting binary (black and white) image data. CCITT was established by the International Telegraph and Telephone Consultative Committee. The Group 3 and Group 4 CCITT compression standards are widely used for transmitting fax data. CCITT compressed images are typically stored in the TIFF image format.

Container
Gets the container for the component. An object implementing the IContainer interface that represents the component's container, or a null reference (Nothing in Visual Basic) if the component does not have a site.

Contrast
An Pegasus Imaging method that enhances the contrast attributes of the pixels in the bitmap. Positive settings produce a higher contrast image while negative settings produce a lower contrast image. Images with a higher contrast have a higher frequency of pixel intensities near the ends of the intensity spectrum while images with a lower contrast have a higher frequency of pixels near the middle of the intensity spectrum.

CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

D

DCOM
Microsoft's extension of their Component Object Model (COM) to support objects distributed across a network. DCOM is currently implemented only by Microsoft for Microsoft Windows; and by Software AG, under the name "EntireX", for Unix and IBM mainframes. DCOM serves the same purpose as IBM's DSOM protocol. DCOM is an object model, but has no provisions for inheritance.

DCX
An image format containing multiple PCX images. A DCX file can contain a maximum of 1024 images.

DDB
Microsoft Device Dependent Bitmap. The actual in-memory information used to display an image.

DEP
Data Execution Prevention (computer security)

Despeckle
A modified median filter primarily used for reducing noise in document images. Despeckling divides the image into pixel groups and uses the brightness value to adjust brightness spikes. This filter will reduce noise in a black and white document image with minimal distortion of document text.

DIB
Microsoft Device Independent Bitmap. An alternative file extension used by the Microsoft Windows Bitmap.

DICOM
Digital Imaging and Communication, a standard for handling digital medical images.

Dispose
Releases the resources used by the Component.

Disposed
Adds an event handler to listen to the Disposed event on the component. When you create a Disposed delegate, you identify the method that handles the event.

Dithering
A technique used in computer graphics to create the illusion of varying shades of gray on a monochrome display or printer, or additional colors on a color display or printer. Dithering relies on treating areas of an image as groups of dots that are colored in different patterns. Akin to the print images called halftones, dithering takes advantage of the eye’s tendency to blur spots of different colors by averaging their effects and merging them into a single perceived shade or color. Depending on the ratio of black dots to white dots within a given area, the overall effect is of a particular shade of gray. Dithering is used to add realism to computer graphics and to soften jagged edges in curves and diagonal lines at low resolutions.

E

Emboss
A Pegasus Imaging method that causes the foreground of an image to appear raised from background. Embossing gives the image a raised metallic-like look

ePIC
Pegasus Imaging enhanced PIC image format. This high performance image compression combines the patented ELS arithmetic coder with the high performance Pegasus JPEG libraries. The result is a new and unbeatable compression technology. The ePIC compression has significant advantages over standard JPEG. Most importantly it produces smaller file sizes and decompresses extremely quickly. ePIC images can be password encrypted. These images can also be 'zoomed' or scaled to larger, arbitrary sizes.

Equalize
An Pegasus Imaging method that is a point process used for adjusting the contrast of an image. A frequency histogram of the colors of the image is computed and adjusted to equalize the colors across the full spectrum of intensity values. The equalized colors are applied to each pixel in the image.

EXIF
EXchangeable Image File format (Japan Electronic Industry Development Association, JEIDA), compressed image format used in digital cameras.

F

Flate
The lossless deflate compression algorithm is based on two other compression algorithms: huffman encoding and LZ77 compression.

Float
Denotes a simple type that stores 32-bit floating-point values.

G

Gamma
A non-linear brightness transform. Gamma values greater than 0 and less that 1.0 generate exponential curves that dim and image. Gamma values greater than 1.0 generate exponential curves that brighten an image.

GDI
Acronym for Graphical Device Interface. In Windows, a graphics display system used by applications to display or print bitmapped text (TrueType fonts), images, and other graphical elements. The GDI is responsible for drawing dialog boxes, buttons, and other elements in a consistent style on screen by calling the appropriate screen drivers and passing them the information on the item to be drawn. The GDI also works with GDI printers, which have limited ability to prepare a page for printing. Instead, the GDI handles that task by calling the appropriate printer drivers and moving the image or document directly to the printer, rather than reformatting the image or document in PostScript or another printer language.

GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.

GIF
Graphical Interchange File, originally developed by CompuServe as a machine independent format. GIF is one of the most popular image formats for storing 8-bit digitized images. GIF files are typically smaller than uncompressed formats like BMP due to the LZW compression algorithm that GIF uses.

Grey-scale
If the pixels of a grey-scale image have N bits, they may take values from zero, representing black up to 2^N-1, representing white with intermediate values representing increasingly light shades of grey. If N=1, the image is not called grey-scale, but could be called monochrome.

H

Halftone
Pertaining to pictures in which gradation of tone in the photograph is reproduced by a graduated system of dotted and checkered spots, usually nearly invisible to the unaided eye, produced by the interposition between the camera and the object of a screen. The name alludes to the fact that this process was the first that was practically successful in reproducing the half tones of the photograph.

Hue
One of the 3 components of the HSL (Hue, Saturation and Luminance ) color space. The hue component controls the overall color space of an image. Adjusting the hue of the image adjusts the color spectrum from red through yellow, green, blue, and violet.

I

ICO
Microsoft Windows Icon file format.

Inverse
To reverse something or change it to its opposite. For example, to invert the colors on a monochrome display means to change light to dark and dark to light. In a digital electrical signal, to replace a high level by a low level and vice versa. This type of operation is the electronic equivalent of a Boolean NOT operation.

IOD
Information Object Definition.

IPTC
The International Press Telecommunications Council, not the International Petroleum Technology Conference

J

JIF
An alternative image file extension used for a JFIF compliant JPEG file. Because many early versions of JPEG contained a JPG extension but did not adhere to the JFIF specifications, the JIF extension was created to identify JPEG files that are JFIF compliant. As the popularity of JPEG grew, JFIF compliance became synonymous with the JPG extension and thus the JIF extension is rarely used.

JPEG
The JPEG (Joint Photographic Experts Group) standard is one of the most important image data compression standards. It is widely used in many industries including graphic arts, desktop publishing, medical imaging, and many more. It is also becoming one of the most widely used image formats on the Internet. Although JPEG supports a lossless mode, it most commonly uses lossy compression. This allows JPEG to achieve very high compression ratios. JPEG compression uses several compression modes. First, an image is transformed to the frequency domain using the discrete cosine transform. The smaller valued frequency components are discarded leaving only the larger valued components. The remaining components are DPCM coded and then Huffman coded. Fortunately, ImagXpress™ handles all of this for you! The compression level is adjustable. Higher quality settings produce a larger image file size with higher image quality. Lower quality settings produce a smaller image file size with lower image quality. Typically, we have found that compression ratios of 10:1 or 15:1 (A 640x480x24-bit image is 921,600 bytes; a 15:1 compressed image would compress to only 61k) produce generally acceptable image quality for photographic type images. Images compressed at higher ratios begin to show more noticeable and sometimes objectionable artifacts and clarity loss. JPEG is a 24-bit format and works only with 24-bit images. If you compress an 8-bit image, ImagXpress™ automatically converts it to 24-bit to do the compression, however, you will obtain better quality when the source image is 24-bit because 8-bit images only contain 256 colors. JPEG works best with photographic type images. It does not work well with solid colors, 16-color images, cartoon like images, or drawings. Progressive JPEG is a multiple-scan sequential JPEG format that is becoming popular on the Internet for the ability to display images in progressively clearer segments.

L

Little-endian
Describes a computer architecture in which, within a given 16- or 32-bit word, bytes at lower addresses have lower significance (the word is stored "little-end-first"). The PDP-11/VAX families of computers, Intel microprocessors, plus a lot of communications and networking hardware are little-endian. The term is sometimes used to describe the ordering of units other than bytes; most often, bits within a byte.

Lock
A lock, represented by the Visual Basic keyword "SyncLock Statement," or the C# keyword "lock Statement", allows a single thread of execution to obtain exclusive execution rights on an object. Although using locks will guarantee that multiple threads do not simultaneously access an object, they can cause significant performance degradation.

Luminance
One of the 3 components of the HSL (Hue, Saturation and Luminance) color space. Luminance controls the overall brightness of an image.

LUT
Look Up Table.

LZW
Lempel-Ziv-Welch (algorithm)

M

Matrix
A matrix filter, also called convolution, alters each pixel's color based on its current color and the colors of any neighboring pixels. The ImagXpress™ Matrix method uses a 3x3 matrix. The numbers in the matrix are coefficients. When a pixel is processed, its color value is multiplied by the coefficient in the center of the matrix, and any pixels within the 3x3 grid are multiplied by the corresponding coefficients in the matrix. The sum of the products becomes the target pixel's new value. The Divisor is simply the coefficient denominator. The matrix method is typically used for sharpening, softening, and edge enhancement.

Mosaic
A mosaic divides the bitmap into tiles of a specified size. All of the pixels in each tile are averaged and changed to the average color.

Multithreading
Multithreading, or free threading, refers to the ability of a program to execute multiple threads of operation simultaneously. An example of a multithreaded application might be a program that receives user input on one thread, performs a variety of complex calculations on a second thread, and updates a database on a third thread. In a single-threaded application, a user might spend idle time waiting for the calculations or database updates to finish. In a multithreaded application, these processes can proceed in the background so user time is not wasted. Multithreading can be a powerful tool to use in component programming. By writing multithreaded components, you can create components that perform complex calculations in the background while leaving the user interface free to respond to user input. Although multithreading can be a powerful tool, it can also be difficult to apply correctly. Improperly implemented multithreaded code can degrade application performance, or even cause frozen applications. (See MSDN)

Multithreading
Multithreading executes multiple threads of operation simultaneously. In a single-threaded application, a user might spend idle time waiting for the calculations or database updates to finish. In a multithreaded application, these processes can proceed in the background so user time is not wasted.

N

Negate
An ImagXpress™ method that creates a color negative of an image.

Noise
An ImagXpress™ method that adds random pixels to the bitmap.

O

Orthogonal
Used loosely to mean mutually independent or well separated. It describes sets of primitives or capabilities that, like linearly independent vectors in geometry, span the entire "capability space" and are in some sense non-overlapping or mutually independent. For example, in logic, the set of operators "not" and "or" is described as orthogonal, but the set "and", "or", and "not" is not (because any one of these can be expressed in terms of the others).

P

PBM
Portable bitmap image format, a very simple uncompressed 1-bit (black and white) image format. Data can be stored in either binary or ASCII format.

PGM
Portable Graymap image format. PGM is a very simple uncompressed 8-bit grayscale image format. Data can be stored in either binary or ASCII format.

PNG
Portable Network Graphics (pronounced "ping") provides a portable, legally unencumbered (royalty-free), well-compressed, well-specified standard for lossless bitmapped image files. The initial motivation for developing PNG was to provide a royalty-free alternative to GIF. The design retains many of the features of GIF that make it an attractive format for transmission of images, such as lossless compression and progressive display capabilities. Additionally, it provides several advantages including 24-bit image support and generally better compression, although decompression is typically somewhat slower than GIF. PNG's success will be ultimately determined by its acceptability on the Internet. At the time of this writing, however, PNG has not been incorporated as part of the major Internet browsers.

PPM
Portable Pixmap image format, a very simple uncompressed 24-bit image format. Data is stored in RGB triplets and can be stored in either binary or ASCII format.

R

RGB
Red, Green Blue. Bitmapped images are most generally stored as RGB data. Each pixel or data point in a true color (24-bit) image contains 3 components, red, green and blue, that describe the color of the pixel. Each of the components can have a value between 0 and 255, 0 being the darkest shade of color and 255 being the lightest shade of color. Since each component can be stored in one byte (8-bits), the 3 components take up 3 bytes or 24-bits per pixel. 8-bit images contain one byte (8-bit) indexes for each pixel that map to a color table called a palette which contains a maximum of 256 RGB entries. Likewise, 4-bit images contain 4-bit indexes for each pixel that map to a palette which contains a maximum of 16 RGB entries. 1-bit images contain 1-bit per pixel. Each bit in a 1-bit image represents either black or white.

RLE
RLE stands for Run Length Encoding. It is a lossless algorithm that only offers decent compression ratios in specific types of data.

S

Saturation
One of the 3 components of the HSL (Hue, Saturation, and Luminance) color space. Saturation controls the purity of a color. Higher saturations result in richer, deeper colors. Lower saturations result in paler colors.

Scalar
In programming, any data type that stores a single value (a number or Boolean), as opposed to an aggregate data type that has many elements. A string is regarded as a scalar in some languages (PERL) and a vector of characters in others (C).

Sharpen
An ImagXpress™ method that is used to sharpen an image. The sharpen filter uses a high-pass convolution matrix filter to accentuate high frequency detail in the image.

Single
Value type represents a single-precision 32-bit number with values ranging from negative 3.402823e38 to positive 3.402823e38, as well as positive or negative zero, PositiveInfinity, NegativeInfinity, and not a number (NaN).

Soften
An ImagXpress™ method that is used to soften an image. The soften filter uses a low-pass convolution matrix filter to accentuate low frequency detail in the image.

T

TGA
Targa Image File) format was developed by TrueVision for its Targa line of products. TGA is one of the earliest image formats and was the first popular format to support 24-bit color. TGA supports uncompressed and RLE compressed formats.

TIFF
Tag Image File Format, originally released by Aldus Corporation is a standard file format found in most paint, imaging, and desktop publishing programs. TIFF is extremely powerful, flexible, and extensible. However, because of its many nuances and its wide scope, TIFF can be a difficult format to understand as well as a difficult format to support. ImagXpress™ supports a wide range of TIFF 6.0 formats including uncompressed, CCITT RLE, CCITT Group 3 Fax, CCITT Group 4 Fax, LZW, Pack Bits, JPEG, and deflate compression types. ImagXpress™ supports black and white, RGB, and RGB palette images but it does not support transparency mask, CMYK, YCbCr, or CIELab.

TWAIN
TWAIN (Technology Without An Interesting Name) is a standard for controlling and acquiring image data from raster-generating devices such as scanners, digital cameras, and video digitizers. Manufacturers write the TWAIN driver (called the Source) for their device. Applications that are TWAIN compliant can be used with any TWAIN compliant Source. Likewise, a TWAIN compliant Source can be used with any TWAIN compliant application. Applications that you build with ImagXpress™ can be used to interface TWAIN compliant Sources to acquire image data. TWAIN compliant applications should provide the following: The capability to select the Source. This is required because you may have more than one TWAIN device connected to a computer. Use the TWAINSelect method to select the source. The ability to acquire image data. Use the TWAINAcquire method to acquire the image data. If Pegasus' TWAIN Acquire method is successful, the image data is converted to a DIB and the control's hDIB property is set to the resulting DIB handle. Once the image is acquired, you may use any of the image processing methods to alter or save the DIB. The TWAIN sample in the SAMPLES directory and the ImagXpress™ Demo application demonstrate how easy it is to add TWAIN support to your applications.

twip
Twips describe the sizes of characters produced by dot matrix printers, which were constrained to multiples of either 12 or 10 dots per inch.

V

VCL
A application framework library for Microsoft Windows and Borland Software Corp.'s Delphi and C++Builder rapid application development software. VCL was originally designed for Delphi but is now also used for C++Builder. This replaces Object Windows Library (OWL) as Borland's Windows C++ framework of choice. VCL encapsulates the C-based Win32 API into a much easier to use, object-oriented form. Like its direct rival, Microsoft Foundation Class Library (MFC), VCL includes classes to create Windows programs. The VCL component class can be inherited to create new VCL components, which are the building blocks of Delphi and C++Builder applications. VCL components compete somewhat with ActiveX controls, though a VCL wrapper can be created to make an ActiveX control seem like a VCL component.

VOI
Value Of Interest

Void structure
Indicates a method that does not return a value; that is, the method has the void return type.

W

Wintel
A term describing the combination of Microsoft Windows operating system running on PCs with Intel or compatible processors. Dominance of the wintel platform began with MS-DOS on PCs with Intel's 8-bit 8088 processors in 1979.

WMF
The Microsoft Windows Metafile format is used to store vector and bitmap image data. Because of its popularity and wide use, many Windows and non-Windows applications support WMF.

WSQ
Wavelet Scalar Quantization (WSQ) Gray-Scale Fingerprint Image Compression Specification based on the results of the NIST (National Institute of Standards and Technology) review. The benefit of WSQ fingerprint-specific compression is reduced file size. A sample fingerprint with a resolution of 589 pixels by 605 pixels, 8-bit grayscale results in a file size of 325 KB when compressed with the standard lossless compression technology LZW.

X

XP
Microsoft says the Windows "XP" designation originates from the word "experience". Windows XP brings many features previously available only in the server- and workstation-oriented Windows NT and Windows 2000 families, such as greater stability and efficiency due to its pure 32-bit kernel, instead of the hybrid 16-bit/32-bit kernel in prior consumer versions of Windows. (The version number of Windows XP is 5.1 just as Windows 2000 was version 5.0, to denote two OS as descendants of Windows NT 4.0.)


Assembly Overview

Namespaces

Namespace | Description
PegasusImaging.WinForms.ThumbnailXpress2 |


Getting Started - PegasusImaging.WinForms.ThumbnailXpress2

PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Getting Started

© 2008, Pegasus Imaging Corporation, All Rights Reserved.


Introduction - PegasusImaging.WinForms.ThumbnailXpress2

PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Introduction

© 2008, Pegasus Imaging Corporation, All Rights Reserved.


ErrorEventArgs Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ErrorEventArgs Class Properties

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ErrorEventArgs Class

For a list of all members of this type, see ErrorEventArgs members.

Public Properties

Public Property ItemIndex | Gets and sets the index for the Thumbnail Item collection member which incurred an error during thumbnail generation.
Public Property Message | Gets and sets the error message for the Thumbnail item collection member which incurred an error during thumbnail generation.
Public Property Number | Gets and sets the error number for the Thumbnail Item collection member which incurred an error during thumbnail generation.

See Also

ErrorEventArgs Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


Filter Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Filter Class Properties

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : Filter Class

For a list of all members of this type, see Filter members.

Public Properties

Public Property CaseSensitive | Gets and sets an indicator if the filter file name matching case sensitivity is enabled.
Public Property Comparison | Gets and sets the filter comparison outcome criteria.
Public Property Enabled | Gets and sets an indicator to enable the filter status.
Public Property FileDate | Gets and sets the filter file date comparison value.
Public Property FilenamePattern | Gets and sets the filter filename matching pattern.
Public Property FileSize | Gets and sets the filter file size comparison value.
Public Property FilterName | Gets and sets the name of the filter.
Public Property IncludeHidden | Gets and sets the filter hidden files inclusion flag.
Public Property IncludeParentDirectory | Gets and sets the filter parent directory inclusion flag.
Public Property IncludeSubDirectory | Gets and sets the filter sub-directory inclusion flag.
Public Property MatchAppliesToDirectory | Gets and sets the filters match applies to directory flag.
Public Property Type | Gets and sets access to the filter type.

See Also

Filter Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


FilterCollection Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

FilterCollection Class Methods

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : FilterCollection Class

For a list of all members of this type, see FilterCollection members.

Public Methods

Public Method Add | Adds the provided filter item to the end of the collection.
Public Method Clear | This method clears all filters out of the collection.
Public Method Contains | Provides an indication as to whether the collection contains the given filter. The matching criteria is based on the filter name.
Public Method CopyTo | Copy the collection to an array of Filters.
Public Method GetEnumerator | Gets an enumerator for traversing the filters collection.
Public Method IndexOf | Returns the index of the given filter in the collection.
Public Method Insert | Inserts the provided filter item into the collection at the given index.
Public Method Remove | Removes the provided filter from the collection.
Public Method RemoveAt | Removes the filter at the given location in the collection.

See Also

FilterCollection Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


FilterCollection Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

FilterCollection Class Properties

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : FilterCollection Class

For a list of all members of this type, see FilterCollection members.

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count | Gets the number of filters in the collection.
Public Property IsFixedSize | Gets an indicator if the collection is a fixed size.
Public Property IsReadOnly | Gets an indicator if the collection access is read-only.
Public Property IsSynchronized | Gets an indicator whether synchronized (thread-safe) read-write access to the collection is available.
Public Property Item | Gets the filter object for the given collection index.
Public Property SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

FilterCollection Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


FilterCollectionEnumerator Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

FilterCollectionEnumerator Class Methods

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : FilterCollectionEnumerator Class

For a list of all members of this type, see FilterCollectionEnumerator members.

Public Methods

Public Method Lock | Locks the collection.
Public Method MoveNext | Moves the collection enumerator position/index by one if not at the end of the collection.
Public Method Reset | Resets the collection enumerator position/index to before the start of the collection.
Public Method Unlock | Unlocks the collection.

See Also

FilterCollectionEnumerator Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


FilterCollectionEnumerator Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

FilterCollectionEnumerator Class Properties

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : FilterCollectionEnumerator Class

For a list of all members of this type, see FilterCollectionEnumerator members.

Public Properties

Public Property Current Gets the Filter at the current enumerator position/index.

See Also

FilterCollectionEnumerator Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ItemCompleteEventArgs Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ItemCompleteEventArgs Class Properties

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ItemCompleteEventArgs Class

For a list of all members of this type, see ItemCompleteEventArgs members.

Public Properties

Public Property ItemIndex Gets and sets the index of the ThumbnailItemCollection member for which the thumbnail image generation has just completed.

See Also

ItemCompleteEventArgs Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


Licensing Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Licensing Class Methods

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : Licensing Class (PegasusImaging.WinForms.ThumbnailXpress2)

For a list of all members of this type, see Licensing members.

Public Methods

Public Method AccessPdfXpress | Overloaded. Method to find and load PDFXpress v1.x. This method should be used on a development machine that a PDFXpress v1.x development kit has been installed on.
Public Method AccessPdfXpress2 | Finds and loads PDF Xpress v2.x.
Public Method UnlockIXAddOn | This function has been deprecated.
Public Method UnlockIXRuntime | Unlocks the ImageXpress control for an instance of the ThumbnailXpress control in runtime environments.
Public Method UnlockPdfXpressRuntime | Unlocks the license for PDF Xpress v1.x or v2.x at runtime for use in distributed environments.
Public Method UnlockRuntime | Unlocks an instance of the ThumbnailXpress control for use in runtime environments.
Public Method UnlockWeb | Unlocks an instance of the ThumbnailXpress control for use on a web page for a specific URL.

See Also

Licensing Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


Licensing Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

Licensing Class Properties

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : Licensing Class (PegasusImaging.WinForms.ThumbnailXpress2)

For a list of all members of this type, see Licensing members.

Public Properties

Public Property EvaluationMode | Gets and sets the licensing trial/evaluation mode behavior.
Public Property IXLicenseEdition | Gets and sets the License Edition for the ImagXpress control used by ThumbnailXpress.

See Also

Licensing Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


LoadFromStreamEventArgs Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace | Item Property

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

LoadFromStreamEventArgs Class Properties

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : LoadFromStreamEventArgs Class

For a list of all members of this type, see LoadFromStreamEventArgs members.

Public Properties

Public Property Item Gets the ThumbnailItem object whose image data is to be loaded using a Stream.

See Also

LoadFromStreamEventArgs Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace | Item Property


SelectedThumbnailItemCollection Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

SelectedThumbnailItemCollection Class Methods

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : SelectedThumbnailItemCollection Class

For a list of all members of this type, see SelectedThumbnailItemCollection members.

Public Methods

Public Method Add | This method adds a new thumbnail item to the selected item collection. The display is updated if appropriate
Public Method Clear | This method clears all thumbnails out of the selected item collection. The display is updated if appropriate
Public Method Contains | This method provides an indication as to whether the selected item collection contains the given thumbnail. The matching criteria is based on the filename / pagenumber information.
Public Method CopyTo | Method to copy the selected item collection to an array of ThumbnailItems.
Public Method GetEnumerator | This method returns an enumerator for traversing the selected item collection.
Public Method IndexOf | This method returns the index of the given thumbnail in the selected item collection. The matching criteria is based on the filename / pagenumber information.
Public Method Insert | This method inserts the provided thumbnail item into the selected item collection at the given index. The display is updated if appropriate
Public Method Remove | This method removes the provided thumbnail from the selected item collection. The matching criteria is based on the filename / pagenumber information. The display is updated if appropriate
Public Method RemoveAt | This method removes the thumbnail at the given location in the selected item collection. The display is updated if appropriate

See Also

SelectedThumbnailItemCollection Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


SelectedThumbnailItemCollection Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

SelectedThumbnailItemCollection Class Properties

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : SelectedThumbnailItemCollection Class

For a list of all members of this type, see SelectedThumbnailItemCollection members.

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count | Read-only property returning the number of items in the selected item collection.
Public Property IsFixedSize | Read-only property returning whether the collection is a fixed size.
Public Property IsReadOnly | Read-only property returning whether the collection access is read-only.
Public Property IsSynchronized | Read only property returning whether synchronized (thread-safe) read-write access to the Collection is available. Will always return false. Use the SelectedThumbnailItemCollectionEnumerator and its Lock method to access the SelectedThumbnailItemCollection in a read-only thread safe manner.
Public Property Item | Read-only property returning the thumbnail item object from the given selected item collection index.
Public Property SyncRoot | Read-only property returning an object that can be used to synchronize access to the collection.

See Also

SelectedThumbnailItemCollection Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


SelectedThumbnailItemCollectionEnumerator Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

SelectedThumbnailItemCollectionEnumerator Class Methods

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : SelectedThumbnailItemCollectionEnumerator Class

For a list of all members of this type, see SelectedThumbnailItemCollectionEnumerator members.

Public Methods

Public Method Lock | Locks the selected item collection.
Public Method MoveNext | Advances the selected item collection enumerator position within the index by one if not at the end of the collection.
Public Method Reset | Resets the selected item collection position within the index to before the start of the collection.
Public Method Unlock | This method unlocks the selected item collection.

See Also

SelectedThumbnailItemCollectionEnumerator Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


SelectedThumbnailItemCollectionEnumerator Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

SelectedThumbnailItemCollectionEnumerator Class Properties

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : SelectedThumbnailItemCollectionEnumerator Class

For a list of all members of this type, see SelectedThumbnailItemCollectionEnumerator members.

Public Properties

Public Property Current Gets the selected ThumbnailItem at the current position within the index.

See Also

SelectedThumbnailItemCollectionEnumerator Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ThumbnailCache Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailCache Class Methods

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailCache Class (PegasusImaging.WinForms.ThumbnailXpress2)

For a list of all members of this type, see ThumbnailCache members.

Public Methods

Public Method CacheClear | Clears all items from the memory and disk cache.
Public Method CacheFlushMemory | Flushes all items from the memory cache to disk cache.

See Also

ThumbnailCache Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ThumbnailCache Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailCache Class Properties

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailCache Class (PegasusImaging.WinForms.ThumbnailXpress2)

For a list of all members of this type, see ThumbnailCache members.

Public Properties

Public Property CacheDiskLimit | Gets or sets the disk cache limit.
Public Property CacheFile | Read only property exposing access to the name of the cache file.
Public Property CacheFilePath | Gets or sets the path of the cache file.
Public Property CacheMemoryLimit | Gets or sets the memory cache limit.

See Also

ThumbnailCache Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ThumbnailItem Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailItem Class Methods

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailItem Class

For a list of all members of this type, see ThumbnailItem members.

Public Methods

Public Method DisposeHbitmap | Object method for the disposal of device dependent bitmap thumbnail images
Public Method FromStream | Object method allowing a Stream containing image data to be associated with the thumbnail item in place of specifying a filename/path containing the image data.
Public Method ToString | Overridden. Overridden object method returning a string value for the thumbnail item in the format of "ThumbnailItem[ item.Filename : item.PageNum ]"

See Also

ThumbnailItem Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ThumbnailItem Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailItem Class Properties

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailItem Class

For a list of all members of this type, see ThumbnailItem members.

Public Properties

Public Property Bitmap | Read-only property returning an System.Drawing.Bitmap object of the thumbnail image. Returns null if item is a directory.
Public Property CadLayoutCount | Read-only property returning the number of layouts contained in a CAD image file represented by the thumbnail item.
Public Property CadLayoutNumber | Read/Write property accessing the layout number in a CAD image file that the thumbnail item represents.
Public Property Descriptor | Read/write property accessing the descriptor text of the thumbnail item.
Public Property ErrorDescription | Read-only property potentially containing an error descripton string that may be associated with the thumbnail item.
Public Property ErrorNumber | Read-only property potentially returning an error number that may be associated with the thumbnail item. This value is 0 for no error
Public Property Filename | Read/write property accessing the file name and path or URL of the thumbnail item.
Public Property Hbitmap | Read-only property returning a handle to a device dependent bitmap copy of the thumbnail image. Returns null if item is a directory.
Public Property Hdib | Read-only property returning a handle to a device independent bitmap copy of the thumbnail image. Returns null if item is a directory.
Public Property MultiPage | Read-only property indicating whether the image file represented by the thumbnail item is a PDF, TIFF, ICO, Modca, or DCX image file that has been determined to contain multiple image pages.
Public Property Page | Read/Write property accessing the page number in a multi-page image file that the thumbnail item represents.
Public Property PageCount | Read-only property returning the number of image pages contained in the image file that the thumbnail item represents. Note that only PDF, TIFF, ICO, Modca, or DCX image files are able to have page counts greater than 1.
Public Property Status | Read-only property returning the status of the thumbnail item.
Public Property Type | Read-only property returning the image type or directory folder type of the thumbnail item.
Public Property UserTag | Read/Write property accessing an object that contains additional or associated data for this object.

See Also

ThumbnailItem Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ThumbnailItemCollection Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailItemCollection Class Methods

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailItemCollection Class

For a list of all members of this type, see ThumbnailItemCollection members.

Public Methods

Public Method Add | Overloaded. This method adds the provided ThumbnailItem to the end of the collection. The display is updated if appropriate. This menthod throws an exception if item is not a directory and item.Filename specifies an invalid, unsupported, or non-existent file.
Public Method AddItemFromStream | Adds the provided ThumbnailItem to the end of the collection. The display is updated if appropriate. Rather than obtaining its image data from a supplied filename/path, the image data will be expected to be provided by a Stream object.
Public Method AddItemsFromDirectory | Adds thumbnail items to the collection from the provided directory.
Public Method AddItemsFromFile | Adds a thumbnail item from a single-page image or optionally multiple items (one per page) from a multi-page image to the collection from the provided image file.
Public Method Clear | This method clears all thumbnails out of the collection. The display is updated.
Public Method Contains | This method provides an indication as to whether the collection contains the given ThumbnailItem. The matching criteria is based on the filename / pagenumber information.
Public Method CopyTo | Copy the collection to an array of ThumbnailItems.
Public Method GetEnumerator | Returns an enumerator for traversing the collection.
Public Method IndexOf | This method returns the index of the given ThumbnailItem in the collection. The matching criteria is based on the filename / pagenumber information.
Public Method Insert | Overloaded. This method inserts the provided ThumbnailItem into the collection at the given index. The display is updated if appropriate. This menthod throws an exception if item is not a directory and item.Filename specifies an invalid, unsupported, or non-existent file.
Public Method InsertItemFromStream | This method inserts the provided ThumbnailItem into the collection at the given index. The display is updated if appropriate. Rather than obtaining its image data from a supplied filename/path, the image data will be expected to be provided by a Stream object.
Public Method Refresh | This method Refreshes the contents of the thumbnail collection. When the contents of a directory or multi-page image file have changed, Refresh can be used to update the items in the thumbnail collection. Refresh is limited in that it can only be used when a collection is created from a directory or a multi-page image file
Public Method Remove | This method removes the provided ThumbnailItem from the collection. The matching criteria is based on the filename / pagenumber information. The display is updated if appropriate
Public Method RemoveAt | This method removes the thumbnail item at the given location in the collection. The display is updated if appropriate

See Also

ThumbnailItemCollection Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ThumbnailItemCollection Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailItemCollection Class Properties

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailItemCollection Class

For a list of all members of this type, see ThumbnailItemCollection members.

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count | Gets the number of items in the collection.
Public Property IsFixedSize | Read-only property returning whether the collection is a fixed size.
Public Property IsReadOnly | Read-only property returning whether the collection access is read-only.
Public Property IsSynchronized | Read only property returning whether synchronized (thread-safe) read-write access to the Collection is available. Will always return false. Use the ThumbnailItemCollectionEnumerator and its Lock method to access the ThumbnailItemCollection in a read-only thread safe manner.
Public Property Item | Read-only property returning the ThumbnailItem object from the given collection index.
Public Property SyncRoot | Read-only property returning an object that can be used to synchronize access to the collection.

See Also

ThumbnailItemCollection Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ThumbnailItemCollectionEnumerator Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailItemCollectionEnumerator Class Methods

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailItemCollectionEnumerator Class

For a list of all members of this type, see ThumbnailItemCollectionEnumerator members.

Public Methods

Public Method Lock | Locks the collection.
Public Method MoveNext | This method advances the collection enumerator position/index by one if not at the end of the collection.
Public Method Reset | Resets the collection index to before the start of the collection.
Public Method Unlock | Unlocks the collection.

See Also

ThumbnailItemCollectionEnumerator Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ThumbnailItemCollectionEnumerator Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailItemCollectionEnumerator Class Properties

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailItemCollectionEnumerator Class

For a list of all members of this type, see ThumbnailItemCollectionEnumerator members.

Public Properties

Public Property Current Gets the ThumbnailItem at the current enumerator index.

See Also

ThumbnailItemCollectionEnumerator Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ThumbnailXpress Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailXpress Class Events

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailXpress Class

For a list of all members of this type, see ThumbnailXpress members.

Public Events

Public Event AutoSizeChanged (Inherited from System.Windows.Forms.UserControl) |
Public Event AutoValidateChanged (Inherited from System.Windows.Forms.UserControl) | Occurs when the AutoValidate property changes.
Public Event BackColorChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the BackColor property changes.
Public Event BackgroundImageChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the BackgroundImage property changes.
Public Event BackgroundImageLayoutChanged (Inherited from System.Windows.Forms.Control) | Occurs when the BackgroundImageLayout property changes.
Public Event BindingContextChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the BindingContext property changes.
Public Event CausesValidationChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the CausesValidation property changes.
Public Event ChangeUICues (Inherited from System.Windows.Forms.Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Public Event Click (Inherited from System.Windows.Forms.Control) | Occurs when the control is clicked.
Public Event ClientSizeChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the ClientSize property changes.
Public Event ContextMenuChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the ContextMenu property changes.
Public Event ContextMenuStripChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the ContextMenuStrip property changes.
Public Event ControlAdded (Inherited from System.Windows.Forms.Control) | Occurs when a new control is added to the ControlCollection.
Public Event ControlRemoved (Inherited from System.Windows.Forms.Control) | Occurs when a control is removed from the ControlCollection.
Public Event CursorChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the Cursor property changes.
Public Event Disposed (Inherited from System.ComponentModel.Component) | Adds an event handler to listen to the Disposed event on the component.
Public Event DockChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the Dock property changes.
Public Event DoubleClick (Inherited from System.Windows.Forms.Control) | Occurs when the control is double-clicked.
Public Event DragDrop (Inherited from System.Windows.Forms.Control) | Occurs when a drag-and-drop operation is completed.
Public Event DragEnter (Inherited from System.Windows.Forms.Control) | Occurs when an object is dragged into the control's bounds.
Public Event DragLeave (Inherited from System.Windows.Forms.Control) | Occurs when an object is dragged out of the control's bounds.
Public Event DragOver (Inherited from System.Windows.Forms.Control) | Occurs when an object is dragged over the control's bounds.
Public Event EnabledChanged (Inherited from System.Windows.Forms.Control) | Occurs when the Enabled property value has changed.
Public Event Enter (Inherited from System.Windows.Forms.Control) | Occurs when the control is entered.
Public Event Error | Event which is called when an error occurs during generation or painting of a thumbnail item.
Public Event FontChanged (Inherited from System.Windows.Forms.Control) | Occurs when the Font property value changes.
Public Event ForeColorChanged (Inherited from System.Windows.Forms.Control) | Occurs when the ForeColor property value changes.
Public Event GiveFeedback (Inherited from System.Windows.Forms.Control) | Occurs during a drag operation.
Public Event GotFocus (Inherited from System.Windows.Forms.Control) | Occurs when the control receives focus.
Public Event HandleCreated (Inherited from System.Windows.Forms.Control) | Occurs when a handle is created for the control.
Public Event HandleDestroyed (Inherited from System.Windows.Forms.Control) | Occurs when the control's handle is in the process of being destroyed.
Public Event HelpRequested (Inherited from System.Windows.Forms.Control) | Occurs when the user requests help for a control.
Public Event ImeModeChanged (Inherited from System.Windows.Forms.Control) | Occurs when the ImeMode property has changed.
Public Event Invalidated (Inherited from System.Windows.Forms.Control) | Occurs when a control's display requires redrawing.
Public Event ItemComplete | Event which is called when a thumbnail item's asynchronous image generation has been completed. Review the the thumbnail item collection information about how thumbnail items are added to the collection, where the items are generated asynchronously.
Public Event KeyDown (Inherited from System.Windows.Forms.Control) | Occurs when a key is pressed while the control has focus.
Public Event KeyPress (Inherited from System.Windows.Forms.Control) | Occurs when a key is pressed while the control has focus.
Public Event KeyUp (Inherited from System.Windows.Forms.Control) | Occurs when a key is released while the control has focus.
Public Event Layout (Inherited from System.Windows.Forms.Control) | Occurs when a control should reposition its child controls.
Public Event Leave (Inherited from System.Windows.Forms.Control) | Occurs when the input focus leaves the control.
Public Event Load (Inherited from System.Windows.Forms.UserControl) | Occurs before the control becomes visible for the first time.
Public Event LoadFromStream | This event is called when the component requires the application to provide a Stream object containing image data for a thumbnail item.
Public Event LocationChanged (Inherited from System.Windows.Forms.Control) | Occurs when the Location property value has changed.
Public Event LostFocus (Inherited from System.Windows.Forms.Control) | Occurs when the control loses focus.
Public Event MarginChanged (Inherited from System.Windows.Forms.Control) | Occurs when the control's margin changes.
Public Event MouseCaptureChanged (Inherited from System.Windows.Forms.Control) | Occurs when the control loses mouse capture.
Public Event MouseClick (Inherited from System.Windows.Forms.Control) | Occurs when the control is clicked by the mouse.
Public Event MouseDoubleClick (Inherited from System.Windows.Forms.Control) | Occurs when the control is double clicked by the mouse.
Public Event MouseDown (Inherited from System.Windows.Forms.Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
Public Event MouseEnter (Inherited from System.Windows.Forms.Control) | Occurs when the mouse pointer enters the control.
Public Event MouseHover (Inherited from System.Windows.Forms.Control) | Occurs when the mouse pointer rests on the control.
Public Event MouseLeave (Inherited from System.Windows.Forms.Control) | Occurs when the mouse pointer leaves the control.
Public Event MouseMove (Inherited from System.Windows.Forms.Control) | Occurs when the mouse pointer is moved over the control.
Public Event MouseUp (Inherited from System.Windows.Forms.Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Public Event MouseWheel (Inherited from System.Windows.Forms.Control) | Occurs when the mouse wheel moves while the control has focus.
Public Event Move (Inherited from System.Windows.Forms.Control) | Occurs when the control is moved.
Public Event PaddingChanged (Inherited from System.Windows.Forms.Control) | Occurs when the control's padding changes.
Public Event Paint (Inherited from System.Windows.Forms.Control) | Occurs when the control is redrawn.
Public Event ParentChanged (Inherited from System.Windows.Forms.Control) | Occurs when the Parent property value changes.
Public Event PreviewKeyDown (Inherited from System.Windows.Forms.Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
Public Event QueryAccessibilityHelp (Inherited from System.Windows.Forms.Control) | Occurs when AccessibleObject is providing help to accessibility applications.
Public Event QueryContinueDrag (Inherited from System.Windows.Forms.Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
Public Event RegionChanged (Inherited from System.Windows.Forms.Control) | Occurs when the value of the Region property changes.
Public Event Resize (Inherited from System.Windows.Forms.Control) | Occurs when the control is resized.
Public Event RightToLeftChanged (Inherited from System.Windows.Forms.Control) | Occurs when the RightToLeft property value changes.
Public Event Scroll (Inherited from System.Windows.Forms.ScrollableControl) | Occurs when the user or code scrolls through the client area.
Public Event SelectedIndexChanged | Event which is called when a thumbnail item is selected using the user interface.
Public Event SizeChanged (Inherited from System.Windows.Forms.Control) | Occurs when the Size property value changes.
Public Event StyleChanged (Inherited from System.Windows.Forms.Control) | Occurs when the control style changes.
Public Event SystemColorsChanged (Inherited from System.Windows.Forms.Control) | Occurs when the system colors change.
Public Event TabIndexChanged (Inherited from System.Windows.Forms.Control) | Occurs when the TabIndex property value changes.
Public Event TabStopChanged (Inherited from System.Windows.Forms.Control) | Occurs when the TabStop property value changes.
Public Event Validated (Inherited from System.Windows.Forms.Control) | Occurs when the control is finished validating.
Public Event Validating (Inherited from System.Windows.Forms.Control) | Occurs when the control is validating.
Public Event VisibleChanged (Inherited from System.Windows.Forms.Control) | Occurs when the Visible property value changes.

See Also

ThumbnailXpress Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ThumbnailXpress Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailXpress Class Methods

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailXpress Class

For a list of all members of this type, see ThumbnailXpress members.

Public Methods

Public Method AboutBox | Displays an AboutBox showing general information about this component.
Public Method BeginInvoke (Inherited from System.Windows.Forms.Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
Public Method BeginUpdate | This method disables control repainting.
Public Method BringToFront (Inherited from System.Windows.Forms.Control) | Brings the control to the front of the z-order.
Public Method Cancel | Cancels all pending thumbnail item image generation requests.
Public Method Contains (Inherited from System.Windows.Forms.Control) | Retrieves a value indicating whether the specified control is a child of the control.
Public Method CreateControl (Inherited from System.Windows.Forms.Control) | Forces the creation of the control, including the creation of the handle and any child controls.
Public Method CreateFilter | This is the method that a user would use to create a new uninitialized filter.
Public Method CreateGraphics (Inherited from System.Windows.Forms.Control) | Creates the Graphics for the control.
Public Method CreateObjRef (Inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Public Method CreateThumbnailItem | Creates a thumbnail and adds it to the collection of thumbnail items.
Public Method Dispose (Inherited from System.ComponentModel.Component) | Releases all resources used by the Component.
Public Method DoDragDrop (Inherited from System.Windows.Forms.Control) | Begins a drag-and-drop operation.
Public Method DrawToBitmap (Inherited from System.Windows.Forms.Control) | Supports rendering to the specified bitmap.
Public Method EndInvoke (Inherited from System.Windows.Forms.Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Public Method EndUpdate | Enables control repainting and is used in conjunction with the BeginUpdate method.
Public Method EnsureVisible | Adjusts the display so that the thumbnail of the given index is visible.
Public Method FindForm (Inherited from System.Windows.Forms.Control) | Retrieves the form that the control is on.
Public Method Focus (Inherited from System.Windows.Forms.Control) | Sets input focus to the control.
Public Method GetChildAtPoint (Inherited from System.Windows.Forms.Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
Public Method GetContainerControl (Inherited from System.Windows.Forms.Control) | Returns the next ContainerControl up the control's chain of parent controls.
Public Method GetItemFromPoint | Overloaded. Returns the thumbnail item containing the window point provided.
Public Method GetItemRectangle | Returns the rectangle of the Thumbnail identified by the provided index.
Public Method GetLifetimeService (Inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Public Method GetNextControl (Inherited from System.Windows.Forms.Control) | Retrieves the next control forward or back in the tab order of child controls.
Public Method GetPreferredSize (Inherited from System.Windows.Forms.Control) | Retrieves the size of a rectangular area into which a control can be fitted.
Public Method Hide (Inherited from System.Windows.Forms.Control) | Conceals the control from the user.
Public Method InitializeLifetimeService (Inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Public Method Invalidate (Inherited from System.Windows.Forms.Control) | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn.
Public Method Invoke (Inherited from System.Windows.Forms.Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
Public Method PerformAutoScale (Inherited from System.Windows.Forms.ContainerControl) | Performs scaling of the container control and its children.
Public Method PerformLayout (Inherited from System.Windows.Forms.Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
Public Method PointToClient (Inherited from System.Windows.Forms.Control) | Computes the location of the specified screen point into client coordinates.
Public Method PointToScreen (Inherited from System.Windows.Forms.Control) | Computes the location of the specified client point into screen coordinates.
Public Method PostInitialize | This function is Obsolete, there is no value of calling it. This will be removed in ThumbnailXpress v3.
Public Method PreProcessControlMessage (Inherited from System.Windows.Forms.Control) |
Public Method PreProcessMessage (Inherited from System.Windows.Forms.Control) |
Public Method RectangleToClient (Inherited from System.Windows.Forms.Control) | Computes the size and location of the specified screen rectangle in client coordinates.
Public Method RectangleToScreen (Inherited from System.Windows.Forms.Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Public Method Refresh (Inherited from System.Windows.Forms.Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
Public Method ResetAllCanceledItems | Resets the status for all items in the thumbnail collection whose image generation requests were canceled by the user.
Public Method ResetCanceledItem | Resets the status for an item in the thumbnail collection whose image generation request was canceled by the user.
Public Method ResetText (Inherited from System.Windows.Forms.Control) | Resets the Text property to its default value.
Public Method ResumeLayout (Inherited from System.Windows.Forms.Control) | Overloaded. Resumes usual layout logic.
Public Method ScrollControlIntoView (Inherited from System.Windows.Forms.ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Public Method ScrollItems | Provides programmatic scrolling of the display.
Public Method Select (Inherited from System.Windows.Forms.Control) | Activates the control.
Public Method SelectNextControl (Inherited from System.Windows.Forms.Control) | Activates the next control.
Public Method SendToBack (Inherited from System.Windows.Forms.Control) | Sends the control to the back of the z-order.
Public Method SetAutoScrollMargin (Inherited from System.Windows.Forms.ScrollableControl) | Sets the size of the auto-scroll margins.
Public Method SetBounds (Inherited from System.Windows.Forms.Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Public Method Show (Inherited from System.Windows.Forms.Control) | Displays the control to the user.
Public Method ShowScrollBar | Shows or hides the scrollbar.
Public Method SuspendLayout (Inherited from System.Windows.Forms.Control) | Temporarily suspends the layout logic for the control.
Public Method ToString (Inherited from System.ComponentModel.Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Public Method Update (Inherited from System.Windows.Forms.Control) | Causes the control to redraw the invalidated regions within its client area.
Public Method Validate (Inherited from System.Windows.Forms.ContainerControl) | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
Public Method ValidateChildren (Inherited from System.Windows.Forms.UserControl) | Overloaded.

See Also

ThumbnailXpress Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ThumbnailXpress Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailXpress Class Properties

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailXpress Class

For a list of all members of this type, see ThumbnailXpress members.

Public Properties

Public Property AccessibilityObject (Inherited from System.Windows.Forms.Control) | Gets the AccessibleObject assigned to the control.
Public Property AccessibleDefaultActionDescription (Inherited from System.Windows.Forms.Control) | Gets or sets the default action description of the control for use by accessibility client applications.
Public Property AccessibleDescription (Inherited from System.Windows.Forms.Control) | Gets or sets the description of the control used by accessibility client applications.
Public Property AccessibleName (Inherited from System.Windows.Forms.Control) | Gets or sets the name of the control used by accessibility client applications.
Public Property AccessibleRole (Inherited from System.Windows.Forms.Control) | Gets or sets the accessible role of the control
Public Property ActiveControl (Inherited from System.Windows.Forms.ContainerControl) | Gets or sets the active control on the container control.
Public Property AllowDrop | This generic control property has been replaced by four new properties specific to ThumbnailXpress2 that allow a finer granularity of control over the types of drag/drop operations the control will allow. The new properties are: IntraComponentThumbnailDragDropEnabled, InterComponentThumbnailDragDropEnabled, EnableAsDragSourceForExternalDragDrop, and EnableAsDropTargetForExternalDragDrop
Public Property Anchor (Inherited from System.Windows.Forms.Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Public Property AutoScaleDimensions (Inherited from System.Windows.Forms.ContainerControl) | Gets or sets the dimensions that the control was designed to.
Public Property AutoScaleMode (Inherited from System.Windows.Forms.ContainerControl) | Gets or sets the automatic scaling mode of the control.
Public Property AutoScroll (Inherited from System.Windows.Forms.ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
Public Property AutoScrollMargin (Inherited from System.Windows.Forms.ScrollableControl) | Gets or sets the size of the auto-scroll margin.
Public Property AutoScrollMinSize (Inherited from System.Windows.Forms.ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
Public Property AutoScrollOffset (Inherited from System.Windows.Forms.Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
Public Property AutoScrollPosition (Inherited from System.Windows.Forms.ScrollableControl) | Gets or sets the location of the auto-scroll position.
Public Property AutoSize (Inherited from System.Windows.Forms.UserControl) |
Public Property AutoSizeMode (Inherited from System.Windows.Forms.UserControl) | Gets or sets how the control will resize itself.
Public Property AutoValidate (Inherited from System.Windows.Forms.UserControl) | Gets or sets how the control performs validation when the user changes focus to another control.
Public Property BackColor | Overridden. Gets and sets the controls unselected items cell background color.
Public Property BackgroundImage (Inherited from System.Windows.Forms.Control) | Gets or sets the background image displayed in the control.
Public Property BackgroundImageLayout (Inherited from System.Windows.Forms.Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
Public Property BindingContext (Inherited from System.Windows.Forms.ContainerControl) |
Public Property BorderStyle | Gets and sets the control's border style.
Public Property Bottom (Inherited from System.Windows.Forms.Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Public Property BottomMargin | Gets and sets the margin on the bottom most side of the control.
Public Property Bounds (Inherited from System.Windows.Forms.Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
Public Property CameraRaw | Gets and sets enabling or disabling of the camera raw image type detection algorithms during thumbnail image generation.
Public Property CanFocus (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control can receive focus.
Public Property CanSelect (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control can be selected.
Public Property Capture (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether the control has captured the mouse.
Public Property CausesValidation (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
Public Property CellBorderColor | Gets and sets the border color of the cells in the control.
Public Property CellBorderWidth | Gets and sets the width of the cells in the control.
Public Property CellHeight | Gets and sets the height of the cells in the control.
Public Property CellHorizontalSpacing | Gets and sets the spacing between columns.
Public Property CellSpacingColor | Gets and sets the controls cell spacing color.
Public Property CellVerticalSpacing | Gets and sets the spacing between the rows in the control.
Public Property CellWidth | Gets and sets the width of the cells in the control.
Public Property ClientRectangle (Inherited from System.Windows.Forms.Control) | Gets the rectangle that represents the client area of the control.
Public Property ClientSize (Inherited from System.Windows.Forms.Control) | Gets or sets the height and width of the client area of the control.
Public Property CompanyName (Inherited from System.Windows.Forms.Control) | Gets the name of the company or creator of the application containing the control.
Public Property Container (Inherited from System.ComponentModel.Component) | Gets the IContainer that contains the Component.
Public Property ContainsFocus (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
Public Property ContextMenu (Inherited from System.Windows.Forms.Control) | Gets or sets the shortcut menu associated with the control.
Public Property ContextMenuStrip (Inherited from System.Windows.Forms.Control) | Gets or sets the ContextMenuStrip associated with this control.
Public Property Controls (Inherited from System.Windows.Forms.Control) | Gets the collection of controls contained within the control.
Public Property Created (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control has been created.
Public Property CurrentAutoScaleDimensions (Inherited from System.Windows.Forms.ContainerControl) | Gets the current run-time dimensions of the screen.
Public Property Cursor (Inherited from System.Windows.Forms.Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Public Property DataBindings (Inherited from System.Windows.Forms.Control) | Gets the data bindings for the control.
Public Property DblClickDirectoryDrillDown | Gets and sets enabling or disabling directory navigation initiated by double-clicking on directory place holder thumbnail images.
Public Property Debug | Gets and sets the on/off state of the logging system.
Public Property DebugErrorLevel | Gets and sets the level of detail written to the error log.
Public Property DebugLogFile | Gets and sets the log file location.
Public Property DescriptorAlignment | Gets and sets the alignment of the descriptor text.
Public Property DescriptorDisplayMethod | Gets and sets the method allowing selection of the source of the descriptor text content.
Public Property DisplayRectangle | Overridden. Gets the current area being displayed.
Public Property Disposing (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Public Property Dock (Inherited from System.Windows.Forms.Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
Public Property EnableAsDragSourceForExternalDragDrop | Gets and sets enabling or disabling the component acting as a drag source for dragging thumbnail images to other applications. Any application that supports acting as a drop target for the CF_DIB clipboard/drag-drop format can be a thumnbnail image drop recipient.
Public Property EnableAsDropTargetForExternalDragDrop | Gets and sets enabling or disabling the component acting as a drop target for other applications to drag files onto the component to display those files as thumbnail images.
Public Property Enabled (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Public Property ErrorAction |
Public Property ErrorLevel | Gets and sets the level of detail written to the error log.
Public Property Filters | Gets the FilterCollection object to access a collection of filters.
Public Property Focused (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control has input focus.
Public Property Font | Overridden. Gets and sets the thumbnail descriptor font.
Public Property ForeColor | Overridden. Gets and sets the controls foreground color.
Public Property FtpPassword | Gets and sets the FTP password.
Public Property FtpUserName | Gets and sets the FTP user name.
Public Property Handle (Inherited from System.Windows.Forms.Control) | Gets the window handle that the control is bound to.
Public Property HasChildren (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control contains one or more child controls.
Public Property Height (Inherited from System.Windows.Forms.Control) | Gets or sets the height of the control.
Public Property HorizontalScroll (Inherited from System.Windows.Forms.ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
Public Property ImeMode (Inherited from System.Windows.Forms.Control) | Gets or sets the Input Method Editor (IME) mode of the control.
Public Property InterComponentThumbnailDragDropEnabled | Gets and sets enabling or disabling the component acting as a drag source or drop target for thumbnail image drag and drop operations between other instances of the ThumbnailXpress component.
Public Property IntraComponentThumbnailDragDropEnabled | Gets and sets enabling or disabling support of drag and drop move operations amongst thumbnail images in the same instance of a ThumbnailXpress component.
Public Property InvokeRequired (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
Public Property IsAccessible (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
Public Property IsDisposed (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control has been disposed of.
Public Property IsHandleCreated (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control has a handle associated with it.
Public Property IsMirrored (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control is mirrored.
Public Property Items | Gets the ThumbnailItemCollection object to access a collection of thumbnail items.
Public Property LayoutEngine (Inherited from System.Windows.Forms.Control) | Gets a cached instance of the control's layout engine.
Public Property Left (Inherited from System.Windows.Forms.Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Public Property LeftMargin | Gets and sets the margin on the left most side of the control.
Public Property Licensing | Gets the Licensing object to allow user to license ThumbnailXpress.
Public Property Location (Inherited from System.Windows.Forms.Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Public Property Margin (Inherited from System.Windows.Forms.Control) | Gets or sets the space between controls.
Public Property MaximumSize (Inherited from System.Windows.Forms.Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
Public Property MaximumThreadCount | Gets and sets the maximum number of concurrent worker threads allowed for thumbnail bitmap generation.
Public Property MaximumThumbnailBitDepth | Gets and sets the maximum bit-depth allowed for the thumbnails.
Public Property MinimumSize (Inherited from System.Windows.Forms.Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Public Property Name (Inherited from System.Windows.Forms.Control) | Gets or sets the name of the control.
Public Property Padding (Inherited from System.Windows.Forms.Control) | Gets or sets padding within the control.
Public Property Parent (Inherited from System.Windows.Forms.Control) | Gets or sets the parent container of the control.
Public Property ParentForm (Inherited from System.Windows.Forms.ContainerControl) | Gets the form that the container control is assigned to.
Public Property PreferredSize (Inherited from System.Windows.Forms.Control) | Gets the size of a rectangular area into which the control can fit.
Public Property PreserveBlack | Gets and sets enabling or disabling the PreserveBlack algorithms during thumbnail image generation.
Public Property ProductName (Inherited from System.Windows.Forms.Control) | Gets the product name of the assembly containing the control.
Public Property ProductVersion (Inherited from System.Windows.Forms.Control) | Gets the version of the assembly containing the control.
Public Property ProxyServer | Gets and sets the name or IP address of an optional proxy server.
Public Property RecreatingHandle (Inherited from System.Windows.Forms.Control) | Gets a value indicating whether the control is currently re-creating its handle.
Public Property Region (Inherited from System.Windows.Forms.Control) | Gets or sets the window region associated with the control.
Public Property Right (Inherited from System.Windows.Forms.Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
Public Property RightMargin | Gets and sets the margin on the right most side of the control.
Public Property RightToLeft (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Public Property ScrollDirection | Gets and sets the current direction of scrolling.
Public Property SelectBackColor | Gets and sets the controls selected items cell background color.
Public Property SelectedItems | Gets the SelectedThumbnailItemCollection object to access a collection of selected thumbnail items.
Public Property SelectionMode | Gets and sets the controls items selection modes.
Public Property ShowHourglass | Gets and sets the displaying of an hourglass cursor when thumbnail images are being loaded from a directory or file.
Public Property ShowImagePlaceholders | Gets and sets the display of a pre-image-generation 'placeholder' icon.
Public Property Site (Inherited from System.Windows.Forms.Control) | Gets or sets the site of the control.
Public Property Size (Inherited from System.Windows.Forms.Control) | Gets or sets the height and width of the control.
Public Property TabIndex (Inherited from System.Windows.Forms.Control) | Gets or sets the tab order of the control within its container.
Public Property TabStop (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Public Property Tag (Inherited from System.Windows.Forms.Control) | Gets or sets the object that contains data about the control.
Public Property TextBackColor | Gets and sets the controls descriptor text background color.
Public Property ThreadHungThreshold | Gets and sets the elapsed time threshold (in milleseconds) beyond which a request to obtain a thumbnail should be abandoned.
Public Property ThreadStartThreshold | Gets and sets the elapsed time threshold (in milleseconds) beyond which a request to obtain a thumbnail should be considered of "extended duration".
Public Property ThumbnailCache | Gets and sets the thumbnail cache object to adjust cache settings.
Public Property Top (Inherited from System.Windows.Forms.Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
Public Property TopLevelControl (Inherited from System.Windows.Forms.Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Public Property TopMargin | Gets and sets the margin on the top most side of the control.
Public Property TopVisibleItem | Gets the thumbnail item of the top-most visible thumbnail item.
Public Property UseWaitCursor (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Public Property VerticalScroll (Inherited from System.Windows.Forms.ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Public Property Visible (Inherited from System.Windows.Forms.Control) | Gets or sets a value indicating whether the control is displayed.
Public Property VisibleColumnCount | Gets the number of visible thumbnail columns.
Public Property VisibleRowCount | Gets the number of visible thumbnail rows.
Public Property Width (Inherited from System.Windows.Forms.Control) | Gets or sets the width of the control.

See Also

ThumbnailXpress Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ThumbnailXpressException Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailXpressException Class Methods

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailXpressException Class

For a list of all members of this type, see ThumbnailXpressException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ThumbnailXpressException Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


ThumbnailXpressException Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

ThumbnailXpressException Class Properties

PegasusImaging.WinForms.ThumbnailXpress2 Namespace : ThumbnailXpressException Class

For a list of all members of this type, see ThumbnailXpressException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number | Gets the error number from the last call.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

ThumbnailXpressException Class | PegasusImaging.WinForms.ThumbnailXpress2 Namespace


PegasusImaging.WinForms.ThumbnailXpress2 Assembly

See Also PegasusImaging.WinForms.ThumbnailXpress2 Send comments on this topic.

PegasusImaging.WinForms.ThumbnailXpress2 Namespace Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.ThumbnailXpress2.Filter
PegasusImaging.WinForms.ThumbnailXpress2.FilterCollectionEnumerator
PegasusImaging.WinForms.ThumbnailXpress2.Licensing
PegasusImaging.WinForms.ThumbnailXpress2.SelectedThumbnailItemCollectionEnumerator
PegasusImaging.WinForms.ThumbnailXpress2.ThumbnailCache
PegasusImaging.WinForms.ThumbnailXpress2.ThumbnailItem
PegasusImaging.WinForms.ThumbnailXpress2.ThumbnailItemCollectionEnumerator
PegasusImaging.WinForms.ThumbnailXpress2.ThumbnailXpressEvents
System.Collections.CollectionBase
PegasusImaging.WinForms.ThumbnailXpress2.FilterCollection
PegasusImaging.WinForms.ThumbnailXpress2.SelectedThumbnailItemCollection
PegasusImaging.WinForms.ThumbnailXpress2.ThumbnailItemCollection
System.EventArgs
PegasusImaging.WinForms.ThumbnailXpress2.ErrorEventArgs
PegasusImaging.WinForms.ThumbnailXpress2.ItemCompleteEventArgs
PegasusImaging.WinForms.ThumbnailXpress2.LoadFromStreamEventArgs
System.Exception
PegasusImaging.WinForms.ThumbnailXpress2.ThumbnailXpressException
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
PegasusImaging.WinForms.ThumbnailXpress2.ThumbnailXpress

See Also

PegasusImaging.WinForms.ThumbnailXpress2 Namespace | PegasusImaging.WinForms.ThumbnailXpress2 Assembly