What is TwainPRO?

TwainPRO™, Version 5 is a windowless control that enables creation of sophisticated TWAIN compliant imaging applications.

The TwainPRO control is designed to communicate with any acquisition device that supplies a standard TWAIN device driver. This includes devices such as flatbed scanners, handheld scanners, and digital cameras.

TwainPRO supports multiple image transfers and is compliant with TWAIN v1.9.

New Features in Version 5

  • New object-oriented .NET interface
  • Access to device’s capability settings and config dialog
  • Ability to maintain scanner settings for each session
  • JPG, JBIG2, TIFF-G4 compression types added to PDF save
  • TIFF write optimization (faster to write large multi-page TIFFs)
  • TW_STR32 type support
  • Save to Stream support

Primary Features Include

  • TWAIN data source selection and image acquisition
  • Option to select data source and acquire image without TWAIN user interface
  • TWAIN capability negotiation for all TWAIN Version 1.9 capabilities
  • File export including: TIFF, Bitmap, JPEG, PIC and PDF (encoded as TIFF, JBIG2, SequentialJPEG)
  • FTP transfer of file exports
See Also

Getting Support and Samples | License Agreement | Operating Requirements

© 2008, Pegasus Imaging Corporation, All Rights Reserved.


What is The ImagXpress Product Family?

ImagXpress® Version 9 is Pegasus Imaging Corporation’s comprehensive image processing toolkit designed for document imaging, medical imaging, and photo imaging application development. The ImagXpress v9 Product Family includes the following Components:

  • ImagXpress v9 – image compression, decompression, viewing, and processing
  • NotateXpress™ v9 – image annotation support
  • ThumbnailXpress™ v2 – thumbnail image support
  • TwainPRO™ v5 – TWAIN image acquisition support
  • PrintPRO™ v4 – image printing support

ImagXpress Editions: The components within the ImagXpress v9 Product Family are available in four editions, designed to meet specific imaging needs:

  • Photo: includes ImagXpress, NotateXpress, TwainPRO, PrintPRO, and ThumbnailXpress
  • Document: includes ImagXpress, NotateXpress, TwainPRO, PrintPRO, and ThumbnailXpress
  • View: Includes ImagXpress, NotateXpress, PrintPRO, and ThumbnailXpress
  • Standard: Includes ImagXpress and TwainPRO

Additional Pegasus Imaging Components: Additional components are available for purchase separately, and integrate easily with to provide a comprehensive imaging solution:

  • PDFXpress™ – PDF creation, viewing, and annotating
  • OCRXpress™ – full page OCR
  • Barcode Xpress™ – recognize barcodes
  • ScanFix Xpress™ – advanced image cleanup
  • FormFix™ – form ID, dropout, and OMR
  • SmartZone™ ICR / OCR – character recognition

See www.PegasusImaging.com for product packaging and sales information.

See Also

Getting Support and Samples | License Agreement | Operating Requirements


Getting Support and Samples

Benefits of Registering your Pegasus Development Kit

Purchasers of development kits need to register with Pegasus in order to be notified of updates and receive support now or in the future. Registration is automatic when purchased directly from the Pegasus web site. If purchased through a Pegasus re-seller, please register your purchase by filling out the form at www.PegasusImaging.com/registration.htm.

Vehicles for Support

Samples

Samples are included in the downloaded installation.

The product installation program installs a common sample folder accessible via the Start Menu.

Samples for the .NET framework:

  • Microsoft VisualBasic.Net
  • Microsoft C#

Access the Samples

  • Through the Windows Start menu: Start | Programs | Pegasus Imaging | TwainPRO | Samples
  • Sample image files included

Sample Code Newsgroups

Customers create samples of great benefit to other developers, so we created a Sample Code Newsgroup. This is a newsgroup for our customers and potential customers. They post and receive sample code from our development team and other developers to expedite their development. Go online at: www.PegasusImaging.com/samplecode.htm

Web Support

Visit the Pegasus Imaging web site frequently asked questions page www.PegasusImaging.com/faq.htm for the fastest answers to common questions. The web site also provides other support options that are accessible at www.PegasusImaging.com/supportagree.htm.

E-mail Support

Both pre-sale and post-sale e-mail support is offered free of charge. Questions are answered on a First-Come-First-Served basis. Support@JPG.com responds instantly to e-mail received with a helpful set of locations to find additional information on Pegasus products including FAQ's, sample code, newsgroup locations and other current information pertaining to the use of the products. The support request is then added to the queue of outstanding requests. The goal of the support team to respond to each e-mail within 1 business day.

The sales team is always available as a backup to the support team. If you feel you have an urgent support or sales issue please contact Sales@JPG.com. They will assist you promptly.

Newsgroup Support

The Publicly accessible NNTP news groups located at News.PegasusImaging.com are available for each of the Controls as well as advanced imaging technology and a sample code group. We expect that the development community will freely access and search these newsgroups to find common questions and answers regarding specific uses of the controls.

On-Demand Phone Support

On-demand priority phone support can be purchased in 15 minute increments with a credit card via the Pegasus Imaging Corporation web site Support, General Info page. If you decide to purchase "on-demand" phone support, instructions will immediately be e-mailed upon receipt of your purchase.

Additionally, Pegasus offers three support plans for those customers whose commercial products or projects are sensitive or critical in nature, where immediate response and 'latest release' code are important.

1. Chariot Support

All Pegasus Imaging customers are given the opportunity to purchase a Chariot Support agreement. This is a maintenance and upgrade agreement that entitles customers to priority e-mail service, direct phone support from the support and development staff and free product upgrades for the covered products. Since upgrades are included for Chariot customers at no additional charge, Chariot customers can frequently save money, plus obtain the benefits of phone and expedited support. Pegasus Imaging reserves the right to change the terms of this service at any renewal period. Contact Sales via the web at www.PegasusImaging.com/contactform.htm for more information.

2. Galleon Support

Customers are given the opportunity to purchase Galleon Support for Pegasus Imaging products that are applications and for products that require Run Time licensing. Galleon Support includes licensing of product upgrades for deployed installations at no additional license fee cost.Pegasus Imaging reserves the right to change the terms of this service at any renewal period. Contact Sales via the web at www.PegasusImaging.com/contactform.htm for more information.

3. Atlas Support

All Pegasus Imaging customers are given the opportunity to purchase an Atlas Support agreement on currently supported products. This is an agreement that entitles customers to priority e-mail service and direct phone support from the support and development staff. It differs from Chariot Support in that it does not include version upgrades free of charge. Pegasus Imaging reserves the right to change the terms of this service at any renewal period. Contact Sales via the web at www.PegasusImaging.com/contactform.htm for more information.

For the latest and most up-to-date support information, access www.PegasusImaging.com/contact.htm

See Also

Operating Requirements | Trial Mode | Installing on a Development Machine


Pegasus Imaging Corporation

Pegasus Imaging is uniquely positioned to serve as your leading imaging technology supplier. A full suite of document imaging toolkits, forms processing technology, medical image compression SDKs, photo editing and compression libraries, browser-based image viewers, and video codecs provide advanced technology designed to enhance imaging software solutions. Fully functional trial downloads and customer-acclaimed support allow you to be certain your requirements will be met before purchase. Work with the best. Choose Pegasus Imaging for all your imaging needs.

Visit www.PegasusImaging.com for full product descriptions, FAQ's, downloads, demos, and contact information.

Pegasus Imaging

4001 North Riverside Drive

Tampa, FL 33603

Sales: 813-875-7575

Copyrights & Trademarks

Pegasus and the Pegasus Horse Logo are registered marks (®) of Pegasus Imaging Corporation.

Barcode Xpress, CapturePRO, FilePrinter, FormAssist, FormDirector, FormSuite, ISIS Xpress, The JPEG Wizard, MedXpress, NotateXpress, PDF Xpress, PICTools, ePIC, PICVideo, PrintPRO, SmartScan Xpress, SmartZone, ThumbnailXpress, and TwainPRO are trademarks (™) of Pegasus Imaging Corporation.

ImagXpress, FormFix, ScanFix, Prizm, ColorDrop, ColorEnhance, ColorFind, ColorForms, CompressDirector, Digital Mark Recognition (DMR), Image Detergent, ViewDirector and Virtual Scoring Center (VSC) by assignment are trademarks (™) or registered trademarks (®) of Pegasus Imaging Corporation.

Pegasus Imaging and/or its agents use these marks and brand names in connection with its goods and/or services, in the United States and other countries. Information in this document is subject to change without notice. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Pegasus Imaging Corporation.

Microsoft, Microsoft.NET, Visual Basic, Visual Studio and Visual Studio.NET are trademarks of Microsoft Corporation in the USA and/or other countries. All other product and brand names are the property of their respective owners.


Operating Requirements

Operating Systems

TwainPRO™ runs on 32-bit Microsoft Windows operating systems: Vista, 2000 Professional and Server, XP Home and Professional, Server 2003 and Windows Server 2008. It works with 32-bit Windows versions running on 32 and 64-bit processors. It runs in 32-bit executables running under 64-bit Windows 2000 Server, 2003 Server and Windows Server 2008.

Threading

Pegasus considers thread-safe to be when an application using this component can use multiple controls running in the same process, where they don't interfere with each other. The thread creating the control owns the control and is the only thread that can interact with it.

Development Environment

Microsoft .NET Framework 2.0, 3.0

Microsoft Visual Studio 2005

Microsoft Visual Studio 2008

Caching Data and Memory Usage

During normal operation TwainPRO caches data to temporary files on the hard drive. The size of the image and the amount of text on an image dictate how much hard drive space each page uses. Each page added to a document also increases the amount of hard drive space needed. To ensure effective operation, there should be 7 to 8 MB of hard drive space for each 8 1/2 by 11 inch 300dpi 24bpp page of full text at 12pt font size.

See Also

Getting Support and Samples | Installing on a Development Machine | Run Time Licensing


Installing on a Development Machine

To Install TwainPRO™

Run the downloaded setup program which installs the development kit on your development machine.

The downloaded development kit includes code samples for supported platforms. Samples are available through the Start | Programs | Pegasus Imaging | TwainPRO v5.0 menu.

By default this will register trial licensing which allows you to develop applications but not to distribute them. The trial license allows testing of all the functions and features.

Please see the topic 'Distributing with Your .NET Application' to understand the limits and details to converting licensing editions.
In order to distribute your finished application you must purchase and install a fully paid license from Pegasus Imaging Corporation. The paid licenses override trial licenses.

To Use TwainPRO Help Files

Stand-alone Help file "PegasusImaging.WinForms.TwainPRO5.chm"

Access the TwainPRO stand-alone help through the Windows Start menu: Start | Programs | Pegasus Imaging | TwainPRO v5.0

The stand-alone compiled Help .chm file is created with MS Help system version 1. To view Help 1 files, you must have:

  • Windows 2000 or higher (to view the file via the Windows HTML Help Viewer)
  • Internet Explorer 6.x or 7.0
  • MS HTML Help Viewer

From within your Visual Studio Development Environment, Compiled Collection Help File "PegasusImaging.WinForms.TwainPRO5.hxs"

Help 2 collection files install into Visual Studio.NET (VS). To view Help 2 files, you must have:

  • Windows 2000 or higher
  • Internet Explorer 6 or higher
  • Visual Studio .NET 2002 or higher
  • MS Help version 2

When TwainPRO installs, if the system installation requirements for Help 2 files are met, the Help 2 file is included on the Start shortcut menu. If the installation requirements for Help 2 files are not met, then the Help 1 file installs on the Start shortcut.

Plugging TwainPRO Help into Visual Studio

TwainPRO Help 2 files integrate within the Help system in Visual Studio .NET. To access TwainPRO Help within Visual Studio, do the following:

  • Ensure that the MSDN Library is installed in your Visual Studio environment. If it is not installed, re-install it from your VS.NET disc.
  • Ensure that MS Help Integration Kit is installed in your Visual Studio environment. If you do not have it installed:

1. Download the Help Integration kit from MSDN

2. Close Visual Studio.

  • Re-open Visual Studio, select the Help Menu and the Contents submenu. Verify Help files for Pegasus Imaging controls are listed.

If Pegasus Help is not listed:

  1. Search for "VSCC" in Visual Studio Help, leaving the "Filtered by:" list box blank. Select the "Visual Studio .NET Combined Help Collection Manager" topic.
  2. Select the Help 2 collections available on your PC under the heading "Collections available for inclusion in VSCC."
  3. Take care when excluding Help collections from the default VSCC collection. These collections may be necessary to view required documentation. Instead, use the "Filtered by:" field on the Contents tab of the Help panel to focus searches on Pegasus Imaging topics. Leave the "Filtered by:" list box empty to view the entire Pegasus Imaging Help files.
  4. Select the Update VSCC button.
  5. Close all instances of Visual Studio and Microsoft Document Explorer. When you restart Visual Studio, the VSCC Help collection revises with your changes. (Note: this may take several minutes.)
  6. Check the Visual Studio Help/Contents tab again to see the Help collections available to you.
  • Select the TwainPRO Help file to view Help content.
See Also

Operating Requirements | Run Time Licensing | Development Mode | License Agreement | Distributing with Your .NET Application


Trial Mode

Default Installation

The default installation installs Trial Mode licensing. This allows you to test features and functions and develop applications but not distribute them. Installing TwainPRO™ in trial mode provides you with access to all features and functionality of the TwainPRO product. E-mail support is available with the trial license.

When using the trial version of TwainPRO, an evaluation dialog box displays periodically.

Applications built with a trial license can only be run on a computer that has TwainPRO Licensing installed on it.

Changing Trial Mode Behavior

You have the flexibility to change the behavior of TwainPRO in evaluation mode as follows:

  • To facilitate server/service mode evaluations, you can choose to halt the component processing after 5 minutes in lieu of displaying an evaluation dialog box periodically. This is the TimeOut setting for the Licensing.EvaluationMode property.
See Also

Development Mode | Run Time Licensing | License Agreement | Getting Support and Samples


Development Mode

To suppress the evaluation dialog box and deploy your application, or attain technical support (beyond e-mail), as well as future product updates and upgrade notifications, you must update from a trial version to a paid version of the TwainPRO™ development kit.

1. Purchase Development Kit(s)

To purchase licensing of the TwainPRO development kit, use one of the following options:

  • Purchase online at www.PegasusImaging.com.
  • Contact Sales via the web at www.PegasusImaging.com/contactform.htm.
  • Contact a Pegasus Imaging Corporation reseller.

When the development kit is purchased, we e-mail a serial number & registration code to you. You need these codes to upgrade from trial to paid licensing.

2. Register the TwainPRO Product

When you purchase TwainPRO online or via Sales at www.PegasusImaging.com/contactform.htm, your product ownership is automatically registered.

To register products purchased through a reseller, use the form found at www.PegasusImaging.com/registration.htm.

See Getting Support and Samples for a discussion of benefits to providing your name to Pegasus Imaging. We never sell our customer information.

If your registration information should change, visit www.PegasusImaging.com/contact.htm for forms to update registration information.

3. Update Your TwainPRO Product Version from Trial to Paid Licensing

Updating your TwainPRO from trial to paid licensing will suppress the trial behavior, including the evaluation dialog box or timeout.

To update components from trial to paid licensing:

  • Enter your new license codes using one of the following options:
    • Enter licensing information (serial number, registration code and personal registration information) during component installation while downloading the latest release from www.PegasusImaging.com (the recommended approach).
    • Alternatively, licensing information (serial number, registration code and personal registration information) can be entered through the Visual Development Environment in response to the dialog display.

For more information on Run Time licensing, see the Pegasus Imaging website for more detailed information regarding Run Times and Deployment Licensing.

See Also

Trial Mode | Run Time Licensing | License Agreement | Getting Support and Samples


Run Time Licensing

Run Time & Deployment Licensing

All copyrights to Pegasus Imaging development kits and software are retained by Pegasus Imaging Corporation. ALL RIGHTS RESERVED. Your use of any of Pegasus Imaging software or run-times created with Pegasus Imaging software is allowed under license terms granted by Pegasus Imaging. It is the Licensee's responsibility to honor the terms of such license grants.

Locking Mechanism

TwainPRO™ contains a locking mechanism that does not permit you to distribute applications created with evaluation versions of TwainPRO. Prior to distributing an application that utilizes TwainPRO, you must purchase and enable run-time licensing. If the application will be delivered on the web, you must also purchase and enable web application licensing.

Obtaining Appropriate Licensing

The Licensee is required to purchase one copy of our development kit(s) for each developer in addition to obtaining the appropriate license agreement prior to deploying applications which contain Pegasus code.

Pegasus Imaging software applications and development tools are limited for use on a single CPU. Any runtimes or copies created must be granted by a direct license from Pegasus Imaging Corporation. These "end user" licenses provide the terms and limits of number and usage.

All prospective customers have every opportunity to evaluate Pegasus Imaging's products prior to purchasing. Product licensing is priced to cover what is considered to be normal (and even high) use. In addition, Pegasus Imaging fully supports and warrants its code and pricing reflects those costs as well. The larger and more valuable an application deployment is, the higher the support and warranty risk is for Pegasus.

Review the licensing categories, and select the one that matches your deployment. Special circumstances should be discussed with a Pegasus Imaging representative.

For more information on Run Time licensing, see the Pegasus Imaging website for more detailed information regarding Run Times and Deployment Licensing.

See Also

www.PegasusImaging.com | Getting Support and Samples | Development Mode | License Agreement | Distributing with Your .NET Application


License Agreement

Pegasus Imaging Corporation

SOFTWARE LICENSE AGREEMENT

GRANT OF LICENSE

This Pegasus Imaging Corporation ("PEGASUS") Agreement ("License") permits Licensee ("LICENSEE") the right to use one copy of a properly registered Pegasus Development Toolkit ("TOOLKIT") for development purposes on any single computer, provided the TOOLKIT is in use on only one computer at any time. TOOLKIT is "in-use" on a computer when it loads into temporary memory (that is, RAM) or installed into the permanent memory (that is, hard disk, CD-ROM, or other storage device) of that computer.

REDISTRIBUTION OF THE TOOLKIT RUNTIMES

PEGASUS does NOT grant any Run Time licenses with the TOOLKIT purchase, except by specific exemptions described on our licensing web pages. For Run Time Licensing information, please visit our web site (www.PegasusImaging.com/licensing.htm), or contact our sales staff. Any rights to distribute TOOLKIT run times as part of the LICENSEE's software application or derivative works ("PRODUCT"), require you to acknowledge and uphold this License Agreement and agree to notify PEGASUS immediately of any changes in status or violations. In cases where PEGASUS grants the LICENSEE a right to use, reproduce, display or otherwise distribute or transfer copies of TOOLKIT run times, LICENSEE agrees and affirms the following:

a) LICENSEE is not using PEGASUS' name, logo, or trademarks to market PRODUCT without prior written approval of PEGASUS.

b) LICENSEE agrees to indemnify, hold harmless and defend PEGASUS from and against any claims or lawsuits, including attorney's fees, that arise or result from the use or distribution of PRODUCT.

c) Only the TOOLKIT run times can be distributed. Distribution of the TOOLKIT development kit, documentation, source code, or the distribution unlock codes, is a violation of this agreement.

d) LICENSEE includes a statement substantially similar to the following within derivative work's documentation and about box: "This product contains portions of imaging code owned by Pegasus Imaging Corporation, Tampa, FL, (www.PegasusImaging.com). ALL RIGHTS RESERVED."

If ANY of the above terms are not applicable to LICENSEE'S situation, or any of the above cannot be complied with, or LICENSEE needs modifications to this license, for any reason; then LICENSEE shall obtain an expanded direct license from PEGASUS for derivative works, (available by phone at: 813-875-7575, x321, by e-mail at: Sales@jpg.com.

PEGASUS reserves the right to charge the LICENSEE up to ten times the normal license price for the use of each unlicensed copy of PRODUCT. The license granted herein and all of your rights to use or maintain possession of TOOLKIT shall terminate immediately upon breach of any material provisions of this Agreement.

This license grants rights to LICENSEE for only the PEGASUS code (TOOLKIT) mentioned above and does not convey any other rights of use or distribution to PEGASUS technology.

COPYRIGHT

The Software is owned by PEGASUS or Pegasus Imaging Corporation and is protected by United States copyright laws and international treaty provisions. LICENSEE may not remove or alter the copyright notice from any copy of the Software or any copy of the written materials, accompanying the Software.

OTHER RESTRICTIONS

This PEGASUS License Agreement is LICENSEE's proof of license to exercise the rights granted herein and must be retained by LICENSEE. LICENSEE may not rent, lease or transfer TOOLKIT or parts thereof. LICENSEE may not reverse engineer, decompile or disassemble TOOLKIT.

NO WARRANTY

ANY USE BY LICENSEE OF THE SOFTWARE IS AT THE LICENSEE'S OWN RISK. THE SOFTWARE IS PROVIDED FOR USE ONLY WITH WINDOWS PRODUCTS AND RELATED APPLICATION SOFTWARE AND/OR HARDWARE PRODUCTS. THE SOFTWARE IS PROVIDED FOR USE "AS IS" WITHOUT WARRANTY OF ANY KIND. TO THE MAXIMUM EXTENT PERMITTED BY LAW, PEGASUS DISCLAIMS ALL WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. PEGASUS IS NOT OBVLIGATED TO PROVIDE ANY UPDATES TO THE SOFTWARE.

NO LIABILITY FOR CONSEQUENTIAL DAMAGES

In no event shall PEGASUS be liable for any damages whatsoever (including, without limitation, incidental, direct, indirect and consequential damages, damages for loss of business profits, business interruption, loss of business information, or other pecuniary loss) arising out of the use or inability to use this PEGASUS product, even if PEGASUS has been advised of the possibility of such damages. Because some states/countries do not allow the exclusion or limitation of liability for consequential or incidental damages, the above limitation may not apply to LICENSEE.

INDEMNIFICATION BY LICENSEE

If LICENSEE distributes TOOLKIT in violation of this Agreement, LICENSEE agrees to indemnify, hold harmless and defend PEGASUS and its suppliers from and against any claims or lawsuits, including attorney's fees that arise or result from the use or distribution of TOOLKIT in violation of this Agreement.

This Agreement is governed by the laws of the State of Florida. The program and data contained in this TOOLKIT Product are provided with Restricted Rights. Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set forth in FAR 52.227-14 (Alternate III) or subparagraph (c)(1)(II) of the rights in technical data and computer software clause at 252.227-7013. Manufacturer is Pegasus Imaging Corporation, 4001 Riverside Drive, Tampa, FL, 33603.

For questions concerning this Agreement, or to contact PEGASUS for any reason, please contact Pegasus Imaging Corporation by phone at 1-813-875-7575 x321 or email Sales@JPG.com.

See Also

Trial Mode | Development Mode | Run Time Licensing | Distributing with Your .NET Application


Verify You Are Using the Latest Service Pack

Service pack updates will not overwrite paid licensing. Your paid licensing will continue to work and you will not be required to re-enter your purchased registration codes. Service pack updates do not include any changes that might "break" previously developed and/or deployed code.

Verify Latest Development Components

To verify you are using the latest version of a Pegasus Imaging Development Component or Components, please use the PegConnect utility program. Please note that a Help File for each product may be found on the Start Bar under Pegasus, or in C:\Windows\Help.

PegConnect is installed by all component product installers and is accessible through the Windows Start menu:

Start | Programs | Pegasus Imaging | Common | Utilities

PegConnect Allows You To:

  1. Check with Pegasus Imaging via online connection and verify that the installed version of the component includes all the most recent updates
  2. Update to the latest version automatically with your permission
  3. Determine if a control is registered or unregistered on the machine
  4. Easily change the registration status from registered to non-registered, or non-registered to registered

Alternatively, you can see the currently released product build numbers at www.PegasusImaging.com/latestbuilds.htm.

If you require further assistance or have questions or comments, please see the topic on Getting Support for more detailed information.

See Also

Getting Support and Samples | Installing on a Development Machine


Distributing with Your .NET Application

Check for Proper Licensing and Unlock Codes

TwainPRO™ contains a locking mechanism that does not permit you to distribute applications created with evaluation versions of TwainPRO. Prior to distributing an application that utilizes TwainPRO, you must purchase and enable run-time licensing. If the application will be delivered on the web, you must also enable web application licensing.

DLL Files to Distribute

The following file is required to be distributed with the TwainPRO .NET Windows Forms control:

  • PegasusImaging.WinForms.TwainPRO5.dll — .NET Control Assembly

The following files are required by TwainPRO but should be installed by the Data Source. TwainPRO will work with any version of the TWAIN dlls, however, we have found many Data Sources are only compatible with the TWAIN dlls they ship. For this reason, we do not recommend shipping the TWAIN dlls unless your application will only be working with a particular source. The latest version of these dlls can be found at www.Twain.org.

  • TWAIN.DLL — 16-bit TWAIN DLL
  • TWAIN_32.DLL — 32-bit TWAIN DLL
  • TWUNK_16.EXE — 16-bit thunking layer for 16-Bit Data Sources
  • TWUNK_32.EXE — 32-bit thunking layer for 32-Bit Data Source
See Also

Getting Support and Samples | Installing on a Development Machine | Development Mode | Run Time Licensing | License Agreement | Verify You Are Using the Latest Service Pack


Definitions, Acronyms, and Abbreviations

Pegasus Imaging Definitions, Acronyms, and Abbreviations

PIC: Pegasus Imaging Corporation

Thread-safe: An application using this component can use multiple controls running in the same process, where they don't interfere with each other. The thread creating the control owns the control and is the only thread that can interact with it.

Industry Definitions, Acronyms, and Abbreviations

See the TWAIN Specification for more information on TWAIN-Specific terms.

Capability - the options offered by a Data Source device. For example, devices may have automatic document feeders, may enable single or multiple image transfers, support color images, etc.

Capability Container - Capabilities have one of four containers, that define the structure of information. Containers include:

    • TW_ONEVALUE - a single value
    • TW_ARRAY - a rectangular array of values
    • TW_RANGE - a range of allowed values
    • TW_ENUMERATION - a list of valid values

Capability Negotiation - The application influences the data source's capability settings through capability negotiation. By determining if the source supports a capability, checking the current value of that capability, and setting the capability to the desired value, then verifying that new values have been accepted by the source.

Data Source (DS) - The image acquisition device, written to comply with the TWAIN specification.

Data Source Manager (DSM) - The software that manages interactions between the application and the Data Source. This code is provided in the TWAIN Developer's Toolkit and should be shipped for free with each TWAIN application and Data Source.

Extended Information - Information associated with the image on the page, such as a barcode.

Transfer Mode - Describes how data is transferred from the Data Source to the Application. Three modes are available: native, disk file, and buffered memory.

TWAIN Identity - A unique identifier of the TWAIN application or Source.


Overview of TWAIN

TWAIN defines a standard software protocol and application programming interface (API) for communication between software applications and image acquisition devices.

Users need a way to get image data into their applications. Software developers need compatibility with the widest range of output devices without writing and maintaining multiple device drivers.

The solution to this situation is an open industry interface (TWAIN) that directly acquires image data from external sources while within an application.

With this, each software developer supports a standard data acquisition manager and each hardware vendor writes one driver for their device. Hardware vendors benefit because they need only provide one standard driver for their device, which can then be used by all software applications supporting the TWAIN data acquisition interface.

Three Key Elements in TWAIN

  1. The Application software — An application which has been written to use TWAIN.

  2. The Data Source Manager software — The software which manages the interaction between the application and Data Source. This manager (TWAIN32.DLL) should be shipped for free with each Data Source.

  3. The Data Source software — The software which controls the image acquisition device which has been written to comply with the TWAIN specifications. It is generally supplied by the acquisition device manufacturer.

TWAIN defines how application developers can acquire image data directly into their application without requiring the user to switch out of the application. To provide this feature, TWAIN requires Data Sources to provide a built-in user interface (UI) for their device. Application developers can, if they choose, disable the built-in User Interface provided by the Data Source and provide their own User Interface to control TWAIN devices.

Support for disabling the built-in User Interface must be provided by the Data Source.


Supported File Formats

TwainPRO™ supports the following file formats:

PDF

Portable Document Format, a file format created by Adobe® System to represent documents independently of the application software, hardware, and operating system used to create them, and independently of the output device on which they are displayed or printed.

BMP

The Microsoft Windows Bitmap file format is based on the Windows internal bitmap data structures. The BMP format is widely used and it is quick and easy to read.

JPEG

The JPEG (Joint Photographic Expert Group) standard is one of the most important image data compression standards. It is widely used in many industries and is becoming the most widely used image format for the Internet.

JPEG Compression is a lossy format that can achieve very high compression ratios. The compression level is adjustable by varying the SaveJPEGChromFactor and SaveJPEGLumFactor properties.

Progressive JPEG is a multiple-scan sequential JPEG format that is becoming popular for its ability to display images in progressively clearer segments.

ePIC

Pegasus enhanced PIC image format (.PIC). This high performance image compression combines the patented ELS arithmetic coder with the high performance Pegasus JPEG libraries. The result is a new and unbeatable compression technology. The ePIC compression has significant advantages over standard JPEG. Most importantly it produces smaller file sizes and decompresses extremely quickly. Other features include password encryption, and scaling and cropping without recompression. All Pegasus products support the ePIC file format.

TIFF

TIFF (Tag Image File Format) originally released by Aldus Corporation is a standard file format found in most print, imaging, and desktop publishing programs. TIFF is extremely powerful, flexible, and extensible.

For TIFF, the compression is selected by the SaveTIFFCompression property. For images above 1-bit, the compression will be uncompressed regardless of this property setting.


Quick Start - Acquire a TWAIN Image

Your application needs only two support features for TWAIN compliance:

  • Data Source (DS) selection

  • Image acquisition through the Data Source User Interface (UI)

The two standard methods supplied within the TwainDevice class are SelectSource and StartSession.

SelectSource displays the TWAIN Data Source Manager's User Interface with the default Data Source highlighted. The user selects the Data Source he or she wishes to use then selects the OK or Cancel buttons.

The StartSession method displays the current or default Data Source User Interface for image acquisition. Any capabilities that the user wishes to change will have to be changed through the Data Source User Interface.

C# Example:

// This code demonstrates how to select the Data Source UI and then acquire an image from the Data Source

private void cmdScan_Click(object sender, EventArgs e)
{
twainDevice.SelectSource();
twainDevice.StartSession();
}

// After the image is acquired you can place it into the windows clipboard then into other applications
// or controls.
public void twainDevice_Scanned(object sender, PegasusImaging.WinForms.TwainPro5.ScannedEventArgs e)
{
try
{
e.ScannedImage.CutToClipboard();
}
catch (PegasusImaging.WinForms.TwainPro5.TwainProException ex)
{
ErrorLabel.Text = ex.Message;
}
}

See Also

SelectSource Method | StartSession Method


Set the Application's TWAIN Identity

All TWAIN Data Sources and applications have a TWAIN Identity. This identity enables the TWAIN Data Source Manager (DSM) to keep track of all running TWAIN applications and Data Sources.

The application's TWAIN identity is set using the TwainDevice.ApplicationIdentity.

The ApplicationIdentity must be assigned prior to starting a TWAIN Session (OpenSession).
See Also

ApplicationIdentity Property | OpenSession Method


Enable Extended Capabilities

Some non-compliant TWAIN drivers don't properly handle a query for support of extended capabilities (CAP_FEEDPAGE and CAP_CLEARPAGE).

If you do not plan to use these capabilities, set the TwainDevice.EnableExtendedCapabilities to False.

The Data Source should be set before opening a TWAIN session (TwainDevice.OpenSession).
See Also

EnableExtendedCapabilities Property | OpenSession Method


Set the Transfer Mode

The TwainPRO™ control now lets you determine the method of transfer you wish to use with the Data Source.

The TwainDevice.TransferMode property should be set before opening a TWAIN Session (TwainDevice.OpenSession).

Native Transfer Mode

By default, TwainPRO control uses Native transfer mode which is the simplest to use because the Data Source is responsible for providing a DIB directly to the control.

Buffered Memory Transfer

An alternative mode of transfer, buffered memory transfer, specifies that data from the Data Source is transferred in blocks of data. In buffered memory transfer mode, the TwainPRO control is responsible for converting the data received from the scanner to the proper format. Typically this would be a standard DIB. This method of transfer can be faster on computers with lesser amounts of memory or higher-end scanners.

The data can be negotiated with the Data Source through the advanced capability ICAP_COMPRESSION to be in compressed format. This results in a TIFF or JPEG file being created in memory so that less memory is used and the transfer time from the Data Source to the application is lower.
See Also

TransferMode Property | OpenSession Method


Enable Multi-page Scanning

The MaximumImages property is negotiated with the TWAIN Data Source during initialization (OpenSession) and should be set prior to invoking the OpenSession method.

This property is only used when the OpenSession method is invoked. To set the transfer count after calling OpenSession, use the CAP_XFERCOUNT capability.

  • A value of –1 indicates the application is willing to transfer multiple images.
  • A value of 1 indicates the application wishes to transfer only one image per session.
The Data Source should be set before opening a TWAIN session (TwainDevice.OpenSession).
See Also

MaximumImages Property | OpenSession Method


Select a Data Source

The Data Source for the TWAIN session must now be identified.

The Data Source should be set before opening a TWAIN session (TwainDevice.OpenSession).

Using the Data Source Manager's User Interface (DSM UI)

To enable the application end user to select a Data Source using the Data Source Manager's User Interface, call TwainDevice.SelectSource. The DataSource Manager's UI will display with the default Data Source highlighted. The user selects the Data Source he or she wishes to use then selects the OK or Cancel buttons.

Without the TWAIN DSM UI

TwainPRO™ can retrieve the list of Data Sources (DS) on the current system and set the current Data Source, without using the DSM User Interface.

In order to obtain a list of the Data Sources you must call the OpenDataSourceManager method first. You can then create a DataSourceCollection which is filled with a list of all Data Source product names. The Count property of the DataSourceCollection can be used to get the number of Data Source product names within the DataSourceCollection. The Current property of the DataSourceCollection can be used to get or set the index of the currently selected Data Source.

See Also

OpenSession Method | SelectSource Method | OpenDataSourceManager Method | DataSourceCollection Class | Count Property | Current Property


Open the TWAIN Session

Prior to Opening the TWAIN Session, the following should be done:

  • Set the Application's TWAIN Identity
  • Enable Extended Capabilities (if desired)
  • Set the Transfer Mode
  • Enable Multi-page Scanning (if desired)

The application opens a TWAIN session by calling the TwainDevice.OpenSession method. Once a TWAIN Session has been initiated, the application can read and modify capabilities, and specify instructions for scanning, such as scanning DPI and layout.

See Also

Set the Application's TWAIN Identity | Enable Extended Capabilities | Set the Transfer Mode | Enable Multi-page Scanning | OpenSession Method


Glossary Item Box

OpenSession Method | StartSession Method | Capability Enumeration | AdvancedCapability Enumeration | IsCapabilitySupported Method | GetCapability Method | CapabilityContainer Class | CapabilityContainerOneValue Class | CapabilityContainerEnum Class | CapabilityContainerRange Class | CapabilityContainerArray Class

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Check Capabilities

TWAIN devices have different capabilities (e.g. levels of resolution, support of color or black and white images, automatic document feeder available, etc.). Applications can check the capabilities available for the TWAIN device, and can also set those capabilities to its desired settings.

Capabilities can be checked once a TWAIN Session has been opened (OpenSession), and before or after a scanning session has been initiated (StartSession).

Identifying Capabilities

TWAIN specifies some capabilities to be basic (Capability) and some to be advanced (AdvancedCapability). TwainPRO methods are overloaded to support both. An overload is also provided to enable the application to access a capability that is not enumerated in the TwainPRO™ interface, by specifying an integer value.

Check that the Capability is Supported by the Data Source

To determine whether the capability of interest is supported by the TWAIN device, call TwainDevice.IsCapabilitySupported.

Read the Capability Information

If the capability is supported by the TWAIN device, call TwainDevice.GetCapability. TWAIN defines four types of containers used to negotiate values between the application and the source device:

  • One Value: The current value is returned.
  • Enum: A list of legal values along with the current and default values are returned.
  • Range: A range of legal values along with the current and default values are returned.
  • Array: A list of values is returned.

The GetCapability method returns the container as a CapabilityContainer, which can then be casted to the appropriate child object (e.g. CapabilityContainerOneValue, CapabilityContainerEnum, CapabilityContainerRange, and CapabilityContainerArray) to access the capability information.

C# Example:

// This code demonstrates how to read a value

// Check for support and stop if none
if (twainDevice.IsCapabilitySupported(capability) == false)
{
labelDefault.Text = "Not Supported";
labelDefault.Visible = true;
textBoxCurrent.Enabled = false;
buttonUpdate.Enabled = false;
return;
}
else
{
capcontainer = twainDevice.GetCapability(capability);
// What data type is the Cap? We have to check the data type
// to know which properties are valid
switch (capcontainer.GetType().ToString())
{
// Type ONEVALUE only returns a single value
case "PegasusImaging.WinForms.TwainPro5.CapabilityContainerOneValueFloat":
{
PegasusImaging.WinForms.TwainPro5.CapabilityContainerOneValueFloat myCap = (CapabilityContainerOneValueFloat)twainDevice.GetCapability(capability);

textBoxCurrent.Text = myCap.Value.ToString();
textBoxCurrent.Visible = true;
break;
}
case "PegasusImaging.WinForms.TwainPro5.CapabilityContainerOneValueString":
{
PegasusImaging.WinForms.TwainPro5.CapabilityContainerOneValueString myCap = (CapabilityContainerOneValueString)twainDevice.GetCapability(capability);

textBoxCurrent.Text = myCap.Value;
textBoxCurrent.Visible = true;
break;
}
// Type ENUM returns a list of legal values as well as current and
// default values. A list of constants is returned and the CapDesc
// property can be used to find out what the constants mean
case "PegasusImaging.WinForms.TwainPro5.CapabilityContainerEnum":
{
PegasusImaging.WinForms.TwainPro5.CapabilityContainerEnum myCap = (CapabilityContainerEnum)twainDevice.GetCapability(capability);

textBoxCurrent.Text = ((CapabilityContainerOneValueFloat)myCap.CurrentValue).Value.ToString();
textBoxCurrent.Visible = true;

labelDefault.Text = "Default = " + ((CapabilityContainerOneValueFloat)myCap.DefaultValue).Value.ToString();
labelDefault.Visible = true;

listBoxCaps.Items.Add("Legal Values:");

for (int nIndex = 0; nIndex < myCap.Values.Count; nIndex++)
{
float fResult = ((CapabilityContainerOneValueFloat)myCap.Values[nIndex]).Value;

string strResult = twainDevice.GetCapabilityConstantDescription(capability, nIndex);

if (strResult == null)
{
strResult = "";
}
listBoxCaps.Items.Add(fResult.ToString() + " - " + strResult.ToString());
}
listBoxCaps.Visible = true;
break;
}
// Type ARRAY returns a list of values, but no current or default values
// This is a less common type that many Data Sources don't use
case "PegasusImaging.WinForms.TwainPro5.CapabilityContainerArray":
 {
PegasusImaging.WinForms.TwainPro5.CapabilityContainerArray myCap = (CapabilityContainerArray)twainDevice.GetCapability(capability);

listBoxCaps.Items.Add("Legal Values:");
for (int nIndex = 0; nIndex < myCap.Values.Count; nIndex++)
{
float fResult = ((CapabilityContainerOneValueFloat)myCap.Values[nIndex]).Value;
listBoxCaps.Items.Add(fResult);
}
break;
}
// Returns a range of values as well as current and default values
 case "PegasusImaging.WinForms.TwainPro5.CapabilityContainerRange":
{
PegasusImaging.WinForms.TwainPro5.CapabilityContainerRange myCap = (CapabilityContainerRange)twainDevice.GetCapability(capability);

textBoxCurrent.Text = myCap.Value.ToString();
textBoxCurrent.Visible = true;

labelDefault.Text = "Default = " + myCap.Default.ToString();
labelDefault.Visible = true;

labelMin.Text = "MinValue = " + myCap.Minimum.ToString(); ;
labelMin.Visible = true;

labelMax.Text = "MaxValue = " + myCap.Maximum.ToString();
labelMax.Visible = true;
break;
}
}

See Also

OpenSession Method | StartSession Method | Capability Enumeration | AdvancedCapability Enumeration | IsCapabilitySupported Method | GetCapability Method | CapabilityContainer Class | CapabilityContainerOneValue Class | CapabilityContainerEnum Class | CapabilityContainerRange Class | CapabilityContainerArray Class


Glossary Item Box

OpenSession Method | StartSession Method | Capability Enumeration | AdvancedCapability Enumeration | IsCapabilitySupported Method | SetCapability Method | CapabilityContainer Class | CapabilityContainerOneValue Class | CapabilityContainerEnum Class | CapabilityContainerRange Class | CapabilityContainerArray Class

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Set Capabilities

Capabilities can only be modified, or set, after a TWAIN Session has been opened (OpenSession), and prior to initiating the scanning session (StartSession).

Identifying Capabilities

TWAIN specifies some capabilities to be basic (Capability) and some to be advanced (AdvancedCapability). TwainPRO™ methods are overloaded to support both. An overload is also provided to enable the application to access a capability that is not enumerated in the TwainPRO interface, by specifying an integer value.

Check that the Capability is supported by the Data Source

To determine whether the capability of interest is supported by the TWAIN device, call IsCapabilitySupported.

Set the Capability

If the capability is supported by the TWAIN device, call SetCapability. TWAIN defines four types of containers used to negotiate values between the application and the source device:

  • One Value: The current value is returned.
  • Enum: A list of legal values along with the current and default values are returned.
  • Range: A range of legal values along with the current and default values are returned.
  • Array: A list of values is returned.

The SetCapability method takes as a parameter a CapabilityContainer object. The CapabilityContainerOneValue, CapabilityContainerEnum, CapabilityContainerRange, and CapabilityContainerArray objects can be filled with information and passed to this method to set the value of the container.

C# Example:

// This code demonstrates setting a single value using the TWON_ONEVALUE container

PegasusImaging.WinForms.TwainPro5.CapabilityContainerOneValueFloat myCap = new CapabilityContainerOneValueFloat(Capability.TwonBitDepth);
myCap.Value = (float)CapabilityConstants.TwptBW;
twainDevice.SetCapability(myCap);

The other containers can be used to set a new range or set of legal values for a capability. These can be used to restrict the choices available to a user when the UI is presented.

C# Example:

// This code demonstrates how to request that the Data Source only allow resolutions in the range of 100 to 400 dpi (assuming the ICAP_UNITS capability is set to inches)

PegasusImaging.WinForms.TwainPro5.CapabilityContainerRange myCap = new CapabilityContainerRange(Capability.IcapXResolution);
myCap.Value = 100;
myCap.Minimum = 100;
myCap.Maximum = 400;
twainDevice.SetCapability(myCap);

Sources are not required to allow their values to be restricted by the application, so support of this feature varies widely. Some devices will ignore these parameters completely, while others may only allow it for certain capabilities. For instance, a device may allow ICAP_PIXELTYPE to be restricted to black and white images, but won’t allow ICAP_XRESOLUTION to be restricted to the range shown in the above example.
See Also

OpenSession Method | StartSession Method | Capability Enumeration | AdvancedCapability Enumeration | IsCapabilitySupported Method | SetCapability Method | CapabilityContainer Class | CapabilityContainerOneValue Class | CapabilityContainerEnum Class | CapabilityContainerRange Class | CapabilityContainerArray Class


Set Image DPI

Image Resolution can only be modified, or set, after a TWAIN Session has been opened (OpenSession), and prior to initiating the scanning session (StartSession).

One capability that is often set by the application is the desired DPI of the scanned image. To set the DPI for scanned images, use the TWAIN capabilities: ICAP_XRESOLUTION and ICAP_YRESOLUTION.

It is important to set the ICAP_UNITS capability equal to TWUN_INCHES prior to setting the resolution capabilities.

C# Example:

// This code demonstrates how to set the DPI of scanned images to 300 DPI

PegasusImaging.WinForms.TwainPro5.CapabilityContainerOneValueFloat myCap = new CapabilityContainerOneValueFloat(Capability.IcapUnits);
myCap.Value = (float)PegasusImaging.WinForms.TwainPro5.CapabilityConstants.TwunInches;
twainDevice.SetCapability(myCap);

myCap = new CapabilityContainerOneValueFloat(Capability.IcapXResolution);
myCap.Value = 300;
twainDevice.SetCapability(myCap);

myCap = new CapabilityContainerOneValueFloat(Capability.IcapYResolution);
myCap.Value = 300;
twainDevice.SetCapability(myCap);

See Also

OpenSession Method | StartSession Method


Define a Caption

A caption is text that is placed on a still frame when scanning. TwainPRO™ enables the user to define a caption to be placed on all scanned images. When a caption is applied during scanning, it becomes a part of the scanned image data, and is no longer separable from the image.

To define a caption, set the TwainDevice.Caption property to specify the text, appearance, and location of the caption. During the scanning session, the caption will be applied to all acquired images.

If no caption is needed, ensure that the Caption property is set to null (the default value) prior to StartSession.

Caption can only be modified, or set, prior to initiating the scanning session (StartSession).
See Also

Caption Class | StartSession Method


Specify Image Layout

The desired layout for scanned images can be specified prior to initiating a scanning session, by setting the TwainDevice.ImageLayout property. The ImageLayout rectangle defines what portion of the Data Source's scanning area is acquired.

It is also a good idea to set the ICAP_UNITS capability for the scanner prior to using the ImageLayout method to specify the unit of measure you'll be using.

C# Example:

// This code demonstrates how to set the Image Layout rectangle to 6.5 inches X 9 inches

twainDevice.ImageLayout = new RectangleF(1, 1, 6.5F, 9);

ImageLayout can only be modified, or set, prior to initiating the scanning session (StartSession) and after opening a session (OpenSession).
See Also

ImageLayout Property | StartSession Method


Initiate a Scanning Session

Prior to initiating a scanning session, the following should be done:

  • Open a TWAIN Session
  • Negotiate Capabilities
  • Define a Caption (if desired)
  • Specify Image Layout

Once a Scanning session has been initiated (StartSession), capabilities, caption, and layout can be checked, but can no longer be modified.

Initiate Scanning Using the Data Source UI

To enable the application end user to initiate image acquisition, ensure that the TwainDevice.ShowUserInterface property is set to True. Then call the StartSession method.

The Data Source User Interface then displays the current or default Data Source User Interface for image acquisition.

C# Example:

// This code demonstrates how to select the Data Source UI and then acquire an image from the Data Source

private void cmdScan_Click(object sender, EventArgs e)
{
twainDevice.SelectSource();
twainDevice.ShowUserInterface = true
twainDevice.StartSession();
}

// After the image is acquired you can place it into the windows clipboard then into other applications
// or controls.
public void twainDevice_Scanned(object sender, PegasusImaging.WinForms.TwainPro5.ScannedEventArgs e)
{
try
{
e.ScannedImage.CutToClipboard();
}
catch (PegasusImaging.WinForms.TwainPro5.TwainProException ex)
{
ErrorLabel.Text = ex.Message;
}
}

Initiate Scanning Without Using the Data Source UI

The TwainDevice.ShowUserInterface property is used to set the Data Source User Interface visibility to True or False. To hide the Data Source's User Interface, you must use the TwainPRO session methods. The ShowUserInterface property has to be set before calling the StartSession method.

When acquiring an image without the Data Source User Interface, you must take into account that the default image size and resolution capabilities may create a very large image and your system may not have enough memory for the image transfer. Check the image height, width, and resolution settings using the ImageLayout property and ICAP_XRESOLUTION capability respectively. If these values are outside of your parameters then you can change them with the ImageLayout property and SetCapability method.

See Also

Open a TWAIN Session | Negotiate Capabilities | Define a Caption | Specify Image Layout | StartSession Method | ShowUserInterface Property | ImageLayout Property


Glossary Item Box

StartSession Method | Scanning Event | PendingTransfers Property | Scanned Event | ScannedImage Property | SaveOptions Class | MultiPage Property | SaveFile Method | SaveStream Method | CopyToClipboard Method | CutToClipboard Method

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Transfer and Save Images

Once a scanning session has been initiated by calling StartSession, one or more images can be scanned by the Data Source, transferred from the Data Source to the application, and saved by the application to file or memory.

Check for Pending Transfers

Prior to initiating a transfer of a scanned image from the Data Source to the application, TwainPRO™ raises a Scanning event. The PendingTransfers property will contain the number of images the Data Source has ready for transfer. If the Data Source doesn't know how many images are ready for transfer, PendingTransfers will be equal to -1. TWAIN Data Sources with Automatic Document Feeders (ADF) will return PendingTransfers equal to -1. Such devices will transfer images until the feeder is empty.

Transfer Images from Data Source to Application

Upon proceeding from the Scanning event, pending images will be transferred from the Data Source to the application.

Save Scanned Images

When the transfer of each image is complete, TwainPRO raises a Scanned event. This event is the trigger to save the image to file or memory.

During the Scanned event, the ScannedImage property contains the latest scanned image. This information will be lost once the transfer of another image is initiated. Therefore, the application must select a method for saving the scanned image prior to initiating the next scan:

  • To save this image to file or stream, first specify instructions for saving, by creating and setting a SaveOptions object. (If the target file format allows mult-page files, ensure that the MultiPage property is set as desired.) Then invoke the ScannedImage.SaveFile or SaveStream methods to save the file according to the properties set.
  • To move the data to an ImagXpress® control, assign the TwainPRO hDIB to ImagXpress hDIB, using the ToBitmap, ToHbitmap, or ToHdib methods.
  • You may also move the data to the Window's Clipboard with the CopyToClipboard or CutToClipBoard methods.

Finish Scanning

Upon exiting the Scanned event, the acquisition process continues, by triggering another Scanning event. Setting the Cancel parameter in the Scanning or Scanned events will terminate the scanning session.

C# Example:

// This code demonstrates how to save to a multi-page file

public void SaveMultipage()
{
mySaveOptions = new PegasusImaging.WinForms.TwainPro5.SaveOptions();
// Note also that PDF files can be saved as multipage files
// and this could be done by setting mySaveOptions.Pdf.MultiPage to true
// and setting mySaveOptions.Format to Pdf.
 mySaveOptions.Format = PegasusImaging.WinForms.TwainPro5.ScannedImageFormat.Tiff;
mySaveOptions.Tiff.MultiPage = true;
outputFile = System.IO.Path.Combine(System.Environment.CurrentDirectory, "..\\..\\multipage.tif");
twainDevice.StartSession();
}

public void twainDevice_Scanned(object sender, PegasusImaging.WinForms.TwainPro5.ScannedEventArgs e)
{
try
{
e.ScannedImage.SaveFile(outputFile, mySaveOptions);
}
catch (PegasusImaging.WinForms.TwainPro5.TwainProException ex)
{
MessageBox.Show(ex.Message);
}
}

C# Example:

// This code demonstrates how to successfully negotiate the transfer mode and to transfer data in a compressed format

twainDevice.TransferMode = PegasusImaging.WinForms.TwainPro5.TransferMode.TwsxMemory;
twainDevice.OpenSession();

if (twainDevice.TransferMode == TransferMode.TwsxMemory)
{
AdvancedCapability capability = AdvancedCapability.IcapCompression;
CapabilityContainer capcontainer = twainDevice.GetCapability(capability);

// Only do the following if the Capability is supported and
// there is more than one compression type to set. Otherwise,
// the data source may say they support this capability but
// might return an error if you try to set to TWCPNONE and
// it is the only type. All data sources must support TWCPNONE.
 if (twainDevice.IsCapabilitySupported(capability) && comboBoxCompression.Items.Count > 1)
{
CapabilityContainerOneValueFloat myCap = new CapabilityContainerOneValueFloat(capability);
myCap.Value = (float)AdvancedCapabilityConstants.TwcpJpeg;
twainDevice.SetCapability(myCap);

// Set the JPEG Quality factor
AdvancedCapability capjpeg = AdvancedCapability.IcapJpegPixelType;
CapabilityContainer capjpegcontainer = twainDevice.GetCapability(capjpeg);

// Normally then you would negotiate the ICAP_JPEGPIXELTYPE
// and ICAP_JPEGQUALITY capabilities.
// Using the defaults for both of these values.
 }
else
{
 twainDevice.TransferMode = PegasusImaging.WinForms.TwainPro5.TransferMode.TwsxNative;
labelStatus.Text = "TwainPRO forced to Native Transfer Mode. Compression unavailable.";
}
}
else
{
twainDevice.TransferMode = PegasusImaging.WinForms.TwainPro5.TransferMode.TwsxMemory;
labelStatus.Text = "TwainPRO forced to Native Transfer Mode. Compression unavailable.";
}
twainDevice.StartSession();

// A simple typical Scanned event handler.
public void twainDevice_Scanned(object sender, PegasusImaging.WinForms.TwainPro5.ScannedEventArgs e)
{
try
{
// Need to check the Compression type to see if we are transferring a DIB
// or we are transferring compressed data.
 if (e.ScannedImage.ScannedImageData.Compression == ScannedImageCompression.TwcpNone)
{
int hImage = e.ScannedImage.ToHdib().ToInt32();
if (hImage != 0)
{
imageXView1.Image = PegasusImaging.WinForms.ImagXpress9.ImageX.FromHdib(imagXpress1,

(System.IntPtr)hImage);
}
}
else
{
int hImage = e.ScannedImage.ToHbitmap().ToInt32();
if (hImage != 0)
{
imageXView1.Image = PegasusImaging.WinForms.ImagXpress9.ImageX.FromHbitmap(imagXpress1,

(System.IntPtr)hImage);
GlobalFree(hImage);
}
}
e.Cancel = false;
}
catch (PegasusImaging.WinForms.ImagXpress9.ImagXpressException ex)
{
MessageBox.Show(ex.Message);
}
catch (PegasusImaging.WinForms.TwainPro5.TwainProException ex)
{
MessageBox.Show(ex.Message);
}
catch (System.Exception ex)
{
MessageBox.Show(ex.Message);
}
}

See Also

StartSession Method | Scanning Event | PendingTransfers Property | Scanned Event | ScannedImage Property | SaveOptions Class | MultiPage Property | SaveFile Method | SaveStream Method | CopyToClipboard Method | CutToClipboard Method


Transfer and Save Multi-page Images

Fast Saving Multi-page TIFF Files (generally over 1000 pages)

When the UseIFDOffset property is false (default), the image is appended to the end of the multi-page TIFF. Due to the linked format of TIFF, the software must traverse all the link pointers to identify the location to which the new page will be appended. The greater the number of pages in the target TIFF file, the longer the write process takes. (Typically, if the target file has more than 1000 pages, the write speed will degrade substantially.)

Setting the UseIFDOffset property to true specifies that the control should write the image to the location stored in the IFDOffset property. This enables much faster writing of TIFF files with many pages because the software can seek to that location without traversing all previous pointer links. This process gives very predictable speeds in adding pages to a multi-page TIFF file.

Important: If the file's IFDOffset ever became out of sync with the IFDOffset property value, file corruption could occur. To protect the application from inadvertently corrupting a saved mutli-page file, the Twain PRO 5 control takes the following measures:

  • If the application sets the UseIFDOffset property to true or false, the IFDOffset property is automatically set to zero. The application must then explicitly set the IFD Offset to be used.
  • Executing the SaveFile method will automatically set the UseIFDOffset property to false. The application must then explicitly set the value back to true as needed.
  • When the IFDOffset property is zero, a normal write (not fast TIFF write) will occur regardless of the UseIFDOffset value. The fast write will take place only when IFDOffset is set to non-zero and the UseIFDOffset is set to true.

C# Example:

// This code demonstrates how to use the UseIFDOffset and IFDOffset properties to safely enable fast TIFF writing

private PegasusImaging.WinForms.TwainPro5.TwainDevice twainDevice;
PegasusImaging.WinForms.TwainPro5.SaveOptions mySaveOptions;
int myIfdOffset = 0;

public void SaveMultipageTifUsingIfd()
{
try
{
mySaveOptions.Tiff.MultiPage = true;
outputFile = System.IO.Path.Combine(System.Environment.CurrentDirectory, "..\\..\\ifd.tif");
twainDevice.StartSession();
}
catch (Exception ex)
{
MessageBox.Show(ex.ToString());
}
}

public void twainDevice_Scanned(object sender, PegasusImaging.WinForms.TwainPro5.ScannedEventArgs e)
{
try
{
mySaveOptions.Tiff.UseIFDOffset = true;
mySaveOptions.Tiff.IFDOffset = myIfdOffset;
e.ScannedImage.SaveFile(outputFile, mySaveOptions);
myIfdOffset = mySaveOptions.Tiff.IFDOffset;
}
catch (Exception ex)
{
MessageBox.Show(ex.Message);
}
}

See Also

UseIFDOffset Property | IFDOffset Property


Glossary Item Box

Scanned Event | ScannedImage Property | GetExtendedImageInfo Method | ExtendedImageInfoContainer Class | ExtendedImageInfoContainerValueCollection Class | ExtendedImageInfoContainerValueFloat Class | ExtendedImageInfoContainerValueString Class

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Access Extended Image Information

What is Extended Image Information?

Extended image information is used to pass information such as barcodes or patch codes found on a scanned page. See the TWAIN specification for additional information on Extended Image Information available for retrieval.

The TWAIN Data Source must be compliant with version 1.7 or higher of the TWAIN specification for accessing this extended information.

Extended Image Information

The extended image information is accessed during the Scanned event, by getting the ScannedImage, and calling the ScannedImage.GetExtendedImageInfo method. The returned ExtendedImageInfoContainer includes the extended information available for that image. To access the information within the ExtendedImageInfoContainer, the application must cast this object to the appropriate child object: ExtendedImageInfoContainerValueCollection, ExtendedImageInfoContainerValueFloat, or ExtendedImageInfoContainerValueString.

C# Example:

// This code demonstrates how to access the TWEI_BARCODEX extended image information and add all of the information for a scanned page to a list box
public void twainDevice_Scanned(object sender, PegasusImaging.WinForms.TwainPro5.ScannedEventArgs e)
{
try
{
ExtendedImageInfoContainer extendedImageInfo = e.ScannedImage.GetExtendedImageInfo(ExtendedImageInfo.TweiBarcodeX);
ExtendedImageInfoContainerValueCollection theValues = extendedImageInfo.Values;
int i = 0;
for (i = 0; i < theValues.Count; i++)
{
ExtendedImageInfoContainerValueFloat extendedImageInfoFloat = (ExtendedImageInfoContainerValueFloat)theValues[i];
listBox1.Items.Add(extendedImageInfoFloat.Value.ToString());
}
}
catch (PegasusImaging.WinForms.TwainPro5.TwainProException ex)
{
ErrorLabel.Text = ex.Message;
}
}

See Also

Scanned Event | ScannedImage Property | GetExtendedImageInfo Method | ExtendedImageInfoContainer Class | ExtendedImageInfoContainerValueCollection Class | ExtendedImageInfoContainerValueFloat Class | ExtendedImageInfoContainerValueString Class


Glossary Item Box

StartSession Method | Scanning Event | PendingTransfers Property | ScanningEventArgs Class | Scanned Event | ScannedImage Property | SaveFile Method | ToHdib Method | CutToClipboard Method | CopyToClipboard Method | Cancel Property

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Multiple Image Acquisition

The StartSession method is all that’s needed to start a multiple image session. After calling StartSession, the Scanning event will fire when images are ready to be transferred. The PendingTransfers property of the ScanningEventArgs will contain the number of images the Data Source has ready for transfer to TwainPRO™. When the transfer is complete, TwainPRO raises the Scanned event.

After each complete transfer, the ScannedImage property of the ScannedEventArgs contains new image data. Save the image data to a file using the SaveFile method of the ScannedImage. To move the data to an ImagXpress® control, use the ToHdib method of ScannedImage to access the handle to the DIB and pass it to the ImagXpress FromHdib method.

C# Example:

// This code demonstrates how to pass the scanned image from TwainPRO to ImagXpress

public void twainDevice_Scanned(object sender, PegasusImaging.WinForms.TwainPro5.ScannedEventArgs e)
{
try
{
imageXView1.Image = PegasusImaging.WinForms.ImagXpress9.ImageX.FromHdib(imagXpress1, e.ScannedImage.ToHdib(), true);
}
catch (PegasusImaging.WinForms.TwainPro5.TwainProException ex)
{
ErrorLabel.Text = ex.Message;
}
}

You may also move the data to the Window's Clipboard with the CutToClipboard or CopyToClipboard method of the ScannedImage.
Each Scanned event will change the image data. Image data from a previous acquire will be lost after each image transfer.

Check the PendingTransfers property in the Scanning or Scanned event to see if there are more images to acquire. A value of -1 for PendingTransfers means the Data Source does not know how many images there are. TWAIN Data Sources with Automatic Document Feeders (ADF) will return PendingTransfers equal to -1. Such devices will transfer images until the feeder is empty.

You can cancel a multiple image acquire by setting the Cancel parameter to True in either the Scanning or Scanned events. This will cancel all pending transfers and end the session.

C# Example:

// This code demonstrates how to start a TWAIN session and save each scanned image until there are no pending transfers from the Data Source

private void cmdScanWith_Click(object sender, EventArgs e)
{
scanCount = 0;
twainDevice.StartSession();
}

public void twainDevice_Scanned(object sender, PegasusImaging.WinForms.TwainPro5.ScannedEventArgs e)
{
try
{
pictureBox1.Image = e.ScannedImage.SaveFile("c:\\ScannedImage" + scanCount.ToString() + ".tiff");
scanCount++;
}
catch (PegasusImaging.WinForms.TwainPro5.TwainProException ex)
{
ErrorLabel.Text = ex.Message;
}
}

See Also

StartSession Method | Scanning Event | PendingTransfers Property | ScanningEventArgs Class | Scanned Event | ScannedImage Property | SaveFile Method | ToHdib Method | CutToClipboard Method | CopyToClipboard Method | Cancel Property


End a TWAIN Session

The TWAIN Session can be ended at any point. The actions to be taken depend on the state of the session.

During Data Source Selection

OpenDataSourceManager or SelectSource has previously been called to open the Data Source Manager. Call CloseSession to close the Data Source Manager and terminate the TWAIN session.

During Capability Negotiation

OpenSession has previously been called to open the Data Source Manager and Data Source. Call CloseSession to close the Data Source and Data Source Manager and terminate the TWAIN session.

During a Scanning Session

StartSession has previously been called to begin a scanning session.

The TWAIN session can be terminated during the Scanning or Scanned event by setting the Cancel parameter.

See Also

OpenDataSourceManager Method | SelectSource Method | CloseSession Method | OpenSession Method | StartSession Method | Scanning Event | Scanned Event | Cancel Property


Debug

I am encountering a problem with a TWAIN Device.

If you have a problem with a TWAIN device we recommend trying the following things:

  1. Get the latest version of the scanner's drivers from the manufacturer's web site and re-install them.

  2. Get the latest TWAIN Data Source Manager files from www.Twain.org and put them in your windows directory (NOT the windows\system directory). Also, make sure you don't have older versions of those DLLs or EXEs anywhere else in your path.

  3. Make sure you have the latest version of TwainPRO™.

  4. If you still have a problem with a particular scanner, let us know, but remember, not all TWAIN capabilities are supported by all devices and there are TWAIN drivers out there that have bugs in them and are not fully TWAIN compliant.

It appears that setting a capability has no effect on the scanned image.

There are a couple of reasons this issue may be occurring:

Resolution 1:

Please make sure that you call OpenSession before setting the capabilities. For example:

ICAP

TwainPRO1.SelectSource

TwainPRO1.ShowUI = False

TwainPRO1.OpenSession

Resolution 2:

Not all TWAIN devices support all TWAIN capabilities. Because of this, you must check to see if a TWAIN capability is supported by your device before setting it.

To do this, TwainPRO™ provides a method called IsCapabilitySupported, which will return True if the capability is supported and False if not. Note that if a scanner supports a capability, it might only support getting it and does not necessarily support setting it.

Below is an example of how to check this property:

if (twainDevice.IsCapabilitySupported(Capability.IcapPixelType) == true)
{
// If the capability is supported this code will be executed.
}

I want to drive a scanner via the Kofax VRS TWAIN driver without using the Kofax TWAIN UI.

Kofax VirtualReScan (VRS) works best with an ISIS driver and only supports some scanners with TWAIN drivers. Documentation for Kofax VRS can be found at www.kofax.com/support/IP/VRS/4.1/4.1_downloads.asp#ProductDocumentation .

Error Codes

This section includes error codes and extended error codes.

7000

TWERR_TWAIN

TWAIN error, check ErrorCode & ErrorString properties.

The Data Source has returned an error. Check the ErrorCode and ErrorString properties to see if the Data Source has returned an error code.

7001

TWERR_TINIT

Can't find or load twain_32.dll.

This file is not shipped with TwainPRO because it is generally provided by the Data Source. It should be located in the windows directory and not the windows\system directory. The latest version of this file can be found at http://www.twain.org.

PoPossible causes:

The file is missing.

The file is in use by another application.

7002

TWERR_FILEOPEN

TwainPRO can’t open an existing TIF file to append pages.

PoPossible causes:

The file is open in another control or application.

The file is read-only

7003

TWERR_MEMORYALLOC

TwainPRO was unable to allocate memory for the requested operation.

PoPossible causes:

The image being transferred is too large to fit in memory.

Too many applications are open.

7004

TWERR_CANCELLED

The user cancelled the requested operation.

PoPossible causes:

The user clicked the cancel button on the source selection dialog invoked by the SelectSource method.

7005

TWERR_CREATEFILE

TwainPRO was unable to create the file specified in the SaveFile method.

PoPossible causes:

The drive or path specified doesn’t exist.

The file exists and is in use by another application.

No file extension or an invalid file extension was specified.

7006

TWERR_FILEWRITE

An error occurred while TwainPRO was attempting to save a file to the path specified in the SaveFile method.

PoPossible causes:

The drive or path became invalid during the write. This can occur if the drive is a network drive.

The disk is full.

7007

TWERR_FORMATNOTSUPPORTED

A file extension for specified for a file type not supported by TwainPRO. Supported file types are: BMP,

JPEG, ePIC, and TIF.

7008

TWERR_BADLENGTH

A string with too many characters was set to a TwainPRO property.

PoPossible causes:

The application identity properties can accept a maximum length of 32 characters.

The PICPassword property can accept a maximum length of 8 characters.

7009

TWERR_BADVALUE

The value is out of range. An invalid value was set to a TwainPRO property.

PoPossible causes:

Many TwainPRO properties can only accept values in a specified range. For example, the SaveJPEGLumFactor property must be in the range 0-255.

7010

TWERR_NODIB

No image is available for the requested operation or an unsupported DIB format was returned in response to a StartSession.

PoPossible causes:

The hDIB property has already been read.

The SaveFile method was invoked after the hDIB property was read.

7011

TWERR_NOPICFILES

The required Pegasus dll file(s) are missing.

PoPossible causes:

Pegasus dll files are required when saving JPEG, ePIC, or TIF files. They are listed in the dependencies section.

7012

TWERR_NONETFILES

The required Internet dll file(s) are missing.

PoPossible causes:

The following files are not present on the system. These files are not shipped with TwainPRO and are not needed unless an FTP address is specified in the SaveFile method. These files are included with other software such as Internet Explorer, and if the machine has a TCP/IP connection, it should have these files.

wininet.dll

urlmon.dll

7013

TWERR_FTP

An error occurred trying to FTP an image.

PoPossible causes:

The machine is not currently connected to a network. The FTPUserName and/or FTPPassword properties are not correct for the requested host specified in the SaveFile method.

The host and or path specified in the SaveFile method doesn’t exist.

The path was not specified in the SaveFile method. A fully qualified URL containing both the servername and file path must be specified. For example, "http://ftp.myserver.com/ftp/public/test.jpg" contains both the server and file information, but "http://ftp.myserver.com" does not.

7014

TWERR_TSEQERROR

Illegal operation for current Source Manager or Source state. The requested action cannot be performed in the current state of the TWAIN session.

PoPossible causes:

Certain methods and properties are only valid during certain states. For example, the DataSourceList property is invalid unless the OpenDSM method was called to open the Data Source Manager.

7015

TWERR_BADINDEX

The requested index was out of range for the property array.

7016

TWERR_WRONGCAPTYPE

A property was set or queried that was not valid for the current capability type. Please see the Capability Negotiation section for more information.

7017

TWERR_CLIPBOARD

An error occurred trying to open the clipboard with the CopyToClipboard or CutToClipboard method.

PoPossible causes:

Another application has the clipboard open.

7018

TWERR_INTERNALERROR

Internal error.

7019

TWERR_BADBITCOUNT

Invalid image resolution for selected file format or an unsupported bits per pixel was returned from a StartSession.

PoPossible causes:

Tried to save a 1-bit or Black and White image to a jpg or pic file.

7020

TWERR_NOTAVAILABLE

The property requested is not currently available.

PoPossible causes:

This error is returned when the CapAdvanced property is being used and the requested capability function is not available. For instance, this error will be returned when the Capability property is set to ICAP_USECAPADVANCED and the property CapDesc is accessed. The CapDesc property is only available for the enumerated Capability values. Also this error will be returned when the Capability property is set to ICAP_USECAPADVANCEDFOREXTINFO and the CapOut properties are accessed.

7021

TWERR_NOIMAGE

No compressed image is available for the requested operation or an unsupported compressed image format was returned in response to a StartSession.

PoPossible causes:

The hImage property has already been read.

The SaveFile method was invoked after the hImage property was read.

7022

TWERR_DSINVALIDOP

The Data Source performed an operation that caused an exception. This error is a critical error. If this error is received then the application should be terminated immediately. No other TwainPRO calls should be made after this error is received. This does give the application the chance to do any non-TWAIN clean-up processing as well as inform the user that a critical error has occurred.

PoPossible causes:

The Data Source TWAIN driver executed an illegal operation, such as an illegal memory access, a divide by zero, etc.

7023

TWERR_INVALIDLICENSE

Invalid license.

7024

TWERR_TIFFTAGNOTFOUND

TIFF tag not found.

7025

TWERR_TIFFTAGITEMNOTFOUND

TIFF tag item not found.

7026

TWERR_BADFILEREAD

Error reading file.

7027

TWERR_SETTINGSFILEINIT

An error occurred while initializing the settings file reader system.

7028

TWERR_SETTINGSFILETERM

An error occurred while terminating the settings file reader system.

7029

TWERR_FILENOTOPEN

An error occurred when opening the settings file.

7030

TWERR_NAMENOTFOUND

The TwainDevice Name attribute was not found in the settings file.

7031

TWERR_SCANNERNOTFOUND

Settings for the current scanner were not found in the settings file.

7032

TWERR_ENUMNOTFOUND

The Capability Enum attribute was not found in the settings file.

7033

TWERR_INVALIDFILENAME

Invalid file name.

7034

TWERR_FILENOTFOUND

The specified file was not found for the current LoadOptions operation.

7035

TWERR_PATHNOTFOUND

The specified path of the filename was not found.

7036

TWERR_FILEINUSE

The file is in use by another process and cannot be opened.

7037

TWERR_FILECLOSE

The file close operation could not be completed.

7038

TWERR_FILERESET

The file reset operation could not be completed.

7039

TWERR_TYPENOTFOUND

The Capability Type attribute was not found in the settings file.

7040

TWERR_CAPNOTSUPPORTED

The Capability is not supported.

Extended Error Codes

The following are error codes and strings that can be returned in the ErrorCode and ErrorString properties when TwainPRO returns a TWERR_TWAIN error.

1 | TWCC_BUMMER | General failure. Unload Source immediately.
2 | TWCC_LOWMEMORY | Not enough memory to complete operation.
3 | TWCC_NODS | Source Manager unable to find the specified Source.
4 | TWCC_MAXCONNECTIONS | Source is connected to maximum supported number of applications.
5 | TWCC_OPERATIONERROR | Source or Source Manager reported an error to the user and handled the error; no application action required.
6 | TWCC_BADCAP | Capability not supported by Source.
9 | TWCC_BADPROTOCOL | Unrecognized operation triplet.
10 | TWCC_BADVALUE | Data parameter out of supported range.
11 | TWCC_SEQERROR | Illegal operation for current Source Manager or Source state.
12 | TWCC_BADDEST | Unknown destination in DSM_Entry.
13 | TWCC_CAPUNSUPPORTED | Capability not supported by Source.
14 | TWCC_CAPBADOPERATION | Operation not supported on capability.
15 | TWCC_CAPSEQERROR | Capability has dependencies on other capabilities and cannot be operated upon at this time.
16 | TWCC_DENIED | File System operation is denied (file is protected).
17 | TWCC_FILEEXISTS | Operation failed because file already exists.
18 | TWCC_FILENOTFOUND | File not found.
19 | TWCC_NOTEMPTY | Operation failed because directory is not empty.
20 | TWCC_PAPERJAM | Transfer failed because of a feeder error.
21 | TWCC_PAPERDOUBLEFEED | Transfer failed because of a feeder error.
22 | TWCC_FILEWRITEERROR | Error writing the file.
23 | TWCC_CHECKDEVICEONLINE | The device went off-line prior to or during this operation.

See Also

OpenSession Method | IsCapabilitySupported Method


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

See Also

PegasusImaging.WinForms.TwainPRO5 Assembly

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PegasusImaging.WinForms.TwainPro5 Namespace

Inheritance Hierarchy

Classes

Class | Description
ApplicationIdentity | An object that represents the TWAIN identity of the application.
CapabilityContainer | This class contains the capability information.
CapabilityContainerArray | This class is an array type container for storing capability information.
CapabilityContainerEnum | A class which contains enumeration capability information.
CapabilityContainerOneValue | This class implements a one value type container for storing capability information.
CapabilityContainerOneValueCollection | This class implements a collection of CapabilityContainerOneValue objects.
CapabilityContainerOneValueFloat | This class implements a capability container for storing a float value.
CapabilityContainerOneValueString | This class implements a capability container for storing a string value.
CapabilityContainerRange | This class implements a range type container for storing capability information.
CapabilityNotSupportedException | This exception is thrown if an operation is performed using an unsupported capability.
Caption | This class implements an object that stores the settings used to place a caption on images when they are scanned.
ClipboardException | This exception is thrown if an error occurs trying to open the clipboard with the CopyToClipboard or CutToClipboard method.
CompressedImageNotAvailableException | This exception is thrown if no compressed image is available for the requested operation or an unsupported compressed image format was returned in response to a StartSession.
DataSourceCollection | A read-only collection of Data Source product names which is set by calling the OpenDataSourceManager method.
DataSourceInvalidOperationException | This exception is thrown if the Data Source performs an operation that caused an exception.
ExtendedImageInfoContainer | This class implements extended image info.
ExtendedImageInfoContainerValue | This class implements a single value of extended image info.
ExtendedImageInfoContainerValueCollection | This class represents a collection of ExtendedImageInfoContainerValue objects.
ExtendedImageInfoContainerValueFloat | This class implements a float value of extended image info.
ExtendedImageInfoContainerValueString | This class implements a string value of extended image info.
FileCreateException | This exception is thrown if TwainPRO is unable to create the file specified in the Save method.
FileOpenException | This exception is thrown if TwainPRO is unable to open an existing file to append pages when saving a multi-page image file, or if TwainPRO is unable to open a settings file.
FileReadException | This exception is thrown if TwainPRO is unable to read an existing file to append pages when saving a multi-page image file, or if TwainPRO is unable to read a settings file.
FileWriteException | This exception is thrown if an error occurs while TwainPRO is attempting to save a file to the path specified in the Save method, or while TwainPRO is attempting to write a settings file.
FtpOptions | This class implements properties and methods necessary for authentication and remote processing when saving an image.
FtpTransferException | This exception is thrown if an error occurs trying to FTP an image.
ImageNotAvailableException | This exception is thrown if no image is available for the requested operation or an unsupported DIB format was returned in response to a StartSession.
IndexOutOfRangeException | This exception is thrown if the requested index was out of range for the property array.
InternalErrorException | This exception is thrown if an internal failure occurs.
InternetFilesNotInstalledException | This exception is thrown if the required Internet DLL file(s) are missing.
InvalidBitDepthException | This exception is thrown if an invalid image resolution for the selected file format or an unsupported bits per pixel was returned from a StartSession.
InvalidLicenseException | This exception is thrown if a user attempts to access functionality that is not covered under the license in effect.
InvalidPropertyException | This exception is thrown if a property was set or queried that was not valid for the current capability type.
Licensing | This class implements methods for setting the license information for the toolkit.
LoadSettingsException | This exception is thrown if an error occurs when loading a settings file.
OperationCancelledException | This exception is thrown if the user cancelled the requested operation.
OutOfMemoryException | This exception is thrown if TwainPRO is unable to allocate memory for the requested operation.
PegasusFilesNotInstalledException | This exception is thrown if the required Pegasus DLL file(s) are missing.
PropertyOrMethodNotAvailableException | This exception is thrown if the property or method requested is not currently available.
SaveOptions | This class implements file writing of image formats.
SaveOptionsJpeg | Implements SaveOptions for the JPEG file format.
SaveOptionsPdf | This class implements SaveOptions for the PDF file format.
SaveOptionsPic | This class implements objects for saving PIC options.
SaveOptionsTiff | Implements SaveOptions for the TIFF file format.
ScannedEventArgs | Arguments for a scanned event.
ScannedImage | This class implements the scanned image and image information.
ScannedImageData | This class implements objects that contain the scanned image information.
ScanningEventArgs | Arguments for a scanning event.
SequenceException | This exception is thrown if an illegal operation is performed for the current Source Manager or Source state.
StringIsTooLongException | This exception is thrown if a TwainPRO property was set to a string with too many characters.
TiffTagItemNotFoundException | This exception is thrown if a TIFF tag item is not found.
TiffTagNotFoundException | This exception is thrown if a TIFF tag is not found.
TwainDevice | This class implements methods and properties for all TWAIN device interaction.
TwainDllLoadException | This exception is thrown if TwainPRO is unable to find or load twain_32.dll.
TwainException | This exception is thrown if a TWAIN error occurs.
TwainPro | The main object for this component.
TwainProException | This class implements the base class for TwainPro Exceptions.
UnsupportedFileFormatException | This exception is thrown if the default file type is set and a file is saved using the extension of a file format that is not supported by TwainPRO, or if an invalid settings file is loaded. Supported file types are BMP, JPEG, ePIC, TIF, and PDF.
ValueOutOfRangeException | This exception is thrown if a TwainPRO property was set to an invalid value.

Enumerations

Enumeration | Description
AdvancedCapability | Option values which determine the advanced TWAIN capability.
AdvancedCapabilityConstants | Option values which determine the TWAIN capability constants for advanced capabilities.
Capability | Option values which determine the TWAIN capability.
CapabilityConstants | Option values which determine the capability constants.
ConditionCode | Option values which determine TWAIN condition codes.
EncodeModeCompression | Option values which specify the encoding mode to use when creating a JBIG2 compressed file.
ErrorLevel | The error level of items to place into the debug log.
EvaluationMode | Option values which determine the evaluation mode of the component.
ExtendedImageInfo | Option values for extended image info enumeration values.
ExtendedImageInfoConstants | Option values for extended image info constants enumeration values.
FileOrganizationCompression | Option values which determine the file organization when saving a JBIG2 compressed file.
HorizontalAlignment | Option values which determine the horizontal alignment of the caption within the clipping rectangle.
Orientation | Option values which determine the TWAIN capability constants for the ICAP_ORIENTATION capability.
PdfCompression | Option values which determine the PDF compression.
PixelType | Option values which determine the type of pixel data that a Source is capable of acquiring (for example, black and white, gray, RGB, etc.).
ScannedImageCompression | Option values which determine the compression format of an acquired image.
ScannedImageFormat | Option values which determine the format of the saved file.
SubSampling | Option values which determine the subsampling type for a JPEG, ePIC, or JPEG compressed PDF file format.
SupportedSizes | Option values which determine the TWAIN capability constants for the ICAP_SUPPORTEDSIZES capability.
TiffCompression | Option values which determine TIFF compression enumeration values.
TransferMode | Option values which determine transferring images from the Data Source.
VerticalAlignment | Option values which determine the vertical alignment of the caption within the clipping rectangle.

Delegates

Delegate | Description
ScannedEventHandler | A delegate for post-scan events.
ScanningEventHandler | A delegate for pre-scan events.

See Also

PegasusImaging.WinForms.TwainPRO5 Assembly


ApplicationIdentity Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ApplicationIdentity Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ApplicationIdentity Class

PegasusImaging.WinForms.TwainPro5 Namespace : ApplicationIdentity Class (PegasusImaging.WinForms.TwainPro5)

An object that represents the TWAIN identity of the application.

For a list of all members of this type, see ApplicationIdentity members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.TwainPro5.ApplicationIdentity

Syntax

[Visual Basic]
Public Class ApplicationIdentity
[C#]
public class ApplicationIdentity
[C++]
public __gc class ApplicationIdentity
[C++/CLI]
public ref class ApplicationIdentity

Remarks

All TWAIN Data Sources and applications have a TWAIN Identity. This enables the TWAIN Data Source Manager (DSM) to keep track of all running TWAIN applications and Data Sources.

A TWAIN Identity consists of four strings: Product Name, Product Family, Manufacturer and Version Information.

These identities can be set for TwainPRO applications using the ProductName, ProductFamily, Manufacturer and VersionInfo properties respectively.

These properties are part of TwainPRO Session Initialization so they need to be set before calling the TwainDevice.OpenSession or TwainDevice.StartSession methods.

Some Data Source User Interfaces will display a progress indicator during image transfer that displays the application's Product Name Identity.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

ApplicationIdentity Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ApplicationIdentity Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ApplicationIdentity Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : ApplicationIdentity Class (PegasusImaging.WinForms.TwainPro5)

ApplicationIdentity overview

Public Properties

Public Property Manufacturer | Gets or sets the Manufacturer string for the application identity.
Public Property ProductFamily | Gets or sets the Product Family string for the application identity.
Public Property ProductName | Gets or sets the Product Name for the application identity.
Public Property VersionInfo | Gets or sets the Version Information for the application identity.

Public Methods

Public Method Dispose Disposes of any unused resources.

See Also

ApplicationIdentity Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ApplicationIdentity Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ApplicationIdentity Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : ApplicationIdentity Class (PegasusImaging.WinForms.TwainPro5)

For a list of all members of this type, see ApplicationIdentity members.

Public Methods

Public Method Dispose Disposes of any unused resources.

See Also

ApplicationIdentity Class | PegasusImaging.WinForms.TwainPro5 Namespace


Dispose Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ApplicationIdentity Class | ApplicationIdentity Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.TwainPro5 Namespace > ApplicationIdentity Class : Dispose Method (ApplicationIdentity)

Disposes of any unused resources.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

Remarks

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

ApplicationIdentity Class | ApplicationIdentity Members


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ApplicationIdentity Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ApplicationIdentity Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : ApplicationIdentity Class (PegasusImaging.WinForms.TwainPro5)

For a list of all members of this type, see ApplicationIdentity members.

Public Properties

Public Property Manufacturer | Gets or sets the Manufacturer string for the application identity.
Public Property ProductFamily | Gets or sets the Product Family string for the application identity.
Public Property ProductName | Gets or sets the Product Name for the application identity.
Public Property VersionInfo | Gets or sets the Version Information for the application identity.

See Also

ApplicationIdentity Class | PegasusImaging.WinForms.TwainPro5 Namespace


Manufacturer Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ApplicationIdentity Class | ApplicationIdentity Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Manufacturer Property

PegasusImaging.WinForms.TwainPro5 Namespace > ApplicationIdentity Class : Manufacturer Property

Gets or sets the Manufacturer string for the application identity.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the Manufacturer string for the application identity.")>
Public Property Manufacturer As String
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the Manufacturer string for the application identity.")]
public string Manufacturer {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the Manufacturer string for the application identity.")]
public: __property string* get_Manufacturer();
public: __property void set_Manufacturer(
   string* value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the Manufacturer string for the application identity.")]
public:
property String^ Manufacturer {
   String^ get();
   void set (String^ value);
}

Value

A string value which represents the application identity.

Remarks

The default value is an empty string "".

The Manufacturer property is used to identify a company name as manufacturer of an application. This information is sent to the TWAIN Data Source Manager. The application identity consists of the Manufacturer, ProductFamily, ProductName and VersionInfo properties.

This property should be set prior to invoking the TwainDevice.OpenSession or TwainDevice.StartSession methods.

Requirements

See Also

ApplicationIdentity Class | ApplicationIdentity Members


ProductFamily Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ApplicationIdentity Class | ApplicationIdentity Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ProductFamily Property

PegasusImaging.WinForms.TwainPro5 Namespace > ApplicationIdentity Class : ProductFamily Property

Gets or sets the Product Family string for the application identity.

[Visual Basic]
<DescriptionAttribute("Gets or sets the Product Family string for the application identity.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
Public Property ProductFamily As String
[C#]
[DescriptionAttribute("Gets or sets the Product Family string for the application identity.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public string ProductFamily {get; set;}
[C++]
[DescriptionAttribute("Gets or sets the Product Family string for the application identity.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public: __property string* get_ProductFamily();
public: __property void set_ProductFamily(
   string* value
);
[C++/CLI]
[DescriptionAttribute("Gets or sets the Product Family string for the application identity.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public:
property String^ ProductFamily {
   String^ get();
   void set (String^ value);
}

Value

A string value which represents the product family application identity.

Remarks

The default value is an empty string "".

This property is used to identify a software group that the application belongs to. This information is sent to the TWAIN Data Source Manager. The application identity consists of the Manufacturer, ProductFamily, ProductName and VersionInfo properties.

This property should be set prior to invoking the TwainDevice.OpenSession or TwainDevice.StartSession methods.

Requirements

See Also

ApplicationIdentity Class | ApplicationIdentity Members


ProductName Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ApplicationIdentity Class | ApplicationIdentity Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ProductName Property

PegasusImaging.WinForms.TwainPro5 Namespace > ApplicationIdentity Class : ProductName Property

Gets or sets the Product Name for the application identity.

[Visual Basic]
<DescriptionAttribute("Gets or sets the Product Name string for the application identity.")>
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
Public Property ProductName As String
[C#]
[DescriptionAttribute("Gets or sets the Product Name string for the application identity.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public string ProductName {get; set;}
[C++]
[DescriptionAttribute("Gets or sets the Product Name string for the application identity.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public: __property string* get_ProductName();
public: __property void set_ProductName(
   string* value
);
[C++/CLI]
[DescriptionAttribute("Gets or sets the Product Name string for the application identity.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public:
property String^ ProductName {
   String^ get();
   void set (String^ value);
}

Value

A string value which represents the product name.

Remarks

The default value is an empty string "".

The ProductName property is used to identify an application name. This information is sent to the TWAIN Data Source Manager. The application identity consists of the Manufacturer, ProductFamily, ProductName and VersionInfo properties.

This property should be set prior to invoking the TwainDevice.OpenSession or TwainDevice.StartSession methods.

ProductName is the most common method for identifying TWAIN applications for Data Sources. Product names for applications are displayed by some Data Sources.

Requirements

See Also

ApplicationIdentity Class | ApplicationIdentity Members


VersionInfo Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ApplicationIdentity Class | ApplicationIdentity Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

VersionInfo Property

PegasusImaging.WinForms.TwainPro5 Namespace > ApplicationIdentity Class : VersionInfo Property

Gets or sets the Version Information for the application identity.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the Version Information string for the application identity.")>
<BrowsableAttribute(False)>
Public Property VersionInfo As String
[C#]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the Version Information string for the application identity.")]
[BrowsableAttribute(false)]
public string VersionInfo {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the Version Information string for the application identity.")]
[BrowsableAttribute(false)]
public: __property string* get_VersionInfo();
public: __property void set_VersionInfo(
   string* value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the Version Information string for the application identity.")]
[BrowsableAttribute(false)]
public:
property String^ VersionInfo {
   String^ get();
   void set (String^ value);
}

Value

A string value which represents the version information for the application.

Remarks

The default value is an empty string "".

This property is used to identify an application's version. This information is sent to the TWAIN Data Source Manager. The application identity consists of the Manufacturer, ProductFamily, ProductName and VersionInfo properties.

This property should be set prior to invoking the TwainDevice.OpenSession or TwainDevice.StartSession methods.

Requirements

See Also

ApplicationIdentity Class | ApplicationIdentity Members


CapabilityContainer Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainer Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainer Class

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityContainer Class

This class contains the capability information.

For a list of all members of this type, see CapabilityContainer members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.TwainPro5.CapabilityContainer
PegasusImaging.WinForms.TwainPro5.CapabilityContainerArray
PegasusImaging.WinForms.TwainPro5.CapabilityContainerEnum
PegasusImaging.WinForms.TwainPro5.CapabilityContainerOneValue
PegasusImaging.WinForms.TwainPro5.CapabilityContainerRange

Syntax

[Visual Basic]
Public Class CapabilityContainer
[C#]
public class CapabilityContainer
[C++]
public __gc class CapabilityContainer
[C++/CLI]
public ref class CapabilityContainer

Remarks

This object stores all the information of a capability.

The CapabilityContainerOneValue, CapabilityContainerEnum, CapabilityContainerRange, and CapabilityContainerArray objects that are inherited from this object can be filled with information and passed to the TwainDevice.SetCapability method to set the value of a capability. The TwainDevice.GetCapability(Capability) method returns a CapabilityContainerOneValue, CapabilityContainerEnum, CapabilityContainerRange, or CapabilityContainerArray object of this type which can be casted to the appropriate child object to access the capability information.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

CapabilityContainer Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainer Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainer Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityContainer Class

CapabilityContainer overview

Public Properties

Public Property Capability Gets and sets which TWAIN capability to negotiate.

See Also

CapabilityContainer Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainer Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainer Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityContainer Class

For a list of all members of this type, see CapabilityContainer members.

Public Properties

Public Property Capability Gets and sets which TWAIN capability to negotiate.

See Also

CapabilityContainer Class | PegasusImaging.WinForms.TwainPro5 Namespace


Capability Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainer Class | CapabilityContainer Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Capability Property

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainer Class : Capability Property (CapabilityContainer)

Gets and sets which TWAIN capability to negotiate.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("Specifies which TWAIN capability to negotiate.")>
<BrowsableAttribute(False)>
Public Property Capability As Integer
[C#]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Specifies which TWAIN capability to negotiate.")]
[BrowsableAttribute(false)]
public int Capability {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Specifies which TWAIN capability to negotiate.")]
[BrowsableAttribute(false)]
public: __property int get_Capability();
public: __property void set_Capability(
   int value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Specifies which TWAIN capability to negotiate.")]
[BrowsableAttribute(false)]
public:
property int Capability {
   int get();
   void set (int value);
}

Value

An integer value which represents the Twain capability.

Remarks

Gets or sets the value of the TWAIN Capability that is negotiated when the TwainDevice.SetCapability method is called.

Requirements

See Also

CapabilityContainer Class | CapabilityContainer Members


CapabilityContainerArray Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerArray Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerArray Class

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityContainerArray Class

This class is an array type container for storing capability information.

For a list of all members of this type, see CapabilityContainerArray members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.TwainPro5.CapabilityContainer
PegasusImaging.WinForms.TwainPro5.CapabilityContainerArray

Syntax

[Visual Basic]
Public Class CapabilityContainerArray
   Inherits CapabilityContainer
[C#]
public class CapabilityContainerArray : CapabilityContainer
[C++]
public __gc class CapabilityContainerArray : public CapabilityContainer
[C++/CLI]
public ref class CapabilityContainerArray : public CapabilityContainer

Remarks

This object stores an array of capability values. This type is less common.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

CapabilityContainerArray Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerArray Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerArray Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityContainerArray Class

CapabilityContainerArray overview

Public Constructors

Public Constructor CapabilityContainerArray Constructor Overloaded. An array container for storing capability information.

Public Properties

Public Property Capability (Inherited from CapabilityContainer) | Gets and sets which TWAIN capability to negotiate.
Public Property Values | Gets a collection of capability values.

See Also

CapabilityContainerArray Class | PegasusImaging.WinForms.TwainPro5 Namespace


CapabilityContainerArray Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerArray Class | CapabilityContainerArray Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerArray Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerArray Class : CapabilityContainerArray Constructor (CapabilityContainerArray)

An array container for storing capability information.

Overload List

An array container for storing capability information.

[Visual Basic] Public Sub New(Integer)

[C#] public CapabilityContainerArray(int);

[C++] public CapabilityContainerArray(int);

[C++/CLI] public CapabilityContainerArray(int);

An array container for storing capability information.

[Visual Basic] Public Sub New(Capability)

[C#] public CapabilityContainerArray(Capability);

[C++] public CapabilityContainerArray(Capability);

[C++/CLI] public CapabilityContainerArray(Capability);

An array container for storing capability information.

[Visual Basic] Public Sub New(AdvancedCapability)

[C#] public CapabilityContainerArray(AdvancedCapability);

[C++] public CapabilityContainerArray(AdvancedCapability);

[C++/CLI] public CapabilityContainerArray(AdvancedCapability);

Requirements

See Also

CapabilityContainerArray Class | CapabilityContainerArray Members


CapabilityContainerArray Constructor(AdvancedCapability)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerArray Class | CapabilityContainerArray Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

capability
A capability object.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerArray Constructor(AdvancedCapability)

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerArray Class > CapabilityContainerArray Constructor : CapabilityContainerArray Constructor(AdvancedCapability)

An array container for storing capability information.

[Visual Basic]
Public Function New( _
   ByVal capability As AdvancedCapability _
)
[C#]
public CapabilityContainerArray(
   AdvancedCapability capability
);
[C++]
public: CapabilityContainerArray(
   AdvancedCapability capability
)
[C++/CLI]
public:
CapabilityContainerArray(
   AdvancedCapability capability
)

Parameters

capability
A capability object.

Requirements

See Also

CapabilityContainerArray Class | CapabilityContainerArray Members | Overload List


CapabilityContainerArray Constructor(Capability)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerArray Class | CapabilityContainerArray Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

capability
A capability object.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerArray Constructor(Capability)

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerArray Class > CapabilityContainerArray Constructor : CapabilityContainerArray Constructor(Capability)

An array container for storing capability information.

[Visual Basic]
Public Function New( _
   ByVal capability As Capability _
)
[C#]
public CapabilityContainerArray(
   Capability capability
);
[C++]
public: CapabilityContainerArray(
   Capability capability
)
[C++/CLI]
public:
CapabilityContainerArray(
   Capability capability
)

Parameters

capability
A capability object.

Requirements

See Also

CapabilityContainerArray Class | CapabilityContainerArray Members | Overload List


CapabilityContainerArray Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerArray Class | CapabilityContainerArray Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

capability
A capability object.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerArray Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerArray Class > CapabilityContainerArray Constructor : CapabilityContainerArray Constructor(Int32)

An array container for storing capability information.

[Visual Basic]
Public Function New( _
   ByVal capability As Integer _
)
[C#]
public CapabilityContainerArray(
   int capability
);
[C++]
public: CapabilityContainerArray(
   int capability
)
[C++/CLI]
public:
CapabilityContainerArray(
   int capability
)

Parameters

capability
A capability object.

Requirements

See Also

CapabilityContainerArray Class | CapabilityContainerArray Members | Overload List


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerArray Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerArray Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityContainerArray Class

For a list of all members of this type, see CapabilityContainerArray members.

Public Properties

Public Property Capability (Inherited from CapabilityContainer) | Gets and sets which TWAIN capability to negotiate.
Public Property Values | Gets a collection of capability values.

See Also

CapabilityContainerArray Class | PegasusImaging.WinForms.TwainPro5 Namespace


Values Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerArray Class | CapabilityContainerArray Members | CapabilityContainerOneValueCollection Class

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Values Property

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerArray Class : Values Property (CapabilityContainerArray)

Gets a collection of capability values.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property Values As CapabilityContainerOneValueCollection
[C#]
[BrowsableAttribute(false)]
public CapabilityContainerOneValueCollection Values {get;}
[C++]
[BrowsableAttribute(false)]
public: __property CapabilityContainerOneValueCollection* get_Values();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property CapabilityContainerOneValueCollection^ Values {
   CapabilityContainerOneValueCollection^ get();
}

Value

A CapabilityContainerOneValueCollection object which contains capability information.

Remarks

Returns a CapabilityContainerOneValueCollection which contains a collection of capability information that can be accessed or set with values.

Requirements

See Also

CapabilityContainerArray Class | CapabilityContainerArray Members | CapabilityContainerOneValueCollection Class


CapabilityContainerEnum Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerEnum Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerEnum Class

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityContainerEnum Class

A class which contains enumeration capability information.

For a list of all members of this type, see CapabilityContainerEnum members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.TwainPro5.CapabilityContainer
PegasusImaging.WinForms.TwainPro5.CapabilityContainerEnum

Syntax

[Visual Basic]
Public Class CapabilityContainerEnum
   Inherits CapabilityContainer
[C#]
public class CapabilityContainerEnum : CapabilityContainer
[C++]
public __gc class CapabilityContainerEnum : public CapabilityContainer
[C++/CLI]
public ref class CapabilityContainerEnum : public CapabilityContainer

Remarks

This object stores a list of capability values, the current value, and the default value.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

CapabilityContainerEnum Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerEnum Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerEnum Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityContainerEnum Class

CapabilityContainerEnum overview

Public Constructors

Public Constructor CapabilityContainerEnum Constructor Overloaded. A constructor which allows passing in a capability ID by integer.

Public Properties

Public Property Capability (Inherited from CapabilityContainer) | Gets and sets which TWAIN capability to negotiate.
Public Property CurrentValue | Gets or sets the current capability value.
Public Property DefaultValue | Gets the default capability value.
Public Property Values | Gets a collection for storing capability values.

See Also

CapabilityContainerEnum Class | PegasusImaging.WinForms.TwainPro5 Namespace


CapabilityContainerEnum Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerEnum Class | CapabilityContainerEnum Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerEnum Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerEnum Class : CapabilityContainerEnum Constructor (CapabilityContainerEnum)

A constructor which allows passing in a capability ID by integer.

Overload List

A constructor which allows passing in a capability ID by integer.

[Visual Basic] Public Sub New(Integer)

[C#] public CapabilityContainerEnum(int);

[C++] public CapabilityContainerEnum(int);

[C++/CLI] public CapabilityContainerEnum(int);

A constructor which allows passing in a capability by object.

[Visual Basic] Public Sub New(Capability)

[C#] public CapabilityContainerEnum(Capability);

[C++] public CapabilityContainerEnum(Capability);

[C++/CLI] public CapabilityContainerEnum(Capability);

A constructor which allows passing in an advanced capability.

[Visual Basic] Public Sub New(AdvancedCapability)

[C#] public CapabilityContainerEnum(AdvancedCapability);

[C++] public CapabilityContainerEnum(AdvancedCapability);

[C++/CLI] public CapabilityContainerEnum(AdvancedCapability);

Requirements

See Also

CapabilityContainerEnum Class | CapabilityContainerEnum Members


CapabilityContainerEnum Constructor(AdvancedCapability)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerEnum Class | CapabilityContainerEnum Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

capability
An AdvancedCapability which represents the advanced capability information.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerEnum Constructor(AdvancedCapability)

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerEnum Class > CapabilityContainerEnum Constructor : CapabilityContainerEnum Constructor(AdvancedCapability)

A constructor which allows passing in an advanced capability.

[Visual Basic]
Public Function New( _
   ByVal capability As AdvancedCapability _
)
[C#]
public CapabilityContainerEnum(
   AdvancedCapability capability
);
[C++]
public: CapabilityContainerEnum(
   AdvancedCapability capability
)
[C++/CLI]
public:
CapabilityContainerEnum(
   AdvancedCapability capability
)

Parameters

capability
An AdvancedCapability which represents the advanced capability information.

Requirements

See Also

CapabilityContainerEnum Class | CapabilityContainerEnum Members | Overload List


CapabilityContainerEnum Constructor(Capability)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerEnum Class | CapabilityContainerEnum Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

capability
A Capability which contains the capability information.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerEnum Constructor(Capability)

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerEnum Class > CapabilityContainerEnum Constructor : CapabilityContainerEnum Constructor(Capability)

A constructor which allows passing in a capability by object.

[Visual Basic]
Public Function New( _
   ByVal capability As Capability _
)
[C#]
public CapabilityContainerEnum(
   Capability capability
);
[C++]
public: CapabilityContainerEnum(
   Capability capability
)
[C++/CLI]
public:
CapabilityContainerEnum(
   Capability capability
)

Parameters

capability
A Capability which contains the capability information.

Requirements

See Also

CapabilityContainerEnum Class | CapabilityContainerEnum Members | Overload List


CapabilityContainerEnum Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerEnum Class | CapabilityContainerEnum Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

capability
An integer value which represents the capability.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerEnum Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerEnum Class > CapabilityContainerEnum Constructor : CapabilityContainerEnum Constructor(Int32)

A constructor which allows passing in a capability ID by integer.

[Visual Basic]
Public Function New( _
   ByVal capability As Integer _
)
[C#]
public CapabilityContainerEnum(
   int capability
);
[C++]
public: CapabilityContainerEnum(
   int capability
)
[C++/CLI]
public:
CapabilityContainerEnum(
   int capability
)

Parameters

capability
An integer value which represents the capability.

Requirements

See Also

CapabilityContainerEnum Class | CapabilityContainerEnum Members | Overload List


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerEnum Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerEnum Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityContainerEnum Class

For a list of all members of this type, see CapabilityContainerEnum members.

Public Properties

Public Property Capability (Inherited from CapabilityContainer) | Gets and sets which TWAIN capability to negotiate.
Public Property CurrentValue | Gets or sets the current capability value.
Public Property DefaultValue | Gets the default capability value.
Public Property Values | Gets a collection for storing capability values.

See Also

CapabilityContainerEnum Class | PegasusImaging.WinForms.TwainPro5 Namespace


CurrentValue Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerEnum Class | CapabilityContainerEnum Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CurrentValue Property

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerEnum Class : CurrentValue Property

Gets or sets the current capability value.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("The current capability value.")>
<BrowsableAttribute(False)>
Public Property CurrentValue As CapabilityContainerOneValue
[C#]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("The current capability value.")]
[BrowsableAttribute(false)]
public CapabilityContainerOneValue CurrentValue {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("The current capability value.")]
[BrowsableAttribute(false)]
public: __property CapabilityContainerOneValue* get_CurrentValue();
public: __property void set_CurrentValue(
   CapabilityContainerOneValue* value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("The current capability value.")]
[BrowsableAttribute(false)]
public:
property CapabilityContainerOneValue^ CurrentValue {
   CapabilityContainerOneValue^ get();
   void set (CapabilityContainerOneValue^ value);
}

Value

A CapabilityContainerOneValue object which represents the current capability value.

Remarks

This property accesses the current value of the capability.

Requirements

See Also

CapabilityContainerEnum Class | CapabilityContainerEnum Members


DefaultValue Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerEnum Class | CapabilityContainerEnum Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

DefaultValue Property

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerEnum Class : DefaultValue Property

Gets the default capability value.

[Visual Basic]
<DescriptionAttribute("The default capability value.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property DefaultValue As CapabilityContainerOneValue
[C#]
[DescriptionAttribute("The default capability value.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public CapabilityContainerOneValue DefaultValue {get;}
[C++]
[DescriptionAttribute("The default capability value.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property CapabilityContainerOneValue* get_DefaultValue();
[C++/CLI]
[DescriptionAttribute("The default capability value.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property CapabilityContainerOneValue^ DefaultValue {
   CapabilityContainerOneValue^ get();
}

Value

A CapabilityContainerOneValue object which contains the default capability value.

Remarks

Gets the default CapabilityContainerOneValue of the capability.

Requirements

See Also

CapabilityContainerEnum Class | CapabilityContainerEnum Members


Values Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerEnum Class | CapabilityContainerEnum Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Values Property

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerEnum Class : Values Property (CapabilityContainerEnum)

Gets a collection for storing capability values.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property Values As CapabilityContainerOneValueCollection
[C#]
[BrowsableAttribute(false)]
public CapabilityContainerOneValueCollection Values {get;}
[C++]
[BrowsableAttribute(false)]
public: __property CapabilityContainerOneValueCollection* get_Values();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property CapabilityContainerOneValueCollection^ Values {
   CapabilityContainerOneValueCollection^ get();
}

Value

A CapabilityContainerOneValueCollection which contains capability values.

Remarks

Returns a collection of CapabilityOneValue objects that can be accessed or set with values.

Requirements

See Also

CapabilityContainerEnum Class | CapabilityContainerEnum Members


CapabilityContainerOneValue Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValue Members | PegasusImaging.WinForms.TwainPro5 Namespace | CapabilityContainerOneValueFloat Class | CapabilityContainerOneValueString Class

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerOneValue Class

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityContainerOneValue Class

This class implements a one value type container for storing capability information.

For a list of all members of this type, see CapabilityContainerOneValue members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.TwainPro5.CapabilityContainer
PegasusImaging.WinForms.TwainPro5.CapabilityContainerOneValue
PegasusImaging.WinForms.TwainPro5.CapabilityContainerOneValueFloat
PegasusImaging.WinForms.TwainPro5.CapabilityContainerOneValueString

Syntax

[Visual Basic]
Public Class CapabilityContainerOneValue
   Inherits CapabilityContainer
[C#]
public class CapabilityContainerOneValue : CapabilityContainer
[C++]
public __gc class CapabilityContainerOneValue : public CapabilityContainer
[C++/CLI]
public ref class CapabilityContainerOneValue : public CapabilityContainer

Remarks

This object stores one capability value.

Note: You cannot create a CapabilityContainerOneValue object directly. The CapabilityContainerOneValueFloat and CapabilityContainerOneValueString objects are inherited from this object and should be used, respectively, for setting a capability containing one float value or a capability containing one string value.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

CapabilityContainerOneValue Members | PegasusImaging.WinForms.TwainPro5 Namespace | CapabilityContainerOneValueFloat Class | CapabilityContainerOneValueString Class


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValue Class | PegasusImaging.WinForms.TwainPro5 Namespace | CapabilityContainerOneValueFloat Class | CapabilityContainerOneValueString Class

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerOneValue Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityContainerOneValue Class

CapabilityContainerOneValue overview

Public Properties

Public Property Capability (Inherited from CapabilityContainer) Gets and sets which TWAIN capability to negotiate.

See Also

CapabilityContainerOneValue Class | PegasusImaging.WinForms.TwainPro5 Namespace | CapabilityContainerOneValueFloat Class | CapabilityContainerOneValueString Class


CapabilityContainerOneValueCollection Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueCollection Members | PegasusImaging.WinForms.TwainPro5 Namespace | CapabilityContainerOneValue Class | CapabilityContainerEnum Class

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerOneValueCollection Class

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityContainerOneValueCollection Class

This class implements a collection of CapabilityContainerOneValue objects.

For a list of all members of this type, see CapabilityContainerOneValueCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PegasusImaging.WinForms.TwainPro5.CapabilityContainerOneValueCollection

Syntax

[Visual Basic]
<DefaultMemberAttribute("Item")>
Public Class CapabilityContainerOneValueCollection
   Inherits CollectionBase
[C#]
[DefaultMemberAttribute("Item")]
public class CapabilityContainerOneValueCollection : CollectionBase
[C++]
[DefaultMemberAttribute("Item")]
public __gc class CapabilityContainerOneValueCollection : public CollectionBase
[C++/CLI]
[DefaultMemberAttribute("Item")]
public ref class CapabilityContainerOneValueCollection : public CollectionBase

Remarks

This object is used by the CapabilityContainerArray and the CapabilityContainerEnum to store a collection of capability values.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

CapabilityContainerOneValueCollection Members | PegasusImaging.WinForms.TwainPro5 Namespace | CapabilityContainerOneValue Class | CapabilityContainerEnum Class


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueCollection Class | PegasusImaging.WinForms.TwainPro5 Namespace | CapabilityContainerOneValue Class | CapabilityContainerEnum Class

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerOneValueCollection Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityContainerOneValueCollection Class

CapabilityContainerOneValueCollection overview

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count | Gets the number of values in the collection.
Public Property Item | Gets or sets the element at the given index.

Public Methods

Public Method Add | Adds a CapabilityContainerOneValue to the collection.
Public Method Clear (Inherited from System.Collections.CollectionBase) | Removes all objects from the CollectionBase instance.
Public Method Contains | Determines if the specified CapabilityContainerOneValue is contained in the collection.
Public Method CopyTo | Copies all elements of the collection to the specified array, beginning at the specified index in the array.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method IndexOf | Searches the collection for the specified CapabilityContainerOneValue and returns the index value of it.
Public Method Insert | Inserts a CapabilityContainerOneValue into the collection at the given index.
Public Method Remove | Removes a CapabilityContainerOneValue from the collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) | Removes the element at the specified index of the CollectionBase instance.

See Also

CapabilityContainerOneValueCollection Class | PegasusImaging.WinForms.TwainPro5 Namespace | CapabilityContainerOneValue Class | CapabilityContainerEnum Class


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueCollection Class | PegasusImaging.WinForms.TwainPro5 Namespace | CapabilityContainerOneValue Class | CapabilityContainerEnum Class

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerOneValueCollection Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityContainerOneValueCollection Class

For a list of all members of this type, see CapabilityContainerOneValueCollection members.

Public Methods

Public Method Add | Adds a CapabilityContainerOneValue to the collection.
Public Method Clear (Inherited from System.Collections.CollectionBase) | Removes all objects from the CollectionBase instance.
Public Method Contains | Determines if the specified CapabilityContainerOneValue is contained in the collection.
Public Method CopyTo | Copies all elements of the collection to the specified array, beginning at the specified index in the array.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method IndexOf | Searches the collection for the specified CapabilityContainerOneValue and returns the index value of it.
Public Method Insert | Inserts a CapabilityContainerOneValue into the collection at the given index.
Public Method Remove | Removes a CapabilityContainerOneValue from the collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) | Removes the element at the specified index of the CollectionBase instance.

See Also

CapabilityContainerOneValueCollection Class | PegasusImaging.WinForms.TwainPro5 Namespace | CapabilityContainerOneValue Class | CapabilityContainerEnum Class


Add Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueCollection Class | CapabilityContainerOneValueCollection Members | CapabilityContainerOneValue Class

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Add Method

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerOneValueCollection Class : Add Method (CapabilityContainerOneValueCollection)

Adds a CapabilityContainerOneValue to the collection.

[Visual Basic]
Public Function Add( _
   ByVal value As CapabilityContainerOneValue _
) As Integer
[C#]
public int Add(
   CapabilityContainerOneValue value
);
[C++]
public: int Add(
   CapabilityContainerOneValue* value
)
[C++/CLI]
public:
int Add(
   CapabilityContainerOneValue^ value
)

Parameters

value

Return Type

An integer value which represents the new index value after adding the element to the collection.

Remarks

This method inserts a new CapabilityContainerOneValue object at the end of the collection. When this method is complete, the length of the collection will be one larger than it was and the element with the highest index will be the new object.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

CapabilityContainerOneValueCollection Class | CapabilityContainerOneValueCollection Members | CapabilityContainerOneValue Class


Contains Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueCollection Class | CapabilityContainerOneValueCollection Members | CapabilityContainerOneValue Class

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Contains Method

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerOneValueCollection Class : Contains Method (CapabilityContainerOneValueCollection)

Determines if the specified CapabilityContainerOneValue is contained in the collection.

[Visual Basic]
Public Function Contains( _
   ByVal value As CapabilityContainerOneValue _
) As Boolean
[C#]
public bool Contains(
   CapabilityContainerOneValue value
);
[C++]
public: bool Contains(
   CapabilityContainerOneValue* value
)
[C++/CLI]
public:
bool Contains(
   CapabilityContainerOneValue^ value
)

Parameters

value

Return Type

A boolean value which is True if the specified object is in the collection. Otherwise, False is returned.

Remarks

This method searches the collection for the given CapabilityContainerOneValue. If a reference to the CapabilityContainerOneValue is found, this method returns true, otherwise, false is returned.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

CapabilityContainerOneValueCollection Class | CapabilityContainerOneValueCollection Members | CapabilityContainerOneValue Class


CopyTo Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueCollection Class | CapabilityContainerOneValueCollection Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

array
Contains an array that receives the elements of the collection.
index
Contains the zero-based index in array where this method starts copying the collection.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CopyTo Method

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerOneValueCollection Class : CopyTo Method (CapabilityContainerOneValueCollection)

Copies all elements of the collection to the specified array, beginning at the specified index in the array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As CapabilityContainerOneValue, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   CapabilityContainerOneValue[] array,
   int index
);
[C++]
public: void CopyTo(
   CapabilityContainerOneValue*[]* array,
   int index
)
[C++/CLI]
public:
void CopyTo(
   CapabilityContainerOneValue^array<array>^ array,
   int index
)

Parameters

array
Contains an array that receives the elements of the collection.
index
Contains the zero-based index in array where this method starts copying the collection.

Remarks

This method implements a standard collection operation. It copies elements from this collection to the given array in order, starting at element 0 in this collection. It places the elements into the array starting at the given zero-based index. This method will stop copying elements when it reaches the end of the collection or the end of the array.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

CapabilityContainerOneValueCollection Class | CapabilityContainerOneValueCollection Members


IndexOf Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueCollection Class | CapabilityContainerOneValueCollection Members | CapabilityContainerOneValue Class

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

IndexOf Method

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerOneValueCollection Class : IndexOf Method (CapabilityContainerOneValueCollection)

Searches the collection for the specified CapabilityContainerOneValue and returns the index value of it.

[Visual Basic]
Public Function IndexOf( _
   ByVal value As CapabilityContainerOneValue _
) As Integer
[C#]
public int IndexOf(
   CapabilityContainerOneValue value
);
[C++]
public: int IndexOf(
   CapabilityContainerOneValue* value
)
[C++/CLI]
public:
int IndexOf(
   CapabilityContainerOneValue^ value
)

Parameters

value

Return Type

An integer value which represents the zero-based index of the CapabilityContainerOneValue specified in the collection.

Remarks

This method searches the collection for a reference to the given object. If it does not find a reference to it, this method returns -1. If the object is present more than once in the collection, this method returns the lowest index of a match.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

CapabilityContainerOneValueCollection Class | CapabilityContainerOneValueCollection Members | CapabilityContainerOneValue Class


Insert Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueCollection Class | CapabilityContainerOneValueCollection Members | CapabilityContainerOneValue Class

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
value
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Insert Method

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerOneValueCollection Class : Insert Method (CapabilityContainerOneValueCollection)

Inserts a CapabilityContainerOneValue into the collection at the given index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As CapabilityContainerOneValue _
)
[C#]
public void Insert(
   int index,
   CapabilityContainerOneValue value
);
[C++]
public: void Insert(
   int index,
   CapabilityContainerOneValue* value
)
[C++/CLI]
public:
void Insert(
   int index,
   CapabilityContainerOneValue^ value
)

Parameters

index
value

Remarks

This method inserts the given CapabilityContainerOneValue into the collection at the given index.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

CapabilityContainerOneValueCollection Class | CapabilityContainerOneValueCollection Members | CapabilityContainerOneValue Class


Remove Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueCollection Class | CapabilityContainerOneValueCollection Members | CapabilityContainerOneValue Class

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Remove Method

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerOneValueCollection Class : Remove Method (CapabilityContainerOneValueCollection)

Removes a CapabilityContainerOneValue from the collection.

[Visual Basic]
Public Sub Remove( _
   ByVal value As CapabilityContainerOneValue _
)
[C#]
public void Remove(
   CapabilityContainerOneValue value
);
[C++]
public: void Remove(
   CapabilityContainerOneValue* value
)
[C++/CLI]
public:
void Remove(
   CapabilityContainerOneValue^ value
)

Parameters

value

Remarks

This method searches the collection for the given CapabilityContainerOneValue and removes it. If there are no occurrences of the object, this method will do nothing.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

CapabilityContainerOneValueCollection Class | CapabilityContainerOneValueCollection Members | CapabilityContainerOneValue Class


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueCollection Class | PegasusImaging.WinForms.TwainPro5 Namespace | CapabilityContainerOneValue Class | CapabilityContainerEnum Class

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerOneValueCollection Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityContainerOneValueCollection Class

For a list of all members of this type, see CapabilityContainerOneValueCollection members.

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count | Gets the number of values in the collection.
Public Property Item | Gets or sets the element at the given index.

See Also

CapabilityContainerOneValueCollection Class | PegasusImaging.WinForms.TwainPro5 Namespace | CapabilityContainerOneValue Class | CapabilityContainerEnum Class


Count Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueCollection Class | CapabilityContainerOneValueCollection Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Count Property

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerOneValueCollection Class : Count Property

Gets the number of values in the collection.

[Visual Basic]
<DescriptionAttribute("Gets the number of values in the collection.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property Count As Integer
[C#]
[DescriptionAttribute("Gets the number of values in the collection.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public int Count {get;}
[C++]
[DescriptionAttribute("Gets the number of values in the collection.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property int get_Count();
[C++/CLI]
[DescriptionAttribute("Gets the number of values in the collection.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property int Count {
   int get();
}

Value

An integer value which represents the number of values in the collection.

Requirements

See Also

CapabilityContainerOneValueCollection Class | CapabilityContainerOneValueCollection Members


Item Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueCollection Class | CapabilityContainerOneValueCollection Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
A zero-based integer specifying the index in the collection to get or set.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Item Property

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerOneValueCollection Class : Item Property (CapabilityContainerOneValueCollection)

Gets or sets the element at the given index.

[Visual Basic]
<BrowsableAttribute(False)>
<DescriptionAttribute("Gets or sets the element at the given index.")>
<DesignerSerializationVisibilityAttribute()>
Public Default Property Item( _
   ByVal index As Integer _
) As CapabilityContainerOneValue
[C#]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the element at the given index.")]
[DesignerSerializationVisibilityAttribute()]
public CapabilityContainerOneValue this[
   int index
]; {get; set;}
[C++]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the element at the given index.")]
[DesignerSerializationVisibilityAttribute()]
public: __property CapabilityContainerOneValue* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   CapabilityContainerOneValue* value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the element at the given index.")]
[DesignerSerializationVisibilityAttribute()]
public:
 property CapabilityContainerOneValue^ default [int] {
   CapabilityContainerOneValue^ get(int index);
   void set (int index, CapabilityContainerOneValue^ value);
}

Parameters

index
A zero-based integer specifying the index in the collection to get or set.

Value

A CapabilityContainerOneValue object to get or set at the given index value.

Remarks

This method implements a standard collection operation. It is the principle method to use to read or change elements in the collection. You can read or modify any element in the collection with this method.

Requirements

See Also

CapabilityContainerOneValueCollection Class | CapabilityContainerOneValueCollection Members


CapabilityContainerOneValueFloat Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueFloat Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerOneValueFloat Class

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityContainerOneValueFloat Class

This class implements a capability container for storing a float value.

For a list of all members of this type, see CapabilityContainerOneValueFloat members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.TwainPro5.CapabilityContainer
PegasusImaging.WinForms.TwainPro5.CapabilityContainerOneValue
PegasusImaging.WinForms.TwainPro5.CapabilityContainerOneValueFloat

Syntax

[Visual Basic]
Public Class CapabilityContainerOneValueFloat
   Inherits CapabilityContainerOneValue
[C#]
public class CapabilityContainerOneValueFloat : CapabilityContainerOneValue
[C++]
public __gc class CapabilityContainerOneValueFloat : public CapabilityContainerOneValue
[C++/CLI]
public ref class CapabilityContainerOneValueFloat : public CapabilityContainerOneValue

Remarks

This object is used to get or set a capability containing one float value.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

CapabilityContainerOneValueFloat Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueFloat Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerOneValueFloat Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityContainerOneValueFloat Class

CapabilityContainerOneValueFloat overview

Public Constructors

Public Constructor CapabilityContainerOneValueFloat Constructor Overloaded. The main constructor for this class.

Public Properties

Public Property Capability (Inherited from CapabilityContainer) | Gets and sets which TWAIN capability to negotiate.
Public Property Value | Gets and sets the specific capability value.

See Also

CapabilityContainerOneValueFloat Class | PegasusImaging.WinForms.TwainPro5 Namespace


CapabilityContainerOneValueFloat Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueFloat Class | CapabilityContainerOneValueFloat Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerOneValueFloat Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerOneValueFloat Class : CapabilityContainerOneValueFloat Constructor (CapabilityContainerOneValueFloat)

The main constructor for this class.

Overload List

The main constructor for this class.

[Visual Basic] Public Sub New(Integer)

[C#] public CapabilityContainerOneValueFloat(int);

[C++] public CapabilityContainerOneValueFloat(int);

[C++/CLI] public CapabilityContainerOneValueFloat(int);

Constructor which allows passing in a capability object.

[Visual Basic] Public Sub New(Capability)

[C#] public CapabilityContainerOneValueFloat(Capability);

[C++] public CapabilityContainerOneValueFloat(Capability);

[C++/CLI] public CapabilityContainerOneValueFloat(Capability);

Constructor which allows passing in an advanced capability object.

[Visual Basic] Public Sub New(AdvancedCapability)

[C#] public CapabilityContainerOneValueFloat(AdvancedCapability);

[C++] public CapabilityContainerOneValueFloat(AdvancedCapability);

[C++/CLI] public CapabilityContainerOneValueFloat(AdvancedCapability);

Requirements

See Also

CapabilityContainerOneValueFloat Class | CapabilityContainerOneValueFloat Members


CapabilityContainerOneValueFloat Constructor(AdvancedCapability)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueFloat Class | CapabilityContainerOneValueFloat Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

capability
An AdvancedCapability object.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerOneValueFloat Constructor(AdvancedCapability)

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerOneValueFloat Class > CapabilityContainerOneValueFloat Constructor : CapabilityContainerOneValueFloat Constructor(AdvancedCapability)

Constructor which allows passing in an advanced capability object.

[Visual Basic]
Public Function New( _
   ByVal capability As AdvancedCapability _
)
[C#]
public CapabilityContainerOneValueFloat(
   AdvancedCapability capability
);
[C++]
public: CapabilityContainerOneValueFloat(
   AdvancedCapability capability
)
[C++/CLI]
public:
CapabilityContainerOneValueFloat(
   AdvancedCapability capability
)

Parameters

capability
An AdvancedCapability object.

Requirements

See Also

CapabilityContainerOneValueFloat Class | CapabilityContainerOneValueFloat Members | Overload List


CapabilityContainerOneValueFloat Constructor(Capability)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueFloat Class | CapabilityContainerOneValueFloat Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

capability
A Capability object.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerOneValueFloat Constructor(Capability)

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerOneValueFloat Class > CapabilityContainerOneValueFloat Constructor : CapabilityContainerOneValueFloat Constructor(Capability)

Constructor which allows passing in a capability object.

[Visual Basic]
Public Function New( _
   ByVal capability As Capability _
)
[C#]
public CapabilityContainerOneValueFloat(
   Capability capability
);
[C++]
public: CapabilityContainerOneValueFloat(
   Capability capability
)
[C++/CLI]
public:
CapabilityContainerOneValueFloat(
   Capability capability
)

Parameters

capability
A Capability object.

Requirements

See Also

CapabilityContainerOneValueFloat Class | CapabilityContainerOneValueFloat Members | Overload List


CapabilityContainerOneValueFloat Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueFloat Class | CapabilityContainerOneValueFloat Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

capability
A Capability object.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerOneValueFloat Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerOneValueFloat Class > CapabilityContainerOneValueFloat Constructor : CapabilityContainerOneValueFloat Constructor(Int32)

The main constructor for this class.

[Visual Basic]
Public Function New( _
   ByVal capability As Integer _
)
[C#]
public CapabilityContainerOneValueFloat(
   int capability
);
[C++]
public: CapabilityContainerOneValueFloat(
   int capability
)
[C++/CLI]
public:
CapabilityContainerOneValueFloat(
   int capability
)

Parameters

capability
A Capability object.

Requirements

See Also

CapabilityContainerOneValueFloat Class | CapabilityContainerOneValueFloat Members | Overload List


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueFloat Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerOneValueFloat Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityContainerOneValueFloat Class

For a list of all members of this type, see CapabilityContainerOneValueFloat members.

Public Properties

Public Property Capability (Inherited from CapabilityContainer) | Gets and sets which TWAIN capability to negotiate.
Public Property Value | Gets and sets the specific capability value.

See Also

CapabilityContainerOneValueFloat Class | PegasusImaging.WinForms.TwainPro5 Namespace


Value Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueFloat Class | CapabilityContainerOneValueFloat Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Value Property

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerOneValueFloat Class : Value Property (CapabilityContainerOneValueFloat)

Gets and sets the specific capability value.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("The capability value.")>
Public Property Value As Single
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("The capability value.")]
public float Value {get; set;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("The capability value.")]
public: __property float get_Value();
public: __property void set_Value(
   float value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("The capability value.")]
public:
property float Value {
   float get();
   void set (float value);
}

Value

A float value which represents the capability value to get or set.

Requirements

See Also

CapabilityContainerOneValueFloat Class | CapabilityContainerOneValueFloat Members


CapabilityContainerOneValueString Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueString Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerOneValueString Class

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityContainerOneValueString Class

This class implements a capability container for storing a string value.

For a list of all members of this type, see CapabilityContainerOneValueString members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.TwainPro5.CapabilityContainer
PegasusImaging.WinForms.TwainPro5.CapabilityContainerOneValue
PegasusImaging.WinForms.TwainPro5.CapabilityContainerOneValueString

Syntax

[Visual Basic]
Public Class CapabilityContainerOneValueString
   Inherits CapabilityContainerOneValue
[C#]
public class CapabilityContainerOneValueString : CapabilityContainerOneValue
[C++]
public __gc class CapabilityContainerOneValueString : public CapabilityContainerOneValue
[C++/CLI]
public ref class CapabilityContainerOneValueString : public CapabilityContainerOneValue

Remarks

This object is used to get or set a capability containing one string value.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

CapabilityContainerOneValueString Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueString Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerOneValueString Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityContainerOneValueString Class

CapabilityContainerOneValueString overview

Public Constructors

Public Constructor CapabilityContainerOneValueString Constructor Overloaded. A CapabilityContainerOneValueString constructor which allows passing in a specified capability by index value.

Public Properties

Public Property Capability (Inherited from CapabilityContainer) | Gets and sets which TWAIN capability to negotiate.
Public Property Value | Gets and sets the capability value.

See Also

CapabilityContainerOneValueString Class | PegasusImaging.WinForms.TwainPro5 Namespace


CapabilityContainerOneValueString Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueString Class | CapabilityContainerOneValueString Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerOneValueString Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerOneValueString Class : CapabilityContainerOneValueString Constructor (CapabilityContainerOneValueString)

A CapabilityContainerOneValueString constructor which allows passing in a specified capability by index value.

Overload List

A CapabilityContainerOneValueString constructor which allows passing in a specified capability by index value.

[Visual Basic] Public Sub New(Integer)

[C#] public CapabilityContainerOneValueString(int);

[C++] public CapabilityContainerOneValueString(int);

[C++/CLI] public CapabilityContainerOneValueString(int);

A CapabilityContainerOneValueString constructor which allows passing in a capability by Capability enumeration object.

[Visual Basic] Public Sub New(Capability)

[C#] public CapabilityContainerOneValueString(Capability);

[C++] public CapabilityContainerOneValueString(Capability);

[C++/CLI] public CapabilityContainerOneValueString(Capability);

A CapabilityContainerOneValueString constructor which allows passing in an advanced capability by AdvancedCapability object.

[Visual Basic] Public Sub New(AdvancedCapability)

[C#] public CapabilityContainerOneValueString(AdvancedCapability);

[C++] public CapabilityContainerOneValueString(AdvancedCapability);

[C++/CLI] public CapabilityContainerOneValueString(AdvancedCapability);

Requirements

See Also

CapabilityContainerOneValueString Class | CapabilityContainerOneValueString Members


CapabilityContainerOneValueString Constructor(AdvancedCapability)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueString Class | CapabilityContainerOneValueString Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

capability
An AdvancedCapability object.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerOneValueString Constructor(AdvancedCapability)

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerOneValueString Class > CapabilityContainerOneValueString Constructor : CapabilityContainerOneValueString Constructor(AdvancedCapability)

A CapabilityContainerOneValueString constructor which allows passing in an advanced capability by AdvancedCapability object.

[Visual Basic]
Public Function New( _
   ByVal capability As AdvancedCapability _
)
[C#]
public CapabilityContainerOneValueString(
   AdvancedCapability capability
);
[C++]
public: CapabilityContainerOneValueString(
   AdvancedCapability capability
)
[C++/CLI]
public:
CapabilityContainerOneValueString(
   AdvancedCapability capability
)

Parameters

capability
An AdvancedCapability object.

Requirements

See Also

CapabilityContainerOneValueString Class | CapabilityContainerOneValueString Members | Overload List


CapabilityContainerOneValueString Constructor(Capability)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueString Class | CapabilityContainerOneValueString Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

capability
A Capability object.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerOneValueString Constructor(Capability)

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerOneValueString Class > CapabilityContainerOneValueString Constructor : CapabilityContainerOneValueString Constructor(Capability)

A CapabilityContainerOneValueString constructor which allows passing in a capability by Capability enumeration object.

[Visual Basic]
Public Function New( _
   ByVal capability As Capability _
)
[C#]
public CapabilityContainerOneValueString(
   Capability capability
);
[C++]
public: CapabilityContainerOneValueString(
   Capability capability
)
[C++/CLI]
public:
CapabilityContainerOneValueString(
   Capability capability
)

Parameters

capability
A Capability object.

Requirements

See Also

CapabilityContainerOneValueString Class | CapabilityContainerOneValueString Members | Overload List


CapabilityContainerOneValueString Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueString Class | CapabilityContainerOneValueString Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

capability
An integer which represents a capability value.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerOneValueString Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerOneValueString Class > CapabilityContainerOneValueString Constructor : CapabilityContainerOneValueString Constructor(Int32)

A CapabilityContainerOneValueString constructor which allows passing in a specified capability by index value.

[Visual Basic]
Public Function New( _
   ByVal capability As Integer _
)
[C#]
public CapabilityContainerOneValueString(
   int capability
);
[C++]
public: CapabilityContainerOneValueString(
   int capability
)
[C++/CLI]
public:
CapabilityContainerOneValueString(
   int capability
)

Parameters

capability
An integer which represents a capability value.

Requirements

See Also

CapabilityContainerOneValueString Class | CapabilityContainerOneValueString Members | Overload List


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueString Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerOneValueString Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityContainerOneValueString Class

For a list of all members of this type, see CapabilityContainerOneValueString members.

Public Properties

Public Property Capability (Inherited from CapabilityContainer) | Gets and sets which TWAIN capability to negotiate.
Public Property Value | Gets and sets the capability value.

See Also

CapabilityContainerOneValueString Class | PegasusImaging.WinForms.TwainPro5 Namespace


Value Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValueString Class | CapabilityContainerOneValueString Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Value Property

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerOneValueString Class : Value Property (CapabilityContainerOneValueString)

Gets and sets the capability value.

[Visual Basic]
<DescriptionAttribute("The capability value.")>
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property Value As String
[C#]
[DescriptionAttribute("The capability value.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public string Value {get; set;}
[C++]
[DescriptionAttribute("The capability value.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property string* get_Value();
public: __property void set_Value(
   string* value
);
[C++/CLI]
[DescriptionAttribute("The capability value.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property String^ Value {
   String^ get();
   void set (String^ value);
}

Value

A string which represents the capability value.

Requirements

See Also

CapabilityContainerOneValueString Class | CapabilityContainerOneValueString Members


CapabilityContainerRange Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerRange Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerRange Class

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityContainerRange Class

This class implements a range type container for storing capability information.

For a list of all members of this type, see CapabilityContainerRange members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.TwainPro5.CapabilityContainer
PegasusImaging.WinForms.TwainPro5.CapabilityContainerRange

Syntax

[Visual Basic]
Public Class CapabilityContainerRange
   Inherits CapabilityContainer
[C#]
public class CapabilityContainerRange : CapabilityContainer
[C++]
public __gc class CapabilityContainerRange : public CapabilityContainer
[C++/CLI]
public ref class CapabilityContainerRange : public CapabilityContainer

Remarks

This object stores a range of values, a current value, and a default value.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

CapabilityContainerRange Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerRange Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerRange Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityContainerRange Class

CapabilityContainerRange overview

Public Constructors

Public Constructor CapabilityContainerRange Constructor Overloaded. A CapabilityContainerRange constructor.

Public Properties

Public Property Capability (Inherited from CapabilityContainer) | Gets and sets which TWAIN capability to negotiate.
Public Property Default | Gets the default capability value.
Public Property Maximum | Gets and sets the maximum capability value.
Public Property Minimum | Gets and sets the minimum capability value.
Public Property Step | Gets the step value in the capability range.
Public Property Value | Gets and sets the capability value.

See Also

CapabilityContainerRange Class | PegasusImaging.WinForms.TwainPro5 Namespace


CapabilityContainerRange Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerRange Class | CapabilityContainerRange Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerRange Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerRange Class : CapabilityContainerRange Constructor (CapabilityContainerRange)

A CapabilityContainerRange constructor.

Overload List

A CapabilityContainerRange constructor.

[Visual Basic] Public Sub New(Integer)

[C#] public CapabilityContainerRange(int);

[C++] public CapabilityContainerRange(int);

[C++/CLI] public CapabilityContainerRange(int);

A CapabilityContainerRange constructor which allows passing in a capability.

[Visual Basic] Public Sub New(Capability)

[C#] public CapabilityContainerRange(Capability);

[C++] public CapabilityContainerRange(Capability);

[C++/CLI] public CapabilityContainerRange(Capability);

A CapabilityContainerRange constructor which allows passing in an advanced capability.

[Visual Basic] Public Sub New(AdvancedCapability)

[C#] public CapabilityContainerRange(AdvancedCapability);

[C++] public CapabilityContainerRange(AdvancedCapability);

[C++/CLI] public CapabilityContainerRange(AdvancedCapability);

Requirements

See Also

CapabilityContainerRange Class | CapabilityContainerRange Members


CapabilityContainerRange Constructor(AdvancedCapability)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerRange Class | CapabilityContainerRange Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

capability
An advanced capability value which represents the capability value.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerRange Constructor(AdvancedCapability)

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerRange Class > CapabilityContainerRange Constructor : CapabilityContainerRange Constructor(AdvancedCapability)

A CapabilityContainerRange constructor which allows passing in an advanced capability.

[Visual Basic]
Public Function New( _
   ByVal capability As AdvancedCapability _
)
[C#]
public CapabilityContainerRange(
   AdvancedCapability capability
);
[C++]
public: CapabilityContainerRange(
   AdvancedCapability capability
)
[C++/CLI]
public:
CapabilityContainerRange(
   AdvancedCapability capability
)

Parameters

capability
An advanced capability value which represents the capability value.

Requirements

See Also

CapabilityContainerRange Class | CapabilityContainerRange Members | Overload List


CapabilityContainerRange Constructor(Capability)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerRange Class | CapabilityContainerRange Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

capability
A CapabilityContainer.Capability object which represents the capability value.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerRange Constructor(Capability)

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerRange Class > CapabilityContainerRange Constructor : CapabilityContainerRange Constructor(Capability)

A CapabilityContainerRange constructor which allows passing in a capability.

[Visual Basic]
Public Function New( _
   ByVal capability As Capability _
)
[C#]
public CapabilityContainerRange(
   Capability capability
);
[C++]
public: CapabilityContainerRange(
   Capability capability
)
[C++/CLI]
public:
CapabilityContainerRange(
   Capability capability
)

Parameters

capability
A CapabilityContainer.Capability object which represents the capability value.

Requirements

See Also

CapabilityContainerRange Class | CapabilityContainerRange Members | Overload List


CapabilityContainerRange Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerRange Class | CapabilityContainerRange Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

capability
An integer which represents the capability value.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerRange Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerRange Class > CapabilityContainerRange Constructor : CapabilityContainerRange Constructor(Int32)

A CapabilityContainerRange constructor.

[Visual Basic]
Public Function New( _
   ByVal capability As Integer _
)
[C#]
public CapabilityContainerRange(
   int capability
);
[C++]
public: CapabilityContainerRange(
   int capability
)
[C++/CLI]
public:
CapabilityContainerRange(
   int capability
)

Parameters

capability
An integer which represents the capability value.

Requirements

See Also

CapabilityContainerRange Class | CapabilityContainerRange Members | Overload List


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerRange Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerRange Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityContainerRange Class

For a list of all members of this type, see CapabilityContainerRange members.

Public Properties

Public Property Capability (Inherited from CapabilityContainer) | Gets and sets which TWAIN capability to negotiate.
Public Property Default | Gets the default capability value.
Public Property Maximum | Gets and sets the maximum capability value.
Public Property Minimum | Gets and sets the minimum capability value.
Public Property Step | Gets the step value in the capability range.
Public Property Value | Gets and sets the capability value.

See Also

CapabilityContainerRange Class | PegasusImaging.WinForms.TwainPro5 Namespace


Default Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerRange Class | CapabilityContainerRange Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Default Property

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerRange Class : Default Property

Gets the default capability value.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("The default capability value.")>
<BrowsableAttribute(False)>
Public ReadOnly Property Default As Single
[C#]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("The default capability value.")]
[BrowsableAttribute(false)]
public float Default {get;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("The default capability value.")]
[BrowsableAttribute(false)]
public: __property float get_Default();
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("The default capability value.")]
[BrowsableAttribute(false)]
public:
property float Default {
   float get();
}

Value

A float value which represents the default capability.

Remarks

The default value is -1.

Requirements

See Also

CapabilityContainerRange Class | CapabilityContainerRange Members


Maximum Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerRange Class | CapabilityContainerRange Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Maximum Property

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerRange Class : Maximum Property

Gets and sets the maximum capability value.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("The maximum capability value.")>
<BrowsableAttribute(False)>
Public Property Maximum As Single
[C#]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("The maximum capability value.")]
[BrowsableAttribute(false)]
public float Maximum {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("The maximum capability value.")]
[BrowsableAttribute(false)]
public: __property float get_Maximum();
public: __property void set_Maximum(
   float value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("The maximum capability value.")]
[BrowsableAttribute(false)]
public:
property float Maximum {
   float get();
   void set (float value);
}

Value

A float value which represents the maximum capability value.

Remarks

The default value is -1.

Requirements

See Also

CapabilityContainerRange Class | CapabilityContainerRange Members


Minimum Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerRange Class | CapabilityContainerRange Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Minimum Property

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerRange Class : Minimum Property

Gets and sets the minimum capability value.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("The minimum capability value.")>
Public Property Minimum As Single
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("The minimum capability value.")]
public float Minimum {get; set;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("The minimum capability value.")]
public: __property float get_Minimum();
public: __property void set_Minimum(
   float value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("The minimum capability value.")]
public:
property float Minimum {
   float get();
   void set (float value);
}

Value

A float value which represents the minimum capability value.

Remarks

The default value is -1.

Requirements

See Also

CapabilityContainerRange Class | CapabilityContainerRange Members


Step Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerRange Class | CapabilityContainerRange Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Step Property

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerRange Class : Step Property

Gets the step value in the capability range.

[Visual Basic]
<BrowsableAttribute(False)>
<DescriptionAttribute("The step value in a range.")>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property Step As Single
[C#]
[BrowsableAttribute(false)]
[DescriptionAttribute("The step value in a range.")]
[DesignerSerializationVisibilityAttribute()]
public float Step {get;}
[C++]
[BrowsableAttribute(false)]
[DescriptionAttribute("The step value in a range.")]
[DesignerSerializationVisibilityAttribute()]
public: __property float get_Step();
[C++/CLI]
[BrowsableAttribute(false)]
[DescriptionAttribute("The step value in a range.")]
[DesignerSerializationVisibilityAttribute()]
public:
property float Step {
   float get();
}

Value

A float value which represents the step value in a range.

Remarks

The default value is -1.

This is the increment that the TWAIN device prefers when setting a new value. For example, if Capability = ICAP_XRESOLUTION, Minimum = 100, Maximum = 600 and Step = 100, then a legal new value would be in the range of 100 - 600 in increments of 100.

Requirements

See Also

CapabilityContainerRange Class | CapabilityContainerRange Members


Value Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerRange Class | CapabilityContainerRange Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Value Property

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityContainerRange Class : Value Property (CapabilityContainerRange)

Gets and sets the capability value.

[Visual Basic]
<DescriptionAttribute("The capability value.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property Value As Single
[C#]
[DescriptionAttribute("The capability value.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public float Value {get; set;}
[C++]
[DescriptionAttribute("The capability value.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property float get_Value();
public: __property void set_Value(
   float value
);
[C++/CLI]
[DescriptionAttribute("The capability value.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property float Value {
   float get();
   void set (float value);
}

Value

A float value which represents the capability value.

Remarks

The default value is -1.

Requirements

See Also

CapabilityContainerRange Class | CapabilityContainerRange Members


CapabilityNotSupportedException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityNotSupportedException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityNotSupportedException Class

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityNotSupportedException Class

This exception is thrown if an operation is performed using an unsupported capability.

For a list of all members of this type, see CapabilityNotSupportedException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.CapabilityNotSupportedException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class CapabilityNotSupportedException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class CapabilityNotSupportedException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class CapabilityNotSupportedException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class CapabilityNotSupportedException sealed : public TwainProException

Remarks

This error might also occur if a SetCapability operation is performed before calling OpenSession.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

CapabilityNotSupportedException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityNotSupportedException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityNotSupportedException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityNotSupportedException Class

CapabilityNotSupportedException overview

Public Constructors

Public Constructor CapabilityNotSupportedException Constructor Overloaded. An exception generated for a capability not supported error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

CapabilityNotSupportedException Class | PegasusImaging.WinForms.TwainPro5 Namespace


CapabilityNotSupportedException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityNotSupportedException Class | CapabilityNotSupportedException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityNotSupportedException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityNotSupportedException Class : CapabilityNotSupportedException Constructor (CapabilityNotSupportedException)

An exception generated for a capability not supported error.

Overload List

An exception generated for a capability not supported error.

[Visual Basic] Public Sub New()

[C#] public CapabilityNotSupportedException();

[C++] public CapabilityNotSupportedException();

[C++/CLI] public CapabilityNotSupportedException();

Generated exception for a capability not supported error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public CapabilityNotSupportedException(int);

[C++] public CapabilityNotSupportedException(int);

[C++/CLI] public CapabilityNotSupportedException(int);

Generated exception for a capability not supported error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public CapabilityNotSupportedException(string);

[C++] public CapabilityNotSupportedException(string*);

[C++/CLI] public CapabilityNotSupportedException(String^);

Generated exception for a capability not supported error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public CapabilityNotSupportedException(int,string);

[C++] public CapabilityNotSupportedException(int,string*);

[C++/CLI] public CapabilityNotSupportedException(int,String^);

Generated exception for a capability not supported error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public CapabilityNotSupportedException(string,Exception);

[C++] public CapabilityNotSupportedException(string*,Exception*);

[C++/CLI] public CapabilityNotSupportedException(String^,Exception^);

Requirements

See Also

CapabilityNotSupportedException Class | CapabilityNotSupportedException Members


CapabilityNotSupportedException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityNotSupportedException Class | CapabilityNotSupportedException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityNotSupportedException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityNotSupportedException Class > CapabilityNotSupportedException Constructor : CapabilityNotSupportedException Constructor()

An exception generated for a capability not supported error.

[Visual Basic]
Public Function New()
[C#]
public CapabilityNotSupportedException();
[C++]
public: CapabilityNotSupportedException();
[C++/CLI]
public:
CapabilityNotSupportedException();

Requirements

See Also

CapabilityNotSupportedException Class | CapabilityNotSupportedException Members | Overload List


CapabilityNotSupportedException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityNotSupportedException Class | CapabilityNotSupportedException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityNotSupportedException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityNotSupportedException Class > CapabilityNotSupportedException Constructor : CapabilityNotSupportedException Constructor(Int32)

Generated exception for a capability not supported error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public CapabilityNotSupportedException(
   int errorNumber
);
[C++]
public: CapabilityNotSupportedException(
   int errorNumber
)
[C++/CLI]
public:
CapabilityNotSupportedException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

CapabilityNotSupportedException Class | CapabilityNotSupportedException Members | Overload List


CapabilityNotSupportedException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityNotSupportedException Class | CapabilityNotSupportedException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityNotSupportedException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityNotSupportedException Class > CapabilityNotSupportedException Constructor : CapabilityNotSupportedException Constructor(Int32,String)

Generated exception for a capability not supported error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public CapabilityNotSupportedException(
   int errorNumber,
   string message
);
[C++]
public: CapabilityNotSupportedException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
CapabilityNotSupportedException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

CapabilityNotSupportedException Class | CapabilityNotSupportedException Members | Overload List


CapabilityNotSupportedException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityNotSupportedException Class | CapabilityNotSupportedException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityNotSupportedException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityNotSupportedException Class > CapabilityNotSupportedException Constructor : CapabilityNotSupportedException Constructor(String)

Generated exception for a capability not supported error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public CapabilityNotSupportedException(
   string message
);
[C++]
public: CapabilityNotSupportedException(
   string* message
)
[C++/CLI]
public:
CapabilityNotSupportedException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

CapabilityNotSupportedException Class | CapabilityNotSupportedException Members | Overload List


CapabilityNotSupportedException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityNotSupportedException Class | CapabilityNotSupportedException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityNotSupportedException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > CapabilityNotSupportedException Class > CapabilityNotSupportedException Constructor : CapabilityNotSupportedException Constructor(String,Exception)

Generated exception for a capability not supported error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public CapabilityNotSupportedException(
   string message,
   Exception innerException
);
[C++]
public: CapabilityNotSupportedException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
CapabilityNotSupportedException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

CapabilityNotSupportedException Class | CapabilityNotSupportedException Members | Overload List


Caption Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

Caption Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Caption Class

PegasusImaging.WinForms.TwainPro5 Namespace : Caption Class (PegasusImaging.WinForms.TwainPro5)

This class implements an object that stores the settings used to place a caption on images when they are scanned.

For a list of all members of this type, see Caption members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.TwainPro5.Caption

Syntax

[Visual Basic]
Public Class Caption
[C#]
public class Caption
[C++]
public __gc class Caption
[C++/CLI]
public ref class Caption

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

Caption Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

Caption Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Caption Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : Caption Class (PegasusImaging.WinForms.TwainPro5)

Caption overview

Public Properties

Public Property Area | Gets and sets the area to write the caption to a frame during a frame capture.
Public Property Clip | Gets and sets an indicator if the Caption is clipped by the Width and Height of the Area property or clipped using the right and bottom edges of the frame.
Public Property Font | Gets and sets the font used to draw the Caption on the current still frame.
Public Property ForeColor | Gets and sets the color used to draw the Caption on the current still frame.
Public Property HorizontalAlignment | Gets and sets the horizontal alignment of the caption within the clipping rectangle.
Public Property ShadowText | Gets and sets an indicator if a drop shadow should be placed under the caption.
Public Property Text | Gets and sets the text that will be placed on a still frame.
Public Property VerticalAlignment | Gets and sets the vertical alignment of the caption within the clipping rectangle.

Public Methods

Public Method Dispose Disposes of unmanaged resources.

See Also

Caption Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

Caption Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Caption Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : Caption Class (PegasusImaging.WinForms.TwainPro5)

For a list of all members of this type, see Caption members.

Public Methods

Public Method Dispose Disposes of unmanaged resources.

See Also

Caption Class | PegasusImaging.WinForms.TwainPro5 Namespace


Dispose Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

Caption Class | Caption Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.TwainPro5 Namespace > Caption Class : Dispose Method (Caption)

Disposes of unmanaged resources.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

Remarks

This method is part of the IDisposable interface.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

Caption Class | Caption Members


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

Caption Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Caption Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : Caption Class (PegasusImaging.WinForms.TwainPro5)

For a list of all members of this type, see Caption members.

Public Properties

Public Property Area | Gets and sets the area to write the caption to a frame during a frame capture.
Public Property Clip | Gets and sets an indicator if the Caption is clipped by the Width and Height of the Area property or clipped using the right and bottom edges of the frame.
Public Property Font | Gets and sets the font used to draw the Caption on the current still frame.
Public Property ForeColor | Gets and sets the color used to draw the Caption on the current still frame.
Public Property HorizontalAlignment | Gets and sets the horizontal alignment of the caption within the clipping rectangle.
Public Property ShadowText | Gets and sets an indicator if a drop shadow should be placed under the caption.
Public Property Text | Gets and sets the text that will be placed on a still frame.
Public Property VerticalAlignment | Gets and sets the vertical alignment of the caption within the clipping rectangle.

See Also

Caption Class | PegasusImaging.WinForms.TwainPro5 Namespace


Area Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

Caption Class | Caption Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Area Property

PegasusImaging.WinForms.TwainPro5 Namespace > Caption Class : Area Property

Gets and sets the area to write the caption to a frame during a frame capture.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<DescriptionAttribute("Gets or sets the area to write the caption to a frame during a frame capture.")>
Public Property Area As Rectangle
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the area to write the caption to a frame during a frame capture.")]
public Rectangle Area {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the area to write the caption to a frame during a frame capture.")]
public: __property Rectangle get_Area();
public: __property void set_Area(
   Rectangle value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the area to write the caption to a frame during a frame capture.")]
public:
property Rectangle Area {
   Rectangle get();
   void set (Rectangle value);
}

Value

A Rectangle which represents the area to write the caption.

Remarks

The default value is X=0, Y=0, Width=0, Height=0

Requirements

See Also

Caption Class | Caption Members


Clip Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

Caption Class | Caption Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Clip Property

PegasusImaging.WinForms.TwainPro5 Namespace > Caption Class : Clip Property

Gets and sets an indicator if the Caption is clipped by the Width and Height of the Area property or clipped using the right and bottom edges of the frame.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
<DescriptionAttribute("Determines if the Caption is clipped by the Width and Height of the Area property or clipped using the right and bottom edges of the frame.")>
<BrowsableAttribute(False)>
Public Property Clip As Boolean
[C#]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Determines if the Caption is clipped by the Width and Height of the Area property or clipped using the right and bottom edges of the frame.")]
[BrowsableAttribute(false)]
public bool Clip {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Determines if the Caption is clipped by the Width and Height of the Area property or clipped using the right and bottom edges of the frame.")]
[BrowsableAttribute(false)]
public: __property bool get_Clip();
public: __property void set_Clip(
   bool value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Determines if the Caption is clipped by the Width and Height of the Area property or clipped using the right and bottom edges of the frame.")]
[BrowsableAttribute(false)]
public:
property bool Clip {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to clip the width and height. Otherwise, false is used and the area is not clipped.

Remarks

The default value is false.

Note: This property has no effect on the Left and Top of the Area property which are always used to determine the placement of the caption.

Requirements

See Also

Caption Class | Caption Members


Font Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

Caption Class | Caption Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Font Property

PegasusImaging.WinForms.TwainPro5 Namespace > Caption Class : Font Property

Gets and sets the font used to draw the Caption on the current still frame.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("Sets the font used to draw the Caption on the current still frame.")>
Public Property Font As Font
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Sets the font used to draw the Caption on the current still frame.")]
public Font Font {get; set;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Sets the font used to draw the Caption on the current still frame.")]
public: __property Font* get_Font();
public: __property void set_Font(
   Font* value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Sets the font used to draw the Caption on the current still frame.")]
public:
property Font^ Font {
   Font^ get();
   void set (Font^ value);
}

Value

The Font value to get or set.

Remarks

The default value is 8 point MS Sans Serif.

Requirements

See Also

Caption Class | Caption Members


ForeColor Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

Caption Class | Caption Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ForeColor Property

PegasusImaging.WinForms.TwainPro5 Namespace > Caption Class : ForeColor Property

Gets and sets the color used to draw the Caption on the current still frame.

[Visual Basic]
<DescriptionAttribute("Sets the color used to draw the Caption on the current still frame.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property ForeColor As Color
[C#]
[DescriptionAttribute("Sets the color used to draw the Caption on the current still frame.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public Color ForeColor {get; set;}
[C++]
[DescriptionAttribute("Sets the color used to draw the Caption on the current still frame.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property Color get_ForeColor();
public: __property void set_ForeColor(
   Color value
);
[C++/CLI]
[DescriptionAttribute("Sets the color used to draw the Caption on the current still frame.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property Color ForeColor {
   Color get();
   void set (Color value);
}

Value

A Color value which is used to draw the color of the Caption.

Remarks

The default value is Black.

Requirements

See Also

Caption Class | Caption Members


HorizontalAlignment Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

Caption Class | Caption Members | Clip Property | Area Property

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

HorizontalAlignment Property

PegasusImaging.WinForms.TwainPro5 Namespace > Caption Class : HorizontalAlignment Property (Caption)

Gets and sets the horizontal alignment of the caption within the clipping rectangle.

[Visual Basic]
<DescriptionAttribute("Controls the horizontal alignment of the caption within the clipping rectangle.")>
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
Public Property HorizontalAlignment As HorizontalAlignment
[C#]
[DescriptionAttribute("Controls the horizontal alignment of the caption within the clipping rectangle.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public HorizontalAlignment HorizontalAlignment {get; set;}
[C++]
[DescriptionAttribute("Controls the horizontal alignment of the caption within the clipping rectangle.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public: __property HorizontalAlignment get_HorizontalAlignment();
public: __property void set_HorizontalAlignment(
   HorizontalAlignment value
);
[C++/CLI]
[DescriptionAttribute("Controls the horizontal alignment of the caption within the clipping rectangle.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public:
property HorizontalAlignment HorizontalAlignment {
   HorizontalAlignment get();
   void set (HorizontalAlignment value);
}

Value

A HorizontalAlignment enumeration value which contains horizontal alignment options to use for clipping the rectangle.

Remarks

The default value is HorizontalAlignment.Left.

The clipping rectangle is determined by the Clip and Area properties.

Requirements

See Also

Caption Class | Caption Members | Clip Property | Area Property


ShadowText Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

Caption Class | Caption Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ShadowText Property

PegasusImaging.WinForms.TwainPro5 Namespace > Caption Class : ShadowText Property

Gets and sets an indicator if a drop shadow should be placed under the caption.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies if a drop shadow should be placed under the caption.")>
Public Property ShadowText As Boolean
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies if a drop shadow should be placed under the caption.")]
public bool ShadowText {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies if a drop shadow should be placed under the caption.")]
public: __property bool get_ShadowText();
public: __property void set_ShadowText(
   bool value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies if a drop shadow should be placed under the caption.")]
public:
property bool ShadowText {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true if a drop shadow should be placed under the caption. Otherwise, false should be used to not place a drop shadow under the caption.

Remarks

The default value is true.

The color of the drop shadow is calculated automatically from the value of the ForeColor property.

Requirements

See Also

Caption Class | Caption Members


Text Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

Caption Class | Caption Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Text Property

PegasusImaging.WinForms.TwainPro5 Namespace > Caption Class : Text Property

Gets and sets the text that will be placed on a still frame.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the text that will be placed on a still frame.")>
<BrowsableAttribute(False)>
Public Property Text As String
[C#]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the text that will be placed on a still frame.")]
[BrowsableAttribute(false)]
public string Text {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the text that will be placed on a still frame.")]
[BrowsableAttribute(false)]
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the text that will be placed on a still frame.")]
[BrowsableAttribute(false)]
public:
property String^ Text {
   String^ get();
   void set (String^ value);
}

Value

A string value which represents the text to be placed on a still frame.

Remarks

The default value is an empty string "".

To scan an image without a caption, set this property to "".

Requirements

See Also

Caption Class | Caption Members


VerticalAlignment Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

Caption Class | Caption Members | Clip Property | Area Property

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

VerticalAlignment Property

PegasusImaging.WinForms.TwainPro5 Namespace > Caption Class : VerticalAlignment Property (Caption)

Gets and sets the vertical alignment of the caption within the clipping rectangle.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<DescriptionAttribute("Controls the vertical alignment of the caption within the clipping rectangle.")>
Public Property VerticalAlignment As VerticalAlignment
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Controls the vertical alignment of the caption within the clipping rectangle.")]
public VerticalAlignment VerticalAlignment {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Controls the vertical alignment of the caption within the clipping rectangle.")]
public: __property VerticalAlignment get_VerticalAlignment();
public: __property void set_VerticalAlignment(
   VerticalAlignment value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Controls the vertical alignment of the caption within the clipping rectangle.")]
public:
property VerticalAlignment VerticalAlignment {
   VerticalAlignment get();
   void set (VerticalAlignment value);
}

Value

A VerticalAlignment enumeration value which determines the vertical alignment of the clipping rectangle.

Remarks

The default value is VerticalAlignment.Top.

The clipping rectangle is determined by the Clip and Area properties.

Requirements

See Also

Caption Class | Caption Members | Clip Property | Area Property


ClipboardException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ClipboardException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ClipboardException Class

PegasusImaging.WinForms.TwainPro5 Namespace : ClipboardException Class

This exception is thrown if an error occurs trying to open the clipboard with the CopyToClipboard or CutToClipboard method.

For a list of all members of this type, see ClipboardException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.ClipboardException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class ClipboardException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class ClipboardException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class ClipboardException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class ClipboardException sealed : public TwainProException

Remarks

Possible causes:

Another application has the clipboard open.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

ClipboardException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ClipboardException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ClipboardException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : ClipboardException Class

ClipboardException overview

Public Constructors

Public Constructor ClipboardException Constructor Overloaded. An exception generated for a clipboard error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ClipboardException Class | PegasusImaging.WinForms.TwainPro5 Namespace


ClipboardException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ClipboardException Class | ClipboardException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ClipboardException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > ClipboardException Class : ClipboardException Constructor (ClipboardException)

An exception generated for a clipboard error.

Overload List

An exception generated for a clipboard error.

[Visual Basic] Public Sub New()

[C#] public ClipboardException();

[C++] public ClipboardException();

[C++/CLI] public ClipboardException();

Generated exception for a clipboard error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public ClipboardException(int);

[C++] public ClipboardException(int);

[C++/CLI] public ClipboardException(int);

Generated exception for a clipboard error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public ClipboardException(string);

[C++] public ClipboardException(string*);

[C++/CLI] public ClipboardException(String^);

Generated exception for a clipboard error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public ClipboardException(int,string);

[C++] public ClipboardException(int,string*);

[C++/CLI] public ClipboardException(int,String^);

Generated exception for a clipboard error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public ClipboardException(string,Exception);

[C++] public ClipboardException(string*,Exception*);

[C++/CLI] public ClipboardException(String^,Exception^);

Requirements

See Also

ClipboardException Class | ClipboardException Members


ClipboardException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ClipboardException Class | ClipboardException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ClipboardException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > ClipboardException Class > ClipboardException Constructor : ClipboardException Constructor()

An exception generated for a clipboard error.

[Visual Basic]
Public Function New()
[C#]
public ClipboardException();
[C++]
public: ClipboardException();
[C++/CLI]
public:
ClipboardException();

Requirements

See Also

ClipboardException Class | ClipboardException Members | Overload List


ClipboardException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ClipboardException Class | ClipboardException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ClipboardException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > ClipboardException Class > ClipboardException Constructor : ClipboardException Constructor(Int32)

Generated exception for a clipboard error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public ClipboardException(
   int errorNumber
);
[C++]
public: ClipboardException(
   int errorNumber
)
[C++/CLI]
public:
ClipboardException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

ClipboardException Class | ClipboardException Members | Overload List


ClipboardException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ClipboardException Class | ClipboardException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ClipboardException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > ClipboardException Class > ClipboardException Constructor : ClipboardException Constructor(Int32,String)

Generated exception for a clipboard error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public ClipboardException(
   int errorNumber,
   string message
);
[C++]
public: ClipboardException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
ClipboardException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

ClipboardException Class | ClipboardException Members | Overload List


ClipboardException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ClipboardException Class | ClipboardException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ClipboardException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > ClipboardException Class > ClipboardException Constructor : ClipboardException Constructor(String)

Generated exception for a clipboard error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public ClipboardException(
   string message
);
[C++]
public: ClipboardException(
   string* message
)
[C++/CLI]
public:
ClipboardException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

ClipboardException Class | ClipboardException Members | Overload List


ClipboardException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ClipboardException Class | ClipboardException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ClipboardException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > ClipboardException Class > ClipboardException Constructor : ClipboardException Constructor(String,Exception)

Generated exception for a clipboard error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public ClipboardException(
   string message,
   Exception innerException
);
[C++]
public: ClipboardException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
ClipboardException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

ClipboardException Class | ClipboardException Members | Overload List


CompressedImageNotAvailableException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CompressedImageNotAvailableException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CompressedImageNotAvailableException Class

PegasusImaging.WinForms.TwainPro5 Namespace : CompressedImageNotAvailableException Class

This exception is thrown if no compressed image is available for the requested operation or an unsupported compressed image format was returned in response to a StartSession.

For a list of all members of this type, see CompressedImageNotAvailableException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.CompressedImageNotAvailableException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class CompressedImageNotAvailableException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class CompressedImageNotAvailableException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class CompressedImageNotAvailableException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class CompressedImageNotAvailableException sealed : public TwainProException

Remarks

Possible causes:

The SaveStream method was already called.

The Save method was invoked after the SaveStream method was called.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

CompressedImageNotAvailableException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CompressedImageNotAvailableException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CompressedImageNotAvailableException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : CompressedImageNotAvailableException Class

CompressedImageNotAvailableException overview

Public Constructors

Public Constructor CompressedImageNotAvailableException Constructor Overloaded. An exception generated for a compressed image not available error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

CompressedImageNotAvailableException Class | PegasusImaging.WinForms.TwainPro5 Namespace


CompressedImageNotAvailableException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CompressedImageNotAvailableException Class | CompressedImageNotAvailableException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CompressedImageNotAvailableException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > CompressedImageNotAvailableException Class : CompressedImageNotAvailableException Constructor (CompressedImageNotAvailableException)

An exception generated for a compressed image not available error.

Overload List

An exception generated for a compressed image not available error.

[Visual Basic] Public Sub New()

[C#] public CompressedImageNotAvailableException();

[C++] public CompressedImageNotAvailableException();

[C++/CLI] public CompressedImageNotAvailableException();

Generated exception for a compressed image not available error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public CompressedImageNotAvailableException(int);

[C++] public CompressedImageNotAvailableException(int);

[C++/CLI] public CompressedImageNotAvailableException(int);

Generated exception for a compressed image not available error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public CompressedImageNotAvailableException(string);

[C++] public CompressedImageNotAvailableException(string*);

[C++/CLI] public CompressedImageNotAvailableException(String^);

Generated exception for a compressed image not available error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public CompressedImageNotAvailableException(int,string);

[C++] public CompressedImageNotAvailableException(int,string*);

[C++/CLI] public CompressedImageNotAvailableException(int,String^);

Generated exception for a compressed image not available error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public CompressedImageNotAvailableException(string,Exception);

[C++] public CompressedImageNotAvailableException(string*,Exception*);

[C++/CLI] public CompressedImageNotAvailableException(String^,Exception^);

Requirements

See Also

CompressedImageNotAvailableException Class | CompressedImageNotAvailableException Members


CompressedImageNotAvailableException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CompressedImageNotAvailableException Class | CompressedImageNotAvailableException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CompressedImageNotAvailableException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > CompressedImageNotAvailableException Class > CompressedImageNotAvailableException Constructor : CompressedImageNotAvailableException Constructor()

An exception generated for a compressed image not available error.

[Visual Basic]
Public Function New()
[C#]
public CompressedImageNotAvailableException();
[C++]
public: CompressedImageNotAvailableException();
[C++/CLI]
public:
CompressedImageNotAvailableException();

Requirements

See Also

CompressedImageNotAvailableException Class | CompressedImageNotAvailableException Members | Overload List


CompressedImageNotAvailableException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CompressedImageNotAvailableException Class | CompressedImageNotAvailableException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CompressedImageNotAvailableException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > CompressedImageNotAvailableException Class > CompressedImageNotAvailableException Constructor : CompressedImageNotAvailableException Constructor(Int32)

Generated exception for a compressed image not available error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public CompressedImageNotAvailableException(
   int errorNumber
);
[C++]
public: CompressedImageNotAvailableException(
   int errorNumber
)
[C++/CLI]
public:
CompressedImageNotAvailableException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

CompressedImageNotAvailableException Class | CompressedImageNotAvailableException Members | Overload List


CompressedImageNotAvailableException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CompressedImageNotAvailableException Class | CompressedImageNotAvailableException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CompressedImageNotAvailableException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > CompressedImageNotAvailableException Class > CompressedImageNotAvailableException Constructor : CompressedImageNotAvailableException Constructor(Int32,String)

Generated exception for a compressed image not available error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public CompressedImageNotAvailableException(
   int errorNumber,
   string message
);
[C++]
public: CompressedImageNotAvailableException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
CompressedImageNotAvailableException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

CompressedImageNotAvailableException Class | CompressedImageNotAvailableException Members | Overload List


CompressedImageNotAvailableException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CompressedImageNotAvailableException Class | CompressedImageNotAvailableException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CompressedImageNotAvailableException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > CompressedImageNotAvailableException Class > CompressedImageNotAvailableException Constructor : CompressedImageNotAvailableException Constructor(String)

Generated exception for a compressed image not available error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public CompressedImageNotAvailableException(
   string message
);
[C++]
public: CompressedImageNotAvailableException(
   string* message
)
[C++/CLI]
public:
CompressedImageNotAvailableException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

CompressedImageNotAvailableException Class | CompressedImageNotAvailableException Members | Overload List


CompressedImageNotAvailableException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CompressedImageNotAvailableException Class | CompressedImageNotAvailableException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CompressedImageNotAvailableException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > CompressedImageNotAvailableException Class > CompressedImageNotAvailableException Constructor : CompressedImageNotAvailableException Constructor(String,Exception)

Generated exception for a compressed image not available error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public CompressedImageNotAvailableException(
   string message,
   Exception innerException
);
[C++]
public: CompressedImageNotAvailableException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
CompressedImageNotAvailableException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

CompressedImageNotAvailableException Class | CompressedImageNotAvailableException Members | Overload List


DataSourceCollection Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

DataSourceCollection Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

DataSourceCollection Class

PegasusImaging.WinForms.TwainPro5 Namespace : DataSourceCollection Class

A read-only collection of Data Source product names which is set by calling the OpenDataSourceManager method.

For a list of all members of this type, see DataSourceCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.ReadOnlyCollectionBase
PegasusImaging.WinForms.TwainPro5.DataSourceCollection

Syntax

[Visual Basic]
<DefaultMemberAttribute("Item")>
Public Class DataSourceCollection
   Inherits ReadOnlyCollectionBase
[C#]
[DefaultMemberAttribute("Item")]
public class DataSourceCollection : ReadOnlyCollectionBase
[C++]
[DefaultMemberAttribute("Item")]
public __gc class DataSourceCollection : public ReadOnlyCollectionBase
[C++/CLI]
[DefaultMemberAttribute("Item")]
public ref class DataSourceCollection : public ReadOnlyCollectionBase

Remarks

This collection contains all of the Data Source product names installed on the current Windows system. Each string is no longer than 32 characters.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

DataSourceCollection Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

DataSourceCollection Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

DataSourceCollection Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : DataSourceCollection Class

DataSourceCollection overview

Public Constructors

Public Constructor DataSourceCollection Constructor The main constructor for the DataSourceCollection class which allows passing in a Twain device object.

Public Properties

Public Property Count (Inherited from System.Collections.ReadOnlyCollectionBase) | Gets the number of elements contained in the ReadOnlyCollectionBase instance.
Public Property Current | Gets and sets the index of the currently selected Data Source.
Public Property Item | Gets the element at the given index.

Public Methods

Public Method Contains | Determines if the specified string is contained in the collection.
Public Method CopyTo | Copies all elements of the collection to the specified array, beginning at the specified index in the array.
Public Method Dispose | Disposes of unmanaged resources.
Public Method GetEnumerator (Inherited from System.Collections.ReadOnlyCollectionBase) | Returns an enumerator that iterates through the ReadOnlyCollectionBase instance.
Public Method IndexOf | Determines if the specified string is in the collection and returns the corresponding index value.

See Also

DataSourceCollection Class | PegasusImaging.WinForms.TwainPro5 Namespace


DataSourceCollection Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

DataSourceCollection Class | DataSourceCollection Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

twainDevice
A TwainDevice object.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

DataSourceCollection Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > DataSourceCollection Class : DataSourceCollection Constructor (DataSourceCollection)

The main constructor for the DataSourceCollection class which allows passing in a Twain device object.

[Visual Basic]
Public Function New( _
   ByVal twainDevice As TwainDevice _
)
[C#]
public DataSourceCollection(
   TwainDevice twainDevice
);
[C++]
public: DataSourceCollection(
   TwainDevice* twainDevice
)
[C++/CLI]
public:
DataSourceCollection(
   TwainDevice^ twainDevice
)

Parameters

twainDevice
A TwainDevice object.

Requirements

See Also

DataSourceCollection Class | DataSourceCollection Members


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

DataSourceCollection Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

DataSourceCollection Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : DataSourceCollection Class

For a list of all members of this type, see DataSourceCollection members.

Public Methods

Public Method Contains | Determines if the specified string is contained in the collection.
Public Method CopyTo | Copies all elements of the collection to the specified array, beginning at the specified index in the array.
Public Method Dispose | Disposes of unmanaged resources.
Public Method GetEnumerator (Inherited from System.Collections.ReadOnlyCollectionBase) | Returns an enumerator that iterates through the ReadOnlyCollectionBase instance.
Public Method IndexOf | Determines if the specified string is in the collection and returns the corresponding index value.

See Also

DataSourceCollection Class | PegasusImaging.WinForms.TwainPro5 Namespace


Contains Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

DataSourceCollection Class | DataSourceCollection Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Contains Method

PegasusImaging.WinForms.TwainPro5 Namespace > DataSourceCollection Class : Contains Method (DataSourceCollection)

Determines if the specified string is contained in the collection.

[Visual Basic]
Public Function Contains( _
   ByVal value As String _
) As Boolean
[C#]
public bool Contains(
   string value
);
[C++]
public: bool Contains(
   string* value
)
[C++/CLI]
public:
bool Contains(
   String^ value
)

Parameters

value

Return Type

A boolean value which is true if the specified element is found in the collection. Otherwise, false is returned.

Remarks

This method searches the collection for the given string. If a reference to the string is found, this method returns true, otherwise, false is returned.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

DataSourceCollection Class | DataSourceCollection Members


CopyTo Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

DataSourceCollection Class | DataSourceCollection Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

array
An array that receives the elements of the collection.
index
The zero-based index in array where this method starts copying the collection.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CopyTo Method

PegasusImaging.WinForms.TwainPro5 Namespace > DataSourceCollection Class : CopyTo Method (DataSourceCollection)

Copies all elements of the collection to the specified array, beginning at the specified index in the array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As String, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   string[] array,
   int index
);
[C++]
public: void CopyTo(
   string*[]* array,
   int index
)
[C++/CLI]
public:
void CopyTo(
   String^array<array>^ array,
   int index
)

Parameters

array
An array that receives the elements of the collection.
index
The zero-based index in array where this method starts copying the collection.

Remarks

This method implements a standard collection operation. It copies elements from this collection to the given array in order, starting at element 0 in this collection. It places the elements into the array starting at the given zero-based index. This method will stop copying elements when it reaches the end of the collection or the end of the array.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

DataSourceCollection Class | DataSourceCollection Members


Dispose Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

DataSourceCollection Class | DataSourceCollection Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.TwainPro5 Namespace > DataSourceCollection Class : Dispose Method (DataSourceCollection)

Disposes of unmanaged resources.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

Remarks

This method is part of the IDisposable interface.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

DataSourceCollection Class | DataSourceCollection Members


IndexOf Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

DataSourceCollection Class | DataSourceCollection Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

IndexOf Method

PegasusImaging.WinForms.TwainPro5 Namespace > DataSourceCollection Class : IndexOf Method (DataSourceCollection)

Determines if the specified string is in the collection and returns the corresponding index value.

[Visual Basic]
Public Function IndexOf( _
   ByVal value As String _
) As Integer
[C#]
public int IndexOf(
   string value
);
[C++]
public: int IndexOf(
   string* value
)
[C++/CLI]
public:
int IndexOf(
   String^ value
)

Parameters

value

Return Type

A zero-based index value which represents where in the collection the element resides.

Remarks

This method searches the collection for a reference to the given object. If it does not find a reference to it, this method returns -1. If the object is present more than once in the collection, this method returns the lowest index of a match.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

DataSourceCollection Class | DataSourceCollection Members


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

DataSourceCollection Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

DataSourceCollection Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : DataSourceCollection Class

For a list of all members of this type, see DataSourceCollection members.

Public Properties

Public Property Count (Inherited from System.Collections.ReadOnlyCollectionBase) | Gets the number of elements contained in the ReadOnlyCollectionBase instance.
Public Property Current | Gets and sets the index of the currently selected Data Source.
Public Property Item | Gets the element at the given index.

See Also

DataSourceCollection Class | PegasusImaging.WinForms.TwainPro5 Namespace


Current Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

DataSourceCollection Class | DataSourceCollection Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Current Property

PegasusImaging.WinForms.TwainPro5 Namespace > DataSourceCollection Class : Current Property

Gets and sets the index of the currently selected Data Source.

[Visual Basic]
<DefaultValueAttribute()>
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<DescriptionAttribute("Returns the index of the currently selected Data Source.")>
Public Property Current As Integer
[C#]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Returns the index of the currently selected Data Source.")]
public int Current {get; set;}
[C++]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Returns the index of the currently selected Data Source.")]
public: __property int get_Current();
public: __property void set_Current(
   int value
);
[C++/CLI]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Returns the index of the currently selected Data Source.")]
public:
property int Current {
   int get();
   void set (int value);
}

Value

An integer value which represents the index of the currently selected data source.

Remarks

Note: This is a runtime, read-only property.

Requirements

See Also

DataSourceCollection Class | DataSourceCollection Members


Item Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

DataSourceCollection Class | DataSourceCollection Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
A zero-based integer specifying the index in the collection to get or set.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Item Property

PegasusImaging.WinForms.TwainPro5 Namespace > DataSourceCollection Class : Item Property (DataSourceCollection)

Gets the element at the given index.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("Gets the element at the given index.")>
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As String
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets the element at the given index.")]
public string this[
   int index
]; {get;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets the element at the given index.")]
public: __property string* get_Item(
   int index
);
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets the element at the given index.")]
public:
 property String^ default [int] {
   String^ get(int index);
}

Parameters

index
A zero-based integer specifying the index in the collection to get or set.

Value

A String value which represents the element at the given index.

Remarks

This method implements a standard collection operation. It is the principle method you will use to read elements in the collection. You can read any element in the collection with this method.

Requirements

See Also

DataSourceCollection Class | DataSourceCollection Members


DataSourceInvalidOperationException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

DataSourceInvalidOperationException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

DataSourceInvalidOperationException Class

PegasusImaging.WinForms.TwainPro5 Namespace : DataSourceInvalidOperationException Class

This exception is thrown if the Data Source performs an operation that caused an exception.

For a list of all members of this type, see DataSourceInvalidOperationException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.DataSourceInvalidOperationException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class DataSourceInvalidOperationException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class DataSourceInvalidOperationException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class DataSourceInvalidOperationException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class DataSourceInvalidOperationException sealed : public TwainProException

Remarks

This error is a critical error. If this error is received then the application should be terminated immediately. No other TwainPRO calls should be made after this error is received. This does give the application the chance to do any non-TWAIN clean-up processing as well as inform the user that a critical error has occurred.

Possible causes:

The Data Source TWAIN driver executed an illegal operation, such as an illegal memory access, a divide by zero, etc.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

DataSourceInvalidOperationException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

DataSourceInvalidOperationException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

DataSourceInvalidOperationException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : DataSourceInvalidOperationException Class

DataSourceInvalidOperationException overview

Public Constructors

Public Constructor DataSourceInvalidOperationException Constructor Overloaded. An exception generated for a Data Source invalid operation error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

DataSourceInvalidOperationException Class | PegasusImaging.WinForms.TwainPro5 Namespace


DataSourceInvalidOperationException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

DataSourceInvalidOperationException Class | DataSourceInvalidOperationException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

DataSourceInvalidOperationException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > DataSourceInvalidOperationException Class : DataSourceInvalidOperationException Constructor (DataSourceInvalidOperationException)

An exception generated for a Data Source invalid operation error.

Overload List

An exception generated for a Data Source invalid operation error.

[Visual Basic] Public Sub New()

[C#] public DataSourceInvalidOperationException();

[C++] public DataSourceInvalidOperationException();

[C++/CLI] public DataSourceInvalidOperationException();

Generated exception for a Data Source invalid operation error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public DataSourceInvalidOperationException(int);

[C++] public DataSourceInvalidOperationException(int);

[C++/CLI] public DataSourceInvalidOperationException(int);

Generated exception for a Data Source invalid operation error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public DataSourceInvalidOperationException(string);

[C++] public DataSourceInvalidOperationException(string*);

[C++/CLI] public DataSourceInvalidOperationException(String^);

Generated exception for a Data Source invalid operation error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public DataSourceInvalidOperationException(int,string);

[C++] public DataSourceInvalidOperationException(int,string*);

[C++/CLI] public DataSourceInvalidOperationException(int,String^);

Generated exception for a Data Source invalid operation error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public DataSourceInvalidOperationException(string,Exception);

[C++] public DataSourceInvalidOperationException(string*,Exception*);

[C++/CLI] public DataSourceInvalidOperationException(String^,Exception^);

Requirements

See Also

DataSourceInvalidOperationException Class | DataSourceInvalidOperationException Members


DataSourceInvalidOperationException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

DataSourceInvalidOperationException Class | DataSourceInvalidOperationException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

DataSourceInvalidOperationException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > DataSourceInvalidOperationException Class > DataSourceInvalidOperationException Constructor : DataSourceInvalidOperationException Constructor()

An exception generated for a Data Source invalid operation error.

[Visual Basic]
Public Function New()
[C#]
public DataSourceInvalidOperationException();
[C++]
public: DataSourceInvalidOperationException();
[C++/CLI]
public:
DataSourceInvalidOperationException();

Requirements

See Also

DataSourceInvalidOperationException Class | DataSourceInvalidOperationException Members | Overload List


DataSourceInvalidOperationException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

DataSourceInvalidOperationException Class | DataSourceInvalidOperationException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

DataSourceInvalidOperationException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > DataSourceInvalidOperationException Class > DataSourceInvalidOperationException Constructor : DataSourceInvalidOperationException Constructor(Int32)

Generated exception for a Data Source invalid operation error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public DataSourceInvalidOperationException(
   int errorNumber
);
[C++]
public: DataSourceInvalidOperationException(
   int errorNumber
)
[C++/CLI]
public:
DataSourceInvalidOperationException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

DataSourceInvalidOperationException Class | DataSourceInvalidOperationException Members | Overload List


DataSourceInvalidOperationException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

DataSourceInvalidOperationException Class | DataSourceInvalidOperationException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

DataSourceInvalidOperationException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > DataSourceInvalidOperationException Class > DataSourceInvalidOperationException Constructor : DataSourceInvalidOperationException Constructor(Int32,String)

Generated exception for a Data Source invalid operation error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public DataSourceInvalidOperationException(
   int errorNumber,
   string message
);
[C++]
public: DataSourceInvalidOperationException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
DataSourceInvalidOperationException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

DataSourceInvalidOperationException Class | DataSourceInvalidOperationException Members | Overload List


DataSourceInvalidOperationException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

DataSourceInvalidOperationException Class | DataSourceInvalidOperationException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

DataSourceInvalidOperationException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > DataSourceInvalidOperationException Class > DataSourceInvalidOperationException Constructor : DataSourceInvalidOperationException Constructor(String)

Generated exception for a Data Source invalid operation error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public DataSourceInvalidOperationException(
   string message
);
[C++]
public: DataSourceInvalidOperationException(
   string* message
)
[C++/CLI]
public:
DataSourceInvalidOperationException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

DataSourceInvalidOperationException Class | DataSourceInvalidOperationException Members | Overload List


DataSourceInvalidOperationException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

DataSourceInvalidOperationException Class | DataSourceInvalidOperationException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

DataSourceInvalidOperationException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > DataSourceInvalidOperationException Class > DataSourceInvalidOperationException Constructor : DataSourceInvalidOperationException Constructor(String,Exception)

Generated exception for a Data Source invalid operation error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public DataSourceInvalidOperationException(
   string message,
   Exception innerException
);
[C++]
public: DataSourceInvalidOperationException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
DataSourceInvalidOperationException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

DataSourceInvalidOperationException Class | DataSourceInvalidOperationException Members | Overload List


ExtendedImageInfoContainer Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ExtendedImageInfoContainer Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ExtendedImageInfoContainer Class

PegasusImaging.WinForms.TwainPro5 Namespace : ExtendedImageInfoContainer Class

This class implements extended image info.

For a list of all members of this type, see ExtendedImageInfoContainer members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.TwainPro5.ExtendedImageInfoContainer

Syntax

[Visual Basic]
Public Class ExtendedImageInfoContainer
[C#]
public class ExtendedImageInfoContainer
[C++]
public __gc class ExtendedImageInfoContainer
[C++/CLI]
public ref class ExtendedImageInfoContainer

Remarks

You cannot create an ExtendedImageInfoContainer object directly. This read-only object is returned by the ScannedImage.GetExtendedImageInfo(ExtendedImageInfo) method.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

ExtendedImageInfoContainer Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ExtendedImageInfoContainer Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ExtendedImageInfoContainer Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : ExtendedImageInfoContainer Class

ExtendedImageInfoContainer overview

Public Properties

Public Property ExtendedImageInfo | Gets the extended image info identification.
Public Property Values | Gets a collection of extended image info.

See Also

ExtendedImageInfoContainer Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ExtendedImageInfoContainer Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ExtendedImageInfoContainer Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : ExtendedImageInfoContainer Class

For a list of all members of this type, see ExtendedImageInfoContainer members.

Public Properties

Public Property ExtendedImageInfo | Gets the extended image info identification.
Public Property Values | Gets a collection of extended image info.

See Also

ExtendedImageInfoContainer Class | PegasusImaging.WinForms.TwainPro5 Namespace


ExtendedImageInfo Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ExtendedImageInfoContainer Class | ExtendedImageInfoContainer Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ExtendedImageInfo Property

PegasusImaging.WinForms.TwainPro5 Namespace > ExtendedImageInfoContainer Class : ExtendedImageInfo Property (ExtendedImageInfoContainer)

Gets the extended image info identification.

[Visual Basic]
<BrowsableAttribute(False)>
<DescriptionAttribute("The extended image info identification.")>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property ExtendedImageInfo As Integer
[C#]
[BrowsableAttribute(false)]
[DescriptionAttribute("The extended image info identification.")]
[DesignerSerializationVisibilityAttribute()]
public int ExtendedImageInfo {get;}
[C++]
[BrowsableAttribute(false)]
[DescriptionAttribute("The extended image info identification.")]
[DesignerSerializationVisibilityAttribute()]
public: __property int get_ExtendedImageInfo();
[C++/CLI]
[BrowsableAttribute(false)]
[DescriptionAttribute("The extended image info identification.")]
[DesignerSerializationVisibilityAttribute()]
public:
property int ExtendedImageInfo {
   int get();
}

Value

An integer value which represents the identity of the extended image info.

Remarks

Returns an identification of the requested value. This matches the value that was passed to the ScannedImage.GetExtendedImageInfo(ExtendedImageInfo) method to obtain this ExtendedImageInfoContainer.

Requirements

See Also

ExtendedImageInfoContainer Class | ExtendedImageInfoContainer Members


Values Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ExtendedImageInfoContainer Class | ExtendedImageInfoContainer Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Values Property

PegasusImaging.WinForms.TwainPro5 Namespace > ExtendedImageInfoContainer Class : Values Property (ExtendedImageInfoContainer)

Gets a collection of extended image info.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property Values As ExtendedImageInfoContainerValueCollection
[C#]
[BrowsableAttribute(false)]
public ExtendedImageInfoContainerValueCollection Values {get;}
[C++]
[BrowsableAttribute(false)]
public: __property ExtendedImageInfoContainerValueCollection* get_Values();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property ExtendedImageInfoContainerValueCollection^ Values {
   ExtendedImageInfoContainerValueCollection^ get();
}

Value

An ExtendedImageInfoContainerValueCollection which contains the extended image info.

Remarks

Returns a collection of ExtendedImageInfoContainerValue objects that contain the extended image info.

Requirements

See Also

ExtendedImageInfoContainer Class | ExtendedImageInfoContainer Members


ExtendedImageInfoContainerValue Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ExtendedImageInfoContainerValue Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ExtendedImageInfoContainerValue Class

PegasusImaging.WinForms.TwainPro5 Namespace : ExtendedImageInfoContainerValue Class

This class implements a single value of extended image info.

For a list of all members of this type, see ExtendedImageInfoContainerValue members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.TwainPro5.ExtendedImageInfoContainerValue
PegasusImaging.WinForms.TwainPro5.ExtendedImageInfoContainerValueFloat
PegasusImaging.WinForms.TwainPro5.ExtendedImageInfoContainerValueString

Syntax

[Visual Basic]
Public Class ExtendedImageInfoContainerValue
[C#]
public class ExtendedImageInfoContainerValue
[C++]
public __gc class ExtendedImageInfoContainerValue
[C++/CLI]
public ref class ExtendedImageInfoContainerValue

Remarks

You cannot create an ExtendedImageInfoContainerValue object directly. This object is a member of the Values collection of the ExtendedImageInfoContainer object which can be obtained by calling the ScannedImage.GetExtendedImageInfo(ExtendedImageInfo) method. The ExtendedImageInfoContainerValueFloat and ExtendedImageInfoContainerValueString objects are inherited from this object, and to access the float or string value stored in this object you must cast this object to the appropriate child object.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

ExtendedImageInfoContainerValue Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ExtendedImageInfoContainerValue Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ExtendedImageInfoContainerValue Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : ExtendedImageInfoContainerValue Class

ExtendedImageInfoContainerValue overview

See Also

ExtendedImageInfoContainerValue Class | PegasusImaging.WinForms.TwainPro5 Namespace


ExtendedImageInfoContainerValueCollection Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ExtendedImageInfoContainerValueCollection Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ExtendedImageInfoContainerValueCollection Class

PegasusImaging.WinForms.TwainPro5 Namespace : ExtendedImageInfoContainerValueCollection Class

This class represents a collection of ExtendedImageInfoContainerValue objects.

For a list of all members of this type, see ExtendedImageInfoContainerValueCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PegasusImaging.WinForms.TwainPro5.ExtendedImageInfoContainerValueCollection

Syntax

[Visual Basic]
<DefaultMemberAttribute("Item")>
Public Class ExtendedImageInfoContainerValueCollection
   Inherits CollectionBase
[C#]
[DefaultMemberAttribute("Item")]
public class ExtendedImageInfoContainerValueCollection : CollectionBase
[C++]
[DefaultMemberAttribute("Item")]
public __gc class ExtendedImageInfoContainerValueCollection : public CollectionBase
[C++/CLI]
[DefaultMemberAttribute("Item")]
public ref class ExtendedImageInfoContainerValueCollection : public CollectionBase

Remarks

This object is used by the ExtendedImageInfoContainer to store a collection of extended image info values.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

ExtendedImageInfoContainerValueCollection Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ExtendedImageInfoContainerValueCollection Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ExtendedImageInfoContainerValueCollection Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : ExtendedImageInfoContainerValueCollection Class

ExtendedImageInfoContainerValueCollection overview

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property Item | Gets or sets the element at the given index within the collection.

Public Methods

Public Method Add | Adds an ExtendedImageInfoContainerValue to the collection.
Public Method Clear (Inherited from System.Collections.CollectionBase) | Removes all objects from the CollectionBase instance.
Public Method Contains | Determines if the specified ExtendedImageInfoContainerValue is contained in the collection.
Public Method CopyTo | Copies all elements of the collection to the specified array, beginning at the specified index in the array.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method IndexOf | Determines if the specified ExtendedImageInfoContainerValue is in the collection and returns its index value.
Public Method Insert | Inserts an ExtendedImageInfoContainerValue into the collection at the given index.
Public Method Remove | Removes an ExtendedImageInfoContainerValue from the collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) | Removes the element at the specified index of the CollectionBase instance.

See Also

ExtendedImageInfoContainerValueCollection Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ExtendedImageInfoContainerValueCollection Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ExtendedImageInfoContainerValueCollection Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : ExtendedImageInfoContainerValueCollection Class

For a list of all members of this type, see ExtendedImageInfoContainerValueCollection members.

Public Methods

Public Method Add | Adds an ExtendedImageInfoContainerValue to the collection.
Public Method Clear (Inherited from System.Collections.CollectionBase) | Removes all objects from the CollectionBase instance.
Public Method Contains | Determines if the specified ExtendedImageInfoContainerValue is contained in the collection.
Public Method CopyTo | Copies all elements of the collection to the specified array, beginning at the specified index in the array.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method IndexOf | Determines if the specified ExtendedImageInfoContainerValue is in the collection and returns its index value.
Public Method Insert | Inserts an ExtendedImageInfoContainerValue into the collection at the given index.
Public Method Remove | Removes an ExtendedImageInfoContainerValue from the collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) | Removes the element at the specified index of the CollectionBase instance.

See Also

ExtendedImageInfoContainerValueCollection Class | PegasusImaging.WinForms.TwainPro5 Namespace


Add Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ExtendedImageInfoContainerValueCollection Class | ExtendedImageInfoContainerValueCollection Members | ExtendedImageInfoContainerValue Class

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Add Method

PegasusImaging.WinForms.TwainPro5 Namespace > ExtendedImageInfoContainerValueCollection Class : Add Method (ExtendedImageInfoContainerValueCollection)

Adds an ExtendedImageInfoContainerValue to the collection.

[Visual Basic]
Public Function Add( _
   ByVal value As ExtendedImageInfoContainerValue _
) As Integer
[C#]
public int Add(
   ExtendedImageInfoContainerValue value
);
[C++]
public: int Add(
   ExtendedImageInfoContainerValue* value
)
[C++/CLI]
public:
int Add(
   ExtendedImageInfoContainerValue^ value
)

Parameters

value

Return Type

An integer which represents the length of the collection.

Remarks

This method inserts a new ExtendedImageInfoContainerValue object at the end of the collection. When this method is complete, the length of the collection will be one larger than it was and the element with the highest index will be the new object.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

ExtendedImageInfoContainerValueCollection Class | ExtendedImageInfoContainerValueCollection Members | ExtendedImageInfoContainerValue Class


Contains Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ExtendedImageInfoContainerValueCollection Class | ExtendedImageInfoContainerValueCollection Members | ExtendedImageInfoContainerValue Class

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Contains Method

PegasusImaging.WinForms.TwainPro5 Namespace > ExtendedImageInfoContainerValueCollection Class : Contains Method (ExtendedImageInfoContainerValueCollection)

Determines if the specified ExtendedImageInfoContainerValue is contained in the collection.

[Visual Basic]
Public Function Contains( _
   ByVal value As ExtendedImageInfoContainerValue _
) As Boolean
[C#]
public bool Contains(
   ExtendedImageInfoContainerValue value
);
[C++]
public: bool Contains(
   ExtendedImageInfoContainerValue* value
)
[C++/CLI]
public:
bool Contains(
   ExtendedImageInfoContainerValue^ value
)

Parameters

value

Return Type

A boolean value which is true if the given element is found within the collection. Otherwise, false is returned.

Remarks

This method searches the collection for the given ExtendedImageInfoContainerValue. If a reference to the ExtendedImageInfoContainerValue is found, this method returns true, otherwise, false is returned.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

ExtendedImageInfoContainerValueCollection Class | ExtendedImageInfoContainerValueCollection Members | ExtendedImageInfoContainerValue Class


CopyTo Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ExtendedImageInfoContainerValueCollection Class | ExtendedImageInfoContainerValueCollection Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

array
Contains an array that receives the elements of the collection.
index
Contains the zero-based index in array where this method starts copying the collection.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CopyTo Method

PegasusImaging.WinForms.TwainPro5 Namespace > ExtendedImageInfoContainerValueCollection Class : CopyTo Method (ExtendedImageInfoContainerValueCollection)

Copies all elements of the collection to the specified array, beginning at the specified index in the array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As ExtendedImageInfoContainerValue, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   ExtendedImageInfoContainerValue[] array,
   int index
);
[C++]
public: void CopyTo(
   ExtendedImageInfoContainerValue*[]* array,
   int index
)
[C++/CLI]
public:
void CopyTo(
   ExtendedImageInfoContainerValue^array<array>^ array,
   int index
)

Parameters

array
Contains an array that receives the elements of the collection.
index
Contains the zero-based index in array where this method starts copying the collection.

Remarks

This method implements a standard collection operation. It copies elements from this collection to the given array in order, starting at element 0 in this collection. It places the elements into the array starting at the given zero-based index. This method will stop copying elements when it reaches the end of the collection or the end of the array.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

ExtendedImageInfoContainerValueCollection Class | ExtendedImageInfoContainerValueCollection Members


IndexOf Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ExtendedImageInfoContainerValueCollection Class | ExtendedImageInfoContainerValueCollection Members | ExtendedImageInfoContainerValue Class

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

IndexOf Method

PegasusImaging.WinForms.TwainPro5 Namespace > ExtendedImageInfoContainerValueCollection Class : IndexOf Method (ExtendedImageInfoContainerValueCollection)

Determines if the specified ExtendedImageInfoContainerValue is in the collection and returns its index value.

[Visual Basic]
Public Function IndexOf( _
   ByVal value As ExtendedImageInfoContainerValue _
) As Integer
[C#]
public int IndexOf(
   ExtendedImageInfoContainerValue value
);
[C++]
public: int IndexOf(
   ExtendedImageInfoContainerValue* value
)
[C++/CLI]
public:
int IndexOf(
   ExtendedImageInfoContainerValue^ value
)

Parameters

value

Return Type

An integer value which represents the index of the given value within the collection.

Remarks

This method searches the collection for a reference to the given object. If it does not find a reference to it, this method returns -1. If the object is present more than once in the collection, this method returns the lowest index of a match.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

ExtendedImageInfoContainerValueCollection Class | ExtendedImageInfoContainerValueCollection Members | ExtendedImageInfoContainerValue Class


Insert Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ExtendedImageInfoContainerValueCollection Class | ExtendedImageInfoContainerValueCollection Members | ExtendedImageInfoContainerValue Class

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
value
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Insert Method

PegasusImaging.WinForms.TwainPro5 Namespace > ExtendedImageInfoContainerValueCollection Class : Insert Method (ExtendedImageInfoContainerValueCollection)

Inserts an ExtendedImageInfoContainerValue into the collection at the given index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As ExtendedImageInfoContainerValue _
)
[C#]
public void Insert(
   int index,
   ExtendedImageInfoContainerValue value
);
[C++]
public: void Insert(
   int index,
   ExtendedImageInfoContainerValue* value
)
[C++/CLI]
public:
void Insert(
   int index,
   ExtendedImageInfoContainerValue^ value
)

Parameters

index
value

Remarks

This method inserts the given ExtendedImageInfoContainerValue into the collection at the given index.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

ExtendedImageInfoContainerValueCollection Class | ExtendedImageInfoContainerValueCollection Members | ExtendedImageInfoContainerValue Class


Remove Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ExtendedImageInfoContainerValueCollection Class | ExtendedImageInfoContainerValueCollection Members | ExtendedImageInfoContainerValue Class

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Remove Method

PegasusImaging.WinForms.TwainPro5 Namespace > ExtendedImageInfoContainerValueCollection Class : Remove Method (ExtendedImageInfoContainerValueCollection)

Removes an ExtendedImageInfoContainerValue from the collection.

[Visual Basic]
Public Sub Remove( _
   ByVal value As ExtendedImageInfoContainerValue _
)
[C#]
public void Remove(
   ExtendedImageInfoContainerValue value
);
[C++]
public: void Remove(
   ExtendedImageInfoContainerValue* value
)
[C++/CLI]
public:
void Remove(
   ExtendedImageInfoContainerValue^ value
)

Parameters

value

Remarks

This method searches the collection for the given ExtendedImageInfoContainerValue and removes it. If there are no occurrences of the object, this method will do nothing.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

ExtendedImageInfoContainerValueCollection Class | ExtendedImageInfoContainerValueCollection Members | ExtendedImageInfoContainerValue Class


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ExtendedImageInfoContainerValueCollection Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ExtendedImageInfoContainerValueCollection Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : ExtendedImageInfoContainerValueCollection Class

For a list of all members of this type, see ExtendedImageInfoContainerValueCollection members.

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property Item | Gets or sets the element at the given index within the collection.

See Also

ExtendedImageInfoContainerValueCollection Class | PegasusImaging.WinForms.TwainPro5 Namespace


Item Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ExtendedImageInfoContainerValueCollection Class | ExtendedImageInfoContainerValueCollection Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
A zero-based integer specifying the index in the collection of the element to get or set.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Item Property

PegasusImaging.WinForms.TwainPro5 Namespace > ExtendedImageInfoContainerValueCollection Class : Item Property (ExtendedImageInfoContainerValueCollection)

Gets or sets the element at the given index within the collection.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("Gets or sets the element at the given index.")>
Public Default Property Item( _
   ByVal index As Integer _
) As ExtendedImageInfoContainerValue
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets or sets the element at the given index.")]
public ExtendedImageInfoContainerValue this[
   int index
]; {get; set;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets or sets the element at the given index.")]
public: __property ExtendedImageInfoContainerValue* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   ExtendedImageInfoContainerValue* value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets or sets the element at the given index.")]
public:
 property ExtendedImageInfoContainerValue^ default [int] {
   ExtendedImageInfoContainerValue^ get(int index);
   void set (int index, ExtendedImageInfoContainerValue^ value);
}

Parameters

index
A zero-based integer specifying the index in the collection of the element to get or set.

Value

An ExtendedImageInfoContainerValue which represents the element to get or set at the given index within the collection.

Remarks

This method implements a standard collection operation. It is the principle method you will use to read or change elements in the collection. You can read or modify any element in the collection with this method.

Requirements

See Also

ExtendedImageInfoContainerValueCollection Class | ExtendedImageInfoContainerValueCollection Members


ExtendedImageInfoContainerValueFloat Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ExtendedImageInfoContainerValueFloat Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ExtendedImageInfoContainerValueFloat Class

PegasusImaging.WinForms.TwainPro5 Namespace : ExtendedImageInfoContainerValueFloat Class

This class implements a float value of extended image info.

For a list of all members of this type, see ExtendedImageInfoContainerValueFloat members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.TwainPro5.ExtendedImageInfoContainerValue
PegasusImaging.WinForms.TwainPro5.ExtendedImageInfoContainerValueFloat

Syntax

[Visual Basic]
Public Class ExtendedImageInfoContainerValueFloat
   Inherits ExtendedImageInfoContainerValue
[C#]
public class ExtendedImageInfoContainerValueFloat : ExtendedImageInfoContainerValue
[C++]
public __gc class ExtendedImageInfoContainerValueFloat : public ExtendedImageInfoContainerValue
[C++/CLI]
public ref class ExtendedImageInfoContainerValueFloat : public ExtendedImageInfoContainerValue

Remarks

You cannot create an ExtendedImageInfoContainerValueFloat object directly. This object is inherited from ExtendedImageInfoContainerValue, which is a member of the Values collection of the ExtendedImageInfoContainer object which can be obtained by calling the ScannedImage.GetExtendedImageInfo(ExtendedImageInfo) method.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

ExtendedImageInfoContainerValueFloat Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ExtendedImageInfoContainerValueFloat Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ExtendedImageInfoContainerValueFloat Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : ExtendedImageInfoContainerValueFloat Class

ExtendedImageInfoContainerValueFloat overview

Public Properties

Public Property Value Gets a float value of extended image info.

See Also

ExtendedImageInfoContainerValueFloat Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ExtendedImageInfoContainerValueFloat Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ExtendedImageInfoContainerValueFloat Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : ExtendedImageInfoContainerValueFloat Class

For a list of all members of this type, see ExtendedImageInfoContainerValueFloat members.

Public Properties

Public Property Value Gets a float value of extended image info.

See Also

ExtendedImageInfoContainerValueFloat Class | PegasusImaging.WinForms.TwainPro5 Namespace


Value Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ExtendedImageInfoContainerValueFloat Class | ExtendedImageInfoContainerValueFloat Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Value Property

PegasusImaging.WinForms.TwainPro5 Namespace > ExtendedImageInfoContainerValueFloat Class : Value Property (ExtendedImageInfoContainerValueFloat)

Gets a float value of extended image info.

[Visual Basic]
<DescriptionAttribute("A float value of extended image info.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property Value As Single
[C#]
[DescriptionAttribute("A float value of extended image info.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public float Value {get;}
[C++]
[DescriptionAttribute("A float value of extended image info.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property float get_Value();
[C++/CLI]
[DescriptionAttribute("A float value of extended image info.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property float Value {
   float get();
}

Value

A float value which represents extended image info.

Remarks

The default value is -1.

Requirements

See Also

ExtendedImageInfoContainerValueFloat Class | ExtendedImageInfoContainerValueFloat Members


ExtendedImageInfoContainerValueString Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ExtendedImageInfoContainerValueString Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ExtendedImageInfoContainerValueString Class

PegasusImaging.WinForms.TwainPro5 Namespace : ExtendedImageInfoContainerValueString Class

This class implements a string value of extended image info.

For a list of all members of this type, see ExtendedImageInfoContainerValueString members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.TwainPro5.ExtendedImageInfoContainerValue
PegasusImaging.WinForms.TwainPro5.ExtendedImageInfoContainerValueString

Syntax

[Visual Basic]
Public Class ExtendedImageInfoContainerValueString
   Inherits ExtendedImageInfoContainerValue
[C#]
public class ExtendedImageInfoContainerValueString : ExtendedImageInfoContainerValue
[C++]
public __gc class ExtendedImageInfoContainerValueString : public ExtendedImageInfoContainerValue
[C++/CLI]
public ref class ExtendedImageInfoContainerValueString : public ExtendedImageInfoContainerValue

Remarks

You cannot create an ExtendedImageInfoContainerValueString object directly. This object is inherited from ExtendedImageInfoContainerValue, which is a member of the Values collection of the ExtendedImageInfoContainer object which can be obtained by calling the ScannedImage.GetExtendedImageInfo(ExtendedImageInfo) method.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

ExtendedImageInfoContainerValueString Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ExtendedImageInfoContainerValueString Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ExtendedImageInfoContainerValueString Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : ExtendedImageInfoContainerValueString Class

ExtendedImageInfoContainerValueString overview

Public Properties

Public Property Value Gets a string value of extended image info.

See Also

ExtendedImageInfoContainerValueString Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ExtendedImageInfoContainerValueString Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ExtendedImageInfoContainerValueString Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : ExtendedImageInfoContainerValueString Class

For a list of all members of this type, see ExtendedImageInfoContainerValueString members.

Public Properties

Public Property Value Gets a string value of extended image info.

See Also

ExtendedImageInfoContainerValueString Class | PegasusImaging.WinForms.TwainPro5 Namespace


Value Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ExtendedImageInfoContainerValueString Class | ExtendedImageInfoContainerValueString Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Value Property

PegasusImaging.WinForms.TwainPro5 Namespace > ExtendedImageInfoContainerValueString Class : Value Property (ExtendedImageInfoContainerValueString)

Gets a string value of extended image info.

[Visual Basic]
<DescriptionAttribute("A string value of extended image info.")>
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public ReadOnly Property Value As String
[C#]
[DescriptionAttribute("A string value of extended image info.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public string Value {get;}
[C++]
[DescriptionAttribute("A string value of extended image info.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property string* get_Value();
[C++/CLI]
[DescriptionAttribute("A string value of extended image info.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property String^ Value {
   String^ get();
}

Value

A string value which represents the extended image info.

Remarks

The default value is -1

Requirements

See Also

ExtendedImageInfoContainerValueString Class | ExtendedImageInfoContainerValueString Members


FileCreateException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileCreateException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileCreateException Class

PegasusImaging.WinForms.TwainPro5 Namespace : FileCreateException Class

This exception is thrown if TwainPRO is unable to create the file specified in the Save method.

For a list of all members of this type, see FileCreateException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.FileCreateException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class FileCreateException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class FileCreateException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class FileCreateException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class FileCreateException sealed : public TwainProException

Remarks

Possible causes:

The drive or path specified doesn't exist.

The file exists and is in use by another application.

No file extension or an invalid file extension was specified.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

FileCreateException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileCreateException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileCreateException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : FileCreateException Class

FileCreateException overview

Public Constructors

Public Constructor FileCreateException Constructor Overloaded. An exception generated for a file create error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

FileCreateException Class | PegasusImaging.WinForms.TwainPro5 Namespace


FileCreateException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileCreateException Class | FileCreateException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileCreateException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > FileCreateException Class : FileCreateException Constructor (FileCreateException)

An exception generated for a file create error.

Overload List

An exception generated for a file create error.

[Visual Basic] Public Sub New()

[C#] public FileCreateException();

[C++] public FileCreateException();

[C++/CLI] public FileCreateException();

Generated exception for a file create error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public FileCreateException(int);

[C++] public FileCreateException(int);

[C++/CLI] public FileCreateException(int);

Generated exception for a file create error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public FileCreateException(string);

[C++] public FileCreateException(string*);

[C++/CLI] public FileCreateException(String^);

Generated exception for a file create error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public FileCreateException(int,string);

[C++] public FileCreateException(int,string*);

[C++/CLI] public FileCreateException(int,String^);

Generated exception for a file create error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public FileCreateException(string,Exception);

[C++] public FileCreateException(string*,Exception*);

[C++/CLI] public FileCreateException(String^,Exception^);

Requirements

See Also

FileCreateException Class | FileCreateException Members


FileCreateException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileCreateException Class | FileCreateException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileCreateException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > FileCreateException Class > FileCreateException Constructor : FileCreateException Constructor()

An exception generated for a file create error.

[Visual Basic]
Public Function New()
[C#]
public FileCreateException();
[C++]
public: FileCreateException();
[C++/CLI]
public:
FileCreateException();

Requirements

See Also

FileCreateException Class | FileCreateException Members | Overload List


FileCreateException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileCreateException Class | FileCreateException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileCreateException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > FileCreateException Class > FileCreateException Constructor : FileCreateException Constructor(Int32)

Generated exception for a file create error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public FileCreateException(
   int errorNumber
);
[C++]
public: FileCreateException(
   int errorNumber
)
[C++/CLI]
public:
FileCreateException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

FileCreateException Class | FileCreateException Members | Overload List


FileCreateException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileCreateException Class | FileCreateException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileCreateException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > FileCreateException Class > FileCreateException Constructor : FileCreateException Constructor(Int32,String)

Generated exception for a file create error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public FileCreateException(
   int errorNumber,
   string message
);
[C++]
public: FileCreateException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
FileCreateException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

FileCreateException Class | FileCreateException Members | Overload List


FileCreateException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileCreateException Class | FileCreateException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileCreateException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > FileCreateException Class > FileCreateException Constructor : FileCreateException Constructor(String)

Generated exception for a file create error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public FileCreateException(
   string message
);
[C++]
public: FileCreateException(
   string* message
)
[C++/CLI]
public:
FileCreateException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

FileCreateException Class | FileCreateException Members | Overload List


FileCreateException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileCreateException Class | FileCreateException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileCreateException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > FileCreateException Class > FileCreateException Constructor : FileCreateException Constructor(String,Exception)

Generated exception for a file create error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public FileCreateException(
   string message,
   Exception innerException
);
[C++]
public: FileCreateException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
FileCreateException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

FileCreateException Class | FileCreateException Members | Overload List


FileOpenException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileOpenException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileOpenException Class

PegasusImaging.WinForms.TwainPro5 Namespace : FileOpenException Class

This exception is thrown if TwainPRO is unable to open an existing file to append pages when saving a multi-page image file, or if TwainPRO is unable to open a settings file.

For a list of all members of this type, see FileOpenException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.FileOpenException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class FileOpenException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class FileOpenException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class FileOpenException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class FileOpenException sealed : public TwainProException

Remarks

Possible causes:

The file is open in another control or application.

The file is read-only.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

FileOpenException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileOpenException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileOpenException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : FileOpenException Class

FileOpenException overview

Public Constructors

Public Constructor FileOpenException Constructor Overloaded. An exception generated for a file open error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

FileOpenException Class | PegasusImaging.WinForms.TwainPro5 Namespace


FileOpenException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileOpenException Class | FileOpenException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileOpenException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > FileOpenException Class : FileOpenException Constructor (FileOpenException)

An exception generated for a file open error.

Overload List

An exception generated for a file open error.

[Visual Basic] Public Sub New()

[C#] public FileOpenException();

[C++] public FileOpenException();

[C++/CLI] public FileOpenException();

Generated exception for a file open error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public FileOpenException(int);

[C++] public FileOpenException(int);

[C++/CLI] public FileOpenException(int);

Generated exception for a file open error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public FileOpenException(string);

[C++] public FileOpenException(string*);

[C++/CLI] public FileOpenException(String^);

Generated exception for a file open error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public FileOpenException(int,string);

[C++] public FileOpenException(int,string*);

[C++/CLI] public FileOpenException(int,String^);

Generated exception for a file open error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public FileOpenException(string,Exception);

[C++] public FileOpenException(string*,Exception*);

[C++/CLI] public FileOpenException(String^,Exception^);

Requirements

See Also

FileOpenException Class | FileOpenException Members


FileOpenException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileOpenException Class | FileOpenException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileOpenException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > FileOpenException Class > FileOpenException Constructor : FileOpenException Constructor()

An exception generated for a file open error.

[Visual Basic]
Public Function New()
[C#]
public FileOpenException();
[C++]
public: FileOpenException();
[C++/CLI]
public:
FileOpenException();

Requirements

See Also

FileOpenException Class | FileOpenException Members | Overload List


FileOpenException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileOpenException Class | FileOpenException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileOpenException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > FileOpenException Class > FileOpenException Constructor : FileOpenException Constructor(Int32)

Generated exception for a file open error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public FileOpenException(
   int errorNumber
);
[C++]
public: FileOpenException(
   int errorNumber
)
[C++/CLI]
public:
FileOpenException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

FileOpenException Class | FileOpenException Members | Overload List


FileOpenException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileOpenException Class | FileOpenException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileOpenException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > FileOpenException Class > FileOpenException Constructor : FileOpenException Constructor(Int32,String)

Generated exception for a file open error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public FileOpenException(
   int errorNumber,
   string message
);
[C++]
public: FileOpenException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
FileOpenException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

FileOpenException Class | FileOpenException Members | Overload List


FileOpenException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileOpenException Class | FileOpenException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileOpenException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > FileOpenException Class > FileOpenException Constructor : FileOpenException Constructor(String)

Generated exception for a file open error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public FileOpenException(
   string message
);
[C++]
public: FileOpenException(
   string* message
)
[C++/CLI]
public:
FileOpenException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

FileOpenException Class | FileOpenException Members | Overload List


FileOpenException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileOpenException Class | FileOpenException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileOpenException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > FileOpenException Class > FileOpenException Constructor : FileOpenException Constructor(String,Exception)

Generated exception for a file open error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public FileOpenException(
   string message,
   Exception innerException
);
[C++]
public: FileOpenException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
FileOpenException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

FileOpenException Class | FileOpenException Members | Overload List


FileReadException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileReadException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileReadException Class

PegasusImaging.WinForms.TwainPro5 Namespace : FileReadException Class

This exception is thrown if TwainPRO is unable to read an existing file to append pages when saving a multi-page image file, or if TwainPRO is unable to read a settings file.

For a list of all members of this type, see FileReadException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.FileReadException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class FileReadException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class FileReadException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class FileReadException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class FileReadException sealed : public TwainProException

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

FileReadException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileReadException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileReadException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : FileReadException Class

FileReadException overview

Public Constructors

Public Constructor FileReadException Constructor Overloaded. An exception generated for a file read error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

FileReadException Class | PegasusImaging.WinForms.TwainPro5 Namespace


FileReadException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileReadException Class | FileReadException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileReadException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > FileReadException Class : FileReadException Constructor (FileReadException)

An exception generated for a file read error.

Overload List

An exception generated for a file read error.

[Visual Basic] Public Sub New()

[C#] public FileReadException();

[C++] public FileReadException();

[C++/CLI] public FileReadException();

Generated exception for a file read error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public FileReadException(int);

[C++] public FileReadException(int);

[C++/CLI] public FileReadException(int);

Generated exception for a file read error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public FileReadException(string);

[C++] public FileReadException(string*);

[C++/CLI] public FileReadException(String^);

Generated exception for a file read error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public FileReadException(int,string);

[C++] public FileReadException(int,string*);

[C++/CLI] public FileReadException(int,String^);

Generated exception for a file read error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public FileReadException(string,Exception);

[C++] public FileReadException(string*,Exception*);

[C++/CLI] public FileReadException(String^,Exception^);

Requirements

See Also

FileReadException Class | FileReadException Members


FileReadException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileReadException Class | FileReadException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileReadException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > FileReadException Class > FileReadException Constructor : FileReadException Constructor()

An exception generated for a file read error.

[Visual Basic]
Public Function New()
[C#]
public FileReadException();
[C++]
public: FileReadException();
[C++/CLI]
public:
FileReadException();

Requirements

See Also

FileReadException Class | FileReadException Members | Overload List


FileReadException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileReadException Class | FileReadException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileReadException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > FileReadException Class > FileReadException Constructor : FileReadException Constructor(Int32)

Generated exception for a file read error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public FileReadException(
   int errorNumber
);
[C++]
public: FileReadException(
   int errorNumber
)
[C++/CLI]
public:
FileReadException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

FileReadException Class | FileReadException Members | Overload List


FileReadException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileReadException Class | FileReadException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileReadException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > FileReadException Class > FileReadException Constructor : FileReadException Constructor(Int32,String)

Generated exception for a file read error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public FileReadException(
   int errorNumber,
   string message
);
[C++]
public: FileReadException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
FileReadException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

FileReadException Class | FileReadException Members | Overload List


FileReadException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileReadException Class | FileReadException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileReadException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > FileReadException Class > FileReadException Constructor : FileReadException Constructor(String)

Generated exception for a file read error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public FileReadException(
   string message
);
[C++]
public: FileReadException(
   string* message
)
[C++/CLI]
public:
FileReadException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

FileReadException Class | FileReadException Members | Overload List


FileReadException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileReadException Class | FileReadException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileReadException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > FileReadException Class > FileReadException Constructor : FileReadException Constructor(String,Exception)

Generated exception for a file read error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public FileReadException(
   string message,
   Exception innerException
);
[C++]
public: FileReadException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
FileReadException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

FileReadException Class | FileReadException Members | Overload List


FileWriteException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileWriteException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileWriteException Class

PegasusImaging.WinForms.TwainPro5 Namespace : FileWriteException Class

This exception is thrown if an error occurs while TwainPRO is attempting to save a file to the path specified in the Save method, or while TwainPRO is attempting to write a settings file.

For a list of all members of this type, see FileWriteException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.FileWriteException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class FileWriteException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class FileWriteException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class FileWriteException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class FileWriteException sealed : public TwainProException

Remarks

Possible causes:

The drive or path became invalid during the write. This can occur if the drive is a network drive.

The disk is full.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

FileWriteException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileWriteException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileWriteException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : FileWriteException Class

FileWriteException overview

Public Constructors

Public Constructor FileWriteException Constructor Overloaded. An exception generated for a file write error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

FileWriteException Class | PegasusImaging.WinForms.TwainPro5 Namespace


FileWriteException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileWriteException Class | FileWriteException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileWriteException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > FileWriteException Class : FileWriteException Constructor (FileWriteException)

An exception generated for a file write error.

Overload List

An exception generated for a file write error.

[Visual Basic] Public Sub New()

[C#] public FileWriteException();

[C++] public FileWriteException();

[C++/CLI] public FileWriteException();

Generated exception for a file write error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public FileWriteException(int);

[C++] public FileWriteException(int);

[C++/CLI] public FileWriteException(int);

Generated exception for a file write error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public FileWriteException(string);

[C++] public FileWriteException(string*);

[C++/CLI] public FileWriteException(String^);

Generated exception for a file write error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public FileWriteException(int,string);

[C++] public FileWriteException(int,string*);

[C++/CLI] public FileWriteException(int,String^);

Generated exception for a file write error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public FileWriteException(string,Exception);

[C++] public FileWriteException(string*,Exception*);

[C++/CLI] public FileWriteException(String^,Exception^);

Requirements

See Also

FileWriteException Class | FileWriteException Members


FileWriteException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileWriteException Class | FileWriteException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileWriteException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > FileWriteException Class > FileWriteException Constructor : FileWriteException Constructor()

An exception generated for a file write error.

[Visual Basic]
Public Function New()
[C#]
public FileWriteException();
[C++]
public: FileWriteException();
[C++/CLI]
public:
FileWriteException();

Requirements

See Also

FileWriteException Class | FileWriteException Members | Overload List


FileWriteException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileWriteException Class | FileWriteException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileWriteException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > FileWriteException Class > FileWriteException Constructor : FileWriteException Constructor(Int32)

Generated exception for a file write error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public FileWriteException(
   int errorNumber
);
[C++]
public: FileWriteException(
   int errorNumber
)
[C++/CLI]
public:
FileWriteException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

FileWriteException Class | FileWriteException Members | Overload List


FileWriteException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileWriteException Class | FileWriteException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileWriteException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > FileWriteException Class > FileWriteException Constructor : FileWriteException Constructor(Int32,String)

Generated exception for a file write error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public FileWriteException(
   int errorNumber,
   string message
);
[C++]
public: FileWriteException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
FileWriteException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

FileWriteException Class | FileWriteException Members | Overload List


FileWriteException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileWriteException Class | FileWriteException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileWriteException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > FileWriteException Class > FileWriteException Constructor : FileWriteException Constructor(String)

Generated exception for a file write error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public FileWriteException(
   string message
);
[C++]
public: FileWriteException(
   string* message
)
[C++/CLI]
public:
FileWriteException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

FileWriteException Class | FileWriteException Members | Overload List


FileWriteException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileWriteException Class | FileWriteException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileWriteException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > FileWriteException Class > FileWriteException Constructor : FileWriteException Constructor(String,Exception)

Generated exception for a file write error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public FileWriteException(
   string message,
   Exception innerException
);
[C++]
public: FileWriteException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
FileWriteException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

FileWriteException Class | FileWriteException Members | Overload List


FtpOptions Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FtpOptions Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FtpOptions Class

PegasusImaging.WinForms.TwainPro5 Namespace : FtpOptions Class (PegasusImaging.WinForms.TwainPro5)

This class implements properties and methods necessary for authentication and remote processing when saving an image.

For a list of all members of this type, see FtpOptions members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.TwainPro5.FtpOptions

Syntax

[Visual Basic]
Public Class FtpOptions
[C#]
public class FtpOptions
[C++]
public __gc class FtpOptions
[C++/CLI]
public ref class FtpOptions

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

FtpOptions Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FtpOptions Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FtpOptions Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : FtpOptions Class (PegasusImaging.WinForms.TwainPro5)

FtpOptions overview

Public Properties

Public Property NetworkCredentials | Gets and sets credentials for password based authentication.
Public Property ProxySettings | Gets and sets the proxy server name or ID.

See Also

FtpOptions Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FtpOptions Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FtpOptions Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : FtpOptions Class (PegasusImaging.WinForms.TwainPro5)

For a list of all members of this type, see FtpOptions members.

Public Properties

Public Property NetworkCredentials | Gets and sets credentials for password based authentication.
Public Property ProxySettings | Gets and sets the proxy server name or ID.

See Also

FtpOptions Class | PegasusImaging.WinForms.TwainPro5 Namespace


NetworkCredentials Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FtpOptions Class | FtpOptions Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

NetworkCredentials Property

PegasusImaging.WinForms.TwainPro5 Namespace > FtpOptions Class : NetworkCredentials Property

Gets and sets credentials for password based authentication.

[Visual Basic]
<DescriptionAttribute("Gets or sets credentials for password based authentication.")>
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property NetworkCredentials As NetworkCredential
[C#]
[DescriptionAttribute("Gets or sets credentials for password based authentication.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public NetworkCredential NetworkCredentials {get; set;}
[C++]
[DescriptionAttribute("Gets or sets credentials for password based authentication.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property NetworkCredential* get_NetworkCredentials();
public: __property void set_NetworkCredentials(
   NetworkCredential* value
);
[C++/CLI]
[DescriptionAttribute("Gets or sets credentials for password based authentication.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property NetworkCredential^ NetworkCredentials {
   NetworkCredential^ get();
   void set (NetworkCredential^ value);
}

Value

A NetworkCredential value which is used for password based authentication.

Requirements

See Also

FtpOptions Class | FtpOptions Members


ProxySettings Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FtpOptions Class | FtpOptions Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ProxySettings Property

PegasusImaging.WinForms.TwainPro5 Namespace > FtpOptions Class : ProxySettings Property

Gets and sets the proxy server name or ID.

[Visual Basic]
<DescriptionAttribute("Gets or sets the proxy server name or ID.")>
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property ProxySettings As WebProxy
[C#]
[DescriptionAttribute("Gets or sets the proxy server name or ID.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public WebProxy ProxySettings {get; set;}
[C++]
[DescriptionAttribute("Gets or sets the proxy server name or ID.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property WebProxy* get_ProxySettings();
public: __property void set_ProxySettings(
   WebProxy* value
);
[C++/CLI]
[DescriptionAttribute("Gets or sets the proxy server name or ID.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property WebProxy^ ProxySettings {
   WebProxy^ get();
   void set (WebProxy^ value);
}

Value

A WebProxy value which represents the server name.

Requirements

See Also

FtpOptions Class | FtpOptions Members


FtpTransferException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FtpTransferException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FtpTransferException Class

PegasusImaging.WinForms.TwainPro5 Namespace : FtpTransferException Class

This exception is thrown if an error occurs trying to FTP an image.

For a list of all members of this type, see FtpTransferException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.FtpTransferException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class FtpTransferException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class FtpTransferException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class FtpTransferException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class FtpTransferException sealed : public TwainProException

Remarks

Possible causes:

The machine is not currently connected to a network. The FTP UserName and/or FTP Password properties are not correct for the requested host specified in the Save method.

The host and or path specified in the Save method doesn’t exist.

The path was not specified in the Save method. A fully qualified url containing both the servername and file path must be specified. For example, "http://ftp.myserver.com/ftp/public/test.jpg" contains both the server and file information, but "http://ftp.myserver.com" does not.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

FtpTransferException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FtpTransferException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FtpTransferException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : FtpTransferException Class

FtpTransferException overview

Public Constructors

Public Constructor FtpTransferException Constructor Overloaded. An exception generated for an FTP transfer error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

FtpTransferException Class | PegasusImaging.WinForms.TwainPro5 Namespace


FtpTransferException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FtpTransferException Class | FtpTransferException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FtpTransferException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > FtpTransferException Class : FtpTransferException Constructor (FtpTransferException)

An exception generated for an FTP transfer error.

Overload List

An exception generated for an FTP transfer error.

[Visual Basic] Public Sub New()

[C#] public FtpTransferException();

[C++] public FtpTransferException();

[C++/CLI] public FtpTransferException();

Generated exception for an FTP transfer error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public FtpTransferException(int);

[C++] public FtpTransferException(int);

[C++/CLI] public FtpTransferException(int);

Generated exception for an FTP transfer error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public FtpTransferException(string);

[C++] public FtpTransferException(string*);

[C++/CLI] public FtpTransferException(String^);

Generated exception for an FTP transfer error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public FtpTransferException(int,string);

[C++] public FtpTransferException(int,string*);

[C++/CLI] public FtpTransferException(int,String^);

Generated exception for an FTP transfer error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public FtpTransferException(string,Exception);

[C++] public FtpTransferException(string*,Exception*);

[C++/CLI] public FtpTransferException(String^,Exception^);

Requirements

See Also

FtpTransferException Class | FtpTransferException Members


FtpTransferException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FtpTransferException Class | FtpTransferException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FtpTransferException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > FtpTransferException Class > FtpTransferException Constructor : FtpTransferException Constructor()

An exception generated for an FTP transfer error.

[Visual Basic]
Public Function New()
[C#]
public FtpTransferException();
[C++]
public: FtpTransferException();
[C++/CLI]
public:
FtpTransferException();

Requirements

See Also

FtpTransferException Class | FtpTransferException Members | Overload List


FtpTransferException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FtpTransferException Class | FtpTransferException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FtpTransferException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > FtpTransferException Class > FtpTransferException Constructor : FtpTransferException Constructor(Int32)

Generated exception for an FTP transfer error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public FtpTransferException(
   int errorNumber
);
[C++]
public: FtpTransferException(
   int errorNumber
)
[C++/CLI]
public:
FtpTransferException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

FtpTransferException Class | FtpTransferException Members | Overload List


FtpTransferException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FtpTransferException Class | FtpTransferException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FtpTransferException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > FtpTransferException Class > FtpTransferException Constructor : FtpTransferException Constructor(Int32,String)

Generated exception for an FTP transfer error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public FtpTransferException(
   int errorNumber,
   string message
);
[C++]
public: FtpTransferException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
FtpTransferException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

FtpTransferException Class | FtpTransferException Members | Overload List


FtpTransferException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FtpTransferException Class | FtpTransferException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FtpTransferException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > FtpTransferException Class > FtpTransferException Constructor : FtpTransferException Constructor(String)

Generated exception for an FTP transfer error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public FtpTransferException(
   string message
);
[C++]
public: FtpTransferException(
   string* message
)
[C++/CLI]
public:
FtpTransferException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

FtpTransferException Class | FtpTransferException Members | Overload List


FtpTransferException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FtpTransferException Class | FtpTransferException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FtpTransferException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > FtpTransferException Class > FtpTransferException Constructor : FtpTransferException Constructor(String,Exception)

Generated exception for an FTP transfer error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public FtpTransferException(
   string message,
   Exception innerException
);
[C++]
public: FtpTransferException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
FtpTransferException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

FtpTransferException Class | FtpTransferException Members | Overload List


ImageNotAvailableException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ImageNotAvailableException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ImageNotAvailableException Class

PegasusImaging.WinForms.TwainPro5 Namespace : ImageNotAvailableException Class

This exception is thrown if no image is available for the requested operation or an unsupported DIB format was returned in response to a StartSession.

For a list of all members of this type, see ImageNotAvailableException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.ImageNotAvailableException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class ImageNotAvailableException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class ImageNotAvailableException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class ImageNotAvailableException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class ImageNotAvailableException sealed : public TwainProException

Remarks

Possible causes:

The image has already been read.

The Save method was invoked after the image was read.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

ImageNotAvailableException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ImageNotAvailableException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ImageNotAvailableException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : ImageNotAvailableException Class

ImageNotAvailableException overview

Public Constructors

Public Constructor ImageNotAvailableException Constructor Overloaded. An exception generated for an image not available error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ImageNotAvailableException Class | PegasusImaging.WinForms.TwainPro5 Namespace


ImageNotAvailableException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ImageNotAvailableException Class | ImageNotAvailableException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ImageNotAvailableException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > ImageNotAvailableException Class : ImageNotAvailableException Constructor (ImageNotAvailableException)

An exception generated for an image not available error.

Overload List

An exception generated for an image not available error.

[Visual Basic] Public Sub New()

[C#] public ImageNotAvailableException();

[C++] public ImageNotAvailableException();

[C++/CLI] public ImageNotAvailableException();

Generated exception for an image not available error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public ImageNotAvailableException(int);

[C++] public ImageNotAvailableException(int);

[C++/CLI] public ImageNotAvailableException(int);

Generated exception for an image not available error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public ImageNotAvailableException(string);

[C++] public ImageNotAvailableException(string*);

[C++/CLI] public ImageNotAvailableException(String^);

Generated exception for an image not available error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public ImageNotAvailableException(int,string);

[C++] public ImageNotAvailableException(int,string*);

[C++/CLI] public ImageNotAvailableException(int,String^);

Generated exception for an image not available error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public ImageNotAvailableException(string,Exception);

[C++] public ImageNotAvailableException(string*,Exception*);

[C++/CLI] public ImageNotAvailableException(String^,Exception^);

Requirements

See Also

ImageNotAvailableException Class | ImageNotAvailableException Members


ImageNotAvailableException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ImageNotAvailableException Class | ImageNotAvailableException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ImageNotAvailableException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > ImageNotAvailableException Class > ImageNotAvailableException Constructor : ImageNotAvailableException Constructor()

An exception generated for an image not available error.

[Visual Basic]
Public Function New()
[C#]
public ImageNotAvailableException();
[C++]
public: ImageNotAvailableException();
[C++/CLI]
public:
ImageNotAvailableException();

Requirements

See Also

ImageNotAvailableException Class | ImageNotAvailableException Members | Overload List


ImageNotAvailableException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ImageNotAvailableException Class | ImageNotAvailableException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ImageNotAvailableException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > ImageNotAvailableException Class > ImageNotAvailableException Constructor : ImageNotAvailableException Constructor(Int32)

Generated exception for an image not available error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public ImageNotAvailableException(
   int errorNumber
);
[C++]
public: ImageNotAvailableException(
   int errorNumber
)
[C++/CLI]
public:
ImageNotAvailableException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

ImageNotAvailableException Class | ImageNotAvailableException Members | Overload List


ImageNotAvailableException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ImageNotAvailableException Class | ImageNotAvailableException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ImageNotAvailableException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > ImageNotAvailableException Class > ImageNotAvailableException Constructor : ImageNotAvailableException Constructor(Int32,String)

Generated exception for an image not available error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public ImageNotAvailableException(
   int errorNumber,
   string message
);
[C++]
public: ImageNotAvailableException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
ImageNotAvailableException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

ImageNotAvailableException Class | ImageNotAvailableException Members | Overload List


ImageNotAvailableException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ImageNotAvailableException Class | ImageNotAvailableException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ImageNotAvailableException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > ImageNotAvailableException Class > ImageNotAvailableException Constructor : ImageNotAvailableException Constructor(String)

Generated exception for an image not available error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public ImageNotAvailableException(
   string message
);
[C++]
public: ImageNotAvailableException(
   string* message
)
[C++/CLI]
public:
ImageNotAvailableException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

ImageNotAvailableException Class | ImageNotAvailableException Members | Overload List


ImageNotAvailableException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ImageNotAvailableException Class | ImageNotAvailableException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ImageNotAvailableException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > ImageNotAvailableException Class > ImageNotAvailableException Constructor : ImageNotAvailableException Constructor(String,Exception)

Generated exception for an image not available error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public ImageNotAvailableException(
   string message,
   Exception innerException
);
[C++]
public: ImageNotAvailableException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
ImageNotAvailableException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

ImageNotAvailableException Class | ImageNotAvailableException Members | Overload List


IndexOutOfRangeException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

IndexOutOfRangeException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

IndexOutOfRangeException Class

PegasusImaging.WinForms.TwainPro5 Namespace : IndexOutOfRangeException Class

This exception is thrown if the requested index was out of range for the property array.

For a list of all members of this type, see IndexOutOfRangeException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.IndexOutOfRangeException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class IndexOutOfRangeException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class IndexOutOfRangeException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class IndexOutOfRangeException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class IndexOutOfRangeException sealed : public TwainProException

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

IndexOutOfRangeException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

IndexOutOfRangeException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

IndexOutOfRangeException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : IndexOutOfRangeException Class

IndexOutOfRangeException overview

Public Constructors

Public Constructor IndexOutOfRangeException Constructor Overloaded. An exception generated for an index out of range error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

IndexOutOfRangeException Class | PegasusImaging.WinForms.TwainPro5 Namespace


IndexOutOfRangeException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

IndexOutOfRangeException Class | IndexOutOfRangeException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

IndexOutOfRangeException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > IndexOutOfRangeException Class : IndexOutOfRangeException Constructor (IndexOutOfRangeException)

An exception generated for an index out of range error.

Overload List

An exception generated for an index out of range error.

[Visual Basic] Public Sub New()

[C#] public IndexOutOfRangeException();

[C++] public IndexOutOfRangeException();

[C++/CLI] public IndexOutOfRangeException();

Generated exception for an index out of range error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public IndexOutOfRangeException(int);

[C++] public IndexOutOfRangeException(int);

[C++/CLI] public IndexOutOfRangeException(int);

Generated exception for an index out of range error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public IndexOutOfRangeException(string);

[C++] public IndexOutOfRangeException(string*);

[C++/CLI] public IndexOutOfRangeException(String^);

Generated exception for an index out of range error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public IndexOutOfRangeException(int,string);

[C++] public IndexOutOfRangeException(int,string*);

[C++/CLI] public IndexOutOfRangeException(int,String^);

Generated exception for an index out of range error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public IndexOutOfRangeException(string,Exception);

[C++] public IndexOutOfRangeException(string*,Exception*);

[C++/CLI] public IndexOutOfRangeException(String^,Exception^);

Requirements

See Also

IndexOutOfRangeException Class | IndexOutOfRangeException Members


IndexOutOfRangeException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

IndexOutOfRangeException Class | IndexOutOfRangeException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

IndexOutOfRangeException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > IndexOutOfRangeException Class > IndexOutOfRangeException Constructor : IndexOutOfRangeException Constructor()

An exception generated for an index out of range error.

[Visual Basic]
Public Function New()
[C#]
public IndexOutOfRangeException();
[C++]
public: IndexOutOfRangeException();
[C++/CLI]
public:
IndexOutOfRangeException();

Requirements

See Also

IndexOutOfRangeException Class | IndexOutOfRangeException Members | Overload List


IndexOutOfRangeException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

IndexOutOfRangeException Class | IndexOutOfRangeException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

IndexOutOfRangeException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > IndexOutOfRangeException Class > IndexOutOfRangeException Constructor : IndexOutOfRangeException Constructor(Int32)

Generated exception for an index out of range error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public IndexOutOfRangeException(
   int errorNumber
);
[C++]
public: IndexOutOfRangeException(
   int errorNumber
)
[C++/CLI]
public:
IndexOutOfRangeException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

IndexOutOfRangeException Class | IndexOutOfRangeException Members | Overload List


IndexOutOfRangeException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

IndexOutOfRangeException Class | IndexOutOfRangeException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

IndexOutOfRangeException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > IndexOutOfRangeException Class > IndexOutOfRangeException Constructor : IndexOutOfRangeException Constructor(Int32,String)

Generated exception for an index out of range error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public IndexOutOfRangeException(
   int errorNumber,
   string message
);
[C++]
public: IndexOutOfRangeException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
IndexOutOfRangeException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

IndexOutOfRangeException Class | IndexOutOfRangeException Members | Overload List


IndexOutOfRangeException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

IndexOutOfRangeException Class | IndexOutOfRangeException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

IndexOutOfRangeException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > IndexOutOfRangeException Class > IndexOutOfRangeException Constructor : IndexOutOfRangeException Constructor(String)

Generated exception for an index out of range error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public IndexOutOfRangeException(
   string message
);
[C++]
public: IndexOutOfRangeException(
   string* message
)
[C++/CLI]
public:
IndexOutOfRangeException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

IndexOutOfRangeException Class | IndexOutOfRangeException Members | Overload List


IndexOutOfRangeException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

IndexOutOfRangeException Class | IndexOutOfRangeException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

IndexOutOfRangeException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > IndexOutOfRangeException Class > IndexOutOfRangeException Constructor : IndexOutOfRangeException Constructor(String,Exception)

Generated exception for an index out of range error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public IndexOutOfRangeException(
   string message,
   Exception innerException
);
[C++]
public: IndexOutOfRangeException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
IndexOutOfRangeException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

IndexOutOfRangeException Class | IndexOutOfRangeException Members | Overload List


InternalErrorException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InternalErrorException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InternalErrorException Class

PegasusImaging.WinForms.TwainPro5 Namespace : InternalErrorException Class

This exception is thrown if an internal failure occurs.

For a list of all members of this type, see InternalErrorException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.InternalErrorException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InternalErrorException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class InternalErrorException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class InternalErrorException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class InternalErrorException sealed : public TwainProException

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

InternalErrorException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InternalErrorException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InternalErrorException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : InternalErrorException Class

InternalErrorException overview

Public Constructors

Public Constructor InternalErrorException Constructor Overloaded. An exception generated for an internal error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InternalErrorException Class | PegasusImaging.WinForms.TwainPro5 Namespace


InternalErrorException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InternalErrorException Class | InternalErrorException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InternalErrorException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > InternalErrorException Class : InternalErrorException Constructor (InternalErrorException)

An exception generated for an internal error.

Overload List

An exception generated for an internal error.

[Visual Basic] Public Sub New()

[C#] public InternalErrorException();

[C++] public InternalErrorException();

[C++/CLI] public InternalErrorException();

Generated exception for an internal error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public InternalErrorException(int);

[C++] public InternalErrorException(int);

[C++/CLI] public InternalErrorException(int);

Generated exception for an internal error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public InternalErrorException(string);

[C++] public InternalErrorException(string*);

[C++/CLI] public InternalErrorException(String^);

Generated exception for an internal error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InternalErrorException(int,string);

[C++] public InternalErrorException(int,string*);

[C++/CLI] public InternalErrorException(int,String^);

Generated exception for an internal error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InternalErrorException(string,Exception);

[C++] public InternalErrorException(string*,Exception*);

[C++/CLI] public InternalErrorException(String^,Exception^);

Requirements

See Also

InternalErrorException Class | InternalErrorException Members


InternalErrorException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InternalErrorException Class | InternalErrorException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InternalErrorException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > InternalErrorException Class > InternalErrorException Constructor : InternalErrorException Constructor()

An exception generated for an internal error.

[Visual Basic]
Public Function New()
[C#]
public InternalErrorException();
[C++]
public: InternalErrorException();
[C++/CLI]
public:
InternalErrorException();

Requirements

See Also

InternalErrorException Class | InternalErrorException Members | Overload List


InternalErrorException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InternalErrorException Class | InternalErrorException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InternalErrorException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > InternalErrorException Class > InternalErrorException Constructor : InternalErrorException Constructor(Int32)

Generated exception for an internal error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InternalErrorException(
   int errorNumber
);
[C++]
public: InternalErrorException(
   int errorNumber
)
[C++/CLI]
public:
InternalErrorException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

InternalErrorException Class | InternalErrorException Members | Overload List


InternalErrorException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InternalErrorException Class | InternalErrorException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InternalErrorException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > InternalErrorException Class > InternalErrorException Constructor : InternalErrorException Constructor(Int32,String)

Generated exception for an internal error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InternalErrorException(
   int errorNumber,
   string message
);
[C++]
public: InternalErrorException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InternalErrorException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

InternalErrorException Class | InternalErrorException Members | Overload List


InternalErrorException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InternalErrorException Class | InternalErrorException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InternalErrorException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > InternalErrorException Class > InternalErrorException Constructor : InternalErrorException Constructor(String)

Generated exception for an internal error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InternalErrorException(
   string message
);
[C++]
public: InternalErrorException(
   string* message
)
[C++/CLI]
public:
InternalErrorException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

InternalErrorException Class | InternalErrorException Members | Overload List


InternalErrorException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InternalErrorException Class | InternalErrorException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InternalErrorException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > InternalErrorException Class > InternalErrorException Constructor : InternalErrorException Constructor(String,Exception)

Generated exception for an internal error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InternalErrorException(
   string message,
   Exception innerException
);
[C++]
public: InternalErrorException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InternalErrorException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

InternalErrorException Class | InternalErrorException Members | Overload List


InternetFilesNotInstalledException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InternetFilesNotInstalledException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InternetFilesNotInstalledException Class

PegasusImaging.WinForms.TwainPro5 Namespace : InternetFilesNotInstalledException Class

This exception is thrown if the required Internet DLL file(s) are missing.

For a list of all members of this type, see InternetFilesNotInstalledException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.InternetFilesNotInstalledException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InternetFilesNotInstalledException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class InternetFilesNotInstalledException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class InternetFilesNotInstalledException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class InternetFilesNotInstalledException sealed : public TwainProException

Remarks

Possible causes:

The following files are not present on the system. These files are not shipped with TwainPRO and are not needed unless an FTP address is specified in the Save method. These files are included with other software such as Internet Explorer, and if the machine has a TCP/IP connection, it should have these files.

wininet.dll

urlmon.dll

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

InternetFilesNotInstalledException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InternetFilesNotInstalledException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InternetFilesNotInstalledException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : InternetFilesNotInstalledException Class

InternetFilesNotInstalledException overview

Public Constructors

Public Constructor InternetFilesNotInstalledException Constructor Overloaded. An exception generated for an Internet files not installed error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InternetFilesNotInstalledException Class | PegasusImaging.WinForms.TwainPro5 Namespace


InternetFilesNotInstalledException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InternetFilesNotInstalledException Class | InternetFilesNotInstalledException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InternetFilesNotInstalledException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > InternetFilesNotInstalledException Class : InternetFilesNotInstalledException Constructor (InternetFilesNotInstalledException)

An exception generated for an Internet files not installed error.

Overload List

An exception generated for an Internet files not installed error.

[Visual Basic] Public Sub New()

[C#] public InternetFilesNotInstalledException();

[C++] public InternetFilesNotInstalledException();

[C++/CLI] public InternetFilesNotInstalledException();

Generated exception for an Internet files not installed error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public InternetFilesNotInstalledException(int);

[C++] public InternetFilesNotInstalledException(int);

[C++/CLI] public InternetFilesNotInstalledException(int);

Generated exception for an Internet files not installed error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public InternetFilesNotInstalledException(string);

[C++] public InternetFilesNotInstalledException(string*);

[C++/CLI] public InternetFilesNotInstalledException(String^);

Generated exception for an Internet files not installed error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InternetFilesNotInstalledException(int,string);

[C++] public InternetFilesNotInstalledException(int,string*);

[C++/CLI] public InternetFilesNotInstalledException(int,String^);

Generated exception for an Internet files not installed error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InternetFilesNotInstalledException(string,Exception);

[C++] public InternetFilesNotInstalledException(string*,Exception*);

[C++/CLI] public InternetFilesNotInstalledException(String^,Exception^);

Requirements

See Also

InternetFilesNotInstalledException Class | InternetFilesNotInstalledException Members


InternetFilesNotInstalledException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InternetFilesNotInstalledException Class | InternetFilesNotInstalledException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InternetFilesNotInstalledException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > InternetFilesNotInstalledException Class > InternetFilesNotInstalledException Constructor : InternetFilesNotInstalledException Constructor()

An exception generated for an Internet files not installed error.

[Visual Basic]
Public Function New()
[C#]
public InternetFilesNotInstalledException();
[C++]
public: InternetFilesNotInstalledException();
[C++/CLI]
public:
InternetFilesNotInstalledException();

Requirements

See Also

InternetFilesNotInstalledException Class | InternetFilesNotInstalledException Members | Overload List


InternetFilesNotInstalledException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InternetFilesNotInstalledException Class | InternetFilesNotInstalledException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InternetFilesNotInstalledException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > InternetFilesNotInstalledException Class > InternetFilesNotInstalledException Constructor : InternetFilesNotInstalledException Constructor(Int32)

Generated exception for an Internet files not installed error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InternetFilesNotInstalledException(
   int errorNumber
);
[C++]
public: InternetFilesNotInstalledException(
   int errorNumber
)
[C++/CLI]
public:
InternetFilesNotInstalledException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

InternetFilesNotInstalledException Class | InternetFilesNotInstalledException Members | Overload List


InternetFilesNotInstalledException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InternetFilesNotInstalledException Class | InternetFilesNotInstalledException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InternetFilesNotInstalledException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > InternetFilesNotInstalledException Class > InternetFilesNotInstalledException Constructor : InternetFilesNotInstalledException Constructor(Int32,String)

Generated exception for an Internet files not installed error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InternetFilesNotInstalledException(
   int errorNumber,
   string message
);
[C++]
public: InternetFilesNotInstalledException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InternetFilesNotInstalledException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

InternetFilesNotInstalledException Class | InternetFilesNotInstalledException Members | Overload List


InternetFilesNotInstalledException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InternetFilesNotInstalledException Class | InternetFilesNotInstalledException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InternetFilesNotInstalledException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > InternetFilesNotInstalledException Class > InternetFilesNotInstalledException Constructor : InternetFilesNotInstalledException Constructor(String)

Generated exception for an Internet files not installed error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InternetFilesNotInstalledException(
   string message
);
[C++]
public: InternetFilesNotInstalledException(
   string* message
)
[C++/CLI]
public:
InternetFilesNotInstalledException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

InternetFilesNotInstalledException Class | InternetFilesNotInstalledException Members | Overload List


InternetFilesNotInstalledException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InternetFilesNotInstalledException Class | InternetFilesNotInstalledException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InternetFilesNotInstalledException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > InternetFilesNotInstalledException Class > InternetFilesNotInstalledException Constructor : InternetFilesNotInstalledException Constructor(String,Exception)

Generated exception for an Internet files not installed error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InternetFilesNotInstalledException(
   string message,
   Exception innerException
);
[C++]
public: InternetFilesNotInstalledException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InternetFilesNotInstalledException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

InternetFilesNotInstalledException Class | InternetFilesNotInstalledException Members | Overload List


InvalidBitDepthException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidBitDepthException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidBitDepthException Class

PegasusImaging.WinForms.TwainPro5 Namespace : InvalidBitDepthException Class

This exception is thrown if an invalid image resolution for the selected file format or an unsupported bits per pixel was returned from a StartSession.

For a list of all members of this type, see InvalidBitDepthException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.InvalidBitDepthException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidBitDepthException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class InvalidBitDepthException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidBitDepthException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidBitDepthException sealed : public TwainProException

Remarks

Possible causes:

Tried to save a 1-bit or Black and White image to a jpg or pic file.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

InvalidBitDepthException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidBitDepthException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidBitDepthException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : InvalidBitDepthException Class

InvalidBitDepthException overview

Public Constructors

Public Constructor InvalidBitDepthException Constructor Overloaded. An exception generated for an invalid bit depth error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidBitDepthException Class | PegasusImaging.WinForms.TwainPro5 Namespace


InvalidBitDepthException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidBitDepthException Class | InvalidBitDepthException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidBitDepthException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > InvalidBitDepthException Class : InvalidBitDepthException Constructor (InvalidBitDepthException)

An exception generated for an invalid bit depth error.

Overload List

An exception generated for an invalid bit depth error.

[Visual Basic] Public Sub New()

[C#] public InvalidBitDepthException();

[C++] public InvalidBitDepthException();

[C++/CLI] public InvalidBitDepthException();

Generated exception for an invalid bit depth error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidBitDepthException(int);

[C++] public InvalidBitDepthException(int);

[C++/CLI] public InvalidBitDepthException(int);

Generated exception for an invalid bit depth error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public InvalidBitDepthException(string);

[C++] public InvalidBitDepthException(string*);

[C++/CLI] public InvalidBitDepthException(String^);

Generated exception for an invalid bit depth error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidBitDepthException(int,string);

[C++] public InvalidBitDepthException(int,string*);

[C++/CLI] public InvalidBitDepthException(int,String^);

Generated exception for an invalid bit depth error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidBitDepthException(string,Exception);

[C++] public InvalidBitDepthException(string*,Exception*);

[C++/CLI] public InvalidBitDepthException(String^,Exception^);

Requirements

See Also

InvalidBitDepthException Class | InvalidBitDepthException Members


InvalidBitDepthException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidBitDepthException Class | InvalidBitDepthException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidBitDepthException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > InvalidBitDepthException Class > InvalidBitDepthException Constructor : InvalidBitDepthException Constructor()

An exception generated for an invalid bit depth error.

[Visual Basic]
Public Function New()
[C#]
public InvalidBitDepthException();
[C++]
public: InvalidBitDepthException();
[C++/CLI]
public:
InvalidBitDepthException();

Requirements

See Also

InvalidBitDepthException Class | InvalidBitDepthException Members | Overload List


InvalidBitDepthException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidBitDepthException Class | InvalidBitDepthException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidBitDepthException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > InvalidBitDepthException Class > InvalidBitDepthException Constructor : InvalidBitDepthException Constructor(Int32)

Generated exception for an invalid bit depth error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidBitDepthException(
   int errorNumber
);
[C++]
public: InvalidBitDepthException(
   int errorNumber
)
[C++/CLI]
public:
InvalidBitDepthException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

InvalidBitDepthException Class | InvalidBitDepthException Members | Overload List


InvalidBitDepthException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidBitDepthException Class | InvalidBitDepthException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidBitDepthException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > InvalidBitDepthException Class > InvalidBitDepthException Constructor : InvalidBitDepthException Constructor(Int32,String)

Generated exception for an invalid bit depth error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidBitDepthException(
   int errorNumber,
   string message
);
[C++]
public: InvalidBitDepthException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidBitDepthException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

InvalidBitDepthException Class | InvalidBitDepthException Members | Overload List


InvalidBitDepthException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidBitDepthException Class | InvalidBitDepthException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidBitDepthException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > InvalidBitDepthException Class > InvalidBitDepthException Constructor : InvalidBitDepthException Constructor(String)

Generated exception for an invalid bit depth error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidBitDepthException(
   string message
);
[C++]
public: InvalidBitDepthException(
   string* message
)
[C++/CLI]
public:
InvalidBitDepthException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

InvalidBitDepthException Class | InvalidBitDepthException Members | Overload List


InvalidBitDepthException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidBitDepthException Class | InvalidBitDepthException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidBitDepthException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > InvalidBitDepthException Class > InvalidBitDepthException Constructor : InvalidBitDepthException Constructor(String,Exception)

Generated exception for an invalid bit depth error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidBitDepthException(
   string message,
   Exception innerException
);
[C++]
public: InvalidBitDepthException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidBitDepthException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

InvalidBitDepthException Class | InvalidBitDepthException Members | Overload List


InvalidLicenseException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidLicenseException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidLicenseException Class

PegasusImaging.WinForms.TwainPro5 Namespace : InvalidLicenseException Class

This exception is thrown if a user attempts to access functionality that is not covered under the license in effect.

For a list of all members of this type, see InvalidLicenseException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.InvalidLicenseException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidLicenseException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class InvalidLicenseException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidLicenseException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidLicenseException sealed : public TwainProException

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

InvalidLicenseException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidLicenseException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidLicenseException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : InvalidLicenseException Class

InvalidLicenseException overview

Public Constructors

Public Constructor InvalidLicenseException Constructor Overloaded. An exception generated for an invalid license error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidLicenseException Class | PegasusImaging.WinForms.TwainPro5 Namespace


InvalidLicenseException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidLicenseException Class | InvalidLicenseException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidLicenseException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > InvalidLicenseException Class : InvalidLicenseException Constructor (InvalidLicenseException)

An exception generated for an invalid license error.

Overload List

An exception generated for an invalid license error.

[Visual Basic] Public Sub New()

[C#] public InvalidLicenseException();

[C++] public InvalidLicenseException();

[C++/CLI] public InvalidLicenseException();

Generated exception for an invalid license error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidLicenseException(int);

[C++] public InvalidLicenseException(int);

[C++/CLI] public InvalidLicenseException(int);

Generated exception for an invalid license error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public InvalidLicenseException(string);

[C++] public InvalidLicenseException(string*);

[C++/CLI] public InvalidLicenseException(String^);

Generated exception for an invalid license error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidLicenseException(int,string);

[C++] public InvalidLicenseException(int,string*);

[C++/CLI] public InvalidLicenseException(int,String^);

Generated exception for an invalid license error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidLicenseException(string,Exception);

[C++] public InvalidLicenseException(string*,Exception*);

[C++/CLI] public InvalidLicenseException(String^,Exception^);

Requirements

See Also

InvalidLicenseException Class | InvalidLicenseException Members


InvalidLicenseException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidLicenseException Class | InvalidLicenseException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidLicenseException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor()

An exception generated for an invalid license error.

[Visual Basic]
Public Function New()
[C#]
public InvalidLicenseException();
[C++]
public: InvalidLicenseException();
[C++/CLI]
public:
InvalidLicenseException();

Requirements

See Also

InvalidLicenseException Class | InvalidLicenseException Members | Overload List


InvalidLicenseException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidLicenseException Class | InvalidLicenseException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidLicenseException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor(Int32)

Generated exception for an invalid license error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidLicenseException(
   int errorNumber
);
[C++]
public: InvalidLicenseException(
   int errorNumber
)
[C++/CLI]
public:
InvalidLicenseException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

InvalidLicenseException Class | InvalidLicenseException Members | Overload List


InvalidLicenseException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidLicenseException Class | InvalidLicenseException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidLicenseException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor(Int32,String)

Generated exception for an invalid license error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidLicenseException(
   int errorNumber,
   string message
);
[C++]
public: InvalidLicenseException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidLicenseException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

InvalidLicenseException Class | InvalidLicenseException Members | Overload List


InvalidLicenseException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidLicenseException Class | InvalidLicenseException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidLicenseException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor(String)

Generated exception for an invalid license error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidLicenseException(
   string message
);
[C++]
public: InvalidLicenseException(
   string* message
)
[C++/CLI]
public:
InvalidLicenseException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

InvalidLicenseException Class | InvalidLicenseException Members | Overload List


InvalidLicenseException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidLicenseException Class | InvalidLicenseException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidLicenseException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor(String,Exception)

Generated exception for an invalid license error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidLicenseException(
   string message,
   Exception innerException
);
[C++]
public: InvalidLicenseException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidLicenseException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

InvalidLicenseException Class | InvalidLicenseException Members | Overload List


InvalidPropertyException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidPropertyException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidPropertyException Class

PegasusImaging.WinForms.TwainPro5 Namespace : InvalidPropertyException Class

This exception is thrown if a property was set or queried that was not valid for the current capability type.

For a list of all members of this type, see InvalidPropertyException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.InvalidPropertyException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidPropertyException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class InvalidPropertyException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidPropertyException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidPropertyException sealed : public TwainProException

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

InvalidPropertyException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidPropertyException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidPropertyException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : InvalidPropertyException Class

InvalidPropertyException overview

Public Constructors

Public Constructor InvalidPropertyException Constructor Overloaded. An exception generated for an invalid property error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidPropertyException Class | PegasusImaging.WinForms.TwainPro5 Namespace


InvalidPropertyException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidPropertyException Class | InvalidPropertyException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidPropertyException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > InvalidPropertyException Class : InvalidPropertyException Constructor (InvalidPropertyException)

An exception generated for an invalid property error.

Overload List

An exception generated for an invalid property error.

[Visual Basic] Public Sub New()

[C#] public InvalidPropertyException();

[C++] public InvalidPropertyException();

[C++/CLI] public InvalidPropertyException();

Generated exception for an invalid property error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidPropertyException(int);

[C++] public InvalidPropertyException(int);

[C++/CLI] public InvalidPropertyException(int);

Generated exception for an invalid property error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public InvalidPropertyException(string);

[C++] public InvalidPropertyException(string*);

[C++/CLI] public InvalidPropertyException(String^);

Generated exception for an invalid property error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidPropertyException(int,string);

[C++] public InvalidPropertyException(int,string*);

[C++/CLI] public InvalidPropertyException(int,String^);

Generated exception for an invalid property error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidPropertyException(string,Exception);

[C++] public InvalidPropertyException(string*,Exception*);

[C++/CLI] public InvalidPropertyException(String^,Exception^);

Requirements

See Also

InvalidPropertyException Class | InvalidPropertyException Members


InvalidPropertyException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidPropertyException Class | InvalidPropertyException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidPropertyException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > InvalidPropertyException Class > InvalidPropertyException Constructor : InvalidPropertyException Constructor()

An exception generated for an invalid property error.

[Visual Basic]
Public Function New()
[C#]
public InvalidPropertyException();
[C++]
public: InvalidPropertyException();
[C++/CLI]
public:
InvalidPropertyException();

Requirements

See Also

InvalidPropertyException Class | InvalidPropertyException Members | Overload List


InvalidPropertyException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidPropertyException Class | InvalidPropertyException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidPropertyException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > InvalidPropertyException Class > InvalidPropertyException Constructor : InvalidPropertyException Constructor(Int32)

Generated exception for an invalid property error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidPropertyException(
   int errorNumber
);
[C++]
public: InvalidPropertyException(
   int errorNumber
)
[C++/CLI]
public:
InvalidPropertyException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

InvalidPropertyException Class | InvalidPropertyException Members | Overload List


InvalidPropertyException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidPropertyException Class | InvalidPropertyException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidPropertyException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > InvalidPropertyException Class > InvalidPropertyException Constructor : InvalidPropertyException Constructor(Int32,String)

Generated exception for an invalid property error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidPropertyException(
   int errorNumber,
   string message
);
[C++]
public: InvalidPropertyException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidPropertyException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

InvalidPropertyException Class | InvalidPropertyException Members | Overload List


InvalidPropertyException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidPropertyException Class | InvalidPropertyException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidPropertyException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > InvalidPropertyException Class > InvalidPropertyException Constructor : InvalidPropertyException Constructor(String)

Generated exception for an invalid property error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidPropertyException(
   string message
);
[C++]
public: InvalidPropertyException(
   string* message
)
[C++/CLI]
public:
InvalidPropertyException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

InvalidPropertyException Class | InvalidPropertyException Members | Overload List


InvalidPropertyException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidPropertyException Class | InvalidPropertyException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidPropertyException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > InvalidPropertyException Class > InvalidPropertyException Constructor : InvalidPropertyException Constructor(String,Exception)

Generated exception for an invalid property error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidPropertyException(
   string message,
   Exception innerException
);
[C++]
public: InvalidPropertyException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidPropertyException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

InvalidPropertyException Class | InvalidPropertyException Members | Overload List


Licensing Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

Licensing Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Licensing Class

PegasusImaging.WinForms.TwainPro5 Namespace : Licensing Class (PegasusImaging.WinForms.TwainPro5)

This class implements methods for setting the license information for the toolkit.

For a list of all members of this type, see Licensing members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.TwainPro5.Licensing

Syntax

[Visual Basic]
Public Class Licensing
[C#]
public class Licensing
[C++]
public __gc class Licensing
[C++/CLI]
public ref class Licensing

Remarks

This object exposes the licensing methods you need to call to license the toolkit.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

Licensing Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

Licensing Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Licensing Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : Licensing Class (PegasusImaging.WinForms.TwainPro5)

Licensing overview

Public Constructors

Public Constructor Licensing Constructor The initial constructor for the licensing class passing in a workspace ID.

Public Properties

Public Property EvaluationMode Gets and sets the way in which this component is limited in evaluation mode.

Public Methods

Public Method Dispose | Disposes of unmanaged resources.
Public Method UnlockRuntime | Enables run-time licensing.
Public Method UnlockWeb | Enable web licensing when deploying to a web application.

See Also

Licensing Class | PegasusImaging.WinForms.TwainPro5 Namespace


Licensing Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

Licensing Class | Licensing Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

pWorkId
A TwainPRO workspace ID.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Licensing Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > Licensing Class : Licensing Constructor (Licensing)

The initial constructor for the licensing class passing in a workspace ID.

[Visual Basic]
Public Function New( _
   ByVal pWorkId As IntPtr _
)
[C#]
public Licensing(
   IntPtr pWorkId
);
[C++]
public: Licensing(
   IntPtr pWorkId
)
[C++/CLI]
public:
Licensing(
   IntPtr pWorkId
)

Parameters

pWorkId
A TwainPRO workspace ID.

Requirements

See Also

Licensing Class | Licensing Members


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

Licensing Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Licensing Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : Licensing Class (PegasusImaging.WinForms.TwainPro5)

For a list of all members of this type, see Licensing members.

Public Methods

Public Method Dispose | Disposes of unmanaged resources.
Public Method UnlockRuntime | Enables run-time licensing.
Public Method UnlockWeb | Enable web licensing when deploying to a web application.

See Also

Licensing Class | PegasusImaging.WinForms.TwainPro5 Namespace


Dispose Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

Licensing Class | Licensing Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.TwainPro5 Namespace > Licensing Class : Dispose Method (Licensing)

Disposes of unmanaged resources.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

Remarks

This method is part of the IDisposable interface.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

Licensing Class | Licensing Members


UnlockRuntime Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

Licensing Class | Licensing Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

code1
A string which represents a unique licensing code, provided by Pegasus Imaging when runtime licenses are purchased.
code2
string which represents a unique licensing code, provided by Pegasus Imaging when runtime licenses are purchased.
code3
string which represents a unique licensing code, provided by Pegasus Imaging when runtime licenses are purchased.
code4
string which represents a unique licensing code, provided by Pegasus Imaging when runtime licenses are purchased.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

UnlockRuntime Method

PegasusImaging.WinForms.TwainPro5 Namespace > Licensing Class : UnlockRuntime Method

Enables run-time licensing.

[Visual Basic]
Public Sub UnlockRuntime( _
   ByVal code1 As Integer, _
   ByVal code2 As Integer, _
   ByVal code3 As Integer, _
   ByVal code4 As Integer _
)
[C#]
public void UnlockRuntime(
   int code1,
   int code2,
   int code3,
   int code4
);
[C++]
public: void UnlockRuntime(
   int code1,
   int code2,
   int code3,
   int code4
)
[C++/CLI]
public:
void UnlockRuntime(
   int code1,
   int code2,
   int code3,
   int code4
)

Parameters

code1
A string which represents a unique licensing code, provided by Pegasus Imaging when runtime licenses are purchased.
code2
string which represents a unique licensing code, provided by Pegasus Imaging when runtime licenses are purchased.
code3
string which represents a unique licensing code, provided by Pegasus Imaging when runtime licenses are purchased.
code4
string which represents a unique licensing code, provided by Pegasus Imaging when runtime licenses are purchased.

Remarks

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

Licensing Class | Licensing Members


UnlockWeb Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

Licensing Class | Licensing Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

code
A string which represents a unique licensing string, provided by Pegasus Imaging when web licensing is purchased.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

UnlockWeb Method

PegasusImaging.WinForms.TwainPro5 Namespace > Licensing Class : UnlockWeb Method

Enable web licensing when deploying to a web application.

[Visual Basic]
Public Sub UnlockWeb( _
   ByVal code As String _
)
[C#]
public void UnlockWeb(
   string code
);
[C++]
public: void UnlockWeb(
   string* code
)
[C++/CLI]
public:
void UnlockWeb(
   String^ code
)

Parameters

code
A string which represents a unique licensing string, provided by Pegasus Imaging when web licensing is purchased.

Remarks

Call this method when the application begins to enable runtime use of the control in a web application.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

Licensing Class | Licensing Members


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

Licensing Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Licensing Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : Licensing Class (PegasusImaging.WinForms.TwainPro5)

For a list of all members of this type, see Licensing members.

Public Properties

Public Property EvaluationMode Gets and sets the way in which this component is limited in evaluation mode.

See Also

Licensing Class | PegasusImaging.WinForms.TwainPro5 Namespace


EvaluationMode Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

Licensing Class | Licensing Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

EvaluationMode Property

PegasusImaging.WinForms.TwainPro5 Namespace > Licensing Class : EvaluationMode Property (Licensing)

Gets and sets the way in which this component is limited in evaluation mode.

[Visual Basic]
<DescriptionAttribute("Indicates the way in which this component is limited in evaluation mode.")>
<DefaultValueAttribute()>
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property EvaluationMode As EvaluationMode
[C#]
[DescriptionAttribute("Indicates the way in which this component is limited in evaluation mode.")]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public EvaluationMode EvaluationMode {get; set;}
[C++]
[DescriptionAttribute("Indicates the way in which this component is limited in evaluation mode.")]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property EvaluationMode get_EvaluationMode();
public: __property void set_EvaluationMode(
   EvaluationMode value
);
[C++/CLI]
[DescriptionAttribute("Indicates the way in which this component is limited in evaluation mode.")]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property EvaluationMode EvaluationMode {
   EvaluationMode get();
   void set (EvaluationMode value);
}

Value

An EvaluationMode enumeration value which determines the evaluation mode for the component.

Remarks

The default value: is Automatic.

Requirements

See Also

Licensing Class | Licensing Members


LoadSettingsException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

LoadSettingsException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

LoadSettingsException Class

PegasusImaging.WinForms.TwainPro5 Namespace : LoadSettingsException Class

This exception is thrown if an error occurs when loading a settings file.

For a list of all members of this type, see LoadSettingsException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.LoadSettingsException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class LoadSettingsException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class LoadSettingsException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class LoadSettingsException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class LoadSettingsException sealed : public TwainProException

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

LoadSettingsException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

LoadSettingsException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

LoadSettingsException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : LoadSettingsException Class

LoadSettingsException overview

Public Constructors

Public Constructor LoadSettingsException Constructor Overloaded. An exception generated for a load settings error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

LoadSettingsException Class | PegasusImaging.WinForms.TwainPro5 Namespace


LoadSettingsException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

LoadSettingsException Class | LoadSettingsException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

LoadSettingsException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > LoadSettingsException Class : LoadSettingsException Constructor (LoadSettingsException)

An exception generated for a load settings error.

Overload List

An exception generated for a load settings error.

[Visual Basic] Public Sub New()

[C#] public LoadSettingsException();

[C++] public LoadSettingsException();

[C++/CLI] public LoadSettingsException();

Generated exception for a load settings error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public LoadSettingsException(int);

[C++] public LoadSettingsException(int);

[C++/CLI] public LoadSettingsException(int);

Generated exception for a load settings error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public LoadSettingsException(string);

[C++] public LoadSettingsException(string*);

[C++/CLI] public LoadSettingsException(String^);

Generated exception for a load settings error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public LoadSettingsException(int,string);

[C++] public LoadSettingsException(int,string*);

[C++/CLI] public LoadSettingsException(int,String^);

Generated exception for a load settings error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public LoadSettingsException(string,Exception);

[C++] public LoadSettingsException(string*,Exception*);

[C++/CLI] public LoadSettingsException(String^,Exception^);

Requirements

See Also

LoadSettingsException Class | LoadSettingsException Members


LoadSettingsException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

LoadSettingsException Class | LoadSettingsException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

LoadSettingsException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > LoadSettingsException Class > LoadSettingsException Constructor : LoadSettingsException Constructor()

An exception generated for a load settings error.

[Visual Basic]
Public Function New()
[C#]
public LoadSettingsException();
[C++]
public: LoadSettingsException();
[C++/CLI]
public:
LoadSettingsException();

Requirements

See Also

LoadSettingsException Class | LoadSettingsException Members | Overload List


LoadSettingsException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

LoadSettingsException Class | LoadSettingsException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

LoadSettingsException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > LoadSettingsException Class > LoadSettingsException Constructor : LoadSettingsException Constructor(Int32)

Generated exception for a load settings error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public LoadSettingsException(
   int errorNumber
);
[C++]
public: LoadSettingsException(
   int errorNumber
)
[C++/CLI]
public:
LoadSettingsException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

LoadSettingsException Class | LoadSettingsException Members | Overload List


LoadSettingsException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

LoadSettingsException Class | LoadSettingsException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

LoadSettingsException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > LoadSettingsException Class > LoadSettingsException Constructor : LoadSettingsException Constructor(Int32,String)

Generated exception for a load settings error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public LoadSettingsException(
   int errorNumber,
   string message
);
[C++]
public: LoadSettingsException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
LoadSettingsException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

LoadSettingsException Class | LoadSettingsException Members | Overload List


LoadSettingsException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

LoadSettingsException Class | LoadSettingsException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

LoadSettingsException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > LoadSettingsException Class > LoadSettingsException Constructor : LoadSettingsException Constructor(String)

Generated exception for a load settings error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public LoadSettingsException(
   string message
);
[C++]
public: LoadSettingsException(
   string* message
)
[C++/CLI]
public:
LoadSettingsException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

LoadSettingsException Class | LoadSettingsException Members | Overload List


LoadSettingsException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

LoadSettingsException Class | LoadSettingsException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

LoadSettingsException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > LoadSettingsException Class > LoadSettingsException Constructor : LoadSettingsException Constructor(String,Exception)

Generated exception for a load settings error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public LoadSettingsException(
   string message,
   Exception innerException
);
[C++]
public: LoadSettingsException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
LoadSettingsException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

LoadSettingsException Class | LoadSettingsException Members | Overload List


OperationCancelledException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

OperationCancelledException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

OperationCancelledException Class

PegasusImaging.WinForms.TwainPro5 Namespace : OperationCancelledException Class

This exception is thrown if the user cancelled the requested operation.

For a list of all members of this type, see OperationCancelledException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.OperationCancelledException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class OperationCancelledException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class OperationCancelledException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class OperationCancelledException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class OperationCancelledException sealed : public TwainProException

Remarks

Possible causes:

The user clicked the cancel button on the source selection dialog invoked by the SelectSource method.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

OperationCancelledException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

OperationCancelledException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

OperationCancelledException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : OperationCancelledException Class

OperationCancelledException overview

Public Constructors

Public Constructor OperationCancelledException Constructor Overloaded. An exception generated for an operation cancelled error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

OperationCancelledException Class | PegasusImaging.WinForms.TwainPro5 Namespace


OperationCancelledException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

OperationCancelledException Class | OperationCancelledException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

OperationCancelledException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > OperationCancelledException Class : OperationCancelledException Constructor (OperationCancelledException)

An exception generated for an operation cancelled error.

Overload List

An exception generated for an operation cancelled error.

[Visual Basic] Public Sub New()

[C#] public OperationCancelledException();

[C++] public OperationCancelledException();

[C++/CLI] public OperationCancelledException();

Generated exception for an operation cancelled error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public OperationCancelledException(int);

[C++] public OperationCancelledException(int);

[C++/CLI] public OperationCancelledException(int);

Generated exception for an operation cancelled error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public OperationCancelledException(string);

[C++] public OperationCancelledException(string*);

[C++/CLI] public OperationCancelledException(String^);

Generated exception for an operation cancelled error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public OperationCancelledException(int,string);

[C++] public OperationCancelledException(int,string*);

[C++/CLI] public OperationCancelledException(int,String^);

Generated exception for an operation cancelled error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public OperationCancelledException(string,Exception);

[C++] public OperationCancelledException(string*,Exception*);

[C++/CLI] public OperationCancelledException(String^,Exception^);

Requirements

See Also

OperationCancelledException Class | OperationCancelledException Members


OperationCancelledException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

OperationCancelledException Class | OperationCancelledException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

OperationCancelledException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > OperationCancelledException Class > OperationCancelledException Constructor : OperationCancelledException Constructor()

An exception generated for an operation cancelled error.

[Visual Basic]
Public Function New()
[C#]
public OperationCancelledException();
[C++]
public: OperationCancelledException();
[C++/CLI]
public:
OperationCancelledException();

Requirements

See Also

OperationCancelledException Class | OperationCancelledException Members | Overload List


OperationCancelledException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

OperationCancelledException Class | OperationCancelledException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

OperationCancelledException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > OperationCancelledException Class > OperationCancelledException Constructor : OperationCancelledException Constructor(Int32)

Generated exception for an operation cancelled error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public OperationCancelledException(
   int errorNumber
);
[C++]
public: OperationCancelledException(
   int errorNumber
)
[C++/CLI]
public:
OperationCancelledException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

OperationCancelledException Class | OperationCancelledException Members | Overload List


OperationCancelledException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

OperationCancelledException Class | OperationCancelledException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

OperationCancelledException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > OperationCancelledException Class > OperationCancelledException Constructor : OperationCancelledException Constructor(Int32,String)

Generated exception for an operation cancelled error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public OperationCancelledException(
   int errorNumber,
   string message
);
[C++]
public: OperationCancelledException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
OperationCancelledException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

OperationCancelledException Class | OperationCancelledException Members | Overload List


OperationCancelledException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

OperationCancelledException Class | OperationCancelledException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

OperationCancelledException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > OperationCancelledException Class > OperationCancelledException Constructor : OperationCancelledException Constructor(String)

Generated exception for an operation cancelled error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public OperationCancelledException(
   string message
);
[C++]
public: OperationCancelledException(
   string* message
)
[C++/CLI]
public:
OperationCancelledException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

OperationCancelledException Class | OperationCancelledException Members | Overload List


OperationCancelledException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

OperationCancelledException Class | OperationCancelledException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

OperationCancelledException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > OperationCancelledException Class > OperationCancelledException Constructor : OperationCancelledException Constructor(String,Exception)

Generated exception for an operation cancelled error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public OperationCancelledException(
   string message,
   Exception innerException
);
[C++]
public: OperationCancelledException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
OperationCancelledException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

OperationCancelledException Class | OperationCancelledException Members | Overload List


OutOfMemoryException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

OutOfMemoryException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

OutOfMemoryException Class

PegasusImaging.WinForms.TwainPro5 Namespace : OutOfMemoryException Class

This exception is thrown if TwainPRO is unable to allocate memory for the requested operation.

For a list of all members of this type, see OutOfMemoryException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.OutOfMemoryException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class OutOfMemoryException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class OutOfMemoryException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class OutOfMemoryException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class OutOfMemoryException sealed : public TwainProException

Remarks

Possible causes:

The image being transferred is too large to fit in memory.

Too many applications are open.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

OutOfMemoryException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

OutOfMemoryException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

OutOfMemoryException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : OutOfMemoryException Class

OutOfMemoryException overview

Public Constructors

Public Constructor OutOfMemoryException Constructor Overloaded. An exception generated for an out of memory error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

OutOfMemoryException Class | PegasusImaging.WinForms.TwainPro5 Namespace


OutOfMemoryException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

OutOfMemoryException Class | OutOfMemoryException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

OutOfMemoryException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > OutOfMemoryException Class : OutOfMemoryException Constructor (OutOfMemoryException)

An exception generated for an out of memory error.

Overload List

An exception generated for an out of memory error.

[Visual Basic] Public Sub New()

[C#] public OutOfMemoryException();

[C++] public OutOfMemoryException();

[C++/CLI] public OutOfMemoryException();

Generated exception for an out of memory error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public OutOfMemoryException(int);

[C++] public OutOfMemoryException(int);

[C++/CLI] public OutOfMemoryException(int);

Generated exception for an out of memory error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public OutOfMemoryException(string);

[C++] public OutOfMemoryException(string*);

[C++/CLI] public OutOfMemoryException(String^);

Generated exception for an out of memory error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public OutOfMemoryException(int,string);

[C++] public OutOfMemoryException(int,string*);

[C++/CLI] public OutOfMemoryException(int,String^);

Generated exception for an out of memory error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public OutOfMemoryException(string,Exception);

[C++] public OutOfMemoryException(string*,Exception*);

[C++/CLI] public OutOfMemoryException(String^,Exception^);

Requirements

See Also

OutOfMemoryException Class | OutOfMemoryException Members


OutOfMemoryException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

OutOfMemoryException Class | OutOfMemoryException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

OutOfMemoryException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor()

An exception generated for an out of memory error.

[Visual Basic]
Public Function New()
[C#]
public OutOfMemoryException();
[C++]
public: OutOfMemoryException();
[C++/CLI]
public:
OutOfMemoryException();

Requirements

See Also

OutOfMemoryException Class | OutOfMemoryException Members | Overload List


OutOfMemoryException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

OutOfMemoryException Class | OutOfMemoryException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

OutOfMemoryException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor(Int32)

Generated exception for an out of memory error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public OutOfMemoryException(
   int errorNumber
);
[C++]
public: OutOfMemoryException(
   int errorNumber
)
[C++/CLI]
public:
OutOfMemoryException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

OutOfMemoryException Class | OutOfMemoryException Members | Overload List


OutOfMemoryException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

OutOfMemoryException Class | OutOfMemoryException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

OutOfMemoryException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor(Int32,String)

Generated exception for an out of memory error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public OutOfMemoryException(
   int errorNumber,
   string message
);
[C++]
public: OutOfMemoryException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
OutOfMemoryException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

OutOfMemoryException Class | OutOfMemoryException Members | Overload List


OutOfMemoryException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

OutOfMemoryException Class | OutOfMemoryException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

OutOfMemoryException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor(String)

Generated exception for an out of memory error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public OutOfMemoryException(
   string message
);
[C++]
public: OutOfMemoryException(
   string* message
)
[C++/CLI]
public:
OutOfMemoryException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

OutOfMemoryException Class | OutOfMemoryException Members | Overload List


OutOfMemoryException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

OutOfMemoryException Class | OutOfMemoryException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

OutOfMemoryException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor(String,Exception)

Generated exception for an out of memory error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public OutOfMemoryException(
   string message,
   Exception innerException
);
[C++]
public: OutOfMemoryException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
OutOfMemoryException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

OutOfMemoryException Class | OutOfMemoryException Members | Overload List


PegasusFilesNotInstalledException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusFilesNotInstalledException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PegasusFilesNotInstalledException Class

PegasusImaging.WinForms.TwainPro5 Namespace : PegasusFilesNotInstalledException Class

This exception is thrown if the required Pegasus DLL file(s) are missing.

For a list of all members of this type, see PegasusFilesNotInstalledException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.PegasusFilesNotInstalledException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class PegasusFilesNotInstalledException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class PegasusFilesNotInstalledException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class PegasusFilesNotInstalledException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class PegasusFilesNotInstalledException sealed : public TwainProException

Remarks

Possible causes:

Pegasus DLL files are required when saving JPEG, ePIC, TIF, or PDF files. They are listed in the dependencies section.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

PegasusFilesNotInstalledException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusFilesNotInstalledException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PegasusFilesNotInstalledException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : PegasusFilesNotInstalledException Class

PegasusFilesNotInstalledException overview

Public Constructors

Public Constructor PegasusFilesNotInstalledException Constructor Overloaded. An exception generated for a Pegasus files not installed error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

PegasusFilesNotInstalledException Class | PegasusImaging.WinForms.TwainPro5 Namespace


PegasusFilesNotInstalledException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusFilesNotInstalledException Class | PegasusFilesNotInstalledException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PegasusFilesNotInstalledException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > PegasusFilesNotInstalledException Class : PegasusFilesNotInstalledException Constructor (PegasusFilesNotInstalledException)

An exception generated for a Pegasus files not installed error.

Overload List

An exception generated for a Pegasus files not installed error.

[Visual Basic] Public Sub New()

[C#] public PegasusFilesNotInstalledException();

[C++] public PegasusFilesNotInstalledException();

[C++/CLI] public PegasusFilesNotInstalledException();

Generated exception for a Pegasus files not installed error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public PegasusFilesNotInstalledException(int);

[C++] public PegasusFilesNotInstalledException(int);

[C++/CLI] public PegasusFilesNotInstalledException(int);

Generated exception for a Pegasus files not installed error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public PegasusFilesNotInstalledException(string);

[C++] public PegasusFilesNotInstalledException(string*);

[C++/CLI] public PegasusFilesNotInstalledException(String^);

Generated exception for a Pegasus files not installed error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public PegasusFilesNotInstalledException(int,string);

[C++] public PegasusFilesNotInstalledException(int,string*);

[C++/CLI] public PegasusFilesNotInstalledException(int,String^);

Generated exception for a Pegasus files not installed error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public PegasusFilesNotInstalledException(string,Exception);

[C++] public PegasusFilesNotInstalledException(string*,Exception*);

[C++/CLI] public PegasusFilesNotInstalledException(String^,Exception^);

Requirements

See Also

PegasusFilesNotInstalledException Class | PegasusFilesNotInstalledException Members


PegasusFilesNotInstalledException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusFilesNotInstalledException Class | PegasusFilesNotInstalledException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PegasusFilesNotInstalledException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > PegasusFilesNotInstalledException Class > PegasusFilesNotInstalledException Constructor : PegasusFilesNotInstalledException Constructor()

An exception generated for a Pegasus files not installed error.

[Visual Basic]
Public Function New()
[C#]
public PegasusFilesNotInstalledException();
[C++]
public: PegasusFilesNotInstalledException();
[C++/CLI]
public:
PegasusFilesNotInstalledException();

Requirements

See Also

PegasusFilesNotInstalledException Class | PegasusFilesNotInstalledException Members | Overload List


PegasusFilesNotInstalledException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusFilesNotInstalledException Class | PegasusFilesNotInstalledException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PegasusFilesNotInstalledException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > PegasusFilesNotInstalledException Class > PegasusFilesNotInstalledException Constructor : PegasusFilesNotInstalledException Constructor(Int32)

Generated exception for a Pegasus files not installed error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public PegasusFilesNotInstalledException(
   int errorNumber
);
[C++]
public: PegasusFilesNotInstalledException(
   int errorNumber
)
[C++/CLI]
public:
PegasusFilesNotInstalledException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

PegasusFilesNotInstalledException Class | PegasusFilesNotInstalledException Members | Overload List


PegasusFilesNotInstalledException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusFilesNotInstalledException Class | PegasusFilesNotInstalledException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PegasusFilesNotInstalledException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > PegasusFilesNotInstalledException Class > PegasusFilesNotInstalledException Constructor : PegasusFilesNotInstalledException Constructor(Int32,String)

Generated exception for a Pegasus files not installed error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public PegasusFilesNotInstalledException(
   int errorNumber,
   string message
);
[C++]
public: PegasusFilesNotInstalledException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
PegasusFilesNotInstalledException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

PegasusFilesNotInstalledException Class | PegasusFilesNotInstalledException Members | Overload List


PegasusFilesNotInstalledException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusFilesNotInstalledException Class | PegasusFilesNotInstalledException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PegasusFilesNotInstalledException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > PegasusFilesNotInstalledException Class > PegasusFilesNotInstalledException Constructor : PegasusFilesNotInstalledException Constructor(String)

Generated exception for a Pegasus files not installed error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public PegasusFilesNotInstalledException(
   string message
);
[C++]
public: PegasusFilesNotInstalledException(
   string* message
)
[C++/CLI]
public:
PegasusFilesNotInstalledException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

PegasusFilesNotInstalledException Class | PegasusFilesNotInstalledException Members | Overload List


PegasusFilesNotInstalledException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusFilesNotInstalledException Class | PegasusFilesNotInstalledException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PegasusFilesNotInstalledException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > PegasusFilesNotInstalledException Class > PegasusFilesNotInstalledException Constructor : PegasusFilesNotInstalledException Constructor(String,Exception)

Generated exception for a Pegasus files not installed error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public PegasusFilesNotInstalledException(
   string message,
   Exception innerException
);
[C++]
public: PegasusFilesNotInstalledException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
PegasusFilesNotInstalledException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

PegasusFilesNotInstalledException Class | PegasusFilesNotInstalledException Members | Overload List


PropertyOrMethodNotAvailableException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PropertyOrMethodNotAvailableException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PropertyOrMethodNotAvailableException Class

PegasusImaging.WinForms.TwainPro5 Namespace : PropertyOrMethodNotAvailableException Class

This exception is thrown if the property or method requested is not currently available.

For a list of all members of this type, see PropertyOrMethodNotAvailableException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.PropertyOrMethodNotAvailableException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class PropertyOrMethodNotAvailableException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class PropertyOrMethodNotAvailableException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class PropertyOrMethodNotAvailableException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class PropertyOrMethodNotAvailableException sealed : public TwainProException

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

PropertyOrMethodNotAvailableException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PropertyOrMethodNotAvailableException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PropertyOrMethodNotAvailableException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : PropertyOrMethodNotAvailableException Class

PropertyOrMethodNotAvailableException overview

Public Constructors

Public Constructor PropertyOrMethodNotAvailableException Constructor Overloaded. An exception generated for a property or method not available error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

PropertyOrMethodNotAvailableException Class | PegasusImaging.WinForms.TwainPro5 Namespace


PropertyOrMethodNotAvailableException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PropertyOrMethodNotAvailableException Class | PropertyOrMethodNotAvailableException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PropertyOrMethodNotAvailableException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > PropertyOrMethodNotAvailableException Class : PropertyOrMethodNotAvailableException Constructor (PropertyOrMethodNotAvailableException)

An exception generated for a property or method not available error.

Overload List

An exception generated for a property or method not available error.

[Visual Basic] Public Sub New()

[C#] public PropertyOrMethodNotAvailableException();

[C++] public PropertyOrMethodNotAvailableException();

[C++/CLI] public PropertyOrMethodNotAvailableException();

Generated exception for a property or method not available error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public PropertyOrMethodNotAvailableException(int);

[C++] public PropertyOrMethodNotAvailableException(int);

[C++/CLI] public PropertyOrMethodNotAvailableException(int);

Generated exception for a property or method not available error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public PropertyOrMethodNotAvailableException(string);

[C++] public PropertyOrMethodNotAvailableException(string*);

[C++/CLI] public PropertyOrMethodNotAvailableException(String^);

Generated exception for a property or method not available error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public PropertyOrMethodNotAvailableException(int,string);

[C++] public PropertyOrMethodNotAvailableException(int,string*);

[C++/CLI] public PropertyOrMethodNotAvailableException(int,String^);

Generated exception for a property or method not available error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public PropertyOrMethodNotAvailableException(string,Exception);

[C++] public PropertyOrMethodNotAvailableException(string*,Exception*);

[C++/CLI] public PropertyOrMethodNotAvailableException(String^,Exception^);

Requirements

See Also

PropertyOrMethodNotAvailableException Class | PropertyOrMethodNotAvailableException Members


PropertyOrMethodNotAvailableException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PropertyOrMethodNotAvailableException Class | PropertyOrMethodNotAvailableException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PropertyOrMethodNotAvailableException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > PropertyOrMethodNotAvailableException Class > PropertyOrMethodNotAvailableException Constructor : PropertyOrMethodNotAvailableException Constructor()

An exception generated for a property or method not available error.

[Visual Basic]
Public Function New()
[C#]
public PropertyOrMethodNotAvailableException();
[C++]
public: PropertyOrMethodNotAvailableException();
[C++/CLI]
public:
PropertyOrMethodNotAvailableException();

Requirements

See Also

PropertyOrMethodNotAvailableException Class | PropertyOrMethodNotAvailableException Members | Overload List


PropertyOrMethodNotAvailableException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PropertyOrMethodNotAvailableException Class | PropertyOrMethodNotAvailableException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PropertyOrMethodNotAvailableException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > PropertyOrMethodNotAvailableException Class > PropertyOrMethodNotAvailableException Constructor : PropertyOrMethodNotAvailableException Constructor(Int32)

Generated exception for a property or method not available error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public PropertyOrMethodNotAvailableException(
   int errorNumber
);
[C++]
public: PropertyOrMethodNotAvailableException(
   int errorNumber
)
[C++/CLI]
public:
PropertyOrMethodNotAvailableException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

PropertyOrMethodNotAvailableException Class | PropertyOrMethodNotAvailableException Members | Overload List


PropertyOrMethodNotAvailableException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PropertyOrMethodNotAvailableException Class | PropertyOrMethodNotAvailableException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PropertyOrMethodNotAvailableException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > PropertyOrMethodNotAvailableException Class > PropertyOrMethodNotAvailableException Constructor : PropertyOrMethodNotAvailableException Constructor(Int32,String)

Generated exception for a property or method not available error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public PropertyOrMethodNotAvailableException(
   int errorNumber,
   string message
);
[C++]
public: PropertyOrMethodNotAvailableException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
PropertyOrMethodNotAvailableException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

PropertyOrMethodNotAvailableException Class | PropertyOrMethodNotAvailableException Members | Overload List


PropertyOrMethodNotAvailableException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PropertyOrMethodNotAvailableException Class | PropertyOrMethodNotAvailableException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PropertyOrMethodNotAvailableException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > PropertyOrMethodNotAvailableException Class > PropertyOrMethodNotAvailableException Constructor : PropertyOrMethodNotAvailableException Constructor(String)

Generated exception for a property or method not available error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public PropertyOrMethodNotAvailableException(
   string message
);
[C++]
public: PropertyOrMethodNotAvailableException(
   string* message
)
[C++/CLI]
public:
PropertyOrMethodNotAvailableException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

PropertyOrMethodNotAvailableException Class | PropertyOrMethodNotAvailableException Members | Overload List


PropertyOrMethodNotAvailableException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PropertyOrMethodNotAvailableException Class | PropertyOrMethodNotAvailableException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PropertyOrMethodNotAvailableException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > PropertyOrMethodNotAvailableException Class > PropertyOrMethodNotAvailableException Constructor : PropertyOrMethodNotAvailableException Constructor(String,Exception)

Generated exception for a property or method not available error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public PropertyOrMethodNotAvailableException(
   string message,
   Exception innerException
);
[C++]
public: PropertyOrMethodNotAvailableException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
PropertyOrMethodNotAvailableException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

PropertyOrMethodNotAvailableException Class | PropertyOrMethodNotAvailableException Members | Overload List


SaveOptions Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptions Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SaveOptions Class

PegasusImaging.WinForms.TwainPro5 Namespace : SaveOptions Class

This class implements file writing of image formats.

For a list of all members of this type, see SaveOptions members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.TwainPro5.SaveOptions

Syntax

[Visual Basic]
Public Class SaveOptions
[C#]
public class SaveOptions
[C++]
public __gc class SaveOptions
[C++/CLI]
public ref class SaveOptions

Remarks

TwainPRO 5.0 saves to the following file formats: BMP, JPEG, ePIC, TIFF, and PDF.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

SaveOptions Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptions Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SaveOptions Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : SaveOptions Class

SaveOptions overview

Public Constructors

Public Constructor SaveOptions Constructor The main constructor for the SaveOptions class.

Public Properties

Public Property Format | Gets and sets the format of the saved file.
Public Property FtpOptions | Gets the FtpOptions settings.
Public Property Jpeg | Gets the SaveOptionsJpeg settings.
Public Property Pdf | Gets the SaveOptionsPdf settings.
Public Property Pic | Gets the SaveOptionsPic settings.
Public Property Tiff | Gets the SaveOptionsTiff settings.

See Also

SaveOptions Class | PegasusImaging.WinForms.TwainPro5 Namespace


SaveOptions Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptions Class | SaveOptions Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SaveOptions Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptions Class : SaveOptions Constructor (SaveOptions)

The main constructor for the SaveOptions class.

[Visual Basic]
Public Function New()
[C#]
public SaveOptions();
[C++]
public: SaveOptions();
[C++/CLI]
public:
SaveOptions();

Requirements

See Also

SaveOptions Class | SaveOptions Members


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptions Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SaveOptions Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : SaveOptions Class

For a list of all members of this type, see SaveOptions members.

Public Properties

Public Property Format | Gets and sets the format of the saved file.
Public Property FtpOptions | Gets the FtpOptions settings.
Public Property Jpeg | Gets the SaveOptionsJpeg settings.
Public Property Pdf | Gets the SaveOptionsPdf settings.
Public Property Pic | Gets the SaveOptionsPic settings.
Public Property Tiff | Gets the SaveOptionsTiff settings.

See Also

SaveOptions Class | PegasusImaging.WinForms.TwainPro5 Namespace


Format Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptions Class | SaveOptions Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Format Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptions Class : Format Property

Gets and sets the format of the saved file.

[Visual Basic]
<BrowsableAttribute(False)>
Public Property Format As ScannedImageFormat
[C#]
[BrowsableAttribute(false)]
public ScannedImageFormat Format {get; set;}
[C++]
[BrowsableAttribute(false)]
public: __property ScannedImageFormat get_Format();
public: __property void set_Format(
   ScannedImageFormat value
);
[C++/CLI]
[BrowsableAttribute(false)]
public:
property ScannedImageFormat Format {
   ScannedImageFormat get();
   void set (ScannedImageFormat value);
}

Value

A ScannedImageFormat to save the file in.

Remarks

The default value is ScannedImageFormat.Default.

Requirements

See Also

SaveOptions Class | SaveOptions Members


FtpOptions Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptions Class | SaveOptions Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FtpOptions Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptions Class : FtpOptions Property (SaveOptions)

Gets the FtpOptions settings.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property FtpOptions As FtpOptions
[C#]
[BrowsableAttribute(false)]
public FtpOptions FtpOptions {get;}
[C++]
[BrowsableAttribute(false)]
public: __property FtpOptions* get_FtpOptions();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property FtpOptions^ FtpOptions {
   FtpOptions^ get();
}

Value

A FtpOptions object value which contains the FtpOptions settings.

Remarks

The default value is null.

Requirements

See Also

SaveOptions Class | SaveOptions Members


Jpeg Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptions Class | SaveOptions Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Jpeg Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptions Class : Jpeg Property

Gets the SaveOptionsJpeg settings.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property Jpeg As SaveOptionsJpeg
[C#]
[BrowsableAttribute(false)]
public SaveOptionsJpeg Jpeg {get;}
[C++]
[BrowsableAttribute(false)]
public: __property SaveOptionsJpeg* get_Jpeg();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property SaveOptionsJpeg^ Jpeg {
   SaveOptionsJpeg^ get();
}

Value

A SaveOptionsJpeg object value which contains the SaveOptionsJpeg settings.

Remarks

The default value is null.

Requirements

See Also

SaveOptions Class | SaveOptions Members


Pdf Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptions Class | SaveOptions Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Pdf Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptions Class : Pdf Property

Gets the SaveOptionsPdf settings.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property Pdf As SaveOptionsPdf
[C#]
[BrowsableAttribute(false)]
public SaveOptionsPdf Pdf {get;}
[C++]
[BrowsableAttribute(false)]
public: __property SaveOptionsPdf* get_Pdf();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property SaveOptionsPdf^ Pdf {
   SaveOptionsPdf^ get();
}

Value

A SaveOptionsPdf object value which contains the SaveOptionsPdf settings.

Remarks

The default value is null.

Requirements

See Also

SaveOptions Class | SaveOptions Members


Pic Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptions Class | SaveOptions Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Pic Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptions Class : Pic Property

Gets the SaveOptionsPic settings.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property Pic As SaveOptionsPic
[C#]
[BrowsableAttribute(false)]
public SaveOptionsPic Pic {get;}
[C++]
[BrowsableAttribute(false)]
public: __property SaveOptionsPic* get_Pic();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property SaveOptionsPic^ Pic {
   SaveOptionsPic^ get();
}

Value

A SaveOptionsPic object value which contains the SaveOptionsPic settings.

Remarks

The default value is null.

Requirements

See Also

SaveOptions Class | SaveOptions Members


Tiff Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptions Class | SaveOptions Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Tiff Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptions Class : Tiff Property

Gets the SaveOptionsTiff settings.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property Tiff As SaveOptionsTiff
[C#]
[BrowsableAttribute(false)]
public SaveOptionsTiff Tiff {get;}
[C++]
[BrowsableAttribute(false)]
public: __property SaveOptionsTiff* get_Tiff();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property SaveOptionsTiff^ Tiff {
   SaveOptionsTiff^ get();
}

Value

A SaveOptionsTiff object value which contains the SaveOptionsTiff settings.

Remarks

The default value is null.

Requirements

See Also

SaveOptions Class | SaveOptions Members


SaveOptionsJpeg Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsJpeg Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SaveOptionsJpeg Class

PegasusImaging.WinForms.TwainPro5 Namespace : SaveOptionsJpeg Class

Implements SaveOptions for the JPEG file format.

For a list of all members of this type, see SaveOptionsJpeg members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.TwainPro5.SaveOptionsJpeg

Syntax

[Visual Basic]
Public Class SaveOptionsJpeg
[C#]
public class SaveOptionsJpeg
[C++]
public __gc class SaveOptionsJpeg
[C++/CLI]
public ref class SaveOptionsJpeg

Remarks

Writes necessary JPEG specific file information.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

SaveOptionsJpeg Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsJpeg Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SaveOptionsJpeg Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : SaveOptionsJpeg Class

SaveOptionsJpeg overview

Public Properties

Public Property Chrominance | Gets and sets the chrominance quality setting for saving JPEG files.
Public Property Luminance | Gets and sets the luminance quality setting for saving JPEG files.
Public Property Progressive | Gets and sets whether JPEG files are to be saved as standard files or progressive files.
Public Property SubSampling | Gets and sets the subsampling type for saving JPEG files.

See Also

SaveOptionsJpeg Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsJpeg Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SaveOptionsJpeg Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : SaveOptionsJpeg Class

For a list of all members of this type, see SaveOptionsJpeg members.

Public Properties

Public Property Chrominance | Gets and sets the chrominance quality setting for saving JPEG files.
Public Property Luminance | Gets and sets the luminance quality setting for saving JPEG files.
Public Property Progressive | Gets and sets whether JPEG files are to be saved as standard files or progressive files.
Public Property SubSampling | Gets and sets the subsampling type for saving JPEG files.

See Also

SaveOptionsJpeg Class | PegasusImaging.WinForms.TwainPro5 Namespace


Chrominance Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsJpeg Class | SaveOptionsJpeg Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Chrominance Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptionsJpeg Class : Chrominance Property (SaveOptionsJpeg)

Gets and sets the chrominance quality setting for saving JPEG files.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<DescriptionAttribute("Specifies the chrominance quality setting for saving JPEG files.")>
<DefaultValueAttribute()>
Public Property Chrominance As Integer
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies the chrominance quality setting for saving JPEG files.")]
[DefaultValueAttribute()]
public int Chrominance {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies the chrominance quality setting for saving JPEG files.")]
[DefaultValueAttribute()]
public: __property int get_Chrominance();
public: __property void set_Chrominance(
   int value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies the chrominance quality setting for saving JPEG files.")]
[DefaultValueAttribute()]
public:
property int Chrominance {
   int get();
   void set (int value);
}

Value

An integer value which represents the chrominance quality setting for saving JPEG files.

Remarks

The default value is 10.

JPEG and ePIC images are stored in a compressed format. Compression is lossy which means when you save a JPEG or ePIC file, there will be data loss. Data loss is the result of JPEG and ePICs ability to achieve high compression ratios. Higher quality settings result in less compression, while lower quality settings result in higher compression. Quality versus compression is a tradeoff.

The image compression ratio can be adjusted by setting the Luminance and Chrominance properties. The Luminance property adjusts the luminance or gray scale quality and the Chrominance property adjusts the chrominance or color quality. Lower settings for these properties result in higher quality images with less compression. Higher settings for these properties result in lower quality images with more compression.

For general use photographic type images, setting Luminance = 24 and Chrominance = 30 provides about a 12:1 image compression ratio with minimal data loss. Compression ratios and perceived image quality will vary depending on the image.

Requirements

See Also

SaveOptionsJpeg Class | SaveOptionsJpeg Members


Luminance Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsJpeg Class | SaveOptionsJpeg Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Luminance Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptionsJpeg Class : Luminance Property (SaveOptionsJpeg)

Gets and sets the luminance quality setting for saving JPEG files.

[Visual Basic]
<BrowsableAttribute(False)>
<DescriptionAttribute("Specifies the luminance quality setting for saving JPEG files.")>
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
Public Property Luminance As Integer
[C#]
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies the luminance quality setting for saving JPEG files.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public int Luminance {get; set;}
[C++]
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies the luminance quality setting for saving JPEG files.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public: __property int get_Luminance();
public: __property void set_Luminance(
   int value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies the luminance quality setting for saving JPEG files.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public:
property int Luminance {
   int get();
   void set (int value);
}

Value

An integer value which represents the luninance quality setting for saving JPEG files.

Remarks

The default value is 10.

JPEG and ePIC images are stored in a compressed format. Compression is lossy which means when you save a JPEG or ePIC file, there will be data loss. Data loss is the result of JPEG and ePICs ability to achieve high compression ratios. Higher quality settings result in less compression, while lower quality settings result in higher compression. Quality versus compression is a tradeoff.

The image compression ratio can be adjusted by setting the Luminance and Chrominance properties. The Luminance property adjusts the luminance or gray scale quality and the Chrominance property adjusts the chrominance or color quality. Lower settings for these properties result in higher quality images with less compression. Higher settings for these properties result in lower quality images with more compression.

For general use photographic type images, setting Luminance = 24 and Chrominance = 30 provides about a 12:1 image compression ratio with minimal data loss. Compression ratios and perceived image quality will vary depending on the image.

Requirements

See Also

SaveOptionsJpeg Class | SaveOptionsJpeg Members


Progressive Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsJpeg Class | SaveOptionsJpeg Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Progressive Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptionsJpeg Class : Progressive Property (SaveOptionsJpeg)

Gets and sets whether JPEG files are to be saved as standard files or progressive files.

[Visual Basic]
<DescriptionAttribute("Specifies whether JPEG files are to be saved as standard files or progressive files.")>
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property Progressive As Boolean
[C#]
[DescriptionAttribute("Specifies whether JPEG files are to be saved as standard files or progressive files.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public bool Progressive {get; set;}
[C++]
[DescriptionAttribute("Specifies whether JPEG files are to be saved as standard files or progressive files.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property bool get_Progressive();
public: __property void set_Progressive(
   bool value
);
[C++/CLI]
[DescriptionAttribute("Specifies whether JPEG files are to be saved as standard files or progressive files.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property bool Progressive {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to save as standard. Otherwise, false should be used to save as progressive.

Remarks

The default value is false.

Requirements

See Also

SaveOptionsJpeg Class | SaveOptionsJpeg Members


SubSampling Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsJpeg Class | SaveOptionsJpeg Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SubSampling Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptionsJpeg Class : SubSampling Property (SaveOptionsJpeg)

Gets and sets the subsampling type for saving JPEG files.

[Visual Basic]
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the subsampling type for saving JPEG files.")>
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property SubSampling As SubSampling
[C#]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the subsampling type for saving JPEG files.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public SubSampling SubSampling {get; set;}
[C++]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the subsampling type for saving JPEG files.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property SubSampling get_SubSampling();
public: __property void set_SubSampling(
   SubSampling value
);
[C++/CLI]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the subsampling type for saving JPEG files.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property SubSampling SubSampling {
   SubSampling get();
   void set (SubSampling value);
}

Value

A SubSampling type to save the JPEG file in.

Remarks

The default value: is SubSampling411

SS_111 provides the highest image quality with lower compression and SS_411 provides the best compression with lower image quality.

Requirements

See Also

SaveOptionsJpeg Class | SaveOptionsJpeg Members


SaveOptionsPdf Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsPdf Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SaveOptionsPdf Class

PegasusImaging.WinForms.TwainPro5 Namespace : SaveOptionsPdf Class

This class implements SaveOptions for the PDF file format.

For a list of all members of this type, see SaveOptionsPdf members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.TwainPro5.SaveOptionsPdf

Syntax

[Visual Basic]
Public Class SaveOptionsPdf
[C#]
public class SaveOptionsPdf
[C++]
public __gc class SaveOptionsPdf
[C++/CLI]
public ref class SaveOptionsPdf

Remarks

Writes necessary PDF specific file information.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

SaveOptionsPdf Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsPdf Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SaveOptionsPdf Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : SaveOptionsPdf Class

SaveOptionsPdf overview

Public Properties

Public Property Chrominance | Gets and sets the chrominance quality setting for saving PDF files.
Public Property Compression | Gets or sets the compression type employed for saving a PDF file.
Public Property EncodeModeCompression | Specifies the encoding mode to use when creating a JBIG2 compressed file.
Public Property FileOrganizationCompression | Gets and sets the file organization when saving a JBIG2 compressed file.
Public Property InvertedRegion | Gets and sets whether the bits should be inverted prior to symbol analysis.
Public Property LoosenessCompression | Gets and sets how loose to be when matching symbols and compressing text using either of the lossy text region encode modes.
Public Property Luminance | Gets and sets the luminance quality setting for saving PDF files.
Public Property MultiPage | Gets and sets whether the image is being saved to a multi-page file.
Public Property Progressive | Gets and sets whether JPEG compressed PDF files are to be saved as standard files or progressive files.
Public Property SubSampling | Gets and sets the subsampling type for saving JPEG compressed PDF files.
Public Property SwapBlackAndWhite | Gets or sets a pixel value of zero to black or white.

See Also

SaveOptionsPdf Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsPdf Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SaveOptionsPdf Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : SaveOptionsPdf Class

For a list of all members of this type, see SaveOptionsPdf members.

Public Properties

Public Property Chrominance | Gets and sets the chrominance quality setting for saving PDF files.
Public Property Compression | Gets or sets the compression type employed for saving a PDF file.
Public Property EncodeModeCompression | Specifies the encoding mode to use when creating a JBIG2 compressed file.
Public Property FileOrganizationCompression | Gets and sets the file organization when saving a JBIG2 compressed file.
Public Property InvertedRegion | Gets and sets whether the bits should be inverted prior to symbol analysis.
Public Property LoosenessCompression | Gets and sets how loose to be when matching symbols and compressing text using either of the lossy text region encode modes.
Public Property Luminance | Gets and sets the luminance quality setting for saving PDF files.
Public Property MultiPage | Gets and sets whether the image is being saved to a multi-page file.
Public Property Progressive | Gets and sets whether JPEG compressed PDF files are to be saved as standard files or progressive files.
Public Property SubSampling | Gets and sets the subsampling type for saving JPEG compressed PDF files.
Public Property SwapBlackAndWhite | Gets or sets a pixel value of zero to black or white.

See Also

SaveOptionsPdf Class | PegasusImaging.WinForms.TwainPro5 Namespace


Chrominance Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsPdf Class | SaveOptionsPdf Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Chrominance Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptionsPdf Class : Chrominance Property (SaveOptionsPdf)

Gets and sets the chrominance quality setting for saving PDF files.

[Visual Basic]
<DescriptionAttribute("Specifies the chrominance quality setting for saving PDF files.")>
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property Chrominance As Integer
[C#]
[DescriptionAttribute("Specifies the chrominance quality setting for saving PDF files.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public int Chrominance {get; set;}
[C++]
[DescriptionAttribute("Specifies the chrominance quality setting for saving PDF files.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property int get_Chrominance();
public: __property void set_Chrominance(
   int value
);
[C++/CLI]
[DescriptionAttribute("Specifies the chrominance quality setting for saving PDF files.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property int Chrominance {
   int get();
   void set (int value);
}

Value

An integer value which represents the chrominance quality setting for saving PDF files.

Remarks

The default value is 10.

JPEG and ePIC images are stored in a compressed format. Compression is lossy which means when you save a JPEG or ePIC file, there will be data loss. Data loss is the result of JPEG and ePICs ability to achieve high compression ratios. Higher quality settings result in less compression, while lower quality settings result in higher compression. Quality versus compression is a tradeoff.

The image compression ratio can be adjusted by setting the Luminance and Chrominance properties. The Luminance property adjusts the luminance or gray scale quality and the Chrominance property adjusts the chrominance or color quality. Lower settings for these properties result in higher quality images with less compression. Higher settings for these properties result in lower quality images with more compression.

For general use photographic type images, setting Luminance = 24 and Chrominance = 30 provides about a 12:1 image compression ratio with minimal data loss. Compression ratios and perceived image quality will vary depending on the image.

Requirements

See Also

SaveOptionsPdf Class | SaveOptionsPdf Members


Compression Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsPdf Class | SaveOptionsPdf Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Compression Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptionsPdf Class : Compression Property (SaveOptionsPdf)

Gets or sets the compression type employed for saving a PDF file.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the compression type employed for saving a PDF file.")>
<BrowsableAttribute(False)>
Public Property Compression As PdfCompression
[C#]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the compression type employed for saving a PDF file.")]
[BrowsableAttribute(false)]
public PdfCompression Compression {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the compression type employed for saving a PDF file.")]
[BrowsableAttribute(false)]
public: __property PdfCompression get_Compression();
public: __property void set_Compression(
   PdfCompression value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the compression type employed for saving a PDF file.")]
[BrowsableAttribute(false)]
public:
property PdfCompression Compression {
   PdfCompression get();
   void set (PdfCompression value);
}

Value

A PdfCompression value which determines the compression type for saving a PDF file.

Remarks

The default value is NoCompression.

Requirements

See Also

SaveOptionsPdf Class | SaveOptionsPdf Members


EncodeModeCompression Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsPdf Class | SaveOptionsPdf Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

EncodeModeCompression Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptionsPdf Class : EncodeModeCompression Property (SaveOptionsPdf)

Specifies the encoding mode to use when creating a JBIG2 compressed file.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the encoding mode to use when creating a JBIG2 compressed file.")>
Public Property EncodeModeCompression As EncodeModeCompression
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the encoding mode to use when creating a JBIG2 compressed file.")]
public EncodeModeCompression EncodeModeCompression {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the encoding mode to use when creating a JBIG2 compressed file.")]
public: __property EncodeModeCompression get_EncodeModeCompression();
public: __property void set_EncodeModeCompression(
   EncodeModeCompression value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the encoding mode to use when creating a JBIG2 compressed file.")]
public:
property EncodeModeCompression EncodeModeCompression {
   EncodeModeCompression get();
   void set (EncodeModeCompression value);
}

Value

The EncodeModeCompression value which determines the encoding mode to use when creating a JBIG2 compressed file.

Remarks

The default value is AutoDetect.

Text regions can be encoded as lossless or as lossy according to the encoding mode specified. The lossy modes use the value in SaveOptions.Pdf.LoosenessCompression to control how loose to be when matching symbols and thereby increase compression and reduce file size. Compression means loss, however, and a consequence of higher compression is an increased risk of errors in the reconstructed image.

Specify a larger value of looseness to reduce the compressed file size; use a smaller value to reduce the errors, if any. Halftone regions can be encoded lossy by specifying one of the lossy halftone encoding modes. Alternatively, they can be encoded lossless by using the lossless generic encoding mode.

Requirements

See Also

SaveOptionsPdf Class | SaveOptionsPdf Members


FileOrganizationCompression Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsPdf Class | SaveOptionsPdf Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileOrganizationCompression Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptionsPdf Class : FileOrganizationCompression Property (SaveOptionsPdf)

Gets and sets the file organization when saving a JBIG2 compressed file.

[Visual Basic]
<DescriptionAttribute("Specifies the file organization when saving a JBIG2 compressed file.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
Public Property FileOrganizationCompression As FileOrganizationCompression
[C#]
[DescriptionAttribute("Specifies the file organization when saving a JBIG2 compressed file.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public FileOrganizationCompression FileOrganizationCompression {get; set;}
[C++]
[DescriptionAttribute("Specifies the file organization when saving a JBIG2 compressed file.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public: __property FileOrganizationCompression get_FileOrganizationCompression();
public: __property void set_FileOrganizationCompression(
   FileOrganizationCompression value
);
[C++/CLI]
[DescriptionAttribute("Specifies the file organization when saving a JBIG2 compressed file.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public:
property FileOrganizationCompression FileOrganizationCompression {
   FileOrganizationCompression get();
   void set (FileOrganizationCompression value);
}

Value

A FileOrganizationCompression value which determines the file organization when saving a JBIG2 compressed file.

Remarks

A JBIG2 compressed file may be organized in two ways: sequential or random access. Sequential organization is intended for streaming applications, where the decoder reads and decodes the file in order as the data is received. Random access organization permits the decoder to know the entire file structure, without having to read the entire file, and then uses that information to access the required data in a random-access fashion. This organization is useful for applications such as decoding only odd-number pages.

The default value is Default.

Requirements

See Also

SaveOptionsPdf Class | SaveOptionsPdf Members


InvertedRegion Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsPdf Class | SaveOptionsPdf Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvertedRegion Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptionsPdf Class : InvertedRegion Property

Gets and sets whether the bits should be inverted prior to symbol analysis.

[Visual Basic]
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("Specifies whether the bits should be inverted prior to symbol analysis.")>
Public Property InvertedRegion As Boolean
[C#]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Specifies whether the bits should be inverted prior to symbol analysis.")]
public bool InvertedRegion {get; set;}
[C++]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Specifies whether the bits should be inverted prior to symbol analysis.")]
public: __property bool get_InvertedRegion();
public: __property void set_InvertedRegion(
   bool value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Specifies whether the bits should be inverted prior to symbol analysis.")]
public:
property bool InvertedRegion {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to invert the bits prior to symbol analysis. Otherwise, false should be used.

Remarks

The default value is false.

Inverting the bits prior to symbol analysis may provide better compression if the text is represented as light bits against a dark background instead of the opposite. This setting is only used by the text encode modes.

Requirements

See Also

SaveOptionsPdf Class | SaveOptionsPdf Members


LoosenessCompression Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsPdf Class | SaveOptionsPdf Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

LoosenessCompression Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptionsPdf Class : LoosenessCompression Property

Gets and sets how loose to be when matching symbols and compressing text using either of the lossy text region encode modes.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<DescriptionAttribute("Specifies how loose to be when matching symbols and compressing text using either of the lossy text region encode modes.")>
<DefaultValueAttribute()>
Public Property LoosenessCompression As Integer
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies how loose to be when matching symbols and compressing text using either of the lossy text region encode modes.")]
[DefaultValueAttribute()]
public int LoosenessCompression {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies how loose to be when matching symbols and compressing text using either of the lossy text region encode modes.")]
[DefaultValueAttribute()]
public: __property int get_LoosenessCompression();
public: __property void set_LoosenessCompression(
   int value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies how loose to be when matching symbols and compressing text using either of the lossy text region encode modes.")]
[DefaultValueAttribute()]
public:
property int LoosenessCompression {
   int get();
   void set (int value);
}

Value

An integer value which represents how loose to be when matching symbols and compressing text.

Remarks

The default value is 0.

The default results in the lossless compression.

The LoosenessCompression property provides the ability to set how loose to be when matching symbols and compressing text using either of the lossy text region encoding modes. The larger the number, the greater the compression and the greater the risk of introducing errors.

Set to 50 for a reasonably small file size and low risk of error.

If set to 0, the compression is lossless.

Requirements

See Also

SaveOptionsPdf Class | SaveOptionsPdf Members


Luminance Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsPdf Class | SaveOptionsPdf Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Luminance Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptionsPdf Class : Luminance Property (SaveOptionsPdf)

Gets and sets the luminance quality setting for saving PDF files.

[Visual Basic]
<DescriptionAttribute("Specifies the luminance quality setting for saving PDF files.")>
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property Luminance As Integer
[C#]
[DescriptionAttribute("Specifies the luminance quality setting for saving PDF files.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public int Luminance {get; set;}
[C++]
[DescriptionAttribute("Specifies the luminance quality setting for saving PDF files.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property int get_Luminance();
public: __property void set_Luminance(
   int value
);
[C++/CLI]
[DescriptionAttribute("Specifies the luminance quality setting for saving PDF files.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property int Luminance {
   int get();
   void set (int value);
}

Value

An integer value which represents the luminance quality setting for saving PDF files.

Remarks

The default value is 10.

JPEG and ePIC images are stored in a compressed format. Compression is lossy which means when you save a JPEG or ePIC file, there will be data loss. Data loss is the result of JPEG and ePICs ability to achieve high compression ratios. Higher quality settings result in less compression, while lower quality settings result in higher compression. Quality versus compression is a trade off.

The image compression ratio can be adjusted by setting the Luminance and Chrominance properties. The Luminance property adjusts the luminance or gray scale quality and the Chrominance property adjusts the chrominance or color quality. Lower settings for these properties result in higher quality images with less compression. Higher settings for these properties result in lower quality images with more compression.

For general use photographic type images, setting Luminance = 24 and Chrominance = 30 provides about a 12:1 image compression ratio with minimal data loss. Compression ratios and perceived image quality will vary depending on the image.

Requirements

See Also

SaveOptionsPdf Class | SaveOptionsPdf Members


MultiPage Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsPdf Class | SaveOptionsPdf Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

MultiPage Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptionsPdf Class : MultiPage Property (SaveOptionsPdf)

Gets and sets whether the image is being saved to a multi-page file.

[Visual Basic]
<DescriptionAttribute("Specifies whether the image is being saved to a multi-page file.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
Public Property MultiPage As Boolean
[C#]
[DescriptionAttribute("Specifies whether the image is being saved to a multi-page file.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public bool MultiPage {get; set;}
[C++]
[DescriptionAttribute("Specifies whether the image is being saved to a multi-page file.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public: __property bool get_MultiPage();
public: __property void set_MultiPage(
   bool value
);
[C++/CLI]
[DescriptionAttribute("Specifies whether the image is being saved to a multi-page file.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public:
property bool MultiPage {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to save the image as a multi-page file. Otherwise, false is used and the file is not saved as multi-page.

Remarks

The default value is false.

Requirements

See Also

SaveOptionsPdf Class | SaveOptionsPdf Members


Progressive Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsPdf Class | SaveOptionsPdf Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Progressive Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptionsPdf Class : Progressive Property (SaveOptionsPdf)

Gets and sets whether JPEG compressed PDF files are to be saved as standard files or progressive files.

[Visual Basic]
<DescriptionAttribute("Specifies whether JPEG compressed PDF files are to be saved as standard files or progressive files.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
Public Property Progressive As Boolean
[C#]
[DescriptionAttribute("Specifies whether JPEG compressed PDF files are to be saved as standard files or progressive files.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public bool Progressive {get; set;}
[C++]
[DescriptionAttribute("Specifies whether JPEG compressed PDF files are to be saved as standard files or progressive files.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public: __property bool get_Progressive();
public: __property void set_Progressive(
   bool value
);
[C++/CLI]
[DescriptionAttribute("Specifies whether JPEG compressed PDF files are to be saved as standard files or progressive files.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public:
property bool Progressive {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to save as standard files. Otherwise, false should be used to save as progressive.

Remarks

The default value is false.

Requirements

See Also

SaveOptionsPdf Class | SaveOptionsPdf Members


SubSampling Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsPdf Class | SaveOptionsPdf Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SubSampling Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptionsPdf Class : SubSampling Property (SaveOptionsPdf)

Gets and sets the subsampling type for saving JPEG compressed PDF files.

[Visual Basic]
<DescriptionAttribute("Specifies the subsampling type for saving JPEG compressed PDF files.")>
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property SubSampling As SubSampling
[C#]
[DescriptionAttribute("Specifies the subsampling type for saving JPEG compressed PDF files.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public SubSampling SubSampling {get; set;}
[C++]
[DescriptionAttribute("Specifies the subsampling type for saving JPEG compressed PDF files.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property SubSampling get_SubSampling();
public: __property void set_SubSampling(
   SubSampling value
);
[C++/CLI]
[DescriptionAttribute("Specifies the subsampling type for saving JPEG compressed PDF files.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property SubSampling SubSampling {
   SubSampling get();
   void set (SubSampling value);
}

Value

A SubSampling value which represents the type for saving JPEG compressed PDF files.

Remarks

The default value is SubSampling411.

SS_111 provides the highest image quality with lower compression and SS_411 provides the best compression with lower image quality.

Requirements

See Also

SaveOptionsPdf Class | SaveOptionsPdf Members


SwapBlackAndWhite Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsPdf Class | SaveOptionsPdf Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SwapBlackAndWhite Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptionsPdf Class : SwapBlackAndWhite Property

Gets or sets a pixel value of zero to black or white.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("Gets or sets a pixel value of zero to black or white.")>
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
Public Property SwapBlackAndWhite As Boolean
[C#]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets or sets a pixel value of zero to black or white.")]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public bool SwapBlackAndWhite {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets or sets a pixel value of zero to black or white.")]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public: __property bool get_SwapBlackAndWhite();
public: __property void set_SwapBlackAndWhite(
   bool value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets or sets a pixel value of zero to black or white.")]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public:
property bool SwapBlackAndWhite {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true when 1 = black and 0 = white. Otherwise, false is used and 1 = white and 0 = black.

Remarks

The default value is false.

When false, the standard definition of black and white are used in the saved image: 1 = white and 0 = black. When true, the definition of black and white are reversed in the saved image: 1 = black and 0 = white.

This property pertains only to G4 Compression types.

Requirements

See Also

SaveOptionsPdf Class | SaveOptionsPdf Members


SaveOptionsPic Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsPic Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SaveOptionsPic Class

PegasusImaging.WinForms.TwainPro5 Namespace : SaveOptionsPic Class

This class implements objects for saving PIC options.

For a list of all members of this type, see SaveOptionsPic members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.TwainPro5.SaveOptionsPic

Syntax

[Visual Basic]
Public Class SaveOptionsPic
[C#]
public class SaveOptionsPic
[C++]
public __gc class SaveOptionsPic
[C++/CLI]
public ref class SaveOptionsPic

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

SaveOptionsPic Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsPic Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SaveOptionsPic Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : SaveOptionsPic Class

SaveOptionsPic overview

Public Properties

Public Property Chrominance | Gets and sets the chrominance quality setting for saving ePIC files.
Public Property Luminance | Gets and sets the luminance quality setting for saving ePIC files.
Public Property Password | Gets and sets the password for an Encrypted Pegasus Imaging Corporation (ePIC) file format.
Public Property Progressive | Gets and sets if ePIC files are to be saved as standard files or progressive files.
Public Property SubSampling | Gets and sets the subsampling type for saving ePIC files.

See Also

SaveOptionsPic Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsPic Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SaveOptionsPic Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : SaveOptionsPic Class

For a list of all members of this type, see SaveOptionsPic members.

Public Properties

Public Property Chrominance | Gets and sets the chrominance quality setting for saving ePIC files.
Public Property Luminance | Gets and sets the luminance quality setting for saving ePIC files.
Public Property Password | Gets and sets the password for an Encrypted Pegasus Imaging Corporation (ePIC) file format.
Public Property Progressive | Gets and sets if ePIC files are to be saved as standard files or progressive files.
Public Property SubSampling | Gets and sets the subsampling type for saving ePIC files.

See Also

SaveOptionsPic Class | PegasusImaging.WinForms.TwainPro5 Namespace


Chrominance Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsPic Class | SaveOptionsPic Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Chrominance Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptionsPic Class : Chrominance Property (SaveOptionsPic)

Gets and sets the chrominance quality setting for saving ePIC files.

[Visual Basic]
<BrowsableAttribute(False)>
<DescriptionAttribute("Specifies the chrominance quality setting for saving ePIC files.")>
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
Public Property Chrominance As Integer
[C#]
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies the chrominance quality setting for saving ePIC files.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public int Chrominance {get; set;}
[C++]
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies the chrominance quality setting for saving ePIC files.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public: __property int get_Chrominance();
public: __property void set_Chrominance(
   int value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies the chrominance quality setting for saving ePIC files.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public:
property int Chrominance {
   int get();
   void set (int value);
}

Value

An integer value which represents the chrominance quality setting for saving ePIC files.

Remarks

The default value is 10.

JPEG and ePIC images are stored in a compressed format. Compression is lossy which means when you save a JPEG or ePIC file, there will be data loss. Data loss is the result of JPEG and ePICs ability to achieve high compression ratios. Higher quality settings result in less compression, while lower quality settings result in higher compression. Quality versus compression is a tradeoff.

The image compression ratio can be adjusted by setting the Luminance and Chrominance properties. The Luminance property adjusts the luminance or gray scale quality and the Chrominance property adjusts the chrominance or color quality. Lower settings for these properties result in higher quality images with less compression. Higher settings for these properties result in lower quality images with more compression.

For general use photographic type images, setting Luminance = 24 and Chrominance = 30 provides about a 12:1 image compression ratio with minimal data loss. Compression ratios and perceived image quality will vary depending on the image.

Requirements

See Also

SaveOptionsPic Class | SaveOptionsPic Members


Luminance Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsPic Class | SaveOptionsPic Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Luminance Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptionsPic Class : Luminance Property (SaveOptionsPic)

Gets and sets the luminance quality setting for saving ePIC files.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<DescriptionAttribute("Specifies the luminance quality setting for saving ePIC files.")>
<DefaultValueAttribute()>
Public Property Luminance As Integer
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies the luminance quality setting for saving ePIC files.")]
[DefaultValueAttribute()]
public int Luminance {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies the luminance quality setting for saving ePIC files.")]
[DefaultValueAttribute()]
public: __property int get_Luminance();
public: __property void set_Luminance(
   int value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies the luminance quality setting for saving ePIC files.")]
[DefaultValueAttribute()]
public:
property int Luminance {
   int get();
   void set (int value);
}

Value

An integer value which represents the luminance quality setting for saving ePIC files.

Remarks

The default value is 10.

JPEG and ePIC images are stored in a compressed format. Compression is lossy which means when you save a JPEG or ePIC file, there will be data loss. Data loss is the result of JPEG and ePICs ability to achieve high compression ratios. Higher quality settings result in less compression, while lower quality settings result in higher compression. Quality versus compression is a tradeoff.

The image compression ratio can be adjusted by setting the Luminance and Chrominance properties. The Luminance property adjusts the luminance or gray scale quality and the Chrominance property adjusts the chrominance or color quality. Lower settings for these properties result in higher quality images with less compression. Higher settings for these properties result in lower quality images with more compression.

For general use photographic type images, setting Luminance = 24 and Chrominance = 30 provides about a 12:1 image compression ratio with minimal data loss. Compression ratios and perceived image quality will vary depending on the image.

Requirements

See Also

SaveOptionsPic Class | SaveOptionsPic Members


Password Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsPic Class | SaveOptionsPic Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Password Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptionsPic Class : Password Property

Gets and sets the password for an Encrypted Pegasus Imaging Corporation (ePIC) file format.

[Visual Basic]
<DescriptionAttribute("Gets or sets the password for an Encrypted Pegasus Imaging Corporation (ePIC) file format.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
Public Property Password As String
[C#]
[DescriptionAttribute("Gets or sets the password for an Encrypted Pegasus Imaging Corporation (ePIC) file format.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public string Password {get; set;}
[C++]
[DescriptionAttribute("Gets or sets the password for an Encrypted Pegasus Imaging Corporation (ePIC) file format.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public: __property string* get_Password();
public: __property void set_Password(
   string* value
);
[C++/CLI]
[DescriptionAttribute("Gets or sets the password for an Encrypted Pegasus Imaging Corporation (ePIC) file format.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public:
property String^ Password {
   String^ get();
   void set (String^ value);
}

Value

A string value which represents the password.

Remarks

The default value is an empty string "".

Requirements

See Also

SaveOptionsPic Class | SaveOptionsPic Members


Progressive Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsPic Class | SaveOptionsPic Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Progressive Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptionsPic Class : Progressive Property (SaveOptionsPic)

Gets and sets if ePIC files are to be saved as standard files or progressive files.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<DescriptionAttribute("Specifies whether ePIC files are to be saved as standard files or progressive files.")>
<DefaultValueAttribute()>
Public Property Progressive As Boolean
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies whether ePIC files are to be saved as standard files or progressive files.")]
[DefaultValueAttribute()]
public bool Progressive {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies whether ePIC files are to be saved as standard files or progressive files.")]
[DefaultValueAttribute()]
public: __property bool get_Progressive();
public: __property void set_Progressive(
   bool value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies whether ePIC files are to be saved as standard files or progressive files.")]
[DefaultValueAttribute()]
public:
property bool Progressive {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to save as standard files. Otherwise, false should be used to save as progressive.

Remarks

The default value is false.

Requirements

See Also

SaveOptionsPic Class | SaveOptionsPic Members


SubSampling Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsPic Class | SaveOptionsPic Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SubSampling Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptionsPic Class : SubSampling Property (SaveOptionsPic)

Gets and sets the subsampling type for saving ePIC files.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<DescriptionAttribute("Specifies the subsampling type for saving ePIC files.")>
<DefaultValueAttribute()>
Public Property SubSampling As SubSampling
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies the subsampling type for saving ePIC files.")]
[DefaultValueAttribute()]
public SubSampling SubSampling {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies the subsampling type for saving ePIC files.")]
[DefaultValueAttribute()]
public: __property SubSampling get_SubSampling();
public: __property void set_SubSampling(
   SubSampling value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies the subsampling type for saving ePIC files.")]
[DefaultValueAttribute()]
public:
property SubSampling SubSampling {
   SubSampling get();
   void set (SubSampling value);
}

Value

A SubSampling type for saving ePIC file.

Remarks

The default value is SubSampling.SubSampling411.

The SS_111 type of subsampling provides the highest image quality with lower compression and the SS_411 type provides the best compression with lower image quality.

Requirements

See Also

SaveOptionsPic Class | SaveOptionsPic Members


SaveOptionsTiff Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsTiff Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SaveOptionsTiff Class

PegasusImaging.WinForms.TwainPro5 Namespace : SaveOptionsTiff Class

Implements SaveOptions for the TIFF file format.

For a list of all members of this type, see SaveOptionsTiff members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.TwainPro5.SaveOptionsTiff

Syntax

[Visual Basic]
Public Class SaveOptionsTiff
[C#]
public class SaveOptionsTiff
[C++]
public __gc class SaveOptionsTiff
[C++/CLI]
public ref class SaveOptionsTiff

Remarks

Writes necessary TIFF specific file information.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

SaveOptionsTiff Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsTiff Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SaveOptionsTiff Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : SaveOptionsTiff Class

SaveOptionsTiff overview

Public Properties

Public Property Compression | Gets and sets the compression type employed for saving a TIFF file.
Public Property IFDOffset | Gets and sets the location to append the next TIFF page when fast saving of multi-page TIFF files is invoked.
Public Property MultiPage | Gets and sets if the image is being saved to a multi-page file.
Public Property UseIFDOffset | Gets and sets an indicator to enable fast multi-page TIFF writes.

See Also

SaveOptionsTiff Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsTiff Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SaveOptionsTiff Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : SaveOptionsTiff Class

For a list of all members of this type, see SaveOptionsTiff members.

Public Properties

Public Property Compression | Gets and sets the compression type employed for saving a TIFF file.
Public Property IFDOffset | Gets and sets the location to append the next TIFF page when fast saving of multi-page TIFF files is invoked.
Public Property MultiPage | Gets and sets if the image is being saved to a multi-page file.
Public Property UseIFDOffset | Gets and sets an indicator to enable fast multi-page TIFF writes.

See Also

SaveOptionsTiff Class | PegasusImaging.WinForms.TwainPro5 Namespace


Compression Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsTiff Class | SaveOptionsTiff Members | TiffCompression Enumeration

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Compression Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptionsTiff Class : Compression Property (SaveOptionsTiff)

Gets and sets the compression type employed for saving a TIFF file.

[Visual Basic]
<BrowsableAttribute(False)>
<DescriptionAttribute("Gets or sets the compression type employed for saving a TIFF file.")>
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
Public Property Compression As TiffCompression
[C#]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the compression type employed for saving a TIFF file.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public TiffCompression Compression {get; set;}
[C++]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the compression type employed for saving a TIFF file.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public: __property TiffCompression get_Compression();
public: __property void set_Compression(
   TiffCompression value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the compression type employed for saving a TIFF file.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public:
property TiffCompression Compression {
   TiffCompression get();
   void set (TiffCompression value);
}

Value

A TiffCompression enumeration value which determines the compression type for saving a TIFF file.

Remarks

The default value is TiffCompression.NoCompression.

Requirements

See Also

SaveOptionsTiff Class | SaveOptionsTiff Members | TiffCompression Enumeration


IFDOffset Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsTiff Class | SaveOptionsTiff Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

IFDOffset Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptionsTiff Class : IFDOffset Property

Gets and sets the location to append the next TIFF page when fast saving of multi-page TIFF files is invoked.

[Visual Basic]
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("Location to append the next tiff page when fast saving of multi-page tiff files is invoked.")>
Public Property IFDOffset As Integer
[C#]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Location to append the next tiff page when fast saving of multi-page tiff files is invoked.")]
public int IFDOffset {get; set;}
[C++]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Location to append the next tiff page when fast saving of multi-page tiff files is invoked.")]
public: __property int get_IFDOffset();
public: __property void set_IFDOffset(
   int value
);
[C++/CLI]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Location to append the next tiff page when fast saving of multi-page tiff files is invoked.")]
public:
property int IFDOffset {
   int get();
   void set (int value);
}

Value

An integer value which represents the location to append the next TIFF page when fast saving of multi-page TIFF files is invoked.

Remarks

The default value is 0.

Requirements

See Also

SaveOptionsTiff Class | SaveOptionsTiff Members


MultiPage Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsTiff Class | SaveOptionsTiff Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

MultiPage Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptionsTiff Class : MultiPage Property (SaveOptionsTiff)

Gets and sets if the image is being saved to a multi-page file.

[Visual Basic]
<DescriptionAttribute("Specifies whether the image is being saved to a multi-page file.")>
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
Public Property MultiPage As Boolean
[C#]
[DescriptionAttribute("Specifies whether the image is being saved to a multi-page file.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public bool MultiPage {get; set;}
[C++]
[DescriptionAttribute("Specifies whether the image is being saved to a multi-page file.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public: __property bool get_MultiPage();
public: __property void set_MultiPage(
   bool value
);
[C++/CLI]
[DescriptionAttribute("Specifies whether the image is being saved to a multi-page file.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public:
property bool MultiPage {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to save as a multi-page file. Otherwise, false is used.

Remarks

The default value is false.

Note: When this property is set to true and an FTP or HTTP address location is specified in the ScannedImage.SaveFile(String) filename parameter, a multi-page file will not be created as this property only supports saving to local files.

Requirements

See Also

SaveOptionsTiff Class | SaveOptionsTiff Members


UseIFDOffset Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SaveOptionsTiff Class | SaveOptionsTiff Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

UseIFDOffset Property

PegasusImaging.WinForms.TwainPro5 Namespace > SaveOptionsTiff Class : UseIFDOffset Property

Gets and sets an indicator to enable fast multi-page TIFF writes.

[Visual Basic]
<DefaultValueAttribute()>
<DescriptionAttribute("Enables or disables fast multi-page TIFF writes.")>
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property UseIFDOffset As Boolean
[C#]
[DefaultValueAttribute()]
[DescriptionAttribute("Enables or disables fast multi-page TIFF writes.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public bool UseIFDOffset {get; set;}
[C++]
[DefaultValueAttribute()]
[DescriptionAttribute("Enables or disables fast multi-page TIFF writes.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property bool get_UseIFDOffset();
public: __property void set_UseIFDOffset(
   bool value
);
[C++/CLI]
[DefaultValueAttribute()]
[DescriptionAttribute("Enables or disables fast multi-page TIFF writes.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property bool UseIFDOffset {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to enable fast multi-page TIFF writes. Otherwise, false is used.

Remarks

The default value is false.

Requirements

See Also

SaveOptionsTiff Class | SaveOptionsTiff Members


ScannedEventArgs Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedEventArgs Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ScannedEventArgs Class

PegasusImaging.WinForms.TwainPro5 Namespace : ScannedEventArgs Class

Arguments for a scanned event.

For a list of all members of this type, see ScannedEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.TwainPro5.ScannedEventArgs

Syntax

[Visual Basic]
Public Class ScannedEventArgs
   Inherits EventArgs
[C#]
public class ScannedEventArgs : EventArgs
[C++]
public __gc class ScannedEventArgs : public EventArgs
[C++/CLI]
public ref class ScannedEventArgs : public EventArgs

Remarks

This class provides the communication between the object that issued a scanned event and the object that handles the event.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

ScannedEventArgs Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedEventArgs Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ScannedEventArgs Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : ScannedEventArgs Class

ScannedEventArgs overview

Public Constructors

Public Constructor ScannedEventArgs Constructor

Public Properties

Public Property Cancel | Gets and sets a cancel on the session. If set to true, the session ends and the StartSession method returns control.
Public Property PendingTransfers | Gets and sets the number of image transfers the TWAIN Data Source is ready to supply to the TwainPRO control.
Public Property ScannedImage | Gets and sets the scanned image and image information.

See Also

ScannedEventArgs Class | PegasusImaging.WinForms.TwainPro5 Namespace


ScannedEventArgs Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedEventArgs Class | ScannedEventArgs Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ScannedEventArgs Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > ScannedEventArgs Class : ScannedEventArgs Constructor (ScannedEventArgs)
[Visual Basic]
Public Function New()
[C#]
public ScannedEventArgs();
[C++]
public: ScannedEventArgs();
[C++/CLI]
public:
ScannedEventArgs();

Requirements

See Also

ScannedEventArgs Class | ScannedEventArgs Members


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedEventArgs Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ScannedEventArgs Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : ScannedEventArgs Class

For a list of all members of this type, see ScannedEventArgs members.

Public Properties

Public Property Cancel | Gets and sets a cancel on the session. If set to true, the session ends and the StartSession method returns control.
Public Property PendingTransfers | Gets and sets the number of image transfers the TWAIN Data Source is ready to supply to the TwainPRO control.
Public Property ScannedImage | Gets and sets the scanned image and image information.

See Also

ScannedEventArgs Class | PegasusImaging.WinForms.TwainPro5 Namespace


Cancel Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedEventArgs Class | ScannedEventArgs Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Cancel Property

PegasusImaging.WinForms.TwainPro5 Namespace > ScannedEventArgs Class : Cancel Property (ScannedEventArgs)

Gets and sets a cancel on the session. If set to true, the session ends and the StartSession method returns control.

[Visual Basic]
Public Property Cancel As Boolean
[C#]
public bool Cancel {get; set;}
[C++]
public: __property bool get_Cancel();
public: __property void set_Cancel(
   bool value
);
[C++/CLI]
public:
property bool Cancel {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to cancel the session. Otherwise, false is used and the session is not canceled.

Requirements

See Also

ScannedEventArgs Class | ScannedEventArgs Members


PendingTransfers Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedEventArgs Class | ScannedEventArgs Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PendingTransfers Property

PegasusImaging.WinForms.TwainPro5 Namespace > ScannedEventArgs Class : PendingTransfers Property (ScannedEventArgs)

Gets and sets the number of image transfers the TWAIN Data Source is ready to supply to the TwainPRO control.

[Visual Basic]
Public ReadOnly Property PendingTransfers As Integer
[C#]
public int PendingTransfers {get;}
[C++]
public: __property int get_PendingTransfers();
[C++/CLI]
public:
property int PendingTransfers {
   int get();
}

Value

An integer value which represents the number of image transfers the TWAIN device is ready to supply to the TwainPRO control.

Remarks

The TWAIN Data Source will return -1 if it is not sure how many transfers are pending. Scanners with Automatic Document Feeders (ADF) will typically return -1.

Requirements

See Also

ScannedEventArgs Class | ScannedEventArgs Members


ScannedImage Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedEventArgs Class | ScannedEventArgs Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ScannedImage Property

PegasusImaging.WinForms.TwainPro5 Namespace > ScannedEventArgs Class : ScannedImage Property (ScannedEventArgs)

Gets and sets the scanned image and image information.

[Visual Basic]
Public Property ScannedImage As ScannedImage
[C#]
public ScannedImage ScannedImage {get; set;}
[C++]
public: __property ScannedImage* get_ScannedImage();
public: __property void set_ScannedImage(
   ScannedImage* value
);
[C++/CLI]
public:
property ScannedImage^ ScannedImage {
   ScannedImage^ get();
   void set (ScannedImage^ value);
}

Value

A ScannedImage object which contains image information.

Requirements

See Also

ScannedEventArgs Class | ScannedEventArgs Members


ScannedImage Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImage Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ScannedImage Class

PegasusImaging.WinForms.TwainPro5 Namespace : ScannedImage Class (PegasusImaging.WinForms.TwainPro5)

This class implements the scanned image and image information.

For a list of all members of this type, see ScannedImage members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.TwainPro5.ScannedImage

Syntax

[Visual Basic]
Public Class ScannedImage
[C#]
public class ScannedImage
[C++]
public __gc class ScannedImage
[C++/CLI]
public ref class ScannedImage

Remarks

Note: You cannot create a ScannedImage object directly.

The ScannedImage is accessible as a parameter of the Scanned event.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

ScannedImage Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImage Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ScannedImage Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : ScannedImage Class (PegasusImaging.WinForms.TwainPro5)

ScannedImage overview

Public Properties

Public Property ScannedImageData Gets the ScannedImageData properties.

Public Methods

Public Method CopyToClipboard | Copies the image to the clipboard.
Public Method CutToClipboard | Cuts the image to the clipboard.
Public Method Dispose | Disposes any unused resources.
Public Method GetExtendedImageInfo | Overloaded. Gets the specified extended image info.
Public Method SaveFile | Overloaded. Saves the scanned image to file using the specified filename and default save options.
Public Method SaveStream | Saves the image to a stream object.
Public Method ToBitmap | Gets a Bitmap object.
Public Method ToHbitmap | Gets a handle to a bitmap.
Public Method ToHdib | Gets a handle to a DIB.

See Also

ScannedImage Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImage Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ScannedImage Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : ScannedImage Class (PegasusImaging.WinForms.TwainPro5)

For a list of all members of this type, see ScannedImage members.

Public Methods

Public Method CopyToClipboard | Copies the image to the clipboard.
Public Method CutToClipboard | Cuts the image to the clipboard.
Public Method Dispose | Disposes any unused resources.
Public Method GetExtendedImageInfo | Overloaded. Gets the specified extended image info.
Public Method SaveFile | Overloaded. Saves the scanned image to file using the specified filename and default save options.
Public Method SaveStream | Saves the image to a stream object.
Public Method ToBitmap | Gets a Bitmap object.
Public Method ToHbitmap | Gets a handle to a bitmap.
Public Method ToHdib | Gets a handle to a DIB.

See Also

ScannedImage Class | PegasusImaging.WinForms.TwainPro5 Namespace


CopyToClipboard Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImage Class | ScannedImage Members | SaveFile(String) Method

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CopyToClipboard Method

PegasusImaging.WinForms.TwainPro5 Namespace > ScannedImage Class : CopyToClipboard Method

Copies the image to the clipboard.

[Visual Basic]
Public Sub CopyToClipboard()
[C#]
public void CopyToClipboard();
[C++]
public: void CopyToClipboard();
[C++/CLI]
public:
void CopyToClipboard();

Remarks

This method makes a copy of the current image and places it on the clipboard. This leaves the hDIB property valid for operations such as the ScannedImage.SaveFile(String) method, but leaves two copies of the image in memory which could be a problem if the image is very large.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

ScannedImage Class | ScannedImage Members | SaveFile(String) Method


CutToClipboard Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImage Class | ScannedImage Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CutToClipboard Method

PegasusImaging.WinForms.TwainPro5 Namespace > ScannedImage Class : CutToClipboard Method

Cuts the image to the clipboard.

[Visual Basic]
Public Sub CutToClipboard()
[C#]
public void CutToClipboard();
[C++]
public: void CutToClipboard();
[C++/CLI]
public:
void CutToClipboard();

Remarks

This method places the current image on the clipboard. The hDIB property is not valid after this operation. If you wish to save the image to file, invoke the ScannedImage.SaveFile(String) method prior to using the CutToClipboard method.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

ScannedImage Class | ScannedImage Members


Dispose Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImage Class | ScannedImage Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.TwainPro5 Namespace > ScannedImage Class : Dispose Method (ScannedImage)

Disposes any unused resources.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

Remarks

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

ScannedImage Class | ScannedImage Members


GetExtendedImageInfo Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImage Class | ScannedImage Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

GetExtendedImageInfo Method

PegasusImaging.WinForms.TwainPro5 Namespace > ScannedImage Class : GetExtendedImageInfo Method

Gets the specified extended image info.

Overload List

Gets the specified extended image info.

[Visual Basic] Overloads Public Function GetExtendedImageInfo(ExtendedImageInfo) As ExtendedImageInfoContainer

[C#] public ExtendedImageInfoContainer GetExtendedImageInfo(ExtendedImageInfo);

[C++] public ExtendedImageInfoContainer* GetExtendedImageInfo(ExtendedImageInfo);

[C++/CLI] public ExtendedImageInfoContainer^ GetExtendedImageInfo(ExtendedImageInfo);

Gets the specified extended image info.

[Visual Basic] Overloads Public Function GetExtendedImageInfo(Integer) As ExtendedImageInfoContainer

[C#] public ExtendedImageInfoContainer GetExtendedImageInfo(int);

[C++] public ExtendedImageInfoContainer* GetExtendedImageInfo(int);

[C++/CLI] public ExtendedImageInfoContainer^ GetExtendedImageInfo(int);

Remarks

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

ScannedImage Class | ScannedImage Members


GetExtendedImageInfo(ExtendedImageInfo) Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImage Class | ScannedImage Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

extendedImageInfo
An extended image info identification
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

GetExtendedImageInfo(ExtendedImageInfo) Method

PegasusImaging.WinForms.TwainPro5 Namespace > ScannedImage Class > GetExtendedImageInfo Method : GetExtendedImageInfo(ExtendedImageInfo) Method

Gets the specified extended image info.

[Visual Basic]
Overloads Public Function GetExtendedImageInfo( _
   ByVal extendedImageInfo As ExtendedImageInfo _
) As ExtendedImageInfoContainer
[C#]
public ExtendedImageInfoContainer GetExtendedImageInfo(
   ExtendedImageInfo extendedImageInfo
);
[C++]
public: ExtendedImageInfoContainer* GetExtendedImageInfo(
   ExtendedImageInfo extendedImageInfo
)
[C++/CLI]
public:
ExtendedImageInfoContainer^ GetExtendedImageInfo(
   ExtendedImageInfo extendedImageInfo
)

Parameters

extendedImageInfo
An extended image info identification

Return Type

An ExtendedImageInfoContainer object

Remarks

Returns an ExtendedImageInfoContainer with the extended image info of the specified extended image info identification.

Requirements

See Also

ScannedImage Class | ScannedImage Members | Overload List


GetExtendedImageInfo(Int32) Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImage Class | ScannedImage Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

extendedImageInfo
An ExtendedImageInfo enumeration value.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

GetExtendedImageInfo(Int32) Method

PegasusImaging.WinForms.TwainPro5 Namespace > ScannedImage Class > GetExtendedImageInfo Method : GetExtendedImageInfo(Int32) Method

Gets the specified extended image info.

[Visual Basic]
Overloads Public Function GetExtendedImageInfo( _
   ByVal extendedImageInfo As Integer _
) As ExtendedImageInfoContainer
[C#]
public ExtendedImageInfoContainer GetExtendedImageInfo(
   int extendedImageInfo
);
[C++]
public: ExtendedImageInfoContainer* GetExtendedImageInfo(
   int extendedImageInfo
)
[C++/CLI]
public:
ExtendedImageInfoContainer^ GetExtendedImageInfo(
   int extendedImageInfo
)

Parameters

extendedImageInfo
An ExtendedImageInfo enumeration value.

Return Type

An ExtendedImageInfoContainer object.

Remarks

Returns an ExtendedImageInfoContainer with the extended image info of the specified extended image info identification.

Requirements

See Also

ScannedImage Class | ScannedImage Members | Overload List


SaveFile Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImage Class | ScannedImage Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SaveFile Method

PegasusImaging.WinForms.TwainPro5 Namespace > ScannedImage Class : SaveFile Method

Saves the scanned image to file using the specified filename and default save options.

Overload List

Saves the scanned image to file using the specified filename and default save options.

[Visual Basic] Overloads Public Sub SaveFile(String)

[C#] public void SaveFile(string);

[C++] public void SaveFile(string*);

[C++/CLI] public void SaveFile(String^);

Saves the scanned image to file using the specified filename and save options.

[Visual Basic] Overloads Public Sub SaveFile(String,SaveOptions)

[C#] public void SaveFile(string,SaveOptions);

[C++] public void SaveFile(string*,SaveOptions*);

[C++/CLI] public void SaveFile(String^,SaveOptions^);

Remarks

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

ScannedImage Class | ScannedImage Members


SaveFile(String) Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImage Class | ScannedImage Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

filename
A string representation of a legal file name (path) to which the file will be saved.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SaveFile(String) Method

PegasusImaging.WinForms.TwainPro5 Namespace > ScannedImage Class > SaveFile Method : SaveFile(String) Method

Saves the scanned image to file using the specified filename and default save options.

[Visual Basic]
Overloads Public Sub SaveFile( _
   ByVal filename As String _
)
[C#]
public void SaveFile(
   string filename
);
[C++]
public: void SaveFile(
   string* filename
)
[C++/CLI]
public:
void SaveFile(
   String^ filename
)

Parameters

filename
A string representation of a legal file name (path) to which the file will be saved.

Remarks

The bitmap saved will be the same bits per pixel and color depth as the current DIB. Valid file extensions for this filename are .bmp, .jpg, .pic, .tif, and .pdf.

Requirements

See Also

ScannedImage Class | ScannedImage Members | Overload List


SaveFile(String,SaveOptions) Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImage Class | ScannedImage Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

filename
A string representation of a legal file name (path) to which the file will be saved.
saveOptions
SaveOptions class that evaluates to the various settings for the particular file format to which the image will be saved.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SaveFile(String,SaveOptions) Method

PegasusImaging.WinForms.TwainPro5 Namespace > ScannedImage Class > SaveFile Method : SaveFile(String,SaveOptions) Method

Saves the scanned image to file using the specified filename and save options.

[Visual Basic]
Overloads Public Sub SaveFile( _
   ByVal filename As String, _
   ByVal saveOptions As SaveOptions _
)
[C#]
public void SaveFile(
   string filename,
   SaveOptions saveOptions
);
[C++]
public: void SaveFile(
   string* filename,
   SaveOptions* saveOptions
)
[C++/CLI]
public:
void SaveFile(
   String^ filename,
   SaveOptions^ saveOptions
)

Parameters

filename
A string representation of a legal file name (path) to which the file will be saved.
saveOptions
SaveOptions class that evaluates to the various settings for the particular file format to which the image will be saved.

Remarks

The bitmap saved will be the same bits per pixel and color depth as the current DIB. If the SaveOptions image format is set to default, one of the following valid file extensions will need to be used: .bmp, .jpg, .pic, .tif, or .pdf."

Requirements

See Also

ScannedImage Class | ScannedImage Members | Overload List


SaveStream Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImage Class | ScannedImage Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

stream
An opened and writable Stream derived stream object.
theFormat
A ScannedImageFormat which represents the format to use to save the image.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SaveStream Method

PegasusImaging.WinForms.TwainPro5 Namespace > ScannedImage Class : SaveStream Method

Saves the image to a stream object.

[Visual Basic]
Public Sub SaveStream( _
   ByVal stream As Stream, _
   ByVal theFormat As ScannedImageFormat _
)
[C#]
public void SaveStream(
   Stream stream,
   ScannedImageFormat theFormat
);
[C++]
public: void SaveStream(
   Stream* stream,
   ScannedImageFormat theFormat
)
[C++/CLI]
public:
void SaveStream(
   Stream^ stream,
   ScannedImageFormat theFormat
)

Parameters

stream
An opened and writable Stream derived stream object.
theFormat
A ScannedImageFormat which represents the format to use to save the image.

Remarks

The stream passed can be any stream derived System.IO.Stream. The stream should be opened by calling this method.

The stream should also allow writes.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

ScannedImage Class | ScannedImage Members


ToBitmap Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImage Class | ScannedImage Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ToBitmap Method

PegasusImaging.WinForms.TwainPro5 Namespace > ScannedImage Class : ToBitmap Method

Gets a Bitmap object.

[Visual Basic]
Public Function ToBitmap() As Bitmap
[C#]
public Bitmap ToBitmap();
[C++]
public: Bitmap* ToBitmap();
[C++/CLI]
public:
Bitmap^ ToBitmap();

Return Type

A Bitmap object.

Remarks

When accessed, the image is released from the ScannedImage object.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

ScannedImage Class | ScannedImage Members


ToHbitmap Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImage Class | ScannedImage Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ToHbitmap Method

PegasusImaging.WinForms.TwainPro5 Namespace > ScannedImage Class : ToHbitmap Method

Gets a handle to a bitmap.

[Visual Basic]
Public Function ToHbitmap() As IntPtr
[C#]
public IntPtr ToHbitmap();
[C++]
public: IntPtr ToHbitmap();
[C++/CLI]
public:
IntPtr ToHbitmap();

Return Type

An HBITMAP (handle to a BITMAP).

Remarks

When accessed, the image is released from the ScannedImage object.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

ScannedImage Class | ScannedImage Members


ToHdib Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImage Class | ScannedImage Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ToHdib Method

PegasusImaging.WinForms.TwainPro5 Namespace > ScannedImage Class : ToHdib Method

Gets a handle to a DIB.

[Visual Basic]
Public Function ToHdib() As IntPtr
[C#]
public IntPtr ToHdib();
[C++]
public: IntPtr ToHdib();
[C++/CLI]
public:
IntPtr ToHdib();

Return Type

An HDIB (handle to a DIB).

Remarks

When accessed, the image is released from the ScannedImage object.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

ScannedImage Class | ScannedImage Members


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImage Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ScannedImage Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : ScannedImage Class (PegasusImaging.WinForms.TwainPro5)

For a list of all members of this type, see ScannedImage members.

Public Properties

Public Property ScannedImageData Gets the ScannedImageData properties.

See Also

ScannedImage Class | PegasusImaging.WinForms.TwainPro5 Namespace


ScannedImageData Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImage Class | ScannedImage Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ScannedImageData Property

PegasusImaging.WinForms.TwainPro5 Namespace > ScannedImage Class : ScannedImageData Property (ScannedImage)

Gets the ScannedImageData properties.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property ScannedImageData As ScannedImageData
[C#]
[BrowsableAttribute(false)]
public ScannedImageData ScannedImageData {get;}
[C++]
[BrowsableAttribute(false)]
public: __property ScannedImageData* get_ScannedImageData();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property ScannedImageData^ ScannedImageData {
   ScannedImageData^ get();
}

Value

A ScannedImageData object which contains scanned image data property information.

Remarks

The default value is null.

Requirements

See Also

ScannedImage Class | ScannedImage Members


ScannedImageData Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImageData Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ScannedImageData Class

PegasusImaging.WinForms.TwainPro5 Namespace : ScannedImageData Class (PegasusImaging.WinForms.TwainPro5)

This class implements objects that contain the scanned image information.

For a list of all members of this type, see ScannedImageData members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.TwainPro5.ScannedImageData

Syntax

[Visual Basic]
Public Class ScannedImageData
[C#]
public class ScannedImageData
[C++]
public __gc class ScannedImageData
[C++/CLI]
public ref class ScannedImageData

Remarks

You cannot create a ScannedImageData object directly. The ScannedImageData is accessible as a parameter of the Scanning event or as a property of the ScannedImage which is accessible in the Scanned event.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

ScannedImageData Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImageData Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ScannedImageData Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : ScannedImageData Class (PegasusImaging.WinForms.TwainPro5)

ScannedImageData overview

Public Properties

Public Property BitsPerPixel | Gets the bits per pixel of the image.
Public Property Compression | Gets the compression of the image.
Public Property Height | Gets the height of the image.
Public Property PixelType | Gets the pixel type of the image.
Public Property ResolutionX | Gets the X resolution of the image.
Public Property ResolutionY | Gets the Y resolution of the image.
Public Property Width | Gets the width of the image.

Public Methods

Public Method Dispose Disposes of unmanaged resources.

See Also

ScannedImageData Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImageData Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ScannedImageData Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : ScannedImageData Class (PegasusImaging.WinForms.TwainPro5)

For a list of all members of this type, see ScannedImageData members.

Public Methods

Public Method Dispose Disposes of unmanaged resources.

See Also

ScannedImageData Class | PegasusImaging.WinForms.TwainPro5 Namespace


Dispose Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImageData Class | ScannedImageData Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.TwainPro5 Namespace > ScannedImageData Class : Dispose Method (ScannedImageData)

Disposes of unmanaged resources.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

Remarks

This method is part of the IDisposable interface.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

ScannedImageData Class | ScannedImageData Members


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImageData Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ScannedImageData Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : ScannedImageData Class (PegasusImaging.WinForms.TwainPro5)

For a list of all members of this type, see ScannedImageData members.

Public Properties

Public Property BitsPerPixel | Gets the bits per pixel of the image.
Public Property Compression | Gets the compression of the image.
Public Property Height | Gets the height of the image.
Public Property PixelType | Gets the pixel type of the image.
Public Property ResolutionX | Gets the X resolution of the image.
Public Property ResolutionY | Gets the Y resolution of the image.
Public Property Width | Gets the width of the image.

See Also

ScannedImageData Class | PegasusImaging.WinForms.TwainPro5 Namespace


BitsPerPixel Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImageData Class | ScannedImageData Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

BitsPerPixel Property

PegasusImaging.WinForms.TwainPro5 Namespace > ScannedImageData Class : BitsPerPixel Property

Gets the bits per pixel of the image.

[Visual Basic]
<DescriptionAttribute("Returns the bits per pixel of the image.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property BitsPerPixel As Integer
[C#]
[DescriptionAttribute("Returns the bits per pixel of the image.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public int BitsPerPixel {get;}
[C++]
[DescriptionAttribute("Returns the bits per pixel of the image.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property int get_BitsPerPixel();
[C++/CLI]
[DescriptionAttribute("Returns the bits per pixel of the image.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property int BitsPerPixel {
   int get();
}

Value

An integer value which represents the bits per pixel of the image.

Remarks

Note: This property is available at runtime and is read-only.

Requirements

See Also

ScannedImageData Class | ScannedImageData Members


Compression Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImageData Class | ScannedImageData Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Compression Property

PegasusImaging.WinForms.TwainPro5 Namespace > ScannedImageData Class : Compression Property (ScannedImageData)

Gets the compression of the image.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("Returns the compression of the image.")>
Public ReadOnly Property Compression As ScannedImageCompression
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Returns the compression of the image.")]
public ScannedImageCompression Compression {get;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Returns the compression of the image.")]
public: __property ScannedImageCompression get_Compression();
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Returns the compression of the image.")]
public:
property ScannedImageCompression Compression {
   ScannedImageCompression get();
}

Value

A ScannedImageCompression enumeration value which determines the compression of the image.

Remarks

Note: This property is available at runtime and is read-only.

TwcpNone means that the image is in an uncompressed DIB format and can be accessed through the ToHdib, ToBitmap, ToHbitmap, or SaveStream methods.

TwcpJpeg means that the image is in a JPEG format and should be accessed through the SaveStream method.

All other values mean that the image is in a TIFF format and should be accessed through the SaveStream method.

Requirements

See Also

ScannedImageData Class | ScannedImageData Members


Height Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImageData Class | ScannedImageData Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Height Property

PegasusImaging.WinForms.TwainPro5 Namespace > ScannedImageData Class : Height Property

Gets the height of the image.

[Visual Basic]
<BrowsableAttribute(False)>
<DescriptionAttribute("Returns the height of the image.")>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property Height As Integer
[C#]
[BrowsableAttribute(false)]
[DescriptionAttribute("Returns the height of the image.")]
[DesignerSerializationVisibilityAttribute()]
public int Height {get;}
[C++]
[BrowsableAttribute(false)]
[DescriptionAttribute("Returns the height of the image.")]
[DesignerSerializationVisibilityAttribute()]
public: __property int get_Height();
[C++/CLI]
[BrowsableAttribute(false)]
[DescriptionAttribute("Returns the height of the image.")]
[DesignerSerializationVisibilityAttribute()]
public:
property int Height {
   int get();
}

Value

An integer value which represents the height of the image.

Remarks

Note: Height is available at runtime and is read-only.

The Height units are determined by the ICAP_UNITS capability.

Requirements

See Also

ScannedImageData Class | ScannedImageData Members


PixelType Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImageData Class | ScannedImageData Members | PixelType Enumeration

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PixelType Property

PegasusImaging.WinForms.TwainPro5 Namespace > ScannedImageData Class : PixelType Property (ScannedImageData)

Gets the pixel type of the image.

[Visual Basic]
<BrowsableAttribute(False)>
<DescriptionAttribute("Returns the pixel type of the image.")>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property PixelType As PixelType
[C#]
[BrowsableAttribute(false)]
[DescriptionAttribute("Returns the pixel type of the image.")]
[DesignerSerializationVisibilityAttribute()]
public PixelType PixelType {get;}
[C++]
[BrowsableAttribute(false)]
[DescriptionAttribute("Returns the pixel type of the image.")]
[DesignerSerializationVisibilityAttribute()]
public: __property PixelType get_PixelType();
[C++/CLI]
[BrowsableAttribute(false)]
[DescriptionAttribute("Returns the pixel type of the image.")]
[DesignerSerializationVisibilityAttribute()]
public:
property PixelType PixelType {
   PixelType get();
}

Value

The PixelType enumeration value which determines the pixel type of the image.

Remarks

PixelType is available at runtime and is read-only.

Requirements

See Also

ScannedImageData Class | ScannedImageData Members | PixelType Enumeration


ResolutionX Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImageData Class | ScannedImageData Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ResolutionX Property

PegasusImaging.WinForms.TwainPro5 Namespace > ScannedImageData Class : ResolutionX Property

Gets the X resolution of the image.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<DescriptionAttribute("Returns the X resolution of the image.")>
Public ReadOnly Property ResolutionX As Single
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Returns the X resolution of the image.")]
public float ResolutionX {get;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Returns the X resolution of the image.")]
public: __property float get_ResolutionX();
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Returns the X resolution of the image.")]
public:
property float ResolutionX {
   float get();
}

Value

A float value which represents the x resolution of the image.

Remarks

Note: ResolutionX is available at runtime and is read-only.

The ResolutionX units are determined by the ICAP_UNITS capability.

Requirements

See Also

ScannedImageData Class | ScannedImageData Members


ResolutionY Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImageData Class | ScannedImageData Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ResolutionY Property

PegasusImaging.WinForms.TwainPro5 Namespace > ScannedImageData Class : ResolutionY Property

Gets the Y resolution of the image.

[Visual Basic]
<BrowsableAttribute(False)>
<DescriptionAttribute("Returns the Y resolution of the image.")>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property ResolutionY As Single
[C#]
[BrowsableAttribute(false)]
[DescriptionAttribute("Returns the Y resolution of the image.")]
[DesignerSerializationVisibilityAttribute()]
public float ResolutionY {get;}
[C++]
[BrowsableAttribute(false)]
[DescriptionAttribute("Returns the Y resolution of the image.")]
[DesignerSerializationVisibilityAttribute()]
public: __property float get_ResolutionY();
[C++/CLI]
[BrowsableAttribute(false)]
[DescriptionAttribute("Returns the Y resolution of the image.")]
[DesignerSerializationVisibilityAttribute()]
public:
property float ResolutionY {
   float get();
}

Value

A float value which represents the y resolution of the image.

Remarks

Note: ResolutionY is available at runtime and is read-only.

The ResolutionY units are determined by the ICAP_UNITS capability.

Requirements

See Also

ScannedImageData Class | ScannedImageData Members


Width Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScannedImageData Class | ScannedImageData Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Width Property

PegasusImaging.WinForms.TwainPro5 Namespace > ScannedImageData Class : Width Property

Gets the width of the image.

[Visual Basic]
<DescriptionAttribute("Returns the width of the image.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property Width As Integer
[C#]
[DescriptionAttribute("Returns the width of the image.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public int Width {get;}
[C++]
[DescriptionAttribute("Returns the width of the image.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property int get_Width();
[C++/CLI]
[DescriptionAttribute("Returns the width of the image.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property int Width {
   int get();
}

Value

An integer value which represents the width of the image.

Remarks

Note: Width is available at runtime and is read-only.

The Width units are determined by the ICAP_UNITS capability.

Requirements

See Also

ScannedImageData Class | ScannedImageData Members


ScanningEventArgs Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScanningEventArgs Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ScanningEventArgs Class

PegasusImaging.WinForms.TwainPro5 Namespace : ScanningEventArgs Class

Arguments for a scanning event.

For a list of all members of this type, see ScanningEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.TwainPro5.ScanningEventArgs

Syntax

[Visual Basic]
Public Class ScanningEventArgs
   Inherits EventArgs
[C#]
public class ScanningEventArgs : EventArgs
[C++]
public __gc class ScanningEventArgs : public EventArgs
[C++/CLI]
public ref class ScanningEventArgs : public EventArgs

Remarks

This class provides the communication between the object that issued a scanning event and the object that handles the event.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

ScanningEventArgs Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScanningEventArgs Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ScanningEventArgs Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : ScanningEventArgs Class

ScanningEventArgs overview

Public Constructors

Public Constructor ScanningEventArgs Constructor

Public Properties

Public Property Cancel | Gets and sets an indicator whether to cancel the session.
Public Property PendingTransfers | Gets and sets the number of image transfers the TWAIN Data Source is ready to supply to the TwainPRO control.
Public Property ScannedImageData | Gets and sets the scanned image information.

See Also

ScanningEventArgs Class | PegasusImaging.WinForms.TwainPro5 Namespace


ScanningEventArgs Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScanningEventArgs Class | ScanningEventArgs Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ScanningEventArgs Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > ScanningEventArgs Class : ScanningEventArgs Constructor (ScanningEventArgs)
[Visual Basic]
Public Function New()
[C#]
public ScanningEventArgs();
[C++]
public: ScanningEventArgs();
[C++/CLI]
public:
ScanningEventArgs();

Requirements

See Also

ScanningEventArgs Class | ScanningEventArgs Members


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScanningEventArgs Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ScanningEventArgs Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : ScanningEventArgs Class

For a list of all members of this type, see ScanningEventArgs members.

Public Properties

Public Property Cancel | Gets and sets an indicator whether to cancel the session.
Public Property PendingTransfers | Gets and sets the number of image transfers the TWAIN Data Source is ready to supply to the TwainPRO control.
Public Property ScannedImageData | Gets and sets the scanned image information.

See Also

ScanningEventArgs Class | PegasusImaging.WinForms.TwainPro5 Namespace


Cancel Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScanningEventArgs Class | ScanningEventArgs Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Cancel Property

PegasusImaging.WinForms.TwainPro5 Namespace > ScanningEventArgs Class : Cancel Property (ScanningEventArgs)

Gets and sets an indicator whether to cancel the session.

[Visual Basic]
Public Property Cancel As Boolean
[C#]
public bool Cancel {get; set;}
[C++]
public: __property bool get_Cancel();
public: __property void set_Cancel(
   bool value
);
[C++/CLI]
public:
property bool Cancel {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to cancel the session. Otherwise, false should be used.

Remarks

If set to true, the session ends and the StartSession method returns control.

Requirements

See Also

ScanningEventArgs Class | ScanningEventArgs Members


PendingTransfers Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScanningEventArgs Class | ScanningEventArgs Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PendingTransfers Property

PegasusImaging.WinForms.TwainPro5 Namespace > ScanningEventArgs Class : PendingTransfers Property (ScanningEventArgs)

Gets and sets the number of image transfers the TWAIN Data Source is ready to supply to the TwainPRO control.

[Visual Basic]
Public ReadOnly Property PendingTransfers As Integer
[C#]
public int PendingTransfers {get;}
[C++]
public: __property int get_PendingTransfers();
[C++/CLI]
public:
property int PendingTransfers {
   int get();
}

Value

An integer value which represents the pending transfers.

Remarks

The default value is 0.

The TWAIN Data Source will return -1 if it is not sure how many transfers are pending. Scanners with Automatic Document Feeders (ADF) will typically return -1.

Requirements

See Also

ScanningEventArgs Class | ScanningEventArgs Members


ScannedImageData Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ScanningEventArgs Class | ScanningEventArgs Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ScannedImageData Property

PegasusImaging.WinForms.TwainPro5 Namespace > ScanningEventArgs Class : ScannedImageData Property (ScanningEventArgs)

Gets and sets the scanned image information.

[Visual Basic]
Public Property ScannedImageData As ScannedImageData
[C#]
public ScannedImageData ScannedImageData {get; set;}
[C++]
public: __property ScannedImageData* get_ScannedImageData();
public: __property void set_ScannedImageData(
   ScannedImageData* value
);
[C++/CLI]
public:
property ScannedImageData^ ScannedImageData {
   ScannedImageData^ get();
   void set (ScannedImageData^ value);
}

Value

A ScannedImageData object which contains image information.

Remarks

The default value is null.

Requirements

See Also

ScanningEventArgs Class | ScanningEventArgs Members


SequenceException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SequenceException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SequenceException Class

PegasusImaging.WinForms.TwainPro5 Namespace : SequenceException Class

This exception is thrown if an illegal operation is performed for the current Source Manager or Source state.

For a list of all members of this type, see SequenceException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.SequenceException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class SequenceException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class SequenceException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class SequenceException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class SequenceException sealed : public TwainProException

Remarks

The requested action cannot be performed in the current state of the TWAIN session.

Possible causes:

Certain methods and properties are only valid during certain states.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

SequenceException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SequenceException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SequenceException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : SequenceException Class

SequenceException overview

Public Constructors

Public Constructor SequenceException Constructor Overloaded. An exception generated for a sequence error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

SequenceException Class | PegasusImaging.WinForms.TwainPro5 Namespace


SequenceException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SequenceException Class | SequenceException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SequenceException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > SequenceException Class : SequenceException Constructor (SequenceException)

An exception generated for a sequence error.

Overload List

An exception generated for a sequence error.

[Visual Basic] Public Sub New()

[C#] public SequenceException();

[C++] public SequenceException();

[C++/CLI] public SequenceException();

Generated exception for a sequence error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public SequenceException(int);

[C++] public SequenceException(int);

[C++/CLI] public SequenceException(int);

Generated exception for a sequence error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public SequenceException(string);

[C++] public SequenceException(string*);

[C++/CLI] public SequenceException(String^);

Generated exception for a sequence error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public SequenceException(int,string);

[C++] public SequenceException(int,string*);

[C++/CLI] public SequenceException(int,String^);

Generated exception for a sequence error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public SequenceException(string,Exception);

[C++] public SequenceException(string*,Exception*);

[C++/CLI] public SequenceException(String^,Exception^);

Requirements

See Also

SequenceException Class | SequenceException Members


SequenceException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SequenceException Class | SequenceException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SequenceException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > SequenceException Class > SequenceException Constructor : SequenceException Constructor()

An exception generated for a sequence error.

[Visual Basic]
Public Function New()
[C#]
public SequenceException();
[C++]
public: SequenceException();
[C++/CLI]
public:
SequenceException();

Requirements

See Also

SequenceException Class | SequenceException Members | Overload List


SequenceException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SequenceException Class | SequenceException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SequenceException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > SequenceException Class > SequenceException Constructor : SequenceException Constructor(Int32)

Generated exception for a sequence error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public SequenceException(
   int errorNumber
);
[C++]
public: SequenceException(
   int errorNumber
)
[C++/CLI]
public:
SequenceException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

SequenceException Class | SequenceException Members | Overload List


SequenceException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SequenceException Class | SequenceException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SequenceException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > SequenceException Class > SequenceException Constructor : SequenceException Constructor(Int32,String)

Generated exception for a sequence error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public SequenceException(
   int errorNumber,
   string message
);
[C++]
public: SequenceException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
SequenceException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

SequenceException Class | SequenceException Members | Overload List


SequenceException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SequenceException Class | SequenceException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SequenceException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > SequenceException Class > SequenceException Constructor : SequenceException Constructor(String)

Generated exception for a sequence error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public SequenceException(
   string message
);
[C++]
public: SequenceException(
   string* message
)
[C++/CLI]
public:
SequenceException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

SequenceException Class | SequenceException Members | Overload List


SequenceException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SequenceException Class | SequenceException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SequenceException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > SequenceException Class > SequenceException Constructor : SequenceException Constructor(String,Exception)

Generated exception for a sequence error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public SequenceException(
   string message,
   Exception innerException
);
[C++]
public: SequenceException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
SequenceException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

SequenceException Class | SequenceException Members | Overload List


StringIsTooLongException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

StringIsTooLongException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

StringIsTooLongException Class

PegasusImaging.WinForms.TwainPro5 Namespace : StringIsTooLongException Class

This exception is thrown if a TwainPRO property was set to a string with too many characters.

For a list of all members of this type, see StringIsTooLongException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.StringIsTooLongException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class StringIsTooLongException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class StringIsTooLongException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class StringIsTooLongException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class StringIsTooLongException sealed : public TwainProException

Remarks

Possible causes:

The application identity properties can accept a maximum length of 32 characters.

The SaveOptionsPic.Password property can accept a maximum length of 8 characters.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

StringIsTooLongException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

StringIsTooLongException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

StringIsTooLongException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : StringIsTooLongException Class

StringIsTooLongException overview

Public Constructors

Public Constructor StringIsTooLongException Constructor Overloaded. An exception generated for a string is too long error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

StringIsTooLongException Class | PegasusImaging.WinForms.TwainPro5 Namespace


StringIsTooLongException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

StringIsTooLongException Class | StringIsTooLongException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

StringIsTooLongException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > StringIsTooLongException Class : StringIsTooLongException Constructor (StringIsTooLongException)

An exception generated for a string is too long error.

Overload List

An exception generated for a string is too long error.

[Visual Basic] Public Sub New()

[C#] public StringIsTooLongException();

[C++] public StringIsTooLongException();

[C++/CLI] public StringIsTooLongException();

Generated exception for a string is too long error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public StringIsTooLongException(int);

[C++] public StringIsTooLongException(int);

[C++/CLI] public StringIsTooLongException(int);

Generated exception for a string is too long error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public StringIsTooLongException(string);

[C++] public StringIsTooLongException(string*);

[C++/CLI] public StringIsTooLongException(String^);

Generated exception for a string is too long error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public StringIsTooLongException(int,string);

[C++] public StringIsTooLongException(int,string*);

[C++/CLI] public StringIsTooLongException(int,String^);

Generated exception for a string is too long error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public StringIsTooLongException(string,Exception);

[C++] public StringIsTooLongException(string*,Exception*);

[C++/CLI] public StringIsTooLongException(String^,Exception^);

Requirements

See Also

StringIsTooLongException Class | StringIsTooLongException Members


StringIsTooLongException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

StringIsTooLongException Class | StringIsTooLongException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

StringIsTooLongException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > StringIsTooLongException Class > StringIsTooLongException Constructor : StringIsTooLongException Constructor()

An exception generated for a string is too long error.

[Visual Basic]
Public Function New()
[C#]
public StringIsTooLongException();
[C++]
public: StringIsTooLongException();
[C++/CLI]
public:
StringIsTooLongException();

Requirements

See Also

StringIsTooLongException Class | StringIsTooLongException Members | Overload List


StringIsTooLongException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

StringIsTooLongException Class | StringIsTooLongException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

StringIsTooLongException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > StringIsTooLongException Class > StringIsTooLongException Constructor : StringIsTooLongException Constructor(Int32)

Generated exception for a string is too long error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public StringIsTooLongException(
   int errorNumber
);
[C++]
public: StringIsTooLongException(
   int errorNumber
)
[C++/CLI]
public:
StringIsTooLongException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

StringIsTooLongException Class | StringIsTooLongException Members | Overload List


StringIsTooLongException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

StringIsTooLongException Class | StringIsTooLongException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

StringIsTooLongException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > StringIsTooLongException Class > StringIsTooLongException Constructor : StringIsTooLongException Constructor(Int32,String)

Generated exception for a string is too long error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public StringIsTooLongException(
   int errorNumber,
   string message
);
[C++]
public: StringIsTooLongException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
StringIsTooLongException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

StringIsTooLongException Class | StringIsTooLongException Members | Overload List


StringIsTooLongException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

StringIsTooLongException Class | StringIsTooLongException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

StringIsTooLongException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > StringIsTooLongException Class > StringIsTooLongException Constructor : StringIsTooLongException Constructor(String)

Generated exception for a string is too long error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public StringIsTooLongException(
   string message
);
[C++]
public: StringIsTooLongException(
   string* message
)
[C++/CLI]
public:
StringIsTooLongException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

StringIsTooLongException Class | StringIsTooLongException Members | Overload List


StringIsTooLongException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

StringIsTooLongException Class | StringIsTooLongException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

StringIsTooLongException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > StringIsTooLongException Class > StringIsTooLongException Constructor : StringIsTooLongException Constructor(String,Exception)

Generated exception for a string is too long error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public StringIsTooLongException(
   string message,
   Exception innerException
);
[C++]
public: StringIsTooLongException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
StringIsTooLongException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

StringIsTooLongException Class | StringIsTooLongException Members | Overload List


TiffTagItemNotFoundException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TiffTagItemNotFoundException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TiffTagItemNotFoundException Class

PegasusImaging.WinForms.TwainPro5 Namespace : TiffTagItemNotFoundException Class

This exception is thrown if a TIFF tag item is not found.

For a list of all members of this type, see TiffTagItemNotFoundException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.TiffTagItemNotFoundException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class TiffTagItemNotFoundException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class TiffTagItemNotFoundException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class TiffTagItemNotFoundException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class TiffTagItemNotFoundException sealed : public TwainProException

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

TiffTagItemNotFoundException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TiffTagItemNotFoundException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TiffTagItemNotFoundException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : TiffTagItemNotFoundException Class

TiffTagItemNotFoundException overview

Public Constructors

Public Constructor TiffTagItemNotFoundException Constructor Overloaded. An exception generated for a TIFF tag item not found error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TiffTagItemNotFoundException Class | PegasusImaging.WinForms.TwainPro5 Namespace


TiffTagItemNotFoundException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TiffTagItemNotFoundException Class | TiffTagItemNotFoundException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TiffTagItemNotFoundException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > TiffTagItemNotFoundException Class : TiffTagItemNotFoundException Constructor (TiffTagItemNotFoundException)

An exception generated for a TIFF tag item not found error.

Overload List

An exception generated for a TIFF tag item not found error.

[Visual Basic] Public Sub New()

[C#] public TiffTagItemNotFoundException();

[C++] public TiffTagItemNotFoundException();

[C++/CLI] public TiffTagItemNotFoundException();

Generated exception for a TIFF tag item not found error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public TiffTagItemNotFoundException(int);

[C++] public TiffTagItemNotFoundException(int);

[C++/CLI] public TiffTagItemNotFoundException(int);

Generated exception for a TIFF tag item not found error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public TiffTagItemNotFoundException(string);

[C++] public TiffTagItemNotFoundException(string*);

[C++/CLI] public TiffTagItemNotFoundException(String^);

Generated exception for a TIFF tag item not found error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public TiffTagItemNotFoundException(int,string);

[C++] public TiffTagItemNotFoundException(int,string*);

[C++/CLI] public TiffTagItemNotFoundException(int,String^);

Generated exception for a TIFF tag item not found error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public TiffTagItemNotFoundException(string,Exception);

[C++] public TiffTagItemNotFoundException(string*,Exception*);

[C++/CLI] public TiffTagItemNotFoundException(String^,Exception^);

Requirements

See Also

TiffTagItemNotFoundException Class | TiffTagItemNotFoundException Members


TiffTagItemNotFoundException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TiffTagItemNotFoundException Class | TiffTagItemNotFoundException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TiffTagItemNotFoundException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > TiffTagItemNotFoundException Class > TiffTagItemNotFoundException Constructor : TiffTagItemNotFoundException Constructor()

An exception generated for a TIFF tag item not found error.

[Visual Basic]
Public Function New()
[C#]
public TiffTagItemNotFoundException();
[C++]
public: TiffTagItemNotFoundException();
[C++/CLI]
public:
TiffTagItemNotFoundException();

Requirements

See Also

TiffTagItemNotFoundException Class | TiffTagItemNotFoundException Members | Overload List


TiffTagItemNotFoundException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TiffTagItemNotFoundException Class | TiffTagItemNotFoundException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TiffTagItemNotFoundException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > TiffTagItemNotFoundException Class > TiffTagItemNotFoundException Constructor : TiffTagItemNotFoundException Constructor(Int32)

Generated exception for a TIFF tag item not found error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public TiffTagItemNotFoundException(
   int errorNumber
);
[C++]
public: TiffTagItemNotFoundException(
   int errorNumber
)
[C++/CLI]
public:
TiffTagItemNotFoundException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

TiffTagItemNotFoundException Class | TiffTagItemNotFoundException Members | Overload List


TiffTagItemNotFoundException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TiffTagItemNotFoundException Class | TiffTagItemNotFoundException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TiffTagItemNotFoundException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > TiffTagItemNotFoundException Class > TiffTagItemNotFoundException Constructor : TiffTagItemNotFoundException Constructor(Int32,String)

Generated exception for a TIFF tag item not found error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public TiffTagItemNotFoundException(
   int errorNumber,
   string message
);
[C++]
public: TiffTagItemNotFoundException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
TiffTagItemNotFoundException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

TiffTagItemNotFoundException Class | TiffTagItemNotFoundException Members | Overload List


TiffTagItemNotFoundException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TiffTagItemNotFoundException Class | TiffTagItemNotFoundException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TiffTagItemNotFoundException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > TiffTagItemNotFoundException Class > TiffTagItemNotFoundException Constructor : TiffTagItemNotFoundException Constructor(String)

Generated exception for a TIFF tag item not found error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public TiffTagItemNotFoundException(
   string message
);
[C++]
public: TiffTagItemNotFoundException(
   string* message
)
[C++/CLI]
public:
TiffTagItemNotFoundException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

TiffTagItemNotFoundException Class | TiffTagItemNotFoundException Members | Overload List


TiffTagItemNotFoundException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TiffTagItemNotFoundException Class | TiffTagItemNotFoundException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TiffTagItemNotFoundException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > TiffTagItemNotFoundException Class > TiffTagItemNotFoundException Constructor : TiffTagItemNotFoundException Constructor(String,Exception)

Generated exception for a TIFF tag item not found error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public TiffTagItemNotFoundException(
   string message,
   Exception innerException
);
[C++]
public: TiffTagItemNotFoundException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
TiffTagItemNotFoundException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

TiffTagItemNotFoundException Class | TiffTagItemNotFoundException Members | Overload List


TiffTagNotFoundException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TiffTagNotFoundException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TiffTagNotFoundException Class

PegasusImaging.WinForms.TwainPro5 Namespace : TiffTagNotFoundException Class

This exception is thrown if a TIFF tag is not found.

For a list of all members of this type, see TiffTagNotFoundException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.TiffTagNotFoundException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class TiffTagNotFoundException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class TiffTagNotFoundException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class TiffTagNotFoundException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class TiffTagNotFoundException sealed : public TwainProException

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

TiffTagNotFoundException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TiffTagNotFoundException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TiffTagNotFoundException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : TiffTagNotFoundException Class

TiffTagNotFoundException overview

Public Constructors

Public Constructor TiffTagNotFoundException Constructor Overloaded. An exception generated for a TIFF tag not found error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TiffTagNotFoundException Class | PegasusImaging.WinForms.TwainPro5 Namespace


TiffTagNotFoundException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TiffTagNotFoundException Class | TiffTagNotFoundException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TiffTagNotFoundException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > TiffTagNotFoundException Class : TiffTagNotFoundException Constructor (TiffTagNotFoundException)

An exception generated for a TIFF tag not found error.

Overload List

An exception generated for a TIFF tag not found error.

[Visual Basic] Public Sub New()

[C#] public TiffTagNotFoundException();

[C++] public TiffTagNotFoundException();

[C++/CLI] public TiffTagNotFoundException();

Generated exception for a TIFF tag not found error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public TiffTagNotFoundException(int);

[C++] public TiffTagNotFoundException(int);

[C++/CLI] public TiffTagNotFoundException(int);

Generated exception for a TIFF tag not found error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public TiffTagNotFoundException(string);

[C++] public TiffTagNotFoundException(string*);

[C++/CLI] public TiffTagNotFoundException(String^);

Generated exception for a TIFF tag not found error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public TiffTagNotFoundException(int,string);

[C++] public TiffTagNotFoundException(int,string*);

[C++/CLI] public TiffTagNotFoundException(int,String^);

Generated exception for a TIFF tag not found error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public TiffTagNotFoundException(string,Exception);

[C++] public TiffTagNotFoundException(string*,Exception*);

[C++/CLI] public TiffTagNotFoundException(String^,Exception^);

Requirements

See Also

TiffTagNotFoundException Class | TiffTagNotFoundException Members


TiffTagNotFoundException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TiffTagNotFoundException Class | TiffTagNotFoundException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TiffTagNotFoundException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > TiffTagNotFoundException Class > TiffTagNotFoundException Constructor : TiffTagNotFoundException Constructor()

An exception generated for a TIFF tag not found error.

[Visual Basic]
Public Function New()
[C#]
public TiffTagNotFoundException();
[C++]
public: TiffTagNotFoundException();
[C++/CLI]
public:
TiffTagNotFoundException();

Requirements

See Also

TiffTagNotFoundException Class | TiffTagNotFoundException Members | Overload List


TiffTagNotFoundException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TiffTagNotFoundException Class | TiffTagNotFoundException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TiffTagNotFoundException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > TiffTagNotFoundException Class > TiffTagNotFoundException Constructor : TiffTagNotFoundException Constructor(Int32)

Generated exception for a TIFF tag not found error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public TiffTagNotFoundException(
   int errorNumber
);
[C++]
public: TiffTagNotFoundException(
   int errorNumber
)
[C++/CLI]
public:
TiffTagNotFoundException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

TiffTagNotFoundException Class | TiffTagNotFoundException Members | Overload List


TiffTagNotFoundException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TiffTagNotFoundException Class | TiffTagNotFoundException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TiffTagNotFoundException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > TiffTagNotFoundException Class > TiffTagNotFoundException Constructor : TiffTagNotFoundException Constructor(Int32,String)

Generated exception for a TIFF tag not found error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public TiffTagNotFoundException(
   int errorNumber,
   string message
);
[C++]
public: TiffTagNotFoundException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
TiffTagNotFoundException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

TiffTagNotFoundException Class | TiffTagNotFoundException Members | Overload List


TiffTagNotFoundException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TiffTagNotFoundException Class | TiffTagNotFoundException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TiffTagNotFoundException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > TiffTagNotFoundException Class > TiffTagNotFoundException Constructor : TiffTagNotFoundException Constructor(String)

Generated exception for a TIFF tag not found error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public TiffTagNotFoundException(
   string message
);
[C++]
public: TiffTagNotFoundException(
   string* message
)
[C++/CLI]
public:
TiffTagNotFoundException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

TiffTagNotFoundException Class | TiffTagNotFoundException Members | Overload List


TiffTagNotFoundException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TiffTagNotFoundException Class | TiffTagNotFoundException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TiffTagNotFoundException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > TiffTagNotFoundException Class > TiffTagNotFoundException Constructor : TiffTagNotFoundException Constructor(String,Exception)

Generated exception for a TIFF tag not found error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public TiffTagNotFoundException(
   string message,
   Exception innerException
);
[C++]
public: TiffTagNotFoundException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
TiffTagNotFoundException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

TiffTagNotFoundException Class | TiffTagNotFoundException Members | Overload List


TwainDevice Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainDevice Class

PegasusImaging.WinForms.TwainPro5 Namespace : TwainDevice Class

This class implements methods and properties for all TWAIN device interaction.

For a list of all members of this type, see TwainDevice members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.TwainPro5.TwainDevice

Syntax

[Visual Basic]
Public Class TwainDevice
[C#]
public class TwainDevice
[C++]
public __gc class TwainDevice
[C++/CLI]
public ref class TwainDevice

Remarks

Use this object to perform all of the TWAIN tasks of this component.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

TwainDevice Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainDevice Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : TwainDevice Class

TwainDevice overview

Public Constructors

Public Constructor TwainDevice Constructor Initializes the TwainPro component and passes in a workspace ID.

Public Properties

Public Property ApplicationIdentity | Returns the ApplicationIdentity properties.
Public Property Caption | Returns the Caption properties.
Public Property CloseOnCancel | Specifies whether the TWAIN User Interface should be closed when the operation is cancelled.
Public Property EnableExtendedCapabilities | Enables the extended capabilities CAP_FEEDPAGE and CAP_CLEARPAGE.
Public Property ImageLayout | Gets or sets the Image Layout rectangle for the current Data Source.
Public Property MaximumImages | Gets or sets the maximum number of images expected from a TWAIN Data Source that supports multiple image scanning.
Public Property ShowUserInterface | Gets or sets the Data Source User Interface flag.
Public Property TransferMode | Gets or sets the transfer mode for scanning.

Public Methods

Public Method CloseSession | Disables and closes the current Data Source and Data Source Manager. For every OpenSession or OpenDataSourceManager method call you need to close the TwainPRO session with CloseSession. This method will also Cancel any pending image transfers if the Data Source was in the Image Transfer state.
Public Method DisplayUserInterface | Displays the User Interface.
Public Method Dispose | Disposes of unmanaged resources.
Public Method GetCapability | Overloaded. Returns a CapabilityContainer with information for the specified capability.
Public Method GetCapabilityConstantDescription | Returns a description of a constant for the current capability. This is a runtime, read-only property.
Public Method IsCapabilitySupported | Overloaded. Determines if the current capability is supported by the TWAIN device.
Public Method LoadSettings | Loads the scanner settings from file.
Public Method OpenDataSourceManager | Opens the Source Manager. Use this method only to set the Data Source without using the SelectSource method.
Public Method OpenSession | Opens the Data Source Manager and Data Source, placing TwainPRO into the Capability Negotiation state.
Public Method SaveSettings | Saves the scanner settings to file.
Public Method SelectSource | Displays the TWAIN Data Source Manager's Source Selection User Interface (UI) so the user can choose which Data Source is the current Source.
Public Method SetCapability | Sets a TWAIN capability using the specified values.
Public Method StartSession | Enables the Current Data Source and places it into the Image Transfer state. Displays the Data Source User Interface if ShowUserInterface is True. This method will return when the user closes the UI if the ShowUserInterface property is True or after the image transfer if ShowUserInterface is False.

Public Events

Public Event Scanned | Use this event to receive ScannedEventArgs information about the event.
Public Event Scanning | Use this event to receive ScanningEventArgs information about the event.

See Also

TwainDevice Class | PegasusImaging.WinForms.TwainPro5 Namespace


TwainDevice Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

workspace
A TwainPro workspace ID.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainDevice Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class : TwainDevice Constructor (TwainDevice)

Initializes the TwainPro component and passes in a workspace ID.

[Visual Basic]
Public Function New( _
   ByVal workspace As TwainPro _
)
[C#]
public TwainDevice(
   TwainPro workspace
);
[C++]
public: TwainDevice(
   TwainPro* workspace
)
[C++/CLI]
public:
TwainDevice(
   TwainPro^ workspace
)

Parameters

workspace
A TwainPro workspace ID.

Requirements

See Also

TwainDevice Class | TwainDevice Members


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainDevice Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : TwainDevice Class

For a list of all members of this type, see TwainDevice members.

Public Methods

Public Method CloseSession | Disables and closes the current Data Source and Data Source Manager. For every OpenSession or OpenDataSourceManager method call you need to close the TwainPRO session with CloseSession. This method will also Cancel any pending image transfers if the Data Source was in the Image Transfer state.
Public Method DisplayUserInterface | Displays the User Interface.
Public Method Dispose | Disposes of unmanaged resources.
Public Method GetCapability | Overloaded. Returns a CapabilityContainer with information for the specified capability.
Public Method GetCapabilityConstantDescription | Returns a description of a constant for the current capability. This is a runtime, read-only property.
Public Method IsCapabilitySupported | Overloaded. Determines if the current capability is supported by the TWAIN device.
Public Method LoadSettings | Loads the scanner settings from file.
Public Method OpenDataSourceManager | Opens the Source Manager. Use this method only to set the Data Source without using the SelectSource method.
Public Method OpenSession | Opens the Data Source Manager and Data Source, placing TwainPRO into the Capability Negotiation state.
Public Method SaveSettings | Saves the scanner settings to file.
Public Method SelectSource | Displays the TWAIN Data Source Manager's Source Selection User Interface (UI) so the user can choose which Data Source is the current Source.
Public Method SetCapability | Sets a TWAIN capability using the specified values.
Public Method StartSession | Enables the Current Data Source and places it into the Image Transfer state. Displays the Data Source User Interface if ShowUserInterface is True. This method will return when the user closes the UI if the ShowUserInterface property is True or after the image transfer if ShowUserInterface is False.

See Also

TwainDevice Class | PegasusImaging.WinForms.TwainPro5 Namespace


CloseSession Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CloseSession Method

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class : CloseSession Method

Disables and closes the current Data Source and Data Source Manager. For every OpenSession or OpenDataSourceManager method call you need to close the TwainPRO session with CloseSession. This method will also Cancel any pending image transfers if the Data Source was in the Image Transfer state.

[Visual Basic]
Public Sub CloseSession()
[C#]
public void CloseSession();
[C++]
public: void CloseSession();
[C++/CLI]
public:
void CloseSession();

Remarks

It is not necessary to call CloseSession after StartSession as this method calls it internally before returning.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

TwainDevice Class | TwainDevice Members


DisplayUserInterface Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

DisplayUserInterface Method

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class : DisplayUserInterface Method

Displays the User Interface.

[Visual Basic]
Public Sub DisplayUserInterface()
[C#]
public void DisplayUserInterface();
[C++]
public: void DisplayUserInterface();
[C++/CLI]
public:
void DisplayUserInterface();

Remarks

Displays the Data Source's User Interface so the user can manipulate scanner settings but not acquire an image at this time.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

TwainDevice Class | TwainDevice Members


Dispose Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class : Dispose Method (TwainDevice)

Disposes of unmanaged resources.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

Remarks

This method is part of the IDisposable interface.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

TwainDevice Class | TwainDevice Members


GetCapability Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

GetCapability Method

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class : GetCapability Method

Returns a CapabilityContainer with information for the specified capability.

Overload List

Returns a CapabilityContainer with information for the specified capability.

[Visual Basic] Overloads Public Function GetCapability(Capability) As CapabilityContainer

[C#] public CapabilityContainer GetCapability(Capability);

[C++] public CapabilityContainer* GetCapability(Capability);

[C++/CLI] public CapabilityContainer^ GetCapability(Capability);

Returns a CapabilityContainer with information for the specified capability.

[Visual Basic] Overloads Public Function GetCapability(AdvancedCapability) As CapabilityContainer

[C#] public CapabilityContainer GetCapability(AdvancedCapability);

[C++] public CapabilityContainer* GetCapability(AdvancedCapability);

[C++/CLI] public CapabilityContainer^ GetCapability(AdvancedCapability);

Returns a CapabilityContainer with information for the specified capability.

[Visual Basic] Overloads Public Function GetCapability(Integer) As CapabilityContainer

[C#] public CapabilityContainer GetCapability(int);

[C++] public CapabilityContainer* GetCapability(int);

[C++/CLI] public CapabilityContainer^ GetCapability(int);

Remarks

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

TwainDevice Class | TwainDevice Members


GetCapability(Capability) Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

capability
The capability in which to retrieve the information
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

GetCapability(Capability) Method

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class > GetCapability Method : GetCapability(Capability) Method

Returns a CapabilityContainer with information for the specified capability.

[Visual Basic]
Overloads Public Function GetCapability( _
   ByVal capability As Capability _
) As CapabilityContainer
[C#]
public CapabilityContainer GetCapability(
   Capability capability
);
[C++]
public: CapabilityContainer* GetCapability(
   Capability capability
)
[C++/CLI]
public:
CapabilityContainer^ GetCapability(
   Capability capability
)

Parameters

capability
The capability in which to retrieve the information

Return Type

A CapabilityContainer object

Remarks

This method will return a CapabilityContainerOneValue, CapabilityContainerEnum, CapabilityContainerRange, or CapabilityContainerArray object of type CapabilityContainer which can be casted to the appropriate child object to access the capability information.

Requirements

See Also

TwainDevice Class | TwainDevice Members | Overload List


GetCapability(AdvancedCapability) Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

capability
The capability in which to retrieve the information
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

GetCapability(AdvancedCapability) Method

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class > GetCapability Method : GetCapability(AdvancedCapability) Method

Returns a CapabilityContainer with information for the specified capability.

[Visual Basic]
Overloads Public Function GetCapability( _
   ByVal capability As AdvancedCapability _
) As CapabilityContainer
[C#]
public CapabilityContainer GetCapability(
   AdvancedCapability capability
);
[C++]
public: CapabilityContainer* GetCapability(
   AdvancedCapability capability
)
[C++/CLI]
public:
CapabilityContainer^ GetCapability(
   AdvancedCapability capability
)

Parameters

capability
The capability in which to retrieve the information

Return Type

A CapabilityContainer object

Remarks

This method will return a CapabilityContainerOneValue, CapabilityContainerEnum, CapabilityContainerRange, or CapabilityContainerArray object of type CapabilityContainer which can be casted to the appropriate child object to access the capability information.

Requirements

See Also

TwainDevice Class | TwainDevice Members | Overload List


GetCapability(Int32) Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

capability
The capability in which to retrieve the information
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

GetCapability(Int32) Method

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class > GetCapability Method : GetCapability(Int32) Method

Returns a CapabilityContainer with information for the specified capability.

[Visual Basic]
Overloads Public Function GetCapability( _
   ByVal capability As Integer _
) As CapabilityContainer
[C#]
public CapabilityContainer GetCapability(
   int capability
);
[C++]
public: CapabilityContainer* GetCapability(
   int capability
)
[C++/CLI]
public:
CapabilityContainer^ GetCapability(
   int capability
)

Parameters

capability
The capability in which to retrieve the information

Return Type

A CapabilityContainer object

Remarks

This method will return a CapabilityContainerOneValue, CapabilityContainerEnum, CapabilityContainerRange, or CapabilityContainerArray object of type CapabilityContainer which can be casted to the appropriate child object to access the capability information.

Requirements

See Also

TwainDevice Class | TwainDevice Members | Overload List


GetCapabilityConstantDescription Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

capability
A Capability.
index
The index of the Capability constant.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

GetCapabilityConstantDescription Method

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class : GetCapabilityConstantDescription Method

Returns a description of a constant for the current capability. This is a runtime, read-only property.

[Visual Basic]
Public Function GetCapabilityConstantDescription( _
   ByVal capability As Capability, _
   ByVal index As Integer _
) As String
[C#]
public string GetCapabilityConstantDescription(
   Capability capability,
   int index
);
[C++]
public: string* GetCapabilityConstantDescription(
   Capability capability,
   int index
)
[C++/CLI]
public:
String^ GetCapabilityConstantDescription(
   Capability capability,
   int index
)

Parameters

capability
A Capability.
index
The index of the Capability constant.

Return Type

A description of the specified Capability constant.

Remarks

When the capability type is TWCAP_ENUM, the Source may return a list of constants that signify settings.

For example, if Capability = ICAP_PIXELTYPE, and the Source returns a TWCAP_ENUM containing the constants, TwptBW (0), TwptGray (1), TwptRgb (2) a description of each may be obtained with the GetCapabilityConstantDescription method.

TwainPRO.GetCapabilityConstantDescription( Capability.IcapPixelType, (System.Int32)CapabilityConstants.TwptBW ) would return "Black and White". This can be used for filling a listbox or combobox with descriptions of available values instead of just the constants.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

TwainDevice Class | TwainDevice Members


IsCapabilitySupported Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

IsCapabilitySupported Method

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class : IsCapabilitySupported Method

Determines if the current capability is supported by the TWAIN device.

Overload List

Determines if the current capability is supported by the TWAIN device.

[Visual Basic] Overloads Public Function IsCapabilitySupported(Capability) As Boolean

[C#] public bool IsCapabilitySupported(Capability);

[C++] public bool IsCapabilitySupported(Capability);

[C++/CLI] public bool IsCapabilitySupported(Capability);

Determines if the current capability is supported by the TWAIN device.

[Visual Basic] Overloads Public Function IsCapabilitySupported(AdvancedCapability) As Boolean

[C#] public bool IsCapabilitySupported(AdvancedCapability);

[C++] public bool IsCapabilitySupported(AdvancedCapability);

[C++/CLI] public bool IsCapabilitySupported(AdvancedCapability);

Determines if the current capability is supported by the TWAIN device.

[Visual Basic] Overloads Public Function IsCapabilitySupported(Integer) As Boolean

[C#] public bool IsCapabilitySupported(int);

[C++] public bool IsCapabilitySupported(int);

[C++/CLI] public bool IsCapabilitySupported(int);

Remarks

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

TwainDevice Class | TwainDevice Members


IsCapabilitySupported(Capability) Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

capability
A TWAIN Capability
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

IsCapabilitySupported(Capability) Method

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class > IsCapabilitySupported Method : IsCapabilitySupported(Capability) Method

Determines if the current capability is supported by the TWAIN device.

[Visual Basic]
Overloads Public Function IsCapabilitySupported( _
   ByVal capability As Capability _
) As Boolean
[C#]
public bool IsCapabilitySupported(
   Capability capability
);
[C++]
public: bool IsCapabilitySupported(
   Capability capability
)
[C++/CLI]
public:
bool IsCapabilitySupported(
   Capability capability
)

Parameters

capability
A TWAIN Capability

Return Type

Whether or not the capability is supported

Remarks

This method should be checked before calling the GetCapability method. Attempting to get a capability that isn't supported will generate an error.

Requirements

See Also

TwainDevice Class | TwainDevice Members | Overload List


IsCapabilitySupported(AdvancedCapability) Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

capability
A TWAIN Capability
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

IsCapabilitySupported(AdvancedCapability) Method

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class > IsCapabilitySupported Method : IsCapabilitySupported(AdvancedCapability) Method

Determines if the current capability is supported by the TWAIN device.

[Visual Basic]
Overloads Public Function IsCapabilitySupported( _
   ByVal capability As AdvancedCapability _
) As Boolean
[C#]
public bool IsCapabilitySupported(
   AdvancedCapability capability
);
[C++]
public: bool IsCapabilitySupported(
   AdvancedCapability capability
)
[C++/CLI]
public:
bool IsCapabilitySupported(
   AdvancedCapability capability
)

Parameters

capability
A TWAIN Capability

Return Type

Whether or not the capability is supported

Remarks

This method should be checked before calling the GetCapability method. Attempting to get a capability that isn't supported will generate an error.

Requirements

See Also

TwainDevice Class | TwainDevice Members | Overload List


IsCapabilitySupported(Int32) Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

capability
A TWAIN Capability
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

IsCapabilitySupported(Int32) Method

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class > IsCapabilitySupported Method : IsCapabilitySupported(Int32) Method

Determines if the current capability is supported by the TWAIN device.

[Visual Basic]
Overloads Public Function IsCapabilitySupported( _
   ByVal capability As Integer _
) As Boolean
[C#]
public bool IsCapabilitySupported(
   int capability
);
[C++]
public: bool IsCapabilitySupported(
   int capability
)
[C++/CLI]
public:
bool IsCapabilitySupported(
   int capability
)

Parameters

capability
A TWAIN Capability

Return Type

Whether or not the capability is supported

Remarks

This method should be checked before calling the GetCapability method. Attempting to get a capability that isn't supported will generate an error.

Requirements

See Also

TwainDevice Class | TwainDevice Members | Overload List


LoadSettings Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

filename
A string representation of a legal file name (path) from which the settings will be loaded.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

LoadSettings Method

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class : LoadSettings Method

Loads the scanner settings from file.

[Visual Basic]
Public Sub LoadSettings( _
   ByVal filename As String _
)
[C#]
public void LoadSettings(
   string filename
);
[C++]
public: void LoadSettings(
   string* filename
)
[C++/CLI]
public:
void LoadSettings(
   String^ filename
)

Parameters

filename
A string representation of a legal file name (path) from which the settings will be loaded.

Remarks

Loads scanner settings that were previously saved to file using the SaveSettings method.

Note that your scanner might not support setting all of the capabilities that are saved in the settings file. If you set the Debug property to True to write a Debug Log File, then during the LoadSettings operation all unsupported capabilities will be written to the Debug Log File.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

TwainDevice Class | TwainDevice Members


OpenDataSourceManager Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

OpenDataSourceManager Method

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class : OpenDataSourceManager Method

Opens the Source Manager. Use this method only to set the Data Source without using the SelectSource method.

[Visual Basic]
Public Sub OpenDataSourceManager()
[C#]
public void OpenDataSourceManager();
[C++]
public: void OpenDataSourceManager();
[C++/CLI]
public:
void OpenDataSourceManager();

Remarks

Use this method before creating a DataSourceCollection. Then set the current data source in the collection before calling OpenSession.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

TwainDevice Class | TwainDevice Members


OpenSession Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

OpenSession Method

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class : OpenSession Method

Opens the Data Source Manager and Data Source, placing TwainPRO into the Capability Negotiation state.

[Visual Basic]
Public Sub OpenSession()
[C#]
public void OpenSession();
[C++]
public: void OpenSession();
[C++/CLI]
public:
void OpenSession();

Remarks

Use this method for controlling the Data Source capabilities and Data Source UI. This Method is used in conjunction with CloseSession and the capability negotiation methods.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

TwainDevice Class | TwainDevice Members


SaveSettings Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

filename
A string representation of a legal file name (path) to which the settings will be saved.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SaveSettings Method

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class : SaveSettings Method

Saves the scanner settings to file.

[Visual Basic]
Public Sub SaveSettings( _
   ByVal filename As String _
)
[C#]
public void SaveSettings(
   string filename
);
[C++]
public: void SaveSettings(
   string* filename
)
[C++/CLI]
public:
void SaveSettings(
   String^ filename
)

Parameters

filename
A string representation of a legal file name (path) to which the settings will be saved.

Remarks

This method will save the settings of all settable, documented capabilities to file. A settings file contains settings for one TWAIN device, and settings for other TWAIN devices will need to be saved to separate settings files.

The LoadSettings method can be used to later load the settings from file. Note that your scanner might not support setting all of the capabilities that are saved in the settings file. If you set the Debug property to True to write a Debug Log File, then during the LoadSettings operation all unsupported capabilities will be written to the Debug Log File.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

TwainDevice Class | TwainDevice Members


SelectSource Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SelectSource Method

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class : SelectSource Method

Displays the TWAIN Data Source Manager's Source Selection User Interface (UI) so the user can choose which Data Source is the current Source.

[Visual Basic]
Public Sub SelectSource()
[C#]
public void SelectSource();
[C++]
public: void SelectSource();
[C++/CLI]
public:
void SelectSource();

Remarks

This method will close any previously opened TwainPRO session.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

TwainDevice Class | TwainDevice Members


SetCapability Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

capabilityContainer
A CapabilityContainer with the specified values.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SetCapability Method

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class : SetCapability Method

Sets a TWAIN capability using the specified values.

[Visual Basic]
Public Sub SetCapability( _
   ByVal capabilityContainer As CapabilityContainer _
)
[C#]
public void SetCapability(
   CapabilityContainer capabilityContainer
);
[C++]
public: void SetCapability(
   CapabilityContainer* capabilityContainer
)
[C++/CLI]
public:
void SetCapability(
   CapabilityContainer^ capabilityContainer
)

Parameters

capabilityContainer
A CapabilityContainer with the specified values.

Remarks

The CapabilityContainerOneValue, CapabilityContainerEnum, CapabilityContainerRange, and CapabilityContainerArray objects that are inherited from CapabilityContainer can be filled with information and passed to this method to set the value of a capability.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

TwainDevice Class | TwainDevice Members


StartSession Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

StartSession Method

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class : StartSession Method

Enables the Current Data Source and places it into the Image Transfer state. Displays the Data Source User Interface if ShowUserInterface is True. This method will return when the user closes the UI if the ShowUserInterface property is True or after the image transfer if ShowUserInterface is False.

[Visual Basic]
Public Sub StartSession()
[C#]
public void StartSession();
[C++]
public: void StartSession();
[C++/CLI]
public:
void StartSession();

Remarks

It is not necessary to call OpenSession before calling this method. All Capability Negotiation methods must be called before this method.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Requirements

See Also

TwainDevice Class | TwainDevice Members


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainDevice Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : TwainDevice Class

For a list of all members of this type, see TwainDevice members.

Public Properties

Public Property ApplicationIdentity | Returns the ApplicationIdentity properties.
Public Property Caption | Returns the Caption properties.
Public Property CloseOnCancel | Specifies whether the TWAIN User Interface should be closed when the operation is cancelled.
Public Property EnableExtendedCapabilities | Enables the extended capabilities CAP_FEEDPAGE and CAP_CLEARPAGE.
Public Property ImageLayout | Gets or sets the Image Layout rectangle for the current Data Source.
Public Property MaximumImages | Gets or sets the maximum number of images expected from a TWAIN Data Source that supports multiple image scanning.
Public Property ShowUserInterface | Gets or sets the Data Source User Interface flag.
Public Property TransferMode | Gets or sets the transfer mode for scanning.

See Also

TwainDevice Class | PegasusImaging.WinForms.TwainPro5 Namespace


ApplicationIdentity Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ApplicationIdentity Property

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class : ApplicationIdentity Property (TwainDevice)

Returns the ApplicationIdentity properties.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property ApplicationIdentity As ApplicationIdentity
[C#]
[BrowsableAttribute(false)]
public ApplicationIdentity ApplicationIdentity {get;}
[C++]
[BrowsableAttribute(false)]
public: __property ApplicationIdentity* get_ApplicationIdentity();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property ApplicationIdentity^ ApplicationIdentity {
   ApplicationIdentity^ get();
}

Requirements

See Also

TwainDevice Class | TwainDevice Members


Caption Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Caption Property

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class : Caption Property (TwainDevice)

Returns the Caption properties.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property Caption As Caption
[C#]
[BrowsableAttribute(false)]
public Caption Caption {get;}
[C++]
[BrowsableAttribute(false)]
public: __property Caption* get_Caption();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property Caption^ Caption {
   Caption^ get();
}

Requirements

See Also

TwainDevice Class | TwainDevice Members


CloseOnCancel Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CloseOnCancel Property

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class : CloseOnCancel Property

Specifies whether the TWAIN User Interface should be closed when the operation is cancelled.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies whether the TWAIN User Interface should be closed when the operation is cancelled.")>
Public Property CloseOnCancel As Boolean
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies whether the TWAIN User Interface should be closed when the operation is cancelled.")]
public bool CloseOnCancel {get; set;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies whether the TWAIN User Interface should be closed when the operation is cancelled.")]
public: __property bool get_CloseOnCancel();
public: __property void set_CloseOnCancel(
   bool value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies whether the TWAIN User Interface should be closed when the operation is cancelled.")]
public:
property bool CloseOnCancel {
   bool get();
   void set (bool value);
}

Remarks

If the TWAIN User Interface is shown, the CloseOnCancel property determines whether the User Interface will be closed when the user issues a cancel.

Default value: false

Requirements

See Also

TwainDevice Class | TwainDevice Members


EnableExtendedCapabilities Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

EnableExtendedCapabilities Property

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class : EnableExtendedCapabilities Property

Enables the extended capabilities CAP_FEEDPAGE and CAP_CLEARPAGE.

[Visual Basic]
<DefaultValueAttribute()>
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<DescriptionAttribute("Enables the extended capabilities TWCAP_FEEDPAGE and TWCAP_CLEARPAGE.")>
Public Property EnableExtendedCapabilities As Boolean
[C#]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Enables the extended capabilities TWCAP_FEEDPAGE and TWCAP_CLEARPAGE.")]
public bool EnableExtendedCapabilities {get; set;}
[C++]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Enables the extended capabilities TWCAP_FEEDPAGE and TWCAP_CLEARPAGE.")]
public: __property bool get_EnableExtendedCapabilities();
public: __property void set_EnableExtendedCapabilities(
   bool value
);
[C++/CLI]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Enables the extended capabilities TWCAP_FEEDPAGE and TWCAP_CLEARPAGE.")]
public:
property bool EnableExtendedCapabilities {
   bool get();
   void set (bool value);
}

Remarks

This property was added for some non-compliant TWAIN drivers that don’t properly handle a query for support of extended capabilities. If you do not plan on using these Caps, then set this property to False.

Default value: true

Requirements

See Also

TwainDevice Class | TwainDevice Members


ImageLayout Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ImageLayout Property

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class : ImageLayout Property

Gets or sets the Image Layout rectangle for the current Data Source.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("Gets or sets the Image Layout rectangle for the current Data Source.")>
<BrowsableAttribute(False)>
Public Property ImageLayout As RectangleF
[C#]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets or sets the Image Layout rectangle for the current Data Source.")]
[BrowsableAttribute(false)]
public RectangleF ImageLayout {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets or sets the Image Layout rectangle for the current Data Source.")]
[BrowsableAttribute(false)]
public: __property RectangleF get_ImageLayout();
public: __property void set_ImageLayout(
   RectangleF value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets or sets the Image Layout rectangle for the current Data Source.")]
[BrowsableAttribute(false)]
public:
property RectangleF ImageLayout {
   RectangleF get();
   void set (RectangleF value);
}

Remarks

The Image Layout rectangle defines what portion of the Data Source's scanning area is acquired.

Call this method after OpenSession and before StartSession.

Requirements

See Also

TwainDevice Class | TwainDevice Members


MaximumImages Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

MaximumImages Property

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class : MaximumImages Property

Gets or sets the maximum number of images expected from a TWAIN Data Source that supports multiple image scanning.

[Visual Basic]
<DescriptionAttribute("Gets or sets the maximum number of images expected from a TWAIN Data Source that supports multiple image scanning.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
Public Property MaximumImages As Integer
[C#]
[DescriptionAttribute("Gets or sets the maximum number of images expected from a TWAIN Data Source that supports multiple image scanning.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public int MaximumImages {get; set;}
[C++]
[DescriptionAttribute("Gets or sets the maximum number of images expected from a TWAIN Data Source that supports multiple image scanning.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public: __property int get_MaximumImages();
public: __property void set_MaximumImages(
   int value
);
[C++/CLI]
[DescriptionAttribute("Gets or sets the maximum number of images expected from a TWAIN Data Source that supports multiple image scanning.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public:
property int MaximumImages {
   int get();
   void set (int value);
}

Remarks

The MaximumImages property is negotiated with the TWAIN Data Source during initialization (OpenSession) and should be set prior to invoking the OpenSession method.

This property is only used when the OpenSession method is invoked. To set the transfer count after calling OpenSession, use the CAP_XFERCOUNT capability.

A value of –1 indicates the application is willing to transfer multiple images.

A value of 1 indicates the application wishes to transfer only one image per session.

Default value: -1

Requirements

See Also

TwainDevice Class | TwainDevice Members


ShowUserInterface Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ShowUserInterface Property

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class : ShowUserInterface Property

Gets or sets the Data Source User Interface flag.

[Visual Basic]
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the Data Source User Interface flag.")>
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property ShowUserInterface As Boolean
[C#]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the Data Source User Interface flag.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public bool ShowUserInterface {get; set;}
[C++]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the Data Source User Interface flag.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property bool get_ShowUserInterface();
public: __property void set_ShowUserInterface(
   bool value
);
[C++/CLI]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the Data Source User Interface flag.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property bool ShowUserInterface {
   bool get();
   void set (bool value);
}

Remarks

When ShowUserInterface is set to True the TWAIN Data Source will display its User Interface when invoking the StartSession method. If ShowUserInterface is set to False the Data Source UI will not be displayed and scanning will begin immediately using the current capability values.

Default value: true

Requirements

See Also

TwainDevice Class | TwainDevice Members


TransferMode Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TransferMode Property

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class : TransferMode Property (TwainDevice)

Gets or sets the transfer mode for scanning.

[Visual Basic]
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("Gets or sets the transfer mode for scanning.")>
Public Property TransferMode As TransferMode
[C#]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets or sets the transfer mode for scanning.")]
public TransferMode TransferMode {get; set;}
[C++]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets or sets the transfer mode for scanning.")]
public: __property TransferMode get_TransferMode();
public: __property void set_TransferMode(
   TransferMode value
);
[C++/CLI]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets or sets the transfer mode for scanning.")]
public:
property TransferMode TransferMode {
   TransferMode get();
   void set (TransferMode value);
}

Remarks

The TransferMode property is used to set or obtain the current method of transferring images from the Data Source. The TransferMode should be set to the value desired prior to a call to the OpenSession or StartSession methods. The default TransferMode of the TwainPRO control is the Native transfer mode. TransferMode is available at runtime only.

NOTE: Transferring of compressed data directly from a Data Source requires that buffered memory mode, TWSX_MEMORY, be used.

Default value: TwsxNative

Requirements

See Also

TwainDevice Class | TwainDevice Members


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainDevice Class Events

PegasusImaging.WinForms.TwainPro5 Namespace : TwainDevice Class

For a list of all members of this type, see TwainDevice members.

Public Events

Public Event Scanned | Use this event to receive ScannedEventArgs information about the event.
Public Event Scanning | Use this event to receive ScanningEventArgs information about the event.

See Also

TwainDevice Class | PegasusImaging.WinForms.TwainPro5 Namespace


Scanned Event

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Scanned Event

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class : Scanned Event

Use this event to receive ScannedEventArgs information about the event.

[Visual Basic]
Public Event Scanned() As ScannedEventHandler
[C#]
public event ScannedEventHandler Scanned();
[C++]
public: __event ScannedEventHandler* Scanned();
[C++/CLI]
public:
event ScannedEventHandler^ Scanned();

Event Data

The event handler receives an argument of type ScannedEventArgs containing data related to this event. The following ScannedEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets and sets a cancel on the session. If set to true, the session ends and the StartSession method returns control.
PendingTransfers | Gets and sets the number of image transfers the TWAIN Data Source is ready to supply to the TwainPRO control.
ScannedImage | Gets and sets the scanned image and image information.

Requirements

See Also

TwainDevice Class | TwainDevice Members


Scanning Event

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDevice Class | TwainDevice Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Scanning Event

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDevice Class : Scanning Event

Use this event to receive ScanningEventArgs information about the event.

[Visual Basic]
Public Event Scanning() As ScanningEventHandler
[C#]
public event ScanningEventHandler Scanning();
[C++]
public: __event ScanningEventHandler* Scanning();
[C++/CLI]
public:
event ScanningEventHandler^ Scanning();

Event Data

The event handler receives an argument of type ScanningEventArgs containing data related to this event. The following ScanningEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets and sets an indicator whether to cancel the session.
PendingTransfers | Gets and sets the number of image transfers the TWAIN Data Source is ready to supply to the TwainPRO control.
ScannedImageData | Gets and sets the scanned image information.

Requirements

See Also

TwainDevice Class | TwainDevice Members


TwainDllLoadException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDllLoadException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainDllLoadException Class

PegasusImaging.WinForms.TwainPro5 Namespace : TwainDllLoadException Class

This exception is thrown if TwainPRO is unable to find or load twain_32.dll.

For a list of all members of this type, see TwainDllLoadException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.TwainDllLoadException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class TwainDllLoadException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class TwainDllLoadException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class TwainDllLoadException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class TwainDllLoadException sealed : public TwainProException

Remarks

This file is not shipped with TwainPRO because it is generally provided by the Data Source. It should be located in the windows directory and not the windows\system directory. The latest version of this file can be found at http://www.twain.org.

Possible causes:

The file is missing.

The file is in use by another application.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

TwainDllLoadException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDllLoadException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainDllLoadException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : TwainDllLoadException Class

TwainDllLoadException overview

Public Constructors

Public Constructor TwainDllLoadException Constructor Overloaded. An exception generated for a DLL load error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TwainDllLoadException Class | PegasusImaging.WinForms.TwainPro5 Namespace


TwainDllLoadException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDllLoadException Class | TwainDllLoadException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainDllLoadException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDllLoadException Class : TwainDllLoadException Constructor (TwainDllLoadException)

An exception generated for a DLL load error.

Overload List

An exception generated for a DLL load error.

[Visual Basic] Public Sub New()

[C#] public TwainDllLoadException();

[C++] public TwainDllLoadException();

[C++/CLI] public TwainDllLoadException();

Generated exception for a DLL load error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public TwainDllLoadException(int);

[C++] public TwainDllLoadException(int);

[C++/CLI] public TwainDllLoadException(int);

Generated exception for a DLL load error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public TwainDllLoadException(string);

[C++] public TwainDllLoadException(string*);

[C++/CLI] public TwainDllLoadException(String^);

Generated exception for a DLL load error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public TwainDllLoadException(int,string);

[C++] public TwainDllLoadException(int,string*);

[C++/CLI] public TwainDllLoadException(int,String^);

Generated exception for a DLL load error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public TwainDllLoadException(string,Exception);

[C++] public TwainDllLoadException(string*,Exception*);

[C++/CLI] public TwainDllLoadException(String^,Exception^);

Requirements

See Also

TwainDllLoadException Class | TwainDllLoadException Members


TwainDllLoadException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDllLoadException Class | TwainDllLoadException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainDllLoadException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDllLoadException Class > TwainDllLoadException Constructor : TwainDllLoadException Constructor()

An exception generated for a DLL load error.

[Visual Basic]
Public Function New()
[C#]
public TwainDllLoadException();
[C++]
public: TwainDllLoadException();
[C++/CLI]
public:
TwainDllLoadException();

Requirements

See Also

TwainDllLoadException Class | TwainDllLoadException Members | Overload List


TwainDllLoadException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDllLoadException Class | TwainDllLoadException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainDllLoadException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDllLoadException Class > TwainDllLoadException Constructor : TwainDllLoadException Constructor(Int32)

Generated exception for a DLL load error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public TwainDllLoadException(
   int errorNumber
);
[C++]
public: TwainDllLoadException(
   int errorNumber
)
[C++/CLI]
public:
TwainDllLoadException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

TwainDllLoadException Class | TwainDllLoadException Members | Overload List


TwainDllLoadException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDllLoadException Class | TwainDllLoadException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainDllLoadException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDllLoadException Class > TwainDllLoadException Constructor : TwainDllLoadException Constructor(Int32,String)

Generated exception for a DLL load error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public TwainDllLoadException(
   int errorNumber,
   string message
);
[C++]
public: TwainDllLoadException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
TwainDllLoadException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

TwainDllLoadException Class | TwainDllLoadException Members | Overload List


TwainDllLoadException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDllLoadException Class | TwainDllLoadException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainDllLoadException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDllLoadException Class > TwainDllLoadException Constructor : TwainDllLoadException Constructor(String)

Generated exception for a DLL load error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public TwainDllLoadException(
   string message
);
[C++]
public: TwainDllLoadException(
   string* message
)
[C++/CLI]
public:
TwainDllLoadException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

TwainDllLoadException Class | TwainDllLoadException Members | Overload List


TwainDllLoadException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDllLoadException Class | TwainDllLoadException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainDllLoadException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > TwainDllLoadException Class > TwainDllLoadException Constructor : TwainDllLoadException Constructor(String,Exception)

Generated exception for a DLL load error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public TwainDllLoadException(
   string message,
   Exception innerException
);
[C++]
public: TwainDllLoadException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
TwainDllLoadException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

TwainDllLoadException Class | TwainDllLoadException Members | Overload List


TwainException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainException Class

PegasusImaging.WinForms.TwainPro5 Namespace : TwainException Class

This exception is thrown if a TWAIN error occurs.

For a list of all members of this type, see TwainException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.TwainException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class TwainException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class TwainException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class TwainException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class TwainException sealed : public TwainProException

Remarks

The Data Source has returned an error. Check the ConditionCode and ConditionDescription properties to see if the Data Source has returned an error code.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

TwainException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : TwainException Class

TwainException overview

Public Constructors

Public Constructor TwainException Constructor Overloaded. An exception generated for a TWAIN error.

Public Properties

Public Property ConditionCode | Gets additional TWAIN error information from the Data Source.
Public Property ConditionDescription | Gets additional TWAIN error information from the Data Source.
Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TwainException Class | PegasusImaging.WinForms.TwainPro5 Namespace


TwainException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainException Class | TwainException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > TwainException Class : TwainException Constructor (TwainException)

An exception generated for a TWAIN error.

Overload List

An exception generated for a TWAIN error.

[Visual Basic] Public Sub New()

[C#] public TwainException();

[C++] public TwainException();

[C++/CLI] public TwainException();

Thrown for a TWAIN error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public TwainException(int);

[C++] public TwainException(int);

[C++/CLI] public TwainException(int);

Thrown for a TWAIN error with a given error message.

[Visual Basic] Public Sub New(String)

[C#] public TwainException(string);

[C++] public TwainException(string*);

[C++/CLI] public TwainException(String^);

Generated exception for a TWAIN error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public TwainException(int,string);

[C++] public TwainException(int,string*);

[C++/CLI] public TwainException(int,String^);

Generated exception for a TWAIN error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public TwainException(string,Exception);

[C++] public TwainException(string*,Exception*);

[C++/CLI] public TwainException(String^,Exception^);

Requirements

See Also

TwainException Class | TwainException Members


TwainException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainException Class | TwainException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > TwainException Class > TwainException Constructor : TwainException Constructor()

An exception generated for a TWAIN error.

[Visual Basic]
Public Function New()
[C#]
public TwainException();
[C++]
public: TwainException();
[C++/CLI]
public:
TwainException();

Requirements

See Also

TwainException Class | TwainException Members | Overload List


TwainException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainException Class | TwainException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > TwainException Class > TwainException Constructor : TwainException Constructor(Int32)

Thrown for a TWAIN error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public TwainException(
   int errorNumber
);
[C++]
public: TwainException(
   int errorNumber
)
[C++/CLI]
public:
TwainException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

TwainException Class | TwainException Members | Overload List


TwainException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainException Class | TwainException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > TwainException Class > TwainException Constructor : TwainException Constructor(Int32,String)

Generated exception for a TWAIN error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public TwainException(
   int errorNumber,
   string message
);
[C++]
public: TwainException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
TwainException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

TwainException Class | TwainException Members | Overload List


TwainException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainException Class | TwainException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > TwainException Class > TwainException Constructor : TwainException Constructor(String)

Thrown for a TWAIN error with a given error message.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public TwainException(
   string message
);
[C++]
public: TwainException(
   string* message
)
[C++/CLI]
public:
TwainException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

TwainException Class | TwainException Members | Overload List


TwainException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainException Class | TwainException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > TwainException Class > TwainException Constructor : TwainException Constructor(String,Exception)

Generated exception for a TWAIN error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public TwainException(
   string message,
   Exception innerException
);
[C++]
public: TwainException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
TwainException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

TwainException Class | TwainException Members | Overload List


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : TwainException Class

For a list of all members of this type, see TwainException members.

Public Properties

Public Property ConditionCode | Gets additional TWAIN error information from the Data Source.
Public Property ConditionDescription | Gets additional TWAIN error information from the Data Source.
Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

TwainException Class | PegasusImaging.WinForms.TwainPro5 Namespace


ConditionCode Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainException Class | TwainException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ConditionCode Property

PegasusImaging.WinForms.TwainPro5 Namespace > TwainException Class : ConditionCode Property (TwainException)

Gets additional TWAIN error information from the Data Source.

[Visual Basic]
Public ReadOnly Property ConditionCode As Integer
[C#]
public int ConditionCode {get;}
[C++]
public: __property int get_ConditionCode();
[C++/CLI]
public:
property int ConditionCode {
   int get();
}

Value

An integer value which represents the condition code from the data source.

Remarks

The default value is 0.

Requirements

See Also

TwainException Class | TwainException Members


ConditionDescription Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainException Class | TwainException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ConditionDescription Property

PegasusImaging.WinForms.TwainPro5 Namespace > TwainException Class : ConditionDescription Property

Gets additional TWAIN error information from the Data Source.

[Visual Basic]
Public ReadOnly Property ConditionDescription As String
[C#]
public string ConditionDescription {get;}
[C++]
public: __property string* get_ConditionDescription();
[C++/CLI]
public:
property String^ ConditionDescription {
   String^ get();
}

Value

A string value which represents the condition description information from the data source.

Remarks

The default value is an empty string "".

Requirements

See Also

TwainException Class | TwainException Members


TwainPro Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainPro Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainPro Class

PegasusImaging.WinForms.TwainPro5 Namespace : TwainPro Class

The main object for this component.

For a list of all members of this type, see TwainPro members.

Object Model

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
PegasusImaging.WinForms.TwainPro5.TwainPro

Syntax

[Visual Basic]
<ToolboxBitmapAttribute()>
Public Class TwainPro
   Inherits Component
[C#]
[ToolboxBitmapAttribute()]
public class TwainPro : Component
[C++]
[ToolboxBitmapAttribute()]
public __gc class TwainPro : public Component
[C++/CLI]
[ToolboxBitmapAttribute()]
public ref class TwainPro : public Component

Remarks

This object is the primary place to perform component-level operations, such as setting licensing information, controlling the debug log, and displaying the toolkit about box.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

TwainPro Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainPro Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainPro Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : TwainPro Class

TwainPro overview

Public Constructors

Public Constructor TwainPro Constructor Overloaded. Initializes a new instance of the TwainPro class.

Public Properties

Public Property Container (Inherited from System.ComponentModel.Component) | Gets the IContainer that contains the Component.
Public Property Debug | Gets or sets an indicator which determines if the component writes information to a DebugLogFile or not.
Public Property DebugLogFile | Gets or sets the filename of the debug log file.
Public Property ErrorLevel | Gets or sets the error level of items that the component should write to the debug log file.
Public Property Licensing | Gets and sets access to an object you can use to provide licensing information to the component.
Public Property ParentWindowHandle | Gets and sets a window to the TwainPRO object.
Public Property Site (Inherited from System.ComponentModel.Component) | Gets or sets the ISite of the Component.

Public Methods

Public Method AboutBox | Displays the toolkit about box.
Public Method CreateObjRef (Inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Public Method Dispose (Inherited from System.ComponentModel.Component) | Releases all resources used by the Component.
Public Method GetLifetimeService (Inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Public Method InitializeLifetimeService (Inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Public Method ToString (Inherited from System.ComponentModel.Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

Public Events

Public Event Disposed (Inherited from System.ComponentModel.Component) Adds an event handler to listen to the Disposed event on the component.

See Also

TwainPro Class | PegasusImaging.WinForms.TwainPro5 Namespace


TwainPro Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainPro Class | TwainPro Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainPro Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > TwainPro Class : TwainPro Constructor (TwainPro)

Initializes a new instance of the TwainPro class.

Overload List

Initializes a new instance of the TwainPro class.

[Visual Basic] Public Sub New()

[C#] public TwainPro();

[C++] public TwainPro();

[C++/CLI] public TwainPro();

Initializes a new instance of the TwainPro class passing in a IContainer.

[Visual Basic] Public Sub New(IContainer)

[C#] public TwainPro(IContainer);

[C++] public TwainPro(IContainer*);

[C++/CLI] public TwainPro(IContainer^);

Requirements

See Also

TwainPro Class | TwainPro Members


TwainPro Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainPro Class | TwainPro Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainPro Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > TwainPro Class > TwainPro Constructor : TwainPro Constructor()

Initializes a new instance of the TwainPro class.

[Visual Basic]
Public Function New()
[C#]
public TwainPro();
[C++]
public: TwainPro();
[C++/CLI]
public:
TwainPro();

Requirements

See Also

TwainPro Class | TwainPro Members | Overload List


TwainPro Constructor(IContainer)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainPro Class | TwainPro Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

container
A container for the TwainPro data.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainPro Constructor(IContainer)

PegasusImaging.WinForms.TwainPro5 Namespace > TwainPro Class > TwainPro Constructor : TwainPro Constructor(IContainer)

Initializes a new instance of the TwainPro class passing in a IContainer.

[Visual Basic]
Public Function New( _
   ByVal container As IContainer _
)
[C#]
public TwainPro(
   IContainer container
);
[C++]
public: TwainPro(
   IContainer* container
)
[C++/CLI]
public:
TwainPro(
   IContainer^ container
)

Parameters

container
A container for the TwainPro data.

Requirements

See Also

TwainPro Class | TwainPro Members | Overload List


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainPro Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainPro Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : TwainPro Class

For a list of all members of this type, see TwainPro members.

Public Methods

Public Method AboutBox | Displays the toolkit about box.
Public Method CreateObjRef (Inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Public Method Dispose (Inherited from System.ComponentModel.Component) | Releases all resources used by the Component.
Public Method GetLifetimeService (Inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Public Method InitializeLifetimeService (Inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Public Method ToString (Inherited from System.ComponentModel.Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

See Also

TwainPro Class | PegasusImaging.WinForms.TwainPro5 Namespace


AboutBox Method

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainPro Class | TwainPro Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

AboutBox Method

PegasusImaging.WinForms.TwainPro5 Namespace > TwainPro Class : AboutBox Method

Displays the toolkit about box.

[Visual Basic]
Public Sub AboutBox()
[C#]
public void AboutBox();
[C++]
public: void AboutBox();
[C++/CLI]
public:
void AboutBox();

Remarks

This method displays an about box for the toolkit. It includes useful information, such as the name and version of the toolkit, copyright dates, and links to Pegasus Imaging Corporation's web site.

This is a TwainPRO method. Please check your ImagXpress edition for licensing allowing use or distribution of these methods.

Example

...

// Call the AboutBox method

tp.AboutBox();

...

Requirements

See Also

TwainPro Class | TwainPro Members


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainPro Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainPro Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : TwainPro Class

For a list of all members of this type, see TwainPro members.

Public Properties

Public Property Container (Inherited from System.ComponentModel.Component) | Gets the IContainer that contains the Component.
Public Property Debug | Gets or sets an indicator which determines if the component writes information to a DebugLogFile or not.
Public Property DebugLogFile | Gets or sets the filename of the debug log file.
Public Property ErrorLevel | Gets or sets the error level of items that the component should write to the debug log file.
Public Property Licensing | Gets and sets access to an object you can use to provide licensing information to the component.
Public Property ParentWindowHandle | Gets and sets a window to the TwainPRO object.
Public Property Site (Inherited from System.ComponentModel.Component) | Gets or sets the ISite of the Component.

See Also

TwainPro Class | PegasusImaging.WinForms.TwainPro5 Namespace


Debug Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainPro Class | TwainPro Members | DebugLogFile Property | ErrorLevel Property | DebugLogFile Property | ErrorLevel Property

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Debug Property

PegasusImaging.WinForms.TwainPro5 Namespace > TwainPro Class : Debug Property

Gets or sets an indicator which determines if the component writes information to a DebugLogFile or not.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property Debug As Boolean
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public bool Debug {get; set;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property bool get_Debug();
public: __property void set_Debug(
   bool value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property bool Debug {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true if the component writes data to a debug log file. Otherwise, false is returned.

Remarks

This property allows you to turn the debug log file on or off without changing any of the other debug settings. When this value is true, the component will write items to the debug log file, as specified by the DebugLogFile and ErrorLevel properties.

Default value: false

Example

...

// Set Debug to true for logging to be performed

tp.Debug = true;

...

Requirements

See Also

TwainPro Class | TwainPro Members | DebugLogFile Property | ErrorLevel Property | DebugLogFile Property | ErrorLevel Property


DebugLogFile Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainPro Class | TwainPro Members | Debug Property | ErrorLevel Property

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

DebugLogFile Property

PegasusImaging.WinForms.TwainPro5 Namespace > TwainPro Class : DebugLogFile Property

Gets or sets the filename of the debug log file.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property DebugLogFile As String
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public string DebugLogFile {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property string* get_DebugLogFile();
public: __property void set_DebugLogFile(
   string* value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property String^ DebugLogFile {
   String^ get();
   void set (String^ value);
}

Value

A string value which represents the full path and name of the debug log file.

Remarks

This property allows you to control the location of the debug log file.

Valid value: Any valid filename.

Default value: "Temp\TwainPro5.log"

Note: This property will have no effect if you set the Debug property to false.

Example

...

// Set the DebugLogFile path and name

tp.DebugLogFile = "c:\logFile.txt";

...

Requirements

See Also

TwainPro Class | TwainPro Members | Debug Property | ErrorLevel Property


ErrorLevel Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainPro Class | TwainPro Members | DebugLogFile Property | Debug Property

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ErrorLevel Property

PegasusImaging.WinForms.TwainPro5 Namespace > TwainPro Class : ErrorLevel Property (TwainPro)

Gets or sets the error level of items that the component should write to the debug log file.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property ErrorLevel As ErrorLevel
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public ErrorLevel ErrorLevel {get; set;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property ErrorLevel get_ErrorLevel();
public: __property void set_ErrorLevel(
   ErrorLevel value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property ErrorLevel ErrorLevel {
   ErrorLevel get();
   void set (ErrorLevel value);
}

Value

The ErrorLevel enumeration value set.

Remarks

The default value is Production.

This property allows you to control the amount of information that the component places into the DebugLogFile. Since it is expensive to generate and write debug log items, set this property to write the least amount of information that you will find useful.

Valid values: Production, Development, and Detailed.

Note: This property will have no effect if the Debug property is set to false.

Example

...

// Set the ErrorLevel of the debugging

tp.ErrorLevel = PegasusImaging.WinForms.TwainPro5.ErrorLevel.Development;

...

Requirements

See Also

TwainPro Class | TwainPro Members | DebugLogFile Property | Debug Property


Licensing Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainPro Class | TwainPro Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Licensing Property

PegasusImaging.WinForms.TwainPro5 Namespace > TwainPro Class : Licensing Property (TwainPro)

Gets and sets access to an object you can use to provide licensing information to the component.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property Licensing As Licensing
[C#]
[BrowsableAttribute(false)]
public Licensing Licensing {get;}
[C++]
[BrowsableAttribute(false)]
public: __property Licensing* get_Licensing();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property Licensing^ Licensing {
   Licensing^ get();
}

Value

The Licensing object which contains the component licensing information.

Remarks

This property holds a reference to a Licensing object. You can use that object to send your licensing information to the component.

Example

...

// Set the License EvaluationMode

tp.Licensing.EvaluationMode = PegasusImaging.WinForms.TwainPro5.EvaluationMode.Automatic;

...

Requirements

See Also

TwainPro Class | TwainPro Members


ParentWindowHandle Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainPro Class | TwainPro Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ParentWindowHandle Property

PegasusImaging.WinForms.TwainPro5 Namespace > TwainPro Class : ParentWindowHandle Property

Gets and sets a window to the TwainPRO object.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("Provides a window to the TwainPRO object.")>
Public Property ParentWindowHandle As IntPtr
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Provides a window to the TwainPRO object.")]
public IntPtr ParentWindowHandle {get; set;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Provides a window to the TwainPRO object.")]
public: __property IntPtr get_ParentWindowHandle();
public: __property void set_ParentWindowHandle(
   IntPtr value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Provides a window to the TwainPRO object.")]
public:
property IntPtr ParentWindowHandle {
   IntPtr get();
   void set (IntPtr value);
}

Value

An integer pointer which represents a handle to the parent window.

Remarks

A window is created internally when using the .NET version of TwainPRO, so it is not necessary to set this property.

Requirements

See Also

TwainPro Class | TwainPro Members


TwainProException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainProException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainProException Class

PegasusImaging.WinForms.TwainPro5 Namespace : TwainProException Class

This class implements the base class for TwainPro Exceptions.

For a list of all members of this type, see TwainProException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.CapabilityNotSupportedException
PegasusImaging.WinForms.TwainPro5.ClipboardException
PegasusImaging.WinForms.TwainPro5.CompressedImageNotAvailableException
PegasusImaging.WinForms.TwainPro5.DataSourceInvalidOperationException
PegasusImaging.WinForms.TwainPro5.FileCreateException
PegasusImaging.WinForms.TwainPro5.FileOpenException
PegasusImaging.WinForms.TwainPro5.FileReadException
PegasusImaging.WinForms.TwainPro5.FileWriteException
PegasusImaging.WinForms.TwainPro5.FtpTransferException
PegasusImaging.WinForms.TwainPro5.ImageNotAvailableException
PegasusImaging.WinForms.TwainPro5.IndexOutOfRangeException
PegasusImaging.WinForms.TwainPro5.InternalErrorException
PegasusImaging.WinForms.TwainPro5.InternetFilesNotInstalledException
PegasusImaging.WinForms.TwainPro5.InvalidBitDepthException
PegasusImaging.WinForms.TwainPro5.InvalidLicenseException
PegasusImaging.WinForms.TwainPro5.InvalidPropertyException
PegasusImaging.WinForms.TwainPro5.LoadSettingsException
PegasusImaging.WinForms.TwainPro5.OperationCancelledException
PegasusImaging.WinForms.TwainPro5.OutOfMemoryException
PegasusImaging.WinForms.TwainPro5.PegasusFilesNotInstalledException
PegasusImaging.WinForms.TwainPro5.PropertyOrMethodNotAvailableException
PegasusImaging.WinForms.TwainPro5.SequenceException
PegasusImaging.WinForms.TwainPro5.StringIsTooLongException
PegasusImaging.WinForms.TwainPro5.TiffTagItemNotFoundException
PegasusImaging.WinForms.TwainPro5.TiffTagNotFoundException
PegasusImaging.WinForms.TwainPro5.TwainDllLoadException
PegasusImaging.WinForms.TwainPro5.TwainException
PegasusImaging.WinForms.TwainPro5.UnsupportedFileFormatException
PegasusImaging.WinForms.TwainPro5.ValueOutOfRangeException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public Class TwainProException
   Inherits ApplicationException
[C#]
[SerializableAttribute()]
public class TwainProException : ApplicationException
[C++]
[SerializableAttribute()]
public __gc class TwainProException : public ApplicationException
[C++/CLI]
[SerializableAttribute()]
public ref class TwainProException : public ApplicationException

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

TwainProException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainProException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainProException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : TwainProException Class

TwainProException overview

Public Constructors

Public Constructor TwainProException Constructor Overloaded. Initializes a new instance of the TwainProException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TwainProException Class | PegasusImaging.WinForms.TwainPro5 Namespace


TwainProException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainProException Class | TwainProException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainProException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > TwainProException Class : TwainProException Constructor (TwainProException)

Initializes a new instance of the TwainProException class.

Overload List

Initializes a new instance of the TwainProException class.

[Visual Basic] Public Sub New()

[C#] public TwainProException();

[C++] public TwainProException();

[C++/CLI] public TwainProException();

Initializes a new instance of the TwainProException class allowing passing in an error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public TwainProException(int,string);

[C++] public TwainProException(int,string*);

[C++/CLI] public TwainProException(int,String^);

Initializes a new instance of the TwainProException class allowing passing in an error number.

[Visual Basic] Public Sub New(Integer)

[C#] public TwainProException(int);

[C++] public TwainProException(int);

[C++/CLI] public TwainProException(int);

Initializes a new instance of the TwainProException class allowing passing in an error message.

[Visual Basic] Public Sub New(String)

[C#] public TwainProException(string);

[C++] public TwainProException(string*);

[C++/CLI] public TwainProException(String^);

Initializes a new instance of the TwainProException class allowing passing in an error message and an inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public TwainProException(string,Exception);

[C++] public TwainProException(string*,Exception*);

[C++/CLI] public TwainProException(String^,Exception^);

Requirements

See Also

TwainProException Class | TwainProException Members


TwainProException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainProException Class | TwainProException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainProException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > TwainProException Class > TwainProException Constructor : TwainProException Constructor()

Initializes a new instance of the TwainProException class.

[Visual Basic]
Public Function New()
[C#]
public TwainProException();
[C++]
public: TwainProException();
[C++/CLI]
public:
TwainProException();

Requirements

See Also

TwainProException Class | TwainProException Members | Overload List


TwainProException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainProException Class | TwainProException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

number
An integer value which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainProException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > TwainProException Class > TwainProException Constructor : TwainProException Constructor(Int32)

Initializes a new instance of the TwainProException class allowing passing in an error number.

[Visual Basic]
Public Function New( _
   ByVal number As Integer _
)
[C#]
public TwainProException(
   int number
);
[C++]
public: TwainProException(
   int number
)
[C++/CLI]
public:
TwainProException(
   int number
)

Parameters

number
An integer value which represents the error number.

Requirements

See Also

TwainProException Class | TwainProException Members | Overload List


TwainProException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainProException Class | TwainProException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

number
An integer value which represents the error number.
message
A string value which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainProException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > TwainProException Class > TwainProException Constructor : TwainProException Constructor(Int32,String)

Initializes a new instance of the TwainProException class allowing passing in an error number and message.

[Visual Basic]
Public Function New( _
   ByVal number As Integer, _
   ByVal message As String _
)
[C#]
public TwainProException(
   int number,
   string message
);
[C++]
public: TwainProException(
   int number,
   string* message
)
[C++/CLI]
public:
TwainProException(
   int number,
   String^ message
)

Parameters

number
An integer value which represents the error number.
message
A string value which represents the error message.

Requirements

See Also

TwainProException Class | TwainProException Members | Overload List


TwainProException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainProException Class | TwainProException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string value which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainProException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > TwainProException Class > TwainProException Constructor : TwainProException Constructor(String)

Initializes a new instance of the TwainProException class allowing passing in an error message.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public TwainProException(
   string message
);
[C++]
public: TwainProException(
   string* message
)
[C++/CLI]
public:
TwainProException(
   String^ message
)

Parameters

message
A string value which represents the error message.

Requirements

See Also

TwainProException Class | TwainProException Members | Overload List


TwainProException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainProException Class | TwainProException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string value which represents the error message.
inner
An inner Exception.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainProException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > TwainProException Class > TwainProException Constructor : TwainProException Constructor(String,Exception)

Initializes a new instance of the TwainProException class allowing passing in an error message and an inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public TwainProException(
   string message,
   Exception inner
);
[C++]
public: TwainProException(
   string* message,
   Exception* inner
)
[C++/CLI]
public:
TwainProException(
   String^ message,
   Exception^ inner
)

Parameters

message
A string value which represents the error message.
inner
An inner Exception.

Requirements

See Also

TwainProException Class | TwainProException Members | Overload List


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainProException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainProException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : TwainProException Class

For a list of all members of this type, see TwainProException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

TwainProException Class | PegasusImaging.WinForms.TwainPro5 Namespace


ErrorNumber Property

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainProException Class | TwainProException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ErrorNumber Property

PegasusImaging.WinForms.TwainPro5 Namespace > TwainProException Class : ErrorNumber Property

Gets the error number of the exception.

[Visual Basic]
Public ReadOnly Property ErrorNumber As Integer
[C#]
public int ErrorNumber {get;}
[C++]
public: __property int get_ErrorNumber();
[C++/CLI]
public:
property int ErrorNumber {
   int get();
}

Value

An integer value which represents the error number.

Remarks

This property holds an error number that you can use to determine the specific type of error that occurred.

Requirements

See Also

TwainProException Class | TwainProException Members


UnsupportedFileFormatException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

UnsupportedFileFormatException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

UnsupportedFileFormatException Class

PegasusImaging.WinForms.TwainPro5 Namespace : UnsupportedFileFormatException Class

This exception is thrown if the default file type is set and a file is saved using the extension of a file format that is not supported by TwainPRO, or if an invalid settings file is loaded. Supported file types are BMP, JPEG, ePIC, TIF, and PDF.

For a list of all members of this type, see UnsupportedFileFormatException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.UnsupportedFileFormatException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class UnsupportedFileFormatException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class UnsupportedFileFormatException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class UnsupportedFileFormatException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class UnsupportedFileFormatException sealed : public TwainProException

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

UnsupportedFileFormatException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

UnsupportedFileFormatException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

UnsupportedFileFormatException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : UnsupportedFileFormatException Class

UnsupportedFileFormatException overview

Public Constructors

Public Constructor UnsupportedFileFormatException Constructor Overloaded. An exception generated for an unsupported file format error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

UnsupportedFileFormatException Class | PegasusImaging.WinForms.TwainPro5 Namespace


UnsupportedFileFormatException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

UnsupportedFileFormatException Class | UnsupportedFileFormatException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

UnsupportedFileFormatException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > UnsupportedFileFormatException Class : UnsupportedFileFormatException Constructor (UnsupportedFileFormatException)

An exception generated for an unsupported file format error.

Overload List

An exception generated for an unsupported file format error.

[Visual Basic] Public Sub New()

[C#] public UnsupportedFileFormatException();

[C++] public UnsupportedFileFormatException();

[C++/CLI] public UnsupportedFileFormatException();

Generated exception for an unsupported file format error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public UnsupportedFileFormatException(int);

[C++] public UnsupportedFileFormatException(int);

[C++/CLI] public UnsupportedFileFormatException(int);

Generated exception for an unsupported file format error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public UnsupportedFileFormatException(string);

[C++] public UnsupportedFileFormatException(string*);

[C++/CLI] public UnsupportedFileFormatException(String^);

Generated exception for an unsupported file format error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public UnsupportedFileFormatException(int,string);

[C++] public UnsupportedFileFormatException(int,string*);

[C++/CLI] public UnsupportedFileFormatException(int,String^);

Generated exception for an unsupported file format error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public UnsupportedFileFormatException(string,Exception);

[C++] public UnsupportedFileFormatException(string*,Exception*);

[C++/CLI] public UnsupportedFileFormatException(String^,Exception^);

Requirements

See Also

UnsupportedFileFormatException Class | UnsupportedFileFormatException Members


UnsupportedFileFormatException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

UnsupportedFileFormatException Class | UnsupportedFileFormatException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

UnsupportedFileFormatException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > UnsupportedFileFormatException Class > UnsupportedFileFormatException Constructor : UnsupportedFileFormatException Constructor()

An exception generated for an unsupported file format error.

[Visual Basic]
Public Function New()
[C#]
public UnsupportedFileFormatException();
[C++]
public: UnsupportedFileFormatException();
[C++/CLI]
public:
UnsupportedFileFormatException();

Requirements

See Also

UnsupportedFileFormatException Class | UnsupportedFileFormatException Members | Overload List


UnsupportedFileFormatException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

UnsupportedFileFormatException Class | UnsupportedFileFormatException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

UnsupportedFileFormatException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > UnsupportedFileFormatException Class > UnsupportedFileFormatException Constructor : UnsupportedFileFormatException Constructor(Int32)

Generated exception for an unsupported file format error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public UnsupportedFileFormatException(
   int errorNumber
);
[C++]
public: UnsupportedFileFormatException(
   int errorNumber
)
[C++/CLI]
public:
UnsupportedFileFormatException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

UnsupportedFileFormatException Class | UnsupportedFileFormatException Members | Overload List


UnsupportedFileFormatException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

UnsupportedFileFormatException Class | UnsupportedFileFormatException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

UnsupportedFileFormatException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > UnsupportedFileFormatException Class > UnsupportedFileFormatException Constructor : UnsupportedFileFormatException Constructor(Int32,String)

Generated exception for an unsupported file format error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public UnsupportedFileFormatException(
   int errorNumber,
   string message
);
[C++]
public: UnsupportedFileFormatException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
UnsupportedFileFormatException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

UnsupportedFileFormatException Class | UnsupportedFileFormatException Members | Overload List


UnsupportedFileFormatException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

UnsupportedFileFormatException Class | UnsupportedFileFormatException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

UnsupportedFileFormatException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > UnsupportedFileFormatException Class > UnsupportedFileFormatException Constructor : UnsupportedFileFormatException Constructor(String)

Generated exception for an unsupported file format error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public UnsupportedFileFormatException(
   string message
);
[C++]
public: UnsupportedFileFormatException(
   string* message
)
[C++/CLI]
public:
UnsupportedFileFormatException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

UnsupportedFileFormatException Class | UnsupportedFileFormatException Members | Overload List


UnsupportedFileFormatException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

UnsupportedFileFormatException Class | UnsupportedFileFormatException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

UnsupportedFileFormatException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > UnsupportedFileFormatException Class > UnsupportedFileFormatException Constructor : UnsupportedFileFormatException Constructor(String,Exception)

Generated exception for an unsupported file format error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public UnsupportedFileFormatException(
   string message,
   Exception innerException
);
[C++]
public: UnsupportedFileFormatException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
UnsupportedFileFormatException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

UnsupportedFileFormatException Class | UnsupportedFileFormatException Members | Overload List


ValueOutOfRangeException Class

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ValueOutOfRangeException Members | PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ValueOutOfRangeException Class

PegasusImaging.WinForms.TwainPro5 Namespace : ValueOutOfRangeException Class

This exception is thrown if a TwainPRO property was set to an invalid value.

For a list of all members of this type, see ValueOutOfRangeException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.ValueOutOfRangeException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class ValueOutOfRangeException
   Inherits TwainProException
[C#]
[SerializableAttribute()]
public sealed class ValueOutOfRangeException : TwainProException
[C++]
[SerializableAttribute()]
public __gc __sealed class ValueOutOfRangeException : public TwainProException
[C++/CLI]
[SerializableAttribute()]
public ref class ValueOutOfRangeException sealed : public TwainProException

Remarks

Possible causes:

Many TwainPRO properties can only accept values in a specified range. For example, the SaveOptionsJpeg.Luminance property must be in the range 0-255.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

ValueOutOfRangeException Members | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ValueOutOfRangeException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ValueOutOfRangeException Class Members

PegasusImaging.WinForms.TwainPro5 Namespace : ValueOutOfRangeException Class

ValueOutOfRangeException overview

Public Constructors

Public Constructor ValueOutOfRangeException Constructor Overloaded. An exception generated for a value out of range error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ValueOutOfRangeException Class | PegasusImaging.WinForms.TwainPro5 Namespace


ValueOutOfRangeException Constructor

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ValueOutOfRangeException Class | ValueOutOfRangeException Members

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ValueOutOfRangeException Constructor

PegasusImaging.WinForms.TwainPro5 Namespace > ValueOutOfRangeException Class : ValueOutOfRangeException Constructor (ValueOutOfRangeException)

An exception generated for a value out of range error.

Overload List

An exception generated for a value out of range error.

[Visual Basic] Public Sub New()

[C#] public ValueOutOfRangeException();

[C++] public ValueOutOfRangeException();

[C++/CLI] public ValueOutOfRangeException();

Generated exception for a value out of range error with a given error number.

[Visual Basic] Public Sub New(Integer)

[C#] public ValueOutOfRangeException(int);

[C++] public ValueOutOfRangeException(int);

[C++/CLI] public ValueOutOfRangeException(int);

Generated exception for a value out of range error with a given string.

[Visual Basic] Public Sub New(String)

[C#] public ValueOutOfRangeException(string);

[C++] public ValueOutOfRangeException(string*);

[C++/CLI] public ValueOutOfRangeException(String^);

Generated exception for a value out of range error with a given error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public ValueOutOfRangeException(int,string);

[C++] public ValueOutOfRangeException(int,string*);

[C++/CLI] public ValueOutOfRangeException(int,String^);

Generated exception for a value out of range error with a given message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public ValueOutOfRangeException(string,Exception);

[C++] public ValueOutOfRangeException(string*,Exception*);

[C++/CLI] public ValueOutOfRangeException(String^,Exception^);

Requirements

See Also

ValueOutOfRangeException Class | ValueOutOfRangeException Members


ValueOutOfRangeException Constructor()

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ValueOutOfRangeException Class | ValueOutOfRangeException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ValueOutOfRangeException Constructor()

PegasusImaging.WinForms.TwainPro5 Namespace > ValueOutOfRangeException Class > ValueOutOfRangeException Constructor : ValueOutOfRangeException Constructor()

An exception generated for a value out of range error.

[Visual Basic]
Public Function New()
[C#]
public ValueOutOfRangeException();
[C++]
public: ValueOutOfRangeException();
[C++/CLI]
public:
ValueOutOfRangeException();

Requirements

See Also

ValueOutOfRangeException Class | ValueOutOfRangeException Members | Overload List


ValueOutOfRangeException Constructor(Int32)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ValueOutOfRangeException Class | ValueOutOfRangeException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ValueOutOfRangeException Constructor(Int32)

PegasusImaging.WinForms.TwainPro5 Namespace > ValueOutOfRangeException Class > ValueOutOfRangeException Constructor : ValueOutOfRangeException Constructor(Int32)

Generated exception for a value out of range error with a given error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public ValueOutOfRangeException(
   int errorNumber
);
[C++]
public: ValueOutOfRangeException(
   int errorNumber
)
[C++/CLI]
public:
ValueOutOfRangeException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

Requirements

See Also

ValueOutOfRangeException Class | ValueOutOfRangeException Members | Overload List


ValueOutOfRangeException Constructor(Int32,String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ValueOutOfRangeException Class | ValueOutOfRangeException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ValueOutOfRangeException Constructor(Int32,String)

PegasusImaging.WinForms.TwainPro5 Namespace > ValueOutOfRangeException Class > ValueOutOfRangeException Constructor : ValueOutOfRangeException Constructor(Int32,String)

Generated exception for a value out of range error with a given error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public ValueOutOfRangeException(
   int errorNumber,
   string message
);
[C++]
public: ValueOutOfRangeException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
ValueOutOfRangeException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Requirements

See Also

ValueOutOfRangeException Class | ValueOutOfRangeException Members | Overload List


ValueOutOfRangeException Constructor(String)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ValueOutOfRangeException Class | ValueOutOfRangeException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ValueOutOfRangeException Constructor(String)

PegasusImaging.WinForms.TwainPro5 Namespace > ValueOutOfRangeException Class > ValueOutOfRangeException Constructor : ValueOutOfRangeException Constructor(String)

Generated exception for a value out of range error with a given string.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public ValueOutOfRangeException(
   string message
);
[C++]
public: ValueOutOfRangeException(
   string* message
)
[C++/CLI]
public:
ValueOutOfRangeException(
   String^ message
)

Parameters

message
A string which represents the error message.

Requirements

See Also

ValueOutOfRangeException Class | ValueOutOfRangeException Members | Overload List


ValueOutOfRangeException Constructor(String,Exception)

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ValueOutOfRangeException Class | ValueOutOfRangeException Members | Overload List

Requirements

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception from the base contructor.
See Also Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ValueOutOfRangeException Constructor(String,Exception)

PegasusImaging.WinForms.TwainPro5 Namespace > ValueOutOfRangeException Class > ValueOutOfRangeException Constructor : ValueOutOfRangeException Constructor(String,Exception)

Generated exception for a value out of range error with a given message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public ValueOutOfRangeException(
   string message,
   Exception innerException
);
[C++]
public: ValueOutOfRangeException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
ValueOutOfRangeException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Requirements

See Also

ValueOutOfRangeException Class | ValueOutOfRangeException Members | Overload List


AdvancedCapability Enumeration

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

AdvancedCapability Enumeration

PegasusImaging.WinForms.TwainPro5 Namespace : AdvancedCapability Enumeration

Option values which determine the advanced TWAIN capability.

Members

Member | Description
CapXferCount | CAP_XFERCOUNT
IcapCompression | ICAP_COMPRESSION
IcapPixelType | ICAP_PIXELTYPE
IcapUnits | ICAP_UNITS
IcapXferMech | ICAP_XFERMECH
CapAuthor | CAP_AUTHOR
CapCaption | CAP_CAPTION
CapFeederEnabled | CAP_FEEDERENABLED
CapFeederLoaded | CAP_FEEDERLOADED
CapTimeDate | CAP_TIMEDATE
CapSupportedCaps | CAP_SUPPORTEDCAPS
CapExtendedCaps | CAP_EXTENDEDCAPS
CapAutoFeed | CAP_AUTOFEED
CapClearPage | CAP_CLEARPAGE
CapFeedPage | CAP_FEEDPAGE
CapRewindPage | CAP_REWINDPAGE
CapIndicators | CAP_INDICATORS
CapSupportedCapsExt | CAP_SUPPORTEDCAPSEXT
CapPaperDetectable | CAP_PAPERDETECTABLE
CapUIControllable | CAP_UICONTROLLABLE
CapDeviceOnline | CAP_DEVICEONLINE
CapAutoScan | CAP_AUTOSCAN
CapThumbnailsEnabled | CAP_THUMBNAILSENABLED
CapDuplex | CAP_DUPLEX
CapDuplexEnabled | CAP_DUPLEXENABLED
CapEnableDSUIOnly | CAP_DSUIONLY
CapCustomDSData | CAP_CUSTOMDSDATA
CapEndorser | CAP_ENDORSER
CapJobControl | CAP_JOBCONTROL
CapAlarms | CAP_ALARMS
CapAlarmVolume | CAP_ALARMVOLUME
CapAutomaticCapture | CAP_AUTOMATICCAPTURE
CapTimeBeforeFirstCapture | CAP_TIMEBEFOREFIRSTCAPTURE
CapTimeBetweenCaptures | CAP_TIMEBETWEENCAPTURES
CapClearBuffers | CAP_CLEARBUFFERS
CapMaxBatchBuffers | CAP_MAXBATCHBUFFERS
CapDeviceTimeDate | CAP_DEVICETIMEDATE
CapPowerSupply | CAP_POWERSUPPLY
CapCameraPreviewUI | CAP_PREVIEWUI
CapDeviceEvent | CAP_DEVICEEVENT
CapPageMultipleAcquire | CAP_PAGEMULTIPLEACQUIRE
CapSerialNumber | CAP_SERIALNUMBER
CapFileSystem | CAP_FILESYSTEM
CapPrinter | CAP_PRINTER
CapPrinterEnabled | CAP_PRINTERENABLED
CapPrinterIndex | CAP_PRINTERINDEX
CapPrinterMode | CAP_PRINTERMODE
CapPrinterString | CAP_PRINTERSTRING
CapPrinterSuffix | CAP_PRINTERSUFFIX
CapLanguage | CAP_LANGUAGE
CapFeederAlignment | CAP_FEEDERALIGNMENT
CapFeederOrder | CAP_FEEDERORDER
CapPaperBinding | CAP_PAPERBINDING
CapReacquireAllowed | CAP_REACQUIREALLOWED
CapPassThru | CAP_PASSTHRU
CapBatteryMinutes | CAP_BATTERYMINUTES
CapBatteryPercentage | CAP_BATTERYPERCENTAGE
IcapAutoBright | ICAP_AUTOBRIGHT
IcapBrightness | ICAP_BRIGHTNESS
IcapContrast | ICAP_CONTRAST
IcapCustHalftone | ICAP_CUSTHALFTONE
IcapExposureTime | ICAP_EXPOSURETIME
IcapFilter | ICAP_FILTER
IcapFlashUsed | ICAP_FLASHUSED
IcapGamma | ICAP_GAMMA
IcapHalftones | ICAP_HALFTONES
IcapHighlight | ICAP_HIGHLIGHT
IcapImageFileFormat | ICAP_IMAGEFILEFORMAT
IcapLampState | ICAP_LAMPSTATE
IcapLightSource | ICAP_LIGHTSOURCE
IcapOrientation | ICAP_ORIENTATION
IcapPhysicalWidth | ICAP_PHYSICALWIDTH
IcapPhysicalHeight | ICAP_PHYSICALHEIGHT
IcapShadow | ICAP_SHADOW
IcapFrames | ICAP_FRAMES
IcapXNativeResolution | ICAP_XNATIVERESOLUTION
IcapYNativeResolution | ICAP_YNATIVERESOLUTION
IcapXResolution | ICAP_XRESOLUTION
IcapYResolution | ICAP_YRESOLUTION
IcapMaxFrames | ICAP_MAXFRAMES
IcapTiles | ICAP_TILES
IcapBitOrder | ICAP_BITORDER
IcapCcittKFactor | ICAP_CCITTKFACTOR
IcapLightPath | ICAP_LIGHTPATH
IcapPixelFlavor | ICAP_PIXELFLAVOR
IcapPlanarChunky | ICAP_PLANARCHUNKY
IcapRotation | ICAP_ROTATION
IcapSupportedSizes | ICAP_SUPPORTEDSIZES
IcapThreshold | ICAP_THRESHOLD
IcapXScaling | ICAP_XSCALING
IcapYScaling | ICAP_YSCALING
IcapBitOrderCodes | ICAP_BITORDERCODES
IcapPixelFlavorCodes | ICAP_PIXELFLAVORCODES
IcapJpegPixelType | ICAP_JPEGPIXELTYPE
IcapTimeFill | ICAP_TIMEFILL
IcapBitDepth | ICAP_BITDEPTH
IcapBitDepthReduction | ICAP_BITDEPTHREDUCTION
IcapUndefinedImageSize | ICAP_UNDEFINEDIMAGESIZE
IcapImageDataSet | ICAP_IMAGEDATASET
IcapExtImageInfo | ICAP_EXTIMAGEINFO
IcapMinimumHeight | ICAP_MINIMUMHEIGHT
IcapMinimumWidth | ICAP_MINIMUMWIDTH
IcapFlipRotation | ICAP_FLIPROTATION
IcapBarcodeDetectionEnabled | ICAP_BARCODEDETECTIONENABLED
IcapSupportedBarcodeTypes | ICAP_SUPPORTEDBARCODETYPES
IcapBarcodeMaxSearchPriorities | ICAP_MAXSEARCHPRIORITIES
IcapBarcodeSearchPriorities | ICAP_BARCODESEARCHPRIORITIES
IcapBarcodeSearchMode | ICAP_BARCODESEARCHMODE
IcapBarcodeMaxRetries | ICAP_BARCODEMAXRETRIES
IcapBarcodeTimeout | ICAP_BARCODETIMEOUT
IcapZoomFactor | ICAP_ZOOMFACTOR
IcapPatchCodeDetectionEnabled | ICAP_PATCHCODEDETECTIONENABLED
IcapSupportedPatchCodeTypes | ICAP_SUPPORTEDPATCHCODETYPES
IcapPatchCodeMaxSearchPriorities | ICAP_PATCHCODEMAXSEARCHPRIORITIES
IcapPatchCodeSearchPriorities | ICAP_PATCHCODESEARCHPRIORITIES
IcapPatchCodeSearchMode | ICAP_PATCHCODESEARCHMODE
IcapPatchCodeMaxRetries | ICAP_PATCHCODEMAXRETRIES
IcapPatchCodeTimeout | ICAP_PATCHCODETIMEOUT
IcapFlashUsed2 | ICAP_FLASHUSED2
IcapImageFilter | ICAP_IMAGEFILTER
IcapNoiseFilter | ICAP_NOISEFILTER
IcapOverscan | ICAP_OVERSCAN
IcapAutomaticBorderDetection | ICAP_AUTOMATICBORDERDETECTION
IcapAutomaticDeskew | ICAP_AUTOMATICDESKEW
IcapAutomaticRotate | ICAP_AUTOMATICROTATE
IcapJpegQuality | ICAP_JPEGQUALITY
AcapAudioFileFormat | ACAP_AUDIOFILEFORMAT
AcapXferMech | ACAP_XFERMECH

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

PegasusImaging.WinForms.TwainPro5 Namespace


AdvancedCapabilityConstants Enumeration

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

AdvancedCapabilityConstants Enumeration

PegasusImaging.WinForms.TwainPro5 Namespace : AdvancedCapabilityConstants Enumeration

Option values which determine the TWAIN capability constants for advanced capabilities.

Members

Member | Description
TwftRed | TWFT_RED
TwftGreen | TWFT_GREEN
TwftBlue | TWFT_BLUE
TwftNone | TWFT_NONE
TwftWhite | TWFT_WHITE
TwftCyan | TWFT_CYAN
TwftMagenta | TWFT_MAGENTA
TwftYellow | TWFT_YELLOW
TwftBlack | TWFT_BLACK
TwlpReflection | TWLP_REFLECTION
TwlpTransmissive | TWLP_TRANSMISSIVE
TwlsRed | TWLS_RED
TwlsGreen | TWLS_GREEN
TwlsBlue | TWLS_BLUE
TwlsNone | TWLS_NONE
TwlsWhite | TWLS_WHITE
TwlsUV | TWLS_UV
TwlsIR | TWLS_IR
TwpfChocolate | TWPF_CHOCOLATE
TwpfVanilla | TWPF_VANILLA
TwbrThreshold | TWBR_THRESHOLD
TwbrHalftone | TWBR_HALFTONE
TwbrCustHalftone | TWBR_CUSTHALFTONE
TwbrDiffusion | TWBR_DIFFUSION
TwalAlarm | TWAL_ALARM
TwalFeederError | TWAL_FEEDERERROR
TwalFeederWarning | TWAL_FEEDERWARNING
TwalBarcode | TWAL_BARCODE
TwalDoubleFeed | TWAL_DOUBLEFEED
TwalJam | TWAL_JAM
TwalPatchCode | TWAL_PATCHCODE
TwalPower | TWAL_POWER
TwalSkew | TWAL_SKEW
TwcbAuto | TWCB_AUTO
TwcbClear | TWCB_CLEAR
TwcbNoClear | TWCB_NOCLEAR
TwfaNone | TWFA_NONE
TwfaLeft | TWFA_LEFT
TwfaCenter | TWFA_CENTER
TwfaRight | TWFA_RIGHT
TwfoFirstPageFirst | TWFO_FIRSTPAGEFIRST
TwfoLastPageFirst | TWFO_LASTPAGEFIRST
TwpsExternal | TWPS_EXTERNAL
TwpsBattery | TWPS_BATTERY
TwbdHorz | TWBD_HORZ
TwbdVert | TWBD_VERT
TwbdHorzVert | TWBD_HORZVERT
TwbdVertHorz | TWBD_VERTHORZ
TwflNone | TWFL_NONE
TwflOff | TWFL_OFF
TwflOn | TWFL_ON
TwflAuto | TWFL_AUTO
TwflRedEye | TWFL_REDEYE
TwfrBook | TWFR_BOOK
TwfrFanFold | TWFR_FANFOLD
TwifNone | TWIF_NONE
TwifAuto | TWIF_AUTO
TwifLowPass | TWIF_LOWPASS
TwifBandPass | TWIF_BANDPASS
TwifHighPass | TWIF_HIGHPASS
TwifText | TWIF_TEXT
TwifFineLine | TWIF_FINELINE
TwnfNone | TWNF_NONE
TwnfAuto | TWNF_AUTO
TwnfLonePixel | TWNF_LONEPIXEL
TwnfMajorityRule | TWNF_MAJORITYRULE
TwovNone | TWOV_NONE
TwovAuto | TWOV_AUTO
TwovTopBottom | TWOV_TOPBOTTOM
TwovLeftRight | TWOV_LEFTRIGHT
TwovAll | TWOV_ALL
TwcpNone | TWCP_NONE
TwcpPackbits | TWCP_PACKBITS
TwcpGroup31D | TWCP_GROUP31D
TwcpGroup31DEol | TWCP_GROUP31DEOL
TwcpGroup32D | TWCP_GROUP32D
TwcpGroup4 | TWCP_GROUP4
TwcpJpeg | TWCP_JPEG
TwjqUnknown | TWJQ_UNKNOWN
TwjqLow | TWJQ_LOW
TwjqMedium | TWJQ_MEDIUM
TwjqHigh | TWJQ_HIGH

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

PegasusImaging.WinForms.TwainPro5 Namespace


Capability Enumeration

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Capability Enumeration

PegasusImaging.WinForms.TwainPro5 Namespace : Capability Enumeration (PegasusImaging.WinForms.TwainPro5)

Option values which determine the TWAIN capability.

Members

Member | Description
IcapAutoBright | ICAP_AUTOBRIGHT
IcapBrightness | ICAP_BRIGHTNESS
IcapContrast | ICAP_CONTRAST
IcapGamma | ICAP_GAMMA
IcapPhysicalWidth | ICAP_PHYSICALWIDTH
IcapPhysicalHeight | ICAP_PHYSICALHEIGHT
IcapPixelType | ICAP_PIXELTYPE
IcapRotation | ICAP_ROTATION
IcapUnits | ICAP_UNITS
IcapXNativeResolution | ICAP_XNATIVERESOLUTION
IcapYNativeResolution | ICAP_YNATIVERESOLUTION
IcapXResolution | ICAP_XRESOLUTION
IcapYResolution | ICAP_YRESOLUTION
IcapXScaling | ICAP_XSCALING
IcapYScaling | ICAP_YSCALING
CapDeviceOnline | CAP_DEVICEONLINE
CapIndicators | CAP_INDICATORS
IcapLampstate | ICAP_LAMPSTATE
CapUIControllable | CAP_UICONTROLLABLE
CapXferCount | CAP_XFERCOUNT
CapAutoFeed | CAP_AUTOFEED
CapAutoScan | CAP_AUTOSCAN
CapClearPage | CAP_CLEARPAGE
CapDuplex | CAP_DUPLEX
CapDuplexEnabled | CAP_DUPLEXENABLED
CapFeederEnabled | CAP_FEEDERENABLED
CapFeederLoaded | CAP_FEEDERLOADED
CapFeedPage | CAP_FEEDPAGE
CapPaperDetectable | CAP_PAPERDETECTABLE
IcapBitDepth | ICAP_BITDEPTH
IcapSupportedSizes | ICAP_SUPPORTEDSIZES

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

PegasusImaging.WinForms.TwainPro5 Namespace


CapabilityConstants Enumeration

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityConstants Enumeration

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityConstants Enumeration

Option values which determine the capability constants.

Members

Member | Description
TwptBW | TWPT_BW
TwptGray | TWPT_GRAY
TwptRgb | TWPT_RGB
TwptPalette | TWPT_PALETTE
TwunInches | TWUN_INCHES
TwunCentimeters | TWUN_CENTIMETERS
TwunPicas | TWUN_PICAS
TwunPoints | TWUN_POINTS
TwunTwips | TWUN_TWIPS
TwunPixels | TWUN_PIXELS
TwdxNone | TWDX_NONE
Twdx1PassDuplex | TWDX_1PASSDUPLEX
Twdx2PassDuplex | TWDX_2PASSDUPLEX

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

PegasusImaging.WinForms.TwainPro5 Namespace


ConditionCode Enumeration

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ConditionCode Enumeration

PegasusImaging.WinForms.TwainPro5 Namespace : ConditionCode Enumeration (PegasusImaging.WinForms.TwainPro5)

Option values which determine TWAIN condition codes.

Members

Member | Description
TwccCustomBase | Custom base
TwccSuccess | 0 - Success
TwccBummer | 1 - Bummer. Failure due to unknown causes.
TwccLowMemory | 2 - Low memory. Not enough memory to perform the operation
TwccNods | 3 - No data source
TwccMaxConnections | 4 - Max Connections. The maximum applications are connected.
TwccOperationError | 5 - Operation error
TwccBadCap | 6 - Unknown or bad capability
TwccBadProtocol | 9 - Bad protocol
TwccBadValue | 10 - Bad value. Data parameter may be out of range
TwccSeqError | 11 - Out of sequence error
TwccBadDest | 12 - Bad or unknown destination source
TwccCapUnsupported | 13 - Unsupported capability
TwccCapBadOperation | 14 - Operation not supported by capability
TwccCapSeqError | 15 - Capability has dependancy on other capability
TwccDenied | 16 - File system operation is denied
TwccFileExists | 17 - Operation failed because file already exists
TwccFileNotFound | 18 - File not found
TwccNotEmpty | 19 - Operation failed because directory is not empty.
TwccPaperJam | 20 - The feeder is jammed
TwccPaperDoubleFeed | 21 - The feeder detected multiple pages
TwccFileWriteError | 22 - File write error
TwccCheckDeviceOnline | 23 - Check device online as device went offline prior to or during this operation

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

PegasusImaging.WinForms.TwainPro5 Namespace


EncodeModeCompression Enumeration

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

EncodeModeCompression Enumeration

PegasusImaging.WinForms.TwainPro5 Namespace : EncodeModeCompression Enumeration (PegasusImaging.WinForms.TwainPro5)

Option values which specify the encoding mode to use when creating a JBIG2 compressed file.

Members

Member | Description
AutoDetect | Default, Lossless Generic MQ
LosslessGenericMq | Fast, great lossless compression, use for any content, uses MQ arithmetic coding
LosslessGenericMmr | Fast, very good lossless compression, use for any content, similar to G4 coding, uses Huffman/MMR coding
LosslessTextMq | Great lossless compression possible, use for text or symbols, uses MQ arithmetic coding
LosslessTextMmr | Very good lossless compression possible, use for text or symbols, uses Huffman/MMR coding
LosslessTextSpmMq | Potentially best lossless compression for text or symbols, uses MQ arithmetic coding
LosslessTextSpmMmr | Potentially best lossless compression for text or symbols, uses Huffman/MMR coding plus MQ arithmetic coding
LossyTextMq | Great lossy compression for text or symbols, uses MQ arithmetic coding
LossyTextMmr | Very good lossy compression for text or symbols, uses Huffman/MMR coding
LossyHalftoneMq | Good lossy compression for halftones, uses MQ arithmetic coding
LossyHalftoneMmr | Good lossy compression for halftones, uses Huffman/MMR coding

Remarks

Text regions can be encoded as lossless or as lossy according to the encoding mode specified. The lossy modes use the value in SaveOptionsPdf.LoosenessCompression to control how loose to be when matching symbols and thereby increase compression and reduce file size. Compression means loss, however, and a consequence of higher compression is an increased risk of errors in the reconstructed image.

Specify a larger value of looseness to reduce the compressed file size; use a smaller value to reduce the errors, if any. Halftone regions can be encoded lossy by specifying one of the lossy halftone encoding modes. Alternatively, they can be encoded lossless by using the lossless generic encoding mode.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

PegasusImaging.WinForms.TwainPro5 Namespace


ErrorLevel Enumeration

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ErrorLevel Enumeration

PegasusImaging.WinForms.TwainPro5 Namespace : ErrorLevel Enumeration (PegasusImaging.WinForms.TwainPro5)

The error level of items to place into the debug log.

Members

Member | Description
Production | Place minimal information into the debug log file.
Development | Place information into the debug log file that is useful during normal development using this toolkit.
Detailed | Place as much information into the debug log file as possible. You should use this option when you are tracking down a problem.

Remarks

This enumeration allows you to specify the amount of detail to place into the debug log file.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

PegasusImaging.WinForms.TwainPro5 Namespace


EvaluationMode Enumeration

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusImaging.WinForms.TwainPro5 Namespace | EvaluationMode Property

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

EvaluationMode Enumeration

PegasusImaging.WinForms.TwainPro5 Namespace : EvaluationMode Enumeration (PegasusImaging.WinForms.TwainPro5)

Option values which determine the evaluation mode of the component.

Members

Member | Description
Automatic | Automatic evaluation mode. When possible, this component will automatically detect that it is running without a user interface and switch to another evaluation mode. Otherwise, it will display the evaluation mode dialog box.
Timeout | Timeout evaluation mode. This is the appropriate evaluation mode for applications that have no user interface.

Remarks

To simplify your evaluation of this component, Pegasus Imaging Corporation has implemented an evaluation mode. Normally, this mode will display a dialog box reminding you that you are using evaluation mode. In certain environments with no user interface, such as services, displaying a dialog box will cause the application to stop and you must change the evaluation mode to avoid that problem.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

PegasusImaging.WinForms.TwainPro5 Namespace | EvaluationMode Property


ExtendedImageInfo Enumeration

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ExtendedImageInfo Enumeration

PegasusImaging.WinForms.TwainPro5 Namespace : ExtendedImageInfo Enumeration (PegasusImaging.WinForms.TwainPro5)

Option values for extended image info enumeration values.

Members

Member | Description
TweiBarcodeX | TWEI_BARCODEX
TweiBarcodeY | TWEI_BARCODEY
TweiBarcodeText | TWEI_BARCODETEXT
TweiBarcodeType | TWEI_BARCODETYPE
TweiDeshadeTop | TWEI_DESHADETOP
TweiDeshadeLeft | TWEI_DESHADELEFT
TweiDeshadeHeight | TWEI_DESHADEHEIGHT
TweiDeshadeWidth | TWEI_DESHADEWIDTH
TweiDeshadeSize | TWEI_DESHADESIZE
TweiSpecklesRemoved | TWEI_SPECKLESREMOVED
TweiHorzLineXCoord | TWEI_HORZLINEXCOORD
TweiHorzLineYCoord | TWEI_HORZLINEYCOORD
TweiHorzLineLength | TWEI_HORZLINELENGTH
TweiHorzLineThickness | TWEI_HORZLINETHICKNESS
TweiVertLineXCoord | TWEI_VERTLINEXCOORD
TweiVertLineYCoord | TWEI_VERTLINEYCOORD
TweiVertLineLength | TWEI_VERTLINELENGTH
TweiVertLineThickness | TWEI_VERTLINETHICKNESS
TweiPatchCode | TWEI_PATCHCODE
TweiEndorsedText | TWEI_ENDORSEDTEXT
TweiFormConfidence | TWEI_FORMCONFIDENCE
TweiFormTemplateMatch | TWEI_FORMTEMPLATEMATCH
TweiFormTemplatePageMatch | TWEI_FORMTEMPLATEPAGEMATCH
TweiFormHorzDocOffset | TWEI_FORMHORZDOCOFFSET
TweiFormVertDocOffset | TWEI_FORMVERTDOCOFFSET
TweiBarcodeCount | TWEI_BARCODECOUNT
TweiBarcodeConfidence | TWEI_BARCODECONFIDENCE
TweiBarcodeRotation | TWEI_BARCODEROTATION
TweiBarcodeTextLength | TWEI_BARCODETEXTLENGTH
TweiDeshadeCount | TWEI_DESHADECOUNT
TweiDeshadeBlackCountOld | TWEI_DESHADEBLACKCOUNTOLD
TweiDeshadeBlackCountNew | TWEI_DESHADEBLACKCOUNTNEW
TweiDeshadeBlackRLMin | TWEI_DESHADEBLACKRLMIN
TweiDeshadeBlackRLMax | TWEI_DESHADEBLACKRLMAX
TweiDeshadeWhiteCountOld | TWEI_DESHADEWHITECOUNTOLD
TweiDeshadeWhiteCountNew | TWEI_DESHADEWHITECOUNTNEW
TweiDeshadeWhiteRLMin | TWEI_DESHADEWHITERLMIN
TweiDeshadeWhiteRLAve | TWEI_DESHADEWHITERLAVE
TweiDeshadeWhiteRLMax | TWEI_DESHADEWHITERLMAX
TweiBlackSpecklesRemoved | TWEI_BLACKSPECKLESREMOVED
TweiWhiteSpecklesRemoved | TWEI_WHITESPECKLESREMOVED
TweiHorzLineCount | TWEI_HORZLINECOUNT
TweiVertLineCount | TWEI_VERTLINECOUNT
TweiDeskewStatus | TWEI_DESKEWSTATUS
TweiSkewOriginalAngle | TWEI_SKEWORIGINALANGLE
TweiSkewFinalAngle | TWEI_SKEWFINALANGLE
TweiSkewConfidence | TWEI_SKEWCONFIDENCE
TweiSkewWindowX1 | TWEI_SKEWWINDOWX1
TweiSkewWindowY1 | TWEI_SKEWWINDOWY1
TweiSkewWindowX2 | TWEI_SKEWWINDOWX2
TweiSkewWindowY2 | TWEI_SKEWWINDOWY2
TweiSkewWindowX3 | TWEI_SKEWWINDOWX3
TweiSkewWindowY3 | TWEI_SKEWWINDOWY3
TweiSkewWindowX4 | TWEI_SKEWWINDOWX4
TweiSkewWindowY4 | TWEI_SKEWWINDOWY4
TwejNone | TWEJ_NONE
TwejMidSeparator | TWEJ_MIDSEPARATOR
TwejPatch1 | TWEJ_PATCH1
TwejPatch2 | TWEJ_PATCH2
TwejPatch3 | TWEJ_PATCH3
TwejPatch4 | TWEJ_PATCH4
TwejPatch6 | TWEJ_PATCH6
TwejPatchT | TWEJ_PATCHT

Remarks

The extended info constants have the equivalent names and values as defined in the C header file, twain.h, available from the TWAIN Working Group’s web site at http://www.twain.org. The exact location of the twain.h header file is http://www.twain.org/devfiles/twain.h

Note: There may be extended info constants that are defined in the twain.h header file that are not included as a constant in the TwainPRO control.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

PegasusImaging.WinForms.TwainPro5 Namespace


ExtendedImageInfoConstants Enumeration

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ExtendedImageInfoConstants Enumeration

PegasusImaging.WinForms.TwainPro5 Namespace : ExtendedImageInfoConstants Enumeration

Option values for extended image info constants enumeration values.

Members

Member | Description
Twbt3Of9 | TWBT_30F9
Twbt2Of5Interleaved | TWBT_2OF5INTERLEAVED
Twbt2Of5Noninterleaved | TWBT_2OF5NONINTERLEAVED
TwbtCode93 | TWBT_CODE93
TwbtCode128 | TWBT_CODE128
TwbtUcc128 | TWBT_UCC128
TwbtCodabar | TWBT_CODABAR
TwbtUpca | TWBT_UPCA
TwbtUpce | TWBT_UPCE
TwbtEan8 | TWBT_EAN8
TwbtEan13 | TWBT_EAN13
TwbtPostNet | TWBT_POSTNET
TwbtPdf417 | TWBT_PDF417
Twbt2Of5Industrial | TWBT_2OF5INDUSTRIAL
Twbt2Of5Matrix | TWBT_2OF5MATRIX
Twbt2Of5DataLogic | TWBT_2OF5DATALOGIC
Twbt2Of5Iata | TWBT_2OF5IATA
Twbt3Of9FullAscii | TWBT_3OF9FULLASCII
TwbtCodabarWithStartStop | TWBT_CODABARWITHSTARTSTOP
TwbtMaxicode | TWBT_MAXICODE
TwdskSuccess | TWDSK_SUCCESS
TwdskReportOnly | TWDSK_REPORTONLY
TwdskFail | TWDSK_FAIL
TwdskDisabled | TWDSK_DISABLED
TwpchPatch1 | TWPCH_PATCH1
TwpchPatch2 | TWPCH_PATCH2
TwpchPatch3 | TWPCH_PATCH3
TwpchPatch4 | TWPCH_PATCH4
TwpchPatch6 | TWPCH_PATCH6
TwpchPatchT | TWPCH_PATCHT
TwbcorRot0 | TWBCOR_ROT0
TwbcorRot90 | TWBCOR_ROT90
TwbcorRot180 | TWBCOR_ROT180
TwbcorRot270 | TWBCOR_ROT270
TwbcorRotX | TWBCOR_ROTX

Remarks

The extended info constants have the equivalent names and values as defined in the C header file, twain.h, available from the TWAIN Working Group’s web site at http://www.twain.org. The exact location of the twain.h header file is http://www.twain.org/devfiles/twain.h

Note: There may be extended info constants that are defined in the twain.h header file that are not included as a constant in the TwainPRO control.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

PegasusImaging.WinForms.TwainPro5 Namespace


FileOrganizationCompression Enumeration

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileOrganizationCompression Enumeration

PegasusImaging.WinForms.TwainPro5 Namespace : FileOrganizationCompression Enumeration (PegasusImaging.WinForms.TwainPro5)

Option values which determine the file organization when saving a JBIG2 compressed file.

Members

Member | Description
Default | Default, sequential organization
Sequential | Sequential organization
RandomAccess | Random access organization

Remarks

A JBIG2 compressed file may be organized in two ways: sequential or random access. Sequential organization is intended for streaming applications, where the decoder reads and decodes the file in order as the data is received. Random access organization permits the decoder to know the entire file structure, without having to read the entire file, and then uses that information to access the required data in a random-access fashion. This organization is useful for applications such as decoding only odd-number pages.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

PegasusImaging.WinForms.TwainPro5 Namespace


HorizontalAlignment Enumeration

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusImaging.WinForms.TwainPro5 Namespace | Clip Property | Area Property

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

HorizontalAlignment Enumeration

PegasusImaging.WinForms.TwainPro5 Namespace : HorizontalAlignment Enumeration (PegasusImaging.WinForms.TwainPro5)

Option values which determine the horizontal alignment of the caption within the clipping rectangle.

Members

Member | Description
Left | The text is left justified.
Right | The text is right justified.
Center | The text is horizontally centered.

Remarks

The clipping rectangle is determined by the Caption.Clip and Caption.Area properties.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

PegasusImaging.WinForms.TwainPro5 Namespace | Clip Property | Area Property


Orientation Enumeration

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Orientation Enumeration

PegasusImaging.WinForms.TwainPro5 Namespace : Orientation Enumeration

Option values which determine the TWAIN capability constants for the ICAP_ORIENTATION capability.

Members

Member | Description
TworRot0 | TWOR_ROT0
TworRot90 | TWOR_ROT90
TworRot180 | TWOR_ROT180
TworRot270 | TWOR_ROT270
TworPortrait | TWOR_PORTRAIT
TworLandscape | TWOR_LANDSCAPE

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

PegasusImaging.WinForms.TwainPro5 Namespace


PdfCompression Enumeration

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PdfCompression Enumeration

PegasusImaging.WinForms.TwainPro5 Namespace : PdfCompression Enumeration

Option values which determine the PDF compression.

Members

Member | Description
NoCompression | No compression
Group3Fax1d | CCITT Group 3 one-dimensional fax compression
Group3Fax2d | CCITT Group 3 two-dimensional fax compression
Group4 | CCITT Group 4 fax compression
Jbig2 | JBIG2 compression format
Jpeg | JPEG compression format
Default | Default compression

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

PegasusImaging.WinForms.TwainPro5 Namespace


PixelType Enumeration

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PixelType Enumeration

PegasusImaging.WinForms.TwainPro5 Namespace : PixelType Enumeration (PegasusImaging.WinForms.TwainPro5)

Option values which determine the type of pixel data that a Source is capable of acquiring (for example, black and white, gray, RGB, etc.).

Members

Member | Description
TwptBW | Black and white
TwptGray | Gray
TwptRgb | RGB
TwptPalette | Palette

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

PegasusImaging.WinForms.TwainPro5 Namespace


ScannedImageCompression Enumeration

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ScannedImageCompression Enumeration

PegasusImaging.WinForms.TwainPro5 Namespace : ScannedImageCompression Enumeration

Option values which determine the compression format of an acquired image.

Members

Member | Description
TwcpNone | No compression
TwcpPackbits | Packbits
TwcpGroup31D | Group 3 1D, follows CCITT spec (no End Of Line)
TwcpGroup31DEol | Group 3 1D, follows CCITT spec (has End Of Line)
TwcpGroup32D | Group 3 2D, follows CCITT spec (use cap for K Factor)
TwcpGroup4 | Group 4, follows CCITT spec
TwcpJpeg | JPEG

Remarks

TwcpNone means that the image is in an uncompressed DIB format and can be accessed through the ToHdib, ToBitmap, ToHbitmap, or SaveStream methods.

TwcpJpeg means that the image is in a JPEG format and should be accessed through the SaveStream method.

All other values mean that the image is in a TIFF format and should be accessed through the SaveStream method.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

PegasusImaging.WinForms.TwainPro5 Namespace


ScannedImageFormat Enumeration

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ScannedImageFormat Enumeration

PegasusImaging.WinForms.TwainPro5 Namespace : ScannedImageFormat Enumeration

Option values which determine the format of the saved file.

Members

Member | Description
Default | Default
Tiff | Tiff
Bmp | BMP
Jpeg | JPEG
Pic | Pegasus PIC
Pdf | PDF

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

PegasusImaging.WinForms.TwainPro5 Namespace


SubSampling Enumeration

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SubSampling Enumeration

PegasusImaging.WinForms.TwainPro5 Namespace : SubSampling Enumeration (PegasusImaging.WinForms.TwainPro5)

Option values which determine the subsampling type for a JPEG, ePIC, or JPEG compressed PDF file format.

Members

Member | Description
SubSampling111 | No sub-sampling
SubSampling211 | Sub-sampled 2:1 horizontally
SubSampling411 | Sub-sampled 2:1 horizontally and vertically
SubSampling211v | Sub-sampled 2:1 vertically (Default)

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

PegasusImaging.WinForms.TwainPro5 Namespace


SupportedSizes Enumeration

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SupportedSizes Enumeration

PegasusImaging.WinForms.TwainPro5 Namespace : SupportedSizes Enumeration

Option values which determine the TWAIN capability constants for the ICAP_SUPPORTEDSIZES capability.

Members

Member | Description
TwssNone | TWSS_NONE
TwssA4Letter | TWSS_A4LETTER
TwssB5Letter | TWSS_B5LETTER
TwssUSLetter | TWSS_USLETTER
TwssUSLegal | TWSS_USLEGAL
TwssA5 | TWSS_A5
TwssB4 | TWSS_B4
TwssB6 | TWSS_B6
TwssUSLedger | TWSS_USLEDGER
TwssUSExecutive | TWSS_USEXECUTIVE
TwssA3 | TWSS_A3
TwssB3 | TWSS_B3
TwssA6 | TWSS_A6
TwssC4 | TWSS_C4
TwssC5 | TWSS_C5
TwssC6 | TWSS_C6
Twss4A0 | TWSS_4A0
Twss2A0 | TWSS_2A0
TwssA0 | TWSS_A0
TwssA1 | TWSS_A1
TwssA2 | TWSS_A2
TwssA4 | TWSS_A4
TwssA7 | TWSS_A7
TwssA8 | TWSS_A8
TwssA9 | TWSS_A9
TwssA10 | TWSS_A10
TwssIsoB0 | TWSS_ISOB0
TwssIsoB1 | TWSS_ISOB1
TwssIsoB2 | TWSS_ISOB2
TwssIsoB3 | TWSS_ISOB3
TwssIsoB4 | TWSS_ISOB4
TwssIsoB5 | TWSS_ISOB5
TwssIsoB6 | TWSS_ISOB6
TwssIsoB7 | TWSS_ISOB7
TwssIsoB8 | TWSS_ISOB8
TwssIsoB9 | TWSS_ISOB9
TwssIsoB10 | TWSS_ISOB10
TwssJisB0 | TWSS_JISB0
TwssJisB1 | TWSS_JISB1
TwssJisB2 | TWSS_JISB2
TwssJisB3 | TWSS_JISB3
TwssJisB4 | TWSS_JISB4
TwssJisB5 | TWSS_JISB5
TwssJisB6 | TWSS_JISB6
TwssJisB7 | TWSS_JISB7
TwssJisB8 | TWSS_JISB8
TwssJisB9 | TWSS_JISB9
TwssJisB10 | TWSS_JISB10
TwssC0 | TWSS_C0
TwssC1 | TWSS_C1
TwssC2 | TWSS_C2
TwssC3 | TWSS_C3
TwssC7 | TWSS_C7
TwssC8 | TWSS_C8
TwssC9 | TWSS_C9
TwssC10 | TWSS_C10
TwssUSStatement | TWSS_USSTATEMENT
TwssBusinessCard | TWSS_BUSINESSCARD

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

PegasusImaging.WinForms.TwainPro5 Namespace


TiffCompression Enumeration

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TiffCompression Enumeration

PegasusImaging.WinForms.TwainPro5 Namespace : TiffCompression Enumeration

Option values which determine TIFF compression enumeration values.

Members

Member | Description
NoCompression | No compression
Rle | Run length encoding
Group3Fax1d | CCITT Group 3 one-dimensional fax compression
Group3Fax2d | CCITT Group 3 two-dimensional fax compression
Group4 | CCITT Group 4 fax compression

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

PegasusImaging.WinForms.TwainPro5 Namespace


TransferMode Enumeration

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TransferMode Enumeration

PegasusImaging.WinForms.TwainPro5 Namespace : TransferMode Enumeration (PegasusImaging.WinForms.TwainPro5)

Option values which determine transferring images from the Data Source.

Members

Member | Description
TwsxNative | Native
TwsxMemory | Memory

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

PegasusImaging.WinForms.TwainPro5 Namespace


VerticalAlignment Enumeration

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusImaging.WinForms.TwainPro5 Namespace | Clip Property | Area Property

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

VerticalAlignment Enumeration

PegasusImaging.WinForms.TwainPro5 Namespace : VerticalAlignment Enumeration (PegasusImaging.WinForms.TwainPro5)

Option values which determine the vertical alignment of the caption within the clipping rectangle.

Members

Member | Description
Top | The text is top justified.
Bottom | The text is bottom justified.
Center | The text is vertically centered.

Remarks

The clipping rectangle is determined by the Clip and Area properties.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

PegasusImaging.WinForms.TwainPro5 Namespace | Clip Property | Area Property


ScannedEventHandler Delegate

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
The object that issued the post-scan event.
e
Arguments for the scanned event. This object contains a scanned image object, a property for cancelling the scanning session, and a property indicating the number of pending transfers.
See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ScannedEventHandler Delegate

PegasusImaging.WinForms.TwainPro5 Namespace : ScannedEventHandler Delegate

A delegate for post-scan events.

[Visual Basic]
Public Delegate Sub ScannedEventHandler( _
   ByVal sender As Object, _
   ByVal e As ScannedEventArgs _
)
[C#]
public delegate void ScannedEventHandler(
   object sender,
   ScannedEventArgs e
);
[C++]
public: __gc __delegate void ScannedEventHandler(
   Object* sender,
   ScannedEventArgs* e
)
[C++/CLI]
public delegate void ScannedEventHandler(
   Object^ sender,
   ScannedEventArgs^ e
)

Parameters

sender
The object that issued the post-scan event.
e
Arguments for the scanned event. This object contains a scanned image object, a property for cancelling the scanning session, and a property indicating the number of pending transfers.

Remarks

This is the delegate for post-scan events. The TwainDevice class uses this delegate whenever a scan or transfer ends.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

PegasusImaging.WinForms.TwainPro5 Namespace


ScanningEventHandler Delegate

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusImaging.WinForms.TwainPro5 Namespace

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
The object that issued the pre-scan event.
e
Arguments for the scanning event. This object contains a scanned image data object, a property for cancelling the scanning session, and a property indicating the number of pending transfers.
See Also Requirements Languages PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ScanningEventHandler Delegate

PegasusImaging.WinForms.TwainPro5 Namespace : ScanningEventHandler Delegate

A delegate for pre-scan events.

[Visual Basic]
Public Delegate Sub ScanningEventHandler( _
   ByVal sender As Object, _
   ByVal e As ScanningEventArgs _
)
[C#]
public delegate void ScanningEventHandler(
   object sender,
   ScanningEventArgs e
);
[C++]
public: __gc __delegate void ScanningEventHandler(
   Object* sender,
   ScanningEventArgs* e
)
[C++/CLI]
public delegate void ScanningEventHandler(
   Object^ sender,
   ScanningEventArgs^ e
)

Parameters

sender
The object that issued the pre-scan event.
e
Arguments for the scanning event. This object contains a scanned image data object, a property for cancelling the scanning session, and a property indicating the number of pending transfers.

Remarks

This is the delegate for pre-scan events. The TwainDevice class uses this delegate whenever a scan or transfer begins.

Requirements

Namespace: PegasusImaging.WinForms.TwainPro5

Platforms: See "Distribution Requirements"

Assembly: PegasusImaging.WinForms.TwainPRO5 (in PegasusImaging.WinForms.TwainPRO5.dll)

See Also

PegasusImaging.WinForms.TwainPro5 Namespace


Glossary

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z


Assembly Overview

Namespaces

Namespace | Description
PegasusImaging.WinForms.TwainPro5 |


Getting Started - PegasusImaging.WinForms.TwainPRO5

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/
PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Getting Started

© 2008, Pegasus Imaging Corporation, All Rights Reserved.


Introduction - PegasusImaging.WinForms.TwainPRO5

 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/
PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

Introduction

© 2008, Pegasus Imaging Corporation, All Rights Reserved.


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityContainerOneValue Class | PegasusImaging.WinForms.TwainPro5 Namespace | CapabilityContainerOneValueFloat Class | CapabilityContainerOneValueString Class

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityContainerOneValue Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityContainerOneValue Class

For a list of all members of this type, see CapabilityContainerOneValue members.

Public Properties

Public Property Capability (Inherited from CapabilityContainer) Gets and sets which TWAIN capability to negotiate.

See Also

CapabilityContainerOneValue Class | PegasusImaging.WinForms.TwainPro5 Namespace | CapabilityContainerOneValueFloat Class | CapabilityContainerOneValueString Class


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityNotSupportedException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityNotSupportedException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityNotSupportedException Class

For a list of all members of this type, see CapabilityNotSupportedException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

CapabilityNotSupportedException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CapabilityNotSupportedException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CapabilityNotSupportedException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : CapabilityNotSupportedException Class

For a list of all members of this type, see CapabilityNotSupportedException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

CapabilityNotSupportedException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ClipboardException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ClipboardException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : ClipboardException Class

For a list of all members of this type, see ClipboardException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ClipboardException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ClipboardException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ClipboardException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : ClipboardException Class

For a list of all members of this type, see ClipboardException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

ClipboardException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CompressedImageNotAvailableException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CompressedImageNotAvailableException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : CompressedImageNotAvailableException Class

For a list of all members of this type, see CompressedImageNotAvailableException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

CompressedImageNotAvailableException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

CompressedImageNotAvailableException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

CompressedImageNotAvailableException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : CompressedImageNotAvailableException Class

For a list of all members of this type, see CompressedImageNotAvailableException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

CompressedImageNotAvailableException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

DataSourceInvalidOperationException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

DataSourceInvalidOperationException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : DataSourceInvalidOperationException Class

For a list of all members of this type, see DataSourceInvalidOperationException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

DataSourceInvalidOperationException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

DataSourceInvalidOperationException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

DataSourceInvalidOperationException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : DataSourceInvalidOperationException Class

For a list of all members of this type, see DataSourceInvalidOperationException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

DataSourceInvalidOperationException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileCreateException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileCreateException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : FileCreateException Class

For a list of all members of this type, see FileCreateException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

FileCreateException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileCreateException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileCreateException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : FileCreateException Class

For a list of all members of this type, see FileCreateException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

FileCreateException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileOpenException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileOpenException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : FileOpenException Class

For a list of all members of this type, see FileOpenException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

FileOpenException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileOpenException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileOpenException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : FileOpenException Class

For a list of all members of this type, see FileOpenException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

FileOpenException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileReadException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileReadException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : FileReadException Class

For a list of all members of this type, see FileReadException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

FileReadException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileReadException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileReadException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : FileReadException Class

For a list of all members of this type, see FileReadException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

FileReadException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileWriteException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileWriteException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : FileWriteException Class

For a list of all members of this type, see FileWriteException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

FileWriteException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FileWriteException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FileWriteException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : FileWriteException Class

For a list of all members of this type, see FileWriteException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

FileWriteException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FtpTransferException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FtpTransferException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : FtpTransferException Class

For a list of all members of this type, see FtpTransferException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

FtpTransferException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

FtpTransferException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

FtpTransferException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : FtpTransferException Class

For a list of all members of this type, see FtpTransferException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

FtpTransferException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ImageNotAvailableException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ImageNotAvailableException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : ImageNotAvailableException Class

For a list of all members of this type, see ImageNotAvailableException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ImageNotAvailableException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ImageNotAvailableException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ImageNotAvailableException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : ImageNotAvailableException Class

For a list of all members of this type, see ImageNotAvailableException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

ImageNotAvailableException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

IndexOutOfRangeException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

IndexOutOfRangeException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : IndexOutOfRangeException Class

For a list of all members of this type, see IndexOutOfRangeException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

IndexOutOfRangeException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

IndexOutOfRangeException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

IndexOutOfRangeException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : IndexOutOfRangeException Class

For a list of all members of this type, see IndexOutOfRangeException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

IndexOutOfRangeException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InternalErrorException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InternalErrorException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : InternalErrorException Class

For a list of all members of this type, see InternalErrorException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InternalErrorException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InternalErrorException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InternalErrorException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : InternalErrorException Class

For a list of all members of this type, see InternalErrorException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InternalErrorException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InternetFilesNotInstalledException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InternetFilesNotInstalledException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : InternetFilesNotInstalledException Class

For a list of all members of this type, see InternetFilesNotInstalledException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InternetFilesNotInstalledException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InternetFilesNotInstalledException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InternetFilesNotInstalledException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : InternetFilesNotInstalledException Class

For a list of all members of this type, see InternetFilesNotInstalledException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InternetFilesNotInstalledException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidBitDepthException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidBitDepthException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : InvalidBitDepthException Class

For a list of all members of this type, see InvalidBitDepthException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidBitDepthException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidBitDepthException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidBitDepthException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : InvalidBitDepthException Class

For a list of all members of this type, see InvalidBitDepthException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidBitDepthException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidLicenseException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidLicenseException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : InvalidLicenseException Class

For a list of all members of this type, see InvalidLicenseException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidLicenseException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidLicenseException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidLicenseException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : InvalidLicenseException Class

For a list of all members of this type, see InvalidLicenseException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidLicenseException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidPropertyException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidPropertyException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : InvalidPropertyException Class

For a list of all members of this type, see InvalidPropertyException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidPropertyException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

InvalidPropertyException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

InvalidPropertyException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : InvalidPropertyException Class

For a list of all members of this type, see InvalidPropertyException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidPropertyException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

LoadSettingsException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

LoadSettingsException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : LoadSettingsException Class

For a list of all members of this type, see LoadSettingsException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

LoadSettingsException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

LoadSettingsException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

LoadSettingsException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : LoadSettingsException Class

For a list of all members of this type, see LoadSettingsException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

LoadSettingsException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

OperationCancelledException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

OperationCancelledException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : OperationCancelledException Class

For a list of all members of this type, see OperationCancelledException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

OperationCancelledException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

OperationCancelledException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

OperationCancelledException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : OperationCancelledException Class

For a list of all members of this type, see OperationCancelledException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

OperationCancelledException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

OutOfMemoryException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

OutOfMemoryException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : OutOfMemoryException Class

For a list of all members of this type, see OutOfMemoryException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

OutOfMemoryException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

OutOfMemoryException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

OutOfMemoryException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : OutOfMemoryException Class

For a list of all members of this type, see OutOfMemoryException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

OutOfMemoryException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusFilesNotInstalledException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PegasusFilesNotInstalledException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : PegasusFilesNotInstalledException Class

For a list of all members of this type, see PegasusFilesNotInstalledException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

PegasusFilesNotInstalledException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusFilesNotInstalledException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PegasusFilesNotInstalledException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : PegasusFilesNotInstalledException Class

For a list of all members of this type, see PegasusFilesNotInstalledException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

PegasusFilesNotInstalledException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PropertyOrMethodNotAvailableException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PropertyOrMethodNotAvailableException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : PropertyOrMethodNotAvailableException Class

For a list of all members of this type, see PropertyOrMethodNotAvailableException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

PropertyOrMethodNotAvailableException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PropertyOrMethodNotAvailableException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PropertyOrMethodNotAvailableException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : PropertyOrMethodNotAvailableException Class

For a list of all members of this type, see PropertyOrMethodNotAvailableException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

PropertyOrMethodNotAvailableException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SequenceException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SequenceException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : SequenceException Class

For a list of all members of this type, see SequenceException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

SequenceException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

SequenceException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

SequenceException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : SequenceException Class

For a list of all members of this type, see SequenceException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

SequenceException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

StringIsTooLongException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

StringIsTooLongException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : StringIsTooLongException Class

For a list of all members of this type, see StringIsTooLongException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

StringIsTooLongException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

StringIsTooLongException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

StringIsTooLongException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : StringIsTooLongException Class

For a list of all members of this type, see StringIsTooLongException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

StringIsTooLongException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TiffTagItemNotFoundException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TiffTagItemNotFoundException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : TiffTagItemNotFoundException Class

For a list of all members of this type, see TiffTagItemNotFoundException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TiffTagItemNotFoundException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TiffTagItemNotFoundException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TiffTagItemNotFoundException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : TiffTagItemNotFoundException Class

For a list of all members of this type, see TiffTagItemNotFoundException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

TiffTagItemNotFoundException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TiffTagNotFoundException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TiffTagNotFoundException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : TiffTagNotFoundException Class

For a list of all members of this type, see TiffTagNotFoundException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TiffTagNotFoundException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TiffTagNotFoundException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TiffTagNotFoundException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : TiffTagNotFoundException Class

For a list of all members of this type, see TiffTagNotFoundException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

TiffTagNotFoundException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDllLoadException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainDllLoadException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : TwainDllLoadException Class

For a list of all members of this type, see TwainDllLoadException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TwainDllLoadException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainDllLoadException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainDllLoadException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : TwainDllLoadException Class

For a list of all members of this type, see TwainDllLoadException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

TwainDllLoadException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : TwainException Class

For a list of all members of this type, see TwainException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TwainException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainPro Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainPro Class Events

PegasusImaging.WinForms.TwainPro5 Namespace : TwainPro Class

For a list of all members of this type, see TwainPro members.

Public Events

Public Event Disposed (Inherited from System.ComponentModel.Component) Adds an event handler to listen to the Disposed event on the component.

See Also

TwainPro Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

TwainProException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

TwainProException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : TwainProException Class

For a list of all members of this type, see TwainProException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TwainProException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

UnsupportedFileFormatException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

UnsupportedFileFormatException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : UnsupportedFileFormatException Class

For a list of all members of this type, see UnsupportedFileFormatException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

UnsupportedFileFormatException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

UnsupportedFileFormatException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

UnsupportedFileFormatException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : UnsupportedFileFormatException Class

For a list of all members of this type, see UnsupportedFileFormatException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

UnsupportedFileFormatException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ValueOutOfRangeException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ValueOutOfRangeException Class Methods

PegasusImaging.WinForms.TwainPro5 Namespace : ValueOutOfRangeException Class

For a list of all members of this type, see ValueOutOfRangeException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ValueOutOfRangeException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

ValueOutOfRangeException Class | PegasusImaging.WinForms.TwainPro5 Namespace

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

ValueOutOfRangeException Class Properties

PegasusImaging.WinForms.TwainPro5 Namespace : ValueOutOfRangeException Class

For a list of all members of this type, see ValueOutOfRangeException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from TwainProException) | Gets the error number of the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

ValueOutOfRangeException Class | PegasusImaging.WinForms.TwainPro5 Namespace


 MSHelp:Attr Name="DocSet" Value="TwainPRO5"/

PegasusImaging.WinForms.TwainPRO5 Assembly

See Also PegasusImaging.WinForms.TwainPRO5 Send comments on this topic.

PegasusImaging.WinForms.TwainPro5 Namespace Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.TwainPro5.ApplicationIdentity
PegasusImaging.WinForms.TwainPro5.CapabilityContainer
PegasusImaging.WinForms.TwainPro5.CapabilityContainerArray
PegasusImaging.WinForms.TwainPro5.CapabilityContainerEnum
PegasusImaging.WinForms.TwainPro5.CapabilityContainerOneValue
PegasusImaging.WinForms.TwainPro5.CapabilityContainerOneValueFloat
PegasusImaging.WinForms.TwainPro5.CapabilityContainerOneValueString
PegasusImaging.WinForms.TwainPro5.CapabilityContainerRange
PegasusImaging.WinForms.TwainPro5.Caption
PegasusImaging.WinForms.TwainPro5.ExtendedImageInfoContainer
PegasusImaging.WinForms.TwainPro5.ExtendedImageInfoContainerValue
PegasusImaging.WinForms.TwainPro5.ExtendedImageInfoContainerValueFloat
PegasusImaging.WinForms.TwainPro5.ExtendedImageInfoContainerValueString
PegasusImaging.WinForms.TwainPro5.FtpOptions
PegasusImaging.WinForms.TwainPro5.Licensing
PegasusImaging.WinForms.TwainPro5.SaveOptions
PegasusImaging.WinForms.TwainPro5.SaveOptionsJpeg
PegasusImaging.WinForms.TwainPro5.SaveOptionsPdf
PegasusImaging.WinForms.TwainPro5.SaveOptionsPic
PegasusImaging.WinForms.TwainPro5.SaveOptionsTiff
PegasusImaging.WinForms.TwainPro5.ScannedImage
PegasusImaging.WinForms.TwainPro5.ScannedImageData
PegasusImaging.WinForms.TwainPro5.TwainDevice
System.Collections.CollectionBase
PegasusImaging.WinForms.TwainPro5.CapabilityContainerOneValueCollection
PegasusImaging.WinForms.TwainPro5.ExtendedImageInfoContainerValueCollection
System.Collections.ReadOnlyCollectionBase
PegasusImaging.WinForms.TwainPro5.DataSourceCollection
System.EventArgs
PegasusImaging.WinForms.TwainPro5.ScannedEventArgs
PegasusImaging.WinForms.TwainPro5.ScanningEventArgs
System.Exception
System.ApplicationException
PegasusImaging.WinForms.TwainPro5.TwainProException
PegasusImaging.WinForms.TwainPro5.CapabilityNotSupportedException
PegasusImaging.WinForms.TwainPro5.ClipboardException
PegasusImaging.WinForms.TwainPro5.CompressedImageNotAvailableException
PegasusImaging.WinForms.TwainPro5.DataSourceInvalidOperationException
PegasusImaging.WinForms.TwainPro5.FileCreateException
PegasusImaging.WinForms.TwainPro5.FileOpenException
PegasusImaging.WinForms.TwainPro5.FileReadException
PegasusImaging.WinForms.TwainPro5.FileWriteException
PegasusImaging.WinForms.TwainPro5.FtpTransferException
PegasusImaging.WinForms.TwainPro5.ImageNotAvailableException
PegasusImaging.WinForms.TwainPro5.IndexOutOfRangeException
PegasusImaging.WinForms.TwainPro5.InternalErrorException
PegasusImaging.WinForms.TwainPro5.InternetFilesNotInstalledException
PegasusImaging.WinForms.TwainPro5.InvalidBitDepthException
PegasusImaging.WinForms.TwainPro5.InvalidLicenseException
PegasusImaging.WinForms.TwainPro5.InvalidPropertyException
PegasusImaging.WinForms.TwainPro5.LoadSettingsException
PegasusImaging.WinForms.TwainPro5.OperationCancelledException
PegasusImaging.WinForms.TwainPro5.OutOfMemoryException
PegasusImaging.WinForms.TwainPro5.PegasusFilesNotInstalledException
PegasusImaging.WinForms.TwainPro5.PropertyOrMethodNotAvailableException
PegasusImaging.WinForms.TwainPro5.SequenceException
PegasusImaging.WinForms.TwainPro5.StringIsTooLongException
PegasusImaging.WinForms.TwainPro5.TiffTagItemNotFoundException
PegasusImaging.WinForms.TwainPro5.TiffTagNotFoundException
PegasusImaging.WinForms.TwainPro5.TwainDllLoadException
PegasusImaging.WinForms.TwainPro5.TwainException
PegasusImaging.WinForms.TwainPro5.UnsupportedFileFormatException
PegasusImaging.WinForms.TwainPro5.ValueOutOfRangeException
System.MarshalByRefObject
System.ComponentModel.Component
PegasusImaging.WinForms.TwainPro5.TwainPro

See Also

PegasusImaging.WinForms.TwainPro5 Namespace | PegasusImaging.WinForms.TwainPRO5 Assembly