What is PrintPRO

PrintPRO version 4 is a windowless control that enables the user to access and modify printer properties, create a print job, preview printing, and print to a device or file. PrintPRO offers the flexibility to create a custom printing UI, and may be used to interact with the printer, by-passing the print driver.

New Features in PrintPRO version 4

  • Access to device's capability settings and configuration dialog
  • Ability to maintain scanner settings for each session
  • JPG, JBIG2, TIFF-G4 compression types added to PDF save
  • TIFF write optimization (faster to write large multi-page TIFFs)

Primary Features Include:

  • Bypass Internet Explorer's printing functions and add your own rich, custom interface
  • Select a Printer
  • Set Printer Properties
  • Set Print Margins and Coordinates
  • Image Color Management for Printers and Monitors
  • Change text font, alignment, rotation, background transparency and more in printed image
  • Add graphics to printed image
  • Print collages
  • Print Preview
  • Print to Device
  • Print to File, including: TIFF, TIFF (JPEG compressed), and PDF (compressed to G3, JBig2, JPEG)
  • Send Raw Data to the Printer, by-passing the Print Driver
  • Supports single and multi-page documents

Note: Purchase the Photo Edition license of ImagXpress to access the Image Color Management features of PrintPRO.

ImagXpress v9 Product Family includes the following Components:

  • ImagXpress® v9 - image compression, decompression, viewing, and processing
  • NotatateXpress™ v9 - image annotation support
  • ThumbnailXpress™ v2 - thumbnail image support
  • TwainPRO™ v5 - TWAIN image acquisition support
  • PrintPRO™ v4 - image printing support

Additional Pegasus Imaging Components: Additional components are available for purchase separately, and integrate easily with to provide a comprehensive imaging solution:

  • PDFXpress™ – PDF creation, viewing, and annotating
  • OCRXpress™ – full page OCR
  • Barcode Xpress™ – recognize barcodes
  • ScanFix Xpress™ – advanced image cleanup
  • FormFix™ – form ID, dropout, and OMR
  • SmartZone™ ICR / OCR – character recognition

© 1997-2008 Pegasus Imaging Corporation, All Rights Reserved.


Getting Support and Samples

Benefits of Registering your Pegasus Development Kit

Purchasers of development kits need to register with Pegasus in order to be notified of updates and receive support now or in the future. Registration is automatic when purchased directly from the Pegasus web site. If purchased through a Pegasus re-seller, please register your purchase by filling out the form at PegasusImaging.com/registration.htm.

Vehicles for Support

Samples

Samples are included in the downloaded installation.

The product installation program installs a common sample folder accessible via the Start Menu.

ActiveX Samples are provided for:

  • Microsoft Visual Basic 6
  • Visual C++
  • Delphi

Access the samples

  • Through the Windows Start menu: Start | Programs | Pegasus Imaging | PrintPRO | Samples
  • Sample image files included

Sample Code Newsgroups

Customers create samples of great benefit to other developers, so we created a Sample Code Newsgroup. This is a newsgroup for our customers and potential customers. They post and receive sample code from our development team and other developers to expedite their development. Go online at:

http://www.PegasusImaging.com/samplecode.htm

Web Support

Visit the Pegasus Imaging web site frequently asked questions page ( PegasusImaging.com/faq.htm ) for the fastest answers to common questions. The web site also provides other support options that are accessible at PegasusImaging.com/supportagree.htm.

E-mail Support

Both pre-sale and post-sale e-mail support is offered free of charge. Questions are answered on a First-Come-First-Served basis. Support@JPG.com responds instantly to e-mail received with a helpful set of locations to find additional information on Pegasus products including FAQ's, sample code, newsgroup locations and other current information pertaining to the use of the products. The support request is then added to the queue of outstanding requests. The goal of the support team is to respond to each e-mail within 1 business day.

The sales team is always available as a backup to the support team. If you feel you have an urgent support or sales issue please contact Sales@JPG.com . They will assist you promptly.

Newsgroup Support

The Publicly accessible NNTP news groups located at News.PegasusImaging.com are available for each of the Controls as well as advanced imaging technology and a sample code group. We expect that the development community will freely access and search these newsgroups to find common questions and answers regarding specific uses of the controls.

On-Demand Phone Support

On-demand priority phone support can be purchased in 15 minute increments with a credit card via the Pegasus Imaging Corporation web site Support, General Info page. If you decide to purchase "on-demand" phone support, instructions will immediately be e-mailed upon receipt of your purchase.

Note: Additionally, Pegasus offers three support plans for those customers whose commercial products or projects are sensitive or critical in nature, where immediate response and 'latest release' code are important.

1. Chariot Support

All Pegasus Imaging customers are given the opportunity to purchase a Chariot Support agreement. This is a maintenance and upgrade agreement that entitles customers to priority e-mail service, direct phone support from the support and development staff and free product upgrades for the covered products. Since upgrades are included for Chariot customers at no additional charge, Chariot customers can frequently save money, plus obtain the benefits of phone and expedited support. Pegasus Imaging reserves the right to change the terms of this service at any renewal period. Contact Sales via the web at www.PegasusImaging.com/contactform.htm for more information.

2. Galleon Support

Customers are given the opportunity to purchase Galleon Support for Pegasus Imaging products that are applications and for products that require runtime licensing. Galleon Support includes licensing of product upgrades for deployed installations at no additional license fee cost. Pegasus Imaging reserves the right to change the terms of this service at any renewal period. Contact Sales via the web at www.PegasusImaging.com/contactform.htm for more information.

3. Atlas Support

All Pegasus Imaging customers are given the opportunity to purchase an Atlas Support agreement on currently supported products. This is an agreement that entitles customers to priority e-mail service and direct phone support from the support and development staff. It differs from Chariot Support in that it does not include version upgrades free of charge. Pegasus Imaging reserves the right to change the terms of this service at any renewal period. Contact Sales via the web at www.PegasusImaging.com/contactform.htm for more information.

To determine if you have the latest version of a Pegasus Imaging development toolkit, please download the PegConnect utility program. Please note that a Help File for each product may be found on the Start bar under Pegasus or in C:\Windows\Help.

For the latest and most up-to-date support information, access PegasusImaging.com/contact.htm


Pegasus Imaging Corporation

Pegasus Imaging is uniquely positioned to serve as your leading imaging technology supplier. A full suite of document imaging toolkits, forms processing technology, medical image compression SDKs, photo editing and compression libraries, browser-based image viewers, and video codecs provide advanced technology designed to enhance imaging software solutions. Fully functional trial downloads and customer-acclaimed support allow you to be certain your requirements will be met before purchase. Work with the best. Choose Pegasus Imaging for all your imaging needs.

Visit www.PegasusImaging.com for full product descriptions, FAQ's, downloads, demos, and contact information.

Pegasus Imaging

4001 North Riverside Drive

Tampa, FL 33603

Sales: 813-875-7575

Copyrights & Trademarks

Pegasus and the Pegasus Horse Logo are registered marks (®) of Pegasus Imaging Corporation.

Barcode Xpress, CapturePRO, FilePrinter, FormAssist, FormDirector, FormSuite, ISIS Xpress, The JPEG Wizard, MedXpress, NotateXpress, PDF Xpress, PICTools, ePIC, PICVideo, PrintPRO, SmartScan Xpress, SmartZone, ThumbnailXpress, and TwainPRO are trademarks (™) of Pegasus Imaging Corporation.

ImagXpress, FormFix, ScanFix, Prizm, ColorDrop, ColorEnhance, ColorFind, ColorForms, CompressDirector, Digital Mark Recognition (DMR), Image Detergent, ViewDirector and Virtual Scoring Center (VSC) by assignment are trademarks (™) or registered trademarks (®) of Pegasus Imaging Corporation.

Pegasus Imaging and/or its agents use these marks and brand names in connection with its goods and/or services, in the United States and other countries. Information in this document is subject to change without notice. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Pegasus Imaging Corporation.

Microsoft, Microsoft.NET, Visual Basic, Visual Studio and Visual Studio.NET are trademarks of Microsoft Corporation in the USA and/or other countries. All other product and brand names are the property of their respective owners.


Operating Requirements

PrintPRO™ version 4 Operating Requirements

Operating Systems

PrintPRO version 4 runs on 32-bit Microsoft Windows operating systems: 2000 Professional and Server, XP Home and Professional, Server 2003 and Server 2008. It works with 32-bit Windows versions running on 32 and 64-bit processors. It runs in 32-bit executables running under 64-bit Windows 2000 Server, 2003 Server and Server 2008. Although it may run, it is not supported on previous Windows versions (for example, Windows 95 and Windows 98).

Threading

Pegasus considers thread-safe to be when an application using this component can use multiple controls running in the same process, where they don't interfere with each other. The thread creating the control owns the control and is the only thread that can interact with it.

Development environment

Microsoft Visual Basic 6

Microsoft Visual C++ 6

Delphi 7 and 8

See Also

Installing on a Development Machine | Getting Support and Samples


Installing on a Development Machine

To Install PrintPRO™ Component

Run the downloaded setup program which installs the development kit on your development machine.

The downloaded development kit includes code samples for supported platforms. Samples are available through the Start | Programs | Pegasus Imaging | PrintPRO v4.0 menu.

By default this will register trial licensing which allows you to develop applications but not to distribute them. The trial license allows testing of all the functions and features.

Note: Please see the section Distributing Applications and Deployment to understand the limits and details to convert licensing editions.

In order to distribute your finished application you must purchase and install a fully paid license from Pegasus Imaging Corporation. The paid licenses override trial licenses.

To Use PrintPRO Help Files

Stand-alone Help file "PegasusImaging.ActiveX.PrintPRO4.chm"

Access the PrintPro v4 stand-alone help through the Windows Start menu: Start | Programs | Pegasus Imaging | PrintPRO v4.0

The stand-alone file is created with MS Help system version 1. To view stand-alone help files, you must have:

  • Windows 2000 (to view the file via the Windows HTML Help Viewer)
  • Internet Explorer 4 or higher
  • MS HTML Help Viewer


Trial Mode

Default Installation

The default installation installs Trial Mode licensing. This allows you to test features and functions and develop applications but not distribute them. Installing PrintPRO™ in trial mode provides you with access to all features and functionality of the PrintPRO product. Email support is available with the trial license.

When using the trial version of PrintPRO, an evaluation dialog box displays periodically. In addition, while using the trial version, PrintPRO will randomly replace portions of text in the output with www.PegasusImaing.com. Applications built with a trial license can only be run on a computer that has PrintPRO Licensing installed on it.

Changing Trial Mode Behavior

You have the flexibility to change the behavior of PrintPRO in evaluation mode as follows:

  • To facilitate server/service mode evaluations, developers may choose to halt the component processing after 5 minutes in lieu of displaying an evaluation dialog box periodically. This is the TimeOut setting for the PrintPRO.EvaluationMode property.

See Also

Development Mode | Runtime Licensing | License Agreement


Development Mode

To suppress the evaluation dialog box and deploy your application, or attain technical support (beyond e-mail), as well as future product updates and upgrade notifications, you must update from a trial version to a paid version of the PrintPRO development kit.

1. Purchase Development Kit(s)

To purchase licensing of the PrintPRO development kit, use one of the following options:

  • Purchase online at http://www.PegasusImaging.com/. Contact Sales via the web at www.PegasusImaging.com/contactform.htm.
  • Contact a Pegasus Imaging Corporation reseller.

When the development kit is purchased, we e-mail a serial number & registration code to you. You need these codes to upgrade from trial to paid licensing.

2. Register the PrintPRO Product

When you purchase PrintPRO online or via Sales at www.PegasusImaging.com/contactform.htm, your product ownership is automatically registered.

To register products purchased through a reseller, use the form found at http://www.PegasusImaging.com/registration.htm.

If your registration information should change, visit http://www.PegasusImaging.com/contactsupport.htm for forms to update registration information.

3. Update Your PrintPRO product version from trial to paid licensing

Updating your PrintPRO v4 from trial to paid licensing will suppress the evaluation dialog box or timeout. This must be done for each component within the ImagXpress toolkit that you are using (for example, PrintPRO v4 and ImagXpress v9). The email you receive when you purchase the product will include entries for each component.

To update components from trial to paid licensing

  • Enter your new license codes using one of the following options:
    • Enter licensing information (serial number, registration code and personal registration information) during component installation while downloading the latest release from www.PegasusImaging.com (the recommended approach).
    • Alternatively, licensing information (serial number, registration code and personal registration information) can be entered through the Visual Development Environment in response to the dialog display.
  • Rebuild any applications that used the components with trial licensing

For more information on Runtime licensing, see the Pegasus Imaging website for more detailed information regarding Runtime Licensing.

To distribute PrintPRO v4 in an application, you must acquire runtime unlock codes.

See Also

Trial Mode | Runtime Licensing | License Agreement | Getting Support and Samples


Runtime Licensing

Runtime & Deployment Licensing

All copyrights to Pegasus Imaging development kits and software are retained by Pegasus Imaging Corporation. ALL RIGHTS RESERVED. Your use of any of Pegasus Imaging software or run-times created with Pegasus Imaging software is allowed under license terms granted by Pegasus Imaging. It is the Licensee's responsibility to honor the terms of such license grants.

Locking Mechanism

PrintPRO contains a locking mechanism that does not permit you to distribute applications created with evaluation versions of PrintPRO. Prior to distributing an application that utilizes PrintPRO, you must purchase and enable run-time licensing. If the application will be delivered on the web, you must also purchase and enable web application licensing.

Obtaining Appropriate Licensing

The Licensee is required to purchase one copy of our development kit(s) for each developer in addition to obtaining the appropriate license agreement prior to deploying applications which contain Pegasus code.

Pegasus Imaging software applications and development tools are limited for use on a single CPU. Any runtimes or copies created must be granted by a direct license from Pegasus Imaging Corporation. These "end user" licenses provide the terms and limits of number and usage.

All prospective customers have every opportunity to evaluate Pegasus Imaging's products prior to purchasing. Product licensing is priced to cover what is considered to be normal (and even high) use. In addition, Pegasus Imaging fully supports and warrants its code and pricing reflects those costs as well. The larger and more valuable an application deployment is, the higher the support and warranty risk is for Pegasus.

Review the licensing categories, and select the one that matches your deployment. Special circumstances should be discussed with a Pegasus Imaging representative.

See the Pegasus Imaging website for more detailed information regarding Runtimes and Deployment Licensing.

See Also

Getting Support and Samples | Distributing with your Application


License Agreement

Pegasus Imaging Corporation

SOFTWARE LICENSE AGREEMENT

GRANT OF LICENSE

This Pegasus Imaging Corporation ("PEGASUS") Agreement ("License") permits Licensee ("LICENSEE") the right to use one copy of a properly registered Pegasus Development Toolkit ("TOOLKIT") for development purposes on any single computer, provided the TOOLKIT is in use on only one computer at any time. TOOLKIT is "in-use" on a computer when it loads into temporary memory (that is, RAM) or installed into the permanent memory (that is, hard disk, CD-ROM, or other storage device) of that computer.

REDISTRIBUTION OF THE TOOLKIT RUNTIMES

PEGASUS does NOT grant any runtime licenses with the TOOLKIT purchase, except by specific exemptions described on our licensing web pages. For Runtime Licensing information, please visit our web site (http://www.PegasusImaging.com/licensing.htm), or contact our sales staff. Any rights to distribute TOOLKIT run times as part of the LICENSEE's software application or derivative works ("PRODUCT"), require you to acknowledge and uphold this License Agreement and agree to notify PEGASUS immediately of any changes in status or violations. In cases where PEGASUS grants the LICENSEE a right to use, reproduce, display or otherwise distribute or transfer copies of TOOLKIT run times, LICENSEE agrees and affirms the following:

a) LICENSEE is not using PEGASUS' name, logo, or trademarks to market PRODUCT without prior written approval of PEGASUS.

b) LICENSEE agrees to indemnify, hold harmless and defend PEGASUS from and against any claims or lawsuits, including attorney's fees, that arise or result from the use or distribution of PRODUCT.

c) Only the TOOLKIT run times can be distributed. Distribution of the TOOLKIT development kit, documentation, source code, or the distribution unlock codes, is a violation of this agreement.

d) LICENSEE includes a statement substantially similar to the following within derivative work's documentation and about box: "This product contains portions of imaging code owned by Pegasus Imaging Corporation, Tampa, FL, (www.PegasusImaging.com). ALL RIGHTS RESERVED."

If ANY of the above terms are not applicable to LICENSEE'S situation, or any of the above cannot be complied with, or LICENSEE needs modifications to this license, for any reason; then LICENSEE shall obtain an expanded direct license from PEGASUS for derivative works, (available by phone at: 813-875-7575, x321, by e-mail at: Sales@jpg.com or by fax at: 813-875-7705).

PEGASUS reserves the right to charge the LICENSEE up to ten times the normal license price for the use of each unlicensed copy of PRODUCT. The license granted herein and all of your rights to use or maintain possession of TOOLKIT shall terminate immediately upon breach of any material provisions of this Agreement.

This license grants rights to LICENSEE for only the PEGASUS code (TOOLKIT) mentioned above and does not convey any other rights of use or distribution to PEGASUS technology.

COPYRIGHT

The Software is owned by PEGASUS or Pegasus Imaging Corporation and is protected by United States copyright laws and international treaty provisions. LICENSEE may not remove or alter the copyright notice from any copy of the Software or any copy of the written materials, accompanying the Software.

OTHER RESTRICTIONS

This PEGASUS License Agreement is LICENSEE's proof of license to exercise the rights granted herein and must be retained by LICENSEE. LICENSEE may not rent, lease or transfer TOOLKIT or parts thereof. LICENSEE may not reverse engineer, decompile or disassemble TOOLKIT.

NO WARRANTY

ANY USE BY LICENSEE OF THE SOFTWARE IS AT THE LICENSEE'S OWN RISK. THE SOFTWARE IS PROVIDED FOR USE ONLY WITH WINDOWS PRODUCTS AND RELATED APPLICATION SOFTWARE AND/OR HARDWARE PRODUCTS. THE SOFTWARE IS PROVIDED FOR USE "AS IS" WITHOUT WARRANTY OF ANY KIND. TO THE MAXIMUM EXTENT PERMITTED BY LAW, PEGASUS DISCLAIMS ALL WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. PEGASUS IS NOT OBVLIGATED TO PROVIDE ANY UPDATES TO THE SOFTWARE.

NO LIABILITY FOR CONSEQUENTIAL DAMAGES

In no event shall PEGASUS be liable for any damages whatsoever (including, without limitation, incidental, direct, indirect and consequential damages, damages for loss of business profits, business interruption, loss of business information, or other pecuniary loss) arising out of the use or inability to use this PEGASUS product, even if PEGASUS has been advised of the possibility of such damages. Because some states/countries do not allow the exclusion or limitation of liability for consequential or incidental damages, the above limitation may not apply to LICENSEE.

INDEMNIFICATION BY LICENSEE

If LICENSEE distributes TOOLKIT in violation of this Agreement, LICENSEE agrees to indemnify, hold harmless and defend PEGASUS and its suppliers from and against any claims or lawsuits, including attorney's fees that arise or result from the use or distribution of TOOLKIT in violation of this Agreement.

This Agreement is governed by the laws of the State of Florida. The program and data contained in this TOOLKIT Product are provided with Restricted Rights. Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set forth in FAR 52.227-14 (Alternate III) or subparagraph (c)(1)(II) of the rights in technical data and computer software clause at 252.227-7013. Manufacturer is Pegasus Imaging Corporation, 4001 Riverside Drive, Tampa, FL, 33603.

For questions concerning this Agreement, or to contact PEGASUS for any reason, please contact Pegasus Imaging Corporation by phone at 1-813-875-7575 x321 or email Sales@JPG.com.

See Also

Getting Support and Samples | Distributing with your Application


Verify You're Using the Latest Service Pack

Service pack updates will not overwrite paid licensing. Your paid licensing will continue to work and you will not be required to re-enter your purchased registration codes. Service pack updates do not include any changes that might "break" previously developed and/or deployed code.

Verify Latest Development Components

To verify you are using the latest version of a Pegasus Imaging Development Component or Components, please use the PegConnect utility program. Please note that a Help File for each product may be found on the Start Bar under Pegasus, or in C:\Windows\Help.

PegConnect is installed by all component product installers and is accessible through the Windows Start menu:

Start | Programs | Pegasus Imaging | Pegasus Imaging | Common | Utilities

PegConnect allows you to:

1) Check with Pegasus Imaging via online connection and verify that the installed version of the component includes all the most recent updates

2) Update to the latest version automatically with your permission

3) Determine if a control is registered or unregistered on the machine

4) Easily change the registration status from registered to non-registered, or non-registered to registered

Alternatively, you can see the currently released product build numbers at http://www.PegasusImaging.com/latestbuilds.htm.

If you require further assistance or have questions or comments, please see the section Getting Support for more detailed information.

See Also

Getting Support and Samples | Installing on a Development Machine


Distributing with your Application

Distributing PrintPRO

Check for Proper Licensing and Unlock Codes

PrintPRO contains a locking mechanism that does not permit you to distribute applications created with evaluation versions of PrintPRO. Prior to distributing an application that utilizes PrintPRO, you must purchase and enable runtime licensing. If the application will be delivered on the web, you must also enable web application licensing.

Rebuild Executable to Register

Open your project with your development tool (Visual Basic or Delphi) and rebuild the executable .exe file. The new registration information will be automatically incorporated in the new executable.

DLL Files to Distribute

Distribute the appropriate assembly DLL files with applications using the PrintPRO component.

  • PegasusImaging.ActiveX.PrintPRO4.dll - ActiveX component - ActiveX Control for accessing and modifying printer properties, create a print jobs, preview printing, and print to a device or file.
  • Oleaut32.dll - the Microsoft support DLL.
  • Stdole2.tlb - the Microsoft support file.


Definitions, Acronyms, and Abbreviations

Pegasus Imaging Definitions, Acronyms, and Abbreviations

PIC: Pegasus Imaging Corporation

Thread-safe: An application using this component can use multiple controls running in the same process, where they don't interfere with each other. The thread creating the control owns the control and is the only thread that can interact with it.


Use PrintPro (an Overview)

PrintPRO enables you to create a document composed of images, text, and graphics, and print the document to a selected printer or print to file.

The process for composing and printing documents is as follows:

  1. Select a printer. PrintPRO automatically selects the system default printer but you can select any printer connected to your system. If you want to use the default printer, you can skip to step 2.

  2. Set the printer properties. Printer properties include the paper size, print quality, orientation, etc. If you want to use the printers default properties, you can skip to step 3.

  3. Set the Image Color Management (ICM) Method and Intent as needed.

  4. Use the DocName Property to set the document name. When the system spools your document for printing, the document name appears in the list of documents to be printed. The default document name is PrintPRO Document. If you want to use the default document name, skip to step 5.

  5. Start a document. You can use the StartPrintDoc method to start a document, however, PrintPRO's text, graphics and bitmap methods will automatically start a document if one has not been started.

  6. Place text, graphics and bitmaps on the document page. The NewPage Method lets you start a new page and the Page Property returns the current page number.

  7. Create, then print and/or display print preview page(s) if desired.

  8. Print the document. Use the EndPrintDoc Method to send the document to the print spooler. If the PrintToFile Property is True, the print output is redirected to a disk file. If you want to stop printing the current document, use the KillPrintDoc Method before you start a new document.


Introduction to Image Color Management

The Problem

You scan a photo in order to edit it but the image on the screen doesn't look like the original. And when you print it out the colors are even less like the original! What you see is not what you get.

Information

The problem is that the different devices (scanner, monitor and printer) have different interpretations of the digital values for colors. Not only are the interpretations different from device to device but so is the “gamut”, the range of realizable colors (some devices can display/output/print colors that others can not).

Solution

Windows’ Image Color Management (ICM) system is the what-you-see-is-what-you-get solution to the color accuracy problem. PrintPRO allows the application programmer to enable and access ICM features.

ICM processes all images via a standardized intermediate color scheme: the Profile Connection Space (PCS). In the above example the image from the scanner would be adjusted for that particular scanner’s profile (data file) to get it into the standard color space. It would then be adjusted for that particular monitor’s profile to display or that particular printer’s profile to be printed. Each device gets its own profile and the devices must be properly calibrated to get good results.

Image Color Management is an involved subject. More information can be found at the International Color Consortium’s web site (www.color.org).

With PrintPRO there are two levels of Image Color Management: enabling the various device drivers or with Windows' ICM as specified by ICMMethod.

Note: Color Management is designed to work with 24-bit color or 8-bit grayscale images. Color correction performed on images with less bit depth than this will result in poor quality images. PrintPRO has no native ability to promote images to higher bit depth; it is recommended that you use ImagXpress to do so.

See Also

PP_IcmIntent Enumeration | PP_IcmMethod Enumeration | ICMMethod Property


State Diagram

PrintPRO enables the application to select a printer, perform printer set up, create a print job, preview the print job, and send the print job to the printing device. These tasks can be illustrated with a state diagram:

No Session in Progress

The application is free to initiate printer selection, printer set up, print job creation, or raw data transfer.

Printer Selection

Once PrintPRO has been created, the application may choose to select a printer. If no printer is selected, the default printer will be used. While a print job is in progress, the printer selection cannot be modified.

Printer SetUp

The application may chose to set up the printer, using either PrintPRO or the printer dialog. If no printer setup is conducted, the printer's default settings will be in effect. While a print job is in progress, the printer settings cannot be modified.

Send Raw Data

To bypass the print driver, the application can send raw data directly to the printer. Since the printer driver is by-passed, the data sent must be printer specific. The raw data may contain printer commands, codes and binary data. Large amounts of data may be sent to the printer using this technique.

Print Job Creation

The application calls PrintPRO methods to construct the document to be printed. Images, text, and drawings can be added to the print job.

Print Preview

At any point during job creation, the application can invoke a print preview to enable the user to view or print the page under construction.

Print Job Has Been Sent

Once the document or raw data to be sent has been finalized, the application calls EndPrintDoc or PrintRawDataEnd to send the print job to the printer spooler. PrintPRO is now done processing the job, and returns to a "No Session in Progress" state.


Set Printer Properties

PrintPRO lets you set or get most printer properties. For example, you can set the orientation of the printer paper and select the paper bin without displaying a dialog box. You cannot be guaranteed that the printer driver supports the printer property you are trying to set. The ErrorCode property will be set to 5016 if a printer property cannot be set.

The following is a list of printer properties supported by PrintPRO.

  • ColorMode property — Tells the printer to print in color or black and white.

  • Collate property — Tells the printer to collate multiple copies of a document.

  • Copies property — Tells the printer how many copies to print. You can determine the number of copies that the printer can print using the NumCopies property.

  • DitherType property — Tells the printer how to dither.

  • ICMIntent property — Tells the printer which Image Color Management method to use.

  • ICMMethod property — Tells the printer how Image Color Management should be handled.

  • PaperBin property — Tells the printer what paper bin to use. If you don’t know what paper bin to select, you can use the NumBins , BinID and BinName properties to determine the bins supported by the printer.

  • PaperSize property — Sets the printers paper size. If you don’t know what paper size to select, you can use the NumPapers , PaperID and PaperName properties to determine the papers supported by the printer.

  • PrintQuality property — Sets the print quality (low, medium, high or a specific DPI).

  • Duplex property — Tells the printer how to print double sided. You can use the DuplexCap property to determine if the printer supports duplex printing.

  • Zoom property — Sets the printers scale factor. For example, setting the Zoom property to 50 tells the printer to print at 50/100 or ½ scale.


Set Margins

PrintPRO has top, left and bottom margins that can be set using the TMargin Property, Lmargin Property, and BMargin Property respectively. Margins are used by the PrintText Method.

When the Lmargin Property is set, the CurrentX Property is automatically set to the same value. When the TMargin Property is set, the CurrentY Property is automatically set to the same value.

The AutoMargin Property can be used to automatically set the margins to the top, left and bottom of the printers display area. For example, the following code prints Hello World at the upper left corner of the display area.

Object.AutoMargin = True

Object.PrintText "Hello World"

You can also set the margins within the printers display area manually as follows:

Object.LMargin = object.DisplayX

Object.TMargin = object.DisplayY

Object.Bmargin = Object.DisplayY


Set Printer Coordinates

Printer Coordinates

Printer System

The printer coordinate system is based on the physical dimensions of the paper in the printer. The horizontal and vertical starting position (0,0) is located at the upper left corner of the paper. Printer units are defined by the ScaleMode property. The default ScaleMode is twips. If the printer has 8½ x 11in. paper and the orientation of the paper is portrait, the width of the printer is 12240 twips and the height is 15840 twips. You can get the physical height and width of the printer using the PHeight and PWidth properties.

Printer Display Area

A printer also has a display area. The display area is located inside the physical area. The ScaleWidth and ScaleHeight properties can be used to get width and height of the display area. The DisplayX and DisplayY properties can be used to get the coordinates of the upper left corner of the display area.

Printer Resolution

The resolution of a printer is measured in dots per inch. You can get the horizontal and vertical resolution of a printer using the ResX and ResY properties.

Twips

There are times when you might need to know the number of twips per printer dot (or pixel). The TwipsPerPixelX and TwipsPerPixelY properties can be used to get the printers horizontal or vertical twips per pixel.

Internal Coordinates

The PrintPRO control maintains internal coordinates that are used, and updated, by some of the text, graphics and bitmap methods. The CurrentX property can be used to get or set the internal horizontal coordinate. The CurrentY property can be used to get or set the internal vertical coordinate. For example, if the CurrentX and CurrentY properties are set to 1440 twips, the following code will print Hello World one inch from the top and left side of the paper since the PrintText method uses the CurrentX and CurrentY values to position the text.

PrintPRO1.CurrentX = 1440

PrintPRO1.CurrentY = 1440

PrintPRO1.PrintText "Hello World"


Change Font

PrintPRO has a font object that makes it easy to change the font of printed text. In some containers, the font object is not readily available. In this case, use the following methods to change the font characteristics:

  • SetCtlFontSize — sets the font size.

  • SetCtlFontStyle — sets the font style.

  • SetCtlFontName — set the font name.


Create Print Job

PrintPRO enables you to create a document to print, display, or store, and include elements such as binary data, graphics, and bitmaps within the document.

To create a document:

  1. Set the Document name using the DocName Property.
  2. Start the document by selecting the StartPrintDoc Method.
  3. HINT: To ensure that the Page Property is reset after printing an image, it is critical that the SelectDefaultPrinter Method or SetDefaultPrinterW Method is used before calling the StartPrintDoc Method.

Create the Print Job by performing the following:

  1. Set Margins - set the margins on the printed page.
  2. Add Text - add text to the document to be printed.
  3. Add Binary Data - add binary data to the document to be printed.
  4. Add Bitmaps - add bitmaps to the document to be printed.
  5. Add Graphics - add graphics to the document to be printed.
  6. For multiple page documents, use the NewPage Method to advance to the next page. The Page Property returns the current page number.
  7. End the document by selecting the EndPrintDoc Method. This will result in your document being sent to the device spooler. KillPrintDoc Method can be called to immediately terminate the print job if needed.


Add Text

PrintPRO gives the developer flexibility when adding text. The simplest way to add text is to use the PrintText Method .

Placing text

The PrintText method adds text at the CurrentX Property and CurrentY Property position. If the AddCR Property is set to True, PrintText Method automatically inserts a carriage return after the text is printed. The PrintText Method does not wrap text to a new line if it does not fit on the current line.

The TextHeight Method and the TextWidth Method can be used to return the height and width of a text string.

Aligning text

If you want to align the text, use the PrintTextAligned Method . This method automatically aligns text inside a rectangular area using the alignment style defined by the Alignment Property . Text will also automatically wordwrap if the WordWrap Property is set to True.

Rotating text

If you want to rotate the text, use the PrintTextRotated Method . This method lets you specify a rotation angle, pivot point and pivot mode. If the pivot point is not specified, the CurrentX Property and CurrentY Property values are used. The pivot mode specifies whether the text is left justified, right justified or center justified at the pivot point.

Setting fonts

The Font object lets you set the printer's font name, size, and attributes (bold, underline, etc.). Use the Font Property to return a font object. If some containers, the font object is not readily available. In this case, use the following methods to change the font characteristics:

  • SetCtlFontSize — sets the font size.

  • SetCtlFontStyle — sets the font style.

  • SetCtlFontName — set the font name.

Setting background style

The BackStyle Property lets you display text transparently or on a solid color background. The BackColor Property determines the color of the text background and the ForeColor Property determines the color of the text.


Add Binary Data

To add binary data stored in an array of bytes, use the PrintData Method.

To add data to print directly to the current printer, use the PrintRawData Method. Since the printer driver is by-passed by this method, the data must be printer specific. The raw data may contain printer commands, codes and binary data. Large amounts of data may be sent to the printer using this technique.


Add Bitmaps

PrintPRO lets you print Device Independent Bitmaps (DIB) and Device Dependent Bitmaps (DDB).

Bitmaps can be printed stretched (or resized) inside a rectangular area with or without the aspect ratio being maintained. The ability to automatically maintain the bitmap's aspect ratio makes it easy to display large document images correctly on the printed page.

Adding a DIB

To add a DIB, the hDIB Property must first be set to a valid Windows DIB handle. The ImagXpress control exports a Windows DIB handle. Next, use the PrintDIB Method to print the DIB. The DIBHeight Property and DIBWidth Property return the height and width of the DIB. If the OwnDIB Property is True, PrintPRO will delete the DIB after it is printed.

Adding a DDB

To print a DDB, the Picture Property must first be set to a valid bitmap. The ImagXpress control export bitmaps using a Picture Property or the Picture property can be set using the LoadPicture function in Visual Basic. Next, use the PrintPicture Method to print the DDB. The PictureHeight Property and PictureWidth Property Picture return the height and width of the DDB. If you want to print a Device Dependent Bitmap using a handle to the bitmap (HBITMAP), you can first set the Picture Property using the SetPictureBMP Method then print the bitmap using the PrintPicture Method.

Adding a Transparent Bitmap

Bitmaps can be printed transparently. To print a bitmap transparently, set the PictureTransparent Property to True, then set the PictureTransparentColor Property to the color in the image that you want transparent.


Add Graphics

PrintPro supports adding the following graphic types to the document to be printed:

  • Arcs - use the DrawArc Method.
  • Curves - use the DrawCurve Method
  • Lines, Rectangles, and Points - use the DrawLine Method
  • Circles and Ellipses - use the DrawCircle Method
  • Pie Shapes - use the DrawPie Method
  • Polygons - use the DrawPolygon Method
  • Rectangles with Rounded Corners - use the DrawRoundRect Method

The method used to draw the graphic is determined by the following:

  • FillColor - to set the color to fill the graphic.
  • FillStyle - to set the pattern to fill the graphic.
  • DrawMode - to specify how pen color and background color will be combined.
  • DrawStyle - to determine the pattern of the line defining the graphic.
  • DrawWidth - to set the width of the line defining the graphic.


Print Preview

PrintPRO lets you create a print preview image for any document page.

1. Decide whether to display print preview while printing document

You can create print preview images only or you can simultaneously create print preview images while printing a document. Set the PrintPreviewOnly Property to True if you only want to create print preview images. If you plan on creating print preview images while printing a document, you need to start a print document using the StartPrintDoc Method before initiating a print preview.

2. Initiate Print Preview

To initiate a print preview, you must call the StartPrintPreview Method. After initiating a print preview, continue to create the document to print. Use the EndPrintPreview Method to end the print preview. If you are creating a multiple page document, PrintPRO will automatically create a print preview for each page.

3. View a Print Preview page:

When you want to view a print preview for a page, you first need to determine the size of the print preview image using the PrintPreviewScale Property. Next, use the GetPrintPreview Method to create a bitmap image for the page you want to view. Finally, use the PrintPreviewPicture Property, PrintPreviewDIB Property, or PrintPreviewDDB Property to export the print preview image.

4. Resource Cleanup:

Print preview requires system resources that PrintPRO automatically takes care of. You can, however, delete the print preview resources yourself. The DelPrintPreviewPicture Method deletes the print preview bitmap image. You can always recreate the bitmap using the GetPrintPreview Method, so deleting the bitmap image when it is no longer needed will conserve system resources.

The DelPrintPreview Method deletes the print preview resources for a page. If you delete the print preview resources, you cannot recreate the bitmap image for that page.

Example:

The following code creates a simple print preview of a single line of text. An ImagXpress control is used to display the image.

PrintPRO1.PrintPreviewOnly = True

PrintPRO1.StartPrintPreview

PrintPRO1.PrintText "Print Preview Page 1"

PrintPRO1.EndPrintPreview

PrintPRO1.GetPrintPreview 1

ImagXpress.Picture = PrintPRO1.PrintPreviewPicture

If you want to draw directly to the print preview Device Context (DC), use the hMetaDC Property to obtain the DC.


Print to a File

This sample shows that with PrintPRO printing to a file is very much the same as generating printer output but with a few properties set to the appropriate values. Any printer output, regardless of how it is generated, can be easily directed to a file.

' NOTE: all of the dimensions in this demo are in twips.

' Give the document a name.The default document

' name is PrintPRO Document.

PrintPRO1.DocName = "Pegasus's PrintPRO Demo"

PrintPRO1.OutputFileName = App.Path + "\PegasusTst.tif"

' Direct output to a file instead of a printer.

PrintPRO1.PrintToFile = True

' Specify which kind of file, could be:

' PP_TIF_G4 (B&W COMPRESSED - STANDARD)

' PP_TIF (COLOR)

' PP_TIF_G3 (B&W COMPRESSED)

' PP_TIF_G3_2D (B&W COMPRESSED)

' PP_TIF_BMP (COLOR)

' PP_EMF (ENHANCED META-FILE)

' PP_PDF_G4 (B&W COMPRESSED IMAGE FILE)

PrintPRO1.SaveFileType = PP_TIF

' Specify the density for the file.

PrintPRO1.RequestedDPI = 100

' Start a print job by starting a new page.

PrintPRO1.StartPrintDoc

PrintPRO1.PrintPreviewOnly = False

' Print the information on the page just as you would for

' creating printer output...

PrintPRO1.BackStyle = 1 'Opaque

PrintPRO1.ForeColor = RGB(255, 255, 255) 'White text

PrintPRO1.BackColor = RGB(0, 0, 0) 'Black background

PrintPRO1.Font.Name = "arial"

PrintPRO1.Font.Bold = True

PrintPRO1.Font.Size = 24

PrintPRO1.Alignment = ALIGN_CenterJustifyMiddle ' Center justify the text

prWidth = PrintPRO1.PWidth

PrintPRO1.PrintTextAligned " Hello! Check out PrintPRO 4.0 ", 1000, PrintPRO1.TMargin, prWidth - 1000, 1100

' Add a previously loaded graphic to the output.

PrintPRO1.PrintPicture 1640, 5700, 0, 0, 0, 0, 0, 0, True

' End the print job. This will end the current page and create the file.

PrintPRO1.EndPrintDoc


Print Using PrintPRO and ImagXpress

VB Example using PrintPRO and ImagXpress:

' define variables

Dim a As Integer

Dim b As Integer

' set the handle to the dib and scale mode

PrintPRO1.hDib = ImagXpress1.hDib

PrintPRO1.ScaleMode = SCALE_Pixel

' start the print document

PrintPRO1.StartPrintDoc

' set the margins

a = PrintPRO1.ScaleWidth - PrintPRO1.LMargin

b = PrintPRO1.ScaleHeight - PrintPRO1.TMargin - PrintPRO1.BMargin

PrintPRO1.PrintDIB PrintPRO1.LMargin, PrintPRO1.TMargin, a, b, 0, 0, 0, 0, True

' end the print document

PrintPRO1.EndPrintDoc


Print Without ImagXpress

To print a document, you should use the following technique:

  1. Select a printer. PrintPRO automatically selects the system default printer but you can select any printer connected to your system. If you want to use the default printer, you can skip to step 2.

  2. Set the printer properties. Printer properties include the paper size, print quality, orientation, etc. If you want to use the printers default properties, you can skip to step 3.

  3. Use the DocName property to set the document name. When the system spools your document for printing, the document name appears in the list of documents to be printed. The default document name is PrintPRO Document. If you want to use the default document name, skip to step 4.

  4. Start a document. You can use the StartPrintDoc method to start a document, however, PrintPROs text, graphics and bitmap methods (e.g. PrintText) will automatically start a document if one has not been started.

  5. Print text, graphics and bitmaps on the document page. The NewPage method lets you start a new page and the Page property returns the current page number.

  6. Print the document. Use the EndPrintDoc method to send the document to the print spooler.

If you want to stop printing the current document, before you start a new document, use the KillPrintDoc method.

' Define variables

Dim a As Integer

Dim b As Integer

' define the image and scale mode

PrintPRO1.Picture = LoadPicture ("\MyDocuments\mypicture.bmp")

PrintPRO1.ScaleMode = SCALE_Pixel

' start the print

PrintPRO1.StartPrintDoc

' set the margins

a = PrintPRO1.ScaleWidth - PrintPRO1.LMargin

b = PrintPRO1.ScaleHeight - PrintPRO1.TMargin - PrintPRO1.BMargin

PrintPRO1.PrintDIB PrintPRO1.LMargin, PrintPRO1.TMargin, a, b, 0, 0, 0, 0, True

' end the print document

PrintPRO1.EndPrintDoc


Print a Multi-Page TIFF Image Using ImagXpress and PrintPRO

This example uses an ImagXpress control to load a multi-page (TIFF, PDF, ICO, MODCA or DCX) file, PrintPRO then prints them, one page at a time.

' define the variables

Dim a As Integer

Dim b As Integer

Dim counter As Integer

' start the print document

PrintPRO1.PrintDialog

PrintPRO1.StartPrintDoc

' set the counter to go through each page of the document

For counter = 1 To ImagXpress1.NumPages(ImagXpress1.FileName)

IX1.PageNbr = counter

IX1.FileName = ImagXpress1.FileName

PrintPRO1.hDib = ImagXpress1.hDib

' set the margins

a = PrintPRO1.ScaleWidth - 1 - PrintPRO1.LMargin

b = PrintPRO1.ScaleHeight - 1 - PrintPRO1.TMargin - PrintPRO1.BMargin

PrintPRO1.PrintDIB PrintPRO1.LMargin, PrintPRO1.TMargin, a, b, 0, 0, 0, 0, True

PrintPRO1.NewPage

' iterate through each page

Next counter

' end print document when all pages are complete

PrintPRO1.EndPrintDoc


Send Raw Data to the Printer, bypassing the Print Driver

Open a direct-to-printer print session by calling PrintRawDataStart.

Specify data to be sent directly to the printer by calling PrintRawData.

Send the print data, then close the direct-to-printer session by calling PrintRawDataEnd.


Debug Your Application

Because debugging and writing debug information to a log file is time consuming and expensive, PrintPRO provides the ability to control the level of information written to the debug log as well as the ability to turn off writing to a file completely.

Use the objects below to adjust the settings of your debugging, event handling, memory and IDispose for optimal performance.

Control Debugging Information

  • Debug - Turns on or off the ability to write to the debug log file.
  • DebugLogFile - A filename which stores the debug log information.
  • ErrorLevel - Controls the amount of information that is written to the debug log file.

Note: When ErrorLevel is set to Detailed, PrintPRO logs most of your calls to the component including the occurrence of exceptions, the result of most major operations and the operation of each event it raises.

Troubleshooting

Stop Memory Leaks

After using the PrintPRO object, call the Dispose method.

Reset the Page Property after Printing the Image

Please make sure that the SelectDefaultPrinter method or SetDefaultPrinter method is being called before using the StartPrintDoc method.

Error Codes

Listed below is a cross reference of error codes and their corresponding descriptions.

    • -5000 — No printer DC.

    • -5001 — A document has already been started.

    • -5002 — A document has not been started.

    • -5003 — StartPrintDoc method failed.

    • -5004 — Windows StartPage function failed.

    • -5005 — Print dialog failed probably because the user clicked the Cancel button.

    • -5006 — EndPrintDoc failed probably because the printer reported an error.

    • -5007 — Bad radius value.

    • -5008 — Bad angle value.

    • -5009 — The Windows StretchBlt function failed when printing a bitmap.

    • -5010 — No Memory.

    • -5011 — Invalid printer number.

    • -5012 — Invalid parameter.

    • -5013 — No printer selected.

    • -5014 — Cannot open the printer.

    • -5015 — Cannot get the property value.

    • -5016 — Cannot set the property value.

    • -5017 — Invalid DIB handle.

    • -5018 — Setup dialog failed, probably because the user pressed the Cancel button

    • -5019 — The Picture property or hDIB property has not been set.

    • -5020 — Cannot get default printer information from the system

    • -5021 — Cannot write to the printer

    • -5022 — Cannot end a print job

    • -5023 — Invalid print preview page number

    • -5024 — A print preview for the current page does not exist

    • -5025 — Cannot get matafile DC

    • -5026 — Cannot create overlay

    • -5027 — Cannot open file

    • -5028 — No DIB

    • -5029 — Error reading file

    • -5030 — Invalid TIFF size

    • -5031 — Error writing file

    • -5032 — TIFF tag not found

    • -5033 — TIFF tag item not found

    • -5034 — Invalid profile

    • -5035 — Generic GDI

    • -5036 — Invalid template

    • -5037 — Invalid print preview

    • -5038 — Invalid handle

    • -5039 — Cannot get error message

    • -5040 — Generic Win32 error

    • -5041 — Printing disabled

    • -5042 — Invalid pointer

    • -5043 — Invalid bin ID

    • -5044 — Invalid paper ID

    • -5045 — Cannot create compatible device

    • -5333 — Invalid license edition

    • -5400 — Invalid worker object ID

    • -5500 — Error initializing worker

    • -5900 — Printer driver failure

    • -5995 — Invalid license

    • -5996 — Invalid web code

    • -5999 — Not license


See Also

PrintPro Members

See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

PrintPro Object

Description

Pegasus Imaging PrintPro Control v4.0

For a list of all members defined in this module, see PrintPro members.

Object Model

See Also

PrintPro Members


PrintPro Overview

PrintPro Object Members

Public Methods

Public Method AboutBox | Displays a licensing, version and copyright information dialog box for PrintPRO.
Public Method BinID | Returns the printer manufacturer's bin ID number for the specified printer bin.
Public Method BinName | Returns the name of the specified paper bin.
Public Method DelPrintPreview | Deletes the print preview resources for a specified page.
Public Method DelPrintPreviewPicture | Deletes the current print preview bitmap.
Public Method DrawArc | Creates an arc on a document to be printed.
Public Method DrawCircle | Creates a circle or ellipse on a document to be printed.
Public Method DrawCurve | Creates a Bezier curve on a document to be printed.
Public Method DrawLine | Creates lines and rectangles on a document to be printed.
Public Method DrawPie | Creates a pie-shaped wedge on a document to be printed.
Public Method DrawPolygon | Creates a three to six sided polygon on a document to be printed.
Public Method DrawRoundRect | Creates a rectangle with rounded corners on the document to be printed.
Public Method EndPrintDoc | Releases the current document to the print device or spooler.
Public Method EndPrintPreview | Creates print preview resources for the current print preview page.
Public Method GetMaxDPI | Fetches the maximum DPI resolution available.
Public Method GetPrintPreview | Creates a bitmap image for a print preview page and sets the PrintPreviewPicture property.
Public Method KillPrintDoc | Call this method to allow the PrintPRO control to run on a specified web site.
Public Method NewPage | Ends the current page and advances to the next page.
Public Method PaperID | Returns the printer manufacturer's paper ID number for any supported paper.
Public Method PaperName | Returns the printer manufacturer's paper name for any supported paper.
Public Method PrintData | Places data stored in an array of bytes into the document to be printed.
Public Method PrintDialog | Displays a printer dialog box.
Public Method PrintDIB | Draws a device independent bitmap (DIB) on a document to be printed.
Public Method PrintPicture | Draws a bitmap image on a document to be printed.
Public Method PrintRawData | Outputs data directly to a printer.
Public Method PrintRawDataEnd | Closes the direct-to-printer session.
Public Method PrintRawDataStart | Opens a direct-to-printer print session.
Public Method PrintTemplateDIB | Incorporates the image currently represented by the control's hDIB member according to a line from the TemplateFile.
Public Method PrintTemplatePicture | Incorporates the image currently represented by the control's Picture member according to a line from the TemplateFile.
Public Method PrintText | Places text in the document to be printed.
Public Method PrintTextAligned | Places text on the document inside a specified rectangular area within the display area.
Public Method PrintTextRotated | Places text rotated on the document to be printed.
Public Method SelectDefaultPrinter | Selects the system default printer.
Public Method SelectPrinter | Selects one of the printers installed on the system.
Public Method SelectPrinterByName | Selects one of the printers installed on the system by the given printer name.
Public Method SetCtlFontName | Sets the font name.
Public Method SetCtlFontSize | Sets the font size.
Public Method SetCtlFontStyle | Sets the font style.
Public Method SetDefaultPrinterW | Selects the system default printer.
Public Method SetPictureBMP | Sets the Picture property using a handle to a Device Dependent Bitmap and a handle to a palette.
Public Method SetupDialog | Displays a printer setup dialog box that lets the user change printer properties.
Public Method StartPrintDoc | Creates a document to be composed and printed.
Public Method StartPrintPreview | Starts a print preview for the current page.
Public Method TextHeight | Calculates the height of a text string as it would be printed in the current font.
Public Method TextWidth | Calculates the width of a text string as it would be printed in the current font.
Public Method UnlockRuntime | Called to allow the control to run as a non-trial mode.
Public Method UnlockWeb | Called to allow the control to run as a non-trial mode when being used on a web page.

Public Properties

Public Property AddCR | Gets and sets the automatic carriage return flag.
Public Property Alignment | Gets and sets the text alignment style used by the PrintTextAligned method.
Public Property AlignTextHeight | Gets the line height based on the Alignment property centering in pixels.
Public Property AutoMargin | Gets or sets a value to determine if the margin values and the current print position values should automatically be set to values inside the printer's display area.
Public Property BackColor | The background color of printed text.
Public Property BackStyle | Sets the background style of printed text.
Public Property BMargin | Gets or sets the bottom margin value.
Public Property Collate | Gets or sets an indicator whether collation should be used when printing multiple copies (if the printer supports this feature).
Public Property ColorMode | Gets or sets a value that determines whether a color printer prints output in color or monochrome.
Public Property Copies | Gets or sets a value that determines the number of copies to be printed.
Public Property CurrentX | Returns or sets the horizontal coordinate for the next printing or drawing method.
Public Property CurrentY | Gets or sets the vertical coordinate for the next printing or drawing method.
Public Property Debug | A property that represents whether or not debug logging is turned on.
Public Property DebugErrorLevel | Minimum error level a debug message must be for it to be logged in the log file.
Public Property DebugLogFile | The file name and location of the debug log file.
Public Property DIBHeight | Gets the height of the bitmap defined by the hDIB property in printer units defined by the ScaleMode property.
Public Property DIBWidth | Gets the width of the bitmap defined by the hDIB property in printer units defined by the ScaleMode property. Not available at design time.
Public Property DisplayX | Gets the horizontal coordinate of the display area in printer units defined by the ScaleMode property.
Public Property DisplayY | Gets the vertical coordinate of the display area in printer units defined by the ScaleMode property.
Public Property DitherType | Gets or sets a value that specifies how dithering is to be done (if the printer supports this feature).
Public Property DocName | Gets or sets the document name.
Public Property DrawMode | Gets or sets a value that determines the appearance of output from graphics methods.
Public Property DrawStyle | Gets or sets a value that determines the line style for output from graphics methods.
Public Property DrawWidth | Gets or sets the line width for output from graphics methods.
Public Property Duplex | Gets or sets a value that determines whether a page is printed on both sides (if the printer supports this feature). Not available at design time.
Public Property DuplexCap | Gets an indicator if duplex printing is possible.
Public Property ErrorCode | Gets and sets the error code.
Public Property ErrorDescription | Gets or sets the error description.
Public Property EvaluationMode | Gets and sets the type of evaluation operation for the component.
Public Property FillColor | Gets or sets the color used to fill in circles, boxes, round rectangles, pie-shapes and polygons created with the DrawCircle, DrawLine, DrawRoundRect, DrawPie and DrawPolygon graphics methods.
Public Property FillStyle | Gets or sets the pattern used to fill circles, boxes, round rectangles, pie-shapes and polygons created with the DrawCircle, DrawLine, DrawRoundRect, DrawPie and DrawPolygon graphics methods.
Public Property Font | Gets a Font object.
Public Property ForeColor | Gets or sets the color used to display text.
Public Property hDC | Gets a handle to the device context of a printer.
Public Property hDIB | Gets or sets a handle to a device independent bitmap image (DIB).
Public Property hMetaDC | Gets a handle to the current print preview metafile device context (DC).
Public Property ICMIntent | Gets or sets a value that specifies which of three possible color management methods, or intents, should be used by default (if the printer supports this feature).
Public Property ICMMethod | Gets or sets a value that specifies how Image Color Management (ICM) is handled.
Public Property ICMMonitorProfileName | This is the file name of the monitor's color management profile.
Public Property ICMPrinterProfileName | This is the file name of the printer's color management profile.
Public Property ICMProfileRenderIntent | Gets and sets the purpose of the color correction.
Public Property ICMWantProof | Gets an indicator if ICM is used.
Public Property Licensed | Gets or sets an indicator if the component is licensed.
Public Property Lmargin | Gets or sets the left margin value.
Public Property MediaType | Gets or sets a value that specifies the type of media being printed on (if the printer supports this feature).
Public Property NumBins | Gets the number of bins supported by the printer.
Public Property NumCopies | Returns the number of copies that the printer can print.
Public Property NumPapers | Gets the number of papers supported by the printer.
Public Property NumPrinters | Gets the number of printers installed on the system.
Public Property Orientation | Gets or sets a value indicating whether documents are printed in portrait or landscape mode (if the printer supports this feature).
Public Property OutputFileName | Gets or sets a string value that specifies the print output file.
Public Property OwnDIB | Gets or sets the DIB ownership flag.
Public Property Page | Gets the current page number.
Public Property PaperBin | Gets or sets a value indicating the default paper bin on the printer from which paper is fed when printing (if the printer supports this feature).
Public Property PaperSize | Gets or sets a value indicating the paper size for the current printer (if the printer supports this feature).
Public Property PdFromPage | Gets and sets the initial value for the starting page edit control in the print dialog box.
Public Property PdMaxPage | Gets or sets a value indicating the maximum page number allowed for the end page number when the user selects the Pages radio button on the Print Dialog box.
Public Property PdMinPage | Gets or sets a value indicating the minimum page number allowed for the start page number when the user selects the Pages radio button on the Print Dialog box.
Public Property PdRange | Gets a value indicating the Print Range selected on the Print Dialog box.
Public Property PdRangeEnable | Gets or sets a value indicating which Print Range radio buttons are enabled on the Print Dialog box.
Public Property PdToPage | Gets or sets a value indicating the end page number when the user selects the Pages radio button on the Print Dialog box.
Public Property PHeight | Gets the height of the bitmap defined by the Picture property in printer units defined by the ScaleMode property. Not available at design time. A bitmap image must be loaded into the control using the Picture property.
Public Property Picture | Gets or sets a bitmap image to load into the control.
Public Property PictureHeight | Gets the height of the bitmap defined by the Picture property in printer units defined by the ScaleMode property.
Public Property PictureTransparent | Sets or returns the transparent picture flag.
Public Property PictureTransparentColor | Sets or returns the transparent color of the image in the control.
Public Property PictureWidth | Gets the width of the bitmap defined by the Picture property in printer units defined by the ScaleMode property.
Public Property PrintEnabled | Disables or enables all printing.
Public Property PrinterDriverName | Returns the current printer driver name.
Public Property PrinterName | Returns the current printer name.
Public Property PrinterNum | Gets the index of the current printer in the printer collection.
Public Property PrinterPortName | Returns the name of the port through which a document is sent to a printer.
Public Property PrintPreviewDDB | Gets a handle to the print preview Device Dependent Bitmap (DDB).
Public Property PrintPreviewDIB | Gets a handle to the print preview Device Independent Bitmap (DIB).
Public Property PrintPreviewOnly | Determines whether PrintPRO only generates print preview images.
Public Property PrintPreviewPicture | Gets a picture object of the print preview page.
Public Property PrintPreviewScale | Sets the size of the print preview image.
Public Property PrintQuality | Gets or sets a value indicating the printer resolution (if the printer supports this feature).
Public Property PrintRightToLeft | Gets and sets an indicator which determines if text output is printed from right-to-left.
Public Property PrintToFile | Gets and sets an indicator if the print output from printer devices to disk file is redirected.
Public Property PWidth | Gets the physical width of the paper set up for the printing device, in units determined by the ScaleMode property.
Public Property RaiseExceptions | Gets and sets an indicator whether to raise exceptions.
Public Property RequestedDPI | Gets or sets the current DPI resolution.
Public Property ResX | Gets the horizontal resolution of the printer in dots per inch (e.g. 600 DPI).
Public Property ResY | Gets the vertical resolution of the printer in dots per inch (e.g. 600 DPI).
Public Property SaveFileType | Controls the type of file generated.
Public Property ScaleHeight | Gets the number of units for the vertical measurement of the interior of a printer.
Public Property ScaleMode | Gets or sets a value indicating the unit of measurement for coordinates of an object when printing or using graphics methods.
Public Property ScaleWidth | Gets the number of units for the horizontal measurement of the interior of a printer.
Public Property TemplateFile | The photograph collage description file name.
Public Property TMargin | Gets or sets the top margin value.
Public Property TTOptions | Gets or sets a value indicating the printer’s TrueType option.
Public Property TwipsPerPixelX | Gets the number of twips per pixel for a printer measured horizontally.
Public Property TwipsPerPixelY | Gets the number of twips per pixel for a printer measured vertically.
Public Property UseDefaultPrinter | Gets and sets an indicator whether PrintPRO uses the system default printer by default.
Public Property UseHardwareMargins | Gets and sets an indicator if hardware margins are used.
Public Property WordWrap | Gets and sets a value to determine whether text word wraps inside the PrintText method’s print rectangle.
Public Property Zoom | Gets or sets the percentage by which printed output is to be scaled up or down (if the printer supports this feature).

See Also

PrintPro Overview


PrintPro Object

AboutBox Method

Description

Displays a licensing, version and copyright information dialog box for PrintPRO.

Syntax

Public Sub AboutBox()

See Also

PrintPro Object


PrintPro Object | NumBins Property

BinNum
Defines the printer's bin for which you want the ID. The value of number can be from 1 to the NumBins property value.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

BinID Method

Description

Returns the printer manufacturer's bin ID number for the specified printer bin.

Syntax

Public Function BinID( _
   ByVal BinNum As Long _
) As Long

Parameters

BinNum
Defines the printer's bin for which you want the ID. The value of number can be from 1 to the NumBins property value.

Return Type

A long value which represents the printer bin using the PaperBin property.

See Also

PrintPro Object | NumBins Property


PrintPro Object

BinNum
Defines the printer's bin for which you want a name. The value of number can be from 1 to the NumBins property value.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

BinName Method

Description

Returns the name of the specified paper bin.

Syntax

Public Function BinName( _
   ByVal BinNum As Long _
) As String

Parameters

BinNum
Defines the printer's bin for which you want a name. The value of number can be from 1 to the NumBins property value.

Return Type

A string value which represents the specified paper bin.

See Also


PrintPro Object | DelPrintPreviewPicture Method

pageNum
The page number for which print preview resources are to be deleted. Page numbers start with 1.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

DelPrintPreview Method

Description

Deletes the print preview resources for a specified page.

Syntax

Public Sub DelPrintPreview( _
   ByVal pageNum As Long _
)

Parameters

pageNum
The page number for which print preview resources are to be deleted. Page numbers start with 1.

Remarks

System resources are required whenever you create a print preview page. These resources are automatically deleted when the PrintPRO control is unloaded or when you replace a current print preview page with a new one.

You can also use this method to delete the print preview page resources when you no longer need them.

Deleting a print preview page does not delete the bitmap image associated with the print preview page, if one exists. Use the DelPrintPreviewPicture method to delete the current print preview bitmap image.

If you call this method to delete print preview resources, you cannot recreate the print preview bitmap image.

See Also

PrintPro Object | DelPrintPreviewPicture Method


PrintPro Object

DelPrintPreviewPicture Method

Description

Deletes the current print preview bitmap.

Syntax

Public Sub DelPrintPreviewPicture()

Remarks

System resources are required whenever you create a print preview page. These resources are automatically deleted when the PrintPRO control is unloaded or when you replace a current print preview page with a new one.

You can also use the DelPrintPreviewPicture method to delete the print preview bitmap image when you no longer need it.

Deleting a print preview bitmap does not delete the print preview page resources. Use the DelPrintPreview method to delete the print preview page resources.

If you call the DelPrintPreviewPicture method to delete the print preview bitmap image, you can always recreate the bitmap using the GetPrintPreview method. So Deleting the bitmap image when it is no longer needed will conserve system resources.

See Also


DrawArc Method

PrintPro Object

X1
Single-precision floating-point value indicating the upper-left x coordinate for the bounding rectangle.
Y1
Single-precision floating-point value indicating the upper-left y coordinate for the bounding rectangle
X2
Single-precision floating-point values indicating the lower-right x coordinate for the bounding rectangle
Y2
Single-precision floating-point values indicating the lower-right y coordinate for the bounding rectangle
StartAngle
Single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
EndAngle
Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
penColor
Long integer value indicating the RGB color of the arc. You can use the RGB function or QBColor function to specify the color.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

DrawArc Method

Description

Creates an arc on a document to be printed.

Syntax

Public Sub DrawArc( _
   ByVal X1 As Single, _
   ByVal Y1 As Single, _
   ByVal X2 As Single, _
   ByVal Y2 As Single, _
   ByVal StartAngle As Single, _
   ByVal EndAngle As Single, _
   ByVal penColor As ULong _
)

Parameters

X1
Single-precision floating-point value indicating the upper-left x coordinate for the bounding rectangle.
Y1
Single-precision floating-point value indicating the upper-left y coordinate for the bounding rectangle
X2
Single-precision floating-point values indicating the lower-right x coordinate for the bounding rectangle
Y2
Single-precision floating-point values indicating the lower-right y coordinate for the bounding rectangle
StartAngle
Single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
EndAngle
Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
penColor
Long integer value indicating the RGB color of the arc. You can use the RGB function or QBColor function to specify the color.

Remarks

Draws an elliptical arc.

The center of the arc is the center of the bounding rectangle specified by x1, y1, x2 and y2.

The bounding rectangle must be within the physical area of the printed page.

The starting and end points of the arc are determined by the StartAngle and EndAngle values. The arc is drawn in a counterclockwise direction.

The width of the line used to draw the arc depends on the setting of the DrawWidth property.

The way the arc is drawn on the background depends on the setting of the DrawMode and DrawStyle properties.

If a printer has not been selected or a document has not been started, the DrawArc method will select the default printer and start a new document.

You can omit an argument in the middle of the syntax, but you must include the argument’s comma before including the next argument. If you omit an optional argument, omit the comma following the last argument you specify.

When DrawArc executes, the CurrentX and CurrentY properties are set to X2 and Y2.

See Also


DrawCircle Method

PrintPro Object

X
Single-precision value indicating the x coordinate for the center point of the circle or ellipse.
Y
Single-precision value indicating the y coordinate for the center point of the circle or ellipse.
Radius
Single-precision value indicating the radius of the circle or ellipse.
penColor
Long integer value indicating the RGB color of the circle’s outline. You can use the Visual Basic RGB function or QBColor function to specify the color.
Aspect
Single-precision value indicating the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

DrawCircle Method

Description

Creates a circle or ellipse on a document to be printed.

Syntax

Public Sub DrawCircle( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Radius As Single, _
   ByVal penColor As ULong, _
   ByVal Aspect As Single _
)

Parameters

X
Single-precision value indicating the x coordinate for the center point of the circle or ellipse.
Y
Single-precision value indicating the y coordinate for the center point of the circle or ellipse.
Radius
Single-precision value indicating the radius of the circle or ellipse.
penColor
Long integer value indicating the RGB color of the circle’s outline. You can use the Visual Basic RGB function or QBColor function to specify the color.
Aspect
Single-precision value indicating the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen.

Remarks

The coordinates of the center point must be within the physical area of the printed page.

To fill a circle, set the FillColor and FillStyle properties of the object on which the circle or ellipse is drawn.

The width of the line used to draw the circle or ellipse depends on the setting of the DrawWidth property.

The way the circle is drawn on the background depends on the setting of the DrawMode and DrawStyle properties.

You can omit an argument in the middle of the syntax, but you must include the argument’s comma before including the next argument. If you omit an optional argument, omit the comma following the last argument you specify.

If a printer has not been selected or a document has not been started, the DrawCircle method will select the default printer and start a new document. When DrawCircle executes, the CurrentX and CurrentY properties are set to the center point of the circle or ellipse.

See Also


DrawCurve Method

PrintPro Object

X1
Single-precision floating-point value indicating the x coordinate for the start of the Bezier curve.
Y1
Single-precision floating-point value indicating the y coordinate for the start of the Bezier curve.
X2
Single-precision floating-point value indicating the x coordinate for the midpoint of the Bezier curve.
Y2
Single-precision floating-point values indicating the y coordinate for the midpoint of the Bezier curve.
X3
Single-precision floating-point values indicating the x coordinate of the curve point that determines the curvature of the Bezier curve.
Y3
Single-precision floating-point values indicating the y coordinate for the curve point that determines the curvature of the Bezier curve.
X4
Single-precision floating-point value indicating the x coordinate for the end point of the Bezier curve.
Y4
Single-precision floating-point value indicating the y coordinate for the end point of the Bezier curve.
penColor
A long value representing the pen color.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

DrawCurve Method

Description

Creates a Bezier curve on a document to be printed.

Syntax

Public Sub DrawCurve( _
   ByVal X1 As Single, _
   ByVal Y1 As Single, _
   ByVal X2 As Single, _
   ByVal Y2 As Single, _
   ByVal X3 As Single, _
   ByVal Y3 As Single, _
   ByVal X4 As Single, _
   ByVal Y4 As Single, _
   ByVal penColor As ULong _
)

Parameters

X1
Single-precision floating-point value indicating the x coordinate for the start of the Bezier curve.
Y1
Single-precision floating-point value indicating the y coordinate for the start of the Bezier curve.
X2
Single-precision floating-point value indicating the x coordinate for the midpoint of the Bezier curve.
Y2
Single-precision floating-point values indicating the y coordinate for the midpoint of the Bezier curve.
X3
Single-precision floating-point values indicating the x coordinate of the curve point that determines the curvature of the Bezier curve.
Y3
Single-precision floating-point values indicating the y coordinate for the curve point that determines the curvature of the Bezier curve.
X4
Single-precision floating-point value indicating the x coordinate for the end point of the Bezier curve.
Y4
Single-precision floating-point value indicating the y coordinate for the end point of the Bezier curve.
penColor
A long value representing the pen color.

Remarks

The coordinates of the curve, with the exception of x3 and y3, must be within the physical area of the printed page.

The width of the line used to draw the curve depends on the setting of the DrawWidth property.

The way the curve is drawn on the background depends on the setting of the DrawMode and DrawStyle properties.

If a printer has not been selected or a document has not been started, the DrawCurve method will select the default printer and start a new document.

You can omit an argument in the middle of the syntax, but you must include the argument’s comma before including the next argument. If you omit an optional argument, omit the comma following the last argument you specify.

When DrawCurve executes, the CurrentX and CurrentY properties are set to the end point specified by the x4 and y4 arguments.

See Also


DrawLine Method

PrintPro Object

X1
Single-precision floating-point value indicating the x coordinate of the starting point for the line or rectangle.
Y1
Single-precision floating-point value indicating the y coordinate of the starting point for the line or rectangle.
X2
Single-precision values indicating the x coordinate of the end point for the line being drawn, or opposite corner of a rectangle being drawn.
Y2
Single-precision values indicating the y coordinate of the end point for the line being drawn, or opposite corner of a rectangle being drawn.
penColor

Optional. If omitted, Black is used.

Long integer value indicating the RGB color used to draw the line.

You can use the RGB function or QBColor function to specify the color.

Box
A Boolean value that if True, causes a box to be drawn using the coordinates to specify opposite corners of the box. If False, a line is drawn.
Fill

A Boolean value that if True and the box option is used, specifies that the box is filled with the same color used to draw the box.

You cannot use Fill without Box. If Box is used without Fill, the Box is filled with the current FillColor and FillStyle. The default value for FillStyle is transparent.

See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

DrawLine Method

Description

Creates lines and rectangles on a document to be printed.

Syntax

Public Sub DrawLine( _
   ByVal X1 As Single, _
   ByVal Y1 As Single, _
   ByVal X2 As Single, _
   ByVal Y2 As Single, _
   ByVal penColor As ULong, _
   ByVal Box As Boolean, _
   ByVal Fill As Boolean _
)

Parameters

X1
Single-precision floating-point value indicating the x coordinate of the starting point for the line or rectangle.
Y1
Single-precision floating-point value indicating the y coordinate of the starting point for the line or rectangle.
X2
Single-precision values indicating the x coordinate of the end point for the line being drawn, or opposite corner of a rectangle being drawn.
Y2
Single-precision values indicating the y coordinate of the end point for the line being drawn, or opposite corner of a rectangle being drawn.
penColor

Optional. If omitted, Black is used.

Long integer value indicating the RGB color used to draw the line.

You can use the RGB function or QBColor function to specify the color.

Box
A Boolean value that if True, causes a box to be drawn using the coordinates to specify opposite corners of the box. If False, a line is drawn.
Fill

A Boolean value that if True and the box option is used, specifies that the box is filled with the same color used to draw the box.

You cannot use Fill without Box. If Box is used without Fill, the Box is filled with the current FillColor and FillStyle. The default value for FillStyle is transparent.

Remarks

The coordinates of the line must be within the physical area of the printed page.

To draw connected lines, begin a subsequent line at the end point of the previous line.

The width of the line drawn depends on the setting of the DrawWidth property.

The way a line or box is drawn on the background depends on the setting of the DrawMode and DrawStyle properties.

If a printer has not been selected or a document has not been started, the DrawLine method selects the default printer and starts a new document. You can omit an argument in the middle of the syntax, but you must include the argument’s comma before including the next argument.

When DrawLine executes, the CurrentX and CurrentY properties are set to x2 and y2.

See Also


DrawPie Method

PrintPro Object

X1
Single-precision values indicating the upper-left x coordinate for the bounding rectangle.
Y1
Single-precision values indicating the upper-left y coordinate for the bounding rectangle.
X2
Single-precision value indicating the lower-right x coordinate for the bounding rectangle.
Y2
Single-precision value indicating the lower-right y coordinate for the bounding rectangle.
StartAngle
Single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
EndAngle
Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
penColor
Long integer value indicating the RGB color of the circle’s outline. You can use the RGB function or QBColor function to specify the color.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

DrawPie Method

Description

Creates a pie-shaped wedge on a document to be printed.

Syntax

Public Sub DrawPie( _
   ByVal X1 As Single, _
   ByVal Y1 As Single, _
   ByVal X2 As Single, _
   ByVal Y2 As Single, _
   ByVal StartAngle As Single, _
   ByVal EndAngle As Single, _
   ByVal penColor As ULong _
)

Parameters

X1
Single-precision values indicating the upper-left x coordinate for the bounding rectangle.
Y1
Single-precision values indicating the upper-left y coordinate for the bounding rectangle.
X2
Single-precision value indicating the lower-right x coordinate for the bounding rectangle.
Y2
Single-precision value indicating the lower-right y coordinate for the bounding rectangle.
StartAngle
Single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
EndAngle
Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
penColor
Long integer value indicating the RGB color of the circle’s outline. You can use the RGB function or QBColor function to specify the color.

Remarks

Draws a pie-shaped wedge by drawing an elliptical arc whose center and two endpoints are joined by lines. The center of the arc is the center of the bounding rectangle specified by x1, y1, x2 and y2. The starting and end points of the arc are determined by the StartAngle and EndAngle values.

The coordinates of the pie must be within the physical area of the printed page. The arc is drawn in a counterclockwise direction.

To fill a pie, set the FillColor and FillStyle properties of the object on which the pie is drawn.

The width of the line used to draw the pie depends on the setting of the DrawWidth property.

The way the pie is drawn on the background depends on the setting of the DrawMode and DrawStyle properties.

If a printer has not been selected or a document has not been started, the DrawPie method will select the default printer and start a new document.

You can omit an argument in the middle of the syntax, but you must include the argument’s comma before including the next argument. If you omit an optional argument, omit the comma following the last argument you specify.

When DrawPie executes, the CurrentX and CurrentY properties are set to X2 and Y2.

See Also


DrawPolygon Method

PrintPro Object

X1
Single-precision value indicating the x coordinate for the first vertex of a polygon.
Y1
Single-precision value indicating the y coordinate for the first vertex of a polygon.
X2
Single-precision value indicating the x coordinate for the second vertex of a polygon.
Y2
Single-precision value indicating the y coordinate for the second vertex of a polygon.
X3
Single-precision value indicating the x coordinate for the third vertex of a polygon.
Y3
Single-precision value indicating the y coordinate for the third vertex of a polygon.
X4
Single-precision value indicating the x coordinate for the fourth vertex of a polygon.
Y4
Single-precision value indicating the y coordinate for the fourth vertex of a polygon.
X5
Single-precision value indicating the X coordinate for the fifth vertex of a polygon.
Y5
Single-precision value indicating the y coordinate for the fifth vertex of a polygon.
X6
Single-precision value indicating the x coordinate for the sixth vertex of a polygon.
Y6
Single-precision value indicating the y coordinate for the sixth vertex of a polygon.
penColor
Long integer value indicating the RGB color of the polygon’s outline. You can use the RGB function or QBColor function to specify the color.
numPoints
The number of valid coordinates defining the polygon.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

DrawPolygon Method

Description

Creates a three to six sided polygon on a document to be printed.

Syntax

Public Sub DrawPolygon( _
   ByVal X1 As Single, _
   ByVal Y1 As Single, _
   ByVal X2 As Single, _
   ByVal Y2 As Single, _
   ByVal X3 As Single, _
   ByVal Y3 As Single, _
   ByVal X4 As Single, _
   ByVal Y4 As Single, _
   ByVal X5 As Single, _
   ByVal Y5 As Single, _
   ByVal X6 As Single, _
   ByVal Y6 As Single, _
   ByVal penColor As ULong, _
   ByVal numPoints As Long _
)

Parameters

X1
Single-precision value indicating the x coordinate for the first vertex of a polygon.
Y1
Single-precision value indicating the y coordinate for the first vertex of a polygon.
X2
Single-precision value indicating the x coordinate for the second vertex of a polygon.
Y2
Single-precision value indicating the y coordinate for the second vertex of a polygon.
X3
Single-precision value indicating the x coordinate for the third vertex of a polygon.
Y3
Single-precision value indicating the y coordinate for the third vertex of a polygon.
X4
Single-precision value indicating the x coordinate for the fourth vertex of a polygon.
Y4
Single-precision value indicating the y coordinate for the fourth vertex of a polygon.
X5
Single-precision value indicating the X coordinate for the fifth vertex of a polygon.
Y5
Single-precision value indicating the y coordinate for the fifth vertex of a polygon.
X6
Single-precision value indicating the x coordinate for the sixth vertex of a polygon.
Y6
Single-precision value indicating the y coordinate for the sixth vertex of a polygon.
penColor
Long integer value indicating the RGB color of the polygon’s outline. You can use the RGB function or QBColor function to specify the color.
numPoints
The number of valid coordinates defining the polygon.

Remarks

Specify as many coordinates as needed to define the polygon (3 for a triangle, 4 for a square, etc.) and pass this number as numPoints. All six coordinates must be passed to this method but the pairs beyond numPoints are ignored.

The coordinates of the polygon must be within the physical area of the printed page.

To fill a polygon, set the FillColor and FillStyle properties of the object on which the polygon is drawn.

The width of the line used to draw the polygon depends on the setting of the DrawWidth property.

The way the polygon is drawn on the background depends on the setting of DrawMode and DrawStyle properties.

If a printer has not been selected or a document has not been started, the DrawPolygon method will select the default printer and start a new document.

You can omit an argument in the middle of the syntax, but you must include the argument’s comma before including the next argument. If you omit an optional argument, omit the comma following the last argument you specify.

When DrawPolygon executes, the CurrentX and CurrentY properties are set to the last valid vertices of the polygon.

See Also


DrawRoundRect Method

PrintPro Object

X1
Single-precision value indicating the upper-left x coordinate for the bounding rectangle.
Y1
Single-precision value indicating the upper-left y coordinate for the bounding rectangle.
X2
Single-precision value indicating the lower-right x coordinate for the bounding rectangle.
Y2
Single-precision value indicating the lower-right y coordinate for the bounding rectangle.
RoundW
A single-precision value that specifies the width of the ellipse used to draw the rounded corners.
RoundH
A single-precision value that specifies the height of the ellipse used to draw the rounded corners.
penColor
Long integer value indicating the RGB color of the circle’s outline. You can use the Visual Basic RGB function or QBColor function to specify the color.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

DrawRoundRect Method

Description

Creates a rectangle with rounded corners on the document to be printed.

Syntax

Public Sub DrawRoundRect( _
   ByVal X1 As Single, _
   ByVal Y1 As Single, _
   ByVal X2 As Single, _
   ByVal Y2 As Single, _
   ByVal RoundW As Single, _
   ByVal RoundH As Single, _
   ByVal penColor As ULong _
)

Parameters

X1
Single-precision value indicating the upper-left x coordinate for the bounding rectangle.
Y1
Single-precision value indicating the upper-left y coordinate for the bounding rectangle.
X2
Single-precision value indicating the lower-right x coordinate for the bounding rectangle.
Y2
Single-precision value indicating the lower-right y coordinate for the bounding rectangle.
RoundW
A single-precision value that specifies the width of the ellipse used to draw the rounded corners.
RoundH
A single-precision value that specifies the height of the ellipse used to draw the rounded corners.
penColor
Long integer value indicating the RGB color of the circle’s outline. You can use the Visual Basic RGB function or QBColor function to specify the color.

Remarks

The coordinates of the round rectangle must be within the physical area of the printed page.

To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn.

The width of the line used to draw the rectangle depends on the setting of the DrawWidth property.

The way the rectangle is drawn on the background depends on the setting of the DrawMode and DrawStyle properties.

If a printer has not been selected or a document has not been started, the DrawRoundRect method will select the default printer and start a new document.

You can omit an argument in the middle of the syntax, but you must include the argument’s comma before including the next argument. If you omit an optional argument, omit the comma following the last argument you specify.

When DrawRoundRect executes, the CurrentX and CurrentY properties are set to X2 and Y2.

See Also


PrintPro Object

EndPrintDoc Method

Description

Releases the current document to the print device or spooler.

Syntax

Public Sub EndPrintDoc()

Remarks

When EndPrintDoc executes, it sets the Page property to 0, the CurrentX property to the LMargin property value, and the CurrentY property to the TMargin property value.

See Also


PrintPro Object

EndPrintPreview Method

Description

Creates print preview resources for the current print preview page.

Syntax

Public Sub EndPrintPreview()

Remarks

Any previous resources for the current page are destroyed.

To create a print preview:

  1. Call StartPrintPreview method. If you plan on creating print preview images while printing a document, you need to start a print document using the StartPrintDoc method before calling StartPrintPreview. If you only want to create a print preview and you don't want to actually print a document, set the PrintPreviewOnly property to True before you call the StartPrintPreview method.
  2. After initiating a print preview, print to the printer in the same manner as you would if you were printing a document. When you are done printing to a page, use the EndPrintPreview method to end the print preview for that page. If you are creating a multiple page document, PrintPro automatically creates a print preview for each page.

See Also


PrintPro Object

GetMaxDPI Method

Description

Fetches the maximum DPI resolution available.

Syntax

Public Function GetMaxDPI() As Long

Remarks

The maximum Dots Per Inch (DPI) possible given the page and system memory constraints.

See Also


PrintPro Object

pageNum
The document page number for which the print preview bitmap will be created. Page numbers start with 1 and cannot exceed the current Page property setting.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

GetPrintPreview Method

Description

Creates a bitmap image for a print preview page and sets the PrintPreviewPicture property.

Syntax

Public Sub GetPrintPreview( _
   ByVal pageNum As Long _
)

Parameters

pageNum
The document page number for which the print preview bitmap will be created. Page numbers start with 1 and cannot exceed the current Page property setting.

Remarks

The size of the bitmap image is determined by the PrintPreviewScale property. After you create a print preview bitmap image, you can export it using the PrintPreviewPic property. You can delete the current bitmap image using the DelPrintPreviewPic method and you can delete the print preview resources for any page using the DelPrintPreview method.

See Also


PrintPro Object

KillPrintDoc Method

Description

Call this method to allow the PrintPRO control to run on a specified web site.

Syntax

Public Sub KillPrintDoc()

Remarks

After a document has been released to the print device or spooler, KillPrintDoc method may be called to terminate the print request.

If the operating system's Print Manager is handling the print job (the Print Manager is running and has background printing enabled), KillPrintDoc deletes the current print job and the printer receives nothing. If Print Manager isn't handling the print job (background printing isn't enabled), some or all of the data may be sent to the printer before KillPrintDoc can take effect. In this case, the printer driver resets the printer when possible and terminates the print job.

See Also


PrintPro Object

NewPage Method

Description

Ends the current page and advances to the next page.

Syntax

Public Sub NewPage()

Remarks

When NewPage executes, the Page property is incremented by 1, the CurrentX property is set to the LMargin property value, and the CurrentY property is set to 0.

See Also


PrintPro Object

PaperNum
The value of number can be from 1 to the NumPapers.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

PaperID Method

Description

Returns the printer manufacturer's paper ID number for any supported paper.

Syntax

Public Function PaperID( _
   ByVal PaperNum As Long _
) As Long

Parameters

PaperNum
The value of number can be from 1 to the NumPapers.

Return Type

The value returned can be used to select the paper using the PaperSize property.

See Also


PrintPro Object

PaperNum
The value can be from 1 to the NumPapers property value.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

PaperName Method

Description

Returns the printer manufacturer's paper name for any supported paper.

Syntax

Public Function PaperName( _
   ByVal PaperNum As Long _
) As String

Parameters

PaperNum
The value can be from 1 to the NumPapers property value.

Return Type

A string value which represents the printer manufacturer's paper name.

See Also


PrintPro Object

varData
A variant array of bytes.
Length
The number of bytes in the array. Length must be between 1 and 255.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

PrintData Method

Description

Places data stored in an array of bytes into the document to be printed.

Syntax

Public Sub PrintData( _
   ByVal varData As Variant, _
   ByVal Length As Long _
)

Parameters

varData
A variant array of bytes.
Length
The number of bytes in the array. Length must be between 1 and 255.

Remarks

If a printer has not been selected or a document has not been started, the PrintData method will select the default printer and start a new document. The PrintData method lets you place binary data in the document to be printed. The data is placed at the CurrentX and CurrentY positions.

See Also


PrintPro Object

PrintDialog Method

Description

Displays a printer dialog box.

Syntax

Public Sub PrintDialog()

Remarks

The selected printer replaces the current printer only if a document has not been started on the current printer.

The printer dialog box can only be displayed when a printer has been selected, and no print job is in progress. When a print job is in progress, the printer dialog box will not be displayed, and an exception message appears. If the user clicks the Cancel button, the ErrorCode property is set to -5005.

See Also


PrintDIB Method

PrintPro Object

X1
Single-precision value indicating the destination horizontal coordinate of the upper-left corner of the image. The ScaleMode property determines the unit of measure used.
Y1
Single-precision value indicating the destination vertical coordinate of the upper-left corner of the image. The ScaleMode property determines the unit of measure used.
Width1

Single-precision value indicating the destination width of the image.

The ScaleMode property of the object determines the unit of measure used.

If omitted, the width of the image will be used.

If Aspect is False and the destination width is larger or smaller than the source width (width2), the image is stretched or compressed to fit.

Height1

Single-precision value indicating the destination height of the image. The ScaleMode property determines the unit of measure used.

If omitted, the height of the image will be used.

If Aspect is False and the destination height is larger or smaller than the source height (height2), the image is stretched or compressed to fit.

X2

Single-precision value indicating the coordinate (x-axis) of a clipping region within the image. The ScaleMode property determines the unit of measure used.

If Aspect is True, 0 is assumed.

Y2

Single-precision value indicating the coordinate (y-axis) of a clipping region within the image. The ScaleMode property determines the unit of measure used.

If Aspect is True, 0 is assumed.

Width2

Single-precision value indicating the source width of a clipping region within the image. The ScaleMode property determines the unit of measure used.

If Aspect is True, the entire source width is used.

Height2

Single-precision value indicating the source height of a clipping region within the image. The ScaleMode property determines the unit of measure used.

If Aspect is True, the entire source height is used.

Aspect

Boolean value indicating whether the aspect ratio of the image should be maintained.

If Aspect is True, and the destination rectangle is larger or smaller than the source rectangle, the aspect ratio of the resized image is maintained.

If Aspect is True, the x2, y2, width2 and height2 parameters are ignored.

See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

PrintDIB Method

Description

Draws a device independent bitmap (DIB) on a document to be printed.

Syntax

Public Sub PrintDIB( _
   ByVal X1 As Single, _
   ByVal Y1 As Single, _
   ByVal Width1 As Single, _
   ByVal Height1 As Single, _
   ByVal X2 As Single, _
   ByVal Y2 As Single, _
   ByVal Width2 As Single, _
   ByVal Height2 As Single, _
   ByVal Aspect As Boolean _
)

Parameters

X1
Single-precision value indicating the destination horizontal coordinate of the upper-left corner of the image. The ScaleMode property determines the unit of measure used.
Y1
Single-precision value indicating the destination vertical coordinate of the upper-left corner of the image. The ScaleMode property determines the unit of measure used.
Width1

Single-precision value indicating the destination width of the image.

The ScaleMode property of the object determines the unit of measure used.

If omitted, the width of the image will be used.

If Aspect is False and the destination width is larger or smaller than the source width (width2), the image is stretched or compressed to fit.

Height1

Single-precision value indicating the destination height of the image. The ScaleMode property determines the unit of measure used.

If omitted, the height of the image will be used.

If Aspect is False and the destination height is larger or smaller than the source height (height2), the image is stretched or compressed to fit.

X2

Single-precision value indicating the coordinate (x-axis) of a clipping region within the image. The ScaleMode property determines the unit of measure used.

If Aspect is True, 0 is assumed.

Y2

Single-precision value indicating the coordinate (y-axis) of a clipping region within the image. The ScaleMode property determines the unit of measure used.

If Aspect is True, 0 is assumed.

Width2

Single-precision value indicating the source width of a clipping region within the image. The ScaleMode property determines the unit of measure used.

If Aspect is True, the entire source width is used.

Height2

Single-precision value indicating the source height of a clipping region within the image. The ScaleMode property determines the unit of measure used.

If Aspect is True, the entire source height is used.

Aspect

Boolean value indicating whether the aspect ratio of the image should be maintained.

If Aspect is True, and the destination rectangle is larger or smaller than the source rectangle, the aspect ratio of the resized image is maintained.

If Aspect is True, the x2, y2, width2 and height2 parameters are ignored.

Remarks

The DIB is defined by the hDIB property. The destination coordinates of the image must be within the physical area of the printer. If a printer has not been selected or a document has not been started, the PrintPicture method will select the default printer and start a new document. Use the EndPrintDoc method to print the document.

If the OwnDIB property is true, the PrintDIB method deletes the DIB after drawing the device independent bitmap (DIB) on a document to be printed.

See Also


PrintPicture Method

PrintPro Object

X1
Single-precision value indicating the destination x coordinate of the upper-left corner of the image on the printer.
Y1
Single-precision value indicating the destination y coordinate of the upper-left corner of the image on the printer.
Width1

Single-precision value indicating the destination width of the image.

If omitted, the width of the image will be used. If Aspect is False and the destination width is larger or smaller than the source width (width2), the image is stretched or compressed to fit.

Height1

Single-precision value indicating the destination height of the image.

If omitted, the height of the image will be used. If Aspect is False and the destination height is larger or smaller than the source height (height2), the image is stretched or compressed to fit.

X2

Single-precision value indicating the coordinate (x-axis) of a clipping region within the image. If Aspect is True, 0 is assumed.

Y2
Single-precision value indicating the coordinate (y-axis) of a clipping region within the image. If Aspect is True, 0 is assumed.
Width2
Single-precision value indicating the width of a clipping region within the image. If Aspect is True, the entire source width is used.
Height2
Single-precision value indicating the height of a clipping region within the image. If Aspect is True, the entire source height is used.
Aspect

Boolean value indicating whether the aspect ratio of the image should be maintained.

  • If Aspect is True and the destination rectangle is larger or smaller than the source rectangle, the aspect ratio of the resized image is maintained.
  • If Aspect is True, the x2, y2, width2 and height2 parameters are ignored.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

PrintPicture Method

Description

Draws a bitmap image on a document to be printed.

Syntax

Public Sub PrintPicture( _
   ByVal X1 As Single, _
   ByVal Y1 As Single, _
   ByVal Width1 As Single, _
   ByVal Height1 As Single, _
   ByVal X2 As Single, _
   ByVal Y2 As Single, _
   ByVal Width2 As Single, _
   ByVal Height2 As Single, _
   ByVal Aspect As Boolean _
)

Parameters

X1
Single-precision value indicating the destination x coordinate of the upper-left corner of the image on the printer.
Y1
Single-precision value indicating the destination y coordinate of the upper-left corner of the image on the printer.
Width1

Single-precision value indicating the destination width of the image.

If omitted, the width of the image will be used. If Aspect is False and the destination width is larger or smaller than the source width (width2), the image is stretched or compressed to fit.

Height1

Single-precision value indicating the destination height of the image.

If omitted, the height of the image will be used. If Aspect is False and the destination height is larger or smaller than the source height (height2), the image is stretched or compressed to fit.

X2

Single-precision value indicating the coordinate (x-axis) of a clipping region within the image. If Aspect is True, 0 is assumed.

Y2
Single-precision value indicating the coordinate (y-axis) of a clipping region within the image. If Aspect is True, 0 is assumed.
Width2
Single-precision value indicating the width of a clipping region within the image. If Aspect is True, the entire source width is used.
Height2
Single-precision value indicating the height of a clipping region within the image. If Aspect is True, the entire source height is used.
Aspect

Boolean value indicating whether the aspect ratio of the image should be maintained.

  • If Aspect is True and the destination rectangle is larger or smaller than the source rectangle, the aspect ratio of the resized image is maintained.
  • If Aspect is True, the x2, y2, width2 and height2 parameters are ignored.

Remarks

The bitmap is defined by the Picture property. The ScaleMode property determines the unit of measure used.

The destination coordinates of the image must be within the physical area of the printer. If a printer has not been selected or a document has not been started, the PrintPicture method will select the default printer and start a new document. Use the EndPrintDoc method to print the document.

If OwnDIB was set when SetPictureBMP was invoked, then the bitmap is owned by the PrintPro control, and the PrintDIB method deletes the DIB after drawing the bitmap on the document to be printed.

See Also


PrintRawData Method

PrintPro Object

varData
A one dimension variant array containing raw printer data.
Length
The size of the array in bytes.
NewPage
When set True the raw output is directed to the next logical page depending on the printer characteristics.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

PrintRawData Method

Description

Outputs data directly to a printer.

Syntax

Public Sub PrintRawData( _
   ByVal varData As Variant, _
   ByVal Length As Long, _
   ByVal NewPage As Boolean _
)

Parameters

varData
A one dimension variant array containing raw printer data.
Length
The size of the array in bytes.
NewPage
When set True the raw output is directed to the next logical page depending on the printer characteristics.

Remarks

The PrintRawData method lets you print data directly to the current printer. Since the printer driver is by-passed by this method the data must be printer specific. The raw data may contain printer commands, codes and binary data. Large amounts of data may be sent to the printer using this technique.

See Also


PrintPro Object

PrintRawDataEnd Method

Description

Closes the direct-to-printer session.

Syntax

Public Sub PrintRawDataEnd()

See Also


PrintPro Object

PrintRawDataStart Method

Description

Opens a direct-to-printer print session.

Syntax

Public Sub PrintRawDataStart()

Remarks

This procedure bypasses the print driver.

See Also


PrintPro Object

LineItem
Which line in the Template File to process. Zero indicates the "next line", or when at the end of the file, the first image parameter line.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

PrintTemplateDIB Method

Description

Incorporates the image currently represented by the control's hDIB member according to a line from the TemplateFile.

Syntax

Public Sub PrintTemplateDIB( _
   ByVal LineItem As Long _
)

Parameters

LineItem
Which line in the Template File to process. Zero indicates the "next line", or when at the end of the file, the first image parameter line.

Remarks

See TemplateFile for examples of how to create collages using the TemplateFile Property and PrintTemplateDIB method.

See Also


PrintPro Object

LineItem
Which line in the Template File to process. Zero indicates the "next line", or when at the end of the file, the first image parameter line.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

PrintTemplatePicture Method

Description

Incorporates the image currently represented by the control's Picture member according to a line from the TemplateFile.

Syntax

Public Sub PrintTemplatePicture( _
   ByVal LineItem As Long _
)

Parameters

LineItem
Which line in the Template File to process. Zero indicates the "next line", or when at the end of the file, the first image parameter line.

Remarks

See TemplateFile for examples of how to create collages using the TemplateFile Property and PrintTemplateDIB method.

See Also


PrintPro Object

prntStr
A string expression to print.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

PrintText Method

Description

Places text in the document to be printed.

Syntax

Public Sub PrintText( _
   ByVal prntStr As String _
)

Parameters

prntStr
A string expression to print.

Remarks

The text is placed at the CurrentX and CurrentY position.

After PrintText executes, CurrentX and CurrentY are updated as follows:

  • If the AddCR property is True, CurrentY is set to the next line position, and CurrentX is set to the LMargin property value.
  • If the AddCR property is False, CurrentX is set to the next text position and CurrentY remains unchanged. The PrintText method prints embedded carriage returns.
  • If the text does not fit on a line, it does not word-wrap to the next line. If you want to word-wrap text, use the PrintTextAligned method.
  • If the text you want to print doesn't fit on the current page, a new page is automatically generated.
  • If a printer has not been selected or a document has not been started, the PrintText method will select the default printer and start a new document.

Note: If the output of a Graphics method (e.g. line, circle, etc.) doesn't fit on the page, a new page is not generated. The output is clipped to fit the page's printable area.

See Also


PrintTextAligned Method

PrintPro Object

prntStr
A string expression to print.
X1
Single-precision values indicating the coordinates of the starting point for the bounding rectangle.
Y1
Single-precision values indicating the coordinates of the starting point for the bounding rectangle.
X2
Single-precision values indicating the coordinates of the end point for the bounding rectangle.
Y2
Single-precision values indicating the coordinates of the end point for the bounding rectangle.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

PrintTextAligned Method

Description

Places text on the document inside a specified rectangular area within the display area.

Syntax

Public Sub PrintTextAligned( _
   ByVal prntStr As String, _
   ByVal X1 As Single, _
   ByVal Y1 As Single, _
   ByVal X2 As Single, _
   ByVal Y2 As Single _
)

Parameters

prntStr
A string expression to print.
X1
Single-precision values indicating the coordinates of the starting point for the bounding rectangle.
Y1
Single-precision values indicating the coordinates of the starting point for the bounding rectangle.
X2
Single-precision values indicating the coordinates of the end point for the bounding rectangle.
Y2
Single-precision values indicating the coordinates of the end point for the bounding rectangle.

Remarks

The text is placed using the current alignment style defined by the Alignment property. The text will automatically word-wrap if the WordWrap property is True. The PrintTextAligned method prints embedded carriage returns.

The CurrentX and CurrentY properties are not changed by the PrintTextAligned method. If a printer has not been selected or a document has not been started, the PrintTextAligned method will select the default printer and start a new document.

Note: When printing an ampersand (&), you must print two (&&) of them for one to print.

See Also


PrintTextRotated Method

PrintPro Object

X
Single-precision value indicating the x coordinate of the rotating text pivot point.
Y
Single-precision value indicating the y coordinate of the rotating text pivot point.
prntStr
A string expression to print.
Angle
An integer value indicating the rotation angle. Valid values range from 0 to 360 degrees.
Mode

An integer value indicating the rotation pivot mode:

0 — The text is left-justified at the pivot point

1 — The text is right-justified at the pivot point

2 — The text is center-justified at the pivot point

See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

PrintTextRotated Method

Description

Places text rotated on the document to be printed.

Syntax

Public Sub PrintTextRotated( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal prntStr As String, _
   ByVal Angle As Long, _
   ByVal Mode As Long _
)

Parameters

X
Single-precision value indicating the x coordinate of the rotating text pivot point.
Y
Single-precision value indicating the y coordinate of the rotating text pivot point.
prntStr
A string expression to print.
Angle
An integer value indicating the rotation angle. Valid values range from 0 to 360 degrees.
Mode

An integer value indicating the rotation pivot mode:

0 — The text is left-justified at the pivot point

1 — The text is right-justified at the pivot point

2 — The text is center-justified at the pivot point

Remarks

The baseline of the text is positioned at the pivot point. If a printer has not been selected or a document has not been started, the PrintTextRotated method will select the default printer and start a new document.

See Also


PrintPro Object

SelectDefaultPrinter Method

Description

Selects the system default printer.

Syntax

Public Sub SelectDefaultPrinter()

Remarks

The default printer replaces the current printer only if a document has not been started on the current printer.

See Also


PrintPro Object

PrinterNum
A long value which represents the printer number. Valid values are 1 to NumPrinters.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

SelectPrinter Method

Description

Selects one of the printers installed on the system.

Syntax

Public Sub SelectPrinter( _
   ByVal PrinterNum As Long _
)

Parameters

PrinterNum
A long value which represents the printer number. Valid values are 1 to NumPrinters.

Remarks

The PrintPRO control, by default, selects the system default printer. Use the SelectPrinter method to select any printer installed on the system.

See Also


PrintPro Object

PrinterName
A string value which represents the printer name.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

SelectPrinterByName Method

Description

Selects one of the printers installed on the system by the given printer name.

Syntax

Public Sub SelectPrinterByName( _
   ByVal PrinterName As String _
)

Parameters

PrinterName
A string value which represents the printer name.

See Also


PrintPro Object

Name
A string value indicating the name of the font, for example "Arial" or "Times New Roman" as described in Remarks.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

SetCtlFontName Method

Description

Sets the font name.

Syntax

Public Sub SetCtlFontName( _
   ByVal Name As String _
)

Parameters

Name
A string value indicating the name of the font, for example "Arial" or "Times New Roman" as described in Remarks.

Remarks

In containers that don’t give you direct access to PrintPRO’s Font object, like Visual C++, the SetCtlName method can be used to set the font name.

See Also


PrintPro Object

fSize
A long value indicating the size of the font, in points.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

SetCtlFontSize Method

Description

Sets the font size.

Syntax

Public Sub SetCtlFontSize( _
   ByVal fSize As Single _
)

Parameters

fSize
A long value indicating the size of the font, in points.

Remarks

In containers that don’t give you direct access to PrintPRO’s Font object, like Visual C++, the SetCtlSize method can be used to set the font size.

See Also


SetCtlFontStyle Method

PrintPro Object

Style

An integer value indicating the desired font style:

0 — Bold font

1 — Italic font

2 — Underline font

3 — Strikethrough font

Value
A boolean value indicating whether the style is set (True) or unset (False).
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

SetCtlFontStyle Method

Description

Sets the font style.

Syntax

Public Sub SetCtlFontStyle( _
   ByVal Style As Long, _
   ByVal Value As Boolean _
)

Parameters

Style

An integer value indicating the desired font style:

0 — Bold font

1 — Italic font

2 — Underline font

3 — Strikethrough font

Value
A boolean value indicating whether the style is set (True) or unset (False).

Remarks

In containers that don’t give you direct access to PrintPRO’s Font object, like Visual C++, the SetCtlFontStyle method can be used to set the font style.

See Also


PrintPro Object

SetDefaultPrinterW Method

Description

Selects the system default printer.

Syntax

Public Sub SetDefaultPrinterW()

Remarks

The default printer replaces the current printer only if a document has not been started on the current printer.

See Also


SetPictureBMP Method

PrintPro Object

hBmp
Long value that specifies the handle to a Device Dependent Bitmap.
hPal
Long value that specifies the handle to a palette.
own
Boolean value specifies ownership.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

SetPictureBMP Method

Description

Sets the Picture property using a handle to a Device Dependent Bitmap and a handle to a palette.

Syntax

Public Sub SetPictureBMP( _
   ByVal hBmp As Long, _
   ByVal hPal As Long, _
   ByVal own As Boolean _
)

Parameters

hBmp
Long value that specifies the handle to a Device Dependent Bitmap.
hPal
Long value that specifies the handle to a palette.
own
Boolean value specifies ownership.

Remarks

When own parameter is True, PrintPRO owns the bitmap and it is responsible for deleting it. If own is False, you need to delete the bitmap when it is no longer needed.

See Also


PrintPro Object | ErrorCode Property

SetupDialog Method

Description

Displays a printer setup dialog box that lets the user change printer properties.

Syntax

Public Sub SetupDialog()

Remarks

If the user clicks the Cancel button, the ErrorCode property is set to -5018.

See Also

PrintPro Object | ErrorCode Property


PrintPro Object

StartPrintDoc Method

Description

Creates a document to be composed and printed.

Syntax

Public Sub StartPrintDoc()

Remarks

Prior to printing, create a document and place the desired text, graphics, and bitmaps on the document.

The text, graphics, and bitmap methods automatically start a document for you, if one is not already started.

Once a document is started, the PrintDialog, SelectDefaultPrinter, and SelectPrinter methods no longer update the current printer.

See Also


PrintPro Object | EndPrintPreview Method

StartPrintPreview Method

Description

Starts a print preview for the current page.

Syntax

Public Sub StartPrintPreview()

Remarks

Any previous resources for the current page are destroyed. To create a print preview:

Call StartPrintPreview method. If you plan on creating print preview images while printing a document, you need to start a print document using the StartPrintDoc method before calling StartPrintPreview. If you only want to create a print preview and you don't want to actually print a document, set the PrintPreviewOnly property to True before you call the StartPrintPreview method.

After initiating a print preview, print to the printer in the same manner as if you were printing a document. When you are done printing to a page, use the EndPrintPreview method to end the print preview for that page. If you are creating a multiple page document, PrintPro automatically creates a print preview for each page.

See Also

PrintPro Object | EndPrintPreview Method


PrintPro Object | ScaleMode Property

textStr

The string you want to know the height of.

See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

TextHeight Method

Description

Calculates the height of a text string as it would be printed in the current font.

Syntax

Public Function TextHeight( _
   ByVal textStr As String _
) As Single

Parameters

textStr

The string you want to know the height of.

Remarks

Not available at design time.

Calculates and returns the height expressed in terms of the ScaleMode property setting.

See Also

PrintPro Object | ScaleMode Property


PrintPro Object | ScaleMode Property

textStr
The string you want to know the width of.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

TextWidth Method

Description

Calculates the width of a text string as it would be printed in the current font.

Syntax

Public Function TextWidth( _
   ByVal textStr As String _
) As Single

Parameters

textStr
The string you want to know the width of.

Remarks

Not available at design time.

Calculates and returns the width expressed in terms of the ScaleMode property setting.

See Also

PrintPro Object | ScaleMode Property


UnlockRuntime Method

PrintPro Object | PrintText Method | CurrentX Property | CurrentY Property

val1
The first in the set of four unlock codes that were given at the time of purchase.
val2
The second in the set of four unlock codes that were given at the time of purchase.
val3
The third in the set of four unlock codes that were given at the time of purchase.
val4
The fourth in the set of four unlock codes that were given at the time of purchase.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

UnlockRuntime Method

Description

Called to allow the control to run as a non-trial mode.

Syntax

Public Sub UnlockRuntime( _
   ByVal val1 As Long, _
   ByVal val2 As Long, _
   ByVal val3 As Long, _
   ByVal val4 As Long _
)

Parameters

val1
The first in the set of four unlock codes that were given at the time of purchase.
val2
The second in the set of four unlock codes that were given at the time of purchase.
val3
The third in the set of four unlock codes that were given at the time of purchase.
val4
The fourth in the set of four unlock codes that were given at the time of purchase.

See Also

PrintPro Object | PrintText Method | CurrentX Property | CurrentY Property


PrintPro Object

pVal
The unlock code that was given at the time of purchase.
See Also Pegasus Imaging PrintPro Control v4.0 Send comments on this topic.

UnlockWeb Method

Description

Called to allow the control to run as a non-trial mode when being used on a web page.

Syntax

Public Sub UnlockWeb( _
   ByVal pVal As String _
)

Parameters

pVal
The unlock code that was given at the time of purchase.

See Also


PrintPro Object

AddCR Property

Description

Gets and sets the automatic carriage return flag.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AddCR() As Boolean

Value

A boolean value which is True to set the automatic carriage return flag.

See Also


PrintPro Object | PP_Alignment Enumeration | PrintTextAligned Method

Alignment Property

Description

Gets and sets the text alignment style used by the PrintTextAligned method.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Alignment() As PP_Alignment

Value

A PP_Alignment enumeration value which determines the alignment.

See Also

PrintPro Object | PP_Alignment Enumeration | PrintTextAligned Method


PrintPro Object | Alignment Property

AlignTextHeight Property

Description

Gets the line height based on the Alignment property centering in pixels.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AlignTextHeight() As Single

Value

A single value which represents the text height alignment.

Remarks

When text is aligned using the PrintTextAligned method, the text may wrap to more than one line. The AlignTextHeight property returns the height (in pixels) of this text spanning one or more lines.

See Also

PrintPro Object | Alignment Property


PrintPro Object

AutoMargin Property

Description

Gets or sets a value to determine if the margin values and the current print position values should automatically be set to values inside the printer's display area.

Property type

Read-write property

Syntax (Visual Basic)

Public Property AutoMargin() As Boolean

Value

A boolean value which is True to automatically set to values inside the printer's display area. Otherwise, False is used and margin values are not automatically set.

Remarks

Returns or sets a Boolean value that specifies whether the BMargin, LMargin, TMargin, CurrentX and CurrentY properties should automatically be set to values inside the display area.

If the AutoMargin property is set to True (Default), the BMargin, LMargin, TMargin, CurrentX and CurrentY properties are set whenever a paper size is selected as follows: The LMargin and CurrentX properties are set to the left edge of the display area. The TMargin, BMargin and CurrentY properties are set to the top edge of the display area.

Note: The coordinate system used by the PrintPRO control is based on the physical dimensions of the paper. This means that the 0,0 coordinate is the upper left corner of the printed page. The display area that is located inside the physical area. This is the area that is normally used for printing. The AutoMargin property automatically sets the margins and the CurrentX and CurrentY properties so that printed text, using the PrintText method, appears inside the display area. If you want to set the margins manually, you can use the DisplayX and DisplayY properties to get the margin values.

See Also


PrintPro Object

BackColor Property

Description

The background color of printed text.

Property type

Read-write property

Syntax (Visual Basic)

Public Property BackColor() As ULong

Value

A Ulong value which represents the background color.

Remarks

The BackColor property determines the background color of printed text when the BackStyle property is set to Back_Opaque.

See Also


PrintPro Object

BackStyle Property

Description

Sets the background style of printed text.

Property type

Read-write property

Syntax (Visual Basic)

Public Property BackStyle() As PP_BackStyle

Value

A PP_BackStyle enumeration value which determines the background style of printed text.

See Also


PrintPro Object

BMargin Property

Description

Gets or sets the bottom margin value.

Property type

Read-write property

Syntax (Visual Basic)

Public Property BMargin() As Single

Value

A single value which represents the bottom margin value.

Remarks

Margin values are expressed in twips, or the current unit of measurement defined by the ScaleMode property.

See Also


PrintPro Object | PP_Collate Enumeration | ErrorCode Property

Collate Property

Description

Gets or sets an indicator whether collation should be used when printing multiple copies (if the printer supports this feature).

Property type

Read-write property

Syntax (Visual Basic)

Public Property Collate() As Boolean

Value

A boolean value which is True if collation should be used when printing multiple copies. Otherwise, False is used and collation does not occur.

Remarks

Not available at design time.

Note: You cannot set the Collate property after a document has been started. The effect of setting the Collate property depends on the driver supplied by the printer manufacturer. Some property settings may have no effect. Settings outside the accepted range may produce an error. The ErrorCode property will be set to -5015 or -5016 if the printer does not support this property. For more information, see the manufacturer's documentation for the specific printer driver.

See Also

PrintPro Object | PP_Collate Enumeration | ErrorCode Property


PrintPro Object | ErrorCode Property

ColorMode Property

Description

Gets or sets a value that determines whether a color printer prints output in color or monochrome.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ColorMode() As PP_ColorMode

Remarks

Not available at design time.

The default value depends on the printer driver and the current printer settings. Monochrome printers ignore this property.

Note: You cannot set the ColorMode property after a document has been started. The effect of setting the ColorMode property depends on the driver supplied by the printer manufacturer. Some property settings may have no effect. Settings outside the accepted range may produce an error. The ErrorCode property will be set to -5015 or -5016 if the printer does not support this property. For more information, see the manufacturer's documentation for the specific printer driver.

See Also

PrintPro Object | ErrorCode Property


PrintPro Object | PrintDialog Method | ErrorCode Property

Copies Property

Description

Gets or sets a value that determines the number of copies to be printed.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Copies() As Long

Value

A long value which represents the number of copies to be printed.

Remarks

Not available at design time.

You cannot set the Copies property after a document has been started. For the PrintDialog method, this property returns the number of copies entered by the user in the Copies box. Multiple copies may or may not be collated, depending on the printer driver. Multiple copies of the entire document or multiple copies of each page may be printed. For printers that don't support collating, set Copies = 1, and then use a loop in code to print multiple copies of the entire document.

Note: The effect of setting the Copies property depends on the driver supplied by the printer manufacturer. Some property settings may have no effect. Settings outside the accepted range may produce an error. The ErrorCode property will be set to -5015 or -5016 if the printer does not support this property. For more information, see the manufacturer's documentation for the specific printer driver.

See Also

PrintPro Object | PrintDialog Method | ErrorCode Property


PrintPro Object

CurrentX Property

Description

Returns or sets the horizontal coordinate for the next printing or drawing method.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CurrentX() As Single

Value

A single value which represents the horizontal coordinate for the next printing or drawing method.

Remarks

Not available at design time. Coordinates are measured from the upper-left corner of an object. Initially, the CurrentX property setting is 0 at a printer’s left edge. Coordinates are expressed in twips, or the current unit of measurement defined by the ScaleMode property.

When you use the following text and graphics methods, the CurrentX and CurrentY settings are changed as indicated:

  • DrawArc — The end point of the arc.

  • DrawCircle — The center of the object.

  • DrawCurve — The end point of the curve.

  • DrawLine — The end point of the line.

  • EndPrintDoc — LMargin property, TMargin property.

  • NewPage — LMargin property, TMargin property.

  • PrintText — The next print position if the AddCR property is False or Margin and the next line if the AddCR property is True.

See Also


PrintPro Object

CurrentY Property

Description

Gets or sets the vertical coordinate for the next printing or drawing method.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CurrentY() As Single

Value

A single value which represents the vertical coordinate for the next printing or drawing method.

Remarks

Not available at design time. Coordinates are measured from the upper-left corner of an object. Initially, the CurrentY property setting is 0 at its top edge. Coordinates are expressed in twips, or the current unit of measurement defined by the ScaleMode property.

When you use the following text and graphics methods, the CurrentX and CurrentY settings are changed as indicated:

  • DrawArc — The end point of the arc.

  • DrawCircle — The center of the object.

  • DrawCurve — The end point of the curve.

  • DrawLine — The end point of the line.

  • EndPrintDoc — LMargin property, TMargin property.

  • NewPage — LMargin property, TMargin property.

  • PrintText — The next print position if the AddCR property is False or Margin and the next line if the AddCR property is True.

See Also


PrintPro Object | DebugLogFile Property

Debug Property

Description

A property that represents whether or not debug logging is turned on.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Debug() As Boolean

Value

A boolean value which is True to log information to the DebugLogFile. Otherwise, False should be used and no information is logged.

See Also

PrintPro Object | DebugLogFile Property


PrintPro Object | PP_DebugErrorLevel Enumeration | Debug Property

DebugErrorLevel Property

Description

Minimum error level a debug message must be for it to be logged in the log file.

Property type

Read-write property

Syntax (Visual Basic)

Public Property DebugErrorLevel() As PP_DebugErrorLevel

Value

A PP_DebugErrorLevel enumeration value which determines the level of logging to occur.

Remarks

Note: No error logging is written if the Debug property is set to False.

See Also

PrintPro Object | PP_DebugErrorLevel Enumeration | Debug Property


PrintPro Object

DebugLogFile Property

Description

The file name and location of the debug log file.

Property type

Read-write property

Syntax (Visual Basic)

Public Property DebugLogFile() As String

Value

A string value which represents the location and name of the debug log file.

See Also


PrintPro Object

DIBHeight Property

Description

Gets the height of the bitmap defined by the hDIB property in printer units defined by the ScaleMode property.

Property type

Read-write property

Syntax (Visual Basic)

Public Property DIBHeight() As Single

Value

A single value which represents the height of the bitmap defined by the hDIB.

Remarks

Not available at design time. Printer units are different than screen units. For example, an image that is 320x240 screen pixels on a 600dpi printer would be 2000x1500 printer pixels.

See Also


PrintPro Object

DIBWidth Property

Description

Gets the width of the bitmap defined by the hDIB property in printer units defined by the ScaleMode property. Not available at design time.

Property type

Read-write property

Syntax (Visual Basic)

Public Property DIBWidth() As Single

Value

A single value which represents the width of the bitmap defined by the hDIB.

Remarks

Not available at design time. Printer units are different than screen units. For example, an image that is 320x240 screen pixels on a 600dpi printer would be 2000x1500 printer pixels.

See Also


PrintPro Object | ScaleMode Property

DisplayX Property

Description

Gets the horizontal coordinate of the display area in printer units defined by the ScaleMode property.

Property type

Read-write property

Syntax (Visual Basic)

Public Property DisplayX() As Single

Value

A single value which represents the horizontal coordinate of the display area in printer units.

Remarks

Not available at design time.

The coordinate system used by the PrintPRO control is based on the physical dimensions of the printer. This means that the 0,0 coordinate is the upper left corner of the printed page. The printer also has a display area that is located inside the physical area. This is the area that is normally used for printing. The DisplayX and DisplayY properties can be used to get the coordinates of the upper left corner of the display area.

See Also

PrintPro Object | ScaleMode Property


PrintPro Object | ScaleMode Property | DisplayX Property

DisplayY Property

Description

Gets the vertical coordinate of the display area in printer units defined by the ScaleMode property.

Property type

Read-write property

Syntax (Visual Basic)

Public Property DisplayY() As Single

Value

A single value which represents the vertical coordinate of the display area in printer units.

Remarks

Not available at design time.

The coordinate system used by the PrintPRO control is based on the physical dimensions of the printer. This means that the 0,0 coordinate is the upper left corner of the printed page. The printer also has a display area located inside the physical area. This is the area normally used for printing. The DisplayX and DisplayY properties can be used to get the coordinates of the upper left corner of the display area.

See Also

PrintPro Object | ScaleMode Property | DisplayX Property


PrintPro Object | PP_DitherType Enumeration

DitherType Property

Description

Gets or sets a value that specifies how dithering is to be done (if the printer supports this feature).

Property type

Read-write property

Syntax (Visual Basic)

Public Property DitherType() As PP_DitherType

Value

A PP_DitherType enumeration value which determines how dithering is to be done.

Remarks

Not available at design time.

Note: You cannot set the DitherType property after a document has been started. The effect of setting the DitherType property depends on the driver supplied by the printer manufacturer. Some property settings may have no effect. Settings outside the accepted range may produce an error. The ErrorCode property will be set to -5015 or -5016 if the printer does not support this property. For more information, see the manufacturer's documentation for the specific printer driver.

See Also

PrintPro Object | PP_DitherType Enumeration


PrintPro Object

DocName Property

Description

Gets or sets the document name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property DocName() As String

Value

A string value which represents the document name.

Remarks

The document name appears in the print spooler document list when the document is printed.

See Also


PrintPro Object | PP_DrawMode Enumeration

DrawMode Property

Description

Gets or sets a value that determines the appearance of output from graphics methods.

Property type

Read-write property

Syntax (Visual Basic)

Public Property DrawMode() As PP_DrawMode

Value

A PP_DrawMode enumeration value which determines the appearance of output from graphics methods.

Remarks

Use this property to produce visual effects when drawing with the graphics methods. The printer compares each pixel in the draw pattern to the corresponding pixel in the existing background and then applies bit-wise operations. For example, setting 7 uses the operator to combine a draw pattern pixel with a background pixel.

The exact effect of a DrawMode setting depends on the way the color of a line, drawn at run time, combines with colors already on the printer. Settings 1, 6, 7, 11, 13, and 16 yield the most predictable results.

See Also

PrintPro Object | PP_DrawMode Enumeration


PrintPro Object | DrawWidth Property | PP_DrawStyle Enumeration

DrawStyle Property

Description

Gets or sets a value that determines the line style for output from graphics methods.

Property type

Read-write property

Syntax (Visual Basic)

Public Property DrawStyle() As PP_DrawStyle

Value

A PP_DrawStyle enumeration value which determines the line style.

Remarks

If the DrawWidth property is set to a value greater than 1, DrawStyle settings 1 through 5 produce a solid line (the DrawStyle property value is not changed). If DrawWidth is set to 1, DrawStyle produces the effect for each setting.

See Also

PrintPro Object | DrawWidth Property | PP_DrawStyle Enumeration


PrintPro Object

DrawWidth Property

Description

Gets or sets the line width for output from graphics methods.

Property type

Read-write property

Syntax (Visual Basic)

Public Property DrawWidth() As Long

Value

A long value which represents the line width for output.

Remarks

A numeric expression from 1 through 32,767. This value represents the width of the line in pixels (or dots).

Increase the value of this property to increase the width of the line. If the DrawWidth property setting is greater than 1, DrawStyle property settings 1 through 4 produce a solid line (the DrawStyle property value is not changed). Setting DrawWidth to 1 allows DrawStyle to produce the results shown in the DrawStyle enumeration.

See Also


PrintPro Object | PP_Duplex Enumeration | ErrorCode Property

Duplex Property

Description

Gets or sets a value that determines whether a page is printed on both sides (if the printer supports this feature). Not available at design time.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Duplex() As PP_Duplex

Value

A PP_Duplex enumeration value which determines if a page is printed on both sides.

Remarks

You cannot set the Duplex property after a document has been started. With horizontal duplex printing, the top of both sides of the page are at the same end of the sheet. With vertical duplex printing, the bottom of one page is at the same end of the sheet as the top of the next page.

Note: The effect of setting the Duplex property depends on the driver supplied by the printer manufacturer. Some property settings may have no effect. Settings outside the accepted range may produce an error. The ErrorCode property will be set to -5015 or -5016 if the printer does not support this property. For more information, see the manufacturer's documentation for the specific printer driver.

See Also

PrintPro Object | PP_Duplex Enumeration | ErrorCode Property


PrintPro Object

DuplexCap Property

Description

Gets an indicator if duplex printing is possible.

Property type

Read-write property

Syntax (Visual Basic)

Public Property DuplexCap() As Boolean

Value

A boolean value which is True if the printer is capable of duplex printing. Otherwise, False is returned and duplex printing is not possible.

Remarks

Not available at design time.

See Also


PrintPro Object

ErrorCode Property

Description

Gets and sets the error code.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ErrorCode() As Long

Value

A long value which represents the error code.

See Also


PrintPro Object

ErrorDescription Property

Description

Gets or sets the error description.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ErrorDescription() As String

Value

A string value which represents the error description.

Remarks

The default value is an empty string "".

See Also


PrintPro Object | PP_EvaluationMode Enumeration

EvaluationMode Property

Description

Gets and sets the type of evaluation operation for the component.

Property type

Read-write property

Syntax (Visual Basic)

Public Property EvaluationMode() As PP_EvaluationMode

Value

A PP_EvaluationMode enumeration value which determines the type of evaluation operation.

Remarks

If it is detected that the Windows desktop is not available (e.g. in an NT Service) the control switches to Watermark mode. If the desktop is not available and cannot be detected as such the control will hang, in this case you must use Watermark mode.

Purchase and register a license to run in regular (not evaluation) mode.

See Also

PrintPro Object | PP_EvaluationMode Enumeration


PrintPro Object

FillColor Property

Description

Gets or sets the color used to fill in circles, boxes, round rectangles, pie-shapes and polygons created with the DrawCircle, DrawLine, DrawRoundRect, DrawPie and DrawPolygon graphics methods.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FillColor() As ULong

Value

A Ulong value which represents the color used to fill in shapes.

Remarks

Returns or sets the color used to fill in circles, boxes, round rectangles, pie-shapes and polygons created with the DrawCircle, DrawLine, DrawRoundRect, DrawPie and DrawPolygon graphics methods. Colors specified with the system color constants in the Visual Basic object library in the Object Browser can be used. The Microsoft Windows operating environment substitutes the user’s choices, as specified by the user’s Control Panel settings.

When the FillStyle property is set to its default, 1 (Transparent), the FillColor setting is ignored.

See Also


PrintPro Object

FillStyle Property

Description

Gets or sets the pattern used to fill circles, boxes, round rectangles, pie-shapes and polygons created with the DrawCircle, DrawLine, DrawRoundRect, DrawPie and DrawPolygon graphics methods.

Property type

Read-write property

Syntax (Visual Basic)

Public Property FillStyle() As PP_FillStyle

Value

A PP_FillStyle enumeration value which determines the pattern to use to fill shapes.

Remarks

Returns or sets the pattern used to fill circles, boxes, round rectangles, pie-shapes and polygons created with the DrawCircle, DrawLine, DrawRoundRect, DrawPie and DrawPolygon graphics methods.

When FillStyle is set to 1 (Transparent), the FillColor property is ignored.

See Also


PrintPro Object

Font Property

Description

Gets a Font object.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Font() As Font

Value

A Font object which represents possible properties to use.

Remarks

Use the Font property of an object to identify a specific Font object whose properties you want to use.

For example, the following code changes the Bold property setting of a Font object identified by the Font property of a PrintPRO control:

PrintPRO1.Font.Bold = True

See Also


PrintPro Object

ForeColor Property

Description

Gets or sets the color used to display text.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ForeColor() As ULong

Value

A Ulong value which represents the color used to display text.

Remarks

The valid range for a normal RGB color is 0 to 16,777,215 (&HFFFFFF). The high byte of a number in this range equals 0; the lower three bytes, from least to most significant byte, determine the amount of red, green, and blue, respectively. The red, green, and blue components are each represented by a number between 0 and 255 (&HFF). If the high byte is not 0, system colors are used, as defined in the user's Control Panel.

See Also


PrintPro Object | hMetaDC Property

hDC Property

Description

Gets a handle to the device context of a printer.

Property type

Read-write property

Syntax (Visual Basic)

Public Property hDC() As Long

Value

A long value which represents a handle to the device context of a printer.

Remarks

Not available at design time.

You can use the hDC property to refer to the handle for a printer device context. This provides a value you can pass to an ImagXpress control when you want to print from these controls.

Note: All printing that is done external to the PrintPRO control will not be viewable in print preview unless you also print to the print preview metafile handle using the hMetaDC property.

See Also

PrintPro Object | hMetaDC Property


PrintPro Object

hDIB Property

Description

Gets or sets a handle to a device independent bitmap image (DIB).

Property type

Read-write property

Syntax (Visual Basic)

Public Property hDIB() As Long

Value

A long value which represents a handle to a DIB.

Remarks

The DIB can be printed using the PrintDIB method.

A Windows handle to a Device Independent Bitmap (DIB). The PrintPRO control does not delete the memory occupied by the DIB. It is up to the user to manage the DIB memory. You can use the hDIB property to import a DIB from other controls including the ImagXpress control.

See Also


PrintPro Object

hMetaDC Property

Description

Gets a handle to the current print preview metafile device context (DC).

Property type

Read-write property

Syntax (Visual Basic)

Public Property hMetaDC() As Long

Value

A long value which represents a handle to the current print preview.

Remarks

Not available at design time.

You can use the hMetaDC property to add items to the current print preview. This gives you the flexibility to add custom items to the print preview that are not provided directly by PrintPRO.

Note: The print preview metafile handle is maintained by the PrintPRO control. You should not delete this handle.

See Also


PrintPro Object | peICMIntent Enumeration

ICMIntent Property

Description

Gets or sets a value that specifies which of three possible color management methods, or intents, should be used by default (if the printer supports this feature).

Property type

Read-write property

Syntax (Visual Basic)

Public Property ICMIntent() As PP_IcmIntent

Value

The PP_IcmIntent value set which determines the color management method to use.

Remarks

Note: You cannot set the ICMIntent property after a document has been started.

The effect of setting the ICMIntent property depends on the driver supplied by the printer manufacturer. Some property settings may have no effect. Settings outside the accepted range may produce an error. The ErrorCode property will be set to -5015 or -5016 if the printer does not support this property. For more information, see the manufacturer's documentation for the specific printer driver.

See Also

PrintPro Object | peICMIntent Enumeration


PrintPro Object | PP_IcmMethod Enumeration | ErrorCode Property

ICMMethod Property

Description

Gets or sets a value that specifies how Image Color Management (ICM) is handled.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ICMMethod() As PP_IcmMethod

Value

The PP_IcmMethod value set which determines how ICM is handled.

Remarks

Note: You cannot set the ICMMethod property after a document has been started.

The printer driver must provide a user interface for setting the ICM Method. Most printer drivers support only the System or Disabled value. Drivers for PostScript printers support all values.

The effect of setting this property depends on the driver supplied by the printer manufacturer. Some property settings may have no effect. Settings outside the accepted range may produce an error. The ErrorCode property will be set to -5015 or -5016 if the printer does not support this property. For more information, see the manufacturer's documentation for the specific printer driver.

Note: Color Management is designed to work with 24-bit color or 8-bit grayscale images. Color correction performed on images with less bit depth that this will result in poor quality images. PrintPRO has no native ability to promote images to higher bit depth; it is recommended that you use ImagXpress to do so.

See Also

PrintPro Object | PP_IcmMethod Enumeration | ErrorCode Property


PrintPro Object

ICMMonitorProfileName Property

Description

This is the file name of the monitor's color management profile.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ICMMonitorProfileName() As String

Value

A string value which represents the file name of the monitor's color management profile.

Remarks

Proofing requires that PrintPreviewOnly is set true and the monitor ICMMonitorProfileName is set or the monitor has a profile associated with it already. For this value to be effective ICMMethod must be set to ICMM_Profile.

See Also


PrintPro Object | PP_IcmMethod Enumeration | ICMMethod Property

ICMPrinterProfileName Property

Description

This is the file name of the printer's color management profile.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ICMPrinterProfileName() As String

Value

A string value which represents the file name of the printer's color management profile.

Remarks

This property is used to set the printer profile if the default printer profile is not desired or if the user wishes to print the image page against another printer profile. For this value to be effective ICMMethod must be set to Profile.

See Also

PrintPro Object | PP_IcmMethod Enumeration | ICMMethod Property


PrintPro Object

ICMProfileRenderIntent Property

Description

Gets and sets the purpose of the color correction.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ICMProfileRenderIntent() As PP_RenderIntent

Value

A PP_RenderIntent enumeration value which determines the color correction.

Remarks

You must set the profile name (ICMPrinterProfileName or ICMMonitorProfileName) when ICMProfileRenderIntent is set to any value other than NONE. ICMMethod is reset to ICMM_Disabled when ICMProfileRenderIntent is set to any value other than NONE so that the device itself doesn't also correct the image.

Note: Color Management is designed to work with 24-bit color or 8-bit grayscale images. Color correction performed on images with less bit depth that this will result in poor quality images. PrintPRO has no native ability to promote images to higher bit depth; it is recommended that you use ImagXpress to do so.

See Also


PrintPro Object

ICMWantProof Property

Description

Gets an indicator if ICM is used.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ICMWantProof() As Boolean

Value

A boolean value which is True if ICM is used. Otherwise, False is returned.

See Also


PrintPro Object

Licensed Property

Description

Gets or sets an indicator if the component is licensed.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Licensed() As Boolean

Value

A boolean value which is True if the component is licensed. Otherwise, False is returned.

See Also


PrintPro Object

Lmargin Property

Description

Gets or sets the left margin value.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Lmargin() As Single

Value

A single value which represents the left margin value.

Remarks

When the LMargin property is set, the CurrentX property is also set to the same value. Margin values are expressed in twips, or the current unit of measurement defined by the ScaleMode property.

The following methods set the CurrentX property to the LMargin value:

  • EndPrintDoc

  • NewPage

  • PrintText, when the AddCR property is True.

See Also


PrintPro Object | peMediaType Enumeration

MediaType Property

Description

Gets or sets a value that specifies the type of media being printed on (if the printer supports this feature).

Property type

Read-write property

Syntax (Visual Basic)

Public Property MediaType() As PP_MediaType

Value

The PP_MediaType value which determines the type of media being printed.

Remarks

Not available at design time.

Note: You cannot set the MediaType property after a document has been started.

The effect of setting the MediaType property depends on the driver supplied by the printer manufacturer. Some property settings may have no effect. Settings outside the accepted range may produce an error. The ErrorCode property will be set to -5015 or -5016 if the printer does not support this property. For more information, see the manufacturer's documentation for the specific printer driver.

See Also

PrintPro Object | peMediaType Enumeration


PrintPro Object

NumBins Property

Description

Gets the number of bins supported by the printer.

Property type

Read-write property

Syntax (Visual Basic)

Public Property NumBins() As Long

Value

A long value which represents the number of bins.

Remarks

Not available at design time.

See Also


PrintPro Object

NumCopies Property

Description

Returns the number of copies that the printer can print.

Property type

Read-write property

Syntax (Visual Basic)

Public Property NumCopies() As Long

Value

A long value which represents the number of copies the printer can print.

Remarks

Not available at design time.

See Also


PrintPro Object

NumPapers Property

Description

Gets the number of papers supported by the printer.

Property type

Read-write property

Syntax (Visual Basic)

Public Property NumPapers() As Long

Value

A long value which represents the number of papers supported by the printer.

Remarks

Not available at design time.

See Also


PrintPro Object

NumPrinters Property

Description

Gets the number of printers installed on the system.

Property type

Read-write property

Syntax (Visual Basic)

Public Property NumPrinters() As Long

Value

A long value which represents the number of printers installed on the system.

Remarks

If NumPrinters returns 0, the PrintPRO control could not find any printers.

Not available at design time.

See Also


PrintPro Object | PP_Orientation Enumeration | Orientation Property

Orientation Property

Description

Gets or sets a value indicating whether documents are printed in portrait or landscape mode (if the printer supports this feature).

Property type

Read-write property

Syntax (Visual Basic)

Public Property Orientation() As PP_Orientation

Value

The PP_Orientation value which determines if documents are printed in portrait or landscape mode.

Remarks

Returns or sets a value indicating whether documents are printed in portrait or landscape mode (if the printer supports this feature). Not available at design time.

Note: If you set the Orientation property after a document has been started, the new orientation will not take effect until you start a new page using the NewPage method.

The effect of setting the Orientation property depends on the driver supplied by the printer manufacturer. Some property settings may have no effect. Settings outside the accepted range may produce an error. The ErrorCode property will be set to -5015 or -5016 if the printer does not support this property. For more information, see the manufacturer's documentation for the specific printer driver.

See Also

PrintPro Object | PP_Orientation Enumeration | Orientation Property


PrintPro Object

OutputFileName Property

Description

Gets or sets a string value that specifies the print output file.

Property type

Read-write property

Syntax (Visual Basic)

Public Property OutputFileName() As String

Value

A string value which represents the print output file.

Remarks

If the OutputFileName property is set, the printed output will go to this file instead of the printer.

See Also


PrintPro Object

OwnDIB Property

Description

Gets or sets the DIB ownership flag.

Property type

Read-write property

Syntax (Visual Basic)

Public Property OwnDIB() As Boolean

Value

A boolean value which is True if the control deletes the DIB. Otherwise, False is used and the DIB is used by another control.

Remarks

  • If the OwnDIB property is True, the PrintPRO control will delete the DIB, set by the hDIB property, after printing the DIB using the PrintDIB method.
  • If the DIB is used by another control or it is maintained by another control, you should set the OwnDIB property to False (Default).

The OwnDIB property returns an integer value. If you use the ImagXpress control to set the hDIB property, the OwnDIB property should be set to False.

See Also


PrintPro Object

Page Property

Description

Gets the current page number.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Page() As Long

Remarks

Not available at design time.

PrintPRO keeps a count of pages that have been printed since your document started or since the last time the EndPrintDoc method was used. This count starts at one and increases by one if you use the NewPage method or the PrintText method automatically starts a new page because the text won’t fit on the current page.

See Also


PrintPro Object | PP_SourceBin Enumeration | NewPage Method

PaperBin Property

Description

Gets or sets a value indicating the default paper bin on the printer from which paper is fed when printing (if the printer supports this feature).

Property type

Read-write property

Syntax (Visual Basic)

Public Property PaperBin() As PP_SourceBin

Value

The PP_SourceBin value which determines the default paper bin.

Remarks

Not available at design time.

Note: If you set the PaperBin property after a document has been started, the new paper bin will not take effect until a new page has been started using the NewPage method.

The effect of setting the paperBin property depends on the driver supplied by the printer manufacturer. Some manufacturers have device-specific paper bin numbers that are greater than 256. You can use the NumBins, BinID and BinName properties to get a list of bin names and bin ID numbers for all bins supported by a printer. The ErrorCode property will be set to -5015 or -5016 if the printer does not support this property. For more information, see the manufacturer's documentation for the specific printer driver.

See Also

PrintPro Object | PP_SourceBin Enumeration | NewPage Method


PrintPro Object | pePaperSize Enumeration

PaperSize Property

Description

Gets or sets a value indicating the paper size for the current printer (if the printer supports this feature).

Property type

Read-write property

Syntax (Visual Basic)

Public Property PaperSize() As PP_PaperSize

Value

The PP_PaperSize value set.

Remarks

Not available at design time.

Note: You cannot set the PaperSize property after a document has been started.

The effect of setting the PaperSize property depends on the driver supplied by the printer manufacturer. Some property settings may have no effect. Settings outside the accepted range may produce an error. The ErrorCode property will be set to -5015 or -5016 if the printer does not support this property. For more information, see the manufacturer's documentation for the specific printer driver.

See Also

PrintPro Object | pePaperSize Enumeration


PrintPro Object

PdFromPage Property

Description

Gets and sets the initial value for the starting page edit control in the print dialog box.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PdFromPage() As Long

Value

A long value which represents the starting page.

Remarks

The current PdFromPage value specifies the initial value for the starting page edit control in the Print Dialog box.

When the PrintDialog method returns, the PdFromPage value is updated to the value the user entered in the starting page edit control.

See Also


PrintPro Object

PdMaxPage Property

Description

Gets or sets a value indicating the maximum page number allowed for the end page number when the user selects the Pages radio button on the Print Dialog box.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PdMaxPage() As Long

Value

A long value which represents the maximum page number allowed.

Remarks

Not available at design time.

See Also


PrintPro Object | PrintDialog Method

PdMinPage Property

Description

Gets or sets a value indicating the minimum page number allowed for the start page number when the user selects the Pages radio button on the Print Dialog box.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PdMinPage() As Long

Value

A long value which represents the minimum page number allowed for the start page number.

Remarks

Not available at design time.

The PrintDialog method is used to display the Print Dialog box.

See Also

PrintPro Object | PrintDialog Method


PrintPro Object

PdRange Property

Description

Gets a value indicating the Print Range selected on the Print Dialog box.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PdRange() As PP_PrintRange

Value

A PP_PrintRange enumeration value which determines the print range selected.

Remarks

Not available at design time.

The PrintDialog method is used to display the Print Dialog box.

See Also


PrintPro Object

PdRangeEnable Property

Description

Gets or sets a value indicating which Print Range radio buttons are enabled on the Print Dialog box.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PdRangeEnable() As PP_PrintRangeEnable

Value

A PP_PrintRangeEnable value which determines which print range radio buttons are enabled.

Remarks

The PrintDialog method is used to display the Print Dialog box.

Note: In order to get the Pages radio button to function properly, you need to make sure that the PdMaxPage property is set to a value that is greater than the pdMinPage property.

See Also


PrintPro Object

PdToPage Property

Description

Gets or sets a value indicating the end page number when the user selects the Pages radio button on the Print Dialog box.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PdToPage() As Long

Value

A long value which represents the end page number.

Remarks

Not available at design time.

The current PdToPage value specifies the initial value for the end page edit control in the Print Dialog box. When the PrintDialog method returns, the PdToPage value is updated to the value the user entered in the end page edit control

See Also


PrintPro Object

PHeight Property

Description

Gets the height of the bitmap defined by the Picture property in printer units defined by the ScaleMode property. Not available at design time. A bitmap image must be loaded into the control using the Picture property.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PHeight() As Single

Value

A single value which represents the height of the bitmap.

Remarks

Not available at design time.

Use the PHeight property for operations or calculations based on the printer’s total area. Use the ScaleHeight, and ScaleWidth properties for operations or calculations based on the printer’s internal area.

See Also


PrintPro Object

Picture Property

Description

Gets or sets a bitmap image to load into the control.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Picture() As Picture

Value

A Picture object to load into the control.

Remarks

The Picture property of PrintPRO can be set to the Picture property of a Form object, PictureBox control, Image control (Visual Basic), ImagXpress control or the Picture property of another PrintPRO control.

After an image is loaded, it can be printed using the PrintPicture method.

Example

You can use LoadPicture in Visual Basic to load a picture into the PrintPRO control:

object.Picture = LoadPicture(pathname)

See Also


PrintPro Object

PictureHeight Property

Description

Gets the height of the bitmap defined by the Picture property in printer units defined by the ScaleMode property.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PictureHeight() As Single

Remarks

Not available at design time.

A bitmap image must be loaded into the control using the Picture property.

Printer units are different than screen units. For example, an image that is 320x240 screen pixels on a 600dpi printer would be 2000x1500 printer pixels.

Example

Not available at design time.

A bitmap image must be loaded into the control using the Picture property.

You can use the PictureHeight and PictureWidth properties to print the image using the PrintPicture method as follows:

object.ScaleMode = 1

object.PrintPicture 0, 0, object.PictureWidth, object.PictureHeight

See Also


PrintPro Object

PictureTransparent Property

Description

Sets or returns the transparent picture flag.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PictureTransparent() As Boolean

Value

A boolean value which is True to make the background transparent. Otherwise, False should be used.

Remarks

When the PictureTransparent property is True, the background under the image will show through the image wherever the transparent color appears in the image. The transparent color is set by the PictureTransparentColor property.

Note: Some printers might not support transparent images.

See Also


PrintPro Object

PictureTransparentColor Property

Description

Sets or returns the transparent color of the image in the control.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PictureTransparentColor() As ULong

Value

A Ulong value which represents the transparent color of the image in the control.

Remarks

If the PictureTransparent property is True when an image is loaded into the control using the Picture or hDIB properties, the background under the image will show through the image wherever the transparent color set by the PictureTransparentColor property appears in the image when the image is printed.

Note: Some printers do not support transparent images.

See Also


PrintPro Object

PictureWidth Property

Description

Gets the width of the bitmap defined by the Picture property in printer units defined by the ScaleMode property.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PictureWidth() As Single

Value

A single value which represents the width of the bitmap.

Remarks

Not available at design time.

A bitmap image must be loaded into the control using the Picture property.

Printer units are different than screen units. For example, an image that is 320x240 screen pixels on a 600dpi printer would be 2000x1500 printer pixels.

Example

Not available at design time.

A bitmap image must be loaded into the control using the Picture property

You can use the PictureHeight and PictureWidth properties to print the image using the PrintPicture method as follows:

object.ScaleMode = 1

object.PrintPicture 0, 0, object.PictureWidth, object.PictureHeight

See Also


PrintPro Object

PrintEnabled Property

Description

Disables or enables all printing.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PrintEnabled() As Boolean

Value

A boolean value which is True to enable all printing. Otherwise, False should be used and printing is disabled.

See Also


PrintPro Object

PrinterDriverName Property

Description

Returns the current printer driver name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PrinterDriverName() As String

Value

A string value which represents the current printer driver name.

See Also


PrintPro Object

PrinterName Property

Description

Returns the current printer name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PrinterName() As String

Value

A string value which represents the current printer name.

See Also


PrintPro Object

PrinterNum Property

Description

Gets the index of the current printer in the printer collection.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PrinterNum() As Long

Value

A long value which represents a zero-based index of the current printer in the printer collection.

Remarks

Not available at design time. PrintPRO maintains a list of available printers in an internal collection (array). The NumPrinters property can be used to determine the number of printers in the collection. The PrinterName method can be used to get the name of a printer based on its index in the collection. The SelectPrinter method can be used to select a printer based on its index in the collection. The property returns the index of the current printer.

See Also


PrintPro Object

PrinterPortName Property

Description

Returns the name of the port through which a document is sent to a printer.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PrinterPortName() As String

Value

A string value which represents the name of the port.

See Also


PrintPro Object

PrintPreviewDDB Property

Description

Gets a handle to the print preview Device Dependent Bitmap (DDB).

Property type

Read-write property

Syntax (Visual Basic)

Public Property PrintPreviewDDB() As Long

Value

A long value which represents a handle to the print preview DDB.

Remarks

The DDB returned by the PrintPreviewDDB property is managed by the PrintPRO control. You can use the DDB to display the print preview but you cannot modify the bitmap, delete it or assign ownership to another object.

See Also


PrintPro Object

PrintPreviewDIB Property

Description

Gets a handle to the print preview Device Independent Bitmap (DIB).

Property type

Read-write property

Syntax (Visual Basic)

Public Property PrintPreviewDIB() As Long

Value

A long value which represents a handle to the print preview DDB.

Remarks

The DIB returned by the PrintPreviewDIB property is a copy of the bitmap used by the PrintPRO control. After using the DIB, you are responsible for deleting it. PrintPreviewDIB will return 0 if a bitmap does not exist.

See Also


PrintPro Object

PrintPreviewOnly Property

Description

Determines whether PrintPRO only generates print preview images.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PrintPreviewOnly() As Boolean

Value

A boolean value which is True to create print preview images without actually printing to a printer. Otherwise, False should be used to create print preview images as PrintPro prints to a printer.

Remarks

Use the StartPrintPreview and EndPrintPreview properties to create print preview images. Then, use the GetPrintPreview method and the PrintPreviewPicture property to display the print preview images.

See Also


PrintPro Object

PrintPreviewPicture Property

Description

Gets a picture object of the print preview page.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PrintPreviewPicture() As Picture

Value

A Picture object of the print preview page.

Remarks

The size of the image is determined by the PrintPreviewScale property. The PrintPreviewPicture property will not return a picture until you call the GetPrintPreview method.

Note: There is currently an exception thrown when attempting to assign the PrintPreviewPicture results in a C++Builder 6 environment. To work around this issue until it can be addressed, assign the PrintPreviewDIB to an ImagXpress control instance. However, note that this will create an ImagXpress dependency.

See Also


PrintPro Object | pePPScaleMode Enumeration

PrintPreviewScale Property

Description

Sets the size of the print preview image.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PrintPreviewScale() As PP_PreviewScale

Value

The PP_PreviewScale value set.

Remarks

Note: One to one (1:1) preview images require substantial memory depending on the paper size and color depth of your monitor. If you create many print preview images, you might run out of memory if you use the 1:1 setting.

See Also

PrintPro Object | pePPScaleMode Enumeration


PrintPro Object | pePrintQuality Enumeration | ErrorCode Property

PrintQuality Property

Description

Gets or sets a value indicating the printer resolution (if the printer supports this feature).

Property type

Read-write property

Syntax (Visual Basic)

Public Property PrintQuality() As PP_PrintQuality

Value

The PP_PrintQuality value set.

Remarks

Not available at design time.

Note: You cannot set the PrintQuality property after a document has been started.

The effect of setting the PrintQuality property depends on the driver supplied by the printer manufacturer. Some property settings may have no effect. Settings outside the accepted range may produce an error. The ErrorCode property will be set to -5015 or -5016 if the printer does not support this property. For more information, see the manufacturer's documentation for the specific printer driver.

See Also

PrintPro Object | pePrintQuality Enumeration | ErrorCode Property


PrintPro Object

PrintRightToLeft Property

Description

Gets and sets an indicator which determines if text output is printed from right-to-left.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PrintRightToLeft() As Boolean

Value

A boolean value which is True to print from right to left. Otherwise, False should be used.

Remarks

The default value is False.

See Also


PrintPro Object

PrintToFile Property

Description

Gets and sets an indicator if the print output from printer devices to disk file is redirected.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PrintToFile() As Boolean

Value

A boolean value which is True to redirect the print output from printer devices to disk file. Otherwise, False should be used.

Remarks

The degree or quality of color will depend on the Display color card in the machine and particular monitor driving settings. If the display is setup in 256 color mode, than an 8 bit color file is generated. If a 24 bit or higher mode is selected, the color file generated will be 24 bit (true color).

The quality or size of the file generated will depend on the dots per inch (dpi) requested.

The highest dpi is actually machine and Windows OS dependent due to memory limitations. Factors which will affect and limit the dpi resolution will be the paper size, Color (B/W or Color) and Windows operating system (see GetMaxDPI (void) to get maximum possible dpi).

Older Windows 98 machines cannot match the newer Windows operating system for dpi quality.

Use RequestedDPI to set or get the current dpi resolution. The default value is 200 dpi.

Be aware that a high DPI, especially for uncompressed color, can generate a file up to 30 megabytes (per page). Since the control will add pages to an existing file, a multi-page file using uncompressed color data will be enormous.

Compressed Black and White TIFF files can attain higher DPI resolution with less memory. The quality and size of the file generated will depend upon the DPI requested.

See Also


PrintPro Object

PWidth Property

Description

Gets the physical width of the paper set up for the printing device, in units determined by the ScaleMode property.

Property type

Read-write property

Syntax (Visual Basic)

Public Property PWidth() As Single

Value

A single value which represents the width of the paper set up for the printing device.

Remarks

Not available at design time.

Use the PWidth property for operations or calculations based on the printer’s total area. Use the ScaleHeight, and ScaleWidth properties for operations or calculations based on the printer’s internal area.

See Also


PrintPro Object

RaiseExceptions Property

Description

Gets and sets an indicator whether to raise exceptions.

Property type

Read-write property

Syntax (Visual Basic)

Public Property RaiseExceptions() As Boolean

Value

A boolean value which is True to raise exceptions. Otherwise, False should be used and no exceptions are raised.

See Also


PrintPro Object

RequestedDPI Property

Description

Gets or sets the current DPI resolution.

Property type

Read-write property

Syntax (Visual Basic)

Public Property RequestedDPI() As Long

Value

A long value which represents the current DPI resolution.

Remarks

The quality and size of the file generated will depend upon the DPI requested. Use GetMaxIDP to determine the upper limit for this property.

See Also


PrintPro Object

ResX Property

Description

Gets the horizontal resolution of the printer in dots per inch (e.g. 600 DPI).

Property type

Read-write property

Syntax (Visual Basic)

Public Property ResX() As Long

Value

A long value which represents the horizontal resolution of the print in DPI.

Remarks

Not available at design time.

See Also


PrintPro Object

ResY Property

Description

Gets the vertical resolution of the printer in dots per inch (e.g. 600 DPI).

Property type

Read-write property

Syntax (Visual Basic)

Public Property ResY() As Long

Value

A long value which represents the vertical resolution of the print in DPI.

Remarks

Not available at design time.

See Also


PrintPro Object | peSaveFileType Enumeration

SaveFileType Property

Description

Controls the type of file generated.

Property type

Read-write property

Syntax (Visual Basic)

Public Property SaveFileType() As PP_SaveFileType

Value

The PP_SaveFileType value set.

Remarks

The PrintToFile property must be set to True for this property to have an effect.

Multi-page files may be saved as TIFF and PDF types.

See Also

PrintPro Object | peSaveFileType Enumeration


PrintPro Object

ScaleHeight Property

Description

Gets the number of units for the vertical measurement of the interior of a printer.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ScaleHeight() As Single

Value

A single value which represents the number of units for the vertical measurement of the interior of a printer.

Remarks

Use the ScaleMode property to define a scale based on a standard unit of measurement, such as twips, points, pixels, characters, inches, millimeters, or centimeters.

See Also


PrintPro Object | PP_ScaleMode Enumeration

ScaleMode Property

Description

Gets or sets a value indicating the unit of measurement for coordinates of an object when printing or using graphics methods.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ScaleMode() As PP_ScaleMode

Value

The PP_ScaleMode value which determines the unit of measurement for coordinates of an object when printing or using graphics methods.

See Also

PrintPro Object | PP_ScaleMode Enumeration


PrintPro Object

ScaleWidth Property

Description

Gets the number of units for the horizontal measurement of the interior of a printer.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ScaleWidth() As Single

Value

A single value which represents the number of units for the horizontal measurement of the interior of a printer.

Remarks

Use the ScaleMode property to define a scale based on a standard unit of measurement, such as twips, points, pixels, characters, inches, millimeters, or centimeters.

See Also


PrintPro Object

TemplateFile Property

Description

The photograph collage description file name.

Property type

Read-write property

Syntax (Visual Basic)

Public Property TemplateFile() As String

Value

A string value which represents the collage description file name.

Remarks

The use of a TemplateFile provides a simplified access to PrintPicture and PrintDIB.

A collage template file is a text file of particular format that describes component image size and location. The first line is a format and version control line so that future modifications may be supported transparently and is as follows:

Pegasus Imaging PrintPRO Template Version 1 Units = TW | PO | PI | CH | IN | MI | CE

Use only one of the unit indicators. They represent Twips, Point, Pixel, Character, Inches, Millimeter and Centimeter. The first two characters are sufficient for selecting the unit used to describe location and dimensions.

Each subsequent line describes the location and cropping of a component image. A line consists of a delimited (by comma, space, spaces or tab) series of values: Left, Top, Width, Height, SourceLeft, SourceTop, SourceWidth, SourceHeight and an Aspect flag.

Example

If the source parameters are omitted, then the entire source image is inserted. For example:

Pegasus Imaging PrintPRO Template Version 1 Units = IN

0,0,8.5,11.0, 0 ' Full size background image, stretch to fit

1.0, 1.0, 4.0, 5.0 ' Insert a 4x5 an inch in from the top left corner

4,5,4.5,6 ' Fill the bottom right corner

3, 2, 1, 1, 7, 0, 1, 1 ' Clip a 1x1 section out of the top right corner of an image and insert it

See PrintDIB for the particulars on these parameters.

The following is an example of building a collage:

Private Sub TiffPrint1_Click()

Dim BaseDir As String

BaseDir = "C:\Develop\PrintPRO\PhotoTest"

PrintPRO.SelectDefaultPrinter

' PrintPRO.PictureTransparent = True

PrintPRO.PrintToFile = True

PrintPRO.SaveFileType = PP_TIF

PrintPRO.OutputFileName = BaseDir & "\Collage.tif"

PrintPRO1.StartPrintDoc

' Page 1

Ixp.FileName = BaseDir & "\Pegasus111.jpg"

PrintPRO.hDIB = Ixp.hDIB

PrintPRO.PrintTemplateDIB 0

Ixp.FileName = BaseDir & "\exif.jpg"

PrintPRO.hDIB = Ixp.hDIB

PrintPRO.PrintTemplateDIB 0

Ixp.FileName = BaseDir & "\jeansFix.jpg"

PrintPRO.hDIB = Ixp.hDIB

PrintPRO.PrintTemplateDIB 0

Ixp.FileName = BaseDir & "\MainTest.bmp"

PrintPRO.hDIB = Ixp.hDIB

PrintPRO.PrintTemplateDIB 0

Ixp.FileName = BaseDir & "\Blue hills.bmp"

PrintPRO.hDIB = Ixp.hDIB

PrintPRO.PrintTemplateDIB 0

‘ Page 2 generated because template file wraps which is a implicit new-page

Ixp.FileName = BaseDir & "\Pegasus111.jpg"

PrintPRO.hDIB = Ixp.hDIB

PrintPRO.PrintTemplateDIB 0

Ixp.FileName = BaseDir & "\monet.jpg"

PrintPRO.hDIB = Ixp.hDIB

PrintPRO.PrintTemplateDIB 0

Ixp.FileName = BaseDir & "\jeansFix.jpg"

PrintPRO.hDIB = Ixp.hDIB

PrintPRO.PrintTemplateDIB 0

Ixp.FileName = BaseDir & "\exif.jpg"

PrintPRO.hDIB = Ixp.hDIB

PrintPRO.PrintTemplateDIB 0

Ixp.FileName = BaseDir & "\MainTest.bmp"

PrintPRO.hDIB = Ixp.hDIB

PrintPRO.PrintTemplateDIB 0

PrintPRO.EndPrintDoc

End Sub

The Template file places images only at this time. Draw text and other objects (circles, rectangles, etc.) using the appropriate Draw method.

See Also


PrintPro Object

TMargin Property

Description

Gets or sets the top margin value.

Property type

Read-write property

Syntax (Visual Basic)

Public Property TMargin() As Single

Value

A single value which represents the top margin value.

Remarks

When the TMargin property is set, the CurrentY property is also set to the same value. Margin values are expressed in twips, or the current unit of measurement defined by the ScaleMode property.

The following methods set the CurrentY property to the TMargin value:

  • EndPrintDoc

  • NewPage

See Also


PrintPro Object

TTOptions Property

Description

Gets or sets a value indicating the printer’s TrueType option.

Property type

Read-write property

Syntax (Visual Basic)

Public Property TTOptions() As PP_TrueTypeOption

Value

The PP_TrueTypeOption value set.

See Also


PrintPro Object

TwipsPerPixelX Property

Description

Gets the number of twips per pixel for a printer measured horizontally.

Property type

Read-write property

Syntax (Visual Basic)

Public Property TwipsPerPixelX() As Single

Value

A single value which represents the number of twips per pixel for a printer measured horizontally.

Remarks

Not available at design time.

Windows API routines generally require measurements in pixels.

You can use these properties to convert measurements quickly without changing an object's ScaleMode property setting.

See Also


PrintPro Object

TwipsPerPixelY Property

Description

Gets the number of twips per pixel for a printer measured vertically.

Property type

Read-write property

Syntax (Visual Basic)

Public Property TwipsPerPixelY() As Single

Value

A single value which represents the number of twips per pixel for a printer measured vertically.

Remarks

Not available at design time.

Windows API routines generally require measurements in pixels.

You can use these properties to convert measurements quickly without changing an object's ScaleMode property setting.

See Also


PrintPro Object

UseDefaultPrinter Property

Description

Gets and sets an indicator whether PrintPRO uses the system default printer by default.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UseDefaultPrinter() As Boolean

Value

A boolean value which is True to automatically select the system default printer when the control is loaded. False should be used to not select any printer when the control is loaded.

See Also


PrintPro Object

UseHardwareMargins Property

Description

Gets and sets an indicator if hardware margins are used.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UseHardwareMargins() As Boolean

Value

A boolean value which is True to use hardware margins. Otherwise, False should be used to not use hardware margins.

See Also


PrintPro Object

WordWrap Property

Description

Gets and sets a value to determine whether text word wraps inside the PrintText method’s print rectangle.

Property type

Read-write property

Syntax (Visual Basic)

Public Property WordWrap() As Boolean

Value

A boolean value which is True to wrap text inside the PrintText method's print rectangle. Otherwise, False should be used.

See Also


PrintPro Object | ErrorCode Property

Zoom Property

Description

Gets or sets the percentage by which printed output is to be scaled up or down (if the printer supports this feature).

Property type

Read-write property

Syntax (Visual Basic)

Public Property Zoom() As Long

Value

A long value which represents the percentage of printed output is to be scaled up or down.

Remarks

Not available at design time.

The Zoom property setting scales the size of the physical page up or down, by a factor of Zoom/100, to the apparent size of the printed output. For example, a letter-size page printed with Zoom set to 50 contains as much data as a page of the size 17 by 22 inches because the printed text and graphics are scaled to one-half their original height and width.

Note: The effect of setting the Zoom property depends on the driver supplied by the printer manufacturer. Some property settings may have no effect. Settings outside the accepted range may produce an error. The ErrorCode property will be set to -5015 or -5016 if the printer does not support this property. For more information, see the manufacturer's documentation for the specific printer driver.

See Also

PrintPro Object | ErrorCode Property


PP_Alignment Enumeration

Description

Option values which define the possible text alignment styles.

Members

Member | Description
PP_Alignment_LeftJustifyTop | (0) Text appears left justified at the top of the print rectangle
PP_Alignment_LeftJustifyMiddle | (1) Text appears left justified in the middle of the print rectangle.
PP_Alignment_LeftJustifyBottom | (2) Text appears left justified at the bottom of the print rectangle.
PP_Alignment_RightJustifyTop | (3) Text appears right justified at the top of the print rectangle
PP_Alignment_RightJustifyMiddle | (4) Text appears right justified in the middle of the print rectangle.
PP_Alignment_RightJustifyBottom | (5) Text appears right-justified at the bottom of the print rectangle.
PP_Alignment_CenterJustifyTop | (6) Text appears centered at the top of the print rectangle.
PP_Alignment_CenterJustifyMiddle | (7) Text appears centered in the middle of the print rectangle.
PP_Alignment_CenterJustifyBottom | (8) Text appears centered at the bottom of the print rectangle.


PP_BackStyle Enumeration

Description

Option values which define the possible background styles of printed text.

Members

Member | Description
PP_BackStyle_Transparent | (0) Background color and any graphics are visible behind the text.
PP_BackStyle_Opaque | (1) The text background is filled with BackColor and obscures any color or graphics behind it.


PP_ColorMode Enumeration

Description

Option values which define two values: one for printing in color and one for printing in monochrome.

Members

Member | Description
PP_ColorMode_Monochrome | (1) Print output in monochrome (usually shades of black and white).
PP_ColorMode_Color | (2) Print output in color.


PP_DebugErrorLevel Enumeration

Description

Option values which determine the amount of logging to write to the debug log file.

Members

Member | Description
PP_DebugErrorLevel_Normal | This is the default. The minimal amount of logging is written.
PP_DebugErrorLevel_Development | Includes any additional information that may be useful while developing.
PP_DebugErrorLevel_Detailed | The highest amount of logging which includes all information.


PP_DitherType Enumeration

Description

Option values which define the possible types of dithering that can be done.

Members

Member | Description
PP_DitherType_NoDither | (1) No dithering.
PP_DitherType_CoarseDither | (2) Dither with a coarse brush.
PP_DitherType_FineDither | (3) Dither with a fine brush.
PP_DitherType_LineArtDither | (4) Line art dithering, a special dithering method that produces well defined borders between black, white, and gray scaling. It is not suitable for images that include continuous gradations in intensity and hue such as scanned photographs.
PP_DitherType_ErrorDiffusionDither |
PP_DitherType_GrayscaleDither |


PP_DrawMode Enumeration

Description

Option values which define the possible values to determine appearance of output from graphics methods.

Members

Member | Description
PP_DrawMode_Blackness | (1) Blackness.
PP_DrawMode_NotMergePen | (2) Inverse of MergePen. (3) Combination of the colors common to the background color and the inverse of the pen.
PP_DrawMode_MaskNotPen | (3) A combination of the colors common to the background and the inverse of the pen.
PP_DrawMode_NotCopyPen | (4) Inverse of CopyPen.
PP_DrawMode_MaskPenNot | (5) Combination of the colors common to both the pen and the inverse of the display.
PP_DrawMode_Invert | (6) Inverse of the display color.
PP_DrawMode_Xor | (7) Combination of the colors in the pen and in the display color, but not in both.
PP_DrawMode_NotMaskPen | (8) Inverse of Mask Pen.
PP_DrawMode_MaskPen | (9) Combination of the colors common to both the pen and the display.
PP_DrawMode_NotXorPen | (10) Inverse of Xor Pen.
PP_DrawMode_Nop | (11) No operation — output remains unchanged. In effect, this setting turns drawing off.
PP_DrawMode_MergeNotPen | (12) Combination of the display color and the inverse of the pen color.
PP_DrawMode_CopyPen | (13) Color specified by the graphic method.
PP_DrawMode_MergePenNot | (14) Combination of the pen color and the inverse of the display color.
PP_DrawMode_MergePen | (15) Combination of the pen color and the display color.
PP_DrawMode_Whiteness | (16) Whiteness.


PP_DrawStyle Enumeration

Description

Option values which define the possible line styles for output from graphics methods.

Members

Member | Description
PP_DrawStyle_Transparent | (0) Transparent line.
PP_DrawStyle_Solid | (1) Solid line.
PP_DrawStyle_Dash | (2) Line comprised of dashes.
PP_DrawStyle_Dot | (3) Line comprised of dots.
PP_DrawStyle_DashDot | (4) Line comprised of alternating dashes and dots.
PP_DrawStyle_DashDotDot | (5) Line comprised of one dash followed by two dots.


PP_Duplex Enumeration

Description

Option values which define the possible duplexing options.

Members

Member | Description
PP_Duplex_Simplex | (1) Single-sided printing with the current orientation setting.
PP_Duplex_Vertical | (2) Double-sided printing using a vertical page turn.
PP_Duplex_Horizontal | (3) Double-sided printing using a horizontal page turn.


PP_EvaluationMode Enumeration

Description

Option values which defines the possible behaviors of the control when in evaluation (non-licensed) mode.

Members

Member | Description
PP_EvaluationMode_Automatic | The trial licensing dialog box will appear at regular intervals.
PP_EvaluationMode_Timeout | The control stops operation after a short period of time.


PP_FillStyle Enumeration

Description

Option values which define the possible patterns used to fill circles, boxes, round rectangles, pie-shapes and polygons created with graphics methods.

Members

Member | Description
PP_FillStyle_Solid | (0) Solid fill.
PP_FillStyle_Transparent | (1) Transparent fill.
PP_FillStyle_HorizontalLine | (2) Horizontal line fill.
PP_FillStyle_VerticalLine | (3) Vertical line fill.
PP_FillStyle_DownwardDiagonal | (4) Downward diagonal fill.
PP_FillStyle_UpwardDiagonal | (5) Upward diagonal fill.
PP_FillStyle_Cross | (6) Cross fill.
PP_FillStyle_DiagonalCross | (7) Diagonal cross fill.


PP_IcmIntent Enumeration

Description

Option values which define the possible color management methods, or intents, to use by default.

Members

Member | Description
PP_IcmIntent_Saturation | (1) Color matching should optimize for color saturation. This value is the most appropriate choice for business graphs when dithering is not desired.
PP_IcmIntent_Contrast | (2) Color matching should optimize for color contrast. This value is the most appropriate choice for scanned or photographic images when dithering is desired.
PP_IcmIntent_ColorMetric | (3) Color matching should optimize to match the exact color requested. This value is most appropriate for use with business logos or other images when an exact color is desired.


PP_IcmMethod Enumeration

Description

Option values which define the possibilities for how Image Color Management (ICM) is handled.

Members

Member | Description
PP_IcmMethod_Disabled | (1) Specifies that ICM is disabled.
PP_IcmMethod_System | (2) Specifies that ICM is handled by Windows.
PP_IcmMethod_Driver | (3) Specifies that ICM is handled by the device driver.
PP_IcmMethod_Device | (4) Specifies that ICM is handled by the device.
PP_IcmMethod_Profile | (5) Specifies that PrintPRO will apply the ICM profile associated with the destination device (printer or monitor).


PP_MediaType Enumeration

Description

Option values which define the possible media to print on.

Members

Member | Description
PP_MediaType_StandardPaper | (1) Glossy paper.
PP_MediaType_Transparency | (2) Transparent film.
PP_MediaType_GlossyPaper | (3) Plain paper.


PP_Orientation Enumeration

Description

Option values which define the set of possible orientations for the document.

Members

Member | Description
PP_Orientation_Portrait | (1) — The top of the document prints at the narrow side (top) of the paper.
PP_Orientation_Landscape | (2) — The top of document prints at the wide side of the paper.
PP_Orientation_Rotate | (3) - The paper is rotated.


PP_PaperSize Enumeration

Description

Option values which define possible paper sizes for printing.

Members

Member | Description
PP_PaperSize_Letter | (1) Letter, 8 1/2 x 11 in.
PP_PaperSize_LetterSmall | (2) Letter Small, 8 1/2 x 11 in.
PP_PaperSize_Tabloid | (3) Tabloid, 11 x 17 in.
PP_PaperSize_Ledger | (4) Ledger, 17 x 11 in.
PP_PaperSize_Legal | (5) Legal, 8 1/2 x 14 in.
PP_PaperSize_Statement | (6) Statement, 5 1/2 x 8 1/2 in.
PP_PaperSize_Executive | (7) Executive, 7 1/2 x 10 1/2 in.
PP_PaperSize_A3 | (8) A3, 297 x 420 mm
PP_PaperSize_A4 | (9) A4, 210 x 297 mm
PP_PaperSize_A4Small | (10) A4 Small, 210 x 297 mm
PP_PaperSize_A5 | (11) A5, 148 x 210 mm
PP_PaperSize_B4 | (12) B4, 250 x 354 mm
PP_PaperSize_B5 | (13) B5, 182 x 257 mm
PP_PaperSize_Filio | (14) Folio, 8 1/2 x 13 in.
PP_PaperSize_Quarto | (15) Quarto, 215 x 275 mm
PP_PaperSize_10x14 | (16) 10 x 14 in.
PP_PaperSize_11x17 | (17) 11 x 17 in.
PP_PaperSize_Note | (18) Note, 8 1/2 x 11 in.
PP_PaperSize_Envelope9 | (19) Envelope #9, 3 7/8 x 8 7/8 in.
PP_PaperSize_Envelope10 | (20) Envelope #10, 4 1/8 x 9 1/2 in.
PP_PaperSize_Envelope11 | (21) Envelope #11, 4 1/2 x 10 3/8 in.
PP_PaperSize_Envelope12 | (22) Envelope #12, 4 1/2 x 11 in.
PP_PaperSize_Envelope14 | (23) Envelope #14, 5 x 11 1/2 in.
PP_PaperSize_CSheet | (24) C size sheet
PP_PaperSize_DSheet | (25) D size sheet
PP_PaperSize_ESheet | (26) E size sheet
PP_PaperSize_EnvelopeDL | (27) Envelope DL, 110 x 220 mm
PP_PaperSize_EnvelopeC5 | (28) Envelope C5, 162 x 229 mm
PP_PaperSize_EnvelopeC3 | (29) Envelope C3, 324 x 458 mm
PP_PaperSize_EnvelopeC4 | (30) Envelope C4, 229 x 324 mm
PP_PaperSize_EnvelopeC6 | (31) Envelope C6, 114 x 162 mm
PP_PaperSize_EnvelopeC65 | (32) Envelope C65, 114 x 229 mm
PP_PaperSize_EnvelopeB4 | (33) Envelope B4, 250 x 353 mm
PP_PaperSize_EnvelopeB5 | (34) Envelope B5, 176 x 250 mm
PP_PaperSize_EnvelopeB6 | (35) Envelope B6, 176 x 125 mm
PP_PaperSize_EnvelopeItaly | (36) Envelope, 110 x 230 mm
PP_PaperSize_EnvelopeMonarch | (37) Envelope Monarch, 3 7/8 x 7 1/2 in.
PP_PaperSize_EnvelopePersonal | (38) Envelope, 3 5/8 x 6 1/2 in.
PP_PaperSize_FanFoldUS | (39) Standard Fanfold, 14 7/8 x 11 in.
PP_PaperSize_FanFoldStdGerman | (40) German Standard Fanfold, 8 1/2 x 12 in.
PP_PaperSize_FanFoldLegalGerman | (41) German Legal Fanfold, 8 1/2 x 13 in.
PP_PaperSize_ISO_B4 | (42) Japanese Postcard 100 x 148 mm
PP_PaperSize_9x11 | (43) 9 x 11 in.
PP_PaperSize_10x11 | (44) 10 x 11 in.
PP_PaperSize_15x11 | (45) 15 x 11 in.
PP_PaperSize_Env_Invite | (46) Envelope Invite 220 x 220 mm
PP_PaperSize_Reserved_48 | (47) Reserved—DO NOT USE
PP_PaperSize_Reserved_49 | (48) Reserved—DO NOT USE
PP_PaperSize_Letter_Extra | (49) Letter Extra 9 \275 x 12 in.
PP_PaperSize_LEGAL_Extra | (50) Legal Extra 9 \275 x 15 in.
PP_PaperSize_TABLOID_Extra | (51) Tabloid Extra 11.69 x 18 in.
PP_PaperSize_A4_Extra | (52) A4 Extra 9.27 x 12.69 in.
PP_PaperSize_Letter_Transverse | (53) Letter Transverse 8 \275 x 11 in.
PP_PaperSize_A4_Transverse | (54) A4 Transverse 210 x 297 mm
PP_PaperSize_Letter_Extra_Transverse | (55) Letter Extra Transverse 9\275 x 12 in.
PP_PaperSize_A_Plus | (56) SuperA/SuperA/A4 227 x 356 mm
PP_PaperSize_B_Plus | (57) SuperB/SuperB/A3 305 x 487 mm
PP_PaperSize_Letter_Plus | (58) Letter Plus
PP_PaperSize_A4_Plus | (59) A4 Plus 210 x 330 mm
PP_PaperSize_A5_Transverse | (60) A5 Transverse 148 x 210 mm
PP_PaperSize_B5_Transverse | (61) B5 (JIS) Transverse 182 x 257 mm
PP_PaperSize_A3_Extra | (62) A3 Extra 322 x 445 mm
PP_PaperSize_A5_Extra | (63) A5 Extra 174 x 235 mm
PP_PaperSize_B5_Extra | (64) B5 (ISO) Extra 201 x 276 mm
PP_PaperSize_A2 | (65) A2 420 x 594 mm
PP_PaperSize_A3_Transverse | (66) A3 Transverse 297 x 420 mm
PP_PaperSize_A3_Extra_Transverse | (67) A3 Extra Transverse 322 x 445 mm
PP_PaperSize_DBL_Japanese_Postcard | (68) Japanese Double Postcard 200 x 148 mm
PP_PaperSize_A6 | (69) A6 105 x 148 mm
PP_PaperSize_JEnv_KAKU2 | (70) Japanese Envelope Kaku #2
PP_PaperSize_JEnv_KAKU3 | (71) Japanese Envelope Kaku #3
PP_PaperSize_JEnv_CHOU3 | (72) Japanese Envelope Chou #3
PP_PaperSize_JEnv_CHOU4 | (73) Japanese Envelope Chou #4
PP_PaperSize_Letter_Rotated | (74) Letter Rotated 11 x 8 1/2 11 in.
PP_PaperSize_A3_Rotated | (75) A3 Rotated 420 x 297 mm
PP_PaperSize_A4_Rotated | (76) A4 Rotated 297 x 210 mm
PP_PaperSize_A5_Rotated | (77) A5 Rotated 210 x 148 mm
PP_PaperSize_B4_JIS_Rotated | (78) B4 (JIS) Rotated 364 x 257 mm
PP_PaperSize_B5_JIS_Rotated | (79) B5 (JIS) Rotated 257 x 182 mm
PP_PaperSize_Japanese_Postcard_Rotated | (80) Japanese Postcard Rotated 148 x 100 mm
PP_PaperSize_DBL_Japanese_Postcard_Rotated | (81) Double Japanese Postcard Rotated 148 x 200 mm
PP_PaperSize_A6_Rotated | (82) A6 Rotated 148 x 105 mm
PP_PaperSize_JEnv_KAKU2_Rotated | (83) Japanese Envelope Kaku #2 Rotated
PP_PaperSize_JEnv_KAKU3_Rotated | (84) Japanese Envelope Kaku #3 Rotated
PP_PaperSize_JEnv_CHOU3_Rotated | (85) Japanese Envelope Chou #3 Rotated
PP_PaperSize_JEnv_CHOU4_Rotated | (86) Japanese Envelope Chou #4 Rotated
PP_PaperSize_B6_JIS | (87) B6 (JIS) 128 x 182 mm
PP_PaperSize_B6_JIS_Rotated | (88) B6 (JIS) Rotated 182 x 128 mm
PP_PaperSize_12x11 | (89) 12 x 11 in.
PP_PaperSize_JEnv_YOU4 | (90) Japanese Envelope You #4
PP_PaperSize_JEnv_YOU4_Rotated | (91) Japanese Envelope You #4 Rotated
PP_PaperSize_P16K | (92) PRC 16K 146 x 215 mm
PP_PaperSize_P32K | (93) PRC 32K 97 x 151 mm
PP_PaperSize_P32KBig | (94) PRC 32K(Big) 97 x 151 mm
PP_PaperSize_PEnv_1 | (95) PRC Envelope #1 102 x 165 mm
PP_PaperSize_PEnv_2 | (96) PRC Envelope #2 102 x 176 mm
PP_PaperSize_PEnv_3 | (97) PRC Envelope #3 125 x 176 mm
PP_PaperSize_PEnv_4 | (98) PRC Envelope #4 110 x 208 mm
PP_PaperSize_PEnv_5 | (99) PRC Envelope #5 110 x 220 mm
PP_PaperSize_PEnv_6 | (100) PRC Envelope #6 120 x 230 mm
PP_PaperSize_PEnv_7 | (101) PRC Envelope #7 160 x 230 mm
PP_PaperSize_PEnv_8 | (102) PRC Envelope #8 120 x 309 mm
PP_PaperSize_PEnv_9 | (103) PRC Envelope #9 229 x 324 mm
PP_PaperSize_PEnv_10 | (104) PRC Envelope #10 324 x 458 mm
PP_PaperSize_P16K_Rotated | (105) PRC 16K Rotated
PP_PaperSize_P32K_Rotated | (106) PRC 32K Rotated
PP_PaperSize_P32KBig_Rotated | (107) PRC 32K(Big) Rotated
PP_PaperSize_PEnv_1_Rotated | (108) PRC Envelope #1 Rotated 165 x 102 mm
PP_PaperSize_PEnv_2_Rotated | (109) PRC Envelope #2 Rotated 176 x 102 mm
PP_PaperSize_PEnv_3_Rotated | (110) PRC Envelope #3 Rotated 176 x 125 mm
PP_PaperSize_PEnv_4_Rotated | (111) PRC Envelope #4 Rotated 208 x 110 mm
PP_PaperSize_PEnv_5_Rotated | (112) PRC Envelope #5 Rotated 220 x 110 mm
PP_PaperSize_PEnv_6_Rotated | (113) PRC Envelope #6 Rotated 230 x 120 mm
PP_PaperSize_PEnv_7_Rotated | (114) PRC Envelope #7 Rotated 230 x 160 mm
PP_PaperSize_PEnv_8_Rotated | (115) PRC Envelope #8 Rotated 309 x 120 mm
PP_PaperSize_PEnv_9_Rotated | (116) PRC Envelope #9 Rotated 324 x 229 mm
PP_PaperSize_PEnv_10_Rotated | (117) PRC Envelope #10 Rotated 458 x 324 mm


PP_PreviewScale Enumeration

Description

Option values which define the possible sizes of the print preview image.

Members

Member | Description
PP_PreviewScale_1_1 | (1) 1:1 – The image size is the same size as the printed image.
PP_PreviewScale_1_2 | (2) 1:2 – The image size is one-half the same size as the printed image.
PP_PreviewScale_1_3 | (3) 1:3 – The image size is one-third the same size as the printed image.
PP_PreviewScale_1_4 | (4) 1:4 – The image size is one-fourth the same size as the printed image.
PP_PreviewScale_1_5 | (5) 1:5 – The image size is one-fifth the same size as the printed image.
PP_PreviewScale_1_6 | (6) 1:6 – The image size is one-sixth the same size as the printed image.
PP_PreviewScale_1_7 | (7) 1:7 – The image size is one-seventh the same size as the printed image.
PP_PreviewScale_1_8 | (8) 1:8 – The image size is one-eight the same size as the printed image.
PP_PreviewScale_1_9 | (9) 1:9 – The image size is one-ninth the same size as the printed image.
PP_PreviewScale_1_10 | (10) 1:10 – The image size is one-tenth the same size as the printed image.


PP_PrintQuality Enumeration

Description

Option values which define the possible values for printer resolution.

Members

Member | Description
PP_PrintQuality_2000 | 2000 DPI
PP_PrintQuality_1800 | 1800 DPI
PP_PrintQuality_1600 | 1600 DPI
PP_PrintQuality_1400 | 1400 DPI
PP_PrintQuality_1200 | 1200 DPI
PP_PrintQuality_1000 | 1000 DPI
PP_PrintQuality_900 | 900 DPI
PP_PrintQuality_800 | 800 DPI
PP_PrintQuality_700 | 700 DPI
PP_PrintQuality_600 | 600 DPI
PP_PrintQuality_500 | 500 DPI
PP_PrintQuality_450 | 450 DPI
PP_PrintQuality_400 | 400 DPI
PP_PrintQuality_375 | 375 DPI
PP_PrintQuality_350 | 350 DPI
PP_PrintQuality_325 | 325 DPI
PP_PrintQuality_300 | 300 DPI
PP_PrintQuality_275 | 275 DPI
PP_PrintQuality_250 | 250 DPI
PP_PrintQuality_225 | 225 DPI
PP_PrintQuality_200 | 200 DPI
PP_PrintQuality_175 | 175 DPI
PP_PrintQuality_150 | 150 DPI
PP_PrintQuality_125 | 125 DPI
PP_PrintQuality_100 | 100 DPI
PP_PrintQuality_75 | 75 DPI
PP_PrintQuality_72 | 72 DPI
PP_PrintQuality_Draft | (-1) Draft Quality Resolution
PP_PrintQuality_Low | (-2) Low Resolution
PP_PrintQuality_Medium | (-3) Medium Resolution
PP_PrintQuality_High | (-4) High Resolution


PP_PrintRange Enumeration

Description

Option values which determine the print range selected on the print dialog.

Members

Member | Description
PP_PrintRange_None | Enables none
PP_PrintRange_All | The user selected the All radio button.
PP_PrintRange_Pages | The user selected the Pages radio button.
PP_PrintRange_Selection | The user selected the Selection radio button.

Remarks

The All value is always enabled. Using All will only enable the All radio button.


PP_PrintRangeEnable Enumeration

Description

Option values which determine the available radio buttons to enable in the print dialog.

Members

Member | Description
PP_PrintRangeEnable_All | Enable the All radio selection
PP_PrintRangeEnable_AllPages | Enable the Pages radio selection
PP_PrintRangeEnable_AllSelection | Enable the Selection radio selection
PP_PrintRangeEnable_AllPagesSelection | Enable all pages radio selection

Remarks

The All value is always enabled. Using All will only enable the All radio button.


PP_RenderIntent Enumeration

Description

Option values which determine the color correction to use.

Members

Member | Description
PP_RenderIntent_None | Disables Image Color Management.
PP_RenderIntent_Images | Gamut of image fits (shrinks or expands) and fills the destination device gamut. Spatial distance of colors are relatively scaled for all color to fit within the gamut of the device. (Perceptual).
PP_RenderIntent_Business | Only colors outside of gamut moved to closest inside value. White Point is not preserved. (Relative Colormetric)
PP_RenderIntent_Graphics | Preserve color saturation at expense of hue and lightness. Colors are vibrant but not accurate. (Saturation)
PP_RenderIntent_AbsoluteColormetric | The white point is preserved. Spatial color distance to white point changes but not the white point itself. (Absolute Colormetric)


PP_SaveFileType Enumeration

Description

Option values which define the possible types of files generated.

Members

Member | Description
PP_SaveFileType_Default | (0) Default file and compression type.
PP_SaveFileType_Tif | (1) TIFF (Color)
PP_SaveFileType_TifG3 | (2) TIFF with CCITT G3 compression (Black & white compressed)
PP_SaveFileType_TifG32D | (3) TIFF with CCITT G3 2D compression (Black & white compressed)
PP_SaveFileType_TifG4 | (4) TIFF with CCITT G4 compression (Black & white compressed)
PP_SaveFileType_Bmp | (5) Bitmap (color)
PP_SaveFileType_Emf | (6) Enhanced MetaFile
PP_SaveFileType_PdfG4 | (7) PDF with CCITT G4 compression (black and white compressed)
PP_SaveFileType_PdfDefault | (8) PDF default.
PP_SaveFileType_PdfNoCompress | (9) PDF with no compression.
PP_SaveFileType_PdfG3 | (10) PDF with CCITT G3 compression (black and white compressed).
PP_SaveFileType_PdfG32D | (11) PDF with CCITT G3 2D compression (black and white compressed).
PP_SaveFileType_PdfJbig2 | (12) PDF with JBig2 compression.
PP_SaveFileType_PdfSeqJpeg | (13) PDF with sequential JPEG compression.
PP_SaveFileType_TifSeqJpeg | (14) TIFF with sequential JPEG compression.

Remarks

© 1997-2008 Pegasus Imaging Corporation, All Rights Reserved.


PP_ScaleMode Enumeration

Description

Option values which define the possible units of measurement for coordinates of an object when printing or using graphics methods.

Members

Member | Description
PP_ScaleMode_Twip | (1) Twip (1440 twips per logical inch; 567 twips per logical centimeter)
PP_ScaleMode_Point | (2) Point (72 points per logical inch)
PP_ScaleMode_Pixel | (3) Pixel (smallest unit of printer resolution).
PP_ScaleMode_Character | (4) Character (horizontal = 120 twips per unit; vertical = 240 twips per unit).
PP_ScaleMode_Inch | (5) Inch
PP_ScaleMode_Millimeter | (6) Millimeter
PP_ScaleMode_Centimeter | (7) Centimeter


PP_SourceBin Enumeration

Description

Option values which define the possible default paper bins that can be set.

Members

Member | Description
PP_SourceBin_Upper | (1) Use paper from the upper bin.
PP_SourceBin_Lower | (2) Use paper from the lower bin.
PP_SourceBin_Middle | (3) Use paper from the middle bin.
PP_SourceBin_Manual | (4) Wait for manual insertion of each sheet of paper.
PP_SourceBin_Envelope | (5) Use envelopes from the envelope feeder.
PP_SourceBin_ManualEnvelope | (6) Use envelopes from the envelope feeder, but wait for manual insertion.
PP_SourceBin_Auto | (7) Use paper from the current default bin.
PP_SourceBin_Tractor | (8) Use paper fed from the tractor feeder
PP_SourceBin_SmallBin | (9) Use paper from the small paper feeder.
PP_SourceBin_LargeBin | (10) Use paper from the large paper bin.
PP_SourceBin_LargeCapacity | (11) Use paper from the large capacity feeder.
PP_SourceBin_Cassette | (14) Use paper from the attached cassette cartridge.
PP_SourceBin_FormSource | (15) Use form source.


PP_TrueTypeOption Enumeration

Description

Option values which define the possible options for printing TrueType fonts.

Members

Member | Description
PP_TrueTypeOption_PrintAsGraphics | (1) Substitute device fonts for TrueType fonts. This is the default for Postscript printers.
PP_TrueTypeOption_DownloadFonts | (2) Download TrueType fonts as soft fonts. This is the default for HP printers that use PCL.
PP_TrueTypeOption_UseDeviceFonts | (3) Print TrueType fonts as graphics. This should be used for dot matrix printers.
PP_TrueTypeOption_DownloadOutline | (4) Downloads TrueType fonts as outline soft fonts.


Glossary

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z


Documentation Overview

Description

Pegasus Imaging PrintPro Control v4.0

Projects

Project | Description
PegasusImagingActiveXPrintPro4 | Pegasus Imaging PrintPro Control v4.0


Project Overview

Description

Pegasus Imaging PrintPro Control v4.0

Classes

Class Module | Description
PrintPro | Pegasus Imaging PrintPro Control v4.0

Public Enumerations

Enumeration | Description
PP_Alignment | Option values which define the possible text alignment styles.
PP_BackStyle | Option values which define the possible background styles of printed text.
PP_ColorMode | Option values which define two values: one for printing in color and one for printing in monochrome.
PP_DebugErrorLevel | Option values which determine the amount of logging to write to the debug log file.
PP_DitherType | Option values which define the possible types of dithering that can be done.
PP_DrawMode | Option values which define the possible values to determine appearance of output from graphics methods.
PP_DrawStyle | Option values which define the possible line styles for output from graphics methods.
PP_Duplex | Option values which define the possible duplexing options.
PP_EvaluationMode | Option values which defines the possible behaviors of the control when in evaluation (non-licensed) mode.
PP_FillStyle | Option values which define the possible patterns used to fill circles, boxes, round rectangles, pie-shapes and polygons created with graphics methods.
PP_IcmIntent | Option values which define the possible color management methods, or intents, to use by default.
PP_IcmMethod | Option values which define the possibilities for how Image Color Management (ICM) is handled.
PP_MediaType | Option values which define the possible media to print on.
PP_Orientation | Option values which define the set of possible orientations for the document.
PP_PaperSize | Option values which define possible paper sizes for printing.
PP_PreviewScale | Option values which define the possible sizes of the print preview image.
PP_PrintQuality | Option values which define the possible values for printer resolution.
PP_PrintRange | Option values which determine the print range selected on the print dialog.
PP_PrintRangeEnable | Option values which determine the available radio buttons to enable in the print dialog.
PP_RenderIntent | Option values which determine the color correction to use.
PP_SaveFileType | Option values which define the possible types of files generated.
PP_ScaleMode | Option values which define the possible units of measurement for coordinates of an object when printing or using graphics methods.
PP_SourceBin | Option values which define the possible default paper bins that can be set.
PP_TrueTypeOption | Option values which define the possible options for printing TrueType fonts.


Enumerations Members

Enumerations Object

For a list of all members defined in this module, see Enumerations members.

Object Model

See Also

Enumerations Members


Enumerations Overview

Enumerations Object Members

See Also

Enumerations Overview


Select a Printer

PrintPro enables you to identify connected printers, select a printer, and retrieve information about the selected printer.

Get information on printers connected to your system:

PrintPRO maintains an array (or collection) of all of the printers connected to your system. The NumPrinters Property returns the number of printers connected to your system.

Select a printer:

The current printer used by PrintPro is set to the system default printer unless you set the UseDefaultPrinter Property to False. Use the SelectPrinter Method to set the current printer to any printer connected to your system. Use the SelectDefaultPrinter Method to set the current printer back to the system default printer. Use the SetDefaultPrinterA Method method to set the default printer to the current printer.

HINT: To ensure that the Page Property is reset after printing an image, it is critical that the SelectDefaultPrinter Method or SetDefaultPrinterA Method is used before calling the StartPrintDoc Method.

If you want to enable the user to pick a printer from a dialog box, use the PrintDialog Method to display the dialog box.

Get information about the current printer:

The PrinterNum Property returns the index value of the current printer in the printer array. You can get the currently selected printer's name, printer driver name and printer port name using the PrinterName Property, PrinterDriverName Property, and PrinterPortName Property respectively. Use the hDC Property to get the device context of the current printer.

** May need some explanation of printenabled and what that prevents you from doing.


Set Image Color Management (ICM) Method and Intent

© 1997-2008 Pegasus Imaging Corporation, All Rights Reserved.