What is PrintPRO?

PrintPRO™ version 4 is a windowless control that enables the user to access and modify printer properties, create a print job, preview printing, and print to a device or file. PrintPRO offers the flexibility to create a custom printing UI, and may be used to interact with the printer, by-passing the print driver.

New Features in PrintPRO version 4

  • New object-oriented .NET interface
  • Access to device's capability settings and configuration dialog
  • Ability to maintain scanner settings for each session
  • JPG, JBIG2, TIFF-G4 compression types added to PDF save
  • TIFF write optimization (faster to write large multi-page TIFFs)
  • TW_STR32 type support

Primary Features Include:

  • Bypass Internet Explorer's printing functions and add your own rich, custom interface
  • Select a Printer
  • Set Printer Properties
  • Set Print Margins and Coordinates
  • Image Color Management for Printers and Monitors
  • Change text font, alignment, rotation, background transparency and more in printed image
  • Add graphics to printed image
  • Print collages
  • Print Preview
  • Print to Device
  • Print to File, including: TIFF, TIFF (JPEG compressed), and PDF (compressed to G3, JBig2, JPEG)
  • Send Raw Data to the Printer, by-passing the Print Driver
  • Supports single and multi-page documents

Note: Purchase the Photo Edition license of ImagXpress to access the Image Color Management features of PrintPRO.

ImagXpress v9 Product Family includes the following Components:

  • ImagXpress® v9 - image compression, decompression, viewing, and processing
  • NotatateXpress™ v9 - image annotation support
  • ThumbnailXpress™ v2 - thumbnail image support
  • TwainPRO™ v5 - TWAIN image acquisition support
  • PrintPRO™ v4 - image printing support

Additional Pegasus Imaging Components: Additional components are available for purchase separately, and integrate easily with to provide a comprehensive imaging solution:

  • PDFXpress™ – PDF creation, viewing, and annotating
  • OCRXpress™ – full page OCR
  • Barcode Xpress™ – recognize barcodes
  • ScanFix Xpress™ – advanced image cleanup
  • FormFix™ – form ID, dropout, and OMR
  • SmartZone™ ICR / OCR – character recognition
See Also

Getting Support | Pegasus Imaging Corporation

© 1997 -2008, Pegaus Imaging Corporation, All Rights Reserved.


Getting Support

Benefits of Registering your Pegasus Development Kit

Purchasers of development kits need to register with Pegasus in order to be notified of updates and receive support now or in the future. Registration is automatic when purchased directly from the Pegasus web site. If purchased through a Pegasus re-seller, please register your purchase by filling out the form at PegasusImaging.com/registration.htm.

Vehicles for Support

Samples

Samples are included in the downloaded installation.

The product installation program installs a common sample folder accessible via the Start Menu.

Samples for the .NET framework:

  • Microsoft VisualBasic.Net
  • Microsoft C#

Access the samples

  • Through the Windows Start menu: Start | Programs | Pegasus Imaging | PrintPRO | Samples
  • Sample image files included

Sample Code Newsgroups

Customers create samples of great benefit to other developers, so we created a Sample Code Newsgroup. This is a newsgroup for our customers and potential customers. They post and receive sample code from our development team and other developers to expedite their development. Go online at:

http://www.PegasusImaging.com/samplecode.htm

Web Support

Visit the Pegasus Imaging web site frequently asked questions page ( PegasusImaging.com/faq.htm ) for the fastest answers to common questions. The web site also provides other support options that are accessible at PegasusImaging.com/supportagree.htm.

E-mail Support

Both pre-sale and post-sale e-mail support is offered free of charge. Questions are answered on a First-Come-First-Served basis. Support@JPG.com responds instantly to e-mail received with a helpful set of locations to find additional information on Pegasus products including FAQ's, sample code, newsgroup locations and other current information pertaining to the use of the products. The support request is then added to the queue of outstanding requests. The goal of the support team is to respond to each e-mail within 1 business day.

The sales team is always available as a backup to the support team. If you feel you have an urgent support or sales issue please contact Sales@JPG.com . They will assist you promptly.

Newsgroup Support

The Publicly accessible NNTP news groups located at News.PegasusImaging.com are available for each of the Controls as well as advanced imaging technology and a sample code group. We expect that the development community will freely access and search these newsgroups to find common questions and answers regarding specific uses of the controls.

On-Demand Phone Support

On-demand priority phone support can be purchased in 15 minute increments with a credit card via the Pegasus Imaging Corporation web site Support, General Info page. If you decide to purchase "on-demand" phone support, instructions will immediately be e-mailed upon receipt of your purchase.

Note: Additionally, Pegasus offers three support plans for those customers whose commercial products or projects are sensitive or critical in nature, where immediate response and 'latest release' code are important.

1. Chariot Support

All Pegasus Imaging customers are given the opportunity to purchase a Chariot Support agreement. This is a maintenance and upgrade agreement that entitles customers to priority e-mail service, direct phone support from the support and development staff and free product upgrades for the covered products. Since upgrades are included for Chariot customers at no additional charge, Chariot customers can frequently save money, plus obtain the benefits of phone and expedited support. Pegasus Imaging reserves the right to change the terms of this service at any renewal period. Contact Sales via the web at www.PegasusImaging.com/contactform.htm for more information.

2. Galleon Support

Customers are given the opportunity to purchase Galleon Support for Pegasus Imaging products that are applications and for products that require runtime licensing. Galleon Support includes licensing of product upgrades for deployed installations at no additional license fee cost. Pegasus Imaging reserves the right to change the terms of this service at any renewal period. Contact Sales via the web at www.PegasusImaging.com/contactform.htm for more information.

3. Atlas Support

All Pegasus Imaging customers are given the opportunity to purchase an Atlas Support agreement on currently supported products. This is an agreement that entitles customers to priority e-mail service and direct phone support from the support and development staff. It differs from Chariot Support in that it does not include version upgrades free of charge. Pegasus Imaging reserves the right to change the terms of this service at any renewal period. Contact Sales via the web at www.PegasusImaging.com/contactform.htm for more information.

To determine if you have the latest version of a Pegasus Imaging development toolkit, please download the PegConnect utility program. Please note that a Help File for each product may be found on the Start bar under Pegasus or in C:\Windows\Help.

For the latest and most up-to-date support information, access PegasusImaging.com/contact.htm


Pegasus Imaging Corporation

Pegasus Imaging is uniquely positioned to serve as your leading imaging technology supplier. A full suite of document imaging toolkits, forms processing technology, medical image compression SDKs, photo editing and compression libraries, browser-based image viewers, and video codecs provide advanced technology designed to enhance imaging software solutions. Fully functional trial downloads and customer-acclaimed support allow you to be certain your requirements will be met before purchase. Work with the best. Choose Pegasus Imaging for all your imaging needs.

Visit www.PegasusImaging.com for full product descriptions, FAQ's, downloads, demos, and contact information.

Pegasus Imaging

4001 North Riverside Drive

Tampa, FL 33603

Sales: 813-875-7575

Copyrights & Trademarks

Pegasus and the Pegasus Horse Logo are registered marks (®) of Pegasus Imaging Corporation.

Barcode Xpress, CapturePRO, FilePrinter, FormAssist, FormDirector, FormSuite, ISIS Xpress, The JPEG Wizard, MedXpress, NotateXpress, PDF Xpress, PICTools, ePIC, PICVideo, PrintPRO, SmartScan Xpress, SmartZone, ThumbnailXpress, and TwainPRO are trademarks (™) of Pegasus Imaging Corporation.

ImagXpress, FormFix, ScanFix, Prizm, ColorDrop, ColorEnhance, ColorFind, ColorForms, CompressDirector, Digital Mark Recognition (DMR), Image Detergent, ViewDirector and Virtual Scoring Center (VSC) by assignment are trademarks (™) or registered trademarks (®) of Pegasus Imaging Corporation.

Pegasus Imaging and/or its agents use these marks and brand names in connection with its goods and/or services, in the United States and other countries. Information in this document is subject to change without notice. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Pegasus Imaging Corporation.

Microsoft, Microsoft.NET, Visual Basic, Visual Studio and Visual Studio.NET are trademarks of Microsoft Corporation in the USA and/or other countries. All other product and brand names are the property of their respective owners.


Operating Requirements

PrintPRO Operating Requirements

Operating Systems

PrintPRO runs on 32-bit Microsoft Windows operating systems: 2000 Professional and Server, XP Home and Professional, Server 2003 and Server 2008. It works with 32-bit Windows versions running on 32 and 64-bit processors. It runs in 32-bit executables running under 64-bit Windows 2000 Server, 2003 Server and Server 2008. Although it may run, it is not supported on previous Windows versions (for example, Windows 95 and Windows 98).

Threading

Pegasus considers thread-safe to be when an application using this component can use multiple controls running in the same process, where they don't interfere with each other. The thread creating the control owns the control and is the only thread that can interact with it.

Development environment

Microsoft .NET Framework 2.0, 3.0

Microsoft Visual Studio 2005

Microsoft Visual Studio 2008

See Also

Installing on a Development Machine | Trial Mode


Installing on a Development Machine

To Install PrintPRO™

Run the downloaded setup program which installs the development kit on your development machine.

The downloaded development kit includes code samples for supported platforms. Samples are available through the Start | Programs | Pegasus Imaging | PrintPRO v4.0 menu.

By default this will register trial licensing which allows you to develop applications but not to distribute them. The trial license allows testing of all the functions and features.

Please see the topic Distributing with Your .NET Application to understand the limits and details to converting licensing editions.
In order to distribute your finished application you must purchase and install a fully paid license from Pegasus Imaging Corporation. The paid licenses override trial licenses.

To Use PrintPRO Help Files

Stand-alone Help file "PegasusImaging.WinForms.PrintPRO4.chm"

Access the PrintPRO stand-alone help through the Windows Start menu: Start | Programs | Pegasus Imaging | PrintPRO v4.0

The stand-alone compiled Help .chm file is created with MS Help system version 1. To view Help 1 files, you must have:

  • Windows 2000 or higher (to view the file via the Windows HTML Help Viewer)
  • Internet Explorer 6.x or 7.0
  • MS HTML Help Viewer

From within your Visual Studio Development Environment, Compiled Collection Help File "PegasusImaging.WinForms.PrintPRO5.hxs"

Help 2 collection files install into Visual Studio.NET (VS). To view Help 2 files, you must have:

  • Windows 2000 or higher
  • Internet Explorer 6 or higher
  • Visual Studio .NET 2002 or higher
  • MS Help version 2

When PrintPRO installs, if the system installation requirements for Help 2 files are met, the Help 2 file is included on the Start shortcut menu. If the installation requirements for Help 2 files are not met, then the Help 1 file installs on the Start shortcut.

Plugging PrintPRO Help into Visual Studio

PrintPRO Help 2 files integrate within the Help system in Visual Studio .NET. To access PrintPRO Help within Visual Studio, do the following:

  • Ensure that the MSDN Library is installed in your Visual Studio environment. If it is not installed, re-install it from your VS.NET disc.
  • Ensure that MS Help Integration Kit is installed in your Visual Studio environment. If you do not have it installed:

1. Download the Help Integration kit from MSDN

2. Close Visual Studio.

  • Re-open Visual Studio, select the Help Menu and the Contents submenu. Verify Help files for Pegasus Imaging controls are listed.

If Pegasus Help is not listed:

  1. Search for "VSCC" in Visual Studio Help, leaving the "Filtered by:" list box blank. Select the "Visual Studio .NET Combined Help Collection Manager" topic.
  2. Select the Help 2 collections available on your PC under the heading "Collections available for inclusion in VSCC."
  3. Take care when excluding Help collections from the default VSCC collection. These collections may be necessary to view required documentation. Instead, use the "Filtered by:" field on the Contents tab of the Help panel to focus searches on Pegasus Imaging topics. Leave the "Filtered by:" list box empty to view the entire Pegasus Imaging Help files.
  4. Select the Update VSCC button.
  5. Close all instances of Visual Studio and Microsoft Document Explorer. When you restart Visual Studio, the VSCC Help collection revises with your changes. (Note: this may take several minutes.)
  6. Check the Visual Studio Help/Contents tab again to see the Help collections available to you.
  • Select the PrintPRO Help file to view Help content.
See Also

Operating Requirements | Trial Mode | Getting Support | Distributing with your Application


Trial Mode

Default Installation

The default installation installs Trial Mode licensing. This allows you to test features and functions and develop applications but not distribute them. Installing PrintPRO™ in trial mode provides you with access to all features and functionality of the PrintPRO product. Email support is available with the trial license.

When using the trial version of PrintPRO, an evaluation dialog box displays periodically. In addition, while using the trial version, PrintPRO will randomly replace portions of text in the output with www.PegasusImaing.com. Applications built with a trial license can only be run on a computer that has PrintPRO Licensing installed on it.

Changing Trial Mode Behavior

You have the flexibility to change the behavior of PrintPRO in evaluation mode as follows:

  • To facilitate server/service mode evaluations, developers may choose to halt the component processing after 5 minutes in lieu of displaying an evaluation dialog box periodically. This is the TimeOut setting for the PrintPRO EvaluationMode property.

Changing Edition

To access ICM, ImageXpress must be set to DocumentEdition.

See Also

Development Mode | Runtime Licensing | Getting Support | License Agreement


Development Mode

To suppress the evaluation dialog box and deploy your application, or attain technical support (beyond e-mail), as well as future product updates and upgrade notifications, you must update from a trial version to a paid version of the PrintPRO™ development kit.

1. Purchase Development Kit(s)

To purchase licensing of the PrintPRO development kit, use one of the following options:

  • Purchase online at http://www.PegasusImaging.com/. Contact Sales via the web at www.PegasusImaging.com/contactform.htm.
  • Contact a Pegasus Imaging Corporation reseller.

When the development kit is purchased, we e-mail a serial number & registration code to you. You need these codes to upgrade from trial to paid licensing.

2. Register the PrintPRO Product

When you purchase PrintPRO online or via Sales at www.PegasusImaging.com/contactform.htm, your product ownership is automatically registered.

To register products purchased through a reseller, use the form found at http://www.PegasusImaging.com/registration.htm.

If your registration information should change, visit http://www.PegasusImaging.com/contactsupport.htm for forms to update registration information.

3. Update Your PrintPRO product version from trial to paid licensing

Updating your PrintPRO from trial to paid licensing will suppress the evaluation dialog box or timeout. This must be done for each component within the ImagXpress toolkit that you are using (for example, PrintPRO and ImagXpress). The email you receive when you purchase the product will include entries for each component.

To update components from trial to paid licensing

  • Enter your new license codes using one of the following options:
    • Enter licensing information (serial number, registration code and personal registration information) during component installation while downloading the latest release from www.PegasusImaging.com (the recommended approach).
    • Alternatively, licensing information (serial number, registration code and personal registration information) can be entered through the Visual Development Environment in response to the dialog display.
  • Rebuild any applications that used the components with trial licensing

For more information on Runtime licensing, see the Pegasus Imaging website for more detailed information regarding Runtime Licensing.

To distribute PrintPRO in an application, you must acquire runtime unlock codes. See Runtime Licensing for more information.

See Also

Runtime Licensing | Getting Support | License Agreement


Runtime Licensing

Runtime & Deployment Licensing

All copyrights to Pegasus Imaging development kits and software are retained by Pegasus Imaging Corporation. ALL RIGHTS RESERVED. Your use of any of Pegasus Imaging software or run-times created with Pegasus Imaging software is allowed under license terms granted by Pegasus Imaging. It is the Licensee's responsibility to honor the terms of such license grants.

Locking Mechanism

PrintPRO™ contains a locking mechanism that does not permit you to distribute applications created with evaluation versions of PrintPRO. Prior to distributing an application that utilizes PrintPRO, you must purchase and enable run-time licensing. If the application will be delivered on the web, you must also purchase and enable web application licensing.

Obtaining Appropriate Licensing

The Licensee is required to purchase one copy of our development kit(s) for each developer in addition to obtaining the appropriate license agreement prior to deploying applications which contain Pegasus code.

Pegasus Imaging software applications and development tools are limited for use on a single CPU. Any runtimes or copies created must be granted by a direct license from Pegasus Imaging Corporation. These "end user" licenses provide the terms and limits of number and usage.

All prospective customers have every opportunity to evaluate Pegasus Imaging's products prior to purchasing. Product licensing is priced to cover what is considered to be normal (and even high) use. In addition, Pegasus Imaging fully supports and warrants its code and pricing reflects those costs as well. The larger and more valuable an application deployment is, the higher the support and warranty risk is for Pegasus.

Review the licensing categories, and select the one that matches your deployment. Special circumstances should be discussed with a Pegasus Imaging representative.

See the Pegasus Imaging website for more detailed information regarding Runtimes and Deployment Licensing.

See Also

Getting Support


License Agreement

Pegasus Imaging Corporation

SOFTWARE LICENSE AGREEMENT

GRANT OF LICENSE

This Pegasus Imaging Corporation ("PEGASUS") Agreement ("License") permits Licensee ("LICENSEE") the right to use one copy of a properly registered Pegasus Development Toolkit ("TOOLKIT") for development purposes on any single computer, provided the TOOLKIT is in use on only one computer at any time. TOOLKIT is "in-use" on a computer when it loads into temporary memory (that is, RAM) or installed into the permanent memory (that is, hard disk, CD-ROM, or other storage device) of that computer.

REDISTRIBUTION OF THE TOOLKIT RUNTIMES

PEGASUS does NOT grant any runtime licenses with the TOOLKIT purchase, except by specific exemptions described on our licensing web pages. For Runtime Licensing information, please visit our web site (http://www.PegasusImaging.com/licensing.htm), or contact our sales staff. Any rights to distribute TOOLKIT run times as part of the LICENSEE's software application or derivative works ("PRODUCT"), require you to acknowledge and uphold this License Agreement and agree to notify PEGASUS immediately of any changes in status or violations. In cases where PEGASUS grants the LICENSEE a right to use, reproduce, display or otherwise distribute or transfer copies of TOOLKIT run times, LICENSEE agrees and affirms the following:

a) LICENSEE is not using PEGASUS' name, logo, or trademarks to market PRODUCT without prior written approval of PEGASUS.

b) LICENSEE agrees to indemnify, hold harmless and defend PEGASUS from and against any claims or lawsuits, including attorney's fees, that arise or result from the use or distribution of PRODUCT.

c) Only the TOOLKIT run times can be distributed. Distribution of the TOOLKIT development kit, documentation, source code, or the distribution unlock codes, is a violation of this agreement.

d) LICENSEE includes a statement substantially similar to the following within derivative work's documentation and about box: "This product contains portions of imaging code owned by Pegasus Imaging Corporation, Tampa, FL, (www.PegasusImaging.com). ALL RIGHTS RESERVED."

If ANY of the above terms are not applicable to LICENSEE'S situation, or any of the above cannot be complied with, or LICENSEE needs modifications to this license, for any reason; then LICENSEE shall obtain an expanded direct license from PEGASUS for derivative works, (available by phone at: 813-875-7575, x321, by e-mail at: Sales@jpg.com or by fax at: 813-875-7705).

PEGASUS reserves the right to charge the LICENSEE up to ten times the normal license price for the use of each unlicensed copy of PRODUCT. The license granted herein and all of your rights to use or maintain possession of TOOLKIT shall terminate immediately upon breach of any material provisions of this Agreement.

This license grants rights to LICENSEE for only the PEGASUS code (TOOLKIT) mentioned above and does not convey any other rights of use or distribution to PEGASUS technology.

COPYRIGHT

The Software is owned by PEGASUS or Pegasus Imaging Corporation and is protected by United States copyright laws and international treaty provisions. LICENSEE may not remove or alter the copyright notice from any copy of the Software or any copy of the written materials, accompanying the Software.

OTHER RESTRICTIONS

This PEGASUS License Agreement is LICENSEE's proof of license to exercise the rights granted herein and must be retained by LICENSEE. LICENSEE may not rent, lease or transfer TOOLKIT or parts thereof. LICENSEE may not reverse engineer, decompile or disassemble TOOLKIT.

NO WARRANTY

ANY USE BY LICENSEE OF THE SOFTWARE IS AT THE LICENSEE'S OWN RISK. THE SOFTWARE IS PROVIDED FOR USE ONLY WITH WINDOWS PRODUCTS AND RELATED APPLICATION SOFTWARE AND/OR HARDWARE PRODUCTS. THE SOFTWARE IS PROVIDED FOR USE "AS IS" WITHOUT WARRANTY OF ANY KIND. TO THE MAXIMUM EXTENT PERMITTED BY LAW, PEGASUS DISCLAIMS ALL WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. PEGASUS IS NOT OBVLIGATED TO PROVIDE ANY UPDATES TO THE SOFTWARE.

NO LIABILITY FOR CONSEQUENTIAL DAMAGES

In no event shall PEGASUS be liable for any damages whatsoever (including, without limitation, incidental, direct, indirect and consequential damages, damages for loss of business profits, business interruption, loss of business information, or other pecuniary loss) arising out of the use or inability to use this PEGASUS product, even if PEGASUS has been advised of the possibility of such damages. Because some states/countries do not allow the exclusion or limitation of liability for consequential or incidental damages, the above limitation may not apply to LICENSEE.

INDEMNIFICATION BY LICENSEE

If LICENSEE distributes TOOLKIT in violation of this Agreement, LICENSEE agrees to indemnify, hold harmless and defend PEGASUS and its suppliers from and against any claims or lawsuits, including attorney's fees that arise or result from the use or distribution of TOOLKIT in violation of this Agreement.

This Agreement is governed by the laws of the State of Florida. The program and data contained in this TOOLKIT Product are provided with Restricted Rights. Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set forth in FAR 52.227-14 (Alternate III) or subparagraph (c)(1)(II) of the rights in technical data and computer software clause at 252.227-7013. Manufacturer is Pegasus Imaging Corporation, 4001 Riverside Drive, Tampa, FL, 33603.

For questions concerning this Agreement, or to contact PEGASUS for any reason, please contact Pegasus Imaging Corporation by phone at 1-813-875-7575 x321 or email Sales@JPG.com.


Verify You're Using the Latest Service Pack

Service pack updates will not overwrite paid licensing. Your paid licensing will continue to work and you will not be required to re-enter your purchased registration codes. Service pack updates do not include any changes that might "break" previously developed and/or deployed code.

Verify Latest Development Components

To verify you are using the latest version of a Pegasus Imaging Development Component or Components, please use the PegConnect utility program. Please note that a Help File for each product may be found on the Start Bar under Pegasus, or in C:\Windows\Help.

PegConnect is installed by all component product installers and is accessible through the Windows Start menu:

Start | Programs | Pegasus Imaging | Pegasus Imaging | Common | Utilities

PegConnect allows you to:

1) Check with Pegasus Imaging via online connection and verify that the installed version of the component includes all the most recent updates

2) Update to the latest version automatically with your permission

3) Determine if a control is registered or unregistered on the machine

4) Easily change the registration status from registered to non-registered, or non-registered to registered

Alternatively, you can see the currently released product build numbers at http://www.PegasusImaging.com/latestbuilds.htm.

If you require further assistance or have questions or comments, please see the section Getting Support for more detailed information.

See Also

Operating Requirements | Getting Support


Distributing with your Application

Distributing PrintPRO™

Check for Proper Licensing and Unlock Codes

PrintPRO contains a locking mechanism that does not permit you to distribute applications created with evaluation versions of PrintPRO. Prior to distributing an application that utilizes PrintPRO, you must purchase and enable runtime licensing. If the application will be delivered on the web, you must also enable web application licensing.

DLL Files to Distribute

Distribute the appropriate assembly DLL files with applications using the PrintPRO component.

  • PegasusImaging.WinForms.PrintPRO4.dll - .NET component - .NET Control for accessing and modifying printer properties, create a print jobs, preview printing, and print to a device or file.

See Also

Runtime Licensing | Getting Support | Development Mode


Definitions, Acronyms, and Abbreviations

Pegasus Imaging Definitions, Acronyms, and Abbreviations

PIC: Pegasus Imaging Corporation

Thread-safe: An application using this component can use multiple controls running in the same process, where they don't interfere with each other. The thread creating the control owns the control and is the only thread that can interact with it.


PrintPRO Overview

PrintPRO™ enables you to create a document composed of images, text, and graphics, and print the document to a selected printer or print to file.

The process for composing and printing documents is as follows:

  1. Select a printer. PrintPRO automatically selects the system default printer but you can select any printer connected to your system. If you want to use the default printer, you can skip to step 2.

  2. Set the printer properties. Printer properties include the paper size, print quality, orientation, etc. If you want to use the printers default properties, you can skip to step 3.

  3. Set the Image Color Management (ICM) Method and Intent as needed.

  4. Use the DocName Property to set the document name. When the system spools your document for printing, the document name appears in the list of documents to be printed. The default document name is PrintPRO Document. If you want to use the default document name, skip to step 5.

  5. Start a document. You can use the StartPrintDoc method to start a document, however, PrintPRO's text, graphics and bitmap methods will automatically start a document if one has not been started.

  6. Place text, graphics and bitmaps on the document page. The NewPage Method lets you start a new page and the Page Property returns the current page number.

  7. Create, then print and/or display print preview page(s) if desired.

  8. Print the document. Use the EndPrintDoc Method to send the document to the print spooler. If the PrintToFile Property is True, the print output is redirected to a disk file. If you want to stop printing the current document, use the KillPrintDoc Method before you start a new document.

See Also

Create Print Job


Introduction to Image Color Management

The Problem

You scan a photo in order to edit it but the image on the screen doesn't look like the original. And when you print it out the colors are even less like the original! What you see is not what you get.

Information

The problem is that the different devices (scanner, monitor and printer) have different interpretations of the digital values for colors. Not only are the interpretations different from device to device but so is the “gamut”, the range of realizable colors (some devices can display/output/print colors that others can not).

Solution

Windows’ Image Color Management (ICM) system is the what-you-see-is-what-you-get solution to the color accuracy problem. PrintPRO™ allows the application programmer to enable and access ICM features.

ICM processes all images via a standardized intermediate color scheme: the Profile Connection Space (PCS). In the above example the image from the scanner would be adjusted for that particular scanner’s profile (data file) to get it into the standard color space. It would then be adjusted for that particular monitor’s profile to display or that particular printer’s profile to be printed. Each device gets its own profile and the devices must be properly calibrated to get good results.

Image Color Management is an involved subject. More information can be found at the International Color Consortium’s web site (www.color.org).

With PrintPRO there are two levels of Image Color Management: enabling the various device drivers or with Windows' ICM as specified by ICM Method.

Note: Color Management is designed to work with 24-bit color or 8-bit grayscale images. Color correction performed on images with less bit depth than this will result in poor quality images. PrintPRO has no native ability to promote images to higher bit depth; it is recommended that you use ImagXpress to do so.

See Also

Icm Class


State Diagram

PrintPRO™ enables the application to select a printer, perform printer set up, create a print job, preview the print job, and send the print job to the printing device. These tasks can be illustrated with a state diagram:

No Session in Progress

The application is free to initiate printer selection, printer set up, print job creation, or raw data transfer.

Printer Selection

Once PrintPRO has been created, the application may choose to select a printer. If no printer is selected, the default printer will be used. While a print job is in progress, the printer selection cannot be modified.

Printer SetUp

The application may chose to set up the printer, using either PrintPRO or the printer dialog. If no printer setup is conducted, the printer's default settings will be in effect. While a print job is in progress, the printer settings cannot be modified.

Send Raw Data

To bypass the print driver, the application can send raw data directly to the printer. Since the printer driver is by-passed, the data sent must be printer specific. The raw data may contain printer commands, codes and binary data. Large amounts of data may be sent to the printer using this technique.

Print Job Creation

The application calls PrintPRO methods to construct the document to be printed. Images, text, and drawings can be added to the print job.

Print Preview

At any point during job creation, the application can invoke a print preview to enable the user to view or print the page under construction.

Print Job Has Been Sent

Once the document or raw data to be sent has been finalized, the application calls EndPrintDoc or PrintRawDataEnd to send the print job to the printer spooler. PrintPRO is now done processing the job, and returns to a "No Session in Progress" state.


Set Printer Properties

PrintPRO maintains a collection of Printers. PrintPRO enables the user to change these printers' properties, either programmatically or through the printer dialog. (If the printer properties are not modified, the printer's default settings will be in effect.)

Note: While a print job is in progress, the printer settings cannot be modified.

Set Up Printer Properties Using a Dialog:

To enable an application end-user to change printer properties, call the Printer.SetupDialog method. A dialog is displayed enabling the user to change the printer's properties.

Set Up Printer Properties Programmatically:

Access the properties within the Printer class to programmatically set the printer properties. If the printer does not support the feature (e.g. Duplex), then the property setting will be ignored.

See Also

Printer Class | PrinterCollection Class | SetupDialog Method


Set Margins

PrintPRO has top, left and bottom margins that can be set using the TopMargin Property, LeftMargin Property, and BottomMargin Property respectively. Margins are used set the distance between the physical page and the printable area in units of the Printer's PrintUnits.

When the LeftMargin Property is set, the CurrentX Property is automatically set to the same value. When the TopMargin Property is set, the CurrentY Property is automatically set to the same value.

The AutoMargin Property can be used to automatically set the margins to the top, left and bottom of the printers display area.

See Also

AutoMargin Property | BottomMargin Property | TopMargin Property | LeftMargin Property | CurrentX Property | CurrentY Property


Use Printer Coordinates

Physical Area

The printer coordinate system is based on the physical dimensions of the paper in the printer. The horizontal and vertical starting position (0,0) is located at the upper left corner of the paper. Printer units are defined by the PrintUnits Property. The default PrintUnits is twips. There are 1440 twips per inch.

For example, if the printer has 8½ x 11in. paper and the orientation of the paper is portrait, the width of the printer is 12240 twips and the height is 15840 twips. You can get the physical height and width of the printer using the PaperHeight Property and PaperWidth Property.

Display Area

A printer also has a display area. The display area is located inside the physical area. The PrintPreviewScale Property can be used to get width and height of the display area. The DisplayX Property and DisplayY Property can be used to get the coordinates of the upper left corner of the display area.

Printer Resolution

The resolution of a printer is measured in dots per inch. You can get the horizontal and vertical resolution of a printer using the PrintResolution Property.

There are times when you might need to know the number of twips per printer dot (or pixel). The TwipsPerPixelX Property and TwipsPerPixelY Property can be used to get the printers horizontal or vertical twips per pixel.

Internal Coordinates

The PrintPRO control maintains internal coordinates that are used and updated by some of the text, graphics and bitmap methods. The CurrentX Property and CurrentY Property can be used to get or set the internal horizontal and vertical coordinates.

For example, if the CurrentX and CurrentY properties are set to 1440 twips, the following code will print Hello World one inch from the top and left side of the paper since the PrintText method uses the CurrentX and CurrentY values to position the text.

printJob.Draw.CurrentX = 1440;

printJob.Draw.CurrentY = 1440;

printJob.Draw.Text("Hello World");


Change Font

PrintPRO has a font object that makes it easy to change the font of printed text. In some containers, the font object is not readily available. In this case, use the following methods to change the font characteristics:

  • Set the text and font by using the Text method parameters and passing in the string and font type.
  • Get the size of the text by calling the TextHeight and TextWidth methods.
  • Align the text by using the TextAligned method to determine the specified alignment for the print.
  • Rotate the text by using the TextRotated method to specify the rotation of the text on the document.
See Also

Draw Class | Text Method | TextAligned Method | TextHeight Method | TextRotated Method | TextWidth Method


Use Image Color Management (ICM)

Image Color Management may be handled by Windows, the Device Driver, the Device itself, PrintPro, or it may be disabled altogether. Use the ICM Method Property to specify one of these options.

If PrintPro is to handle the Image Color Management, perform the following steps:

  1. Make sure you have the ICM Profiles appropriate to your destination device (printer or monitor).

  2. If you want to use a profile other than the default, set IMC PrinterProfile or ICM MonitorProfile to the one you do want to use.

  3. Set ICM Method to Profile.

  4. Make sure ICM RenderIntent is set other than NONE.

Color Management adjustments will now be made to images previewed or printed.


Create Print Job

A print job provides instructions to the printer about what to print. To construct a print job,

  • Define a PrintJob object.
  • Specify a Name for the print job, if desired.
  • Set margins that will be used to define placement of the page within the printable area, by setting BottomMargin, TopMargin, LeftMargin, and UseHardwareMargins.
  • Create the pages in the print job. Call the NewPage method to define a new page in the print job. Then, populate the page using a TemplateFileName, or by adding bitmaps (PrintBitmap), DIBs (PrintDib), and images (PrintImage), and graphics. When the page has been populated, call NewPage to start another page in the print job, and repeat until the entire print job has been defined.
  • Once the print job has been created, call Finish to release the job to the print device or spooler.

Note: The Kill method can be called at any time during the life of a print job, prior to calling Finish. Calling Kill immediately terminates the current print job.

Populating a Page Using a Template File

A collage template file is a text file, formatted to describe the image sizes and locations to be placed on the page. To use a template file in a print job, specify the TemplateFileName. Then, call the PrintTemplateBitmap, PrintTemplateDib and PrintTemplateImage methods to add the bitmap, DIB, or image to the page using the size and location information specified in the template file.

Drawing on a Page

PrintPro enables the user to draw on the page to be printed, using PrintPRO drawing methods, or by using .NET drawing methods.

Using .NET Drawing Methods: Call GetGraphics to apply a .NET graphics object to the page.

Using PrintPRO: Use the Draw property to acquire a PrintPRO drawing object.

See Also

PrintJob Class | Draw Class


Add Text

PrintPRO gives the developer flexibility when adding text. The simplest way to add text is to use the Text Method.

Placing text

The Text method adds text at the CurrentX Property and CurrentY Property position.

The TextHeight Method and the TextWidth Method can be used to return the height and width of a text string.

Aligning text

If you want to align the text, use the TextAligned Method. This method automatically aligns text inside a rectangular area using the alignment style defined by the Alignment enumeration set . Text will also automatically wordwrap if the wordWrap parameter is set to True.

Rotating text

If you want to rotate the text, use the TextRotated Method. This method lets you specify a rotation angle, pivot point and pivot mode. If the pivot point is not specified, the CurrentX Property and CurrentY Property values are used. The pivot mode specifies whether the text is left justified, right justified or center justified at the pivot point.

Setting fonts

The Font parameters used in the Text methods let you set the printer's font name, size, and attributes (bold, underline, etc.). Use the TextHeight and TextWidth methods to return the font height and width. See the Change Font topic for more information on modifying Fonts.

Setting background style

The BackStyle Property lets you display text transparently or on a solid color background. The BackColor Property determines the color of the text background and the ForeColor Property determines the color of the text.

See Also

Change Font | Draw Class


Add Bitmaps

PrintPRO lets you print Device Independent Bitmaps (DIB), a Bitmap, and an Image. Bitmaps can be printed stretched (or resized) inside a rectangular area with or without the aspect ratio being maintained. The ability to automatically maintain the bitmap's aspect ratio makes it easy to display large document images correctly on the printed page.

Adding a Bitmap

To add a Bitmap use the PrintBitmap Method to print the bitmap. The parameters set the height and width of the source and destination of the bitmap. If the aspect parameter is set to true, the destination size is adjusted to maintain the image data's aspect ratio.

Adding a DIB

To add a DIB, use the PrintDib Method to print the DIB. The parameters set the height and width of the source and destination of the DIB. If the aspect parameter is set to true, the destination size is adjusted to maintain the image data's aspect ratio.

Adding an Image

To add an image, use the PrintImage Method to print the DIB. The parameters set the height and width of the source and destination of the image. If the aspect parameter is set to true, the destination size is adjusted to maintain the image data's aspect ratio.

See Also

PrintBitmap Method | PrintDib Method | PrintImage Method


Add Graphics

PrintPro supports adding the following graphic types to the document to be printed:

  • Arcs - use the Arc Method.
  • Circles and Ellipses - use the Circle Method.
  • Curves - use the Curve Method.
  • Lines, Rectangles, and Points - use the Line Method.
  • Pie Shapes - use the Pie Method.
  • Polygons - use the Polygon Method.
  • Rectangles - use the Rectangle Method.
  • Round Rectangles with rounded corners - use the RoundRectangle Method.

The method used to draw the graphic is determined by the following:

  • FillColor - use the FillColor Property to set the color to fill the graphic.
  • FillStyle - use the FillStyle Property to set the pattern to fill the graphic.
  • Draw Mode - use the Mode Property to specify how pen color and background color will be combined.
  • Draw Style - use the Style Property to determine the pattern of the line defining the graphic.
  • Draw Width - use the Width Property to set the width of the line defining the graphic.
See Also

Draw Class


Print Preview

PrintPRO lets you create a print preview image for any document page.

1. Decide whether to display print preview while printing document

If you plan on creating print preview images while printing a document, you need to start a print document using the CreateFilePrinter Method before initiating a print preview.

2. Initiate Print Preview

To initiate a print preview, you must call the PrintPreviewJob Method. After initiating a print preview, continue to create a print job. Use the Finish Method to end the print preview. If you are creating a multiple page document, PrintPRO will automatically create a print preview for each page.

3. View a Print Preview page:

When you want to view a print preview for a page, you first need to determine the size of the print preview image using the PrintPreviewScale Property. Next, use one of the GetPrintPreview Methods to create a bitmap, DIB or image for the page you want to view. Finally, use the PrintBitmap, PrintDib, or PrintImage methods to export the print preview image.

4. Resource Cleanup:

Print preview requires system resources that PrintPRO automatically takes care of. You can, however, delete the print preview resources yourself. The Finish method releases the print preview image. You can always recreate the bitmap using the GetPrintPreview Methods, so deleting the image when it is no longer needed will conserve system resources.

The Dispose Method deletes the print preview resources for a page. If you delete the print preview resources, you cannot recreate the bitmap image for that page.

Example:

The following code creates a simple print preview of a single line of text. An ImagXpress control is used to display the image.

/* prompt the user for the desired printer */

printer = PegasusImaging.WinForms.PrintPro4.Printer.SelectPrinter(pp,true);

/* create a print preview job for the above-specified printer */

job = new PegasusImaging.WinForms.PrintPro4.PrintPreviewJob(printer);

/* draw text */

job.Draw.Text("Print Preview Page 1");

/* Finish the print job to the end of the current page and "print" the document */

job.Finish();

/* display the generated preview image by getting a .NET Bitmap from the PrintPreviewJob

and converting it into an ImagXpress ImageX object. */

ixvPreview.Image = PegasusImaging.WinForms.ImagXpress9.ImageX.FromBitmap(ix,job.GetPrintPreviewBitmap(1));


How Do I Print to a File

This sample shows that with PrintPRO printing to a file is very much the same as generating printer output but with a few properties set to the appropriate values. Any printer output, regardless of how it is generated, can be easily directed to a file.

// generic Printer object, this is a real printer or a file depending on the user's selection

PegasusImaging.WinForms.PrintPRO4.Printer printer;

PegasusImaging.WinForms.PrintPro4.PrintJob job; // object representation of a print job

// prompt the user for the desired printer

printer = PegasusImaging.WinForms.PrintPro4.Printer.SelectPrinter(pp, true);

string destinationFile = System.IO.Path.Combine(Application.StartupPath, "PrintToFile.tif");

// create a file printer

printer = PegasusImaging.WinForms.PrintPro4.Printer.CreateFilePrinter(pp, destinationFile, PegasusImaging.WinForms.PrintPro4.SaveFileType.Tif);

// Set the dpi so the generated file is not too large.

// The resulting image will be the selected dpi times the printable area

// (slightly smaller than 8.5x11 because of margins).

printer.RequestedDpi = 100;

if(printer != null)

{

// Create a PrintJob object for the above-selected Printer.

// If the printer is not specified, PrintPRO will just use Window's default printer.

job = new PegasusImaging.WinForms.PrintPro4.PrintJob(printer);

job.Name = "Pegasus PrintPRO Demo";

System.Drawing.Font font =

new System.Drawing.Font("Arial",24,System.Drawing.FontStyle.Bold);

job.Draw.TextAligned(new System.Drawing.RectangleF(1000,job.TopMargin,

job.PaperWidth - 2000, 1100 - job.TopMargin), Hello! Check out PrintPRO v4!", font,

PegasusImaging.WinForms.PrintPro4.Alignment.CenterJustifyMiddle);

// Finish the print job to the end of the current page and print the document */

job.Finish();

}


How Do I Print an Image File Without ImagXpress

The following example shows how to print an image file without ImagXpress.

//generic Printer object, this is a real printer or a file depending on the user's selection

PegasusImaging.WinForms.PrintPro4.Printer printer;

PegasusImaging.WinForms.PrintPro4.PrintJob job; // object representation of a print job

// prompt the user for the desired printer

printer = PegasusImaging.WinForms.PrintPro4.Printer.SelectPrinter(pp,true);

if (printer != null)

{

// Create a PrintJob object for the above-selected Printer.

// If the printer is not specified, PrintPRO will use Window's default printer.

job = new PegasusImaging.WinForms.PrintPro4.PrintJob(printer);

job.Name = "Pegasus PrintPRO Demo";

job.Printbitmap(new Bitmap("c:\\image.bmp"), job.LeftMargin, job.TopMargin,

job.PrintWidth- job.LeftMargin, job.PrintHeight - job.TopMargin - job.BottomMargin, true);

// Finish the print job to the end of the current page and print the document

job.Finish();

}


How Do I Print a Multi-Page TIFF Image Using ImagXpress and PrintPRO

This example uses an ImagXpress control to load a multi-page (TIFF, PDF, ICO, MODCA or DCX) file, PrintPRO then prints them, one page at a time.

//generic Printer object, this is a real printer or a file depending on the user's selection

PegasusImaging.WinForms.PrintPro4.Printer printer;

PegasusImaging.WinForms.PrintPro4.PrintJob job; // object representation of a print job

/* prompt the user for the desired printer */

printer = PegasusImaging.WinForms.PrintPro4.Printer.SelectPrinter(pp,true);

if (printer != null)

{

// Create a PrintJob object for the above-selected Printer.

// If the printer is not specified, PrintPRO will use Window's default printer.

job = new PegasusImaging.WinForms.PrintPro4.PrintJob(printer);

job.Name = "Pegasus PrintPRO Demo";

int i = 0

int numPages = PegasusImaging.WinForms.ImagXpress9.ImageX.NumPages(ix, "c:\\multi.tif");

for(i = 1; i <= numPages; i++)

{

if (i > 1)

{

job.NewPage();

}

ixvPreview.Image = PegasusImaging.WinForms.ImagXpress9.ImageX.FromFile(ix, "c:\\multi.tif", i);

job.PrintDib(ixvPreview.Image.ToHdib(false), 0,0,0,0, job.LeftMargin, job.TopMargin,

job.PrintWidth - job.LeftMargin, job.PrintHeight - job.TopMargin - job.BottomMargin, true);

}

}

// Finish the print job to the end of the current page and print the document */

job.Finish();

}


Debug Your Application

Because debugging and writing debug information to a log file is time consuming and expensive, PrintPRO provides the ability to control the level of information written to the debug log as well as the ability to turn off writing to a file completely.

Use the properties and methods within the PrintPro Class below to adjust the settings of your debugging, event handling, memory and IDispose for optimal performance.

Control Debugging Information

  • Debug - Turns on or off the ability to write to the debug log file.
  • DebugLogFile - A filename which stores the debug log information.
  • DebugErrorLevel - Controls the amount of information that is written to the debug log file.

Note: When DebugErrorLevel is set to Detailed, PrintPRO logs most of your calls to the component including the occurrence of exceptions, the result of most major operations and the operation of each event it raises.

Troubleshooting

Stop Memory Leaks

After you are done using a PrintPRO object, call the Dispose method.

These are the errors that PrintPRO may raise:

Values

  • -5000 — No printer DC.

  • -5001 — A document has already been started.

  • -5002 — A document has not been started.

  • -5003 — StartPrintDoc method failed.

  • -5004 — Windows StartPage function failed.

  • -5005 — Print dialog failed probably because the user clicked the Cancel button.

  • -5006 — EndPrintDoc failed probably because the printer reported an error.

  • -5007 — Bad radius value.

  • -5008 — Bad angle value.

  • -5009 — The Windows StretchBlt function failed when printing a bitmap.

  • -5010 — No Memory.

  • -5011 — Invalid printer number.

  • -5012 — Invalid parameter.

  • -5013 — No printer selected.

  • -5014 — Cannot open the printer.

  • -5015 — Cannot get the property value.

  • -5016 — Cannot set the property value.

  • -5017 — Invalid DIB handle.

  • -5018 — Setup dialog failed, probably because the user pressed the Cancel button

  • -5019 — The Picture property or hDIB property has not been set.

  • -5020 — Cannot get default printer information from the system

  • -5021 — Cannot write to the printer

  • -5022 — Cannot end a print job

  • -5023 — Invalid print preview page number

  • -5024 — A print preview for the current page does not exist

  • -5025 — Cannot get matafile DC

  • -5026 — Cannot create overlay

  • -5027 — Cannot open file

  • -5028 — No DIB

  • -5029 — Error reading file

  • -5030 — Invalid TIFF size

  • -5031 — Error writing file

  • -5032 — TIFF tag not found

  • -5033 — TIFF tag item not found

  • -5034 — Invalid profile

  • -5035 — Generic GDI

  • -5036 — Invalid template

  • -5037 — Invalid print preview

  • -5038 — Invalid handle

  • -5039 — Cannot get error message

  • -5040 — Generic Win32 error

  • -5041 — Printing disabled

  • -5042 — Invalid pointer

  • -5043 — Invalid bin ID

  • -5044 — Invalid paper ID

  • -5045 — Cannot create compatible device

  • -5333 — Invalid license edition

  • -5400 — Invalid worker object ID

  • -5500 — Error initializing worker

  • -5900 — Printer driver failure

  • -5995 — Invalid license

  • -5996 — Invalid web code

  • -5999 — Not licensed


See Also

PegasusImaging.WinForms.PrintPro4 Assembly

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PegasusImaging.WinForms.PrintPro4 Namespace

Inheritance Hierarchy

Classes

Class | Description
Draw | This class implements methods and properties for drawing.
Icm | Ths class implements image color matching settings.
Licensing | This class implements methods for setting the license information for the toolkit.
Paper | This class implements methods and properties to define types of paper.
PaperBin | A class that implements a paper bin for a printer.
PaperBinCollection | This class implements a collection of paper bin objects.
PaperBinEnumerator | This class implements a paper bin enumerator.
PaperCollection | This class implements methods and properties for PaperBin objects.
PaperEnumerator | This class implements enumerating through paper collections.
Printer | This class implements available printers for printing.
PrinterCollection | This class implements a collection of available printers.
PrinterEnumerator | This class implements an enumerator that can be used to iterate through a collection of printers.
PrintJob | This class implements a normal print job.
PrintPreviewJob | This class represents a print preview job.
PrintPro | This class implements the main functionality of the PrintPro component.
PrintQuality | This class is used to represent the print quality.
UserPaper | This class implements methods and properties that are used in place of a paper class when a user paper type has been selected for a printer.

Enumerations

Enumeration | Description
Alignment | Option values which determine the alignment when printing.
BackStyle | Option values which determine the available backstyles to be used for printed text.
DebugErrorLevel | Option values which determine the available error levels for debugging.
DrawMode | Option values which determine the available drawing modes for the PrintPro native drawing routines.
DrawStyle | Option values which determine the available drawing styles for the PrintPro native drawing routines.
EvaluationMode | Option values which determine licensing evaluation modes.
FillStyle | Option values which determine the pattern used to fill circles, boxes, round rectangles, pie-shapes and polygons created with the native PrintPro drawing routines.
IcmIntent | Option values which determine the possible color management methods, or intents.
IcmMethod | Option values which determine the ICM method to use.
IcmRenderIntent | Option values which determine the purpose of the color correction.
MediaType | Option values which determine the type of media being printed on (if the printer supports this feature).
Orientation | Option values which determine whether documents are printed in portrait or landscape mode (if the printer supports this feature).
PrintColorMode | Option values which determine whether a color printer prints output in color or monochrome.
PrintDitherType | Option values which determine how dithering is to be done (if the printer supports this feature).
PrintDuplex | Option values which determine whether a page is printed on both sides (if the printer supports this feature).
PrintPreviewScale | Option values which determine the scaling size of the print preview image.
PrintRangeAvailable | Option values which determine the available radio buttons in the print dialog. The All value is always enabled. Using All will only enable the All radio button.
PrintRangeSelection | Option values which determine the Print Range selected on the Print Dialog box.
RotationPivotMode | Option values which determine the pivot location for Draw.TextRotated.
SaveFileType | Option values which determine the type of file generated when printing to file.
TrueTypeOption | Option values which determine the printer’s TrueType option.

Structures

Structure | Description
PrintingUnit | An object that represents units for printing. Made so that its use is similar to an Enumeration.

See Also

PegasusImaging.WinForms.PrintPro4 Assembly


Draw Class

Draw Members | PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Draw Class

PegasusImaging.WinForms.PrintPro4 Namespace : Draw Class (PegasusImaging.WinForms.PrintPro4)

This class implements methods and properties for drawing.

For a list of all members of this type, see Draw members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.PrintPro4.Draw

Syntax

[Visual Basic]
Public Class Draw
[C#]
public class Draw
[C++]
public __gc class Draw
[C++/CLI]
public ref class Draw

See Also

Draw Members | PegasusImaging.WinForms.PrintPro4 Namespace


Draw Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Draw Class Members

PegasusImaging.WinForms.PrintPro4 Namespace : Draw Class (PegasusImaging.WinForms.PrintPro4)

Draw overview

Public Properties

Public Property BackColor | Gets and sets the background color used for drawing.
Public Property BackStyle | Gets and sets the background style used for drawing.
Public Property CurrentX | Gets and sets the current x (horizontal) coordinate the draw cursor is at.
Public Property CurrentY | Gets and sets the current y (vertical) coordinate the draw cursor is at.
Public Property FillColor | Gets and sets the fill color used for drawing.
Public Property FillStyle | Gets and sets the FillStyle used for drawing.
Public Property ForeColor | Gets and sets the foreground color used for drawing.
Public Property Mode | Gets and sets the DrawMode enumeration value used for drawing.
Public Property Style | Gets and sets the DrawStyle used for drawing.
Public Property Width | Gets and sets the width of the pen used for drawing.

Public Methods

Public Method Arc | Overloaded. Draws an arc on a printer.
Public Method Circle | Overloaded. Draws a circle or ellipse on a printer.
Public Method Curve | Overloaded. Draws a cubic bezier curve on a printer.
Public Method Line | Overloaded. Draws a line or rectangle on a printer.
Public Method Pie | Overloaded. Draws part of a circle.
Public Method Polygon | Overloaded. Draws a 3-6 sided polygon on a printer.
Public Method Rectangle | Overloaded. Draws a rectangle on a printer.
Public Method RoundRectangle | Overloaded. Draws a rectangle with rounded corners on printer.
Public Method Text | Overloaded. Draws the specified text string.
Public Method TextAligned | Overloaded. Draws text with the specified alignment.
Public Method TextHeight | Overloaded. Returns the height the text would be if the output has a specified font.
Public Method TextRotated | Overloaded. Outputs text rotated by a specified number of degrees.
Public Method TextWidth | Overloaded. Returns the width the text would be if output with specified font.

See Also

Draw Class | PegasusImaging.WinForms.PrintPro4 Namespace


Arc Method

Draw Class | Draw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Arc Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class : Arc Method

Draws an arc on a printer.

Overload List

Draws an arc on a printer.

[Visual Basic] Overloads Public Sub Arc(PointF,PointF,Single,Single,Color)

[C#] public void Arc(PointF,PointF,float,float,Color);

[C++] public void Arc(PointF,PointF,float,float,Color);

[C++/CLI] public void Arc(PointF,PointF,float,float,Color);

Draws a black arc on a printer.

[Visual Basic] Overloads Public Sub Arc(RectangleF,Single,Single,Color)

[C#] public void Arc(RectangleF,float,float,Color);

[C++] public void Arc(RectangleF,float,float,Color);

[C++/CLI] public void Arc(RectangleF,float,float,Color);

Draws an arc on a printer from the current Draw location.

[Visual Basic] Overloads Public Sub Arc(PointF,Single,Single,Color)

[C#] public void Arc(PointF,float,float,Color);

[C++] public void Arc(PointF,float,float,Color);

[C++/CLI] public void Arc(PointF,float,float,Color);

Draws a black arc on a printer.

[Visual Basic] Overloads Public Sub Arc(PointF,PointF,Single,Single)

[C#] public void Arc(PointF,PointF,float,float);

[C++] public void Arc(PointF,PointF,float,float);

[C++/CLI] public void Arc(PointF,PointF,float,float);

Draws a black arc on a printer.

[Visual Basic] Overloads Public Sub Arc(RectangleF,Single,Single)

[C#] public void Arc(RectangleF,float,float);

[C++] public void Arc(RectangleF,float,float);

[C++/CLI] public void Arc(RectangleF,float,float);

Draws a black arc on a printer from the current draw location.

[Visual Basic] Overloads Public Sub Arc(PointF,Single,Single)

[C#] public void Arc(PointF,float,float);

[C++] public void Arc(PointF,float,float);

[C++/CLI] public void Arc(PointF,float,float);

Draws an arc on a printer.

[Visual Basic] Overloads Public Sub Arc(Point,Point,Single,Single,Color)

[C#] public void Arc(Point,Point,float,float,Color);

[C++] public void Arc(Point,Point,float,float,Color);

[C++/CLI] public void Arc(Point,Point,float,float,Color);

Draws a black arc on a printer.

[Visual Basic] Overloads Public Sub Arc(Rectangle,Single,Single,Color)

[C#] public void Arc(Rectangle,float,float,Color);

[C++] public void Arc(Rectangle,float,float,Color);

[C++/CLI] public void Arc(Rectangle,float,float,Color);

Draws an arc on a printer from the current Draw location.

[Visual Basic] Overloads Public Sub Arc(Point,Single,Single,Color)

[C#] public void Arc(Point,float,float,Color);

[C++] public void Arc(Point,float,float,Color);

[C++/CLI] public void Arc(Point,float,float,Color);

Draws a black arc on a printer.

[Visual Basic] Overloads Public Sub Arc(Point,Point,Single,Single)

[C#] public void Arc(Point,Point,float,float);

[C++] public void Arc(Point,Point,float,float);

[C++/CLI] public void Arc(Point,Point,float,float);

Draws a black arc on a printer.

[Visual Basic] Overloads Public Sub Arc(Rectangle,Single,Single)

[C#] public void Arc(Rectangle,float,float);

[C++] public void Arc(Rectangle,float,float);

[C++/CLI] public void Arc(Rectangle,float,float);

Draws a black arc on a printer from the current draw location.

[Visual Basic] Overloads Public Sub Arc(Point,Single,Single)

[C#] public void Arc(Point,float,float);

[C++] public void Arc(Point,float,float);

[C++/CLI] public void Arc(Point,float,float);

See Also

Draw Class | Draw Members


Arc(PointF,PointF,Single,Single,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

upperLeft
A PointF which represents the upper-left coordinate for the bounding rectangle.
lowerRight
A PointF which represents the lower-right coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
The Color of the circle’s outline.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Arc(PointF,PointF,Single,Single,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Arc Method : Arc(PointF,PointF,Single,Single,Color) Method

Draws an arc on a printer.

[Visual Basic]
Overloads Public Sub Arc( _
   ByVal upperLeft As PointF, _
   ByVal lowerRight As PointF, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
[C#]
public void Arc(
   PointF upperLeft,
   PointF lowerRight,
   float startAngle,
   float endAngle,
   Color color
);
[C++]
public: void Arc(
   PointF upperLeft,
   PointF lowerRight,
   float startAngle,
   float endAngle,
   Color color
)
[C++/CLI]
public:
void Arc(
   PointF upperLeft,
   PointF lowerRight,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

upperLeft
A PointF which represents the upper-left coordinate for the bounding rectangle.
lowerRight
A PointF which represents the lower-right coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
The Color of the circle’s outline.

See Also

Draw Class | Draw Members | Overload List


Arc(RectangleF,Single,Single,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
The bounding RectangleF that specifies the size of the arc.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
The Color of the circle’s outline.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Arc(RectangleF,Single,Single,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Arc Method : Arc(RectangleF,Single,Single,Color) Method

Draws a black arc on a printer.

[Visual Basic]
Overloads Public Sub Arc( _
   ByVal boundingBox As RectangleF, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
[C#]
public void Arc(
   RectangleF boundingBox,
   float startAngle,
   float endAngle,
   Color color
);
[C++]
public: void Arc(
   RectangleF boundingBox,
   float startAngle,
   float endAngle,
   Color color
)
[C++/CLI]
public:
void Arc(
   RectangleF boundingBox,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

boundingBox
The bounding RectangleF that specifies the size of the arc.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
The Color of the circle’s outline.

See Also

Draw Class | Draw Members | Overload List


Arc(PointF,Single,Single,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A PointF which represents the end coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
A Color of the circle’s outline.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Arc(PointF,Single,Single,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Arc Method : Arc(PointF,Single,Single,Color) Method

Draws an arc on a printer from the current Draw location.

[Visual Basic]
Overloads Public Sub Arc( _
   ByVal endPoint As PointF, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
[C#]
public void Arc(
   PointF endPoint,
   float startAngle,
   float endAngle,
   Color color
);
[C++]
public: void Arc(
   PointF endPoint,
   float startAngle,
   float endAngle,
   Color color
)
[C++/CLI]
public:
void Arc(
   PointF endPoint,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

endPoint
A PointF which represents the end coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
A Color of the circle’s outline.

See Also

Draw Class | Draw Members | Overload List


Arc(PointF,PointF,Single,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

upperLeft
A PointF which represents the upper-left coordinate for the bounding rectangle.
lowerRight
A PointF which represents the lower-right coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Arc(PointF,PointF,Single,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Arc Method : Arc(PointF,PointF,Single,Single) Method

Draws a black arc on a printer.

[Visual Basic]
Overloads Public Sub Arc( _
   ByVal upperLeft As PointF, _
   ByVal lowerRight As PointF, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
[C#]
public void Arc(
   PointF upperLeft,
   PointF lowerRight,
   float startAngle,
   float endAngle
);
[C++]
public: void Arc(
   PointF upperLeft,
   PointF lowerRight,
   float startAngle,
   float endAngle
)
[C++/CLI]
public:
void Arc(
   PointF upperLeft,
   PointF lowerRight,
   float startAngle,
   float endAngle
)

Parameters

upperLeft
A PointF which represents the upper-left coordinate for the bounding rectangle.
lowerRight
A PointF which represents the lower-right coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Draw Class | Draw Members | Overload List


Arc(RectangleF,Single,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
The bounding RectangleF that specifies the size of the arc
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Arc(RectangleF,Single,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Arc Method : Arc(RectangleF,Single,Single) Method

Draws a black arc on a printer.

[Visual Basic]
Overloads Public Sub Arc( _
   ByVal boundingBox As RectangleF, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
[C#]
public void Arc(
   RectangleF boundingBox,
   float startAngle,
   float endAngle
);
[C++]
public: void Arc(
   RectangleF boundingBox,
   float startAngle,
   float endAngle
)
[C++/CLI]
public:
void Arc(
   RectangleF boundingBox,
   float startAngle,
   float endAngle
)

Parameters

boundingBox
The bounding RectangleF that specifies the size of the arc
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Draw Class | Draw Members | Overload List


Arc(PointF,Single,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A PointF which represents the end coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Arc(PointF,Single,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Arc Method : Arc(PointF,Single,Single) Method

Draws a black arc on a printer from the current draw location.

[Visual Basic]
Overloads Public Sub Arc( _
   ByVal endPoint As PointF, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
[C#]
public void Arc(
   PointF endPoint,
   float startAngle,
   float endAngle
);
[C++]
public: void Arc(
   PointF endPoint,
   float startAngle,
   float endAngle
)
[C++/CLI]
public:
void Arc(
   PointF endPoint,
   float startAngle,
   float endAngle
)

Parameters

endPoint
A PointF which represents the end coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Draw Class | Draw Members | Overload List


Arc(Point,Point,Single,Single,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

upperLeft
A PointF which represents the upper-left coordinate for the bounding rectangle.
lowerRight
A PointF which represents the lower-right coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
A Color of the circle’s outline.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Arc(Point,Point,Single,Single,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Arc Method : Arc(Point,Point,Single,Single,Color) Method

Draws an arc on a printer.

[Visual Basic]
Overloads Public Sub Arc( _
   ByVal upperLeft As Point, _
   ByVal lowerRight As Point, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
[C#]
public void Arc(
   Point upperLeft,
   Point lowerRight,
   float startAngle,
   float endAngle,
   Color color
);
[C++]
public: void Arc(
   Point upperLeft,
   Point lowerRight,
   float startAngle,
   float endAngle,
   Color color
)
[C++/CLI]
public:
void Arc(
   Point upperLeft,
   Point lowerRight,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

upperLeft
A PointF which represents the upper-left coordinate for the bounding rectangle.
lowerRight
A PointF which represents the lower-right coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
A Color of the circle’s outline.

See Also

Draw Class | Draw Members | Overload List


Arc(Rectangle,Single,Single,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
The bounding Rectangle that specifies the size of the arc.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
The Color to draw the arc.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Arc(Rectangle,Single,Single,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Arc Method : Arc(Rectangle,Single,Single,Color) Method

Draws a black arc on a printer.

[Visual Basic]
Overloads Public Sub Arc( _
   ByVal boundingBox As Rectangle, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
[C#]
public void Arc(
   Rectangle boundingBox,
   float startAngle,
   float endAngle,
   Color color
);
[C++]
public: void Arc(
   Rectangle boundingBox,
   float startAngle,
   float endAngle,
   Color color
)
[C++/CLI]
public:
void Arc(
   Rectangle boundingBox,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

boundingBox
The bounding Rectangle that specifies the size of the arc.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
The Color to draw the arc.

See Also

Draw Class | Draw Members | Overload List


Arc(Point,Single,Single,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A Point which represents the end coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
A Color of the circle’s outline.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Arc(Point,Single,Single,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Arc Method : Arc(Point,Single,Single,Color) Method

Draws an arc on a printer from the current Draw location.

[Visual Basic]
Overloads Public Sub Arc( _
   ByVal endPoint As Point, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
[C#]
public void Arc(
   Point endPoint,
   float startAngle,
   float endAngle,
   Color color
);
[C++]
public: void Arc(
   Point endPoint,
   float startAngle,
   float endAngle,
   Color color
)
[C++/CLI]
public:
void Arc(
   Point endPoint,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

endPoint
A Point which represents the end coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
A Color of the circle’s outline.

See Also

Draw Class | Draw Members | Overload List


Arc(Point,Point,Single,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

upperLeft
A Point which represents the upper-left coordinate for the bounding rectangle.
lowerRight
A Point which represents the lower-right coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Arc(Point,Point,Single,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Arc Method : Arc(Point,Point,Single,Single) Method

Draws a black arc on a printer.

[Visual Basic]
Overloads Public Sub Arc( _
   ByVal upperLeft As Point, _
   ByVal lowerRight As Point, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
[C#]
public void Arc(
   Point upperLeft,
   Point lowerRight,
   float startAngle,
   float endAngle
);
[C++]
public: void Arc(
   Point upperLeft,
   Point lowerRight,
   float startAngle,
   float endAngle
)
[C++/CLI]
public:
void Arc(
   Point upperLeft,
   Point lowerRight,
   float startAngle,
   float endAngle
)

Parameters

upperLeft
A Point which represents the upper-left coordinate for the bounding rectangle.
lowerRight
A Point which represents the lower-right coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Draw Class | Draw Members | Overload List


Arc(Rectangle,Single,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
The bounding Rectangle that specifies the size of the arc
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Arc(Rectangle,Single,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Arc Method : Arc(Rectangle,Single,Single) Method

Draws a black arc on a printer.

[Visual Basic]
Overloads Public Sub Arc( _
   ByVal boundingBox As Rectangle, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
[C#]
public void Arc(
   Rectangle boundingBox,
   float startAngle,
   float endAngle
);
[C++]
public: void Arc(
   Rectangle boundingBox,
   float startAngle,
   float endAngle
)
[C++/CLI]
public:
void Arc(
   Rectangle boundingBox,
   float startAngle,
   float endAngle
)

Parameters

boundingBox
The bounding Rectangle that specifies the size of the arc
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Draw Class | Draw Members | Overload List


Arc(Point,Single,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A Point which represents the end coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Arc(Point,Single,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Arc Method : Arc(Point,Single,Single) Method

Draws a black arc on a printer from the current draw location.

[Visual Basic]
Overloads Public Sub Arc( _
   ByVal endPoint As Point, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
[C#]
public void Arc(
   Point endPoint,
   float startAngle,
   float endAngle
);
[C++]
public: void Arc(
   Point endPoint,
   float startAngle,
   float endAngle
)
[C++/CLI]
public:
void Arc(
   Point endPoint,
   float startAngle,
   float endAngle
)

Parameters

endPoint
A Point which represents the end coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Draw Class | Draw Members | Overload List


Circle Method

Draw Class | Draw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Circle Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class : Circle Method

Draws a circle or ellipse on a printer.

Overload List

Draws a circle or ellipse on a printer.

[Visual Basic] Overloads Public Sub Circle(PointF,Single,Color,Single)

[C#] public void Circle(PointF,float,Color,float);

[C++] public void Circle(PointF,float,Color,float);

[C++/CLI] public void Circle(PointF,float,Color,float);

Draws a circle or ellipse on a printer at the current draw location.

[Visual Basic] Overloads Public Sub Circle(Single,Color,Single)

[C#] public void Circle(float,Color,float);

[C++] public void Circle(float,Color,float);

[C++/CLI] public void Circle(float,Color,float);

Draws a black circle or ellipse on a printer.

[Visual Basic] Overloads Public Sub Circle(PointF,Single,Single)

[C#] public void Circle(PointF,float,float);

[C++] public void Circle(PointF,float,float);

[C++/CLI] public void Circle(PointF,float,float);

Draws a black circle or ellipse on a printer at the current draw location.

[Visual Basic] Overloads Public Sub Circle(Single,Single)

[C#] public void Circle(float,float);

[C++] public void Circle(float,float);

[C++/CLI] public void Circle(float,float);

Draws a circle or ellipse on a printer.

[Visual Basic] Overloads Public Sub Circle(Point,Integer,Color,Single)

[C#] public void Circle(Point,int,Color,float);

[C++] public void Circle(Point,int,Color,float);

[C++/CLI] public void Circle(Point,int,Color,float);

Draws a circle or ellipse on a printer at the current draw location.

[Visual Basic] Overloads Public Sub Circle(Integer,Color,Single)

[C#] public void Circle(int,Color,float);

[C++] public void Circle(int,Color,float);

[C++/CLI] public void Circle(int,Color,float);

Draws a black circle or ellipse on a printer.

[Visual Basic] Overloads Public Sub Circle(Point,Integer,Single)

[C#] public void Circle(Point,int,float);

[C++] public void Circle(Point,int,float);

[C++/CLI] public void Circle(Point,int,float);

Draws a black circle or ellipse on a printer at the current draw location.

[Visual Basic] Overloads Public Sub Circle(Integer,Single)

[C#] public void Circle(int,float);

[C++] public void Circle(int,float);

[C++/CLI] public void Circle(int,float);

See Also

Draw Class | Draw Members


Circle(PointF,Single,Color,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

location
The PointF coordinate for the center point of the circle or ellipse.
radius
A single value which represents the radius of the circle or ellipse.
color
The Color of the circle’s outline.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Circle(PointF,Single,Color,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Circle Method : Circle(PointF,Single,Color,Single) Method

Draws a circle or ellipse on a printer.

[Visual Basic]
Overloads Public Sub Circle( _
   ByVal location As PointF, _
   ByVal radius As Single, _
   ByVal color As Color, _
   ByVal aspectRatio As Single _
)
[C#]
public void Circle(
   PointF location,
   float radius,
   Color color,
   float aspectRatio
);
[C++]
public: void Circle(
   PointF location,
   float radius,
   Color color,
   float aspectRatio
)
[C++/CLI]
public:
void Circle(
   PointF location,
   float radius,
   Color color,
   float aspectRatio
)

Parameters

location
The PointF coordinate for the center point of the circle or ellipse.
radius
A single value which represents the radius of the circle or ellipse.
color
The Color of the circle’s outline.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.

See Also

Draw Class | Draw Members | Overload List


Circle(Single,Color,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

radius
A single value which represents the radius of the circle or ellipse.
color
The Color of the circle’s outline.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Circle(Single,Color,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Circle Method : Circle(Single,Color,Single) Method

Draws a circle or ellipse on a printer at the current draw location.

[Visual Basic]
Overloads Public Sub Circle( _
   ByVal radius As Single, _
   ByVal color As Color, _
   ByVal aspectRatio As Single _
)
[C#]
public void Circle(
   float radius,
   Color color,
   float aspectRatio
);
[C++]
public: void Circle(
   float radius,
   Color color,
   float aspectRatio
)
[C++/CLI]
public:
void Circle(
   float radius,
   Color color,
   float aspectRatio
)

Parameters

radius
A single value which represents the radius of the circle or ellipse.
color
The Color of the circle’s outline.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.

See Also

Draw Class | Draw Members | Overload List


Circle(PointF,Single,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

location
The PointF coordinate for the center point of the circle or ellipse.
radius
A single value which represents the radius of the circle or ellipse.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Circle(PointF,Single,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Circle Method : Circle(PointF,Single,Single) Method

Draws a black circle or ellipse on a printer.

[Visual Basic]
Overloads Public Sub Circle( _
   ByVal location As PointF, _
   ByVal radius As Single, _
   ByVal aspectRatio As Single _
)
[C#]
public void Circle(
   PointF location,
   float radius,
   float aspectRatio
);
[C++]
public: void Circle(
   PointF location,
   float radius,
   float aspectRatio
)
[C++/CLI]
public:
void Circle(
   PointF location,
   float radius,
   float aspectRatio
)

Parameters

location
The PointF coordinate for the center point of the circle or ellipse.
radius
A single value which represents the radius of the circle or ellipse.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.

See Also

Draw Class | Draw Members | Overload List


Circle(Single,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

radius
A single value which represents the radius of the circle or ellipse.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Circle(Single,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Circle Method : Circle(Single,Single) Method

Draws a black circle or ellipse on a printer at the current draw location.

[Visual Basic]
Overloads Public Sub Circle( _
   ByVal radius As Single, _
   ByVal aspectRatio As Single _
)
[C#]
public void Circle(
   float radius,
   float aspectRatio
);
[C++]
public: void Circle(
   float radius,
   float aspectRatio
)
[C++/CLI]
public:
void Circle(
   float radius,
   float aspectRatio
)

Parameters

radius
A single value which represents the radius of the circle or ellipse.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.

See Also

Draw Class | Draw Members | Overload List


Circle(Point,Int32,Color,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

location
The Point coordinate for the center point of the circle or ellipse.
radius
An integer value which represents the radius of the circle or ellipse.
color
The Color of the circle’s outline.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Circle(Point,Int32,Color,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Circle Method : Circle(Point,Int32,Color,Single) Method

Draws a circle or ellipse on a printer.

[Visual Basic]
Overloads Public Sub Circle( _
   ByVal location As Point, _
   ByVal radius As Integer, _
   ByVal color As Color, _
   ByVal aspectRatio As Single _
)
[C#]
public void Circle(
   Point location,
   int radius,
   Color color,
   float aspectRatio
);
[C++]
public: void Circle(
   Point location,
   int radius,
   Color color,
   float aspectRatio
)
[C++/CLI]
public:
void Circle(
   Point location,
   int radius,
   Color color,
   float aspectRatio
)

Parameters

location
The Point coordinate for the center point of the circle or ellipse.
radius
An integer value which represents the radius of the circle or ellipse.
color
The Color of the circle’s outline.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.

See Also

Draw Class | Draw Members | Overload List


Circle(Int32,Color,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

radius
An integer value which represents the radius of the circle or ellipse.
color
The Color of the circle’s outline.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Circle(Int32,Color,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Circle Method : Circle(Int32,Color,Single) Method

Draws a circle or ellipse on a printer at the current draw location.

[Visual Basic]
Overloads Public Sub Circle( _
   ByVal radius As Integer, _
   ByVal color As Color, _
   ByVal aspectRatio As Single _
)
[C#]
public void Circle(
   int radius,
   Color color,
   float aspectRatio
);
[C++]
public: void Circle(
   int radius,
   Color color,
   float aspectRatio
)
[C++/CLI]
public:
void Circle(
   int radius,
   Color color,
   float aspectRatio
)

Parameters

radius
An integer value which represents the radius of the circle or ellipse.
color
The Color of the circle’s outline.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.

See Also

Draw Class | Draw Members | Overload List


Circle(Point,Int32,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

location
The Point coordinate for the center point of the circle or ellipse.
radius
An integer value which represents the radius of the circle or ellipse.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Circle(Point,Int32,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Circle Method : Circle(Point,Int32,Single) Method

Draws a black circle or ellipse on a printer.

[Visual Basic]
Overloads Public Sub Circle( _
   ByVal location As Point, _
   ByVal radius As Integer, _
   ByVal aspectRatio As Single _
)
[C#]
public void Circle(
   Point location,
   int radius,
   float aspectRatio
);
[C++]
public: void Circle(
   Point location,
   int radius,
   float aspectRatio
)
[C++/CLI]
public:
void Circle(
   Point location,
   int radius,
   float aspectRatio
)

Parameters

location
The Point coordinate for the center point of the circle or ellipse.
radius
An integer value which represents the radius of the circle or ellipse.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.

See Also

Draw Class | Draw Members | Overload List


Circle(Int32,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

radius
An integer value which represents the radius of the circle or ellipse.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Circle(Int32,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Circle Method : Circle(Int32,Single) Method

Draws a black circle or ellipse on a printer at the current draw location.

[Visual Basic]
Overloads Public Sub Circle( _
   ByVal radius As Integer, _
   ByVal aspectRatio As Single _
)
[C#]
public void Circle(
   int radius,
   float aspectRatio
);
[C++]
public: void Circle(
   int radius,
   float aspectRatio
)
[C++/CLI]
public:
void Circle(
   int radius,
   float aspectRatio
)

Parameters

radius
An integer value which represents the radius of the circle or ellipse.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.

See Also

Draw Class | Draw Members | Overload List


Curve Method

Draw Class | Draw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Curve Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class : Curve Method

Draws a cubic bezier curve on a printer.

Overload List

Draws a cubic bezier curve on a printer.

[Visual Basic] Overloads Public Sub Curve(PointF,PointF,PointF,PointF,Color)

[C#] public void Curve(PointF,PointF,PointF,PointF,Color);

[C++] public void Curve(PointF,PointF,PointF,PointF,Color);

[C++/CLI] public void Curve(PointF,PointF,PointF,PointF,Color);

Draws a black cubic bezier curve on a printer.

[Visual Basic] Overloads Public Sub Curve(PointF,PointF,PointF,PointF)

[C#] public void Curve(PointF,PointF,PointF,PointF);

[C++] public void Curve(PointF,PointF,PointF,PointF);

[C++/CLI] public void Curve(PointF,PointF,PointF,PointF);

Draws a cubic bezier curve on a printer.

[Visual Basic] Overloads Public Sub Curve(Point,Point,Point,Point,Color)

[C#] public void Curve(Point,Point,Point,Point,Color);

[C++] public void Curve(Point,Point,Point,Point,Color);

[C++/CLI] public void Curve(Point,Point,Point,Point,Color);

Draws a cubic bezier curve on a printer.

[Visual Basic] Overloads Public Sub Curve(Point,Point,Point,Point)

[C#] public void Curve(Point,Point,Point,Point);

[C++] public void Curve(Point,Point,Point,Point);

[C++/CLI] public void Curve(Point,Point,Point,Point);

See Also

Draw Class | Draw Members


Curve(PointF,PointF,PointF,PointF,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
A PointF which represents the starting point of the bezier curve.
controlPoint1
A PointF which represents the first control point of the bezier curve.
controlPoint2
A PointF which represents the second control point of the bezier curve.
endPoint
A PointF which represents the end point of the bezier curve.
color
The Color of the curve.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Curve(PointF,PointF,PointF,PointF,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Curve Method : Curve(PointF,PointF,PointF,PointF,Color) Method

Draws a cubic bezier curve on a printer.

[Visual Basic]
Overloads Public Sub Curve( _
   ByVal startPoint As PointF, _
   ByVal controlPoint1 As PointF, _
   ByVal controlPoint2 As PointF, _
   ByVal endPoint As PointF, _
   ByVal color As Color _
)
[C#]
public void Curve(
   PointF startPoint,
   PointF controlPoint1,
   PointF controlPoint2,
   PointF endPoint,
   Color color
);
[C++]
public: void Curve(
   PointF startPoint,
   PointF controlPoint1,
   PointF controlPoint2,
   PointF endPoint,
   Color color
)
[C++/CLI]
public:
void Curve(
   PointF startPoint,
   PointF controlPoint1,
   PointF controlPoint2,
   PointF endPoint,
   Color color
)

Parameters

startPoint
A PointF which represents the starting point of the bezier curve.
controlPoint1
A PointF which represents the first control point of the bezier curve.
controlPoint2
A PointF which represents the second control point of the bezier curve.
endPoint
A PointF which represents the end point of the bezier curve.
color
The Color of the curve.

Remarks

The curve starts at StartPoint going toward ControlPoint1 and arrives at EndPoint coming from the direction of ControlPoint2. Usually, it will not pass through ControlPoint1 or ControlPoint2; these points are only there to provide directional information. The distance between StartPoint and ControlPoint1 determines "how long" the curve moves into direction ControlPoint2 before turning towards EndPoint.

See Also

Draw Class | Draw Members | Overload List


Curve(PointF,PointF,PointF,PointF) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
A PointF which represents the starting point of the bezier curve.
controlPoint1
A PointF which represents the first control point of the bezier curve.
controlPoint2
A PointF which represents the second control point of the bezier curve.
endPoint
A PointF which represents the end point of the bezier curve.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Curve(PointF,PointF,PointF,PointF) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Curve Method : Curve(PointF,PointF,PointF,PointF) Method

Draws a black cubic bezier curve on a printer.

[Visual Basic]
Overloads Public Sub Curve( _
   ByVal startPoint As PointF, _
   ByVal controlPoint1 As PointF, _
   ByVal controlPoint2 As PointF, _
   ByVal endPoint As PointF _
)
[C#]
public void Curve(
   PointF startPoint,
   PointF controlPoint1,
   PointF controlPoint2,
   PointF endPoint
);
[C++]
public: void Curve(
   PointF startPoint,
   PointF controlPoint1,
   PointF controlPoint2,
   PointF endPoint
)
[C++/CLI]
public:
void Curve(
   PointF startPoint,
   PointF controlPoint1,
   PointF controlPoint2,
   PointF endPoint
)

Parameters

startPoint
A PointF which represents the starting point of the bezier curve.
controlPoint1
A PointF which represents the first control point of the bezier curve.
controlPoint2
A PointF which represents the second control point of the bezier curve.
endPoint
A PointF which represents the end point of the bezier curve.

Remarks

The curve starts at the StartPoint going toward ControlPoint1 and arrives at EndPoint coming from the direction of ControlPoint2. Usually, it will not pass through ControlPoint1 or ControlPoint2; these points are only there to provide directional information. The distance between StartPoint and ControlPoint1 determines "how long" the curve moves into direction ControlPoint2 before turning towards EndPoint.

See Also

Draw Class | Draw Members | Overload List


Curve(Point,Point,Point,Point,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
A Point which represents the starting point of the bezier curve.
controlPoint1
A Point which represents the first control point of the bezier curve.
controlPoint2
A Point which represents the second control point of the bezier curve.
endPoint
A Point which represents the end point of the bezier curve.
color
The Color of the curve.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Curve(Point,Point,Point,Point,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Curve Method : Curve(Point,Point,Point,Point,Color) Method

Draws a cubic bezier curve on a printer.

[Visual Basic]
Overloads Public Sub Curve( _
   ByVal startPoint As Point, _
   ByVal controlPoint1 As Point, _
   ByVal controlPoint2 As Point, _
   ByVal endPoint As Point, _
   ByVal color As Color _
)
[C#]
public void Curve(
   Point startPoint,
   Point controlPoint1,
   Point controlPoint2,
   Point endPoint,
   Color color
);
[C++]
public: void Curve(
   Point startPoint,
   Point controlPoint1,
   Point controlPoint2,
   Point endPoint,
   Color color
)
[C++/CLI]
public:
void Curve(
   Point startPoint,
   Point controlPoint1,
   Point controlPoint2,
   Point endPoint,
   Color color
)

Parameters

startPoint
A Point which represents the starting point of the bezier curve.
controlPoint1
A Point which represents the first control point of the bezier curve.
controlPoint2
A Point which represents the second control point of the bezier curve.
endPoint
A Point which represents the end point of the bezier curve.
color
The Color of the curve.

Remarks

The curve starts at StartPoint going toward ControlPoint1 and arrives at EndPoint coming from the direction of ControlPoint2. Usually, it will not pass through ControlPoint1 or ControlPoint2; these points are only there to provide directional information. The distance between StartPoint and ControlPoint1 determines "how long" the curve moves into direction ControlPoint2 before turning towards EndPoint.

See Also

Draw Class | Draw Members | Overload List


Curve(Point,Point,Point,Point) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
A Point which represents the starting point of the bezier curve.
controlPoint1
A Point which represents the first control point of the bezier curve.
controlPoint2
A Point which represents the second control point of the bezier curve.
endPoint
A Point which represents the end point of the bezier curve.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Curve(Point,Point,Point,Point) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Curve Method : Curve(Point,Point,Point,Point) Method

Draws a cubic bezier curve on a printer.

[Visual Basic]
Overloads Public Sub Curve( _
   ByVal startPoint As Point, _
   ByVal controlPoint1 As Point, _
   ByVal controlPoint2 As Point, _
   ByVal endPoint As Point _
)
[C#]
public void Curve(
   Point startPoint,
   Point controlPoint1,
   Point controlPoint2,
   Point endPoint
);
[C++]
public: void Curve(
   Point startPoint,
   Point controlPoint1,
   Point controlPoint2,
   Point endPoint
)
[C++/CLI]
public:
void Curve(
   Point startPoint,
   Point controlPoint1,
   Point controlPoint2,
   Point endPoint
)

Parameters

startPoint
A Point which represents the starting point of the bezier curve.
controlPoint1
A Point which represents the first control point of the bezier curve.
controlPoint2
A Point which represents the second control point of the bezier curve.
endPoint
A Point which represents the end point of the bezier curve.

Remarks

The curve starts at StartPoint going toward ControlPoint1 and arrives at EndPoint coming from the direction of ControlPoint2. Usually, it will not pass through ControlPoint1 or ControlPoint2; these points are only there to provide directional information. The distance between StartPoint and ControlPoint1 determines "how long" the curve moves into direction ControlPoint2 before turning towards EndPoint.

See Also

Draw Class | Draw Members | Overload List


Line Method

Draw Class | Draw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Line Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class : Line Method

Draws a line or rectangle on a printer.

Overload List

Draws a line or rectangle on a printer.

[Visual Basic] Overloads Public Sub Line(PointF,PointF,Color,Boolean,Boolean)

[C#] public void Line(PointF,PointF,Color,bool,bool);

[C++] public void Line(PointF,PointF,Color,bool,bool);

[C++/CLI] public void Line(PointF,PointF,Color,bool,bool);

Draws a line on a printer.

[Visual Basic] Overloads Public Sub Line(PointF,PointF,Color)

[C#] public void Line(PointF,PointF,Color);

[C++] public void Line(PointF,PointF,Color);

[C++/CLI] public void Line(PointF,PointF,Color);

Draws a black line or rectangle on a printer.

[Visual Basic] Overloads Public Sub Line(PointF,PointF,Boolean,Boolean)

[C#] public void Line(PointF,PointF,bool,bool);

[C++] public void Line(PointF,PointF,bool,bool);

[C++/CLI] public void Line(PointF,PointF,bool,bool);

Draws a black line.

[Visual Basic] Overloads Public Sub Line(PointF,PointF)

[C#] public void Line(PointF,PointF);

[C++] public void Line(PointF,PointF);

[C++/CLI] public void Line(PointF,PointF);

Draws a line or rectangle on a printer starting from the current draw location.

[Visual Basic] Overloads Public Sub Line(PointF,Color,Boolean,Boolean)

[C#] public void Line(PointF,Color,bool,bool);

[C++] public void Line(PointF,Color,bool,bool);

[C++/CLI] public void Line(PointF,Color,bool,bool);

Draws a line on a printer starting at the current draw location.

[Visual Basic] Overloads Public Sub Line(PointF,Color)

[C#] public void Line(PointF,Color);

[C++] public void Line(PointF,Color);

[C++/CLI] public void Line(PointF,Color);

Draws a black line or rectangle on a printer starting at the current draw location.

[Visual Basic] Overloads Public Sub Line(PointF,Boolean,Boolean)

[C#] public void Line(PointF,bool,bool);

[C++] public void Line(PointF,bool,bool);

[C++/CLI] public void Line(PointF,bool,bool);

Draws a black line starting at the current draw location.

[Visual Basic] Overloads Public Sub Line(PointF)

[C#] public void Line(PointF);

[C++] public void Line(PointF);

[C++/CLI] public void Line(PointF);

Draws a line or rectangle on a printer

[Visual Basic] Overloads Public Sub Line(Point,Point,Color,Boolean,Boolean)

[C#] public void Line(Point,Point,Color,bool,bool);

[C++] public void Line(Point,Point,Color,bool,bool);

[C++/CLI] public void Line(Point,Point,Color,bool,bool);

Draws a line on a printer

[Visual Basic] Overloads Public Sub Line(Point,Point,Color)

[C#] public void Line(Point,Point,Color);

[C++] public void Line(Point,Point,Color);

[C++/CLI] public void Line(Point,Point,Color);

Draws a black line or rectangle on a printer

[Visual Basic] Overloads Public Sub Line(Point,Point,Boolean,Boolean)

[C#] public void Line(Point,Point,bool,bool);

[C++] public void Line(Point,Point,bool,bool);

[C++/CLI] public void Line(Point,Point,bool,bool);

Draws a black line

[Visual Basic] Overloads Public Sub Line(Point,Point)

[C#] public void Line(Point,Point);

[C++] public void Line(Point,Point);

[C++/CLI] public void Line(Point,Point);

Draws a line or rectangle on a printer starting from the current draw location

[Visual Basic] Overloads Public Sub Line(Point,Color,Boolean,Boolean)

[C#] public void Line(Point,Color,bool,bool);

[C++] public void Line(Point,Color,bool,bool);

[C++/CLI] public void Line(Point,Color,bool,bool);

Draws a line on a printer starting at the current draw location.

[Visual Basic] Overloads Public Sub Line(Point,Color)

[C#] public void Line(Point,Color);

[C++] public void Line(Point,Color);

[C++/CLI] public void Line(Point,Color);

Draws a black line or rectangle on a printer starting at the current draw location.

[Visual Basic] Overloads Public Sub Line(Point,Boolean,Boolean)

[C#] public void Line(Point,bool,bool);

[C++] public void Line(Point,bool,bool);

[C++/CLI] public void Line(Point,bool,bool);

Draws a black line starting at the current draw location.

[Visual Basic] Overloads Public Sub Line(Point)

[C#] public void Line(Point);

[C++] public void Line(Point);

[C++/CLI] public void Line(Point);

See Also

Draw Class | Draw Members


Line(PointF,PointF,Color,Boolean,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
A PointF which represents the coordinate of the starting point for the line or rectangle.
endPoint
A PointF which represents the coordinate of the end point for the line or rectangle being drawn.
color
The Color used to draw the line or box.
box
A boolean value that if true, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if true and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Line(PointF,PointF,Color,Boolean,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Line Method : Line(PointF,PointF,Color,Boolean,Boolean) Method

Draws a line or rectangle on a printer.

[Visual Basic]
Overloads Public Sub Line( _
   ByVal startPoint As PointF, _
   ByVal endPoint As PointF, _
   ByVal color As Color, _
   ByVal box As Boolean, _
   ByVal fill As Boolean _
)
[C#]
public void Line(
   PointF startPoint,
   PointF endPoint,
   Color color,
   bool box,
   bool fill
);
[C++]
public: void Line(
   PointF startPoint,
   PointF endPoint,
   Color color,
   bool box,
   bool fill
)
[C++/CLI]
public:
void Line(
   PointF startPoint,
   PointF endPoint,
   Color color,
   bool box,
   bool fill
)

Parameters

startPoint
A PointF which represents the coordinate of the starting point for the line or rectangle.
endPoint
A PointF which represents the coordinate of the end point for the line or rectangle being drawn.
color
The Color used to draw the line or box.
box
A boolean value that if true, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if true and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.

See Also

Draw Class | Draw Members | Overload List


Line(PointF,PointF,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
A PointF which represents the coordinate of the starting point for the line.
endPoint
A PointF which represents the coordinate of the end point for the line being drawn.
color
The Color used to draw the line.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Line(PointF,PointF,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Line Method : Line(PointF,PointF,Color) Method

Draws a line on a printer.

[Visual Basic]
Overloads Public Sub Line( _
   ByVal startPoint As PointF, _
   ByVal endPoint As PointF, _
   ByVal color As Color _
)
[C#]
public void Line(
   PointF startPoint,
   PointF endPoint,
   Color color
);
[C++]
public: void Line(
   PointF startPoint,
   PointF endPoint,
   Color color
)
[C++/CLI]
public:
void Line(
   PointF startPoint,
   PointF endPoint,
   Color color
)

Parameters

startPoint
A PointF which represents the coordinate of the starting point for the line.
endPoint
A PointF which represents the coordinate of the end point for the line being drawn.
color
The Color used to draw the line.

See Also

Draw Class | Draw Members | Overload List


Line(PointF,PointF,Boolean,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
A PointF which represents the coordinate of the starting point for the line or rectangle.
endPoint
A PointF which represents the coordinate of the end point for the line or rectangle being drawn.
box
A boolean value that if true, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if true and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Line(PointF,PointF,Boolean,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Line Method : Line(PointF,PointF,Boolean,Boolean) Method

Draws a black line or rectangle on a printer.

[Visual Basic]
Overloads Public Sub Line( _
   ByVal startPoint As PointF, _
   ByVal endPoint As PointF, _
   ByVal box As Boolean, _
   ByVal fill As Boolean _
)
[C#]
public void Line(
   PointF startPoint,
   PointF endPoint,
   bool box,
   bool fill
);
[C++]
public: void Line(
   PointF startPoint,
   PointF endPoint,
   bool box,
   bool fill
)
[C++/CLI]
public:
void Line(
   PointF startPoint,
   PointF endPoint,
   bool box,
   bool fill
)

Parameters

startPoint
A PointF which represents the coordinate of the starting point for the line or rectangle.
endPoint
A PointF which represents the coordinate of the end point for the line or rectangle being drawn.
box
A boolean value that if true, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if true and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.

See Also

Draw Class | Draw Members | Overload List


Line(PointF,PointF) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
A PointF which represents the coordinate of the starting point for the line.
endPoint
A PointF which represents the coordinate of the end point for the line being drawn.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Line(PointF,PointF) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Line Method : Line(PointF,PointF) Method

Draws a black line.

[Visual Basic]
Overloads Public Sub Line( _
   ByVal startPoint As PointF, _
   ByVal endPoint As PointF _
)
[C#]
public void Line(
   PointF startPoint,
   PointF endPoint
);
[C++]
public: void Line(
   PointF startPoint,
   PointF endPoint
)
[C++/CLI]
public:
void Line(
   PointF startPoint,
   PointF endPoint
)

Parameters

startPoint
A PointF which represents the coordinate of the starting point for the line.
endPoint
A PointF which represents the coordinate of the end point for the line being drawn.

See Also

Draw Class | Draw Members | Overload List


Line(PointF,Color,Boolean,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A PointF which represents the coordinate of the end point for the line or rectangle being drawn.
color
A Color which is used to draw the line or box.
box
A boolean value that if true, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if true, and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Line(PointF,Color,Boolean,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Line Method : Line(PointF,Color,Boolean,Boolean) Method

Draws a line or rectangle on a printer starting from the current draw location.

[Visual Basic]
Overloads Public Sub Line( _
   ByVal endPoint As PointF, _
   ByVal color As Color, _
   ByVal box As Boolean, _
   ByVal fill As Boolean _
)
[C#]
public void Line(
   PointF endPoint,
   Color color,
   bool box,
   bool fill
);
[C++]
public: void Line(
   PointF endPoint,
   Color color,
   bool box,
   bool fill
)
[C++/CLI]
public:
void Line(
   PointF endPoint,
   Color color,
   bool box,
   bool fill
)

Parameters

endPoint
A PointF which represents the coordinate of the end point for the line or rectangle being drawn.
color
A Color which is used to draw the line or box.
box
A boolean value that if true, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if true, and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.

See Also

Draw Class | Draw Members | Overload List


Line(PointF,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A PointF which represents the coordinate of the end point for the line being drawn.
color
The Color used to draw the line.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Line(PointF,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Line Method : Line(PointF,Color) Method

Draws a line on a printer starting at the current draw location.

[Visual Basic]
Overloads Public Sub Line( _
   ByVal endPoint As PointF, _
   ByVal color As Color _
)
[C#]
public void Line(
   PointF endPoint,
   Color color
);
[C++]
public: void Line(
   PointF endPoint,
   Color color
)
[C++/CLI]
public:
void Line(
   PointF endPoint,
   Color color
)

Parameters

endPoint
A PointF which represents the coordinate of the end point for the line being drawn.
color
The Color used to draw the line.

See Also

Draw Class | Draw Members | Overload List


Line(PointF,Boolean,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A PointF which represents the coordinate of the end point for the line or rectangle being drawn.
box
A boolean value that if true, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if true, and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Line(PointF,Boolean,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Line Method : Line(PointF,Boolean,Boolean) Method

Draws a black line or rectangle on a printer starting at the current draw location.

[Visual Basic]
Overloads Public Sub Line( _
   ByVal endPoint As PointF, _
   ByVal box As Boolean, _
   ByVal fill As Boolean _
)
[C#]
public void Line(
   PointF endPoint,
   bool box,
   bool fill
);
[C++]
public: void Line(
   PointF endPoint,
   bool box,
   bool fill
)
[C++/CLI]
public:
void Line(
   PointF endPoint,
   bool box,
   bool fill
)

Parameters

endPoint
A PointF which represents the coordinate of the end point for the line or rectangle being drawn.
box
A boolean value that if true, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if true, and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.

See Also

Draw Class | Draw Members | Overload List


Line(PointF) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A Color which represents the coordinate of the end point for the line being drawn.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Line(PointF) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Line Method : Line(PointF) Method

Draws a black line starting at the current draw location.

[Visual Basic]
Overloads Public Sub Line( _
   ByVal endPoint As PointF _
)
[C#]
public void Line(
   PointF endPoint
);
[C++]
public: void Line(
   PointF endPoint
)
[C++/CLI]
public:
void Line(
   PointF endPoint
)

Parameters

endPoint
A Color which represents the coordinate of the end point for the line being drawn.

See Also

Draw Class | Draw Members | Overload List


Line(Point,Point,Color,Boolean,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
The coordinate of the starting point for the line or rectangle.
endPoint
The coordinate of the end point for the line or rectangle being drawn.
color
The color used to draw the line or box
box
A boolean value that if True, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if True and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Line(Point,Point,Color,Boolean,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Line Method : Line(Point,Point,Color,Boolean,Boolean) Method

Draws a line or rectangle on a printer

[Visual Basic]
Overloads Public Sub Line( _
   ByVal startPoint As Point, _
   ByVal endPoint As Point, _
   ByVal color As Color, _
   ByVal box As Boolean, _
   ByVal fill As Boolean _
)
[C#]
public void Line(
   Point startPoint,
   Point endPoint,
   Color color,
   bool box,
   bool fill
);
[C++]
public: void Line(
   Point startPoint,
   Point endPoint,
   Color color,
   bool box,
   bool fill
)
[C++/CLI]
public:
void Line(
   Point startPoint,
   Point endPoint,
   Color color,
   bool box,
   bool fill
)

Parameters

startPoint
The coordinate of the starting point for the line or rectangle.
endPoint
The coordinate of the end point for the line or rectangle being drawn.
color
The color used to draw the line or box
box
A boolean value that if True, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if True and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.

See Also

Draw Class | Draw Members | Overload List


Line(Point,Point,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
The coordinate of the starting point for the line.
endPoint
The coordinate of the end point for the line being drawn.
color
The color used to draw the line
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Line(Point,Point,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Line Method : Line(Point,Point,Color) Method

Draws a line on a printer

[Visual Basic]
Overloads Public Sub Line( _
   ByVal startPoint As Point, _
   ByVal endPoint As Point, _
   ByVal color As Color _
)
[C#]
public void Line(
   Point startPoint,
   Point endPoint,
   Color color
);
[C++]
public: void Line(
   Point startPoint,
   Point endPoint,
   Color color
)
[C++/CLI]
public:
void Line(
   Point startPoint,
   Point endPoint,
   Color color
)

Parameters

startPoint
The coordinate of the starting point for the line.
endPoint
The coordinate of the end point for the line being drawn.
color
The color used to draw the line

See Also

Draw Class | Draw Members | Overload List


Line(Point,Point,Boolean,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
The coordinate of the starting point for the line or rectangle.
endPoint
The coordinate of the end point for the line or rectangle being drawn.
box
A boolean value that if True, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if True and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Line(Point,Point,Boolean,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Line Method : Line(Point,Point,Boolean,Boolean) Method

Draws a black line or rectangle on a printer

[Visual Basic]
Overloads Public Sub Line( _
   ByVal startPoint As Point, _
   ByVal endPoint As Point, _
   ByVal box As Boolean, _
   ByVal fill As Boolean _
)
[C#]
public void Line(
   Point startPoint,
   Point endPoint,
   bool box,
   bool fill
);
[C++]
public: void Line(
   Point startPoint,
   Point endPoint,
   bool box,
   bool fill
)
[C++/CLI]
public:
void Line(
   Point startPoint,
   Point endPoint,
   bool box,
   bool fill
)

Parameters

startPoint
The coordinate of the starting point for the line or rectangle.
endPoint
The coordinate of the end point for the line or rectangle being drawn.
box
A boolean value that if True, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if True and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.

See Also

Draw Class | Draw Members | Overload List


Line(Point,Point) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
The coordinate of the starting point for the line.
endPoint
The coordinate of the end point for the line being drawn.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Line(Point,Point) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Line Method : Line(Point,Point) Method

Draws a black line

[Visual Basic]
Overloads Public Sub Line( _
   ByVal startPoint As Point, _
   ByVal endPoint As Point _
)
[C#]
public void Line(
   Point startPoint,
   Point endPoint
);
[C++]
public: void Line(
   Point startPoint,
   Point endPoint
)
[C++/CLI]
public:
void Line(
   Point startPoint,
   Point endPoint
)

Parameters

startPoint
The coordinate of the starting point for the line.
endPoint
The coordinate of the end point for the line being drawn.

See Also

Draw Class | Draw Members | Overload List


Line(Point,Color,Boolean,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
The coordinate of the end point for the line or rectangle being drawn.
color
The color used to draw the line or box
box
A boolean value that if True, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if True and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Line(Point,Color,Boolean,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Line Method : Line(Point,Color,Boolean,Boolean) Method

Draws a line or rectangle on a printer starting from the current draw location

[Visual Basic]
Overloads Public Sub Line( _
   ByVal endPoint As Point, _
   ByVal color As Color, _
   ByVal box As Boolean, _
   ByVal fill As Boolean _
)
[C#]
public void Line(
   Point endPoint,
   Color color,
   bool box,
   bool fill
);
[C++]
public: void Line(
   Point endPoint,
   Color color,
   bool box,
   bool fill
)
[C++/CLI]
public:
void Line(
   Point endPoint,
   Color color,
   bool box,
   bool fill
)

Parameters

endPoint
The coordinate of the end point for the line or rectangle being drawn.
color
The color used to draw the line or box
box
A boolean value that if True, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if True and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.

See Also

Draw Class | Draw Members | Overload List


Line(Point,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A Point which represents the coordinate of the end point for the line being drawn.
color
The Color used to draw the line.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Line(Point,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Line Method : Line(Point,Color) Method

Draws a line on a printer starting at the current draw location.

[Visual Basic]
Overloads Public Sub Line( _
   ByVal endPoint As Point, _
   ByVal color As Color _
)
[C#]
public void Line(
   Point endPoint,
   Color color
);
[C++]
public: void Line(
   Point endPoint,
   Color color
)
[C++/CLI]
public:
void Line(
   Point endPoint,
   Color color
)

Parameters

endPoint
A Point which represents the coordinate of the end point for the line being drawn.
color
The Color used to draw the line.

See Also

Draw Class | Draw Members | Overload List


Line(Point,Boolean,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A Point which represents the coordinate of the end point for the line or rectangle being drawn.
box
A boolean value that if true, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if true, and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Line(Point,Boolean,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Line Method : Line(Point,Boolean,Boolean) Method

Draws a black line or rectangle on a printer starting at the current draw location.

[Visual Basic]
Overloads Public Sub Line( _
   ByVal endPoint As Point, _
   ByVal box As Boolean, _
   ByVal fill As Boolean _
)
[C#]
public void Line(
   Point endPoint,
   bool box,
   bool fill
);
[C++]
public: void Line(
   Point endPoint,
   bool box,
   bool fill
)
[C++/CLI]
public:
void Line(
   Point endPoint,
   bool box,
   bool fill
)

Parameters

endPoint
A Point which represents the coordinate of the end point for the line or rectangle being drawn.
box
A boolean value that if true, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if true, and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.

See Also

Draw Class | Draw Members | Overload List


Line(Point) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A Point which represents the coordinate of the end point for the line or rectangle being drawn.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Line(Point) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Line Method : Line(Point) Method

Draws a black line starting at the current draw location.

[Visual Basic]
Overloads Public Sub Line( _
   ByVal endPoint As Point _
)
[C#]
public void Line(
   Point endPoint
);
[C++]
public: void Line(
   Point endPoint
)
[C++/CLI]
public:
void Line(
   Point endPoint
)

Parameters

endPoint
A Point which represents the coordinate of the end point for the line or rectangle being drawn.

See Also

Draw Class | Draw Members | Overload List


Pie Method

Draw Class | Draw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class : Pie Method

Draws part of a circle.

Overload List

Draws part of a circle.

[Visual Basic] Overloads Public Sub Pie(PointF,Single,Single,Single,Color)

[C#] public void Pie(PointF,float,float,float,Color);

[C++] public void Pie(PointF,float,float,float,Color);

[C++/CLI] public void Pie(PointF,float,float,float,Color);

Draws part of a circle.

[Visual Basic] Overloads Public Sub Pie(PointF,Single,Single,Color)

[C#] public void Pie(PointF,float,float,Color);

[C++] public void Pie(PointF,float,float,Color);

[C++/CLI] public void Pie(PointF,float,float,Color);

Draws part of a circle.

[Visual Basic] Overloads Public Sub Pie(Single,Single,Single,Color)

[C#] public void Pie(float,float,float,Color);

[C++] public void Pie(float,float,float,Color);

[C++/CLI] public void Pie(float,float,float,Color);

Draws part of a circle.

[Visual Basic] Overloads Public Sub Pie(Single,Single,Color)

[C#] public void Pie(float,float,Color);

[C++] public void Pie(float,float,Color);

[C++/CLI] public void Pie(float,float,Color);

Draws part of a circle.

[Visual Basic] Overloads Public Sub Pie(PointF,Single,Single,Single)

[C#] public void Pie(PointF,float,float,float);

[C++] public void Pie(PointF,float,float,float);

[C++/CLI] public void Pie(PointF,float,float,float);

Draws part of a circle.

[Visual Basic] Overloads Public Sub Pie(PointF,Single,Single)

[C#] public void Pie(PointF,float,float);

[C++] public void Pie(PointF,float,float);

[C++/CLI] public void Pie(PointF,float,float);

Draws part of a circle.

[Visual Basic] Overloads Public Sub Pie(Single,Single,Single)

[C#] public void Pie(float,float,float);

[C++] public void Pie(float,float,float);

[C++/CLI] public void Pie(float,float,float);

Draws part of a circle.

[Visual Basic] Overloads Public Sub Pie(Single,Single)

[C#] public void Pie(float,float);

[C++] public void Pie(float,float);

[C++/CLI] public void Pie(float,float);

Draws a pie-shaped wedge on a printer.

[Visual Basic] Overloads Public Sub Pie(PointF,PointF,Single,Single,Color)

[C#] public void Pie(PointF,PointF,float,float,Color);

[C++] public void Pie(PointF,PointF,float,float,Color);

[C++/CLI] public void Pie(PointF,PointF,float,float,Color);

Draws part of a circle.

[Visual Basic] Overloads Public Sub Pie(RectangleF,Single,Single,Color)

[C#] public void Pie(RectangleF,float,float,Color);

[C++] public void Pie(RectangleF,float,float,Color);

[C++/CLI] public void Pie(RectangleF,float,float,Color);

Draws a pie-shaped wedge on a printer.

[Visual Basic] Overloads Public Sub Pie(PointF,PointF,Single,Color)

[C#] public void Pie(PointF,PointF,float,Color);

[C++] public void Pie(PointF,PointF,float,Color);

[C++/CLI] public void Pie(PointF,PointF,float,Color);

Draws part of a circle.

[Visual Basic] Overloads Public Sub Pie(RectangleF,Single,Color)

[C#] public void Pie(RectangleF,float,Color);

[C++] public void Pie(RectangleF,float,Color);

[C++/CLI] public void Pie(RectangleF,float,Color);

Draws a black pie-shaped wedge on a printer.

[Visual Basic] Overloads Public Sub Pie(PointF,PointF,Single,Single)

[C#] public void Pie(PointF,PointF,float,float);

[C++] public void Pie(PointF,PointF,float,float);

[C++/CLI] public void Pie(PointF,PointF,float,float);

Draws part of a circle.

[Visual Basic] Overloads Public Sub Pie(RectangleF,Single,Single)

[C#] public void Pie(RectangleF,float,float);

[C++] public void Pie(RectangleF,float,float);

[C++/CLI] public void Pie(RectangleF,float,float);

Draws a black pie-shaped wedge on a printer.

[Visual Basic] Overloads Public Sub Pie(PointF,PointF,Single)

[C#] public void Pie(PointF,PointF,float);

[C++] public void Pie(PointF,PointF,float);

[C++/CLI] public void Pie(PointF,PointF,float);

Draws part of a circle.

[Visual Basic] Overloads Public Sub Pie(RectangleF,Single)

[C#] public void Pie(RectangleF,float);

[C++] public void Pie(RectangleF,float);

[C++/CLI] public void Pie(RectangleF,float);

Draws part of a circle.

[Visual Basic] Overloads Public Sub Pie(Point,Integer,Single,Single,Color)

[C#] public void Pie(Point,int,float,float,Color);

[C++] public void Pie(Point,int,float,float,Color);

[C++/CLI] public void Pie(Point,int,float,float,Color);

Draws part of a circle.

[Visual Basic] Overloads Public Sub Pie(Point,Integer,Single,Color)

[C#] public void Pie(Point,int,float,Color);

[C++] public void Pie(Point,int,float,Color);

[C++/CLI] public void Pie(Point,int,float,Color);

Draws part of a circle.

[Visual Basic] Overloads Public Sub Pie(Integer,Single,Single,Color)

[C#] public void Pie(int,float,float,Color);

[C++] public void Pie(int,float,float,Color);

[C++/CLI] public void Pie(int,float,float,Color);

Draws part of a circle.

[Visual Basic] Overloads Public Sub Pie(Integer,Single,Color)

[C#] public void Pie(int,float,Color);

[C++] public void Pie(int,float,Color);

[C++/CLI] public void Pie(int,float,Color);

Draws part of a circle.

[Visual Basic] Overloads Public Sub Pie(Point,Integer,Single,Single)

[C#] public void Pie(Point,int,float,float);

[C++] public void Pie(Point,int,float,float);

[C++/CLI] public void Pie(Point,int,float,float);

Draws part of a circle.

[Visual Basic] Overloads Public Sub Pie(Point,Integer,Single)

[C#] public void Pie(Point,int,float);

[C++] public void Pie(Point,int,float);

[C++/CLI] public void Pie(Point,int,float);

Draws part of a circle.

[Visual Basic] Overloads Public Sub Pie(Integer,Single,Single)

[C#] public void Pie(int,float,float);

[C++] public void Pie(int,float,float);

[C++/CLI] public void Pie(int,float,float);

Draws part of a circle.

[Visual Basic] Overloads Public Sub Pie(Integer,Single)

[C#] public void Pie(int,float);

[C++] public void Pie(int,float);

[C++/CLI] public void Pie(int,float);

Draws a pie-shaped wedge on a printer.

[Visual Basic] Overloads Public Sub Pie(Point,Point,Single,Single,Color)

[C#] public void Pie(Point,Point,float,float,Color);

[C++] public void Pie(Point,Point,float,float,Color);

[C++/CLI] public void Pie(Point,Point,float,float,Color);

Draws part of a circle.

[Visual Basic] Overloads Public Sub Pie(Rectangle,Single,Single,Color)

[C#] public void Pie(Rectangle,float,float,Color);

[C++] public void Pie(Rectangle,float,float,Color);

[C++/CLI] public void Pie(Rectangle,float,float,Color);

Draws a pie-shaped wedge on a printer.

[Visual Basic] Overloads Public Sub Pie(Point,Point,Single,Color)

[C#] public void Pie(Point,Point,float,Color);

[C++] public void Pie(Point,Point,float,Color);

[C++/CLI] public void Pie(Point,Point,float,Color);

Draws part of a circle.

[Visual Basic] Overloads Public Sub Pie(Rectangle,Single,Color)

[C#] public void Pie(Rectangle,float,Color);

[C++] public void Pie(Rectangle,float,Color);

[C++/CLI] public void Pie(Rectangle,float,Color);

Draws a black pie-shaped wedge on a printer.

[Visual Basic] Overloads Public Sub Pie(Point,Point,Single,Single)

[C#] public void Pie(Point,Point,float,float);

[C++] public void Pie(Point,Point,float,float);

[C++/CLI] public void Pie(Point,Point,float,float);

Draws part of a circle.

[Visual Basic] Overloads Public Sub Pie(Rectangle,Single,Single)

[C#] public void Pie(Rectangle,float,float);

[C++] public void Pie(Rectangle,float,float);

[C++/CLI] public void Pie(Rectangle,float,float);

Draws a black pie-shaped wedge on a printer.

[Visual Basic] Overloads Public Sub Pie(Point,Point,Single)

[C#] public void Pie(Point,Point,float);

[C++] public void Pie(Point,Point,float);

[C++/CLI] public void Pie(Point,Point,float);

Draws part of a circle.

[Visual Basic] Overloads Public Sub Pie(Rectangle,Single)

[C#] public void Pie(Rectangle,float);

[C++] public void Pie(Rectangle,float);

[C++/CLI] public void Pie(Rectangle,float);

See Also

Draw Class | Draw Members


Pie(PointF,Single,Single,Single,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

location
A PointF which represents the location of the center of the circle of the pie slice.
radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
The Color of the slice.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(PointF,Single,Single,Single,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(PointF,Single,Single,Single,Color) Method

Draws part of a circle.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal location As PointF, _
   ByVal radius As Single, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
[C#]
public void Pie(
   PointF location,
   float radius,
   float startAngle,
   float endAngle,
   Color color
);
[C++]
public: void Pie(
   PointF location,
   float radius,
   float startAngle,
   float endAngle,
   Color color
)
[C++/CLI]
public:
void Pie(
   PointF location,
   float radius,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

location
A PointF which represents the location of the center of the circle of the pie slice.
radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
The Color of the slice.

See Also

Draw Class | Draw Members | Overload List


Pie(PointF,Single,Single,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

location
A PointF which represents the location of the center of the circle of the pie slice.
radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.
color
The Color of the slice.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(PointF,Single,Single,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(PointF,Single,Single,Color) Method

Draws part of a circle.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal location As PointF, _
   ByVal radius As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
[C#]
public void Pie(
   PointF location,
   float radius,
   float endAngle,
   Color color
);
[C++]
public: void Pie(
   PointF location,
   float radius,
   float endAngle,
   Color color
)
[C++/CLI]
public:
void Pie(
   PointF location,
   float radius,
   float endAngle,
   Color color
)

Parameters

location
A PointF which represents the location of the center of the circle of the pie slice.
radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.
color
The Color of the slice.

See Also

Draw Class | Draw Members | Overload List


Pie(Single,Single,Single,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
The Color of the slice.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(Single,Single,Single,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(Single,Single,Single,Color) Method

Draws part of a circle.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal radius As Single, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
[C#]
public void Pie(
   float radius,
   float startAngle,
   float endAngle,
   Color color
);
[C++]
public: void Pie(
   float radius,
   float startAngle,
   float endAngle,
   Color color
)
[C++/CLI]
public:
void Pie(
   float radius,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
The Color of the slice.

See Also

Draw Class | Draw Members | Overload List


Pie(Single,Single,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.
color
The Color of the slice.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(Single,Single,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(Single,Single,Color) Method

Draws part of a circle.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal radius As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
[C#]
public void Pie(
   float radius,
   float endAngle,
   Color color
);
[C++]
public: void Pie(
   float radius,
   float endAngle,
   Color color
)
[C++/CLI]
public:
void Pie(
   float radius,
   float endAngle,
   Color color
)

Parameters

radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.
color
The Color of the slice.

See Also

Draw Class | Draw Members | Overload List


Pie(PointF,Single,Single,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

location
A PointF which represents the location of the center of the circle of the pie slice.
radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(PointF,Single,Single,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(PointF,Single,Single,Single) Method

Draws part of a circle.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal location As PointF, _
   ByVal radius As Single, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
[C#]
public void Pie(
   PointF location,
   float radius,
   float startAngle,
   float endAngle
);
[C++]
public: void Pie(
   PointF location,
   float radius,
   float startAngle,
   float endAngle
)
[C++/CLI]
public:
void Pie(
   PointF location,
   float radius,
   float startAngle,
   float endAngle
)

Parameters

location
A PointF which represents the location of the center of the circle of the pie slice.
radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.

See Also

Draw Class | Draw Members | Overload List


Pie(PointF,Single,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

location
A PointF which represents the location of the center of the circle of the pie slice.
radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(PointF,Single,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(PointF,Single,Single) Method

Draws part of a circle.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal location As PointF, _
   ByVal radius As Single, _
   ByVal endAngle As Single _
)
[C#]
public void Pie(
   PointF location,
   float radius,
   float endAngle
);
[C++]
public: void Pie(
   PointF location,
   float radius,
   float endAngle
)
[C++/CLI]
public:
void Pie(
   PointF location,
   float radius,
   float endAngle
)

Parameters

location
A PointF which represents the location of the center of the circle of the pie slice.
radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.

See Also

Draw Class | Draw Members | Overload List


Pie(Single,Single,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(Single,Single,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(Single,Single,Single) Method

Draws part of a circle.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal radius As Single, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
[C#]
public void Pie(
   float radius,
   float startAngle,
   float endAngle
);
[C++]
public: void Pie(
   float radius,
   float startAngle,
   float endAngle
)
[C++/CLI]
public:
void Pie(
   float radius,
   float startAngle,
   float endAngle
)

Parameters

radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.

See Also

Draw Class | Draw Members | Overload List


Pie(Single,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(Single,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(Single,Single) Method

Draws part of a circle.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal radius As Single, _
   ByVal endAngle As Single _
)
[C#]
public void Pie(
   float radius,
   float endAngle
);
[C++]
public: void Pie(
   float radius,
   float endAngle
)
[C++/CLI]
public:
void Pie(
   float radius,
   float endAngle
)

Parameters

radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.

See Also

Draw Class | Draw Members | Overload List


Pie(PointF,PointF,Single,Single,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

upperLeft
A PointF which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A PointF which represents the upper-right coordinate of the bouding rectangle.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
color of the circle’s outline.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(PointF,PointF,Single,Single,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(PointF,PointF,Single,Single,Color) Method

Draws a pie-shaped wedge on a printer.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal upperLeft As PointF, _
   ByVal lowerRight As PointF, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
[C#]
public void Pie(
   PointF upperLeft,
   PointF lowerRight,
   float startAngle,
   float endAngle,
   Color color
);
[C++]
public: void Pie(
   PointF upperLeft,
   PointF lowerRight,
   float startAngle,
   float endAngle,
   Color color
)
[C++/CLI]
public:
void Pie(
   PointF upperLeft,
   PointF lowerRight,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

upperLeft
A PointF which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A PointF which represents the upper-right coordinate of the bouding rectangle.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
color of the circle’s outline.

See Also

Draw Class | Draw Members | Overload List


Pie(RectangleF,Single,Single,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
The bounding RectangleF of the circle.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
The Color of the slice.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(RectangleF,Single,Single,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(RectangleF,Single,Single,Color) Method

Draws part of a circle.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal boundingBox As RectangleF, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
[C#]
public void Pie(
   RectangleF boundingBox,
   float startAngle,
   float endAngle,
   Color color
);
[C++]
public: void Pie(
   RectangleF boundingBox,
   float startAngle,
   float endAngle,
   Color color
)
[C++/CLI]
public:
void Pie(
   RectangleF boundingBox,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

boundingBox
The bounding RectangleF of the circle.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
The Color of the slice.

See Also

Draw Class | Draw Members | Overload List


Pie(PointF,PointF,Single,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

upperLeft
A PointF which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A PointF which represents the upper-right coordinate of the bouding rectangle.
endAngle
Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
color of the circle’s outline.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(PointF,PointF,Single,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(PointF,PointF,Single,Color) Method

Draws a pie-shaped wedge on a printer.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal upperLeft As PointF, _
   ByVal lowerRight As PointF, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
[C#]
public void Pie(
   PointF upperLeft,
   PointF lowerRight,
   float endAngle,
   Color color
);
[C++]
public: void Pie(
   PointF upperLeft,
   PointF lowerRight,
   float endAngle,
   Color color
)
[C++/CLI]
public:
void Pie(
   PointF upperLeft,
   PointF lowerRight,
   float endAngle,
   Color color
)

Parameters

upperLeft
A PointF which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A PointF which represents the upper-right coordinate of the bouding rectangle.
endAngle
Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
color of the circle’s outline.

See Also

Draw Class | Draw Members | Overload List


Pie(RectangleF,Single,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
The bounding RectangleF of the circle.
endAngle
A single value which represents the ending angle of the slice.
color
The Color of the circle’s outline.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(RectangleF,Single,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(RectangleF,Single,Color) Method

Draws part of a circle.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal boundingBox As RectangleF, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
[C#]
public void Pie(
   RectangleF boundingBox,
   float endAngle,
   Color color
);
[C++]
public: void Pie(
   RectangleF boundingBox,
   float endAngle,
   Color color
)
[C++/CLI]
public:
void Pie(
   RectangleF boundingBox,
   float endAngle,
   Color color
)

Parameters

boundingBox
The bounding RectangleF of the circle.
endAngle
A single value which represents the ending angle of the slice.
color
The Color of the circle’s outline.

See Also

Draw Class | Draw Members | Overload List


Pie(PointF,PointF,Single,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

upperLeft
A PointF which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A PointF which represents the upper-right coordinate of the bouding rectangle.
startAngle
A Single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(PointF,PointF,Single,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(PointF,PointF,Single,Single) Method

Draws a black pie-shaped wedge on a printer.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal upperLeft As PointF, _
   ByVal lowerRight As PointF, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
[C#]
public void Pie(
   PointF upperLeft,
   PointF lowerRight,
   float startAngle,
   float endAngle
);
[C++]
public: void Pie(
   PointF upperLeft,
   PointF lowerRight,
   float startAngle,
   float endAngle
)
[C++/CLI]
public:
void Pie(
   PointF upperLeft,
   PointF lowerRight,
   float startAngle,
   float endAngle
)

Parameters

upperLeft
A PointF which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A PointF which represents the upper-right coordinate of the bouding rectangle.
startAngle
A Single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Draw Class | Draw Members | Overload List


Pie(RectangleF,Single,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
The bounding Rectangle of the circle.
startAngle
A Single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(RectangleF,Single,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(RectangleF,Single,Single) Method

Draws part of a circle.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal boundingBox As RectangleF, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
[C#]
public void Pie(
   RectangleF boundingBox,
   float startAngle,
   float endAngle
);
[C++]
public: void Pie(
   RectangleF boundingBox,
   float startAngle,
   float endAngle
)
[C++/CLI]
public:
void Pie(
   RectangleF boundingBox,
   float startAngle,
   float endAngle
)

Parameters

boundingBox
The bounding Rectangle of the circle.
startAngle
A Single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Draw Class | Draw Members | Overload List


Pie(PointF,PointF,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

upperLeft
A PointF which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A PointF which represents the upper-right coordinate of the bouding rectangle.
endAngle
A Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(PointF,PointF,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(PointF,PointF,Single) Method

Draws a black pie-shaped wedge on a printer.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal upperLeft As PointF, _
   ByVal lowerRight As PointF, _
   ByVal endAngle As Single _
)
[C#]
public void Pie(
   PointF upperLeft,
   PointF lowerRight,
   float endAngle
);
[C++]
public: void Pie(
   PointF upperLeft,
   PointF lowerRight,
   float endAngle
)
[C++/CLI]
public:
void Pie(
   PointF upperLeft,
   PointF lowerRight,
   float endAngle
)

Parameters

upperLeft
A PointF which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A PointF which represents the upper-right coordinate of the bouding rectangle.
endAngle
A Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Draw Class | Draw Members | Overload List


Pie(RectangleF,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
The bounding Rectangle of the circle.
endAngle
A Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(RectangleF,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(RectangleF,Single) Method

Draws part of a circle.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal boundingBox As RectangleF, _
   ByVal endAngle As Single _
)
[C#]
public void Pie(
   RectangleF boundingBox,
   float endAngle
);
[C++]
public: void Pie(
   RectangleF boundingBox,
   float endAngle
)
[C++/CLI]
public:
void Pie(
   RectangleF boundingBox,
   float endAngle
)

Parameters

boundingBox
The bounding Rectangle of the circle.
endAngle
A Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Draw Class | Draw Members | Overload List


Pie(Point,Int32,Single,Single,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

location
A Point which represents the location of the center of the circle of the pie slice.
radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
The Color of the slice.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(Point,Int32,Single,Single,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(Point,Int32,Single,Single,Color) Method

Draws part of a circle.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal location As Point, _
   ByVal radius As Integer, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
[C#]
public void Pie(
   Point location,
   int radius,
   float startAngle,
   float endAngle,
   Color color
);
[C++]
public: void Pie(
   Point location,
   int radius,
   float startAngle,
   float endAngle,
   Color color
)
[C++/CLI]
public:
void Pie(
   Point location,
   int radius,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

location
A Point which represents the location of the center of the circle of the pie slice.
radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
The Color of the slice.

See Also

Draw Class | Draw Members | Overload List


Pie(Point,Int32,Single,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

location
A Point which represents the location of the center of the circle of the pie slice.
radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.
color
The Color of the slice.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(Point,Int32,Single,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(Point,Int32,Single,Color) Method

Draws part of a circle.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal location As Point, _
   ByVal radius As Integer, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
[C#]
public void Pie(
   Point location,
   int radius,
   float endAngle,
   Color color
);
[C++]
public: void Pie(
   Point location,
   int radius,
   float endAngle,
   Color color
)
[C++/CLI]
public:
void Pie(
   Point location,
   int radius,
   float endAngle,
   Color color
)

Parameters

location
A Point which represents the location of the center of the circle of the pie slice.
radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.
color
The Color of the slice.

See Also

Draw Class | Draw Members | Overload List


Pie(Int32,Single,Single,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
The Color of the slice.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(Int32,Single,Single,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(Int32,Single,Single,Color) Method

Draws part of a circle.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal radius As Integer, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
[C#]
public void Pie(
   int radius,
   float startAngle,
   float endAngle,
   Color color
);
[C++]
public: void Pie(
   int radius,
   float startAngle,
   float endAngle,
   Color color
)
[C++/CLI]
public:
void Pie(
   int radius,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
The Color of the slice.

See Also

Draw Class | Draw Members | Overload List


Pie(Int32,Single,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.
color
The Color of the slice.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(Int32,Single,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(Int32,Single,Color) Method

Draws part of a circle.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal radius As Integer, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
[C#]
public void Pie(
   int radius,
   float endAngle,
   Color color
);
[C++]
public: void Pie(
   int radius,
   float endAngle,
   Color color
)
[C++/CLI]
public:
void Pie(
   int radius,
   float endAngle,
   Color color
)

Parameters

radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.
color
The Color of the slice.

See Also

Draw Class | Draw Members | Overload List


Pie(Point,Int32,Single,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

location
A Point which represents the location of the center of the circle of the pie slice.
radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(Point,Int32,Single,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(Point,Int32,Single,Single) Method

Draws part of a circle.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal location As Point, _
   ByVal radius As Integer, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
[C#]
public void Pie(
   Point location,
   int radius,
   float startAngle,
   float endAngle
);
[C++]
public: void Pie(
   Point location,
   int radius,
   float startAngle,
   float endAngle
)
[C++/CLI]
public:
void Pie(
   Point location,
   int radius,
   float startAngle,
   float endAngle
)

Parameters

location
A Point which represents the location of the center of the circle of the pie slice.
radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.

See Also

Draw Class | Draw Members | Overload List


Pie(Point,Int32,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

location
A Point which represents the location of the center of the circle of the pie slice.
radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(Point,Int32,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(Point,Int32,Single) Method

Draws part of a circle.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal location As Point, _
   ByVal radius As Integer, _
   ByVal endAngle As Single _
)
[C#]
public void Pie(
   Point location,
   int radius,
   float endAngle
);
[C++]
public: void Pie(
   Point location,
   int radius,
   float endAngle
)
[C++/CLI]
public:
void Pie(
   Point location,
   int radius,
   float endAngle
)

Parameters

location
A Point which represents the location of the center of the circle of the pie slice.
radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.

See Also

Draw Class | Draw Members | Overload List


Pie(Int32,Single,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(Int32,Single,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(Int32,Single,Single) Method

Draws part of a circle.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal radius As Integer, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
[C#]
public void Pie(
   int radius,
   float startAngle,
   float endAngle
);
[C++]
public: void Pie(
   int radius,
   float startAngle,
   float endAngle
)
[C++/CLI]
public:
void Pie(
   int radius,
   float startAngle,
   float endAngle
)

Parameters

radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.

See Also

Draw Class | Draw Members | Overload List


Pie(Int32,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(Int32,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(Int32,Single) Method

Draws part of a circle.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal radius As Integer, _
   ByVal endAngle As Single _
)
[C#]
public void Pie(
   int radius,
   float endAngle
);
[C++]
public: void Pie(
   int radius,
   float endAngle
)
[C++/CLI]
public:
void Pie(
   int radius,
   float endAngle
)

Parameters

radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.

See Also

Draw Class | Draw Members | Overload List


Pie(Point,Point,Single,Single,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

upperLeft
A Point which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A Point which represents the upper-right coordinate of the bouding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
The Color of the circle’s outline.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(Point,Point,Single,Single,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(Point,Point,Single,Single,Color) Method

Draws a pie-shaped wedge on a printer.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal upperLeft As Point, _
   ByVal lowerRight As Point, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
[C#]
public void Pie(
   Point upperLeft,
   Point lowerRight,
   float startAngle,
   float endAngle,
   Color color
);
[C++]
public: void Pie(
   Point upperLeft,
   Point lowerRight,
   float startAngle,
   float endAngle,
   Color color
)
[C++/CLI]
public:
void Pie(
   Point upperLeft,
   Point lowerRight,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

upperLeft
A Point which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A Point which represents the upper-right coordinate of the bouding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
The Color of the circle’s outline.

See Also

Draw Class | Draw Members | Overload List


Pie(Rectangle,Single,Single,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
The bounding A Rectangle of the circle.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
The Color of the slice.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(Rectangle,Single,Single,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(Rectangle,Single,Single,Color) Method

Draws part of a circle.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal boundingBox As Rectangle, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
[C#]
public void Pie(
   Rectangle boundingBox,
   float startAngle,
   float endAngle,
   Color color
);
[C++]
public: void Pie(
   Rectangle boundingBox,
   float startAngle,
   float endAngle,
   Color color
)
[C++/CLI]
public:
void Pie(
   Rectangle boundingBox,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

boundingBox
The bounding A Rectangle of the circle.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
The Color of the slice.

See Also

Draw Class | Draw Members | Overload List


Pie(Point,Point,Single,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

upperLeft
A Point which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A Point which represents the upper-right coordinate of the bouding rectangle.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
The Color of the circle’s outline.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(Point,Point,Single,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(Point,Point,Single,Color) Method

Draws a pie-shaped wedge on a printer.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal upperLeft As Point, _
   ByVal lowerRight As Point, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
[C#]
public void Pie(
   Point upperLeft,
   Point lowerRight,
   float endAngle,
   Color color
);
[C++]
public: void Pie(
   Point upperLeft,
   Point lowerRight,
   float endAngle,
   Color color
)
[C++/CLI]
public:
void Pie(
   Point upperLeft,
   Point lowerRight,
   float endAngle,
   Color color
)

Parameters

upperLeft
A Point which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A Point which represents the upper-right coordinate of the bouding rectangle.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
The Color of the circle’s outline.

See Also

Draw Class | Draw Members | Overload List


Pie(Rectangle,Single,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
The bounding A Rectangle of the circle.
endAngle
A single value which represents the ending angle of the slice.
color
The Color of the slice.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(Rectangle,Single,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(Rectangle,Single,Color) Method

Draws part of a circle.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal boundingBox As Rectangle, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
[C#]
public void Pie(
   Rectangle boundingBox,
   float endAngle,
   Color color
);
[C++]
public: void Pie(
   Rectangle boundingBox,
   float endAngle,
   Color color
)
[C++/CLI]
public:
void Pie(
   Rectangle boundingBox,
   float endAngle,
   Color color
)

Parameters

boundingBox
The bounding A Rectangle of the circle.
endAngle
A single value which represents the ending angle of the slice.
color
The Color of the slice.

See Also

Draw Class | Draw Members | Overload List


Pie(Point,Point,Single,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

upperLeft
A Point which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A Point which represents the upper-right coordinate of the bouding rectangle.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(Point,Point,Single,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(Point,Point,Single,Single) Method

Draws a black pie-shaped wedge on a printer.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal upperLeft As Point, _
   ByVal lowerRight As Point, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
[C#]
public void Pie(
   Point upperLeft,
   Point lowerRight,
   float startAngle,
   float endAngle
);
[C++]
public: void Pie(
   Point upperLeft,
   Point lowerRight,
   float startAngle,
   float endAngle
)
[C++/CLI]
public:
void Pie(
   Point upperLeft,
   Point lowerRight,
   float startAngle,
   float endAngle
)

Parameters

upperLeft
A Point which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A Point which represents the upper-right coordinate of the bouding rectangle.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Draw Class | Draw Members | Overload List


Pie(Rectangle,Single,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
The bounding A Rectangle of the circle.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(Rectangle,Single,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(Rectangle,Single,Single) Method

Draws part of a circle.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal boundingBox As Rectangle, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
[C#]
public void Pie(
   Rectangle boundingBox,
   float startAngle,
   float endAngle
);
[C++]
public: void Pie(
   Rectangle boundingBox,
   float startAngle,
   float endAngle
)
[C++/CLI]
public:
void Pie(
   Rectangle boundingBox,
   float startAngle,
   float endAngle
)

Parameters

boundingBox
The bounding A Rectangle of the circle.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Draw Class | Draw Members | Overload List


Pie(Point,Point,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

upperLeft
A Point which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A Point which represents the upper-right coordinate of the bouding rectangle.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(Point,Point,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(Point,Point,Single) Method

Draws a black pie-shaped wedge on a printer.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal upperLeft As Point, _
   ByVal lowerRight As Point, _
   ByVal endAngle As Single _
)
[C#]
public void Pie(
   Point upperLeft,
   Point lowerRight,
   float endAngle
);
[C++]
public: void Pie(
   Point upperLeft,
   Point lowerRight,
   float endAngle
)
[C++/CLI]
public:
void Pie(
   Point upperLeft,
   Point lowerRight,
   float endAngle
)

Parameters

upperLeft
A Point which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A Point which represents the upper-right coordinate of the bouding rectangle.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Draw Class | Draw Members | Overload List


Pie(Rectangle,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
The bounding A Rectangle of the circle.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pie(Rectangle,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Pie Method : Pie(Rectangle,Single) Method

Draws part of a circle.

[Visual Basic]
Overloads Public Sub Pie( _
   ByVal boundingBox As Rectangle, _
   ByVal endAngle As Single _
)
[C#]
public void Pie(
   Rectangle boundingBox,
   float endAngle
);
[C++]
public: void Pie(
   Rectangle boundingBox,
   float endAngle
)
[C++/CLI]
public:
void Pie(
   Rectangle boundingBox,
   float endAngle
)

Parameters

boundingBox
The bounding A Rectangle of the circle.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Draw Class | Draw Members | Overload List


Polygon Method

Draw Class | Draw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Polygon Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class : Polygon Method

Draws a 3-6 sided polygon on a printer.

Overload List

Draws a 3-6 sided polygon on a printer.

[Visual Basic] Overloads Public Sub Polygon(PointF(),Color)

[C#] public void Polygon(PointF[],Color);

[C++] public void Polygon(PointF[]*,Color);

[C++/CLI] public void Polygon(PointFarray<points>^,Color);

Draws a 3-6 sided polygon on a printer.

[Visual Basic] Overloads Public Sub Polygon(PointF())

[C#] public void Polygon(PointF[]);

[C++] public void Polygon(PointF[]*);

[C++/CLI] public void Polygon(PointFarray<points>^);

Draws a 3-6 sided polygon on a printer.

[Visual Basic] Overloads Public Sub Polygon(Point(),Color)

[C#] public void Polygon(Point[],Color);

[C++] public void Polygon(Point[]*,Color);

[C++/CLI] public void Polygon(Pointarray<points>^,Color);

Draws a 3-6 sided polygon on a printer.

[Visual Basic] Overloads Public Sub Polygon(Point())

[C#] public void Polygon(Point[]);

[C++] public void Polygon(Point[]*);

[C++/CLI] public void Polygon(Pointarray<points>^);

See Also

Draw Class | Draw Members


Polygon(PointF[],Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

points
A PointF value which represents the coordinates for a polygon.
color
The Color of the polygon’s outline.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Polygon(PointF[],Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Polygon Method : Polygon(PointF[],Color) Method

Draws a 3-6 sided polygon on a printer.

[Visual Basic]
Overloads Public Sub Polygon( _
   ByVal points() As PointF, _
   ByVal color As Color _
)
[C#]
public void Polygon(
   PointF[] points,
   Color color
);
[C++]
public: void Polygon(
   PointF[]* points,
   Color color
)
[C++/CLI]
public:
void Polygon(
   PointFarray<points>^ points,
   Color color
)

Parameters

points
A PointF value which represents the coordinates for a polygon.
color
The Color of the polygon’s outline.

Remarks

The coordinates of the polygon must be within the physical area of the printer. To fill a polygon, set the FillColor and FillStyle properties of the object on which the polygon is drawn. Specify as many coordinates as needed to define the polygon (3 for a triangle, 4 for a square, etc.) The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

See Also

Draw Class | Draw Members | Overload List


Polygon(PointF[]) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

points
A PointF value which represents the coordinates for a polygon.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Polygon(PointF[]) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Polygon Method : Polygon(PointF[]) Method

Draws a 3-6 sided polygon on a printer.

[Visual Basic]
Overloads Public Sub Polygon( _
   ByVal points() As PointF _
)
[C#]
public void Polygon(
   PointF[] points
);
[C++]
public: void Polygon(
   PointF[]* points
)
[C++/CLI]
public:
void Polygon(
   PointFarray<points>^ points
)

Parameters

points
A PointF value which represents the coordinates for a polygon.

Remarks

The coordinates of the polygon must be within the physical area of the printer. To fill a polygon, set the FillColor and FillStyle properties of the object on which the polygon is drawn. Specify as many coordinates as needed to define the polygon (3 for a triangle, 4 for a square, etc.) The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

See Also

Draw Class | Draw Members | Overload List


Polygon(Point[],Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

points
A Point value which represents the coordinates for a polygon.
color
The Color of the polygon’s outline.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Polygon(Point[],Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Polygon Method : Polygon(Point[],Color) Method

Draws a 3-6 sided polygon on a printer.

[Visual Basic]
Overloads Public Sub Polygon( _
   ByVal points() As Point, _
   ByVal color As Color _
)
[C#]
public void Polygon(
   Point[] points,
   Color color
);
[C++]
public: void Polygon(
   Point[]* points,
   Color color
)
[C++/CLI]
public:
void Polygon(
   Pointarray<points>^ points,
   Color color
)

Parameters

points
A Point value which represents the coordinates for a polygon.
color
The Color of the polygon’s outline.

Remarks

The coordinates of the polygon must be within the physical area of the printer. To fill a polygon, set the FillColor and FillStyle properties of the object on which the polygon is drawn. Specify as many coordinates as needed to define the polygon (3 for a triangle, 4 for a square, etc.) The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

See Also

Draw Class | Draw Members | Overload List


Polygon(Point[]) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

points
A Point value which represents the coordinates for a polygon.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Polygon(Point[]) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Polygon Method : Polygon(Point[]) Method

Draws a 3-6 sided polygon on a printer.

[Visual Basic]
Overloads Public Sub Polygon( _
   ByVal points() As Point _
)
[C#]
public void Polygon(
   Point[] points
);
[C++]
public: void Polygon(
   Point[]* points
)
[C++/CLI]
public:
void Polygon(
   Pointarray<points>^ points
)

Parameters

points
A Point value which represents the coordinates for a polygon.

Remarks

The coordinates of the polygon must be within the physical area of the printer. To fill a polygon, set the FillColor and FillStyle properties of the object on which the polygon is drawn. Specify as many coordinates as needed to define the polygon (3 for a triangle, 4 for a square, etc.) The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

See Also

Draw Class | Draw Members | Overload List


Rectangle Method

Draw Class | Draw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Rectangle Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class : Rectangle Method

Draws a rectangle on a printer.

Overload List

Draws a rectangle on a printer.

[Visual Basic] Overloads Public Sub Rectangle(PointF,PointF,Color,Boolean)

[C#] public void Rectangle(PointF,PointF,Color,bool);

[C++] public void Rectangle(PointF,PointF,Color,bool);

[C++/CLI] public void Rectangle(PointF,PointF,Color,bool);

Draws a rectangle on a printer.

[Visual Basic] Overloads Public Sub Rectangle(RectangleF,Color,Boolean)

[C#] public void Rectangle(RectangleF,Color,bool);

[C++] public void Rectangle(RectangleF,Color,bool);

[C++/CLI] public void Rectangle(RectangleF,Color,bool);

Draws a rectangle on a printer.

[Visual Basic] Overloads Public Sub Rectangle(PointF,PointF,Color)

[C#] public void Rectangle(PointF,PointF,Color);

[C++] public void Rectangle(PointF,PointF,Color);

[C++/CLI] public void Rectangle(PointF,PointF,Color);

Draws a rectangle on a printer.

[Visual Basic] Overloads Public Sub Rectangle(RectangleF,Color)

[C#] public void Rectangle(RectangleF,Color);

[C++] public void Rectangle(RectangleF,Color);

[C++/CLI] public void Rectangle(RectangleF,Color);

Draws a black rectangle on a printer.

[Visual Basic] Overloads Public Sub Rectangle(PointF,PointF,Boolean)

[C#] public void Rectangle(PointF,PointF,bool);

[C++] public void Rectangle(PointF,PointF,bool);

[C++/CLI] public void Rectangle(PointF,PointF,bool);

Draws a black rectangle on a printer.

[Visual Basic] Overloads Public Sub Rectangle(RectangleF,Boolean)

[C#] public void Rectangle(RectangleF,bool);

[C++] public void Rectangle(RectangleF,bool);

[C++/CLI] public void Rectangle(RectangleF,bool);

Draws a black rectangle on a printer.

[Visual Basic] Overloads Public Sub Rectangle(PointF,PointF)

[C#] public void Rectangle(PointF,PointF);

[C++] public void Rectangle(PointF,PointF);

[C++/CLI] public void Rectangle(PointF,PointF);

Draws a black rectangle on a printer.

[Visual Basic] Overloads Public Sub Rectangle(RectangleF)

[C#] public void Rectangle(RectangleF);

[C++] public void Rectangle(RectangleF);

[C++/CLI] public void Rectangle(RectangleF);

Draws a rectangle on a printer starting at the current draw location.

[Visual Basic] Overloads Public Sub Rectangle(PointF,Color,Boolean)

[C#] public void Rectangle(PointF,Color,bool);

[C++] public void Rectangle(PointF,Color,bool);

[C++/CLI] public void Rectangle(PointF,Color,bool);

Draws a rectangle on a printer starting at the current draw coordinate.

[Visual Basic] Overloads Public Sub Rectangle(PointF,Color)

[C#] public void Rectangle(PointF,Color);

[C++] public void Rectangle(PointF,Color);

[C++/CLI] public void Rectangle(PointF,Color);

Draws a black rectangle on a printer starting at the current draw coordinate.

[Visual Basic] Overloads Public Sub Rectangle(PointF,Boolean)

[C#] public void Rectangle(PointF,bool);

[C++] public void Rectangle(PointF,bool);

[C++/CLI] public void Rectangle(PointF,bool);

Draws a black rectangle on a printer starting from the current draw coordinate.

[Visual Basic] Overloads Public Sub Rectangle(PointF)

[C#] public void Rectangle(PointF);

[C++] public void Rectangle(PointF);

[C++/CLI] public void Rectangle(PointF);

Draws a rectangle on a printer.

[Visual Basic] Overloads Public Sub Rectangle(Point,Point,Color,Boolean)

[C#] public void Rectangle(Point,Point,Color,bool);

[C++] public void Rectangle(Point,Point,Color,bool);

[C++/CLI] public void Rectangle(Point,Point,Color,bool);

Draws a rectangle on a printer.

[Visual Basic] Overloads Public Sub Rectangle(Rectangle,Color,Boolean)

[C#] public void Rectangle(Rectangle,Color,bool);

[C++] public void Rectangle(Rectangle,Color,bool);

[C++/CLI] public void Rectangle(Rectangle,Color,bool);

Draws a rectangle on a printer.

[Visual Basic] Overloads Public Sub Rectangle(Point,Point,Color)

[C#] public void Rectangle(Point,Point,Color);

[C++] public void Rectangle(Point,Point,Color);

[C++/CLI] public void Rectangle(Point,Point,Color);

Draws a rectangle on a printer.

[Visual Basic] Overloads Public Sub Rectangle(Rectangle,Color)

[C#] public void Rectangle(Rectangle,Color);

[C++] public void Rectangle(Rectangle,Color);

[C++/CLI] public void Rectangle(Rectangle,Color);

Draws a black rectangle on a printer.

[Visual Basic] Overloads Public Sub Rectangle(Point,Point,Boolean)

[C#] public void Rectangle(Point,Point,bool);

[C++] public void Rectangle(Point,Point,bool);

[C++/CLI] public void Rectangle(Point,Point,bool);

Draws a black rectangle on a printer.

[Visual Basic] Overloads Public Sub Rectangle(Rectangle,Boolean)

[C#] public void Rectangle(Rectangle,bool);

[C++] public void Rectangle(Rectangle,bool);

[C++/CLI] public void Rectangle(Rectangle,bool);

Draws a black rectangle on a printer.

[Visual Basic] Overloads Public Sub Rectangle(Point,Point)

[C#] public void Rectangle(Point,Point);

[C++] public void Rectangle(Point,Point);

[C++/CLI] public void Rectangle(Point,Point);

Draws a black rectangle on a printer.

[Visual Basic] Overloads Public Sub Rectangle(Rectangle)

[C#] public void Rectangle(Rectangle);

[C++] public void Rectangle(Rectangle);

[C++/CLI] public void Rectangle(Rectangle);

Draws a rectangle on a printer starting at the current draw location.

[Visual Basic] Overloads Public Sub Rectangle(Point,Color,Boolean)

[C#] public void Rectangle(Point,Color,bool);

[C++] public void Rectangle(Point,Color,bool);

[C++/CLI] public void Rectangle(Point,Color,bool);

Draws a rectangle on a printer starting at the current draw coordinate.

[Visual Basic] Overloads Public Sub Rectangle(Point,Color)

[C#] public void Rectangle(Point,Color);

[C++] public void Rectangle(Point,Color);

[C++/CLI] public void Rectangle(Point,Color);

Draws a black rectangle on a printer starting at the current draw coordinate.

[Visual Basic] Overloads Public Sub Rectangle(Point,Boolean)

[C#] public void Rectangle(Point,bool);

[C++] public void Rectangle(Point,bool);

[C++/CLI] public void Rectangle(Point,bool);

Draws a black rectangle on a printer starting from the current draw coordinate.

[Visual Basic] Overloads Public Sub Rectangle(Point)

[C#] public void Rectangle(Point);

[C++] public void Rectangle(Point);

[C++/CLI] public void Rectangle(Point);

See Also

Draw Class | Draw Members


Rectangle(PointF,PointF,Color,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
A Point which represents the coordinate of the starting point for the rectangle.
endPoint
A Point which represents the coordinate of the end point for the rectangle being drawn.
color
The Color used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Rectangle(PointF,PointF,Color,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Rectangle Method : Rectangle(PointF,PointF,Color,Boolean) Method

Draws a rectangle on a printer.

[Visual Basic]
Overloads Public Sub Rectangle( _
   ByVal startPoint As PointF, _
   ByVal endPoint As PointF, _
   ByVal color As Color, _
   ByVal fill As Boolean _
)
[C#]
public void Rectangle(
   PointF startPoint,
   PointF endPoint,
   Color color,
   bool fill
);
[C++]
public: void Rectangle(
   PointF startPoint,
   PointF endPoint,
   Color color,
   bool fill
)
[C++/CLI]
public:
void Rectangle(
   PointF startPoint,
   PointF endPoint,
   Color color,
   bool fill
)

Parameters

startPoint
A Point which represents the coordinate of the starting point for the rectangle.
endPoint
A Point which represents the coordinate of the end point for the rectangle being drawn.
color
The Color used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

See Also

Draw Class | Draw Members | Overload List


Rectangle(RectangleF,Color,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
A RectangleF which represents the coordinates used to draw the rectangle.
color
The Color used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Rectangle(RectangleF,Color,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Rectangle Method : Rectangle(RectangleF,Color,Boolean) Method

Draws a rectangle on a printer.

[Visual Basic]
Overloads Public Sub Rectangle( _
   ByVal boundingBox As RectangleF, _
   ByVal color As Color, _
   ByVal fill As Boolean _
)
[C#]
public void Rectangle(
   RectangleF boundingBox,
   Color color,
   bool fill
);
[C++]
public: void Rectangle(
   RectangleF boundingBox,
   Color color,
   bool fill
)
[C++/CLI]
public:
void Rectangle(
   RectangleF boundingBox,
   Color color,
   bool fill
)

Parameters

boundingBox
A RectangleF which represents the coordinates used to draw the rectangle.
color
The Color used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

See Also

Draw Class | Draw Members | Overload List


Rectangle(PointF,PointF,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
A PointF which represents the coordinate of the starting point for the rectangle.
endPoint
A PointF which represents the coordinate of the end point for the rectangle being drawn.
color
The Color used to draw the rectangle.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Rectangle(PointF,PointF,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Rectangle Method : Rectangle(PointF,PointF,Color) Method

Draws a rectangle on a printer.

[Visual Basic]
Overloads Public Sub Rectangle( _
   ByVal startPoint As PointF, _
   ByVal endPoint As PointF, _
   ByVal color As Color _
)
[C#]
public void Rectangle(
   PointF startPoint,
   PointF endPoint,
   Color color
);
[C++]
public: void Rectangle(
   PointF startPoint,
   PointF endPoint,
   Color color
)
[C++/CLI]
public:
void Rectangle(
   PointF startPoint,
   PointF endPoint,
   Color color
)

Parameters

startPoint
A PointF which represents the coordinate of the starting point for the rectangle.
endPoint
A PointF which represents the coordinate of the end point for the rectangle being drawn.
color
The Color used to draw the rectangle.

See Also

Draw Class | Draw Members | Overload List


Rectangle(RectangleF,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
A RectangleF which represents the coordinates used to draw the rectangle.
color
The Color used to draw the rectangle.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Rectangle(RectangleF,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Rectangle Method : Rectangle(RectangleF,Color) Method

Draws a rectangle on a printer.

[Visual Basic]
Overloads Public Sub Rectangle( _
   ByVal boundingBox As RectangleF, _
   ByVal color As Color _
)
[C#]
public void Rectangle(
   RectangleF boundingBox,
   Color color
);
[C++]
public: void Rectangle(
   RectangleF boundingBox,
   Color color
)
[C++/CLI]
public:
void Rectangle(
   RectangleF boundingBox,
   Color color
)

Parameters

boundingBox
A RectangleF which represents the coordinates used to draw the rectangle.
color
The Color used to draw the rectangle.

See Also

Draw Class | Draw Members | Overload List


Rectangle(PointF,PointF,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
A PointF which represents the coordinate of the starting point for the rectangle.
endPoint
A PointF which represents the coordinate of the end point for the rectangle being drawn.
fill
A boolean value which when true, the black is used to fill the rectangle and the FillColor and FillStyle properties are ignored.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Rectangle(PointF,PointF,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Rectangle Method : Rectangle(PointF,PointF,Boolean) Method

Draws a black rectangle on a printer.

[Visual Basic]
Overloads Public Sub Rectangle( _
   ByVal startPoint As PointF, _
   ByVal endPoint As PointF, _
   ByVal fill As Boolean _
)
[C#]
public void Rectangle(
   PointF startPoint,
   PointF endPoint,
   bool fill
);
[C++]
public: void Rectangle(
   PointF startPoint,
   PointF endPoint,
   bool fill
)
[C++/CLI]
public:
void Rectangle(
   PointF startPoint,
   PointF endPoint,
   bool fill
)

Parameters

startPoint
A PointF which represents the coordinate of the starting point for the rectangle.
endPoint
A PointF which represents the coordinate of the end point for the rectangle being drawn.
fill
A boolean value which when true, the black is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

See Also

Draw Class | Draw Members | Overload List


Rectangle(RectangleF,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
A RectangleF which represents the coordinates used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Rectangle(RectangleF,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Rectangle Method : Rectangle(RectangleF,Boolean) Method

Draws a black rectangle on a printer.

[Visual Basic]
Overloads Public Sub Rectangle( _
   ByVal boundingBox As RectangleF, _
   ByVal fill As Boolean _
)
[C#]
public void Rectangle(
   RectangleF boundingBox,
   bool fill
);
[C++]
public: void Rectangle(
   RectangleF boundingBox,
   bool fill
)
[C++/CLI]
public:
void Rectangle(
   RectangleF boundingBox,
   bool fill
)

Parameters

boundingBox
A RectangleF which represents the coordinates used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

See Also

Draw Class | Draw Members | Overload List


Rectangle(PointF,PointF) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
A PointF which represents the coordinate of the starting point for the rectangle.
endPoint
A PointF which represents the coordinate of the end point for the rectangle being drawn.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Rectangle(PointF,PointF) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Rectangle Method : Rectangle(PointF,PointF) Method

Draws a black rectangle on a printer.

[Visual Basic]
Overloads Public Sub Rectangle( _
   ByVal startPoint As PointF, _
   ByVal endPoint As PointF _
)
[C#]
public void Rectangle(
   PointF startPoint,
   PointF endPoint
);
[C++]
public: void Rectangle(
   PointF startPoint,
   PointF endPoint
)
[C++/CLI]
public:
void Rectangle(
   PointF startPoint,
   PointF endPoint
)

Parameters

startPoint
A PointF which represents the coordinate of the starting point for the rectangle.
endPoint
A PointF which represents the coordinate of the end point for the rectangle being drawn.

See Also

Draw Class | Draw Members | Overload List


Rectangle(RectangleF) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
A Rectangle which represents the coordinates used to draw the rectangle.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Rectangle(RectangleF) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Rectangle Method : Rectangle(RectangleF) Method

Draws a black rectangle on a printer.

[Visual Basic]
Overloads Public Sub Rectangle( _
   ByVal boundingBox As RectangleF _
)
[C#]
public void Rectangle(
   RectangleF boundingBox
);
[C++]
public: void Rectangle(
   RectangleF boundingBox
)
[C++/CLI]
public:
void Rectangle(
   RectangleF boundingBox
)

Parameters

boundingBox
A Rectangle which represents the coordinates used to draw the rectangle.

See Also

Draw Class | Draw Members | Overload List


Rectangle(PointF,Color,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A PointF which represents the coordinate of the end point for the rectangle being drawn.
color
A Color which represents the color used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Rectangle(PointF,Color,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Rectangle Method : Rectangle(PointF,Color,Boolean) Method

Draws a rectangle on a printer starting at the current draw location.

[Visual Basic]
Overloads Public Sub Rectangle( _
   ByVal endPoint As PointF, _
   ByVal color As Color, _
   ByVal fill As Boolean _
)
[C#]
public void Rectangle(
   PointF endPoint,
   Color color,
   bool fill
);
[C++]
public: void Rectangle(
   PointF endPoint,
   Color color,
   bool fill
)
[C++/CLI]
public:
void Rectangle(
   PointF endPoint,
   Color color,
   bool fill
)

Parameters

endPoint
A PointF which represents the coordinate of the end point for the rectangle being drawn.
color
A Color which represents the color used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

See Also

Draw Class | Draw Members | Overload List


Rectangle(PointF,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A PointF which represents the coordinate of the end point for the rectangle being drawn.
color
A Color which represents the color used to draw the rectangle.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Rectangle(PointF,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Rectangle Method : Rectangle(PointF,Color) Method

Draws a rectangle on a printer starting at the current draw coordinate.

[Visual Basic]
Overloads Public Sub Rectangle( _
   ByVal endPoint As PointF, _
   ByVal color As Color _
)
[C#]
public void Rectangle(
   PointF endPoint,
   Color color
);
[C++]
public: void Rectangle(
   PointF endPoint,
   Color color
)
[C++/CLI]
public:
void Rectangle(
   PointF endPoint,
   Color color
)

Parameters

endPoint
A PointF which represents the coordinate of the end point for the rectangle being drawn.
color
A Color which represents the color used to draw the rectangle.

See Also

Draw Class | Draw Members | Overload List


Rectangle(PointF,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A PointF which represents the coordinate of the end point for the rectangle being drawn.
fill
A boolean value which when true, the black is used to fill the rectangle and the FillColor and FillStyle properties are ignored.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Rectangle(PointF,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Rectangle Method : Rectangle(PointF,Boolean) Method

Draws a black rectangle on a printer starting at the current draw coordinate.

[Visual Basic]
Overloads Public Sub Rectangle( _
   ByVal endPoint As PointF, _
   ByVal fill As Boolean _
)
[C#]
public void Rectangle(
   PointF endPoint,
   bool fill
);
[C++]
public: void Rectangle(
   PointF endPoint,
   bool fill
)
[C++/CLI]
public:
void Rectangle(
   PointF endPoint,
   bool fill
)

Parameters

endPoint
A PointF which represents the coordinate of the end point for the rectangle being drawn.
fill
A boolean value which when true, the black is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

See Also

Draw Class | Draw Members | Overload List


Rectangle(PointF) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A PointF which represents the coordinate of the end point for the rectangle being drawn.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Rectangle(PointF) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Rectangle Method : Rectangle(PointF) Method

Draws a black rectangle on a printer starting from the current draw coordinate.

[Visual Basic]
Overloads Public Sub Rectangle( _
   ByVal endPoint As PointF _
)
[C#]
public void Rectangle(
   PointF endPoint
);
[C++]
public: void Rectangle(
   PointF endPoint
)
[C++/CLI]
public:
void Rectangle(
   PointF endPoint
)

Parameters

endPoint
A PointF which represents the coordinate of the end point for the rectangle being drawn.

See Also

Draw Class | Draw Members | Overload List


Rectangle(Point,Point,Color,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
A PointF which represents the coordinate of the starting point for the rectangle.
endPoint
A PointF which represents the coordinate of the end point for the rectangle being drawn.
color
A Color which represents the color used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Rectangle(Point,Point,Color,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Rectangle Method : Rectangle(Point,Point,Color,Boolean) Method

Draws a rectangle on a printer.

[Visual Basic]
Overloads Public Sub Rectangle( _
   ByVal startPoint As Point, _
   ByVal endPoint As Point, _
   ByVal color As Color, _
   ByVal fill As Boolean _
)
[C#]
public void Rectangle(
   Point startPoint,
   Point endPoint,
   Color color,
   bool fill
);
[C++]
public: void Rectangle(
   Point startPoint,
   Point endPoint,
   Color color,
   bool fill
)
[C++/CLI]
public:
void Rectangle(
   Point startPoint,
   Point endPoint,
   Color color,
   bool fill
)

Parameters

startPoint
A PointF which represents the coordinate of the starting point for the rectangle.
endPoint
A PointF which represents the coordinate of the end point for the rectangle being drawn.
color
A Color which represents the color used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

See Also

Draw Class | Draw Members | Overload List


Rectangle(Rectangle,Color,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
A Rectangle which represents the coordinates used to draw the rectangle.
color
A Color which represents the color used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Rectangle(Rectangle,Color,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Rectangle Method : Rectangle(Rectangle,Color,Boolean) Method

Draws a rectangle on a printer.

[Visual Basic]
Overloads Public Sub Rectangle( _
   ByVal boundingBox As Rectangle, _
   ByVal color As Color, _
   ByVal fill As Boolean _
)
[C#]
public void Rectangle(
   Rectangle boundingBox,
   Color color,
   bool fill
);
[C++]
public: void Rectangle(
   Rectangle boundingBox,
   Color color,
   bool fill
)
[C++/CLI]
public:
void Rectangle(
   Rectangle boundingBox,
   Color color,
   bool fill
)

Parameters

boundingBox
A Rectangle which represents the coordinates used to draw the rectangle.
color
A Color which represents the color used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

See Also

Draw Class | Draw Members | Overload List


Rectangle(Point,Point,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
A Point which represents the coordinate of the starting point for the rectangle.
endPoint
A Point which represents the coordinate of the end point for the rectangle being drawn.
color
The Color used to draw the rectangle.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Rectangle(Point,Point,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Rectangle Method : Rectangle(Point,Point,Color) Method

Draws a rectangle on a printer.

[Visual Basic]
Overloads Public Sub Rectangle( _
   ByVal startPoint As Point, _
   ByVal endPoint As Point, _
   ByVal color As Color _
)
[C#]
public void Rectangle(
   Point startPoint,
   Point endPoint,
   Color color
);
[C++]
public: void Rectangle(
   Point startPoint,
   Point endPoint,
   Color color
)
[C++/CLI]
public:
void Rectangle(
   Point startPoint,
   Point endPoint,
   Color color
)

Parameters

startPoint
A Point which represents the coordinate of the starting point for the rectangle.
endPoint
A Point which represents the coordinate of the end point for the rectangle being drawn.
color
The Color used to draw the rectangle.

See Also

Draw Class | Draw Members | Overload List


Rectangle(Rectangle,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
A Rectangle which represents the coordinates used to draw the rectangle
color
The Color used to draw the rectangle.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Rectangle(Rectangle,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Rectangle Method : Rectangle(Rectangle,Color) Method

Draws a rectangle on a printer.

[Visual Basic]
Overloads Public Sub Rectangle( _
   ByVal boundingBox As Rectangle, _
   ByVal color As Color _
)
[C#]
public void Rectangle(
   Rectangle boundingBox,
   Color color
);
[C++]
public: void Rectangle(
   Rectangle boundingBox,
   Color color
)
[C++/CLI]
public:
void Rectangle(
   Rectangle boundingBox,
   Color color
)

Parameters

boundingBox
A Rectangle which represents the coordinates used to draw the rectangle
color
The Color used to draw the rectangle.

See Also

Draw Class | Draw Members | Overload List


Rectangle(Point,Point,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
A Point which represents the coordinate of the starting point for the rectangle.
endPoint
A Point which represents the coordinate of the end point for the rectangle being drawn.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Rectangle(Point,Point,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Rectangle Method : Rectangle(Point,Point,Boolean) Method

Draws a black rectangle on a printer.

[Visual Basic]
Overloads Public Sub Rectangle( _
   ByVal startPoint As Point, _
   ByVal endPoint As Point, _
   ByVal fill As Boolean _
)
[C#]
public void Rectangle(
   Point startPoint,
   Point endPoint,
   bool fill
);
[C++]
public: void Rectangle(
   Point startPoint,
   Point endPoint,
   bool fill
)
[C++/CLI]
public:
void Rectangle(
   Point startPoint,
   Point endPoint,
   bool fill
)

Parameters

startPoint
A Point which represents the coordinate of the starting point for the rectangle.
endPoint
A Point which represents the coordinate of the end point for the rectangle being drawn.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

See Also

Draw Class | Draw Members | Overload List


Rectangle(Rectangle,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
A Rectangle which represents the coordinates used to draw the rectangle
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Rectangle(Rectangle,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Rectangle Method : Rectangle(Rectangle,Boolean) Method

Draws a black rectangle on a printer.

[Visual Basic]
Overloads Public Sub Rectangle( _
   ByVal boundingBox As Rectangle, _
   ByVal fill As Boolean _
)
[C#]
public void Rectangle(
   Rectangle boundingBox,
   bool fill
);
[C++]
public: void Rectangle(
   Rectangle boundingBox,
   bool fill
)
[C++/CLI]
public:
void Rectangle(
   Rectangle boundingBox,
   bool fill
)

Parameters

boundingBox
A Rectangle which represents the coordinates used to draw the rectangle
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

See Also

Draw Class | Draw Members | Overload List


Rectangle(Point,Point) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
A Point which represents the coordinate of the starting point for the rectangle.
endPoint
A Point which represents the coordinate of the end point for the rectangle being drawn.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Rectangle(Point,Point) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Rectangle Method : Rectangle(Point,Point) Method

Draws a black rectangle on a printer.

[Visual Basic]
Overloads Public Sub Rectangle( _
   ByVal startPoint As Point, _
   ByVal endPoint As Point _
)
[C#]
public void Rectangle(
   Point startPoint,
   Point endPoint
);
[C++]
public: void Rectangle(
   Point startPoint,
   Point endPoint
)
[C++/CLI]
public:
void Rectangle(
   Point startPoint,
   Point endPoint
)

Parameters

startPoint
A Point which represents the coordinate of the starting point for the rectangle.
endPoint
A Point which represents the coordinate of the end point for the rectangle being drawn.

See Also

Draw Class | Draw Members | Overload List


Rectangle(Rectangle) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
A Rectangle which represents the coordinates used to draw the rectangle
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Rectangle(Rectangle) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Rectangle Method : Rectangle(Rectangle) Method

Draws a black rectangle on a printer.

[Visual Basic]
Overloads Public Sub Rectangle( _
   ByVal boundingBox As Rectangle _
)
[C#]
public void Rectangle(
   Rectangle boundingBox
);
[C++]
public: void Rectangle(
   Rectangle boundingBox
)
[C++/CLI]
public:
void Rectangle(
   Rectangle boundingBox
)

Parameters

boundingBox
A Rectangle which represents the coordinates used to draw the rectangle

See Also

Draw Class | Draw Members | Overload List


Rectangle(Point,Color,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A Point which represents the coordinate of the end point for the rectangle being drawn.
color
The Color used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Rectangle(Point,Color,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Rectangle Method : Rectangle(Point,Color,Boolean) Method

Draws a rectangle on a printer starting at the current draw location.

[Visual Basic]
Overloads Public Sub Rectangle( _
   ByVal endPoint As Point, _
   ByVal color As Color, _
   ByVal fill As Boolean _
)
[C#]
public void Rectangle(
   Point endPoint,
   Color color,
   bool fill
);
[C++]
public: void Rectangle(
   Point endPoint,
   Color color,
   bool fill
)
[C++/CLI]
public:
void Rectangle(
   Point endPoint,
   Color color,
   bool fill
)

Parameters

endPoint
A Point which represents the coordinate of the end point for the rectangle being drawn.
color
The Color used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

See Also

Draw Class | Draw Members | Overload List


Rectangle(Point,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A Point which represents the coordinate of the end point for the rectangle being drawn.
color
The Color used to draw the rectangle.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Rectangle(Point,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Rectangle Method : Rectangle(Point,Color) Method

Draws a rectangle on a printer starting at the current draw coordinate.

[Visual Basic]
Overloads Public Sub Rectangle( _
   ByVal endPoint As Point, _
   ByVal color As Color _
)
[C#]
public void Rectangle(
   Point endPoint,
   Color color
);
[C++]
public: void Rectangle(
   Point endPoint,
   Color color
)
[C++/CLI]
public:
void Rectangle(
   Point endPoint,
   Color color
)

Parameters

endPoint
A Point which represents the coordinate of the end point for the rectangle being drawn.
color
The Color used to draw the rectangle.

See Also

Draw Class | Draw Members | Overload List


Rectangle(Point,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A Point which represents the coordinate of the end point for the rectangle being drawn.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Rectangle(Point,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Rectangle Method : Rectangle(Point,Boolean) Method

Draws a black rectangle on a printer starting at the current draw coordinate.

[Visual Basic]
Overloads Public Sub Rectangle( _
   ByVal endPoint As Point, _
   ByVal fill As Boolean _
)
[C#]
public void Rectangle(
   Point endPoint,
   bool fill
);
[C++]
public: void Rectangle(
   Point endPoint,
   bool fill
)
[C++/CLI]
public:
void Rectangle(
   Point endPoint,
   bool fill
)

Parameters

endPoint
A Point which represents the coordinate of the end point for the rectangle being drawn.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

See Also

Draw Class | Draw Members | Overload List


Rectangle(Point) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A Point which represents the coordinate of the end point for the rectangle being drawn.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Rectangle(Point) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Rectangle Method : Rectangle(Point) Method

Draws a black rectangle on a printer starting from the current draw coordinate.

[Visual Basic]
Overloads Public Sub Rectangle( _
   ByVal endPoint As Point _
)
[C#]
public void Rectangle(
   Point endPoint
);
[C++]
public: void Rectangle(
   Point endPoint
)
[C++/CLI]
public:
void Rectangle(
   Point endPoint
)

Parameters

endPoint
A Point which represents the coordinate of the end point for the rectangle being drawn.

See Also

Draw Class | Draw Members | Overload List


RoundRectangle Method

Draw Class | Draw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

RoundRectangle Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class : RoundRectangle Method

Draws a rectangle with rounded corners on printer.

Overload List

Draws a rectangle with rounded corners on printer.

[Visual Basic] Overloads Public Sub RoundRectangle(PointF,PointF,Single,Color)

[C#] public void RoundRectangle(PointF,PointF,float,Color);

[C++] public void RoundRectangle(PointF,PointF,float,Color);

[C++/CLI] public void RoundRectangle(PointF,PointF,float,Color);

Draws a rectangle with rounded corners on printer.

[Visual Basic] Overloads Public Sub RoundRectangle(RectangleF,Single,Color)

[C#] public void RoundRectangle(RectangleF,float,Color);

[C++] public void RoundRectangle(RectangleF,float,Color);

[C++/CLI] public void RoundRectangle(RectangleF,float,Color);

Draws a rectangle with rounded corners on printer.

[Visual Basic] Overloads Public Sub RoundRectangle(PointF,PointF,Single,Single,Color)

[C#] public void RoundRectangle(PointF,PointF,float,float,Color);

[C++] public void RoundRectangle(PointF,PointF,float,float,Color);

[C++/CLI] public void RoundRectangle(PointF,PointF,float,float,Color);

Draws a rectangle with rounded corners on printer.

[Visual Basic] Overloads Public Sub RoundRectangle(RectangleF,Single,Single,Color)

[C#] public void RoundRectangle(RectangleF,float,float,Color);

[C++] public void RoundRectangle(RectangleF,float,float,Color);

[C++/CLI] public void RoundRectangle(RectangleF,float,float,Color);

Draws a black rectangle with rounded corners on printer.

[Visual Basic] Overloads Public Sub RoundRectangle(PointF,PointF,Single)

[C#] public void RoundRectangle(PointF,PointF,float);

[C++] public void RoundRectangle(PointF,PointF,float);

[C++/CLI] public void RoundRectangle(PointF,PointF,float);

Draws a rectangle with rounded corners on printer.

[Visual Basic] Overloads Public Sub RoundRectangle(RectangleF,Single)

[C#] public void RoundRectangle(RectangleF,float);

[C++] public void RoundRectangle(RectangleF,float);

[C++/CLI] public void RoundRectangle(RectangleF,float);

Draws a black rectangle with rounded corners on printer.

[Visual Basic] Overloads Public Sub RoundRectangle(PointF,PointF,Single,Single)

[C#] public void RoundRectangle(PointF,PointF,float,float);

[C++] public void RoundRectangle(PointF,PointF,float,float);

[C++/CLI] public void RoundRectangle(PointF,PointF,float,float);

Draws a rectangle with rounded corners on printer.

[Visual Basic] Overloads Public Sub RoundRectangle(RectangleF,Single,Single)

[C#] public void RoundRectangle(RectangleF,float,float);

[C++] public void RoundRectangle(RectangleF,float,float);

[C++/CLI] public void RoundRectangle(RectangleF,float,float);

Draws a rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

[Visual Basic] Overloads Public Sub RoundRectangle(Point,Point,Integer,Color)

[C#] public void RoundRectangle(Point,Point,int,Color);

[C++] public void RoundRectangle(Point,Point,int,Color);

[C++/CLI] public void RoundRectangle(Point,Point,int,Color);

Draws a rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

[Visual Basic] Overloads Public Sub RoundRectangle(Rectangle,Integer,Color)

[C#] public void RoundRectangle(Rectangle,int,Color);

[C++] public void RoundRectangle(Rectangle,int,Color);

[C++/CLI] public void RoundRectangle(Rectangle,int,Color);

Draws a rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

[Visual Basic] Overloads Public Sub RoundRectangle(Point,Point,Integer,Integer,Color)

[C#] public void RoundRectangle(Point,Point,int,int,Color);

[C++] public void RoundRectangle(Point,Point,int,int,Color);

[C++/CLI] public void RoundRectangle(Point,Point,int,int,Color);

Draws a rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

[Visual Basic] Overloads Public Sub RoundRectangle(Rectangle,Integer,Integer,Color)

[C#] public void RoundRectangle(Rectangle,int,int,Color);

[C++] public void RoundRectangle(Rectangle,int,int,Color);

[C++/CLI] public void RoundRectangle(Rectangle,int,int,Color);

Draws a black rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

[Visual Basic] Overloads Public Sub RoundRectangle(Point,Point,Integer)

[C#] public void RoundRectangle(Point,Point,int);

[C++] public void RoundRectangle(Point,Point,int);

[C++/CLI] public void RoundRectangle(Point,Point,int);

Draws a rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

[Visual Basic] Overloads Public Sub RoundRectangle(Rectangle,Integer)

[C#] public void RoundRectangle(Rectangle,int);

[C++] public void RoundRectangle(Rectangle,int);

[C++/CLI] public void RoundRectangle(Rectangle,int);

Draws a black rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

[Visual Basic] Overloads Public Sub RoundRectangle(Point,Point,Integer,Integer)

[C#] public void RoundRectangle(Point,Point,int,int);

[C++] public void RoundRectangle(Point,Point,int,int);

[C++/CLI] public void RoundRectangle(Point,Point,int,int);

Draws a rectangle with rounded corners on printer.

[Visual Basic] Overloads Public Sub RoundRectangle(Rectangle,Integer,Integer)

[C#] public void RoundRectangle(Rectangle,int,int);

[C++] public void RoundRectangle(Rectangle,int,int);

[C++/CLI] public void RoundRectangle(Rectangle,int,int);

See Also

Draw Class | Draw Members


RoundRectangle(PointF,PointF,Single,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

upperLeft
A PointF which represents the upper-left coordinate.
lowerRight
A PointF which represents the lower-right coordinate.
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.
color
A Color of the circle’s outline.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

RoundRectangle(PointF,PointF,Single,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > RoundRectangle Method : RoundRectangle(PointF,PointF,Single,Color) Method

Draws a rectangle with rounded corners on printer.

[Visual Basic]
Overloads Public Sub RoundRectangle( _
   ByVal upperLeft As PointF, _
   ByVal lowerRight As PointF, _
   ByVal roundSize As Single, _
   ByVal color As Color _
)
[C#]
public void RoundRectangle(
   PointF upperLeft,
   PointF lowerRight,
   float roundSize,
   Color color
);
[C++]
public: void RoundRectangle(
   PointF upperLeft,
   PointF lowerRight,
   float roundSize,
   Color color
)
[C++/CLI]
public:
void RoundRectangle(
   PointF upperLeft,
   PointF lowerRight,
   float roundSize,
   Color color
)

Parameters

upperLeft
A PointF which represents the upper-left coordinate.
lowerRight
A PointF which represents the lower-right coordinate.
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.
color
A Color of the circle’s outline.

Remarks

The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn.

The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties.

See Also

Draw Class | Draw Members | Overload List


RoundRectangle(RectangleF,Single,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
A RectangleF which represents the location of the rectangle.
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.
color
A Color of the circle’s outline.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

RoundRectangle(RectangleF,Single,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > RoundRectangle Method : RoundRectangle(RectangleF,Single,Color) Method

Draws a rectangle with rounded corners on printer.

[Visual Basic]
Overloads Public Sub RoundRectangle( _
   ByVal boundingBox As RectangleF, _
   ByVal roundSize As Single, _
   ByVal color As Color _
)
[C#]
public void RoundRectangle(
   RectangleF boundingBox,
   float roundSize,
   Color color
);
[C++]
public: void RoundRectangle(
   RectangleF boundingBox,
   float roundSize,
   Color color
)
[C++/CLI]
public:
void RoundRectangle(
   RectangleF boundingBox,
   float roundSize,
   Color color
)

Parameters

boundingBox
A RectangleF which represents the location of the rectangle.
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.
color
A Color of the circle’s outline.

Remarks

The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn.

The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties.

See Also

Draw Class | Draw Members | Overload List


RoundRectangle(PointF,PointF,Single,Single,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

upperLeft
A PointF which represents the upper-left coordinate.
lowerRight
A PointF which represents the lower-right coordinate.
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
color
A Color of the circle’s outline.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

RoundRectangle(PointF,PointF,Single,Single,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > RoundRectangle Method : RoundRectangle(PointF,PointF,Single,Single,Color) Method

Draws a rectangle with rounded corners on printer.

[Visual Basic]
Overloads Public Sub RoundRectangle( _
   ByVal upperLeft As PointF, _
   ByVal lowerRight As PointF, _
   ByVal roundWidth As Single, _
   ByVal roundHeight As Single, _
   ByVal color As Color _
)
[C#]
public void RoundRectangle(
   PointF upperLeft,
   PointF lowerRight,
   float roundWidth,
   float roundHeight,
   Color color
);
[C++]
public: void RoundRectangle(
   PointF upperLeft,
   PointF lowerRight,
   float roundWidth,
   float roundHeight,
   Color color
)
[C++/CLI]
public:
void RoundRectangle(
   PointF upperLeft,
   PointF lowerRight,
   float roundWidth,
   float roundHeight,
   Color color
)

Parameters

upperLeft
A PointF which represents the upper-left coordinate.
lowerRight
A PointF which represents the lower-right coordinate.
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
color
A Color of the circle’s outline.

Remarks

The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn.

The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties.

See Also

Draw Class | Draw Members | Overload List


RoundRectangle(RectangleF,Single,Single,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
A RectangleF which represents the location of the rectangle.
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
color
A Color which represents the Color of the circle’s outline.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

RoundRectangle(RectangleF,Single,Single,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > RoundRectangle Method : RoundRectangle(RectangleF,Single,Single,Color) Method

Draws a rectangle with rounded corners on printer.

[Visual Basic]
Overloads Public Sub RoundRectangle( _
   ByVal boundingBox As RectangleF, _
   ByVal roundWidth As Single, _
   ByVal roundHeight As Single, _
   ByVal color As Color _
)
[C#]
public void RoundRectangle(
   RectangleF boundingBox,
   float roundWidth,
   float roundHeight,
   Color color
);
[C++]
public: void RoundRectangle(
   RectangleF boundingBox,
   float roundWidth,
   float roundHeight,
   Color color
)
[C++/CLI]
public:
void RoundRectangle(
   RectangleF boundingBox,
   float roundWidth,
   float roundHeight,
   Color color
)

Parameters

boundingBox
A RectangleF which represents the location of the rectangle.
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
color
A Color which represents the Color of the circle’s outline.

Remarks

The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn.

The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties.

See Also

Draw Class | Draw Members | Overload List


RoundRectangle(PointF,PointF,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

upperLeft
A PointF which represents the upper-left coordinate.
lowerRight
A PointF which represents the lower-right coordinate.
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

RoundRectangle(PointF,PointF,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > RoundRectangle Method : RoundRectangle(PointF,PointF,Single) Method

Draws a black rectangle with rounded corners on printer.

[Visual Basic]
Overloads Public Sub RoundRectangle( _
   ByVal upperLeft As PointF, _
   ByVal lowerRight As PointF, _
   ByVal roundSize As Single _
)
[C#]
public void RoundRectangle(
   PointF upperLeft,
   PointF lowerRight,
   float roundSize
);
[C++]
public: void RoundRectangle(
   PointF upperLeft,
   PointF lowerRight,
   float roundSize
)
[C++/CLI]
public:
void RoundRectangle(
   PointF upperLeft,
   PointF lowerRight,
   float roundSize
)

Parameters

upperLeft
A PointF which represents the upper-left coordinate.
lowerRight
A PointF which represents the lower-right coordinate.
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.

Remarks

The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn.

The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties.

See Also

Draw Class | Draw Members | Overload List


RoundRectangle(RectangleF,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
A RectangleF which represents the location of the rectangle.
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

RoundRectangle(RectangleF,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > RoundRectangle Method : RoundRectangle(RectangleF,Single) Method

Draws a rectangle with rounded corners on printer.

[Visual Basic]
Overloads Public Sub RoundRectangle( _
   ByVal boundingBox As RectangleF, _
   ByVal roundSize As Single _
)
[C#]
public void RoundRectangle(
   RectangleF boundingBox,
   float roundSize
);
[C++]
public: void RoundRectangle(
   RectangleF boundingBox,
   float roundSize
)
[C++/CLI]
public:
void RoundRectangle(
   RectangleF boundingBox,
   float roundSize
)

Parameters

boundingBox
A RectangleF which represents the location of the rectangle.
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.

Remarks

The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn.

The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties.

See Also

Draw Class | Draw Members | Overload List


RoundRectangle(PointF,PointF,Single,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

upperLeft
A PointF which represents the upper-left coordinate.
lowerRight
A PointF which represents the the lower-right coordinate.
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

RoundRectangle(PointF,PointF,Single,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > RoundRectangle Method : RoundRectangle(PointF,PointF,Single,Single) Method

Draws a black rectangle with rounded corners on printer.

[Visual Basic]
Overloads Public Sub RoundRectangle( _
   ByVal upperLeft As PointF, _
   ByVal lowerRight As PointF, _
   ByVal roundWidth As Single, _
   ByVal roundHeight As Single _
)
[C#]
public void RoundRectangle(
   PointF upperLeft,
   PointF lowerRight,
   float roundWidth,
   float roundHeight
);
[C++]
public: void RoundRectangle(
   PointF upperLeft,
   PointF lowerRight,
   float roundWidth,
   float roundHeight
)
[C++/CLI]
public:
void RoundRectangle(
   PointF upperLeft,
   PointF lowerRight,
   float roundWidth,
   float roundHeight
)

Parameters

upperLeft
A PointF which represents the upper-left coordinate.
lowerRight
A PointF which represents the the lower-right coordinate.
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.

Remarks

The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn.

The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties.

See Also

Draw Class | Draw Members | Overload List


RoundRectangle(RectangleF,Single,Single) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
A RectangleF which represents the location of the rectangle.
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

RoundRectangle(RectangleF,Single,Single) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > RoundRectangle Method : RoundRectangle(RectangleF,Single,Single) Method

Draws a rectangle with rounded corners on printer.

[Visual Basic]
Overloads Public Sub RoundRectangle( _
   ByVal boundingBox As RectangleF, _
   ByVal roundWidth As Single, _
   ByVal roundHeight As Single _
)
[C#]
public void RoundRectangle(
   RectangleF boundingBox,
   float roundWidth,
   float roundHeight
);
[C++]
public: void RoundRectangle(
   RectangleF boundingBox,
   float roundWidth,
   float roundHeight
)
[C++/CLI]
public:
void RoundRectangle(
   RectangleF boundingBox,
   float roundWidth,
   float roundHeight
)

Parameters

boundingBox
A RectangleF which represents the location of the rectangle.
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.

Remarks

The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn.

The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties.

See Also

Draw Class | Draw Members | Overload List


RoundRectangle(Point,Point,Int32,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

upperLeft
the upper-left coordinate
lowerRight
the lower-right coordinate
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.
color
Color of the circle’s outline
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

RoundRectangle(Point,Point,Int32,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > RoundRectangle Method : RoundRectangle(Point,Point,Int32,Color) Method

Draws a rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

[Visual Basic]
Overloads Public Sub RoundRectangle( _
   ByVal upperLeft As Point, _
   ByVal lowerRight As Point, _
   ByVal roundSize As Integer, _
   ByVal color As Color _
)
[C#]
public void RoundRectangle(
   Point upperLeft,
   Point lowerRight,
   int roundSize,
   Color color
);
[C++]
public: void RoundRectangle(
   Point upperLeft,
   Point lowerRight,
   int roundSize,
   Color color
)
[C++/CLI]
public:
void RoundRectangle(
   Point upperLeft,
   Point lowerRight,
   int roundSize,
   Color color
)

Parameters

upperLeft
the upper-left coordinate
lowerRight
the lower-right coordinate
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.
color
Color of the circle’s outline

See Also

Draw Class | Draw Members | Overload List


RoundRectangle(Rectangle,Int32,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
The location of the rectangle
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.
color
Color of the circle’s outline
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

RoundRectangle(Rectangle,Int32,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > RoundRectangle Method : RoundRectangle(Rectangle,Int32,Color) Method

Draws a rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

[Visual Basic]
Overloads Public Sub RoundRectangle( _
   ByVal boundingBox As Rectangle, _
   ByVal roundSize As Integer, _
   ByVal color As Color _
)
[C#]
public void RoundRectangle(
   Rectangle boundingBox,
   int roundSize,
   Color color
);
[C++]
public: void RoundRectangle(
   Rectangle boundingBox,
   int roundSize,
   Color color
)
[C++/CLI]
public:
void RoundRectangle(
   Rectangle boundingBox,
   int roundSize,
   Color color
)

Parameters

boundingBox
The location of the rectangle
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.
color
Color of the circle’s outline

See Also

Draw Class | Draw Members | Overload List


RoundRectangle(Point,Point,Int32,Int32,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

upperLeft
the upper-left coordinate
lowerRight
the lower-right coordinate
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
color
Color of the circle’s outline
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

RoundRectangle(Point,Point,Int32,Int32,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > RoundRectangle Method : RoundRectangle(Point,Point,Int32,Int32,Color) Method

Draws a rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

[Visual Basic]
Overloads Public Sub RoundRectangle( _
   ByVal upperLeft As Point, _
   ByVal lowerRight As Point, _
   ByVal roundWidth As Integer, _
   ByVal roundHeight As Integer, _
   ByVal color As Color _
)
[C#]
public void RoundRectangle(
   Point upperLeft,
   Point lowerRight,
   int roundWidth,
   int roundHeight,
   Color color
);
[C++]
public: void RoundRectangle(
   Point upperLeft,
   Point lowerRight,
   int roundWidth,
   int roundHeight,
   Color color
)
[C++/CLI]
public:
void RoundRectangle(
   Point upperLeft,
   Point lowerRight,
   int roundWidth,
   int roundHeight,
   Color color
)

Parameters

upperLeft
the upper-left coordinate
lowerRight
the lower-right coordinate
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
color
Color of the circle’s outline

See Also

Draw Class | Draw Members | Overload List


RoundRectangle(Rectangle,Int32,Int32,Color) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
The location of the rectangle
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
color
Color of the circle’s outline
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

RoundRectangle(Rectangle,Int32,Int32,Color) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > RoundRectangle Method : RoundRectangle(Rectangle,Int32,Int32,Color) Method

Draws a rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

[Visual Basic]
Overloads Public Sub RoundRectangle( _
   ByVal boundingBox As Rectangle, _
   ByVal roundWidth As Integer, _
   ByVal roundHeight As Integer, _
   ByVal color As Color _
)
[C#]
public void RoundRectangle(
   Rectangle boundingBox,
   int roundWidth,
   int roundHeight,
   Color color
);
[C++]
public: void RoundRectangle(
   Rectangle boundingBox,
   int roundWidth,
   int roundHeight,
   Color color
)
[C++/CLI]
public:
void RoundRectangle(
   Rectangle boundingBox,
   int roundWidth,
   int roundHeight,
   Color color
)

Parameters

boundingBox
The location of the rectangle
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
color
Color of the circle’s outline

See Also

Draw Class | Draw Members | Overload List


RoundRectangle(Point,Point,Int32) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

upperLeft
the upper-left coordinate
lowerRight
the lower-right coordinate
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

RoundRectangle(Point,Point,Int32) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > RoundRectangle Method : RoundRectangle(Point,Point,Int32) Method

Draws a black rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

[Visual Basic]
Overloads Public Sub RoundRectangle( _
   ByVal upperLeft As Point, _
   ByVal lowerRight As Point, _
   ByVal roundSize As Integer _
)
[C#]
public void RoundRectangle(
   Point upperLeft,
   Point lowerRight,
   int roundSize
);
[C++]
public: void RoundRectangle(
   Point upperLeft,
   Point lowerRight,
   int roundSize
)
[C++/CLI]
public:
void RoundRectangle(
   Point upperLeft,
   Point lowerRight,
   int roundSize
)

Parameters

upperLeft
the upper-left coordinate
lowerRight
the lower-right coordinate
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.

See Also

Draw Class | Draw Members | Overload List


RoundRectangle(Rectangle,Int32) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
The location of the rectangle
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

RoundRectangle(Rectangle,Int32) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > RoundRectangle Method : RoundRectangle(Rectangle,Int32) Method

Draws a rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

[Visual Basic]
Overloads Public Sub RoundRectangle( _
   ByVal boundingBox As Rectangle, _
   ByVal roundSize As Integer _
)
[C#]
public void RoundRectangle(
   Rectangle boundingBox,
   int roundSize
);
[C++]
public: void RoundRectangle(
   Rectangle boundingBox,
   int roundSize
)
[C++/CLI]
public:
void RoundRectangle(
   Rectangle boundingBox,
   int roundSize
)

Parameters

boundingBox
The location of the rectangle
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.

See Also

Draw Class | Draw Members | Overload List


RoundRectangle(Point,Point,Int32,Int32) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

upperLeft
the upper-left coordinate
lowerRight
the lower-right coordinate
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

RoundRectangle(Point,Point,Int32,Int32) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > RoundRectangle Method : RoundRectangle(Point,Point,Int32,Int32) Method

Draws a black rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

[Visual Basic]
Overloads Public Sub RoundRectangle( _
   ByVal upperLeft As Point, _
   ByVal lowerRight As Point, _
   ByVal roundWidth As Integer, _
   ByVal roundHeight As Integer _
)
[C#]
public void RoundRectangle(
   Point upperLeft,
   Point lowerRight,
   int roundWidth,
   int roundHeight
);
[C++]
public: void RoundRectangle(
   Point upperLeft,
   Point lowerRight,
   int roundWidth,
   int roundHeight
)
[C++/CLI]
public:
void RoundRectangle(
   Point upperLeft,
   Point lowerRight,
   int roundWidth,
   int roundHeight
)

Parameters

upperLeft
the upper-left coordinate
lowerRight
the lower-right coordinate
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.

See Also

Draw Class | Draw Members | Overload List


RoundRectangle(Rectangle,Int32,Int32) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
A Rectangle which represents the location of the rectangle
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

RoundRectangle(Rectangle,Int32,Int32) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > RoundRectangle Method : RoundRectangle(Rectangle,Int32,Int32) Method

Draws a rectangle with rounded corners on printer.

[Visual Basic]
Overloads Public Sub RoundRectangle( _
   ByVal boundingBox As Rectangle, _
   ByVal roundWidth As Integer, _
   ByVal roundHeight As Integer _
)
[C#]
public void RoundRectangle(
   Rectangle boundingBox,
   int roundWidth,
   int roundHeight
);
[C++]
public: void RoundRectangle(
   Rectangle boundingBox,
   int roundWidth,
   int roundHeight
)
[C++/CLI]
public:
void RoundRectangle(
   Rectangle boundingBox,
   int roundWidth,
   int roundHeight
)

Parameters

boundingBox
A Rectangle which represents the location of the rectangle
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.

Remarks

The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties.

See Also

Draw Class | Draw Members | Overload List


Text Method

Draw Class | Draw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Text Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class : Text Method

Draws the specified text string.

Overload List

Draws the specified text string.

[Visual Basic] Overloads Public Sub Text(PointF,String,Font)

[C#] public void Text(PointF,string,Font);

[C++] public void Text(PointF,string*,Font*);

[C++/CLI] public void Text(PointF,String^,Font^);

Draws the specified text string.

[Visual Basic] Overloads Public Sub Text(PointF,String)

[C#] public void Text(PointF,string);

[C++] public void Text(PointF,string*);

[C++/CLI] public void Text(PointF,String^);

Draws the specified text string.

[Visual Basic] Overloads Public Sub Text(Point,String,Font)

[C#] public void Text(Point,string,Font);

[C++] public void Text(Point,string*,Font*);

[C++/CLI] public void Text(Point,String^,Font^);

Draws the specified text string.

[Visual Basic] Overloads Public Sub Text(Point,String)

[C#] public void Text(Point,string);

[C++] public void Text(Point,string*);

[C++/CLI] public void Text(Point,String^);

Draws the specified text string.

[Visual Basic] Overloads Public Sub Text(String,Font)

[C#] public void Text(string,Font);

[C++] public void Text(string*,Font*);

[C++/CLI] public void Text(String^,Font^);

Draws the specified text string.

[Visual Basic] Overloads Public Sub Text(String)

[C#] public void Text(string);

[C++] public void Text(string*);

[C++/CLI] public void Text(String^);

See Also

Draw Class | Draw Members


Text(PointF,String,Font) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

location
A PointF location value which represents the location for the string.
drawText
A string value which represents the text to output.
font
A Font which represents the font to render the text in.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Text(PointF,String,Font) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Text Method : Text(PointF,String,Font) Method

Draws the specified text string.

[Visual Basic]
Overloads Public Sub Text( _
   ByVal location As PointF, _
   ByVal drawText As String, _
   ByVal font As Font _
)
[C#]
public void Text(
   PointF location,
   string drawText,
   Font font
);
[C++]
public: void Text(
   PointF location,
   string* drawText,
   Font* font
)
[C++/CLI]
public:
void Text(
   PointF location,
   String^ drawText,
   Font^ font
)

Parameters

location
A PointF location value which represents the location for the string.
drawText
A string value which represents the text to output.
font
A Font which represents the font to render the text in.

See Also

Draw Class | Draw Members | Overload List


Text(PointF,String) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

location
A PointF location value which represents the location for the string.
drawText
A string value which represents the text to output.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Text(PointF,String) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Text Method : Text(PointF,String) Method

Draws the specified text string.

[Visual Basic]
Overloads Public Sub Text( _
   ByVal location As PointF, _
   ByVal drawText As String _
)
[C#]
public void Text(
   PointF location,
   string drawText
);
[C++]
public: void Text(
   PointF location,
   string* drawText
)
[C++/CLI]
public:
void Text(
   PointF location,
   String^ drawText
)

Parameters

location
A PointF location value which represents the location for the string.
drawText
A string value which represents the text to output.

See Also

Draw Class | Draw Members | Overload List


Text(Point,String,Font) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

location
A Point which represents the location for the string.
drawText
A string value which represents the text to output.
font
The Font to render the text in.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Text(Point,String,Font) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Text Method : Text(Point,String,Font) Method

Draws the specified text string.

[Visual Basic]
Overloads Public Sub Text( _
   ByVal location As Point, _
   ByVal drawText As String, _
   ByVal font As Font _
)
[C#]
public void Text(
   Point location,
   string drawText,
   Font font
);
[C++]
public: void Text(
   Point location,
   string* drawText,
   Font* font
)
[C++/CLI]
public:
void Text(
   Point location,
   String^ drawText,
   Font^ font
)

Parameters

location
A Point which represents the location for the string.
drawText
A string value which represents the text to output.
font
The Font to render the text in.

See Also

Draw Class | Draw Members | Overload List


Text(Point,String) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

location
A Point which represents the location for the string.
drawText
A string value which represents the text to output.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Text(Point,String) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Text Method : Text(Point,String) Method

Draws the specified text string.

[Visual Basic]
Overloads Public Sub Text( _
   ByVal location As Point, _
   ByVal drawText As String _
)
[C#]
public void Text(
   Point location,
   string drawText
);
[C++]
public: void Text(
   Point location,
   string* drawText
)
[C++/CLI]
public:
void Text(
   Point location,
   String^ drawText
)

Parameters

location
A Point which represents the location for the string.
drawText
A string value which represents the text to output.

See Also

Draw Class | Draw Members | Overload List


Text(String,Font) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

drawText
A string value which represents the text to output.
font
A Font which represents the font to render the text in.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Text(String,Font) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Text Method : Text(String,Font) Method

Draws the specified text string.

[Visual Basic]
Overloads Public Sub Text( _
   ByVal drawText As String, _
   ByVal font As Font _
)
[C#]
public void Text(
   string drawText,
   Font font
);
[C++]
public: void Text(
   string* drawText,
   Font* font
)
[C++/CLI]
public:
void Text(
   String^ drawText,
   Font^ font
)

Parameters

drawText
A string value which represents the text to output.
font
A Font which represents the font to render the text in.

See Also

Draw Class | Draw Members | Overload List


Text(String) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

drawText
A string value which represents the text to output.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Text(String) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > Text Method : Text(String) Method

Draws the specified text string.

[Visual Basic]
Overloads Public Sub Text( _
   ByVal drawText As String _
)
[C#]
public void Text(
   string drawText
);
[C++]
public: void Text(
   string* drawText
)
[C++/CLI]
public:
void Text(
   String^ drawText
)

Parameters

drawText
A string value which represents the text to output.

See Also

Draw Class | Draw Members | Overload List


TextAligned Method

Draw Class | Draw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextAligned Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class : TextAligned Method

Draws text with the specified alignment.

Overload List

Draws text with the specified alignment.

[Visual Basic] Overloads Public Sub TextAligned(PointF,PointF,String,Font,Alignment,Boolean)

[C#] public void TextAligned(PointF,PointF,string,Font,Alignment,bool);

[C++] public void TextAligned(PointF,PointF,string*,Font*,Alignment,bool);

[C++/CLI] public void TextAligned(PointF,PointF,String^,Font^,Alignment,bool);

Draws text with the specified alignment.

[Visual Basic] Overloads Public Sub TextAligned(RectangleF,String,Font,Alignment,Boolean)

[C#] public void TextAligned(RectangleF,string,Font,Alignment,bool);

[C++] public void TextAligned(RectangleF,string*,Font*,Alignment,bool);

[C++/CLI] public void TextAligned(RectangleF,String^,Font^,Alignment,bool);

Draws text with the specified alignment.

[Visual Basic] Overloads Public Sub TextAligned(PointF,String,Font,Alignment,Boolean)

[C#] public void TextAligned(PointF,string,Font,Alignment,bool);

[C++] public void TextAligned(PointF,string*,Font*,Alignment,bool);

[C++/CLI] public void TextAligned(PointF,String^,Font^,Alignment,bool);

Draws text with a specified alignment.

[Visual Basic] Overloads Public Sub TextAligned(PointF,PointF,String,Font,Alignment)

[C#] public void TextAligned(PointF,PointF,string,Font,Alignment);

[C++] public void TextAligned(PointF,PointF,string*,Font*,Alignment);

[C++/CLI] public void TextAligned(PointF,PointF,String^,Font^,Alignment);

Draws text with a specified alignment.

[Visual Basic] Overloads Public Sub TextAligned(RectangleF,String,Font,Alignment)

[C#] public void TextAligned(RectangleF,string,Font,Alignment);

[C++] public void TextAligned(RectangleF,string*,Font*,Alignment);

[C++/CLI] public void TextAligned(RectangleF,String^,Font^,Alignment);

Draws text with a specified alignment.

[Visual Basic] Overloads Public Sub TextAligned(PointF,String,Font,Alignment)

[C#] public void TextAligned(PointF,string,Font,Alignment);

[C++] public void TextAligned(PointF,string*,Font*,Alignment);

[C++/CLI] public void TextAligned(PointF,String^,Font^,Alignment);

Outputs text with a specified alignment.

[Visual Basic] Overloads Public Sub TextAligned(PointF,PointF,String,Alignment,Boolean)

[C#] public void TextAligned(PointF,PointF,string,Alignment,bool);

[C++] public void TextAligned(PointF,PointF,string*,Alignment,bool);

[C++/CLI] public void TextAligned(PointF,PointF,String^,Alignment,bool);

Outputs text with a specified alignment.

[Visual Basic] Overloads Public Sub TextAligned(RectangleF,String,Alignment,Boolean)

[C#] public void TextAligned(RectangleF,string,Alignment,bool);

[C++] public void TextAligned(RectangleF,string*,Alignment,bool);

[C++/CLI] public void TextAligned(RectangleF,String^,Alignment,bool);

Outputs text with a specified alignment.

[Visual Basic] Overloads Public Sub TextAligned(PointF,String,Alignment,Boolean)

[C#] public void TextAligned(PointF,string,Alignment,bool);

[C++] public void TextAligned(PointF,string*,Alignment,bool);

[C++/CLI] public void TextAligned(PointF,String^,Alignment,bool);

Outputs text with a specified alignment.

[Visual Basic] Overloads Public Sub TextAligned(PointF,PointF,String,Alignment)

[C#] public void TextAligned(PointF,PointF,string,Alignment);

[C++] public void TextAligned(PointF,PointF,string*,Alignment);

[C++/CLI] public void TextAligned(PointF,PointF,String^,Alignment);

Outputs text with a specified alignment.

[Visual Basic] Overloads Public Sub TextAligned(RectangleF,String,Alignment)

[C#] public void TextAligned(RectangleF,string,Alignment);

[C++] public void TextAligned(RectangleF,string*,Alignment);

[C++/CLI] public void TextAligned(RectangleF,String^,Alignment);

Outputs text with a specified alignment.

[Visual Basic] Overloads Public Sub TextAligned(PointF,String,Alignment)

[C#] public void TextAligned(PointF,string,Alignment);

[C++] public void TextAligned(PointF,string*,Alignment);

[C++/CLI] public void TextAligned(PointF,String^,Alignment);

Outputs text with a specified alignment.

[Visual Basic] Overloads Public Sub TextAligned(Point,Point,String,Font,Alignment,Boolean)

[C#] public void TextAligned(Point,Point,string,Font,Alignment,bool);

[C++] public void TextAligned(Point,Point,string*,Font*,Alignment,bool);

[C++/CLI] public void TextAligned(Point,Point,String^,Font^,Alignment,bool);

Outputs text with a specified alignment.

[Visual Basic] Overloads Public Sub TextAligned(Rectangle,String,Font,Alignment,Boolean)

[C#] public void TextAligned(Rectangle,string,Font,Alignment,bool);

[C++] public void TextAligned(Rectangle,string*,Font*,Alignment,bool);

[C++/CLI] public void TextAligned(Rectangle,String^,Font^,Alignment,bool);

Outputs text with a specified alignment

[Visual Basic] Overloads Public Sub TextAligned(Point,String,Font,Alignment,Boolean)

[C#] public void TextAligned(Point,string,Font,Alignment,bool);

[C++] public void TextAligned(Point,string*,Font*,Alignment,bool);

[C++/CLI] public void TextAligned(Point,String^,Font^,Alignment,bool);

Outputs text with a specified alignment.

[Visual Basic] Overloads Public Sub TextAligned(Point,Point,String,Font,Alignment)

[C#] public void TextAligned(Point,Point,string,Font,Alignment);

[C++] public void TextAligned(Point,Point,string*,Font*,Alignment);

[C++/CLI] public void TextAligned(Point,Point,String^,Font^,Alignment);

Outputs text with a specified alignment.

[Visual Basic] Overloads Public Sub TextAligned(Rectangle,String,Font,Alignment)

[C#] public void TextAligned(Rectangle,string,Font,Alignment);

[C++] public void TextAligned(Rectangle,string*,Font*,Alignment);

[C++/CLI] public void TextAligned(Rectangle,String^,Font^,Alignment);

Outputs text with a specified alignment.

[Visual Basic] Overloads Public Sub TextAligned(Point,String,Font,Alignment)

[C#] public void TextAligned(Point,string,Font,Alignment);

[C++] public void TextAligned(Point,string*,Font*,Alignment);

[C++/CLI] public void TextAligned(Point,String^,Font^,Alignment);

Outputs text with a specified alignment.

[Visual Basic] Overloads Public Sub TextAligned(Point,Point,String,Alignment,Boolean)

[C#] public void TextAligned(Point,Point,string,Alignment,bool);

[C++] public void TextAligned(Point,Point,string*,Alignment,bool);

[C++/CLI] public void TextAligned(Point,Point,String^,Alignment,bool);

Outputs text with a specified alignment.

[Visual Basic] Overloads Public Sub TextAligned(Rectangle,String,Alignment,Boolean)

[C#] public void TextAligned(Rectangle,string,Alignment,bool);

[C++] public void TextAligned(Rectangle,string*,Alignment,bool);

[C++/CLI] public void TextAligned(Rectangle,String^,Alignment,bool);

Outputs text with a specified alignment.

[Visual Basic] Overloads Public Sub TextAligned(Point,String,Alignment,Boolean)

[C#] public void TextAligned(Point,string,Alignment,bool);

[C++] public void TextAligned(Point,string*,Alignment,bool);

[C++/CLI] public void TextAligned(Point,String^,Alignment,bool);

Outputs text with a specified alignment.

[Visual Basic] Overloads Public Sub TextAligned(Point,Point,String,Alignment)

[C#] public void TextAligned(Point,Point,string,Alignment);

[C++] public void TextAligned(Point,Point,string*,Alignment);

[C++/CLI] public void TextAligned(Point,Point,String^,Alignment);

Outputs text with a specified alignment.

[Visual Basic] Overloads Public Sub TextAligned(Rectangle,String,Alignment)

[C#] public void TextAligned(Rectangle,string,Alignment);

[C++] public void TextAligned(Rectangle,string*,Alignment);

[C++/CLI] public void TextAligned(Rectangle,String^,Alignment);

Outputs text with a specified alignment.

[Visual Basic] Overloads Public Sub TextAligned(Point,String,Alignment)

[C#] public void TextAligned(Point,string,Alignment);

[C++] public void TextAligned(Point,string*,Alignment);

[C++/CLI] public void TextAligned(Point,String^,Alignment);

See Also

Draw Class | Draw Members


TextAligned(PointF,PointF,String,Font,Alignment,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
A PointF which represents the upper-left point where the text is to be aligned from.
endPoint
A PointF which represents the lower-right point where the text is to be aligned from.
text
A string value which represents the text to align and output.
font
A Font which represents the font the text is to be rendered in.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextAligned(PointF,PointF,String,Font,Alignment,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextAligned Method : TextAligned(PointF,PointF,String,Font,Alignment,Boolean) Method

Draws text with the specified alignment.

[Visual Basic]
Overloads Public Sub TextAligned( _
   ByVal startPoint As PointF, _
   ByVal endPoint As PointF, _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal alignment As Alignment, _
   ByVal wordWrap As Boolean _
)
[C#]
public void TextAligned(
   PointF startPoint,
   PointF endPoint,
   string text,
   Font font,
   Alignment alignment,
   bool wordWrap
);
[C++]
public: void TextAligned(
   PointF startPoint,
   PointF endPoint,
   string* text,
   Font* font,
   Alignment alignment,
   bool wordWrap
)
[C++/CLI]
public:
void TextAligned(
   PointF startPoint,
   PointF endPoint,
   String^ text,
   Font^ font,
   Alignment alignment,
   bool wordWrap
)

Parameters

startPoint
A PointF which represents the upper-left point where the text is to be aligned from.
endPoint
A PointF which represents the lower-right point where the text is to be aligned from.
text
A string value which represents the text to align and output.
font
A Font which represents the font the text is to be rendered in.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

See Also

Draw Class | Draw Members | Overload List


TextAligned(RectangleF,String,Font,Alignment,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
A RectangleF which represents the bounding box.
text
A string value which represents the text to align and output.
font
A Font which represents the font the text is to be rendered in.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextAligned(RectangleF,String,Font,Alignment,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextAligned Method : TextAligned(RectangleF,String,Font,Alignment,Boolean) Method

Draws text with the specified alignment.

[Visual Basic]
Overloads Public Sub TextAligned( _
   ByVal boundingBox As RectangleF, _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal alignment As Alignment, _
   ByVal wordWrap As Boolean _
)
[C#]
public void TextAligned(
   RectangleF boundingBox,
   string text,
   Font font,
   Alignment alignment,
   bool wordWrap
);
[C++]
public: void TextAligned(
   RectangleF boundingBox,
   string* text,
   Font* font,
   Alignment alignment,
   bool wordWrap
)
[C++/CLI]
public:
void TextAligned(
   RectangleF boundingBox,
   String^ text,
   Font^ font,
   Alignment alignment,
   bool wordWrap
)

Parameters

boundingBox
A RectangleF which represents the bounding box.
text
A string value which represents the text to align and output.
font
A Font which represents the font the text is to be rendered in.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

See Also

Draw Class | Draw Members | Overload List


TextAligned(PointF,String,Font,Alignment,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A PointF which represents the lower-right point where the text is to be aligned from.
text
A string value which represents the text to align and output.
font
A Font which represents the font the text is to be rendered in.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextAligned(PointF,String,Font,Alignment,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextAligned Method : TextAligned(PointF,String,Font,Alignment,Boolean) Method

Draws text with the specified alignment.

[Visual Basic]
Overloads Public Sub TextAligned( _
   ByVal endPoint As PointF, _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal alignment As Alignment, _
   ByVal wordWrap As Boolean _
)
[C#]
public void TextAligned(
   PointF endPoint,
   string text,
   Font font,
   Alignment alignment,
   bool wordWrap
);
[C++]
public: void TextAligned(
   PointF endPoint,
   string* text,
   Font* font,
   Alignment alignment,
   bool wordWrap
)
[C++/CLI]
public:
void TextAligned(
   PointF endPoint,
   String^ text,
   Font^ font,
   Alignment alignment,
   bool wordWrap
)

Parameters

endPoint
A PointF which represents the lower-right point where the text is to be aligned from.
text
A string value which represents the text to align and output.
font
A Font which represents the font the text is to be rendered in.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

See Also

Draw Class | Draw Members | Overload List


TextAligned(PointF,PointF,String,Font,Alignment) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
A PointF which represents the upper-left point where the text is to be aligned from.
endPoint
A PointF which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
font
A Font which represents the font the text is to be rendered in.
alignment
The Alignment of the text.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextAligned(PointF,PointF,String,Font,Alignment) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextAligned Method : TextAligned(PointF,PointF,String,Font,Alignment) Method

Draws text with a specified alignment.

[Visual Basic]
Overloads Public Sub TextAligned( _
   ByVal startPoint As PointF, _
   ByVal endPoint As PointF, _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal alignment As Alignment _
)
[C#]
public void TextAligned(
   PointF startPoint,
   PointF endPoint,
   string text,
   Font font,
   Alignment alignment
);
[C++]
public: void TextAligned(
   PointF startPoint,
   PointF endPoint,
   string* text,
   Font* font,
   Alignment alignment
)
[C++/CLI]
public:
void TextAligned(
   PointF startPoint,
   PointF endPoint,
   String^ text,
   Font^ font,
   Alignment alignment
)

Parameters

startPoint
A PointF which represents the upper-left point where the text is to be aligned from.
endPoint
A PointF which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
font
A Font which represents the font the text is to be rendered in.
alignment
The Alignment of the text.

See Also

Draw Class | Draw Members | Overload List


TextAligned(RectangleF,String,Font,Alignment) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
The bounding RectangleF for the text.
text
A string which represents the text to align and output.
font
A Font which represents the font the text is to be rendered in.
alignment
The Alignment of the text.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextAligned(RectangleF,String,Font,Alignment) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextAligned Method : TextAligned(RectangleF,String,Font,Alignment) Method

Draws text with a specified alignment.

[Visual Basic]
Overloads Public Sub TextAligned( _
   ByVal boundingBox As RectangleF, _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal alignment As Alignment _
)
[C#]
public void TextAligned(
   RectangleF boundingBox,
   string text,
   Font font,
   Alignment alignment
);
[C++]
public: void TextAligned(
   RectangleF boundingBox,
   string* text,
   Font* font,
   Alignment alignment
)
[C++/CLI]
public:
void TextAligned(
   RectangleF boundingBox,
   String^ text,
   Font^ font,
   Alignment alignment
)

Parameters

boundingBox
The bounding RectangleF for the text.
text
A string which represents the text to align and output.
font
A Font which represents the font the text is to be rendered in.
alignment
The Alignment of the text.

See Also

Draw Class | Draw Members | Overload List


TextAligned(PointF,String,Font,Alignment) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A PointF which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
font
A Font which represents the font the text is to be rendered in.
alignment
The Alignment of the text.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextAligned(PointF,String,Font,Alignment) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextAligned Method : TextAligned(PointF,String,Font,Alignment) Method

Draws text with a specified alignment.

[Visual Basic]
Overloads Public Sub TextAligned( _
   ByVal endPoint As PointF, _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal alignment As Alignment _
)
[C#]
public void TextAligned(
   PointF endPoint,
   string text,
   Font font,
   Alignment alignment
);
[C++]
public: void TextAligned(
   PointF endPoint,
   string* text,
   Font* font,
   Alignment alignment
)
[C++/CLI]
public:
void TextAligned(
   PointF endPoint,
   String^ text,
   Font^ font,
   Alignment alignment
)

Parameters

endPoint
A PointF which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
font
A Font which represents the font the text is to be rendered in.
alignment
The Alignment of the text.

See Also

Draw Class | Draw Members | Overload List


TextAligned(PointF,PointF,String,Alignment,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
A PointF which represents the upper-left point where the text is to be aligned from.
endPoint
A PointF which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextAligned(PointF,PointF,String,Alignment,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextAligned Method : TextAligned(PointF,PointF,String,Alignment,Boolean) Method

Outputs text with a specified alignment.

[Visual Basic]
Overloads Public Sub TextAligned( _
   ByVal startPoint As PointF, _
   ByVal endPoint As PointF, _
   ByVal text As String, _
   ByVal alignment As Alignment, _
   ByVal wordWrap As Boolean _
)
[C#]
public void TextAligned(
   PointF startPoint,
   PointF endPoint,
   string text,
   Alignment alignment,
   bool wordWrap
);
[C++]
public: void TextAligned(
   PointF startPoint,
   PointF endPoint,
   string* text,
   Alignment alignment,
   bool wordWrap
)
[C++/CLI]
public:
void TextAligned(
   PointF startPoint,
   PointF endPoint,
   String^ text,
   Alignment alignment,
   bool wordWrap
)

Parameters

startPoint
A PointF which represents the upper-left point where the text is to be aligned from.
endPoint
A PointF which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

See Also

Draw Class | Draw Members | Overload List


TextAligned(RectangleF,String,Alignment,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
The bounding RectangleF for the text.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextAligned(RectangleF,String,Alignment,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextAligned Method : TextAligned(RectangleF,String,Alignment,Boolean) Method

Outputs text with a specified alignment.

[Visual Basic]
Overloads Public Sub TextAligned( _
   ByVal boundingBox As RectangleF, _
   ByVal text As String, _
   ByVal alignment As Alignment, _
   ByVal wordWrap As Boolean _
)
[C#]
public void TextAligned(
   RectangleF boundingBox,
   string text,
   Alignment alignment,
   bool wordWrap
);
[C++]
public: void TextAligned(
   RectangleF boundingBox,
   string* text,
   Alignment alignment,
   bool wordWrap
)
[C++/CLI]
public:
void TextAligned(
   RectangleF boundingBox,
   String^ text,
   Alignment alignment,
   bool wordWrap
)

Parameters

boundingBox
The bounding RectangleF for the text.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

See Also

Draw Class | Draw Members | Overload List


TextAligned(PointF,String,Alignment,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A PointF which represents the lower-right where the text is to be aligned from.
text
A string value which represents the text to align and output.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextAligned(PointF,String,Alignment,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextAligned Method : TextAligned(PointF,String,Alignment,Boolean) Method

Outputs text with a specified alignment.

[Visual Basic]
Overloads Public Sub TextAligned( _
   ByVal endPoint As PointF, _
   ByVal text As String, _
   ByVal alignment As Alignment, _
   ByVal wordWrap As Boolean _
)
[C#]
public void TextAligned(
   PointF endPoint,
   string text,
   Alignment alignment,
   bool wordWrap
);
[C++]
public: void TextAligned(
   PointF endPoint,
   string* text,
   Alignment alignment,
   bool wordWrap
)
[C++/CLI]
public:
void TextAligned(
   PointF endPoint,
   String^ text,
   Alignment alignment,
   bool wordWrap
)

Parameters

endPoint
A PointF which represents the lower-right where the text is to be aligned from.
text
A string value which represents the text to align and output.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

See Also

Draw Class | Draw Members | Overload List


TextAligned(PointF,PointF,String,Alignment) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
A PointF which represents the upper-left point where the text is to be aligned from.
endPoint
A PointF which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextAligned(PointF,PointF,String,Alignment) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextAligned Method : TextAligned(PointF,PointF,String,Alignment) Method

Outputs text with a specified alignment.

[Visual Basic]
Overloads Public Sub TextAligned( _
   ByVal startPoint As PointF, _
   ByVal endPoint As PointF, _
   ByVal text As String, _
   ByVal alignment As Alignment _
)
[C#]
public void TextAligned(
   PointF startPoint,
   PointF endPoint,
   string text,
   Alignment alignment
);
[C++]
public: void TextAligned(
   PointF startPoint,
   PointF endPoint,
   string* text,
   Alignment alignment
)
[C++/CLI]
public:
void TextAligned(
   PointF startPoint,
   PointF endPoint,
   String^ text,
   Alignment alignment
)

Parameters

startPoint
A PointF which represents the upper-left point where the text is to be aligned from.
endPoint
A PointF which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.

See Also

Draw Class | Draw Members | Overload List


TextAligned(RectangleF,String,Alignment) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
The bounding RectangleF for the text.
text
A string value which represents the text to align and output.
alignment
The Alignment of the text.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextAligned(RectangleF,String,Alignment) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextAligned Method : TextAligned(RectangleF,String,Alignment) Method

Outputs text with a specified alignment.

[Visual Basic]
Overloads Public Sub TextAligned( _
   ByVal boundingBox As RectangleF, _
   ByVal text As String, _
   ByVal alignment As Alignment _
)
[C#]
public void TextAligned(
   RectangleF boundingBox,
   string text,
   Alignment alignment
);
[C++]
public: void TextAligned(
   RectangleF boundingBox,
   string* text,
   Alignment alignment
)
[C++/CLI]
public:
void TextAligned(
   RectangleF boundingBox,
   String^ text,
   Alignment alignment
)

Parameters

boundingBox
The bounding RectangleF for the text.
text
A string value which represents the text to align and output.
alignment
The Alignment of the text.

See Also

Draw Class | Draw Members | Overload List


TextAligned(PointF,String,Alignment) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A PointF which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextAligned(PointF,String,Alignment) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextAligned Method : TextAligned(PointF,String,Alignment) Method

Outputs text with a specified alignment.

[Visual Basic]
Overloads Public Sub TextAligned( _
   ByVal endPoint As PointF, _
   ByVal text As String, _
   ByVal alignment As Alignment _
)
[C#]
public void TextAligned(
   PointF endPoint,
   string text,
   Alignment alignment
);
[C++]
public: void TextAligned(
   PointF endPoint,
   string* text,
   Alignment alignment
)
[C++/CLI]
public:
void TextAligned(
   PointF endPoint,
   String^ text,
   Alignment alignment
)

Parameters

endPoint
A PointF which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.

See Also

Draw Class | Draw Members | Overload List


TextAligned(Point,Point,String,Font,Alignment,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
A Point which represents the upper-left point where the text is to be aligned from.
endPoint
A Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
font
The fFont the text is to be rendered in.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextAligned(Point,Point,String,Font,Alignment,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextAligned Method : TextAligned(Point,Point,String,Font,Alignment,Boolean) Method

Outputs text with a specified alignment.

[Visual Basic]
Overloads Public Sub TextAligned( _
   ByVal startPoint As Point, _
   ByVal endPoint As Point, _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal alignment As Alignment, _
   ByVal wordWrap As Boolean _
)
[C#]
public void TextAligned(
   Point startPoint,
   Point endPoint,
   string text,
   Font font,
   Alignment alignment,
   bool wordWrap
);
[C++]
public: void TextAligned(
   Point startPoint,
   Point endPoint,
   string* text,
   Font* font,
   Alignment alignment,
   bool wordWrap
)
[C++/CLI]
public:
void TextAligned(
   Point startPoint,
   Point endPoint,
   String^ text,
   Font^ font,
   Alignment alignment,
   bool wordWrap
)

Parameters

startPoint
A Point which represents the upper-left point where the text is to be aligned from.
endPoint
A Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
font
The fFont the text is to be rendered in.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

See Also

Draw Class | Draw Members | Overload List


TextAligned(Rectangle,String,Font,Alignment,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
The bounding Rectangle for the text.
text
A string which represents the text to align and output.
font
The Font the text is to be rendered in.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextAligned(Rectangle,String,Font,Alignment,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextAligned Method : TextAligned(Rectangle,String,Font,Alignment,Boolean) Method

Outputs text with a specified alignment.

[Visual Basic]
Overloads Public Sub TextAligned( _
   ByVal boundingBox As Rectangle, _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal alignment As Alignment, _
   ByVal wordWrap As Boolean _
)
[C#]
public void TextAligned(
   Rectangle boundingBox,
   string text,
   Font font,
   Alignment alignment,
   bool wordWrap
);
[C++]
public: void TextAligned(
   Rectangle boundingBox,
   string* text,
   Font* font,
   Alignment alignment,
   bool wordWrap
)
[C++/CLI]
public:
void TextAligned(
   Rectangle boundingBox,
   String^ text,
   Font^ font,
   Alignment alignment,
   bool wordWrap
)

Parameters

boundingBox
The bounding Rectangle for the text.
text
A string which represents the text to align and output.
font
The Font the text is to be rendered in.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

See Also

Draw Class | Draw Members | Overload List


TextAligned(Point,String,Font,Alignment,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
font
The Font the text is to be rendered in.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextAligned(Point,String,Font,Alignment,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextAligned Method : TextAligned(Point,String,Font,Alignment,Boolean) Method

Outputs text with a specified alignment

[Visual Basic]
Overloads Public Sub TextAligned( _
   ByVal endPoint As Point, _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal alignment As Alignment, _
   ByVal wordWrap As Boolean _
)
[C#]
public void TextAligned(
   Point endPoint,
   string text,
   Font font,
   Alignment alignment,
   bool wordWrap
);
[C++]
public: void TextAligned(
   Point endPoint,
   string* text,
   Font* font,
   Alignment alignment,
   bool wordWrap
)
[C++/CLI]
public:
void TextAligned(
   Point endPoint,
   String^ text,
   Font^ font,
   Alignment alignment,
   bool wordWrap
)

Parameters

endPoint
A Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
font
The Font the text is to be rendered in.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

See Also

Draw Class | Draw Members | Overload List


TextAligned(Point,Point,String,Font,Alignment) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
A Point which represents the upper-left point where the text is to be aligned from.
endPoint
A Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
font
The Font the text is to be rendered in.
alignment
The Alignment of the text.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextAligned(Point,Point,String,Font,Alignment) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextAligned Method : TextAligned(Point,Point,String,Font,Alignment) Method

Outputs text with a specified alignment.

[Visual Basic]
Overloads Public Sub TextAligned( _
   ByVal startPoint As Point, _
   ByVal endPoint As Point, _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal alignment As Alignment _
)
[C#]
public void TextAligned(
   Point startPoint,
   Point endPoint,
   string text,
   Font font,
   Alignment alignment
);
[C++]
public: void TextAligned(
   Point startPoint,
   Point endPoint,
   string* text,
   Font* font,
   Alignment alignment
)
[C++/CLI]
public:
void TextAligned(
   Point startPoint,
   Point endPoint,
   String^ text,
   Font^ font,
   Alignment alignment
)

Parameters

startPoint
A Point which represents the upper-left point where the text is to be aligned from.
endPoint
A Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
font
The Font the text is to be rendered in.
alignment
The Alignment of the text.

See Also

Draw Class | Draw Members | Overload List


TextAligned(Rectangle,String,Font,Alignment) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
The bounding Rectangle for the text.
text
A string which represents the text to align and output.
font
The Font the text is to be rendered in.
alignment
The Alignment of the text.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextAligned(Rectangle,String,Font,Alignment) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextAligned Method : TextAligned(Rectangle,String,Font,Alignment) Method

Outputs text with a specified alignment.

[Visual Basic]
Overloads Public Sub TextAligned( _
   ByVal boundingBox As Rectangle, _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal alignment As Alignment _
)
[C#]
public void TextAligned(
   Rectangle boundingBox,
   string text,
   Font font,
   Alignment alignment
);
[C++]
public: void TextAligned(
   Rectangle boundingBox,
   string* text,
   Font* font,
   Alignment alignment
)
[C++/CLI]
public:
void TextAligned(
   Rectangle boundingBox,
   String^ text,
   Font^ font,
   Alignment alignment
)

Parameters

boundingBox
The bounding Rectangle for the text.
text
A string which represents the text to align and output.
font
The Font the text is to be rendered in.
alignment
The Alignment of the text.

See Also

Draw Class | Draw Members | Overload List


TextAligned(Point,String,Font,Alignment) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
font
The Font the text is to be rendered in.
alignment
The Alignment of the text.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextAligned(Point,String,Font,Alignment) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextAligned Method : TextAligned(Point,String,Font,Alignment) Method

Outputs text with a specified alignment.

[Visual Basic]
Overloads Public Sub TextAligned( _
   ByVal endPoint As Point, _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal alignment As Alignment _
)
[C#]
public void TextAligned(
   Point endPoint,
   string text,
   Font font,
   Alignment alignment
);
[C++]
public: void TextAligned(
   Point endPoint,
   string* text,
   Font* font,
   Alignment alignment
)
[C++/CLI]
public:
void TextAligned(
   Point endPoint,
   String^ text,
   Font^ font,
   Alignment alignment
)

Parameters

endPoint
A Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
font
The Font the text is to be rendered in.
alignment
The Alignment of the text.

See Also

Draw Class | Draw Members | Overload List


TextAligned(Point,Point,String,Alignment,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
A Point which represents the upper-left point where the text is to be aligned from.
endPoint
A Point which represents the lower-right point where the text is to be aligned from.
text
The text to align and output.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextAligned(Point,Point,String,Alignment,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextAligned Method : TextAligned(Point,Point,String,Alignment,Boolean) Method

Outputs text with a specified alignment.

[Visual Basic]
Overloads Public Sub TextAligned( _
   ByVal startPoint As Point, _
   ByVal endPoint As Point, _
   ByVal text As String, _
   ByVal alignment As Alignment, _
   ByVal wordWrap As Boolean _
)
[C#]
public void TextAligned(
   Point startPoint,
   Point endPoint,
   string text,
   Alignment alignment,
   bool wordWrap
);
[C++]
public: void TextAligned(
   Point startPoint,
   Point endPoint,
   string* text,
   Alignment alignment,
   bool wordWrap
)
[C++/CLI]
public:
void TextAligned(
   Point startPoint,
   Point endPoint,
   String^ text,
   Alignment alignment,
   bool wordWrap
)

Parameters

startPoint
A Point which represents the upper-left point where the text is to be aligned from.
endPoint
A Point which represents the lower-right point where the text is to be aligned from.
text
The text to align and output.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

See Also

Draw Class | Draw Members | Overload List


TextAligned(Rectangle,String,Alignment,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
The bounding Rectangle for the text.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextAligned(Rectangle,String,Alignment,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextAligned Method : TextAligned(Rectangle,String,Alignment,Boolean) Method

Outputs text with a specified alignment.

[Visual Basic]
Overloads Public Sub TextAligned( _
   ByVal boundingBox As Rectangle, _
   ByVal text As String, _
   ByVal alignment As Alignment, _
   ByVal wordWrap As Boolean _
)
[C#]
public void TextAligned(
   Rectangle boundingBox,
   string text,
   Alignment alignment,
   bool wordWrap
);
[C++]
public: void TextAligned(
   Rectangle boundingBox,
   string* text,
   Alignment alignment,
   bool wordWrap
)
[C++/CLI]
public:
void TextAligned(
   Rectangle boundingBox,
   String^ text,
   Alignment alignment,
   bool wordWrap
)

Parameters

boundingBox
The bounding Rectangle for the text.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

See Also

Draw Class | Draw Members | Overload List


TextAligned(Point,String,Alignment,Boolean) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextAligned(Point,String,Alignment,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextAligned Method : TextAligned(Point,String,Alignment,Boolean) Method

Outputs text with a specified alignment.

[Visual Basic]
Overloads Public Sub TextAligned( _
   ByVal endPoint As Point, _
   ByVal text As String, _
   ByVal alignment As Alignment, _
   ByVal wordWrap As Boolean _
)
[C#]
public void TextAligned(
   Point endPoint,
   string text,
   Alignment alignment,
   bool wordWrap
);
[C++]
public: void TextAligned(
   Point endPoint,
   string* text,
   Alignment alignment,
   bool wordWrap
)
[C++/CLI]
public:
void TextAligned(
   Point endPoint,
   String^ text,
   Alignment alignment,
   bool wordWrap
)

Parameters

endPoint
A Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

See Also

Draw Class | Draw Members | Overload List


TextAligned(Point,Point,String,Alignment) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

startPoint
A Point which represents the upper-left point where the text is to be aligned from.
endPoint
A Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextAligned(Point,Point,String,Alignment) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextAligned Method : TextAligned(Point,Point,String,Alignment) Method

Outputs text with a specified alignment.

[Visual Basic]
Overloads Public Sub TextAligned( _
   ByVal startPoint As Point, _
   ByVal endPoint As Point, _
   ByVal text As String, _
   ByVal alignment As Alignment _
)
[C#]
public void TextAligned(
   Point startPoint,
   Point endPoint,
   string text,
   Alignment alignment
);
[C++]
public: void TextAligned(
   Point startPoint,
   Point endPoint,
   string* text,
   Alignment alignment
)
[C++/CLI]
public:
void TextAligned(
   Point startPoint,
   Point endPoint,
   String^ text,
   Alignment alignment
)

Parameters

startPoint
A Point which represents the upper-left point where the text is to be aligned from.
endPoint
A Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.

See Also

Draw Class | Draw Members | Overload List


TextAligned(Rectangle,String,Alignment) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

boundingBox
The bounding Rectangle for the text.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextAligned(Rectangle,String,Alignment) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextAligned Method : TextAligned(Rectangle,String,Alignment) Method

Outputs text with a specified alignment.

[Visual Basic]
Overloads Public Sub TextAligned( _
   ByVal boundingBox As Rectangle, _
   ByVal text As String, _
   ByVal alignment As Alignment _
)
[C#]
public void TextAligned(
   Rectangle boundingBox,
   string text,
   Alignment alignment
);
[C++]
public: void TextAligned(
   Rectangle boundingBox,
   string* text,
   Alignment alignment
)
[C++/CLI]
public:
void TextAligned(
   Rectangle boundingBox,
   String^ text,
   Alignment alignment
)

Parameters

boundingBox
The bounding Rectangle for the text.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.

See Also

Draw Class | Draw Members | Overload List


TextAligned(Point,String,Alignment) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

endPoint
A Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextAligned(Point,String,Alignment) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextAligned Method : TextAligned(Point,String,Alignment) Method

Outputs text with a specified alignment.

[Visual Basic]
Overloads Public Sub TextAligned( _
   ByVal endPoint As Point, _
   ByVal text As String, _
   ByVal alignment As Alignment _
)
[C#]
public void TextAligned(
   Point endPoint,
   string text,
   Alignment alignment
);
[C++]
public: void TextAligned(
   Point endPoint,
   string* text,
   Alignment alignment
)
[C++/CLI]
public:
void TextAligned(
   Point endPoint,
   String^ text,
   Alignment alignment
)

Parameters

endPoint
A Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.

See Also

Draw Class | Draw Members | Overload List


TextHeight Method

Draw Class | Draw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextHeight Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class : TextHeight Method

Returns the height the text would be if the output has a specified font.

Overload List

Returns the height the text would be if the output has a specified font.

[Visual Basic] Overloads Public Function TextHeight(Font,String) As Single

[C#] public float TextHeight(Font,string);

[C++] public float TextHeight(Font*,string*);

[C++/CLI] public float TextHeight(Font^,String^);

Returns the height the text would be if drawn with the given text.

[Visual Basic] Overloads Public Function TextHeight(String) As Single

[C#] public float TextHeight(string);

[C++] public float TextHeight(string*);

[C++/CLI] public float TextHeight(String^);

See Also

Draw Class | Draw Members


TextHeight(Font,String) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

font
A Font to use.
text
A string which represents the text to get the printed height of.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextHeight(Font,String) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextHeight Method : TextHeight(Font,String) Method

Returns the height the text would be if the output has a specified font.

[Visual Basic]
Overloads Public Function TextHeight( _
   ByVal font As Font, _
   ByVal text As String _
) As Single
[C#]
public float TextHeight(
   Font font,
   string text
);
[C++]
public: float TextHeight(
   Font* font,
   string* text
)
[C++/CLI]
public:
float TextHeight(
   Font^ font,
   String^ text
)

Parameters

font
A Font to use.
text
A string which represents the text to get the printed height of.

Return Type

A float value which represents the height of the text when printed.

See Also

Draw Class | Draw Members | Overload List


TextHeight(String) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

text
A string which represents the text to get the printed height of.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextHeight(String) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextHeight Method : TextHeight(String) Method

Returns the height the text would be if drawn with the given text.

[Visual Basic]
Overloads Public Function TextHeight( _
   ByVal text As String _
) As Single
[C#]
public float TextHeight(
   string text
);
[C++]
public: float TextHeight(
   string* text
)
[C++/CLI]
public:
float TextHeight(
   String^ text
)

Parameters

text
A string which represents the text to get the printed height of.

Return Type

A float value which represents the height of the text when printed.

See Also

Draw Class | Draw Members | Overload List


TextRotated Method

Draw Class | Draw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextRotated Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class : TextRotated Method

Outputs text rotated by a specified number of degrees.

Overload List

Outputs text rotated by a specified number of degrees.

[Visual Basic] Overloads Public Sub TextRotated(PointF,Single,RotationPivotMode,String,Font)

[C#] public void TextRotated(PointF,float,RotationPivotMode,string,Font);

[C++] public void TextRotated(PointF,float,RotationPivotMode,string*,Font*);

[C++/CLI] public void TextRotated(PointF,float,RotationPivotMode,String^,Font^);

Outputs text rotated by specified number of degrees.

[Visual Basic] Overloads Public Sub TextRotated(Single,RotationPivotMode,String,Font)

[C#] public void TextRotated(float,RotationPivotMode,string,Font);

[C++] public void TextRotated(float,RotationPivotMode,string*,Font*);

[C++/CLI] public void TextRotated(float,RotationPivotMode,String^,Font^);

Outputs text rotated by a specified number of degrees.

[Visual Basic] Overloads Public Sub TextRotated(PointF,Single,RotationPivotMode,String)

[C#] public void TextRotated(PointF,float,RotationPivotMode,string);

[C++] public void TextRotated(PointF,float,RotationPivotMode,string*);

[C++/CLI] public void TextRotated(PointF,float,RotationPivotMode,String^);

Outputs text rotated by a specified number of degrees.

[Visual Basic] Overloads Public Sub TextRotated(Single,RotationPivotMode,String)

[C#] public void TextRotated(float,RotationPivotMode,string);

[C++] public void TextRotated(float,RotationPivotMode,string*);

[C++/CLI] public void TextRotated(float,RotationPivotMode,String^);

Outputs text rotated by a specified number of degrees.

[Visual Basic] Overloads Public Sub TextRotated(Point,Single,RotationPivotMode,String,Font)

[C#] public void TextRotated(Point,float,RotationPivotMode,string,Font);

[C++] public void TextRotated(Point,float,RotationPivotMode,string*,Font*);

[C++/CLI] public void TextRotated(Point,float,RotationPivotMode,String^,Font^);

Outputs text rotated by a specified number of degrees.

[Visual Basic] Overloads Public Sub TextRotated(Point,Single,RotationPivotMode,String)

[C#] public void TextRotated(Point,float,RotationPivotMode,string);

[C++] public void TextRotated(Point,float,RotationPivotMode,string*);

[C++/CLI] public void TextRotated(Point,float,RotationPivotMode,String^);

See Also

Draw Class | Draw Members


TextRotated(PointF,Single,RotationPivotMode,String,Font) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

location
A PointF which represents the location for the origin of rotation.
angle
A single value which represents the angle by which to rotate.
pivotMode
The RotationPivotMode the text is aligned to the rotation by.
text
A string which represents the text to output.
font
The Font to render the text in.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextRotated(PointF,Single,RotationPivotMode,String,Font) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextRotated Method : TextRotated(PointF,Single,RotationPivotMode,String,Font) Method

Outputs text rotated by a specified number of degrees.

[Visual Basic]
Overloads Public Sub TextRotated( _
   ByVal location As PointF, _
   ByVal angle As Single, _
   ByVal pivotMode As RotationPivotMode, _
   ByVal text As String, _
   ByVal font As Font _
)
[C#]
public void TextRotated(
   PointF location,
   float angle,
   RotationPivotMode pivotMode,
   string text,
   Font font
);
[C++]
public: void TextRotated(
   PointF location,
   float angle,
   RotationPivotMode pivotMode,
   string* text,
   Font* font
)
[C++/CLI]
public:
void TextRotated(
   PointF location,
   float angle,
   RotationPivotMode pivotMode,
   String^ text,
   Font^ font
)

Parameters

location
A PointF which represents the location for the origin of rotation.
angle
A single value which represents the angle by which to rotate.
pivotMode
The RotationPivotMode the text is aligned to the rotation by.
text
A string which represents the text to output.
font
The Font to render the text in.

See Also

Draw Class | Draw Members | Overload List


TextRotated(Single,RotationPivotMode,String,Font) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

angle
A single which represents the angle by which to rotate.
pivotMode
The RotationPivotMode the text is aligned to the rotation by.
text
A string which represents the text to output.
font
The Font to render the text in.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextRotated(Single,RotationPivotMode,String,Font) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextRotated Method : TextRotated(Single,RotationPivotMode,String,Font) Method

Outputs text rotated by specified number of degrees.

[Visual Basic]
Overloads Public Sub TextRotated( _
   ByVal angle As Single, _
   ByVal pivotMode As RotationPivotMode, _
   ByVal text As String, _
   ByVal font As Font _
)
[C#]
public void TextRotated(
   float angle,
   RotationPivotMode pivotMode,
   string text,
   Font font
);
[C++]
public: void TextRotated(
   float angle,
   RotationPivotMode pivotMode,
   string* text,
   Font* font
)
[C++/CLI]
public:
void TextRotated(
   float angle,
   RotationPivotMode pivotMode,
   String^ text,
   Font^ font
)

Parameters

angle
A single which represents the angle by which to rotate.
pivotMode
The RotationPivotMode the text is aligned to the rotation by.
text
A string which represents the text to output.
font
The Font to render the text in.

See Also

Draw Class | Draw Members | Overload List


TextRotated(PointF,Single,RotationPivotMode,String) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

location
A Point which represents the location for the origin of rotation.
angle
A single value which represents the angle by which to rotate.
pivotMode
The RotationPivotMode the text is aligned to the rotation by.
text
A string which represents the text to output.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextRotated(PointF,Single,RotationPivotMode,String) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextRotated Method : TextRotated(PointF,Single,RotationPivotMode,String) Method

Outputs text rotated by a specified number of degrees.

[Visual Basic]
Overloads Public Sub TextRotated( _
   ByVal location As PointF, _
   ByVal angle As Single, _
   ByVal pivotMode As RotationPivotMode, _
   ByVal text As String _
)
[C#]
public void TextRotated(
   PointF location,
   float angle,
   RotationPivotMode pivotMode,
   string text
);
[C++]
public: void TextRotated(
   PointF location,
   float angle,
   RotationPivotMode pivotMode,
   string* text
)
[C++/CLI]
public:
void TextRotated(
   PointF location,
   float angle,
   RotationPivotMode pivotMode,
   String^ text
)

Parameters

location
A Point which represents the location for the origin of rotation.
angle
A single value which represents the angle by which to rotate.
pivotMode
The RotationPivotMode the text is aligned to the rotation by.
text
A string which represents the text to output.

See Also

Draw Class | Draw Members | Overload List


TextRotated(Single,RotationPivotMode,String) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

angle
A single value which represents the angle by which to rotate.
pivotMode
The RotationPivotMode the text is aligned to the rotation by.
text
A string which represents the text to output.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextRotated(Single,RotationPivotMode,String) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextRotated Method : TextRotated(Single,RotationPivotMode,String) Method

Outputs text rotated by a specified number of degrees.

[Visual Basic]
Overloads Public Sub TextRotated( _
   ByVal angle As Single, _
   ByVal pivotMode As RotationPivotMode, _
   ByVal text As String _
)
[C#]
public void TextRotated(
   float angle,
   RotationPivotMode pivotMode,
   string text
);
[C++]
public: void TextRotated(
   float angle,
   RotationPivotMode pivotMode,
   string* text
)
[C++/CLI]
public:
void TextRotated(
   float angle,
   RotationPivotMode pivotMode,
   String^ text
)

Parameters

angle
A single value which represents the angle by which to rotate.
pivotMode
The RotationPivotMode the text is aligned to the rotation by.
text
A string which represents the text to output.

See Also

Draw Class | Draw Members | Overload List


TextRotated(Point,Single,RotationPivotMode,String,Font) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

location
A Point which represents the location for the origin of rotation.
angle
A single value which represents the angle by which to rotate.
pivotMode
The RotationPivotMode the text is aligned to the rotation by.
text
A string which represents the text to output.
font
The Font to render the text in.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextRotated(Point,Single,RotationPivotMode,String,Font) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextRotated Method : TextRotated(Point,Single,RotationPivotMode,String,Font) Method

Outputs text rotated by a specified number of degrees.

[Visual Basic]
Overloads Public Sub TextRotated( _
   ByVal location As Point, _
   ByVal angle As Single, _
   ByVal pivotMode As RotationPivotMode, _
   ByVal text As String, _
   ByVal font As Font _
)
[C#]
public void TextRotated(
   Point location,
   float angle,
   RotationPivotMode pivotMode,
   string text,
   Font font
);
[C++]
public: void TextRotated(
   Point location,
   float angle,
   RotationPivotMode pivotMode,
   string* text,
   Font* font
)
[C++/CLI]
public:
void TextRotated(
   Point location,
   float angle,
   RotationPivotMode pivotMode,
   String^ text,
   Font^ font
)

Parameters

location
A Point which represents the location for the origin of rotation.
angle
A single value which represents the angle by which to rotate.
pivotMode
The RotationPivotMode the text is aligned to the rotation by.
text
A string which represents the text to output.
font
The Font to render the text in.

See Also

Draw Class | Draw Members | Overload List


TextRotated(Point,Single,RotationPivotMode,String) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

location
A Point which represents the location for the origin of rotation.
angle
A single value which represents the angle by which to rotate.
pivotMode
The RotationPivotMode the text is aligned to the rotation by.
text
A string which represents the text to output.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextRotated(Point,Single,RotationPivotMode,String) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextRotated Method : TextRotated(Point,Single,RotationPivotMode,String) Method

Outputs text rotated by a specified number of degrees.

[Visual Basic]
Overloads Public Sub TextRotated( _
   ByVal location As Point, _
   ByVal angle As Single, _
   ByVal pivotMode As RotationPivotMode, _
   ByVal text As String _
)
[C#]
public void TextRotated(
   Point location,
   float angle,
   RotationPivotMode pivotMode,
   string text
);
[C++]
public: void TextRotated(
   Point location,
   float angle,
   RotationPivotMode pivotMode,
   string* text
)
[C++/CLI]
public:
void TextRotated(
   Point location,
   float angle,
   RotationPivotMode pivotMode,
   String^ text
)

Parameters

location
A Point which represents the location for the origin of rotation.
angle
A single value which represents the angle by which to rotate.
pivotMode
The RotationPivotMode the text is aligned to the rotation by.
text
A string which represents the text to output.

See Also

Draw Class | Draw Members | Overload List


TextWidth Method

Draw Class | Draw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextWidth Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class : TextWidth Method

Returns the width the text would be if output with specified font.

Overload List

Returns the width the text would be if output with specified font.

[Visual Basic] Overloads Public Function TextWidth(Font,String) As Single

[C#] public float TextWidth(Font,string);

[C++] public float TextWidth(Font*,string*);

[C++/CLI] public float TextWidth(Font^,String^);

Returns the width the text would be if output with the given text.

[Visual Basic] Overloads Public Function TextWidth(String) As Single

[C#] public float TextWidth(string);

[C++] public float TextWidth(string*);

[C++/CLI] public float TextWidth(String^);

See Also

Draw Class | Draw Members


TextWidth(Font,String) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

font
A Font to use with the given text.
text
A string which represents the text to get the printed height of.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextWidth(Font,String) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextWidth Method : TextWidth(Font,String) Method

Returns the width the text would be if output with specified font.

[Visual Basic]
Overloads Public Function TextWidth( _
   ByVal font As Font, _
   ByVal text As String _
) As Single
[C#]
public float TextWidth(
   Font font,
   string text
);
[C++]
public: float TextWidth(
   Font* font,
   string* text
)
[C++/CLI]
public:
float TextWidth(
   Font^ font,
   String^ text
)

Parameters

font
A Font to use with the given text.
text
A string which represents the text to get the printed height of.

Return Type

A float value which represents the width of the text when printed.

See Also

Draw Class | Draw Members | Overload List


TextWidth(String) Method

Draw Class | Draw Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

text
A string which represents the text to get the printed height of.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TextWidth(String) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class > TextWidth Method : TextWidth(String) Method

Returns the width the text would be if output with the given text.

[Visual Basic]
Overloads Public Function TextWidth( _
   ByVal text As String _
) As Single
[C#]
public float TextWidth(
   string text
);
[C++]
public: float TextWidth(
   string* text
)
[C++/CLI]
public:
float TextWidth(
   String^ text
)

Parameters

text
A string which represents the text to get the printed height of.

Return Type

A float value which represents the width of the text when printed.

See Also

Draw Class | Draw Members | Overload List


Draw Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Draw Class Properties

PegasusImaging.WinForms.PrintPro4 Namespace : Draw Class (PegasusImaging.WinForms.PrintPro4)

For a list of all members of this type, see Draw members.

Public Properties

Public Property BackColor | Gets and sets the background color used for drawing.
Public Property BackStyle | Gets and sets the background style used for drawing.
Public Property CurrentX | Gets and sets the current x (horizontal) coordinate the draw cursor is at.
Public Property CurrentY | Gets and sets the current y (vertical) coordinate the draw cursor is at.
Public Property FillColor | Gets and sets the fill color used for drawing.
Public Property FillStyle | Gets and sets the FillStyle used for drawing.
Public Property ForeColor | Gets and sets the foreground color used for drawing.
Public Property Mode | Gets and sets the DrawMode enumeration value used for drawing.
Public Property Style | Gets and sets the DrawStyle used for drawing.
Public Property Width | Gets and sets the width of the pen used for drawing.

See Also

Draw Class | PegasusImaging.WinForms.PrintPro4 Namespace


BackColor Property

Draw Class | Draw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

BackColor Property

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class : BackColor Property

Gets and sets the background color used for drawing.

[Visual Basic]
Public Property BackColor As Color
[C#]
public Color BackColor {get; set;}
[C++]
public: __property Color get_BackColor();
public: __property void set_BackColor(
   Color value
);
[C++/CLI]
public:
property Color BackColor {
   Color get();
   void set (Color value);
}

Value

A Color used as the background color in drawing.

See Also

Draw Class | Draw Members


BackStyle Property

Draw Class | Draw Members | BackStyle Enumeration

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

BackStyle Property

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class : BackStyle Property (Draw)

Gets and sets the background style used for drawing.

[Visual Basic]
Public Property BackStyle As BackStyle
[C#]
public BackStyle BackStyle {get; set;}
[C++]
public: __property BackStyle get_BackStyle();
public: __property void set_BackStyle(
   BackStyle value
);
[C++/CLI]
public:
property BackStyle BackStyle {
   BackStyle get();
   void set (BackStyle value);
}

Value

A BackStyle enumeration value which determines the background style used for drawing.

Remarks

The default value is BackStyle.Transparent.

See Also

Draw Class | Draw Members | BackStyle Enumeration


CurrentX Property

Draw Class | Draw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

CurrentX Property

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class : CurrentX Property

Gets and sets the current x (horizontal) coordinate the draw cursor is at.

[Visual Basic]
Public Property CurrentX As Single
[C#]
public float CurrentX {get; set;}
[C++]
public: __property float get_CurrentX();
public: __property void set_CurrentX(
   float value
);
[C++/CLI]
public:
property float CurrentX {
   float get();
   void set (float value);
}

Value

A single value which represents the x coordinate.

See Also

Draw Class | Draw Members


CurrentY Property

Draw Class | Draw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

CurrentY Property

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class : CurrentY Property

Gets and sets the current y (vertical) coordinate the draw cursor is at.

[Visual Basic]
Public Property CurrentY As Single
[C#]
public float CurrentY {get; set;}
[C++]
public: __property float get_CurrentY();
public: __property void set_CurrentY(
   float value
);
[C++/CLI]
public:
property float CurrentY {
   float get();
   void set (float value);
}

Value

A single value which represents the y coordinate.

See Also

Draw Class | Draw Members


FillColor Property

Draw Class | Draw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

FillColor Property

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class : FillColor Property

Gets and sets the fill color used for drawing.

[Visual Basic]
Public Property FillColor As Color
[C#]
public Color FillColor {get; set;}
[C++]
public: __property Color get_FillColor();
public: __property void set_FillColor(
   Color value
);
[C++/CLI]
public:
property Color FillColor {
   Color get();
   void set (Color value);
}

Value

A Color value used as the fill color for drawing.

See Also

Draw Class | Draw Members


FillStyle Property

Draw Class | Draw Members | FillStyle Enumeration

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

FillStyle Property

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class : FillStyle Property (Draw)

Gets and sets the FillStyle used for drawing.

[Visual Basic]
Public Property FillStyle As FillStyle
[C#]
public FillStyle FillStyle {get; set;}
[C++]
public: __property FillStyle get_FillStyle();
public: __property void set_FillStyle(
   FillStyle value
);
[C++/CLI]
public:
property FillStyle FillStyle {
   FillStyle get();
   void set (FillStyle value);
}

Value

A FillStyle enumeration value which determines the fill style used for drawing.

Remarks

The default value is FillStyle.Transparent.

See Also

Draw Class | Draw Members | FillStyle Enumeration


ForeColor Property

Draw Class | Draw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

ForeColor Property

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class : ForeColor Property

Gets and sets the foreground color used for drawing.

[Visual Basic]
Public Property ForeColor As Color
[C#]
public Color ForeColor {get; set;}
[C++]
public: __property Color get_ForeColor();
public: __property void set_ForeColor(
   Color value
);
[C++/CLI]
public:
property Color ForeColor {
   Color get();
   void set (Color value);
}

Value

A Color value used for the foreground color in drawing.

See Also

Draw Class | Draw Members


Mode Property

Draw Class | Draw Members | DrawMode Enumeration

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Mode Property

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class : Mode Property

Gets and sets the DrawMode enumeration value used for drawing.

[Visual Basic]
Public Property Mode As DrawMode
[C#]
public DrawMode Mode {get; set;}
[C++]
public: __property DrawMode get_Mode();
public: __property void set_Mode(
   DrawMode value
);
[C++/CLI]
public:
property DrawMode Mode {
   DrawMode get();
   void set (DrawMode value);
}

Value

A DrawMode enumeration option value which determines the mode for drawing.

Remarks

The default value is DrawMode.CopyPen.

See Also

Draw Class | Draw Members | DrawMode Enumeration


Style Property

Draw Class | Draw Members | DrawStyle Enumeration

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Style Property

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class : Style Property

Gets and sets the DrawStyle used for drawing.

[Visual Basic]
Public Property Style As DrawStyle
[C#]
public DrawStyle Style {get; set;}
[C++]
public: __property DrawStyle get_Style();
public: __property void set_Style(
   DrawStyle value
);
[C++/CLI]
public:
property DrawStyle Style {
   DrawStyle get();
   void set (DrawStyle value);
}

Value

A DrawStyle enumeration value which determines the style used for drawing.

Remarks

The default value is DrawStyle.Solid.

See Also

Draw Class | Draw Members | DrawStyle Enumeration


Width Property

Draw Class | Draw Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Width Property

PegasusImaging.WinForms.PrintPro4 Namespace > Draw Class : Width Property

Gets and sets the width of the pen used for drawing.

[Visual Basic]
Public Property Width As Integer
[C#]
public int Width {get; set;}
[C++]
public: __property int get_Width();
public: __property void set_Width(
   int value
);
[C++/CLI]
public:
property int Width {
   int get();
   void set (int value);
}

Value

An integer which represents the width of the pen used for drawing.

Remarks

The default value is 0.

See Also

Draw Class | Draw Members


Icm Class

Icm Members | PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Icm Class

PegasusImaging.WinForms.PrintPro4 Namespace : Icm Class (PegasusImaging.WinForms.PrintPro4)

Ths class implements image color matching settings.

For a list of all members of this type, see Icm members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.PrintPro4.Icm

Syntax

[Visual Basic]
Public Class Icm
[C#]
public class Icm
[C++]
public __gc class Icm
[C++/CLI]
public ref class Icm

See Also

Icm Members | PegasusImaging.WinForms.PrintPro4 Namespace


Icm Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Icm Class Members

PegasusImaging.WinForms.PrintPro4 Namespace : Icm Class (PegasusImaging.WinForms.PrintPro4)

Icm overview

Public Constructors

Public Constructor Icm Constructor Overloaded. The main ICM (Image Color Matching) settings constructor for use in print jobs.

Public Properties

Public Property Intent | Gets and sets a value that specifies which of three possible color management methods, or intents, should be used by default (if the printer supports this feature).
Public Property Method | Gets and sets a value that specifies how Image Color Management (ICM) is handled.
Public Property MonitorProfile | Gets and sets the file name of the monitor's color management profile.
Public Property PrinterProfile | Gets and sets the filename of the printer's color management profile.
Public Property RenderIntent | Gets and sets the purpose of the color correction.
Public Property WantProof | Gets and sets an indicator that proof print matching is requested.

See Also

Icm Class | PegasusImaging.WinForms.PrintPro4 Namespace


Icm Constructor

Icm Class | Icm Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Icm Constructor

PegasusImaging.WinForms.PrintPro4 Namespace > Icm Class : Icm Constructor (Icm)

The main ICM (Image Color Matching) settings constructor for use in print jobs.

Overload List

The main ICM (Image Color Matching) settings constructor for use in print jobs.

[Visual Basic] Public Sub New()

[C#] public Icm();

[C++] public Icm();

[C++/CLI] public Icm();

Creates an ICM settings object for use in print job construction.

[Visual Basic] Public Sub New(String,String)

[C#] public Icm(string,string);

[C++] public Icm(string*,string*);

[C++/CLI] public Icm(String^,String^);

Creates an ICM settings object for use in print job construction.

[Visual Basic] Public Sub New(String,String,IcmRenderIntent)

[C#] public Icm(string,string,IcmRenderIntent);

[C++] public Icm(string*,string*,IcmRenderIntent);

[C++/CLI] public Icm(String^,String^,IcmRenderIntent);

See Also

Icm Class | Icm Members


Icm Constructor()

Icm Class | Icm Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Icm Constructor()

PegasusImaging.WinForms.PrintPro4 Namespace > Icm Class > Icm Constructor : Icm Constructor()

The main ICM (Image Color Matching) settings constructor for use in print jobs.

[Visual Basic]
Public Function New()
[C#]
public Icm();
[C++]
public: Icm();
[C++/CLI]
public:
Icm();

See Also

Icm Class | Icm Members | Overload List


Icm Constructor(String,String)

Icm Class | Icm Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

monitorProfile
A string which represents the filename of the monitor's color management profile.
printerProfile
A string which represents the filename of the printer's color management profile.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Icm Constructor(String,String)

PegasusImaging.WinForms.PrintPro4 Namespace > Icm Class > Icm Constructor : Icm Constructor(String,String)

Creates an ICM settings object for use in print job construction.

[Visual Basic]
Public Function New( _
   ByVal monitorProfile As String, _
   ByVal printerProfile As String _
)
[C#]
public Icm(
   string monitorProfile,
   string printerProfile
);
[C++]
public: Icm(
   string* monitorProfile,
   string* printerProfile
)
[C++/CLI]
public:
Icm(
   String^ monitorProfile,
   String^ printerProfile
)

Parameters

monitorProfile
A string which represents the filename of the monitor's color management profile.
printerProfile
A string which represents the filename of the printer's color management profile.

Remarks

It automatically sets the method used to profile, and the profiles for use to the values below.

See Also

Icm Class | Icm Members | Overload List


Icm Constructor(String,String,IcmRenderIntent)

Icm Class | Icm Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

monitorProfile
A string which represents the filename of the monitor's color management profile.
printerProfile
A string which represents the filename of the printer's color management profile.
profileRenderIntent
An IcmRenderIntent enumeration value which specifies the purpose of the color correction.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Icm Constructor(String,String,IcmRenderIntent)

PegasusImaging.WinForms.PrintPro4 Namespace > Icm Class > Icm Constructor : Icm Constructor(String,String,IcmRenderIntent)

Creates an ICM settings object for use in print job construction.

[Visual Basic]
Public Function New( _
   ByVal monitorProfile As String, _
   ByVal printerProfile As String, _
   ByVal profileRenderIntent As IcmRenderIntent _
)
[C#]
public Icm(
   string monitorProfile,
   string printerProfile,
   IcmRenderIntent profileRenderIntent
);
[C++]
public: Icm(
   string* monitorProfile,
   string* printerProfile,
   IcmRenderIntent profileRenderIntent
)
[C++/CLI]
public:
Icm(
   String^ monitorProfile,
   String^ printerProfile,
   IcmRenderIntent profileRenderIntent
)

Parameters

monitorProfile
A string which represents the filename of the monitor's color management profile.
printerProfile
A string which represents the filename of the printer's color management profile.
profileRenderIntent
An IcmRenderIntent enumeration value which specifies the purpose of the color correction.

Remarks

It automatically sets the method used to profile, and the profiles for use to the values below. If the parameter ProfileRenderIntent is set to None, then Image Color Management is disabled.

See Also

Icm Class | Icm Members | Overload List


Icm Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Icm Class Properties

PegasusImaging.WinForms.PrintPro4 Namespace : Icm Class (PegasusImaging.WinForms.PrintPro4)

For a list of all members of this type, see Icm members.

Public Properties

Public Property Intent | Gets and sets a value that specifies which of three possible color management methods, or intents, should be used by default (if the printer supports this feature).
Public Property Method | Gets and sets a value that specifies how Image Color Management (ICM) is handled.
Public Property MonitorProfile | Gets and sets the file name of the monitor's color management profile.
Public Property PrinterProfile | Gets and sets the filename of the printer's color management profile.
Public Property RenderIntent | Gets and sets the purpose of the color correction.
Public Property WantProof | Gets and sets an indicator that proof print matching is requested.

See Also

Icm Class | PegasusImaging.WinForms.PrintPro4 Namespace


Intent Property

Icm Class | Icm Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Intent Property

PegasusImaging.WinForms.PrintPro4 Namespace > Icm Class : Intent Property

Gets and sets a value that specifies which of three possible color management methods, or intents, should be used by default (if the printer supports this feature).

[Visual Basic]
Public Property Intent As IcmIntent
[C#]
public IcmIntent Intent {get; set;}
[C++]
public: __property IcmIntent get_Intent();
public: __property void set_Intent(
   IcmIntent value
);
[C++/CLI]
public:
property IcmIntent Intent {
   IcmIntent get();
   void set (IcmIntent value);
}

Value

An IcmIntent enumeration value which determines the color management methods.

Remarks

The default value is IcmIntent.ColorMetric.

See Also

Icm Class | Icm Members


Method Property

Icm Class | Icm Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Method Property

PegasusImaging.WinForms.PrintPro4 Namespace > Icm Class : Method Property

Gets and sets a value that specifies how Image Color Management (ICM) is handled.

[Visual Basic]
Public Property Method As IcmMethod
[C#]
public IcmMethod Method {get; set;}
[C++]
public: __property IcmMethod get_Method();
public: __property void set_Method(
   IcmMethod value
);
[C++/CLI]
public:
property IcmMethod Method {
   IcmMethod get();
   void set (IcmMethod value);
}

Value

An IcmMethod enumeration value which determines how ICM is handled.

Remarks

The default value is IcmMethod.System.

See Also

Icm Class | Icm Members


MonitorProfile Property

Icm Class | Icm Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

MonitorProfile Property

PegasusImaging.WinForms.PrintPro4 Namespace > Icm Class : MonitorProfile Property

Gets and sets the file name of the monitor's color management profile.

[Visual Basic]
Public Property MonitorProfile As String
[C#]
public string MonitorProfile {get; set;}
[C++]
public: __property string* get_MonitorProfile();
public: __property void set_MonitorProfile(
   string* value
);
[C++/CLI]
public:
property String^ MonitorProfile {
   String^ get();
   void set (String^ value);
}

Value

A string value which represents the filename of the monitor's color management profile.

Remarks

The default value is an empty string "".

See Also

Icm Class | Icm Members


PrinterProfile Property

Icm Class | Icm Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrinterProfile Property

PegasusImaging.WinForms.PrintPro4 Namespace > Icm Class : PrinterProfile Property

Gets and sets the filename of the printer's color management profile.

[Visual Basic]
Public Property PrinterProfile As String
[C#]
public string PrinterProfile {get; set;}
[C++]
public: __property string* get_PrinterProfile();
public: __property void set_PrinterProfile(
   string* value
);
[C++/CLI]
public:
property String^ PrinterProfile {
   String^ get();
   void set (String^ value);
}

Value

A string value which represents the filename of the printer's color management profile.

Remarks

The default value is an empty string "".

See Also

Icm Class | Icm Members


RenderIntent Property

Icm Class | Icm Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

RenderIntent Property

PegasusImaging.WinForms.PrintPro4 Namespace > Icm Class : RenderIntent Property

Gets and sets the purpose of the color correction.

[Visual Basic]
Public Property RenderIntent As IcmRenderIntent
[C#]
public IcmRenderIntent RenderIntent {get; set;}
[C++]
public: __property IcmRenderIntent get_RenderIntent();
public: __property void set_RenderIntent(
   IcmRenderIntent value
);
[C++/CLI]
public:
property IcmRenderIntent RenderIntent {
   IcmRenderIntent get();
   void set (IcmRenderIntent value);
}

Value

An IcmRenderIntent enumeration value which determines the purpose of the color correction.

Remarks

The default value is IcmRenderIntent.Images.

See Also

Icm Class | Icm Members


WantProof Property

Icm Class | Icm Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

WantProof Property

PegasusImaging.WinForms.PrintPro4 Namespace > Icm Class : WantProof Property

Gets and sets an indicator that proof print matching is requested.

[Visual Basic]
Public Property WantProof As Boolean
[C#]
public bool WantProof {get; set;}
[C++]
public: __property bool get_WantProof();
public: __property void set_WantProof(
   bool value
);
[C++/CLI]
public:
property bool WantProof {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true when proof print matching is requested. Otherwise, false is returned.

Remarks

The default value is false.

See Also

Icm Class | Icm Members


Licensing Class

Licensing Members | PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Licensing Class

PegasusImaging.WinForms.PrintPro4 Namespace : Licensing Class (PegasusImaging.WinForms.PrintPro4)

This class implements methods for setting the license information for the toolkit.

For a list of all members of this type, see Licensing members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.PrintPro4.Licensing

Syntax

[Visual Basic]
Public Class Licensing
[C#]
public class Licensing
[C++]
public __gc class Licensing
[C++/CLI]
public ref class Licensing

Remarks

This object exposes the licensing methods you need to call to license the toolkit.

See Also

Licensing Members | PegasusImaging.WinForms.PrintPro4 Namespace


Licensing Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Licensing Class Members

PegasusImaging.WinForms.PrintPro4 Namespace : Licensing Class (PegasusImaging.WinForms.PrintPro4)

Licensing overview

Public Constructors

Public Constructor Licensing Constructor The initial constructor for the licensing class passing in a workspace ID.

Public Properties

Public Property EvaluationMode Gets and sets how the control will behave when in evaluation (non-licensed) mode.

Public Methods

Public Method Dispose | Disposes of unmanaged resources.
Public Method UnlockRuntime | Called to allow the control to run as a non-trial mode.
Public Method UnlockWeb | Called to allow the control to run as a non-trial mode when being used on a web page.

See Also

Licensing Class | PegasusImaging.WinForms.PrintPro4 Namespace


Licensing Constructor

Licensing Class | Licensing Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

pWorkId
A PrintPRO workspace ID.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Licensing Constructor

PegasusImaging.WinForms.PrintPro4 Namespace > Licensing Class : Licensing Constructor (Licensing)

The initial constructor for the licensing class passing in a workspace ID.

[Visual Basic]
Public Function New( _
   ByVal pWorkId As IntPtr _
)
[C#]
public Licensing(
   IntPtr pWorkId
);
[C++]
public: Licensing(
   IntPtr pWorkId
)
[C++/CLI]
public:
Licensing(
   IntPtr pWorkId
)

Parameters

pWorkId
A PrintPRO workspace ID.

See Also

Licensing Class | Licensing Members


Dispose Method

Licensing Class | Licensing Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.PrintPro4 Namespace > Licensing Class : Dispose Method (Licensing)

Disposes of unmanaged resources.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

Remarks

This method is part of the IDisposable interface.

See Also

Licensing Class | Licensing Members


UnlockRuntime Method

Licensing Class | Licensing Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

v1
The first in the set of four unlock codes that were given at the time of purchase.
v2
The second in the set of four unlock codes that were given at the time of purchase.
v3
The third in the set of four unlock codes that were given at the time of purchase.
v4
The fourth in the set of four unlock codes that were given at the time of purchase.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

UnlockRuntime Method

PegasusImaging.WinForms.PrintPro4 Namespace > Licensing Class : UnlockRuntime Method

Called to allow the control to run as a non-trial mode.

[Visual Basic]
Public Sub UnlockRuntime( _
   ByVal v1 As Integer, _
   ByVal v2 As Integer, _
   ByVal v3 As Integer, _
   ByVal v4 As Integer _
)
[C#]
public void UnlockRuntime(
   int v1,
   int v2,
   int v3,
   int v4
);
[C++]
public: void UnlockRuntime(
   int v1,
   int v2,
   int v3,
   int v4
)
[C++/CLI]
public:
void UnlockRuntime(
   int v1,
   int v2,
   int v3,
   int v4
)

Parameters

v1
The first in the set of four unlock codes that were given at the time of purchase.
v2
The second in the set of four unlock codes that were given at the time of purchase.
v3
The third in the set of four unlock codes that were given at the time of purchase.
v4
The fourth in the set of four unlock codes that were given at the time of purchase.

See Also

Licensing Class | Licensing Members


UnlockWeb Method

Licensing Class | Licensing Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

unlockCode
The unlock code that was given at the time of purchase.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

UnlockWeb Method

PegasusImaging.WinForms.PrintPro4 Namespace > Licensing Class : UnlockWeb Method

Called to allow the control to run as a non-trial mode when being used on a web page.

[Visual Basic]
Public Sub UnlockWeb( _
   ByVal unlockCode As String _
)
[C#]
public void UnlockWeb(
   string unlockCode
);
[C++]
public: void UnlockWeb(
   string* unlockCode
)
[C++/CLI]
public:
void UnlockWeb(
   String^ unlockCode
)

Parameters

unlockCode
The unlock code that was given at the time of purchase.

See Also

Licensing Class | Licensing Members


Licensing Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Licensing Class Properties

PegasusImaging.WinForms.PrintPro4 Namespace : Licensing Class (PegasusImaging.WinForms.PrintPro4)

For a list of all members of this type, see Licensing members.

Public Properties

Public Property EvaluationMode Gets and sets how the control will behave when in evaluation (non-licensed) mode.

See Also

Licensing Class | PegasusImaging.WinForms.PrintPro4 Namespace


EvaluationMode Property

Licensing Class | Licensing Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

EvaluationMode Property

PegasusImaging.WinForms.PrintPro4 Namespace > Licensing Class : EvaluationMode Property (Licensing)

Gets and sets how the control will behave when in evaluation (non-licensed) mode.

[Visual Basic]
Public Property EvaluationMode As EvaluationMode
[C#]
public EvaluationMode EvaluationMode {get; set;}
[C++]
public: __property EvaluationMode get_EvaluationMode();
public: __property void set_EvaluationMode(
   EvaluationMode value
);
[C++/CLI]
public:
property EvaluationMode EvaluationMode {
   EvaluationMode get();
   void set (EvaluationMode value);
}

Value

An EvaluationMode enumeration value which determines the evaluation mode behavior for the component.

See Also

Licensing Class | Licensing Members


Paper Class

Paper Members | PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Paper Class

PegasusImaging.WinForms.PrintPro4 Namespace : Paper Class (PegasusImaging.WinForms.PrintPro4)

This class implements methods and properties to define types of paper.

For a list of all members of this type, see Paper members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.PrintPro4.Paper
PegasusImaging.WinForms.PrintPro4.UserPaper

Syntax

[Visual Basic]
Public Class Paper
[C#]
public class Paper
[C++]
public __gc class Paper
[C++/CLI]
public ref class Paper

See Also

Paper Members | PegasusImaging.WinForms.PrintPro4 Namespace


Paper Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Paper Class Members

PegasusImaging.WinForms.PrintPro4 Namespace : Paper Class (PegasusImaging.WinForms.PrintPro4)

Paper overview

Public Properties

Public Property Id | Gets the ID of the paper.
Public Property Name | Gets the name of the paper.

Public Methods

Public Method ToString Overridden. Creates a string and returns the paper name.

See Also

Paper Class | PegasusImaging.WinForms.PrintPro4 Namespace


ToString Method

Paper Class | Paper Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.PrintPro4 Namespace > Paper Class : ToString Method (Paper)

Creates a string and returns the paper name.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: string* ToString(); override
[C++/CLI]
public:
String^ ToString(); override

Return Type

A string value which represents the paper name.

See Also

Paper Class | Paper Members


Paper Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Paper Class Properties

PegasusImaging.WinForms.PrintPro4 Namespace : Paper Class (PegasusImaging.WinForms.PrintPro4)

For a list of all members of this type, see Paper members.

Public Properties

Public Property Id | Gets the ID of the paper.
Public Property Name | Gets the name of the paper.

See Also

Paper Class | PegasusImaging.WinForms.PrintPro4 Namespace


Id Property

Paper Class | Paper Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Id Property

PegasusImaging.WinForms.PrintPro4 Namespace > Paper Class : Id Property (Paper)

Gets the ID of the paper.

[Visual Basic]
Public ReadOnly Property Id As Integer
[C#]
public int Id {get;}
[C++]
public: __property int get_Id();
[C++/CLI]
public:
property int Id {
   int get();
}

Value

An integer which represents the ID of the paper.

See Also

Paper Class | Paper Members


Name Property

Paper Class | Paper Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Name Property

PegasusImaging.WinForms.PrintPro4 Namespace > Paper Class : Name Property (Paper)

Gets the name of the paper.

[Visual Basic]
Public Overridable ReadOnly Property Name As String
[C#]
public virtual string Name {get;}
[C++]
public: __property virtual string* get_Name();
[C++/CLI]
public:
virtual property String^ Name {
   String^ get();
}

Value

A string value which represents the paper name.

See Also

Paper Class | Paper Members


PaperBin Class

PaperBin Members | PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PaperBin Class

PegasusImaging.WinForms.PrintPro4 Namespace : PaperBin Class (PegasusImaging.WinForms.PrintPro4)

A class that implements a paper bin for a printer.

For a list of all members of this type, see PaperBin members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.PrintPro4.PaperBin

Syntax

[Visual Basic]
Public Class PaperBin
[C#]
public class PaperBin
[C++]
public __gc class PaperBin
[C++/CLI]
public ref class PaperBin

See Also

PaperBin Members | PegasusImaging.WinForms.PrintPro4 Namespace


PaperBin Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PaperBin Class Members

PegasusImaging.WinForms.PrintPro4 Namespace : PaperBin Class (PegasusImaging.WinForms.PrintPro4)

PaperBin overview

Public Properties

Public Property Id | Gets the ID of the printer bin.
Public Property Name | Gets the name of the printer bin.

Public Methods

Public Method ToString Overridden.

See Also

PaperBin Class | PegasusImaging.WinForms.PrintPro4 Namespace


ToString Method

PaperBin Class | PaperBin Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.PrintPro4 Namespace > PaperBin Class : ToString Method (PaperBin)
[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: string* ToString(); override
[C++/CLI]
public:
String^ ToString(); override

See Also

PaperBin Class | PaperBin Members


PaperBin Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PaperBin Class Properties

PegasusImaging.WinForms.PrintPro4 Namespace : PaperBin Class (PegasusImaging.WinForms.PrintPro4)

For a list of all members of this type, see PaperBin members.

Public Properties

Public Property Id | Gets the ID of the printer bin.
Public Property Name | Gets the name of the printer bin.

See Also

PaperBin Class | PegasusImaging.WinForms.PrintPro4 Namespace


Id Property

PaperBin Class | PaperBin Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Id Property

PegasusImaging.WinForms.PrintPro4 Namespace > PaperBin Class : Id Property (PaperBin)

Gets the ID of the printer bin.

[Visual Basic]
Public ReadOnly Property Id As Integer
[C#]
public int Id {get;}
[C++]
public: __property int get_Id();
[C++/CLI]
public:
property int Id {
   int get();
}

Value

An integer value which represents the ID of the printer bin.

See Also

PaperBin Class | PaperBin Members


Name Property

PaperBin Class | PaperBin Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Name Property

PegasusImaging.WinForms.PrintPro4 Namespace > PaperBin Class : Name Property (PaperBin)

Gets the name of the printer bin.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property string* get_Name();
[C++/CLI]
public:
property String^ Name {
   String^ get();
}

Value

A string value which represents the name of the printer bin.

Remarks

The default value is an empty string "".

See Also

PaperBin Class | PaperBin Members


PaperBinCollection Class

PaperBinCollection Members | PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PaperBinCollection Class

PegasusImaging.WinForms.PrintPro4 Namespace : PaperBinCollection Class

This class implements a collection of paper bin objects.

For a list of all members of this type, see PaperBinCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.ReadOnlyCollectionBase
PegasusImaging.WinForms.PrintPro4.PaperBinCollection

Syntax

[Visual Basic]
<DefaultMemberAttribute("Item")>
Public Class PaperBinCollection
   Inherits ReadOnlyCollectionBase
[C#]
[DefaultMemberAttribute("Item")]
public class PaperBinCollection : ReadOnlyCollectionBase
[C++]
[DefaultMemberAttribute("Item")]
public __gc class PaperBinCollection : public ReadOnlyCollectionBase
[C++/CLI]
[DefaultMemberAttribute("Item")]
public ref class PaperBinCollection : public ReadOnlyCollectionBase

See Also

PaperBinCollection Members | PegasusImaging.WinForms.PrintPro4 Namespace


PaperBinCollection Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PaperBinCollection Class Members

PegasusImaging.WinForms.PrintPro4 Namespace : PaperBinCollection Class

PaperBinCollection overview

Public Properties

Public Property Count | Overridden. Gets the number of paper bins in the collection.
Public Property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
Public Property Item | Overloaded. Gets the PaperBin object at specified index within the collection.
Public Property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

Public Method Contains | Used to determine if the specified PaperBin object exists in the collection.
Public Method CopyTo | Copies the elements of the collection to an array of paper bin type.
Public Method GetEnumerator | Overridden. Returns an enumerator that can be used to iterate through all of the PaperBin objects in the collection.

See Also

PaperBinCollection Class | PegasusImaging.WinForms.PrintPro4 Namespace


Contains Method

PaperBinCollection Class | PaperBinCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

pb
The PaperBin to look for in the collection.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Contains Method

PegasusImaging.WinForms.PrintPro4 Namespace > PaperBinCollection Class : Contains Method (PaperBinCollection)

Used to determine if the specified PaperBin object exists in the collection.

[Visual Basic]
Public Function Contains( _
   ByVal pb As PaperBin _
) As Boolean
[C#]
public bool Contains(
   PaperBin pb
);
[C++]
public: bool Contains(
   PaperBin* pb
)
[C++/CLI]
public:
bool Contains(
   PaperBin^ pb
)

Parameters

pb
The PaperBin to look for in the collection.

Return Type

A boolean value which is true if the given PaperBin is found within the collection. Otherwise, false is returned.

See Also

PaperBinCollection Class | PaperBinCollection Members


CopyTo Method

PaperBinCollection Class | PaperBinCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

array
The array to copy the elements to.
index
An integer which represents the index location to start copying at.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

CopyTo Method

PegasusImaging.WinForms.PrintPro4 Namespace > PaperBinCollection Class : CopyTo Method (PaperBinCollection)

Copies the elements of the collection to an array of paper bin type.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As PaperBin, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   PaperBin[] array,
   int index
);
[C++]
public: void CopyTo(
   PaperBin*[]* array,
   int index
)
[C++/CLI]
public:
void CopyTo(
   PaperBin^array<array>^ array,
   int index
)

Parameters

array
The array to copy the elements to.
index
An integer which represents the index location to start copying at.

See Also

PaperBinCollection Class | PaperBinCollection Members


GetEnumerator Method

PaperBinCollection Class | PaperBinCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

GetEnumerator Method

PegasusImaging.WinForms.PrintPro4 Namespace > PaperBinCollection Class : GetEnumerator Method (PaperBinCollection)

Returns an enumerator that can be used to iterate through all of the PaperBin objects in the collection.

[Visual Basic]
Overrides Public Function GetEnumerator() As IEnumerator
[C#]
public override IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator(); override
[C++/CLI]
public:
IEnumerator^ GetEnumerator(); override

Return Type

An enumerator object of type paper bin.

See Also

PaperBinCollection Class | PaperBinCollection Members


PaperBinCollection Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PaperBinCollection Class Properties

PegasusImaging.WinForms.PrintPro4 Namespace : PaperBinCollection Class

For a list of all members of this type, see PaperBinCollection members.

Public Properties

Public Property Count | Overridden. Gets the number of paper bins in the collection.
Public Property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
Public Property Item | Overloaded. Gets the PaperBin object at specified index within the collection.
Public Property SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

PaperBinCollection Class | PegasusImaging.WinForms.PrintPro4 Namespace


Count Property

PaperBinCollection Class | PaperBinCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Count Property

PegasusImaging.WinForms.PrintPro4 Namespace > PaperBinCollection Class : Count Property (PaperBinCollection)

Gets the number of paper bins in the collection.

[Visual Basic]
Overrides Public ReadOnly Property Count As Integer
[C#]
public override int Count {get;}
[C++]
public: __property int get_Count()override ;
[C++/CLI]
public:
property int Count override {
   int get();
}

Value

An integer which represents the number of PaperBin objects in the collection.

See Also

PaperBinCollection Class | PaperBinCollection Members


IsSynchronized Property

PaperBinCollection Class | PaperBinCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

IsSynchronized Property

PegasusImaging.WinForms.PrintPro4 Namespace > PaperBinCollection Class : IsSynchronized Property (PaperBinCollection)

Gets a value indicating whether access to the collection is synchronized (thread safe).

[Visual Basic]
Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {get;}
[C++]
public: __property bool get_IsSynchronized();
[C++/CLI]
public:
property bool IsSynchronized {
   bool get();
}

Value

A boolean value which is false when the collection is not synchronized.

See Also

PaperBinCollection Class | PaperBinCollection Members


Item Property

PaperBinCollection Class | PaperBinCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Item Property

PegasusImaging.WinForms.PrintPro4 Namespace > PaperBinCollection Class : Item Property (PaperBinCollection)

Gets the PaperBin object at specified index within the collection.

Overload List

Gets the PaperBin object at specified index within the collection.

[Visual Basic] Overloads Public Item(Integer) As PaperBin

[C#] public PaperBin Item(int);

[C++] public PaperBin* Item(int);

[C++/CLI] public PaperBin^ Item(int);

Gets the PaperBin object with the specified name within the collection.

[Visual Basic] Overloads Public Item(String) As PaperBin

[C#] public PaperBin Item(string);

[C++] public PaperBin* Item(string*);

[C++/CLI] public PaperBin^ Item(String^);

See Also

PaperBinCollection Class | PaperBinCollection Members


Item(Int32) Property

PaperBinCollection Class | PaperBinCollection Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
An integer which represents the index of the paper bin to retrieve.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Item(Int32) Property

PegasusImaging.WinForms.PrintPro4 Namespace > PaperBinCollection Class > Item Property : Item(Int32) Property

Gets the PaperBin object at specified index within the collection.

[Visual Basic]
Overloads Public ReadOnly Property Item( _
   ByVal index As Integer _
) As PaperBin
[C#]
public PaperBin Item(
   int index
); {get;}
[C++]
public: __property PaperBin* get_Item(
   int index
);
[C++/CLI]
public:
property PaperBin^ Item {
   PaperBin^ get(int index);
}

Parameters

index
An integer which represents the index of the paper bin to retrieve.

Value

The PaperBin ojbect which matches the specified index within the collection.

See Also

PaperBinCollection Class | PaperBinCollection Members | Overload List


Item(String) Property

PaperBinCollection Class | PaperBinCollection Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
An integer which represents the name of the paper bin to retrieve.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Item(String) Property

PegasusImaging.WinForms.PrintPro4 Namespace > PaperBinCollection Class > Item Property : Item(String) Property

Gets the PaperBin object with the specified name within the collection.

[Visual Basic]
Overloads Public ReadOnly Property Item( _
   ByVal index As String _
) As PaperBin
[C#]
public PaperBin Item(
   string index
); {get;}
[C++]
public: __property PaperBin* get_Item(
   string* index
);
[C++/CLI]
public:
property PaperBin^ Item {
   PaperBin^ get(String^ index);
}

Parameters

index
An integer which represents the name of the paper bin to retrieve.

Value

The PaperBin object with specified name within the collection.

See Also

PaperBinCollection Class | PaperBinCollection Members | Overload List


SyncRoot Property

PaperBinCollection Class | PaperBinCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

SyncRoot Property

PegasusImaging.WinForms.PrintPro4 Namespace > PaperBinCollection Class : SyncRoot Property (PaperBinCollection)

Gets an object that can be used to synchronize access to the collection.

[Visual Basic]
Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {get;}
[C++]
public: __property Object* get_SyncRoot();
[C++/CLI]
public:
property Object^ SyncRoot {
   Object^ get();
}

Value

An object which contains information to synchronize access to the collection.

See Also

PaperBinCollection Class | PaperBinCollection Members


PaperBinEnumerator Class

PaperBinEnumerator Members | PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PaperBinEnumerator Class

PegasusImaging.WinForms.PrintPro4 Namespace : PaperBinEnumerator Class

This class implements a paper bin enumerator.

For a list of all members of this type, see PaperBinEnumerator members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.PrintPro4.PaperBinEnumerator

Syntax

[Visual Basic]
Public Class PaperBinEnumerator
[C#]
public class PaperBinEnumerator
[C++]
public __gc class PaperBinEnumerator
[C++/CLI]
public ref class PaperBinEnumerator

See Also

PaperBinEnumerator Members | PegasusImaging.WinForms.PrintPro4 Namespace


PaperBinEnumerator Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PaperBinEnumerator Class Members

PegasusImaging.WinForms.PrintPro4 Namespace : PaperBinEnumerator Class

PaperBinEnumerator overview

Public Properties

Public Property Current Gets the current paper bin the enumerator is on within the collection.

Public Methods

Public Method Dispose | Disposes the paper bin enumerator.
Public Method MoveNext | Moves the enumerator to the next paper bin within the collection.
Public Method Reset | Resets the enumerator to right before the first element within the collection.

See Also

PaperBinEnumerator Class | PegasusImaging.WinForms.PrintPro4 Namespace


Dispose Method

PaperBinEnumerator Class | PaperBinEnumerator Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.PrintPro4 Namespace > PaperBinEnumerator Class : Dispose Method (PaperBinEnumerator)

Disposes the paper bin enumerator.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

See Also

PaperBinEnumerator Class | PaperBinEnumerator Members


MoveNext Method

PaperBinEnumerator Class | PaperBinEnumerator Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

MoveNext Method

PegasusImaging.WinForms.PrintPro4 Namespace > PaperBinEnumerator Class : MoveNext Method (PaperBinEnumerator)

Moves the enumerator to the next paper bin within the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();
[C++]
public: bool MoveNext();
[C++/CLI]
public:
bool MoveNext();

Return Type

A boolean value which is true if the move was successful, false otherwise.

See Also

PaperBinEnumerator Class | PaperBinEnumerator Members


Reset Method

PaperBinEnumerator Class | PaperBinEnumerator Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Reset Method

PegasusImaging.WinForms.PrintPro4 Namespace > PaperBinEnumerator Class : Reset Method (PaperBinEnumerator)

Resets the enumerator to right before the first element within the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();
[C++]
public: void Reset();
[C++/CLI]
public:
void Reset();

See Also

PaperBinEnumerator Class | PaperBinEnumerator Members


PaperBinEnumerator Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PaperBinEnumerator Class Properties

PegasusImaging.WinForms.PrintPro4 Namespace : PaperBinEnumerator Class

For a list of all members of this type, see PaperBinEnumerator members.

Public Properties

Public Property Current Gets the current paper bin the enumerator is on within the collection.

See Also

PaperBinEnumerator Class | PegasusImaging.WinForms.PrintPro4 Namespace


Current Property

PaperBinEnumerator Class | PaperBinEnumerator Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Current Property

PegasusImaging.WinForms.PrintPro4 Namespace > PaperBinEnumerator Class : Current Property (PaperBinEnumerator)

Gets the current paper bin the enumerator is on within the collection.

[Visual Basic]
Public ReadOnly Property Current As PaperBin
[C#]
public PaperBin Current {get;}
[C++]
public: __property PaperBin* get_Current();
[C++/CLI]
public:
property PaperBin^ Current {
   PaperBin^ get();
}

Value

The current PaperBin object the enumerator is on within the collection.

See Also

PaperBinEnumerator Class | PaperBinEnumerator Members


PaperCollection Class

PaperCollection Members | PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PaperCollection Class

PegasusImaging.WinForms.PrintPro4 Namespace : PaperCollection Class

This class implements methods and properties for PaperBin objects.

For a list of all members of this type, see PaperCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.ReadOnlyCollectionBase
PegasusImaging.WinForms.PrintPro4.PaperCollection

Syntax

[Visual Basic]
<DefaultMemberAttribute("Item")>
Public Class PaperCollection
   Inherits ReadOnlyCollectionBase
[C#]
[DefaultMemberAttribute("Item")]
public class PaperCollection : ReadOnlyCollectionBase
[C++]
[DefaultMemberAttribute("Item")]
public __gc class PaperCollection : public ReadOnlyCollectionBase
[C++/CLI]
[DefaultMemberAttribute("Item")]
public ref class PaperCollection : public ReadOnlyCollectionBase

See Also

PaperCollection Members | PegasusImaging.WinForms.PrintPro4 Namespace


PaperCollection Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PaperCollection Class Members

PegasusImaging.WinForms.PrintPro4 Namespace : PaperCollection Class

PaperCollection overview

Public Properties

Public Property Count | Overridden. Gets the number of paper objects in the papers collection.
Public Property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
Public Property Item | Overloaded. Gets the given Paper object at the specified index within the collection.
Public Property SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

Public Method Contains | Determines if the specified paper type exists in the collection.
Public Method CopyTo | Copies the collection of Paper objects to an array of papers.
Public Method GetEnumerator | Overridden. Returns an enumerator that can be used to iterate through all of the Paper objects in the collection.

See Also

PaperCollection Class | PegasusImaging.WinForms.PrintPro4 Namespace


Contains Method

PaperCollection Class | PaperCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

p
The Paper object to search for in the collection.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Contains Method

PegasusImaging.WinForms.PrintPro4 Namespace > PaperCollection Class : Contains Method (PaperCollection)

Determines if the specified paper type exists in the collection.

[Visual Basic]
Public Function Contains( _
   ByVal p As Paper _
) As Boolean
[C#]
public bool Contains(
   Paper p
);
[C++]
public: bool Contains(
   Paper* p
)
[C++/CLI]
public:
bool Contains(
   Paper^ p
)

Parameters

p
The Paper object to search for in the collection.

Return Type

A boolean value which indicates if the given Paper object is contained within the collection.

See Also

PaperCollection Class | PaperCollection Members


CopyTo Method

PaperCollection Class | PaperCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

array
An array to copy the paper object to.
index
An integer value which represents the initial index to start copying at.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

CopyTo Method

PegasusImaging.WinForms.PrintPro4 Namespace > PaperCollection Class : CopyTo Method (PaperCollection)

Copies the collection of Paper objects to an array of papers.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As Paper, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   Paper[] array,
   int index
);
[C++]
public: void CopyTo(
   Paper*[]* array,
   int index
)
[C++/CLI]
public:
void CopyTo(
   Paper^array<array>^ array,
   int index
)

Parameters

array
An array to copy the paper object to.
index
An integer value which represents the initial index to start copying at.

See Also

PaperCollection Class | PaperCollection Members


GetEnumerator Method

PaperCollection Class | PaperCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

GetEnumerator Method

PegasusImaging.WinForms.PrintPro4 Namespace > PaperCollection Class : GetEnumerator Method (PaperCollection)

Returns an enumerator that can be used to iterate through all of the Paper objects in the collection.

[Visual Basic]
Overrides Public Function GetEnumerator() As IEnumerator
[C#]
public override IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator(); override
[C++/CLI]
public:
IEnumerator^ GetEnumerator(); override

Return Type

An enumerator that can be used to iterate through all of the Paper objects in the collection.

See Also

PaperCollection Class | PaperCollection Members


PaperCollection Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PaperCollection Class Properties

PegasusImaging.WinForms.PrintPro4 Namespace : PaperCollection Class

For a list of all members of this type, see PaperCollection members.

Public Properties

Public Property Count | Overridden. Gets the number of paper objects in the papers collection.
Public Property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
Public Property Item | Overloaded. Gets the given Paper object at the specified index within the collection.
Public Property SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

PaperCollection Class | PegasusImaging.WinForms.PrintPro4 Namespace


Count Property

PaperCollection Class | PaperCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Count Property

PegasusImaging.WinForms.PrintPro4 Namespace > PaperCollection Class : Count Property (PaperCollection)

Gets the number of paper objects in the papers collection.

[Visual Basic]
Overrides Public ReadOnly Property Count As Integer
[C#]
public override int Count {get;}
[C++]
public: __property int get_Count()override ;
[C++/CLI]
public:
property int Count override {
   int get();
}

Value

An integer value which represents the number of Paper ojbects in the papers collection.

See Also

PaperCollection Class | PaperCollection Members


IsSynchronized Property

PaperCollection Class | PaperCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

IsSynchronized Property

PegasusImaging.WinForms.PrintPro4 Namespace > PaperCollection Class : IsSynchronized Property (PaperCollection)

Gets a value indicating whether access to the collection is synchronized (thread safe).

[Visual Basic]
Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {get;}
[C++]
public: __property bool get_IsSynchronized();
[C++/CLI]
public:
property bool IsSynchronized {
   bool get();
}

Value

A boolean value which is true when the collection is synchronized. Otherwise, false is used.

See Also

PaperCollection Class | PaperCollection Members


Item Property

PaperCollection Class | PaperCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Item Property

PegasusImaging.WinForms.PrintPro4 Namespace > PaperCollection Class : Item Property (PaperCollection)

Gets the given Paper object at the specified index within the collection.

Overload List

Gets the given Paper object at the specified index within the collection.

[Visual Basic] Overloads Public Item(Integer) As Paper

[C#] public Paper Item(int);

[C++] public Paper* Item(int);

[C++/CLI] public Paper^ Item(int);

Gets the Paper object with specified name within the collection.

[Visual Basic] Overloads Public Item(String) As Paper

[C#] public Paper Item(string);

[C++] public Paper* Item(string*);

[C++/CLI] public Paper^ Item(String^);

See Also

PaperCollection Class | PaperCollection Members


Item(Int32) Property

PaperCollection Class | PaperCollection Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
An integer value which represents the index of the Paper object to get within the collection.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Item(Int32) Property

PegasusImaging.WinForms.PrintPro4 Namespace > PaperCollection Class > Item Property : Item(Int32) Property

Gets the given Paper object at the specified index within the collection.

[Visual Basic]
Overloads Public ReadOnly Property Item( _
   ByVal index As Integer _
) As Paper
[C#]
public Paper Item(
   int index
); {get;}
[C++]
public: __property Paper* get_Item(
   int index
);
[C++/CLI]
public:
property Paper^ Item {
   Paper^ get(int index);
}

Parameters

index
An integer value which represents the index of the Paper object to get within the collection.

See Also

PaperCollection Class | PaperCollection Members | Overload List


Item(String) Property

PaperCollection Class | PaperCollection Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
A string value which represents the name of the paper to retrieve from within the colleciton.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Item(String) Property

PegasusImaging.WinForms.PrintPro4 Namespace > PaperCollection Class > Item Property : Item(String) Property

Gets the Paper object with specified name within the collection.

[Visual Basic]
Overloads Public ReadOnly Property Item( _
   ByVal index As String _
) As Paper
[C#]
public Paper Item(
   string index
); {get;}
[C++]
public: __property Paper* get_Item(
   string* index
);
[C++/CLI]
public:
property Paper^ Item {
   Paper^ get(String^ index);
}

Parameters

index
A string value which represents the name of the paper to retrieve from within the colleciton.

Value

The Paper object which matches the specified name.

See Also

PaperCollection Class | PaperCollection Members | Overload List


SyncRoot Property

PaperCollection Class | PaperCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

SyncRoot Property

PegasusImaging.WinForms.PrintPro4 Namespace > PaperCollection Class : SyncRoot Property (PaperCollection)

Gets an object that can be used to synchronize access to the collection.

[Visual Basic]
Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {get;}
[C++]
public: __property Object* get_SyncRoot();
[C++/CLI]
public:
property Object^ SyncRoot {
   Object^ get();
}

Value

An object which contains information to synchronize access to the collection.

See Also

PaperCollection Class | PaperCollection Members


PaperEnumerator Class

PaperEnumerator Members | PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PaperEnumerator Class

PegasusImaging.WinForms.PrintPro4 Namespace : PaperEnumerator Class

This class implements enumerating through paper collections.

For a list of all members of this type, see PaperEnumerator members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.PrintPro4.PaperEnumerator

Syntax

[Visual Basic]
Public Class PaperEnumerator
[C#]
public class PaperEnumerator
[C++]
public __gc class PaperEnumerator
[C++/CLI]
public ref class PaperEnumerator

See Also

PaperEnumerator Members | PegasusImaging.WinForms.PrintPro4 Namespace


PaperEnumerator Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PaperEnumerator Class Members

PegasusImaging.WinForms.PrintPro4 Namespace : PaperEnumerator Class

PaperEnumerator overview

Public Properties

Public Property Current Gets the current Paper object.

Public Methods

Public Method Dispose | Destroys the enumerator object.
Public Method MoveNext | Moves the enumerator to the next Paper object in the collection.
Public Method Reset | Resets the paper enumerator to the first paper in the collection.

See Also

PaperEnumerator Class | PegasusImaging.WinForms.PrintPro4 Namespace


Dispose Method

PaperEnumerator Class | PaperEnumerator Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.PrintPro4 Namespace > PaperEnumerator Class : Dispose Method (PaperEnumerator)

Destroys the enumerator object.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

See Also

PaperEnumerator Class | PaperEnumerator Members


MoveNext Method

PaperEnumerator Class | PaperEnumerator Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

MoveNext Method

PegasusImaging.WinForms.PrintPro4 Namespace > PaperEnumerator Class : MoveNext Method (PaperEnumerator)

Moves the enumerator to the next Paper object in the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();
[C++]
public: bool MoveNext();
[C++/CLI]
public:
bool MoveNext();

Return Type

A boolean value which indicates if it was successful in moving and a paper existed there, false otherwise.

See Also

PaperEnumerator Class | PaperEnumerator Members


Reset Method

PaperEnumerator Class | PaperEnumerator Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Reset Method

PegasusImaging.WinForms.PrintPro4 Namespace > PaperEnumerator Class : Reset Method (PaperEnumerator)

Resets the paper enumerator to the first paper in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();
[C++]
public: void Reset();
[C++/CLI]
public:
void Reset();

See Also

PaperEnumerator Class | PaperEnumerator Members


PaperEnumerator Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PaperEnumerator Class Properties

PegasusImaging.WinForms.PrintPro4 Namespace : PaperEnumerator Class

For a list of all members of this type, see PaperEnumerator members.

Public Properties

Public Property Current Gets the current Paper object.

See Also

PaperEnumerator Class | PegasusImaging.WinForms.PrintPro4 Namespace


Current Property

PaperEnumerator Class | PaperEnumerator Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Current Property

PegasusImaging.WinForms.PrintPro4 Namespace > PaperEnumerator Class : Current Property (PaperEnumerator)

Gets the current Paper object.

[Visual Basic]
Public ReadOnly Property Current As Paper
[C#]
public Paper Current {get;}
[C++]
public: __property Paper* get_Current();
[C++/CLI]
public:
property Paper^ Current {
   Paper^ get();
}

Value

A Paper object.

See Also

PaperEnumerator Class | PaperEnumerator Members


Printer Class

Printer Members | PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Printer Class

PegasusImaging.WinForms.PrintPro4 Namespace : Printer Class (PegasusImaging.WinForms.PrintPro4)

This class implements available printers for printing.

For a list of all members of this type, see Printer members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.PrintPro4.Printer

Syntax

[Visual Basic]
Public Class Printer
[C#]
public class Printer
[C++]
public __gc class Printer
[C++/CLI]
public ref class Printer

See Also

Printer Members | PegasusImaging.WinForms.PrintPro4 Namespace


Printer Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Printer Class Members

PegasusImaging.WinForms.PrintPro4 Namespace : Printer Class (PegasusImaging.WinForms.PrintPro4)

Printer overview

Public Properties

Public Property AutoMargin | Gets and sets an indicator which determines whether the margin values and the current print position values should automatically be set to values inside the printer's display area.
Public Property Collate | Gets and sets an indicator which specifies whether collation should be used when printing multiple copies (if the printer supports this feature).
Public Property ColorMode | Gets and sets an indicator which determines whether a color printer prints output in color or monochrome.
Public Property Copies | Gets and sets the number of copies to be printed.
Public Property Dither | Gets and sets a value that specifies how dithering is to be done (if the printer supports this feature).
Public Property DriverName | Gets the printer driver name.
Public Property Duplex | Gets and sets the PrintDuplex option for how a page is printed on both sides (if the printer supports this feature).
Public Property DuplexAvailable | Gets an indicator of the level of duplex support.
Public Property FileName | Gets the filename that the print is saved to.
Public Property IsFilePrinter | Gets an indicator which determines if this printer object is actually a file printer.
Public Property MaxCopies | Gets the number of copies that the printer can print.
Public Property MaxDpi | Gets the maximum resolution available.
Public Property MediaType | Gets and sets the type of media being printed on (if the printer supports this feature).
Public Property Name | Gets the printer's name.
Public Property Orientation | Gets and sets whether documents are printed in portrait or landscape mode (if the printer supports this feature).
Public Property Paper | Gets and sets the type of paper being used for printing (if the printer supports this feature).
Public Property PaperBin | Gets and sets the paper bin that is to be used to feed the printer paper.
Public Property PaperBins | Gets a collection of paper bins that can be used to feed the printer paper.
Public Property PaperHeight | Gets the physical height of the paper set up for the printing device, in units determined by the PrintUnits property.
Public Property Papers | Gets a collection of papers that represent the different types of papers available to the user (if the printer supports this feature).
Public Property PaperWidth | Gets the physical width of the paper set up for the printing device, in units determined by the PrintUnits property.
Public Property PortName | Gets the name of the port through which a document is sent to a printer.
Public Property PrintHeight | Gets the printable area height of the paper set up for the printing device, in units determined by the PrintUnits property.
Public Property PrintQuality | Gets and sets a value indicating the printer resolution (if the printer supports this feature).
Public Property PrintResolution | Gets the print resolution in dots per inch - horizontal and vertical.
Public Property PrintUnits | Gets and sets the units that are used to describe measurements for printing.
Public Property PrintWidth | Gets the printable area width of the paper set up for the printing device, in units determined by the PrintUnits property.
Public Property RangeFrom | Gets and sets the value that was selected for the beginning of the print range via the print dialog.
Public Property RangeSelection | Gets the value of the print range radio button from the print dialog.
Public Property RangeTo | Gets and sets the value that was selected for the end of the print range via the print dialog.
Public Property RequestedDpi | Gets and sets the current DPI resolution.
Public Property SaveFileType | Gets the file type that the print is saved as.
Public Property TrueType | Gets and sets a value indicating the printer’s TrueTypeOption enumeration option.
Public Property TwipsPerPixelX | Gets the number of twips per pixel for a printer measured horizontally.
Public Property TwipsPerPixelY | Gets the number of twips per pixel for a printer measured vertically.
Public Property UserDither | Gets and sets a value which specifies how dithering is to be done (if the printer supports this feature).
Public Property UserMediaType | Gets and sets the type of media being printed on (if the printer supports this feature).
Public Property UserPaper | Gets and sets the type of paper being used for printing (if the printer supports this feature).
Public Property Zoom | Gets or sets the percentage by which printed output is to be scaled up or down (if the printer supports this feature).

Public Methods

Public Method static (Shared in Visual Basic) CreateFilePrinter | Creates a new printer object that prints to the specified file as the specified file type.
Public Method Dispose |
Public Method static (Shared in Visual Basic) SelectPrinter | Overloaded. Selects and returns the default printer.
Public Method SetupDialog | Displays a printer setup dialog box that lets you change printer properties.
Public Method ToFilePrinter | Takes the current printer object and converts it to print to a file.

See Also

Printer Class | PegasusImaging.WinForms.PrintPro4 Namespace


CreateFilePrinter Method

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The PrintPro workspace instance to be used.
fileName
A string which represents the filename to save to.
saveFileType
A SaveFileType enumeration option to save to.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

CreateFilePrinter Method

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : CreateFilePrinter Method

Creates a new printer object that prints to the specified file as the specified file type.

[Visual Basic]
Public Shared Function CreateFilePrinter( _
   ByVal printProWorkspace As PrintPro, _
   ByVal fileName As String, _
   ByVal saveFileType As SaveFileType _
) As Printer
[C#]
public static Printer CreateFilePrinter(
   PrintPro printProWorkspace,
   string fileName,
   SaveFileType saveFileType
);
[C++]
public: static Printer* CreateFilePrinter(
   PrintPro* printProWorkspace,
   string* fileName,
   SaveFileType saveFileType
)
[C++/CLI]
public:
static Printer^ CreateFilePrinter(
   PrintPro^ printProWorkspace,
   String^ fileName,
   SaveFileType saveFileType
)

Parameters

printProWorkspace
The PrintPro workspace instance to be used.
fileName
A string which represents the filename to save to.
saveFileType
A SaveFileType enumeration option to save to.

Return Type

A new Printer object which prints to the specified file.

See Also

Printer Class | Printer Members


Dispose Method

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : Dispose Method (Printer)
[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

See Also

Printer Class | Printer Members


SelectPrinter Method

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

SelectPrinter Method

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : SelectPrinter Method

Selects and returns the default printer.

Overload List

Selects and returns the default printer.

[Visual Basic] Overloads Public Shared Function SelectPrinter(PrintPro) As Printer

[C#] public static Printer SelectPrinter(PrintPro);

[C++] public static Printer* SelectPrinter(PrintPro*);

[C++/CLI] public static Printer^ SelectPrinter(PrintPro^);

Selects a printer from the PrintPro workspace using the windows select printer dialog if ShowDialog is true, otherwise it selects the default printer.

[Visual Basic] Overloads Public Shared Function SelectPrinter(PrintPro,Boolean) As Printer

[C#] public static Printer SelectPrinter(PrintPro,bool);

[C++] public static Printer* SelectPrinter(PrintPro*,bool);

[C++/CLI] public static Printer^ SelectPrinter(PrintPro^,bool);

Selects a printer from the PrintPro workspace using the windows select printer dialog

[Visual Basic] Overloads Public Shared Function SelectPrinter(PrintPro,PrintRangeAvailable) As Printer

[C#] public static Printer SelectPrinter(PrintPro,PrintRangeAvailable);

[C++] public static Printer* SelectPrinter(PrintPro*,PrintRangeAvailable);

[C++/CLI] public static Printer^ SelectPrinter(PrintPro^,PrintRangeAvailable);

Selects a printer from the PrintPro workspace using the windows select printer dialog

[Visual Basic] Overloads Public Shared Function SelectPrinter(PrintPro,PrintRangeAvailable,PrintRangeSelection) As Printer

[C#] public static Printer SelectPrinter(PrintPro,PrintRangeAvailable,PrintRangeSelection);

[C++] public static Printer* SelectPrinter(PrintPro*,PrintRangeAvailable,PrintRangeSelection);

[C++/CLI] public static Printer^ SelectPrinter(PrintPro^,PrintRangeAvailable,PrintRangeSelection);

Selects a printer from the PrintPro workspace by name.

[Visual Basic] Overloads Public Shared Function SelectPrinter(PrintPro,String) As Printer

[C#] public static Printer SelectPrinter(PrintPro,string);

[C++] public static Printer* SelectPrinter(PrintPro*,string*);

[C++/CLI] public static Printer^ SelectPrinter(PrintPro^,String^);

Selects a printer from the PrintPro workspace using the windows select printer dialog and setting the minimum and maximum page range the user is allowed to choose from if ShowDialog is true.

[Visual Basic] Overloads Public Shared Function SelectPrinter(PrintPro,Boolean,Integer,Integer) As Printer

[C#] public static Printer SelectPrinter(PrintPro,bool,int,int);

[C++] public static Printer* SelectPrinter(PrintPro*,bool,int,int);

[C++/CLI] public static Printer^ SelectPrinter(PrintPro^,bool,int,int);

Selects a printer from the PrintPro workspace using the windows select printer dialog and setting the minimum and maximum page range the user is allowed to choose from if ShowDialog is true.

[Visual Basic] Overloads Public Shared Function SelectPrinter(PrintPro,Integer,Integer,PrintRangeAvailable) As Printer

[C#] public static Printer SelectPrinter(PrintPro,int,int,PrintRangeAvailable);

[C++] public static Printer* SelectPrinter(PrintPro*,int,int,PrintRangeAvailable);

[C++/CLI] public static Printer^ SelectPrinter(PrintPro^,int,int,PrintRangeAvailable);

Selects a printer from the PrintPro workspace using the windows select printer dialog and setting the minimum and maximum page range the user is allowed to choose from if ShowDialog is true.

[Visual Basic] Overloads Public Shared Function SelectPrinter(PrintPro,Integer,Integer,PrintRangeAvailable,PrintRangeSelection) As Printer

[C#] public static Printer SelectPrinter(PrintPro,int,int,PrintRangeAvailable,PrintRangeSelection);

[C++] public static Printer* SelectPrinter(PrintPro*,int,int,PrintRangeAvailable,PrintRangeSelection);

[C++/CLI] public static Printer^ SelectPrinter(PrintPro^,int,int,PrintRangeAvailable,PrintRangeSelection);

Selects a printer from the PrintPro workspace using the windows select printer dialog and setting the minimum and maximum page range along with the default from and to values the user is allowed to choose from.

[Visual Basic] Overloads Public Shared Function SelectPrinter(PrintPro,Integer,Integer,Integer,Integer,PrintRangeAvailable) As Printer

[C#] public static Printer SelectPrinter(PrintPro,int,int,int,int,PrintRangeAvailable);

[C++] public static Printer* SelectPrinter(PrintPro*,int,int,int,int,PrintRangeAvailable);

[C++/CLI] public static Printer^ SelectPrinter(PrintPro^,int,int,int,int,PrintRangeAvailable);

Selects a printer from the PrintPro workspace using the windows select printer dialog and setting the minimum and maximum page range along with the default from and to values the user is allowed to choose from.

[Visual Basic] Overloads Public Shared Function SelectPrinter(PrintPro,Integer,Integer,Integer,Integer) As Printer

[C#] public static Printer SelectPrinter(PrintPro,int,int,int,int);

[C++] public static Printer* SelectPrinter(PrintPro*,int,int,int,int);

[C++/CLI] public static Printer^ SelectPrinter(PrintPro^,int,int,int,int);

See Also

Printer Class | Printer Members


SelectPrinter(PrintPro) Method

Printer Class | Printer Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The PrintPro workspace to be used.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

SelectPrinter(PrintPro) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class > SelectPrinter Method : SelectPrinter(PrintPro) Method

Selects and returns the default printer.

[Visual Basic]
Overloads Public Shared Function SelectPrinter( _
   ByVal printProWorkspace As PrintPro _
) As Printer
[C#]
public static Printer SelectPrinter(
   PrintPro printProWorkspace
);
[C++]
public: static Printer* SelectPrinter(
   PrintPro* printProWorkspace
)
[C++/CLI]
public:
static Printer^ SelectPrinter(
   PrintPro^ printProWorkspace
)

Parameters

printProWorkspace
The PrintPro workspace to be used.

Return Type

The default printer.

See Also

Printer Class | Printer Members | Overload List


SelectPrinter(PrintPro,Boolean) Method

Printer Class | Printer Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The PrintPro workspace to be used
showDialog
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

SelectPrinter(PrintPro,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class > SelectPrinter Method : SelectPrinter(PrintPro,Boolean) Method

Selects a printer from the PrintPro workspace using the windows select printer dialog if ShowDialog is true, otherwise it selects the default printer.

[Visual Basic]
Overloads Public Shared Function SelectPrinter( _
   ByVal printProWorkspace As PrintPro, _
   ByVal showDialog As Boolean _
) As Printer
[C#]
public static Printer SelectPrinter(
   PrintPro printProWorkspace,
   bool showDialog
);
[C++]
public: static Printer* SelectPrinter(
   PrintPro* printProWorkspace,
   bool showDialog
)
[C++/CLI]
public:
static Printer^ SelectPrinter(
   PrintPro^ printProWorkspace,
   bool showDialog
)

Parameters

printProWorkspace
The PrintPro workspace to be used
showDialog

Return Type

the printer object that was selected

See Also

Printer Class | Printer Members | Overload List


SelectPrinter(PrintPro,PrintRangeAvailable) Method

Printer Class | Printer Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The PrintPro workspace to be used.
availableRange
The available range options that can be selected from the dialog box.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

SelectPrinter(PrintPro,PrintRangeAvailable) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class > SelectPrinter Method : SelectPrinter(PrintPro,PrintRangeAvailable) Method

Selects a printer from the PrintPro workspace using the windows select printer dialog

[Visual Basic]
Overloads Public Shared Function SelectPrinter( _
   ByVal printProWorkspace As PrintPro, _
   ByVal availableRange As PrintRangeAvailable _
) As Printer
[C#]
public static Printer SelectPrinter(
   PrintPro printProWorkspace,
   PrintRangeAvailable availableRange
);
[C++]
public: static Printer* SelectPrinter(
   PrintPro* printProWorkspace,
   PrintRangeAvailable availableRange
)
[C++/CLI]
public:
static Printer^ SelectPrinter(
   PrintPro^ printProWorkspace,
   PrintRangeAvailable availableRange
)

Parameters

printProWorkspace
The PrintPro workspace to be used.
availableRange
The available range options that can be selected from the dialog box.

Return Type

The printer that was selected.

See Also

Printer Class | Printer Members | Overload List


SelectPrinter(PrintPro,PrintRangeAvailable,PrintRangeSelection) Method

Printer Class | Printer Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The PrintPro workspace to be used.
availableRange
The available range options that can be selected from the dialog box.
defaultRangeSelection
The default range option selection for the dialog box. Note that Pages can only be enabled via a constructor that enables you to set the min and max pages.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

SelectPrinter(PrintPro,PrintRangeAvailable,PrintRangeSelection) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class > SelectPrinter Method : SelectPrinter(PrintPro,PrintRangeAvailable,PrintRangeSelection) Method

Selects a printer from the PrintPro workspace using the windows select printer dialog

[Visual Basic]
Overloads Public Shared Function SelectPrinter( _
   ByVal printProWorkspace As PrintPro, _
   ByVal availableRange As PrintRangeAvailable, _
   ByVal defaultRangeSelection As PrintRangeSelection _
) As Printer
[C#]
public static Printer SelectPrinter(
   PrintPro printProWorkspace,
   PrintRangeAvailable availableRange,
   PrintRangeSelection defaultRangeSelection
);
[C++]
public: static Printer* SelectPrinter(
   PrintPro* printProWorkspace,
   PrintRangeAvailable availableRange,
   PrintRangeSelection defaultRangeSelection
)
[C++/CLI]
public:
static Printer^ SelectPrinter(
   PrintPro^ printProWorkspace,
   PrintRangeAvailable availableRange,
   PrintRangeSelection defaultRangeSelection
)

Parameters

printProWorkspace
The PrintPro workspace to be used.
availableRange
The available range options that can be selected from the dialog box.
defaultRangeSelection
The default range option selection for the dialog box. Note that Pages can only be enabled via a constructor that enables you to set the min and max pages.

Return Type

The printer that was selected.

See Also

Printer Class | Printer Members | Overload List


SelectPrinter(PrintPro,String) Method

Printer Class | Printer Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
PrintPro workspace instance.
name
A string which represents the name of the printer.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

SelectPrinter(PrintPro,String) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class > SelectPrinter Method : SelectPrinter(PrintPro,String) Method

Selects a printer from the PrintPro workspace by name.

[Visual Basic]
Overloads Public Shared Function SelectPrinter( _
   ByVal printProWorkspace As PrintPro, _
   ByVal name As String _
) As Printer
[C#]
public static Printer SelectPrinter(
   PrintPro printProWorkspace,
   string name
);
[C++]
public: static Printer* SelectPrinter(
   PrintPro* printProWorkspace,
   string* name
)
[C++/CLI]
public:
static Printer^ SelectPrinter(
   PrintPro^ printProWorkspace,
   String^ name
)

Parameters

printProWorkspace
PrintPro workspace instance.
name
A string which represents the name of the printer.

Return Type

The Printer with specified name.

See Also

Printer Class | Printer Members | Overload List


SelectPrinter(PrintPro,Boolean,Int32,Int32) Method

Printer Class | Printer Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
A PrintPro workspace.
showDialog
A boolean value which determines whether or not to show the select printer dialog
minPage
An integer value which represents if ShowDialog is true, this is the minimum available page range the user is allowed to select from in the print dialog. If ShowDialog is false, this is the starting page number for the printer and subsequent print jobs with it.
maxPage
If ShowDialog is true, this is the maximum available page range the user is allowed to select from in the print dialog. If ShowDialog is false, this is the ending page number for the printer and subsequent print jobs with it.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

SelectPrinter(PrintPro,Boolean,Int32,Int32) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class > SelectPrinter Method : SelectPrinter(PrintPro,Boolean,Int32,Int32) Method

Selects a printer from the PrintPro workspace using the windows select printer dialog and setting the minimum and maximum page range the user is allowed to choose from if ShowDialog is true.

[Visual Basic]
Overloads Public Shared Function SelectPrinter( _
   ByVal printProWorkspace As PrintPro, _
   ByVal showDialog As Boolean, _
   ByVal minPage As Integer, _
   ByVal maxPage As Integer _
) As Printer
[C#]
public static Printer SelectPrinter(
   PrintPro printProWorkspace,
   bool showDialog,
   int minPage,
   int maxPage
);
[C++]
public: static Printer* SelectPrinter(
   PrintPro* printProWorkspace,
   bool showDialog,
   int minPage,
   int maxPage
)
[C++/CLI]
public:
static Printer^ SelectPrinter(
   PrintPro^ printProWorkspace,
   bool showDialog,
   int minPage,
   int maxPage
)

Parameters

printProWorkspace
A PrintPro workspace.
showDialog
A boolean value which determines whether or not to show the select printer dialog
minPage
An integer value which represents if ShowDialog is true, this is the minimum available page range the user is allowed to select from in the print dialog. If ShowDialog is false, this is the starting page number for the printer and subsequent print jobs with it.
maxPage
If ShowDialog is true, this is the maximum available page range the user is allowed to select from in the print dialog. If ShowDialog is false, this is the ending page number for the printer and subsequent print jobs with it.

Return Type

The printer that was selected

Remarks

Note:If ShowDialog is false, MinPage and MaxPage are used for the print from and print to range. The dialog if shown has pages as the default range selection.

See Also

Printer Class | Printer Members | Overload List


SelectPrinter(PrintPro,Int32,Int32,PrintRangeAvailable) Method

Printer Class | Printer Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
A PrintPro workspace.
minPage
An integer value which represents the minimum available page range the user is allowed to select from in the print dialog.
maxPage
An integer value which represents the maximum available page range the user is allowed to select from in the print dialog.
availableRange
The available range options to select from.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

SelectPrinter(PrintPro,Int32,Int32,PrintRangeAvailable) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class > SelectPrinter Method : SelectPrinter(PrintPro,Int32,Int32,PrintRangeAvailable) Method

Selects a printer from the PrintPro workspace using the windows select printer dialog and setting the minimum and maximum page range the user is allowed to choose from if ShowDialog is true.

[Visual Basic]
Overloads Public Shared Function SelectPrinter( _
   ByVal printProWorkspace As PrintPro, _
   ByVal minPage As Integer, _
   ByVal maxPage As Integer, _
   ByVal availableRange As PrintRangeAvailable _
) As Printer
[C#]
public static Printer SelectPrinter(
   PrintPro printProWorkspace,
   int minPage,
   int maxPage,
   PrintRangeAvailable availableRange
);
[C++]
public: static Printer* SelectPrinter(
   PrintPro* printProWorkspace,
   int minPage,
   int maxPage,
   PrintRangeAvailable availableRange
)
[C++/CLI]
public:
static Printer^ SelectPrinter(
   PrintPro^ printProWorkspace,
   int minPage,
   int maxPage,
   PrintRangeAvailable availableRange
)

Parameters

printProWorkspace
A PrintPro workspace.
minPage
An integer value which represents the minimum available page range the user is allowed to select from in the print dialog.
maxPage
An integer value which represents the maximum available page range the user is allowed to select from in the print dialog.
availableRange
The available range options to select from.

Return Type

The printer that was selected.

Remarks

Note: If ShowDialog is false, MinPage and MaxPage are used for the print from and print to range.

See Also

Printer Class | Printer Members | Overload List


SelectPrinter(PrintPro,Int32,Int32,PrintRangeAvailable,PrintRangeSelection) Method

Printer Class | Printer Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
A PrintPro workspace.
minPage
An integer value which represents the minimum available page range the user is allowed to select from in the print dialog.
maxPage
An integer value which represents the maximum available page range the user is allowed to select from in the print dialog.
availableRange
A PrintRangeAvailable enumeration value which determines the available range options to select from.
defaultRangeSelection
A PrintRangeSelection enumeration value which determines the default range selection.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

SelectPrinter(PrintPro,Int32,Int32,PrintRangeAvailable,PrintRangeSelection) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class > SelectPrinter Method : SelectPrinter(PrintPro,Int32,Int32,PrintRangeAvailable,PrintRangeSelection) Method

Selects a printer from the PrintPro workspace using the windows select printer dialog and setting the minimum and maximum page range the user is allowed to choose from if ShowDialog is true.

[Visual Basic]
Overloads Public Shared Function SelectPrinter( _
   ByVal printProWorkspace As PrintPro, _
   ByVal minPage As Integer, _
   ByVal maxPage As Integer, _
   ByVal availableRange As PrintRangeAvailable, _
   ByVal defaultRangeSelection As PrintRangeSelection _
) As Printer
[C#]
public static Printer SelectPrinter(
   PrintPro printProWorkspace,
   int minPage,
   int maxPage,
   PrintRangeAvailable availableRange,
   PrintRangeSelection defaultRangeSelection
);
[C++]
public: static Printer* SelectPrinter(
   PrintPro* printProWorkspace,
   int minPage,
   int maxPage,
   PrintRangeAvailable availableRange,
   PrintRangeSelection defaultRangeSelection
)
[C++/CLI]
public:
static Printer^ SelectPrinter(
   PrintPro^ printProWorkspace,
   int minPage,
   int maxPage,
   PrintRangeAvailable availableRange,
   PrintRangeSelection defaultRangeSelection
)

Parameters

printProWorkspace
A PrintPro workspace.
minPage
An integer value which represents the minimum available page range the user is allowed to select from in the print dialog.
maxPage
An integer value which represents the maximum available page range the user is allowed to select from in the print dialog.
availableRange
A PrintRangeAvailable enumeration value which determines the available range options to select from.
defaultRangeSelection
A PrintRangeSelection enumeration value which determines the default range selection.

Return Type

The printer that was selected.

Remarks

Note: If ShowDialog is false, MinPage and MaxPage are used for the print from and print to range.

See Also

Printer Class | Printer Members | Overload List


SelectPrinter(PrintPro,Int32,Int32,Int32,Int32,PrintRangeAvailable) Method

Printer Class | Printer Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The PrintPro workspace to use.
minPage
An integer value which represents the minimum available page range the user is allowed to select from in the print dialog.
maxPage
An integer value which represents the maximum available page range the user is allowed to select from in the print dialog.
fromPage
An integer which represents the default from page set in the page range portion of the setup dialog.
toPage
An integer which represents the default to page set in the page range portion of the setup dialog.
availableRange
The available range to select from in the select printer dialog
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

SelectPrinter(PrintPro,Int32,Int32,Int32,Int32,PrintRangeAvailable) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class > SelectPrinter Method : SelectPrinter(PrintPro,Int32,Int32,Int32,Int32,PrintRangeAvailable) Method

Selects a printer from the PrintPro workspace using the windows select printer dialog and setting the minimum and maximum page range along with the default from and to values the user is allowed to choose from.

[Visual Basic]
Overloads Public Shared Function SelectPrinter( _
   ByVal printProWorkspace As PrintPro, _
   ByVal minPage As Integer, _
   ByVal maxPage As Integer, _
   ByVal fromPage As Integer, _
   ByVal toPage As Integer, _
   ByVal availableRange As PrintRangeAvailable _
) As Printer
[C#]
public static Printer SelectPrinter(
   PrintPro printProWorkspace,
   int minPage,
   int maxPage,
   int fromPage,
   int toPage,
   PrintRangeAvailable availableRange
);
[C++]
public: static Printer* SelectPrinter(
   PrintPro* printProWorkspace,
   int minPage,
   int maxPage,
   int fromPage,
   int toPage,
   PrintRangeAvailable availableRange
)
[C++/CLI]
public:
static Printer^ SelectPrinter(
   PrintPro^ printProWorkspace,
   int minPage,
   int maxPage,
   int fromPage,
   int toPage,
   PrintRangeAvailable availableRange
)

Parameters

printProWorkspace
The PrintPro workspace to use.
minPage
An integer value which represents the minimum available page range the user is allowed to select from in the print dialog.
maxPage
An integer value which represents the maximum available page range the user is allowed to select from in the print dialog.
fromPage
An integer which represents the default from page set in the page range portion of the setup dialog.
toPage
An integer which represents the default to page set in the page range portion of the setup dialog.
availableRange
The available range to select from in the select printer dialog

Return Type

The Printer that was selected.

Remarks

The dialog shown will have the ranges available for selection that are passed with a default selection of pages if that selection is available. If pages is not in the available selection, another constructor is likely to be more appropriate.

See Also

Printer Class | Printer Members | Overload List


SelectPrinter(PrintPro,Int32,Int32,Int32,Int32) Method

Printer Class | Printer Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The PrintPro workspace to use.
minPage
An integer value which represents the minimum available page range the user is allowed to select from in the print dialog.
maxPage
An integer value which represents the maximum available page range the user is allowed to select from in the print dialog.
fromPage
An integer which represents the default from page set in the page range portion of the print setup dialog
toPage
An integer which represents the default to page set in the page range portion of the print setup dialog
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

SelectPrinter(PrintPro,Int32,Int32,Int32,Int32) Method

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class > SelectPrinter Method : SelectPrinter(PrintPro,Int32,Int32,Int32,Int32) Method

Selects a printer from the PrintPro workspace using the windows select printer dialog and setting the minimum and maximum page range along with the default from and to values the user is allowed to choose from.

[Visual Basic]
Overloads Public Shared Function SelectPrinter( _
   ByVal printProWorkspace As PrintPro, _
   ByVal minPage As Integer, _
   ByVal maxPage As Integer, _
   ByVal fromPage As Integer, _
   ByVal toPage As Integer _
) As Printer
[C#]
public static Printer SelectPrinter(
   PrintPro printProWorkspace,
   int minPage,
   int maxPage,
   int fromPage,
   int toPage
);
[C++]
public: static Printer* SelectPrinter(
   PrintPro* printProWorkspace,
   int minPage,
   int maxPage,
   int fromPage,
   int toPage
)
[C++/CLI]
public:
static Printer^ SelectPrinter(
   PrintPro^ printProWorkspace,
   int minPage,
   int maxPage,
   int fromPage,
   int toPage
)

Parameters

printProWorkspace
The PrintPro workspace to use.
minPage
An integer value which represents the minimum available page range the user is allowed to select from in the print dialog.
maxPage
An integer value which represents the maximum available page range the user is allowed to select from in the print dialog.
fromPage
An integer which represents the default from page set in the page range portion of the print setup dialog
toPage
An integer which represents the default to page set in the page range portion of the print setup dialog

Return Type

The printer that was selected.

See Also

Printer Class | Printer Members | Overload List


SetupDialog Method

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

SetupDialog Method

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : SetupDialog Method

Displays a printer setup dialog box that lets you change printer properties.

[Visual Basic]
Public Sub SetupDialog()
[C#]
public void SetupDialog();
[C++]
public: void SetupDialog();
[C++/CLI]
public:
void SetupDialog();

See Also

Printer Class | Printer Members


ToFilePrinter Method

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

fileName
A string which represents the filename to save to.
saveFileType
A SaveFileType enumeration value which represents the file type to save to.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

ToFilePrinter Method

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : ToFilePrinter Method

Takes the current printer object and converts it to print to a file.

[Visual Basic]
Public Sub ToFilePrinter( _
   ByVal fileName As String, _
   ByVal saveFileType As SaveFileType _
)
[C#]
public void ToFilePrinter(
   string fileName,
   SaveFileType saveFileType
);
[C++]
public: void ToFilePrinter(
   string* fileName,
   SaveFileType saveFileType
)
[C++/CLI]
public:
void ToFilePrinter(
   String^ fileName,
   SaveFileType saveFileType
)

Parameters

fileName
A string which represents the filename to save to.
saveFileType
A SaveFileType enumeration value which represents the file type to save to.

Remarks

After this is done the printer object will no longer print to a printer. This cannot be done once this object has been used to start a print job.

See Also

Printer Class | Printer Members


Printer Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Printer Class Properties

PegasusImaging.WinForms.PrintPro4 Namespace : Printer Class (PegasusImaging.WinForms.PrintPro4)

For a list of all members of this type, see Printer members.

Public Properties

Public Property AutoMargin | Gets and sets an indicator which determines whether the margin values and the current print position values should automatically be set to values inside the printer's display area.
Public Property Collate | Gets and sets an indicator which specifies whether collation should be used when printing multiple copies (if the printer supports this feature).
Public Property ColorMode | Gets and sets an indicator which determines whether a color printer prints output in color or monochrome.
Public Property Copies | Gets and sets the number of copies to be printed.
Public Property Dither | Gets and sets a value that specifies how dithering is to be done (if the printer supports this feature).
Public Property DriverName | Gets the printer driver name.
Public Property Duplex | Gets and sets the PrintDuplex option for how a page is printed on both sides (if the printer supports this feature).
Public Property DuplexAvailable | Gets an indicator of the level of duplex support.
Public Property FileName | Gets the filename that the print is saved to.
Public Property IsFilePrinter | Gets an indicator which determines if this printer object is actually a file printer.
Public Property MaxCopies | Gets the number of copies that the printer can print.
Public Property MaxDpi | Gets the maximum resolution available.
Public Property MediaType | Gets and sets the type of media being printed on (if the printer supports this feature).
Public Property Name | Gets the printer's name.
Public Property Orientation | Gets and sets whether documents are printed in portrait or landscape mode (if the printer supports this feature).
Public Property Paper | Gets and sets the type of paper being used for printing (if the printer supports this feature).
Public Property PaperBin | Gets and sets the paper bin that is to be used to feed the printer paper.
Public Property PaperBins | Gets a collection of paper bins that can be used to feed the printer paper.
Public Property PaperHeight | Gets the physical height of the paper set up for the printing device, in units determined by the PrintUnits property.
Public Property Papers | Gets a collection of papers that represent the different types of papers available to the user (if the printer supports this feature).
Public Property PaperWidth | Gets the physical width of the paper set up for the printing device, in units determined by the PrintUnits property.
Public Property PortName | Gets the name of the port through which a document is sent to a printer.
Public Property PrintHeight | Gets the printable area height of the paper set up for the printing device, in units determined by the PrintUnits property.
Public Property PrintQuality | Gets and sets a value indicating the printer resolution (if the printer supports this feature).
Public Property PrintResolution | Gets the print resolution in dots per inch - horizontal and vertical.
Public Property PrintUnits | Gets and sets the units that are used to describe measurements for printing.
Public Property PrintWidth | Gets the printable area width of the paper set up for the printing device, in units determined by the PrintUnits property.
Public Property RangeFrom | Gets and sets the value that was selected for the beginning of the print range via the print dialog.
Public Property RangeSelection | Gets the value of the print range radio button from the print dialog.
Public Property RangeTo | Gets and sets the value that was selected for the end of the print range via the print dialog.
Public Property RequestedDpi | Gets and sets the current DPI resolution.
Public Property SaveFileType | Gets the file type that the print is saved as.
Public Property TrueType | Gets and sets a value indicating the printer’s TrueTypeOption enumeration option.
Public Property TwipsPerPixelX | Gets the number of twips per pixel for a printer measured horizontally.
Public Property TwipsPerPixelY | Gets the number of twips per pixel for a printer measured vertically.
Public Property UserDither | Gets and sets a value which specifies how dithering is to be done (if the printer supports this feature).
Public Property UserMediaType | Gets and sets the type of media being printed on (if the printer supports this feature).
Public Property UserPaper | Gets and sets the type of paper being used for printing (if the printer supports this feature).
Public Property Zoom | Gets or sets the percentage by which printed output is to be scaled up or down (if the printer supports this feature).

See Also

Printer Class | PegasusImaging.WinForms.PrintPro4 Namespace


AutoMargin Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

AutoMargin Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : AutoMargin Property

Gets and sets an indicator which determines whether the margin values and the current print position values should automatically be set to values inside the printer's display area.

[Visual Basic]
Public Property AutoMargin As Boolean
[C#]
public bool AutoMargin {get; set;}
[C++]
public: __property bool get_AutoMargin();
public: __property void set_AutoMargin(
   bool value
);
[C++/CLI]
public:
property bool AutoMargin {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to automatically set to values inside the printer's display area. Otherwise, false is used.

Remarks

The default value is false.

See Also

Printer Class | Printer Members


Collate Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Collate Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : Collate Property

Gets and sets an indicator which specifies whether collation should be used when printing multiple copies (if the printer supports this feature).

[Visual Basic]
Public Property Collate As Boolean
[C#]
public bool Collate {get; set;}
[C++]
public: __property bool get_Collate();
public: __property void set_Collate(
   bool value
);
[C++/CLI]
public:
property bool Collate {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true when collation should be used when printing multiple copies. Otherwise, false should be used.

Remarks

The default value is false.

See Also

Printer Class | Printer Members


ColorMode Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

ColorMode Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : ColorMode Property

Gets and sets an indicator which determines whether a color printer prints output in color or monochrome.

[Visual Basic]
Public Property ColorMode As PrintColorMode
[C#]
public PrintColorMode ColorMode {get; set;}
[C++]
public: __property PrintColorMode get_ColorMode();
public: __property void set_ColorMode(
   PrintColorMode value
);
[C++/CLI]
public:
property PrintColorMode ColorMode {
   PrintColorMode get();
   void set (PrintColorMode value);
}

Value

A PrintColorMode enumeration option which determines the color mode for a printer output.

Remarks

The default value is PrintColorMode.Monochrome.

See Also

Printer Class | Printer Members


Copies Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Copies Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : Copies Property

Gets and sets the number of copies to be printed.

[Visual Basic]
Public Property Copies As Integer
[C#]
public int Copies {get; set;}
[C++]
public: __property int get_Copies();
public: __property void set_Copies(
   int value
);
[C++/CLI]
public:
property int Copies {
   int get();
   void set (int value);
}

Value

An integer value which represents the number of copies to be printed.

Remarks

The default value is 0.

See Also

Printer Class | Printer Members


Dither Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Dither Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : Dither Property

Gets and sets a value that specifies how dithering is to be done (if the printer supports this feature).

[Visual Basic]
Public Property Dither As PrintDitherType
[C#]
public PrintDitherType Dither {get; set;}
[C++]
public: __property PrintDitherType get_Dither();
public: __property void set_Dither(
   PrintDitherType value
);
[C++/CLI]
public:
property PrintDitherType Dither {
   PrintDitherType get();
   void set (PrintDitherType value);
}

Value

A PrintDitherType enumeration value option.

See Also

Printer Class | Printer Members


DriverName Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

DriverName Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : DriverName Property

Gets the printer driver name.

[Visual Basic]
Public ReadOnly Property DriverName As String
[C#]
public string DriverName {get;}
[C++]
public: __property string* get_DriverName();
[C++/CLI]
public:
property String^ DriverName {
   String^ get();
}

Value

A string which represents the printer driver name.

Remarks

The default value is an empty string "".

See Also

Printer Class | Printer Members


Duplex Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Duplex Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : Duplex Property

Gets and sets the PrintDuplex option for how a page is printed on both sides (if the printer supports this feature).

[Visual Basic]
Public Property Duplex As PrintDuplex
[C#]
public PrintDuplex Duplex {get; set;}
[C++]
public: __property PrintDuplex get_Duplex();
public: __property void set_Duplex(
   PrintDuplex value
);
[C++/CLI]
public:
property PrintDuplex Duplex {
   PrintDuplex get();
   void set (PrintDuplex value);
}

Value

A PrintDuplex enumeration value which determines how a page is printed on both sides.

Remarks

The default value is PrintDuplex.Simplex.

See Also

Printer Class | Printer Members


DuplexAvailable Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

DuplexAvailable Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : DuplexAvailable Property

Gets an indicator of the level of duplex support.

[Visual Basic]
Public ReadOnly Property DuplexAvailable As Boolean
[C#]
public bool DuplexAvailable {get;}
[C++]
public: __property bool get_DuplexAvailable();
[C++/CLI]
public:
property bool DuplexAvailable {
   bool get();
}

Value

A boolean value which is true if the printer is capable of duplex printing. Otherwise, false is returned.

Remarks

The default value is false.

Note: If DuplexAvailable returns true, the printer is capable of duplex printing.

See Also

Printer Class | Printer Members


FileName Property

Printer Class | Printer Members | IsFilePrinter Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

FileName Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : FileName Property

Gets the filename that the print is saved to.

[Visual Basic]
Public ReadOnly Property FileName As String
[C#]
public string FileName {get;}
[C++]
public: __property string* get_FileName();
[C++/CLI]
public:
property String^ FileName {
   String^ get();
}

Value

A string value which represents the filename that the print is saved to.

Remarks

If it is not a file printer, this method throws an exception. Use the IsFilePrinter property to test if a printer object is a file printer.

See Also

Printer Class | Printer Members | IsFilePrinter Property


IsFilePrinter Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

IsFilePrinter Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : IsFilePrinter Property

Gets an indicator which determines if this printer object is actually a file printer.

[Visual Basic]
Public ReadOnly Property IsFilePrinter As Boolean
[C#]
public bool IsFilePrinter {get;}
[C++]
public: __property bool get_IsFilePrinter();
[C++/CLI]
public:
property bool IsFilePrinter {
   bool get();
}

Value

A boolean value which is true if this printer object is a file printer. Otherwise, false is used.

See Also

Printer Class | Printer Members


MaxCopies Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

MaxCopies Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : MaxCopies Property

Gets the number of copies that the printer can print.

[Visual Basic]
Public ReadOnly Property MaxCopies As Integer
[C#]
public int MaxCopies {get;}
[C++]
public: __property int get_MaxCopies();
[C++/CLI]
public:
property int MaxCopies {
   int get();
}

Value

An integer value which represents the number of copies that the printer can print.

Remarks

The default value is 0.

See Also

Printer Class | Printer Members


MaxDpi Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

MaxDpi Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : MaxDpi Property

Gets the maximum resolution available.

[Visual Basic]
Public ReadOnly Property MaxDpi As Integer
[C#]
public int MaxDpi {get;}
[C++]
public: __property int get_MaxDpi();
[C++/CLI]
public:
property int MaxDpi {
   int get();
}

Value

An integer value which represents the maximum resolution available.

Remarks

The default value is 0.

See Also

Printer Class | Printer Members


MediaType Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

MediaType Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : MediaType Property (Printer)

Gets and sets the type of media being printed on (if the printer supports this feature).

[Visual Basic]
Public Property MediaType As MediaType
[C#]
public MediaType MediaType {get; set;}
[C++]
public: __property MediaType get_MediaType();
public: __property void set_MediaType(
   MediaType value
);
[C++/CLI]
public:
property MediaType MediaType {
   MediaType get();
   void set (MediaType value);
}

Value

A MediaType enumeration value option which determines the type of media being printed on.

See Also

Printer Class | Printer Members


Name Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Name Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : Name Property (Printer)

Gets the printer's name.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}
[C++]
public: __property string* get_Name();
[C++/CLI]
public:
property String^ Name {
   String^ get();
}

Value

A string value which represents the printer's name.

Remarks

The default value is an empty string "".

See Also

Printer Class | Printer Members


Orientation Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Orientation Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : Orientation Property (Printer)

Gets and sets whether documents are printed in portrait or landscape mode (if the printer supports this feature).

[Visual Basic]
Public Property Orientation As Orientation
[C#]
public Orientation Orientation {get; set;}
[C++]
public: __property Orientation get_Orientation();
public: __property void set_Orientation(
   Orientation value
);
[C++/CLI]
public:
property Orientation Orientation {
   Orientation get();
   void set (Orientation value);
}

Value

An Orientation enumeration value which determines the orientation documents are printed in.

See Also

Printer Class | Printer Members


Paper Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Paper Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : Paper Property (Printer)

Gets and sets the type of paper being used for printing (if the printer supports this feature).

[Visual Basic]
Public Property Paper As Paper
[C#]
public Paper Paper {get; set;}
[C++]
public: __property Paper* get_Paper();
public: __property void set_Paper(
   Paper* value
);
[C++/CLI]
public:
property Paper^ Paper {
   Paper^ get();
   void set (Paper^ value);
}

Value

A Paper object which contains information about the type of paper being used.

See Also

Printer Class | Printer Members


PaperBin Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PaperBin Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : PaperBin Property (Printer)

Gets and sets the paper bin that is to be used to feed the printer paper.

[Visual Basic]
Public Property PaperBin As PaperBin
[C#]
public PaperBin PaperBin {get; set;}
[C++]
public: __property PaperBin* get_PaperBin();
public: __property void set_PaperBin(
   PaperBin* value
);
[C++/CLI]
public:
property PaperBin^ PaperBin {
   PaperBin^ get();
   void set (PaperBin^ value);
}

Value

A PaperBin object which contains information about the paper bin used to feed the printer paper.

See Also

Printer Class | Printer Members


PaperBins Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PaperBins Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : PaperBins Property

Gets a collection of paper bins that can be used to feed the printer paper.

[Visual Basic]
Public ReadOnly Property PaperBins As PaperBinCollection
[C#]
public PaperBinCollection PaperBins {get;}
[C++]
public: __property PaperBinCollection* get_PaperBins();
[C++/CLI]
public:
property PaperBinCollection^ PaperBins {
   PaperBinCollection^ get();
}

Value

A PaperBinCollection object which contains a collection of paper bins.

See Also

Printer Class | Printer Members


PaperHeight Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PaperHeight Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : PaperHeight Property (Printer)

Gets the physical height of the paper set up for the printing device, in units determined by the PrintUnits property.

[Visual Basic]
Public ReadOnly Property PaperHeight As Single
[C#]
public float PaperHeight {get;}
[C++]
public: __property float get_PaperHeight();
[C++/CLI]
public:
property float PaperHeight {
   float get();
}

Value

A single value which represents the paper height.

See Also

Printer Class | Printer Members


Papers Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Papers Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : Papers Property

Gets a collection of papers that represent the different types of papers available to the user (if the printer supports this feature).

[Visual Basic]
Public ReadOnly Property Papers As PaperCollection
[C#]
public PaperCollection Papers {get;}
[C++]
public: __property PaperCollection* get_Papers();
[C++/CLI]
public:
property PaperCollection^ Papers {
   PaperCollection^ get();
}

Value

A PaperCollection object which contains a collection of papers that are available to the user.

See Also

Printer Class | Printer Members


PaperWidth Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PaperWidth Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : PaperWidth Property (Printer)

Gets the physical width of the paper set up for the printing device, in units determined by the PrintUnits property.

[Visual Basic]
Public ReadOnly Property PaperWidth As Single
[C#]
public float PaperWidth {get;}
[C++]
public: __property float get_PaperWidth();
[C++/CLI]
public:
property float PaperWidth {
   float get();
}

Value

A single value which represents the width.

See Also

Printer Class | Printer Members


PortName Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PortName Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : PortName Property

Gets the name of the port through which a document is sent to a printer.

[Visual Basic]
Public ReadOnly Property PortName As String
[C#]
public string PortName {get;}
[C++]
public: __property string* get_PortName();
[C++/CLI]
public:
property String^ PortName {
   String^ get();
}

Value

A string value which represents the port name.

Remarks

The default value is an empty string "".

See Also

Printer Class | Printer Members


PrintHeight Property

Printer Class | Printer Members | PrintUnits Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintHeight Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : PrintHeight Property (Printer)

Gets the printable area height of the paper set up for the printing device, in units determined by the PrintUnits property.

[Visual Basic]
Public ReadOnly Property PrintHeight As Single
[C#]
public float PrintHeight {get;}
[C++]
public: __property float get_PrintHeight();
[C++/CLI]
public:
property float PrintHeight {
   float get();
}

Value

A single value which represents the print height.

See Also

Printer Class | Printer Members | PrintUnits Property


PrintQuality Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintQuality Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : PrintQuality Property (Printer)

Gets and sets a value indicating the printer resolution (if the printer supports this feature).

[Visual Basic]
Public Property PrintQuality As PrintQuality
[C#]
public PrintQuality PrintQuality {get; set;}
[C++]
public: __property PrintQuality* get_PrintQuality();
public: __property void set_PrintQuality(
   PrintQuality* value
);
[C++/CLI]
public:
property PrintQuality^ PrintQuality {
   PrintQuality^ get();
   void set (PrintQuality^ value);
}

Value

A PrintQuality object which contains information about the print resolution.

See Also

Printer Class | Printer Members


PrintResolution Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintResolution Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : PrintResolution Property

Gets the print resolution in dots per inch - horizontal and vertical.

[Visual Basic]
Public ReadOnly Property PrintResolution As Size
[C#]
public Size PrintResolution {get;}
[C++]
public: __property Size get_PrintResolution();
[C++/CLI]
public:
property Size PrintResolution {
   Size get();
}

Value

A Size object.

See Also

Printer Class | Printer Members


PrintUnits Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintUnits Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : PrintUnits Property

Gets and sets the units that are used to describe measurements for printing.

[Visual Basic]
Public Property PrintUnits As PrintingUnit
[C#]
public PrintingUnit PrintUnits {get; set;}
[C++]
public: __property PrintingUnit get_PrintUnits();
public: __property void set_PrintUnits(
   PrintingUnit value
);
[C++/CLI]
public:
property PrintingUnit PrintUnits {
   PrintingUnit get();
   void set (PrintingUnit value);
}

Value

A PrintingUnit object that contains information used to describe measurements for printing.

See Also

Printer Class | Printer Members


PrintWidth Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintWidth Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : PrintWidth Property (Printer)

Gets the printable area width of the paper set up for the printing device, in units determined by the PrintUnits property.

[Visual Basic]
Public ReadOnly Property PrintWidth As Single
[C#]
public float PrintWidth {get;}
[C++]
public: __property float get_PrintWidth();
[C++/CLI]
public:
property float PrintWidth {
   float get();
}

Value

A single value which represents the printable area width of the paper set up for the printing device.

See Also

Printer Class | Printer Members


RangeFrom Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

RangeFrom Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : RangeFrom Property

Gets and sets the value that was selected for the beginning of the print range via the print dialog.

[Visual Basic]
Public Property RangeFrom As Integer
[C#]
public int RangeFrom {get; set;}
[C++]
public: __property int get_RangeFrom();
public: __property void set_RangeFrom(
   int value
);
[C++/CLI]
public:
property int RangeFrom {
   int get();
   void set (int value);
}

Value

An integer which represents the print from range.

Remarks

The default value is 0.

See Also

Printer Class | Printer Members


RangeSelection Property

Printer Class | Printer Members | PrintRangeSelection Enumeration

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

RangeSelection Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : RangeSelection Property

Gets the value of the print range radio button from the print dialog.

[Visual Basic]
Public ReadOnly Property RangeSelection As PrintRangeSelection
[C#]
public PrintRangeSelection RangeSelection {get;}
[C++]
public: __property PrintRangeSelection get_RangeSelection();
[C++/CLI]
public:
property PrintRangeSelection RangeSelection {
   PrintRangeSelection get();
}

Value

A PrintRangeSelection enumeration value which determines the print range.

Remarks

The default value is PrintRangeSelection.NoSelection.

See Also

Printer Class | Printer Members | PrintRangeSelection Enumeration


RangeTo Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

RangeTo Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : RangeTo Property

Gets and sets the value that was selected for the end of the print range via the print dialog.

[Visual Basic]
Public Property RangeTo As Integer
[C#]
public int RangeTo {get; set;}
[C++]
public: __property int get_RangeTo();
public: __property void set_RangeTo(
   int value
);
[C++/CLI]
public:
property int RangeTo {
   int get();
   void set (int value);
}

Value

An integer value which represents the print to range.

Remarks

The default value is 0.

See Also

Printer Class | Printer Members


RequestedDpi Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

RequestedDpi Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : RequestedDpi Property

Gets and sets the current DPI resolution.

[Visual Basic]
Public Property RequestedDpi As Integer
[C#]
public int RequestedDpi {get; set;}
[C++]
public: __property int get_RequestedDpi();
public: __property void set_RequestedDpi(
   int value
);
[C++/CLI]
public:
property int RequestedDpi {
   int get();
   void set (int value);
}

Value

An integer value which represents the current DPI resolution.

Remarks

The quality and size of the file generated will depend upon the DPI requested.

See Also

Printer Class | Printer Members


SaveFileType Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

SaveFileType Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : SaveFileType Property (Printer)

Gets the file type that the print is saved as.

[Visual Basic]
Public ReadOnly Property SaveFileType As SaveFileType
[C#]
public SaveFileType SaveFileType {get;}
[C++]
public: __property SaveFileType get_SaveFileType();
[C++/CLI]
public:
property SaveFileType SaveFileType {
   SaveFileType get();
}

Value

A SaveFileType enumeration value which determines the file type that the print is saved as.

Remarks

If it is not a file printer, this method throws an exception. See the IsFilePrinter property to test if a printer object is a file printer.

See Also

Printer Class | Printer Members


TrueType Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TrueType Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : TrueType Property

Gets and sets a value indicating the printer’s TrueTypeOption enumeration option.

[Visual Basic]
Public Property TrueType As TrueTypeOption
[C#]
public TrueTypeOption TrueType {get; set;}
[C++]
public: __property TrueTypeOption get_TrueType();
public: __property void set_TrueType(
   TrueTypeOption value
);
[C++/CLI]
public:
property TrueTypeOption TrueType {
   TrueTypeOption get();
   void set (TrueTypeOption value);
}

Value

A TrueTypeOption enumeration option value which determines the printer's true type.

Remarks

The default value is TrueTypeOption.PrintAsGraphics.

See Also

Printer Class | Printer Members


TwipsPerPixelX Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TwipsPerPixelX Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : TwipsPerPixelX Property

Gets the number of twips per pixel for a printer measured horizontally.

[Visual Basic]
Public ReadOnly Property TwipsPerPixelX As Single
[C#]
public float TwipsPerPixelX {get;}
[C++]
public: __property float get_TwipsPerPixelX();
[C++/CLI]
public:
property float TwipsPerPixelX {
   float get();
}

Value

A single value which represents the number of twips per pixel for a printer measured horizontally.

See Also

Printer Class | Printer Members


TwipsPerPixelY Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TwipsPerPixelY Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : TwipsPerPixelY Property

Gets the number of twips per pixel for a printer measured vertically.

[Visual Basic]
Public ReadOnly Property TwipsPerPixelY As Single
[C#]
public float TwipsPerPixelY {get;}
[C++]
public: __property float get_TwipsPerPixelY();
[C++/CLI]
public:
property float TwipsPerPixelY {
   float get();
}

Value

A single value which represents the number of twips per pixel for a printer measured vertically.

See Also

Printer Class | Printer Members


UserDither Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

UserDither Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : UserDither Property

Gets and sets a value which specifies how dithering is to be done (if the printer supports this feature).

[Visual Basic]
Public Property UserDither As Integer
[C#]
public int UserDither {get; set;}
[C++]
public: __property int get_UserDither();
public: __property void set_UserDither(
   int value
);
[C++/CLI]
public:
property int UserDither {
   int get();
   void set (int value);
}

Value

An integer value which represents the dithering to be performed.

Remarks

Use this property when the desired setting is manufacturer specific.

See Also

Printer Class | Printer Members


UserMediaType Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

UserMediaType Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : UserMediaType Property

Gets and sets the type of media being printed on (if the printer supports this feature).

[Visual Basic]
Public Property UserMediaType As Integer
[C#]
public int UserMediaType {get; set;}
[C++]
public: __property int get_UserMediaType();
public: __property void set_UserMediaType(
   int value
);
[C++/CLI]
public:
property int UserMediaType {
   int get();
   void set (int value);
}

Value

An integer value which represents the type of media being printed on.

Remarks

Use this property when the desired setting is manufacturer specific.

See Also

Printer Class | Printer Members


UserPaper Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

UserPaper Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : UserPaper Property (Printer)

Gets and sets the type of paper being used for printing (if the printer supports this feature).

[Visual Basic]
Public Property UserPaper As Integer
[C#]
public int UserPaper {get; set;}
[C++]
public: __property int get_UserPaper();
public: __property void set_UserPaper(
   int value
);
[C++/CLI]
public:
property int UserPaper {
   int get();
   void set (int value);
}

Value

An integer value which represents the type of paper used for printing.

Remarks

The default value is 0.

Use this property when the desired setting is manufacturer specific.

See Also

Printer Class | Printer Members


Zoom Property

Printer Class | Printer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Zoom Property

PegasusImaging.WinForms.PrintPro4 Namespace > Printer Class : Zoom Property

Gets or sets the percentage by which printed output is to be scaled up or down (if the printer supports this feature).

[Visual Basic]
Public Property Zoom As Integer
[C#]
public int Zoom {get; set;}
[C++]
public: __property int get_Zoom();
public: __property void set_Zoom(
   int value
);
[C++/CLI]
public:
property int Zoom {
   int get();
   void set (int value);
}

Value

An integer value which represents the percentage output is scaled up or down.

See Also

Printer Class | Printer Members


PrinterCollection Class

PrinterCollection Members | PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrinterCollection Class

PegasusImaging.WinForms.PrintPro4 Namespace : PrinterCollection Class

This class implements a collection of available printers.

For a list of all members of this type, see PrinterCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.ReadOnlyCollectionBase
PegasusImaging.WinForms.PrintPro4.PrinterCollection

Syntax

[Visual Basic]
<DefaultMemberAttribute("Item")>
Public Class PrinterCollection
   Inherits ReadOnlyCollectionBase
[C#]
[DefaultMemberAttribute("Item")]
public class PrinterCollection : ReadOnlyCollectionBase
[C++]
[DefaultMemberAttribute("Item")]
public __gc class PrinterCollection : public ReadOnlyCollectionBase
[C++/CLI]
[DefaultMemberAttribute("Item")]
public ref class PrinterCollection : public ReadOnlyCollectionBase

See Also

PrinterCollection Members | PegasusImaging.WinForms.PrintPro4 Namespace


PrinterCollection Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrinterCollection Class Members

PegasusImaging.WinForms.PrintPro4 Namespace : PrinterCollection Class

PrinterCollection overview

Public Properties

Public Property Count | Overridden. Gets the number of Printer objects in the collection.
Public Property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
Public Property Item | Overloaded. Gets a Printer object which matches the given index value.
Public Property SyncRoot | Gets an object to be used for thread synchronization.

Public Methods

Public Method Contains | Checks if the given Printer object is contained within the collection.
Public Method CopyTo | Copies the elements of the printer collection to an array, starting at the given index location.
Public Method GetEnumerator | Overridden. Returns an enumerator that can iterate through the printer collection.

See Also

PrinterCollection Class | PegasusImaging.WinForms.PrintPro4 Namespace


Contains Method

PrinterCollection Class | PrinterCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

printer
The Printer to check the specified collection for.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Contains Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrinterCollection Class : Contains Method (PrinterCollection)

Checks if the given Printer object is contained within the collection.

[Visual Basic]
Public Function Contains( _
   ByVal printer As Printer _
) As Boolean
[C#]
public bool Contains(
   Printer printer
);
[C++]
public: bool Contains(
   Printer* printer
)
[C++/CLI]
public:
bool Contains(
   Printer^ printer
)

Parameters

printer
The Printer to check the specified collection for.

Return Type

A boolean value which is true if the specified printer exists in the collection.

See Also

PrinterCollection Class | PrinterCollection Members


CopyTo Method

PrinterCollection Class | PrinterCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

array
A one-dimensional array that is the destination of the elements copied from the collection. The Array must have zero-based indexing and be of type Printer.
index
An integer value which represents the zero-based index in array at which copying begins.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

CopyTo Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrinterCollection Class : CopyTo Method (PrinterCollection)

Copies the elements of the printer collection to an array, starting at the given index location.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As Printer, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   Printer[] array,
   int index
);
[C++]
public: void CopyTo(
   Printer*[]* array,
   int index
)
[C++/CLI]
public:
void CopyTo(
   Printer^array<array>^ array,
   int index
)

Parameters

array
A one-dimensional array that is the destination of the elements copied from the collection. The Array must have zero-based indexing and be of type Printer.
index
An integer value which represents the zero-based index in array at which copying begins.

Remarks

Note: It is not recommended that this method be used.

See Also

PrinterCollection Class | PrinterCollection Members


GetEnumerator Method

PrinterCollection Class | PrinterCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

GetEnumerator Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrinterCollection Class : GetEnumerator Method (PrinterCollection)

Returns an enumerator that can iterate through the printer collection.

[Visual Basic]
Overrides Public Function GetEnumerator() As IEnumerator
[C#]
public override IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator(); override
[C++/CLI]
public:
IEnumerator^ GetEnumerator(); override

Return Type

An enumerator that can iterate through the printer collection.

See Also

PrinterCollection Class | PrinterCollection Members


PrinterCollection Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrinterCollection Class Properties

PegasusImaging.WinForms.PrintPro4 Namespace : PrinterCollection Class

For a list of all members of this type, see PrinterCollection members.

Public Properties

Public Property Count | Overridden. Gets the number of Printer objects in the collection.
Public Property IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
Public Property Item | Overloaded. Gets a Printer object which matches the given index value.
Public Property SyncRoot | Gets an object to be used for thread synchronization.

See Also

PrinterCollection Class | PegasusImaging.WinForms.PrintPro4 Namespace


Count Property

PrinterCollection Class | PrinterCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Count Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrinterCollection Class : Count Property (PrinterCollection)

Gets the number of Printer objects in the collection.

[Visual Basic]
Overrides Public ReadOnly Property Count As Integer
[C#]
public override int Count {get;}
[C++]
public: __property int get_Count()override ;
[C++/CLI]
public:
property int Count override {
   int get();
}

Value

An integer value which represents the number of printer objects in the collection.

Remarks

The default value is 0.

See Also

PrinterCollection Class | PrinterCollection Members


IsSynchronized Property

PrinterCollection Class | PrinterCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

IsSynchronized Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrinterCollection Class : IsSynchronized Property (PrinterCollection)

Gets a value indicating whether access to the collection is synchronized (thread safe).

[Visual Basic]
Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {get;}
[C++]
public: __property bool get_IsSynchronized();
[C++/CLI]
public:
property bool IsSynchronized {
   bool get();
}

Value

A boolean value which is true if access to the collection is synchronized. Otherwise, false is used.

See Also

PrinterCollection Class | PrinterCollection Members


Item Property

PrinterCollection Class | PrinterCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Item Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrinterCollection Class : Item Property (PrinterCollection)

Gets a Printer object which matches the given index value.

Overload List

Gets a Printer object which matches the given index value.

[Visual Basic] Overloads Public Item(Integer) As Printer

[C#] public Printer Item(int);

[C++] public Printer* Item(int);

[C++/CLI] public Printer^ Item(int);

Gets a printer from the given name.

[Visual Basic] Overloads Public Item(String) As Printer

[C#] public Printer Item(string);

[C++] public Printer* Item(string*);

[C++/CLI] public Printer^ Item(String^);

See Also

PrinterCollection Class | PrinterCollection Members


Item(Int32) Property

PrinterCollection Class | PrinterCollection Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
An integer value which represents the index of the printer to return from the collection.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Item(Int32) Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrinterCollection Class > Item Property : Item(Int32) Property

Gets a Printer object which matches the given index value.

[Visual Basic]
Overloads Public ReadOnly Property Item( _
   ByVal index As Integer _
) As Printer
[C#]
public Printer Item(
   int index
); {get;}
[C++]
public: __property Printer* get_Item(
   int index
);
[C++/CLI]
public:
property Printer^ Item {
   Printer^ get(int index);
}

Parameters

index
An integer value which represents the index of the printer to return from the collection.

Value

A Printer object which matches the given index.

See Also

PrinterCollection Class | PrinterCollection Members | Overload List


Item(String) Property

PrinterCollection Class | PrinterCollection Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
A string which represents the name of the printer.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Item(String) Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrinterCollection Class > Item Property : Item(String) Property

Gets a printer from the given name.

[Visual Basic]
Overloads Public ReadOnly Property Item( _
   ByVal index As String _
) As Printer
[C#]
public Printer Item(
   string index
); {get;}
[C++]
public: __property Printer* get_Item(
   string* index
);
[C++/CLI]
public:
property Printer^ Item {
   Printer^ get(String^ index);
}

Parameters

index
A string which represents the name of the printer.

Value

A Printer which matches the given index name value.

See Also

PrinterCollection Class | PrinterCollection Members | Overload List


SyncRoot Property

PrinterCollection Class | PrinterCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

SyncRoot Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrinterCollection Class : SyncRoot Property (PrinterCollection)

Gets an object to be used for thread synchronization.

[Visual Basic]
Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {get;}
[C++]
public: __property Object* get_SyncRoot();
[C++/CLI]
public:
property Object^ SyncRoot {
   Object^ get();
}

Value

An object used for thread synchronization.

See Also

PrinterCollection Class | PrinterCollection Members


PrinterEnumerator Class

PrinterEnumerator Members | PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrinterEnumerator Class

PegasusImaging.WinForms.PrintPro4 Namespace : PrinterEnumerator Class

This class implements an enumerator that can be used to iterate through a collection of printers.

For a list of all members of this type, see PrinterEnumerator members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.PrintPro4.PrinterEnumerator

Syntax

[Visual Basic]
Public Class PrinterEnumerator
[C#]
public class PrinterEnumerator
[C++]
public __gc class PrinterEnumerator
[C++/CLI]
public ref class PrinterEnumerator

See Also

PrinterEnumerator Members | PegasusImaging.WinForms.PrintPro4 Namespace


PrinterEnumerator Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrinterEnumerator Class Members

PegasusImaging.WinForms.PrintPro4 Namespace : PrinterEnumerator Class

PrinterEnumerator overview

Public Properties

Public Property Current Gets the current Printer the enumerator is on in the collection.

Public Methods

Public Method Dispose | Disposes of the collection object when it is done being used.
Public Method MoveNext | Used to move to the next printer in the collection.
Public Method Reset | Resets the collection to the first Printer in the collection.

See Also

PrinterEnumerator Class | PegasusImaging.WinForms.PrintPro4 Namespace


Dispose Method

PrinterEnumerator Class | PrinterEnumerator Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrinterEnumerator Class : Dispose Method (PrinterEnumerator)

Disposes of the collection object when it is done being used.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

See Also

PrinterEnumerator Class | PrinterEnumerator Members


MoveNext Method

PrinterEnumerator Class | PrinterEnumerator Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

MoveNext Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrinterEnumerator Class : MoveNext Method (PrinterEnumerator)

Used to move to the next printer in the collection.

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();
[C++]
public: bool MoveNext();
[C++/CLI]
public:
bool MoveNext();

Return Type

A boolean value which is true if there was another printer in the collection and the change was successful. Otherwise, false is returned.

See Also

PrinterEnumerator Class | PrinterEnumerator Members


Reset Method

PrinterEnumerator Class | PrinterEnumerator Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Reset Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrinterEnumerator Class : Reset Method (PrinterEnumerator)

Resets the collection to the first Printer in the collection.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();
[C++]
public: void Reset();
[C++/CLI]
public:
void Reset();

See Also

PrinterEnumerator Class | PrinterEnumerator Members


PrinterEnumerator Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrinterEnumerator Class Properties

PegasusImaging.WinForms.PrintPro4 Namespace : PrinterEnumerator Class

For a list of all members of this type, see PrinterEnumerator members.

Public Properties

Public Property Current Gets the current Printer the enumerator is on in the collection.

See Also

PrinterEnumerator Class | PegasusImaging.WinForms.PrintPro4 Namespace


Current Property

PrinterEnumerator Class | PrinterEnumerator Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Current Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrinterEnumerator Class : Current Property (PrinterEnumerator)

Gets the current Printer the enumerator is on in the collection.

[Visual Basic]
Public ReadOnly Property Current As Printer
[C#]
public Printer Current {get;}
[C++]
public: __property Printer* get_Current();
[C++/CLI]
public:
property Printer^ Current {
   Printer^ get();
}

Value

A Printer which matches the enumerator is on currently within the collection.

See Also

PrinterEnumerator Class | PrinterEnumerator Members


PrintJob Class

PrintJob Members | PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintJob Class

PegasusImaging.WinForms.PrintPro4 Namespace : PrintJob Class

This class implements a normal print job.

For a list of all members of this type, see PrintJob members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.PrintPro4.PrintJob
PegasusImaging.WinForms.PrintPro4.PrintPreviewJob

Syntax

[Visual Basic]
Public Class PrintJob
[C#]
public class PrintJob
[C++]
public __gc class PrintJob
[C++/CLI]
public ref class PrintJob

See Also

PrintJob Members | PegasusImaging.WinForms.PrintPro4 Namespace


PrintJob Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintJob Class Members

PegasusImaging.WinForms.PrintPro4 Namespace : PrintJob Class

PrintJob overview

Public Constructors

Public Constructor PrintJob Constructor Overloaded. Creates a new print job using the default printer.

Public Properties

Public Property BottomMargin | Gets or sets the distance between the bottom of the physical page and the bottom of the printable area in units of the Printer's PrintUnits.
Public Property DisplayX | Gets the horizontal coordinate of the display area in printer units defined by the PrintPreviewScale property. Not available at design time.
Public Property DisplayY | Gets the vertical coordinate of the display area in printer units defined by the PrintPreviewScale property.
Public Property Draw | Gets a pseudo object used to contain all of the drawing methods.
Public Property Icm | Gets the Image Color Management values that the print job is using.
Public Property LeftMargin | Gets or sets the distance between the left of the physical page and the left of the printable area in units of the Printer's PrintUnits.
Public Property Name | Gets or sets the document name for the print job.
Public Property Page | Gets the current page number of the document for the print job.
Public Property PaperHeight | Gets the physical height of the paper set up for the printing device, in units determined by the PrintPreviewScale property.
Public Property PaperWidth | Gets the physical width of the paper set up for the printing device, in units determined by the PrintPreviewScale property.
Public Property Printer | Gets the Printer the print job is using.
Public Property PrintHeight | Gets the printable height of the paper set up for the printing device, in units determined by the PrintPreviewScale property.
Public Property PrintWidth | Gets the printable width of the paper set up for the printing device, in units determined by the PrintPreviewScale property.
Public Property TemplateFileName | Gets and sets the photograph collage description filename.
Public Property TopMargin | Gets or sets the distance between the top of the physical page and the top of the printable area in units of the Printer's PrintUnits.
Public Property UseHardwareMargins | Gets or sets the value to determine if the printer's hardware margins are used or if the margin values are calculated from the average of the printable area subtracted from the physical area.

Public Methods

Public Method Dispose | Overloaded. Forces destruction of the print job object.
Public Method Finish | Releases the current document to the print device or spooler.
Public Method GetGraphics | Returns a graphics object to the current page.
Public Method Kill | Immediately terminates the current print job cancelling any operations that have been performed on it.
Public Method NewPage | Starts a new page for printing.
Public Method PrintBitmap | Overloaded. Draws a Bitmap on the printer.
Public Method PrintDib | Overloaded. Draws a DIB on the printer.
Public Method PrintImage | Overloaded. Draws an image on the printer.
Public Method PrintTemplateBitmap | Draws a bitmap image on a printer using details provided by the template file.
Public Method PrintTemplateDib | Draws a DIB image on a printer using details provided by the template file.
Public Method PrintTemplateImage | Draws an image on a printer using details provided by the template file.

See Also

PrintJob Class | PegasusImaging.WinForms.PrintPro4 Namespace


PrintJob Constructor

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintJob Constructor

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : PrintJob Constructor (PrintJob)

Creates a new print job using the default printer.

Overload List

Creates a new print job using the default printer.

[Visual Basic] Public Sub New(PrintPro)

[C#] public PrintJob(PrintPro);

[C++] public PrintJob(PrintPro*);

[C++/CLI] public PrintJob(PrintPro^);

Creates a new print job using the default printer.

[Visual Basic] Public Sub New(PrintPro,Boolean)

[C#] public PrintJob(PrintPro,bool);

[C++] public PrintJob(PrintPro*,bool);

[C++/CLI] public PrintJob(PrintPro^,bool);

Creates a new print job using the default printer and specified image color management object for image color management settings.

[Visual Basic] Public Sub New(PrintPro,Icm)

[C#] public PrintJob(PrintPro,Icm);

[C++] public PrintJob(PrintPro*,Icm*);

[C++/CLI] public PrintJob(PrintPro^,Icm^);

Creates a new print job using the default printer and specified image color management object for image color management settings.

[Visual Basic] Public Sub New(PrintPro,Icm,Boolean)

[C#] public PrintJob(PrintPro,Icm,bool);

[C++] public PrintJob(PrintPro*,Icm*,bool);

[C++/CLI] public PrintJob(PrintPro^,Icm^,bool);

Creates a new print job using the specified printer for the destination.

[Visual Basic] Public Sub New(Printer)

[C#] public PrintJob(Printer);

[C++] public PrintJob(Printer*);

[C++/CLI] public PrintJob(Printer^);

Creates a new print job using the specified printer for the destination.

[Visual Basic] Public Sub New(Printer,Boolean)

[C#] public PrintJob(Printer,bool);

[C++] public PrintJob(Printer*,bool);

[C++/CLI] public PrintJob(Printer^,bool);

Creates a new print job using the specified printer for the destination.

[Visual Basic] Public Sub New(Printer,Icm)

[C#] public PrintJob(Printer,Icm);

[C++] public PrintJob(Printer*,Icm*);

[C++/CLI] public PrintJob(Printer^,Icm^);

Creates a new print job using the specified printer for the destination.

[Visual Basic] Public Sub New(Printer,Icm,Boolean)

[C#] public PrintJob(Printer,Icm,bool);

[C++] public PrintJob(Printer*,Icm*,bool);

[C++/CLI] public PrintJob(Printer^,Icm^,bool);

Creates a new print job using the specified printer for the destination.

[Visual Basic] Public Sub New(PrintPro,Printer)

[C#] public PrintJob(PrintPro,Printer);

[C++] public PrintJob(PrintPro*,Printer*);

[C++/CLI] public PrintJob(PrintPro^,Printer^);

Creates a new print job using the specified printer for the destination.

[Visual Basic] Public Sub New(PrintPro,Printer,Boolean)

[C#] public PrintJob(PrintPro,Printer,bool);

[C++] public PrintJob(PrintPro*,Printer*,bool);

[C++/CLI] public PrintJob(PrintPro^,Printer^,bool);

Creates a new print job using the specified printer for the destination.

[Visual Basic] Public Sub New(PrintPro,Printer,Icm)

[C#] public PrintJob(PrintPro,Printer,Icm);

[C++] public PrintJob(PrintPro*,Printer*,Icm*);

[C++/CLI] public PrintJob(PrintPro^,Printer^,Icm^);

Creates a new print job using the specified printer for the destination.

[Visual Basic] Public Sub New(PrintPro,Printer,Icm,Boolean)

[C#] public PrintJob(PrintPro,Printer,Icm,bool);

[C++] public PrintJob(PrintPro*,Printer*,Icm*,bool);

[C++/CLI] public PrintJob(PrintPro^,Printer^,Icm^,bool);

See Also

PrintJob Class | PrintJob Members


PrintJob Constructor(Printer)

PrintJob Class | PrintJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printer
The Printer the print job is to print to.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintJob Constructor(Printer)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(Printer)

Creates a new print job using the specified printer for the destination.

[Visual Basic]
Public Function New( _
   ByVal printer As Printer _
)
[C#]
public PrintJob(
   Printer printer
);
[C++]
public: PrintJob(
   Printer* printer
)
[C++/CLI]
public:
PrintJob(
   Printer^ printer
)

Parameters

printer
The Printer the print job is to print to.

See Also

PrintJob Class | PrintJob Members | Overload List


PrintJob Constructor(Printer,Boolean)

PrintJob Class | PrintJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printer
The Printer the print job is to print to.
useHardwareMargins
The initial setting for whether or not to use hardware margins when printing.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintJob Constructor(Printer,Boolean)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(Printer,Boolean)

Creates a new print job using the specified printer for the destination.

[Visual Basic]
Public Function New( _
   ByVal printer As Printer, _
   ByVal useHardwareMargins As Boolean _
)
[C#]
public PrintJob(
   Printer printer,
   bool useHardwareMargins
);
[C++]
public: PrintJob(
   Printer* printer,
   bool useHardwareMargins
)
[C++/CLI]
public:
PrintJob(
   Printer^ printer,
   bool useHardwareMargins
)

Parameters

printer
The Printer the print job is to print to.
useHardwareMargins
The initial setting for whether or not to use hardware margins when printing.

See Also

PrintJob Class | PrintJob Members | Overload List


PrintJob Constructor(Printer,Icm)

PrintJob Class | PrintJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printer
The Printer the print job is to print to.
imageColorManagement
The Icm image color management settings to use for the print job.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintJob Constructor(Printer,Icm)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(Printer,Icm)

Creates a new print job using the specified printer for the destination.

[Visual Basic]
Public Function New( _
   ByVal printer As Printer, _
   ByVal imageColorManagement As Icm _
)
[C#]
public PrintJob(
   Printer printer,
   Icm imageColorManagement
);
[C++]
public: PrintJob(
   Printer* printer,
   Icm* imageColorManagement
)
[C++/CLI]
public:
PrintJob(
   Printer^ printer,
   Icm^ imageColorManagement
)

Parameters

printer
The Printer the print job is to print to.
imageColorManagement
The Icm image color management settings to use for the print job.

See Also

PrintJob Class | PrintJob Members | Overload List


PrintJob Constructor(Printer,Icm,Boolean)

PrintJob Class | PrintJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printer
The Printer the print job is to print to.
imageColorManagement
The Icm image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not to use hardware margins when printing.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintJob Constructor(Printer,Icm,Boolean)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(Printer,Icm,Boolean)

Creates a new print job using the specified printer for the destination.

[Visual Basic]
Public Function New( _
   ByVal printer As Printer, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean _
)
[C#]
public PrintJob(
   Printer printer,
   Icm imageColorManagement,
   bool useHardwareMargins
);
[C++]
public: PrintJob(
   Printer* printer,
   Icm* imageColorManagement,
   bool useHardwareMargins
)
[C++/CLI]
public:
PrintJob(
   Printer^ printer,
   Icm^ imageColorManagement,
   bool useHardwareMargins
)

Parameters

printer
The Printer the print job is to print to.
imageColorManagement
The Icm image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not to use hardware margins when printing.

See Also

PrintJob Class | PrintJob Members | Overload List


PrintJob Constructor(PrintPro)

PrintJob Class | PrintJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The PrintPro workspace object to obtain the default printer from.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintJob Constructor(PrintPro)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(PrintPro)

Creates a new print job using the default printer.

[Visual Basic]
Public Function New( _
   ByVal printProWorkspace As PrintPro _
)
[C#]
public PrintJob(
   PrintPro printProWorkspace
);
[C++]
public: PrintJob(
   PrintPro* printProWorkspace
)
[C++/CLI]
public:
PrintJob(
   PrintPro^ printProWorkspace
)

Parameters

printProWorkspace
The PrintPro workspace object to obtain the default printer from.

See Also

PrintJob Class | PrintJob Members | Overload List


PrintJob Constructor(PrintPro,Boolean)

PrintJob Class | PrintJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The PrintPro workspace object to obtain the default printer from.
useHardwareMargins
A boolean value which represents the initial setting for whether or not to use hardware margins when printing.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintJob Constructor(PrintPro,Boolean)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(PrintPro,Boolean)

Creates a new print job using the default printer.

[Visual Basic]
Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal useHardwareMargins As Boolean _
)
[C#]
public PrintJob(
   PrintPro printProWorkspace,
   bool useHardwareMargins
);
[C++]
public: PrintJob(
   PrintPro* printProWorkspace,
   bool useHardwareMargins
)
[C++/CLI]
public:
PrintJob(
   PrintPro^ printProWorkspace,
   bool useHardwareMargins
)

Parameters

printProWorkspace
The PrintPro workspace object to obtain the default printer from.
useHardwareMargins
A boolean value which represents the initial setting for whether or not to use hardware margins when printing.

See Also

PrintJob Class | PrintJob Members | Overload List


PrintJob Constructor(PrintPro,Icm)

PrintJob Class | PrintJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The PrintPro workspace object to obtain the default printer from.
imageColorManagement
The Icm image color management settings to use for the print job.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintJob Constructor(PrintPro,Icm)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(PrintPro,Icm)

Creates a new print job using the default printer and specified image color management object for image color management settings.

[Visual Basic]
Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal imageColorManagement As Icm _
)
[C#]
public PrintJob(
   PrintPro printProWorkspace,
   Icm imageColorManagement
);
[C++]
public: PrintJob(
   PrintPro* printProWorkspace,
   Icm* imageColorManagement
)
[C++/CLI]
public:
PrintJob(
   PrintPro^ printProWorkspace,
   Icm^ imageColorManagement
)

Parameters

printProWorkspace
The PrintPro workspace object to obtain the default printer from.
imageColorManagement
The Icm image color management settings to use for the print job.

See Also

PrintJob Class | PrintJob Members | Overload List


PrintJob Constructor(PrintPro,Icm,Boolean)

PrintJob Class | PrintJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The PrintPro workspace object to obtain the default printer from.
imageColorManagement
The Icm image color management settings to use for the print job.
useHardwareMargins
A boolean value which is an indicator if the initial setting whether or not to use hardware margins when printing.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintJob Constructor(PrintPro,Icm,Boolean)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(PrintPro,Icm,Boolean)

Creates a new print job using the default printer and specified image color management object for image color management settings.

[Visual Basic]
Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean _
)
[C#]
public PrintJob(
   PrintPro printProWorkspace,
   Icm imageColorManagement,
   bool useHardwareMargins
);
[C++]
public: PrintJob(
   PrintPro* printProWorkspace,
   Icm* imageColorManagement,
   bool useHardwareMargins
)
[C++/CLI]
public:
PrintJob(
   PrintPro^ printProWorkspace,
   Icm^ imageColorManagement,
   bool useHardwareMargins
)

Parameters

printProWorkspace
The PrintPro workspace object to obtain the default printer from.
imageColorManagement
The Icm image color management settings to use for the print job.
useHardwareMargins
A boolean value which is an indicator if the initial setting whether or not to use hardware margins when printing.

See Also

PrintJob Class | PrintJob Members | Overload List


PrintJob Constructor(PrintPro,Printer)

PrintJob Class | PrintJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The PrintPro workspace object to use.
printer
The Printer the print job is to print to.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintJob Constructor(PrintPro,Printer)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(PrintPro,Printer)

Creates a new print job using the specified printer for the destination.

[Visual Basic]
Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer _
)
[C#]
public PrintJob(
   PrintPro printProWorkspace,
   Printer printer
);
[C++]
public: PrintJob(
   PrintPro* printProWorkspace,
   Printer* printer
)
[C++/CLI]
public:
PrintJob(
   PrintPro^ printProWorkspace,
   Printer^ printer
)

Parameters

printProWorkspace
The PrintPro workspace object to use.
printer
The Printer the print job is to print to.

See Also

PrintJob Class | PrintJob Members | Overload List


PrintJob Constructor(PrintPro,Printer,Boolean)

PrintJob Class | PrintJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The PrintPro workspace object to use.
printer
The Printer the print job is to print to.
useHardwareMargins
A boolean value which determines the initial setting for whether or not to use hardware margins when printing.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintJob Constructor(PrintPro,Printer,Boolean)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(PrintPro,Printer,Boolean)

Creates a new print job using the specified printer for the destination.

[Visual Basic]
Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer, _
   ByVal useHardwareMargins As Boolean _
)
[C#]
public PrintJob(
   PrintPro printProWorkspace,
   Printer printer,
   bool useHardwareMargins
);
[C++]
public: PrintJob(
   PrintPro* printProWorkspace,
   Printer* printer,
   bool useHardwareMargins
)
[C++/CLI]
public:
PrintJob(
   PrintPro^ printProWorkspace,
   Printer^ printer,
   bool useHardwareMargins
)

Parameters

printProWorkspace
The PrintPro workspace object to use.
printer
The Printer the print job is to print to.
useHardwareMargins
A boolean value which determines the initial setting for whether or not to use hardware margins when printing.

See Also

PrintJob Class | PrintJob Members | Overload List


PrintJob Constructor(PrintPro,Printer,Icm)

PrintJob Class | PrintJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The PrintPro workspace object to use.
printer
The Printer the print job is to print to.
imageColorManagement
The Icm image color management settings to use for the print job.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintJob Constructor(PrintPro,Printer,Icm)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(PrintPro,Printer,Icm)

Creates a new print job using the specified printer for the destination.

[Visual Basic]
Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer, _
   ByVal imageColorManagement As Icm _
)
[C#]
public PrintJob(
   PrintPro printProWorkspace,
   Printer printer,
   Icm imageColorManagement
);
[C++]
public: PrintJob(
   PrintPro* printProWorkspace,
   Printer* printer,
   Icm* imageColorManagement
)
[C++/CLI]
public:
PrintJob(
   PrintPro^ printProWorkspace,
   Printer^ printer,
   Icm^ imageColorManagement
)

Parameters

printProWorkspace
The PrintPro workspace object to use.
printer
The Printer the print job is to print to.
imageColorManagement
The Icm image color management settings to use for the print job.

See Also

PrintJob Class | PrintJob Members | Overload List


PrintJob Constructor(PrintPro,Printer,Icm,Boolean)

PrintJob Class | PrintJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The PrintPro workspace object to use.
printer
The Printer the print job is to print to.
imageColorManagement
The Icm image color management settings to use for the print job.
useHardwareMargins
The initial setting for whether or not to use hardware margins when printing.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintJob Constructor(PrintPro,Printer,Icm,Boolean)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(PrintPro,Printer,Icm,Boolean)

Creates a new print job using the specified printer for the destination.

[Visual Basic]
Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean _
)
[C#]
public PrintJob(
   PrintPro printProWorkspace,
   Printer printer,
   Icm imageColorManagement,
   bool useHardwareMargins
);
[C++]
public: PrintJob(
   PrintPro* printProWorkspace,
   Printer* printer,
   Icm* imageColorManagement,
   bool useHardwareMargins
)
[C++/CLI]
public:
PrintJob(
   PrintPro^ printProWorkspace,
   Printer^ printer,
   Icm^ imageColorManagement,
   bool useHardwareMargins
)

Parameters

printProWorkspace
The PrintPro workspace object to use.
printer
The Printer the print job is to print to.
imageColorManagement
The Icm image color management settings to use for the print job.
useHardwareMargins
The initial setting for whether or not to use hardware margins when printing.

See Also

PrintJob Class | PrintJob Members | Overload List


Dispose Method

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : Dispose Method (PrintJob)

Forces destruction of the print job object.

Overload List

Forces destruction of the print job object.

[Visual Basic] Overloads Public Sub Dispose()

[C#] public void Dispose();

[C++] public void Dispose()

[C++/CLI] public void Dispose()

Forces destruction of the print job object.

[Visual Basic] Overloads Public Sub Dispose(Boolean)

[C#] public void Dispose(bool);

[C++] public void Dispose(bool);

[C++/CLI] public void Dispose(bool);

See Also

PrintJob Class | PrintJob Members


Dispose() Method

PrintJob Class | PrintJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Dispose() Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class > Dispose Method : Dispose() Method

Forces destruction of the print job object.

[Visual Basic]
Overloads Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

Remarks

If Finish was not called prior to calling this, it is automatically called to finish the print job.

See Also

PrintJob Class | PrintJob Members | Overload List


Dispose(Boolean) Method

PrintJob Class | PrintJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

disposing
Determines whether actual disposition is done. If this value is false, Finish is not called and no changes are made.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Dispose(Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class > Dispose Method : Dispose(Boolean) Method

Forces destruction of the print job object.

[Visual Basic]
Overloads Public Sub Dispose( _
   ByVal disposing As Boolean _
)
[C#]
public void Dispose(
   bool disposing
);
[C++]
public: void Dispose(
   bool disposing
)
[C++/CLI]
public:
void Dispose(
   bool disposing
)

Parameters

disposing
Determines whether actual disposition is done. If this value is false, Finish is not called and no changes are made.

Remarks

If Finish was not called prior to calling this, it is automatically called to finish the print job.

See Also

PrintJob Class | PrintJob Members | Overload List


Finish Method

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Finish Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : Finish Method (PrintJob)

Releases the current document to the print device or spooler.

[Visual Basic]
Public Overridable Sub Finish()
[C#]
public virtual void Finish();
[C++]
public: virtual void Finish();
[C++/CLI]
public:
virtual void Finish();

See Also

PrintJob Class | PrintJob Members


GetGraphics Method

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

GetGraphics Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : GetGraphics Method (PrintJob)

Returns a graphics object to the current page.

[Visual Basic]
Public Overridable Function GetGraphics() As Graphics
[C#]
public virtual Graphics GetGraphics();
[C++]
public: virtual Graphics* GetGraphics();
[C++/CLI]
public:
virtual Graphics^ GetGraphics();

Return Type

A Graphics object for the current page. You must call Dispose to release resources when drawing has finished.

Remarks

This allows for using native .NET drawing methods to print to the page.

See Also

PrintJob Class | PrintJob Members


Kill Method

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Kill Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : Kill Method

Immediately terminates the current print job cancelling any operations that have been performed on it.

[Visual Basic]
Public Sub Kill()
[C#]
public void Kill();
[C++]
public: void Kill();
[C++/CLI]
public:
void Kill();

See Also

PrintJob Class | PrintJob Members


NewPage Method

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

NewPage Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : NewPage Method

Starts a new page for printing.

[Visual Basic]
Public Sub NewPage()
[C#]
public void NewPage();
[C++]
public: void NewPage();
[C++/CLI]
public:
void NewPage();

See Also

PrintJob Class | PrintJob Members


PrintBitmap Method

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintBitmap Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : PrintBitmap Method

Draws a Bitmap on the printer.

Overload List

Draws a Bitmap on the printer.

[Visual Basic] Overloads Public Sub PrintBitmap(Bitmap,PointF,SizeF,Boolean)

[C#] public void PrintBitmap(Bitmap,PointF,SizeF,bool);

[C++] public void PrintBitmap(Bitmap*,PointF,SizeF,bool);

[C++/CLI] public void PrintBitmap(Bitmap^,PointF,SizeF,bool);

Draws a Bitmap on the printer.

[Visual Basic] Overloads Public Sub PrintBitmap(Bitmap,PointF,SizeF,PointF,SizeF,Boolean)

[C#] public void PrintBitmap(Bitmap,PointF,SizeF,PointF,SizeF,bool);

[C++] public void PrintBitmap(Bitmap*,PointF,SizeF,PointF,SizeF,bool);

[C++/CLI] public void PrintBitmap(Bitmap^,PointF,SizeF,PointF,SizeF,bool);

Draws a Bitmap on the printer.

[Visual Basic] Overloads Public Sub PrintBitmap(Bitmap,Single,Single,Single,Single,Boolean)

[C#] public void PrintBitmap(Bitmap,float,float,float,float,bool);

[C++] public void PrintBitmap(Bitmap*,float,float,float,float,bool);

[C++/CLI] public void PrintBitmap(Bitmap^,float,float,float,float,bool);

Draws a Bitmap on the printer.

[Visual Basic] Overloads Public Sub PrintBitmap(Bitmap,Single,Single,Single,Single,Single,Single,Single,Single,Boolean)

[C#] public void PrintBitmap(Bitmap,float,float,float,float,float,float,float,float,bool);

[C++] public void PrintBitmap(Bitmap*,float,float,float,float,float,float,float,float,bool);

[C++/CLI] public void PrintBitmap(Bitmap^,float,float,float,float,float,float,float,float,bool);

See Also

PrintJob Class | PrintJob Members


PrintBitmap(Bitmap,PointF,SizeF,Boolean) Method

PrintJob Class | PrintJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

bitmap
The bitmap object to draw.
destination
The location of the destination for the upper-left corner of the image data.
destinationSize
The destination size of the Image data.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image data's aspect ratio.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintBitmap(Bitmap,PointF,SizeF,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class > PrintBitmap Method : PrintBitmap(Bitmap,PointF,SizeF,Boolean) Method

Draws a Bitmap on the printer.

[Visual Basic]
Overloads Public Sub PrintBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal destination As PointF, _
   ByVal destinationSize As SizeF, _
   ByVal aspect As Boolean _
)
[C#]
public void PrintBitmap(
   Bitmap bitmap,
   PointF destination,
   SizeF destinationSize,
   bool aspect
);
[C++]
public: void PrintBitmap(
   Bitmap* bitmap,
   PointF destination,
   SizeF destinationSize,
   bool aspect
)
[C++/CLI]
public:
void PrintBitmap(
   Bitmap^ bitmap,
   PointF destination,
   SizeF destinationSize,
   bool aspect
)

Parameters

bitmap
The bitmap object to draw.
destination
The location of the destination for the upper-left corner of the image data.
destinationSize
The destination size of the Image data.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image data's aspect ratio.

See Also

PrintJob Class | PrintJob Members | Overload List


PrintBitmap(Bitmap,PointF,SizeF,PointF,SizeF,Boolean) Method

PrintJob Class | PrintJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

bitmap
The Bitmap object to draw.
source
The location in the source image of the upper-left of the source image data.
sourceSize
The source size of the image data.
destination
The location of the destination for the upper-left corner of the image data.
destinationSize
The destination size of the Image data.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image data's aspect ratio.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintBitmap(Bitmap,PointF,SizeF,PointF,SizeF,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class > PrintBitmap Method : PrintBitmap(Bitmap,PointF,SizeF,PointF,SizeF,Boolean) Method

Draws a Bitmap on the printer.

[Visual Basic]
Overloads Public Sub PrintBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal source As PointF, _
   ByVal sourceSize As SizeF, _
   ByVal destination As PointF, _
   ByVal destinationSize As SizeF, _
   ByVal aspect As Boolean _
)
[C#]
public void PrintBitmap(
   Bitmap bitmap,
   PointF source,
   SizeF sourceSize,
   PointF destination,
   SizeF destinationSize,
   bool aspect
);
[C++]
public: void PrintBitmap(
   Bitmap* bitmap,
   PointF source,
   SizeF sourceSize,
   PointF destination,
   SizeF destinationSize,
   bool aspect
)
[C++/CLI]
public:
void PrintBitmap(
   Bitmap^ bitmap,
   PointF source,
   SizeF sourceSize,
   PointF destination,
   SizeF destinationSize,
   bool aspect
)

Parameters

bitmap
The Bitmap object to draw.
source
The location in the source image of the upper-left of the source image data.
sourceSize
The source size of the image data.
destination
The location of the destination for the upper-left corner of the image data.
destinationSize
The destination size of the Image data.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image data's aspect ratio.

See Also

PrintJob Class | PrintJob Members | Overload List


PrintBitmap(Bitmap,Single,Single,Single,Single,Boolean) Method

PrintJob Class | PrintJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

bitmap
The Bitmap object to draw.
destinationX
The X location of the destination for the upper-left corner of the image data.
destinationY
The Y location of the destination for the upper-left corner of the image data.
destinationWidth
The destination width of the Image data.
destinationHeight
The destination height of the Image data.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image data's aspect ratio.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintBitmap(Bitmap,Single,Single,Single,Single,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class > PrintBitmap Method : PrintBitmap(Bitmap,Single,Single,Single,Single,Boolean) Method

Draws a Bitmap on the printer.

[Visual Basic]
Overloads Public Sub PrintBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal destinationX As Single, _
   ByVal destinationY As Single, _
   ByVal destinationWidth As Single, _
   ByVal destinationHeight As Single, _
   ByVal aspect As Boolean _
)
[C#]
public void PrintBitmap(
   Bitmap bitmap,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
);
[C++]
public: void PrintBitmap(
   Bitmap* bitmap,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
)
[C++/CLI]
public:
void PrintBitmap(
   Bitmap^ bitmap,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
)

Parameters

bitmap
The Bitmap object to draw.
destinationX
The X location of the destination for the upper-left corner of the image data.
destinationY
The Y location of the destination for the upper-left corner of the image data.
destinationWidth
The destination width of the Image data.
destinationHeight
The destination height of the Image data.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image data's aspect ratio.

See Also

PrintJob Class | PrintJob Members | Overload List


PrintBitmap(Bitmap,Single,Single,Single,Single,Single,Single,Single,Single,Boolean) Method

PrintJob Class | PrintJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

bitmap
The Bitmap object to draw.
sourceX
The X location in the source image of the upper-left of the source image data.
sourceY
The Y location in the source image of the upper-left of the source image data.
sourceWidth
The source width of the image data.
sourceHeight
The source height of the image data.
destinationX
The X location of the destination for the upper-left corner of the image data.
destinationY
The Y location of the destination for the upper-left corner of the image data.
destinationWidth
The destination width of the Image data.
destinationHeight
The destination height of the Image data.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image data's aspect ratio.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintBitmap(Bitmap,Single,Single,Single,Single,Single,Single,Single,Single,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class > PrintBitmap Method : PrintBitmap(Bitmap,Single,Single,Single,Single,Single,Single,Single,Single,Boolean) Method

Draws a Bitmap on the printer.

[Visual Basic]
Overloads Public Sub PrintBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal sourceX As Single, _
   ByVal sourceY As Single, _
   ByVal sourceWidth As Single, _
   ByVal sourceHeight As Single, _
   ByVal destinationX As Single, _
   ByVal destinationY As Single, _
   ByVal destinationWidth As Single, _
   ByVal destinationHeight As Single, _
   ByVal aspect As Boolean _
)
[C#]
public void PrintBitmap(
   Bitmap bitmap,
   float sourceX,
   float sourceY,
   float sourceWidth,
   float sourceHeight,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
);
[C++]
public: void PrintBitmap(
   Bitmap* bitmap,
   float sourceX,
   float sourceY,
   float sourceWidth,
   float sourceHeight,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
)
[C++/CLI]
public:
void PrintBitmap(
   Bitmap^ bitmap,
   float sourceX,
   float sourceY,
   float sourceWidth,
   float sourceHeight,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
)

Parameters

bitmap
The Bitmap object to draw.
sourceX
The X location in the source image of the upper-left of the source image data.
sourceY
The Y location in the source image of the upper-left of the source image data.
sourceWidth
The source width of the image data.
sourceHeight
The source height of the image data.
destinationX
The X location of the destination for the upper-left corner of the image data.
destinationY
The Y location of the destination for the upper-left corner of the image data.
destinationWidth
The destination width of the Image data.
destinationHeight
The destination height of the Image data.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image data's aspect ratio.

See Also

PrintJob Class | PrintJob Members | Overload List


PrintDib Method

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintDib Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : PrintDib Method

Draws a DIB on the printer.

Overload List

Draws a DIB on the printer.

[Visual Basic] Overloads Public Sub PrintDib(IntPtr,PointF,SizeF,PointF,SizeF,Boolean)

[C#] public void PrintDib(IntPtr,PointF,SizeF,PointF,SizeF,bool);

[C++] public void PrintDib(IntPtr,PointF,SizeF,PointF,SizeF,bool);

[C++/CLI] public void PrintDib(IntPtr,PointF,SizeF,PointF,SizeF,bool);

Draws a DIB on the printer.

[Visual Basic] Overloads Public Sub PrintDib(IntPtr,Single,Single,Single,Single,Single,Single,Single,Single,Boolean)

[C#] public void PrintDib(IntPtr,float,float,float,float,float,float,float,float,bool);

[C++] public void PrintDib(IntPtr,float,float,float,float,float,float,float,float,bool);

[C++/CLI] public void PrintDib(IntPtr,float,float,float,float,float,float,float,float,bool);

See Also

PrintJob Class | PrintJob Members


PrintDib(IntPtr,PointF,SizeF,PointF,SizeF,Boolean) Method

PrintJob Class | PrintJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

dib
A pointer which points to the dib to draw.
source
A PointF which represents the source location of the DIB.
sourceSize
A SizeF which represents the source size of the DIB.
destination
A PointF value which represents the destination.
destinationSize
A SizeF value which represents the destination size.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image data's aspect ratio.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintDib(IntPtr,PointF,SizeF,PointF,SizeF,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class > PrintDib Method : PrintDib(IntPtr,PointF,SizeF,PointF,SizeF,Boolean) Method

Draws a DIB on the printer.

[Visual Basic]
Overloads Public Sub PrintDib( _
   ByVal dib As IntPtr, _
   ByVal source As PointF, _
   ByVal sourceSize As SizeF, _
   ByVal destination As PointF, _
   ByVal destinationSize As SizeF, _
   ByVal aspect As Boolean _
)
[C#]
public void PrintDib(
   IntPtr dib,
   PointF source,
   SizeF sourceSize,
   PointF destination,
   SizeF destinationSize,
   bool aspect
);
[C++]
public: void PrintDib(
   IntPtr dib,
   PointF source,
   SizeF sourceSize,
   PointF destination,
   SizeF destinationSize,
   bool aspect
)
[C++/CLI]
public:
void PrintDib(
   IntPtr dib,
   PointF source,
   SizeF sourceSize,
   PointF destination,
   SizeF destinationSize,
   bool aspect
)

Parameters

dib
A pointer which points to the dib to draw.
source
A PointF which represents the source location of the DIB.
sourceSize
A SizeF which represents the source size of the DIB.
destination
A PointF value which represents the destination.
destinationSize
A SizeF value which represents the destination size.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image data's aspect ratio.

See Also

PrintJob Class | PrintJob Members | Overload List


PrintDib(IntPtr,Single,Single,Single,Single,Single,Single,Single,Single,Boolean) Method

PrintJob Class | PrintJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

dib
The DIB object to draw.
sourceX
The X location in the source image of the upper-left of the source image data.
sourceY
The Y location in the source image of the upper-left of the source image data.
sourceWidth
The source width of the image data.
sourceHeight
The source height of the image data.
destinationX
The X location of the destination for the upper-left corner of the image data.
destinationY
The Y location of the destination for the upper-left corner of the image data.
destinationWidth
The destination width of the Image data.
destinationHeight
The destination height of the Image data.
aspect
when true, the destination size is adjusted to maintain the image data's aspect ratio.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintDib(IntPtr,Single,Single,Single,Single,Single,Single,Single,Single,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class > PrintDib Method : PrintDib(IntPtr,Single,Single,Single,Single,Single,Single,Single,Single,Boolean) Method

Draws a DIB on the printer.

[Visual Basic]
Overloads Public Sub PrintDib( _
   ByVal dib As IntPtr, _
   ByVal sourceX As Single, _
   ByVal sourceY As Single, _
   ByVal sourceWidth As Single, _
   ByVal sourceHeight As Single, _
   ByVal destinationX As Single, _
   ByVal destinationY As Single, _
   ByVal destinationWidth As Single, _
   ByVal destinationHeight As Single, _
   ByVal aspect As Boolean _
)
[C#]
public void PrintDib(
   IntPtr dib,
   float sourceX,
   float sourceY,
   float sourceWidth,
   float sourceHeight,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
);
[C++]
public: void PrintDib(
   IntPtr dib,
   float sourceX,
   float sourceY,
   float sourceWidth,
   float sourceHeight,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
)
[C++/CLI]
public:
void PrintDib(
   IntPtr dib,
   float sourceX,
   float sourceY,
   float sourceWidth,
   float sourceHeight,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
)

Parameters

dib
The DIB object to draw.
sourceX
The X location in the source image of the upper-left of the source image data.
sourceY
The Y location in the source image of the upper-left of the source image data.
sourceWidth
The source width of the image data.
sourceHeight
The source height of the image data.
destinationX
The X location of the destination for the upper-left corner of the image data.
destinationY
The Y location of the destination for the upper-left corner of the image data.
destinationWidth
The destination width of the Image data.
destinationHeight
The destination height of the Image data.
aspect
when true, the destination size is adjusted to maintain the image data's aspect ratio.

See Also

PrintJob Class | PrintJob Members | Overload List


PrintImage Method

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintImage Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : PrintImage Method

Draws an image on the printer.

Overload List

Draws an image on the printer.

[Visual Basic] Overloads Public Sub PrintImage(Image,PointF,SizeF,Boolean)

[C#] public void PrintImage(Image,PointF,SizeF,bool);

[C++] public void PrintImage(Image*,PointF,SizeF,bool);

[C++/CLI] public void PrintImage(Image^,PointF,SizeF,bool);

Draws an image on the printer.

[Visual Basic] Overloads Public Sub PrintImage(Image,PointF,SizeF,PointF,SizeF,Boolean)

[C#] public void PrintImage(Image,PointF,SizeF,PointF,SizeF,bool);

[C++] public void PrintImage(Image*,PointF,SizeF,PointF,SizeF,bool);

[C++/CLI] public void PrintImage(Image^,PointF,SizeF,PointF,SizeF,bool);

Draws an image on the printer.

[Visual Basic] Overloads Public Sub PrintImage(Image,Single,Single,Single,Single,Boolean)

[C#] public void PrintImage(Image,float,float,float,float,bool);

[C++] public void PrintImage(Image*,float,float,float,float,bool);

[C++/CLI] public void PrintImage(Image^,float,float,float,float,bool);

Draws an image on the printer.

[Visual Basic] Overloads Public Sub PrintImage(Image,Single,Single,Single,Single,Single,Single,Single,Single,Boolean)

[C#] public void PrintImage(Image,float,float,float,float,float,float,float,float,bool);

[C++] public void PrintImage(Image*,float,float,float,float,float,float,float,float,bool);

[C++/CLI] public void PrintImage(Image^,float,float,float,float,float,float,float,float,bool);

See Also

PrintJob Class | PrintJob Members


PrintImage(Image,PointF,SizeF,Boolean) Method

PrintJob Class | PrintJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

image
The Image object to draw.
destination
A PointF which represents the location of the destination for the upper-left corner of the image.
destinationSize
A SizeF which represents the destination size of the image.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image's aspect ratio.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintImage(Image,PointF,SizeF,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class > PrintImage Method : PrintImage(Image,PointF,SizeF,Boolean) Method

Draws an image on the printer.

[Visual Basic]
Overloads Public Sub PrintImage( _
   ByVal image As Image, _
   ByVal destination As PointF, _
   ByVal destinationSize As SizeF, _
   ByVal aspect As Boolean _
)
[C#]
public void PrintImage(
   Image image,
   PointF destination,
   SizeF destinationSize,
   bool aspect
);
[C++]
public: void PrintImage(
   Image* image,
   PointF destination,
   SizeF destinationSize,
   bool aspect
)
[C++/CLI]
public:
void PrintImage(
   Image^ image,
   PointF destination,
   SizeF destinationSize,
   bool aspect
)

Parameters

image
The Image object to draw.
destination
A PointF which represents the location of the destination for the upper-left corner of the image.
destinationSize
A SizeF which represents the destination size of the image.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image's aspect ratio.

See Also

PrintJob Class | PrintJob Members | Overload List


PrintImage(Image,PointF,SizeF,PointF,SizeF,Boolean) Method

PrintJob Class | PrintJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

image
The image object to draw.
source
The location in the source image of the upper-left of the source image data.
sourceSize
The source size of the image data.
destination
The location of the destination for the upper-left corner of the image data.
destinationSize
The destination size of the Image data.
aspect
when true, the destination size is adjusted to maintain the image data's aspect ratio.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintImage(Image,PointF,SizeF,PointF,SizeF,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class > PrintImage Method : PrintImage(Image,PointF,SizeF,PointF,SizeF,Boolean) Method

Draws an image on the printer.

[Visual Basic]
Overloads Public Sub PrintImage( _
   ByVal image As Image, _
   ByVal source As PointF, _
   ByVal sourceSize As SizeF, _
   ByVal destination As PointF, _
   ByVal destinationSize As SizeF, _
   ByVal aspect As Boolean _
)
[C#]
public void PrintImage(
   Image image,
   PointF source,
   SizeF sourceSize,
   PointF destination,
   SizeF destinationSize,
   bool aspect
);
[C++]
public: void PrintImage(
   Image* image,
   PointF source,
   SizeF sourceSize,
   PointF destination,
   SizeF destinationSize,
   bool aspect
)
[C++/CLI]
public:
void PrintImage(
   Image^ image,
   PointF source,
   SizeF sourceSize,
   PointF destination,
   SizeF destinationSize,
   bool aspect
)

Parameters

image
The image object to draw.
source
The location in the source image of the upper-left of the source image data.
sourceSize
The source size of the image data.
destination
The location of the destination for the upper-left corner of the image data.
destinationSize
The destination size of the Image data.
aspect
when true, the destination size is adjusted to maintain the image data's aspect ratio.

See Also

PrintJob Class | PrintJob Members | Overload List


PrintImage(Image,Single,Single,Single,Single,Boolean) Method

PrintJob Class | PrintJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

image
The image object to draw.
destinationX
The X location of the destination for the upper-left corner of the image data.
destinationY
The Y location of the destination for the upper-left corner of the image data.
destinationWidth
A single value which represents the destination width of the Image data.
destinationHeight
A single value which represents the destination height of the Image data.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image data's aspect ratio.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintImage(Image,Single,Single,Single,Single,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class > PrintImage Method : PrintImage(Image,Single,Single,Single,Single,Boolean) Method

Draws an image on the printer.

[Visual Basic]
Overloads Public Sub PrintImage( _
   ByVal image As Image, _
   ByVal destinationX As Single, _
   ByVal destinationY As Single, _
   ByVal destinationWidth As Single, _
   ByVal destinationHeight As Single, _
   ByVal aspect As Boolean _
)
[C#]
public void PrintImage(
   Image image,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
);
[C++]
public: void PrintImage(
   Image* image,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
)
[C++/CLI]
public:
void PrintImage(
   Image^ image,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
)

Parameters

image
The image object to draw.
destinationX
The X location of the destination for the upper-left corner of the image data.
destinationY
The Y location of the destination for the upper-left corner of the image data.
destinationWidth
A single value which represents the destination width of the Image data.
destinationHeight
A single value which represents the destination height of the Image data.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image data's aspect ratio.

See Also

PrintJob Class | PrintJob Members | Overload List


PrintImage(Image,Single,Single,Single,Single,Single,Single,Single,Single,Boolean) Method

PrintJob Class | PrintJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

image
The image object to draw.
sourceX
The X location in the source image of the upper-left of the source image data.
sourceY
The Y location in the source image of the upper-left of the source image data.
sourceWidth
The source width of the image data.
sourceHeight
The source height of the image data.
destinationX
The X location of the destination for the upper-left corner of the image data.
destinationY
The Y location of the destination for the upper-left corner of the image data.
destinationWidth
The destination width of the Image data.
destinationHeight
The destination height of the Image data.
aspect
when true, the destination size is adjusted to maintain the image data's aspect ratio.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintImage(Image,Single,Single,Single,Single,Single,Single,Single,Single,Boolean) Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class > PrintImage Method : PrintImage(Image,Single,Single,Single,Single,Single,Single,Single,Single,Boolean) Method

Draws an image on the printer.

[Visual Basic]
Overloads Public Sub PrintImage( _
   ByVal image As Image, _
   ByVal sourceX As Single, _
   ByVal sourceY As Single, _
   ByVal sourceWidth As Single, _
   ByVal sourceHeight As Single, _
   ByVal destinationX As Single, _
   ByVal destinationY As Single, _
   ByVal destinationWidth As Single, _
   ByVal destinationHeight As Single, _
   ByVal aspect As Boolean _
)
[C#]
public void PrintImage(
   Image image,
   float sourceX,
   float sourceY,
   float sourceWidth,
   float sourceHeight,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
);
[C++]
public: void PrintImage(
   Image* image,
   float sourceX,
   float sourceY,
   float sourceWidth,
   float sourceHeight,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
)
[C++/CLI]
public:
void PrintImage(
   Image^ image,
   float sourceX,
   float sourceY,
   float sourceWidth,
   float sourceHeight,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
)

Parameters

image
The image object to draw.
sourceX
The X location in the source image of the upper-left of the source image data.
sourceY
The Y location in the source image of the upper-left of the source image data.
sourceWidth
The source width of the image data.
sourceHeight
The source height of the image data.
destinationX
The X location of the destination for the upper-left corner of the image data.
destinationY
The Y location of the destination for the upper-left corner of the image data.
destinationWidth
The destination width of the Image data.
destinationHeight
The destination height of the Image data.
aspect
when true, the destination size is adjusted to maintain the image data's aspect ratio.

See Also

PrintJob Class | PrintJob Members | Overload List


PrintTemplateBitmap Method

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

bitmap
The bitmap to draw.
line
An integer value which represents the line of the template file to use.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintTemplateBitmap Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : PrintTemplateBitmap Method

Draws a bitmap image on a printer using details provided by the template file.

[Visual Basic]
Public Sub PrintTemplateBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal line As Integer _
)
[C#]
public void PrintTemplateBitmap(
   Bitmap bitmap,
   int line
);
[C++]
public: void PrintTemplateBitmap(
   Bitmap* bitmap,
   int line
)
[C++/CLI]
public:
void PrintTemplateBitmap(
   Bitmap^ bitmap,
   int line
)

Parameters

bitmap
The bitmap to draw.
line
An integer value which represents the line of the template file to use.

See Also

PrintJob Class | PrintJob Members


PrintTemplateDib Method

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

dib
The pointer to the dib to draw.
line
An integer value which represents the line of the template file to use.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintTemplateDib Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : PrintTemplateDib Method

Draws a DIB image on a printer using details provided by the template file.

[Visual Basic]
Public Sub PrintTemplateDib( _
   ByVal dib As IntPtr, _
   ByVal line As Integer _
)
[C#]
public void PrintTemplateDib(
   IntPtr dib,
   int line
);
[C++]
public: void PrintTemplateDib(
   IntPtr dib,
   int line
)
[C++/CLI]
public:
void PrintTemplateDib(
   IntPtr dib,
   int line
)

Parameters

dib
The pointer to the dib to draw.
line
An integer value which represents the line of the template file to use.

See Also

PrintJob Class | PrintJob Members


PrintTemplateImage Method

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

image
The Image to draw.
line
An integer value which represents the line of the template file to use.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintTemplateImage Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : PrintTemplateImage Method

Draws an image on a printer using details provided by the template file.

[Visual Basic]
Public Sub PrintTemplateImage( _
   ByVal image As Image, _
   ByVal line As Integer _
)
[C#]
public void PrintTemplateImage(
   Image image,
   int line
);
[C++]
public: void PrintTemplateImage(
   Image* image,
   int line
)
[C++/CLI]
public:
void PrintTemplateImage(
   Image^ image,
   int line
)

Parameters

image
The Image to draw.
line
An integer value which represents the line of the template file to use.

See Also

PrintJob Class | PrintJob Members


PrintJob Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintJob Class Properties

PegasusImaging.WinForms.PrintPro4 Namespace : PrintJob Class

For a list of all members of this type, see PrintJob members.

Public Properties

Public Property BottomMargin | Gets or sets the distance between the bottom of the physical page and the bottom of the printable area in units of the Printer's PrintUnits.
Public Property DisplayX | Gets the horizontal coordinate of the display area in printer units defined by the PrintPreviewScale property. Not available at design time.
Public Property DisplayY | Gets the vertical coordinate of the display area in printer units defined by the PrintPreviewScale property.
Public Property Draw | Gets a pseudo object used to contain all of the drawing methods.
Public Property Icm | Gets the Image Color Management values that the print job is using.
Public Property LeftMargin | Gets or sets the distance between the left of the physical page and the left of the printable area in units of the Printer's PrintUnits.
Public Property Name | Gets or sets the document name for the print job.
Public Property Page | Gets the current page number of the document for the print job.
Public Property PaperHeight | Gets the physical height of the paper set up for the printing device, in units determined by the PrintPreviewScale property.
Public Property PaperWidth | Gets the physical width of the paper set up for the printing device, in units determined by the PrintPreviewScale property.
Public Property Printer | Gets the Printer the print job is using.
Public Property PrintHeight | Gets the printable height of the paper set up for the printing device, in units determined by the PrintPreviewScale property.
Public Property PrintWidth | Gets the printable width of the paper set up for the printing device, in units determined by the PrintPreviewScale property.
Public Property TemplateFileName | Gets and sets the photograph collage description filename.
Public Property TopMargin | Gets or sets the distance between the top of the physical page and the top of the printable area in units of the Printer's PrintUnits.
Public Property UseHardwareMargins | Gets or sets the value to determine if the printer's hardware margins are used or if the margin values are calculated from the average of the printable area subtracted from the physical area.

See Also

PrintJob Class | PegasusImaging.WinForms.PrintPro4 Namespace


BottomMargin Property

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

BottomMargin Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : BottomMargin Property

Gets or sets the distance between the bottom of the physical page and the bottom of the printable area in units of the Printer's PrintUnits.

[Visual Basic]
Public Property BottomMargin As Single
[C#]
public float BottomMargin {get; set;}
[C++]
public: __property float get_BottomMargin();
public: __property void set_BottomMargin(
   float value
);
[C++/CLI]
public:
property float BottomMargin {
   float get();
   void set (float value);
}

Value

A single value which represents the distance between the bottom of the physical page and the bottom of the printable area in the Printer's PrintUnits.

See Also

PrintJob Class | PrintJob Members


DisplayX Property

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

DisplayX Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : DisplayX Property

Gets the horizontal coordinate of the display area in printer units defined by the PrintPreviewScale property. Not available at design time.

[Visual Basic]
Public ReadOnly Property DisplayX As Single
[C#]
public float DisplayX {get;}
[C++]
public: __property float get_DisplayX();
[C++/CLI]
public:
property float DisplayX {
   float get();
}

Value

A single value which represents the horizontal coordinate of the display area.

See Also

PrintJob Class | PrintJob Members


DisplayY Property

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

DisplayY Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : DisplayY Property

Gets the vertical coordinate of the display area in printer units defined by the PrintPreviewScale property.

[Visual Basic]
Public ReadOnly Property DisplayY As Single
[C#]
public float DisplayY {get;}
[C++]
public: __property float get_DisplayY();
[C++/CLI]
public:
property float DisplayY {
   float get();
}

Value

A single value which represents the vertical coordinate of the display area.

See Also

PrintJob Class | PrintJob Members


Draw Property

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Draw Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : Draw Property (PrintJob)

Gets a pseudo object used to contain all of the drawing methods.

[Visual Basic]
Public ReadOnly Property Draw As Draw
[C#]
public Draw Draw {get;}
[C++]
public: __property Draw* get_Draw();
[C++/CLI]
public:
property Draw^ Draw {
   Draw^ get();
}

Value

A Draw object which contains all the drawing methods for the print job.

See Also

PrintJob Class | PrintJob Members


Icm Property

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Icm Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : Icm Property (PrintJob)

Gets the Image Color Management values that the print job is using.

[Visual Basic]
Public ReadOnly Property Icm As Icm
[C#]
public Icm Icm {get;}
[C++]
public: __property Icm* get_Icm();
[C++/CLI]
public:
property Icm^ Icm {
   Icm^ get();
}

Value

An Icm object which contains information about the image color management that the print job is using.

See Also

PrintJob Class | PrintJob Members


LeftMargin Property

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

LeftMargin Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : LeftMargin Property

Gets or sets the distance between the left of the physical page and the left of the printable area in units of the Printer's PrintUnits.

[Visual Basic]
Public Property LeftMargin As Single
[C#]
public float LeftMargin {get; set;}
[C++]
public: __property float get_LeftMargin();
public: __property void set_LeftMargin(
   float value
);
[C++/CLI]
public:
property float LeftMargin {
   float get();
   void set (float value);
}

Value

A single value which represents the distance between the left of the physical page and the left of the printable area in the Printer's PrintUnits.

See Also

PrintJob Class | PrintJob Members


Name Property

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Name Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : Name Property (PrintJob)

Gets or sets the document name for the print job.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}
[C++]
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
[C++/CLI]
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Value

A string value which represents the name of the document for the print job.

Remarks

The default value is an empty string "".

See Also

PrintJob Class | PrintJob Members


Page Property

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Page Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : Page Property

Gets the current page number of the document for the print job.

[Visual Basic]
Public ReadOnly Property Page As Integer
[C#]
public int Page {get;}
[C++]
public: __property int get_Page();
[C++/CLI]
public:
property int Page {
   int get();
}

Value

An integer value which represents the current page number of the document for the print job.

Remarks

The default value is 0.

See Also

PrintJob Class | PrintJob Members


PaperHeight Property

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PaperHeight Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : PaperHeight Property (PrintJob)

Gets the physical height of the paper set up for the printing device, in units determined by the PrintPreviewScale property.

[Visual Basic]
Public ReadOnly Property PaperHeight As Single
[C#]
public float PaperHeight {get;}
[C++]
public: __property float get_PaperHeight();
[C++/CLI]
public:
property float PaperHeight {
   float get();
}

Value

A single value which represents the physical height of the paper.

See Also

PrintJob Class | PrintJob Members


PaperWidth Property

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PaperWidth Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : PaperWidth Property (PrintJob)

Gets the physical width of the paper set up for the printing device, in units determined by the PrintPreviewScale property.

[Visual Basic]
Public ReadOnly Property PaperWidth As Single
[C#]
public float PaperWidth {get;}
[C++]
public: __property float get_PaperWidth();
[C++/CLI]
public:
property float PaperWidth {
   float get();
}

Value

A single value which represents the physical width of the paper set up for the printing device.

See Also

PrintJob Class | PrintJob Members


Printer Property

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Printer Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : Printer Property (PrintJob)

Gets the Printer the print job is using.

[Visual Basic]
Public ReadOnly Property Printer As Printer
[C#]
public Printer Printer {get;}
[C++]
public: __property Printer* get_Printer();
[C++/CLI]
public:
property Printer^ Printer {
   Printer^ get();
}

Value

A Printer object which contains information about the printer.

See Also

PrintJob Class | PrintJob Members


PrintHeight Property

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintHeight Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : PrintHeight Property (PrintJob)

Gets the printable height of the paper set up for the printing device, in units determined by the PrintPreviewScale property.

[Visual Basic]
Public ReadOnly Property PrintHeight As Single
[C#]
public float PrintHeight {get;}
[C++]
public: __property float get_PrintHeight();
[C++/CLI]
public:
property float PrintHeight {
   float get();
}

Value

A single value which represents the printable height.

See Also

PrintJob Class | PrintJob Members


PrintWidth Property

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintWidth Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : PrintWidth Property (PrintJob)

Gets the printable width of the paper set up for the printing device, in units determined by the PrintPreviewScale property.

[Visual Basic]
Public ReadOnly Property PrintWidth As Single
[C#]
public float PrintWidth {get;}
[C++]
public: __property float get_PrintWidth();
[C++/CLI]
public:
property float PrintWidth {
   float get();
}

Value

A single value which represents the printable width.

See Also

PrintJob Class | PrintJob Members


TemplateFileName Property

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TemplateFileName Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : TemplateFileName Property

Gets and sets the photograph collage description filename.

[Visual Basic]
Public Property TemplateFileName As String
[C#]
public string TemplateFileName {get; set;}
[C++]
public: __property string* get_TemplateFileName();
public: __property void set_TemplateFileName(
   string* value
);
[C++/CLI]
public:
property String^ TemplateFileName {
   String^ get();
   void set (String^ value);
}

Remarks

The default value is an empty string.

A collage template file is a text file of particular format that describes component image size and location. The first line is a format and version control line so that future modifications may be supported transparently and is as follows: Pegasus Imaging PrintPRO Template Version 1 Units = TW | PO | PI | CH | IN | MI | CE

Use only one of the unit indicators. They represent Twips, Point, Pixel, Character, Inches, Millimeter and Centimeter. The first two characters are sufficient for selecting the unit used to describe location and dimensions. Each subsequent line describes the location and cropping of an component image.

A line consists of a delimited (by comma, space, spaces or tab) series of values: Left, Top, Width, Height, SourceLeft, SourceTop, SourceWidth, SourceHeight and an Aspect flag. If the source parameters are omitted then the entire source image is inserted.

See Also

PrintJob Class | PrintJob Members


TopMargin Property

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TopMargin Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : TopMargin Property

Gets or sets the distance between the top of the physical page and the top of the printable area in units of the Printer's PrintUnits.

[Visual Basic]
Public Property TopMargin As Single
[C#]
public float TopMargin {get; set;}
[C++]
public: __property float get_TopMargin();
public: __property void set_TopMargin(
   float value
);
[C++/CLI]
public:
property float TopMargin {
   float get();
   void set (float value);
}

See Also

PrintJob Class | PrintJob Members


UseHardwareMargins Property

PrintJob Class | PrintJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

UseHardwareMargins Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrintJob Class : UseHardwareMargins Property

Gets or sets the value to determine if the printer's hardware margins are used or if the margin values are calculated from the average of the printable area subtracted from the physical area.

[Visual Basic]
Public Property UseHardwareMargins As Boolean
[C#]
public bool UseHardwareMargins {get; set;}
[C++]
public: __property bool get_UseHardwareMargins();
public: __property void set_UseHardwareMargins(
   bool value
);
[C++/CLI]
public:
property bool UseHardwareMargins {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true if the hardware margins are used. Otherwise, false is used.

See Also

PrintJob Class | PrintJob Members


PrintPreviewJob Class

PrintPreviewJob Members | PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Class

PegasusImaging.WinForms.PrintPro4 Namespace : PrintPreviewJob Class

This class represents a print preview job.

For a list of all members of this type, see PrintPreviewJob members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.PrintPro4.PrintJob
PegasusImaging.WinForms.PrintPro4.PrintPreviewJob

Syntax

[Visual Basic]
Public Class PrintPreviewJob
   Inherits PrintJob
[C#]
public class PrintPreviewJob : PrintJob
[C++]
public __gc class PrintPreviewJob : public PrintJob
[C++/CLI]
public ref class PrintPreviewJob : public PrintJob

See Also

PrintPreviewJob Members | PegasusImaging.WinForms.PrintPro4 Namespace


PrintPreviewJob Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Class Members

PegasusImaging.WinForms.PrintPro4 Namespace : PrintPreviewJob Class

PrintPreviewJob overview

Public Constructors

Public Constructor PrintPreviewJob Constructor Overloaded. Creates a new print preview job using the specified printer for the destination.

Public Properties

Public Property BottomMargin (Inherited from PrintJob) | Gets or sets the distance between the bottom of the physical page and the bottom of the printable area in units of the Printer's PrintUnits.
Public Property DisplayX (Inherited from PrintJob) | Gets the horizontal coordinate of the display area in printer units defined by the PrintPreviewScale property. Not available at design time.
Public Property DisplayY (Inherited from PrintJob) | Gets the vertical coordinate of the display area in printer units defined by the PrintPreviewScale property.
Public Property Draw (Inherited from PrintJob) | Gets a pseudo object used to contain all of the drawing methods.
Public Property Icm (Inherited from PrintJob) | Gets the Image Color Management values that the print job is using.
Public Property LeftMargin (Inherited from PrintJob) | Gets or sets the distance between the left of the physical page and the left of the printable area in units of the Printer's PrintUnits.
Public Property Name (Inherited from PrintJob) | Gets or sets the document name for the print job.
Public Property Page (Inherited from PrintJob) | Gets the current page number of the document for the print job.
Public Property PaperHeight (Inherited from PrintJob) | Gets the physical height of the paper set up for the printing device, in units determined by the PrintPreviewScale property.
Public Property PaperWidth (Inherited from PrintJob) | Gets the physical width of the paper set up for the printing device, in units determined by the PrintPreviewScale property.
Public Property Printer (Inherited from PrintJob) | Gets the Printer the print job is using.
Public Property PrintHeight (Inherited from PrintJob) | Gets the printable height of the paper set up for the printing device, in units determined by the PrintPreviewScale property.
Public Property PrintPreviewScale | Gets or sets the size of the print preview image.
Public Property PrintWidth (Inherited from PrintJob) | Gets the printable width of the paper set up for the printing device, in units determined by the PrintPreviewScale property.
Public Property TemplateFileName (Inherited from PrintJob) | Gets and sets the photograph collage description filename.
Public Property TopMargin (Inherited from PrintJob) | Gets or sets the distance between the top of the physical page and the top of the printable area in units of the Printer's PrintUnits.
Public Property UseHardwareMargins (Inherited from PrintJob) | Gets or sets the value to determine if the printer's hardware margins are used or if the margin values are calculated from the average of the printable area subtracted from the physical area.

Public Methods

Public Method Dispose (Inherited from PrintJob) | Overloaded. Forces destruction of the print job object.
Public Method Finish | Overridden. Releases the current document to the print device or spooler.
Public Method GetGraphics | Overridden. Returns a graphics object to the current page.
Public Method GetPrintPreviewBitmap | Obtain the print preview Bitmap for a specified page.
Public Method GetPrintPreviewDib | Obtain the print preview dib for a specified page.
Public Method GetPrintPreviewImage | Obtain the print preview Image for a specified page.
Public Method Kill (Inherited from PrintJob) | Immediately terminates the current print job cancelling any operations that have been performed on it.
Public Method NewPage (Inherited from PrintJob) | Starts a new page for printing.
Public Method PrintBitmap (Inherited from PrintJob) | Overloaded. Draws a Bitmap on the printer.
Public Method PrintDib (Inherited from PrintJob) | Overloaded. Draws a DIB on the printer.
Public Method PrintImage (Inherited from PrintJob) | Overloaded. Draws an image on the printer.
Public Method PrintTemplateBitmap (Inherited from PrintJob) | Draws a bitmap image on a printer using details provided by the template file.
Public Method PrintTemplateDib (Inherited from PrintJob) | Draws a DIB image on a printer using details provided by the template file.
Public Method PrintTemplateImage (Inherited from PrintJob) | Draws an image on a printer using details provided by the template file.

See Also

PrintPreviewJob Class | PegasusImaging.WinForms.PrintPro4 Namespace


PrintPreviewJob Constructor

PrintPreviewJob Class | PrintPreviewJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Constructor

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class : PrintPreviewJob Constructor (PrintPreviewJob)

Creates a new print preview job using the specified printer for the destination.

Overload List

Creates a new print preview job using the specified printer for the destination.

[Visual Basic] Public Sub New(Printer)

[C#] public PrintPreviewJob(Printer);

[C++] public PrintPreviewJob(Printer*);

[C++/CLI] public PrintPreviewJob(Printer^);

Creates a new print preview job using the specified printer for the destination.

[Visual Basic] Public Sub New(Printer,Boolean)

[C#] public PrintPreviewJob(Printer,bool);

[C++] public PrintPreviewJob(Printer*,bool);

[C++/CLI] public PrintPreviewJob(Printer^,bool);

Creates a new print preview job using the default printer for the destination.

[Visual Basic] Public Sub New(PrintPro)

[C#] public PrintPreviewJob(PrintPro);

[C++] public PrintPreviewJob(PrintPro*);

[C++/CLI] public PrintPreviewJob(PrintPro^);

Creates a new print preview job using the default printer for the destination.

[Visual Basic] Public Sub New(PrintPro,Boolean)

[C#] public PrintPreviewJob(PrintPro,bool);

[C++] public PrintPreviewJob(PrintPro*,bool);

[C++/CLI] public PrintPreviewJob(PrintPro^,bool);

Creates a new print preview job using the default printer for the destination.

[Visual Basic] Public Sub New(PrintPro,Printer)

[C#] public PrintPreviewJob(PrintPro,Printer);

[C++] public PrintPreviewJob(PrintPro*,Printer*);

[C++/CLI] public PrintPreviewJob(PrintPro^,Printer^);

Creates a new print preview job using the default printer for the destination.

[Visual Basic] Public Sub New(PrintPro,Printer,Boolean)

[C#] public PrintPreviewJob(PrintPro,Printer,bool);

[C++] public PrintPreviewJob(PrintPro*,Printer*,bool);

[C++/CLI] public PrintPreviewJob(PrintPro^,Printer^,bool);

Creates a new print preview job using the default printer for the destination.

[Visual Basic] Public Sub New(PrintPro,Icm)

[C#] public PrintPreviewJob(PrintPro,Icm);

[C++] public PrintPreviewJob(PrintPro*,Icm*);

[C++/CLI] public PrintPreviewJob(PrintPro^,Icm^);

Creates a new print preview job using the default printer for the destination.

[Visual Basic] Public Sub New(PrintPro,Icm,Boolean)

[C#] public PrintPreviewJob(PrintPro,Icm,bool);

[C++] public PrintPreviewJob(PrintPro*,Icm*,bool);

[C++/CLI] public PrintPreviewJob(PrintPro^,Icm^,bool);

Creates a new print preview job using the specified printer for the destination and specified image color management object for image color management settings.

[Visual Basic] Public Sub New(Printer,Icm)

[C#] public PrintPreviewJob(Printer,Icm);

[C++] public PrintPreviewJob(Printer*,Icm*);

[C++/CLI] public PrintPreviewJob(Printer^,Icm^);

Creates a new print preview job using the specified printer for the destination and specified image color management object for image color management settings.

[Visual Basic] Public Sub New(Printer,Icm,Boolean)

[C#] public PrintPreviewJob(Printer,Icm,bool);

[C++] public PrintPreviewJob(Printer*,Icm*,bool);

[C++/CLI] public PrintPreviewJob(Printer^,Icm^,bool);

Creates a new print preview job using the default printer for the destination.

[Visual Basic] Public Sub New(PrintPro,Printer,Icm)

[C#] public PrintPreviewJob(PrintPro,Printer,Icm);

[C++] public PrintPreviewJob(PrintPro*,Printer*,Icm*);

[C++/CLI] public PrintPreviewJob(PrintPro^,Printer^,Icm^);

Creates a new print preview job using the default printer for the destination.

[Visual Basic] Public Sub New(PrintPro,Printer,Icm,Boolean)

[C#] public PrintPreviewJob(PrintPro,Printer,Icm,bool);

[C++] public PrintPreviewJob(PrintPro*,Printer*,Icm*,bool);

[C++/CLI] public PrintPreviewJob(PrintPro^,Printer^,Icm^,bool);

Creates a new print job using the default printer for the destination and specified scaling

[Visual Basic] Public Sub New(PrintPro,PrintPreviewScale)

[C#] public PrintPreviewJob(PrintPro,PrintPreviewScale);

[C++] public PrintPreviewJob(PrintPro*,PrintPreviewScale);

[C++/CLI] public PrintPreviewJob(PrintPro^,PrintPreviewScale);

Creates a new print job using the default printer for the destination and specified scaling.

[Visual Basic] Public Sub New(PrintPro,PrintPreviewScale,Boolean)

[C#] public PrintPreviewJob(PrintPro,PrintPreviewScale,bool);

[C++] public PrintPreviewJob(PrintPro*,PrintPreviewScale,bool);

[C++/CLI] public PrintPreviewJob(PrintPro^,PrintPreviewScale,bool);

Creates a new print job using the default printer for the destination and specified scaling.

[Visual Basic] Public Sub New(PrintPro,PrintPreviewScale,Icm)

[C#] public PrintPreviewJob(PrintPro,PrintPreviewScale,Icm);

[C++] public PrintPreviewJob(PrintPro*,PrintPreviewScale,Icm*);

[C++/CLI] public PrintPreviewJob(PrintPro^,PrintPreviewScale,Icm^);

Creates a new print job using the default printer for the destination and specified scaling.

[Visual Basic] Public Sub New(PrintPro,PrintPreviewScale,Icm,Boolean)

[C#] public PrintPreviewJob(PrintPro,PrintPreviewScale,Icm,bool);

[C++] public PrintPreviewJob(PrintPro*,PrintPreviewScale,Icm*,bool);

[C++/CLI] public PrintPreviewJob(PrintPro^,PrintPreviewScale,Icm^,bool);

Creates a new print job using the specified printer for the destination and specified scaling.

[Visual Basic] Public Sub New(PrintPro,Printer,PrintPreviewScale,Icm,Boolean)

[C#] public PrintPreviewJob(PrintPro,Printer,PrintPreviewScale,Icm,bool);

[C++] public PrintPreviewJob(PrintPro*,Printer*,PrintPreviewScale,Icm*,bool);

[C++/CLI] public PrintPreviewJob(PrintPro^,Printer^,PrintPreviewScale,Icm^,bool);

Creates a new print job using the specified printer for the destination and specified scaling.

[Visual Basic] Public Sub New(PrintPro,Printer,PrintPreviewScale,Boolean)

[C#] public PrintPreviewJob(PrintPro,Printer,PrintPreviewScale,bool);

[C++] public PrintPreviewJob(PrintPro*,Printer*,PrintPreviewScale,bool);

[C++/CLI] public PrintPreviewJob(PrintPro^,Printer^,PrintPreviewScale,bool);

Creates a new print job using the specified printer for the destination and specified scaling.

[Visual Basic] Public Sub New(Printer,PrintPreviewScale)

[C#] public PrintPreviewJob(Printer,PrintPreviewScale);

[C++] public PrintPreviewJob(Printer*,PrintPreviewScale);

[C++/CLI] public PrintPreviewJob(Printer^,PrintPreviewScale);

Creates a new print job using the specified printer for the destination and specified scaling.

[Visual Basic] Public Sub New(Printer,PrintPreviewScale,Boolean)

[C#] public PrintPreviewJob(Printer,PrintPreviewScale,bool);

[C++] public PrintPreviewJob(Printer*,PrintPreviewScale,bool);

[C++/CLI] public PrintPreviewJob(Printer^,PrintPreviewScale,bool);

Creates a new print job using the specified printer for the destination and specified scaling.

[Visual Basic] Public Sub New(Printer,PrintPreviewScale,Icm)

[C#] public PrintPreviewJob(Printer,PrintPreviewScale,Icm);

[C++] public PrintPreviewJob(Printer*,PrintPreviewScale,Icm*);

[C++/CLI] public PrintPreviewJob(Printer^,PrintPreviewScale,Icm^);

Creates a new print job using the specified printer for the destination and specified scaling.

[Visual Basic] Public Sub New(Printer,PrintPreviewScale,Icm,Boolean)

[C#] public PrintPreviewJob(Printer,PrintPreviewScale,Icm,bool);

[C++] public PrintPreviewJob(Printer*,PrintPreviewScale,Icm*,bool);

[C++/CLI] public PrintPreviewJob(Printer^,PrintPreviewScale,Icm^,bool);

See Also

PrintPreviewJob Class | PrintPreviewJob Members


PrintPreviewJob Constructor(Printer)

PrintPreviewJob Class | PrintPreviewJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printer
The printer the print preview job is to print to.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Constructor(Printer)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(Printer)

Creates a new print preview job using the specified printer for the destination.

[Visual Basic]
Public Function New( _
   ByVal printer As Printer _
)
[C#]
public PrintPreviewJob(
   Printer printer
);
[C++]
public: PrintPreviewJob(
   Printer* printer
)
[C++/CLI]
public:
PrintPreviewJob(
   Printer^ printer
)

Parameters

printer
The printer the print preview job is to print to.

See Also

PrintPreviewJob Class | PrintPreviewJob Members | Overload List


PrintPreviewJob Constructor(Printer,Boolean)

PrintPreviewJob Class | PrintPreviewJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printer
The printer the print preview job is to print to.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Constructor(Printer,Boolean)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(Printer,Boolean)

Creates a new print preview job using the specified printer for the destination.

[Visual Basic]
Public Function New( _
   ByVal printer As Printer, _
   ByVal useHardwareMargins As Boolean _
)
[C#]
public PrintPreviewJob(
   Printer printer,
   bool useHardwareMargins
);
[C++]
public: PrintPreviewJob(
   Printer* printer,
   bool useHardwareMargins
)
[C++/CLI]
public:
PrintPreviewJob(
   Printer^ printer,
   bool useHardwareMargins
)

Parameters

printer
The printer the print preview job is to print to.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

See Also

PrintPreviewJob Class | PrintPreviewJob Members | Overload List


PrintPreviewJob Constructor(Printer,Icm)

PrintPreviewJob Class | PrintPreviewJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printer
The printer the print preview job is to print to.
imageColorManagement
The image color management settings to use for the print job.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Constructor(Printer,Icm)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(Printer,Icm)

Creates a new print preview job using the specified printer for the destination and specified image color management object for image color management settings.

[Visual Basic]
Public Function New( _
   ByVal printer As Printer, _
   ByVal imageColorManagement As Icm _
)
[C#]
public PrintPreviewJob(
   Printer printer,
   Icm imageColorManagement
);
[C++]
public: PrintPreviewJob(
   Printer* printer,
   Icm* imageColorManagement
)
[C++/CLI]
public:
PrintPreviewJob(
   Printer^ printer,
   Icm^ imageColorManagement
)

Parameters

printer
The printer the print preview job is to print to.
imageColorManagement
The image color management settings to use for the print job.

See Also

PrintPreviewJob Class | PrintPreviewJob Members | Overload List


PrintPreviewJob Constructor(Printer,Icm,Boolean)

PrintPreviewJob Class | PrintPreviewJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printer
The printer the print preview job is to print to.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Constructor(Printer,Icm,Boolean)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(Printer,Icm,Boolean)

Creates a new print preview job using the specified printer for the destination and specified image color management object for image color management settings.

[Visual Basic]
Public Function New( _
   ByVal printer As Printer, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean _
)
[C#]
public PrintPreviewJob(
   Printer printer,
   Icm imageColorManagement,
   bool useHardwareMargins
);
[C++]
public: PrintPreviewJob(
   Printer* printer,
   Icm* imageColorManagement,
   bool useHardwareMargins
)
[C++/CLI]
public:
PrintPreviewJob(
   Printer^ printer,
   Icm^ imageColorManagement,
   bool useHardwareMargins
)

Parameters

printer
The printer the print preview job is to print to.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

See Also

PrintPreviewJob Class | PrintPreviewJob Members | Overload List


PrintPreviewJob Constructor(Printer,PrintPreviewScale)

PrintPreviewJob Class | PrintPreviewJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Constructor(Printer,PrintPreviewScale)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(Printer,PrintPreviewScale)

Creates a new print job using the specified printer for the destination and specified scaling.

[Visual Basic]
Public Function New( _
   ByVal printer As Printer, _
   ByVal printPreviewScale As PrintPreviewScale _
)
[C#]
public PrintPreviewJob(
   Printer printer,
   PrintPreviewScale printPreviewScale
);
[C++]
public: PrintPreviewJob(
   Printer* printer,
   PrintPreviewScale printPreviewScale
)
[C++/CLI]
public:
PrintPreviewJob(
   Printer^ printer,
   PrintPreviewScale printPreviewScale
)

Parameters

printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.

See Also

PrintPreviewJob Class | PrintPreviewJob Members | Overload List


PrintPreviewJob Constructor(Printer,PrintPreviewScale,Boolean)

PrintPreviewJob Class | PrintPreviewJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Constructor(Printer,PrintPreviewScale,Boolean)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(Printer,PrintPreviewScale,Boolean)

Creates a new print job using the specified printer for the destination and specified scaling.

[Visual Basic]
Public Function New( _
   ByVal printer As Printer, _
   ByVal printPreviewScale As PrintPreviewScale, _
   ByVal useHardwareMargins As Boolean _
)
[C#]
public PrintPreviewJob(
   Printer printer,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins
);
[C++]
public: PrintPreviewJob(
   Printer* printer,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins
)
[C++/CLI]
public:
PrintPreviewJob(
   Printer^ printer,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins
)

Parameters

printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

See Also

PrintPreviewJob Class | PrintPreviewJob Members | Overload List


PrintPreviewJob Constructor(Printer,PrintPreviewScale,Icm)

PrintPreviewJob Class | PrintPreviewJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Constructor(Printer,PrintPreviewScale,Icm)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(Printer,PrintPreviewScale,Icm)

Creates a new print job using the specified printer for the destination and specified scaling.

[Visual Basic]
Public Function New( _
   ByVal printer As Printer, _
   ByVal printPreviewScale As PrintPreviewScale, _
   ByVal imageColorManagement As Icm _
)
[C#]
public PrintPreviewJob(
   Printer printer,
   PrintPreviewScale printPreviewScale,
   Icm imageColorManagement
);
[C++]
public: PrintPreviewJob(
   Printer* printer,
   PrintPreviewScale printPreviewScale,
   Icm* imageColorManagement
)
[C++/CLI]
public:
PrintPreviewJob(
   Printer^ printer,
   PrintPreviewScale printPreviewScale,
   Icm^ imageColorManagement
)

Parameters

printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.

See Also

PrintPreviewJob Class | PrintPreviewJob Members | Overload List


PrintPreviewJob Constructor(Printer,PrintPreviewScale,Icm,Boolean)

PrintPreviewJob Class | PrintPreviewJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Constructor(Printer,PrintPreviewScale,Icm,Boolean)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(Printer,PrintPreviewScale,Icm,Boolean)

Creates a new print job using the specified printer for the destination and specified scaling.

[Visual Basic]
Public Function New( _
   ByVal printer As Printer, _
   ByVal printPreviewScale As PrintPreviewScale, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean _
)
[C#]
public PrintPreviewJob(
   Printer printer,
   PrintPreviewScale printPreviewScale,
   Icm imageColorManagement,
   bool useHardwareMargins
);
[C++]
public: PrintPreviewJob(
   Printer* printer,
   PrintPreviewScale printPreviewScale,
   Icm* imageColorManagement,
   bool useHardwareMargins
)
[C++/CLI]
public:
PrintPreviewJob(
   Printer^ printer,
   PrintPreviewScale printPreviewScale,
   Icm^ imageColorManagement,
   bool useHardwareMargins
)

Parameters

printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

See Also

PrintPreviewJob Class | PrintPreviewJob Members | Overload List


PrintPreviewJob Constructor(PrintPro)

PrintPreviewJob Class | PrintPreviewJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The workspace object to use with the job.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Constructor(PrintPro)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro)

Creates a new print preview job using the default printer for the destination.

[Visual Basic]
Public Function New( _
   ByVal printProWorkspace As PrintPro _
)
[C#]
public PrintPreviewJob(
   PrintPro printProWorkspace
);
[C++]
public: PrintPreviewJob(
   PrintPro* printProWorkspace
)
[C++/CLI]
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace
)

Parameters

printProWorkspace
The workspace object to use with the job.

See Also

PrintPreviewJob Class | PrintPreviewJob Members | Overload List


PrintPreviewJob Constructor(PrintPro,Boolean)

PrintPreviewJob Class | PrintPreviewJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The workspace object to use with the job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Constructor(PrintPro,Boolean)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Boolean)

Creates a new print preview job using the default printer for the destination.

[Visual Basic]
Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal useHardwareMargins As Boolean _
)
[C#]
public PrintPreviewJob(
   PrintPro printProWorkspace,
   bool useHardwareMargins
);
[C++]
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   bool useHardwareMargins
)
[C++/CLI]
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   bool useHardwareMargins
)

Parameters

printProWorkspace
The workspace object to use with the job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

See Also

PrintPreviewJob Class | PrintPreviewJob Members | Overload List


PrintPreviewJob Constructor(PrintPro,Icm)

PrintPreviewJob Class | PrintPreviewJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The workspace object to use with the job.
imageColorManagement
The image color management settings to use for the print job.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Constructor(PrintPro,Icm)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Icm)

Creates a new print preview job using the default printer for the destination.

[Visual Basic]
Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal imageColorManagement As Icm _
)
[C#]
public PrintPreviewJob(
   PrintPro printProWorkspace,
   Icm imageColorManagement
);
[C++]
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   Icm* imageColorManagement
)
[C++/CLI]
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   Icm^ imageColorManagement
)

Parameters

printProWorkspace
The workspace object to use with the job.
imageColorManagement
The image color management settings to use for the print job.

See Also

PrintPreviewJob Class | PrintPreviewJob Members | Overload List


PrintPreviewJob Constructor(PrintPro,Icm,Boolean)

PrintPreviewJob Class | PrintPreviewJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The workspace object to use with the job.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Constructor(PrintPro,Icm,Boolean)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Icm,Boolean)

Creates a new print preview job using the default printer for the destination.

[Visual Basic]
Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean _
)
[C#]
public PrintPreviewJob(
   PrintPro printProWorkspace,
   Icm imageColorManagement,
   bool useHardwareMargins
);
[C++]
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   Icm* imageColorManagement,
   bool useHardwareMargins
)
[C++/CLI]
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   Icm^ imageColorManagement,
   bool useHardwareMargins
)

Parameters

printProWorkspace
The workspace object to use with the job.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

See Also

PrintPreviewJob Class | PrintPreviewJob Members | Overload List


PrintPreviewJob Constructor(PrintPro,Printer)

PrintPreviewJob Class | PrintPreviewJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Constructor(PrintPro,Printer)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Printer)

Creates a new print preview job using the default printer for the destination.

[Visual Basic]
Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer _
)
[C#]
public PrintPreviewJob(
   PrintPro printProWorkspace,
   Printer printer
);
[C++]
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   Printer* printer
)
[C++/CLI]
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   Printer^ printer
)

Parameters

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.

See Also

PrintPreviewJob Class | PrintPreviewJob Members | Overload List


PrintPreviewJob Constructor(PrintPro,Printer,Boolean)

PrintPreviewJob Class | PrintPreviewJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Constructor(PrintPro,Printer,Boolean)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Printer,Boolean)

Creates a new print preview job using the default printer for the destination.

[Visual Basic]
Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer, _
   ByVal useHardwareMargins As Boolean _
)
[C#]
public PrintPreviewJob(
   PrintPro printProWorkspace,
   Printer printer,
   bool useHardwareMargins
);
[C++]
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   Printer* printer,
   bool useHardwareMargins
)
[C++/CLI]
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   Printer^ printer,
   bool useHardwareMargins
)

Parameters

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

See Also

PrintPreviewJob Class | PrintPreviewJob Members | Overload List


PrintPreviewJob Constructor(PrintPro,Printer,Icm)

PrintPreviewJob Class | PrintPreviewJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
imageColorManagement
The image color management settings to use for the print job.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Constructor(PrintPro,Printer,Icm)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Printer,Icm)

Creates a new print preview job using the default printer for the destination.

[Visual Basic]
Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer, _
   ByVal imageColorManagement As Icm _
)
[C#]
public PrintPreviewJob(
   PrintPro printProWorkspace,
   Printer printer,
   Icm imageColorManagement
);
[C++]
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   Printer* printer,
   Icm* imageColorManagement
)
[C++/CLI]
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   Printer^ printer,
   Icm^ imageColorManagement
)

Parameters

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
imageColorManagement
The image color management settings to use for the print job.

See Also

PrintPreviewJob Class | PrintPreviewJob Members | Overload List


PrintPreviewJob Constructor(PrintPro,Printer,Icm,Boolean)

PrintPreviewJob Class | PrintPreviewJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Constructor(PrintPro,Printer,Icm,Boolean)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Printer,Icm,Boolean)

Creates a new print preview job using the default printer for the destination.

[Visual Basic]
Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean _
)
[C#]
public PrintPreviewJob(
   PrintPro printProWorkspace,
   Printer printer,
   Icm imageColorManagement,
   bool useHardwareMargins
);
[C++]
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   Printer* printer,
   Icm* imageColorManagement,
   bool useHardwareMargins
)
[C++/CLI]
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   Printer^ printer,
   Icm^ imageColorManagement,
   bool useHardwareMargins
)

Parameters

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

See Also

PrintPreviewJob Class | PrintPreviewJob Members | Overload List


PrintPreviewJob Constructor(PrintPro,Printer,PrintPreviewScale,Boolean)

PrintPreviewJob Class | PrintPreviewJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Constructor(PrintPro,Printer,PrintPreviewScale,Boolean)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Printer,PrintPreviewScale,Boolean)

Creates a new print job using the specified printer for the destination and specified scaling.

[Visual Basic]
Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer, _
   ByVal printPreviewScale As PrintPreviewScale, _
   ByVal useHardwareMargins As Boolean _
)
[C#]
public PrintPreviewJob(
   PrintPro printProWorkspace,
   Printer printer,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins
);
[C++]
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   Printer* printer,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins
)
[C++/CLI]
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   Printer^ printer,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins
)

Parameters

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

See Also

PrintPreviewJob Class | PrintPreviewJob Members | Overload List


PrintPreviewJob Constructor(PrintPro,Printer,PrintPreviewScale,Icm,Boolean)

PrintPreviewJob Class | PrintPreviewJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Constructor(PrintPro,Printer,PrintPreviewScale,Icm,Boolean)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Printer,PrintPreviewScale,Icm,Boolean)

Creates a new print job using the specified printer for the destination and specified scaling.

[Visual Basic]
Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer, _
   ByVal printPreviewScale As PrintPreviewScale, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean _
)
[C#]
public PrintPreviewJob(
   PrintPro printProWorkspace,
   Printer printer,
   PrintPreviewScale printPreviewScale,
   Icm imageColorManagement,
   bool useHardwareMargins
);
[C++]
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   Printer* printer,
   PrintPreviewScale printPreviewScale,
   Icm* imageColorManagement,
   bool useHardwareMargins
)
[C++/CLI]
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   Printer^ printer,
   PrintPreviewScale printPreviewScale,
   Icm^ imageColorManagement,
   bool useHardwareMargins
)

Parameters

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

See Also

PrintPreviewJob Class | PrintPreviewJob Members | Overload List


PrintPreviewJob Constructor(PrintPro,PrintPreviewScale)

PrintPreviewJob Class | PrintPreviewJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The workspace object to use with the job.
printPreviewScale
The print preview scaling that should be used.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Constructor(PrintPro,PrintPreviewScale)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,PrintPreviewScale)

Creates a new print job using the default printer for the destination and specified scaling

[Visual Basic]
Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printPreviewScale As PrintPreviewScale _
)
[C#]
public PrintPreviewJob(
   PrintPro printProWorkspace,
   PrintPreviewScale printPreviewScale
);
[C++]
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   PrintPreviewScale printPreviewScale
)
[C++/CLI]
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   PrintPreviewScale printPreviewScale
)

Parameters

printProWorkspace
The workspace object to use with the job.
printPreviewScale
The print preview scaling that should be used.

See Also

PrintPreviewJob Class | PrintPreviewJob Members | Overload List


PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Boolean)

PrintPreviewJob Class | PrintPreviewJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The workspace object to use with the job.
printPreviewScale
The print preview scaling that should be used.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Boolean)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Boolean)

Creates a new print job using the default printer for the destination and specified scaling.

[Visual Basic]
Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printPreviewScale As PrintPreviewScale, _
   ByVal useHardwareMargins As Boolean _
)
[C#]
public PrintPreviewJob(
   PrintPro printProWorkspace,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins
);
[C++]
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins
)
[C++/CLI]
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins
)

Parameters

printProWorkspace
The workspace object to use with the job.
printPreviewScale
The print preview scaling that should be used.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

See Also

PrintPreviewJob Class | PrintPreviewJob Members | Overload List


PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Icm)

PrintPreviewJob Class | PrintPreviewJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The workspace object to use with the job.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Icm)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Icm)

Creates a new print job using the default printer for the destination and specified scaling.

[Visual Basic]
Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printPreviewScale As PrintPreviewScale, _
   ByVal imageColorManagement As Icm _
)
[C#]
public PrintPreviewJob(
   PrintPro printProWorkspace,
   PrintPreviewScale printPreviewScale,
   Icm imageColorManagement
);
[C++]
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   PrintPreviewScale printPreviewScale,
   Icm* imageColorManagement
)
[C++/CLI]
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   PrintPreviewScale printPreviewScale,
   Icm^ imageColorManagement
)

Parameters

printProWorkspace
The workspace object to use with the job.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.

See Also

PrintPreviewJob Class | PrintPreviewJob Members | Overload List


PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Icm,Boolean)

PrintPreviewJob Class | PrintPreviewJob Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

printProWorkspace
The workspace object to use with the job.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Icm,Boolean)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Icm,Boolean)

Creates a new print job using the default printer for the destination and specified scaling.

[Visual Basic]
Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printPreviewScale As PrintPreviewScale, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean _
)
[C#]
public PrintPreviewJob(
   PrintPro printProWorkspace,
   PrintPreviewScale printPreviewScale,
   Icm imageColorManagement,
   bool useHardwareMargins
);
[C++]
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   PrintPreviewScale printPreviewScale,
   Icm* imageColorManagement,
   bool useHardwareMargins
)
[C++/CLI]
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   PrintPreviewScale printPreviewScale,
   Icm^ imageColorManagement,
   bool useHardwareMargins
)

Parameters

printProWorkspace
The workspace object to use with the job.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

See Also

PrintPreviewJob Class | PrintPreviewJob Members | Overload List


Finish Method

PrintPreviewJob Class | PrintPreviewJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Finish Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class : Finish Method (PrintPreviewJob)

Releases the current document to the print device or spooler.

[Visual Basic]
Overrides Public Sub Finish()
[C#]
public override void Finish();
[C++]
public: void Finish(); override
[C++/CLI]
public:
void Finish(); override

See Also

PrintPreviewJob Class | PrintPreviewJob Members


GetGraphics Method

PrintPreviewJob Class | PrintPreviewJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

GetGraphics Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class : GetGraphics Method (PrintPreviewJob)

Returns a graphics object to the current page.

[Visual Basic]
Overrides Public Function GetGraphics() As Graphics
[C#]
public override Graphics GetGraphics();
[C++]
public: Graphics* GetGraphics(); override
[C++/CLI]
public:
Graphics^ GetGraphics(); override

Return Type

A graphics object for the current page. You must call Dispose to release resources when drawing has finished.

Remarks

This allows for using native .NET drawing methods to print to the page.

See Also

PrintPreviewJob Class | PrintPreviewJob Members


GetPrintPreviewBitmap Method

PrintPreviewJob Class | PrintPreviewJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

page
The number of the page you wish to retrieve. Page numbers start with 1 and cannot exceed the current Page property setting.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

GetPrintPreviewBitmap Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class : GetPrintPreviewBitmap Method

Obtain the print preview Bitmap for a specified page.

[Visual Basic]
Public Function GetPrintPreviewBitmap( _
   ByVal page As Integer _
) As Bitmap
[C#]
public Bitmap GetPrintPreviewBitmap(
   int page
);
[C++]
public: Bitmap* GetPrintPreviewBitmap(
   int page
)
[C++/CLI]
public:
Bitmap^ GetPrintPreviewBitmap(
   int page
)

Parameters

page
The number of the page you wish to retrieve. Page numbers start with 1 and cannot exceed the current Page property setting.

Return Type

An image object of the specified print preview page.

Remarks

The Bitmap returned by GetPrintPreviewBitmap is a copy of the bitmap used by the PrintPro control. GetPrintPreviewBitmap will return null if a bitmap does not exist.

See Also

PrintPreviewJob Class | PrintPreviewJob Members


GetPrintPreviewDib Method

PrintPreviewJob Class | PrintPreviewJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

page
The number of the page you wish to retrieve. Page numbers start with 1 and cannot exceed the current Page property setting.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

GetPrintPreviewDib Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class : GetPrintPreviewDib Method

Obtain the print preview dib for a specified page.

[Visual Basic]
Public Function GetPrintPreviewDib( _
   ByVal page As Integer _
) As IntPtr
[C#]
public IntPtr GetPrintPreviewDib(
   int page
);
[C++]
public: IntPtr GetPrintPreviewDib(
   int page
)
[C++/CLI]
public:
IntPtr GetPrintPreviewDib(
   int page
)

Parameters

page
The number of the page you wish to retrieve. Page numbers start with 1 and cannot exceed the current Page property setting.

Return Type

A handle to the print preview Device Independent Bitmap (DIB).

Remarks

The DIB returned by GetPrintPreviewDib is a copy of the bitmap used by the PrintPro control. After using the DIB, you are responsible for deleting it. GetPrintPreviewDib will return IntPtr.Zero if a bitmap does not exist.

See Also

PrintPreviewJob Class | PrintPreviewJob Members


GetPrintPreviewImage Method

PrintPreviewJob Class | PrintPreviewJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

page
The number of the page you wish to retrieve. Page numbers start with 1 and cannot exceed the current Page property setting.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

GetPrintPreviewImage Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class : GetPrintPreviewImage Method

Obtain the print preview Image for a specified page.

[Visual Basic]
Public Function GetPrintPreviewImage( _
   ByVal page As Integer _
) As Image
[C#]
public Image GetPrintPreviewImage(
   int page
);
[C++]
public: Image* GetPrintPreviewImage(
   int page
)
[C++/CLI]
public:
Image^ GetPrintPreviewImage(
   int page
)

Parameters

page
The number of the page you wish to retrieve. Page numbers start with 1 and cannot exceed the current Page property setting.

Return Type

An image object of the specified print preview page.

Remarks

The Image returned by GetPrintPreviewImage is a copy of the bitmap used by the PrintPro control. GetPrintPreviewImage will return null if a bitmap does not exist.

See Also

PrintPreviewJob Class | PrintPreviewJob Members


PrintPreviewJob Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Class Properties

PegasusImaging.WinForms.PrintPro4 Namespace : PrintPreviewJob Class

For a list of all members of this type, see PrintPreviewJob members.

Public Properties

Public Property BottomMargin (Inherited from PrintJob) | Gets or sets the distance between the bottom of the physical page and the bottom of the printable area in units of the Printer's PrintUnits.
Public Property DisplayX (Inherited from PrintJob) | Gets the horizontal coordinate of the display area in printer units defined by the PrintPreviewScale property. Not available at design time.
Public Property DisplayY (Inherited from PrintJob) | Gets the vertical coordinate of the display area in printer units defined by the PrintPreviewScale property.
Public Property Draw (Inherited from PrintJob) | Gets a pseudo object used to contain all of the drawing methods.
Public Property Icm (Inherited from PrintJob) | Gets the Image Color Management values that the print job is using.
Public Property LeftMargin (Inherited from PrintJob) | Gets or sets the distance between the left of the physical page and the left of the printable area in units of the Printer's PrintUnits.
Public Property Name (Inherited from PrintJob) | Gets or sets the document name for the print job.
Public Property Page (Inherited from PrintJob) | Gets the current page number of the document for the print job.
Public Property PaperHeight (Inherited from PrintJob) | Gets the physical height of the paper set up for the printing device, in units determined by the PrintPreviewScale property.
Public Property PaperWidth (Inherited from PrintJob) | Gets the physical width of the paper set up for the printing device, in units determined by the PrintPreviewScale property.
Public Property Printer (Inherited from PrintJob) | Gets the Printer the print job is using.
Public Property PrintHeight (Inherited from PrintJob) | Gets the printable height of the paper set up for the printing device, in units determined by the PrintPreviewScale property.
Public Property PrintPreviewScale | Gets or sets the size of the print preview image.
Public Property PrintWidth (Inherited from PrintJob) | Gets the printable width of the paper set up for the printing device, in units determined by the PrintPreviewScale property.
Public Property TemplateFileName (Inherited from PrintJob) | Gets and sets the photograph collage description filename.
Public Property TopMargin (Inherited from PrintJob) | Gets or sets the distance between the top of the physical page and the top of the printable area in units of the Printer's PrintUnits.
Public Property UseHardwareMargins (Inherited from PrintJob) | Gets or sets the value to determine if the printer's hardware margins are used or if the margin values are calculated from the average of the printable area subtracted from the physical area.

See Also

PrintPreviewJob Class | PegasusImaging.WinForms.PrintPro4 Namespace


PrintPreviewScale Property

PrintPreviewJob Class | PrintPreviewJob Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewScale Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPreviewJob Class : PrintPreviewScale Property (PrintPreviewJob)

Gets or sets the size of the print preview image.

[Visual Basic]
Public Property PrintPreviewScale As PrintPreviewScale
[C#]
public PrintPreviewScale PrintPreviewScale {get; set;}
[C++]
public: __property PrintPreviewScale get_PrintPreviewScale();
public: __property void set_PrintPreviewScale(
   PrintPreviewScale value
);
[C++/CLI]
public:
property PrintPreviewScale PrintPreviewScale {
   PrintPreviewScale get();
   void set (PrintPreviewScale value);
}

Value

A PrintPreviewScale value which represents the size of the print preview image.

Remarks

1:1 preview images require substantial memory depending on the paper size and color depth of your monitor. If you create many print preview images, you might run out of memory if you use the 1:1 setting.

See Also

PrintPreviewJob Class | PrintPreviewJob Members


PrintPro Class

PrintPro Members | PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPro Class

PegasusImaging.WinForms.PrintPro4 Namespace : PrintPro Class

This class implements the main functionality of the PrintPro component.

For a list of all members of this type, see PrintPro members.

Object Model

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
PegasusImaging.WinForms.PrintPro4.PrintPro

Syntax

[Visual Basic]
<DebuggerNonUserCodeAttribute()>
<GeneratedCodeAttribute(Tool="System.Resources.Tools.StronglyTypedResourceBuilder", Version="2.0.0.0")>
<CompilerGeneratedAttribute()>
<ToolboxBitmapAttribute()>
Public Class PrintPro
   Inherits Component
[C#]
[DebuggerNonUserCodeAttribute()]
[GeneratedCodeAttribute(Tool="System.Resources.Tools.StronglyTypedResourceBuilder", Version="2.0.0.0")]
[CompilerGeneratedAttribute()]
[ToolboxBitmapAttribute()]
public class PrintPro : Component
[C++]
[DebuggerNonUserCodeAttribute()]
[GeneratedCodeAttribute(Tool="System.Resources.Tools.StronglyTypedResourceBuilder", Version="2.0.0.0")]
[CompilerGeneratedAttribute()]
[ToolboxBitmapAttribute()]
public __gc class PrintPro : public Component
[C++/CLI]
[DebuggerNonUserCodeAttribute()]
[GeneratedCodeAttribute(Tool="System.Resources.Tools.StronglyTypedResourceBuilder", Version="2.0.0.0")]
[CompilerGeneratedAttribute()]
[ToolboxBitmapAttribute()]
public ref class PrintPro : public Component

See Also

PrintPro Members | PegasusImaging.WinForms.PrintPro4 Namespace


PrintPro Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPro Class Members

PegasusImaging.WinForms.PrintPro4 Namespace : PrintPro Class

PrintPro overview

Public Constructors

Public Constructor PrintPro Constructor Overloaded. Create an instance of the PrintPro workspace.

Public Properties

Public Property Container (Inherited from System.ComponentModel.Component) | Gets the IContainer that contains the Component.
Public Property Debug | A property that represents whether or not debug logging is turned on.
Public Property DebugErrorLevel | Gets and sets a minimum error level a debug message must be for it to be logged in the log file.
Public Property DebugLogFile | Gets and sets the filename of the debug log file.
Public Property Licensing | Gets and sets access to an object you can use to provide licensing information to the component.
Public Property Printers | Gets the collection of printers for printing use.
Public Property Site (Inherited from System.ComponentModel.Component) | Gets or sets the ISite of the Component.

Public Methods

Public Method AboutBox | Displays a licensing, version and copyright information dialog box for the PrintPRO product.
Public Method CreateObjRef (Inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Public Method Dispose | Disposes of any unused resources.
Public Method GetLifetimeService (Inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Public Method InitializeLifetimeService (Inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Public Method ToString (Inherited from System.ComponentModel.Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

Public Events

Public Event Disposed (Inherited from System.ComponentModel.Component) Adds an event handler to listen to the Disposed event on the component.

See Also

PrintPro Class | PegasusImaging.WinForms.PrintPro4 Namespace


PrintPro Constructor

PrintPro Class | PrintPro Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPro Constructor

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPro Class : PrintPro Constructor (PrintPro)

Create an instance of the PrintPro workspace.

Overload List

Create an instance of the PrintPro workspace.

[Visual Basic] Public Sub New()

[C#] public PrintPro();

[C++] public PrintPro();

[C++/CLI] public PrintPro();

Creates an instance of the PrintPro workspace.

[Visual Basic] Public Sub New(IContainer)

[C#] public PrintPro(IContainer);

[C++] public PrintPro(IContainer*);

[C++/CLI] public PrintPro(IContainer^);

See Also

PrintPro Class | PrintPro Members


PrintPro Constructor()

PrintPro Class | PrintPro Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPro Constructor()

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPro Class > PrintPro Constructor : PrintPro Constructor()

Create an instance of the PrintPro workspace.

[Visual Basic]
Public Function New()
[C#]
public PrintPro();
[C++]
public: PrintPro();
[C++/CLI]
public:
PrintPro();

See Also

PrintPro Class | PrintPro Members | Overload List


PrintPro Constructor(IContainer)

PrintPro Class | PrintPro Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

container
A container.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPro Constructor(IContainer)

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPro Class > PrintPro Constructor : PrintPro Constructor(IContainer)

Creates an instance of the PrintPro workspace.

[Visual Basic]
Public Function New( _
   ByVal container As IContainer _
)
[C#]
public PrintPro(
   IContainer container
);
[C++]
public: PrintPro(
   IContainer* container
)
[C++/CLI]
public:
PrintPro(
   IContainer^ container
)

Parameters

container
A container.

See Also

PrintPro Class | PrintPro Members | Overload List


AboutBox Method

PrintPro Class | PrintPro Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

AboutBox Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPro Class : AboutBox Method

Displays a licensing, version and copyright information dialog box for the PrintPRO product.

[Visual Basic]
Public Sub AboutBox()
[C#]
public void AboutBox();
[C++]
public: void AboutBox();
[C++/CLI]
public:
void AboutBox();

See Also

PrintPro Class | PrintPro Members


Dispose Method

PrintPro Class | PrintPro Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPro Class : Dispose Method (PrintPro)

Disposes of any unused resources.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

See Also

PrintPro Class | PrintPro Members


PrintPro Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPro Class Properties

PegasusImaging.WinForms.PrintPro4 Namespace : PrintPro Class

For a list of all members of this type, see PrintPro members.

Public Properties

Public Property Container (Inherited from System.ComponentModel.Component) | Gets the IContainer that contains the Component.
Public Property Debug | A property that represents whether or not debug logging is turned on.
Public Property DebugErrorLevel | Gets and sets a minimum error level a debug message must be for it to be logged in the log file.
Public Property DebugLogFile | Gets and sets the filename of the debug log file.
Public Property Licensing | Gets and sets access to an object you can use to provide licensing information to the component.
Public Property Printers | Gets the collection of printers for printing use.
Public Property Site (Inherited from System.ComponentModel.Component) | Gets or sets the ISite of the Component.

See Also

PrintPro Class | PegasusImaging.WinForms.PrintPro4 Namespace


Debug Property

PrintPro Class | PrintPro Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Debug Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPro Class : Debug Property

A property that represents whether or not debug logging is turned on.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property Debug As Boolean
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public bool Debug {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property bool get_Debug();
public: __property void set_Debug(
   bool value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property bool Debug {
   bool get();
   void set (bool value);
}

See Also

PrintPro Class | PrintPro Members


DebugErrorLevel Property

PrintPro Class | PrintPro Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

DebugErrorLevel Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPro Class : DebugErrorLevel Property (PrintPro)

Gets and sets a minimum error level a debug message must be for it to be logged in the log file.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property DebugErrorLevel As DebugErrorLevel
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public DebugErrorLevel DebugErrorLevel {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property DebugErrorLevel get_DebugErrorLevel();
public: __property void set_DebugErrorLevel(
   DebugErrorLevel value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property DebugErrorLevel DebugErrorLevel {
   DebugErrorLevel get();
   void set (DebugErrorLevel value);
}

Value

A DebugErrorLevel enumeration value which determines the level of logging to the DebugLogFile.

Remarks

The default value is DebugErrorLevel.Normal

.

See Also

PrintPro Class | PrintPro Members


DebugLogFile Property

PrintPro Class | PrintPro Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

DebugLogFile Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPro Class : DebugLogFile Property

Gets and sets the filename of the debug log file.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property DebugLogFile As String
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public string DebugLogFile {get; set;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property string* get_DebugLogFile();
public: __property void set_DebugLogFile(
   string* value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property String^ DebugLogFile {
   String^ get();
   void set (String^ value);
}

Value

A string value which represents the name of the Debug Log File.

Remarks

The default value is an empty string "".

See Also

PrintPro Class | PrintPro Members


Licensing Property

PrintPro Class | PrintPro Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Licensing Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPro Class : Licensing Property (PrintPro)

Gets and sets access to an object you can use to provide licensing information to the component.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property Licensing As Licensing
[C#]
[BrowsableAttribute(false)]
public Licensing Licensing {get;}
[C++]
[BrowsableAttribute(false)]
public: __property Licensing* get_Licensing();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property Licensing^ Licensing {
   Licensing^ get();
}

Value

The Licensing object which contains the component licensing information.

Remarks

This property holds a reference to a Licensing object. You can use that object to send your licensing information to the component.

Example

...

// Set the License EvaluationMode

pp.Licensing.EvaluationMode = PegasusImaging.WinForms.PrintPro4.EvaluationMode.Automatic;

...

See Also

PrintPro Class | PrintPro Members


Printers Property

PrintPro Class | PrintPro Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Printers Property

PegasusImaging.WinForms.PrintPro4 Namespace > PrintPro Class : Printers Property

Gets the collection of printers for printing use.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public ReadOnly Property Printers As PrinterCollection
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public PrinterCollection Printers {get;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property PrinterCollection* get_Printers();
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property PrinterCollection^ Printers {
   PrinterCollection^ get();
}

Value

A PrinterCollection object which contains all the printers available for use.

See Also

PrintPro Class | PrintPro Members


PrintQuality Class

PrintQuality Members | PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintQuality Class

PegasusImaging.WinForms.PrintPro4 Namespace : PrintQuality Class (PegasusImaging.WinForms.PrintPro4)

This class is used to represent the print quality.

For a list of all members of this type, see PrintQuality members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.PrintPro4.PrintQuality

Syntax

[Visual Basic]
Public Class PrintQuality
[C#]
public class PrintQuality
[C++]
public __gc class PrintQuality
[C++/CLI]
public ref class PrintQuality

Remarks

Since quality can be specified by values such as high, medium, or low, and can also be specified by DPI, this object is used to encapsulate that.

See Also

PrintQuality Members | PegasusImaging.WinForms.PrintPro4 Namespace


PrintQuality Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintQuality Class Members

PegasusImaging.WinForms.PrintPro4 Namespace : PrintQuality Class (PegasusImaging.WinForms.PrintPro4)

PrintQuality overview

Public Methods

Public Method Dpi | Returns the DPI value for the print quality object.
Public Method static (Shared in Visual Basic) Draft | A print quality object that represents a request for draft quality.
Public Method Equals | Overridden. Determines whether two object instances are equal.
Public Method static (Shared in Visual Basic) FromDpi | Creates a print quality object that represents the specified DPI (dots per inch).
Public Method GetHashCode | Overridden. Serves as a hash function.
Public Method static (Shared in Visual Basic) High | A print quality object that represents a request for high quality.
Public Method static (Shared in Visual Basic) Low | A print quality object that represents a request for low quality.
Public Method static (Shared in Visual Basic) Medium | A print quality object that represents a request for medium quality.

Operators

Public Operator Equality | Compares two print quality objects for equality.
Public Operator Inequality | Compares two print quality objects for equality.

See Also

PrintQuality Class | PegasusImaging.WinForms.PrintPro4 Namespace


Dpi Method

PrintQuality Class | PrintQuality Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Dpi Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintQuality Class : Dpi Method

Returns the DPI value for the print quality object.

[Visual Basic]
Public Function Dpi() As Integer
[C#]
public int Dpi();
[C++]
public: int Dpi();
[C++/CLI]
public:
int Dpi();

Return Type

An integer value which represents the DPI for the print quality.

See Also

PrintQuality Class | PrintQuality Members


Draft Method

PrintQuality Class | PrintQuality Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Draft Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintQuality Class : Draft Method

A print quality object that represents a request for draft quality.

[Visual Basic]
Public Shared Function Draft() As PrintQuality
[C#]
public static PrintQuality Draft();
[C++]
public: static PrintQuality* Draft();
[C++/CLI]
public:
static PrintQuality^ Draft();

Return Type

A print quality object that represents a request for draft quality.

See Also

PrintQuality Class | PrintQuality Members


Equals Method

PrintQuality Class | PrintQuality Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

obj
An object to compare to.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Equals Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintQuality Class : Equals Method (PrintQuality)

Determines whether two object instances are equal.

[Visual Basic]
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: bool Equals(
   Object* obj
) override
[C++/CLI]
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
An object to compare to.

Return Type

A boolean value which is true if they represent the same print quality value, false otherwise

See Also

PrintQuality Class | PrintQuality Members


FromDpi Method

PrintQuality Class | PrintQuality Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

Dpi
An integer which represents the desired DPI.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

FromDpi Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintQuality Class : FromDpi Method

Creates a print quality object that represents the specified DPI (dots per inch).

[Visual Basic]
Public Shared Function FromDpi( _
   ByVal Dpi As Integer _
) As PrintQuality
[C#]
public static PrintQuality FromDpi(
   int Dpi
);
[C++]
public: static PrintQuality* FromDpi(
   int Dpi
)
[C++/CLI]
public:
static PrintQuality^ FromDpi(
   int Dpi
)

Parameters

Dpi
An integer which represents the desired DPI.

Return Type

A print quality object that represents the requested DPI.

See Also

PrintQuality Class | PrintQuality Members


GetHashCode Method

PrintQuality Class | PrintQuality Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

GetHashCode Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintQuality Class : GetHashCode Method (PrintQuality)

Serves as a hash function.

[Visual Basic]
Overrides Public Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: int GetHashCode(); override
[C++/CLI]
public:
int GetHashCode(); override

Return Type

A hash code for the current print quality object.

See Also

PrintQuality Class | PrintQuality Members


High Method

PrintQuality Class | PrintQuality Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

High Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintQuality Class : High Method

A print quality object that represents a request for high quality.

[Visual Basic]
Public Shared Function High() As PrintQuality
[C#]
public static PrintQuality High();
[C++]
public: static PrintQuality* High();
[C++/CLI]
public:
static PrintQuality^ High();

Return Type

A print quality object that represents a request for high quality.

See Also

PrintQuality Class | PrintQuality Members


Low Method

PrintQuality Class | PrintQuality Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Low Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintQuality Class : Low Method

A print quality object that represents a request for low quality.

[Visual Basic]
Public Shared Function Low() As PrintQuality
[C#]
public static PrintQuality Low();
[C++]
public: static PrintQuality* Low();
[C++/CLI]
public:
static PrintQuality^ Low();

Return Type

A print quality object that represents a request for low quality.

See Also

PrintQuality Class | PrintQuality Members


Medium Method

PrintQuality Class | PrintQuality Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Medium Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintQuality Class : Medium Method

A print quality object that represents a request for medium quality.

[Visual Basic]
Public Shared Function Medium() As PrintQuality
[C#]
public static PrintQuality Medium();
[C++]
public: static PrintQuality* Medium();
[C++/CLI]
public:
static PrintQuality^ Medium();

Return Type

A print quality object that represents a request for medium quality.

See Also

PrintQuality Class | PrintQuality Members


UserPaper Class

UserPaper Members | PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

UserPaper Class

PegasusImaging.WinForms.PrintPro4 Namespace : UserPaper Class (PegasusImaging.WinForms.PrintPro4)

This class implements methods and properties that are used in place of a paper class when a user paper type has been selected for a printer.

For a list of all members of this type, see UserPaper members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.PrintPro4.Paper
PegasusImaging.WinForms.PrintPro4.UserPaper

Syntax

[Visual Basic]
Public Class UserPaper
   Inherits Paper
[C#]
public class UserPaper : Paper
[C++]
public __gc class UserPaper : public Paper
[C++/CLI]
public ref class UserPaper : public Paper

See Also

UserPaper Members | PegasusImaging.WinForms.PrintPro4 Namespace


UserPaper Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

UserPaper Class Members

PegasusImaging.WinForms.PrintPro4 Namespace : UserPaper Class (PegasusImaging.WinForms.PrintPro4)

UserPaper overview

Public Properties

Public Property Id (Inherited from Paper) | Gets the ID of the paper.
Public Property Name | Overridden. Gets the name of the paper.

Public Methods

Public Method ToString (Inherited from Paper) Creates a string and returns the paper name.

See Also

UserPaper Class | PegasusImaging.WinForms.PrintPro4 Namespace


UserPaper Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

UserPaper Class Properties

PegasusImaging.WinForms.PrintPro4 Namespace : UserPaper Class (PegasusImaging.WinForms.PrintPro4)

For a list of all members of this type, see UserPaper members.

Public Properties

Public Property Id (Inherited from Paper) | Gets the ID of the paper.
Public Property Name | Overridden. Gets the name of the paper.

See Also

UserPaper Class | PegasusImaging.WinForms.PrintPro4 Namespace


Name Property

UserPaper Class | UserPaper Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Name Property

PegasusImaging.WinForms.PrintPro4 Namespace > UserPaper Class : Name Property (UserPaper)

Gets the name of the paper.

[Visual Basic]
Overrides Public ReadOnly Property Name As String
[C#]
public override string Name {get;}
[C++]
public: __property string* get_Name()override ;
[C++/CLI]
public:
property String^ Name override {
   String^ get();
}

Value

A string which represents the name of the paper.

See Also

UserPaper Class | UserPaper Members


PrintingUnit Structure

PrintingUnit Members | PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintingUnit Structure

PegasusImaging.WinForms.PrintPro4 Namespace : PrintingUnit Structure

An object that represents units for printing. Made so that its use is similar to an Enumeration.

For a list of all members of this type, see PrintingUnit members.

Inheritance Hierarchy

System.Object
System.ValueType
PegasusImaging.WinForms.PrintPro4.PrintingUnit

Syntax

[Visual Basic]
Public Structure PrintingUnit
   Inherits ValueType
[C#]
public struct PrintingUnit : ValueType
[C++]
public __value struct PrintingUnit : public ValueType
[C++/CLI]
public value class PrintingUnit : public ValueType

See Also

PrintingUnit Members | PegasusImaging.WinForms.PrintPro4 Namespace


PrintingUnit Structure | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintingUnit Structure Members

PegasusImaging.WinForms.PrintPro4 Namespace : PrintingUnit Structure

PrintingUnit overview

Public Fields

Public Field static (Shared in Visual Basic) Centimeter | The centimeter printing unit.
Public Field static (Shared in Visual Basic) Character | The character printing unit.
Public Field static (Shared in Visual Basic) HundredthsOfAMillimeter | A printing unit of 1/100th of a millimeter.
Public Field static (Shared in Visual Basic) HundredthsOfAnInch | A printing unit of 1/100th of an inch.
Public Field static (Shared in Visual Basic) Inch | The inch printing unit.
Public Field static (Shared in Visual Basic) Millimeter | The millimeter printing unit.
Public Field static (Shared in Visual Basic) Pixel | The pixel printing unit.
Public Field static (Shared in Visual Basic) Point | The point printing unit.
Public Field static (Shared in Visual Basic) TenthsOfAMillimeter | A printing unit of 1/10th a millimeter.
Public Field static (Shared in Visual Basic) ThousandthsOfAnInch | A printing unit of 1/1000th of an inch.
Public Field static (Shared in Visual Basic) ThreeHundredthsOfAnInch | A printing unit of 1/300th of an inch.
Public Field static (Shared in Visual Basic) Twip | The twip printing unit.

Public Methods

Public Method Equals | Overridden. Determines whether two object instances are equal.
Public Method GetHashCode | Overridden. Serves as a hash function for a particular type.
Public Method ToString (Inherited from System.ValueType) | Returns the fully qualified type name of this instance.

Operators

Public Operator Equality | Determines whether two PrintingUnits are the same printing unit.
Public Operator Implicit Type Conversion | Overloaded. To implicitly convert between integer values and printing units.
Public Operator Inequality | Determines whether two PrintingUnits are not the same printing unit.

See Also

PrintingUnit Structure | PegasusImaging.WinForms.PrintPro4 Namespace


PrintingUnit Structure | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintingUnit Structure Methods

PegasusImaging.WinForms.PrintPro4 Namespace : PrintingUnit Structure

For a list of all members of this type, see PrintingUnit members.

Public Methods

Public Method Equals | Overridden. Determines whether two object instances are equal.
Public Method GetHashCode | Overridden. Serves as a hash function for a particular type.
Public Method ToString (Inherited from System.ValueType) | Returns the fully qualified type name of this instance.

See Also

PrintingUnit Structure | PegasusImaging.WinForms.PrintPro4 Namespace


Equals Method

PrintingUnit Structure | PrintingUnit Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

obj
An object to compare to.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Equals Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintingUnit Structure : Equals Method (PrintingUnit)

Determines whether two object instances are equal.

[Visual Basic]
Overrides Public NotOverridable Function Equals( _
   ByVal obj As Object _
) As Boolean
[C#]
public override bool Equals(
   object obj
);
[C++]
public: bool Equals(
   Object* obj
) override
[C++/CLI]
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
An object to compare to.

Return Type

A boolean value which is true if they are equal. Otherwise, false is returned.

See Also

PrintingUnit Structure | PrintingUnit Members


GetHashCode Method

PrintingUnit Structure | PrintingUnit Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

GetHashCode Method

PegasusImaging.WinForms.PrintPro4 Namespace > PrintingUnit Structure : GetHashCode Method (PrintingUnit)

Serves as a hash function for a particular type.

[Visual Basic]
Overrides Public NotOverridable Function GetHashCode() As Integer
[C#]
public override int GetHashCode();
[C++]
public: int GetHashCode(); override
[C++/CLI]
public:
int GetHashCode(); override

Return Type

A hash code for the current unit type.

Remarks

This method is suitable for use in hashing algorithms and data structures like a hash table.

See Also

PrintingUnit Structure | PrintingUnit Members


PrintingUnit Structure | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintingUnit Structure Fields

PegasusImaging.WinForms.PrintPro4 Namespace : PrintingUnit Structure

For a list of all members of this type, see PrintingUnit members.

Public Fields

Public Field static (Shared in Visual Basic) Centimeter | The centimeter printing unit.
Public Field static (Shared in Visual Basic) Character | The character printing unit.
Public Field static (Shared in Visual Basic) HundredthsOfAMillimeter | A printing unit of 1/100th of a millimeter.
Public Field static (Shared in Visual Basic) HundredthsOfAnInch | A printing unit of 1/100th of an inch.
Public Field static (Shared in Visual Basic) Inch | The inch printing unit.
Public Field static (Shared in Visual Basic) Millimeter | The millimeter printing unit.
Public Field static (Shared in Visual Basic) Pixel | The pixel printing unit.
Public Field static (Shared in Visual Basic) Point | The point printing unit.
Public Field static (Shared in Visual Basic) TenthsOfAMillimeter | A printing unit of 1/10th a millimeter.
Public Field static (Shared in Visual Basic) ThousandthsOfAnInch | A printing unit of 1/1000th of an inch.
Public Field static (Shared in Visual Basic) ThreeHundredthsOfAnInch | A printing unit of 1/300th of an inch.
Public Field static (Shared in Visual Basic) Twip | The twip printing unit.

See Also

PrintingUnit Structure | PegasusImaging.WinForms.PrintPro4 Namespace


Centimeter Field

PrintingUnit Structure | PrintingUnit Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Centimeter Field

PegasusImaging.WinForms.PrintPro4 Namespace > PrintingUnit Structure : Centimeter Field

The centimeter printing unit.

[Visual Basic]
Public Shared Centimeter As Integer
[C#]
public static int Centimeter
[C++]
public: static int Centimeter
[C++/CLI]
public:
static int Centimeter

See Also

PrintingUnit Structure | PrintingUnit Members


Character Field

PrintingUnit Structure | PrintingUnit Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Character Field

PegasusImaging.WinForms.PrintPro4 Namespace > PrintingUnit Structure : Character Field

The character printing unit.

[Visual Basic]
Public Shared Character As Integer
[C#]
public static int Character
[C++]
public: static int Character
[C++/CLI]
public:
static int Character

See Also

PrintingUnit Structure | PrintingUnit Members


HundredthsOfAMillimeter Field

PrintingUnit Structure | PrintingUnit Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

HundredthsOfAMillimeter Field

PegasusImaging.WinForms.PrintPro4 Namespace > PrintingUnit Structure : HundredthsOfAMillimeter Field

A printing unit of 1/100th of a millimeter.

[Visual Basic]
Public Shared HundredthsOfAMillimeter As Integer
[C#]
public static int HundredthsOfAMillimeter
[C++]
public: static int HundredthsOfAMillimeter
[C++/CLI]
public:
static int HundredthsOfAMillimeter

See Also

PrintingUnit Structure | PrintingUnit Members


HundredthsOfAnInch Field

PrintingUnit Structure | PrintingUnit Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

HundredthsOfAnInch Field

PegasusImaging.WinForms.PrintPro4 Namespace > PrintingUnit Structure : HundredthsOfAnInch Field

A printing unit of 1/100th of an inch.

[Visual Basic]
Public Shared HundredthsOfAnInch As Integer
[C#]
public static int HundredthsOfAnInch
[C++]
public: static int HundredthsOfAnInch
[C++/CLI]
public:
static int HundredthsOfAnInch

See Also

PrintingUnit Structure | PrintingUnit Members


Inch Field

PrintingUnit Structure | PrintingUnit Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Inch Field

PegasusImaging.WinForms.PrintPro4 Namespace > PrintingUnit Structure : Inch Field

The inch printing unit.

[Visual Basic]
Public Shared Inch As Integer
[C#]
public static int Inch
[C++]
public: static int Inch
[C++/CLI]
public:
static int Inch

See Also

PrintingUnit Structure | PrintingUnit Members


Millimeter Field

PrintingUnit Structure | PrintingUnit Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Millimeter Field

PegasusImaging.WinForms.PrintPro4 Namespace > PrintingUnit Structure : Millimeter Field

The millimeter printing unit.

[Visual Basic]
Public Shared Millimeter As Integer
[C#]
public static int Millimeter
[C++]
public: static int Millimeter
[C++/CLI]
public:
static int Millimeter

See Also

PrintingUnit Structure | PrintingUnit Members


Pixel Field

PrintingUnit Structure | PrintingUnit Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Pixel Field

PegasusImaging.WinForms.PrintPro4 Namespace > PrintingUnit Structure : Pixel Field

The pixel printing unit.

[Visual Basic]
Public Shared Pixel As Integer
[C#]
public static int Pixel
[C++]
public: static int Pixel
[C++/CLI]
public:
static int Pixel

See Also

PrintingUnit Structure | PrintingUnit Members


Point Field

PrintingUnit Structure | PrintingUnit Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Point Field

PegasusImaging.WinForms.PrintPro4 Namespace > PrintingUnit Structure : Point Field

The point printing unit.

[Visual Basic]
Public Shared Point As Integer
[C#]
public static int Point
[C++]
public: static int Point
[C++/CLI]
public:
static int Point

Remarks

One point is 1/72 inch.

See Also

PrintingUnit Structure | PrintingUnit Members


TenthsOfAMillimeter Field

PrintingUnit Structure | PrintingUnit Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TenthsOfAMillimeter Field

PegasusImaging.WinForms.PrintPro4 Namespace > PrintingUnit Structure : TenthsOfAMillimeter Field

A printing unit of 1/10th a millimeter.

[Visual Basic]
Public Shared TenthsOfAMillimeter As Integer
[C#]
public static int TenthsOfAMillimeter
[C++]
public: static int TenthsOfAMillimeter
[C++/CLI]
public:
static int TenthsOfAMillimeter

See Also

PrintingUnit Structure | PrintingUnit Members


ThousandthsOfAnInch Field

PrintingUnit Structure | PrintingUnit Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

ThousandthsOfAnInch Field

PegasusImaging.WinForms.PrintPro4 Namespace > PrintingUnit Structure : ThousandthsOfAnInch Field

A printing unit of 1/1000th of an inch.

[Visual Basic]
Public Shared ThousandthsOfAnInch As Integer
[C#]
public static int ThousandthsOfAnInch
[C++]
public: static int ThousandthsOfAnInch
[C++/CLI]
public:
static int ThousandthsOfAnInch

See Also

PrintingUnit Structure | PrintingUnit Members


ThreeHundredthsOfAnInch Field

PrintingUnit Structure | PrintingUnit Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

ThreeHundredthsOfAnInch Field

PegasusImaging.WinForms.PrintPro4 Namespace > PrintingUnit Structure : ThreeHundredthsOfAnInch Field

A printing unit of 1/300th of an inch.

[Visual Basic]
Public Shared ThreeHundredthsOfAnInch As Integer
[C#]
public static int ThreeHundredthsOfAnInch
[C++]
public: static int ThreeHundredthsOfAnInch
[C++/CLI]
public:
static int ThreeHundredthsOfAnInch

See Also

PrintingUnit Structure | PrintingUnit Members


Twip Field

PrintingUnit Structure | PrintingUnit Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Twip Field

PegasusImaging.WinForms.PrintPro4 Namespace > PrintingUnit Structure : Twip Field

The twip printing unit.

[Visual Basic]
Public Shared Twip As Integer
[C#]
public static int Twip
[C++]
public: static int Twip
[C++/CLI]
public:
static int Twip

Remarks

One twip is 1/1440 inch.

See Also

PrintingUnit Structure | PrintingUnit Members


Alignment Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Alignment Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace : Alignment Enumeration

Option values which determine the alignment when printing.

Members

Member | Description
LeftJustifyTop | Left Justify Top
LeftJustifyMiddle | Left Justify Middle
LeftJustifyBottom | Left Justify Bottom
RightJustifyTop | Right Justify Top
RightJustifyMiddle | Right Justify Middle
RightJustifyBottom | Right Justify Bottom
CenterJustifyTop | Center Justify Top
CenterJustifyMiddle | Center Justify Middle
CenterJustifyBottom | Center Justify Bottom

See Also

PegasusImaging.WinForms.PrintPro4 Namespace


BackStyle Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

BackStyle Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace : BackStyle Enumeration (PegasusImaging.WinForms.PrintPro4)

Option values which determine the available backstyles to be used for printed text.

Members

Member | Description
Transparent | transparent
Opaque | opaque/filled

See Also

PegasusImaging.WinForms.PrintPro4 Namespace


DebugErrorLevel Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

DebugErrorLevel Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace : DebugErrorLevel Enumeration (PegasusImaging.WinForms.PrintPro4)

Option values which determine the available error levels for debugging.

Members

Member | Description
Normal | Normal - minimal logging would be done
Development | Development - Additionally logs information that would be helpful for developers
Detailed | Detailed - The highest level of logging

See Also

PegasusImaging.WinForms.PrintPro4 Namespace


DrawMode Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

DrawMode Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace : DrawMode Enumeration

Option values which determine the available drawing modes for the PrintPro native drawing routines.

Members

Member | Description
Blackness | Always draws black
NotMergePen | Pixel is the inverse of the MergePen color
MaskNotPen | Pixel is a combination of the colors common to both the screen and the inverse of the pen.
NotCopyPen | Pixel is the inverse of the pen color.
MaskPenNot | Pixel is a combination of the colors common to both the pen and the inverse of the screen.
Invert | Pixel is the inverse of the screen color.
Xor | Pixel is a combination of the colors in the pen and in the screen, but not in both.
NotMaskPen | Pixel is the inverse of the MaskPen color.
MaskPen | Pixel is a combination of the colors common to both the pen and the screen.
NotXorPen | Pixel is the inverse of the Xor color.
Nop | Pixel remains unchanged. (In effect, this turns drawing off)
MergeNotPen | Pixel is a combination of the screen color and the inverse of the pen color.
CopyPen | Pixel is the pen color.
MergePenNot | Pixel is a combination of the pen color and the inverse of the screen color.
MergePen | Pixel is a combination of the pen color and the screen color.
Whiteness | Always draws white

See Also

PegasusImaging.WinForms.PrintPro4 Namespace


DrawStyle Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

DrawStyle Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace : DrawStyle Enumeration

Option values which determine the available drawing styles for the PrintPro native drawing routines.

Members

Member | Description
Transparent | Transparent
Solid | Solid
Dash | Dashes
Dot | Dots
DashDot | Dash, Dot repeated
DashDotDot | Dash, Dot, Dot repeated

See Also

PegasusImaging.WinForms.PrintPro4 Namespace


EvaluationMode Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

EvaluationMode Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace : EvaluationMode Enumeration (PegasusImaging.WinForms.PrintPro4)

Option values which determine licensing evaluation modes.

Members

Member | Description
Automatic | The trial licensing dialog box will appear at regular intervals.
Timeout | The control will stop operation after five minutes and raise an error condition.

See Also

PegasusImaging.WinForms.PrintPro4 Namespace


FillStyle Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

FillStyle Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace : FillStyle Enumeration (PegasusImaging.WinForms.PrintPro4)

Option values which determine the pattern used to fill circles, boxes, round rectangles, pie-shapes and polygons created with the native PrintPro drawing routines.

Members

Member | Description
Solid | Solid fill
Transparent | Transparent fill
HorizontalLine | Horizontal line fill
VerticalLine | Vertical line fill
DownwardDiagonal | A 45-degree downward, left-to-right line fill
UpwardDiagonal | A 45-degree upward, left-to-right line fill
Cross | Horizontal and vertical hatch fill
DiagonalCross | 45-degree crosshatch fill

See Also

PegasusImaging.WinForms.PrintPro4 Namespace


IcmIntent Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

IcmIntent Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace : IcmIntent Enumeration

Option values which determine the possible color management methods, or intents.

Members

Member | Description
Saturation | Color matching should optimize for color saturation. This value is the most appropriate choice for business graphs when dithering is not desired.
Contrast | Color matching should optimize for color contrast. This value is the most appropriate choice for scanned or photographic images when dithering is desired.
ColorMetric | Color matching should optimize to match the exact color requested. This value is most appropriate for use with business logos or other images when an exact color is desired.

See Also

PegasusImaging.WinForms.PrintPro4 Namespace


IcmMethod Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

IcmMethod Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace : IcmMethod Enumeration

Option values which determine the ICM method to use.

Members

Member | Description
Disabled | Specifies that ICM is disabled.
System | Specifies that ICM is handled by Windows.
Driver | Specifies that ICM is handled by the device driver.
Device | Specifies that ICM is handled by the device.
Profile | Specifies that PrintPRO will apply the ICM profile associated with the destination device (printer or monitor).

See Also

PegasusImaging.WinForms.PrintPro4 Namespace


IcmRenderIntent Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

IcmRenderIntent Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace : IcmRenderIntent Enumeration

Option values which determine the purpose of the color correction.

Members

Member | Description
None | Disables Image Color Management.
Images | Gamut of image fits (shrinks or expands) and fills the destination device gamut. Spatial distance of colors are relatively scaled for all color to fit within the gamut of the device. (Perceptual).
Business | Only colors outside of gamut moved to closest inside value. White Point is not preserved. (Relative Colormetric)
Graphics | Preserve color saturation at expense of hue and lightness. Colors are vibrant but not accurate. (Saturation)
AbsoluteColormetric | The white point is preserved. Spatial color distance to white point changes but not the white point itself. (Absolute Colormetric)

See Also

PegasusImaging.WinForms.PrintPro4 Namespace


MediaType Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

MediaType Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace : MediaType Enumeration (PegasusImaging.WinForms.PrintPro4)

Option values which determine the type of media being printed on (if the printer supports this feature).

Members

Member | Description
UserDefined | A user defined media type is selected
NotSupported | Media type selection is not supported
Standard | Standard paper
Transparency | Transparancy "paper"
Glossy | Glossy paper

See Also

PegasusImaging.WinForms.PrintPro4 Namespace


Orientation Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Orientation Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace : Orientation Enumeration (PegasusImaging.WinForms.PrintPro4)

Option values which determine whether documents are printed in portrait or landscape mode (if the printer supports this feature).

Members

Member | Description
Portrait | Documents are printed with the top at the narrow side of the paper.
Landscape | Documents are printed with the top at the wide side of the paper.
Rotate | Documents are rotated. This is rarely supported by printers.

See Also

PegasusImaging.WinForms.PrintPro4 Namespace


PrintColorMode Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintColorMode Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace : PrintColorMode Enumeration

Option values which determine whether a color printer prints output in color or monochrome.

Members

Member | Description
Monochrome | Print output in monochrome (usually shades of black and white).
Color | Print output in color.

See Also

PegasusImaging.WinForms.PrintPro4 Namespace


PrintDitherType Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintDitherType Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace : PrintDitherType Enumeration

Option values which determine how dithering is to be done (if the printer supports this feature).

Members

Member | Description
UserDefined | The user has specified a printer specific dithering type.
NotSet | Specification of the dither type is not supported
NotSupported | Specification of the dither type is not supported
NoDither | No dithering.
CoarseDither | Dither with a coarse brush.
FineDither | Dither with a fine brush.
LineArtDither | Line art dithering, a special dithering method that produces well defined borders between black, white, and gray scaling. It is not suitable for images that include continuous gradations in intensity and hue such as scanned photographs.
ErrorDiffusion | A special type of dithering in which the quantization residual is distributed to neighboring pixels which have not yet been processed. Error diffusion has the tendency to enhance edges in an image. This can make text in images more readable than in other dithering techniques.
GrayScale | Printer does grayscaling.

See Also

PegasusImaging.WinForms.PrintPro4 Namespace


PrintDuplex Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintDuplex Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace : PrintDuplex Enumeration

Option values which determine whether a page is printed on both sides (if the printer supports this feature).

Members

Member | Description
Simplex | Single-sided printing with the current orientation setting.
Vertical | Double-sided printing using a vertical page turn.
Horizontal | Double-sided printing using a horizontal page turn.

See Also

PegasusImaging.WinForms.PrintPro4 Namespace


PrintPreviewScale Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewScale Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace : PrintPreviewScale Enumeration (PegasusImaging.WinForms.PrintPro4)

Option values which determine the scaling size of the print preview image.

Members

Member | Description
Scale1to1 | The image size is the same size as the printed image.
Scale1to2 | The image size is one-half the same size as the printed image.
Scale1to3 | The image size is one-third the same size as the printed image.
Scale1to4 | The image size is one-fourth the same size as the printed image.
Scale1to5 | The image size is one-fifth the same size as the printed image.
Scale1to6 | The image size is one-sixth the same size as the printed image.
Scale1to7 | The image size is one-seventh the same size as the printed image.
Scale1to8 | The image size is one-eight the same size as the printed image.
Scale1to9 | The image size is one-ninth the same size as the printed image.
Scale1to10 | The image size is one-tenth the same size as the printed image.

See Also

PegasusImaging.WinForms.PrintPro4 Namespace


PrintRangeAvailable Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintRangeAvailable Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace : PrintRangeAvailable Enumeration

Option values which determine the available radio buttons in the print dialog. The All value is always enabled. Using All will only enable the All radio button.

Members

Member | Description
All | Enable the All radio selection
Pages | Enable the Pages radio selection
Selection | Enable the Selection radio selection

See Also

PegasusImaging.WinForms.PrintPro4 Namespace


PrintRangeSelection Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintRangeSelection Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace : PrintRangeSelection Enumeration

Option values which determine the Print Range selected on the Print Dialog box.

Members

Member | Description
NoSelection | No selection.
All | The user selected the All radio button.
Pages | The user selected the Pages radio button.
Selection | The user selected the Selection radio button.

See Also

PegasusImaging.WinForms.PrintPro4 Namespace


RotationPivotMode Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

RotationPivotMode Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace : RotationPivotMode Enumeration

Option values which determine the pivot location for Draw.TextRotated.

Members

Member | Description
LeftJustified | left justified
RightJustified | right justified
CenterJustified | center justified

See Also

PegasusImaging.WinForms.PrintPro4 Namespace


SaveFileType Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

SaveFileType Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace : SaveFileType Enumeration (PegasusImaging.WinForms.PrintPro4)

Option values which determine the type of file generated when printing to file.

Members

Member | Description
Default | bitmap output
Tif | uncompressed tiff output
TifG3 | g3 compressed tiff output
TifG32D | g3-2d compressed tiff output
TifG4 | g4 compressed tiff output
Bmp | bmp output
Emf | enhanced metafile output
PdfG4 | g4 compressed pdf output
PdfDefault | default compression pdf output
PdfNoCompress | uncompressed pdf output
PdfG3 | g3 compressed pdf output
PdfG32D | g3-2d compressed pdf output
PdfJbig2 | jbig2 compressed pdf output
PdfSeqJpeg | sequential jpeg compressed pdf output
TifSeqJpeg | sequential jpeg compressed tif output

See Also

PegasusImaging.WinForms.PrintPro4 Namespace


TrueTypeOption Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

TrueTypeOption Enumeration

PegasusImaging.WinForms.PrintPro4 Namespace : TrueTypeOption Enumeration

Option values which determine the printer’s TrueType option.

Members

Member | Description
PrintAsGraphics | Print TrueType fonts as graphics. This should be used for dot matrix printers.
DownloadFonts | Download TrueType fonts as soft fonts. This is the default for HP printers that use PCL.
UseDeviceFonts | Substitute device fonts for TrueType fonts. This is the default for Postscript printers.
DownloadOutline | Downloads TrueType fonts as outline soft fonts.

See Also

PegasusImaging.WinForms.PrintPro4 Namespace


Glossary

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z


Assembly Overview

Namespaces

Namespace | Description
PegasusImaging.WinForms.PrintPro4 |


Getting Started - PegasusImaging.WinForms.PrintPro4

PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Getting Started

© 1997 -2008, Pegaus Imaging Corporation, All Rights Reserved.


Introduction - PegasusImaging.WinForms.PrintPro4

PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Introduction

© 1997 -2008, Pegaus Imaging Corporation, All Rights Reserved.


Draw Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Draw Class Methods

PegasusImaging.WinForms.PrintPro4 Namespace : Draw Class (PegasusImaging.WinForms.PrintPro4)

For a list of all members of this type, see Draw members.

Public Methods

Public Method Arc | Overloaded. Draws an arc on a printer.
Public Method Circle | Overloaded. Draws a circle or ellipse on a printer.
Public Method Curve | Overloaded. Draws a cubic bezier curve on a printer.
Public Method Line | Overloaded. Draws a line or rectangle on a printer.
Public Method Pie | Overloaded. Draws part of a circle.
Public Method Polygon | Overloaded. Draws a 3-6 sided polygon on a printer.
Public Method Rectangle | Overloaded. Draws a rectangle on a printer.
Public Method RoundRectangle | Overloaded. Draws a rectangle with rounded corners on printer.
Public Method Text | Overloaded. Draws the specified text string.
Public Method TextAligned | Overloaded. Draws text with the specified alignment.
Public Method TextHeight | Overloaded. Returns the height the text would be if the output has a specified font.
Public Method TextRotated | Overloaded. Outputs text rotated by a specified number of degrees.
Public Method TextWidth | Overloaded. Returns the width the text would be if output with specified font.

See Also

Draw Class | PegasusImaging.WinForms.PrintPro4 Namespace


Licensing Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Licensing Class Methods

PegasusImaging.WinForms.PrintPro4 Namespace : Licensing Class (PegasusImaging.WinForms.PrintPro4)

For a list of all members of this type, see Licensing members.

Public Methods

Public Method Dispose | Disposes of unmanaged resources.
Public Method UnlockRuntime | Called to allow the control to run as a non-trial mode.
Public Method UnlockWeb | Called to allow the control to run as a non-trial mode when being used on a web page.

See Also

Licensing Class | PegasusImaging.WinForms.PrintPro4 Namespace


Paper Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Paper Class Methods

PegasusImaging.WinForms.PrintPro4 Namespace : Paper Class (PegasusImaging.WinForms.PrintPro4)

For a list of all members of this type, see Paper members.

Public Methods

Public Method ToString Overridden. Creates a string and returns the paper name.

See Also

Paper Class | PegasusImaging.WinForms.PrintPro4 Namespace


PaperBin Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PaperBin Class Methods

PegasusImaging.WinForms.PrintPro4 Namespace : PaperBin Class (PegasusImaging.WinForms.PrintPro4)

For a list of all members of this type, see PaperBin members.

Public Methods

Public Method ToString Overridden.

See Also

PaperBin Class | PegasusImaging.WinForms.PrintPro4 Namespace


PaperBinCollection Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PaperBinCollection Class Methods

PegasusImaging.WinForms.PrintPro4 Namespace : PaperBinCollection Class

For a list of all members of this type, see PaperBinCollection members.

Public Methods

Public Method Contains | Used to determine if the specified PaperBin object exists in the collection.
Public Method CopyTo | Copies the elements of the collection to an array of paper bin type.
Public Method GetEnumerator | Overridden. Returns an enumerator that can be used to iterate through all of the PaperBin objects in the collection.

See Also

PaperBinCollection Class | PegasusImaging.WinForms.PrintPro4 Namespace


PaperBinEnumerator Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PaperBinEnumerator Class Methods

PegasusImaging.WinForms.PrintPro4 Namespace : PaperBinEnumerator Class

For a list of all members of this type, see PaperBinEnumerator members.

Public Methods

Public Method Dispose | Disposes the paper bin enumerator.
Public Method MoveNext | Moves the enumerator to the next paper bin within the collection.
Public Method Reset | Resets the enumerator to right before the first element within the collection.

See Also

PaperBinEnumerator Class | PegasusImaging.WinForms.PrintPro4 Namespace


PaperCollection Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PaperCollection Class Methods

PegasusImaging.WinForms.PrintPro4 Namespace : PaperCollection Class

For a list of all members of this type, see PaperCollection members.

Public Methods

Public Method Contains | Determines if the specified paper type exists in the collection.
Public Method CopyTo | Copies the collection of Paper objects to an array of papers.
Public Method GetEnumerator | Overridden. Returns an enumerator that can be used to iterate through all of the Paper objects in the collection.

See Also

PaperCollection Class | PegasusImaging.WinForms.PrintPro4 Namespace


PaperEnumerator Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PaperEnumerator Class Methods

PegasusImaging.WinForms.PrintPro4 Namespace : PaperEnumerator Class

For a list of all members of this type, see PaperEnumerator members.

Public Methods

Public Method Dispose | Destroys the enumerator object.
Public Method MoveNext | Moves the enumerator to the next Paper object in the collection.
Public Method Reset | Resets the paper enumerator to the first paper in the collection.

See Also

PaperEnumerator Class | PegasusImaging.WinForms.PrintPro4 Namespace


Printer Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Printer Class Methods

PegasusImaging.WinForms.PrintPro4 Namespace : Printer Class (PegasusImaging.WinForms.PrintPro4)

For a list of all members of this type, see Printer members.

Public Methods

Public Method static (Shared in Visual Basic) CreateFilePrinter | Creates a new printer object that prints to the specified file as the specified file type.
Public Method Dispose |
Public Method static (Shared in Visual Basic) SelectPrinter | Overloaded. Selects and returns the default printer.
Public Method SetupDialog | Displays a printer setup dialog box that lets you change printer properties.
Public Method ToFilePrinter | Takes the current printer object and converts it to print to a file.

See Also

Printer Class | PegasusImaging.WinForms.PrintPro4 Namespace


PrinterCollection Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrinterCollection Class Methods

PegasusImaging.WinForms.PrintPro4 Namespace : PrinterCollection Class

For a list of all members of this type, see PrinterCollection members.

Public Methods

Public Method Contains | Checks if the given Printer object is contained within the collection.
Public Method CopyTo | Copies the elements of the printer collection to an array, starting at the given index location.
Public Method GetEnumerator | Overridden. Returns an enumerator that can iterate through the printer collection.

See Also

PrinterCollection Class | PegasusImaging.WinForms.PrintPro4 Namespace


PrinterEnumerator Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrinterEnumerator Class Methods

PegasusImaging.WinForms.PrintPro4 Namespace : PrinterEnumerator Class

For a list of all members of this type, see PrinterEnumerator members.

Public Methods

Public Method Dispose | Disposes of the collection object when it is done being used.
Public Method MoveNext | Used to move to the next printer in the collection.
Public Method Reset | Resets the collection to the first Printer in the collection.

See Also

PrinterEnumerator Class | PegasusImaging.WinForms.PrintPro4 Namespace


Equality Operator

PrintingUnit Structure | PrintingUnit Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

a
A PrintingUnit which represents the left side of the comparison.
b
A PrintingUnit which represents the right side of the comparison.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Equality Operator

PegasusImaging.WinForms.PrintPro4 Namespace > PrintingUnit Structure : Equality Operator (PrintingUnit)

Determines whether two PrintingUnits are the same printing unit.

[Visual Basic]
Public Operator =( _
   ByVal a As PrintingUnit, _
   ByVal b As PrintingUnit _
) As Boolean
[C#]
public bool operator ==(
   PrintingUnit a,
   PrintingUnit b
);
[C++]
public: bool op_Equality(
   PrintingUnit a,
   PrintingUnit b
)
[C++/CLI]
public:
bool operator ==(
   PrintingUnit a,
   PrintingUnit b
)

Operands

a
A PrintingUnit which represents the left side of the comparison.
b
A PrintingUnit which represents the right side of the comparison.

Return Type

A boolean value which is true if the units are the same. Otherwise, false is returned.

See Also

PrintingUnit Structure | PrintingUnit Members


Implicit Type Conversion Operator

PrintingUnit Structure | PrintingUnit Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Implicit Type Conversion Operator

PegasusImaging.WinForms.PrintPro4 Namespace > PrintingUnit Structure : Implicit Type Conversion Operator

To implicitly convert between integer values and printing units.

Overload List

Implicit cast operator to obtain a GraphicsUnit from a PrintingUnit.

[Visual Basic] Overloads Public Operator Widening CType(PrintingUnit) As GraphicsUnit

[C#] public GraphicsUnit operator implicit(PrintingUnit);

[C++] public GraphicsUnit op_Implicit(PrintingUnit);

[C++/CLI] public GraphicsUnit operator implicit(PrintingUnit);

To implicitly convert between printing unit values and integers.

[Visual Basic] Overloads Public Operator Widening CType(PrintingUnit) As Integer

[C#] public int operator implicit(PrintingUnit);

[C++] public int op_Implicit(PrintingUnit);

[C++/CLI] public int operator implicit(PrintingUnit);

Implicit operator to obtain a PrintingUnit from a graphics unit.

[Visual Basic] Overloads Public Operator Widening CType(GraphicsUnit) As PrintingUnit

[C#] public PrintingUnit operator implicit(GraphicsUnit);

[C++] public PrintingUnit op_Implicit(GraphicsUnit);

[C++/CLI] public PrintingUnit operator implicit(GraphicsUnit);

To implicitly convert between integer values and printing units.

[Visual Basic] Overloads Public Operator Widening CType(Integer) As PrintingUnit

[C#] public PrintingUnit operator implicit(int);

[C++] public PrintingUnit op_Implicit(int);

[C++/CLI] public PrintingUnit operator implicit(int);

See Also

PrintingUnit Structure | PrintingUnit Members


Implicit Type Conversion(GraphicsUnit,PrintingUnit) Operator

PrintingUnit Structure | PrintingUnit Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

source
A PrintingUnit to convert to a GraphicsUnit.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Implicit Type Conversion(GraphicsUnit,PrintingUnit) Operator

PegasusImaging.WinForms.PrintPro4 Namespace > PrintingUnit Structure > Implicit Type Conversion Operator : Implicit Type Conversion(GraphicsUnit,PrintingUnit) Operator

Implicit cast operator to obtain a GraphicsUnit from a PrintingUnit.

[Visual Basic]
Overloads Public Operator Widening CType( _
   ByVal source As PrintingUnit _
) As GraphicsUnit
[C#]
public GraphicsUnit operator implicit(
   PrintingUnit source
);
[C++]
public: GraphicsUnit op_Implicit(
   PrintingUnit source
)
[C++/CLI]
public:
GraphicsUnit operator implicit(
   PrintingUnit source
)

Operands

source
A PrintingUnit to convert to a GraphicsUnit.

Return Type

The equivalent graphics unit. If one is not available, an invalid cast exception is thrown.

See Also

PrintingUnit Structure | PrintingUnit Members | Overload List


Implicit Type Conversion(Int32,PrintingUnit) Operator

PrintingUnit Structure | PrintingUnit Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

source
A PrintingUnit printing unit value.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Implicit Type Conversion(Int32,PrintingUnit) Operator

PegasusImaging.WinForms.PrintPro4 Namespace > PrintingUnit Structure > Implicit Type Conversion Operator : Implicit Type Conversion(Int32,PrintingUnit) Operator

To implicitly convert between printing unit values and integers.

[Visual Basic]
Overloads Public Operator Widening CType( _
   ByVal source As PrintingUnit _
) As Integer
[C#]
public int operator implicit(
   PrintingUnit source
);
[C++]
public: int op_Implicit(
   PrintingUnit source
)
[C++/CLI]
public:
int operator implicit(
   PrintingUnit source
)

Operands

source
A PrintingUnit printing unit value.

Return Type

An integer value which represents the printing unit value.

See Also

PrintingUnit Structure | PrintingUnit Members | Overload List


Implicit Type Conversion(PrintingUnit,GraphicsUnit) Operator

PrintingUnit Structure | PrintingUnit Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

source
A GraphicsUnit value which represents the source to obtain a PrintingUnit from.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Implicit Type Conversion(PrintingUnit,GraphicsUnit) Operator

PegasusImaging.WinForms.PrintPro4 Namespace > PrintingUnit Structure > Implicit Type Conversion Operator : Implicit Type Conversion(PrintingUnit,GraphicsUnit) Operator

Implicit operator to obtain a PrintingUnit from a graphics unit.

[Visual Basic]
Overloads Public Operator Widening CType( _
   ByVal source As GraphicsUnit _
) As PrintingUnit
[C#]
public PrintingUnit operator implicit(
   GraphicsUnit source
);
[C++]
public: PrintingUnit op_Implicit(
   GraphicsUnit source
)
[C++/CLI]
public:
PrintingUnit operator implicit(
   GraphicsUnit source
)

Operands

source
A GraphicsUnit value which represents the source to obtain a PrintingUnit from.

Return Type

A PrintingUnit equivalent value based on the given GraphicsUnit.

See Also

PrintingUnit Structure | PrintingUnit Members | Overload List


Implicit Type Conversion(PrintingUnit,Int32) Operator

PrintingUnit Structure | PrintingUnit Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

source
An integer value which represents the source units.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Implicit Type Conversion(PrintingUnit,Int32) Operator

PegasusImaging.WinForms.PrintPro4 Namespace > PrintingUnit Structure > Implicit Type Conversion Operator : Implicit Type Conversion(PrintingUnit,Int32) Operator

To implicitly convert between integer values and printing units.

[Visual Basic]
Overloads Public Operator Widening CType( _
   ByVal source As Integer _
) As PrintingUnit
[C#]
public PrintingUnit operator implicit(
   int source
);
[C++]
public: PrintingUnit op_Implicit(
   int source
)
[C++/CLI]
public:
PrintingUnit operator implicit(
   int source
)

Operands

source
An integer value which represents the source units.

Return Type

A printing unit converted which represents the number given.

See Also

PrintingUnit Structure | PrintingUnit Members | Overload List


Inequality Operator

PrintingUnit Structure | PrintingUnit Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

a
left side of the comparison
b
right side of the comparison
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Inequality Operator

PegasusImaging.WinForms.PrintPro4 Namespace > PrintingUnit Structure : Inequality Operator (PrintingUnit)

Determines whether two PrintingUnits are not the same printing unit.

[Visual Basic]
Public Operator <>( _
   ByVal a As PrintingUnit, _
   ByVal b As PrintingUnit _
) As Boolean
[C#]
public bool operator !=(
   PrintingUnit a,
   PrintingUnit b
);
[C++]
public: bool op_Inequality(
   PrintingUnit a,
   PrintingUnit b
)
[C++/CLI]
public:
bool operator !=(
   PrintingUnit a,
   PrintingUnit b
)

Operands

a
left side of the comparison
b
right side of the comparison

Return Type

false if the units are the same. true otherwise

See Also

PrintingUnit Structure | PrintingUnit Members


PrintJob Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintJob Class Methods

PegasusImaging.WinForms.PrintPro4 Namespace : PrintJob Class

For a list of all members of this type, see PrintJob members.

Public Methods

Public Method Dispose | Overloaded. Forces destruction of the print job object.
Public Method Finish | Releases the current document to the print device or spooler.
Public Method GetGraphics | Returns a graphics object to the current page.
Public Method Kill | Immediately terminates the current print job cancelling any operations that have been performed on it.
Public Method NewPage | Starts a new page for printing.
Public Method PrintBitmap | Overloaded. Draws a Bitmap on the printer.
Public Method PrintDib | Overloaded. Draws a DIB on the printer.
Public Method PrintImage | Overloaded. Draws an image on the printer.
Public Method PrintTemplateBitmap | Draws a bitmap image on a printer using details provided by the template file.
Public Method PrintTemplateDib | Draws a DIB image on a printer using details provided by the template file.
Public Method PrintTemplateImage | Draws an image on a printer using details provided by the template file.

See Also

PrintJob Class | PegasusImaging.WinForms.PrintPro4 Namespace


PrintPreviewJob Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPreviewJob Class Methods

PegasusImaging.WinForms.PrintPro4 Namespace : PrintPreviewJob Class

For a list of all members of this type, see PrintPreviewJob members.

Public Methods

Public Method Dispose (Inherited from PrintJob) | Overloaded. Forces destruction of the print job object.
Public Method Finish | Overridden. Releases the current document to the print device or spooler.
Public Method GetGraphics | Overridden. Returns a graphics object to the current page.
Public Method GetPrintPreviewBitmap | Obtain the print preview Bitmap for a specified page.
Public Method GetPrintPreviewDib | Obtain the print preview dib for a specified page.
Public Method GetPrintPreviewImage | Obtain the print preview Image for a specified page.
Public Method Kill (Inherited from PrintJob) | Immediately terminates the current print job cancelling any operations that have been performed on it.
Public Method NewPage (Inherited from PrintJob) | Starts a new page for printing.
Public Method PrintBitmap (Inherited from PrintJob) | Overloaded. Draws a Bitmap on the printer.
Public Method PrintDib (Inherited from PrintJob) | Overloaded. Draws a DIB on the printer.
Public Method PrintImage (Inherited from PrintJob) | Overloaded. Draws an image on the printer.
Public Method PrintTemplateBitmap (Inherited from PrintJob) | Draws a bitmap image on a printer using details provided by the template file.
Public Method PrintTemplateDib (Inherited from PrintJob) | Draws a DIB image on a printer using details provided by the template file.
Public Method PrintTemplateImage (Inherited from PrintJob) | Draws an image on a printer using details provided by the template file.

See Also

PrintPreviewJob Class | PegasusImaging.WinForms.PrintPro4 Namespace


PrintPro Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPro Class Events

PegasusImaging.WinForms.PrintPro4 Namespace : PrintPro Class

For a list of all members of this type, see PrintPro members.

Public Events

Public Event Disposed (Inherited from System.ComponentModel.Component) Adds an event handler to listen to the Disposed event on the component.

See Also

PrintPro Class | PegasusImaging.WinForms.PrintPro4 Namespace


PrintPro Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintPro Class Methods

PegasusImaging.WinForms.PrintPro4 Namespace : PrintPro Class

For a list of all members of this type, see PrintPro members.

Public Methods

Public Method AboutBox | Displays a licensing, version and copyright information dialog box for the PrintPRO product.
Public Method CreateObjRef (Inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Public Method Dispose | Disposes of any unused resources.
Public Method GetLifetimeService (Inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Public Method InitializeLifetimeService (Inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Public Method ToString (Inherited from System.ComponentModel.Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

See Also

PrintPro Class | PegasusImaging.WinForms.PrintPro4 Namespace


PrintQuality Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PrintQuality Class Methods

PegasusImaging.WinForms.PrintPro4 Namespace : PrintQuality Class (PegasusImaging.WinForms.PrintPro4)

For a list of all members of this type, see PrintQuality members.

Public Methods

Public Method Dpi | Returns the DPI value for the print quality object.
Public Method static (Shared in Visual Basic) Draft | A print quality object that represents a request for draft quality.
Public Method Equals | Overridden. Determines whether two object instances are equal.
Public Method static (Shared in Visual Basic) FromDpi | Creates a print quality object that represents the specified DPI (dots per inch).
Public Method GetHashCode | Overridden. Serves as a hash function.
Public Method static (Shared in Visual Basic) High | A print quality object that represents a request for high quality.
Public Method static (Shared in Visual Basic) Low | A print quality object that represents a request for low quality.
Public Method static (Shared in Visual Basic) Medium | A print quality object that represents a request for medium quality.

See Also

PrintQuality Class | PegasusImaging.WinForms.PrintPro4 Namespace


Equality Operator

PrintQuality Class | PrintQuality Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

pq1
The left side of the comparison.
pq2
The right side of the comparison.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Equality Operator

PegasusImaging.WinForms.PrintPro4 Namespace > PrintQuality Class : Equality Operator (PrintQuality)

Compares two print quality objects for equality.

[Visual Basic]
Public Operator =( _
   ByVal pq1 As PrintQuality, _
   ByVal pq2 As PrintQuality _
) As Boolean
[C#]
public bool operator ==(
   PrintQuality pq1,
   PrintQuality pq2
);
[C++]
public: bool op_Equality(
   PrintQuality* pq1,
   PrintQuality* pq2
)
[C++/CLI]
public:
bool operator ==(
   PrintQuality^ pq1,
   PrintQuality^ pq2
)

Operands

pq1
The left side of the comparison.
pq2
The right side of the comparison.

Return Type

A boolean value that is true if they represent the same value, false otherwise.

See Also

PrintQuality Class | PrintQuality Members


Inequality Operator

PrintQuality Class | PrintQuality Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

pq1
The left side of the comparison.
pq2
The right side of the comparison.
See Also Languages PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

Inequality Operator

PegasusImaging.WinForms.PrintPro4 Namespace > PrintQuality Class : Inequality Operator (PrintQuality)

Compares two print quality objects for equality.

[Visual Basic]
Public Operator <>( _
   ByVal pq1 As PrintQuality, _
   ByVal pq2 As PrintQuality _
) As Boolean
[C#]
public bool operator !=(
   PrintQuality pq1,
   PrintQuality pq2
);
[C++]
public: bool op_Inequality(
   PrintQuality* pq1,
   PrintQuality* pq2
)
[C++/CLI]
public:
bool operator !=(
   PrintQuality^ pq1,
   PrintQuality^ pq2
)

Operands

pq1
The left side of the comparison.
pq2
The right side of the comparison.

Return Type

A boolean value which is false if they represent the same value, true otherwise.

See Also

PrintQuality Class | PrintQuality Members


UserPaper Class | PegasusImaging.WinForms.PrintPro4 Namespace

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

UserPaper Class Methods

PegasusImaging.WinForms.PrintPro4 Namespace : UserPaper Class (PegasusImaging.WinForms.PrintPro4)

For a list of all members of this type, see UserPaper members.

Public Methods

Public Method ToString (Inherited from Paper) Creates a string and returns the paper name.

See Also

UserPaper Class | PegasusImaging.WinForms.PrintPro4 Namespace


PegasusImaging.WinForms.PrintPro4 Assembly

See Also PegasusImaging.WinForms.PrintPro4 Send comments on this topic.

PegasusImaging.WinForms.PrintPro4 Namespace Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.PrintPro4.Draw
PegasusImaging.WinForms.PrintPro4.Icm
PegasusImaging.WinForms.PrintPro4.Licensing
PegasusImaging.WinForms.PrintPro4.Paper
PegasusImaging.WinForms.PrintPro4.UserPaper
PegasusImaging.WinForms.PrintPro4.PaperBin
PegasusImaging.WinForms.PrintPro4.PaperBinEnumerator
PegasusImaging.WinForms.PrintPro4.PaperEnumerator
PegasusImaging.WinForms.PrintPro4.Printer
PegasusImaging.WinForms.PrintPro4.PrinterEnumerator
PegasusImaging.WinForms.PrintPro4.PrintJob
PegasusImaging.WinForms.PrintPro4.PrintPreviewJob
PegasusImaging.WinForms.PrintPro4.PrintQuality
System.Collections.ReadOnlyCollectionBase
PegasusImaging.WinForms.PrintPro4.PaperBinCollection
PegasusImaging.WinForms.PrintPro4.PaperCollection
PegasusImaging.WinForms.PrintPro4.PrinterCollection
System.MarshalByRefObject
System.ComponentModel.Component
PegasusImaging.WinForms.PrintPro4.PrintPro

See Also

PegasusImaging.WinForms.PrintPro4 Namespace | PegasusImaging.WinForms.PrintPro4 Assembly